Jump to content
This site uses cookies! Learn More

This site uses cookies!

By continuing to use this site, you agree to allow us to store cookies on your computer. :)

  • PathFinder.ReportArea missing ContintentId parameter


    Matenia
    • Product: WRobot General Type: Bug Status: Unconfirmed

    hey @Droidz,

     

    when my products starts up, I am trying to add road and water vectors. 
    This method is missing a parameter to tell the pathfinder which continentId to use:

    athFinder.ReportArea(arathiRoad.Position.ToVector3(), arathiRoad.Radius, arathiRoad.AreaType, true);

    For water it is easy, I can just use blacklist like this:

    wManagerSetting.AddBlackListZone(water.Position.ToVector3(), water.Radius, ContinentId.PVPZone04, water.AreaType, true);

    But please add a parameter so I don't have to blacklist anything and I can use pathfinder properly.
    Thank you




    User Feedback

    Recommended Comments

    Hello, it is normal, WRobot call PathFinder.ReportArea when you change continent (from list that you create with wManagerSetting.AddBlackListZone, WRobot add only blacklist of current continent)

    Share this comment


    Link to comment
    Share on other sites


    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Add a comment...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...