Jump to content
This site uses cookies! Learn More

This site uses cookies!

By continuing to use this site, you agree to allow us to store cookies on your computer. :)

  • WoW Vanilla Memory error after 06/05/2019 update


    Watcher
    • Version: All Product: WRobot General Type: Bug Status: Fixed

    Greetigns,

    I dunno if it's a bug, but since the last update the WoW Client is crashing in a very short time, showing a Memory Error failure.

    I start the game, login, select the character, start the Wrobot and a few minutes, Memoru Error crash.

     

    Regards,

     

    Fabio




    User Feedback

    Recommended Comments

    Hello, you still get this problem? You have updated plugins/fightclasses/profiles? All crashes is in Vanilla?

    Share this comment


    Link to comment
    Share on other sites

    same thing for me, after update the bot works only for a 10 sec or so and getting the same error as guy that posted it

    Share this comment


    Link to comment
    Share on other sites
    1 hour ago, Droidz said:

    Hello, you still get this problem? You have updated plugins/fightclasses/profiles? All crashes is in Vanilla?

    Yes, I updated everything and still happening.

    Share this comment


    Link to comment
    Share on other sites
    4 minutes ago, Droidz said:

    Only vanilla? you have try with another fightclass? and to disable plugins?

    I don't know about the others, but I'm using these fight class/profile:

    Both updated yesterday

    Share this comment


    Link to comment
    Share on other sites

    Can you try without fightclass, and can you send me (by private message) few recent crash rapports files please (in folder "World of Warcraft\Errors\", only .txt files)

    Share this comment


    Link to comment
    Share on other sites
    3 hours ago, Droidz said:

    Can you try without fightclass, and can you send me (by private message) few recent crash rapports files please (in folder "World of Warcraft\Errors\", only .txt files)

    Just sent to you. It happened withou any Fight Class / Plugin selected.

    Share this comment


    Link to comment
    Share on other sites

    thank you, I check, you can try to launch WRobot with shortcut "WRobot no dx" and tell me if you get crash please

    Share this comment


    Link to comment
    Share on other sites
    3 hours ago, Droidz said:

    thank you, I check, you can try to launch WRobot with shortcut "WRobot no dx" and tell me if you get crash please

    Yeap, it happened with no dx tooo, sending the WoW logs, WRobot logs and a screenshot to you.

    Share this comment


    Link to comment
    Share on other sites

    I've verified all Windows updates are installed, no antivirus running, installed the SlimDX then rebooted but I still get the The instruction at "0x0529400A" referenced memory at "0x00000000". The memory could not be "written". After a few minutes... 

    Any other suggestions?

    Edit: Also updated Wrobot to latest. 

    Share this comment


    Link to comment
    Share on other sites

    I created a brand new character and so far it seems to work! Are there any settings/configs saved for characters in wrobot that I can clear out to try on my main character?

    Share this comment


    Link to comment
    Share on other sites

    can anyone confirm that new toons are working fine? or deleteing the settings and config settings are working when they are deleted and re made the settings makes it work?

     

    Share this comment


    Link to comment
    Share on other sites

    I deleted the General-Character.Server.xml from the Settings folder and it crashed after about 6 minutes. Before I was getting the crash about 30 seconds after starting. This is using default FightClass, no plugins and a basic Grinder profile I made to test it. 

    Share this comment


    Link to comment
    Share on other sites

    So as I mentioned.
    Fresh WoW.
    Fresh Wrobot.

    Also:
    Only plugin is your general setup backup plugin. (and I imported the settings)
    Tried with two different Fightclasses. Ordush's and the standard one.
    Both a profile and Automation has been tried both with and without NO DX.

    Let me know if you want anything else, Droidz. I'll be home all night.

    6 apr 2019 20H01.log.html

    Edited by Chiffon
    Added: I imported general settings.

    Share this comment


    Link to comment
    Share on other sites

    ERROR #132 (0x85100084) Fatal Exception
    Program:    C:\X\WoW.exe
    Exception:    0xC0000005 (ACCESS_VIOLATION) at 0023:04F8800A

    The instruction at "0x04F8800A" referenced memory at "0x00000000".
    The memory could not be "written".
     

    Share this comment


    Link to comment
    Share on other sites

    Didnt realize a post was already made.

    I can also confirm this problem, At first i thought it was the custom script in my profile, after using a few different profiles, with different fight classes, all crashed when they started to attack it seemed. Was happy to see Successful Authentication without a popup, but i cant fully be sure its working unless it runs for 5 mins or so and this well, the log speaks for itself.

    0 plugins were enabled.

    imo , revert wrobot back to before this update >< lol

     

     

    [D] 14:50:09.351 - [Quester] RunCode[2919]: Var.SetVar("MyVarName_SelectedTask", Others.Random(1, 2));
    Logging.Write("v = " + Var.GetVar("MyVarName_SelectedTask") );

    14:50:09.783 - v = 2
    [D] 14:50:09.826 - [Quester] New step (2921): KILL5154AzsharaBeasts2>Pulse
    [N] 14:50:09.850 - [Path-Finding] FindPath from 2971.298 ; -5394.058 ; 135.7778 ; "None" to 3024.844 ; -5147.429 ; 132.9492 ; "None" (Kalimdor)
    [N] 14:50:10.267 - [Path-Finding] Path Count: 19 (276.5257y, 414ms, smoothed)
    [N] 14:50:10.268 - [Path-Finding] FindPath from 3024.844 ; -5147.429 ; 132.9492 ; "None" to 3121.561 ; -5058.395 ; 140.2133 ; "None" (Kalimdor)
    [N] 14:50:10.609 - [Path-Finding] Path Count: 9 (133.2678y, 341ms, smoothed)
    [N] 14:50:10.609 - [Path-Finding] FindPath from 3121.561 ; -5058.395 ; 140.2133 ; "None" to 2948.518 ; -5229.407 ; 131.4716 ; "None" (Kalimdor)
    [N] 14:50:10.950 - [Path-Finding] Path Count: 5 (243.6328y, 340ms, smoothed)
    [N] 14:50:10.951 - [Path-Finding] FindPath from 2948.518 ; -5229.407 ; 131.4716 ; "None" to 2940.913 ; -5432.207 ; 123.026 ; "None" (Kalimdor)
    [N] 14:50:11.295 - [Path-Finding] Path Count: 13 (211.2383y, 344ms, smoothed)
    [N] 14:50:11.295 - [Path-Finding] FindPath from 2940.913 ; -5432.207 ; 123.026 ; "None" to 3088.876 ; -5770.376 ; 16.33735 ; "None" (Kalimdor)
    [N] 14:50:11.647 - [Path-Finding] Path Count: 37 (485.0228y, 351ms, smoothed)
    [N] 14:50:11.647 - [Path-Finding] FindPath from 3088.876 ; -5770.376 ; 16.33735 ; "None" to 3360.201 ; -5538.602 ; 18.79542 ; "None" (Kalimdor)
    [N] 14:50:11.990 - [Path-Finding] Path Count: 7 (362.6261y, 342ms, smoothed)
    [N] 14:50:11.990 - [Path-Finding] FindPath from 3360.201 ; -5538.602 ; 18.79542 ; "None" to 3667.632 ; -5525.905 ; 21.78755 ; "None" (Kalimdor)
    [N] 14:50:12.333 - [Path-Finding] Path Count: 5 (308.1746y, 342ms, smoothed)
    [N] 14:50:12.333 - [Path-Finding] FindPath from 3667.632 ; -5525.905 ; 21.78755 ; "None" to 3853.551 ; -5647.844 ; 15.16007 ; "None" (Kalimdor)
    [N] 14:50:12.675 - [Path-Finding] Path Count: 7 (227.9904y, 342ms, smoothed)
    [N] 14:50:12.675 - [Path-Finding] FindPath from 3853.551 ; -5647.844 ; 15.16007 ; "None" to 3939.223 ; -5864.805 ; 8.561554 ; "None" (Kalimdor)
    [N] 14:50:13.018 - [Path-Finding] Path Count: 13 (236.3589y, 342ms, smoothed)
    [N] 14:50:13.018 - [Path-Finding] FindPath from 3939.223 ; -5864.805 ; 8.561554 ; "None" to 2971.298 ; -5394.058 ; 135.7778 ; "None" (Kalimdor)
    [N] 14:50:13.435 - [Path-Finding] Path Count: 57 (1256.219y, 417ms, smoothed)
    [D] 14:50:13.445 - [Mount] No ground mount selected.
    [D] 14:50:13.445 - [Mount] No aquatic mount selected.
    [D] 14:50:13.445 - [Mount] No flying mount selected.
    [N] 14:50:13.461 - [Path-Finding] FindPath from -7762.74 ; -1591.74 ; -270.222 ; "None" to 2948.518 ; -5229.407 ; 131.4716 ; "None" (Kalimdor)
    [N] 14:50:17.639 - [Path-Finding] Path Count: 1081 (25675y, 4176ms, smoothed)
    14:50:48.504 - [Andoido_Quester_Horde]: Authentication sucessful
    14:50:55.870 - [Pause] started
    14:51:07.647 - [Pause] Stoped
    [N] 14:51:07.711 - [Path-Finding] FindPath from 3341.36 ; -4603.79 ; 92.5027 ; "None" to 3121.561 ; -5058.395 ; 140.2133 ; "None" (Kalimdor)
    [N] 14:51:08.079 - [Path-Finding] Path Count: 23 (657.5963y, 368ms, smoothed)
    14:51:19.259 - [Fight] Player Attack Mosshoof Courser (lvl 53)
    [F] 14:51:21.239 - Fightclass successfully casted: Immolate()
    [F] 14:51:21.570 - Fightclass successfully casted: Immolate()
    [F] 14:51:23.695 - Fightclass successfully casted: Siphon Life()
    [F] 14:51:25.217 - Fightclass successfully casted: Curse of Agony()
    [F] 14:51:26.752 - Fightclass successfully casted: Corruption()
    [F] 14:51:28.330 - Fightclass successfully casted: Shadow Bolt()
    14:51:31.482 - [Looting] Loot Mosshoof Courser
    [N] 14:51:31.483 - [Path-Finding] FindPath from 3130.235 ; -5052.319 ; 139.6838 ; "None" to 3118.681 ; -5056.052 ; 141.134 ; "None" (Kalimdor)
    [N] 14:51:31.823 - [Path-Finding] Path Count: 3 (12.22794y, 340ms, smoothed)
    14:51:35.136 - [Fight] Player Attack Mosshoof Courser (lvl 52)
    [N] 14:51:35.367 - [Path-Finding] FindPath from 3122.368 ; -5054.893 ; 140.5915 ; "None" to 3083.444 ; -5092.193 ; 135.8211 ; "None" (Kalimdor)
    [N] 14:51:35.707 - [Path-Finding] Path Count: 3 (54.12147y, 340ms, smoothed)
    [F] 14:51:38.626 - Fightclass successfully casted: Immolate()
    [F] 14:51:38.898 - Fightclass successfully casted: Immolate()
    [F] 14:51:40.743 - Fightclass successfully casted: Immolate()
    [F] 14:51:42.547 - Fightclass successfully casted: Siphon Life()
    [F] 14:51:44.095 - Fightclass successfully casted: Corruption()
    [F] 14:51:45.658 - Fightclass successfully casted: Curse of Agony()
    [F] 14:51:47.180 - Fightclass successfully casted: Shadow Bolt()
    [F] 14:51:47.473 - Fightclass successfully casted: Shadow Bolt()
    [F] 14:51:50.186 - Fightclass successfully casted: Shadow Bolt()
    [F] 14:51:52.893 - Fightclass successfully casted: Shadow Bolt()
    14:51:57.030 - [Looting] Loot Mosshoof Courser
    [N] 14:51:57.030 - [Path-Finding] FindPath from 3107.655 ; -5069.095 ; 140.8493 ; "None" to 3091.85 ; -5080.934 ; 138.0142 ; "None" (Kalimdor)
    [N] 14:51:57.371 - [Path-Finding] Path Count: 3 (19.94936y, 340ms, smoothed)
    14:52:01.749 - [Fight] Player Attack Mosshoof Courser (lvl 53)
    [N] 14:52:04.699 - [MovementManager] Think we are stuck
    [N] 14:52:04.699 - [MovementManager] Trying something funny, hang on
    [D] 14:52:07.127 - [MovementManager] Avoid wall: StrafeLeft
    [D] 14:52:07.207 - [Fight] Fight stopped
    [E] 14:52:07.227 - !Memory.IsProcessOpen
    [E] 14:52:07.300 - !Memory.IsProcessOpen
    [N] 14:52:07.703 - [MovementManager] Waypoint timed out
    [E] 14:52:07.757 - !Memory.IsProcessOpen
    [E] 14:52:07.764 - !Memory.IsProcessOpen
    [E] 14:52:07.769 - !Memory.IsProcessOpen
    [E] 14:52:07.831 - !Memory.IsProcessOpen
    14:52:28.731 - [WarlockVanilla]: Force closing authentication thread
    14:52:28.741 - Unloaded Warlock Fightclass
    [E] 14:52:28.770 - !Memory.IsProcessOpen
    [E] 14:52:28.800 - !Memory.IsProcessOpen
    [E] 14:52:28.805 - !Memory.IsProcessOpen
    14:52:29.317 - [Quester] Stopped
    [E] 14:52:29.323 - !Memory.IsProcessOpen
    [E] 14:52:29.330 - !Memory.IsProcessOpen
    [E] 14:52:29.337 - !Memory.IsProcessOpen
    [E] 14:52:29.342 - !Memory.IsProcessOpen
    [E] 14:52:29.347 - !Memory.IsProcessOpen
    [E] 14:52:29.352 - !Memory.IsProcessOpen
    [E] 14:52:29.389 - !Memory.IsProcessOpen
    14:52:29.424 - Session statistics:
    Elapsed time: 00h:02m:41s
    XP/HR: 33333 - 125 min
    Kills: 2 (53/hr)
    Deaths: 0 (0/hr)
    Stucks: 0 (0/hr)
    Farms: 0 (0/hr)
    Loots: 2 (53/hr)
    Money/HR: 0 G 00 S 00 C (0 G 00 S 00 C)

    [E] 14:52:29.444 - !Memory.IsProcessOpen
    [E] 14:52:29.455 - !Memory.IsProcessOpen

     

    Edited by Andoido

    Share this comment


    Link to comment
    Share on other sites

    Hi all,

    After the new update the problem still occurs. I created a new character (Horde mage, on vanilla wow) but the error still occurs. (I will also sent you the logs Droidz)

    Share this comment


    Link to comment
    Share on other sites

    The crash seems to happen right as I pull something every time. Looking at Andoido's log it looks like that too. Don't know if it's helpful 😛

    Share this comment


    Link to comment
    Share on other sites

    Yes happening for me as well. Tried many different things, including rebuilding the entire game/robot. Still happens on fresh everything, including new computer.

    Share this comment


    Link to comment
    Share on other sites
    5 hours ago, Droidz said:

    And to start, please try dll without profile (use Automaton))/fightlcass/plugin/wow addon.

    still crashes with error :[

    Share this comment


    Link to comment
    Share on other sites

    Hey i have the same Problems but i dont understand it becaus i can runn it with shami no Problems and when i start the same wow with the lock or the warri it crasches allways

     

    Share this comment


    Link to comment
    Share on other sites
    14 minutes ago, sl1der said:

    im watch three game sessions, a flight normal (pala,war,hunt) war\hunt party now 

    Still not working for me

    Share this comment


    Link to comment
    Share on other sites

    can you tell your server, current zone and character level/race/class please, I tried on several computer I cannot reproduce crash

    Share this comment


    Link to comment
    Share on other sites
    2 minutes ago, Droidz said:

    can you tell your server, current zone and character level/race/class please, I tried on several computer I cannot reproduce crash

    For me its..

    Northdale
    The Barrens around Camp Taurajo
    Level 23 Orc Warrior

    Share this comment


    Link to comment
    Share on other sites

    Droidz - run 2-3 wRobot sessions at the same time. People have said if you do that it happens much faster

    Share this comment


    Link to comment
    Share on other sites

    I tried to run several sessions, to spam hook (with lua), no crash. And it is very small update, no big change, only change affect all version (and problem seem only on Vanilla for few users).

    Can you try with new update

    Share this comment


    Link to comment
    Share on other sites

    It happens to me all the time. I built a new VM and installed wrobot and wow from scratch. no other procesess running, 4vcpu 8gb ram. no addons and no custom classes.

    I can run it and it will crash and I can leave the process in memory and will still get about 30 minutes of grinding out of it before it stops for real.

     

    northdale 

     

    edit: just updated it, will tell you how it goes

    Share this comment


    Link to comment
    Share on other sites

    Log with your last posted patch.
    I play a hunter in Tanaris, but the same happened in Hillsbrand.
    Notes: For me, it crashes as soon as the hunter runs towards a mob, and the second the "click to walk" circle appears beneath the mob, it crashes.

    The only exception is if I start the bot when there is a mob to loot. It then loots, kills one (for some reason just melee) and then crashes the next time it tries to target a mob.

    So my crashes happen almost immediately. 
    Edit: All addons turned off. Automation. Ordush's Beast Master.

    Edit 2: I'll be around all evening again. I'll check back every Overwatch match if you need something from me or if you want me to test and provide logs. Just let me know. 

     

    20.34.25 - [SpellManager] Please wait, loading spellbook...
    20.34.25 - [SpellManager] Spellbook loaded.
    [D] 20.34.25 - [Keybindings]
    Sit / Stand: X
    Backward: S
    Forward: W
    Jump: SPACE
    Strafe Left: LEFT
    Strafe Right: RIGHT
    [D] 20.34.32 - [Blacklist] Added, 0 uniques Npcs, 0 Blackspots and 0 Npcs types (Training dummy ignored = True).
    [F] 20.34.32 - Gather = True ; KillMobs = True ; AttackMobsForExperience = False ; PetBattle = False ; IgnoreNeutral = False ; UseFlyingMount = False ; MaxDistanceFromStartPosition = 299 ; HeightFlight = 30 ; BlackListWhereIAmDead = False ; DisableAttackBeforeAttacked = False ; ObjectNpcHarvest = ; CurrentSetting = Automaton.Bot.AutomatonSetting ; 
    [F] 20.34.32 - [FightClass] No Fight Class selected
    [D] 20.34.32 - [FightPetBattle] Cannot load pet battle fight class, use default.
    [D] 20.34.32 - [Spell] spellName=Battle Pet Training => Failed
    20.34.32 - [Looting] Loot Scorpid Tail Lasher
    [N] 20.34.32 - [Path-Finding] FindPath from -7584,477 ; -3621,639 ; 12,77655 ; "None" to -7575,16 ; -3671,461 ; 12,43131 ; "None" (Kalimdor)
    [N] 20.34.32 - [Path-Finding] Path Count: 3 (50,68661y, 158ms, smoothed)
    20.34.33 - [Automaton] Started
    [D] 20.34.37 - [Mount] No ground mount selected.
    [D] 20.34.37 - [Mount] No aquatic mount selected.
    [D] 20.34.37 - [Mount] No flying mount selected.
    20.34.37 - [Fight] Player Attack Starving Blisterpaw (lvl 42)
    [D] 20.34.44 - [Security] [CHAT] [CHANNEL] (Andutz) LF3M ZF heal+dps
    [D] 20.35.05 - [Security] [CHAT] [CHANNEL] (Afonsobruno) if need love whisper Dwemerkun ( he pay 2000 gold for kiss )
    [D] 20.35.05 - [Security] [CHAT] [CHANNEL] (Akianne) No one from yesterday online to join ?
    20.35.15 - [Looting] Loot Starving Blisterpaw
    20.35.16 - [Fight] Player Attack Roc (lvl 42)
    [N] 20.35.16 - [Path-Finding] FindPath from -7558,107 ; -3639,911 ; 13,60894 ; "None" to -7541,899 ; -3626,827 ; 11,34436 ; "None" (Kalimdor)
    [N] 20.35.16 - [Path-Finding] Path Count: 6 (21,93628y, 61ms, smoothed)
    [N] 20.35.16 - [Path-Finding] FindPath from -7558,107 ; -3639,911 ; 13,60894 ; "None" to -7541,899 ; -3626,827 ; 11,34436 ; "None" (Kalimdor)
    [N] 20.35.16 - [Path-Finding] Path Count: 6 (21,93628y, 62ms, smoothed)
    [N] 20.35.16 - [MovementManager] Try to avoid unsafe zone, change current path
    [D] 20.35.17 - [Security] [CHAT] [CHANNEL] (Andutz) LF1M ZF dps
    [D] 20.35.33 - [Security] [CHAT] [CHANNEL] (Canel) LFM Scarlet Monastery Need 1 Tank, 2 Dps! (Cath)
    20.35.45 - [Fight] Player Attacked by Roc (lvl 43)
    20.36.13 - [Looting] Loot Roc
    [N] 20.36.13 - [Path-Finding] FindPath from -7549,603 ; -3633,698 ; 13,00291 ; "None" to -7546,443 ; -3630,52 ; 12,34198 ; "None" (Kalimdor)
    [N] 20.36.13 - [Path-Finding] Path Count: 4 (6,363315y, 63ms, smoothed)
    20.36.15 - [Fight] Player Attack Scorpid Tail Lasher (lvl 44)
    [N] 20.36.15 - [Path-Finding] FindPath from -7549,408 ; -3633,131 ; 12,92816 ; "None" to -7541,837 ; -3671,31 ; 9,115306 ; "None" (Kalimdor)
    [N] 20.36.15 - [Path-Finding] Path Count: 5 (39,31107y, 98ms, smoothed)
    [E] 20.36.32 - Error injection: Cannot launch it, skipped.
    [E] 20.36.32 - Error injection: Cannot launch it, skipped.
    [E] 20.36.32 - Error injection: Cannot launch it, skipped.
    [E] 20.36.32 - Error injection: Cannot launch it, skipped.
    [E] 20.36.32 - Error injection: Cannot launch it, skipped.
    [E] 20.36.32 - Error injection: Cannot launch it, skipped.
    [N] 20.36.41 - [MovementManager] Think we are stuck
    [N] 20.36.41 - [MovementManager] Trying something funny, hang on
    [D] 20.36.41 - [MovementManager] Avoid wall: StrafeLeft
    [E] 20.36.41 - !Memory.IsProcessOpen
    [D] 20.36.41 - [Fight] Fight stopped
    [E] 20.36.41 - !Memory.IsProcessOpen
    [E] 20.36.41 - !Memory.IsProcessOpen
    [N] 20.36.42 - [MovementManager] Waypoint timed out
    [E] 20.36.42 - !Memory.IsProcessOpen
    [E] 20.36.42 - !Memory.IsProcessOpen
    [E] 20.36.42 - !Memory.IsProcessOpen
    [E] 20.36.42 - !Memory.IsProcessOpen
    [E] 20.36.42 - !Memory.IsProcessOpen
    20.36.42 - [Automaton] Stopped
    [E] 20.36.42 - !Memory.IsProcessOpen
    [E] 20.36.43 - !Memory.IsProcessOpen
    [E] 20.36.43 - !Memory.IsProcessOpen
    [E] 20.36.43 - !Memory.IsProcessOpen
    [E] 20.36.43 - !Memory.IsProcessOpen
    20.36.43 - [Automaton] Stopped
    20.36.43 - [Automaton] Closed

     

    Share this comment


    Link to comment
    Share on other sites
    17 minutes ago, Droidz said:

    You can try to disable "use ctm" in advanced general settings

    I did the last update, disabled all add-ons and the problem persists...

    Are you sure that a version rollback isn't the best choice for the moment?

    Share this comment


    Link to comment
    Share on other sites

    What does 

    [E] 20.36.32 - Error injection: Cannot launch it, skipped.

    Mean? Clearly something with the wrobot program, right?

    Share this comment


    Link to comment
    Share on other sites

    Also, so far with new update I have been running for 1h02m26s. That's nearing the max I've been able to run wrobot for in the past 3 days. I will keep you posted on when/if it crashes.

     

    Share this comment


    Link to comment
    Share on other sites

     

    CTM: on + Use LUA to move: on = crash

    CTM: off + Use LUA to move: on = crash

    Turned the CTM on again. 
    Changed to the standard hunter fightclass: It was behaving really odd. Not stopping, but running closer to the mob, back again and repeat.
    I figured I'd stick with Ordush's to not troubleshoot two things at once.
    Reinstalled Ordush as I remembered I had copied that in from the old wRobot install. 

    Ordush, CTM: off + Use LUA to move: on = Ran fine for a bit, then I stopped it just to try on and off again. 

    Turned on CTM: 4th mob crash

    Turned off CTM thinking I'll just let it run this time to be sure: 2nd mob crash

    Turned off LUA to move (still CTM off): Good after 10 mobs. Will keep running and update you.

     

    Observarion: when the game has crashed, my fans go crazy until I close wRobot. I assume it's a memory leak, but thought I'd mention it. 

     

    Share this comment


    Link to comment
    Share on other sites
    25 minutes ago, Droidz said:

    I haven't copy of old files, I recompiled from old source code (I hope it is ok): wrobotvanilla.zip , but I need to found where is the problem, thank for report, I'll check "Lua to move"

    Didn't work too, the same problem is happening

    Share this comment


    Link to comment
    Share on other sites

    so i ran for 18 mins with lua off and ctm on and it spammed movement then crashed. dont know if thats related to all of this but yeah.

    Share this comment


    Link to comment
    Share on other sites

    Not sure what that last patch you posted was Droidz, but I applied it to another bot and ran it with CTM on, and it crashed after 5 mobs.

    Turned LUA off and it's still running. 

    I don't know what you did to the .dll file you posted before this zip either, but to the other people in here who have crashes with LUA movement on: that's the one I'm running. 
     

    Share this comment


    Link to comment
    Share on other sites

    I ran it for about 3 minutes and got wow internal crash error. So i assume its still going on for everybody

     

    Share this comment


    Link to comment
    Share on other sites

    same its ok with the file inside the zippppppppp, without lua

    Ok for one fightclass, not another one

    Share this comment


    Link to comment
    Share on other sites

    with the files inside the zip im getting a crash after like 3 minutes. most of the time it happens when the bot targets a new mob

    Share this comment


    Link to comment
    Share on other sites

    I think than I found problem, I'll release update quickly (it is the Jump when you use option "Use lua to move")

    Share this comment


    Link to comment
    Share on other sites
    1 minute ago, Droidz said:

    I think than I found problem, I'll release update quickly (it is the Jump when you use option "Use lua to move")

    I often feel so hopeless wanting to help with these things, so I'm glad I could contribute for once ^^

    Share this comment


    Link to comment
    Share on other sites

    It is that, if you use "Use lua to move" option Wow crash when you Jump (and if you use also option "random jump" you get crash after few seconds).

    Thank for your help, and sorry for the delay, I'll add 15 days of subscription at all users of this post.

    I released update

    Share this comment


    Link to comment
    Share on other sites
    Just now, Droidz said:

    It is that, if you use "Use lua to move" option Wow crash when you Jump (and if you use also option "random jump" you get crash after few seconds).

    Thank for your help, and sorry for the delay, I'll add 15 days of subscription at all users of this post.

    I released update

    So... No extra login session 😓

    Do we need to disable the Random Jump or it will be fixed?

    Share this comment


    Link to comment
    Share on other sites

    Ah, so that's why I could run so many tests quickly while others could run for hours 😅
    Gj, Droidz and thanx. 

    Share this comment


    Link to comment
    Share on other sites
    1 minute ago, Chiffon said:

    Ah, so that's why I could run so many tests quickly while others could run for hours 😅
    Gj, Droidz and thanx. 

    yes, if you don't use "Random Jump" option WRobot jump when you are stuck

    Share this comment


    Link to comment
    Share on other sites

    Hello Droidz, congrats for find the bug, thx for the bonus of help

    Say here when we can update wrobot with the good fix

    Share this comment


    Link to comment
    Share on other sites

    So I got banned in netherwing for botting. Im trying kronos now and after 30sec to 1 min im getting this crash im getting some getspell lua error then wow just crashes with the error 132. Im using bambos 1-70 grinder and some paid ret pally fc.

    Share this comment


    Link to comment
    Share on other sites
    3 hours ago, gh0stfac3 said:

    So I got banned in netherwing for botting. Im trying kronos now and after 30sec to 1 min im getting this crash im getting some getspell lua error then wow just crashes with the error 132. Im using bambos 1-70 grinder and some paid ret pally fc.

    hello, do you use fightclass for Vanillma?

    Share this comment


    Link to comment
    Share on other sites


    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Add a comment...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...