Quester Namespace

Classes

 | Class | Description
Public class | ProfileUserSettingsForm | Class ProfileUserSettingsForm. Implements the Form
Public class | SettingsUserControl | Logique d'interaction pour SettingsUserControl.xaml
Help File generated with GhostDoc


ProfileUserSettingsForm Class

Class ProfileUserSettingsForm. Implements the Form

Namespace: Quester
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public class ProfileUserSettingsForm : Form
Public Class ProfileUserSettingsForm _
    Inherits Form
public ref class ProfileUserSettingsForm : public Form

Inheritance Hierarchy

Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
Quester..::..ProfileUserSettingsForm

See Also

ProfileUserSettingsForm Members
Quester Namespace
Form


ProfileUserSettingsForm Members

The ProfileUserSettingsForm type exposes the following members.

Constructors

 | Name | Description
Public method | ProfileUserSettingsForm | Initializes a new instance of the ProfileUserSettingsForm class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Public method | Activate | (Inherited from Form.)
Protected method | ActivateMdiChild(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | AddOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from Form.)
Protected method | ApplyAutoScaling | (Inherited from Form.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Protected method | CenterToParent | (Inherited from Form.)
Protected method | CenterToScreen | (Inherited from Form.)
Public method | Close | (Inherited from Form.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Form.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Clean up any resources being used.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Public method | LayoutMdi(System.Windows.Forms.MdiLayout) | (Inherited from Form.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnActivated(System.EventArgs) | (Inherited from Form.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnClosed(System.EventArgs) | (Inherited from Form.)
Protected method | OnClosing(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from Form.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDeactivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Form.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnFormClosed(System.Windows.Forms.FormClosedEventArgs) | (Inherited from Form.)
Protected method | OnFormClosing(System.Windows.Forms.FormClosingEventArgs) | (Inherited from Form.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Form.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Form.)
Protected method | OnHelpButtonClicked(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInputLanguageChanged(System.Windows.Forms.InputLanguageChangedEventArgs) | (Inherited from Form.)
Protected method | OnInputLanguageChanging(System.Windows.Forms.InputLanguageChangingEventArgs) | (Inherited from Form.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from Form.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from Form.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMaximumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMdiChildActivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuComplete(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuStart(System.EventArgs) | (Inherited from Form.)
Protected method | OnMinimumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Form.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeBegin(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeEnd(System.EventArgs) | (Inherited from Form.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnShown(System.EventArgs) | (Inherited from Form.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from Form.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from Form.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from Form.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | RemoveOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from Form.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from Form.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopLocation(System.Int32,System.Int32) | (Inherited from Form.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Form.)
Public method | Show(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Public method | Show | (Inherited from Control.)
Public method | ShowDialog | (Inherited from Form.)
Public method | ShowDialog(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Form.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from Form.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from Form.)

Properties

 | Name | Description
Public property | AcceptButton | (Inherited from Form.)
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | ActiveMdiChild | (Inherited from Form.)
Public property | AllowDrop | (Inherited from Control.)
Public property | AllowTransparency | (Inherited from Form.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScale | (Inherited from Form.)
Public property | AutoScaleBaseSize | (Inherited from Form.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from Form.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Form.)
Public property | AutoSizeMode | (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Public property | CancelButton | (Inherited from Form.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Form.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | ControlBox | (Inherited from Form.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Form.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DesktopBounds | (Inherited from Form.)
Public property | DesktopLocation | (Inherited from Form.)
Public property | DialogResult | (Inherited from Form.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | FormBorderStyle | (Inherited from Form.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HelpButton | (Inherited from Form.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | Icon | (Inherited from Form.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMdiChild | (Inherited from Form.)
Public property | IsMdiContainer | (Inherited from Form.)
Public property | IsMirrored | (Inherited from Control.)
Public property | IsRestrictedWindow | (Inherited from Form.)
Public property | KeyPreview | (Inherited from Form.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Form.)
Public property | MainMenuStrip | (Inherited from Form.)
Public property | Margin | (Inherited from Form.)
Public property | MaximizeBox | (Inherited from Form.)
Protected property | MaximizedBounds | (Inherited from Form.)
Public property | MaximumSize | (Inherited from Form.)
Public property | MdiChildren | (Inherited from Form.)
Public property | MdiParent | (Inherited from Form.)
Public property | Menu | (Inherited from Form.)
Public property | MergedMenu | (Inherited from Form.)
Public property | MinimizeBox | (Inherited from Form.)
Public property | MinimumSize | (Inherited from Form.)
Public property | Modal | (Inherited from Form.)
Public property | Name | (Inherited from Control.)
Public property | Opacity | (Inherited from Form.)
Public property | OwnedForms | (Inherited from Form.)
Public property | Owner | (Inherited from Form.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | RestoreBounds | (Inherited from Form.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Public property | RightToLeftLayout | (Inherited from Form.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | ShowIcon | (Inherited from Form.)
Public property | ShowInTaskbar | (Inherited from Form.)
Protected property | ShowWithoutActivation | (Inherited from Form.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Form.)
Public property | SizeGripStyle | (Inherited from Form.)
Public property | StartPosition | (Inherited from Form.)
Public property | TabIndex | (Inherited from Form.)
Public property | TabStop | (Inherited from Form.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | (Inherited from Control.)
Public property | TopLevel | (Inherited from Form.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | TopMost | (Inherited from Form.)
Public property | TransparencyKey | (Inherited from Form.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowState | (Inherited from Form.)
Public property | WindowTarget | (Inherited from Control.)

Events

 | Name | Description
Public event | Activated | (Inherited from Form.)
Public event | AutoSizeChanged | (Inherited from Form.)
Public event | AutoValidateChanged | (Inherited from Form.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | Closed | (Inherited from Form.)
Public event | Closing | (Inherited from Form.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Deactivate | (Inherited from Form.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | FormClosed | (Inherited from Form.)
Public event | FormClosing | (Inherited from Form.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpButtonClicked | (Inherited from Form.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | InputLanguageChanged | (Inherited from Form.)
Public event | InputLanguageChanging | (Inherited from Form.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from Form.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Form.)
Public event | MaximizedBoundsChanged | (Inherited from Form.)
Public event | MaximumSizeChanged | (Inherited from Form.)
Public event | MdiChildActivate | (Inherited from Form.)
Public event | MenuComplete | (Inherited from Form.)
Public event | MenuStart | (Inherited from Form.)
Public event | MinimumSizeChanged | (Inherited from Form.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | ResizeBegin | (Inherited from Form.)
Public event | ResizeEnd | (Inherited from Form.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | RightToLeftLayoutChanged | (Inherited from Form.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | Shown | (Inherited from Form.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Form.)
Public event | TabStopChanged | (Inherited from Form.)
Public event | TextChanged | (Inherited from Control.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

ProfileUserSettingsForm Class
Quester Namespace


ProfileUserSettingsForm Constructor

Initializes a new instance of the ProfileUserSettingsForm class.

Namespace: Quester
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public ProfileUserSettingsForm(
    string profilePath
)
Public Sub New ( _
    profilePath As String _
)
public:
ProfileUserSettingsForm(
    String^ profilePath
)

Parameters

profilePath
Type: String
The profile path.

See Also

ProfileUserSettingsForm Class
Quester Namespace


ProfileUserSettingsForm Methods

The ProfileUserSettingsForm type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Public method | Activate | (Inherited from Form.)
Protected method | ActivateMdiChild(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | AddOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from Form.)
Protected method | ApplyAutoScaling | (Inherited from Form.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Protected method | CenterToParent | (Inherited from Form.)
Protected method | CenterToScreen | (Inherited from Form.)
Public method | Close | (Inherited from Form.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Form.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Clean up any resources being used.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Public method | LayoutMdi(System.Windows.Forms.MdiLayout) | (Inherited from Form.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnActivated(System.EventArgs) | (Inherited from Form.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnClosed(System.EventArgs) | (Inherited from Form.)
Protected method | OnClosing(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from Form.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDeactivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Form.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnFormClosed(System.Windows.Forms.FormClosedEventArgs) | (Inherited from Form.)
Protected method | OnFormClosing(System.Windows.Forms.FormClosingEventArgs) | (Inherited from Form.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Form.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Form.)
Protected method | OnHelpButtonClicked(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInputLanguageChanged(System.Windows.Forms.InputLanguageChangedEventArgs) | (Inherited from Form.)
Protected method | OnInputLanguageChanging(System.Windows.Forms.InputLanguageChangingEventArgs) | (Inherited from Form.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from Form.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from Form.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMaximumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMdiChildActivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuComplete(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuStart(System.EventArgs) | (Inherited from Form.)
Protected method | OnMinimumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Form.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeBegin(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeEnd(System.EventArgs) | (Inherited from Form.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnShown(System.EventArgs) | (Inherited from Form.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from Form.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from Form.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from Form.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | RemoveOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from Form.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from Form.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopLocation(System.Int32,System.Int32) | (Inherited from Form.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Form.)
Public method | Show(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Public method | Show | (Inherited from Control.)
Public method | ShowDialog | (Inherited from Form.)
Public method | ShowDialog(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Form.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from Form.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from Form.)

See Also

ProfileUserSettingsForm Class
Quester Namespace


Dispose Method

WRobot

ProfileUserSettingsForm..::..Dispose Method

Overload List

 | Name | Description
Protected method | Dispose(Boolean) | Clean up any resources being used.
Public method | Dispose | (Inherited from Component.)

See Also

ProfileUserSettingsForm Class
ProfileUserSettingsForm Members
Quester Namespace


Dispose Method

ProfileUserSettingsForm..::..Dispose Method

Clean up any resources being used.

Namespace: Quester
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
protected void Dispose(
    bool disposing
)
Protected Sub Dispose ( _
    disposing As Boolean _
)
protected:
void Dispose(
    bool^ disposing
)

Parameters

disposing
Type: Boolean
true if managed resources should be disposed; otherwise, false.

See Also

ProfileUserSettingsForm Class
Quester Namespace


ProfileUserSettingsForm Properties

The ProfileUserSettingsForm type exposes the following members.

Properties

 | Name | Description
Public property | AcceptButton | (Inherited from Form.)
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | ActiveMdiChild | (Inherited from Form.)
Public property | AllowDrop | (Inherited from Control.)
Public property | AllowTransparency | (Inherited from Form.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScale | (Inherited from Form.)
Public property | AutoScaleBaseSize | (Inherited from Form.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from Form.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Form.)
Public property | AutoSizeMode | (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Public property | CancelButton | (Inherited from Form.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Form.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | ControlBox | (Inherited from Form.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Form.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DesktopBounds | (Inherited from Form.)
Public property | DesktopLocation | (Inherited from Form.)
Public property | DialogResult | (Inherited from Form.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | FormBorderStyle | (Inherited from Form.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HelpButton | (Inherited from Form.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | Icon | (Inherited from Form.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMdiChild | (Inherited from Form.)
Public property | IsMdiContainer | (Inherited from Form.)
Public property | IsMirrored | (Inherited from Control.)
Public property | IsRestrictedWindow | (Inherited from Form.)
Public property | KeyPreview | (Inherited from Form.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Form.)
Public property | MainMenuStrip | (Inherited from Form.)
Public property | Margin | (Inherited from Form.)
Public property | MaximizeBox | (Inherited from Form.)
Protected property | MaximizedBounds | (Inherited from Form.)
Public property | MaximumSize | (Inherited from Form.)
Public property | MdiChildren | (Inherited from Form.)
Public property | MdiParent | (Inherited from Form.)
Public property | Menu | (Inherited from Form.)
Public property | MergedMenu | (Inherited from Form.)
Public property | MinimizeBox | (Inherited from Form.)
Public property | MinimumSize | (Inherited from Form.)
Public property | Modal | (Inherited from Form.)
Public property | Name | (Inherited from Control.)
Public property | Opacity | (Inherited from Form.)
Public property | OwnedForms | (Inherited from Form.)
Public property | Owner | (Inherited from Form.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | RestoreBounds | (Inherited from Form.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Public property | RightToLeftLayout | (Inherited from Form.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | ShowIcon | (Inherited from Form.)
Public property | ShowInTaskbar | (Inherited from Form.)
Protected property | ShowWithoutActivation | (Inherited from Form.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Form.)
Public property | SizeGripStyle | (Inherited from Form.)
Public property | StartPosition | (Inherited from Form.)
Public property | TabIndex | (Inherited from Form.)
Public property | TabStop | (Inherited from Form.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | (Inherited from Control.)
Public property | TopLevel | (Inherited from Form.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | TopMost | (Inherited from Form.)
Public property | TransparencyKey | (Inherited from Form.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowState | (Inherited from Form.)
Public property | WindowTarget | (Inherited from Control.)

See Also

ProfileUserSettingsForm Class
Quester Namespace


ProfileUserSettingsForm Events

The ProfileUserSettingsForm type exposes the following members.

Events

 | Name | Description
Public event | Activated | (Inherited from Form.)
Public event | AutoSizeChanged | (Inherited from Form.)
Public event | AutoValidateChanged | (Inherited from Form.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | Closed | (Inherited from Form.)
Public event | Closing | (Inherited from Form.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Deactivate | (Inherited from Form.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | FormClosed | (Inherited from Form.)
Public event | FormClosing | (Inherited from Form.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpButtonClicked | (Inherited from Form.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | InputLanguageChanged | (Inherited from Form.)
Public event | InputLanguageChanging | (Inherited from Form.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from Form.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Form.)
Public event | MaximizedBoundsChanged | (Inherited from Form.)
Public event | MaximumSizeChanged | (Inherited from Form.)
Public event | MdiChildActivate | (Inherited from Form.)
Public event | MenuComplete | (Inherited from Form.)
Public event | MenuStart | (Inherited from Form.)
Public event | MinimumSizeChanged | (Inherited from Form.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | ResizeBegin | (Inherited from Form.)
Public event | ResizeEnd | (Inherited from Form.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | RightToLeftLayoutChanged | (Inherited from Form.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | Shown | (Inherited from Form.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Form.)
Public event | TabStopChanged | (Inherited from Form.)
Public event | TextChanged | (Inherited from Control.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

ProfileUserSettingsForm Class
Quester Namespace


SettingsUserControl Class

Logique d'interaction pour SettingsUserControl.xaml

Namespace: Quester
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public class SettingsUserControl : UserControl
Public Class SettingsUserControl _
    Inherits UserControl
public ref class SettingsUserControl : public UserControl

Inheritance Hierarchy

Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
Quester..::..SettingsUserControl

See Also

SettingsUserControl Members
Quester Namespace


SettingsUserControl Members

The SettingsUserControl type exposes the following members.

Constructors

 | Name | Description
Public method | SettingsUserControl | Initializes a new instance of the SettingsUserControl class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from ContainerControl.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Control.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Control.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(System.Boolean) | (Inherited from ContainerControl.)
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from UserControl.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Control.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from ContainerControl.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from UserControl.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from ContainerControl.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from ScrollableControl.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from ContainerControl.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Control.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Control.)
Public method | Show | (Inherited from Control.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Component.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from ContainerControl.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from UserControl.)

Properties

 | Name | Description
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | AllowDrop | (Inherited from Control.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | (Inherited from UserControl.)
Public property | AutoValidate | (Inherited from UserControl.)
Public property | BackColor | (Inherited from Control.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | (Inherited from UserControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Control.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Control.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMirrored | (Inherited from Control.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Control.)
Public property | Margin | (Inherited from Control.)
Public property | MaximumSize | (Inherited from Control.)
Public property | MinimumSize | (Inherited from Control.)
Public property | Name | (Inherited from Control.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Control.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabStop | (Inherited from Control.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | (Inherited from Control.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowTarget | (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | (Inherited from UserControl.)
Public event | AutoValidateChanged | (Inherited from UserControl.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Control.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Control.)
Public event | TabStopChanged | (Inherited from Control.)
Public event | TextChanged | (Inherited from UserControl.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

SettingsUserControl Class
Quester Namespace


SettingsUserControl Constructor

Initializes a new instance of the SettingsUserControl class.

Namespace: Quester
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public SettingsUserControl()
Public Sub New
public:
SettingsUserControl()

See Also

SettingsUserControl Class
Quester Namespace


SettingsUserControl Methods

The SettingsUserControl type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from ContainerControl.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Control.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Control.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(System.Boolean) | (Inherited from ContainerControl.)
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from UserControl.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Control.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from ContainerControl.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from UserControl.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from ContainerControl.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from ScrollableControl.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from ContainerControl.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Control.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Control.)
Public method | Show | (Inherited from Control.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Component.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from ContainerControl.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from UserControl.)

See Also

SettingsUserControl Class
Quester Namespace


SettingsUserControl Properties

The SettingsUserControl type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | AllowDrop | (Inherited from Control.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | (Inherited from UserControl.)
Public property | AutoValidate | (Inherited from UserControl.)
Public property | BackColor | (Inherited from Control.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | (Inherited from UserControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Control.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Control.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMirrored | (Inherited from Control.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Control.)
Public property | Margin | (Inherited from Control.)
Public property | MaximumSize | (Inherited from Control.)
Public property | MinimumSize | (Inherited from Control.)
Public property | Name | (Inherited from Control.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Control.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabStop | (Inherited from Control.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | (Inherited from Control.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowTarget | (Inherited from Control.)

See Also

SettingsUserControl Class
Quester Namespace


SettingsUserControl Events

The SettingsUserControl type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | (Inherited from UserControl.)
Public event | AutoValidateChanged | (Inherited from UserControl.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Control.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Control.)
Public event | TabStopChanged | (Inherited from Control.)
Public event | TextChanged | (Inherited from UserControl.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

SettingsUserControl Class
Quester Namespace


Quester.Bot Namespace

Classes

 | Class | Description
Public class | ProfileUserSettings | Class ProfileUserSettings.
Public class | QuesterSetting | Class QuesterSetting. Implements the Settings

Interfaces

 | Interface | Description
Public interface | IQuesterCondition |


IQuesterCondition Interface

Namespace: Quester.Bot
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public interface IQuesterCondition
Public Interface IQuesterCondition
public interface class IQuesterCondition

See Also

IQuesterCondition Members
Quester.Bot Namespace


IQuesterCondition Members

The IQuesterCondition type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Pulse |
Public method | Pulse2 |
Public method | ToString | (Inherited from Object.)

See Also

IQuesterCondition Interface
Quester.Bot Namespace


IQuesterCondition Methods

The IQuesterCondition type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Pulse |
Public method | Pulse2 |
Public method | ToString | (Inherited from Object.)

See Also

IQuesterCondition Interface
Quester.Bot Namespace


Pulse Method

IQuesterCondition..::..Pulse Method

Namespace: Quester.Bot
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
bool Pulse()
Function Pulse As Boolean
bool^ Pulse()

See Also

IQuesterCondition Interface
Quester.Bot Namespace


Pulse2 Method

IQuesterCondition..::..Pulse2 Method

Namespace: Quester.Bot
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
void Pulse2()
Sub Pulse2
void Pulse2()

See Also

IQuesterCondition Interface
Quester.Bot Namespace


ProfileUserSettings Class

Class ProfileUserSettings.

Namespace: Quester.Bot
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class ProfileUserSettings
<SerializableAttribute> _
Public Class ProfileUserSettings
[SerializableAttribute]
public ref class ProfileUserSettings

Inheritance Hierarchy

Object
Quester.Bot..::..ProfileUserSettings

See Also

ProfileUserSettings Members
Quester.Bot Namespace


ProfileUserSettings Members

The ProfileUserSettings type exposes the following members.

Constructors

 | Name | Description
Public method | ProfileUserSettings | Initializes a new instance of the ProfileUserSettings class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | ProfilePath | Gets or sets the profile path (relative to "WRobot\Profiles\Quester\").
Public property | SkipSteps | Gets or sets the skipped steps index.

See Also

ProfileUserSettings Class
Quester.Bot Namespace


ProfileUserSettings Constructor

Initializes a new instance of the ProfileUserSettings class.

Namespace: Quester.Bot
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public ProfileUserSettings()
Public Sub New
public:
ProfileUserSettings()

See Also

ProfileUserSettings Class
Quester.Bot Namespace


ProfileUserSettings Methods

The ProfileUserSettings type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

ProfileUserSettings Class
Quester.Bot Namespace


ProfileUserSettings Properties

The ProfileUserSettings type exposes the following members.

Properties

 | Name | Description
Public property | ProfilePath | Gets or sets the profile path (relative to "WRobot\Profiles\Quester\").
Public property | SkipSteps | Gets or sets the skipped steps index.

See Also

ProfileUserSettings Class
Quester.Bot Namespace


ProfilePath Property

ProfileUserSettings..::..ProfilePath Property

Gets or sets the profile path (relative to "WRobot\Profiles\Quester\").

Namespace: Quester.Bot
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public string ProfilePath { get; set; }
Public Property ProfilePath As String
    Get
    Set
public:
property String^ ProfilePath {
    String^ get ();
    void set (String^ value);
}

Field Value

The profile path.

See Also

ProfileUserSettings Class
Quester.Bot Namespace


SkipSteps Property

ProfileUserSettings..::..SkipSteps Property

Gets or sets the skipped steps index.

Namespace: Quester.Bot
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public List<int> SkipSteps { get; set; }
Public Property SkipSteps As List(Of Integer)
    Get
    Set
public:
property List<int^>^ SkipSteps {
    List<int^>^ get ();
    void set (List<int^>^ value);
}

Field Value

The skip steps.

See Also

ProfileUserSettings Class
Quester.Bot Namespace


QuesterSetting Class

Class QuesterSetting. Implements the Settings

Namespace: Quester.Bot
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class QuesterSetting : Settings
<SerializableAttribute> _
Public Class QuesterSetting _
    Inherits Settings
[SerializableAttribute]
public ref class QuesterSetting : public Settings

Inheritance Hierarchy

Object
robotManager.Helpful..::..Settings
Quester.Bot..::..QuesterSetting

See Also

QuesterSetting Members
Quester.Bot Namespace
robotManager.Helpful..::..Settings


QuesterSetting Members

The QuesterSetting type exposes the following members.

Methods

 | Name | Description
Protected method | ConfigWinForm | (Inherited from Settings.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
 | Load | Load settings
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Save()()()() | Save settings
Protected method | Save(String) | Save to xml file (Inherited from Settings.)
Public method | ToForm | Converts to form. (Inherited from Settings.)
Public method | ToString | (Inherited from Object.)
Public method | ToStringFormat | Converts to stringformat. (Inherited from Settings.)

Fields

 | Name | Description
Public field | BlackListWhereIAmDead | BlackList zone where I died
Public field | ProfileName | The profile path (relative to "WRobot\Profiles\Quester\"), but it is better to use ProfileName
Public field | ProfilesUserSettings | Profiles settings (enable/disable quests/steps)
Public field | SaveModifiedGeneralSettings | Save general settings modified by the profiles
Public field | SkipPickUpQuestAfterXSecondes | Skip 'PickUp' quest after (sec), but it is better to use SkipPickUpQuestAfterXSecondes

Properties

Name | Description
CurrentSetting | Gets or sets the current setting.

See Also

QuesterSetting Class
Quester.Bot Namespace


QuesterSetting Fields

The QuesterSetting type exposes the following members.

Fields

 | Name | Description
Public field | BlackListWhereIAmDead | BlackList zone where I died
Public field | ProfileName | The profile path (relative to "WRobot\Profiles\Quester\"), but it is better to use ProfileName
Public field | ProfilesUserSettings | Profiles settings (enable/disable quests/steps)
Public field | SaveModifiedGeneralSettings | Save general settings modified by the profiles
Public field | SkipPickUpQuestAfterXSecondes | Skip 'PickUp' quest after (sec), but it is better to use SkipPickUpQuestAfterXSecondes

See Also

QuesterSetting Class
Quester.Bot Namespace


BlackListWhereIAmDead Field

QuesterSetting..::..BlackListWhereIAmDead Field

BlackList zone where I died

Namespace: Quester.Bot
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public bool BlackListWhereIAmDead
Public BlackListWhereIAmDead As Boolean
public:
bool^ BlackListWhereIAmDead

See Also

QuesterSetting Class
Quester.Bot Namespace


ProfileName Field

QuesterSetting..::..ProfileName Field

The profile path (relative to "WRobot\Profiles\Quester\"), but it is better to use ProfileName

Namespace: Quester.Bot
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public string ProfileName
Public ProfileName As String
public:
String^ ProfileName

See Also

QuesterSetting Class
Quester.Bot Namespace


ProfilesUserSettings Field

QuesterSetting..::..ProfilesUserSettings Field

Profiles settings (enable/disable quests/steps)

Namespace: Quester.Bot
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public List<ProfileUserSettings> ProfilesUserSettings
Public ProfilesUserSettings As List(Of ProfileUserSettings)
public:
List<ProfileUserSettings^>^ ProfilesUserSettings

See Also

QuesterSetting Class
Quester.Bot Namespace


SaveModifiedGeneralSettings Field

QuesterSetting..::..SaveModifiedGeneralSettings Field

Save general settings modified by the profiles

Namespace: Quester.Bot
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public bool SaveModifiedGeneralSettings
Public SaveModifiedGeneralSettings As Boolean
public:
bool^ SaveModifiedGeneralSettings

See Also

QuesterSetting Class
Quester.Bot Namespace


SkipPickUpQuestAfterXSecondes Field

QuesterSetting..::..SkipPickUpQuestAfterXSecondes Field

Skip 'PickUp' quest after (sec), but it is better to use SkipPickUpQuestAfterXSecondes

Namespace: Quester.Bot
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public long SkipPickUpQuestAfterXSecondes
Public SkipPickUpQuestAfterXSecondes As Long
public:
long long^ SkipPickUpQuestAfterXSecondes

See Also

QuesterSetting Class
Quester.Bot Namespace


QuesterSetting Methods

The QuesterSetting type exposes the following members.

Methods

 | Name | Description
Protected method | ConfigWinForm | (Inherited from Settings.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
 | Load | Load settings
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Save()()()() | Save settings
Protected method | Save(String) | Save to xml file (Inherited from Settings.)
Public method | ToForm | Converts to form. (Inherited from Settings.)
Public method | ToString | (Inherited from Object.)
Public method | ToStringFormat | Converts to stringformat. (Inherited from Settings.)

See Also

QuesterSetting Class
Quester.Bot Namespace


Load Method

QuesterSetting..::..Load Method

Load settings

Namespace: Quester.Bot
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public static bool Load()
Public Shared Function Load As Boolean
public:
static bool^ Load()

Return Value

true if success, false otherwise.

See Also

QuesterSetting Class
Quester.Bot Namespace


Save Method

QuesterSetting..::..Save Method

Overload List

 | Name | Description
Public method | Save()()()() | Save settings
Protected method | Save(String) | Save to xml file (Inherited from Settings.)

See Also

QuesterSetting Class
QuesterSetting Members
Quester.Bot Namespace


Save Method

QuesterSetting..::..Save Method

Save settings

Namespace: Quester.Bot
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public bool Save()
Public Function Save As Boolean
public:
bool^ Save()

Return Value

true if success, false otherwise.

See Also

QuesterSetting Class
Quester.Bot Namespace


QuesterSetting Properties

The QuesterSetting type exposes the following members.

Properties

Name | Description
CurrentSetting | Gets or sets the current setting.

See Also

QuesterSetting Class
Quester.Bot Namespace


CurrentSetting Property

QuesterSetting..::..CurrentSetting Property

Gets or sets the current setting.

Namespace: Quester.Bot
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public static QuesterSetting CurrentSetting { get; set; }
Public Shared Property CurrentSetting As QuesterSetting
    Get
    Set
public:
static property QuesterSetting^ CurrentSetting {
    QuesterSetting^ get ();
    void set (QuesterSetting^ value);
}

Field Value

The current setting.

See Also

QuesterSetting Class
Quester.Bot Namespace


Quester.Profile Namespace

Classes

 | Class | Description
Public class | BaseEasyQuestClass | Class BaseEasyQuestClass.
Public class | EasyQuest | Class EasyQuest.
Public class | EasyQuestProfile | Class EasyQuestProfile.
Public class | EntryObjectiveQuest | Class EntryObjectiveQuest.
Public class | FollowNpcEasyQuestClass | Class FollowNpcEasyQuestClass. Implements the BaseEasyQuestClass
Public class | FollowPathEasyQuestClass | Class FollowPathEasyQuestClass. Implements the BaseEasyQuestClass
Public class | FullCSharpCodeEasyQuestClass | Class FullCSharpCodeEasyQuestClass. Implements the BaseEasyQuestClass
Public class | GathererEasyQuestClass | Class GathererEasyQuestClass. Implements the BaseEasyQuestClass
Public class | GrinderGathererEasyQuestClass | Class GrinderGathererEasyQuestClass. Implements the BaseEasyQuestClass
Public class | InteractWithNpcEasyQuestClass | Class InteractWithNpcEasyQuestClass. Implements the BaseEasyQuestClass
Public class | KillAndLootEasyQuestClass | Class KillAndLootEasyQuestClass. Implements the BaseEasyQuestClass
Public class | OverridePulseCSharpCodeEasyQuestClass | Class OverridePulseCSharpCodeEasyQuestClass. Implements the BaseEasyQuestClass
Public class | ParallelQuestsEasyQuestClass | Class ParallelQuestsEasyQuestClass. Implements the BaseEasyQuestClass
Public class | ProfileEditor | Class ProfileEditor. Implements the Form
Public class | QuesterProfile | Class QuesterProfile, old profile replaced by EasyQuestProfile (more info here), but this class still used internally by the quester (EasyQuestProfile is converted to this class)
Public class | UseItemOnEasyQuestClass | Class UseItemOnEasyQuestClass. Implements the BaseEasyQuestClass
Public class | UseScriptOnEasyQuestClass | Class UseScriptOnEasyQuestClass. Implements the BaseEasyQuestClass
Public class | UseSpellOnEasyQuestClass | Class UseSpellOnEasyQuestClass. Implements the BaseEasyQuestClass

Enumerations

 | Enumeration | Description
Public enumeration | EasyQuestType | Enum EasyQuestType


BaseEasyQuestClass Class

Class BaseEasyQuestClass.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
[XmlIncludeAttribute]
[XmlIncludeAttribute]
[XmlIncludeAttribute]
[XmlIncludeAttribute]
[XmlIncludeAttribute]
[XmlIncludeAttribute]
[XmlIncludeAttribute]
[XmlIncludeAttribute]
[XmlIncludeAttribute]
[XmlIncludeAttribute]
[XmlIncludeAttribute]
[XmlIncludeAttribute]
public class BaseEasyQuestClass
<SerializableAttribute> _
<XmlIncludeAttribute> _
<XmlIncludeAttribute> _
<XmlIncludeAttribute> _
<XmlIncludeAttribute> _
<XmlIncludeAttribute> _
<XmlIncludeAttribute> _
<XmlIncludeAttribute> _
<XmlIncludeAttribute> _
<XmlIncludeAttribute> _
<XmlIncludeAttribute> _
<XmlIncludeAttribute> _
<XmlIncludeAttribute> _
Public Class BaseEasyQuestClass
[SerializableAttribute]
[XmlIncludeAttribute]
[XmlIncludeAttribute]
[XmlIncludeAttribute]
[XmlIncludeAttribute]
[XmlIncludeAttribute]
[XmlIncludeAttribute]
[XmlIncludeAttribute]
[XmlIncludeAttribute]
[XmlIncludeAttribute]
[XmlIncludeAttribute]
[XmlIncludeAttribute]
[XmlIncludeAttribute]
public ref class BaseEasyQuestClass

Inheritance Hierarchy

Object
Quester.Profile..::..BaseEasyQuestClass

See Also

BaseEasyQuestClass Members
Quester.Profile Namespace


BaseEasyQuestClass Members

The BaseEasyQuestClass type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

BaseEasyQuestClass Class
Quester.Profile Namespace


BaseEasyQuestClass Methods

The BaseEasyQuestClass type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

BaseEasyQuestClass Class
Quester.Profile Namespace


EasyQuest Class

Class EasyQuest.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class EasyQuest
<SerializableAttribute> _
Public Class EasyQuest
[SerializableAttribute]
public ref class EasyQuest

Inheritance Hierarchy

Object
Quester.Profile..::..EasyQuest

See Also

EasyQuest Members
Quester.Profile Namespace


EasyQuest Members

The EasyQuest type exposes the following members.

Constructors

 | Name | Description
Public method | EasyQuest | Initializes a new instance of the EasyQuest class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance.

Properties

 | Name | Description
Public property | AutoDetectObjectiveCount1 | Gets or sets auto detection of objective count 1
Public property | AutoDetectObjectiveCount2 | Gets or sets auto detection of objective count 2.
Public property | AutoDetectObjectiveCount3 | Gets or sets auto detection of objective count 3.
Public property | AutoDetectObjectiveCount4 | Gets or sets auto detection of objective count 4.
Public property | AutoDetectObjectiveCount5 | Gets or sets auto detection of objective count 5.
Public property | CanCondition | Gets or sets can condition C# code, if the code returning false this quest is skipped (put code like return (ObjectManager.Me.PlayerRace == PlayerFactions.Troll) || (ObjectManager.Me.PlayerRace == PlayerFactions.Orc);)
Public property | Comment | Gets or sets comment (no used in profile, only for help you)
Public property | GossipOptionRewardItem | Gets or sets gossip id of the reward at choose.
Public property | IsCompleteCondition | Gets or sets the is complete condition C# code, if this code return true, quester go to next step, empty if you want than quester manage this (put code like return ItemsManager.GetItemCountById(113578) >= 20;).
Public property | MaxLevel | Gets or sets the maximum level.
Public property | MinLevel | Gets or sets the minimum level.
Public property | Name | Gets or sets unique name
Public property | NameClass | Gets the class name (return Name without space and special character). There can only be one NameClass per profile.
Public property | NotRequiredInQuestLog | Gets or sets a value indicating if quest is not required in quest log. Activate this option if you want pulse and turnin this quest even if it is not in the quest log (if this option is activated, option Objective count 1,... and 'Can Condition' don't work, you need to use option ''Is complete condition'').
Public property | ObjectiveCount1 | Gets or sets the objective count 1.
Public property | ObjectiveCount2 | Gets or sets the objective count 2.
Public property | ObjectiveCount3 | Gets or sets the objective count 3.
Public property | ObjectiveCount4 | Gets or sets the objective count 4.
Public property | ObjectiveCount5 | Gets or sets the objective count 5.
Public property | PickUpQuestOnItem | Gets or sets a value indicating if you take this quest in bag item, don't forget to complete PickUpQuestOnItemID.
Public property | PickUpQuestOnItemID | If option PickUpQuestOnItem is activated, put item id where you take quest.
Public property | QuestClass | Gets or sets quest class (based on QuestType selected).
Public property | QuestId | Gets or sets quest id list.
Public property | QuestType | Gets or sets the type of quest (don't forget to instantiate new instance of QuestClass).
Public property | RepeatableQuest | Gets or sets a value indicating if it is repeatable quest. By default, quester skip the quests already completed, put true if you want than quester don't skip this quest same if already completed (useful for daily quests) (if 'True', this option override the options 'min/max level', 'wow class', 'required quest', ..., you need to check it manually with option 'Can Conditon')
Public property | RequiredQuest | Gets or sets the required completed quest id for pick up this quest (0 to ignore).
Public property | WhenLeaveStep | Gets or sets C# code to run when quest is complete (one time).
Public property | WhenSelectStep | Gets or sets C# code to run before to pulse this quest (one time).
Public property | WoWClass | Gets or sets the wow class required (WoWClass.None to ignore).

See Also

EasyQuest Class
Quester.Profile Namespace


EasyQuest Constructor

Initializes a new instance of the EasyQuest class.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public EasyQuest()
Public Sub New
public:
EasyQuest()

See Also

EasyQuest Class
Quester.Profile Namespace


EasyQuest Methods

The EasyQuest type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance.

See Also

EasyQuest Class
Quester.Profile Namespace


ToString Method

EasyQuest..::..ToString Method

Returns a String that represents this instance.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public string ToString()
Public Function ToString As String
public:
String^ ToString()

Return Value

A String that represents this instance.

See Also

EasyQuest Class
Quester.Profile Namespace


EasyQuest Properties

The EasyQuest type exposes the following members.

Properties

 | Name | Description
Public property | AutoDetectObjectiveCount1 | Gets or sets auto detection of objective count 1
Public property | AutoDetectObjectiveCount2 | Gets or sets auto detection of objective count 2.
Public property | AutoDetectObjectiveCount3 | Gets or sets auto detection of objective count 3.
Public property | AutoDetectObjectiveCount4 | Gets or sets auto detection of objective count 4.
Public property | AutoDetectObjectiveCount5 | Gets or sets auto detection of objective count 5.
Public property | CanCondition | Gets or sets can condition C# code, if the code returning false this quest is skipped (put code like return (ObjectManager.Me.PlayerRace == PlayerFactions.Troll) || (ObjectManager.Me.PlayerRace == PlayerFactions.Orc);)
Public property | Comment | Gets or sets comment (no used in profile, only for help you)
Public property | GossipOptionRewardItem | Gets or sets gossip id of the reward at choose.
Public property | IsCompleteCondition | Gets or sets the is complete condition C# code, if this code return true, quester go to next step, empty if you want than quester manage this (put code like return ItemsManager.GetItemCountById(113578) >= 20;).
Public property | MaxLevel | Gets or sets the maximum level.
Public property | MinLevel | Gets or sets the minimum level.
Public property | Name | Gets or sets unique name
Public property | NameClass | Gets the class name (return Name without space and special character). There can only be one NameClass per profile.
Public property | NotRequiredInQuestLog | Gets or sets a value indicating if quest is not required in quest log. Activate this option if you want pulse and turnin this quest even if it is not in the quest log (if this option is activated, option Objective count 1,... and 'Can Condition' don't work, you need to use option ''Is complete condition'').
Public property | ObjectiveCount1 | Gets or sets the objective count 1.
Public property | ObjectiveCount2 | Gets or sets the objective count 2.
Public property | ObjectiveCount3 | Gets or sets the objective count 3.
Public property | ObjectiveCount4 | Gets or sets the objective count 4.
Public property | ObjectiveCount5 | Gets or sets the objective count 5.
Public property | PickUpQuestOnItem | Gets or sets a value indicating if you take this quest in bag item, don't forget to complete PickUpQuestOnItemID.
Public property | PickUpQuestOnItemID | If option PickUpQuestOnItem is activated, put item id where you take quest.
Public property | QuestClass | Gets or sets quest class (based on QuestType selected).
Public property | QuestId | Gets or sets quest id list.
Public property | QuestType | Gets or sets the type of quest (don't forget to instantiate new instance of QuestClass).
Public property | RepeatableQuest | Gets or sets a value indicating if it is repeatable quest. By default, quester skip the quests already completed, put true if you want than quester don't skip this quest same if already completed (useful for daily quests) (if 'True', this option override the options 'min/max level', 'wow class', 'required quest', ..., you need to check it manually with option 'Can Conditon')
Public property | RequiredQuest | Gets or sets the required completed quest id for pick up this quest (0 to ignore).
Public property | WhenLeaveStep | Gets or sets C# code to run when quest is complete (one time).
Public property | WhenSelectStep | Gets or sets C# code to run before to pulse this quest (one time).
Public property | WoWClass | Gets or sets the wow class required (WoWClass.None to ignore).

See Also

EasyQuest Class
Quester.Profile Namespace


AutoDetectObjectiveCount1 Property

EasyQuest..::..AutoDetectObjectiveCount1 Property

Gets or sets auto detection of objective count 1

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public bool AutoDetectObjectiveCount1 { get; set; }
<SettingAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property AutoDetectObjectiveCount1 As Boolean
    Get
    Set
[SettingAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property bool^ AutoDetectObjectiveCount1 {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if auto detection of objective count 1 otherwise, false.

See Also

EasyQuest Class
Quester.Profile Namespace


AutoDetectObjectiveCount2 Property

EasyQuest..::..AutoDetectObjectiveCount2 Property

Gets or sets auto detection of objective count 2.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public bool AutoDetectObjectiveCount2 { get; set; }
<SettingAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property AutoDetectObjectiveCount2 As Boolean
    Get
    Set
[SettingAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property bool^ AutoDetectObjectiveCount2 {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if auto detection of objective count 2 otherwise, false.

See Also

EasyQuest Class
Quester.Profile Namespace


AutoDetectObjectiveCount3 Property

EasyQuest..::..AutoDetectObjectiveCount3 Property

Gets or sets auto detection of objective count 3.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public bool AutoDetectObjectiveCount3 { get; set; }
<SettingAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property AutoDetectObjectiveCount3 As Boolean
    Get
    Set
[SettingAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property bool^ AutoDetectObjectiveCount3 {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if auto detection of objective count 3 otherwise, false.

See Also

EasyQuest Class
Quester.Profile Namespace


AutoDetectObjectiveCount4 Property

EasyQuest..::..AutoDetectObjectiveCount4 Property

Gets or sets auto detection of objective count 4.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public bool AutoDetectObjectiveCount4 { get; set; }
<SettingAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property AutoDetectObjectiveCount4 As Boolean
    Get
    Set
[SettingAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property bool^ AutoDetectObjectiveCount4 {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if auto detection of objective count 4 otherwise, false.

See Also

EasyQuest Class
Quester.Profile Namespace


AutoDetectObjectiveCount5 Property

EasyQuest..::..AutoDetectObjectiveCount5 Property

Gets or sets auto detection of objective count 5.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public bool AutoDetectObjectiveCount5 { get; set; }
<SettingAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property AutoDetectObjectiveCount5 As Boolean
    Get
    Set
[SettingAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property bool^ AutoDetectObjectiveCount5 {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if auto detection of objective count 5 otherwise, false.

See Also

EasyQuest Class
Quester.Profile Namespace


CanCondition Property

EasyQuest..::..CanCondition Property

Gets or sets can condition C# code, if the code returning false this quest is skipped (put code like return (ObjectManager.Me.PlayerRace == PlayerFactions.Troll) || (ObjectManager.Me.PlayerRace == PlayerFactions.Orc);)

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
[EditorAttribute]
public string CanCondition { get; set; }
<SettingAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
<EditorAttribute> _
Public Property CanCondition As String
    Get
    Set
[SettingAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
[EditorAttribute]
public:
property String^ CanCondition {
    String^ get ();
    void set (String^ value);
}

Field Value

The can condition code.

See Also

EasyQuest Class
Quester.Profile Namespace


Comment Property

EasyQuest..::..Comment Property

Gets or sets comment (no used in profile, only for help you)

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public string Comment { get; set; }
<SettingAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property Comment As String
    Get
    Set
[SettingAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property String^ Comment {
    String^ get ();
    void set (String^ value);
}

Field Value

The comment.

See Also

EasyQuest Class
Quester.Profile Namespace


GossipOptionRewardItem Property

EasyQuest..::..GossipOptionRewardItem Property

Gets or sets gossip id of the reward at choose.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public int GossipOptionRewardItem { get; set; }
<SettingAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property GossipOptionRewardItem As Integer
    Get
    Set
[SettingAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property int^ GossipOptionRewardItem {
    int^ get ();
    void set (int^ value);
}

Field Value

The gossip option id of reward item.

See Also

EasyQuest Class
Quester.Profile Namespace


IsCompleteCondition Property

EasyQuest..::..IsCompleteCondition Property

Gets or sets the is complete condition C# code, if this code return true, quester go to next step, empty if you want than quester manage this (put code like return ItemsManager.GetItemCountById(113578) >= 20;).

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
[EditorAttribute]
public string IsCompleteCondition { get; set; }
<SettingAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
<EditorAttribute> _
Public Property IsCompleteCondition As String
    Get
    Set
[SettingAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
[EditorAttribute]
public:
property String^ IsCompleteCondition {
    String^ get ();
    void set (String^ value);
}

Field Value

The is complete condition code.

See Also

EasyQuest Class
Quester.Profile Namespace


MaxLevel Property

EasyQuest..::..MaxLevel Property

Gets or sets the maximum level.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public int MaxLevel { get; set; }
<SettingAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property MaxLevel As Integer
    Get
    Set
[SettingAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property int^ MaxLevel {
    int^ get ();
    void set (int^ value);
}

Field Value

The maximum level.

See Also

EasyQuest Class
Quester.Profile Namespace


MinLevel Property

EasyQuest..::..MinLevel Property

Gets or sets the minimum level.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public int MinLevel { get; set; }
<SettingAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property MinLevel As Integer
    Get
    Set
[SettingAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property int^ MinLevel {
    int^ get ();
    void set (int^ value);
}

Field Value

The minimum level.

See Also

EasyQuest Class
Quester.Profile Namespace


Name Property

EasyQuest..::..Name Property

Gets or sets unique name

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public string Name { get; set; }
<SettingAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property Name As String
    Get
    Set
[SettingAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Field Value

The name.

See Also

EasyQuest Class
Quester.Profile Namespace


NameClass Property

EasyQuest..::..NameClass Property

Gets the class name (return Name without space and special character). There can only be one NameClass per profile.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public string NameClass { get; }
<SettingAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public ReadOnly Property NameClass As String
    Get
[SettingAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property String^ NameClass {
    String^ get ();
}

Field Value

The name class.

See Also

EasyQuest Class
Quester.Profile Namespace


NotRequiredInQuestLog Property

EasyQuest..::..NotRequiredInQuestLog Property

Gets or sets a value indicating if quest is not required in quest log. Activate this option if you want pulse and turnin this quest even if it is not in the quest log (if this option is activated, option Objective count 1,... and 'Can Condition' don't work, you need to use option ''Is complete condition'').

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public bool NotRequiredInQuestLog { get; set; }
<SettingAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property NotRequiredInQuestLog As Boolean
    Get
    Set
[SettingAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property bool^ NotRequiredInQuestLog {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if not required in quest log otherwise false.

See Also

EasyQuest Class
Quester.Profile Namespace


ObjectiveCount1 Property

EasyQuest..::..ObjectiveCount1 Property

Gets or sets the objective count 1.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public int ObjectiveCount1 { get; set; }
<SettingAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property ObjectiveCount1 As Integer
    Get
    Set
[SettingAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property int^ ObjectiveCount1 {
    int^ get ();
    void set (int^ value);
}

Field Value

The objective count 1.

See Also

EasyQuest Class
Quester.Profile Namespace


ObjectiveCount2 Property

EasyQuest..::..ObjectiveCount2 Property

Gets or sets the objective count 2.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public int ObjectiveCount2 { get; set; }
<SettingAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property ObjectiveCount2 As Integer
    Get
    Set
[SettingAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property int^ ObjectiveCount2 {
    int^ get ();
    void set (int^ value);
}

Field Value

The objective count 2.

See Also

EasyQuest Class
Quester.Profile Namespace


ObjectiveCount3 Property

EasyQuest..::..ObjectiveCount3 Property

Gets or sets the objective count 3.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public int ObjectiveCount3 { get; set; }
<SettingAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property ObjectiveCount3 As Integer
    Get
    Set
[SettingAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property int^ ObjectiveCount3 {
    int^ get ();
    void set (int^ value);
}

Field Value

The objective count 3.

See Also

EasyQuest Class
Quester.Profile Namespace


ObjectiveCount4 Property

EasyQuest..::..ObjectiveCount4 Property

Gets or sets the objective count 4.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public int ObjectiveCount4 { get; set; }
<SettingAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property ObjectiveCount4 As Integer
    Get
    Set
[SettingAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property int^ ObjectiveCount4 {
    int^ get ();
    void set (int^ value);
}

Field Value

The objective count 4.

See Also

EasyQuest Class
Quester.Profile Namespace


ObjectiveCount5 Property

EasyQuest..::..ObjectiveCount5 Property

Gets or sets the objective count 5.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public int ObjectiveCount5 { get; set; }
<SettingAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property ObjectiveCount5 As Integer
    Get
    Set
[SettingAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property int^ ObjectiveCount5 {
    int^ get ();
    void set (int^ value);
}

Field Value

The objective count 5.

See Also

EasyQuest Class
Quester.Profile Namespace


PickUpQuestOnItem Property

EasyQuest..::..PickUpQuestOnItem Property

Gets or sets a value indicating if you take this quest in bag item, don't forget to complete PickUpQuestOnItemID.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public bool PickUpQuestOnItem { get; set; }
<SettingAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property PickUpQuestOnItem As Boolean
    Get
    Set
[SettingAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property bool^ PickUpQuestOnItem {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if you pick up quest on item otherwise false.

See Also

EasyQuest Class
Quester.Profile Namespace


PickUpQuestOnItemID Property

EasyQuest..::..PickUpQuestOnItemID Property

If option PickUpQuestOnItem is activated, put item id where you take quest.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public int PickUpQuestOnItemID { get; set; }
<SettingAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property PickUpQuestOnItemID As Integer
    Get
    Set
[SettingAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property int^ PickUpQuestOnItemID {
    int^ get ();
    void set (int^ value);
}

Field Value

The item id where pickup quest.

See Also

EasyQuest Class
Quester.Profile Namespace


QuestClass Property

EasyQuest..::..QuestClass Property

Gets or sets quest class (based on QuestType selected).

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[BrowsableAttribute]
public BaseEasyQuestClass QuestClass { get; set; }
<BrowsableAttribute> _
Public Property QuestClass As BaseEasyQuestClass
    Get
    Set
[BrowsableAttribute]
public:
property BaseEasyQuestClass^ QuestClass {
    BaseEasyQuestClass^ get ();
    void set (BaseEasyQuestClass^ value);
}

Field Value

The quest class.

See Also

EasyQuest Class
Quester.Profile Namespace


QuestId Property

EasyQuest..::..QuestId Property

Gets or sets quest id list.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[BrowsableAttribute]
public List<int> QuestId { get; set; }
<BrowsableAttribute> _
Public Property QuestId As List(Of Integer)
    Get
    Set
[BrowsableAttribute]
public:
property List<int^>^ QuestId {
    List<int^>^ get ();
    void set (List<int^>^ value);
}

Field Value

Quest IDs.

See Also

EasyQuest Class
Quester.Profile Namespace


QuestType Property

EasyQuest..::..QuestType Property

Gets or sets the type of quest (don't forget to instantiate new instance of QuestClass).

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[BrowsableAttribute]
public EasyQuestType QuestType { get; set; }
<BrowsableAttribute> _
Public Property QuestType As EasyQuestType
    Get
    Set
[BrowsableAttribute]
public:
property EasyQuestType^ QuestType {
    EasyQuestType^ get ();
    void set (EasyQuestType^ value);
}

Field Value

The type of quest.

See Also

EasyQuest Class
Quester.Profile Namespace


RepeatableQuest Property

EasyQuest..::..RepeatableQuest Property

Gets or sets a value indicating if it is repeatable quest. By default, quester skip the quests already completed, put true if you want than quester don't skip this quest same if already completed (useful for daily quests) (if 'True', this option override the options 'min/max level', 'wow class', 'required quest', ..., you need to check it manually with option 'Can Conditon')

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public bool RepeatableQuest { get; set; }
<SettingAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property RepeatableQuest As Boolean
    Get
    Set
[SettingAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property bool^ RepeatableQuest {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if repeatable quest otherwise false.

See Also

EasyQuest Class
Quester.Profile Namespace


RequiredQuest Property

EasyQuest..::..RequiredQuest Property

Gets or sets the required completed quest id for pick up this quest (0 to ignore).

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public int RequiredQuest { get; set; }
<SettingAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property RequiredQuest As Integer
    Get
    Set
[SettingAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property int^ RequiredQuest {
    int^ get ();
    void set (int^ value);
}

Field Value

The required quest id.

See Also

EasyQuest Class
Quester.Profile Namespace


WhenLeaveStep Property

EasyQuest..::..WhenLeaveStep Property

Gets or sets C# code to run when quest is complete (one time).

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
[EditorAttribute]
public string WhenLeaveStep { get; set; }
<SettingAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
<EditorAttribute> _
Public Property WhenLeaveStep As String
    Get
    Set
[SettingAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
[EditorAttribute]
public:
property String^ WhenLeaveStep {
    String^ get ();
    void set (String^ value);
}

Field Value

The when leave step code.

See Also

EasyQuest Class
Quester.Profile Namespace


WhenSelectStep Property

EasyQuest..::..WhenSelectStep Property

Gets or sets C# code to run before to pulse this quest (one time).

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
[EditorAttribute]
public string WhenSelectStep { get; set; }
<SettingAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
<EditorAttribute> _
Public Property WhenSelectStep As String
    Get
    Set
[SettingAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
[EditorAttribute]
public:
property String^ WhenSelectStep {
    String^ get ();
    void set (String^ value);
}

Field Value

The when select step code.

See Also

EasyQuest Class
Quester.Profile Namespace


WoWClass Property

EasyQuest..::..WoWClass Property

Gets or sets the wow class required (WoWClass.None to ignore).

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public WoWClass WoWClass { get; set; }
<SettingAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property WoWClass As WoWClass
    Get
    Set
[SettingAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property WoWClass^ WoWClass {
    WoWClass^ get ();
    void set (WoWClass^ value);
}

Field Value

The required wow class.

See Also

EasyQuest Class
Quester.Profile Namespace


EasyQuestProfile Class

Class EasyQuestProfile.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class EasyQuestProfile
<SerializableAttribute> _
Public Class EasyQuestProfile
[SerializableAttribute]
public ref class EasyQuestProfile

Inheritance Hierarchy

Object
Quester.Profile..::..EasyQuestProfile

See Also

EasyQuestProfile Members
Quester.Profile Namespace


EasyQuestProfile Members

The EasyQuestProfile type exposes the following members.

Constructors

 | Name | Description
Public method | EasyQuestProfile | Initializes a new instance of the EasyQuestProfile class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

Name Description
Public property BlackGuids
Old, unused
Public property BlacklistNpc
Gets or sets the blacklist NPCs by GUID.
Public property BlacklistNpcType
Gets or sets the blacklist NPCs by EntryId.
Public property Blackspots
Gets or sets the blackspots.
Public property EasyQuests
Gets or sets the easy quests.
Public property Npc
Gets or sets the NPC (vendor, repair, ...).
Public property NpcQuest
Gets or sets the NPC quest giver.
Public property OffMeshConnections
Gets or sets the offmeshconnections.
Public property QuestsSorted
Gets or sets steps.
Public property Script
Gets or sets the script custom script.

Examples

C#
public class MyCustomScript
{
     static MyCustomScript()
     {
         // You can put here code to run when bot start, you can also add methods and classes.
     }
}

See Also

EasyQuestProfile Class
Quester.Profile Namespace


EasyQuestProfile Constructor

Initializes a new instance of the EasyQuestProfile class.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public EasyQuestProfile()
Public Sub New
public:
EasyQuestProfile()

See Also

EasyQuestProfile Class
Quester.Profile Namespace


EasyQuestProfile Methods

The EasyQuestProfile type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

EasyQuestProfile Class
Quester.Profile Namespace


EasyQuestProfile Properties

The EasyQuestProfile type exposes the following members.

Properties

Name Description
Public property BlackGuids
Old, unused
Public property BlacklistNpc
Gets or sets the blacklist NPCs by GUID.
Public property BlacklistNpcType
Gets or sets the blacklist NPCs by EntryId.
Public property Blackspots
Gets or sets the blackspots.
Public property EasyQuests
Gets or sets the easy quests.
Public property Npc
Gets or sets the NPC (vendor, repair, ...).
Public property NpcQuest
Gets or sets the NPC quest giver.
Public property OffMeshConnections
Gets or sets the offmeshconnections.
Public property QuestsSorted
Gets or sets steps.
Public property Script
Gets or sets the script custom script.

Examples

C#
public class MyCustomScript
{
     static MyCustomScript()
     {
         // You can put here code to run when bot start, you can also add methods and classes.
     }
}

See Also

EasyQuestProfile Class
Quester.Profile Namespace


BlackGuids Property

EasyQuestProfile..::..BlackGuids Property

Old, unused

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public List<string> BlackGuids { get; set; }
Public Property BlackGuids As List(Of String)
    Get
    Set
public:
property List<String^>^ BlackGuids {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

Field Value

Old, unused.

See Also

EasyQuestProfile Class
Quester.Profile Namespace


BlacklistNpc Property

EasyQuestProfile..::..BlacklistNpc Property

Gets or sets the blacklist NPCs by GUID.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public List<BlackListSerializable..::..BlackNpc> BlacklistNpc { get; set; }
Public Property BlacklistNpc As List(Of BlackListSerializable..::..BlackNpc)
    Get
    Set
public:
property List<BlackListSerializable..::..BlackNpc^>^ BlacklistNpc {
    List<BlackListSerializable..::..BlackNpc^>^ get ();
    void set (List<BlackListSerializable..::..BlackNpc^>^ value);
}

Field Value

The blacklisted NPCs list.

See Also

EasyQuestProfile Class
Quester.Profile Namespace


BlacklistNpcType Property

EasyQuestProfile..::..BlacklistNpcType Property

Gets or sets the blacklist NPCs by EntryId.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public List<BlackListSerializable..::..BlackNpcType> BlacklistNpcType { get; set; }
Public Property BlacklistNpcType As List(Of BlackListSerializable..::..BlackNpcType)
    Get
    Set
public:
property List<BlackListSerializable..::..BlackNpcType^>^ BlacklistNpcType {
    List<BlackListSerializable..::..BlackNpcType^>^ get ();
    void set (List<BlackListSerializable..::..BlackNpcType^>^ value);
}

Field Value

The type of the blacklist NPC.

See Also

EasyQuestProfile Class
Quester.Profile Namespace


Blackspots Property

EasyQuestProfile..::..Blackspots Property

Gets or sets the blackspots.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public List<Blackspot> Blackspots { get; set; }
Public Property Blackspots As List(Of Blackspot)
    Get
    Set
public:
property List<Blackspot^>^ Blackspots {
    List<Blackspot^>^ get ();
    void set (List<Blackspot^>^ value);
}

Field Value

The blackspots.

See Also

EasyQuestProfile Class
Quester.Profile Namespace


EasyQuests Property

EasyQuestProfile..::..EasyQuests Property

Gets or sets the easy quests.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public List<EasyQuest> EasyQuests { get; set; }
Public Property EasyQuests As List(Of EasyQuest)
    Get
    Set
public:
property List<EasyQuest^>^ EasyQuests {
    List<EasyQuest^>^ get ();
    void set (List<EasyQuest^>^ value);
}

Field Value

The easy quests list.

See Also

EasyQuestProfile Class
Quester.Profile Namespace


Npc Property

EasyQuestProfile..::..Npc Property

Gets or sets the NPC (vendor, repair, ...).

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public List<Npc> Npc { get; set; }
Public Property Npc As List(Of Npc)
    Get
    Set
public:
property List<Npc^>^ Npc {
    List<Npc^>^ get ();
    void set (List<Npc^>^ value);
}

Field Value

The NPCs.

See Also

EasyQuestProfile Class
Quester.Profile Namespace


NpcQuest Property

EasyQuestProfile..::..NpcQuest Property

Gets or sets the NPC quest giver.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public List<NPCQuest> NpcQuest { get; set; }
Public Property NpcQuest As List(Of NPCQuest)
    Get
    Set
public:
property List<NPCQuest^>^ NpcQuest {
    List<NPCQuest^>^ get ();
    void set (List<NPCQuest^>^ value);
}

Field Value

The NPCs quest.

See Also

EasyQuestProfile Class
Quester.Profile Namespace


OffMeshConnections Property

EasyQuestProfile..::..OffMeshConnections Property

Gets or sets the offmeshconnections.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public List<PathFinder..::..OffMeshConnection> OffMeshConnections { get; set; }
Public Property OffMeshConnections As List(Of PathFinder..::..OffMeshConnection)
    Get
    Set
public:
property List<PathFinder..::..OffMeshConnection^>^ OffMeshConnections {
    List<PathFinder..::..OffMeshConnection^>^ get ();
    void set (List<PathFinder..::..OffMeshConnection^>^ value);
}

Field Value

The offmeshconnections list.

See Also

EasyQuestProfile Class
Quester.Profile Namespace


QuestsSorted Property

EasyQuestProfile..::..QuestsSorted Property

Gets or sets steps.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public List<QuestsSorted> QuestsSorted { get; set; }
Public Property QuestsSorted As List(Of QuestsSorted)
    Get
    Set
public:
property List<QuestsSorted^>^ QuestsSorted {
    List<QuestsSorted^>^ get ();
    void set (List<QuestsSorted^>^ value);
}

Field Value

The quests sorted.

See Also

EasyQuestProfile Class
Quester.Profile Namespace


Script Property

EasyQuestProfile..::..Script Property

Gets or sets the script custom script.

Examples

C#
public class MyCustomScript
{
     static MyCustomScript()
     {
         // You can put here code to run when bot start, you can also add methods and classes.
     }
}

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public string Script { get; set; }
Public Property Script As String
    Get
    Set
public:
property String^ Script {
    String^ get ();
    void set (String^ value);
}

Field Value

The script.

See Also

EasyQuestProfile Class
Quester.Profile Namespace


EasyQuestType Enumeration

Enum EasyQuestType

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public enum EasyQuestType
<SerializableAttribute> _
Public Enumeration EasyQuestType
[SerializableAttribute]
public enum class EasyQuestType

Members

Member name | Description
None |
KillAndLoot |
Gatherer |
GrinderGathererQuests |
UseItemOn |
UseSpellOn |
UseScriptOn |
InteractWithNpc |
FollowPath |
FollowNpc |
FullCSharpCode |
OverridePulseCSharpCode |
ParallelQuests |

See Also

Quester.Profile Namespace


EntryObjectiveQuest Class

Class EntryObjectiveQuest.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class EntryObjectiveQuest
<SerializableAttribute> _
Public Class EntryObjectiveQuest
[SerializableAttribute]
public ref class EntryObjectiveQuest

Inheritance Hierarchy

Object
Quester.Profile..::..EntryObjectiveQuest

See Also

EntryObjectiveQuest Members
Quester.Profile Namespace


EntryObjectiveQuest Members

The EntryObjectiveQuest type exposes the following members.

Constructors

 | Name | Description
Public method | EntryObjectiveQuest()()()() | Initializes a new instance of the EntryObjectiveQuest class.
Public method | EntryObjectiveQuest(Int32, Int32, Int32, Int32, Boolean, String) | Initializes a new instance of the EntryObjectiveQuest class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Description | Gets or sets the description.
Public property | Entry | Gets or sets the entry.
Public property | ObjectiveNumber | Gets or sets the objective number.
Public property | ObjectiveRequiredAutoDetectCount | Gets or sets a value indicating whether [objective required automatic detect count].
Public property | ObjectiveRequiredCount | Gets or sets the objective required count.
Public property | QuestId | Gets or sets the quest identifier.

See Also

EntryObjectiveQuest Class
Quester.Profile Namespace


EntryObjectiveQuest Constructor

Overload List

 | Name | Description
Public method | EntryObjectiveQuest()()()() | Initializes a new instance of the EntryObjectiveQuest class.
Public method | EntryObjectiveQuest(Int32, Int32, Int32, Int32, Boolean, String) | Initializes a new instance of the EntryObjectiveQuest class.

See Also

EntryObjectiveQuest Class
EntryObjectiveQuest Members
Quester.Profile Namespace


EntryObjectiveQuest Constructor

Initializes a new instance of the EntryObjectiveQuest class.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public EntryObjectiveQuest()
Public Sub New
public:
EntryObjectiveQuest()

See Also

EntryObjectiveQuest Class
EntryObjectiveQuest Overload
Quester.Profile Namespace


EntryObjectiveQuest Constructor (Int32, Int32, Int32, Int32, Boolean, String)

Initializes a new instance of the EntryObjectiveQuest class.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public EntryObjectiveQuest(
    int entry,
    int objectiveNumber,
    int questId,
    int objectiveRequiredCount,
    bool objectiveRequiredAutoDetectCount,
    string description
)
Public Sub New ( _
    entry As Integer, _
    objectiveNumber As Integer, _
    questId As Integer, _
    objectiveRequiredCount As Integer, _
    objectiveRequiredAutoDetectCount As Boolean, _
    description As String _
)
public:
EntryObjectiveQuest(
    int^ entry,
    int^ objectiveNumber,
    int^ questId,
    int^ objectiveRequiredCount,
    bool^ objectiveRequiredAutoDetectCount,
    String^ description
)

Parameters

entry
Type: Int32
The entry.
objectiveNumber
Type: Int32
The objective number.
questId
Type: Int32
The quest identifier.
objectiveRequiredCount
Type: Int32
The objective required count.
objectiveRequiredAutoDetectCount
Type: Boolean
if set to true [objective required automatic detect count].
description
Type: String
The description.

See Also

EntryObjectiveQuest Class
EntryObjectiveQuest Overload
Quester.Profile Namespace


EntryObjectiveQuest Methods

The EntryObjectiveQuest type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

EntryObjectiveQuest Class
Quester.Profile Namespace


EntryObjectiveQuest Properties

The EntryObjectiveQuest type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets or sets the description.
Public property | Entry | Gets or sets the entry.
Public property | ObjectiveNumber | Gets or sets the objective number.
Public property | ObjectiveRequiredAutoDetectCount | Gets or sets a value indicating whether [objective required automatic detect count].
Public property | ObjectiveRequiredCount | Gets or sets the objective required count.
Public property | QuestId | Gets or sets the quest identifier.

See Also

EntryObjectiveQuest Class
Quester.Profile Namespace


Description Property

EntryObjectiveQuest..::..Description Property

Gets or sets the description.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Field Value

The description.

See Also

EntryObjectiveQuest Class
Quester.Profile Namespace


Entry Property

EntryObjectiveQuest..::..Entry Property

Gets or sets the entry.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public int Entry { get; set; }
Public Property Entry As Integer
    Get
    Set
public:
property int^ Entry {
    int^ get ();
    void set (int^ value);
}

Field Value

The entry.

See Also

EntryObjectiveQuest Class
Quester.Profile Namespace


ObjectiveNumber Property

EntryObjectiveQuest..::..ObjectiveNumber Property

Gets or sets the objective number.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public int ObjectiveNumber { get; set; }
Public Property ObjectiveNumber As Integer
    Get
    Set
public:
property int^ ObjectiveNumber {
    int^ get ();
    void set (int^ value);
}

Field Value

The objective number.

See Also

EntryObjectiveQuest Class
Quester.Profile Namespace


ObjectiveRequiredAutoDetectCount Property

EntryObjectiveQuest..::..ObjectiveRequiredAutoDetectCount Property

Gets or sets a value indicating whether [objective required automatic detect count].

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public bool ObjectiveRequiredAutoDetectCount { get; set; }
Public Property ObjectiveRequiredAutoDetectCount As Boolean
    Get
    Set
public:
property bool^ ObjectiveRequiredAutoDetectCount {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if [objective required automatic detect count]; otherwise, false.

See Also

EntryObjectiveQuest Class
Quester.Profile Namespace


ObjectiveRequiredCount Property

EntryObjectiveQuest..::..ObjectiveRequiredCount Property

Gets or sets the objective required count.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public int ObjectiveRequiredCount { get; set; }
Public Property ObjectiveRequiredCount As Integer
    Get
    Set
public:
property int^ ObjectiveRequiredCount {
    int^ get ();
    void set (int^ value);
}

Field Value

The objective required count.

See Also

EntryObjectiveQuest Class
Quester.Profile Namespace


QuestId Property

EntryObjectiveQuest..::..QuestId Property

Gets or sets the quest identifier.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public int QuestId { get; set; }
Public Property QuestId As Integer
    Get
    Set
public:
property int^ QuestId {
    int^ get ();
    void set (int^ value);
}

Field Value

The quest identifier.

See Also

EntryObjectiveQuest Class
Quester.Profile Namespace


FollowNpcEasyQuestClass Class

Class FollowNpcEasyQuestClass. Implements the BaseEasyQuestClass

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class FollowNpcEasyQuestClass : BaseEasyQuestClass
<SerializableAttribute> _
Public Class FollowNpcEasyQuestClass _
    Inherits BaseEasyQuestClass
[SerializableAttribute]
public ref class FollowNpcEasyQuestClass : public BaseEasyQuestClass

Inheritance Hierarchy

Object
Quester.Profile..::..BaseEasyQuestClass
Quester.Profile..::..FollowNpcEasyQuestClass

See Also

FollowNpcEasyQuestClass Members
Quester.Profile Namespace
Quester.Profile..::..BaseEasyQuestClass


FollowNpcEasyQuestClass Members

The FollowNpcEasyQuestClass type exposes the following members.

Constructors

 | Name | Description
Public method | FollowNpcEasyQuestClass | Initializes a new instance of the FollowNpcEasyQuestClass class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Assist | Gets or sets a value indicating whether this FollowNpcEasyQuestClass is assist.
Public property | FollowDistance | Gets or sets the follow distance.
Public property | NpcEntry | Gets or sets the NPC entry.
Public property | StartPosition | Gets or sets the start position.

See Also

FollowNpcEasyQuestClass Class
Quester.Profile Namespace


FollowNpcEasyQuestClass Constructor

Initializes a new instance of the FollowNpcEasyQuestClass class.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public FollowNpcEasyQuestClass()
Public Sub New
public:
FollowNpcEasyQuestClass()

See Also

FollowNpcEasyQuestClass Class
Quester.Profile Namespace


FollowNpcEasyQuestClass Methods

The FollowNpcEasyQuestClass type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

FollowNpcEasyQuestClass Class
Quester.Profile Namespace


FollowNpcEasyQuestClass Properties

The FollowNpcEasyQuestClass type exposes the following members.

Properties

 | Name | Description
Public property | Assist | Gets or sets a value indicating whether this FollowNpcEasyQuestClass is assist.
Public property | FollowDistance | Gets or sets the follow distance.
Public property | NpcEntry | Gets or sets the NPC entry.
Public property | StartPosition | Gets or sets the start position.

See Also

FollowNpcEasyQuestClass Class
Quester.Profile Namespace


Assist Property

FollowNpcEasyQuestClass..::..Assist Property

Gets or sets a value indicating whether this FollowNpcEasyQuestClass is assist.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public bool Assist { get; set; }
Public Property Assist As Boolean
    Get
    Set
public:
property bool^ Assist {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if assist; otherwise, false.

See Also

FollowNpcEasyQuestClass Class
Quester.Profile Namespace


FollowDistance Property

FollowNpcEasyQuestClass..::..FollowDistance Property

Gets or sets the follow distance.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public float FollowDistance { get; set; }
Public Property FollowDistance As Single
    Get
    Set
public:
property float^ FollowDistance {
    float^ get ();
    void set (float^ value);
}

Field Value

The follow distance.

See Also

FollowNpcEasyQuestClass Class
Quester.Profile Namespace


NpcEntry Property

FollowNpcEasyQuestClass..::..NpcEntry Property

Gets or sets the NPC entry.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public int NpcEntry { get; set; }
Public Property NpcEntry As Integer
    Get
    Set
public:
property int^ NpcEntry {
    int^ get ();
    void set (int^ value);
}

Field Value

The NPC entry.

See Also

FollowNpcEasyQuestClass Class
Quester.Profile Namespace


StartPosition Property

FollowNpcEasyQuestClass..::..StartPosition Property

Gets or sets the start position.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public Vector3 StartPosition { get; set; }
Public Property StartPosition As Vector3
    Get
    Set
public:
property Vector3^ StartPosition {
    Vector3^ get ();
    void set (Vector3^ value);
}

Field Value

The start position.

See Also

FollowNpcEasyQuestClass Class
Quester.Profile Namespace


FollowPathEasyQuestClass Class

Class FollowPathEasyQuestClass. Implements the BaseEasyQuestClass

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class FollowPathEasyQuestClass : BaseEasyQuestClass
<SerializableAttribute> _
Public Class FollowPathEasyQuestClass _
    Inherits BaseEasyQuestClass
[SerializableAttribute]
public ref class FollowPathEasyQuestClass : public BaseEasyQuestClass

Inheritance Hierarchy

Object
Quester.Profile..::..BaseEasyQuestClass
Quester.Profile..::..FollowPathEasyQuestClass

See Also

FollowPathEasyQuestClass Members
Quester.Profile Namespace
Quester.Profile..::..BaseEasyQuestClass


FollowPathEasyQuestClass Members

The FollowPathEasyQuestClass type exposes the following members.

Constructors

 | Name | Description
Public method | FollowPathEasyQuestClass | Initializes a new instance of the FollowPathEasyQuestClass class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | ForceToStartFirstPosition | Gets or sets a value indicating whether [force to start first position].
Public property | IsCompleteWhenAtLastPath | Gets or sets a value indicating whether this instance is complete when at last path.
Public property | IsHotSpots | Gets or sets a value indicating whether this instance is hot spots.
Public property | IsLoop | Gets or sets a value indicating whether this instance is loop.
Public property | Path | Gets or sets the path.

See Also

FollowPathEasyQuestClass Class
Quester.Profile Namespace


FollowPathEasyQuestClass Constructor

Initializes a new instance of the FollowPathEasyQuestClass class.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public FollowPathEasyQuestClass()
Public Sub New
public:
FollowPathEasyQuestClass()

See Also

FollowPathEasyQuestClass Class
Quester.Profile Namespace


FollowPathEasyQuestClass Methods

The FollowPathEasyQuestClass type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

FollowPathEasyQuestClass Class
Quester.Profile Namespace


FollowPathEasyQuestClass Properties

The FollowPathEasyQuestClass type exposes the following members.

Properties

 | Name | Description
Public property | ForceToStartFirstPosition | Gets or sets a value indicating whether [force to start first position].
Public property | IsCompleteWhenAtLastPath | Gets or sets a value indicating whether this instance is complete when at last path.
Public property | IsHotSpots | Gets or sets a value indicating whether this instance is hot spots.
Public property | IsLoop | Gets or sets a value indicating whether this instance is loop.
Public property | Path | Gets or sets the path.

See Also

FollowPathEasyQuestClass Class
Quester.Profile Namespace


ForceToStartFirstPosition Property

FollowPathEasyQuestClass..::..ForceToStartFirstPosition Property

Gets or sets a value indicating whether [force to start first position].

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public bool ForceToStartFirstPosition { get; set; }
Public Property ForceToStartFirstPosition As Boolean
    Get
    Set
public:
property bool^ ForceToStartFirstPosition {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if [force to start first position]; otherwise, false.

See Also

FollowPathEasyQuestClass Class
Quester.Profile Namespace


IsCompleteWhenAtLastPath Property

FollowPathEasyQuestClass..::..IsCompleteWhenAtLastPath Property

Gets or sets a value indicating whether this instance is complete when at last path.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public bool IsCompleteWhenAtLastPath { get; set; }
Public Property IsCompleteWhenAtLastPath As Boolean
    Get
    Set
public:
property bool^ IsCompleteWhenAtLastPath {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if this instance is complete when at last path; otherwise, false.

See Also

FollowPathEasyQuestClass Class
Quester.Profile Namespace


IsHotSpots Property

FollowPathEasyQuestClass..::..IsHotSpots Property

Gets or sets a value indicating whether this instance is hot spots.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public bool IsHotSpots { get; set; }
Public Property IsHotSpots As Boolean
    Get
    Set
public:
property bool^ IsHotSpots {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if this instance is hot spots; otherwise, false.

See Also

FollowPathEasyQuestClass Class
Quester.Profile Namespace


IsLoop Property

FollowPathEasyQuestClass..::..IsLoop Property

Gets or sets a value indicating whether this instance is loop.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public bool IsLoop { get; set; }
Public Property IsLoop As Boolean
    Get
    Set
public:
property bool^ IsLoop {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if this instance is loop; otherwise, false.

See Also

FollowPathEasyQuestClass Class
Quester.Profile Namespace


Path Property

FollowPathEasyQuestClass..::..Path Property

Gets or sets the path.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public List<Vector3> Path { get; set; }
Public Property Path As List(Of Vector3)
    Get
    Set
public:
property List<Vector3^>^ Path {
    List<Vector3^>^ get ();
    void set (List<Vector3^>^ value);
}

Field Value

The path.

See Also

FollowPathEasyQuestClass Class
Quester.Profile Namespace


FullCSharpCodeEasyQuestClass Class

Class FullCSharpCodeEasyQuestClass. Implements the BaseEasyQuestClass

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class FullCSharpCodeEasyQuestClass : BaseEasyQuestClass
<SerializableAttribute> _
Public Class FullCSharpCodeEasyQuestClass _
    Inherits BaseEasyQuestClass
[SerializableAttribute]
public ref class FullCSharpCodeEasyQuestClass : public BaseEasyQuestClass

Inheritance Hierarchy

Object
Quester.Profile..::..BaseEasyQuestClass
Quester.Profile..::..FullCSharpCodeEasyQuestClass

See Also

FullCSharpCodeEasyQuestClass Members
Quester.Profile Namespace
Quester.Profile..::..BaseEasyQuestClass


FullCSharpCodeEasyQuestClass Members

The FullCSharpCodeEasyQuestClass type exposes the following members.

Constructors

 | Name | Description
Public method | FullCSharpCodeEasyQuestClass | Initializes a new instance of the FullCSharpCodeEasyQuestClass class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Code | Gets or sets the code.

See Also

FullCSharpCodeEasyQuestClass Class
Quester.Profile Namespace


FullCSharpCodeEasyQuestClass Constructor

Initializes a new instance of the FullCSharpCodeEasyQuestClass class.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public FullCSharpCodeEasyQuestClass()
Public Sub New
public:
FullCSharpCodeEasyQuestClass()

See Also

FullCSharpCodeEasyQuestClass Class
Quester.Profile Namespace


FullCSharpCodeEasyQuestClass Methods

The FullCSharpCodeEasyQuestClass type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

FullCSharpCodeEasyQuestClass Class
Quester.Profile Namespace


FullCSharpCodeEasyQuestClass Properties

The FullCSharpCodeEasyQuestClass type exposes the following members.

Properties

 | Name | Description
Public property | Code | Gets or sets the code.

See Also

FullCSharpCodeEasyQuestClass Class
Quester.Profile Namespace


Code Property

FullCSharpCodeEasyQuestClass..::..Code Property

Gets or sets the code.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public string Code { get; set; }
Public Property Code As String
    Get
    Set
public:
property String^ Code {
    String^ get ();
    void set (String^ value);
}

Field Value

The code.

See Also

FullCSharpCodeEasyQuestClass Class
Quester.Profile Namespace


GathererEasyQuestClass Class

Class GathererEasyQuestClass. Implements the BaseEasyQuestClass

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class GathererEasyQuestClass : BaseEasyQuestClass
<SerializableAttribute> _
Public Class GathererEasyQuestClass _
    Inherits BaseEasyQuestClass
[SerializableAttribute]
public ref class GathererEasyQuestClass : public BaseEasyQuestClass

Inheritance Hierarchy

Object
Quester.Profile..::..BaseEasyQuestClass
Quester.Profile..::..GathererEasyQuestClass

See Also

GathererEasyQuestClass Members
Quester.Profile Namespace
Quester.Profile..::..BaseEasyQuestClass


GathererEasyQuestClass Members

The GathererEasyQuestClass type exposes the following members.

Constructors

 | Name | Description
Public method | GathererEasyQuestClass | Initializes a new instance of the GathererEasyQuestClass class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | EntryIdObjects | Gets or sets the entry identifier objects.
Public property | HotSpots | Gets or sets the hot spots.
Public property | IsHotspots | Gets or sets a value indicating whether this instance is hotspots.

See Also

GathererEasyQuestClass Class
Quester.Profile Namespace


GathererEasyQuestClass Constructor

Initializes a new instance of the GathererEasyQuestClass class.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public GathererEasyQuestClass()
Public Sub New
public:
GathererEasyQuestClass()

See Also

GathererEasyQuestClass Class
Quester.Profile Namespace


GathererEasyQuestClass Methods

The GathererEasyQuestClass type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

GathererEasyQuestClass Class
Quester.Profile Namespace


GathererEasyQuestClass Properties

The GathererEasyQuestClass type exposes the following members.

Properties

 | Name | Description
Public property | EntryIdObjects | Gets or sets the entry identifier objects.
Public property | HotSpots | Gets or sets the hot spots.
Public property | IsHotspots | Gets or sets a value indicating whether this instance is hotspots.

See Also

GathererEasyQuestClass Class
Quester.Profile Namespace


EntryIdObjects Property

GathererEasyQuestClass..::..EntryIdObjects Property

Gets or sets the entry identifier objects.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public List<int> EntryIdObjects { get; set; }
Public Property EntryIdObjects As List(Of Integer)
    Get
    Set
public:
property List<int^>^ EntryIdObjects {
    List<int^>^ get ();
    void set (List<int^>^ value);
}

Field Value

The entry identifier objects.

See Also

GathererEasyQuestClass Class
Quester.Profile Namespace


HotSpots Property

GathererEasyQuestClass..::..HotSpots Property

Gets or sets the hot spots.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public List<Vector3> HotSpots { get; set; }
Public Property HotSpots As List(Of Vector3)
    Get
    Set
public:
property List<Vector3^>^ HotSpots {
    List<Vector3^>^ get ();
    void set (List<Vector3^>^ value);
}

Field Value

The hot spots.

See Also

GathererEasyQuestClass Class
Quester.Profile Namespace


IsHotspots Property

GathererEasyQuestClass..::..IsHotspots Property

Gets or sets a value indicating whether this instance is hotspots.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public bool IsHotspots { get; set; }
Public Property IsHotspots As Boolean
    Get
    Set
public:
property bool^ IsHotspots {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if this instance is hotspots; otherwise, false.

See Also

GathererEasyQuestClass Class
Quester.Profile Namespace


GrinderGathererEasyQuestClass Class

Class GrinderGathererEasyQuestClass. Implements the BaseEasyQuestClass

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class GrinderGathererEasyQuestClass : BaseEasyQuestClass
<SerializableAttribute> _
Public Class GrinderGathererEasyQuestClass _
    Inherits BaseEasyQuestClass
[SerializableAttribute]
public ref class GrinderGathererEasyQuestClass : public BaseEasyQuestClass

Inheritance Hierarchy

Object
Quester.Profile..::..BaseEasyQuestClass
Quester.Profile..::..GrinderGathererEasyQuestClass

See Also

GrinderGathererEasyQuestClass Members
Quester.Profile Namespace
Quester.Profile..::..BaseEasyQuestClass


GrinderGathererEasyQuestClass Members

The GrinderGathererEasyQuestClass type exposes the following members.

Constructors

 | Name | Description
Public method | GrinderGathererEasyQuestClass | Initializes a new instance of the GrinderGathererEasyQuestClass class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | EntryGathererTarget | Gets or sets the entry gatherer target.
Public property | EntryGrinderTarget | Gets or sets the entry grinder target.
Public property | HotSpots | Gets or sets the hot spots.
Public property | IsGrinderNotQuest | Gets or sets a value indicating whether this instance is grinder not quest.
Public property | IsHotspots | Gets or sets a value indicating whether this instance is hotspots.
Public property | RandomizePositions | Randomize positions (if enabled, bot will go to random positions, don't forget to setting RandomizePositionsRadius).
Public property | RandomizePositionsRadius | Maximum distance from position (HotSpots) to randomized position (don't forget to activate option RandomizePositions)..

See Also

GrinderGathererEasyQuestClass Class
Quester.Profile Namespace


GrinderGathererEasyQuestClass Constructor

Initializes a new instance of the GrinderGathererEasyQuestClass class.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public GrinderGathererEasyQuestClass()
Public Sub New
public:
GrinderGathererEasyQuestClass()

See Also

GrinderGathererEasyQuestClass Class
Quester.Profile Namespace


GrinderGathererEasyQuestClass Methods

The GrinderGathererEasyQuestClass type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

GrinderGathererEasyQuestClass Class
Quester.Profile Namespace


GrinderGathererEasyQuestClass Properties

The GrinderGathererEasyQuestClass type exposes the following members.

Properties

 | Name | Description
Public property | EntryGathererTarget | Gets or sets the entry gatherer target.
Public property | EntryGrinderTarget | Gets or sets the entry grinder target.
Public property | HotSpots | Gets or sets the hot spots.
Public property | IsGrinderNotQuest | Gets or sets a value indicating whether this instance is grinder not quest.
Public property | IsHotspots | Gets or sets a value indicating whether this instance is hotspots.
Public property | RandomizePositions | Randomize positions (if enabled, bot will go to random positions, don't forget to setting RandomizePositionsRadius).
Public property | RandomizePositionsRadius | Maximum distance from position (HotSpots) to randomized position (don't forget to activate option RandomizePositions)..

See Also

GrinderGathererEasyQuestClass Class
Quester.Profile Namespace


EntryGathererTarget Property

GrinderGathererEasyQuestClass..::..EntryGathererTarget Property

Gets or sets the entry gatherer target.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public List<EntryObjectiveQuest> EntryGathererTarget { get; set; }
Public Property EntryGathererTarget As List(Of EntryObjectiveQuest)
    Get
    Set
public:
property List<EntryObjectiveQuest^>^ EntryGathererTarget {
    List<EntryObjectiveQuest^>^ get ();
    void set (List<EntryObjectiveQuest^>^ value);
}

Field Value

The entry gatherer target.

See Also

GrinderGathererEasyQuestClass Class
Quester.Profile Namespace


EntryGrinderTarget Property

GrinderGathererEasyQuestClass..::..EntryGrinderTarget Property

Gets or sets the entry grinder target.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public List<EntryObjectiveQuest> EntryGrinderTarget { get; set; }
Public Property EntryGrinderTarget As List(Of EntryObjectiveQuest)
    Get
    Set
public:
property List<EntryObjectiveQuest^>^ EntryGrinderTarget {
    List<EntryObjectiveQuest^>^ get ();
    void set (List<EntryObjectiveQuest^>^ value);
}

Field Value

The entry grinder target.

See Also

GrinderGathererEasyQuestClass Class
Quester.Profile Namespace


HotSpots Property

GrinderGathererEasyQuestClass..::..HotSpots Property

Gets or sets the hot spots.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public List<Vector3> HotSpots { get; set; }
Public Property HotSpots As List(Of Vector3)
    Get
    Set
public:
property List<Vector3^>^ HotSpots {
    List<Vector3^>^ get ();
    void set (List<Vector3^>^ value);
}

Field Value

The hot spots.

See Also

GrinderGathererEasyQuestClass Class
Quester.Profile Namespace


IsGrinderNotQuest Property

GrinderGathererEasyQuestClass..::..IsGrinderNotQuest Property

Gets or sets a value indicating whether this instance is grinder not quest.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public bool IsGrinderNotQuest { get; set; }
Public Property IsGrinderNotQuest As Boolean
    Get
    Set
public:
property bool^ IsGrinderNotQuest {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if this instance is grinder not quest; otherwise, false.

See Also

GrinderGathererEasyQuestClass Class
Quester.Profile Namespace


IsHotspots Property

GrinderGathererEasyQuestClass..::..IsHotspots Property

Gets or sets a value indicating whether this instance is hotspots.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public bool IsHotspots { get; set; }
Public Property IsHotspots As Boolean
    Get
    Set
public:
property bool^ IsHotspots {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if this instance is hotspots; otherwise, false.

See Also

GrinderGathererEasyQuestClass Class
Quester.Profile Namespace


RandomizePositions Property

GrinderGathererEasyQuestClass..::..RandomizePositions Property

Randomize positions (if enabled, bot will go to random positions, don't forget to setting RandomizePositionsRadius).

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public bool RandomizePositions { get; set; }
Public Property RandomizePositions As Boolean
    Get
    Set
public:
property bool^ RandomizePositions {
    bool^ get ();
    void set (bool^ value);
}

See Also

GrinderGathererEasyQuestClass Class
Quester.Profile Namespace


RandomizePositionsRadius Property

GrinderGathererEasyQuestClass..::..RandomizePositionsRadius Property

Maximum distance from position (HotSpots) to randomized position (don't forget to activate option RandomizePositions)..

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public float RandomizePositionsRadius { get; set; }
Public Property RandomizePositionsRadius As Single
    Get
    Set
public:
property float^ RandomizePositionsRadius {
    float^ get ();
    void set (float^ value);
}

See Also

GrinderGathererEasyQuestClass Class
Quester.Profile Namespace


InteractWithNpcEasyQuestClass Class

Class InteractWithNpcEasyQuestClass. Implements the BaseEasyQuestClass

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class InteractWithNpcEasyQuestClass : BaseEasyQuestClass
<SerializableAttribute> _
Public Class InteractWithNpcEasyQuestClass _
    Inherits BaseEasyQuestClass
[SerializableAttribute]
public ref class InteractWithNpcEasyQuestClass : public BaseEasyQuestClass

Inheritance Hierarchy

Object
Quester.Profile..::..BaseEasyQuestClass
Quester.Profile..::..InteractWithNpcEasyQuestClass

See Also

InteractWithNpcEasyQuestClass Members
Quester.Profile Namespace
Quester.Profile..::..BaseEasyQuestClass


InteractWithNpcEasyQuestClass Members

The InteractWithNpcEasyQuestClass type exposes the following members.

Constructors

 | Name | Description
Public method | InteractWithNpcEasyQuestClass | Initializes a new instance of the InteractWithNpcEasyQuestClass class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | EntryIdTarget | Gets or sets the entry identifier target.
Public property | GossipOptionNpcInteractWith | Gets or sets the gossip option NPC interact with.
Public property | HotSpots | Gets or sets the hot spots.
Public property | IgnoreIfDead | Gets or sets a value indicating whether [ignore if dead].
Public property | Macro | Gets or sets the macro.
Public property | Range | Gets or sets the range.

See Also

InteractWithNpcEasyQuestClass Class
Quester.Profile Namespace


InteractWithNpcEasyQuestClass Constructor

Initializes a new instance of the InteractWithNpcEasyQuestClass class.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public InteractWithNpcEasyQuestClass()
Public Sub New
public:
InteractWithNpcEasyQuestClass()

See Also

InteractWithNpcEasyQuestClass Class
Quester.Profile Namespace


InteractWithNpcEasyQuestClass Methods

The InteractWithNpcEasyQuestClass type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

InteractWithNpcEasyQuestClass Class
Quester.Profile Namespace


InteractWithNpcEasyQuestClass Properties

The InteractWithNpcEasyQuestClass type exposes the following members.

Properties

 | Name | Description
Public property | EntryIdTarget | Gets or sets the entry identifier target.
Public property | GossipOptionNpcInteractWith | Gets or sets the gossip option NPC interact with.
Public property | HotSpots | Gets or sets the hot spots.
Public property | IgnoreIfDead | Gets or sets a value indicating whether [ignore if dead].
Public property | Macro | Gets or sets the macro.
Public property | Range | Gets or sets the range.

See Also

InteractWithNpcEasyQuestClass Class
Quester.Profile Namespace


EntryIdTarget Property

InteractWithNpcEasyQuestClass..::..EntryIdTarget Property

Gets or sets the entry identifier target.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public List<int> EntryIdTarget { get; set; }
Public Property EntryIdTarget As List(Of Integer)
    Get
    Set
public:
property List<int^>^ EntryIdTarget {
    List<int^>^ get ();
    void set (List<int^>^ value);
}

Field Value

The entry identifier target.

See Also

InteractWithNpcEasyQuestClass Class
Quester.Profile Namespace


GossipOptionNpcInteractWith Property

InteractWithNpcEasyQuestClass..::..GossipOptionNpcInteractWith Property

Gets or sets the gossip option NPC interact with.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public int GossipOptionNpcInteractWith { get; set; }
Public Property GossipOptionNpcInteractWith As Integer
    Get
    Set
public:
property int^ GossipOptionNpcInteractWith {
    int^ get ();
    void set (int^ value);
}

Field Value

The gossip option NPC interact with.

See Also

InteractWithNpcEasyQuestClass Class
Quester.Profile Namespace


HotSpots Property

InteractWithNpcEasyQuestClass..::..HotSpots Property

Gets or sets the hot spots.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public List<Vector3> HotSpots { get; set; }
Public Property HotSpots As List(Of Vector3)
    Get
    Set
public:
property List<Vector3^>^ HotSpots {
    List<Vector3^>^ get ();
    void set (List<Vector3^>^ value);
}

Field Value

The hot spots.

See Also

InteractWithNpcEasyQuestClass Class
Quester.Profile Namespace


IgnoreIfDead Property

InteractWithNpcEasyQuestClass..::..IgnoreIfDead Property

Gets or sets a value indicating whether [ignore if dead].

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public bool IgnoreIfDead { get; set; }
Public Property IgnoreIfDead As Boolean
    Get
    Set
public:
property bool^ IgnoreIfDead {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if [ignore if dead]; otherwise, false.

See Also

InteractWithNpcEasyQuestClass Class
Quester.Profile Namespace


Macro Property

InteractWithNpcEasyQuestClass..::..Macro Property

Gets or sets the macro.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public string Macro { get; set; }
Public Property Macro As String
    Get
    Set
public:
property String^ Macro {
    String^ get ();
    void set (String^ value);
}

Field Value

The macro.

See Also

InteractWithNpcEasyQuestClass Class
Quester.Profile Namespace


Range Property

InteractWithNpcEasyQuestClass..::..Range Property

Gets or sets the range.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public float Range { get; set; }
Public Property Range As Single
    Get
    Set
public:
property float^ Range {
    float^ get ();
    void set (float^ value);
}

Field Value

The range.

See Also

InteractWithNpcEasyQuestClass Class
Quester.Profile Namespace


KillAndLootEasyQuestClass Class

Class KillAndLootEasyQuestClass. Implements the BaseEasyQuestClass

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class KillAndLootEasyQuestClass : BaseEasyQuestClass
<SerializableAttribute> _
Public Class KillAndLootEasyQuestClass _
    Inherits BaseEasyQuestClass
[SerializableAttribute]
public ref class KillAndLootEasyQuestClass : public BaseEasyQuestClass

Inheritance Hierarchy

Object
Quester.Profile..::..BaseEasyQuestClass
Quester.Profile..::..KillAndLootEasyQuestClass

See Also

KillAndLootEasyQuestClass Members
Quester.Profile Namespace
Quester.Profile..::..BaseEasyQuestClass


KillAndLootEasyQuestClass Members

The KillAndLootEasyQuestClass type exposes the following members.

Constructors

 | Name | Description
Public method | KillAndLootEasyQuestClass | Initializes a new instance of the KillAndLootEasyQuestClass class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | EntryTarget | Gets or sets the entry target.
Public property | HotSpots | Gets or sets the hot spots.
Public property | IsGrinderNotQuest | Gets or sets a value indicating whether this instance is grinder not quest.
Public property | IsHotspots | Gets or sets a value indicating whether this instance is hotspots.

See Also

KillAndLootEasyQuestClass Class
Quester.Profile Namespace


KillAndLootEasyQuestClass Constructor

Initializes a new instance of the KillAndLootEasyQuestClass class.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public KillAndLootEasyQuestClass()
Public Sub New
public:
KillAndLootEasyQuestClass()

See Also

KillAndLootEasyQuestClass Class
Quester.Profile Namespace


KillAndLootEasyQuestClass Methods

The KillAndLootEasyQuestClass type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

KillAndLootEasyQuestClass Class
Quester.Profile Namespace


KillAndLootEasyQuestClass Properties

The KillAndLootEasyQuestClass type exposes the following members.

Properties

 | Name | Description
Public property | EntryTarget | Gets or sets the entry target.
Public property | HotSpots | Gets or sets the hot spots.
Public property | IsGrinderNotQuest | Gets or sets a value indicating whether this instance is grinder not quest.
Public property | IsHotspots | Gets or sets a value indicating whether this instance is hotspots.

See Also

KillAndLootEasyQuestClass Class
Quester.Profile Namespace


EntryTarget Property

KillAndLootEasyQuestClass..::..EntryTarget Property

Gets or sets the entry target.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public List<int> EntryTarget { get; set; }
Public Property EntryTarget As List(Of Integer)
    Get
    Set
public:
property List<int^>^ EntryTarget {
    List<int^>^ get ();
    void set (List<int^>^ value);
}

Field Value

The entry target.

See Also

KillAndLootEasyQuestClass Class
Quester.Profile Namespace


HotSpots Property

KillAndLootEasyQuestClass..::..HotSpots Property

Gets or sets the hot spots.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public List<Vector3> HotSpots { get; set; }
Public Property HotSpots As List(Of Vector3)
    Get
    Set
public:
property List<Vector3^>^ HotSpots {
    List<Vector3^>^ get ();
    void set (List<Vector3^>^ value);
}

Field Value

The hot spots.

See Also

KillAndLootEasyQuestClass Class
Quester.Profile Namespace


IsGrinderNotQuest Property

KillAndLootEasyQuestClass..::..IsGrinderNotQuest Property

Gets or sets a value indicating whether this instance is grinder not quest.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public bool IsGrinderNotQuest { get; set; }
Public Property IsGrinderNotQuest As Boolean
    Get
    Set
public:
property bool^ IsGrinderNotQuest {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if this instance is grinder not quest; otherwise, false.

See Also

KillAndLootEasyQuestClass Class
Quester.Profile Namespace


IsHotspots Property

KillAndLootEasyQuestClass..::..IsHotspots Property

Gets or sets a value indicating whether this instance is hotspots.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public bool IsHotspots { get; set; }
Public Property IsHotspots As Boolean
    Get
    Set
public:
property bool^ IsHotspots {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if this instance is hotspots; otherwise, false.

See Also

KillAndLootEasyQuestClass Class
Quester.Profile Namespace


OverridePulseCSharpCodeEasyQuestClass Class

Class OverridePulseCSharpCodeEasyQuestClass. Implements the BaseEasyQuestClass

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class OverridePulseCSharpCodeEasyQuestClass : BaseEasyQuestClass
<SerializableAttribute> _
Public Class OverridePulseCSharpCodeEasyQuestClass _
    Inherits BaseEasyQuestClass
[SerializableAttribute]
public ref class OverridePulseCSharpCodeEasyQuestClass : public BaseEasyQuestClass

Inheritance Hierarchy

Object
Quester.Profile..::..BaseEasyQuestClass
Quester.Profile..::..OverridePulseCSharpCodeEasyQuestClass

See Also

OverridePulseCSharpCodeEasyQuestClass Members
Quester.Profile Namespace
Quester.Profile..::..BaseEasyQuestClass


OverridePulseCSharpCodeEasyQuestClass Members

The OverridePulseCSharpCodeEasyQuestClass type exposes the following members.

Constructors

 | Name | Description
Public method | OverridePulseCSharpCodeEasyQuestClass | Initializes a new instance of the OverridePulseCSharpCodeEasyQuestClass class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Code | Gets or sets the code.

See Also

OverridePulseCSharpCodeEasyQuestClass Class
Quester.Profile Namespace


OverridePulseCSharpCodeEasyQuestClass Constructor

Initializes a new instance of the OverridePulseCSharpCodeEasyQuestClass class.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public OverridePulseCSharpCodeEasyQuestClass()
Public Sub New
public:
OverridePulseCSharpCodeEasyQuestClass()

See Also

OverridePulseCSharpCodeEasyQuestClass Class
Quester.Profile Namespace


OverridePulseCSharpCodeEasyQuestClass Methods

The OverridePulseCSharpCodeEasyQuestClass type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

OverridePulseCSharpCodeEasyQuestClass Class
Quester.Profile Namespace


OverridePulseCSharpCodeEasyQuestClass Properties

The OverridePulseCSharpCodeEasyQuestClass type exposes the following members.

Properties

 | Name | Description
Public property | Code | Gets or sets the code.

See Also

OverridePulseCSharpCodeEasyQuestClass Class
Quester.Profile Namespace


Code Property

OverridePulseCSharpCodeEasyQuestClass..::..Code Property

Gets or sets the code.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public string Code { get; set; }
Public Property Code As String
    Get
    Set
public:
property String^ Code {
    String^ get ();
    void set (String^ value);
}

Field Value

The code.

See Also

OverridePulseCSharpCodeEasyQuestClass Class
Quester.Profile Namespace


ParallelQuestsEasyQuestClass Class

Class ParallelQuestsEasyQuestClass. Implements the BaseEasyQuestClass

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class ParallelQuestsEasyQuestClass : BaseEasyQuestClass
<SerializableAttribute> _
Public Class ParallelQuestsEasyQuestClass _
    Inherits BaseEasyQuestClass
[SerializableAttribute]
public ref class ParallelQuestsEasyQuestClass : public BaseEasyQuestClass

Inheritance Hierarchy

Object
Quester.Profile..::..BaseEasyQuestClass
Quester.Profile..::..ParallelQuestsEasyQuestClass

See Also

ParallelQuestsEasyQuestClass Members
Quester.Profile Namespace
Quester.Profile..::..BaseEasyQuestClass


ParallelQuestsEasyQuestClass Members

The ParallelQuestsEasyQuestClass type exposes the following members.

Constructors

 | Name | Description
Public method | ParallelQuestsEasyQuestClass | Initializes a new instance of the ParallelQuestsEasyQuestClass class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | SkipNextPulseIfKillOrFarm | Gets or sets a value indicating whether [skip next pulse if kill or farm].
Public property | SubQuestsClassName | Gets or sets the name of the sub quests class.

See Also

ParallelQuestsEasyQuestClass Class
Quester.Profile Namespace


ParallelQuestsEasyQuestClass Constructor

Initializes a new instance of the ParallelQuestsEasyQuestClass class.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public ParallelQuestsEasyQuestClass()
Public Sub New
public:
ParallelQuestsEasyQuestClass()

See Also

ParallelQuestsEasyQuestClass Class
Quester.Profile Namespace


ParallelQuestsEasyQuestClass Methods

The ParallelQuestsEasyQuestClass type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

ParallelQuestsEasyQuestClass Class
Quester.Profile Namespace


ParallelQuestsEasyQuestClass Properties

The ParallelQuestsEasyQuestClass type exposes the following members.

Properties

 | Name | Description
Public property | SkipNextPulseIfKillOrFarm | Gets or sets a value indicating whether [skip next pulse if kill or farm].
Public property | SubQuestsClassName | Gets or sets the name of the sub quests class.

See Also

ParallelQuestsEasyQuestClass Class
Quester.Profile Namespace


SkipNextPulseIfKillOrFarm Property

ParallelQuestsEasyQuestClass..::..SkipNextPulseIfKillOrFarm Property

Gets or sets a value indicating whether [skip next pulse if kill or farm].

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public bool SkipNextPulseIfKillOrFarm { get; set; }
Public Property SkipNextPulseIfKillOrFarm As Boolean
    Get
    Set
public:
property bool^ SkipNextPulseIfKillOrFarm {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if [skip next pulse if kill or farm]; otherwise, false.

See Also

ParallelQuestsEasyQuestClass Class
Quester.Profile Namespace


SubQuestsClassName Property

ParallelQuestsEasyQuestClass..::..SubQuestsClassName Property

Gets or sets the name of the sub quests class.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public List<string> SubQuestsClassName { get; set; }
Public Property SubQuestsClassName As List(Of String)
    Get
    Set
public:
property List<String^>^ SubQuestsClassName {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

Field Value

The name of the sub quests class.

See Also

ParallelQuestsEasyQuestClass Class
Quester.Profile Namespace


ProfileEditor Class

Class ProfileEditor. Implements the Form

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public class ProfileEditor : Form
Public Class ProfileEditor _
    Inherits Form
public ref class ProfileEditor : public Form

Inheritance Hierarchy

Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
Quester.Profile..::..ProfileEditor

See Also

ProfileEditor Members
Quester.Profile Namespace
Form


ProfileEditor Members

The ProfileEditor type exposes the following members.

Constructors

 | Name | Description
Public method | ProfileEditor | Initializes a new instance of the ProfileEditor class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Public method | Activate | (Inherited from Form.)
Protected method | ActivateMdiChild(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | AddOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from Form.)
Protected method | ApplyAutoScaling | (Inherited from Form.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Protected method | CenterToParent | (Inherited from Form.)
Protected method | CenterToScreen | (Inherited from Form.)
Public method | Close | (Inherited from Form.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Form.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Clean up any resources being used.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Public method | LayoutMdi(System.Windows.Forms.MdiLayout) | (Inherited from Form.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnActivated(System.EventArgs) | (Inherited from Form.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnClosed(System.EventArgs) | (Inherited from Form.)
Protected method | OnClosing(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from Form.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDeactivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Form.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnFormClosed(System.Windows.Forms.FormClosedEventArgs) | (Inherited from Form.)
Protected method | OnFormClosing(System.Windows.Forms.FormClosingEventArgs) | (Inherited from Form.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Form.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Form.)
Protected method | OnHelpButtonClicked(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInputLanguageChanged(System.Windows.Forms.InputLanguageChangedEventArgs) | (Inherited from Form.)
Protected method | OnInputLanguageChanging(System.Windows.Forms.InputLanguageChangingEventArgs) | (Inherited from Form.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from Form.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from Form.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMaximumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMdiChildActivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuComplete(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuStart(System.EventArgs) | (Inherited from Form.)
Protected method | OnMinimumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Form.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeBegin(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeEnd(System.EventArgs) | (Inherited from Form.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnShown(System.EventArgs) | (Inherited from Form.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from Form.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from Form.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from Form.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | RemoveOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from Form.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from Form.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopLocation(System.Int32,System.Int32) | (Inherited from Form.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Form.)
Public method | Show(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Public method | Show | (Inherited from Control.)
Public method | ShowDialog | (Inherited from Form.)
Public method | ShowDialog(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Form.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from Form.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from Form.)

Properties

 | Name | Description
Public property | AcceptButton | (Inherited from Form.)
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | ActiveMdiChild | (Inherited from Form.)
Public property | AllowDrop | (Inherited from Control.)
Public property | AllowTransparency | (Inherited from Form.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScale | (Inherited from Form.)
Public property | AutoScaleBaseSize | (Inherited from Form.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from Form.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Form.)
Public property | AutoSizeMode | (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Public property | CancelButton | (Inherited from Form.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Form.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | ControlBox | (Inherited from Form.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Form.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DesktopBounds | (Inherited from Form.)
Public property | DesktopLocation | (Inherited from Form.)
Public property | DialogResult | (Inherited from Form.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | FormBorderStyle | (Inherited from Form.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HelpButton | (Inherited from Form.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | Icon | (Inherited from Form.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMdiChild | (Inherited from Form.)
Public property | IsMdiContainer | (Inherited from Form.)
Public property | IsMirrored | (Inherited from Control.)
Public property | IsRestrictedWindow | (Inherited from Form.)
Public property | KeyPreview | (Inherited from Form.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Form.)
Public property | MainMenuStrip | (Inherited from Form.)
Public property | Margin | (Inherited from Form.)
Public property | MaximizeBox | (Inherited from Form.)
Protected property | MaximizedBounds | (Inherited from Form.)
Public property | MaximumSize | (Inherited from Form.)
Public property | MdiChildren | (Inherited from Form.)
Public property | MdiParent | (Inherited from Form.)
Public property | Menu | (Inherited from Form.)
Public property | MergedMenu | (Inherited from Form.)
Public property | MinimizeBox | (Inherited from Form.)
Public property | MinimumSize | (Inherited from Form.)
Public property | Modal | (Inherited from Form.)
Public property | Name | (Inherited from Control.)
Public property | Opacity | (Inherited from Form.)
Public property | OwnedForms | (Inherited from Form.)
Public property | Owner | (Inherited from Form.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | RestoreBounds | (Inherited from Form.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Public property | RightToLeftLayout | (Inherited from Form.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | ShowIcon | (Inherited from Form.)
Public property | ShowInTaskbar | (Inherited from Form.)
Protected property | ShowWithoutActivation | (Inherited from Form.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Form.)
Public property | SizeGripStyle | (Inherited from Form.)
Public property | StartPosition | (Inherited from Form.)
Public property | TabIndex | (Inherited from Form.)
Public property | TabStop | (Inherited from Form.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | (Inherited from Control.)
Public property | TopLevel | (Inherited from Form.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | TopMost | (Inherited from Form.)
Public property | TransparencyKey | (Inherited from Form.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowState | (Inherited from Form.)
Public property | WindowTarget | (Inherited from Control.)

Events

 | Name | Description
Public event | Activated | (Inherited from Form.)
Public event | AutoSizeChanged | (Inherited from Form.)
Public event | AutoValidateChanged | (Inherited from Form.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | Closed | (Inherited from Form.)
Public event | Closing | (Inherited from Form.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Deactivate | (Inherited from Form.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | FormClosed | (Inherited from Form.)
Public event | FormClosing | (Inherited from Form.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpButtonClicked | (Inherited from Form.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | InputLanguageChanged | (Inherited from Form.)
Public event | InputLanguageChanging | (Inherited from Form.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from Form.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Form.)
Public event | MaximizedBoundsChanged | (Inherited from Form.)
Public event | MaximumSizeChanged | (Inherited from Form.)
Public event | MdiChildActivate | (Inherited from Form.)
Public event | MenuComplete | (Inherited from Form.)
Public event | MenuStart | (Inherited from Form.)
Public event | MinimumSizeChanged | (Inherited from Form.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | ResizeBegin | (Inherited from Form.)
Public event | ResizeEnd | (Inherited from Form.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | RightToLeftLayoutChanged | (Inherited from Form.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | Shown | (Inherited from Form.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Form.)
Public event | TabStopChanged | (Inherited from Form.)
Public event | TextChanged | (Inherited from Control.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

ProfileEditor Class
Quester.Profile Namespace


ProfileEditor Constructor

Initializes a new instance of the ProfileEditor class.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public ProfileEditor()
Public Sub New
public:
ProfileEditor()

See Also

ProfileEditor Class
Quester.Profile Namespace


ProfileEditor Methods

The ProfileEditor type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Public method | Activate | (Inherited from Form.)
Protected method | ActivateMdiChild(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | AddOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from Form.)
Protected method | ApplyAutoScaling | (Inherited from Form.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Protected method | CenterToParent | (Inherited from Form.)
Protected method | CenterToScreen | (Inherited from Form.)
Public method | Close | (Inherited from Form.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Form.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Clean up any resources being used.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Public method | LayoutMdi(System.Windows.Forms.MdiLayout) | (Inherited from Form.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnActivated(System.EventArgs) | (Inherited from Form.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnClosed(System.EventArgs) | (Inherited from Form.)
Protected method | OnClosing(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from Form.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDeactivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Form.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnFormClosed(System.Windows.Forms.FormClosedEventArgs) | (Inherited from Form.)
Protected method | OnFormClosing(System.Windows.Forms.FormClosingEventArgs) | (Inherited from Form.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Form.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Form.)
Protected method | OnHelpButtonClicked(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInputLanguageChanged(System.Windows.Forms.InputLanguageChangedEventArgs) | (Inherited from Form.)
Protected method | OnInputLanguageChanging(System.Windows.Forms.InputLanguageChangingEventArgs) | (Inherited from Form.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from Form.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from Form.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMaximumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMdiChildActivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuComplete(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuStart(System.EventArgs) | (Inherited from Form.)
Protected method | OnMinimumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Form.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeBegin(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeEnd(System.EventArgs) | (Inherited from Form.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnShown(System.EventArgs) | (Inherited from Form.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from Form.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from Form.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from Form.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | RemoveOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from Form.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from Form.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopLocation(System.Int32,System.Int32) | (Inherited from Form.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Form.)
Public method | Show(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Public method | Show | (Inherited from Control.)
Public method | ShowDialog | (Inherited from Form.)
Public method | ShowDialog(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Form.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from Form.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from Form.)

See Also

ProfileEditor Class
Quester.Profile Namespace


Dispose Method

ProfileEditor..::..Dispose Method

Overload List

 | Name | Description
Protected method | Dispose(Boolean) | Clean up any resources being used.
Public method | Dispose | (Inherited from Component.)

See Also

ProfileEditor Class
ProfileEditor Members
Quester.Profile Namespace


Dispose Method

ProfileEditor..::..Dispose Method

Clean up any resources being used.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
protected void Dispose(
    bool disposing
)
Protected Sub Dispose ( _
    disposing As Boolean _
)
protected:
void Dispose(
    bool^ disposing
)

Parameters

disposing
Type: Boolean
true if managed resources should be disposed; otherwise, false.

See Also

ProfileEditor Class
Quester.Profile Namespace


ProfileEditor Properties

The ProfileEditor type exposes the following members.

Properties

 | Name | Description
Public property | AcceptButton | (Inherited from Form.)
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | ActiveMdiChild | (Inherited from Form.)
Public property | AllowDrop | (Inherited from Control.)
Public property | AllowTransparency | (Inherited from Form.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScale | (Inherited from Form.)
Public property | AutoScaleBaseSize | (Inherited from Form.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from Form.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Form.)
Public property | AutoSizeMode | (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Public property | CancelButton | (Inherited from Form.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Form.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | ControlBox | (Inherited from Form.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Form.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DesktopBounds | (Inherited from Form.)
Public property | DesktopLocation | (Inherited from Form.)
Public property | DialogResult | (Inherited from Form.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | FormBorderStyle | (Inherited from Form.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HelpButton | (Inherited from Form.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | Icon | (Inherited from Form.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMdiChild | (Inherited from Form.)
Public property | IsMdiContainer | (Inherited from Form.)
Public property | IsMirrored | (Inherited from Control.)
Public property | IsRestrictedWindow | (Inherited from Form.)
Public property | KeyPreview | (Inherited from Form.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Form.)
Public property | MainMenuStrip | (Inherited from Form.)
Public property | Margin | (Inherited from Form.)
Public property | MaximizeBox | (Inherited from Form.)
Protected property | MaximizedBounds | (Inherited from Form.)
Public property | MaximumSize | (Inherited from Form.)
Public property | MdiChildren | (Inherited from Form.)
Public property | MdiParent | (Inherited from Form.)
Public property | Menu | (Inherited from Form.)
Public property | MergedMenu | (Inherited from Form.)
Public property | MinimizeBox | (Inherited from Form.)
Public property | MinimumSize | (Inherited from Form.)
Public property | Modal | (Inherited from Form.)
Public property | Name | (Inherited from Control.)
Public property | Opacity | (Inherited from Form.)
Public property | OwnedForms | (Inherited from Form.)
Public property | Owner | (Inherited from Form.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | RestoreBounds | (Inherited from Form.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Public property | RightToLeftLayout | (Inherited from Form.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | ShowIcon | (Inherited from Form.)
Public property | ShowInTaskbar | (Inherited from Form.)
Protected property | ShowWithoutActivation | (Inherited from Form.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Form.)
Public property | SizeGripStyle | (Inherited from Form.)
Public property | StartPosition | (Inherited from Form.)
Public property | TabIndex | (Inherited from Form.)
Public property | TabStop | (Inherited from Form.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | (Inherited from Control.)
Public property | TopLevel | (Inherited from Form.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | TopMost | (Inherited from Form.)
Public property | TransparencyKey | (Inherited from Form.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowState | (Inherited from Form.)
Public property | WindowTarget | (Inherited from Control.)

See Also

ProfileEditor Class
Quester.Profile Namespace


ProfileEditor Events

The ProfileEditor type exposes the following members.

Events

 | Name | Description
Public event | Activated | (Inherited from Form.)
Public event | AutoSizeChanged | (Inherited from Form.)
Public event | AutoValidateChanged | (Inherited from Form.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | Closed | (Inherited from Form.)
Public event | Closing | (Inherited from Form.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Deactivate | (Inherited from Form.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | FormClosed | (Inherited from Form.)
Public event | FormClosing | (Inherited from Form.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpButtonClicked | (Inherited from Form.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | InputLanguageChanged | (Inherited from Form.)
Public event | InputLanguageChanging | (Inherited from Form.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from Form.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Form.)
Public event | MaximizedBoundsChanged | (Inherited from Form.)
Public event | MaximumSizeChanged | (Inherited from Form.)
Public event | MdiChildActivate | (Inherited from Form.)
Public event | MenuComplete | (Inherited from Form.)
Public event | MenuStart | (Inherited from Form.)
Public event | MinimumSizeChanged | (Inherited from Form.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | ResizeBegin | (Inherited from Form.)
Public event | ResizeEnd | (Inherited from Form.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | RightToLeftLayoutChanged | (Inherited from Form.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | Shown | (Inherited from Form.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Form.)
Public event | TabStopChanged | (Inherited from Form.)
Public event | TextChanged | (Inherited from Control.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

ProfileEditor Class
Quester.Profile Namespace


QuesterProfile Class

Class QuesterProfile, old profile replaced by EasyQuestProfile (more info here), but this class still used internally by the quester (EasyQuestProfile is converted to this class)

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class QuesterProfile
<SerializableAttribute> _
Public Class QuesterProfile
[SerializableAttribute]
public ref class QuesterProfile

Inheritance Hierarchy

Object
Quester.Profile..::..QuesterProfile

See Also

QuesterProfile Members
Quester.Profile Namespace


QuesterProfile Members

The QuesterProfile type exposes the following members.

Constructors

 | Name | Description
Public method | QuesterProfile | Initializes a new instance of the QuesterProfile class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | BlackGuids | Gets or sets the blacklist NPCs by GUID.
Public property | Blackspots | Gets or sets the blackspots.
Public property | BlackType | Gets or sets the blacklist NPCs by EntryId.
Public property | Npc | Gets or sets the NPC (vendor, repair, ...).
Public property | NpcQuest | Gets or sets the NPC quest giver.
Public property | OffMeshConnections | Gets or sets the offmeshconnections.
Public property | QuestFile | Gets or sets path .cs file that contains the c # code for quests (more info here, relative to "WRobot\Profiles\Quester\").
Public property | QuestsSorted | Gets or sets list of step

See Also

QuesterProfile Class
Quester.Profile Namespace


QuesterProfile Constructor

Initializes a new instance of the QuesterProfile class.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public QuesterProfile()
Public Sub New
public:
QuesterProfile()

See Also

QuesterProfile Class
Quester.Profile Namespace


QuesterProfile Methods

The QuesterProfile type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

QuesterProfile Class
Quester.Profile Namespace


QuesterProfile Properties

The QuesterProfile type exposes the following members.

Properties

 | Name | Description
Public property | BlackGuids | Gets or sets the blacklist NPCs by GUID.
Public property | Blackspots | Gets or sets the blackspots.
Public property | BlackType | Gets or sets the blacklist NPCs by EntryId.
Public property | Npc | Gets or sets the NPC (vendor, repair, ...).
Public property | NpcQuest | Gets or sets the NPC quest giver.
Public property | OffMeshConnections | Gets or sets the offmeshconnections.
Public property | QuestFile | Gets or sets path .cs file that contains the c # code for quests (more info here, relative to "WRobot\Profiles\Quester\").
Public property | QuestsSorted | Gets or sets list of step

See Also

QuesterProfile Class
Quester.Profile Namespace


BlackGuids Property

QuesterProfile..::..BlackGuids Property

Gets or sets the blacklist NPCs by GUID.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public List<string> BlackGuids { get; set; }
Public Property BlackGuids As List(Of String)
    Get
    Set
public:
property List<String^>^ BlackGuids {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

Field Value

The blacklisted NPCs list.

See Also

QuesterProfile Class
Quester.Profile Namespace


Blackspots Property

QuesterProfile..::..Blackspots Property

Gets or sets the blackspots.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public List<Blackspot> Blackspots { get; set; }
Public Property Blackspots As List(Of Blackspot)
    Get
    Set
public:
property List<Blackspot^>^ Blackspots {
    List<Blackspot^>^ get ();
    void set (List<Blackspot^>^ value);
}

Field Value

The blackspots.

See Also

QuesterProfile Class
Quester.Profile Namespace


BlackType Property

QuesterProfile..::..BlackType Property

Gets or sets the blacklist NPCs by EntryId.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public List<int> BlackType { get; set; }
Public Property BlackType As List(Of Integer)
    Get
    Set
public:
property List<int^>^ BlackType {
    List<int^>^ get ();
    void set (List<int^>^ value);
}

Field Value

The type of the blacklist NPC.

See Also

QuesterProfile Class
Quester.Profile Namespace


Npc Property

QuesterProfile..::..Npc Property

Gets or sets the NPC (vendor, repair, ...).

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public List<Npc> Npc { get; set; }
Public Property Npc As List(Of Npc)
    Get
    Set
public:
property List<Npc^>^ Npc {
    List<Npc^>^ get ();
    void set (List<Npc^>^ value);
}

Field Value

The NPCs.

See Also

QuesterProfile Class
Quester.Profile Namespace


NpcQuest Property

QuesterProfile..::..NpcQuest Property

Gets or sets the NPC quest giver.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public List<NPCQuest> NpcQuest { get; set; }
Public Property NpcQuest As List(Of NPCQuest)
    Get
    Set
public:
property List<NPCQuest^>^ NpcQuest {
    List<NPCQuest^>^ get ();
    void set (List<NPCQuest^>^ value);
}

Field Value

The NPCs quest.

See Also

QuesterProfile Class
Quester.Profile Namespace


OffMeshConnections Property

QuesterProfile..::..OffMeshConnections Property

Gets or sets the offmeshconnections.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public List<PathFinder..::..OffMeshConnection> OffMeshConnections { get; set; }
Public Property OffMeshConnections As List(Of PathFinder..::..OffMeshConnection)
    Get
    Set
public:
property List<PathFinder..::..OffMeshConnection^>^ OffMeshConnections {
    List<PathFinder..::..OffMeshConnection^>^ get ();
    void set (List<PathFinder..::..OffMeshConnection^>^ value);
}

Field Value

The offmeshconnections list.

See Also

QuesterProfile Class
Quester.Profile Namespace


QuestFile Property

QuesterProfile..::..QuestFile Property

Gets or sets path .cs file that contains the c # code for quests (more info here, relative to "WRobot\Profiles\Quester\").

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public string QuestFile { get; set; }
Public Property QuestFile As String
    Get
    Set
public:
property String^ QuestFile {
    String^ get ();
    void set (String^ value);
}

Field Value

The quests code file path.

See Also

QuesterProfile Class
Quester.Profile Namespace


QuestsSorted Property

QuesterProfile..::..QuestsSorted Property

Gets or sets list of step

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public List<QuestsSorted> QuestsSorted { get; set; }
Public Property QuestsSorted As List(Of QuestsSorted)
    Get
    Set
public:
property List<QuestsSorted^>^ QuestsSorted {
    List<QuestsSorted^>^ get ();
    void set (List<QuestsSorted^>^ value);
}

Field Value

The quests sorted.

See Also

QuesterProfile Class
Quester.Profile Namespace


UseItemOnEasyQuestClass Class

Class UseItemOnEasyQuestClass. Implements the BaseEasyQuestClass

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class UseItemOnEasyQuestClass : BaseEasyQuestClass
<SerializableAttribute> _
Public Class UseItemOnEasyQuestClass _
    Inherits BaseEasyQuestClass
[SerializableAttribute]
public ref class UseItemOnEasyQuestClass : public BaseEasyQuestClass

Inheritance Hierarchy

Object
Quester.Profile..::..BaseEasyQuestClass
Quester.Profile..::..UseItemOnEasyQuestClass

See Also

UseItemOnEasyQuestClass Members
Quester.Profile Namespace
Quester.Profile..::..BaseEasyQuestClass


UseItemOnEasyQuestClass Members

The UseItemOnEasyQuestClass type exposes the following members.

Constructors

 | Name | Description
Public method | UseItemOnEasyQuestClass | Initializes a new instance of the UseItemOnEasyQuestClass class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | EntryIdTarget | Gets or sets the entry identifier target.
Public property | HotSpots | Gets or sets the hot spots.
Public property | ItemId | Gets or sets the item identifier.
Public property | Range | Gets or sets the range.

See Also

UseItemOnEasyQuestClass Class
Quester.Profile Namespace


UseItemOnEasyQuestClass Constructor

Initializes a new instance of the UseItemOnEasyQuestClass class.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public UseItemOnEasyQuestClass()
Public Sub New
public:
UseItemOnEasyQuestClass()

See Also

UseItemOnEasyQuestClass Class
Quester.Profile Namespace


UseItemOnEasyQuestClass Methods

The UseItemOnEasyQuestClass type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

UseItemOnEasyQuestClass Class
Quester.Profile Namespace


UseItemOnEasyQuestClass Properties

The UseItemOnEasyQuestClass type exposes the following members.

Properties

 | Name | Description
Public property | EntryIdTarget | Gets or sets the entry identifier target.
Public property | HotSpots | Gets or sets the hot spots.
Public property | ItemId | Gets or sets the item identifier.
Public property | Range | Gets or sets the range.

See Also

UseItemOnEasyQuestClass Class
Quester.Profile Namespace


EntryIdTarget Property

UseItemOnEasyQuestClass..::..EntryIdTarget Property

Gets or sets the entry identifier target.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public List<int> EntryIdTarget { get; set; }
Public Property EntryIdTarget As List(Of Integer)
    Get
    Set
public:
property List<int^>^ EntryIdTarget {
    List<int^>^ get ();
    void set (List<int^>^ value);
}

Field Value

The entry identifier target.

See Also

UseItemOnEasyQuestClass Class
Quester.Profile Namespace


HotSpots Property

UseItemOnEasyQuestClass..::..HotSpots Property

Gets or sets the hot spots.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public List<Vector3> HotSpots { get; set; }
Public Property HotSpots As List(Of Vector3)
    Get
    Set
public:
property List<Vector3^>^ HotSpots {
    List<Vector3^>^ get ();
    void set (List<Vector3^>^ value);
}

Field Value

The hot spots.

See Also

UseItemOnEasyQuestClass Class
Quester.Profile Namespace


ItemId Property

UseItemOnEasyQuestClass..::..ItemId Property

Gets or sets the item identifier.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public int ItemId { get; set; }
Public Property ItemId As Integer
    Get
    Set
public:
property int^ ItemId {
    int^ get ();
    void set (int^ value);
}

Field Value

The item identifier.

See Also

UseItemOnEasyQuestClass Class
Quester.Profile Namespace


Range Property

UseItemOnEasyQuestClass..::..Range Property

Gets or sets the range.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public float Range { get; set; }
Public Property Range As Single
    Get
    Set
public:
property float^ Range {
    float^ get ();
    void set (float^ value);
}

Field Value

The range.

See Also

UseItemOnEasyQuestClass Class
Quester.Profile Namespace


UseScriptOnEasyQuestClass Class

Class UseScriptOnEasyQuestClass. Implements the BaseEasyQuestClass

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class UseScriptOnEasyQuestClass : BaseEasyQuestClass
<SerializableAttribute> _
Public Class UseScriptOnEasyQuestClass _
    Inherits BaseEasyQuestClass
[SerializableAttribute]
public ref class UseScriptOnEasyQuestClass : public BaseEasyQuestClass

Inheritance Hierarchy

Object
Quester.Profile..::..BaseEasyQuestClass
Quester.Profile..::..UseScriptOnEasyQuestClass

See Also

UseScriptOnEasyQuestClass Members
Quester.Profile Namespace
Quester.Profile..::..BaseEasyQuestClass


UseScriptOnEasyQuestClass Members

The UseScriptOnEasyQuestClass type exposes the following members.

Constructors

 | Name | Description
Public method | UseScriptOnEasyQuestClass | Initializes a new instance of the UseScriptOnEasyQuestClass class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | IsCSharpCode | The is c sharp code

Properties

 | Name | Description
Public property | EntryIdTarget | Gets or sets the entry identifier target.
Public property | HotSpots | Gets or sets the hot spots.
Public property | Range | Gets or sets the range.
Public property | Script | Gets or sets the script.

See Also

UseScriptOnEasyQuestClass Class
Quester.Profile Namespace


UseScriptOnEasyQuestClass Constructor

Initializes a new instance of the UseScriptOnEasyQuestClass class.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public UseScriptOnEasyQuestClass()
Public Sub New
public:
UseScriptOnEasyQuestClass()

See Also

UseScriptOnEasyQuestClass Class
Quester.Profile Namespace


UseScriptOnEasyQuestClass Fields

The UseScriptOnEasyQuestClass type exposes the following members.

Fields

 | Name | Description
Public field | IsCSharpCode | The is c sharp code

See Also

UseScriptOnEasyQuestClass Class
Quester.Profile Namespace


IsCSharpCode Field

UseScriptOnEasyQuestClass..::..IsCSharpCode Field

The is c sharp code

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public bool IsCSharpCode
Public IsCSharpCode As Boolean
public:
bool^ IsCSharpCode

See Also

UseScriptOnEasyQuestClass Class
Quester.Profile Namespace


UseScriptOnEasyQuestClass Methods

The UseScriptOnEasyQuestClass type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

UseScriptOnEasyQuestClass Class
Quester.Profile Namespace


UseScriptOnEasyQuestClass Properties

The UseScriptOnEasyQuestClass type exposes the following members.

Properties

 | Name | Description
Public property | EntryIdTarget | Gets or sets the entry identifier target.
Public property | HotSpots | Gets or sets the hot spots.
Public property | Range | Gets or sets the range.
Public property | Script | Gets or sets the script.

See Also

UseScriptOnEasyQuestClass Class
Quester.Profile Namespace


EntryIdTarget Property

UseScriptOnEasyQuestClass..::..EntryIdTarget Property

Gets or sets the entry identifier target.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public List<int> EntryIdTarget { get; set; }
Public Property EntryIdTarget As List(Of Integer)
    Get
    Set
public:
property List<int^>^ EntryIdTarget {
    List<int^>^ get ();
    void set (List<int^>^ value);
}

Field Value

The entry identifier target.

See Also

UseScriptOnEasyQuestClass Class
Quester.Profile Namespace


HotSpots Property

UseScriptOnEasyQuestClass..::..HotSpots Property

Gets or sets the hot spots.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public List<Vector3> HotSpots { get; set; }
Public Property HotSpots As List(Of Vector3)
    Get
    Set
public:
property List<Vector3^>^ HotSpots {
    List<Vector3^>^ get ();
    void set (List<Vector3^>^ value);
}

Field Value

The hot spots.

See Also

UseScriptOnEasyQuestClass Class
Quester.Profile Namespace


Range Property

UseScriptOnEasyQuestClass..::..Range Property

Gets or sets the range.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public float Range { get; set; }
Public Property Range As Single
    Get
    Set
public:
property float^ Range {
    float^ get ();
    void set (float^ value);
}

Field Value

The range.

See Also

UseScriptOnEasyQuestClass Class
Quester.Profile Namespace


Script Property

UseScriptOnEasyQuestClass..::..Script Property

Gets or sets the script.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public string Script { get; set; }
Public Property Script As String
    Get
    Set
public:
property String^ Script {
    String^ get ();
    void set (String^ value);
}

Field Value

The script.

See Also

UseScriptOnEasyQuestClass Class
Quester.Profile Namespace


UseSpellOnEasyQuestClass Class

Class UseSpellOnEasyQuestClass. Implements the BaseEasyQuestClass

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class UseSpellOnEasyQuestClass : BaseEasyQuestClass
<SerializableAttribute> _
Public Class UseSpellOnEasyQuestClass _
    Inherits BaseEasyQuestClass
[SerializableAttribute]
public ref class UseSpellOnEasyQuestClass : public BaseEasyQuestClass

Inheritance Hierarchy

Object
Quester.Profile..::..BaseEasyQuestClass
Quester.Profile..::..UseSpellOnEasyQuestClass

See Also

UseSpellOnEasyQuestClass Members
Quester.Profile Namespace
Quester.Profile..::..BaseEasyQuestClass


UseSpellOnEasyQuestClass Members

The UseSpellOnEasyQuestClass type exposes the following members.

Constructors

 | Name | Description
Public method | UseSpellOnEasyQuestClass | Initializes a new instance of the UseSpellOnEasyQuestClass class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | EntryIdTarget | Gets or sets the entry identifier target.
Public property | HotSpots | Gets or sets the hot spots.
Public property | Range | Gets or sets the range.
Public property | SpellId | Gets or sets the spell identifier.

See Also

UseSpellOnEasyQuestClass Class
Quester.Profile Namespace


UseSpellOnEasyQuestClass Constructor

Initializes a new instance of the UseSpellOnEasyQuestClass class.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public UseSpellOnEasyQuestClass()
Public Sub New
public:
UseSpellOnEasyQuestClass()

See Also

UseSpellOnEasyQuestClass Class
Quester.Profile Namespace


UseSpellOnEasyQuestClass Methods

The UseSpellOnEasyQuestClass type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

UseSpellOnEasyQuestClass Class
Quester.Profile Namespace


UseSpellOnEasyQuestClass Properties

The UseSpellOnEasyQuestClass type exposes the following members.

Properties

 | Name | Description
Public property | EntryIdTarget | Gets or sets the entry identifier target.
Public property | HotSpots | Gets or sets the hot spots.
Public property | Range | Gets or sets the range.
Public property | SpellId | Gets or sets the spell identifier.

See Also

UseSpellOnEasyQuestClass Class
Quester.Profile Namespace


EntryIdTarget Property

UseSpellOnEasyQuestClass..::..EntryIdTarget Property

Gets or sets the entry identifier target.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public List<int> EntryIdTarget { get; set; }
Public Property EntryIdTarget As List(Of Integer)
    Get
    Set
public:
property List<int^>^ EntryIdTarget {
    List<int^>^ get ();
    void set (List<int^>^ value);
}

Field Value

The entry identifier target.

See Also

UseSpellOnEasyQuestClass Class
Quester.Profile Namespace


HotSpots Property

UseSpellOnEasyQuestClass..::..HotSpots Property

Gets or sets the hot spots.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public List<Vector3> HotSpots { get; set; }
Public Property HotSpots As List(Of Vector3)
    Get
    Set
public:
property List<Vector3^>^ HotSpots {
    List<Vector3^>^ get ();
    void set (List<Vector3^>^ value);
}

Field Value

The hot spots.

See Also

UseSpellOnEasyQuestClass Class
Quester.Profile Namespace


Range Property

UseSpellOnEasyQuestClass..::..Range Property

Gets or sets the range.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public float Range { get; set; }
Public Property Range As Single
    Get
    Set
public:
property float^ Range {
    float^ get ();
    void set (float^ value);
}

Field Value

The range.

See Also

UseSpellOnEasyQuestClass Class
Quester.Profile Namespace


SpellId Property

UseSpellOnEasyQuestClass..::..SpellId Property

Gets or sets the spell identifier.

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public int SpellId { get; set; }
Public Property SpellId As Integer
    Get
    Set
public:
property int^ SpellId {
    int^ get ();
    void set (int^ value);
}

Field Value

The spell identifier.

See Also

UseSpellOnEasyQuestClass Class
Quester.Profile Namespace


Quester.Profile.HB Namespace

Classes

 | Class | Description
Public class | Blackspot |
Public class | CollectFrom |
Public class | CustomBehavior |
Public class | Else |
Public class | ElseIf |
Public class | EndIf |
Public class | EndWhile |
Public class | GrindArea |
Public class | GrindTo |
Public class | HBProfile |
Public class | Hotspot |
Public class | If |
Public class | Mailbox |
Public class | Mob |
Public class | Objective |
Public class | ObjectiveQuestOrder |
Public class | PickUp |
Public class | Position |
Public class | Quest |
Public class | QuestOrder |
Public class | TurnIn |
Public class | Vendor |
Public class | While |


Blackspot Class

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class Blackspot : Position
<SerializableAttribute> _
Public Class Blackspot _
    Inherits Position
[SerializableAttribute]
public ref class Blackspot : public Position

Inheritance Hierarchy

Object
Quester.Profile.HB..::..Position
Quester.Profile.HB..::..Blackspot

See Also

Blackspot Members
Quester.Profile.HB Namespace


Blackspot Members

The Blackspot type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | Radius |

See Also

Blackspot Class
Quester.Profile.HB Namespace


Blackspot Fields

The Blackspot type exposes the following members.

Fields

 | Name | Description
Public field | Radius |

See Also

Blackspot Class
Quester.Profile.HB Namespace


Radius Field

Blackspot..::..Radius Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public float Radius
Public Radius As Single
public:
float^ Radius

See Also

Blackspot Class
Quester.Profile.HB Namespace


Blackspot Methods

The Blackspot type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Blackspot Class
Quester.Profile.HB Namespace


CollectFrom Class

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class CollectFrom
<SerializableAttribute> _
Public Class CollectFrom
[SerializableAttribute]
public ref class CollectFrom

Inheritance Hierarchy

Object
Quester.Profile.HB..::..CollectFrom

See Also

CollectFrom Members
Quester.Profile.HB Namespace


CollectFrom Members

The CollectFrom type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | GameObjects |
Public field | Mobs |

See Also

CollectFrom Class
Quester.Profile.HB Namespace


CollectFrom Fields

The CollectFrom type exposes the following members.

Fields

 | Name | Description
Public field | GameObjects |
Public field | Mobs |

See Also

CollectFrom Class
Quester.Profile.HB Namespace


GameObjects Field

CollectFrom..::..GameObjects Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[XmlElementAttribute]
public List<Mob> GameObjects
<XmlElementAttribute> _
Public GameObjects As List(Of Mob)
[XmlElementAttribute]
public:
List<Mob^>^ GameObjects

See Also

CollectFrom Class
Quester.Profile.HB Namespace


Mobs Field

CollectFrom..::..Mobs Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[XmlElementAttribute]
public List<Mob> Mobs
<XmlElementAttribute> _
Public Mobs As List(Of Mob)
[XmlElementAttribute]
public:
List<Mob^>^ Mobs

See Also

CollectFrom Class
Quester.Profile.HB Namespace


CollectFrom Methods

The CollectFrom type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

CollectFrom Class
Quester.Profile.HB Namespace


CustomBehavior Class

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class CustomBehavior
<SerializableAttribute> _
Public Class CustomBehavior
[SerializableAttribute]
public ref class CustomBehavior

Inheritance Hierarchy

Object
Quester.Profile.HB..::..CustomBehavior

See Also

CustomBehavior Members
Quester.Profile.HB Namespace


CustomBehavior Members

The CustomBehavior type exposes the following members.

Constructors

 | Name | Description
Protected method | CustomBehavior |

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | DoSell |
Public field | File |
Public field | GossipOptions |
Public field | ItemId |
Public field | Lua |
Public field | Macro |
Public field | MobId |
Public field | ProfileName |
Public field | QuestId |
Public field | Text |
Public field | VehicleMountId |
Public field | WaitTime |
Public field | X |
Public field | Y |
Public field | Z |

See Also

CustomBehavior Class
Quester.Profile.HB Namespace


CustomBehavior Constructor

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
protected CustomBehavior()
Protected Sub New
protected:
CustomBehavior()

See Also

CustomBehavior Class
Quester.Profile.HB Namespace


CustomBehavior Fields

The CustomBehavior type exposes the following members.

Fields

 | Name | Description
Public field | DoSell |
Public field | File |
Public field | GossipOptions |
Public field | ItemId |
Public field | Lua |
Public field | Macro |
Public field | MobId |
Public field | ProfileName |
Public field | QuestId |
Public field | Text |
Public field | VehicleMountId |
Public field | WaitTime |
Public field | X |
Public field | Y |
Public field | Z |

See Also

CustomBehavior Class
Quester.Profile.HB Namespace


DoSell Field

CustomBehavior..::..DoSell Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public string DoSell
Public DoSell As String
public:
String^ DoSell

See Also

CustomBehavior Class
Quester.Profile.HB Namespace


File Field

CustomBehavior..::..File Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public string File
Public File As String
public:
String^ File

See Also

CustomBehavior Class
Quester.Profile.HB Namespace


GossipOptions Field

CustomBehavior..::..GossipOptions Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public string GossipOptions
Public GossipOptions As String
public:
String^ GossipOptions

See Also

CustomBehavior Class
Quester.Profile.HB Namespace


ItemId Field

CustomBehavior..::..ItemId Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public int ItemId
Public ItemId As Integer
public:
int^ ItemId

See Also

CustomBehavior Class
Quester.Profile.HB Namespace


Lua Field

CustomBehavior..::..Lua Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public string Lua
Public Lua As String
public:
String^ Lua

See Also

CustomBehavior Class
Quester.Profile.HB Namespace


Macro Field

CustomBehavior..::..Macro Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public string Macro
Public Macro As String
public:
String^ Macro

See Also

CustomBehavior Class
Quester.Profile.HB Namespace


MobId Field

CustomBehavior..::..MobId Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public int MobId
Public MobId As Integer
public:
int^ MobId

See Also

CustomBehavior Class
Quester.Profile.HB Namespace


ProfileName Field

CustomBehavior..::..ProfileName Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public string ProfileName
Public ProfileName As String
public:
String^ ProfileName

See Also

CustomBehavior Class
Quester.Profile.HB Namespace


QuestId Field

CustomBehavior..::..QuestId Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public int QuestId
Public QuestId As Integer
public:
int^ QuestId

See Also

CustomBehavior Class
Quester.Profile.HB Namespace


Text Field

CustomBehavior..::..Text Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public string Text
Public Text As String
public:
String^ Text

See Also

CustomBehavior Class
Quester.Profile.HB Namespace


VehicleMountId Field

CustomBehavior..::..VehicleMountId Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public int VehicleMountId
Public VehicleMountId As Integer
public:
int^ VehicleMountId

See Also

CustomBehavior Class
Quester.Profile.HB Namespace


WaitTime Field

CustomBehavior..::..WaitTime Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public int WaitTime
Public WaitTime As Integer
public:
int^ WaitTime

See Also

CustomBehavior Class
Quester.Profile.HB Namespace


X Field

CustomBehavior..::..X Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public float X
Public X As Single
public:
float^ X

See Also

CustomBehavior Class
Quester.Profile.HB Namespace


Y Field

CustomBehavior..::..Y Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public float Y
Public Y As Single
public:
float^ Y

See Also

CustomBehavior Class
Quester.Profile.HB Namespace


Z Field

CustomBehavior..::..Z Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public float Z
Public Z As Single
public:
float^ Z

See Also

CustomBehavior Class
Quester.Profile.HB Namespace


CustomBehavior Methods

The CustomBehavior type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

CustomBehavior Class
Quester.Profile.HB Namespace


Else Class

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class Else : If
<SerializableAttribute> _
Public Class Else _
    Inherits If
[SerializableAttribute]
public ref class Else : public If

Inheritance Hierarchy

Object
Quester.Profile.HB..::..QuestOrder
Quester.Profile.HB..::..If
Quester.Profile.HB..::..Else

See Also

Quester.Profile.HB Namespace


Else Methods

The Else type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Else Class
Quester.Profile.HB Namespace


ElseIf Class

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class ElseIf : If
<SerializableAttribute> _
Public Class ElseIf _
    Inherits If
[SerializableAttribute]
public ref class ElseIf : public If

Inheritance Hierarchy

Object
Quester.Profile.HB..::..QuestOrder
Quester.Profile.HB..::..If
Quester.Profile.HB..::..ElseIf

See Also

Quester.Profile.HB Namespace


ElseIf Methods

The ElseIf type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

ElseIf Class
Quester.Profile.HB Namespace


EndIf Class

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class EndIf
<SerializableAttribute> _
Public Class EndIf
[SerializableAttribute]
public ref class EndIf

Inheritance Hierarchy

Object
Quester.Profile.HB..::..EndIf

See Also

EndIf Members
Quester.Profile.HB Namespace


EndIf Members

The EndIf type exposes the following members.

Constructors

 | Name | Description
Protected method | EndIf |

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

EndIf Class
Quester.Profile.HB Namespace


EndIf Constructor

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
protected EndIf()
Protected Sub New
protected:
EndIf()

See Also

EndIf Class
Quester.Profile.HB Namespace


EndIf Methods

The EndIf type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

EndIf Class
Quester.Profile.HB Namespace


EndWhile Class

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class EndWhile : EndIf
<SerializableAttribute> _
Public Class EndWhile _
    Inherits EndIf
[SerializableAttribute]
public ref class EndWhile : public EndIf

Inheritance Hierarchy

Object
Quester.Profile.HB..::..EndIf
Quester.Profile.HB..::..EndWhile

See Also

Quester.Profile.HB Namespace


EndWhile Methods

The EndWhile type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

EndWhile Class
Quester.Profile.HB Namespace


GrindArea Class

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class GrindArea
<SerializableAttribute> _
Public Class GrindArea
[SerializableAttribute]
public ref class GrindArea

Inheritance Hierarchy

Object
Quester.Profile.HB..::..GrindArea

See Also

GrindArea Members
Quester.Profile.HB Namespace


GrindArea Members

The GrindArea type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | Factions |
Public field | Hotspots |

See Also

GrindArea Class
Quester.Profile.HB Namespace


GrindArea Fields

The GrindArea type exposes the following members.

Fields

 | Name | Description
Public field | Factions |
Public field | Hotspots |

See Also

GrindArea Class
Quester.Profile.HB Namespace


Factions Field

GrindArea..::..Factions Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public string Factions
Public Factions As String
public:
String^ Factions

See Also

GrindArea Class
Quester.Profile.HB Namespace


Hotspots Field

GrindArea..::..Hotspots Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public List<Hotspot> Hotspots
Public Hotspots As List(Of Hotspot)
public:
List<Hotspot^>^ Hotspots

See Also

GrindArea Class
Quester.Profile.HB Namespace


GrindArea Methods

The GrindArea type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

GrindArea Class
Quester.Profile.HB Namespace


GrindTo Class

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class GrindTo : If
<SerializableAttribute> _
Public Class GrindTo _
    Inherits If
[SerializableAttribute]
public ref class GrindTo : public If

Inheritance Hierarchy

Object
Quester.Profile.HB..::..QuestOrder
Quester.Profile.HB..::..If
Quester.Profile.HB..::..GrindTo

See Also

Quester.Profile.HB Namespace


GrindTo Methods

The GrindTo type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

GrindTo Class
Quester.Profile.HB Namespace


HBProfile Class

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class HBProfile
<SerializableAttribute> _
Public Class HBProfile
[SerializableAttribute]
public ref class HBProfile

Inheritance Hierarchy

Object
Quester.Profile.HB..::..HBProfile

See Also

HBProfile Members
Quester.Profile.HB Namespace


HBProfile Members

The HBProfile type exposes the following members.

Constructors

 | Name | Description
Public method | HBProfile |

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | AvoidMobs |
Public field | Blackspots |
Public field | Creator |
Public field | Mailboxes |
Public field | MaxLevel |
Public field | MinLevel |
Public field | Name |
Public field | QuestOrder |
Public field | Quests |
Public field | Vendors |
Public field | Version |

See Also

HBProfile Class
Quester.Profile.HB Namespace


HBProfile Constructor

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public HBProfile()
Public Sub New
public:
HBProfile()

See Also

HBProfile Class
Quester.Profile.HB Namespace


HBProfile Fields

The HBProfile type exposes the following members.

Fields

 | Name | Description
Public field | AvoidMobs |
Public field | Blackspots |
Public field | Creator |
Public field | Mailboxes |
Public field | MaxLevel |
Public field | MinLevel |
Public field | Name |
Public field | QuestOrder |
Public field | Quests |
Public field | Vendors |
Public field | Version |

See Also

HBProfile Class
Quester.Profile.HB Namespace


AvoidMobs Field

HBProfile..::..AvoidMobs Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public List<Mob> AvoidMobs
Public AvoidMobs As List(Of Mob)
public:
List<Mob^>^ AvoidMobs

See Also

HBProfile Class
Quester.Profile.HB Namespace


Blackspots Field

HBProfile..::..Blackspots Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public List<Blackspot> Blackspots
Public Blackspots As List(Of Blackspot)
public:
List<Blackspot^>^ Blackspots

See Also

HBProfile Class
Quester.Profile.HB Namespace


Creator Field

HBProfile..::..Creator Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public string Creator
Public Creator As String
public:
String^ Creator

See Also

HBProfile Class
Quester.Profile.HB Namespace


Mailboxes Field

HBProfile..::..Mailboxes Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public List<Mailbox> Mailboxes
Public Mailboxes As List(Of Mailbox)
public:
List<Mailbox^>^ Mailboxes

See Also

HBProfile Class
Quester.Profile.HB Namespace


MaxLevel Field

HBProfile..::..MaxLevel Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public int MaxLevel
Public MaxLevel As Integer
public:
int^ MaxLevel

See Also

HBProfile Class
Quester.Profile.HB Namespace


MinLevel Field

HBProfile..::..MinLevel Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public int MinLevel
Public MinLevel As Integer
public:
int^ MinLevel

See Also

HBProfile Class
Quester.Profile.HB Namespace


Name Field

HBProfile..::..Name Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public string Name
Public Name As String
public:
String^ Name

See Also

HBProfile Class
Quester.Profile.HB Namespace


QuestOrder Field

HBProfile..::..QuestOrder Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public QuestOrder QuestOrder
Public QuestOrder As QuestOrder
public:
QuestOrder^ QuestOrder

See Also

HBProfile Class
Quester.Profile.HB Namespace


Quests Field

HBProfile..::..Quests Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[XmlElementAttribute]
public List<Quest> Quests
<XmlElementAttribute> _
Public Quests As List(Of Quest)
[XmlElementAttribute]
public:
List<Quest^>^ Quests

See Also

HBProfile Class
Quester.Profile.HB Namespace


Vendors Field

HBProfile..::..Vendors Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public List<Vendor> Vendors
Public Vendors As List(Of Vendor)
public:
List<Vendor^>^ Vendors

See Also

HBProfile Class
Quester.Profile.HB Namespace


Version Field

HBProfile..::..Version Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public string Version
Public Version As String
public:
String^ Version

See Also

HBProfile Class
Quester.Profile.HB Namespace


HBProfile Methods

The HBProfile type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

HBProfile Class
Quester.Profile.HB Namespace


Hotspot Class

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class Hotspot : Position
<SerializableAttribute> _
Public Class Hotspot _
    Inherits Position
[SerializableAttribute]
public ref class Hotspot : public Position

Inheritance Hierarchy

Object
Quester.Profile.HB..::..Position
Quester.Profile.HB..::..Hotspot

See Also

Quester.Profile.HB Namespace


Hotspot Methods

The Hotspot type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Hotspot Class
Quester.Profile.HB Namespace


If Class

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class If : QuestOrder
<SerializableAttribute> _
Public Class If _
    Inherits QuestOrder
[SerializableAttribute]
public ref class If : public QuestOrder

Inheritance Hierarchy

Object
Quester.Profile.HB..::..QuestOrder
Quester.Profile.HB..::..If

See Also

If Members
Quester.Profile.HB Namespace


If Members

The If type exposes the following members.

Constructors

 | Name | Description
Protected method | If |

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | Condition |

See Also

If Class
Quester.Profile.HB Namespace


If Constructor

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
protected If()
Protected Sub New
protected:
If()

See Also

If Class
Quester.Profile.HB Namespace


If Fields

The If type exposes the following members.

Fields

 | Name | Description
Public field | Condition |

See Also

If Class
Quester.Profile.HB Namespace


Condition Field

If..::..Condition Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public string Condition
Public Condition As String
public:
String^ Condition

See Also

If Class
Quester.Profile.HB Namespace


If Methods

The If type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

If Class
Quester.Profile.HB Namespace


Mailbox Class

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class Mailbox : Position
<SerializableAttribute> _
Public Class Mailbox _
    Inherits Position
[SerializableAttribute]
public ref class Mailbox : public Position

Inheritance Hierarchy

Object
Quester.Profile.HB..::..Position
Quester.Profile.HB..::..Mailbox

See Also

Quester.Profile.HB Namespace


Mailbox Methods

The Mailbox type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Mailbox Class
Quester.Profile.HB Namespace


Mob Class

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class Mob
<SerializableAttribute> _
Public Class Mob
[SerializableAttribute]
public ref class Mob

Inheritance Hierarchy

Object
Quester.Profile.HB..::..Mob

See Also

Mob Members
Quester.Profile.HB Namespace


Mob Members

The Mob type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | Entry |
Public field | Name |

Properties

 | Name | Description
Public property | Id |

See Also

Mob Class
Quester.Profile.HB Namespace


Mob Fields

The Mob type exposes the following members.

Fields

 | Name | Description
Public field | Entry |
Public field | Name |

See Also

Mob Class
Quester.Profile.HB Namespace


Entry Field

Mob..::..Entry Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public int Entry
Public Entry As Integer
public:
int^ Entry

See Also

Mob Class
Quester.Profile.HB Namespace


Name Field

Mob..::..Name Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public string Name
Public Name As String
public:
String^ Name

See Also

Mob Class
Quester.Profile.HB Namespace


Mob Methods

The Mob type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Mob Class
Quester.Profile.HB Namespace


Mob Properties

The Mob type exposes the following members.

Properties

 | Name | Description
Public property | Id |

See Also

Mob Class
Quester.Profile.HB Namespace


Id Property

Mob..::..Id Property

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public int Id { get; set; }
Public Property Id As Integer
    Get
    Set
public:
property int^ Id {
    int^ get ();
    void set (int^ value);
}

See Also

Mob Class
Quester.Profile.HB Namespace


Objective Class

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class Objective
<SerializableAttribute> _
Public Class Objective
[SerializableAttribute]
public ref class Objective

Inheritance Hierarchy

Object
Quester.Profile.HB..::..Objective

See Also

Objective Members
Quester.Profile.HB Namespace


Objective Members

The Objective type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | CollectCount |
Public field | CollectFrom |
Public field | Hotspots |
Public field | ItemId |
Public field | KillCount |
Public field | MobId |
Public field | ObjectId |
Public field | QuestId |
Public field | Type |
Public field | UseCount |

See Also

Objective Class
Quester.Profile.HB Namespace


Objective Fields

The Objective type exposes the following members.

Fields

 | Name | Description
Public field | CollectCount |
Public field | CollectFrom |
Public field | Hotspots |
Public field | ItemId |
Public field | KillCount |
Public field | MobId |
Public field | ObjectId |
Public field | QuestId |
Public field | Type |
Public field | UseCount |

See Also

Objective Class
Quester.Profile.HB Namespace


CollectCount Field

Objective..::..CollectCount Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public int CollectCount
Public CollectCount As Integer
public:
int^ CollectCount

See Also

Objective Class
Quester.Profile.HB Namespace


CollectFrom Field

Objective..::..CollectFrom Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public CollectFrom CollectFrom
Public CollectFrom As CollectFrom
public:
CollectFrom^ CollectFrom

See Also

Objective Class
Quester.Profile.HB Namespace


Hotspots Field

Objective..::..Hotspots Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public List<Hotspot> Hotspots
Public Hotspots As List(Of Hotspot)
public:
List<Hotspot^>^ Hotspots

See Also

Objective Class
Quester.Profile.HB Namespace


ItemId Field

Objective..::..ItemId Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public int ItemId
Public ItemId As Integer
public:
int^ ItemId

See Also

Objective Class
Quester.Profile.HB Namespace


KillCount Field

Objective..::..KillCount Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public int KillCount
Public KillCount As Integer
public:
int^ KillCount

See Also

Objective Class
Quester.Profile.HB Namespace


MobId Field

Objective..::..MobId Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public int MobId
Public MobId As Integer
public:
int^ MobId

See Also

Objective Class
Quester.Profile.HB Namespace


ObjectId Field

Objective..::..ObjectId Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public int ObjectId
Public ObjectId As Integer
public:
int^ ObjectId

See Also

Objective Class
Quester.Profile.HB Namespace


QuestId Field

Objective..::..QuestId Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public int QuestId
Public QuestId As Integer
public:
int^ QuestId

See Also

Objective Class
Quester.Profile.HB Namespace


Type Field

Objective..::..Type Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public string Type
Public Type As String
public:
String^ Type

See Also

Objective Class
Quester.Profile.HB Namespace


UseCount Field

Objective..::..UseCount Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public int UseCount
Public UseCount As Integer
public:
int^ UseCount

See Also

Objective Class
Quester.Profile.HB Namespace


Objective Methods

The Objective type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Objective Class
Quester.Profile.HB Namespace


ObjectiveQuestOrder Class

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class ObjectiveQuestOrder : Objective
<SerializableAttribute> _
Public Class ObjectiveQuestOrder _
    Inherits Objective
[SerializableAttribute]
public ref class ObjectiveQuestOrder : public Objective

Inheritance Hierarchy

Object
Quester.Profile.HB..::..Objective
Quester.Profile.HB..::..ObjectiveQuestOrder

See Also

ObjectiveQuestOrder Members
Quester.Profile.HB Namespace


ObjectiveQuestOrder Members

The ObjectiveQuestOrder type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | QuestName |

See Also

ObjectiveQuestOrder Class
Quester.Profile.HB Namespace


ObjectiveQuestOrder Fields

The ObjectiveQuestOrder type exposes the following members.

Fields

 | Name | Description
Public field | QuestName |

See Also

ObjectiveQuestOrder Class
Quester.Profile.HB Namespace


QuestName Field

ObjectiveQuestOrder..::..QuestName Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public string QuestName
Public QuestName As String
public:
String^ QuestName

See Also

ObjectiveQuestOrder Class
Quester.Profile.HB Namespace


ObjectiveQuestOrder Methods

The ObjectiveQuestOrder type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

ObjectiveQuestOrder Class
Quester.Profile.HB Namespace


PickUp Class

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class PickUp : TurnIn
<SerializableAttribute> _
Public Class PickUp _
    Inherits TurnIn
[SerializableAttribute]
public ref class PickUp : public TurnIn

Inheritance Hierarchy

Object
Quester.Profile.HB..::..Position
Quester.Profile.HB..::..TurnIn
Quester.Profile.HB..::..PickUp

See Also

PickUp Members
Quester.Profile.HB Namespace


PickUp Members

The PickUp type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | GiverId |
Public field | GiverName |

See Also

PickUp Class
Quester.Profile.HB Namespace


PickUp Fields

The PickUp type exposes the following members.

Fields

 | Name | Description
Public field | GiverId |
Public field | GiverName |

See Also

PickUp Class
Quester.Profile.HB Namespace


GiverId Field

PickUp..::..GiverId Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public int GiverId
Public GiverId As Integer
public:
int^ GiverId

See Also

PickUp Class
Quester.Profile.HB Namespace


GiverName Field

PickUp..::..GiverName Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public string GiverName
Public GiverName As String
public:
String^ GiverName

See Also

PickUp Class
Quester.Profile.HB Namespace


PickUp Methods

The PickUp type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

PickUp Class
Quester.Profile.HB Namespace


Position Class

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class Position
<SerializableAttribute> _
Public Class Position
[SerializableAttribute]
public ref class Position

Inheritance Hierarchy

Object
Quester.Profile.HB..::..Position

See Also

Position Members
Quester.Profile.HB Namespace


Position Members

The Position type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | X |
Public field | Y |
Public field | Z |

See Also

Position Class
Quester.Profile.HB Namespace


Position Fields

The Position type exposes the following members.

Fields

 | Name | Description
Public field | X |
Public field | Y |
Public field | Z |

See Also

Position Class
Quester.Profile.HB Namespace


X Field

Position..::..X Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public float X
Public X As Single
public:
float^ X

See Also

Position Class
Quester.Profile.HB Namespace


Y Field

Position..::..Y Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public float Y
Public Y As Single
public:
float^ Y

See Also

Position Class
Quester.Profile.HB Namespace


Z Field

Position..::..Z Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public float Z
Public Z As Single
public:
float^ Z

See Also

Position Class
Quester.Profile.HB Namespace


Position Methods

The Position type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Position Class
Quester.Profile.HB Namespace


Quest Class

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class Quest
<SerializableAttribute> _
Public Class Quest
[SerializableAttribute]
public ref class Quest

Inheritance Hierarchy

Object
Quester.Profile.HB..::..Quest

See Also

Quest Members
Quester.Profile.HB Namespace


Quest Members

The Quest type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | Id |
Public field | Name |
Public field | Objectives |

See Also

Quest Class
Quester.Profile.HB Namespace


Quest Fields

The Quest type exposes the following members.

Fields

 | Name | Description
Public field | Id |
Public field | Name |
Public field | Objectives |

See Also

Quest Class
Quester.Profile.HB Namespace


Id Field

Quest..::..Id Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public int Id
Public Id As Integer
public:
int^ Id

See Also

Quest Class
Quester.Profile.HB Namespace


Name Field

Quest..::..Name Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public string Name
Public Name As String
public:
String^ Name

See Also

Quest Class
Quester.Profile.HB Namespace


Objectives Field

Quest..::..Objectives Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[XmlElementAttribute]
public List<Objective> Objectives
<XmlElementAttribute> _
Public Objectives As List(Of Objective)
[XmlElementAttribute]
public:
List<Objective^>^ Objectives

See Also

Quest Class
Quester.Profile.HB Namespace


Quest Methods

The Quest type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Quest Class
Quester.Profile.HB Namespace


QuestOrder Class

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class QuestOrder
<SerializableAttribute> _
Public Class QuestOrder
[SerializableAttribute]
public ref class QuestOrder

Inheritance Hierarchy

Object
Quester.Profile.HB..::..QuestOrder

See Also

QuestOrder Members
Quester.Profile.HB Namespace


QuestOrder Members

The QuestOrder type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | CustomBehavior |
Public field | Else |
Public field | ElseIf |
Public field | EndIfs |
Public field | EndWhiles |
Public field | If |
Public field | IgnoreCheckPoints |
Public field | Objectives |
Public field | PickUp |
Public field | SetGrindArea |
Public field | TurnIn |
Public field | While |

See Also

QuestOrder Class
Quester.Profile.HB Namespace


QuestOrder Fields

The QuestOrder type exposes the following members.

Fields

 | Name | Description
Public field | CustomBehavior |
Public field | Else |
Public field | ElseIf |
Public field | EndIfs |
Public field | EndWhiles |
Public field | If |
Public field | IgnoreCheckPoints |
Public field | Objectives |
Public field | PickUp |
Public field | SetGrindArea |
Public field | TurnIn |
Public field | While |

See Also

QuestOrder Class
Quester.Profile.HB Namespace


CustomBehavior Field

QuestOrder..::..CustomBehavior Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[XmlElementAttribute]
public List<CustomBehavior> CustomBehavior
<XmlElementAttribute> _
Public CustomBehavior As List(Of CustomBehavior)
[XmlElementAttribute]
public:
List<CustomBehavior^>^ CustomBehavior

See Also

QuestOrder Class
Quester.Profile.HB Namespace


Else Field

QuestOrder..::..Else Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[XmlElementAttribute]
public List<Else> Else
<XmlElementAttribute> _
Public Else As List(Of Else)
[XmlElementAttribute]
public:
List<Else^>^ Else

See Also

QuestOrder Class
Quester.Profile.HB Namespace


ElseIf Field

QuestOrder..::..ElseIf Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[XmlElementAttribute]
public List<ElseIf> ElseIf
<XmlElementAttribute> _
Public ElseIf As List(Of ElseIf)
[XmlElementAttribute]
public:
List<ElseIf^>^ ElseIf

See Also

QuestOrder Class
Quester.Profile.HB Namespace


EndIfs Field

QuestOrder..::..EndIfs Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[XmlElementAttribute]
public List<EndIf> EndIfs
<XmlElementAttribute> _
Public EndIfs As List(Of EndIf)
[XmlElementAttribute]
public:
List<EndIf^>^ EndIfs

See Also

QuestOrder Class
Quester.Profile.HB Namespace


EndWhiles Field

QuestOrder..::..EndWhiles Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[XmlElementAttribute]
public List<EndWhile> EndWhiles
<XmlElementAttribute> _
Public EndWhiles As List(Of EndWhile)
[XmlElementAttribute]
public:
List<EndWhile^>^ EndWhiles

See Also

QuestOrder Class
Quester.Profile.HB Namespace


If Field

QuestOrder..::..If Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[XmlElementAttribute]
public List<If> If
<XmlElementAttribute> _
Public If As List(Of If)
[XmlElementAttribute]
public:
List<If^>^ If

See Also

QuestOrder Class
Quester.Profile.HB Namespace


IgnoreCheckPoints Field

QuestOrder..::..IgnoreCheckPoints Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public string IgnoreCheckPoints
Public IgnoreCheckPoints As String
public:
String^ IgnoreCheckPoints

See Also

QuestOrder Class
Quester.Profile.HB Namespace


Objectives Field

QuestOrder..::..Objectives Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[XmlElementAttribute]
public List<ObjectiveQuestOrder> Objectives
<XmlElementAttribute> _
Public Objectives As List(Of ObjectiveQuestOrder)
[XmlElementAttribute]
public:
List<ObjectiveQuestOrder^>^ Objectives

See Also

QuestOrder Class
Quester.Profile.HB Namespace


PickUp Field

QuestOrder..::..PickUp Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[XmlElementAttribute]
public List<PickUp> PickUp
<XmlElementAttribute> _
Public PickUp As List(Of PickUp)
[XmlElementAttribute]
public:
List<PickUp^>^ PickUp

See Also

QuestOrder Class
Quester.Profile.HB Namespace


SetGrindArea Field

QuestOrder..::..SetGrindArea Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public List<GrindArea> SetGrindArea
Public SetGrindArea As List(Of GrindArea)
public:
List<GrindArea^>^ SetGrindArea

See Also

QuestOrder Class
Quester.Profile.HB Namespace


TurnIn Field

QuestOrder..::..TurnIn Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[XmlElementAttribute]
public List<TurnIn> TurnIn
<XmlElementAttribute> _
Public TurnIn As List(Of TurnIn)
[XmlElementAttribute]
public:
List<TurnIn^>^ TurnIn

See Also

QuestOrder Class
Quester.Profile.HB Namespace


While Field

QuestOrder..::..While Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[XmlElementAttribute]
public List<While> While
<XmlElementAttribute> _
Public While As List(Of While)
[XmlElementAttribute]
public:
List<While^>^ While

See Also

QuestOrder Class
Quester.Profile.HB Namespace


QuestOrder Methods

The QuestOrder type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

QuestOrder Class
Quester.Profile.HB Namespace


TurnIn Class

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class TurnIn : Position
<SerializableAttribute> _
Public Class TurnIn _
    Inherits Position
[SerializableAttribute]
public ref class TurnIn : public Position

Inheritance Hierarchy

Object
Quester.Profile.HB..::..Position
Quester.Profile.HB..::..TurnIn

See Also

TurnIn Members
Quester.Profile.HB Namespace


TurnIn Members

The TurnIn type exposes the following members.

Constructors

 | Name | Description
Protected method | TurnIn |

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | GiverType |
Public field | QuestId |
Public field | QuestName |
Public field | TurnInId |
Public field | TurnInName |

See Also

TurnIn Class
Quester.Profile.HB Namespace


TurnIn Constructor

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
protected TurnIn()
Protected Sub New
protected:
TurnIn()

See Also

TurnIn Class
Quester.Profile.HB Namespace


TurnIn Fields

The TurnIn type exposes the following members.

Fields

 | Name | Description
Public field | GiverType |
Public field | QuestId |
Public field | QuestName |
Public field | TurnInId |
Public field | TurnInName |

See Also

TurnIn Class
Quester.Profile.HB Namespace


GiverType Field

TurnIn..::..GiverType Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public string GiverType
Public GiverType As String
public:
String^ GiverType

See Also

TurnIn Class
Quester.Profile.HB Namespace


QuestId Field

TurnIn..::..QuestId Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public int QuestId
Public QuestId As Integer
public:
int^ QuestId

See Also

TurnIn Class
Quester.Profile.HB Namespace


QuestName Field

TurnIn..::..QuestName Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public string QuestName
Public QuestName As String
public:
String^ QuestName

See Also

TurnIn Class
Quester.Profile.HB Namespace


TurnInId Field

TurnIn..::..TurnInId Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public int TurnInId
Public TurnInId As Integer
public:
int^ TurnInId

See Also

TurnIn Class
Quester.Profile.HB Namespace


TurnInName Field

TurnIn..::..TurnInName Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public string TurnInName
Public TurnInName As String
public:
String^ TurnInName

See Also

TurnIn Class
Quester.Profile.HB Namespace


TurnIn Methods

The TurnIn type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

TurnIn Class
Quester.Profile.HB Namespace


Vendor Class

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class Vendor : Position
<SerializableAttribute> _
Public Class Vendor _
    Inherits Position
[SerializableAttribute]
public ref class Vendor : public Position

Inheritance Hierarchy

Object
Quester.Profile.HB..::..Position
Quester.Profile.HB..::..Vendor

See Also

Vendor Members
Quester.Profile.HB Namespace


Vendor Members

The Vendor type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | Entry |
Public field | Name |
Public field | Type |

See Also

Vendor Class
Quester.Profile.HB Namespace


Vendor Fields

The Vendor type exposes the following members.

Fields

 | Name | Description
Public field | Entry |
Public field | Name |
Public field | Type |

See Also

Vendor Class
Quester.Profile.HB Namespace


Entry Field

Vendor..::..Entry Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public int Entry
Public Entry As Integer
public:
int^ Entry

See Also

Vendor Class
Quester.Profile.HB Namespace


Name Field

Vendor..::..Name Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public string Name
Public Name As String
public:
String^ Name

See Also

Vendor Class
Quester.Profile.HB Namespace


Type Field

Vendor..::..Type Field

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public string Type
Public Type As String
public:
String^ Type

See Also

Vendor Class
Quester.Profile.HB Namespace


Vendor Methods

The Vendor type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Vendor Class
Quester.Profile.HB Namespace


While Class

Namespace: Quester.Profile.HB
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class While : If
<SerializableAttribute> _
Public Class While _
    Inherits If
[SerializableAttribute]
public ref class While : public If

Inheritance Hierarchy

Object
Quester.Profile.HB..::..QuestOrder
Quester.Profile.HB..::..If
Quester.Profile.HB..::..While

See Also

Quester.Profile.HB Namespace


While Methods

The While type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

While Class
Quester.Profile.HB Namespace


Quester.Profile.ProfilesCreator Namespace

Classes

 | Class | Description
Public class | BaseToolsHelperClass..::..NPCGiver |
Public class | BaseToolsHelperClass..::..Quest |
Public class | BaseUI | Class BaseUI. Implements the Form
Public class | CheckErrorsUI | Class CheckErrorsUI. Implements the Form
Public class | QuestCustomScriptUI | Class QuestCustomScriptUI. Implements the Form
Public class | QuestGiverUI | Class QuestGiverUI. Implements the Form
Public class | QuestOrderUI | Class QuestOrderUI. Implements the Form
Public class | QuestTools | Class QuestTools. Implements the Form
Public class | QuestUI | Class QuestUI. Implements the Form
Public class | VendorsUI | Class VendorsUI. Implements the Form


BaseToolsHelperClass.NPCGiver Class

BaseToolsHelperClass..::..NPCGiver Class

Namespace: Quester.Profile.ProfilesCreator
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public class NPCGiver
Public Class NPCGiver
public ref class NPCGiver

Inheritance Hierarchy

Object
Quester.Profile.ProfilesCreator..::..BaseToolsHelperClass..::..NPCGiver

See Also

BaseToolsHelperClass..::..NPCGiver Members
Quester.Profile.ProfilesCreator Namespace


BaseToolsHelperClass.NPCGiver Members

BaseToolsHelperClass..::..NPCGiver Members

The BaseToolsHelperClass..::..NPCGiver type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | GameObject |
Public field | Id |
Public field | Name |
Public field | PickUpQuests |
Public field | Position |
Public field | TurnInQuests |

See Also

BaseToolsHelperClass..::..NPCGiver Class
Quester.Profile.ProfilesCreator Namespace


BaseToolsHelperClass.NPCGiver Fields

BaseToolsHelperClass..::..NPCGiver Fields

The BaseToolsHelperClass..::..NPCGiver type exposes the following members.

Fields

 | Name | Description
Public field | GameObject |
Public field | Id |
Public field | Name |
Public field | PickUpQuests |
Public field | Position |
Public field | TurnInQuests |

See Also

BaseToolsHelperClass..::..NPCGiver Class
Quester.Profile.ProfilesCreator Namespace


GameObject Field

NPCGiver..::..GameObject Field

Namespace: Quester.Profile.ProfilesCreator
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public bool GameObject
Public GameObject As Boolean
public:
bool^ GameObject

See Also

BaseToolsHelperClass..::..NPCGiver Class
Quester.Profile.ProfilesCreator Namespace


Id Field

NPCGiver..::..Id Field

Namespace: Quester.Profile.ProfilesCreator
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public int Id
Public Id As Integer
public:
int^ Id

See Also

BaseToolsHelperClass..::..NPCGiver Class
Quester.Profile.ProfilesCreator Namespace


Name Field

NPCGiver..::..Name Field

Namespace: Quester.Profile.ProfilesCreator
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public string Name
Public Name As String
public:
String^ Name

See Also

BaseToolsHelperClass..::..NPCGiver Class
Quester.Profile.ProfilesCreator Namespace


PickUpQuests Field

NPCGiver..::..PickUpQuests Field

Namespace: Quester.Profile.ProfilesCreator
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public List<int> PickUpQuests
Public PickUpQuests As List(Of Integer)
public:
List<int^>^ PickUpQuests

See Also

BaseToolsHelperClass..::..NPCGiver Class
Quester.Profile.ProfilesCreator Namespace


Position Field

NPCGiver..::..Position Field

Namespace: Quester.Profile.ProfilesCreator
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public Vector3 Position
Public Position As Vector3
public:
Vector3^ Position

See Also

BaseToolsHelperClass..::..NPCGiver Class
Quester.Profile.ProfilesCreator Namespace


TurnInQuests Field

NPCGiver..::..TurnInQuests Field

Namespace: Quester.Profile.ProfilesCreator
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public List<int> TurnInQuests
Public TurnInQuests As List(Of Integer)
public:
List<int^>^ TurnInQuests

See Also

BaseToolsHelperClass..::..NPCGiver Class
Quester.Profile.ProfilesCreator Namespace


BaseToolsHelperClass.NPCGiver Methods

BaseToolsHelperClass..::..NPCGiver Methods

The BaseToolsHelperClass..::..NPCGiver type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

BaseToolsHelperClass..::..NPCGiver Class
Quester.Profile.ProfilesCreator Namespace


BaseToolsHelperClass.Quest Class

BaseToolsHelperClass..::..Quest Class

Namespace: Quester.Profile.ProfilesCreator
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public class Quest
Public Class Quest
public ref class Quest

Inheritance Hierarchy

Object
Quester.Profile.ProfilesCreator..::..BaseToolsHelperClass..::..Quest

See Also

BaseToolsHelperClass..::..Quest Members
Quester.Profile.ProfilesCreator Namespace


BaseToolsHelperClass.Quest Members

BaseToolsHelperClass..::..Quest Members

The BaseToolsHelperClass..::..Quest type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | AddParam |
Public field | Id |
Public field | Name |
Public field | Obj1 |
Public field | Obj2 |
Public field | Obj3 |
Public field | Obj4 |
Public field | Type |

See Also

BaseToolsHelperClass..::..Quest Class
Quester.Profile.ProfilesCreator Namespace


BaseToolsHelperClass.Quest Fields

BaseToolsHelperClass..::..Quest Fields

The BaseToolsHelperClass..::..Quest type exposes the following members.

Fields

 | Name | Description
Public field | AddParam |
Public field | Id |
Public field | Name |
Public field | Obj1 |
Public field | Obj2 |
Public field | Obj3 |
Public field | Obj4 |
Public field | Type |

See Also

BaseToolsHelperClass..::..Quest Class
Quester.Profile.ProfilesCreator Namespace


AddParam Field

Quest..::..AddParam Field

Namespace: Quester.Profile.ProfilesCreator
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public string AddParam
Public AddParam As String
public:
String^ AddParam

See Also

BaseToolsHelperClass..::..Quest Class
Quester.Profile.ProfilesCreator Namespace


Id Field

Quest..::..Id Field

Namespace: Quester.Profile.ProfilesCreator
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public int Id
Public Id As Integer
public:
int^ Id

See Also

BaseToolsHelperClass..::..Quest Class
Quester.Profile.ProfilesCreator Namespace


Name Field

Quest..::..Name Field

Namespace: Quester.Profile.ProfilesCreator
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public string Name
Public Name As String
public:
String^ Name

See Also

BaseToolsHelperClass..::..Quest Class
Quester.Profile.ProfilesCreator Namespace


Obj1 Field

Quest..::..Obj1 Field

Namespace: Quester.Profile.ProfilesCreator
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public int Obj1
Public Obj1 As Integer
public:
int^ Obj1

See Also

BaseToolsHelperClass..::..Quest Class
Quester.Profile.ProfilesCreator Namespace


Obj2 Field

Quest..::..Obj2 Field

Namespace: Quester.Profile.ProfilesCreator
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public int Obj2
Public Obj2 As Integer
public:
int^ Obj2

See Also

BaseToolsHelperClass..::..Quest Class
Quester.Profile.ProfilesCreator Namespace


Obj3 Field

Quest..::..Obj3 Field

Namespace: Quester.Profile.ProfilesCreator
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public int Obj3
Public Obj3 As Integer
public:
int^ Obj3

See Also

BaseToolsHelperClass..::..Quest Class
Quester.Profile.ProfilesCreator Namespace


Obj4 Field

Quest..::..Obj4 Field

Namespace: Quester.Profile.ProfilesCreator
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public int Obj4
Public Obj4 As Integer
public:
int^ Obj4

See Also

BaseToolsHelperClass..::..Quest Class
Quester.Profile.ProfilesCreator Namespace


Type Field

Quest..::..Type Field

Namespace: Quester.Profile.ProfilesCreator
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public string Type
Public Type As String
public:
String^ Type

See Also

BaseToolsHelperClass..::..Quest Class
Quester.Profile.ProfilesCreator Namespace


BaseToolsHelperClass.Quest Methods

BaseToolsHelperClass..::..Quest Methods

The BaseToolsHelperClass..::..Quest type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

BaseToolsHelperClass..::..Quest Class
Quester.Profile.ProfilesCreator Namespace


BaseUI Class

Class BaseUI. Implements the Form

Namespace: Quester.Profile.ProfilesCreator
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public class BaseUI : Form
Public Class BaseUI _
    Inherits Form
public ref class BaseUI : public Form

Inheritance Hierarchy

Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
Quester.Profile.ProfilesCreator..::..BaseUI

See Also

BaseUI Members
Quester.Profile.ProfilesCreator Namespace
Form


BaseUI Members

The BaseUI type exposes the following members.

Constructors

 | Name | Description
Public method | BaseUI | Initializes a new instance of the BaseUI class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Public method | Activate | (Inherited from Form.)
Protected method | ActivateMdiChild(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | AddOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from Form.)
Protected method | ApplyAutoScaling | (Inherited from Form.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Protected method | CenterToParent | (Inherited from Form.)
Protected method | CenterToScreen | (Inherited from Form.)
Public method | Close | (Inherited from Form.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Form.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Clean up any resources being used.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Public method | LayoutMdi(System.Windows.Forms.MdiLayout) | (Inherited from Form.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnActivated(System.EventArgs) | (Inherited from Form.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnClosed(System.EventArgs) | (Inherited from Form.)
Protected method | OnClosing(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from Form.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDeactivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Form.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnFormClosed(System.Windows.Forms.FormClosedEventArgs) | (Inherited from Form.)
Protected method | OnFormClosing(System.Windows.Forms.FormClosingEventArgs) | (Inherited from Form.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Form.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Form.)
Protected method | OnHelpButtonClicked(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInputLanguageChanged(System.Windows.Forms.InputLanguageChangedEventArgs) | (Inherited from Form.)
Protected method | OnInputLanguageChanging(System.Windows.Forms.InputLanguageChangingEventArgs) | (Inherited from Form.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from Form.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from Form.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMaximumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMdiChildActivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuComplete(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuStart(System.EventArgs) | (Inherited from Form.)
Protected method | OnMinimumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Form.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeBegin(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeEnd(System.EventArgs) | (Inherited from Form.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnShown(System.EventArgs) | (Inherited from Form.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from Form.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from Form.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from Form.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | RemoveOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from Form.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from Form.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopLocation(System.Int32,System.Int32) | (Inherited from Form.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Form.)
Public method | Show(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Public method | Show | (Inherited from Control.)
Public method | ShowDialog | (Inherited from Form.)
Public method | ShowDialog(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Form.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from Form.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from Form.)

Properties

 | Name | Description
Public property | AcceptButton | (Inherited from Form.)
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | ActiveMdiChild | (Inherited from Form.)
Public property | AllowDrop | (Inherited from Control.)
Public property | AllowTransparency | (Inherited from Form.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScale | (Inherited from Form.)
Public property | AutoScaleBaseSize | (Inherited from Form.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from Form.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Form.)
Public property | AutoSizeMode | (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Public property | CancelButton | (Inherited from Form.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Form.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | ControlBox | (Inherited from Form.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Form.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DesktopBounds | (Inherited from Form.)
Public property | DesktopLocation | (Inherited from Form.)
Public property | DialogResult | (Inherited from Form.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | FormBorderStyle | (Inherited from Form.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HelpButton | (Inherited from Form.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | Icon | (Inherited from Form.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMdiChild | (Inherited from Form.)
Public property | IsMdiContainer | (Inherited from Form.)
Public property | IsMirrored | (Inherited from Control.)
Public property | IsRestrictedWindow | (Inherited from Form.)
Public property | KeyPreview | (Inherited from Form.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Form.)
Public property | MainMenuStrip | (Inherited from Form.)
Public property | Margin | (Inherited from Form.)
Public property | MaximizeBox | (Inherited from Form.)
Protected property | MaximizedBounds | (Inherited from Form.)
Public property | MaximumSize | (Inherited from Form.)
Public property | MdiChildren | (Inherited from Form.)
Public property | MdiParent | (Inherited from Form.)
Public property | Menu | (Inherited from Form.)
Public property | MergedMenu | (Inherited from Form.)
Public property | MinimizeBox | (Inherited from Form.)
Public property | MinimumSize | (Inherited from Form.)
Public property | Modal | (Inherited from Form.)
Public property | Name | (Inherited from Control.)
Public property | Opacity | (Inherited from Form.)
Public property | OwnedForms | (Inherited from Form.)
Public property | Owner | (Inherited from Form.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | RestoreBounds | (Inherited from Form.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Public property | RightToLeftLayout | (Inherited from Form.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | ShowIcon | (Inherited from Form.)
Public property | ShowInTaskbar | (Inherited from Form.)
Protected property | ShowWithoutActivation | (Inherited from Form.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Form.)
Public property | SizeGripStyle | (Inherited from Form.)
Public property | StartPosition | (Inherited from Form.)
Public property | TabIndex | (Inherited from Form.)
Public property | TabStop | (Inherited from Form.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | (Inherited from Control.)
Public property | TopLevel | (Inherited from Form.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | TopMost | (Inherited from Form.)
Public property | TransparencyKey | (Inherited from Form.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowState | (Inherited from Form.)
Public property | WindowTarget | (Inherited from Control.)

Events

 | Name | Description
Public event | Activated | (Inherited from Form.)
Public event | AutoSizeChanged | (Inherited from Form.)
Public event | AutoValidateChanged | (Inherited from Form.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | Closed | (Inherited from Form.)
Public event | Closing | (Inherited from Form.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Deactivate | (Inherited from Form.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | FormClosed | (Inherited from Form.)
Public event | FormClosing | (Inherited from Form.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpButtonClicked | (Inherited from Form.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | InputLanguageChanged | (Inherited from Form.)
Public event | InputLanguageChanging | (Inherited from Form.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from Form.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Form.)
Public event | MaximizedBoundsChanged | (Inherited from Form.)
Public event | MaximumSizeChanged | (Inherited from Form.)
Public event | MdiChildActivate | (Inherited from Form.)
Public event | MenuComplete | (Inherited from Form.)
Public event | MenuStart | (Inherited from Form.)
Public event | MinimumSizeChanged | (Inherited from Form.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | ResizeBegin | (Inherited from Form.)
Public event | ResizeEnd | (Inherited from Form.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | RightToLeftLayoutChanged | (Inherited from Form.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | Shown | (Inherited from Form.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Form.)
Public event | TabStopChanged | (Inherited from Form.)
Public event | TextChanged | (Inherited from Control.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

BaseUI Class
Quester.Profile.ProfilesCreator Namespace


BaseUI Constructor

Initializes a new instance of the BaseUI class.

Namespace: Quester.Profile.ProfilesCreator
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public BaseUI()
Public Sub New
public:
BaseUI()

See Also

BaseUI Class
Quester.Profile.ProfilesCreator Namespace


BaseUI Methods

The BaseUI type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Public method | Activate | (Inherited from Form.)
Protected method | ActivateMdiChild(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | AddOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from Form.)
Protected method | ApplyAutoScaling | (Inherited from Form.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Protected method | CenterToParent | (Inherited from Form.)
Protected method | CenterToScreen | (Inherited from Form.)
Public method | Close | (Inherited from Form.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Form.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Clean up any resources being used.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Public method | LayoutMdi(System.Windows.Forms.MdiLayout) | (Inherited from Form.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnActivated(System.EventArgs) | (Inherited from Form.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnClosed(System.EventArgs) | (Inherited from Form.)
Protected method | OnClosing(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from Form.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDeactivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Form.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnFormClosed(System.Windows.Forms.FormClosedEventArgs) | (Inherited from Form.)
Protected method | OnFormClosing(System.Windows.Forms.FormClosingEventArgs) | (Inherited from Form.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Form.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Form.)
Protected method | OnHelpButtonClicked(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInputLanguageChanged(System.Windows.Forms.InputLanguageChangedEventArgs) | (Inherited from Form.)
Protected method | OnInputLanguageChanging(System.Windows.Forms.InputLanguageChangingEventArgs) | (Inherited from Form.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from Form.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from Form.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMaximumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMdiChildActivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuComplete(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuStart(System.EventArgs) | (Inherited from Form.)
Protected method | OnMinimumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Form.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeBegin(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeEnd(System.EventArgs) | (Inherited from Form.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnShown(System.EventArgs) | (Inherited from Form.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from Form.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from Form.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from Form.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | RemoveOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from Form.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from Form.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopLocation(System.Int32,System.Int32) | (Inherited from Form.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Form.)
Public method | Show(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Public method | Show | (Inherited from Control.)
Public method | ShowDialog | (Inherited from Form.)
Public method | ShowDialog(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Form.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from Form.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from Form.)

See Also

BaseUI Class
Quester.Profile.ProfilesCreator Namespace


Dispose Method

BaseUI..::..Dispose Method

Overload List

 | Name | Description
Protected method | Dispose(Boolean) | Clean up any resources being used.
Public method | Dispose | (Inherited from Component.)

See Also

BaseUI Class
BaseUI Members
Quester.Profile.ProfilesCreator Namespace


Dispose Method

BaseUI..::..Dispose Method

Clean up any resources being used.

Namespace: Quester.Profile.ProfilesCreator
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
protected void Dispose(
    bool disposing
)
Protected Sub Dispose ( _
    disposing As Boolean _
)
protected:
void Dispose(
    bool^ disposing
)

Parameters

disposing
Type: Boolean
true if managed resources should be disposed; otherwise, false.

See Also

BaseUI Class
Quester.Profile.ProfilesCreator Namespace


BaseUI Properties

The BaseUI type exposes the following members.

Properties

 | Name | Description
Public property | AcceptButton | (Inherited from Form.)
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | ActiveMdiChild | (Inherited from Form.)
Public property | AllowDrop | (Inherited from Control.)
Public property | AllowTransparency | (Inherited from Form.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScale | (Inherited from Form.)
Public property | AutoScaleBaseSize | (Inherited from Form.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from Form.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Form.)
Public property | AutoSizeMode | (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Public property | CancelButton | (Inherited from Form.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Form.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | ControlBox | (Inherited from Form.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Form.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DesktopBounds | (Inherited from Form.)
Public property | DesktopLocation | (Inherited from Form.)
Public property | DialogResult | (Inherited from Form.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | FormBorderStyle | (Inherited from Form.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HelpButton | (Inherited from Form.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | Icon | (Inherited from Form.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMdiChild | (Inherited from Form.)
Public property | IsMdiContainer | (Inherited from Form.)
Public property | IsMirrored | (Inherited from Control.)
Public property | IsRestrictedWindow | (Inherited from Form.)
Public property | KeyPreview | (Inherited from Form.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Form.)
Public property | MainMenuStrip | (Inherited from Form.)
Public property | Margin | (Inherited from Form.)
Public property | MaximizeBox | (Inherited from Form.)
Protected property | MaximizedBounds | (Inherited from Form.)
Public property | MaximumSize | (Inherited from Form.)
Public property | MdiChildren | (Inherited from Form.)
Public property | MdiParent | (Inherited from Form.)
Public property | Menu | (Inherited from Form.)
Public property | MergedMenu | (Inherited from Form.)
Public property | MinimizeBox | (Inherited from Form.)
Public property | MinimumSize | (Inherited from Form.)
Public property | Modal | (Inherited from Form.)
Public property | Name | (Inherited from Control.)
Public property | Opacity | (Inherited from Form.)
Public property | OwnedForms | (Inherited from Form.)
Public property | Owner | (Inherited from Form.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | RestoreBounds | (Inherited from Form.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Public property | RightToLeftLayout | (Inherited from Form.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | ShowIcon | (Inherited from Form.)
Public property | ShowInTaskbar | (Inherited from Form.)
Protected property | ShowWithoutActivation | (Inherited from Form.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Form.)
Public property | SizeGripStyle | (Inherited from Form.)
Public property | StartPosition | (Inherited from Form.)
Public property | TabIndex | (Inherited from Form.)
Public property | TabStop | (Inherited from Form.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | (Inherited from Control.)
Public property | TopLevel | (Inherited from Form.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | TopMost | (Inherited from Form.)
Public property | TransparencyKey | (Inherited from Form.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowState | (Inherited from Form.)
Public property | WindowTarget | (Inherited from Control.)

See Also

BaseUI Class
Quester.Profile.ProfilesCreator Namespace


BaseUI Events

The BaseUI type exposes the following members.

Events

 | Name | Description
Public event | Activated | (Inherited from Form.)
Public event | AutoSizeChanged | (Inherited from Form.)
Public event | AutoValidateChanged | (Inherited from Form.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | Closed | (Inherited from Form.)
Public event | Closing | (Inherited from Form.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Deactivate | (Inherited from Form.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | FormClosed | (Inherited from Form.)
Public event | FormClosing | (Inherited from Form.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpButtonClicked | (Inherited from Form.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | InputLanguageChanged | (Inherited from Form.)
Public event | InputLanguageChanging | (Inherited from Form.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from Form.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Form.)
Public event | MaximizedBoundsChanged | (Inherited from Form.)
Public event | MaximumSizeChanged | (Inherited from Form.)
Public event | MdiChildActivate | (Inherited from Form.)
Public event | MenuComplete | (Inherited from Form.)
Public event | MenuStart | (Inherited from Form.)
Public event | MinimumSizeChanged | (Inherited from Form.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | ResizeBegin | (Inherited from Form.)
Public event | ResizeEnd | (Inherited from Form.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | RightToLeftLayoutChanged | (Inherited from Form.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | Shown | (Inherited from Form.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Form.)
Public event | TabStopChanged | (Inherited from Form.)
Public event | TextChanged | (Inherited from Control.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

BaseUI Class
Quester.Profile.ProfilesCreator Namespace


CheckErrorsUI Class

Class CheckErrorsUI. Implements the Form

Namespace: Quester.Profile.ProfilesCreator
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public class CheckErrorsUI : Form
Public Class CheckErrorsUI _
    Inherits Form
public ref class CheckErrorsUI : public Form

Inheritance Hierarchy

Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
Quester.Profile.ProfilesCreator..::..CheckErrorsUI

See Also

CheckErrorsUI Members
Quester.Profile.ProfilesCreator Namespace
Form


CheckErrorsUI Members

The CheckErrorsUI type exposes the following members.

Constructors

 | Name | Description
Public method | CheckErrorsUI | Initializes a new instance of the CheckErrorsUI class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Public method | Activate | (Inherited from Form.)
Protected method | ActivateMdiChild(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | AddOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from Form.)
Protected method | ApplyAutoScaling | (Inherited from Form.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Protected method | CenterToParent | (Inherited from Form.)
Protected method | CenterToScreen | (Inherited from Form.)
Public method | Close | (Inherited from Form.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Form.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Clean up any resources being used.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Public method | LayoutMdi(System.Windows.Forms.MdiLayout) | (Inherited from Form.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnActivated(System.EventArgs) | (Inherited from Form.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnClosed(System.EventArgs) | (Inherited from Form.)
Protected method | OnClosing(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from Form.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDeactivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Form.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnFormClosed(System.Windows.Forms.FormClosedEventArgs) | (Inherited from Form.)
Protected method | OnFormClosing(System.Windows.Forms.FormClosingEventArgs) | (Inherited from Form.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Form.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Form.)
Protected method | OnHelpButtonClicked(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInputLanguageChanged(System.Windows.Forms.InputLanguageChangedEventArgs) | (Inherited from Form.)
Protected method | OnInputLanguageChanging(System.Windows.Forms.InputLanguageChangingEventArgs) | (Inherited from Form.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from Form.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from Form.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMaximumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMdiChildActivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuComplete(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuStart(System.EventArgs) | (Inherited from Form.)
Protected method | OnMinimumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Form.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeBegin(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeEnd(System.EventArgs) | (Inherited from Form.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnShown(System.EventArgs) | (Inherited from Form.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from Form.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from Form.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from Form.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | RemoveOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from Form.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from Form.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopLocation(System.Int32,System.Int32) | (Inherited from Form.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Form.)
Public method | Show(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Public method | Show | (Inherited from Control.)
Public method | ShowDialog | (Inherited from Form.)
Public method | ShowDialog(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Form.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from Form.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from Form.)

Properties

 | Name | Description
Public property | AcceptButton | (Inherited from Form.)
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | ActiveMdiChild | (Inherited from Form.)
Public property | AllowDrop | (Inherited from Control.)
Public property | AllowTransparency | (Inherited from Form.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScale | (Inherited from Form.)
Public property | AutoScaleBaseSize | (Inherited from Form.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from Form.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Form.)
Public property | AutoSizeMode | (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Public property | CancelButton | (Inherited from Form.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Form.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | ControlBox | (Inherited from Form.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Form.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DesktopBounds | (Inherited from Form.)
Public property | DesktopLocation | (Inherited from Form.)
Public property | DialogResult | (Inherited from Form.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | FormBorderStyle | (Inherited from Form.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HelpButton | (Inherited from Form.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | Icon | (Inherited from Form.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMdiChild | (Inherited from Form.)
Public property | IsMdiContainer | (Inherited from Form.)
Public property | IsMirrored | (Inherited from Control.)
Public property | IsRestrictedWindow | (Inherited from Form.)
Public property | KeyPreview | (Inherited from Form.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Form.)
Public property | MainMenuStrip | (Inherited from Form.)
Public property | Margin | (Inherited from Form.)
Public property | MaximizeBox | (Inherited from Form.)
Protected property | MaximizedBounds | (Inherited from Form.)
Public property | MaximumSize | (Inherited from Form.)
Public property | MdiChildren | (Inherited from Form.)
Public property | MdiParent | (Inherited from Form.)
Public property | Menu | (Inherited from Form.)
Public property | MergedMenu | (Inherited from Form.)
Public property | MinimizeBox | (Inherited from Form.)
Public property | MinimumSize | (Inherited from Form.)
Public property | Modal | (Inherited from Form.)
Public property | Name | (Inherited from Control.)
Public property | Opacity | (Inherited from Form.)
Public property | OwnedForms | (Inherited from Form.)
Public property | Owner | (Inherited from Form.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | RestoreBounds | (Inherited from Form.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Public property | RightToLeftLayout | (Inherited from Form.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | ShowIcon | (Inherited from Form.)
Public property | ShowInTaskbar | (Inherited from Form.)
Protected property | ShowWithoutActivation | (Inherited from Form.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Form.)
Public property | SizeGripStyle | (Inherited from Form.)
Public property | StartPosition | (Inherited from Form.)
Public property | TabIndex | (Inherited from Form.)
Public property | TabStop | (Inherited from Form.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | (Inherited from Control.)
Public property | TopLevel | (Inherited from Form.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | TopMost | (Inherited from Form.)
Public property | TransparencyKey | (Inherited from Form.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowState | (Inherited from Form.)
Public property | WindowTarget | (Inherited from Control.)

Events

 | Name | Description
Public event | Activated | (Inherited from Form.)
Public event | AutoSizeChanged | (Inherited from Form.)
Public event | AutoValidateChanged | (Inherited from Form.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | Closed | (Inherited from Form.)
Public event | Closing | (Inherited from Form.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Deactivate | (Inherited from Form.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | FormClosed | (Inherited from Form.)
Public event | FormClosing | (Inherited from Form.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpButtonClicked | (Inherited from Form.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | InputLanguageChanged | (Inherited from Form.)
Public event | InputLanguageChanging | (Inherited from Form.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from Form.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Form.)
Public event | MaximizedBoundsChanged | (Inherited from Form.)
Public event | MaximumSizeChanged | (Inherited from Form.)
Public event | MdiChildActivate | (Inherited from Form.)
Public event | MenuComplete | (Inherited from Form.)
Public event | MenuStart | (Inherited from Form.)
Public event | MinimumSizeChanged | (Inherited from Form.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | ResizeBegin | (Inherited from Form.)
Public event | ResizeEnd | (Inherited from Form.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | RightToLeftLayoutChanged | (Inherited from Form.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | Shown | (Inherited from Form.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Form.)
Public event | TabStopChanged | (Inherited from Form.)
Public event | TextChanged | (Inherited from Control.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

CheckErrorsUI Class
Quester.Profile.ProfilesCreator Namespace


CheckErrorsUI Constructor

Initializes a new instance of the CheckErrorsUI class.

Namespace: Quester.Profile.ProfilesCreator
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public CheckErrorsUI(
    ref EasyQuestProfile questProfile
)
Public Sub New ( _
    ByRef questProfile As EasyQuestProfile _
)
public:
CheckErrorsUI(
    EasyQuestProfile^% questProfile
)

Parameters

questProfile
Type: Quester.Profile..::..EasyQuestProfile %
The quest profile.

See Also

CheckErrorsUI Class
Quester.Profile.ProfilesCreator Namespace


CheckErrorsUI Methods

The CheckErrorsUI type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Public method | Activate | (Inherited from Form.)
Protected method | ActivateMdiChild(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | AddOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from Form.)
Protected method | ApplyAutoScaling | (Inherited from Form.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Protected method | CenterToParent | (Inherited from Form.)
Protected method | CenterToScreen | (Inherited from Form.)
Public method | Close | (Inherited from Form.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Form.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Clean up any resources being used.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Public method | LayoutMdi(System.Windows.Forms.MdiLayout) | (Inherited from Form.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnActivated(System.EventArgs) | (Inherited from Form.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnClosed(System.EventArgs) | (Inherited from Form.)
Protected method | OnClosing(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from Form.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDeactivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Form.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnFormClosed(System.Windows.Forms.FormClosedEventArgs) | (Inherited from Form.)
Protected method | OnFormClosing(System.Windows.Forms.FormClosingEventArgs) | (Inherited from Form.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Form.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Form.)
Protected method | OnHelpButtonClicked(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInputLanguageChanged(System.Windows.Forms.InputLanguageChangedEventArgs) | (Inherited from Form.)
Protected method | OnInputLanguageChanging(System.Windows.Forms.InputLanguageChangingEventArgs) | (Inherited from Form.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from Form.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from Form.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMaximumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMdiChildActivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuComplete(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuStart(System.EventArgs) | (Inherited from Form.)
Protected method | OnMinimumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Form.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeBegin(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeEnd(System.EventArgs) | (Inherited from Form.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnShown(System.EventArgs) | (Inherited from Form.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from Form.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from Form.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from Form.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | RemoveOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from Form.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from Form.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopLocation(System.Int32,System.Int32) | (Inherited from Form.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Form.)
Public method | Show(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Public method | Show | (Inherited from Control.)
Public method | ShowDialog | (Inherited from Form.)
Public method | ShowDialog(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Form.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from Form.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from Form.)

See Also

CheckErrorsUI Class
Quester.Profile.ProfilesCreator Namespace


Dispose Method

CheckErrorsUI..::..Dispose Method

Overload List

 | Name | Description
Protected method | Dispose(Boolean) | Clean up any resources being used.
Public method | Dispose | (Inherited from Component.)

See Also

CheckErrorsUI Class
CheckErrorsUI Members
Quester.Profile.ProfilesCreator Namespace


Dispose Method

CheckErrorsUI..::..Dispose Method

Clean up any resources being used.

Namespace: Quester.Profile.ProfilesCreator
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
protected void Dispose(
    bool disposing
)
Protected Sub Dispose ( _
    disposing As Boolean _
)
protected:
void Dispose(
    bool^ disposing
)

Parameters

disposing
Type: Boolean
true if managed resources should be disposed; otherwise, false.

See Also

CheckErrorsUI Class
Quester.Profile.ProfilesCreator Namespace


CheckErrorsUI Properties

The CheckErrorsUI type exposes the following members.

Properties

 | Name | Description
Public property | AcceptButton | (Inherited from Form.)
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | ActiveMdiChild | (Inherited from Form.)
Public property | AllowDrop | (Inherited from Control.)
Public property | AllowTransparency | (Inherited from Form.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScale | (Inherited from Form.)
Public property | AutoScaleBaseSize | (Inherited from Form.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from Form.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Form.)
Public property | AutoSizeMode | (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Public property | CancelButton | (Inherited from Form.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Form.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | ControlBox | (Inherited from Form.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Form.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DesktopBounds | (Inherited from Form.)
Public property | DesktopLocation | (Inherited from Form.)
Public property | DialogResult | (Inherited from Form.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | FormBorderStyle | (Inherited from Form.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HelpButton | (Inherited from Form.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | Icon | (Inherited from Form.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMdiChild | (Inherited from Form.)
Public property | IsMdiContainer | (Inherited from Form.)
Public property | IsMirrored | (Inherited from Control.)
Public property | IsRestrictedWindow | (Inherited from Form.)
Public property | KeyPreview | (Inherited from Form.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Form.)
Public property | MainMenuStrip | (Inherited from Form.)
Public property | Margin | (Inherited from Form.)
Public property | MaximizeBox | (Inherited from Form.)
Protected property | MaximizedBounds | (Inherited from Form.)
Public property | MaximumSize | (Inherited from Form.)
Public property | MdiChildren | (Inherited from Form.)
Public property | MdiParent | (Inherited from Form.)
Public property | Menu | (Inherited from Form.)
Public property | MergedMenu | (Inherited from Form.)
Public property | MinimizeBox | (Inherited from Form.)
Public property | MinimumSize | (Inherited from Form.)
Public property | Modal | (Inherited from Form.)
Public property | Name | (Inherited from Control.)
Public property | Opacity | (Inherited from Form.)
Public property | OwnedForms | (Inherited from Form.)
Public property | Owner | (Inherited from Form.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | RestoreBounds | (Inherited from Form.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Public property | RightToLeftLayout | (Inherited from Form.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | ShowIcon | (Inherited from Form.)
Public property | ShowInTaskbar | (Inherited from Form.)
Protected property | ShowWithoutActivation | (Inherited from Form.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Form.)
Public property | SizeGripStyle | (Inherited from Form.)
Public property | StartPosition | (Inherited from Form.)
Public property | TabIndex | (Inherited from Form.)
Public property | TabStop | (Inherited from Form.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | (Inherited from Control.)
Public property | TopLevel | (Inherited from Form.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | TopMost | (Inherited from Form.)
Public property | TransparencyKey | (Inherited from Form.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowState | (Inherited from Form.)
Public property | WindowTarget | (Inherited from Control.)

See Also

CheckErrorsUI Class
Quester.Profile.ProfilesCreator Namespace


CheckErrorsUI Events

The CheckErrorsUI type exposes the following members.

Events

 | Name | Description
Public event | Activated | (Inherited from Form.)
Public event | AutoSizeChanged | (Inherited from Form.)
Public event | AutoValidateChanged | (Inherited from Form.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | Closed | (Inherited from Form.)
Public event | Closing | (Inherited from Form.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Deactivate | (Inherited from Form.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | FormClosed | (Inherited from Form.)
Public event | FormClosing | (Inherited from Form.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpButtonClicked | (Inherited from Form.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | InputLanguageChanged | (Inherited from Form.)
Public event | InputLanguageChanging | (Inherited from Form.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from Form.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Form.)
Public event | MaximizedBoundsChanged | (Inherited from Form.)
Public event | MaximumSizeChanged | (Inherited from Form.)
Public event | MdiChildActivate | (Inherited from Form.)
Public event | MenuComplete | (Inherited from Form.)
Public event | MenuStart | (Inherited from Form.)
Public event | MinimumSizeChanged | (Inherited from Form.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | ResizeBegin | (Inherited from Form.)
Public event | ResizeEnd | (Inherited from Form.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | RightToLeftLayoutChanged | (Inherited from Form.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | Shown | (Inherited from Form.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Form.)
Public event | TabStopChanged | (Inherited from Form.)
Public event | TextChanged | (Inherited from Control.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

CheckErrorsUI Class
Quester.Profile.ProfilesCreator Namespace


QuestCustomScriptUI Class

Class QuestCustomScriptUI. Implements the Form

Namespace: Quester.Profile.ProfilesCreator
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public class QuestCustomScriptUI : Form
Public Class QuestCustomScriptUI _
    Inherits Form
public ref class QuestCustomScriptUI : public Form

Inheritance Hierarchy

Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
Quester.Profile.ProfilesCreator..::..QuestCustomScriptUI

See Also

QuestCustomScriptUI Members
Quester.Profile.ProfilesCreator Namespace
Form


QuestCustomScriptUI Members

The QuestCustomScriptUI type exposes the following members.

Constructors

 | Name | Description
Public method | QuestCustomScriptUI | Initializes a new instance of the QuestCustomScriptUI class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Public method | Activate | (Inherited from Form.)
Protected method | ActivateMdiChild(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | AddOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from Form.)
Protected method | ApplyAutoScaling | (Inherited from Form.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Protected method | CenterToParent | (Inherited from Form.)
Protected method | CenterToScreen | (Inherited from Form.)
Public method | Close | (Inherited from Form.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Form.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Clean up any resources being used.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Public method | LayoutMdi(System.Windows.Forms.MdiLayout) | (Inherited from Form.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnActivated(System.EventArgs) | (Inherited from Form.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnClosed(System.EventArgs) | (Inherited from Form.)
Protected method | OnClosing(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from Form.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDeactivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Form.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnFormClosed(System.Windows.Forms.FormClosedEventArgs) | (Inherited from Form.)
Protected method | OnFormClosing(System.Windows.Forms.FormClosingEventArgs) | (Inherited from Form.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Form.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Form.)
Protected method | OnHelpButtonClicked(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInputLanguageChanged(System.Windows.Forms.InputLanguageChangedEventArgs) | (Inherited from Form.)
Protected method | OnInputLanguageChanging(System.Windows.Forms.InputLanguageChangingEventArgs) | (Inherited from Form.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from Form.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from Form.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMaximumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMdiChildActivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuComplete(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuStart(System.EventArgs) | (Inherited from Form.)
Protected method | OnMinimumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Form.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeBegin(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeEnd(System.EventArgs) | (Inherited from Form.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnShown(System.EventArgs) | (Inherited from Form.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from Form.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from Form.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from Form.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | RemoveOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from Form.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from Form.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopLocation(System.Int32,System.Int32) | (Inherited from Form.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Form.)
Public method | Show(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Public method | Show | (Inherited from Control.)
Public method | ShowDialog | (Inherited from Form.)
Public method | ShowDialog(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Form.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from Form.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from Form.)

Properties

 | Name | Description
Public property | AcceptButton | (Inherited from Form.)
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | ActiveMdiChild | (Inherited from Form.)
Public property | AllowDrop | (Inherited from Control.)
Public property | AllowTransparency | (Inherited from Form.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScale | (Inherited from Form.)
Public property | AutoScaleBaseSize | (Inherited from Form.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from Form.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Form.)
Public property | AutoSizeMode | (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Public property | CancelButton | (Inherited from Form.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Form.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | ControlBox | (Inherited from Form.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Form.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DesktopBounds | (Inherited from Form.)
Public property | DesktopLocation | (Inherited from Form.)
Public property | DialogResult | (Inherited from Form.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | FormBorderStyle | (Inherited from Form.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HelpButton | (Inherited from Form.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | Icon | (Inherited from Form.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMdiChild | (Inherited from Form.)
Public property | IsMdiContainer | (Inherited from Form.)
Public property | IsMirrored | (Inherited from Control.)
Public property | IsRestrictedWindow | (Inherited from Form.)
Public property | KeyPreview | (Inherited from Form.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Form.)
Public property | MainMenuStrip | (Inherited from Form.)
Public property | Margin | (Inherited from Form.)
Public property | MaximizeBox | (Inherited from Form.)
Protected property | MaximizedBounds | (Inherited from Form.)
Public property | MaximumSize | (Inherited from Form.)
Public property | MdiChildren | (Inherited from Form.)
Public property | MdiParent | (Inherited from Form.)
Public property | Menu | (Inherited from Form.)
Public property | MergedMenu | (Inherited from Form.)
Public property | MinimizeBox | (Inherited from Form.)
Public property | MinimumSize | (Inherited from Form.)
Public property | Modal | (Inherited from Form.)
Public property | Name | (Inherited from Control.)
Public property | Opacity | (Inherited from Form.)
Public property | OwnedForms | (Inherited from Form.)
Public property | Owner | (Inherited from Form.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | RestoreBounds | (Inherited from Form.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Public property | RightToLeftLayout | (Inherited from Form.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | ShowIcon | (Inherited from Form.)
Public property | ShowInTaskbar | (Inherited from Form.)
Protected property | ShowWithoutActivation | (Inherited from Form.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Form.)
Public property | SizeGripStyle | (Inherited from Form.)
Public property | StartPosition | (Inherited from Form.)
Public property | TabIndex | (Inherited from Form.)
Public property | TabStop | (Inherited from Form.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | (Inherited from Control.)
Public property | TopLevel | (Inherited from Form.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | TopMost | (Inherited from Form.)
Public property | TransparencyKey | (Inherited from Form.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowState | (Inherited from Form.)
Public property | WindowTarget | (Inherited from Control.)

Events

 | Name | Description
Public event | Activated | (Inherited from Form.)
Public event | AutoSizeChanged | (Inherited from Form.)
Public event | AutoValidateChanged | (Inherited from Form.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | Closed | (Inherited from Form.)
Public event | Closing | (Inherited from Form.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Deactivate | (Inherited from Form.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | FormClosed | (Inherited from Form.)
Public event | FormClosing | (Inherited from Form.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpButtonClicked | (Inherited from Form.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | InputLanguageChanged | (Inherited from Form.)
Public event | InputLanguageChanging | (Inherited from Form.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from Form.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Form.)
Public event | MaximizedBoundsChanged | (Inherited from Form.)
Public event | MaximumSizeChanged | (Inherited from Form.)
Public event | MdiChildActivate | (Inherited from Form.)
Public event | MenuComplete | (Inherited from Form.)
Public event | MenuStart | (Inherited from Form.)
Public event | MinimumSizeChanged | (Inherited from Form.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | ResizeBegin | (Inherited from Form.)
Public event | ResizeEnd | (Inherited from Form.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | RightToLeftLayoutChanged | (Inherited from Form.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | Shown | (Inherited from Form.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Form.)
Public event | TabStopChanged | (Inherited from Form.)
Public event | TextChanged | (Inherited from Control.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

QuestCustomScriptUI Class
Quester.Profile.ProfilesCreator Namespace


QuestCustomScriptUI Constructor

Initializes a new instance of the QuestCustomScriptUI class.

Namespace: Quester.Profile.ProfilesCreator
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public QuestCustomScriptUI(
    ref EasyQuestProfile questProfile
)
Public Sub New ( _
    ByRef questProfile As EasyQuestProfile _
)
public:
QuestCustomScriptUI(
    EasyQuestProfile^% questProfile
)

Parameters

questProfile
Type: Quester.Profile..::..EasyQuestProfile %
The quest profile.

See Also

QuestCustomScriptUI Class
Quester.Profile.ProfilesCreator Namespace


QuestCustomScriptUI Methods

The QuestCustomScriptUI type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Public method | Activate | (Inherited from Form.)
Protected method | ActivateMdiChild(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | AddOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from Form.)
Protected method | ApplyAutoScaling | (Inherited from Form.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Protected method | CenterToParent | (Inherited from Form.)
Protected method | CenterToScreen | (Inherited from Form.)
Public method | Close | (Inherited from Form.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Form.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Clean up any resources being used.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Public method | LayoutMdi(System.Windows.Forms.MdiLayout) | (Inherited from Form.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnActivated(System.EventArgs) | (Inherited from Form.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnClosed(System.EventArgs) | (Inherited from Form.)
Protected method | OnClosing(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from Form.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDeactivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Form.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnFormClosed(System.Windows.Forms.FormClosedEventArgs) | (Inherited from Form.)
Protected method | OnFormClosing(System.Windows.Forms.FormClosingEventArgs) | (Inherited from Form.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Form.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Form.)
Protected method | OnHelpButtonClicked(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInputLanguageChanged(System.Windows.Forms.InputLanguageChangedEventArgs) | (Inherited from Form.)
Protected method | OnInputLanguageChanging(System.Windows.Forms.InputLanguageChangingEventArgs) | (Inherited from Form.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from Form.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from Form.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMaximumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMdiChildActivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuComplete(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuStart(System.EventArgs) | (Inherited from Form.)
Protected method | OnMinimumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Form.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeBegin(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeEnd(System.EventArgs) | (Inherited from Form.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnShown(System.EventArgs) | (Inherited from Form.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from Form.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from Form.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from Form.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | RemoveOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from Form.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from Form.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopLocation(System.Int32,System.Int32) | (Inherited from Form.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Form.)
Public method | Show(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Public method | Show | (Inherited from Control.)
Public method | ShowDialog | (Inherited from Form.)
Public method | ShowDialog(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Form.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from Form.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from Form.)

See Also

QuestCustomScriptUI Class
Quester.Profile.ProfilesCreator Namespace


Dispose Method

QuestCustomScriptUI..::..Dispose Method

Overload List

 | Name | Description
Protected method | Dispose(Boolean) | Clean up any resources being used.
Public method | Dispose | (Inherited from Component.)

See Also

QuestCustomScriptUI Class
QuestCustomScriptUI Members
Quester.Profile.ProfilesCreator Namespace


Dispose Method

QuestCustomScriptUI..::..Dispose Method

Clean up any resources being used.

Namespace: Quester.Profile.ProfilesCreator
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
protected void Dispose(
    bool disposing
)
Protected Sub Dispose ( _
    disposing As Boolean _
)
protected:
void Dispose(
    bool^ disposing
)

Parameters

disposing
Type: Boolean
true if managed resources should be disposed; otherwise, false.

See Also

QuestCustomScriptUI Class
Quester.Profile.ProfilesCreator Namespace


QuestCustomScriptUI Properties

The QuestCustomScriptUI type exposes the following members.

Properties

 | Name | Description
Public property | AcceptButton | (Inherited from Form.)
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | ActiveMdiChild | (Inherited from Form.)
Public property | AllowDrop | (Inherited from Control.)
Public property | AllowTransparency | (Inherited from Form.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScale | (Inherited from Form.)
Public property | AutoScaleBaseSize | (Inherited from Form.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from Form.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Form.)
Public property | AutoSizeMode | (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Public property | CancelButton | (Inherited from Form.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Form.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | ControlBox | (Inherited from Form.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Form.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DesktopBounds | (Inherited from Form.)
Public property | DesktopLocation | (Inherited from Form.)
Public property | DialogResult | (Inherited from Form.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | FormBorderStyle | (Inherited from Form.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HelpButton | (Inherited from Form.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | Icon | (Inherited from Form.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMdiChild | (Inherited from Form.)
Public property | IsMdiContainer | (Inherited from Form.)
Public property | IsMirrored | (Inherited from Control.)
Public property | IsRestrictedWindow | (Inherited from Form.)
Public property | KeyPreview | (Inherited from Form.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Form.)
Public property | MainMenuStrip | (Inherited from Form.)
Public property | Margin | (Inherited from Form.)
Public property | MaximizeBox | (Inherited from Form.)
Protected property | MaximizedBounds | (Inherited from Form.)
Public property | MaximumSize | (Inherited from Form.)
Public property | MdiChildren | (Inherited from Form.)
Public property | MdiParent | (Inherited from Form.)
Public property | Menu | (Inherited from Form.)
Public property | MergedMenu | (Inherited from Form.)
Public property | MinimizeBox | (Inherited from Form.)
Public property | MinimumSize | (Inherited from Form.)
Public property | Modal | (Inherited from Form.)
Public property | Name | (Inherited from Control.)
Public property | Opacity | (Inherited from Form.)
Public property | OwnedForms | (Inherited from Form.)
Public property | Owner | (Inherited from Form.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | RestoreBounds | (Inherited from Form.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Public property | RightToLeftLayout | (Inherited from Form.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | ShowIcon | (Inherited from Form.)
Public property | ShowInTaskbar | (Inherited from Form.)
Protected property | ShowWithoutActivation | (Inherited from Form.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Form.)
Public property | SizeGripStyle | (Inherited from Form.)
Public property | StartPosition | (Inherited from Form.)
Public property | TabIndex | (Inherited from Form.)
Public property | TabStop | (Inherited from Form.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | (Inherited from Control.)
Public property | TopLevel | (Inherited from Form.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | TopMost | (Inherited from Form.)
Public property | TransparencyKey | (Inherited from Form.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowState | (Inherited from Form.)
Public property | WindowTarget | (Inherited from Control.)

See Also

QuestCustomScriptUI Class
Quester.Profile.ProfilesCreator Namespace


QuestCustomScriptUI Events

The QuestCustomScriptUI type exposes the following members.

Events

 | Name | Description
Public event | Activated | (Inherited from Form.)
Public event | AutoSizeChanged | (Inherited from Form.)
Public event | AutoValidateChanged | (Inherited from Form.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | Closed | (Inherited from Form.)
Public event | Closing | (Inherited from Form.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Deactivate | (Inherited from Form.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | FormClosed | (Inherited from Form.)
Public event | FormClosing | (Inherited from Form.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpButtonClicked | (Inherited from Form.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | InputLanguageChanged | (Inherited from Form.)
Public event | InputLanguageChanging | (Inherited from Form.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from Form.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Form.)
Public event | MaximizedBoundsChanged | (Inherited from Form.)
Public event | MaximumSizeChanged | (Inherited from Form.)
Public event | MdiChildActivate | (Inherited from Form.)
Public event | MenuComplete | (Inherited from Form.)
Public event | MenuStart | (Inherited from Form.)
Public event | MinimumSizeChanged | (Inherited from Form.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | ResizeBegin | (Inherited from Form.)
Public event | ResizeEnd | (Inherited from Form.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | RightToLeftLayoutChanged | (Inherited from Form.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | Shown | (Inherited from Form.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Form.)
Public event | TabStopChanged | (Inherited from Form.)
Public event | TextChanged | (Inherited from Control.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

QuestCustomScriptUI Class
Quester.Profile.ProfilesCreator Namespace


QuestGiverUI Class

Class QuestGiverUI. Implements the Form

Namespace: Quester.Profile.ProfilesCreator
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public class QuestGiverUI : Form
Public Class QuestGiverUI _
    Inherits Form
public ref class QuestGiverUI : public Form

Inheritance Hierarchy

Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
Quester.Profile.ProfilesCreator..::..QuestGiverUI

See Also

QuestGiverUI Members
Quester.Profile.ProfilesCreator Namespace
Form


QuestGiverUI Members

The QuestGiverUI type exposes the following members.

Constructors

 | Name | Description
Public method | QuestGiverUI | Initializes a new instance of the QuestGiverUI class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Public method | Activate | (Inherited from Form.)
Protected method | ActivateMdiChild(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | AddOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from Form.)
Protected method | ApplyAutoScaling | (Inherited from Form.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Protected method | CenterToParent | (Inherited from Form.)
Protected method | CenterToScreen | (Inherited from Form.)
Public method | Close | (Inherited from Form.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Form.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Clean up any resources being used.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Public method | LayoutMdi(System.Windows.Forms.MdiLayout) | (Inherited from Form.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnActivated(System.EventArgs) | (Inherited from Form.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnClosed(System.EventArgs) | (Inherited from Form.)
Protected method | OnClosing(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from Form.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDeactivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Form.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnFormClosed(System.Windows.Forms.FormClosedEventArgs) | (Inherited from Form.)
Protected method | OnFormClosing(System.Windows.Forms.FormClosingEventArgs) | (Inherited from Form.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Form.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Form.)
Protected method | OnHelpButtonClicked(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInputLanguageChanged(System.Windows.Forms.InputLanguageChangedEventArgs) | (Inherited from Form.)
Protected method | OnInputLanguageChanging(System.Windows.Forms.InputLanguageChangingEventArgs) | (Inherited from Form.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from Form.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from Form.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMaximumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMdiChildActivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuComplete(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuStart(System.EventArgs) | (Inherited from Form.)
Protected method | OnMinimumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Form.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeBegin(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeEnd(System.EventArgs) | (Inherited from Form.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnShown(System.EventArgs) | (Inherited from Form.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from Form.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from Form.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from Form.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | RemoveOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from Form.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from Form.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopLocation(System.Int32,System.Int32) | (Inherited from Form.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Form.)
Public method | Show(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Public method | Show | (Inherited from Control.)
Public method | ShowDialog | (Inherited from Form.)
Public method | ShowDialog(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Form.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from Form.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from Form.)

Properties

 | Name | Description
Public property | AcceptButton | (Inherited from Form.)
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | ActiveMdiChild | (Inherited from Form.)
Public property | AllowDrop | (Inherited from Control.)
Public property | AllowTransparency | (Inherited from Form.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScale | (Inherited from Form.)
Public property | AutoScaleBaseSize | (Inherited from Form.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from Form.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Form.)
Public property | AutoSizeMode | (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Public property | CancelButton | (Inherited from Form.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Form.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | ControlBox | (Inherited from Form.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Form.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DesktopBounds | (Inherited from Form.)
Public property | DesktopLocation | (Inherited from Form.)
Public property | DialogResult | (Inherited from Form.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | FormBorderStyle | (Inherited from Form.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HelpButton | (Inherited from Form.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | Icon | (Inherited from Form.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMdiChild | (Inherited from Form.)
Public property | IsMdiContainer | (Inherited from Form.)
Public property | IsMirrored | (Inherited from Control.)
Public property | IsRestrictedWindow | (Inherited from Form.)
Public property | KeyPreview | (Inherited from Form.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Form.)
Public property | MainMenuStrip | (Inherited from Form.)
Public property | Margin | (Inherited from Form.)
Public property | MaximizeBox | (Inherited from Form.)
Protected property | MaximizedBounds | (Inherited from Form.)
Public property | MaximumSize | (Inherited from Form.)
Public property | MdiChildren | (Inherited from Form.)
Public property | MdiParent | (Inherited from Form.)
Public property | Menu | (Inherited from Form.)
Public property | MergedMenu | (Inherited from Form.)
Public property | MinimizeBox | (Inherited from Form.)
Public property | MinimumSize | (Inherited from Form.)
Public property | Modal | (Inherited from Form.)
Public property | Name | (Inherited from Control.)
Public property | Opacity | (Inherited from Form.)
Public property | OwnedForms | (Inherited from Form.)
Public property | Owner | (Inherited from Form.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | RestoreBounds | (Inherited from Form.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Public property | RightToLeftLayout | (Inherited from Form.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | ShowIcon | (Inherited from Form.)
Public property | ShowInTaskbar | (Inherited from Form.)
Protected property | ShowWithoutActivation | (Inherited from Form.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Form.)
Public property | SizeGripStyle | (Inherited from Form.)
Public property | StartPosition | (Inherited from Form.)
Public property | TabIndex | (Inherited from Form.)
Public property | TabStop | (Inherited from Form.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | (Inherited from Control.)
Public property | TopLevel | (Inherited from Form.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | TopMost | (Inherited from Form.)
Public property | TransparencyKey | (Inherited from Form.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowState | (Inherited from Form.)
Public property | WindowTarget | (Inherited from Control.)

Events

 | Name | Description
Public event | Activated | (Inherited from Form.)
Public event | AutoSizeChanged | (Inherited from Form.)
Public event | AutoValidateChanged | (Inherited from Form.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | Closed | (Inherited from Form.)
Public event | Closing | (Inherited from Form.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Deactivate | (Inherited from Form.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | FormClosed | (Inherited from Form.)
Public event | FormClosing | (Inherited from Form.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpButtonClicked | (Inherited from Form.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | InputLanguageChanged | (Inherited from Form.)
Public event | InputLanguageChanging | (Inherited from Form.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from Form.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Form.)
Public event | MaximizedBoundsChanged | (Inherited from Form.)
Public event | MaximumSizeChanged | (Inherited from Form.)
Public event | MdiChildActivate | (Inherited from Form.)
Public event | MenuComplete | (Inherited from Form.)
Public event | MenuStart | (Inherited from Form.)
Public event | MinimumSizeChanged | (Inherited from Form.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | ResizeBegin | (Inherited from Form.)
Public event | ResizeEnd | (Inherited from Form.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | RightToLeftLayoutChanged | (Inherited from Form.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | Shown | (Inherited from Form.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Form.)
Public event | TabStopChanged | (Inherited from Form.)
Public event | TextChanged | (Inherited from Control.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

QuestGiverUI Class
Quester.Profile.ProfilesCreator Namespace


QuestGiverUI Constructor

Initializes a new instance of the QuestGiverUI class.

Namespace: Quester.Profile.ProfilesCreator
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public QuestGiverUI(
    ref EasyQuestProfile questProfile
)
Public Sub New ( _
    ByRef questProfile As EasyQuestProfile _
)
public:
QuestGiverUI(
    EasyQuestProfile^% questProfile
)

Parameters

questProfile
Type: Quester.Profile..::..EasyQuestProfile %
The quest profile.

See Also

QuestGiverUI Class
Quester.Profile.ProfilesCreator Namespace


QuestGiverUI Methods

The QuestGiverUI type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Public method | Activate | (Inherited from Form.)
Protected method | ActivateMdiChild(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | AddOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from Form.)
Protected method | ApplyAutoScaling | (Inherited from Form.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Protected method | CenterToParent | (Inherited from Form.)
Protected method | CenterToScreen | (Inherited from Form.)
Public method | Close | (Inherited from Form.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Form.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Clean up any resources being used.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Public method | LayoutMdi(System.Windows.Forms.MdiLayout) | (Inherited from Form.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnActivated(System.EventArgs) | (Inherited from Form.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnClosed(System.EventArgs) | (Inherited from Form.)
Protected method | OnClosing(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from Form.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDeactivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Form.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnFormClosed(System.Windows.Forms.FormClosedEventArgs) | (Inherited from Form.)
Protected method | OnFormClosing(System.Windows.Forms.FormClosingEventArgs) | (Inherited from Form.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Form.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Form.)
Protected method | OnHelpButtonClicked(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInputLanguageChanged(System.Windows.Forms.InputLanguageChangedEventArgs) | (Inherited from Form.)
Protected method | OnInputLanguageChanging(System.Windows.Forms.InputLanguageChangingEventArgs) | (Inherited from Form.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from Form.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from Form.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMaximumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMdiChildActivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuComplete(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuStart(System.EventArgs) | (Inherited from Form.)
Protected method | OnMinimumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Form.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeBegin(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeEnd(System.EventArgs) | (Inherited from Form.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnShown(System.EventArgs) | (Inherited from Form.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from Form.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from Form.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from Form.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | RemoveOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from Form.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from Form.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopLocation(System.Int32,System.Int32) | (Inherited from Form.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Form.)
Public method | Show(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Public method | Show | (Inherited from Control.)
Public method | ShowDialog | (Inherited from Form.)
Public method | ShowDialog(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Form.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from Form.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from Form.)

See Also

QuestGiverUI Class
Quester.Profile.ProfilesCreator Namespace


Dispose Method

QuestGiverUI..::..Dispose Method

Overload List

 | Name | Description
Protected method | Dispose(Boolean) | Clean up any resources being used.
Public method | Dispose | (Inherited from Component.)

See Also

QuestGiverUI Class
QuestGiverUI Members
Quester.Profile.ProfilesCreator Namespace


Dispose Method

QuestGiverUI..::..Dispose Method

Clean up any resources being used.

Namespace: Quester.Profile.ProfilesCreator
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
protected void Dispose(
    bool disposing
)
Protected Sub Dispose ( _
    disposing As Boolean _
)
protected:
void Dispose(
    bool^ disposing
)

Parameters

disposing
Type: Boolean
true if managed resources should be disposed; otherwise, false.

See Also

QuestGiverUI Class
Quester.Profile.ProfilesCreator Namespace


QuestGiverUI Properties

The QuestGiverUI type exposes the following members.

Properties

 | Name | Description
Public property | AcceptButton | (Inherited from Form.)
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | ActiveMdiChild | (Inherited from Form.)
Public property | AllowDrop | (Inherited from Control.)
Public property | AllowTransparency | (Inherited from Form.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScale | (Inherited from Form.)
Public property | AutoScaleBaseSize | (Inherited from Form.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from Form.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Form.)
Public property | AutoSizeMode | (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Public property | CancelButton | (Inherited from Form.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Form.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | ControlBox | (Inherited from Form.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Form.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DesktopBounds | (Inherited from Form.)
Public property | DesktopLocation | (Inherited from Form.)
Public property | DialogResult | (Inherited from Form.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | FormBorderStyle | (Inherited from Form.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HelpButton | (Inherited from Form.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | Icon | (Inherited from Form.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMdiChild | (Inherited from Form.)
Public property | IsMdiContainer | (Inherited from Form.)
Public property | IsMirrored | (Inherited from Control.)
Public property | IsRestrictedWindow | (Inherited from Form.)
Public property | KeyPreview | (Inherited from Form.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Form.)
Public property | MainMenuStrip | (Inherited from Form.)
Public property | Margin | (Inherited from Form.)
Public property | MaximizeBox | (Inherited from Form.)
Protected property | MaximizedBounds | (Inherited from Form.)
Public property | MaximumSize | (Inherited from Form.)
Public property | MdiChildren | (Inherited from Form.)
Public property | MdiParent | (Inherited from Form.)
Public property | Menu | (Inherited from Form.)
Public property | MergedMenu | (Inherited from Form.)
Public property | MinimizeBox | (Inherited from Form.)
Public property | MinimumSize | (Inherited from Form.)
Public property | Modal | (Inherited from Form.)
Public property | Name | (Inherited from Control.)
Public property | Opacity | (Inherited from Form.)
Public property | OwnedForms | (Inherited from Form.)
Public property | Owner | (Inherited from Form.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | RestoreBounds | (Inherited from Form.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Public property | RightToLeftLayout | (Inherited from Form.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | ShowIcon | (Inherited from Form.)
Public property | ShowInTaskbar | (Inherited from Form.)
Protected property | ShowWithoutActivation | (Inherited from Form.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Form.)
Public property | SizeGripStyle | (Inherited from Form.)
Public property | StartPosition | (Inherited from Form.)
Public property | TabIndex | (Inherited from Form.)
Public property | TabStop | (Inherited from Form.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | (Inherited from Control.)
Public property | TopLevel | (Inherited from Form.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | TopMost | (Inherited from Form.)
Public property | TransparencyKey | (Inherited from Form.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowState | (Inherited from Form.)
Public property | WindowTarget | (Inherited from Control.)

See Also

QuestGiverUI Class
Quester.Profile.ProfilesCreator Namespace


QuestGiverUI Events

The QuestGiverUI type exposes the following members.

Events

 | Name | Description
Public event | Activated | (Inherited from Form.)
Public event | AutoSizeChanged | (Inherited from Form.)
Public event | AutoValidateChanged | (Inherited from Form.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | Closed | (Inherited from Form.)
Public event | Closing | (Inherited from Form.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Deactivate | (Inherited from Form.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | FormClosed | (Inherited from Form.)
Public event | FormClosing | (Inherited from Form.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpButtonClicked | (Inherited from Form.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | InputLanguageChanged | (Inherited from Form.)
Public event | InputLanguageChanging | (Inherited from Form.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from Form.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Form.)
Public event | MaximizedBoundsChanged | (Inherited from Form.)
Public event | MaximumSizeChanged | (Inherited from Form.)
Public event | MdiChildActivate | (Inherited from Form.)
Public event | MenuComplete | (Inherited from Form.)
Public event | MenuStart | (Inherited from Form.)
Public event | MinimumSizeChanged | (Inherited from Form.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | ResizeBegin | (Inherited from Form.)
Public event | ResizeEnd | (Inherited from Form.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | RightToLeftLayoutChanged | (Inherited from Form.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | Shown | (Inherited from Form.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Form.)
Public event | TabStopChanged | (Inherited from Form.)
Public event | TextChanged | (Inherited from Control.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

QuestGiverUI Class
Quester.Profile.ProfilesCreator Namespace


QuestOrderUI Class

Class QuestOrderUI. Implements the Form

Namespace: Quester.Profile.ProfilesCreator
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public class QuestOrderUI : Form
Public Class QuestOrderUI _
    Inherits Form
public ref class QuestOrderUI : public Form

Inheritance Hierarchy

Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
Quester.Profile.ProfilesCreator..::..QuestOrderUI

See Also

QuestOrderUI Members
Quester.Profile.ProfilesCreator Namespace
Form


QuestOrderUI Members

The QuestOrderUI type exposes the following members.

Constructors

 | Name | Description
Public method | QuestOrderUI | Initializes a new instance of the QuestOrderUI class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Public method | Activate | (Inherited from Form.)
Protected method | ActivateMdiChild(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | AddOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from Form.)
Protected method | ApplyAutoScaling | (Inherited from Form.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Protected method | CenterToParent | (Inherited from Form.)
Protected method | CenterToScreen | (Inherited from Form.)
Public method | Close | (Inherited from Form.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Form.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Clean up any resources being used.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Public method | LayoutMdi(System.Windows.Forms.MdiLayout) | (Inherited from Form.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnActivated(System.EventArgs) | (Inherited from Form.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnClosed(System.EventArgs) | (Inherited from Form.)
Protected method | OnClosing(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from Form.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDeactivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Form.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnFormClosed(System.Windows.Forms.FormClosedEventArgs) | (Inherited from Form.)
Protected method | OnFormClosing(System.Windows.Forms.FormClosingEventArgs) | (Inherited from Form.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Form.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Form.)
Protected method | OnHelpButtonClicked(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInputLanguageChanged(System.Windows.Forms.InputLanguageChangedEventArgs) | (Inherited from Form.)
Protected method | OnInputLanguageChanging(System.Windows.Forms.InputLanguageChangingEventArgs) | (Inherited from Form.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from Form.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from Form.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMaximumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMdiChildActivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuComplete(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuStart(System.EventArgs) | (Inherited from Form.)
Protected method | OnMinimumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Form.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeBegin(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeEnd(System.EventArgs) | (Inherited from Form.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnShown(System.EventArgs) | (Inherited from Form.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from Form.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from Form.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from Form.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | RemoveOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from Form.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from Form.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopLocation(System.Int32,System.Int32) | (Inherited from Form.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Form.)
Public method | Show(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Public method | Show | (Inherited from Control.)
Public method | ShowDialog | (Inherited from Form.)
Public method | ShowDialog(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Form.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from Form.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from Form.)

Properties

 | Name | Description
Public property | AcceptButton | (Inherited from Form.)
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | ActiveMdiChild | (Inherited from Form.)
Public property | AllowDrop | (Inherited from Control.)
Public property | AllowTransparency | (Inherited from Form.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScale | (Inherited from Form.)
Public property | AutoScaleBaseSize | (Inherited from Form.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from Form.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Form.)
Public property | AutoSizeMode | (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Public property | CancelButton | (Inherited from Form.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Form.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | ControlBox | (Inherited from Form.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Form.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DesktopBounds | (Inherited from Form.)
Public property | DesktopLocation | (Inherited from Form.)
Public property | DialogResult | (Inherited from Form.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | FormBorderStyle | (Inherited from Form.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HelpButton | (Inherited from Form.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | Icon | (Inherited from Form.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMdiChild | (Inherited from Form.)
Public property | IsMdiContainer | (Inherited from Form.)
Public property | IsMirrored | (Inherited from Control.)
Public property | IsRestrictedWindow | (Inherited from Form.)
Public property | KeyPreview | (Inherited from Form.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Form.)
Public property | MainMenuStrip | (Inherited from Form.)
Public property | Margin | (Inherited from Form.)
Public property | MaximizeBox | (Inherited from Form.)
Protected property | MaximizedBounds | (Inherited from Form.)
Public property | MaximumSize | (Inherited from Form.)
Public property | MdiChildren | (Inherited from Form.)
Public property | MdiParent | (Inherited from Form.)
Public property | Menu | (Inherited from Form.)
Public property | MergedMenu | (Inherited from Form.)
Public property | MinimizeBox | (Inherited from Form.)
Public property | MinimumSize | (Inherited from Form.)
Public property | Modal | (Inherited from Form.)
Public property | Name | (Inherited from Control.)
Public property | Opacity | (Inherited from Form.)
Public property | OwnedForms | (Inherited from Form.)
Public property | Owner | (Inherited from Form.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | RestoreBounds | (Inherited from Form.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Public property | RightToLeftLayout | (Inherited from Form.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | ShowIcon | (Inherited from Form.)
Public property | ShowInTaskbar | (Inherited from Form.)
Protected property | ShowWithoutActivation | (Inherited from Form.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Form.)
Public property | SizeGripStyle | (Inherited from Form.)
Public property | StartPosition | (Inherited from Form.)
Public property | TabIndex | (Inherited from Form.)
Public property | TabStop | (Inherited from Form.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | (Inherited from Control.)
Public property | TopLevel | (Inherited from Form.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | TopMost | (Inherited from Form.)
Public property | TransparencyKey | (Inherited from Form.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowState | (Inherited from Form.)
Public property | WindowTarget | (Inherited from Control.)

Events

 | Name | Description
Public event | Activated | (Inherited from Form.)
Public event | AutoSizeChanged | (Inherited from Form.)
Public event | AutoValidateChanged | (Inherited from Form.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | Closed | (Inherited from Form.)
Public event | Closing | (Inherited from Form.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Deactivate | (Inherited from Form.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | FormClosed | (Inherited from Form.)
Public event | FormClosing | (Inherited from Form.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpButtonClicked | (Inherited from Form.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | InputLanguageChanged | (Inherited from Form.)
Public event | InputLanguageChanging | (Inherited from Form.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from Form.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Form.)
Public event | MaximizedBoundsChanged | (Inherited from Form.)
Public event | MaximumSizeChanged | (Inherited from Form.)
Public event | MdiChildActivate | (Inherited from Form.)
Public event | MenuComplete | (Inherited from Form.)
Public event | MenuStart | (Inherited from Form.)
Public event | MinimumSizeChanged | (Inherited from Form.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | ResizeBegin | (Inherited from Form.)
Public event | ResizeEnd | (Inherited from Form.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | RightToLeftLayoutChanged | (Inherited from Form.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | Shown | (Inherited from Form.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Form.)
Public event | TabStopChanged | (Inherited from Form.)
Public event | TextChanged | (Inherited from Control.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

QuestOrderUI Class
Quester.Profile.ProfilesCreator Namespace


QuestOrderUI Constructor

Initializes a new instance of the QuestOrderUI class.

Namespace: Quester.Profile.ProfilesCreator
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public QuestOrderUI(
    ref EasyQuestProfile questProfile
)
Public Sub New ( _
    ByRef questProfile As EasyQuestProfile _
)
public:
QuestOrderUI(
    EasyQuestProfile^% questProfile
)

Parameters

questProfile
Type: Quester.Profile..::..EasyQuestProfile %
The quest profile.

See Also

QuestOrderUI Class
Quester.Profile.ProfilesCreator Namespace


QuestOrderUI Methods

The QuestOrderUI type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Public method | Activate | (Inherited from Form.)
Protected method | ActivateMdiChild(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | AddOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from Form.)
Protected method | ApplyAutoScaling | (Inherited from Form.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Protected method | CenterToParent | (Inherited from Form.)
Protected method | CenterToScreen | (Inherited from Form.)
Public method | Close | (Inherited from Form.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Form.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Clean up any resources being used.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Public method | LayoutMdi(System.Windows.Forms.MdiLayout) | (Inherited from Form.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnActivated(System.EventArgs) | (Inherited from Form.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnClosed(System.EventArgs) | (Inherited from Form.)
Protected method | OnClosing(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from Form.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDeactivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Form.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnFormClosed(System.Windows.Forms.FormClosedEventArgs) | (Inherited from Form.)
Protected method | OnFormClosing(System.Windows.Forms.FormClosingEventArgs) | (Inherited from Form.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Form.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Form.)
Protected method | OnHelpButtonClicked(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInputLanguageChanged(System.Windows.Forms.InputLanguageChangedEventArgs) | (Inherited from Form.)
Protected method | OnInputLanguageChanging(System.Windows.Forms.InputLanguageChangingEventArgs) | (Inherited from Form.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from Form.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from Form.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMaximumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMdiChildActivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuComplete(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuStart(System.EventArgs) | (Inherited from Form.)
Protected method | OnMinimumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Form.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeBegin(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeEnd(System.EventArgs) | (Inherited from Form.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnShown(System.EventArgs) | (Inherited from Form.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from Form.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from Form.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from Form.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | RemoveOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from Form.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from Form.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopLocation(System.Int32,System.Int32) | (Inherited from Form.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Form.)
Public method | Show(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Public method | Show | (Inherited from Control.)
Public method | ShowDialog | (Inherited from Form.)
Public method | ShowDialog(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Form.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from Form.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from Form.)

See Also

QuestOrderUI Class
Quester.Profile.ProfilesCreator Namespace


Dispose Method

QuestOrderUI..::..Dispose Method

Overload List

 | Name | Description
Protected method | Dispose(Boolean) | Clean up any resources being used.
Public method | Dispose | (Inherited from Component.)

See Also

QuestOrderUI Class
QuestOrderUI Members
Quester.Profile.ProfilesCreator Namespace


Dispose Method

QuestOrderUI..::..Dispose Method

Clean up any resources being used.

Namespace: Quester.Profile.ProfilesCreator
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
protected void Dispose(
    bool disposing
)
Protected Sub Dispose ( _
    disposing As Boolean _
)
protected:
void Dispose(
    bool^ disposing
)

Parameters

disposing
Type: Boolean
true if managed resources should be disposed; otherwise, false.

See Also

QuestOrderUI Class
Quester.Profile.ProfilesCreator Namespace


QuestOrderUI Properties

The QuestOrderUI type exposes the following members.

Properties

 | Name | Description
Public property | AcceptButton | (Inherited from Form.)
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | ActiveMdiChild | (Inherited from Form.)
Public property | AllowDrop | (Inherited from Control.)
Public property | AllowTransparency | (Inherited from Form.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScale | (Inherited from Form.)
Public property | AutoScaleBaseSize | (Inherited from Form.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from Form.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Form.)
Public property | AutoSizeMode | (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Public property | CancelButton | (Inherited from Form.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Form.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | ControlBox | (Inherited from Form.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Form.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DesktopBounds | (Inherited from Form.)
Public property | DesktopLocation | (Inherited from Form.)
Public property | DialogResult | (Inherited from Form.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | FormBorderStyle | (Inherited from Form.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HelpButton | (Inherited from Form.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | Icon | (Inherited from Form.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMdiChild | (Inherited from Form.)
Public property | IsMdiContainer | (Inherited from Form.)
Public property | IsMirrored | (Inherited from Control.)
Public property | IsRestrictedWindow | (Inherited from Form.)
Public property | KeyPreview | (Inherited from Form.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Form.)
Public property | MainMenuStrip | (Inherited from Form.)
Public property | Margin | (Inherited from Form.)
Public property | MaximizeBox | (Inherited from Form.)
Protected property | MaximizedBounds | (Inherited from Form.)
Public property | MaximumSize | (Inherited from Form.)
Public property | MdiChildren | (Inherited from Form.)
Public property | MdiParent | (Inherited from Form.)
Public property | Menu | (Inherited from Form.)
Public property | MergedMenu | (Inherited from Form.)
Public property | MinimizeBox | (Inherited from Form.)
Public property | MinimumSize | (Inherited from Form.)
Public property | Modal | (Inherited from Form.)
Public property | Name | (Inherited from Control.)
Public property | Opacity | (Inherited from Form.)
Public property | OwnedForms | (Inherited from Form.)
Public property | Owner | (Inherited from Form.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | RestoreBounds | (Inherited from Form.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Public property | RightToLeftLayout | (Inherited from Form.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | ShowIcon | (Inherited from Form.)
Public property | ShowInTaskbar | (Inherited from Form.)
Protected property | ShowWithoutActivation | (Inherited from Form.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Form.)
Public property | SizeGripStyle | (Inherited from Form.)
Public property | StartPosition | (Inherited from Form.)
Public property | TabIndex | (Inherited from Form.)
Public property | TabStop | (Inherited from Form.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | (Inherited from Control.)
Public property | TopLevel | (Inherited from Form.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | TopMost | (Inherited from Form.)
Public property | TransparencyKey | (Inherited from Form.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowState | (Inherited from Form.)
Public property | WindowTarget | (Inherited from Control.)

See Also

QuestOrderUI Class
Quester.Profile.ProfilesCreator Namespace


QuestOrderUI Events

The QuestOrderUI type exposes the following members.

Events

 | Name | Description
Public event | Activated | (Inherited from Form.)
Public event | AutoSizeChanged | (Inherited from Form.)
Public event | AutoValidateChanged | (Inherited from Form.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | Closed | (Inherited from Form.)
Public event | Closing | (Inherited from Form.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Deactivate | (Inherited from Form.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | FormClosed | (Inherited from Form.)
Public event | FormClosing | (Inherited from Form.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpButtonClicked | (Inherited from Form.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | InputLanguageChanged | (Inherited from Form.)
Public event | InputLanguageChanging | (Inherited from Form.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from Form.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Form.)
Public event | MaximizedBoundsChanged | (Inherited from Form.)
Public event | MaximumSizeChanged | (Inherited from Form.)
Public event | MdiChildActivate | (Inherited from Form.)
Public event | MenuComplete | (Inherited from Form.)
Public event | MenuStart | (Inherited from Form.)
Public event | MinimumSizeChanged | (Inherited from Form.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | ResizeBegin | (Inherited from Form.)
Public event | ResizeEnd | (Inherited from Form.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | RightToLeftLayoutChanged | (Inherited from Form.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | Shown | (Inherited from Form.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Form.)
Public event | TabStopChanged | (Inherited from Form.)
Public event | TextChanged | (Inherited from Control.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

QuestOrderUI Class
Quester.Profile.ProfilesCreator Namespace


QuestTools Class

Class QuestTools. Implements the Form

Namespace: Quester.Profile.ProfilesCreator
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public class QuestTools : Form
Public Class QuestTools _
    Inherits Form
public ref class QuestTools : public Form

Inheritance Hierarchy

Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
Quester.Profile.ProfilesCreator..::..QuestTools

See Also

QuestTools Members
Quester.Profile.ProfilesCreator Namespace
Form


QuestTools Members

The QuestTools type exposes the following members.

Constructors

 | Name | Description
Public method | QuestTools | Initializes a new instance of the QuestTools class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Public method | Activate | (Inherited from Form.)
Protected method | ActivateMdiChild(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | AddOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from Form.)
Protected method | ApplyAutoScaling | (Inherited from Form.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Protected method | CenterToParent | (Inherited from Form.)
Protected method | CenterToScreen | (Inherited from Form.)
Public method | Close | (Inherited from Form.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Form.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Clean up any resources being used.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Public method | LayoutMdi(System.Windows.Forms.MdiLayout) | (Inherited from Form.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnActivated(System.EventArgs) | (Inherited from Form.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnClosed(System.EventArgs) | (Inherited from Form.)
Protected method | OnClosing(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from Form.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDeactivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Form.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnFormClosed(System.Windows.Forms.FormClosedEventArgs) | (Inherited from Form.)
Protected method | OnFormClosing(System.Windows.Forms.FormClosingEventArgs) | (Inherited from Form.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Form.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Form.)
Protected method | OnHelpButtonClicked(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInputLanguageChanged(System.Windows.Forms.InputLanguageChangedEventArgs) | (Inherited from Form.)
Protected method | OnInputLanguageChanging(System.Windows.Forms.InputLanguageChangingEventArgs) | (Inherited from Form.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from Form.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from Form.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMaximumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMdiChildActivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuComplete(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuStart(System.EventArgs) | (Inherited from Form.)
Protected method | OnMinimumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Form.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeBegin(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeEnd(System.EventArgs) | (Inherited from Form.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnShown(System.EventArgs) | (Inherited from Form.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from Form.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from Form.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from Form.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | RemoveOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from Form.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from Form.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopLocation(System.Int32,System.Int32) | (Inherited from Form.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Form.)
Public method | Show(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Public method | Show | (Inherited from Control.)
Public method | ShowDialog | (Inherited from Form.)
Public method | ShowDialog(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Form.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from Form.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from Form.)

Properties

 | Name | Description
Public property | AcceptButton | (Inherited from Form.)
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | ActiveMdiChild | (Inherited from Form.)
Public property | AllowDrop | (Inherited from Control.)
Public property | AllowTransparency | (Inherited from Form.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScale | (Inherited from Form.)
Public property | AutoScaleBaseSize | (Inherited from Form.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from Form.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Form.)
Public property | AutoSizeMode | (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Public property | CancelButton | (Inherited from Form.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Form.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | ControlBox | (Inherited from Form.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Form.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DesktopBounds | (Inherited from Form.)
Public property | DesktopLocation | (Inherited from Form.)
Public property | DialogResult | (Inherited from Form.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | FormBorderStyle | (Inherited from Form.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HelpButton | (Inherited from Form.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | Icon | (Inherited from Form.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMdiChild | (Inherited from Form.)
Public property | IsMdiContainer | (Inherited from Form.)
Public property | IsMirrored | (Inherited from Control.)
Public property | IsRestrictedWindow | (Inherited from Form.)
Public property | KeyPreview | (Inherited from Form.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Form.)
Public property | MainMenuStrip | (Inherited from Form.)
Public property | Margin | (Inherited from Form.)
Public property | MaximizeBox | (Inherited from Form.)
Protected property | MaximizedBounds | (Inherited from Form.)
Public property | MaximumSize | (Inherited from Form.)
Public property | MdiChildren | (Inherited from Form.)
Public property | MdiParent | (Inherited from Form.)
Public property | Menu | (Inherited from Form.)
Public property | MergedMenu | (Inherited from Form.)
Public property | MinimizeBox | (Inherited from Form.)
Public property | MinimumSize | (Inherited from Form.)
Public property | Modal | (Inherited from Form.)
Public property | Name | (Inherited from Control.)
Public property | Opacity | (Inherited from Form.)
Public property | OwnedForms | (Inherited from Form.)
Public property | Owner | (Inherited from Form.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | RestoreBounds | (Inherited from Form.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Public property | RightToLeftLayout | (Inherited from Form.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | ShowIcon | (Inherited from Form.)
Public property | ShowInTaskbar | (Inherited from Form.)
Protected property | ShowWithoutActivation | (Inherited from Form.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Form.)
Public property | SizeGripStyle | (Inherited from Form.)
Public property | StartPosition | (Inherited from Form.)
Public property | TabIndex | (Inherited from Form.)
Public property | TabStop | (Inherited from Form.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | (Inherited from Control.)
Public property | TopLevel | (Inherited from Form.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | TopMost | (Inherited from Form.)
Public property | TransparencyKey | (Inherited from Form.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowState | (Inherited from Form.)
Public property | WindowTarget | (Inherited from Control.)

Events

 | Name | Description
Public event | Activated | (Inherited from Form.)
Public event | AutoSizeChanged | (Inherited from Form.)
Public event | AutoValidateChanged | (Inherited from Form.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | Closed | (Inherited from Form.)
Public event | Closing | (Inherited from Form.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Deactivate | (Inherited from Form.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | FormClosed | (Inherited from Form.)
Public event | FormClosing | (Inherited from Form.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpButtonClicked | (Inherited from Form.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | InputLanguageChanged | (Inherited from Form.)
Public event | InputLanguageChanging | (Inherited from Form.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from Form.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Form.)
Public event | MaximizedBoundsChanged | (Inherited from Form.)
Public event | MaximumSizeChanged | (Inherited from Form.)
Public event | MdiChildActivate | (Inherited from Form.)
Public event | MenuComplete | (Inherited from Form.)
Public event | MenuStart | (Inherited from Form.)
Public event | MinimumSizeChanged | (Inherited from Form.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | ResizeBegin | (Inherited from Form.)
Public event | ResizeEnd | (Inherited from Form.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | RightToLeftLayoutChanged | (Inherited from Form.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | Shown | (Inherited from Form.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Form.)
Public event | TabStopChanged | (Inherited from Form.)
Public event | TextChanged | (Inherited from Control.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

QuestTools Class
Quester.Profile.ProfilesCreator Namespace


QuestTools Constructor

Initializes a new instance of the QuestTools class.

Namespace: Quester.Profile.ProfilesCreator
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public QuestTools()
Public Sub New
public:
QuestTools()

See Also

QuestTools Class
Quester.Profile.ProfilesCreator Namespace


QuestTools Methods

The QuestTools type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Public method | Activate | (Inherited from Form.)
Protected method | ActivateMdiChild(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | AddOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from Form.)
Protected method | ApplyAutoScaling | (Inherited from Form.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Protected method | CenterToParent | (Inherited from Form.)
Protected method | CenterToScreen | (Inherited from Form.)
Public method | Close | (Inherited from Form.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Form.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Clean up any resources being used.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Public method | LayoutMdi(System.Windows.Forms.MdiLayout) | (Inherited from Form.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnActivated(System.EventArgs) | (Inherited from Form.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnClosed(System.EventArgs) | (Inherited from Form.)
Protected method | OnClosing(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from Form.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDeactivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Form.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnFormClosed(System.Windows.Forms.FormClosedEventArgs) | (Inherited from Form.)
Protected method | OnFormClosing(System.Windows.Forms.FormClosingEventArgs) | (Inherited from Form.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Form.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Form.)
Protected method | OnHelpButtonClicked(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInputLanguageChanged(System.Windows.Forms.InputLanguageChangedEventArgs) | (Inherited from Form.)
Protected method | OnInputLanguageChanging(System.Windows.Forms.InputLanguageChangingEventArgs) | (Inherited from Form.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from Form.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from Form.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMaximumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMdiChildActivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuComplete(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuStart(System.EventArgs) | (Inherited from Form.)
Protected method | OnMinimumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Form.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeBegin(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeEnd(System.EventArgs) | (Inherited from Form.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnShown(System.EventArgs) | (Inherited from Form.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from Form.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from Form.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from Form.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | RemoveOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from Form.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from Form.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopLocation(System.Int32,System.Int32) | (Inherited from Form.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Form.)
Public method | Show(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Public method | Show | (Inherited from Control.)
Public method | ShowDialog | (Inherited from Form.)
Public method | ShowDialog(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Form.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from Form.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from Form.)

See Also

QuestTools Class
Quester.Profile.ProfilesCreator Namespace


Dispose Method

QuestTools..::..Dispose Method

Overload List

 | Name | Description
Protected method | Dispose(Boolean) | Clean up any resources being used.
Public method | Dispose | (Inherited from Component.)

See Also

QuestTools Class
QuestTools Members
Quester.Profile.ProfilesCreator Namespace


Dispose Method

QuestTools..::..Dispose Method

Clean up any resources being used.

Namespace: Quester.Profile.ProfilesCreator
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
protected void Dispose(
    bool disposing
)
Protected Sub Dispose ( _
    disposing As Boolean _
)
protected:
void Dispose(
    bool^ disposing
)

Parameters

disposing
Type: Boolean
true if managed resources should be disposed; otherwise, false.

See Also

QuestTools Class
Quester.Profile.ProfilesCreator Namespace


QuestTools Properties

The QuestTools type exposes the following members.

Properties

 | Name | Description
Public property | AcceptButton | (Inherited from Form.)
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | ActiveMdiChild | (Inherited from Form.)
Public property | AllowDrop | (Inherited from Control.)
Public property | AllowTransparency | (Inherited from Form.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScale | (Inherited from Form.)
Public property | AutoScaleBaseSize | (Inherited from Form.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from Form.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Form.)
Public property | AutoSizeMode | (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Public property | CancelButton | (Inherited from Form.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Form.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | ControlBox | (Inherited from Form.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Form.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DesktopBounds | (Inherited from Form.)
Public property | DesktopLocation | (Inherited from Form.)
Public property | DialogResult | (Inherited from Form.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | FormBorderStyle | (Inherited from Form.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HelpButton | (Inherited from Form.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | Icon | (Inherited from Form.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMdiChild | (Inherited from Form.)
Public property | IsMdiContainer | (Inherited from Form.)
Public property | IsMirrored | (Inherited from Control.)
Public property | IsRestrictedWindow | (Inherited from Form.)
Public property | KeyPreview | (Inherited from Form.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Form.)
Public property | MainMenuStrip | (Inherited from Form.)
Public property | Margin | (Inherited from Form.)
Public property | MaximizeBox | (Inherited from Form.)
Protected property | MaximizedBounds | (Inherited from Form.)
Public property | MaximumSize | (Inherited from Form.)
Public property | MdiChildren | (Inherited from Form.)
Public property | MdiParent | (Inherited from Form.)
Public property | Menu | (Inherited from Form.)
Public property | MergedMenu | (Inherited from Form.)
Public property | MinimizeBox | (Inherited from Form.)
Public property | MinimumSize | (Inherited from Form.)
Public property | Modal | (Inherited from Form.)
Public property | Name | (Inherited from Control.)
Public property | Opacity | (Inherited from Form.)
Public property | OwnedForms | (Inherited from Form.)
Public property | Owner | (Inherited from Form.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | RestoreBounds | (Inherited from Form.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Public property | RightToLeftLayout | (Inherited from Form.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | ShowIcon | (Inherited from Form.)
Public property | ShowInTaskbar | (Inherited from Form.)
Protected property | ShowWithoutActivation | (Inherited from Form.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Form.)
Public property | SizeGripStyle | (Inherited from Form.)
Public property | StartPosition | (Inherited from Form.)
Public property | TabIndex | (Inherited from Form.)
Public property | TabStop | (Inherited from Form.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | (Inherited from Control.)
Public property | TopLevel | (Inherited from Form.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | TopMost | (Inherited from Form.)
Public property | TransparencyKey | (Inherited from Form.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowState | (Inherited from Form.)
Public property | WindowTarget | (Inherited from Control.)

See Also

QuestTools Class
Quester.Profile.ProfilesCreator Namespace


QuestTools Events

The QuestTools type exposes the following members.

Events

 | Name | Description
Public event | Activated | (Inherited from Form.)
Public event | AutoSizeChanged | (Inherited from Form.)
Public event | AutoValidateChanged | (Inherited from Form.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | Closed | (Inherited from Form.)
Public event | Closing | (Inherited from Form.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Deactivate | (Inherited from Form.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | FormClosed | (Inherited from Form.)
Public event | FormClosing | (Inherited from Form.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpButtonClicked | (Inherited from Form.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | InputLanguageChanged | (Inherited from Form.)
Public event | InputLanguageChanging | (Inherited from Form.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from Form.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Form.)
Public event | MaximizedBoundsChanged | (Inherited from Form.)
Public event | MaximumSizeChanged | (Inherited from Form.)
Public event | MdiChildActivate | (Inherited from Form.)
Public event | MenuComplete | (Inherited from Form.)
Public event | MenuStart | (Inherited from Form.)
Public event | MinimumSizeChanged | (Inherited from Form.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | ResizeBegin | (Inherited from Form.)
Public event | ResizeEnd | (Inherited from Form.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | RightToLeftLayoutChanged | (Inherited from Form.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | Shown | (Inherited from Form.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Form.)
Public event | TabStopChanged | (Inherited from Form.)
Public event | TextChanged | (Inherited from Control.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

QuestTools Class
Quester.Profile.ProfilesCreator Namespace


QuestUI Class

Class QuestUI. Implements the Form

Namespace: Quester.Profile.ProfilesCreator
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public class QuestUI : Form
Public Class QuestUI _
    Inherits Form
public ref class QuestUI : public Form

Inheritance Hierarchy

Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
Quester.Profile.ProfilesCreator..::..QuestUI

See Also

QuestUI Members
Quester.Profile.ProfilesCreator Namespace
Form


QuestUI Members

The QuestUI type exposes the following members.

Constructors

 | Name | Description
Public method | QuestUI | Initializes a new instance of the QuestUI class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Public method | Activate | (Inherited from Form.)
Protected method | ActivateMdiChild(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | AddOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from Form.)
Protected method | ApplyAutoScaling | (Inherited from Form.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Protected method | CenterToParent | (Inherited from Form.)
Protected method | CenterToScreen | (Inherited from Form.)
Public method | Close | (Inherited from Form.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Form.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Clean up any resources being used.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Public method | LayoutMdi(System.Windows.Forms.MdiLayout) | (Inherited from Form.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnActivated(System.EventArgs) | (Inherited from Form.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnClosed(System.EventArgs) | (Inherited from Form.)
Protected method | OnClosing(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from Form.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDeactivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Form.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnFormClosed(System.Windows.Forms.FormClosedEventArgs) | (Inherited from Form.)
Protected method | OnFormClosing(System.Windows.Forms.FormClosingEventArgs) | (Inherited from Form.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Form.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Form.)
Protected method | OnHelpButtonClicked(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInputLanguageChanged(System.Windows.Forms.InputLanguageChangedEventArgs) | (Inherited from Form.)
Protected method | OnInputLanguageChanging(System.Windows.Forms.InputLanguageChangingEventArgs) | (Inherited from Form.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from Form.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from Form.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMaximumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMdiChildActivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuComplete(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuStart(System.EventArgs) | (Inherited from Form.)
Protected method | OnMinimumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Form.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeBegin(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeEnd(System.EventArgs) | (Inherited from Form.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnShown(System.EventArgs) | (Inherited from Form.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from Form.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from Form.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from Form.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | RemoveOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from Form.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from Form.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopLocation(System.Int32,System.Int32) | (Inherited from Form.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Form.)
Public method | Show(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Public method | Show | (Inherited from Control.)
Public method | ShowDialog | (Inherited from Form.)
Public method | ShowDialog(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Form.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from Form.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from Form.)

Properties

 | Name | Description
Public property | AcceptButton | (Inherited from Form.)
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | ActiveMdiChild | (Inherited from Form.)
Public property | AllowDrop | (Inherited from Control.)
Public property | AllowTransparency | (Inherited from Form.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScale | (Inherited from Form.)
Public property | AutoScaleBaseSize | (Inherited from Form.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from Form.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Form.)
Public property | AutoSizeMode | (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Public property | CancelButton | (Inherited from Form.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Form.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | ControlBox | (Inherited from Form.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Form.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DesktopBounds | (Inherited from Form.)
Public property | DesktopLocation | (Inherited from Form.)
Public property | DialogResult | (Inherited from Form.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | FormBorderStyle | (Inherited from Form.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HelpButton | (Inherited from Form.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | Icon | (Inherited from Form.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMdiChild | (Inherited from Form.)
Public property | IsMdiContainer | (Inherited from Form.)
Public property | IsMirrored | (Inherited from Control.)
Public property | IsRestrictedWindow | (Inherited from Form.)
Public property | KeyPreview | (Inherited from Form.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Form.)
Public property | MainMenuStrip | (Inherited from Form.)
Public property | Margin | (Inherited from Form.)
Public property | MaximizeBox | (Inherited from Form.)
Protected property | MaximizedBounds | (Inherited from Form.)
Public property | MaximumSize | (Inherited from Form.)
Public property | MdiChildren | (Inherited from Form.)
Public property | MdiParent | (Inherited from Form.)
Public property | Menu | (Inherited from Form.)
Public property | MergedMenu | (Inherited from Form.)
Public property | MinimizeBox | (Inherited from Form.)
Public property | MinimumSize | (Inherited from Form.)
Public property | Modal | (Inherited from Form.)
Public property | Name | (Inherited from Control.)
Public property | Opacity | (Inherited from Form.)
Public property | OwnedForms | (Inherited from Form.)
Public property | Owner | (Inherited from Form.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | RestoreBounds | (Inherited from Form.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Public property | RightToLeftLayout | (Inherited from Form.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | ShowIcon | (Inherited from Form.)
Public property | ShowInTaskbar | (Inherited from Form.)
Protected property | ShowWithoutActivation | (Inherited from Form.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Form.)
Public property | SizeGripStyle | (Inherited from Form.)
Public property | StartPosition | (Inherited from Form.)
Public property | TabIndex | (Inherited from Form.)
Public property | TabStop | (Inherited from Form.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | (Inherited from Control.)
Public property | TopLevel | (Inherited from Form.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | TopMost | (Inherited from Form.)
Public property | TransparencyKey | (Inherited from Form.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowState | (Inherited from Form.)
Public property | WindowTarget | (Inherited from Control.)

Events

 | Name | Description
Public event | Activated | (Inherited from Form.)
Public event | AutoSizeChanged | (Inherited from Form.)
Public event | AutoValidateChanged | (Inherited from Form.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | Closed | (Inherited from Form.)
Public event | Closing | (Inherited from Form.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Deactivate | (Inherited from Form.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | FormClosed | (Inherited from Form.)
Public event | FormClosing | (Inherited from Form.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpButtonClicked | (Inherited from Form.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | InputLanguageChanged | (Inherited from Form.)
Public event | InputLanguageChanging | (Inherited from Form.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from Form.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Form.)
Public event | MaximizedBoundsChanged | (Inherited from Form.)
Public event | MaximumSizeChanged | (Inherited from Form.)
Public event | MdiChildActivate | (Inherited from Form.)
Public event | MenuComplete | (Inherited from Form.)
Public event | MenuStart | (Inherited from Form.)
Public event | MinimumSizeChanged | (Inherited from Form.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | ResizeBegin | (Inherited from Form.)
Public event | ResizeEnd | (Inherited from Form.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | RightToLeftLayoutChanged | (Inherited from Form.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | Shown | (Inherited from Form.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Form.)
Public event | TabStopChanged | (Inherited from Form.)
Public event | TextChanged | (Inherited from Control.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

QuestUI Class
Quester.Profile.ProfilesCreator Namespace


QuestUI Constructor

Initializes a new instance of the QuestUI class.

Namespace: Quester.Profile.ProfilesCreator
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public QuestUI(
    ref EasyQuestProfile questProfile
)
Public Sub New ( _
    ByRef questProfile As EasyQuestProfile _
)
public:
QuestUI(
    EasyQuestProfile^% questProfile
)

Parameters

questProfile
Type: Quester.Profile..::..EasyQuestProfile %
The quest profile.

See Also

QuestUI Class
Quester.Profile.ProfilesCreator Namespace


QuestUI Methods

The QuestUI type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Public method | Activate | (Inherited from Form.)
Protected method | ActivateMdiChild(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | AddOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from Form.)
Protected method | ApplyAutoScaling | (Inherited from Form.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Protected method | CenterToParent | (Inherited from Form.)
Protected method | CenterToScreen | (Inherited from Form.)
Public method | Close | (Inherited from Form.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Form.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Clean up any resources being used.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Public method | LayoutMdi(System.Windows.Forms.MdiLayout) | (Inherited from Form.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnActivated(System.EventArgs) | (Inherited from Form.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnClosed(System.EventArgs) | (Inherited from Form.)
Protected method | OnClosing(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from Form.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDeactivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Form.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnFormClosed(System.Windows.Forms.FormClosedEventArgs) | (Inherited from Form.)
Protected method | OnFormClosing(System.Windows.Forms.FormClosingEventArgs) | (Inherited from Form.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Form.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Form.)
Protected method | OnHelpButtonClicked(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInputLanguageChanged(System.Windows.Forms.InputLanguageChangedEventArgs) | (Inherited from Form.)
Protected method | OnInputLanguageChanging(System.Windows.Forms.InputLanguageChangingEventArgs) | (Inherited from Form.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from Form.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from Form.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMaximumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMdiChildActivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuComplete(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuStart(System.EventArgs) | (Inherited from Form.)
Protected method | OnMinimumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Form.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeBegin(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeEnd(System.EventArgs) | (Inherited from Form.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnShown(System.EventArgs) | (Inherited from Form.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from Form.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from Form.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from Form.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | RemoveOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from Form.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from Form.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopLocation(System.Int32,System.Int32) | (Inherited from Form.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Form.)
Public method | Show(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Public method | Show | (Inherited from Control.)
Public method | ShowDialog | (Inherited from Form.)
Public method | ShowDialog(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Form.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from Form.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from Form.)

See Also

QuestUI Class
Quester.Profile.ProfilesCreator Namespace


Dispose Method

QuestUI..::..Dispose Method

Overload List

 | Name | Description
Protected method | Dispose(Boolean) | Clean up any resources being used.
Public method | Dispose | (Inherited from Component.)

See Also

QuestUI Class
QuestUI Members
Quester.Profile.ProfilesCreator Namespace


Dispose Method

QuestUI..::..Dispose Method

Clean up any resources being used.

Namespace: Quester.Profile.ProfilesCreator
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
protected void Dispose(
    bool disposing
)
Protected Sub Dispose ( _
    disposing As Boolean _
)
protected:
void Dispose(
    bool^ disposing
)

Parameters

disposing
Type: Boolean
true if managed resources should be disposed; otherwise, false.

See Also

QuestUI Class
Quester.Profile.ProfilesCreator Namespace


QuestUI Properties

The QuestUI type exposes the following members.

Properties

 | Name | Description
Public property | AcceptButton | (Inherited from Form.)
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | ActiveMdiChild | (Inherited from Form.)
Public property | AllowDrop | (Inherited from Control.)
Public property | AllowTransparency | (Inherited from Form.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScale | (Inherited from Form.)
Public property | AutoScaleBaseSize | (Inherited from Form.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from Form.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Form.)
Public property | AutoSizeMode | (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Public property | CancelButton | (Inherited from Form.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Form.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | ControlBox | (Inherited from Form.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Form.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DesktopBounds | (Inherited from Form.)
Public property | DesktopLocation | (Inherited from Form.)
Public property | DialogResult | (Inherited from Form.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | FormBorderStyle | (Inherited from Form.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HelpButton | (Inherited from Form.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | Icon | (Inherited from Form.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMdiChild | (Inherited from Form.)
Public property | IsMdiContainer | (Inherited from Form.)
Public property | IsMirrored | (Inherited from Control.)
Public property | IsRestrictedWindow | (Inherited from Form.)
Public property | KeyPreview | (Inherited from Form.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Form.)
Public property | MainMenuStrip | (Inherited from Form.)
Public property | Margin | (Inherited from Form.)
Public property | MaximizeBox | (Inherited from Form.)
Protected property | MaximizedBounds | (Inherited from Form.)
Public property | MaximumSize | (Inherited from Form.)
Public property | MdiChildren | (Inherited from Form.)
Public property | MdiParent | (Inherited from Form.)
Public property | Menu | (Inherited from Form.)
Public property | MergedMenu | (Inherited from Form.)
Public property | MinimizeBox | (Inherited from Form.)
Public property | MinimumSize | (Inherited from Form.)
Public property | Modal | (Inherited from Form.)
Public property | Name | (Inherited from Control.)
Public property | Opacity | (Inherited from Form.)
Public property | OwnedForms | (Inherited from Form.)
Public property | Owner | (Inherited from Form.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | RestoreBounds | (Inherited from Form.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Public property | RightToLeftLayout | (Inherited from Form.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | ShowIcon | (Inherited from Form.)
Public property | ShowInTaskbar | (Inherited from Form.)
Protected property | ShowWithoutActivation | (Inherited from Form.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Form.)
Public property | SizeGripStyle | (Inherited from Form.)
Public property | StartPosition | (Inherited from Form.)
Public property | TabIndex | (Inherited from Form.)
Public property | TabStop | (Inherited from Form.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | (Inherited from Control.)
Public property | TopLevel | (Inherited from Form.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | TopMost | (Inherited from Form.)
Public property | TransparencyKey | (Inherited from Form.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowState | (Inherited from Form.)
Public property | WindowTarget | (Inherited from Control.)

See Also

QuestUI Class
Quester.Profile.ProfilesCreator Namespace


QuestUI Events

The QuestUI type exposes the following members.

Events

 | Name | Description
Public event | Activated | (Inherited from Form.)
Public event | AutoSizeChanged | (Inherited from Form.)
Public event | AutoValidateChanged | (Inherited from Form.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | Closed | (Inherited from Form.)
Public event | Closing | (Inherited from Form.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Deactivate | (Inherited from Form.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | FormClosed | (Inherited from Form.)
Public event | FormClosing | (Inherited from Form.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpButtonClicked | (Inherited from Form.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | InputLanguageChanged | (Inherited from Form.)
Public event | InputLanguageChanging | (Inherited from Form.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from Form.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Form.)
Public event | MaximizedBoundsChanged | (Inherited from Form.)
Public event | MaximumSizeChanged | (Inherited from Form.)
Public event | MdiChildActivate | (Inherited from Form.)
Public event | MenuComplete | (Inherited from Form.)
Public event | MenuStart | (Inherited from Form.)
Public event | MinimumSizeChanged | (Inherited from Form.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | ResizeBegin | (Inherited from Form.)
Public event | ResizeEnd | (Inherited from Form.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | RightToLeftLayoutChanged | (Inherited from Form.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | Shown | (Inherited from Form.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Form.)
Public event | TabStopChanged | (Inherited from Form.)
Public event | TextChanged | (Inherited from Control.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

QuestUI Class
Quester.Profile.ProfilesCreator Namespace


VendorsUI Class

Class VendorsUI. Implements the Form

Namespace: Quester.Profile.ProfilesCreator
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public class VendorsUI : Form
Public Class VendorsUI _
    Inherits Form
public ref class VendorsUI : public Form

Inheritance Hierarchy

Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
Quester.Profile.ProfilesCreator..::..VendorsUI

See Also

VendorsUI Members
Quester.Profile.ProfilesCreator Namespace
Form


VendorsUI Members

The VendorsUI type exposes the following members.

Constructors

 | Name | Description
Public method | VendorsUI | Initializes a new instance of the VendorsUI class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Public method | Activate | (Inherited from Form.)
Protected method | ActivateMdiChild(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | AddOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from Form.)
Protected method | ApplyAutoScaling | (Inherited from Form.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Protected method | CenterToParent | (Inherited from Form.)
Protected method | CenterToScreen | (Inherited from Form.)
Public method | Close | (Inherited from Form.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Form.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Clean up any resources being used.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Public method | LayoutMdi(System.Windows.Forms.MdiLayout) | (Inherited from Form.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnActivated(System.EventArgs) | (Inherited from Form.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnClosed(System.EventArgs) | (Inherited from Form.)
Protected method | OnClosing(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from Form.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDeactivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Form.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnFormClosed(System.Windows.Forms.FormClosedEventArgs) | (Inherited from Form.)
Protected method | OnFormClosing(System.Windows.Forms.FormClosingEventArgs) | (Inherited from Form.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Form.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Form.)
Protected method | OnHelpButtonClicked(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInputLanguageChanged(System.Windows.Forms.InputLanguageChangedEventArgs) | (Inherited from Form.)
Protected method | OnInputLanguageChanging(System.Windows.Forms.InputLanguageChangingEventArgs) | (Inherited from Form.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from Form.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from Form.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMaximumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMdiChildActivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuComplete(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuStart(System.EventArgs) | (Inherited from Form.)
Protected method | OnMinimumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Form.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeBegin(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeEnd(System.EventArgs) | (Inherited from Form.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnShown(System.EventArgs) | (Inherited from Form.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from Form.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from Form.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from Form.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | RemoveOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from Form.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from Form.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopLocation(System.Int32,System.Int32) | (Inherited from Form.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Form.)
Public method | Show(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Public method | Show | (Inherited from Control.)
Public method | ShowDialog | (Inherited from Form.)
Public method | ShowDialog(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Form.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from Form.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from Form.)

Properties

 | Name | Description
Public property | AcceptButton | (Inherited from Form.)
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | ActiveMdiChild | (Inherited from Form.)
Public property | AllowDrop | (Inherited from Control.)
Public property | AllowTransparency | (Inherited from Form.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScale | (Inherited from Form.)
Public property | AutoScaleBaseSize | (Inherited from Form.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from Form.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Form.)
Public property | AutoSizeMode | (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Public property | CancelButton | (Inherited from Form.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Form.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | ControlBox | (Inherited from Form.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Form.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DesktopBounds | (Inherited from Form.)
Public property | DesktopLocation | (Inherited from Form.)
Public property | DialogResult | (Inherited from Form.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | FormBorderStyle | (Inherited from Form.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HelpButton | (Inherited from Form.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | Icon | (Inherited from Form.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMdiChild | (Inherited from Form.)
Public property | IsMdiContainer | (Inherited from Form.)
Public property | IsMirrored | (Inherited from Control.)
Public property | IsRestrictedWindow | (Inherited from Form.)
Public property | KeyPreview | (Inherited from Form.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Form.)
Public property | MainMenuStrip | (Inherited from Form.)
Public property | Margin | (Inherited from Form.)
Public property | MaximizeBox | (Inherited from Form.)
Protected property | MaximizedBounds | (Inherited from Form.)
Public property | MaximumSize | (Inherited from Form.)
Public property | MdiChildren | (Inherited from Form.)
Public property | MdiParent | (Inherited from Form.)
Public property | Menu | (Inherited from Form.)
Public property | MergedMenu | (Inherited from Form.)
Public property | MinimizeBox | (Inherited from Form.)
Public property | MinimumSize | (Inherited from Form.)
Public property | Modal | (Inherited from Form.)
Public property | Name | (Inherited from Control.)
Public property | Opacity | (Inherited from Form.)
Public property | OwnedForms | (Inherited from Form.)
Public property | Owner | (Inherited from Form.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | RestoreBounds | (Inherited from Form.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Public property | RightToLeftLayout | (Inherited from Form.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | ShowIcon | (Inherited from Form.)
Public property | ShowInTaskbar | (Inherited from Form.)
Protected property | ShowWithoutActivation | (Inherited from Form.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Form.)
Public property | SizeGripStyle | (Inherited from Form.)
Public property | StartPosition | (Inherited from Form.)
Public property | TabIndex | (Inherited from Form.)
Public property | TabStop | (Inherited from Form.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | (Inherited from Control.)
Public property | TopLevel | (Inherited from Form.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | TopMost | (Inherited from Form.)
Public property | TransparencyKey | (Inherited from Form.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowState | (Inherited from Form.)
Public property | WindowTarget | (Inherited from Control.)

Events

 | Name | Description
Public event | Activated | (Inherited from Form.)
Public event | AutoSizeChanged | (Inherited from Form.)
Public event | AutoValidateChanged | (Inherited from Form.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | Closed | (Inherited from Form.)
Public event | Closing | (Inherited from Form.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Deactivate | (Inherited from Form.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | FormClosed | (Inherited from Form.)
Public event | FormClosing | (Inherited from Form.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpButtonClicked | (Inherited from Form.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | InputLanguageChanged | (Inherited from Form.)
Public event | InputLanguageChanging | (Inherited from Form.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from Form.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Form.)
Public event | MaximizedBoundsChanged | (Inherited from Form.)
Public event | MaximumSizeChanged | (Inherited from Form.)
Public event | MdiChildActivate | (Inherited from Form.)
Public event | MenuComplete | (Inherited from Form.)
Public event | MenuStart | (Inherited from Form.)
Public event | MinimumSizeChanged | (Inherited from Form.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | ResizeBegin | (Inherited from Form.)
Public event | ResizeEnd | (Inherited from Form.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | RightToLeftLayoutChanged | (Inherited from Form.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | Shown | (Inherited from Form.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Form.)
Public event | TabStopChanged | (Inherited from Form.)
Public event | TextChanged | (Inherited from Control.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

VendorsUI Class
Quester.Profile.ProfilesCreator Namespace


VendorsUI Constructor

Initializes a new instance of the VendorsUI class.

Namespace: Quester.Profile.ProfilesCreator
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public VendorsUI(
    ref EasyQuestProfile questProfile
)
Public Sub New ( _
    ByRef questProfile As EasyQuestProfile _
)
public:
VendorsUI(
    EasyQuestProfile^% questProfile
)

Parameters

questProfile
Type: Quester.Profile..::..EasyQuestProfile %
The quest profile.

See Also

VendorsUI Class
Quester.Profile.ProfilesCreator Namespace


VendorsUI Methods

The VendorsUI type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Public method | Activate | (Inherited from Form.)
Protected method | ActivateMdiChild(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | AddOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from Form.)
Protected method | ApplyAutoScaling | (Inherited from Form.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Protected method | CenterToParent | (Inherited from Form.)
Protected method | CenterToScreen | (Inherited from Form.)
Public method | Close | (Inherited from Form.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Form.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Clean up any resources being used.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Public method | LayoutMdi(System.Windows.Forms.MdiLayout) | (Inherited from Form.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnActivated(System.EventArgs) | (Inherited from Form.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnClosed(System.EventArgs) | (Inherited from Form.)
Protected method | OnClosing(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from Form.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDeactivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Form.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnFormClosed(System.Windows.Forms.FormClosedEventArgs) | (Inherited from Form.)
Protected method | OnFormClosing(System.Windows.Forms.FormClosingEventArgs) | (Inherited from Form.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Form.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Form.)
Protected method | OnHelpButtonClicked(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInputLanguageChanged(System.Windows.Forms.InputLanguageChangedEventArgs) | (Inherited from Form.)
Protected method | OnInputLanguageChanging(System.Windows.Forms.InputLanguageChangingEventArgs) | (Inherited from Form.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from Form.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from Form.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMaximumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMdiChildActivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuComplete(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuStart(System.EventArgs) | (Inherited from Form.)
Protected method | OnMinimumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Form.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeBegin(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeEnd(System.EventArgs) | (Inherited from Form.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnShown(System.EventArgs) | (Inherited from Form.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from Form.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from Form.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from Form.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | RemoveOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from Form.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from Form.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopLocation(System.Int32,System.Int32) | (Inherited from Form.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Form.)
Public method | Show(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Public method | Show | (Inherited from Control.)
Public method | ShowDialog | (Inherited from Form.)
Public method | ShowDialog(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Form.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from Form.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from Form.)

See Also

VendorsUI Class
Quester.Profile.ProfilesCreator Namespace


Dispose Method

VendorsUI..::..Dispose Method

Overload List

 | Name | Description
Protected method | Dispose(Boolean) | Clean up any resources being used.
Public method | Dispose | (Inherited from Component.)

See Also

VendorsUI Class
VendorsUI Members
Quester.Profile.ProfilesCreator Namespace


Dispose Method

VendorsUI..::..Dispose Method

Clean up any resources being used.

Namespace: Quester.Profile.ProfilesCreator
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
protected void Dispose(
    bool disposing
)
Protected Sub Dispose ( _
    disposing As Boolean _
)
protected:
void Dispose(
    bool^ disposing
)

Parameters

disposing
Type: Boolean
true if managed resources should be disposed; otherwise, false.

See Also

VendorsUI Class
Quester.Profile.ProfilesCreator Namespace


VendorsUI Properties

The VendorsUI type exposes the following members.

Properties

 | Name | Description
Public property | AcceptButton | (Inherited from Form.)
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | ActiveMdiChild | (Inherited from Form.)
Public property | AllowDrop | (Inherited from Control.)
Public property | AllowTransparency | (Inherited from Form.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScale | (Inherited from Form.)
Public property | AutoScaleBaseSize | (Inherited from Form.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from Form.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Form.)
Public property | AutoSizeMode | (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Public property | CancelButton | (Inherited from Form.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Form.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | ControlBox | (Inherited from Form.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Form.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DesktopBounds | (Inherited from Form.)
Public property | DesktopLocation | (Inherited from Form.)
Public property | DialogResult | (Inherited from Form.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | FormBorderStyle | (Inherited from Form.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HelpButton | (Inherited from Form.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | Icon | (Inherited from Form.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMdiChild | (Inherited from Form.)
Public property | IsMdiContainer | (Inherited from Form.)
Public property | IsMirrored | (Inherited from Control.)
Public property | IsRestrictedWindow | (Inherited from Form.)
Public property | KeyPreview | (Inherited from Form.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Form.)
Public property | MainMenuStrip | (Inherited from Form.)
Public property | Margin | (Inherited from Form.)
Public property | MaximizeBox | (Inherited from Form.)
Protected property | MaximizedBounds | (Inherited from Form.)
Public property | MaximumSize | (Inherited from Form.)
Public property | MdiChildren | (Inherited from Form.)
Public property | MdiParent | (Inherited from Form.)
Public property | Menu | (Inherited from Form.)
Public property | MergedMenu | (Inherited from Form.)
Public property | MinimizeBox | (Inherited from Form.)
Public property | MinimumSize | (Inherited from Form.)
Public property | Modal | (Inherited from Form.)
Public property | Name | (Inherited from Control.)
Public property | Opacity | (Inherited from Form.)
Public property | OwnedForms | (Inherited from Form.)
Public property | Owner | (Inherited from Form.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | RestoreBounds | (Inherited from Form.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Public property | RightToLeftLayout | (Inherited from Form.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | ShowIcon | (Inherited from Form.)
Public property | ShowInTaskbar | (Inherited from Form.)
Protected property | ShowWithoutActivation | (Inherited from Form.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Form.)
Public property | SizeGripStyle | (Inherited from Form.)
Public property | StartPosition | (Inherited from Form.)
Public property | TabIndex | (Inherited from Form.)
Public property | TabStop | (Inherited from Form.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | (Inherited from Control.)
Public property | TopLevel | (Inherited from Form.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | TopMost | (Inherited from Form.)
Public property | TransparencyKey | (Inherited from Form.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowState | (Inherited from Form.)
Public property | WindowTarget | (Inherited from Control.)

See Also

VendorsUI Class
Quester.Profile.ProfilesCreator Namespace


VendorsUI Events

The VendorsUI type exposes the following members.

Events

 | Name | Description
Public event | Activated | (Inherited from Form.)
Public event | AutoSizeChanged | (Inherited from Form.)
Public event | AutoValidateChanged | (Inherited from Form.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | Closed | (Inherited from Form.)
Public event | Closing | (Inherited from Form.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Deactivate | (Inherited from Form.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | FormClosed | (Inherited from Form.)
Public event | FormClosing | (Inherited from Form.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpButtonClicked | (Inherited from Form.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | InputLanguageChanged | (Inherited from Form.)
Public event | InputLanguageChanging | (Inherited from Form.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from Form.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Form.)
Public event | MaximizedBoundsChanged | (Inherited from Form.)
Public event | MaximumSizeChanged | (Inherited from Form.)
Public event | MdiChildActivate | (Inherited from Form.)
Public event | MenuComplete | (Inherited from Form.)
Public event | MenuStart | (Inherited from Form.)
Public event | MinimumSizeChanged | (Inherited from Form.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | ResizeBegin | (Inherited from Form.)
Public event | ResizeEnd | (Inherited from Form.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | RightToLeftLayoutChanged | (Inherited from Form.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | Shown | (Inherited from Form.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Form.)
Public event | TabStopChanged | (Inherited from Form.)
Public event | TextChanged | (Inherited from Control.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

VendorsUI Class
Quester.Profile.ProfilesCreator Namespace


Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace

Classes

 | Class | Description
Public class | FollowNpcUserControl | Class FollowNpcUserControl. Implements the UserControl
Public class | FollowPathUserControl | Class FollowPathUserControl. Implements the UserControl
Public class | FullCSharpCodeUserControl | Class FullCSharpCodeUserControl. Implements the UserControl
Public class | GathererUserControl | Class GathererUserControl. Implements the UserControl
Public class | GrinderGathererUserControl | Class GrinderGathererUserControl. Implements the UserControl
Public class | InteractWithNpcUserControl | Class InteractWithNpcUserControl. Implements the UserControl
Public class | KillAndLootUserControl | Class KillAndLootUserControl. Implements the UserControl
Public class | OverridePulseCSharpCodeUserControl | Class OverridePulseCSharpCodeUserControl. Implements the UserControl
Public class | ParallelQuestsUserControl | Class ParallelQuestsUserControl. Implements the UserControl
Public class | UseItemOnUserControl | Class UseItemOnUserControl. Implements the UserControl
Public class | UseScriptOnUserControl | Class UseScriptOnUserControl. Implements the UserControl
Public class | UseSpellOnUserControl | Class UseSpellOnUserControl. Implements the UserControl


FollowNpcUserControl Class

Class FollowNpcUserControl. Implements the UserControl

Namespace: Quester.Profile.ProfilesCreator.EasyQuestClassUserControl
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public class FollowNpcUserControl : UserControl
Public Class FollowNpcUserControl _
    Inherits UserControl
public ref class FollowNpcUserControl : public UserControl

Inheritance Hierarchy

Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl..::..FollowNpcUserControl

See Also

FollowNpcUserControl Members
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace
UserControl


FollowNpcUserControl Members

The FollowNpcUserControl type exposes the following members.

Constructors

 | Name | Description
Public method | FollowNpcUserControl | Initializes a new instance of the FollowNpcUserControl class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from ContainerControl.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Control.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Control.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Nettoyage des ressources utilisées.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from UserControl.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Control.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from ContainerControl.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from UserControl.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from ContainerControl.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from ScrollableControl.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from ContainerControl.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Control.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Control.)
Public method | Show | (Inherited from Control.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Component.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from ContainerControl.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from UserControl.)

Properties

 | Name | Description
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | AllowDrop | (Inherited from Control.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | (Inherited from UserControl.)
Public property | AutoValidate | (Inherited from UserControl.)
Public property | BackColor | (Inherited from Control.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | (Inherited from UserControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Control.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Control.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMirrored | (Inherited from Control.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Control.)
Public property | Margin | (Inherited from Control.)
Public property | MaximumSize | (Inherited from Control.)
Public property | MinimumSize | (Inherited from Control.)
Public property | Name | (Inherited from Control.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Control.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabStop | (Inherited from Control.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | (Inherited from Control.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowTarget | (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | (Inherited from UserControl.)
Public event | AutoValidateChanged | (Inherited from UserControl.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from UserControl.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Control.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Control.)
Public event | TabStopChanged | (Inherited from Control.)
Public event | TextChanged | (Inherited from UserControl.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

FollowNpcUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


FollowNpcUserControl Constructor

Initializes a new instance of the FollowNpcUserControl class.

Namespace: Quester.Profile.ProfilesCreator.EasyQuestClassUserControl
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public FollowNpcUserControl(
    ref FollowNpcEasyQuestClass followNpcEasyQuestClass
)
Public Sub New ( _
    ByRef followNpcEasyQuestClass As FollowNpcEasyQuestClass _
)
public:
FollowNpcUserControl(
    FollowNpcEasyQuestClass^% followNpcEasyQuestClass
)

Parameters

followNpcEasyQuestClass
Type: Quester.Profile..::..FollowNpcEasyQuestClass %
The follow NPC easy quest class.

See Also

FollowNpcUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


FollowNpcUserControl Methods

The FollowNpcUserControl type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from ContainerControl.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Control.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Control.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Nettoyage des ressources utilisées.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from UserControl.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Control.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from ContainerControl.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from UserControl.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from ContainerControl.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from ScrollableControl.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from ContainerControl.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Control.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Control.)
Public method | Show | (Inherited from Control.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Component.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from ContainerControl.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from UserControl.)

See Also

FollowNpcUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


Dispose Method

FollowNpcUserControl..::..Dispose Method

Overload List

 | Name | Description
Protected method | Dispose(Boolean) | Nettoyage des ressources utilisées.
Public method | Dispose | (Inherited from Component.)

See Also

FollowNpcUserControl Class
FollowNpcUserControl Members
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


Dispose Method

FollowNpcUserControl..::..Dispose Method

Nettoyage des ressources utilisées.

Namespace: Quester.Profile.ProfilesCreator.EasyQuestClassUserControl
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
protected void Dispose(
    bool disposing
)
Protected Sub Dispose ( _
    disposing As Boolean _
)
protected:
void Dispose(
    bool^ disposing
)

Parameters

disposing
Type: Boolean
true si les ressources managées doivent être supprimées ; sinon, false.

See Also

FollowNpcUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


FollowNpcUserControl Properties

The FollowNpcUserControl type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | AllowDrop | (Inherited from Control.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | (Inherited from UserControl.)
Public property | AutoValidate | (Inherited from UserControl.)
Public property | BackColor | (Inherited from Control.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | (Inherited from UserControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Control.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Control.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMirrored | (Inherited from Control.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Control.)
Public property | Margin | (Inherited from Control.)
Public property | MaximumSize | (Inherited from Control.)
Public property | MinimumSize | (Inherited from Control.)
Public property | Name | (Inherited from Control.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Control.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabStop | (Inherited from Control.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | (Inherited from Control.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowTarget | (Inherited from Control.)

See Also

FollowNpcUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


FollowNpcUserControl Events

The FollowNpcUserControl type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | (Inherited from UserControl.)
Public event | AutoValidateChanged | (Inherited from UserControl.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from UserControl.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Control.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Control.)
Public event | TabStopChanged | (Inherited from Control.)
Public event | TextChanged | (Inherited from UserControl.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

FollowNpcUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


FollowPathUserControl Class

Class FollowPathUserControl. Implements the UserControl

Namespace: Quester.Profile.ProfilesCreator.EasyQuestClassUserControl
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public class FollowPathUserControl : UserControl
Public Class FollowPathUserControl _
    Inherits UserControl
public ref class FollowPathUserControl : public UserControl

Inheritance Hierarchy

Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl..::..FollowPathUserControl

See Also

FollowPathUserControl Members
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace
UserControl


FollowPathUserControl Members

The FollowPathUserControl type exposes the following members.

Constructors

 | Name | Description
Public method | FollowPathUserControl | Initializes a new instance of the FollowPathUserControl class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from ContainerControl.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Control.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Control.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Nettoyage des ressources utilisées.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from UserControl.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Control.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from ContainerControl.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from UserControl.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from ContainerControl.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from ScrollableControl.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from ContainerControl.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Control.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Control.)
Public method | Show | (Inherited from Control.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Component.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from ContainerControl.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from UserControl.)

Properties

 | Name | Description
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | AllowDrop | (Inherited from Control.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | (Inherited from UserControl.)
Public property | AutoValidate | (Inherited from UserControl.)
Public property | BackColor | (Inherited from Control.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | (Inherited from UserControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Control.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Control.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMirrored | (Inherited from Control.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Control.)
Public property | Margin | (Inherited from Control.)
Public property | MaximumSize | (Inherited from Control.)
Public property | MinimumSize | (Inherited from Control.)
Public property | Name | (Inherited from Control.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Control.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabStop | (Inherited from Control.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | (Inherited from Control.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowTarget | (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | (Inherited from UserControl.)
Public event | AutoValidateChanged | (Inherited from UserControl.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from UserControl.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Control.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Control.)
Public event | TabStopChanged | (Inherited from Control.)
Public event | TextChanged | (Inherited from UserControl.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

FollowPathUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


FollowPathUserControl Constructor

Initializes a new instance of the FollowPathUserControl class.

Namespace: Quester.Profile.ProfilesCreator.EasyQuestClassUserControl
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public FollowPathUserControl(
    ref FollowPathEasyQuestClass followEasyQuestClass
)
Public Sub New ( _
    ByRef followEasyQuestClass As FollowPathEasyQuestClass _
)
public:
FollowPathUserControl(
    FollowPathEasyQuestClass^% followEasyQuestClass
)

Parameters

followEasyQuestClass
Type: Quester.Profile..::..FollowPathEasyQuestClass %
The follow easy quest class.

See Also

FollowPathUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


FollowPathUserControl Methods

The FollowPathUserControl type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from ContainerControl.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Control.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Control.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Nettoyage des ressources utilisées.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from UserControl.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Control.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from ContainerControl.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from UserControl.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from ContainerControl.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from ScrollableControl.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from ContainerControl.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Control.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Control.)
Public method | Show | (Inherited from Control.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Component.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from ContainerControl.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from UserControl.)

See Also

FollowPathUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


Dispose Method

FollowPathUserControl..::..Dispose Method

Overload List

 | Name | Description
Protected method | Dispose(Boolean) | Nettoyage des ressources utilisées.
Public method | Dispose | (Inherited from Component.)

See Also

FollowPathUserControl Class
FollowPathUserControl Members
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


Dispose Method

FollowPathUserControl..::..Dispose Method

Nettoyage des ressources utilisées.

Namespace: Quester.Profile.ProfilesCreator.EasyQuestClassUserControl
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
protected void Dispose(
    bool disposing
)
Protected Sub Dispose ( _
    disposing As Boolean _
)
protected:
void Dispose(
    bool^ disposing
)

Parameters

disposing
Type: Boolean
true si les ressources managées doivent être supprimées ; sinon, false.

See Also

FollowPathUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


FollowPathUserControl Properties

The FollowPathUserControl type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | AllowDrop | (Inherited from Control.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | (Inherited from UserControl.)
Public property | AutoValidate | (Inherited from UserControl.)
Public property | BackColor | (Inherited from Control.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | (Inherited from UserControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Control.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Control.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMirrored | (Inherited from Control.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Control.)
Public property | Margin | (Inherited from Control.)
Public property | MaximumSize | (Inherited from Control.)
Public property | MinimumSize | (Inherited from Control.)
Public property | Name | (Inherited from Control.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Control.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabStop | (Inherited from Control.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | (Inherited from Control.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowTarget | (Inherited from Control.)

See Also

FollowPathUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


FollowPathUserControl Events

The FollowPathUserControl type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | (Inherited from UserControl.)
Public event | AutoValidateChanged | (Inherited from UserControl.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from UserControl.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Control.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Control.)
Public event | TabStopChanged | (Inherited from Control.)
Public event | TextChanged | (Inherited from UserControl.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

FollowPathUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


FullCSharpCodeUserControl Class

Class FullCSharpCodeUserControl. Implements the UserControl

Namespace: Quester.Profile.ProfilesCreator.EasyQuestClassUserControl
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public class FullCSharpCodeUserControl : UserControl
Public Class FullCSharpCodeUserControl _
    Inherits UserControl
public ref class FullCSharpCodeUserControl : public UserControl

Inheritance Hierarchy

Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl..::..FullCSharpCodeUserControl

See Also

FullCSharpCodeUserControl Members
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace
UserControl


FullCSharpCodeUserControl Members

The FullCSharpCodeUserControl type exposes the following members.

Constructors

 | Name | Description
Public method | FullCSharpCodeUserControl | Initializes a new instance of the FullCSharpCodeUserControl class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from ContainerControl.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Control.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Control.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Nettoyage des ressources utilisées.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from UserControl.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Control.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from ContainerControl.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from UserControl.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from ContainerControl.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from ScrollableControl.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from ContainerControl.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Control.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Control.)
Public method | Show | (Inherited from Control.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Component.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from ContainerControl.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from UserControl.)

Properties

 | Name | Description
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | AllowDrop | (Inherited from Control.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | (Inherited from UserControl.)
Public property | AutoValidate | (Inherited from UserControl.)
Public property | BackColor | (Inherited from Control.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | (Inherited from UserControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Control.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Control.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMirrored | (Inherited from Control.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Control.)
Public property | Margin | (Inherited from Control.)
Public property | MaximumSize | (Inherited from Control.)
Public property | MinimumSize | (Inherited from Control.)
Public property | Name | (Inherited from Control.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Control.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabStop | (Inherited from Control.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | (Inherited from Control.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowTarget | (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | (Inherited from UserControl.)
Public event | AutoValidateChanged | (Inherited from UserControl.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from UserControl.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Control.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Control.)
Public event | TabStopChanged | (Inherited from Control.)
Public event | TextChanged | (Inherited from UserControl.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

FullCSharpCodeUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


FullCSharpCodeUserControl Constructor

Initializes a new instance of the FullCSharpCodeUserControl class.

Namespace: Quester.Profile.ProfilesCreator.EasyQuestClassUserControl
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public FullCSharpCodeUserControl(
    ref FullCSharpCodeEasyQuestClass fullCSharpCodeEasyQuestClass
)
Public Sub New ( _
    ByRef fullCSharpCodeEasyQuestClass As FullCSharpCodeEasyQuestClass _
)
public:
FullCSharpCodeUserControl(
    FullCSharpCodeEasyQuestClass^% fullCSharpCodeEasyQuestClass
)

Parameters

fullCSharpCodeEasyQuestClass
Type: Quester.Profile..::..FullCSharpCodeEasyQuestClass %
The full c sharp code easy quest class.

See Also

FullCSharpCodeUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


FullCSharpCodeUserControl Methods

The FullCSharpCodeUserControl type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from ContainerControl.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Control.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Control.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Nettoyage des ressources utilisées.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from UserControl.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Control.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from ContainerControl.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from UserControl.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from ContainerControl.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from ScrollableControl.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from ContainerControl.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Control.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Control.)
Public method | Show | (Inherited from Control.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Component.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from ContainerControl.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from UserControl.)

See Also

FullCSharpCodeUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


Dispose Method

FullCSharpCodeUserControl..::..Dispose Method

Overload List

 | Name | Description
Protected method | Dispose(Boolean) | Nettoyage des ressources utilisées.
Public method | Dispose | (Inherited from Component.)

See Also

FullCSharpCodeUserControl Class
FullCSharpCodeUserControl Members
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


Dispose Method

FullCSharpCodeUserControl..::..Dispose Method

Nettoyage des ressources utilisées.

Namespace: Quester.Profile.ProfilesCreator.EasyQuestClassUserControl
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
protected void Dispose(
    bool disposing
)
Protected Sub Dispose ( _
    disposing As Boolean _
)
protected:
void Dispose(
    bool^ disposing
)

Parameters

disposing
Type: Boolean
true si les ressources managées doivent être supprimées ; sinon, false.

See Also

FullCSharpCodeUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


FullCSharpCodeUserControl Properties

The FullCSharpCodeUserControl type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | AllowDrop | (Inherited from Control.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | (Inherited from UserControl.)
Public property | AutoValidate | (Inherited from UserControl.)
Public property | BackColor | (Inherited from Control.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | (Inherited from UserControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Control.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Control.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMirrored | (Inherited from Control.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Control.)
Public property | Margin | (Inherited from Control.)
Public property | MaximumSize | (Inherited from Control.)
Public property | MinimumSize | (Inherited from Control.)
Public property | Name | (Inherited from Control.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Control.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabStop | (Inherited from Control.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | (Inherited from Control.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowTarget | (Inherited from Control.)

See Also

FullCSharpCodeUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


FullCSharpCodeUserControl Events

The FullCSharpCodeUserControl type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | (Inherited from UserControl.)
Public event | AutoValidateChanged | (Inherited from UserControl.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from UserControl.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Control.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Control.)
Public event | TabStopChanged | (Inherited from Control.)
Public event | TextChanged | (Inherited from UserControl.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

FullCSharpCodeUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


GathererUserControl Class

Class GathererUserControl. Implements the UserControl

Namespace: Quester.Profile.ProfilesCreator.EasyQuestClassUserControl
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public class GathererUserControl : UserControl
Public Class GathererUserControl _
    Inherits UserControl
public ref class GathererUserControl : public UserControl

Inheritance Hierarchy

Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl..::..GathererUserControl

See Also

GathererUserControl Members
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace
UserControl


GathererUserControl Members

The GathererUserControl type exposes the following members.

Constructors

 | Name | Description
Public method | GathererUserControl | Initializes a new instance of the GathererUserControl class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from ContainerControl.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Control.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Control.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Nettoyage des ressources utilisées.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from UserControl.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Control.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from ContainerControl.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from UserControl.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from ContainerControl.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from ScrollableControl.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from ContainerControl.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Control.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Control.)
Public method | Show | (Inherited from Control.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Component.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from ContainerControl.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from UserControl.)

Properties

 | Name | Description
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | AllowDrop | (Inherited from Control.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | (Inherited from UserControl.)
Public property | AutoValidate | (Inherited from UserControl.)
Public property | BackColor | (Inherited from Control.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | (Inherited from UserControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Control.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Control.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMirrored | (Inherited from Control.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Control.)
Public property | Margin | (Inherited from Control.)
Public property | MaximumSize | (Inherited from Control.)
Public property | MinimumSize | (Inherited from Control.)
Public property | Name | (Inherited from Control.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Control.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabStop | (Inherited from Control.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | (Inherited from Control.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowTarget | (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | (Inherited from UserControl.)
Public event | AutoValidateChanged | (Inherited from UserControl.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from UserControl.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Control.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Control.)
Public event | TabStopChanged | (Inherited from Control.)
Public event | TextChanged | (Inherited from UserControl.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

GathererUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


GathererUserControl Constructor

Initializes a new instance of the GathererUserControl class.

Namespace: Quester.Profile.ProfilesCreator.EasyQuestClassUserControl
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public GathererUserControl(
    ref GathererEasyQuestClass gathererEasyQuestClass
)
Public Sub New ( _
    ByRef gathererEasyQuestClass As GathererEasyQuestClass _
)
public:
GathererUserControl(
    GathererEasyQuestClass^% gathererEasyQuestClass
)

Parameters

gathererEasyQuestClass
Type: Quester.Profile..::..GathererEasyQuestClass %
The gatherer easy quest class.

See Also

GathererUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


GathererUserControl Methods

The GathererUserControl type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from ContainerControl.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Control.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Control.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Nettoyage des ressources utilisées.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from UserControl.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Control.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from ContainerControl.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from UserControl.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from ContainerControl.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from ScrollableControl.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from ContainerControl.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Control.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Control.)
Public method | Show | (Inherited from Control.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Component.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from ContainerControl.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from UserControl.)

See Also

GathererUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


Dispose Method

GathererUserControl..::..Dispose Method

Overload List

 | Name | Description
Protected method | Dispose(Boolean) | Nettoyage des ressources utilisées.
Public method | Dispose | (Inherited from Component.)

See Also

GathererUserControl Class
GathererUserControl Members
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


Dispose Method

GathererUserControl..::..Dispose Method

Nettoyage des ressources utilisées.

Namespace: Quester.Profile.ProfilesCreator.EasyQuestClassUserControl
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
protected void Dispose(
    bool disposing
)
Protected Sub Dispose ( _
    disposing As Boolean _
)
protected:
void Dispose(
    bool^ disposing
)

Parameters

disposing
Type: Boolean
true si les ressources managées doivent être supprimées ; sinon, false.

See Also

GathererUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


GathererUserControl Properties

The GathererUserControl type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | AllowDrop | (Inherited from Control.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | (Inherited from UserControl.)
Public property | AutoValidate | (Inherited from UserControl.)
Public property | BackColor | (Inherited from Control.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | (Inherited from UserControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Control.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Control.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMirrored | (Inherited from Control.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Control.)
Public property | Margin | (Inherited from Control.)
Public property | MaximumSize | (Inherited from Control.)
Public property | MinimumSize | (Inherited from Control.)
Public property | Name | (Inherited from Control.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Control.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabStop | (Inherited from Control.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | (Inherited from Control.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowTarget | (Inherited from Control.)

See Also

GathererUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


GathererUserControl Events

The GathererUserControl type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | (Inherited from UserControl.)
Public event | AutoValidateChanged | (Inherited from UserControl.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from UserControl.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Control.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Control.)
Public event | TabStopChanged | (Inherited from Control.)
Public event | TextChanged | (Inherited from UserControl.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

GathererUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


GrinderGathererUserControl Class

Class GrinderGathererUserControl. Implements the UserControl

Namespace: Quester.Profile.ProfilesCreator.EasyQuestClassUserControl
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public class GrinderGathererUserControl : UserControl
Public Class GrinderGathererUserControl _
    Inherits UserControl
public ref class GrinderGathererUserControl : public UserControl

Inheritance Hierarchy

Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl..::..GrinderGathererUserControl

See Also

GrinderGathererUserControl Members
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace
UserControl


GrinderGathererUserControl Members

The GrinderGathererUserControl type exposes the following members.

Constructors

 | Name | Description
Public method | GrinderGathererUserControl | Initializes a new instance of the GrinderGathererUserControl class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from ContainerControl.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Control.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Control.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Nettoyage des ressources utilisées.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from UserControl.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Control.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from ContainerControl.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from UserControl.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from ContainerControl.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from ScrollableControl.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from ContainerControl.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Control.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Control.)
Public method | Show | (Inherited from Control.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Component.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from ContainerControl.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from UserControl.)

Properties

 | Name | Description
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | AllowDrop | (Inherited from Control.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | (Inherited from UserControl.)
Public property | AutoValidate | (Inherited from UserControl.)
Public property | BackColor | (Inherited from Control.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | (Inherited from UserControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Control.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Control.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMirrored | (Inherited from Control.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Control.)
Public property | Margin | (Inherited from Control.)
Public property | MaximumSize | (Inherited from Control.)
Public property | MinimumSize | (Inherited from Control.)
Public property | Name | (Inherited from Control.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Control.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabStop | (Inherited from Control.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | (Inherited from Control.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowTarget | (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | (Inherited from UserControl.)
Public event | AutoValidateChanged | (Inherited from UserControl.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from UserControl.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Control.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Control.)
Public event | TabStopChanged | (Inherited from Control.)
Public event | TextChanged | (Inherited from UserControl.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

GrinderGathererUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


GrinderGathererUserControl Constructor

Initializes a new instance of the GrinderGathererUserControl class.

Namespace: Quester.Profile.ProfilesCreator.EasyQuestClassUserControl
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public GrinderGathererUserControl(
    ref GrinderGathererEasyQuestClass grinderGathererEasyQuestClass
)
Public Sub New ( _
    ByRef grinderGathererEasyQuestClass As GrinderGathererEasyQuestClass _
)
public:
GrinderGathererUserControl(
    GrinderGathererEasyQuestClass^% grinderGathererEasyQuestClass
)

Parameters

grinderGathererEasyQuestClass
Type: Quester.Profile..::..GrinderGathererEasyQuestClass %
The grinder gatherer easy quest class.

See Also

GrinderGathererUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


GrinderGathererUserControl Methods

The GrinderGathererUserControl type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from ContainerControl.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Control.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Control.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Nettoyage des ressources utilisées.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from UserControl.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Control.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from ContainerControl.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from UserControl.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from ContainerControl.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from ScrollableControl.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from ContainerControl.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Control.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Control.)
Public method | Show | (Inherited from Control.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Component.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from ContainerControl.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from UserControl.)

See Also

GrinderGathererUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


Dispose Method

GrinderGathererUserControl..::..Dispose Method

Overload List

 | Name | Description
Protected method | Dispose(Boolean) | Nettoyage des ressources utilisées.
Public method | Dispose | (Inherited from Component.)

See Also

GrinderGathererUserControl Class
GrinderGathererUserControl Members
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


Dispose Method

GrinderGathererUserControl..::..Dispose Method

Nettoyage des ressources utilisées.

Namespace: Quester.Profile.ProfilesCreator.EasyQuestClassUserControl
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
protected void Dispose(
    bool disposing
)
Protected Sub Dispose ( _
    disposing As Boolean _
)
protected:
void Dispose(
    bool^ disposing
)

Parameters

disposing
Type: Boolean
true si les ressources managées doivent être supprimées ; sinon, false.

See Also

GrinderGathererUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


GrinderGathererUserControl Properties

The GrinderGathererUserControl type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | AllowDrop | (Inherited from Control.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | (Inherited from UserControl.)
Public property | AutoValidate | (Inherited from UserControl.)
Public property | BackColor | (Inherited from Control.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | (Inherited from UserControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Control.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Control.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMirrored | (Inherited from Control.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Control.)
Public property | Margin | (Inherited from Control.)
Public property | MaximumSize | (Inherited from Control.)
Public property | MinimumSize | (Inherited from Control.)
Public property | Name | (Inherited from Control.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Control.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabStop | (Inherited from Control.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | (Inherited from Control.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowTarget | (Inherited from Control.)

See Also

GrinderGathererUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


GrinderGathererUserControl Events

The GrinderGathererUserControl type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | (Inherited from UserControl.)
Public event | AutoValidateChanged | (Inherited from UserControl.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from UserControl.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Control.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Control.)
Public event | TabStopChanged | (Inherited from Control.)
Public event | TextChanged | (Inherited from UserControl.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

GrinderGathererUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


InteractWithNpcUserControl Class

Class InteractWithNpcUserControl. Implements the UserControl

Namespace: Quester.Profile.ProfilesCreator.EasyQuestClassUserControl
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public class InteractWithNpcUserControl : UserControl
Public Class InteractWithNpcUserControl _
    Inherits UserControl
public ref class InteractWithNpcUserControl : public UserControl

Inheritance Hierarchy

Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl..::..InteractWithNpcUserControl

See Also

InteractWithNpcUserControl Members
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace
UserControl


InteractWithNpcUserControl Members

The InteractWithNpcUserControl type exposes the following members.

Constructors

 | Name | Description
Public method | InteractWithNpcUserControl | Initializes a new instance of the InteractWithNpcUserControl class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from ContainerControl.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Control.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Control.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Nettoyage des ressources utilisées.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from UserControl.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Control.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from ContainerControl.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from UserControl.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from ContainerControl.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from ScrollableControl.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from ContainerControl.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Control.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Control.)
Public method | Show | (Inherited from Control.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Component.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from ContainerControl.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from UserControl.)

Properties

 | Name | Description
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | AllowDrop | (Inherited from Control.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | (Inherited from UserControl.)
Public property | AutoValidate | (Inherited from UserControl.)
Public property | BackColor | (Inherited from Control.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | (Inherited from UserControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Control.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Control.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMirrored | (Inherited from Control.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Control.)
Public property | Margin | (Inherited from Control.)
Public property | MaximumSize | (Inherited from Control.)
Public property | MinimumSize | (Inherited from Control.)
Public property | Name | (Inherited from Control.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Control.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabStop | (Inherited from Control.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | (Inherited from Control.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowTarget | (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | (Inherited from UserControl.)
Public event | AutoValidateChanged | (Inherited from UserControl.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from UserControl.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Control.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Control.)
Public event | TabStopChanged | (Inherited from Control.)
Public event | TextChanged | (Inherited from UserControl.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

InteractWithNpcUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


InteractWithNpcUserControl Constructor

Initializes a new instance of the InteractWithNpcUserControl class.

Namespace: Quester.Profile.ProfilesCreator.EasyQuestClassUserControl
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public InteractWithNpcUserControl(
    ref InteractWithNpcEasyQuestClass interactWithNpcEasyQuestClass
)
Public Sub New ( _
    ByRef interactWithNpcEasyQuestClass As InteractWithNpcEasyQuestClass _
)
public:
InteractWithNpcUserControl(
    InteractWithNpcEasyQuestClass^% interactWithNpcEasyQuestClass
)

Parameters

interactWithNpcEasyQuestClass
Type: Quester.Profile..::..InteractWithNpcEasyQuestClass %
The interact with NPC easy quest class.

See Also

InteractWithNpcUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


InteractWithNpcUserControl Methods

The InteractWithNpcUserControl type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from ContainerControl.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Control.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Control.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Nettoyage des ressources utilisées.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from UserControl.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Control.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from ContainerControl.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from UserControl.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from ContainerControl.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from ScrollableControl.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from ContainerControl.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Control.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Control.)
Public method | Show | (Inherited from Control.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Component.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from ContainerControl.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from UserControl.)

See Also

InteractWithNpcUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


Dispose Method

InteractWithNpcUserControl..::..Dispose Method

Overload List

 | Name | Description
Protected method | Dispose(Boolean) | Nettoyage des ressources utilisées.
Public method | Dispose | (Inherited from Component.)

See Also

InteractWithNpcUserControl Class
InteractWithNpcUserControl Members
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


Dispose Method

InteractWithNpcUserControl..::..Dispose Method

Nettoyage des ressources utilisées.

Namespace: Quester.Profile.ProfilesCreator.EasyQuestClassUserControl
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
protected void Dispose(
    bool disposing
)
Protected Sub Dispose ( _
    disposing As Boolean _
)
protected:
void Dispose(
    bool^ disposing
)

Parameters

disposing
Type: Boolean
true si les ressources managées doivent être supprimées ; sinon, false.

See Also

InteractWithNpcUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


InteractWithNpcUserControl Properties

The InteractWithNpcUserControl type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | AllowDrop | (Inherited from Control.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | (Inherited from UserControl.)
Public property | AutoValidate | (Inherited from UserControl.)
Public property | BackColor | (Inherited from Control.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | (Inherited from UserControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Control.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Control.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMirrored | (Inherited from Control.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Control.)
Public property | Margin | (Inherited from Control.)
Public property | MaximumSize | (Inherited from Control.)
Public property | MinimumSize | (Inherited from Control.)
Public property | Name | (Inherited from Control.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Control.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabStop | (Inherited from Control.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | (Inherited from Control.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowTarget | (Inherited from Control.)

See Also

InteractWithNpcUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


InteractWithNpcUserControl Events

The InteractWithNpcUserControl type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | (Inherited from UserControl.)
Public event | AutoValidateChanged | (Inherited from UserControl.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from UserControl.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Control.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Control.)
Public event | TabStopChanged | (Inherited from Control.)
Public event | TextChanged | (Inherited from UserControl.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

InteractWithNpcUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


KillAndLootUserControl Class

Class KillAndLootUserControl. Implements the UserControl

Namespace: Quester.Profile.ProfilesCreator.EasyQuestClassUserControl
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public class KillAndLootUserControl : UserControl
Public Class KillAndLootUserControl _
    Inherits UserControl
public ref class KillAndLootUserControl : public UserControl

Inheritance Hierarchy

Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl..::..KillAndLootUserControl

See Also

KillAndLootUserControl Members
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace
UserControl


KillAndLootUserControl Members

The KillAndLootUserControl type exposes the following members.

Constructors

 | Name | Description
Public method | KillAndLootUserControl | Initializes a new instance of the KillAndLootUserControl class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from ContainerControl.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Control.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Control.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Nettoyage des ressources utilisées.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from UserControl.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Control.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from ContainerControl.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from UserControl.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from ContainerControl.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from ScrollableControl.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from ContainerControl.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Control.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Control.)
Public method | Show | (Inherited from Control.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Component.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from ContainerControl.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from UserControl.)

Properties

 | Name | Description
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | AllowDrop | (Inherited from Control.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | (Inherited from UserControl.)
Public property | AutoValidate | (Inherited from UserControl.)
Public property | BackColor | (Inherited from Control.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | (Inherited from UserControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Control.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Control.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMirrored | (Inherited from Control.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Control.)
Public property | Margin | (Inherited from Control.)
Public property | MaximumSize | (Inherited from Control.)
Public property | MinimumSize | (Inherited from Control.)
Public property | Name | (Inherited from Control.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Control.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabStop | (Inherited from Control.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | (Inherited from Control.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowTarget | (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | (Inherited from UserControl.)
Public event | AutoValidateChanged | (Inherited from UserControl.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from UserControl.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Control.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Control.)
Public event | TabStopChanged | (Inherited from Control.)
Public event | TextChanged | (Inherited from UserControl.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

KillAndLootUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


KillAndLootUserControl Constructor

Initializes a new instance of the KillAndLootUserControl class.

Namespace: Quester.Profile.ProfilesCreator.EasyQuestClassUserControl
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public KillAndLootUserControl(
    ref KillAndLootEasyQuestClass killAndLootEasyQuestClass
)
Public Sub New ( _
    ByRef killAndLootEasyQuestClass As KillAndLootEasyQuestClass _
)
public:
KillAndLootUserControl(
    KillAndLootEasyQuestClass^% killAndLootEasyQuestClass
)

Parameters

killAndLootEasyQuestClass
Type: Quester.Profile..::..KillAndLootEasyQuestClass %
The kill and loot easy quest class.

See Also

KillAndLootUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


KillAndLootUserControl Methods

The KillAndLootUserControl type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from ContainerControl.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Control.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Control.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Nettoyage des ressources utilisées.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from UserControl.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Control.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from ContainerControl.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from UserControl.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from ContainerControl.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from ScrollableControl.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from ContainerControl.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Control.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Control.)
Public method | Show | (Inherited from Control.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Component.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from ContainerControl.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from UserControl.)

See Also

KillAndLootUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


Dispose Method

KillAndLootUserControl..::..Dispose Method

Overload List

 | Name | Description
Protected method | Dispose(Boolean) | Nettoyage des ressources utilisées.
Public method | Dispose | (Inherited from Component.)

See Also

KillAndLootUserControl Class
KillAndLootUserControl Members
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


Dispose Method

KillAndLootUserControl..::..Dispose Method

Nettoyage des ressources utilisées.

Namespace: Quester.Profile.ProfilesCreator.EasyQuestClassUserControl
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
protected void Dispose(
    bool disposing
)
Protected Sub Dispose ( _
    disposing As Boolean _
)
protected:
void Dispose(
    bool^ disposing
)

Parameters

disposing
Type: Boolean
true si les ressources managées doivent être supprimées ; sinon, false.

See Also

KillAndLootUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


KillAndLootUserControl Properties

The KillAndLootUserControl type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | AllowDrop | (Inherited from Control.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | (Inherited from UserControl.)
Public property | AutoValidate | (Inherited from UserControl.)
Public property | BackColor | (Inherited from Control.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | (Inherited from UserControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Control.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Control.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMirrored | (Inherited from Control.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Control.)
Public property | Margin | (Inherited from Control.)
Public property | MaximumSize | (Inherited from Control.)
Public property | MinimumSize | (Inherited from Control.)
Public property | Name | (Inherited from Control.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Control.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabStop | (Inherited from Control.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | (Inherited from Control.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowTarget | (Inherited from Control.)

See Also

KillAndLootUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


KillAndLootUserControl Events

The KillAndLootUserControl type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | (Inherited from UserControl.)
Public event | AutoValidateChanged | (Inherited from UserControl.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from UserControl.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Control.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Control.)
Public event | TabStopChanged | (Inherited from Control.)
Public event | TextChanged | (Inherited from UserControl.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

KillAndLootUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


OverridePulseCSharpCodeUserControl Class

Class OverridePulseCSharpCodeUserControl. Implements the UserControl

Namespace: Quester.Profile.ProfilesCreator.EasyQuestClassUserControl
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public class OverridePulseCSharpCodeUserControl : UserControl
Public Class OverridePulseCSharpCodeUserControl _
    Inherits UserControl
public ref class OverridePulseCSharpCodeUserControl : public UserControl

Inheritance Hierarchy

Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl..::..OverridePulseCSharpCodeUserControl

See Also

OverridePulseCSharpCodeUserControl Members
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace
UserControl


OverridePulseCSharpCodeUserControl Members

The OverridePulseCSharpCodeUserControl type exposes the following members.

Constructors

 | Name | Description
Public method | OverridePulseCSharpCodeUserControl | Initializes a new instance of the OverridePulseCSharpCodeUserControl class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from ContainerControl.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Control.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Control.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Nettoyage des ressources utilisées.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from UserControl.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Control.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from ContainerControl.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from UserControl.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from ContainerControl.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from ScrollableControl.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from ContainerControl.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Control.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Control.)
Public method | Show | (Inherited from Control.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Component.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from ContainerControl.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from UserControl.)

Properties

 | Name | Description
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | AllowDrop | (Inherited from Control.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | (Inherited from UserControl.)
Public property | AutoValidate | (Inherited from UserControl.)
Public property | BackColor | (Inherited from Control.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | (Inherited from UserControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Control.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Control.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMirrored | (Inherited from Control.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Control.)
Public property | Margin | (Inherited from Control.)
Public property | MaximumSize | (Inherited from Control.)
Public property | MinimumSize | (Inherited from Control.)
Public property | Name | (Inherited from Control.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Control.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabStop | (Inherited from Control.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | (Inherited from Control.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowTarget | (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | (Inherited from UserControl.)
Public event | AutoValidateChanged | (Inherited from UserControl.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from UserControl.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Control.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Control.)
Public event | TabStopChanged | (Inherited from Control.)
Public event | TextChanged | (Inherited from UserControl.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

OverridePulseCSharpCodeUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


OverridePulseCSharpCodeUserControl Constructor

Initializes a new instance of the OverridePulseCSharpCodeUserControl class.

Namespace: Quester.Profile.ProfilesCreator.EasyQuestClassUserControl
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public OverridePulseCSharpCodeUserControl(
    ref OverridePulseCSharpCodeEasyQuestClass fullCSharpCodeEasyQuestClass
)
Public Sub New ( _
    ByRef fullCSharpCodeEasyQuestClass As OverridePulseCSharpCodeEasyQuestClass _
)
public:
OverridePulseCSharpCodeUserControl(
    OverridePulseCSharpCodeEasyQuestClass^% fullCSharpCodeEasyQuestClass
)

Parameters

fullCSharpCodeEasyQuestClass
Type: Quester.Profile..::..OverridePulseCSharpCodeEasyQuestClass %
The full c sharp code easy quest class.

See Also

OverridePulseCSharpCodeUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


OverridePulseCSharpCodeUserControl Methods

The OverridePulseCSharpCodeUserControl type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from ContainerControl.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Control.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Control.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Nettoyage des ressources utilisées.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from UserControl.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Control.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from ContainerControl.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from UserControl.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from ContainerControl.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from ScrollableControl.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from ContainerControl.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Control.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Control.)
Public method | Show | (Inherited from Control.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Component.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from ContainerControl.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from UserControl.)

See Also

OverridePulseCSharpCodeUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


Dispose Method

OverridePulseCSharpCodeUserControl..::..Dispose Method

Overload List

 | Name | Description
Protected method | Dispose(Boolean) | Nettoyage des ressources utilisées.
Public method | Dispose | (Inherited from Component.)

See Also

OverridePulseCSharpCodeUserControl Class
OverridePulseCSharpCodeUserControl Members
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


Dispose Method

OverridePulseCSharpCodeUserControl..::..Dispose Method

Nettoyage des ressources utilisées.

Namespace: Quester.Profile.ProfilesCreator.EasyQuestClassUserControl
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
protected void Dispose(
    bool disposing
)
Protected Sub Dispose ( _
    disposing As Boolean _
)
protected:
void Dispose(
    bool^ disposing
)

Parameters

disposing
Type: Boolean
true si les ressources managées doivent être supprimées ; sinon, false.

See Also

OverridePulseCSharpCodeUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


OverridePulseCSharpCodeUserControl Properties

The OverridePulseCSharpCodeUserControl type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | AllowDrop | (Inherited from Control.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | (Inherited from UserControl.)
Public property | AutoValidate | (Inherited from UserControl.)
Public property | BackColor | (Inherited from Control.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | (Inherited from UserControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Control.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Control.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMirrored | (Inherited from Control.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Control.)
Public property | Margin | (Inherited from Control.)
Public property | MaximumSize | (Inherited from Control.)
Public property | MinimumSize | (Inherited from Control.)
Public property | Name | (Inherited from Control.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Control.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabStop | (Inherited from Control.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | (Inherited from Control.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowTarget | (Inherited from Control.)

See Also

OverridePulseCSharpCodeUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


OverridePulseCSharpCodeUserControl Events

The OverridePulseCSharpCodeUserControl type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | (Inherited from UserControl.)
Public event | AutoValidateChanged | (Inherited from UserControl.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from UserControl.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Control.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Control.)
Public event | TabStopChanged | (Inherited from Control.)
Public event | TextChanged | (Inherited from UserControl.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

OverridePulseCSharpCodeUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


ParallelQuestsUserControl Class

Class ParallelQuestsUserControl. Implements the UserControl

Namespace: Quester.Profile.ProfilesCreator.EasyQuestClassUserControl
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public class ParallelQuestsUserControl : UserControl
Public Class ParallelQuestsUserControl _
    Inherits UserControl
public ref class ParallelQuestsUserControl : public UserControl

Inheritance Hierarchy

Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl..::..ParallelQuestsUserControl

See Also

ParallelQuestsUserControl Members
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace
UserControl


ParallelQuestsUserControl Members

The ParallelQuestsUserControl type exposes the following members.

Constructors

 | Name | Description
Public method | ParallelQuestsUserControl | Initializes a new instance of the ParallelQuestsUserControl class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from ContainerControl.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Control.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Control.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Nettoyage des ressources utilisées.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from UserControl.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Control.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from ContainerControl.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from UserControl.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from ContainerControl.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from ScrollableControl.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from ContainerControl.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Control.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Control.)
Public method | Show | (Inherited from Control.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Component.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from ContainerControl.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from UserControl.)

Properties

 | Name | Description
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | AllowDrop | (Inherited from Control.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | (Inherited from UserControl.)
Public property | AutoValidate | (Inherited from UserControl.)
Public property | BackColor | (Inherited from Control.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | (Inherited from UserControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Control.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Control.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMirrored | (Inherited from Control.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Control.)
Public property | Margin | (Inherited from Control.)
Public property | MaximumSize | (Inherited from Control.)
Public property | MinimumSize | (Inherited from Control.)
Public property | Name | (Inherited from Control.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Control.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabStop | (Inherited from Control.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | (Inherited from Control.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowTarget | (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | (Inherited from UserControl.)
Public event | AutoValidateChanged | (Inherited from UserControl.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from UserControl.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Control.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Control.)
Public event | TabStopChanged | (Inherited from Control.)
Public event | TextChanged | (Inherited from UserControl.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

ParallelQuestsUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


ParallelQuestsUserControl Constructor

Initializes a new instance of the ParallelQuestsUserControl class.

Namespace: Quester.Profile.ProfilesCreator.EasyQuestClassUserControl
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public ParallelQuestsUserControl(
    ref ParallelQuestsEasyQuestClass fullCSharpCodeEasyQuestClass
)
Public Sub New ( _
    ByRef fullCSharpCodeEasyQuestClass As ParallelQuestsEasyQuestClass _
)
public:
ParallelQuestsUserControl(
    ParallelQuestsEasyQuestClass^% fullCSharpCodeEasyQuestClass
)

Parameters

fullCSharpCodeEasyQuestClass
Type: Quester.Profile..::..ParallelQuestsEasyQuestClass %
The full c sharp code easy quest class.

See Also

ParallelQuestsUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


ParallelQuestsUserControl Methods

The ParallelQuestsUserControl type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from ContainerControl.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Control.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Control.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Nettoyage des ressources utilisées.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from UserControl.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Control.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from ContainerControl.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from UserControl.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from ContainerControl.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from ScrollableControl.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from ContainerControl.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Control.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Control.)
Public method | Show | (Inherited from Control.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Component.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from ContainerControl.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from UserControl.)

See Also

ParallelQuestsUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


Dispose Method

ParallelQuestsUserControl..::..Dispose Method

Overload List

 | Name | Description
Protected method | Dispose(Boolean) | Nettoyage des ressources utilisées.
Public method | Dispose | (Inherited from Component.)

See Also

ParallelQuestsUserControl Class
ParallelQuestsUserControl Members
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


Dispose Method

ParallelQuestsUserControl..::..Dispose Method

Nettoyage des ressources utilisées.

Namespace: Quester.Profile.ProfilesCreator.EasyQuestClassUserControl
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
protected void Dispose(
    bool disposing
)
Protected Sub Dispose ( _
    disposing As Boolean _
)
protected:
void Dispose(
    bool^ disposing
)

Parameters

disposing
Type: Boolean
true si les ressources managées doivent être supprimées ; sinon, false.

See Also

ParallelQuestsUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


ParallelQuestsUserControl Properties

The ParallelQuestsUserControl type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | AllowDrop | (Inherited from Control.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | (Inherited from UserControl.)
Public property | AutoValidate | (Inherited from UserControl.)
Public property | BackColor | (Inherited from Control.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | (Inherited from UserControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Control.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Control.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMirrored | (Inherited from Control.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Control.)
Public property | Margin | (Inherited from Control.)
Public property | MaximumSize | (Inherited from Control.)
Public property | MinimumSize | (Inherited from Control.)
Public property | Name | (Inherited from Control.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Control.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabStop | (Inherited from Control.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | (Inherited from Control.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowTarget | (Inherited from Control.)

See Also

ParallelQuestsUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


ParallelQuestsUserControl Events

The ParallelQuestsUserControl type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | (Inherited from UserControl.)
Public event | AutoValidateChanged | (Inherited from UserControl.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from UserControl.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Control.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Control.)
Public event | TabStopChanged | (Inherited from Control.)
Public event | TextChanged | (Inherited from UserControl.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

ParallelQuestsUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


UseItemOnUserControl Class

Class UseItemOnUserControl. Implements the UserControl

Namespace: Quester.Profile.ProfilesCreator.EasyQuestClassUserControl
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public class UseItemOnUserControl : UserControl
Public Class UseItemOnUserControl _
    Inherits UserControl
public ref class UseItemOnUserControl : public UserControl

Inheritance Hierarchy

Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl..::..UseItemOnUserControl

See Also

UseItemOnUserControl Members
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace
UserControl


UseItemOnUserControl Members

The UseItemOnUserControl type exposes the following members.

Constructors

 | Name | Description
Public method | UseItemOnUserControl | Initializes a new instance of the UseItemOnUserControl class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from ContainerControl.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Control.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Control.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Nettoyage des ressources utilisées.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from UserControl.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Control.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from ContainerControl.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from UserControl.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from ContainerControl.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from ScrollableControl.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from ContainerControl.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Control.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Control.)
Public method | Show | (Inherited from Control.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Component.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from ContainerControl.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from UserControl.)

Properties

 | Name | Description
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | AllowDrop | (Inherited from Control.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | (Inherited from UserControl.)
Public property | AutoValidate | (Inherited from UserControl.)
Public property | BackColor | (Inherited from Control.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | (Inherited from UserControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Control.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Control.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMirrored | (Inherited from Control.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Control.)
Public property | Margin | (Inherited from Control.)
Public property | MaximumSize | (Inherited from Control.)
Public property | MinimumSize | (Inherited from Control.)
Public property | Name | (Inherited from Control.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Control.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabStop | (Inherited from Control.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | (Inherited from Control.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowTarget | (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | (Inherited from UserControl.)
Public event | AutoValidateChanged | (Inherited from UserControl.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from UserControl.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Control.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Control.)
Public event | TabStopChanged | (Inherited from Control.)
Public event | TextChanged | (Inherited from UserControl.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

UseItemOnUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


UseItemOnUserControl Constructor

Initializes a new instance of the UseItemOnUserControl class.

Namespace: Quester.Profile.ProfilesCreator.EasyQuestClassUserControl
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public UseItemOnUserControl(
    ref UseItemOnEasyQuestClass useItemOnEasyQuestClass
)
Public Sub New ( _
    ByRef useItemOnEasyQuestClass As UseItemOnEasyQuestClass _
)
public:
UseItemOnUserControl(
    UseItemOnEasyQuestClass^% useItemOnEasyQuestClass
)

Parameters

useItemOnEasyQuestClass
Type: Quester.Profile..::..UseItemOnEasyQuestClass %
The use item on easy quest class.

See Also

UseItemOnUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


UseItemOnUserControl Methods

The UseItemOnUserControl type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from ContainerControl.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Control.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Control.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Nettoyage des ressources utilisées.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from UserControl.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Control.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from ContainerControl.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from UserControl.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from ContainerControl.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from ScrollableControl.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from ContainerControl.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Control.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Control.)
Public method | Show | (Inherited from Control.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Component.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from ContainerControl.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from UserControl.)

See Also

UseItemOnUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


Dispose Method

UseItemOnUserControl..::..Dispose Method

Overload List

 | Name | Description
Protected method | Dispose(Boolean) | Nettoyage des ressources utilisées.
Public method | Dispose | (Inherited from Component.)

See Also

UseItemOnUserControl Class
UseItemOnUserControl Members
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


Dispose Method

UseItemOnUserControl..::..Dispose Method

Nettoyage des ressources utilisées.

Namespace: Quester.Profile.ProfilesCreator.EasyQuestClassUserControl
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
protected void Dispose(
    bool disposing
)
Protected Sub Dispose ( _
    disposing As Boolean _
)
protected:
void Dispose(
    bool^ disposing
)

Parameters

disposing
Type: Boolean
true si les ressources managées doivent être supprimées ; sinon, false.

See Also

UseItemOnUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


UseItemOnUserControl Properties

The UseItemOnUserControl type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | AllowDrop | (Inherited from Control.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | (Inherited from UserControl.)
Public property | AutoValidate | (Inherited from UserControl.)
Public property | BackColor | (Inherited from Control.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | (Inherited from UserControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Control.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Control.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMirrored | (Inherited from Control.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Control.)
Public property | Margin | (Inherited from Control.)
Public property | MaximumSize | (Inherited from Control.)
Public property | MinimumSize | (Inherited from Control.)
Public property | Name | (Inherited from Control.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Control.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabStop | (Inherited from Control.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | (Inherited from Control.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowTarget | (Inherited from Control.)

See Also

UseItemOnUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


UseItemOnUserControl Events

The UseItemOnUserControl type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | (Inherited from UserControl.)
Public event | AutoValidateChanged | (Inherited from UserControl.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from UserControl.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Control.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Control.)
Public event | TabStopChanged | (Inherited from Control.)
Public event | TextChanged | (Inherited from UserControl.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

UseItemOnUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


UseScriptOnUserControl Class

Class UseScriptOnUserControl. Implements the UserControl

Namespace: Quester.Profile.ProfilesCreator.EasyQuestClassUserControl
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public class UseScriptOnUserControl : UserControl
Public Class UseScriptOnUserControl _
    Inherits UserControl
public ref class UseScriptOnUserControl : public UserControl

Inheritance Hierarchy

Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl..::..UseScriptOnUserControl

See Also

UseScriptOnUserControl Members
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace
UserControl


UseScriptOnUserControl Members

The UseScriptOnUserControl type exposes the following members.

Constructors

 | Name | Description
Public method | UseScriptOnUserControl | Initializes a new instance of the UseScriptOnUserControl class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from ContainerControl.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Control.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Control.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Nettoyage des ressources utilisées.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from UserControl.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Control.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from ContainerControl.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from UserControl.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from ContainerControl.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from ScrollableControl.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from ContainerControl.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Control.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Control.)
Public method | Show | (Inherited from Control.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Component.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from ContainerControl.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from UserControl.)

Properties

 | Name | Description
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | AllowDrop | (Inherited from Control.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | (Inherited from UserControl.)
Public property | AutoValidate | (Inherited from UserControl.)
Public property | BackColor | (Inherited from Control.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | (Inherited from UserControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Control.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Control.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMirrored | (Inherited from Control.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Control.)
Public property | Margin | (Inherited from Control.)
Public property | MaximumSize | (Inherited from Control.)
Public property | MinimumSize | (Inherited from Control.)
Public property | Name | (Inherited from Control.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Control.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabStop | (Inherited from Control.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | (Inherited from Control.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowTarget | (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | (Inherited from UserControl.)
Public event | AutoValidateChanged | (Inherited from UserControl.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from UserControl.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Control.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Control.)
Public event | TabStopChanged | (Inherited from Control.)
Public event | TextChanged | (Inherited from UserControl.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

UseScriptOnUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


UseScriptOnUserControl Constructor

Initializes a new instance of the UseScriptOnUserControl class.

Namespace: Quester.Profile.ProfilesCreator.EasyQuestClassUserControl
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public UseScriptOnUserControl(
    ref UseScriptOnEasyQuestClass useScriptOnEasyQuestClass
)
Public Sub New ( _
    ByRef useScriptOnEasyQuestClass As UseScriptOnEasyQuestClass _
)
public:
UseScriptOnUserControl(
    UseScriptOnEasyQuestClass^% useScriptOnEasyQuestClass
)

Parameters

useScriptOnEasyQuestClass
Type: Quester.Profile..::..UseScriptOnEasyQuestClass %
The use script on easy quest class.

See Also

UseScriptOnUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


UseScriptOnUserControl Methods

The UseScriptOnUserControl type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from ContainerControl.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Control.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Control.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Nettoyage des ressources utilisées.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from UserControl.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Control.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from ContainerControl.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from UserControl.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from ContainerControl.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from ScrollableControl.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from ContainerControl.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Control.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Control.)
Public method | Show | (Inherited from Control.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Component.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from ContainerControl.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from UserControl.)

See Also

UseScriptOnUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


Dispose Method

UseScriptOnUserControl..::..Dispose Method

Overload List

 | Name | Description
Protected method | Dispose(Boolean) | Nettoyage des ressources utilisées.
Public method | Dispose | (Inherited from Component.)

See Also

UseScriptOnUserControl Class
UseScriptOnUserControl Members
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


Dispose Method

UseScriptOnUserControl..::..Dispose Method

Nettoyage des ressources utilisées.

Namespace: Quester.Profile.ProfilesCreator.EasyQuestClassUserControl
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
protected void Dispose(
    bool disposing
)
Protected Sub Dispose ( _
    disposing As Boolean _
)
protected:
void Dispose(
    bool^ disposing
)

Parameters

disposing
Type: Boolean
true si les ressources managées doivent être supprimées ; sinon, false.

See Also

UseScriptOnUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


UseScriptOnUserControl Properties

The UseScriptOnUserControl type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | AllowDrop | (Inherited from Control.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | (Inherited from UserControl.)
Public property | AutoValidate | (Inherited from UserControl.)
Public property | BackColor | (Inherited from Control.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | (Inherited from UserControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Control.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Control.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMirrored | (Inherited from Control.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Control.)
Public property | Margin | (Inherited from Control.)
Public property | MaximumSize | (Inherited from Control.)
Public property | MinimumSize | (Inherited from Control.)
Public property | Name | (Inherited from Control.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Control.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabStop | (Inherited from Control.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | (Inherited from Control.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowTarget | (Inherited from Control.)

See Also

UseScriptOnUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


UseScriptOnUserControl Events

The UseScriptOnUserControl type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | (Inherited from UserControl.)
Public event | AutoValidateChanged | (Inherited from UserControl.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from UserControl.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Control.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Control.)
Public event | TabStopChanged | (Inherited from Control.)
Public event | TextChanged | (Inherited from UserControl.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

UseScriptOnUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


UseSpellOnUserControl Class

Class UseSpellOnUserControl. Implements the UserControl

Namespace: Quester.Profile.ProfilesCreator.EasyQuestClassUserControl
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public class UseSpellOnUserControl : UserControl
Public Class UseSpellOnUserControl _
    Inherits UserControl
public ref class UseSpellOnUserControl : public UserControl

Inheritance Hierarchy

Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl..::..UseSpellOnUserControl

See Also

UseSpellOnUserControl Members
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace
UserControl


UseSpellOnUserControl Members

The UseSpellOnUserControl type exposes the following members.

Constructors

 | Name | Description
Public method | UseSpellOnUserControl | Initializes a new instance of the UseSpellOnUserControl class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from ContainerControl.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Control.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Control.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Nettoyage des ressources utilisées.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from UserControl.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Control.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from ContainerControl.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from UserControl.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from ContainerControl.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from ScrollableControl.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from ContainerControl.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Control.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Control.)
Public method | Show | (Inherited from Control.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Component.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from ContainerControl.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from UserControl.)

Properties

 | Name | Description
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | AllowDrop | (Inherited from Control.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | (Inherited from UserControl.)
Public property | AutoValidate | (Inherited from UserControl.)
Public property | BackColor | (Inherited from Control.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | (Inherited from UserControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Control.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Control.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMirrored | (Inherited from Control.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Control.)
Public property | Margin | (Inherited from Control.)
Public property | MaximumSize | (Inherited from Control.)
Public property | MinimumSize | (Inherited from Control.)
Public property | Name | (Inherited from Control.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Control.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabStop | (Inherited from Control.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | (Inherited from Control.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowTarget | (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | (Inherited from UserControl.)
Public event | AutoValidateChanged | (Inherited from UserControl.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from UserControl.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Control.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Control.)
Public event | TabStopChanged | (Inherited from Control.)
Public event | TextChanged | (Inherited from UserControl.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

UseSpellOnUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


UseSpellOnUserControl Constructor

Initializes a new instance of the UseSpellOnUserControl class.

Namespace: Quester.Profile.ProfilesCreator.EasyQuestClassUserControl
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public UseSpellOnUserControl(
    ref UseSpellOnEasyQuestClass useSpellOnEasyQuestClass
)
Public Sub New ( _
    ByRef useSpellOnEasyQuestClass As UseSpellOnEasyQuestClass _
)
public:
UseSpellOnUserControl(
    UseSpellOnEasyQuestClass^% useSpellOnEasyQuestClass
)

Parameters

useSpellOnEasyQuestClass
Type: Quester.Profile..::..UseSpellOnEasyQuestClass %
The use spell on easy quest class.

See Also

UseSpellOnUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


UseSpellOnUserControl Methods

The UseSpellOnUserControl type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from ContainerControl.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Control.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Control.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Nettoyage des ressources utilisées.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from UserControl.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Control.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from ContainerControl.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from UserControl.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from ContainerControl.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from ScrollableControl.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from ContainerControl.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Control.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Control.)
Public method | Show | (Inherited from Control.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Component.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from ContainerControl.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from UserControl.)

See Also

UseSpellOnUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


Dispose Method

UseSpellOnUserControl..::..Dispose Method

Overload List

 | Name | Description
Protected method | Dispose(Boolean) | Nettoyage des ressources utilisées.
Public method | Dispose | (Inherited from Component.)

See Also

UseSpellOnUserControl Class
UseSpellOnUserControl Members
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


Dispose Method

UseSpellOnUserControl..::..Dispose Method

Nettoyage des ressources utilisées.

Namespace: Quester.Profile.ProfilesCreator.EasyQuestClassUserControl
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
protected void Dispose(
    bool disposing
)
Protected Sub Dispose ( _
    disposing As Boolean _
)
protected:
void Dispose(
    bool^ disposing
)

Parameters

disposing
Type: Boolean
true si les ressources managées doivent être supprimées ; sinon, false.

See Also

UseSpellOnUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


UseSpellOnUserControl Properties

The UseSpellOnUserControl type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | AllowDrop | (Inherited from Control.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | (Inherited from UserControl.)
Public property | AutoValidate | (Inherited from UserControl.)
Public property | BackColor | (Inherited from Control.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | (Inherited from UserControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Control.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Control.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMirrored | (Inherited from Control.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Control.)
Public property | Margin | (Inherited from Control.)
Public property | MaximumSize | (Inherited from Control.)
Public property | MinimumSize | (Inherited from Control.)
Public property | Name | (Inherited from Control.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Control.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabStop | (Inherited from Control.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | (Inherited from Control.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowTarget | (Inherited from Control.)

See Also

UseSpellOnUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


UseSpellOnUserControl Events

The UseSpellOnUserControl type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | (Inherited from UserControl.)
Public event | AutoValidateChanged | (Inherited from UserControl.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from UserControl.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Control.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Control.)
Public event | TabStopChanged | (Inherited from Control.)
Public event | TextChanged | (Inherited from UserControl.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

UseSpellOnUserControl Class
Quester.Profile.ProfilesCreator.EasyQuestClassUserControl Namespace


Quester.Profile.Zygor Namespace

Classes

 | Class | Description
Public class | ZygorSelectGuideForm |


ZygorSelectGuideForm Class

Namespace: Quester.Profile.Zygor
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public class ZygorSelectGuideForm : Form
Public Class ZygorSelectGuideForm _
    Inherits Form
public ref class ZygorSelectGuideForm : public Form

Inheritance Hierarchy

Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
Quester.Profile.Zygor..::..ZygorSelectGuideForm

See Also

ZygorSelectGuideForm Members
Quester.Profile.Zygor Namespace


ZygorSelectGuideForm Members

The ZygorSelectGuideForm type exposes the following members.

Constructors

 | Name | Description
Public method | ZygorSelectGuideForm |

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Public method | Activate | (Inherited from Form.)
Protected method | ActivateMdiChild(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | AddOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from Form.)
Protected method | ApplyAutoScaling | (Inherited from Form.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Protected method | CenterToParent | (Inherited from Form.)
Protected method | CenterToScreen | (Inherited from Form.)
Public method | Close | (Inherited from Form.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Form.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Clean up any resources being used.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Public method | LayoutMdi(System.Windows.Forms.MdiLayout) | (Inherited from Form.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnActivated(System.EventArgs) | (Inherited from Form.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnClosed(System.EventArgs) | (Inherited from Form.)
Protected method | OnClosing(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from Form.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDeactivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Form.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnFormClosed(System.Windows.Forms.FormClosedEventArgs) | (Inherited from Form.)
Protected method | OnFormClosing(System.Windows.Forms.FormClosingEventArgs) | (Inherited from Form.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Form.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Form.)
Protected method | OnHelpButtonClicked(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInputLanguageChanged(System.Windows.Forms.InputLanguageChangedEventArgs) | (Inherited from Form.)
Protected method | OnInputLanguageChanging(System.Windows.Forms.InputLanguageChangingEventArgs) | (Inherited from Form.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from Form.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from Form.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMaximumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMdiChildActivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuComplete(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuStart(System.EventArgs) | (Inherited from Form.)
Protected method | OnMinimumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Form.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeBegin(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeEnd(System.EventArgs) | (Inherited from Form.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnShown(System.EventArgs) | (Inherited from Form.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from Form.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from Form.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from Form.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | RemoveOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from Form.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from Form.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopLocation(System.Int32,System.Int32) | (Inherited from Form.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Form.)
Public method | Show(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Public method | Show | (Inherited from Control.)
Public method | ShowDialog | (Inherited from Form.)
Public method | ShowDialog(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Form.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from Form.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from Form.)

Fields

 | Name | Description
Public field | SelectedGuide |

Properties

 | Name | Description
Public property | AcceptButton | (Inherited from Form.)
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | ActiveMdiChild | (Inherited from Form.)
Public property | AllowDrop | (Inherited from Control.)
Public property | AllowTransparency | (Inherited from Form.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScale | (Inherited from Form.)
Public property | AutoScaleBaseSize | (Inherited from Form.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from Form.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Form.)
Public property | AutoSizeMode | (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Public property | CancelButton | (Inherited from Form.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Form.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | ControlBox | (Inherited from Form.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Form.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DesktopBounds | (Inherited from Form.)
Public property | DesktopLocation | (Inherited from Form.)
Public property | DialogResult | (Inherited from Form.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | FormBorderStyle | (Inherited from Form.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HelpButton | (Inherited from Form.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | Icon | (Inherited from Form.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMdiChild | (Inherited from Form.)
Public property | IsMdiContainer | (Inherited from Form.)
Public property | IsMirrored | (Inherited from Control.)
Public property | IsRestrictedWindow | (Inherited from Form.)
Public property | KeyPreview | (Inherited from Form.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Form.)
Public property | MainMenuStrip | (Inherited from Form.)
Public property | Margin | (Inherited from Form.)
Public property | MaximizeBox | (Inherited from Form.)
Protected property | MaximizedBounds | (Inherited from Form.)
Public property | MaximumSize | (Inherited from Form.)
Public property | MdiChildren | (Inherited from Form.)
Public property | MdiParent | (Inherited from Form.)
Public property | Menu | (Inherited from Form.)
Public property | MergedMenu | (Inherited from Form.)
Public property | MinimizeBox | (Inherited from Form.)
Public property | MinimumSize | (Inherited from Form.)
Public property | Modal | (Inherited from Form.)
Public property | Name | (Inherited from Control.)
Public property | Opacity | (Inherited from Form.)
Public property | OwnedForms | (Inherited from Form.)
Public property | Owner | (Inherited from Form.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | RestoreBounds | (Inherited from Form.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Public property | RightToLeftLayout | (Inherited from Form.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | ShowIcon | (Inherited from Form.)
Public property | ShowInTaskbar | (Inherited from Form.)
Protected property | ShowWithoutActivation | (Inherited from Form.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Form.)
Public property | SizeGripStyle | (Inherited from Form.)
Public property | StartPosition | (Inherited from Form.)
Public property | TabIndex | (Inherited from Form.)
Public property | TabStop | (Inherited from Form.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | (Inherited from Control.)
Public property | TopLevel | (Inherited from Form.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | TopMost | (Inherited from Form.)
Public property | TransparencyKey | (Inherited from Form.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowState | (Inherited from Form.)
Public property | WindowTarget | (Inherited from Control.)

Events

 | Name | Description
Public event | Activated | (Inherited from Form.)
Public event | AutoSizeChanged | (Inherited from Form.)
Public event | AutoValidateChanged | (Inherited from Form.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | Closed | (Inherited from Form.)
Public event | Closing | (Inherited from Form.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Deactivate | (Inherited from Form.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | FormClosed | (Inherited from Form.)
Public event | FormClosing | (Inherited from Form.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpButtonClicked | (Inherited from Form.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | InputLanguageChanged | (Inherited from Form.)
Public event | InputLanguageChanging | (Inherited from Form.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from Form.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Form.)
Public event | MaximizedBoundsChanged | (Inherited from Form.)
Public event | MaximumSizeChanged | (Inherited from Form.)
Public event | MdiChildActivate | (Inherited from Form.)
Public event | MenuComplete | (Inherited from Form.)
Public event | MenuStart | (Inherited from Form.)
Public event | MinimumSizeChanged | (Inherited from Form.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | ResizeBegin | (Inherited from Form.)
Public event | ResizeEnd | (Inherited from Form.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | RightToLeftLayoutChanged | (Inherited from Form.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | Shown | (Inherited from Form.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Form.)
Public event | TabStopChanged | (Inherited from Form.)
Public event | TextChanged | (Inherited from Control.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

ZygorSelectGuideForm Class
Quester.Profile.Zygor Namespace


ZygorSelectGuideForm Constructor

Namespace: Quester.Profile.Zygor
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public ZygorSelectGuideForm(
    List<string> guidesNames
)
Public Sub New ( _
    guidesNames As List(Of String) _
)
public:
ZygorSelectGuideForm(
    List<String^>^ guidesNames
)

Parameters

guidesNames
Type: List <(Of <(<' String >)>)>

See Also

ZygorSelectGuideForm Class
Quester.Profile.Zygor Namespace


ZygorSelectGuideForm Fields

The ZygorSelectGuideForm type exposes the following members.

Fields

 | Name | Description
Public field | SelectedGuide |

See Also

ZygorSelectGuideForm Class
Quester.Profile.Zygor Namespace


SelectedGuide Field

ZygorSelectGuideForm..::..SelectedGuide Field

Namespace: Quester.Profile.Zygor
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public string SelectedGuide
Public SelectedGuide As String
public:
String^ SelectedGuide

See Also

ZygorSelectGuideForm Class
Quester.Profile.Zygor Namespace


ZygorSelectGuideForm Methods

The ZygorSelectGuideForm type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Public method | Activate | (Inherited from Form.)
Protected method | ActivateMdiChild(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | AddOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from Form.)
Protected method | ApplyAutoScaling | (Inherited from Form.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Protected method | CenterToParent | (Inherited from Form.)
Protected method | CenterToScreen | (Inherited from Form.)
Public method | Close | (Inherited from Form.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Form.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Clean up any resources being used.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Public method | LayoutMdi(System.Windows.Forms.MdiLayout) | (Inherited from Form.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnActivated(System.EventArgs) | (Inherited from Form.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnClosed(System.EventArgs) | (Inherited from Form.)
Protected method | OnClosing(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from Form.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDeactivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Form.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnFormClosed(System.Windows.Forms.FormClosedEventArgs) | (Inherited from Form.)
Protected method | OnFormClosing(System.Windows.Forms.FormClosingEventArgs) | (Inherited from Form.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Form.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Form.)
Protected method | OnHelpButtonClicked(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInputLanguageChanged(System.Windows.Forms.InputLanguageChangedEventArgs) | (Inherited from Form.)
Protected method | OnInputLanguageChanging(System.Windows.Forms.InputLanguageChangingEventArgs) | (Inherited from Form.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from Form.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from Form.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMaximumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMdiChildActivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuComplete(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuStart(System.EventArgs) | (Inherited from Form.)
Protected method | OnMinimumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Form.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeBegin(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeEnd(System.EventArgs) | (Inherited from Form.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnShown(System.EventArgs) | (Inherited from Form.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from Form.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from Form.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from Form.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | RemoveOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from Form.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from Form.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopLocation(System.Int32,System.Int32) | (Inherited from Form.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Form.)
Public method | Show(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Public method | Show | (Inherited from Control.)
Public method | ShowDialog | (Inherited from Form.)
Public method | ShowDialog(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Form.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from Form.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from Form.)

See Also

ZygorSelectGuideForm Class
Quester.Profile.Zygor Namespace


Dispose Method

ZygorSelectGuideForm..::..Dispose Method

Overload List

 | Name | Description
Protected method | Dispose(Boolean) | Clean up any resources being used.
Public method | Dispose | (Inherited from Component.)

See Also

ZygorSelectGuideForm Class
ZygorSelectGuideForm Members
Quester.Profile.Zygor Namespace


Dispose Method

ZygorSelectGuideForm..::..Dispose Method

Clean up any resources being used.

Namespace: Quester.Profile.Zygor
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
protected void Dispose(
    bool disposing
)
Protected Sub Dispose ( _
    disposing As Boolean _
)
protected:
void Dispose(
    bool^ disposing
)

Parameters

disposing
Type: Boolean
true if managed resources should be disposed; otherwise, false.

See Also

ZygorSelectGuideForm Class
Quester.Profile.Zygor Namespace


ZygorSelectGuideForm Properties

The ZygorSelectGuideForm type exposes the following members.

Properties

 | Name | Description
Public property | AcceptButton | (Inherited from Form.)
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | ActiveMdiChild | (Inherited from Form.)
Public property | AllowDrop | (Inherited from Control.)
Public property | AllowTransparency | (Inherited from Form.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScale | (Inherited from Form.)
Public property | AutoScaleBaseSize | (Inherited from Form.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from Form.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Form.)
Public property | AutoSizeMode | (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Public property | CancelButton | (Inherited from Form.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Form.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | ControlBox | (Inherited from Form.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Form.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DesktopBounds | (Inherited from Form.)
Public property | DesktopLocation | (Inherited from Form.)
Public property | DialogResult | (Inherited from Form.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | FormBorderStyle | (Inherited from Form.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HelpButton | (Inherited from Form.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | Icon | (Inherited from Form.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMdiChild | (Inherited from Form.)
Public property | IsMdiContainer | (Inherited from Form.)
Public property | IsMirrored | (Inherited from Control.)
Public property | IsRestrictedWindow | (Inherited from Form.)
Public property | KeyPreview | (Inherited from Form.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Form.)
Public property | MainMenuStrip | (Inherited from Form.)
Public property | Margin | (Inherited from Form.)
Public property | MaximizeBox | (Inherited from Form.)
Protected property | MaximizedBounds | (Inherited from Form.)
Public property | MaximumSize | (Inherited from Form.)
Public property | MdiChildren | (Inherited from Form.)
Public property | MdiParent | (Inherited from Form.)
Public property | Menu | (Inherited from Form.)
Public property | MergedMenu | (Inherited from Form.)
Public property | MinimizeBox | (Inherited from Form.)
Public property | MinimumSize | (Inherited from Form.)
Public property | Modal | (Inherited from Form.)
Public property | Name | (Inherited from Control.)
Public property | Opacity | (Inherited from Form.)
Public property | OwnedForms | (Inherited from Form.)
Public property | Owner | (Inherited from Form.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | RestoreBounds | (Inherited from Form.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Public property | RightToLeftLayout | (Inherited from Form.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | ShowIcon | (Inherited from Form.)
Public property | ShowInTaskbar | (Inherited from Form.)
Protected property | ShowWithoutActivation | (Inherited from Form.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Form.)
Public property | SizeGripStyle | (Inherited from Form.)
Public property | StartPosition | (Inherited from Form.)
Public property | TabIndex | (Inherited from Form.)
Public property | TabStop | (Inherited from Form.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | (Inherited from Control.)
Public property | TopLevel | (Inherited from Form.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | TopMost | (Inherited from Form.)
Public property | TransparencyKey | (Inherited from Form.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowState | (Inherited from Form.)
Public property | WindowTarget | (Inherited from Control.)

See Also

ZygorSelectGuideForm Class
Quester.Profile.Zygor Namespace


ZygorSelectGuideForm Events

The ZygorSelectGuideForm type exposes the following members.

Events

 | Name | Description
Public event | Activated | (Inherited from Form.)
Public event | AutoSizeChanged | (Inherited from Form.)
Public event | AutoValidateChanged | (Inherited from Form.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | Closed | (Inherited from Form.)
Public event | Closing | (Inherited from Form.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Deactivate | (Inherited from Form.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | FormClosed | (Inherited from Form.)
Public event | FormClosing | (Inherited from Form.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpButtonClicked | (Inherited from Form.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | InputLanguageChanged | (Inherited from Form.)
Public event | InputLanguageChanging | (Inherited from Form.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from Form.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Form.)
Public event | MaximizedBoundsChanged | (Inherited from Form.)
Public event | MaximumSizeChanged | (Inherited from Form.)
Public event | MdiChildActivate | (Inherited from Form.)
Public event | MenuComplete | (Inherited from Form.)
Public event | MenuStart | (Inherited from Form.)
Public event | MinimumSizeChanged | (Inherited from Form.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | ResizeBegin | (Inherited from Form.)
Public event | ResizeEnd | (Inherited from Form.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | RightToLeftLayoutChanged | (Inherited from Form.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | Shown | (Inherited from Form.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Form.)
Public event | TabStopChanged | (Inherited from Form.)
Public event | TextChanged | (Inherited from Control.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

ZygorSelectGuideForm Class
Quester.Profile.Zygor Namespace


Relogger Namespace

Classes

 | Class | Description
Public class | App | Logique d'interaction pour App.xaml
Public class | Events | Class Events of Relogger.
Public class | MainWindow | Class MainWindow. Implements the Window Implements the IComponentConnector Implements the IStyleConnector
Public class | ReloggerPlugin | Class ReloggerPlugin. Save plugin in the folder "WRobot\Plugins\Relogger\". Support .dll and .cs file
Public class | Utility | Class Utility.

Delegates

 | Delegate | Description
Public delegate | Events..::..ReloggerProfileCancelableHandler | Delegate ReloggerProfileCancelableHandler
Public delegate | Utility..::..EnumWindowProc | Delegate for the EnumChildWindows method

Enumerations

 | Enumeration | Description
Public enumeration | Utility..::..SetWindowPosFlags |


App Class

Logique d'interaction pour App.xaml

Namespace: Relogger
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public class App : Application
Public Class App _
    Inherits Application
public ref class App : public Application

Inheritance Hierarchy

Object
DispatcherObject
Application
Relogger..::..App

See Also

App Members
Relogger Namespace


App Members

The App type exposes the following members.

Methods

 | Name | Description
Public method | CheckAccess | (Inherited from DispatcherObject.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindResource(System.Object) | (Inherited from Application.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnActivated(System.EventArgs) | (Inherited from Application.)
Protected method | OnDeactivated(System.EventArgs) | (Inherited from Application.)
Protected method | OnExit(System.Windows.ExitEventArgs) | (Inherited from Application.)
Protected method | OnFragmentNavigation(System.Windows.Navigation.FragmentNavigationEventArgs) | (Inherited from Application.)
Protected method | OnLoadCompleted(System.Windows.Navigation.NavigationEventArgs) | (Inherited from Application.)
Protected method | OnNavigated(System.Windows.Navigation.NavigationEventArgs) | (Inherited from Application.)
Protected method | OnNavigating(System.Windows.Navigation.NavigatingCancelEventArgs) | (Inherited from Application.)
Protected method | OnNavigationFailed(System.Windows.Navigation.NavigationFailedEventArgs) | (Inherited from Application.)
Protected method | OnNavigationProgress(System.Windows.Navigation.NavigationProgressEventArgs) | (Inherited from Application.)
Protected method | OnNavigationStopped(System.Windows.Navigation.NavigationEventArgs) | (Inherited from Application.)
Protected method | OnSessionEnding(System.Windows.SessionEndingCancelEventArgs) | (Inherited from Application.)
Protected method | OnStartup(System.Windows.StartupEventArgs) | (Inherited from Application.)
Public method | Run | (Inherited from Application.)
Public method | Run(System.Windows.Window) | (Inherited from Application.)
Public method | Shutdown | (Inherited from Application.)
Public method | Shutdown(System.Int32) | (Inherited from Application.)
Public method | ToString | (Inherited from Object.)
Public method | TryFindResource(System.Object) | (Inherited from Application.)
Public method | VerifyAccess | (Inherited from DispatcherObject.)

Properties

 | Name | Description
Public property | Dispatcher | (Inherited from DispatcherObject.)
Public property | MainWindow | (Inherited from Application.)
Public property | Properties | (Inherited from Application.)
Public property | Resources | (Inherited from Application.)
Public property | ShutdownMode | (Inherited from Application.)
Public property | StartupUri | (Inherited from Application.)
Public property | Windows | (Inherited from Application.)

Events

 | Name | Description
Public event | Activated | (Inherited from Application.)
Public event | Deactivated | (Inherited from Application.)
Public event | DispatcherUnhandledException | (Inherited from Application.)
Public event | Exit | (Inherited from Application.)
Public event | FragmentNavigation | (Inherited from Application.)
Public event | LoadCompleted | (Inherited from Application.)
Public event | Navigated | (Inherited from Application.)
Public event | Navigating | (Inherited from Application.)
Public event | NavigationFailed | (Inherited from Application.)
Public event | NavigationProgress | (Inherited from Application.)
Public event | NavigationStopped | (Inherited from Application.)
Public event | SessionEnding | (Inherited from Application.)
Public event | Startup | (Inherited from Application.)

See Also

App Class
Relogger Namespace


App Methods

The App type exposes the following members.

Methods

 | Name | Description
Public method | CheckAccess | (Inherited from DispatcherObject.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindResource(System.Object) | (Inherited from Application.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnActivated(System.EventArgs) | (Inherited from Application.)
Protected method | OnDeactivated(System.EventArgs) | (Inherited from Application.)
Protected method | OnExit(System.Windows.ExitEventArgs) | (Inherited from Application.)
Protected method | OnFragmentNavigation(System.Windows.Navigation.FragmentNavigationEventArgs) | (Inherited from Application.)
Protected method | OnLoadCompleted(System.Windows.Navigation.NavigationEventArgs) | (Inherited from Application.)
Protected method | OnNavigated(System.Windows.Navigation.NavigationEventArgs) | (Inherited from Application.)
Protected method | OnNavigating(System.Windows.Navigation.NavigatingCancelEventArgs) | (Inherited from Application.)
Protected method | OnNavigationFailed(System.Windows.Navigation.NavigationFailedEventArgs) | (Inherited from Application.)
Protected method | OnNavigationProgress(System.Windows.Navigation.NavigationProgressEventArgs) | (Inherited from Application.)
Protected method | OnNavigationStopped(System.Windows.Navigation.NavigationEventArgs) | (Inherited from Application.)
Protected method | OnSessionEnding(System.Windows.SessionEndingCancelEventArgs) | (Inherited from Application.)
Protected method | OnStartup(System.Windows.StartupEventArgs) | (Inherited from Application.)
Public method | Run | (Inherited from Application.)
Public method | Run(System.Windows.Window) | (Inherited from Application.)
Public method | Shutdown | (Inherited from Application.)
Public method | Shutdown(System.Int32) | (Inherited from Application.)
Public method | ToString | (Inherited from Object.)
Public method | TryFindResource(System.Object) | (Inherited from Application.)
Public method | VerifyAccess | (Inherited from DispatcherObject.)

See Also

App Class
Relogger Namespace


App Properties

The App type exposes the following members.

Properties

 | Name | Description
Public property | Dispatcher | (Inherited from DispatcherObject.)
Public property | MainWindow | (Inherited from Application.)
Public property | Properties | (Inherited from Application.)
Public property | Resources | (Inherited from Application.)
Public property | ShutdownMode | (Inherited from Application.)
Public property | StartupUri | (Inherited from Application.)
Public property | Windows | (Inherited from Application.)

See Also

App Class
Relogger Namespace


App Events

The App type exposes the following members.

Events

 | Name | Description
Public event | Activated | (Inherited from Application.)
Public event | Deactivated | (Inherited from Application.)
Public event | DispatcherUnhandledException | (Inherited from Application.)
Public event | Exit | (Inherited from Application.)
Public event | FragmentNavigation | (Inherited from Application.)
Public event | LoadCompleted | (Inherited from Application.)
Public event | Navigated | (Inherited from Application.)
Public event | Navigating | (Inherited from Application.)
Public event | NavigationFailed | (Inherited from Application.)
Public event | NavigationProgress | (Inherited from Application.)
Public event | NavigationStopped | (Inherited from Application.)
Public event | SessionEnding | (Inherited from Application.)
Public event | Startup | (Inherited from Application.)

See Also

App Class
Relogger Namespace


Events Class

Class Events of Relogger.

Namespace: Relogger
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public static class Events
Public NotInheritable Class Events
public ref class Events abstract sealed

Inheritance Hierarchy

Object
Relogger..::..Events

See Also

Events Members
Relogger Namespace


Events Members

The Events type exposes the following members.

Methods

Name Description

Events

Name | Description
OnCloseBot | Occurs when close bot.
OnCloseGame | Occurs when close game.
OnStartBot | Occurs when start bot.
OnStartGame | Occurs when start game.

See Also

Events Class
Relogger Namespace


Events Methods

The Events type exposes the following members.

Methods

Name Description

See Also

Events Class
Relogger Namespace


Events Events

The Events type exposes the following members.

Events

Name | Description
OnCloseBot | Occurs when close bot.
OnCloseGame | Occurs when close game.
OnStartBot | Occurs when start bot.
OnStartGame | Occurs when start game.

See Also

Events Class
Relogger Namespace


OnCloseBot Event

Events..::..OnCloseBot Event

Occurs when close bot.

Namespace: Relogger
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public static event Events..::..ReloggerProfileCancelableHandler OnCloseBot
Public Shared Event OnCloseBot As Events..::..ReloggerProfileCancelableHandler
public:
static  event Events..::..ReloggerProfileCancelableHandler^ OnCloseBot {
    void add (Events..::..ReloggerProfileCancelableHandler^ value);
    void remove (Events..::..ReloggerProfileCancelableHandler^ value);
}

See Also

Events Class
Relogger Namespace


OnCloseGame Event

Events..::..OnCloseGame Event

Occurs when close game.

Namespace: Relogger
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public static event Events..::..ReloggerProfileCancelableHandler OnCloseGame
Public Shared Event OnCloseGame As Events..::..ReloggerProfileCancelableHandler
public:
static  event Events..::..ReloggerProfileCancelableHandler^ OnCloseGame {
    void add (Events..::..ReloggerProfileCancelableHandler^ value);
    void remove (Events..::..ReloggerProfileCancelableHandler^ value);
}

See Also

Events Class
Relogger Namespace


OnStartBot Event

Events..::..OnStartBot Event

Occurs when start bot.

Namespace: Relogger
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public static event Events..::..ReloggerProfileCancelableHandler OnStartBot
Public Shared Event OnStartBot As Events..::..ReloggerProfileCancelableHandler
public:
static  event Events..::..ReloggerProfileCancelableHandler^ OnStartBot {
    void add (Events..::..ReloggerProfileCancelableHandler^ value);
    void remove (Events..::..ReloggerProfileCancelableHandler^ value);
}

See Also

Events Class
Relogger Namespace


OnStartGame Event

Events..::..OnStartGame Event

Occurs when start game.

Namespace: Relogger
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public static event Events..::..ReloggerProfileCancelableHandler OnStartGame
Public Shared Event OnStartGame As Events..::..ReloggerProfileCancelableHandler
public:
static  event Events..::..ReloggerProfileCancelableHandler^ OnStartGame {
    void add (Events..::..ReloggerProfileCancelableHandler^ value);
    void remove (Events..::..ReloggerProfileCancelableHandler^ value);
}

See Also

Events Class
Relogger Namespace


Events.ReloggerProfileCancelableHandler Delegate

Events..::..ReloggerProfileCancelableHandler Delegate

Delegate ReloggerProfileCancelableHandler

Namespace: Relogger
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public delegate void ReloggerProfileCancelableHandler(
    ReloggerProfile profile,
    CancelEventArgs cancelable
)
Public Delegate Sub ReloggerProfileCancelableHandler ( _
    profile As ReloggerProfile, _
    cancelable As CancelEventArgs _
)
public delegate void ReloggerProfileCancelableHandler(
    ReloggerProfile^ profile,
    CancelEventArgs^ cancelable
)

Parameters

profile
Type: Relogger.Classes..::..ReloggerProfile
The profile.
cancelable
Type: CancelEventArgs
The CancelEventArgs instance containing the event data.

See Also

Relogger Namespace


MainWindow Class

Class MainWindow. Implements the Window Implements the IComponentConnector Implements the IStyleConnector

Namespace: Relogger
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
[ObfuscationAttribute]
public class MainWindow : Window
<ObfuscationAttribute> _
Public Class MainWindow _
    Inherits Window
[ObfuscationAttribute]
public ref class MainWindow : public Window

Inheritance Hierarchy

Object
DispatcherObject
DependencyObject
Visual
UIElement
FrameworkElement
Control
ContentControl
Window
Relogger..::..MainWindow

See Also

MainWindow Members
Relogger Namespace
Window
IComponentConnector
IStyleConnector


MainWindow Members

The MainWindow type exposes the following members.

Constructors

 | Name | Description
Public method | MainWindow | Initializes a new instance of the MainWindow class.

Methods

 | Name | Description
Public method | Activate | (Inherited from Window.)
Protected method | AddChild(System.Object) | (Inherited from ContentControl.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate,System.Boolean) | (Inherited from UIElement.)
Protected method | AddText(System.String) | (Inherited from ContentControl.)
Public method | AddToEventRoute(System.Windows.EventRoute,System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | AddVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock) | (Inherited from UIElement.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from FrameworkElement.)
Public method | Arrange(System.Windows.Rect) | (Inherited from UIElement.)
Protected method | ArrangeCore(System.Windows.Rect) | (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(System.Windows.Size) | (Inherited from Window.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline) | (Inherited from UIElement.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | BeginInit | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior,System.Boolean) | (Inherited from FrameworkElement.)
Public method | BringIntoView | (Inherited from FrameworkElement.)
Public method | BringIntoView(System.Windows.Rect) | (Inherited from FrameworkElement.)
Public method | CaptureMouse | (Inherited from UIElement.)
Public method | CaptureStylus | (Inherited from UIElement.)
Public method | CaptureTouch(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DispatcherObject.)
Public method | ClearValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | ClearValue(System.Windows.DependencyPropertyKey) | (Inherited from DependencyObject.)
Public method | Close | (Inherited from Window.)
Public method | CoerceValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | DragMove | (Inherited from Window.)
Public method | EndInit | (Inherited from FrameworkElement.)
Public method | Equals(System.Object) | (Inherited from DependencyObject.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindCommonVisualAncestor(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | FindName(System.String) | (Inherited from FrameworkElement.)
Public method | FindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from UIElement.)
Public method | GetAnimationBaseValue(System.Windows.DependencyProperty) | (Inherited from UIElement.)
Public method | GetBindingExpression(System.Windows.DependencyProperty) | (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from DependencyObject.)
Protected method | GetLayoutClip(System.Windows.Size) | (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | (Inherited from DependencyObject.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Protected method | GetVisualChild(System.Int32) | (Inherited from FrameworkElement.)
Public method | Hide | (Inherited from Window.)
Protected method | HitTestCore(System.Windows.Media.PointHitTestParameters) | (Inherited from UIElement.)
Protected method | HitTestCore(System.Windows.Media.GeometryHitTestParameters) | (Inherited from UIElement.)
Public method | InputHitTest(System.Windows.Point) | (Inherited from UIElement.)
Public method | InvalidateArrange | (Inherited from UIElement.)
Public method | InvalidateMeasure | (Inherited from UIElement.)
Public method | InvalidateProperty(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | InvalidateVisual | (Inherited from UIElement.)
Public method | IsAncestorOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | IsDescendantOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | Measure(System.Windows.Size) | (Inherited from UIElement.)
Protected method | MeasureCore(System.Windows.Size) | (Inherited from FrameworkElement.)
Protected method | MeasureOverride(System.Windows.Size) | (Inherited from Window.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | MoveFocus(System.Windows.Input.TraversalRequest) | (Inherited from FrameworkElement.)
Protected method | OnAccessKey(System.Windows.Input.AccessKeyEventArgs) | (Inherited from UIElement.)
Protected method | OnActivated(System.EventArgs) | (Inherited from Window.)
Public method | OnApplyTemplate | (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged(System.Windows.UIElement) | (Inherited from UIElement.)
Protected method | OnClosed(System.EventArgs) | (Inherited from Window.)
Protected method | OnClosing(System.ComponentModel.CancelEventArgs) | (Inherited from Window.)
Protected method | OnContentChanged(System.Object,System.Object) | (Inherited from Window.)
Protected method | OnContentRendered(System.EventArgs) | (Inherited from Window.)
Protected method | OnContentStringFormatChanged(System.String,System.String) | (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged(System.Windows.DataTemplate,System.Windows.DataTemplate) | (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged(System.Windows.Controls.DataTemplateSelector,System.Windows.Controls.DataTemplateSelector) | (Inherited from ContentControl.)
Protected method | OnContextMenuClosing(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | (Inherited from Window.)
Protected method | OnDeactivated(System.EventArgs) | (Inherited from Window.)
Protected method | OnDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnGotFocus(System.Windows.RoutedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnGotMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnGotStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnGotTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnInitialized(System.EventArgs) | (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Window.)
Protected method | OnLostFocus(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnLostStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnLostTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback(System.Windows.Input.ManipulationBoundaryFeedbackEventArgs) | (Inherited from Window.)
Protected method | OnManipulationCompleted(System.Windows.Input.ManipulationCompletedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationDelta(System.Windows.Input.ManipulationDeltaEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting(System.Windows.Input.ManipulationInertiaStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarted(System.Windows.Input.ManipulationStartedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarting(System.Windows.Input.ManipulationStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseEnter(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeave(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnPreviewMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPropertyChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnQueryCursor(System.Windows.Input.QueryCursorEventArgs) | (Inherited from UIElement.)
Protected method | OnRender(System.Windows.Media.DrawingContext) | (Inherited from UIElement.)
Protected method | OnSourceInitialized(System.EventArgs) | (Inherited from Window.)
Protected method | OnStateChanged(System.EventArgs) | (Inherited from Window.)
Protected method | OnStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusEnter(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusLeave(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnTemplateChanged(System.Windows.Controls.ControlTemplate,System.Windows.Controls.ControlTemplate) | (Inherited from Control.)
Protected method | OnTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnToolTipClosing(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchEnter(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchLeave(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Public method | PointFromScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PointToScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PredictFocus(System.Windows.Input.FocusNavigationDirection) | (Inherited from FrameworkElement.)
Public method | RaiseEvent(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Public method | ReadLocalValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | RegisterName(System.String,System.Object) | (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | (Inherited from UIElement.)
Public method | ReleaseMouseCapture | (Inherited from UIElement.)
Public method | ReleaseStylusCapture | (Inherited from UIElement.)
Public method | ReleaseTouchCapture(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | RemoveHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Protected method | RemoveVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | SetBinding(System.Windows.DependencyProperty,System.Windows.Data.BindingBase) | (Inherited from FrameworkElement.)
Public method | SetBinding(System.Windows.DependencyProperty,System.String) | (Inherited from FrameworkElement.)
Public method | SetCurrentValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetResourceReference(System.Windows.DependencyProperty,System.Object) | (Inherited from FrameworkElement.)
Public method | SetValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetValue(System.Windows.DependencyPropertyKey,System.Object) | (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | (Inherited from UIElement.)
Public method | ShouldSerializeContent | (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | (Inherited from UIElement.)
Public method | ShouldSerializeResources | (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | (Inherited from FrameworkElement.)
Public method | Show | (Inherited from Window.)
Public method | ShowDialog | (Inherited from Window.)
Public method | ToString | (Inherited from Control.)
Public method | TransformToAncestor(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToAncestor(System.Windows.Media.Media3D.Visual3D) | (Inherited from Visual.)
Public method | TransformToDescendant(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToVisual(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TranslatePoint(System.Windows.Point,System.Windows.UIElement) | (Inherited from UIElement.)
Public method | TryFindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | UnregisterName(System.String) | (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | (Inherited from FrameworkElement.)
Public method | UpdateLayout | (Inherited from UIElement.)
Public method | VerifyAccess | (Inherited from DispatcherObject.)

Properties

 | Name | Description
Public property | ActualHeight | (Inherited from FrameworkElement.)
Public property | ActualWidth | (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from UIElement.)
Public property | AllowsTransparency | (Inherited from Window.)
Public property | AreAnyTouchesCaptured | (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
Public property | AreAnyTouchesOver | (Inherited from UIElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from FrameworkElement.)
Public property | BitmapEffect | (Inherited from UIElement.)
Public property | BitmapEffectInput | (Inherited from UIElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | (Inherited from UIElement.)
Public property | ClipToBounds | (Inherited from UIElement.)
Public property | CommandBindings | (Inherited from UIElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContentTemplate | (Inherited from ContentControl.)
Public property | ContentTemplateSelector | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from FrameworkElement.)
Public property | Cursor | (Inherited from FrameworkElement.)
Public property | DataContext | (Inherited from FrameworkElement.)
Public property | DependencyObjectType | (Inherited from DependencyObject.)
Public property | DesiredSize | (Inherited from UIElement.)
Public property | DialogResult | (Inherited from Window.)
Public property | Dispatcher | (Inherited from DispatcherObject.)
Public property | Effect | (Inherited from UIElement.)
Public property | FlowDirection | (Inherited from FrameworkElement.)
Public property | Focusable | (Inherited from UIElement.)
Public property | FocusVisualStyle | (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from FrameworkElement.)
Public property | Foreground | (Inherited from Control.)
Public property | GeneralSettings | Gets or sets the general settings.
Public property | HasAnimatedProperties | (Inherited from UIElement.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Icon | (Inherited from Window.)
Public property | InputBindings | (Inherited from UIElement.)
Public property | InputScope | (Inherited from FrameworkElement.)
Public property | IsActive | (Inherited from Window.)
Public property | IsArrangeValid | (Inherited from UIElement.)
Public property | IsEnabled | (Inherited from UIElement.)
Protected property | IsEnabledCore | (Inherited from UIElement.)
Public property | IsFocused | (Inherited from UIElement.)
Public property | IsHitTestVisible | (Inherited from UIElement.)
Public property | IsInitialized | (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | (Inherited from UIElement.)
Public property | IsKeyboardFocused | (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | (Inherited from UIElement.)
Public property | IsLoaded | (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | (Inherited from UIElement.)
Public property | IsMeasureValid | (Inherited from UIElement.)
Public property | IsMouseCaptured | (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | (Inherited from UIElement.)
Public property | IsMouseOver | (Inherited from UIElement.)
Public property | IsSealed | (Inherited from DependencyObject.)
Public property | IsStylusCaptured | (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | (Inherited from UIElement.)
Public property | IsStylusOver | (Inherited from UIElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsVisible | (Inherited from UIElement.)
Public property | Language | (Inherited from FrameworkElement.)
Public property | LayoutTransform | (Inherited from FrameworkElement.)
Public property | Left | (Inherited from Window.)
Public property | Margin | (Inherited from FrameworkElement.)
Public property | MaxHeight | (Inherited from FrameworkElement.)
Public property | MaxWidth | (Inherited from FrameworkElement.)
Public property | MinHeight | (Inherited from FrameworkElement.)
Public property | MinWidth | (Inherited from FrameworkElement.)
Public property | Name | (Inherited from FrameworkElement.)
Public property | Opacity | (Inherited from UIElement.)
Public property | OpacityMask | (Inherited from UIElement.)
Public property | OverridesDefaultStyle | (Inherited from FrameworkElement.)
Public property | OwnedWindows | (Inherited from Window.)
Public property | Owner | (Inherited from Window.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from FrameworkElement.)
Public property | PersistId | (Inherited from UIElement.)
Public property | Profiles | Gets or sets the profiles.
Public property | RenderSize | (Inherited from UIElement.)
Public property | RenderTransform | (Inherited from UIElement.)
Public property | RenderTransformOrigin | (Inherited from UIElement.)
Public property | ResizeMode | (Inherited from Window.)
Public property | Resources | (Inherited from FrameworkElement.)
Public property | RestoreBounds | (Inherited from Window.)
Public property | ShowActivated | (Inherited from Window.)
Public property | ShowInTaskbar | (Inherited from Window.)
Public property | SizeToContent | (Inherited from Window.)
Public property | SnapsToDevicePixels | (Inherited from UIElement.)
Public property | Style | (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | (Inherited from UIElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | Tag | (Inherited from FrameworkElement.)
Public property | TaskbarItemInfo | (Inherited from Window.)
Public property | Template | (Inherited from Control.)
Public property | TemplatedParent | (Inherited from FrameworkElement.)
Public property | Title | (Inherited from Window.)
Public property | ToolTip | (Inherited from FrameworkElement.)
Public property | Top | (Inherited from Window.)
Public property | Topmost | (Inherited from Window.)
Public property | TouchesCaptured | (Inherited from UIElement.)
Public property | TouchesCapturedWithin | (Inherited from UIElement.)
Public property | TouchesDirectlyOver | (Inherited from UIElement.)
Public property | TouchesOver | (Inherited from UIElement.)
Public property | Triggers | (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from UIElement.)
Public property | UseLayoutRounding | (Inherited from FrameworkElement.)
Public property | VerticalAlignment | (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | (Inherited from UIElement.)
Protected property | VisualChildrenCount | (Inherited from FrameworkElement.)
Protected property | VisualParent | (Inherited from Visual.)
Public property | Width | (Inherited from FrameworkElement.)
Public property | WindowStartupLocation | (Inherited from Window.)
Public property | WindowState | (Inherited from Window.)
Public property | WindowStyle | (Inherited from Window.)

Events

 | Name | Description
Public event | Activated | (Inherited from Window.)
Public event | Closed | (Inherited from Window.)
Public event | Closing | (Inherited from Window.)
Public event | ContentRendered | (Inherited from Window.)
Public event | ContextMenuClosing | (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | (Inherited from FrameworkElement.)
Public event | DataContextChanged | (Inherited from FrameworkElement.)
Public event | Deactivated | (Inherited from Window.)
Public event | DragEnter | (Inherited from UIElement.)
Public event | DragLeave | (Inherited from UIElement.)
Public event | DragOver | (Inherited from UIElement.)
Public event | Drop | (Inherited from UIElement.)
Public event | FocusableChanged | (Inherited from UIElement.)
Public event | GiveFeedback | (Inherited from UIElement.)
Public event | GotFocus | (Inherited from UIElement.)
Public event | GotKeyboardFocus | (Inherited from UIElement.)
Public event | GotMouseCapture | (Inherited from UIElement.)
Public event | GotStylusCapture | (Inherited from UIElement.)
Public event | GotTouchCapture | (Inherited from UIElement.)
Public event | Initialized | (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsVisibleChanged | (Inherited from UIElement.)
Public event | KeyDown | (Inherited from UIElement.)
Public event | KeyUp | (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from UIElement.)
Public event | Loaded | (Inherited from FrameworkElement.)
Public event | LocationChanged | (Inherited from Window.)
Public event | LostFocus | (Inherited from UIElement.)
Public event | LostKeyboardFocus | (Inherited from UIElement.)
Public event | LostMouseCapture | (Inherited from UIElement.)
Public event | LostStylusCapture | (Inherited from UIElement.)
Public event | LostTouchCapture | (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | ManipulationStarting | (Inherited from UIElement.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from UIElement.)
Public event | MouseEnter | (Inherited from UIElement.)
Public event | MouseLeave | (Inherited from UIElement.)
Public event | MouseLeftButtonDown | (Inherited from UIElement.)
Public event | MouseLeftButtonUp | (Inherited from UIElement.)
Public event | MouseMove | (Inherited from UIElement.)
Public event | MouseRightButtonDown | (Inherited from UIElement.)
Public event | MouseRightButtonUp | (Inherited from UIElement.)
Public event | MouseUp | (Inherited from UIElement.)
Public event | MouseWheel | (Inherited from UIElement.)
Public event | PreviewDragEnter | (Inherited from UIElement.)
Public event | PreviewDragLeave | (Inherited from UIElement.)
Public event | PreviewDragOver | (Inherited from UIElement.)
Public event | PreviewDrop | (Inherited from UIElement.)
Public event | PreviewGiveFeedback | (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewKeyDown | (Inherited from UIElement.)
Public event | PreviewKeyUp | (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | (Inherited from Control.)
Public event | PreviewMouseDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseMove | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseUp | (Inherited from UIElement.)
Public event | PreviewMouseWheel | (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | (Inherited from UIElement.)
Public event | PreviewStylusDown | (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | (Inherited from UIElement.)
Public event | PreviewStylusInRange | (Inherited from UIElement.)
Public event | PreviewStylusMove | (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | (Inherited from UIElement.)
Public event | PreviewStylusUp | (Inherited from UIElement.)
Public event | PreviewTextInput | (Inherited from UIElement.)
Public event | PreviewTouchDown | (Inherited from UIElement.)
Public event | PreviewTouchMove | (Inherited from UIElement.)
Public event | PreviewTouchUp | (Inherited from UIElement.)
Public event | QueryContinueDrag | (Inherited from UIElement.)
Public event | QueryCursor | (Inherited from UIElement.)
Public event | RequestBringIntoView | (Inherited from FrameworkElement.)
Public event | SizeChanged | (Inherited from FrameworkElement.)
Public event | SourceInitialized | (Inherited from Window.)
Public event | SourceUpdated | (Inherited from FrameworkElement.)
Public event | StateChanged | (Inherited from Window.)
Public event | StylusButtonDown | (Inherited from UIElement.)
Public event | StylusButtonUp | (Inherited from UIElement.)
Public event | StylusDown | (Inherited from UIElement.)
Public event | StylusEnter | (Inherited from UIElement.)
Public event | StylusInAirMove | (Inherited from UIElement.)
Public event | StylusInRange | (Inherited from UIElement.)
Public event | StylusLeave | (Inherited from UIElement.)
Public event | StylusMove | (Inherited from UIElement.)
Public event | StylusOutOfRange | (Inherited from UIElement.)
Public event | StylusSystemGesture | (Inherited from UIElement.)
Public event | StylusUp | (Inherited from UIElement.)
Public event | TargetUpdated | (Inherited from FrameworkElement.)
Public event | TextInput | (Inherited from UIElement.)
Public event | ToolTipClosing | (Inherited from FrameworkElement.)
Public event | ToolTipOpening | (Inherited from FrameworkElement.)
Public event | TouchDown | (Inherited from UIElement.)
Public event | TouchEnter | (Inherited from UIElement.)
Public event | TouchLeave | (Inherited from UIElement.)
Public event | TouchMove | (Inherited from UIElement.)
Public event | TouchUp | (Inherited from UIElement.)
Public event | Unloaded | (Inherited from FrameworkElement.)

See Also

MainWindow Class
Relogger Namespace


MainWindow Constructor

Initializes a new instance of the MainWindow class.

Namespace: Relogger
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public MainWindow()
Public Sub New
public:
MainWindow()

See Also

MainWindow Class
Relogger Namespace


MainWindow Methods

The MainWindow type exposes the following members.

Methods

 | Name | Description
Public method | Activate | (Inherited from Window.)
Protected method | AddChild(System.Object) | (Inherited from ContentControl.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate,System.Boolean) | (Inherited from UIElement.)
Protected method | AddText(System.String) | (Inherited from ContentControl.)
Public method | AddToEventRoute(System.Windows.EventRoute,System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | AddVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock) | (Inherited from UIElement.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from FrameworkElement.)
Public method | Arrange(System.Windows.Rect) | (Inherited from UIElement.)
Protected method | ArrangeCore(System.Windows.Rect) | (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(System.Windows.Size) | (Inherited from Window.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline) | (Inherited from UIElement.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | BeginInit | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior,System.Boolean) | (Inherited from FrameworkElement.)
Public method | BringIntoView | (Inherited from FrameworkElement.)
Public method | BringIntoView(System.Windows.Rect) | (Inherited from FrameworkElement.)
Public method | CaptureMouse | (Inherited from UIElement.)
Public method | CaptureStylus | (Inherited from UIElement.)
Public method | CaptureTouch(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DispatcherObject.)
Public method | ClearValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | ClearValue(System.Windows.DependencyPropertyKey) | (Inherited from DependencyObject.)
Public method | Close | (Inherited from Window.)
Public method | CoerceValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | DragMove | (Inherited from Window.)
Public method | EndInit | (Inherited from FrameworkElement.)
Public method | Equals(System.Object) | (Inherited from DependencyObject.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindCommonVisualAncestor(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | FindName(System.String) | (Inherited from FrameworkElement.)
Public method | FindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from UIElement.)
Public method | GetAnimationBaseValue(System.Windows.DependencyProperty) | (Inherited from UIElement.)
Public method | GetBindingExpression(System.Windows.DependencyProperty) | (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from DependencyObject.)
Protected method | GetLayoutClip(System.Windows.Size) | (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | (Inherited from DependencyObject.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Protected method | GetVisualChild(System.Int32) | (Inherited from FrameworkElement.)
Public method | Hide | (Inherited from Window.)
Protected method | HitTestCore(System.Windows.Media.PointHitTestParameters) | (Inherited from UIElement.)
Protected method | HitTestCore(System.Windows.Media.GeometryHitTestParameters) | (Inherited from UIElement.)
Public method | InputHitTest(System.Windows.Point) | (Inherited from UIElement.)
Public method | InvalidateArrange | (Inherited from UIElement.)
Public method | InvalidateMeasure | (Inherited from UIElement.)
Public method | InvalidateProperty(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | InvalidateVisual | (Inherited from UIElement.)
Public method | IsAncestorOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | IsDescendantOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | Measure(System.Windows.Size) | (Inherited from UIElement.)
Protected method | MeasureCore(System.Windows.Size) | (Inherited from FrameworkElement.)
Protected method | MeasureOverride(System.Windows.Size) | (Inherited from Window.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | MoveFocus(System.Windows.Input.TraversalRequest) | (Inherited from FrameworkElement.)
Protected method | OnAccessKey(System.Windows.Input.AccessKeyEventArgs) | (Inherited from UIElement.)
Protected method | OnActivated(System.EventArgs) | (Inherited from Window.)
Public method | OnApplyTemplate | (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged(System.Windows.UIElement) | (Inherited from UIElement.)
Protected method | OnClosed(System.EventArgs) | (Inherited from Window.)
Protected method | OnClosing(System.ComponentModel.CancelEventArgs) | (Inherited from Window.)
Protected method | OnContentChanged(System.Object,System.Object) | (Inherited from Window.)
Protected method | OnContentRendered(System.EventArgs) | (Inherited from Window.)
Protected method | OnContentStringFormatChanged(System.String,System.String) | (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged(System.Windows.DataTemplate,System.Windows.DataTemplate) | (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged(System.Windows.Controls.DataTemplateSelector,System.Windows.Controls.DataTemplateSelector) | (Inherited from ContentControl.)
Protected method | OnContextMenuClosing(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | (Inherited from Window.)
Protected method | OnDeactivated(System.EventArgs) | (Inherited from Window.)
Protected method | OnDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnGotFocus(System.Windows.RoutedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnGotMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnGotStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnGotTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnInitialized(System.EventArgs) | (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Window.)
Protected method | OnLostFocus(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnLostStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnLostTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback(System.Windows.Input.ManipulationBoundaryFeedbackEventArgs) | (Inherited from Window.)
Protected method | OnManipulationCompleted(System.Windows.Input.ManipulationCompletedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationDelta(System.Windows.Input.ManipulationDeltaEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting(System.Windows.Input.ManipulationInertiaStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarted(System.Windows.Input.ManipulationStartedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarting(System.Windows.Input.ManipulationStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseEnter(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeave(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnPreviewMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPropertyChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnQueryCursor(System.Windows.Input.QueryCursorEventArgs) | (Inherited from UIElement.)
Protected method | OnRender(System.Windows.Media.DrawingContext) | (Inherited from UIElement.)
Protected method | OnSourceInitialized(System.EventArgs) | (Inherited from Window.)
Protected method | OnStateChanged(System.EventArgs) | (Inherited from Window.)
Protected method | OnStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusEnter(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusLeave(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnTemplateChanged(System.Windows.Controls.ControlTemplate,System.Windows.Controls.ControlTemplate) | (Inherited from Control.)
Protected method | OnTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnToolTipClosing(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchEnter(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchLeave(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Public method | PointFromScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PointToScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PredictFocus(System.Windows.Input.FocusNavigationDirection) | (Inherited from FrameworkElement.)
Public method | RaiseEvent(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Public method | ReadLocalValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | RegisterName(System.String,System.Object) | (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | (Inherited from UIElement.)
Public method | ReleaseMouseCapture | (Inherited from UIElement.)
Public method | ReleaseStylusCapture | (Inherited from UIElement.)
Public method | ReleaseTouchCapture(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | RemoveHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Protected method | RemoveVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | SetBinding(System.Windows.DependencyProperty,System.Windows.Data.BindingBase) | (Inherited from FrameworkElement.)
Public method | SetBinding(System.Windows.DependencyProperty,System.String) | (Inherited from FrameworkElement.)
Public method | SetCurrentValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetResourceReference(System.Windows.DependencyProperty,System.Object) | (Inherited from FrameworkElement.)
Public method | SetValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetValue(System.Windows.DependencyPropertyKey,System.Object) | (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | (Inherited from UIElement.)
Public method | ShouldSerializeContent | (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | (Inherited from UIElement.)
Public method | ShouldSerializeResources | (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | (Inherited from FrameworkElement.)
Public method | Show | (Inherited from Window.)
Public method | ShowDialog | (Inherited from Window.)
Public method | ToString | (Inherited from Control.)
Public method | TransformToAncestor(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToAncestor(System.Windows.Media.Media3D.Visual3D) | (Inherited from Visual.)
Public method | TransformToDescendant(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToVisual(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TranslatePoint(System.Windows.Point,System.Windows.UIElement) | (Inherited from UIElement.)
Public method | TryFindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | UnregisterName(System.String) | (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | (Inherited from FrameworkElement.)
Public method | UpdateLayout | (Inherited from UIElement.)
Public method | VerifyAccess | (Inherited from DispatcherObject.)

See Also

MainWindow Class
Relogger Namespace


MainWindow Properties

The MainWindow type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | (Inherited from FrameworkElement.)
Public property | ActualWidth | (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from UIElement.)
Public property | AllowsTransparency | (Inherited from Window.)
Public property | AreAnyTouchesCaptured | (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
Public property | AreAnyTouchesOver | (Inherited from UIElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from FrameworkElement.)
Public property | BitmapEffect | (Inherited from UIElement.)
Public property | BitmapEffectInput | (Inherited from UIElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | (Inherited from UIElement.)
Public property | ClipToBounds | (Inherited from UIElement.)
Public property | CommandBindings | (Inherited from UIElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContentTemplate | (Inherited from ContentControl.)
Public property | ContentTemplateSelector | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from FrameworkElement.)
Public property | Cursor | (Inherited from FrameworkElement.)
Public property | DataContext | (Inherited from FrameworkElement.)
Public property | DependencyObjectType | (Inherited from DependencyObject.)
Public property | DesiredSize | (Inherited from UIElement.)
Public property | DialogResult | (Inherited from Window.)
Public property | Dispatcher | (Inherited from DispatcherObject.)
Public property | Effect | (Inherited from UIElement.)
Public property | FlowDirection | (Inherited from FrameworkElement.)
Public property | Focusable | (Inherited from UIElement.)
Public property | FocusVisualStyle | (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from FrameworkElement.)
Public property | Foreground | (Inherited from Control.)
Public property | GeneralSettings | Gets or sets the general settings.
Public property | HasAnimatedProperties | (Inherited from UIElement.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Icon | (Inherited from Window.)
Public property | InputBindings | (Inherited from UIElement.)
Public property | InputScope | (Inherited from FrameworkElement.)
Public property | IsActive | (Inherited from Window.)
Public property | IsArrangeValid | (Inherited from UIElement.)
Public property | IsEnabled | (Inherited from UIElement.)
Protected property | IsEnabledCore | (Inherited from UIElement.)
Public property | IsFocused | (Inherited from UIElement.)
Public property | IsHitTestVisible | (Inherited from UIElement.)
Public property | IsInitialized | (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | (Inherited from UIElement.)
Public property | IsKeyboardFocused | (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | (Inherited from UIElement.)
Public property | IsLoaded | (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | (Inherited from UIElement.)
Public property | IsMeasureValid | (Inherited from UIElement.)
Public property | IsMouseCaptured | (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | (Inherited from UIElement.)
Public property | IsMouseOver | (Inherited from UIElement.)
Public property | IsSealed | (Inherited from DependencyObject.)
Public property | IsStylusCaptured | (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | (Inherited from UIElement.)
Public property | IsStylusOver | (Inherited from UIElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsVisible | (Inherited from UIElement.)
Public property | Language | (Inherited from FrameworkElement.)
Public property | LayoutTransform | (Inherited from FrameworkElement.)
Public property | Left | (Inherited from Window.)
Public property | Margin | (Inherited from FrameworkElement.)
Public property | MaxHeight | (Inherited from FrameworkElement.)
Public property | MaxWidth | (Inherited from FrameworkElement.)
Public property | MinHeight | (Inherited from FrameworkElement.)
Public property | MinWidth | (Inherited from FrameworkElement.)
Public property | Name | (Inherited from FrameworkElement.)
Public property | Opacity | (Inherited from UIElement.)
Public property | OpacityMask | (Inherited from UIElement.)
Public property | OverridesDefaultStyle | (Inherited from FrameworkElement.)
Public property | OwnedWindows | (Inherited from Window.)
Public property | Owner | (Inherited from Window.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from FrameworkElement.)
Public property | PersistId | (Inherited from UIElement.)
Public property | Profiles | Gets or sets the profiles.
Public property | RenderSize | (Inherited from UIElement.)
Public property | RenderTransform | (Inherited from UIElement.)
Public property | RenderTransformOrigin | (Inherited from UIElement.)
Public property | ResizeMode | (Inherited from Window.)
Public property | Resources | (Inherited from FrameworkElement.)
Public property | RestoreBounds | (Inherited from Window.)
Public property | ShowActivated | (Inherited from Window.)
Public property | ShowInTaskbar | (Inherited from Window.)
Public property | SizeToContent | (Inherited from Window.)
Public property | SnapsToDevicePixels | (Inherited from UIElement.)
Public property | Style | (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | (Inherited from UIElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | Tag | (Inherited from FrameworkElement.)
Public property | TaskbarItemInfo | (Inherited from Window.)
Public property | Template | (Inherited from Control.)
Public property | TemplatedParent | (Inherited from FrameworkElement.)
Public property | Title | (Inherited from Window.)
Public property | ToolTip | (Inherited from FrameworkElement.)
Public property | Top | (Inherited from Window.)
Public property | Topmost | (Inherited from Window.)
Public property | TouchesCaptured | (Inherited from UIElement.)
Public property | TouchesCapturedWithin | (Inherited from UIElement.)
Public property | TouchesDirectlyOver | (Inherited from UIElement.)
Public property | TouchesOver | (Inherited from UIElement.)
Public property | Triggers | (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from UIElement.)
Public property | UseLayoutRounding | (Inherited from FrameworkElement.)
Public property | VerticalAlignment | (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | (Inherited from UIElement.)
Protected property | VisualChildrenCount | (Inherited from FrameworkElement.)
Protected property | VisualParent | (Inherited from Visual.)
Public property | Width | (Inherited from FrameworkElement.)
Public property | WindowStartupLocation | (Inherited from Window.)
Public property | WindowState | (Inherited from Window.)
Public property | WindowStyle | (Inherited from Window.)

See Also

MainWindow Class
Relogger Namespace


GeneralSettings Property

MainWindow..::..GeneralSettings Property

Gets or sets the general settings.

Namespace: Relogger
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public ReloggerGeneralSettings GeneralSettings { get; set; }
Public Property GeneralSettings As ReloggerGeneralSettings
    Get
    Set
public:
property ReloggerGeneralSettings^ GeneralSettings {
    ReloggerGeneralSettings^ get ();
    void set (ReloggerGeneralSettings^ value);
}

Field Value

The general settings.

See Also

MainWindow Class
Relogger Namespace


Profiles Property

MainWindow..::..Profiles Property

Gets or sets the profiles.

Namespace: Relogger
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public List<ReloggerProfile> Profiles { get; set; }
Public Property Profiles As List(Of ReloggerProfile)
    Get
    Set
public:
property List<ReloggerProfile^>^ Profiles {
    List<ReloggerProfile^>^ get ();
    void set (List<ReloggerProfile^>^ value);
}

Field Value

The profiles.

See Also

MainWindow Class
Relogger Namespace


MainWindow Events

The MainWindow type exposes the following members.

Events

 | Name | Description
Public event | Activated | (Inherited from Window.)
Public event | Closed | (Inherited from Window.)
Public event | Closing | (Inherited from Window.)
Public event | ContentRendered | (Inherited from Window.)
Public event | ContextMenuClosing | (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | (Inherited from FrameworkElement.)
Public event | DataContextChanged | (Inherited from FrameworkElement.)
Public event | Deactivated | (Inherited from Window.)
Public event | DragEnter | (Inherited from UIElement.)
Public event | DragLeave | (Inherited from UIElement.)
Public event | DragOver | (Inherited from UIElement.)
Public event | Drop | (Inherited from UIElement.)
Public event | FocusableChanged | (Inherited from UIElement.)
Public event | GiveFeedback | (Inherited from UIElement.)
Public event | GotFocus | (Inherited from UIElement.)
Public event | GotKeyboardFocus | (Inherited from UIElement.)
Public event | GotMouseCapture | (Inherited from UIElement.)
Public event | GotStylusCapture | (Inherited from UIElement.)
Public event | GotTouchCapture | (Inherited from UIElement.)
Public event | Initialized | (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsVisibleChanged | (Inherited from UIElement.)
Public event | KeyDown | (Inherited from UIElement.)
Public event | KeyUp | (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from UIElement.)
Public event | Loaded | (Inherited from FrameworkElement.)
Public event | LocationChanged | (Inherited from Window.)
Public event | LostFocus | (Inherited from UIElement.)
Public event | LostKeyboardFocus | (Inherited from UIElement.)
Public event | LostMouseCapture | (Inherited from UIElement.)
Public event | LostStylusCapture | (Inherited from UIElement.)
Public event | LostTouchCapture | (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | ManipulationStarting | (Inherited from UIElement.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from UIElement.)
Public event | MouseEnter | (Inherited from UIElement.)
Public event | MouseLeave | (Inherited from UIElement.)
Public event | MouseLeftButtonDown | (Inherited from UIElement.)
Public event | MouseLeftButtonUp | (Inherited from UIElement.)
Public event | MouseMove | (Inherited from UIElement.)
Public event | MouseRightButtonDown | (Inherited from UIElement.)
Public event | MouseRightButtonUp | (Inherited from UIElement.)
Public event | MouseUp | (Inherited from UIElement.)
Public event | MouseWheel | (Inherited from UIElement.)
Public event | PreviewDragEnter | (Inherited from UIElement.)
Public event | PreviewDragLeave | (Inherited from UIElement.)
Public event | PreviewDragOver | (Inherited from UIElement.)
Public event | PreviewDrop | (Inherited from UIElement.)
Public event | PreviewGiveFeedback | (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewKeyDown | (Inherited from UIElement.)
Public event | PreviewKeyUp | (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | (Inherited from Control.)
Public event | PreviewMouseDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseMove | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseUp | (Inherited from UIElement.)
Public event | PreviewMouseWheel | (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | (Inherited from UIElement.)
Public event | PreviewStylusDown | (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | (Inherited from UIElement.)
Public event | PreviewStylusInRange | (Inherited from UIElement.)
Public event | PreviewStylusMove | (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | (Inherited from UIElement.)
Public event | PreviewStylusUp | (Inherited from UIElement.)
Public event | PreviewTextInput | (Inherited from UIElement.)
Public event | PreviewTouchDown | (Inherited from UIElement.)
Public event | PreviewTouchMove | (Inherited from UIElement.)
Public event | PreviewTouchUp | (Inherited from UIElement.)
Public event | QueryContinueDrag | (Inherited from UIElement.)
Public event | QueryCursor | (Inherited from UIElement.)
Public event | RequestBringIntoView | (Inherited from FrameworkElement.)
Public event | SizeChanged | (Inherited from FrameworkElement.)
Public event | SourceInitialized | (Inherited from Window.)
Public event | SourceUpdated | (Inherited from FrameworkElement.)
Public event | StateChanged | (Inherited from Window.)
Public event | StylusButtonDown | (Inherited from UIElement.)
Public event | StylusButtonUp | (Inherited from UIElement.)
Public event | StylusDown | (Inherited from UIElement.)
Public event | StylusEnter | (Inherited from UIElement.)
Public event | StylusInAirMove | (Inherited from UIElement.)
Public event | StylusInRange | (Inherited from UIElement.)
Public event | StylusLeave | (Inherited from UIElement.)
Public event | StylusMove | (Inherited from UIElement.)
Public event | StylusOutOfRange | (Inherited from UIElement.)
Public event | StylusSystemGesture | (Inherited from UIElement.)
Public event | StylusUp | (Inherited from UIElement.)
Public event | TargetUpdated | (Inherited from FrameworkElement.)
Public event | TextInput | (Inherited from UIElement.)
Public event | ToolTipClosing | (Inherited from FrameworkElement.)
Public event | ToolTipOpening | (Inherited from FrameworkElement.)
Public event | TouchDown | (Inherited from UIElement.)
Public event | TouchEnter | (Inherited from UIElement.)
Public event | TouchLeave | (Inherited from UIElement.)
Public event | TouchMove | (Inherited from UIElement.)
Public event | TouchUp | (Inherited from UIElement.)
Public event | Unloaded | (Inherited from FrameworkElement.)

See Also

MainWindow Class
Relogger Namespace


ReloggerPlugin Class

Class ReloggerPlugin. Save plugin in the folder "WRobot\Plugins\Relogger\". Support .dll and .cs file

Namespace: Relogger
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public abstract class ReloggerPlugin
Public MustInherit Class ReloggerPlugin
public ref class ReloggerPlugin abstract

Examples

C#
using System;
   using System.Windows.Forms;

   namespace MyNamespace
   {
       public class MyPlugin : Relogger.ReloggerPlugin
       {
           public override string Name { get { return "My test plugin"; } }

           bool IsRunning { get; set; }

           public override void OnStart()
           {
               IsRunning = true;
               while (IsRunning)
               {
                   try
                   {
                       for (int i = 0; i < Relogger.Classes.ReloggerGeneralSettings.CurrentSetting.Profiles.Count; i++)
                       {
                           var p = Relogger.Classes.ReloggerGeneralSettings.CurrentSetting.Profiles[i];
                           if (p.Status == Relogger.Classes.Status.Running && p.ExistWowProcess() && p.ExistWRobotProcess())
                           {
                               robotManager.Helpful.Logging.Write(Name + " > Wow pid = " + p.WowProcessId() + " - Bot pid = " + p.WRobotProcessId());
                           }
                       }
                   }
                   catch (Exception e)
                   {
                       robotManager.Helpful.Logging.WriteError(Name + " > " + e);
                   }
                   System.Threading.Thread.Sleep(500);
               }
           }
           public override void OnStop()
           {
               IsRunning = false;
           }

           public override void OnButtonPress()
           {
               MessageBox.Show("TEST");
               base.OnButtonPress();
           }
       }
   }

Inheritance Hierarchy

Object
Relogger..::..ReloggerPlugin

See Also

ReloggerPlugin Members
Relogger Namespace


ReloggerPlugin Members

The ReloggerPlugin type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
 | LoadPlugin | Loads plugin.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OnButtonPress | Called when this plugin button is pressed.
Public method | OnStart | Called when open relogger.
Public method | OnStop | Called when close relogger.
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Name | Gets the plugin name.
 | Plugins | Gets list of loaded plugins.

See Also

ReloggerPlugin Class
Relogger Namespace


ReloggerPlugin Methods

The ReloggerPlugin type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
 | LoadPlugin | Loads plugin.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OnButtonPress | Called when this plugin button is pressed.
Public method | OnStart | Called when open relogger.
Public method | OnStop | Called when close relogger.
Public method | ToString | (Inherited from Object.)

See Also

ReloggerPlugin Class
Relogger Namespace


LoadPlugin Method

ReloggerPlugin..::..LoadPlugin Method

Loads plugin.

Namespace: Relogger
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public static Nullable<ReloggerPlugin> LoadPlugin(
    string pathOrUrl
)
Public Shared Function LoadPlugin ( _
    pathOrUrl As String _
) As Nullable(Of ReloggerPlugin)
public:
static Nullable<ReloggerPlugin^> LoadPlugin(
    String^ pathOrUrl
)

Parameters

pathOrUrl
Type: String
The path (file .cs or .dll) or URL.

Return Value

System.Nullable<ReloggerPlugin>.

See Also

ReloggerPlugin Class
Relogger Namespace


OnButtonPress Method

ReloggerPlugin..::..OnButtonPress Method

Called when this plugin button is pressed.

Namespace: Relogger
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public virtual void OnButtonPress()
Public Overridable Sub OnButtonPress
public:
virtual void OnButtonPress()

See Also

ReloggerPlugin Class
Relogger Namespace


OnStart Method

ReloggerPlugin..::..OnStart Method

Called when open relogger.

Namespace: Relogger
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public void OnStart()
Public Sub OnStart
public:
void OnStart()

See Also

ReloggerPlugin Class
Relogger Namespace


OnStop Method

ReloggerPlugin..::..OnStop Method

Called when close relogger.

Namespace: Relogger
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public void OnStop()
Public Sub OnStop
public:
void OnStop()

See Also

ReloggerPlugin Class
Relogger Namespace


ReloggerPlugin Properties

The ReloggerPlugin type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets the plugin name.
 | Plugins | Gets list of loaded plugins.

See Also

ReloggerPlugin Class
Relogger Namespace


Name Property

ReloggerPlugin..::..Name Property

Gets the plugin name.

Namespace: Relogger
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}

Field Value

The name.

See Also

ReloggerPlugin Class
Relogger Namespace


Plugins Property

ReloggerPlugin..::..Plugins Property

Gets list of loaded plugins.

Namespace: Relogger
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public static List<ReloggerPlugin> Plugins { get; }
Public Shared ReadOnly Property Plugins As List(Of ReloggerPlugin)
    Get
public:
static property List<ReloggerPlugin^>^ Plugins {
    List<ReloggerPlugin^>^ get ();
}

Field Value

The plugins.

See Also

ReloggerPlugin Class
Relogger Namespace


Utility Class

Class Utility.

Namespace: Relogger
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public static class Utility
Public NotInheritable Class Utility
public ref class Utility abstract sealed

Inheritance Hierarchy

Object
Relogger..::..Utility

See Also

Utility Members
Relogger Namespace


Utility Members

The Utility type exposes the following members.

Methods

Name | Description
EnumerateProcessWindowHandles | Enumerates the process window handles.
GetWindowText(IntPtr) | Gets the window text.
MinMaxTime | Min/Max time string to double.
MinMaxTimeValid | Min/max time is valid.
Ping | Pings the specified address.
ResizeAndMoveWindow(Process, Rectangle) | Resizes and move window.
ResizeAndMoveWindow(IntPtr, Int32, Int32, Int32, Int32) | Resizes the and move window.

See Also

Utility Class
Relogger Namespace


Utility Methods

The Utility type exposes the following members.

Methods

Name | Description
EnumerateProcessWindowHandles | Enumerates the process window handles.
GetWindowText(IntPtr) | Gets the window text.
MinMaxTime | Min/Max time string to double.
MinMaxTimeValid | Min/max time is valid.
Ping | Pings the specified address.
ResizeAndMoveWindow(Process, Rectangle) | Resizes and move window.
ResizeAndMoveWindow(IntPtr, Int32, Int32, Int32, Int32) | Resizes the and move window.

See Also

Utility Class
Relogger Namespace


EnumerateProcessWindowHandles Method

Utility..::..EnumerateProcessWindowHandles Method

Enumerates the process window handles.

Namespace: Relogger
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public static List<IntPtr> EnumerateProcessWindowHandles(
    int processId
)
Public Shared Function EnumerateProcessWindowHandles ( _
    processId As Integer _
) As List(Of IntPtr)
public:
static List<IntPtr^>^ EnumerateProcessWindowHandles(
    int^ processId
)

Parameters

processId
Type: Int32
The process identifier.

Return Value

List<IntPtr>.

See Also

Utility Class
Relogger Namespace


GetWindowText Method (IntPtr)

Utility..::..GetWindowText Method (IntPtr)

Gets the window text.

Namespace: Relogger
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public static string GetWindowText(
    IntPtr hWnd
)
Public Shared Function GetWindowText ( _
    hWnd As IntPtr _
) As String
public:
static String^ GetWindowText(
    IntPtr^ hWnd
)

Parameters

hWnd
Type: IntPtr
A handle to the window.

Return Value

System.String.

See Also

Utility Class
GetWindowText Overload
Relogger Namespace


MinMaxTime Method

Utility..::..MinMaxTime Method

Min/Max time string to double.

Namespace: Relogger
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public static Tuple<double, double> MinMaxTime(
    string time
)
Public Shared Function MinMaxTime ( _
    time As String _
) As Tuple(Of Double, Double)
public:
static Tuple<double^, double^>^ MinMaxTime(
    String^ time
)

Parameters

time
Type: String
time value like "60-70".

Return Value

Tuple<System.Double, System.Double>.

See Also

Utility Class
Relogger Namespace


MinMaxTimeValid Method

Utility..::..MinMaxTimeValid Method

Min/max time is valid.

Namespace: Relogger
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public static bool MinMaxTimeValid(
    string time
)
Public Shared Function MinMaxTimeValid ( _
    time As String _
) As Boolean
public:
static bool^ MinMaxTimeValid(
    String^ time
)

Parameters

time
Type: String
time value like "60-70"

Return Value

true if valid, false otherwise.

See Also

Utility Class
Relogger Namespace


Ping Method

Utility..::..Ping Method

Pings the specified address.

Namespace: Relogger
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public static bool Ping(
    string address
)
Public Shared Function Ping ( _
    address As String _
) As Boolean
public:
static bool^ Ping(
    String^ address
)

Parameters

address
Type: String
Url like "google.com".

Return Value

true if can ping, false otherwise.

See Also

Utility Class
Relogger Namespace


ResizeAndMoveWindow Method

Utility..::..ResizeAndMoveWindow Method

Overload List

Name | Description
ResizeAndMoveWindow(Process, Rectangle) | Resizes and move window.
ResizeAndMoveWindow(IntPtr, Int32, Int32, Int32, Int32) | Resizes the and move window.

See Also

Utility Class
Utility Members
Relogger Namespace


ResizeAndMoveWindow Method (Process, Rectangle)

Utility..::..ResizeAndMoveWindow Method (Process, Rectangle)

Resizes and move window.

Namespace: Relogger
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public static void ResizeAndMoveWindow(
    Process process,
    Rectangle rectangle
)
Public Shared Sub ResizeAndMoveWindow ( _
    process As Process, _
    rectangle As Rectangle _
)
public:
static void ResizeAndMoveWindow(
    Process^ process,
    Rectangle^ rectangle
)

Parameters

process
Type: Process
The process.
rectangle
Type: Rectangle
The rectangle.

See Also

Utility Class
ResizeAndMoveWindow Overload
Relogger Namespace


ResizeAndMoveWindow Method (IntPtr, Int32, Int32, Int32, Int32)

Utility..::..ResizeAndMoveWindow Method (IntPtr, Int32, Int32, Int32, Int32)

Resizes the and move window.

Namespace: Relogger
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public static void ResizeAndMoveWindow(
    IntPtr hWnd,
    int x,
    int y,
    int width,
    int height
)
Public Shared Sub ResizeAndMoveWindow ( _
    hWnd As IntPtr, _
    x As Integer, _
    y As Integer, _
    width As Integer, _
    height As Integer _
)
public:
static void ResizeAndMoveWindow(
    IntPtr^ hWnd,
    int^ x,
    int^ y,
    int^ width,
    int^ height
)

Parameters

hWnd
Type: IntPtr
A handle to the window.
x
Type: Int32
x.
y
Type: Int32
y.
width
Type: Int32
The width.
height
Type: Int32
The height.

See Also

Utility Class
ResizeAndMoveWindow Overload
Relogger Namespace


Utility.EnumWindowProc Delegate

Utility..::..EnumWindowProc Delegate

Delegate for the EnumChildWindows method

Namespace: Relogger
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public delegate bool EnumWindowProc(
    IntPtr hWnd,
    IntPtr parameter
)
Public Delegate Function EnumWindowProc ( _
    hWnd As IntPtr, _
    parameter As IntPtr _
) As Boolean
public delegate bool^ EnumWindowProc(
    IntPtr^ hWnd,
    IntPtr^ parameter
)

Parameters

hWnd
Type: IntPtr
Window handle
parameter
Type: IntPtr
Caller-defined variable; we use it for a pointer to our list

Return Value

True to continue enumerating, false to bail.

See Also

Relogger Namespace


Utility.SetWindowPosFlags Enumeration

Utility..::..SetWindowPosFlags Enumeration

Namespace: Relogger
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
[FlagsAttribute]
public enum SetWindowPosFlags
<FlagsAttribute> _
Public Enumeration SetWindowPosFlags
[FlagsAttribute]
public enum class SetWindowPosFlags

Members

Member name | Description
SWP_ASYNCWINDOWPOS | If the calling thread and the thread that owns the window are attached to different input queues, the system posts the request to the thread that owns the window. This prevents the calling thread from blocking its execution while other threads process the request.
SWP_DEFERERASE | Prevents generation of the WM_SYNCPAINT message.
SWP_DRAWFRAME | Draws a frame (defined in the window's class description) around the window.
SWP_FRAMECHANGED | Applies new frame styles set using the SetWindowLong function. Sends a WM_NCCALCSIZE message to the window, even if the window's size is not being changed. If this flag is not specified, WM_NCCALCSIZE is sent only when the window's size is being changed.
SWP_HIDEWINDOW | Hides the window.
SWP_NOACTIVATE | Does not activate the window. If this flag is not set, the window is activated and moved to the top of either the topmost or non-topmost group (depending on the setting of the hWndInsertAfter parameter).
SWP_NOCOPYBITS | Discards the entire contents of the client area. If this flag is not specified, the valid contents of the client area are saved and copied back into the client area after the window is sized or repositioned.
SWP_NOMOVE | Retains the current position (ignores X and Y parameters).
SWP_NOOWNERZORDER | Does not change the owner window's position in the Z order.
SWP_NOREDRAW | Does not redraw changes. If this flag is set, no repainting of any kind occurs. This applies to the client area, the nonclient area (including the title bar and scroll bars), and any part of the parent window uncovered as a result of the window being moved. When this flag is set, the application must explicitly invalidate or redraw any parts of the window and parent window that need redrawing.
SWP_NOREPOSITION | Same as the SWP_NOOWNERZORDER flag.
SWP_NOSENDCHANGING | Prevents the window from receiving the WM_WINDOWPOSCHANGING message.
SWP_NOSIZE | Retains the current size (ignores the cx and cy parameters).
SWP_NOZORDER | Retains the current Z order (ignores the hWndInsertAfter parameter).
SWP_SHOWWINDOW | Displays the window.

See Also

Relogger Namespace


Relogger.Classes Namespace

Classes

 | Class | Description
Public class | BaseReloggerTask | Class BaseReloggerTask.
Public class | ChangeCharacterReloggerTask | Class ChangeCharacterReloggerTask. Implements the BaseReloggerTask
Public class | ChangeWowPathReloggerTask | Class ChangeWowPathReloggerTask. Implements the BaseReloggerTask
Public class | ChangeWRobotLicenseKeyReloggerTask | Class ChangeWRobotLicenseKeyReloggerTask. Implements the BaseReloggerTask
Public class | ChangeWRobotPathReloggerTask | Class ChangeWRobotPathReloggerTask. Implements the BaseReloggerTask
Public class | ReloggerGeneralSettings | Class ReloggerGeneralSettings. Implements the Settings
Public class | ReloggerProfile | Class ReloggerProfile.
Public class | ReloggerProfileSettings | Class ReloggerProfileSettings.
Public class | ReloggerTask | Class ReloggerTask, adaptator of classes that inherit of BaseReloggerTask.
Public class | RunReloggerTask | Class RunReloggerTask. Implements the BaseReloggerTask
Public class | WaitReloggerTask | Class WaitReloggerTask. Implements the BaseReloggerTask

Enumerations

 | Enumeration | Description
Public enumeration | Status | Profile status
Public enumeration | TaskType | Tasks type


BaseReloggerTask Class

Class BaseReloggerTask.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
[SerializableAttribute]
[XmlIncludeAttribute]
[XmlIncludeAttribute]
[XmlIncludeAttribute]
[XmlIncludeAttribute]
[XmlIncludeAttribute]
[XmlIncludeAttribute]
[ObfuscationAttribute]
public class BaseReloggerTask
<SerializableAttribute> _
<XmlIncludeAttribute> _
<XmlIncludeAttribute> _
<XmlIncludeAttribute> _
<XmlIncludeAttribute> _
<XmlIncludeAttribute> _
<XmlIncludeAttribute> _
<ObfuscationAttribute> _
Public Class BaseReloggerTask
[SerializableAttribute]
[XmlIncludeAttribute]
[XmlIncludeAttribute]
[XmlIncludeAttribute]
[XmlIncludeAttribute]
[XmlIncludeAttribute]
[XmlIncludeAttribute]
[ObfuscationAttribute]
public ref class BaseReloggerTask

Inheritance Hierarchy

Object
Relogger.Classes..::..BaseReloggerTask

See Also

BaseReloggerTask Members
Relogger.Classes Namespace


BaseReloggerTask Members

The BaseReloggerTask type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetErrors | Gets settings errors.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs task.
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValid | Returns true if is valid.
Public property | TaskType | Gets the type of the task.
Public property | UserControlWpf | Gets or sets the user control.

See Also

BaseReloggerTask Class
Relogger.Classes Namespace


BaseReloggerTask Methods

The BaseReloggerTask type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetErrors | Gets settings errors.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs task.
Public method | ToString | (Inherited from Object.)

See Also

BaseReloggerTask Class
Relogger.Classes Namespace


GetErrors Method

BaseReloggerTask..::..GetErrors Method

Gets settings errors.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public virtual List<string> GetErrors()
Public Overridable Function GetErrors As List(Of String)
public:
virtual List<String^>^ GetErrors()

Return Value

List<System.String>.

See Also

BaseReloggerTask Class
Relogger.Classes Namespace


Run Method

BaseReloggerTask..::..Run Method

Runs task.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public virtual void Run(
    ReloggerProfile parent
)
Public Overridable Sub Run ( _
    parent As ReloggerProfile _
)
public:
virtual void Run(
    ReloggerProfile^ parent
)

Parameters

parent
Type: Relogger.Classes..::..ReloggerProfile
profile that contain this task.

See Also

BaseReloggerTask Class
Relogger.Classes Namespace


BaseReloggerTask Properties

The BaseReloggerTask type exposes the following members.

Properties

 | Name | Description
Public property | IsValid | Returns true if is valid.
Public property | TaskType | Gets the type of the task.
Public property | UserControlWpf | Gets or sets the user control.

See Also

BaseReloggerTask Class
Relogger.Classes Namespace


IsValid Property

BaseReloggerTask..::..IsValid Property

Returns true if is valid.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public bool IsValid { get; }
Public ReadOnly Property IsValid As Boolean
    Get
public:
property bool^ IsValid {
    bool^ get ();
}

Field Value

true if this instance is valid; otherwise, false.

See Also

BaseReloggerTask Class
Relogger.Classes Namespace


TaskType Property

BaseReloggerTask..::..TaskType Property

Gets the type of the task.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public virtual TaskType TaskType { get; }
Public Overridable ReadOnly Property TaskType As TaskType
    Get
public:
virtual property TaskType^ TaskType {
    TaskType^ get ();
}

Field Value

The type of the task.

See Also

BaseReloggerTask Class
Relogger.Classes Namespace


UserControlWpf Property

BaseReloggerTask..::..UserControlWpf Property

Gets or sets the user control.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
[XmlIgnoreAttribute]
public UserControl UserControlWpf { get; set; }
<XmlIgnoreAttribute> _
Public Property UserControlWpf As UserControl
    Get
    Set
[XmlIgnoreAttribute]
public:
property UserControl^ UserControlWpf {
    UserControl^ get ();
    void set (UserControl^ value);
}

Field Value

The WPF UserControl.

See Also

BaseReloggerTask Class
Relogger.Classes Namespace


ChangeCharacterReloggerTask Class

Class ChangeCharacterReloggerTask. Implements the BaseReloggerTask

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
[SerializableAttribute]
[ObfuscationAttribute]
public class ChangeCharacterReloggerTask : BaseReloggerTask
<SerializableAttribute> _
<ObfuscationAttribute> _
Public Class ChangeCharacterReloggerTask _
    Inherits BaseReloggerTask
[SerializableAttribute]
[ObfuscationAttribute]
public ref class ChangeCharacterReloggerTask : public BaseReloggerTask

Inheritance Hierarchy

Object
Relogger.Classes..::..BaseReloggerTask
Relogger.Classes..::..ChangeCharacterReloggerTask

See Also

ChangeCharacterReloggerTask Members
Relogger.Classes Namespace
Relogger.Classes..::..BaseReloggerTask


ChangeCharacterReloggerTask Members

The ChangeCharacterReloggerTask type exposes the following members.

Constructors

 | Name | Description
Public method | ChangeCharacterReloggerTask | Initializes a new instance of the ChangeCharacterReloggerTask class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetErrors | Gets settings errors.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs task.
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | AccountName | Gets or sets the name of the account.
Public property | BattleNet | Gets or sets account email or name.
Public property | Character | Gets or sets the character name.
Public property | IsValid | Returns true if is valid. (Inherited from BaseReloggerTask.)
Public property | Password | Gets or sets the password.
Public property | PasswordCrypted | Gets or sets the password crypted.
Public property | Server | Gets or sets the realm name.
Public property | TaskType | Gets the type of the task.
Public property | UserControlWpf | Gets or sets the user control. (Inherited from BaseReloggerTask.)

See Also

ChangeCharacterReloggerTask Class
Relogger.Classes Namespace


ChangeCharacterReloggerTask Constructor

Initializes a new instance of the ChangeCharacterReloggerTask class.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public ChangeCharacterReloggerTask()
Public Sub New
public:
ChangeCharacterReloggerTask()

See Also

ChangeCharacterReloggerTask Class
Relogger.Classes Namespace


ChangeCharacterReloggerTask Methods

The ChangeCharacterReloggerTask type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetErrors | Gets settings errors.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs task.
Public method | ToString | (Inherited from Object.)

See Also

ChangeCharacterReloggerTask Class
Relogger.Classes Namespace


GetErrors Method

ChangeCharacterReloggerTask..::..GetErrors Method

Gets settings errors.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public List<string> GetErrors()
Public Function GetErrors As List(Of String)
public:
List<String^>^ GetErrors()

Return Value

List<System.String>.

See Also

ChangeCharacterReloggerTask Class
Relogger.Classes Namespace


Run Method

ChangeCharacterReloggerTask..::..Run Method

Runs task.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public void Run(
    ReloggerProfile parent
)
Public Sub Run ( _
    parent As ReloggerProfile _
)
public:
void Run(
    ReloggerProfile^ parent
)

Parameters

parent
Type: Relogger.Classes..::..ReloggerProfile
profile that contain this task.

See Also

ChangeCharacterReloggerTask Class
Relogger.Classes Namespace


ChangeCharacterReloggerTask Properties

The ChangeCharacterReloggerTask type exposes the following members.

Properties

 | Name | Description
Public property | AccountName | Gets or sets the name of the account.
Public property | BattleNet | Gets or sets account email or name.
Public property | Character | Gets or sets the character name.
Public property | IsValid | Returns true if is valid. (Inherited from BaseReloggerTask.)
Public property | Password | Gets or sets the password.
Public property | PasswordCrypted | Gets or sets the password crypted.
Public property | Server | Gets or sets the realm name.
Public property | TaskType | Gets the type of the task.
Public property | UserControlWpf | Gets or sets the user control. (Inherited from BaseReloggerTask.)

See Also

ChangeCharacterReloggerTask Class
Relogger.Classes Namespace


AccountName Property

ChangeCharacterReloggerTask..::..AccountName Property

Gets or sets the name of the account.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public string AccountName { get; set; }
Public Property AccountName As String
    Get
    Set
public:
property String^ AccountName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the account.

See Also

ChangeCharacterReloggerTask Class
Relogger.Classes Namespace


BattleNet Property

ChangeCharacterReloggerTask..::..BattleNet Property

Gets or sets account email or name.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public string BattleNet { get; set; }
Public Property BattleNet As String
    Get
    Set
public:
property String^ BattleNet {
    String^ get ();
    void set (String^ value);
}

Field Value

The battle net.

See Also

ChangeCharacterReloggerTask Class
Relogger.Classes Namespace


Character Property

ChangeCharacterReloggerTask..::..Character Property

Gets or sets the character name.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public string Character { get; set; }
Public Property Character As String
    Get
    Set
public:
property String^ Character {
    String^ get ();
    void set (String^ value);
}

Field Value

The character name.

See Also

ChangeCharacterReloggerTask Class
Relogger.Classes Namespace


Password Property

ChangeCharacterReloggerTask..::..Password Property

Gets or sets the password.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
[XmlIgnoreAttribute]
public string Password { get; set; }
<XmlIgnoreAttribute> _
Public Property Password As String
    Get
    Set
[XmlIgnoreAttribute]
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

Field Value

The password.

See Also

ChangeCharacterReloggerTask Class
Relogger.Classes Namespace


PasswordCrypted Property

ChangeCharacterReloggerTask..::..PasswordCrypted Property

Gets or sets the password crypted.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public string PasswordCrypted { get; set; }
Public Property PasswordCrypted As String
    Get
    Set
public:
property String^ PasswordCrypted {
    String^ get ();
    void set (String^ value);
}

Field Value

The password crypted.

See Also

ChangeCharacterReloggerTask Class
Relogger.Classes Namespace


Server Property

ChangeCharacterReloggerTask..::..Server Property

Gets or sets the realm name.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public string Server { get; set; }
Public Property Server As String
    Get
    Set
public:
property String^ Server {
    String^ get ();
    void set (String^ value);
}

Field Value

The realm name.

See Also

ChangeCharacterReloggerTask Class
Relogger.Classes Namespace


TaskType Property

ChangeCharacterReloggerTask..::..TaskType Property

Gets the type of the task.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public TaskType TaskType { get; }
Public ReadOnly Property TaskType As TaskType
    Get
public:
property TaskType^ TaskType {
    TaskType^ get ();
}

Field Value

The type of the task.

See Also

ChangeCharacterReloggerTask Class
Relogger.Classes Namespace


ChangeWowPathReloggerTask Class

Class ChangeWowPathReloggerTask. Implements the BaseReloggerTask

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
[SerializableAttribute]
[ObfuscationAttribute]
public class ChangeWowPathReloggerTask : BaseReloggerTask
<SerializableAttribute> _
<ObfuscationAttribute> _
Public Class ChangeWowPathReloggerTask _
    Inherits BaseReloggerTask
[SerializableAttribute]
[ObfuscationAttribute]
public ref class ChangeWowPathReloggerTask : public BaseReloggerTask

Inheritance Hierarchy

Object
Relogger.Classes..::..BaseReloggerTask
Relogger.Classes..::..ChangeWowPathReloggerTask

See Also

ChangeWowPathReloggerTask Members
Relogger.Classes Namespace
Relogger.Classes..::..BaseReloggerTask


ChangeWowPathReloggerTask Members

The ChangeWowPathReloggerTask type exposes the following members.

Constructors

 | Name | Description
Public method | ChangeWowPathReloggerTask | Initializes a new instance of the ChangeWowPathReloggerTask class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetErrors | Gets settings errors.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs task.
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValid | Returns true if is valid. (Inherited from BaseReloggerTask.)
Public property | TaskType | Gets the type of the task.
Public property | UserControlWpf | Gets or sets the user control. (Inherited from BaseReloggerTask.)
Public property | WowPath | Gets or sets the wow path.

See Also

ChangeWowPathReloggerTask Class
Relogger.Classes Namespace


ChangeWowPathReloggerTask Constructor

Initializes a new instance of the ChangeWowPathReloggerTask class.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public ChangeWowPathReloggerTask()
Public Sub New
public:
ChangeWowPathReloggerTask()

See Also

ChangeWowPathReloggerTask Class
Relogger.Classes Namespace


ChangeWowPathReloggerTask Methods

The ChangeWowPathReloggerTask type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetErrors | Gets settings errors.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs task.
Public method | ToString | (Inherited from Object.)

See Also

ChangeWowPathReloggerTask Class
Relogger.Classes Namespace


GetErrors Method

ChangeWowPathReloggerTask..::..GetErrors Method

Gets settings errors.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public List<string> GetErrors()
Public Function GetErrors As List(Of String)
public:
List<String^>^ GetErrors()

Return Value

List<System.String>.

See Also

ChangeWowPathReloggerTask Class
Relogger.Classes Namespace


Run Method

ChangeWowPathReloggerTask..::..Run Method

Runs task.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public void Run(
    ReloggerProfile parent
)
Public Sub Run ( _
    parent As ReloggerProfile _
)
public:
void Run(
    ReloggerProfile^ parent
)

Parameters

parent
Type: Relogger.Classes..::..ReloggerProfile
profile that contain this task.

See Also

ChangeWowPathReloggerTask Class
Relogger.Classes Namespace


ChangeWowPathReloggerTask Properties

The ChangeWowPathReloggerTask type exposes the following members.

Properties

 | Name | Description
Public property | IsValid | Returns true if is valid. (Inherited from BaseReloggerTask.)
Public property | TaskType | Gets the type of the task.
Public property | UserControlWpf | Gets or sets the user control. (Inherited from BaseReloggerTask.)
Public property | WowPath | Gets or sets the wow path.

See Also

ChangeWowPathReloggerTask Class
Relogger.Classes Namespace


TaskType Property

ChangeWowPathReloggerTask..::..TaskType Property

Gets the type of the task.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public TaskType TaskType { get; }
Public ReadOnly Property TaskType As TaskType
    Get
public:
property TaskType^ TaskType {
    TaskType^ get ();
}

Field Value

The type of the task.

See Also

ChangeWowPathReloggerTask Class
Relogger.Classes Namespace


WowPath Property

ChangeWowPathReloggerTask..::..WowPath Property

Gets or sets the wow path.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public string WowPath { get; set; }
Public Property WowPath As String
    Get
    Set
public:
property String^ WowPath {
    String^ get ();
    void set (String^ value);
}

Field Value

The wow path.

See Also

ChangeWowPathReloggerTask Class
Relogger.Classes Namespace


ChangeWRobotLicenseKeyReloggerTask Class

Class ChangeWRobotLicenseKeyReloggerTask. Implements the BaseReloggerTask

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
[SerializableAttribute]
[ObfuscationAttribute]
public class ChangeWRobotLicenseKeyReloggerTask : BaseReloggerTask
<SerializableAttribute> _
<ObfuscationAttribute> _
Public Class ChangeWRobotLicenseKeyReloggerTask _
    Inherits BaseReloggerTask
[SerializableAttribute]
[ObfuscationAttribute]
public ref class ChangeWRobotLicenseKeyReloggerTask : public BaseReloggerTask

Inheritance Hierarchy

Object
Relogger.Classes..::..BaseReloggerTask
Relogger.Classes..::..ChangeWRobotLicenseKeyReloggerTask

See Also

ChangeWRobotLicenseKeyReloggerTask Members
Relogger.Classes Namespace
Relogger.Classes..::..BaseReloggerTask


ChangeWRobotLicenseKeyReloggerTask Members

The ChangeWRobotLicenseKeyReloggerTask type exposes the following members.

Constructors

 | Name | Description
Public method | ChangeWRobotLicenseKeyReloggerTask | Initializes a new instance of the ChangeWRobotLicenseKeyReloggerTask class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetErrors | Gets settings errors.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs task.
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValid | Returns true if is valid. (Inherited from BaseReloggerTask.)
Public property | TaskType | Gets the type of the task.
Public property | UserControlWpf | Gets or sets the user control. (Inherited from BaseReloggerTask.)
Public property | WRobotKey | Gets or sets the bot license key.
Public property | WRobotKeyCrypted | Gets or sets the bot key crypted.

See Also

ChangeWRobotLicenseKeyReloggerTask Class
Relogger.Classes Namespace


ChangeWRobotLicenseKeyReloggerTask Constructor

Initializes a new instance of the ChangeWRobotLicenseKeyReloggerTask class.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public ChangeWRobotLicenseKeyReloggerTask()
Public Sub New
public:
ChangeWRobotLicenseKeyReloggerTask()

See Also

ChangeWRobotLicenseKeyReloggerTask Class
Relogger.Classes Namespace


ChangeWRobotLicenseKeyReloggerTask Methods

The ChangeWRobotLicenseKeyReloggerTask type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetErrors | Gets settings errors.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs task.
Public method | ToString | (Inherited from Object.)

See Also

ChangeWRobotLicenseKeyReloggerTask Class
Relogger.Classes Namespace


GetErrors Method

ChangeWRobotLicenseKeyReloggerTask..::..GetErrors Method

Gets settings errors.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public List<string> GetErrors()
Public Function GetErrors As List(Of String)
public:
List<String^>^ GetErrors()

Return Value

List<System.String>.

See Also

ChangeWRobotLicenseKeyReloggerTask Class
Relogger.Classes Namespace


Run Method

ChangeWRobotLicenseKeyReloggerTask..::..Run Method

Runs task.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public void Run(
    ReloggerProfile parent
)
Public Sub Run ( _
    parent As ReloggerProfile _
)
public:
void Run(
    ReloggerProfile^ parent
)

Parameters

parent
Type: Relogger.Classes..::..ReloggerProfile
profile that contain this task.

See Also

ChangeWRobotLicenseKeyReloggerTask Class
Relogger.Classes Namespace


ChangeWRobotLicenseKeyReloggerTask Properties

The ChangeWRobotLicenseKeyReloggerTask type exposes the following members.

Properties

 | Name | Description
Public property | IsValid | Returns true if is valid. (Inherited from BaseReloggerTask.)
Public property | TaskType | Gets the type of the task.
Public property | UserControlWpf | Gets or sets the user control. (Inherited from BaseReloggerTask.)
Public property | WRobotKey | Gets or sets the bot license key.
Public property | WRobotKeyCrypted | Gets or sets the bot key crypted.

See Also

ChangeWRobotLicenseKeyReloggerTask Class
Relogger.Classes Namespace


TaskType Property

ChangeWRobotLicenseKeyReloggerTask..::..TaskType Property

Gets the type of the task.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public TaskType TaskType { get; }
Public ReadOnly Property TaskType As TaskType
    Get
public:
property TaskType^ TaskType {
    TaskType^ get ();
}

Field Value

The type of the task.

See Also

ChangeWRobotLicenseKeyReloggerTask Class
Relogger.Classes Namespace


WRobotKey Property

ChangeWRobotLicenseKeyReloggerTask..::..WRobotKey Property

Gets or sets the bot license key.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
[XmlIgnoreAttribute]
public string WRobotKey { get; set; }
<XmlIgnoreAttribute> _
Public Property WRobotKey As String
    Get
    Set
[XmlIgnoreAttribute]
public:
property String^ WRobotKey {
    String^ get ();
    void set (String^ value);
}

Field Value

The bot key.

See Also

ChangeWRobotLicenseKeyReloggerTask Class
Relogger.Classes Namespace


WRobotKeyCrypted Property

ChangeWRobotLicenseKeyReloggerTask..::..WRobotKeyCrypted Property

Gets or sets the bot key crypted.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public string WRobotKeyCrypted { get; set; }
Public Property WRobotKeyCrypted As String
    Get
    Set
public:
property String^ WRobotKeyCrypted {
    String^ get ();
    void set (String^ value);
}

Field Value

The w robot key crypted.

See Also

ChangeWRobotLicenseKeyReloggerTask Class
Relogger.Classes Namespace


ChangeWRobotPathReloggerTask Class

Class ChangeWRobotPathReloggerTask. Implements the BaseReloggerTask

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
[SerializableAttribute]
[ObfuscationAttribute]
public class ChangeWRobotPathReloggerTask : BaseReloggerTask
<SerializableAttribute> _
<ObfuscationAttribute> _
Public Class ChangeWRobotPathReloggerTask _
    Inherits BaseReloggerTask
[SerializableAttribute]
[ObfuscationAttribute]
public ref class ChangeWRobotPathReloggerTask : public BaseReloggerTask

Inheritance Hierarchy

Object
Relogger.Classes..::..BaseReloggerTask
Relogger.Classes..::..ChangeWRobotPathReloggerTask

See Also

ChangeWRobotPathReloggerTask Members
Relogger.Classes Namespace
Relogger.Classes..::..BaseReloggerTask


ChangeWRobotPathReloggerTask Members

The ChangeWRobotPathReloggerTask type exposes the following members.

Constructors

 | Name | Description
Public method | ChangeWRobotPathReloggerTask | Initializes a new instance of the ChangeWRobotPathReloggerTask class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetErrors | Gets settings errors.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs the specified parent.
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValid | Returns true if is valid. (Inherited from BaseReloggerTask.)
Public property | TaskType | Gets the type of the task.
Public property | UserControlWpf | Gets or sets the user control. (Inherited from BaseReloggerTask.)
Public property | WRobotPath | Gets or sets the bot path.

See Also

ChangeWRobotPathReloggerTask Class
Relogger.Classes Namespace


ChangeWRobotPathReloggerTask Constructor

Initializes a new instance of the ChangeWRobotPathReloggerTask class.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public ChangeWRobotPathReloggerTask()
Public Sub New
public:
ChangeWRobotPathReloggerTask()

See Also

ChangeWRobotPathReloggerTask Class
Relogger.Classes Namespace


ChangeWRobotPathReloggerTask Methods

The ChangeWRobotPathReloggerTask type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetErrors | Gets settings errors.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs the specified parent.
Public method | ToString | (Inherited from Object.)

See Also

ChangeWRobotPathReloggerTask Class
Relogger.Classes Namespace


GetErrors Method

ChangeWRobotPathReloggerTask..::..GetErrors Method

Gets settings errors.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public List<string> GetErrors()
Public Function GetErrors As List(Of String)
public:
List<String^>^ GetErrors()

Return Value

List<System.String>.

See Also

ChangeWRobotPathReloggerTask Class
Relogger.Classes Namespace


Run Method

ChangeWRobotPathReloggerTask..::..Run Method

Runs the specified parent.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public void Run(
    ReloggerProfile parent
)
Public Sub Run ( _
    parent As ReloggerProfile _
)
public:
void Run(
    ReloggerProfile^ parent
)

Parameters

parent
Type: Relogger.Classes..::..ReloggerProfile
The parent.

See Also

ChangeWRobotPathReloggerTask Class
Relogger.Classes Namespace


ChangeWRobotPathReloggerTask Properties

The ChangeWRobotPathReloggerTask type exposes the following members.

Properties

 | Name | Description
Public property | IsValid | Returns true if is valid. (Inherited from BaseReloggerTask.)
Public property | TaskType | Gets the type of the task.
Public property | UserControlWpf | Gets or sets the user control. (Inherited from BaseReloggerTask.)
Public property | WRobotPath | Gets or sets the bot path.

See Also

ChangeWRobotPathReloggerTask Class
Relogger.Classes Namespace


TaskType Property

ChangeWRobotPathReloggerTask..::..TaskType Property

Gets the type of the task.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public TaskType TaskType { get; }
Public ReadOnly Property TaskType As TaskType
    Get
public:
property TaskType^ TaskType {
    TaskType^ get ();
}

Field Value

The type of the task.

See Also

ChangeWRobotPathReloggerTask Class
Relogger.Classes Namespace


WRobotPath Property

ChangeWRobotPathReloggerTask..::..WRobotPath Property

Gets or sets the bot path.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public string WRobotPath { get; set; }
Public Property WRobotPath As String
    Get
    Set
public:
property String^ WRobotPath {
    String^ get ();
    void set (String^ value);
}

Field Value

The bot path.

See Also

ChangeWRobotPathReloggerTask Class
Relogger.Classes Namespace


ReloggerGeneralSettings Class

Class ReloggerGeneralSettings. Implements the Settings

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
[SerializableAttribute]
[ObfuscationAttribute]
public class ReloggerGeneralSettings : Settings
<SerializableAttribute> _
<ObfuscationAttribute> _
Public Class ReloggerGeneralSettings _
    Inherits Settings
[SerializableAttribute]
[ObfuscationAttribute]
public ref class ReloggerGeneralSettings : public Settings

Inheritance Hierarchy

Object
robotManager.Helpful..::..Settings
Relogger.Classes..::..ReloggerGeneralSettings

See Also

ReloggerGeneralSettings Members
Relogger.Classes Namespace
robotManager.Helpful..::..Settings


ReloggerGeneralSettings Members

The ReloggerGeneralSettings type exposes the following members.

Constructors

 | Name | Description
Public method | ReloggerGeneralSettings()()()() | Initializes a new instance of the ReloggerGeneralSettings class.

Methods

 | Name | Description
Protected method | ConfigWinForm | (Inherited from Settings.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
 | Load | Loads this instance.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Save()()()() | Saves this instance.
Protected method | Save(String) | Save to xml file (Inherited from Settings.)
Public method | ToForm | Converts to form. (Inherited from Settings.)
Public method | ToString | (Inherited from Object.)
Public method | ToStringFormat | Converts to stringformat. (Inherited from Settings.)

Fields

 | Name | Description
 | FileName | The file path
Public field | Profiles | The profiles list

Properties

 | Name | Description
Public property | AdditionalWowArgs | Gets or sets the additional wow arguments.
Public property | AdditionalWRobotArgs | Gets or sets the additional WRobot arguments.
Public property | AtPingToCheckInternetConnectivity | Gets or sets url at ping to check internet connectivity (use value like "google.com", empty if unused)
Public property | AutoCloseBlizzardErrorReport | Gets or sets a value indicating if relogger close blizzard error report.
Public property | CloseBotAndGameWhenOneClosed | Gets or sets a value indicating if relogger close bot and game when one closed.
 | CurrentSetting | Gets or sets the current setting.
Public property | LockCrossProcessWhenLaunch | Lock when launch Wow or bot (to launch one by one) (cross relogger process), you need to use same [robotManager.robotManagerGlobalSetting.CurrentSetting.ArgsEnvironmentVariables] on all relogger.
Public property | LockWhenLaunch | Lock when launch Wow or bot (to launch one by one) (only this relogger process)
Public property | PathToWow | Gets or sets the path to wow client.
Public property | PathToWRobot | Gets or sets the path to WRobot.
Public property | SaveWindowPosition | Gets or sets a value indicating save relogger window position for next usage
Public property | SizeHeight | If you use use option SaveWindowPosition it is height of relogger window.
Public property | SizeWidth | If you use use option SaveWindowPosition it is width of relogger window.
Public property | ToTrayBar | Minimize to to tray bar.
Public property | UnresponsiveTimeAfter | Gets or sets the time after which we consider unresponsive (in seconds).
Public property | WaitTimeAfterLaunch | Gets or sets the time to wait after launch (in seconds)
Public property | WaitTimeToRelogWhenCrash | Wait time to relaunch and relogge after crash (in seconds)
Public property | WindowName | Gets or sets the name of the relogger window (empty to no use this option).
Public property | WindowPosX | If you use use option SaveWindowPosition it is position X of relogger window.
Public property | WindowPosY | If you use use option SaveWindowPosition it is position Y of relogger window.

See Also

ReloggerGeneralSettings Class
Relogger.Classes Namespace


ReloggerGeneralSettings Constructor

Initializes a new instance of the ReloggerGeneralSettings class.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public ReloggerGeneralSettings()
Public Sub New
public:
ReloggerGeneralSettings()

See Also

ReloggerGeneralSettings Class
#ctor Overload
Relogger.Classes Namespace


ReloggerGeneralSettings Fields

The ReloggerGeneralSettings type exposes the following members.

Fields

 | Name | Description
 | FileName | The file path
Public field | Profiles | The profiles list

See Also

ReloggerGeneralSettings Class
Relogger.Classes Namespace


FileName Field

ReloggerGeneralSettings..::..FileName Field

The file path

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public static string FileName
Public Shared FileName As String
public:
static String^ FileName

See Also

ReloggerGeneralSettings Class
Relogger.Classes Namespace


Profiles Field

ReloggerGeneralSettings..::..Profiles Field

The profiles list

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public List<ReloggerProfile> Profiles
Public Profiles As List(Of ReloggerProfile)
public:
List<ReloggerProfile^>^ Profiles

See Also

ReloggerGeneralSettings Class
Relogger.Classes Namespace


ReloggerGeneralSettings Methods

The ReloggerGeneralSettings type exposes the following members.

Methods

 | Name | Description
Protected method | ConfigWinForm | (Inherited from Settings.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
 | Load | Loads this instance.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Save()()()() | Saves this instance.
Protected method | Save(String) | Save to xml file (Inherited from Settings.)
Public method | ToForm | Converts to form. (Inherited from Settings.)
Public method | ToString | (Inherited from Object.)
Public method | ToStringFormat | Converts to stringformat. (Inherited from Settings.)

See Also

ReloggerGeneralSettings Class
Relogger.Classes Namespace


Load Method

ReloggerGeneralSettings..::..Load Method

Loads this instance.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public static bool Load()
Public Shared Function Load As Boolean
public:
static bool^ Load()

Return Value

true if success, false otherwise.

See Also

ReloggerGeneralSettings Class
Relogger.Classes Namespace


Save Method

ReloggerGeneralSettings..::..Save Method

Overload List

 | Name | Description
Public method | Save()()()() | Saves this instance.
Protected method | Save(String) | Save to xml file (Inherited from Settings.)

See Also

ReloggerGeneralSettings Class
ReloggerGeneralSettings Members
Relogger.Classes Namespace


Save Method

ReloggerGeneralSettings..::..Save Method

Saves this instance.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public bool Save()
Public Function Save As Boolean
public:
bool^ Save()

Return Value

true if success, false otherwise.

See Also

ReloggerGeneralSettings Class
Relogger.Classes Namespace


ReloggerGeneralSettings Properties

The ReloggerGeneralSettings type exposes the following members.

Properties

 | Name | Description
Public property | AdditionalWowArgs | Gets or sets the additional wow arguments.
Public property | AdditionalWRobotArgs | Gets or sets the additional WRobot arguments.
Public property | AtPingToCheckInternetConnectivity | Gets or sets url at ping to check internet connectivity (use value like "google.com", empty if unused)
Public property | AutoCloseBlizzardErrorReport | Gets or sets a value indicating if relogger close blizzard error report.
Public property | CloseBotAndGameWhenOneClosed | Gets or sets a value indicating if relogger close bot and game when one closed.
 | CurrentSetting | Gets or sets the current setting.
Public property | LockCrossProcessWhenLaunch | Lock when launch Wow or bot (to launch one by one) (cross relogger process), you need to use same [robotManager.robotManagerGlobalSetting.CurrentSetting.ArgsEnvironmentVariables] on all relogger.
Public property | LockWhenLaunch | Lock when launch Wow or bot (to launch one by one) (only this relogger process)
Public property | PathToWow | Gets or sets the path to wow client.
Public property | PathToWRobot | Gets or sets the path to WRobot.
Public property | SaveWindowPosition | Gets or sets a value indicating save relogger window position for next usage
Public property | SizeHeight | If you use use option SaveWindowPosition it is height of relogger window.
Public property | SizeWidth | If you use use option SaveWindowPosition it is width of relogger window.
Public property | ToTrayBar | Minimize to to tray bar.
Public property | UnresponsiveTimeAfter | Gets or sets the time after which we consider unresponsive (in seconds).
Public property | WaitTimeAfterLaunch | Gets or sets the time to wait after launch (in seconds)
Public property | WaitTimeToRelogWhenCrash | Wait time to relaunch and relogge after crash (in seconds)
Public property | WindowName | Gets or sets the name of the relogger window (empty to no use this option).
Public property | WindowPosX | If you use use option SaveWindowPosition it is position X of relogger window.
Public property | WindowPosY | If you use use option SaveWindowPosition it is position Y of relogger window.

See Also

ReloggerGeneralSettings Class
Relogger.Classes Namespace


AdditionalWowArgs Property

ReloggerGeneralSettings..::..AdditionalWowArgs Property

Gets or sets the additional wow arguments.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public string AdditionalWowArgs { get; set; }
Public Property AdditionalWowArgs As String
    Get
    Set
public:
property String^ AdditionalWowArgs {
    String^ get ();
    void set (String^ value);
}

Field Value

The additional wow arguments.

See Also

ReloggerGeneralSettings Class
Relogger.Classes Namespace


AdditionalWRobotArgs Property

ReloggerGeneralSettings..::..AdditionalWRobotArgs Property

Gets or sets the additional WRobot arguments.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public string AdditionalWRobotArgs { get; set; }
Public Property AdditionalWRobotArgs As String
    Get
    Set
public:
property String^ AdditionalWRobotArgs {
    String^ get ();
    void set (String^ value);
}

Field Value

The additional WRobot arguments.

See Also

ReloggerGeneralSettings Class
Relogger.Classes Namespace


AtPingToCheckInternetConnectivity Property

ReloggerGeneralSettings..::..AtPingToCheckInternetConnectivity Property

Gets or sets url at ping to check internet connectivity (use value like "google.com", empty if unused)

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public string AtPingToCheckInternetConnectivity { get; set; }
Public Property AtPingToCheckInternetConnectivity As String
    Get
    Set
public:
property String^ AtPingToCheckInternetConnectivity {
    String^ get ();
    void set (String^ value);
}

Field Value

At ping to check internet connectivity.

See Also

ReloggerGeneralSettings Class
Relogger.Classes Namespace


AutoCloseBlizzardErrorReport Property

ReloggerGeneralSettings..::..AutoCloseBlizzardErrorReport Property

Gets or sets a value indicating if relogger close blizzard error report.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public bool AutoCloseBlizzardErrorReport { get; set; }
Public Property AutoCloseBlizzardErrorReport As Boolean
    Get
    Set
public:
property bool^ AutoCloseBlizzardErrorReport {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if automatic close blizzard error otherwise false.

See Also

ReloggerGeneralSettings Class
Relogger.Classes Namespace


CloseBotAndGameWhenOneClosed Property

ReloggerGeneralSettings..::..CloseBotAndGameWhenOneClosed Property

Gets or sets a value indicating if relogger close bot and game when one closed.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public bool CloseBotAndGameWhenOneClosed { get; set; }
Public Property CloseBotAndGameWhenOneClosed As Boolean
    Get
    Set
public:
property bool^ CloseBotAndGameWhenOneClosed {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if close bot and game when one closed otherwise false.

See Also

ReloggerGeneralSettings Class
Relogger.Classes Namespace


CurrentSetting Property

ReloggerGeneralSettings..::..CurrentSetting Property

Gets or sets the current setting.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public static ReloggerGeneralSettings CurrentSetting { get; set; }
Public Shared Property CurrentSetting As ReloggerGeneralSettings
    Get
    Set
public:
static property ReloggerGeneralSettings^ CurrentSetting {
    ReloggerGeneralSettings^ get ();
    void set (ReloggerGeneralSettings^ value);
}

Field Value

The current setting.

See Also

ReloggerGeneralSettings Class
Relogger.Classes Namespace


LockCrossProcessWhenLaunch Property

ReloggerGeneralSettings..::..LockCrossProcessWhenLaunch Property

Lock when launch Wow or bot (to launch one by one) (cross relogger process), you need to use same [robotManager.robotManagerGlobalSetting.CurrentSetting.ArgsEnvironmentVariables] on all relogger.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public bool LockCrossProcessWhenLaunch { get; set; }
Public Property LockCrossProcessWhenLaunch As Boolean
    Get
    Set
public:
property bool^ LockCrossProcessWhenLaunch {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if lock when launch Wow or bot (cross relogger process) otherwise false.

See Also

ReloggerGeneralSettings Class
Relogger.Classes Namespace


LockWhenLaunch Property

ReloggerGeneralSettings..::..LockWhenLaunch Property

Lock when launch Wow or bot (to launch one by one) (only this relogger process)

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public bool LockWhenLaunch { get; set; }
Public Property LockWhenLaunch As Boolean
    Get
    Set
public:
property bool^ LockWhenLaunch {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if lock when launch Wow or bot otherwise false.

See Also

ReloggerGeneralSettings Class
Relogger.Classes Namespace


PathToWow Property

ReloggerGeneralSettings..::..PathToWow Property

Gets or sets the path to wow client.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public string PathToWow { get; set; }
Public Property PathToWow As String
    Get
    Set
public:
property String^ PathToWow {
    String^ get ();
    void set (String^ value);
}

Field Value

The path to wow.

See Also

ReloggerGeneralSettings Class
Relogger.Classes Namespace


PathToWRobot Property

ReloggerGeneralSettings..::..PathToWRobot Property

Gets or sets the path to WRobot.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public string PathToWRobot { get; set; }
Public Property PathToWRobot As String
    Get
    Set
public:
property String^ PathToWRobot {
    String^ get ();
    void set (String^ value);
}

Field Value

The path to WRobot.

See Also

ReloggerGeneralSettings Class
Relogger.Classes Namespace


SaveWindowPosition Property

ReloggerGeneralSettings..::..SaveWindowPosition Property

Gets or sets a value indicating save relogger window position for next usage

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public bool SaveWindowPosition { get; set; }
Public Property SaveWindowPosition As Boolean
    Get
    Set
public:
property bool^ SaveWindowPosition {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if save window position otherwise false.

See Also

ReloggerGeneralSettings Class
Relogger.Classes Namespace


SizeHeight Property

ReloggerGeneralSettings..::..SizeHeight Property

If you use use option SaveWindowPosition it is height of relogger window.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public double SizeHeight { get; set; }
Public Property SizeHeight As Double
    Get
    Set
public:
property double^ SizeHeight {
    double^ get ();
    void set (double^ value);
}

Field Value

The height of the size.

See Also

ReloggerGeneralSettings Class
Relogger.Classes Namespace


SizeWidth Property

ReloggerGeneralSettings..::..SizeWidth Property

If you use use option SaveWindowPosition it is width of relogger window.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public double SizeWidth { get; set; }
Public Property SizeWidth As Double
    Get
    Set
public:
property double^ SizeWidth {
    double^ get ();
    void set (double^ value);
}

Field Value

The width of the size.

See Also

ReloggerGeneralSettings Class
Relogger.Classes Namespace


ToTrayBar Property

ReloggerGeneralSettings..::..ToTrayBar Property

Minimize to to tray bar.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public bool ToTrayBar { get; set; }
Public Property ToTrayBar As Boolean
    Get
    Set
public:
property bool^ ToTrayBar {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if you want minimize to tray bar otherwise false.

See Also

ReloggerGeneralSettings Class
Relogger.Classes Namespace


UnresponsiveTimeAfter Property

ReloggerGeneralSettings..::..UnresponsiveTimeAfter Property

Gets or sets the time after which we consider unresponsive (in seconds).

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public int UnresponsiveTimeAfter { get; set; }
Public Property UnresponsiveTimeAfter As Integer
    Get
    Set
public:
property int^ UnresponsiveTimeAfter {
    int^ get ();
    void set (int^ value);
}

Field Value

The unresponsive time after.

See Also

ReloggerGeneralSettings Class
Relogger.Classes Namespace


WaitTimeAfterLaunch Property

ReloggerGeneralSettings..::..WaitTimeAfterLaunch Property

Gets or sets the time to wait after launch (in seconds)

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public int WaitTimeAfterLaunch { get; set; }
Public Property WaitTimeAfterLaunch As Integer
    Get
    Set
public:
property int^ WaitTimeAfterLaunch {
    int^ get ();
    void set (int^ value);
}

Field Value

The wait time after launch.

See Also

ReloggerGeneralSettings Class
Relogger.Classes Namespace


WaitTimeToRelogWhenCrash Property

ReloggerGeneralSettings..::..WaitTimeToRelogWhenCrash Property

Wait time to relaunch and relogge after crash (in seconds)

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public int WaitTimeToRelogWhenCrash { get; set; }
Public Property WaitTimeToRelogWhenCrash As Integer
    Get
    Set
public:
property int^ WaitTimeToRelogWhenCrash {
    int^ get ();
    void set (int^ value);
}

Field Value

The wait time to relog when crash.

See Also

ReloggerGeneralSettings Class
Relogger.Classes Namespace


WindowName Property

ReloggerGeneralSettings..::..WindowName Property

Gets or sets the name of the relogger window (empty to no use this option).

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public string WindowName { get; set; }
Public Property WindowName As String
    Get
    Set
public:
property String^ WindowName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the window.

See Also

ReloggerGeneralSettings Class
Relogger.Classes Namespace


WindowPosX Property

ReloggerGeneralSettings..::..WindowPosX Property

If you use use option SaveWindowPosition it is position X of relogger window.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public double WindowPosX { get; set; }
Public Property WindowPosX As Double
    Get
    Set
public:
property double^ WindowPosX {
    double^ get ();
    void set (double^ value);
}

Field Value

The window position x.

See Also

ReloggerGeneralSettings Class
Relogger.Classes Namespace


WindowPosY Property

ReloggerGeneralSettings..::..WindowPosY Property

If you use use option SaveWindowPosition it is position Y of relogger window.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public double WindowPosY { get; set; }
Public Property WindowPosY As Double
    Get
    Set
public:
property double^ WindowPosY {
    double^ get ();
    void set (double^ value);
}

Field Value

The window position y.

See Also

ReloggerGeneralSettings Class
Relogger.Classes Namespace


ReloggerProfile Class

Class ReloggerProfile.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
[SerializableAttribute]
[ObfuscationAttribute]
public class ReloggerProfile
<SerializableAttribute> _
<ObfuscationAttribute> _
Public Class ReloggerProfile
[SerializableAttribute]
[ObfuscationAttribute]
public ref class ReloggerProfile

Inheritance Hierarchy

Object
Relogger.Classes..::..ReloggerProfile

See Also

ReloggerProfile Members
Relogger.Classes Namespace


ReloggerProfile Members

The ReloggerProfile type exposes the following members.

Constructors

 | Name | Description
Public method | ReloggerProfile | Initializes a new instance of the ReloggerProfile class.

Methods

 | Name | Description
Public method | CloseAndKillWRobotProcess | try to close, if cannot kill bot process.
Public method | CloseWowErrorProcess | Closes wow error window.
Public method | CloseWowProcess | Close wow process.
Public method | CloseWRobotProcess | Closes bot process.
Public method | Equals(System.Object) | (Inherited from Object.)
Public method | ExistWowProcess | Wow process is running
Public method | ExistWRobotProcess | Bot process is running.
Protected method | Finalize | (Inherited from Object.)
Public method | GetErrors | Gets the errors.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | InRunningScheduleRange | Check if in working schedule (current time is between ScheduleFrom and ScheduleTo)
Public method | IsStart | Determines this profile is start.
Public method | KillWowProcess | Kill wow process.
Public method | KillWRobotProcess | Kills bot process.
Public method | LaunchWowProcess | Launches wow process.
Public method | LaunchWRobotProcess | Launch bot.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Start | Starts this profile.
Public method | Stop | Stops this profile
Public method | ToString | Returns a String that represents this instance.
Public method | WowIsUnresponsive | Wow is unresponsive (if process not responding for more that UnresponsiveTimeAfter).
Public method | WowProcessId | Wow process id.
Public method | WRobotIsUnresponsive | Bot is unresponsive (if process not responding for more that UnresponsiveTimeAfter).
Public method | WRobotProcessId | Bot process id.

Fields

 | Name | Description
Public field | CurrentWowAccount | The current wow account
Public field | CurrentWowPath | The current wow path
Public field | CurrentWowProcess | The current wow process
Public field | CurrentWRobotAccount | The current bot license key
Public field | CurrentWRobotPath | The current bot path
Public field | CurrentWRobotProcess | The current bot process
Public field | Settings | The settings
 | Wowlocker | The locker used to launch wow

Properties

 | Name | Description
Public property | Checked | Gets or sets a value indicating if is checked.
Public property | Comment | Gets or sets profile comment.
Public property | CurrentTaskIndex | Running task index (index of Tasks)
Public property | IsValid | Returns true if profile is valid.
Public property | Name | Gets or sets profile name.
Public property | RunningTime | Gets running time.
Public property | Status | Gets or sets the status (avoid to edit value manually, to check if profile is running you can use IsStart()()()(), to start or stop profile use Start()()()() or Stop()()()()).

See Also

ReloggerProfile Class
Relogger.Classes Namespace


ReloggerProfile Constructor

Initializes a new instance of the ReloggerProfile class.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public ReloggerProfile()
Public Sub New
public:
ReloggerProfile()

See Also

ReloggerProfile Class
Relogger.Classes Namespace


ReloggerProfile Fields

The ReloggerProfile type exposes the following members.

Fields

 | Name | Description
Public field | CurrentWowAccount | The current wow account
Public field | CurrentWowPath | The current wow path
Public field | CurrentWowProcess | The current wow process
Public field | CurrentWRobotAccount | The current bot license key
Public field | CurrentWRobotPath | The current bot path
Public field | CurrentWRobotProcess | The current bot process
Public field | Settings | The settings
 | Wowlocker | The locker used to launch wow

See Also

ReloggerProfile Class
Relogger.Classes Namespace


CurrentWowAccount Field

ReloggerProfile..::..CurrentWowAccount Field

The current wow account

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
[XmlIgnoreAttribute]
public ChangeCharacterReloggerTask CurrentWowAccount
<XmlIgnoreAttribute> _
Public CurrentWowAccount As ChangeCharacterReloggerTask
[XmlIgnoreAttribute]
public:
ChangeCharacterReloggerTask^ CurrentWowAccount

See Also

ReloggerProfile Class
Relogger.Classes Namespace


CurrentWowPath Field

ReloggerProfile..::..CurrentWowPath Field

The current wow path

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
[XmlIgnoreAttribute]
public string CurrentWowPath
<XmlIgnoreAttribute> _
Public CurrentWowPath As String
[XmlIgnoreAttribute]
public:
String^ CurrentWowPath

See Also

ReloggerProfile Class
Relogger.Classes Namespace


CurrentWowProcess Field

ReloggerProfile..::..CurrentWowProcess Field

The current wow process

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
[XmlIgnoreAttribute]
public Process CurrentWowProcess
<XmlIgnoreAttribute> _
Public CurrentWowProcess As Process
[XmlIgnoreAttribute]
public:
Process^ CurrentWowProcess

See Also

ReloggerProfile Class
Relogger.Classes Namespace


CurrentWRobotAccount Field

ReloggerProfile..::..CurrentWRobotAccount Field

The current bot license key

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
[XmlIgnoreAttribute]
public ChangeWRobotLicenseKeyReloggerTask CurrentWRobotAccount
<XmlIgnoreAttribute> _
Public CurrentWRobotAccount As ChangeWRobotLicenseKeyReloggerTask
[XmlIgnoreAttribute]
public:
ChangeWRobotLicenseKeyReloggerTask^ CurrentWRobotAccount

See Also

ReloggerProfile Class
Relogger.Classes Namespace


CurrentWRobotPath Field

ReloggerProfile..::..CurrentWRobotPath Field

The current bot path

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
[XmlIgnoreAttribute]
public string CurrentWRobotPath
<XmlIgnoreAttribute> _
Public CurrentWRobotPath As String
[XmlIgnoreAttribute]
public:
String^ CurrentWRobotPath

See Also

ReloggerProfile Class
Relogger.Classes Namespace


CurrentWRobotProcess Field

ReloggerProfile..::..CurrentWRobotProcess Field

The current bot process

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
[XmlIgnoreAttribute]
public Process CurrentWRobotProcess
<XmlIgnoreAttribute> _
Public CurrentWRobotProcess As Process
[XmlIgnoreAttribute]
public:
Process^ CurrentWRobotProcess

See Also

ReloggerProfile Class
Relogger.Classes Namespace


Settings Field

ReloggerProfile..::..Settings Field

The settings

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public ReloggerProfileSettings Settings
Public Settings As ReloggerProfileSettings
public:
ReloggerProfileSettings^ Settings

See Also

ReloggerProfile Class
Relogger.Classes Namespace


Wowlocker Field

ReloggerProfile..::..Wowlocker Field

The locker used to launch wow

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public static Object Wowlocker
Public Shared Wowlocker As Object
public:
static Object^ Wowlocker

See Also

ReloggerProfile Class
Relogger.Classes Namespace


ReloggerProfile Methods

The ReloggerProfile type exposes the following members.

Methods

 | Name | Description
Public method | CloseAndKillWRobotProcess | try to close, if cannot kill bot process.
Public method | CloseWowErrorProcess | Closes wow error window.
Public method | CloseWowProcess | Close wow process.
Public method | CloseWRobotProcess | Closes bot process.
Public method | Equals(System.Object) | (Inherited from Object.)
Public method | ExistWowProcess | Wow process is running
Public method | ExistWRobotProcess | Bot process is running.
Protected method | Finalize | (Inherited from Object.)
Public method | GetErrors | Gets the errors.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | InRunningScheduleRange | Check if in working schedule (current time is between ScheduleFrom and ScheduleTo)
Public method | IsStart | Determines this profile is start.
Public method | KillWowProcess | Kill wow process.
Public method | KillWRobotProcess | Kills bot process.
Public method | LaunchWowProcess | Launches wow process.
Public method | LaunchWRobotProcess | Launch bot.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Start | Starts this profile.
Public method | Stop | Stops this profile
Public method | ToString | Returns a String that represents this instance.
Public method | WowIsUnresponsive | Wow is unresponsive (if process not responding for more that UnresponsiveTimeAfter).
Public method | WowProcessId | Wow process id.
Public method | WRobotIsUnresponsive | Bot is unresponsive (if process not responding for more that UnresponsiveTimeAfter).
Public method | WRobotProcessId | Bot process id.

See Also

ReloggerProfile Class
Relogger.Classes Namespace


CloseAndKillWRobotProcess Method

ReloggerProfile..::..CloseAndKillWRobotProcess Method

try to close, if cannot kill bot process.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public void CloseAndKillWRobotProcess()
Public Sub CloseAndKillWRobotProcess
public:
void CloseAndKillWRobotProcess()

See Also

ReloggerProfile Class
Relogger.Classes Namespace


CloseWowErrorProcess Method

ReloggerProfile..::..CloseWowErrorProcess Method

Closes wow error window.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public void CloseWowErrorProcess()
Public Sub CloseWowErrorProcess
public:
void CloseWowErrorProcess()

See Also

ReloggerProfile Class
Relogger.Classes Namespace


CloseWowProcess Method

ReloggerProfile..::..CloseWowProcess Method

Close wow process.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public void CloseWowProcess()
Public Sub CloseWowProcess
public:
void CloseWowProcess()

See Also

ReloggerProfile Class
Relogger.Classes Namespace


CloseWRobotProcess Method

ReloggerProfile..::..CloseWRobotProcess Method

Closes bot process.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public void CloseWRobotProcess()
Public Sub CloseWRobotProcess
public:
void CloseWRobotProcess()

See Also

ReloggerProfile Class
Relogger.Classes Namespace


ExistWowProcess Method

ReloggerProfile..::..ExistWowProcess Method

Wow process is running

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public bool ExistWowProcess()
Public Function ExistWowProcess As Boolean
public:
bool^ ExistWowProcess()

Return Value

true if is running, false otherwise.

See Also

ReloggerProfile Class
Relogger.Classes Namespace


ExistWRobotProcess Method

ReloggerProfile..::..ExistWRobotProcess Method

Bot process is running.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public bool ExistWRobotProcess()
Public Function ExistWRobotProcess As Boolean
public:
bool^ ExistWRobotProcess()

Return Value

true if bot process is running. false otherwise.

See Also

ReloggerProfile Class
Relogger.Classes Namespace


GetErrors Method

ReloggerProfile..::..GetErrors Method

Gets the errors.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public List<string> GetErrors()
Public Function GetErrors As List(Of String)
public:
List<String^>^ GetErrors()

Return Value

List<System.String>.

See Also

ReloggerProfile Class
Relogger.Classes Namespace


InRunningScheduleRange Method

ReloggerProfile..::..InRunningScheduleRange Method

Check if in working schedule (current time is between ScheduleFrom and ScheduleTo)

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public bool InRunningScheduleRange()
Public Function InRunningScheduleRange As Boolean
public:
bool^ InRunningScheduleRange()

Return Value

true if in working schedule, false otherwise.

See Also

ReloggerProfile Class
Relogger.Classes Namespace


IsStart Method

ReloggerProfile..::..IsStart Method

Determines this profile is start.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public bool IsStart()
Public Function IsStart As Boolean
public:
bool^ IsStart()

Return Value

true if this profile is running; otherwise, false.

See Also

ReloggerProfile Class
Relogger.Classes Namespace


KillWowProcess Method

ReloggerProfile..::..KillWowProcess Method

Kill wow process.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public void KillWowProcess()
Public Sub KillWowProcess
public:
void KillWowProcess()

See Also

ReloggerProfile Class
Relogger.Classes Namespace


KillWRobotProcess Method

ReloggerProfile..::..KillWRobotProcess Method

Kills bot process.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public void KillWRobotProcess()
Public Sub KillWRobotProcess
public:
void KillWRobotProcess()

See Also

ReloggerProfile Class
Relogger.Classes Namespace


LaunchWowProcess Method

ReloggerProfile..::..LaunchWowProcess Method

Launches wow process.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public void LaunchWowProcess(
    string pathToWow,
    Rectangle rectangle,
    string arguments,
    bool waitLaunching
)
Public Sub LaunchWowProcess ( _
    pathToWow As String, _
    rectangle As Rectangle, _
    arguments As String, _
    waitLaunching As Boolean _
)
public:
void LaunchWowProcess(
    String^ pathToWow,
    Rectangle^ rectangle,
    String^ arguments,
    bool^ waitLaunching
)

Parameters

pathToWow
Type: String
path to wow.
rectangle
Type: Rectangle
position and size
arguments
Type: String
arguments.
waitLaunching
Type: Boolean
if set to true wait launching

See Also

ReloggerProfile Class
Relogger.Classes Namespace


LaunchWRobotProcess Method

ReloggerProfile..::..LaunchWRobotProcess Method

Launch bot.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public void LaunchWRobotProcess(
    string pathToWRobot,
    Args arguments,
    bool minimizeWRobotOnStart,
    bool waitLaunching
)
Public Sub LaunchWRobotProcess ( _
    pathToWRobot As String, _
    arguments As Args, _
    minimizeWRobotOnStart As Boolean, _
    waitLaunching As Boolean _
)
public:
void LaunchWRobotProcess(
    String^ pathToWRobot,
    Args^ arguments,
    bool^ minimizeWRobotOnStart,
    bool^ waitLaunching
)

Parameters

pathToWRobot
Type: String
path to bot.
arguments
Type: robotManager.Helpful..::..Args
arguments.
minimizeWRobotOnStart
Type: Boolean
if set to true minimize bot on start].
waitLaunching
Type: Boolean
if set to true wait launch.

See Also

ReloggerProfile Class
Relogger.Classes Namespace


Start Method

ReloggerProfile..::..Start Method

Starts this profile.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public void Start()
Public Sub Start
public:
void Start()

See Also

ReloggerProfile Class
Relogger.Classes Namespace


Stop Method

ReloggerProfile..::..Stop Method

Stops this profile

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public void Stop()
Public Sub Stop
public:
void Stop()

See Also

ReloggerProfile Class
Relogger.Classes Namespace


ToString Method

ReloggerProfile..::..ToString Method

Returns a String that represents this instance.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public string ToString()
Public Function ToString As String
public:
String^ ToString()

Return Value

A String that represents this instance.

See Also

ReloggerProfile Class
Relogger.Classes Namespace


WowIsUnresponsive Method

ReloggerProfile..::..WowIsUnresponsive Method

Wow is unresponsive (if process not responding for more that UnresponsiveTimeAfter).

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public bool WowIsUnresponsive()
Public Function WowIsUnresponsive As Boolean
public:
bool^ WowIsUnresponsive()

Return Value

true if unresponsive, false otherwise.

See Also

ReloggerProfile Class
Relogger.Classes Namespace


WowProcessId Method

ReloggerProfile..::..WowProcessId Method

Wow process id.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public int WowProcessId()
Public Function WowProcessId As Integer
public:
int^ WowProcessId()

Return Value

System.Int32.

See Also

ReloggerProfile Class
Relogger.Classes Namespace


WRobotIsUnresponsive Method

ReloggerProfile..::..WRobotIsUnresponsive Method

Bot is unresponsive (if process not responding for more that UnresponsiveTimeAfter).

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public bool WRobotIsUnresponsive()
Public Function WRobotIsUnresponsive As Boolean
public:
bool^ WRobotIsUnresponsive()

Return Value

true if unresponsive false otherwise.

See Also

ReloggerProfile Class
Relogger.Classes Namespace


WRobotProcessId Method

ReloggerProfile..::..WRobotProcessId Method

Bot process id.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public int WRobotProcessId()
Public Function WRobotProcessId As Integer
public:
int^ WRobotProcessId()

Return Value

System.Int32.

See Also

ReloggerProfile Class
Relogger.Classes Namespace


ReloggerProfile Properties

The ReloggerProfile type exposes the following members.

Properties

 | Name | Description
Public property | Checked | Gets or sets a value indicating if is checked.
Public property | Comment | Gets or sets profile comment.
Public property | CurrentTaskIndex | Running task index (index of Tasks)
Public property | IsValid | Returns true if profile is valid.
Public property | Name | Gets or sets profile name.
Public property | RunningTime | Gets running time.
Public property | Status | Gets or sets the status (avoid to edit value manually, to check if profile is running you can use IsStart()()()(), to start or stop profile use Start()()()() or Stop()()()()).

See Also

ReloggerProfile Class
Relogger.Classes Namespace


Checked Property

ReloggerProfile..::..Checked Property

Gets or sets a value indicating if is checked.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public bool Checked { get; set; }
Public Property Checked As Boolean
    Get
    Set
public:
property bool^ Checked {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if checked; otherwise, false.

See Also

ReloggerProfile Class
Relogger.Classes Namespace


Comment Property

ReloggerProfile..::..Comment Property

Gets or sets profile comment.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public string Comment { get; set; }
Public Property Comment As String
    Get
    Set
public:
property String^ Comment {
    String^ get ();
    void set (String^ value);
}

Field Value

The comment.

See Also

ReloggerProfile Class
Relogger.Classes Namespace


CurrentTaskIndex Property

ReloggerProfile..::..CurrentTaskIndex Property

Running task index (index of Tasks)

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
[XmlIgnoreAttribute]
public int CurrentTaskIndex { get; set; }
<XmlIgnoreAttribute> _
Public Property CurrentTaskIndex As Integer
    Get
    Set
[XmlIgnoreAttribute]
public:
property int^ CurrentTaskIndex {
    int^ get ();
    void set (int^ value);
}

See Also

ReloggerProfile Class
Relogger.Classes Namespace


IsValid Property

ReloggerProfile..::..IsValid Property

Returns true if profile is valid.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public bool IsValid { get; }
Public ReadOnly Property IsValid As Boolean
    Get
public:
property bool^ IsValid {
    bool^ get ();
}

Field Value

true if this instance is valid; otherwise, false.

See Also

ReloggerProfile Class
Relogger.Classes Namespace


Name Property

ReloggerProfile..::..Name Property

Gets or sets profile name.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Field Value

The name.

See Also

ReloggerProfile Class
Relogger.Classes Namespace


RunningTime Property

ReloggerProfile..::..RunningTime Property

Gets running time.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
[XmlIgnoreAttribute]
public string RunningTime { get; set; }
<XmlIgnoreAttribute> _
Public Property RunningTime As String
    Get
    Set
[XmlIgnoreAttribute]
public:
property String^ RunningTime {
    String^ get ();
    void set (String^ value);
}

Field Value

The running time.

See Also

ReloggerProfile Class
Relogger.Classes Namespace


Status Property

ReloggerProfile..::..Status Property

Gets or sets the status (avoid to edit value manually, to check if profile is running you can use IsStart()()()(), to start or stop profile use Start()()()() or Stop()()()()).

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
[XmlIgnoreAttribute]
public Status Status { get; set; }
<XmlIgnoreAttribute> _
Public Property Status As Status
    Get
    Set
[XmlIgnoreAttribute]
public:
property Status^ Status {
    Status^ get ();
    void set (Status^ value);
}

Field Value

The status.

See Also

ReloggerProfile Class
Relogger.Classes Namespace


ReloggerProfileSettings Class

Class ReloggerProfileSettings.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
[SerializableAttribute]
[ObfuscationAttribute]
public class ReloggerProfileSettings
<SerializableAttribute> _
<ObfuscationAttribute> _
Public Class ReloggerProfileSettings
[SerializableAttribute]
[ObfuscationAttribute]
public ref class ReloggerProfileSettings

Inheritance Hierarchy

Object
Relogger.Classes..::..ReloggerProfileSettings

See Also

ReloggerProfileSettings Members
Relogger.Classes Namespace


ReloggerProfileSettings Members

The ReloggerProfileSettings type exposes the following members.

Constructors

 | Name | Description
Public method | ReloggerProfileSettings | Initializes a new instance of the ReloggerProfileSettings class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetErrors | Gets profile and tasks configuration errors.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValid | Returns true if profile and tasks are valid, no GetErrors()()()().
Public property | MinimiseWRobotOnStart | Minimize bot on start.
Public property | RelaunchIfWowOrWRobotCrash | Relaunch if Wow or bot crash
Public property | RunTasksLoop | Run profile tasks in loop (run again first task when last task is finish)
Public property | ScheduleFrom | Gets or sets working schedule start time, by default new DateTime(1, 1, 1, 00, 00, 00);.
Public property | ScheduleResetAtEnd | Gets or sets a value indicating if reset tasks progress (start every time from the first task) at end of working schedule
Public property | ScheduleTo | Gets or sets working schedule end time, by default new DateTime(1, 1, 1, 23, 59, 59);.
Public property | Tasks | Gets or sets profile tasks list.
Public property | WowAccount | Gets or sets wow account information.
Public property | WowWindow | Gets or sets the wow window position and size ( new Rectangle(); to don't use this option).
Public property | WRobotAccount | Gets or sets bot license key

See Also

ReloggerProfileSettings Class
Relogger.Classes Namespace


ReloggerProfileSettings Constructor

Initializes a new instance of the ReloggerProfileSettings class.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public ReloggerProfileSettings()
Public Sub New
public:
ReloggerProfileSettings()

See Also

ReloggerProfileSettings Class
Relogger.Classes Namespace


ReloggerProfileSettings Methods

The ReloggerProfileSettings type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetErrors | Gets profile and tasks configuration errors.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

ReloggerProfileSettings Class
Relogger.Classes Namespace


GetErrors Method

ReloggerProfileSettings..::..GetErrors Method

Gets profile and tasks configuration errors.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public List<string> GetErrors()
Public Function GetErrors As List(Of String)
public:
List<String^>^ GetErrors()

Return Value

List<System.String>.

See Also

ReloggerProfileSettings Class
Relogger.Classes Namespace


ReloggerProfileSettings Properties

The ReloggerProfileSettings type exposes the following members.

Properties

 | Name | Description
Public property | IsValid | Returns true if profile and tasks are valid, no GetErrors()()()().
Public property | MinimiseWRobotOnStart | Minimize bot on start.
Public property | RelaunchIfWowOrWRobotCrash | Relaunch if Wow or bot crash
Public property | RunTasksLoop | Run profile tasks in loop (run again first task when last task is finish)
Public property | ScheduleFrom | Gets or sets working schedule start time, by default new DateTime(1, 1, 1, 00, 00, 00);.
Public property | ScheduleResetAtEnd | Gets or sets a value indicating if reset tasks progress (start every time from the first task) at end of working schedule
Public property | ScheduleTo | Gets or sets working schedule end time, by default new DateTime(1, 1, 1, 23, 59, 59);.
Public property | Tasks | Gets or sets profile tasks list.
Public property | WowAccount | Gets or sets wow account information.
Public property | WowWindow | Gets or sets the wow window position and size ( new Rectangle(); to don't use this option).
Public property | WRobotAccount | Gets or sets bot license key

See Also

ReloggerProfileSettings Class
Relogger.Classes Namespace


IsValid Property

ReloggerProfileSettings..::..IsValid Property

Returns true if profile and tasks are valid, no GetErrors()()()().

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public bool IsValid { get; }
Public ReadOnly Property IsValid As Boolean
    Get
public:
property bool^ IsValid {
    bool^ get ();
}

Field Value

true if this profile and tasks are valid; otherwise, false.

See Also

ReloggerProfileSettings Class
Relogger.Classes Namespace


MinimiseWRobotOnStart Property

ReloggerProfileSettings..::..MinimiseWRobotOnStart Property

Minimize bot on start.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public bool MinimiseWRobotOnStart { get; set; }
Public Property MinimiseWRobotOnStart As Boolean
    Get
    Set
public:
property bool^ MinimiseWRobotOnStart {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if minimize bot on start; otherwise, false.

See Also

ReloggerProfileSettings Class
Relogger.Classes Namespace


RelaunchIfWowOrWRobotCrash Property

ReloggerProfileSettings..::..RelaunchIfWowOrWRobotCrash Property

Relaunch if Wow or bot crash

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public bool RelaunchIfWowOrWRobotCrash { get; set; }
Public Property RelaunchIfWowOrWRobotCrash As Boolean
    Get
    Set
public:
property bool^ RelaunchIfWowOrWRobotCrash {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if relaunch when crash; otherwise, false.

See Also

ReloggerProfileSettings Class
Relogger.Classes Namespace


RunTasksLoop Property

ReloggerProfileSettings..::..RunTasksLoop Property

Run profile tasks in loop (run again first task when last task is finish)

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public bool RunTasksLoop { get; set; }
Public Property RunTasksLoop As Boolean
    Get
    Set
public:
property bool^ RunTasksLoop {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if run in loop, otherwise false.

See Also

ReloggerProfileSettings Class
Relogger.Classes Namespace


ScheduleFrom Property

ReloggerProfileSettings..::..ScheduleFrom Property

Gets or sets working schedule start time, by default new DateTime(1, 1, 1, 00, 00, 00);.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public DateTime ScheduleFrom { get; set; }
Public Property ScheduleFrom As DateTime
    Get
    Set
public:
property DateTime^ ScheduleFrom {
    DateTime^ get ();
    void set (DateTime^ value);
}

Field Value

The schedule from.

See Also

ReloggerProfileSettings Class
Relogger.Classes Namespace


ScheduleResetAtEnd Property

ReloggerProfileSettings..::..ScheduleResetAtEnd Property

Gets or sets a value indicating if reset tasks progress (start every time from the first task) at end of working schedule

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public bool ScheduleResetAtEnd { get; set; }
Public Property ScheduleResetAtEnd As Boolean
    Get
    Set
public:
property bool^ ScheduleResetAtEnd {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if you want start all time from first task; otherwise false to continue the task where he was.

See Also

ReloggerProfileSettings Class
Relogger.Classes Namespace


ScheduleTo Property

ReloggerProfileSettings..::..ScheduleTo Property

Gets or sets working schedule end time, by default new DateTime(1, 1, 1, 23, 59, 59);.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public DateTime ScheduleTo { get; set; }
Public Property ScheduleTo As DateTime
    Get
    Set
public:
property DateTime^ ScheduleTo {
    DateTime^ get ();
    void set (DateTime^ value);
}

Field Value

The schedule to.

See Also

ReloggerProfileSettings Class
Relogger.Classes Namespace


Tasks Property

ReloggerProfileSettings..::..Tasks Property

Gets or sets profile tasks list.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public List<ReloggerTask> Tasks { get; set; }
Public Property Tasks As List(Of ReloggerTask)
    Get
    Set
public:
property List<ReloggerTask^>^ Tasks {
    List<ReloggerTask^>^ get ();
    void set (List<ReloggerTask^>^ value);
}

Field Value

The tasks.

See Also

ReloggerProfileSettings Class
Relogger.Classes Namespace


WowAccount Property

ReloggerProfileSettings..::..WowAccount Property

Gets or sets wow account information.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public ChangeCharacterReloggerTask WowAccount { get; set; }
Public Property WowAccount As ChangeCharacterReloggerTask
    Get
    Set
public:
property ChangeCharacterReloggerTask^ WowAccount {
    ChangeCharacterReloggerTask^ get ();
    void set (ChangeCharacterReloggerTask^ value);
}

Field Value

The wow account.

See Also

ReloggerProfileSettings Class
Relogger.Classes Namespace


WowWindow Property

ReloggerProfileSettings..::..WowWindow Property

Gets or sets the wow window position and size ( new Rectangle(); to don't use this option).

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public Rectangle WowWindow { get; set; }
Public Property WowWindow As Rectangle
    Get
    Set
public:
property Rectangle^ WowWindow {
    Rectangle^ get ();
    void set (Rectangle^ value);
}

Field Value

The wow window.

See Also

ReloggerProfileSettings Class
Relogger.Classes Namespace


WRobotAccount Property

ReloggerProfileSettings..::..WRobotAccount Property

Gets or sets bot license key

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public ChangeWRobotLicenseKeyReloggerTask WRobotAccount { get; set; }
Public Property WRobotAccount As ChangeWRobotLicenseKeyReloggerTask
    Get
    Set
public:
property ChangeWRobotLicenseKeyReloggerTask^ WRobotAccount {
    ChangeWRobotLicenseKeyReloggerTask^ get ();
    void set (ChangeWRobotLicenseKeyReloggerTask^ value);
}

Field Value

The w robot account.

See Also

ReloggerProfileSettings Class
Relogger.Classes Namespace


ReloggerTask Class

Class ReloggerTask, adaptator of classes that inherit of BaseReloggerTask.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
[SerializableAttribute]
[ObfuscationAttribute]
public class ReloggerTask
<SerializableAttribute> _
<ObfuscationAttribute> _
Public Class ReloggerTask
[SerializableAttribute]
[ObfuscationAttribute]
public ref class ReloggerTask

Inheritance Hierarchy

Object
Relogger.Classes..::..ReloggerTask

See Also

ReloggerTask Members
Relogger.Classes Namespace


ReloggerTask Members

The ReloggerTask type exposes the following members.

Constructors

 | Name | Description
Public method | ReloggerTask | Initializes a new instance of the ReloggerTask class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetErrors | Gets the task settings errors.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs Task
Public method | ToString | Returns a String that represents this instance.

Properties

 | Name | Description
Public property | IsValid | Returns true if is valid.
Public property | Name | Gets or sets task name.
Public property | Task | Gets or sets task instance.
Public property | TaskType | Gets or sets string task type (you can found supported names here TaskType)

See Also

ReloggerTask Class
Relogger.Classes Namespace


ReloggerTask Constructor

Initializes a new instance of the ReloggerTask class.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public ReloggerTask()
Public Sub New
public:
ReloggerTask()

See Also

ReloggerTask Class
Relogger.Classes Namespace


ReloggerTask Methods

The ReloggerTask type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetErrors | Gets the task settings errors.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs Task
Public method | ToString | Returns a String that represents this instance.

See Also

ReloggerTask Class
Relogger.Classes Namespace


GetErrors Method

ReloggerTask..::..GetErrors Method

Gets the task settings errors.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public List<string> GetErrors()
Public Function GetErrors As List(Of String)
public:
List<String^>^ GetErrors()

Return Value

List<System.String>.

See Also

ReloggerTask Class
Relogger.Classes Namespace


Run Method

ReloggerTask..::..Run Method

Runs Task

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public void Run(
    ReloggerProfile parent
)
Public Sub Run ( _
    parent As ReloggerProfile _
)
public:
void Run(
    ReloggerProfile^ parent
)

Parameters

parent
Type: Relogger.Classes..::..ReloggerProfile
profile instance that contain this task

See Also

ReloggerTask Class
Relogger.Classes Namespace


ToString Method

ReloggerTask..::..ToString Method

Returns a String that represents this instance.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public string ToString()
Public Function ToString As String
public:
String^ ToString()

Return Value

A String that represents this instance.

See Also

ReloggerTask Class
Relogger.Classes Namespace


ReloggerTask Properties

The ReloggerTask type exposes the following members.

Properties

 | Name | Description
Public property | IsValid | Returns true if is valid.
Public property | Name | Gets or sets task name.
Public property | Task | Gets or sets task instance.
Public property | TaskType | Gets or sets string task type (you can found supported names here TaskType)

See Also

ReloggerTask Class
Relogger.Classes Namespace


IsValid Property

ReloggerTask..::..IsValid Property

Returns true if is valid.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public bool IsValid { get; }
Public ReadOnly Property IsValid As Boolean
    Get
public:
property bool^ IsValid {
    bool^ get ();
}

Field Value

true if this instance is valid; otherwise, false.

See Also

ReloggerTask Class
Relogger.Classes Namespace


Name Property

ReloggerTask..::..Name Property

Gets or sets task name.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Field Value

The name.

See Also

ReloggerTask Class
Relogger.Classes Namespace


Task Property

ReloggerTask..::..Task Property

Gets or sets task instance.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public BaseReloggerTask Task { get; set; }
Public Property Task As BaseReloggerTask
    Get
    Set
public:
property BaseReloggerTask^ Task {
    BaseReloggerTask^ get ();
    void set (BaseReloggerTask^ value);
}

Field Value

The task.

See Also

ReloggerTask Class
Relogger.Classes Namespace


TaskType Property

ReloggerTask..::..TaskType Property

Gets or sets string task type (you can found supported names here TaskType)

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
[XmlIgnoreAttribute]
public string TaskType { get; set; }
<XmlIgnoreAttribute> _
Public Property TaskType As String
    Get
    Set
[XmlIgnoreAttribute]
public:
property String^ TaskType {
    String^ get ();
    void set (String^ value);
}

Field Value

The type of the task.

See Also

ReloggerTask Class
Relogger.Classes Namespace


RunReloggerTask Class

Class RunReloggerTask. Implements the BaseReloggerTask

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
[SerializableAttribute]
[ObfuscationAttribute]
public class RunReloggerTask : BaseReloggerTask
<SerializableAttribute> _
<ObfuscationAttribute> _
Public Class RunReloggerTask _
    Inherits BaseReloggerTask
[SerializableAttribute]
[ObfuscationAttribute]
public ref class RunReloggerTask : public BaseReloggerTask

Inheritance Hierarchy

Object
Relogger.Classes..::..BaseReloggerTask
Relogger.Classes..::..RunReloggerTask

See Also

RunReloggerTask Members
Relogger.Classes Namespace
Relogger.Classes..::..BaseReloggerTask


RunReloggerTask Members

The RunReloggerTask type exposes the following members.

Constructors

 | Name | Description
Public method | RunReloggerTask | Initializes a new instance of the RunReloggerTask class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetErrors | Gets settings errors.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs task.
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | AdditionalArgs | Gets or sets additional bot args.
Public property | FightClass | Gets or sets the fight class path (path relative to "WRobot\FightClass\").
Public property | IsValid | Returns true if is valid. (Inherited from BaseReloggerTask.)
Public property | Product | Gets or sets the bot product name (file name found in folder "Products" without .dll).
Public property | Profile | Gets or sets the profile path used by product (path like he appear in bot product settings, no full path).
Public property | RunTime | Gets or sets the run time, like "60-70".
Public property | TaskType | Gets the type of the task.
Public property | UserControlWpf | Gets or sets the user control. (Inherited from BaseReloggerTask.)

See Also

RunReloggerTask Class
Relogger.Classes Namespace


RunReloggerTask Constructor

Initializes a new instance of the RunReloggerTask class.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public RunReloggerTask()
Public Sub New
public:
RunReloggerTask()

See Also

RunReloggerTask Class
Relogger.Classes Namespace


RunReloggerTask Methods

The RunReloggerTask type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetErrors | Gets settings errors.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs task.
Public method | ToString | (Inherited from Object.)

See Also

RunReloggerTask Class
Relogger.Classes Namespace


GetErrors Method

RunReloggerTask..::..GetErrors Method

Gets settings errors.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public List<string> GetErrors()
Public Function GetErrors As List(Of String)
public:
List<String^>^ GetErrors()

Return Value

List<System.String>.

See Also

RunReloggerTask Class
Relogger.Classes Namespace


Run Method

RunReloggerTask..::..Run Method

Runs task.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public void Run(
    ReloggerProfile parent
)
Public Sub Run ( _
    parent As ReloggerProfile _
)
public:
void Run(
    ReloggerProfile^ parent
)

Parameters

parent
Type: Relogger.Classes..::..ReloggerProfile
profile that contain this task.

See Also

RunReloggerTask Class
Relogger.Classes Namespace


RunReloggerTask Properties

The RunReloggerTask type exposes the following members.

Properties

 | Name | Description
Public property | AdditionalArgs | Gets or sets additional bot args.
Public property | FightClass | Gets or sets the fight class path (path relative to "WRobot\FightClass\").
Public property | IsValid | Returns true if is valid. (Inherited from BaseReloggerTask.)
Public property | Product | Gets or sets the bot product name (file name found in folder "Products" without .dll).
Public property | Profile | Gets or sets the profile path used by product (path like he appear in bot product settings, no full path).
Public property | RunTime | Gets or sets the run time, like "60-70".
Public property | TaskType | Gets the type of the task.
Public property | UserControlWpf | Gets or sets the user control. (Inherited from BaseReloggerTask.)

See Also

RunReloggerTask Class
Relogger.Classes Namespace


AdditionalArgs Property

RunReloggerTask..::..AdditionalArgs Property

Gets or sets additional bot args.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public string AdditionalArgs { get; set; }
Public Property AdditionalArgs As String
    Get
    Set
public:
property String^ AdditionalArgs {
    String^ get ();
    void set (String^ value);
}

Field Value

The additional bot arguments.

See Also

RunReloggerTask Class
Relogger.Classes Namespace


FightClass Property

RunReloggerTask..::..FightClass Property

Gets or sets the fight class path (path relative to "WRobot\FightClass\").

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public string FightClass { get; set; }
Public Property FightClass As String
    Get
    Set
public:
property String^ FightClass {
    String^ get ();
    void set (String^ value);
}

Field Value

The fight class.

See Also

RunReloggerTask Class
Relogger.Classes Namespace


Product Property

RunReloggerTask..::..Product Property

Gets or sets the bot product name (file name found in folder "Products" without .dll).

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public string Product { get; set; }
Public Property Product As String
    Get
    Set
public:
property String^ Product {
    String^ get ();
    void set (String^ value);
}

Field Value

The product.

See Also

RunReloggerTask Class
Relogger.Classes Namespace


Profile Property

RunReloggerTask..::..Profile Property

Gets or sets the profile path used by product (path like he appear in bot product settings, no full path).

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public string Profile { get; set; }
Public Property Profile As String
    Get
    Set
public:
property String^ Profile {
    String^ get ();
    void set (String^ value);
}

Field Value

The profile.

See Also

RunReloggerTask Class
Relogger.Classes Namespace


RunTime Property

RunReloggerTask..::..RunTime Property

Gets or sets the run time, like "60-70".

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public string RunTime { get; set; }
Public Property RunTime As String
    Get
    Set
public:
property String^ RunTime {
    String^ get ();
    void set (String^ value);
}

Field Value

The run time.

See Also

RunReloggerTask Class
Relogger.Classes Namespace


TaskType Property

RunReloggerTask..::..TaskType Property

Gets the type of the task.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public TaskType TaskType { get; }
Public ReadOnly Property TaskType As TaskType
    Get
public:
property TaskType^ TaskType {
    TaskType^ get ();
}

Field Value

The type of the task.

See Also

RunReloggerTask Class
Relogger.Classes Namespace


Status Enumeration

Profile status

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
[ObfuscationAttribute]
public enum Status
<ObfuscationAttribute> _
Public Enumeration Status
[ObfuscationAttribute]
public enum class Status

Members

Member name | Description
Stopped |
Stopping |
Running |
WaitingSchedule |

See Also

Relogger.Classes Namespace


TaskType Enumeration

Tasks type

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
[ObfuscationAttribute]
public enum TaskType
<ObfuscationAttribute> _
Public Enumeration TaskType
[ObfuscationAttribute]
public enum class TaskType

Members

Member name | Description
None | Task BaseReloggerTask
Run | Task RunReloggerTask
Wait | Task WaitReloggerTask
ChangeCharacter | Task ChangeCharacterReloggerTask
ChangeRagnarLicenseKey | Task ChangeWRobotLicenseKeyReloggerTask
ChangeWowPath | Task ChangeWowPathReloggerTask
ChangeRagnarPath | Task ChangeWRobotPathReloggerTask

See Also

Relogger.Classes Namespace


WaitReloggerTask Class

Class WaitReloggerTask. Implements the BaseReloggerTask

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
[SerializableAttribute]
[ObfuscationAttribute]
public class WaitReloggerTask : BaseReloggerTask
<SerializableAttribute> _
<ObfuscationAttribute> _
Public Class WaitReloggerTask _
    Inherits BaseReloggerTask
[SerializableAttribute]
[ObfuscationAttribute]
public ref class WaitReloggerTask : public BaseReloggerTask

Inheritance Hierarchy

Object
Relogger.Classes..::..BaseReloggerTask
Relogger.Classes..::..WaitReloggerTask

See Also

WaitReloggerTask Members
Relogger.Classes Namespace
Relogger.Classes..::..BaseReloggerTask


WaitReloggerTask Members

The WaitReloggerTask type exposes the following members.

Constructors

 | Name | Description
Public method | WaitReloggerTask | Initializes a new instance of the WaitReloggerTask class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetErrors | Gets settings errors.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs task.
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | CloseWow | Gets or sets a value indicating he closes wow during wait time.
Public property | IsValid | Returns true if is valid. (Inherited from BaseReloggerTask.)
Public property | TaskType | Gets the type of the task.
Public property | UserControlWpf | Gets or sets the user control. (Inherited from BaseReloggerTask.)
Public property | WaitTime | Gets or sets the wait time.

See Also

WaitReloggerTask Class
Relogger.Classes Namespace


WaitReloggerTask Constructor

Initializes a new instance of the WaitReloggerTask class.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public WaitReloggerTask()
Public Sub New
public:
WaitReloggerTask()

See Also

WaitReloggerTask Class
Relogger.Classes Namespace


WaitReloggerTask Methods

The WaitReloggerTask type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetErrors | Gets settings errors.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs task.
Public method | ToString | (Inherited from Object.)

See Also

WaitReloggerTask Class
Relogger.Classes Namespace


GetErrors Method

WaitReloggerTask..::..GetErrors Method

Gets settings errors.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public List<string> GetErrors()
Public Function GetErrors As List(Of String)
public:
List<String^>^ GetErrors()

Return Value

List<System.String>.

See Also

WaitReloggerTask Class
Relogger.Classes Namespace


Run Method

WaitReloggerTask..::..Run Method

Runs task.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public void Run(
    ReloggerProfile parent
)
Public Sub Run ( _
    parent As ReloggerProfile _
)
public:
void Run(
    ReloggerProfile^ parent
)

Parameters

parent
Type: Relogger.Classes..::..ReloggerProfile
profile that contain this task.

See Also

WaitReloggerTask Class
Relogger.Classes Namespace


WaitReloggerTask Properties

The WaitReloggerTask type exposes the following members.

Properties

 | Name | Description
Public property | CloseWow | Gets or sets a value indicating he closes wow during wait time.
Public property | IsValid | Returns true if is valid. (Inherited from BaseReloggerTask.)
Public property | TaskType | Gets the type of the task.
Public property | UserControlWpf | Gets or sets the user control. (Inherited from BaseReloggerTask.)
Public property | WaitTime | Gets or sets the wait time.

See Also

WaitReloggerTask Class
Relogger.Classes Namespace


CloseWow Property

WaitReloggerTask..::..CloseWow Property

Gets or sets a value indicating he closes wow during wait time.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public bool CloseWow { get; set; }
Public Property CloseWow As Boolean
    Get
    Set
public:
property bool^ CloseWow {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if he closes wow during wait time.; otherwise, false.

See Also

WaitReloggerTask Class
Relogger.Classes Namespace


TaskType Property

WaitReloggerTask..::..TaskType Property

Gets the type of the task.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public TaskType TaskType { get; }
Public ReadOnly Property TaskType As TaskType
    Get
public:
property TaskType^ TaskType {
    TaskType^ get ();
}

Field Value

The type of the task.

See Also

WaitReloggerTask Class
Relogger.Classes Namespace


WaitTime Property

WaitReloggerTask..::..WaitTime Property

Gets or sets the wait time.

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public string WaitTime { get; set; }
Public Property WaitTime As String
    Get
    Set
public:
property String^ WaitTime {
    String^ get ();
    void set (String^ value);
}

Field Value

The wait time.

See Also

WaitReloggerTask Class
Relogger.Classes Namespace


Relogger.UserControlsAndWindows Namespace

Classes

 | Class | Description
Public class | ChangeCharacterReloggerUserControl | Logique d'interaction pour ChangeCharacterReloggerUserControl.xaml
Public class | ChangeWowPathUserControl | Logique d'interaction pour ChangeWowPath.xaml
Public class | ChangeWRobotLicenseKeyUserControl | Logique d'interaction pour ChangeWRobotLicenseKeyUserControl.xaml
Public class | ChangeWRobotPathUserControl | Logique d'interaction pour ChangeWRobotPath.xaml
Public class | ReloggerGeneralSettingsWindow | Class ReloggerGeneralSettingsWindow. Implements the Window Implements the IComponentConnector
Public class | ReloggerProfileSettingsUserControl | Logique d'interaction pour ReloggerProfileSettingsUserControl.xaml
Public class | RunReloggerTaskUserControl | Logique d'interaction pour RunReloggerTaskUserControl.xaml
Public class | TasksUserControl | Logique d'interaction pour TasksUserControl.xaml
Public class | WaitReloggerTaskUserControl | Logique d'interaction pour WaitReloggerTaskUserControl.xaml
Public class | ZoneSelectWindow | Logique d'interaction pour ZoneSelectWindow.xaml


ChangeCharacterReloggerUserControl Class

Logique d'interaction pour ChangeCharacterReloggerUserControl.xaml

Namespace: Relogger.UserControlsAndWindows
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public class ChangeCharacterReloggerUserControl : UserControl
Public Class ChangeCharacterReloggerUserControl _
    Inherits UserControl
public ref class ChangeCharacterReloggerUserControl : public UserControl

Inheritance Hierarchy

Object
DispatcherObject
DependencyObject
Visual
UIElement
FrameworkElement
Control
ContentControl
UserControl
Relogger.UserControlsAndWindows..::..ChangeCharacterReloggerUserControl

See Also

ChangeCharacterReloggerUserControl Members
Relogger.UserControlsAndWindows Namespace


ChangeCharacterReloggerUserControl Members

The ChangeCharacterReloggerUserControl type exposes the following members.

Constructors

 | Name | Description
Public method | ChangeCharacterReloggerUserControl | Initializes a new instance of the ChangeCharacterReloggerUserControl class.

Methods

 | Name | Description
Protected method | AddChild(System.Object) | (Inherited from ContentControl.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate,System.Boolean) | (Inherited from UIElement.)
Protected method | AddText(System.String) | (Inherited from ContentControl.)
Public method | AddToEventRoute(System.Windows.EventRoute,System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | AddVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock) | (Inherited from UIElement.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from FrameworkElement.)
Public method | Arrange(System.Windows.Rect) | (Inherited from UIElement.)
Protected method | ArrangeCore(System.Windows.Rect) | (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(System.Windows.Size) | (Inherited from Control.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline) | (Inherited from UIElement.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | BeginInit | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior,System.Boolean) | (Inherited from FrameworkElement.)
Public method | BringIntoView | (Inherited from FrameworkElement.)
Public method | BringIntoView(System.Windows.Rect) | (Inherited from FrameworkElement.)
Public method | CaptureMouse | (Inherited from UIElement.)
Public method | CaptureStylus | (Inherited from UIElement.)
Public method | CaptureTouch(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DispatcherObject.)
Public method | ClearValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | ClearValue(System.Windows.DependencyPropertyKey) | (Inherited from DependencyObject.)
Public method | CoerceValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | EndInit | (Inherited from FrameworkElement.)
Public method | Equals(System.Object) | (Inherited from DependencyObject.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindCommonVisualAncestor(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | FindName(System.String) | (Inherited from FrameworkElement.)
Public method | FindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from UIElement.)
Public method | GetAnimationBaseValue(System.Windows.DependencyProperty) | (Inherited from UIElement.)
Public method | GetBindingExpression(System.Windows.DependencyProperty) | (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from DependencyObject.)
Protected method | GetLayoutClip(System.Windows.Size) | (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | (Inherited from DependencyObject.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Protected method | GetVisualChild(System.Int32) | (Inherited from FrameworkElement.)
Protected method | HitTestCore(System.Windows.Media.PointHitTestParameters) | (Inherited from UIElement.)
Protected method | HitTestCore(System.Windows.Media.GeometryHitTestParameters) | (Inherited from UIElement.)
Public method | InputHitTest(System.Windows.Point) | (Inherited from UIElement.)
Public method | InvalidateArrange | (Inherited from UIElement.)
Public method | InvalidateMeasure | (Inherited from UIElement.)
Public method | InvalidateProperty(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | InvalidateVisual | (Inherited from UIElement.)
Public method | IsAncestorOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | IsDescendantOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | Measure(System.Windows.Size) | (Inherited from UIElement.)
Protected method | MeasureCore(System.Windows.Size) | (Inherited from FrameworkElement.)
Protected method | MeasureOverride(System.Windows.Size) | (Inherited from Control.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | MoveFocus(System.Windows.Input.TraversalRequest) | (Inherited from FrameworkElement.)
Protected method | OnAccessKey(System.Windows.Input.AccessKeyEventArgs) | (Inherited from UIElement.)
Public method | OnApplyTemplate | (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged(System.Windows.UIElement) | (Inherited from UIElement.)
Protected method | OnContentChanged(System.Object,System.Object) | (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged(System.String,System.String) | (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged(System.Windows.DataTemplate,System.Windows.DataTemplate) | (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged(System.Windows.Controls.DataTemplateSelector,System.Windows.Controls.DataTemplateSelector) | (Inherited from ContentControl.)
Protected method | OnContextMenuClosing(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | (Inherited from UserControl.)
Protected method | OnDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnGotFocus(System.Windows.RoutedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnGotMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnGotStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnGotTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnInitialized(System.EventArgs) | (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnLostFocus(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnLostStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnLostTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback(System.Windows.Input.ManipulationBoundaryFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationCompleted(System.Windows.Input.ManipulationCompletedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationDelta(System.Windows.Input.ManipulationDeltaEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting(System.Windows.Input.ManipulationInertiaStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarted(System.Windows.Input.ManipulationStartedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarting(System.Windows.Input.ManipulationStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseEnter(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeave(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnPreviewMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPropertyChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnQueryCursor(System.Windows.Input.QueryCursorEventArgs) | (Inherited from UIElement.)
Protected method | OnRender(System.Windows.Media.DrawingContext) | (Inherited from UIElement.)
Protected method | OnStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusEnter(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusLeave(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnTemplateChanged(System.Windows.Controls.ControlTemplate,System.Windows.Controls.ControlTemplate) | (Inherited from Control.)
Protected method | OnTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnToolTipClosing(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchEnter(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchLeave(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Public method | PointFromScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PointToScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PredictFocus(System.Windows.Input.FocusNavigationDirection) | (Inherited from FrameworkElement.)
Public method | RaiseEvent(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Public method | ReadLocalValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | RegisterName(System.String,System.Object) | (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | (Inherited from UIElement.)
Public method | ReleaseMouseCapture | (Inherited from UIElement.)
Public method | ReleaseStylusCapture | (Inherited from UIElement.)
Public method | ReleaseTouchCapture(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | RemoveHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Protected method | RemoveVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | SetBinding(System.Windows.DependencyProperty,System.Windows.Data.BindingBase) | (Inherited from FrameworkElement.)
Public method | SetBinding(System.Windows.DependencyProperty,System.String) | (Inherited from FrameworkElement.)
Public method | SetCurrentValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetResourceReference(System.Windows.DependencyProperty,System.Object) | (Inherited from FrameworkElement.)
Public method | SetValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetValue(System.Windows.DependencyPropertyKey,System.Object) | (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | (Inherited from UIElement.)
Public method | ShouldSerializeContent | (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | (Inherited from UIElement.)
Public method | ShouldSerializeResources | (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | (Inherited from FrameworkElement.)
Public method | ToString | (Inherited from Control.)
Public method | TransformToAncestor(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToAncestor(System.Windows.Media.Media3D.Visual3D) | (Inherited from Visual.)
Public method | TransformToDescendant(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToVisual(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TranslatePoint(System.Windows.Point,System.Windows.UIElement) | (Inherited from UIElement.)
Public method | TryFindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | UnregisterName(System.String) | (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | (Inherited from FrameworkElement.)
Public method | UpdateLayout | (Inherited from UIElement.)
Public method | VerifyAccess | (Inherited from DispatcherObject.)

Properties

 | Name | Description
Public property | ActualHeight | (Inherited from FrameworkElement.)
Public property | ActualWidth | (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
Public property | AreAnyTouchesOver | (Inherited from UIElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from FrameworkElement.)
Public property | BitmapEffect | (Inherited from UIElement.)
Public property | BitmapEffectInput | (Inherited from UIElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | (Inherited from UIElement.)
Public property | ClipToBounds | (Inherited from UIElement.)
Public property | CommandBindings | (Inherited from UIElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContentTemplate | (Inherited from ContentControl.)
Public property | ContentTemplateSelector | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from FrameworkElement.)
Public property | Cursor | (Inherited from FrameworkElement.)
Public property | DataContext | (Inherited from FrameworkElement.)
Public property | DependencyObjectType | (Inherited from DependencyObject.)
Public property | DesiredSize | (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DispatcherObject.)
Public property | Effect | (Inherited from UIElement.)
Public property | FlowDirection | (Inherited from FrameworkElement.)
Public property | Focusable | (Inherited from UIElement.)
Public property | FocusVisualStyle | (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from FrameworkElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasAnimatedProperties | (Inherited from UIElement.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | InputBindings | (Inherited from UIElement.)
Public property | InputScope | (Inherited from FrameworkElement.)
Public property | IsArrangeValid | (Inherited from UIElement.)
Public property | IsEnabled | (Inherited from UIElement.)
Protected property | IsEnabledCore | (Inherited from UIElement.)
Public property | IsFocused | (Inherited from UIElement.)
Public property | IsHitTestVisible | (Inherited from UIElement.)
Public property | IsInitialized | (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | (Inherited from UIElement.)
Public property | IsKeyboardFocused | (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | (Inherited from UIElement.)
Public property | IsLoaded | (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | (Inherited from UIElement.)
Public property | IsMeasureValid | (Inherited from UIElement.)
Public property | IsMouseCaptured | (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | (Inherited from UIElement.)
Public property | IsMouseOver | (Inherited from UIElement.)
Public property | IsSealed | (Inherited from DependencyObject.)
Public property | IsStylusCaptured | (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | (Inherited from UIElement.)
Public property | IsStylusOver | (Inherited from UIElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsVisible | (Inherited from UIElement.)
Public property | Language | (Inherited from FrameworkElement.)
Public property | LayoutTransform | (Inherited from FrameworkElement.)
Public property | Margin | (Inherited from FrameworkElement.)
Public property | MaxHeight | (Inherited from FrameworkElement.)
Public property | MaxWidth | (Inherited from FrameworkElement.)
Public property | MinHeight | (Inherited from FrameworkElement.)
Public property | MinWidth | (Inherited from FrameworkElement.)
Public property | Name | (Inherited from FrameworkElement.)
Public property | Opacity | (Inherited from UIElement.)
Public property | OpacityMask | (Inherited from UIElement.)
Public property | OverridesDefaultStyle | (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from FrameworkElement.)
Public property | PersistId | (Inherited from UIElement.)
Public property | RenderSize | (Inherited from UIElement.)
Public property | RenderTransform | (Inherited from UIElement.)
Public property | RenderTransformOrigin | (Inherited from UIElement.)
Public property | Resources | (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from UIElement.)
Public property | Style | (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | (Inherited from UIElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | Tag | (Inherited from FrameworkElement.)
Public property | Template | (Inherited from Control.)
Public property | TemplatedParent | (Inherited from FrameworkElement.)
Public property | ToolTip | (Inherited from FrameworkElement.)
Public property | TouchesCaptured | (Inherited from UIElement.)
Public property | TouchesCapturedWithin | (Inherited from UIElement.)
Public property | TouchesDirectlyOver | (Inherited from UIElement.)
Public property | TouchesOver | (Inherited from UIElement.)
Public property | Triggers | (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from UIElement.)
Public property | UseLayoutRounding | (Inherited from FrameworkElement.)
Public property | VerticalAlignment | (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | (Inherited from UIElement.)
Protected property | VisualChildrenCount | (Inherited from FrameworkElement.)
Protected property | VisualParent | (Inherited from Visual.)
Public property | Width | (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | ContextMenuClosing | (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | (Inherited from FrameworkElement.)
Public event | DataContextChanged | (Inherited from FrameworkElement.)
Public event | DragEnter | (Inherited from UIElement.)
Public event | DragLeave | (Inherited from UIElement.)
Public event | DragOver | (Inherited from UIElement.)
Public event | Drop | (Inherited from UIElement.)
Public event | FocusableChanged | (Inherited from UIElement.)
Public event | GiveFeedback | (Inherited from UIElement.)
Public event | GotFocus | (Inherited from UIElement.)
Public event | GotKeyboardFocus | (Inherited from UIElement.)
Public event | GotMouseCapture | (Inherited from UIElement.)
Public event | GotStylusCapture | (Inherited from UIElement.)
Public event | GotTouchCapture | (Inherited from UIElement.)
Public event | Initialized | (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsVisibleChanged | (Inherited from UIElement.)
Public event | KeyDown | (Inherited from UIElement.)
Public event | KeyUp | (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from UIElement.)
Public event | Loaded | (Inherited from FrameworkElement.)
Public event | LostFocus | (Inherited from UIElement.)
Public event | LostKeyboardFocus | (Inherited from UIElement.)
Public event | LostMouseCapture | (Inherited from UIElement.)
Public event | LostStylusCapture | (Inherited from UIElement.)
Public event | LostTouchCapture | (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | ManipulationStarting | (Inherited from UIElement.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from UIElement.)
Public event | MouseEnter | (Inherited from UIElement.)
Public event | MouseLeave | (Inherited from UIElement.)
Public event | MouseLeftButtonDown | (Inherited from UIElement.)
Public event | MouseLeftButtonUp | (Inherited from UIElement.)
Public event | MouseMove | (Inherited from UIElement.)
Public event | MouseRightButtonDown | (Inherited from UIElement.)
Public event | MouseRightButtonUp | (Inherited from UIElement.)
Public event | MouseUp | (Inherited from UIElement.)
Public event | MouseWheel | (Inherited from UIElement.)
Public event | PreviewDragEnter | (Inherited from UIElement.)
Public event | PreviewDragLeave | (Inherited from UIElement.)
Public event | PreviewDragOver | (Inherited from UIElement.)
Public event | PreviewDrop | (Inherited from UIElement.)
Public event | PreviewGiveFeedback | (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewKeyDown | (Inherited from UIElement.)
Public event | PreviewKeyUp | (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | (Inherited from Control.)
Public event | PreviewMouseDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseMove | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseUp | (Inherited from UIElement.)
Public event | PreviewMouseWheel | (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | (Inherited from UIElement.)
Public event | PreviewStylusDown | (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | (Inherited from UIElement.)
Public event | PreviewStylusInRange | (Inherited from UIElement.)
Public event | PreviewStylusMove | (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | (Inherited from UIElement.)
Public event | PreviewStylusUp | (Inherited from UIElement.)
Public event | PreviewTextInput | (Inherited from UIElement.)
Public event | PreviewTouchDown | (Inherited from UIElement.)
Public event | PreviewTouchMove | (Inherited from UIElement.)
Public event | PreviewTouchUp | (Inherited from UIElement.)
Public event | QueryContinueDrag | (Inherited from UIElement.)
Public event | QueryCursor | (Inherited from UIElement.)
Public event | RequestBringIntoView | (Inherited from FrameworkElement.)
Public event | SizeChanged | (Inherited from FrameworkElement.)
Public event | SourceUpdated | (Inherited from FrameworkElement.)
Public event | StylusButtonDown | (Inherited from UIElement.)
Public event | StylusButtonUp | (Inherited from UIElement.)
Public event | StylusDown | (Inherited from UIElement.)
Public event | StylusEnter | (Inherited from UIElement.)
Public event | StylusInAirMove | (Inherited from UIElement.)
Public event | StylusInRange | (Inherited from UIElement.)
Public event | StylusLeave | (Inherited from UIElement.)
Public event | StylusMove | (Inherited from UIElement.)
Public event | StylusOutOfRange | (Inherited from UIElement.)
Public event | StylusSystemGesture | (Inherited from UIElement.)
Public event | StylusUp | (Inherited from UIElement.)
Public event | TargetUpdated | (Inherited from FrameworkElement.)
Public event | TextInput | (Inherited from UIElement.)
Public event | ToolTipClosing | (Inherited from FrameworkElement.)
Public event | ToolTipOpening | (Inherited from FrameworkElement.)
Public event | TouchDown | (Inherited from UIElement.)
Public event | TouchEnter | (Inherited from UIElement.)
Public event | TouchLeave | (Inherited from UIElement.)
Public event | TouchMove | (Inherited from UIElement.)
Public event | TouchUp | (Inherited from UIElement.)
Public event | Unloaded | (Inherited from FrameworkElement.)

See Also

ChangeCharacterReloggerUserControl Class
Relogger.UserControlsAndWindows Namespace


ChangeCharacterReloggerUserControl Constructor

Initializes a new instance of the ChangeCharacterReloggerUserControl class.

Namespace: Relogger.UserControlsAndWindows
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public ChangeCharacterReloggerUserControl()
Public Sub New
public:
ChangeCharacterReloggerUserControl()

See Also

ChangeCharacterReloggerUserControl Class
Relogger.UserControlsAndWindows Namespace


ChangeCharacterReloggerUserControl Methods

The ChangeCharacterReloggerUserControl type exposes the following members.

Methods

 | Name | Description
Protected method | AddChild(System.Object) | (Inherited from ContentControl.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate,System.Boolean) | (Inherited from UIElement.)
Protected method | AddText(System.String) | (Inherited from ContentControl.)
Public method | AddToEventRoute(System.Windows.EventRoute,System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | AddVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock) | (Inherited from UIElement.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from FrameworkElement.)
Public method | Arrange(System.Windows.Rect) | (Inherited from UIElement.)
Protected method | ArrangeCore(System.Windows.Rect) | (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(System.Windows.Size) | (Inherited from Control.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline) | (Inherited from UIElement.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | BeginInit | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior,System.Boolean) | (Inherited from FrameworkElement.)
Public method | BringIntoView | (Inherited from FrameworkElement.)
Public method | BringIntoView(System.Windows.Rect) | (Inherited from FrameworkElement.)
Public method | CaptureMouse | (Inherited from UIElement.)
Public method | CaptureStylus | (Inherited from UIElement.)
Public method | CaptureTouch(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DispatcherObject.)
Public method | ClearValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | ClearValue(System.Windows.DependencyPropertyKey) | (Inherited from DependencyObject.)
Public method | CoerceValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | EndInit | (Inherited from FrameworkElement.)
Public method | Equals(System.Object) | (Inherited from DependencyObject.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindCommonVisualAncestor(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | FindName(System.String) | (Inherited from FrameworkElement.)
Public method | FindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from UIElement.)
Public method | GetAnimationBaseValue(System.Windows.DependencyProperty) | (Inherited from UIElement.)
Public method | GetBindingExpression(System.Windows.DependencyProperty) | (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from DependencyObject.)
Protected method | GetLayoutClip(System.Windows.Size) | (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | (Inherited from DependencyObject.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Protected method | GetVisualChild(System.Int32) | (Inherited from FrameworkElement.)
Protected method | HitTestCore(System.Windows.Media.PointHitTestParameters) | (Inherited from UIElement.)
Protected method | HitTestCore(System.Windows.Media.GeometryHitTestParameters) | (Inherited from UIElement.)
Public method | InputHitTest(System.Windows.Point) | (Inherited from UIElement.)
Public method | InvalidateArrange | (Inherited from UIElement.)
Public method | InvalidateMeasure | (Inherited from UIElement.)
Public method | InvalidateProperty(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | InvalidateVisual | (Inherited from UIElement.)
Public method | IsAncestorOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | IsDescendantOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | Measure(System.Windows.Size) | (Inherited from UIElement.)
Protected method | MeasureCore(System.Windows.Size) | (Inherited from FrameworkElement.)
Protected method | MeasureOverride(System.Windows.Size) | (Inherited from Control.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | MoveFocus(System.Windows.Input.TraversalRequest) | (Inherited from FrameworkElement.)
Protected method | OnAccessKey(System.Windows.Input.AccessKeyEventArgs) | (Inherited from UIElement.)
Public method | OnApplyTemplate | (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged(System.Windows.UIElement) | (Inherited from UIElement.)
Protected method | OnContentChanged(System.Object,System.Object) | (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged(System.String,System.String) | (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged(System.Windows.DataTemplate,System.Windows.DataTemplate) | (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged(System.Windows.Controls.DataTemplateSelector,System.Windows.Controls.DataTemplateSelector) | (Inherited from ContentControl.)
Protected method | OnContextMenuClosing(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | (Inherited from UserControl.)
Protected method | OnDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnGotFocus(System.Windows.RoutedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnGotMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnGotStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnGotTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnInitialized(System.EventArgs) | (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnLostFocus(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnLostStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnLostTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback(System.Windows.Input.ManipulationBoundaryFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationCompleted(System.Windows.Input.ManipulationCompletedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationDelta(System.Windows.Input.ManipulationDeltaEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting(System.Windows.Input.ManipulationInertiaStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarted(System.Windows.Input.ManipulationStartedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarting(System.Windows.Input.ManipulationStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseEnter(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeave(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnPreviewMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPropertyChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnQueryCursor(System.Windows.Input.QueryCursorEventArgs) | (Inherited from UIElement.)
Protected method | OnRender(System.Windows.Media.DrawingContext) | (Inherited from UIElement.)
Protected method | OnStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusEnter(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusLeave(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnTemplateChanged(System.Windows.Controls.ControlTemplate,System.Windows.Controls.ControlTemplate) | (Inherited from Control.)
Protected method | OnTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnToolTipClosing(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchEnter(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchLeave(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Public method | PointFromScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PointToScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PredictFocus(System.Windows.Input.FocusNavigationDirection) | (Inherited from FrameworkElement.)
Public method | RaiseEvent(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Public method | ReadLocalValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | RegisterName(System.String,System.Object) | (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | (Inherited from UIElement.)
Public method | ReleaseMouseCapture | (Inherited from UIElement.)
Public method | ReleaseStylusCapture | (Inherited from UIElement.)
Public method | ReleaseTouchCapture(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | RemoveHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Protected method | RemoveVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | SetBinding(System.Windows.DependencyProperty,System.Windows.Data.BindingBase) | (Inherited from FrameworkElement.)
Public method | SetBinding(System.Windows.DependencyProperty,System.String) | (Inherited from FrameworkElement.)
Public method | SetCurrentValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetResourceReference(System.Windows.DependencyProperty,System.Object) | (Inherited from FrameworkElement.)
Public method | SetValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetValue(System.Windows.DependencyPropertyKey,System.Object) | (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | (Inherited from UIElement.)
Public method | ShouldSerializeContent | (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | (Inherited from UIElement.)
Public method | ShouldSerializeResources | (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | (Inherited from FrameworkElement.)
Public method | ToString | (Inherited from Control.)
Public method | TransformToAncestor(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToAncestor(System.Windows.Media.Media3D.Visual3D) | (Inherited from Visual.)
Public method | TransformToDescendant(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToVisual(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TranslatePoint(System.Windows.Point,System.Windows.UIElement) | (Inherited from UIElement.)
Public method | TryFindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | UnregisterName(System.String) | (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | (Inherited from FrameworkElement.)
Public method | UpdateLayout | (Inherited from UIElement.)
Public method | VerifyAccess | (Inherited from DispatcherObject.)

See Also

ChangeCharacterReloggerUserControl Class
Relogger.UserControlsAndWindows Namespace


ChangeCharacterReloggerUserControl Properties

The ChangeCharacterReloggerUserControl type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | (Inherited from FrameworkElement.)
Public property | ActualWidth | (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
Public property | AreAnyTouchesOver | (Inherited from UIElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from FrameworkElement.)
Public property | BitmapEffect | (Inherited from UIElement.)
Public property | BitmapEffectInput | (Inherited from UIElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | (Inherited from UIElement.)
Public property | ClipToBounds | (Inherited from UIElement.)
Public property | CommandBindings | (Inherited from UIElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContentTemplate | (Inherited from ContentControl.)
Public property | ContentTemplateSelector | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from FrameworkElement.)
Public property | Cursor | (Inherited from FrameworkElement.)
Public property | DataContext | (Inherited from FrameworkElement.)
Public property | DependencyObjectType | (Inherited from DependencyObject.)
Public property | DesiredSize | (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DispatcherObject.)
Public property | Effect | (Inherited from UIElement.)
Public property | FlowDirection | (Inherited from FrameworkElement.)
Public property | Focusable | (Inherited from UIElement.)
Public property | FocusVisualStyle | (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from FrameworkElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasAnimatedProperties | (Inherited from UIElement.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | InputBindings | (Inherited from UIElement.)
Public property | InputScope | (Inherited from FrameworkElement.)
Public property | IsArrangeValid | (Inherited from UIElement.)
Public property | IsEnabled | (Inherited from UIElement.)
Protected property | IsEnabledCore | (Inherited from UIElement.)
Public property | IsFocused | (Inherited from UIElement.)
Public property | IsHitTestVisible | (Inherited from UIElement.)
Public property | IsInitialized | (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | (Inherited from UIElement.)
Public property | IsKeyboardFocused | (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | (Inherited from UIElement.)
Public property | IsLoaded | (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | (Inherited from UIElement.)
Public property | IsMeasureValid | (Inherited from UIElement.)
Public property | IsMouseCaptured | (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | (Inherited from UIElement.)
Public property | IsMouseOver | (Inherited from UIElement.)
Public property | IsSealed | (Inherited from DependencyObject.)
Public property | IsStylusCaptured | (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | (Inherited from UIElement.)
Public property | IsStylusOver | (Inherited from UIElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsVisible | (Inherited from UIElement.)
Public property | Language | (Inherited from FrameworkElement.)
Public property | LayoutTransform | (Inherited from FrameworkElement.)
Public property | Margin | (Inherited from FrameworkElement.)
Public property | MaxHeight | (Inherited from FrameworkElement.)
Public property | MaxWidth | (Inherited from FrameworkElement.)
Public property | MinHeight | (Inherited from FrameworkElement.)
Public property | MinWidth | (Inherited from FrameworkElement.)
Public property | Name | (Inherited from FrameworkElement.)
Public property | Opacity | (Inherited from UIElement.)
Public property | OpacityMask | (Inherited from UIElement.)
Public property | OverridesDefaultStyle | (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from FrameworkElement.)
Public property | PersistId | (Inherited from UIElement.)
Public property | RenderSize | (Inherited from UIElement.)
Public property | RenderTransform | (Inherited from UIElement.)
Public property | RenderTransformOrigin | (Inherited from UIElement.)
Public property | Resources | (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from UIElement.)
Public property | Style | (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | (Inherited from UIElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | Tag | (Inherited from FrameworkElement.)
Public property | Template | (Inherited from Control.)
Public property | TemplatedParent | (Inherited from FrameworkElement.)
Public property | ToolTip | (Inherited from FrameworkElement.)
Public property | TouchesCaptured | (Inherited from UIElement.)
Public property | TouchesCapturedWithin | (Inherited from UIElement.)
Public property | TouchesDirectlyOver | (Inherited from UIElement.)
Public property | TouchesOver | (Inherited from UIElement.)
Public property | Triggers | (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from UIElement.)
Public property | UseLayoutRounding | (Inherited from FrameworkElement.)
Public property | VerticalAlignment | (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | (Inherited from UIElement.)
Protected property | VisualChildrenCount | (Inherited from FrameworkElement.)
Protected property | VisualParent | (Inherited from Visual.)
Public property | Width | (Inherited from FrameworkElement.)

See Also

ChangeCharacterReloggerUserControl Class
Relogger.UserControlsAndWindows Namespace


ChangeCharacterReloggerUserControl Events

The ChangeCharacterReloggerUserControl type exposes the following members.

Events

 | Name | Description
Public event | ContextMenuClosing | (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | (Inherited from FrameworkElement.)
Public event | DataContextChanged | (Inherited from FrameworkElement.)
Public event | DragEnter | (Inherited from UIElement.)
Public event | DragLeave | (Inherited from UIElement.)
Public event | DragOver | (Inherited from UIElement.)
Public event | Drop | (Inherited from UIElement.)
Public event | FocusableChanged | (Inherited from UIElement.)
Public event | GiveFeedback | (Inherited from UIElement.)
Public event | GotFocus | (Inherited from UIElement.)
Public event | GotKeyboardFocus | (Inherited from UIElement.)
Public event | GotMouseCapture | (Inherited from UIElement.)
Public event | GotStylusCapture | (Inherited from UIElement.)
Public event | GotTouchCapture | (Inherited from UIElement.)
Public event | Initialized | (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsVisibleChanged | (Inherited from UIElement.)
Public event | KeyDown | (Inherited from UIElement.)
Public event | KeyUp | (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from UIElement.)
Public event | Loaded | (Inherited from FrameworkElement.)
Public event | LostFocus | (Inherited from UIElement.)
Public event | LostKeyboardFocus | (Inherited from UIElement.)
Public event | LostMouseCapture | (Inherited from UIElement.)
Public event | LostStylusCapture | (Inherited from UIElement.)
Public event | LostTouchCapture | (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | ManipulationStarting | (Inherited from UIElement.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from UIElement.)
Public event | MouseEnter | (Inherited from UIElement.)
Public event | MouseLeave | (Inherited from UIElement.)
Public event | MouseLeftButtonDown | (Inherited from UIElement.)
Public event | MouseLeftButtonUp | (Inherited from UIElement.)
Public event | MouseMove | (Inherited from UIElement.)
Public event | MouseRightButtonDown | (Inherited from UIElement.)
Public event | MouseRightButtonUp | (Inherited from UIElement.)
Public event | MouseUp | (Inherited from UIElement.)
Public event | MouseWheel | (Inherited from UIElement.)
Public event | PreviewDragEnter | (Inherited from UIElement.)
Public event | PreviewDragLeave | (Inherited from UIElement.)
Public event | PreviewDragOver | (Inherited from UIElement.)
Public event | PreviewDrop | (Inherited from UIElement.)
Public event | PreviewGiveFeedback | (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewKeyDown | (Inherited from UIElement.)
Public event | PreviewKeyUp | (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | (Inherited from Control.)
Public event | PreviewMouseDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseMove | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseUp | (Inherited from UIElement.)
Public event | PreviewMouseWheel | (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | (Inherited from UIElement.)
Public event | PreviewStylusDown | (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | (Inherited from UIElement.)
Public event | PreviewStylusInRange | (Inherited from UIElement.)
Public event | PreviewStylusMove | (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | (Inherited from UIElement.)
Public event | PreviewStylusUp | (Inherited from UIElement.)
Public event | PreviewTextInput | (Inherited from UIElement.)
Public event | PreviewTouchDown | (Inherited from UIElement.)
Public event | PreviewTouchMove | (Inherited from UIElement.)
Public event | PreviewTouchUp | (Inherited from UIElement.)
Public event | QueryContinueDrag | (Inherited from UIElement.)
Public event | QueryCursor | (Inherited from UIElement.)
Public event | RequestBringIntoView | (Inherited from FrameworkElement.)
Public event | SizeChanged | (Inherited from FrameworkElement.)
Public event | SourceUpdated | (Inherited from FrameworkElement.)
Public event | StylusButtonDown | (Inherited from UIElement.)
Public event | StylusButtonUp | (Inherited from UIElement.)
Public event | StylusDown | (Inherited from UIElement.)
Public event | StylusEnter | (Inherited from UIElement.)
Public event | StylusInAirMove | (Inherited from UIElement.)
Public event | StylusInRange | (Inherited from UIElement.)
Public event | StylusLeave | (Inherited from UIElement.)
Public event | StylusMove | (Inherited from UIElement.)
Public event | StylusOutOfRange | (Inherited from UIElement.)
Public event | StylusSystemGesture | (Inherited from UIElement.)
Public event | StylusUp | (Inherited from UIElement.)
Public event | TargetUpdated | (Inherited from FrameworkElement.)
Public event | TextInput | (Inherited from UIElement.)
Public event | ToolTipClosing | (Inherited from FrameworkElement.)
Public event | ToolTipOpening | (Inherited from FrameworkElement.)
Public event | TouchDown | (Inherited from UIElement.)
Public event | TouchEnter | (Inherited from UIElement.)
Public event | TouchLeave | (Inherited from UIElement.)
Public event | TouchMove | (Inherited from UIElement.)
Public event | TouchUp | (Inherited from UIElement.)
Public event | Unloaded | (Inherited from FrameworkElement.)

See Also

ChangeCharacterReloggerUserControl Class
Relogger.UserControlsAndWindows Namespace


ChangeWowPathUserControl Class

Logique d'interaction pour ChangeWowPath.xaml

Namespace: Relogger.UserControlsAndWindows
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public class ChangeWowPathUserControl : UserControl
Public Class ChangeWowPathUserControl _
    Inherits UserControl
public ref class ChangeWowPathUserControl : public UserControl

Inheritance Hierarchy

Object
DispatcherObject
DependencyObject
Visual
UIElement
FrameworkElement
Control
ContentControl
UserControl
Relogger.UserControlsAndWindows..::..ChangeWowPathUserControl

See Also

ChangeWowPathUserControl Members
Relogger.UserControlsAndWindows Namespace


ChangeWowPathUserControl Members

The ChangeWowPathUserControl type exposes the following members.

Constructors

 | Name | Description
Public method | ChangeWowPathUserControl | Initializes a new instance of the ChangeWowPathUserControl class.

Methods

 | Name | Description
Protected method | AddChild(System.Object) | (Inherited from ContentControl.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate,System.Boolean) | (Inherited from UIElement.)
Protected method | AddText(System.String) | (Inherited from ContentControl.)
Public method | AddToEventRoute(System.Windows.EventRoute,System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | AddVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock) | (Inherited from UIElement.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from FrameworkElement.)
Public method | Arrange(System.Windows.Rect) | (Inherited from UIElement.)
Protected method | ArrangeCore(System.Windows.Rect) | (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(System.Windows.Size) | (Inherited from Control.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline) | (Inherited from UIElement.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | BeginInit | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior,System.Boolean) | (Inherited from FrameworkElement.)
Public method | BringIntoView | (Inherited from FrameworkElement.)
Public method | BringIntoView(System.Windows.Rect) | (Inherited from FrameworkElement.)
Public method | CaptureMouse | (Inherited from UIElement.)
Public method | CaptureStylus | (Inherited from UIElement.)
Public method | CaptureTouch(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DispatcherObject.)
Public method | ClearValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | ClearValue(System.Windows.DependencyPropertyKey) | (Inherited from DependencyObject.)
Public method | CoerceValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | EndInit | (Inherited from FrameworkElement.)
Public method | Equals(System.Object) | (Inherited from DependencyObject.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindCommonVisualAncestor(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | FindName(System.String) | (Inherited from FrameworkElement.)
Public method | FindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from UIElement.)
Public method | GetAnimationBaseValue(System.Windows.DependencyProperty) | (Inherited from UIElement.)
Public method | GetBindingExpression(System.Windows.DependencyProperty) | (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from DependencyObject.)
Protected method | GetLayoutClip(System.Windows.Size) | (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | (Inherited from DependencyObject.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Protected method | GetVisualChild(System.Int32) | (Inherited from FrameworkElement.)
Protected method | HitTestCore(System.Windows.Media.PointHitTestParameters) | (Inherited from UIElement.)
Protected method | HitTestCore(System.Windows.Media.GeometryHitTestParameters) | (Inherited from UIElement.)
Public method | InputHitTest(System.Windows.Point) | (Inherited from UIElement.)
Public method | InvalidateArrange | (Inherited from UIElement.)
Public method | InvalidateMeasure | (Inherited from UIElement.)
Public method | InvalidateProperty(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | InvalidateVisual | (Inherited from UIElement.)
Public method | IsAncestorOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | IsDescendantOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | Measure(System.Windows.Size) | (Inherited from UIElement.)
Protected method | MeasureCore(System.Windows.Size) | (Inherited from FrameworkElement.)
Protected method | MeasureOverride(System.Windows.Size) | (Inherited from Control.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | MoveFocus(System.Windows.Input.TraversalRequest) | (Inherited from FrameworkElement.)
Protected method | OnAccessKey(System.Windows.Input.AccessKeyEventArgs) | (Inherited from UIElement.)
Public method | OnApplyTemplate | (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged(System.Windows.UIElement) | (Inherited from UIElement.)
Protected method | OnContentChanged(System.Object,System.Object) | (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged(System.String,System.String) | (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged(System.Windows.DataTemplate,System.Windows.DataTemplate) | (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged(System.Windows.Controls.DataTemplateSelector,System.Windows.Controls.DataTemplateSelector) | (Inherited from ContentControl.)
Protected method | OnContextMenuClosing(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | (Inherited from UserControl.)
Protected method | OnDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnGotFocus(System.Windows.RoutedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnGotMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnGotStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnGotTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnInitialized(System.EventArgs) | (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnLostFocus(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnLostStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnLostTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback(System.Windows.Input.ManipulationBoundaryFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationCompleted(System.Windows.Input.ManipulationCompletedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationDelta(System.Windows.Input.ManipulationDeltaEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting(System.Windows.Input.ManipulationInertiaStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarted(System.Windows.Input.ManipulationStartedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarting(System.Windows.Input.ManipulationStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseEnter(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeave(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnPreviewMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPropertyChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnQueryCursor(System.Windows.Input.QueryCursorEventArgs) | (Inherited from UIElement.)
Protected method | OnRender(System.Windows.Media.DrawingContext) | (Inherited from UIElement.)
Protected method | OnStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusEnter(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusLeave(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnTemplateChanged(System.Windows.Controls.ControlTemplate,System.Windows.Controls.ControlTemplate) | (Inherited from Control.)
Protected method | OnTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnToolTipClosing(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchEnter(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchLeave(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Public method | PointFromScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PointToScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PredictFocus(System.Windows.Input.FocusNavigationDirection) | (Inherited from FrameworkElement.)
Public method | RaiseEvent(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Public method | ReadLocalValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | RegisterName(System.String,System.Object) | (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | (Inherited from UIElement.)
Public method | ReleaseMouseCapture | (Inherited from UIElement.)
Public method | ReleaseStylusCapture | (Inherited from UIElement.)
Public method | ReleaseTouchCapture(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | RemoveHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Protected method | RemoveVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | SetBinding(System.Windows.DependencyProperty,System.Windows.Data.BindingBase) | (Inherited from FrameworkElement.)
Public method | SetBinding(System.Windows.DependencyProperty,System.String) | (Inherited from FrameworkElement.)
Public method | SetCurrentValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetResourceReference(System.Windows.DependencyProperty,System.Object) | (Inherited from FrameworkElement.)
Public method | SetValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetValue(System.Windows.DependencyPropertyKey,System.Object) | (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | (Inherited from UIElement.)
Public method | ShouldSerializeContent | (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | (Inherited from UIElement.)
Public method | ShouldSerializeResources | (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | (Inherited from FrameworkElement.)
Public method | ToString | (Inherited from Control.)
Public method | TransformToAncestor(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToAncestor(System.Windows.Media.Media3D.Visual3D) | (Inherited from Visual.)
Public method | TransformToDescendant(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToVisual(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TranslatePoint(System.Windows.Point,System.Windows.UIElement) | (Inherited from UIElement.)
Public method | TryFindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | UnregisterName(System.String) | (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | (Inherited from FrameworkElement.)
Public method | UpdateLayout | (Inherited from UIElement.)
Public method | VerifyAccess | (Inherited from DispatcherObject.)

Properties

 | Name | Description
Public property | ActualHeight | (Inherited from FrameworkElement.)
Public property | ActualWidth | (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
Public property | AreAnyTouchesOver | (Inherited from UIElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from FrameworkElement.)
Public property | BitmapEffect | (Inherited from UIElement.)
Public property | BitmapEffectInput | (Inherited from UIElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | (Inherited from UIElement.)
Public property | ClipToBounds | (Inherited from UIElement.)
Public property | CommandBindings | (Inherited from UIElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContentTemplate | (Inherited from ContentControl.)
Public property | ContentTemplateSelector | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from FrameworkElement.)
Public property | Cursor | (Inherited from FrameworkElement.)
Public property | DataContext | (Inherited from FrameworkElement.)
Public property | DependencyObjectType | (Inherited from DependencyObject.)
Public property | DesiredSize | (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DispatcherObject.)
Public property | Effect | (Inherited from UIElement.)
Public property | FlowDirection | (Inherited from FrameworkElement.)
Public property | Focusable | (Inherited from UIElement.)
Public property | FocusVisualStyle | (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from FrameworkElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasAnimatedProperties | (Inherited from UIElement.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | InputBindings | (Inherited from UIElement.)
Public property | InputScope | (Inherited from FrameworkElement.)
Public property | IsArrangeValid | (Inherited from UIElement.)
Public property | IsEnabled | (Inherited from UIElement.)
Protected property | IsEnabledCore | (Inherited from UIElement.)
Public property | IsFocused | (Inherited from UIElement.)
Public property | IsHitTestVisible | (Inherited from UIElement.)
Public property | IsInitialized | (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | (Inherited from UIElement.)
Public property | IsKeyboardFocused | (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | (Inherited from UIElement.)
Public property | IsLoaded | (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | (Inherited from UIElement.)
Public property | IsMeasureValid | (Inherited from UIElement.)
Public property | IsMouseCaptured | (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | (Inherited from UIElement.)
Public property | IsMouseOver | (Inherited from UIElement.)
Public property | IsSealed | (Inherited from DependencyObject.)
Public property | IsStylusCaptured | (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | (Inherited from UIElement.)
Public property | IsStylusOver | (Inherited from UIElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsVisible | (Inherited from UIElement.)
Public property | Language | (Inherited from FrameworkElement.)
Public property | LayoutTransform | (Inherited from FrameworkElement.)
Public property | Margin | (Inherited from FrameworkElement.)
Public property | MaxHeight | (Inherited from FrameworkElement.)
Public property | MaxWidth | (Inherited from FrameworkElement.)
Public property | MinHeight | (Inherited from FrameworkElement.)
Public property | MinWidth | (Inherited from FrameworkElement.)
Public property | Name | (Inherited from FrameworkElement.)
Public property | Opacity | (Inherited from UIElement.)
Public property | OpacityMask | (Inherited from UIElement.)
Public property | OverridesDefaultStyle | (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from FrameworkElement.)
Public property | PersistId | (Inherited from UIElement.)
Public property | RenderSize | (Inherited from UIElement.)
Public property | RenderTransform | (Inherited from UIElement.)
Public property | RenderTransformOrigin | (Inherited from UIElement.)
Public property | Resources | (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from UIElement.)
Public property | Style | (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | (Inherited from UIElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | Tag | (Inherited from FrameworkElement.)
Public property | Template | (Inherited from Control.)
Public property | TemplatedParent | (Inherited from FrameworkElement.)
Public property | ToolTip | (Inherited from FrameworkElement.)
Public property | TouchesCaptured | (Inherited from UIElement.)
Public property | TouchesCapturedWithin | (Inherited from UIElement.)
Public property | TouchesDirectlyOver | (Inherited from UIElement.)
Public property | TouchesOver | (Inherited from UIElement.)
Public property | Triggers | (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from UIElement.)
Public property | UseLayoutRounding | (Inherited from FrameworkElement.)
Public property | VerticalAlignment | (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | (Inherited from UIElement.)
Protected property | VisualChildrenCount | (Inherited from FrameworkElement.)
Protected property | VisualParent | (Inherited from Visual.)
Public property | Width | (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | ContextMenuClosing | (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | (Inherited from FrameworkElement.)
Public event | DataContextChanged | (Inherited from FrameworkElement.)
Public event | DragEnter | (Inherited from UIElement.)
Public event | DragLeave | (Inherited from UIElement.)
Public event | DragOver | (Inherited from UIElement.)
Public event | Drop | (Inherited from UIElement.)
Public event | FocusableChanged | (Inherited from UIElement.)
Public event | GiveFeedback | (Inherited from UIElement.)
Public event | GotFocus | (Inherited from UIElement.)
Public event | GotKeyboardFocus | (Inherited from UIElement.)
Public event | GotMouseCapture | (Inherited from UIElement.)
Public event | GotStylusCapture | (Inherited from UIElement.)
Public event | GotTouchCapture | (Inherited from UIElement.)
Public event | Initialized | (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsVisibleChanged | (Inherited from UIElement.)
Public event | KeyDown | (Inherited from UIElement.)
Public event | KeyUp | (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from UIElement.)
Public event | Loaded | (Inherited from FrameworkElement.)
Public event | LostFocus | (Inherited from UIElement.)
Public event | LostKeyboardFocus | (Inherited from UIElement.)
Public event | LostMouseCapture | (Inherited from UIElement.)
Public event | LostStylusCapture | (Inherited from UIElement.)
Public event | LostTouchCapture | (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | ManipulationStarting | (Inherited from UIElement.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from UIElement.)
Public event | MouseEnter | (Inherited from UIElement.)
Public event | MouseLeave | (Inherited from UIElement.)
Public event | MouseLeftButtonDown | (Inherited from UIElement.)
Public event | MouseLeftButtonUp | (Inherited from UIElement.)
Public event | MouseMove | (Inherited from UIElement.)
Public event | MouseRightButtonDown | (Inherited from UIElement.)
Public event | MouseRightButtonUp | (Inherited from UIElement.)
Public event | MouseUp | (Inherited from UIElement.)
Public event | MouseWheel | (Inherited from UIElement.)
Public event | PreviewDragEnter | (Inherited from UIElement.)
Public event | PreviewDragLeave | (Inherited from UIElement.)
Public event | PreviewDragOver | (Inherited from UIElement.)
Public event | PreviewDrop | (Inherited from UIElement.)
Public event | PreviewGiveFeedback | (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewKeyDown | (Inherited from UIElement.)
Public event | PreviewKeyUp | (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | (Inherited from Control.)
Public event | PreviewMouseDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseMove | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseUp | (Inherited from UIElement.)
Public event | PreviewMouseWheel | (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | (Inherited from UIElement.)
Public event | PreviewStylusDown | (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | (Inherited from UIElement.)
Public event | PreviewStylusInRange | (Inherited from UIElement.)
Public event | PreviewStylusMove | (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | (Inherited from UIElement.)
Public event | PreviewStylusUp | (Inherited from UIElement.)
Public event | PreviewTextInput | (Inherited from UIElement.)
Public event | PreviewTouchDown | (Inherited from UIElement.)
Public event | PreviewTouchMove | (Inherited from UIElement.)
Public event | PreviewTouchUp | (Inherited from UIElement.)
Public event | QueryContinueDrag | (Inherited from UIElement.)
Public event | QueryCursor | (Inherited from UIElement.)
Public event | RequestBringIntoView | (Inherited from FrameworkElement.)
Public event | SizeChanged | (Inherited from FrameworkElement.)
Public event | SourceUpdated | (Inherited from FrameworkElement.)
Public event | StylusButtonDown | (Inherited from UIElement.)
Public event | StylusButtonUp | (Inherited from UIElement.)
Public event | StylusDown | (Inherited from UIElement.)
Public event | StylusEnter | (Inherited from UIElement.)
Public event | StylusInAirMove | (Inherited from UIElement.)
Public event | StylusInRange | (Inherited from UIElement.)
Public event | StylusLeave | (Inherited from UIElement.)
Public event | StylusMove | (Inherited from UIElement.)
Public event | StylusOutOfRange | (Inherited from UIElement.)
Public event | StylusSystemGesture | (Inherited from UIElement.)
Public event | StylusUp | (Inherited from UIElement.)
Public event | TargetUpdated | (Inherited from FrameworkElement.)
Public event | TextInput | (Inherited from UIElement.)
Public event | ToolTipClosing | (Inherited from FrameworkElement.)
Public event | ToolTipOpening | (Inherited from FrameworkElement.)
Public event | TouchDown | (Inherited from UIElement.)
Public event | TouchEnter | (Inherited from UIElement.)
Public event | TouchLeave | (Inherited from UIElement.)
Public event | TouchMove | (Inherited from UIElement.)
Public event | TouchUp | (Inherited from UIElement.)
Public event | Unloaded | (Inherited from FrameworkElement.)

See Also

ChangeWowPathUserControl Class
Relogger.UserControlsAndWindows Namespace


ChangeWowPathUserControl Constructor

Initializes a new instance of the ChangeWowPathUserControl class.

Namespace: Relogger.UserControlsAndWindows
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public ChangeWowPathUserControl()
Public Sub New
public:
ChangeWowPathUserControl()

See Also

ChangeWowPathUserControl Class
Relogger.UserControlsAndWindows Namespace


ChangeWowPathUserControl Methods

The ChangeWowPathUserControl type exposes the following members.

Methods

 | Name | Description
Protected method | AddChild(System.Object) | (Inherited from ContentControl.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate,System.Boolean) | (Inherited from UIElement.)
Protected method | AddText(System.String) | (Inherited from ContentControl.)
Public method | AddToEventRoute(System.Windows.EventRoute,System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | AddVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock) | (Inherited from UIElement.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from FrameworkElement.)
Public method | Arrange(System.Windows.Rect) | (Inherited from UIElement.)
Protected method | ArrangeCore(System.Windows.Rect) | (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(System.Windows.Size) | (Inherited from Control.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline) | (Inherited from UIElement.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | BeginInit | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior,System.Boolean) | (Inherited from FrameworkElement.)
Public method | BringIntoView | (Inherited from FrameworkElement.)
Public method | BringIntoView(System.Windows.Rect) | (Inherited from FrameworkElement.)
Public method | CaptureMouse | (Inherited from UIElement.)
Public method | CaptureStylus | (Inherited from UIElement.)
Public method | CaptureTouch(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DispatcherObject.)
Public method | ClearValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | ClearValue(System.Windows.DependencyPropertyKey) | (Inherited from DependencyObject.)
Public method | CoerceValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | EndInit | (Inherited from FrameworkElement.)
Public method | Equals(System.Object) | (Inherited from DependencyObject.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindCommonVisualAncestor(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | FindName(System.String) | (Inherited from FrameworkElement.)
Public method | FindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from UIElement.)
Public method | GetAnimationBaseValue(System.Windows.DependencyProperty) | (Inherited from UIElement.)
Public method | GetBindingExpression(System.Windows.DependencyProperty) | (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from DependencyObject.)
Protected method | GetLayoutClip(System.Windows.Size) | (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | (Inherited from DependencyObject.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Protected method | GetVisualChild(System.Int32) | (Inherited from FrameworkElement.)
Protected method | HitTestCore(System.Windows.Media.PointHitTestParameters) | (Inherited from UIElement.)
Protected method | HitTestCore(System.Windows.Media.GeometryHitTestParameters) | (Inherited from UIElement.)
Public method | InputHitTest(System.Windows.Point) | (Inherited from UIElement.)
Public method | InvalidateArrange | (Inherited from UIElement.)
Public method | InvalidateMeasure | (Inherited from UIElement.)
Public method | InvalidateProperty(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | InvalidateVisual | (Inherited from UIElement.)
Public method | IsAncestorOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | IsDescendantOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | Measure(System.Windows.Size) | (Inherited from UIElement.)
Protected method | MeasureCore(System.Windows.Size) | (Inherited from FrameworkElement.)
Protected method | MeasureOverride(System.Windows.Size) | (Inherited from Control.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | MoveFocus(System.Windows.Input.TraversalRequest) | (Inherited from FrameworkElement.)
Protected method | OnAccessKey(System.Windows.Input.AccessKeyEventArgs) | (Inherited from UIElement.)
Public method | OnApplyTemplate | (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged(System.Windows.UIElement) | (Inherited from UIElement.)
Protected method | OnContentChanged(System.Object,System.Object) | (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged(System.String,System.String) | (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged(System.Windows.DataTemplate,System.Windows.DataTemplate) | (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged(System.Windows.Controls.DataTemplateSelector,System.Windows.Controls.DataTemplateSelector) | (Inherited from ContentControl.)
Protected method | OnContextMenuClosing(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | (Inherited from UserControl.)
Protected method | OnDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnGotFocus(System.Windows.RoutedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnGotMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnGotStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnGotTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnInitialized(System.EventArgs) | (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnLostFocus(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnLostStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnLostTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback(System.Windows.Input.ManipulationBoundaryFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationCompleted(System.Windows.Input.ManipulationCompletedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationDelta(System.Windows.Input.ManipulationDeltaEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting(System.Windows.Input.ManipulationInertiaStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarted(System.Windows.Input.ManipulationStartedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarting(System.Windows.Input.ManipulationStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseEnter(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeave(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnPreviewMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPropertyChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnQueryCursor(System.Windows.Input.QueryCursorEventArgs) | (Inherited from UIElement.)
Protected method | OnRender(System.Windows.Media.DrawingContext) | (Inherited from UIElement.)
Protected method | OnStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusEnter(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusLeave(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnTemplateChanged(System.Windows.Controls.ControlTemplate,System.Windows.Controls.ControlTemplate) | (Inherited from Control.)
Protected method | OnTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnToolTipClosing(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchEnter(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchLeave(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Public method | PointFromScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PointToScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PredictFocus(System.Windows.Input.FocusNavigationDirection) | (Inherited from FrameworkElement.)
Public method | RaiseEvent(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Public method | ReadLocalValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | RegisterName(System.String,System.Object) | (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | (Inherited from UIElement.)
Public method | ReleaseMouseCapture | (Inherited from UIElement.)
Public method | ReleaseStylusCapture | (Inherited from UIElement.)
Public method | ReleaseTouchCapture(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | RemoveHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Protected method | RemoveVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | SetBinding(System.Windows.DependencyProperty,System.Windows.Data.BindingBase) | (Inherited from FrameworkElement.)
Public method | SetBinding(System.Windows.DependencyProperty,System.String) | (Inherited from FrameworkElement.)
Public method | SetCurrentValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetResourceReference(System.Windows.DependencyProperty,System.Object) | (Inherited from FrameworkElement.)
Public method | SetValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetValue(System.Windows.DependencyPropertyKey,System.Object) | (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | (Inherited from UIElement.)
Public method | ShouldSerializeContent | (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | (Inherited from UIElement.)
Public method | ShouldSerializeResources | (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | (Inherited from FrameworkElement.)
Public method | ToString | (Inherited from Control.)
Public method | TransformToAncestor(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToAncestor(System.Windows.Media.Media3D.Visual3D) | (Inherited from Visual.)
Public method | TransformToDescendant(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToVisual(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TranslatePoint(System.Windows.Point,System.Windows.UIElement) | (Inherited from UIElement.)
Public method | TryFindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | UnregisterName(System.String) | (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | (Inherited from FrameworkElement.)
Public method | UpdateLayout | (Inherited from UIElement.)
Public method | VerifyAccess | (Inherited from DispatcherObject.)

See Also

ChangeWowPathUserControl Class
Relogger.UserControlsAndWindows Namespace


ChangeWowPathUserControl Properties

The ChangeWowPathUserControl type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | (Inherited from FrameworkElement.)
Public property | ActualWidth | (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
Public property | AreAnyTouchesOver | (Inherited from UIElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from FrameworkElement.)
Public property | BitmapEffect | (Inherited from UIElement.)
Public property | BitmapEffectInput | (Inherited from UIElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | (Inherited from UIElement.)
Public property | ClipToBounds | (Inherited from UIElement.)
Public property | CommandBindings | (Inherited from UIElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContentTemplate | (Inherited from ContentControl.)
Public property | ContentTemplateSelector | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from FrameworkElement.)
Public property | Cursor | (Inherited from FrameworkElement.)
Public property | DataContext | (Inherited from FrameworkElement.)
Public property | DependencyObjectType | (Inherited from DependencyObject.)
Public property | DesiredSize | (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DispatcherObject.)
Public property | Effect | (Inherited from UIElement.)
Public property | FlowDirection | (Inherited from FrameworkElement.)
Public property | Focusable | (Inherited from UIElement.)
Public property | FocusVisualStyle | (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from FrameworkElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasAnimatedProperties | (Inherited from UIElement.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | InputBindings | (Inherited from UIElement.)
Public property | InputScope | (Inherited from FrameworkElement.)
Public property | IsArrangeValid | (Inherited from UIElement.)
Public property | IsEnabled | (Inherited from UIElement.)
Protected property | IsEnabledCore | (Inherited from UIElement.)
Public property | IsFocused | (Inherited from UIElement.)
Public property | IsHitTestVisible | (Inherited from UIElement.)
Public property | IsInitialized | (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | (Inherited from UIElement.)
Public property | IsKeyboardFocused | (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | (Inherited from UIElement.)
Public property | IsLoaded | (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | (Inherited from UIElement.)
Public property | IsMeasureValid | (Inherited from UIElement.)
Public property | IsMouseCaptured | (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | (Inherited from UIElement.)
Public property | IsMouseOver | (Inherited from UIElement.)
Public property | IsSealed | (Inherited from DependencyObject.)
Public property | IsStylusCaptured | (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | (Inherited from UIElement.)
Public property | IsStylusOver | (Inherited from UIElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsVisible | (Inherited from UIElement.)
Public property | Language | (Inherited from FrameworkElement.)
Public property | LayoutTransform | (Inherited from FrameworkElement.)
Public property | Margin | (Inherited from FrameworkElement.)
Public property | MaxHeight | (Inherited from FrameworkElement.)
Public property | MaxWidth | (Inherited from FrameworkElement.)
Public property | MinHeight | (Inherited from FrameworkElement.)
Public property | MinWidth | (Inherited from FrameworkElement.)
Public property | Name | (Inherited from FrameworkElement.)
Public property | Opacity | (Inherited from UIElement.)
Public property | OpacityMask | (Inherited from UIElement.)
Public property | OverridesDefaultStyle | (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from FrameworkElement.)
Public property | PersistId | (Inherited from UIElement.)
Public property | RenderSize | (Inherited from UIElement.)
Public property | RenderTransform | (Inherited from UIElement.)
Public property | RenderTransformOrigin | (Inherited from UIElement.)
Public property | Resources | (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from UIElement.)
Public property | Style | (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | (Inherited from UIElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | Tag | (Inherited from FrameworkElement.)
Public property | Template | (Inherited from Control.)
Public property | TemplatedParent | (Inherited from FrameworkElement.)
Public property | ToolTip | (Inherited from FrameworkElement.)
Public property | TouchesCaptured | (Inherited from UIElement.)
Public property | TouchesCapturedWithin | (Inherited from UIElement.)
Public property | TouchesDirectlyOver | (Inherited from UIElement.)
Public property | TouchesOver | (Inherited from UIElement.)
Public property | Triggers | (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from UIElement.)
Public property | UseLayoutRounding | (Inherited from FrameworkElement.)
Public property | VerticalAlignment | (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | (Inherited from UIElement.)
Protected property | VisualChildrenCount | (Inherited from FrameworkElement.)
Protected property | VisualParent | (Inherited from Visual.)
Public property | Width | (Inherited from FrameworkElement.)

See Also

ChangeWowPathUserControl Class
Relogger.UserControlsAndWindows Namespace


ChangeWowPathUserControl Events

The ChangeWowPathUserControl type exposes the following members.

Events

 | Name | Description
Public event | ContextMenuClosing | (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | (Inherited from FrameworkElement.)
Public event | DataContextChanged | (Inherited from FrameworkElement.)
Public event | DragEnter | (Inherited from UIElement.)
Public event | DragLeave | (Inherited from UIElement.)
Public event | DragOver | (Inherited from UIElement.)
Public event | Drop | (Inherited from UIElement.)
Public event | FocusableChanged | (Inherited from UIElement.)
Public event | GiveFeedback | (Inherited from UIElement.)
Public event | GotFocus | (Inherited from UIElement.)
Public event | GotKeyboardFocus | (Inherited from UIElement.)
Public event | GotMouseCapture | (Inherited from UIElement.)
Public event | GotStylusCapture | (Inherited from UIElement.)
Public event | GotTouchCapture | (Inherited from UIElement.)
Public event | Initialized | (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsVisibleChanged | (Inherited from UIElement.)
Public event | KeyDown | (Inherited from UIElement.)
Public event | KeyUp | (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from UIElement.)
Public event | Loaded | (Inherited from FrameworkElement.)
Public event | LostFocus | (Inherited from UIElement.)
Public event | LostKeyboardFocus | (Inherited from UIElement.)
Public event | LostMouseCapture | (Inherited from UIElement.)
Public event | LostStylusCapture | (Inherited from UIElement.)
Public event | LostTouchCapture | (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | ManipulationStarting | (Inherited from UIElement.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from UIElement.)
Public event | MouseEnter | (Inherited from UIElement.)
Public event | MouseLeave | (Inherited from UIElement.)
Public event | MouseLeftButtonDown | (Inherited from UIElement.)
Public event | MouseLeftButtonUp | (Inherited from UIElement.)
Public event | MouseMove | (Inherited from UIElement.)
Public event | MouseRightButtonDown | (Inherited from UIElement.)
Public event | MouseRightButtonUp | (Inherited from UIElement.)
Public event | MouseUp | (Inherited from UIElement.)
Public event | MouseWheel | (Inherited from UIElement.)
Public event | PreviewDragEnter | (Inherited from UIElement.)
Public event | PreviewDragLeave | (Inherited from UIElement.)
Public event | PreviewDragOver | (Inherited from UIElement.)
Public event | PreviewDrop | (Inherited from UIElement.)
Public event | PreviewGiveFeedback | (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewKeyDown | (Inherited from UIElement.)
Public event | PreviewKeyUp | (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | (Inherited from Control.)
Public event | PreviewMouseDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseMove | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseUp | (Inherited from UIElement.)
Public event | PreviewMouseWheel | (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | (Inherited from UIElement.)
Public event | PreviewStylusDown | (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | (Inherited from UIElement.)
Public event | PreviewStylusInRange | (Inherited from UIElement.)
Public event | PreviewStylusMove | (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | (Inherited from UIElement.)
Public event | PreviewStylusUp | (Inherited from UIElement.)
Public event | PreviewTextInput | (Inherited from UIElement.)
Public event | PreviewTouchDown | (Inherited from UIElement.)
Public event | PreviewTouchMove | (Inherited from UIElement.)
Public event | PreviewTouchUp | (Inherited from UIElement.)
Public event | QueryContinueDrag | (Inherited from UIElement.)
Public event | QueryCursor | (Inherited from UIElement.)
Public event | RequestBringIntoView | (Inherited from FrameworkElement.)
Public event | SizeChanged | (Inherited from FrameworkElement.)
Public event | SourceUpdated | (Inherited from FrameworkElement.)
Public event | StylusButtonDown | (Inherited from UIElement.)
Public event | StylusButtonUp | (Inherited from UIElement.)
Public event | StylusDown | (Inherited from UIElement.)
Public event | StylusEnter | (Inherited from UIElement.)
Public event | StylusInAirMove | (Inherited from UIElement.)
Public event | StylusInRange | (Inherited from UIElement.)
Public event | StylusLeave | (Inherited from UIElement.)
Public event | StylusMove | (Inherited from UIElement.)
Public event | StylusOutOfRange | (Inherited from UIElement.)
Public event | StylusSystemGesture | (Inherited from UIElement.)
Public event | StylusUp | (Inherited from UIElement.)
Public event | TargetUpdated | (Inherited from FrameworkElement.)
Public event | TextInput | (Inherited from UIElement.)
Public event | ToolTipClosing | (Inherited from FrameworkElement.)
Public event | ToolTipOpening | (Inherited from FrameworkElement.)
Public event | TouchDown | (Inherited from UIElement.)
Public event | TouchEnter | (Inherited from UIElement.)
Public event | TouchLeave | (Inherited from UIElement.)
Public event | TouchMove | (Inherited from UIElement.)
Public event | TouchUp | (Inherited from UIElement.)
Public event | Unloaded | (Inherited from FrameworkElement.)

See Also

ChangeWowPathUserControl Class
Relogger.UserControlsAndWindows Namespace


ChangeWRobotLicenseKeyUserControl Class

Logique d'interaction pour ChangeWRobotLicenseKeyUserControl.xaml

Namespace: Relogger.UserControlsAndWindows
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public class ChangeWRobotLicenseKeyUserControl : UserControl
Public Class ChangeWRobotLicenseKeyUserControl _
    Inherits UserControl
public ref class ChangeWRobotLicenseKeyUserControl : public UserControl

Inheritance Hierarchy

Object
DispatcherObject
DependencyObject
Visual
UIElement
FrameworkElement
Control
ContentControl
UserControl
Relogger.UserControlsAndWindows..::..ChangeWRobotLicenseKeyUserControl

See Also

ChangeWRobotLicenseKeyUserControl Members
Relogger.UserControlsAndWindows Namespace


ChangeWRobotLicenseKeyUserControl Members

The ChangeWRobotLicenseKeyUserControl type exposes the following members.

Constructors

 | Name | Description
Public method | ChangeWRobotLicenseKeyUserControl | Initializes a new instance of the ChangeWRobotLicenseKeyUserControl class.

Methods

 | Name | Description
Protected method | AddChild(System.Object) | (Inherited from ContentControl.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate,System.Boolean) | (Inherited from UIElement.)
Protected method | AddText(System.String) | (Inherited from ContentControl.)
Public method | AddToEventRoute(System.Windows.EventRoute,System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | AddVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock) | (Inherited from UIElement.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from FrameworkElement.)
Public method | Arrange(System.Windows.Rect) | (Inherited from UIElement.)
Protected method | ArrangeCore(System.Windows.Rect) | (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(System.Windows.Size) | (Inherited from Control.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline) | (Inherited from UIElement.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | BeginInit | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior,System.Boolean) | (Inherited from FrameworkElement.)
Public method | BringIntoView | (Inherited from FrameworkElement.)
Public method | BringIntoView(System.Windows.Rect) | (Inherited from FrameworkElement.)
Public method | CaptureMouse | (Inherited from UIElement.)
Public method | CaptureStylus | (Inherited from UIElement.)
Public method | CaptureTouch(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DispatcherObject.)
Public method | ClearValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | ClearValue(System.Windows.DependencyPropertyKey) | (Inherited from DependencyObject.)
Public method | CoerceValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | EndInit | (Inherited from FrameworkElement.)
Public method | Equals(System.Object) | (Inherited from DependencyObject.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindCommonVisualAncestor(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | FindName(System.String) | (Inherited from FrameworkElement.)
Public method | FindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from UIElement.)
Public method | GetAnimationBaseValue(System.Windows.DependencyProperty) | (Inherited from UIElement.)
Public method | GetBindingExpression(System.Windows.DependencyProperty) | (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from DependencyObject.)
Protected method | GetLayoutClip(System.Windows.Size) | (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | (Inherited from DependencyObject.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Protected method | GetVisualChild(System.Int32) | (Inherited from FrameworkElement.)
Protected method | HitTestCore(System.Windows.Media.PointHitTestParameters) | (Inherited from UIElement.)
Protected method | HitTestCore(System.Windows.Media.GeometryHitTestParameters) | (Inherited from UIElement.)
Public method | InputHitTest(System.Windows.Point) | (Inherited from UIElement.)
Public method | InvalidateArrange | (Inherited from UIElement.)
Public method | InvalidateMeasure | (Inherited from UIElement.)
Public method | InvalidateProperty(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | InvalidateVisual | (Inherited from UIElement.)
Public method | IsAncestorOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | IsDescendantOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | Measure(System.Windows.Size) | (Inherited from UIElement.)
Protected method | MeasureCore(System.Windows.Size) | (Inherited from FrameworkElement.)
Protected method | MeasureOverride(System.Windows.Size) | (Inherited from Control.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | MoveFocus(System.Windows.Input.TraversalRequest) | (Inherited from FrameworkElement.)
Protected method | OnAccessKey(System.Windows.Input.AccessKeyEventArgs) | (Inherited from UIElement.)
Public method | OnApplyTemplate | (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged(System.Windows.UIElement) | (Inherited from UIElement.)
Protected method | OnContentChanged(System.Object,System.Object) | (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged(System.String,System.String) | (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged(System.Windows.DataTemplate,System.Windows.DataTemplate) | (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged(System.Windows.Controls.DataTemplateSelector,System.Windows.Controls.DataTemplateSelector) | (Inherited from ContentControl.)
Protected method | OnContextMenuClosing(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | (Inherited from UserControl.)
Protected method | OnDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnGotFocus(System.Windows.RoutedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnGotMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnGotStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnGotTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnInitialized(System.EventArgs) | (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnLostFocus(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnLostStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnLostTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback(System.Windows.Input.ManipulationBoundaryFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationCompleted(System.Windows.Input.ManipulationCompletedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationDelta(System.Windows.Input.ManipulationDeltaEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting(System.Windows.Input.ManipulationInertiaStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarted(System.Windows.Input.ManipulationStartedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarting(System.Windows.Input.ManipulationStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseEnter(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeave(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnPreviewMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPropertyChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnQueryCursor(System.Windows.Input.QueryCursorEventArgs) | (Inherited from UIElement.)
Protected method | OnRender(System.Windows.Media.DrawingContext) | (Inherited from UIElement.)
Protected method | OnStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusEnter(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusLeave(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnTemplateChanged(System.Windows.Controls.ControlTemplate,System.Windows.Controls.ControlTemplate) | (Inherited from Control.)
Protected method | OnTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnToolTipClosing(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchEnter(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchLeave(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Public method | PointFromScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PointToScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PredictFocus(System.Windows.Input.FocusNavigationDirection) | (Inherited from FrameworkElement.)
Public method | RaiseEvent(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Public method | ReadLocalValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | RegisterName(System.String,System.Object) | (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | (Inherited from UIElement.)
Public method | ReleaseMouseCapture | (Inherited from UIElement.)
Public method | ReleaseStylusCapture | (Inherited from UIElement.)
Public method | ReleaseTouchCapture(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | RemoveHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Protected method | RemoveVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | SetBinding(System.Windows.DependencyProperty,System.Windows.Data.BindingBase) | (Inherited from FrameworkElement.)
Public method | SetBinding(System.Windows.DependencyProperty,System.String) | (Inherited from FrameworkElement.)
Public method | SetCurrentValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetResourceReference(System.Windows.DependencyProperty,System.Object) | (Inherited from FrameworkElement.)
Public method | SetValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetValue(System.Windows.DependencyPropertyKey,System.Object) | (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | (Inherited from UIElement.)
Public method | ShouldSerializeContent | (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | (Inherited from UIElement.)
Public method | ShouldSerializeResources | (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | (Inherited from FrameworkElement.)
Public method | ToString | (Inherited from Control.)
Public method | TransformToAncestor(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToAncestor(System.Windows.Media.Media3D.Visual3D) | (Inherited from Visual.)
Public method | TransformToDescendant(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToVisual(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TranslatePoint(System.Windows.Point,System.Windows.UIElement) | (Inherited from UIElement.)
Public method | TryFindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | UnregisterName(System.String) | (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | (Inherited from FrameworkElement.)
Public method | UpdateLayout | (Inherited from UIElement.)
Public method | VerifyAccess | (Inherited from DispatcherObject.)

Properties

 | Name | Description
Public property | ActualHeight | (Inherited from FrameworkElement.)
Public property | ActualWidth | (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
Public property | AreAnyTouchesOver | (Inherited from UIElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from FrameworkElement.)
Public property | BitmapEffect | (Inherited from UIElement.)
Public property | BitmapEffectInput | (Inherited from UIElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | (Inherited from UIElement.)
Public property | ClipToBounds | (Inherited from UIElement.)
Public property | CommandBindings | (Inherited from UIElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContentTemplate | (Inherited from ContentControl.)
Public property | ContentTemplateSelector | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from FrameworkElement.)
Public property | Cursor | (Inherited from FrameworkElement.)
Public property | DataContext | (Inherited from FrameworkElement.)
Public property | DependencyObjectType | (Inherited from DependencyObject.)
Public property | DesiredSize | (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DispatcherObject.)
Public property | Effect | (Inherited from UIElement.)
Public property | FlowDirection | (Inherited from FrameworkElement.)
Public property | Focusable | (Inherited from UIElement.)
Public property | FocusVisualStyle | (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from FrameworkElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasAnimatedProperties | (Inherited from UIElement.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | InputBindings | (Inherited from UIElement.)
Public property | InputScope | (Inherited from FrameworkElement.)
Public property | IsArrangeValid | (Inherited from UIElement.)
Public property | IsEnabled | (Inherited from UIElement.)
Protected property | IsEnabledCore | (Inherited from UIElement.)
Public property | IsFocused | (Inherited from UIElement.)
Public property | IsHitTestVisible | (Inherited from UIElement.)
Public property | IsInitialized | (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | (Inherited from UIElement.)
Public property | IsKeyboardFocused | (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | (Inherited from UIElement.)
Public property | IsLoaded | (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | (Inherited from UIElement.)
Public property | IsMeasureValid | (Inherited from UIElement.)
Public property | IsMouseCaptured | (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | (Inherited from UIElement.)
Public property | IsMouseOver | (Inherited from UIElement.)
Public property | IsSealed | (Inherited from DependencyObject.)
Public property | IsStylusCaptured | (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | (Inherited from UIElement.)
Public property | IsStylusOver | (Inherited from UIElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsVisible | (Inherited from UIElement.)
Public property | Language | (Inherited from FrameworkElement.)
Public property | LayoutTransform | (Inherited from FrameworkElement.)
Public property | Margin | (Inherited from FrameworkElement.)
Public property | MaxHeight | (Inherited from FrameworkElement.)
Public property | MaxWidth | (Inherited from FrameworkElement.)
Public property | MinHeight | (Inherited from FrameworkElement.)
Public property | MinWidth | (Inherited from FrameworkElement.)
Public property | Name | (Inherited from FrameworkElement.)
Public property | Opacity | (Inherited from UIElement.)
Public property | OpacityMask | (Inherited from UIElement.)
Public property | OverridesDefaultStyle | (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from FrameworkElement.)
Public property | PersistId | (Inherited from UIElement.)
Public property | RenderSize | (Inherited from UIElement.)
Public property | RenderTransform | (Inherited from UIElement.)
Public property | RenderTransformOrigin | (Inherited from UIElement.)
Public property | Resources | (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from UIElement.)
Public property | Style | (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | (Inherited from UIElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | Tag | (Inherited from FrameworkElement.)
Public property | Template | (Inherited from Control.)
Public property | TemplatedParent | (Inherited from FrameworkElement.)
Public property | ToolTip | (Inherited from FrameworkElement.)
Public property | TouchesCaptured | (Inherited from UIElement.)
Public property | TouchesCapturedWithin | (Inherited from UIElement.)
Public property | TouchesDirectlyOver | (Inherited from UIElement.)
Public property | TouchesOver | (Inherited from UIElement.)
Public property | Triggers | (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from UIElement.)
Public property | UseLayoutRounding | (Inherited from FrameworkElement.)
Public property | VerticalAlignment | (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | (Inherited from UIElement.)
Protected property | VisualChildrenCount | (Inherited from FrameworkElement.)
Protected property | VisualParent | (Inherited from Visual.)
Public property | Width | (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | ContextMenuClosing | (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | (Inherited from FrameworkElement.)
Public event | DataContextChanged | (Inherited from FrameworkElement.)
Public event | DragEnter | (Inherited from UIElement.)
Public event | DragLeave | (Inherited from UIElement.)
Public event | DragOver | (Inherited from UIElement.)
Public event | Drop | (Inherited from UIElement.)
Public event | FocusableChanged | (Inherited from UIElement.)
Public event | GiveFeedback | (Inherited from UIElement.)
Public event | GotFocus | (Inherited from UIElement.)
Public event | GotKeyboardFocus | (Inherited from UIElement.)
Public event | GotMouseCapture | (Inherited from UIElement.)
Public event | GotStylusCapture | (Inherited from UIElement.)
Public event | GotTouchCapture | (Inherited from UIElement.)
Public event | Initialized | (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsVisibleChanged | (Inherited from UIElement.)
Public event | KeyDown | (Inherited from UIElement.)
Public event | KeyUp | (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from UIElement.)
Public event | Loaded | (Inherited from FrameworkElement.)
Public event | LostFocus | (Inherited from UIElement.)
Public event | LostKeyboardFocus | (Inherited from UIElement.)
Public event | LostMouseCapture | (Inherited from UIElement.)
Public event | LostStylusCapture | (Inherited from UIElement.)
Public event | LostTouchCapture | (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | ManipulationStarting | (Inherited from UIElement.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from UIElement.)
Public event | MouseEnter | (Inherited from UIElement.)
Public event | MouseLeave | (Inherited from UIElement.)
Public event | MouseLeftButtonDown | (Inherited from UIElement.)
Public event | MouseLeftButtonUp | (Inherited from UIElement.)
Public event | MouseMove | (Inherited from UIElement.)
Public event | MouseRightButtonDown | (Inherited from UIElement.)
Public event | MouseRightButtonUp | (Inherited from UIElement.)
Public event | MouseUp | (Inherited from UIElement.)
Public event | MouseWheel | (Inherited from UIElement.)
Public event | PreviewDragEnter | (Inherited from UIElement.)
Public event | PreviewDragLeave | (Inherited from UIElement.)
Public event | PreviewDragOver | (Inherited from UIElement.)
Public event | PreviewDrop | (Inherited from UIElement.)
Public event | PreviewGiveFeedback | (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewKeyDown | (Inherited from UIElement.)
Public event | PreviewKeyUp | (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | (Inherited from Control.)
Public event | PreviewMouseDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseMove | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseUp | (Inherited from UIElement.)
Public event | PreviewMouseWheel | (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | (Inherited from UIElement.)
Public event | PreviewStylusDown | (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | (Inherited from UIElement.)
Public event | PreviewStylusInRange | (Inherited from UIElement.)
Public event | PreviewStylusMove | (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | (Inherited from UIElement.)
Public event | PreviewStylusUp | (Inherited from UIElement.)
Public event | PreviewTextInput | (Inherited from UIElement.)
Public event | PreviewTouchDown | (Inherited from UIElement.)
Public event | PreviewTouchMove | (Inherited from UIElement.)
Public event | PreviewTouchUp | (Inherited from UIElement.)
Public event | QueryContinueDrag | (Inherited from UIElement.)
Public event | QueryCursor | (Inherited from UIElement.)
Public event | RequestBringIntoView | (Inherited from FrameworkElement.)
Public event | SizeChanged | (Inherited from FrameworkElement.)
Public event | SourceUpdated | (Inherited from FrameworkElement.)
Public event | StylusButtonDown | (Inherited from UIElement.)
Public event | StylusButtonUp | (Inherited from UIElement.)
Public event | StylusDown | (Inherited from UIElement.)
Public event | StylusEnter | (Inherited from UIElement.)
Public event | StylusInAirMove | (Inherited from UIElement.)
Public event | StylusInRange | (Inherited from UIElement.)
Public event | StylusLeave | (Inherited from UIElement.)
Public event | StylusMove | (Inherited from UIElement.)
Public event | StylusOutOfRange | (Inherited from UIElement.)
Public event | StylusSystemGesture | (Inherited from UIElement.)
Public event | StylusUp | (Inherited from UIElement.)
Public event | TargetUpdated | (Inherited from FrameworkElement.)
Public event | TextInput | (Inherited from UIElement.)
Public event | ToolTipClosing | (Inherited from FrameworkElement.)
Public event | ToolTipOpening | (Inherited from FrameworkElement.)
Public event | TouchDown | (Inherited from UIElement.)
Public event | TouchEnter | (Inherited from UIElement.)
Public event | TouchLeave | (Inherited from UIElement.)
Public event | TouchMove | (Inherited from UIElement.)
Public event | TouchUp | (Inherited from UIElement.)
Public event | Unloaded | (Inherited from FrameworkElement.)

See Also

ChangeWRobotLicenseKeyUserControl Class
Relogger.UserControlsAndWindows Namespace


ChangeWRobotLicenseKeyUserControl Constructor

Initializes a new instance of the ChangeWRobotLicenseKeyUserControl class.

Namespace: Relogger.UserControlsAndWindows
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public ChangeWRobotLicenseKeyUserControl()
Public Sub New
public:
ChangeWRobotLicenseKeyUserControl()

See Also

ChangeWRobotLicenseKeyUserControl Class
Relogger.UserControlsAndWindows Namespace


ChangeWRobotLicenseKeyUserControl Methods

The ChangeWRobotLicenseKeyUserControl type exposes the following members.

Methods

 | Name | Description
Protected method | AddChild(System.Object) | (Inherited from ContentControl.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate,System.Boolean) | (Inherited from UIElement.)
Protected method | AddText(System.String) | (Inherited from ContentControl.)
Public method | AddToEventRoute(System.Windows.EventRoute,System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | AddVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock) | (Inherited from UIElement.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from FrameworkElement.)
Public method | Arrange(System.Windows.Rect) | (Inherited from UIElement.)
Protected method | ArrangeCore(System.Windows.Rect) | (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(System.Windows.Size) | (Inherited from Control.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline) | (Inherited from UIElement.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | BeginInit | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior,System.Boolean) | (Inherited from FrameworkElement.)
Public method | BringIntoView | (Inherited from FrameworkElement.)
Public method | BringIntoView(System.Windows.Rect) | (Inherited from FrameworkElement.)
Public method | CaptureMouse | (Inherited from UIElement.)
Public method | CaptureStylus | (Inherited from UIElement.)
Public method | CaptureTouch(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DispatcherObject.)
Public method | ClearValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | ClearValue(System.Windows.DependencyPropertyKey) | (Inherited from DependencyObject.)
Public method | CoerceValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | EndInit | (Inherited from FrameworkElement.)
Public method | Equals(System.Object) | (Inherited from DependencyObject.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindCommonVisualAncestor(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | FindName(System.String) | (Inherited from FrameworkElement.)
Public method | FindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from UIElement.)
Public method | GetAnimationBaseValue(System.Windows.DependencyProperty) | (Inherited from UIElement.)
Public method | GetBindingExpression(System.Windows.DependencyProperty) | (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from DependencyObject.)
Protected method | GetLayoutClip(System.Windows.Size) | (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | (Inherited from DependencyObject.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Protected method | GetVisualChild(System.Int32) | (Inherited from FrameworkElement.)
Protected method | HitTestCore(System.Windows.Media.PointHitTestParameters) | (Inherited from UIElement.)
Protected method | HitTestCore(System.Windows.Media.GeometryHitTestParameters) | (Inherited from UIElement.)
Public method | InputHitTest(System.Windows.Point) | (Inherited from UIElement.)
Public method | InvalidateArrange | (Inherited from UIElement.)
Public method | InvalidateMeasure | (Inherited from UIElement.)
Public method | InvalidateProperty(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | InvalidateVisual | (Inherited from UIElement.)
Public method | IsAncestorOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | IsDescendantOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | Measure(System.Windows.Size) | (Inherited from UIElement.)
Protected method | MeasureCore(System.Windows.Size) | (Inherited from FrameworkElement.)
Protected method | MeasureOverride(System.Windows.Size) | (Inherited from Control.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | MoveFocus(System.Windows.Input.TraversalRequest) | (Inherited from FrameworkElement.)
Protected method | OnAccessKey(System.Windows.Input.AccessKeyEventArgs) | (Inherited from UIElement.)
Public method | OnApplyTemplate | (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged(System.Windows.UIElement) | (Inherited from UIElement.)
Protected method | OnContentChanged(System.Object,System.Object) | (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged(System.String,System.String) | (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged(System.Windows.DataTemplate,System.Windows.DataTemplate) | (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged(System.Windows.Controls.DataTemplateSelector,System.Windows.Controls.DataTemplateSelector) | (Inherited from ContentControl.)
Protected method | OnContextMenuClosing(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | (Inherited from UserControl.)
Protected method | OnDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnGotFocus(System.Windows.RoutedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnGotMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnGotStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnGotTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnInitialized(System.EventArgs) | (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnLostFocus(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnLostStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnLostTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback(System.Windows.Input.ManipulationBoundaryFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationCompleted(System.Windows.Input.ManipulationCompletedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationDelta(System.Windows.Input.ManipulationDeltaEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting(System.Windows.Input.ManipulationInertiaStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarted(System.Windows.Input.ManipulationStartedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarting(System.Windows.Input.ManipulationStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseEnter(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeave(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnPreviewMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPropertyChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnQueryCursor(System.Windows.Input.QueryCursorEventArgs) | (Inherited from UIElement.)
Protected method | OnRender(System.Windows.Media.DrawingContext) | (Inherited from UIElement.)
Protected method | OnStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusEnter(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusLeave(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnTemplateChanged(System.Windows.Controls.ControlTemplate,System.Windows.Controls.ControlTemplate) | (Inherited from Control.)
Protected method | OnTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnToolTipClosing(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchEnter(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchLeave(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Public method | PointFromScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PointToScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PredictFocus(System.Windows.Input.FocusNavigationDirection) | (Inherited from FrameworkElement.)
Public method | RaiseEvent(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Public method | ReadLocalValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | RegisterName(System.String,System.Object) | (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | (Inherited from UIElement.)
Public method | ReleaseMouseCapture | (Inherited from UIElement.)
Public method | ReleaseStylusCapture | (Inherited from UIElement.)
Public method | ReleaseTouchCapture(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | RemoveHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Protected method | RemoveVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | SetBinding(System.Windows.DependencyProperty,System.Windows.Data.BindingBase) | (Inherited from FrameworkElement.)
Public method | SetBinding(System.Windows.DependencyProperty,System.String) | (Inherited from FrameworkElement.)
Public method | SetCurrentValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetResourceReference(System.Windows.DependencyProperty,System.Object) | (Inherited from FrameworkElement.)
Public method | SetValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetValue(System.Windows.DependencyPropertyKey,System.Object) | (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | (Inherited from UIElement.)
Public method | ShouldSerializeContent | (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | (Inherited from UIElement.)
Public method | ShouldSerializeResources | (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | (Inherited from FrameworkElement.)
Public method | ToString | (Inherited from Control.)
Public method | TransformToAncestor(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToAncestor(System.Windows.Media.Media3D.Visual3D) | (Inherited from Visual.)
Public method | TransformToDescendant(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToVisual(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TranslatePoint(System.Windows.Point,System.Windows.UIElement) | (Inherited from UIElement.)
Public method | TryFindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | UnregisterName(System.String) | (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | (Inherited from FrameworkElement.)
Public method | UpdateLayout | (Inherited from UIElement.)
Public method | VerifyAccess | (Inherited from DispatcherObject.)

See Also

ChangeWRobotLicenseKeyUserControl Class
Relogger.UserControlsAndWindows Namespace


ChangeWRobotLicenseKeyUserControl Properties

The ChangeWRobotLicenseKeyUserControl type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | (Inherited from FrameworkElement.)
Public property | ActualWidth | (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
Public property | AreAnyTouchesOver | (Inherited from UIElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from FrameworkElement.)
Public property | BitmapEffect | (Inherited from UIElement.)
Public property | BitmapEffectInput | (Inherited from UIElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | (Inherited from UIElement.)
Public property | ClipToBounds | (Inherited from UIElement.)
Public property | CommandBindings | (Inherited from UIElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContentTemplate | (Inherited from ContentControl.)
Public property | ContentTemplateSelector | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from FrameworkElement.)
Public property | Cursor | (Inherited from FrameworkElement.)
Public property | DataContext | (Inherited from FrameworkElement.)
Public property | DependencyObjectType | (Inherited from DependencyObject.)
Public property | DesiredSize | (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DispatcherObject.)
Public property | Effect | (Inherited from UIElement.)
Public property | FlowDirection | (Inherited from FrameworkElement.)
Public property | Focusable | (Inherited from UIElement.)
Public property | FocusVisualStyle | (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from FrameworkElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasAnimatedProperties | (Inherited from UIElement.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | InputBindings | (Inherited from UIElement.)
Public property | InputScope | (Inherited from FrameworkElement.)
Public property | IsArrangeValid | (Inherited from UIElement.)
Public property | IsEnabled | (Inherited from UIElement.)
Protected property | IsEnabledCore | (Inherited from UIElement.)
Public property | IsFocused | (Inherited from UIElement.)
Public property | IsHitTestVisible | (Inherited from UIElement.)
Public property | IsInitialized | (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | (Inherited from UIElement.)
Public property | IsKeyboardFocused | (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | (Inherited from UIElement.)
Public property | IsLoaded | (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | (Inherited from UIElement.)
Public property | IsMeasureValid | (Inherited from UIElement.)
Public property | IsMouseCaptured | (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | (Inherited from UIElement.)
Public property | IsMouseOver | (Inherited from UIElement.)
Public property | IsSealed | (Inherited from DependencyObject.)
Public property | IsStylusCaptured | (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | (Inherited from UIElement.)
Public property | IsStylusOver | (Inherited from UIElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsVisible | (Inherited from UIElement.)
Public property | Language | (Inherited from FrameworkElement.)
Public property | LayoutTransform | (Inherited from FrameworkElement.)
Public property | Margin | (Inherited from FrameworkElement.)
Public property | MaxHeight | (Inherited from FrameworkElement.)
Public property | MaxWidth | (Inherited from FrameworkElement.)
Public property | MinHeight | (Inherited from FrameworkElement.)
Public property | MinWidth | (Inherited from FrameworkElement.)
Public property | Name | (Inherited from FrameworkElement.)
Public property | Opacity | (Inherited from UIElement.)
Public property | OpacityMask | (Inherited from UIElement.)
Public property | OverridesDefaultStyle | (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from FrameworkElement.)
Public property | PersistId | (Inherited from UIElement.)
Public property | RenderSize | (Inherited from UIElement.)
Public property | RenderTransform | (Inherited from UIElement.)
Public property | RenderTransformOrigin | (Inherited from UIElement.)
Public property | Resources | (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from UIElement.)
Public property | Style | (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | (Inherited from UIElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | Tag | (Inherited from FrameworkElement.)
Public property | Template | (Inherited from Control.)
Public property | TemplatedParent | (Inherited from FrameworkElement.)
Public property | ToolTip | (Inherited from FrameworkElement.)
Public property | TouchesCaptured | (Inherited from UIElement.)
Public property | TouchesCapturedWithin | (Inherited from UIElement.)
Public property | TouchesDirectlyOver | (Inherited from UIElement.)
Public property | TouchesOver | (Inherited from UIElement.)
Public property | Triggers | (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from UIElement.)
Public property | UseLayoutRounding | (Inherited from FrameworkElement.)
Public property | VerticalAlignment | (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | (Inherited from UIElement.)
Protected property | VisualChildrenCount | (Inherited from FrameworkElement.)
Protected property | VisualParent | (Inherited from Visual.)
Public property | Width | (Inherited from FrameworkElement.)

See Also

ChangeWRobotLicenseKeyUserControl Class
Relogger.UserControlsAndWindows Namespace


ChangeWRobotLicenseKeyUserControl Events

The ChangeWRobotLicenseKeyUserControl type exposes the following members.

Events

 | Name | Description
Public event | ContextMenuClosing | (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | (Inherited from FrameworkElement.)
Public event | DataContextChanged | (Inherited from FrameworkElement.)
Public event | DragEnter | (Inherited from UIElement.)
Public event | DragLeave | (Inherited from UIElement.)
Public event | DragOver | (Inherited from UIElement.)
Public event | Drop | (Inherited from UIElement.)
Public event | FocusableChanged | (Inherited from UIElement.)
Public event | GiveFeedback | (Inherited from UIElement.)
Public event | GotFocus | (Inherited from UIElement.)
Public event | GotKeyboardFocus | (Inherited from UIElement.)
Public event | GotMouseCapture | (Inherited from UIElement.)
Public event | GotStylusCapture | (Inherited from UIElement.)
Public event | GotTouchCapture | (Inherited from UIElement.)
Public event | Initialized | (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsVisibleChanged | (Inherited from UIElement.)
Public event | KeyDown | (Inherited from UIElement.)
Public event | KeyUp | (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from UIElement.)
Public event | Loaded | (Inherited from FrameworkElement.)
Public event | LostFocus | (Inherited from UIElement.)
Public event | LostKeyboardFocus | (Inherited from UIElement.)
Public event | LostMouseCapture | (Inherited from UIElement.)
Public event | LostStylusCapture | (Inherited from UIElement.)
Public event | LostTouchCapture | (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | ManipulationStarting | (Inherited from UIElement.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from UIElement.)
Public event | MouseEnter | (Inherited from UIElement.)
Public event | MouseLeave | (Inherited from UIElement.)
Public event | MouseLeftButtonDown | (Inherited from UIElement.)
Public event | MouseLeftButtonUp | (Inherited from UIElement.)
Public event | MouseMove | (Inherited from UIElement.)
Public event | MouseRightButtonDown | (Inherited from UIElement.)
Public event | MouseRightButtonUp | (Inherited from UIElement.)
Public event | MouseUp | (Inherited from UIElement.)
Public event | MouseWheel | (Inherited from UIElement.)
Public event | PreviewDragEnter | (Inherited from UIElement.)
Public event | PreviewDragLeave | (Inherited from UIElement.)
Public event | PreviewDragOver | (Inherited from UIElement.)
Public event | PreviewDrop | (Inherited from UIElement.)
Public event | PreviewGiveFeedback | (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewKeyDown | (Inherited from UIElement.)
Public event | PreviewKeyUp | (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | (Inherited from Control.)
Public event | PreviewMouseDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseMove | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseUp | (Inherited from UIElement.)
Public event | PreviewMouseWheel | (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | (Inherited from UIElement.)
Public event | PreviewStylusDown | (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | (Inherited from UIElement.)
Public event | PreviewStylusInRange | (Inherited from UIElement.)
Public event | PreviewStylusMove | (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | (Inherited from UIElement.)
Public event | PreviewStylusUp | (Inherited from UIElement.)
Public event | PreviewTextInput | (Inherited from UIElement.)
Public event | PreviewTouchDown | (Inherited from UIElement.)
Public event | PreviewTouchMove | (Inherited from UIElement.)
Public event | PreviewTouchUp | (Inherited from UIElement.)
Public event | QueryContinueDrag | (Inherited from UIElement.)
Public event | QueryCursor | (Inherited from UIElement.)
Public event | RequestBringIntoView | (Inherited from FrameworkElement.)
Public event | SizeChanged | (Inherited from FrameworkElement.)
Public event | SourceUpdated | (Inherited from FrameworkElement.)
Public event | StylusButtonDown | (Inherited from UIElement.)
Public event | StylusButtonUp | (Inherited from UIElement.)
Public event | StylusDown | (Inherited from UIElement.)
Public event | StylusEnter | (Inherited from UIElement.)
Public event | StylusInAirMove | (Inherited from UIElement.)
Public event | StylusInRange | (Inherited from UIElement.)
Public event | StylusLeave | (Inherited from UIElement.)
Public event | StylusMove | (Inherited from UIElement.)
Public event | StylusOutOfRange | (Inherited from UIElement.)
Public event | StylusSystemGesture | (Inherited from UIElement.)
Public event | StylusUp | (Inherited from UIElement.)
Public event | TargetUpdated | (Inherited from FrameworkElement.)
Public event | TextInput | (Inherited from UIElement.)
Public event | ToolTipClosing | (Inherited from FrameworkElement.)
Public event | ToolTipOpening | (Inherited from FrameworkElement.)
Public event | TouchDown | (Inherited from UIElement.)
Public event | TouchEnter | (Inherited from UIElement.)
Public event | TouchLeave | (Inherited from UIElement.)
Public event | TouchMove | (Inherited from UIElement.)
Public event | TouchUp | (Inherited from UIElement.)
Public event | Unloaded | (Inherited from FrameworkElement.)

See Also

ChangeWRobotLicenseKeyUserControl Class
Relogger.UserControlsAndWindows Namespace


ChangeWRobotPathUserControl Class

Logique d'interaction pour ChangeWRobotPath.xaml

Namespace: Relogger.UserControlsAndWindows
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public class ChangeWRobotPathUserControl : UserControl
Public Class ChangeWRobotPathUserControl _
    Inherits UserControl
public ref class ChangeWRobotPathUserControl : public UserControl

Inheritance Hierarchy

Object
DispatcherObject
DependencyObject
Visual
UIElement
FrameworkElement
Control
ContentControl
UserControl
Relogger.UserControlsAndWindows..::..ChangeWRobotPathUserControl

See Also

ChangeWRobotPathUserControl Members
Relogger.UserControlsAndWindows Namespace


ChangeWRobotPathUserControl Members

The ChangeWRobotPathUserControl type exposes the following members.

Constructors

 | Name | Description
Public method | ChangeWRobotPathUserControl | Initializes a new instance of the ChangeWRobotPathUserControl class.

Methods

 | Name | Description
Protected method | AddChild(System.Object) | (Inherited from ContentControl.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate,System.Boolean) | (Inherited from UIElement.)
Protected method | AddText(System.String) | (Inherited from ContentControl.)
Public method | AddToEventRoute(System.Windows.EventRoute,System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | AddVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock) | (Inherited from UIElement.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from FrameworkElement.)
Public method | Arrange(System.Windows.Rect) | (Inherited from UIElement.)
Protected method | ArrangeCore(System.Windows.Rect) | (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(System.Windows.Size) | (Inherited from Control.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline) | (Inherited from UIElement.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | BeginInit | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior,System.Boolean) | (Inherited from FrameworkElement.)
Public method | BringIntoView | (Inherited from FrameworkElement.)
Public method | BringIntoView(System.Windows.Rect) | (Inherited from FrameworkElement.)
Public method | CaptureMouse | (Inherited from UIElement.)
Public method | CaptureStylus | (Inherited from UIElement.)
Public method | CaptureTouch(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DispatcherObject.)
Public method | ClearValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | ClearValue(System.Windows.DependencyPropertyKey) | (Inherited from DependencyObject.)
Public method | CoerceValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | EndInit | (Inherited from FrameworkElement.)
Public method | Equals(System.Object) | (Inherited from DependencyObject.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindCommonVisualAncestor(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | FindName(System.String) | (Inherited from FrameworkElement.)
Public method | FindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from UIElement.)
Public method | GetAnimationBaseValue(System.Windows.DependencyProperty) | (Inherited from UIElement.)
Public method | GetBindingExpression(System.Windows.DependencyProperty) | (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from DependencyObject.)
Protected method | GetLayoutClip(System.Windows.Size) | (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | (Inherited from DependencyObject.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Protected method | GetVisualChild(System.Int32) | (Inherited from FrameworkElement.)
Protected method | HitTestCore(System.Windows.Media.PointHitTestParameters) | (Inherited from UIElement.)
Protected method | HitTestCore(System.Windows.Media.GeometryHitTestParameters) | (Inherited from UIElement.)
Public method | InputHitTest(System.Windows.Point) | (Inherited from UIElement.)
Public method | InvalidateArrange | (Inherited from UIElement.)
Public method | InvalidateMeasure | (Inherited from UIElement.)
Public method | InvalidateProperty(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | InvalidateVisual | (Inherited from UIElement.)
Public method | IsAncestorOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | IsDescendantOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | Measure(System.Windows.Size) | (Inherited from UIElement.)
Protected method | MeasureCore(System.Windows.Size) | (Inherited from FrameworkElement.)
Protected method | MeasureOverride(System.Windows.Size) | (Inherited from Control.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | MoveFocus(System.Windows.Input.TraversalRequest) | (Inherited from FrameworkElement.)
Protected method | OnAccessKey(System.Windows.Input.AccessKeyEventArgs) | (Inherited from UIElement.)
Public method | OnApplyTemplate | (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged(System.Windows.UIElement) | (Inherited from UIElement.)
Protected method | OnContentChanged(System.Object,System.Object) | (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged(System.String,System.String) | (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged(System.Windows.DataTemplate,System.Windows.DataTemplate) | (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged(System.Windows.Controls.DataTemplateSelector,System.Windows.Controls.DataTemplateSelector) | (Inherited from ContentControl.)
Protected method | OnContextMenuClosing(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | (Inherited from UserControl.)
Protected method | OnDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnGotFocus(System.Windows.RoutedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnGotMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnGotStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnGotTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnInitialized(System.EventArgs) | (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnLostFocus(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnLostStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnLostTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback(System.Windows.Input.ManipulationBoundaryFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationCompleted(System.Windows.Input.ManipulationCompletedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationDelta(System.Windows.Input.ManipulationDeltaEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting(System.Windows.Input.ManipulationInertiaStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarted(System.Windows.Input.ManipulationStartedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarting(System.Windows.Input.ManipulationStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseEnter(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeave(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnPreviewMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPropertyChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnQueryCursor(System.Windows.Input.QueryCursorEventArgs) | (Inherited from UIElement.)
Protected method | OnRender(System.Windows.Media.DrawingContext) | (Inherited from UIElement.)
Protected method | OnStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusEnter(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusLeave(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnTemplateChanged(System.Windows.Controls.ControlTemplate,System.Windows.Controls.ControlTemplate) | (Inherited from Control.)
Protected method | OnTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnToolTipClosing(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchEnter(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchLeave(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Public method | PointFromScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PointToScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PredictFocus(System.Windows.Input.FocusNavigationDirection) | (Inherited from FrameworkElement.)
Public method | RaiseEvent(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Public method | ReadLocalValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | RegisterName(System.String,System.Object) | (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | (Inherited from UIElement.)
Public method | ReleaseMouseCapture | (Inherited from UIElement.)
Public method | ReleaseStylusCapture | (Inherited from UIElement.)
Public method | ReleaseTouchCapture(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | RemoveHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Protected method | RemoveVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | SetBinding(System.Windows.DependencyProperty,System.Windows.Data.BindingBase) | (Inherited from FrameworkElement.)
Public method | SetBinding(System.Windows.DependencyProperty,System.String) | (Inherited from FrameworkElement.)
Public method | SetCurrentValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetResourceReference(System.Windows.DependencyProperty,System.Object) | (Inherited from FrameworkElement.)
Public method | SetValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetValue(System.Windows.DependencyPropertyKey,System.Object) | (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | (Inherited from UIElement.)
Public method | ShouldSerializeContent | (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | (Inherited from UIElement.)
Public method | ShouldSerializeResources | (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | (Inherited from FrameworkElement.)
Public method | ToString | (Inherited from Control.)
Public method | TransformToAncestor(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToAncestor(System.Windows.Media.Media3D.Visual3D) | (Inherited from Visual.)
Public method | TransformToDescendant(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToVisual(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TranslatePoint(System.Windows.Point,System.Windows.UIElement) | (Inherited from UIElement.)
Public method | TryFindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | UnregisterName(System.String) | (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | (Inherited from FrameworkElement.)
Public method | UpdateLayout | (Inherited from UIElement.)
Public method | VerifyAccess | (Inherited from DispatcherObject.)

Properties

 | Name | Description
Public property | ActualHeight | (Inherited from FrameworkElement.)
Public property | ActualWidth | (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
Public property | AreAnyTouchesOver | (Inherited from UIElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from FrameworkElement.)
Public property | BitmapEffect | (Inherited from UIElement.)
Public property | BitmapEffectInput | (Inherited from UIElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | (Inherited from UIElement.)
Public property | ClipToBounds | (Inherited from UIElement.)
Public property | CommandBindings | (Inherited from UIElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContentTemplate | (Inherited from ContentControl.)
Public property | ContentTemplateSelector | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from FrameworkElement.)
Public property | Cursor | (Inherited from FrameworkElement.)
Public property | DataContext | (Inherited from FrameworkElement.)
Public property | DependencyObjectType | (Inherited from DependencyObject.)
Public property | DesiredSize | (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DispatcherObject.)
Public property | Effect | (Inherited from UIElement.)
Public property | FlowDirection | (Inherited from FrameworkElement.)
Public property | Focusable | (Inherited from UIElement.)
Public property | FocusVisualStyle | (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from FrameworkElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasAnimatedProperties | (Inherited from UIElement.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | InputBindings | (Inherited from UIElement.)
Public property | InputScope | (Inherited from FrameworkElement.)
Public property | IsArrangeValid | (Inherited from UIElement.)
Public property | IsEnabled | (Inherited from UIElement.)
Protected property | IsEnabledCore | (Inherited from UIElement.)
Public property | IsFocused | (Inherited from UIElement.)
Public property | IsHitTestVisible | (Inherited from UIElement.)
Public property | IsInitialized | (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | (Inherited from UIElement.)
Public property | IsKeyboardFocused | (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | (Inherited from UIElement.)
Public property | IsLoaded | (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | (Inherited from UIElement.)
Public property | IsMeasureValid | (Inherited from UIElement.)
Public property | IsMouseCaptured | (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | (Inherited from UIElement.)
Public property | IsMouseOver | (Inherited from UIElement.)
Public property | IsSealed | (Inherited from DependencyObject.)
Public property | IsStylusCaptured | (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | (Inherited from UIElement.)
Public property | IsStylusOver | (Inherited from UIElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsVisible | (Inherited from UIElement.)
Public property | Language | (Inherited from FrameworkElement.)
Public property | LayoutTransform | (Inherited from FrameworkElement.)
Public property | Margin | (Inherited from FrameworkElement.)
Public property | MaxHeight | (Inherited from FrameworkElement.)
Public property | MaxWidth | (Inherited from FrameworkElement.)
Public property | MinHeight | (Inherited from FrameworkElement.)
Public property | MinWidth | (Inherited from FrameworkElement.)
Public property | Name | (Inherited from FrameworkElement.)
Public property | Opacity | (Inherited from UIElement.)
Public property | OpacityMask | (Inherited from UIElement.)
Public property | OverridesDefaultStyle | (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from FrameworkElement.)
Public property | PersistId | (Inherited from UIElement.)
Public property | RenderSize | (Inherited from UIElement.)
Public property | RenderTransform | (Inherited from UIElement.)
Public property | RenderTransformOrigin | (Inherited from UIElement.)
Public property | Resources | (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from UIElement.)
Public property | Style | (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | (Inherited from UIElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | Tag | (Inherited from FrameworkElement.)
Public property | Template | (Inherited from Control.)
Public property | TemplatedParent | (Inherited from FrameworkElement.)
Public property | ToolTip | (Inherited from FrameworkElement.)
Public property | TouchesCaptured | (Inherited from UIElement.)
Public property | TouchesCapturedWithin | (Inherited from UIElement.)
Public property | TouchesDirectlyOver | (Inherited from UIElement.)
Public property | TouchesOver | (Inherited from UIElement.)
Public property | Triggers | (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from UIElement.)
Public property | UseLayoutRounding | (Inherited from FrameworkElement.)
Public property | VerticalAlignment | (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | (Inherited from UIElement.)
Protected property | VisualChildrenCount | (Inherited from FrameworkElement.)
Protected property | VisualParent | (Inherited from Visual.)
Public property | Width | (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | ContextMenuClosing | (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | (Inherited from FrameworkElement.)
Public event | DataContextChanged | (Inherited from FrameworkElement.)
Public event | DragEnter | (Inherited from UIElement.)
Public event | DragLeave | (Inherited from UIElement.)
Public event | DragOver | (Inherited from UIElement.)
Public event | Drop | (Inherited from UIElement.)
Public event | FocusableChanged | (Inherited from UIElement.)
Public event | GiveFeedback | (Inherited from UIElement.)
Public event | GotFocus | (Inherited from UIElement.)
Public event | GotKeyboardFocus | (Inherited from UIElement.)
Public event | GotMouseCapture | (Inherited from UIElement.)
Public event | GotStylusCapture | (Inherited from UIElement.)
Public event | GotTouchCapture | (Inherited from UIElement.)
Public event | Initialized | (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsVisibleChanged | (Inherited from UIElement.)
Public event | KeyDown | (Inherited from UIElement.)
Public event | KeyUp | (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from UIElement.)
Public event | Loaded | (Inherited from FrameworkElement.)
Public event | LostFocus | (Inherited from UIElement.)
Public event | LostKeyboardFocus | (Inherited from UIElement.)
Public event | LostMouseCapture | (Inherited from UIElement.)
Public event | LostStylusCapture | (Inherited from UIElement.)
Public event | LostTouchCapture | (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | ManipulationStarting | (Inherited from UIElement.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from UIElement.)
Public event | MouseEnter | (Inherited from UIElement.)
Public event | MouseLeave | (Inherited from UIElement.)
Public event | MouseLeftButtonDown | (Inherited from UIElement.)
Public event | MouseLeftButtonUp | (Inherited from UIElement.)
Public event | MouseMove | (Inherited from UIElement.)
Public event | MouseRightButtonDown | (Inherited from UIElement.)
Public event | MouseRightButtonUp | (Inherited from UIElement.)
Public event | MouseUp | (Inherited from UIElement.)
Public event | MouseWheel | (Inherited from UIElement.)
Public event | PreviewDragEnter | (Inherited from UIElement.)
Public event | PreviewDragLeave | (Inherited from UIElement.)
Public event | PreviewDragOver | (Inherited from UIElement.)
Public event | PreviewDrop | (Inherited from UIElement.)
Public event | PreviewGiveFeedback | (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewKeyDown | (Inherited from UIElement.)
Public event | PreviewKeyUp | (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | (Inherited from Control.)
Public event | PreviewMouseDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseMove | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseUp | (Inherited from UIElement.)
Public event | PreviewMouseWheel | (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | (Inherited from UIElement.)
Public event | PreviewStylusDown | (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | (Inherited from UIElement.)
Public event | PreviewStylusInRange | (Inherited from UIElement.)
Public event | PreviewStylusMove | (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | (Inherited from UIElement.)
Public event | PreviewStylusUp | (Inherited from UIElement.)
Public event | PreviewTextInput | (Inherited from UIElement.)
Public event | PreviewTouchDown | (Inherited from UIElement.)
Public event | PreviewTouchMove | (Inherited from UIElement.)
Public event | PreviewTouchUp | (Inherited from UIElement.)
Public event | QueryContinueDrag | (Inherited from UIElement.)
Public event | QueryCursor | (Inherited from UIElement.)
Public event | RequestBringIntoView | (Inherited from FrameworkElement.)
Public event | SizeChanged | (Inherited from FrameworkElement.)
Public event | SourceUpdated | (Inherited from FrameworkElement.)
Public event | StylusButtonDown | (Inherited from UIElement.)
Public event | StylusButtonUp | (Inherited from UIElement.)
Public event | StylusDown | (Inherited from UIElement.)
Public event | StylusEnter | (Inherited from UIElement.)
Public event | StylusInAirMove | (Inherited from UIElement.)
Public event | StylusInRange | (Inherited from UIElement.)
Public event | StylusLeave | (Inherited from UIElement.)
Public event | StylusMove | (Inherited from UIElement.)
Public event | StylusOutOfRange | (Inherited from UIElement.)
Public event | StylusSystemGesture | (Inherited from UIElement.)
Public event | StylusUp | (Inherited from UIElement.)
Public event | TargetUpdated | (Inherited from FrameworkElement.)
Public event | TextInput | (Inherited from UIElement.)
Public event | ToolTipClosing | (Inherited from FrameworkElement.)
Public event | ToolTipOpening | (Inherited from FrameworkElement.)
Public event | TouchDown | (Inherited from UIElement.)
Public event | TouchEnter | (Inherited from UIElement.)
Public event | TouchLeave | (Inherited from UIElement.)
Public event | TouchMove | (Inherited from UIElement.)
Public event | TouchUp | (Inherited from UIElement.)
Public event | Unloaded | (Inherited from FrameworkElement.)

See Also

ChangeWRobotPathUserControl Class
Relogger.UserControlsAndWindows Namespace


ChangeWRobotPathUserControl Constructor

Initializes a new instance of the ChangeWRobotPathUserControl class.

Namespace: Relogger.UserControlsAndWindows
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public ChangeWRobotPathUserControl()
Public Sub New
public:
ChangeWRobotPathUserControl()

See Also

ChangeWRobotPathUserControl Class
Relogger.UserControlsAndWindows Namespace


ChangeWRobotPathUserControl Methods

The ChangeWRobotPathUserControl type exposes the following members.

Methods

 | Name | Description
Protected method | AddChild(System.Object) | (Inherited from ContentControl.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate,System.Boolean) | (Inherited from UIElement.)
Protected method | AddText(System.String) | (Inherited from ContentControl.)
Public method | AddToEventRoute(System.Windows.EventRoute,System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | AddVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock) | (Inherited from UIElement.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from FrameworkElement.)
Public method | Arrange(System.Windows.Rect) | (Inherited from UIElement.)
Protected method | ArrangeCore(System.Windows.Rect) | (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(System.Windows.Size) | (Inherited from Control.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline) | (Inherited from UIElement.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | BeginInit | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior,System.Boolean) | (Inherited from FrameworkElement.)
Public method | BringIntoView | (Inherited from FrameworkElement.)
Public method | BringIntoView(System.Windows.Rect) | (Inherited from FrameworkElement.)
Public method | CaptureMouse | (Inherited from UIElement.)
Public method | CaptureStylus | (Inherited from UIElement.)
Public method | CaptureTouch(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DispatcherObject.)
Public method | ClearValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | ClearValue(System.Windows.DependencyPropertyKey) | (Inherited from DependencyObject.)
Public method | CoerceValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | EndInit | (Inherited from FrameworkElement.)
Public method | Equals(System.Object) | (Inherited from DependencyObject.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindCommonVisualAncestor(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | FindName(System.String) | (Inherited from FrameworkElement.)
Public method | FindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from UIElement.)
Public method | GetAnimationBaseValue(System.Windows.DependencyProperty) | (Inherited from UIElement.)
Public method | GetBindingExpression(System.Windows.DependencyProperty) | (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from DependencyObject.)
Protected method | GetLayoutClip(System.Windows.Size) | (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | (Inherited from DependencyObject.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Protected method | GetVisualChild(System.Int32) | (Inherited from FrameworkElement.)
Protected method | HitTestCore(System.Windows.Media.PointHitTestParameters) | (Inherited from UIElement.)
Protected method | HitTestCore(System.Windows.Media.GeometryHitTestParameters) | (Inherited from UIElement.)
Public method | InputHitTest(System.Windows.Point) | (Inherited from UIElement.)
Public method | InvalidateArrange | (Inherited from UIElement.)
Public method | InvalidateMeasure | (Inherited from UIElement.)
Public method | InvalidateProperty(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | InvalidateVisual | (Inherited from UIElement.)
Public method | IsAncestorOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | IsDescendantOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | Measure(System.Windows.Size) | (Inherited from UIElement.)
Protected method | MeasureCore(System.Windows.Size) | (Inherited from FrameworkElement.)
Protected method | MeasureOverride(System.Windows.Size) | (Inherited from Control.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | MoveFocus(System.Windows.Input.TraversalRequest) | (Inherited from FrameworkElement.)
Protected method | OnAccessKey(System.Windows.Input.AccessKeyEventArgs) | (Inherited from UIElement.)
Public method | OnApplyTemplate | (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged(System.Windows.UIElement) | (Inherited from UIElement.)
Protected method | OnContentChanged(System.Object,System.Object) | (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged(System.String,System.String) | (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged(System.Windows.DataTemplate,System.Windows.DataTemplate) | (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged(System.Windows.Controls.DataTemplateSelector,System.Windows.Controls.DataTemplateSelector) | (Inherited from ContentControl.)
Protected method | OnContextMenuClosing(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | (Inherited from UserControl.)
Protected method | OnDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnGotFocus(System.Windows.RoutedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnGotMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnGotStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnGotTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnInitialized(System.EventArgs) | (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnLostFocus(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnLostStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnLostTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback(System.Windows.Input.ManipulationBoundaryFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationCompleted(System.Windows.Input.ManipulationCompletedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationDelta(System.Windows.Input.ManipulationDeltaEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting(System.Windows.Input.ManipulationInertiaStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarted(System.Windows.Input.ManipulationStartedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarting(System.Windows.Input.ManipulationStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseEnter(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeave(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnPreviewMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPropertyChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnQueryCursor(System.Windows.Input.QueryCursorEventArgs) | (Inherited from UIElement.)
Protected method | OnRender(System.Windows.Media.DrawingContext) | (Inherited from UIElement.)
Protected method | OnStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusEnter(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusLeave(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnTemplateChanged(System.Windows.Controls.ControlTemplate,System.Windows.Controls.ControlTemplate) | (Inherited from Control.)
Protected method | OnTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnToolTipClosing(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchEnter(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchLeave(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Public method | PointFromScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PointToScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PredictFocus(System.Windows.Input.FocusNavigationDirection) | (Inherited from FrameworkElement.)
Public method | RaiseEvent(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Public method | ReadLocalValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | RegisterName(System.String,System.Object) | (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | (Inherited from UIElement.)
Public method | ReleaseMouseCapture | (Inherited from UIElement.)
Public method | ReleaseStylusCapture | (Inherited from UIElement.)
Public method | ReleaseTouchCapture(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | RemoveHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Protected method | RemoveVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | SetBinding(System.Windows.DependencyProperty,System.Windows.Data.BindingBase) | (Inherited from FrameworkElement.)
Public method | SetBinding(System.Windows.DependencyProperty,System.String) | (Inherited from FrameworkElement.)
Public method | SetCurrentValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetResourceReference(System.Windows.DependencyProperty,System.Object) | (Inherited from FrameworkElement.)
Public method | SetValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetValue(System.Windows.DependencyPropertyKey,System.Object) | (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | (Inherited from UIElement.)
Public method | ShouldSerializeContent | (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | (Inherited from UIElement.)
Public method | ShouldSerializeResources | (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | (Inherited from FrameworkElement.)
Public method | ToString | (Inherited from Control.)
Public method | TransformToAncestor(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToAncestor(System.Windows.Media.Media3D.Visual3D) | (Inherited from Visual.)
Public method | TransformToDescendant(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToVisual(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TranslatePoint(System.Windows.Point,System.Windows.UIElement) | (Inherited from UIElement.)
Public method | TryFindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | UnregisterName(System.String) | (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | (Inherited from FrameworkElement.)
Public method | UpdateLayout | (Inherited from UIElement.)
Public method | VerifyAccess | (Inherited from DispatcherObject.)

See Also

ChangeWRobotPathUserControl Class
Relogger.UserControlsAndWindows Namespace


ChangeWRobotPathUserControl Properties

The ChangeWRobotPathUserControl type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | (Inherited from FrameworkElement.)
Public property | ActualWidth | (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
Public property | AreAnyTouchesOver | (Inherited from UIElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from FrameworkElement.)
Public property | BitmapEffect | (Inherited from UIElement.)
Public property | BitmapEffectInput | (Inherited from UIElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | (Inherited from UIElement.)
Public property | ClipToBounds | (Inherited from UIElement.)
Public property | CommandBindings | (Inherited from UIElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContentTemplate | (Inherited from ContentControl.)
Public property | ContentTemplateSelector | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from FrameworkElement.)
Public property | Cursor | (Inherited from FrameworkElement.)
Public property | DataContext | (Inherited from FrameworkElement.)
Public property | DependencyObjectType | (Inherited from DependencyObject.)
Public property | DesiredSize | (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DispatcherObject.)
Public property | Effect | (Inherited from UIElement.)
Public property | FlowDirection | (Inherited from FrameworkElement.)
Public property | Focusable | (Inherited from UIElement.)
Public property | FocusVisualStyle | (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from FrameworkElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasAnimatedProperties | (Inherited from UIElement.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | InputBindings | (Inherited from UIElement.)
Public property | InputScope | (Inherited from FrameworkElement.)
Public property | IsArrangeValid | (Inherited from UIElement.)
Public property | IsEnabled | (Inherited from UIElement.)
Protected property | IsEnabledCore | (Inherited from UIElement.)
Public property | IsFocused | (Inherited from UIElement.)
Public property | IsHitTestVisible | (Inherited from UIElement.)
Public property | IsInitialized | (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | (Inherited from UIElement.)
Public property | IsKeyboardFocused | (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | (Inherited from UIElement.)
Public property | IsLoaded | (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | (Inherited from UIElement.)
Public property | IsMeasureValid | (Inherited from UIElement.)
Public property | IsMouseCaptured | (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | (Inherited from UIElement.)
Public property | IsMouseOver | (Inherited from UIElement.)
Public property | IsSealed | (Inherited from DependencyObject.)
Public property | IsStylusCaptured | (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | (Inherited from UIElement.)
Public property | IsStylusOver | (Inherited from UIElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsVisible | (Inherited from UIElement.)
Public property | Language | (Inherited from FrameworkElement.)
Public property | LayoutTransform | (Inherited from FrameworkElement.)
Public property | Margin | (Inherited from FrameworkElement.)
Public property | MaxHeight | (Inherited from FrameworkElement.)
Public property | MaxWidth | (Inherited from FrameworkElement.)
Public property | MinHeight | (Inherited from FrameworkElement.)
Public property | MinWidth | (Inherited from FrameworkElement.)
Public property | Name | (Inherited from FrameworkElement.)
Public property | Opacity | (Inherited from UIElement.)
Public property | OpacityMask | (Inherited from UIElement.)
Public property | OverridesDefaultStyle | (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from FrameworkElement.)
Public property | PersistId | (Inherited from UIElement.)
Public property | RenderSize | (Inherited from UIElement.)
Public property | RenderTransform | (Inherited from UIElement.)
Public property | RenderTransformOrigin | (Inherited from UIElement.)
Public property | Resources | (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from UIElement.)
Public property | Style | (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | (Inherited from UIElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | Tag | (Inherited from FrameworkElement.)
Public property | Template | (Inherited from Control.)
Public property | TemplatedParent | (Inherited from FrameworkElement.)
Public property | ToolTip | (Inherited from FrameworkElement.)
Public property | TouchesCaptured | (Inherited from UIElement.)
Public property | TouchesCapturedWithin | (Inherited from UIElement.)
Public property | TouchesDirectlyOver | (Inherited from UIElement.)
Public property | TouchesOver | (Inherited from UIElement.)
Public property | Triggers | (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from UIElement.)
Public property | UseLayoutRounding | (Inherited from FrameworkElement.)
Public property | VerticalAlignment | (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | (Inherited from UIElement.)
Protected property | VisualChildrenCount | (Inherited from FrameworkElement.)
Protected property | VisualParent | (Inherited from Visual.)
Public property | Width | (Inherited from FrameworkElement.)

See Also

ChangeWRobotPathUserControl Class
Relogger.UserControlsAndWindows Namespace


ChangeWRobotPathUserControl Events

The ChangeWRobotPathUserControl type exposes the following members.

Events

 | Name | Description
Public event | ContextMenuClosing | (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | (Inherited from FrameworkElement.)
Public event | DataContextChanged | (Inherited from FrameworkElement.)
Public event | DragEnter | (Inherited from UIElement.)
Public event | DragLeave | (Inherited from UIElement.)
Public event | DragOver | (Inherited from UIElement.)
Public event | Drop | (Inherited from UIElement.)
Public event | FocusableChanged | (Inherited from UIElement.)
Public event | GiveFeedback | (Inherited from UIElement.)
Public event | GotFocus | (Inherited from UIElement.)
Public event | GotKeyboardFocus | (Inherited from UIElement.)
Public event | GotMouseCapture | (Inherited from UIElement.)
Public event | GotStylusCapture | (Inherited from UIElement.)
Public event | GotTouchCapture | (Inherited from UIElement.)
Public event | Initialized | (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsVisibleChanged | (Inherited from UIElement.)
Public event | KeyDown | (Inherited from UIElement.)
Public event | KeyUp | (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from UIElement.)
Public event | Loaded | (Inherited from FrameworkElement.)
Public event | LostFocus | (Inherited from UIElement.)
Public event | LostKeyboardFocus | (Inherited from UIElement.)
Public event | LostMouseCapture | (Inherited from UIElement.)
Public event | LostStylusCapture | (Inherited from UIElement.)
Public event | LostTouchCapture | (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | ManipulationStarting | (Inherited from UIElement.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from UIElement.)
Public event | MouseEnter | (Inherited from UIElement.)
Public event | MouseLeave | (Inherited from UIElement.)
Public event | MouseLeftButtonDown | (Inherited from UIElement.)
Public event | MouseLeftButtonUp | (Inherited from UIElement.)
Public event | MouseMove | (Inherited from UIElement.)
Public event | MouseRightButtonDown | (Inherited from UIElement.)
Public event | MouseRightButtonUp | (Inherited from UIElement.)
Public event | MouseUp | (Inherited from UIElement.)
Public event | MouseWheel | (Inherited from UIElement.)
Public event | PreviewDragEnter | (Inherited from UIElement.)
Public event | PreviewDragLeave | (Inherited from UIElement.)
Public event | PreviewDragOver | (Inherited from UIElement.)
Public event | PreviewDrop | (Inherited from UIElement.)
Public event | PreviewGiveFeedback | (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewKeyDown | (Inherited from UIElement.)
Public event | PreviewKeyUp | (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | (Inherited from Control.)
Public event | PreviewMouseDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseMove | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseUp | (Inherited from UIElement.)
Public event | PreviewMouseWheel | (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | (Inherited from UIElement.)
Public event | PreviewStylusDown | (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | (Inherited from UIElement.)
Public event | PreviewStylusInRange | (Inherited from UIElement.)
Public event | PreviewStylusMove | (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | (Inherited from UIElement.)
Public event | PreviewStylusUp | (Inherited from UIElement.)
Public event | PreviewTextInput | (Inherited from UIElement.)
Public event | PreviewTouchDown | (Inherited from UIElement.)
Public event | PreviewTouchMove | (Inherited from UIElement.)
Public event | PreviewTouchUp | (Inherited from UIElement.)
Public event | QueryContinueDrag | (Inherited from UIElement.)
Public event | QueryCursor | (Inherited from UIElement.)
Public event | RequestBringIntoView | (Inherited from FrameworkElement.)
Public event | SizeChanged | (Inherited from FrameworkElement.)
Public event | SourceUpdated | (Inherited from FrameworkElement.)
Public event | StylusButtonDown | (Inherited from UIElement.)
Public event | StylusButtonUp | (Inherited from UIElement.)
Public event | StylusDown | (Inherited from UIElement.)
Public event | StylusEnter | (Inherited from UIElement.)
Public event | StylusInAirMove | (Inherited from UIElement.)
Public event | StylusInRange | (Inherited from UIElement.)
Public event | StylusLeave | (Inherited from UIElement.)
Public event | StylusMove | (Inherited from UIElement.)
Public event | StylusOutOfRange | (Inherited from UIElement.)
Public event | StylusSystemGesture | (Inherited from UIElement.)
Public event | StylusUp | (Inherited from UIElement.)
Public event | TargetUpdated | (Inherited from FrameworkElement.)
Public event | TextInput | (Inherited from UIElement.)
Public event | ToolTipClosing | (Inherited from FrameworkElement.)
Public event | ToolTipOpening | (Inherited from FrameworkElement.)
Public event | TouchDown | (Inherited from UIElement.)
Public event | TouchEnter | (Inherited from UIElement.)
Public event | TouchLeave | (Inherited from UIElement.)
Public event | TouchMove | (Inherited from UIElement.)
Public event | TouchUp | (Inherited from UIElement.)
Public event | Unloaded | (Inherited from FrameworkElement.)

See Also

ChangeWRobotPathUserControl Class
Relogger.UserControlsAndWindows Namespace


ReloggerGeneralSettingsWindow Class

Class ReloggerGeneralSettingsWindow. Implements the Window Implements the IComponentConnector

Namespace: Relogger.UserControlsAndWindows
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public class ReloggerGeneralSettingsWindow : Window
Public Class ReloggerGeneralSettingsWindow _
    Inherits Window
public ref class ReloggerGeneralSettingsWindow : public Window

Inheritance Hierarchy

Object
DispatcherObject
DependencyObject
Visual
UIElement
FrameworkElement
Control
ContentControl
Window
Relogger.UserControlsAndWindows..::..ReloggerGeneralSettingsWindow

See Also

ReloggerGeneralSettingsWindow Members
Relogger.UserControlsAndWindows Namespace
Window
IComponentConnector


ReloggerGeneralSettingsWindow Members

The ReloggerGeneralSettingsWindow type exposes the following members.

Constructors

 | Name | Description
Public method | ReloggerGeneralSettingsWindow | Initializes a new instance of the ReloggerGeneralSettingsWindow class.

Methods

 | Name | Description
Public method | Activate | (Inherited from Window.)
Protected method | AddChild(System.Object) | (Inherited from ContentControl.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate,System.Boolean) | (Inherited from UIElement.)
Protected method | AddText(System.String) | (Inherited from ContentControl.)
Public method | AddToEventRoute(System.Windows.EventRoute,System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | AddVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock) | (Inherited from UIElement.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from FrameworkElement.)
Public method | Arrange(System.Windows.Rect) | (Inherited from UIElement.)
Protected method | ArrangeCore(System.Windows.Rect) | (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(System.Windows.Size) | (Inherited from Window.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline) | (Inherited from UIElement.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | BeginInit | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior,System.Boolean) | (Inherited from FrameworkElement.)
Public method | BringIntoView | (Inherited from FrameworkElement.)
Public method | BringIntoView(System.Windows.Rect) | (Inherited from FrameworkElement.)
Public method | CaptureMouse | (Inherited from UIElement.)
Public method | CaptureStylus | (Inherited from UIElement.)
Public method | CaptureTouch(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DispatcherObject.)
Public method | ClearValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | ClearValue(System.Windows.DependencyPropertyKey) | (Inherited from DependencyObject.)
Public method | Close | (Inherited from Window.)
Public method | CoerceValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | DragMove | (Inherited from Window.)
Public method | EndInit | (Inherited from FrameworkElement.)
Public method | Equals(System.Object) | (Inherited from DependencyObject.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindCommonVisualAncestor(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | FindName(System.String) | (Inherited from FrameworkElement.)
Public method | FindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from UIElement.)
Public method | GetAnimationBaseValue(System.Windows.DependencyProperty) | (Inherited from UIElement.)
Public method | GetBindingExpression(System.Windows.DependencyProperty) | (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from DependencyObject.)
Protected method | GetLayoutClip(System.Windows.Size) | (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | (Inherited from DependencyObject.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Protected method | GetVisualChild(System.Int32) | (Inherited from FrameworkElement.)
Public method | Hide | (Inherited from Window.)
Protected method | HitTestCore(System.Windows.Media.PointHitTestParameters) | (Inherited from UIElement.)
Protected method | HitTestCore(System.Windows.Media.GeometryHitTestParameters) | (Inherited from UIElement.)
Public method | InputHitTest(System.Windows.Point) | (Inherited from UIElement.)
Public method | InvalidateArrange | (Inherited from UIElement.)
Public method | InvalidateMeasure | (Inherited from UIElement.)
Public method | InvalidateProperty(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | InvalidateVisual | (Inherited from UIElement.)
Public method | IsAncestorOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | IsDescendantOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | Measure(System.Windows.Size) | (Inherited from UIElement.)
Protected method | MeasureCore(System.Windows.Size) | (Inherited from FrameworkElement.)
Protected method | MeasureOverride(System.Windows.Size) | (Inherited from Window.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | MoveFocus(System.Windows.Input.TraversalRequest) | (Inherited from FrameworkElement.)
Protected method | OnAccessKey(System.Windows.Input.AccessKeyEventArgs) | (Inherited from UIElement.)
Protected method | OnActivated(System.EventArgs) | (Inherited from Window.)
Public method | OnApplyTemplate | (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged(System.Windows.UIElement) | (Inherited from UIElement.)
Protected method | OnClosed(System.EventArgs) | (Inherited from Window.)
Protected method | OnClosing(System.ComponentModel.CancelEventArgs) | (Inherited from Window.)
Protected method | OnContentChanged(System.Object,System.Object) | (Inherited from Window.)
Protected method | OnContentRendered(System.EventArgs) | (Inherited from Window.)
Protected method | OnContentStringFormatChanged(System.String,System.String) | (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged(System.Windows.DataTemplate,System.Windows.DataTemplate) | (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged(System.Windows.Controls.DataTemplateSelector,System.Windows.Controls.DataTemplateSelector) | (Inherited from ContentControl.)
Protected method | OnContextMenuClosing(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | (Inherited from Window.)
Protected method | OnDeactivated(System.EventArgs) | (Inherited from Window.)
Protected method | OnDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnGotFocus(System.Windows.RoutedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnGotMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnGotStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnGotTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnInitialized(System.EventArgs) | (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Window.)
Protected method | OnLostFocus(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnLostStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnLostTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback(System.Windows.Input.ManipulationBoundaryFeedbackEventArgs) | (Inherited from Window.)
Protected method | OnManipulationCompleted(System.Windows.Input.ManipulationCompletedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationDelta(System.Windows.Input.ManipulationDeltaEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting(System.Windows.Input.ManipulationInertiaStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarted(System.Windows.Input.ManipulationStartedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarting(System.Windows.Input.ManipulationStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseEnter(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeave(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnPreviewMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPropertyChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnQueryCursor(System.Windows.Input.QueryCursorEventArgs) | (Inherited from UIElement.)
Protected method | OnRender(System.Windows.Media.DrawingContext) | (Inherited from UIElement.)
Protected method | OnSourceInitialized(System.EventArgs) | (Inherited from Window.)
Protected method | OnStateChanged(System.EventArgs) | (Inherited from Window.)
Protected method | OnStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusEnter(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusLeave(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnTemplateChanged(System.Windows.Controls.ControlTemplate,System.Windows.Controls.ControlTemplate) | (Inherited from Control.)
Protected method | OnTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnToolTipClosing(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchEnter(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchLeave(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Public method | PointFromScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PointToScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PredictFocus(System.Windows.Input.FocusNavigationDirection) | (Inherited from FrameworkElement.)
Public method | RaiseEvent(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Public method | ReadLocalValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | RegisterName(System.String,System.Object) | (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | (Inherited from UIElement.)
Public method | ReleaseMouseCapture | (Inherited from UIElement.)
Public method | ReleaseStylusCapture | (Inherited from UIElement.)
Public method | ReleaseTouchCapture(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | RemoveHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Protected method | RemoveVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | SetBinding(System.Windows.DependencyProperty,System.Windows.Data.BindingBase) | (Inherited from FrameworkElement.)
Public method | SetBinding(System.Windows.DependencyProperty,System.String) | (Inherited from FrameworkElement.)
Public method | SetCurrentValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetResourceReference(System.Windows.DependencyProperty,System.Object) | (Inherited from FrameworkElement.)
Public method | SetValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetValue(System.Windows.DependencyPropertyKey,System.Object) | (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | (Inherited from UIElement.)
Public method | ShouldSerializeContent | (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | (Inherited from UIElement.)
Public method | ShouldSerializeResources | (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | (Inherited from FrameworkElement.)
Public method | Show | (Inherited from Window.)
Public method | ShowDialog | (Inherited from Window.)
Public method | ToString | (Inherited from Control.)
Public method | TransformToAncestor(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToAncestor(System.Windows.Media.Media3D.Visual3D) | (Inherited from Visual.)
Public method | TransformToDescendant(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToVisual(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TranslatePoint(System.Windows.Point,System.Windows.UIElement) | (Inherited from UIElement.)
Public method | TryFindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | UnregisterName(System.String) | (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | (Inherited from FrameworkElement.)
Public method | UpdateLayout | (Inherited from UIElement.)
Public method | VerifyAccess | (Inherited from DispatcherObject.)

Properties

 | Name | Description
Public property | ActualHeight | (Inherited from FrameworkElement.)
Public property | ActualWidth | (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from UIElement.)
Public property | AllowsTransparency | (Inherited from Window.)
Public property | AreAnyTouchesCaptured | (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
Public property | AreAnyTouchesOver | (Inherited from UIElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from FrameworkElement.)
Public property | BitmapEffect | (Inherited from UIElement.)
Public property | BitmapEffectInput | (Inherited from UIElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | (Inherited from UIElement.)
Public property | ClipToBounds | (Inherited from UIElement.)
Public property | CommandBindings | (Inherited from UIElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContentTemplate | (Inherited from ContentControl.)
Public property | ContentTemplateSelector | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from FrameworkElement.)
Public property | Cursor | (Inherited from FrameworkElement.)
Public property | DataContext | (Inherited from FrameworkElement.)
Public property | DependencyObjectType | (Inherited from DependencyObject.)
Public property | DesiredSize | (Inherited from UIElement.)
Public property | DialogResult | (Inherited from Window.)
Public property | Dispatcher | (Inherited from DispatcherObject.)
Public property | Effect | (Inherited from UIElement.)
Public property | FlowDirection | (Inherited from FrameworkElement.)
Public property | Focusable | (Inherited from UIElement.)
Public property | FocusVisualStyle | (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from FrameworkElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasAnimatedProperties | (Inherited from UIElement.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Icon | (Inherited from Window.)
Public property | InputBindings | (Inherited from UIElement.)
Public property | InputScope | (Inherited from FrameworkElement.)
Public property | IsActive | (Inherited from Window.)
Public property | IsArrangeValid | (Inherited from UIElement.)
Public property | IsEnabled | (Inherited from UIElement.)
Protected property | IsEnabledCore | (Inherited from UIElement.)
Public property | IsFocused | (Inherited from UIElement.)
Public property | IsHitTestVisible | (Inherited from UIElement.)
Public property | IsInitialized | (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | (Inherited from UIElement.)
Public property | IsKeyboardFocused | (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | (Inherited from UIElement.)
Public property | IsLoaded | (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | (Inherited from UIElement.)
Public property | IsMeasureValid | (Inherited from UIElement.)
Public property | IsMouseCaptured | (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | (Inherited from UIElement.)
Public property | IsMouseOver | (Inherited from UIElement.)
Public property | IsSealed | (Inherited from DependencyObject.)
Public property | IsStylusCaptured | (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | (Inherited from UIElement.)
Public property | IsStylusOver | (Inherited from UIElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsVisible | (Inherited from UIElement.)
Public property | Language | (Inherited from FrameworkElement.)
Public property | LayoutTransform | (Inherited from FrameworkElement.)
Public property | Left | (Inherited from Window.)
Public property | Margin | (Inherited from FrameworkElement.)
Public property | MaxHeight | (Inherited from FrameworkElement.)
Public property | MaxWidth | (Inherited from FrameworkElement.)
Public property | MinHeight | (Inherited from FrameworkElement.)
Public property | MinWidth | (Inherited from FrameworkElement.)
Public property | Name | (Inherited from FrameworkElement.)
Public property | Opacity | (Inherited from UIElement.)
Public property | OpacityMask | (Inherited from UIElement.)
Public property | OverridesDefaultStyle | (Inherited from FrameworkElement.)
Public property | OwnedWindows | (Inherited from Window.)
Public property | Owner | (Inherited from Window.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from FrameworkElement.)
Public property | PersistId | (Inherited from UIElement.)
Public property | RenderSize | (Inherited from UIElement.)
Public property | RenderTransform | (Inherited from UIElement.)
Public property | RenderTransformOrigin | (Inherited from UIElement.)
Public property | ResizeMode | (Inherited from Window.)
Public property | Resources | (Inherited from FrameworkElement.)
Public property | RestoreBounds | (Inherited from Window.)
Public property | ShowActivated | (Inherited from Window.)
Public property | ShowInTaskbar | (Inherited from Window.)
Public property | SizeToContent | (Inherited from Window.)
Public property | SnapsToDevicePixels | (Inherited from UIElement.)
Public property | Style | (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | (Inherited from UIElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | Tag | (Inherited from FrameworkElement.)
Public property | TaskbarItemInfo | (Inherited from Window.)
Public property | Template | (Inherited from Control.)
Public property | TemplatedParent | (Inherited from FrameworkElement.)
Public property | Title | (Inherited from Window.)
Public property | ToolTip | (Inherited from FrameworkElement.)
Public property | Top | (Inherited from Window.)
Public property | Topmost | (Inherited from Window.)
Public property | TouchesCaptured | (Inherited from UIElement.)
Public property | TouchesCapturedWithin | (Inherited from UIElement.)
Public property | TouchesDirectlyOver | (Inherited from UIElement.)
Public property | TouchesOver | (Inherited from UIElement.)
Public property | Triggers | (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from UIElement.)
Public property | UseLayoutRounding | (Inherited from FrameworkElement.)
Public property | VerticalAlignment | (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | (Inherited from UIElement.)
Protected property | VisualChildrenCount | (Inherited from FrameworkElement.)
Protected property | VisualParent | (Inherited from Visual.)
Public property | Width | (Inherited from FrameworkElement.)
Public property | WindowStartupLocation | (Inherited from Window.)
Public property | WindowState | (Inherited from Window.)
Public property | WindowStyle | (Inherited from Window.)

Events

 | Name | Description
Public event | Activated | (Inherited from Window.)
Public event | Closed | (Inherited from Window.)
Public event | Closing | (Inherited from Window.)
Public event | ContentRendered | (Inherited from Window.)
Public event | ContextMenuClosing | (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | (Inherited from FrameworkElement.)
Public event | DataContextChanged | (Inherited from FrameworkElement.)
Public event | Deactivated | (Inherited from Window.)
Public event | DragEnter | (Inherited from UIElement.)
Public event | DragLeave | (Inherited from UIElement.)
Public event | DragOver | (Inherited from UIElement.)
Public event | Drop | (Inherited from UIElement.)
Public event | FocusableChanged | (Inherited from UIElement.)
Public event | GiveFeedback | (Inherited from UIElement.)
Public event | GotFocus | (Inherited from UIElement.)
Public event | GotKeyboardFocus | (Inherited from UIElement.)
Public event | GotMouseCapture | (Inherited from UIElement.)
Public event | GotStylusCapture | (Inherited from UIElement.)
Public event | GotTouchCapture | (Inherited from UIElement.)
Public event | Initialized | (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsVisibleChanged | (Inherited from UIElement.)
Public event | KeyDown | (Inherited from UIElement.)
Public event | KeyUp | (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from UIElement.)
Public event | Loaded | (Inherited from FrameworkElement.)
Public event | LocationChanged | (Inherited from Window.)
Public event | LostFocus | (Inherited from UIElement.)
Public event | LostKeyboardFocus | (Inherited from UIElement.)
Public event | LostMouseCapture | (Inherited from UIElement.)
Public event | LostStylusCapture | (Inherited from UIElement.)
Public event | LostTouchCapture | (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | ManipulationStarting | (Inherited from UIElement.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from UIElement.)
Public event | MouseEnter | (Inherited from UIElement.)
Public event | MouseLeave | (Inherited from UIElement.)
Public event | MouseLeftButtonDown | (Inherited from UIElement.)
Public event | MouseLeftButtonUp | (Inherited from UIElement.)
Public event | MouseMove | (Inherited from UIElement.)
Public event | MouseRightButtonDown | (Inherited from UIElement.)
Public event | MouseRightButtonUp | (Inherited from UIElement.)
Public event | MouseUp | (Inherited from UIElement.)
Public event | MouseWheel | (Inherited from UIElement.)
Public event | PreviewDragEnter | (Inherited from UIElement.)
Public event | PreviewDragLeave | (Inherited from UIElement.)
Public event | PreviewDragOver | (Inherited from UIElement.)
Public event | PreviewDrop | (Inherited from UIElement.)
Public event | PreviewGiveFeedback | (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewKeyDown | (Inherited from UIElement.)
Public event | PreviewKeyUp | (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | (Inherited from Control.)
Public event | PreviewMouseDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseMove | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseUp | (Inherited from UIElement.)
Public event | PreviewMouseWheel | (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | (Inherited from UIElement.)
Public event | PreviewStylusDown | (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | (Inherited from UIElement.)
Public event | PreviewStylusInRange | (Inherited from UIElement.)
Public event | PreviewStylusMove | (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | (Inherited from UIElement.)
Public event | PreviewStylusUp | (Inherited from UIElement.)
Public event | PreviewTextInput | (Inherited from UIElement.)
Public event | PreviewTouchDown | (Inherited from UIElement.)
Public event | PreviewTouchMove | (Inherited from UIElement.)
Public event | PreviewTouchUp | (Inherited from UIElement.)
Public event | QueryContinueDrag | (Inherited from UIElement.)
Public event | QueryCursor | (Inherited from UIElement.)
Public event | RequestBringIntoView | (Inherited from FrameworkElement.)
Public event | SizeChanged | (Inherited from FrameworkElement.)
Public event | SourceInitialized | (Inherited from Window.)
Public event | SourceUpdated | (Inherited from FrameworkElement.)
Public event | StateChanged | (Inherited from Window.)
Public event | StylusButtonDown | (Inherited from UIElement.)
Public event | StylusButtonUp | (Inherited from UIElement.)
Public event | StylusDown | (Inherited from UIElement.)
Public event | StylusEnter | (Inherited from UIElement.)
Public event | StylusInAirMove | (Inherited from UIElement.)
Public event | StylusInRange | (Inherited from UIElement.)
Public event | StylusLeave | (Inherited from UIElement.)
Public event | StylusMove | (Inherited from UIElement.)
Public event | StylusOutOfRange | (Inherited from UIElement.)
Public event | StylusSystemGesture | (Inherited from UIElement.)
Public event | StylusUp | (Inherited from UIElement.)
Public event | TargetUpdated | (Inherited from FrameworkElement.)
Public event | TextInput | (Inherited from UIElement.)
Public event | ToolTipClosing | (Inherited from FrameworkElement.)
Public event | ToolTipOpening | (Inherited from FrameworkElement.)
Public event | TouchDown | (Inherited from UIElement.)
Public event | TouchEnter | (Inherited from UIElement.)
Public event | TouchLeave | (Inherited from UIElement.)
Public event | TouchMove | (Inherited from UIElement.)
Public event | TouchUp | (Inherited from UIElement.)
Public event | Unloaded | (Inherited from FrameworkElement.)

See Also

ReloggerGeneralSettingsWindow Class
Relogger.UserControlsAndWindows Namespace


ReloggerGeneralSettingsWindow Constructor

Initializes a new instance of the ReloggerGeneralSettingsWindow class.

Namespace: Relogger.UserControlsAndWindows
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public ReloggerGeneralSettingsWindow()
Public Sub New
public:
ReloggerGeneralSettingsWindow()

See Also

ReloggerGeneralSettingsWindow Class
Relogger.UserControlsAndWindows Namespace


ReloggerGeneralSettingsWindow Methods

The ReloggerGeneralSettingsWindow type exposes the following members.

Methods

 | Name | Description
Public method | Activate | (Inherited from Window.)
Protected method | AddChild(System.Object) | (Inherited from ContentControl.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate,System.Boolean) | (Inherited from UIElement.)
Protected method | AddText(System.String) | (Inherited from ContentControl.)
Public method | AddToEventRoute(System.Windows.EventRoute,System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | AddVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock) | (Inherited from UIElement.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from FrameworkElement.)
Public method | Arrange(System.Windows.Rect) | (Inherited from UIElement.)
Protected method | ArrangeCore(System.Windows.Rect) | (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(System.Windows.Size) | (Inherited from Window.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline) | (Inherited from UIElement.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | BeginInit | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior,System.Boolean) | (Inherited from FrameworkElement.)
Public method | BringIntoView | (Inherited from FrameworkElement.)
Public method | BringIntoView(System.Windows.Rect) | (Inherited from FrameworkElement.)
Public method | CaptureMouse | (Inherited from UIElement.)
Public method | CaptureStylus | (Inherited from UIElement.)
Public method | CaptureTouch(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DispatcherObject.)
Public method | ClearValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | ClearValue(System.Windows.DependencyPropertyKey) | (Inherited from DependencyObject.)
Public method | Close | (Inherited from Window.)
Public method | CoerceValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | DragMove | (Inherited from Window.)
Public method | EndInit | (Inherited from FrameworkElement.)
Public method | Equals(System.Object) | (Inherited from DependencyObject.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindCommonVisualAncestor(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | FindName(System.String) | (Inherited from FrameworkElement.)
Public method | FindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from UIElement.)
Public method | GetAnimationBaseValue(System.Windows.DependencyProperty) | (Inherited from UIElement.)
Public method | GetBindingExpression(System.Windows.DependencyProperty) | (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from DependencyObject.)
Protected method | GetLayoutClip(System.Windows.Size) | (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | (Inherited from DependencyObject.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Protected method | GetVisualChild(System.Int32) | (Inherited from FrameworkElement.)
Public method | Hide | (Inherited from Window.)
Protected method | HitTestCore(System.Windows.Media.PointHitTestParameters) | (Inherited from UIElement.)
Protected method | HitTestCore(System.Windows.Media.GeometryHitTestParameters) | (Inherited from UIElement.)
Public method | InputHitTest(System.Windows.Point) | (Inherited from UIElement.)
Public method | InvalidateArrange | (Inherited from UIElement.)
Public method | InvalidateMeasure | (Inherited from UIElement.)
Public method | InvalidateProperty(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | InvalidateVisual | (Inherited from UIElement.)
Public method | IsAncestorOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | IsDescendantOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | Measure(System.Windows.Size) | (Inherited from UIElement.)
Protected method | MeasureCore(System.Windows.Size) | (Inherited from FrameworkElement.)
Protected method | MeasureOverride(System.Windows.Size) | (Inherited from Window.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | MoveFocus(System.Windows.Input.TraversalRequest) | (Inherited from FrameworkElement.)
Protected method | OnAccessKey(System.Windows.Input.AccessKeyEventArgs) | (Inherited from UIElement.)
Protected method | OnActivated(System.EventArgs) | (Inherited from Window.)
Public method | OnApplyTemplate | (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged(System.Windows.UIElement) | (Inherited from UIElement.)
Protected method | OnClosed(System.EventArgs) | (Inherited from Window.)
Protected method | OnClosing(System.ComponentModel.CancelEventArgs) | (Inherited from Window.)
Protected method | OnContentChanged(System.Object,System.Object) | (Inherited from Window.)
Protected method | OnContentRendered(System.EventArgs) | (Inherited from Window.)
Protected method | OnContentStringFormatChanged(System.String,System.String) | (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged(System.Windows.DataTemplate,System.Windows.DataTemplate) | (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged(System.Windows.Controls.DataTemplateSelector,System.Windows.Controls.DataTemplateSelector) | (Inherited from ContentControl.)
Protected method | OnContextMenuClosing(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | (Inherited from Window.)
Protected method | OnDeactivated(System.EventArgs) | (Inherited from Window.)
Protected method | OnDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnGotFocus(System.Windows.RoutedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnGotMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnGotStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnGotTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnInitialized(System.EventArgs) | (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Window.)
Protected method | OnLostFocus(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnLostStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnLostTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback(System.Windows.Input.ManipulationBoundaryFeedbackEventArgs) | (Inherited from Window.)
Protected method | OnManipulationCompleted(System.Windows.Input.ManipulationCompletedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationDelta(System.Windows.Input.ManipulationDeltaEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting(System.Windows.Input.ManipulationInertiaStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarted(System.Windows.Input.ManipulationStartedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarting(System.Windows.Input.ManipulationStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseEnter(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeave(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnPreviewMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPropertyChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnQueryCursor(System.Windows.Input.QueryCursorEventArgs) | (Inherited from UIElement.)
Protected method | OnRender(System.Windows.Media.DrawingContext) | (Inherited from UIElement.)
Protected method | OnSourceInitialized(System.EventArgs) | (Inherited from Window.)
Protected method | OnStateChanged(System.EventArgs) | (Inherited from Window.)
Protected method | OnStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusEnter(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusLeave(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnTemplateChanged(System.Windows.Controls.ControlTemplate,System.Windows.Controls.ControlTemplate) | (Inherited from Control.)
Protected method | OnTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnToolTipClosing(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchEnter(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchLeave(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Public method | PointFromScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PointToScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PredictFocus(System.Windows.Input.FocusNavigationDirection) | (Inherited from FrameworkElement.)
Public method | RaiseEvent(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Public method | ReadLocalValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | RegisterName(System.String,System.Object) | (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | (Inherited from UIElement.)
Public method | ReleaseMouseCapture | (Inherited from UIElement.)
Public method | ReleaseStylusCapture | (Inherited from UIElement.)
Public method | ReleaseTouchCapture(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | RemoveHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Protected method | RemoveVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | SetBinding(System.Windows.DependencyProperty,System.Windows.Data.BindingBase) | (Inherited from FrameworkElement.)
Public method | SetBinding(System.Windows.DependencyProperty,System.String) | (Inherited from FrameworkElement.)
Public method | SetCurrentValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetResourceReference(System.Windows.DependencyProperty,System.Object) | (Inherited from FrameworkElement.)
Public method | SetValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetValue(System.Windows.DependencyPropertyKey,System.Object) | (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | (Inherited from UIElement.)
Public method | ShouldSerializeContent | (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | (Inherited from UIElement.)
Public method | ShouldSerializeResources | (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | (Inherited from FrameworkElement.)
Public method | Show | (Inherited from Window.)
Public method | ShowDialog | (Inherited from Window.)
Public method | ToString | (Inherited from Control.)
Public method | TransformToAncestor(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToAncestor(System.Windows.Media.Media3D.Visual3D) | (Inherited from Visual.)
Public method | TransformToDescendant(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToVisual(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TranslatePoint(System.Windows.Point,System.Windows.UIElement) | (Inherited from UIElement.)
Public method | TryFindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | UnregisterName(System.String) | (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | (Inherited from FrameworkElement.)
Public method | UpdateLayout | (Inherited from UIElement.)
Public method | VerifyAccess | (Inherited from DispatcherObject.)

See Also

ReloggerGeneralSettingsWindow Class
Relogger.UserControlsAndWindows Namespace


ReloggerGeneralSettingsWindow Properties

The ReloggerGeneralSettingsWindow type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | (Inherited from FrameworkElement.)
Public property | ActualWidth | (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from UIElement.)
Public property | AllowsTransparency | (Inherited from Window.)
Public property | AreAnyTouchesCaptured | (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
Public property | AreAnyTouchesOver | (Inherited from UIElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from FrameworkElement.)
Public property | BitmapEffect | (Inherited from UIElement.)
Public property | BitmapEffectInput | (Inherited from UIElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | (Inherited from UIElement.)
Public property | ClipToBounds | (Inherited from UIElement.)
Public property | CommandBindings | (Inherited from UIElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContentTemplate | (Inherited from ContentControl.)
Public property | ContentTemplateSelector | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from FrameworkElement.)
Public property | Cursor | (Inherited from FrameworkElement.)
Public property | DataContext | (Inherited from FrameworkElement.)
Public property | DependencyObjectType | (Inherited from DependencyObject.)
Public property | DesiredSize | (Inherited from UIElement.)
Public property | DialogResult | (Inherited from Window.)
Public property | Dispatcher | (Inherited from DispatcherObject.)
Public property | Effect | (Inherited from UIElement.)
Public property | FlowDirection | (Inherited from FrameworkElement.)
Public property | Focusable | (Inherited from UIElement.)
Public property | FocusVisualStyle | (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from FrameworkElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasAnimatedProperties | (Inherited from UIElement.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Icon | (Inherited from Window.)
Public property | InputBindings | (Inherited from UIElement.)
Public property | InputScope | (Inherited from FrameworkElement.)
Public property | IsActive | (Inherited from Window.)
Public property | IsArrangeValid | (Inherited from UIElement.)
Public property | IsEnabled | (Inherited from UIElement.)
Protected property | IsEnabledCore | (Inherited from UIElement.)
Public property | IsFocused | (Inherited from UIElement.)
Public property | IsHitTestVisible | (Inherited from UIElement.)
Public property | IsInitialized | (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | (Inherited from UIElement.)
Public property | IsKeyboardFocused | (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | (Inherited from UIElement.)
Public property | IsLoaded | (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | (Inherited from UIElement.)
Public property | IsMeasureValid | (Inherited from UIElement.)
Public property | IsMouseCaptured | (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | (Inherited from UIElement.)
Public property | IsMouseOver | (Inherited from UIElement.)
Public property | IsSealed | (Inherited from DependencyObject.)
Public property | IsStylusCaptured | (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | (Inherited from UIElement.)
Public property | IsStylusOver | (Inherited from UIElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsVisible | (Inherited from UIElement.)
Public property | Language | (Inherited from FrameworkElement.)
Public property | LayoutTransform | (Inherited from FrameworkElement.)
Public property | Left | (Inherited from Window.)
Public property | Margin | (Inherited from FrameworkElement.)
Public property | MaxHeight | (Inherited from FrameworkElement.)
Public property | MaxWidth | (Inherited from FrameworkElement.)
Public property | MinHeight | (Inherited from FrameworkElement.)
Public property | MinWidth | (Inherited from FrameworkElement.)
Public property | Name | (Inherited from FrameworkElement.)
Public property | Opacity | (Inherited from UIElement.)
Public property | OpacityMask | (Inherited from UIElement.)
Public property | OverridesDefaultStyle | (Inherited from FrameworkElement.)
Public property | OwnedWindows | (Inherited from Window.)
Public property | Owner | (Inherited from Window.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from FrameworkElement.)
Public property | PersistId | (Inherited from UIElement.)
Public property | RenderSize | (Inherited from UIElement.)
Public property | RenderTransform | (Inherited from UIElement.)
Public property | RenderTransformOrigin | (Inherited from UIElement.)
Public property | ResizeMode | (Inherited from Window.)
Public property | Resources | (Inherited from FrameworkElement.)
Public property | RestoreBounds | (Inherited from Window.)
Public property | ShowActivated | (Inherited from Window.)
Public property | ShowInTaskbar | (Inherited from Window.)
Public property | SizeToContent | (Inherited from Window.)
Public property | SnapsToDevicePixels | (Inherited from UIElement.)
Public property | Style | (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | (Inherited from UIElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | Tag | (Inherited from FrameworkElement.)
Public property | TaskbarItemInfo | (Inherited from Window.)
Public property | Template | (Inherited from Control.)
Public property | TemplatedParent | (Inherited from FrameworkElement.)
Public property | Title | (Inherited from Window.)
Public property | ToolTip | (Inherited from FrameworkElement.)
Public property | Top | (Inherited from Window.)
Public property | Topmost | (Inherited from Window.)
Public property | TouchesCaptured | (Inherited from UIElement.)
Public property | TouchesCapturedWithin | (Inherited from UIElement.)
Public property | TouchesDirectlyOver | (Inherited from UIElement.)
Public property | TouchesOver | (Inherited from UIElement.)
Public property | Triggers | (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from UIElement.)
Public property | UseLayoutRounding | (Inherited from FrameworkElement.)
Public property | VerticalAlignment | (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | (Inherited from UIElement.)
Protected property | VisualChildrenCount | (Inherited from FrameworkElement.)
Protected property | VisualParent | (Inherited from Visual.)
Public property | Width | (Inherited from FrameworkElement.)
Public property | WindowStartupLocation | (Inherited from Window.)
Public property | WindowState | (Inherited from Window.)
Public property | WindowStyle | (Inherited from Window.)

See Also

ReloggerGeneralSettingsWindow Class
Relogger.UserControlsAndWindows Namespace


ReloggerGeneralSettingsWindow Events

The ReloggerGeneralSettingsWindow type exposes the following members.

Events

 | Name | Description
Public event | Activated | (Inherited from Window.)
Public event | Closed | (Inherited from Window.)
Public event | Closing | (Inherited from Window.)
Public event | ContentRendered | (Inherited from Window.)
Public event | ContextMenuClosing | (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | (Inherited from FrameworkElement.)
Public event | DataContextChanged | (Inherited from FrameworkElement.)
Public event | Deactivated | (Inherited from Window.)
Public event | DragEnter | (Inherited from UIElement.)
Public event | DragLeave | (Inherited from UIElement.)
Public event | DragOver | (Inherited from UIElement.)
Public event | Drop | (Inherited from UIElement.)
Public event | FocusableChanged | (Inherited from UIElement.)
Public event | GiveFeedback | (Inherited from UIElement.)
Public event | GotFocus | (Inherited from UIElement.)
Public event | GotKeyboardFocus | (Inherited from UIElement.)
Public event | GotMouseCapture | (Inherited from UIElement.)
Public event | GotStylusCapture | (Inherited from UIElement.)
Public event | GotTouchCapture | (Inherited from UIElement.)
Public event | Initialized | (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsVisibleChanged | (Inherited from UIElement.)
Public event | KeyDown | (Inherited from UIElement.)
Public event | KeyUp | (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from UIElement.)
Public event | Loaded | (Inherited from FrameworkElement.)
Public event | LocationChanged | (Inherited from Window.)
Public event | LostFocus | (Inherited from UIElement.)
Public event | LostKeyboardFocus | (Inherited from UIElement.)
Public event | LostMouseCapture | (Inherited from UIElement.)
Public event | LostStylusCapture | (Inherited from UIElement.)
Public event | LostTouchCapture | (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | ManipulationStarting | (Inherited from UIElement.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from UIElement.)
Public event | MouseEnter | (Inherited from UIElement.)
Public event | MouseLeave | (Inherited from UIElement.)
Public event | MouseLeftButtonDown | (Inherited from UIElement.)
Public event | MouseLeftButtonUp | (Inherited from UIElement.)
Public event | MouseMove | (Inherited from UIElement.)
Public event | MouseRightButtonDown | (Inherited from UIElement.)
Public event | MouseRightButtonUp | (Inherited from UIElement.)
Public event | MouseUp | (Inherited from UIElement.)
Public event | MouseWheel | (Inherited from UIElement.)
Public event | PreviewDragEnter | (Inherited from UIElement.)
Public event | PreviewDragLeave | (Inherited from UIElement.)
Public event | PreviewDragOver | (Inherited from UIElement.)
Public event | PreviewDrop | (Inherited from UIElement.)
Public event | PreviewGiveFeedback | (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewKeyDown | (Inherited from UIElement.)
Public event | PreviewKeyUp | (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | (Inherited from Control.)
Public event | PreviewMouseDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseMove | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseUp | (Inherited from UIElement.)
Public event | PreviewMouseWheel | (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | (Inherited from UIElement.)
Public event | PreviewStylusDown | (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | (Inherited from UIElement.)
Public event | PreviewStylusInRange | (Inherited from UIElement.)
Public event | PreviewStylusMove | (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | (Inherited from UIElement.)
Public event | PreviewStylusUp | (Inherited from UIElement.)
Public event | PreviewTextInput | (Inherited from UIElement.)
Public event | PreviewTouchDown | (Inherited from UIElement.)
Public event | PreviewTouchMove | (Inherited from UIElement.)
Public event | PreviewTouchUp | (Inherited from UIElement.)
Public event | QueryContinueDrag | (Inherited from UIElement.)
Public event | QueryCursor | (Inherited from UIElement.)
Public event | RequestBringIntoView | (Inherited from FrameworkElement.)
Public event | SizeChanged | (Inherited from FrameworkElement.)
Public event | SourceInitialized | (Inherited from Window.)
Public event | SourceUpdated | (Inherited from FrameworkElement.)
Public event | StateChanged | (Inherited from Window.)
Public event | StylusButtonDown | (Inherited from UIElement.)
Public event | StylusButtonUp | (Inherited from UIElement.)
Public event | StylusDown | (Inherited from UIElement.)
Public event | StylusEnter | (Inherited from UIElement.)
Public event | StylusInAirMove | (Inherited from UIElement.)
Public event | StylusInRange | (Inherited from UIElement.)
Public event | StylusLeave | (Inherited from UIElement.)
Public event | StylusMove | (Inherited from UIElement.)
Public event | StylusOutOfRange | (Inherited from UIElement.)
Public event | StylusSystemGesture | (Inherited from UIElement.)
Public event | StylusUp | (Inherited from UIElement.)
Public event | TargetUpdated | (Inherited from FrameworkElement.)
Public event | TextInput | (Inherited from UIElement.)
Public event | ToolTipClosing | (Inherited from FrameworkElement.)
Public event | ToolTipOpening | (Inherited from FrameworkElement.)
Public event | TouchDown | (Inherited from UIElement.)
Public event | TouchEnter | (Inherited from UIElement.)
Public event | TouchLeave | (Inherited from UIElement.)
Public event | TouchMove | (Inherited from UIElement.)
Public event | TouchUp | (Inherited from UIElement.)
Public event | Unloaded | (Inherited from FrameworkElement.)

See Also

ReloggerGeneralSettingsWindow Class
Relogger.UserControlsAndWindows Namespace


ReloggerProfileSettingsUserControl Class

Logique d'interaction pour ReloggerProfileSettingsUserControl.xaml

Namespace: Relogger.UserControlsAndWindows
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public class ReloggerProfileSettingsUserControl : UserControl
Public Class ReloggerProfileSettingsUserControl _
    Inherits UserControl
public ref class ReloggerProfileSettingsUserControl : public UserControl

Inheritance Hierarchy

Object
DispatcherObject
DependencyObject
Visual
UIElement
FrameworkElement
Control
ContentControl
UserControl
Relogger.UserControlsAndWindows..::..ReloggerProfileSettingsUserControl

See Also

ReloggerProfileSettingsUserControl Members
Relogger.UserControlsAndWindows Namespace


ReloggerProfileSettingsUserControl Members

The ReloggerProfileSettingsUserControl type exposes the following members.

Constructors

 | Name | Description
Public method | ReloggerProfileSettingsUserControl | Initializes a new instance of the ReloggerProfileSettingsUserControl class.

Methods

 | Name | Description
Protected method | AddChild(System.Object) | (Inherited from ContentControl.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate,System.Boolean) | (Inherited from UIElement.)
Protected method | AddText(System.String) | (Inherited from ContentControl.)
Public method | AddToEventRoute(System.Windows.EventRoute,System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | AddVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock) | (Inherited from UIElement.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from FrameworkElement.)
Public method | Arrange(System.Windows.Rect) | (Inherited from UIElement.)
Protected method | ArrangeCore(System.Windows.Rect) | (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(System.Windows.Size) | (Inherited from Control.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline) | (Inherited from UIElement.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | BeginInit | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior,System.Boolean) | (Inherited from FrameworkElement.)
Public method | BringIntoView | (Inherited from FrameworkElement.)
Public method | BringIntoView(System.Windows.Rect) | (Inherited from FrameworkElement.)
Public method | CaptureMouse | (Inherited from UIElement.)
Public method | CaptureStylus | (Inherited from UIElement.)
Public method | CaptureTouch(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DispatcherObject.)
Public method | ClearValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | ClearValue(System.Windows.DependencyPropertyKey) | (Inherited from DependencyObject.)
Public method | CoerceValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | EndInit | (Inherited from FrameworkElement.)
Public method | Equals(System.Object) | (Inherited from DependencyObject.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindCommonVisualAncestor(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | FindName(System.String) | (Inherited from FrameworkElement.)
Public method | FindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from UIElement.)
Public method | GetAnimationBaseValue(System.Windows.DependencyProperty) | (Inherited from UIElement.)
Public method | GetBindingExpression(System.Windows.DependencyProperty) | (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from DependencyObject.)
Protected method | GetLayoutClip(System.Windows.Size) | (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | (Inherited from DependencyObject.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Protected method | GetVisualChild(System.Int32) | (Inherited from FrameworkElement.)
Protected method | HitTestCore(System.Windows.Media.PointHitTestParameters) | (Inherited from UIElement.)
Protected method | HitTestCore(System.Windows.Media.GeometryHitTestParameters) | (Inherited from UIElement.)
Public method | InputHitTest(System.Windows.Point) | (Inherited from UIElement.)
Public method | InvalidateArrange | (Inherited from UIElement.)
Public method | InvalidateMeasure | (Inherited from UIElement.)
Public method | InvalidateProperty(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | InvalidateVisual | (Inherited from UIElement.)
Public method | IsAncestorOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | IsDescendantOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | Measure(System.Windows.Size) | (Inherited from UIElement.)
Protected method | MeasureCore(System.Windows.Size) | (Inherited from FrameworkElement.)
Protected method | MeasureOverride(System.Windows.Size) | (Inherited from Control.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | MoveFocus(System.Windows.Input.TraversalRequest) | (Inherited from FrameworkElement.)
Protected method | OnAccessKey(System.Windows.Input.AccessKeyEventArgs) | (Inherited from UIElement.)
Public method | OnApplyTemplate | (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged(System.Windows.UIElement) | (Inherited from UIElement.)
Protected method | OnContentChanged(System.Object,System.Object) | (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged(System.String,System.String) | (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged(System.Windows.DataTemplate,System.Windows.DataTemplate) | (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged(System.Windows.Controls.DataTemplateSelector,System.Windows.Controls.DataTemplateSelector) | (Inherited from ContentControl.)
Protected method | OnContextMenuClosing(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | (Inherited from UserControl.)
Protected method | OnDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnGotFocus(System.Windows.RoutedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnGotMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnGotStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnGotTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnInitialized(System.EventArgs) | (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnLostFocus(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnLostStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnLostTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback(System.Windows.Input.ManipulationBoundaryFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationCompleted(System.Windows.Input.ManipulationCompletedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationDelta(System.Windows.Input.ManipulationDeltaEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting(System.Windows.Input.ManipulationInertiaStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarted(System.Windows.Input.ManipulationStartedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarting(System.Windows.Input.ManipulationStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseEnter(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeave(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnPreviewMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPropertyChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnQueryCursor(System.Windows.Input.QueryCursorEventArgs) | (Inherited from UIElement.)
Protected method | OnRender(System.Windows.Media.DrawingContext) | (Inherited from UIElement.)
Protected method | OnStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusEnter(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusLeave(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnTemplateChanged(System.Windows.Controls.ControlTemplate,System.Windows.Controls.ControlTemplate) | (Inherited from Control.)
Protected method | OnTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnToolTipClosing(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchEnter(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchLeave(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Public method | PointFromScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PointToScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PredictFocus(System.Windows.Input.FocusNavigationDirection) | (Inherited from FrameworkElement.)
Public method | RaiseEvent(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Public method | ReadLocalValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | RegisterName(System.String,System.Object) | (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | (Inherited from UIElement.)
Public method | ReleaseMouseCapture | (Inherited from UIElement.)
Public method | ReleaseStylusCapture | (Inherited from UIElement.)
Public method | ReleaseTouchCapture(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | RemoveHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Protected method | RemoveVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | SetBinding(System.Windows.DependencyProperty,System.Windows.Data.BindingBase) | (Inherited from FrameworkElement.)
Public method | SetBinding(System.Windows.DependencyProperty,System.String) | (Inherited from FrameworkElement.)
Public method | SetCurrentValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetResourceReference(System.Windows.DependencyProperty,System.Object) | (Inherited from FrameworkElement.)
Public method | SetValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetValue(System.Windows.DependencyPropertyKey,System.Object) | (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | (Inherited from UIElement.)
Public method | ShouldSerializeContent | (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | (Inherited from UIElement.)
Public method | ShouldSerializeResources | (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | (Inherited from FrameworkElement.)
Public method | ToString | (Inherited from Control.)
Public method | TransformToAncestor(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToAncestor(System.Windows.Media.Media3D.Visual3D) | (Inherited from Visual.)
Public method | TransformToDescendant(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToVisual(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TranslatePoint(System.Windows.Point,System.Windows.UIElement) | (Inherited from UIElement.)
Public method | TryFindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | UnregisterName(System.String) | (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | (Inherited from FrameworkElement.)
Public method | UpdateLayout | (Inherited from UIElement.)
Public method | VerifyAccess | (Inherited from DispatcherObject.)

Properties

 | Name | Description
Public property | ActualHeight | (Inherited from FrameworkElement.)
Public property | ActualWidth | (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
Public property | AreAnyTouchesOver | (Inherited from UIElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from FrameworkElement.)
Public property | BitmapEffect | (Inherited from UIElement.)
Public property | BitmapEffectInput | (Inherited from UIElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | (Inherited from UIElement.)
Public property | ClipToBounds | (Inherited from UIElement.)
Public property | CommandBindings | (Inherited from UIElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContentTemplate | (Inherited from ContentControl.)
Public property | ContentTemplateSelector | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from FrameworkElement.)
Public property | Cursor | (Inherited from FrameworkElement.)
Public property | DataContext | (Inherited from FrameworkElement.)
Public property | DependencyObjectType | (Inherited from DependencyObject.)
Public property | DesiredSize | (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DispatcherObject.)
Public property | Effect | (Inherited from UIElement.)
Public property | FlowDirection | (Inherited from FrameworkElement.)
Public property | Focusable | (Inherited from UIElement.)
Public property | FocusVisualStyle | (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from FrameworkElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasAnimatedProperties | (Inherited from UIElement.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | InputBindings | (Inherited from UIElement.)
Public property | InputScope | (Inherited from FrameworkElement.)
Public property | IsArrangeValid | (Inherited from UIElement.)
Public property | IsEnabled | (Inherited from UIElement.)
Protected property | IsEnabledCore | (Inherited from UIElement.)
Public property | IsFocused | (Inherited from UIElement.)
Public property | IsHitTestVisible | (Inherited from UIElement.)
Public property | IsInitialized | (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | (Inherited from UIElement.)
Public property | IsKeyboardFocused | (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | (Inherited from UIElement.)
Public property | IsLoaded | (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | (Inherited from UIElement.)
Public property | IsMeasureValid | (Inherited from UIElement.)
Public property | IsMouseCaptured | (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | (Inherited from UIElement.)
Public property | IsMouseOver | (Inherited from UIElement.)
Public property | IsSealed | (Inherited from DependencyObject.)
Public property | IsStylusCaptured | (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | (Inherited from UIElement.)
Public property | IsStylusOver | (Inherited from UIElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsVisible | (Inherited from UIElement.)
Public property | Language | (Inherited from FrameworkElement.)
Public property | LayoutTransform | (Inherited from FrameworkElement.)
Public property | Margin | (Inherited from FrameworkElement.)
Public property | MaxHeight | (Inherited from FrameworkElement.)
Public property | MaxWidth | (Inherited from FrameworkElement.)
Public property | MinHeight | (Inherited from FrameworkElement.)
Public property | MinWidth | (Inherited from FrameworkElement.)
Public property | Name | (Inherited from FrameworkElement.)
Public property | Opacity | (Inherited from UIElement.)
Public property | OpacityMask | (Inherited from UIElement.)
Public property | OverridesDefaultStyle | (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from FrameworkElement.)
Public property | PersistId | (Inherited from UIElement.)
Public property | RenderSize | (Inherited from UIElement.)
Public property | RenderTransform | (Inherited from UIElement.)
Public property | RenderTransformOrigin | (Inherited from UIElement.)
Public property | Resources | (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from UIElement.)
Public property | Style | (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | (Inherited from UIElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | Tag | (Inherited from FrameworkElement.)
Public property | Template | (Inherited from Control.)
Public property | TemplatedParent | (Inherited from FrameworkElement.)
Public property | ToolTip | (Inherited from FrameworkElement.)
Public property | TouchesCaptured | (Inherited from UIElement.)
Public property | TouchesCapturedWithin | (Inherited from UIElement.)
Public property | TouchesDirectlyOver | (Inherited from UIElement.)
Public property | TouchesOver | (Inherited from UIElement.)
Public property | Triggers | (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from UIElement.)
Public property | UseLayoutRounding | (Inherited from FrameworkElement.)
Public property | VerticalAlignment | (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | (Inherited from UIElement.)
Protected property | VisualChildrenCount | (Inherited from FrameworkElement.)
Protected property | VisualParent | (Inherited from Visual.)
Public property | Width | (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | ContextMenuClosing | (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | (Inherited from FrameworkElement.)
Public event | DataContextChanged | (Inherited from FrameworkElement.)
Public event | DragEnter | (Inherited from UIElement.)
Public event | DragLeave | (Inherited from UIElement.)
Public event | DragOver | (Inherited from UIElement.)
Public event | Drop | (Inherited from UIElement.)
Public event | FocusableChanged | (Inherited from UIElement.)
Public event | GiveFeedback | (Inherited from UIElement.)
Public event | GotFocus | (Inherited from UIElement.)
Public event | GotKeyboardFocus | (Inherited from UIElement.)
Public event | GotMouseCapture | (Inherited from UIElement.)
Public event | GotStylusCapture | (Inherited from UIElement.)
Public event | GotTouchCapture | (Inherited from UIElement.)
Public event | Initialized | (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsVisibleChanged | (Inherited from UIElement.)
Public event | KeyDown | (Inherited from UIElement.)
Public event | KeyUp | (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from UIElement.)
Public event | Loaded | (Inherited from FrameworkElement.)
Public event | LostFocus | (Inherited from UIElement.)
Public event | LostKeyboardFocus | (Inherited from UIElement.)
Public event | LostMouseCapture | (Inherited from UIElement.)
Public event | LostStylusCapture | (Inherited from UIElement.)
Public event | LostTouchCapture | (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | ManipulationStarting | (Inherited from UIElement.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from UIElement.)
Public event | MouseEnter | (Inherited from UIElement.)
Public event | MouseLeave | (Inherited from UIElement.)
Public event | MouseLeftButtonDown | (Inherited from UIElement.)
Public event | MouseLeftButtonUp | (Inherited from UIElement.)
Public event | MouseMove | (Inherited from UIElement.)
Public event | MouseRightButtonDown | (Inherited from UIElement.)
Public event | MouseRightButtonUp | (Inherited from UIElement.)
Public event | MouseUp | (Inherited from UIElement.)
Public event | MouseWheel | (Inherited from UIElement.)
Public event | PreviewDragEnter | (Inherited from UIElement.)
Public event | PreviewDragLeave | (Inherited from UIElement.)
Public event | PreviewDragOver | (Inherited from UIElement.)
Public event | PreviewDrop | (Inherited from UIElement.)
Public event | PreviewGiveFeedback | (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewKeyDown | (Inherited from UIElement.)
Public event | PreviewKeyUp | (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | (Inherited from Control.)
Public event | PreviewMouseDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseMove | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseUp | (Inherited from UIElement.)
Public event | PreviewMouseWheel | (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | (Inherited from UIElement.)
Public event | PreviewStylusDown | (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | (Inherited from UIElement.)
Public event | PreviewStylusInRange | (Inherited from UIElement.)
Public event | PreviewStylusMove | (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | (Inherited from UIElement.)
Public event | PreviewStylusUp | (Inherited from UIElement.)
Public event | PreviewTextInput | (Inherited from UIElement.)
Public event | PreviewTouchDown | (Inherited from UIElement.)
Public event | PreviewTouchMove | (Inherited from UIElement.)
Public event | PreviewTouchUp | (Inherited from UIElement.)
Public event | QueryContinueDrag | (Inherited from UIElement.)
Public event | QueryCursor | (Inherited from UIElement.)
Public event | RequestBringIntoView | (Inherited from FrameworkElement.)
Public event | SizeChanged | (Inherited from FrameworkElement.)
Public event | SourceUpdated | (Inherited from FrameworkElement.)
Public event | StylusButtonDown | (Inherited from UIElement.)
Public event | StylusButtonUp | (Inherited from UIElement.)
Public event | StylusDown | (Inherited from UIElement.)
Public event | StylusEnter | (Inherited from UIElement.)
Public event | StylusInAirMove | (Inherited from UIElement.)
Public event | StylusInRange | (Inherited from UIElement.)
Public event | StylusLeave | (Inherited from UIElement.)
Public event | StylusMove | (Inherited from UIElement.)
Public event | StylusOutOfRange | (Inherited from UIElement.)
Public event | StylusSystemGesture | (Inherited from UIElement.)
Public event | StylusUp | (Inherited from UIElement.)
Public event | TargetUpdated | (Inherited from FrameworkElement.)
Public event | TextInput | (Inherited from UIElement.)
Public event | ToolTipClosing | (Inherited from FrameworkElement.)
Public event | ToolTipOpening | (Inherited from FrameworkElement.)
Public event | TouchDown | (Inherited from UIElement.)
Public event | TouchEnter | (Inherited from UIElement.)
Public event | TouchLeave | (Inherited from UIElement.)
Public event | TouchMove | (Inherited from UIElement.)
Public event | TouchUp | (Inherited from UIElement.)
Public event | Unloaded | (Inherited from FrameworkElement.)

See Also

ReloggerProfileSettingsUserControl Class
Relogger.UserControlsAndWindows Namespace


ReloggerProfileSettingsUserControl Constructor

Initializes a new instance of the ReloggerProfileSettingsUserControl class.

Namespace: Relogger.UserControlsAndWindows
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public ReloggerProfileSettingsUserControl()
Public Sub New
public:
ReloggerProfileSettingsUserControl()

See Also

ReloggerProfileSettingsUserControl Class
Relogger.UserControlsAndWindows Namespace


ReloggerProfileSettingsUserControl Methods

The ReloggerProfileSettingsUserControl type exposes the following members.

Methods

 | Name | Description
Protected method | AddChild(System.Object) | (Inherited from ContentControl.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate,System.Boolean) | (Inherited from UIElement.)
Protected method | AddText(System.String) | (Inherited from ContentControl.)
Public method | AddToEventRoute(System.Windows.EventRoute,System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | AddVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock) | (Inherited from UIElement.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from FrameworkElement.)
Public method | Arrange(System.Windows.Rect) | (Inherited from UIElement.)
Protected method | ArrangeCore(System.Windows.Rect) | (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(System.Windows.Size) | (Inherited from Control.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline) | (Inherited from UIElement.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | BeginInit | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior,System.Boolean) | (Inherited from FrameworkElement.)
Public method | BringIntoView | (Inherited from FrameworkElement.)
Public method | BringIntoView(System.Windows.Rect) | (Inherited from FrameworkElement.)
Public method | CaptureMouse | (Inherited from UIElement.)
Public method | CaptureStylus | (Inherited from UIElement.)
Public method | CaptureTouch(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DispatcherObject.)
Public method | ClearValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | ClearValue(System.Windows.DependencyPropertyKey) | (Inherited from DependencyObject.)
Public method | CoerceValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | EndInit | (Inherited from FrameworkElement.)
Public method | Equals(System.Object) | (Inherited from DependencyObject.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindCommonVisualAncestor(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | FindName(System.String) | (Inherited from FrameworkElement.)
Public method | FindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from UIElement.)
Public method | GetAnimationBaseValue(System.Windows.DependencyProperty) | (Inherited from UIElement.)
Public method | GetBindingExpression(System.Windows.DependencyProperty) | (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from DependencyObject.)
Protected method | GetLayoutClip(System.Windows.Size) | (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | (Inherited from DependencyObject.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Protected method | GetVisualChild(System.Int32) | (Inherited from FrameworkElement.)
Protected method | HitTestCore(System.Windows.Media.PointHitTestParameters) | (Inherited from UIElement.)
Protected method | HitTestCore(System.Windows.Media.GeometryHitTestParameters) | (Inherited from UIElement.)
Public method | InputHitTest(System.Windows.Point) | (Inherited from UIElement.)
Public method | InvalidateArrange | (Inherited from UIElement.)
Public method | InvalidateMeasure | (Inherited from UIElement.)
Public method | InvalidateProperty(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | InvalidateVisual | (Inherited from UIElement.)
Public method | IsAncestorOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | IsDescendantOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | Measure(System.Windows.Size) | (Inherited from UIElement.)
Protected method | MeasureCore(System.Windows.Size) | (Inherited from FrameworkElement.)
Protected method | MeasureOverride(System.Windows.Size) | (Inherited from Control.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | MoveFocus(System.Windows.Input.TraversalRequest) | (Inherited from FrameworkElement.)
Protected method | OnAccessKey(System.Windows.Input.AccessKeyEventArgs) | (Inherited from UIElement.)
Public method | OnApplyTemplate | (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged(System.Windows.UIElement) | (Inherited from UIElement.)
Protected method | OnContentChanged(System.Object,System.Object) | (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged(System.String,System.String) | (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged(System.Windows.DataTemplate,System.Windows.DataTemplate) | (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged(System.Windows.Controls.DataTemplateSelector,System.Windows.Controls.DataTemplateSelector) | (Inherited from ContentControl.)
Protected method | OnContextMenuClosing(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | (Inherited from UserControl.)
Protected method | OnDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnGotFocus(System.Windows.RoutedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnGotMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnGotStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnGotTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnInitialized(System.EventArgs) | (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnLostFocus(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnLostStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnLostTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback(System.Windows.Input.ManipulationBoundaryFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationCompleted(System.Windows.Input.ManipulationCompletedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationDelta(System.Windows.Input.ManipulationDeltaEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting(System.Windows.Input.ManipulationInertiaStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarted(System.Windows.Input.ManipulationStartedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarting(System.Windows.Input.ManipulationStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseEnter(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeave(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnPreviewMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPropertyChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnQueryCursor(System.Windows.Input.QueryCursorEventArgs) | (Inherited from UIElement.)
Protected method | OnRender(System.Windows.Media.DrawingContext) | (Inherited from UIElement.)
Protected method | OnStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusEnter(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusLeave(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnTemplateChanged(System.Windows.Controls.ControlTemplate,System.Windows.Controls.ControlTemplate) | (Inherited from Control.)
Protected method | OnTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnToolTipClosing(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchEnter(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchLeave(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Public method | PointFromScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PointToScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PredictFocus(System.Windows.Input.FocusNavigationDirection) | (Inherited from FrameworkElement.)
Public method | RaiseEvent(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Public method | ReadLocalValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | RegisterName(System.String,System.Object) | (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | (Inherited from UIElement.)
Public method | ReleaseMouseCapture | (Inherited from UIElement.)
Public method | ReleaseStylusCapture | (Inherited from UIElement.)
Public method | ReleaseTouchCapture(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | RemoveHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Protected method | RemoveVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | SetBinding(System.Windows.DependencyProperty,System.Windows.Data.BindingBase) | (Inherited from FrameworkElement.)
Public method | SetBinding(System.Windows.DependencyProperty,System.String) | (Inherited from FrameworkElement.)
Public method | SetCurrentValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetResourceReference(System.Windows.DependencyProperty,System.Object) | (Inherited from FrameworkElement.)
Public method | SetValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetValue(System.Windows.DependencyPropertyKey,System.Object) | (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | (Inherited from UIElement.)
Public method | ShouldSerializeContent | (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | (Inherited from UIElement.)
Public method | ShouldSerializeResources | (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | (Inherited from FrameworkElement.)
Public method | ToString | (Inherited from Control.)
Public method | TransformToAncestor(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToAncestor(System.Windows.Media.Media3D.Visual3D) | (Inherited from Visual.)
Public method | TransformToDescendant(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToVisual(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TranslatePoint(System.Windows.Point,System.Windows.UIElement) | (Inherited from UIElement.)
Public method | TryFindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | UnregisterName(System.String) | (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | (Inherited from FrameworkElement.)
Public method | UpdateLayout | (Inherited from UIElement.)
Public method | VerifyAccess | (Inherited from DispatcherObject.)

See Also

ReloggerProfileSettingsUserControl Class
Relogger.UserControlsAndWindows Namespace


ReloggerProfileSettingsUserControl Properties

The ReloggerProfileSettingsUserControl type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | (Inherited from FrameworkElement.)
Public property | ActualWidth | (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
Public property | AreAnyTouchesOver | (Inherited from UIElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from FrameworkElement.)
Public property | BitmapEffect | (Inherited from UIElement.)
Public property | BitmapEffectInput | (Inherited from UIElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | (Inherited from UIElement.)
Public property | ClipToBounds | (Inherited from UIElement.)
Public property | CommandBindings | (Inherited from UIElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContentTemplate | (Inherited from ContentControl.)
Public property | ContentTemplateSelector | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from FrameworkElement.)
Public property | Cursor | (Inherited from FrameworkElement.)
Public property | DataContext | (Inherited from FrameworkElement.)
Public property | DependencyObjectType | (Inherited from DependencyObject.)
Public property | DesiredSize | (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DispatcherObject.)
Public property | Effect | (Inherited from UIElement.)
Public property | FlowDirection | (Inherited from FrameworkElement.)
Public property | Focusable | (Inherited from UIElement.)
Public property | FocusVisualStyle | (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from FrameworkElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasAnimatedProperties | (Inherited from UIElement.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | InputBindings | (Inherited from UIElement.)
Public property | InputScope | (Inherited from FrameworkElement.)
Public property | IsArrangeValid | (Inherited from UIElement.)
Public property | IsEnabled | (Inherited from UIElement.)
Protected property | IsEnabledCore | (Inherited from UIElement.)
Public property | IsFocused | (Inherited from UIElement.)
Public property | IsHitTestVisible | (Inherited from UIElement.)
Public property | IsInitialized | (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | (Inherited from UIElement.)
Public property | IsKeyboardFocused | (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | (Inherited from UIElement.)
Public property | IsLoaded | (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | (Inherited from UIElement.)
Public property | IsMeasureValid | (Inherited from UIElement.)
Public property | IsMouseCaptured | (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | (Inherited from UIElement.)
Public property | IsMouseOver | (Inherited from UIElement.)
Public property | IsSealed | (Inherited from DependencyObject.)
Public property | IsStylusCaptured | (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | (Inherited from UIElement.)
Public property | IsStylusOver | (Inherited from UIElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsVisible | (Inherited from UIElement.)
Public property | Language | (Inherited from FrameworkElement.)
Public property | LayoutTransform | (Inherited from FrameworkElement.)
Public property | Margin | (Inherited from FrameworkElement.)
Public property | MaxHeight | (Inherited from FrameworkElement.)
Public property | MaxWidth | (Inherited from FrameworkElement.)
Public property | MinHeight | (Inherited from FrameworkElement.)
Public property | MinWidth | (Inherited from FrameworkElement.)
Public property | Name | (Inherited from FrameworkElement.)
Public property | Opacity | (Inherited from UIElement.)
Public property | OpacityMask | (Inherited from UIElement.)
Public property | OverridesDefaultStyle | (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from FrameworkElement.)
Public property | PersistId | (Inherited from UIElement.)
Public property | RenderSize | (Inherited from UIElement.)
Public property | RenderTransform | (Inherited from UIElement.)
Public property | RenderTransformOrigin | (Inherited from UIElement.)
Public property | Resources | (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from UIElement.)
Public property | Style | (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | (Inherited from UIElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | Tag | (Inherited from FrameworkElement.)
Public property | Template | (Inherited from Control.)
Public property | TemplatedParent | (Inherited from FrameworkElement.)
Public property | ToolTip | (Inherited from FrameworkElement.)
Public property | TouchesCaptured | (Inherited from UIElement.)
Public property | TouchesCapturedWithin | (Inherited from UIElement.)
Public property | TouchesDirectlyOver | (Inherited from UIElement.)
Public property | TouchesOver | (Inherited from UIElement.)
Public property | Triggers | (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from UIElement.)
Public property | UseLayoutRounding | (Inherited from FrameworkElement.)
Public property | VerticalAlignment | (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | (Inherited from UIElement.)
Protected property | VisualChildrenCount | (Inherited from FrameworkElement.)
Protected property | VisualParent | (Inherited from Visual.)
Public property | Width | (Inherited from FrameworkElement.)

See Also

ReloggerProfileSettingsUserControl Class
Relogger.UserControlsAndWindows Namespace


ReloggerProfileSettingsUserControl Events

The ReloggerProfileSettingsUserControl type exposes the following members.

Events

 | Name | Description
Public event | ContextMenuClosing | (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | (Inherited from FrameworkElement.)
Public event | DataContextChanged | (Inherited from FrameworkElement.)
Public event | DragEnter | (Inherited from UIElement.)
Public event | DragLeave | (Inherited from UIElement.)
Public event | DragOver | (Inherited from UIElement.)
Public event | Drop | (Inherited from UIElement.)
Public event | FocusableChanged | (Inherited from UIElement.)
Public event | GiveFeedback | (Inherited from UIElement.)
Public event | GotFocus | (Inherited from UIElement.)
Public event | GotKeyboardFocus | (Inherited from UIElement.)
Public event | GotMouseCapture | (Inherited from UIElement.)
Public event | GotStylusCapture | (Inherited from UIElement.)
Public event | GotTouchCapture | (Inherited from UIElement.)
Public event | Initialized | (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsVisibleChanged | (Inherited from UIElement.)
Public event | KeyDown | (Inherited from UIElement.)
Public event | KeyUp | (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from UIElement.)
Public event | Loaded | (Inherited from FrameworkElement.)
Public event | LostFocus | (Inherited from UIElement.)
Public event | LostKeyboardFocus | (Inherited from UIElement.)
Public event | LostMouseCapture | (Inherited from UIElement.)
Public event | LostStylusCapture | (Inherited from UIElement.)
Public event | LostTouchCapture | (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | ManipulationStarting | (Inherited from UIElement.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from UIElement.)
Public event | MouseEnter | (Inherited from UIElement.)
Public event | MouseLeave | (Inherited from UIElement.)
Public event | MouseLeftButtonDown | (Inherited from UIElement.)
Public event | MouseLeftButtonUp | (Inherited from UIElement.)
Public event | MouseMove | (Inherited from UIElement.)
Public event | MouseRightButtonDown | (Inherited from UIElement.)
Public event | MouseRightButtonUp | (Inherited from UIElement.)
Public event | MouseUp | (Inherited from UIElement.)
Public event | MouseWheel | (Inherited from UIElement.)
Public event | PreviewDragEnter | (Inherited from UIElement.)
Public event | PreviewDragLeave | (Inherited from UIElement.)
Public event | PreviewDragOver | (Inherited from UIElement.)
Public event | PreviewDrop | (Inherited from UIElement.)
Public event | PreviewGiveFeedback | (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewKeyDown | (Inherited from UIElement.)
Public event | PreviewKeyUp | (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | (Inherited from Control.)
Public event | PreviewMouseDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseMove | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseUp | (Inherited from UIElement.)
Public event | PreviewMouseWheel | (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | (Inherited from UIElement.)
Public event | PreviewStylusDown | (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | (Inherited from UIElement.)
Public event | PreviewStylusInRange | (Inherited from UIElement.)
Public event | PreviewStylusMove | (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | (Inherited from UIElement.)
Public event | PreviewStylusUp | (Inherited from UIElement.)
Public event | PreviewTextInput | (Inherited from UIElement.)
Public event | PreviewTouchDown | (Inherited from UIElement.)
Public event | PreviewTouchMove | (Inherited from UIElement.)
Public event | PreviewTouchUp | (Inherited from UIElement.)
Public event | QueryContinueDrag | (Inherited from UIElement.)
Public event | QueryCursor | (Inherited from UIElement.)
Public event | RequestBringIntoView | (Inherited from FrameworkElement.)
Public event | SizeChanged | (Inherited from FrameworkElement.)
Public event | SourceUpdated | (Inherited from FrameworkElement.)
Public event | StylusButtonDown | (Inherited from UIElement.)
Public event | StylusButtonUp | (Inherited from UIElement.)
Public event | StylusDown | (Inherited from UIElement.)
Public event | StylusEnter | (Inherited from UIElement.)
Public event | StylusInAirMove | (Inherited from UIElement.)
Public event | StylusInRange | (Inherited from UIElement.)
Public event | StylusLeave | (Inherited from UIElement.)
Public event | StylusMove | (Inherited from UIElement.)
Public event | StylusOutOfRange | (Inherited from UIElement.)
Public event | StylusSystemGesture | (Inherited from UIElement.)
Public event | StylusUp | (Inherited from UIElement.)
Public event | TargetUpdated | (Inherited from FrameworkElement.)
Public event | TextInput | (Inherited from UIElement.)
Public event | ToolTipClosing | (Inherited from FrameworkElement.)
Public event | ToolTipOpening | (Inherited from FrameworkElement.)
Public event | TouchDown | (Inherited from UIElement.)
Public event | TouchEnter | (Inherited from UIElement.)
Public event | TouchLeave | (Inherited from UIElement.)
Public event | TouchMove | (Inherited from UIElement.)
Public event | TouchUp | (Inherited from UIElement.)
Public event | Unloaded | (Inherited from FrameworkElement.)

See Also

ReloggerProfileSettingsUserControl Class
Relogger.UserControlsAndWindows Namespace


RunReloggerTaskUserControl Class

Logique d'interaction pour RunReloggerTaskUserControl.xaml

Namespace: Relogger.UserControlsAndWindows
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public class RunReloggerTaskUserControl : UserControl
Public Class RunReloggerTaskUserControl _
    Inherits UserControl
public ref class RunReloggerTaskUserControl : public UserControl

Inheritance Hierarchy

Object
DispatcherObject
DependencyObject
Visual
UIElement
FrameworkElement
Control
ContentControl
UserControl
Relogger.UserControlsAndWindows..::..RunReloggerTaskUserControl

See Also

RunReloggerTaskUserControl Members
Relogger.UserControlsAndWindows Namespace


RunReloggerTaskUserControl Members

The RunReloggerTaskUserControl type exposes the following members.

Constructors

 | Name | Description
Public method | RunReloggerTaskUserControl | Initializes a new instance of the RunReloggerTaskUserControl class.

Methods

 | Name | Description
Protected method | AddChild(System.Object) | (Inherited from ContentControl.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate,System.Boolean) | (Inherited from UIElement.)
Protected method | AddText(System.String) | (Inherited from ContentControl.)
Public method | AddToEventRoute(System.Windows.EventRoute,System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | AddVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock) | (Inherited from UIElement.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from FrameworkElement.)
Public method | Arrange(System.Windows.Rect) | (Inherited from UIElement.)
Protected method | ArrangeCore(System.Windows.Rect) | (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(System.Windows.Size) | (Inherited from Control.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline) | (Inherited from UIElement.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | BeginInit | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior,System.Boolean) | (Inherited from FrameworkElement.)
Public method | BringIntoView | (Inherited from FrameworkElement.)
Public method | BringIntoView(System.Windows.Rect) | (Inherited from FrameworkElement.)
Public method | CaptureMouse | (Inherited from UIElement.)
Public method | CaptureStylus | (Inherited from UIElement.)
Public method | CaptureTouch(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DispatcherObject.)
Public method | ClearValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | ClearValue(System.Windows.DependencyPropertyKey) | (Inherited from DependencyObject.)
Public method | CoerceValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | EndInit | (Inherited from FrameworkElement.)
Public method | Equals(System.Object) | (Inherited from DependencyObject.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindCommonVisualAncestor(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | FindName(System.String) | (Inherited from FrameworkElement.)
Public method | FindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from UIElement.)
Public method | GetAnimationBaseValue(System.Windows.DependencyProperty) | (Inherited from UIElement.)
Public method | GetBindingExpression(System.Windows.DependencyProperty) | (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from DependencyObject.)
Protected method | GetLayoutClip(System.Windows.Size) | (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | (Inherited from DependencyObject.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Protected method | GetVisualChild(System.Int32) | (Inherited from FrameworkElement.)
Protected method | HitTestCore(System.Windows.Media.PointHitTestParameters) | (Inherited from UIElement.)
Protected method | HitTestCore(System.Windows.Media.GeometryHitTestParameters) | (Inherited from UIElement.)
Public method | InputHitTest(System.Windows.Point) | (Inherited from UIElement.)
Public method | InvalidateArrange | (Inherited from UIElement.)
Public method | InvalidateMeasure | (Inherited from UIElement.)
Public method | InvalidateProperty(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | InvalidateVisual | (Inherited from UIElement.)
Public method | IsAncestorOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | IsDescendantOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | Measure(System.Windows.Size) | (Inherited from UIElement.)
Protected method | MeasureCore(System.Windows.Size) | (Inherited from FrameworkElement.)
Protected method | MeasureOverride(System.Windows.Size) | (Inherited from Control.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | MoveFocus(System.Windows.Input.TraversalRequest) | (Inherited from FrameworkElement.)
Protected method | OnAccessKey(System.Windows.Input.AccessKeyEventArgs) | (Inherited from UIElement.)
Public method | OnApplyTemplate | (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged(System.Windows.UIElement) | (Inherited from UIElement.)
Protected method | OnContentChanged(System.Object,System.Object) | (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged(System.String,System.String) | (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged(System.Windows.DataTemplate,System.Windows.DataTemplate) | (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged(System.Windows.Controls.DataTemplateSelector,System.Windows.Controls.DataTemplateSelector) | (Inherited from ContentControl.)
Protected method | OnContextMenuClosing(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | (Inherited from UserControl.)
Protected method | OnDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnGotFocus(System.Windows.RoutedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnGotMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnGotStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnGotTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnInitialized(System.EventArgs) | (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnLostFocus(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnLostStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnLostTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback(System.Windows.Input.ManipulationBoundaryFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationCompleted(System.Windows.Input.ManipulationCompletedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationDelta(System.Windows.Input.ManipulationDeltaEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting(System.Windows.Input.ManipulationInertiaStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarted(System.Windows.Input.ManipulationStartedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarting(System.Windows.Input.ManipulationStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseEnter(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeave(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnPreviewMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPropertyChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnQueryCursor(System.Windows.Input.QueryCursorEventArgs) | (Inherited from UIElement.)
Protected method | OnRender(System.Windows.Media.DrawingContext) | (Inherited from UIElement.)
Protected method | OnStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusEnter(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusLeave(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnTemplateChanged(System.Windows.Controls.ControlTemplate,System.Windows.Controls.ControlTemplate) | (Inherited from Control.)
Protected method | OnTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnToolTipClosing(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchEnter(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchLeave(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Public method | PointFromScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PointToScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PredictFocus(System.Windows.Input.FocusNavigationDirection) | (Inherited from FrameworkElement.)
Public method | RaiseEvent(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Public method | ReadLocalValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | RegisterName(System.String,System.Object) | (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | (Inherited from UIElement.)
Public method | ReleaseMouseCapture | (Inherited from UIElement.)
Public method | ReleaseStylusCapture | (Inherited from UIElement.)
Public method | ReleaseTouchCapture(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | RemoveHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Protected method | RemoveVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | SetBinding(System.Windows.DependencyProperty,System.Windows.Data.BindingBase) | (Inherited from FrameworkElement.)
Public method | SetBinding(System.Windows.DependencyProperty,System.String) | (Inherited from FrameworkElement.)
Public method | SetCurrentValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetResourceReference(System.Windows.DependencyProperty,System.Object) | (Inherited from FrameworkElement.)
Public method | SetValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetValue(System.Windows.DependencyPropertyKey,System.Object) | (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | (Inherited from UIElement.)
Public method | ShouldSerializeContent | (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | (Inherited from UIElement.)
Public method | ShouldSerializeResources | (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | (Inherited from FrameworkElement.)
Public method | ToString | (Inherited from Control.)
Public method | TransformToAncestor(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToAncestor(System.Windows.Media.Media3D.Visual3D) | (Inherited from Visual.)
Public method | TransformToDescendant(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToVisual(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TranslatePoint(System.Windows.Point,System.Windows.UIElement) | (Inherited from UIElement.)
Public method | TryFindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | UnregisterName(System.String) | (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | (Inherited from FrameworkElement.)
Public method | UpdateLayout | (Inherited from UIElement.)
Public method | VerifyAccess | (Inherited from DispatcherObject.)

Properties

 | Name | Description
Public property | ActualHeight | (Inherited from FrameworkElement.)
Public property | ActualWidth | (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
Public property | AreAnyTouchesOver | (Inherited from UIElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from FrameworkElement.)
Public property | BitmapEffect | (Inherited from UIElement.)
Public property | BitmapEffectInput | (Inherited from UIElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | (Inherited from UIElement.)
Public property | ClipToBounds | (Inherited from UIElement.)
Public property | CommandBindings | (Inherited from UIElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContentTemplate | (Inherited from ContentControl.)
Public property | ContentTemplateSelector | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from FrameworkElement.)
Public property | Cursor | (Inherited from FrameworkElement.)
Public property | DataContext | (Inherited from FrameworkElement.)
Public property | DependencyObjectType | (Inherited from DependencyObject.)
Public property | DesiredSize | (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DispatcherObject.)
Public property | Effect | (Inherited from UIElement.)
Public property | FlowDirection | (Inherited from FrameworkElement.)
Public property | Focusable | (Inherited from UIElement.)
Public property | FocusVisualStyle | (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from FrameworkElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasAnimatedProperties | (Inherited from UIElement.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | InputBindings | (Inherited from UIElement.)
Public property | InputScope | (Inherited from FrameworkElement.)
Public property | IsArrangeValid | (Inherited from UIElement.)
Public property | IsEnabled | (Inherited from UIElement.)
Protected property | IsEnabledCore | (Inherited from UIElement.)
Public property | IsFocused | (Inherited from UIElement.)
Public property | IsHitTestVisible | (Inherited from UIElement.)
Public property | IsInitialized | (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | (Inherited from UIElement.)
Public property | IsKeyboardFocused | (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | (Inherited from UIElement.)
Public property | IsLoaded | (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | (Inherited from UIElement.)
Public property | IsMeasureValid | (Inherited from UIElement.)
Public property | IsMouseCaptured | (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | (Inherited from UIElement.)
Public property | IsMouseOver | (Inherited from UIElement.)
Public property | IsSealed | (Inherited from DependencyObject.)
Public property | IsStylusCaptured | (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | (Inherited from UIElement.)
Public property | IsStylusOver | (Inherited from UIElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsVisible | (Inherited from UIElement.)
Public property | Language | (Inherited from FrameworkElement.)
Public property | LayoutTransform | (Inherited from FrameworkElement.)
Public property | Margin | (Inherited from FrameworkElement.)
Public property | MaxHeight | (Inherited from FrameworkElement.)
Public property | MaxWidth | (Inherited from FrameworkElement.)
Public property | MinHeight | (Inherited from FrameworkElement.)
Public property | MinWidth | (Inherited from FrameworkElement.)
Public property | Name | (Inherited from FrameworkElement.)
Public property | Opacity | (Inherited from UIElement.)
Public property | OpacityMask | (Inherited from UIElement.)
Public property | OverridesDefaultStyle | (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from FrameworkElement.)
Public property | PersistId | (Inherited from UIElement.)
Public property | RenderSize | (Inherited from UIElement.)
Public property | RenderTransform | (Inherited from UIElement.)
Public property | RenderTransformOrigin | (Inherited from UIElement.)
Public property | Resources | (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from UIElement.)
Public property | Style | (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | (Inherited from UIElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | Tag | (Inherited from FrameworkElement.)
Public property | Template | (Inherited from Control.)
Public property | TemplatedParent | (Inherited from FrameworkElement.)
Public property | ToolTip | (Inherited from FrameworkElement.)
Public property | TouchesCaptured | (Inherited from UIElement.)
Public property | TouchesCapturedWithin | (Inherited from UIElement.)
Public property | TouchesDirectlyOver | (Inherited from UIElement.)
Public property | TouchesOver | (Inherited from UIElement.)
Public property | Triggers | (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from UIElement.)
Public property | UseLayoutRounding | (Inherited from FrameworkElement.)
Public property | VerticalAlignment | (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | (Inherited from UIElement.)
Protected property | VisualChildrenCount | (Inherited from FrameworkElement.)
Protected property | VisualParent | (Inherited from Visual.)
Public property | Width | (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | ContextMenuClosing | (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | (Inherited from FrameworkElement.)
Public event | DataContextChanged | (Inherited from FrameworkElement.)
Public event | DragEnter | (Inherited from UIElement.)
Public event | DragLeave | (Inherited from UIElement.)
Public event | DragOver | (Inherited from UIElement.)
Public event | Drop | (Inherited from UIElement.)
Public event | FocusableChanged | (Inherited from UIElement.)
Public event | GiveFeedback | (Inherited from UIElement.)
Public event | GotFocus | (Inherited from UIElement.)
Public event | GotKeyboardFocus | (Inherited from UIElement.)
Public event | GotMouseCapture | (Inherited from UIElement.)
Public event | GotStylusCapture | (Inherited from UIElement.)
Public event | GotTouchCapture | (Inherited from UIElement.)
Public event | Initialized | (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsVisibleChanged | (Inherited from UIElement.)
Public event | KeyDown | (Inherited from UIElement.)
Public event | KeyUp | (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from UIElement.)
Public event | Loaded | (Inherited from FrameworkElement.)
Public event | LostFocus | (Inherited from UIElement.)
Public event | LostKeyboardFocus | (Inherited from UIElement.)
Public event | LostMouseCapture | (Inherited from UIElement.)
Public event | LostStylusCapture | (Inherited from UIElement.)
Public event | LostTouchCapture | (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | ManipulationStarting | (Inherited from UIElement.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from UIElement.)
Public event | MouseEnter | (Inherited from UIElement.)
Public event | MouseLeave | (Inherited from UIElement.)
Public event | MouseLeftButtonDown | (Inherited from UIElement.)
Public event | MouseLeftButtonUp | (Inherited from UIElement.)
Public event | MouseMove | (Inherited from UIElement.)
Public event | MouseRightButtonDown | (Inherited from UIElement.)
Public event | MouseRightButtonUp | (Inherited from UIElement.)
Public event | MouseUp | (Inherited from UIElement.)
Public event | MouseWheel | (Inherited from UIElement.)
Public event | PreviewDragEnter | (Inherited from UIElement.)
Public event | PreviewDragLeave | (Inherited from UIElement.)
Public event | PreviewDragOver | (Inherited from UIElement.)
Public event | PreviewDrop | (Inherited from UIElement.)
Public event | PreviewGiveFeedback | (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewKeyDown | (Inherited from UIElement.)
Public event | PreviewKeyUp | (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | (Inherited from Control.)
Public event | PreviewMouseDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseMove | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseUp | (Inherited from UIElement.)
Public event | PreviewMouseWheel | (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | (Inherited from UIElement.)
Public event | PreviewStylusDown | (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | (Inherited from UIElement.)
Public event | PreviewStylusInRange | (Inherited from UIElement.)
Public event | PreviewStylusMove | (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | (Inherited from UIElement.)
Public event | PreviewStylusUp | (Inherited from UIElement.)
Public event | PreviewTextInput | (Inherited from UIElement.)
Public event | PreviewTouchDown | (Inherited from UIElement.)
Public event | PreviewTouchMove | (Inherited from UIElement.)
Public event | PreviewTouchUp | (Inherited from UIElement.)
Public event | QueryContinueDrag | (Inherited from UIElement.)
Public event | QueryCursor | (Inherited from UIElement.)
Public event | RequestBringIntoView | (Inherited from FrameworkElement.)
Public event | SizeChanged | (Inherited from FrameworkElement.)
Public event | SourceUpdated | (Inherited from FrameworkElement.)
Public event | StylusButtonDown | (Inherited from UIElement.)
Public event | StylusButtonUp | (Inherited from UIElement.)
Public event | StylusDown | (Inherited from UIElement.)
Public event | StylusEnter | (Inherited from UIElement.)
Public event | StylusInAirMove | (Inherited from UIElement.)
Public event | StylusInRange | (Inherited from UIElement.)
Public event | StylusLeave | (Inherited from UIElement.)
Public event | StylusMove | (Inherited from UIElement.)
Public event | StylusOutOfRange | (Inherited from UIElement.)
Public event | StylusSystemGesture | (Inherited from UIElement.)
Public event | StylusUp | (Inherited from UIElement.)
Public event | TargetUpdated | (Inherited from FrameworkElement.)
Public event | TextInput | (Inherited from UIElement.)
Public event | ToolTipClosing | (Inherited from FrameworkElement.)
Public event | ToolTipOpening | (Inherited from FrameworkElement.)
Public event | TouchDown | (Inherited from UIElement.)
Public event | TouchEnter | (Inherited from UIElement.)
Public event | TouchLeave | (Inherited from UIElement.)
Public event | TouchMove | (Inherited from UIElement.)
Public event | TouchUp | (Inherited from UIElement.)
Public event | Unloaded | (Inherited from FrameworkElement.)

See Also

RunReloggerTaskUserControl Class
Relogger.UserControlsAndWindows Namespace


RunReloggerTaskUserControl Constructor

Initializes a new instance of the RunReloggerTaskUserControl class.

Namespace: Relogger.UserControlsAndWindows
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public RunReloggerTaskUserControl()
Public Sub New
public:
RunReloggerTaskUserControl()

See Also

RunReloggerTaskUserControl Class
Relogger.UserControlsAndWindows Namespace


RunReloggerTaskUserControl Methods

The RunReloggerTaskUserControl type exposes the following members.

Methods

 | Name | Description
Protected method | AddChild(System.Object) | (Inherited from ContentControl.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate,System.Boolean) | (Inherited from UIElement.)
Protected method | AddText(System.String) | (Inherited from ContentControl.)
Public method | AddToEventRoute(System.Windows.EventRoute,System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | AddVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock) | (Inherited from UIElement.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from FrameworkElement.)
Public method | Arrange(System.Windows.Rect) | (Inherited from UIElement.)
Protected method | ArrangeCore(System.Windows.Rect) | (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(System.Windows.Size) | (Inherited from Control.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline) | (Inherited from UIElement.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | BeginInit | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior,System.Boolean) | (Inherited from FrameworkElement.)
Public method | BringIntoView | (Inherited from FrameworkElement.)
Public method | BringIntoView(System.Windows.Rect) | (Inherited from FrameworkElement.)
Public method | CaptureMouse | (Inherited from UIElement.)
Public method | CaptureStylus | (Inherited from UIElement.)
Public method | CaptureTouch(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DispatcherObject.)
Public method | ClearValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | ClearValue(System.Windows.DependencyPropertyKey) | (Inherited from DependencyObject.)
Public method | CoerceValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | EndInit | (Inherited from FrameworkElement.)
Public method | Equals(System.Object) | (Inherited from DependencyObject.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindCommonVisualAncestor(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | FindName(System.String) | (Inherited from FrameworkElement.)
Public method | FindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from UIElement.)
Public method | GetAnimationBaseValue(System.Windows.DependencyProperty) | (Inherited from UIElement.)
Public method | GetBindingExpression(System.Windows.DependencyProperty) | (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from DependencyObject.)
Protected method | GetLayoutClip(System.Windows.Size) | (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | (Inherited from DependencyObject.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Protected method | GetVisualChild(System.Int32) | (Inherited from FrameworkElement.)
Protected method | HitTestCore(System.Windows.Media.PointHitTestParameters) | (Inherited from UIElement.)
Protected method | HitTestCore(System.Windows.Media.GeometryHitTestParameters) | (Inherited from UIElement.)
Public method | InputHitTest(System.Windows.Point) | (Inherited from UIElement.)
Public method | InvalidateArrange | (Inherited from UIElement.)
Public method | InvalidateMeasure | (Inherited from UIElement.)
Public method | InvalidateProperty(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | InvalidateVisual | (Inherited from UIElement.)
Public method | IsAncestorOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | IsDescendantOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | Measure(System.Windows.Size) | (Inherited from UIElement.)
Protected method | MeasureCore(System.Windows.Size) | (Inherited from FrameworkElement.)
Protected method | MeasureOverride(System.Windows.Size) | (Inherited from Control.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | MoveFocus(System.Windows.Input.TraversalRequest) | (Inherited from FrameworkElement.)
Protected method | OnAccessKey(System.Windows.Input.AccessKeyEventArgs) | (Inherited from UIElement.)
Public method | OnApplyTemplate | (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged(System.Windows.UIElement) | (Inherited from UIElement.)
Protected method | OnContentChanged(System.Object,System.Object) | (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged(System.String,System.String) | (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged(System.Windows.DataTemplate,System.Windows.DataTemplate) | (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged(System.Windows.Controls.DataTemplateSelector,System.Windows.Controls.DataTemplateSelector) | (Inherited from ContentControl.)
Protected method | OnContextMenuClosing(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | (Inherited from UserControl.)
Protected method | OnDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnGotFocus(System.Windows.RoutedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnGotMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnGotStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnGotTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnInitialized(System.EventArgs) | (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnLostFocus(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnLostStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnLostTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback(System.Windows.Input.ManipulationBoundaryFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationCompleted(System.Windows.Input.ManipulationCompletedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationDelta(System.Windows.Input.ManipulationDeltaEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting(System.Windows.Input.ManipulationInertiaStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarted(System.Windows.Input.ManipulationStartedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarting(System.Windows.Input.ManipulationStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseEnter(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeave(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnPreviewMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPropertyChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnQueryCursor(System.Windows.Input.QueryCursorEventArgs) | (Inherited from UIElement.)
Protected method | OnRender(System.Windows.Media.DrawingContext) | (Inherited from UIElement.)
Protected method | OnStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusEnter(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusLeave(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnTemplateChanged(System.Windows.Controls.ControlTemplate,System.Windows.Controls.ControlTemplate) | (Inherited from Control.)
Protected method | OnTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnToolTipClosing(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchEnter(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchLeave(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Public method | PointFromScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PointToScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PredictFocus(System.Windows.Input.FocusNavigationDirection) | (Inherited from FrameworkElement.)
Public method | RaiseEvent(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Public method | ReadLocalValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | RegisterName(System.String,System.Object) | (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | (Inherited from UIElement.)
Public method | ReleaseMouseCapture | (Inherited from UIElement.)
Public method | ReleaseStylusCapture | (Inherited from UIElement.)
Public method | ReleaseTouchCapture(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | RemoveHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Protected method | RemoveVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | SetBinding(System.Windows.DependencyProperty,System.Windows.Data.BindingBase) | (Inherited from FrameworkElement.)
Public method | SetBinding(System.Windows.DependencyProperty,System.String) | (Inherited from FrameworkElement.)
Public method | SetCurrentValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetResourceReference(System.Windows.DependencyProperty,System.Object) | (Inherited from FrameworkElement.)
Public method | SetValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetValue(System.Windows.DependencyPropertyKey,System.Object) | (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | (Inherited from UIElement.)
Public method | ShouldSerializeContent | (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | (Inherited from UIElement.)
Public method | ShouldSerializeResources | (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | (Inherited from FrameworkElement.)
Public method | ToString | (Inherited from Control.)
Public method | TransformToAncestor(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToAncestor(System.Windows.Media.Media3D.Visual3D) | (Inherited from Visual.)
Public method | TransformToDescendant(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToVisual(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TranslatePoint(System.Windows.Point,System.Windows.UIElement) | (Inherited from UIElement.)
Public method | TryFindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | UnregisterName(System.String) | (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | (Inherited from FrameworkElement.)
Public method | UpdateLayout | (Inherited from UIElement.)
Public method | VerifyAccess | (Inherited from DispatcherObject.)

See Also

RunReloggerTaskUserControl Class
Relogger.UserControlsAndWindows Namespace


RunReloggerTaskUserControl Properties

The RunReloggerTaskUserControl type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | (Inherited from FrameworkElement.)
Public property | ActualWidth | (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
Public property | AreAnyTouchesOver | (Inherited from UIElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from FrameworkElement.)
Public property | BitmapEffect | (Inherited from UIElement.)
Public property | BitmapEffectInput | (Inherited from UIElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | (Inherited from UIElement.)
Public property | ClipToBounds | (Inherited from UIElement.)
Public property | CommandBindings | (Inherited from UIElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContentTemplate | (Inherited from ContentControl.)
Public property | ContentTemplateSelector | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from FrameworkElement.)
Public property | Cursor | (Inherited from FrameworkElement.)
Public property | DataContext | (Inherited from FrameworkElement.)
Public property | DependencyObjectType | (Inherited from DependencyObject.)
Public property | DesiredSize | (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DispatcherObject.)
Public property | Effect | (Inherited from UIElement.)
Public property | FlowDirection | (Inherited from FrameworkElement.)
Public property | Focusable | (Inherited from UIElement.)
Public property | FocusVisualStyle | (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from FrameworkElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasAnimatedProperties | (Inherited from UIElement.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | InputBindings | (Inherited from UIElement.)
Public property | InputScope | (Inherited from FrameworkElement.)
Public property | IsArrangeValid | (Inherited from UIElement.)
Public property | IsEnabled | (Inherited from UIElement.)
Protected property | IsEnabledCore | (Inherited from UIElement.)
Public property | IsFocused | (Inherited from UIElement.)
Public property | IsHitTestVisible | (Inherited from UIElement.)
Public property | IsInitialized | (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | (Inherited from UIElement.)
Public property | IsKeyboardFocused | (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | (Inherited from UIElement.)
Public property | IsLoaded | (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | (Inherited from UIElement.)
Public property | IsMeasureValid | (Inherited from UIElement.)
Public property | IsMouseCaptured | (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | (Inherited from UIElement.)
Public property | IsMouseOver | (Inherited from UIElement.)
Public property | IsSealed | (Inherited from DependencyObject.)
Public property | IsStylusCaptured | (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | (Inherited from UIElement.)
Public property | IsStylusOver | (Inherited from UIElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsVisible | (Inherited from UIElement.)
Public property | Language | (Inherited from FrameworkElement.)
Public property | LayoutTransform | (Inherited from FrameworkElement.)
Public property | Margin | (Inherited from FrameworkElement.)
Public property | MaxHeight | (Inherited from FrameworkElement.)
Public property | MaxWidth | (Inherited from FrameworkElement.)
Public property | MinHeight | (Inherited from FrameworkElement.)
Public property | MinWidth | (Inherited from FrameworkElement.)
Public property | Name | (Inherited from FrameworkElement.)
Public property | Opacity | (Inherited from UIElement.)
Public property | OpacityMask | (Inherited from UIElement.)
Public property | OverridesDefaultStyle | (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from FrameworkElement.)
Public property | PersistId | (Inherited from UIElement.)
Public property | RenderSize | (Inherited from UIElement.)
Public property | RenderTransform | (Inherited from UIElement.)
Public property | RenderTransformOrigin | (Inherited from UIElement.)
Public property | Resources | (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from UIElement.)
Public property | Style | (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | (Inherited from UIElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | Tag | (Inherited from FrameworkElement.)
Public property | Template | (Inherited from Control.)
Public property | TemplatedParent | (Inherited from FrameworkElement.)
Public property | ToolTip | (Inherited from FrameworkElement.)
Public property | TouchesCaptured | (Inherited from UIElement.)
Public property | TouchesCapturedWithin | (Inherited from UIElement.)
Public property | TouchesDirectlyOver | (Inherited from UIElement.)
Public property | TouchesOver | (Inherited from UIElement.)
Public property | Triggers | (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from UIElement.)
Public property | UseLayoutRounding | (Inherited from FrameworkElement.)
Public property | VerticalAlignment | (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | (Inherited from UIElement.)
Protected property | VisualChildrenCount | (Inherited from FrameworkElement.)
Protected property | VisualParent | (Inherited from Visual.)
Public property | Width | (Inherited from FrameworkElement.)

See Also

RunReloggerTaskUserControl Class
Relogger.UserControlsAndWindows Namespace


RunReloggerTaskUserControl Events

The RunReloggerTaskUserControl type exposes the following members.

Events

 | Name | Description
Public event | ContextMenuClosing | (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | (Inherited from FrameworkElement.)
Public event | DataContextChanged | (Inherited from FrameworkElement.)
Public event | DragEnter | (Inherited from UIElement.)
Public event | DragLeave | (Inherited from UIElement.)
Public event | DragOver | (Inherited from UIElement.)
Public event | Drop | (Inherited from UIElement.)
Public event | FocusableChanged | (Inherited from UIElement.)
Public event | GiveFeedback | (Inherited from UIElement.)
Public event | GotFocus | (Inherited from UIElement.)
Public event | GotKeyboardFocus | (Inherited from UIElement.)
Public event | GotMouseCapture | (Inherited from UIElement.)
Public event | GotStylusCapture | (Inherited from UIElement.)
Public event | GotTouchCapture | (Inherited from UIElement.)
Public event | Initialized | (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsVisibleChanged | (Inherited from UIElement.)
Public event | KeyDown | (Inherited from UIElement.)
Public event | KeyUp | (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from UIElement.)
Public event | Loaded | (Inherited from FrameworkElement.)
Public event | LostFocus | (Inherited from UIElement.)
Public event | LostKeyboardFocus | (Inherited from UIElement.)
Public event | LostMouseCapture | (Inherited from UIElement.)
Public event | LostStylusCapture | (Inherited from UIElement.)
Public event | LostTouchCapture | (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | ManipulationStarting | (Inherited from UIElement.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from UIElement.)
Public event | MouseEnter | (Inherited from UIElement.)
Public event | MouseLeave | (Inherited from UIElement.)
Public event | MouseLeftButtonDown | (Inherited from UIElement.)
Public event | MouseLeftButtonUp | (Inherited from UIElement.)
Public event | MouseMove | (Inherited from UIElement.)
Public event | MouseRightButtonDown | (Inherited from UIElement.)
Public event | MouseRightButtonUp | (Inherited from UIElement.)
Public event | MouseUp | (Inherited from UIElement.)
Public event | MouseWheel | (Inherited from UIElement.)
Public event | PreviewDragEnter | (Inherited from UIElement.)
Public event | PreviewDragLeave | (Inherited from UIElement.)
Public event | PreviewDragOver | (Inherited from UIElement.)
Public event | PreviewDrop | (Inherited from UIElement.)
Public event | PreviewGiveFeedback | (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewKeyDown | (Inherited from UIElement.)
Public event | PreviewKeyUp | (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | (Inherited from Control.)
Public event | PreviewMouseDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseMove | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseUp | (Inherited from UIElement.)
Public event | PreviewMouseWheel | (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | (Inherited from UIElement.)
Public event | PreviewStylusDown | (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | (Inherited from UIElement.)
Public event | PreviewStylusInRange | (Inherited from UIElement.)
Public event | PreviewStylusMove | (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | (Inherited from UIElement.)
Public event | PreviewStylusUp | (Inherited from UIElement.)
Public event | PreviewTextInput | (Inherited from UIElement.)
Public event | PreviewTouchDown | (Inherited from UIElement.)
Public event | PreviewTouchMove | (Inherited from UIElement.)
Public event | PreviewTouchUp | (Inherited from UIElement.)
Public event | QueryContinueDrag | (Inherited from UIElement.)
Public event | QueryCursor | (Inherited from UIElement.)
Public event | RequestBringIntoView | (Inherited from FrameworkElement.)
Public event | SizeChanged | (Inherited from FrameworkElement.)
Public event | SourceUpdated | (Inherited from FrameworkElement.)
Public event | StylusButtonDown | (Inherited from UIElement.)
Public event | StylusButtonUp | (Inherited from UIElement.)
Public event | StylusDown | (Inherited from UIElement.)
Public event | StylusEnter | (Inherited from UIElement.)
Public event | StylusInAirMove | (Inherited from UIElement.)
Public event | StylusInRange | (Inherited from UIElement.)
Public event | StylusLeave | (Inherited from UIElement.)
Public event | StylusMove | (Inherited from UIElement.)
Public event | StylusOutOfRange | (Inherited from UIElement.)
Public event | StylusSystemGesture | (Inherited from UIElement.)
Public event | StylusUp | (Inherited from UIElement.)
Public event | TargetUpdated | (Inherited from FrameworkElement.)
Public event | TextInput | (Inherited from UIElement.)
Public event | ToolTipClosing | (Inherited from FrameworkElement.)
Public event | ToolTipOpening | (Inherited from FrameworkElement.)
Public event | TouchDown | (Inherited from UIElement.)
Public event | TouchEnter | (Inherited from UIElement.)
Public event | TouchLeave | (Inherited from UIElement.)
Public event | TouchMove | (Inherited from UIElement.)
Public event | TouchUp | (Inherited from UIElement.)
Public event | Unloaded | (Inherited from FrameworkElement.)

See Also

RunReloggerTaskUserControl Class
Relogger.UserControlsAndWindows Namespace


TasksUserControl Class

Logique d'interaction pour TasksUserControl.xaml

Namespace: Relogger.UserControlsAndWindows
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public class TasksUserControl : UserControl
Public Class TasksUserControl _
    Inherits UserControl
public ref class TasksUserControl : public UserControl

Inheritance Hierarchy

Object
DispatcherObject
DependencyObject
Visual
UIElement
FrameworkElement
Control
ContentControl
UserControl
Relogger.UserControlsAndWindows..::..TasksUserControl

See Also

TasksUserControl Members
Relogger.UserControlsAndWindows Namespace


TasksUserControl Members

The TasksUserControl type exposes the following members.

Constructors

 | Name | Description
Public method | TasksUserControl | Initializes a new instance of the TasksUserControl class.

Methods

 | Name | Description
Protected method | AddChild(System.Object) | (Inherited from ContentControl.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate,System.Boolean) | (Inherited from UIElement.)
Protected method | AddText(System.String) | (Inherited from ContentControl.)
Public method | AddToEventRoute(System.Windows.EventRoute,System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | AddVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock) | (Inherited from UIElement.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from FrameworkElement.)
Public method | Arrange(System.Windows.Rect) | (Inherited from UIElement.)
Protected method | ArrangeCore(System.Windows.Rect) | (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(System.Windows.Size) | (Inherited from Control.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline) | (Inherited from UIElement.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | BeginInit | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior,System.Boolean) | (Inherited from FrameworkElement.)
Public method | BringIntoView | (Inherited from FrameworkElement.)
Public method | BringIntoView(System.Windows.Rect) | (Inherited from FrameworkElement.)
Public method | CaptureMouse | (Inherited from UIElement.)
Public method | CaptureStylus | (Inherited from UIElement.)
Public method | CaptureTouch(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DispatcherObject.)
Public method | ClearValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | ClearValue(System.Windows.DependencyPropertyKey) | (Inherited from DependencyObject.)
Public method | CoerceValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | EndInit | (Inherited from FrameworkElement.)
Public method | Equals(System.Object) | (Inherited from DependencyObject.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindCommonVisualAncestor(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | FindName(System.String) | (Inherited from FrameworkElement.)
Public method | FindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from UIElement.)
Public method | GetAnimationBaseValue(System.Windows.DependencyProperty) | (Inherited from UIElement.)
Public method | GetBindingExpression(System.Windows.DependencyProperty) | (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from DependencyObject.)
Protected method | GetLayoutClip(System.Windows.Size) | (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | (Inherited from DependencyObject.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Protected method | GetVisualChild(System.Int32) | (Inherited from FrameworkElement.)
Protected method | HitTestCore(System.Windows.Media.PointHitTestParameters) | (Inherited from UIElement.)
Protected method | HitTestCore(System.Windows.Media.GeometryHitTestParameters) | (Inherited from UIElement.)
Public method | InputHitTest(System.Windows.Point) | (Inherited from UIElement.)
Public method | InvalidateArrange | (Inherited from UIElement.)
Public method | InvalidateMeasure | (Inherited from UIElement.)
Public method | InvalidateProperty(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | InvalidateVisual | (Inherited from UIElement.)
Public method | IsAncestorOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | IsDescendantOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | Measure(System.Windows.Size) | (Inherited from UIElement.)
Protected method | MeasureCore(System.Windows.Size) | (Inherited from FrameworkElement.)
Protected method | MeasureOverride(System.Windows.Size) | (Inherited from Control.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | MoveFocus(System.Windows.Input.TraversalRequest) | (Inherited from FrameworkElement.)
Protected method | OnAccessKey(System.Windows.Input.AccessKeyEventArgs) | (Inherited from UIElement.)
Public method | OnApplyTemplate | (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged(System.Windows.UIElement) | (Inherited from UIElement.)
Protected method | OnContentChanged(System.Object,System.Object) | (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged(System.String,System.String) | (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged(System.Windows.DataTemplate,System.Windows.DataTemplate) | (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged(System.Windows.Controls.DataTemplateSelector,System.Windows.Controls.DataTemplateSelector) | (Inherited from ContentControl.)
Protected method | OnContextMenuClosing(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | (Inherited from UserControl.)
Protected method | OnDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnGotFocus(System.Windows.RoutedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnGotMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnGotStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnGotTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnInitialized(System.EventArgs) | (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnLostFocus(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnLostStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnLostTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback(System.Windows.Input.ManipulationBoundaryFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationCompleted(System.Windows.Input.ManipulationCompletedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationDelta(System.Windows.Input.ManipulationDeltaEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting(System.Windows.Input.ManipulationInertiaStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarted(System.Windows.Input.ManipulationStartedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarting(System.Windows.Input.ManipulationStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseEnter(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeave(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnPreviewMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPropertyChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnQueryCursor(System.Windows.Input.QueryCursorEventArgs) | (Inherited from UIElement.)
Protected method | OnRender(System.Windows.Media.DrawingContext) | (Inherited from UIElement.)
Protected method | OnStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusEnter(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusLeave(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnTemplateChanged(System.Windows.Controls.ControlTemplate,System.Windows.Controls.ControlTemplate) | (Inherited from Control.)
Protected method | OnTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnToolTipClosing(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchEnter(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchLeave(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Public method | PointFromScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PointToScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PredictFocus(System.Windows.Input.FocusNavigationDirection) | (Inherited from FrameworkElement.)
Public method | RaiseEvent(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Public method | ReadLocalValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | RegisterName(System.String,System.Object) | (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | (Inherited from UIElement.)
Public method | ReleaseMouseCapture | (Inherited from UIElement.)
Public method | ReleaseStylusCapture | (Inherited from UIElement.)
Public method | ReleaseTouchCapture(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | RemoveHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Protected method | RemoveVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | SetBinding(System.Windows.DependencyProperty,System.Windows.Data.BindingBase) | (Inherited from FrameworkElement.)
Public method | SetBinding(System.Windows.DependencyProperty,System.String) | (Inherited from FrameworkElement.)
Public method | SetCurrentValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetResourceReference(System.Windows.DependencyProperty,System.Object) | (Inherited from FrameworkElement.)
Public method | SetValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetValue(System.Windows.DependencyPropertyKey,System.Object) | (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | (Inherited from UIElement.)
Public method | ShouldSerializeContent | (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | (Inherited from UIElement.)
Public method | ShouldSerializeResources | (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | (Inherited from FrameworkElement.)
Public method | ToString | (Inherited from Control.)
Public method | TransformToAncestor(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToAncestor(System.Windows.Media.Media3D.Visual3D) | (Inherited from Visual.)
Public method | TransformToDescendant(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToVisual(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TranslatePoint(System.Windows.Point,System.Windows.UIElement) | (Inherited from UIElement.)
Public method | TryFindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | UnregisterName(System.String) | (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | (Inherited from FrameworkElement.)
Public method | UpdateLayout | (Inherited from UIElement.)
Public method | VerifyAccess | (Inherited from DispatcherObject.)

Properties

 | Name | Description
Public property | ActualHeight | (Inherited from FrameworkElement.)
Public property | ActualWidth | (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
Public property | AreAnyTouchesOver | (Inherited from UIElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from FrameworkElement.)
Public property | BitmapEffect | (Inherited from UIElement.)
Public property | BitmapEffectInput | (Inherited from UIElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | (Inherited from UIElement.)
Public property | ClipToBounds | (Inherited from UIElement.)
Public property | CommandBindings | (Inherited from UIElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContentTemplate | (Inherited from ContentControl.)
Public property | ContentTemplateSelector | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from FrameworkElement.)
Public property | Cursor | (Inherited from FrameworkElement.)
Public property | DataContext | (Inherited from FrameworkElement.)
Public property | DependencyObjectType | (Inherited from DependencyObject.)
Public property | DesiredSize | (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DispatcherObject.)
Public property | Effect | (Inherited from UIElement.)
Public property | FlowDirection | (Inherited from FrameworkElement.)
Public property | Focusable | (Inherited from UIElement.)
Public property | FocusVisualStyle | (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from FrameworkElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasAnimatedProperties | (Inherited from UIElement.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | InputBindings | (Inherited from UIElement.)
Public property | InputScope | (Inherited from FrameworkElement.)
Public property | IsArrangeValid | (Inherited from UIElement.)
Public property | IsEnabled | (Inherited from UIElement.)
Protected property | IsEnabledCore | (Inherited from UIElement.)
Public property | IsFocused | (Inherited from UIElement.)
Public property | IsHitTestVisible | (Inherited from UIElement.)
Public property | IsInitialized | (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | (Inherited from UIElement.)
Public property | IsKeyboardFocused | (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | (Inherited from UIElement.)
Public property | IsLoaded | (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | (Inherited from UIElement.)
Public property | IsMeasureValid | (Inherited from UIElement.)
Public property | IsMouseCaptured | (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | (Inherited from UIElement.)
Public property | IsMouseOver | (Inherited from UIElement.)
Public property | IsSealed | (Inherited from DependencyObject.)
Public property | IsStylusCaptured | (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | (Inherited from UIElement.)
Public property | IsStylusOver | (Inherited from UIElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsVisible | (Inherited from UIElement.)
Public property | Language | (Inherited from FrameworkElement.)
Public property | LayoutTransform | (Inherited from FrameworkElement.)
Public property | Margin | (Inherited from FrameworkElement.)
Public property | MaxHeight | (Inherited from FrameworkElement.)
Public property | MaxWidth | (Inherited from FrameworkElement.)
Public property | MinHeight | (Inherited from FrameworkElement.)
Public property | MinWidth | (Inherited from FrameworkElement.)
Public property | Name | (Inherited from FrameworkElement.)
Public property | Opacity | (Inherited from UIElement.)
Public property | OpacityMask | (Inherited from UIElement.)
Public property | OverridesDefaultStyle | (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from FrameworkElement.)
Public property | PersistId | (Inherited from UIElement.)
Public property | RenderSize | (Inherited from UIElement.)
Public property | RenderTransform | (Inherited from UIElement.)
Public property | RenderTransformOrigin | (Inherited from UIElement.)
Public property | Resources | (Inherited from FrameworkElement.)
Public property | SelectedReloggerTask | Gets the selected relogger task.
Public property | SnapsToDevicePixels | (Inherited from UIElement.)
Public property | Source | Gets or sets the source.
Public property | Style | (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | (Inherited from UIElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | Tag | (Inherited from FrameworkElement.)
Public property | Template | (Inherited from Control.)
Public property | TemplatedParent | (Inherited from FrameworkElement.)
Public property | ToolTip | (Inherited from FrameworkElement.)
Public property | TouchesCaptured | (Inherited from UIElement.)
Public property | TouchesCapturedWithin | (Inherited from UIElement.)
Public property | TouchesDirectlyOver | (Inherited from UIElement.)
Public property | TouchesOver | (Inherited from UIElement.)
Public property | Triggers | (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from UIElement.)
Public property | UseLayoutRounding | (Inherited from FrameworkElement.)
Public property | VerticalAlignment | (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | (Inherited from UIElement.)
Protected property | VisualChildrenCount | (Inherited from FrameworkElement.)
Protected property | VisualParent | (Inherited from Visual.)
Public property | Width | (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | ContextMenuClosing | (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | (Inherited from FrameworkElement.)
Public event | DataContextChanged | (Inherited from FrameworkElement.)
Public event | DragEnter | (Inherited from UIElement.)
Public event | DragLeave | (Inherited from UIElement.)
Public event | DragOver | (Inherited from UIElement.)
Public event | Drop | (Inherited from UIElement.)
Public event | FocusableChanged | (Inherited from UIElement.)
Public event | GiveFeedback | (Inherited from UIElement.)
Public event | GotFocus | (Inherited from UIElement.)
Public event | GotKeyboardFocus | (Inherited from UIElement.)
Public event | GotMouseCapture | (Inherited from UIElement.)
Public event | GotStylusCapture | (Inherited from UIElement.)
Public event | GotTouchCapture | (Inherited from UIElement.)
Public event | Initialized | (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsVisibleChanged | (Inherited from UIElement.)
Public event | KeyDown | (Inherited from UIElement.)
Public event | KeyUp | (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from UIElement.)
Public event | Loaded | (Inherited from FrameworkElement.)
Public event | LostFocus | (Inherited from UIElement.)
Public event | LostKeyboardFocus | (Inherited from UIElement.)
Public event | LostMouseCapture | (Inherited from UIElement.)
Public event | LostStylusCapture | (Inherited from UIElement.)
Public event | LostTouchCapture | (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | ManipulationStarting | (Inherited from UIElement.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from UIElement.)
Public event | MouseEnter | (Inherited from UIElement.)
Public event | MouseLeave | (Inherited from UIElement.)
Public event | MouseLeftButtonDown | (Inherited from UIElement.)
Public event | MouseLeftButtonUp | (Inherited from UIElement.)
Public event | MouseMove | (Inherited from UIElement.)
Public event | MouseRightButtonDown | (Inherited from UIElement.)
Public event | MouseRightButtonUp | (Inherited from UIElement.)
Public event | MouseUp | (Inherited from UIElement.)
Public event | MouseWheel | (Inherited from UIElement.)
Public event | PreviewDragEnter | (Inherited from UIElement.)
Public event | PreviewDragLeave | (Inherited from UIElement.)
Public event | PreviewDragOver | (Inherited from UIElement.)
Public event | PreviewDrop | (Inherited from UIElement.)
Public event | PreviewGiveFeedback | (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewKeyDown | (Inherited from UIElement.)
Public event | PreviewKeyUp | (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | (Inherited from Control.)
Public event | PreviewMouseDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseMove | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseUp | (Inherited from UIElement.)
Public event | PreviewMouseWheel | (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | (Inherited from UIElement.)
Public event | PreviewStylusDown | (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | (Inherited from UIElement.)
Public event | PreviewStylusInRange | (Inherited from UIElement.)
Public event | PreviewStylusMove | (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | (Inherited from UIElement.)
Public event | PreviewStylusUp | (Inherited from UIElement.)
Public event | PreviewTextInput | (Inherited from UIElement.)
Public event | PreviewTouchDown | (Inherited from UIElement.)
Public event | PreviewTouchMove | (Inherited from UIElement.)
Public event | PreviewTouchUp | (Inherited from UIElement.)
Public event | QueryContinueDrag | (Inherited from UIElement.)
Public event | QueryCursor | (Inherited from UIElement.)
Public event | RequestBringIntoView | (Inherited from FrameworkElement.)
Public event | SizeChanged | (Inherited from FrameworkElement.)
Public event | SourceUpdated | (Inherited from FrameworkElement.)
Public event | StylusButtonDown | (Inherited from UIElement.)
Public event | StylusButtonUp | (Inherited from UIElement.)
Public event | StylusDown | (Inherited from UIElement.)
Public event | StylusEnter | (Inherited from UIElement.)
Public event | StylusInAirMove | (Inherited from UIElement.)
Public event | StylusInRange | (Inherited from UIElement.)
Public event | StylusLeave | (Inherited from UIElement.)
Public event | StylusMove | (Inherited from UIElement.)
Public event | StylusOutOfRange | (Inherited from UIElement.)
Public event | StylusSystemGesture | (Inherited from UIElement.)
Public event | StylusUp | (Inherited from UIElement.)
Public event | TargetUpdated | (Inherited from FrameworkElement.)
Public event | TextInput | (Inherited from UIElement.)
Public event | ToolTipClosing | (Inherited from FrameworkElement.)
Public event | ToolTipOpening | (Inherited from FrameworkElement.)
Public event | TouchDown | (Inherited from UIElement.)
Public event | TouchEnter | (Inherited from UIElement.)
Public event | TouchLeave | (Inherited from UIElement.)
Public event | TouchMove | (Inherited from UIElement.)
Public event | TouchUp | (Inherited from UIElement.)
Public event | Unloaded | (Inherited from FrameworkElement.)

See Also

TasksUserControl Class
Relogger.UserControlsAndWindows Namespace


TasksUserControl Constructor

Initializes a new instance of the TasksUserControl class.

Namespace: Relogger.UserControlsAndWindows
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public TasksUserControl()
Public Sub New
public:
TasksUserControl()

See Also

TasksUserControl Class
Relogger.UserControlsAndWindows Namespace


TasksUserControl Methods

The TasksUserControl type exposes the following members.

Methods

 | Name | Description
Protected method | AddChild(System.Object) | (Inherited from ContentControl.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate,System.Boolean) | (Inherited from UIElement.)
Protected method | AddText(System.String) | (Inherited from ContentControl.)
Public method | AddToEventRoute(System.Windows.EventRoute,System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | AddVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock) | (Inherited from UIElement.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from FrameworkElement.)
Public method | Arrange(System.Windows.Rect) | (Inherited from UIElement.)
Protected method | ArrangeCore(System.Windows.Rect) | (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(System.Windows.Size) | (Inherited from Control.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline) | (Inherited from UIElement.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | BeginInit | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior,System.Boolean) | (Inherited from FrameworkElement.)
Public method | BringIntoView | (Inherited from FrameworkElement.)
Public method | BringIntoView(System.Windows.Rect) | (Inherited from FrameworkElement.)
Public method | CaptureMouse | (Inherited from UIElement.)
Public method | CaptureStylus | (Inherited from UIElement.)
Public method | CaptureTouch(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DispatcherObject.)
Public method | ClearValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | ClearValue(System.Windows.DependencyPropertyKey) | (Inherited from DependencyObject.)
Public method | CoerceValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | EndInit | (Inherited from FrameworkElement.)
Public method | Equals(System.Object) | (Inherited from DependencyObject.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindCommonVisualAncestor(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | FindName(System.String) | (Inherited from FrameworkElement.)
Public method | FindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from UIElement.)
Public method | GetAnimationBaseValue(System.Windows.DependencyProperty) | (Inherited from UIElement.)
Public method | GetBindingExpression(System.Windows.DependencyProperty) | (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from DependencyObject.)
Protected method | GetLayoutClip(System.Windows.Size) | (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | (Inherited from DependencyObject.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Protected method | GetVisualChild(System.Int32) | (Inherited from FrameworkElement.)
Protected method | HitTestCore(System.Windows.Media.PointHitTestParameters) | (Inherited from UIElement.)
Protected method | HitTestCore(System.Windows.Media.GeometryHitTestParameters) | (Inherited from UIElement.)
Public method | InputHitTest(System.Windows.Point) | (Inherited from UIElement.)
Public method | InvalidateArrange | (Inherited from UIElement.)
Public method | InvalidateMeasure | (Inherited from UIElement.)
Public method | InvalidateProperty(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | InvalidateVisual | (Inherited from UIElement.)
Public method | IsAncestorOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | IsDescendantOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | Measure(System.Windows.Size) | (Inherited from UIElement.)
Protected method | MeasureCore(System.Windows.Size) | (Inherited from FrameworkElement.)
Protected method | MeasureOverride(System.Windows.Size) | (Inherited from Control.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | MoveFocus(System.Windows.Input.TraversalRequest) | (Inherited from FrameworkElement.)
Protected method | OnAccessKey(System.Windows.Input.AccessKeyEventArgs) | (Inherited from UIElement.)
Public method | OnApplyTemplate | (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged(System.Windows.UIElement) | (Inherited from UIElement.)
Protected method | OnContentChanged(System.Object,System.Object) | (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged(System.String,System.String) | (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged(System.Windows.DataTemplate,System.Windows.DataTemplate) | (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged(System.Windows.Controls.DataTemplateSelector,System.Windows.Controls.DataTemplateSelector) | (Inherited from ContentControl.)
Protected method | OnContextMenuClosing(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | (Inherited from UserControl.)
Protected method | OnDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnGotFocus(System.Windows.RoutedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnGotMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnGotStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnGotTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnInitialized(System.EventArgs) | (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnLostFocus(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnLostStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnLostTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback(System.Windows.Input.ManipulationBoundaryFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationCompleted(System.Windows.Input.ManipulationCompletedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationDelta(System.Windows.Input.ManipulationDeltaEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting(System.Windows.Input.ManipulationInertiaStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarted(System.Windows.Input.ManipulationStartedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarting(System.Windows.Input.ManipulationStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseEnter(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeave(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnPreviewMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPropertyChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnQueryCursor(System.Windows.Input.QueryCursorEventArgs) | (Inherited from UIElement.)
Protected method | OnRender(System.Windows.Media.DrawingContext) | (Inherited from UIElement.)
Protected method | OnStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusEnter(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusLeave(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnTemplateChanged(System.Windows.Controls.ControlTemplate,System.Windows.Controls.ControlTemplate) | (Inherited from Control.)
Protected method | OnTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnToolTipClosing(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchEnter(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchLeave(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Public method | PointFromScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PointToScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PredictFocus(System.Windows.Input.FocusNavigationDirection) | (Inherited from FrameworkElement.)
Public method | RaiseEvent(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Public method | ReadLocalValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | RegisterName(System.String,System.Object) | (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | (Inherited from UIElement.)
Public method | ReleaseMouseCapture | (Inherited from UIElement.)
Public method | ReleaseStylusCapture | (Inherited from UIElement.)
Public method | ReleaseTouchCapture(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | RemoveHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Protected method | RemoveVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | SetBinding(System.Windows.DependencyProperty,System.Windows.Data.BindingBase) | (Inherited from FrameworkElement.)
Public method | SetBinding(System.Windows.DependencyProperty,System.String) | (Inherited from FrameworkElement.)
Public method | SetCurrentValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetResourceReference(System.Windows.DependencyProperty,System.Object) | (Inherited from FrameworkElement.)
Public method | SetValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetValue(System.Windows.DependencyPropertyKey,System.Object) | (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | (Inherited from UIElement.)
Public method | ShouldSerializeContent | (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | (Inherited from UIElement.)
Public method | ShouldSerializeResources | (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | (Inherited from FrameworkElement.)
Public method | ToString | (Inherited from Control.)
Public method | TransformToAncestor(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToAncestor(System.Windows.Media.Media3D.Visual3D) | (Inherited from Visual.)
Public method | TransformToDescendant(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToVisual(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TranslatePoint(System.Windows.Point,System.Windows.UIElement) | (Inherited from UIElement.)
Public method | TryFindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | UnregisterName(System.String) | (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | (Inherited from FrameworkElement.)
Public method | UpdateLayout | (Inherited from UIElement.)
Public method | VerifyAccess | (Inherited from DispatcherObject.)

See Also

TasksUserControl Class
Relogger.UserControlsAndWindows Namespace


TasksUserControl Properties

The TasksUserControl type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | (Inherited from FrameworkElement.)
Public property | ActualWidth | (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
Public property | AreAnyTouchesOver | (Inherited from UIElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from FrameworkElement.)
Public property | BitmapEffect | (Inherited from UIElement.)
Public property | BitmapEffectInput | (Inherited from UIElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | (Inherited from UIElement.)
Public property | ClipToBounds | (Inherited from UIElement.)
Public property | CommandBindings | (Inherited from UIElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContentTemplate | (Inherited from ContentControl.)
Public property | ContentTemplateSelector | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from FrameworkElement.)
Public property | Cursor | (Inherited from FrameworkElement.)
Public property | DataContext | (Inherited from FrameworkElement.)
Public property | DependencyObjectType | (Inherited from DependencyObject.)
Public property | DesiredSize | (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DispatcherObject.)
Public property | Effect | (Inherited from UIElement.)
Public property | FlowDirection | (Inherited from FrameworkElement.)
Public property | Focusable | (Inherited from UIElement.)
Public property | FocusVisualStyle | (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from FrameworkElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasAnimatedProperties | (Inherited from UIElement.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | InputBindings | (Inherited from UIElement.)
Public property | InputScope | (Inherited from FrameworkElement.)
Public property | IsArrangeValid | (Inherited from UIElement.)
Public property | IsEnabled | (Inherited from UIElement.)
Protected property | IsEnabledCore | (Inherited from UIElement.)
Public property | IsFocused | (Inherited from UIElement.)
Public property | IsHitTestVisible | (Inherited from UIElement.)
Public property | IsInitialized | (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | (Inherited from UIElement.)
Public property | IsKeyboardFocused | (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | (Inherited from UIElement.)
Public property | IsLoaded | (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | (Inherited from UIElement.)
Public property | IsMeasureValid | (Inherited from UIElement.)
Public property | IsMouseCaptured | (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | (Inherited from UIElement.)
Public property | IsMouseOver | (Inherited from UIElement.)
Public property | IsSealed | (Inherited from DependencyObject.)
Public property | IsStylusCaptured | (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | (Inherited from UIElement.)
Public property | IsStylusOver | (Inherited from UIElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsVisible | (Inherited from UIElement.)
Public property | Language | (Inherited from FrameworkElement.)
Public property | LayoutTransform | (Inherited from FrameworkElement.)
Public property | Margin | (Inherited from FrameworkElement.)
Public property | MaxHeight | (Inherited from FrameworkElement.)
Public property | MaxWidth | (Inherited from FrameworkElement.)
Public property | MinHeight | (Inherited from FrameworkElement.)
Public property | MinWidth | (Inherited from FrameworkElement.)
Public property | Name | (Inherited from FrameworkElement.)
Public property | Opacity | (Inherited from UIElement.)
Public property | OpacityMask | (Inherited from UIElement.)
Public property | OverridesDefaultStyle | (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from FrameworkElement.)
Public property | PersistId | (Inherited from UIElement.)
Public property | RenderSize | (Inherited from UIElement.)
Public property | RenderTransform | (Inherited from UIElement.)
Public property | RenderTransformOrigin | (Inherited from UIElement.)
Public property | Resources | (Inherited from FrameworkElement.)
Public property | SelectedReloggerTask | Gets the selected relogger task.
Public property | SnapsToDevicePixels | (Inherited from UIElement.)
Public property | Source | Gets or sets the source.
Public property | Style | (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | (Inherited from UIElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | Tag | (Inherited from FrameworkElement.)
Public property | Template | (Inherited from Control.)
Public property | TemplatedParent | (Inherited from FrameworkElement.)
Public property | ToolTip | (Inherited from FrameworkElement.)
Public property | TouchesCaptured | (Inherited from UIElement.)
Public property | TouchesCapturedWithin | (Inherited from UIElement.)
Public property | TouchesDirectlyOver | (Inherited from UIElement.)
Public property | TouchesOver | (Inherited from UIElement.)
Public property | Triggers | (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from UIElement.)
Public property | UseLayoutRounding | (Inherited from FrameworkElement.)
Public property | VerticalAlignment | (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | (Inherited from UIElement.)
Protected property | VisualChildrenCount | (Inherited from FrameworkElement.)
Protected property | VisualParent | (Inherited from Visual.)
Public property | Width | (Inherited from FrameworkElement.)

See Also

TasksUserControl Class
Relogger.UserControlsAndWindows Namespace


SelectedReloggerTask Property

TasksUserControl..::..SelectedReloggerTask Property

Gets the selected relogger task.

Namespace: Relogger.UserControlsAndWindows
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public ReloggerTask SelectedReloggerTask { get; }
Public ReadOnly Property SelectedReloggerTask As ReloggerTask
    Get
public:
property ReloggerTask^ SelectedReloggerTask {
    ReloggerTask^ get ();
}

Field Value

The selected relogger task.

See Also

TasksUserControl Class
Relogger.UserControlsAndWindows Namespace


Source Property

TasksUserControl..::..Source Property

Gets or sets the source.

Namespace: Relogger.UserControlsAndWindows
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public ReloggerProfileSettings Source { get; set; }
Public Property Source As ReloggerProfileSettings
    Get
    Set
public:
property ReloggerProfileSettings^ Source {
    ReloggerProfileSettings^ get ();
    void set (ReloggerProfileSettings^ value);
}

Field Value

The source.

See Also

TasksUserControl Class
Relogger.UserControlsAndWindows Namespace


TasksUserControl Events

The TasksUserControl type exposes the following members.

Events

 | Name | Description
Public event | ContextMenuClosing | (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | (Inherited from FrameworkElement.)
Public event | DataContextChanged | (Inherited from FrameworkElement.)
Public event | DragEnter | (Inherited from UIElement.)
Public event | DragLeave | (Inherited from UIElement.)
Public event | DragOver | (Inherited from UIElement.)
Public event | Drop | (Inherited from UIElement.)
Public event | FocusableChanged | (Inherited from UIElement.)
Public event | GiveFeedback | (Inherited from UIElement.)
Public event | GotFocus | (Inherited from UIElement.)
Public event | GotKeyboardFocus | (Inherited from UIElement.)
Public event | GotMouseCapture | (Inherited from UIElement.)
Public event | GotStylusCapture | (Inherited from UIElement.)
Public event | GotTouchCapture | (Inherited from UIElement.)
Public event | Initialized | (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsVisibleChanged | (Inherited from UIElement.)
Public event | KeyDown | (Inherited from UIElement.)
Public event | KeyUp | (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from UIElement.)
Public event | Loaded | (Inherited from FrameworkElement.)
Public event | LostFocus | (Inherited from UIElement.)
Public event | LostKeyboardFocus | (Inherited from UIElement.)
Public event | LostMouseCapture | (Inherited from UIElement.)
Public event | LostStylusCapture | (Inherited from UIElement.)
Public event | LostTouchCapture | (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | ManipulationStarting | (Inherited from UIElement.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from UIElement.)
Public event | MouseEnter | (Inherited from UIElement.)
Public event | MouseLeave | (Inherited from UIElement.)
Public event | MouseLeftButtonDown | (Inherited from UIElement.)
Public event | MouseLeftButtonUp | (Inherited from UIElement.)
Public event | MouseMove | (Inherited from UIElement.)
Public event | MouseRightButtonDown | (Inherited from UIElement.)
Public event | MouseRightButtonUp | (Inherited from UIElement.)
Public event | MouseUp | (Inherited from UIElement.)
Public event | MouseWheel | (Inherited from UIElement.)
Public event | PreviewDragEnter | (Inherited from UIElement.)
Public event | PreviewDragLeave | (Inherited from UIElement.)
Public event | PreviewDragOver | (Inherited from UIElement.)
Public event | PreviewDrop | (Inherited from UIElement.)
Public event | PreviewGiveFeedback | (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewKeyDown | (Inherited from UIElement.)
Public event | PreviewKeyUp | (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | (Inherited from Control.)
Public event | PreviewMouseDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseMove | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseUp | (Inherited from UIElement.)
Public event | PreviewMouseWheel | (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | (Inherited from UIElement.)
Public event | PreviewStylusDown | (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | (Inherited from UIElement.)
Public event | PreviewStylusInRange | (Inherited from UIElement.)
Public event | PreviewStylusMove | (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | (Inherited from UIElement.)
Public event | PreviewStylusUp | (Inherited from UIElement.)
Public event | PreviewTextInput | (Inherited from UIElement.)
Public event | PreviewTouchDown | (Inherited from UIElement.)
Public event | PreviewTouchMove | (Inherited from UIElement.)
Public event | PreviewTouchUp | (Inherited from UIElement.)
Public event | QueryContinueDrag | (Inherited from UIElement.)
Public event | QueryCursor | (Inherited from UIElement.)
Public event | RequestBringIntoView | (Inherited from FrameworkElement.)
Public event | SizeChanged | (Inherited from FrameworkElement.)
Public event | SourceUpdated | (Inherited from FrameworkElement.)
Public event | StylusButtonDown | (Inherited from UIElement.)
Public event | StylusButtonUp | (Inherited from UIElement.)
Public event | StylusDown | (Inherited from UIElement.)
Public event | StylusEnter | (Inherited from UIElement.)
Public event | StylusInAirMove | (Inherited from UIElement.)
Public event | StylusInRange | (Inherited from UIElement.)
Public event | StylusLeave | (Inherited from UIElement.)
Public event | StylusMove | (Inherited from UIElement.)
Public event | StylusOutOfRange | (Inherited from UIElement.)
Public event | StylusSystemGesture | (Inherited from UIElement.)
Public event | StylusUp | (Inherited from UIElement.)
Public event | TargetUpdated | (Inherited from FrameworkElement.)
Public event | TextInput | (Inherited from UIElement.)
Public event | ToolTipClosing | (Inherited from FrameworkElement.)
Public event | ToolTipOpening | (Inherited from FrameworkElement.)
Public event | TouchDown | (Inherited from UIElement.)
Public event | TouchEnter | (Inherited from UIElement.)
Public event | TouchLeave | (Inherited from UIElement.)
Public event | TouchMove | (Inherited from UIElement.)
Public event | TouchUp | (Inherited from UIElement.)
Public event | Unloaded | (Inherited from FrameworkElement.)

See Also

TasksUserControl Class
Relogger.UserControlsAndWindows Namespace


WaitReloggerTaskUserControl Class

Logique d'interaction pour WaitReloggerTaskUserControl.xaml

Namespace: Relogger.UserControlsAndWindows
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public class WaitReloggerTaskUserControl : UserControl
Public Class WaitReloggerTaskUserControl _
    Inherits UserControl
public ref class WaitReloggerTaskUserControl : public UserControl

Inheritance Hierarchy

Object
DispatcherObject
DependencyObject
Visual
UIElement
FrameworkElement
Control
ContentControl
UserControl
Relogger.UserControlsAndWindows..::..WaitReloggerTaskUserControl

See Also

WaitReloggerTaskUserControl Members
Relogger.UserControlsAndWindows Namespace


WaitReloggerTaskUserControl Members

The WaitReloggerTaskUserControl type exposes the following members.

Constructors

 | Name | Description
Public method | WaitReloggerTaskUserControl | Initializes a new instance of the WaitReloggerTaskUserControl class.

Methods

 | Name | Description
Protected method | AddChild(System.Object) | (Inherited from ContentControl.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate,System.Boolean) | (Inherited from UIElement.)
Protected method | AddText(System.String) | (Inherited from ContentControl.)
Public method | AddToEventRoute(System.Windows.EventRoute,System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | AddVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock) | (Inherited from UIElement.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from FrameworkElement.)
Public method | Arrange(System.Windows.Rect) | (Inherited from UIElement.)
Protected method | ArrangeCore(System.Windows.Rect) | (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(System.Windows.Size) | (Inherited from Control.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline) | (Inherited from UIElement.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | BeginInit | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior,System.Boolean) | (Inherited from FrameworkElement.)
Public method | BringIntoView | (Inherited from FrameworkElement.)
Public method | BringIntoView(System.Windows.Rect) | (Inherited from FrameworkElement.)
Public method | CaptureMouse | (Inherited from UIElement.)
Public method | CaptureStylus | (Inherited from UIElement.)
Public method | CaptureTouch(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DispatcherObject.)
Public method | ClearValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | ClearValue(System.Windows.DependencyPropertyKey) | (Inherited from DependencyObject.)
Public method | CoerceValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | EndInit | (Inherited from FrameworkElement.)
Public method | Equals(System.Object) | (Inherited from DependencyObject.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindCommonVisualAncestor(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | FindName(System.String) | (Inherited from FrameworkElement.)
Public method | FindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from UIElement.)
Public method | GetAnimationBaseValue(System.Windows.DependencyProperty) | (Inherited from UIElement.)
Public method | GetBindingExpression(System.Windows.DependencyProperty) | (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from DependencyObject.)
Protected method | GetLayoutClip(System.Windows.Size) | (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | (Inherited from DependencyObject.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Protected method | GetVisualChild(System.Int32) | (Inherited from FrameworkElement.)
Protected method | HitTestCore(System.Windows.Media.PointHitTestParameters) | (Inherited from UIElement.)
Protected method | HitTestCore(System.Windows.Media.GeometryHitTestParameters) | (Inherited from UIElement.)
Public method | InputHitTest(System.Windows.Point) | (Inherited from UIElement.)
Public method | InvalidateArrange | (Inherited from UIElement.)
Public method | InvalidateMeasure | (Inherited from UIElement.)
Public method | InvalidateProperty(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | InvalidateVisual | (Inherited from UIElement.)
Public method | IsAncestorOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | IsDescendantOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | Measure(System.Windows.Size) | (Inherited from UIElement.)
Protected method | MeasureCore(System.Windows.Size) | (Inherited from FrameworkElement.)
Protected method | MeasureOverride(System.Windows.Size) | (Inherited from Control.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | MoveFocus(System.Windows.Input.TraversalRequest) | (Inherited from FrameworkElement.)
Protected method | OnAccessKey(System.Windows.Input.AccessKeyEventArgs) | (Inherited from UIElement.)
Public method | OnApplyTemplate | (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged(System.Windows.UIElement) | (Inherited from UIElement.)
Protected method | OnContentChanged(System.Object,System.Object) | (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged(System.String,System.String) | (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged(System.Windows.DataTemplate,System.Windows.DataTemplate) | (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged(System.Windows.Controls.DataTemplateSelector,System.Windows.Controls.DataTemplateSelector) | (Inherited from ContentControl.)
Protected method | OnContextMenuClosing(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | (Inherited from UserControl.)
Protected method | OnDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnGotFocus(System.Windows.RoutedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnGotMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnGotStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnGotTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnInitialized(System.EventArgs) | (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnLostFocus(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnLostStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnLostTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback(System.Windows.Input.ManipulationBoundaryFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationCompleted(System.Windows.Input.ManipulationCompletedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationDelta(System.Windows.Input.ManipulationDeltaEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting(System.Windows.Input.ManipulationInertiaStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarted(System.Windows.Input.ManipulationStartedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarting(System.Windows.Input.ManipulationStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseEnter(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeave(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnPreviewMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPropertyChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnQueryCursor(System.Windows.Input.QueryCursorEventArgs) | (Inherited from UIElement.)
Protected method | OnRender(System.Windows.Media.DrawingContext) | (Inherited from UIElement.)
Protected method | OnStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusEnter(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusLeave(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnTemplateChanged(System.Windows.Controls.ControlTemplate,System.Windows.Controls.ControlTemplate) | (Inherited from Control.)
Protected method | OnTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnToolTipClosing(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchEnter(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchLeave(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Public method | PointFromScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PointToScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PredictFocus(System.Windows.Input.FocusNavigationDirection) | (Inherited from FrameworkElement.)
Public method | RaiseEvent(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Public method | ReadLocalValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | RegisterName(System.String,System.Object) | (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | (Inherited from UIElement.)
Public method | ReleaseMouseCapture | (Inherited from UIElement.)
Public method | ReleaseStylusCapture | (Inherited from UIElement.)
Public method | ReleaseTouchCapture(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | RemoveHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Protected method | RemoveVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | SetBinding(System.Windows.DependencyProperty,System.Windows.Data.BindingBase) | (Inherited from FrameworkElement.)
Public method | SetBinding(System.Windows.DependencyProperty,System.String) | (Inherited from FrameworkElement.)
Public method | SetCurrentValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetResourceReference(System.Windows.DependencyProperty,System.Object) | (Inherited from FrameworkElement.)
Public method | SetValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetValue(System.Windows.DependencyPropertyKey,System.Object) | (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | (Inherited from UIElement.)
Public method | ShouldSerializeContent | (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | (Inherited from UIElement.)
Public method | ShouldSerializeResources | (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | (Inherited from FrameworkElement.)
Public method | ToString | (Inherited from Control.)
Public method | TransformToAncestor(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToAncestor(System.Windows.Media.Media3D.Visual3D) | (Inherited from Visual.)
Public method | TransformToDescendant(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToVisual(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TranslatePoint(System.Windows.Point,System.Windows.UIElement) | (Inherited from UIElement.)
Public method | TryFindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | UnregisterName(System.String) | (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | (Inherited from FrameworkElement.)
Public method | UpdateLayout | (Inherited from UIElement.)
Public method | VerifyAccess | (Inherited from DispatcherObject.)

Properties

 | Name | Description
Public property | ActualHeight | (Inherited from FrameworkElement.)
Public property | ActualWidth | (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
Public property | AreAnyTouchesOver | (Inherited from UIElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from FrameworkElement.)
Public property | BitmapEffect | (Inherited from UIElement.)
Public property | BitmapEffectInput | (Inherited from UIElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | (Inherited from UIElement.)
Public property | ClipToBounds | (Inherited from UIElement.)
Public property | CommandBindings | (Inherited from UIElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContentTemplate | (Inherited from ContentControl.)
Public property | ContentTemplateSelector | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from FrameworkElement.)
Public property | Cursor | (Inherited from FrameworkElement.)
Public property | DataContext | (Inherited from FrameworkElement.)
Public property | DependencyObjectType | (Inherited from DependencyObject.)
Public property | DesiredSize | (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DispatcherObject.)
Public property | Effect | (Inherited from UIElement.)
Public property | FlowDirection | (Inherited from FrameworkElement.)
Public property | Focusable | (Inherited from UIElement.)
Public property | FocusVisualStyle | (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from FrameworkElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasAnimatedProperties | (Inherited from UIElement.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | InputBindings | (Inherited from UIElement.)
Public property | InputScope | (Inherited from FrameworkElement.)
Public property | IsArrangeValid | (Inherited from UIElement.)
Public property | IsEnabled | (Inherited from UIElement.)
Protected property | IsEnabledCore | (Inherited from UIElement.)
Public property | IsFocused | (Inherited from UIElement.)
Public property | IsHitTestVisible | (Inherited from UIElement.)
Public property | IsInitialized | (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | (Inherited from UIElement.)
Public property | IsKeyboardFocused | (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | (Inherited from UIElement.)
Public property | IsLoaded | (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | (Inherited from UIElement.)
Public property | IsMeasureValid | (Inherited from UIElement.)
Public property | IsMouseCaptured | (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | (Inherited from UIElement.)
Public property | IsMouseOver | (Inherited from UIElement.)
Public property | IsSealed | (Inherited from DependencyObject.)
Public property | IsStylusCaptured | (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | (Inherited from UIElement.)
Public property | IsStylusOver | (Inherited from UIElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsVisible | (Inherited from UIElement.)
Public property | Language | (Inherited from FrameworkElement.)
Public property | LayoutTransform | (Inherited from FrameworkElement.)
Public property | Margin | (Inherited from FrameworkElement.)
Public property | MaxHeight | (Inherited from FrameworkElement.)
Public property | MaxWidth | (Inherited from FrameworkElement.)
Public property | MinHeight | (Inherited from FrameworkElement.)
Public property | MinWidth | (Inherited from FrameworkElement.)
Public property | Name | (Inherited from FrameworkElement.)
Public property | Opacity | (Inherited from UIElement.)
Public property | OpacityMask | (Inherited from UIElement.)
Public property | OverridesDefaultStyle | (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from FrameworkElement.)
Public property | PersistId | (Inherited from UIElement.)
Public property | RenderSize | (Inherited from UIElement.)
Public property | RenderTransform | (Inherited from UIElement.)
Public property | RenderTransformOrigin | (Inherited from UIElement.)
Public property | Resources | (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from UIElement.)
Public property | Style | (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | (Inherited from UIElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | Tag | (Inherited from FrameworkElement.)
Public property | Template | (Inherited from Control.)
Public property | TemplatedParent | (Inherited from FrameworkElement.)
Public property | ToolTip | (Inherited from FrameworkElement.)
Public property | TouchesCaptured | (Inherited from UIElement.)
Public property | TouchesCapturedWithin | (Inherited from UIElement.)
Public property | TouchesDirectlyOver | (Inherited from UIElement.)
Public property | TouchesOver | (Inherited from UIElement.)
Public property | Triggers | (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from UIElement.)
Public property | UseLayoutRounding | (Inherited from FrameworkElement.)
Public property | VerticalAlignment | (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | (Inherited from UIElement.)
Protected property | VisualChildrenCount | (Inherited from FrameworkElement.)
Protected property | VisualParent | (Inherited from Visual.)
Public property | Width | (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | ContextMenuClosing | (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | (Inherited from FrameworkElement.)
Public event | DataContextChanged | (Inherited from FrameworkElement.)
Public event | DragEnter | (Inherited from UIElement.)
Public event | DragLeave | (Inherited from UIElement.)
Public event | DragOver | (Inherited from UIElement.)
Public event | Drop | (Inherited from UIElement.)
Public event | FocusableChanged | (Inherited from UIElement.)
Public event | GiveFeedback | (Inherited from UIElement.)
Public event | GotFocus | (Inherited from UIElement.)
Public event | GotKeyboardFocus | (Inherited from UIElement.)
Public event | GotMouseCapture | (Inherited from UIElement.)
Public event | GotStylusCapture | (Inherited from UIElement.)
Public event | GotTouchCapture | (Inherited from UIElement.)
Public event | Initialized | (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsVisibleChanged | (Inherited from UIElement.)
Public event | KeyDown | (Inherited from UIElement.)
Public event | KeyUp | (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from UIElement.)
Public event | Loaded | (Inherited from FrameworkElement.)
Public event | LostFocus | (Inherited from UIElement.)
Public event | LostKeyboardFocus | (Inherited from UIElement.)
Public event | LostMouseCapture | (Inherited from UIElement.)
Public event | LostStylusCapture | (Inherited from UIElement.)
Public event | LostTouchCapture | (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | ManipulationStarting | (Inherited from UIElement.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from UIElement.)
Public event | MouseEnter | (Inherited from UIElement.)
Public event | MouseLeave | (Inherited from UIElement.)
Public event | MouseLeftButtonDown | (Inherited from UIElement.)
Public event | MouseLeftButtonUp | (Inherited from UIElement.)
Public event | MouseMove | (Inherited from UIElement.)
Public event | MouseRightButtonDown | (Inherited from UIElement.)
Public event | MouseRightButtonUp | (Inherited from UIElement.)
Public event | MouseUp | (Inherited from UIElement.)
Public event | MouseWheel | (Inherited from UIElement.)
Public event | PreviewDragEnter | (Inherited from UIElement.)
Public event | PreviewDragLeave | (Inherited from UIElement.)
Public event | PreviewDragOver | (Inherited from UIElement.)
Public event | PreviewDrop | (Inherited from UIElement.)
Public event | PreviewGiveFeedback | (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewKeyDown | (Inherited from UIElement.)
Public event | PreviewKeyUp | (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | (Inherited from Control.)
Public event | PreviewMouseDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseMove | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseUp | (Inherited from UIElement.)
Public event | PreviewMouseWheel | (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | (Inherited from UIElement.)
Public event | PreviewStylusDown | (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | (Inherited from UIElement.)
Public event | PreviewStylusInRange | (Inherited from UIElement.)
Public event | PreviewStylusMove | (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | (Inherited from UIElement.)
Public event | PreviewStylusUp | (Inherited from UIElement.)
Public event | PreviewTextInput | (Inherited from UIElement.)
Public event | PreviewTouchDown | (Inherited from UIElement.)
Public event | PreviewTouchMove | (Inherited from UIElement.)
Public event | PreviewTouchUp | (Inherited from UIElement.)
Public event | QueryContinueDrag | (Inherited from UIElement.)
Public event | QueryCursor | (Inherited from UIElement.)
Public event | RequestBringIntoView | (Inherited from FrameworkElement.)
Public event | SizeChanged | (Inherited from FrameworkElement.)
Public event | SourceUpdated | (Inherited from FrameworkElement.)
Public event | StylusButtonDown | (Inherited from UIElement.)
Public event | StylusButtonUp | (Inherited from UIElement.)
Public event | StylusDown | (Inherited from UIElement.)
Public event | StylusEnter | (Inherited from UIElement.)
Public event | StylusInAirMove | (Inherited from UIElement.)
Public event | StylusInRange | (Inherited from UIElement.)
Public event | StylusLeave | (Inherited from UIElement.)
Public event | StylusMove | (Inherited from UIElement.)
Public event | StylusOutOfRange | (Inherited from UIElement.)
Public event | StylusSystemGesture | (Inherited from UIElement.)
Public event | StylusUp | (Inherited from UIElement.)
Public event | TargetUpdated | (Inherited from FrameworkElement.)
Public event | TextInput | (Inherited from UIElement.)
Public event | ToolTipClosing | (Inherited from FrameworkElement.)
Public event | ToolTipOpening | (Inherited from FrameworkElement.)
Public event | TouchDown | (Inherited from UIElement.)
Public event | TouchEnter | (Inherited from UIElement.)
Public event | TouchLeave | (Inherited from UIElement.)
Public event | TouchMove | (Inherited from UIElement.)
Public event | TouchUp | (Inherited from UIElement.)
Public event | Unloaded | (Inherited from FrameworkElement.)

See Also

WaitReloggerTaskUserControl Class
Relogger.UserControlsAndWindows Namespace


WaitReloggerTaskUserControl Constructor

Initializes a new instance of the WaitReloggerTaskUserControl class.

Namespace: Relogger.UserControlsAndWindows
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public WaitReloggerTaskUserControl()
Public Sub New
public:
WaitReloggerTaskUserControl()

See Also

WaitReloggerTaskUserControl Class
Relogger.UserControlsAndWindows Namespace


WaitReloggerTaskUserControl Methods

The WaitReloggerTaskUserControl type exposes the following members.

Methods

 | Name | Description
Protected method | AddChild(System.Object) | (Inherited from ContentControl.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate,System.Boolean) | (Inherited from UIElement.)
Protected method | AddText(System.String) | (Inherited from ContentControl.)
Public method | AddToEventRoute(System.Windows.EventRoute,System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | AddVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock) | (Inherited from UIElement.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from FrameworkElement.)
Public method | Arrange(System.Windows.Rect) | (Inherited from UIElement.)
Protected method | ArrangeCore(System.Windows.Rect) | (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(System.Windows.Size) | (Inherited from Control.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline) | (Inherited from UIElement.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | BeginInit | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior,System.Boolean) | (Inherited from FrameworkElement.)
Public method | BringIntoView | (Inherited from FrameworkElement.)
Public method | BringIntoView(System.Windows.Rect) | (Inherited from FrameworkElement.)
Public method | CaptureMouse | (Inherited from UIElement.)
Public method | CaptureStylus | (Inherited from UIElement.)
Public method | CaptureTouch(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DispatcherObject.)
Public method | ClearValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | ClearValue(System.Windows.DependencyPropertyKey) | (Inherited from DependencyObject.)
Public method | CoerceValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | EndInit | (Inherited from FrameworkElement.)
Public method | Equals(System.Object) | (Inherited from DependencyObject.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindCommonVisualAncestor(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | FindName(System.String) | (Inherited from FrameworkElement.)
Public method | FindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from UIElement.)
Public method | GetAnimationBaseValue(System.Windows.DependencyProperty) | (Inherited from UIElement.)
Public method | GetBindingExpression(System.Windows.DependencyProperty) | (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from DependencyObject.)
Protected method | GetLayoutClip(System.Windows.Size) | (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | (Inherited from DependencyObject.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Protected method | GetVisualChild(System.Int32) | (Inherited from FrameworkElement.)
Protected method | HitTestCore(System.Windows.Media.PointHitTestParameters) | (Inherited from UIElement.)
Protected method | HitTestCore(System.Windows.Media.GeometryHitTestParameters) | (Inherited from UIElement.)
Public method | InputHitTest(System.Windows.Point) | (Inherited from UIElement.)
Public method | InvalidateArrange | (Inherited from UIElement.)
Public method | InvalidateMeasure | (Inherited from UIElement.)
Public method | InvalidateProperty(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | InvalidateVisual | (Inherited from UIElement.)
Public method | IsAncestorOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | IsDescendantOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | Measure(System.Windows.Size) | (Inherited from UIElement.)
Protected method | MeasureCore(System.Windows.Size) | (Inherited from FrameworkElement.)
Protected method | MeasureOverride(System.Windows.Size) | (Inherited from Control.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | MoveFocus(System.Windows.Input.TraversalRequest) | (Inherited from FrameworkElement.)
Protected method | OnAccessKey(System.Windows.Input.AccessKeyEventArgs) | (Inherited from UIElement.)
Public method | OnApplyTemplate | (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged(System.Windows.UIElement) | (Inherited from UIElement.)
Protected method | OnContentChanged(System.Object,System.Object) | (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged(System.String,System.String) | (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged(System.Windows.DataTemplate,System.Windows.DataTemplate) | (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged(System.Windows.Controls.DataTemplateSelector,System.Windows.Controls.DataTemplateSelector) | (Inherited from ContentControl.)
Protected method | OnContextMenuClosing(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | (Inherited from UserControl.)
Protected method | OnDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnGotFocus(System.Windows.RoutedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnGotMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnGotStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnGotTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnInitialized(System.EventArgs) | (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnLostFocus(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnLostStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnLostTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback(System.Windows.Input.ManipulationBoundaryFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationCompleted(System.Windows.Input.ManipulationCompletedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationDelta(System.Windows.Input.ManipulationDeltaEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting(System.Windows.Input.ManipulationInertiaStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarted(System.Windows.Input.ManipulationStartedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarting(System.Windows.Input.ManipulationStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseEnter(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeave(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnPreviewMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPropertyChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnQueryCursor(System.Windows.Input.QueryCursorEventArgs) | (Inherited from UIElement.)
Protected method | OnRender(System.Windows.Media.DrawingContext) | (Inherited from UIElement.)
Protected method | OnStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusEnter(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusLeave(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnTemplateChanged(System.Windows.Controls.ControlTemplate,System.Windows.Controls.ControlTemplate) | (Inherited from Control.)
Protected method | OnTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnToolTipClosing(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchEnter(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchLeave(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Public method | PointFromScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PointToScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PredictFocus(System.Windows.Input.FocusNavigationDirection) | (Inherited from FrameworkElement.)
Public method | RaiseEvent(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Public method | ReadLocalValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | RegisterName(System.String,System.Object) | (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | (Inherited from UIElement.)
Public method | ReleaseMouseCapture | (Inherited from UIElement.)
Public method | ReleaseStylusCapture | (Inherited from UIElement.)
Public method | ReleaseTouchCapture(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | RemoveHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Protected method | RemoveVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | SetBinding(System.Windows.DependencyProperty,System.Windows.Data.BindingBase) | (Inherited from FrameworkElement.)
Public method | SetBinding(System.Windows.DependencyProperty,System.String) | (Inherited from FrameworkElement.)
Public method | SetCurrentValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetResourceReference(System.Windows.DependencyProperty,System.Object) | (Inherited from FrameworkElement.)
Public method | SetValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetValue(System.Windows.DependencyPropertyKey,System.Object) | (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | (Inherited from UIElement.)
Public method | ShouldSerializeContent | (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | (Inherited from UIElement.)
Public method | ShouldSerializeResources | (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | (Inherited from FrameworkElement.)
Public method | ToString | (Inherited from Control.)
Public method | TransformToAncestor(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToAncestor(System.Windows.Media.Media3D.Visual3D) | (Inherited from Visual.)
Public method | TransformToDescendant(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToVisual(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TranslatePoint(System.Windows.Point,System.Windows.UIElement) | (Inherited from UIElement.)
Public method | TryFindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | UnregisterName(System.String) | (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | (Inherited from FrameworkElement.)
Public method | UpdateLayout | (Inherited from UIElement.)
Public method | VerifyAccess | (Inherited from DispatcherObject.)

See Also

WaitReloggerTaskUserControl Class
Relogger.UserControlsAndWindows Namespace


WaitReloggerTaskUserControl Properties

The WaitReloggerTaskUserControl type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | (Inherited from FrameworkElement.)
Public property | ActualWidth | (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
Public property | AreAnyTouchesOver | (Inherited from UIElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from FrameworkElement.)
Public property | BitmapEffect | (Inherited from UIElement.)
Public property | BitmapEffectInput | (Inherited from UIElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | (Inherited from UIElement.)
Public property | ClipToBounds | (Inherited from UIElement.)
Public property | CommandBindings | (Inherited from UIElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContentTemplate | (Inherited from ContentControl.)
Public property | ContentTemplateSelector | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from FrameworkElement.)
Public property | Cursor | (Inherited from FrameworkElement.)
Public property | DataContext | (Inherited from FrameworkElement.)
Public property | DependencyObjectType | (Inherited from DependencyObject.)
Public property | DesiredSize | (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DispatcherObject.)
Public property | Effect | (Inherited from UIElement.)
Public property | FlowDirection | (Inherited from FrameworkElement.)
Public property | Focusable | (Inherited from UIElement.)
Public property | FocusVisualStyle | (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from FrameworkElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasAnimatedProperties | (Inherited from UIElement.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | InputBindings | (Inherited from UIElement.)
Public property | InputScope | (Inherited from FrameworkElement.)
Public property | IsArrangeValid | (Inherited from UIElement.)
Public property | IsEnabled | (Inherited from UIElement.)
Protected property | IsEnabledCore | (Inherited from UIElement.)
Public property | IsFocused | (Inherited from UIElement.)
Public property | IsHitTestVisible | (Inherited from UIElement.)
Public property | IsInitialized | (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | (Inherited from UIElement.)
Public property | IsKeyboardFocused | (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | (Inherited from UIElement.)
Public property | IsLoaded | (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | (Inherited from UIElement.)
Public property | IsMeasureValid | (Inherited from UIElement.)
Public property | IsMouseCaptured | (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | (Inherited from UIElement.)
Public property | IsMouseOver | (Inherited from UIElement.)
Public property | IsSealed | (Inherited from DependencyObject.)
Public property | IsStylusCaptured | (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | (Inherited from UIElement.)
Public property | IsStylusOver | (Inherited from UIElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsVisible | (Inherited from UIElement.)
Public property | Language | (Inherited from FrameworkElement.)
Public property | LayoutTransform | (Inherited from FrameworkElement.)
Public property | Margin | (Inherited from FrameworkElement.)
Public property | MaxHeight | (Inherited from FrameworkElement.)
Public property | MaxWidth | (Inherited from FrameworkElement.)
Public property | MinHeight | (Inherited from FrameworkElement.)
Public property | MinWidth | (Inherited from FrameworkElement.)
Public property | Name | (Inherited from FrameworkElement.)
Public property | Opacity | (Inherited from UIElement.)
Public property | OpacityMask | (Inherited from UIElement.)
Public property | OverridesDefaultStyle | (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from FrameworkElement.)
Public property | PersistId | (Inherited from UIElement.)
Public property | RenderSize | (Inherited from UIElement.)
Public property | RenderTransform | (Inherited from UIElement.)
Public property | RenderTransformOrigin | (Inherited from UIElement.)
Public property | Resources | (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from UIElement.)
Public property | Style | (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | (Inherited from UIElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | Tag | (Inherited from FrameworkElement.)
Public property | Template | (Inherited from Control.)
Public property | TemplatedParent | (Inherited from FrameworkElement.)
Public property | ToolTip | (Inherited from FrameworkElement.)
Public property | TouchesCaptured | (Inherited from UIElement.)
Public property | TouchesCapturedWithin | (Inherited from UIElement.)
Public property | TouchesDirectlyOver | (Inherited from UIElement.)
Public property | TouchesOver | (Inherited from UIElement.)
Public property | Triggers | (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from UIElement.)
Public property | UseLayoutRounding | (Inherited from FrameworkElement.)
Public property | VerticalAlignment | (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | (Inherited from UIElement.)
Protected property | VisualChildrenCount | (Inherited from FrameworkElement.)
Protected property | VisualParent | (Inherited from Visual.)
Public property | Width | (Inherited from FrameworkElement.)

See Also

WaitReloggerTaskUserControl Class
Relogger.UserControlsAndWindows Namespace


WaitReloggerTaskUserControl Events

The WaitReloggerTaskUserControl type exposes the following members.

Events

 | Name | Description
Public event | ContextMenuClosing | (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | (Inherited from FrameworkElement.)
Public event | DataContextChanged | (Inherited from FrameworkElement.)
Public event | DragEnter | (Inherited from UIElement.)
Public event | DragLeave | (Inherited from UIElement.)
Public event | DragOver | (Inherited from UIElement.)
Public event | Drop | (Inherited from UIElement.)
Public event | FocusableChanged | (Inherited from UIElement.)
Public event | GiveFeedback | (Inherited from UIElement.)
Public event | GotFocus | (Inherited from UIElement.)
Public event | GotKeyboardFocus | (Inherited from UIElement.)
Public event | GotMouseCapture | (Inherited from UIElement.)
Public event | GotStylusCapture | (Inherited from UIElement.)
Public event | GotTouchCapture | (Inherited from UIElement.)
Public event | Initialized | (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsVisibleChanged | (Inherited from UIElement.)
Public event | KeyDown | (Inherited from UIElement.)
Public event | KeyUp | (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from UIElement.)
Public event | Loaded | (Inherited from FrameworkElement.)
Public event | LostFocus | (Inherited from UIElement.)
Public event | LostKeyboardFocus | (Inherited from UIElement.)
Public event | LostMouseCapture | (Inherited from UIElement.)
Public event | LostStylusCapture | (Inherited from UIElement.)
Public event | LostTouchCapture | (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | ManipulationStarting | (Inherited from UIElement.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from UIElement.)
Public event | MouseEnter | (Inherited from UIElement.)
Public event | MouseLeave | (Inherited from UIElement.)
Public event | MouseLeftButtonDown | (Inherited from UIElement.)
Public event | MouseLeftButtonUp | (Inherited from UIElement.)
Public event | MouseMove | (Inherited from UIElement.)
Public event | MouseRightButtonDown | (Inherited from UIElement.)
Public event | MouseRightButtonUp | (Inherited from UIElement.)
Public event | MouseUp | (Inherited from UIElement.)
Public event | MouseWheel | (Inherited from UIElement.)
Public event | PreviewDragEnter | (Inherited from UIElement.)
Public event | PreviewDragLeave | (Inherited from UIElement.)
Public event | PreviewDragOver | (Inherited from UIElement.)
Public event | PreviewDrop | (Inherited from UIElement.)
Public event | PreviewGiveFeedback | (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewKeyDown | (Inherited from UIElement.)
Public event | PreviewKeyUp | (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | (Inherited from Control.)
Public event | PreviewMouseDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseMove | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseUp | (Inherited from UIElement.)
Public event | PreviewMouseWheel | (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | (Inherited from UIElement.)
Public event | PreviewStylusDown | (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | (Inherited from UIElement.)
Public event | PreviewStylusInRange | (Inherited from UIElement.)
Public event | PreviewStylusMove | (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | (Inherited from UIElement.)
Public event | PreviewStylusUp | (Inherited from UIElement.)
Public event | PreviewTextInput | (Inherited from UIElement.)
Public event | PreviewTouchDown | (Inherited from UIElement.)
Public event | PreviewTouchMove | (Inherited from UIElement.)
Public event | PreviewTouchUp | (Inherited from UIElement.)
Public event | QueryContinueDrag | (Inherited from UIElement.)
Public event | QueryCursor | (Inherited from UIElement.)
Public event | RequestBringIntoView | (Inherited from FrameworkElement.)
Public event | SizeChanged | (Inherited from FrameworkElement.)
Public event | SourceUpdated | (Inherited from FrameworkElement.)
Public event | StylusButtonDown | (Inherited from UIElement.)
Public event | StylusButtonUp | (Inherited from UIElement.)
Public event | StylusDown | (Inherited from UIElement.)
Public event | StylusEnter | (Inherited from UIElement.)
Public event | StylusInAirMove | (Inherited from UIElement.)
Public event | StylusInRange | (Inherited from UIElement.)
Public event | StylusLeave | (Inherited from UIElement.)
Public event | StylusMove | (Inherited from UIElement.)
Public event | StylusOutOfRange | (Inherited from UIElement.)
Public event | StylusSystemGesture | (Inherited from UIElement.)
Public event | StylusUp | (Inherited from UIElement.)
Public event | TargetUpdated | (Inherited from FrameworkElement.)
Public event | TextInput | (Inherited from UIElement.)
Public event | ToolTipClosing | (Inherited from FrameworkElement.)
Public event | ToolTipOpening | (Inherited from FrameworkElement.)
Public event | TouchDown | (Inherited from UIElement.)
Public event | TouchEnter | (Inherited from UIElement.)
Public event | TouchLeave | (Inherited from UIElement.)
Public event | TouchMove | (Inherited from UIElement.)
Public event | TouchUp | (Inherited from UIElement.)
Public event | Unloaded | (Inherited from FrameworkElement.)

See Also

WaitReloggerTaskUserControl Class
Relogger.UserControlsAndWindows Namespace


ZoneSelectWindow Class

Logique d'interaction pour ZoneSelectWindow.xaml

Namespace: Relogger.UserControlsAndWindows
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public class ZoneSelectWindow
Public Class ZoneSelectWindow
public ref class ZoneSelectWindow

Inheritance Hierarchy

Object
Relogger.UserControlsAndWindows..::..ZoneSelectWindow

See Also

ZoneSelectWindow Members
Relogger.UserControlsAndWindows Namespace


ZoneSelectWindow Members

The ZoneSelectWindow type exposes the following members.

Constructors

 | Name | Description
Public method | ZoneSelectWindow | Initializes a new instance of the ZoneSelectWindow class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

ZoneSelectWindow Class
Relogger.UserControlsAndWindows Namespace


ZoneSelectWindow Constructor

Initializes a new instance of the ZoneSelectWindow class.

Namespace: Relogger.UserControlsAndWindows
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public ZoneSelectWindow()
Public Sub New
public:
ZoneSelectWindow()

See Also

ZoneSelectWindow Class
Relogger.UserControlsAndWindows Namespace


ZoneSelectWindow Methods

The ZoneSelectWindow type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

ZoneSelectWindow Class
Relogger.UserControlsAndWindows Namespace


robotManager Namespace

Classes

 | Class | Description
Public class | LanguageExport | Class LanguageExport.
Public class | LanguageText | Class LanguageText.
Public class | robotManagerGlobalSetting | Class robotManagerGlobalSetting. Few settings saved in FilePath Implements the Settings
Public class | Translate | Class Translate. Manage program translate. XML translation files are in the folder "WRobot\Data\Lang\Translation.xml"


LanguageExport Class

Class LanguageExport.

Namespace: robotManager
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class LanguageExport
<SerializableAttribute> _
Public Class LanguageExport
[SerializableAttribute]
public ref class LanguageExport

Inheritance Hierarchy

Object
robotManager..::..LanguageExport

See Also

LanguageExport Members
robotManager Namespace


LanguageExport Members

The LanguageExport type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | TryGetValue | Tries the get value.

Fields

 | Name | Description
Public field | LanguageTexts | The language texts

See Also

LanguageExport Class
robotManager Namespace


LanguageExport Fields

The LanguageExport type exposes the following members.

Fields

 | Name | Description
Public field | LanguageTexts | The language texts

See Also

LanguageExport Class
robotManager Namespace


LanguageTexts Field

LanguageExport..::..LanguageTexts Field

The language texts

Namespace: robotManager
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public List<LanguageText> LanguageTexts
Public LanguageTexts As List(Of LanguageText)
public:
List<LanguageText^>^ LanguageTexts

See Also

LanguageExport Class
robotManager Namespace


LanguageExport Methods

The LanguageExport type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | TryGetValue | Tries the get value.

See Also

LanguageExport Class
robotManager Namespace


TryGetValue Method

LanguageExport..::..TryGetValue Method

Tries the get value.

Namespace: robotManager
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public bool TryGetValue(
    string original,
    out string translation
)
Public Function TryGetValue ( _
    original As String, _
    <OutAttribute> ByRef translation As String _
) As Boolean
public:
bool^ TryGetValue(
    String^ original,
    [OutAttribute] String^% translation
)

Parameters

original
Type: String
The original.
translation
Type: String %
The translation.

Return Value

true if XXXX, false otherwise.

See Also

LanguageExport Class
robotManager Namespace


LanguageText Class

Class LanguageText.

Namespace: robotManager
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class LanguageText
<SerializableAttribute> _
Public Class LanguageText
[SerializableAttribute]
public ref class LanguageText

Inheritance Hierarchy

Object
robotManager..::..LanguageText

See Also

LanguageText Members
robotManager Namespace


LanguageText Members

The LanguageText type exposes the following members.

Constructors

 | Name | Description
Public method | LanguageText()()()() | Initializes a new instance of the LanguageText class.
Public method | LanguageText(String, String) | Initializes a new instance of the LanguageText class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Original | Gets or sets the original.
Public property | Translation | Gets or sets the translation.

See Also

LanguageText Class
robotManager Namespace


LanguageText Constructor

Overload List

 | Name | Description
Public method | LanguageText()()()() | Initializes a new instance of the LanguageText class.
Public method | LanguageText(String, String) | Initializes a new instance of the LanguageText class.

See Also

LanguageText Class
LanguageText Members
robotManager Namespace


LanguageText Constructor

Initializes a new instance of the LanguageText class.

Namespace: robotManager
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public LanguageText()
Public Sub New
public:
LanguageText()

See Also

LanguageText Class
LanguageText Overload
robotManager Namespace


LanguageText Constructor (String, String)

Initializes a new instance of the LanguageText class.

Namespace: robotManager
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public LanguageText(
    string translation,
    string original
)
Public Sub New ( _
    translation As String, _
    original As String _
)
public:
LanguageText(
    String^ translation,
    String^ original
)

Parameters

translation
Type: String
The translation.
original
Type: String
The original.

See Also

LanguageText Class
LanguageText Overload
robotManager Namespace


LanguageText Methods

The LanguageText type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

LanguageText Class
robotManager Namespace


LanguageText Properties

The LanguageText type exposes the following members.

Properties

 | Name | Description
Public property | Original | Gets or sets the original.
Public property | Translation | Gets or sets the translation.

See Also

LanguageText Class
robotManager Namespace


Original Property

LanguageText..::..Original Property

Gets or sets the original.

Namespace: robotManager
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public string Original { get; set; }
Public Property Original As String
    Get
    Set
public:
property String^ Original {
    String^ get ();
    void set (String^ value);
}

Field Value

The original.

See Also

LanguageText Class
robotManager Namespace


Translation Property

LanguageText..::..Translation Property

Gets or sets the translation.

Namespace: robotManager
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public string Translation { get; set; }
Public Property Translation As String
    Get
    Set
public:
property String^ Translation {
    String^ get ();
    void set (String^ value);
}

Field Value

The translation.

See Also

LanguageText Class
robotManager Namespace


robotManagerGlobalSetting Class

Class robotManagerGlobalSetting. Few settings saved in FilePath Implements the Settings

Namespace: robotManager
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class robotManagerGlobalSetting : Settings
<SerializableAttribute> _
Public Class robotManagerGlobalSetting _
    Inherits Settings
[SerializableAttribute]
public ref class robotManagerGlobalSetting : public Settings

Inheritance Hierarchy

Object
robotManager.Helpful..::..Settings
robotManager..::..robotManagerGlobalSetting

See Also

robotManagerGlobalSetting Members
robotManager Namespace
robotManager.Helpful..::..Settings


robotManagerGlobalSetting Members

The robotManagerGlobalSetting type exposes the following members.

Methods

 | Name | Description
Protected method | ConfigWinForm | (Inherited from Settings.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
 | Load | Load settings from FilePath.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Save()()()() | Save settings to FilePath.
Protected method | Save(String) | Save to xml file (Inherited from Settings.)
Public method | ToForm | Converts to form. (Inherited from Settings.)
Public method | ToString | (Inherited from Object.)
Public method | ToStringFormat | Converts to stringformat. (Inherited from Settings.)

Fields

 | Name | Description
Public field | ArgsEnvironmentVariables | The arguments environment variables ArgsParser
Public field | CanProtectAgainstScreenshots | Protect against screenshots
Public field | debugCb | Show debug log
Public field | ErrorCb | Show error log
Public field | fightCb | Show fight log
Public field | ForceStaticEncryptKey | 0 to don't use, but if you use same bot settings files on several Windows installations/computers you can use static key to encrypt passwords (use by StringToEncryptString(String) EncryptStringToString(String))
Public field | HowLongDaysKeepLogFiles | How many days keep log files (in folder "Logs", after files are removed)
Public field | InstallDateTime | creation date
Public field | navigatorCb | Show navigator log
Public field | normalCb | Show normal log
Public field | SendErrorCb | Send error log
Public field | ShowMs | Log show milliseconds

Properties

Name | Description
CurrentSetting | Get or set the current setting.
FilePath | Get the file path (WRobot\Settings\RobotManagerGlobalSetting.xml).

See Also

robotManagerGlobalSetting Class
robotManager Namespace


robotManagerGlobalSetting Fields

The robotManagerGlobalSetting type exposes the following members.

Fields

 | Name | Description
Public field | ArgsEnvironmentVariables | The arguments environment variables ArgsParser
Public field | CanProtectAgainstScreenshots | Protect against screenshots
Public field | debugCb | Show debug log
Public field | ErrorCb | Show error log
Public field | fightCb | Show fight log
Public field | ForceStaticEncryptKey | 0 to don't use, but if you use same bot settings files on several Windows installations/computers you can use static key to encrypt passwords (use by StringToEncryptString(String) EncryptStringToString(String))
Public field | HowLongDaysKeepLogFiles | How many days keep log files (in folder "Logs", after files are removed)
Public field | InstallDateTime | creation date
Public field | navigatorCb | Show navigator log
Public field | normalCb | Show normal log
Public field | SendErrorCb | Send error log
Public field | ShowMs | Log show milliseconds

See Also

robotManagerGlobalSetting Class
robotManager Namespace


ArgsEnvironmentVariables Field

robotManagerGlobalSetting..::..ArgsEnvironmentVariables Field

The arguments environment variables ArgsParser

Namespace: robotManager
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public string ArgsEnvironmentVariables
Public ArgsEnvironmentVariables As String
public:
String^ ArgsEnvironmentVariables

See Also

robotManagerGlobalSetting Class
robotManager Namespace


CanProtectAgainstScreenshots Field

robotManagerGlobalSetting..::..CanProtectAgainstScreenshots Field

Protect against screenshots

Namespace: robotManager
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public bool CanProtectAgainstScreenshots
Public CanProtectAgainstScreenshots As Boolean
public:
bool^ CanProtectAgainstScreenshots

See Also

robotManagerGlobalSetting Class
robotManager Namespace


debugCb Field

robotManagerGlobalSetting..::..debugCb Field

Show debug log

Namespace: robotManager
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public bool debugCb
Public debugCb As Boolean
public:
bool^ debugCb

See Also

robotManagerGlobalSetting Class
robotManager Namespace


ErrorCb Field

robotManagerGlobalSetting..::..ErrorCb Field

Show error log

Namespace: robotManager
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public bool ErrorCb
Public ErrorCb As Boolean
public:
bool^ ErrorCb

See Also

robotManagerGlobalSetting Class
robotManager Namespace


fightCb Field

robotManagerGlobalSetting..::..fightCb Field

Show fight log

Namespace: robotManager
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public bool fightCb
Public fightCb As Boolean
public:
bool^ fightCb

See Also

robotManagerGlobalSetting Class
robotManager Namespace


ForceStaticEncryptKey Field

robotManagerGlobalSetting..::..ForceStaticEncryptKey Field

0 to don't use, but if you use same bot settings files on several Windows installations/computers you can use static key to encrypt passwords (use by StringToEncryptString(String) EncryptStringToString(String))

Namespace: robotManager
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public int ForceStaticEncryptKey
Public ForceStaticEncryptKey As Integer
public:
int^ ForceStaticEncryptKey

See Also

robotManagerGlobalSetting Class
robotManager Namespace


HowLongDaysKeepLogFiles Field

robotManagerGlobalSetting..::..HowLongDaysKeepLogFiles Field

How many days keep log files (in folder "Logs", after files are removed)

Namespace: robotManager
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public double HowLongDaysKeepLogFiles
Public HowLongDaysKeepLogFiles As Double
public:
double^ HowLongDaysKeepLogFiles

See Also

robotManagerGlobalSetting Class
robotManager Namespace


InstallDateTime Field

robotManagerGlobalSetting..::..InstallDateTime Field

creation date

Namespace: robotManager
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public DateTime InstallDateTime
Public InstallDateTime As DateTime
public:
DateTime^ InstallDateTime

See Also

robotManagerGlobalSetting Class
robotManager Namespace


navigatorCb Field

robotManagerGlobalSetting..::..navigatorCb Field

Show navigator log

Namespace: robotManager
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public bool navigatorCb
Public navigatorCb As Boolean
public:
bool^ navigatorCb

See Also

robotManagerGlobalSetting Class
robotManager Namespace


normalCb Field

robotManagerGlobalSetting..::..normalCb Field

Show normal log

Namespace: robotManager
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public bool normalCb
Public normalCb As Boolean
public:
bool^ normalCb

See Also

robotManagerGlobalSetting Class
robotManager Namespace


SendErrorCb Field

robotManagerGlobalSetting..::..SendErrorCb Field

Send error log

Namespace: robotManager
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public bool SendErrorCb
Public SendErrorCb As Boolean
public:
bool^ SendErrorCb

See Also

robotManagerGlobalSetting Class
robotManager Namespace


ShowMs Field

robotManagerGlobalSetting..::..ShowMs Field

Log show milliseconds

Namespace: robotManager
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public bool ShowMs
Public ShowMs As Boolean
public:
bool^ ShowMs

See Also

robotManagerGlobalSetting Class
robotManager Namespace


robotManagerGlobalSetting Methods

The robotManagerGlobalSetting type exposes the following members.

Methods

 | Name | Description
Protected method | ConfigWinForm | (Inherited from Settings.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
 | Load | Load settings from FilePath.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Save()()()() | Save settings to FilePath.
Protected method | Save(String) | Save to xml file (Inherited from Settings.)
Public method | ToForm | Converts to form. (Inherited from Settings.)
Public method | ToString | (Inherited from Object.)
Public method | ToStringFormat | Converts to stringformat. (Inherited from Settings.)

See Also

robotManagerGlobalSetting Class
robotManager Namespace


Load Method

robotManagerGlobalSetting..::..Load Method

Load settings from FilePath.

Namespace: robotManager
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static bool Load()
Public Shared Function Load As Boolean
public:
static bool^ Load()

Return Value

true if success, false otherwise.

See Also

robotManagerGlobalSetting Class
robotManager Namespace


Save Method

robotManagerGlobalSetting..::..Save Method

Overload List

 | Name | Description
Public method | Save()()()() | Save settings to FilePath.
Protected method | Save(String) | Save to xml file (Inherited from Settings.)

See Also

robotManagerGlobalSetting Class
robotManagerGlobalSetting Members
robotManager Namespace


Save Method

robotManagerGlobalSetting..::..Save Method

Save settings to FilePath.

Namespace: robotManager
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public bool Save()
Public Function Save As Boolean
public:
bool^ Save()

Return Value

true if success, false otherwise.

See Also

robotManagerGlobalSetting Class
robotManager Namespace


robotManagerGlobalSetting Properties

The robotManagerGlobalSetting type exposes the following members.

Properties

Name | Description
CurrentSetting | Get or set the current setting.
FilePath | Get the file path (WRobot\Settings\RobotManagerGlobalSetting.xml).

See Also

robotManagerGlobalSetting Class
robotManager Namespace


CurrentSetting Property

robotManagerGlobalSetting..::..CurrentSetting Property

Get or set the current setting.

Namespace: robotManager
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static robotManagerGlobalSetting CurrentSetting { get; set; }
Public Shared Property CurrentSetting As robotManagerGlobalSetting
    Get
    Set
public:
static property robotManagerGlobalSetting^ CurrentSetting {
    robotManagerGlobalSetting^ get ();
    void set (robotManagerGlobalSetting^ value);
}

Field Value

The current setting.

See Also

robotManagerGlobalSetting Class
robotManager Namespace


FilePath Property

robotManagerGlobalSetting..::..FilePath Property

Get the file path (WRobot\Settings\RobotManagerGlobalSetting.xml).

Namespace: robotManager
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static string FilePath { get; }
Public Shared ReadOnly Property FilePath As String
    Get
public:
static property String^ FilePath {
    String^ get ();
}

Field Value

The file path.

See Also

robotManagerGlobalSetting Class
robotManager Namespace


Translate Class

Class Translate. Manage program translate. XML translation files are in the folder "WRobot\Data\Lang\Translation.xml"

Namespace: robotManager
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static class Translate
Public NotInheritable Class Translate
public ref class Translate abstract sealed

Inheritance Hierarchy

Object
robotManager..::..Translate

See Also

Translate Members
robotManager Namespace


Translate Members

The Translate type exposes the following members.

Methods

Name | Description
Add | Add the specified id.
Get | Get the specified translated text by id.
Load | Load the specified translation file name (relative to folder "WRobot\Data\Lang\", use file name like "Translation.xml").
Reset | Reset default translation.

See Also

Translate Class
robotManager Namespace


Translate Methods

The Translate type exposes the following members.

Methods

Name | Description
Add | Add the specified id.
Get | Get the specified translated text by id.
Load | Load the specified translation file name (relative to folder "WRobot\Data\Lang\", use file name like "Translation.xml").
Reset | Reset default translation.

See Also

Translate Class
robotManager Namespace


Add Method

Translate..::..Add Method

Add the specified id.

Namespace: robotManager
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void Add(
    string id,
    string text
)
Public Shared Sub Add ( _
    id As String, _
    text As String _
)
public:
static void Add(
    String^ id,
    String^ text
)

Parameters

id
Type: String
The id.
text
Type: String
The text translated.

See Also

Translate Class
robotManager Namespace


Get Method

Translate..::..Get Method

Get the specified translated text by id.

Namespace: robotManager
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static string Get(
    string id
)
Public Shared Function Get ( _
    id As String _
) As String
public:
static String^ Get(
    String^ id
)

Parameters

id
Type: String
The id.

Return Value

translated text.

See Also

Translate Class
robotManager Namespace


Load Method

Translate..::..Load Method

Load the specified translation file name (relative to folder "WRobot\Data\Lang\", use file name like "Translation.xml").

Namespace: robotManager
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static bool Load(
    string fileName
)
Public Shared Function Load ( _
    fileName As String _
) As Boolean
public:
static bool^ Load(
    String^ fileName
)

Parameters

fileName
Type: String
Name of the file.

Return Value

true if success, false otherwise.

See Also

Translate Class
robotManager Namespace


Reset Method

Translate..::..Reset Method

Reset default translation.

Namespace: robotManager
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void Reset()
Public Shared Sub Reset
public:
static void Reset()

See Also

Translate Class
robotManager Namespace


robotManager.Events Namespace

Classes

 | Class | Description
Public class | Events | Class Events manager.
Public class | FiniteStateMachineEvents | Class FiniteStateMachineEvents. Fired by Engine
Public class | LoggingEvents | Class LoggingEvents. Fired by Logging
Public class | ProductEvents | Class ProductEvents. Fired by Products.

Delegates

 | Delegate | Description
Public delegate | CancelableHandler | Delegate CancelableHandler
Public delegate | FiniteStateMachineEvents..::..FSMEngineHandler | Delegate FSMEngineHandler
Public delegate | FiniteStateMachineEvents..::..FSMEngineStateCancelableHandler | Delegate FSMEngineStateCancelableHandler
Public delegate | FiniteStateMachineEvents..::..FSMEngineStateHandler | Delegate FSMEngineStateHandler
Public delegate | LoggingEvents..::..LogHandler | Delegate LogHandler
Public delegate | SimpleHandler | Delegate SimpleHandler
Public delegate | StringCancelableHandler | Delegate StringCancelableHandler
Public delegate | StringHandler | Delegate StringHandler


CancelableHandler Delegate

Delegate CancelableHandler

Namespace: robotManager.Events
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public delegate void CancelableHandler(
    CancelEventArgs cancelable
)
Public Delegate Sub CancelableHandler ( _
    cancelable As CancelEventArgs _
)
public delegate void CancelableHandler(
    CancelEventArgs^ cancelable
)

Parameters

cancelable
Type: CancelEventArgs
The CancelEventArgs instance containing the event data.

See Also

robotManager.Events Namespace


Events Class

Class Events manager.

Namespace: robotManager.Events
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static class Events
Public NotInheritable Class Events
public ref class Events abstract sealed

Inheritance Hierarchy

Object
robotManager.Events..::..Events

See Also

Events Members
robotManager.Events Namespace


Events Members

The Events type exposes the following members.

Methods

Name | Description
ClearEvents | Request cleaning of events (fire OnEventsClearRequest and OnEventsClearEnd). This is called by default when bot product is stopped.

Events

Name | Description
OnEventsClearEnd | Occurs when OnEventsClearRequest is done (called by ClearEvents()()()())
OnEventsClearRequest | Occurs when cleaning events is requested (called by ClearEvents()()()(), it is used by all events in Events and Events to detach automatically all events when stopping product.

See Also

Events Class
robotManager.Events Namespace


Events Methods

The Events type exposes the following members.

Methods

Name | Description
ClearEvents | Request cleaning of events (fire OnEventsClearRequest and OnEventsClearEnd). This is called by default when bot product is stopped.

See Also

Events Class
robotManager.Events Namespace


ClearEvents Method

Events..::..ClearEvents Method

Request cleaning of events (fire OnEventsClearRequest and OnEventsClearEnd). This is called by default when bot product is stopped.

Namespace: robotManager.Events
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void ClearEvents()
Public Shared Sub ClearEvents
public:
static void ClearEvents()

See Also

Events Class
robotManager.Events Namespace


Events Events

The Events type exposes the following members.

Events

Name | Description
OnEventsClearEnd | Occurs when OnEventsClearRequest is done (called by ClearEvents()()()())
OnEventsClearRequest | Occurs when cleaning events is requested (called by ClearEvents()()()(), it is used by all events in Events and Events to detach automatically all events when stopping product.

See Also

Events Class
robotManager.Events Namespace


OnEventsClearEnd Event

Events..::..OnEventsClearEnd Event

Occurs when OnEventsClearRequest is done (called by ClearEvents()()()())

Namespace: robotManager.Events
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static event SimpleHandler OnEventsClearEnd
Public Shared Event OnEventsClearEnd As SimpleHandler
public:
static  event SimpleHandler^ OnEventsClearEnd {
    void add (SimpleHandler^ value);
    void remove (SimpleHandler^ value);
}

See Also

Events Class
robotManager.Events Namespace


OnEventsClearRequest Event

Events..::..OnEventsClearRequest Event

Occurs when cleaning events is requested (called by ClearEvents()()()(), it is used by all events in Events and Events to detach automatically all events when stopping product.

Namespace: robotManager.Events
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static event SimpleHandler OnEventsClearRequest
Public Shared Event OnEventsClearRequest As SimpleHandler
public:
static  event SimpleHandler^ OnEventsClearRequest {
    void add (SimpleHandler^ value);
    void remove (SimpleHandler^ value);
}

See Also

Events Class
robotManager.Events Namespace


FiniteStateMachineEvents Class

Class FiniteStateMachineEvents. Fired by Engine

Namespace: robotManager.Events
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static class FiniteStateMachineEvents
Public NotInheritable Class FiniteStateMachineEvents
public ref class FiniteStateMachineEvents abstract sealed

Inheritance Hierarchy

Object
robotManager.Events..::..FiniteStateMachineEvents

See Also

FiniteStateMachineEvents Members
robotManager.Events Namespace


FiniteStateMachineEvents Members

The FiniteStateMachineEvents type exposes the following members.

Methods

Name Description

Events

Name | Description
OnAddState | Occurs when add state (AddState(State)).
OnAfterRunState | Occurs after run state (RunState(State)).
OnBeforeCheckIfNeedToRunState | Occurs before check if state need to run (RunState(State)).
OnRunState | Occurs when before to run state (RunState(State)).
OnStartEngine | Occurs when [on start engine].
OnStopEngine | Occurs when stop engine (StopEngine()()()()).

See Also

FiniteStateMachineEvents Class
robotManager.Events Namespace


FiniteStateMachineEvents Methods

The FiniteStateMachineEvents type exposes the following members.

Methods

Name Description

See Also

FiniteStateMachineEvents Class
robotManager.Events Namespace


FiniteStateMachineEvents Events

The FiniteStateMachineEvents type exposes the following members.

Events

Name | Description
OnAddState | Occurs when add state (AddState(State)).
OnAfterRunState | Occurs after run state (RunState(State)).
OnBeforeCheckIfNeedToRunState | Occurs before check if state need to run (RunState(State)).
OnRunState | Occurs when before to run state (RunState(State)).
OnStartEngine | Occurs when [on start engine].
OnStopEngine | Occurs when stop engine (StopEngine()()()()).

See Also

FiniteStateMachineEvents Class
robotManager.Events Namespace


OnAddState Event

FiniteStateMachineEvents..::..OnAddState Event

Occurs when add state (AddState(State)).

Namespace: robotManager.Events
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static event FiniteStateMachineEvents..::..FSMEngineStateCancelableHandler OnAddState
Public Shared Event OnAddState As FiniteStateMachineEvents..::..FSMEngineStateCancelableHandler
public:
static  event FiniteStateMachineEvents..::..FSMEngineStateCancelableHandler^ OnAddState {
    void add (FiniteStateMachineEvents..::..FSMEngineStateCancelableHandler^ value);
    void remove (FiniteStateMachineEvents..::..FSMEngineStateCancelableHandler^ value);
}

See Also

FiniteStateMachineEvents Class
robotManager.Events Namespace


OnAfterRunState Event

FiniteStateMachineEvents..::..OnAfterRunState Event

Occurs after run state (RunState(State)).

Namespace: robotManager.Events
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static event FiniteStateMachineEvents..::..FSMEngineStateHandler OnAfterRunState
Public Shared Event OnAfterRunState As FiniteStateMachineEvents..::..FSMEngineStateHandler
public:
static  event FiniteStateMachineEvents..::..FSMEngineStateHandler^ OnAfterRunState {
    void add (FiniteStateMachineEvents..::..FSMEngineStateHandler^ value);
    void remove (FiniteStateMachineEvents..::..FSMEngineStateHandler^ value);
}

See Also

FiniteStateMachineEvents Class
robotManager.Events Namespace


OnBeforeCheckIfNeedToRunState Event

FiniteStateMachineEvents..::..OnBeforeCheckIfNeedToRunState Event

Occurs before check if state need to run (RunState(State)).

Namespace: robotManager.Events
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static event FiniteStateMachineEvents..::..FSMEngineStateCancelableHandler OnBeforeCheckIfNeedToRunState
Public Shared Event OnBeforeCheckIfNeedToRunState As FiniteStateMachineEvents..::..FSMEngineStateCancelableHandler
public:
static  event FiniteStateMachineEvents..::..FSMEngineStateCancelableHandler^ OnBeforeCheckIfNeedToRunState {
    void add (FiniteStateMachineEvents..::..FSMEngineStateCancelableHandler^ value);
    void remove (FiniteStateMachineEvents..::..FSMEngineStateCancelableHandler^ value);
}

See Also

FiniteStateMachineEvents Class
robotManager.Events Namespace


OnRunState Event

FiniteStateMachineEvents..::..OnRunState Event

Occurs when before to run state (RunState(State)).

Namespace: robotManager.Events
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static event FiniteStateMachineEvents..::..FSMEngineStateCancelableHandler OnRunState
Public Shared Event OnRunState As FiniteStateMachineEvents..::..FSMEngineStateCancelableHandler
public:
static  event FiniteStateMachineEvents..::..FSMEngineStateCancelableHandler^ OnRunState {
    void add (FiniteStateMachineEvents..::..FSMEngineStateCancelableHandler^ value);
    void remove (FiniteStateMachineEvents..::..FSMEngineStateCancelableHandler^ value);
}

See Also

FiniteStateMachineEvents Class
robotManager.Events Namespace


OnStartEngine Event

FiniteStateMachineEvents..::..OnStartEngine Event

Occurs when [on start engine].

Namespace: robotManager.Events
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static event FiniteStateMachineEvents..::..FSMEngineHandler OnStartEngine
Public Shared Event OnStartEngine As FiniteStateMachineEvents..::..FSMEngineHandler
public:
static  event FiniteStateMachineEvents..::..FSMEngineHandler^ OnStartEngine {
    void add (FiniteStateMachineEvents..::..FSMEngineHandler^ value);
    void remove (FiniteStateMachineEvents..::..FSMEngineHandler^ value);
}

See Also

FiniteStateMachineEvents Class
robotManager.Events Namespace


OnStopEngine Event

FiniteStateMachineEvents..::..OnStopEngine Event

Occurs when stop engine (StopEngine()()()()).

Namespace: robotManager.Events
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static event FiniteStateMachineEvents..::..FSMEngineHandler OnStopEngine
Public Shared Event OnStopEngine As FiniteStateMachineEvents..::..FSMEngineHandler
public:
static  event FiniteStateMachineEvents..::..FSMEngineHandler^ OnStopEngine {
    void add (FiniteStateMachineEvents..::..FSMEngineHandler^ value);
    void remove (FiniteStateMachineEvents..::..FSMEngineHandler^ value);
}

See Also

FiniteStateMachineEvents Class
robotManager.Events Namespace


FiniteStateMachineEvents.FSMEngineHandler Delegate

FiniteStateMachineEvents..::..FSMEngineHandler Delegate

Delegate FSMEngineHandler

Namespace: robotManager.Events
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public delegate void FSMEngineHandler(
    Engine engine
)
Public Delegate Sub FSMEngineHandler ( _
    engine As Engine _
)
public delegate void FSMEngineHandler(
    Engine^ engine
)

Parameters

engine
Type: robotManager.FiniteStateMachine..::..Engine
The engine.

See Also

robotManager.Events Namespace


FiniteStateMachineEvents.FSMEngineStateCancelableHandler Delegate

FiniteStateMachineEvents..::..FSMEngineStateCancelableHandler Delegate

Delegate FSMEngineStateCancelableHandler

Namespace: robotManager.Events
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public delegate void FSMEngineStateCancelableHandler(
    Engine engine,
    State state,
    CancelEventArgs cancelable
)
Public Delegate Sub FSMEngineStateCancelableHandler ( _
    engine As Engine, _
    state As State, _
    cancelable As CancelEventArgs _
)
public delegate void FSMEngineStateCancelableHandler(
    Engine^ engine,
    State^ state,
    CancelEventArgs^ cancelable
)

Parameters

engine
Type: robotManager.FiniteStateMachine..::..Engine
The engine.
state
Type: robotManager.FiniteStateMachine..::..State
The state.
cancelable
Type: CancelEventArgs
The CancelEventArgs instance containing the event data.

See Also

robotManager.Events Namespace


FiniteStateMachineEvents.FSMEngineStateHandler Delegate

FiniteStateMachineEvents..::..FSMEngineStateHandler Delegate

Delegate FSMEngineStateHandler

Namespace: robotManager.Events
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public delegate void FSMEngineStateHandler(
    Engine engine,
    State state
)
Public Delegate Sub FSMEngineStateHandler ( _
    engine As Engine, _
    state As State _
)
public delegate void FSMEngineStateHandler(
    Engine^ engine,
    State^ state
)

Parameters

engine
Type: robotManager.FiniteStateMachine..::..Engine
The engine.
state
Type: robotManager.FiniteStateMachine..::..State
The state.

See Also

robotManager.Events Namespace


LoggingEvents Class

Class LoggingEvents. Fired by Logging

Namespace: robotManager.Events
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static class LoggingEvents
Public NotInheritable Class LoggingEvents
public ref class LoggingEvents abstract sealed

Inheritance Hierarchy

Object
robotManager.Events..::..LoggingEvents

See Also

LoggingEvents Members
robotManager.Events Namespace


LoggingEvents Members

The LoggingEvents type exposes the following members.

Methods

Name Description

Events

Name | Description
OnAddLog | Occurs when add log (OnChanged).
OnStatusChange | Occurs when status change (Status) (OnChangedStatus).

See Also

LoggingEvents Class
robotManager.Events Namespace


LoggingEvents Methods

The LoggingEvents type exposes the following members.

Methods

Name Description

See Also

LoggingEvents Class
robotManager.Events Namespace


LoggingEvents Events

The LoggingEvents type exposes the following members.

Events

Name | Description
OnAddLog | Occurs when add log (OnChanged).
OnStatusChange | Occurs when status change (Status) (OnChangedStatus).

See Also

LoggingEvents Class
robotManager.Events Namespace


OnAddLog Event

LoggingEvents..::..OnAddLog Event

Occurs when add log (OnChanged).

Namespace: robotManager.Events
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static event LoggingEvents..::..LogHandler OnAddLog
Public Shared Event OnAddLog As LoggingEvents..::..LogHandler
public:
static  event LoggingEvents..::..LogHandler^ OnAddLog {
    void add (LoggingEvents..::..LogHandler^ value);
    void remove (LoggingEvents..::..LogHandler^ value);
}

See Also

LoggingEvents Class
robotManager.Events Namespace


OnStatusChange Event

LoggingEvents..::..OnStatusChange Event

Occurs when status change (Status) (OnChangedStatus).

Namespace: robotManager.Events
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static event StringHandler OnStatusChange
Public Shared Event OnStatusChange As StringHandler
public:
static  event StringHandler^ OnStatusChange {
    void add (StringHandler^ value);
    void remove (StringHandler^ value);
}

See Also

LoggingEvents Class
robotManager.Events Namespace


LoggingEvents.LogHandler Delegate

LoggingEvents..::..LogHandler Delegate

Delegate LogHandler

Namespace: robotManager.Events
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public delegate void LogHandler(
    Logging..::..Log log
)
Public Delegate Sub LogHandler ( _
    log As Logging..::..Log _
)
public delegate void LogHandler(
    Logging..::..Log^ log
)

Parameters

log
Type: robotManager.Helpful..::..Logging..::..Log
The log.

See Also

robotManager.Events Namespace


ProductEvents Class

Class ProductEvents. Fired by Products.

Namespace: robotManager.Events
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static class ProductEvents
Public NotInheritable Class ProductEvents
public ref class ProductEvents abstract sealed

Inheritance Hierarchy

Object
robotManager.Events..::..ProductEvents

See Also

ProductEvents Members
robotManager.Events Namespace


ProductEvents Members

The ProductEvents type exposes the following members.

Methods

Name Description

Events

Name | Description
OnDisposeProduct | Occurs when dispose product (DisposeProduct()()()()).
OnProductLoaded | Occurs when product loaded (LoadProducts(String)).
OnProductPauseStarted | Occurs when product pause started (InPause).
OnProductPauseStopped | Occurs when product unpause (InPause).
OnProductRestarting | Occurs when product restarting (ProductRestart()()()()).
OnProductStarted | Occurs when product started (OnChangedIsStarted).
OnProductStarting | Occurs when product starting (ProductStart()()()()).
OnProductStopped | Occurs when product stopped (OnChangedIsStarted).
OnProductStopping | Occurs when product stopping (ProductStop()()()()).

See Also

ProductEvents Class
robotManager.Events Namespace


ProductEvents Methods

The ProductEvents type exposes the following members.

Methods

Name Description

See Also

ProductEvents Class
robotManager.Events Namespace


ProductEvents Events

The ProductEvents type exposes the following members.

Events

Name | Description
OnDisposeProduct | Occurs when dispose product (DisposeProduct()()()()).
OnProductLoaded | Occurs when product loaded (LoadProducts(String)).
OnProductPauseStarted | Occurs when product pause started (InPause).
OnProductPauseStopped | Occurs when product unpause (InPause).
OnProductRestarting | Occurs when product restarting (ProductRestart()()()()).
OnProductStarted | Occurs when product started (OnChangedIsStarted).
OnProductStarting | Occurs when product starting (ProductStart()()()()).
OnProductStopped | Occurs when product stopped (OnChangedIsStarted).
OnProductStopping | Occurs when product stopping (ProductStop()()()()).

See Also

ProductEvents Class
robotManager.Events Namespace


OnDisposeProduct Event

ProductEvents..::..OnDisposeProduct Event

Occurs when dispose product (DisposeProduct()()()()).

Namespace: robotManager.Events
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static event StringHandler OnDisposeProduct
Public Shared Event OnDisposeProduct As StringHandler
public:
static  event StringHandler^ OnDisposeProduct {
    void add (StringHandler^ value);
    void remove (StringHandler^ value);
}

See Also

ProductEvents Class
robotManager.Events Namespace


OnProductLoaded Event

ProductEvents..::..OnProductLoaded Event

Occurs when product loaded (LoadProducts(String)).

Namespace: robotManager.Events
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static event StringHandler OnProductLoaded
Public Shared Event OnProductLoaded As StringHandler
public:
static  event StringHandler^ OnProductLoaded {
    void add (StringHandler^ value);
    void remove (StringHandler^ value);
}

See Also

ProductEvents Class
robotManager.Events Namespace


OnProductPauseStarted Event

ProductEvents..::..OnProductPauseStarted Event

Occurs when product pause started (InPause).

Namespace: robotManager.Events
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static event StringHandler OnProductPauseStarted
Public Shared Event OnProductPauseStarted As StringHandler
public:
static  event StringHandler^ OnProductPauseStarted {
    void add (StringHandler^ value);
    void remove (StringHandler^ value);
}

See Also

ProductEvents Class
robotManager.Events Namespace


OnProductPauseStopped Event

ProductEvents..::..OnProductPauseStopped Event

Occurs when product unpause (InPause).

Namespace: robotManager.Events
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static event StringHandler OnProductPauseStopped
Public Shared Event OnProductPauseStopped As StringHandler
public:
static  event StringHandler^ OnProductPauseStopped {
    void add (StringHandler^ value);
    void remove (StringHandler^ value);
}

See Also

ProductEvents Class
robotManager.Events Namespace


OnProductRestarting Event

ProductEvents..::..OnProductRestarting Event

Occurs when product restarting (ProductRestart()()()()).

Namespace: robotManager.Events
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static event StringHandler OnProductRestarting
Public Shared Event OnProductRestarting As StringHandler
public:
static  event StringHandler^ OnProductRestarting {
    void add (StringHandler^ value);
    void remove (StringHandler^ value);
}

See Also

ProductEvents Class
robotManager.Events Namespace


OnProductStarted Event

ProductEvents..::..OnProductStarted Event

Occurs when product started (OnChangedIsStarted).

Namespace: robotManager.Events
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static event StringHandler OnProductStarted
Public Shared Event OnProductStarted As StringHandler
public:
static  event StringHandler^ OnProductStarted {
    void add (StringHandler^ value);
    void remove (StringHandler^ value);
}

See Also

ProductEvents Class
robotManager.Events Namespace


OnProductStarting Event

ProductEvents..::..OnProductStarting Event

Occurs when product starting (ProductStart()()()()).

Namespace: robotManager.Events
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static event StringHandler OnProductStarting
Public Shared Event OnProductStarting As StringHandler
public:
static  event StringHandler^ OnProductStarting {
    void add (StringHandler^ value);
    void remove (StringHandler^ value);
}

See Also

ProductEvents Class
robotManager.Events Namespace


OnProductStopped Event

ProductEvents..::..OnProductStopped Event

Occurs when product stopped (OnChangedIsStarted).

Namespace: robotManager.Events
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static event StringHandler OnProductStopped
Public Shared Event OnProductStopped As StringHandler
public:
static  event StringHandler^ OnProductStopped {
    void add (StringHandler^ value);
    void remove (StringHandler^ value);
}

See Also

ProductEvents Class
robotManager.Events Namespace


OnProductStopping Event

ProductEvents..::..OnProductStopping Event

Occurs when product stopping (ProductStop()()()()).

Namespace: robotManager.Events
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static event StringHandler OnProductStopping
Public Shared Event OnProductStopping As StringHandler
public:
static  event StringHandler^ OnProductStopping {
    void add (StringHandler^ value);
    void remove (StringHandler^ value);
}

See Also

ProductEvents Class
robotManager.Events Namespace


SimpleHandler Delegate

Delegate SimpleHandler

Namespace: robotManager.Events
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public delegate void SimpleHandler()
Public Delegate Sub SimpleHandler
public delegate void SimpleHandler()

See Also

robotManager.Events Namespace


StringCancelableHandler Delegate

Delegate StringCancelableHandler

Namespace: robotManager.Events
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public delegate void StringCancelableHandler(
    string str,
    CancelEventArgs cancelable
)
Public Delegate Sub StringCancelableHandler ( _
    str As String, _
    cancelable As CancelEventArgs _
)
public delegate void StringCancelableHandler(
    String^ str,
    CancelEventArgs^ cancelable
)

Parameters

str
Type: String
The string.
cancelable
Type: CancelEventArgs
The CancelEventArgs instance containing the event data.

See Also

robotManager.Events Namespace


StringHandler Delegate

Delegate StringHandler

Namespace: robotManager.Events
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public delegate void StringHandler(
    string str
)
Public Delegate Sub StringHandler ( _
    str As String _
)
public delegate void StringHandler(
    String^ str
)

Parameters

str
Type: String
The string.

See Also

robotManager.Events Namespace


robotManager.FiniteStateMachine Namespace

Classes

 | Class | Description
Public class | Engine | FSM Engine. The bot's behavior is mainly based on it.
Public class | State | State used with Engine. Don't forget to configure Priority and DisplayName (must be unique name)


Engine Class

FSM Engine. The bot's behavior is mainly based on it.

Namespace: robotManager.FiniteStateMachine
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public sealed class Engine
Public NotInheritable Class Engine
public ref class Engine sealed

Examples

C#
using System;
   using robotManager.FiniteStateMachine;

   namespace EngineSample
   {
       class Program
       {
           class Context
           {
               internal Engine Engine { get; set; }
               internal int I { get; set; }
           }

           #region States

           class EvenNumberState : State
           {
               internal EvenNumberState(Context c)
               {
                   Context = c;
               }
               Context Context { get; set; }

               public override bool NeedToRun
               {
                   get
                   {
                       return Context.I % 2 == 0; // return true if number is even
                   }
               }

               public override void Run()
               {
                   Console.WriteLine("Number is even: " + Context.I);
                   Context.I++;
               }
           }

           class OddNumberState : State
           {
               internal OddNumberState(Context c)
               {
                   Context = c;
               }
               Context Context { get; set; }

               public override bool NeedToRun
               {
                   get
                   {
                       return Context.I % 2 != 0; // return true if number is odd
                   }
               }

               public override void Run()
               {
                   Console.WriteLine("Number is odd: " + Context.I);
                   Context.I++;
               }
           }

           class FinishState : State
           {
               internal FinishState(Context c)
               {
                   Context = c;
               }
               Context Context { get; set; }

               public override bool NeedToRun
               {
                   get
                   {
                       return Context.I == 5;
                   }
               }

               public override void Run()
               {
                   Console.WriteLine("Finish: " + Context.I);
                   Context.Engine.StopEngine();
               }
           }

           class AlwaysTrueState : State
           {
               public override bool NeedToRun
               {
                   get
                   {
                       return true;
                   }
               }

               public override void Run()
               {
                   Console.WriteLine("AlwaysTrueState!");
               }
           }

           #endregion States

           static void Main(string[] args)
           {
               var c = new Context
               {
                   Engine = new Engine(),
                   I = 0
               };

               c.Engine.AddState(new FinishState(c) { Priority = 4 }); // if state.NeedToRun (c.I == 5) then state.Run and return to the state with the highest priority (this state) else check next state (OddNumberState)
               c.Engine.AddState(new OddNumberState(c) { Priority = 3 }); // if state.NeedToRun (c.I is odd) then state.Run and return to the state with the highest priority (FinishState) else check next state (EvenNumberState)
               c.Engine.AddState(new EvenNumberState(c) { Priority = 2 }); // ....
               c.Engine.AddState(new AlwaysTrueState() { Priority = 1 }); // should never be called, the number can be odd or even.

               c.Engine.StartEngine(25); // start engine in new thread

               Console.ReadKey();
           }
       }
   }

Inheritance Hierarchy

Object
robotManager.FiniteStateMachine..::..Engine

See Also

Engine Members
robotManager.FiniteStateMachine Namespace


Engine Members

The Engine type exposes the following members.

Constructors

 | Name | Description
Public method | Engine | Initializes a new instance of the Engine class.

Methods

 | Name | Description
Public method | AddState | Add state.
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Pulse | Pulses states list one time
Public method | RemoveStateByName | Remove state by name.
Public method | StartEngine | Starts the engine Pulse()()()() states list in loop in new thread.
Public method | StopEngine | Stops the engine (and abort thread).
Public method | ToString | (Inherited from Object.)

Fields

Name | Description
LaunchedStateTypeName | The launched states names list

Properties

 | Name | Description
Public property | Running | Gets a value indicating whether this Engine is running.
Public property | States | Gets the states list (to add state it is better to use AddState(State)).

See Also

Engine Class
robotManager.FiniteStateMachine Namespace


Engine Constructor

Initializes a new instance of the Engine class.

Namespace: robotManager.FiniteStateMachine
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public Engine(
    bool showStateInStatus
)
Public Sub New ( _
    showStateInStatus As Boolean _
)
public:
Engine(
    bool^ showStateInStatus
)

Parameters

showStateInStatus
Type: Boolean
if set to true show current state name in Status.

See Also

Engine Class
robotManager.FiniteStateMachine Namespace


Engine Fields

The Engine type exposes the following members.

Fields

Name | Description
LaunchedStateTypeName | The launched states names list

See Also

Engine Class
robotManager.FiniteStateMachine Namespace


LaunchedStateTypeName Field

Engine..::..LaunchedStateTypeName Field

The launched states names list

Namespace: robotManager.FiniteStateMachine
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static List<string> LaunchedStateTypeName
Public Shared LaunchedStateTypeName As List(Of String)
public:
static List<String^>^ LaunchedStateTypeName

See Also

Engine Class
robotManager.FiniteStateMachine Namespace


Engine Methods

The Engine type exposes the following members.

Methods

 | Name | Description
Public method | AddState | Add state.
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Pulse | Pulses states list one time
Public method | RemoveStateByName | Remove state by name.
Public method | StartEngine | Starts the engine Pulse()()()() states list in loop in new thread.
Public method | StopEngine | Stops the engine (and abort thread).
Public method | ToString | (Inherited from Object.)

See Also

Engine Class
robotManager.FiniteStateMachine Namespace


AddState Method

Engine..::..AddState Method

Add state.

Namespace: robotManager.FiniteStateMachine
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public void AddState(
    State tempState
)
Public Sub AddState ( _
    tempState As State _
)
public:
void AddState(
    State^ tempState
)

Parameters

tempState
Type: robotManager.FiniteStateMachine..::..State
state.

See Also

Engine Class
robotManager.FiniteStateMachine Namespace


Pulse Method

Engine..::..Pulse Method

Pulses states list one time

Namespace: robotManager.FiniteStateMachine
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public void Pulse()
Public Sub Pulse
public:
void Pulse()

See Also

Engine Class
robotManager.FiniteStateMachine Namespace


RemoveStateByName Method

Engine..::..RemoveStateByName Method

Remove state by name.

Namespace: robotManager.FiniteStateMachine
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public bool RemoveStateByName(
    string displayName
)
Public Function RemoveStateByName ( _
    displayName As String _
) As Boolean
public:
bool^ RemoveStateByName(
    String^ displayName
)

Parameters

displayName
Type: String
The display name.

Return Value

Boolean.

See Also

Engine Class
robotManager.FiniteStateMachine Namespace


StartEngine Method

Engine..::..StartEngine Method

Starts the engine Pulse()()()() states list in loop in new thread.

Namespace: robotManager.FiniteStateMachine
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public void StartEngine(
    int framesPerSecond,
    string threadName,
    bool ignoreIfAlreadyLaunched
)
Public Sub StartEngine ( _
    framesPerSecond As Integer, _
    threadName As String, _
    ignoreIfAlreadyLaunched As Boolean _
)
public:
void StartEngine(
    int^ framesPerSecond,
    String^ threadName,
    bool^ ignoreIfAlreadyLaunched
)

Parameters

framesPerSecond
Type: Int32
The frames per second.
threadName
Type: String
Name of thread
ignoreIfAlreadyLaunched
Type: Boolean
Ignore if already launched on other Engine

See Also

Engine Class
robotManager.FiniteStateMachine Namespace


StopEngine Method

Engine..::..StopEngine Method

Stops the engine (and abort thread).

Namespace: robotManager.FiniteStateMachine
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public void StopEngine()
Public Sub StopEngine
public:
void StopEngine()

See Also

Engine Class
robotManager.FiniteStateMachine Namespace


Engine Properties

The Engine type exposes the following members.

Properties

 | Name | Description
Public property | Running | Gets a value indicating whether this Engine is running.
Public property | States | Gets the states list (to add state it is better to use AddState(State)).

See Also

Engine Class
robotManager.FiniteStateMachine Namespace


Running Property

Engine..::..Running Property

Gets a value indicating whether this Engine is running.

Namespace: robotManager.FiniteStateMachine
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public bool Running { get; set; }
Public Property Running As Boolean
    Get
    Set
public:
property bool^ Running {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if running; otherwise, false .

See Also

Engine Class
robotManager.FiniteStateMachine Namespace


States Property

Engine..::..States Property

Gets the states list (to add state it is better to use AddState(State)).

Namespace: robotManager.FiniteStateMachine
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public List<State> States { get; set; }
Public Property States As List(Of State)
    Get
    Set
public:
property List<State^>^ States {
    List<State^>^ get ();
    void set (List<State^>^ value);
}

Field Value

The states.

See Also

Engine Class
robotManager.FiniteStateMachine Namespace


State Class

State used with Engine. Don't forget to configure Priority and DisplayName (must be unique name)

Namespace: robotManager.FiniteStateMachine
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public abstract class State : IComparable<State>,
    IComparer<State>
Public MustInherit Class State _
    Implements IComparable(Of State), IComparer(Of State)
public ref class State abstract : IComparable<State^>,
    IComparer<State^>

Inheritance Hierarchy

Object
robotManager.FiniteStateMachine..::..State

See Also

State Members
robotManager.FiniteStateMachine Namespace


State Members

The State type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs state.
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used.
Public property | DisplayName | Gets the display name (must be unique name).
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used.
Public property | Priority | Gets the priority (determine the order of execution by Engine).

See Also

State Class
robotManager.FiniteStateMachine Namespace


State Methods

The State type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs state.
Public method | ToString | (Inherited from Object.)

See Also

State Class
robotManager.FiniteStateMachine Namespace


Compare Method

State..::..Compare Method

Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.

Namespace: robotManager.FiniteStateMachine
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public int Compare(
    State x,
    State y
)
Public Function Compare ( _
    x As State, _
    y As State _
) As Integer
public:
int^ Compare(
    State^ x,
    State^ y
)

Parameters

x
Type: robotManager.FiniteStateMachine..::..State
The first object to compare.
y
Type: robotManager.FiniteStateMachine..::..State
The second object to compare.

Return Value

A signed integer that indicates the relative values of x and y, as shown in the following table.Value Meaning Less than zerox is less than y.Zerox equals y.Greater than zerox is greater than y.

See Also

State Class
robotManager.FiniteStateMachine Namespace


CompareTo Method

State..::..CompareTo Method

Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.

Namespace: robotManager.FiniteStateMachine
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public int CompareTo(
    State other
)
Public Function CompareTo ( _
    other As State _
) As Integer
public:
int^ CompareTo(
    State^ other
)

Parameters

other
Type: robotManager.FiniteStateMachine..::..State
An object to compare with this instance.

Return Value

A value that indicates the relative order of the objects being compared. The return value has these meanings: Value Meaning Less than zero This instance precedes other in the sort order. Zero This instance occurs in the same position in the sort order as other. Greater than zero This instance follows other in the sort order.

See Also

State Class
robotManager.FiniteStateMachine Namespace


Run Method

State..::..Run Method

Runs state.

Namespace: robotManager.FiniteStateMachine
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public void Run()
Public Sub Run
public:
void Run()

See Also

State Class
robotManager.FiniteStateMachine Namespace


State Properties

The State type exposes the following members.

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used.
Public property | DisplayName | Gets the display name (must be unique name).
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used.
Public property | Priority | Gets the priority (determine the order of execution by Engine).

See Also

State Class
robotManager.FiniteStateMachine Namespace


BeforeStates Property

State..::..BeforeStates Property

Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used.

Namespace: robotManager.FiniteStateMachine
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public virtual List<State> BeforeStates { get; }
Public Overridable ReadOnly Property BeforeStates As List(Of State)
    Get
public:
virtual property List<State^>^ BeforeStates {
    List<State^>^ get ();
}

Field Value

The before states.

See Also

State Class
robotManager.FiniteStateMachine Namespace


DisplayName Property

State..::..DisplayName Property

Gets the display name (must be unique name).

Namespace: robotManager.FiniteStateMachine
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public virtual string DisplayName { get; set; }
Public Overridable Property DisplayName As String
    Get
    Set
public:
virtual property String^ DisplayName {
    String^ get ();
    void set (String^ value);
}

Field Value

The display name.

See Also

State Class
robotManager.FiniteStateMachine Namespace


NeedToRun Property

State..::..NeedToRun Property

Indicate if Engine need to call method Run()()()().

Namespace: robotManager.FiniteStateMachine
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public bool NeedToRun { get; }
Public ReadOnly Property NeedToRun As Boolean
    Get
public:
property bool^ NeedToRun {
    bool^ get ();
}

Field Value

true if need to run; otherwise, false .

See Also

State Class
robotManager.FiniteStateMachine Namespace


NextStates Property

State..::..NextStates Property

Launch these states after Run()()()() this state, empty if not used.

Namespace: robotManager.FiniteStateMachine
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public virtual List<State> NextStates { get; }
Public Overridable ReadOnly Property NextStates As List(Of State)
    Get
public:
virtual property List<State^>^ NextStates {
    List<State^>^ get ();
}

Field Value

The next states.

See Also

State Class
robotManager.FiniteStateMachine Namespace


Priority Property

State..::..Priority Property

Gets the priority (determine the order of execution by Engine).

Namespace: robotManager.FiniteStateMachine
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public virtual int Priority { get; set; }
Public Overridable Property Priority As Integer
    Get
    Set
public:
virtual property int^ Priority {
    int^ get ();
    void set (int^ value);
}

Field Value

The priority.

See Also

State Class
robotManager.FiniteStateMachine Namespace


robotManager.Helpful Namespace

Classes

Class Description
Public class Args
Class Args.
Public class ArgsParser
Class ArgsParser. To facilitate the reading and the use of command line arguments (you can can parse command-line arguments normally (program.exe -arg1) or use the environment variable ArgsEnvironmentVariables with the Json code of the Args class)
Public class BinarySerializer
BinarySerializer. Save/Load binary file.
Public class CustomUrlProtocol
Class CustomUrlProtocol. No longer used by the bot, more info here https://docs.microsoft.com/en-us/previous-versions/windows/internet-explorer/ie-developer/platform-apis/aa767914(v=vs.85)?redirectedfrom=MSDN
Public class Display
Some functions of the Windows API to manage windows/screen
Public class Extensions
Class Extensions. Some useful class extensions.
Public class GraphicsExtensions
Class GraphicsExtensions.
Public class GZip
Class GZip.
Public class IniFile
Create a New INI file to store or load data
Public class Keyboard
Keyboard Manager
Public class KeyboardHook
Registers a hot key with Windows.

Examples

C#
KeyboardHook hookKeybindingsPause = new KeyboardHook();
hookKeybindingsPause.RegisterHotKey(ModifierKeys.Alt, Keys.X);
hookKeybindingsPause.KeyPressed += delegate(object sender, KeyPressedEventArgs args)
{
     Products.InPause = !Products.InPause;
};
 // ....
hookKeybindingsPause.Dispose();
Public class KeyPressedEventArgs
Event Args for the event that is fired after the hot key has been pressed.
Public class Logging
Class Logging. Methods to help log, user interface to show log is LoggingUserControl
Public class Logging..::..Log
Class Log.
Public class Logging..::..LoggingChangeEventArgs
Class LoggingChangeEventArgs. Implements the EventArgs
Public class Logging..::..StatusChangeEventArgs
Class StatusChangeEventArgs. Implements the EventArgs
Public class LuaBot
Class LuaBot. Methods to run lua code with access to all .net and bot API.

Examples

C#
local log = clr.robotManager.Helpful.Logging
local wowLua = clr.wManager.Wow.Helpers.Lua.Wow
local lua = clr.wManager.Wow.Helpers.Lua

local playerName = lua.LuaDoString('return GetUnitName("player")', clr.System.String, '') -- OR wowLua.GetUnitName("player")
local txt = 'Player name: ' .. playerName .. ' - WRobot version: ' .. clr.wManager.Information.Version
log.Write(txt);
clr.System.Windows.MessageBox.Show(txt)
Public class Math
Class Math.
Public class Mouse
Class Mouse.
Public class Others
Class Others. Several useful methods.
Public class RunCode
Class RunCode. Run C# and VB.net code from string.
Public class ScintillaStyles
Class ScintillaStyles.
Public class Settings
Class Settings. Used by bot to manage settings files.

Examples

C#
using System;
using System.IO;
using robotManager.Helpful;
using wManager.Wow.Helpers;
using wManager.Wow.ObjectManager;

[Serializable]
public class TestSetting : Settings
{
    public static TestSetting CurrentSetting { get; set; }

    private static string FilePath
    {
        get
        {
            // return path like "C:\WRobot\Settings\Test-NAME.REALMNAME.xml"
            return AdviserFilePathAndName("Test", ObjectManager.Me.Name + "." + Usefuls.RealmName);
        }
    }

    private TestSetting()
    {
        TestValue1 = true;
        TestValue2 = "test text";
    }

    public bool Save()
    {
        try
        {
            return Save(FilePath);
        }
        catch (Exception e)
        {
            Logging.WriteError("TestSetting > Save(): " + e);
            return false;
        }
    }

    public static bool Load()
    {
        try
        {
            if (File.Exists(FilePath))
            {
                CurrentSetting = Load<TestSetting>(FilePath);
                return true;
            }
            CurrentSetting = new TestSetting();
        }
        catch (Exception e)
        {
            Logging.WriteError("TestSetting > Load(): " + e);
        }
        return false;
    }

    public bool TestValue1 { get; set; }

    public string TestValue2  { get; set; }
}
Public class Timer
Class Timer.
Public class Utf8StringWriter
Class Utf8StringWriter. Implements the StringWriter
Public class Var
Class Var. Useful to store values for the session.

Examples

C#
Var.SetVar("VariableName", "Test value");
 // ...
string v = Var.GetVar<string>("VariableName");
System.Windows.Forms.MessageBox.Show(v);
Public class Vector3
Vector3 class
Public class XmlSerializer
XmlSerializer

Delegates

 | Delegate | Description
Public delegate | Logging..::..LoggingChangeEventHandler | Delegate LoggingChangeEventHandler
Public delegate | Logging..::..StatusChangeEventHandler | Delegate StatusChangeEventHandler

Enumerations

 | Enumeration | Description
Public enumeration | Logging..::..LogType | LogType
Public enumeration | ModifierKeys | The enumeration of possible modifiers.
Public enumeration | RunCode..::..CodeType | CodeType


Args Class

Class Args.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class Args
<SerializableAttribute> _
Public Class Args
[SerializableAttribute]
public ref class Args

Inheritance Hierarchy

Object
robotManager.Helpful..::..Args

See Also

Args Members
robotManager.Helpful Namespace


Args Members

The Args type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | AccountName | Game account name AccountName="WoW1"
Public field | AdditionalArgs | The additional arguments
Public field | AutoAttachAndLog | Automatically attach game process and connect to the bot server -AutoAttachAndLog
Public field | BattleNet | Game account mail (or name) BattleNet="my@mail.com"
Public field | BPHOOK | To use BP hook (if not enabled by default in your version) -bphook
Public field | Character | Game character name Character="MyName"
Public field | Dx | To use directx hook (if not enabled by default in your version) -dx
Public field | FightClass | Bot fightclass selected FightClass="fightclass.xml"
Public field | FightClassUI | To launch Fightclass creator (not launch bot) -fightclassui
Public field | LicenseKey | Bot license key to use LicenseKey="123456789"
Public field | LockFrame | To lock game frame (better responsiveness, but this option is activated by default) -lockframe
Public field | LogInject | Logging game injections (for debug) -LogInject
Public field | MinimiseOnStart | Minimize window on start -MinimiseOnStart
Public field | NoDx | To don't use directx hook (if enabled by default in your version) -nodx
Public field | NoFakeCallStack | To don't falsify call stack (when bot call game functions) -nofakecallstack
Public field | NoLockFrame | To don't lock game frame (lose reactivity) -nolockframe
Public field | Password | Game account password Password="*****"
Public field | ProcessId | Game process id ProcessId=1234
Public field | Product | Bot product selected Product="Grinder"
Public field | Profile | Product profile selected Profile="myprofile.xml"
Public field | ReloggerUI | To launch relogger creator (not launch bot) -reloggerui
Public field | Server | Game realmlist name Server="ServerName"
Public field | WaitTimeToRelog | The wait time (in seconds) to relog character after a disconnection WaitTimeToRelog=15

Properties

 | Name | Description
Public property | AutoStart | Gets a value indicating if automatically attach game, connect to the bot server and start bot product.
Public property | LogInWow | Gets a value indicating if automatically login in game.

See Also

Args Class
robotManager.Helpful Namespace


Args Fields

The Args type exposes the following members.

Fields

 | Name | Description
Public field | AccountName | Game account name AccountName="WoW1"
Public field | AdditionalArgs | The additional arguments
Public field | AutoAttachAndLog | Automatically attach game process and connect to the bot server -AutoAttachAndLog
Public field | BattleNet | Game account mail (or name) BattleNet="my@mail.com"
Public field | BPHOOK | To use BP hook (if not enabled by default in your version) -bphook
Public field | Character | Game character name Character="MyName"
Public field | Dx | To use directx hook (if not enabled by default in your version) -dx
Public field | FightClass | Bot fightclass selected FightClass="fightclass.xml"
Public field | FightClassUI | To launch Fightclass creator (not launch bot) -fightclassui
Public field | LicenseKey | Bot license key to use LicenseKey="123456789"
Public field | LockFrame | To lock game frame (better responsiveness, but this option is activated by default) -lockframe
Public field | LogInject | Logging game injections (for debug) -LogInject
Public field | MinimiseOnStart | Minimize window on start -MinimiseOnStart
Public field | NoDx | To don't use directx hook (if enabled by default in your version) -nodx
Public field | NoFakeCallStack | To don't falsify call stack (when bot call game functions) -nofakecallstack
Public field | NoLockFrame | To don't lock game frame (lose reactivity) -nolockframe
Public field | Password | Game account password Password="*****"
Public field | ProcessId | Game process id ProcessId=1234
Public field | Product | Bot product selected Product="Grinder"
Public field | Profile | Product profile selected Profile="myprofile.xml"
Public field | ReloggerUI | To launch relogger creator (not launch bot) -reloggerui
Public field | Server | Game realmlist name Server="ServerName"
Public field | WaitTimeToRelog | The wait time (in seconds) to relog character after a disconnection WaitTimeToRelog=15

See Also

Args Class
robotManager.Helpful Namespace


AccountName Field

Args..::..AccountName Field

Game account name AccountName="WoW1"

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public string AccountName
Public AccountName As String
public:
String^ AccountName

See Also

Args Class
robotManager.Helpful Namespace


AdditionalArgs Field

Args..::..AdditionalArgs Field

The additional arguments

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public string AdditionalArgs
Public AdditionalArgs As String
public:
String^ AdditionalArgs

See Also

Args Class
robotManager.Helpful Namespace


AutoAttachAndLog Field

Args..::..AutoAttachAndLog Field

Automatically attach game process and connect to the bot server -AutoAttachAndLog

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public bool AutoAttachAndLog
Public AutoAttachAndLog As Boolean
public:
bool^ AutoAttachAndLog

See Also

Args Class
robotManager.Helpful Namespace


BattleNet Field

Args..::..BattleNet Field

Game account mail (or name) BattleNet="my@mail.com"

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public string BattleNet
Public BattleNet As String
public:
String^ BattleNet

See Also

Args Class
robotManager.Helpful Namespace


BPHOOK Field

Args..::..BPHOOK Field

To use BP hook (if not enabled by default in your version) -bphook

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public bool BPHOOK
Public BPHOOK As Boolean
public:
bool^ BPHOOK

See Also

Args Class
robotManager.Helpful Namespace


Character Field

Args..::..Character Field

Game character name Character="MyName"

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public string Character
Public Character As String
public:
String^ Character

See Also

Args Class
robotManager.Helpful Namespace


Dx Field

Args..::..Dx Field

To use directx hook (if not enabled by default in your version) -dx

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public bool Dx
Public Dx As Boolean
public:
bool^ Dx

See Also

Args Class
robotManager.Helpful Namespace


FightClass Field

Args..::..FightClass Field

Bot fightclass selected FightClass="fightclass.xml"

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public string FightClass
Public FightClass As String
public:
String^ FightClass

See Also

Args Class
robotManager.Helpful Namespace


FightClassUI Field

Args..::..FightClassUI Field

To launch Fightclass creator (not launch bot) -fightclassui

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public bool FightClassUI
Public FightClassUI As Boolean
public:
bool^ FightClassUI

See Also

Args Class
robotManager.Helpful Namespace


LicenseKey Field

Args..::..LicenseKey Field

Bot license key to use LicenseKey="123456789"

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public string LicenseKey
Public LicenseKey As String
public:
String^ LicenseKey

See Also

Args Class
robotManager.Helpful Namespace


LockFrame Field

Args..::..LockFrame Field

To lock game frame (better responsiveness, but this option is activated by default) -lockframe

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public bool LockFrame
Public LockFrame As Boolean
public:
bool^ LockFrame

See Also

Args Class
robotManager.Helpful Namespace


LogInject Field

Args..::..LogInject Field

Logging game injections (for debug) -LogInject

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public bool LogInject
Public LogInject As Boolean
public:
bool^ LogInject

See Also

Args Class
robotManager.Helpful Namespace


MinimiseOnStart Field

Args..::..MinimiseOnStart Field

Minimize window on start -MinimiseOnStart

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public bool MinimiseOnStart
Public MinimiseOnStart As Boolean
public:
bool^ MinimiseOnStart

See Also

Args Class
robotManager.Helpful Namespace


NoDx Field

Args..::..NoDx Field

To don't use directx hook (if enabled by default in your version) -nodx

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public bool NoDx
Public NoDx As Boolean
public:
bool^ NoDx

See Also

Args Class
robotManager.Helpful Namespace


NoFakeCallStack Field

Args..::..NoFakeCallStack Field

To don't falsify call stack (when bot call game functions) -nofakecallstack

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public bool NoFakeCallStack
Public NoFakeCallStack As Boolean
public:
bool^ NoFakeCallStack

See Also

Args Class
robotManager.Helpful Namespace


NoLockFrame Field

Args..::..NoLockFrame Field

To don't lock game frame (lose reactivity) -nolockframe

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public bool NoLockFrame
Public NoLockFrame As Boolean
public:
bool^ NoLockFrame

See Also

Args Class
robotManager.Helpful Namespace


Password Field

Args..::..Password Field

Game account password Password="*****"

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public string Password
Public Password As String
public:
String^ Password

See Also

Args Class
robotManager.Helpful Namespace


ProcessId Field

Args..::..ProcessId Field

Game process id ProcessId=1234

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public int ProcessId
Public ProcessId As Integer
public:
int^ ProcessId

See Also

Args Class
robotManager.Helpful Namespace


Product Field

Args..::..Product Field

Bot product selected Product="Grinder"

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public string Product
Public Product As String
public:
String^ Product

See Also

Args Class
robotManager.Helpful Namespace


Profile Field

Args..::..Profile Field

Product profile selected Profile="myprofile.xml"

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public string Profile
Public Profile As String
public:
String^ Profile

See Also

Args Class
robotManager.Helpful Namespace


ReloggerUI Field

Args..::..ReloggerUI Field

To launch relogger creator (not launch bot) -reloggerui

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public bool ReloggerUI
Public ReloggerUI As Boolean
public:
bool^ ReloggerUI

See Also

Args Class
robotManager.Helpful Namespace


Server Field

Args..::..Server Field

Game realmlist name Server="ServerName"

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public string Server
Public Server As String
public:
String^ Server

See Also

Args Class
robotManager.Helpful Namespace


WaitTimeToRelog Field

Args..::..WaitTimeToRelog Field

The wait time (in seconds) to relog character after a disconnection WaitTimeToRelog=15

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public int WaitTimeToRelog
Public WaitTimeToRelog As Integer
public:
int^ WaitTimeToRelog

See Also

Args Class
robotManager.Helpful Namespace


Args Methods

The Args type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Args Class
robotManager.Helpful Namespace


Args Properties

The Args type exposes the following members.

Properties

 | Name | Description
Public property | AutoStart | Gets a value indicating if automatically attach game, connect to the bot server and start bot product.
Public property | LogInWow | Gets a value indicating if automatically login in game.

See Also

Args Class
robotManager.Helpful Namespace


AutoStart Property

Args..::..AutoStart Property

Gets a value indicating if automatically attach game, connect to the bot server and start bot product.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public bool AutoStart { get; }
Public ReadOnly Property AutoStart As Boolean
    Get
public:
property bool^ AutoStart {
    bool^ get ();
}

See Also

Args Class
robotManager.Helpful Namespace


LogInWow Property

Args..::..LogInWow Property

Gets a value indicating if automatically login in game.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public bool LogInWow { get; }
Public ReadOnly Property LogInWow As Boolean
    Get
public:
property bool^ LogInWow {
    bool^ get ();
}

See Also

Args Class
robotManager.Helpful Namespace


ArgsParser Class

Class ArgsParser. To facilitate the reading and the use of command line arguments (you can can parse command-line arguments normally (program.exe -arg1) or use the environment variable ArgsEnvironmentVariables with the Json code of the Args class)

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static class ArgsParser
Public NotInheritable Class ArgsParser
public ref class ArgsParser abstract sealed

Inheritance Hierarchy

Object
robotManager.Helpful..::..ArgsParser

See Also

ArgsParser Members
robotManager.Helpful Namespace


ArgsParser Members

The ArgsParser type exposes the following members.

Methods

Name | Description
ExistArg | Check if argument is present.
GetArgValue | Gets the argument value.

Fields

Name | Description
Args | The arguments (initialized at startup, GetCommandLineArgs used).
GetArgs | Get arguments parsed (initialized at startup).

See Also

ArgsParser Class
robotManager.Helpful Namespace


ArgsParser Fields

The ArgsParser type exposes the following members.

Fields

Name | Description
Args | The arguments (initialized at startup, GetCommandLineArgs used).
GetArgs | Get arguments parsed (initialized at startup).

See Also

ArgsParser Class
robotManager.Helpful Namespace


Args Field

ArgsParser..::..Args Field

The arguments (initialized at startup, GetCommandLineArgs used).

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static string[] Args
Public Shared Args As String()
public:
static array<String^>^ Args

See Also

ArgsParser Class
robotManager.Helpful Namespace


GetArgs Field

ArgsParser..::..GetArgs Field

Get arguments parsed (initialized at startup).

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static Args GetArgs
Public Shared GetArgs As Args
public:
static Args^ GetArgs

See Also

ArgsParser Class
robotManager.Helpful Namespace


ArgsParser Methods

The ArgsParser type exposes the following members.

Methods

Name | Description
ExistArg | Check if argument is present.
GetArgValue | Gets the argument value.

See Also

ArgsParser Class
robotManager.Helpful Namespace


ExistArg Method

ArgsParser..::..ExistArg Method

Check if argument is present.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static bool ExistArg(
    string argName
)
Public Shared Function ExistArg ( _
    argName As String _
) As Boolean
public:
static bool^ ExistArg(
    String^ argName
)

Parameters

argName
Type: String
Name of the argument.

Return Value

true if argument exist, false otherwise.

See Also

ArgsParser Class
robotManager.Helpful Namespace


GetArgValue Method

ArgsParser..::..GetArgValue Method

Gets the argument value.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static string GetArgValue(
    string argName
)
Public Shared Function GetArgValue ( _
    argName As String _
) As String
public:
static String^ GetArgValue(
    String^ argName
)

Parameters

argName
Type: String
Name of the argument.

Return Value

System.String.

See Also

ArgsParser Class
robotManager.Helpful Namespace


BinarySerializer Class

BinarySerializer. Save/Load binary file.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static class BinarySerializer
Public NotInheritable Class BinarySerializer
public ref class BinarySerializer abstract sealed

Inheritance Hierarchy

Object
robotManager.Helpful..::..BinarySerializer

See Also

BinarySerializer Members
robotManager.Helpful Namespace


BinarySerializer Members

The BinarySerializer type exposes the following members.

Methods

Name | Description
Deserialize<(Of <<'(T>)>>) | Deserializes the Binary to Class.
Serialize | Serializes the specified Class to binary file.

See Also

BinarySerializer Class
robotManager.Helpful Namespace


BinarySerializer Methods

The BinarySerializer type exposes the following members.

Methods

Name | Description
Deserialize<(Of <<'(T>)>>) | Deserializes the Binary to Class.
Serialize | Serializes the specified Class to binary file.

See Also

BinarySerializer Class
robotManager.Helpful Namespace


Deserialize(T) Method

BinarySerializer..::..Deserialize<(Of <(<'T>)>)> Method

Deserializes the Binary to Class.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static T Deserialize<T>(
    string path
)

Public Shared Function Deserialize(Of T) ( _
    path As String _
) As T
public:
generic<typename T>
static T Deserialize(
    String^ path
)

Type Parameters

T

Parameters

path
Type: String
The path.

Return Value

T.

See Also

BinarySerializer Class
robotManager.Helpful Namespace


Serialize Method

BinarySerializer..::..Serialize Method

Serializes the specified Class to binary file.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static bool Serialize(
    string path,
    Object object
)
Public Shared Function Serialize ( _
    path As String, _
    object As Object _
) As Boolean
public:
static bool^ Serialize(
    String^ path,
    Object^ object
)

Parameters

path
Type: String
The path.
object
Type: Object
The @object.

Return Value

Boolean.

See Also

BinarySerializer Class
robotManager.Helpful Namespace


CustomUrlProtocol Class

Class CustomUrlProtocol. No longer used by the bot, more info here https://docs.microsoft.com/en-us/previous-versions/windows/internet-explorer/ie-developer/platform-apis/aa767914(v=vs.85)?redirectedfrom=MSDN

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public class CustomUrlProtocol
Public Class CustomUrlProtocol
public ref class CustomUrlProtocol

Inheritance Hierarchy

Object
robotManager.Helpful..::..CustomUrlProtocol

See Also

CustomUrlProtocol Members
robotManager.Helpful Namespace


CustomUrlProtocol Members

The CustomUrlProtocol type exposes the following members.

Methods

 | Name | Description
 | CheckForProtocolMessage | Checks for protocol message.
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
 | RegisterUrlProtocol | Registers the URL protocol.
Public method | ToString | (Inherited from Object.)

See Also

CustomUrlProtocol Class
robotManager.Helpful Namespace


CustomUrlProtocol Methods

The CustomUrlProtocol type exposes the following members.

Methods

 | Name | Description
 | CheckForProtocolMessage | Checks for protocol message.
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
 | RegisterUrlProtocol | Registers the URL protocol.
Public method | ToString | (Inherited from Object.)

See Also

CustomUrlProtocol Class
robotManager.Helpful Namespace


CheckForProtocolMessage Method

CustomUrlProtocol..::..CheckForProtocolMessage Method

Checks for protocol message.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static string CheckForProtocolMessage(
    string urlProtocol
)
Public Shared Function CheckForProtocolMessage ( _
    urlProtocol As String _
) As String
public:
static String^ CheckForProtocolMessage(
    String^ urlProtocol
)

Parameters

urlProtocol
Type: String
The URL protocol.

Return Value

System.String.

See Also

CustomUrlProtocol Class
robotManager.Helpful Namespace


RegisterUrlProtocol Method

CustomUrlProtocol..::..RegisterUrlProtocol Method

Registers the URL protocol.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void RegisterUrlProtocol(
    string urlProtocol,
    string pathExecutableFile
)
Public Shared Sub RegisterUrlProtocol ( _
    urlProtocol As String, _
    pathExecutableFile As String _
)
public:
static void RegisterUrlProtocol(
    String^ urlProtocol,
    String^ pathExecutableFile
)

Parameters

urlProtocol
Type: String
The URL protocol.
pathExecutableFile
Type: String
The path executable file.

See Also

CustomUrlProtocol Class
robotManager.Helpful Namespace


Display Class

Some functions of the Windows API to manage windows/screen

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static class Display
Public NotInheritable Class Display
public ref class Display abstract sealed

Inheritance Hierarchy

Object
robotManager.Helpful..::..Display

See Also

Display Members
robotManager.Helpful Namespace


Display Members

The Display type exposes the following members.

Methods

Name | Description
GetWindowHeight | Gets the height window.
GetWindowPosX | Gets window pos X.
GetWindowPosY | Gets window pos Y.
GetWindowWidth | Gets the width of the window.
ProtectAgainstScreenshots(Window, Boolean) | Protects the against screenshots.
ProtectAgainstScreenshots(Form, Boolean) | Protects the against screenshots.
ProtectAgainstScreenshots(IntPtr) | Protects the against screenshots.
ScreenshotWindow(IntPtr, String, ImageFormat, Int32, Int32) | Take a window screenshot and save to file.
ScreenshotWindow(IntPtr, String, Int32, Int32) | Take a window screenshot and save to .jpeg file.
ScreenshotWindow(IntPtr, Int32, Int32) | Take a window screenshot and return Image.
ScreenshotWindowToBytes(IntPtr, ImageFormat, Int32, Int32) | Take a window screenshot and return file.
ScreenshotWindowToBytes(IntPtr, Int32, Int32) | Take a window screenshot and return .jpeg file.
SetWindowPositionSize | Move and resize Windows.
ShowWindow | Show window (used when minimized to restore it).
WindowInTaskBarre | Window is in taskbar (minimized).
WndProc |

See Also

Display Class
robotManager.Helpful Namespace


Display Methods

The Display type exposes the following members.

Methods

Name | Description
GetWindowHeight | Gets the height window.
GetWindowPosX | Gets window pos X.
GetWindowPosY | Gets window pos Y.
GetWindowWidth | Gets the width of the window.
ProtectAgainstScreenshots(Window, Boolean) | Protects the against screenshots.
ProtectAgainstScreenshots(Form, Boolean) | Protects the against screenshots.
ProtectAgainstScreenshots(IntPtr) | Protects the against screenshots.
ScreenshotWindow(IntPtr, String, ImageFormat, Int32, Int32) | Take a window screenshot and save to file.
ScreenshotWindow(IntPtr, String, Int32, Int32) | Take a window screenshot and save to .jpeg file.
ScreenshotWindow(IntPtr, Int32, Int32) | Take a window screenshot and return Image.
ScreenshotWindowToBytes(IntPtr, ImageFormat, Int32, Int32) | Take a window screenshot and return file.
ScreenshotWindowToBytes(IntPtr, Int32, Int32) | Take a window screenshot and return .jpeg file.
SetWindowPositionSize | Move and resize Windows.
ShowWindow | Show window (used when minimized to restore it).
WindowInTaskBarre | Window is in taskbar (minimized).
WndProc |

See Also

Display Class
robotManager.Helpful Namespace


GetWindowHeight Method

Display..::..GetWindowHeight Method

Gets the height window.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static int GetWindowHeight(
    IntPtr mainWindowHandle
)
Public Shared Function GetWindowHeight ( _
    mainWindowHandle As IntPtr _
) As Integer
public:
static int^ GetWindowHeight(
    IntPtr^ mainWindowHandle
)

Parameters

mainWindowHandle
Type: IntPtr
The main window handle.

Field Value

The height of the window.

Return Value

System.Int32.

See Also

Display Class
robotManager.Helpful Namespace


GetWindowPosX Method

Display..::..GetWindowPosX Method

Gets window pos X.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static int GetWindowPosX(
    IntPtr mainWindowHandle
)
Public Shared Function GetWindowPosX ( _
    mainWindowHandle As IntPtr _
) As Integer
public:
static int^ GetWindowPosX(
    IntPtr^ mainWindowHandle
)

Parameters

mainWindowHandle
Type: IntPtr
The main window handle.

Return Value

System.Int32.

See Also

Display Class
robotManager.Helpful Namespace


GetWindowPosY Method

Display..::..GetWindowPosY Method

Gets window pos Y.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static int GetWindowPosY(
    IntPtr mainWindowHandle
)
Public Shared Function GetWindowPosY ( _
    mainWindowHandle As IntPtr _
) As Integer
public:
static int^ GetWindowPosY(
    IntPtr^ mainWindowHandle
)

Parameters

mainWindowHandle
Type: IntPtr
The main window handle.

Return Value

System.Int32.

See Also

Display Class
robotManager.Helpful Namespace


GetWindowWidth Method

Display..::..GetWindowWidth Method

Gets the width of the window.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static int GetWindowWidth(
    IntPtr mainWindowHandle
)
Public Shared Function GetWindowWidth ( _
    mainWindowHandle As IntPtr _
) As Integer
public:
static int^ GetWindowWidth(
    IntPtr^ mainWindowHandle
)

Parameters

mainWindowHandle
Type: IntPtr
The main window handle.

Field Value

The width of the window.

Return Value

System.Int32.

See Also

Display Class
robotManager.Helpful Namespace


ProtectAgainstScreenshots Method

Display..::..ProtectAgainstScreenshots Method

Overload List

Name | Description
ProtectAgainstScreenshots(Window, Boolean) | Protects the against screenshots.
ProtectAgainstScreenshots(Form, Boolean) | Protects the against screenshots.
ProtectAgainstScreenshots(IntPtr) | Protects the against screenshots.

See Also

Display Class
Display Members
robotManager.Helpful Namespace


ProtectAgainstScreenshots Method (Window, Boolean)

Display..::..ProtectAgainstScreenshots Method (Window, Boolean)

Protects the against screenshots.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static bool ProtectAgainstScreenshots(
    this Window wpfWindow,
    bool removeWindowTitle
)
<ExtensionAttribute> _
Public Shared Function ProtectAgainstScreenshots ( _
    wpfWindow As Window, _
    removeWindowTitle As Boolean _
) As Boolean
[ExtensionAttribute]
public:
static bool^ ProtectAgainstScreenshots(
    Window^ wpfWindow,
    bool^ removeWindowTitle
)

Parameters

wpfWindow
Type: Window
The WPF window to protect.
removeWindowTitle
Type: Boolean
if set to true empty window title.

See Also

Display Class
ProtectAgainstScreenshots Overload
robotManager.Helpful Namespace


ProtectAgainstScreenshots Method (Form, Boolean)

Display..::..ProtectAgainstScreenshots Method (Form, Boolean)

Protects the against screenshots.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static bool ProtectAgainstScreenshots(
    this Form winForm,
    bool removeWindowTitle
)
<ExtensionAttribute> _
Public Shared Function ProtectAgainstScreenshots ( _
    winForm As Form, _
    removeWindowTitle As Boolean _
) As Boolean
[ExtensionAttribute]
public:
static bool^ ProtectAgainstScreenshots(
    Form^ winForm,
    bool^ removeWindowTitle
)

Parameters

winForm
Type: Form
The window form.
removeWindowTitle
Type: Boolean
if set to true empty window title.

See Also

Display Class
ProtectAgainstScreenshots Overload
robotManager.Helpful Namespace


ProtectAgainstScreenshots Method (IntPtr)

Display..::..ProtectAgainstScreenshots Method (IntPtr)

Protects the against screenshots.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static bool ProtectAgainstScreenshots(
    IntPtr windowsHandle
)
Public Shared Function ProtectAgainstScreenshots ( _
    windowsHandle As IntPtr _
) As Boolean
public:
static bool^ ProtectAgainstScreenshots(
    IntPtr^ windowsHandle
)

Parameters

windowsHandle
Type: IntPtr
The windows handle.

See Also

Display Class
ProtectAgainstScreenshots Overload
robotManager.Helpful Namespace


ScreenshotWindow Method

Display..::..ScreenshotWindow Method

Overload List

Name | Description
ScreenshotWindow(IntPtr, String, ImageFormat, Int32, Int32) | Take a window screenshot and save to file.
ScreenshotWindow(IntPtr, String, Int32, Int32) | Take a window screenshot and save to .jpeg file.
ScreenshotWindow(IntPtr, Int32, Int32) | Take a window screenshot and return Image.

See Also

Display Class
Display Members
robotManager.Helpful Namespace


ScreenshotWindow Method (IntPtr, String, ImageFormat, Int32, Int32)

Display..::..ScreenshotWindow Method (IntPtr, String, ImageFormat, Int32, Int32)

Take a window screenshot and save to file.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void ScreenshotWindow(
    IntPtr mainWindowHandle,
    string filename,
    ImageFormat format,
    int maxHeight,
    int maxWidth
)
Public Shared Sub ScreenshotWindow ( _
    mainWindowHandle As IntPtr, _
    filename As String, _
    format As ImageFormat, _
    maxHeight As Integer, _
    maxWidth As Integer _
)
public:
static void ScreenshotWindow(
    IntPtr^ mainWindowHandle,
    String^ filename,
    ImageFormat^ format,
    int^ maxHeight,
    int^ maxWidth
)

Parameters

mainWindowHandle
Type: IntPtr
The main window handle.
filename
Type: String
The file path.
format
Type: ImageFormat
The format.
maxHeight
Type: Int32
The maximum height.
maxWidth
Type: Int32
The maximum width.

See Also

Display Class
ScreenshotWindow Overload
robotManager.Helpful Namespace


ScreenshotWindow Method (IntPtr, String, Int32, Int32)

Display..::..ScreenshotWindow Method (IntPtr, String, Int32, Int32)

Take a window screenshot and save to .jpeg file.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void ScreenshotWindow(
    IntPtr mainWindowHandle,
    string filename,
    int maxHeight,
    int maxWidth
)
Public Shared Sub ScreenshotWindow ( _
    mainWindowHandle As IntPtr, _
    filename As String, _
    maxHeight As Integer, _
    maxWidth As Integer _
)
public:
static void ScreenshotWindow(
    IntPtr^ mainWindowHandle,
    String^ filename,
    int^ maxHeight,
    int^ maxWidth
)

Parameters

mainWindowHandle
Type: IntPtr
The main window handle.
filename
Type: String
The filename.
maxHeight
Type: Int32
The maximum height.
maxWidth
Type: Int32
The maximum width.

See Also

Display Class
ScreenshotWindow Overload
robotManager.Helpful Namespace


ScreenshotWindow Method (IntPtr, Int32, Int32)

Display..::..ScreenshotWindow Method (IntPtr, Int32, Int32)

Take a window screenshot and return Image.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static Image ScreenshotWindow(
    IntPtr mainWindowHandle,
    int maxHeight,
    int maxWidth
)
Public Shared Function ScreenshotWindow ( _
    mainWindowHandle As IntPtr, _
    maxHeight As Integer, _
    maxWidth As Integer _
) As Image
public:
static Image^ ScreenshotWindow(
    IntPtr^ mainWindowHandle,
    int^ maxHeight,
    int^ maxWidth
)

Parameters

mainWindowHandle
Type: IntPtr
The main window handle.
maxHeight
Type: Int32
The maximum height.
maxWidth
Type: Int32
The maximum width.

Return Value

Image.

See Also

Display Class
ScreenshotWindow Overload
robotManager.Helpful Namespace


ScreenshotWindowToBytes Method

Display..::..ScreenshotWindowToBytes Method

Overload List

Name | Description
ScreenshotWindowToBytes(IntPtr, ImageFormat, Int32, Int32) | Take a window screenshot and return file.
ScreenshotWindowToBytes(IntPtr, Int32, Int32) | Take a window screenshot and return .jpeg file.

See Also

Display Class
Display Members
robotManager.Helpful Namespace


ScreenshotWindowToBytes Method (IntPtr, ImageFormat, Int32, Int32)

Display..::..ScreenshotWindowToBytes Method (IntPtr, ImageFormat, Int32, Int32)

Take a window screenshot and return file.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static byte[] ScreenshotWindowToBytes(
    IntPtr mainWindowHandle,
    ImageFormat format,
    int maxHeight,
    int maxWidth
)
Public Shared Function ScreenshotWindowToBytes ( _
    mainWindowHandle As IntPtr, _
    format As ImageFormat, _
    maxHeight As Integer, _
    maxWidth As Integer _
) As Byte()
public:
static array<unsigned char^>^ ScreenshotWindowToBytes(
    IntPtr^ mainWindowHandle,
    ImageFormat^ format,
    int^ maxHeight,
    int^ maxWidth
)

Parameters

mainWindowHandle
Type: IntPtr
The main window handle.
format
Type: ImageFormat
The format.
maxHeight
Type: Int32
The maximum height.
maxWidth
Type: Int32
The maximum width.

Return Value

System.Byte[].

See Also

Display Class
ScreenshotWindowToBytes Overload
robotManager.Helpful Namespace


ScreenshotWindowToBytes Method (IntPtr, Int32, Int32)

Display..::..ScreenshotWindowToBytes Method (IntPtr, Int32, Int32)

Take a window screenshot and return .jpeg file.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static byte[] ScreenshotWindowToBytes(
    IntPtr mainWindowHandle,
    int maxHeight,
    int maxWidth
)
Public Shared Function ScreenshotWindowToBytes ( _
    mainWindowHandle As IntPtr, _
    maxHeight As Integer, _
    maxWidth As Integer _
) As Byte()
public:
static array<unsigned char^>^ ScreenshotWindowToBytes(
    IntPtr^ mainWindowHandle,
    int^ maxHeight,
    int^ maxWidth
)

Parameters

mainWindowHandle
Type: IntPtr
The main window handle.
maxHeight
Type: Int32
The maximum height.
maxWidth
Type: Int32
The maximum width.

Return Value

System.Byte[].

See Also

Display Class
ScreenshotWindowToBytes Overload
robotManager.Helpful Namespace


SetWindowPositionSize Method

Display..::..SetWindowPositionSize Method

Move and resize Windows.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void SetWindowPositionSize(
    IntPtr mainWindowHandle,
    int x,
    int y,
    int width,
    int height
)
Public Shared Sub SetWindowPositionSize ( _
    mainWindowHandle As IntPtr, _
    x As Integer, _
    y As Integer, _
    width As Integer, _
    height As Integer _
)
public:
static void SetWindowPositionSize(
    IntPtr^ mainWindowHandle,
    int^ x,
    int^ y,
    int^ width,
    int^ height
)

Parameters

mainWindowHandle
Type: IntPtr
The main window handle.
x
Type: Int32
The new position x.
y
Type: Int32
The new position y.
width
Type: Int32
The new width.
height
Type: Int32
The new height.

See Also

Display Class
robotManager.Helpful Namespace


ShowWindow Method

Display..::..ShowWindow Method

Show window (used when minimized to restore it).

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void ShowWindow(
    IntPtr mainWindowHandle
)
Public Shared Sub ShowWindow ( _
    mainWindowHandle As IntPtr _
)
public:
static void ShowWindow(
    IntPtr^ mainWindowHandle
)

Parameters

mainWindowHandle
Type: IntPtr
The main window handle.

See Also

Display Class
robotManager.Helpful Namespace


WindowInTaskBarre Method

Display..::..WindowInTaskBarre Method

Window is in taskbar (minimized).

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static bool WindowInTaskBarre(
    IntPtr mainWindowHandle
)
Public Shared Function WindowInTaskBarre ( _
    mainWindowHandle As IntPtr _
) As Boolean
public:
static bool^ WindowInTaskBarre(
    IntPtr^ mainWindowHandle
)

Parameters

mainWindowHandle
Type: IntPtr
The main window handle.

See Also

Display Class
robotManager.Helpful Namespace


WndProc Method

Display..::..WndProc Method

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static IntPtr WndProc(
    IntPtr hwnd,
    int msg,
    IntPtr wParam,
    IntPtr lParam,
    ref bool handled
)
Public Shared Function WndProc ( _
    hwnd As IntPtr, _
    msg As Integer, _
    wParam As IntPtr, _
    lParam As IntPtr, _
    ByRef handled As Boolean _
) As IntPtr
public:
static IntPtr^ WndProc(
    IntPtr^ hwnd,
    int^ msg,
    IntPtr^ wParam,
    IntPtr^ lParam,
    bool^% handled
)

Parameters

hwnd
Type: IntPtr
msg
Type: Int32
wParam
Type: IntPtr
lParam
Type: IntPtr
handled
Type: Boolean %

See Also

Display Class
robotManager.Helpful Namespace


Extensions Class

Class Extensions. Some useful class extensions.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static class Extensions
Public NotInheritable Class Extensions
public ref class Extensions abstract sealed

Inheritance Hierarchy

Object
robotManager.Helpful..::..Extensions

See Also

Extensions Members
robotManager.Helpful Namespace


Extensions Members

The Extensions type exposes the following members.

Methods

Name | Description
GetMainThread | Gets the main thread of external process.
IsNotZero | Determines if the value is not zero.
IsScrolledToEnd | Determines whether wpf TextBoxBase is scrolled to bottom.
IsScrolledToTop | Determines whether is scrolled to top.
IsZero | Determines if the value is zero.
Replace(array<Byte>[]()[][], array<Byte>[]()[][], array<Byte>[]()[][]) | Replaces the specified bytes by others.
Replace(array<Byte>[]()[][], UInt64, UInt64) | Replaces the specified bytes by others.
Replace(array<Byte>[]()[][], Int64, Int64) | Replaces the specified bytes by others.
Replace(array<Byte>[]()[][], Int32, Int32) | Replaces the specified bytes by others.
Replace(array<Byte>[]()[][], UInt32, UInt32) | Replaces the specified bytes by others.
Replace(array<Byte>[]()[][], Int16, Int16) | Replaces the specified bytes by others.
Replace(array<Byte>[]()[][], UInt16, UInt16) | Replaces the specified bytes by others.
Replace(array<Byte>[]()[][], Single, Single) | Replaces the specified bytes by others.
Replace(array<Byte>[]()[][], Double, Double) | Replaces the specified bytes by others.
Replace(array<Byte>[]()[][], Byte, Byte) | Replaces the specified bytes by others.
ResumeAllThreads | Resumes all threads of external process.
ResumeThread | Resumes a thread.
Serialize<(Of <<'(T>)>>) | Serializes the specified class (to Xml).
Shuffle(String) | Shuffles the specified string.
Shuffle<(Of <<'(T>)>>)(IList<(Of <<'(T>)>>)) | Shuffles the specified list.
SuspendAllThreads | Suspends all threads of external process.
SuspendMainThread | Suspends the main thread of external process.
SuspendThread | Suspends the thread.
TerminateAllThreads | Terminates all threads of external process.
ToReadableAgeString | Converts to readable age (in years) string.
ToReadableString | Converts to readable string result like "1 day, 10 hours, 30 minutes, 42 seconds".
ToStringArray | Converts to string array (by line).
Translate(ContentControl) | Translates the specified ContentControl (translate with Translate).
Translate(TextBlock) | Translates the specified TextBlock (translate with Translate).

See Also

Extensions Class
robotManager.Helpful Namespace


Extensions Methods

The Extensions type exposes the following members.

Methods

Name | Description
GetMainThread | Gets the main thread of external process.
IsNotZero | Determines if the value is not zero.
IsScrolledToEnd | Determines whether wpf TextBoxBase is scrolled to bottom.
IsScrolledToTop | Determines whether is scrolled to top.
IsZero | Determines if the value is zero.
Replace(array<Byte>[]()[][], array<Byte>[]()[][], array<Byte>[]()[][]) | Replaces the specified bytes by others.
Replace(array<Byte>[]()[][], UInt64, UInt64) | Replaces the specified bytes by others.
Replace(array<Byte>[]()[][], Int64, Int64) | Replaces the specified bytes by others.
Replace(array<Byte>[]()[][], Int32, Int32) | Replaces the specified bytes by others.
Replace(array<Byte>[]()[][], UInt32, UInt32) | Replaces the specified bytes by others.
Replace(array<Byte>[]()[][], Int16, Int16) | Replaces the specified bytes by others.
Replace(array<Byte>[]()[][], UInt16, UInt16) | Replaces the specified bytes by others.
Replace(array<Byte>[]()[][], Single, Single) | Replaces the specified bytes by others.
Replace(array<Byte>[]()[][], Double, Double) | Replaces the specified bytes by others.
Replace(array<Byte>[]()[][], Byte, Byte) | Replaces the specified bytes by others.
ResumeAllThreads | Resumes all threads of external process.
ResumeThread | Resumes a thread.
Serialize<(Of <<'(T>)>>) | Serializes the specified class (to Xml).
Shuffle(String) | Shuffles the specified string.
Shuffle<(Of <<'(T>)>>)(IList<(Of <<'(T>)>>)) | Shuffles the specified list.
SuspendAllThreads | Suspends all threads of external process.
SuspendMainThread | Suspends the main thread of external process.
SuspendThread | Suspends the thread.
TerminateAllThreads | Terminates all threads of external process.
ToReadableAgeString | Converts to readable age (in years) string.
ToReadableString | Converts to readable string result like "1 day, 10 hours, 30 minutes, 42 seconds".
ToStringArray | Converts to string array (by line).
Translate(ContentControl) | Translates the specified ContentControl (translate with Translate).
Translate(TextBlock) | Translates the specified TextBlock (translate with Translate).

See Also

Extensions Class
robotManager.Helpful Namespace


GetMainThread Method

Extensions..::..GetMainThread Method

Gets the main thread of external process.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static ProcessThread GetMainThread(
    this Process process
)
<ExtensionAttribute> _
Public Shared Function GetMainThread ( _
    process As Process _
) As ProcessThread
[ExtensionAttribute]
public:
static ProcessThread^ GetMainThread(
    Process^ process
)

Parameters

process
Type: Process
The process.

Return Value

ProcessThread.

See Also

Extensions Class
robotManager.Helpful Namespace


IsNotZero Method

Extensions..::..IsNotZero Method

Determines if the value is not zero.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static bool IsNotZero(
    this ulong thisT
)
<ExtensionAttribute> _
Public Shared Function IsNotZero ( _
    thisT As ULong _
) As Boolean
[ExtensionAttribute]
public:
static bool^ IsNotZero(
    unsigned long long^ thisT
)

Parameters

thisT
Type: UInt64
The this t.

Return Value

true if the value is not zero; otherwise, false.

See Also

Extensions Class
robotManager.Helpful Namespace


IsScrolledToEnd Method

Extensions..::..IsScrolledToEnd Method

Determines whether wpf TextBoxBase is scrolled to bottom.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static bool IsScrolledToEnd(
    this TextBoxBase textBoxBase
)
<ExtensionAttribute> _
Public Shared Function IsScrolledToEnd ( _
    textBoxBase As TextBoxBase _
) As Boolean
[ExtensionAttribute]
public:
static bool^ IsScrolledToEnd(
    TextBoxBase^ textBoxBase
)

Parameters

textBoxBase
Type: TextBoxBase
The TextBoxBase.

Return Value

true if is scrolled to end; otherwise, false.

See Also

Extensions Class
robotManager.Helpful Namespace


IsScrolledToTop Method

Extensions..::..IsScrolledToTop Method

Determines whether is scrolled to top.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static bool IsScrolledToTop(
    this TextBoxBase textBoxBase
)
<ExtensionAttribute> _
Public Shared Function IsScrolledToTop ( _
    textBoxBase As TextBoxBase _
) As Boolean
[ExtensionAttribute]
public:
static bool^ IsScrolledToTop(
    TextBoxBase^ textBoxBase
)

Parameters

textBoxBase
Type: TextBoxBase
The text box base.

Return Value

true if is scrolled to top; otherwise, false.

See Also

Extensions Class
robotManager.Helpful Namespace


IsZero Method

Extensions..::..IsZero Method

Determines if the value is zero.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static bool IsZero(
    this ulong thisT
)
<ExtensionAttribute> _
Public Shared Function IsZero ( _
    thisT As ULong _
) As Boolean
[ExtensionAttribute]
public:
static bool^ IsZero(
    unsigned long long^ thisT
)

Parameters

thisT
Type: UInt64
The this t.

Return Value

true if the value is zero; otherwise, false.

See Also

Extensions Class
robotManager.Helpful Namespace


Replace Method

Extensions..::..Replace Method

Overload List

Name | Description
Replace(array<Byte>[]()[][], array<Byte>[]()[][], array<Byte>[]()[][]) | Replaces the specified bytes by others.
Replace(array<Byte>[]()[][], UInt64, UInt64) | Replaces the specified bytes by others.
Replace(array<Byte>[]()[][], Int64, Int64) | Replaces the specified bytes by others.
Replace(array<Byte>[]()[][], Int32, Int32) | Replaces the specified bytes by others.
Replace(array<Byte>[]()[][], UInt32, UInt32) | Replaces the specified bytes by others.
Replace(array<Byte>[]()[][], Int16, Int16) | Replaces the specified bytes by others.
Replace(array<Byte>[]()[][], UInt16, UInt16) | Replaces the specified bytes by others.
Replace(array<Byte>[]()[][], Single, Single) | Replaces the specified bytes by others.
Replace(array<Byte>[]()[][], Double, Double) | Replaces the specified bytes by others.
Replace(array<Byte>[]()[][], Byte, Byte) | Replaces the specified bytes by others.

See Also

Extensions Class
Extensions Members
robotManager.Helpful Namespace


Replace Method (Byte[], Byte[], Byte[])

Extensions..::..Replace Method (array<Byte>[]()[][], array<Byte>[]()[][], array<Byte>[]()[][])

Replaces the specified bytes by others.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static byte[] Replace(
    this byte[] src,
    byte[] find,
    byte[] replaceBy
)
<ExtensionAttribute> _
Public Shared Function Replace ( _
    src As Byte(), _
    find As Byte(), _
    replaceBy As Byte() _
) As Byte()
[ExtensionAttribute]
public:
static array<unsigned char^>^ Replace(
    array<unsigned char^>^ src,
    array<unsigned char^>^ find,
    array<unsigned char^>^ replaceBy
)

Parameters

src
Type: array< Byte >[]()[][]
The source.
find
Type: array< Byte >[]()[][]
bytes to find.
replaceBy
Type: array< Byte >[]()[][]
replace found bytes by.

Return Value

System.Byte[].

See Also

Extensions Class
Replace Overload
robotManager.Helpful Namespace


Replace Method (Byte[], UInt64, UInt64)

Extensions..::..Replace Method (array<Byte>[]()[][], UInt64, UInt64)

Replaces the specified bytes by others.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static byte[] Replace(
    this byte[] src,
    ulong find,
    ulong replaceBy
)
<ExtensionAttribute> _
Public Shared Function Replace ( _
    src As Byte(), _
    find As ULong, _
    replaceBy As ULong _
) As Byte()
[ExtensionAttribute]
public:
static array<unsigned char^>^ Replace(
    array<unsigned char^>^ src,
    unsigned long long^ find,
    unsigned long long^ replaceBy
)

Parameters

src
Type: array< Byte >[]()[][]
The source.
find
Type: UInt64
bytes to find.
replaceBy
Type: UInt64
replace found bytes by.

Return Value

System.Byte[].

See Also

Extensions Class
Replace Overload
robotManager.Helpful Namespace


Replace Method (Byte[], Int64, Int64)

Extensions..::..Replace Method (array<Byte>[]()[][], Int64, Int64)

Replaces the specified bytes by others.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static byte[] Replace(
    this byte[] src,
    long find,
    long replaceBy
)
<ExtensionAttribute> _
Public Shared Function Replace ( _
    src As Byte(), _
    find As Long, _
    replaceBy As Long _
) As Byte()
[ExtensionAttribute]
public:
static array<unsigned char^>^ Replace(
    array<unsigned char^>^ src,
    long long^ find,
    long long^ replaceBy
)

Parameters

src
Type: array< Byte >[]()[][]
The source.
find
Type: Int64
bytes to find.
replaceBy
Type: Int64
replace found bytes by.

Return Value

System.Byte[].

See Also

Extensions Class
Replace Overload
robotManager.Helpful Namespace


Replace Method (Byte[], Int32, Int32)

Extensions..::..Replace Method (array<Byte>[]()[][], Int32, Int32)

Replaces the specified bytes by others.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static byte[] Replace(
    this byte[] src,
    int find,
    int replaceBy
)
<ExtensionAttribute> _
Public Shared Function Replace ( _
    src As Byte(), _
    find As Integer, _
    replaceBy As Integer _
) As Byte()
[ExtensionAttribute]
public:
static array<unsigned char^>^ Replace(
    array<unsigned char^>^ src,
    int^ find,
    int^ replaceBy
)

Parameters

src
Type: array< Byte >[]()[][]
The source.
find
Type: Int32
bytes to find.
replaceBy
Type: Int32
replace found bytes by.

Return Value

System.Byte[].

See Also

Extensions Class
Replace Overload
robotManager.Helpful Namespace


Replace Method (Byte[], UInt32, UInt32)

Extensions..::..Replace Method (array<Byte>[]()[][], UInt32, UInt32)

Replaces the specified bytes by others.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static byte[] Replace(
    this byte[] src,
    uint find,
    uint replaceBy
)
<ExtensionAttribute> _
Public Shared Function Replace ( _
    src As Byte(), _
    find As UInteger, _
    replaceBy As UInteger _
) As Byte()
[ExtensionAttribute]
public:
static array<unsigned char^>^ Replace(
    array<unsigned char^>^ src,
    unsigned int^ find,
    unsigned int^ replaceBy
)

Parameters

src
Type: array< Byte >[]()[][]
The source.
find
Type: UInt32
bytes to find.
replaceBy
Type: UInt32
replace found bytes by.

Return Value

System.Byte[].

See Also

Extensions Class
Replace Overload
robotManager.Helpful Namespace


Replace Method (Byte[], Int16, Int16)

Extensions..::..Replace Method (array<Byte>[]()[][], Int16, Int16)

Replaces the specified bytes by others.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static byte[] Replace(
    this byte[] src,
    short find,
    short replaceBy
)
<ExtensionAttribute> _
Public Shared Function Replace ( _
    src As Byte(), _
    find As Short, _
    replaceBy As Short _
) As Byte()
[ExtensionAttribute]
public:
static array<unsigned char^>^ Replace(
    array<unsigned char^>^ src,
    short^ find,
    short^ replaceBy
)

Parameters

src
Type: array< Byte >[]()[][]
The source.
find
Type: Int16
bytes to find.
replaceBy
Type: Int16
replace found bytes by.

Return Value

System.Byte[].

See Also

Extensions Class
Replace Overload
robotManager.Helpful Namespace


Replace Method (Byte[], UInt16, UInt16)

Extensions..::..Replace Method (array<Byte>[]()[][], UInt16, UInt16)

Replaces the specified bytes by others.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static byte[] Replace(
    this byte[] src,
    ushort find,
    ushort replaceBy
)
<ExtensionAttribute> _
Public Shared Function Replace ( _
    src As Byte(), _
    find As UShort, _
    replaceBy As UShort _
) As Byte()
[ExtensionAttribute]
public:
static array<unsigned char^>^ Replace(
    array<unsigned char^>^ src,
    unsigned short^ find,
    unsigned short^ replaceBy
)

Parameters

src
Type: array< Byte >[]()[][]
The source.
find
Type: UInt16
bytes to find.
replaceBy
Type: UInt16
replace found bytes by.

Return Value

System.Byte[].

See Also

Extensions Class
Replace Overload
robotManager.Helpful Namespace


Replace Method (Byte[], Single, Single)

Extensions..::..Replace Method (array<Byte>[]()[][], Single, Single)

Replaces the specified bytes by others.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static byte[] Replace(
    this byte[] src,
    float find,
    float replaceBy
)
<ExtensionAttribute> _
Public Shared Function Replace ( _
    src As Byte(), _
    find As Single, _
    replaceBy As Single _
) As Byte()
[ExtensionAttribute]
public:
static array<unsigned char^>^ Replace(
    array<unsigned char^>^ src,
    float^ find,
    float^ replaceBy
)

Parameters

src
Type: array< Byte >[]()[][]
The source.
find
Type: Single
bytes to find.
replaceBy
Type: Single
replace found bytes by.

Return Value

System.Byte[].

See Also

Extensions Class
Replace Overload
robotManager.Helpful Namespace


Replace Method (Byte[], Double, Double)

Extensions..::..Replace Method (array<Byte>[]()[][], Double, Double)

Replaces the specified bytes by others.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static byte[] Replace(
    this byte[] src,
    double find,
    double replaceBy
)
<ExtensionAttribute> _
Public Shared Function Replace ( _
    src As Byte(), _
    find As Double, _
    replaceBy As Double _
) As Byte()
[ExtensionAttribute]
public:
static array<unsigned char^>^ Replace(
    array<unsigned char^>^ src,
    double^ find,
    double^ replaceBy
)

Parameters

src
Type: array< Byte >[]()[][]
The source.
find
Type: Double
bytes to find.
replaceBy
Type: Double
replace found bytes by.

Return Value

System.Byte[].

See Also

Extensions Class
Replace Overload
robotManager.Helpful Namespace


Replace Method (Byte[], Byte, Byte)

Extensions..::..Replace Method (array<Byte>[]()[][], Byte, Byte)

Replaces the specified bytes by others.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static byte[] Replace(
    this byte[] src,
    byte find,
    byte replaceBy
)
<ExtensionAttribute> _
Public Shared Function Replace ( _
    src As Byte(), _
    find As Byte, _
    replaceBy As Byte _
) As Byte()
[ExtensionAttribute]
public:
static array<unsigned char^>^ Replace(
    array<unsigned char^>^ src,
    unsigned char^ find,
    unsigned char^ replaceBy
)

Parameters

src
Type: array< Byte >[]()[][]
The source.
find
Type: Byte
bytes to find.
replaceBy
Type: Byte
replace found bytes by.

Return Value

System.Byte[].

See Also

Extensions Class
Replace Overload
robotManager.Helpful Namespace


ResumeAllThreads Method

Extensions..::..ResumeAllThreads Method

Resumes all threads of external process.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void ResumeAllThreads(
    this Process process,
    List<int> ignores
)
<ExtensionAttribute> _
Public Shared Sub ResumeAllThreads ( _
    process As Process, _
    ignores As List(Of Integer) _
)
[ExtensionAttribute]
public:
static void ResumeAllThreads(
    Process^ process,
    List<int^>^ ignores
)

Parameters

process
Type: Process
The process.
ignores
Type: List <(Of <(<' Int32 >)>)>
The thead IDs to ignores.

See Also

Extensions Class
robotManager.Helpful Namespace


ResumeThread Method

Extensions..::..ResumeThread Method

Resumes a thread.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static bool ResumeThread(
    this ProcessThread thread
)
<ExtensionAttribute> _
Public Shared Function ResumeThread ( _
    thread As ProcessThread _
) As Boolean
[ExtensionAttribute]
public:
static bool^ ResumeThread(
    ProcessThread^ thread
)

Parameters

thread
Type: ProcessThread
The thread.

Return Value

true if success, false otherwise.

See Also

Extensions Class
robotManager.Helpful Namespace


Serialize(T) Method

Extensions..::..Serialize<(Of <(<'T>)>)> Method

Serializes the specified class (to Xml).

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static string Serialize<T>(
    this T thisT
)

<ExtensionAttribute> _
Public Shared Function Serialize(Of T) ( _
    thisT As T _
) As String
[ExtensionAttribute]
public:
generic<typename T>
static String^ Serialize(
    T thisT
)

Type Parameters

T

Parameters

thisT
Type: T
The serializable class.

Return Value

System.String.

See Also

Extensions Class
robotManager.Helpful Namespace


Shuffle Method (String)

Extensions..::..Shuffle Method (String)

Shuffles the specified string.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static string Shuffle(
    this string str
)
<ExtensionAttribute> _
Public Shared Function Shuffle ( _
    str As String _
) As String
[ExtensionAttribute]
public:
static String^ Shuffle(
    String^ str
)

Parameters

str
Type: String
The string.

Return Value

System.String.

See Also

Extensions Class
Shuffle Overload
robotManager.Helpful Namespace


Shuffle(T) Method (IList(T))

Extensions..::..Shuffle<(Of <(<'T>)>)> Method (IList<(Of <(<'T>)>)>)

Shuffles the specified list.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void Shuffle<T>(
    this IList<T> list
)

<ExtensionAttribute> _
Public Shared Sub Shuffle(Of T) ( _
    list As IList(Of T) _
)
[ExtensionAttribute]
public:
generic<typename T>
static void Shuffle(
    IList<T>^ list
)

Type Parameters

T

Parameters

list
Type: IList <(Of <(<'T>)>)>
The list.

See Also

Extensions Class
Shuffle Overload
robotManager.Helpful Namespace


SuspendAllThreads Method

Extensions..::..SuspendAllThreads Method

Suspends all threads of external process.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void SuspendAllThreads(
    this Process process,
    List<int> ignores
)
<ExtensionAttribute> _
Public Shared Sub SuspendAllThreads ( _
    process As Process, _
    ignores As List(Of Integer) _
)
[ExtensionAttribute]
public:
static void SuspendAllThreads(
    Process^ process,
    List<int^>^ ignores
)

Parameters

process
Type: Process
The process.
ignores
Type: List <(Of <(<' Int32 >)>)>
The thead IDs to ignores.

See Also

Extensions Class
robotManager.Helpful Namespace


SuspendMainThread Method

Extensions..::..SuspendMainThread Method

Suspends the main thread of external process.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void SuspendMainThread(
    this Process process
)
<ExtensionAttribute> _
Public Shared Sub SuspendMainThread ( _
    process As Process _
)
[ExtensionAttribute]
public:
static void SuspendMainThread(
    Process^ process
)

Parameters

process
Type: Process
The process.

See Also

Extensions Class
robotManager.Helpful Namespace


SuspendThread Method

Extensions..::..SuspendThread Method

Suspends the thread.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static bool SuspendThread(
    this ProcessThread thread
)
<ExtensionAttribute> _
Public Shared Function SuspendThread ( _
    thread As ProcessThread _
) As Boolean
[ExtensionAttribute]
public:
static bool^ SuspendThread(
    ProcessThread^ thread
)

Parameters

thread
Type: ProcessThread
The thread.

Return Value

true if success, false otherwise.

See Also

Extensions Class
robotManager.Helpful Namespace


TerminateAllThreads Method

Extensions..::..TerminateAllThreads Method

Terminates all threads of external process.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void TerminateAllThreads(
    this Process process,
    List<int> ignores
)
<ExtensionAttribute> _
Public Shared Sub TerminateAllThreads ( _
    process As Process, _
    ignores As List(Of Integer) _
)
[ExtensionAttribute]
public:
static void TerminateAllThreads(
    Process^ process,
    List<int^>^ ignores
)

Parameters

process
Type: Process
The process.
ignores
Type: List <(Of <(<' Int32 >)>)>
The thead IDs to ignores.

See Also

Extensions Class
robotManager.Helpful Namespace


ToReadableAgeString Method

Extensions..::..ToReadableAgeString Method

Converts to readable age (in years) string.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static string ToReadableAgeString(
    this TimeSpan span
)
<ExtensionAttribute> _
Public Shared Function ToReadableAgeString ( _
    span As TimeSpan _
) As String
[ExtensionAttribute]
public:
static String^ ToReadableAgeString(
    TimeSpan^ span
)

Parameters

span
Type: TimeSpan
The span.

Return Value

System.String.

See Also

Extensions Class
robotManager.Helpful Namespace


ToReadableString Method

Extensions..::..ToReadableString Method

Converts to readable string result like "1 day, 10 hours, 30 minutes, 42 seconds".

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static string ToReadableString(
    this TimeSpan span,
    bool showSecond
)
<ExtensionAttribute> _
Public Shared Function ToReadableString ( _
    span As TimeSpan, _
    showSecond As Boolean _
) As String
[ExtensionAttribute]
public:
static String^ ToReadableString(
    TimeSpan^ span,
    bool^ showSecond
)

Parameters

span
Type: TimeSpan
The timespan.
showSecond
Type: Boolean
if set to true to show seconds.

Return Value

System.String.

See Also

Extensions Class
robotManager.Helpful Namespace


ToStringArray Method

Extensions..::..ToStringArray Method

Converts to string array (by line).

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static string[] ToStringArray(
    this StringBuilder thisT
)
<ExtensionAttribute> _
Public Shared Function ToStringArray ( _
    thisT As StringBuilder _
) As String()
[ExtensionAttribute]
public:
static array<String^>^ ToStringArray(
    StringBuilder^ thisT
)

Parameters

thisT
Type: StringBuilder
The this t.

Return Value

System.String[].

See Also

Extensions Class
robotManager.Helpful Namespace


Translate Method

Extensions..::..Translate Method

Overload List

Name | Description
Translate(ContentControl) | Translates the specified ContentControl (translate with Translate).
Translate(TextBlock) | Translates the specified TextBlock (translate with Translate).

See Also

Extensions Class
Extensions Members
robotManager.Helpful Namespace


Translate Method (ContentControl)

Extensions..::..Translate Method (ContentControl)

Translates the specified ContentControl (translate with Translate).

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void Translate(
    this ContentControl thisT
)
<ExtensionAttribute> _
Public Shared Sub Translate ( _
    thisT As ContentControl _
)
[ExtensionAttribute]
public:
static void Translate(
    ContentControl^ thisT
)

Parameters

thisT
Type: ContentControl
The wpf control to translate.

See Also

Extensions Class
Translate Overload
robotManager.Helpful Namespace


Translate Method (TextBlock)

Extensions..::..Translate Method (TextBlock)

Translates the specified TextBlock (translate with Translate).

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void Translate(
    this TextBlock thisT
)
<ExtensionAttribute> _
Public Shared Sub Translate ( _
    thisT As TextBlock _
)
[ExtensionAttribute]
public:
static void Translate(
    TextBlock^ thisT
)

Parameters

thisT
Type: TextBlock
The wpf TextBlock to translate.

See Also

Extensions Class
Translate Overload
robotManager.Helpful Namespace


GraphicsExtensions Class

Class GraphicsExtensions.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static class GraphicsExtensions
Public NotInheritable Class GraphicsExtensions
public ref class GraphicsExtensions abstract sealed

Inheritance Hierarchy

Object
robotManager.Helpful..::..GraphicsExtensions

See Also

GraphicsExtensions Members
robotManager.Helpful Namespace


GraphicsExtensions Members

The GraphicsExtensions type exposes the following members.

Methods

Name | Description
ToHighQuality | Converts to highquality.
ToLowQuality | Converts to lowquality.

See Also

GraphicsExtensions Class
robotManager.Helpful Namespace


GraphicsExtensions Methods

The GraphicsExtensions type exposes the following members.

Methods

Name | Description
ToHighQuality | Converts to highquality.
ToLowQuality | Converts to lowquality.

See Also

GraphicsExtensions Class
robotManager.Helpful Namespace


ToHighQuality Method

GraphicsExtensions..::..ToHighQuality Method

Converts to highquality.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void ToHighQuality(
    this Graphics graphics
)
<ExtensionAttribute> _
Public Shared Sub ToHighQuality ( _
    graphics As Graphics _
)
[ExtensionAttribute]
public:
static void ToHighQuality(
    Graphics^ graphics
)

Parameters

graphics
Type: Graphics
The graphics.

See Also

GraphicsExtensions Class
robotManager.Helpful Namespace


ToLowQuality Method

GraphicsExtensions..::..ToLowQuality Method

Converts to lowquality.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void ToLowQuality(
    this Graphics graphics
)
<ExtensionAttribute> _
Public Shared Sub ToLowQuality ( _
    graphics As Graphics _
)
[ExtensionAttribute]
public:
static void ToLowQuality(
    Graphics^ graphics
)

Parameters

graphics
Type: Graphics
The graphics.

See Also

GraphicsExtensions Class
robotManager.Helpful Namespace


GZip Class

Class GZip.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public class GZip
Public Class GZip
public ref class GZip

Inheritance Hierarchy

Object
robotManager.Helpful..::..GZip

See Also

GZip Members
robotManager.Helpful Namespace


GZip Members

The GZip type exposes the following members.

Methods

 | Name | Description
 | Compress | Compress the specified file.
 | CompressInMemory(String) | Compress the specified file.
 | CompressInMemory(array<Byte>[]()[][]) | Compress the specified file.
 | CompressInMemoryToBase64 | Compress the specified file.
 | Decompress | Decompresses the specified file.
 | DecompressInMemoryFromBase64(String) | Decompresses the in memory from base64.
 | DecompressInMemoryFromBase64(String, Boolean%) | Decompresses the in memory from base64.
 | DecompressOnMemory(String) | Decompresses the specified file.
 | DecompressOnMemory(array<Byte>[]()[][]) | Decompresses the on memory.
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

GZip Class
robotManager.Helpful Namespace


GZip Methods

The GZip type exposes the following members.

Methods

 | Name | Description
 | Compress | Compress the specified file.
 | CompressInMemory(String) | Compress the specified file.
 | CompressInMemory(array<Byte>[]()[][]) | Compress the specified file.
 | CompressInMemoryToBase64 | Compress the specified file.
 | Decompress | Decompresses the specified file.
 | DecompressInMemoryFromBase64(String) | Decompresses the in memory from base64.
 | DecompressInMemoryFromBase64(String, Boolean%) | Decompresses the in memory from base64.
 | DecompressOnMemory(String) | Decompresses the specified file.
 | DecompressOnMemory(array<Byte>[]()[][]) | Decompresses the on memory.
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

GZip Class
robotManager.Helpful Namespace


Compress Method

GZip..::..Compress Method

Compress the specified file.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static bool Compress(
    string filename,
    string toFile
)
Public Shared Function Compress ( _
    filename As String, _
    toFile As String _
) As Boolean
public:
static bool^ Compress(
    String^ filename,
    String^ toFile
)

Parameters

filename
Type: String
The file path.
toFile
Type: String
To file.

Return Value

true if success, false otherwise.

See Also

GZip Class
robotManager.Helpful Namespace


CompressInMemory Method

GZip..::..CompressInMemory Method

Overload List

Name | Description
CompressInMemory(String) | Compress the specified file.
CompressInMemory(array<Byte>[]()[][]) | Compress the specified file.

See Also

GZip Class
GZip Members
robotManager.Helpful Namespace


CompressInMemory Method (String)

GZip..::..CompressInMemory Method (String)

Compress the specified file.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static byte[] CompressInMemory(
    string stringAtCompress
)
Public Shared Function CompressInMemory ( _
    stringAtCompress As String _
) As Byte()
public:
static array<unsigned char^>^ CompressInMemory(
    String^ stringAtCompress
)

Parameters

stringAtCompress
Type: String
string at compress.

Return Value

file bytes.

See Also

GZip Class
CompressInMemory Overload
robotManager.Helpful Namespace


CompressInMemory Method (Byte[])

GZip..::..CompressInMemory Method (array<Byte>[]()[][])

Compress the specified file.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static byte[] CompressInMemory(
    byte[] file
)
Public Shared Function CompressInMemory ( _
    file As Byte() _
) As Byte()
public:
static array<unsigned char^>^ CompressInMemory(
    array<unsigned char^>^ file
)

Parameters

file
Type: array< Byte >[]()[][]
file.

Return Value

file bytes.

See Also

GZip Class
CompressInMemory Overload
robotManager.Helpful Namespace


CompressInMemoryToBase64 Method

GZip..::..CompressInMemoryToBase64 Method

Compress the specified file.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static string CompressInMemoryToBase64(
    string stringAtCompress
)
Public Shared Function CompressInMemoryToBase64 ( _
    stringAtCompress As String _
) As String
public:
static String^ CompressInMemoryToBase64(
    String^ stringAtCompress
)

Parameters

stringAtCompress
Type: String
string at compress.

Return Value

base64 file.

See Also

GZip Class
robotManager.Helpful Namespace


Decompress Method

GZip..::..Decompress Method

Decompresses the specified file.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static bool Decompress(
    string filename
)
Public Shared Function Decompress ( _
    filename As String _
) As Boolean
public:
static bool^ Decompress(
    String^ filename
)

Parameters

filename
Type: String
The file path.

Return Value

true if success, false otherwise.

See Also

GZip Class
robotManager.Helpful Namespace


DecompressInMemoryFromBase64 Method

GZip..::..DecompressInMemoryFromBase64 Method

Overload List

Name | Description
DecompressInMemoryFromBase64(String) | Decompresses the in memory from base64.
DecompressInMemoryFromBase64(String, Boolean%) | Decompresses the in memory from base64.

See Also

GZip Class
GZip Members
robotManager.Helpful Namespace


DecompressInMemoryFromBase64 Method (String)

GZip..::..DecompressInMemoryFromBase64 Method (String)

Decompresses the in memory from base64.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static string DecompressInMemoryFromBase64(
    string base64string
)
Public Shared Function DecompressInMemoryFromBase64 ( _
    base64string As String _
) As String
public:
static String^ DecompressInMemoryFromBase64(
    String^ base64string
)

Parameters

base64string
Type: String
The base64string.

Return Value

string content file.

See Also

GZip Class
DecompressInMemoryFromBase64 Overload
robotManager.Helpful Namespace


DecompressInMemoryFromBase64 Method (String, Boolean)

GZip..::..DecompressInMemoryFromBase64 Method (String, Boolean%)

Decompresses the in memory from base64.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static string DecompressInMemoryFromBase64(
    string base64string,
    out bool isGzip
)
Public Shared Function DecompressInMemoryFromBase64 ( _
    base64string As String, _
    <OutAttribute> ByRef isGzip As Boolean _
) As String
public:
static String^ DecompressInMemoryFromBase64(
    String^ base64string,
    [OutAttribute] bool^% isGzip
)

Parameters

base64string
Type: String
The base64string.
isGzip
Type: Boolean %
if set to true [is gzip].

Return Value

string content file.

See Also

GZip Class
DecompressInMemoryFromBase64 Overload
robotManager.Helpful Namespace


DecompressOnMemory Method

GZip..::..DecompressOnMemory Method

Overload List

Name | Description
DecompressOnMemory(String) | Decompresses the specified file.
DecompressOnMemory(array<Byte>[]()[][]) | Decompresses the on memory.

See Also

GZip Class
GZip Members
robotManager.Helpful Namespace


DecompressOnMemory Method (String)

GZip..::..DecompressOnMemory Method (String)

Decompresses the specified file.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static byte[] DecompressOnMemory(
    string filename
)
Public Shared Function DecompressOnMemory ( _
    filename As String _
) As Byte()
public:
static array<unsigned char^>^ DecompressOnMemory(
    String^ filename
)

Parameters

filename
Type: String
The file path.

Return Value

file bytes.

See Also

GZip Class
DecompressOnMemory Overload
robotManager.Helpful Namespace


DecompressOnMemory Method (Byte[])

GZip..::..DecompressOnMemory Method (array<Byte>[]()[][])

Decompresses the on memory.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static byte[] DecompressOnMemory(
    byte[] fileBytes
)
Public Shared Function DecompressOnMemory ( _
    fileBytes As Byte() _
) As Byte()
public:
static array<unsigned char^>^ DecompressOnMemory(
    array<unsigned char^>^ fileBytes
)

Parameters

fileBytes
Type: array< Byte >[]()[][]
The file bytes.

Return Value

file bytes.

See Also

GZip Class
DecompressOnMemory Overload
robotManager.Helpful Namespace


IniFile Class

Create a New INI file to store or load data

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public class IniFile
Public Class IniFile
public ref class IniFile

Inheritance Hierarchy

Object
robotManager.Helpful..::..IniFile

See Also

IniFile Members
robotManager.Helpful Namespace


IniFile Members

The IniFile type exposes the following members.

Constructors

 | Name | Description
Public method | IniFile | INIFile Constructor.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IniReadValue | Read Data Value From the Ini File
Public method | IniWriteValue | Write Data to the INI File
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

IniFile Class
robotManager.Helpful Namespace


IniFile Constructor

INIFile Constructor.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public IniFile(
    string iniPath
)
Public Sub New ( _
    iniPath As String _
)
public:
IniFile(
    String^ iniPath
)

Parameters

iniPath
Type: String
The ini path.

See Also

IniFile Class
robotManager.Helpful Namespace


IniFile Methods

The IniFile type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IniReadValue | Read Data Value From the Ini File
Public method | IniWriteValue | Write Data to the INI File
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

IniFile Class
robotManager.Helpful Namespace


IniReadValue Method

IniFile..::..IniReadValue Method

Read Data Value From the Ini File

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public string IniReadValue(
    string section,
    string key
)
Public Function IniReadValue ( _
    section As String, _
    key As String _
) As String
public:
String^ IniReadValue(
    String^ section,
    String^ key
)

Parameters

section
Type: String
The section.
key
Type: String
The key.

Return Value

System.String.

See Also

IniFile Class
robotManager.Helpful Namespace


IniWriteValue Method

IniFile..::..IniWriteValue Method

Write Data to the INI File

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public void IniWriteValue(
    string section,
    string key,
    string value
)
Public Sub IniWriteValue ( _
    section As String, _
    key As String, _
    value As String _
)
public:
void IniWriteValue(
    String^ section,
    String^ key,
    String^ value
)

Parameters

section
Type: String
The section.
key
Type: String
The key.
value
Type: String
The value.

See Also

IniFile Class
robotManager.Helpful Namespace


Keyboard Class

Keyboard Manager

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static class Keyboard
Public NotInheritable Class Keyboard
public ref class Keyboard abstract sealed

Inheritance Hierarchy

Object
robotManager.Helpful..::..Keyboard

See Also

Keyboard Members
robotManager.Helpful Namespace


Keyboard Members

The Keyboard type exposes the following members.

Methods

Name | Description
DownKey(IntPtr, Keys) | Down a Keyboard Key.
DownKey(IntPtr, String) | Down a Keyboard Key.
PressKey(IntPtr, Keys) | Press a Keyboard Key.
PressKey(IntPtr, String) | Press a Keyboard Key.
SendText | Sends the text to specified window.
UpKey(IntPtr, Keys) | Up a Keyboard Key.
UpKey(IntPtr, String) | Up a Keyboard Key.

Fields

Name | Description
ErrorSendKeyCount | The error send key count

See Also

Keyboard Class
robotManager.Helpful Namespace


Keyboard Fields

The Keyboard type exposes the following members.

Fields

Name | Description
ErrorSendKeyCount | The error send key count

See Also

Keyboard Class
robotManager.Helpful Namespace


ErrorSendKeyCount Field

Keyboard..::..ErrorSendKeyCount Field

The error send key count

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static int ErrorSendKeyCount
Public Shared ErrorSendKeyCount As Integer
public:
static int^ ErrorSendKeyCount

See Also

Keyboard Class
robotManager.Helpful Namespace


Keyboard Methods

The Keyboard type exposes the following members.

Methods

Name | Description
DownKey(IntPtr, Keys) | Down a Keyboard Key.
DownKey(IntPtr, String) | Down a Keyboard Key.
PressKey(IntPtr, Keys) | Press a Keyboard Key.
PressKey(IntPtr, String) | Press a Keyboard Key.
SendText | Sends the text to specified window.
UpKey(IntPtr, Keys) | Up a Keyboard Key.
UpKey(IntPtr, String) | Up a Keyboard Key.

See Also

Keyboard Class
robotManager.Helpful Namespace


DownKey Method

Keyboard..::..DownKey Method

Overload List

Name | Description
DownKey(IntPtr, Keys) | Down a Keyboard Key.
DownKey(IntPtr, String) | Down a Keyboard Key.

See Also

Keyboard Class
Keyboard Members
robotManager.Helpful Namespace


DownKey Method (IntPtr, Keys)

Keyboard..::..DownKey Method (IntPtr, Keys)

Down a Keyboard Key.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void DownKey(
    IntPtr mainWindowHandle,
    Keys key
)
Public Shared Sub DownKey ( _
    mainWindowHandle As IntPtr, _
    key As Keys _
)
public:
static void DownKey(
    IntPtr^ mainWindowHandle,
    Keys^ key
)

Parameters

mainWindowHandle
Type: IntPtr
The main window handle.
key
Type: Keys
The key.

See Also

Keyboard Class
DownKey Overload
robotManager.Helpful Namespace


DownKey Method (IntPtr, String)

Keyboard..::..DownKey Method (IntPtr, String)

Down a Keyboard Key.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void DownKey(
    IntPtr mainWindowHandle,
    string key
)
Public Shared Sub DownKey ( _
    mainWindowHandle As IntPtr, _
    key As String _
)
public:
static void DownKey(
    IntPtr^ mainWindowHandle,
    String^ key
)

Parameters

mainWindowHandle
Type: IntPtr
The main window handle.
key
Type: String
The key.

See Also

Keyboard Class
DownKey Overload
robotManager.Helpful Namespace


PressKey Method

Keyboard..::..PressKey Method

Overload List

Name | Description
PressKey(IntPtr, Keys) | Press a Keyboard Key.
PressKey(IntPtr, String) | Press a Keyboard Key.

See Also

Keyboard Class
Keyboard Members
robotManager.Helpful Namespace


PressKey Method (IntPtr, Keys)

Keyboard..::..PressKey Method (IntPtr, Keys)

Press a Keyboard Key.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void PressKey(
    IntPtr mainWindowHandle,
    Keys key
)
Public Shared Sub PressKey ( _
    mainWindowHandle As IntPtr, _
    key As Keys _
)
public:
static void PressKey(
    IntPtr^ mainWindowHandle,
    Keys^ key
)

Parameters

mainWindowHandle
Type: IntPtr
The main window handle.
key
Type: Keys
The key.

See Also

Keyboard Class
PressKey Overload
robotManager.Helpful Namespace


PressKey Method (IntPtr, String)

Keyboard..::..PressKey Method (IntPtr, String)

Press a Keyboard Key.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void PressKey(
    IntPtr mainWindowHandle,
    string key
)
Public Shared Sub PressKey ( _
    mainWindowHandle As IntPtr, _
    key As String _
)
public:
static void PressKey(
    IntPtr^ mainWindowHandle,
    String^ key
)

Parameters

mainWindowHandle
Type: IntPtr
The main window handle.
key
Type: String
The key.

See Also

Keyboard Class
PressKey Overload
robotManager.Helpful Namespace


SendText Method

Keyboard..::..SendText Method

Sends the text to specified window.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void SendText(
    IntPtr mainWindowHandle,
    string text
)
Public Shared Sub SendText ( _
    mainWindowHandle As IntPtr, _
    text As String _
)
public:
static void SendText(
    IntPtr^ mainWindowHandle,
    String^ text
)

Parameters

mainWindowHandle
Type: IntPtr
The main window handle.
text
Type: String
The text.

See Also

Keyboard Class
robotManager.Helpful Namespace


UpKey Method

Keyboard..::..UpKey Method

Overload List

Name | Description
UpKey(IntPtr, Keys) | Up a Keyboard Key.
UpKey(IntPtr, String) | Up a Keyboard Key.

See Also

Keyboard Class
Keyboard Members
robotManager.Helpful Namespace


UpKey Method (IntPtr, Keys)

Keyboard..::..UpKey Method (IntPtr, Keys)

Up a Keyboard Key.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void UpKey(
    IntPtr mainWindowHandle,
    Keys key
)
Public Shared Sub UpKey ( _
    mainWindowHandle As IntPtr, _
    key As Keys _
)
public:
static void UpKey(
    IntPtr^ mainWindowHandle,
    Keys^ key
)

Parameters

mainWindowHandle
Type: IntPtr
The main window handle.
key
Type: Keys
The key.

See Also

Keyboard Class
UpKey Overload
robotManager.Helpful Namespace


UpKey Method (IntPtr, String)

Keyboard..::..UpKey Method (IntPtr, String)

Up a Keyboard Key.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void UpKey(
    IntPtr mainWindowHandle,
    string key
)
Public Shared Sub UpKey ( _
    mainWindowHandle As IntPtr, _
    key As String _
)
public:
static void UpKey(
    IntPtr^ mainWindowHandle,
    String^ key
)

Parameters

mainWindowHandle
Type: IntPtr
The main window handle.
key
Type: String
The key.

See Also

Keyboard Class
UpKey Overload
robotManager.Helpful Namespace


KeyboardHook Class

Registers a hot key with Windows.

Examples

C#
KeyboardHook hookKeybindingsPause = new KeyboardHook();
hookKeybindingsPause.RegisterHotKey(ModifierKeys.Alt, Keys.X);
hookKeybindingsPause.KeyPressed += delegate(object sender, KeyPressedEventArgs args)
{
     Products.InPause = !Products.InPause;
};
 // ....
hookKeybindingsPause.Dispose();

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public sealed class KeyboardHook : IDisposable
Public NotInheritable Class KeyboardHook _
    Implements IDisposable
public ref class KeyboardHook sealed : IDisposable

Inheritance Hierarchy

Object
robotManager.Helpful..::..KeyboardHook

See Also

KeyboardHook Members
robotManager.Helpful Namespace


KeyboardHook Members

The KeyboardHook type exposes the following members.

Constructors

 | Name | Description
Public method | KeyboardHook | Initializes a new instance of the KeyboardHook class.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | RegisterHotKey(ModifierKeys, Keys) | Registers a hot key in the system.
Public method | ToString | (Inherited from Object.)

Events

 | Name | Description
Public event | KeyPressed | A hot key has been pressed.

See Also

KeyboardHook Class
robotManager.Helpful Namespace


KeyboardHook Constructor

Initializes a new instance of the KeyboardHook class.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public KeyboardHook()
Public Sub New
public:
KeyboardHook()

See Also

KeyboardHook Class
robotManager.Helpful Namespace


KeyboardHook Methods

The KeyboardHook type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | RegisterHotKey(ModifierKeys, Keys) | Registers a hot key in the system.
Public method | ToString | (Inherited from Object.)

See Also

KeyboardHook Class
robotManager.Helpful Namespace


Dispose Method

KeyboardHook..::..Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public void Dispose()
Public Sub Dispose
public:
void Dispose()

See Also

KeyboardHook Class
robotManager.Helpful Namespace


RegisterHotKey Method (ModifierKeys, Keys)

KeyboardHook..::..RegisterHotKey Method (ModifierKeys, Keys)

Registers a hot key in the system.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public void RegisterHotKey(
    ModifierKeys modifier,
    Keys key
)
Public Sub RegisterHotKey ( _
    modifier As ModifierKeys, _
    key As Keys _
)
public:
void RegisterHotKey(
    ModifierKeys^ modifier,
    Keys^ key
)

Parameters

modifier
Type: robotManager.Helpful..::..ModifierKeys
The modifiers that are associated with the hot key.
key
Type: Keys
The key itself that is associated with the hot key.

See Also

KeyboardHook Class
RegisterHotKey Overload
robotManager.Helpful Namespace


KeyboardHook Events

The KeyboardHook type exposes the following members.

Events

 | Name | Description
Public event | KeyPressed | A hot key has been pressed.

See Also

KeyboardHook Class
robotManager.Helpful Namespace


KeyPressed Event

KeyboardHook..::..KeyPressed Event

A hot key has been pressed.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public event EventHandler<KeyPressedEventArgs> KeyPressed
Public Event KeyPressed As EventHandler(Of KeyPressedEventArgs)
public:
 event EventHandler<KeyPressedEventArgs^>^ KeyPressed {
    void add (EventHandler<KeyPressedEventArgs^>^ value);
    void remove (EventHandler<KeyPressedEventArgs^>^ value);
}

See Also

KeyboardHook Class
robotManager.Helpful Namespace


KeyPressedEventArgs Class

Event Args for the event that is fired after the hot key has been pressed.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public class KeyPressedEventArgs : EventArgs
Public Class KeyPressedEventArgs _
    Inherits EventArgs
public ref class KeyPressedEventArgs : public EventArgs

Inheritance Hierarchy

Object
EventArgs
robotManager.Helpful..::..KeyPressedEventArgs

See Also

KeyPressedEventArgs Members
robotManager.Helpful Namespace


KeyPressedEventArgs Members

The KeyPressedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Key | Gets the key.
Public property | Modifier | Gets the modifier.

See Also

KeyPressedEventArgs Class
robotManager.Helpful Namespace


KeyPressedEventArgs Methods

The KeyPressedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

KeyPressedEventArgs Class
robotManager.Helpful Namespace


KeyPressedEventArgs Properties

The KeyPressedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Key | Gets the key.
Public property | Modifier | Gets the modifier.

See Also

KeyPressedEventArgs Class
robotManager.Helpful Namespace


Key Property

KeyPressedEventArgs..::..Key Property

Gets the key.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public Keys Key { get; }
Public ReadOnly Property Key As Keys
    Get
public:
property Keys^ Key {
    Keys^ get ();
}

Field Value

The key.

See Also

KeyPressedEventArgs Class
robotManager.Helpful Namespace


Modifier Property

KeyPressedEventArgs..::..Modifier Property

Gets the modifier.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public ModifierKeys Modifier { get; }
Public ReadOnly Property Modifier As ModifierKeys
    Get
public:
property ModifierKeys^ Modifier {
    ModifierKeys^ get ();
}

Field Value

The modifier.

See Also

KeyPressedEventArgs Class
robotManager.Helpful Namespace


Logging Class

Class Logging. Methods to help log, user interface to show log is LoggingUserControl

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public class Logging
Public Class Logging
public ref class Logging

Inheritance Hierarchy

Object
robotManager.Helpful..::..Logging

See Also

Logging Members
robotManager.Helpful Namespace


Logging Members

The Logging type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
 | NameCurrentLogFile | Name of current log file.
 | NewFile | Create new file.
 | ReadLast | Read the last log by type.
 | ReadLastString | Read the last log string by type.
 | ReadList()()()() | Read all logs list.
 | ReadList(Logging..::..LogType) | Read all logs list by type.
 | ReadListString | Read the logs list string by type.
 | Stop | Stop logging (close file stream).
Public method | ToString | (Inherited from Object.)
 | Write(Logging..::..Log) | Write the specified log.
 | Write(String, Logging..::..LogType, Color) | Write the specified text.
 | Write(String) | Write the specified text.
 | WriteDebug | Write debug log.
 | WriteDebugDev | Write the debug dev log.
 | WriteError | Write error log.
 | WriteFight | Write fight log.
 | WriteFileOnly | Write file only log (no show in LoggingUserControl).
 | WriteNavigator | Write navigator log.

Properties

Name | Description
CountNumberInQueue | Get logs count in queue.
List | Get logs list.
Status | Get or set the status.

Events

Name | Description
OnChanged | Occurs when [on changed].
OnChangedStatus | Occurs when [on changed status].

See Also

Logging Class
robotManager.Helpful Namespace


Logging Methods

The Logging type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
 | NameCurrentLogFile | Name of current log file.
 | NewFile | Create new file.
 | ReadLast | Read the last log by type.
 | ReadLastString | Read the last log string by type.
 | ReadList()()()() | Read all logs list.
 | ReadList(Logging..::..LogType) | Read all logs list by type.
 | ReadListString | Read the logs list string by type.
 | Stop | Stop logging (close file stream).
Public method | ToString | (Inherited from Object.)
 | Write(Logging..::..Log) | Write the specified log.
 | Write(String, Logging..::..LogType, Color) | Write the specified text.
 | Write(String) | Write the specified text.
 | WriteDebug | Write debug log.
 | WriteDebugDev | Write the debug dev log.
 | WriteError | Write error log.
 | WriteFight | Write fight log.
 | WriteFileOnly | Write file only log (no show in LoggingUserControl).
 | WriteNavigator | Write navigator log.

See Also

Logging Class
robotManager.Helpful Namespace


NameCurrentLogFile Method

Logging..::..NameCurrentLogFile Method

Name of current log file.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static string NameCurrentLogFile()
Public Shared Function NameCurrentLogFile As String
public:
static String^ NameCurrentLogFile()

Return Value

System.String.

See Also

Logging Class
robotManager.Helpful Namespace


NewFile Method

Logging..::..NewFile Method

Create new file.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void NewFile()
Public Shared Sub NewFile
public:
static void NewFile()

See Also

Logging Class
robotManager.Helpful Namespace


ReadLast Method

Logging..::..ReadLast Method

Read the last log by type.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static Logging..::..Log ReadLast(
    Logging..::..LogType logType
)
Public Shared Function ReadLast ( _
    logType As Logging..::..LogType _
) As Logging..::..Log
public:
static Logging..::..Log^ ReadLast(
    Logging..::..LogType^ logType
)

Parameters

logType
Type: robotManager.Helpful..::..Logging..::..LogType
Type of the log.

Return Value

Log.

See Also

Logging Class
robotManager.Helpful Namespace


ReadLastString Method

Logging..::..ReadLastString Method

Read the last log string by type.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static string ReadLastString(
    Logging..::..LogType logType
)
Public Shared Function ReadLastString ( _
    logType As Logging..::..LogType _
) As String
public:
static String^ ReadLastString(
    Logging..::..LogType^ logType
)

Parameters

logType
Type: robotManager.Helpful..::..Logging..::..LogType
Type of the log.

Return Value

log.

See Also

Logging Class
robotManager.Helpful Namespace


ReadList Method

Logging..::..ReadList Method

Overload List

Name | Description
ReadList()()()() | Read all logs list.
ReadList(Logging..::..LogType) | Read all logs list by type.

See Also

Logging Class
Logging Members
robotManager.Helpful Namespace


ReadList Method

Logging..::..ReadList Method

Read all logs list.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static List<Logging..::..Log> ReadList()
Public Shared Function ReadList As List(Of Logging..::..Log)
public:
static List<Logging..::..Log^>^ ReadList()

Return Value

list.

See Also

Logging Class
ReadList Overload
robotManager.Helpful Namespace


ReadList Method (LogType)

Logging..::..ReadList Method (LogType)

Read all logs list by type.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static List<Logging..::..Log> ReadList(
    Logging..::..LogType logType
)
Public Shared Function ReadList ( _
    logType As Logging..::..LogType _
) As List(Of Logging..::..Log)
public:
static List<Logging..::..Log^>^ ReadList(
    Logging..::..LogType^ logType
)

Parameters

logType
Type: robotManager.Helpful..::..Logging..::..LogType
Type of the log.

Return Value

List.

See Also

Logging Class
ReadList Overload
robotManager.Helpful Namespace


ReadListString Method

Logging..::..ReadListString Method

Read the logs list string by type.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static List<string> ReadListString(
    Logging..::..LogType logType
)
Public Shared Function ReadListString ( _
    logType As Logging..::..LogType _
) As List(Of String)
public:
static List<String^>^ ReadListString(
    Logging..::..LogType^ logType
)

Parameters

logType
Type: robotManager.Helpful..::..Logging..::..LogType
Type of the log.

Return Value

List.

See Also

Logging Class
robotManager.Helpful Namespace


Stop Method

Logging..::..Stop Method

Stop logging (close file stream).

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void Stop()
Public Shared Sub Stop
public:
static void Stop()

See Also

Logging Class
robotManager.Helpful Namespace


Write Method

Logging..::..Write Method

Overload List

Name | Description
Write(Logging..::..Log) | Write the specified log.
Write(String, Logging..::..LogType, Color) | Write the specified text.
Write(String) | Write the specified text.

See Also

Logging Class
Logging Members
robotManager.Helpful Namespace


Write Method (Log)

Logging..::..Write Method (Log)

Write the specified log.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void Write(
    Logging..::..Log log
)
Public Shared Sub Write ( _
    log As Logging..::..Log _
)
public:
static void Write(
    Logging..::..Log^ log
)

Parameters

log
Type: robotManager.Helpful..::..Logging..::..Log
The log.

See Also

Logging Class
Write Overload
robotManager.Helpful Namespace


Write Method (String, LogType, Color)

Logging..::..Write Method (String, LogType, Color)

Write the specified text.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void Write(
    string text,
    Logging..::..LogType logType,
    Color color
)
Public Shared Sub Write ( _
    text As String, _
    logType As Logging..::..LogType, _
    color As Color _
)
public:
static void Write(
    String^ text,
    Logging..::..LogType^ logType,
    Color^ color
)

Parameters

text
Type: String
The text.
logType
Type: robotManager.Helpful..::..Logging..::..LogType
Type of the log.
color
Type: Color
The color.

See Also

Logging Class
Write Overload
robotManager.Helpful Namespace


Write Method (String)

Logging..::..Write Method (String)

Write the specified text.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void Write(
    string text
)
Public Shared Sub Write ( _
    text As String _
)
public:
static void Write(
    String^ text
)

Parameters

text
Type: String
The text.

See Also

Logging Class
Write Overload
robotManager.Helpful Namespace


WriteDebug Method

Logging..::..WriteDebug Method

Write debug log.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void WriteDebug(
    string text
)
Public Shared Sub WriteDebug ( _
    text As String _
)
public:
static void WriteDebug(
    String^ text
)

Parameters

text
Type: String
The text.

See Also

Logging Class
robotManager.Helpful Namespace


WriteDebugDev Method

Logging..::..WriteDebugDev Method

Write the debug dev log.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void WriteDebugDev(
    string text
)
Public Shared Sub WriteDebugDev ( _
    text As String _
)
public:
static void WriteDebugDev(
    String^ text
)

Parameters

text
Type: String
The text.

See Also

Logging Class
robotManager.Helpful Namespace


WriteError Method

Logging..::..WriteError Method

Write error log.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void WriteError(
    string text,
    bool skipThreadAbortExceptionError
)
Public Shared Sub WriteError ( _
    text As String, _
    skipThreadAbortExceptionError As Boolean _
)
public:
static void WriteError(
    String^ text,
    bool^ skipThreadAbortExceptionError
)

Parameters

text
Type: String
The text.
skipThreadAbortExceptionError
Type: Boolean
if set to true [skip thread abort exception error].

See Also

Logging Class
robotManager.Helpful Namespace


WriteFight Method

Logging..::..WriteFight Method

Write fight log.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void WriteFight(
    string text
)
Public Shared Sub WriteFight ( _
    text As String _
)
public:
static void WriteFight(
    String^ text
)

Parameters

text
Type: String
The text.

See Also

Logging Class
robotManager.Helpful Namespace


WriteFileOnly Method

Logging..::..WriteFileOnly Method

Write file only log (no show in LoggingUserControl).

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void WriteFileOnly(
    string text
)
Public Shared Sub WriteFileOnly ( _
    text As String _
)
public:
static void WriteFileOnly(
    String^ text
)

Parameters

text
Type: String
The text.

See Also

Logging Class
robotManager.Helpful Namespace


WriteNavigator Method

Logging..::..WriteNavigator Method

Write navigator log.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void WriteNavigator(
    string text
)
Public Shared Sub WriteNavigator ( _
    text As String _
)
public:
static void WriteNavigator(
    String^ text
)

Parameters

text
Type: String
The text.

See Also

Logging Class
robotManager.Helpful Namespace


Logging Properties

The Logging type exposes the following members.

Properties

Name | Description
CountNumberInQueue | Get logs count in queue.
List | Get logs list.
Status | Get or set the status.

See Also

Logging Class
robotManager.Helpful Namespace


CountNumberInQueue Property

Logging..::..CountNumberInQueue Property

Get logs count in queue.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static int CountNumberInQueue { get; }
Public Shared ReadOnly Property CountNumberInQueue As Integer
    Get
public:
static property int^ CountNumberInQueue {
    int^ get ();
}

Field Value

The count number in queue.

See Also

Logging Class
robotManager.Helpful Namespace


List Property

Logging..::..List Property

Get logs list.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static List<Logging..::..Log> List { get; }
Public Shared ReadOnly Property List As List(Of Logging..::..Log)
    Get
public:
static property List<Logging..::..Log^>^ List {
    List<Logging..::..Log^>^ get ();
}

Field Value

The list.

See Also

Logging Class
robotManager.Helpful Namespace


Status Property

Logging..::..Status Property

Get or set the status.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static string Status { get; set; }
Public Shared Property Status As String
    Get
    Set
public:
static property String^ Status {
    String^ get ();
    void set (String^ value);
}

Field Value

The status.

See Also

Logging Class
robotManager.Helpful Namespace


Logging Events

The Logging type exposes the following members.

Events

Name | Description
OnChanged | Occurs when [on changed].
OnChangedStatus | Occurs when [on changed status].

See Also

Logging Class
robotManager.Helpful Namespace


OnChanged Event

Logging..::..OnChanged Event

Occurs when [on changed].

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static event Logging..::..LoggingChangeEventHandler OnChanged
Public Shared Event OnChanged As Logging..::..LoggingChangeEventHandler
public:
static  event Logging..::..LoggingChangeEventHandler^ OnChanged {
    void add (Logging..::..LoggingChangeEventHandler^ value);
    void remove (Logging..::..LoggingChangeEventHandler^ value);
}

See Also

Logging Class
robotManager.Helpful Namespace


OnChangedStatus Event

Logging..::..OnChangedStatus Event

Occurs when [on changed status].

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static event Logging..::..StatusChangeEventHandler OnChangedStatus
Public Shared Event OnChangedStatus As Logging..::..StatusChangeEventHandler
public:
static  event Logging..::..StatusChangeEventHandler^ OnChangedStatus {
    void add (Logging..::..StatusChangeEventHandler^ value);
    void remove (Logging..::..StatusChangeEventHandler^ value);
}

See Also

Logging Class
robotManager.Helpful Namespace


Logging.Log Class

Logging..::..Log Class

Class Log.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public class Log
Public Class Log
public ref class Log

Inheritance Hierarchy

Object
robotManager.Helpful..::..Logging..::..Log

See Also

Logging..::..Log Members
robotManager.Helpful Namespace


Logging.Log Members

Logging..::..Log Members

The Logging..::..Log type exposes the following members.

Constructors

 | Name | Description
Public method | Logging..::..Log()()()() | Initializes a new instance of the Logging..::..Log class.
Public method | Logging..::..Log(String, Logging..::..LogType, Color) | Initializes a new instance of the Logging..::..Log class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance.

Properties

 | Name | Description
Public property | Color | Gets or sets the color.
Public property | DateTime | Gets or sets the date time.
Public property | LogType | Gets or sets the type of the log.
Public property | Text | Gets or sets the text.

See Also

Logging..::..Log Class
robotManager.Helpful Namespace


Log Constructor

Overload List

 | Name | Description
Public method | Logging..::..Log()()()() | Initializes a new instance of the Logging..::..Log class.
Public method | Logging..::..Log(String, Logging..::..LogType, Color) | Initializes a new instance of the Logging..::..Log class.

See Also

Logging..::..Log Class
Logging..::..Log Members
robotManager.Helpful Namespace


Log Constructor

Initializes a new instance of the Logging..::..Log class.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public Log()
Public Sub New
public:
Log()

See Also

Logging..::..Log Class
Logging..::..Log Overload
robotManager.Helpful Namespace


Log Constructor (String, LogType, Color)

Initializes a new instance of the Logging..::..Log class.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public Log(
    string text,
    Logging..::..LogType logType,
    Color color
)
Public Sub New ( _
    text As String, _
    logType As Logging..::..LogType, _
    color As Color _
)
public:
Log(
    String^ text,
    Logging..::..LogType^ logType,
    Color^ color
)

Parameters

text
Type: String
The text.
logType
Type: robotManager.Helpful..::..Logging..::..LogType
Type of the log.
color
Type: Color
The color.

See Also

Logging..::..Log Class
Logging..::..Log Overload
robotManager.Helpful Namespace


Logging.Log Methods

Logging..::..Log Methods

The Logging..::..Log type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance.

See Also

Logging..::..Log Class
robotManager.Helpful Namespace


ToString Method

Log..::..ToString Method

Returns a String that represents this instance.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public string ToString()
Public Function ToString As String
public:
String^ ToString()

Return Value

A String that represents this instance.

See Also

Logging..::..Log Class
robotManager.Helpful Namespace


Logging.Log Properties

Logging..::..Log Properties

The Logging..::..Log type exposes the following members.

Properties

 | Name | Description
Public property | Color | Gets or sets the color.
Public property | DateTime | Gets or sets the date time.
Public property | LogType | Gets or sets the type of the log.
Public property | Text | Gets or sets the text.

See Also

Logging..::..Log Class
robotManager.Helpful Namespace


Color Property

Log..::..Color Property

Gets or sets the color.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public Color Color { get; set; }
Public Property Color As Color
    Get
    Set
public:
property Color^ Color {
    Color^ get ();
    void set (Color^ value);
}

Field Value

The color.

See Also

Logging..::..Log Class
robotManager.Helpful Namespace


DateTime Property

Log..::..DateTime Property

Gets or sets the date time.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public DateTime DateTime { get; set; }
Public Property DateTime As DateTime
    Get
    Set
public:
property DateTime^ DateTime {
    DateTime^ get ();
    void set (DateTime^ value);
}

Field Value

The date time.

See Also

Logging..::..Log Class
robotManager.Helpful Namespace


LogType Property

Log..::..LogType Property

Gets or sets the type of the log.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public Logging..::..LogType LogType { get; set; }
Public Property LogType As Logging..::..LogType
    Get
    Set
public:
property Logging..::..LogType^ LogType {
    Logging..::..LogType^ get ();
    void set (Logging..::..LogType^ value);
}

Field Value

The type of the log.

See Also

Logging..::..Log Class
robotManager.Helpful Namespace


Text Property

Log..::..Text Property

Gets or sets the text.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Field Value

The text.

See Also

Logging..::..Log Class
robotManager.Helpful Namespace


Logging.LoggingChangeEventArgs Class

Logging..::..LoggingChangeEventArgs Class

Class LoggingChangeEventArgs. Implements the EventArgs

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public class LoggingChangeEventArgs : EventArgs
Public Class LoggingChangeEventArgs _
    Inherits EventArgs
public ref class LoggingChangeEventArgs : public EventArgs

Inheritance Hierarchy

Object
EventArgs
robotManager.Helpful..::..Logging..::..LoggingChangeEventArgs

See Also

Logging..::..LoggingChangeEventArgs Members
robotManager.Helpful Namespace
EventArgs


Logging.LoggingChangeEventArgs Members

Logging..::..LoggingChangeEventArgs Members

The Logging..::..LoggingChangeEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Log | Gets or sets the log.

See Also

Logging..::..LoggingChangeEventArgs Class
robotManager.Helpful Namespace


Logging.LoggingChangeEventArgs Methods

Logging..::..LoggingChangeEventArgs Methods

The Logging..::..LoggingChangeEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Logging..::..LoggingChangeEventArgs Class
robotManager.Helpful Namespace


Logging.LoggingChangeEventArgs Properties

Logging..::..LoggingChangeEventArgs Properties

The Logging..::..LoggingChangeEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Log | Gets or sets the log.

See Also

Logging..::..LoggingChangeEventArgs Class
robotManager.Helpful Namespace


Log Property

LoggingChangeEventArgs..::..Log Property

Gets or sets the log.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public Logging..::..Log Log { get; set; }
Public Property Log As Logging..::..Log
    Get
    Set
public:
property Logging..::..Log^ Log {
    Logging..::..Log^ get ();
    void set (Logging..::..Log^ value);
}

Field Value

The log.

See Also

Logging..::..LoggingChangeEventArgs Class
robotManager.Helpful Namespace


Logging.LoggingChangeEventHandler Delegate

Logging..::..LoggingChangeEventHandler Delegate

Delegate LoggingChangeEventHandler

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public delegate void LoggingChangeEventHandler(
    Object sender,
    Logging..::..LoggingChangeEventArgs e
)
Public Delegate Sub LoggingChangeEventHandler ( _
    sender As Object, _
    e As Logging..::..LoggingChangeEventArgs _
)
public delegate void LoggingChangeEventHandler(
    Object^ sender,
    Logging..::..LoggingChangeEventArgs^ e
)

Parameters

sender
Type: Object
The sender.
e
Type: robotManager.Helpful..::..Logging..::..LoggingChangeEventArgs
The Logging..::..LoggingChangeEventArgs instance containing the event data.

See Also

robotManager.Helpful Namespace


Logging.LogType Enumeration

Logging..::..LogType Enumeration

LogType

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[FlagsAttribute]
public enum LogType
<FlagsAttribute> _
Public Enumeration LogType
[FlagsAttribute]
public enum class LogType

Members

Member name | Description
None |
Normal |
Debug |
Error |
Navigator |
Fight |
FileOnly |

See Also

robotManager.Helpful Namespace


Logging.StatusChangeEventArgs Class

Logging..::..StatusChangeEventArgs Class

Class StatusChangeEventArgs. Implements the EventArgs

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public class StatusChangeEventArgs : EventArgs
Public Class StatusChangeEventArgs _
    Inherits EventArgs
public ref class StatusChangeEventArgs : public EventArgs

Inheritance Hierarchy

Object
EventArgs
robotManager.Helpful..::..Logging..::..StatusChangeEventArgs

See Also

Logging..::..StatusChangeEventArgs Members
robotManager.Helpful Namespace
EventArgs


Logging.StatusChangeEventArgs Members

Logging..::..StatusChangeEventArgs Members

The Logging..::..StatusChangeEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Status | Gets or sets the status.

See Also

Logging..::..StatusChangeEventArgs Class
robotManager.Helpful Namespace


Logging.StatusChangeEventArgs Methods

Logging..::..StatusChangeEventArgs Methods

The Logging..::..StatusChangeEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Logging..::..StatusChangeEventArgs Class
robotManager.Helpful Namespace


Logging.StatusChangeEventArgs Properties

Logging..::..StatusChangeEventArgs Properties

The Logging..::..StatusChangeEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Status | Gets or sets the status.

See Also

Logging..::..StatusChangeEventArgs Class
robotManager.Helpful Namespace


Status Property

StatusChangeEventArgs..::..Status Property

Gets or sets the status.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public string Status { get; set; }
Public Property Status As String
    Get
    Set
public:
property String^ Status {
    String^ get ();
    void set (String^ value);
}

Field Value

The status.

See Also

Logging..::..StatusChangeEventArgs Class
robotManager.Helpful Namespace


Logging.StatusChangeEventHandler Delegate

Logging..::..StatusChangeEventHandler Delegate

Delegate StatusChangeEventHandler

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public delegate void StatusChangeEventHandler(
    Object sender,
    Logging..::..StatusChangeEventArgs e
)
Public Delegate Sub StatusChangeEventHandler ( _
    sender As Object, _
    e As Logging..::..StatusChangeEventArgs _
)
public delegate void StatusChangeEventHandler(
    Object^ sender,
    Logging..::..StatusChangeEventArgs^ e
)

Parameters

sender
Type: Object
The sender.
e
Type: robotManager.Helpful..::..Logging..::..StatusChangeEventArgs
The Logging..::..StatusChangeEventArgs instance containing the event data.

See Also

robotManager.Helpful Namespace


LuaBot Class

Class LuaBot. Methods to run lua code with access to all .net and bot API.

Examples

C#
local log = clr.robotManager.Helpful.Logging
local wowLua = clr.wManager.Wow.Helpers.Lua.Wow
local lua = clr.wManager.Wow.Helpers.Lua

local playerName = lua.LuaDoString('return GetUnitName("player")', clr.System.String, '') -- OR wowLua.GetUnitName("player")
local txt = 'Player name: ' .. playerName .. ' - WRobot version: ' .. clr.wManager.Information.Version
log.Write(txt);
clr.System.Windows.MessageBox.Show(txt)

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static class LuaBot
Public NotInheritable Class LuaBot
public ref class LuaBot abstract sealed

Inheritance Hierarchy

Object
robotManager.Helpful..::..LuaBot

See Also

LuaBot Members
robotManager.Helpful Namespace


LuaBot Members

The LuaBot type exposes the following members.

Methods

Name | Description
DoChunk(String, String) | Run code
DoChunk(String, LuaResult%, String%, Boolean, String) | Run code

Fields

Name | Description
Environment | Lua environment instance
Lua | Lua instance

Properties

Name | Description
EnvironmentDynamic | Gets the Environment dynamic.

See Also

LuaBot Class
robotManager.Helpful Namespace


LuaBot Fields

The LuaBot type exposes the following members.

Fields

Name | Description
Environment | Lua environment instance
Lua | Lua instance

See Also

LuaBot Class
robotManager.Helpful Namespace


Environment Field

LuaBot..::..Environment Field

Lua environment instance

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static LuaGlobal Environment
Public Shared Environment As LuaGlobal
public:
static LuaGlobal^ Environment

See Also

LuaBot Class
robotManager.Helpful Namespace


Lua Field

LuaBot..::..Lua Field

Lua instance

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static Lua Lua
Public Shared Lua As Lua
public:
static Lua^ Lua

See Also

LuaBot Class
robotManager.Helpful Namespace


LuaBot Methods

The LuaBot type exposes the following members.

Methods

Name | Description
DoChunk(String, String) | Run code
DoChunk(String, LuaResult%, String%, Boolean, String) | Run code

See Also

LuaBot Class
robotManager.Helpful Namespace


DoChunk Method

LuaBot..::..DoChunk Method

Overload List

Name | Description
DoChunk(String, String) | Run code
DoChunk(String, LuaResult%, String%, Boolean, String) | Run code

See Also

LuaBot Class
LuaBot Members
robotManager.Helpful Namespace


DoChunk Method (String, String)

LuaBot..::..DoChunk Method (String, String)

Run code

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static bool DoChunk(
    string script,
    string name
)
Public Shared Function DoChunk ( _
    script As String, _
    name As String _
) As Boolean
public:
static bool^ DoChunk(
    String^ script,
    String^ name
)

Parameters

script
Type: String
The script.
name
Type: String
The name.

Return Value

true if success, false otherwise.

See Also

LuaBot Class
DoChunk Overload
robotManager.Helpful Namespace


DoChunk Method (String, LuaResult, String, Boolean, String)

LuaBot..::..DoChunk Method (String, LuaResult%, String%, Boolean, String)

Run code

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static bool DoChunk(
    string script,
    out LuaResult luaResult,
    out string errors,
    bool logErrors,
    string name
)
Public Shared Function DoChunk ( _
    script As String, _
    <OutAttribute> ByRef luaResult As LuaResult, _
    <OutAttribute> ByRef errors As String, _
    logErrors As Boolean, _
    name As String _
) As Boolean
public:
static bool^ DoChunk(
    String^ script,
    [OutAttribute] LuaResult^% luaResult,
    [OutAttribute] String^% errors,
    bool^ logErrors,
    String^ name
)

Parameters

script
Type: String
The script.
luaResult
Type: LuaResult%
The lua result.
errors
Type: String %
The errors.
logErrors
Type: Boolean
if set to true [log errors].
name
Type: String
The name.

Return Value

true if success, false otherwise.

See Also

LuaBot Class
DoChunk Overload
robotManager.Helpful Namespace


LuaBot Properties

The LuaBot type exposes the following members.

Properties

Name | Description
EnvironmentDynamic | Gets the Environment dynamic.

See Also

LuaBot Class
robotManager.Helpful Namespace


EnvironmentDynamic Property

LuaBot..::..EnvironmentDynamic Property

Gets the Environment dynamic.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static Object EnvironmentDynamic { get; }
Public Shared ReadOnly Property EnvironmentDynamic As Object
    Get
public:
static property Object^ EnvironmentDynamic {
    Object^ get ();
}

Field Value

The environment dynamic.

See Also

LuaBot Class
robotManager.Helpful Namespace


Math Class

Class Math.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static class Math
Public NotInheritable Class Math
public ref class Math abstract sealed

Inheritance Hierarchy

Object
robotManager.Helpful..::..Math

See Also

Math Members
robotManager.Helpful Namespace


Math Members

The Math type exposes the following members.

Methods

Name | Description
Clamp | Returns value clamped to the inclusive range of min and max.
DegreeToRadian | Degree to radian
DistanceListVectors3 | Total distance of path
GetAngle(Single, Single) | Return Angle to pos x =0 z = 0.
GetAngle(Vector3, Vector3) | Get angle from A to B
GetPosition2DOfAngleAndDistance | Get the position 2D by angle and distance.
GetPosition2DOfAngleAndPitchAndDistance | Get the position 3D by angle, pitch and distance.
GetPostion2DOfLineByDistance | Get position 2D on the line (a-b) by distance
GetPostion3DOfLineByDistance | Get position 3D on the line (a-b) by distance
GetPostionOffsetBy3DDistance | Get position 3D on the line (a-b) by distance
GetRadian | Get radian rotation from A to B.
GetRadianDiff | Get radian rotation difference.
GetRandomPointInCircle(Single, Single, Single) | Gets the random point in circle.
GetRandomPointInCircle(Vector3, Single) | Gets the random point in circle.
NearestVector3OfListVectors3 | Find the nearest position in the list of positions (return a id).
NormalizeRadian | Normalizes the radian.
RadianToDegree | Radian to degree
SameListVectors3 | Is same list of position?.
TargetFacingToRadian | Facing position B from A radian.

See Also

Math Class
robotManager.Helpful Namespace


Math Methods

The Math type exposes the following members.

Methods

Name | Description
Clamp | Returns value clamped to the inclusive range of min and max.
DegreeToRadian | Degree to radian
DistanceListVectors3 | Total distance of path
GetAngle(Single, Single) | Return Angle to pos x =0 z = 0.
GetAngle(Vector3, Vector3) | Get angle from A to B
GetPosition2DOfAngleAndDistance | Get the position 2D by angle and distance.
GetPosition2DOfAngleAndPitchAndDistance | Get the position 3D by angle, pitch and distance.
GetPostion2DOfLineByDistance | Get position 2D on the line (a-b) by distance
GetPostion3DOfLineByDistance | Get position 3D on the line (a-b) by distance
GetPostionOffsetBy3DDistance | Get position 3D on the line (a-b) by distance
GetRadian | Get radian rotation from A to B.
GetRadianDiff | Get radian rotation difference.
GetRandomPointInCircle(Single, Single, Single) | Gets the random point in circle.
GetRandomPointInCircle(Vector3, Single) | Gets the random point in circle.
NearestVector3OfListVectors3 | Find the nearest position in the list of positions (return a id).
NormalizeRadian | Normalizes the radian.
RadianToDegree | Radian to degree
SameListVectors3 | Is same list of position?.
TargetFacingToRadian | Facing position B from A radian.

See Also

Math Class
robotManager.Helpful Namespace


Clamp Method

Math..::..Clamp Method

Returns value clamped to the inclusive range of min and max.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static float Clamp(
    float f,
    float Min,
    float Max
)
Public Shared Function Clamp ( _
    f As Single, _
    Min As Single, _
    Max As Single _
) As Single
public:
static float^ Clamp(
    float^ f,
    float^ Min,
    float^ Max
)

Parameters

f
Type: Single
The value.
Min
Type: Single
Determines the minimum value.
Max
Type: Single
Determines the maximum value.

Return Value

value clamped.

See Also

Math Class
robotManager.Helpful Namespace


DegreeToRadian Method

Math..::..DegreeToRadian Method

Degree to radian

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static float DegreeToRadian(
    float degrees
)
Public Shared Function DegreeToRadian ( _
    degrees As Single _
) As Single
public:
static float^ DegreeToRadian(
    float^ degrees
)

Parameters

degrees
Type: Single
The degrees.

Return Value

radian.

See Also

Math Class
robotManager.Helpful Namespace


DistanceListVectors3 Method

Math..::..DistanceListVectors3 Method

Total distance of path

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static float DistanceListVectors3(
    List<Vector3> listVectors3,
    Vector3 myPosition
)
Public Shared Function DistanceListVectors3 ( _
    listVectors3 As List(Of Vector3), _
    myPosition As Vector3 _
) As Single
public:
static float^ DistanceListVectors3(
    List<Vector3^>^ listVectors3,
    Vector3^ myPosition
)

Parameters

listVectors3
Type: List <(Of <(<' Vector3 >)>)>
The path.
myPosition
Type: robotManager.Helpful..::..Vector3
Start position if not in path.

Return Value

distance.

See Also

Math Class
robotManager.Helpful Namespace


GetAngle Method

Math..::..GetAngle Method

Overload List

Name | Description
GetAngle(Single, Single) | Return Angle to pos x =0 z = 0.
GetAngle(Vector3, Vector3) | Get angle from A to B

See Also

Math Class
Math Members
robotManager.Helpful Namespace


GetAngle Method (Single, Single)

Math..::..GetAngle Method (Single, Single)

Return Angle to pos x =0 z = 0.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static float GetAngle(
    float x,
    float y
)
Public Shared Function GetAngle ( _
    x As Single, _
    y As Single _
) As Single
public:
static float^ GetAngle(
    float^ x,
    float^ y
)

Parameters

x
Type: Single
The x.
y
Type: Single
The y.

Return Value

Angle.

See Also

Math Class
GetAngle Overload
robotManager.Helpful Namespace


GetAngle Method (Vector3, Vector3)

Math..::..GetAngle Method (Vector3, Vector3)

Get angle from A to B

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static float GetAngle(
    Vector3 Vector3A,
    Vector3 Vector3B
)
Public Shared Function GetAngle ( _
    Vector3A As Vector3, _
    Vector3B As Vector3 _
) As Single
public:
static float^ GetAngle(
    Vector3^ Vector3A,
    Vector3^ Vector3B
)

Parameters

Vector3A
Type: robotManager.Helpful..::..Vector3
The position A.
Vector3B
Type: robotManager.Helpful..::..Vector3
The position B.

Return Value

angle.

See Also

Math Class
GetAngle Overload
robotManager.Helpful Namespace


GetPosition2DOfAngleAndDistance Method

Math..::..GetPosition2DOfAngleAndDistance Method

Get the position 2D by angle and distance.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static Vector3 GetPosition2DOfAngleAndDistance(
    Vector3 a,
    float angle,
    float distance
)
Public Shared Function GetPosition2DOfAngleAndDistance ( _
    a As Vector3, _
    angle As Single, _
    distance As Single _
) As Vector3
public:
static Vector3^ GetPosition2DOfAngleAndDistance(
    Vector3^ a,
    float^ angle,
    float^ distance
)

Parameters

a
Type: robotManager.Helpful..::..Vector3
from position a.
angle
Type: Single
The angle.
distance
Type: Single
The distance.

Return Value

position 2D.

See Also

Math Class
robotManager.Helpful Namespace


GetPosition2DOfAngleAndPitchAndDistance Method

Math..::..GetPosition2DOfAngleAndPitchAndDistance Method

Get the position 3D by angle, pitch and distance.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static Vector3 GetPosition2DOfAngleAndPitchAndDistance(
    Vector3 from,
    float distance,
    float rotationRadians,
    float pitchRadians
)
Public Shared Function GetPosition2DOfAngleAndPitchAndDistance ( _
    from As Vector3, _
    distance As Single, _
    rotationRadians As Single, _
    pitchRadians As Single _
) As Vector3
public:
static Vector3^ GetPosition2DOfAngleAndPitchAndDistance(
    Vector3^ from,
    float^ distance,
    float^ rotationRadians,
    float^ pitchRadians
)

Parameters

from
Type: robotManager.Helpful..::..Vector3
from position a.
distance
Type: Single
The distance.
rotationRadians
Type: Single
The angle.
pitchRadians
Type: Single
The pitch.

Return Value

position 3D.

See Also

Math Class
robotManager.Helpful Namespace


GetPostion2DOfLineByDistance Method

Math..::..GetPostion2DOfLineByDistance Method

Get position 2D on the line (a-b) by distance

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static Vector3 GetPostion2DOfLineByDistance(
    Vector3 a,
    Vector3 b,
    float distance
)
Public Shared Function GetPostion2DOfLineByDistance ( _
    a As Vector3, _
    b As Vector3, _
    distance As Single _
) As Vector3
public:
static Vector3^ GetPostion2DOfLineByDistance(
    Vector3^ a,
    Vector3^ b,
    float^ distance
)

Parameters

a
Type: robotManager.Helpful..::..Vector3
line start a.
b
Type: robotManager.Helpful..::..Vector3
one point of line b.
distance
Type: Single
The distance.

Return Value

position 2d.

See Also

Math Class
robotManager.Helpful Namespace


GetPostion3DOfLineByDistance Method

Math..::..GetPostion3DOfLineByDistance Method

Get position 3D on the line (a-b) by distance

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static Vector3 GetPostion3DOfLineByDistance(
    Vector3 a,
    Vector3 b,
    float distance
)
Public Shared Function GetPostion3DOfLineByDistance ( _
    a As Vector3, _
    b As Vector3, _
    distance As Single _
) As Vector3
public:
static Vector3^ GetPostion3DOfLineByDistance(
    Vector3^ a,
    Vector3^ b,
    float^ distance
)

Parameters

a
Type: robotManager.Helpful..::..Vector3
line start a.
b
Type: robotManager.Helpful..::..Vector3
one point of line b.
distance
Type: Single
The distance.

Return Value

position 3d.

See Also

Math Class
robotManager.Helpful Namespace


GetPostionOffsetBy3DDistance Method

Math..::..GetPostionOffsetBy3DDistance Method

Get position 3D on the line (a-b) by distance

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static Vector3 GetPostionOffsetBy3DDistance(
    Vector3 a,
    Vector3 b,
    float distance
)
Public Shared Function GetPostionOffsetBy3DDistance ( _
    a As Vector3, _
    b As Vector3, _
    distance As Single _
) As Vector3
public:
static Vector3^ GetPostionOffsetBy3DDistance(
    Vector3^ a,
    Vector3^ b,
    float^ distance
)

Parameters

a
Type: robotManager.Helpful..::..Vector3
line start a.
b
Type: robotManager.Helpful..::..Vector3
one point of line b.
distance
Type: Single
The distance.

Return Value

position 3d.

See Also

Math Class
robotManager.Helpful Namespace


GetRadian Method

Math..::..GetRadian Method

Get radian rotation from A to B.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static float GetRadian(
    Vector3 pos,
    Vector3 pos2
)
Public Shared Function GetRadian ( _
    pos As Vector3, _
    pos2 As Vector3 _
) As Single
public:
static float^ GetRadian(
    Vector3^ pos,
    Vector3^ pos2
)

Parameters

pos
Type: robotManager.Helpful..::..Vector3
position A.
pos2
Type: robotManager.Helpful..::..Vector3
position B.

Return Value

radian.

See Also

Math Class
robotManager.Helpful Namespace


GetRadianDiff Method

Math..::..GetRadianDiff Method

Get radian rotation difference.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static float GetRadianDiff(
    float rot1,
    float rot2
)
Public Shared Function GetRadianDiff ( _
    rot1 As Single, _
    rot2 As Single _
) As Single
public:
static float^ GetRadianDiff(
    float^ rot1,
    float^ rot2
)

Parameters

rot1
Type: Single
The rot1.
rot2
Type: Single
The rot2.

Return Value

rotation difference.

See Also

Math Class
robotManager.Helpful Namespace


GetRandomPointInCircle Method

Math..::..GetRandomPointInCircle Method

Overload List

Name | Description
GetRandomPointInCircle(Single, Single, Single) | Gets the random point in circle.
GetRandomPointInCircle(Vector3, Single) | Gets the random point in circle.

See Also

Math Class
Math Members
robotManager.Helpful Namespace


GetRandomPointInCircle Method (Single, Single, Single)

Math..::..GetRandomPointInCircle Method (Single, Single, Single)

Gets the random point in circle.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static PointF GetRandomPointInCircle(
    float posX,
    float posY,
    float radius
)
Public Shared Function GetRandomPointInCircle ( _
    posX As Single, _
    posY As Single, _
    radius As Single _
) As PointF
public:
static PointF^ GetRandomPointInCircle(
    float^ posX,
    float^ posY,
    float^ radius
)

Parameters

posX
Type: Single
The position x.
posY
Type: Single
The position y.
radius
Type: Single
The radius.

Return Value

PointF.

See Also

Math Class
GetRandomPointInCircle Overload
robotManager.Helpful Namespace


GetRandomPointInCircle Method (Vector3, Single)

Math..::..GetRandomPointInCircle Method (Vector3, Single)

Gets the random point in circle.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static Vector3 GetRandomPointInCircle(
    Vector3 center,
    float radius
)
Public Shared Function GetRandomPointInCircle ( _
    center As Vector3, _
    radius As Single _
) As Vector3
public:
static Vector3^ GetRandomPointInCircle(
    Vector3^ center,
    float^ radius
)

Parameters

center
Type: robotManager.Helpful..::..Vector3
The center.
radius
Type: Single
The radius.

Return Value

Vector3.

See Also

Math Class
GetRandomPointInCircle Overload
robotManager.Helpful Namespace


NearestVector3OfListVectors3 Method

Math..::..NearestVector3OfListVectors3 Method

Find the nearest position in the list of positions (return a id).

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static int NearestVector3OfListVectors3(
    List<Vector3> listVector3,
    Vector3 Vector3
)
Public Shared Function NearestVector3OfListVectors3 ( _
    listVector3 As List(Of Vector3), _
    Vector3 As Vector3 _
) As Integer
public:
static int^ NearestVector3OfListVectors3(
    List<Vector3^>^ listVector3,
    Vector3^ Vector3
)

Parameters

listVector3
Type: List <(Of <(<' Vector3 >)>)>
The list positions.
Vector3
Type: robotManager.Helpful..::..Vector3
The position.

Return Value

list index of nearest position.

See Also

Math Class
robotManager.Helpful Namespace


NormalizeRadian Method

Math..::..NormalizeRadian Method

Normalizes the radian.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static float NormalizeRadian(
    float radian
)
Public Shared Function NormalizeRadian ( _
    radian As Single _
) As Single
public:
static float^ NormalizeRadian(
    float^ radian
)

Parameters

radian
Type: Single
The radian.

Return Value

radian normalized.

See Also

Math Class
robotManager.Helpful Namespace


RadianToDegree Method

Math..::..RadianToDegree Method

Radian to degree

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static float RadianToDegree(
    float radianValue
)
Public Shared Function RadianToDegree ( _
    radianValue As Single _
) As Single
public:
static float^ RadianToDegree(
    float^ radianValue
)

Parameters

radianValue
Type: Single
The radian value.

Return Value

degree.

See Also

Math Class
robotManager.Helpful Namespace


SameListVectors3 Method

Math..::..SameListVectors3 Method

Is same list of position?.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static bool SameListVectors3(
    List<Vector3> listVectors3_1,
    List<Vector3> listVectors3_2
)
Public Shared Function SameListVectors3 ( _
    listVectors3_1 As List(Of Vector3), _
    listVectors3_2 As List(Of Vector3) _
) As Boolean
public:
static bool^ SameListVectors3(
    List<Vector3^>^ listVectors3_1,
    List<Vector3^>^ listVectors3_2
)

Parameters

listVectors3_1
Type: List <(Of <(<' Vector3 >)>)>
The list 1.
listVectors3_2
Type: List <(Of <(<' Vector3 >)>)>
The list 2.

Return Value

true if same list, false otherwise.

See Also

Math Class
robotManager.Helpful Namespace


TargetFacingToRadian Method

Math..::..TargetFacingToRadian Method

Facing position B from A radian.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static float TargetFacingToRadian(
    Vector3 start,
    Vector3 faceTarget
)
Public Shared Function TargetFacingToRadian ( _
    start As Vector3, _
    faceTarget As Vector3 _
) As Single
public:
static float^ TargetFacingToRadian(
    Vector3^ start,
    Vector3^ faceTarget
)

Parameters

start
Type: robotManager.Helpful..::..Vector3
position A.
faceTarget
Type: robotManager.Helpful..::..Vector3
position B.

Return Value

radian facing.

See Also

Math Class
robotManager.Helpful Namespace


ModifierKeys Enumeration

The enumeration of possible modifiers.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[FlagsAttribute]
public enum ModifierKeys
<FlagsAttribute> _
Public Enumeration ModifierKeys
[FlagsAttribute]
public enum class ModifierKeys

Members

Member name | Description
Alt | ALT
Control | CTRL
Shift | shift
Win | win

See Also

robotManager.Helpful Namespace


Mouse Class

Class Mouse.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public class Mouse
Public Class Mouse
public ref class Mouse

Inheritance Hierarchy

Object
robotManager.Helpful..::..Mouse

See Also

Mouse Members
robotManager.Helpful Namespace


Mouse Members

The Mouse type exposes the following members.

Methods

 | Name | Description
 | ClickLeft | Click Left.
 | ClickRight | Click Right.
 | ClickRoller | Click Roller.
 | CurseurPosition | Position Curseur.
 | CurseurWindowPercentagePosition | Position Curseur in window.
 | CurseurWindowPosition | Position Curseur in window.
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Mouse Class
robotManager.Helpful Namespace


Mouse Methods

The Mouse type exposes the following members.

Methods

 | Name | Description
 | ClickLeft | Click Left.
 | ClickRight | Click Right.
 | ClickRoller | Click Roller.
 | CurseurPosition | Position Curseur.
 | CurseurWindowPercentagePosition | Position Curseur in window.
 | CurseurWindowPosition | Position Curseur in window.
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Mouse Class
robotManager.Helpful Namespace


ClickLeft Method

Mouse..::..ClickLeft Method

Click Left.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void ClickLeft()
Public Shared Sub ClickLeft
public:
static void ClickLeft()

See Also

Mouse Class
robotManager.Helpful Namespace


ClickRight Method

Mouse..::..ClickRight Method

Click Right.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void ClickRight()
Public Shared Sub ClickRight
public:
static void ClickRight()

See Also

Mouse Class
robotManager.Helpful Namespace


ClickRoller Method

Mouse..::..ClickRoller Method

Click Roller.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void ClickRoller()
Public Shared Sub ClickRoller
public:
static void ClickRoller()

See Also

Mouse Class
robotManager.Helpful Namespace


CurseurPosition Method

Mouse..::..CurseurPosition Method

Position Curseur.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void CurseurPosition(
    int posX,
    int posY
)
Public Shared Sub CurseurPosition ( _
    posX As Integer, _
    posY As Integer _
)
public:
static void CurseurPosition(
    int^ posX,
    int^ posY
)

Parameters

posX
Type: Int32
The position x.
posY
Type: Int32
The position y.

See Also

Mouse Class
robotManager.Helpful Namespace


CurseurWindowPercentagePosition Method

Mouse..::..CurseurWindowPercentagePosition Method

Position Curseur in window.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void CurseurWindowPercentagePosition(
    IntPtr mainWindowHandle,
    int percentageX,
    int percentageY
)
Public Shared Sub CurseurWindowPercentagePosition ( _
    mainWindowHandle As IntPtr, _
    percentageX As Integer, _
    percentageY As Integer _
)
public:
static void CurseurWindowPercentagePosition(
    IntPtr^ mainWindowHandle,
    int^ percentageX,
    int^ percentageY
)

Parameters

mainWindowHandle
Type: IntPtr
The main window handle.
percentageX
Type: Int32
The percentage x.
percentageY
Type: Int32
The percentage y.

See Also

Mouse Class
robotManager.Helpful Namespace


CurseurWindowPosition Method

Mouse..::..CurseurWindowPosition Method

Position Curseur in window.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void CurseurWindowPosition(
    IntPtr mainWindowHandle,
    int posX,
    int posY
)
Public Shared Sub CurseurWindowPosition ( _
    mainWindowHandle As IntPtr, _
    posX As Integer, _
    posY As Integer _
)
public:
static void CurseurWindowPosition(
    IntPtr^ mainWindowHandle,
    int^ posX,
    int^ posY
)

Parameters

mainWindowHandle
Type: IntPtr
The main window handle.
posX
Type: Int32
The position x.
posY
Type: Int32
The position y.

See Also

Mouse Class
robotManager.Helpful Namespace


Others Class

Class Others. Several useful methods.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static class Others
Public NotInheritable Class Others
public ref class Others abstract sealed

Inheritance Hierarchy

Object
robotManager.Helpful..::..Others

See Also

Others Members
robotManager.Helpful Namespace


Others Members

The Others type exposes the following members.

Methods

Name | Description
__ROL1__ | ROL1
__ROL2__ | ROL2
__ROL4__ | ROL4
__ROL8__ | _ROL8
__ROR1__ | ROR1
__ROR2__ | ROR2
__ROR4__ | ROR4
__ROR8__ | ROR8
ArrayToTextByLine | Strings array to string (separate by new line).
CallBack | Call Action every X milliseconds X times.
CallBackAfter | Call Action after X milliseconds.
CallBackEvery | Call Action every X milliseconds.
CreateShortcut | Create Windows shortcut
DelFileNameIllegalChar | Delete file name illegal character.
DelSpecialChar | Delete the specials characters.
DialogBoxOpenFile | "Open File" dialog box and return selected file path.
DialogBoxOpenFileMultiselect | "Open File" (multi files mode) dialog box and return selected files paths.
DialogBoxSaveFile | "Save File" dialog box and return selected file path.
DoEvents | Application.DoEvents (refresh UI, works with wpf et winform).
DownloadFile | Download file from http address, return true if success.
EncrypterMD5 | Return MD5.
EncryptStringToString | Return a decrypted text.
ExistFile | Return true if File exist.
GetFileMd5CheckSum | Return the MD5 checksum of the file.
GetFilesDirectory | Return a list of the file.
GetFilesDirectoryAndSubDirectory | Return a list of the file on folder and subfolders.
GetFileSize | Return file size, return -1 if error.
GetFileSizeHttp | Get file size from http address, return -1 if error.
GetRandomString | Get random string.
GetRandomStringReadable | Get random string readable.
GetRequest(String, String) | Return the code source of the page. Sample: GetRequest("http://www.google.com/index.php", "a=5&b=10" )
GetRequest(String, String, Boolean, Int32) | Return the code source of the page. Sample: GetRequest("http://www.google.com/index.php", "a=5&b=10" )
GetReqWithAuthHeader | Request with authentication header.
GetStackTrace | Get call stack trace.
GetVisualCpp2010 | Gets if visual C++2010 is installed.
HardDriveID | HardDrive ID.
IsUserAdministrator | Determines whether is administrator Windows user.
OpenWebBrowserOrApplication | Open WebBrowser or Windows explorer
ParseDouble(String, Double%) | String to double.
ParseDouble(String) | String to double.
ParseDouble(String, Boolean%) | String to double.
ParseFloat(String, Single%) | String to float.
ParseFloat(String) | String to float.
ParseFloat(String, Boolean%) | String to float.
ParseInt(String, Int32%) | String to int.
ParseInt(String) | String to int.
ParseInt(String, Boolean%) | String to int.
ParseLong(String, Int64%) | String to long.
ParseLong(String) | String to long.
ParseLong(String, Boolean%) | String to long.
ParseUInt(String, UInt32%) | String to uint.
ParseUInt(String) | String to uint.
ParseUInt(String, Boolean%) | String to uint.
PathCombine | Combines an array of strings into a path (file path).
PostRequest | Post request.
Random(Double, Double) | Random double.
Random(Int32, Int32) | Return Random number.
Random()()()() | Get Random instance.
ReadFile | Read file content to string.
ReadFileAllLines | Read file and return array by line.
RemoveFile | Remove file.
ReplaceUpperCharBySpaceChar | Replace upper char by space.
SecToHour | int Seconds to string HH:MM:SS.
ShutDownPc | ShutDown the Computer.
StringArrayToListInt | Strings array to int arrays.
StringBetween | Find strings between two string delimiters
StringToEncryptString | Return a encrypted text.
StringToListInt | Strings to list int.
TextToArrayByLine | String to strings array by line.
ToUtf8(String) | Text to UTF8.
ToUtf8(array<Byte>[]()[][]) | Converts to utf8.
Wait | Wait.
WriteFile | Write string file.

Properties

Name | Description
GetCurrentDirectory | Get current directory (like "C:\program\WRobot").
GetTempFolder | Get temporary directory path.
Times | Gets the number of milliseconds elapsed since the system started.
TimesSec | Gets the number of seconds elapsed since the system started.
WindowsVersion | Get Windows version.

See Also

Others Class
robotManager.Helpful Namespace


Others Methods

The Others type exposes the following members.

Methods

Name | Description
__ROL1__ | ROL1
__ROL2__ | ROL2
__ROL4__ | ROL4
__ROL8__ | _ROL8
__ROR1__ | ROR1
__ROR2__ | ROR2
__ROR4__ | ROR4
__ROR8__ | ROR8
ArrayToTextByLine | Strings array to string (separate by new line).
CallBack | Call Action every X milliseconds X times.
CallBackAfter | Call Action after X milliseconds.
CallBackEvery | Call Action every X milliseconds.
CreateShortcut | Create Windows shortcut
DelFileNameIllegalChar | Delete file name illegal character.
DelSpecialChar | Delete the specials characters.
DialogBoxOpenFile | "Open File" dialog box and return selected file path.
DialogBoxOpenFileMultiselect | "Open File" (multi files mode) dialog box and return selected files paths.
DialogBoxSaveFile | "Save File" dialog box and return selected file path.
DoEvents | Application.DoEvents (refresh UI, works with wpf et winform).
DownloadFile | Download file from http address, return true if success.
EncrypterMD5 | Return MD5.
EncryptStringToString | Return a decrypted text.
ExistFile | Return true if File exist.
GetFileMd5CheckSum | Return the MD5 checksum of the file.
GetFilesDirectory | Return a list of the file.
GetFilesDirectoryAndSubDirectory | Return a list of the file on folder and subfolders.
GetFileSize | Return file size, return -1 if error.
GetFileSizeHttp | Get file size from http address, return -1 if error.
GetRandomString | Get random string.
GetRandomStringReadable | Get random string readable.
GetRequest(String, String) | Return the code source of the page. Sample: GetRequest("http://www.google.com/index.php", "a=5&b=10" )
GetRequest(String, String, Boolean, Int32) | Return the code source of the page. Sample: GetRequest("http://www.google.com/index.php", "a=5&b=10" )
GetReqWithAuthHeader | Request with authentication header.
GetStackTrace | Get call stack trace.
GetVisualCpp2010 | Gets if visual C++2010 is installed.
HardDriveID | HardDrive ID.
IsUserAdministrator | Determines whether is administrator Windows user.
OpenWebBrowserOrApplication | Open WebBrowser or Windows explorer
ParseDouble(String, Double%) | String to double.
ParseDouble(String) | String to double.
ParseDouble(String, Boolean%) | String to double.
ParseFloat(String, Single%) | String to float.
ParseFloat(String) | String to float.
ParseFloat(String, Boolean%) | String to float.
ParseInt(String, Int32%) | String to int.
ParseInt(String) | String to int.
ParseInt(String, Boolean%) | String to int.
ParseLong(String, Int64%) | String to long.
ParseLong(String) | String to long.
ParseLong(String, Boolean%) | String to long.
ParseUInt(String, UInt32%) | String to uint.
ParseUInt(String) | String to uint.
ParseUInt(String, Boolean%) | String to uint.
PathCombine | Combines an array of strings into a path (file path).
PostRequest | Post request.
Random(Double, Double) | Random double.
Random(Int32, Int32) | Return Random number.
Random()()()() | Get Random instance.
ReadFile | Read file content to string.
ReadFileAllLines | Read file and return array by line.
RemoveFile | Remove file.
ReplaceUpperCharBySpaceChar | Replace upper char by space.
SecToHour | int Seconds to string HH:MM:SS.
ShutDownPc | ShutDown the Computer.
StringArrayToListInt | Strings array to int arrays.
StringBetween | Find strings between two string delimiters
StringToEncryptString | Return a encrypted text.
StringToListInt | Strings to list int.
TextToArrayByLine | String to strings array by line.
ToUtf8(String) | Text to UTF8.
ToUtf8(array<Byte>[]()[][]) | Converts to utf8.
Wait | Wait.
WriteFile | Write string file.

See Also

Others Class
robotManager.Helpful Namespace


__ROL1__ Method

Others..::..__ROL1__ Method

ROL1

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static byte __ROL1__(
    byte value,
    int count
)
Public Shared Function __ROL1__ ( _
    value As Byte, _
    count As Integer _
) As Byte
public:
static unsigned char^ __ROL1__(
    unsigned char^ value,
    int^ count
)

Parameters

value
Type: Byte
The value.
count
Type: Int32
The count.

Return Value

System.Byte.

See Also

Others Class
robotManager.Helpful Namespace


__ROL2__ Method

Others..::..__ROL2__ Method

ROL2

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static ushort __ROL2__(
    ushort value,
    int count
)
Public Shared Function __ROL2__ ( _
    value As UShort, _
    count As Integer _
) As UShort
public:
static unsigned short^ __ROL2__(
    unsigned short^ value,
    int^ count
)

Parameters

value
Type: UInt16
The value.
count
Type: Int32
The count.

Return Value

System.UInt16.

See Also

Others Class
robotManager.Helpful Namespace


__ROL4__ Method

Others..::..__ROL4__ Method

ROL4

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static uint __ROL4__(
    uint value,
    int count
)
Public Shared Function __ROL4__ ( _
    value As UInteger, _
    count As Integer _
) As UInteger
public:
static unsigned int^ __ROL4__(
    unsigned int^ value,
    int^ count
)

Parameters

value
Type: UInt32
The value.
count
Type: Int32
The count.

Return Value

System.UInt32.

See Also

Others Class
robotManager.Helpful Namespace


__ROL8__ Method

Others..::..__ROL8__ Method

_ROL8

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static ulong __ROL8__(
    ulong value,
    int count
)
Public Shared Function __ROL8__ ( _
    value As ULong, _
    count As Integer _
) As ULong
public:
static unsigned long long^ __ROL8__(
    unsigned long long^ value,
    int^ count
)

Parameters

value
Type: UInt64
The value.
count
Type: Int32
The count.

Return Value

System.UInt64.

See Also

Others Class
robotManager.Helpful Namespace


__ROR1__ Method

Others..::..__ROR1__ Method

ROR1

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static byte __ROR1__(
    byte value,
    int count
)
Public Shared Function __ROR1__ ( _
    value As Byte, _
    count As Integer _
) As Byte
public:
static unsigned char^ __ROR1__(
    unsigned char^ value,
    int^ count
)

Parameters

value
Type: Byte
The value.
count
Type: Int32
The count.

Return Value

System.Byte.

See Also

Others Class
robotManager.Helpful Namespace


__ROR2__ Method

Others..::..__ROR2__ Method

ROR2

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static ushort __ROR2__(
    ushort value,
    int count
)
Public Shared Function __ROR2__ ( _
    value As UShort, _
    count As Integer _
) As UShort
public:
static unsigned short^ __ROR2__(
    unsigned short^ value,
    int^ count
)

Parameters

value
Type: UInt16
The value.
count
Type: Int32
The count.

Return Value

System.UInt16.

See Also

Others Class
robotManager.Helpful Namespace


__ROR4__ Method

Others..::..__ROR4__ Method

ROR4

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static uint __ROR4__(
    uint value,
    int count
)
Public Shared Function __ROR4__ ( _
    value As UInteger, _
    count As Integer _
) As UInteger
public:
static unsigned int^ __ROR4__(
    unsigned int^ value,
    int^ count
)

Parameters

value
Type: UInt32
The value.
count
Type: Int32
The count.

Return Value

System.UInt32.

See Also

Others Class
robotManager.Helpful Namespace


__ROR8__ Method

Others..::..__ROR8__ Method

ROR8

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static ulong __ROR8__(
    ulong value,
    int count
)
Public Shared Function __ROR8__ ( _
    value As ULong, _
    count As Integer _
) As ULong
public:
static unsigned long long^ __ROR8__(
    unsigned long long^ value,
    int^ count
)

Parameters

value
Type: UInt64
The value.
count
Type: Int32
The count.

Return Value

System.UInt64.

See Also

Others Class
robotManager.Helpful Namespace


ArrayToTextByLine Method

Others..::..ArrayToTextByLine Method

Strings array to string (separate by new line).

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static string ArrayToTextByLine(
    string[] array
)
Public Shared Function ArrayToTextByLine ( _
    array As String() _
) As String
public:
static String^ ArrayToTextByLine(
    array<String^>^ array
)

Parameters

array
Type: array< String >[]()[][]
The strings array.

Return Value

multilines string.

See Also

Others Class
robotManager.Helpful Namespace


CallBack Method

Others..::..CallBack Method

Call Action every X milliseconds X times.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void CallBack(
    long ms,
    int numberOfTimes,
    Action callBack
)
Public Shared Sub CallBack ( _
    ms As Long, _
    numberOfTimes As Integer, _
    callBack As Action _
)
public:
static void CallBack(
    long long^ ms,
    int^ numberOfTimes,
    Action^ callBack
)

Parameters

ms
Type: Int64
The milliseconds.
numberOfTimes
Type: Int32
The number of times to call Action.
callBack
Type: Action
Action to call.

See Also

Others Class
robotManager.Helpful Namespace


CallBackAfter Method

Others..::..CallBackAfter Method

Call Action after X milliseconds.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void CallBackAfter(
    long ms,
    Action callBack
)
Public Shared Sub CallBackAfter ( _
    ms As Long, _
    callBack As Action _
)
public:
static void CallBackAfter(
    long long^ ms,
    Action^ callBack
)

Parameters

ms
Type: Int64
The milliseconds.
callBack
Type: Action
Action to call.

See Also

Others Class
robotManager.Helpful Namespace


CallBackEvery Method

Others..::..CallBackEvery Method

Call Action every X milliseconds.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static Timer CallBackEvery(
    long ms,
    Action callBack
)
Public Shared Function CallBackEvery ( _
    ms As Long, _
    callBack As Action _
) As Timer
public:
static Timer^ CallBackEvery(
    long long^ ms,
    Action^ callBack
)

Parameters

ms
Type: Int64
The milliseconds.
callBack
Type: Action
Action to call.

Return Value

Timer used to call

See Also

Others Class
robotManager.Helpful Namespace


CreateShortcut Method

Others..::..CreateShortcut Method

Create Windows shortcut

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void CreateShortcut(
    string sourceFile,
    string shortcutFile,
    string description,
    string arguments,
    string hotKey,
    string workingDirectory
)
Public Shared Sub CreateShortcut ( _
    sourceFile As String, _
    shortcutFile As String, _
    description As String, _
    arguments As String, _
    hotKey As String, _
    workingDirectory As String _
)
public:
static void CreateShortcut(
    String^ sourceFile,
    String^ shortcutFile,
    String^ description,
    String^ arguments,
    String^ hotKey,
    String^ workingDirectory
)

Parameters

sourceFile
Type: String
A file you want to make shortcut to
shortcutFile
Type: String
Path and shortcut file name including file extension (.lnk)
description
Type: String
Shortcut description
arguments
Type: String
Command line arguments
hotKey
Type: String
Shortcut hot key as a string, for example "Ctrl+F"
workingDirectory
Type: String
"Start in" shortcut parameter

Exceptions

Exception | Condition
ArgumentNullException | sourceFile
ArgumentNullException | shortcutFile

See Also

Others Class
robotManager.Helpful Namespace


DelFileNameIllegalChar Method

Others..::..DelFileNameIllegalChar Method

Delete file name illegal character.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static string DelFileNameIllegalChar(
    string filename
)
Public Shared Function DelFileNameIllegalChar ( _
    filename As String _
) As String
public:
static String^ DelFileNameIllegalChar(
    String^ filename
)

Parameters

filename
Type: String
The filename.

Return Value

System.String.

See Also

Others Class
robotManager.Helpful Namespace


DelSpecialChar Method

Others..::..DelSpecialChar Method

Delete the specials characters.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static string DelSpecialChar(
    string stringSpecialChar
)
Public Shared Function DelSpecialChar ( _
    stringSpecialChar As String _
) As String
public:
static String^ DelSpecialChar(
    String^ stringSpecialChar
)

Parameters

stringSpecialChar
Type: String
The string with specials characters.

Return Value

System.String.

See Also

Others Class
robotManager.Helpful Namespace


DialogBoxOpenFile Method

Others..::..DialogBoxOpenFile Method

"Open File" dialog box and return selected file path.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static string DialogBoxOpenFile(
    string path,
    string typeFile
)
Public Shared Function DialogBoxOpenFile ( _
    path As String, _
    typeFile As String _
) As String
public:
static String^ DialogBoxOpenFile(
    String^ path,
    String^ typeFile
)

Parameters

path
Type: String
The base path.
typeFile
Type: String
The file type (like "XML files (*.xml)|*.xml").

Return Value

selected file path.

See Also

Others Class
robotManager.Helpful Namespace


DialogBoxOpenFileMultiselect Method

Others..::..DialogBoxOpenFileMultiselect Method

"Open File" (multi files mode) dialog box and return selected files paths.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static string[] DialogBoxOpenFileMultiselect(
    string path,
    string typeFile
)
Public Shared Function DialogBoxOpenFileMultiselect ( _
    path As String, _
    typeFile As String _
) As String()
public:
static array<String^>^ DialogBoxOpenFileMultiselect(
    String^ path,
    String^ typeFile
)

Parameters

path
Type: String
The base path.
typeFile
Type: String
The file type (like "XML files (*.xml)|*.xml").

Return Value

selected files paths.

See Also

Others Class
robotManager.Helpful Namespace


DialogBoxSaveFile Method

Others..::..DialogBoxSaveFile Method

"Save File" dialog box and return selected file path.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static string DialogBoxSaveFile(
    string path,
    string typeFile
)
Public Shared Function DialogBoxSaveFile ( _
    path As String, _
    typeFile As String _
) As String
public:
static String^ DialogBoxSaveFile(
    String^ path,
    String^ typeFile
)

Parameters

path
Type: String
The base path.
typeFile
Type: String
The file type (like "XML files (*.xml)|*.xml").

Return Value

selected file path.

See Also

Others Class
robotManager.Helpful Namespace


DoEvents Method

Others..::..DoEvents Method

Application.DoEvents (refresh UI, works with wpf et winform).

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void DoEvents()
Public Shared Sub DoEvents
public:
static void DoEvents()

See Also

Others Class
robotManager.Helpful Namespace


DownloadFile Method

Others..::..DownloadFile Method

Download file from http address, return true if success.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static bool DownloadFile(
    string httpUrl,
    string fileDest,
    bool showErrorLog,
    bool doEvents
)
Public Shared Function DownloadFile ( _
    httpUrl As String, _
    fileDest As String, _
    showErrorLog As Boolean, _
    doEvents As Boolean _
) As Boolean
public:
static bool^ DownloadFile(
    String^ httpUrl,
    String^ fileDest,
    bool^ showErrorLog,
    bool^ doEvents
)

Parameters

httpUrl
Type: String
The HTTP URL.
fileDest
Type: String
The file dest.
showErrorLog
Type: Boolean
if set to true show errors in log
doEvents
Type: Boolean
if set to true do events when wait (avoid UI freeze).

Return Value

true if success, false otherwise.

See Also

Others Class
robotManager.Helpful Namespace


EncrypterMD5 Method

Others..::..EncrypterMD5 Method

Return MD5.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static string EncrypterMD5(
    string value
)
Public Shared Function EncrypterMD5 ( _
    value As String _
) As String
public:
static String^ EncrypterMD5(
    String^ value
)

Parameters

value
Type: String
The value.

Return Value

System.String.

See Also

Others Class
robotManager.Helpful Namespace


EncryptStringToString Method

Others..::..EncryptStringToString Method

Return a decrypted text.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static string EncryptStringToString(
    string encryptText
)
Public Shared Function EncryptStringToString ( _
    encryptText As String _
) As String
public:
static String^ EncryptStringToString(
    String^ encryptText
)

Parameters

encryptText
Type: String
encrypted text.

Return Value

decrypted text.

See Also

Others Class
robotManager.Helpful Namespace


ExistFile Method

Others..::..ExistFile Method

Return true if File exist.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static bool ExistFile(
    string strPath
)
Public Shared Function ExistFile ( _
    strPath As String _
) As Boolean
public:
static bool^ ExistFile(
    String^ strPath
)

Parameters

strPath
Type: String
The string path.

Return Value

true if exist, false otherwise.

See Also

Others Class
robotManager.Helpful Namespace


GetFileMd5CheckSum Method

Others..::..GetFileMd5CheckSum Method

Return the MD5 checksum of the file.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static string GetFileMd5CheckSum(
    string filePath
)
Public Shared Function GetFileMd5CheckSum ( _
    filePath As String _
) As String
public:
static String^ GetFileMd5CheckSum(
    String^ filePath
)

Parameters

filePath
Type: String
The file path.

Return Value

MD5 checksum.

See Also

Others Class
robotManager.Helpful Namespace


GetFilesDirectory Method

Others..::..GetFilesDirectory Method

Return a list of the file.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static List<string> GetFilesDirectory(
    string pathDirectory,
    string searchPattern
)
Public Shared Function GetFilesDirectory ( _
    pathDirectory As String, _
    searchPattern As String _
) As List(Of String)
public:
static List<String^>^ GetFilesDirectory(
    String^ pathDirectory,
    String^ searchPattern
)

Parameters

pathDirectory
Type: String
The path directory.
searchPattern
Type: String
The search pattern (like "*.dll" or "*.*").

Return Value

Files list.

See Also

Others Class
robotManager.Helpful Namespace


GetFilesDirectoryAndSubDirectory Method

Others..::..GetFilesDirectoryAndSubDirectory Method

Return a list of the file on folder and subfolders.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static List<string> GetFilesDirectoryAndSubDirectory(
    string pathDirectory,
    string searchPattern
)
Public Shared Function GetFilesDirectoryAndSubDirectory ( _
    pathDirectory As String, _
    searchPattern As String _
) As List(Of String)
public:
static List<String^>^ GetFilesDirectoryAndSubDirectory(
    String^ pathDirectory,
    String^ searchPattern
)

Parameters

pathDirectory
Type: String
The path directory.
searchPattern
Type: String
The search pattern (like "*.dll" or "*.*").

Return Value

Files list.

See Also

Others Class
robotManager.Helpful Namespace


GetFileSize Method

Others..::..GetFileSize Method

Return file size, return -1 if error.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static long GetFileSize(
    string strPath
)
Public Shared Function GetFileSize ( _
    strPath As String _
) As Long
public:
static long long^ GetFileSize(
    String^ strPath
)

Parameters

strPath
Type: String
The string path.

Return Value

size.

See Also

Others Class
robotManager.Helpful Namespace


GetFileSizeHttp Method

Others..::..GetFileSizeHttp Method

Get file size from http address, return -1 if error.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static long GetFileSizeHttp(
    string httpUrl
)
Public Shared Function GetFileSizeHttp ( _
    httpUrl As String _
) As Long
public:
static long long^ GetFileSizeHttp(
    String^ httpUrl
)

Parameters

httpUrl
Type: String
The HTTP URL.

Return Value

size

See Also

Others Class
robotManager.Helpful Namespace


GetRandomString Method

Others..::..GetRandomString Method

Get random string.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static string GetRandomString(
    int maxSize
)
Public Shared Function GetRandomString ( _
    maxSize As Integer _
) As String
public:
static String^ GetRandomString(
    int^ maxSize
)

Parameters

maxSize
Type: Int32
The size.

Return Value

System.String.

See Also

Others Class
robotManager.Helpful Namespace


GetRandomStringReadable Method

Others..::..GetRandomStringReadable Method

Get random string readable.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static string GetRandomStringReadable(
    int maxSize,
    bool firstCharUpper
)
Public Shared Function GetRandomStringReadable ( _
    maxSize As Integer, _
    firstCharUpper As Boolean _
) As String
public:
static String^ GetRandomStringReadable(
    int^ maxSize,
    bool^ firstCharUpper
)

Parameters

maxSize
Type: Int32
The size.
firstCharUpper
Type: Boolean
if set to true first character upper case.

Return Value

System.String.

See Also

Others Class
robotManager.Helpful Namespace


GetRequest Method

Others..::..GetRequest Method

Overload List

Name | Description
GetRequest(String, String) | Return the code source of the page. Sample: GetRequest("http://www.google.com/index.php", "a=5&b=10" )
GetRequest(String, String, Boolean, Int32) | Return the code source of the page. Sample: GetRequest("http://www.google.com/index.php", "a=5&b=10" )

See Also

Others Class
Others Members
robotManager.Helpful Namespace


GetRequest Method (String, String)

Others..::..GetRequest Method (String, String)

Return the code source of the page. Sample: GetRequest("http://www.google.com/index.php", "a=5&b=10" )

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static Task<string> GetRequest(
    string url,
    string data
)
Public Shared Function GetRequest ( _
    url As String, _
    data As String _
) As Task(Of String)
public:
static Task<String^>^ GetRequest(
    String^ url,
    String^ data
)

Parameters

url
Type: String
The URL.
data
Type: String
The data.

Return Value

System.String.

See Also

Others Class
GetRequest Overload
robotManager.Helpful Namespace


GetRequest Method (String, String, Boolean, Int32)

Others..::..GetRequest Method (String, String, Boolean, Int32)

Return the code source of the page. Sample: GetRequest("http://www.google.com/index.php", "a=5&b=10" )

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static Task<string> GetRequest(
    string url,
    string data,
    bool showErrors,
    int requestTimeoutMs
)
Public Shared Function GetRequest ( _
    url As String, _
    data As String, _
    showErrors As Boolean, _
    requestTimeoutMs As Integer _
) As Task(Of String)
public:
static Task<String^>^ GetRequest(
    String^ url,
    String^ data,
    bool^ showErrors,
    int^ requestTimeoutMs
)

Parameters

url
Type: String
The URL.
data
Type: String
The data.
showErrors
Type: Boolean
if set to true [show errors].
requestTimeoutMs
Type: Int32
The request timeout ms.

Return Value

System.String.

See Also

Others Class
GetRequest Overload
robotManager.Helpful Namespace


GetReqWithAuthHeader Method

Others..::..GetReqWithAuthHeader Method

Request with authentication header.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static List<string> GetReqWithAuthHeader(
    string url,
    string userName,
    string userPassword,
    string othersValue
)
Public Shared Function GetReqWithAuthHeader ( _
    url As String, _
    userName As String, _
    userPassword As String, _
    othersValue As String _
) As List(Of String)
public:
static List<String^>^ GetReqWithAuthHeader(
    String^ url,
    String^ userName,
    String^ userPassword,
    String^ othersValue
)

Parameters

url
Type: String
The URL.
userName
Type: String
Name of the user.
userPassword
Type: String
The user password.
othersValue
Type: String
The others value.

Return Value

result.

See Also

Others Class
robotManager.Helpful Namespace


GetStackTrace Method

Others..::..GetStackTrace Method

Get call stack trace.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static string GetStackTrace()
Public Shared Function GetStackTrace As String
public:
static String^ GetStackTrace()

Return Value

StackTrace.

See Also

Others Class
robotManager.Helpful Namespace


GetVisualCpp2010 Method

Others..::..GetVisualCpp2010 Method

Gets if visual C++2010 is installed.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void GetVisualCpp2010()
Public Shared Sub GetVisualCpp2010
public:
static void GetVisualCpp2010()

See Also

Others Class
robotManager.Helpful Namespace


HardDriveID Method

Others..::..HardDriveID Method

HardDrive ID.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static int HardDriveID()
Public Shared Function HardDriveID As Integer
public:
static int^ HardDriveID()

Return Value

ID.

See Also

Others Class
robotManager.Helpful Namespace


IsUserAdministrator Method

Others..::..IsUserAdministrator Method

Determines whether is administrator Windows user.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static bool IsUserAdministrator()
Public Shared Function IsUserAdministrator As Boolean
public:
static bool^ IsUserAdministrator()

Return Value

true if is administrator Windows user; otherwise, false.

See Also

Others Class
robotManager.Helpful Namespace


OpenWebBrowserOrApplication Method

Others..::..OpenWebBrowserOrApplication Method

Open WebBrowser or Windows explorer

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void OpenWebBrowserOrApplication(
    string urlOrPath
)
Public Shared Sub OpenWebBrowserOrApplication ( _
    urlOrPath As String _
)
public:
static void OpenWebBrowserOrApplication(
    String^ urlOrPath
)

Parameters

urlOrPath
Type: String
The URL or path.

See Also

Others Class
robotManager.Helpful Namespace


ParseDouble Method

Others..::..ParseDouble Method

Overload List

Name | Description
ParseDouble(String, Double%) | String to double.
ParseDouble(String) | String to double.
ParseDouble(String, Boolean%) | String to double.

See Also

Others Class
Others Members
robotManager.Helpful Namespace


ParseDouble Method (String, Double)

Others..::..ParseDouble Method (String, Double%)

String to double.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static bool ParseDouble(
    string doubleString,
    out double result
)
Public Shared Function ParseDouble ( _
    doubleString As String, _
    <OutAttribute> ByRef result As Double _
) As Boolean
public:
static bool^ ParseDouble(
    String^ doubleString,
    [OutAttribute] double^% result
)

Parameters

doubleString
Type: String
The double string.
result
Type: Double %
The result.

Return Value

true if success, false otherwise.

See Also

Others Class
ParseDouble Overload
robotManager.Helpful Namespace


ParseDouble Method (String)

Others..::..ParseDouble Method (String)

String to double.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static double ParseDouble(
    string doubleString
)
Public Shared Function ParseDouble ( _
    doubleString As String _
) As Double
public:
static double^ ParseDouble(
    String^ doubleString
)

Parameters

doubleString
Type: String
The double string.

Return Value

result.

See Also

Others Class
ParseDouble Overload
robotManager.Helpful Namespace


ParseDouble Method (String, Boolean)

Others..::..ParseDouble Method (String, Boolean%)

String to double.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static double ParseDouble(
    string doubleString,
    out bool result
)
Public Shared Function ParseDouble ( _
    doubleString As String, _
    <OutAttribute> ByRef result As Boolean _
) As Double
public:
static double^ ParseDouble(
    String^ doubleString,
    [OutAttribute] bool^% result
)

Parameters

doubleString
Type: String
The double string.
result
Type: Boolean %
true if success.

Return Value

result.

See Also

Others Class
ParseDouble Overload
robotManager.Helpful Namespace


ParseFloat Method

Others..::..ParseFloat Method

Overload List

Name | Description
ParseFloat(String, Single%) | String to float.
ParseFloat(String) | String to float.
ParseFloat(String, Boolean%) | String to float.

See Also

Others Class
Others Members
robotManager.Helpful Namespace


ParseFloat Method (String, Single)

Others..::..ParseFloat Method (String, Single%)

String to float.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static bool ParseFloat(
    string floatString,
    out float result
)
Public Shared Function ParseFloat ( _
    floatString As String, _
    <OutAttribute> ByRef result As Single _
) As Boolean
public:
static bool^ ParseFloat(
    String^ floatString,
    [OutAttribute] float^% result
)

Parameters

floatString
Type: String
The float string.
result
Type: Single %
The result.

Return Value

true if success, false otherwise.

See Also

Others Class
ParseFloat Overload
robotManager.Helpful Namespace


ParseFloat Method (String)

Others..::..ParseFloat Method (String)

String to float.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static float ParseFloat(
    string floatString
)
Public Shared Function ParseFloat ( _
    floatString As String _
) As Single
public:
static float^ ParseFloat(
    String^ floatString
)

Parameters

floatString
Type: String
The float string.

Return Value

result.

See Also

Others Class
ParseFloat Overload
robotManager.Helpful Namespace


ParseFloat Method (String, Boolean)

Others..::..ParseFloat Method (String, Boolean%)

String to float.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static float ParseFloat(
    string floatString,
    out bool result
)
Public Shared Function ParseFloat ( _
    floatString As String, _
    <OutAttribute> ByRef result As Boolean _
) As Single
public:
static float^ ParseFloat(
    String^ floatString,
    [OutAttribute] bool^% result
)

Parameters

floatString
Type: String
The float string.
result
Type: Boolean %
true if success.

Return Value

result.

See Also

Others Class
ParseFloat Overload
robotManager.Helpful Namespace


ParseInt Method

Others..::..ParseInt Method

Overload List

Name | Description
ParseInt(String, Int32%) | String to int.
ParseInt(String) | String to int.
ParseInt(String, Boolean%) | String to int.

See Also

Others Class
Others Members
robotManager.Helpful Namespace


ParseInt Method (String, Int32)

Others..::..ParseInt Method (String, Int32%)

String to int.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static bool ParseInt(
    string IntString,
    out int result
)
Public Shared Function ParseInt ( _
    IntString As String, _
    <OutAttribute> ByRef result As Integer _
) As Boolean
public:
static bool^ ParseInt(
    String^ IntString,
    [OutAttribute] int^% result
)

Parameters

IntString
Type: String
The int string.
result
Type: Int32 %
The result.

Return Value

true if success, false otherwise.

See Also

Others Class
ParseInt Overload
robotManager.Helpful Namespace


ParseInt Method (String)

Others..::..ParseInt Method (String)

String to int.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static int ParseInt(
    string intString
)
Public Shared Function ParseInt ( _
    intString As String _
) As Integer
public:
static int^ ParseInt(
    String^ intString
)

Parameters

intString
Type: String
The int string.

Return Value

result.

See Also

Others Class
ParseInt Overload
robotManager.Helpful Namespace


ParseInt Method (String, Boolean)

Others..::..ParseInt Method (String, Boolean%)

String to int.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static int ParseInt(
    string intString,
    out bool result
)
Public Shared Function ParseInt ( _
    intString As String, _
    <OutAttribute> ByRef result As Boolean _
) As Integer
public:
static int^ ParseInt(
    String^ intString,
    [OutAttribute] bool^% result
)

Parameters

intString
Type: String
The int string.
result
Type: Boolean %
true if success.

Return Value

result.

See Also

Others Class
ParseInt Overload
robotManager.Helpful Namespace


ParseLong Method

Others..::..ParseLong Method

Overload List

Name | Description
ParseLong(String, Int64%) | String to long.
ParseLong(String) | String to long.
ParseLong(String, Boolean%) | String to long.

See Also

Others Class
Others Members
robotManager.Helpful Namespace


ParseLong Method (String, Int64)

Others..::..ParseLong Method (String, Int64%)

String to long.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static bool ParseLong(
    string LongString,
    out long result
)
Public Shared Function ParseLong ( _
    LongString As String, _
    <OutAttribute> ByRef result As Long _
) As Boolean
public:
static bool^ ParseLong(
    String^ LongString,
    [OutAttribute] long long^% result
)

Parameters

LongString
Type: String
The long string.
result
Type: Int64 %
The result.

Return Value

true if success, false otherwise.

See Also

Others Class
ParseLong Overload
robotManager.Helpful Namespace


ParseLong Method (String)

Others..::..ParseLong Method (String)

String to long.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static long ParseLong(
    string longString
)
Public Shared Function ParseLong ( _
    longString As String _
) As Long
public:
static long long^ ParseLong(
    String^ longString
)

Parameters

longString
Type: String
The long string.

Return Value

result.

See Also

Others Class
ParseLong Overload
robotManager.Helpful Namespace


ParseLong Method (String, Boolean)

Others..::..ParseLong Method (String, Boolean%)

String to long.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static long ParseLong(
    string longString,
    out bool result
)
Public Shared Function ParseLong ( _
    longString As String, _
    <OutAttribute> ByRef result As Boolean _
) As Long
public:
static long long^ ParseLong(
    String^ longString,
    [OutAttribute] bool^% result
)

Parameters

longString
Type: String
The long string.
result
Type: Boolean %
true if success.

Return Value

result?

See Also

Others Class
ParseLong Overload
robotManager.Helpful Namespace


ParseUInt Method

Others..::..ParseUInt Method

Overload List

Name | Description
ParseUInt(String, UInt32%) | String to uint.
ParseUInt(String) | String to uint.
ParseUInt(String, Boolean%) | String to uint.

See Also

Others Class
Others Members
robotManager.Helpful Namespace


ParseUInt Method (String, UInt32)

Others..::..ParseUInt Method (String, UInt32%)

String to uint.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static bool ParseUInt(
    string UIntString,
    out uint result
)
Public Shared Function ParseUInt ( _
    UIntString As String, _
    <OutAttribute> ByRef result As UInteger _
) As Boolean
public:
static bool^ ParseUInt(
    String^ UIntString,
    [OutAttribute] unsigned int^% result
)

Parameters

UIntString
Type: String
The uint string.
result
Type: UInt32 %
The result.

Return Value

true if success, false otherwise.

See Also

Others Class
ParseUInt Overload
robotManager.Helpful Namespace


ParseUInt Method (String)

Others..::..ParseUInt Method (String)

String to uint.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static uint ParseUInt(
    string uintString
)
Public Shared Function ParseUInt ( _
    uintString As String _
) As UInteger
public:
static unsigned int^ ParseUInt(
    String^ uintString
)

Parameters

uintString
Type: String
The uint string.

Return Value

result.

See Also

Others Class
ParseUInt Overload
robotManager.Helpful Namespace


ParseUInt Method (String, Boolean)

Others..::..ParseUInt Method (String, Boolean%)

String to uint.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static uint ParseUInt(
    string uintString,
    out bool result
)
Public Shared Function ParseUInt ( _
    uintString As String, _
    <OutAttribute> ByRef result As Boolean _
) As UInteger
public:
static unsigned int^ ParseUInt(
    String^ uintString,
    [OutAttribute] bool^% result
)

Parameters

uintString
Type: String
The uint string.
result
Type: Boolean %
true if success.

Return Value

result.

See Also

Others Class
ParseUInt Overload
robotManager.Helpful Namespace


PathCombine Method

Others..::..PathCombine Method

Combines an array of strings into a path (file path).

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static string PathCombine(
    params string[] paths
)
Public Shared Function PathCombine ( _
    ParamArray paths As String() _
) As String
public:
static String^ PathCombine(
    ... array<String^>^ paths
)

Parameters

paths
Type: array< String >[]()[][]
The path array.

Return Value

path.

See Also

Others Class
robotManager.Helpful Namespace


PostRequest Method

Others..::..PostRequest Method

Post request.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static Task<string> PostRequest(
    string url,
    Dictionary<string, string> parameters,
    bool showErrors,
    int requestTimeoutMs
)
Public Shared Function PostRequest ( _
    url As String, _
    parameters As Dictionary(Of String, String), _
    showErrors As Boolean, _
    requestTimeoutMs As Integer _
) As Task(Of String)
public:
static Task<String^>^ PostRequest(
    String^ url,
    Dictionary<String^, String^>^ parameters,
    bool^ showErrors,
    int^ requestTimeoutMs
)

Parameters

url
Type: String
The URL.
parameters
Type: Dictionary <(Of <(<' String, String >)>)>
The parameters (like new Dictionary<string, string> { { "Name", "Value" } }).
showErrors
Type: Boolean
if set to true show errors in log.
requestTimeoutMs
Type: Int32
The request timeout milliseconds.

Return Value

result.

See Also

Others Class
robotManager.Helpful Namespace


Random Method

Others..::..Random Method

Overload List

Name | Description
Random(Double, Double) | Random double.
Random(Int32, Int32) | Return Random number.
Random()()()() | Get Random instance.

See Also

Others Class
Others Members
robotManager.Helpful Namespace


Random Method (Double, Double)

Others..::..Random Method (Double, Double)

Random double.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static double Random(
    double from,
    double to
)
Public Shared Function Random ( _
    from As Double, _
    to As Double _
) As Double
public:
static double^ Random(
    double^ from,
    double^ to
)

Parameters

from
Type: Double
From.
to
Type: Double
To.

Return Value

System.Double.

See Also

Others Class
Random Overload
robotManager.Helpful Namespace


Random Method (Int32, Int32)

Others..::..Random Method (Int32, Int32)

Return Random number.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static int Random(
    int from,
    int to
)
Public Shared Function Random ( _
    from As Integer, _
    to As Integer _
) As Integer
public:
static int^ Random(
    int^ from,
    int^ to
)

Parameters

from
Type: Int32
From.
to
Type: Int32
To.

Return Value

System.Int32.

See Also

Others Class
Random Overload
robotManager.Helpful Namespace


Random Method

Others..::..Random Method

Get Random instance.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static Random Random()
Public Shared Function Random As Random
public:
static Random^ Random()

Return Value

Random.

See Also

Others Class
Random Overload
robotManager.Helpful Namespace


ReadFile Method

Others..::..ReadFile Method

Read file content to string.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static string ReadFile(
    string filePath
)
Public Shared Function ReadFile ( _
    filePath As String _
) As String
public:
static String^ ReadFile(
    String^ filePath
)

Parameters

filePath
Type: String
The file path.

Return Value

file content.

See Also

Others Class
robotManager.Helpful Namespace


ReadFileAllLines Method

Others..::..ReadFileAllLines Method

Read file and return array by line.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static string[] ReadFileAllLines(
    string path
)
Public Shared Function ReadFileAllLines ( _
    path As String _
) As String()
public:
static array<String^>^ ReadFileAllLines(
    String^ path
)

Parameters

path
Type: String
The file path.

Return Value

System.String[].

See Also

Others Class
robotManager.Helpful Namespace


RemoveFile Method

Others..::..RemoveFile Method

Remove file.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static bool RemoveFile(
    string strPath
)
Public Shared Function RemoveFile ( _
    strPath As String _
) As Boolean
public:
static bool^ RemoveFile(
    String^ strPath
)

Parameters

strPath
Type: String
The string path.

Return Value

true if success, false otherwise.

See Also

Others Class
robotManager.Helpful Namespace


ReplaceUpperCharBySpaceChar Method

Others..::..ReplaceUpperCharBySpaceChar Method

Replace upper char by space.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static string ReplaceUpperCharBySpaceChar(
    string s
)
Public Shared Function ReplaceUpperCharBySpaceChar ( _
    s As String _
) As String
public:
static String^ ReplaceUpperCharBySpaceChar(
    String^ s
)

Parameters

s
Type: String
text.

Return Value

text without upper case.

See Also

Others Class
robotManager.Helpful Namespace


SecToHour Method

Others..::..SecToHour Method

int Seconds to string HH:MM:SS.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static string SecToHour(
    int sec
)
Public Shared Function SecToHour ( _
    sec As Integer _
) As String
public:
static String^ SecToHour(
    int^ sec
)

Parameters

sec
Type: Int32
The seconds.

Return Value

System.String.

See Also

Others Class
robotManager.Helpful Namespace


ShutDownPc Method

Others..::..ShutDownPc Method

ShutDown the Computer.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void ShutDownPc()
Public Shared Sub ShutDownPc
public:
static void ShutDownPc()

See Also

Others Class
robotManager.Helpful Namespace


StringArrayToListInt Method

Others..::..StringArrayToListInt Method

Strings array to int arrays.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static List<int> StringArrayToListInt(
    IEnumerable<string> array
)
Public Shared Function StringArrayToListInt ( _
    array As IEnumerable(Of String) _
) As List(Of Integer)
public:
static List<int^>^ StringArrayToListInt(
    IEnumerable<String^>^ array
)

Parameters

array
Type: IEnumerable <(Of <(<' String >)>)>
The strings array.

Return Value

int arrays.

See Also

Others Class
robotManager.Helpful Namespace


StringBetween Method

Others..::..StringBetween Method

Find strings between two string delimiters

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static string StringBetween(
    string str,
    string start,
    string end,
    bool trim
)
Public Shared Function StringBetween ( _
    str As String, _
    start As String, _
    end As String, _
    trim As Boolean _
) As String
public:
static String^ StringBetween(
    String^ str,
    String^ start,
    String^ end,
    bool^ trim
)

Parameters

str
Type: String
The string to search.
start
Type: String
The beginning of the string to find. Passing an empty string starts at the beginning
end
Type: String
The end of the string to find. Passing an empty string searches from $sStart to end of string.
trim
Type: Boolean
if set to true if you want trim result.

Return Value

result.

See Also

Others Class
robotManager.Helpful Namespace


StringToEncryptString Method

Others..::..StringToEncryptString Method

Return a encrypted text.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static string StringToEncryptString(
    string text
)
Public Shared Function StringToEncryptString ( _
    text As String _
) As String
public:
static String^ StringToEncryptString(
    String^ text
)

Parameters

text
Type: String
The text.

Return Value

encrypted text.

See Also

Others Class
robotManager.Helpful Namespace


StringToListInt Method

Others..::..StringToListInt Method

Strings to list int.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static List<int> StringToListInt(
    string text
)
Public Shared Function StringToListInt ( _
    text As String _
) As List(Of Integer)
public:
static List<int^>^ StringToListInt(
    String^ text
)

Parameters

text
Type: String
The text.

Return Value

List<System.Int32>.

See Also

Others Class
robotManager.Helpful Namespace


TextToArrayByLine Method

Others..::..TextToArrayByLine Method

String to strings array by line.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static string[] TextToArrayByLine(
    string text
)
Public Shared Function TextToArrayByLine ( _
    text As String _
) As String()
public:
static array<String^>^ TextToArrayByLine(
    String^ text
)

Parameters

text
Type: String
The string.

Return Value

strings array.

See Also

Others Class
robotManager.Helpful Namespace


ToUtf8 Method

Others..::..ToUtf8 Method

Overload List

Name | Description
ToUtf8(String) | Text to UTF8.
ToUtf8(array<Byte>[]()[][]) | Converts to utf8.

See Also

Others Class
Others Members
robotManager.Helpful Namespace


ToUtf8 Method (String)

Others..::..ToUtf8 Method (String)

Text to UTF8.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static string ToUtf8(
    string text
)
Public Shared Function ToUtf8 ( _
    text As String _
) As String
public:
static String^ ToUtf8(
    String^ text
)

Parameters

text
Type: String
The text.

Return Value

UTF8 text.

See Also

Others Class
ToUtf8 Overload
robotManager.Helpful Namespace


ToUtf8 Method (Byte[])

Others..::..ToUtf8 Method (array<Byte>[]()[][])

Converts to utf8.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static string ToUtf8(
    byte[] bytes
)
Public Shared Function ToUtf8 ( _
    bytes As Byte() _
) As String
public:
static String^ ToUtf8(
    array<unsigned char^>^ bytes
)

Parameters

bytes
Type: array< Byte >[]()[][]
The bytes.

Return Value

System.String.

See Also

Others Class
ToUtf8 Overload
robotManager.Helpful Namespace


Wait Method

Others..::..Wait Method

Wait.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void Wait(
    int milsecToWait
)
Public Shared Sub Wait ( _
    milsecToWait As Integer _
)
public:
static void Wait(
    int^ milsecToWait
)

Parameters

milsecToWait
Type: Int32
milliseconds to wait.

See Also

Others Class
robotManager.Helpful Namespace


WriteFile Method

Others..::..WriteFile Method

Write string file.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void WriteFile(
    string filePath,
    string value
)
Public Shared Sub WriteFile ( _
    filePath As String, _
    value As String _
)
public:
static void WriteFile(
    String^ filePath,
    String^ value
)

Parameters

filePath
Type: String
The file path.
value
Type: String
The value.

See Also

Others Class
robotManager.Helpful Namespace


Others Properties

The Others type exposes the following members.

Properties

Name | Description
GetCurrentDirectory | Get current directory (like "C:\program\WRobot").
GetTempFolder | Get temporary directory path.
Times | Gets the number of milliseconds elapsed since the system started.
TimesSec | Gets the number of seconds elapsed since the system started.
WindowsVersion | Get Windows version.

See Also

Others Class
robotManager.Helpful Namespace


GetCurrentDirectory Property

Others..::..GetCurrentDirectory Property

Get current directory (like "C:\program\WRobot").

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static string GetCurrentDirectory { get; }
Public Shared ReadOnly Property GetCurrentDirectory As String
    Get
public:
static property String^ GetCurrentDirectory {
    String^ get ();
}

Field Value

The current directory.

See Also

Others Class
robotManager.Helpful Namespace


GetTempFolder Property

Others..::..GetTempFolder Property

Get temporary directory path.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static string GetTempFolder { get; }
Public Shared ReadOnly Property GetTempFolder As String
    Get
public:
static property String^ GetTempFolder {
    String^ get ();
}

Field Value

The get temporary folder.

See Also

Others Class
robotManager.Helpful Namespace


Times Property

Others..::..Times Property

Gets the number of milliseconds elapsed since the system started.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static int Times { get; }
Public Shared ReadOnly Property Times As Integer
    Get
public:
static property int^ Times {
    int^ get ();
}

Field Value

The times milliseconds.

See Also

Others Class
robotManager.Helpful Namespace


TimesSec Property

Others..::..TimesSec Property

Gets the number of seconds elapsed since the system started.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static int TimesSec { get; }
Public Shared ReadOnly Property TimesSec As Integer
    Get
public:
static property int^ TimesSec {
    int^ get ();
}

Field Value

The times seconds.

See Also

Others Class
robotManager.Helpful Namespace


WindowsVersion Property

Others..::..WindowsVersion Property

Get Windows version.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static string WindowsVersion { get; }
Public Shared ReadOnly Property WindowsVersion As String
    Get
public:
static property String^ WindowsVersion {
    String^ get ();
}

Field Value

The Windows version.

See Also

Others Class
robotManager.Helpful Namespace


RunCode Class

Class RunCode. Run C# and VB.net code from string.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public class RunCode
Public Class RunCode
public ref class RunCode

Inheritance Hierarchy

Object
robotManager.Helpful..::..RunCode

See Also

RunCode Members
robotManager.Helpful Namespace


RunCode Members

The RunCode type exposes the following members.

Methods

 | Name | Description
 | Compile | Compile the specified code type.
 | CompileAndCreateInstance | Compile and create instance.
 | CompileAndInvokeStaticMethod | Compiles the and invoke static method.
 | CompileFile | Compile the file.
 | CreateInstance | Create instance from CompilerResults.
Public method | Equals(System.Object) | (Inherited from Object.)
 | ErrorsToString | Errors or CompilerResults to string.
Protected method | Finalize | (Inherited from Object.)
 | GenerateExe | Generate executable from code.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
 | HasErrors | Determines whether the specified compiler results has errors.
 | InvokeStaticMethod | Invoke static method from CompilerResults..
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Fields

Name | Description
CompiledCache | Compiled cache

See Also

RunCode Class
robotManager.Helpful Namespace


RunCode Fields

The RunCode type exposes the following members.

Fields

Name | Description
CompiledCache | Compiled cache

See Also

RunCode Class
robotManager.Helpful Namespace


CompiledCache Field

RunCode..::..CompiledCache Field

Compiled cache

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static Dictionary<string, CompilerResults> CompiledCache
Public Shared CompiledCache As Dictionary(Of String, CompilerResults)
public:
static Dictionary<String^, CompilerResults^>^ CompiledCache

See Also

RunCode Class
robotManager.Helpful Namespace


RunCode Methods

The RunCode type exposes the following members.

Methods

 | Name | Description
 | Compile | Compile the specified code type.
 | CompileAndCreateInstance | Compile and create instance.
 | CompileAndInvokeStaticMethod | Compiles the and invoke static method.
 | CompileFile | Compile the file.
 | CreateInstance | Create instance from CompilerResults.
Public method | Equals(System.Object) | (Inherited from Object.)
 | ErrorsToString | Errors or CompilerResults to string.
Protected method | Finalize | (Inherited from Object.)
 | GenerateExe | Generate executable from code.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
 | HasErrors | Determines whether the specified compiler results has errors.
 | InvokeStaticMethod | Invoke static method from CompilerResults..
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

RunCode Class
robotManager.Helpful Namespace


Compile Method

RunCode..::..Compile Method

Compile the specified code type.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static CompilerResults Compile(
    RunCode..::..CodeType codeType,
    string code,
    bool generateInMemory,
    bool canCache
)
Public Shared Function Compile ( _
    codeType As RunCode..::..CodeType, _
    code As String, _
    generateInMemory As Boolean, _
    canCache As Boolean _
) As CompilerResults
public:
static CompilerResults^ Compile(
    RunCode..::..CodeType^ codeType,
    String^ code,
    bool^ generateInMemory,
    bool^ canCache
)

Parameters

codeType
Type: robotManager.Helpful..::..RunCode..::..CodeType
Type of the code.
code
Type: String
The code.
generateInMemory
Type: Boolean
if set to true generate in memory.
canCache
Type: Boolean
if set to true can cache.

Return Value

CompilerResults.

See Also

RunCode Class
robotManager.Helpful Namespace


CompileAndCreateInstance Method

RunCode..::..CompileAndCreateInstance Method

Compile and create instance.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static Object CompileAndCreateInstance(
    RunCode..::..CodeType codeType,
    string code,
    string createInstanceTypeClassName,
    out string errors,
    bool generateInMemory,
    bool canCache
)
Public Shared Function CompileAndCreateInstance ( _
    codeType As RunCode..::..CodeType, _
    code As String, _
    createInstanceTypeClassName As String, _
    <OutAttribute> ByRef errors As String, _
    generateInMemory As Boolean, _
    canCache As Boolean _
) As Object
public:
static Object^ CompileAndCreateInstance(
    RunCode..::..CodeType^ codeType,
    String^ code,
    String^ createInstanceTypeClassName,
    [OutAttribute] String^% errors,
    bool^ generateInMemory,
    bool^ canCache
)

Parameters

codeType
Type: robotManager.Helpful..::..RunCode..::..CodeType
Type of the code.
code
Type: String
The code.
createInstanceTypeClassName
Type: String
Name of the type like "MyNameSpace.MyClassName".
errors
Type: String %
The errors.
generateInMemory
Type: Boolean
if set to true generate in memory.
canCache
Type: Boolean
if set to true can cache.

Return Value

instance.

See Also

RunCode Class
robotManager.Helpful Namespace


CompileAndInvokeStaticMethod Method

RunCode..::..CompileAndInvokeStaticMethod Method

Compiles the and invoke static method.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static bool CompileAndInvokeStaticMethod(
    RunCode..::..CodeType codeType,
    string code,
    string invokeTypeClassName,
    string invokeMethodName,
    out string errors,
    bool generateInMemory,
    bool canCache
)
Public Shared Function CompileAndInvokeStaticMethod ( _
    codeType As RunCode..::..CodeType, _
    code As String, _
    invokeTypeClassName As String, _
    invokeMethodName As String, _
    <OutAttribute> ByRef errors As String, _
    generateInMemory As Boolean, _
    canCache As Boolean _
) As Boolean
public:
static bool^ CompileAndInvokeStaticMethod(
    RunCode..::..CodeType^ codeType,
    String^ code,
    String^ invokeTypeClassName,
    String^ invokeMethodName,
    [OutAttribute] String^% errors,
    bool^ generateInMemory,
    bool^ canCache
)

Parameters

codeType
Type: robotManager.Helpful..::..RunCode..::..CodeType
Type of the code.
code
Type: String
The code.
invokeTypeClassName
Type: String
Name of the class type like "MyNameSpace.MyClassName".
invokeMethodName
Type: String
Name of the invoke method.
errors
Type: String %
The errors.
generateInMemory
Type: Boolean
if set to true generate in memory.
canCache
Type: Boolean
if set to true can cache.

Return Value

true if success, false otherwise.

See Also

RunCode Class
robotManager.Helpful Namespace


CompileFile Method

RunCode..::..CompileFile Method

Compile the file.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static CompilerResults CompileFile(
    string filePath,
    bool generateInMemory,
    bool canCache
)
Public Shared Function CompileFile ( _
    filePath As String, _
    generateInMemory As Boolean, _
    canCache As Boolean _
) As CompilerResults
public:
static CompilerResults^ CompileFile(
    String^ filePath,
    bool^ generateInMemory,
    bool^ canCache
)

Parameters

filePath
Type: String
The file path (.vb or .cs file).
generateInMemory
Type: Boolean
if set to true generate in memory.
canCache
Type: Boolean
if set to true can cache.

Return Value

CompilerResults.

See Also

RunCode Class
robotManager.Helpful Namespace


CreateInstance Method

RunCode..::..CreateInstance Method

Create instance from CompilerResults.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static Object CreateInstance(
    CompilerResults compilerResults,
    string typeName,
    bool ignoreCase
)
Public Shared Function CreateInstance ( _
    compilerResults As CompilerResults, _
    typeName As String, _
    ignoreCase As Boolean _
) As Object
public:
static Object^ CreateInstance(
    CompilerResults^ compilerResults,
    String^ typeName,
    bool^ ignoreCase
)

Parameters

compilerResults
Type: CompilerResults
The compiler results.
typeName
Type: String
Name of the type like "MyNameSpace.MyClassName".
ignoreCase
Type: Boolean
if set to true ignore case.

Return Value

instance.

See Also

RunCode Class
robotManager.Helpful Namespace


ErrorsToString Method

RunCode..::..ErrorsToString Method

Errors or CompilerResults to string.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static string ErrorsToString(
    CompilerResults compilerResults
)
Public Shared Function ErrorsToString ( _
    compilerResults As CompilerResults _
) As String
public:
static String^ ErrorsToString(
    CompilerResults^ compilerResults
)

Parameters

compilerResults
Type: CompilerResults
The compiler results.

Return Value

errors.

See Also

RunCode Class
robotManager.Helpful Namespace


GenerateExe Method

RunCode..::..GenerateExe Method

Generate executable from code.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static bool GenerateExe(
    RunCode..::..CodeType codeType,
    string code,
    string pathOutput,
    out string errors,
    bool includeDebugInfo,
    string[] assemblyNames,
    bool targetWinexeInsteadConsole
)
Public Shared Function GenerateExe ( _
    codeType As RunCode..::..CodeType, _
    code As String, _
    pathOutput As String, _
    <OutAttribute> ByRef errors As String, _
    includeDebugInfo As Boolean, _
    assemblyNames As String(), _
    targetWinexeInsteadConsole As Boolean _
) As Boolean
public:
static bool^ GenerateExe(
    RunCode..::..CodeType^ codeType,
    String^ code,
    String^ pathOutput,
    [OutAttribute] String^% errors,
    bool^ includeDebugInfo,
    array<String^>^ assemblyNames,
    bool^ targetWinexeInsteadConsole
)

Parameters

codeType
Type: robotManager.Helpful..::..RunCode..::..CodeType
Type of the code.
code
Type: String
The code.
pathOutput
Type: String
The path output.
errors
Type: String %
The errors.
includeDebugInfo
Type: Boolean
if set to true include debug information.
assemblyNames
Type: array< String >[]()[][]
The assembly names.
targetWinexeInsteadConsole
Type: Boolean
if set to true target winexe instead console.

Return Value

true if success, false otherwise.

See Also

RunCode Class
robotManager.Helpful Namespace


HasErrors Method

RunCode..::..HasErrors Method

Determines whether the specified compiler results has errors.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static bool HasErrors(
    CompilerResults compilerResults
)
Public Shared Function HasErrors ( _
    compilerResults As CompilerResults _
) As Boolean
public:
static bool^ HasErrors(
    CompilerResults^ compilerResults
)

Parameters

compilerResults
Type: CompilerResults
The compiler results.

Return Value

true if the specified compiler results has errors; otherwise, false.

See Also

RunCode Class
robotManager.Helpful Namespace


InvokeStaticMethod Method

RunCode..::..InvokeStaticMethod Method

Invoke static method from CompilerResults..

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static bool InvokeStaticMethod(
    CompilerResults compilerResults,
    string typeClassName,
    string methodName,
    bool ignoreCase
)
Public Shared Function InvokeStaticMethod ( _
    compilerResults As CompilerResults, _
    typeClassName As String, _
    methodName As String, _
    ignoreCase As Boolean _
) As Boolean
public:
static bool^ InvokeStaticMethod(
    CompilerResults^ compilerResults,
    String^ typeClassName,
    String^ methodName,
    bool^ ignoreCase
)

Parameters

compilerResults
Type: CompilerResults
The compiler results.
typeClassName
Type: String
Name of the class type like "MyNameSpace.MyClassName".
methodName
Type: String
Name of the method.
ignoreCase
Type: Boolean
if set to true ignore case.

Return Value

true if success, false otherwise.

See Also

RunCode Class
robotManager.Helpful Namespace


RunCode.CodeType Enumeration

RunCode..::..CodeType Enumeration

CodeType

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public enum CodeType
Public Enumeration CodeType
public enum class CodeType

Members

Member name | Description
CSharp | C#
VB | VB.net

See Also

robotManager.Helpful Namespace


ScintillaStyles Class

Class ScintillaStyles.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static class ScintillaStyles
Public NotInheritable Class ScintillaStyles
public ref class ScintillaStyles abstract sealed

Inheritance Hierarchy

Object
robotManager.Helpful..::..ScintillaStyles

See Also

ScintillaStyles Members
robotManager.Helpful Namespace


ScintillaStyles Members

The ScintillaStyles type exposes the following members.

Methods

Name | Description
CSharp | C# style
Lua | Lua style
XML | XML style.

See Also

ScintillaStyles Class
robotManager.Helpful Namespace


ScintillaStyles Methods

The ScintillaStyles type exposes the following members.

Methods

Name | Description
CSharp | C# style
Lua | Lua style
XML | XML style.

See Also

ScintillaStyles Class
robotManager.Helpful Namespace


CSharp Method

ScintillaStyles..::..CSharp Method

C# style

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void CSharp(
    this ScintillaWPF codeEditor
)
<ExtensionAttribute> _
Public Shared Sub CSharp ( _
    codeEditor As ScintillaWPF _
)
[ExtensionAttribute]
public:
static void CSharp(
    ScintillaWPF^ codeEditor
)

Parameters

codeEditor
Type: ScintillaWPF
The code editor.

See Also

ScintillaStyles Class
robotManager.Helpful Namespace


Lua Method

ScintillaStyles..::..Lua Method

Lua style

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void Lua(
    this ScintillaWPF codeEditor
)
<ExtensionAttribute> _
Public Shared Sub Lua ( _
    codeEditor As ScintillaWPF _
)
[ExtensionAttribute]
public:
static void Lua(
    ScintillaWPF^ codeEditor
)

Parameters

codeEditor
Type: ScintillaWPF
The code editor.

See Also

ScintillaStyles Class
robotManager.Helpful Namespace


XML Method

ScintillaStyles..::..XML Method

XML style.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void XML(
    this ScintillaWPF codeEditor
)
<ExtensionAttribute> _
Public Shared Sub XML ( _
    codeEditor As ScintillaWPF _
)
[ExtensionAttribute]
public:
static void XML(
    ScintillaWPF^ codeEditor
)

Parameters

codeEditor
Type: ScintillaWPF
The code editor.

See Also

ScintillaStyles Class
robotManager.Helpful Namespace


Settings Class

Class Settings. Used by bot to manage settings files.

Examples

C#
using System;
using System.IO;
using robotManager.Helpful;
using wManager.Wow.Helpers;
using wManager.Wow.ObjectManager;

[Serializable]
public class TestSetting : Settings
{
    public static TestSetting CurrentSetting { get; set; }

    private static string FilePath
    {
        get
        {
            // return path like "C:\WRobot\Settings\Test-NAME.REALMNAME.xml"
            return AdviserFilePathAndName("Test", ObjectManager.Me.Name + "." + Usefuls.RealmName);
        }
    }

    private TestSetting()
    {
        TestValue1 = true;
        TestValue2 = "test text";
    }

    public bool Save()
    {
        try
        {
            return Save(FilePath);
        }
        catch (Exception e)
        {
            Logging.WriteError("TestSetting > Save(): " + e);
            return false;
        }
    }

    public static bool Load()
    {
        try
        {
            if (File.Exists(FilePath))
            {
                CurrentSetting = Load<TestSetting>(FilePath);
                return true;
            }
            CurrentSetting = new TestSetting();
        }
        catch (Exception e)
        {
            Logging.WriteError("TestSetting > Load(): " + e);
        }
        return false;
    }

    public bool TestValue1 { get; set; }

    public string TestValue2  { get; set; }
}

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public abstract class Settings
<SerializableAttribute> _
Public MustInherit Class Settings
[SerializableAttribute]
public ref class Settings abstract

Inheritance Hierarchy

Object
robotManager.Helpful..::..Settings

See Also

Settings Members
robotManager.Helpful Namespace


Settings Members

The Settings type exposes the following members.

Methods

 | Name | Description
 | AdviserFilePathAndName | return path like "C:\WRobot\Settings\productName-ID.xml"
Protected method | ConfigWinForm |
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
 | Load<(Of <<'(T>)>>) | Load from XML file
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | Save | Save to xml file
Public method | ToForm | Converts to form.
Public method | ToString | (Inherited from Object.)
Public method | ToStringFormat | Converts to stringformat.

See Also

Settings Class
robotManager.Helpful Namespace


Settings Methods

The Settings type exposes the following members.

Methods

 | Name | Description
 | AdviserFilePathAndName | return path like "C:\WRobot\Settings\productName-ID.xml"
Protected method | ConfigWinForm |
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
 | Load<(Of <<'(T>)>>) | Load from XML file
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | Save | Save to xml file
Public method | ToForm | Converts to form.
Public method | ToString | (Inherited from Object.)
Public method | ToStringFormat | Converts to stringformat.

See Also

Settings Class
robotManager.Helpful Namespace


AdviserFilePathAndName Method

Settings..::..AdviserFilePathAndName Method

return path like "C:\WRobot\Settings\productName-ID.xml"

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
protected static string AdviserFilePathAndName(
    string productName,
    string id
)
Protected Shared Function AdviserFilePathAndName ( _
    productName As String, _
    id As String _
) As String
protected:
static String^ AdviserFilePathAndName(
    String^ productName,
    String^ id
)

Parameters

productName
Type: String
product name
id
Type: String
id

See Also

Settings Class
robotManager.Helpful Namespace


ConfigWinForm Method

Settings..::..ConfigWinForm Method

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
protected void ConfigWinForm(
    Point size,
    string windowName,
    bool resizable
)
Protected Sub ConfigWinForm ( _
    size As Point, _
    windowName As String, _
    resizable As Boolean _
)
protected:
void ConfigWinForm(
    Point^ size,
    String^ windowName,
    bool^ resizable
)

Parameters

size
Type: Point
windowName
Type: String
resizable
Type: Boolean

See Also

Settings Class
robotManager.Helpful Namespace


Load(T) Method

Settings..::..Load<(Of <(<'T>)>)> Method

Load from XML file

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
protected static T Load<T>(
    string settingsPath
)

Protected Shared Function Load(Of T) ( _
    settingsPath As String _
) As T
protected:
generic<typename T>
static T Load(
    String^ settingsPath
)

Type Parameters

T

Parameters

settingsPath
Type: String
xml file path

Return Value

See Also

Settings Class
robotManager.Helpful Namespace


Save Method

Settings..::..Save Method

Save to xml file

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
protected bool Save(
    string settingsPath
)
Protected Function Save ( _
    settingsPath As String _
) As Boolean
protected:
bool^ Save(
    String^ settingsPath
)

Parameters

settingsPath
Type: String
file path

Return Value

success

See Also

Settings Class
robotManager.Helpful Namespace


ToForm Method

Settings..::..ToForm Method

Converts to form.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public void ToForm()
Public Sub ToForm
public:
void ToForm()

See Also

Settings Class
robotManager.Helpful Namespace


ToStringFormat Method

Settings..::..ToStringFormat Method

Converts to stringformat.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public string ToStringFormat()
Public Function ToStringFormat As String
public:
String^ ToStringFormat()

Return Value

System.String.

See Also

Settings Class
robotManager.Helpful Namespace


Timer Class

Class Timer.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public class Timer
Public Class Timer
public ref class Timer

Inheritance Hierarchy

Object
robotManager.Helpful..::..Timer

See Also

Timer Members
robotManager.Helpful Namespace


Timer Members

The Timer type exposes the following members.

Constructors

 | Name | Description
Public method | Timer()()()() | Initializes a new instance of the StopWatch class.
Public method | Timer(Double) | Initializes a new instance of the Timer class.
Public method | Timer(TimeSpan) | Initializes a new instance of the Timer class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | ForceReady | Forces the ready.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Peek | Returns the time that has passed since the Reset() method was called.
Public method | Reset()()()() | Resets the stopwatch. This method should be called when you start measuring.
Public method | Reset(Double) | Resets the stopwatch. This method should be called when you start measuring.
Public method | TimeLeft | Returns timer left.
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | CountDowntime | Holds the value of the Frequency property.
Public property | IsReady | Returns true if the timer is ready
Public property | StartTime | Gets or sets the start time.

See Also

Timer Class
robotManager.Helpful Namespace


Timer Constructor

Overload List

 | Name | Description
Public method | Timer()()()() | Initializes a new instance of the StopWatch class.
Public method | Timer(Double) | Initializes a new instance of the Timer class.
Public method | Timer(TimeSpan) | Initializes a new instance of the Timer class.

See Also

Timer Class
Timer Members
robotManager.Helpful Namespace


Timer Constructor

Initializes a new instance of the StopWatch class.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public Timer()
Public Sub New
public:
Timer()

Exceptions

Exception | Condition
NotSupportedException | The system does not have a high-resolution performance counter.

See Also

Timer Class
Timer Overload
robotManager.Helpful Namespace


Timer Constructor (Double)

Initializes a new instance of the Timer class.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public Timer(
    double countDowntime
)
Public Sub New ( _
    countDowntime As Double _
)
public:
Timer(
    double^ countDowntime
)

Parameters

countDowntime
Type: Double
The count downtime.

See Also

Timer Class
Timer Overload
robotManager.Helpful Namespace


Timer Constructor (TimeSpan)

Initializes a new instance of the Timer class.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public Timer(
    TimeSpan countDowntime
)
Public Sub New ( _
    countDowntime As TimeSpan _
)
public:
Timer(
    TimeSpan^ countDowntime
)

Parameters

countDowntime
Type: TimeSpan
The count downtime.

See Also

Timer Class
Timer Overload
robotManager.Helpful Namespace


Timer Methods

The Timer type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | ForceReady | Forces the ready.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Peek | Returns the time that has passed since the Reset() method was called.
Public method | Reset()()()() | Resets the stopwatch. This method should be called when you start measuring.
Public method | Reset(Double) | Resets the stopwatch. This method should be called when you start measuring.
Public method | TimeLeft | Returns timer left.
Public method | ToString | (Inherited from Object.)

See Also

Timer Class
robotManager.Helpful Namespace


ForceReady Method

Timer..::..ForceReady Method

Forces the ready.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public void ForceReady()
Public Sub ForceReady
public:
void ForceReady()

See Also

Timer Class
robotManager.Helpful Namespace


Peek Method

Timer..::..Peek Method

Returns the time that has passed since the Reset() method was called.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public long Peek()
Public Function Peek As Long
public:
long long^ Peek()

Return Value

A long that contains the time that has passed since the Reset() method was called.

Exceptions

Exception | Condition
NotSupportedException | The system does not have a high-resolution performance counter.

Remarks

The time is returned in tenths-of-a-millisecond. If the Peek method returns '10000', it means the interval took exactely one second.

See Also

Timer Class
robotManager.Helpful Namespace


Reset Method

Timer..::..Reset Method

Overload List

 | Name | Description
Public method | Reset()()()() | Resets the stopwatch. This method should be called when you start measuring.
Public method | Reset(Double) | Resets the stopwatch. This method should be called when you start measuring.

See Also

Timer Class
Timer Members
robotManager.Helpful Namespace


Reset Method

Timer..::..Reset Method

Resets the stopwatch. This method should be called when you start measuring.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public void Reset()
Public Sub Reset
public:
void Reset()

Exceptions

Exception | Condition
NotSupportedException | The system does not have a high-resolution performance counter.

See Also

Timer Class
Reset Overload
robotManager.Helpful Namespace


Reset Method (Double)

Timer..::..Reset Method (Double)

Resets the stopwatch. This method should be called when you start measuring.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public void Reset(
    double countDowntime
)
Public Sub Reset ( _
    countDowntime As Double _
)
public:
void Reset(
    double^ countDowntime
)

Parameters

countDowntime
Type: Double
The count downtime.

Exceptions

Exception | Condition
NotSupportedException | The system does not have a high-resolution performance counter.

See Also

Timer Class
Reset Overload
robotManager.Helpful Namespace


TimeLeft Method

Timer..::..TimeLeft Method

Returns timer left.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public long TimeLeft()
Public Function TimeLeft As Long
public:
long long^ TimeLeft()

Return Value

System.Int64.

See Also

Timer Class
robotManager.Helpful Namespace


Timer Properties

The Timer type exposes the following members.

Properties

 | Name | Description
Public property | CountDowntime | Holds the value of the Frequency property.
Public property | IsReady | Returns true if the timer is ready
Public property | StartTime | Gets or sets the start time.

See Also

Timer Class
robotManager.Helpful Namespace


CountDowntime Property

Timer..::..CountDowntime Property

Holds the value of the Frequency property.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public double CountDowntime { get; set; }
Public Property CountDowntime As Double
    Get
    Set
public:
property double^ CountDowntime {
    double^ get ();
    void set (double^ value);
}

Field Value

The count downtime.

See Also

Timer Class
robotManager.Helpful Namespace


IsReady Property

Timer..::..IsReady Property

Returns true if the timer is ready

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public bool IsReady { get; }
Public ReadOnly Property IsReady As Boolean
    Get
public:
property bool^ IsReady {
    bool^ get ();
}

Field Value

true if this instance is ready; otherwise, false.

Exceptions

Exception | Condition
NotSupportedException | The system does not have a high-resolution performance counter.

See Also

Timer Class
robotManager.Helpful Namespace


StartTime Property

Timer..::..StartTime Property

Gets or sets the start time.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public long StartTime { get; set; }
Public Property StartTime As Long
    Get
    Set
public:
property long long^ StartTime {
    long long^ get ();
    void set (long long^ value);
}

Field Value

A long that holds the start time.

See Also

Timer Class
robotManager.Helpful Namespace


Utf8StringWriter Class

Class Utf8StringWriter. Implements the StringWriter

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public class Utf8StringWriter : StringWriter
Public Class Utf8StringWriter _
    Inherits StringWriter
public ref class Utf8StringWriter : public StringWriter

Inheritance Hierarchy

Object
MarshalByRefObject
TextWriter
StringWriter
robotManager.Helpful..::..Utf8StringWriter

See Also

Utf8StringWriter Members
robotManager.Helpful Namespace
StringWriter


Utf8StringWriter Members

The Utf8StringWriter type exposes the following members.

Methods

 | Name | Description
Public method | Close | (Inherited from StringWriter.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | Dispose(System.Boolean) | (Inherited from StringWriter.)
Public method | Dispose | (Inherited from TextWriter.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | Flush | (Inherited from TextWriter.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetStringBuilder | (Inherited from StringWriter.)
Public method | GetType | (Inherited from Object.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from StringWriter.)
Public method | Write(System.Char) | (Inherited from StringWriter.)
Public method | Write(System.Char[],System.Int32,System.Int32) | (Inherited from StringWriter.)
Public method | Write(System.String) | (Inherited from StringWriter.)
Public method | Write(System.Char[]) | (Inherited from TextWriter.)
Public method | Write(System.Boolean) | (Inherited from TextWriter.)
Public method | Write(System.Int32) | (Inherited from TextWriter.)
Public method | Write(System.UInt32) | (Inherited from TextWriter.)
Public method | Write(System.Int64) | (Inherited from TextWriter.)
Public method | Write(System.UInt64) | (Inherited from TextWriter.)
Public method | Write(System.Single) | (Inherited from TextWriter.)
Public method | Write(System.Double) | (Inherited from TextWriter.)
Public method | Write(System.Decimal) | (Inherited from TextWriter.)
Public method | Write(System.Object) | (Inherited from TextWriter.)
Public method | Write(System.String,System.Object) | (Inherited from TextWriter.)
Public method | Write(System.String,System.Object,System.Object) | (Inherited from TextWriter.)
Public method | Write(System.String,System.Object,System.Object,System.Object) | (Inherited from TextWriter.)
Public method | Write(System.String,System.Object[]) | (Inherited from TextWriter.)
Public method | WriteLine | (Inherited from TextWriter.)
Public method | WriteLine(System.Char) | (Inherited from TextWriter.)
Public method | WriteLine(System.Char[]) | (Inherited from TextWriter.)
Public method | WriteLine(System.Char[],System.Int32,System.Int32) | (Inherited from TextWriter.)
Public method | WriteLine(System.Boolean) | (Inherited from TextWriter.)
Public method | WriteLine(System.Int32) | (Inherited from TextWriter.)
Public method | WriteLine(System.UInt32) | (Inherited from TextWriter.)
Public method | WriteLine(System.Int64) | (Inherited from TextWriter.)
Public method | WriteLine(System.UInt64) | (Inherited from TextWriter.)
Public method | WriteLine(System.Single) | (Inherited from TextWriter.)
Public method | WriteLine(System.Double) | (Inherited from TextWriter.)
Public method | WriteLine(System.Decimal) | (Inherited from TextWriter.)
Public method | WriteLine(System.String) | (Inherited from TextWriter.)
Public method | WriteLine(System.Object) | (Inherited from TextWriter.)
Public method | WriteLine(System.String,System.Object) | (Inherited from TextWriter.)
Public method | WriteLine(System.String,System.Object,System.Object) | (Inherited from TextWriter.)
Public method | WriteLine(System.String,System.Object,System.Object,System.Object) | (Inherited from TextWriter.)
Public method | WriteLine(System.String,System.Object[]) | (Inherited from TextWriter.)

Properties

 | Name | Description
Public property | Encoding | Gets the encoding.
Public property | FormatProvider | (Inherited from TextWriter.)
Public property | NewLine | (Inherited from TextWriter.)

See Also

Utf8StringWriter Class
robotManager.Helpful Namespace


Utf8StringWriter Methods

The Utf8StringWriter type exposes the following members.

Methods

 | Name | Description
Public method | Close | (Inherited from StringWriter.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | Dispose(System.Boolean) | (Inherited from StringWriter.)
Public method | Dispose | (Inherited from TextWriter.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | Flush | (Inherited from TextWriter.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetStringBuilder | (Inherited from StringWriter.)
Public method | GetType | (Inherited from Object.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from StringWriter.)
Public method | Write(System.Char) | (Inherited from StringWriter.)
Public method | Write(System.Char[],System.Int32,System.Int32) | (Inherited from StringWriter.)
Public method | Write(System.String) | (Inherited from StringWriter.)
Public method | Write(System.Char[]) | (Inherited from TextWriter.)
Public method | Write(System.Boolean) | (Inherited from TextWriter.)
Public method | Write(System.Int32) | (Inherited from TextWriter.)
Public method | Write(System.UInt32) | (Inherited from TextWriter.)
Public method | Write(System.Int64) | (Inherited from TextWriter.)
Public method | Write(System.UInt64) | (Inherited from TextWriter.)
Public method | Write(System.Single) | (Inherited from TextWriter.)
Public method | Write(System.Double) | (Inherited from TextWriter.)
Public method | Write(System.Decimal) | (Inherited from TextWriter.)
Public method | Write(System.Object) | (Inherited from TextWriter.)
Public method | Write(System.String,System.Object) | (Inherited from TextWriter.)
Public method | Write(System.String,System.Object,System.Object) | (Inherited from TextWriter.)
Public method | Write(System.String,System.Object,System.Object,System.Object) | (Inherited from TextWriter.)
Public method | Write(System.String,System.Object[]) | (Inherited from TextWriter.)
Public method | WriteLine | (Inherited from TextWriter.)
Public method | WriteLine(System.Char) | (Inherited from TextWriter.)
Public method | WriteLine(System.Char[]) | (Inherited from TextWriter.)
Public method | WriteLine(System.Char[],System.Int32,System.Int32) | (Inherited from TextWriter.)
Public method | WriteLine(System.Boolean) | (Inherited from TextWriter.)
Public method | WriteLine(System.Int32) | (Inherited from TextWriter.)
Public method | WriteLine(System.UInt32) | (Inherited from TextWriter.)
Public method | WriteLine(System.Int64) | (Inherited from TextWriter.)
Public method | WriteLine(System.UInt64) | (Inherited from TextWriter.)
Public method | WriteLine(System.Single) | (Inherited from TextWriter.)
Public method | WriteLine(System.Double) | (Inherited from TextWriter.)
Public method | WriteLine(System.Decimal) | (Inherited from TextWriter.)
Public method | WriteLine(System.String) | (Inherited from TextWriter.)
Public method | WriteLine(System.Object) | (Inherited from TextWriter.)
Public method | WriteLine(System.String,System.Object) | (Inherited from TextWriter.)
Public method | WriteLine(System.String,System.Object,System.Object) | (Inherited from TextWriter.)
Public method | WriteLine(System.String,System.Object,System.Object,System.Object) | (Inherited from TextWriter.)
Public method | WriteLine(System.String,System.Object[]) | (Inherited from TextWriter.)

See Also

Utf8StringWriter Class
robotManager.Helpful Namespace


Utf8StringWriter Properties

The Utf8StringWriter type exposes the following members.

Properties

 | Name | Description
Public property | Encoding | Gets the encoding.
Public property | FormatProvider | (Inherited from TextWriter.)
Public property | NewLine | (Inherited from TextWriter.)

See Also

Utf8StringWriter Class
robotManager.Helpful Namespace


Encoding Property

Utf8StringWriter..::..Encoding Property

Gets the encoding.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public Encoding Encoding { get; }
Public ReadOnly Property Encoding As Encoding
    Get
public:
property Encoding^ Encoding {
    Encoding^ get ();
}

Field Value

The encoding.

See Also

Utf8StringWriter Class
robotManager.Helpful Namespace


Var Class

Class Var. Useful to store values for the session.

Examples

C#
Var.SetVar("VariableName", "Test value");
 // ...
string v = Var.GetVar<string>("VariableName");
System.Windows.Forms.MessageBox.Show(v);

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static class Var
Public NotInheritable Class Var
public ref class Var abstract sealed

Inheritance Hierarchy

Object
robotManager.Helpful..::..Var

See Also

Var Members
robotManager.Helpful Namespace


Var Members

The Var type exposes the following members.

Methods

Name | Description
Exist | Exist variable name.
GetVar<(Of <<'(T>)>>) | Get variable value.
IsType | Determine whether the specified variable name is specified type.
SetVar | Set variable value.

Fields

Name | Description
VarDictionary | The storage dictionary, should not be used directly.

See Also

Var Class
robotManager.Helpful Namespace


Var Fields

The Var type exposes the following members.

Fields

Name | Description
VarDictionary | The storage dictionary, should not be used directly.

See Also

Var Class
robotManager.Helpful Namespace


VarDictionary Field

Var..::..VarDictionary Field

The storage dictionary, should not be used directly.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static Dictionary<string, Object> VarDictionary
Public Shared VarDictionary As Dictionary(Of String, Object)
public:
static Dictionary<String^, Object^>^ VarDictionary

See Also

Var Class
robotManager.Helpful Namespace


Var Methods

The Var type exposes the following members.

Methods

Name | Description
Exist | Exist variable name.
GetVar<(Of <<'(T>)>>) | Get variable value.
IsType | Determine whether the specified variable name is specified type.
SetVar | Set variable value.

See Also

Var Class
robotManager.Helpful Namespace


Exist Method

Var..::..Exist Method

Exist variable name.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static bool Exist(
    string varName
)
Public Shared Function Exist ( _
    varName As String _
) As Boolean
public:
static bool^ Exist(
    String^ varName
)

Parameters

varName
Type: String
Name of the variable.

Return Value

true if exist, false otherwise.

See Also

Var Class
robotManager.Helpful Namespace


GetVar(T) Method

Var..::..GetVar<(Of <(<'T>)>)> Method

Get variable value.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static T GetVar<T>(
    string varName
)

Public Shared Function GetVar(Of T) ( _
    varName As String _
) As T
public:
generic<typename T>
static T GetVar(
    String^ varName
)

Type Parameters

T

Parameters

varName
Type: String
Name of the variable.

Return Value

value.

See Also

Var Class
robotManager.Helpful Namespace


IsType Method

Var..::..IsType Method

Determine whether the specified variable name is specified type.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static bool IsType(
    string varName,
    Type type
)
Public Shared Function IsType ( _
    varName As String, _
    type As Type _
) As Boolean
public:
static bool^ IsType(
    String^ varName,
    Type^ type
)

Parameters

varName
Type: String
Name of the variable.
type
Type: Type
The type.

Return Value

true if the variable name is the specified type; otherwise, false.

See Also

Var Class
robotManager.Helpful Namespace


SetVar Method

Var..::..SetVar Method

Set variable value.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static bool SetVar(
    string varName,
    Object var
)
Public Shared Function SetVar ( _
    varName As String, _
    var As Object _
) As Boolean
public:
static bool^ SetVar(
    String^ varName,
    Object^ var
)

Parameters

varName
Type: String
Name of the variable.
var
Type: Object
The variable value.

Return Value

true if success, false otherwise.

See Also

Var Class
robotManager.Helpful Namespace


Vector3 Class

Vector3 class

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class Vector3 : IXmlSerializable
<SerializableAttribute> _
Public Class Vector3 _
    Implements IXmlSerializable
[SerializableAttribute]
public ref class Vector3 : IXmlSerializable

Inheritance Hierarchy

Object
robotManager.Helpful..::..Vector3

See Also

Vector3 Members
robotManager.Helpful Namespace


Vector3 Members

The Vector3 type exposes the following members.

Constructors

 | Name | Description
Public method | Vector3()()()() | Initializes a new instance of the Vector3 class.
Public method | Vector3(Single, Single, Single, String) | Initializes a new instance of the Vector3 class.
Public method | Vector3(Double, Double, Double, String) | Initializes a new instance of the Vector3 class.
Public method | Vector3(Vector3) | Initializes a new instance of the Vector3 class.
Public method | Vector3(array<Single>[]()[][]) | Initializes a new instance of the Vector3 class.

Methods

 | Name | Description
 | Distance | Distance between.
 | Distance2D | Distance 2D.
 | DistanceListVectors3 | Distance total of vectors3 list.
Public method | DistanceTo | Distance to.
Public method | DistanceTo2D | Distance 2D to.
Public method | DistanceZ(Vector3, Vector3) | Distance z.
Public method | DistanceZ(Vector3) | Distance z.
 | Dot | Dots the specified v1.
Public method | Equals | Determines whether the specified Object is equal to.
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetSchema | Gets the schema.
Public method | GetType | (Inherited from Object.)
Public method | InFrontOf | In front of.
Public method | IsFlying | Determines if is flying type.
Public method | IsGround | Determines whether is ground (default) type.
Public method | IsSwimming | Determines whether is swimming type.
Public method | Magnitude | Magnitude.
Public method | MagnitudeSqr | Magnitude the SQR.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadXml | Read XML.
Public method | SetFlying | Set to flying type.
Public method | SetGround | Set to ground (default) type.
Public method | SetSwimming | Set to swimming type.
Public method | Size | Sizes.
Public method | Size2D | Size2D.
Public method | ToSlimDxVector3 | Converts to slimdxvector3.
Public method | ToString | Returns a String that represents.
Public method | ToStringInvariantCulture | Converts to stringinvariantculture.
Public method | ToStringNewVector | Converts to stringnewvector.
Public method | ToStringXml | Converts to stringxml.
Public method | WriteXml | Write XML.

Operators

Name | Description
Addition | Implements the + operator.
Division(Vector3, Vector3) | Implements the / operator.
Division(Vector3, Single) | Implements the / operator.
Equality | Implements the == operator.
Inequality | Implements the != operator.
Multiply(Vector3, Vector3) | Implements the * operator.
Multiply(Vector3, Single) | Implements the * operator.
Subtraction | Implements the - operator.

Properties

 | Name | Description
Public property | Action | Action.
 | Empty | Get empty vector3.
Public property | Type | Vector3 Type.
Public property | X | Gets or sets the X Position.
Public property | Y | Gets or sets the Y Position.
Public property | Z | Gets or sets the Z Position.
 | Zero | Get vector3 position zero.

See Also

Vector3 Class
robotManager.Helpful Namespace


Vector3 Constructor

Overload List

 | Name | Description
Public method | Vector3()()()() | Initializes a new instance of the Vector3 class.
Public method | Vector3(Single, Single, Single, String) | Initializes a new instance of the Vector3 class.
Public method | Vector3(Double, Double, Double, String) | Initializes a new instance of the Vector3 class.
Public method | Vector3(Vector3) | Initializes a new instance of the Vector3 class.
Public method | Vector3(array<Single>[]()[][]) | Initializes a new instance of the Vector3 class.

See Also

Vector3 Class
Vector3 Members
robotManager.Helpful Namespace


Vector3 Constructor

Initializes a new instance of the Vector3 class.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public Vector3()
Public Sub New
public:
Vector3()

See Also

Vector3 Class
Vector3 Overload
robotManager.Helpful Namespace


Vector3 Constructor (Single, Single, Single, String)

Initializes a new instance of the Vector3 class.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public Vector3(
    float x,
    float y,
    float z,
    string type
)
Public Sub New ( _
    x As Single, _
    y As Single, _
    z As Single, _
    type As String _
)
public:
Vector3(
    float^ x,
    float^ y,
    float^ z,
    String^ type
)

Parameters

x
Type: Single
The x.
y
Type: Single
The y.
z
Type: Single
The z.
type
Type: String
Type (Flying, None)

See Also

Vector3 Class
Vector3 Overload
robotManager.Helpful Namespace


Vector3 Constructor (Double, Double, Double, String)

Initializes a new instance of the Vector3 class.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public Vector3(
    double x,
    double y,
    double z,
    string type
)
Public Sub New ( _
    x As Double, _
    y As Double, _
    z As Double, _
    type As String _
)
public:
Vector3(
    double^ x,
    double^ y,
    double^ z,
    String^ type
)

Parameters

x
Type: Double
The x.
y
Type: Double
The y.
z
Type: Double
The z.
type
Type: String
The type.

See Also

Vector3 Class
Vector3 Overload
robotManager.Helpful Namespace


Vector3 Constructor (Vector3)

Initializes a new instance of the Vector3 class.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public Vector3(
    Vector3 vector3
)
Public Sub New ( _
    vector3 As Vector3 _
)
public:
Vector3(
    Vector3^ vector3
)

Parameters

vector3
Type: robotManager.Helpful..::..Vector3
The Vector3.

See Also

Vector3 Class
Vector3 Overload
robotManager.Helpful Namespace


Vector3 Constructor (Single[])

Vector3 Constructor (array<Single>[]()[][])

Initializes a new instance of the Vector3 class.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public Vector3(
    float[] pos
)
Public Sub New ( _
    pos As Single() _
)
public:
Vector3(
    array<float^>^ pos
)

Parameters

pos
Type: array< Single >[]()[][]
The position.

See Also

Vector3 Class
Vector3 Overload
robotManager.Helpful Namespace


Vector3 Methods

The Vector3 type exposes the following members.

Methods

 | Name | Description
 | Distance | Distance between.
 | Distance2D | Distance 2D.
 | DistanceListVectors3 | Distance total of vectors3 list.
Public method | DistanceTo | Distance to.
Public method | DistanceTo2D | Distance 2D to.
Public method | DistanceZ(Vector3, Vector3) | Distance z.
Public method | DistanceZ(Vector3) | Distance z.
 | Dot | Dots the specified v1.
Public method | Equals | Determines whether the specified Object is equal to.
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetSchema | Gets the schema.
Public method | GetType | (Inherited from Object.)
Public method | InFrontOf | In front of.
Public method | IsFlying | Determines if is flying type.
Public method | IsGround | Determines whether is ground (default) type.
Public method | IsSwimming | Determines whether is swimming type.
Public method | Magnitude | Magnitude.
Public method | MagnitudeSqr | Magnitude the SQR.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadXml | Read XML.
Public method | SetFlying | Set to flying type.
Public method | SetGround | Set to ground (default) type.
Public method | SetSwimming | Set to swimming type.
Public method | Size | Sizes.
Public method | Size2D | Size2D.
Public method | ToSlimDxVector3 | Converts to slimdxvector3.
Public method | ToString | Returns a String that represents.
Public method | ToStringInvariantCulture | Converts to stringinvariantculture.
Public method | ToStringNewVector | Converts to stringnewvector.
Public method | ToStringXml | Converts to stringxml.
Public method | WriteXml | Write XML.

See Also

Vector3 Class
robotManager.Helpful Namespace


Distance Method

Vector3..::..Distance Method

Distance between.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static float Distance(
    Vector3 a,
    Vector3 b
)
Public Shared Function Distance ( _
    a As Vector3, _
    b As Vector3 _
) As Single
public:
static float^ Distance(
    Vector3^ a,
    Vector3^ b
)

Parameters

a
Type: robotManager.Helpful..::..Vector3
position a.
b
Type: robotManager.Helpful..::..Vector3
position b.

Return Value

distance.

See Also

Vector3 Class
robotManager.Helpful Namespace


Distance2D Method

Vector3..::..Distance2D Method

Distance 2D.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static float Distance2D(
    Vector3 a,
    Vector3 b
)
Public Shared Function Distance2D ( _
    a As Vector3, _
    b As Vector3 _
) As Single
public:
static float^ Distance2D(
    Vector3^ a,
    Vector3^ b
)

Parameters

a
Type: robotManager.Helpful..::..Vector3
position a.
b
Type: robotManager.Helpful..::..Vector3
position b.

Return Value

distance.

See Also

Vector3 Class
robotManager.Helpful Namespace


DistanceListVectors3 Method

Vector3..::..DistanceListVectors3 Method

Distance total of vectors3 list.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static float DistanceListVectors3(
    List<Vector3> listVectors3,
    Vector3 myPosition
)
Public Shared Function DistanceListVectors3 ( _
    listVectors3 As List(Of Vector3), _
    myPosition As Vector3 _
) As Single
public:
static float^ DistanceListVectors3(
    List<Vector3^>^ listVectors3,
    Vector3^ myPosition
)

Parameters

listVectors3
Type: List <(Of <(<' Vector3 >)>)>
vectors3 list.
myPosition
Type: robotManager.Helpful..::..Vector3
start position if not in list.

Return Value

distance.

See Also

Vector3 Class
robotManager.Helpful Namespace


DistanceTo Method

Vector3..::..DistanceTo Method

Distance to.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public float DistanceTo(
    Vector3 b
)
Public Function DistanceTo ( _
    b As Vector3 _
) As Single
public:
float^ DistanceTo(
    Vector3^ b
)

Parameters

b
Type: robotManager.Helpful..::..Vector3
position b.

Return Value

distance.

See Also

Vector3 Class
robotManager.Helpful Namespace


DistanceTo2D Method

Vector3..::..DistanceTo2D Method

Distance 2D to.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public float DistanceTo2D(
    Vector3 b
)
Public Function DistanceTo2D ( _
    b As Vector3 _
) As Single
public:
float^ DistanceTo2D(
    Vector3^ b
)

Parameters

b
Type: robotManager.Helpful..::..Vector3
position b.

Return Value

distance.

See Also

Vector3 Class
robotManager.Helpful Namespace


DistanceZ Method

Vector3..::..DistanceZ Method

Overload List

 | Name | Description
Public method | DistanceZ(Vector3, Vector3) | Distance z.
Public method | DistanceZ(Vector3) | Distance z.

See Also

Vector3 Class
Vector3 Members
robotManager.Helpful Namespace


DistanceZ Method (Vector3, Vector3)

Vector3..::..DistanceZ Method (Vector3, Vector3)

Distance z.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public float DistanceZ(
    Vector3 a,
    Vector3 b
)
Public Function DistanceZ ( _
    a As Vector3, _
    b As Vector3 _
) As Single
public:
float^ DistanceZ(
    Vector3^ a,
    Vector3^ b
)

Parameters

a
Type: robotManager.Helpful..::..Vector3
position a.
b
Type: robotManager.Helpful..::..Vector3
position b.

Return Value

distance.

See Also

Vector3 Class
DistanceZ Overload
robotManager.Helpful Namespace


DistanceZ Method (Vector3)

Vector3..::..DistanceZ Method (Vector3)

Distance z.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public float DistanceZ(
    Vector3 b
)
Public Function DistanceZ ( _
    b As Vector3 _
) As Single
public:
float^ DistanceZ(
    Vector3^ b
)

Parameters

b
Type: robotManager.Helpful..::..Vector3
position b.

Return Value

distance.

See Also

Vector3 Class
DistanceZ Overload
robotManager.Helpful Namespace


Dot Method

Vector3..::..Dot Method

Dots the specified v1.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static float Dot(
    ref Vector3 v1,
    ref Vector3 v2
)
Public Shared Function Dot ( _
    ByRef v1 As Vector3, _
    ByRef v2 As Vector3 _
) As Single
public:
static float^ Dot(
    Vector3^% v1,
    Vector3^% v2
)

Parameters

v1
Type: robotManager.Helpful..::..Vector3 %
position v1.
v2
Type: robotManager.Helpful..::..Vector3 %
position v2.

Return Value

System.Single.

See Also

Vector3 Class
robotManager.Helpful Namespace


Equals Method

Vector3..::..Equals Method

Determines whether the specified Object is equal to.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public bool Equals(
    Object obj
)
Public Function Equals ( _
    obj As Object _
) As Boolean
public:
bool^ Equals(
    Object^ obj
)

Parameters

obj
Type: Object
The object to compare with the current object.

Return Value

true if the specified Object is equal to; otherwise, false.

See Also

Vector3 Class
robotManager.Helpful Namespace


GetSchema Method

Vector3..::..GetSchema Method

Gets the schema.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public XmlSchema GetSchema()
Public Function GetSchema As XmlSchema
public:
XmlSchema^ GetSchema()

Return Value

XmlSchema.

See Also

Vector3 Class
robotManager.Helpful Namespace


InFrontOf Method

Vector3..::..InFrontOf Method

In front of.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public Vector3 InFrontOf(
    float heading,
    float d
)
Public Function InFrontOf ( _
    heading As Single, _
    d As Single _
) As Vector3
public:
Vector3^ InFrontOf(
    float^ heading,
    float^ d
)

Parameters

heading
Type: Single
The heading.
d
Type: Single
The d.

Return Value

Vector3.

See Also

Vector3 Class
robotManager.Helpful Namespace


IsFlying Method

Vector3..::..IsFlying Method

Determines if is flying type.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public bool IsFlying()
Public Function IsFlying As Boolean
public:
bool^ IsFlying()

Return Value

true if is flying type; otherwise, false.

See Also

Vector3 Class
robotManager.Helpful Namespace


IsGround Method

Vector3..::..IsGround Method

Determines whether is ground (default) type.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public bool IsGround()
Public Function IsGround As Boolean
public:
bool^ IsGround()

Return Value

true if is ground type; otherwise, false.

See Also

Vector3 Class
robotManager.Helpful Namespace


IsSwimming Method

Vector3..::..IsSwimming Method

Determines whether is swimming type.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public bool IsSwimming()
Public Function IsSwimming As Boolean
public:
bool^ IsSwimming()

Return Value

true if is swimming type; otherwise, false.

See Also

Vector3 Class
robotManager.Helpful Namespace


Magnitude Method

Vector3..::..Magnitude Method

Magnitude.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public float Magnitude()
Public Function Magnitude As Single
public:
float^ Magnitude()

Return Value

System.Single.

See Also

Vector3 Class
robotManager.Helpful Namespace


MagnitudeSqr Method

Vector3..::..MagnitudeSqr Method

Magnitude the SQR.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public float MagnitudeSqr()
Public Function MagnitudeSqr As Single
public:
float^ MagnitudeSqr()

Return Value

System.Single.

See Also

Vector3 Class
robotManager.Helpful Namespace


ReadXml Method

Vector3..::..ReadXml Method

Read XML.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public void ReadXml(
    XmlReader reader
)
Public Sub ReadXml ( _
    reader As XmlReader _
)
public:
void ReadXml(
    XmlReader^ reader
)

Parameters

reader
Type: XmlReader
The reader.

See Also

Vector3 Class
robotManager.Helpful Namespace


SetFlying Method

Vector3..::..SetFlying Method

Set to flying type.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public void SetFlying()
Public Sub SetFlying
public:
void SetFlying()

See Also

Vector3 Class
robotManager.Helpful Namespace


SetGround Method

Vector3..::..SetGround Method

Set to ground (default) type.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public void SetGround()
Public Sub SetGround
public:
void SetGround()

See Also

Vector3 Class
robotManager.Helpful Namespace


SetSwimming Method

Vector3..::..SetSwimming Method

Set to swimming type.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public void SetSwimming()
Public Sub SetSwimming
public:
void SetSwimming()

See Also

Vector3 Class
robotManager.Helpful Namespace


Size Method

Vector3..::..Size Method

Sizes.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public float Size()
Public Function Size As Single
public:
float^ Size()

Return Value

System.Single.

See Also

Vector3 Class
robotManager.Helpful Namespace


Size2D Method

Vector3..::..Size2D Method

Size2D.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public float Size2D()
Public Function Size2D As Single
public:
float^ Size2D()

Return Value

size.

See Also

Vector3 Class
robotManager.Helpful Namespace


ToSlimDxVector3 Method

Vector3..::..ToSlimDxVector3 Method

Converts to slimdxvector3.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public Vector3 ToSlimDxVector3()
Public Function ToSlimDxVector3 As Vector3
public:
Vector3^ ToSlimDxVector3()

Return Value

SlimDX.Vector3.

See Also

Vector3 Class
robotManager.Helpful Namespace


ToString Method

Vector3..::..ToString Method

Returns a String that represents.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public string ToString()
Public Function ToString As String
public:
String^ ToString()

Return Value

A String that represents.

See Also

Vector3 Class
robotManager.Helpful Namespace


ToStringInvariantCulture Method

Vector3..::..ToStringInvariantCulture Method

Converts to stringinvariantculture.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public string ToStringInvariantCulture()
Public Function ToStringInvariantCulture As String
public:
String^ ToStringInvariantCulture()

Return Value

System.String.

See Also

Vector3 Class
robotManager.Helpful Namespace


ToStringNewVector Method

Vector3..::..ToStringNewVector Method

Converts to stringnewvector.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public string ToStringNewVector()
Public Function ToStringNewVector As String
public:
String^ ToStringNewVector()

Return Value

System.String.

See Also

Vector3 Class
robotManager.Helpful Namespace


ToStringXml Method

Vector3..::..ToStringXml Method

Converts to stringxml.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public string ToStringXml()
Public Function ToStringXml As String
public:
String^ ToStringXml()

Return Value

System.String.

See Also

Vector3 Class
robotManager.Helpful Namespace


WriteXml Method

Vector3..::..WriteXml Method

Write XML.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public void WriteXml(
    XmlWriter writer
)
Public Sub WriteXml ( _
    writer As XmlWriter _
)
public:
void WriteXml(
    XmlWriter^ writer
)

Parameters

writer
Type: XmlWriter
The writer.

See Also

Vector3 Class
robotManager.Helpful Namespace


Vector3 Operators

The Vector3 type exposes the following members.

Operators

Name | Description
Addition | Implements the + operator.
Division(Vector3, Vector3) | Implements the / operator.
Division(Vector3, Single) | Implements the / operator.
Equality | Implements the == operator.
Inequality | Implements the != operator.
Multiply(Vector3, Vector3) | Implements the * operator.
Multiply(Vector3, Single) | Implements the * operator.
Subtraction | Implements the - operator.

See Also

Vector3 Class
robotManager.Helpful Namespace


Addition Operator

Vector3..::..Addition Operator

Implements the + operator.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static Vector3 operator +(
    Vector3 a,
    Vector3 b
)
Public Shared Operator + ( _
    a As Vector3, _
    b As Vector3 _
) As Vector3
public:
static Vector3^ operator +(
    Vector3^ a,
    Vector3^ b
)

Parameters

a
Type: robotManager.Helpful..::..Vector3
position a.
b
Type: robotManager.Helpful..::..Vector3
position b.

Return Value

The result of the operator.

See Also

Vector3 Class
robotManager.Helpful Namespace


Division Operator

Vector3..::..Division Operator

Overload List

Name | Description
Division(Vector3, Vector3) | Implements the / operator.
Division(Vector3, Single) | Implements the / operator.

See Also

Vector3 Class
Vector3 Members
robotManager.Helpful Namespace


Division Operator (Vector3, Vector3)

Vector3..::..Division Operator (Vector3, Vector3)

Implements the / operator.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static Vector3 operator /(
    Vector3 a,
    Vector3 b
)
Public Shared Operator / ( _
    a As Vector3, _
    b As Vector3 _
) As Vector3
public:
static Vector3^ operator /(
    Vector3^ a,
    Vector3^ b
)

Parameters

a
Type: robotManager.Helpful..::..Vector3
position a.
b
Type: robotManager.Helpful..::..Vector3
position b.

Return Value

The result of the operator.

See Also

Vector3 Class
Division Overload
robotManager.Helpful Namespace


Division Operator (Vector3, Single)

Vector3..::..Division Operator (Vector3, Single)

Implements the / operator.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static Vector3 operator /(
    Vector3 a,
    float b
)
Public Shared Operator / ( _
    a As Vector3, _
    b As Single _
) As Vector3
public:
static Vector3^ operator /(
    Vector3^ a,
    float^ b
)

Parameters

a
Type: robotManager.Helpful..::..Vector3
position a.
b
Type: Single
b.

Return Value

The result of the operator.

See Also

Vector3 Class
Division Overload
robotManager.Helpful Namespace


Equality Operator

Vector3..::..Equality Operator

Implements the == operator.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static bool operator ==(
    Vector3 a,
    Vector3 b
)
Public Shared Operator = ( _
    a As Vector3, _
    b As Vector3 _
) As Boolean
public:
static bool^ operator ==(
    Vector3^ a,
    Vector3^ b
)

Parameters

a
Type: robotManager.Helpful..::..Vector3
position a.
b
Type: robotManager.Helpful..::..Vector3
position b.

Return Value

The result of the operator.

See Also

Vector3 Class
robotManager.Helpful Namespace


Inequality Operator

Vector3..::..Inequality Operator

Implements the != operator.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static bool operator !=(
    Vector3 a,
    Vector3 b
)
Public Shared Operator <> ( _
    a As Vector3, _
    b As Vector3 _
) As Boolean
public:
static bool^ operator !=(
    Vector3^ a,
    Vector3^ b
)

Parameters

a
Type: robotManager.Helpful..::..Vector3
position a.
b
Type: robotManager.Helpful..::..Vector3
position b.

Return Value

The result of the operator.

See Also

Vector3 Class
robotManager.Helpful Namespace


Multiply Operator

Vector3..::..Multiply Operator

Overload List

Name | Description
Multiply(Vector3, Vector3) | Implements the * operator.
Multiply(Vector3, Single) | Implements the * operator.

See Also

Vector3 Class
Vector3 Members
robotManager.Helpful Namespace


Multiply Operator (Vector3, Vector3)

Vector3..::..Multiply Operator (Vector3, Vector3)

Implements the * operator.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static Vector3 operator *(
    Vector3 a,
    Vector3 b
)
Public Shared Operator * ( _
    a As Vector3, _
    b As Vector3 _
) As Vector3
public:
static Vector3^ operator *(
    Vector3^ a,
    Vector3^ b
)

Parameters

a
Type: robotManager.Helpful..::..Vector3
position a.
b
Type: robotManager.Helpful..::..Vector3
position b.

Return Value

The result of the operator.

See Also

Vector3 Class
Multiply Overload
robotManager.Helpful Namespace


Multiply Operator (Vector3, Single)

Vector3..::..Multiply Operator (Vector3, Single)

Implements the * operator.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static Vector3 operator *(
    Vector3 a,
    float b
)
Public Shared Operator * ( _
    a As Vector3, _
    b As Single _
) As Vector3
public:
static Vector3^ operator *(
    Vector3^ a,
    float^ b
)

Parameters

a
Type: robotManager.Helpful..::..Vector3
position a.
b
Type: Single
b.

Return Value

The result of the operator.

See Also

Vector3 Class
Multiply Overload
robotManager.Helpful Namespace


Subtraction Operator

Vector3..::..Subtraction Operator

Implements the - operator.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static Vector3 operator -(
    Vector3 a,
    Vector3 b
)
Public Shared Operator - ( _
    a As Vector3, _
    b As Vector3 _
) As Vector3
public:
static Vector3^ operator -(
    Vector3^ a,
    Vector3^ b
)

Parameters

a
Type: robotManager.Helpful..::..Vector3
position a.
b
Type: robotManager.Helpful..::..Vector3
position b.

Return Value

The result of the operator.

See Also

Vector3 Class
robotManager.Helpful Namespace


Vector3 Properties

The Vector3 type exposes the following members.

Properties

 | Name | Description
Public property | Action | Action.
 | Empty | Get empty vector3.
Public property | Type | Vector3 Type.
Public property | X | Gets or sets the X Position.
Public property | Y | Gets or sets the Y Position.
Public property | Z | Gets or sets the Z Position.
 | Zero | Get vector3 position zero.

See Also

Vector3 Class
robotManager.Helpful Namespace


Action Property

Vector3..::..Action Property

Action.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[DefaultValueAttribute]
[XmlAttribute]
public string Action { get; set; }
<DefaultValueAttribute> _
<XmlAttribute> _
Public Property Action As String
    Get
    Set
[DefaultValueAttribute]
[XmlAttribute]
public:
property String^ Action {
    String^ get ();
    void set (String^ value);
}

Field Value

Action (jump, left, right, land, watersurface, mount, dismount, totown, stopmove, stopmoveto, c#: [CODE], lua: [CODE]).

See Also

Vector3 Class
robotManager.Helpful Namespace


Empty Property

Vector3..::..Empty Property

Get empty vector3.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static Vector3 Empty { get; }
Public Shared ReadOnly Property Empty As Vector3
    Get
public:
static property Vector3^ Empty {
    Vector3^ get ();
}

Field Value

empty vector3.

See Also

Vector3 Class
robotManager.Helpful Namespace


Type Property

Vector3..::..Type Property

Vector3 Type.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[DefaultValueAttribute]
[XmlAttribute]
public string Type { get; set; }
<DefaultValueAttribute> _
<XmlAttribute> _
Public Property Type As String
    Get
    Set
[DefaultValueAttribute]
[XmlAttribute]
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}

Field Value

Vector3 Type (Swimming, Flying or None).

See Also

Vector3 Class
robotManager.Helpful Namespace


X Property

Vector3..::..X Property

Gets or sets the X Position.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[XmlAttribute]
public float X { get; set; }
<XmlAttribute> _
Public Property X As Single
    Get
    Set
[XmlAttribute]
public:
property float^ X {
    float^ get ();
    void set (float^ value);
}

Field Value

The X Position.

See Also

Vector3 Class
robotManager.Helpful Namespace


Y Property

Vector3..::..Y Property

Gets or sets the Y Position.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[XmlAttribute]
public float Y { get; set; }
<XmlAttribute> _
Public Property Y As Single
    Get
    Set
[XmlAttribute]
public:
property float^ Y {
    float^ get ();
    void set (float^ value);
}

Field Value

The Y Position.

See Also

Vector3 Class
robotManager.Helpful Namespace


Z Property

Vector3..::..Z Property

Gets or sets the Z Position.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[XmlAttribute]
public float Z { get; set; }
<XmlAttribute> _
Public Property Z As Single
    Get
    Set
[XmlAttribute]
public:
property float^ Z {
    float^ get ();
    void set (float^ value);
}

Field Value

The Z Position.

See Also

Vector3 Class
robotManager.Helpful Namespace


Zero Property

Vector3..::..Zero Property

Get vector3 position zero.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static Vector3 Zero { get; }
Public Shared ReadOnly Property Zero As Vector3
    Get
public:
static property Vector3^ Zero {
    Vector3^ get ();
}

Field Value

vector3 position zero.

See Also

Vector3 Class
robotManager.Helpful Namespace


XmlSerializer Class

XmlSerializer

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static class XmlSerializer
Public NotInheritable Class XmlSerializer
public ref class XmlSerializer abstract sealed

Inheritance Hierarchy

Object
robotManager.Helpful..::..XmlSerializer

See Also

XmlSerializer Members
robotManager.Helpful Namespace


XmlSerializer Members

The XmlSerializer type exposes the following members.

Methods

Name | Description
Deserialize<(Of <<'(T>)>>)(String) | Deserializes the XML to Class instance.
Deserialize<(Of <<'(T>)>>)(TextReader) | Deserializes the specified reader.
DeserializeText<(Of <<'(T>)>>) | Deserializes the text.
Serialize | Serializes the specified Class to XML.

See Also

XmlSerializer Class
robotManager.Helpful Namespace


XmlSerializer Methods

The XmlSerializer type exposes the following members.

Methods

Name | Description
Deserialize<(Of <<'(T>)>>)(String) | Deserializes the XML to Class instance.
Deserialize<(Of <<'(T>)>>)(TextReader) | Deserializes the specified reader.
DeserializeText<(Of <<'(T>)>>) | Deserializes the text.
Serialize | Serializes the specified Class to XML.

See Also

XmlSerializer Class
robotManager.Helpful Namespace


Deserialize Method

XmlSerializer..::..Deserialize Method

Overload List

Name | Description
Deserialize<(Of <<'(T>)>>)(String) | Deserializes the XML to Class instance.
Deserialize<(Of <<'(T>)>>)(TextReader) | Deserializes the specified reader.

See Also

XmlSerializer Class
XmlSerializer Members
robotManager.Helpful Namespace


Deserialize(T) Method (String)

XmlSerializer..::..Deserialize<(Of <(<'T>)>)> Method (String)

Deserializes the XML to Class instance.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static T Deserialize<T>(
    string path
)

Public Shared Function Deserialize(Of T) ( _
    path As String _
) As T
public:
generic<typename T>
static T Deserialize(
    String^ path
)

Type Parameters

T

Parameters

path
Type: String
The path.

Return Value

instance.

See Also

XmlSerializer Class
Deserialize Overload
robotManager.Helpful Namespace


Deserialize(T) Method (TextReader)

XmlSerializer..::..Deserialize<(Of <(<'T>)>)> Method (TextReader)

Deserializes the specified reader.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static T Deserialize<T>(
    TextReader reader
)

Public Shared Function Deserialize(Of T) ( _
    reader As TextReader _
) As T
public:
generic<typename T>
static T Deserialize(
    TextReader^ reader
)

Type Parameters

T

Parameters

reader
Type: TextReader
The reader.

Return Value

T.

See Also

XmlSerializer Class
Deserialize Overload
robotManager.Helpful Namespace


DeserializeText(T) Method

XmlSerializer..::..DeserializeText<(Of <(<'T>)>)> Method

Deserializes the text.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static T DeserializeText<T>(
    string xmlCode
)

Public Shared Function DeserializeText(Of T) ( _
    xmlCode As String _
) As T
public:
generic<typename T>
static T DeserializeText(
    String^ xmlCode
)

Type Parameters

T

Parameters

xmlCode
Type: String
The XML code.

Return Value

T.

See Also

XmlSerializer Class
robotManager.Helpful Namespace


Serialize Method

XmlSerializer..::..Serialize Method

Serializes the specified Class to XML.

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static bool Serialize(
    string path,
    Object object
)
Public Shared Function Serialize ( _
    path As String, _
    object As Object _
) As Boolean
public:
static bool^ Serialize(
    String^ path,
    Object^ object
)

Parameters

path
Type: String
The path.
object
Type: Object
The @object to serialize.

Return Value

success.

See Also

XmlSerializer Class
robotManager.Helpful Namespace


robotManager.Helpful.Forms Namespace

Classes

 | Class | Description
Public class | DownloadContents | Class DownloadContents. Implements the Window Implements the IComponentConnector Implements the IStyleConnector
Public class | DownloadEntry | Class DownloadEntry.
Public class | DownloadList | Class DownloadList.
Public class | InputBoxMultiline | Class InputBoxMultiline. Quick way to request text to user. Implements the Form
Public class | PopUpPropertyGrid | Class PopUpPropertyGrid. Useful to create quickly settings window, this form use PropertyGrid Implements the Form
Public class | TranslateToolsWindow | TranslateToolsWindow is UI to create LanguageExport for Translate.


DownloadContents Class

Class DownloadContents. Implements the Window Implements the IComponentConnector Implements the IStyleConnector

Namespace: robotManager.Helpful.Forms
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public class DownloadContents
Public Class DownloadContents
public ref class DownloadContents

Inheritance Hierarchy

Object
robotManager.Helpful.Forms..::..DownloadContents

See Also

DownloadContents Members
robotManager.Helpful.Forms Namespace
Window
IComponentConnector
IStyleConnector


DownloadContents Members

The DownloadContents type exposes the following members.

Constructors

 | Name | Description
Public method | DownloadContents | Initializes a new instance of the DownloadContents class.

Methods

 | Name | Description
Public method | DownloadContents_OnLoaded | Handles the OnLoaded event of the DownloadContents control.
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
 | ShowWindow | Shows the window.
 | ShowWindowNewThread(String, String) | Shows the window new thread.
Public method | ToString | (Inherited from Object.)
Public method | UpdateItems | Updates the items.

Properties

 | Name | Description
Public property | Downloads | Gets or sets the downloads.

See Also

DownloadContents Class
robotManager.Helpful.Forms Namespace


DownloadContents Constructor

Initializes a new instance of the DownloadContents class.

Namespace: robotManager.Helpful.Forms
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public DownloadContents(
    string category,
    string search
)
Public Sub New ( _
    category As String, _
    search As String _
)
public:
DownloadContents(
    String^ category,
    String^ search
)

Parameters

category
Type: String
The category.
search
Type: String
The search.

See Also

DownloadContents Class
robotManager.Helpful.Forms Namespace


DownloadContents Methods

The DownloadContents type exposes the following members.

Methods

 | Name | Description
Public method | DownloadContents_OnLoaded | Handles the OnLoaded event of the DownloadContents control.
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
 | ShowWindow | Shows the window.
 | ShowWindowNewThread(String, String) | Shows the window new thread.
Public method | ToString | (Inherited from Object.)
Public method | UpdateItems | Updates the items.

See Also

DownloadContents Class
robotManager.Helpful.Forms Namespace


DownloadContents_OnLoaded Method

DownloadContents..::..DownloadContents_OnLoaded Method

Handles the OnLoaded event of the DownloadContents control.

Namespace: robotManager.Helpful.Forms
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public void DownloadContents_OnLoaded(
    Object sender,
    RoutedEventArgs e
)
Public Sub DownloadContents_OnLoaded ( _
    sender As Object, _
    e As RoutedEventArgs _
)
public:
void DownloadContents_OnLoaded(
    Object^ sender,
    RoutedEventArgs^ e
)

Parameters

sender
Type: Object
The source of the event.
e
Type: RoutedEventArgs
The RoutedEventArgs instance containing the event data.

See Also

DownloadContents Class
robotManager.Helpful.Forms Namespace


ShowWindow Method

DownloadContents..::..ShowWindow Method

Shows the window.

Namespace: robotManager.Helpful.Forms
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void ShowWindow(
    string category,
    string search,
    bool showDialog
)
Public Shared Sub ShowWindow ( _
    category As String, _
    search As String, _
    showDialog As Boolean _
)
public:
static void ShowWindow(
    String^ category,
    String^ search,
    bool^ showDialog
)

Parameters

category
Type: String
The category.
search
Type: String
The search.
showDialog
Type: Boolean
if set to true [show dialog].

See Also

DownloadContents Class
robotManager.Helpful.Forms Namespace


ShowWindowNewThread Method (String, String)

DownloadContents..::..ShowWindowNewThread Method (String, String)

Shows the window new thread.

Namespace: robotManager.Helpful.Forms
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void ShowWindowNewThread(
    string category,
    string search
)
Public Shared Sub ShowWindowNewThread ( _
    category As String, _
    search As String _
)
public:
static void ShowWindowNewThread(
    String^ category,
    String^ search
)

Parameters

category
Type: String
The category.
search
Type: String
The search.

See Also

DownloadContents Class
ShowWindowNewThread Overload
robotManager.Helpful.Forms Namespace


UpdateItems Method

DownloadContents..::..UpdateItems Method

Updates the items.

Namespace: robotManager.Helpful.Forms
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public void UpdateItems()
Public Sub UpdateItems
public:
void UpdateItems()

See Also

DownloadContents Class
robotManager.Helpful.Forms Namespace


DownloadContents Properties

The DownloadContents type exposes the following members.

Properties

 | Name | Description
Public property | Downloads | Gets or sets the downloads.

See Also

DownloadContents Class
robotManager.Helpful.Forms Namespace


Downloads Property

DownloadContents..::..Downloads Property

Gets or sets the downloads.

Namespace: robotManager.Helpful.Forms
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public List<DownloadEntry> Downloads { get; set; }
Public Property Downloads As List(Of DownloadEntry)
    Get
    Set
public:
property List<DownloadEntry^>^ Downloads {
    List<DownloadEntry^>^ get ();
    void set (List<DownloadEntry^>^ value);
}

Field Value

The downloads.

See Also

DownloadContents Class
robotManager.Helpful.Forms Namespace


DownloadEntry Class

Class DownloadEntry.

Namespace: robotManager.Helpful.Forms
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public class DownloadEntry
Public Class DownloadEntry
public ref class DownloadEntry

Inheritance Hierarchy

Object
robotManager.Helpful.Forms..::..DownloadEntry

See Also

DownloadEntry Members
robotManager.Helpful.Forms Namespace


DownloadEntry Members

The DownloadEntry type exposes the following members.

Constructors

 | Name | Description
Public method | DownloadEntry | Initializes a new instance of the DownloadEntry class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IsValid | Returns true if instance is valid.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToEmpty | Empty all.
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Category | Gets or sets the category.
Public property | Description | Gets or sets the description.
Public property | Downloads | Gets or sets the downloads count.
Public property | Id | Gets or sets the identifier.
Public property | Name | Gets or sets the name.
Public property | Rating | Gets or sets the rating.
Public property | Updated | Gets or sets the update date.

See Also

DownloadEntry Class
robotManager.Helpful.Forms Namespace


DownloadEntry Constructor

Initializes a new instance of the DownloadEntry class.

Namespace: robotManager.Helpful.Forms
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public DownloadEntry(
    string line
)
Public Sub New ( _
    line As String _
)
public:
DownloadEntry(
    String^ line
)

Parameters

line
Type: String
The line.

See Also

DownloadEntry Class
robotManager.Helpful.Forms Namespace


DownloadEntry Methods

The DownloadEntry type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IsValid | Returns true if instance is valid.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToEmpty | Empty all.
Public method | ToString | (Inherited from Object.)

See Also

DownloadEntry Class
robotManager.Helpful.Forms Namespace


IsValid Method

DownloadEntry..::..IsValid Method

Returns true if instance is valid.

Namespace: robotManager.Helpful.Forms
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public bool IsValid()
Public Function IsValid As Boolean
public:
bool^ IsValid()

Return Value

true if this instance is valid; otherwise, false.

See Also

DownloadEntry Class
robotManager.Helpful.Forms Namespace


ToEmpty Method

DownloadEntry..::..ToEmpty Method

Empty all.

Namespace: robotManager.Helpful.Forms
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public void ToEmpty()
Public Sub ToEmpty
public:
void ToEmpty()

See Also

DownloadEntry Class
robotManager.Helpful.Forms Namespace


DownloadEntry Properties

The DownloadEntry type exposes the following members.

Properties

 | Name | Description
Public property | Category | Gets or sets the category.
Public property | Description | Gets or sets the description.
Public property | Downloads | Gets or sets the downloads count.
Public property | Id | Gets or sets the identifier.
Public property | Name | Gets or sets the name.
Public property | Rating | Gets or sets the rating.
Public property | Updated | Gets or sets the update date.

See Also

DownloadEntry Class
robotManager.Helpful.Forms Namespace


Category Property

DownloadEntry..::..Category Property

Gets or sets the category.

Namespace: robotManager.Helpful.Forms
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public string Category { get; set; }
Public Property Category As String
    Get
    Set
public:
property String^ Category {
    String^ get ();
    void set (String^ value);
}

Field Value

The category.

See Also

DownloadEntry Class
robotManager.Helpful.Forms Namespace


Description Property

DownloadEntry..::..Description Property

Gets or sets the description.

Namespace: robotManager.Helpful.Forms
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Field Value

The description.

See Also

DownloadEntry Class
robotManager.Helpful.Forms Namespace


Downloads Property

DownloadEntry..::..Downloads Property

Gets or sets the downloads count.

Namespace: robotManager.Helpful.Forms
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public int Downloads { get; set; }
Public Property Downloads As Integer
    Get
    Set
public:
property int^ Downloads {
    int^ get ();
    void set (int^ value);
}

Field Value

The downloads count.

See Also

DownloadEntry Class
robotManager.Helpful.Forms Namespace


Id Property

DownloadEntry..::..Id Property

Gets or sets the identifier.

Namespace: robotManager.Helpful.Forms
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public int Id { get; set; }
Public Property Id As Integer
    Get
    Set
public:
property int^ Id {
    int^ get ();
    void set (int^ value);
}

Field Value

The identifier.

See Also

DownloadEntry Class
robotManager.Helpful.Forms Namespace


Name Property

DownloadEntry..::..Name Property

Gets or sets the name.

Namespace: robotManager.Helpful.Forms
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Field Value

The name.

See Also

DownloadEntry Class
robotManager.Helpful.Forms Namespace


Rating Property

DownloadEntry..::..Rating Property

Gets or sets the rating.

Namespace: robotManager.Helpful.Forms
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public string Rating { get; set; }
Public Property Rating As String
    Get
    Set
public:
property String^ Rating {
    String^ get ();
    void set (String^ value);
}

Field Value

The rating.

See Also

DownloadEntry Class
robotManager.Helpful.Forms Namespace


Updated Property

DownloadEntry..::..Updated Property

Gets or sets the update date.

Namespace: robotManager.Helpful.Forms
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public long Updated { get; set; }
Public Property Updated As Long
    Get
    Set
public:
property long long^ Updated {
    long long^ get ();
    void set (long long^ value);
}

Field Value

The updated date.

See Also

DownloadEntry Class
robotManager.Helpful.Forms Namespace


DownloadList Class

Class DownloadList.

Namespace: robotManager.Helpful.Forms
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public class DownloadList
Public Class DownloadList
public ref class DownloadList

Inheritance Hierarchy

Object
robotManager.Helpful.Forms..::..DownloadList

See Also

DownloadList Members
robotManager.Helpful.Forms Namespace


DownloadList Members

The DownloadList type exposes the following members.

Constructors

 | Name | Description
Public method | DownloadList | Initializes a new instance of the DownloadList class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Downloads | Gets or sets the downloads.

See Also

DownloadList Class
robotManager.Helpful.Forms Namespace


DownloadList Constructor

Initializes a new instance of the DownloadList class.

Namespace: robotManager.Helpful.Forms
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public DownloadList(
    string url
)
Public Sub New ( _
    url As String _
)
public:
DownloadList(
    String^ url
)

Parameters

url
Type: String
The URL.

See Also

DownloadList Class
robotManager.Helpful.Forms Namespace


DownloadList Methods

The DownloadList type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

DownloadList Class
robotManager.Helpful.Forms Namespace


DownloadList Properties

The DownloadList type exposes the following members.

Properties

 | Name | Description
Public property | Downloads | Gets or sets the downloads.

See Also

DownloadList Class
robotManager.Helpful.Forms Namespace


Downloads Property

DownloadList..::..Downloads Property

Gets or sets the downloads.

Namespace: robotManager.Helpful.Forms
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public List<DownloadEntry> Downloads { get; set; }
Public Property Downloads As List(Of DownloadEntry)
    Get
    Set
public:
property List<DownloadEntry^>^ Downloads {
    List<DownloadEntry^>^ get ();
    void set (List<DownloadEntry^>^ value);
}

Field Value

The downloads.

See Also

DownloadList Class
robotManager.Helpful.Forms Namespace


InputBoxMultiline Class

Class InputBoxMultiline. Quick way to request text to user. Implements the Form

Namespace: robotManager.Helpful.Forms
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public class InputBoxMultiline : Form
Public Class InputBoxMultiline _
    Inherits Form
public ref class InputBoxMultiline : public Form

Inheritance Hierarchy

Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
robotManager.Helpful.Forms..::..InputBoxMultiline

See Also

InputBoxMultiline Members
robotManager.Helpful.Forms Namespace
Form


InputBoxMultiline Members

The InputBoxMultiline type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Public method | Activate | (Inherited from Form.)
Protected method | ActivateMdiChild(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | AddOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from Form.)
Protected method | ApplyAutoScaling | (Inherited from Form.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Protected method | CenterToParent | (Inherited from Form.)
Protected method | CenterToScreen | (Inherited from Form.)
Public method | Close | (Inherited from Form.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Form.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Clean up any resources being used.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Public method | LayoutMdi(System.Windows.Forms.MdiLayout) | (Inherited from Form.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnActivated(System.EventArgs) | (Inherited from Form.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnClosed(System.EventArgs) | (Inherited from Form.)
Protected method | OnClosing(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from Form.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDeactivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Form.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnFormClosed(System.Windows.Forms.FormClosedEventArgs) | (Inherited from Form.)
Protected method | OnFormClosing(System.Windows.Forms.FormClosingEventArgs) | (Inherited from Form.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Form.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Form.)
Protected method | OnHelpButtonClicked(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInputLanguageChanged(System.Windows.Forms.InputLanguageChangedEventArgs) | (Inherited from Form.)
Protected method | OnInputLanguageChanging(System.Windows.Forms.InputLanguageChangingEventArgs) | (Inherited from Form.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from Form.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from Form.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMaximumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMdiChildActivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuComplete(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuStart(System.EventArgs) | (Inherited from Form.)
Protected method | OnMinimumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Form.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeBegin(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeEnd(System.EventArgs) | (Inherited from Form.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnShown(System.EventArgs) | (Inherited from Form.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from Form.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from Form.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from Form.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | RemoveOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from Form.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from Form.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopLocation(System.Int32,System.Int32) | (Inherited from Form.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Form.)
 | Show(String, String, Boolean, Boolean) | Shows the specified editable text.
 | Show(String, String, Size, Boolean, Boolean) | Shows the specified editable text.
Public method | Show(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Public method | Show | (Inherited from Control.)
Public method | ShowDialog | (Inherited from Form.)
Public method | ShowDialog(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Form.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from Form.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from Form.)

Properties

 | Name | Description
Public property | AcceptButton | (Inherited from Form.)
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | ActiveMdiChild | (Inherited from Form.)
Public property | AllowDrop | (Inherited from Control.)
Public property | AllowTransparency | (Inherited from Form.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScale | (Inherited from Form.)
Public property | AutoScaleBaseSize | (Inherited from Form.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from Form.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Form.)
Public property | AutoSizeMode | (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Public property | CancelButton | (Inherited from Form.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Form.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | ControlBox | (Inherited from Form.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Form.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DesktopBounds | (Inherited from Form.)
Public property | DesktopLocation | (Inherited from Form.)
Public property | DialogResult | (Inherited from Form.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | FormBorderStyle | (Inherited from Form.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HelpButton | (Inherited from Form.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | Icon | (Inherited from Form.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMdiChild | (Inherited from Form.)
Public property | IsMdiContainer | (Inherited from Form.)
Public property | IsMirrored | (Inherited from Control.)
Public property | IsRestrictedWindow | (Inherited from Form.)
Public property | KeyPreview | (Inherited from Form.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Form.)
Public property | MainMenuStrip | (Inherited from Form.)
Public property | Margin | (Inherited from Form.)
Public property | MaximizeBox | (Inherited from Form.)
Protected property | MaximizedBounds | (Inherited from Form.)
Public property | MaximumSize | (Inherited from Form.)
Public property | MdiChildren | (Inherited from Form.)
Public property | MdiParent | (Inherited from Form.)
Public property | Menu | (Inherited from Form.)
Public property | MergedMenu | (Inherited from Form.)
Public property | MinimizeBox | (Inherited from Form.)
Public property | MinimumSize | (Inherited from Form.)
Public property | Modal | (Inherited from Form.)
Public property | Name | (Inherited from Control.)
Public property | Opacity | (Inherited from Form.)
Public property | OwnedForms | (Inherited from Form.)
Public property | Owner | (Inherited from Form.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | RestoreBounds | (Inherited from Form.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Public property | RightToLeftLayout | (Inherited from Form.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | ShowIcon | (Inherited from Form.)
Public property | ShowInTaskbar | (Inherited from Form.)
Protected property | ShowWithoutActivation | (Inherited from Form.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Form.)
Public property | SizeGripStyle | (Inherited from Form.)
Public property | StartPosition | (Inherited from Form.)
Public property | TabIndex | (Inherited from Form.)
Public property | TabStop | (Inherited from Form.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | (Inherited from Control.)
Public property | TopLevel | (Inherited from Form.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | TopMost | (Inherited from Form.)
Public property | TransparencyKey | (Inherited from Form.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowState | (Inherited from Form.)
Public property | WindowTarget | (Inherited from Control.)

Events

 | Name | Description
Public event | Activated | (Inherited from Form.)
Public event | AutoSizeChanged | (Inherited from Form.)
Public event | AutoValidateChanged | (Inherited from Form.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | Closed | (Inherited from Form.)
Public event | Closing | (Inherited from Form.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Deactivate | (Inherited from Form.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | FormClosed | (Inherited from Form.)
Public event | FormClosing | (Inherited from Form.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpButtonClicked | (Inherited from Form.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | InputLanguageChanged | (Inherited from Form.)
Public event | InputLanguageChanging | (Inherited from Form.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from Form.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Form.)
Public event | MaximizedBoundsChanged | (Inherited from Form.)
Public event | MaximumSizeChanged | (Inherited from Form.)
Public event | MdiChildActivate | (Inherited from Form.)
Public event | MenuComplete | (Inherited from Form.)
Public event | MenuStart | (Inherited from Form.)
Public event | MinimumSizeChanged | (Inherited from Form.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | ResizeBegin | (Inherited from Form.)
Public event | ResizeEnd | (Inherited from Form.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | RightToLeftLayoutChanged | (Inherited from Form.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | Shown | (Inherited from Form.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Form.)
Public event | TabStopChanged | (Inherited from Form.)
Public event | TextChanged | (Inherited from Control.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

InputBoxMultiline Class
robotManager.Helpful.Forms Namespace


InputBoxMultiline Methods

The InputBoxMultiline type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Public method | Activate | (Inherited from Form.)
Protected method | ActivateMdiChild(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | AddOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from Form.)
Protected method | ApplyAutoScaling | (Inherited from Form.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Protected method | CenterToParent | (Inherited from Form.)
Protected method | CenterToScreen | (Inherited from Form.)
Public method | Close | (Inherited from Form.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Form.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Clean up any resources being used.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Public method | LayoutMdi(System.Windows.Forms.MdiLayout) | (Inherited from Form.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnActivated(System.EventArgs) | (Inherited from Form.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnClosed(System.EventArgs) | (Inherited from Form.)
Protected method | OnClosing(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from Form.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDeactivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Form.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnFormClosed(System.Windows.Forms.FormClosedEventArgs) | (Inherited from Form.)
Protected method | OnFormClosing(System.Windows.Forms.FormClosingEventArgs) | (Inherited from Form.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Form.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Form.)
Protected method | OnHelpButtonClicked(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInputLanguageChanged(System.Windows.Forms.InputLanguageChangedEventArgs) | (Inherited from Form.)
Protected method | OnInputLanguageChanging(System.Windows.Forms.InputLanguageChangingEventArgs) | (Inherited from Form.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from Form.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from Form.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMaximumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMdiChildActivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuComplete(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuStart(System.EventArgs) | (Inherited from Form.)
Protected method | OnMinimumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Form.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeBegin(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeEnd(System.EventArgs) | (Inherited from Form.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnShown(System.EventArgs) | (Inherited from Form.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from Form.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from Form.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from Form.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | RemoveOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from Form.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from Form.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopLocation(System.Int32,System.Int32) | (Inherited from Form.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Form.)
 | Show(String, String, Boolean, Boolean) | Shows the specified editable text.
 | Show(String, String, Size, Boolean, Boolean) | Shows the specified editable text.
Public method | Show(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Public method | Show | (Inherited from Control.)
Public method | ShowDialog | (Inherited from Form.)
Public method | ShowDialog(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Form.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from Form.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from Form.)

See Also

InputBoxMultiline Class
robotManager.Helpful.Forms Namespace


Dispose Method

InputBoxMultiline..::..Dispose Method

Overload List

 | Name | Description
Protected method | Dispose(Boolean) | Clean up any resources being used.
Public method | Dispose | (Inherited from Component.)

See Also

InputBoxMultiline Class
InputBoxMultiline Members
robotManager.Helpful.Forms Namespace


Dispose Method

InputBoxMultiline..::..Dispose Method

Clean up any resources being used.

Namespace: robotManager.Helpful.Forms
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
protected void Dispose(
    bool disposing
)
Protected Sub Dispose ( _
    disposing As Boolean _
)
protected:
void Dispose(
    bool^ disposing
)

Parameters

disposing
Type: Boolean
true if managed resources should be disposed; otherwise, false.

See Also

InputBoxMultiline Class
robotManager.Helpful.Forms Namespace


Show Method

InputBoxMultiline..::..Show Method

Overload List

 | Name | Description
 | Show(String, String, Boolean, Boolean) | Shows the specified editable text.
 | Show(String, String, Size, Boolean, Boolean) | Shows the specified editable text.
Public method | Show(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Public method | Show | (Inherited from Control.)

See Also

InputBoxMultiline Class
InputBoxMultiline Members
robotManager.Helpful.Forms Namespace


Show Method (String, String, Boolean, Boolean)

InputBoxMultiline..::..Show Method (String, String, Boolean, Boolean)

Shows the specified editable text.

Namespace: robotManager.Helpful.Forms
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static string Show(
    string text,
    string windowName,
    bool resizable,
    bool showInTaskbar
)
Public Shared Function Show ( _
    text As String, _
    windowName As String, _
    resizable As Boolean, _
    showInTaskbar As Boolean _
) As String
public:
static String^ Show(
    String^ text,
    String^ windowName,
    bool^ resizable,
    bool^ showInTaskbar
)

Parameters

text
Type: String
The text.
windowName
Type: String
Name of the window.
resizable
Type: Boolean
if set to true [resizable].
showInTaskbar
Type: Boolean
if set to true [show in taskbar].

Return Value

Text edited by the user.

See Also

InputBoxMultiline Class
Show Overload
robotManager.Helpful.Forms Namespace


Show Method (String, String, Size, Boolean, Boolean)

InputBoxMultiline..::..Show Method (String, String, Size, Boolean, Boolean)

Shows the specified editable text.

Namespace: robotManager.Helpful.Forms
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static string Show(
    string text,
    string windowName,
    Size size,
    bool resizable,
    bool showInTaskbar
)
Public Shared Function Show ( _
    text As String, _
    windowName As String, _
    size As Size, _
    resizable As Boolean, _
    showInTaskbar As Boolean _
) As String
public:
static String^ Show(
    String^ text,
    String^ windowName,
    Size^ size,
    bool^ resizable,
    bool^ showInTaskbar
)

Parameters

text
Type: String
The text.
windowName
Type: String
Name of the window.
size
Type: Size
The size.
resizable
Type: Boolean
if set to true [resizable].
showInTaskbar
Type: Boolean
if set to true [show in taskbar].

Return Value

Text edited by the user.

See Also

InputBoxMultiline Class
Show Overload
robotManager.Helpful.Forms Namespace


InputBoxMultiline Properties

The InputBoxMultiline type exposes the following members.

Properties

 | Name | Description
Public property | AcceptButton | (Inherited from Form.)
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | ActiveMdiChild | (Inherited from Form.)
Public property | AllowDrop | (Inherited from Control.)
Public property | AllowTransparency | (Inherited from Form.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScale | (Inherited from Form.)
Public property | AutoScaleBaseSize | (Inherited from Form.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from Form.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Form.)
Public property | AutoSizeMode | (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Public property | CancelButton | (Inherited from Form.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Form.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | ControlBox | (Inherited from Form.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Form.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DesktopBounds | (Inherited from Form.)
Public property | DesktopLocation | (Inherited from Form.)
Public property | DialogResult | (Inherited from Form.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | FormBorderStyle | (Inherited from Form.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HelpButton | (Inherited from Form.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | Icon | (Inherited from Form.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMdiChild | (Inherited from Form.)
Public property | IsMdiContainer | (Inherited from Form.)
Public property | IsMirrored | (Inherited from Control.)
Public property | IsRestrictedWindow | (Inherited from Form.)
Public property | KeyPreview | (Inherited from Form.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Form.)
Public property | MainMenuStrip | (Inherited from Form.)
Public property | Margin | (Inherited from Form.)
Public property | MaximizeBox | (Inherited from Form.)
Protected property | MaximizedBounds | (Inherited from Form.)
Public property | MaximumSize | (Inherited from Form.)
Public property | MdiChildren | (Inherited from Form.)
Public property | MdiParent | (Inherited from Form.)
Public property | Menu | (Inherited from Form.)
Public property | MergedMenu | (Inherited from Form.)
Public property | MinimizeBox | (Inherited from Form.)
Public property | MinimumSize | (Inherited from Form.)
Public property | Modal | (Inherited from Form.)
Public property | Name | (Inherited from Control.)
Public property | Opacity | (Inherited from Form.)
Public property | OwnedForms | (Inherited from Form.)
Public property | Owner | (Inherited from Form.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | RestoreBounds | (Inherited from Form.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Public property | RightToLeftLayout | (Inherited from Form.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | ShowIcon | (Inherited from Form.)
Public property | ShowInTaskbar | (Inherited from Form.)
Protected property | ShowWithoutActivation | (Inherited from Form.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Form.)
Public property | SizeGripStyle | (Inherited from Form.)
Public property | StartPosition | (Inherited from Form.)
Public property | TabIndex | (Inherited from Form.)
Public property | TabStop | (Inherited from Form.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | (Inherited from Control.)
Public property | TopLevel | (Inherited from Form.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | TopMost | (Inherited from Form.)
Public property | TransparencyKey | (Inherited from Form.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowState | (Inherited from Form.)
Public property | WindowTarget | (Inherited from Control.)

See Also

InputBoxMultiline Class
robotManager.Helpful.Forms Namespace


InputBoxMultiline Events

The InputBoxMultiline type exposes the following members.

Events

 | Name | Description
Public event | Activated | (Inherited from Form.)
Public event | AutoSizeChanged | (Inherited from Form.)
Public event | AutoValidateChanged | (Inherited from Form.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | Closed | (Inherited from Form.)
Public event | Closing | (Inherited from Form.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Deactivate | (Inherited from Form.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | FormClosed | (Inherited from Form.)
Public event | FormClosing | (Inherited from Form.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpButtonClicked | (Inherited from Form.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | InputLanguageChanged | (Inherited from Form.)
Public event | InputLanguageChanging | (Inherited from Form.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from Form.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Form.)
Public event | MaximizedBoundsChanged | (Inherited from Form.)
Public event | MaximumSizeChanged | (Inherited from Form.)
Public event | MdiChildActivate | (Inherited from Form.)
Public event | MenuComplete | (Inherited from Form.)
Public event | MenuStart | (Inherited from Form.)
Public event | MinimumSizeChanged | (Inherited from Form.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | ResizeBegin | (Inherited from Form.)
Public event | ResizeEnd | (Inherited from Form.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | RightToLeftLayoutChanged | (Inherited from Form.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | Shown | (Inherited from Form.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Form.)
Public event | TabStopChanged | (Inherited from Form.)
Public event | TextChanged | (Inherited from Control.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

InputBoxMultiline Class
robotManager.Helpful.Forms Namespace


PopUpPropertyGrid Class

Class PopUpPropertyGrid. Useful to create quickly settings window, this form use PropertyGrid Implements the Form

Namespace: robotManager.Helpful.Forms
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public class PopUpPropertyGrid : Form
Public Class PopUpPropertyGrid _
    Inherits Form
public ref class PopUpPropertyGrid : public Form

Inheritance Hierarchy

Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
robotManager.Helpful.Forms..::..PopUpPropertyGrid

See Also

PopUpPropertyGrid Members
robotManager.Helpful.Forms Namespace
Form


PopUpPropertyGrid Members

The PopUpPropertyGrid type exposes the following members.

Constructors

 | Name | Description
Public method | PopUpPropertyGrid(Object, String, Boolean, Boolean) | Initializes a new instance of the PopUpPropertyGrid class.
Public method | PopUpPropertyGrid(Object, String, Size, Boolean, Boolean) | Initializes a new instance of the PopUpPropertyGrid class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Public method | Activate | (Inherited from Form.)
Protected method | ActivateMdiChild(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | AddOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from Form.)
Protected method | ApplyAutoScaling | (Inherited from Form.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Protected method | CenterToParent | (Inherited from Form.)
Protected method | CenterToScreen | (Inherited from Form.)
Public method | Close | (Inherited from Form.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Form.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Clean up any resources being used.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Public method | LayoutMdi(System.Windows.Forms.MdiLayout) | (Inherited from Form.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnActivated(System.EventArgs) | (Inherited from Form.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnClosed(System.EventArgs) | (Inherited from Form.)
Protected method | OnClosing(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from Form.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDeactivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Form.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnFormClosed(System.Windows.Forms.FormClosedEventArgs) | (Inherited from Form.)
Protected method | OnFormClosing(System.Windows.Forms.FormClosingEventArgs) | (Inherited from Form.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Form.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Form.)
Protected method | OnHelpButtonClicked(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInputLanguageChanged(System.Windows.Forms.InputLanguageChangedEventArgs) | (Inherited from Form.)
Protected method | OnInputLanguageChanging(System.Windows.Forms.InputLanguageChangingEventArgs) | (Inherited from Form.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from Form.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from Form.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMaximumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMdiChildActivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuComplete(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuStart(System.EventArgs) | (Inherited from Form.)
Protected method | OnMinimumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Form.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeBegin(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeEnd(System.EventArgs) | (Inherited from Form.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnShown(System.EventArgs) | (Inherited from Form.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from Form.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from Form.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from Form.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | RemoveOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from Form.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from Form.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopLocation(System.Int32,System.Int32) | (Inherited from Form.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Form.)
Public method | Show(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Public method | Show | (Inherited from Control.)
Public method | ShowDialog | (Inherited from Form.)
Public method | ShowDialog(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Form.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from Form.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from Form.)

Properties

 | Name | Description
Public property | AcceptButton | (Inherited from Form.)
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | ActiveMdiChild | (Inherited from Form.)
Public property | AllowDrop | (Inherited from Control.)
Public property | AllowTransparency | (Inherited from Form.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScale | (Inherited from Form.)
Public property | AutoScaleBaseSize | (Inherited from Form.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from Form.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Form.)
Public property | AutoSizeMode | (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Public property | CancelButton | (Inherited from Form.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Form.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | ControlBox | (Inherited from Form.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Form.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DesktopBounds | (Inherited from Form.)
Public property | DesktopLocation | (Inherited from Form.)
Public property | DialogResult | (Inherited from Form.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | FormBorderStyle | (Inherited from Form.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HelpButton | (Inherited from Form.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | Icon | (Inherited from Form.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMdiChild | (Inherited from Form.)
Public property | IsMdiContainer | (Inherited from Form.)
Public property | IsMirrored | (Inherited from Control.)
Public property | IsRestrictedWindow | (Inherited from Form.)
Public property | KeyPreview | (Inherited from Form.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Form.)
Public property | MainMenuStrip | (Inherited from Form.)
Public property | Margin | (Inherited from Form.)
Public property | MaximizeBox | (Inherited from Form.)
Protected property | MaximizedBounds | (Inherited from Form.)
Public property | MaximumSize | (Inherited from Form.)
Public property | MdiChildren | (Inherited from Form.)
Public property | MdiParent | (Inherited from Form.)
Public property | Menu | (Inherited from Form.)
Public property | MergedMenu | (Inherited from Form.)
Public property | MinimizeBox | (Inherited from Form.)
Public property | MinimumSize | (Inherited from Form.)
Public property | Modal | (Inherited from Form.)
Public property | Name | (Inherited from Control.)
Public property | Opacity | (Inherited from Form.)
Public property | OwnedForms | (Inherited from Form.)
Public property | Owner | (Inherited from Form.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | RestoreBounds | (Inherited from Form.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Public property | RightToLeftLayout | (Inherited from Form.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | ShowIcon | (Inherited from Form.)
Public property | ShowInTaskbar | (Inherited from Form.)
Protected property | ShowWithoutActivation | (Inherited from Form.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Form.)
Public property | SizeGripStyle | (Inherited from Form.)
Public property | StartPosition | (Inherited from Form.)
Public property | TabIndex | (Inherited from Form.)
Public property | TabStop | (Inherited from Form.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | (Inherited from Control.)
Public property | TopLevel | (Inherited from Form.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | TopMost | (Inherited from Form.)
Public property | TransparencyKey | (Inherited from Form.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowState | (Inherited from Form.)
Public property | WindowTarget | (Inherited from Control.)

Events

 | Name | Description
Public event | Activated | (Inherited from Form.)
Public event | AutoSizeChanged | (Inherited from Form.)
Public event | AutoValidateChanged | (Inherited from Form.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | Closed | (Inherited from Form.)
Public event | Closing | (Inherited from Form.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Deactivate | (Inherited from Form.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | FormClosed | (Inherited from Form.)
Public event | FormClosing | (Inherited from Form.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpButtonClicked | (Inherited from Form.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | InputLanguageChanged | (Inherited from Form.)
Public event | InputLanguageChanging | (Inherited from Form.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from Form.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Form.)
Public event | MaximizedBoundsChanged | (Inherited from Form.)
Public event | MaximumSizeChanged | (Inherited from Form.)
Public event | MdiChildActivate | (Inherited from Form.)
Public event | MenuComplete | (Inherited from Form.)
Public event | MenuStart | (Inherited from Form.)
Public event | MinimumSizeChanged | (Inherited from Form.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | ResizeBegin | (Inherited from Form.)
Public event | ResizeEnd | (Inherited from Form.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | RightToLeftLayoutChanged | (Inherited from Form.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | Shown | (Inherited from Form.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Form.)
Public event | TabStopChanged | (Inherited from Form.)
Public event | TextChanged | (Inherited from Control.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

PopUpPropertyGrid Class
robotManager.Helpful.Forms Namespace


PopUpPropertyGrid Constructor

Overload List

 | Name | Description
Public method | PopUpPropertyGrid(Object, String, Boolean, Boolean) | Initializes a new instance of the PopUpPropertyGrid class.
Public method | PopUpPropertyGrid(Object, String, Size, Boolean, Boolean) | Initializes a new instance of the PopUpPropertyGrid class.

See Also

PopUpPropertyGrid Class
PopUpPropertyGrid Members
robotManager.Helpful.Forms Namespace


PopUpPropertyGrid Constructor (Object, String, Boolean, Boolean)

Initializes a new instance of the PopUpPropertyGrid class.

Namespace: robotManager.Helpful.Forms
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public PopUpPropertyGrid(
    Object settings,
    string windowName,
    bool resizable,
    bool showInTaskbar
)
Public Sub New ( _
    settings As Object, _
    windowName As String, _
    resizable As Boolean, _
    showInTaskbar As Boolean _
)
public:
PopUpPropertyGrid(
    Object^ settings,
    String^ windowName,
    bool^ resizable,
    bool^ showInTaskbar
)

Parameters

settings
Type: Object
The settings (options must be http://csharphelper.com/blog/2014/09/use-propertygrid-descriptions-and-categories-in-c/ ).
windowName
Type: String
Name of the window.
resizable
Type: Boolean
if set to true if resizable.
showInTaskbar
Type: Boolean
if set to true if show in taskbar.

See Also

PopUpPropertyGrid Class
PopUpPropertyGrid Overload
robotManager.Helpful.Forms Namespace


PopUpPropertyGrid Constructor (Object, String, Size, Boolean, Boolean)

Initializes a new instance of the PopUpPropertyGrid class.

Namespace: robotManager.Helpful.Forms
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public PopUpPropertyGrid(
    Object settings,
    string windowName,
    Size size,
    bool resizable,
    bool showInTaskbar
)
Public Sub New ( _
    settings As Object, _
    windowName As String, _
    size As Size, _
    resizable As Boolean, _
    showInTaskbar As Boolean _
)
public:
PopUpPropertyGrid(
    Object^ settings,
    String^ windowName,
    Size^ size,
    bool^ resizable,
    bool^ showInTaskbar
)

Parameters

settings
Type: Object
The settings (options must be http://csharphelper.com/blog/2014/09/use-propertygrid-descriptions-and-categories-in-c/ ).
windowName
Type: String
Name of the window.
size
Type: Size
The size.
resizable
Type: Boolean
if set to true if resizable.
showInTaskbar
Type: Boolean
if set to true if show in taskbar.

See Also

PopUpPropertyGrid Class
PopUpPropertyGrid Overload
robotManager.Helpful.Forms Namespace


PopUpPropertyGrid Methods

The PopUpPropertyGrid type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Public method | Activate | (Inherited from Form.)
Protected method | ActivateMdiChild(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | AddOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from Form.)
Protected method | ApplyAutoScaling | (Inherited from Form.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Protected method | CenterToParent | (Inherited from Form.)
Protected method | CenterToScreen | (Inherited from Form.)
Public method | Close | (Inherited from Form.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Form.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Clean up any resources being used.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Public method | LayoutMdi(System.Windows.Forms.MdiLayout) | (Inherited from Form.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnActivated(System.EventArgs) | (Inherited from Form.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnClosed(System.EventArgs) | (Inherited from Form.)
Protected method | OnClosing(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from Form.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDeactivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Form.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnFormClosed(System.Windows.Forms.FormClosedEventArgs) | (Inherited from Form.)
Protected method | OnFormClosing(System.Windows.Forms.FormClosingEventArgs) | (Inherited from Form.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Form.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Form.)
Protected method | OnHelpButtonClicked(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInputLanguageChanged(System.Windows.Forms.InputLanguageChangedEventArgs) | (Inherited from Form.)
Protected method | OnInputLanguageChanging(System.Windows.Forms.InputLanguageChangingEventArgs) | (Inherited from Form.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from Form.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from Form.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMaximumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMdiChildActivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuComplete(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuStart(System.EventArgs) | (Inherited from Form.)
Protected method | OnMinimumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Form.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeBegin(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeEnd(System.EventArgs) | (Inherited from Form.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnShown(System.EventArgs) | (Inherited from Form.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from Form.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from Form.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from Form.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | RemoveOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from Form.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from Form.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopLocation(System.Int32,System.Int32) | (Inherited from Form.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Form.)
Public method | Show(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Public method | Show | (Inherited from Control.)
Public method | ShowDialog | (Inherited from Form.)
Public method | ShowDialog(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Form.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from Form.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from Form.)

See Also

PopUpPropertyGrid Class
robotManager.Helpful.Forms Namespace


Dispose Method

PopUpPropertyGrid..::..Dispose Method

Overload List

 | Name | Description
Protected method | Dispose(Boolean) | Clean up any resources being used.
Public method | Dispose | (Inherited from Component.)

See Also

PopUpPropertyGrid Class
PopUpPropertyGrid Members
robotManager.Helpful.Forms Namespace


Dispose Method

PopUpPropertyGrid..::..Dispose Method

Clean up any resources being used.

Namespace: robotManager.Helpful.Forms
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
protected void Dispose(
    bool disposing
)
Protected Sub Dispose ( _
    disposing As Boolean _
)
protected:
void Dispose(
    bool^ disposing
)

Parameters

disposing
Type: Boolean
true if managed resources should be disposed; otherwise, false.

See Also

PopUpPropertyGrid Class
robotManager.Helpful.Forms Namespace


PopUpPropertyGrid Properties

The PopUpPropertyGrid type exposes the following members.

Properties

 | Name | Description
Public property | AcceptButton | (Inherited from Form.)
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | ActiveMdiChild | (Inherited from Form.)
Public property | AllowDrop | (Inherited from Control.)
Public property | AllowTransparency | (Inherited from Form.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScale | (Inherited from Form.)
Public property | AutoScaleBaseSize | (Inherited from Form.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from Form.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Form.)
Public property | AutoSizeMode | (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Public property | CancelButton | (Inherited from Form.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Form.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | ControlBox | (Inherited from Form.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Form.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DesktopBounds | (Inherited from Form.)
Public property | DesktopLocation | (Inherited from Form.)
Public property | DialogResult | (Inherited from Form.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | FormBorderStyle | (Inherited from Form.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HelpButton | (Inherited from Form.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | Icon | (Inherited from Form.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMdiChild | (Inherited from Form.)
Public property | IsMdiContainer | (Inherited from Form.)
Public property | IsMirrored | (Inherited from Control.)
Public property | IsRestrictedWindow | (Inherited from Form.)
Public property | KeyPreview | (Inherited from Form.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Form.)
Public property | MainMenuStrip | (Inherited from Form.)
Public property | Margin | (Inherited from Form.)
Public property | MaximizeBox | (Inherited from Form.)
Protected property | MaximizedBounds | (Inherited from Form.)
Public property | MaximumSize | (Inherited from Form.)
Public property | MdiChildren | (Inherited from Form.)
Public property | MdiParent | (Inherited from Form.)
Public property | Menu | (Inherited from Form.)
Public property | MergedMenu | (Inherited from Form.)
Public property | MinimizeBox | (Inherited from Form.)
Public property | MinimumSize | (Inherited from Form.)
Public property | Modal | (Inherited from Form.)
Public property | Name | (Inherited from Control.)
Public property | Opacity | (Inherited from Form.)
Public property | OwnedForms | (Inherited from Form.)
Public property | Owner | (Inherited from Form.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | RestoreBounds | (Inherited from Form.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Public property | RightToLeftLayout | (Inherited from Form.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | ShowIcon | (Inherited from Form.)
Public property | ShowInTaskbar | (Inherited from Form.)
Protected property | ShowWithoutActivation | (Inherited from Form.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Form.)
Public property | SizeGripStyle | (Inherited from Form.)
Public property | StartPosition | (Inherited from Form.)
Public property | TabIndex | (Inherited from Form.)
Public property | TabStop | (Inherited from Form.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | (Inherited from Control.)
Public property | TopLevel | (Inherited from Form.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | TopMost | (Inherited from Form.)
Public property | TransparencyKey | (Inherited from Form.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowState | (Inherited from Form.)
Public property | WindowTarget | (Inherited from Control.)

See Also

PopUpPropertyGrid Class
robotManager.Helpful.Forms Namespace


PopUpPropertyGrid Events

The PopUpPropertyGrid type exposes the following members.

Events

 | Name | Description
Public event | Activated | (Inherited from Form.)
Public event | AutoSizeChanged | (Inherited from Form.)
Public event | AutoValidateChanged | (Inherited from Form.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | Closed | (Inherited from Form.)
Public event | Closing | (Inherited from Form.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Deactivate | (Inherited from Form.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | FormClosed | (Inherited from Form.)
Public event | FormClosing | (Inherited from Form.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpButtonClicked | (Inherited from Form.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | InputLanguageChanged | (Inherited from Form.)
Public event | InputLanguageChanging | (Inherited from Form.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from Form.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Form.)
Public event | MaximizedBoundsChanged | (Inherited from Form.)
Public event | MaximumSizeChanged | (Inherited from Form.)
Public event | MdiChildActivate | (Inherited from Form.)
Public event | MenuComplete | (Inherited from Form.)
Public event | MenuStart | (Inherited from Form.)
Public event | MinimumSizeChanged | (Inherited from Form.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | ResizeBegin | (Inherited from Form.)
Public event | ResizeEnd | (Inherited from Form.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | RightToLeftLayoutChanged | (Inherited from Form.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | Shown | (Inherited from Form.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Form.)
Public event | TabStopChanged | (Inherited from Form.)
Public event | TextChanged | (Inherited from Control.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

PopUpPropertyGrid Class
robotManager.Helpful.Forms Namespace


TranslateToolsWindow Class

TranslateToolsWindow is UI to create LanguageExport for Translate.

Namespace: robotManager.Helpful.Forms
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public class TranslateToolsWindow
Public Class TranslateToolsWindow
public ref class TranslateToolsWindow

Inheritance Hierarchy

Object
robotManager.Helpful.Forms..::..TranslateToolsWindow

See Also

TranslateToolsWindow Members
robotManager.Helpful.Forms Namespace


TranslateToolsWindow Members

The TranslateToolsWindow type exposes the following members.

Constructors

 | Name | Description
Public method | TranslateToolsWindow | Initializes a new instance of the TranslateToolsWindow class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

TranslateToolsWindow Class
robotManager.Helpful.Forms Namespace


TranslateToolsWindow Constructor

Initializes a new instance of the TranslateToolsWindow class.

Namespace: robotManager.Helpful.Forms
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public TranslateToolsWindow()
Public Sub New
public:
TranslateToolsWindow()

See Also

TranslateToolsWindow Class
robotManager.Helpful.Forms Namespace


TranslateToolsWindow Methods

The TranslateToolsWindow type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

TranslateToolsWindow Class
robotManager.Helpful.Forms Namespace


robotManager.Helpful.Forms.UserControls Namespace

Classes

 | Class | Description
Public class | LoggingUserControl | LoggingUserControl (the wpf usercontrol used tab "Log")


LoggingUserControl Class

LoggingUserControl (the wpf usercontrol used tab "Log")

Namespace: robotManager.Helpful.Forms.UserControls
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public class LoggingUserControl
Public Class LoggingUserControl
public ref class LoggingUserControl

Inheritance Hierarchy

Object
robotManager.Helpful.Forms.UserControls..::..LoggingUserControl

See Also

LoggingUserControl Members
robotManager.Helpful.Forms.UserControls Namespace


LoggingUserControl Members

The LoggingUserControl type exposes the following members.

Constructors

 | Name | Description
Public method | LoggingUserControl | Initializes a new instance of the LoggingUserControl class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IsBlackStyle | Determines whether is dark WPF style.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Fields

Name | Description
AddedLogsByFrame | Maximum number of logs to add by frame
CanSendLog | Can send errors log (this option is no longer used)
MaxLogsInTextbox | The maximum logs count in textbox
SendLogIgnoredLogs | List of errors log to don't send to server (CanSendLog).
SendLogProductName | CanSendLog selected product name info

See Also

LoggingUserControl Class
robotManager.Helpful.Forms.UserControls Namespace


LoggingUserControl Constructor

Initializes a new instance of the LoggingUserControl class.

Namespace: robotManager.Helpful.Forms.UserControls
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public LoggingUserControl()
Public Sub New
public:
LoggingUserControl()

See Also

LoggingUserControl Class
robotManager.Helpful.Forms.UserControls Namespace


LoggingUserControl Fields

The LoggingUserControl type exposes the following members.

Fields

Name | Description
AddedLogsByFrame | Maximum number of logs to add by frame
CanSendLog | Can send errors log (this option is no longer used)
MaxLogsInTextbox | The maximum logs count in textbox
SendLogIgnoredLogs | List of errors log to don't send to server (CanSendLog).
SendLogProductName | CanSendLog selected product name info

See Also

LoggingUserControl Class
robotManager.Helpful.Forms.UserControls Namespace


AddedLogsByFrame Field

LoggingUserControl..::..AddedLogsByFrame Field

Maximum number of logs to add by frame

Namespace: robotManager.Helpful.Forms.UserControls
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static int AddedLogsByFrame
Public Shared AddedLogsByFrame As Integer
public:
static int^ AddedLogsByFrame

See Also

LoggingUserControl Class
robotManager.Helpful.Forms.UserControls Namespace


CanSendLog Field

LoggingUserControl..::..CanSendLog Field

Can send errors log (this option is no longer used)

Namespace: robotManager.Helpful.Forms.UserControls
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static bool CanSendLog
Public Shared CanSendLog As Boolean
public:
static bool^ CanSendLog

See Also

LoggingUserControl Class
robotManager.Helpful.Forms.UserControls Namespace


MaxLogsInTextbox Field

LoggingUserControl..::..MaxLogsInTextbox Field

The maximum logs count in textbox

Namespace: robotManager.Helpful.Forms.UserControls
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static int MaxLogsInTextbox
Public Shared MaxLogsInTextbox As Integer
public:
static int^ MaxLogsInTextbox

See Also

LoggingUserControl Class
robotManager.Helpful.Forms.UserControls Namespace


SendLogIgnoredLogs Field

LoggingUserControl..::..SendLogIgnoredLogs Field

List of errors log to don't send to server (CanSendLog).

Namespace: robotManager.Helpful.Forms.UserControls
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static List<string> SendLogIgnoredLogs
Public Shared SendLogIgnoredLogs As List(Of String)
public:
static List<String^>^ SendLogIgnoredLogs

See Also

LoggingUserControl Class
robotManager.Helpful.Forms.UserControls Namespace


SendLogProductName Field

LoggingUserControl..::..SendLogProductName Field

CanSendLog selected product name info

Namespace: robotManager.Helpful.Forms.UserControls
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static string SendLogProductName
Public Shared SendLogProductName As String
public:
static String^ SendLogProductName

See Also

LoggingUserControl Class
robotManager.Helpful.Forms.UserControls Namespace


LoggingUserControl Methods

The LoggingUserControl type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IsBlackStyle | Determines whether is dark WPF style.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

LoggingUserControl Class
robotManager.Helpful.Forms.UserControls Namespace


IsBlackStyle Method

LoggingUserControl..::..IsBlackStyle Method

Determines whether is dark WPF style.

Namespace: robotManager.Helpful.Forms.UserControls
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public void IsBlackStyle()
Public Sub IsBlackStyle
public:
void IsBlackStyle()

See Also

LoggingUserControl Class
robotManager.Helpful.Forms.UserControls Namespace


robotManager.Helpful.Win32 Namespace

Structures

 | Structure | Description
Public structure | Native..::..PROCESS_INFORMATION |
Public structure | Native..::..RECT |
Public structure | Native..::..STARTUPINFO |

Delegates

 | Delegate | Description
Public delegate | Native..::..ConsoleEventHandlerDelegate |

Enumerations

 | Enumeration | Description
Public enumeration | Native..::..ChangeWindowMessageFilterFlags |
Public enumeration | Native..::..CompositionAction |
Public enumeration | Native..::..ConsoleHandlerEventCode |
Public enumeration | Native..::..DisplayAffinity |
Public enumeration | Native..::..ProcessCreationFlags |
Public enumeration | Native..::..ThreadAccess |
Public enumeration | UnreservedVK | UnreservedVK
Public enumeration | VK | VK


Native.ChangeWindowMessageFilterFlags Enumeration

Native..::..ChangeWindowMessageFilterFlags Enumeration

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public enum ChangeWindowMessageFilterFlags
Public Enumeration ChangeWindowMessageFilterFlags
public enum class ChangeWindowMessageFilterFlags

Members

Member name | Description
Add |
Remove |

See Also

robotManager.Helpful.Win32 Namespace


Native.CompositionAction Enumeration

Native..::..CompositionAction Enumeration

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[FlagsAttribute]
public enum CompositionAction
<FlagsAttribute> _
Public Enumeration CompositionAction
[FlagsAttribute]
public enum class CompositionAction

Members

Member name | Description
DWM_EC_DISABLECOMPOSITION | To enable DWM composition
DWM_EC_ENABLECOMPOSITION | To disable composition.

See Also

robotManager.Helpful.Win32 Namespace


Native.ConsoleEventHandlerDelegate Delegate

Native..::..ConsoleEventHandlerDelegate Delegate

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public delegate bool ConsoleEventHandlerDelegate(
    Native..::..ConsoleHandlerEventCode eventCode
)
Public Delegate Function ConsoleEventHandlerDelegate ( _
    eventCode As Native..::..ConsoleHandlerEventCode _
) As Boolean
public delegate bool^ ConsoleEventHandlerDelegate(
    Native..::..ConsoleHandlerEventCode^ eventCode
)

Parameters

eventCode
Type: robotManager.Helpful.Win32..::..Native..::..ConsoleHandlerEventCode

See Also

robotManager.Helpful.Win32 Namespace


Native.ConsoleHandlerEventCode Enumeration

Native..::..ConsoleHandlerEventCode Enumeration

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public enum ConsoleHandlerEventCode
Public Enumeration ConsoleHandlerEventCode
public enum class ConsoleHandlerEventCode

Members

Member name | Description
CTRL_C_EVENT |
CTRL_BREAK_EVENT |
CTRL_CLOSE_EVENT |
CTRL_LOGOFF_EVENT |
CTRL_SHUTDOWN_EVENT |

See Also

robotManager.Helpful.Win32 Namespace


Native.DisplayAffinity Enumeration

Native..::..DisplayAffinity Enumeration

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public enum DisplayAffinity
Public Enumeration DisplayAffinity
public enum class DisplayAffinity

Members

Member name | Description
None |
Monitor |

See Also

robotManager.Helpful.Win32 Namespace


Native.PROCESS_INFORMATION Structure

Native..::..PROCESS_INFORMATION Structure

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public struct PROCESS_INFORMATION
Public Structure PROCESS_INFORMATION
public value class PROCESS_INFORMATION

See Also

Native..::..PROCESS_INFORMATION Members
robotManager.Helpful.Win32 Namespace


Native.PROCESS_INFORMATION Members

Native..::..PROCESS_INFORMATION Members

The Native..::..PROCESS_INFORMATION type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from ValueType.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from ValueType.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from ValueType.)

Fields

 | Name | Description
Public field | dwProcessId |
Public field | dwThreadId |
Public field | hProcess |
Public field | hThread |

See Also

Native..::..PROCESS_INFORMATION Structure
robotManager.Helpful.Win32 Namespace


Native.PROCESS_INFORMATION Fields

Native..::..PROCESS_INFORMATION Fields

The Native..::..PROCESS_INFORMATION type exposes the following members.

Fields

 | Name | Description
Public field | dwProcessId |
Public field | dwThreadId |
Public field | hProcess |
Public field | hThread |

See Also

Native..::..PROCESS_INFORMATION Structure
robotManager.Helpful.Win32 Namespace


dwProcessId Field

PROCESS_INFORMATION..::..dwProcessId Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public uint dwProcessId
Public dwProcessId As UInteger
public:
unsigned int^ dwProcessId

See Also

Native..::..PROCESS_INFORMATION Structure
robotManager.Helpful.Win32 Namespace


dwThreadId Field

PROCESS_INFORMATION..::..dwThreadId Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public uint dwThreadId
Public dwThreadId As UInteger
public:
unsigned int^ dwThreadId

See Also

Native..::..PROCESS_INFORMATION Structure
robotManager.Helpful.Win32 Namespace


hProcess Field

PROCESS_INFORMATION..::..hProcess Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public IntPtr hProcess
Public hProcess As IntPtr
public:
IntPtr^ hProcess

See Also

Native..::..PROCESS_INFORMATION Structure
robotManager.Helpful.Win32 Namespace


hThread Field

PROCESS_INFORMATION..::..hThread Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public IntPtr hThread
Public hThread As IntPtr
public:
IntPtr^ hThread

See Also

Native..::..PROCESS_INFORMATION Structure
robotManager.Helpful.Win32 Namespace


Native.PROCESS_INFORMATION Methods

Native..::..PROCESS_INFORMATION Methods

The Native..::..PROCESS_INFORMATION type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from ValueType.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from ValueType.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from ValueType.)

See Also

Native..::..PROCESS_INFORMATION Structure
robotManager.Helpful.Win32 Namespace


Native.ProcessCreationFlags Enumeration

Native..::..ProcessCreationFlags Enumeration

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[FlagsAttribute]
public enum ProcessCreationFlags
<FlagsAttribute> _
Public Enumeration ProcessCreationFlags
[FlagsAttribute]
public enum class ProcessCreationFlags

Members

Member name | Description
ZERO_FLAG |
CREATE_BREAKAWAY_FROM_JOB |
CREATE_DEFAULT_ERROR_MODE |
CREATE_NEW_CONSOLE |
CREATE_NEW_PROCESS_GROUP |
CREATE_NO_WINDOW |
CREATE_PROTECTED_PROCESS |
CREATE_PRESERVE_CODE_AUTHZ_LEVEL |
CREATE_SEPARATE_WOW_VDM |
CREATE_SHARED_WOW_VDM |
CREATE_SUSPENDED |
CREATE_UNICODE_ENVIRONMENT |
DEBUG_ONLY_THIS_PROCESS |
DEBUG_PROCESS |
DETACHED_PROCESS |
EXTENDED_STARTUPINFO_PRESENT |
INHERIT_PARENT_AFFINITY |

See Also

robotManager.Helpful.Win32 Namespace


Native.RECT Structure

Native..::..RECT Structure

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[StructLayoutAttribute]
public struct RECT
<StructLayoutAttribute> _
Public Structure RECT
[StructLayoutAttribute]
public value class RECT

See Also

Native..::..RECT Members
robotManager.Helpful.Win32 Namespace


Native.RECT Members

Native..::..RECT Members

The Native..::..RECT type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from ValueType.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from ValueType.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from ValueType.)

Fields

 | Name | Description
Public field | bottom |
Public field | left |
Public field | right |
Public field | top |

See Also

Native..::..RECT Structure
robotManager.Helpful.Win32 Namespace


Native.RECT Fields

Native..::..RECT Fields

The Native..::..RECT type exposes the following members.

Fields

 | Name | Description
Public field | bottom |
Public field | left |
Public field | right |
Public field | top |

See Also

Native..::..RECT Structure
robotManager.Helpful.Win32 Namespace


bottom Field

RECT..::..bottom Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public int bottom
Public bottom As Integer
public:
int^ bottom

See Also

Native..::..RECT Structure
robotManager.Helpful.Win32 Namespace


left Field

RECT..::..left Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public int left
Public left As Integer
public:
int^ left

See Also

Native..::..RECT Structure
robotManager.Helpful.Win32 Namespace


right Field

RECT..::..right Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public int right
Public right As Integer
public:
int^ right

See Also

Native..::..RECT Structure
robotManager.Helpful.Win32 Namespace


top Field

RECT..::..top Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public int top
Public top As Integer
public:
int^ top

See Also

Native..::..RECT Structure
robotManager.Helpful.Win32 Namespace


Native.RECT Methods

Native..::..RECT Methods

The Native..::..RECT type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from ValueType.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from ValueType.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from ValueType.)

See Also

Native..::..RECT Structure
robotManager.Helpful.Win32 Namespace


Native.STARTUPINFO Structure

Native..::..STARTUPINFO Structure

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public struct STARTUPINFO
Public Structure STARTUPINFO
public value class STARTUPINFO

See Also

Native..::..STARTUPINFO Members
robotManager.Helpful.Win32 Namespace


Native.STARTUPINFO Members

Native..::..STARTUPINFO Members

The Native..::..STARTUPINFO type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from ValueType.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from ValueType.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from ValueType.)

Fields

 | Name | Description
Public field | cb |
Public field | cbReserved2 |
Public field | dwFillAttribute |
Public field | dwFlags |
Public field | dwX |
Public field | dwXCountChars |
Public field | dwXSize |
Public field | dwY |
Public field | dwYCountChars |
Public field | dwYSize |
Public field | hStdError |
Public field | hStdInput |
Public field | hStdOutput |
Public field | lpDesktop |
Public field | lpReserved |
Public field | lpReserved2 |
Public field | lpTitle |
Public field | wShowWindow |

See Also

Native..::..STARTUPINFO Structure
robotManager.Helpful.Win32 Namespace


Native.STARTUPINFO Fields

Native..::..STARTUPINFO Fields

The Native..::..STARTUPINFO type exposes the following members.

Fields

 | Name | Description
Public field | cb |
Public field | cbReserved2 |
Public field | dwFillAttribute |
Public field | dwFlags |
Public field | dwX |
Public field | dwXCountChars |
Public field | dwXSize |
Public field | dwY |
Public field | dwYCountChars |
Public field | dwYSize |
Public field | hStdError |
Public field | hStdInput |
Public field | hStdOutput |
Public field | lpDesktop |
Public field | lpReserved |
Public field | lpReserved2 |
Public field | lpTitle |
Public field | wShowWindow |

See Also

Native..::..STARTUPINFO Structure
robotManager.Helpful.Win32 Namespace


cb Field

STARTUPINFO..::..cb Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public uint cb
Public cb As UInteger
public:
unsigned int^ cb

See Also

Native..::..STARTUPINFO Structure
robotManager.Helpful.Win32 Namespace


cbReserved2 Field

STARTUPINFO..::..cbReserved2 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public short cbReserved2
Public cbReserved2 As Short
public:
short^ cbReserved2

See Also

Native..::..STARTUPINFO Structure
robotManager.Helpful.Win32 Namespace


dwFillAttribute Field

STARTUPINFO..::..dwFillAttribute Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public uint dwFillAttribute
Public dwFillAttribute As UInteger
public:
unsigned int^ dwFillAttribute

See Also

Native..::..STARTUPINFO Structure
robotManager.Helpful.Win32 Namespace


dwFlags Field

STARTUPINFO..::..dwFlags Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public uint dwFlags
Public dwFlags As UInteger
public:
unsigned int^ dwFlags

See Also

Native..::..STARTUPINFO Structure
robotManager.Helpful.Win32 Namespace


dwX Field

STARTUPINFO..::..dwX Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public uint dwX
Public dwX As UInteger
public:
unsigned int^ dwX

See Also

Native..::..STARTUPINFO Structure
robotManager.Helpful.Win32 Namespace


dwXCountChars Field

STARTUPINFO..::..dwXCountChars Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public uint dwXCountChars
Public dwXCountChars As UInteger
public:
unsigned int^ dwXCountChars

See Also

Native..::..STARTUPINFO Structure
robotManager.Helpful.Win32 Namespace


dwXSize Field

STARTUPINFO..::..dwXSize Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public uint dwXSize
Public dwXSize As UInteger
public:
unsigned int^ dwXSize

See Also

Native..::..STARTUPINFO Structure
robotManager.Helpful.Win32 Namespace


dwY Field

STARTUPINFO..::..dwY Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public uint dwY
Public dwY As UInteger
public:
unsigned int^ dwY

See Also

Native..::..STARTUPINFO Structure
robotManager.Helpful.Win32 Namespace


dwYCountChars Field

STARTUPINFO..::..dwYCountChars Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public uint dwYCountChars
Public dwYCountChars As UInteger
public:
unsigned int^ dwYCountChars

See Also

Native..::..STARTUPINFO Structure
robotManager.Helpful.Win32 Namespace


dwYSize Field

STARTUPINFO..::..dwYSize Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public uint dwYSize
Public dwYSize As UInteger
public:
unsigned int^ dwYSize

See Also

Native..::..STARTUPINFO Structure
robotManager.Helpful.Win32 Namespace


hStdError Field

STARTUPINFO..::..hStdError Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public IntPtr hStdError
Public hStdError As IntPtr
public:
IntPtr^ hStdError

See Also

Native..::..STARTUPINFO Structure
robotManager.Helpful.Win32 Namespace


hStdInput Field

STARTUPINFO..::..hStdInput Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public IntPtr hStdInput
Public hStdInput As IntPtr
public:
IntPtr^ hStdInput

See Also

Native..::..STARTUPINFO Structure
robotManager.Helpful.Win32 Namespace


hStdOutput Field

STARTUPINFO..::..hStdOutput Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public IntPtr hStdOutput
Public hStdOutput As IntPtr
public:
IntPtr^ hStdOutput

See Also

Native..::..STARTUPINFO Structure
robotManager.Helpful.Win32 Namespace


lpDesktop Field

STARTUPINFO..::..lpDesktop Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public string lpDesktop
Public lpDesktop As String
public:
String^ lpDesktop

See Also

Native..::..STARTUPINFO Structure
robotManager.Helpful.Win32 Namespace


lpReserved Field

STARTUPINFO..::..lpReserved Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public string lpReserved
Public lpReserved As String
public:
String^ lpReserved

See Also

Native..::..STARTUPINFO Structure
robotManager.Helpful.Win32 Namespace


lpReserved2 Field

STARTUPINFO..::..lpReserved2 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public IntPtr lpReserved2
Public lpReserved2 As IntPtr
public:
IntPtr^ lpReserved2

See Also

Native..::..STARTUPINFO Structure
robotManager.Helpful.Win32 Namespace


lpTitle Field

STARTUPINFO..::..lpTitle Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public string lpTitle
Public lpTitle As String
public:
String^ lpTitle

See Also

Native..::..STARTUPINFO Structure
robotManager.Helpful.Win32 Namespace


wShowWindow Field

STARTUPINFO..::..wShowWindow Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public short wShowWindow
Public wShowWindow As Short
public:
short^ wShowWindow

See Also

Native..::..STARTUPINFO Structure
robotManager.Helpful.Win32 Namespace


Native.STARTUPINFO Methods

Native..::..STARTUPINFO Methods

The Native..::..STARTUPINFO type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from ValueType.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from ValueType.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from ValueType.)

See Also

Native..::..STARTUPINFO Structure
robotManager.Helpful.Win32 Namespace


Native.ThreadAccess Enumeration

Native..::..ThreadAccess Enumeration

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[FlagsAttribute]
public enum ThreadAccess
<FlagsAttribute> _
Public Enumeration ThreadAccess
[FlagsAttribute]
public enum class ThreadAccess

Members

Member name | Description
TERMINATE |
SUSPEND_RESUME |
GET_CONTEXT |
SET_CONTEXT |
SET_INFORMATION |
QUERY_INFORMATION |
SET_THREAD_TOKEN |
IMPERSONATE |
DIRECT_IMPERSONATION |

See Also

robotManager.Helpful.Win32 Namespace


UnreservedVK Enumeration

UnreservedVK

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public enum UnreservedVK
Public Enumeration UnreservedVK
public enum class UnreservedVK

Members

Member name | Description
A |
B |
C |
D |
E |
F |
G |
H |
I |
J |
K |
L |
M |
N |
O |
P |
Q |
R |
S |
T |
U |
V |
W |
X |
Y |
Z |
NUMPAD0 |
NUMPAD1 |
NUMPAD2 |
NUMPAD3 |
NUMPAD4 |
NUMPAD5 |
NUMPAD6 |
NUMPAD7 |
NUMPAD8 |
NUMPAD9 |
F1 |
F2 |
F3 |
F4 |
F5 |
F6 |
F7 |
F8 |
F9 |
F10 |
F11 |
F12 |
F13 |
F14 |
F15 |
F16 |
F17 |
F18 |
F19 |
F20 |
F21 |
F23 |
F24 |

See Also

robotManager.Helpful.Win32 Namespace


VK Enumeration

VK

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public enum VK
Public Enumeration VK
public enum class VK

Members

Member name | Description
LBUTTON |
RBUTTON |
CANCEL |
MBUTTON |
XBUTTON1 |
XBUTTON2 |
BACK |
TAB |
CLEAR |
RETURN |
SHIFT |
CONTROL |
MENU |
PAUSE |
CAPITAL |
KANA |
HANGUL |
JUNJA |
FINAL |
HANJA |
KANJI |
ESCAPE |
CONVERT |
NONCONVERT |
ACCEPT |
MODECHANGE |
SPACE |
PRIOR |
NEXT |
END |
HOME |
LEFT |
UP |
RIGHT |
DOWN |
SELECT |
PRINT |
EXECUTE |
SNAPSHOT |
INSERT |
DELETE |
HELP |
KEY_0 |
KEY_1 |
KEY_2 |
KEY_3 |
KEY_4 |
KEY_5 |
KEY_6 |
KEY_7 |
KEY_8 |
KEY_9 |
KEY_A |
KEY_B |
KEY_C |
KEY_D |
KEY_E |
KEY_F |
KEY_G |
KEY_H |
KEY_I |
KEY_J |
KEY_K |
KEY_L |
KEY_M |
KEY_N |
KEY_O |
KEY_P |
KEY_Q |
KEY_R |
KEY_S |
KEY_T |
KEY_U |
KEY_V |
KEY_W |
KEY_X |
KEY_Y |
KEY_Z |
LWIN |
RWIN |
APPS |
SLEEP |
NUMPAD0 |
NUMPAD1 |
NUMPAD2 |
NUMPAD3 |
NUMPAD4 |
NUMPAD5 |
NUMPAD6 |
NUMPAD7 |
NUMPAD8 |
NUMPAD9 |
MULTIPLY |
ADD |
SEPARATOR |
SUBTRACT |
DECIMAL |
DIVIDE |
F1 |
F2 |
F3 |
F4 |
F5 |
F6 |
F7 |
F8 |
F9 |
F10 |
F11 |
F12 |
F13 |
F14 |
F15 |
F16 |
F17 |
F18 |
F19 |
F20 |
F21 |
F22 |
F23 |
F24 |
NUMLOCK |
SCROLL |
LSHIFT |
RSHIFT |
LCONTROL |
RCONTROL |
LMENU |
RMENU |
BROWSER_BACK |
BROWSER_FORWARD |
BROWSER_REFRESH |
BROWSER_STOP |
BROWSER_SEARCH |
BROWSER_FAVORITES |
BROWSER_HOME |
VOLUME_MUTE |
VOLUME_DOWN |
VOLUME_UP |
MEDIA_NEXT_TRACK |
MEDIA_PREV_TRACK |
MEDIA_STOP |
MEDIA_PLAY_PAUSE |
LAUNCH_MAIL |
LAUNCH_MEDIA_SELECT |
LAUNCH_APP1 |
LAUNCH_APP2 |
OEM_1 |
OEM_PLUS |
OEM_COMMA |
OEM_MINUS |
OEM_PERIOD |
OEM_2 |
OEM_3 |
OEM_4 |
OEM_5 |
OEM_6 |
OEM_7 |
OEM_8 |
OEM_102 |
PROCESSKEY |
PACKET |
ATTN |
CRSEL |
EXSEL |
EREOF |
PLAY |
ZOOM |
NONAME |
PA1 |
OEM_CLEAR |

See Also

robotManager.Helpful.Win32 Namespace


robotManager.MemoryClass Namespace

Classes

 | Class | Description
Public class | AllocManager | Class AllocManager. Advanced memory allocation in external process Implements the IDisposable
Public class | D3D | Class D3D.


AllocManager Class

Class AllocManager. Advanced memory allocation in external process Implements the IDisposable

Namespace: robotManager.MemoryClass
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public class AllocManager : IDisposable
Public Class AllocManager _
    Implements IDisposable
public ref class AllocManager : IDisposable

Inheritance Hierarchy

Object
robotManager.MemoryClass..::..AllocManager

See Also

AllocManager Members
robotManager.MemoryClass Namespace
IDisposable


AllocManager Members

The AllocManager type exposes the following members.

Constructors

 | Name | Description
Public method | AllocManager | Initializes a new instance of the AllocManager class.

Methods

 | Name | Description
Public method | Dispose | Dispose instance and free/release process memory.
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | Free | Free the specified address.
Public method | Get | Get the specified size.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

AllocManager Class
robotManager.MemoryClass Namespace


AllocManager Constructor

Initializes a new instance of the AllocManager class.

Namespace: robotManager.MemoryClass
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public AllocManager(
    int startSize,
    Memory memory,
    MemoryProtection pageProtection,
    bool onTopPage
)
Public Sub New ( _
    startSize As Integer, _
    memory As Memory, _
    pageProtection As MemoryProtection, _
    onTopPage As Boolean _
)
public:
AllocManager(
    int^ startSize,
    Memory^ memory,
    MemoryProtection^ pageProtection,
    bool^ onTopPage
)

Parameters

startSize
Type: Int32
The start size.
memory
Type: Memory
The memory.
pageProtection
Type: MemoryProtection
The page protection.
onTopPage
Type: Boolean
if set to true [on top page].

See Also

AllocManager Class
robotManager.MemoryClass Namespace


AllocManager Methods

The AllocManager type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Dispose instance and free/release process memory.
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | Free | Free the specified address.
Public method | Get | Get the specified size.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

AllocManager Class
robotManager.MemoryClass Namespace


Dispose Method

AllocManager..::..Dispose Method

Dispose instance and free/release process memory.

Namespace: robotManager.MemoryClass
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public void Dispose()
Public Sub Dispose
public:
void Dispose()

See Also

AllocManager Class
robotManager.MemoryClass Namespace


Free Method

AllocManager..::..Free Method

Free the specified address.

Namespace: robotManager.MemoryClass
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public bool Free(
    ulong address
)
Public Function Free ( _
    address As ULong _
) As Boolean
public:
bool^ Free(
    unsigned long long^ address
)

Parameters

address
Type: UInt64
The address.

Return Value

true if XXXX, false otherwise.

See Also

AllocManager Class
robotManager.MemoryClass Namespace


Get Method

AllocManager..::..Get Method

Get the specified size.

Namespace: robotManager.MemoryClass
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public ulong Get(
    int size
)
Public Function Get ( _
    size As Integer _
) As ULong
public:
unsigned long long^ Get(
    int^ size
)

Parameters

size
Type: Int32
The size.

Return Value

Ptr.

See Also

AllocManager Class
robotManager.MemoryClass Namespace


D3D Class

Class D3D.

Namespace: robotManager.MemoryClass
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static class D3D
Public NotInheritable Class D3D
public ref class D3D abstract sealed

Inheritance Hierarchy

Object
robotManager.MemoryClass..::..D3D

See Also

D3D Members
robotManager.MemoryClass Namespace


D3D Members

The D3D type exposes the following members.

Methods

Name | Description
ShowSlimDxError | Shows the slim dx error.

See Also

D3D Class
robotManager.MemoryClass Namespace


D3D Methods

The D3D type exposes the following members.

Methods

Name | Description
ShowSlimDxError | Shows the slim dx error.

See Also

D3D Class
robotManager.MemoryClass Namespace


ShowSlimDxError Method

D3D..::..ShowSlimDxError Method

Shows the slim dx error.

Namespace: robotManager.MemoryClass
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void ShowSlimDxError()
Public Shared Sub ShowSlimDxError
public:
static void ShowSlimDxError()

See Also

D3D Class
robotManager.MemoryClass Namespace


robotManager.Products Namespace

Classes

 | Class | Description
Public class | Products | Class Products.
Public class | Products..::..IsAliveProductChangeEventArgs | Class IsAliveProductChangeEventArgs. Implements the EventArgs
Public class | Products..::..IsStartedChangeEventArgs | Class IsStartedChangeEventArgs. Implements the EventArgs
Public class | Products..::..ProductNeedSettingsEventArgs | Class ProductNeedSettingsEventArgs. Implements the EventArgs

Interfaces

Interface Description
Public interface IProduct
Product interface. If you want create your own product you need to compile your code to .dll file and move dll to folder "WRobot\Products\". To be compatible you need to implement this interface on class named "Main" without namespace.

Examples

C#
using System.Threading;
using robotManager.Helpful;
using robotManager.Products;
using UserControl = System.Windows.Controls.UserControl;

public class Main : IProduct
{
    public void Initialize()
    {
        _isStarted = false;
        Logging.Status = "Initialized";
        Logging.Write("Initialized");
    }

    public void Dispose()
    {
        Stop();
        Logging.Status = "Disposed";
        Logging.Write("Disposed");
    }

    public void Start()
    {
         _isStarted = true;
        Logging.Status = "Started";
        Logging.Write("Started");

        while (IsStarted)
        {
            if (!Products.InPause)
            {
                 Logging.Status = "Running";
                Logging.Write("Running");
                Thread.Sleep(1000);
            }
        }
    }

    public void Stop()
    {
        _isStarted = false;
        Logging.Status = "Stopped";
        Logging.Write("Stopped");
    }

    public UserControl Settings
    {
        get
        {
            return new UserControl();
        }
    }

    public bool IsStarted
    {
        get { return _isStarted; }
    }
    private bool _isStarted;
}

Delegates

 | Delegate | Description
Public delegate | Products..::..IsAliveProductChangeEventHandler | Delegate IsAliveProductChangeEventHandler
Public delegate | Products..::..IsStartedChangeEventHandler | Delegate IsStartedChangeEventHandler
Public delegate | Products..::..ProductNeedSettingsEventHandler | Delegate ProductNeedSettingsEventHandler


IProduct Interface

Product interface. If you want create your own product you need to compile your code to .dll file and move dll to folder "WRobot\Products\". To be compatible you need to implement this interface on class named "Main" without namespace.

Examples

C#
using System.Threading;
using robotManager.Helpful;
using robotManager.Products;
using UserControl = System.Windows.Controls.UserControl;

public class Main : IProduct
{
    public void Initialize()
    {
        _isStarted = false;
        Logging.Status = "Initialized";
        Logging.Write("Initialized");
    }

    public void Dispose()
    {
        Stop();
        Logging.Status = "Disposed";
        Logging.Write("Disposed");
    }

    public void Start()
    {
         _isStarted = true;
        Logging.Status = "Started";
        Logging.Write("Started");

        while (IsStarted)
        {
            if (!Products.InPause)
            {
                 Logging.Status = "Running";
                Logging.Write("Running");
                Thread.Sleep(1000);
            }
        }
    }

    public void Stop()
    {
        _isStarted = false;
        Logging.Status = "Stopped";
        Logging.Write("Stopped");
    }

    public UserControl Settings
    {
        get
        {
            return new UserControl();
        }
    }

    public bool IsStarted
    {
        get { return _isStarted; }
    }
    private bool _isStarted;
}

Namespace: robotManager.Products
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public interface IProduct
Public Interface IProduct
public interface class IProduct

See Also

IProduct Members
robotManager.Products Namespace


IProduct Members

The IProduct type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Dispose Product
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | Initialize | Initialize Product.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Start | Start Product.
Public method | Stop | Stop Product.
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | IsStarted | Get product running status.
Public property | Settings | Settings Product WPF usercontrol.

See Also

IProduct Interface
robotManager.Products Namespace


IProduct Methods

The IProduct type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Dispose Product
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | Initialize | Initialize Product.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Start | Start Product.
Public method | Stop | Stop Product.
Public method | ToString | (Inherited from Object.)

See Also

IProduct Interface
robotManager.Products Namespace


Dispose Method

IProduct..::..Dispose Method

Dispose Product

Namespace: robotManager.Products
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
void Dispose()
Sub Dispose
void Dispose()

See Also

IProduct Interface
robotManager.Products Namespace


Initialize Method

IProduct..::..Initialize Method

Initialize Product.

Namespace: robotManager.Products
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
void Initialize()
Sub Initialize
void Initialize()

See Also

IProduct Interface
robotManager.Products Namespace


Start Method

IProduct..::..Start Method

Start Product.

Namespace: robotManager.Products
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
void Start()
Sub Start
void Start()

See Also

IProduct Interface
robotManager.Products Namespace


Stop Method

IProduct..::..Stop Method

Stop Product.

Namespace: robotManager.Products
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
void Stop()
Sub Stop
void Stop()

See Also

IProduct Interface
robotManager.Products Namespace


IProduct Properties

The IProduct type exposes the following members.

Properties

 | Name | Description
Public property | IsStarted | Get product running status.
Public property | Settings | Settings Product WPF usercontrol.

See Also

IProduct Interface
robotManager.Products Namespace


IsStarted Property

IProduct..::..IsStarted Property

Get product running status.

Namespace: robotManager.Products
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
bool IsStarted { get; }
ReadOnly Property IsStarted As Boolean
    Get
property bool^ IsStarted {
    bool^ get ();
}

Field Value

true if product is started, else false .

See Also

IProduct Interface
robotManager.Products Namespace


Settings Property

IProduct..::..Settings Property

Settings Product WPF usercontrol.

Namespace: robotManager.Products
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
UserControl Settings { get; }
ReadOnly Property Settings As UserControl
    Get
property UserControl^ Settings {
    UserControl^ get ();
}

Field Value

The settings.

See Also

IProduct Interface
robotManager.Products Namespace


Products Class

Class Products.

Namespace: robotManager.Products
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public class Products
Public Class Products
public ref class Products

Inheritance Hierarchy

Object
robotManager.Products..::..Products

See Also

Products Members
robotManager.Products Namespace


Products Members

The Products type exposes the following members.

Methods

 | Name | Description
 | DisposeProduct | Dispose loaded product.
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
 | LoadProducts | Load and initialise product.
 | LoadProductsWithoutInit | Load product without initialize.
Protected method | MemberwiseClone | (Inherited from Object.)
 | ProductNeedSettings | Show product settings tab.
 | ProductRestart | Restart product (don't call it from product thread to avoid problem).
 | ProductStart | Start product.
 | ProductStop | Stop product.
Public method | ToString | (Inherited from Object.)

Properties

Name | Description
InPause | Get or set a value indicating whether product is in pause.
IsAliveProduct | Gets a value indicating whether product instance is alive product.
IsStarted | Get a value indicating whether product instance is started.
ProductName | Get the name of the product.
ProductSettings | Get product settings.

Events

Name | Description
OnChangedIsAliveProduct | Occurs when [on changed is alive product].
OnChangedIsStarted | Occurs when started state change.
OnProductNeedSettings | Occurs when [on product need settings].

See Also

Products Class
robotManager.Products Namespace


Products Methods

The Products type exposes the following members.

Methods

 | Name | Description
 | DisposeProduct | Dispose loaded product.
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
 | LoadProducts | Load and initialise product.
 | LoadProductsWithoutInit | Load product without initialize.
Protected method | MemberwiseClone | (Inherited from Object.)
 | ProductNeedSettings | Show product settings tab.
 | ProductRestart | Restart product (don't call it from product thread to avoid problem).
 | ProductStart | Start product.
 | ProductStop | Stop product.
Public method | ToString | (Inherited from Object.)

See Also

Products Class
robotManager.Products Namespace


DisposeProduct Method

Products..::..DisposeProduct Method

Dispose loaded product.

Namespace: robotManager.Products
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void DisposeProduct()
Public Shared Sub DisposeProduct
public:
static void DisposeProduct()

See Also

Products Class
robotManager.Products Namespace


LoadProducts Method

Products..::..LoadProducts Method

Load and initialise product.

Namespace: robotManager.Products
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void LoadProducts(
    string nameDll
)
Public Shared Sub LoadProducts ( _
    nameDll As String _
)
public:
static void LoadProducts(
    String^ nameDll
)

Parameters

nameDll
Type: String
The file name (for "WRobot\Products\MyProduct.dll" use "MyProduct").

See Also

Products Class
robotManager.Products Namespace


LoadProductsWithoutInit Method

Products..::..LoadProductsWithoutInit Method

Load product without initialize.

Namespace: robotManager.Products
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static IProduct LoadProductsWithoutInit(
    string nameDll
)
Public Shared Function LoadProductsWithoutInit ( _
    nameDll As String _
) As IProduct
public:
static IProduct^ LoadProductsWithoutInit(
    String^ nameDll
)

Parameters

nameDll
Type: String
File name (for "WRobot\Products\MyProduct.dll" use "MyProduct").

Return Value

product instance.

See Also

Products Class
robotManager.Products Namespace


ProductNeedSettings Method

Products..::..ProductNeedSettings Method

Show product settings tab.

Namespace: robotManager.Products
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static void ProductNeedSettings()
Public Shared Sub ProductNeedSettings
public:
static void ProductNeedSettings()

See Also

Products Class
robotManager.Products Namespace


ProductRestart Method

Products..::..ProductRestart Method

Restart product (don't call it from product thread to avoid problem).

Namespace: robotManager.Products
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static bool ProductRestart()
Public Shared Function ProductRestart As Boolean
public:
static bool^ ProductRestart()

Return Value

true if success, false otherwise.

See Also

Products Class
robotManager.Products Namespace


ProductStart Method

Products..::..ProductStart Method

Start product.

Namespace: robotManager.Products
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static bool ProductStart()
Public Shared Function ProductStart As Boolean
public:
static bool^ ProductStart()

Return Value

true if success, false otherwise.

See Also

Products Class
robotManager.Products Namespace


ProductStop Method

Products..::..ProductStop Method

Stop product.

Namespace: robotManager.Products
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static bool ProductStop()
Public Shared Function ProductStop As Boolean
public:
static bool^ ProductStop()

Return Value

true if success, false otherwise.

See Also

Products Class
robotManager.Products Namespace


Products Properties

The Products type exposes the following members.

Properties

Name | Description
InPause | Get or set a value indicating whether product is in pause.
IsAliveProduct | Gets a value indicating whether product instance is alive product.
IsStarted | Get a value indicating whether product instance is started.
ProductName | Get the name of the product.
ProductSettings | Get product settings.

See Also

Products Class
robotManager.Products Namespace


InPause Property

Products..::..InPause Property

Get or set a value indicating whether product is in pause.

Namespace: robotManager.Products
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static bool InPause { get; set; }
Public Shared Property InPause As Boolean
    Get
    Set
public:
static property bool^ InPause {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if product is in pause; otherwise, false.

See Also

Products Class
robotManager.Products Namespace


IsAliveProduct Property

Products..::..IsAliveProduct Property

Gets a value indicating whether product instance is alive product.

Namespace: robotManager.Products
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static bool IsAliveProduct { get; }
Public Shared ReadOnly Property IsAliveProduct As Boolean
    Get
public:
static property bool^ IsAliveProduct {
    bool^ get ();
}

Field Value

true if product instance is alive product; otherwise, false.

See Also

Products Class
robotManager.Products Namespace


IsStarted Property

Products..::..IsStarted Property

Get a value indicating whether product instance is started.

Namespace: robotManager.Products
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static bool IsStarted { get; }
Public Shared ReadOnly Property IsStarted As Boolean
    Get
public:
static property bool^ IsStarted {
    bool^ get ();
}

Field Value

true if product instance is started; otherwise, false.

See Also

Products Class
robotManager.Products Namespace


ProductName Property

Products..::..ProductName Property

Get the name of the product.

Namespace: robotManager.Products
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static string ProductName { get; set; }
Public Shared Property ProductName As String
    Get
    Set
public:
static property String^ ProductName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the product.

See Also

Products Class
robotManager.Products Namespace


ProductSettings Property

Products..::..ProductSettings Property

Get product settings.

Namespace: robotManager.Products
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static UserControl ProductSettings { get; }
Public Shared ReadOnly Property ProductSettings As UserControl
    Get
public:
static property UserControl^ ProductSettings {
    UserControl^ get ();
}

Field Value

The product settings.

See Also

Products Class
robotManager.Products Namespace


Products Events

The Products type exposes the following members.

Events

Name | Description
OnChangedIsAliveProduct | Occurs when [on changed is alive product].
OnChangedIsStarted | Occurs when started state change.
OnProductNeedSettings | Occurs when [on product need settings].

See Also

Products Class
robotManager.Products Namespace


OnChangedIsAliveProduct Event

Products..::..OnChangedIsAliveProduct Event

Occurs when [on changed is alive product].

Namespace: robotManager.Products
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static event Products..::..IsAliveProductChangeEventHandler OnChangedIsAliveProduct
Public Shared Event OnChangedIsAliveProduct As Products..::..IsAliveProductChangeEventHandler
public:
static  event Products..::..IsAliveProductChangeEventHandler^ OnChangedIsAliveProduct {
    void add (Products..::..IsAliveProductChangeEventHandler^ value);
    void remove (Products..::..IsAliveProductChangeEventHandler^ value);
}

See Also

Products Class
robotManager.Products Namespace


OnChangedIsStarted Event

Products..::..OnChangedIsStarted Event

Occurs when started state change.

Namespace: robotManager.Products
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static event Products..::..IsStartedChangeEventHandler OnChangedIsStarted
Public Shared Event OnChangedIsStarted As Products..::..IsStartedChangeEventHandler
public:
static  event Products..::..IsStartedChangeEventHandler^ OnChangedIsStarted {
    void add (Products..::..IsStartedChangeEventHandler^ value);
    void remove (Products..::..IsStartedChangeEventHandler^ value);
}

See Also

Products Class
robotManager.Products Namespace


OnProductNeedSettings Event

Products..::..OnProductNeedSettings Event

Occurs when [on product need settings].

Namespace: robotManager.Products
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static event Products..::..ProductNeedSettingsEventHandler OnProductNeedSettings
Public Shared Event OnProductNeedSettings As Products..::..ProductNeedSettingsEventHandler
public:
static  event Products..::..ProductNeedSettingsEventHandler^ OnProductNeedSettings {
    void add (Products..::..ProductNeedSettingsEventHandler^ value);
    void remove (Products..::..ProductNeedSettingsEventHandler^ value);
}

See Also

Products Class
robotManager.Products Namespace


Products.IsAliveProductChangeEventArgs Class

Products..::..IsAliveProductChangeEventArgs Class

Class IsAliveProductChangeEventArgs. Implements the EventArgs

Namespace: robotManager.Products
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public class IsAliveProductChangeEventArgs : EventArgs
Public Class IsAliveProductChangeEventArgs _
    Inherits EventArgs
public ref class IsAliveProductChangeEventArgs : public EventArgs

Inheritance Hierarchy

Object
EventArgs
robotManager.Products..::..Products..::..IsAliveProductChangeEventArgs

See Also

Products..::..IsAliveProductChangeEventArgs Members
robotManager.Products Namespace
EventArgs


Products.IsAliveProductChangeEventArgs Members

Products..::..IsAliveProductChangeEventArgs Members

The Products..::..IsAliveProductChangeEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | IsAliveProduct | Gets or sets a value indicating whether product instance is alive product.

See Also

Products..::..IsAliveProductChangeEventArgs Class
robotManager.Products Namespace


Products.IsAliveProductChangeEventArgs Methods

Products..::..IsAliveProductChangeEventArgs Methods

The Products..::..IsAliveProductChangeEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Products..::..IsAliveProductChangeEventArgs Class
robotManager.Products Namespace


Products.IsAliveProductChangeEventArgs Properties

Products..::..IsAliveProductChangeEventArgs Properties

The Products..::..IsAliveProductChangeEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | IsAliveProduct | Gets or sets a value indicating whether product instance is alive product.

See Also

Products..::..IsAliveProductChangeEventArgs Class
robotManager.Products Namespace


IsAliveProduct Property

IsAliveProductChangeEventArgs..::..IsAliveProduct Property

Gets or sets a value indicating whether product instance is alive product.

Namespace: robotManager.Products
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public bool IsAliveProduct { get; set; }
Public Property IsAliveProduct As Boolean
    Get
    Set
public:
property bool^ IsAliveProduct {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if product instance is alive product; otherwise, false.

See Also

Products..::..IsAliveProductChangeEventArgs Class
robotManager.Products Namespace


Products.IsAliveProductChangeEventHandler Delegate

Products..::..IsAliveProductChangeEventHandler Delegate

Delegate IsAliveProductChangeEventHandler

Namespace: robotManager.Products
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public delegate void IsAliveProductChangeEventHandler(
    Products..::..IsAliveProductChangeEventArgs e
)
Public Delegate Sub IsAliveProductChangeEventHandler ( _
    e As Products..::..IsAliveProductChangeEventArgs _
)
public delegate void IsAliveProductChangeEventHandler(
    Products..::..IsAliveProductChangeEventArgs^ e
)

Parameters

e
Type: robotManager.Products..::..Products..::..IsAliveProductChangeEventArgs
The Products..::..IsAliveProductChangeEventArgs instance containing the event data.

See Also

robotManager.Products Namespace


Products.IsStartedChangeEventArgs Class

Products..::..IsStartedChangeEventArgs Class

Class IsStartedChangeEventArgs. Implements the EventArgs

Namespace: robotManager.Products
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public class IsStartedChangeEventArgs : EventArgs
Public Class IsStartedChangeEventArgs _
    Inherits EventArgs
public ref class IsStartedChangeEventArgs : public EventArgs

Inheritance Hierarchy

Object
EventArgs
robotManager.Products..::..Products..::..IsStartedChangeEventArgs

See Also

Products..::..IsStartedChangeEventArgs Members
robotManager.Products Namespace
EventArgs


Products.IsStartedChangeEventArgs Members

Products..::..IsStartedChangeEventArgs Members

The Products..::..IsStartedChangeEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | IsStarted | Gets or sets a value indicating whether product instance is started.

See Also

Products..::..IsStartedChangeEventArgs Class
robotManager.Products Namespace


Products.IsStartedChangeEventArgs Methods

Products..::..IsStartedChangeEventArgs Methods

The Products..::..IsStartedChangeEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Products..::..IsStartedChangeEventArgs Class
robotManager.Products Namespace


Products.IsStartedChangeEventArgs Properties

Products..::..IsStartedChangeEventArgs Properties

The Products..::..IsStartedChangeEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | IsStarted | Gets or sets a value indicating whether product instance is started.

See Also

Products..::..IsStartedChangeEventArgs Class
robotManager.Products Namespace


IsStarted Property

IsStartedChangeEventArgs..::..IsStarted Property

Gets or sets a value indicating whether product instance is started.

Namespace: robotManager.Products
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public bool IsStarted { get; set; }
Public Property IsStarted As Boolean
    Get
    Set
public:
property bool^ IsStarted {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if product instance is started; otherwise, false.

See Also

Products..::..IsStartedChangeEventArgs Class
robotManager.Products Namespace


Products.IsStartedChangeEventHandler Delegate

Products..::..IsStartedChangeEventHandler Delegate

Delegate IsStartedChangeEventHandler

Namespace: robotManager.Products
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public delegate void IsStartedChangeEventHandler(
    Products..::..IsStartedChangeEventArgs e
)
Public Delegate Sub IsStartedChangeEventHandler ( _
    e As Products..::..IsStartedChangeEventArgs _
)
public delegate void IsStartedChangeEventHandler(
    Products..::..IsStartedChangeEventArgs^ e
)

Parameters

e
Type: robotManager.Products..::..Products..::..IsStartedChangeEventArgs
The Products..::..IsStartedChangeEventArgs instance containing the event data.

See Also

robotManager.Products Namespace


Products.ProductNeedSettingsEventArgs Class

Products..::..ProductNeedSettingsEventArgs Class

Class ProductNeedSettingsEventArgs. Implements the EventArgs

Namespace: robotManager.Products
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public class ProductNeedSettingsEventArgs : EventArgs
Public Class ProductNeedSettingsEventArgs _
    Inherits EventArgs
public ref class ProductNeedSettingsEventArgs : public EventArgs

Inheritance Hierarchy

Object
EventArgs
robotManager.Products..::..Products..::..ProductNeedSettingsEventArgs

See Also

Products..::..ProductNeedSettingsEventArgs Members
robotManager.Products Namespace
EventArgs


Products.ProductNeedSettingsEventArgs Members

Products..::..ProductNeedSettingsEventArgs Members

The Products..::..ProductNeedSettingsEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | NeedSettings | Gets or sets a value indicating whether [need settings].

See Also

Products..::..ProductNeedSettingsEventArgs Class
robotManager.Products Namespace


Products.ProductNeedSettingsEventArgs Methods

Products..::..ProductNeedSettingsEventArgs Methods

The Products..::..ProductNeedSettingsEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Products..::..ProductNeedSettingsEventArgs Class
robotManager.Products Namespace


Products.ProductNeedSettingsEventArgs Properties

Products..::..ProductNeedSettingsEventArgs Properties

The Products..::..ProductNeedSettingsEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | NeedSettings | Gets or sets a value indicating whether [need settings].

See Also

Products..::..ProductNeedSettingsEventArgs Class
robotManager.Products Namespace


NeedSettings Property

ProductNeedSettingsEventArgs..::..NeedSettings Property

Gets or sets a value indicating whether [need settings].

Namespace: robotManager.Products
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public bool NeedSettings { get; set; }
Public Property NeedSettings As Boolean
    Get
    Set
public:
property bool^ NeedSettings {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if [need settings]; otherwise, false.

See Also

Products..::..ProductNeedSettingsEventArgs Class
robotManager.Products Namespace


Products.ProductNeedSettingsEventHandler Delegate

Products..::..ProductNeedSettingsEventHandler Delegate

Delegate ProductNeedSettingsEventHandler

Namespace: robotManager.Products
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public delegate void ProductNeedSettingsEventHandler(
    Products..::..ProductNeedSettingsEventArgs e
)
Public Delegate Sub ProductNeedSettingsEventHandler ( _
    e As Products..::..ProductNeedSettingsEventArgs _
)
public delegate void ProductNeedSettingsEventHandler(
    Products..::..ProductNeedSettingsEventArgs^ e
)

Parameters

e
Type: robotManager.Products..::..Products..::..ProductNeedSettingsEventArgs
The Products..::..ProductNeedSettingsEventArgs instance containing the event data.

See Also

robotManager.Products Namespace


wManager Namespace

Classes

 | Class | Description
Public class | BlackListSerializable | Class BlackListSerializable. This class is saved in an .xml file ("\ Data \ BlackList.xml"). The blacklist contained in this file is used by all characters of this bot installation.
Public class | BlackListSerializable..::..BlackNpc | Class BlackNpc.
Public class | BlackListSerializable..::..BlackNpcType | Class BlackNpcType.
Public class | BlackListSerializable..::..Blackspot | Class Blackspot.
Public class | GeneralSettings | Class GeneralSettings (UI for settings file wManagerSetting). Implements the Form
Public class | Information | Class Information.
Public class | Pulsator | Class Pulsator. Use to attach game and initialize bot.
Public class | Statistics | Class Statistics (show tab "In Game").
Public class | wManagerGlobalSetting | Class wManagerGlobalSetting. The configurations in this file are used by all the characters. XML file is in "WRobot\Settings\WRobotGlobalSetting.xml" Implements the Settings
Public class | wManagerSetting | Class wManagerSetting. This class contains options attached to the used character. It also contains the session blacklists. File is in folder "WRobot\Settings\", file name format is: Settings.AdviserFilePathAndName("General", ObjectManager.Me.Name + "." + Usefuls.RealmName) (result like "WRobot\Settings\General-PlayerName.RealmName.xml") Implements the Settings
Public class | wManagerSetting..::..IgnoredNerbyPlayerClass | Class IgnoredNerbyPlayerClass ([IgnoredNerbyPlayer]).
Public class | wManagerSetting..::..MyMacro | Class MyMacro. Allows you to simulate the pressing of a keyboard key every X seconds according to simple conditions. This option is rarely used now it is better to use a plugin for this kind of task. Used by state MyMacro
Public class | wManagerSetting..::..PluginSetting | Class PluginSetting. Used in wManagerSetting by the settings [PluginsSettings]. This allows the bot to remember which IPlugin are activated or not ("Plugins" tab).


BlackListSerializable Class

Class BlackListSerializable. This class is saved in an .xml file ("\ Data \ BlackList.xml"). The blacklist contained in this file is used by all characters of this bot installation.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class BlackListSerializable
<SerializableAttribute> _
Public Class BlackListSerializable
[SerializableAttribute]
public ref class BlackListSerializable

Inheritance Hierarchy

Object
wManager..::..BlackListSerializable

See Also

BlackListSerializable Members
wManager Namespace


BlackListSerializable Members

The BlackListSerializable type exposes the following members.

Methods

 | Name | Description
 | AddBlackListToWRobotSession | Add blacklists of this instance to bot session (in wManagerSetting). This method clear session blacklists before to add blacklists of this instance(he calls InitPather()()()() and ClearBlacklist()()()(). It is called when the bot starts, when continent change or when there edit blacklists.
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
 | Load | Load instance from xml FilePath.
Protected method | MemberwiseClone | (Inherited from Object.)
 | Save | Save instance to xml FilePath.
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | BlackGuids | The GUID blacklist, OLD prefer BlackNpcs
Public field | BlackNpcs | NPCs GUID blacklist
Public field | BlackNpcTypes | NPCs entry id blacklist
Public field | Blackspots | The blackspots

Properties

Name | Description
FilePath | Gets full xml file path.

See Also

BlackListSerializable Class
wManager Namespace


BlackListSerializable Fields

The BlackListSerializable type exposes the following members.

Fields

 | Name | Description
Public field | BlackGuids | The GUID blacklist, OLD prefer BlackNpcs
Public field | BlackNpcs | NPCs GUID blacklist
Public field | BlackNpcTypes | NPCs entry id blacklist
Public field | Blackspots | The blackspots

See Also

BlackListSerializable Class
wManager Namespace


BlackGuids Field

BlackListSerializable..::..BlackGuids Field

The GUID blacklist, OLD prefer BlackNpcs

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<ulong> BlackGuids
Public BlackGuids As List(Of ULong)
public:
List<unsigned long long^>^ BlackGuids

See Also

BlackListSerializable Class
wManager Namespace


BlackNpcs Field

BlackListSerializable..::..BlackNpcs Field

NPCs GUID blacklist

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<BlackListSerializable..::..BlackNpc> BlackNpcs
Public BlackNpcs As List(Of BlackListSerializable..::..BlackNpc)
public:
List<BlackListSerializable..::..BlackNpc^>^ BlackNpcs

See Also

BlackListSerializable Class
wManager Namespace


BlackNpcTypes Field

BlackListSerializable..::..BlackNpcTypes Field

NPCs entry id blacklist

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<BlackListSerializable..::..BlackNpcType> BlackNpcTypes
Public BlackNpcTypes As List(Of BlackListSerializable..::..BlackNpcType)
public:
List<BlackListSerializable..::..BlackNpcType^>^ BlackNpcTypes

See Also

BlackListSerializable Class
wManager Namespace


Blackspots Field

BlackListSerializable..::..Blackspots Field

The blackspots

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<BlackListSerializable..::..Blackspot> Blackspots
Public Blackspots As List(Of BlackListSerializable..::..Blackspot)
public:
List<BlackListSerializable..::..Blackspot^>^ Blackspots

See Also

BlackListSerializable Class
wManager Namespace


BlackListSerializable Methods

The BlackListSerializable type exposes the following members.

Methods

 | Name | Description
 | AddBlackListToWRobotSession | Add blacklists of this instance to bot session (in wManagerSetting). This method clear session blacklists before to add blacklists of this instance(he calls InitPather()()()() and ClearBlacklist()()()(). It is called when the bot starts, when continent change or when there edit blacklists.
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
 | Load | Load instance from xml FilePath.
Protected method | MemberwiseClone | (Inherited from Object.)
 | Save | Save instance to xml FilePath.
Public method | ToString | (Inherited from Object.)

See Also

BlackListSerializable Class
wManager Namespace


AddBlackListToWRobotSession Method

BlackListSerializable..::..AddBlackListToWRobotSession Method

Add blacklists of this instance to bot session (in wManagerSetting). This method clear session blacklists before to add blacklists of this instance(he calls InitPather()()()() and ClearBlacklist()()()(). It is called when the bot starts, when continent change or when there edit blacklists.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void AddBlackListToWRobotSession()
Public Shared Sub AddBlackListToWRobotSession
public:
static void AddBlackListToWRobotSession()

See Also

BlackListSerializable Class
wManager Namespace


Load Method

BlackListSerializable..::..Load Method

Load instance from xml FilePath.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static BlackListSerializable Load()
Public Shared Function Load As BlackListSerializable
public:
static BlackListSerializable^ Load()

Return Value

BlackListSerializable.

See Also

BlackListSerializable Class
wManager Namespace


Save Method

BlackListSerializable..::..Save Method

Save instance to xml FilePath.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool Save(
    BlackListSerializable blackListSerializable
)
Public Shared Function Save ( _
    blackListSerializable As BlackListSerializable _
) As Boolean
public:
static bool^ Save(
    BlackListSerializable^ blackListSerializable
)

Parameters

blackListSerializable
Type: wManager..::..BlackListSerializable
The blacklist serializable.

Return Value

true if success, false otherwise.

See Also

BlackListSerializable Class
wManager Namespace


BlackListSerializable Properties

The BlackListSerializable type exposes the following members.

Properties

Name | Description
FilePath | Gets full xml file path.

See Also

BlackListSerializable Class
wManager Namespace


FilePath Property

BlackListSerializable..::..FilePath Property

Gets full xml file path.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string FilePath { get; }
Public Shared ReadOnly Property FilePath As String
    Get
public:
static property String^ FilePath {
    String^ get ();
}

Field Value

The file path.

See Also

BlackListSerializable Class
wManager Namespace


BlackListSerializable.BlackNpc Class

BlackListSerializable..::..BlackNpc Class

Class BlackNpc.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class BlackNpc
<SerializableAttribute> _
Public Class BlackNpc
[SerializableAttribute]
public ref class BlackNpc

Inheritance Hierarchy

Object
wManager..::..BlackListSerializable..::..BlackNpc

See Also

BlackListSerializable..::..BlackNpc Members
wManager Namespace


BlackListSerializable.BlackNpc Members

BlackListSerializable..::..BlackNpc Members

The BlackListSerializable..::..BlackNpc type exposes the following members.

Constructors

 | Name | Description
Public method | BlackListSerializable..::..BlackNpc | Initializes a new instance of the BlackListSerializable..::..BlackNpc class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance.
Public method | ToStringGuidFormat | ulong to string guid.
 | ToStringGuidFormatStatic | ulong to string guid.
Public method | ToULong()()()() | To ulong.
 | ToULong(String) | To ulong.

Properties

 | Name | Description
Public property | GuidNpc | Gets or sets object GUID in string format (Guid)
Public property | NameNpc | Gets or sets unit name or description.

See Also

BlackListSerializable..::..BlackNpc Class
wManager Namespace


BlackNpc Constructor

Initializes a new instance of the BlackListSerializable..::..BlackNpc class.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public BlackNpc()
Public Sub New
public:
BlackNpc()

See Also

BlackListSerializable..::..BlackNpc Class
wManager Namespace


BlackListSerializable.BlackNpc Methods

BlackListSerializable..::..BlackNpc Methods

The BlackListSerializable..::..BlackNpc type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance.
Public method | ToStringGuidFormat | ulong to string guid.
 | ToStringGuidFormatStatic | ulong to string guid.
Public method | ToULong()()()() | To ulong.
 | ToULong(String) | To ulong.

See Also

BlackListSerializable..::..BlackNpc Class
wManager Namespace


ToString Method

BlackNpc..::..ToString Method

Returns a String that represents this instance.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string ToString()
Public Function ToString As String
public:
String^ ToString()

Return Value

A String that represents this instance.

See Also

BlackListSerializable..::..BlackNpc Class
wManager Namespace


ToStringGuidFormat Method

BlackNpc..::..ToStringGuidFormat Method

ulong to string guid.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool ToStringGuidFormat(
    ulong guid
)
Public Function ToStringGuidFormat ( _
    guid As ULong _
) As Boolean
public:
bool^ ToStringGuidFormat(
    unsigned long long^ guid
)

Parameters

guid
Type: UInt64

See Also

BlackListSerializable..::..BlackNpc Class
wManager Namespace


ToStringGuidFormatStatic Method

BlackNpc..::..ToStringGuidFormatStatic Method

ulong to string guid.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string ToStringGuidFormatStatic(
    ulong guid
)
Public Shared Function ToStringGuidFormatStatic ( _
    guid As ULong _
) As String
public:
static String^ ToStringGuidFormatStatic(
    unsigned long long^ guid
)

Parameters

guid
Type: UInt64

See Also

BlackListSerializable..::..BlackNpc Class
wManager Namespace


ToULong Method

BlackNpc..::..ToULong Method

Overload List

 | Name | Description
Public method | ToULong()()()() | To ulong.
 | ToULong(String) | To ulong.

See Also

BlackListSerializable..::..BlackNpc Class
BlackListSerializable..::..BlackNpc Members
wManager Namespace


ToULong Method

BlackNpc..::..ToULong Method

To ulong.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public ulong ToULong()
Public Function ToULong As ULong
public:
unsigned long long^ ToULong()

See Also

BlackListSerializable..::..BlackNpc Class
ToULong Overload
wManager Namespace


ToULong Method (String)

BlackNpc..::..ToULong Method (String)

To ulong.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static ulong ToULong(
    string guidNpc
)
Public Shared Function ToULong ( _
    guidNpc As String _
) As ULong
public:
static unsigned long long^ ToULong(
    String^ guidNpc
)

Parameters

guidNpc
Type: String

See Also

BlackListSerializable..::..BlackNpc Class
ToULong Overload
wManager Namespace


BlackListSerializable.BlackNpc Properties

BlackListSerializable..::..BlackNpc Properties

The BlackListSerializable..::..BlackNpc type exposes the following members.

Properties

 | Name | Description
Public property | GuidNpc | Gets or sets object GUID in string format (Guid)
Public property | NameNpc | Gets or sets unit name or description.

See Also

BlackListSerializable..::..BlackNpc Class
wManager Namespace


GuidNpc Property

BlackNpc..::..GuidNpc Property

Gets or sets object GUID in string format (Guid)

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string GuidNpc { get; set; }
Public Property GuidNpc As String
    Get
    Set
public:
property String^ GuidNpc {
    String^ get ();
    void set (String^ value);
}

Field Value

The NPC GUID.

See Also

BlackListSerializable..::..BlackNpc Class
wManager Namespace


NameNpc Property

BlackNpc..::..NameNpc Property

Gets or sets unit name or description.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string NameNpc { get; set; }
Public Property NameNpc As String
    Get
    Set
public:
property String^ NameNpc {
    String^ get ();
    void set (String^ value);
}

Field Value

The name.

See Also

BlackListSerializable..::..BlackNpc Class
wManager Namespace


BlackListSerializable.BlackNpcType Class

BlackListSerializable..::..BlackNpcType Class

Class BlackNpcType.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class BlackNpcType
<SerializableAttribute> _
Public Class BlackNpcType
[SerializableAttribute]
public ref class BlackNpcType

Inheritance Hierarchy

Object
wManager..::..BlackListSerializable..::..BlackNpcType

See Also

BlackListSerializable..::..BlackNpcType Members
wManager Namespace


BlackListSerializable.BlackNpcType Members

BlackListSerializable..::..BlackNpcType Members

The BlackListSerializable..::..BlackNpcType type exposes the following members.

Constructors

 | Name | Description
Public method | BlackListSerializable..::..BlackNpcType | Initializes a new instance of the BlackListSerializable..::..BlackNpcType class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance.

Properties

 | Name | Description
Public property | EntryId | Gets or sets the entry id (Entry).
Public property | NameNpc | Gets or sets unit name or description.

See Also

BlackListSerializable..::..BlackNpcType Class
wManager Namespace


BlackNpcType Constructor

Initializes a new instance of the BlackListSerializable..::..BlackNpcType class.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public BlackNpcType()
Public Sub New
public:
BlackNpcType()

See Also

BlackListSerializable..::..BlackNpcType Class
wManager Namespace


BlackListSerializable.BlackNpcType Methods

BlackListSerializable..::..BlackNpcType Methods

The BlackListSerializable..::..BlackNpcType type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance.

See Also

BlackListSerializable..::..BlackNpcType Class
wManager Namespace


ToString Method

BlackNpcType..::..ToString Method

Returns a String that represents this instance.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string ToString()
Public Function ToString As String
public:
String^ ToString()

Return Value

A String that represents this instance.

See Also

BlackListSerializable..::..BlackNpcType Class
wManager Namespace


BlackListSerializable.BlackNpcType Properties

BlackListSerializable..::..BlackNpcType Properties

The BlackListSerializable..::..BlackNpcType type exposes the following members.

Properties

 | Name | Description
Public property | EntryId | Gets or sets the entry id (Entry).
Public property | NameNpc | Gets or sets unit name or description.

See Also

BlackListSerializable..::..BlackNpcType Class
wManager Namespace


EntryId Property

BlackNpcType..::..EntryId Property

Gets or sets the entry id (Entry).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int EntryId { get; set; }
Public Property EntryId As Integer
    Get
    Set
public:
property int^ EntryId {
    int^ get ();
    void set (int^ value);
}

Field Value

The entry identifier.

See Also

BlackListSerializable..::..BlackNpcType Class
wManager Namespace


NameNpc Property

BlackNpcType..::..NameNpc Property

Gets or sets unit name or description.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string NameNpc { get; set; }
Public Property NameNpc As String
    Get
    Set
public:
property String^ NameNpc {
    String^ get ();
    void set (String^ value);
}

Field Value

The name.

See Also

BlackListSerializable..::..BlackNpcType Class
wManager Namespace


BlackListSerializable.Blackspot Class

BlackListSerializable..::..Blackspot Class

Class Blackspot.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class Blackspot
<SerializableAttribute> _
Public Class Blackspot
[SerializableAttribute]
public ref class Blackspot

Inheritance Hierarchy

Object
wManager..::..BlackListSerializable..::..Blackspot

See Also

BlackListSerializable..::..Blackspot Members
wManager Namespace


BlackListSerializable.Blackspot Members

BlackListSerializable..::..Blackspot Members

The BlackListSerializable..::..Blackspot type exposes the following members.

Constructors

 | Name | Description
Public method | BlackListSerializable..::..Blackspot | Initializes a new instance of the BlackListSerializable..::..Blackspot class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetPosition | Gets the position.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance.

Properties

 | Name | Description
Public property | Comment | Gets or sets comment.
Public property | Continent | Gets or sets the continent id.
Public property | Radius | The height.
Public property | TypeArea | Gets or sets the type area (used by PathFinder).
Public property | X | Gets or sets the x position.
Public property | Y | Gets or sets the y position.
Public property | Z | Gets or sets the z position.

See Also

BlackListSerializable..::..Blackspot Class
wManager Namespace


Blackspot Constructor

Initializes a new instance of the BlackListSerializable..::..Blackspot class.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Blackspot()
Public Sub New
public:
Blackspot()

See Also

BlackListSerializable..::..Blackspot Class
wManager Namespace


BlackListSerializable.Blackspot Methods

BlackListSerializable..::..Blackspot Methods

The BlackListSerializable..::..Blackspot type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetPosition | Gets the position.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance.

See Also

BlackListSerializable..::..Blackspot Class
wManager Namespace


GetPosition Method

Blackspot..::..GetPosition Method

Gets the position.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Vector3 GetPosition()
Public Function GetPosition As Vector3
public:
Vector3^ GetPosition()

Return Value

Vector3.

See Also

BlackListSerializable..::..Blackspot Class
wManager Namespace


ToString Method

Blackspot..::..ToString Method

Returns a String that represents this instance.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string ToString()
Public Function ToString As String
public:
String^ ToString()

Return Value

A String that represents this instance.

See Also

BlackListSerializable..::..Blackspot Class
wManager Namespace


BlackListSerializable.Blackspot Properties

BlackListSerializable..::..Blackspot Properties

The BlackListSerializable..::..Blackspot type exposes the following members.

Properties

 | Name | Description
Public property | Comment | Gets or sets comment.
Public property | Continent | Gets or sets the continent id.
Public property | Radius | The height.
Public property | TypeArea | Gets or sets the type area (used by PathFinder).
Public property | X | Gets or sets the x position.
Public property | Y | Gets or sets the y position.
Public property | Z | Gets or sets the z position.

See Also

BlackListSerializable..::..Blackspot Class
wManager Namespace


Comment Property

Blackspot..::..Comment Property

Gets or sets comment.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string Comment { get; set; }
Public Property Comment As String
    Get
    Set
public:
property String^ Comment {
    String^ get ();
    void set (String^ value);
}

Field Value

The comment.

See Also

BlackListSerializable..::..Blackspot Class
wManager Namespace


Continent Property

Blackspot..::..Continent Property

Gets or sets the continent id.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public ContinentId Continent { get; set; }
Public Property Continent As ContinentId
    Get
    Set
public:
property ContinentId^ Continent {
    ContinentId^ get ();
    void set (ContinentId^ value);
}

Field Value

The continent.

See Also

BlackListSerializable..::..Blackspot Class
wManager Namespace


Radius Property

Blackspot..::..Radius Property

The height.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float Radius { get; set; }
Public Property Radius As Single
    Get
    Set
public:
property float^ Radius {
    float^ get ();
    void set (float^ value);
}

Field Value

The radius.

See Also

BlackListSerializable..::..Blackspot Class
wManager Namespace


TypeArea Property

Blackspot..::..TypeArea Property

Gets or sets the type area (used by PathFinder).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public PolyArea TypeArea { get; set; }
Public Property TypeArea As PolyArea
    Get
    Set
public:
property PolyArea^ TypeArea {
    PolyArea^ get ();
    void set (PolyArea^ value);
}

Field Value

The type area.

See Also

BlackListSerializable..::..Blackspot Class
wManager Namespace


X Property

Blackspot..::..X Property

Gets or sets the x position.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float X { get; set; }
Public Property X As Single
    Get
    Set
public:
property float^ X {
    float^ get ();
    void set (float^ value);
}

Field Value

The x.

See Also

BlackListSerializable..::..Blackspot Class
wManager Namespace


Y Property

Blackspot..::..Y Property

Gets or sets the y position.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float Y { get; set; }
Public Property Y As Single
    Get
    Set
public:
property float^ Y {
    float^ get ();
    void set (float^ value);
}

Field Value

The y.

See Also

BlackListSerializable..::..Blackspot Class
wManager Namespace


Z Property

Blackspot..::..Z Property

Gets or sets the z position.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float Z { get; set; }
Public Property Z As Single
    Get
    Set
public:
property float^ Z {
    float^ get ();
    void set (float^ value);
}

Field Value

The z.

See Also

BlackListSerializable..::..Blackspot Class
wManager Namespace


GeneralSettings Class

Class GeneralSettings (UI for settings file wManagerSetting). Implements the Form

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class GeneralSettings : Form
Public Class GeneralSettings _
    Inherits Form
public ref class GeneralSettings : public Form

Inheritance Hierarchy

Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
wManager..::..GeneralSettings

See Also

GeneralSettings Members
wManager Namespace
Form


GeneralSettings Members

The GeneralSettings type exposes the following members.

Constructors

 | Name | Description
Public method | GeneralSettings | Initializes a new instance of the GeneralSettings class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Public method | Activate | (Inherited from Form.)
Protected method | ActivateMdiChild(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | AddOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from Form.)
Protected method | ApplyAutoScaling | (Inherited from Form.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Protected method | CenterToParent | (Inherited from Form.)
Protected method | CenterToScreen | (Inherited from Form.)
Public method | Close | (Inherited from Form.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Form.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Clean up any resources being used.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Public method | LayoutMdi(System.Windows.Forms.MdiLayout) | (Inherited from Form.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnActivated(System.EventArgs) | (Inherited from Form.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnClosed(System.EventArgs) | (Inherited from Form.)
Protected method | OnClosing(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from Form.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDeactivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Form.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnFormClosed(System.Windows.Forms.FormClosedEventArgs) | (Inherited from Form.)
Protected method | OnFormClosing(System.Windows.Forms.FormClosingEventArgs) | (Inherited from Form.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Form.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Form.)
Protected method | OnHelpButtonClicked(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInputLanguageChanged(System.Windows.Forms.InputLanguageChangedEventArgs) | (Inherited from Form.)
Protected method | OnInputLanguageChanging(System.Windows.Forms.InputLanguageChangingEventArgs) | (Inherited from Form.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from Form.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from Form.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMaximumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMdiChildActivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuComplete(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuStart(System.EventArgs) | (Inherited from Form.)
Protected method | OnMinimumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Form.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeBegin(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeEnd(System.EventArgs) | (Inherited from Form.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnShown(System.EventArgs) | (Inherited from Form.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from Form.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from Form.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from Form.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | RemoveOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from Form.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from Form.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopLocation(System.Int32,System.Int32) | (Inherited from Form.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Form.)
Public method | Show(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Public method | Show | (Inherited from Control.)
Public method | ShowDialog | (Inherited from Form.)
Public method | ShowDialog(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Form.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from Form.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from Form.)

Properties

 | Name | Description
Public property | AcceptButton | (Inherited from Form.)
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | ActiveMdiChild | (Inherited from Form.)
Public property | AllowDrop | (Inherited from Control.)
Public property | AllowTransparency | (Inherited from Form.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScale | (Inherited from Form.)
Public property | AutoScaleBaseSize | (Inherited from Form.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from Form.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Form.)
Public property | AutoSizeMode | (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Public property | CancelButton | (Inherited from Form.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Form.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | ControlBox | (Inherited from Form.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Form.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DesktopBounds | (Inherited from Form.)
Public property | DesktopLocation | (Inherited from Form.)
Public property | DialogResult | (Inherited from Form.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | FormBorderStyle | (Inherited from Form.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HelpButton | (Inherited from Form.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | Icon | (Inherited from Form.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMdiChild | (Inherited from Form.)
Public property | IsMdiContainer | (Inherited from Form.)
Public property | IsMirrored | (Inherited from Control.)
Public property | IsRestrictedWindow | (Inherited from Form.)
Public property | KeyPreview | (Inherited from Form.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Form.)
Public property | MainMenuStrip | (Inherited from Form.)
Public property | Margin | (Inherited from Form.)
Public property | MaximizeBox | (Inherited from Form.)
Protected property | MaximizedBounds | (Inherited from Form.)
Public property | MaximumSize | (Inherited from Form.)
Public property | MdiChildren | (Inherited from Form.)
Public property | MdiParent | (Inherited from Form.)
Public property | Menu | (Inherited from Form.)
Public property | MergedMenu | (Inherited from Form.)
Public property | MinimizeBox | (Inherited from Form.)
Public property | MinimumSize | (Inherited from Form.)
Public property | Modal | (Inherited from Form.)
Public property | Name | (Inherited from Control.)
Public property | Opacity | (Inherited from Form.)
Public property | OwnedForms | (Inherited from Form.)
Public property | Owner | (Inherited from Form.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | RestoreBounds | (Inherited from Form.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Public property | RightToLeftLayout | (Inherited from Form.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | ShowIcon | (Inherited from Form.)
Public property | ShowInTaskbar | (Inherited from Form.)
Protected property | ShowWithoutActivation | (Inherited from Form.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Form.)
Public property | SizeGripStyle | (Inherited from Form.)
Public property | StartPosition | (Inherited from Form.)
Public property | TabIndex | (Inherited from Form.)
Public property | TabStop | (Inherited from Form.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | (Inherited from Control.)
Public property | TopLevel | (Inherited from Form.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | TopMost | (Inherited from Form.)
Public property | TransparencyKey | (Inherited from Form.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowState | (Inherited from Form.)
Public property | WindowTarget | (Inherited from Control.)

Events

 | Name | Description
Public event | Activated | (Inherited from Form.)
Public event | AutoSizeChanged | (Inherited from Form.)
Public event | AutoValidateChanged | (Inherited from Form.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | Closed | (Inherited from Form.)
Public event | Closing | (Inherited from Form.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Deactivate | (Inherited from Form.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | FormClosed | (Inherited from Form.)
Public event | FormClosing | (Inherited from Form.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpButtonClicked | (Inherited from Form.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | InputLanguageChanged | (Inherited from Form.)
Public event | InputLanguageChanging | (Inherited from Form.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from Form.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Form.)
Public event | MaximizedBoundsChanged | (Inherited from Form.)
Public event | MaximumSizeChanged | (Inherited from Form.)
Public event | MdiChildActivate | (Inherited from Form.)
Public event | MenuComplete | (Inherited from Form.)
Public event | MenuStart | (Inherited from Form.)
Public event | MinimumSizeChanged | (Inherited from Form.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | ResizeBegin | (Inherited from Form.)
Public event | ResizeEnd | (Inherited from Form.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | RightToLeftLayoutChanged | (Inherited from Form.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | Shown | (Inherited from Form.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Form.)
Public event | TabStopChanged | (Inherited from Form.)
Public event | TextChanged | (Inherited from Control.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

GeneralSettings Class
wManager Namespace


GeneralSettings Constructor

Initializes a new instance of the GeneralSettings class.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public GeneralSettings()
Public Sub New
public:
GeneralSettings()

See Also

GeneralSettings Class
wManager Namespace


GeneralSettings Methods

The GeneralSettings type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Public method | Activate | (Inherited from Form.)
Protected method | ActivateMdiChild(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | AddOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from Form.)
Protected method | ApplyAutoScaling | (Inherited from Form.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Protected method | CenterToParent | (Inherited from Form.)
Protected method | CenterToScreen | (Inherited from Form.)
Public method | Close | (Inherited from Form.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Form.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Clean up any resources being used.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Public method | LayoutMdi(System.Windows.Forms.MdiLayout) | (Inherited from Form.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnActivated(System.EventArgs) | (Inherited from Form.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnClosed(System.EventArgs) | (Inherited from Form.)
Protected method | OnClosing(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from Form.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDeactivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Form.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnFormClosed(System.Windows.Forms.FormClosedEventArgs) | (Inherited from Form.)
Protected method | OnFormClosing(System.Windows.Forms.FormClosingEventArgs) | (Inherited from Form.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Form.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Form.)
Protected method | OnHelpButtonClicked(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInputLanguageChanged(System.Windows.Forms.InputLanguageChangedEventArgs) | (Inherited from Form.)
Protected method | OnInputLanguageChanging(System.Windows.Forms.InputLanguageChangingEventArgs) | (Inherited from Form.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from Form.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from Form.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMaximumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMdiChildActivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuComplete(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuStart(System.EventArgs) | (Inherited from Form.)
Protected method | OnMinimumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Form.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeBegin(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeEnd(System.EventArgs) | (Inherited from Form.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnShown(System.EventArgs) | (Inherited from Form.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from Form.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from Form.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from Form.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | RemoveOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from Form.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from Form.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopLocation(System.Int32,System.Int32) | (Inherited from Form.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Form.)
Public method | Show(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Public method | Show | (Inherited from Control.)
Public method | ShowDialog | (Inherited from Form.)
Public method | ShowDialog(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Form.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from Form.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from Form.)

See Also

GeneralSettings Class
wManager Namespace


Dispose Method

GeneralSettings..::..Dispose Method

Overload List

 | Name | Description
Protected method | Dispose(Boolean) | Clean up any resources being used.
Public method | Dispose | (Inherited from Component.)

See Also

GeneralSettings Class
GeneralSettings Members
wManager Namespace


Dispose Method

GeneralSettings..::..Dispose Method

Clean up any resources being used.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
protected void Dispose(
    bool disposing
)
Protected Sub Dispose ( _
    disposing As Boolean _
)
protected:
void Dispose(
    bool^ disposing
)

Parameters

disposing
Type: Boolean
true if managed resources should be disposed; otherwise, false.

See Also

GeneralSettings Class
wManager Namespace


GeneralSettings Properties

The GeneralSettings type exposes the following members.

Properties

 | Name | Description
Public property | AcceptButton | (Inherited from Form.)
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | ActiveMdiChild | (Inherited from Form.)
Public property | AllowDrop | (Inherited from Control.)
Public property | AllowTransparency | (Inherited from Form.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScale | (Inherited from Form.)
Public property | AutoScaleBaseSize | (Inherited from Form.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from Form.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Form.)
Public property | AutoSizeMode | (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Public property | CancelButton | (Inherited from Form.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Form.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | ControlBox | (Inherited from Form.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Form.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DesktopBounds | (Inherited from Form.)
Public property | DesktopLocation | (Inherited from Form.)
Public property | DialogResult | (Inherited from Form.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | FormBorderStyle | (Inherited from Form.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HelpButton | (Inherited from Form.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | Icon | (Inherited from Form.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMdiChild | (Inherited from Form.)
Public property | IsMdiContainer | (Inherited from Form.)
Public property | IsMirrored | (Inherited from Control.)
Public property | IsRestrictedWindow | (Inherited from Form.)
Public property | KeyPreview | (Inherited from Form.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Form.)
Public property | MainMenuStrip | (Inherited from Form.)
Public property | Margin | (Inherited from Form.)
Public property | MaximizeBox | (Inherited from Form.)
Protected property | MaximizedBounds | (Inherited from Form.)
Public property | MaximumSize | (Inherited from Form.)
Public property | MdiChildren | (Inherited from Form.)
Public property | MdiParent | (Inherited from Form.)
Public property | Menu | (Inherited from Form.)
Public property | MergedMenu | (Inherited from Form.)
Public property | MinimizeBox | (Inherited from Form.)
Public property | MinimumSize | (Inherited from Form.)
Public property | Modal | (Inherited from Form.)
Public property | Name | (Inherited from Control.)
Public property | Opacity | (Inherited from Form.)
Public property | OwnedForms | (Inherited from Form.)
Public property | Owner | (Inherited from Form.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | RestoreBounds | (Inherited from Form.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Public property | RightToLeftLayout | (Inherited from Form.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | ShowIcon | (Inherited from Form.)
Public property | ShowInTaskbar | (Inherited from Form.)
Protected property | ShowWithoutActivation | (Inherited from Form.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Form.)
Public property | SizeGripStyle | (Inherited from Form.)
Public property | StartPosition | (Inherited from Form.)
Public property | TabIndex | (Inherited from Form.)
Public property | TabStop | (Inherited from Form.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | (Inherited from Control.)
Public property | TopLevel | (Inherited from Form.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | TopMost | (Inherited from Form.)
Public property | TransparencyKey | (Inherited from Form.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowState | (Inherited from Form.)
Public property | WindowTarget | (Inherited from Control.)

See Also

GeneralSettings Class
wManager Namespace


GeneralSettings Events

The GeneralSettings type exposes the following members.

Events

 | Name | Description
Public event | Activated | (Inherited from Form.)
Public event | AutoSizeChanged | (Inherited from Form.)
Public event | AutoValidateChanged | (Inherited from Form.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | Closed | (Inherited from Form.)
Public event | Closing | (Inherited from Form.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Deactivate | (Inherited from Form.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | FormClosed | (Inherited from Form.)
Public event | FormClosing | (Inherited from Form.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpButtonClicked | (Inherited from Form.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | InputLanguageChanged | (Inherited from Form.)
Public event | InputLanguageChanging | (Inherited from Form.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from Form.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Form.)
Public event | MaximizedBoundsChanged | (Inherited from Form.)
Public event | MaximumSizeChanged | (Inherited from Form.)
Public event | MdiChildActivate | (Inherited from Form.)
Public event | MenuComplete | (Inherited from Form.)
Public event | MenuStart | (Inherited from Form.)
Public event | MinimumSizeChanged | (Inherited from Form.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | ResizeBegin | (Inherited from Form.)
Public event | ResizeEnd | (Inherited from Form.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | RightToLeftLayoutChanged | (Inherited from Form.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | Shown | (Inherited from Form.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Form.)
Public event | TabStopChanged | (Inherited from Form.)
Public event | TextChanged | (Inherited from Control.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

GeneralSettings Class
wManager Namespace


Information Class

Class Information.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class Information
Public NotInheritable Class Information
public ref class Information abstract sealed

Inheritance Hierarchy

Object
wManager..::..Information

See Also

Information Members
wManager Namespace


Information Members

The Information type exposes the following members.

Methods

Name | Description
LaunchBot | Launch the bot.

Properties

Name | Description
BotName |
ForWow | Gets for wow version (like "3.3.5").
ForWowBuild | Gets Wow build (like 12340).
Version | Gets the bot version number (like "2.7.0).
WRobotVersion | Get bot version name (like "wrobotvanilla" or "wrobotwotlk").

See Also

Information Class
wManager Namespace


Information Methods

The Information type exposes the following members.

Methods

Name | Description
LaunchBot | Launch the bot.

See Also

Information Class
wManager Namespace


LaunchBot Method

Information..::..LaunchBot Method

Launch the bot.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int LaunchBot(
    string arg,
    Args argsEnvironmentVariables,
    bool minimizeOnStart
)
Public Shared Function LaunchBot ( _
    arg As String, _
    argsEnvironmentVariables As Args, _
    minimizeOnStart As Boolean _
) As Integer
public:
static int^ LaunchBot(
    String^ arg,
    Args^ argsEnvironmentVariables,
    bool^ minimizeOnStart
)

Parameters

arg
Type: String
The argument.
argsEnvironmentVariables
Type: robotManager.Helpful..::..Args
The arguments environment variables.
minimizeOnStart
Type: Boolean
if set to true minimize on start.

Return Value

System.Int32.

See Also

Information Class
wManager Namespace


Information Properties

The Information type exposes the following members.

Properties

Name | Description
BotName |
ForWow | Gets for wow version (like "3.3.5").
ForWowBuild | Gets Wow build (like 12340).
Version | Gets the bot version number (like "2.7.0).
WRobotVersion | Get bot version name (like "wrobotvanilla" or "wrobotwotlk").

See Also

Information Class
wManager Namespace


BotName Property

Information..::..BotName Property

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string BotName { get; }
Public Shared ReadOnly Property BotName As String
    Get
public:
static property String^ BotName {
    String^ get ();
}

See Also

Information Class
wManager Namespace


ForWow Property

Information..::..ForWow Property

Gets for wow version (like "3.3.5").

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string ForWow { get; }
Public Shared ReadOnly Property ForWow As String
    Get
public:
static property String^ ForWow {
    String^ get ();
}

Field Value

Wow version.

See Also

Information Class
wManager Namespace


ForWowBuild Property

Information..::..ForWowBuild Property

Gets Wow build (like 12340).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int ForWowBuild { get; }
Public Shared ReadOnly Property ForWowBuild As Integer
    Get
public:
static property int^ ForWowBuild {
    int^ get ();
}

Field Value

Wow build.

See Also

Information Class
wManager Namespace


Version Property

Information..::..Version Property

Gets the bot version number (like "2.7.0).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string Version { get; }
Public Shared ReadOnly Property Version As String
    Get
public:
static property String^ Version {
    String^ get ();
}

Field Value

The version.

See Also

Information Class
wManager Namespace


WRobotVersion Property

Information..::..WRobotVersion Property

Get bot version name (like "wrobotvanilla" or "wrobotwotlk").

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string WRobotVersion { get; }
Public Shared ReadOnly Property WRobotVersion As String
    Get
public:
static property String^ WRobotVersion {
    String^ get ();
}

Field Value

The bot version name.

See Also

Information Class
wManager Namespace


Pulsator Class

Class Pulsator. Use to attach game and initialize bot.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[ObfuscationAttribute]
public class Pulsator
<ObfuscationAttribute> _
Public Class Pulsator
[ObfuscationAttribute]
public ref class Pulsator

Inheritance Hierarchy

Object
wManager..::..Pulsator

See Also

Pulsator Members
wManager Namespace


Pulsator Members

The Pulsator type exposes the following members.

Methods

 | Name | Description
 | Dispose | Detach Wow process
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
 | Pulse | Attach to game process
 | Reset | Dispose and Pulse again.
Public method | ToString | (Inherited from Object.)

Properties

Name | Description
IsActive | Get a value indicating Wow process is active, attached and hooked
K |

See Also

Pulsator Class
wManager Namespace


Pulsator Methods

The Pulsator type exposes the following members.

Methods

 | Name | Description
 | Dispose | Detach Wow process
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
 | Pulse | Attach to game process
 | Reset | Dispose and Pulse again.
Public method | ToString | (Inherited from Object.)

See Also

Pulsator Class
wManager Namespace


Dispose Method

Pulsator..::..Dispose Method

Detach Wow process

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void Dispose(
    bool closePocess
)
Public Shared Sub Dispose ( _
    closePocess As Boolean _
)
public:
static void Dispose(
    bool^ closePocess
)

Parameters

closePocess
Type: Boolean
true to close current process; false to only detach Wow process.

See Also

Pulsator Class
wManager Namespace


Pulse Method

Pulsator..::..Pulse Method

Attach to game process

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void Pulse(
    int processId
)
Public Shared Sub Pulse ( _
    processId As Integer _
)
public:
static void Pulse(
    int^ processId
)

Parameters

processId
Type: Int32
The process id.

See Also

Pulsator Class
wManager Namespace


Reset Method

Pulsator..::..Reset Method

Dispose and Pulse again.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void Reset()
Public Shared Sub Reset
public:
static void Reset()

See Also

Pulsator Class
wManager Namespace


Pulsator Properties

The Pulsator type exposes the following members.

Properties

Name | Description
IsActive | Get a value indicating Wow process is active, attached and hooked
K |

See Also

Pulsator Class
wManager Namespace


IsActive Property

Pulsator..::..IsActive Property

Get a value indicating Wow process is active, attached and hooked

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool IsActive { get; }
Public Shared ReadOnly Property IsActive As Boolean
    Get
public:
static property bool^ IsActive {
    bool^ get ();
}

Field Value

true if this instance is active; otherwise, false.

See Also

Pulsator Class
wManager Namespace


K Property

Pulsator..::..K Property

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string K { set; }
Public Shared WriteOnly Property K As String
    Set
public:
static property String^ K {
    void set (String^ value);
}

See Also

Pulsator Class
wManager Namespace


Statistics Class

Class Statistics (show tab "In Game").

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class Statistics
Public NotInheritable Class Statistics
public ref class Statistics abstract sealed

Inheritance Hierarchy

Object
wManager..::..Statistics

See Also

Statistics Members
wManager Namespace


Statistics Members

The Statistics type exposes the following members.

Methods

Name | Description
DeathsByHr | Death by hour.
ExperienceByHr | Experiences by hour.
FarmsByHr | Farms by hour.
Honor | Honor.
HonorByHr | Honor by hour.
KillsByHr | Kills by hour.
LootsByHr | Loots by hour.
Money | Money since last Reset()()()().
MoneyByHr | Money by hour.
NextLevelMin | Time remaining before next level (in minute).
NextLevelSec | Time remaining before next level (in second).
Reset | Resets all statistics.
RunningTimeInSec | Running time in second.
StucksByHr | Stucks by hour.

Properties

Name | Description
Deaths | Deaths count since Reset()()()().
Farms | Farms count since Reset()()()().
Kills | Kills count since Reset()()()().
Loots | Loots count since Reset()()()().
Stucks | Stucks count since Reset()()()().

See Also

Statistics Class
wManager Namespace


Statistics Methods

The Statistics type exposes the following members.

Methods

Name | Description
DeathsByHr | Death by hour.
ExperienceByHr | Experiences by hour.
FarmsByHr | Farms by hour.
Honor | Honor.
HonorByHr | Honor by hour.
KillsByHr | Kills by hour.
LootsByHr | Loots by hour.
Money | Money since last Reset()()()().
MoneyByHr | Money by hour.
NextLevelMin | Time remaining before next level (in minute).
NextLevelSec | Time remaining before next level (in second).
Reset | Resets all statistics.
RunningTimeInSec | Running time in second.
StucksByHr | Stucks by hour.

See Also

Statistics Class
wManager Namespace


DeathsByHr Method

Statistics..::..DeathsByHr Method

Death by hour.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int DeathsByHr()
Public Shared Function DeathsByHr As Integer
public:
static int^ DeathsByHr()

Return Value

System.Int32.

See Also

Statistics Class
wManager Namespace


ExperienceByHr Method

Statistics..::..ExperienceByHr Method

Experiences by hour.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int ExperienceByHr()
Public Shared Function ExperienceByHr As Integer
public:
static int^ ExperienceByHr()

Return Value

System.Int32.

See Also

Statistics Class
wManager Namespace


FarmsByHr Method

Statistics..::..FarmsByHr Method

Farms by hour.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int FarmsByHr()
Public Shared Function FarmsByHr As Integer
public:
static int^ FarmsByHr()

Return Value

System.Int32.

See Also

Statistics Class
wManager Namespace


Honor Method

Statistics..::..Honor Method

Honor.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int Honor()
Public Shared Function Honor As Integer
public:
static int^ Honor()

Return Value

Honor.

See Also

Statistics Class
wManager Namespace


HonorByHr Method

Statistics..::..HonorByHr Method

Honor by hour.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int HonorByHr()
Public Shared Function HonorByHr As Integer
public:
static int^ HonorByHr()

Return Value

Honor by hour.

See Also

Statistics Class
wManager Namespace


KillsByHr Method

Statistics..::..KillsByHr Method

Kills by hour.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int KillsByHr()
Public Shared Function KillsByHr As Integer
public:
static int^ KillsByHr()

Return Value

System.Int32.

See Also

Statistics Class
wManager Namespace


LootsByHr Method

Statistics..::..LootsByHr Method

Loots by hour.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int LootsByHr()
Public Shared Function LootsByHr As Integer
public:
static int^ LootsByHr()

Return Value

System.Int32.

See Also

Statistics Class
wManager Namespace


Money Method

Statistics..::..Money Method

Money since last Reset()()()().

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static long Money()
Public Shared Function Money As Long
public:
static long long^ Money()

Return Value

Int64.

See Also

Statistics Class
wManager Namespace


MoneyByHr Method

Statistics..::..MoneyByHr Method

Money by hour.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static long MoneyByHr()
Public Shared Function MoneyByHr As Long
public:
static long long^ MoneyByHr()

Return Value

Int64.

See Also

Statistics Class
wManager Namespace


NextLevelMin Method

Statistics..::..NextLevelMin Method

Time remaining before next level (in minute).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int NextLevelMin()
Public Shared Function NextLevelMin As Integer
public:
static int^ NextLevelMin()

Return Value

System.Int32.

See Also

Statistics Class
wManager Namespace


NextLevelSec Method

Statistics..::..NextLevelSec Method

Time remaining before next level (in second).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int NextLevelSec()
Public Shared Function NextLevelSec As Integer
public:
static int^ NextLevelSec()

Return Value

System.Int32.

See Also

Statistics Class
wManager Namespace


Reset Method

Statistics..::..Reset Method

Resets all statistics.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void Reset()
Public Shared Sub Reset
public:
static void Reset()

See Also

Statistics Class
wManager Namespace


RunningTimeInSec Method

Statistics..::..RunningTimeInSec Method

Running time in second.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int RunningTimeInSec()
Public Shared Function RunningTimeInSec As Integer
public:
static int^ RunningTimeInSec()

Return Value

System.Int32.

See Also

Statistics Class
wManager Namespace


StucksByHr Method

Statistics..::..StucksByHr Method

Stucks by hour.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int StucksByHr()
Public Shared Function StucksByHr As Integer
public:
static int^ StucksByHr()

Return Value

Stucks by hour.

See Also

Statistics Class
wManager Namespace


Statistics Properties

The Statistics type exposes the following members.

Properties

Name | Description
Deaths | Deaths count since Reset()()()().
Farms | Farms count since Reset()()()().
Kills | Kills count since Reset()()()().
Loots | Loots count since Reset()()()().
Stucks | Stucks count since Reset()()()().

See Also

Statistics Class
wManager Namespace


Deaths Property

Statistics..::..Deaths Property

Deaths count since Reset()()()().

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static uint Deaths { get; set; }
Public Shared Property Deaths As UInteger
    Get
    Set
public:
static property unsigned int^ Deaths {
    unsigned int^ get ();
    void set (unsigned int^ value);
}

Field Value

deaths count.

See Also

Statistics Class
wManager Namespace


Farms Property

Statistics..::..Farms Property

Farms count since Reset()()()().

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static uint Farms { get; set; }
Public Shared Property Farms As UInteger
    Get
    Set
public:
static property unsigned int^ Farms {
    unsigned int^ get ();
    void set (unsigned int^ value);
}

Field Value

farms count.

See Also

Statistics Class
wManager Namespace


Kills Property

Statistics..::..Kills Property

Kills count since Reset()()()().

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static uint Kills { get; set; }
Public Shared Property Kills As UInteger
    Get
    Set
public:
static property unsigned int^ Kills {
    unsigned int^ get ();
    void set (unsigned int^ value);
}

Field Value

kills count.

See Also

Statistics Class
wManager Namespace


Loots Property

Statistics..::..Loots Property

Loots count since Reset()()()().

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static uint Loots { get; set; }
Public Shared Property Loots As UInteger
    Get
    Set
public:
static property unsigned int^ Loots {
    unsigned int^ get ();
    void set (unsigned int^ value);
}

Field Value

loots count.

See Also

Statistics Class
wManager Namespace


Stucks Property

Statistics..::..Stucks Property

Stucks count since Reset()()()().

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static uint Stucks { get; set; }
Public Shared Property Stucks As UInteger
    Get
    Set
public:
static property unsigned int^ Stucks {
    unsigned int^ get ();
    void set (unsigned int^ value);
}

Field Value

stucks count.

See Also

Statistics Class
wManager Namespace


wManagerGlobalSetting Class

Class wManagerGlobalSetting. The configurations in this file are used by all the characters. XML file is in "WRobot\Settings\WRobotGlobalSetting.xml" Implements the Settings

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class wManagerGlobalSetting : Settings
<SerializableAttribute> _
Public Class wManagerGlobalSetting _
    Inherits Settings
[SerializableAttribute]
public ref class wManagerGlobalSetting : public Settings

Inheritance Hierarchy

Object
robotManager.Helpful..::..Settings
wManager..::..wManagerGlobalSetting

See Also

wManagerGlobalSetting Members
wManager Namespace
robotManager.Helpful..::..Settings


wManagerGlobalSetting Members

The wManagerGlobalSetting type exposes the following members.

Methods

 | Name | Description
Protected method | ConfigWinForm | (Inherited from Settings.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
 | Load | Loads instance from FilePath.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Save()()()() | Saves instance to FilePath..
Protected method | Save(String) | Save to xml file (Inherited from Settings.)
Public method | ToForm | Converts to form. (Inherited from Settings.)
Public method | ToString | (Inherited from Object.)
Public method | ToStringFormat | Converts to stringformat. (Inherited from Settings.)

Fields

 | Name | Description
Public field | BlacklistShow | Show blacklists (in map 2D and 3D tab "Map")
Public field | ByName | Show NPC/object by name (in map 2D and 3D tab "Map")
Public field | CloseGameIfAdminRights | Close the game if it has Administrator rights (Windows)
Public field | CloseIfCannotLoginWowMinutes | Close bot if cannot login ingame after X minutes (this option is only used if you are using the relloger application)
Public field | DriveLetter | Security option used in few bot versions to create fake drive that link to WRobotFileName folder.
Public field | FullWowPath | The path to Wow
Public field | HideLuaError | Hide in-game lua error
Public field | LowFps | Low FPS (in map 2D and 3D tab "Map")
Public field | LowQuality | Low quality (in map 2D and 3D tab "Map")
Public field | MaxFPS | Most versions require a minimum of FPS in-game to work properly. This option increase the "Maximum FPS" option in game if it is lower than the value of this option (https://wowwiki.fandom.com/wiki/CVar_maxFPS and https://wowwiki.fandom.com/wiki/CVar_maxFPSBk)
Public field | MaxLuaMemoryUsage | The maximum amount of memory in use by Lua (in kilobytes). If the value is greater than this option the bot uses the lua reload function.
Public field | MeShow | Show my character (in map 2D and 3D tab "Map")
Public field | NpcShow | Show NPCs (in map 2D and 3D tab "Map")
Public field | ObjectsShow | Show objects (in map 2D and 3D tab "Map")
Public field | PathShow | Show path (in map 2D and 3D tab "Map")
Public field | PlayersShow | Show other players (in map 2D and 3D tab "Map")
Public field | Remote | Activate remote option (to access to the bot from the website) (option found tab "Main")
Public field | TargetShow | Show target (in map 2D and 3D tab "Map")
Public field | TopMost | Bot window away in top most (option found tab "Tools")
Public field | ToTrayBar | Minimize to tray bar (option found tab "Tools")
Public field | UseShortcuts | Use shortcuts, activate shortcuts to start/stop/pause bot (you need to restart bot to activate/disable this feature) (option found tab "Tools")
Public field | WaitTimeToRelogSeconds | Time to wait (second) before reconnecting after disconnection.
Public field | WindowName | Bot window name (empty to use default window name) (option found tab "Tools")
Public field | WRobotFileName | Security option used in few bot versions to assign name of generated executable bot launcher. The name is automatically generated but can be changed.
Public field | WRobotTmpFolderName | Security option used in few bot versions to assign folder where to save WRobotFileName. The name is automatically generated but can be changed.

Properties

Name | Description
CurrentSetting | Gets or sets the current global setting.
FilePath | Gets the file path.

See Also

wManagerGlobalSetting Class
wManager Namespace


wManagerGlobalSetting Fields

The wManagerGlobalSetting type exposes the following members.

Fields

 | Name | Description
Public field | BlacklistShow | Show blacklists (in map 2D and 3D tab "Map")
Public field | ByName | Show NPC/object by name (in map 2D and 3D tab "Map")
Public field | CloseGameIfAdminRights | Close the game if it has Administrator rights (Windows)
Public field | CloseIfCannotLoginWowMinutes | Close bot if cannot login ingame after X minutes (this option is only used if you are using the relloger application)
Public field | DriveLetter | Security option used in few bot versions to create fake drive that link to WRobotFileName folder.
Public field | FullWowPath | The path to Wow
Public field | HideLuaError | Hide in-game lua error
Public field | LowFps | Low FPS (in map 2D and 3D tab "Map")
Public field | LowQuality | Low quality (in map 2D and 3D tab "Map")
Public field | MaxFPS | Most versions require a minimum of FPS in-game to work properly. This option increase the "Maximum FPS" option in game if it is lower than the value of this option (https://wowwiki.fandom.com/wiki/CVar_maxFPS and https://wowwiki.fandom.com/wiki/CVar_maxFPSBk)
Public field | MaxLuaMemoryUsage | The maximum amount of memory in use by Lua (in kilobytes). If the value is greater than this option the bot uses the lua reload function.
Public field | MeShow | Show my character (in map 2D and 3D tab "Map")
Public field | NpcShow | Show NPCs (in map 2D and 3D tab "Map")
Public field | ObjectsShow | Show objects (in map 2D and 3D tab "Map")
Public field | PathShow | Show path (in map 2D and 3D tab "Map")
Public field | PlayersShow | Show other players (in map 2D and 3D tab "Map")
Public field | Remote | Activate remote option (to access to the bot from the website) (option found tab "Main")
Public field | TargetShow | Show target (in map 2D and 3D tab "Map")
Public field | TopMost | Bot window away in top most (option found tab "Tools")
Public field | ToTrayBar | Minimize to tray bar (option found tab "Tools")
Public field | UseShortcuts | Use shortcuts, activate shortcuts to start/stop/pause bot (you need to restart bot to activate/disable this feature) (option found tab "Tools")
Public field | WaitTimeToRelogSeconds | Time to wait (second) before reconnecting after disconnection.
Public field | WindowName | Bot window name (empty to use default window name) (option found tab "Tools")
Public field | WRobotFileName | Security option used in few bot versions to assign name of generated executable bot launcher. The name is automatically generated but can be changed.
Public field | WRobotTmpFolderName | Security option used in few bot versions to assign folder where to save WRobotFileName. The name is automatically generated but can be changed.

See Also

wManagerGlobalSetting Class
wManager Namespace


BlacklistShow Field

wManagerGlobalSetting..::..BlacklistShow Field

Show blacklists (in map 2D and 3D tab "Map")

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool BlacklistShow
Public BlacklistShow As Boolean
public:
bool^ BlacklistShow

See Also

wManagerGlobalSetting Class
wManager Namespace


ByName Field

wManagerGlobalSetting..::..ByName Field

Show NPC/object by name (in map 2D and 3D tab "Map")

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string ByName
Public ByName As String
public:
String^ ByName

See Also

wManagerGlobalSetting Class
wManager Namespace


CloseGameIfAdminRights Field

wManagerGlobalSetting..::..CloseGameIfAdminRights Field

Close the game if it has Administrator rights (Windows)

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool CloseGameIfAdminRights
Public CloseGameIfAdminRights As Boolean
public:
bool^ CloseGameIfAdminRights

See Also

wManagerGlobalSetting Class
wManager Namespace


CloseIfCannotLoginWowMinutes Field

wManagerGlobalSetting..::..CloseIfCannotLoginWowMinutes Field

Close bot if cannot login ingame after X minutes (this option is only used if you are using the relloger application)

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public double CloseIfCannotLoginWowMinutes
Public CloseIfCannotLoginWowMinutes As Double
public:
double^ CloseIfCannotLoginWowMinutes

See Also

wManagerGlobalSetting Class
wManager Namespace


DriveLetter Field

wManagerGlobalSetting..::..DriveLetter Field

Security option used in few bot versions to create fake drive that link to WRobotFileName folder.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string DriveLetter
Public DriveLetter As String
public:
String^ DriveLetter

See Also

wManagerGlobalSetting Class
wManager Namespace


FullWowPath Field

wManagerGlobalSetting..::..FullWowPath Field

The path to Wow

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string FullWowPath
Public FullWowPath As String
public:
String^ FullWowPath

See Also

wManagerGlobalSetting Class
wManager Namespace


HideLuaError Field

wManagerGlobalSetting..::..HideLuaError Field

Hide in-game lua error

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool HideLuaError
Public HideLuaError As Boolean
public:
bool^ HideLuaError

See Also

wManagerGlobalSetting Class
wManager Namespace


LowFps Field

wManagerGlobalSetting..::..LowFps Field

Low FPS (in map 2D and 3D tab "Map")

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool LowFps
Public LowFps As Boolean
public:
bool^ LowFps

See Also

wManagerGlobalSetting Class
wManager Namespace


LowQuality Field

wManagerGlobalSetting..::..LowQuality Field

Low quality (in map 2D and 3D tab "Map")

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool LowQuality
Public LowQuality As Boolean
public:
bool^ LowQuality

See Also

wManagerGlobalSetting Class
wManager Namespace


MaxFPS Field

wManagerGlobalSetting..::..MaxFPS Field

Most versions require a minimum of FPS in-game to work properly. This option increase the "Maximum FPS" option in game if it is lower than the value of this option (https://wowwiki.fandom.com/wiki/CVar_maxFPS and https://wowwiki.fandom.com/wiki/CVar_maxFPSBk)

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int MaxFPS
Public MaxFPS As Integer
public:
int^ MaxFPS

See Also

wManagerGlobalSetting Class
wManager Namespace


MaxLuaMemoryUsage Field

wManagerGlobalSetting..::..MaxLuaMemoryUsage Field

The maximum amount of memory in use by Lua (in kilobytes). If the value is greater than this option the bot uses the lua reload function.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int MaxLuaMemoryUsage
Public MaxLuaMemoryUsage As Integer
public:
int^ MaxLuaMemoryUsage

See Also

wManagerGlobalSetting Class
wManager Namespace


MeShow Field

wManagerGlobalSetting..::..MeShow Field

Show my character (in map 2D and 3D tab "Map")

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool MeShow
Public MeShow As Boolean
public:
bool^ MeShow

See Also

wManagerGlobalSetting Class
wManager Namespace


NpcShow Field

wManagerGlobalSetting..::..NpcShow Field

Show NPCs (in map 2D and 3D tab "Map")

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool NpcShow
Public NpcShow As Boolean
public:
bool^ NpcShow

See Also

wManagerGlobalSetting Class
wManager Namespace


ObjectsShow Field

wManagerGlobalSetting..::..ObjectsShow Field

Show objects (in map 2D and 3D tab "Map")

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool ObjectsShow
Public ObjectsShow As Boolean
public:
bool^ ObjectsShow

See Also

wManagerGlobalSetting Class
wManager Namespace


PathShow Field

wManagerGlobalSetting..::..PathShow Field

Show path (in map 2D and 3D tab "Map")

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool PathShow
Public PathShow As Boolean
public:
bool^ PathShow

See Also

wManagerGlobalSetting Class
wManager Namespace


PlayersShow Field

wManagerGlobalSetting..::..PlayersShow Field

Show other players (in map 2D and 3D tab "Map")

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool PlayersShow
Public PlayersShow As Boolean
public:
bool^ PlayersShow

See Also

wManagerGlobalSetting Class
wManager Namespace


Remote Field

wManagerGlobalSetting..::..Remote Field

Activate remote option (to access to the bot from the website) (option found tab "Main")

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool Remote
Public Remote As Boolean
public:
bool^ Remote

See Also

wManagerGlobalSetting Class
wManager Namespace


TargetShow Field

wManagerGlobalSetting..::..TargetShow Field

Show target (in map 2D and 3D tab "Map")

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool TargetShow
Public TargetShow As Boolean
public:
bool^ TargetShow

See Also

wManagerGlobalSetting Class
wManager Namespace


TopMost Field

wManagerGlobalSetting..::..TopMost Field

Bot window away in top most (option found tab "Tools")

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool TopMost
Public TopMost As Boolean
public:
bool^ TopMost

See Also

wManagerGlobalSetting Class
wManager Namespace


ToTrayBar Field

wManagerGlobalSetting..::..ToTrayBar Field

Minimize to tray bar (option found tab "Tools")

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool ToTrayBar
Public ToTrayBar As Boolean
public:
bool^ ToTrayBar

See Also

wManagerGlobalSetting Class
wManager Namespace


UseShortcuts Field

wManagerGlobalSetting..::..UseShortcuts Field

Use shortcuts, activate shortcuts to start/stop/pause bot (you need to restart bot to activate/disable this feature) (option found tab "Tools")

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool UseShortcuts
Public UseShortcuts As Boolean
public:
bool^ UseShortcuts

See Also

wManagerGlobalSetting Class
wManager Namespace


WaitTimeToRelogSeconds Field

wManagerGlobalSetting..::..WaitTimeToRelogSeconds Field

Time to wait (second) before reconnecting after disconnection.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int WaitTimeToRelogSeconds
Public WaitTimeToRelogSeconds As Integer
public:
int^ WaitTimeToRelogSeconds

See Also

wManagerGlobalSetting Class
wManager Namespace


WindowName Field

wManagerGlobalSetting..::..WindowName Field

Bot window name (empty to use default window name) (option found tab "Tools")

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string WindowName
Public WindowName As String
public:
String^ WindowName

See Also

wManagerGlobalSetting Class
wManager Namespace


WRobotFileName Field

wManagerGlobalSetting..::..WRobotFileName Field

Security option used in few bot versions to assign name of generated executable bot launcher. The name is automatically generated but can be changed.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string WRobotFileName
Public WRobotFileName As String
public:
String^ WRobotFileName

See Also

wManagerGlobalSetting Class
wManager Namespace


WRobotTmpFolderName Field

wManagerGlobalSetting..::..WRobotTmpFolderName Field

Security option used in few bot versions to assign folder where to save WRobotFileName. The name is automatically generated but can be changed.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string WRobotTmpFolderName
Public WRobotTmpFolderName As String
public:
String^ WRobotTmpFolderName

See Also

wManagerGlobalSetting Class
wManager Namespace


wManagerGlobalSetting Methods

The wManagerGlobalSetting type exposes the following members.

Methods

 | Name | Description
Protected method | ConfigWinForm | (Inherited from Settings.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
 | Load | Loads instance from FilePath.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Save()()()() | Saves instance to FilePath..
Protected method | Save(String) | Save to xml file (Inherited from Settings.)
Public method | ToForm | Converts to form. (Inherited from Settings.)
Public method | ToString | (Inherited from Object.)
Public method | ToStringFormat | Converts to stringformat. (Inherited from Settings.)

See Also

wManagerGlobalSetting Class
wManager Namespace


Load Method

wManagerGlobalSetting..::..Load Method

Loads instance from FilePath.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool Load()
Public Shared Function Load As Boolean
public:
static bool^ Load()

Return Value

true if success, false otherwise.

See Also

wManagerGlobalSetting Class
wManager Namespace


Save Method

wManagerGlobalSetting..::..Save Method

Overload List

 | Name | Description
Public method | Save()()()() | Saves instance to FilePath..
Protected method | Save(String) | Save to xml file (Inherited from Settings.)

See Also

wManagerGlobalSetting Class
wManagerGlobalSetting Members
wManager Namespace


Save Method

wManagerGlobalSetting..::..Save Method

Saves instance to FilePath..

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool Save()
Public Function Save As Boolean
public:
bool^ Save()

Return Value

true if success, false otherwise.

See Also

wManagerGlobalSetting Class
wManager Namespace


wManagerGlobalSetting Properties

The wManagerGlobalSetting type exposes the following members.

Properties

Name | Description
CurrentSetting | Gets or sets the current global setting.
FilePath | Gets the file path.

See Also

wManagerGlobalSetting Class
wManager Namespace


CurrentSetting Property

wManagerGlobalSetting..::..CurrentSetting Property

Gets or sets the current global setting.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static wManagerGlobalSetting CurrentSetting { get; set; }
Public Shared Property CurrentSetting As wManagerGlobalSetting
    Get
    Set
public:
static property wManagerGlobalSetting^ CurrentSetting {
    wManagerGlobalSetting^ get ();
    void set (wManagerGlobalSetting^ value);
}

Field Value

The current setting.

See Also

wManagerGlobalSetting Class
wManager Namespace


FilePath Property

wManagerGlobalSetting..::..FilePath Property

Gets the file path.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string FilePath { get; }
Public Shared ReadOnly Property FilePath As String
    Get
public:
static property String^ FilePath {
    String^ get ();
}

Field Value

The file path.

See Also

wManagerGlobalSetting Class
wManager Namespace


wManagerSetting Class

Class wManagerSetting. This class contains options attached to the used character. It also contains the session blacklists.

File is in folder "WRobot\Settings\", file name format is: Settings.AdviserFilePathAndName("General", ObjectManager.Me.Name + "." + Usefuls.RealmName) (result like "WRobot\Settings\General-PlayerName.RealmName.xml")

Implements the Settings

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class wManagerSetting : Settings
<SerializableAttribute> _
Public Class wManagerSetting _
    Inherits Settings
[SerializableAttribute]
public ref class wManagerSetting : public Settings

Inheritance Hierarchy

Object
robotManager.Helpful..::..Settings
wManager..::..wManagerSetting

See Also

wManagerSetting Members
wManager Namespace
robotManager.Helpful..::..Settings


wManagerSetting Members

The wManagerSetting type exposes the following members.

Methods

 | Name | Description
 | AddBlackList | Adds GUID to blacklist
 | AddBlackListNpcEntry | Add to entry id blacklist.
 | AddBlackListZone(Vector3, Single, Boolean) | Add zone to blacklisted zones.
 | AddBlackListZone(Vector3, Single, PolyArea, Boolean) | Add zone to blacklisted zones.
 | AddBlackListZone(Vector3, Single, ContinentId, PolyArea, Boolean) | Add zone to blacklisted zones.
 | AddBlackListZone(BlackListSerializable..::..Blackspot, Boolean) | Add zone to blacklisted zones.
 | AddBlackListZoneRectangle | Add zone to rectangle blacklisted zones.
 | AddRangeBlackListZone | Add range zones to blacklist .
 | AddToBlacklistCurrentProductSession | Adds blacklist of current product (blacklist added with param isSessionBlacklist = true) to blacklist, this is called by AddBlackListToWRobotSession()()()())
 | ClearBlacklist | Clear all blacklists (zone, guid, entry).
 | ClearBlacklistOfCurrentProductSession | Clear blacklists of current product (blacklist added with param isSessionBlacklist = true, generally it is the blacklist contained in the profile, it is added to blacklist with method AddToBlacklistCurrentProductSession()()()()) This method is called when product start.
Protected method | ConfigWinForm | (Inherited from Settings.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
 | GetListGuidBlackListed | Gets list of GUID blacklisted.
 | GetListZoneBlackListed | Get list of blacklisted zones.
 | GetListZoneBlackListedRectangle | Get list of blacklisted rectangle zones.
Public method | GetType | (Inherited from Object.)
 | IsBlackListed | Determines GUID is blacklisted
 | IsBlackListedAllConditions(WoWUnit) | Determines if unit is blacklisted (position, guid or entry id).
 | IsBlackListedAllConditions(WoWGameObject) | Determines if game object is blacklisted (position, guid or entry id).
 | IsBlackListedAllConditions(Int32, Vector3, UInt64) | Determines if is blacklisted (position, guid or entry id).
 | IsBlackListedNpcEntry | Determines if entry id blacklisted.
 | IsBlackListedZone | Determine if position is blacklisted.
 | Load | Loads the specified load blacklist.
 | MaxUnitNearest(WoWUnit, Int32) | Check if there are more than MaxUnitsNearMobs hostiles units near (in aggro distance) the unit.
 | MaxUnitNearest(WoWGameObject, Int32) | Check if there are more than MaxUnitsNearObjects hostiles units near (in aggro distance) the gameobject.
 | MaxUnitNearest(Vector3, Int32, Int32%, UInt64, Single, Single) | Check if there are more than maxUnitsNear hostiles "units" near (in aggro distance) of the "position".
Protected method | MemberwiseClone | (Inherited from Object.)
 | RemoveBlackList | Removes GUID from blacklist.
Public method | Save()()()() | Saves this instance.
Public method | Save(Boolean, Boolean) | Saves the specified write in log.
Protected method | Save(String) | Save to xml file (Inherited from Settings.)
Public method | ToForm | Converts to form. (Inherited from Settings.)
Public method | ToString | (Inherited from Object.)
Public method | ToStringFormat | Converts to string (dump settings).
 | UnitAggroRange | Get hostiles units who have in their aggro distance of the "position".

Fields

 | Name | Description
Public field | AcceptOnlyProfileNpc | Accept only NPC (vendor, repair, ...) of the product profile (don't use NPC already in NpcDB, when you start product he adds NPCs to the NpcDB with CurrentProfileNpc at true, when you use AcceptOnlyProfileNpc option bot search only NPC with Npc.CurrentProfileNpc = true).
Public field | BlacklistGameObjectDefaultTimeMs | GameObject blacklist default time (in millisecond) (herbs, mines, chest, ...)
Public field | BlacklistTaxiDefaultTimeMs | Taxi blacklist default time (in millisecond)
Public field | BlacklistUnitDefaultTimeMs | Unit blacklist default time (in millisecond) (mobs, npc)
Public field | CustomClass | FightClass selected, file name like "MyFightclass.xml" (fightclasses are in folder "WRobot\FightClass\")
Public field | DetectEvadingMob | Detect evading mob and leave combat
Public field | DismountLandGroundDistance | Dismount flying mount ground distance (when Land(Single, Single) 0 to dismount when hit the ground)
Public field | DismountWhenStuck | Dismount when character seems stuck
Public field | DrinkMaxPercent | Stop character regen if more than X % of mana.
Public field | EquipAvailableBagIfFreeContainerSlot | Equip available bag if free container slot
Public field | EventsLuaWithArgsWaitTime | Refresh time of EventsLuaWithArgs (read new in game events) (in milliseconds)
Public field | FightInteractTargetMinDistance | Interact with target during fight if distance is lower than X even if not line of sight
Public field | FoodMaxPercent | Stop character regen if more than X % of health.
Public field | ForceAutoLoot | Force auto loot
Public field | HearthstoneAfterXBlockagesLatest10Minutes | Use hearthstone after x blockages latest 10 minutes (0 to disable, see also HearthstoneNameOrIdAfterXBlockagesLatest10Minutes)
Public field | HearthstoneNameOrIdAfterXBlockagesLatest10Minutes | Hearthstone item name or id (used with HearthstoneAfterXBlockagesLatest10Minutes)
Public field | IgnoreFightWhenInMove | Ignore fight when traveling
Public field | IgnoreFightWithPlayer | Ignore combat with other players
Public field | IgnoreServerRoadsWater | If you don't want use roads and water of the PathFinder server (the bot take the shortest paths instead of the roads)
Public field | KeyBindingMacro | Key used to run macro when you call RunMacroTextHW(String)
Public field | KeyboardToTurn | Use keyboard to turn (instead of direct rotation)
Public field | LastProductSelected | The last product used (used at startup to select last product)
Public field | LootAndHarvestRangeQuickly | The loot and harvest quickly if in interact range (FarmingRange and LootingRange)
Public field | LootInCombat | Loot in combat
Public field | MaxCheckIfGoodMouseShortcutsWhenInteract | Some GM change your mouse buttons shortcut (to no longer be able to interact with unit/object), try to detect that (0 to disable this option)
Public field | MaxTryPerNode | Number maximum of try per node (farming)
Public field | MaxUnitsNearMobs | The maximum units near mobs MaxUnitNearest(WoWUnit, Int32)
Public field | MaxUnitsNearObjects | The maximum units near objects MaxUnitNearest(WoWUnit, Int32)
Public field | MaxZDistanceAttack | Maximum z distance to start attack
Public field | MaxZDistanceFarm | Maximum z distance to go farming node
Public field | MaxZDistanceIsAttacked | Maximum z distance to defend oneself when mobs attack character
Public field | MyMacro1 | My macro 1
Public field | MyMacro2 | My macro 2
Public field | MyMacro3 | My macro 3
Public field | MyMacro4 | My macro 4
Public field | NewUserSettings | This value is true only if settings was created with new instance (false if was loaded from xml file) (assigned in Load(Boolean)).
Public field | NpcScanAuctioneer | Automatically add nearest Npc auctioneer to NpcDB.
Public field | NpcScanMailboxes | Automatically add nearest Mailbox to NpcDB.
Public field | NpcScanRepair | Automatically add nearest Npc repair to NpcDB.
Public field | NpcScanVendor | Automatically add nearest Npc vendor to NpcDB.
Public field | OffMeshConnectionsSearchDistance | The off mesh connections search distance
Public field | PathFinderFromServer | Use PathFinder server (else use local pathfinder but it is no longer available on recent versions of the bot)
Public field | PathFinderRequestLog | Request pathfinder server log
Public field | PathFinderRequestTimeoutMs | Pathfinder server request timeout (in milliseconds)
Public field | PathFinderServerSeemDownPauseBotTimeSec | How many time pause bot (in seconds) when pathfinder server seems down
Public field | PluginsSettings | Plugins list (when user removes a plugin from the folder ("WRobot/Plugins/") it remains in this list, but only plugins present in the folder are displayed tab "Plugins")
Public field | RandomJumping | Jump randomly during travel.
Public field | ReadObjectManagerFTS | Number of ObjectManager refreshes per second (a high value is better, but also uses a lot more CPU)
Public field | RecordChatInLog | Write Wow chat messages in log file.
Public field | RetrieveCorpseMaxDistance | Max distance of the character corpse to retrieve corpse
Public field | SaveWindowPosition | Save bot window position
Public field | SearchRadiusMobs | Mobs search distance (mainly grinding).
Public field | SearchRadiusObjects | GameObject search distance (mainly farming).
Public field | SizeHeight | Last bot window height
Public field | SizeWidth | Last bot window width.
Public field | SkipInOutDoors | Skip node inside if character is outside, and skip node outside if character is inside.
Public field | SkipNodesInWater | Skip nodes in water
Public field | SkipRegenIfFlaggedInCombat | Skip regen if flagged in combat
Public field | SmoothPath | Smoothing paths generated by PathFinder (makes movement a little more human, in very rare cases can add blockages).
Public field | SmoothPathDistance | Smoothing paths distance (1.0 by default, option for SmoothPathDistance).
Public field | TryToAvoidEnemyGroupsRatio | Try to avoid group of mobs (Ratio), 0 to disable, recommended value is ~1.2 (Bot will add up all the level of the mobs and divide it by the level of your character, if the result gives a ratio higher than the given hi will try to avoid zone)
Public field | TryToUseBestBagFoodDrink | Try to use best food and drink available in the bag.
Public field | UseCTM | To use CTM (click to move in game option)
Public field | UseSpiritHealerAfterXDeathsLatest10Minutes | The use spirit healer after x deaths latest10 minutes
Public field | WaitWhenBuffWaitingToResurrect | Wait when character has buff "Waiting to Resurrect"
Public field | WindowPosX | Last bot window position x (need option SaveWindowPosition)
Public field | WindowPosY | Last bot window position y (need option SaveWindowPosition)

Properties

 | Name | Description
Public property | AccountEmail | Account email (or account name on old Wow version) (you need to activate Relogger).
Public property | AccountPassword | Account password (you need to activate Relogger).
Public property | AddToNpcDb | Add NPCs of used profiles to your NpcDB.
Public property | AquaticMountName | Gets or sets the name of the aquatic mount (like it appears in game).
Public property | AssignTalents | Assign Talents (no used in all WRobot version, used in Talents)
Public property | AttackBeforeBeingAttacked | Attack before being attacked (Start the fight when the character is close to the mob's aggro zone. It allows to be more reactive, but this option is not always reliable (it depends on the server and the version of the game)).
Public property | AttackElite | Can start fight with elite mobs (in any case the bot will attack if it is attacked).
Public property | AvoidBlacklistedZonesPathFinder | Avoid blacklisted zones with the paths generated by the PathFinder.
Public property | AvoidWallWithRays | Try to avoid wall and small obstacle not in pathfinder with rays (TraceLine).
Public property | BlackListHarvest | List of gameobjects entry id to not harvest.
Public property | BlackListHarvestByName | List of gameobjects name to not harvest.
Public property | BlackListIfNotCompletePath | Blacklist mobs, NPCs, nodes... if cannot found complete path (if PathFinder return partial or no success result)
Public property | BlackListTrainingDummy | Blacklist training dummy.
Public property | BlackListZoneWhereDead | Automatically blacklist the zone where the character is dead (with 30 y radius), some products like grinder, quester and automaton override this value with their values.
Public property | BNetName | Account name (you need to activate Relogger).
Public property | BuyList | List of items to buy.
Public property | CalcuCombatRange | Calculate interact/combat distance by target size (CombatReach, on some servers this option is bugged).
Public property | CanAttackUnitsAlreadyInFight | Gets or sets a value indicating whether this instance can attack units already in combat.
Public property | CloseAfterXBlockagesActive | Close after CloseAfterXBlockagesLatest10Minutes blockages latest 10 minutes.
Public property | CloseAfterXBlockagesLatest10Minutes | Close game after x blockages latest 10 minutes (you need to use option CloseAfterXBlockagesActive).
Public property | CloseAfterXDeathsActive | Close after CloseAfterXDeathsLatest10Minutes deaths latest 10 minutes.
Public property | CloseAfterXDeathsLatest10Minutes | Close after x deaths latest 10 minutes (you need to use option CloseAfterXDeathsActive).
Public property | CloseAfterXLevel | Close the game after increasing your level by X levels.
Public property | CloseAfterXMin | Close game after x minutes (you need to activate CloseAfterXMinActive).
Public property | CloseAfterXMinActive | Close bot after CloseAfterXMin minutes.
Public property | CloseIfFullBag | Close game when bag is full.
Public property | CloseIfPlayerTeleported | Close game if character seems to have been teleported (GM can use this method, but there may be false detection, by example when character continent change, when using the hearthstone, ...).
Public property | CloseIfReached4000HonorPoints | Close game if you have more than 4000 honor points
Public property | CloseIfWhisperBiggerOrEgalAt | Close the game If you have received more or egal at X whispers
 | CurrentSetting | Gets or sets the current character setting.
Public property | DetectNodesStuck | Detect nodes stuck (test if can landing)
Public property | DisableNearPlayerToTown | Don't pause bot is player nerby when character go to town (option for SecurityPauseBotIfNerbyPlayer)
Public property | DoNotMailList | List of items names to not send by mail (this option override item quality filter options, you need to activate option UseMail).
Public property | DoNotSellList | List of items names to not sell (this option override item quality filter options, you need to activate option Selling).
Public property | DontStartFighting | Gets or sets a value indicating to don't start fight (defend oneself only).
Public property | DrinkAmount | Number of DrinkName item to buy (0 to don't buy food, you need to have food vendor in your profile of NpcDB)
Public property | DrinkIsSpell | DrinkName is spell name (not item)
Public property | DrinkName | Gets or sets the name of the drink (like it appears in game).
Public property | DrinkPercent | Start character regen if less than X % of mana.
Public property | FlightMasterDiscoverRange | Flightmasters discover range (0 to don't discover unknown flightmasters (with green exclamation)).
Public property | FlightMasterTaxiDistance | Flightmaster search distance (to take only is nearby taxi use FlightMasterTaxiUseOnlyIfNear, you need to use option FlightMasterTaxiUse).
Public property | FlightMasterTaxiUse | Take taxi (from FlightMaster) if can.
Public property | FlightMasterTaxiUseOnlyIfNear | Take taxi only if flightmaster is nearby (else the bot searchs by distance with FlightMasterTaxiDistance, you need to use option FlightMasterTaxiUse).
Public property | FlyAboveGroundHeight | When the bot uses the flying mount on a normal (ground) path how high to fly?
Public property | FlyingMountName | Gets or sets the name of the flying mount (like it appears in game).
Public property | FoodAmount | Number of FoodName item to buy (0 to don't buy food, you need to have food vendor in your profile of NpcDB)
Public property | FoodIsSpell | FoodName is spell name (not item)
Public property | FoodName | Gets or sets the name of the food (like it appears in game).
Public property | FoodPercent | Start character regen if less than X % of health.
Public property | ForceMailList | List of items names to send by mail (this option override item quality filter options, you need to activate option UseMail).
Public property | ForceSellList | List of items names to sell (this option override item quality filter options, you need to activate option Selling).
Public property | GoToTownHerbBags | Go to town when herb bags are fulls.
Public property | GoToTownMiningBags | Go to town when mining bags are fulls.
Public property | GroundMountName | The name of the ground mount (like it appears in game).
Public property | HarvestAvoidPlayersRadius | Cancel farm if another player is within X yards (0 to don't avoid players).
Public property | HarvestDuringLongMove | Harvest (farming) during long move.
Public property | HarvestHerbs | Harvest herbs.
Public property | HarvestMinerals | Harvest minerals.
Public property | HarvestTimber | Harvest timber.
Public property | HelpingGroupMembers | Helping party members (if one of the members is attacked you will help him) (the bot will consider that your character is attacked if a member of your group is attacked).
Public property | IgnoreCombatWithPet | Ignore combat with pet.
Public property | IgnoredNerbyPlayer | List if accepted players when you activate option SecurityPauseBotIfNerbyPlayer
Public property | IgnoreFightDuringFarmIfDruidForm | Ignore fight during farm when in druid form (bot skip node if he is attacked and don't harvest the gameboject).
Public property | IgnoreFightGoundMount | Ignore fight when in mount
Public property | LatencyMax | Use this value if real latency is bigger than this value (look also LatencyMin, bot use latency time to wait after action (https://wow.gamepedia.com/API_GetNetStats realLatency = latencyHome + latencyWorld), but sometime result is bad).
Public property | LatencyMin | Use this value if real latency is smaller than this value (look also LatencyMax, bot use latency time to wait after action (https://wow.gamepedia.com/API_GetNetStats realLatency = latencyHome + latencyWorld), but sometime result is bad).
Public property | ListHarvest | List of gameobjects entry id to harvest.
Public property | ListHarvestByName | List of gameobjects name to harvest.
Public property | LootChests | Loot chests
Public property | LootMobs | Loot mobs corpses (Looting and LootingRange)
Public property | MailBlue | Send blue items (you need to activate option UseMail).
Public property | MailGray | Send gray items (you need to activate option UseMail).
Public property | MailGreen | Send green items (you need to activate option UseMail).
Public property | MailPurple | Send purple items (you need to activate option UseMail).
Public property | MailRecipient | Mail recipient name (you need to activate option UseMail).
Public property | MailSubject | Mail subject (you need to activate option UseMail).
Public property | MailWhite | Send white items (you need to activate option UseMail).
Public property | MaxUnitsNear | Obsolete. Obsolete, use MaxUnitsNearMobs and MaxUnitsNearObjects
Public property | Milling | Milling (MillingState, don't forget to complete MillingList).
Public property | MillingInTown | Milling when go to town.
Public property | MillingList | Milling items list (like the name appears in game, you need to enable Milling).
Public property | MillingTime | Milling every X minutes (you need to enable Milling).
Public property | MinFreeBagSlotsToGoToTown | Minimum free bag slots to go to town.
Public property | MountDistance | Required minimum path distance to use mount (if it is path loop, bot use mount without distance check)
Public property | NpcMailboxSearchRadius | NPC (Npc vendor, repair, ...) and Mailbox search radius
Public property | PathFinderPostionOffset | Pathfinder is too precise, sometimes you have to be exactly at position A to be able to reach position B without any obstacle. The problem is that the bot cannot go exactly to position A (CTM not always precise and this cause sudden movement because it stops move when it gets to the position). This option allows you to shift away the position of the position A (1.0 by default) which allows the bot to go to point B when distance to position A is PathFinderPostionOffset (the character is actually at the original position of point A).
Public property | Prospecting | Prospecting, you need to complete ProspectingList and ProspectingTime or ProspectingInTown.
Public property | ProspectingInTown | Prospecting when go to town (you need to enable Prospecting).
Public property | ProspectingList | Prospecting items list (like the name appears in game, you need to enable Prospecting).
Public property | ProspectingTime | Prospecting every X minutes (you need to enable Prospecting).
Public property | Relogger | Relogge player when disconnected (you need to complete AccountEmail, AccountPassword, BNetName)
Public property | Repair | Repair when go to town.
Public property | RestingMana | Regen character mana
Public property | SearchRadius | Obsolete. Obsolete, use SearchRadiusMobs and SearchRadiusObjects
Public property | SecurityPauseBotIfNerbyPlayer | Pause Bot if nearby other player (combined with options SecurityPauseBotIfNerbyPlayerRadius, SecurityPauseBotIfNerbyPlayerTime, IgnoredNerbyPlayer, DisableNearPlayerToTown).
Public property | SecurityPauseBotIfNerbyPlayerRadius | Nearby player search radius (option for SecurityPauseBotIfNerbyPlayer)
Public property | SecurityPauseBotIfNerbyPlayerTime | Nearby player since X seconds before to pause bot (option for SecurityPauseBotIfNerbyPlayer)
Public property | SecurityRecordWhisperInLogFile | Obsolete. Obsolete, RecordChatInLog
Public property | SecurityShutdownComputer | After to close the game, shutdown computer.
Public property | SecuritySongIfNewWhisper | Play song if new whisper (if you want use custom song, you can put song file at "WRobot\Data\newWhisper.wav").
Public property | SellBlue | Sell all blue items (you need to activate option Selling).
Public property | SellGray | Sell all gray items (you need to activate option Selling).
Public property | SellGreen | Sell all green items (you need to activate option Selling).
Public property | Selling | Sell the bag items when go to town (look options SellGray, SellWhite, SellGreen, SellBlue, SellPurple, DoNotSellList, ForceSellList).
Public property | SellPurple | Sell all purple items (you need to activate option Selling).
Public property | SellWhite | Sell all white items (you need to activate option Selling).
Public property | SkinMobs | Skin mobs killed by character (enable SkinNinja to skin all corpse available).
Public property | SkinNinja | Skin all corpse available (you need to active option SkinMobs).
Public property | Smelting | Smelting (SmeltingState, you need to add in NpcDB fake NPC type NpcType.Smelting nearest smelting zone).
Public property | SpellRotationSpeed | Try improve spells rotation speed, don't wait that cast finished before to cast new spell (we lose reliability)
Public property | ToTownTimer | Force to go to town every X minutes (you need to activate ToTownTimerActivated)
Public property | ToTownTimerActivated | Activate go to town every ToTownTimer minutes
Public property | TrainNewSkills | Train New Skills (used in Trainers)
Public property | UnlockMaxFps | Most versions of bot works better with high FPS in-game (but this use more CPU and RAM. This option unlock the "Maximum FPS" option in game (https://wowwiki.fandom.com/wiki/CVar_maxFPS and https://wowwiki.fandom.com/wiki/CVar_maxFPSBk)
Public property | UseFlyingMount | Use flying mount (need FlyingMountName)
Public property | UseGroundMount | Gets or sets a value indicating whether [use ground mount].
Public property | UseLuaToMove | Use lua api to move (otherwise the bot simulate keyboard keys).
Public property | UseMail | Send items by email when the bot goes to town (look options MailRecipient, MailSubject, UseMollE, MailGray, MailWhite, MailGreen, MailBlue, MailPurple, DoNotMailList, ForceMailList).
Public property | UseMammoth | Use "Traveler's Tundra Mammoth" to repair and sell instead of go to town
Public property | UseMollE | Use MOLL-E item instead of to go to Mailbox (you need to activate option UseMail).
Public property | UseMount | Use ground mount (need GroundMountName)
Public property | UsePathsFinder | Use PathFinder (if this option is disabled it goes from position A to position B without avoiding obstacles).
Public property | UseSpiritHealer | Use spirit healer to revive
Public property | WaitResurrectionSickness | Wait when character has debuff "Resurrection Sickness" (after resurrect at the "Spirit Healer")
Public property | WallDistancePathFinder | Wall distance of generated path by PathFinder (sometime this option can return a funny path).

See Also

wManagerSetting Class
wManager Namespace


wManagerSetting Fields

The wManagerSetting type exposes the following members.

Fields

 | Name | Description
Public field | AcceptOnlyProfileNpc | Accept only NPC (vendor, repair, ...) of the product profile (don't use NPC already in NpcDB, when you start product he adds NPCs to the NpcDB with CurrentProfileNpc at true, when you use AcceptOnlyProfileNpc option bot search only NPC with Npc.CurrentProfileNpc = true).
Public field | BlacklistGameObjectDefaultTimeMs | GameObject blacklist default time (in millisecond) (herbs, mines, chest, ...)
Public field | BlacklistTaxiDefaultTimeMs | Taxi blacklist default time (in millisecond)
Public field | BlacklistUnitDefaultTimeMs | Unit blacklist default time (in millisecond) (mobs, npc)
Public field | CustomClass | FightClass selected, file name like "MyFightclass.xml" (fightclasses are in folder "WRobot\FightClass\")
Public field | DetectEvadingMob | Detect evading mob and leave combat
Public field | DismountLandGroundDistance | Dismount flying mount ground distance (when Land(Single, Single) 0 to dismount when hit the ground)
Public field | DismountWhenStuck | Dismount when character seems stuck
Public field | DrinkMaxPercent | Stop character regen if more than X % of mana.
Public field | EquipAvailableBagIfFreeContainerSlot | Equip available bag if free container slot
Public field | EventsLuaWithArgsWaitTime | Refresh time of EventsLuaWithArgs (read new in game events) (in milliseconds)
Public field | FightInteractTargetMinDistance | Interact with target during fight if distance is lower than X even if not line of sight
Public field | FoodMaxPercent | Stop character regen if more than X % of health.
Public field | ForceAutoLoot | Force auto loot
Public field | HearthstoneAfterXBlockagesLatest10Minutes | Use hearthstone after x blockages latest 10 minutes (0 to disable, see also HearthstoneNameOrIdAfterXBlockagesLatest10Minutes)
Public field | HearthstoneNameOrIdAfterXBlockagesLatest10Minutes | Hearthstone item name or id (used with HearthstoneAfterXBlockagesLatest10Minutes)
Public field | IgnoreFightWhenInMove | Ignore fight when traveling
Public field | IgnoreFightWithPlayer | Ignore combat with other players
Public field | IgnoreServerRoadsWater | If you don't want use roads and water of the PathFinder server (the bot take the shortest paths instead of the roads)
Public field | KeyBindingMacro | Key used to run macro when you call RunMacroTextHW(String)
Public field | KeyboardToTurn | Use keyboard to turn (instead of direct rotation)
Public field | LastProductSelected | The last product used (used at startup to select last product)
Public field | LootAndHarvestRangeQuickly | The loot and harvest quickly if in interact range (FarmingRange and LootingRange)
Public field | LootInCombat | Loot in combat
Public field | MaxCheckIfGoodMouseShortcutsWhenInteract | Some GM change your mouse buttons shortcut (to no longer be able to interact with unit/object), try to detect that (0 to disable this option)
Public field | MaxTryPerNode | Number maximum of try per node (farming)
Public field | MaxUnitsNearMobs | The maximum units near mobs MaxUnitNearest(WoWUnit, Int32)
Public field | MaxUnitsNearObjects | The maximum units near objects MaxUnitNearest(WoWUnit, Int32)
Public field | MaxZDistanceAttack | Maximum z distance to start attack
Public field | MaxZDistanceFarm | Maximum z distance to go farming node
Public field | MaxZDistanceIsAttacked | Maximum z distance to defend oneself when mobs attack character
Public field | MyMacro1 | My macro 1
Public field | MyMacro2 | My macro 2
Public field | MyMacro3 | My macro 3
Public field | MyMacro4 | My macro 4
Public field | NewUserSettings | This value is true only if settings was created with new instance (false if was loaded from xml file) (assigned in Load(Boolean)).
Public field | NpcScanAuctioneer | Automatically add nearest Npc auctioneer to NpcDB.
Public field | NpcScanMailboxes | Automatically add nearest Mailbox to NpcDB.
Public field | NpcScanRepair | Automatically add nearest Npc repair to NpcDB.
Public field | NpcScanVendor | Automatically add nearest Npc vendor to NpcDB.
Public field | OffMeshConnectionsSearchDistance | The off mesh connections search distance
Public field | PathFinderFromServer | Use PathFinder server (else use local pathfinder but it is no longer available on recent versions of the bot)
Public field | PathFinderRequestLog | Request pathfinder server log
Public field | PathFinderRequestTimeoutMs | Pathfinder server request timeout (in milliseconds)
Public field | PathFinderServerSeemDownPauseBotTimeSec | How many time pause bot (in seconds) when pathfinder server seems down
Public field | PluginsSettings | Plugins list (when user removes a plugin from the folder ("WRobot/Plugins/") it remains in this list, but only plugins present in the folder are displayed tab "Plugins")
Public field | RandomJumping | Jump randomly during travel.
Public field | ReadObjectManagerFTS | Number of ObjectManager refreshes per second (a high value is better, but also uses a lot more CPU)
Public field | RecordChatInLog | Write Wow chat messages in log file.
Public field | RetrieveCorpseMaxDistance | Max distance of the character corpse to retrieve corpse
Public field | SaveWindowPosition | Save bot window position
Public field | SearchRadiusMobs | Mobs search distance (mainly grinding).
Public field | SearchRadiusObjects | GameObject search distance (mainly farming).
Public field | SizeHeight | Last bot window height
Public field | SizeWidth | Last bot window width.
Public field | SkipInOutDoors | Skip node inside if character is outside, and skip node outside if character is inside.
Public field | SkipNodesInWater | Skip nodes in water
Public field | SkipRegenIfFlaggedInCombat | Skip regen if flagged in combat
Public field | SmoothPath | Smoothing paths generated by PathFinder (makes movement a little more human, in very rare cases can add blockages).
Public field | SmoothPathDistance | Smoothing paths distance (1.0 by default, option for SmoothPathDistance).
Public field | TryToAvoidEnemyGroupsRatio | Try to avoid group of mobs (Ratio), 0 to disable, recommended value is ~1.2 (Bot will add up all the level of the mobs and divide it by the level of your character, if the result gives a ratio higher than the given hi will try to avoid zone)
Public field | TryToUseBestBagFoodDrink | Try to use best food and drink available in the bag.
Public field | UseCTM | To use CTM (click to move in game option)
Public field | UseSpiritHealerAfterXDeathsLatest10Minutes | The use spirit healer after x deaths latest10 minutes
Public field | WaitWhenBuffWaitingToResurrect | Wait when character has buff "Waiting to Resurrect"
Public field | WindowPosX | Last bot window position x (need option SaveWindowPosition)
Public field | WindowPosY | Last bot window position y (need option SaveWindowPosition)

See Also

wManagerSetting Class
wManager Namespace


AcceptOnlyProfileNpc Field

wManagerSetting..::..AcceptOnlyProfileNpc Field

Accept only NPC (vendor, repair, ...) of the product profile (don't use NPC already in NpcDB, when you start product he adds NPCs to the NpcDB with CurrentProfileNpc at true, when you use AcceptOnlyProfileNpc option bot search only NPC with Npc.CurrentProfileNpc = true).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool AcceptOnlyProfileNpc
Public AcceptOnlyProfileNpc As Boolean
public:
bool^ AcceptOnlyProfileNpc

See Also

wManagerSetting Class
wManager Namespace


BlacklistGameObjectDefaultTimeMs Field

wManagerSetting..::..BlacklistGameObjectDefaultTimeMs Field

GameObject blacklist default time (in millisecond) (herbs, mines, chest, ...)

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int BlacklistGameObjectDefaultTimeMs
Public BlacklistGameObjectDefaultTimeMs As Integer
public:
int^ BlacklistGameObjectDefaultTimeMs

See Also

wManagerSetting Class
wManager Namespace


BlacklistTaxiDefaultTimeMs Field

wManagerSetting..::..BlacklistTaxiDefaultTimeMs Field

Taxi blacklist default time (in millisecond)

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int BlacklistTaxiDefaultTimeMs
Public BlacklistTaxiDefaultTimeMs As Integer
public:
int^ BlacklistTaxiDefaultTimeMs

See Also

wManagerSetting Class
wManager Namespace


BlacklistUnitDefaultTimeMs Field

wManagerSetting..::..BlacklistUnitDefaultTimeMs Field

Unit blacklist default time (in millisecond) (mobs, npc)

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int BlacklistUnitDefaultTimeMs
Public BlacklistUnitDefaultTimeMs As Integer
public:
int^ BlacklistUnitDefaultTimeMs

See Also

wManagerSetting Class
wManager Namespace


CustomClass Field

wManagerSetting..::..CustomClass Field

FightClass selected, file name like "MyFightclass.xml" (fightclasses are in folder "WRobot\FightClass\")

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string CustomClass
Public CustomClass As String
public:
String^ CustomClass

See Also

wManagerSetting Class
wManager Namespace


DetectEvadingMob Field

wManagerSetting..::..DetectEvadingMob Field

Detect evading mob and leave combat

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool DetectEvadingMob
Public DetectEvadingMob As Boolean
public:
bool^ DetectEvadingMob

See Also

wManagerSetting Class
wManager Namespace


DismountLandGroundDistance Field

wManagerSetting..::..DismountLandGroundDistance Field

Dismount flying mount ground distance (when Land(Single, Single) 0 to dismount when hit the ground)

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float DismountLandGroundDistance
Public DismountLandGroundDistance As Single
public:
float^ DismountLandGroundDistance

See Also

wManagerSetting Class
wManager Namespace


DismountWhenStuck Field

wManagerSetting..::..DismountWhenStuck Field

Dismount when character seems stuck

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool DismountWhenStuck
Public DismountWhenStuck As Boolean
public:
bool^ DismountWhenStuck

See Also

wManagerSetting Class
wManager Namespace


DrinkMaxPercent Field

wManagerSetting..::..DrinkMaxPercent Field

Stop character regen if more than X % of mana.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int DrinkMaxPercent
Public DrinkMaxPercent As Integer
public:
int^ DrinkMaxPercent

See Also

wManagerSetting Class
wManager Namespace


EquipAvailableBagIfFreeContainerSlot Field

wManagerSetting..::..EquipAvailableBagIfFreeContainerSlot Field

Equip available bag if free container slot

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool EquipAvailableBagIfFreeContainerSlot
Public EquipAvailableBagIfFreeContainerSlot As Boolean
public:
bool^ EquipAvailableBagIfFreeContainerSlot

See Also

wManagerSetting Class
wManager Namespace


EventsLuaWithArgsWaitTime Field

wManagerSetting..::..EventsLuaWithArgsWaitTime Field

Refresh time of EventsLuaWithArgs (read new in game events) (in milliseconds)

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int EventsLuaWithArgsWaitTime
Public EventsLuaWithArgsWaitTime As Integer
public:
int^ EventsLuaWithArgsWaitTime

See Also

wManagerSetting Class
wManager Namespace


FightInteractTargetMinDistance Field

wManagerSetting..::..FightInteractTargetMinDistance Field

Interact with target during fight if distance is lower than X even if not line of sight

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float FightInteractTargetMinDistance
Public FightInteractTargetMinDistance As Single
public:
float^ FightInteractTargetMinDistance

See Also

wManagerSetting Class
wManager Namespace


FoodMaxPercent Field

wManagerSetting..::..FoodMaxPercent Field

Stop character regen if more than X % of health.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int FoodMaxPercent
Public FoodMaxPercent As Integer
public:
int^ FoodMaxPercent

See Also

wManagerSetting Class
wManager Namespace


ForceAutoLoot Field

wManagerSetting..::..ForceAutoLoot Field

Force auto loot

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool ForceAutoLoot
Public ForceAutoLoot As Boolean
public:
bool^ ForceAutoLoot

See Also

wManagerSetting Class
wManager Namespace


HearthstoneAfterXBlockagesLatest10Minutes Field

wManagerSetting..::..HearthstoneAfterXBlockagesLatest10Minutes Field

Use hearthstone after x blockages latest 10 minutes (0 to disable, see also HearthstoneNameOrIdAfterXBlockagesLatest10Minutes)

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int HearthstoneAfterXBlockagesLatest10Minutes
Public HearthstoneAfterXBlockagesLatest10Minutes As Integer
public:
int^ HearthstoneAfterXBlockagesLatest10Minutes

See Also

wManagerSetting Class
wManager Namespace


HearthstoneNameOrIdAfterXBlockagesLatest10Minutes Field

wManagerSetting..::..HearthstoneNameOrIdAfterXBlockagesLatest10Minutes Field

Hearthstone item name or id (used with HearthstoneAfterXBlockagesLatest10Minutes)

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string HearthstoneNameOrIdAfterXBlockagesLatest10Minutes
Public HearthstoneNameOrIdAfterXBlockagesLatest10Minutes As String
public:
String^ HearthstoneNameOrIdAfterXBlockagesLatest10Minutes

See Also

wManagerSetting Class
wManager Namespace


IgnoreFightWhenInMove Field

wManagerSetting..::..IgnoreFightWhenInMove Field

Ignore fight when traveling

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IgnoreFightWhenInMove
Public IgnoreFightWhenInMove As Boolean
public:
bool^ IgnoreFightWhenInMove

See Also

wManagerSetting Class
wManager Namespace


IgnoreFightWithPlayer Field

wManagerSetting..::..IgnoreFightWithPlayer Field

Ignore combat with other players

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IgnoreFightWithPlayer
Public IgnoreFightWithPlayer As Boolean
public:
bool^ IgnoreFightWithPlayer

See Also

wManagerSetting Class
wManager Namespace


IgnoreServerRoadsWater Field

wManagerSetting..::..IgnoreServerRoadsWater Field

If you don't want use roads and water of the PathFinder server (the bot take the shortest paths instead of the roads)

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IgnoreServerRoadsWater
Public IgnoreServerRoadsWater As Boolean
public:
bool^ IgnoreServerRoadsWater

See Also

wManagerSetting Class
wManager Namespace


KeyBindingMacro Field

wManagerSetting..::..KeyBindingMacro Field

Key used to run macro when you call RunMacroTextHW(String)

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string KeyBindingMacro
Public KeyBindingMacro As String
public:
String^ KeyBindingMacro

See Also

wManagerSetting Class
wManager Namespace


KeyboardToTurn Field

wManagerSetting..::..KeyboardToTurn Field

Use keyboard to turn (instead of direct rotation)

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool KeyboardToTurn
Public KeyboardToTurn As Boolean
public:
bool^ KeyboardToTurn

See Also

wManagerSetting Class
wManager Namespace


LastProductSelected Field

wManagerSetting..::..LastProductSelected Field

The last product used (used at startup to select last product)

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string LastProductSelected
Public LastProductSelected As String
public:
String^ LastProductSelected

See Also

wManagerSetting Class
wManager Namespace


LootAndHarvestRangeQuickly Field

wManagerSetting..::..LootAndHarvestRangeQuickly Field

The loot and harvest quickly if in interact range (FarmingRange and LootingRange)

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool LootAndHarvestRangeQuickly
Public LootAndHarvestRangeQuickly As Boolean
public:
bool^ LootAndHarvestRangeQuickly

See Also

wManagerSetting Class
wManager Namespace


LootInCombat Field

wManagerSetting..::..LootInCombat Field

Loot in combat

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool LootInCombat
Public LootInCombat As Boolean
public:
bool^ LootInCombat

See Also

wManagerSetting Class
wManager Namespace


MaxCheckIfGoodMouseShortcutsWhenInteract Field

wManagerSetting..::..MaxCheckIfGoodMouseShortcutsWhenInteract Field

Some GM change your mouse buttons shortcut (to no longer be able to interact with unit/object), try to detect that (0 to disable this option)

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int MaxCheckIfGoodMouseShortcutsWhenInteract
Public MaxCheckIfGoodMouseShortcutsWhenInteract As Integer
public:
int^ MaxCheckIfGoodMouseShortcutsWhenInteract

See Also

wManagerSetting Class
wManager Namespace


MaxTryPerNode Field

wManagerSetting..::..MaxTryPerNode Field

Number maximum of try per node (farming)

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int MaxTryPerNode
Public MaxTryPerNode As Integer
public:
int^ MaxTryPerNode

See Also

wManagerSetting Class
wManager Namespace


MaxUnitsNearMobs Field

wManagerSetting..::..MaxUnitsNearMobs Field

The maximum units near mobs MaxUnitNearest(WoWUnit, Int32)

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int MaxUnitsNearMobs
Public MaxUnitsNearMobs As Integer
public:
int^ MaxUnitsNearMobs

See Also

wManagerSetting Class
wManager Namespace


MaxUnitsNearObjects Field

wManagerSetting..::..MaxUnitsNearObjects Field

The maximum units near objects MaxUnitNearest(WoWUnit, Int32)

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int MaxUnitsNearObjects
Public MaxUnitsNearObjects As Integer
public:
int^ MaxUnitsNearObjects

See Also

wManagerSetting Class
wManager Namespace


MaxZDistanceAttack Field

wManagerSetting..::..MaxZDistanceAttack Field

Maximum z distance to start attack

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float MaxZDistanceAttack
Public MaxZDistanceAttack As Single
public:
float^ MaxZDistanceAttack

See Also

wManagerSetting Class
wManager Namespace


MaxZDistanceFarm Field

wManagerSetting..::..MaxZDistanceFarm Field

Maximum z distance to go farming node

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float MaxZDistanceFarm
Public MaxZDistanceFarm As Single
public:
float^ MaxZDistanceFarm

See Also

wManagerSetting Class
wManager Namespace


MaxZDistanceIsAttacked Field

wManagerSetting..::..MaxZDistanceIsAttacked Field

Maximum z distance to defend oneself when mobs attack character

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float MaxZDistanceIsAttacked
Public MaxZDistanceIsAttacked As Single
public:
float^ MaxZDistanceIsAttacked

See Also

wManagerSetting Class
wManager Namespace


MyMacro1 Field

wManagerSetting..::..MyMacro1 Field

My macro 1

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public wManagerSetting..::..MyMacro MyMacro1
Public MyMacro1 As wManagerSetting..::..MyMacro
public:
wManagerSetting..::..MyMacro^ MyMacro1

See Also

wManagerSetting Class
wManager Namespace


MyMacro2 Field

wManagerSetting..::..MyMacro2 Field

My macro 2

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public wManagerSetting..::..MyMacro MyMacro2
Public MyMacro2 As wManagerSetting..::..MyMacro
public:
wManagerSetting..::..MyMacro^ MyMacro2

See Also

wManagerSetting Class
wManager Namespace


MyMacro3 Field

wManagerSetting..::..MyMacro3 Field

My macro 3

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public wManagerSetting..::..MyMacro MyMacro3
Public MyMacro3 As wManagerSetting..::..MyMacro
public:
wManagerSetting..::..MyMacro^ MyMacro3

See Also

wManagerSetting Class
wManager Namespace


MyMacro4 Field

wManagerSetting..::..MyMacro4 Field

My macro 4

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public wManagerSetting..::..MyMacro MyMacro4
Public MyMacro4 As wManagerSetting..::..MyMacro
public:
wManagerSetting..::..MyMacro^ MyMacro4

See Also

wManagerSetting Class
wManager Namespace


NewUserSettings Field

wManagerSetting..::..NewUserSettings Field

This value is true only if settings was created with new instance (false if was loaded from xml file) (assigned in Load(Boolean)).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[XmlIgnoreAttribute]
public bool NewUserSettings
<XmlIgnoreAttribute> _
Public NewUserSettings As Boolean
[XmlIgnoreAttribute]
public:
bool^ NewUserSettings

See Also

wManagerSetting Class
wManager Namespace


NpcScanAuctioneer Field

wManagerSetting..::..NpcScanAuctioneer Field

Automatically add nearest Npc auctioneer to NpcDB.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool NpcScanAuctioneer
Public NpcScanAuctioneer As Boolean
public:
bool^ NpcScanAuctioneer

See Also

wManagerSetting Class
wManager Namespace


NpcScanMailboxes Field

wManagerSetting..::..NpcScanMailboxes Field

Automatically add nearest Mailbox to NpcDB.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool NpcScanMailboxes
Public NpcScanMailboxes As Boolean
public:
bool^ NpcScanMailboxes

See Also

wManagerSetting Class
wManager Namespace


NpcScanRepair Field

wManagerSetting..::..NpcScanRepair Field

Automatically add nearest Npc repair to NpcDB.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool NpcScanRepair
Public NpcScanRepair As Boolean
public:
bool^ NpcScanRepair

See Also

wManagerSetting Class
wManager Namespace


NpcScanVendor Field

wManagerSetting..::..NpcScanVendor Field

Automatically add nearest Npc vendor to NpcDB.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool NpcScanVendor
Public NpcScanVendor As Boolean
public:
bool^ NpcScanVendor

See Also

wManagerSetting Class
wManager Namespace


OffMeshConnectionsSearchDistance Field

wManagerSetting..::..OffMeshConnectionsSearchDistance Field

The off mesh connections search distance

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float OffMeshConnectionsSearchDistance
Public OffMeshConnectionsSearchDistance As Single
public:
float^ OffMeshConnectionsSearchDistance

See Also

wManagerSetting Class
wManager Namespace


PathFinderFromServer Field

wManagerSetting..::..PathFinderFromServer Field

Use PathFinder server (else use local pathfinder but it is no longer available on recent versions of the bot)

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool PathFinderFromServer
Public PathFinderFromServer As Boolean
public:
bool^ PathFinderFromServer

See Also

wManagerSetting Class
wManager Namespace


PathFinderRequestLog Field

wManagerSetting..::..PathFinderRequestLog Field

Request pathfinder server log

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool PathFinderRequestLog
Public PathFinderRequestLog As Boolean
public:
bool^ PathFinderRequestLog

See Also

wManagerSetting Class
wManager Namespace


PathFinderRequestTimeoutMs Field

wManagerSetting..::..PathFinderRequestTimeoutMs Field

Pathfinder server request timeout (in milliseconds)

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int PathFinderRequestTimeoutMs
Public PathFinderRequestTimeoutMs As Integer
public:
int^ PathFinderRequestTimeoutMs

See Also

wManagerSetting Class
wManager Namespace


PathFinderServerSeemDownPauseBotTimeSec Field

wManagerSetting..::..PathFinderServerSeemDownPauseBotTimeSec Field

How many time pause bot (in seconds) when pathfinder server seems down

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float PathFinderServerSeemDownPauseBotTimeSec
Public PathFinderServerSeemDownPauseBotTimeSec As Single
public:
float^ PathFinderServerSeemDownPauseBotTimeSec

See Also

wManagerSetting Class
wManager Namespace


PluginsSettings Field

wManagerSetting..::..PluginsSettings Field

Plugins list (when user removes a plugin from the folder ("WRobot/Plugins/") it remains in this list, but only plugins present in the folder are displayed tab "Plugins")

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<wManagerSetting..::..PluginSetting> PluginsSettings
Public PluginsSettings As List(Of wManagerSetting..::..PluginSetting)
public:
List<wManagerSetting..::..PluginSetting^>^ PluginsSettings

See Also

wManagerSetting Class
wManager Namespace


RandomJumping Field

wManagerSetting..::..RandomJumping Field

Jump randomly during travel.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool RandomJumping
Public RandomJumping As Boolean
public:
bool^ RandomJumping

See Also

wManagerSetting Class
wManager Namespace


ReadObjectManagerFTS Field

wManagerSetting..::..ReadObjectManagerFTS Field

Number of ObjectManager refreshes per second (a high value is better, but also uses a lot more CPU)

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int ReadObjectManagerFTS
Public ReadObjectManagerFTS As Integer
public:
int^ ReadObjectManagerFTS

See Also

wManagerSetting Class
wManager Namespace


RecordChatInLog Field

wManagerSetting..::..RecordChatInLog Field

Write Wow chat messages in log file.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool RecordChatInLog
Public RecordChatInLog As Boolean
public:
bool^ RecordChatInLog

See Also

wManagerSetting Class
wManager Namespace


RetrieveCorpseMaxDistance Field

wManagerSetting..::..RetrieveCorpseMaxDistance Field

Max distance of the character corpse to retrieve corpse

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float RetrieveCorpseMaxDistance
Public RetrieveCorpseMaxDistance As Single
public:
float^ RetrieveCorpseMaxDistance

See Also

wManagerSetting Class
wManager Namespace


SaveWindowPosition Field

wManagerSetting..::..SaveWindowPosition Field

Save bot window position

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool SaveWindowPosition
Public SaveWindowPosition As Boolean
public:
bool^ SaveWindowPosition

See Also

wManagerSetting Class
wManager Namespace


SearchRadiusMobs Field

wManagerSetting..::..SearchRadiusMobs Field

Mobs search distance (mainly grinding).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float SearchRadiusMobs
Public SearchRadiusMobs As Single
public:
float^ SearchRadiusMobs

See Also

wManagerSetting Class
wManager Namespace


SearchRadiusObjects Field

wManagerSetting..::..SearchRadiusObjects Field

GameObject search distance (mainly farming).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float SearchRadiusObjects
Public SearchRadiusObjects As Single
public:
float^ SearchRadiusObjects

See Also

wManagerSetting Class
wManager Namespace


SizeHeight Field

wManagerSetting..::..SizeHeight Field

Last bot window height

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public double SizeHeight
Public SizeHeight As Double
public:
double^ SizeHeight

See Also

wManagerSetting Class
wManager Namespace


SizeWidth Field

wManagerSetting..::..SizeWidth Field

Last bot window width.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public double SizeWidth
Public SizeWidth As Double
public:
double^ SizeWidth

See Also

wManagerSetting Class
wManager Namespace


SkipInOutDoors Field

wManagerSetting..::..SkipInOutDoors Field

Skip node inside if character is outside, and skip node outside if character is inside.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool SkipInOutDoors
Public SkipInOutDoors As Boolean
public:
bool^ SkipInOutDoors

See Also

wManagerSetting Class
wManager Namespace


SkipNodesInWater Field

wManagerSetting..::..SkipNodesInWater Field

Skip nodes in water

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool SkipNodesInWater
Public SkipNodesInWater As Boolean
public:
bool^ SkipNodesInWater

See Also

wManagerSetting Class
wManager Namespace


SkipRegenIfFlaggedInCombat Field

wManagerSetting..::..SkipRegenIfFlaggedInCombat Field

Skip regen if flagged in combat

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool SkipRegenIfFlaggedInCombat
Public SkipRegenIfFlaggedInCombat As Boolean
public:
bool^ SkipRegenIfFlaggedInCombat

See Also

wManagerSetting Class
wManager Namespace


SmoothPath Field

wManagerSetting..::..SmoothPath Field

Smoothing paths generated by PathFinder (makes movement a little more human, in very rare cases can add blockages).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool SmoothPath
Public SmoothPath As Boolean
public:
bool^ SmoothPath

See Also

wManagerSetting Class
wManager Namespace


SmoothPathDistance Field

wManagerSetting..::..SmoothPathDistance Field

Smoothing paths distance (1.0 by default, option for SmoothPathDistance).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float SmoothPathDistance
Public SmoothPathDistance As Single
public:
float^ SmoothPathDistance

See Also

wManagerSetting Class
wManager Namespace


TryToAvoidEnemyGroupsRatio Field

wManagerSetting..::..TryToAvoidEnemyGroupsRatio Field

Try to avoid group of mobs (Ratio), 0 to disable, recommended value is ~1.2 (Bot will add up all the level of the mobs and divide it by the level of your character, if the result gives a ratio higher than the given hi will try to avoid zone)

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public double TryToAvoidEnemyGroupsRatio
Public TryToAvoidEnemyGroupsRatio As Double
public:
double^ TryToAvoidEnemyGroupsRatio

See Also

wManagerSetting Class
wManager Namespace


TryToUseBestBagFoodDrink Field

wManagerSetting..::..TryToUseBestBagFoodDrink Field

Try to use best food and drink available in the bag.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool TryToUseBestBagFoodDrink
Public TryToUseBestBagFoodDrink As Boolean
public:
bool^ TryToUseBestBagFoodDrink

See Also

wManagerSetting Class
wManager Namespace


UseCTM Field

wManagerSetting..::..UseCTM Field

To use CTM (click to move in game option)

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool UseCTM
Public UseCTM As Boolean
public:
bool^ UseCTM

See Also

wManagerSetting Class
wManager Namespace


UseSpiritHealerAfterXDeathsLatest10Minutes Field

wManagerSetting..::..UseSpiritHealerAfterXDeathsLatest10Minutes Field

The use spirit healer after x deaths latest10 minutes

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int UseSpiritHealerAfterXDeathsLatest10Minutes
Public UseSpiritHealerAfterXDeathsLatest10Minutes As Integer
public:
int^ UseSpiritHealerAfterXDeathsLatest10Minutes

See Also

wManagerSetting Class
wManager Namespace


WaitWhenBuffWaitingToResurrect Field

wManagerSetting..::..WaitWhenBuffWaitingToResurrect Field

Wait when character has buff "Waiting to Resurrect"

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool WaitWhenBuffWaitingToResurrect
Public WaitWhenBuffWaitingToResurrect As Boolean
public:
bool^ WaitWhenBuffWaitingToResurrect

See Also

wManagerSetting Class
wManager Namespace


WindowPosX Field

wManagerSetting..::..WindowPosX Field

Last bot window position x (need option SaveWindowPosition)

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public double WindowPosX
Public WindowPosX As Double
public:
double^ WindowPosX

See Also

wManagerSetting Class
wManager Namespace


WindowPosY Field

wManagerSetting..::..WindowPosY Field

Last bot window position y (need option SaveWindowPosition)

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public double WindowPosY
Public WindowPosY As Double
public:
double^ WindowPosY

See Also

wManagerSetting Class
wManager Namespace


wManagerSetting Methods

The wManagerSetting type exposes the following members.

Methods

 | Name | Description
 | AddBlackList | Adds GUID to blacklist
 | AddBlackListNpcEntry | Add to entry id blacklist.
 | AddBlackListZone(Vector3, Single, Boolean) | Add zone to blacklisted zones.
 | AddBlackListZone(Vector3, Single, PolyArea, Boolean) | Add zone to blacklisted zones.
 | AddBlackListZone(Vector3, Single, ContinentId, PolyArea, Boolean) | Add zone to blacklisted zones.
 | AddBlackListZone(BlackListSerializable..::..Blackspot, Boolean) | Add zone to blacklisted zones.
 | AddBlackListZoneRectangle | Add zone to rectangle blacklisted zones.
 | AddRangeBlackListZone | Add range zones to blacklist .
 | AddToBlacklistCurrentProductSession | Adds blacklist of current product (blacklist added with param isSessionBlacklist = true) to blacklist, this is called by AddBlackListToWRobotSession()()()())
 | ClearBlacklist | Clear all blacklists (zone, guid, entry).
 | ClearBlacklistOfCurrentProductSession | Clear blacklists of current product (blacklist added with param isSessionBlacklist = true, generally it is the blacklist contained in the profile, it is added to blacklist with method AddToBlacklistCurrentProductSession()()()()) This method is called when product start.
Protected method | ConfigWinForm | (Inherited from Settings.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
 | GetListGuidBlackListed | Gets list of GUID blacklisted.
 | GetListZoneBlackListed | Get list of blacklisted zones.
 | GetListZoneBlackListedRectangle | Get list of blacklisted rectangle zones.
Public method | GetType | (Inherited from Object.)
 | IsBlackListed | Determines GUID is blacklisted
 | IsBlackListedAllConditions(WoWUnit) | Determines if unit is blacklisted (position, guid or entry id).
 | IsBlackListedAllConditions(WoWGameObject) | Determines if game object is blacklisted (position, guid or entry id).
 | IsBlackListedAllConditions(Int32, Vector3, UInt64) | Determines if is blacklisted (position, guid or entry id).
 | IsBlackListedNpcEntry | Determines if entry id blacklisted.
 | IsBlackListedZone | Determine if position is blacklisted.
 | Load | Loads the specified load blacklist.
 | MaxUnitNearest(WoWUnit, Int32) | Check if there are more than MaxUnitsNearMobs hostiles units near (in aggro distance) the unit.
 | MaxUnitNearest(WoWGameObject, Int32) | Check if there are more than MaxUnitsNearObjects hostiles units near (in aggro distance) the gameobject.
 | MaxUnitNearest(Vector3, Int32, Int32%, UInt64, Single, Single) | Check if there are more than maxUnitsNear hostiles "units" near (in aggro distance) of the "position".
Protected method | MemberwiseClone | (Inherited from Object.)
 | RemoveBlackList | Removes GUID from blacklist.
Public method | Save()()()() | Saves this instance.
Public method | Save(Boolean, Boolean) | Saves the specified write in log.
Protected method | Save(String) | Save to xml file (Inherited from Settings.)
Public method | ToForm | Converts to form. (Inherited from Settings.)
Public method | ToString | (Inherited from Object.)
Public method | ToStringFormat | Converts to string (dump settings).
 | UnitAggroRange | Get hostiles units who have in their aggro distance of the "position".

See Also

wManagerSetting Class
wManager Namespace


AddBlackList Method

wManagerSetting..::..AddBlackList Method

Adds GUID to blacklist

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void AddBlackList(
    ulong guid,
    int timeInMilisec,
    bool isSessionBlacklist
)
Public Shared Sub AddBlackList ( _
    guid As ULong, _
    timeInMilisec As Integer, _
    isSessionBlacklist As Boolean _
)
public:
static void AddBlackList(
    unsigned long long^ guid,
    int^ timeInMilisec,
    bool^ isSessionBlacklist
)

Parameters

guid
Type: UInt64
The GUID.
timeInMilisec
Type: Int32
Blacklist time in millisecond.
isSessionBlacklist
Type: Boolean
if set to true it will be added again to the blacklist if the continent change for example.

See Also

wManagerSetting Class
wManager Namespace


AddBlackListNpcEntry Method

wManagerSetting..::..AddBlackListNpcEntry Method

Add to entry id blacklist.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void AddBlackListNpcEntry(
    int entryId,
    bool isSessionBlacklist
)
Public Shared Sub AddBlackListNpcEntry ( _
    entryId As Integer, _
    isSessionBlacklist As Boolean _
)
public:
static void AddBlackListNpcEntry(
    int^ entryId,
    bool^ isSessionBlacklist
)

Parameters

entryId
Type: Int32
The entry id.
isSessionBlacklist
Type: Boolean
if set to true it will be added again to the blacklist if the continent change for example.

See Also

wManagerSetting Class
wManager Namespace


AddBlackListZone Method

wManagerSetting..::..AddBlackListZone Method

Overload List

Name | Description
AddBlackListZone(Vector3, Single, Boolean) | Add zone to blacklisted zones.
AddBlackListZone(Vector3, Single, PolyArea, Boolean) | Add zone to blacklisted zones.
AddBlackListZone(Vector3, Single, ContinentId, PolyArea, Boolean) | Add zone to blacklisted zones.
AddBlackListZone(BlackListSerializable..::..Blackspot, Boolean) | Add zone to blacklisted zones.

See Also

wManagerSetting Class
wManagerSetting Members
wManager Namespace


AddBlackListZone Method (Vector3, Single, Boolean)

wManagerSetting..::..AddBlackListZone Method (Vector3, Single, Boolean)

Add zone to blacklisted zones.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void AddBlackListZone(
    Vector3 position,
    float radius,
    bool isSessionBlacklist
)
Public Shared Sub AddBlackListZone ( _
    position As Vector3, _
    radius As Single, _
    isSessionBlacklist As Boolean _
)
public:
static void AddBlackListZone(
    Vector3^ position,
    float^ radius,
    bool^ isSessionBlacklist
)

Parameters

position
Type: robotManager.Helpful..::..Vector3
The position.
radius
Type: Single
The radius.
isSessionBlacklist
Type: Boolean
if set to true it will be added again to the blacklist if the continent change for example.

See Also

wManagerSetting Class
AddBlackListZone Overload
wManager Namespace


AddBlackListZone Method (Vector3, Single, PolyArea, Boolean)

wManagerSetting..::..AddBlackListZone Method (Vector3, Single, PolyArea, Boolean)

Add zone to blacklisted zones.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void AddBlackListZone(
    Vector3 position,
    float radius,
    PolyArea typeArea,
    bool isSessionBlacklist
)
Public Shared Sub AddBlackListZone ( _
    position As Vector3, _
    radius As Single, _
    typeArea As PolyArea, _
    isSessionBlacklist As Boolean _
)
public:
static void AddBlackListZone(
    Vector3^ position,
    float^ radius,
    PolyArea^ typeArea,
    bool^ isSessionBlacklist
)

Parameters

position
Type: robotManager.Helpful..::..Vector3
The position.
radius
Type: Single
The radius.
typeArea
Type: PolyArea
The type area.
isSessionBlacklist
Type: Boolean
if set to true it will be added again to the blacklist if the continent change for example.

See Also

wManagerSetting Class
AddBlackListZone Overload
wManager Namespace


AddBlackListZone Method (Vector3, Single, ContinentId, PolyArea, Boolean)

wManagerSetting..::..AddBlackListZone Method (Vector3, Single, ContinentId, PolyArea, Boolean)

Add zone to blacklisted zones.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void AddBlackListZone(
    Vector3 position,
    float radius,
    ContinentId continent,
    PolyArea typeArea,
    bool isSessionBlacklist
)
Public Shared Sub AddBlackListZone ( _
    position As Vector3, _
    radius As Single, _
    continent As ContinentId, _
    typeArea As PolyArea, _
    isSessionBlacklist As Boolean _
)
public:
static void AddBlackListZone(
    Vector3^ position,
    float^ radius,
    ContinentId^ continent,
    PolyArea^ typeArea,
    bool^ isSessionBlacklist
)

Parameters

position
Type: robotManager.Helpful..::..Vector3
The position.
radius
Type: Single
The radius.
continent
Type: wManager.Wow.Enums..::..ContinentId
The continent.
typeArea
Type: PolyArea
The type area.
isSessionBlacklist
Type: Boolean
if set to true it will be added again to the blacklist if the continent change for example.

See Also

wManagerSetting Class
AddBlackListZone Overload
wManager Namespace


AddBlackListZone Method (Blackspot, Boolean)

wManagerSetting..::..AddBlackListZone Method (Blackspot, Boolean)

Add zone to blacklisted zones.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void AddBlackListZone(
    BlackListSerializable..::..Blackspot blackspot,
    bool isSessionBlacklist
)
Public Shared Sub AddBlackListZone ( _
    blackspot As BlackListSerializable..::..Blackspot, _
    isSessionBlacklist As Boolean _
)
public:
static void AddBlackListZone(
    BlackListSerializable..::..Blackspot^ blackspot,
    bool^ isSessionBlacklist
)

Parameters

blackspot
Type: wManager..::..BlackListSerializable..::..Blackspot
The blackspot.
isSessionBlacklist
Type: Boolean
if set to true it will be added again to the blacklist if the continent change for example.

See Also

wManagerSetting Class
AddBlackListZone Overload
wManager Namespace


AddBlackListZoneRectangle Method

wManagerSetting..::..AddBlackListZoneRectangle Method

Add zone to rectangle blacklisted zones.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void AddBlackListZoneRectangle(
    Vector3 position1,
    Vector3 position2
)
Public Shared Sub AddBlackListZoneRectangle ( _
    position1 As Vector3, _
    position2 As Vector3 _
)
public:
static void AddBlackListZoneRectangle(
    Vector3^ position1,
    Vector3^ position2
)

Parameters

position1
Type: robotManager.Helpful..::..Vector3
The position1.
position2
Type: robotManager.Helpful..::..Vector3
The position2.

See Also

wManagerSetting Class
wManager Namespace


AddRangeBlackListZone Method

wManagerSetting..::..AddRangeBlackListZone Method

Add range zones to blacklist .

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void AddRangeBlackListZone(
    List<BlackListSerializable..::..Blackspot> listBlackZone,
    bool isSessionBlacklist
)
Public Shared Sub AddRangeBlackListZone ( _
    listBlackZone As List(Of BlackListSerializable..::..Blackspot), _
    isSessionBlacklist As Boolean _
)
public:
static void AddRangeBlackListZone(
    List<BlackListSerializable..::..Blackspot^>^ listBlackZone,
    bool^ isSessionBlacklist
)

Parameters

listBlackZone
Type: List <(Of <(<' BlackListSerializable..::..Blackspot >)>)>
The list black zone.
isSessionBlacklist
Type: Boolean
if set to true it will be added again to the blacklist if the continent change for example.

See Also

wManagerSetting Class
wManager Namespace


AddToBlacklistCurrentProductSession Method

wManagerSetting..::..AddToBlacklistCurrentProductSession Method

Adds blacklist of current product (blacklist added with param isSessionBlacklist = true) to blacklist, this is called by AddBlackListToWRobotSession()()()())

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void AddToBlacklistCurrentProductSession()
Public Shared Sub AddToBlacklistCurrentProductSession
public:
static void AddToBlacklistCurrentProductSession()

See Also

wManagerSetting Class
wManager Namespace


ClearBlacklist Method

wManagerSetting..::..ClearBlacklist Method

Clear all blacklists (zone, guid, entry).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void ClearBlacklist()
Public Shared Sub ClearBlacklist
public:
static void ClearBlacklist()

See Also

wManagerSetting Class
wManager Namespace


ClearBlacklistOfCurrentProductSession Method

wManagerSetting..::..ClearBlacklistOfCurrentProductSession Method

Clear blacklists of current product (blacklist added with param isSessionBlacklist = true, generally it is the blacklist contained in the profile, it is added to blacklist with method AddToBlacklistCurrentProductSession()()()()) This method is called when product start.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void ClearBlacklistOfCurrentProductSession(
    bool reloadBlacklist
)
Public Shared Sub ClearBlacklistOfCurrentProductSession ( _
    reloadBlacklist As Boolean _
)
public:
static void ClearBlacklistOfCurrentProductSession(
    bool^ reloadBlacklist
)

Parameters

reloadBlacklist
Type: Boolean
if set to true [reload blacklist].

See Also

wManagerSetting Class
wManager Namespace


GetListGuidBlackListed Method

wManagerSetting..::..GetListGuidBlackListed Method

Gets list of GUID blacklisted.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<ulong> GetListGuidBlackListed()
Public Shared Function GetListGuidBlackListed As List(Of ULong)
public:
static List<unsigned long long^>^ GetListGuidBlackListed()

Return Value

List<Int128>.

See Also

wManagerSetting Class
wManager Namespace


GetListZoneBlackListed Method

wManagerSetting..::..GetListZoneBlackListed Method

Get list of blacklisted zones.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<BlackListSerializable..::..Blackspot> GetListZoneBlackListed()
Public Shared Function GetListZoneBlackListed As List(Of BlackListSerializable..::..Blackspot)
public:
static List<BlackListSerializable..::..Blackspot^>^ GetListZoneBlackListed()

Return Value

List<BlackListSerializable.Blackspot>.

See Also

wManagerSetting Class
wManager Namespace


GetListZoneBlackListedRectangle Method

wManagerSetting..::..GetListZoneBlackListedRectangle Method

Get list of blacklisted rectangle zones.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static Dictionary<Vector3, Vector3> GetListZoneBlackListedRectangle()
Public Shared Function GetListZoneBlackListedRectangle As Dictionary(Of Vector3, Vector3)
public:
static Dictionary<Vector3^, Vector3^>^ GetListZoneBlackListedRectangle()

Return Value

Dictionary<Vector3, Vector3>.

See Also

wManagerSetting Class
wManager Namespace


IsBlackListed Method

wManagerSetting..::..IsBlackListed Method

Determines GUID is blacklisted

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool IsBlackListed(
    ulong guid
)
Public Shared Function IsBlackListed ( _
    guid As ULong _
) As Boolean
public:
static bool^ IsBlackListed(
    unsigned long long^ guid
)

Parameters

guid
Type: UInt64
The GUID.

Return Value

true if blacklisted otherwise, false.

See Also

wManagerSetting Class
wManager Namespace


IsBlackListedAllConditions Method

wManagerSetting..::..IsBlackListedAllConditions Method

Overload List

Name | Description
IsBlackListedAllConditions(WoWUnit) | Determines if unit is blacklisted (position, guid or entry id).
IsBlackListedAllConditions(WoWGameObject) | Determines if game object is blacklisted (position, guid or entry id).
IsBlackListedAllConditions(Int32, Vector3, UInt64) | Determines if is blacklisted (position, guid or entry id).

See Also

wManagerSetting Class
wManagerSetting Members
wManager Namespace


IsBlackListedAllConditions Method (WoWUnit)

wManagerSetting..::..IsBlackListedAllConditions Method (WoWUnit)

Determines if unit is blacklisted (position, guid or entry id).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool IsBlackListedAllConditions(
    WoWUnit woWUnit
)
Public Shared Function IsBlackListedAllConditions ( _
    woWUnit As WoWUnit _
) As Boolean
public:
static bool^ IsBlackListedAllConditions(
    WoWUnit^ woWUnit
)

Parameters

woWUnit
Type: wManager.Wow.ObjectManager..::..WoWUnit
The unit.

Return Value

true if blacklisted otherwise, false.

See Also

wManagerSetting Class
IsBlackListedAllConditions Overload
wManager Namespace


IsBlackListedAllConditions Method (WoWGameObject)

wManagerSetting..::..IsBlackListedAllConditions Method (WoWGameObject)

Determines if game object is blacklisted (position, guid or entry id).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool IsBlackListedAllConditions(
    WoWGameObject woWGameObject
)
Public Shared Function IsBlackListedAllConditions ( _
    woWGameObject As WoWGameObject _
) As Boolean
public:
static bool^ IsBlackListedAllConditions(
    WoWGameObject^ woWGameObject
)

Parameters

woWGameObject
Type: wManager.Wow.ObjectManager..::..WoWGameObject
The wo w game object.

Return Value

true if blacklisted otherwise, false.

See Also

wManagerSetting Class
IsBlackListedAllConditions Overload
wManager Namespace


IsBlackListedAllConditions Method (Int32, Vector3, UInt64)

wManagerSetting..::..IsBlackListedAllConditions Method (Int32, Vector3, UInt64)

Determines if is blacklisted (position, guid or entry id).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool IsBlackListedAllConditions(
    int entryId,
    Vector3 position,
    ulong guid
)
Public Shared Function IsBlackListedAllConditions ( _
    entryId As Integer, _
    position As Vector3, _
    guid As ULong _
) As Boolean
public:
static bool^ IsBlackListedAllConditions(
    int^ entryId,
    Vector3^ position,
    unsigned long long^ guid
)

Parameters

entryId
Type: Int32
The entry identifier.
position
Type: robotManager.Helpful..::..Vector3
The position.
guid
Type: UInt64
The unique identifier.

Return Value

true if blacklisted; otherwise, false.

See Also

wManagerSetting Class
IsBlackListedAllConditions Overload
wManager Namespace


IsBlackListedNpcEntry Method

wManagerSetting..::..IsBlackListedNpcEntry Method

Determines if entry id blacklisted.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool IsBlackListedNpcEntry(
    int entryId
)
Public Shared Function IsBlackListedNpcEntry ( _
    entryId As Integer _
) As Boolean
public:
static bool^ IsBlackListedNpcEntry(
    int^ entryId
)

Parameters

entryId
Type: Int32
The entry id.

Return Value

true if blacklisted otherwise, false.

See Also

wManagerSetting Class
wManager Namespace


IsBlackListedZone Method

wManagerSetting..::..IsBlackListedZone Method

Determine if position is blacklisted.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool IsBlackListedZone(
    Vector3 position
)
Public Shared Function IsBlackListedZone ( _
    position As Vector3 _
) As Boolean
public:
static bool^ IsBlackListedZone(
    Vector3^ position
)

Parameters

position
Type: robotManager.Helpful..::..Vector3
The position.

Return Value

true if blacklisted otherwise, false.

See Also

wManagerSetting Class
wManager Namespace


Load Method

wManagerSetting..::..Load Method

Loads the specified load blacklist.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool Load(
    bool loadBlacklist
)
Public Shared Function Load ( _
    loadBlacklist As Boolean _
) As Boolean
public:
static bool^ Load(
    bool^ loadBlacklist
)

Parameters

loadBlacklist
Type: Boolean
if set to true load blacklist (AddBlackListToWRobotSession()()()()).

Return Value

true if success, false otherwise.

See Also

wManagerSetting Class
wManager Namespace


MaxUnitNearest Method

wManagerSetting..::..MaxUnitNearest Method

Overload List

Name | Description
MaxUnitNearest(WoWUnit, Int32) | Check if there are more than MaxUnitsNearMobs hostiles units near (in aggro distance) the unit.
MaxUnitNearest(WoWGameObject, Int32) | Check if there are more than MaxUnitsNearObjects hostiles units near (in aggro distance) the gameobject.
MaxUnitNearest(Vector3, Int32, Int32%, UInt64, Single, Single) | Check if there are more than maxUnitsNear hostiles "units" near (in aggro distance) of the "position".

See Also

wManagerSetting Class
wManagerSetting Members
wManager Namespace


MaxUnitNearest Method (WoWUnit, Int32)

wManagerSetting..::..MaxUnitNearest Method (WoWUnit, Int32)

Check if there are more than MaxUnitsNearMobs hostiles units near (in aggro distance) the unit.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool MaxUnitNearest(
    WoWUnit unit,
    int ifMaxNearBlackListTimeMs
)
Public Shared Function MaxUnitNearest ( _
    unit As WoWUnit, _
    ifMaxNearBlackListTimeMs As Integer _
) As Boolean
public:
static bool^ MaxUnitNearest(
    WoWUnit^ unit,
    int^ ifMaxNearBlackListTimeMs
)

Parameters

unit
Type: wManager.Wow.ObjectManager..::..WoWUnit
The unit.
ifMaxNearBlackListTimeMs
Type: Int32
If more than MaxUnitsNearMobs hostiles units near the unit blacklist the unit X millisecond (-1 to don't blacklist unit).

Return Value

true if max unit near, false otherwise.

See Also

wManagerSetting Class
MaxUnitNearest Overload
wManager Namespace


MaxUnitNearest Method (WoWGameObject, Int32)

wManagerSetting..::..MaxUnitNearest Method (WoWGameObject, Int32)

Check if there are more than MaxUnitsNearObjects hostiles units near (in aggro distance) the gameobject.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool MaxUnitNearest(
    WoWGameObject obj,
    int ifMaxNearBlackListTimeMs
)
Public Shared Function MaxUnitNearest ( _
    obj As WoWGameObject, _
    ifMaxNearBlackListTimeMs As Integer _
) As Boolean
public:
static bool^ MaxUnitNearest(
    WoWGameObject^ obj,
    int^ ifMaxNearBlackListTimeMs
)

Parameters

obj
Type: wManager.Wow.ObjectManager..::..WoWGameObject
The gameobject.
ifMaxNearBlackListTimeMs
Type: Int32
If more than MaxUnitsNearObjects hostiles units near the gameobject blacklist the gameobject X millisecond (-1 to don't blacklist gameobject).

Return Value

true if max unit near, false otherwise.

See Also

wManagerSetting Class
MaxUnitNearest Overload
wManager Namespace


MaxUnitNearest Method (Vector3, Int32, Int32, UInt64, Single, Single)

wManagerSetting..::..MaxUnitNearest Method (Vector3, Int32, Int32%, UInt64, Single, Single)

Check if there are more than maxUnitsNear hostiles "units" near (in aggro distance) of the "position".

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool MaxUnitNearest(
    Vector3 position,
    int maxUnitsNear,
    out int number,
    ulong unitGuid,
    float margin,
    float maxZDiff
)
Public Shared Function MaxUnitNearest ( _
    position As Vector3, _
    maxUnitsNear As Integer, _
    <OutAttribute> ByRef number As Integer, _
    unitGuid As ULong, _
    margin As Single, _
    maxZDiff As Single _
) As Boolean
public:
static bool^ MaxUnitNearest(
    Vector3^ position,
    int^ maxUnitsNear,
    [OutAttribute] int^% number,
    unsigned long long^ unitGuid,
    float^ margin,
    float^ maxZDiff
)

Parameters

position
Type: robotManager.Helpful..::..Vector3
The position.
maxUnitsNear
Type: Int32
The maximum units near.
number
Type: Int32 %
The number of hostiles units near.
unitGuid
Type: UInt64
The object GUID to ignore.
margin
Type: Single
The margin (woWUnit.Position.DistanceTo2D(position) <= woWUnit.AggroDistance + margin).
maxZDiff
Type: Single
The maximum Z difference.

Return Value

true if max unit near, false otherwise.

See Also

wManagerSetting Class
MaxUnitNearest Overload
wManager Namespace


RemoveBlackList Method

wManagerSetting..::..RemoveBlackList Method

Removes GUID from blacklist.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void RemoveBlackList(
    ulong guid
)
Public Shared Sub RemoveBlackList ( _
    guid As ULong _
)
public:
static void RemoveBlackList(
    unsigned long long^ guid
)

Parameters

guid
Type: UInt64
The GUID.

See Also

wManagerSetting Class
wManager Namespace


Save Method

wManagerSetting..::..Save Method

Overload List

 | Name | Description
Public method | Save()()()() | Saves this instance.
Public method | Save(Boolean, Boolean) | Saves the specified write in log.
Protected method | Save(String) | Save to xml file (Inherited from Settings.)

See Also

wManagerSetting Class
wManagerSetting Members
wManager Namespace


Save Method

wManagerSetting..::..Save Method

Saves this instance.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool Save()
Public Function Save As Boolean
public:
bool^ Save()

Return Value

true if success, false otherwise.

See Also

wManagerSetting Class
Save Overload
wManager Namespace


Save Method (Boolean, Boolean)

wManagerSetting..::..Save Method (Boolean, Boolean)

Saves the specified write in log.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool Save(
    bool writeInLog,
    bool reloadBlackList
)
Public Function Save ( _
    writeInLog As Boolean, _
    reloadBlackList As Boolean _
) As Boolean
public:
bool^ Save(
    bool^ writeInLog,
    bool^ reloadBlackList
)

Parameters

writeInLog
Type: Boolean
if set to true write in log ToStringFormat()()()().
reloadBlackList
Type: Boolean
if set to true reload blacklist (AddBlackListToWRobotSession()()()()).

Return Value

true if success, false otherwise.

See Also

wManagerSetting Class
Save Overload
wManager Namespace


ToStringFormat Method

wManagerSetting..::..ToStringFormat Method

Converts to string (dump settings).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string ToStringFormat()
Public Function ToStringFormat As String
public:
String^ ToStringFormat()

Return Value

System.String.

See Also

wManagerSetting Class
wManager Namespace


UnitAggroRange Method

wManagerSetting..::..UnitAggroRange Method

Get hostiles units who have in their aggro distance of the "position".

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWUnit> UnitAggroRange(
    Vector3 position,
    float margin,
    float maxZDiff
)
Public Shared Function UnitAggroRange ( _
    position As Vector3, _
    margin As Single, _
    maxZDiff As Single _
) As List(Of WoWUnit)
public:
static List<WoWUnit^>^ UnitAggroRange(
    Vector3^ position,
    float^ margin,
    float^ maxZDiff
)

Parameters

position
Type: robotManager.Helpful..::..Vector3
The position.
margin
Type: Single
The margin (woWUnit.Position.DistanceTo2D(position) <= woWUnit.AggroDistance + margin).
maxZDiff
Type: Single
The maximum Z difference.

Return Value

List<WoWUnit>.

See Also

wManagerSetting Class
wManager Namespace


wManagerSetting Properties

The wManagerSetting type exposes the following members.

Properties

 | Name | Description
Public property | AccountEmail | Account email (or account name on old Wow version) (you need to activate Relogger).
Public property | AccountPassword | Account password (you need to activate Relogger).
Public property | AddToNpcDb | Add NPCs of used profiles to your NpcDB.
Public property | AquaticMountName | Gets or sets the name of the aquatic mount (like it appears in game).
Public property | AssignTalents | Assign Talents (no used in all WRobot version, used in Talents)
Public property | AttackBeforeBeingAttacked | Attack before being attacked (Start the fight when the character is close to the mob's aggro zone. It allows to be more reactive, but this option is not always reliable (it depends on the server and the version of the game)).
Public property | AttackElite | Can start fight with elite mobs (in any case the bot will attack if it is attacked).
Public property | AvoidBlacklistedZonesPathFinder | Avoid blacklisted zones with the paths generated by the PathFinder.
Public property | AvoidWallWithRays | Try to avoid wall and small obstacle not in pathfinder with rays (TraceLine).
Public property | BlackListHarvest | List of gameobjects entry id to not harvest.
Public property | BlackListHarvestByName | List of gameobjects name to not harvest.
Public property | BlackListIfNotCompletePath | Blacklist mobs, NPCs, nodes... if cannot found complete path (if PathFinder return partial or no success result)
Public property | BlackListTrainingDummy | Blacklist training dummy.
Public property | BlackListZoneWhereDead | Automatically blacklist the zone where the character is dead (with 30 y radius), some products like grinder, quester and automaton override this value with their values.
Public property | BNetName | Account name (you need to activate Relogger).
Public property | BuyList | List of items to buy.
Public property | CalcuCombatRange | Calculate interact/combat distance by target size (CombatReach, on some servers this option is bugged).
Public property | CanAttackUnitsAlreadyInFight | Gets or sets a value indicating whether this instance can attack units already in combat.
Public property | CloseAfterXBlockagesActive | Close after CloseAfterXBlockagesLatest10Minutes blockages latest 10 minutes.
Public property | CloseAfterXBlockagesLatest10Minutes | Close game after x blockages latest 10 minutes (you need to use option CloseAfterXBlockagesActive).
Public property | CloseAfterXDeathsActive | Close after CloseAfterXDeathsLatest10Minutes deaths latest 10 minutes.
Public property | CloseAfterXDeathsLatest10Minutes | Close after x deaths latest 10 minutes (you need to use option CloseAfterXDeathsActive).
Public property | CloseAfterXLevel | Close the game after increasing your level by X levels.
Public property | CloseAfterXMin | Close game after x minutes (you need to activate CloseAfterXMinActive).
Public property | CloseAfterXMinActive | Close bot after CloseAfterXMin minutes.
Public property | CloseIfFullBag | Close game when bag is full.
Public property | CloseIfPlayerTeleported | Close game if character seems to have been teleported (GM can use this method, but there may be false detection, by example when character continent change, when using the hearthstone, ...).
Public property | CloseIfReached4000HonorPoints | Close game if you have more than 4000 honor points
Public property | CloseIfWhisperBiggerOrEgalAt | Close the game If you have received more or egal at X whispers
 | CurrentSetting | Gets or sets the current character setting.
Public property | DetectNodesStuck | Detect nodes stuck (test if can landing)
Public property | DisableNearPlayerToTown | Don't pause bot is player nerby when character go to town (option for SecurityPauseBotIfNerbyPlayer)
Public property | DoNotMailList | List of items names to not send by mail (this option override item quality filter options, you need to activate option UseMail).
Public property | DoNotSellList | List of items names to not sell (this option override item quality filter options, you need to activate option Selling).
Public property | DontStartFighting | Gets or sets a value indicating to don't start fight (defend oneself only).
Public property | DrinkAmount | Number of DrinkName item to buy (0 to don't buy food, you need to have food vendor in your profile of NpcDB)
Public property | DrinkIsSpell | DrinkName is spell name (not item)
Public property | DrinkName | Gets or sets the name of the drink (like it appears in game).
Public property | DrinkPercent | Start character regen if less than X % of mana.
Public property | FlightMasterDiscoverRange | Flightmasters discover range (0 to don't discover unknown flightmasters (with green exclamation)).
Public property | FlightMasterTaxiDistance | Flightmaster search distance (to take only is nearby taxi use FlightMasterTaxiUseOnlyIfNear, you need to use option FlightMasterTaxiUse).
Public property | FlightMasterTaxiUse | Take taxi (from FlightMaster) if can.
Public property | FlightMasterTaxiUseOnlyIfNear | Take taxi only if flightmaster is nearby (else the bot searchs by distance with FlightMasterTaxiDistance, you need to use option FlightMasterTaxiUse).
Public property | FlyAboveGroundHeight | When the bot uses the flying mount on a normal (ground) path how high to fly?
Public property | FlyingMountName | Gets or sets the name of the flying mount (like it appears in game).
Public property | FoodAmount | Number of FoodName item to buy (0 to don't buy food, you need to have food vendor in your profile of NpcDB)
Public property | FoodIsSpell | FoodName is spell name (not item)
Public property | FoodName | Gets or sets the name of the food (like it appears in game).
Public property | FoodPercent | Start character regen if less than X % of health.
Public property | ForceMailList | List of items names to send by mail (this option override item quality filter options, you need to activate option UseMail).
Public property | ForceSellList | List of items names to sell (this option override item quality filter options, you need to activate option Selling).
Public property | GoToTownHerbBags | Go to town when herb bags are fulls.
Public property | GoToTownMiningBags | Go to town when mining bags are fulls.
Public property | GroundMountName | The name of the ground mount (like it appears in game).
Public property | HarvestAvoidPlayersRadius | Cancel farm if another player is within X yards (0 to don't avoid players).
Public property | HarvestDuringLongMove | Harvest (farming) during long move.
Public property | HarvestHerbs | Harvest herbs.
Public property | HarvestMinerals | Harvest minerals.
Public property | HarvestTimber | Harvest timber.
Public property | HelpingGroupMembers | Helping party members (if one of the members is attacked you will help him) (the bot will consider that your character is attacked if a member of your group is attacked).
Public property | IgnoreCombatWithPet | Ignore combat with pet.
Public property | IgnoredNerbyPlayer | List if accepted players when you activate option SecurityPauseBotIfNerbyPlayer
Public property | IgnoreFightDuringFarmIfDruidForm | Ignore fight during farm when in druid form (bot skip node if he is attacked and don't harvest the gameboject).
Public property | IgnoreFightGoundMount | Ignore fight when in mount
Public property | LatencyMax | Use this value if real latency is bigger than this value (look also LatencyMin, bot use latency time to wait after action (https://wow.gamepedia.com/API_GetNetStats realLatency = latencyHome + latencyWorld), but sometime result is bad).
Public property | LatencyMin | Use this value if real latency is smaller than this value (look also LatencyMax, bot use latency time to wait after action (https://wow.gamepedia.com/API_GetNetStats realLatency = latencyHome + latencyWorld), but sometime result is bad).
Public property | ListHarvest | List of gameobjects entry id to harvest.
Public property | ListHarvestByName | List of gameobjects name to harvest.
Public property | LootChests | Loot chests
Public property | LootMobs | Loot mobs corpses (Looting and LootingRange)
Public property | MailBlue | Send blue items (you need to activate option UseMail).
Public property | MailGray | Send gray items (you need to activate option UseMail).
Public property | MailGreen | Send green items (you need to activate option UseMail).
Public property | MailPurple | Send purple items (you need to activate option UseMail).
Public property | MailRecipient | Mail recipient name (you need to activate option UseMail).
Public property | MailSubject | Mail subject (you need to activate option UseMail).
Public property | MailWhite | Send white items (you need to activate option UseMail).
Public property | MaxUnitsNear | Obsolete. Obsolete, use MaxUnitsNearMobs and MaxUnitsNearObjects
Public property | Milling | Milling (MillingState, don't forget to complete MillingList).
Public property | MillingInTown | Milling when go to town.
Public property | MillingList | Milling items list (like the name appears in game, you need to enable Milling).
Public property | MillingTime | Milling every X minutes (you need to enable Milling).
Public property | MinFreeBagSlotsToGoToTown | Minimum free bag slots to go to town.
Public property | MountDistance | Required minimum path distance to use mount (if it is path loop, bot use mount without distance check)
Public property | NpcMailboxSearchRadius | NPC (Npc vendor, repair, ...) and Mailbox search radius
Public property | PathFinderPostionOffset | Pathfinder is too precise, sometimes you have to be exactly at position A to be able to reach position B without any obstacle. The problem is that the bot cannot go exactly to position A (CTM not always precise and this cause sudden movement because it stops move when it gets to the position). This option allows you to shift away the position of the position A (1.0 by default) which allows the bot to go to point B when distance to position A is PathFinderPostionOffset (the character is actually at the original position of point A).
Public property | Prospecting | Prospecting, you need to complete ProspectingList and ProspectingTime or ProspectingInTown.
Public property | ProspectingInTown | Prospecting when go to town (you need to enable Prospecting).
Public property | ProspectingList | Prospecting items list (like the name appears in game, you need to enable Prospecting).
Public property | ProspectingTime | Prospecting every X minutes (you need to enable Prospecting).
Public property | Relogger | Relogge player when disconnected (you need to complete AccountEmail, AccountPassword, BNetName)
Public property | Repair | Repair when go to town.
Public property | RestingMana | Regen character mana
Public property | SearchRadius | Obsolete. Obsolete, use SearchRadiusMobs and SearchRadiusObjects
Public property | SecurityPauseBotIfNerbyPlayer | Pause Bot if nearby other player (combined with options SecurityPauseBotIfNerbyPlayerRadius, SecurityPauseBotIfNerbyPlayerTime, IgnoredNerbyPlayer, DisableNearPlayerToTown).
Public property | SecurityPauseBotIfNerbyPlayerRadius | Nearby player search radius (option for SecurityPauseBotIfNerbyPlayer)
Public property | SecurityPauseBotIfNerbyPlayerTime | Nearby player since X seconds before to pause bot (option for SecurityPauseBotIfNerbyPlayer)
Public property | SecurityRecordWhisperInLogFile | Obsolete. Obsolete, RecordChatInLog
Public property | SecurityShutdownComputer | After to close the game, shutdown computer.
Public property | SecuritySongIfNewWhisper | Play song if new whisper (if you want use custom song, you can put song file at "WRobot\Data\newWhisper.wav").
Public property | SellBlue | Sell all blue items (you need to activate option Selling).
Public property | SellGray | Sell all gray items (you need to activate option Selling).
Public property | SellGreen | Sell all green items (you need to activate option Selling).
Public property | Selling | Sell the bag items when go to town (look options SellGray, SellWhite, SellGreen, SellBlue, SellPurple, DoNotSellList, ForceSellList).
Public property | SellPurple | Sell all purple items (you need to activate option Selling).
Public property | SellWhite | Sell all white items (you need to activate option Selling).
Public property | SkinMobs | Skin mobs killed by character (enable SkinNinja to skin all corpse available).
Public property | SkinNinja | Skin all corpse available (you need to active option SkinMobs).
Public property | Smelting | Smelting (SmeltingState, you need to add in NpcDB fake NPC type NpcType.Smelting nearest smelting zone).
Public property | SpellRotationSpeed | Try improve spells rotation speed, don't wait that cast finished before to cast new spell (we lose reliability)
Public property | ToTownTimer | Force to go to town every X minutes (you need to activate ToTownTimerActivated)
Public property | ToTownTimerActivated | Activate go to town every ToTownTimer minutes
Public property | TrainNewSkills | Train New Skills (used in Trainers)
Public property | UnlockMaxFps | Most versions of bot works better with high FPS in-game (but this use more CPU and RAM. This option unlock the "Maximum FPS" option in game (https://wowwiki.fandom.com/wiki/CVar_maxFPS and https://wowwiki.fandom.com/wiki/CVar_maxFPSBk)
Public property | UseFlyingMount | Use flying mount (need FlyingMountName)
Public property | UseGroundMount | Gets or sets a value indicating whether [use ground mount].
Public property | UseLuaToMove | Use lua api to move (otherwise the bot simulate keyboard keys).
Public property | UseMail | Send items by email when the bot goes to town (look options MailRecipient, MailSubject, UseMollE, MailGray, MailWhite, MailGreen, MailBlue, MailPurple, DoNotMailList, ForceMailList).
Public property | UseMammoth | Use "Traveler's Tundra Mammoth" to repair and sell instead of go to town
Public property | UseMollE | Use MOLL-E item instead of to go to Mailbox (you need to activate option UseMail).
Public property | UseMount | Use ground mount (need GroundMountName)
Public property | UsePathsFinder | Use PathFinder (if this option is disabled it goes from position A to position B without avoiding obstacles).
Public property | UseSpiritHealer | Use spirit healer to revive
Public property | WaitResurrectionSickness | Wait when character has debuff "Resurrection Sickness" (after resurrect at the "Spirit Healer")
Public property | WallDistancePathFinder | Wall distance of generated path by PathFinder (sometime this option can return a funny path).

See Also

wManagerSetting Class
wManager Namespace


AccountEmail Property

wManagerSetting..::..AccountEmail Property

Account email (or account name on old Wow version) (you need to activate Relogger).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string AccountEmail { get; set; }
Public Property AccountEmail As String
    Get
    Set
public:
property String^ AccountEmail {
    String^ get ();
    void set (String^ value);
}

See Also

wManagerSetting Class
wManager Namespace


AccountPassword Property

wManagerSetting..::..AccountPassword Property

Account password (you need to activate Relogger).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string AccountPassword { get; set; }
Public Property AccountPassword As String
    Get
    Set
public:
property String^ AccountPassword {
    String^ get ();
    void set (String^ value);
}

See Also

wManagerSetting Class
wManager Namespace


AddToNpcDb Property

wManagerSetting..::..AddToNpcDb Property

Add NPCs of used profiles to your NpcDB.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool AddToNpcDb { get; set; }
Public Property AddToNpcDb As Boolean
    Get
    Set
public:
property bool^ AddToNpcDb {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


AquaticMountName Property

wManagerSetting..::..AquaticMountName Property

Gets or sets the name of the aquatic mount (like it appears in game).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string AquaticMountName { get; set; }
Public Property AquaticMountName As String
    Get
    Set
public:
property String^ AquaticMountName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the aquatic mount.

See Also

wManagerSetting Class
wManager Namespace


AssignTalents Property

wManagerSetting..::..AssignTalents Property

Assign Talents (no used in all WRobot version, used in Talents)

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool AssignTalents { get; set; }
Public Property AssignTalents As Boolean
    Get
    Set
public:
property bool^ AssignTalents {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if assign talents; otherwise, false.

See Also

wManagerSetting Class
wManager Namespace


AttackBeforeBeingAttacked Property

wManagerSetting..::..AttackBeforeBeingAttacked Property

Attack before being attacked (Start the fight when the character is close to the mob's aggro zone. It allows to be more reactive, but this option is not always reliable (it depends on the server and the version of the game)).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool AttackBeforeBeingAttacked { get; set; }
Public Property AttackBeforeBeingAttacked As Boolean
    Get
    Set
public:
property bool^ AttackBeforeBeingAttacked {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


AttackElite Property

wManagerSetting..::..AttackElite Property

Can start fight with elite mobs (in any case the bot will attack if it is attacked).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool AttackElite { get; set; }
Public Property AttackElite As Boolean
    Get
    Set
public:
property bool^ AttackElite {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


AvoidBlacklistedZonesPathFinder Property

wManagerSetting..::..AvoidBlacklistedZonesPathFinder Property

Avoid blacklisted zones with the paths generated by the PathFinder.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool AvoidBlacklistedZonesPathFinder { get; set; }
Public Property AvoidBlacklistedZonesPathFinder As Boolean
    Get
    Set
public:
property bool^ AvoidBlacklistedZonesPathFinder {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


AvoidWallWithRays Property

wManagerSetting..::..AvoidWallWithRays Property

Try to avoid wall and small obstacle not in pathfinder with rays (TraceLine).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool AvoidWallWithRays { get; set; }
Public Property AvoidWallWithRays As Boolean
    Get
    Set
public:
property bool^ AvoidWallWithRays {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


BlackListHarvest Property

wManagerSetting..::..BlackListHarvest Property

List of gameobjects entry id to not harvest.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<int> BlackListHarvest { get; set; }
Public Property BlackListHarvest As List(Of Integer)
    Get
    Set
public:
property List<int^>^ BlackListHarvest {
    List<int^>^ get ();
    void set (List<int^>^ value);
}

See Also

wManagerSetting Class
wManager Namespace


BlackListHarvestByName Property

wManagerSetting..::..BlackListHarvestByName Property

List of gameobjects name to not harvest.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<string> BlackListHarvestByName { get; set; }
Public Property BlackListHarvestByName As List(Of String)
    Get
    Set
public:
property List<String^>^ BlackListHarvestByName {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

See Also

wManagerSetting Class
wManager Namespace


BlackListIfNotCompletePath Property

wManagerSetting..::..BlackListIfNotCompletePath Property

Blacklist mobs, NPCs, nodes... if cannot found complete path (if PathFinder return partial or no success result)

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool BlackListIfNotCompletePath { get; set; }
Public Property BlackListIfNotCompletePath As Boolean
    Get
    Set
public:
property bool^ BlackListIfNotCompletePath {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


BlackListTrainingDummy Property

wManagerSetting..::..BlackListTrainingDummy Property

Blacklist training dummy.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool BlackListTrainingDummy { get; set; }
Public Property BlackListTrainingDummy As Boolean
    Get
    Set
public:
property bool^ BlackListTrainingDummy {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


BlackListZoneWhereDead Property

wManagerSetting..::..BlackListZoneWhereDead Property

Automatically blacklist the zone where the character is dead (with 30 y radius), some products like grinder, quester and automaton override this value with their values.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool BlackListZoneWhereDead { get; set; }
Public Property BlackListZoneWhereDead As Boolean
    Get
    Set
public:
property bool^ BlackListZoneWhereDead {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


BNetName Property

wManagerSetting..::..BNetName Property

Account name (you need to activate Relogger).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string BNetName { get; set; }
Public Property BNetName As String
    Get
    Set
public:
property String^ BNetName {
    String^ get ();
    void set (String^ value);
}

See Also

wManagerSetting Class
wManager Namespace


BuyList Property

wManagerSetting..::..BuyList Property

List of items to buy.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<Buy> BuyList { get; set; }
Public Property BuyList As List(Of Buy)
    Get
    Set
public:
property List<Buy^>^ BuyList {
    List<Buy^>^ get ();
    void set (List<Buy^>^ value);
}

See Also

wManagerSetting Class
wManager Namespace


CalcuCombatRange Property

wManagerSetting..::..CalcuCombatRange Property

Calculate interact/combat distance by target size (CombatReach, on some servers this option is bugged).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool CalcuCombatRange { get; set; }
Public Property CalcuCombatRange As Boolean
    Get
    Set
public:
property bool^ CalcuCombatRange {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


CanAttackUnitsAlreadyInFight Property

wManagerSetting..::..CanAttackUnitsAlreadyInFight Property

Gets or sets a value indicating whether this instance can attack units already in combat.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool CanAttackUnitsAlreadyInFight { get; set; }
Public Property CanAttackUnitsAlreadyInFight As Boolean
    Get
    Set
public:
property bool^ CanAttackUnitsAlreadyInFight {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if this instance can attack units already in fight; otherwise, false.

See Also

wManagerSetting Class
wManager Namespace


CloseAfterXBlockagesActive Property

wManagerSetting..::..CloseAfterXBlockagesActive Property

Close after CloseAfterXBlockagesLatest10Minutes blockages latest 10 minutes.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool CloseAfterXBlockagesActive { get; set; }
Public Property CloseAfterXBlockagesActive As Boolean
    Get
    Set
public:
property bool^ CloseAfterXBlockagesActive {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


CloseAfterXBlockagesLatest10Minutes Property

wManagerSetting..::..CloseAfterXBlockagesLatest10Minutes Property

Close game after x blockages latest 10 minutes (you need to use option CloseAfterXBlockagesActive).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int CloseAfterXBlockagesLatest10Minutes { get; set; }
Public Property CloseAfterXBlockagesLatest10Minutes As Integer
    Get
    Set
public:
property int^ CloseAfterXBlockagesLatest10Minutes {
    int^ get ();
    void set (int^ value);
}

See Also

wManagerSetting Class
wManager Namespace


CloseAfterXDeathsActive Property

wManagerSetting..::..CloseAfterXDeathsActive Property

Close after CloseAfterXDeathsLatest10Minutes deaths latest 10 minutes.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool CloseAfterXDeathsActive { get; set; }
Public Property CloseAfterXDeathsActive As Boolean
    Get
    Set
public:
property bool^ CloseAfterXDeathsActive {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


CloseAfterXDeathsLatest10Minutes Property

wManagerSetting..::..CloseAfterXDeathsLatest10Minutes Property

Close after x deaths latest 10 minutes (you need to use option CloseAfterXDeathsActive).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int CloseAfterXDeathsLatest10Minutes { get; set; }
Public Property CloseAfterXDeathsLatest10Minutes As Integer
    Get
    Set
public:
property int^ CloseAfterXDeathsLatest10Minutes {
    int^ get ();
    void set (int^ value);
}

See Also

wManagerSetting Class
wManager Namespace


CloseAfterXLevel Property

wManagerSetting..::..CloseAfterXLevel Property

Close the game after increasing your level by X levels.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int CloseAfterXLevel { get; set; }
Public Property CloseAfterXLevel As Integer
    Get
    Set
public:
property int^ CloseAfterXLevel {
    int^ get ();
    void set (int^ value);
}

See Also

wManagerSetting Class
wManager Namespace


CloseAfterXMin Property

wManagerSetting..::..CloseAfterXMin Property

Close game after x minutes (you need to activate CloseAfterXMinActive).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int CloseAfterXMin { get; set; }
Public Property CloseAfterXMin As Integer
    Get
    Set
public:
property int^ CloseAfterXMin {
    int^ get ();
    void set (int^ value);
}

See Also

wManagerSetting Class
wManager Namespace


CloseAfterXMinActive Property

wManagerSetting..::..CloseAfterXMinActive Property

Close bot after CloseAfterXMin minutes.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool CloseAfterXMinActive { get; set; }
Public Property CloseAfterXMinActive As Boolean
    Get
    Set
public:
property bool^ CloseAfterXMinActive {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


CloseIfFullBag Property

wManagerSetting..::..CloseIfFullBag Property

Close game when bag is full.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool CloseIfFullBag { get; set; }
Public Property CloseIfFullBag As Boolean
    Get
    Set
public:
property bool^ CloseIfFullBag {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


CloseIfPlayerTeleported Property

wManagerSetting..::..CloseIfPlayerTeleported Property

Close game if character seems to have been teleported (GM can use this method, but there may be false detection, by example when character continent change, when using the hearthstone, ...).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool CloseIfPlayerTeleported { get; set; }
Public Property CloseIfPlayerTeleported As Boolean
    Get
    Set
public:
property bool^ CloseIfPlayerTeleported {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


CloseIfReached4000HonorPoints Property

wManagerSetting..::..CloseIfReached4000HonorPoints Property

Close game if you have more than 4000 honor points

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool CloseIfReached4000HonorPoints { get; set; }
Public Property CloseIfReached4000HonorPoints As Boolean
    Get
    Set
public:
property bool^ CloseIfReached4000HonorPoints {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


CloseIfWhisperBiggerOrEgalAt Property

wManagerSetting..::..CloseIfWhisperBiggerOrEgalAt Property

Close the game If you have received more or egal at X whispers

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int CloseIfWhisperBiggerOrEgalAt { get; set; }
Public Property CloseIfWhisperBiggerOrEgalAt As Integer
    Get
    Set
public:
property int^ CloseIfWhisperBiggerOrEgalAt {
    int^ get ();
    void set (int^ value);
}

See Also

wManagerSetting Class
wManager Namespace


CurrentSetting Property

wManagerSetting..::..CurrentSetting Property

Gets or sets the current character setting.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static wManagerSetting CurrentSetting { get; set; }
Public Shared Property CurrentSetting As wManagerSetting
    Get
    Set
public:
static property wManagerSetting^ CurrentSetting {
    wManagerSetting^ get ();
    void set (wManagerSetting^ value);
}

Field Value

The current setting.

See Also

wManagerSetting Class
wManager Namespace


DetectNodesStuck Property

wManagerSetting..::..DetectNodesStuck Property

Detect nodes stuck (test if can landing)

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool DetectNodesStuck { get; set; }
Public Property DetectNodesStuck As Boolean
    Get
    Set
public:
property bool^ DetectNodesStuck {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


DisableNearPlayerToTown Property

wManagerSetting..::..DisableNearPlayerToTown Property

Don't pause bot is player nerby when character go to town (option for SecurityPauseBotIfNerbyPlayer)

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool DisableNearPlayerToTown { get; set; }
Public Property DisableNearPlayerToTown As Boolean
    Get
    Set
public:
property bool^ DisableNearPlayerToTown {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


DoNotMailList Property

wManagerSetting..::..DoNotMailList Property

List of items names to not send by mail (this option override item quality filter options, you need to activate option UseMail).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<string> DoNotMailList { get; set; }
Public Property DoNotMailList As List(Of String)
    Get
    Set
public:
property List<String^>^ DoNotMailList {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

See Also

wManagerSetting Class
wManager Namespace


DoNotSellList Property

wManagerSetting..::..DoNotSellList Property

List of items names to not sell (this option override item quality filter options, you need to activate option Selling).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<string> DoNotSellList { get; set; }
Public Property DoNotSellList As List(Of String)
    Get
    Set
public:
property List<String^>^ DoNotSellList {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

See Also

wManagerSetting Class
wManager Namespace


DontStartFighting Property

wManagerSetting..::..DontStartFighting Property

Gets or sets a value indicating to don't start fight (defend oneself only).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool DontStartFighting { get; set; }
Public Property DontStartFighting As Boolean
    Get
    Set
public:
property bool^ DontStartFighting {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if don't start fight; otherwise, false.

See Also

wManagerSetting Class
wManager Namespace


DrinkAmount Property

wManagerSetting..::..DrinkAmount Property

Number of DrinkName item to buy (0 to don't buy food, you need to have food vendor in your profile of NpcDB)

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int DrinkAmount { get; set; }
Public Property DrinkAmount As Integer
    Get
    Set
public:
property int^ DrinkAmount {
    int^ get ();
    void set (int^ value);
}

See Also

wManagerSetting Class
wManager Namespace


DrinkIsSpell Property

wManagerSetting..::..DrinkIsSpell Property

DrinkName is spell name (not item)

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool DrinkIsSpell { get; set; }
Public Property DrinkIsSpell As Boolean
    Get
    Set
public:
property bool^ DrinkIsSpell {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if it is spell name, false if it is item name.

See Also

wManagerSetting Class
wManager Namespace


DrinkName Property

wManagerSetting..::..DrinkName Property

Gets or sets the name of the drink (like it appears in game).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string DrinkName { get; set; }
Public Property DrinkName As String
    Get
    Set
public:
property String^ DrinkName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the drink.

See Also

wManagerSetting Class
wManager Namespace


DrinkPercent Property

wManagerSetting..::..DrinkPercent Property

Start character regen if less than X % of mana.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int DrinkPercent { get; set; }
Public Property DrinkPercent As Integer
    Get
    Set
public:
property int^ DrinkPercent {
    int^ get ();
    void set (int^ value);
}

See Also

wManagerSetting Class
wManager Namespace


FlightMasterDiscoverRange Property

wManagerSetting..::..FlightMasterDiscoverRange Property

Flightmasters discover range (0 to don't discover unknown flightmasters (with green exclamation)).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float FlightMasterDiscoverRange { get; set; }
Public Property FlightMasterDiscoverRange As Single
    Get
    Set
public:
property float^ FlightMasterDiscoverRange {
    float^ get ();
    void set (float^ value);
}

See Also

wManagerSetting Class
wManager Namespace


FlightMasterTaxiDistance Property

wManagerSetting..::..FlightMasterTaxiDistance Property

Flightmaster search distance (to take only is nearby taxi use FlightMasterTaxiUseOnlyIfNear, you need to use option FlightMasterTaxiUse).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float FlightMasterTaxiDistance { get; set; }
Public Property FlightMasterTaxiDistance As Single
    Get
    Set
public:
property float^ FlightMasterTaxiDistance {
    float^ get ();
    void set (float^ value);
}

See Also

wManagerSetting Class
wManager Namespace


FlightMasterTaxiUse Property

wManagerSetting..::..FlightMasterTaxiUse Property

Take taxi (from FlightMaster) if can.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool FlightMasterTaxiUse { get; set; }
Public Property FlightMasterTaxiUse As Boolean
    Get
    Set
public:
property bool^ FlightMasterTaxiUse {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


FlightMasterTaxiUseOnlyIfNear Property

wManagerSetting..::..FlightMasterTaxiUseOnlyIfNear Property

Take taxi only if flightmaster is nearby (else the bot searchs by distance with FlightMasterTaxiDistance, you need to use option FlightMasterTaxiUse).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool FlightMasterTaxiUseOnlyIfNear { get; set; }
Public Property FlightMasterTaxiUseOnlyIfNear As Boolean
    Get
    Set
public:
property bool^ FlightMasterTaxiUseOnlyIfNear {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


FlyAboveGroundHeight Property

wManagerSetting..::..FlyAboveGroundHeight Property

When the bot uses the flying mount on a normal (ground) path how high to fly?

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float FlyAboveGroundHeight { get; set; }
Public Property FlyAboveGroundHeight As Single
    Get
    Set
public:
property float^ FlyAboveGroundHeight {
    float^ get ();
    void set (float^ value);
}

See Also

wManagerSetting Class
wManager Namespace


FlyingMountName Property

wManagerSetting..::..FlyingMountName Property

Gets or sets the name of the flying mount (like it appears in game).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string FlyingMountName { get; set; }
Public Property FlyingMountName As String
    Get
    Set
public:
property String^ FlyingMountName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the flying mount.

See Also

wManagerSetting Class
wManager Namespace


FoodAmount Property

wManagerSetting..::..FoodAmount Property

Number of FoodName item to buy (0 to don't buy food, you need to have food vendor in your profile of NpcDB)

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int FoodAmount { get; set; }
Public Property FoodAmount As Integer
    Get
    Set
public:
property int^ FoodAmount {
    int^ get ();
    void set (int^ value);
}

See Also

wManagerSetting Class
wManager Namespace


FoodIsSpell Property

wManagerSetting..::..FoodIsSpell Property

FoodName is spell name (not item)

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool FoodIsSpell { get; set; }
Public Property FoodIsSpell As Boolean
    Get
    Set
public:
property bool^ FoodIsSpell {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if it is spell name, false if it is item name.

See Also

wManagerSetting Class
wManager Namespace


FoodName Property

wManagerSetting..::..FoodName Property

Gets or sets the name of the food (like it appears in game).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string FoodName { get; set; }
Public Property FoodName As String
    Get
    Set
public:
property String^ FoodName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the food.

See Also

wManagerSetting Class
wManager Namespace


FoodPercent Property

wManagerSetting..::..FoodPercent Property

Start character regen if less than X % of health.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int FoodPercent { get; set; }
Public Property FoodPercent As Integer
    Get
    Set
public:
property int^ FoodPercent {
    int^ get ();
    void set (int^ value);
}

See Also

wManagerSetting Class
wManager Namespace


ForceMailList Property

wManagerSetting..::..ForceMailList Property

List of items names to send by mail (this option override item quality filter options, you need to activate option UseMail).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<string> ForceMailList { get; set; }
Public Property ForceMailList As List(Of String)
    Get
    Set
public:
property List<String^>^ ForceMailList {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

See Also

wManagerSetting Class
wManager Namespace


ForceSellList Property

wManagerSetting..::..ForceSellList Property

List of items names to sell (this option override item quality filter options, you need to activate option Selling).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<string> ForceSellList { get; set; }
Public Property ForceSellList As List(Of String)
    Get
    Set
public:
property List<String^>^ ForceSellList {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

See Also

wManagerSetting Class
wManager Namespace


GoToTownHerbBags Property

wManagerSetting..::..GoToTownHerbBags Property

Go to town when herb bags are fulls.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool GoToTownHerbBags { get; set; }
Public Property GoToTownHerbBags As Boolean
    Get
    Set
public:
property bool^ GoToTownHerbBags {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


GoToTownMiningBags Property

wManagerSetting..::..GoToTownMiningBags Property

Go to town when mining bags are fulls.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool GoToTownMiningBags { get; set; }
Public Property GoToTownMiningBags As Boolean
    Get
    Set
public:
property bool^ GoToTownMiningBags {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


GroundMountName Property

wManagerSetting..::..GroundMountName Property

The name of the ground mount (like it appears in game).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string GroundMountName { get; set; }
Public Property GroundMountName As String
    Get
    Set
public:
property String^ GroundMountName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the ground mount.

See Also

wManagerSetting Class
wManager Namespace


HarvestAvoidPlayersRadius Property

wManagerSetting..::..HarvestAvoidPlayersRadius Property

Cancel farm if another player is within X yards (0 to don't avoid players).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float HarvestAvoidPlayersRadius { get; set; }
Public Property HarvestAvoidPlayersRadius As Single
    Get
    Set
public:
property float^ HarvestAvoidPlayersRadius {
    float^ get ();
    void set (float^ value);
}

See Also

wManagerSetting Class
wManager Namespace


HarvestDuringLongMove Property

wManagerSetting..::..HarvestDuringLongMove Property

Harvest (farming) during long move.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool HarvestDuringLongMove { get; set; }
Public Property HarvestDuringLongMove As Boolean
    Get
    Set
public:
property bool^ HarvestDuringLongMove {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


HarvestHerbs Property

wManagerSetting..::..HarvestHerbs Property

Harvest herbs.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool HarvestHerbs { get; set; }
Public Property HarvestHerbs As Boolean
    Get
    Set
public:
property bool^ HarvestHerbs {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


HarvestMinerals Property

wManagerSetting..::..HarvestMinerals Property

Harvest minerals.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool HarvestMinerals { get; set; }
Public Property HarvestMinerals As Boolean
    Get
    Set
public:
property bool^ HarvestMinerals {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


HarvestTimber Property

wManagerSetting..::..HarvestTimber Property

Harvest timber.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool HarvestTimber { get; set; }
Public Property HarvestTimber As Boolean
    Get
    Set
public:
property bool^ HarvestTimber {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


HelpingGroupMembers Property

wManagerSetting..::..HelpingGroupMembers Property

Helping party members (if one of the members is attacked you will help him) (the bot will consider that your character is attacked if a member of your group is attacked).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool HelpingGroupMembers { get; set; }
Public Property HelpingGroupMembers As Boolean
    Get
    Set
public:
property bool^ HelpingGroupMembers {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


IgnoreCombatWithPet Property

wManagerSetting..::..IgnoreCombatWithPet Property

Ignore combat with pet.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IgnoreCombatWithPet { get; set; }
Public Property IgnoreCombatWithPet As Boolean
    Get
    Set
public:
property bool^ IgnoreCombatWithPet {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


IgnoredNerbyPlayer Property

wManagerSetting..::..IgnoredNerbyPlayer Property

List if accepted players when you activate option SecurityPauseBotIfNerbyPlayer

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public wManagerSetting..::..IgnoredNerbyPlayerClass IgnoredNerbyPlayer { get; set; }
Public Property IgnoredNerbyPlayer As wManagerSetting..::..IgnoredNerbyPlayerClass
    Get
    Set
public:
property wManagerSetting..::..IgnoredNerbyPlayerClass^ IgnoredNerbyPlayer {
    wManagerSetting..::..IgnoredNerbyPlayerClass^ get ();
    void set (wManagerSetting..::..IgnoredNerbyPlayerClass^ value);
}

See Also

wManagerSetting Class
wManager Namespace


IgnoreFightDuringFarmIfDruidForm Property

wManagerSetting..::..IgnoreFightDuringFarmIfDruidForm Property

Ignore fight during farm when in druid form (bot skip node if he is attacked and don't harvest the gameboject).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IgnoreFightDuringFarmIfDruidForm { get; set; }
Public Property IgnoreFightDuringFarmIfDruidForm As Boolean
    Get
    Set
public:
property bool^ IgnoreFightDuringFarmIfDruidForm {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


IgnoreFightGoundMount Property

wManagerSetting..::..IgnoreFightGoundMount Property

Ignore fight when in mount

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IgnoreFightGoundMount { get; set; }
Public Property IgnoreFightGoundMount As Boolean
    Get
    Set
public:
property bool^ IgnoreFightGoundMount {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if ignore fight when in mount; otherwise, false.

See Also

wManagerSetting Class
wManager Namespace


LatencyMax Property

wManagerSetting..::..LatencyMax Property

Use this value if real latency is bigger than this value (look also LatencyMin, bot use latency time to wait after action (https://wow.gamepedia.com/API_GetNetStats realLatency = latencyHome + latencyWorld), but sometime result is bad).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int LatencyMax { get; set; }
Public Property LatencyMax As Integer
    Get
    Set
public:
property int^ LatencyMax {
    int^ get ();
    void set (int^ value);
}

See Also

wManagerSetting Class
wManager Namespace


LatencyMin Property

wManagerSetting..::..LatencyMin Property

Use this value if real latency is smaller than this value (look also LatencyMax, bot use latency time to wait after action (https://wow.gamepedia.com/API_GetNetStats realLatency = latencyHome + latencyWorld), but sometime result is bad).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int LatencyMin { get; set; }
Public Property LatencyMin As Integer
    Get
    Set
public:
property int^ LatencyMin {
    int^ get ();
    void set (int^ value);
}

Field Value

The latency minimum.

See Also

wManagerSetting Class
wManager Namespace


ListHarvest Property

wManagerSetting..::..ListHarvest Property

List of gameobjects entry id to harvest.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<int> ListHarvest { get; set; }
Public Property ListHarvest As List(Of Integer)
    Get
    Set
public:
property List<int^>^ ListHarvest {
    List<int^>^ get ();
    void set (List<int^>^ value);
}

See Also

wManagerSetting Class
wManager Namespace


ListHarvestByName Property

wManagerSetting..::..ListHarvestByName Property

List of gameobjects name to harvest.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<string> ListHarvestByName { get; set; }
Public Property ListHarvestByName As List(Of String)
    Get
    Set
public:
property List<String^>^ ListHarvestByName {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

See Also

wManagerSetting Class
wManager Namespace


LootChests Property

wManagerSetting..::..LootChests Property

Loot chests

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool LootChests { get; set; }
Public Property LootChests As Boolean
    Get
    Set
public:
property bool^ LootChests {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


LootMobs Property

wManagerSetting..::..LootMobs Property

Loot mobs corpses (Looting and LootingRange)

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool LootMobs { get; set; }
Public Property LootMobs As Boolean
    Get
    Set
public:
property bool^ LootMobs {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


MailBlue Property

wManagerSetting..::..MailBlue Property

Send blue items (you need to activate option UseMail).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool MailBlue { get; set; }
Public Property MailBlue As Boolean
    Get
    Set
public:
property bool^ MailBlue {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


MailGray Property

wManagerSetting..::..MailGray Property

Send gray items (you need to activate option UseMail).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool MailGray { get; set; }
Public Property MailGray As Boolean
    Get
    Set
public:
property bool^ MailGray {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


MailGreen Property

wManagerSetting..::..MailGreen Property

Send green items (you need to activate option UseMail).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool MailGreen { get; set; }
Public Property MailGreen As Boolean
    Get
    Set
public:
property bool^ MailGreen {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


MailPurple Property

wManagerSetting..::..MailPurple Property

Send purple items (you need to activate option UseMail).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool MailPurple { get; set; }
Public Property MailPurple As Boolean
    Get
    Set
public:
property bool^ MailPurple {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


MailRecipient Property

wManagerSetting..::..MailRecipient Property

Mail recipient name (you need to activate option UseMail).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string MailRecipient { get; set; }
Public Property MailRecipient As String
    Get
    Set
public:
property String^ MailRecipient {
    String^ get ();
    void set (String^ value);
}

See Also

wManagerSetting Class
wManager Namespace


MailSubject Property

wManagerSetting..::..MailSubject Property

Mail subject (you need to activate option UseMail).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string MailSubject { get; set; }
Public Property MailSubject As String
    Get
    Set
public:
property String^ MailSubject {
    String^ get ();
    void set (String^ value);
}

See Also

wManagerSetting Class
wManager Namespace


MailWhite Property

wManagerSetting..::..MailWhite Property

Send white items (you need to activate option UseMail).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool MailWhite { get; set; }
Public Property MailWhite As Boolean
    Get
    Set
public:
property bool^ MailWhite {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


MaxUnitsNear Property

wManagerSetting..::..MaxUnitsNear Property

Note: This API is now obsolete.
Obsolete, use MaxUnitsNearMobs and MaxUnitsNearObjects

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[ObsoleteAttribute]
[XmlIgnoreAttribute]
[JsonIgnoreAttribute]
public int MaxUnitsNear { get; set; }
<ObsoleteAttribute> _
<XmlIgnoreAttribute> _
<JsonIgnoreAttribute> _
Public Property MaxUnitsNear As Integer
    Get
    Set
[ObsoleteAttribute]
[XmlIgnoreAttribute]
[JsonIgnoreAttribute]
public:
property int^ MaxUnitsNear {
    int^ get ();
    void set (int^ value);
}

See Also

wManagerSetting Class
wManager Namespace


Milling Property

wManagerSetting..::..Milling Property

Milling (MillingState, don't forget to complete MillingList).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool Milling { get; set; }
Public Property Milling As Boolean
    Get
    Set
public:
property bool^ Milling {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


MillingInTown Property

wManagerSetting..::..MillingInTown Property

Milling when go to town.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool MillingInTown { get; set; }
Public Property MillingInTown As Boolean
    Get
    Set
public:
property bool^ MillingInTown {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


MillingList Property

wManagerSetting..::..MillingList Property

Milling items list (like the name appears in game, you need to enable Milling).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<string> MillingList { get; set; }
Public Property MillingList As List(Of String)
    Get
    Set
public:
property List<String^>^ MillingList {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

Field Value

The milling list.

See Also

wManagerSetting Class
wManager Namespace


MillingTime Property

wManagerSetting..::..MillingTime Property

Milling every X minutes (you need to enable Milling).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int MillingTime { get; set; }
Public Property MillingTime As Integer
    Get
    Set
public:
property int^ MillingTime {
    int^ get ();
    void set (int^ value);
}

See Also

wManagerSetting Class
wManager Namespace


MinFreeBagSlotsToGoToTown Property

wManagerSetting..::..MinFreeBagSlotsToGoToTown Property

Minimum free bag slots to go to town.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int MinFreeBagSlotsToGoToTown { get; set; }
Public Property MinFreeBagSlotsToGoToTown As Integer
    Get
    Set
public:
property int^ MinFreeBagSlotsToGoToTown {
    int^ get ();
    void set (int^ value);
}

See Also

wManagerSetting Class
wManager Namespace


MountDistance Property

wManagerSetting..::..MountDistance Property

Required minimum path distance to use mount (if it is path loop, bot use mount without distance check)

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float MountDistance { get; set; }
Public Property MountDistance As Single
    Get
    Set
public:
property float^ MountDistance {
    float^ get ();
    void set (float^ value);
}

Field Value

The minimum distance to use mount.

See Also

wManagerSetting Class
wManager Namespace


NpcMailboxSearchRadius Property

wManagerSetting..::..NpcMailboxSearchRadius Property

NPC (Npc vendor, repair, ...) and Mailbox search radius

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float NpcMailboxSearchRadius { get; set; }
Public Property NpcMailboxSearchRadius As Single
    Get
    Set
public:
property float^ NpcMailboxSearchRadius {
    float^ get ();
    void set (float^ value);
}

See Also

wManagerSetting Class
wManager Namespace


PathFinderPostionOffset Property

wManagerSetting..::..PathFinderPostionOffset Property

Pathfinder is too precise, sometimes you have to be exactly at position A to be able to reach position B without any obstacle. The problem is that the bot cannot go exactly to position A (CTM not always precise and this cause sudden movement because it stops move when it gets to the position). This option allows you to shift away the position of the position A (1.0 by default) which allows the bot to go to point B when distance to position A is PathFinderPostionOffset (the character is actually at the original position of point A).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float PathFinderPostionOffset { get; set; }
Public Property PathFinderPostionOffset As Single
    Get
    Set
public:
property float^ PathFinderPostionOffset {
    float^ get ();
    void set (float^ value);
}

See Also

wManagerSetting Class
wManager Namespace


Prospecting Property

wManagerSetting..::..Prospecting Property

Prospecting, you need to complete ProspectingList and ProspectingTime or ProspectingInTown.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool Prospecting { get; set; }
Public Property Prospecting As Boolean
    Get
    Set
public:
property bool^ Prospecting {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


ProspectingInTown Property

wManagerSetting..::..ProspectingInTown Property

Prospecting when go to town (you need to enable Prospecting).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool ProspectingInTown { get; set; }
Public Property ProspectingInTown As Boolean
    Get
    Set
public:
property bool^ ProspectingInTown {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


ProspectingList Property

wManagerSetting..::..ProspectingList Property

Prospecting items list (like the name appears in game, you need to enable Prospecting).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<string> ProspectingList { get; set; }
Public Property ProspectingList As List(Of String)
    Get
    Set
public:
property List<String^>^ ProspectingList {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

See Also

wManagerSetting Class
wManager Namespace


ProspectingTime Property

wManagerSetting..::..ProspectingTime Property

Prospecting every X minutes (you need to enable Prospecting).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int ProspectingTime { get; set; }
Public Property ProspectingTime As Integer
    Get
    Set
public:
property int^ ProspectingTime {
    int^ get ();
    void set (int^ value);
}

See Also

wManagerSetting Class
wManager Namespace


Relogger Property

wManagerSetting..::..Relogger Property

Relogge player when disconnected (you need to complete AccountEmail, AccountPassword, BNetName)

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool Relogger { get; set; }
Public Property Relogger As Boolean
    Get
    Set
public:
property bool^ Relogger {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


Repair Property

wManagerSetting..::..Repair Property

Repair when go to town.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool Repair { get; set; }
Public Property Repair As Boolean
    Get
    Set
public:
property bool^ Repair {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


RestingMana Property

wManagerSetting..::..RestingMana Property

Regen character mana

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool RestingMana { get; set; }
Public Property RestingMana As Boolean
    Get
    Set
public:
property bool^ RestingMana {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if you want regen mana otherwise, false.

See Also

wManagerSetting Class
wManager Namespace


SearchRadius Property

wManagerSetting..::..SearchRadius Property

Note: This API is now obsolete.
Obsolete, use SearchRadiusMobs and SearchRadiusObjects

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[ObsoleteAttribute]
[XmlIgnoreAttribute]
[JsonIgnoreAttribute]
public float SearchRadius { get; set; }
<ObsoleteAttribute> _
<XmlIgnoreAttribute> _
<JsonIgnoreAttribute> _
Public Property SearchRadius As Single
    Get
    Set
[ObsoleteAttribute]
[XmlIgnoreAttribute]
[JsonIgnoreAttribute]
public:
property float^ SearchRadius {
    float^ get ();
    void set (float^ value);
}

Field Value

The search radius.

See Also

wManagerSetting Class
wManager Namespace


SecurityPauseBotIfNerbyPlayer Property

wManagerSetting..::..SecurityPauseBotIfNerbyPlayer Property

Pause Bot if nearby other player (combined with options SecurityPauseBotIfNerbyPlayerRadius, SecurityPauseBotIfNerbyPlayerTime, IgnoredNerbyPlayer, DisableNearPlayerToTown).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool SecurityPauseBotIfNerbyPlayer { get; set; }
Public Property SecurityPauseBotIfNerbyPlayer As Boolean
    Get
    Set
public:
property bool^ SecurityPauseBotIfNerbyPlayer {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


SecurityPauseBotIfNerbyPlayerRadius Property

wManagerSetting..::..SecurityPauseBotIfNerbyPlayerRadius Property

Nearby player search radius (option for SecurityPauseBotIfNerbyPlayer)

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int SecurityPauseBotIfNerbyPlayerRadius { get; set; }
Public Property SecurityPauseBotIfNerbyPlayerRadius As Integer
    Get
    Set
public:
property int^ SecurityPauseBotIfNerbyPlayerRadius {
    int^ get ();
    void set (int^ value);
}

See Also

wManagerSetting Class
wManager Namespace


SecurityPauseBotIfNerbyPlayerTime Property

wManagerSetting..::..SecurityPauseBotIfNerbyPlayerTime Property

Nearby player since X seconds before to pause bot (option for SecurityPauseBotIfNerbyPlayer)

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int SecurityPauseBotIfNerbyPlayerTime { get; set; }
Public Property SecurityPauseBotIfNerbyPlayerTime As Integer
    Get
    Set
public:
property int^ SecurityPauseBotIfNerbyPlayerTime {
    int^ get ();
    void set (int^ value);
}

See Also

wManagerSetting Class
wManager Namespace


SecurityRecordWhisperInLogFile Property

wManagerSetting..::..SecurityRecordWhisperInLogFile Property

Note: This API is now obsolete.
Obsolete, RecordChatInLog

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[XmlIgnoreAttribute]
[ObsoleteAttribute]
public bool SecurityRecordWhisperInLogFile { get; set; }
<XmlIgnoreAttribute> _
<ObsoleteAttribute> _
Public Property SecurityRecordWhisperInLogFile As Boolean
    Get
    Set
[XmlIgnoreAttribute]
[ObsoleteAttribute]
public:
property bool^ SecurityRecordWhisperInLogFile {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


SecurityShutdownComputer Property

wManagerSetting..::..SecurityShutdownComputer Property

After to close the game, shutdown computer.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool SecurityShutdownComputer { get; set; }
Public Property SecurityShutdownComputer As Boolean
    Get
    Set
public:
property bool^ SecurityShutdownComputer {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


SecuritySongIfNewWhisper Property

wManagerSetting..::..SecuritySongIfNewWhisper Property

Play song if new whisper (if you want use custom song, you can put song file at "WRobot\Data\newWhisper.wav").

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool SecuritySongIfNewWhisper { get; set; }
Public Property SecuritySongIfNewWhisper As Boolean
    Get
    Set
public:
property bool^ SecuritySongIfNewWhisper {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if [security song if new whisper]; otherwise, false.

See Also

wManagerSetting Class
wManager Namespace


SellBlue Property

wManagerSetting..::..SellBlue Property

Sell all blue items (you need to activate option Selling).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool SellBlue { get; set; }
Public Property SellBlue As Boolean
    Get
    Set
public:
property bool^ SellBlue {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


SellGray Property

wManagerSetting..::..SellGray Property

Sell all gray items (you need to activate option Selling).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool SellGray { get; set; }
Public Property SellGray As Boolean
    Get
    Set
public:
property bool^ SellGray {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


SellGreen Property

wManagerSetting..::..SellGreen Property

Sell all green items (you need to activate option Selling).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool SellGreen { get; set; }
Public Property SellGreen As Boolean
    Get
    Set
public:
property bool^ SellGreen {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


Selling Property

wManagerSetting..::..Selling Property

Sell the bag items when go to town (look options SellGray, SellWhite, SellGreen, SellBlue, SellPurple, DoNotSellList, ForceSellList).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool Selling { get; set; }
Public Property Selling As Boolean
    Get
    Set
public:
property bool^ Selling {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


SellPurple Property

wManagerSetting..::..SellPurple Property

Sell all purple items (you need to activate option Selling).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool SellPurple { get; set; }
Public Property SellPurple As Boolean
    Get
    Set
public:
property bool^ SellPurple {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


SellWhite Property

wManagerSetting..::..SellWhite Property

Sell all white items (you need to activate option Selling).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool SellWhite { get; set; }
Public Property SellWhite As Boolean
    Get
    Set
public:
property bool^ SellWhite {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


SkinMobs Property

wManagerSetting..::..SkinMobs Property

Skin mobs killed by character (enable SkinNinja to skin all corpse available).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool SkinMobs { get; set; }
Public Property SkinMobs As Boolean
    Get
    Set
public:
property bool^ SkinMobs {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


SkinNinja Property

wManagerSetting..::..SkinNinja Property

Skin all corpse available (you need to active option SkinMobs).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool SkinNinja { get; set; }
Public Property SkinNinja As Boolean
    Get
    Set
public:
property bool^ SkinNinja {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


Smelting Property

wManagerSetting..::..Smelting Property

Smelting (SmeltingState, you need to add in NpcDB fake NPC type NpcType.Smelting nearest smelting zone).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool Smelting { get; set; }
Public Property Smelting As Boolean
    Get
    Set
public:
property bool^ Smelting {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


SpellRotationSpeed Property

wManagerSetting..::..SpellRotationSpeed Property

Try improve spells rotation speed, don't wait that cast finished before to cast new spell (we lose reliability)

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool SpellRotationSpeed { get; set; }
Public Property SpellRotationSpeed As Boolean
    Get
    Set
public:
property bool^ SpellRotationSpeed {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


ToTownTimer Property

wManagerSetting..::..ToTownTimer Property

Force to go to town every X minutes (you need to activate ToTownTimerActivated)

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int ToTownTimer { get; set; }
Public Property ToTownTimer As Integer
    Get
    Set
public:
property int^ ToTownTimer {
    int^ get ();
    void set (int^ value);
}

See Also

wManagerSetting Class
wManager Namespace


ToTownTimerActivated Property

wManagerSetting..::..ToTownTimerActivated Property

Activate go to town every ToTownTimer minutes

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool ToTownTimerActivated { get; set; }
Public Property ToTownTimerActivated As Boolean
    Get
    Set
public:
property bool^ ToTownTimerActivated {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


TrainNewSkills Property

wManagerSetting..::..TrainNewSkills Property

Train New Skills (used in Trainers)

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool TrainNewSkills { get; set; }
Public Property TrainNewSkills As Boolean
    Get
    Set
public:
property bool^ TrainNewSkills {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if Train New Skills; otherwise, false.

See Also

wManagerSetting Class
wManager Namespace


UnlockMaxFps Property

wManagerSetting..::..UnlockMaxFps Property

Most versions of bot works better with high FPS in-game (but this use more CPU and RAM. This option unlock the "Maximum FPS" option in game (https://wowwiki.fandom.com/wiki/CVar_maxFPS and https://wowwiki.fandom.com/wiki/CVar_maxFPSBk)

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool UnlockMaxFps { get; set; }
Public Property UnlockMaxFps As Boolean
    Get
    Set
public:
property bool^ UnlockMaxFps {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


UseFlyingMount Property

wManagerSetting..::..UseFlyingMount Property

Use flying mount (need FlyingMountName)

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool UseFlyingMount { get; set; }
Public Property UseFlyingMount As Boolean
    Get
    Set
public:
property bool^ UseFlyingMount {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if [use flying mount]; otherwise, false.

See Also

wManagerSetting Class
wManager Namespace


UseGroundMount Property

wManagerSetting..::..UseGroundMount Property

Gets or sets a value indicating whether [use ground mount].

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[XmlIgnoreAttribute]
public bool UseGroundMount { get; set; }
<XmlIgnoreAttribute> _
Public Property UseGroundMount As Boolean
    Get
    Set
[XmlIgnoreAttribute]
public:
property bool^ UseGroundMount {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if [use ground mount]; otherwise, false.

See Also

wManagerSetting Class
wManager Namespace


UseLuaToMove Property

wManagerSetting..::..UseLuaToMove Property

Use lua api to move (otherwise the bot simulate keyboard keys).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool UseLuaToMove { get; set; }
Public Property UseLuaToMove As Boolean
    Get
    Set
public:
property bool^ UseLuaToMove {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


UseMail Property

wManagerSetting..::..UseMail Property

Send items by email when the bot goes to town (look options MailRecipient, MailSubject, UseMollE, MailGray, MailWhite, MailGreen, MailBlue, MailPurple, DoNotMailList, ForceMailList).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool UseMail { get; set; }
Public Property UseMail As Boolean
    Get
    Set
public:
property bool^ UseMail {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


UseMammoth Property

wManagerSetting..::..UseMammoth Property

Use "Traveler's Tundra Mammoth" to repair and sell instead of go to town

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool UseMammoth { get; set; }
Public Property UseMammoth As Boolean
    Get
    Set
public:
property bool^ UseMammoth {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


UseMollE Property

wManagerSetting..::..UseMollE Property

Use MOLL-E item instead of to go to Mailbox (you need to activate option UseMail).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool UseMollE { get; set; }
Public Property UseMollE As Boolean
    Get
    Set
public:
property bool^ UseMollE {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


UseMount Property

wManagerSetting..::..UseMount Property

Use ground mount (need GroundMountName)

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool UseMount { get; set; }
Public Property UseMount As Boolean
    Get
    Set
public:
property bool^ UseMount {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if [use mount]; otherwise, false.

See Also

wManagerSetting Class
wManager Namespace


UsePathsFinder Property

wManagerSetting..::..UsePathsFinder Property

Use PathFinder (if this option is disabled it goes from position A to position B without avoiding obstacles).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool UsePathsFinder { get; set; }
Public Property UsePathsFinder As Boolean
    Get
    Set
public:
property bool^ UsePathsFinder {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


UseSpiritHealer Property

wManagerSetting..::..UseSpiritHealer Property

Use spirit healer to revive

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool UseSpiritHealer { get; set; }
Public Property UseSpiritHealer As Boolean
    Get
    Set
public:
property bool^ UseSpiritHealer {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if [use spirit healer]; otherwise, false.

See Also

wManagerSetting Class
wManager Namespace


WaitResurrectionSickness Property

wManagerSetting..::..WaitResurrectionSickness Property

Wait when character has debuff "Resurrection Sickness" (after resurrect at the "Spirit Healer")

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool WaitResurrectionSickness { get; set; }
Public Property WaitResurrectionSickness As Boolean
    Get
    Set
public:
property bool^ WaitResurrectionSickness {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting Class
wManager Namespace


WallDistancePathFinder Property

wManagerSetting..::..WallDistancePathFinder Property

Wall distance of generated path by PathFinder (sometime this option can return a funny path).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float WallDistancePathFinder { get; set; }
Public Property WallDistancePathFinder As Single
    Get
    Set
public:
property float^ WallDistancePathFinder {
    float^ get ();
    void set (float^ value);
}

See Also

wManagerSetting Class
wManager Namespace


wManagerSetting.IgnoredNerbyPlayerClass Class

wManagerSetting..::..IgnoredNerbyPlayerClass Class

Class IgnoredNerbyPlayerClass ([IgnoredNerbyPlayer]).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class IgnoredNerbyPlayerClass
<SerializableAttribute> _
Public Class IgnoredNerbyPlayerClass
[SerializableAttribute]
public ref class IgnoredNerbyPlayerClass

Inheritance Hierarchy

Object
wManager..::..wManagerSetting..::..IgnoredNerbyPlayerClass

See Also

wManagerSetting..::..IgnoredNerbyPlayerClass Members
wManager Namespace


wManagerSetting.IgnoredNerbyPlayerClass Members

wManagerSetting..::..IgnoredNerbyPlayerClass Members

The wManagerSetting..::..IgnoredNerbyPlayerClass type exposes the following members.

Constructors

 | Name | Description
Public method | wManagerSetting..::..IgnoredNerbyPlayerClass | Initializes a new instance of the wManagerSetting..::..IgnoredNerbyPlayerClass class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | ListPlayer | List of players names allowed to be nearby the character.

See Also

wManagerSetting..::..IgnoredNerbyPlayerClass Class
wManager Namespace


IgnoredNerbyPlayerClass Constructor

Initializes a new instance of the wManagerSetting..::..IgnoredNerbyPlayerClass class.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public IgnoredNerbyPlayerClass()
Public Sub New
public:
IgnoredNerbyPlayerClass()

See Also

wManagerSetting..::..IgnoredNerbyPlayerClass Class
wManager Namespace


wManagerSetting.IgnoredNerbyPlayerClass Methods

wManagerSetting..::..IgnoredNerbyPlayerClass Methods

The wManagerSetting..::..IgnoredNerbyPlayerClass type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

wManagerSetting..::..IgnoredNerbyPlayerClass Class
wManager Namespace


wManagerSetting.IgnoredNerbyPlayerClass Properties

wManagerSetting..::..IgnoredNerbyPlayerClass Properties

The wManagerSetting..::..IgnoredNerbyPlayerClass type exposes the following members.

Properties

 | Name | Description
Public property | ListPlayer | List of players names allowed to be nearby the character.

See Also

wManagerSetting..::..IgnoredNerbyPlayerClass Class
wManager Namespace


ListPlayer Property

IgnoredNerbyPlayerClass..::..ListPlayer Property

List of players names allowed to be nearby the character.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[CategoryAttribute]
[DescriptionAttribute]
[EditorAttribute]
public List<string> ListPlayer { get; set; }
<CategoryAttribute> _
<DescriptionAttribute> _
<EditorAttribute> _
Public Property ListPlayer As List(Of String)
    Get
    Set
[CategoryAttribute]
[DescriptionAttribute]
[EditorAttribute]
public:
property List<String^>^ ListPlayer {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

See Also

wManagerSetting..::..IgnoredNerbyPlayerClass Class
wManager Namespace


wManagerSetting.MyMacro Class

wManagerSetting..::..MyMacro Class

Class MyMacro. Allows you to simulate the pressing of a keyboard key every X seconds according to simple conditions. This option is rarely used now it is better to use a plugin for this kind of task. Used by state MyMacro

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class MyMacro
<SerializableAttribute> _
Public Class MyMacro
[SerializableAttribute]
public ref class MyMacro

Inheritance Hierarchy

Object
wManager..::..wManagerSetting..::..MyMacro

See Also

wManagerSetting..::..MyMacro Members
wManager Namespace


wManagerSetting.MyMacro Members

wManagerSetting..::..MyMacro Members

The wManagerSetting..::..MyMacro type exposes the following members.

Methods

 | Name | Description
Public method | Conditions | Return true if all conditions is ok (time since last Use()()()(), mount, ...)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | Use | Press key (and stopmove if option enabled), this reset timer (call this method when Conditions is true).

Properties

 | Name | Description
Public property | Actif | Indicates whether or not this macro is used
Public property | Key | Key to press (like "k" to press keyboard key K)
Public property | LaunchIfNoCast | Press key only if character not casting spell.
Public property | LaunchIfNoInCombat | Press key only if character is not in combat.
Public property | LaunchIfNoInMount | Press key only if character not in mount.
Public property | StopMoveWhenLaunch | Stop move for press key.
Public property | Time | Press the key every X seconds.

See Also

wManagerSetting..::..MyMacro Class
wManager Namespace


wManagerSetting.MyMacro Methods

wManagerSetting..::..MyMacro Methods

The wManagerSetting..::..MyMacro type exposes the following members.

Methods

 | Name | Description
Public method | Conditions | Return true if all conditions is ok (time since last Use()()()(), mount, ...)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | Use | Press key (and stopmove if option enabled), this reset timer (call this method when Conditions is true).

See Also

wManagerSetting..::..MyMacro Class
wManager Namespace


Conditions Method

MyMacro..::..Conditions Method

Return true if all conditions is ok (time since last Use()()()(), mount, ...)

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool Conditions()
Public Function Conditions As Boolean
public:
bool^ Conditions()

See Also

wManagerSetting..::..MyMacro Class
wManager Namespace


Use Method

MyMacro..::..Use Method

Press key (and stopmove if option enabled), this reset timer (call this method when Conditions is true).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Use()
Public Sub Use
public:
void Use()

See Also

wManagerSetting..::..MyMacro Class
wManager Namespace


wManagerSetting.MyMacro Properties

wManagerSetting..::..MyMacro Properties

The wManagerSetting..::..MyMacro type exposes the following members.

Properties

 | Name | Description
Public property | Actif | Indicates whether or not this macro is used
Public property | Key | Key to press (like "k" to press keyboard key K)
Public property | LaunchIfNoCast | Press key only if character not casting spell.
Public property | LaunchIfNoInCombat | Press key only if character is not in combat.
Public property | LaunchIfNoInMount | Press key only if character not in mount.
Public property | StopMoveWhenLaunch | Stop move for press key.
Public property | Time | Press the key every X seconds.

See Also

wManagerSetting..::..MyMacro Class
wManager Namespace


Actif Property

MyMacro..::..Actif Property

Indicates whether or not this macro is used

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public bool Actif { get; set; }
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property Actif As Boolean
    Get
    Set
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property bool^ Actif {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting..::..MyMacro Class
wManager Namespace


Key Property

MyMacro..::..Key Property

Key to press (like "k" to press keyboard key K)

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public string Key { get; set; }
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property Key As String
    Get
    Set
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property String^ Key {
    String^ get ();
    void set (String^ value);
}

See Also

wManagerSetting..::..MyMacro Class
wManager Namespace


LaunchIfNoCast Property

MyMacro..::..LaunchIfNoCast Property

Press key only if character not casting spell.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public bool LaunchIfNoCast { get; set; }
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property LaunchIfNoCast As Boolean
    Get
    Set
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property bool^ LaunchIfNoCast {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting..::..MyMacro Class
wManager Namespace


LaunchIfNoInCombat Property

MyMacro..::..LaunchIfNoInCombat Property

Press key only if character is not in combat.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public bool LaunchIfNoInCombat { get; set; }
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property LaunchIfNoInCombat As Boolean
    Get
    Set
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property bool^ LaunchIfNoInCombat {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting..::..MyMacro Class
wManager Namespace


LaunchIfNoInMount Property

MyMacro..::..LaunchIfNoInMount Property

Press key only if character not in mount.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public bool LaunchIfNoInMount { get; set; }
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property LaunchIfNoInMount As Boolean
    Get
    Set
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property bool^ LaunchIfNoInMount {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting..::..MyMacro Class
wManager Namespace


StopMoveWhenLaunch Property

MyMacro..::..StopMoveWhenLaunch Property

Stop move for press key.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public bool StopMoveWhenLaunch { get; set; }
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property StopMoveWhenLaunch As Boolean
    Get
    Set
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property bool^ StopMoveWhenLaunch {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting..::..MyMacro Class
wManager Namespace


Time Property

MyMacro..::..Time Property

Press the key every X seconds.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public int Time { get; set; }
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property Time As Integer
    Get
    Set
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property int^ Time {
    int^ get ();
    void set (int^ value);
}

See Also

wManagerSetting..::..MyMacro Class
wManager Namespace


wManagerSetting.PluginSetting Class

wManagerSetting..::..PluginSetting Class

Class PluginSetting. Used in wManagerSetting by the settings [PluginsSettings]. This allows the bot to remember which IPlugin are activated or not ("Plugins" tab).

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class PluginSetting
<SerializableAttribute> _
Public Class PluginSetting
[SerializableAttribute]
public ref class PluginSetting

Inheritance Hierarchy

Object
wManager..::..wManagerSetting..::..PluginSetting

See Also

wManagerSetting..::..PluginSetting Members
wManager Namespace


wManagerSetting.PluginSetting Members

wManagerSetting..::..PluginSetting Members

The wManagerSetting..::..PluginSetting type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance.

Properties

 | Name | Description
Public property | Actif | Plugin is enabled or not (if true, will be loaded when product start)
Public property | FileName | File name like "My plugin.cs" (plugins are in folder "WRobot\Plugins\")

See Also

wManagerSetting..::..PluginSetting Class
wManager Namespace


wManagerSetting.PluginSetting Methods

wManagerSetting..::..PluginSetting Methods

The wManagerSetting..::..PluginSetting type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance.

See Also

wManagerSetting..::..PluginSetting Class
wManager Namespace


ToString Method

PluginSetting..::..ToString Method

Returns a String that represents this instance.

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string ToString()
Public Function ToString As String
public:
String^ ToString()

Return Value

A String that represents this instance.

See Also

wManagerSetting..::..PluginSetting Class
wManager Namespace


wManagerSetting.PluginSetting Properties

wManagerSetting..::..PluginSetting Properties

The wManagerSetting..::..PluginSetting type exposes the following members.

Properties

 | Name | Description
Public property | Actif | Plugin is enabled or not (if true, will be loaded when product start)
Public property | FileName | File name like "My plugin.cs" (plugins are in folder "WRobot\Plugins\")

See Also

wManagerSetting..::..PluginSetting Class
wManager Namespace


Actif Property

PluginSetting..::..Actif Property

Plugin is enabled or not (if true, will be loaded when product start)

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool Actif { get; set; }
Public Property Actif As Boolean
    Get
    Set
public:
property bool^ Actif {
    bool^ get ();
    void set (bool^ value);
}

See Also

wManagerSetting..::..PluginSetting Class
wManager Namespace


FileName Property

PluginSetting..::..FileName Property

File name like "My plugin.cs" (plugins are in folder "WRobot\Plugins\")

Namespace: wManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the file.

See Also

wManagerSetting..::..PluginSetting Class
wManager Namespace


wManager.Events Namespace

Classes

 | Class | Description
Public class | FarmingEvents | Class FarmingEvents. Event mainly fired by FarmingTask
Public class | FightEvents | Class FightEvents.. Event mainly fired by Fight and FightBG
Public class | FishingEvents | Class FishingEvents. Event mainly fired by FishingTask
Public class | InteractEvents | Class InteractEvents. Event mainly fired by Interact
Public class | LootingEvents | Class LootingEvents. Event mainly fired by LootingTask
Public class | MovementEvents | Class MovementEvents. Event mainly fired by MovementManager
Public class | NpcDBEvents | Class NpcDBEvents. Event mainly fired by NpcDB
Public class | ObjectManagerEvents | Class ObjectManagerEvents. Event mainly fired by ObjectManager
Public class | OthersEvents | Class OthersEvents.
Public class | PluginEvents | Class PluginEvents.
Public class | TaxiEvents | Class TaxiEvents (Taxi).

Delegates

 | Delegate | Description
Public delegate | FarmingEvents..::..FarmingCancelableHandler | Delegate FarmingCancelableHandler
Public delegate | FarmingEvents..::..FarmingHandler | Delegate FarmingHandler
Public delegate | FightEvents..::..FightTargetGuidHandler | Delegate FightTargetGuidHandler
Public delegate | FightEvents..::..FightTargetHandler | Delegate FightTargetHandler
Public delegate | FishingEvents..::..FishingCancelableHandler | Delegate FishingCancelableHandler
Public delegate | FishingEvents..::..FishingHandler | Delegate FishingHandler
Public delegate | FishingEvents..::..FishingSimpleHandler | Delegate FishingSimpleHandler
Public delegate | InteractEvents..::..InteractHandler | Delegate InteractHandler
Public delegate | LootingEvents..::..LootingCancelableHandler | Delegate LootingCancelableHandler
Public delegate | LootingEvents..::..LootingHandler | Delegate LootingHandler
Public delegate | LootingEvents..::..LootingTaskCancelableHandler | Delegate LootingTaskCancelableHandler
Public delegate | LootingEvents..::..LootingTaskHandler | Delegate LootingTaskHandler
Public delegate | MovementEvents..::..MovementCancelableHandler | Delegate MovementCancelableHandler
Public delegate | MovementEvents..::..MovementVector3Handler | Delegate MovementVector3Handler
Public delegate | NpcDBEvents..::..AddingNpcCancelableHandler | Delegate AddingNpcCancelableHandler
Public delegate | OthersEvents..::..AddBlackListGuidHandler | Delegate AddBlackListGuidHandler
Public delegate | OthersEvents..::..AddBlackListNpcEntryHandler | Delegate AddBlackListNpcEntryHandler
Public delegate | OthersEvents..::..AddBlacklistZoneHandler | Delegate AddBlacklistZoneHandler
Public delegate | OthersEvents..::..AddBlackListZoneRectangleHandler | Delegate AddBlackListZoneRectangleHandler
Public delegate | OthersEvents..::..CancelabletHandler | Delegate CancelabletHandler
Public delegate | OthersEvents..::..OnSelectQuestRewardItemCancelableHandler | Delegate OnSelectQuestRewardItemCancelableHandler
Public delegate | OthersEvents..::..StringCancelabletHandler | Delegate StringCancelabletHandler
Public delegate | OthersEvents..::..VectorVectorCancelableHandler | Delegate VectorVectorCancelableHandler
Public delegate | OthersEvents..::..VectorVectorListVectorHandler | Delegate VectorVectorListVectorHandler
Public delegate | TaxiEvents..::..TaxiNodeCancelableHandler | Delegate TaxiNodeCancelableHandler


FarmingEvents Class

Class FarmingEvents. Event mainly fired by FarmingTask

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class FarmingEvents
Public NotInheritable Class FarmingEvents
public ref class FarmingEvents abstract sealed

Inheritance Hierarchy

Object
wManager.Events..::..FarmingEvents

See Also

FarmingEvents Members
wManager.Events Namespace


FarmingEvents Members

The FarmingEvents type exposes the following members.

Methods

Name Description

Events

Name | Description
OnFarmEnd | Occurs when farm finish.
OnFarmingPulse | Occurs on farming pulse.
OnFarmSuccessful | Occurs when farm success.

See Also

FarmingEvents Class
wManager.Events Namespace


FarmingEvents Methods

The FarmingEvents type exposes the following members.

Methods

Name Description

See Also

FarmingEvents Class
wManager.Events Namespace


FarmingEvents Events

The FarmingEvents type exposes the following members.

Events

Name | Description
OnFarmEnd | Occurs when farm finish.
OnFarmingPulse | Occurs on farming pulse.
OnFarmSuccessful | Occurs when farm success.

See Also

FarmingEvents Class
wManager.Events Namespace


OnFarmEnd Event

FarmingEvents..::..OnFarmEnd Event

Occurs when farm finish.

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static event FarmingEvents..::..FarmingHandler OnFarmEnd
Public Shared Event OnFarmEnd As FarmingEvents..::..FarmingHandler
public:
static  event FarmingEvents..::..FarmingHandler^ OnFarmEnd {
    void add (FarmingEvents..::..FarmingHandler^ value);
    void remove (FarmingEvents..::..FarmingHandler^ value);
}

See Also

FarmingEvents Class
wManager.Events Namespace


OnFarmingPulse Event

FarmingEvents..::..OnFarmingPulse Event

Occurs on farming pulse.

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static event FarmingEvents..::..FarmingCancelableHandler OnFarmingPulse
Public Shared Event OnFarmingPulse As FarmingEvents..::..FarmingCancelableHandler
public:
static  event FarmingEvents..::..FarmingCancelableHandler^ OnFarmingPulse {
    void add (FarmingEvents..::..FarmingCancelableHandler^ value);
    void remove (FarmingEvents..::..FarmingCancelableHandler^ value);
}

See Also

FarmingEvents Class
wManager.Events Namespace


OnFarmSuccessful Event

FarmingEvents..::..OnFarmSuccessful Event

Occurs when farm success.

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static event FarmingEvents..::..FarmingHandler OnFarmSuccessful
Public Shared Event OnFarmSuccessful As FarmingEvents..::..FarmingHandler
public:
static  event FarmingEvents..::..FarmingHandler^ OnFarmSuccessful {
    void add (FarmingEvents..::..FarmingHandler^ value);
    void remove (FarmingEvents..::..FarmingHandler^ value);
}

See Also

FarmingEvents Class
wManager.Events Namespace


FarmingEvents.FarmingCancelableHandler Delegate

FarmingEvents..::..FarmingCancelableHandler Delegate

Delegate FarmingCancelableHandler

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public delegate void FarmingCancelableHandler(
    WoWGameObject node,
    CancelEventArgs cancelable
)
Public Delegate Sub FarmingCancelableHandler ( _
    node As WoWGameObject, _
    cancelable As CancelEventArgs _
)
public delegate void FarmingCancelableHandler(
    WoWGameObject^ node,
    CancelEventArgs^ cancelable
)

Parameters

node
Type: wManager.Wow.ObjectManager..::..WoWGameObject
The node.
cancelable
Type: CancelEventArgs
The CancelEventArgs instance containing the event data.

See Also

wManager.Events Namespace


FarmingEvents.FarmingHandler Delegate

FarmingEvents..::..FarmingHandler Delegate

Delegate FarmingHandler

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public delegate void FarmingHandler(
    WoWGameObject node
)
Public Delegate Sub FarmingHandler ( _
    node As WoWGameObject _
)
public delegate void FarmingHandler(
    WoWGameObject^ node
)

Parameters

node
Type: wManager.Wow.ObjectManager..::..WoWGameObject
The node.

See Also

wManager.Events Namespace


FightEvents Class

Class FightEvents.. Event mainly fired by Fight and FightBG

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class FightEvents
Public NotInheritable Class FightEvents
public ref class FightEvents abstract sealed

Inheritance Hierarchy

Object
wManager.Events..::..FightEvents

See Also

FightEvents Members
wManager.Events Namespace


FightEvents Members

The FightEvents type exposes the following members.

Methods

Name Description

Events

Name | Description
OnFightEnd | Occurs when fight is finish.
OnFightLoop | Fired in fight loop.
OnFightStart | Occurs when [on fight start].

See Also

FightEvents Class
wManager.Events Namespace


FightEvents Methods

The FightEvents type exposes the following members.

Methods

Name Description

See Also

FightEvents Class
wManager.Events Namespace


FightEvents Events

The FightEvents type exposes the following members.

Events

Name | Description
OnFightEnd | Occurs when fight is finish.
OnFightLoop | Fired in fight loop.
OnFightStart | Occurs when [on fight start].

See Also

FightEvents Class
wManager.Events Namespace


OnFightEnd Event

FightEvents..::..OnFightEnd Event

Occurs when fight is finish.

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static event FightEvents..::..FightTargetGuidHandler OnFightEnd
Public Shared Event OnFightEnd As FightEvents..::..FightTargetGuidHandler
public:
static  event FightEvents..::..FightTargetGuidHandler^ OnFightEnd {
    void add (FightEvents..::..FightTargetGuidHandler^ value);
    void remove (FightEvents..::..FightTargetGuidHandler^ value);
}

See Also

FightEvents Class
wManager.Events Namespace


OnFightLoop Event

FightEvents..::..OnFightLoop Event

Fired in fight loop.

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static event FightEvents..::..FightTargetHandler OnFightLoop
Public Shared Event OnFightLoop As FightEvents..::..FightTargetHandler
public:
static  event FightEvents..::..FightTargetHandler^ OnFightLoop {
    void add (FightEvents..::..FightTargetHandler^ value);
    void remove (FightEvents..::..FightTargetHandler^ value);
}

See Also

FightEvents Class
wManager.Events Namespace


OnFightStart Event

FightEvents..::..OnFightStart Event

Occurs when [on fight start].

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static event FightEvents..::..FightTargetHandler OnFightStart
Public Shared Event OnFightStart As FightEvents..::..FightTargetHandler
public:
static  event FightEvents..::..FightTargetHandler^ OnFightStart {
    void add (FightEvents..::..FightTargetHandler^ value);
    void remove (FightEvents..::..FightTargetHandler^ value);
}

See Also

FightEvents Class
wManager.Events Namespace


FightEvents.FightTargetGuidHandler Delegate

FightEvents..::..FightTargetGuidHandler Delegate

Delegate FightTargetGuidHandler

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public delegate void FightTargetGuidHandler(
    ulong guid
)
Public Delegate Sub FightTargetGuidHandler ( _
    guid As ULong _
)
public delegate void FightTargetGuidHandler(
    unsigned long long^ guid
)

Parameters

guid
Type: UInt64
The unique identifier.

See Also

wManager.Events Namespace


FightEvents.FightTargetHandler Delegate

FightEvents..::..FightTargetHandler Delegate

Delegate FightTargetHandler

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public delegate void FightTargetHandler(
    WoWUnit unit,
    CancelEventArgs cancelable
)
Public Delegate Sub FightTargetHandler ( _
    unit As WoWUnit, _
    cancelable As CancelEventArgs _
)
public delegate void FightTargetHandler(
    WoWUnit^ unit,
    CancelEventArgs^ cancelable
)

Parameters

unit
Type: wManager.Wow.ObjectManager..::..WoWUnit
The unit.
cancelable
Type: CancelEventArgs
The CancelEventArgs instance containing the event data.

See Also

wManager.Events Namespace


FishingEvents Class

Class FishingEvents. Event mainly fired by FishingTask

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class FishingEvents
Public NotInheritable Class FishingEvents
public ref class FishingEvents abstract sealed

Inheritance Hierarchy

Object
wManager.Events..::..FishingEvents

See Also

FishingEvents Members
wManager.Events Namespace


FishingEvents Members

The FishingEvents type exposes the following members.

Methods

Name Description

Events

Name | Description
OnFishEnd | Occurs when fishing end.
OnFishingPulse | Occurs when fishing pulse.
OnFishLoop | Occurs on fishing loop.
OnFishSuccessful | Occurs when fish success.

See Also

FishingEvents Class
wManager.Events Namespace


FishingEvents Methods

The FishingEvents type exposes the following members.

Methods

Name Description

See Also

FishingEvents Class
wManager.Events Namespace


FishingEvents Events

The FishingEvents type exposes the following members.

Events

Name | Description
OnFishEnd | Occurs when fishing end.
OnFishingPulse | Occurs when fishing pulse.
OnFishLoop | Occurs on fishing loop.
OnFishSuccessful | Occurs when fish success.

See Also

FishingEvents Class
wManager.Events Namespace


OnFishEnd Event

FishingEvents..::..OnFishEnd Event

Occurs when fishing end.

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static event FishingEvents..::..FishingSimpleHandler OnFishEnd
Public Shared Event OnFishEnd As FishingEvents..::..FishingSimpleHandler
public:
static  event FishingEvents..::..FishingSimpleHandler^ OnFishEnd {
    void add (FishingEvents..::..FishingSimpleHandler^ value);
    void remove (FishingEvents..::..FishingSimpleHandler^ value);
}

See Also

FishingEvents Class
wManager.Events Namespace


OnFishingPulse Event

FishingEvents..::..OnFishingPulse Event

Occurs when fishing pulse.

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static event FishingEvents..::..FishingCancelableHandler OnFishingPulse
Public Shared Event OnFishingPulse As FishingEvents..::..FishingCancelableHandler
public:
static  event FishingEvents..::..FishingCancelableHandler^ OnFishingPulse {
    void add (FishingEvents..::..FishingCancelableHandler^ value);
    void remove (FishingEvents..::..FishingCancelableHandler^ value);
}

See Also

FishingEvents Class
wManager.Events Namespace


OnFishLoop Event

FishingEvents..::..OnFishLoop Event

Occurs on fishing loop.

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static event FishingEvents..::..FishingHandler OnFishLoop
Public Shared Event OnFishLoop As FishingEvents..::..FishingHandler
public:
static  event FishingEvents..::..FishingHandler^ OnFishLoop {
    void add (FishingEvents..::..FishingHandler^ value);
    void remove (FishingEvents..::..FishingHandler^ value);
}

See Also

FishingEvents Class
wManager.Events Namespace


OnFishSuccessful Event

FishingEvents..::..OnFishSuccessful Event

Occurs when fish success.

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static event FishingEvents..::..FishingHandler OnFishSuccessful
Public Shared Event OnFishSuccessful As FishingEvents..::..FishingHandler
public:
static  event FishingEvents..::..FishingHandler^ OnFishSuccessful {
    void add (FishingEvents..::..FishingHandler^ value);
    void remove (FishingEvents..::..FishingHandler^ value);
}

See Also

FishingEvents Class
wManager.Events Namespace


FishingEvents.FishingCancelableHandler Delegate

FishingEvents..::..FishingCancelableHandler Delegate

Delegate FishingCancelableHandler

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public delegate void FishingCancelableHandler(
    ulong node,
    CancelEventArgs cancelable
)
Public Delegate Sub FishingCancelableHandler ( _
    node As ULong, _
    cancelable As CancelEventArgs _
)
public delegate void FishingCancelableHandler(
    unsigned long long^ node,
    CancelEventArgs^ cancelable
)

Parameters

node
Type: UInt64
The node.
cancelable
Type: CancelEventArgs
The CancelEventArgs instance containing the event data.

See Also

wManager.Events Namespace


FishingEvents.FishingHandler Delegate

FishingEvents..::..FishingHandler Delegate

Delegate FishingHandler

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public delegate void FishingHandler(
    ulong node
)
Public Delegate Sub FishingHandler ( _
    node As ULong _
)
public delegate void FishingHandler(
    unsigned long long^ node
)

Parameters

node
Type: UInt64
The node.

See Also

wManager.Events Namespace


FishingEvents.FishingSimpleHandler Delegate

FishingEvents..::..FishingSimpleHandler Delegate

Delegate FishingSimpleHandler

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public delegate void FishingSimpleHandler()
Public Delegate Sub FishingSimpleHandler
public delegate void FishingSimpleHandler()

See Also

wManager.Events Namespace


InteractEvents Class

Class InteractEvents. Event mainly fired by Interact

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class InteractEvents
Public NotInheritable Class InteractEvents
public ref class InteractEvents abstract sealed

Inheritance Hierarchy

Object
wManager.Events..::..InteractEvents

See Also

InteractEvents Members
wManager.Events Namespace


InteractEvents Members

The InteractEvents type exposes the following members.

Methods

Name Description

Events

Name | Description
OnInteractPulse | Occurs when interact.

See Also

InteractEvents Class
wManager.Events Namespace


InteractEvents Methods

The InteractEvents type exposes the following members.

Methods

Name Description

See Also

InteractEvents Class
wManager.Events Namespace


InteractEvents Events

The InteractEvents type exposes the following members.

Events

Name | Description
OnInteractPulse | Occurs when interact.

See Also

InteractEvents Class
wManager.Events Namespace


OnInteractPulse Event

InteractEvents..::..OnInteractPulse Event

Occurs when interact.

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static event InteractEvents..::..InteractHandler OnInteractPulse
Public Shared Event OnInteractPulse As InteractEvents..::..InteractHandler
public:
static  event InteractEvents..::..InteractHandler^ OnInteractPulse {
    void add (InteractEvents..::..InteractHandler^ value);
    void remove (InteractEvents..::..InteractHandler^ value);
}

See Also

InteractEvents Class
wManager.Events Namespace


InteractEvents.InteractHandler Delegate

InteractEvents..::..InteractHandler Delegate

Delegate InteractHandler

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public delegate void InteractHandler(
    ulong target,
    CancelEventArgs cancelable
)
Public Delegate Sub InteractHandler ( _
    target As ULong, _
    cancelable As CancelEventArgs _
)
public delegate void InteractHandler(
    unsigned long long^ target,
    CancelEventArgs^ cancelable
)

Parameters

target
Type: UInt64
The target.
cancelable
Type: CancelEventArgs
The CancelEventArgs instance containing the event data.

See Also

wManager.Events Namespace


LootingEvents Class

Class LootingEvents. Event mainly fired by LootingTask

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class LootingEvents
Public NotInheritable Class LootingEvents
public ref class LootingEvents abstract sealed

Inheritance Hierarchy

Object
wManager.Events..::..LootingEvents

See Also

LootingEvents Members
wManager.Events Namespace


LootingEvents Members

The LootingEvents type exposes the following members.

Methods

Name Description

Events

Name | Description
OnLootingPulse | Occurs when loot pulse.
OnLootingTaskEnd | Occurs when looting task end.
OnLootingTaskPulse | Occurs when looting task pulse.
OnLootSuccessful | Occurs when loot success.

See Also

LootingEvents Class
wManager.Events Namespace


LootingEvents Methods

The LootingEvents type exposes the following members.

Methods

Name Description

See Also

LootingEvents Class
wManager.Events Namespace


LootingEvents Events

The LootingEvents type exposes the following members.

Events

Name | Description
OnLootingPulse | Occurs when loot pulse.
OnLootingTaskEnd | Occurs when looting task end.
OnLootingTaskPulse | Occurs when looting task pulse.
OnLootSuccessful | Occurs when loot success.

See Also

LootingEvents Class
wManager.Events Namespace


OnLootingPulse Event

LootingEvents..::..OnLootingPulse Event

Occurs when loot pulse.

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static event LootingEvents..::..LootingCancelableHandler OnLootingPulse
Public Shared Event OnLootingPulse As LootingEvents..::..LootingCancelableHandler
public:
static  event LootingEvents..::..LootingCancelableHandler^ OnLootingPulse {
    void add (LootingEvents..::..LootingCancelableHandler^ value);
    void remove (LootingEvents..::..LootingCancelableHandler^ value);
}

See Also

LootingEvents Class
wManager.Events Namespace


OnLootingTaskEnd Event

LootingEvents..::..OnLootingTaskEnd Event

Occurs when looting task end.

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static event LootingEvents..::..LootingTaskHandler OnLootingTaskEnd
Public Shared Event OnLootingTaskEnd As LootingEvents..::..LootingTaskHandler
public:
static  event LootingEvents..::..LootingTaskHandler^ OnLootingTaskEnd {
    void add (LootingEvents..::..LootingTaskHandler^ value);
    void remove (LootingEvents..::..LootingTaskHandler^ value);
}

See Also

LootingEvents Class
wManager.Events Namespace


OnLootingTaskPulse Event

LootingEvents..::..OnLootingTaskPulse Event

Occurs when looting task pulse.

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static event LootingEvents..::..LootingTaskCancelableHandler OnLootingTaskPulse
Public Shared Event OnLootingTaskPulse As LootingEvents..::..LootingTaskCancelableHandler
public:
static  event LootingEvents..::..LootingTaskCancelableHandler^ OnLootingTaskPulse {
    void add (LootingEvents..::..LootingTaskCancelableHandler^ value);
    void remove (LootingEvents..::..LootingTaskCancelableHandler^ value);
}

See Also

LootingEvents Class
wManager.Events Namespace


OnLootSuccessful Event

LootingEvents..::..OnLootSuccessful Event

Occurs when loot success.

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static event LootingEvents..::..LootingHandler OnLootSuccessful
Public Shared Event OnLootSuccessful As LootingEvents..::..LootingHandler
public:
static  event LootingEvents..::..LootingHandler^ OnLootSuccessful {
    void add (LootingEvents..::..LootingHandler^ value);
    void remove (LootingEvents..::..LootingHandler^ value);
}

See Also

LootingEvents Class
wManager.Events Namespace


LootingEvents.LootingCancelableHandler Delegate

LootingEvents..::..LootingCancelableHandler Delegate

Delegate LootingCancelableHandler

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public delegate void LootingCancelableHandler(
    WoWUnit unit,
    CancelEventArgs cancelable
)
Public Delegate Sub LootingCancelableHandler ( _
    unit As WoWUnit, _
    cancelable As CancelEventArgs _
)
public delegate void LootingCancelableHandler(
    WoWUnit^ unit,
    CancelEventArgs^ cancelable
)

Parameters

unit
Type: wManager.Wow.ObjectManager..::..WoWUnit
The unit.
cancelable
Type: CancelEventArgs
The CancelEventArgs instance containing the event data.

See Also

wManager.Events Namespace


LootingEvents.LootingHandler Delegate

LootingEvents..::..LootingHandler Delegate

Delegate LootingHandler

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public delegate void LootingHandler(
    WoWUnit unit
)
Public Delegate Sub LootingHandler ( _
    unit As WoWUnit _
)
public delegate void LootingHandler(
    WoWUnit^ unit
)

Parameters

unit
Type: wManager.Wow.ObjectManager..::..WoWUnit
The unit.

See Also

wManager.Events Namespace


LootingEvents.LootingTaskCancelableHandler Delegate

LootingEvents..::..LootingTaskCancelableHandler Delegate

Delegate LootingTaskCancelableHandler

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public delegate void LootingTaskCancelableHandler(
    List<WoWUnit> units,
    CancelEventArgs cancelable
)
Public Delegate Sub LootingTaskCancelableHandler ( _
    units As List(Of WoWUnit), _
    cancelable As CancelEventArgs _
)
public delegate void LootingTaskCancelableHandler(
    List<WoWUnit^>^ units,
    CancelEventArgs^ cancelable
)

Parameters

units
Type: List <(Of <(<' WoWUnit >)>)>
The units.
cancelable
Type: CancelEventArgs
The CancelEventArgs instance containing the event data.

See Also

wManager.Events Namespace


LootingEvents.LootingTaskHandler Delegate

LootingEvents..::..LootingTaskHandler Delegate

Delegate LootingTaskHandler

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public delegate void LootingTaskHandler(
    List<WoWUnit> units
)
Public Delegate Sub LootingTaskHandler ( _
    units As List(Of WoWUnit) _
)
public delegate void LootingTaskHandler(
    List<WoWUnit^>^ units
)

Parameters

units
Type: List <(Of <(<' WoWUnit >)>)>
The units.

See Also

wManager.Events Namespace


MovementEvents Class

Class MovementEvents. Event mainly fired by MovementManager

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class MovementEvents
Public NotInheritable Class MovementEvents
public ref class MovementEvents abstract sealed

Inheritance Hierarchy

Object
wManager.Events..::..MovementEvents

See Also

MovementEvents Members
wManager.Events Namespace


MovementEvents Members

The MovementEvents type exposes the following members.

Methods

Name Description

Events

Name | Description
OnMovementLoop | Occurs on movement loop thread.
OnMovementParseVector3Action | Occurs when movement thread parse vector3 action.
OnMovementPulse | Occurs when movement pulse (in Go(List<(Of <<'(Vector3>)>>), Boolean) and GoLoop(List<(Of <<'(Vector3>)>>), Boolean, Int32)).
OnMovementStop | Occurs when movement stop (in StopMove()()()() and StopMoveOnly()()()())..
OnMoveToLoop | Occurs in move to loop.
OnMoveToPulse | Occurs when move to pulse (in MoveTo(Vector3)).
OnMoveToStop | Occurs in move to stop (in StopMoveTo()()()()).
OnPulseStuckResolver | Occurs when pulse stuck resolver (in StuckResolver).
OnSeemStuck | Occurs when seem stuck.

See Also

MovementEvents Class
wManager.Events Namespace


MovementEvents Methods

The MovementEvents type exposes the following members.

Methods

Name Description

See Also

MovementEvents Class
wManager.Events Namespace


MovementEvents Events

The MovementEvents type exposes the following members.

Events

Name | Description
OnMovementLoop | Occurs on movement loop thread.
OnMovementParseVector3Action | Occurs when movement thread parse vector3 action.
OnMovementPulse | Occurs when movement pulse (in Go(List<(Of <<'(Vector3>)>>), Boolean) and GoLoop(List<(Of <<'(Vector3>)>>), Boolean, Int32)).
OnMovementStop | Occurs when movement stop (in StopMove()()()() and StopMoveOnly()()()())..
OnMoveToLoop | Occurs in move to loop.
OnMoveToPulse | Occurs when move to pulse (in MoveTo(Vector3)).
OnMoveToStop | Occurs in move to stop (in StopMoveTo()()()()).
OnPulseStuckResolver | Occurs when pulse stuck resolver (in StuckResolver).
OnSeemStuck | Occurs when seem stuck.

See Also

MovementEvents Class
wManager.Events Namespace


OnMovementLoop Event

MovementEvents..::..OnMovementLoop Event

Occurs on movement loop thread.

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static event SimpleHandler OnMovementLoop
Public Shared Event OnMovementLoop As SimpleHandler
public:
static  event SimpleHandler^ OnMovementLoop {
    void add (SimpleHandler^ value);
    void remove (SimpleHandler^ value);
}

See Also

MovementEvents Class
wManager.Events Namespace


OnMovementParseVector3Action Event

MovementEvents..::..OnMovementParseVector3Action Event

Occurs when movement thread parse vector3 action.

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static event MovementEvents..::..MovementVector3Handler OnMovementParseVector3Action
Public Shared Event OnMovementParseVector3Action As MovementEvents..::..MovementVector3Handler
public:
static  event MovementEvents..::..MovementVector3Handler^ OnMovementParseVector3Action {
    void add (MovementEvents..::..MovementVector3Handler^ value);
    void remove (MovementEvents..::..MovementVector3Handler^ value);
}

See Also

MovementEvents Class
wManager.Events Namespace


OnMovementPulse Event

MovementEvents..::..OnMovementPulse Event

Occurs when movement pulse (in Go(List<(Of <<'(Vector3>)>>), Boolean) and GoLoop(List<(Of <<'(Vector3>)>>), Boolean, Int32)).

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static event MovementEvents..::..MovementCancelableHandler OnMovementPulse
Public Shared Event OnMovementPulse As MovementEvents..::..MovementCancelableHandler
public:
static  event MovementEvents..::..MovementCancelableHandler^ OnMovementPulse {
    void add (MovementEvents..::..MovementCancelableHandler^ value);
    void remove (MovementEvents..::..MovementCancelableHandler^ value);
}

See Also

MovementEvents Class
wManager.Events Namespace


OnMovementStop Event

MovementEvents..::..OnMovementStop Event

Occurs when movement stop (in StopMove()()()() and StopMoveOnly()()()())..

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static event CancelableHandler OnMovementStop
Public Shared Event OnMovementStop As CancelableHandler
public:
static  event CancelableHandler^ OnMovementStop {
    void add (CancelableHandler^ value);
    void remove (CancelableHandler^ value);
}

See Also

MovementEvents Class
wManager.Events Namespace


OnMoveToLoop Event

MovementEvents..::..OnMoveToLoop Event

Occurs in move to loop.

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static event SimpleHandler OnMoveToLoop
Public Shared Event OnMoveToLoop As SimpleHandler
public:
static  event SimpleHandler^ OnMoveToLoop {
    void add (SimpleHandler^ value);
    void remove (SimpleHandler^ value);
}

See Also

MovementEvents Class
wManager.Events Namespace


OnMoveToPulse Event

MovementEvents..::..OnMoveToPulse Event

Occurs when move to pulse (in MoveTo(Vector3)).

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static event MovementEvents..::..MovementVector3Handler OnMoveToPulse
Public Shared Event OnMoveToPulse As MovementEvents..::..MovementVector3Handler
public:
static  event MovementEvents..::..MovementVector3Handler^ OnMoveToPulse {
    void add (MovementEvents..::..MovementVector3Handler^ value);
    void remove (MovementEvents..::..MovementVector3Handler^ value);
}

See Also

MovementEvents Class
wManager.Events Namespace


OnMoveToStop Event

MovementEvents..::..OnMoveToStop Event

Occurs in move to stop (in StopMoveTo()()()()).

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static event CancelableHandler OnMoveToStop
Public Shared Event OnMoveToStop As CancelableHandler
public:
static  event CancelableHandler^ OnMoveToStop {
    void add (CancelableHandler^ value);
    void remove (CancelableHandler^ value);
}

See Also

MovementEvents Class
wManager.Events Namespace


OnPulseStuckResolver Event

MovementEvents..::..OnPulseStuckResolver Event

Occurs when pulse stuck resolver (in StuckResolver).

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static event CancelableHandler OnPulseStuckResolver
Public Shared Event OnPulseStuckResolver As CancelableHandler
public:
static  event CancelableHandler^ OnPulseStuckResolver {
    void add (CancelableHandler^ value);
    void remove (CancelableHandler^ value);
}

See Also

MovementEvents Class
wManager.Events Namespace


OnSeemStuck Event

MovementEvents..::..OnSeemStuck Event

Occurs when seem stuck.

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static event SimpleHandler OnSeemStuck
Public Shared Event OnSeemStuck As SimpleHandler
public:
static  event SimpleHandler^ OnSeemStuck {
    void add (SimpleHandler^ value);
    void remove (SimpleHandler^ value);
}

See Also

MovementEvents Class
wManager.Events Namespace


MovementEvents.MovementCancelableHandler Delegate

MovementEvents..::..MovementCancelableHandler Delegate

Delegate MovementCancelableHandler

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public delegate void MovementCancelableHandler(
    List<Vector3> points,
    CancelEventArgs cancelable
)
Public Delegate Sub MovementCancelableHandler ( _
    points As List(Of Vector3), _
    cancelable As CancelEventArgs _
)
public delegate void MovementCancelableHandler(
    List<Vector3^>^ points,
    CancelEventArgs^ cancelable
)

Parameters

points
Type: List <(Of <(<' Vector3 >)>)>
The points.
cancelable
Type: CancelEventArgs
The CancelEventArgs instance containing the event data.

See Also

wManager.Events Namespace


MovementEvents.MovementVector3Handler Delegate

MovementEvents..::..MovementVector3Handler Delegate

Delegate MovementVector3Handler

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public delegate void MovementVector3Handler(
    Vector3 point,
    CancelEventArgs cancelable
)
Public Delegate Sub MovementVector3Handler ( _
    point As Vector3, _
    cancelable As CancelEventArgs _
)
public delegate void MovementVector3Handler(
    Vector3^ point,
    CancelEventArgs^ cancelable
)

Parameters

point
Type: robotManager.Helpful..::..Vector3
The point.
cancelable
Type: CancelEventArgs
The CancelEventArgs instance containing the event data.

See Also

wManager.Events Namespace


NpcDBEvents Class

Class NpcDBEvents. Event mainly fired by NpcDB

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class NpcDBEvents
Public NotInheritable Class NpcDBEvents
public ref class NpcDBEvents abstract sealed

Inheritance Hierarchy

Object
wManager.Events..::..NpcDBEvents

See Also

NpcDBEvents Members
wManager.Events Namespace


NpcDBEvents Members

The NpcDBEvents type exposes the following members.

Methods

Name Description

Events

Name | Description
OnAddingNpcPulse | Occurs when adding NPC to database.

See Also

NpcDBEvents Class
wManager.Events Namespace


NpcDBEvents Methods

The NpcDBEvents type exposes the following members.

Methods

Name Description

See Also

NpcDBEvents Class
wManager.Events Namespace


NpcDBEvents Events

The NpcDBEvents type exposes the following members.

Events

Name | Description
OnAddingNpcPulse | Occurs when adding NPC to database.

See Also

NpcDBEvents Class
wManager.Events Namespace


OnAddingNpcPulse Event

NpcDBEvents..::..OnAddingNpcPulse Event

Occurs when adding NPC to database.

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static event NpcDBEvents..::..AddingNpcCancelableHandler OnAddingNpcPulse
Public Shared Event OnAddingNpcPulse As NpcDBEvents..::..AddingNpcCancelableHandler
public:
static  event NpcDBEvents..::..AddingNpcCancelableHandler^ OnAddingNpcPulse {
    void add (NpcDBEvents..::..AddingNpcCancelableHandler^ value);
    void remove (NpcDBEvents..::..AddingNpcCancelableHandler^ value);
}

See Also

NpcDBEvents Class
wManager.Events Namespace


NpcDBEvents.AddingNpcCancelableHandler Delegate

NpcDBEvents..::..AddingNpcCancelableHandler Delegate

Delegate AddingNpcCancelableHandler

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public delegate void AddingNpcCancelableHandler(
    Npc npc,
    CancelEventArgs cancelable
)
Public Delegate Sub AddingNpcCancelableHandler ( _
    npc As Npc, _
    cancelable As CancelEventArgs _
)
public delegate void AddingNpcCancelableHandler(
    Npc^ npc,
    CancelEventArgs^ cancelable
)

Parameters

npc
Type: wManager.Wow.Class..::..Npc
The NPC.
cancelable
Type: CancelEventArgs
The CancelEventArgs instance containing the event data.

See Also

wManager.Events Namespace


ObjectManagerEvents Class

Class ObjectManagerEvents. Event mainly fired by ObjectManager

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class ObjectManagerEvents
Public NotInheritable Class ObjectManagerEvents
public ref class ObjectManagerEvents abstract sealed

Inheritance Hierarchy

Object
wManager.Events..::..ObjectManagerEvents

See Also

ObjectManagerEvents Members
wManager.Events Namespace


ObjectManagerEvents Members

The ObjectManagerEvents type exposes the following members.

Methods

Name Description

Events

Name | Description
OnObjectManagerPulsed | Occurs when object manager objects list is updated.

See Also

ObjectManagerEvents Class
wManager.Events Namespace


ObjectManagerEvents Methods

The ObjectManagerEvents type exposes the following members.

Methods

Name Description

See Also

ObjectManagerEvents Class
wManager.Events Namespace


ObjectManagerEvents Events

The ObjectManagerEvents type exposes the following members.

Events

Name | Description
OnObjectManagerPulsed | Occurs when object manager objects list is updated.

See Also

ObjectManagerEvents Class
wManager.Events Namespace


OnObjectManagerPulsed Event

ObjectManagerEvents..::..OnObjectManagerPulsed Event

Occurs when object manager objects list is updated.

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static event SimpleHandler OnObjectManagerPulsed
Public Shared Event OnObjectManagerPulsed As SimpleHandler
public:
static  event SimpleHandler^ OnObjectManagerPulsed {
    void add (SimpleHandler^ value);
    void remove (SimpleHandler^ value);
}

See Also

ObjectManagerEvents Class
wManager.Events Namespace


OthersEvents Class

Class OthersEvents.

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class OthersEvents
Public NotInheritable Class OthersEvents
public ref class OthersEvents abstract sealed

Inheritance Hierarchy

Object
wManager.Events..::..OthersEvents

See Also

OthersEvents Members
wManager.Events Namespace


OthersEvents Members

The OthersEvents type exposes the following members.

Methods

Name Description

Events

Name | Description
OnAddBlackListGuid | Occurs when add black list GUID (AddBlackList(UInt64, Int32, Boolean)).
OnAddBlackListNpcEntry | Occurs when add black list NPC entry (AddBlackListNpcEntry(Int32, Boolean)).
OnAddBlacklistZone | Occurs when add blacklist zone ([wManager.wManagerSetting.AddBlackListZone(BlackListSerializable.Blackspot, bool)]).
OnAddBlackListZoneRectangle | Occurs when add black list zone rectangle (AddBlackListZoneRectangle(Vector3, Vector3)).
OnDismount | Occurs when dismount (DismountMount(Boolean, Boolean, Int32)).
OnMount | Occurs when mount ([MountTask.Mount(bool,wManager.Wow.Bot.Tasks.MountTask.MountCapacity)], MountingAquaticMount(Boolean, Boolean), MountingFlyingMount(Boolean, Boolean), MountingGroundMount(Boolean, Boolean)).
OnPathFinderFindPath | Occurs when pathfinder FindPath (FindPath(Vector3)).
OnPathFinderFindPathResult | Occurs when PathFinder path result is ready.
OnSelectQuestRewardItem | Occurs when select quest reward item (CompleteQuest(Int32)).

See Also

OthersEvents Class
wManager.Events Namespace


OthersEvents Methods

The OthersEvents type exposes the following members.

Methods

Name Description

See Also

OthersEvents Class
wManager.Events Namespace


OthersEvents Events

The OthersEvents type exposes the following members.

Events

Name | Description
OnAddBlackListGuid | Occurs when add black list GUID (AddBlackList(UInt64, Int32, Boolean)).
OnAddBlackListNpcEntry | Occurs when add black list NPC entry (AddBlackListNpcEntry(Int32, Boolean)).
OnAddBlacklistZone | Occurs when add blacklist zone ([wManager.wManagerSetting.AddBlackListZone(BlackListSerializable.Blackspot, bool)]).
OnAddBlackListZoneRectangle | Occurs when add black list zone rectangle (AddBlackListZoneRectangle(Vector3, Vector3)).
OnDismount | Occurs when dismount (DismountMount(Boolean, Boolean, Int32)).
OnMount | Occurs when mount ([MountTask.Mount(bool,wManager.Wow.Bot.Tasks.MountTask.MountCapacity)], MountingAquaticMount(Boolean, Boolean), MountingFlyingMount(Boolean, Boolean), MountingGroundMount(Boolean, Boolean)).
OnPathFinderFindPath | Occurs when pathfinder FindPath (FindPath(Vector3)).
OnPathFinderFindPathResult | Occurs when PathFinder path result is ready.
OnSelectQuestRewardItem | Occurs when select quest reward item (CompleteQuest(Int32)).

See Also

OthersEvents Class
wManager.Events Namespace


OnAddBlackListGuid Event

OthersEvents..::..OnAddBlackListGuid Event

Occurs when add black list GUID (AddBlackList(UInt64, Int32, Boolean)).

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static event OthersEvents..::..AddBlackListGuidHandler OnAddBlackListGuid
Public Shared Event OnAddBlackListGuid As OthersEvents..::..AddBlackListGuidHandler
public:
static  event OthersEvents..::..AddBlackListGuidHandler^ OnAddBlackListGuid {
    void add (OthersEvents..::..AddBlackListGuidHandler^ value);
    void remove (OthersEvents..::..AddBlackListGuidHandler^ value);
}

See Also

OthersEvents Class
wManager.Events Namespace


OnAddBlackListNpcEntry Event

OthersEvents..::..OnAddBlackListNpcEntry Event

Occurs when add black list NPC entry (AddBlackListNpcEntry(Int32, Boolean)).

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static event OthersEvents..::..AddBlackListNpcEntryHandler OnAddBlackListNpcEntry
Public Shared Event OnAddBlackListNpcEntry As OthersEvents..::..AddBlackListNpcEntryHandler
public:
static  event OthersEvents..::..AddBlackListNpcEntryHandler^ OnAddBlackListNpcEntry {
    void add (OthersEvents..::..AddBlackListNpcEntryHandler^ value);
    void remove (OthersEvents..::..AddBlackListNpcEntryHandler^ value);
}

See Also

OthersEvents Class
wManager.Events Namespace


OnAddBlacklistZone Event

OthersEvents..::..OnAddBlacklistZone Event

Occurs when add blacklist zone ([wManager.wManagerSetting.AddBlackListZone(BlackListSerializable.Blackspot, bool)]).

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static event OthersEvents..::..AddBlacklistZoneHandler OnAddBlacklistZone
Public Shared Event OnAddBlacklistZone As OthersEvents..::..AddBlacklistZoneHandler
public:
static  event OthersEvents..::..AddBlacklistZoneHandler^ OnAddBlacklistZone {
    void add (OthersEvents..::..AddBlacklistZoneHandler^ value);
    void remove (OthersEvents..::..AddBlacklistZoneHandler^ value);
}

See Also

OthersEvents Class
wManager.Events Namespace


OnAddBlackListZoneRectangle Event

OthersEvents..::..OnAddBlackListZoneRectangle Event

Occurs when add black list zone rectangle (AddBlackListZoneRectangle(Vector3, Vector3)).

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static event OthersEvents..::..AddBlackListZoneRectangleHandler OnAddBlackListZoneRectangle
Public Shared Event OnAddBlackListZoneRectangle As OthersEvents..::..AddBlackListZoneRectangleHandler
public:
static  event OthersEvents..::..AddBlackListZoneRectangleHandler^ OnAddBlackListZoneRectangle {
    void add (OthersEvents..::..AddBlackListZoneRectangleHandler^ value);
    void remove (OthersEvents..::..AddBlackListZoneRectangleHandler^ value);
}

See Also

OthersEvents Class
wManager.Events Namespace


OnDismount Event

OthersEvents..::..OnDismount Event

Occurs when dismount (DismountMount(Boolean, Boolean, Int32)).

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static event OthersEvents..::..CancelabletHandler OnDismount
Public Shared Event OnDismount As OthersEvents..::..CancelabletHandler
public:
static  event OthersEvents..::..CancelabletHandler^ OnDismount {
    void add (OthersEvents..::..CancelabletHandler^ value);
    void remove (OthersEvents..::..CancelabletHandler^ value);
}

See Also

OthersEvents Class
wManager.Events Namespace


OnMount Event

OthersEvents..::..OnMount Event

Occurs when mount ([MountTask.Mount(bool,wManager.Wow.Bot.Tasks.MountTask.MountCapacity)], MountingAquaticMount(Boolean, Boolean), MountingFlyingMount(Boolean, Boolean), MountingGroundMount(Boolean, Boolean)).

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static event OthersEvents..::..StringCancelabletHandler OnMount
Public Shared Event OnMount As OthersEvents..::..StringCancelabletHandler
public:
static  event OthersEvents..::..StringCancelabletHandler^ OnMount {
    void add (OthersEvents..::..StringCancelabletHandler^ value);
    void remove (OthersEvents..::..StringCancelabletHandler^ value);
}

See Also

OthersEvents Class
wManager.Events Namespace


OnPathFinderFindPath Event

OthersEvents..::..OnPathFinderFindPath Event

Occurs when pathfinder FindPath (FindPath(Vector3)).

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static event OthersEvents..::..VectorVectorCancelableHandler OnPathFinderFindPath
Public Shared Event OnPathFinderFindPath As OthersEvents..::..VectorVectorCancelableHandler
public:
static  event OthersEvents..::..VectorVectorCancelableHandler^ OnPathFinderFindPath {
    void add (OthersEvents..::..VectorVectorCancelableHandler^ value);
    void remove (OthersEvents..::..VectorVectorCancelableHandler^ value);
}

See Also

OthersEvents Class
wManager.Events Namespace


OnPathFinderFindPathResult Event

OthersEvents..::..OnPathFinderFindPathResult Event

Occurs when PathFinder path result is ready.

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static event OthersEvents..::..VectorVectorListVectorHandler OnPathFinderFindPathResult
Public Shared Event OnPathFinderFindPathResult As OthersEvents..::..VectorVectorListVectorHandler
public:
static  event OthersEvents..::..VectorVectorListVectorHandler^ OnPathFinderFindPathResult {
    void add (OthersEvents..::..VectorVectorListVectorHandler^ value);
    void remove (OthersEvents..::..VectorVectorListVectorHandler^ value);
}

See Also

OthersEvents Class
wManager.Events Namespace


OnSelectQuestRewardItem Event

OthersEvents..::..OnSelectQuestRewardItem Event

Occurs when select quest reward item (CompleteQuest(Int32)).

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static event OthersEvents..::..OnSelectQuestRewardItemCancelableHandler OnSelectQuestRewardItem
Public Shared Event OnSelectQuestRewardItem As OthersEvents..::..OnSelectQuestRewardItemCancelableHandler
public:
static  event OthersEvents..::..OnSelectQuestRewardItemCancelableHandler^ OnSelectQuestRewardItem {
    void add (OthersEvents..::..OnSelectQuestRewardItemCancelableHandler^ value);
    void remove (OthersEvents..::..OnSelectQuestRewardItemCancelableHandler^ value);
}

See Also

OthersEvents Class
wManager.Events Namespace


OthersEvents.AddBlackListGuidHandler Delegate

OthersEvents..::..AddBlackListGuidHandler Delegate

Delegate AddBlackListGuidHandler

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public delegate void AddBlackListGuidHandler(
    ulong guid,
    int timeInMilisec,
    bool isSessionBlacklist,
    CancelEventArgs cancelable
)
Public Delegate Sub AddBlackListGuidHandler ( _
    guid As ULong, _
    timeInMilisec As Integer, _
    isSessionBlacklist As Boolean, _
    cancelable As CancelEventArgs _
)
public delegate void AddBlackListGuidHandler(
    unsigned long long^ guid,
    int^ timeInMilisec,
    bool^ isSessionBlacklist,
    CancelEventArgs^ cancelable
)

Parameters

guid
Type: UInt64
The unique identifier.
timeInMilisec
Type: Int32
The time in milisec.
isSessionBlacklist
Type: Boolean
if set to true it will be added again to the blacklist if the continent change for example.
cancelable
Type: CancelEventArgs
The CancelEventArgs instance containing the event data.

See Also

wManager.Events Namespace


OthersEvents.AddBlackListNpcEntryHandler Delegate

OthersEvents..::..AddBlackListNpcEntryHandler Delegate

Delegate AddBlackListNpcEntryHandler

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public delegate void AddBlackListNpcEntryHandler(
    int entryId,
    bool isSessionBlacklist,
    CancelEventArgs cancelable
)
Public Delegate Sub AddBlackListNpcEntryHandler ( _
    entryId As Integer, _
    isSessionBlacklist As Boolean, _
    cancelable As CancelEventArgs _
)
public delegate void AddBlackListNpcEntryHandler(
    int^ entryId,
    bool^ isSessionBlacklist,
    CancelEventArgs^ cancelable
)

Parameters

entryId
Type: Int32
The entry identifier.
isSessionBlacklist
Type: Boolean
if set to true it will be added again to the blacklist if the continent change for example.
cancelable
Type: CancelEventArgs
The CancelEventArgs instance containing the event data.

See Also

wManager.Events Namespace


OthersEvents.AddBlacklistZoneHandler Delegate

OthersEvents..::..AddBlacklistZoneHandler Delegate

Delegate AddBlacklistZoneHandler

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public delegate void AddBlacklistZoneHandler(
    BlackListSerializable..::..Blackspot blackspot,
    bool isSessionBlacklist,
    CancelEventArgs cancelable
)
Public Delegate Sub AddBlacklistZoneHandler ( _
    blackspot As BlackListSerializable..::..Blackspot, _
    isSessionBlacklist As Boolean, _
    cancelable As CancelEventArgs _
)
public delegate void AddBlacklistZoneHandler(
    BlackListSerializable..::..Blackspot^ blackspot,
    bool^ isSessionBlacklist,
    CancelEventArgs^ cancelable
)

Parameters

blackspot
Type: wManager..::..BlackListSerializable..::..Blackspot
The blackspot.
isSessionBlacklist
Type: Boolean
if set to true it will be added again to the blacklist if the continent change for example.
cancelable
Type: CancelEventArgs
The CancelEventArgs instance containing the event data.

See Also

wManager.Events Namespace


OthersEvents.AddBlackListZoneRectangleHandler Delegate

OthersEvents..::..AddBlackListZoneRectangleHandler Delegate

Delegate AddBlackListZoneRectangleHandler

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public delegate void AddBlackListZoneRectangleHandler(
    Vector3 position1,
    Vector3 position2,
    CancelEventArgs cancelable
)
Public Delegate Sub AddBlackListZoneRectangleHandler ( _
    position1 As Vector3, _
    position2 As Vector3, _
    cancelable As CancelEventArgs _
)
public delegate void AddBlackListZoneRectangleHandler(
    Vector3^ position1,
    Vector3^ position2,
    CancelEventArgs^ cancelable
)

Parameters

position1
Type: robotManager.Helpful..::..Vector3
The position1.
position2
Type: robotManager.Helpful..::..Vector3
The position2.
cancelable
Type: CancelEventArgs
The CancelEventArgs instance containing the event data.

See Also

wManager.Events Namespace


OthersEvents.CancelabletHandler Delegate

OthersEvents..::..CancelabletHandler Delegate

Delegate CancelabletHandler

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public delegate void CancelabletHandler(
    CancelEventArgs cancelable
)
Public Delegate Sub CancelabletHandler ( _
    cancelable As CancelEventArgs _
)
public delegate void CancelabletHandler(
    CancelEventArgs^ cancelable
)

Parameters

cancelable
Type: CancelEventArgs
The CancelEventArgs instance containing the event data.

See Also

wManager.Events Namespace


OthersEvents.OnSelectQuestRewardItemCancelableHandler Delegate

OthersEvents..::..OnSelectQuestRewardItemCancelableHandler Delegate

Delegate OnSelectQuestRewardItemCancelableHandler

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public delegate void OnSelectQuestRewardItemCancelableHandler(
    CancelEventArgs cancelable
)
Public Delegate Sub OnSelectQuestRewardItemCancelableHandler ( _
    cancelable As CancelEventArgs _
)
public delegate void OnSelectQuestRewardItemCancelableHandler(
    CancelEventArgs^ cancelable
)

Parameters

cancelable
Type: CancelEventArgs
The CancelEventArgs instance containing the event data.

See Also

wManager.Events Namespace


OthersEvents.StringCancelabletHandler Delegate

OthersEvents..::..StringCancelabletHandler Delegate

Delegate StringCancelabletHandler

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public delegate void StringCancelabletHandler(
    string mountName,
    CancelEventArgs cancelable
)
Public Delegate Sub StringCancelabletHandler ( _
    mountName As String, _
    cancelable As CancelEventArgs _
)
public delegate void StringCancelabletHandler(
    String^ mountName,
    CancelEventArgs^ cancelable
)

Parameters

mountName
Type: String
Name of the mount.
cancelable
Type: CancelEventArgs
The CancelEventArgs instance containing the event data.

See Also

wManager.Events Namespace


OthersEvents.VectorVectorCancelableHandler Delegate

OthersEvents..::..VectorVectorCancelableHandler Delegate

Delegate VectorVectorCancelableHandler

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public delegate void VectorVectorCancelableHandler(
    Vector3 from,
    Vector3 to,
    string continentNameMpq,
    CancelEventArgs cancelable
)
Public Delegate Sub VectorVectorCancelableHandler ( _
    from As Vector3, _
    to As Vector3, _
    continentNameMpq As String, _
    cancelable As CancelEventArgs _
)
public delegate void VectorVectorCancelableHandler(
    Vector3^ from,
    Vector3^ to,
    String^ continentNameMpq,
    CancelEventArgs^ cancelable
)

Parameters

from
Type: robotManager.Helpful..::..Vector3
From.
to
Type: robotManager.Helpful..::..Vector3
To.
continentNameMpq
Type: String
The continent name MPQ.
cancelable
Type: CancelEventArgs
The CancelEventArgs instance containing the event data.

See Also

wManager.Events Namespace


OthersEvents.VectorVectorListVectorHandler Delegate

OthersEvents..::..VectorVectorListVectorHandler Delegate

Delegate VectorVectorListVectorHandler

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public delegate void VectorVectorListVectorHandler(
    Vector3 from,
    Vector3 to,
    List<Vector3> path,
    string continentNameMpq,
    bool resultSuccess
)
Public Delegate Sub VectorVectorListVectorHandler ( _
    from As Vector3, _
    to As Vector3, _
    path As List(Of Vector3), _
    continentNameMpq As String, _
    resultSuccess As Boolean _
)
public delegate void VectorVectorListVectorHandler(
    Vector3^ from,
    Vector3^ to,
    List<Vector3^>^ path,
    String^ continentNameMpq,
    bool^ resultSuccess
)

Parameters

from
Type: robotManager.Helpful..::..Vector3
From.
to
Type: robotManager.Helpful..::..Vector3
To.
path
Type: List <(Of <(<' Vector3 >)>)>
The path.
continentNameMpq
Type: String
The continent name MPQ.
resultSuccess
Type: Boolean
if set to true [result success].

See Also

wManager.Events Namespace


PluginEvents Class

Class PluginEvents.

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class PluginEvents
Public NotInheritable Class PluginEvents
public ref class PluginEvents abstract sealed

Inheritance Hierarchy

Object
wManager.Events..::..PluginEvents

See Also

PluginEvents Members
wManager.Events Namespace


PluginEvents Members

The PluginEvents type exposes the following members.

Methods

Name Description

Events

Name | Description
OnDisposePlugin | Occurs when dispose plugin.
OnLoadPlugin | Occurs when load plugin.

See Also

PluginEvents Class
wManager.Events Namespace


PluginEvents Methods

The PluginEvents type exposes the following members.

Methods

Name Description

See Also

PluginEvents Class
wManager.Events Namespace


PluginEvents Events

The PluginEvents type exposes the following members.

Events

Name | Description
OnDisposePlugin | Occurs when dispose plugin.
OnLoadPlugin | Occurs when load plugin.

See Also

PluginEvents Class
wManager.Events Namespace


OnDisposePlugin Event

PluginEvents..::..OnDisposePlugin Event

Occurs when dispose plugin.

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static event StringHandler OnDisposePlugin
Public Shared Event OnDisposePlugin As StringHandler
public:
static  event StringHandler^ OnDisposePlugin {
    void add (StringHandler^ value);
    void remove (StringHandler^ value);
}

See Also

PluginEvents Class
wManager.Events Namespace


OnLoadPlugin Event

PluginEvents..::..OnLoadPlugin Event

Occurs when load plugin.

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static event StringCancelableHandler OnLoadPlugin
Public Shared Event OnLoadPlugin As StringCancelableHandler
public:
static  event StringCancelableHandler^ OnLoadPlugin {
    void add (StringCancelableHandler^ value);
    void remove (StringCancelableHandler^ value);
}

See Also

PluginEvents Class
wManager.Events Namespace


TaxiEvents Class

Class TaxiEvents (Taxi).

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class TaxiEvents
Public NotInheritable Class TaxiEvents
public ref class TaxiEvents abstract sealed

Inheritance Hierarchy

Object
wManager.Events..::..TaxiEvents

See Also

TaxiEvents Members
wManager.Events Namespace


TaxiEvents Members

The TaxiEvents type exposes the following members.

Methods

Name Description

Events

Name | Description
OnAddOrEditForCurrentPlayerTaxiNode | Occurs when add or edit taxi list for current character.
OnTakeTaxiNode | Occurs when take taxi.

See Also

TaxiEvents Class
wManager.Events Namespace


TaxiEvents Methods

The TaxiEvents type exposes the following members.

Methods

Name Description

See Also

TaxiEvents Class
wManager.Events Namespace


TaxiEvents Events

The TaxiEvents type exposes the following members.

Events

Name | Description
OnAddOrEditForCurrentPlayerTaxiNode | Occurs when add or edit taxi list for current character.
OnTakeTaxiNode | Occurs when take taxi.

See Also

TaxiEvents Class
wManager.Events Namespace


OnAddOrEditForCurrentPlayerTaxiNode Event

TaxiEvents..::..OnAddOrEditForCurrentPlayerTaxiNode Event

Occurs when add or edit taxi list for current character.

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static event TaxiEvents..::..TaxiNodeCancelableHandler OnAddOrEditForCurrentPlayerTaxiNode
Public Shared Event OnAddOrEditForCurrentPlayerTaxiNode As TaxiEvents..::..TaxiNodeCancelableHandler
public:
static  event TaxiEvents..::..TaxiNodeCancelableHandler^ OnAddOrEditForCurrentPlayerTaxiNode {
    void add (TaxiEvents..::..TaxiNodeCancelableHandler^ value);
    void remove (TaxiEvents..::..TaxiNodeCancelableHandler^ value);
}

See Also

TaxiEvents Class
wManager.Events Namespace


OnTakeTaxiNode Event

TaxiEvents..::..OnTakeTaxiNode Event

Occurs when take taxi.

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static event TaxiEvents..::..TaxiNodeCancelableHandler OnTakeTaxiNode
Public Shared Event OnTakeTaxiNode As TaxiEvents..::..TaxiNodeCancelableHandler
public:
static  event TaxiEvents..::..TaxiNodeCancelableHandler^ OnTakeTaxiNode {
    void add (TaxiEvents..::..TaxiNodeCancelableHandler^ value);
    void remove (TaxiEvents..::..TaxiNodeCancelableHandler^ value);
}

See Also

TaxiEvents Class
wManager.Events Namespace


TaxiEvents.TaxiNodeCancelableHandler Delegate

TaxiEvents..::..TaxiNodeCancelableHandler Delegate

Delegate TaxiNodeCancelableHandler

Namespace: wManager.Events
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public delegate void TaxiNodeCancelableHandler(
    TaxiNode taxiNode,
    CancelEventArgs cancelable
)
Public Delegate Sub TaxiNodeCancelableHandler ( _
    taxiNode As TaxiNode, _
    cancelable As CancelEventArgs _
)
public delegate void TaxiNodeCancelableHandler(
    TaxiNode^ taxiNode,
    CancelEventArgs^ cancelable
)

Parameters

taxiNode
Type: wManager.Wow.Class..::..TaxiNode
The taxi node.
cancelable
Type: CancelEventArgs
The CancelEventArgs instance containing the event data.

See Also

wManager.Events Namespace


wManager.Plugin Namespace

Classes

 | Class | Description
Public class | PluginsManager | Class to manage plugins (IPlugin). You can use .cs (for C#), .vb (for Visual Basic.net) or .dll file (you can also use .lua if you want use lua code with LuaBot, but you don't need to implement this interface), you need to save plugin in the folder "WRobot\Plugins\" (and restart bot to appear in plugins tab).

Interfaces

 | Interface | Description
Public interface | IPlugin | Plugin interface, implement IPlugin to create your plugin. You can use .cs (for C#), .vb (for Visual Basic.net) or .dll file (you can also use .lua if you want use lua code with LuaBot, but you don't need to implement this interface), you need to save plugin in the folder "WRobot\Plugins\" (and restart bot to appear in plugins tab).


IPlugin Interface

Plugin interface, implement IPlugin to create your plugin.

You can use .cs (for C#), .vb (for Visual Basic.net) or .dll file (you can also use .lua if you want use lua code with LuaBot, but you don't need to implement this interface), you need to save plugin in the folder "WRobot\Plugins\" (and restart bot to appear in plugins tab).

Namespace: wManager.Plugin
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public interface IPlugin
Public Interface IPlugin
public interface class IPlugin

Remarks

You need to use class name "main" without namespace for that WRobot found your class.

Examples

C#
using System;
   using System.ComponentModel;
   using System.Threading;
   using System.Windows.Forms;
   using robotManager.Helpful;
   using robotManager.Products;
   using wManager.Wow.Helpers;
   using wManager.Wow.ObjectManager;

   // You need to name class "Main" and you can't use namespace
   public class Main : wManager.Plugin.IPlugin
   {
       private bool _isLaunched;

       // Called when plugin loaded.
       public void Initialize()
       {
           Logging.Write("[IgnoreAllCombat] Starting.");

           _isLaunched = true;

           // Init events (the bot events are automatically cleaned when the product is stopped):
           wManager.Events.FightEvents.OnFightStart += delegate (WoWUnit unit, CancelEventArgs cancelable)
           {
               cancelable.Cancel = true;
               if (unit.IsValid)
                   ObjectManager.BlackListGetUnitAttackPlayerGuidTime.Add(unit.Guid, DateTime.Now + TimeSpan.FromMinutes(10));
           };

           // If you need to watch something else:
           while (_isLaunched && Products.IsStarted)
           {
               try
               {
                   if (Conditions.InGameAndConnectedAndAliveAndProductStartedNotInPause)
                   {
                       // My code here
                   }
               }
               catch (Exception e)
               {
                   Logging.WriteError("[IgnoreAllCombat] " + e);
               }
               Thread.Sleep(50);
           }
       }

       // Called when plugin disposed.
       public void Dispose()
       {
           _isLaunched = false;
           Logging.Write("[IgnoreAllCombat] Disposed.");
       }

       // Called when user click on plugin settings button.
       public void Settings()
       {
           MessageBox.Show("[IgnoreAllCombat] No settings for this plugin.");
       }
   }

See Also

IPlugin Members
wManager.Plugin Namespace


IPlugin Members

The IPlugin type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | WRobot call this method when user stop an product (bot).
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | Initialize | WRobot call this method when user start an product (bot) (method is called on new thread, you need to make loop to keep your plugin alive).
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Settings | WRobot call this method when user click on plugin settings button.
Public method | ToString | (Inherited from Object.)

See Also

IPlugin Interface
wManager.Plugin Namespace


IPlugin Methods

The IPlugin type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | WRobot call this method when user stop an product (bot).
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | Initialize | WRobot call this method when user start an product (bot) (method is called on new thread, you need to make loop to keep your plugin alive).
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Settings | WRobot call this method when user click on plugin settings button.
Public method | ToString | (Inherited from Object.)

See Also

IPlugin Interface
wManager.Plugin Namespace


Dispose Method

IPlugin..::..Dispose Method

WRobot call this method when user stop an product (bot).

Namespace: wManager.Plugin
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
void Dispose()
Sub Dispose
void Dispose()

See Also

IPlugin Interface
wManager.Plugin Namespace


Initialize Method

IPlugin..::..Initialize Method

WRobot call this method when user start an product (bot) (method is called on new thread, you need to make loop to keep your plugin alive).

Namespace: wManager.Plugin
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
void Initialize()
Sub Initialize
void Initialize()

See Also

IPlugin Interface
wManager.Plugin Namespace


Settings Method

IPlugin..::..Settings Method

WRobot call this method when user click on plugin settings button.

Namespace: wManager.Plugin
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
void Settings()
Sub Settings
void Settings()

See Also

IPlugin Interface
wManager.Plugin Namespace


PluginsManager Class

Class to manage plugins (IPlugin).

You can use .cs (for C#), .vb (for Visual Basic.net) or .dll file (you can also use .lua if you want use lua code with LuaBot, but you don't need to implement this interface), you need to save plugin in the folder "WRobot\Plugins\" (and restart bot to appear in plugins tab).

Namespace: wManager.Plugin
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class PluginsManager
Public Class PluginsManager
public ref class PluginsManager

Inheritance Hierarchy

Object
wManager.Plugin..::..PluginsManager

See Also

PluginsManager Members
wManager.Plugin Namespace


PluginsManager Members

The PluginsManager type exposes the following members.

Methods

 | Name | Description
 | DisposeAllPlugins | Dispose all plugins.
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
 | LoadAllPlugins | Load all plugins (plugins activated by user in wManagerSetting).
Protected method | MemberwiseClone | (Inherited from Object.)
 | SettingsPlugin | Settings the plugin by file name.
Public method | ToString | (Inherited from Object.)

See Also

PluginsManager Class
wManager.Plugin Namespace


PluginsManager Methods

The PluginsManager type exposes the following members.

Methods

 | Name | Description
 | DisposeAllPlugins | Dispose all plugins.
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
 | LoadAllPlugins | Load all plugins (plugins activated by user in wManagerSetting).
Protected method | MemberwiseClone | (Inherited from Object.)
 | SettingsPlugin | Settings the plugin by file name.
Public method | ToString | (Inherited from Object.)

See Also

PluginsManager Class
wManager.Plugin Namespace


DisposeAllPlugins Method

PluginsManager..::..DisposeAllPlugins Method

Dispose all plugins.

Namespace: wManager.Plugin
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void DisposeAllPlugins()
Public Shared Sub DisposeAllPlugins
public:
static void DisposeAllPlugins()

See Also

PluginsManager Class
wManager.Plugin Namespace


LoadAllPlugins Method

PluginsManager..::..LoadAllPlugins Method

Load all plugins (plugins activated by user in wManagerSetting).

Namespace: wManager.Plugin
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void LoadAllPlugins()
Public Shared Sub LoadAllPlugins
public:
static void LoadAllPlugins()

See Also

PluginsManager Class
wManager.Plugin Namespace


SettingsPlugin Method

PluginsManager..::..SettingsPlugin Method

Settings the plugin by file name.

Namespace: wManager.Plugin
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void SettingsPlugin(
    string fileName
)
Public Shared Sub SettingsPlugin ( _
    fileName As String _
)
public:
static void SettingsPlugin(
    String^ fileName
)

Parameters

fileName
Type: String
Name of the file (like "MyPlugin.cs" or "MyPlugin.dll").

See Also

PluginsManager Class
wManager.Plugin Namespace


wManager.Wow Namespace

Classes

 | Class | Description
Public class | Memory | Memory Class


Memory Class

Memory Class

Namespace: wManager.Wow
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class Memory
Public NotInheritable Class Memory
public ref class Memory abstract sealed

Inheritance Hierarchy

Object
wManager.Wow..::..Memory

See Also

Memory Members
wManager.Wow Namespace


Memory Members

The Memory type exposes the following members.

Methods

Name | Description
D3D9AdresseByMemoryRead |
DetourAddress |
GetOffset | Get offset.
IsD3D9 | Check if game use Directx9
IsGoodVersion | Determine whether is good version.
IsInGame | Determines whether is in game.
OriginalOpCode |
PlayerName | Get local player name.

Fields

Name | Description
WowMemory | The wow memory

See Also

Memory Class
wManager.Wow Namespace


Memory Fields

The Memory type exposes the following members.

Fields

Name | Description
WowMemory | The wow memory

See Also

Memory Class
wManager.Wow Namespace


WowMemory Field

Memory..::..WowMemory Field

The wow memory

Namespace: wManager.Wow
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static Hook WowMemory
Public Shared WowMemory As Hook
public:
static Hook^ WowMemory

See Also

Memory Class
wManager.Wow Namespace


Memory Methods

The Memory type exposes the following members.

Methods

Name | Description
D3D9AdresseByMemoryRead |
DetourAddress |
GetOffset | Get offset.
IsD3D9 | Check if game use Directx9
IsGoodVersion | Determine whether is good version.
IsInGame | Determines whether is in game.
OriginalOpCode |
PlayerName | Get local player name.

See Also

Memory Class
wManager.Wow Namespace


D3D9AdresseByMemoryRead Method

Memory..::..D3D9AdresseByMemoryRead Method

Namespace: wManager.Wow
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static uint D3D9AdresseByMemoryRead(
    Memory memory
)
Public Shared Function D3D9AdresseByMemoryRead ( _
    memory As Memory _
) As UInteger
public:
static unsigned int^ D3D9AdresseByMemoryRead(
    Memory^ memory
)

Parameters

memory
Type: Memory

See Also

Memory Class
wManager.Wow Namespace


DetourAddress Method

Memory..::..DetourAddress Method

Namespace: wManager.Wow
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static uint DetourAddress(
    int processId
)
Public Shared Function DetourAddress ( _
    processId As Integer _
) As UInteger
public:
static unsigned int^ DetourAddress(
    int^ processId
)

Parameters

processId
Type: Int32

See Also

Memory Class
wManager.Wow Namespace


GetOffset Method

Memory..::..GetOffset Method

Get offset.

Namespace: wManager.Wow
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static uint GetOffset(
    string pattern,
    int position,
    bool isFunction,
    bool rebase,
    Memory memory
)
Public Shared Function GetOffset ( _
    pattern As String, _
    position As Integer, _
    isFunction As Boolean, _
    rebase As Boolean, _
    memory As Memory _
) As UInteger
public:
static unsigned int^ GetOffset(
    String^ pattern,
    int^ position,
    bool^ isFunction,
    bool^ rebase,
    Memory^ memory
)

Parameters

pattern
Type: String
The pattern.
position
Type: Int32
The position.
isFunction
Type: Boolean
if set to true is function.
rebase
Type: Boolean
if set to true rebase.
memory
Type: Memory
The memory.

Return Value

Ptr.

See Also

Memory Class
wManager.Wow Namespace


IsD3D9 Method

Memory..::..IsD3D9 Method

Check if game use Directx9

Namespace: wManager.Wow
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool IsD3D9(
    int processId
)
Public Shared Function IsD3D9 ( _
    processId As Integer _
) As Boolean
public:
static bool^ IsD3D9(
    int^ processId
)

Parameters

processId
Type: Int32

See Also

Memory Class
wManager.Wow Namespace


IsGoodVersion Method

Memory..::..IsGoodVersion Method

Determine whether is good version.

Namespace: wManager.Wow
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[ObfuscationAttribute]
public static bool IsGoodVersion(
    int processId
)
<ObfuscationAttribute> _
Public Shared Function IsGoodVersion ( _
    processId As Integer _
) As Boolean
[ObfuscationAttribute]
public:
static bool^ IsGoodVersion(
    int^ processId
)

Parameters

processId
Type: Int32
The process id.

Return Value

true if is good version; otherwise, false.

See Also

Memory Class
wManager.Wow Namespace


IsInGame Method

Memory..::..IsInGame Method

Determines whether is in game.

Namespace: wManager.Wow
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool IsInGame(
    int processId
)
Public Shared Function IsInGame ( _
    processId As Integer _
) As Boolean
public:
static bool^ IsInGame(
    int^ processId
)

Parameters

processId
Type: Int32
The process od.

Return Value

true if is in game; otherwise, false.

See Also

Memory Class
wManager.Wow Namespace


OriginalOpCode Method

Memory..::..OriginalOpCode Method

Namespace: wManager.Wow
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static byte[] OriginalOpCode(
    int processId
)
Public Shared Function OriginalOpCode ( _
    processId As Integer _
) As Byte()
public:
static array<unsigned char^>^ OriginalOpCode(
    int^ processId
)

Parameters

processId
Type: Int32

See Also

Memory Class
wManager.Wow Namespace


PlayerName Method

Memory..::..PlayerName Method

Get local player name.

Namespace: wManager.Wow
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string PlayerName(
    int processId
)
Public Shared Function PlayerName ( _
    processId As Integer _
) As String
public:
static String^ PlayerName(
    int^ processId
)

Parameters

processId
Type: Int32
The process id.

Return Value

System.String.

See Also

Memory Class
wManager.Wow Namespace


wManager.Wow.Bot.States Namespace

Classes

 | Class | Description
Public class | AntiAfk | Anti-afk State.
Public class | ArchaeologyStates | Archaeology State (search and go to dig-sites, search the fragments).
Public class | BattlegrounderCombination | Battlegrounder combination State, this State is used in products usable with Battlegrounder product, put high Priority, it is usually just below Pause.
Public class | BattlePetState | Pet battle State, call StartFight()()()() if in pet battle.
Public class | Farming | Farming State, search and farm WoWGameObject.
Public class | FarmingBG | Class FarmingBG. Used to interact with battleground gameobjects (like door, ...). Implements the State
Public class | FarmingRange | Class FarmingRange. LootAndHarvestRangeQuickly. Implements the Farming
Public class | FightHostileTarget | Class FightHostileTarget. Used by product "WRotation", this state [Fight.StartFight(MemoryRobot.Int128, bool, bool, bool, bool)] with current character target. Implements the State
Public class | FlightMasterDiscoverState | Class FlightMasterDiscoverState. Used if FlightMasterDiscoverRange enabled. Implements the State
Public class | FlightMasterTakeTaxiState | Class FlightMasterTakeTaxiState. Use to take taxi at flightmaster if InMovement (to reach destination position of CurrentPathOrigine), behavior set with options FlightMasterTaxiUse, FlightMasterTaxiDistance, FlightMasterTaxiUseOnlyIfNear. Can be used without state with static methods NeedToRunStatic and RunStatic()()()(). Implements the State
Public class | Grinding | Class Grinding. To kills mobs. Implements the State
Public class | GrindingBG | Class GrindingBG. To attack opposing faction players. Implements the State
Public class | GrindingNearestMobs | Class GrindingNearestMobs. To kills enemies mobs near. Implements the State
Public class | Idle | Class Idle. This state is in last position (lower Priority) of Engine states. It is called only if no states are executed, it allows to lower the CPU usage (with a Sleep(System.Int32)) Implements the State
Public class | IsAttacked | Class IsAttacked. Call [Fight.StartFight(MemoryRobot.Int128, bool, bool, bool, bool)] if player is in combat and cannot ignore that (IsAttackedAndCannotIgnore) Implements the State
Public class | Looting | Class Looting. If lootable corpses call Pulse(List<(Of <<'(WoWUnit>)>>)). Implements the State
Public class | LootingRange | Class LootingRange. LootAndHarvestRangeQuickly. Implements the Looting
Public class | MillingState | Class MillingState. State of option Milling. Implements the State
Public class | MountingState | Class MountingState. To use mount (this state is not used by the bot). Implements the State
Public class | MovementLoop | Class MovementLoop. Manage profile path in products like Grinder or Gatherer. If bot is not InMovement or CurrentPathOrigine is different that PathLoop bot run this state. Must be one of the last states of Engine. Implements the State
Public class | MovementRandomInCircle | Class MovementRandomInCircle. Used in Automaton product to move to random position when no task to do near. If not InMovement bot run this state. Must be one of the last states of Engine. Implements the State
Public class | MyMacro | Class MyMacro. To run wManagerSetting..::..MyMacro Implements the State
Public class | NPCScanState | Class NPCScanState. For options NpcScanAuctioneer, NpcScanMailboxes, NpcScanRepair, NpcScanVendor, but also for ExtractGameObjects()()()(). Implements the State Usually bot don't use this class as State, but call LaunchNewThread()()()() when product start and StopThread()()()() when product is stopped
Public class | Pause | Class Pause. NeedToRun return true when InPause. All states with lower priority will not be executed while the bot is paused. Implements the State
Public class | ProspectingState | Class ProspectingState. Prospecting Implements the State
Public class | Regeneration | Class Regeneration. To restore health points and mana of character. Use regen options that you can found in wManagerSetting Implements the State
Public class | Relogger | Class Relogger. reconnect the character to the game when he is disconnected. You need to use option Relogger Implements the State
Public class | Resurrect | Class Resurrect. To revive when dead(with corpse or spirit healer, options in wManagerSetting). Implements the State
Public class | ResurrectBG | Class ResurrectBG. To revive when dead in battleground. Implements the State
Public class | SmeltingState | Class SmeltingState. Look Smelting Implements the State
Public class | SpellState | Class SpellState. This class was created for FightClasses in XML (create with Creator), the bot converted XML to C# code that use this state for the spells, this class is not practical and should not be used in any other context. Implements the State
Public class | StopBotIf | Class StopBotIf. This state manages the various security options found in wManagerSetting (teleportation, pathfinder down, blockages, whispers, players nearby, ...). Class is mainly not used as State, but product call LaunchNewThread()()()() when starting and StopThread()()()() when stopped. Implements the State
Public class | Talents | Class Talents. If option AssignTalents is enabled use class Talent Implements the State
Public class | ToTown | Class ToTown. To repair, sell, send mail, buy items (options can be found in wManagerSetting Implements the State
Public class | Trainers | Class Trainers. TrainNewSkills Implements the State


AntiAfk Class

Anti-afk State.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class AntiAfk : State
Public Class AntiAfk _
    Inherits State
public ref class AntiAfk : public State

Inheritance Hierarchy

Object
robotManager.FiniteStateMachine..::..State
wManager.Wow.Bot.States..::..AntiAfk

See Also

AntiAfk Members
wManager.Wow.Bot.States Namespace


AntiAfk Members

The AntiAfk type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
 | Pulse | You can call frequently this method manually to avoid AFK, this method is automatically called by AntiAfk
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

AntiAfk Class
wManager.Wow.Bot.States Namespace


AntiAfk Methods

The AntiAfk type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
 | Pulse | You can call frequently this method manually to avoid AFK, this method is automatically called by AntiAfk
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

See Also

AntiAfk Class
wManager.Wow.Bot.States Namespace


Pulse Method

AntiAfk..::..Pulse Method

You can call frequently this method manually to avoid AFK, this method is automatically called by AntiAfk

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void Pulse()
Public Shared Sub Pulse
public:
static void Pulse()

See Also

AntiAfk Class
wManager.Wow.Bot.States Namespace


Run Method

AntiAfk..::..Run Method

Runs this instance.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Run()
Public Sub Run
public:
void Run()

See Also

AntiAfk Class
wManager.Wow.Bot.States Namespace


AntiAfk Properties

The AntiAfk type exposes the following members.

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

AntiAfk Class
wManager.Wow.Bot.States Namespace


DisplayName Property

AntiAfk..::..DisplayName Property

Gets the display name.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string DisplayName { get; }
Public ReadOnly Property DisplayName As String
    Get
public:
property String^ DisplayName {
    String^ get ();
}

Field Value

The display name.

See Also

AntiAfk Class
wManager.Wow.Bot.States Namespace


NeedToRun Property

AntiAfk..::..NeedToRun Property

Indicate if Engine need to call method Run()()()().

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool NeedToRun { get; }
Public ReadOnly Property NeedToRun As Boolean
    Get
public:
property bool^ NeedToRun {
    bool^ get ();
}

Field Value

true if need to run; otherwise, false .

See Also

AntiAfk Class
wManager.Wow.Bot.States Namespace


ArchaeologyStates Class

Archaeology State (search and go to dig-sites, search the fragments).

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class ArchaeologyStates : State
Public Class ArchaeologyStates _
    Inherits State
public ref class ArchaeologyStates : public State

Inheritance Hierarchy

Object
robotManager.FiniteStateMachine..::..State
wManager.Wow.Bot.States..::..ArchaeologyStates

See Also

ArchaeologyStates Members
wManager.Wow.Bot.States Namespace


ArchaeologyStates Members

The ArchaeologyStates type exposes the following members.

Constructors

 | Name | Description
Public method | ArchaeologyStates | Initializes a new instance of the ArchaeologyStates class.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | CompleteFragments | To complete fragments when resolve artifacts
Public field | MaxTryByDigsite | Maximum try by digsite
Public field | SolvingEveryXMin | Resolve artifacts every x minimum

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

ArchaeologyStates Class
wManager.Wow.Bot.States Namespace


ArchaeologyStates Constructor

Initializes a new instance of the ArchaeologyStates class.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public ArchaeologyStates()
Public Sub New
public:
ArchaeologyStates()

See Also

ArchaeologyStates Class
wManager.Wow.Bot.States Namespace


ArchaeologyStates Fields

The ArchaeologyStates type exposes the following members.

Fields

 | Name | Description
Public field | CompleteFragments | To complete fragments when resolve artifacts
Public field | MaxTryByDigsite | Maximum try by digsite
Public field | SolvingEveryXMin | Resolve artifacts every x minimum

See Also

ArchaeologyStates Class
wManager.Wow.Bot.States Namespace


CompleteFragments Field

ArchaeologyStates..::..CompleteFragments Field

To complete fragments when resolve artifacts

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool CompleteFragments
Public CompleteFragments As Boolean
public:
bool^ CompleteFragments

See Also

ArchaeologyStates Class
wManager.Wow.Bot.States Namespace


MaxTryByDigsite Field

ArchaeologyStates..::..MaxTryByDigsite Field

Maximum try by digsite

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int MaxTryByDigsite
Public MaxTryByDigsite As Integer
public:
int^ MaxTryByDigsite

See Also

ArchaeologyStates Class
wManager.Wow.Bot.States Namespace


SolvingEveryXMin Field

ArchaeologyStates..::..SolvingEveryXMin Field

Resolve artifacts every x minimum

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int SolvingEveryXMin
Public SolvingEveryXMin As Integer
public:
int^ SolvingEveryXMin

See Also

ArchaeologyStates Class
wManager.Wow.Bot.States Namespace


ArchaeologyStates Methods

The ArchaeologyStates type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

See Also

ArchaeologyStates Class
wManager.Wow.Bot.States Namespace


Run Method

ArchaeologyStates..::..Run Method

Runs this instance.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Run()
Public Sub Run
public:
void Run()

See Also

ArchaeologyStates Class
wManager.Wow.Bot.States Namespace


ArchaeologyStates Properties

The ArchaeologyStates type exposes the following members.

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

ArchaeologyStates Class
wManager.Wow.Bot.States Namespace


DisplayName Property

ArchaeologyStates..::..DisplayName Property

Gets the display name.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string DisplayName { get; }
Public ReadOnly Property DisplayName As String
    Get
public:
property String^ DisplayName {
    String^ get ();
}

Field Value

The display name.

See Also

ArchaeologyStates Class
wManager.Wow.Bot.States Namespace


NeedToRun Property

ArchaeologyStates..::..NeedToRun Property

Indicate if Engine need to call method Run()()()().

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool NeedToRun { get; }
Public ReadOnly Property NeedToRun As Boolean
    Get
public:
property bool^ NeedToRun {
    bool^ get ();
}

Field Value

true if need to run; otherwise, false .

See Also

ArchaeologyStates Class
wManager.Wow.Bot.States Namespace


BattlegrounderCombination Class

Battlegrounder combination State, this State is used in products usable with Battlegrounder product, put high Priority, it is usually just below Pause.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class BattlegrounderCombination : State
Public Class BattlegrounderCombination _
    Inherits State
public ref class BattlegrounderCombination : public State

Inheritance Hierarchy

Object
robotManager.FiniteStateMachine..::..State
wManager.Wow.Bot.States..::..BattlegrounderCombination

See Also

BattlegrounderCombination Members
wManager.Wow.Bot.States Namespace


BattlegrounderCombination Members

The BattlegrounderCombination type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

BattlegrounderCombination Class
wManager.Wow.Bot.States Namespace


BattlegrounderCombination Methods

The BattlegrounderCombination type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

See Also

BattlegrounderCombination Class
wManager.Wow.Bot.States Namespace


Run Method

BattlegrounderCombination..::..Run Method

Runs this instance.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Run()
Public Sub Run
public:
void Run()

See Also

BattlegrounderCombination Class
wManager.Wow.Bot.States Namespace


BattlegrounderCombination Properties

The BattlegrounderCombination type exposes the following members.

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

BattlegrounderCombination Class
wManager.Wow.Bot.States Namespace


DisplayName Property

BattlegrounderCombination..::..DisplayName Property

Gets the display name.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string DisplayName { get; }
Public ReadOnly Property DisplayName As String
    Get
public:
property String^ DisplayName {
    String^ get ();
}

Field Value

The display name.

See Also

BattlegrounderCombination Class
wManager.Wow.Bot.States Namespace


NeedToRun Property

BattlegrounderCombination..::..NeedToRun Property

Indicate if Engine need to call method Run()()()().

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool NeedToRun { get; }
Public ReadOnly Property NeedToRun As Boolean
    Get
public:
property bool^ NeedToRun {
    bool^ get ();
}

Field Value

true if need to run; otherwise, false .

See Also

BattlegrounderCombination Class
wManager.Wow.Bot.States Namespace


BattlePetState Class

Pet battle State, call StartFight()()()() if in pet battle.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class BattlePetState : State
Public Class BattlePetState _
    Inherits State
public ref class BattlePetState : public State

Inheritance Hierarchy

Object
robotManager.FiniteStateMachine..::..State
wManager.Wow.Bot.States..::..BattlePetState

See Also

BattlePetState Members
wManager.Wow.Bot.States Namespace


BattlePetState Members

The BattlePetState type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

BattlePetState Class
wManager.Wow.Bot.States Namespace


BattlePetState Methods

The BattlePetState type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

See Also

BattlePetState Class
wManager.Wow.Bot.States Namespace


Run Method

BattlePetState..::..Run Method

Runs this instance.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Run()
Public Sub Run
public:
void Run()

See Also

BattlePetState Class
wManager.Wow.Bot.States Namespace


BattlePetState Properties

The BattlePetState type exposes the following members.

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

BattlePetState Class
wManager.Wow.Bot.States Namespace


DisplayName Property

BattlePetState..::..DisplayName Property

Gets the display name.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string DisplayName { get; }
Public ReadOnly Property DisplayName As String
    Get
public:
property String^ DisplayName {
    String^ get ();
}

Field Value

The display name.

See Also

BattlePetState Class
wManager.Wow.Bot.States Namespace


NeedToRun Property

BattlePetState..::..NeedToRun Property

Indicate if Engine need to call method Run()()()().

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool NeedToRun { get; }
Public ReadOnly Property NeedToRun As Boolean
    Get
public:
property bool^ NeedToRun {
    bool^ get ();
}

Field Value

true if need to run; otherwise, false .

See Also

BattlePetState Class
wManager.Wow.Bot.States Namespace


Farming Class

Farming State, search and farm WoWGameObject.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class Farming : State
Public Class Farming _
    Inherits State
public ref class Farming : public State

Inheritance Hierarchy

Object
robotManager.FiniteStateMachine..::..State
wManager.Wow.Bot.States..::..Farming

See Also

Farming Members
wManager.Wow.Bot.States Namespace


Farming Members

The Farming type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
 | PlayerNearest | Cancel farm if another player is within HarvestAvoidPlayersRadius yards (need also option IgnoreIfInBlackListZone to be called by Farming).
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | AutoMountIfSuccess | Put "true" to mount after all farm.
Public field | ByGatherEntryOnly | Put "true" to harvests only objects of the lists GatherEntry and GatherNames (ignore herbs, mines, ...).
Public field | ForceSkipInOutDoors | Put "true" to force to activate option SkipInOutDoors.
Public field | GatherEntry | List of Entry to harvest.
Public field | GatherNames | List of Name to harvest (like is appear in game).
Public field | IgnoreBlackListed | Put "true" to skip blacklisted nodes.
Public field | IgnoreIfInBlackListZone | Put "true" to skip nodes in zone blacklisted (HarvestAvoidPlayersRadius).
Public field | IgnoreIfPlayerNear | Put "true" to skip node if any player near.
Public field | InRangeOnly | Loot only in range (if don't need to move) LootAndHarvestRangeQuickly.
Public field | RandomizeNodePositionFly | Fly only, randomize landing position, use small distance, no more than 2.5, this option can add bugs or fails some farming

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | NodeTarget | Gets target node.
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

Farming Class
wManager.Wow.Bot.States Namespace


Farming Fields

The Farming type exposes the following members.

Fields

 | Name | Description
Public field | AutoMountIfSuccess | Put "true" to mount after all farm.
Public field | ByGatherEntryOnly | Put "true" to harvests only objects of the lists GatherEntry and GatherNames (ignore herbs, mines, ...).
Public field | ForceSkipInOutDoors | Put "true" to force to activate option SkipInOutDoors.
Public field | GatherEntry | List of Entry to harvest.
Public field | GatherNames | List of Name to harvest (like is appear in game).
Public field | IgnoreBlackListed | Put "true" to skip blacklisted nodes.
Public field | IgnoreIfInBlackListZone | Put "true" to skip nodes in zone blacklisted (HarvestAvoidPlayersRadius).
Public field | IgnoreIfPlayerNear | Put "true" to skip node if any player near.
Public field | InRangeOnly | Loot only in range (if don't need to move) LootAndHarvestRangeQuickly.
Public field | RandomizeNodePositionFly | Fly only, randomize landing position, use small distance, no more than 2.5, this option can add bugs or fails some farming

See Also

Farming Class
wManager.Wow.Bot.States Namespace


AutoMountIfSuccess Field

Farming..::..AutoMountIfSuccess Field

Put "true" to mount after all farm.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool AutoMountIfSuccess
Public AutoMountIfSuccess As Boolean
public:
bool^ AutoMountIfSuccess

See Also

Farming Class
wManager.Wow.Bot.States Namespace


ByGatherEntryOnly Field

Farming..::..ByGatherEntryOnly Field

Put "true" to harvests only objects of the lists GatherEntry and GatherNames (ignore herbs, mines, ...).

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool ByGatherEntryOnly
Public ByGatherEntryOnly As Boolean
public:
bool^ ByGatherEntryOnly

See Also

Farming Class
wManager.Wow.Bot.States Namespace


ForceSkipInOutDoors Field

Farming..::..ForceSkipInOutDoors Field

Put "true" to force to activate option SkipInOutDoors.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool ForceSkipInOutDoors
Public ForceSkipInOutDoors As Boolean
public:
bool^ ForceSkipInOutDoors

See Also

Farming Class
wManager.Wow.Bot.States Namespace


GatherEntry Field

Farming..::..GatherEntry Field

List of Entry to harvest.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<int> GatherEntry
Public GatherEntry As List(Of Integer)
public:
List<int^>^ GatherEntry

See Also

Farming Class
wManager.Wow.Bot.States Namespace


GatherNames Field

Farming..::..GatherNames Field

List of Name to harvest (like is appear in game).

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<string> GatherNames
Public GatherNames As List(Of String)
public:
List<String^>^ GatherNames

See Also

Farming Class
wManager.Wow.Bot.States Namespace


IgnoreBlackListed Field

Farming..::..IgnoreBlackListed Field

Put "true" to skip blacklisted nodes.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IgnoreBlackListed
Public IgnoreBlackListed As Boolean
public:
bool^ IgnoreBlackListed

See Also

Farming Class
wManager.Wow.Bot.States Namespace


IgnoreIfInBlackListZone Field

Farming..::..IgnoreIfInBlackListZone Field

Put "true" to skip nodes in zone blacklisted (HarvestAvoidPlayersRadius).

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IgnoreIfInBlackListZone
Public IgnoreIfInBlackListZone As Boolean
public:
bool^ IgnoreIfInBlackListZone

See Also

Farming Class
wManager.Wow.Bot.States Namespace


IgnoreIfPlayerNear Field

Farming..::..IgnoreIfPlayerNear Field

Put "true" to skip node if any player near.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IgnoreIfPlayerNear
Public IgnoreIfPlayerNear As Boolean
public:
bool^ IgnoreIfPlayerNear

See Also

Farming Class
wManager.Wow.Bot.States Namespace


InRangeOnly Field

Farming..::..InRangeOnly Field

Loot only in range (if don't need to move) LootAndHarvestRangeQuickly.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool InRangeOnly
Public InRangeOnly As Boolean
public:
bool^ InRangeOnly

See Also

Farming Class
wManager.Wow.Bot.States Namespace


RandomizeNodePositionFly Field

Farming..::..RandomizeNodePositionFly Field

Fly only, randomize landing position, use small distance, no more than 2.5, this option can add bugs or fails some farming

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float RandomizeNodePositionFly
Public RandomizeNodePositionFly As Single
public:
float^ RandomizeNodePositionFly

See Also

Farming Class
wManager.Wow.Bot.States Namespace


Farming Methods

The Farming type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
 | PlayerNearest | Cancel farm if another player is within HarvestAvoidPlayersRadius yards (need also option IgnoreIfInBlackListZone to be called by Farming).
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

See Also

Farming Class
wManager.Wow.Bot.States Namespace


PlayerNearest Method

Farming..::..PlayerNearest Method

Cancel farm if another player is within HarvestAvoidPlayersRadius yards (need also option IgnoreIfInBlackListZone to be called by Farming).

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool PlayerNearest(
    WoWGameObject node
)
Public Shared Function PlayerNearest ( _
    node As WoWGameObject _
) As Boolean
public:
static bool^ PlayerNearest(
    WoWGameObject^ node
)

Parameters

node
Type: wManager.Wow.ObjectManager..::..WoWGameObject
The node.

See Also

Farming Class
wManager.Wow.Bot.States Namespace


Run Method

Farming..::..Run Method

Runs this instance.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Run()
Public Sub Run
public:
void Run()

See Also

Farming Class
wManager.Wow.Bot.States Namespace


Farming Properties

The Farming type exposes the following members.

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | NodeTarget | Gets target node.
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

Farming Class
wManager.Wow.Bot.States Namespace


DisplayName Property

Farming..::..DisplayName Property

Gets the display name.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string DisplayName { get; }
Public ReadOnly Property DisplayName As String
    Get
public:
property String^ DisplayName {
    String^ get ();
}

Field Value

The display name.

See Also

Farming Class
wManager.Wow.Bot.States Namespace


NeedToRun Property

Farming..::..NeedToRun Property

Indicate if Engine need to call method Run()()()().

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool NeedToRun { get; }
Public ReadOnly Property NeedToRun As Boolean
    Get
public:
property bool^ NeedToRun {
    bool^ get ();
}

Field Value

true if need to run; otherwise, false .

See Also

Farming Class
wManager.Wow.Bot.States Namespace


NodeTarget Property

Farming..::..NodeTarget Property

Gets target node.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public WoWGameObject NodeTarget { get; }
Public ReadOnly Property NodeTarget As WoWGameObject
    Get
public:
property WoWGameObject^ NodeTarget {
    WoWGameObject^ get ();
}

Field Value

The node target.

See Also

Farming Class
wManager.Wow.Bot.States Namespace


FarmingBG Class

Class FarmingBG. Used to interact with battleground gameobjects (like door, ...). Implements the State

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class FarmingBG : State
Public Class FarmingBG _
    Inherits State
public ref class FarmingBG : public State

Inheritance Hierarchy

Object
robotManager.FiniteStateMachine..::..State
wManager.Wow.Bot.States..::..FarmingBG

See Also

FarmingBG Members
wManager.Wow.Bot.States Namespace
robotManager.FiniteStateMachine..::..State


FarmingBG Members

The FarmingBG type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

FarmingBG Class
wManager.Wow.Bot.States Namespace


FarmingBG Methods

The FarmingBG type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

See Also

FarmingBG Class
wManager.Wow.Bot.States Namespace


Run Method

FarmingBG..::..Run Method

Runs this instance.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Run()
Public Sub Run
public:
void Run()

See Also

FarmingBG Class
wManager.Wow.Bot.States Namespace


FarmingBG Properties

The FarmingBG type exposes the following members.

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

FarmingBG Class
wManager.Wow.Bot.States Namespace


DisplayName Property

FarmingBG..::..DisplayName Property

Gets the display name.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string DisplayName { get; }
Public ReadOnly Property DisplayName As String
    Get
public:
property String^ DisplayName {
    String^ get ();
}

Field Value

The display name.

See Also

FarmingBG Class
wManager.Wow.Bot.States Namespace


NeedToRun Property

FarmingBG..::..NeedToRun Property

Indicate if Engine need to call method Run()()()().

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool NeedToRun { get; }
Public ReadOnly Property NeedToRun As Boolean
    Get
public:
property bool^ NeedToRun {
    bool^ get ();
}

Field Value

true if need to run; otherwise, false .

See Also

FarmingBG Class
wManager.Wow.Bot.States Namespace


FarmingRange Class

Class FarmingRange. LootAndHarvestRangeQuickly. Implements the Farming

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class FarmingRange : Farming
Public Class FarmingRange _
    Inherits Farming
public ref class FarmingRange : public Farming

Inheritance Hierarchy

Object
robotManager.FiniteStateMachine..::..State
wManager.Wow.Bot.States..::..Farming
wManager.Wow.Bot.States..::..FarmingRange

See Also

FarmingRange Members
wManager.Wow.Bot.States Namespace
wManager.Wow.Bot.States..::..Farming


FarmingRange Members

The FarmingRange type exposes the following members.

Constructors

 | Name | Description
Public method | FarmingRange | Initializes a new instance of the FarmingRange class.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance. (Inherited from Farming.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()(). (Inherited from Farming.)
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | NodeTarget | Gets target node. (Inherited from Farming.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

FarmingRange Class
wManager.Wow.Bot.States Namespace


FarmingRange Constructor

Initializes a new instance of the FarmingRange class.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public FarmingRange()
Public Sub New
public:
FarmingRange()

See Also

FarmingRange Class
wManager.Wow.Bot.States Namespace


FarmingRange Methods

The FarmingRange type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance. (Inherited from Farming.)
Public method | ToString | (Inherited from Object.)

See Also

FarmingRange Class
wManager.Wow.Bot.States Namespace


FarmingRange Properties

The FarmingRange type exposes the following members.

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()(). (Inherited from Farming.)
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | NodeTarget | Gets target node. (Inherited from Farming.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

FarmingRange Class
wManager.Wow.Bot.States Namespace


DisplayName Property

FarmingRange..::..DisplayName Property

Gets the display name.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string DisplayName { get; }
Public ReadOnly Property DisplayName As String
    Get
public:
property String^ DisplayName {
    String^ get ();
}

Field Value

The display name.

See Also

FarmingRange Class
wManager.Wow.Bot.States Namespace


FightHostileTarget Class

Class FightHostileTarget. Used by product "WRotation", this state [Fight.StartFight(MemoryRobot.Int128, bool, bool, bool, bool)] with current character target. Implements the State

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class FightHostileTarget : State
Public Class FightHostileTarget _
    Inherits State
public ref class FightHostileTarget : public State

Inheritance Hierarchy

Object
robotManager.FiniteStateMachine..::..State
wManager.Wow.Bot.States..::..FightHostileTarget

See Also

FightHostileTarget Members
wManager.Wow.Bot.States Namespace
robotManager.FiniteStateMachine..::..State


FightHostileTarget Members

The FightHostileTarget type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | AttackAll | Attack all character target (even if friendly)
Public field | AttackOnlyIfFlaggedInCombat | [Fight.StartFight(MemoryRobot.Int128, bool, bool, bool, bool)] only when character flagged in combat
Public field | ManageMovement | If activated the bot will move the character when he is in combat, if deactivated the movement will be 100% controlled by user.
Public field | SkipIfPlayerAttackedButNotByTheTarget | Skip if player attacked but not by the target

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

FightHostileTarget Class
wManager.Wow.Bot.States Namespace


FightHostileTarget Fields

The FightHostileTarget type exposes the following members.

Fields

 | Name | Description
Public field | AttackAll | Attack all character target (even if friendly)
Public field | AttackOnlyIfFlaggedInCombat | [Fight.StartFight(MemoryRobot.Int128, bool, bool, bool, bool)] only when character flagged in combat
Public field | ManageMovement | If activated the bot will move the character when he is in combat, if deactivated the movement will be 100% controlled by user.
Public field | SkipIfPlayerAttackedButNotByTheTarget | Skip if player attacked but not by the target

See Also

FightHostileTarget Class
wManager.Wow.Bot.States Namespace


AttackAll Field

FightHostileTarget..::..AttackAll Field

Attack all character target (even if friendly)

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool AttackAll
Public AttackAll As Boolean
public:
bool^ AttackAll

See Also

FightHostileTarget Class
wManager.Wow.Bot.States Namespace


AttackOnlyIfFlaggedInCombat Field

FightHostileTarget..::..AttackOnlyIfFlaggedInCombat Field

[Fight.StartFight(MemoryRobot.Int128, bool, bool, bool, bool)] only when character flagged in combat

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool AttackOnlyIfFlaggedInCombat
Public AttackOnlyIfFlaggedInCombat As Boolean
public:
bool^ AttackOnlyIfFlaggedInCombat

See Also

FightHostileTarget Class
wManager.Wow.Bot.States Namespace


ManageMovement Field

FightHostileTarget..::..ManageMovement Field

If activated the bot will move the character when he is in combat, if deactivated the movement will be 100% controlled by user.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool ManageMovement
Public ManageMovement As Boolean
public:
bool^ ManageMovement

See Also

FightHostileTarget Class
wManager.Wow.Bot.States Namespace


SkipIfPlayerAttackedButNotByTheTarget Field

FightHostileTarget..::..SkipIfPlayerAttackedButNotByTheTarget Field

Skip if player attacked but not by the target

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool SkipIfPlayerAttackedButNotByTheTarget
Public SkipIfPlayerAttackedButNotByTheTarget As Boolean
public:
bool^ SkipIfPlayerAttackedButNotByTheTarget

See Also

FightHostileTarget Class
wManager.Wow.Bot.States Namespace


FightHostileTarget Methods

The FightHostileTarget type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

See Also

FightHostileTarget Class
wManager.Wow.Bot.States Namespace


Run Method

FightHostileTarget..::..Run Method

Runs this instance.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Run()
Public Sub Run
public:
void Run()

See Also

FightHostileTarget Class
wManager.Wow.Bot.States Namespace


FightHostileTarget Properties

The FightHostileTarget type exposes the following members.

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

FightHostileTarget Class
wManager.Wow.Bot.States Namespace


DisplayName Property

FightHostileTarget..::..DisplayName Property

Gets the display name.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string DisplayName { get; }
Public ReadOnly Property DisplayName As String
    Get
public:
property String^ DisplayName {
    String^ get ();
}

Field Value

The display name.

See Also

FightHostileTarget Class
wManager.Wow.Bot.States Namespace


NeedToRun Property

FightHostileTarget..::..NeedToRun Property

Indicate if Engine need to call method Run()()()().

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool NeedToRun { get; }
Public ReadOnly Property NeedToRun As Boolean
    Get
public:
property bool^ NeedToRun {
    bool^ get ();
}

Field Value

true if need to run; otherwise, false .

See Also

FightHostileTarget Class
wManager.Wow.Bot.States Namespace


FlightMasterDiscoverState Class

Class FlightMasterDiscoverState. Used if FlightMasterDiscoverRange enabled. Implements the State

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class FlightMasterDiscoverState : State
Public Class FlightMasterDiscoverState _
    Inherits State
public ref class FlightMasterDiscoverState : public State

Inheritance Hierarchy

Object
robotManager.FiniteStateMachine..::..State
wManager.Wow.Bot.States..::..FlightMasterDiscoverState

See Also

FlightMasterDiscoverState Members
wManager.Wow.Bot.States Namespace
robotManager.FiniteStateMachine..::..State


FlightMasterDiscoverState Members

The FlightMasterDiscoverState type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

FlightMasterDiscoverState Class
wManager.Wow.Bot.States Namespace


FlightMasterDiscoverState Methods

The FlightMasterDiscoverState type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

See Also

FlightMasterDiscoverState Class
wManager.Wow.Bot.States Namespace


Run Method

FlightMasterDiscoverState..::..Run Method

Runs this instance.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Run()
Public Sub Run
public:
void Run()

See Also

FlightMasterDiscoverState Class
wManager.Wow.Bot.States Namespace


FlightMasterDiscoverState Properties

The FlightMasterDiscoverState type exposes the following members.

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

FlightMasterDiscoverState Class
wManager.Wow.Bot.States Namespace


DisplayName Property

FlightMasterDiscoverState..::..DisplayName Property

Gets the display name.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string DisplayName { get; }
Public ReadOnly Property DisplayName As String
    Get
public:
property String^ DisplayName {
    String^ get ();
}

Field Value

The display name.

See Also

FlightMasterDiscoverState Class
wManager.Wow.Bot.States Namespace


NeedToRun Property

FlightMasterDiscoverState..::..NeedToRun Property

Indicate if Engine need to call method Run()()()().

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool NeedToRun { get; }
Public ReadOnly Property NeedToRun As Boolean
    Get
public:
property bool^ NeedToRun {
    bool^ get ();
}

Field Value

true if need to run; otherwise, false .

See Also

FlightMasterDiscoverState Class
wManager.Wow.Bot.States Namespace


FlightMasterTakeTaxiState Class

Class FlightMasterTakeTaxiState. Use to take taxi at flightmaster if InMovement (to reach destination position of CurrentPathOrigine), behavior set with options FlightMasterTaxiUse, FlightMasterTaxiDistance, FlightMasterTaxiUseOnlyIfNear. Can be used without state with static methods NeedToRunStatic and RunStatic()()()(). Implements the State

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class FlightMasterTakeTaxiState : State
Public Class FlightMasterTakeTaxiState _
    Inherits State
public ref class FlightMasterTakeTaxiState : public State

Inheritance Hierarchy

Object
robotManager.FiniteStateMachine..::..State
wManager.Wow.Bot.States..::..FlightMasterTakeTaxiState

See Also

FlightMasterTakeTaxiState Members
wManager.Wow.Bot.States Namespace
robotManager.FiniteStateMachine..::..State


FlightMasterTakeTaxiState Members

The FlightMasterTakeTaxiState type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
 | GetNearestFlightMaster | Gets the nearest WoWUnit flightmaster (in game (ObjectManager) from character position).
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
 | RunStatic | Call this method if NeedToRunStatic is true (called by Run()()()())
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
 | NeedToRunStatic | Gets a value indicating if you can call RunStatic()()()() (called by NeedToRun)
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

FlightMasterTakeTaxiState Class
wManager.Wow.Bot.States Namespace


FlightMasterTakeTaxiState Methods

The FlightMasterTakeTaxiState type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
 | GetNearestFlightMaster | Gets the nearest WoWUnit flightmaster (in game (ObjectManager) from character position).
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
 | RunStatic | Call this method if NeedToRunStatic is true (called by Run()()()())
Public method | ToString | (Inherited from Object.)

See Also

FlightMasterTakeTaxiState Class
wManager.Wow.Bot.States Namespace


GetNearestFlightMaster Method

FlightMasterTakeTaxiState..::..GetNearestFlightMaster Method

Gets the nearest WoWUnit flightmaster (in game (ObjectManager) from character position).

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static WoWUnit GetNearestFlightMaster()
Public Shared Function GetNearestFlightMaster As WoWUnit
public:
static WoWUnit^ GetNearestFlightMaster()

Return Value

WoWUnit.

See Also

FlightMasterTakeTaxiState Class
wManager.Wow.Bot.States Namespace


Run Method

FlightMasterTakeTaxiState..::..Run Method

Runs this instance.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Run()
Public Sub Run
public:
void Run()

See Also

FlightMasterTakeTaxiState Class
wManager.Wow.Bot.States Namespace


RunStatic Method

FlightMasterTakeTaxiState..::..RunStatic Method

Call this method if NeedToRunStatic is true (called by Run()()()())

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void RunStatic()
Public Shared Sub RunStatic
public:
static void RunStatic()

See Also

FlightMasterTakeTaxiState Class
wManager.Wow.Bot.States Namespace


FlightMasterTakeTaxiState Properties

The FlightMasterTakeTaxiState type exposes the following members.

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
 | NeedToRunStatic | Gets a value indicating if you can call RunStatic()()()() (called by NeedToRun)
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

FlightMasterTakeTaxiState Class
wManager.Wow.Bot.States Namespace


DisplayName Property

FlightMasterTakeTaxiState..::..DisplayName Property

Gets the display name.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string DisplayName { get; }
Public ReadOnly Property DisplayName As String
    Get
public:
property String^ DisplayName {
    String^ get ();
}

Field Value

The display name.

See Also

FlightMasterTakeTaxiState Class
wManager.Wow.Bot.States Namespace


NeedToRun Property

FlightMasterTakeTaxiState..::..NeedToRun Property

Indicate if Engine need to call method Run()()()().

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool NeedToRun { get; }
Public ReadOnly Property NeedToRun As Boolean
    Get
public:
property bool^ NeedToRun {
    bool^ get ();
}

Field Value

true if need to run; otherwise, false .

See Also

FlightMasterTakeTaxiState Class
wManager.Wow.Bot.States Namespace


NeedToRunStatic Property

FlightMasterTakeTaxiState..::..NeedToRunStatic Property

Gets a value indicating if you can call RunStatic()()()() (called by NeedToRun)

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool NeedToRunStatic { get; }
Public Shared ReadOnly Property NeedToRunStatic As Boolean
    Get
public:
static property bool^ NeedToRunStatic {
    bool^ get ();
}

See Also

FlightMasterTakeTaxiState Class
wManager.Wow.Bot.States Namespace


Grinding Class

Class Grinding. To kills mobs. Implements the State

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class Grinding : State
Public Class Grinding _
    Inherits State
public ref class Grinding : public State

Inheritance Hierarchy

Object
robotManager.FiniteStateMachine..::..State
wManager.Wow.Bot.States..::..Grinding

See Also

Grinding Members
wManager.Wow.Bot.States Namespace
robotManager.FiniteStateMachine..::..State


Grinding Members

The Grinding type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | EntryTarget | Entry list to kills
Public field | FactionsTarget | Faction list to kills
Public field | MaxTargetLevel | Maximum mob level
Public field | MinTargetLevel | Minimum mob level
Public field | NamesTarget | Name list to kills
Public field | PetBattle | Start combat with PetBattle

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)
Public property | UnitTarget | Gets the current target.

See Also

Grinding Class
wManager.Wow.Bot.States Namespace


Grinding Fields

The Grinding type exposes the following members.

Fields

 | Name | Description
Public field | EntryTarget | Entry list to kills
Public field | FactionsTarget | Faction list to kills
Public field | MaxTargetLevel | Maximum mob level
Public field | MinTargetLevel | Minimum mob level
Public field | NamesTarget | Name list to kills
Public field | PetBattle | Start combat with PetBattle

See Also

Grinding Class
wManager.Wow.Bot.States Namespace


EntryTarget Field

Grinding..::..EntryTarget Field

Entry list to kills

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<int> EntryTarget
Public EntryTarget As List(Of Integer)
public:
List<int^>^ EntryTarget

See Also

Grinding Class
wManager.Wow.Bot.States Namespace


FactionsTarget Field

Grinding..::..FactionsTarget Field

Faction list to kills

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<uint> FactionsTarget
Public FactionsTarget As List(Of UInteger)
public:
List<unsigned int^>^ FactionsTarget

See Also

Grinding Class
wManager.Wow.Bot.States Namespace


MaxTargetLevel Field

Grinding..::..MaxTargetLevel Field

Maximum mob level

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint MaxTargetLevel
Public MaxTargetLevel As UInteger
public:
unsigned int^ MaxTargetLevel

See Also

Grinding Class
wManager.Wow.Bot.States Namespace


MinTargetLevel Field

Grinding..::..MinTargetLevel Field

Minimum mob level

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint MinTargetLevel
Public MinTargetLevel As UInteger
public:
unsigned int^ MinTargetLevel

See Also

Grinding Class
wManager.Wow.Bot.States Namespace


NamesTarget Field

Grinding..::..NamesTarget Field

Name list to kills

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<string> NamesTarget
Public NamesTarget As List(Of String)
public:
List<String^>^ NamesTarget

See Also

Grinding Class
wManager.Wow.Bot.States Namespace


PetBattle Field

Grinding..::..PetBattle Field

Start combat with PetBattle

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool PetBattle
Public PetBattle As Boolean
public:
bool^ PetBattle

See Also

Grinding Class
wManager.Wow.Bot.States Namespace


Grinding Methods

The Grinding type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

See Also

Grinding Class
wManager.Wow.Bot.States Namespace


Run Method

Grinding..::..Run Method

Runs this instance.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Run()
Public Sub Run
public:
void Run()

See Also

Grinding Class
wManager.Wow.Bot.States Namespace


Grinding Properties

The Grinding type exposes the following members.

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)
Public property | UnitTarget | Gets the current target.

See Also

Grinding Class
wManager.Wow.Bot.States Namespace


DisplayName Property

Grinding..::..DisplayName Property

Gets the display name.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string DisplayName { get; }
Public ReadOnly Property DisplayName As String
    Get
public:
property String^ DisplayName {
    String^ get ();
}

Field Value

The display name.

See Also

Grinding Class
wManager.Wow.Bot.States Namespace


NeedToRun Property

Grinding..::..NeedToRun Property

Indicate if Engine need to call method Run()()()().

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool NeedToRun { get; }
Public ReadOnly Property NeedToRun As Boolean
    Get
public:
property bool^ NeedToRun {
    bool^ get ();
}

Field Value

true if need to run; otherwise, false .

See Also

Grinding Class
wManager.Wow.Bot.States Namespace


UnitTarget Property

Grinding..::..UnitTarget Property

Gets the current target.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public WoWUnit UnitTarget { get; }
Public ReadOnly Property UnitTarget As WoWUnit
    Get
public:
property WoWUnit^ UnitTarget {
    WoWUnit^ get ();
}

See Also

Grinding Class
wManager.Wow.Bot.States Namespace


GrindingBG Class

Class GrindingBG. To attack opposing faction players. Implements the State

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class GrindingBG : State
Public Class GrindingBG _
    Inherits State
public ref class GrindingBG : public State

Inheritance Hierarchy

Object
robotManager.FiniteStateMachine..::..State
wManager.Wow.Bot.States..::..GrindingBG

See Also

GrindingBG Members
wManager.Wow.Bot.States Namespace
robotManager.FiniteStateMachine..::..State


GrindingBG Members

The GrindingBG type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | DistanceSearch | Target search distance
Public field | EntryTarget | Entry list to kills (optional)
Public field | FactionsTarget | Faction list to kills (optional)
Public field | RatioAllyEnemy | The ratio allies/enemies to start fight (1 if you want minimum 1 ally for 1 enemy, 0.5 if you want minimum 1 ally for two enemies, 2 if you want 2 allies for 1 enemy).

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

GrindingBG Class
wManager.Wow.Bot.States Namespace


GrindingBG Fields

The GrindingBG type exposes the following members.

Fields

 | Name | Description
Public field | DistanceSearch | Target search distance
Public field | EntryTarget | Entry list to kills (optional)
Public field | FactionsTarget | Faction list to kills (optional)
Public field | RatioAllyEnemy | The ratio allies/enemies to start fight (1 if you want minimum 1 ally for 1 enemy, 0.5 if you want minimum 1 ally for two enemies, 2 if you want 2 allies for 1 enemy).

See Also

GrindingBG Class
wManager.Wow.Bot.States Namespace


DistanceSearch Field

GrindingBG..::..DistanceSearch Field

Target search distance

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float DistanceSearch
Public DistanceSearch As Single
public:
float^ DistanceSearch

See Also

GrindingBG Class
wManager.Wow.Bot.States Namespace


EntryTarget Field

GrindingBG..::..EntryTarget Field

Entry list to kills (optional)

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<int> EntryTarget
Public EntryTarget As List(Of Integer)
public:
List<int^>^ EntryTarget

See Also

GrindingBG Class
wManager.Wow.Bot.States Namespace


FactionsTarget Field

GrindingBG..::..FactionsTarget Field

Faction list to kills (optional)

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<uint> FactionsTarget
Public FactionsTarget As List(Of UInteger)
public:
List<unsigned int^>^ FactionsTarget

See Also

GrindingBG Class
wManager.Wow.Bot.States Namespace


RatioAllyEnemy Field

GrindingBG..::..RatioAllyEnemy Field

The ratio allies/enemies to start fight (1 if you want minimum 1 ally for 1 enemy, 0.5 if you want minimum 1 ally for two enemies, 2 if you want 2 allies for 1 enemy).

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public double RatioAllyEnemy
Public RatioAllyEnemy As Double
public:
double^ RatioAllyEnemy

See Also

GrindingBG Class
wManager.Wow.Bot.States Namespace


GrindingBG Methods

The GrindingBG type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

See Also

GrindingBG Class
wManager.Wow.Bot.States Namespace


Run Method

GrindingBG..::..Run Method

Runs this instance.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Run()
Public Sub Run
public:
void Run()

See Also

GrindingBG Class
wManager.Wow.Bot.States Namespace


GrindingBG Properties

The GrindingBG type exposes the following members.

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

GrindingBG Class
wManager.Wow.Bot.States Namespace


DisplayName Property

GrindingBG..::..DisplayName Property

Gets the display name.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string DisplayName { get; }
Public ReadOnly Property DisplayName As String
    Get
public:
property String^ DisplayName {
    String^ get ();
}

Field Value

The display name.

See Also

GrindingBG Class
wManager.Wow.Bot.States Namespace


NeedToRun Property

GrindingBG..::..NeedToRun Property

Indicate if Engine need to call method Run()()()().

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool NeedToRun { get; }
Public ReadOnly Property NeedToRun As Boolean
    Get
public:
property bool^ NeedToRun {
    bool^ get ();
}

Field Value

true if need to run; otherwise, false .

See Also

GrindingBG Class
wManager.Wow.Bot.States Namespace


GrindingNearestMobs Class

Class GrindingNearestMobs. To kills enemies mobs near. Implements the State

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class GrindingNearestMobs : State
Public Class GrindingNearestMobs _
    Inherits State
public ref class GrindingNearestMobs : public State

Inheritance Hierarchy

Object
robotManager.FiniteStateMachine..::..State
wManager.Wow.Bot.States..::..GrindingNearestMobs

See Also

GrindingNearestMobs Members
wManager.Wow.Bot.States Namespace
robotManager.FiniteStateMachine..::..State


GrindingNearestMobs Members

The GrindingNearestMobs type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | AttackMobsForExperience | To attack only mobs that give experience.
Public field | CenterGinderZone | Center position of grind zone.
Public field | IgnoreNeutral | Ignore neutral (reaction) mobs
Public field | RadiusGrinderZone | Monster search distance from CenterGinderZone.

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

GrindingNearestMobs Class
wManager.Wow.Bot.States Namespace


GrindingNearestMobs Fields

The GrindingNearestMobs type exposes the following members.

Fields

 | Name | Description
Public field | AttackMobsForExperience | To attack only mobs that give experience.
Public field | CenterGinderZone | Center position of grind zone.
Public field | IgnoreNeutral | Ignore neutral (reaction) mobs
Public field | RadiusGrinderZone | Monster search distance from CenterGinderZone.

See Also

GrindingNearestMobs Class
wManager.Wow.Bot.States Namespace


AttackMobsForExperience Field

GrindingNearestMobs..::..AttackMobsForExperience Field

To attack only mobs that give experience.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool AttackMobsForExperience
Public AttackMobsForExperience As Boolean
public:
bool^ AttackMobsForExperience

See Also

GrindingNearestMobs Class
wManager.Wow.Bot.States Namespace


CenterGinderZone Field

GrindingNearestMobs..::..CenterGinderZone Field

Center position of grind zone.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Vector3 CenterGinderZone
Public CenterGinderZone As Vector3
public:
Vector3^ CenterGinderZone

See Also

GrindingNearestMobs Class
wManager.Wow.Bot.States Namespace


IgnoreNeutral Field

GrindingNearestMobs..::..IgnoreNeutral Field

Ignore neutral (reaction) mobs

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IgnoreNeutral
Public IgnoreNeutral As Boolean
public:
bool^ IgnoreNeutral

See Also

GrindingNearestMobs Class
wManager.Wow.Bot.States Namespace


RadiusGrinderZone Field

GrindingNearestMobs..::..RadiusGrinderZone Field

Monster search distance from CenterGinderZone.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float RadiusGrinderZone
Public RadiusGrinderZone As Single
public:
float^ RadiusGrinderZone

See Also

GrindingNearestMobs Class
wManager.Wow.Bot.States Namespace


GrindingNearestMobs Methods

The GrindingNearestMobs type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

See Also

GrindingNearestMobs Class
wManager.Wow.Bot.States Namespace


Run Method

GrindingNearestMobs..::..Run Method

Runs this instance.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Run()
Public Sub Run
public:
void Run()

See Also

GrindingNearestMobs Class
wManager.Wow.Bot.States Namespace


GrindingNearestMobs Properties

The GrindingNearestMobs type exposes the following members.

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

GrindingNearestMobs Class
wManager.Wow.Bot.States Namespace


DisplayName Property

GrindingNearestMobs..::..DisplayName Property

Gets the display name.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string DisplayName { get; }
Public ReadOnly Property DisplayName As String
    Get
public:
property String^ DisplayName {
    String^ get ();
}

See Also

GrindingNearestMobs Class
wManager.Wow.Bot.States Namespace


NeedToRun Property

GrindingNearestMobs..::..NeedToRun Property

Indicate if Engine need to call method Run()()()().

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool NeedToRun { get; }
Public ReadOnly Property NeedToRun As Boolean
    Get
public:
property bool^ NeedToRun {
    bool^ get ();
}

Field Value

true if need to run; otherwise, false .

See Also

GrindingNearestMobs Class
wManager.Wow.Bot.States Namespace


Idle Class

Class Idle. This state is in last position (lower Priority) of Engine states. It is called only if no states are executed, it allows to lower the CPU usage (with a Sleep(System.Int32)) Implements the State

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class Idle : State
Public Class Idle _
    Inherits State
public ref class Idle : public State

Inheritance Hierarchy

Object
robotManager.FiniteStateMachine..::..State
wManager.Wow.Bot.States..::..Idle

See Also

Idle Members
wManager.Wow.Bot.States Namespace
robotManager.FiniteStateMachine..::..State


Idle Members

The Idle type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | TimeSleepMs | Sleep time, in milliseconds

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

Idle Class
wManager.Wow.Bot.States Namespace


Idle Fields

The Idle type exposes the following members.

Fields

 | Name | Description
Public field | TimeSleepMs | Sleep time, in milliseconds

See Also

Idle Class
wManager.Wow.Bot.States Namespace


TimeSleepMs Field

Idle..::..TimeSleepMs Field

Sleep time, in milliseconds

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int TimeSleepMs
Public TimeSleepMs As Integer
public:
int^ TimeSleepMs

See Also

Idle Class
wManager.Wow.Bot.States Namespace


Idle Methods

The Idle type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

See Also

Idle Class
wManager.Wow.Bot.States Namespace


Run Method

Idle..::..Run Method

Runs this instance.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Run()
Public Sub Run
public:
void Run()

See Also

Idle Class
wManager.Wow.Bot.States Namespace


Idle Properties

The Idle type exposes the following members.

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

Idle Class
wManager.Wow.Bot.States Namespace


DisplayName Property

Idle..::..DisplayName Property

Gets the display name.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string DisplayName { get; }
Public ReadOnly Property DisplayName As String
    Get
public:
property String^ DisplayName {
    String^ get ();
}

Field Value

The display name.

See Also

Idle Class
wManager.Wow.Bot.States Namespace


NeedToRun Property

Idle..::..NeedToRun Property

Indicate if Engine need to call method Run()()()().

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool NeedToRun { get; }
Public ReadOnly Property NeedToRun As Boolean
    Get
public:
property bool^ NeedToRun {
    bool^ get ();
}

Field Value

true if need to run; otherwise, false .

See Also

Idle Class
wManager.Wow.Bot.States Namespace


IsAttacked Class

Class IsAttacked. Call [Fight.StartFight(MemoryRobot.Int128, bool, bool, bool, bool)] if player is in combat and cannot ignore that (IsAttackedAndCannotIgnore) Implements the State

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class IsAttacked : State
Public Class IsAttacked _
    Inherits State
public ref class IsAttacked : public State

Inheritance Hierarchy

Object
robotManager.FiniteStateMachine..::..State
wManager.Wow.Bot.States..::..IsAttacked

See Also

IsAttacked Members
wManager.Wow.Bot.States Namespace
robotManager.FiniteStateMachine..::..State


IsAttacked Members

The IsAttacked type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

IsAttacked Class
wManager.Wow.Bot.States Namespace


IsAttacked Methods

The IsAttacked type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

See Also

IsAttacked Class
wManager.Wow.Bot.States Namespace


Run Method

IsAttacked..::..Run Method

Runs this instance.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Run()
Public Sub Run
public:
void Run()

See Also

IsAttacked Class
wManager.Wow.Bot.States Namespace


IsAttacked Properties

The IsAttacked type exposes the following members.

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

IsAttacked Class
wManager.Wow.Bot.States Namespace


DisplayName Property

IsAttacked..::..DisplayName Property

Gets the display name.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string DisplayName { get; }
Public ReadOnly Property DisplayName As String
    Get
public:
property String^ DisplayName {
    String^ get ();
}

Field Value

The display name.

See Also

IsAttacked Class
wManager.Wow.Bot.States Namespace


NeedToRun Property

IsAttacked..::..NeedToRun Property

Indicate if Engine need to call method Run()()()().

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool NeedToRun { get; }
Public ReadOnly Property NeedToRun As Boolean
    Get
public:
property bool^ NeedToRun {
    bool^ get ();
}

Field Value

true if need to run; otherwise, false .

See Also

IsAttacked Class
wManager.Wow.Bot.States Namespace


Looting Class

Class Looting. If lootable corpses call Pulse(List<(Of <<'(WoWUnit>)>>)). Implements the State

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class Looting : State
Public Class Looting _
    Inherits State
public ref class Looting : public State

Inheritance Hierarchy

Object
robotManager.FiniteStateMachine..::..State
wManager.Wow.Bot.States..::..Looting

See Also

Looting Members
wManager.Wow.Bot.States Namespace
robotManager.FiniteStateMachine..::..State


Looting Members

The Looting type exposes the following members.

Constructors

 | Name | Description
Public method | Looting |

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | InRangeOnly | Loot only in range (if don't need to move).

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

Looting Class
wManager.Wow.Bot.States Namespace


Looting Constructor

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Looting()
Public Sub New
public:
Looting()

See Also

Looting Class
wManager.Wow.Bot.States Namespace


Looting Fields

The Looting type exposes the following members.

Fields

 | Name | Description
Public field | InRangeOnly | Loot only in range (if don't need to move).

See Also

Looting Class
wManager.Wow.Bot.States Namespace


InRangeOnly Field

Looting..::..InRangeOnly Field

Loot only in range (if don't need to move).

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool InRangeOnly
Public InRangeOnly As Boolean
public:
bool^ InRangeOnly

See Also

Looting Class
wManager.Wow.Bot.States Namespace


Looting Methods

The Looting type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

See Also

Looting Class
wManager.Wow.Bot.States Namespace


Run Method

Looting..::..Run Method

Runs this instance.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Run()
Public Sub Run
public:
void Run()

See Also

Looting Class
wManager.Wow.Bot.States Namespace


Looting Properties

The Looting type exposes the following members.

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

Looting Class
wManager.Wow.Bot.States Namespace


DisplayName Property

Looting..::..DisplayName Property

Gets the display name.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string DisplayName { get; }
Public ReadOnly Property DisplayName As String
    Get
public:
property String^ DisplayName {
    String^ get ();
}

Field Value

The display name.

See Also

Looting Class
wManager.Wow.Bot.States Namespace


NeedToRun Property

Looting..::..NeedToRun Property

Indicate if Engine need to call method Run()()()().

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool NeedToRun { get; }
Public ReadOnly Property NeedToRun As Boolean
    Get
public:
property bool^ NeedToRun {
    bool^ get ();
}

Field Value

true if need to run; otherwise, false .

See Also

Looting Class
wManager.Wow.Bot.States Namespace


LootingRange Class

Class LootingRange. LootAndHarvestRangeQuickly. Implements the Looting

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class LootingRange : Looting
Public Class LootingRange _
    Inherits Looting
public ref class LootingRange : public Looting

Inheritance Hierarchy

Object
robotManager.FiniteStateMachine..::..State
wManager.Wow.Bot.States..::..Looting
wManager.Wow.Bot.States..::..LootingRange

See Also

LootingRange Members
wManager.Wow.Bot.States Namespace
wManager.Wow.Bot.States..::..Looting


LootingRange Members

The LootingRange type exposes the following members.

Constructors

 | Name | Description
Public method | LootingRange | Initializes a new instance of the LootingRange class.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance. (Inherited from Looting.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()(). (Inherited from Looting.)
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

LootingRange Class
wManager.Wow.Bot.States Namespace


LootingRange Constructor

Initializes a new instance of the LootingRange class.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public LootingRange()
Public Sub New
public:
LootingRange()

See Also

LootingRange Class
wManager.Wow.Bot.States Namespace


LootingRange Methods

The LootingRange type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance. (Inherited from Looting.)
Public method | ToString | (Inherited from Object.)

See Also

LootingRange Class
wManager.Wow.Bot.States Namespace


LootingRange Properties

The LootingRange type exposes the following members.

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()(). (Inherited from Looting.)
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

LootingRange Class
wManager.Wow.Bot.States Namespace


DisplayName Property

LootingRange..::..DisplayName Property

Gets the display name.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string DisplayName { get; }
Public ReadOnly Property DisplayName As String
    Get
public:
property String^ DisplayName {
    String^ get ();
}

Field Value

The display name.

See Also

LootingRange Class
wManager.Wow.Bot.States Namespace


MillingState Class

Class MillingState. State of option Milling. Implements the State

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class MillingState : State
Public Class MillingState _
    Inherits State
public ref class MillingState : public State

Inheritance Hierarchy

Object
robotManager.FiniteStateMachine..::..State
wManager.Wow.Bot.States..::..MillingState

See Also

MillingState Members
wManager.Wow.Bot.States Namespace
robotManager.FiniteStateMachine..::..State


MillingState Members

The MillingState type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

MillingState Class
wManager.Wow.Bot.States Namespace


MillingState Methods

The MillingState type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

See Also

MillingState Class
wManager.Wow.Bot.States Namespace


Run Method

MillingState..::..Run Method

Runs this instance.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Run()
Public Sub Run
public:
void Run()

See Also

MillingState Class
wManager.Wow.Bot.States Namespace


MillingState Properties

The MillingState type exposes the following members.

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

MillingState Class
wManager.Wow.Bot.States Namespace


DisplayName Property

MillingState..::..DisplayName Property

Gets the display name.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string DisplayName { get; }
Public ReadOnly Property DisplayName As String
    Get
public:
property String^ DisplayName {
    String^ get ();
}

Field Value

The display name.

See Also

MillingState Class
wManager.Wow.Bot.States Namespace


NeedToRun Property

MillingState..::..NeedToRun Property

Indicate if Engine need to call method Run()()()().

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool NeedToRun { get; }
Public ReadOnly Property NeedToRun As Boolean
    Get
public:
property bool^ NeedToRun {
    bool^ get ();
}

Field Value

true if need to run; otherwise, false .

See Also

MillingState Class
wManager.Wow.Bot.States Namespace


MountingState Class

Class MountingState. To use mount (this state is not used by the bot). Implements the State

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class MountingState : State
Public Class MountingState _
    Inherits State
public ref class MountingState : public State

Inheritance Hierarchy

Object
robotManager.FiniteStateMachine..::..State
wManager.Wow.Bot.States..::..MountingState

See Also

MountingState Members
wManager.Wow.Bot.States Namespace
robotManager.FiniteStateMachine..::..State


MountingState Members

The MountingState type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

MountingState Class
wManager.Wow.Bot.States Namespace


MountingState Methods

The MountingState type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

See Also

MountingState Class
wManager.Wow.Bot.States Namespace


Run Method

MountingState..::..Run Method

Runs this instance.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Run()
Public Sub Run
public:
void Run()

See Also

MountingState Class
wManager.Wow.Bot.States Namespace


MountingState Properties

The MountingState type exposes the following members.

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

MountingState Class
wManager.Wow.Bot.States Namespace


DisplayName Property

MountingState..::..DisplayName Property

Gets the display name.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string DisplayName { get; }
Public ReadOnly Property DisplayName As String
    Get
public:
property String^ DisplayName {
    String^ get ();
}

Field Value

The display name.

See Also

MountingState Class
wManager.Wow.Bot.States Namespace


NeedToRun Property

MountingState..::..NeedToRun Property

Indicate if Engine need to call method Run()()()().

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool NeedToRun { get; }
Public ReadOnly Property NeedToRun As Boolean
    Get
public:
property bool^ NeedToRun {
    bool^ get ();
}

Field Value

true if need to run; otherwise, false .

See Also

MountingState Class
wManager.Wow.Bot.States Namespace


MovementLoop Class

Class MovementLoop. Manage profile path in products like Grinder or Gatherer. If bot is not InMovement or CurrentPathOrigine is different that PathLoop bot run this state. Must be one of the last states of Engine. Implements the State

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class MovementLoop : State
Public Class MovementLoop _
    Inherits State
public ref class MovementLoop : public State

Inheritance Hierarchy

Object
robotManager.FiniteStateMachine..::..State
wManager.Wow.Bot.States..::..MovementLoop

See Also

MovementLoop Members
wManager.Wow.Bot.States Namespace
robotManager.FiniteStateMachine..::..State


MovementLoop Members

The MovementLoop type exposes the following members.

Constructors

 | Name | Description
Public method | MovementLoop(List<(Of <<'(Vector3>)>>)) | Initializes a new instance of the MovementLoop class.
Public method | MovementLoop()()()() | Initializes a new instance of the MovementLoop class.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | IsLoop | Loop the PathLoop
Public field | RandomiseDistanceMax | Distance maximum of randomized position RandomisePath
Public field | RandomisePath | Randomize path (can cause blockages when the randomized position is underground or in an obstacle, use with caution).
Public field | ReturnToLastPositionWhenLoop | Return to last position after stop move (if disabled the bot goes to the position closest to the PathLoop)

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | PathLoop | Gets or sets the path loop.
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

MovementLoop Class
wManager.Wow.Bot.States Namespace


MovementLoop Constructor

Overload List

 | Name | Description
Public method | MovementLoop(List<(Of <<'(Vector3>)>>)) | Initializes a new instance of the MovementLoop class.
Public method | MovementLoop()()()() | Initializes a new instance of the MovementLoop class.

See Also

MovementLoop Class
MovementLoop Members
wManager.Wow.Bot.States Namespace


MovementLoop Constructor (List(Vector3))

MovementLoop Constructor (List<(Of <(<'Vector3>)>)>)

Initializes a new instance of the MovementLoop class.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public MovementLoop(
    List<Vector3> pathLoop
)
Public Sub New ( _
    pathLoop As List(Of Vector3) _
)
public:
MovementLoop(
    List<Vector3^>^ pathLoop
)

Parameters

pathLoop
Type: List <(Of <(<' Vector3 >)>)>
The path loop.

See Also

MovementLoop Class
MovementLoop Overload
wManager.Wow.Bot.States Namespace


MovementLoop Constructor

Initializes a new instance of the MovementLoop class.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public MovementLoop()
Public Sub New
public:
MovementLoop()

See Also

MovementLoop Class
MovementLoop Overload
wManager.Wow.Bot.States Namespace


MovementLoop Fields

The MovementLoop type exposes the following members.

Fields

 | Name | Description
Public field | IsLoop | Loop the PathLoop
Public field | RandomiseDistanceMax | Distance maximum of randomized position RandomisePath
Public field | RandomisePath | Randomize path (can cause blockages when the randomized position is underground or in an obstacle, use with caution).
Public field | ReturnToLastPositionWhenLoop | Return to last position after stop move (if disabled the bot goes to the position closest to the PathLoop)

See Also

MovementLoop Class
wManager.Wow.Bot.States Namespace


IsLoop Field

MovementLoop..::..IsLoop Field

Loop the PathLoop

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsLoop
Public IsLoop As Boolean
public:
bool^ IsLoop

See Also

MovementLoop Class
wManager.Wow.Bot.States Namespace


RandomiseDistanceMax Field

MovementLoop..::..RandomiseDistanceMax Field

Distance maximum of randomized position RandomisePath

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public double RandomiseDistanceMax
Public RandomiseDistanceMax As Double
public:
double^ RandomiseDistanceMax

See Also

MovementLoop Class
wManager.Wow.Bot.States Namespace


RandomisePath Field

MovementLoop..::..RandomisePath Field

Randomize path (can cause blockages when the randomized position is underground or in an obstacle, use with caution).

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool RandomisePath
Public RandomisePath As Boolean
public:
bool^ RandomisePath

See Also

MovementLoop Class
wManager.Wow.Bot.States Namespace


ReturnToLastPositionWhenLoop Field

MovementLoop..::..ReturnToLastPositionWhenLoop Field

Return to last position after stop move (if disabled the bot goes to the position closest to the PathLoop)

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool ReturnToLastPositionWhenLoop
Public ReturnToLastPositionWhenLoop As Boolean
public:
bool^ ReturnToLastPositionWhenLoop

See Also

MovementLoop Class
wManager.Wow.Bot.States Namespace


MovementLoop Methods

The MovementLoop type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

See Also

MovementLoop Class
wManager.Wow.Bot.States Namespace


Run Method

MovementLoop..::..Run Method

Runs this instance.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Run()
Public Sub Run
public:
void Run()

See Also

MovementLoop Class
wManager.Wow.Bot.States Namespace


MovementLoop Properties

The MovementLoop type exposes the following members.

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | PathLoop | Gets or sets the path loop.
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

MovementLoop Class
wManager.Wow.Bot.States Namespace


DisplayName Property

MovementLoop..::..DisplayName Property

Gets the display name.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string DisplayName { get; }
Public ReadOnly Property DisplayName As String
    Get
public:
property String^ DisplayName {
    String^ get ();
}

Field Value

The display name.

See Also

MovementLoop Class
wManager.Wow.Bot.States Namespace


NeedToRun Property

MovementLoop..::..NeedToRun Property

Indicate if Engine need to call method Run()()()().

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool NeedToRun { get; }
Public ReadOnly Property NeedToRun As Boolean
    Get
public:
property bool^ NeedToRun {
    bool^ get ();
}

Field Value

true if need to run; otherwise, false .

See Also

MovementLoop Class
wManager.Wow.Bot.States Namespace


PathLoop Property

MovementLoop..::..PathLoop Property

Gets or sets the path loop.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<Vector3> PathLoop { get; set; }
Public Property PathLoop As List(Of Vector3)
    Get
    Set
public:
property List<Vector3^>^ PathLoop {
    List<Vector3^>^ get ();
    void set (List<Vector3^>^ value);
}

Field Value

The path loop.

See Also

MovementLoop Class
wManager.Wow.Bot.States Namespace


MovementRandomInCircle Class

Class MovementRandomInCircle. Used in Automaton product to move to random position when no task to do near. If not InMovement bot run this state. Must be one of the last states of Engine. Implements the State

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class MovementRandomInCircle : State
Public Class MovementRandomInCircle _
    Inherits State
public ref class MovementRandomInCircle : public State

Inheritance Hierarchy

Object
robotManager.FiniteStateMachine..::..State
wManager.Wow.Bot.States..::..MovementRandomInCircle

See Also

MovementRandomInCircle Members
wManager.Wow.Bot.States Namespace
robotManager.FiniteStateMachine..::..State


MovementRandomInCircle Members

The MovementRandomInCircle type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | CenterCircle | Center circle (center of zone to explore)
Public field | HeightFlight | Flight height (when option UseFlyingMount is enabled)
Public field | RadiusCircle | Maximum distance from CenterCircle of destination
Public field | UseFlyingMount | Can use flying mount

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

MovementRandomInCircle Class
wManager.Wow.Bot.States Namespace


MovementRandomInCircle Fields

The MovementRandomInCircle type exposes the following members.

Fields

 | Name | Description
Public field | CenterCircle | Center circle (center of zone to explore)
Public field | HeightFlight | Flight height (when option UseFlyingMount is enabled)
Public field | RadiusCircle | Maximum distance from CenterCircle of destination
Public field | UseFlyingMount | Can use flying mount

See Also

MovementRandomInCircle Class
wManager.Wow.Bot.States Namespace


CenterCircle Field

MovementRandomInCircle..::..CenterCircle Field

Center circle (center of zone to explore)

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Vector3 CenterCircle
Public CenterCircle As Vector3
public:
Vector3^ CenterCircle

See Also

MovementRandomInCircle Class
wManager.Wow.Bot.States Namespace


HeightFlight Field

MovementRandomInCircle..::..HeightFlight Field

Flight height (when option UseFlyingMount is enabled)

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float HeightFlight
Public HeightFlight As Single
public:
float^ HeightFlight

See Also

MovementRandomInCircle Class
wManager.Wow.Bot.States Namespace


RadiusCircle Field

MovementRandomInCircle..::..RadiusCircle Field

Maximum distance from CenterCircle of destination

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float RadiusCircle
Public RadiusCircle As Single
public:
float^ RadiusCircle

See Also

MovementRandomInCircle Class
wManager.Wow.Bot.States Namespace


UseFlyingMount Field

MovementRandomInCircle..::..UseFlyingMount Field

Can use flying mount

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool UseFlyingMount
Public UseFlyingMount As Boolean
public:
bool^ UseFlyingMount

See Also

MovementRandomInCircle Class
wManager.Wow.Bot.States Namespace


MovementRandomInCircle Methods

The MovementRandomInCircle type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

See Also

MovementRandomInCircle Class
wManager.Wow.Bot.States Namespace


Run Method

MovementRandomInCircle..::..Run Method

Runs this instance.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Run()
Public Sub Run
public:
void Run()

See Also

MovementRandomInCircle Class
wManager.Wow.Bot.States Namespace


MovementRandomInCircle Properties

The MovementRandomInCircle type exposes the following members.

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

MovementRandomInCircle Class
wManager.Wow.Bot.States Namespace


DisplayName Property

MovementRandomInCircle..::..DisplayName Property

Gets the display name.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string DisplayName { get; }
Public ReadOnly Property DisplayName As String
    Get
public:
property String^ DisplayName {
    String^ get ();
}

Field Value

The display name.

See Also

MovementRandomInCircle Class
wManager.Wow.Bot.States Namespace


NeedToRun Property

MovementRandomInCircle..::..NeedToRun Property

Indicate if Engine need to call method Run()()()().

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool NeedToRun { get; }
Public ReadOnly Property NeedToRun As Boolean
    Get
public:
property bool^ NeedToRun {
    bool^ get ();
}

Field Value

true if need to run; otherwise, false .

See Also

MovementRandomInCircle Class
wManager.Wow.Bot.States Namespace


MyMacro Class

Class MyMacro. To run wManagerSetting..::..MyMacro Implements the State

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class MyMacro : State
Public Class MyMacro _
    Inherits State
public ref class MyMacro : public State

Inheritance Hierarchy

Object
robotManager.FiniteStateMachine..::..State
wManager.Wow.Bot.States..::..MyMacro

See Also

MyMacro Members
wManager.Wow.Bot.States Namespace
robotManager.FiniteStateMachine..::..State


MyMacro Members

The MyMacro type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

MyMacro Class
wManager.Wow.Bot.States Namespace


MyMacro Methods

The MyMacro type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

See Also

MyMacro Class
wManager.Wow.Bot.States Namespace


Run Method

MyMacro..::..Run Method

Runs this instance.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Run()
Public Sub Run
public:
void Run()

See Also

MyMacro Class
wManager.Wow.Bot.States Namespace


MyMacro Properties

The MyMacro type exposes the following members.

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

MyMacro Class
wManager.Wow.Bot.States Namespace


DisplayName Property

MyMacro..::..DisplayName Property

Gets the display name.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string DisplayName { get; }
Public ReadOnly Property DisplayName As String
    Get
public:
property String^ DisplayName {
    String^ get ();
}

Field Value

The display name.

See Also

MyMacro Class
wManager.Wow.Bot.States Namespace


NeedToRun Property

MyMacro..::..NeedToRun Property

Indicate if Engine need to call method Run()()()().

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool NeedToRun { get; }
Public ReadOnly Property NeedToRun As Boolean
    Get
public:
property bool^ NeedToRun {
    bool^ get ();
}

Field Value

true if need to run; otherwise, false .

See Also

MyMacro Class
wManager.Wow.Bot.States Namespace


NPCScanState Class

Class NPCScanState. For options NpcScanAuctioneer, NpcScanMailboxes, NpcScanRepair, NpcScanVendor, but also for ExtractGameObjects()()()(). Implements the State

Usually bot don't use this class as State, but call LaunchNewThread()()()() when product start and StopThread()()()() when product is stopped

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class NPCScanState : State
Public Class NPCScanState _
    Inherits State
public ref class NPCScanState : public State

Inheritance Hierarchy

Object
robotManager.FiniteStateMachine..::..State
wManager.Wow.Bot.States..::..NPCScanState

See Also

NPCScanState Members
wManager.Wow.Bot.States Namespace
robotManager.FiniteStateMachine..::..State


NPCScanState Members

The NPCScanState type exposes the following members.

Constructors

 | Name | Description
Public method | NPCScanState | Initializes a new instance of the NPCScanState class.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
 | LaunchNewThread | Launches the new thread.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
 | StopThread | Stops the thread.
 | ThreadIsLaunched | Threads the is launched.
Public method | ToString | (Inherited from Object.)

Fields

Name | Description
Locker | The thread locker

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
 | ExtractGameObjects | Share collidable GameObjects information (position, 3D model, name) with bot server (this help to create better meshes for PathFinder), this option can be enabled at start by bot server.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

NPCScanState Class
wManager.Wow.Bot.States Namespace


NPCScanState Constructor

Initializes a new instance of the NPCScanState class.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public NPCScanState()
Public Sub New
public:
NPCScanState()

See Also

NPCScanState Class
wManager.Wow.Bot.States Namespace


NPCScanState Fields

The NPCScanState type exposes the following members.

Fields

Name | Description
Locker | The thread locker

See Also

NPCScanState Class
wManager.Wow.Bot.States Namespace


Locker Field

NPCScanState..::..Locker Field

The thread locker

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static Object Locker
Public Shared Locker As Object
public:
static Object^ Locker

See Also

NPCScanState Class
wManager.Wow.Bot.States Namespace


NPCScanState Methods

The NPCScanState type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
 | LaunchNewThread | Launches the new thread.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
 | StopThread | Stops the thread.
 | ThreadIsLaunched | Threads the is launched.
Public method | ToString | (Inherited from Object.)

See Also

NPCScanState Class
wManager.Wow.Bot.States Namespace


LaunchNewThread Method

NPCScanState..::..LaunchNewThread Method

Launches the new thread.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void LaunchNewThread()
Public Shared Sub LaunchNewThread
public:
static void LaunchNewThread()

See Also

NPCScanState Class
wManager.Wow.Bot.States Namespace


Run Method

NPCScanState..::..Run Method

Runs this instance.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Run()
Public Sub Run
public:
void Run()

See Also

NPCScanState Class
wManager.Wow.Bot.States Namespace


StopThread Method

NPCScanState..::..StopThread Method

Stops the thread.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void StopThread()
Public Shared Sub StopThread
public:
static void StopThread()

See Also

NPCScanState Class
wManager.Wow.Bot.States Namespace


ThreadIsLaunched Method

NPCScanState..::..ThreadIsLaunched Method

Threads the is launched.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool ThreadIsLaunched()
Public Shared Function ThreadIsLaunched As Boolean
public:
static bool^ ThreadIsLaunched()

Return Value

true if thread launched, false otherwise.

See Also

NPCScanState Class
wManager.Wow.Bot.States Namespace


NPCScanState Properties

The NPCScanState type exposes the following members.

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
 | ExtractGameObjects | Share collidable GameObjects information (position, 3D model, name) with bot server (this help to create better meshes for PathFinder), this option can be enabled at start by bot server.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

NPCScanState Class
wManager.Wow.Bot.States Namespace


DisplayName Property

NPCScanState..::..DisplayName Property

Gets the display name.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string DisplayName { get; }
Public ReadOnly Property DisplayName As String
    Get
public:
property String^ DisplayName {
    String^ get ();
}

Field Value

The display name.

See Also

NPCScanState Class
wManager.Wow.Bot.States Namespace


ExtractGameObjects Property

NPCScanState..::..ExtractGameObjects Property

Share collidable GameObjects information (position, 3D model, name) with bot server (this help to create better meshes for PathFinder), this option can be enabled at start by bot server.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool ExtractGameObjects { get; set; }
Public Shared Property ExtractGameObjects As Boolean
    Get
    Set
public:
static property bool^ ExtractGameObjects {
    bool^ get ();
    void set (bool^ value);
}

See Also

NPCScanState Class
wManager.Wow.Bot.States Namespace


NeedToRun Property

NPCScanState..::..NeedToRun Property

Indicate if Engine need to call method Run()()()().

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool NeedToRun { get; }
Public ReadOnly Property NeedToRun As Boolean
    Get
public:
property bool^ NeedToRun {
    bool^ get ();
}

Field Value

true if need to run; otherwise, false .

See Also

NPCScanState Class
wManager.Wow.Bot.States Namespace


Pause Class

Class Pause. NeedToRun return true when InPause. All states with lower priority will not be executed while the bot is paused. Implements the State

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class Pause : State
Public Class Pause _
    Inherits State
public ref class Pause : public State

Inheritance Hierarchy

Object
robotManager.FiniteStateMachine..::..State
wManager.Wow.Bot.States..::..Pause

See Also

Pause Members
wManager.Wow.Bot.States Namespace
robotManager.FiniteStateMachine..::..State


Pause Members

The Pause type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

Pause Class
wManager.Wow.Bot.States Namespace


Pause Methods

The Pause type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

See Also

Pause Class
wManager.Wow.Bot.States Namespace


Run Method

Pause..::..Run Method

Runs this instance.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Run()
Public Sub Run
public:
void Run()

See Also

Pause Class
wManager.Wow.Bot.States Namespace


Pause Properties

The Pause type exposes the following members.

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

Pause Class
wManager.Wow.Bot.States Namespace


DisplayName Property

Pause..::..DisplayName Property

Gets the display name.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string DisplayName { get; }
Public ReadOnly Property DisplayName As String
    Get
public:
property String^ DisplayName {
    String^ get ();
}

Field Value

The display name.

See Also

Pause Class
wManager.Wow.Bot.States Namespace


NeedToRun Property

Pause..::..NeedToRun Property

Indicate if Engine need to call method Run()()()().

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool NeedToRun { get; }
Public ReadOnly Property NeedToRun As Boolean
    Get
public:
property bool^ NeedToRun {
    bool^ get ();
}

Field Value

true if need to run; otherwise, false .

See Also

Pause Class
wManager.Wow.Bot.States Namespace


ProspectingState Class

Class ProspectingState. Prospecting Implements the State

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class ProspectingState : State
Public Class ProspectingState _
    Inherits State
public ref class ProspectingState : public State

Inheritance Hierarchy

Object
robotManager.FiniteStateMachine..::..State
wManager.Wow.Bot.States..::..ProspectingState

See Also

ProspectingState Members
wManager.Wow.Bot.States Namespace
robotManager.FiniteStateMachine..::..State


ProspectingState Members

The ProspectingState type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

ProspectingState Class
wManager.Wow.Bot.States Namespace


ProspectingState Methods

The ProspectingState type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

See Also

ProspectingState Class
wManager.Wow.Bot.States Namespace


Run Method

ProspectingState..::..Run Method

Runs this instance.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Run()
Public Sub Run
public:
void Run()

See Also

ProspectingState Class
wManager.Wow.Bot.States Namespace


ProspectingState Properties

The ProspectingState type exposes the following members.

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

ProspectingState Class
wManager.Wow.Bot.States Namespace


DisplayName Property

ProspectingState..::..DisplayName Property

Gets the display name.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string DisplayName { get; }
Public ReadOnly Property DisplayName As String
    Get
public:
property String^ DisplayName {
    String^ get ();
}

Field Value

The display name.

See Also

ProspectingState Class
wManager.Wow.Bot.States Namespace


NeedToRun Property

ProspectingState..::..NeedToRun Property

Indicate if Engine need to call method Run()()()().

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool NeedToRun { get; }
Public ReadOnly Property NeedToRun As Boolean
    Get
public:
property bool^ NeedToRun {
    bool^ get ();
}

Field Value

true if need to run; otherwise, false .

See Also

ProspectingState Class
wManager.Wow.Bot.States Namespace


Regeneration Class

Class Regeneration. To restore health points and mana of character. Use regen options that you can found in wManagerSetting Implements the State

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class Regeneration : State
Public Class Regeneration _
    Inherits State
public ref class Regeneration : public State

Inheritance Hierarchy

Object
robotManager.FiniteStateMachine..::..State
wManager.Wow.Bot.States..::..Regeneration

See Also

Regeneration Members
wManager.Wow.Bot.States Namespace
robotManager.FiniteStateMachine..::..State


Regeneration Members

The Regeneration type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

Regeneration Class
wManager.Wow.Bot.States Namespace


Regeneration Methods

The Regeneration type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

See Also

Regeneration Class
wManager.Wow.Bot.States Namespace


Run Method

Regeneration..::..Run Method

Runs this instance.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Run()
Public Sub Run
public:
void Run()

See Also

Regeneration Class
wManager.Wow.Bot.States Namespace


Regeneration Properties

The Regeneration type exposes the following members.

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

Regeneration Class
wManager.Wow.Bot.States Namespace


DisplayName Property

Regeneration..::..DisplayName Property

Gets the display name.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string DisplayName { get; }
Public ReadOnly Property DisplayName As String
    Get
public:
property String^ DisplayName {
    String^ get ();
}

Field Value

The display name.

See Also

Regeneration Class
wManager.Wow.Bot.States Namespace


NeedToRun Property

Regeneration..::..NeedToRun Property

Indicate if Engine need to call method Run()()()().

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool NeedToRun { get; }
Public ReadOnly Property NeedToRun As Boolean
    Get
public:
property bool^ NeedToRun {
    bool^ get ();
}

Field Value

true if need to run; otherwise, false .

See Also

Regeneration Class
wManager.Wow.Bot.States Namespace


Relogger Class

Class Relogger. reconnect the character to the game when he is disconnected. You need to use option Relogger Implements the State

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class Relogger : State
Public Class Relogger _
    Inherits State
public ref class Relogger : public State

Inheritance Hierarchy

Object
robotManager.FiniteStateMachine..::..State
wManager.Wow.Bot.States..::..Relogger

See Also

Relogger Members
wManager.Wow.Bot.States Namespace
robotManager.FiniteStateMachine..::..State


Relogger Members

The Relogger type exposes the following members.

Constructors

 | Name | Description
Public method | Relogger | Initializes a new instance of the Relogger class.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

Relogger Class
wManager.Wow.Bot.States Namespace


Relogger Constructor

Initializes a new instance of the Relogger class.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Relogger()
Public Sub New
public:
Relogger()

See Also

Relogger Class
wManager.Wow.Bot.States Namespace


Relogger Methods

The Relogger type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

See Also

Relogger Class
wManager.Wow.Bot.States Namespace


Run Method

Relogger..::..Run Method

Runs this instance.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Run()
Public Sub Run
public:
void Run()

See Also

Relogger Class
wManager.Wow.Bot.States Namespace


Relogger Properties

The Relogger type exposes the following members.

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

Relogger Class
wManager.Wow.Bot.States Namespace


DisplayName Property

Relogger..::..DisplayName Property

Gets the display name.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string DisplayName { get; }
Public ReadOnly Property DisplayName As String
    Get
public:
property String^ DisplayName {
    String^ get ();
}

Field Value

The display name.

See Also

Relogger Class
wManager.Wow.Bot.States Namespace


NeedToRun Property

Relogger..::..NeedToRun Property

Indicate if Engine need to call method Run()()()().

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool NeedToRun { get; }
Public ReadOnly Property NeedToRun As Boolean
    Get
public:
property bool^ NeedToRun {
    bool^ get ();
}

Field Value

true if need to run; otherwise, false .

See Also

Relogger Class
wManager.Wow.Bot.States Namespace


Resurrect Class

Class Resurrect. To revive when dead(with corpse or spirit healer, options in wManagerSetting). Implements the State

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class Resurrect : State
Public Class Resurrect _
    Inherits State
public ref class Resurrect : public State

Inheritance Hierarchy

Object
robotManager.FiniteStateMachine..::..State
wManager.Wow.Bot.States..::..Resurrect

See Also

Resurrect Members
wManager.Wow.Bot.States Namespace
robotManager.FiniteStateMachine..::..State


Resurrect Members

The Resurrect type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

Resurrect Class
wManager.Wow.Bot.States Namespace


Resurrect Methods

The Resurrect type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

See Also

Resurrect Class
wManager.Wow.Bot.States Namespace


Run Method

Resurrect..::..Run Method

Runs this instance.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Run()
Public Sub Run
public:
void Run()

See Also

Resurrect Class
wManager.Wow.Bot.States Namespace


Resurrect Properties

The Resurrect type exposes the following members.

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

Resurrect Class
wManager.Wow.Bot.States Namespace


DisplayName Property

Resurrect..::..DisplayName Property

Gets the display name.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string DisplayName { get; }
Public ReadOnly Property DisplayName As String
    Get
public:
property String^ DisplayName {
    String^ get ();
}

Field Value

The display name.

See Also

Resurrect Class
wManager.Wow.Bot.States Namespace


NeedToRun Property

Resurrect..::..NeedToRun Property

Indicate if Engine need to call method Run()()()().

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool NeedToRun { get; }
Public ReadOnly Property NeedToRun As Boolean
    Get
public:
property bool^ NeedToRun {
    bool^ get ();
}

Field Value

true if need to run; otherwise, false .

See Also

Resurrect Class
wManager.Wow.Bot.States Namespace


ResurrectBG Class

Class ResurrectBG. To revive when dead in battleground. Implements the State

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class ResurrectBG : State
Public Class ResurrectBG _
    Inherits State
public ref class ResurrectBG : public State

Inheritance Hierarchy

Object
robotManager.FiniteStateMachine..::..State
wManager.Wow.Bot.States..::..ResurrectBG

See Also

ResurrectBG Members
wManager.Wow.Bot.States Namespace
robotManager.FiniteStateMachine..::..State


ResurrectBG Members

The ResurrectBG type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

ResurrectBG Class
wManager.Wow.Bot.States Namespace


ResurrectBG Methods

The ResurrectBG type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

See Also

ResurrectBG Class
wManager.Wow.Bot.States Namespace


Run Method

ResurrectBG..::..Run Method

Runs this instance.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Run()
Public Sub Run
public:
void Run()

See Also

ResurrectBG Class
wManager.Wow.Bot.States Namespace


ResurrectBG Properties

The ResurrectBG type exposes the following members.

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

ResurrectBG Class
wManager.Wow.Bot.States Namespace


DisplayName Property

ResurrectBG..::..DisplayName Property

Gets the display name.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string DisplayName { get; }
Public ReadOnly Property DisplayName As String
    Get
public:
property String^ DisplayName {
    String^ get ();
}

Field Value

The display name.

See Also

ResurrectBG Class
wManager.Wow.Bot.States Namespace


NeedToRun Property

ResurrectBG..::..NeedToRun Property

Indicate if Engine need to call method Run()()()().

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool NeedToRun { get; }
Public ReadOnly Property NeedToRun As Boolean
    Get
public:
property bool^ NeedToRun {
    bool^ get ();
}

Field Value

true if need to run; otherwise, false .

See Also

ResurrectBG Class
wManager.Wow.Bot.States Namespace


SmeltingState Class

Class SmeltingState. Look Smelting Implements the State

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class SmeltingState : State
Public Class SmeltingState _
    Inherits State
public ref class SmeltingState : public State

Inheritance Hierarchy

Object
robotManager.FiniteStateMachine..::..State
wManager.Wow.Bot.States..::..SmeltingState

See Also

SmeltingState Members
wManager.Wow.Bot.States Namespace
robotManager.FiniteStateMachine..::..State


SmeltingState Members

The SmeltingState type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | IgnoreSmeltingZone | If enabled smelting at current character position, else bot got to nearby Smelting NPC found in NpcDB

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

SmeltingState Class
wManager.Wow.Bot.States Namespace


SmeltingState Fields

The SmeltingState type exposes the following members.

Fields

 | Name | Description
Public field | IgnoreSmeltingZone | If enabled smelting at current character position, else bot got to nearby Smelting NPC found in NpcDB

See Also

SmeltingState Class
wManager.Wow.Bot.States Namespace


IgnoreSmeltingZone Field

SmeltingState..::..IgnoreSmeltingZone Field

If enabled smelting at current character position, else bot got to nearby Smelting NPC found in NpcDB

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IgnoreSmeltingZone
Public IgnoreSmeltingZone As Boolean
public:
bool^ IgnoreSmeltingZone

See Also

SmeltingState Class
wManager.Wow.Bot.States Namespace


SmeltingState Methods

The SmeltingState type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

See Also

SmeltingState Class
wManager.Wow.Bot.States Namespace


Run Method

SmeltingState..::..Run Method

Runs this instance.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Run()
Public Sub Run
public:
void Run()

See Also

SmeltingState Class
wManager.Wow.Bot.States Namespace


SmeltingState Properties

The SmeltingState type exposes the following members.

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

SmeltingState Class
wManager.Wow.Bot.States Namespace


DisplayName Property

SmeltingState..::..DisplayName Property

Gets the display name.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string DisplayName { get; }
Public ReadOnly Property DisplayName As String
    Get
public:
property String^ DisplayName {
    String^ get ();
}

Field Value

The display name.

See Also

SmeltingState Class
wManager.Wow.Bot.States Namespace


NeedToRun Property

SmeltingState..::..NeedToRun Property

Indicate if Engine need to call method Run()()()().

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool NeedToRun { get; }
Public ReadOnly Property NeedToRun As Boolean
    Get
public:
property bool^ NeedToRun {
    bool^ get ();
}

Field Value

true if need to run; otherwise, false .

See Also

SmeltingState Class
wManager.Wow.Bot.States Namespace


SpellState Class

Class SpellState. This class was created for FightClasses in XML (create with Creator), the bot converted XML to C# code that use this state for the spells, this class is not practical and should not be used in any other context. Implements the State

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class SpellState : State
Public Class SpellState _
    Inherits State
public ref class SpellState : public State

Inheritance Hierarchy

Object
robotManager.FiniteStateMachine..::..State
wManager.Wow.Bot.States..::..SpellState

See Also

SpellState Members
wManager.Wow.Bot.States Namespace
robotManager.FiniteStateMachine..::..State


SpellState Members

The SpellState type exposes the following members.

Constructors

 | Name | Description
Public method | SpellState | Initializes a new instance of the SpellState class.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NameAndDescription | Gets the name and description.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority.
Public property | Spell | Gets the spell.

See Also

SpellState Class
wManager.Wow.Bot.States Namespace


SpellState Constructor

Initializes a new instance of the SpellState class.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public SpellState(
    string spellName,
    int priority,
    BooleanDelegate condition,
    bool isBuff,
    bool inCombatOnly,
    bool castIfInMount,
    bool castIfMeDead,
    bool checkIfKnow,
    bool checkIfSpellUsable,
    bool checkSpellDistance,
    bool needInView,
    int timer,
    bool notSpellIsLuaScript,
    bool debug,
    bool targetFriends,
    bool aoeSpell,
    bool aoeSpellMePos,
    bool oncePerTarget,
    YesNoAuto canMoveDuringCast,
    string description,
    string castOn,
    bool lockFrame,
    bool waitDuringCasting,
    bool notSpellIsCSharpCode,
    bool notSpellIsVBCode,
    bool notSpellIsLuaBotCode
)
Public Sub New ( _
    spellName As String, _
    priority As Integer, _
    condition As BooleanDelegate, _
    isBuff As Boolean, _
    inCombatOnly As Boolean, _
    castIfInMount As Boolean, _
    castIfMeDead As Boolean, _
    checkIfKnow As Boolean, _
    checkIfSpellUsable As Boolean, _
    checkSpellDistance As Boolean, _
    needInView As Boolean, _
    timer As Integer, _
    notSpellIsLuaScript As Boolean, _
    debug As Boolean, _
    targetFriends As Boolean, _
    aoeSpell As Boolean, _
    aoeSpellMePos As Boolean, _
    oncePerTarget As Boolean, _
    canMoveDuringCast As YesNoAuto, _
    description As String, _
    castOn As String, _
    lockFrame As Boolean, _
    waitDuringCasting As Boolean, _
    notSpellIsCSharpCode As Boolean, _
    notSpellIsVBCode As Boolean, _
    notSpellIsLuaBotCode As Boolean _
)
public:
SpellState(
    String^ spellName,
    int^ priority,
    BooleanDelegate^ condition,
    bool^ isBuff,
    bool^ inCombatOnly,
    bool^ castIfInMount,
    bool^ castIfMeDead,
    bool^ checkIfKnow,
    bool^ checkIfSpellUsable,
    bool^ checkSpellDistance,
    bool^ needInView,
    int^ timer,
    bool^ notSpellIsLuaScript,
    bool^ debug,
    bool^ targetFriends,
    bool^ aoeSpell,
    bool^ aoeSpellMePos,
    bool^ oncePerTarget,
    YesNoAuto^ canMoveDuringCast,
    String^ description,
    String^ castOn,
    bool^ lockFrame,
    bool^ waitDuringCasting,
    bool^ notSpellIsCSharpCode,
    bool^ notSpellIsVBCode,
    bool^ notSpellIsLuaBotCode
)

Parameters

spellName
Type: String
Name of the spell (in English).
priority
Type: Int32
The priority.
condition
Type: wManager.Wow.Class..::..BooleanDelegate
The condition.
isBuff
Type: Boolean
if set to true is buff (cast only if character haven't this spell).
inCombatOnly
Type: Boolean
if set to true use it in combat only.
castIfInMount
Type: Boolean
if set to true can use when in mount.
castIfMeDead
Type: Boolean
if set to true can use when dead.
checkIfKnow
Type: Boolean
if set to true if you want check if character know the spell.
checkIfSpellUsable
Type: Boolean
if set to true if you want check if spell is usable.
checkSpellDistance
Type: Boolean
if set to true if you want cast only when in good distance.
needInView
Type: Boolean
if set to true your target need to be in line of sight.
timer
Type: Int32
Minimum interval between 2 use (in milliseconds).
notSpellIsLuaScript
Type: Boolean
if set to true[spellName] is lua code (not spell name).
debug
Type: Boolean
if set to true add debug info in log.
targetFriends
Type: Boolean
if set to true target party members (for heals spells).
aoeSpell
Type: Boolean
if set to true it is AOE spell (need to click on ground, by default in target position).
aoeSpellMePos
Type: Boolean
if set to true and [aoeSpell] is true, click on me position.
oncePerTarget
Type: Boolean
if set to true to use once per target.
canMoveDuringCast
Type: wManager.Wow.Helpers.FightClassCreator..::..YesNoAuto
Can move during cast.
description
Type: String
The description.
castOn
Type: String
Cast on.
lockFrame
Type: Boolean
if set to true lock game frame when check spell condition (faster).
waitDuringCasting
Type: Boolean
if set to true wait during casting.
notSpellIsCSharpCode
Type: Boolean
if set to true[spellName] is C# code (not spell name).
notSpellIsVBCode
Type: Boolean
if set to true[spellName] is VB.net code (not spell name).
notSpellIsLuaBotCode
Type: Boolean
if set to true[spellName] is luabot code (not spell name).

See Also

SpellState Class
wManager.Wow.Bot.States Namespace


SpellState Methods

The SpellState type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

See Also

SpellState Class
wManager.Wow.Bot.States Namespace


Run Method

SpellState..::..Run Method

Runs this instance.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Run()
Public Sub Run
public:
void Run()

See Also

SpellState Class
wManager.Wow.Bot.States Namespace


SpellState Properties

The SpellState type exposes the following members.

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NameAndDescription | Gets the name and description.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority.
Public property | Spell | Gets the spell.

See Also

SpellState Class
wManager.Wow.Bot.States Namespace


DisplayName Property

SpellState..::..DisplayName Property

Gets the display name.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string DisplayName { get; }
Public ReadOnly Property DisplayName As String
    Get
public:
property String^ DisplayName {
    String^ get ();
}

Field Value

The display name.

See Also

SpellState Class
wManager.Wow.Bot.States Namespace


NameAndDescription Property

SpellState..::..NameAndDescription Property

Gets the name and description.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string NameAndDescription { get; }
Public ReadOnly Property NameAndDescription As String
    Get
public:
property String^ NameAndDescription {
    String^ get ();
}

Field Value

The name and description.

See Also

SpellState Class
wManager.Wow.Bot.States Namespace


NeedToRun Property

SpellState..::..NeedToRun Property

Indicate if Engine need to call method Run()()()().

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool NeedToRun { get; }
Public ReadOnly Property NeedToRun As Boolean
    Get
public:
property bool^ NeedToRun {
    bool^ get ();
}

Field Value

true if need to run; otherwise, false .

See Also

SpellState Class
wManager.Wow.Bot.States Namespace


Priority Property

SpellState..::..Priority Property

Gets the priority.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int Priority { get; set; }
Public Property Priority As Integer
    Get
    Set
public:
property int^ Priority {
    int^ get ();
    void set (int^ value);
}

Field Value

The priority.

See Also

SpellState Class
wManager.Wow.Bot.States Namespace


Spell Property

SpellState..::..Spell Property

Gets the spell.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Spell Spell { get; }
Public ReadOnly Property Spell As Spell
    Get
public:
property Spell^ Spell {
    Spell^ get ();
}

Field Value

The spell.

See Also

SpellState Class
wManager.Wow.Bot.States Namespace


StopBotIf Class

Class StopBotIf. This state manages the various security options found in wManagerSetting (teleportation, pathfinder down, blockages, whispers, players nearby, ...). Class is mainly not used as State, but product call LaunchNewThread()()()() when starting and StopThread()()()() when stopped. Implements the State

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class StopBotIf : State
Public Class StopBotIf _
    Inherits State
public ref class StopBotIf : public State

Inheritance Hierarchy

Object
robotManager.FiniteStateMachine..::..State
wManager.Wow.Bot.States..::..StopBotIf

See Also

StopBotIf Members
wManager.Wow.Bot.States Namespace
robotManager.FiniteStateMachine..::..State


StopBotIf Members

The StopBotIf type exposes the following members.

Constructors

 | Name | Description
Public method | StopBotIf | Initializes a new instance of the StopBotIf class.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
 | LaunchNewThread | Launch new thread with an Engine that contains this state.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
 | StopThread | Stops Engine that contains this state.
 | ThreadIsLaunched | Threads the is launched.
Public method | ToString | (Inherited from Object.)

Fields

Name | Description
ForcePvpMode | The force PVP mode
TPLastContinent | The tp last continent
TPLastPos | The tp last position
TPLastTime | The tp last time

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

StopBotIf Class
wManager.Wow.Bot.States Namespace


StopBotIf Constructor

Initializes a new instance of the StopBotIf class.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public StopBotIf()
Public Sub New
public:
StopBotIf()

See Also

StopBotIf Class
wManager.Wow.Bot.States Namespace


StopBotIf Fields

The StopBotIf type exposes the following members.

Fields

Name | Description
ForcePvpMode | The force PVP mode
TPLastContinent | The tp last continent
TPLastPos | The tp last position
TPLastTime | The tp last time

See Also

StopBotIf Class
wManager.Wow.Bot.States Namespace


ForcePvpMode Field

StopBotIf..::..ForcePvpMode Field

The force PVP mode

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool ForcePvpMode
Public Shared ForcePvpMode As Boolean
public:
static bool^ ForcePvpMode

See Also

StopBotIf Class
wManager.Wow.Bot.States Namespace


TPLastContinent Field

StopBotIf..::..TPLastContinent Field

The tp last continent

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int TPLastContinent
Public Shared TPLastContinent As Integer
public:
static int^ TPLastContinent

See Also

StopBotIf Class
wManager.Wow.Bot.States Namespace


TPLastPos Field

StopBotIf..::..TPLastPos Field

The tp last position

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static Vector3 TPLastPos
Public Shared TPLastPos As Vector3
public:
static Vector3^ TPLastPos

See Also

StopBotIf Class
wManager.Wow.Bot.States Namespace


TPLastTime Field

StopBotIf..::..TPLastTime Field

The tp last time

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static Stopwatch TPLastTime
Public Shared TPLastTime As Stopwatch
public:
static Stopwatch^ TPLastTime

See Also

StopBotIf Class
wManager.Wow.Bot.States Namespace


StopBotIf Methods

The StopBotIf type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
 | LaunchNewThread | Launch new thread with an Engine that contains this state.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
 | StopThread | Stops Engine that contains this state.
 | ThreadIsLaunched | Threads the is launched.
Public method | ToString | (Inherited from Object.)

See Also

StopBotIf Class
wManager.Wow.Bot.States Namespace


LaunchNewThread Method

StopBotIf..::..LaunchNewThread Method

Launch new thread with an Engine that contains this state.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void LaunchNewThread()
Public Shared Sub LaunchNewThread
public:
static void LaunchNewThread()

See Also

StopBotIf Class
wManager.Wow.Bot.States Namespace


Run Method

StopBotIf..::..Run Method

Runs this instance.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Run()
Public Sub Run
public:
void Run()

See Also

StopBotIf Class
wManager.Wow.Bot.States Namespace


StopThread Method

StopBotIf..::..StopThread Method

Stops Engine that contains this state.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void StopThread()
Public Shared Sub StopThread
public:
static void StopThread()

See Also

StopBotIf Class
wManager.Wow.Bot.States Namespace


ThreadIsLaunched Method

StopBotIf..::..ThreadIsLaunched Method

Threads the is launched.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool ThreadIsLaunched()
Public Shared Function ThreadIsLaunched As Boolean
public:
static bool^ ThreadIsLaunched()

Return Value

true if XXXX, false otherwise.

See Also

StopBotIf Class
wManager.Wow.Bot.States Namespace


StopBotIf Properties

The StopBotIf type exposes the following members.

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

StopBotIf Class
wManager.Wow.Bot.States Namespace


DisplayName Property

StopBotIf..::..DisplayName Property

Gets the display name.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string DisplayName { get; }
Public ReadOnly Property DisplayName As String
    Get
public:
property String^ DisplayName {
    String^ get ();
}

Field Value

The display name.

See Also

StopBotIf Class
wManager.Wow.Bot.States Namespace


NeedToRun Property

StopBotIf..::..NeedToRun Property

Indicate if Engine need to call method Run()()()().

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool NeedToRun { get; }
Public ReadOnly Property NeedToRun As Boolean
    Get
public:
property bool^ NeedToRun {
    bool^ get ();
}

Field Value

true if need to run; otherwise, false .

See Also

StopBotIf Class
wManager.Wow.Bot.States Namespace


Talents Class

Class Talents. If option AssignTalents is enabled use class Talent Implements the State

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class Talents : State
Public Class Talents _
    Inherits State
public ref class Talents : public State

Inheritance Hierarchy

Object
robotManager.FiniteStateMachine..::..State
wManager.Wow.Bot.States..::..Talents

See Also

Talents Members
wManager.Wow.Bot.States Namespace
robotManager.FiniteStateMachine..::..State


Talents Members

The Talents type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

Talents Class
wManager.Wow.Bot.States Namespace


Talents Methods

The Talents type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

See Also

Talents Class
wManager.Wow.Bot.States Namespace


Run Method

Talents..::..Run Method

Runs this instance.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Run()
Public Sub Run
public:
void Run()

See Also

Talents Class
wManager.Wow.Bot.States Namespace


Talents Properties

The Talents type exposes the following members.

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

Talents Class
wManager.Wow.Bot.States Namespace


DisplayName Property

Talents..::..DisplayName Property

Gets the display name.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string DisplayName { get; }
Public ReadOnly Property DisplayName As String
    Get
public:
property String^ DisplayName {
    String^ get ();
}

Field Value

The display name.

See Also

Talents Class
wManager.Wow.Bot.States Namespace


NeedToRun Property

Talents..::..NeedToRun Property

Indicate if Engine need to call method Run()()()().

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool NeedToRun { get; }
Public ReadOnly Property NeedToRun As Boolean
    Get
public:
property bool^ NeedToRun {
    bool^ get ();
}

Field Value

true if need to run; otherwise, false .

See Also

Talents Class
wManager.Wow.Bot.States Namespace


ToTown Class

Class ToTown. To repair, sell, send mail, buy items (options can be found in wManagerSetting Implements the State

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class ToTown : State
Public Class ToTown _
    Inherits State
public ref class ToTown : public State

Inheritance Hierarchy

Object
robotManager.FiniteStateMachine..::..State
wManager.Wow.Bot.States..::..ToTown

See Also

ToTown Members
wManager.Wow.Bot.States Namespace
robotManager.FiniteStateMachine..::..State


ToTown Members

The ToTown type exposes the following members.

Constructors

 | Name | Description
Public method | ToTown | Initializes a new instance of the ToTown class.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
 | ForceToTown | Enable this option to force to go to town (this option will be disabled automatically once it is done).
 | GoToTownInProgress | true if town in progress
 | MaxItemsQuantityToBuyByRequest | The maximum items quantity to buy by request
Public field | PetBattleMode | Enabled this option to use Npc type ResurrectBattlePets (of profile or NpcDB).

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

ToTown Class
wManager.Wow.Bot.States Namespace


ToTown Constructor

Initializes a new instance of the ToTown class.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public ToTown()
Public Sub New
public:
ToTown()

See Also

ToTown Class
wManager.Wow.Bot.States Namespace


ToTown Fields

The ToTown type exposes the following members.

Fields

 | Name | Description
 | ForceToTown | Enable this option to force to go to town (this option will be disabled automatically once it is done).
 | GoToTownInProgress | true if town in progress
 | MaxItemsQuantityToBuyByRequest | The maximum items quantity to buy by request
Public field | PetBattleMode | Enabled this option to use Npc type ResurrectBattlePets (of profile or NpcDB).

See Also

ToTown Class
wManager.Wow.Bot.States Namespace


ForceToTown Field

ToTown..::..ForceToTown Field

Enable this option to force to go to town (this option will be disabled automatically once it is done).

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool ForceToTown
Public Shared ForceToTown As Boolean
public:
static bool^ ForceToTown

See Also

ToTown Class
wManager.Wow.Bot.States Namespace


GoToTownInProgress Field

ToTown..::..GoToTownInProgress Field

true if town in progress

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool GoToTownInProgress
Public Shared GoToTownInProgress As Boolean
public:
static bool^ GoToTownInProgress

See Also

ToTown Class
wManager.Wow.Bot.States Namespace


MaxItemsQuantityToBuyByRequest Field

ToTown..::..MaxItemsQuantityToBuyByRequest Field

The maximum items quantity to buy by request

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int MaxItemsQuantityToBuyByRequest
Public Shared MaxItemsQuantityToBuyByRequest As Integer
public:
static int^ MaxItemsQuantityToBuyByRequest

See Also

ToTown Class
wManager.Wow.Bot.States Namespace


PetBattleMode Field

ToTown..::..PetBattleMode Field

Enabled this option to use Npc type ResurrectBattlePets (of profile or NpcDB).

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool PetBattleMode
Public PetBattleMode As Boolean
public:
bool^ PetBattleMode

See Also

ToTown Class
wManager.Wow.Bot.States Namespace


ToTown Methods

The ToTown type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

See Also

ToTown Class
wManager.Wow.Bot.States Namespace


Run Method

ToTown..::..Run Method

Runs this instance.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Run()
Public Sub Run
public:
void Run()

See Also

ToTown Class
wManager.Wow.Bot.States Namespace


ToTown Properties

The ToTown type exposes the following members.

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

ToTown Class
wManager.Wow.Bot.States Namespace


DisplayName Property

ToTown..::..DisplayName Property

Gets the display name.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string DisplayName { get; }
Public ReadOnly Property DisplayName As String
    Get
public:
property String^ DisplayName {
    String^ get ();
}

Field Value

The display name.

See Also

ToTown Class
wManager.Wow.Bot.States Namespace


NeedToRun Property

ToTown..::..NeedToRun Property

Indicate if Engine need to call method Run()()()().

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool NeedToRun { get; }
Public ReadOnly Property NeedToRun As Boolean
    Get
public:
property bool^ NeedToRun {
    bool^ get ();
}

Field Value

true if need to run; otherwise, false .

See Also

ToTown Class
wManager.Wow.Bot.States Namespace


Trainers Class

Class Trainers. TrainNewSkills Implements the State

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class Trainers : State
Public Class Trainers _
    Inherits State
public ref class Trainers : public State

Inheritance Hierarchy

Object
robotManager.FiniteStateMachine..::..State
wManager.Wow.Bot.States..::..Trainers

See Also

Trainers Members
wManager.Wow.Bot.States Namespace
robotManager.FiniteStateMachine..::..State


Trainers Members

The Trainers type exposes the following members.

Constructors

 | Name | Description
Public method | Trainers |

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
 | ForceGoClassTrainer | Force to go the trainer.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

Trainers Class
wManager.Wow.Bot.States Namespace


Trainers Constructor

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Trainers()
Public Sub New
public:
Trainers()

See Also

Trainers Class
wManager.Wow.Bot.States Namespace


Trainers Methods

The Trainers type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from State.)
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from State.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
 | ForceGoClassTrainer | Force to go the trainer.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Run | Runs this instance.
Public method | ToString | (Inherited from Object.)

See Also

Trainers Class
wManager.Wow.Bot.States Namespace


ForceGoClassTrainer Method

Trainers..::..ForceGoClassTrainer Method

Force to go the trainer.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void ForceGoClassTrainer()
Public Shared Sub ForceGoClassTrainer
public:
static void ForceGoClassTrainer()

See Also

Trainers Class
wManager.Wow.Bot.States Namespace


Run Method

Trainers..::..Run Method

Runs this instance.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Run()
Public Sub Run
public:
void Run()

See Also

Trainers Class
wManager.Wow.Bot.States Namespace


Trainers Properties

The Trainers type exposes the following members.

Properties

 | Name | Description
Public property | BeforeStates | Launch these states before Run()()()() this state (NeedToRun must be true), empty if not used. (Inherited from State.)
Public property | DisplayName | Gets the display name.
Public property | NeedToRun | Indicate if Engine need to call method Run()()()().
Public property | NextStates | Launch these states after Run()()()() this state, empty if not used. (Inherited from State.)
Public property | Priority | Gets the priority (determine the order of execution by Engine). (Inherited from State.)

See Also

Trainers Class
wManager.Wow.Bot.States Namespace


DisplayName Property

Trainers..::..DisplayName Property

Gets the display name.

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string DisplayName { get; }
Public ReadOnly Property DisplayName As String
    Get
public:
property String^ DisplayName {
    String^ get ();
}

Field Value

The display name.

See Also

Trainers Class
wManager.Wow.Bot.States Namespace


NeedToRun Property

Trainers..::..NeedToRun Property

Indicate if Engine need to call method Run()()()().

Namespace: wManager.Wow.Bot.States
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool NeedToRun { get; }
Public ReadOnly Property NeedToRun As Boolean
    Get
public:
property bool^ NeedToRun {
    bool^ get ();
}

Field Value

true if need to run; otherwise, false .

See Also

Trainers Class
wManager.Wow.Bot.States Namespace


wManager.Wow.Bot.Tasks Namespace

Classes

 | Class | Description
Public class | FarmingTask | Class FarmingTask. Harvest gamebobject.
Public class | FishingTask | Class FishingTask. Do fishing task
Public class | GoToTask | Class GoToTask. Very useful methods to go to a position (methods generate path and manage movement) and/or interact with a WoWItem or WoWGameObject (this class use PathFinder, MovementManager, Interact, ...)
Public class | LootingTask | Class LootingTask. Looting WowUnits
Public class | MountTask | Class MountTask, methods to mount/dismount.

Enumerations

 | Enumeration | Description
Public enumeration | MountTask..::..MountCapacity | Mount capacity


FarmingTask Class

Class FarmingTask. Harvest gamebobject.

Namespace: wManager.Wow.Bot.Tasks
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class FarmingTask
Public NotInheritable Class FarmingTask
public ref class FarmingTask abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Bot.Tasks..::..FarmingTask

See Also

FarmingTask Members
wManager.Wow.Bot.Tasks Namespace


FarmingTask Members

The FarmingTask type exposes the following members.

Methods

Name | Description
Pulse | Pulses the specified node.

See Also

FarmingTask Class
wManager.Wow.Bot.Tasks Namespace


FarmingTask Methods

The FarmingTask type exposes the following members.

Methods

Name | Description
Pulse | Pulses the specified node.

See Also

FarmingTask Class
wManager.Wow.Bot.Tasks Namespace


Pulse Method

FarmingTask..::..Pulse Method

Pulses the specified node.

Namespace: wManager.Wow.Bot.Tasks
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void Pulse(
    WoWGameObject node,
    bool autoMountIfSuccess,
    bool ignoreIfPlayerNear,
    float flyFarmRandomizeNodePostion
)
Public Shared Sub Pulse ( _
    node As WoWGameObject, _
    autoMountIfSuccess As Boolean, _
    ignoreIfPlayerNear As Boolean, _
    flyFarmRandomizeNodePostion As Single _
)
public:
static void Pulse(
    WoWGameObject^ node,
    bool^ autoMountIfSuccess,
    bool^ ignoreIfPlayerNear,
    float^ flyFarmRandomizeNodePostion
)

Parameters

node
Type: wManager.Wow.ObjectManager..::..WoWGameObject
The gamebobject to harvest.
autoMountIfSuccess
Type: Boolean
if set to true automatic mount if success.
ignoreIfPlayerNear
Type: Boolean
if set to true skip if player nearby.
flyFarmRandomizeNodePostion
Type: Single
randomize landing position (if fly).

See Also

FarmingTask Class
wManager.Wow.Bot.Tasks Namespace


FishingTask Class

Class FishingTask. Do fishing task

Namespace: wManager.Wow.Bot.Tasks
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class FishingTask
Public Class FishingTask
public ref class FishingTask

Inheritance Hierarchy

Object
wManager.Wow.Bot.Tasks..::..FishingTask

See Also

FishingTask Members
wManager.Wow.Bot.Tasks Namespace


FishingTask Members

The FishingTask type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
 | LoopFish()()()() | Launch fishing.
 | LoopFish(UInt64, Boolean, String, String, Int32, String, Int32, Int32, Int32, Int32, Boolean) | Launch fishing.
Protected method | MemberwiseClone | (Inherited from Object.)
 | StopLoopFish | Stop fishing.
Public method | ToString | (Inherited from Object.)

Properties

Name | Description
IsLaunched | Is fishing.

See Also

FishingTask Class
wManager.Wow.Bot.Tasks Namespace


FishingTask Methods

The FishingTask type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
 | LoopFish()()()() | Launch fishing.
 | LoopFish(UInt64, Boolean, String, String, Int32, String, Int32, Int32, Int32, Int32, Boolean) | Launch fishing.
Protected method | MemberwiseClone | (Inherited from Object.)
 | StopLoopFish | Stop fishing.
Public method | ToString | (Inherited from Object.)

See Also

FishingTask Class
wManager.Wow.Bot.Tasks Namespace


LoopFish Method

FishingTask..::..LoopFish Method

Overload List

Name | Description
LoopFish()()()() | Launch fishing.
LoopFish(UInt64, Boolean, String, String, Int32, String, Int32, Int32, Int32, Int32, Boolean) | Launch fishing.

See Also

FishingTask Class
FishingTask Members
wManager.Wow.Bot.Tasks Namespace


LoopFish Method

FishingTask..::..LoopFish Method

Launch fishing.

Namespace: wManager.Wow.Bot.Tasks
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void LoopFish()
Public Shared Sub LoopFish
public:
static void LoopFish()

See Also

FishingTask Class
LoopFish Overload
wManager.Wow.Bot.Tasks Namespace


LoopFish Method (UInt64, Boolean, String, String, Int32, String, Int32, Int32, Int32, Int32, Boolean)

FishingTask..::..LoopFish Method (UInt64, Boolean, String, String, Int32, String, Int32, Int32, Int32, Int32, Boolean)

Launch fishing.

Namespace: wManager.Wow.Bot.Tasks
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void LoopFish(
    ulong guidNode,
    bool useLure,
    string lureName,
    string temporaryBait,
    int temporaryBaitDurationMs,
    string customName,
    int customDurationMs,
    int waitAfterInteractTime,
    int waitBobberTime,
    int waitBobberInteractTime,
    bool precision
)
Public Shared Sub LoopFish ( _
    guidNode As ULong, _
    useLure As Boolean, _
    lureName As String, _
    temporaryBait As String, _
    temporaryBaitDurationMs As Integer, _
    customName As String, _
    customDurationMs As Integer, _
    waitAfterInteractTime As Integer, _
    waitBobberTime As Integer, _
    waitBobberInteractTime As Integer, _
    precision As Boolean _
)
public:
static void LoopFish(
    unsigned long long^ guidNode,
    bool^ useLure,
    String^ lureName,
    String^ temporaryBait,
    int^ temporaryBaitDurationMs,
    String^ customName,
    int^ customDurationMs,
    int^ waitAfterInteractTime,
    int^ waitBobberTime,
    int^ waitBobberInteractTime,
    bool^ precision
)

Parameters

guidNode
Type: UInt64
The node GUID (MemoryRobot.Int128.Zero() if you don't fishing a school of fish).
useLure
Type: Boolean
if set to true to use lure.
lureName
Type: String
Name of the lure (name like in game).
temporaryBait
Type: String
The temporary bait (name like in game).
temporaryBaitDurationMs
Type: Int32
Temporary bait duration in milliseconds.
customName
Type: String
Name of the custom spell/item (name like in game).
customDurationMs
Type: Int32
The custom spell/item duration in milliseconds.
waitAfterInteractTime
Type: Int32
Wait time after catch in milliseconds.
waitBobberTime
Type: Int32
Wait time to search bobber in milliseconds.
waitBobberInteractTime
Type: Int32
Wait time to interact with bobber when fish in milliseconds.
precision
Type: Boolean
if set to true bot will relaunch the bobber if not close to [guidNode].

See Also

FishingTask Class
LoopFish Overload
wManager.Wow.Bot.Tasks Namespace


StopLoopFish Method

FishingTask..::..StopLoopFish Method

Stop fishing.

Namespace: wManager.Wow.Bot.Tasks
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void StopLoopFish()
Public Shared Sub StopLoopFish
public:
static void StopLoopFish()

See Also

FishingTask Class
wManager.Wow.Bot.Tasks Namespace


FishingTask Properties

The FishingTask type exposes the following members.

Properties

Name | Description
IsLaunched | Is fishing.

See Also

FishingTask Class
wManager.Wow.Bot.Tasks Namespace


IsLaunched Property

FishingTask..::..IsLaunched Property

Is fishing.

Namespace: wManager.Wow.Bot.Tasks
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool IsLaunched { get; }
Public Shared ReadOnly Property IsLaunched As Boolean
    Get
public:
static property bool^ IsLaunched {
    bool^ get ();
}

Field Value

true if this instance is launched; otherwise, false.

See Also

FishingTask Class
wManager.Wow.Bot.Tasks Namespace


GoToTask Class

Class GoToTask. Very useful methods to go to a position (methods generate path and manage movement) and/or interact with a WoWItem or WoWGameObject (this class use PathFinder, MovementManager, Interact, ...)

Namespace: wManager.Wow.Bot.Tasks
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class GoToTask
Public NotInheritable Class GoToTask
public ref class GoToTask abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Bot.Tasks..::..GoToTask

See Also

GoToTask Members
wManager.Wow.Bot.Tasks Namespace


GoToTask Members

The GoToTask type exposes the following members.

Methods

Name | Description
ToPosition | Go to position.
ToPositionAndIntecractWith(Npc, Boolean, BooleanDelegate, Boolean) | Go to position and interact with npc (closest to the position, if success the method will select good gossip option depending of Type, for example if it is a repair the bot will choose the gossip option vendor).
ToPositionAndIntecractWith(WoWUnit, Int32, Boolean, BooleanDelegate, Boolean) | Go to position and interact with npc (closest to the position).
ToPositionAndIntecractWith(WoWGameObject, Int32, Boolean, BooleanDelegate) | Go to position and interact with object (closest to the position).
ToPositionAndIntecractWithGameObject | Go to position and interact with object (closest to the position).
ToPositionAndIntecractWithNpc | Go to position and interact with npc (closest to the position).

See Also

GoToTask Class
wManager.Wow.Bot.Tasks Namespace


GoToTask Methods

The GoToTask type exposes the following members.

Methods

Name | Description
ToPosition | Go to position.
ToPositionAndIntecractWith(Npc, Boolean, BooleanDelegate, Boolean) | Go to position and interact with npc (closest to the position, if success the method will select good gossip option depending of Type, for example if it is a repair the bot will choose the gossip option vendor).
ToPositionAndIntecractWith(WoWUnit, Int32, Boolean, BooleanDelegate, Boolean) | Go to position and interact with npc (closest to the position).
ToPositionAndIntecractWith(WoWGameObject, Int32, Boolean, BooleanDelegate) | Go to position and interact with object (closest to the position).
ToPositionAndIntecractWithGameObject | Go to position and interact with object (closest to the position).
ToPositionAndIntecractWithNpc | Go to position and interact with npc (closest to the position).

See Also

GoToTask Class
wManager.Wow.Bot.Tasks Namespace


ToPosition Method

GoToTask..::..ToPosition Method

Go to position.

Namespace: wManager.Wow.Bot.Tasks
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool ToPosition(
    Vector3 position,
    float precision,
    bool skipIfCannotMakePath,
    BooleanDelegate conditionExit
)
Public Shared Function ToPosition ( _
    position As Vector3, _
    precision As Single, _
    skipIfCannotMakePath As Boolean, _
    conditionExit As BooleanDelegate _
) As Boolean
public:
static bool^ ToPosition(
    Vector3^ position,
    float^ precision,
    bool^ skipIfCannotMakePath,
    BooleanDelegate^ conditionExit
)

Parameters

position
Type: robotManager.Helpful..::..Vector3
Destination position.
precision
Type: Single
Precision (of destination position, you can't use less than 3.5).
skipIfCannotMakePath
Type: Boolean
if set to true skip if PathFinder cannot make path (the method return false).
conditionExit
Type: wManager.Wow.Class..::..BooleanDelegate
Exit condition, default code is: context => (Conditions.InGameAndConnectedAndAliveAndProductStartedNotInPause && !Conditions.IsAttackedAndCannotIgnore).

Return Value

true if success, false otherwise.

See Also

GoToTask Class
wManager.Wow.Bot.Tasks Namespace


ToPositionAndIntecractWith Method

GoToTask..::..ToPositionAndIntecractWith Method

Overload List

Name | Description
ToPositionAndIntecractWith(Npc, Boolean, BooleanDelegate, Boolean) | Go to position and interact with npc (closest to the position, if success the method will select good gossip option depending of Type, for example if it is a repair the bot will choose the gossip option vendor).
ToPositionAndIntecractWith(WoWUnit, Int32, Boolean, BooleanDelegate, Boolean) | Go to position and interact with npc (closest to the position).
ToPositionAndIntecractWith(WoWGameObject, Int32, Boolean, BooleanDelegate) | Go to position and interact with object (closest to the position).

See Also

GoToTask Class
GoToTask Members
wManager.Wow.Bot.Tasks Namespace


ToPositionAndIntecractWith Method (Npc, Boolean, BooleanDelegate, Boolean)

GoToTask..::..ToPositionAndIntecractWith Method (Npc, Boolean, BooleanDelegate, Boolean)

Go to position and interact with npc (closest to the position, if success the method will select good gossip option depending of Type, for example if it is a repair the bot will choose the gossip option vendor).

Namespace: wManager.Wow.Bot.Tasks
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool ToPositionAndIntecractWith(
    Npc npc,
    bool skipIfCannotMakePath,
    BooleanDelegate conditionExit,
    bool acceptNpcDead
)
Public Shared Function ToPositionAndIntecractWith ( _
    npc As Npc, _
    skipIfCannotMakePath As Boolean, _
    conditionExit As BooleanDelegate, _
    acceptNpcDead As Boolean _
) As Boolean
public:
static bool^ ToPositionAndIntecractWith(
    Npc^ npc,
    bool^ skipIfCannotMakePath,
    BooleanDelegate^ conditionExit,
    bool^ acceptNpcDead
)

Parameters

npc
Type: wManager.Wow.Class..::..Npc
The NPC.
skipIfCannotMakePath
Type: Boolean
if set to true skip if PathFinder cannot make path (the method return false).
conditionExit
Type: wManager.Wow.Class..::..BooleanDelegate
Exit condition, default code is: context => (Conditions.InGameAndConnectedAndAliveAndProductStartedNotInPause && !Conditions.IsAttackedAndCannotIgnore);.
acceptNpcDead
Type: Boolean
if set to true bot can interact with dead NPC.

Return Value

true if success, false otherwise.

See Also

GoToTask Class
ToPositionAndIntecractWith Overload
wManager.Wow.Bot.Tasks Namespace


ToPositionAndIntecractWith Method (WoWUnit, Int32, Boolean, BooleanDelegate, Boolean)

GoToTask..::..ToPositionAndIntecractWith Method (WoWUnit, Int32, Boolean, BooleanDelegate, Boolean)

Go to position and interact with npc (closest to the position).

Namespace: wManager.Wow.Bot.Tasks
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool ToPositionAndIntecractWith(
    WoWUnit unit,
    int gossipOptions,
    bool skipIfCannotMakePath,
    BooleanDelegate conditionExit,
    bool acceptNpcDead
)
Public Shared Function ToPositionAndIntecractWith ( _
    unit As WoWUnit, _
    gossipOptions As Integer, _
    skipIfCannotMakePath As Boolean, _
    conditionExit As BooleanDelegate, _
    acceptNpcDead As Boolean _
) As Boolean
public:
static bool^ ToPositionAndIntecractWith(
    WoWUnit^ unit,
    int^ gossipOptions,
    bool^ skipIfCannotMakePath,
    BooleanDelegate^ conditionExit,
    bool^ acceptNpcDead
)

Parameters

unit
Type: wManager.Wow.ObjectManager..::..WoWUnit
The unit.
gossipOptions
Type: Int32
Selects a gossip (conversation) option (in game). (-1 to don't use this option).
skipIfCannotMakePath
Type: Boolean
if set to true skip if PathFinder cannot make path (the method return false).
conditionExit
Type: wManager.Wow.Class..::..BooleanDelegate
Exit condition, default code is: context => (Conditions.InGameAndConnectedAndAliveAndProductStartedNotInPause && !Conditions.IsAttackedAndCannotIgnore);.
acceptNpcDead
Type: Boolean
if set to true bot can interact with dead NPC.

Return Value

true if success, false otherwise.

See Also

GoToTask Class
ToPositionAndIntecractWith Overload
wManager.Wow.Bot.Tasks Namespace


ToPositionAndIntecractWith Method (WoWGameObject, Int32, Boolean, BooleanDelegate)

GoToTask..::..ToPositionAndIntecractWith Method (WoWGameObject, Int32, Boolean, BooleanDelegate)

Go to position and interact with object (closest to the position).

Namespace: wManager.Wow.Bot.Tasks
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool ToPositionAndIntecractWith(
    WoWGameObject gameObject,
    int gossipOptions,
    bool skipIfCannotMakePath,
    BooleanDelegate conditionExit
)
Public Shared Function ToPositionAndIntecractWith ( _
    gameObject As WoWGameObject, _
    gossipOptions As Integer, _
    skipIfCannotMakePath As Boolean, _
    conditionExit As BooleanDelegate _
) As Boolean
public:
static bool^ ToPositionAndIntecractWith(
    WoWGameObject^ gameObject,
    int^ gossipOptions,
    bool^ skipIfCannotMakePath,
    BooleanDelegate^ conditionExit
)

Parameters

gameObject
Type: wManager.Wow.ObjectManager..::..WoWGameObject
The game object.
gossipOptions
Type: Int32
Selects a gossip (conversation) option (in game). (-1 to don't use this option).
skipIfCannotMakePath
Type: Boolean
if set to true skip if PathFinder cannot make path (the method return false).
conditionExit
Type: wManager.Wow.Class..::..BooleanDelegate
Exit condition, default code is: context => (Conditions.InGameAndConnectedAndAliveAndProductStartedNotInPause && !Conditions.IsAttackedAndCannotIgnore);.

Return Value

true if success, false otherwise.

See Also

GoToTask Class
ToPositionAndIntecractWith Overload
wManager.Wow.Bot.Tasks Namespace


ToPositionAndIntecractWithGameObject Method

GoToTask..::..ToPositionAndIntecractWithGameObject Method

Go to position and interact with object (closest to the position).

Namespace: wManager.Wow.Bot.Tasks
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool ToPositionAndIntecractWithGameObject(
    Vector3 positionObj,
    int objEntry,
    int gossipOptions,
    bool skipIfCannotMakePath,
    BooleanDelegate conditionExit
)
Public Shared Function ToPositionAndIntecractWithGameObject ( _
    positionObj As Vector3, _
    objEntry As Integer, _
    gossipOptions As Integer, _
    skipIfCannotMakePath As Boolean, _
    conditionExit As BooleanDelegate _
) As Boolean
public:
static bool^ ToPositionAndIntecractWithGameObject(
    Vector3^ positionObj,
    int^ objEntry,
    int^ gossipOptions,
    bool^ skipIfCannotMakePath,
    BooleanDelegate^ conditionExit
)

Parameters

positionObj
Type: robotManager.Helpful..::..Vector3
Destination position.
objEntry
Type: Int32
The Entry.
gossipOptions
Type: Int32
Selects a gossip (conversation) option (in game). (-1 to don't use this option).
skipIfCannotMakePath
Type: Boolean
if set to true skip if PathFinder cannot make path (the method return false).
conditionExit
Type: wManager.Wow.Class..::..BooleanDelegate
Exit condition, default code is: context => (Conditions.InGameAndConnectedAndAliveAndProductStartedNotInPause && !Conditions.IsAttackedAndCannotIgnore);.

Return Value

true if success, false otherwise.

See Also

GoToTask Class
wManager.Wow.Bot.Tasks Namespace


ToPositionAndIntecractWithNpc Method

GoToTask..::..ToPositionAndIntecractWithNpc Method

Go to position and interact with npc (closest to the position).

Namespace: wManager.Wow.Bot.Tasks
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool ToPositionAndIntecractWithNpc(
    Vector3 positionNpc,
    int npcEntry,
    int gossipOptions,
    bool skipIfCannotMakePath,
    BooleanDelegate conditionExit,
    bool acceptNpcDead
)
Public Shared Function ToPositionAndIntecractWithNpc ( _
    positionNpc As Vector3, _
    npcEntry As Integer, _
    gossipOptions As Integer, _
    skipIfCannotMakePath As Boolean, _
    conditionExit As BooleanDelegate, _
    acceptNpcDead As Boolean _
) As Boolean
public:
static bool^ ToPositionAndIntecractWithNpc(
    Vector3^ positionNpc,
    int^ npcEntry,
    int^ gossipOptions,
    bool^ skipIfCannotMakePath,
    BooleanDelegate^ conditionExit,
    bool^ acceptNpcDead
)

Parameters

positionNpc
Type: robotManager.Helpful..::..Vector3
Destination position.
npcEntry
Type: Int32
NPC Entry
gossipOptions
Type: Int32
Selects a gossip (conversation) option (in game). (-1 to don't use this option).
skipIfCannotMakePath
Type: Boolean
if set to true skip if PathFinder cannot make path (the method return false).
conditionExit
Type: wManager.Wow.Class..::..BooleanDelegate
Exit condition, default code is: context => (Conditions.InGameAndConnectedAndAliveAndProductStartedNotInPause && !Conditions.IsAttackedAndCannotIgnore);.
acceptNpcDead
Type: Boolean
if set to true bot can interact with dead NPC.

Return Value

true if success, false otherwise.

See Also

GoToTask Class
wManager.Wow.Bot.Tasks Namespace


LootingTask Class

Class LootingTask. Looting WowUnits

Namespace: wManager.Wow.Bot.Tasks
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class LootingTask
Public NotInheritable Class LootingTask
public ref class LootingTask abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Bot.Tasks..::..LootingTask

See Also

LootingTask Members
wManager.Wow.Bot.Tasks Namespace


LootingTask Members

The LootingTask type exposes the following members.

Methods

Name | Description
Pulse | Looting specified WoWUnits

See Also

LootingTask Class
wManager.Wow.Bot.Tasks Namespace


LootingTask Methods

The LootingTask type exposes the following members.

Methods

Name | Description
Pulse | Looting specified WoWUnits

See Also

LootingTask Class
wManager.Wow.Bot.Tasks Namespace


Pulse Method

LootingTask..::..Pulse Method

Looting specified WoWUnits

Namespace: wManager.Wow.Bot.Tasks
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void Pulse(
    List<WoWUnit> woWUnits
)
Public Shared Sub Pulse ( _
    woWUnits As List(Of WoWUnit) _
)
public:
static void Pulse(
    List<WoWUnit^>^ woWUnits
)

Parameters

woWUnits
Type: List <(Of <(<' WoWUnit >)>)>
The wo w units.

See Also

LootingTask Class
wManager.Wow.Bot.Tasks Namespace


MountTask Class

Class MountTask, methods to mount/dismount.

Namespace: wManager.Wow.Bot.Tasks
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class MountTask
Public NotInheritable Class MountTask
public ref class MountTask abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Bot.Tasks..::..MountTask

See Also

MountTask Members
wManager.Wow.Bot.Tasks Namespace


MountTask Members

The MountTask type exposes the following members.

Methods

Name | Description
DismountMount | Dismounts the mount.
GetMountCapacity | Get the mount capacity (depending of bot configurations and in-game status).
Land | Landing (if flying)
Mount(Boolean, MountTask..::..MountCapacity) | Use mount
Mount(Boolean, Boolean, MountTask..::..MountCapacity) | Use mount
MountExist | Mounts the exist (depending of bot configurations and in-game status).
MountingAquaticMount | Mounting the aquatic mount.
MountingFlyingMount | Mounting the flying mount.
MountingGroundMount | Mounting the ground mount.
OnAquaticMount | Check if on aquatic mount (mount selected in AquaticMountName).
OnFlyMount | Check if on flying mount (mount selected in FlyingMountName).
OnGroundMount | Check if on ground mount (mount selected in GroundMountName).
Takeof | Take off ground (jump, stop when character is flying or after 700 ms)
WaterSurface | Go to waters surface.

See Also

MountTask Class
wManager.Wow.Bot.Tasks Namespace


MountTask Methods

The MountTask type exposes the following members.

Methods

Name | Description
DismountMount | Dismounts the mount.
GetMountCapacity | Get the mount capacity (depending of bot configurations and in-game status).
Land | Landing (if flying)
Mount(Boolean, MountTask..::..MountCapacity) | Use mount
Mount(Boolean, Boolean, MountTask..::..MountCapacity) | Use mount
MountExist | Mounts the exist (depending of bot configurations and in-game status).
MountingAquaticMount | Mounting the aquatic mount.
MountingFlyingMount | Mounting the flying mount.
MountingGroundMount | Mounting the ground mount.
OnAquaticMount | Check if on aquatic mount (mount selected in AquaticMountName).
OnFlyMount | Check if on flying mount (mount selected in FlyingMountName).
OnGroundMount | Check if on ground mount (mount selected in GroundMountName).
Takeof | Take off ground (jump, stop when character is flying or after 700 ms)
WaterSurface | Go to waters surface.

See Also

MountTask Class
wManager.Wow.Bot.Tasks Namespace


DismountMount Method

MountTask..::..DismountMount Method

Dismounts the mount.

Namespace: wManager.Wow.Bot.Tasks
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void DismountMount(
    bool stopMove,
    bool stand,
    int wait
)
Public Shared Sub DismountMount ( _
    stopMove As Boolean, _
    stand As Boolean, _
    wait As Integer _
)
public:
static void DismountMount(
    bool^ stopMove,
    bool^ stand,
    int^ wait
)

Parameters

stopMove
Type: Boolean
if set to true stop move.
stand
Type: Boolean
if set to true landing (if flying).
wait
Type: Int32
wait time after dismount (in milliseconds).

See Also

MountTask Class
wManager.Wow.Bot.Tasks Namespace


GetMountCapacity Method

MountTask..::..GetMountCapacity Method

Get the mount capacity (depending of bot configurations and in-game status).

Namespace: wManager.Wow.Bot.Tasks
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static MountTask..::..MountCapacity GetMountCapacity()
Public Shared Function GetMountCapacity As MountTask..::..MountCapacity
public:
static MountTask..::..MountCapacity^ GetMountCapacity()

Return Value

Mount capacity.

See Also

MountTask Class
wManager.Wow.Bot.Tasks Namespace


Land Method

MountTask..::..Land Method

Landing (if flying)

Namespace: wManager.Wow.Bot.Tasks
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void Land(
    float zMin,
    float distGround
)
Public Shared Sub Land ( _
    zMin As Single, _
    distGround As Single _
)
public:
static void Land(
    float^ zMin,
    float^ distGround
)

Parameters

zMin
Type: Single
Character minimum Z position (float.MinValue by default).
distGround
Type: Single
Ground distance (0 to land on the ground).

See Also

MountTask Class
wManager.Wow.Bot.Tasks Namespace


Mount Method

MountTask..::..Mount Method

Overload List

Name | Description
Mount(Boolean, MountTask..::..MountCapacity) | Use mount
Mount(Boolean, Boolean, MountTask..::..MountCapacity) | Use mount

See Also

MountTask Class
MountTask Members
wManager.Wow.Bot.Tasks Namespace


Mount Method (Boolean, MountCapacity)

MountTask..::..Mount Method (Boolean, MountCapacity)

Use mount

Namespace: wManager.Wow.Bot.Tasks
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void Mount(
    bool stopMove,
    MountTask..::..MountCapacity mountCapacity
)
Public Shared Sub Mount ( _
    stopMove As Boolean, _
    mountCapacity As MountTask..::..MountCapacity _
)
public:
static void Mount(
    bool^ stopMove,
    MountTask..::..MountCapacity^ mountCapacity
)

Parameters

stopMove
Type: Boolean
if set to true stop move to mount mount.
mountCapacity
Type: wManager.Wow.Bot.Tasks..::..MountTask..::..MountCapacity
The mount capacity to mount.

See Also

MountTask Class
Mount Overload
wManager.Wow.Bot.Tasks Namespace


Mount Method (Boolean, Boolean, MountCapacity)

MountTask..::..Mount Method (Boolean, Boolean, MountCapacity)

Use mount

Namespace: wManager.Wow.Bot.Tasks
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void Mount(
    bool stopMove,
    bool launchUnstuckIfFail,
    MountTask..::..MountCapacity mountCapacity
)
Public Shared Sub Mount ( _
    stopMove As Boolean, _
    launchUnstuckIfFail As Boolean, _
    mountCapacity As MountTask..::..MountCapacity _
)
public:
static void Mount(
    bool^ stopMove,
    bool^ launchUnstuckIfFail,
    MountTask..::..MountCapacity^ mountCapacity
)

Parameters

stopMove
Type: Boolean
if set to true stop move to mount mount.
launchUnstuckIfFail
Type: Boolean
if set to true call UnStuck()()()() if mounting fail.
mountCapacity
Type: wManager.Wow.Bot.Tasks..::..MountTask..::..MountCapacity
The mount capacity to mount.

See Also

MountTask Class
Mount Overload
wManager.Wow.Bot.Tasks Namespace


MountExist Method

MountTask..::..MountExist Method

Mounts the exist (depending of bot configurations and in-game status).

Namespace: wManager.Wow.Bot.Tasks
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool MountExist(
    MountTask..::..MountCapacity mountCapacity
)
Public Shared Function MountExist ( _
    mountCapacity As MountTask..::..MountCapacity _
) As Boolean
public:
static bool^ MountExist(
    MountTask..::..MountCapacity^ mountCapacity
)

Parameters

mountCapacity
Type: wManager.Wow.Bot.Tasks..::..MountTask..::..MountCapacity
The mount capacity.

Return Value

true if exist, false otherwise.

See Also

MountTask Class
wManager.Wow.Bot.Tasks Namespace


MountingAquaticMount Method

MountTask..::..MountingAquaticMount Method

Mounting the aquatic mount.

Namespace: wManager.Wow.Bot.Tasks
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void MountingAquaticMount(
    bool stopMove,
    bool launchUnstuckIfFail
)
Public Shared Sub MountingAquaticMount ( _
    stopMove As Boolean, _
    launchUnstuckIfFail As Boolean _
)
public:
static void MountingAquaticMount(
    bool^ stopMove,
    bool^ launchUnstuckIfFail
)

Parameters

stopMove
Type: Boolean
if set to true stop move to mount mount.
launchUnstuckIfFail
Type: Boolean
if set to true call UnStuck()()()() if mounting fail.

See Also

MountTask Class
wManager.Wow.Bot.Tasks Namespace


MountingFlyingMount Method

MountTask..::..MountingFlyingMount Method

Mounting the flying mount.

Namespace: wManager.Wow.Bot.Tasks
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void MountingFlyingMount(
    bool stopMove,
    bool launchUnstuckIfFail
)
Public Shared Sub MountingFlyingMount ( _
    stopMove As Boolean, _
    launchUnstuckIfFail As Boolean _
)
public:
static void MountingFlyingMount(
    bool^ stopMove,
    bool^ launchUnstuckIfFail
)

Parameters

stopMove
Type: Boolean
if set to true stop move to mount mount.
launchUnstuckIfFail
Type: Boolean
if set to true call UnStuck()()()() if mounting fail.

See Also

MountTask Class
wManager.Wow.Bot.Tasks Namespace


MountingGroundMount Method

MountTask..::..MountingGroundMount Method

Mounting the ground mount.

Namespace: wManager.Wow.Bot.Tasks
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void MountingGroundMount(
    bool stopMove,
    bool launchUnstuckIfFail
)
Public Shared Sub MountingGroundMount ( _
    stopMove As Boolean, _
    launchUnstuckIfFail As Boolean _
)
public:
static void MountingGroundMount(
    bool^ stopMove,
    bool^ launchUnstuckIfFail
)

Parameters

stopMove
Type: Boolean
if set to true stop move to mount mount.
launchUnstuckIfFail
Type: Boolean
if set to true call UnStuck()()()() if mounting fail.

See Also

MountTask Class
wManager.Wow.Bot.Tasks Namespace


OnAquaticMount Method

MountTask..::..OnAquaticMount Method

Check if on aquatic mount (mount selected in AquaticMountName).

Namespace: wManager.Wow.Bot.Tasks
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool OnAquaticMount()
Public Shared Function OnAquaticMount As Boolean
public:
static bool^ OnAquaticMount()

Return Value

true if on aquatic mount, false otherwise.

See Also

MountTask Class
wManager.Wow.Bot.Tasks Namespace


OnFlyMount Method

MountTask..::..OnFlyMount Method

Check if on flying mount (mount selected in FlyingMountName).

Namespace: wManager.Wow.Bot.Tasks
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool OnFlyMount()
Public Shared Function OnFlyMount As Boolean
public:
static bool^ OnFlyMount()

Return Value

true if on flying mount, false otherwise.

See Also

MountTask Class
wManager.Wow.Bot.Tasks Namespace


OnGroundMount Method

MountTask..::..OnGroundMount Method

Check if on ground mount (mount selected in GroundMountName).

Namespace: wManager.Wow.Bot.Tasks
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool OnGroundMount()
Public Shared Function OnGroundMount As Boolean
public:
static bool^ OnGroundMount()

Return Value

true if on ground mount, false otherwise.

See Also

MountTask Class
wManager.Wow.Bot.Tasks Namespace


Takeof Method

MountTask..::..Takeof Method

Take off ground (jump, stop when character is flying or after 700 ms)

Namespace: wManager.Wow.Bot.Tasks
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void Takeof()
Public Shared Sub Takeof
public:
static void Takeof()

See Also

MountTask Class
wManager.Wow.Bot.Tasks Namespace


WaterSurface Method

MountTask..::..WaterSurface Method

Go to waters surface.

Namespace: wManager.Wow.Bot.Tasks
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void WaterSurface()
Public Shared Sub WaterSurface
public:
static void WaterSurface()

See Also

MountTask Class
wManager.Wow.Bot.Tasks Namespace


MountTask.MountCapacity Enumeration

MountTask..::..MountCapacity Enumeration

Mount capacity

Namespace: wManager.Wow.Bot.Tasks
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public enum MountCapacity
Public Enumeration MountCapacity
public enum class MountCapacity

Members

Member name | Description
Feet |
Ground |
Swimm |
Fly |

See Also

wManager.Wow.Bot.Tasks Namespace


wManager.Wow.Class Namespace

Classes

 | Class | Description
Public class | Aura | Class Aura, for debuff/buff
Public class | Blackspot | Class Blackspot used by product quester (do not confuse with Blackspots).
Public class | Buy | Class Buy. BuyList (BuyWindow) and used by ToTown
Public class | CompanionInfo | Class CompanionInfo. https://wow.gamepedia.com/API_GetCompanionInfo , used in some bot versions by GetCompanionInfo()()()()
Public class | DBCStruct |
Public class | Digsite | Class Digsite.
Public class | EntryIndexQuest | Class EntryIndexQuest. Used by QuestGrinderGathererClass
Public class | ItemInfo | Item Information Class, based on https://wow.gamepedia.com/API_GetItemInfo (can change in some bot versions)
Public class | Npc | Class Npc, used by NpcDB.
Public class | NPCQuest | Class NPCQuest. NPCs (or object) who give and complete quests
Public class | QuestClass | Class QuestClass.
Public class | QuestEmptyClass | Class QuestEmptyClass. This class cannot be inherited. Implements the QuestClass
Public class | QuestFollowNpcClass | Class QuestFollowNpcClass. Override this class when you need follow Npc. Implements the QuestClass
Public class | QuestFollowPathClass | Class QuestFollowPathClass. Override this class when you need to use a precise path or when quest objectives is to go to specific position. Implements the QuestClass
Public class | QuestGathererClass | Class QuestGathererClass. Override this class when quest objectives is to harvest objects. Implements the QuestClass
Public class | QuestGrinderClass | Class QuestGrinderClass. Override this class when quest objectives is to kills mobs. Implements the QuestClass
Public class | QuestGrinderGathererClass | Class QuestGrinderGathererClass. Override this class when quest objectives is to kills mobs and harvest objects. Implements the QuestClass
Public class | QuestInteractWithClass | Class QuestInteractWithClass. Override this class when quest objectives is to interact with WoWUnit, WoWGameObject. Implements the QuestClass
Public class | QuestParallelQuestsClass | Class QuestParallelQuestsClass. Override this class if you want do several quest at same time. Implements the QuestClass
Public class | QuestsSorted | Class QuestsSorted, quest profile step.
Public class | QuestUseItemOnClass | Class QuestUseItemOnClass. Override this class when quest objectives is to use item on WoWUnit, WoWGameObject or at specific position. Implements the QuestClass
Public class | QuestUseScriptOnClass | Class QuestUseScriptOnClass. Override this class when quest objectives is to use the script on WoWUnit, WoWGameObject or at specific position. Implements the QuestClass
Public class | QuestUseSpellOnClass | Class QuestUseSpellOnClass. Override this class when quest objectives is to use spell on WoWUnit, WoWGameObject or at specific position. Implements the QuestClass
Public class | RuneStruct | Class RuneStruct.
Public class | Spell | Class Spell. Convenient to manage a spell easily.
Public class | SpellInfo | Class SpellInfo.
Public class | TaxiNode | Class TaxiNode.

Structures

 | Structure | Description
Public structure | DBCStruct..::..WoWClientDB |

Delegates

 | Delegate | Description
Public delegate | BooleanDelegate | Delegate BooleanDelegate, used in SpellState and GoToTask

Enumerations

 | Enumeration | Description
Public enumeration | Npc..::..FactionType | Faction type
Public enumeration | Npc..::..NpcType | Npc type
Public enumeration | Npc..::..NpcVendorItemClass | Npc vendor item class
Public enumeration | QuestAction | Quest step action type (QuestsSorted)


Aura Class

Class Aura, for debuff/buff

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class Aura
Public Class Aura
public ref class Aura

Inheritance Hierarchy

Object
wManager.Wow.Class..::..Aura

See Also

Aura Members
wManager.Wow.Class Namespace


Aura Members

The Aura type exposes the following members.

Constructors

 | Name | Description
Public method | Aura()()()() | Initializes a new instance of the Aura class.
Public method | Aura(UInt32, UInt32) | Initializes a new instance of the Aura class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IsValid | Returns true if is valid.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance.

Fields

 | Name | Description
Public field | _timeEnd | The end time

Properties

 | Name | Description
Public property | GetSpell | Gets the spell.
Public property | Owner | Gets the owner.
Public property | SpellId | Gets the spell id.
Public property | Stack | Gets the stack.
Public property | TimeEnd | Gets the end time.
Public property | TimeLeft | Gets the time left in milliseconds.
Public property | TimeLeftSeconde | Gets the time left in seconds.

See Also

Aura Class
wManager.Wow.Class Namespace


Aura Constructor

Overload List

 | Name | Description
Public method | Aura()()()() | Initializes a new instance of the Aura class.
Public method | Aura(UInt32, UInt32) | Initializes a new instance of the Aura class.

See Also

Aura Class
Aura Members
wManager.Wow.Class Namespace


Aura Constructor

Initializes a new instance of the Aura class.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Aura()
Public Sub New
public:
Aura()

See Also

Aura Class
Aura Overload
wManager.Wow.Class Namespace


Aura Constructor (UInt32, UInt32)

Initializes a new instance of the Aura class.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Aura(
    uint baseAddress,
    uint spellId
)
Public Sub New ( _
    baseAddress As UInteger, _
    spellId As UInteger _
)
public:
Aura(
    unsigned int^ baseAddress,
    unsigned int^ spellId
)

Parameters

baseAddress
Type: UInt32
The aura base address.
spellId
Type: UInt32
The spell id.

See Also

Aura Class
Aura Overload
wManager.Wow.Class Namespace


Aura Fields

The Aura type exposes the following members.

Fields

 | Name | Description
Public field | _timeEnd | The end time

See Also

Aura Class
wManager.Wow.Class Namespace


_timeEnd Field

Aura..::.._timeEnd Field

The end time

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int _timeEnd
Public _timeEnd As Integer
public:
int^ _timeEnd

See Also

Aura Class
wManager.Wow.Class Namespace


Aura Methods

The Aura type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IsValid | Returns true if is valid.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance.

See Also

Aura Class
wManager.Wow.Class Namespace


IsValid Method

Aura..::..IsValid Method

Returns true if is valid.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsValid()
Public Function IsValid As Boolean
public:
bool^ IsValid()

Return Value

true if this instance is valid; otherwise, false.

See Also

Aura Class
wManager.Wow.Class Namespace


ToString Method

Aura..::..ToString Method

Returns a String that represents this instance.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string ToString()
Public Function ToString As String
public:
String^ ToString()

Return Value

A String that represents this instance.

See Also

Aura Class
wManager.Wow.Class Namespace


Aura Properties

The Aura type exposes the following members.

Properties

 | Name | Description
Public property | GetSpell | Gets the spell.
Public property | Owner | Gets the owner.
Public property | SpellId | Gets the spell id.
Public property | Stack | Gets the stack.
Public property | TimeEnd | Gets the end time.
Public property | TimeLeft | Gets the time left in milliseconds.
Public property | TimeLeftSeconde | Gets the time left in seconds.

See Also

Aura Class
wManager.Wow.Class Namespace


GetSpell Property

Aura..::..GetSpell Property

Gets the spell.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Spell GetSpell { get; }
Public ReadOnly Property GetSpell As Spell
    Get
public:
property Spell^ GetSpell {
    Spell^ get ();
}

Field Value

The spell.

See Also

Aura Class
wManager.Wow.Class Namespace


Owner Property

Aura..::..Owner Property

Gets the owner.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public ulong Owner { get; }
Public ReadOnly Property Owner As ULong
    Get
public:
property unsigned long long^ Owner {
    unsigned long long^ get ();
}

Field Value

The owner.

See Also

Aura Class
wManager.Wow.Class Namespace


SpellId Property

Aura..::..SpellId Property

Gets the spell id.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint SpellId { get; }
Public ReadOnly Property SpellId As UInteger
    Get
public:
property unsigned int^ SpellId {
    unsigned int^ get ();
}

Field Value

The spell id.

See Also

Aura Class
wManager.Wow.Class Namespace


Stack Property

Aura..::..Stack Property

Gets the stack.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int Stack { get; }
Public ReadOnly Property Stack As Integer
    Get
public:
property int^ Stack {
    int^ get ();
}

Field Value

The stack.

See Also

Aura Class
wManager.Wow.Class Namespace


TimeEnd Property

Aura..::..TimeEnd Property

Gets the end time.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int TimeEnd { get; }
Public ReadOnly Property TimeEnd As Integer
    Get
public:
property int^ TimeEnd {
    int^ get ();
}

Field Value

The end time.

See Also

Aura Class
wManager.Wow.Class Namespace


TimeLeft Property

Aura..::..TimeLeft Property

Gets the time left in milliseconds.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int TimeLeft { get; }
Public ReadOnly Property TimeLeft As Integer
    Get
public:
property int^ TimeLeft {
    int^ get ();
}

Field Value

The time left in milliseconds.

See Also

Aura Class
wManager.Wow.Class Namespace


TimeLeftSeconde Property

Aura..::..TimeLeftSeconde Property

Gets the time left in seconds.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public double TimeLeftSeconde { get; }
Public ReadOnly Property TimeLeftSeconde As Double
    Get
public:
property double^ TimeLeftSeconde {
    double^ get ();
}

Field Value

The time left in seconds.

See Also

Aura Class
wManager.Wow.Class Namespace


Blackspot Class

Class Blackspot used by product quester (do not confuse with Blackspots).

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class Blackspot
<SerializableAttribute> _
Public Class Blackspot
[SerializableAttribute]
public ref class Blackspot

Inheritance Hierarchy

Object
wManager.Wow.Class..::..Blackspot

See Also

Blackspot Members
wManager.Wow.Class Namespace


Blackspot Members

The Blackspot type exposes the following members.

Constructors

 | Name | Description
Public method | Blackspot | Initializes a new instance of the Blackspot class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToBlackspot | Converts to blackspot.
Public method | ToString | Returns a String that represents this instance.

Properties

 | Name | Description
Public property | Comment | Gets or sets comment.
Public property | Continent | Gets or sets the continent id.
Public property | Radius | The height.
Public property | TypeArea | Gets or sets the type area (used by PathFinder).
Public property | X | Gets or sets the x.
Public property | Y | Gets or sets the y.
Public property | Z | Gets or sets the z.

See Also

Blackspot Class
wManager.Wow.Class Namespace


Blackspot Constructor

Initializes a new instance of the Blackspot class.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Blackspot()
Public Sub New
public:
Blackspot()

See Also

Blackspot Class
wManager.Wow.Class Namespace


Blackspot Methods

The Blackspot type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToBlackspot | Converts to blackspot.
Public method | ToString | Returns a String that represents this instance.

See Also

Blackspot Class
wManager.Wow.Class Namespace


ToBlackspot Method

Blackspot..::..ToBlackspot Method

Converts to blackspot.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public BlackListSerializable..::..Blackspot ToBlackspot()
Public Function ToBlackspot As BlackListSerializable..::..Blackspot
public:
BlackListSerializable..::..Blackspot^ ToBlackspot()

Return Value

BlackListSerializable.Blackspot.

See Also

Blackspot Class
wManager.Wow.Class Namespace


ToString Method

Blackspot..::..ToString Method

Returns a String that represents this instance.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string ToString()
Public Function ToString As String
public:
String^ ToString()

Return Value

A String that represents this instance.

See Also

Blackspot Class
wManager.Wow.Class Namespace


Blackspot Properties

The Blackspot type exposes the following members.

Properties

 | Name | Description
Public property | Comment | Gets or sets comment.
Public property | Continent | Gets or sets the continent id.
Public property | Radius | The height.
Public property | TypeArea | Gets or sets the type area (used by PathFinder).
Public property | X | Gets or sets the x.
Public property | Y | Gets or sets the y.
Public property | Z | Gets or sets the z.

See Also

Blackspot Class
wManager.Wow.Class Namespace


Comment Property

Blackspot..::..Comment Property

Gets or sets comment.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string Comment { get; set; }
Public Property Comment As String
    Get
    Set
public:
property String^ Comment {
    String^ get ();
    void set (String^ value);
}

Field Value

The comment.

See Also

Blackspot Class
wManager.Wow.Class Namespace


Continent Property

Blackspot..::..Continent Property

Gets or sets the continent id.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public ContinentId Continent { get; set; }
Public Property Continent As ContinentId
    Get
    Set
public:
property ContinentId^ Continent {
    ContinentId^ get ();
    void set (ContinentId^ value);
}

Field Value

The continent.

See Also

Blackspot Class
wManager.Wow.Class Namespace


Radius Property

Blackspot..::..Radius Property

The height.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float Radius { get; set; }
Public Property Radius As Single
    Get
    Set
public:
property float^ Radius {
    float^ get ();
    void set (float^ value);
}

Field Value

The radius.

See Also

Blackspot Class
wManager.Wow.Class Namespace


TypeArea Property

Blackspot..::..TypeArea Property

Gets or sets the type area (used by PathFinder).

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public PolyArea TypeArea { get; set; }
Public Property TypeArea As PolyArea
    Get
    Set
public:
property PolyArea^ TypeArea {
    PolyArea^ get ();
    void set (PolyArea^ value);
}

Field Value

The type area.

See Also

Blackspot Class
wManager.Wow.Class Namespace


X Property

Blackspot..::..X Property

Gets or sets the x.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float X { get; set; }
Public Property X As Single
    Get
    Set
public:
property float^ X {
    float^ get ();
    void set (float^ value);
}

Field Value

The x.

See Also

Blackspot Class
wManager.Wow.Class Namespace


Y Property

Blackspot..::..Y Property

Gets or sets the y.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float Y { get; set; }
Public Property Y As Single
    Get
    Set
public:
property float^ Y {
    float^ get ();
    void set (float^ value);
}

Field Value

The y.

See Also

Blackspot Class
wManager.Wow.Class Namespace


Z Property

Blackspot..::..Z Property

Gets or sets the z.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float Z { get; set; }
Public Property Z As Single
    Get
    Set
public:
property float^ Z {
    float^ get ();
    void set (float^ value);
}

Field Value

The z.

See Also

Blackspot Class
wManager.Wow.Class Namespace


BooleanDelegate Delegate

Delegate BooleanDelegate, used in SpellState and GoToTask

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public delegate bool BooleanDelegate(
    Object context
)
Public Delegate Function BooleanDelegate ( _
    context As Object _
) As Boolean
public delegate bool^ BooleanDelegate(
    Object^ context
)

Parameters

context
Type: Object
The context.

Return Value

true if true, false otherwise.

See Also

wManager.Wow.Class Namespace


Buy Class

Class Buy. BuyList (BuyWindow) and used by ToTown

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class Buy
<SerializableAttribute> _
Public Class Buy
[SerializableAttribute]
public ref class Buy

Inheritance Hierarchy

Object
wManager.Wow.Class..::..Buy

See Also

Buy Members
wManager.Wow.Class Namespace


Buy Members

The Buy type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | ForceGoToVendorNow | Need go to vendor now (GoToVendorIfQuantityLessOrEqual).
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IsValid | Returns true if the configurations of buy is valid.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | NeedToBuy | Needs to buy.
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | GoToVendorIfQuantityLessOrEqual | Force to go to vendor if value is bigger or equal than 0 (-1 to disable)
Public property | ItemName | Gets or sets the name of the item (like is appear in game).
Public property | Quantity | Quantity to buy.
Public property | ScriptCanCondition | Script can condition (code like return wManager.Wow.ObjectManager.ObjectManager.Me.Level > 10;, default language is C#, start by lua: or luabot: or vb: to change script language).
Public property | VendorItemClass | Gets or sets the vendor item class.

See Also

Buy Class
wManager.Wow.Class Namespace


Buy Methods

The Buy type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | ForceGoToVendorNow | Need go to vendor now (GoToVendorIfQuantityLessOrEqual).
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IsValid | Returns true if the configurations of buy is valid.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | NeedToBuy | Needs to buy.
Public method | ToString | (Inherited from Object.)

See Also

Buy Class
wManager.Wow.Class Namespace


ForceGoToVendorNow Method

Buy..::..ForceGoToVendorNow Method

Need go to vendor now (GoToVendorIfQuantityLessOrEqual).

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool ForceGoToVendorNow()
Public Function ForceGoToVendorNow As Boolean
public:
bool^ ForceGoToVendorNow()

Return Value

true if need to go to vendor now (GoToVendorIfQuantityLessOrEqual), false otherwise.

See Also

Buy Class
wManager.Wow.Class Namespace


IsValid Method

Buy..::..IsValid Method

Returns true if the configurations of buy is valid.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsValid()
Public Function IsValid As Boolean
public:
bool^ IsValid()

Return Value

true if this instance configurations is valid; otherwise, false.

See Also

Buy Class
wManager.Wow.Class Namespace


NeedToBuy Method

Buy..::..NeedToBuy Method

Needs to buy.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool NeedToBuy()
Public Function NeedToBuy As Boolean
public:
bool^ NeedToBuy()

Return Value

true if need to buy, false otherwise.

See Also

Buy Class
wManager.Wow.Class Namespace


Buy Properties

The Buy type exposes the following members.

Properties

 | Name | Description
Public property | GoToVendorIfQuantityLessOrEqual | Force to go to vendor if value is bigger or equal than 0 (-1 to disable)
Public property | ItemName | Gets or sets the name of the item (like is appear in game).
Public property | Quantity | Quantity to buy.
Public property | ScriptCanCondition | Script can condition (code like return wManager.Wow.ObjectManager.ObjectManager.Me.Level > 10;, default language is C#, start by lua: or luabot: or vb: to change script language).
Public property | VendorItemClass | Gets or sets the vendor item class.

See Also

Buy Class
wManager.Wow.Class Namespace


GoToVendorIfQuantityLessOrEqual Property

Buy..::..GoToVendorIfQuantityLessOrEqual Property

Force to go to vendor if value is bigger or equal than 0 (-1 to disable)

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int GoToVendorIfQuantityLessOrEqual { get; set; }
Public Property GoToVendorIfQuantityLessOrEqual As Integer
    Get
    Set
public:
property int^ GoToVendorIfQuantityLessOrEqual {
    int^ get ();
    void set (int^ value);
}

Field Value

The go to vendor quantity less or equal.

See Also

Buy Class
wManager.Wow.Class Namespace


ItemName Property

Buy..::..ItemName Property

Gets or sets the name of the item (like is appear in game).

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string ItemName { get; set; }
Public Property ItemName As String
    Get
    Set
public:
property String^ ItemName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the item.

See Also

Buy Class
wManager.Wow.Class Namespace


Quantity Property

Buy..::..Quantity Property

Quantity to buy.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int Quantity { get; set; }
Public Property Quantity As Integer
    Get
    Set
public:
property int^ Quantity {
    int^ get ();
    void set (int^ value);
}

Field Value

The quantity.

See Also

Buy Class
wManager.Wow.Class Namespace


ScriptCanCondition Property

Buy..::..ScriptCanCondition Property

Script can condition (code like return wManager.Wow.ObjectManager.ObjectManager.Me.Level > 10;, default language is C#, start by lua: or luabot: or vb: to change script language).

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string ScriptCanCondition { get; set; }
Public Property ScriptCanCondition As String
    Get
    Set
public:
property String^ ScriptCanCondition {
    String^ get ();
    void set (String^ value);
}

Field Value

The script can condition.

See Also

Buy Class
wManager.Wow.Class Namespace


VendorItemClass Property

Buy..::..VendorItemClass Property

Gets or sets the vendor item class.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Npc..::..NpcVendorItemClass VendorItemClass { get; set; }
Public Property VendorItemClass As Npc..::..NpcVendorItemClass
    Get
    Set
public:
property Npc..::..NpcVendorItemClass^ VendorItemClass {
    Npc..::..NpcVendorItemClass^ get ();
    void set (Npc..::..NpcVendorItemClass^ value);
}

Field Value

The vendor item class.

See Also

Buy Class
wManager.Wow.Class Namespace


CompanionInfo Class

Class CompanionInfo. https://wow.gamepedia.com/API_GetCompanionInfo , used in some bot versions by GetCompanionInfo()()()()

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class CompanionInfo
Public Class CompanionInfo
public ref class CompanionInfo

Inheritance Hierarchy

Object
wManager.Wow.Class..::..CompanionInfo

See Also

CompanionInfo Members
wManager.Wow.Class Namespace


CompanionInfo Members

The CompanionInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | CreatureID | The creature id
Public field | CreatureName | The creature name
Public field | Icon | The icon
Public field | MountFlags | The mount flags
Public field | SpellID | The creature spell id

Properties

 | Name | Description
Public property | Spell | Gets creature spell.

See Also

CompanionInfo Class
wManager.Wow.Class Namespace


CompanionInfo Fields

The CompanionInfo type exposes the following members.

Fields

 | Name | Description
Public field | CreatureID | The creature id
Public field | CreatureName | The creature name
Public field | Icon | The icon
Public field | MountFlags | The mount flags
Public field | SpellID | The creature spell id

See Also

CompanionInfo Class
wManager.Wow.Class Namespace


CreatureID Field

CompanionInfo..::..CreatureID Field

The creature id

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int CreatureID
Public CreatureID As Integer
public:
int^ CreatureID

See Also

CompanionInfo Class
wManager.Wow.Class Namespace


CreatureName Field

CompanionInfo..::..CreatureName Field

The creature name

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string CreatureName
Public CreatureName As String
public:
String^ CreatureName

See Also

CompanionInfo Class
wManager.Wow.Class Namespace


Icon Field

CompanionInfo..::..Icon Field

The icon

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string Icon
Public Icon As String
public:
String^ Icon

See Also

CompanionInfo Class
wManager.Wow.Class Namespace


MountFlags Field

CompanionInfo..::..MountFlags Field

The mount flags

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public MountFlags MountFlags
Public MountFlags As MountFlags
public:
MountFlags^ MountFlags

See Also

CompanionInfo Class
wManager.Wow.Class Namespace


SpellID Field

CompanionInfo..::..SpellID Field

The creature spell id

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int SpellID
Public SpellID As Integer
public:
int^ SpellID

See Also

CompanionInfo Class
wManager.Wow.Class Namespace


CompanionInfo Methods

The CompanionInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

CompanionInfo Class
wManager.Wow.Class Namespace


CompanionInfo Properties

The CompanionInfo type exposes the following members.

Properties

 | Name | Description
Public property | Spell | Gets creature spell.

See Also

CompanionInfo Class
wManager.Wow.Class Namespace


Spell Property

CompanionInfo..::..Spell Property

Gets creature spell.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Spell Spell { get; }
Public ReadOnly Property Spell As Spell
    Get
public:
property Spell^ Spell {
    Spell^ get ();
}

Field Value

The spell.

See Also

CompanionInfo Class
wManager.Wow.Class Namespace


DBCStruct Class

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class DBCStruct
Public Class DBCStruct
public ref class DBCStruct

Inheritance Hierarchy

Object
wManager.Wow.Class..::..DBCStruct

See Also

wManager.Wow.Class Namespace


DBCStruct Methods

The DBCStruct type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

DBCStruct Class
wManager.Wow.Class Namespace


DBCStruct.WoWClientDB Structure

DBCStruct..::..WoWClientDB Structure

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[StructLayoutAttribute]
public struct WoWClientDB
<StructLayoutAttribute> _
Public Structure WoWClientDB
[StructLayoutAttribute]
public value class WoWClientDB

See Also

DBCStruct..::..WoWClientDB Members
wManager.Wow.Class Namespace


DBCStruct.WoWClientDB Members

DBCStruct..::..WoWClientDB Members

The DBCStruct..::..WoWClientDB type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from ValueType.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from ValueType.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from ValueType.)

Fields

 | Name | Description
Public field | FirstRow |
Public field | IsLoaded |
Public field | maxIndex |
Public field | minIndex |
Public field | numRows |
Public field | Rows |
Public field | StringTable |

See Also

DBCStruct..::..WoWClientDB Structure
wManager.Wow.Class Namespace


DBCStruct.WoWClientDB Fields

DBCStruct..::..WoWClientDB Fields

The DBCStruct..::..WoWClientDB type exposes the following members.

Fields

 | Name | Description
Public field | FirstRow |
Public field | IsLoaded |
Public field | maxIndex |
Public field | minIndex |
Public field | numRows |
Public field | Rows |
Public field | StringTable |

See Also

DBCStruct..::..WoWClientDB Structure
wManager.Wow.Class Namespace


FirstRow Field

WoWClientDB..::..FirstRow Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint FirstRow
Public FirstRow As UInteger
public:
unsigned int^ FirstRow

See Also

DBCStruct..::..WoWClientDB Structure
wManager.Wow.Class Namespace


IsLoaded Field

WoWClientDB..::..IsLoaded Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int IsLoaded
Public IsLoaded As Integer
public:
int^ IsLoaded

See Also

DBCStruct..::..WoWClientDB Structure
wManager.Wow.Class Namespace


maxIndex Field

WoWClientDB..::..maxIndex Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int maxIndex
Public maxIndex As Integer
public:
int^ maxIndex

See Also

DBCStruct..::..WoWClientDB Structure
wManager.Wow.Class Namespace


minIndex Field

WoWClientDB..::..minIndex Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int minIndex
Public minIndex As Integer
public:
int^ minIndex

See Also

DBCStruct..::..WoWClientDB Structure
wManager.Wow.Class Namespace


numRows Field

WoWClientDB..::..numRows Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int numRows
Public numRows As Integer
public:
int^ numRows

See Also

DBCStruct..::..WoWClientDB Structure
wManager.Wow.Class Namespace


Rows Field

WoWClientDB..::..Rows Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint Rows
Public Rows As UInteger
public:
unsigned int^ Rows

See Also

DBCStruct..::..WoWClientDB Structure
wManager.Wow.Class Namespace


StringTable Field

WoWClientDB..::..StringTable Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int StringTable
Public StringTable As Integer
public:
int^ StringTable

See Also

DBCStruct..::..WoWClientDB Structure
wManager.Wow.Class Namespace


DBCStruct.WoWClientDB Methods

DBCStruct..::..WoWClientDB Methods

The DBCStruct..::..WoWClientDB type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from ValueType.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from ValueType.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from ValueType.)

See Also

DBCStruct..::..WoWClientDB Structure
wManager.Wow.Class Namespace


Digsite Class

Class Digsite.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class Digsite
<SerializableAttribute> _
Public Class Digsite
[SerializableAttribute]
public ref class Digsite

Inheritance Hierarchy

Object
wManager.Wow.Class..::..Digsite

See Also

Digsite Members
wManager.Wow.Class Namespace


Digsite Members

The Digsite type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | Id | Identifiers this instance.
Public method | IsValid | Returns true if is valid.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Active | Gets or sets a value indicating whether this Digsite is active.
Public property | ContinentId | Continent id of the digsite.
Public property | Name | Digsite name.
Public property | Position | Digsite position.
Public property | PositionX | Digsite position x.
Public property | PositionY | Digsite position y.
Public property | PositionZ | Digsite position z.
Public property | PriorityDigsites | Gets or sets the priority the digsite.
Public property | Px | Lua X position.
Public property | Py | Lua Y position.

See Also

Digsite Class
wManager.Wow.Class Namespace


Digsite Methods

The Digsite type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | Id | Identifiers this instance.
Public method | IsValid | Returns true if is valid.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Digsite Class
wManager.Wow.Class Namespace


Id Method

Digsite..::..Id Method

Identifiers this instance.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string Id()
Public Function Id As String
public:
String^ Id()

Return Value

System.String.

See Also

Digsite Class
wManager.Wow.Class Namespace


IsValid Method

Digsite..::..IsValid Method

Returns true if is valid.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsValid()
Public Function IsValid As Boolean
public:
bool^ IsValid()

Return Value

true if this instance is valid; otherwise, false.

See Also

Digsite Class
wManager.Wow.Class Namespace


Digsite Properties

The Digsite type exposes the following members.

Properties

 | Name | Description
Public property | Active | Gets or sets a value indicating whether this Digsite is active.
Public property | ContinentId | Continent id of the digsite.
Public property | Name | Digsite name.
Public property | Position | Digsite position.
Public property | PositionX | Digsite position x.
Public property | PositionY | Digsite position y.
Public property | PositionZ | Digsite position z.
Public property | PriorityDigsites | Gets or sets the priority the digsite.
Public property | Px | Lua X position.
Public property | Py | Lua Y position.

See Also

Digsite Class
wManager.Wow.Class Namespace


Active Property

Digsite..::..Active Property

Gets or sets a value indicating whether this Digsite is active.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool Active { get; set; }
Public Property Active As Boolean
    Get
    Set
public:
property bool^ Active {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if active; otherwise, false.

See Also

Digsite Class
wManager.Wow.Class Namespace


ContinentId Property

Digsite..::..ContinentId Property

Continent id of the digsite.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint ContinentId { get; set; }
Public Property ContinentId As UInteger
    Get
    Set
public:
property unsigned int^ ContinentId {
    unsigned int^ get ();
    void set (unsigned int^ value);
}

Field Value

The continent id.

See Also

Digsite Class
wManager.Wow.Class Namespace


Name Property

Digsite..::..Name Property

Digsite name.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Field Value

The name.

See Also

Digsite Class
wManager.Wow.Class Namespace


Position Property

Digsite..::..Position Property

Digsite position.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[BrowsableAttribute]
[EditorBrowsableAttribute]
public Vector3 Position { get; set; }
<BrowsableAttribute> _
<EditorBrowsableAttribute> _
Public Property Position As Vector3
    Get
    Set
[BrowsableAttribute]
[EditorBrowsableAttribute]
public:
property Vector3^ Position {
    Vector3^ get ();
    void set (Vector3^ value);
}

Field Value

The position.

See Also

Digsite Class
wManager.Wow.Class Namespace


PositionX Property

Digsite..::..PositionX Property

Digsite position x.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[XmlIgnoreAttribute]
public float PositionX { get; set; }
<XmlIgnoreAttribute> _
Public Property PositionX As Single
    Get
    Set
[XmlIgnoreAttribute]
public:
property float^ PositionX {
    float^ get ();
    void set (float^ value);
}

Field Value

The position x.

See Also

Digsite Class
wManager.Wow.Class Namespace


PositionY Property

Digsite..::..PositionY Property

Digsite position y.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[XmlIgnoreAttribute]
public float PositionY { get; set; }
<XmlIgnoreAttribute> _
Public Property PositionY As Single
    Get
    Set
[XmlIgnoreAttribute]
public:
property float^ PositionY {
    float^ get ();
    void set (float^ value);
}

Field Value

The position y.

See Also

Digsite Class
wManager.Wow.Class Namespace


PositionZ Property

Digsite..::..PositionZ Property

Digsite position z.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[XmlIgnoreAttribute]
public float PositionZ { get; set; }
<XmlIgnoreAttribute> _
Public Property PositionZ As Single
    Get
    Set
[XmlIgnoreAttribute]
public:
property float^ PositionZ {
    float^ get ();
    void set (float^ value);
}

Field Value

The position z.

See Also

Digsite Class
wManager.Wow.Class Namespace


PriorityDigsites Property

Digsite..::..PriorityDigsites Property

Gets or sets the priority the digsite.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float PriorityDigsites { get; set; }
Public Property PriorityDigsites As Single
    Get
    Set
public:
property float^ PriorityDigsites {
    float^ get ();
    void set (float^ value);
}

Field Value

The priority digsite.

See Also

Digsite Class
wManager.Wow.Class Namespace


Px Property

Digsite..::..Px Property

Lua X position.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string Px { get; set; }
Public Property Px As String
    Get
    Set
public:
property String^ Px {
    String^ get ();
    void set (String^ value);
}

Field Value

The px.

See Also

Digsite Class
wManager.Wow.Class Namespace


Py Property

Digsite..::..Py Property

Lua Y position.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string Py { get; set; }
Public Property Py As String
    Get
    Set
public:
property String^ Py {
    String^ get ();
    void set (String^ value);
}

Field Value

The py.

See Also

Digsite Class
wManager.Wow.Class Namespace


EntryIndexQuest Class

Class EntryIndexQuest. Used by QuestGrinderGathererClass

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class EntryIndexQuest
<SerializableAttribute> _
Public Class EntryIndexQuest
[SerializableAttribute]
public ref class EntryIndexQuest

Inheritance Hierarchy

Object
wManager.Wow.Class..::..EntryIndexQuest

See Also

EntryIndexQuest Members
wManager.Wow.Class Namespace


EntryIndexQuest Members

The EntryIndexQuest type exposes the following members.

Constructors

 | Name | Description
Public method | EntryIndexQuest()()()() | Initializes a new instance of the EntryIndexQuest class.
Public method | EntryIndexQuest(Int32, Int32, Int32, Int32, Boolean, String) | Initializes a new instance of the EntryIndexQuest class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Description | Gets or sets the description.
Public property | Entry | Gets or sets the entry id.
Public property | Index | Gets or sets the objective index.
Public property | ObjectiveRequiredAutoDetectCount | Gets or sets a value indicating if automatically detect count objective.
Public property | ObjectiveRequiredCount | Gets or sets the objective required count.
Public property | QuestId | Gets or sets the quest id.

See Also

EntryIndexQuest Class
wManager.Wow.Class Namespace


EntryIndexQuest Constructor

Overload List

 | Name | Description
Public method | EntryIndexQuest()()()() | Initializes a new instance of the EntryIndexQuest class.
Public method | EntryIndexQuest(Int32, Int32, Int32, Int32, Boolean, String) | Initializes a new instance of the EntryIndexQuest class.

See Also

EntryIndexQuest Class
EntryIndexQuest Members
wManager.Wow.Class Namespace


EntryIndexQuest Constructor

Initializes a new instance of the EntryIndexQuest class.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public EntryIndexQuest()
Public Sub New
public:
EntryIndexQuest()

See Also

EntryIndexQuest Class
EntryIndexQuest Overload
wManager.Wow.Class Namespace


EntryIndexQuest Constructor (Int32, Int32, Int32, Int32, Boolean, String)

Initializes a new instance of the EntryIndexQuest class.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public EntryIndexQuest(
    int entry,
    int index,
    int questId,
    int objectiveRequiredCount,
    bool objectiveRequiredAutoDetectCount,
    string description
)
Public Sub New ( _
    entry As Integer, _
    index As Integer, _
    questId As Integer, _
    objectiveRequiredCount As Integer, _
    objectiveRequiredAutoDetectCount As Boolean, _
    description As String _
)
public:
EntryIndexQuest(
    int^ entry,
    int^ index,
    int^ questId,
    int^ objectiveRequiredCount,
    bool^ objectiveRequiredAutoDetectCount,
    String^ description
)

Parameters

entry
Type: Int32
The entry id.
index
Type: Int32
The objective index.
questId
Type: Int32
The quest id.
objectiveRequiredCount
Type: Int32
Objective required count.
objectiveRequiredAutoDetectCount
Type: Boolean
if set to true automatically detect count objective.
description
Type: String
The description.

See Also

EntryIndexQuest Class
EntryIndexQuest Overload
wManager.Wow.Class Namespace


EntryIndexQuest Methods

The EntryIndexQuest type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

EntryIndexQuest Class
wManager.Wow.Class Namespace


EntryIndexQuest Properties

The EntryIndexQuest type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets or sets the description.
Public property | Entry | Gets or sets the entry id.
Public property | Index | Gets or sets the objective index.
Public property | ObjectiveRequiredAutoDetectCount | Gets or sets a value indicating if automatically detect count objective.
Public property | ObjectiveRequiredCount | Gets or sets the objective required count.
Public property | QuestId | Gets or sets the quest id.

See Also

EntryIndexQuest Class
wManager.Wow.Class Namespace


Description Property

EntryIndexQuest..::..Description Property

Gets or sets the description.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Field Value

The description.

See Also

EntryIndexQuest Class
wManager.Wow.Class Namespace


Entry Property

EntryIndexQuest..::..Entry Property

Gets or sets the entry id.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int Entry { get; set; }
Public Property Entry As Integer
    Get
    Set
public:
property int^ Entry {
    int^ get ();
    void set (int^ value);
}

Field Value

The entry.

See Also

EntryIndexQuest Class
wManager.Wow.Class Namespace


Index Property

EntryIndexQuest..::..Index Property

Gets or sets the objective index.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int Index { get; set; }
Public Property Index As Integer
    Get
    Set
public:
property int^ Index {
    int^ get ();
    void set (int^ value);
}

Field Value

The objective index.

See Also

EntryIndexQuest Class
wManager.Wow.Class Namespace


ObjectiveRequiredAutoDetectCount Property

EntryIndexQuest..::..ObjectiveRequiredAutoDetectCount Property

Gets or sets a value indicating if automatically detect count objective.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool ObjectiveRequiredAutoDetectCount { get; set; }
Public Property ObjectiveRequiredAutoDetectCount As Boolean
    Get
    Set
public:
property bool^ ObjectiveRequiredAutoDetectCount {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if automatically detect count objective; otherwise, false (to use ObjectiveRequiredCount).

See Also

EntryIndexQuest Class
wManager.Wow.Class Namespace


ObjectiveRequiredCount Property

EntryIndexQuest..::..ObjectiveRequiredCount Property

Gets or sets the objective required count.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int ObjectiveRequiredCount { get; set; }
Public Property ObjectiveRequiredCount As Integer
    Get
    Set
public:
property int^ ObjectiveRequiredCount {
    int^ get ();
    void set (int^ value);
}

Field Value

The objective required count.

See Also

EntryIndexQuest Class
wManager.Wow.Class Namespace


QuestId Property

EntryIndexQuest..::..QuestId Property

Gets or sets the quest id.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int QuestId { get; set; }
Public Property QuestId As Integer
    Get
    Set
public:
property int^ QuestId {
    int^ get ();
    void set (int^ value);
}

Field Value

The quest id.

See Also

EntryIndexQuest Class
wManager.Wow.Class Namespace


ItemInfo Class

Item Information Class, based on https://wow.gamepedia.com/API_GetItemInfo (can change in some bot versions)

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class ItemInfo
Public Class ItemInfo
public ref class ItemInfo

Inheritance Hierarchy

Object
wManager.Wow.Class..::..ItemInfo

See Also

ItemInfo Members
wManager.Wow.Class Namespace


ItemInfo Members

The ItemInfo type exposes the following members.

Constructors

 | Name | Description
Public method | ItemInfo(Int32) | Initializes a new instance of the ItemInfo class.
Public method | ItemInfo(String) | Initializes a new instance of the ItemInfo class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | ItemEquipLoc | The inventory equipment location in which the item may be equipped, or "" if it cannot be equipped.
Public property | ItemLevel | The base item level, not including upgrades
Public property | ItemLink | The localized lua link of the item.
Public property | ItemMinLevel | The minimum level required to use the item
Public property | ItemName | Gets the name of the item.
Public property | ItemRarity | The quality of the item, WoWItemQuality
Public property | ItemSellPrice | The vendor price in copper, or 0 for items that cannot be sold.
Public property | ItemStackCount | The max amount of an item per stack, e.g. 200 for Runecloth.
Public property | ItemSubType | The localized sub-type name of the item: Bows, Guns, Staves, etc. https://wow.gamepedia.com/ItemType
Public property | ItemTexture | The texture for the item icon.
Public property | ItemType | The localized type name of the item: Armor, Weapon, Quest, etc. https://wow.gamepedia.com/ItemType

See Also

ItemInfo Class
wManager.Wow.Class Namespace


ItemInfo Constructor

Overload List

 | Name | Description
Public method | ItemInfo(Int32) | Initializes a new instance of the ItemInfo class.
Public method | ItemInfo(String) | Initializes a new instance of the ItemInfo class.

See Also

ItemInfo Class
ItemInfo Members
wManager.Wow.Class Namespace


ItemInfo Constructor (Int32)

Initializes a new instance of the ItemInfo class.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public ItemInfo(
    int itemId
)
Public Sub New ( _
    itemId As Integer _
)
public:
ItemInfo(
    int^ itemId
)

Parameters

itemId
Type: Int32
The item id.

See Also

ItemInfo Class
ItemInfo Overload
wManager.Wow.Class Namespace


ItemInfo Constructor (String)

Initializes a new instance of the ItemInfo class.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public ItemInfo(
    string nameItem
)
Public Sub New ( _
    nameItem As String _
)
public:
ItemInfo(
    String^ nameItem
)

Parameters

nameItem
Type: String
The name of item (like is appear in game).

See Also

ItemInfo Class
ItemInfo Overload
wManager.Wow.Class Namespace


ItemInfo Methods

The ItemInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

ItemInfo Class
wManager.Wow.Class Namespace


ItemInfo Properties

The ItemInfo type exposes the following members.

Properties

 | Name | Description
Public property | ItemEquipLoc | The inventory equipment location in which the item may be equipped, or "" if it cannot be equipped.
Public property | ItemLevel | The base item level, not including upgrades
Public property | ItemLink | The localized lua link of the item.
Public property | ItemMinLevel | The minimum level required to use the item
Public property | ItemName | Gets the name of the item.
Public property | ItemRarity | The quality of the item, WoWItemQuality
Public property | ItemSellPrice | The vendor price in copper, or 0 for items that cannot be sold.
Public property | ItemStackCount | The max amount of an item per stack, e.g. 200 for Runecloth.
Public property | ItemSubType | The localized sub-type name of the item: Bows, Guns, Staves, etc. https://wow.gamepedia.com/ItemType
Public property | ItemTexture | The texture for the item icon.
Public property | ItemType | The localized type name of the item: Armor, Weapon, Quest, etc. https://wow.gamepedia.com/ItemType

See Also

ItemInfo Class
wManager.Wow.Class Namespace


ItemEquipLoc Property

ItemInfo..::..ItemEquipLoc Property

The inventory equipment location in which the item may be equipped, or "" if it cannot be equipped.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string ItemEquipLoc { get; set; }
Public Property ItemEquipLoc As String
    Get
    Set
public:
property String^ ItemEquipLoc {
    String^ get ();
    void set (String^ value);
}

See Also

ItemInfo Class
wManager.Wow.Class Namespace


ItemLevel Property

ItemInfo..::..ItemLevel Property

The base item level, not including upgrades

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int ItemLevel { get; set; }
Public Property ItemLevel As Integer
    Get
    Set
public:
property int^ ItemLevel {
    int^ get ();
    void set (int^ value);
}

See Also

ItemInfo Class
wManager.Wow.Class Namespace


ItemLink Property

ItemInfo..::..ItemLink Property

The localized lua link of the item.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string ItemLink { get; set; }
Public Property ItemLink As String
    Get
    Set
public:
property String^ ItemLink {
    String^ get ();
    void set (String^ value);
}

See Also

ItemInfo Class
wManager.Wow.Class Namespace


ItemMinLevel Property

ItemInfo..::..ItemMinLevel Property

The minimum level required to use the item

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int ItemMinLevel { get; set; }
Public Property ItemMinLevel As Integer
    Get
    Set
public:
property int^ ItemMinLevel {
    int^ get ();
    void set (int^ value);
}

See Also

ItemInfo Class
wManager.Wow.Class Namespace


ItemName Property

ItemInfo..::..ItemName Property

Gets the name of the item.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string ItemName { get; set; }
Public Property ItemName As String
    Get
    Set
public:
property String^ ItemName {
    String^ get ();
    void set (String^ value);
}

See Also

ItemInfo Class
wManager.Wow.Class Namespace


ItemRarity Property

ItemInfo..::..ItemRarity Property

The quality of the item, WoWItemQuality

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int ItemRarity { get; set; }
Public Property ItemRarity As Integer
    Get
    Set
public:
property int^ ItemRarity {
    int^ get ();
    void set (int^ value);
}

See Also

ItemInfo Class
wManager.Wow.Class Namespace


ItemSellPrice Property

ItemInfo..::..ItemSellPrice Property

The vendor price in copper, or 0 for items that cannot be sold.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int ItemSellPrice { get; set; }
Public Property ItemSellPrice As Integer
    Get
    Set
public:
property int^ ItemSellPrice {
    int^ get ();
    void set (int^ value);
}

See Also

ItemInfo Class
wManager.Wow.Class Namespace


ItemStackCount Property

ItemInfo..::..ItemStackCount Property

The max amount of an item per stack, e.g. 200 for Runecloth.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int ItemStackCount { get; set; }
Public Property ItemStackCount As Integer
    Get
    Set
public:
property int^ ItemStackCount {
    int^ get ();
    void set (int^ value);
}

See Also

ItemInfo Class
wManager.Wow.Class Namespace


ItemSubType Property

ItemInfo..::..ItemSubType Property

The localized sub-type name of the item: Bows, Guns, Staves, etc. https://wow.gamepedia.com/ItemType

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string ItemSubType { get; set; }
Public Property ItemSubType As String
    Get
    Set
public:
property String^ ItemSubType {
    String^ get ();
    void set (String^ value);
}

See Also

ItemInfo Class
wManager.Wow.Class Namespace


ItemTexture Property

ItemInfo..::..ItemTexture Property

The texture for the item icon.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string ItemTexture { get; set; }
Public Property ItemTexture As String
    Get
    Set
public:
property String^ ItemTexture {
    String^ get ();
    void set (String^ value);
}

See Also

ItemInfo Class
wManager.Wow.Class Namespace


ItemType Property

ItemInfo..::..ItemType Property

The localized type name of the item: Armor, Weapon, Quest, etc. https://wow.gamepedia.com/ItemType

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string ItemType { get; set; }
Public Property ItemType As String
    Get
    Set
public:
property String^ ItemType {
    String^ get ();
    void set (String^ value);
}

See Also

ItemInfo Class
wManager.Wow.Class Namespace


Npc Class

Class Npc, used by NpcDB.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class Npc
<SerializableAttribute> _
Public Class Npc
[SerializableAttribute]
public ref class Npc

Inheritance Hierarchy

Object
wManager.Wow.Class..::..Npc

See Also

Npc Members
wManager.Wow.Class Namespace


Npc Members

The Npc type exposes the following members.

Methods

 | Name | Description
Public method | BlackList | Blacklist this npc temporarily.
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IsBlackListedOrDisabled | Determines whether is blacklisted or disabled.
Public method | IsValid | Returns true if is valid.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ScriptCanConditionExecute | Test ScriptCanCondition returned value (return true if not script).
Public method | ToString | Returns a String that represents this instance.

Fields

 | Name | Description
Public field | Position | The position

Properties

 | Name | Description
Public property | Active | Gets or sets a value indicating whether this Npc can be used.
Public property | CanFlyTo | Gets or sets a value indicating if character can fly to.
Public property | ContinentId | Gets or sets the continent id.
Public property | CurrentProfileNpc | Gets or sets a value indicating if it is Npc of current product profile (for AcceptOnlyProfileNpc).
Public property | Entry | Gets or sets the entry id.
Public property | Faction | Gets or sets the faction.
Public property | GossipOption | Gets or sets the gossip option.
Public property | Name | Gets or sets the name (or description).
Public property | PosX | Gets or sets the position x.
Public property | PosY | Gets or sets the position y.
Public property | PosZ | Gets or sets the position z.
Public property | Save | Gets or sets a value indicating if save this Npc when bot save NpcDB (to be usable again after restart).
Public property | ScriptCanCondition | Script can condition (code like return wManager.Wow.ObjectManager.ObjectManager.Me.Level > 10;, default language is C#, start by lua: or luabot: or vb: to change script language).
Public property | Type | Gets or sets the type.
Public property | VendorItemClass | Gets or sets the vendor item class.

See Also

Npc Class
wManager.Wow.Class Namespace


Npc Fields

The Npc type exposes the following members.

Fields

 | Name | Description
Public field | Position | The position

See Also

Npc Class
wManager.Wow.Class Namespace


Position Field

Npc..::..Position Field

The position

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Vector3 Position
Public Position As Vector3
public:
Vector3^ Position

See Also

Npc Class
wManager.Wow.Class Namespace


Npc Methods

The Npc type exposes the following members.

Methods

 | Name | Description
Public method | BlackList | Blacklist this npc temporarily.
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IsBlackListedOrDisabled | Determines whether is blacklisted or disabled.
Public method | IsValid | Returns true if is valid.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ScriptCanConditionExecute | Test ScriptCanCondition returned value (return true if not script).
Public method | ToString | Returns a String that represents this instance.

See Also

Npc Class
wManager.Wow.Class Namespace


BlackList Method

Npc..::..BlackList Method

Blacklist this npc temporarily.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void BlackList(
    int timeMs
)
Public Sub BlackList ( _
    timeMs As Integer _
)
public:
void BlackList(
    int^ timeMs
)

Parameters

timeMs
Type: Int32
The time in milliseconds.

See Also

Npc Class
wManager.Wow.Class Namespace


IsBlackListedOrDisabled Method

Npc..::..IsBlackListedOrDisabled Method

Determines whether is blacklisted or disabled.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsBlackListedOrDisabled()
Public Function IsBlackListedOrDisabled As Boolean
public:
bool^ IsBlackListedOrDisabled()

See Also

Npc Class
wManager.Wow.Class Namespace


IsValid Method

Npc..::..IsValid Method

Returns true if is valid.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsValid()
Public Function IsValid As Boolean
public:
bool^ IsValid()

Return Value

true if this instance is valid; otherwise, false.

See Also

Npc Class
wManager.Wow.Class Namespace


ScriptCanConditionExecute Method

Npc..::..ScriptCanConditionExecute Method

Test ScriptCanCondition returned value (return true if not script).

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool ScriptCanConditionExecute()
Public Function ScriptCanConditionExecute As Boolean
public:
bool^ ScriptCanConditionExecute()

See Also

Npc Class
wManager.Wow.Class Namespace


ToString Method

Npc..::..ToString Method

Returns a String that represents this instance.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string ToString()
Public Function ToString As String
public:
String^ ToString()

Return Value

A String that represents this instance.

See Also

Npc Class
wManager.Wow.Class Namespace


Npc Properties

The Npc type exposes the following members.

Properties

 | Name | Description
Public property | Active | Gets or sets a value indicating whether this Npc can be used.
Public property | CanFlyTo | Gets or sets a value indicating if character can fly to.
Public property | ContinentId | Gets or sets the continent id.
Public property | CurrentProfileNpc | Gets or sets a value indicating if it is Npc of current product profile (for AcceptOnlyProfileNpc).
Public property | Entry | Gets or sets the entry id.
Public property | Faction | Gets or sets the faction.
Public property | GossipOption | Gets or sets the gossip option.
Public property | Name | Gets or sets the name (or description).
Public property | PosX | Gets or sets the position x.
Public property | PosY | Gets or sets the position y.
Public property | PosZ | Gets or sets the position z.
Public property | Save | Gets or sets a value indicating if save this Npc when bot save NpcDB (to be usable again after restart).
Public property | ScriptCanCondition | Script can condition (code like return wManager.Wow.ObjectManager.ObjectManager.Me.Level > 10;, default language is C#, start by lua: or luabot: or vb: to change script language).
Public property | Type | Gets or sets the type.
Public property | VendorItemClass | Gets or sets the vendor item class.

See Also

Npc Class
wManager.Wow.Class Namespace


Active Property

Npc..::..Active Property

Gets or sets a value indicating whether this Npc can be used.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool Active { get; set; }
Public Property Active As Boolean
    Get
    Set
public:
property bool^ Active {
    bool^ get ();
    void set (bool^ value);
}

See Also

Npc Class
wManager.Wow.Class Namespace


CanFlyTo Property

Npc..::..CanFlyTo Property

Gets or sets a value indicating if character can fly to.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[XmlIgnoreAttribute]
public bool CanFlyTo { get; set; }
<XmlIgnoreAttribute> _
Public Property CanFlyTo As Boolean
    Get
    Set
[XmlIgnoreAttribute]
public:
property bool^ CanFlyTo {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if character can fly to; otherwise, false.

See Also

Npc Class
wManager.Wow.Class Namespace


ContinentId Property

Npc..::..ContinentId Property

Gets or sets the continent id.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public ContinentId ContinentId { get; set; }
Public Property ContinentId As ContinentId
    Get
    Set
public:
property ContinentId^ ContinentId {
    ContinentId^ get ();
    void set (ContinentId^ value);
}

Field Value

The continent id.

See Also

Npc Class
wManager.Wow.Class Namespace


CurrentProfileNpc Property

Npc..::..CurrentProfileNpc Property

Gets or sets a value indicating if it is Npc of current product profile (for AcceptOnlyProfileNpc).

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[XmlIgnoreAttribute]
public bool CurrentProfileNpc { get; set; }
<XmlIgnoreAttribute> _
Public Property CurrentProfileNpc As Boolean
    Get
    Set
[XmlIgnoreAttribute]
public:
property bool^ CurrentProfileNpc {
    bool^ get ();
    void set (bool^ value);
}

See Also

Npc Class
wManager.Wow.Class Namespace


Entry Property

Npc..::..Entry Property

Gets or sets the entry id.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int Entry { get; set; }
Public Property Entry As Integer
    Get
    Set
public:
property int^ Entry {
    int^ get ();
    void set (int^ value);
}

Field Value

The entry.

See Also

Npc Class
wManager.Wow.Class Namespace


Faction Property

Npc..::..Faction Property

Gets or sets the faction.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Npc..::..FactionType Faction { get; set; }
Public Property Faction As Npc..::..FactionType
    Get
    Set
public:
property Npc..::..FactionType^ Faction {
    Npc..::..FactionType^ get ();
    void set (Npc..::..FactionType^ value);
}

See Also

Npc Class
wManager.Wow.Class Namespace


GossipOption Property

Npc..::..GossipOption Property

Gets or sets the gossip option.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int GossipOption { get; set; }
Public Property GossipOption As Integer
    Get
    Set
public:
property int^ GossipOption {
    int^ get ();
    void set (int^ value);
}

Field Value

The gossip option.

See Also

Npc Class
wManager.Wow.Class Namespace


Name Property

Npc..::..Name Property

Gets or sets the name (or description).

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Field Value

The name.

See Also

Npc Class
wManager.Wow.Class Namespace


PosX Property

Npc..::..PosX Property

Gets or sets the position x.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[XmlIgnoreAttribute]
public float PosX { get; set; }
<XmlIgnoreAttribute> _
Public Property PosX As Single
    Get
    Set
[XmlIgnoreAttribute]
public:
property float^ PosX {
    float^ get ();
    void set (float^ value);
}

Field Value

The position x.

See Also

Npc Class
wManager.Wow.Class Namespace


PosY Property

Npc..::..PosY Property

Gets or sets the position y.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[XmlIgnoreAttribute]
public float PosY { get; set; }
<XmlIgnoreAttribute> _
Public Property PosY As Single
    Get
    Set
[XmlIgnoreAttribute]
public:
property float^ PosY {
    float^ get ();
    void set (float^ value);
}

Field Value

The position y.

See Also

Npc Class
wManager.Wow.Class Namespace


PosZ Property

Npc..::..PosZ Property

Gets or sets the position z.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[XmlIgnoreAttribute]
public float PosZ { get; set; }
<XmlIgnoreAttribute> _
Public Property PosZ As Single
    Get
    Set
[XmlIgnoreAttribute]
public:
property float^ PosZ {
    float^ get ();
    void set (float^ value);
}

Field Value

The position z.

See Also

Npc Class
wManager.Wow.Class Namespace


Save Property

Npc..::..Save Property

Gets or sets a value indicating if save this Npc when bot save NpcDB (to be usable again after restart).

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[XmlIgnoreAttribute]
public bool Save { get; set; }
<XmlIgnoreAttribute> _
Public Property Save As Boolean
    Get
    Set
[XmlIgnoreAttribute]
public:
property bool^ Save {
    bool^ get ();
    void set (bool^ value);
}

See Also

Npc Class
wManager.Wow.Class Namespace


ScriptCanCondition Property

Npc..::..ScriptCanCondition Property

Script can condition (code like return wManager.Wow.ObjectManager.ObjectManager.Me.Level > 10;, default language is C#, start by lua: or luabot: or vb: to change script language).

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string ScriptCanCondition { get; set; }
Public Property ScriptCanCondition As String
    Get
    Set
public:
property String^ ScriptCanCondition {
    String^ get ();
    void set (String^ value);
}

Field Value

The script can condition.

See Also

Npc Class
wManager.Wow.Class Namespace


Type Property

Npc..::..Type Property

Gets or sets the type.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Npc..::..NpcType Type { get; set; }
Public Property Type As Npc..::..NpcType
    Get
    Set
public:
property Npc..::..NpcType^ Type {
    Npc..::..NpcType^ get ();
    void set (Npc..::..NpcType^ value);
}

Field Value

The type.

See Also

Npc Class
wManager.Wow.Class Namespace


VendorItemClass Property

Npc..::..VendorItemClass Property

Gets or sets the vendor item class.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Npc..::..NpcVendorItemClass VendorItemClass { get; set; }
Public Property VendorItemClass As Npc..::..NpcVendorItemClass
    Get
    Set
public:
property Npc..::..NpcVendorItemClass^ VendorItemClass {
    Npc..::..NpcVendorItemClass^ get ();
    void set (Npc..::..NpcVendorItemClass^ value);
}

Field Value

The vendor item class.

See Also

Npc Class
wManager.Wow.Class Namespace


Npc.FactionType Enumeration

Npc..::..FactionType Enumeration

Faction type

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public enum FactionType
<SerializableAttribute> _
Public Enumeration FactionType
[SerializableAttribute]
public enum class FactionType

Members

Member name | Description
Neutral |
Horde |
Alliance |

See Also

wManager.Wow.Class Namespace


Npc.NpcType Enumeration

Npc..::..NpcType Enumeration

Npc type

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public enum NpcType
<SerializableAttribute> _
Public Enumeration NpcType
[SerializableAttribute]
public enum class NpcType

Members

Member name | Description
None |
Vendor |
Repair |
Mailbox |
MiningTrainer |
HerbalismTrainer |
FishingTrainer |
ResurrectBattlePets |
Smelting |
ArchaeologyTrainers |
AuctionHouse |
DruidTrainer |
RogueTrainer |
WarriorTrainer |
PaladinTrainer |
HunterTrainer |
PriestTrainer |
DeathKnightTrainer |
ShamanTrainer |
MageTrainer |
WarlockTrainer |
AlchemyTrainer |
BlacksmithingTrainer |
EnchantingTrainer |
EngineeringTrainer |
InscriptionTrainer |
JewelcraftingTrainer |
LeatherworkingTrainer |
TailoringTrainer |
SkinningTrainer |
CookingTrainer |
FirstAidTrainer |
RidingTrainer |
MonkTrainer |

See Also

wManager.Wow.Class Namespace


Npc.NpcVendorItemClass Enumeration

Npc..::..NpcVendorItemClass Enumeration

Npc vendor item class

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
[FlagsAttribute]
public enum NpcVendorItemClass
<SerializableAttribute> _
<FlagsAttribute> _
Public Enumeration NpcVendorItemClass
[SerializableAttribute]
[FlagsAttribute]
public enum class NpcVendorItemClass

Members

Member name | Description
None |
Consumable |
Potion |
Elixir |
Flask |
Scroll |
Food |
ItemEnhancement |
Bandage |
ConsumableOther |
Container |
SoulContainer |
HerbContainer |
EnchantingContainer |
EngineeringContainer |
WeaponAxe |
WeaponAxe2 |
WeaponBow |
WeaponGun |
WeaponMace |
WeaponMace2 |
WeaponPolearm |
WeaponSword |
WeaponSword2 |
WeaponReserved1 |
WeaponStaff |
WeaponReserved2 |
WeaponReserved3 |
WeaponFist |
WeaponMisc |
WeaponDagger |
WeaponThrown |
WeaponSpear |
WeaponCrossbow |
WeaponWand |
WeaponFishingPole |
ArmorMisc |
ArmorCloth |
ArmorLeather |
ArmorMail |
ArmorPlate |
ArmorBuckler |
ArmorShield |
ArmorLibram |
ArmorIdol |
ArmorTotem |
Reagent |
Arrow |
Bullet |
TradeGoods |
Parts |
Explosives |
Devices |
Book |
LeatherworkingPattern |
TailoringPattern |
EngineeringSchematic |
Blacksmithing |
CookingRecipe |
AlchemyRecipe |
FirstAidManual |
EnchantingFormula |
FishingManual |
Quiver |
AmmoPouch |
Quest |
Key |
Lockpick |
Permanent |
Junk |
Custom |

See Also

wManager.Wow.Class Namespace


NPCQuest Class

Class NPCQuest. NPCs (or object) who give and complete quests

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class NPCQuest
<SerializableAttribute> _
Public Class NPCQuest
[SerializableAttribute]
public ref class NPCQuest

Inheritance Hierarchy

Object
wManager.Wow.Class..::..NPCQuest

See Also

NPCQuest Members
wManager.Wow.Class Namespace


NPCQuest Members

The NPCQuest type exposes the following members.

Constructors

 | Name | Description
Public method | NPCQuest()()()() | Initializes a new instance of the NPCQuest class.
Public method | NPCQuest(Int32, Vector3, List<(Of <<'(Int32>)>>), List<(Of <<'(Int32>)>>), Boolean, String) | Initializes a new instance of the NPCQuest class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance.

Properties

 | Name | Description
Public property | CanFlyTo | Gets or sets a value indicating if character can fly to.
Public property | GameObject | Gets or sets a value indicating whether it isWoWGameObject (by default bot search WoWUnit).
Public property | Id | Entry ID
Public property | Name | Gets or sets the name or description.
Public property | PickUpQuests | Gets or sets the pick up quests IDs.
Public property | Position | Gets or sets the position.
Public property | PosX | Gets or sets the position x.
Public property | PosY | Gets or sets the position y.
Public property | PosZ | Gets or sets the position z.
Public property | TurnInQuests | Gets or sets the turn in quests IDs.

See Also

NPCQuest Class
wManager.Wow.Class Namespace


NPCQuest Constructor

Overload List

 | Name | Description
Public method | NPCQuest()()()() | Initializes a new instance of the NPCQuest class.
Public method | NPCQuest(Int32, Vector3, List<(Of <<'(Int32>)>>), List<(Of <<'(Int32>)>>), Boolean, String) | Initializes a new instance of the NPCQuest class.

See Also

NPCQuest Class
NPCQuest Members
wManager.Wow.Class Namespace


NPCQuest Constructor

Initializes a new instance of the NPCQuest class.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public NPCQuest()
Public Sub New
public:
NPCQuest()

See Also

NPCQuest Class
NPCQuest Overload
wManager.Wow.Class Namespace


NPCQuest Constructor (Int32, Vector3, List(Int32), List(Int32), Boolean, String)

NPCQuest Constructor (Int32, Vector3, List<(Of <(<'Int32>)>)>, List<(Of <(<'Int32>)>)>, Boolean, String)

Initializes a new instance of the NPCQuest class.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public NPCQuest(
    int id,
    Vector3 position,
    List<int> pickUpQuests,
    List<int> turnInQuests,
    bool gameObject,
    string name
)
Public Sub New ( _
    id As Integer, _
    position As Vector3, _
    pickUpQuests As List(Of Integer), _
    turnInQuests As List(Of Integer), _
    gameObject As Boolean, _
    name As String _
)
public:
NPCQuest(
    int^ id,
    Vector3^ position,
    List<int^>^ pickUpQuests,
    List<int^>^ turnInQuests,
    bool^ gameObject,
    String^ name
)

Parameters

id
Type: Int32
The entry id.
position
Type: robotManager.Helpful..::..Vector3
The position.
pickUpQuests
Type: List <(Of <(<' Int32 >)>)>
The pick up quests IDs.
turnInQuests
Type: List <(Of <(<' Int32 >)>)>
The turn in questsIDs.
gameObject
Type: Boolean
if set to true game object.
name
Type: String
The name.

See Also

NPCQuest Class
NPCQuest Overload
wManager.Wow.Class Namespace


NPCQuest Methods

The NPCQuest type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance.

See Also

NPCQuest Class
wManager.Wow.Class Namespace


ToString Method

NPCQuest..::..ToString Method

Returns a String that represents this instance.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string ToString()
Public Function ToString As String
public:
String^ ToString()

Return Value

A String that represents this instance.

See Also

NPCQuest Class
wManager.Wow.Class Namespace


NPCQuest Properties

The NPCQuest type exposes the following members.

Properties

 | Name | Description
Public property | CanFlyTo | Gets or sets a value indicating if character can fly to.
Public property | GameObject | Gets or sets a value indicating whether it isWoWGameObject (by default bot search WoWUnit).
Public property | Id | Entry ID
Public property | Name | Gets or sets the name or description.
Public property | PickUpQuests | Gets or sets the pick up quests IDs.
Public property | Position | Gets or sets the position.
Public property | PosX | Gets or sets the position x.
Public property | PosY | Gets or sets the position y.
Public property | PosZ | Gets or sets the position z.
Public property | TurnInQuests | Gets or sets the turn in quests IDs.

See Also

NPCQuest Class
wManager.Wow.Class Namespace


CanFlyTo Property

NPCQuest..::..CanFlyTo Property

Gets or sets a value indicating if character can fly to.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[XmlIgnoreAttribute]
public bool CanFlyTo { get; set; }
<XmlIgnoreAttribute> _
Public Property CanFlyTo As Boolean
    Get
    Set
[XmlIgnoreAttribute]
public:
property bool^ CanFlyTo {
    bool^ get ();
    void set (bool^ value);
}

See Also

NPCQuest Class
wManager.Wow.Class Namespace


GameObject Property

NPCQuest..::..GameObject Property

Gets or sets a value indicating whether it isWoWGameObject (by default bot search WoWUnit).

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool GameObject { get; set; }
Public Property GameObject As Boolean
    Get
    Set
public:
property bool^ GameObject {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if game object; otherwise, false.

See Also

NPCQuest Class
wManager.Wow.Class Namespace


Id Property

NPCQuest..::..Id Property

Entry ID

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int Id { get; set; }
Public Property Id As Integer
    Get
    Set
public:
property int^ Id {
    int^ get ();
    void set (int^ value);
}

See Also

NPCQuest Class
wManager.Wow.Class Namespace


Name Property

NPCQuest..::..Name Property

Gets or sets the name or description.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

NPCQuest Class
wManager.Wow.Class Namespace


PickUpQuests Property

NPCQuest..::..PickUpQuests Property

Gets or sets the pick up quests IDs.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<int> PickUpQuests { get; set; }
Public Property PickUpQuests As List(Of Integer)
    Get
    Set
public:
property List<int^>^ PickUpQuests {
    List<int^>^ get ();
    void set (List<int^>^ value);
}

See Also

NPCQuest Class
wManager.Wow.Class Namespace


Position Property

NPCQuest..::..Position Property

Gets or sets the position.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Vector3 Position { get; set; }
Public Property Position As Vector3
    Get
    Set
public:
property Vector3^ Position {
    Vector3^ get ();
    void set (Vector3^ value);
}

Field Value

The position.

See Also

NPCQuest Class
wManager.Wow.Class Namespace


PosX Property

NPCQuest..::..PosX Property

Gets or sets the position x.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[XmlIgnoreAttribute]
public float PosX { get; set; }
<XmlIgnoreAttribute> _
Public Property PosX As Single
    Get
    Set
[XmlIgnoreAttribute]
public:
property float^ PosX {
    float^ get ();
    void set (float^ value);
}

Field Value

The position x.

See Also

NPCQuest Class
wManager.Wow.Class Namespace


PosY Property

NPCQuest..::..PosY Property

Gets or sets the position y.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[XmlIgnoreAttribute]
public float PosY { get; set; }
<XmlIgnoreAttribute> _
Public Property PosY As Single
    Get
    Set
[XmlIgnoreAttribute]
public:
property float^ PosY {
    float^ get ();
    void set (float^ value);
}

Field Value

The position y.

See Also

NPCQuest Class
wManager.Wow.Class Namespace


PosZ Property

NPCQuest..::..PosZ Property

Gets or sets the position z.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[XmlIgnoreAttribute]
public float PosZ { get; set; }
<XmlIgnoreAttribute> _
Public Property PosZ As Single
    Get
    Set
[XmlIgnoreAttribute]
public:
property float^ PosZ {
    float^ get ();
    void set (float^ value);
}

Field Value

The position z.

See Also

NPCQuest Class
wManager.Wow.Class Namespace


TurnInQuests Property

NPCQuest..::..TurnInQuests Property

Gets or sets the turn in quests IDs.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<int> TurnInQuests { get; set; }
Public Property TurnInQuests As List(Of Integer)
    Get
    Set
public:
property List<int^>^ TurnInQuests {
    List<int^>^ get ();
    void set (List<int^>^ value);
}

See Also

NPCQuest Class
wManager.Wow.Class Namespace


QuestAction Enumeration

Quest step action type (QuestsSorted)

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public enum QuestAction
<SerializableAttribute> _
Public Enumeration QuestAction
[SerializableAttribute]
public enum class QuestAction

Members

Member name | Description
None |
Pulse |
TurnIn |
PickUp |
PulseAllInOne |
Reset |
LoadProfile |
StopBot |
If |
IfVB |
IfHasQuest |
IfHasNotQuest |
EndIf |
While |
WhileVB |
WhileHasQuest |
WhileHasNotQuest |
EndWhile |
GoToStep |
StepName |
MessageBox |
WriteLog |
WriteDebugLog |
RunCode |
RunCodeVB |
RunCodeLuaBot |
RunLuaCode |
RunMacroLua |
Wait |

See Also

wManager.Wow.Class Namespace


QuestClass Class

Class QuestClass.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public abstract class QuestClass
Public MustInherit Class QuestClass
public ref class QuestClass abstract

Inheritance Hierarchy

Object
wManager.Wow.Class..::..QuestClass

See Also

QuestClass Members
wManager.Wow.Class Namespace


QuestClass Members

The QuestClass type exposes the following members.

Methods

 | Name | Description
Public method | CanConditions | Determines whether this can (by default this option return true, conditions can be added by override this method).
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | HasQuest | Check if character have one of QuestId in his quest log.
Public method | IsComplete | Determines if quest objective is complete (Step and StepAutoDetect).
Public method | IsCompleted | Quest is completed (already turn in, or can't do (min/max level, required quest, character class)).
Public method | IsCompleteObjectiveIndex | Determines whether is complete objective by objective index
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | PickUp | Go to NPC and Pick up quest.
Public method | Pulse | Pulse quest
Public method | PulseAllInOne | Pulses all in one (PickUp()()()(), Pulse()()()(), TurnIn()()()()).
Public method | Reset | Resets this instance (reset to default the progress). When you override this method don't forget to call method of super class.
Public method | ToString | (Inherited from Object.)
Public method | TurnIn | Go to NPC and turn in quest.
Public method | WhenLeaveStep | Called one time when the quester product leave this step (with Pulse or PulseAllInOne action).
Public method | WhenSelectStep | Called one time when the quester product select this step (with Pulse or PulseAllInOne action).

Fields

 | Name | Description
Public field | MaxLevel | The maximum level
Public field | MinLevel | The minimum level required
Public field | Name | The name
Public field | PickUpQuestOnItem | To pick up quest from item (PickUpQuestOnItemID).
Public field | PickUpQuestOnItemID | Pick up quest on item id (enable PickUpQuestOnItem).
Public field | RequiredQuest | The required completed quest id (to pickup and do this quest, 0 if no required quest)
Public field | WoWClass | To limit quest to one player class

Properties

 | Name | Description
Public property | GossipOptionItem | Gets or sets the gossip option to use to select reward item.
Public property | NpcPickUp | Gets the NPC where pick up quest (search in NPCList).
Public property | NpcTurnIn | Gets the NPC to turn in quest (search in NPCList)..
Public property | QuestId | Gets or sets the quest IDs list.
Public property | Step | Gets or sets the quest objectives required count (example, if this quest need 5 kills for objective 3 use Step = new List<int> {0, 0, 5, 0, 0};.
Public property | StepAutoDetect | Gets or sets the quest objectives to auto detect if complete (example, if you want detect if the objective 4 is done StepAutoDetect = new List<bool> {false, false, false, true, false};.

See Also

QuestClass Class
wManager.Wow.Class Namespace


QuestClass Fields

The QuestClass type exposes the following members.

Fields

 | Name | Description
Public field | MaxLevel | The maximum level
Public field | MinLevel | The minimum level required
Public field | Name | The name
Public field | PickUpQuestOnItem | To pick up quest from item (PickUpQuestOnItemID).
Public field | PickUpQuestOnItemID | Pick up quest on item id (enable PickUpQuestOnItem).
Public field | RequiredQuest | The required completed quest id (to pickup and do this quest, 0 if no required quest)
Public field | WoWClass | To limit quest to one player class

See Also

QuestClass Class
wManager.Wow.Class Namespace


MaxLevel Field

QuestClass..::..MaxLevel Field

The maximum level

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int MaxLevel
Public MaxLevel As Integer
public:
int^ MaxLevel

See Also

QuestClass Class
wManager.Wow.Class Namespace


MinLevel Field

QuestClass..::..MinLevel Field

The minimum level required

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int MinLevel
Public MinLevel As Integer
public:
int^ MinLevel

See Also

QuestClass Class
wManager.Wow.Class Namespace


Name Field

QuestClass..::..Name Field

The name

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string Name
Public Name As String
public:
String^ Name

See Also

QuestClass Class
wManager.Wow.Class Namespace


PickUpQuestOnItem Field

QuestClass..::..PickUpQuestOnItem Field

To pick up quest from item (PickUpQuestOnItemID).

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool PickUpQuestOnItem
Public PickUpQuestOnItem As Boolean
public:
bool^ PickUpQuestOnItem

See Also

QuestClass Class
wManager.Wow.Class Namespace


PickUpQuestOnItemID Field

QuestClass..::..PickUpQuestOnItemID Field

Pick up quest on item id (enable PickUpQuestOnItem).

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int PickUpQuestOnItemID
Public PickUpQuestOnItemID As Integer
public:
int^ PickUpQuestOnItemID

See Also

QuestClass Class
wManager.Wow.Class Namespace


RequiredQuest Field

QuestClass..::..RequiredQuest Field

The required completed quest id (to pickup and do this quest, 0 if no required quest)

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int RequiredQuest
Public RequiredQuest As Integer
public:
int^ RequiredQuest

See Also

QuestClass Class
wManager.Wow.Class Namespace


WoWClass Field

QuestClass..::..WoWClass Field

To limit quest to one player class

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public WoWClass WoWClass
Public WoWClass As WoWClass
public:
WoWClass^ WoWClass

See Also

QuestClass Class
wManager.Wow.Class Namespace


QuestClass Methods

The QuestClass type exposes the following members.

Methods

 | Name | Description
Public method | CanConditions | Determines whether this can (by default this option return true, conditions can be added by override this method).
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | HasQuest | Check if character have one of QuestId in his quest log.
Public method | IsComplete | Determines if quest objective is complete (Step and StepAutoDetect).
Public method | IsCompleted | Quest is completed (already turn in, or can't do (min/max level, required quest, character class)).
Public method | IsCompleteObjectiveIndex | Determines whether is complete objective by objective index
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | PickUp | Go to NPC and Pick up quest.
Public method | Pulse | Pulse quest
Public method | PulseAllInOne | Pulses all in one (PickUp()()()(), Pulse()()()(), TurnIn()()()()).
Public method | Reset | Resets this instance (reset to default the progress). When you override this method don't forget to call method of super class.
Public method | ToString | (Inherited from Object.)
Public method | TurnIn | Go to NPC and turn in quest.
Public method | WhenLeaveStep | Called one time when the quester product leave this step (with Pulse or PulseAllInOne action).
Public method | WhenSelectStep | Called one time when the quester product select this step (with Pulse or PulseAllInOne action).

See Also

QuestClass Class
wManager.Wow.Class Namespace


CanConditions Method

QuestClass..::..CanConditions Method

Determines whether this can (by default this option return true, conditions can be added by override this method).

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public virtual bool CanConditions()
Public Overridable Function CanConditions As Boolean
public:
virtual bool^ CanConditions()

See Also

QuestClass Class
wManager.Wow.Class Namespace


HasQuest Method

QuestClass..::..HasQuest Method

Check if character have one of QuestId in his quest log.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public virtual bool HasQuest()
Public Overridable Function HasQuest As Boolean
public:
virtual bool^ HasQuest()

See Also

QuestClass Class
wManager.Wow.Class Namespace


IsComplete Method

QuestClass..::..IsComplete Method

Determines if quest objective is complete (Step and StepAutoDetect).

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public virtual bool IsComplete()
Public Overridable Function IsComplete As Boolean
public:
virtual bool^ IsComplete()

See Also

QuestClass Class
wManager.Wow.Class Namespace


IsCompleted Method

QuestClass..::..IsCompleted Method

Quest is completed (already turn in, or can't do (min/max level, required quest, character class)).

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public virtual bool IsCompleted()
Public Overridable Function IsCompleted As Boolean
public:
virtual bool^ IsCompleted()

See Also

QuestClass Class
wManager.Wow.Class Namespace


IsCompleteObjectiveIndex Method

QuestClass..::..IsCompleteObjectiveIndex Method

Determines whether is complete objective by objective index

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsCompleteObjectiveIndex(
    int objectiveIndex,
    int objectiveRequiredCount,
    bool objectiveRequiredAutoDetectCount,
    int questId
)
Public Function IsCompleteObjectiveIndex ( _
    objectiveIndex As Integer, _
    objectiveRequiredCount As Integer, _
    objectiveRequiredAutoDetectCount As Boolean, _
    questId As Integer _
) As Boolean
public:
bool^ IsCompleteObjectiveIndex(
    int^ objectiveIndex,
    int^ objectiveRequiredCount,
    bool^ objectiveRequiredAutoDetectCount,
    int^ questId
)

Parameters

objectiveIndex
Type: Int32
Index of the objective.
objectiveRequiredCount
Type: Int32
The objective required count.
objectiveRequiredAutoDetectCount
Type: Boolean
if set to true detect automatically if objective is complete.
questId
Type: Int32
The quest id.

Return Value

true if quest objective index is complete; otherwise, false.

See Also

QuestClass Class
wManager.Wow.Class Namespace


PickUp Method

QuestClass..::..PickUp Method

Go to NPC and Pick up quest.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public virtual bool PickUp()
Public Overridable Function PickUp As Boolean
public:
virtual bool^ PickUp()

See Also

QuestClass Class
wManager.Wow.Class Namespace


Pulse Method

QuestClass..::..Pulse Method

Pulse quest

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public virtual bool Pulse()
Public Overridable Function Pulse As Boolean
public:
virtual bool^ Pulse()

See Also

QuestClass Class
wManager.Wow.Class Namespace


PulseAllInOne Method

QuestClass..::..PulseAllInOne Method

Pulses all in one (PickUp()()()(), Pulse()()()(), TurnIn()()()()).

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public virtual bool PulseAllInOne()
Public Overridable Function PulseAllInOne As Boolean
public:
virtual bool^ PulseAllInOne()

See Also

QuestClass Class
wManager.Wow.Class Namespace


Reset Method

QuestClass..::..Reset Method

Resets this instance (reset to default the progress). When you override this method don't forget to call method of super class.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public virtual bool Reset()
Public Overridable Function Reset As Boolean
public:
virtual bool^ Reset()

See Also

QuestClass Class
wManager.Wow.Class Namespace


TurnIn Method

QuestClass..::..TurnIn Method

Go to NPC and turn in quest.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public virtual bool TurnIn()
Public Overridable Function TurnIn As Boolean
public:
virtual bool^ TurnIn()

Return Value

true if XXXX, false otherwise.

See Also

QuestClass Class
wManager.Wow.Class Namespace


WhenLeaveStep Method

QuestClass..::..WhenLeaveStep Method

Called one time when the quester product leave this step (with Pulse or PulseAllInOne action).

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public virtual void WhenLeaveStep()
Public Overridable Sub WhenLeaveStep
public:
virtual void WhenLeaveStep()

See Also

QuestClass Class
wManager.Wow.Class Namespace


WhenSelectStep Method

QuestClass..::..WhenSelectStep Method

Called one time when the quester product select this step (with Pulse or PulseAllInOne action).

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public virtual void WhenSelectStep()
Public Overridable Sub WhenSelectStep
public:
virtual void WhenSelectStep()

See Also

QuestClass Class
wManager.Wow.Class Namespace


QuestClass Properties

The QuestClass type exposes the following members.

Properties

 | Name | Description
Public property | GossipOptionItem | Gets or sets the gossip option to use to select reward item.
Public property | NpcPickUp | Gets the NPC where pick up quest (search in NPCList).
Public property | NpcTurnIn | Gets the NPC to turn in quest (search in NPCList)..
Public property | QuestId | Gets or sets the quest IDs list.
Public property | Step | Gets or sets the quest objectives required count (example, if this quest need 5 kills for objective 3 use Step = new List<int> {0, 0, 5, 0, 0};.
Public property | StepAutoDetect | Gets or sets the quest objectives to auto detect if complete (example, if you want detect if the objective 4 is done StepAutoDetect = new List<bool> {false, false, false, true, false};.

See Also

QuestClass Class
wManager.Wow.Class Namespace


GossipOptionItem Property

QuestClass..::..GossipOptionItem Property

Gets or sets the gossip option to use to select reward item.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public virtual int GossipOptionItem { get; set; }
Public Overridable Property GossipOptionItem As Integer
    Get
    Set
public:
virtual property int^ GossipOptionItem {
    int^ get ();
    void set (int^ value);
}

See Also

QuestClass Class
wManager.Wow.Class Namespace


NpcPickUp Property

QuestClass..::..NpcPickUp Property

Gets the NPC where pick up quest (search in NPCList).

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public virtual NPCQuest NpcPickUp { get; }
Public Overridable ReadOnly Property NpcPickUp As NPCQuest
    Get
public:
virtual property NPCQuest^ NpcPickUp {
    NPCQuest^ get ();
}

See Also

QuestClass Class
wManager.Wow.Class Namespace


NpcTurnIn Property

QuestClass..::..NpcTurnIn Property

Gets the NPC to turn in quest (search in NPCList)..

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public virtual NPCQuest NpcTurnIn { get; }
Public Overridable ReadOnly Property NpcTurnIn As NPCQuest
    Get
public:
virtual property NPCQuest^ NpcTurnIn {
    NPCQuest^ get ();
}

See Also

QuestClass Class
wManager.Wow.Class Namespace


QuestId Property

QuestClass..::..QuestId Property

Gets or sets the quest IDs list.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public virtual List<int> QuestId { get; set; }
Public Overridable Property QuestId As List(Of Integer)
    Get
    Set
public:
virtual property List<int^>^ QuestId {
    List<int^>^ get ();
    void set (List<int^>^ value);
}

Field Value

The quest IDs.

See Also

QuestClass Class
wManager.Wow.Class Namespace


Step Property

QuestClass..::..Step Property

Gets or sets the quest objectives required count (example, if this quest need 5 kills for objective 3 use Step = new List<int> {0, 0, 5, 0, 0};.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public virtual List<int> Step { get; set; }
Public Overridable Property Step As List(Of Integer)
    Get
    Set
public:
virtual property List<int^>^ Step {
    List<int^>^ get ();
    void set (List<int^>^ value);
}

See Also

QuestClass Class
wManager.Wow.Class Namespace


StepAutoDetect Property

QuestClass..::..StepAutoDetect Property

Gets or sets the quest objectives to auto detect if complete (example, if you want detect if the objective 4 is done StepAutoDetect = new List<bool> {false, false, false, true, false};.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public virtual bool[] StepAutoDetect { get; set; }
Public Overridable Property StepAutoDetect As Boolean()
    Get
    Set
public:
virtual property array<bool^>^ StepAutoDetect {
    array<bool^>^ get ();
    void set (array<bool^>^ value);
}

See Also

QuestClass Class
wManager.Wow.Class Namespace


QuestEmptyClass Class

Class QuestEmptyClass. This class cannot be inherited. Implements the QuestClass

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public sealed class QuestEmptyClass : QuestClass
Public NotInheritable Class QuestEmptyClass _
    Inherits QuestClass
public ref class QuestEmptyClass sealed : public QuestClass

Inheritance Hierarchy

Object
wManager.Wow.Class..::..QuestClass
wManager.Wow.Class..::..QuestEmptyClass

See Also

wManager.Wow.Class Namespace
wManager.Wow.Class..::..QuestClass


QuestEmptyClass Methods

The QuestEmptyClass type exposes the following members.

Methods

 | Name | Description
Public method | CanConditions | Determines whether this can (by default this option return true, conditions can be added by override this method). (Inherited from QuestClass.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | HasQuest | Check if character have one of QuestId in his quest log. (Inherited from QuestClass.)
Public method | IsComplete | Determines if quest objective is complete (Step and StepAutoDetect). (Inherited from QuestClass.)
Public method | IsCompleted | Quest is completed (already turn in, or can't do (min/max level, required quest, character class)). (Inherited from QuestClass.)
Public method | IsCompleteObjectiveIndex | Determines whether is complete objective by objective index (Inherited from QuestClass.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | PickUp | Go to NPC and Pick up quest. (Inherited from QuestClass.)
Public method | Pulse | Pulse quest (Inherited from QuestClass.)
Public method | PulseAllInOne | Pulses all in one (PickUp()()()(), Pulse()()()(), TurnIn()()()()). (Inherited from QuestClass.)
Public method | Reset | Resets this instance (reset to default the progress). When you override this method don't forget to call method of super class. (Inherited from QuestClass.)
Public method | ToString | (Inherited from Object.)
Public method | TurnIn | Go to NPC and turn in quest. (Inherited from QuestClass.)
Public method | WhenLeaveStep | Called one time when the quester product leave this step (with Pulse or PulseAllInOne action). (Inherited from QuestClass.)
Public method | WhenSelectStep | Called one time when the quester product select this step (with Pulse or PulseAllInOne action). (Inherited from QuestClass.)

See Also

QuestEmptyClass Class
wManager.Wow.Class Namespace


QuestEmptyClass Properties

The QuestEmptyClass type exposes the following members.

Properties

 | Name | Description
Public property | GossipOptionItem | Gets or sets the gossip option to use to select reward item. (Inherited from QuestClass.)
Public property | NpcPickUp | Gets the NPC where pick up quest (search in NPCList). (Inherited from QuestClass.)
Public property | NpcTurnIn | Gets the NPC to turn in quest (search in NPCList).. (Inherited from QuestClass.)
Public property | QuestId | Gets or sets the quest IDs list. (Inherited from QuestClass.)
Public property | Step | Gets or sets the quest objectives required count (example, if this quest need 5 kills for objective 3 use Step = new List<int> {0, 0, 5, 0, 0};. (Inherited from QuestClass.)
Public property | StepAutoDetect | Gets or sets the quest objectives to auto detect if complete (example, if you want detect if the objective 4 is done StepAutoDetect = new List<bool> {false, false, false, true, false};. (Inherited from QuestClass.)

See Also

QuestEmptyClass Class
wManager.Wow.Class Namespace


QuestFollowNpcClass Class

Class QuestFollowNpcClass. Override this class when you need follow Npc. Implements the QuestClass

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public abstract class QuestFollowNpcClass : QuestClass
Public MustInherit Class QuestFollowNpcClass _
    Inherits QuestClass
public ref class QuestFollowNpcClass abstract : public QuestClass

Inheritance Hierarchy

Object
wManager.Wow.Class..::..QuestClass
wManager.Wow.Class..::..QuestFollowNpcClass

See Also

QuestFollowNpcClass Members
wManager.Wow.Class Namespace
wManager.Wow.Class..::..QuestClass


QuestFollowNpcClass Members

The QuestFollowNpcClass type exposes the following members.

Methods

 | Name | Description
Public method | CanConditions | Determines whether this can (by default this option return true, conditions can be added by override this method). (Inherited from QuestClass.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | HasQuest | Check if character have one of QuestId in his quest log. (Inherited from QuestClass.)
Public method | IsComplete | Determines if quest objective is complete (Step and StepAutoDetect). (Inherited from QuestClass.)
Public method | IsCompleted | Quest is completed (already turn in, or can't do (min/max level, required quest, character class)). (Inherited from QuestClass.)
Public method | IsCompleteObjectiveIndex | Determines whether is complete objective by objective index (Inherited from QuestClass.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | PickUp | Go to NPC and Pick up quest. (Inherited from QuestClass.)
Public method | Pulse | Pulse quest
Public method | PulseAllInOne | Pulses all in one (PickUp()()()(), Pulse()()()(), TurnIn()()()()). (Inherited from QuestClass.)
Public method | Reset | Resets this instance (reset to default the progress). When you override this method don't forget to call method of super class. (Inherited from QuestClass.)
Public method | ToString | (Inherited from Object.)
Public method | TurnIn | Go to NPC and turn in quest. (Inherited from QuestClass.)
Public method | WhenLeaveStep | Called one time when the quester product leave this step (with Pulse or PulseAllInOne action). (Inherited from QuestClass.)
Public method | WhenSelectStep | Called one time when the quester product select this step (with Pulse or PulseAllInOne action). (Inherited from QuestClass.)

Fields

 | Name | Description
Public field | Assist | Enable to assist npc (help him when attacked)
Public field | FollowDistance | The follow distance
Public field | NpcEntry | The NPC entry id to follow
Public field | StartPosition | The start position (where bot can found npc to follow, Vector3.Zero to don't use this option).

Properties

 | Name | Description
Public property | GossipOptionItem | Gets or sets the gossip option to use to select reward item. (Inherited from QuestClass.)
Public property | NpcPickUp | Gets the NPC where pick up quest (search in NPCList). (Inherited from QuestClass.)
Public property | NpcTurnIn | Gets the NPC to turn in quest (search in NPCList).. (Inherited from QuestClass.)
Public property | QuestId | Gets or sets the quest IDs list. (Inherited from QuestClass.)
Public property | Step | Gets or sets the quest objectives required count (example, if this quest need 5 kills for objective 3 use Step = new List<int> {0, 0, 5, 0, 0};. (Inherited from QuestClass.)
Public property | StepAutoDetect | Gets or sets the quest objectives to auto detect if complete (example, if you want detect if the objective 4 is done StepAutoDetect = new List<bool> {false, false, false, true, false};. (Inherited from QuestClass.)

See Also

QuestFollowNpcClass Class
wManager.Wow.Class Namespace


QuestFollowNpcClass Fields

The QuestFollowNpcClass type exposes the following members.

Fields

 | Name | Description
Public field | Assist | Enable to assist npc (help him when attacked)
Public field | FollowDistance | The follow distance
Public field | NpcEntry | The NPC entry id to follow
Public field | StartPosition | The start position (where bot can found npc to follow, Vector3.Zero to don't use this option).

See Also

QuestFollowNpcClass Class
wManager.Wow.Class Namespace


Assist Field

QuestFollowNpcClass..::..Assist Field

Enable to assist npc (help him when attacked)

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool Assist
Public Assist As Boolean
public:
bool^ Assist

See Also

QuestFollowNpcClass Class
wManager.Wow.Class Namespace


FollowDistance Field

QuestFollowNpcClass..::..FollowDistance Field

The follow distance

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float FollowDistance
Public FollowDistance As Single
public:
float^ FollowDistance

See Also

QuestFollowNpcClass Class
wManager.Wow.Class Namespace


NpcEntry Field

QuestFollowNpcClass..::..NpcEntry Field

The NPC entry id to follow

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int NpcEntry
Public NpcEntry As Integer
public:
int^ NpcEntry

See Also

QuestFollowNpcClass Class
wManager.Wow.Class Namespace


StartPosition Field

QuestFollowNpcClass..::..StartPosition Field

The start position (where bot can found npc to follow, Vector3.Zero to don't use this option).

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Vector3 StartPosition
Public StartPosition As Vector3
public:
Vector3^ StartPosition

See Also

QuestFollowNpcClass Class
wManager.Wow.Class Namespace


QuestFollowNpcClass Methods

The QuestFollowNpcClass type exposes the following members.

Methods

 | Name | Description
Public method | CanConditions | Determines whether this can (by default this option return true, conditions can be added by override this method). (Inherited from QuestClass.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | HasQuest | Check if character have one of QuestId in his quest log. (Inherited from QuestClass.)
Public method | IsComplete | Determines if quest objective is complete (Step and StepAutoDetect). (Inherited from QuestClass.)
Public method | IsCompleted | Quest is completed (already turn in, or can't do (min/max level, required quest, character class)). (Inherited from QuestClass.)
Public method | IsCompleteObjectiveIndex | Determines whether is complete objective by objective index (Inherited from QuestClass.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | PickUp | Go to NPC and Pick up quest. (Inherited from QuestClass.)
Public method | Pulse | Pulse quest
Public method | PulseAllInOne | Pulses all in one (PickUp()()()(), Pulse()()()(), TurnIn()()()()). (Inherited from QuestClass.)
Public method | Reset | Resets this instance (reset to default the progress). When you override this method don't forget to call method of super class. (Inherited from QuestClass.)
Public method | ToString | (Inherited from Object.)
Public method | TurnIn | Go to NPC and turn in quest. (Inherited from QuestClass.)
Public method | WhenLeaveStep | Called one time when the quester product leave this step (with Pulse or PulseAllInOne action). (Inherited from QuestClass.)
Public method | WhenSelectStep | Called one time when the quester product select this step (with Pulse or PulseAllInOne action). (Inherited from QuestClass.)

See Also

QuestFollowNpcClass Class
wManager.Wow.Class Namespace


Pulse Method

QuestFollowNpcClass..::..Pulse Method

Pulse quest

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool Pulse()
Public Function Pulse As Boolean
public:
bool^ Pulse()

See Also

QuestFollowNpcClass Class
wManager.Wow.Class Namespace


QuestFollowNpcClass Properties

The QuestFollowNpcClass type exposes the following members.

Properties

 | Name | Description
Public property | GossipOptionItem | Gets or sets the gossip option to use to select reward item. (Inherited from QuestClass.)
Public property | NpcPickUp | Gets the NPC where pick up quest (search in NPCList). (Inherited from QuestClass.)
Public property | NpcTurnIn | Gets the NPC to turn in quest (search in NPCList).. (Inherited from QuestClass.)
Public property | QuestId | Gets or sets the quest IDs list. (Inherited from QuestClass.)
Public property | Step | Gets or sets the quest objectives required count (example, if this quest need 5 kills for objective 3 use Step = new List<int> {0, 0, 5, 0, 0};. (Inherited from QuestClass.)
Public property | StepAutoDetect | Gets or sets the quest objectives to auto detect if complete (example, if you want detect if the objective 4 is done StepAutoDetect = new List<bool> {false, false, false, true, false};. (Inherited from QuestClass.)

See Also

QuestFollowNpcClass Class
wManager.Wow.Class Namespace


QuestFollowPathClass Class

Class QuestFollowPathClass. Override this class when you need to use a precise path or when quest objectives is to go to specific position. Implements the QuestClass

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public abstract class QuestFollowPathClass : QuestClass
Public MustInherit Class QuestFollowPathClass _
    Inherits QuestClass
public ref class QuestFollowPathClass abstract : public QuestClass

Inheritance Hierarchy

Object
wManager.Wow.Class..::..QuestClass
wManager.Wow.Class..::..QuestFollowPathClass

See Also

QuestFollowPathClass Members
wManager.Wow.Class Namespace
wManager.Wow.Class..::..QuestClass


QuestFollowPathClass Members

The QuestFollowPathClass type exposes the following members.

Methods

 | Name | Description
Public method | CanConditions | Determines whether this can (by default this option return true, conditions can be added by override this method). (Inherited from QuestClass.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | HasQuest | Check if character have one of QuestId in his quest log. (Inherited from QuestClass.)
Public method | IsComplete | if you use option IsCompleteWhenAtLastPath this method return true when at last path position, else return value of super class method.
Public method | IsCompleted | Quest is completed (already turn in, or can't do (min/max level, required quest, character class)). (Inherited from QuestClass.)
Public method | IsCompleteObjectiveIndex | Determines whether is complete objective by objective index (Inherited from QuestClass.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | PickUp | Go to NPC and Pick up quest. (Inherited from QuestClass.)
Public method | Pulse | Pulse quest
Public method | PulseAllInOne | Pulses all in one (PickUp()()()(), Pulse()()()(), TurnIn()()()()). (Inherited from QuestClass.)
Public method | Reset | Resets this instance, useful for the option ForceToStartFirstPosition.
Public method | ToString | (Inherited from Object.)
Public method | TurnIn | Go to NPC and turn in quest. (Inherited from QuestClass.)
Public method | WhenLeaveStep | Called one time when the quester product leave this step (with Pulse or PulseAllInOne action). (Inherited from QuestClass.)
Public method | WhenSelectStep | Called one time when the quester product select this step (with Pulse or PulseAllInOne action). (Inherited from QuestClass.)

Fields

 | Name | Description
Public field | ForceToStartFirstPosition | Force to start from first path position (you need to call Reset()()()() before usage if you use this quest several time and use this option)
Public field | IsCompleteWhenAtLastPath | This quest objective is complete when at last position of path (go to next profile step).
Public field | IsHotSpots | Path is hotspots (and not path).
Public field | IsLoop | To run Path in loop (return to the first when to the last path position)
Public field | Path | The path to follow

Properties

 | Name | Description
Public property | GossipOptionItem | Gets or sets the gossip option to use to select reward item. (Inherited from QuestClass.)
Public property | NpcPickUp | Gets the NPC where pick up quest (search in NPCList). (Inherited from QuestClass.)
Public property | NpcTurnIn | Gets the NPC to turn in quest (search in NPCList).. (Inherited from QuestClass.)
Public property | QuestId | Gets or sets the quest IDs list. (Inherited from QuestClass.)
Public property | Step | Gets or sets the quest objectives required count (example, if this quest need 5 kills for objective 3 use Step = new List<int> {0, 0, 5, 0, 0};. (Inherited from QuestClass.)
Public property | StepAutoDetect | Gets or sets the quest objectives to auto detect if complete (example, if you want detect if the objective 4 is done StepAutoDetect = new List<bool> {false, false, false, true, false};. (Inherited from QuestClass.)

See Also

QuestFollowPathClass Class
wManager.Wow.Class Namespace


QuestFollowPathClass Fields

The QuestFollowPathClass type exposes the following members.

Fields

 | Name | Description
Public field | ForceToStartFirstPosition | Force to start from first path position (you need to call Reset()()()() before usage if you use this quest several time and use this option)
Public field | IsCompleteWhenAtLastPath | This quest objective is complete when at last position of path (go to next profile step).
Public field | IsHotSpots | Path is hotspots (and not path).
Public field | IsLoop | To run Path in loop (return to the first when to the last path position)
Public field | Path | The path to follow

See Also

QuestFollowPathClass Class
wManager.Wow.Class Namespace


ForceToStartFirstPosition Field

QuestFollowPathClass..::..ForceToStartFirstPosition Field

Force to start from first path position (you need to call Reset()()()() before usage if you use this quest several time and use this option)

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool ForceToStartFirstPosition
Public ForceToStartFirstPosition As Boolean
public:
bool^ ForceToStartFirstPosition

See Also

QuestFollowPathClass Class
wManager.Wow.Class Namespace


IsCompleteWhenAtLastPath Field

QuestFollowPathClass..::..IsCompleteWhenAtLastPath Field

This quest objective is complete when at last position of path (go to next profile step).

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsCompleteWhenAtLastPath
Public IsCompleteWhenAtLastPath As Boolean
public:
bool^ IsCompleteWhenAtLastPath

See Also

QuestFollowPathClass Class
wManager.Wow.Class Namespace


IsHotSpots Field

QuestFollowPathClass..::..IsHotSpots Field

Path is hotspots (and not path).

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsHotSpots
Public IsHotSpots As Boolean
public:
bool^ IsHotSpots

See Also

QuestFollowPathClass Class
wManager.Wow.Class Namespace


IsLoop Field

QuestFollowPathClass..::..IsLoop Field

To run Path in loop (return to the first when to the last path position)

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsLoop
Public IsLoop As Boolean
public:
bool^ IsLoop

See Also

QuestFollowPathClass Class
wManager.Wow.Class Namespace


Path Field

QuestFollowPathClass..::..Path Field

The path to follow

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<Vector3> Path
Public Path As List(Of Vector3)
public:
List<Vector3^>^ Path

See Also

QuestFollowPathClass Class
wManager.Wow.Class Namespace


QuestFollowPathClass Methods

The QuestFollowPathClass type exposes the following members.

Methods

 | Name | Description
Public method | CanConditions | Determines whether this can (by default this option return true, conditions can be added by override this method). (Inherited from QuestClass.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | HasQuest | Check if character have one of QuestId in his quest log. (Inherited from QuestClass.)
Public method | IsComplete | if you use option IsCompleteWhenAtLastPath this method return true when at last path position, else return value of super class method.
Public method | IsCompleted | Quest is completed (already turn in, or can't do (min/max level, required quest, character class)). (Inherited from QuestClass.)
Public method | IsCompleteObjectiveIndex | Determines whether is complete objective by objective index (Inherited from QuestClass.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | PickUp | Go to NPC and Pick up quest. (Inherited from QuestClass.)
Public method | Pulse | Pulse quest
Public method | PulseAllInOne | Pulses all in one (PickUp()()()(), Pulse()()()(), TurnIn()()()()). (Inherited from QuestClass.)
Public method | Reset | Resets this instance, useful for the option ForceToStartFirstPosition.
Public method | ToString | (Inherited from Object.)
Public method | TurnIn | Go to NPC and turn in quest. (Inherited from QuestClass.)
Public method | WhenLeaveStep | Called one time when the quester product leave this step (with Pulse or PulseAllInOne action). (Inherited from QuestClass.)
Public method | WhenSelectStep | Called one time when the quester product select this step (with Pulse or PulseAllInOne action). (Inherited from QuestClass.)

See Also

QuestFollowPathClass Class
wManager.Wow.Class Namespace


IsComplete Method

QuestFollowPathClass..::..IsComplete Method

if you use option IsCompleteWhenAtLastPath this method return true when at last path position, else return value of super class method.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsComplete()
Public Function IsComplete As Boolean
public:
bool^ IsComplete()

See Also

QuestFollowPathClass Class
wManager.Wow.Class Namespace


Pulse Method

QuestFollowPathClass..::..Pulse Method

Pulse quest

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool Pulse()
Public Function Pulse As Boolean
public:
bool^ Pulse()

See Also

QuestFollowPathClass Class
wManager.Wow.Class Namespace


Reset Method

QuestFollowPathClass..::..Reset Method

Resets this instance, useful for the option ForceToStartFirstPosition.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool Reset()
Public Function Reset As Boolean
public:
bool^ Reset()

See Also

QuestFollowPathClass Class
wManager.Wow.Class Namespace


QuestFollowPathClass Properties

The QuestFollowPathClass type exposes the following members.

Properties

 | Name | Description
Public property | GossipOptionItem | Gets or sets the gossip option to use to select reward item. (Inherited from QuestClass.)
Public property | NpcPickUp | Gets the NPC where pick up quest (search in NPCList). (Inherited from QuestClass.)
Public property | NpcTurnIn | Gets the NPC to turn in quest (search in NPCList).. (Inherited from QuestClass.)
Public property | QuestId | Gets or sets the quest IDs list. (Inherited from QuestClass.)
Public property | Step | Gets or sets the quest objectives required count (example, if this quest need 5 kills for objective 3 use Step = new List<int> {0, 0, 5, 0, 0};. (Inherited from QuestClass.)
Public property | StepAutoDetect | Gets or sets the quest objectives to auto detect if complete (example, if you want detect if the objective 4 is done StepAutoDetect = new List<bool> {false, false, false, true, false};. (Inherited from QuestClass.)

See Also

QuestFollowPathClass Class
wManager.Wow.Class Namespace


QuestGathererClass Class

Class QuestGathererClass. Override this class when quest objectives is to harvest objects. Implements the QuestClass

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public abstract class QuestGathererClass : QuestClass
Public MustInherit Class QuestGathererClass _
    Inherits QuestClass
public ref class QuestGathererClass abstract : public QuestClass

Inheritance Hierarchy

Object
wManager.Wow.Class..::..QuestClass
wManager.Wow.Class..::..QuestGathererClass

See Also

QuestGathererClass Members
wManager.Wow.Class Namespace
wManager.Wow.Class..::..QuestClass


QuestGathererClass Members

The QuestGathererClass type exposes the following members.

Methods

 | Name | Description
Public method | CanConditions | Determines whether this can (by default this option return true, conditions can be added by override this method). (Inherited from QuestClass.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | HasQuest | Check if character have one of QuestId in his quest log. (Inherited from QuestClass.)
Public method | IsComplete | Determines if quest objective is complete (Step and StepAutoDetect). (Inherited from QuestClass.)
Public method | IsCompleted | Quest is completed (already turn in, or can't do (min/max level, required quest, character class)). (Inherited from QuestClass.)
Public method | IsCompleteObjectiveIndex | Determines whether is complete objective by objective index (Inherited from QuestClass.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | PickUp | Go to NPC and Pick up quest. (Inherited from QuestClass.)
Public method | Pulse | Pulse quest
Public method | PulseAllInOne | Pulses all in one (PickUp()()()(), Pulse()()()(), TurnIn()()()()). (Inherited from QuestClass.)
Public method | Reset | Resets this instance (reset to default the progress). When you override this method don't forget to call method of super class. (Inherited from QuestClass.)
Public method | ToString | (Inherited from Object.)
Public method | TurnIn | Go to NPC and turn in quest. (Inherited from QuestClass.)
Public method | WhenLeaveStep | Called one time when the quester product leave this step (with Pulse or PulseAllInOne action). (Inherited from QuestClass.)
Public method | WhenSelectStep | Called one time when the quester product select this step (with Pulse or PulseAllInOne action). (Inherited from QuestClass.)

Fields

 | Name | Description
Public field | EntryIdObjects | The Entry of objects to harvests.
Public field | HotSpots | The hot spots
Public field | IsHotspots | The hotspots (positions to explore, bot will generate paths between your the hotspots)

Properties

 | Name | Description
Public property | GossipOptionItem | Gets or sets the gossip option to use to select reward item. (Inherited from QuestClass.)
Public property | NpcPickUp | Gets the NPC where pick up quest (search in NPCList). (Inherited from QuestClass.)
Public property | NpcTurnIn | Gets the NPC to turn in quest (search in NPCList).. (Inherited from QuestClass.)
Public property | QuestId | Gets or sets the quest IDs list. (Inherited from QuestClass.)
Public property | Step | Gets or sets the quest objectives required count (example, if this quest need 5 kills for objective 3 use Step = new List<int> {0, 0, 5, 0, 0};. (Inherited from QuestClass.)
Public property | StepAutoDetect | Gets or sets the quest objectives to auto detect if complete (example, if you want detect if the objective 4 is done StepAutoDetect = new List<bool> {false, false, false, true, false};. (Inherited from QuestClass.)

See Also

QuestGathererClass Class
wManager.Wow.Class Namespace


QuestGathererClass Fields

The QuestGathererClass type exposes the following members.

Fields

 | Name | Description
Public field | EntryIdObjects | The Entry of objects to harvests.
Public field | HotSpots | The hot spots
Public field | IsHotspots | The hotspots (positions to explore, bot will generate paths between your the hotspots)

See Also

QuestGathererClass Class
wManager.Wow.Class Namespace


EntryIdObjects Field

QuestGathererClass..::..EntryIdObjects Field

The Entry of objects to harvests.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<int> EntryIdObjects
Public EntryIdObjects As List(Of Integer)
public:
List<int^>^ EntryIdObjects

See Also

QuestGathererClass Class
wManager.Wow.Class Namespace


HotSpots Field

QuestGathererClass..::..HotSpots Field

The hot spots

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<Vector3> HotSpots
Public HotSpots As List(Of Vector3)
public:
List<Vector3^>^ HotSpots

See Also

QuestGathererClass Class
wManager.Wow.Class Namespace


IsHotspots Field

QuestGathererClass..::..IsHotspots Field

The hotspots (positions to explore, bot will generate paths between your the hotspots)

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsHotspots
Public IsHotspots As Boolean
public:
bool^ IsHotspots

See Also

QuestGathererClass Class
wManager.Wow.Class Namespace


QuestGathererClass Methods

The QuestGathererClass type exposes the following members.

Methods

 | Name | Description
Public method | CanConditions | Determines whether this can (by default this option return true, conditions can be added by override this method). (Inherited from QuestClass.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | HasQuest | Check if character have one of QuestId in his quest log. (Inherited from QuestClass.)
Public method | IsComplete | Determines if quest objective is complete (Step and StepAutoDetect). (Inherited from QuestClass.)
Public method | IsCompleted | Quest is completed (already turn in, or can't do (min/max level, required quest, character class)). (Inherited from QuestClass.)
Public method | IsCompleteObjectiveIndex | Determines whether is complete objective by objective index (Inherited from QuestClass.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | PickUp | Go to NPC and Pick up quest. (Inherited from QuestClass.)
Public method | Pulse | Pulse quest
Public method | PulseAllInOne | Pulses all in one (PickUp()()()(), Pulse()()()(), TurnIn()()()()). (Inherited from QuestClass.)
Public method | Reset | Resets this instance (reset to default the progress). When you override this method don't forget to call method of super class. (Inherited from QuestClass.)
Public method | ToString | (Inherited from Object.)
Public method | TurnIn | Go to NPC and turn in quest. (Inherited from QuestClass.)
Public method | WhenLeaveStep | Called one time when the quester product leave this step (with Pulse or PulseAllInOne action). (Inherited from QuestClass.)
Public method | WhenSelectStep | Called one time when the quester product select this step (with Pulse or PulseAllInOne action). (Inherited from QuestClass.)

See Also

QuestGathererClass Class
wManager.Wow.Class Namespace


Pulse Method

QuestGathererClass..::..Pulse Method

Pulse quest

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool Pulse()
Public Function Pulse As Boolean
public:
bool^ Pulse()

See Also

QuestGathererClass Class
wManager.Wow.Class Namespace


QuestGathererClass Properties

The QuestGathererClass type exposes the following members.

Properties

 | Name | Description
Public property | GossipOptionItem | Gets or sets the gossip option to use to select reward item. (Inherited from QuestClass.)
Public property | NpcPickUp | Gets the NPC where pick up quest (search in NPCList). (Inherited from QuestClass.)
Public property | NpcTurnIn | Gets the NPC to turn in quest (search in NPCList).. (Inherited from QuestClass.)
Public property | QuestId | Gets or sets the quest IDs list. (Inherited from QuestClass.)
Public property | Step | Gets or sets the quest objectives required count (example, if this quest need 5 kills for objective 3 use Step = new List<int> {0, 0, 5, 0, 0};. (Inherited from QuestClass.)
Public property | StepAutoDetect | Gets or sets the quest objectives to auto detect if complete (example, if you want detect if the objective 4 is done StepAutoDetect = new List<bool> {false, false, false, true, false};. (Inherited from QuestClass.)

See Also

QuestGathererClass Class
wManager.Wow.Class Namespace


QuestGrinderClass Class

Class QuestGrinderClass. Override this class when quest objectives is to kills mobs. Implements the QuestClass

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public abstract class QuestGrinderClass : QuestClass
Public MustInherit Class QuestGrinderClass _
    Inherits QuestClass
public ref class QuestGrinderClass abstract : public QuestClass

Inheritance Hierarchy

Object
wManager.Wow.Class..::..QuestClass
wManager.Wow.Class..::..QuestGrinderClass

See Also

QuestGrinderClass Members
wManager.Wow.Class Namespace
wManager.Wow.Class..::..QuestClass


QuestGrinderClass Members

The QuestGrinderClass type exposes the following members.

Methods

 | Name | Description
Public method | CanConditions | Determines whether this can (by default this option return true, conditions can be added by override this method). (Inherited from QuestClass.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | HasQuest | Check if character have one of QuestId in his quest log, if you use option IsGrinderNotQuest this method check min/max level.
Public method | IsComplete | Determines if quest objective is complete (Step and StepAutoDetect), if you use option IsGrinderNotQuest this method check min/max level.
Public method | IsCompleted | Quest is completed (already turn in, or can't do (min/max level, required quest, character class)). (Inherited from QuestClass.)
Public method | IsCompleteObjectiveIndex | Determines whether is complete objective by objective index (Inherited from QuestClass.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | PickUp | Go to NPC and Pick up quest. (Inherited from QuestClass.)
Public method | Pulse | Pulse quest
Public method | PulseAllInOne | Pulses all in one (PickUp()()()(), Pulse()()()(), TurnIn()()()()). (Inherited from QuestClass.)
Public method | Reset | Resets this instance (reset to default the progress). When you override this method don't forget to call method of super class. (Inherited from QuestClass.)
Public method | ToString | (Inherited from Object.)
Public method | TurnIn | Go to NPC and turn in quest. (Inherited from QuestClass.)
Public method | WhenLeaveStep | Called one time when the quester product leave this step (with Pulse or PulseAllInOne action). (Inherited from QuestClass.)
Public method | WhenSelectStep | Called one time when the quester product select this step (with Pulse or PulseAllInOne action). (Inherited from QuestClass.)

Fields

 | Name | Description
Public field | EntryTarget | The Entry of mobs to kills.
Public field | FactionsTarget | The Faction of mobs to kills (it is better to use EntryTarget).
Public field | HotSpots | The hotspots (positions to explore, bot will generate paths between your the hotspots)
Public field | IsGrinderNotQuest | Enable this option if you don't need quest to run this quest (in this case don't forget to assigns MinLevel and MaxLevel).
Public field | IsHotspots | It is hotspots (if disabled, bot won't generate paths between your HotSpots).

Properties

 | Name | Description
Public property | GossipOptionItem | Gets or sets the gossip option to use to select reward item. (Inherited from QuestClass.)
Public property | NpcPickUp | Gets the NPC where pick up quest (search in NPCList). (Inherited from QuestClass.)
Public property | NpcTurnIn | Gets the NPC to turn in quest (search in NPCList).. (Inherited from QuestClass.)
Public property | QuestId | Gets or sets the quest IDs list. (Inherited from QuestClass.)
Public property | Step | Gets or sets the quest objectives required count (example, if this quest need 5 kills for objective 3 use Step = new List<int> {0, 0, 5, 0, 0};. (Inherited from QuestClass.)
Public property | StepAutoDetect | Gets or sets the quest objectives to auto detect if complete (example, if you want detect if the objective 4 is done StepAutoDetect = new List<bool> {false, false, false, true, false};. (Inherited from QuestClass.)

See Also

QuestGrinderClass Class
wManager.Wow.Class Namespace


QuestGrinderClass Fields

The QuestGrinderClass type exposes the following members.

Fields

 | Name | Description
Public field | EntryTarget | The Entry of mobs to kills.
Public field | FactionsTarget | The Faction of mobs to kills (it is better to use EntryTarget).
Public field | HotSpots | The hotspots (positions to explore, bot will generate paths between your the hotspots)
Public field | IsGrinderNotQuest | Enable this option if you don't need quest to run this quest (in this case don't forget to assigns MinLevel and MaxLevel).
Public field | IsHotspots | It is hotspots (if disabled, bot won't generate paths between your HotSpots).

See Also

QuestGrinderClass Class
wManager.Wow.Class Namespace


EntryTarget Field

QuestGrinderClass..::..EntryTarget Field

The Entry of mobs to kills.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<int> EntryTarget
Public EntryTarget As List(Of Integer)
public:
List<int^>^ EntryTarget

See Also

QuestGrinderClass Class
wManager.Wow.Class Namespace


FactionsTarget Field

QuestGrinderClass..::..FactionsTarget Field

The Faction of mobs to kills (it is better to use EntryTarget).

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<uint> FactionsTarget
Public FactionsTarget As List(Of UInteger)
public:
List<unsigned int^>^ FactionsTarget

See Also

QuestGrinderClass Class
wManager.Wow.Class Namespace


HotSpots Field

QuestGrinderClass..::..HotSpots Field

The hotspots (positions to explore, bot will generate paths between your the hotspots)

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<Vector3> HotSpots
Public HotSpots As List(Of Vector3)
public:
List<Vector3^>^ HotSpots

See Also

QuestGrinderClass Class
wManager.Wow.Class Namespace


IsGrinderNotQuest Field

QuestGrinderClass..::..IsGrinderNotQuest Field

Enable this option if you don't need quest to run this quest (in this case don't forget to assigns MinLevel and MaxLevel).

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsGrinderNotQuest
Public IsGrinderNotQuest As Boolean
public:
bool^ IsGrinderNotQuest

See Also

QuestGrinderClass Class
wManager.Wow.Class Namespace


IsHotspots Field

QuestGrinderClass..::..IsHotspots Field

It is hotspots (if disabled, bot won't generate paths between your HotSpots).

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsHotspots
Public IsHotspots As Boolean
public:
bool^ IsHotspots

See Also

QuestGrinderClass Class
wManager.Wow.Class Namespace


QuestGrinderClass Methods

The QuestGrinderClass type exposes the following members.

Methods

 | Name | Description
Public method | CanConditions | Determines whether this can (by default this option return true, conditions can be added by override this method). (Inherited from QuestClass.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | HasQuest | Check if character have one of QuestId in his quest log, if you use option IsGrinderNotQuest this method check min/max level.
Public method | IsComplete | Determines if quest objective is complete (Step and StepAutoDetect), if you use option IsGrinderNotQuest this method check min/max level.
Public method | IsCompleted | Quest is completed (already turn in, or can't do (min/max level, required quest, character class)). (Inherited from QuestClass.)
Public method | IsCompleteObjectiveIndex | Determines whether is complete objective by objective index (Inherited from QuestClass.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | PickUp | Go to NPC and Pick up quest. (Inherited from QuestClass.)
Public method | Pulse | Pulse quest
Public method | PulseAllInOne | Pulses all in one (PickUp()()()(), Pulse()()()(), TurnIn()()()()). (Inherited from QuestClass.)
Public method | Reset | Resets this instance (reset to default the progress). When you override this method don't forget to call method of super class. (Inherited from QuestClass.)
Public method | ToString | (Inherited from Object.)
Public method | TurnIn | Go to NPC and turn in quest. (Inherited from QuestClass.)
Public method | WhenLeaveStep | Called one time when the quester product leave this step (with Pulse or PulseAllInOne action). (Inherited from QuestClass.)
Public method | WhenSelectStep | Called one time when the quester product select this step (with Pulse or PulseAllInOne action). (Inherited from QuestClass.)

See Also

QuestGrinderClass Class
wManager.Wow.Class Namespace


HasQuest Method

QuestGrinderClass..::..HasQuest Method

Check if character have one of QuestId in his quest log, if you use option IsGrinderNotQuest this method check min/max level.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool HasQuest()
Public Function HasQuest As Boolean
public:
bool^ HasQuest()

See Also

QuestGrinderClass Class
wManager.Wow.Class Namespace


IsComplete Method

QuestGrinderClass..::..IsComplete Method

Determines if quest objective is complete (Step and StepAutoDetect), if you use option IsGrinderNotQuest this method check min/max level.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsComplete()
Public Function IsComplete As Boolean
public:
bool^ IsComplete()

See Also

QuestGrinderClass Class
wManager.Wow.Class Namespace


Pulse Method

QuestGrinderClass..::..Pulse Method

Pulse quest

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool Pulse()
Public Function Pulse As Boolean
public:
bool^ Pulse()

See Also

QuestGrinderClass Class
wManager.Wow.Class Namespace


QuestGrinderClass Properties

The QuestGrinderClass type exposes the following members.

Properties

 | Name | Description
Public property | GossipOptionItem | Gets or sets the gossip option to use to select reward item. (Inherited from QuestClass.)
Public property | NpcPickUp | Gets the NPC where pick up quest (search in NPCList). (Inherited from QuestClass.)
Public property | NpcTurnIn | Gets the NPC to turn in quest (search in NPCList).. (Inherited from QuestClass.)
Public property | QuestId | Gets or sets the quest IDs list. (Inherited from QuestClass.)
Public property | Step | Gets or sets the quest objectives required count (example, if this quest need 5 kills for objective 3 use Step = new List<int> {0, 0, 5, 0, 0};. (Inherited from QuestClass.)
Public property | StepAutoDetect | Gets or sets the quest objectives to auto detect if complete (example, if you want detect if the objective 4 is done StepAutoDetect = new List<bool> {false, false, false, true, false};. (Inherited from QuestClass.)

See Also

QuestGrinderClass Class
wManager.Wow.Class Namespace


QuestGrinderGathererClass Class

Class QuestGrinderGathererClass. Override this class when quest objectives is to kills mobs and harvest objects. Implements the QuestClass

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public abstract class QuestGrinderGathererClass : QuestClass
Public MustInherit Class QuestGrinderGathererClass _
    Inherits QuestClass
public ref class QuestGrinderGathererClass abstract : public QuestClass

Inheritance Hierarchy

Object
wManager.Wow.Class..::..QuestClass
wManager.Wow.Class..::..QuestGrinderGathererClass

See Also

QuestGrinderGathererClass Members
wManager.Wow.Class Namespace
wManager.Wow.Class..::..QuestClass


QuestGrinderGathererClass Members

The QuestGrinderGathererClass type exposes the following members.

Methods

 | Name | Description
Public method | CanConditions | Determines whether this can (by default this option return true, conditions can be added by override this method). (Inherited from QuestClass.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | HasQuest | Check if character have one of QuestId in his quest log, if you use option IsGrinderNotQuest this method check min/max level.
Public method | IsComplete | Determines if quest objective is complete (Step and StepAutoDetect), if you use option IsGrinderNotQuest this method check min/max level.
Public method | IsCompleted | Quest is completed (already turn in, or can't do (min/max level, required quest, character class)). (Inherited from QuestClass.)
Public method | IsCompleteObjectiveIndex | Determines whether is complete objective by objective index (Inherited from QuestClass.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | PickUp | Go to NPC and Pick up quest. (Inherited from QuestClass.)
Public method | Pulse | Pulse quest
Public method | PulseAllInOne | Pulses all in one (PickUp()()()(), Pulse()()()(), TurnIn()()()()). (Inherited from QuestClass.)
Public method | Reset | Resets this instance (reset to default the progress). When you override this method don't forget to call method of super class.
Public method | ToString | (Inherited from Object.)
Public method | TurnIn | Go to NPC and turn in quest. (Inherited from QuestClass.)
Public method | WhenLeaveStep | Called one time when the quester product leave this step (with Pulse or PulseAllInOne action). (Inherited from QuestClass.)
Public method | WhenSelectStep | Called one time when the quester product select this step (with Pulse or PulseAllInOne action). (Inherited from QuestClass.)

Fields

 | Name | Description
Public field | EntryGathererTarget | The Entry of objects to harvests.
Public field | EntryGrinderTarget | The Entry of mobs to kills.
Public field | HotSpots | The hotspots (positions to explore, bot will generate paths between your the hotspots)
Public field | IsGrinderNotQuest | Enable this option if you don't need quest to run this quest (in this case don't forget to assigns MinLevel and MaxLevel).
Public field | IsHotspots | It is hotspots (if disabled, bot won't generate paths between your HotSpots).
Public field | RandomizePositions | Randomize positions (if enabled, bot will go to random positions, don't forget to setting RandomizePositionsRadius).
Public field | RandomizePositionsRadius | Maximum distance from position (HotSpots) to randomized position (don't forget to activate option RandomizePositions)..

Properties

 | Name | Description
Public property | GossipOptionItem | Gets or sets the gossip option to use to select reward item. (Inherited from QuestClass.)
Public property | NpcPickUp | Gets the NPC where pick up quest (search in NPCList). (Inherited from QuestClass.)
Public property | NpcTurnIn | Gets the NPC to turn in quest (search in NPCList).. (Inherited from QuestClass.)
Public property | QuestId | Gets or sets the quest IDs list. (Inherited from QuestClass.)
Public property | Step | Gets or sets the quest objectives required count (example, if this quest need 5 kills for objective 3 use Step = new List<int> {0, 0, 5, 0, 0};. (Inherited from QuestClass.)
Public property | StepAutoDetect | Gets or sets the quest objectives to auto detect if complete (example, if you want detect if the objective 4 is done StepAutoDetect = new List<bool> {false, false, false, true, false};. (Inherited from QuestClass.)

See Also

QuestGrinderGathererClass Class
wManager.Wow.Class Namespace


QuestGrinderGathererClass Fields

The QuestGrinderGathererClass type exposes the following members.

Fields

 | Name | Description
Public field | EntryGathererTarget | The Entry of objects to harvests.
Public field | EntryGrinderTarget | The Entry of mobs to kills.
Public field | HotSpots | The hotspots (positions to explore, bot will generate paths between your the hotspots)
Public field | IsGrinderNotQuest | Enable this option if you don't need quest to run this quest (in this case don't forget to assigns MinLevel and MaxLevel).
Public field | IsHotspots | It is hotspots (if disabled, bot won't generate paths between your HotSpots).
Public field | RandomizePositions | Randomize positions (if enabled, bot will go to random positions, don't forget to setting RandomizePositionsRadius).
Public field | RandomizePositionsRadius | Maximum distance from position (HotSpots) to randomized position (don't forget to activate option RandomizePositions)..

See Also

QuestGrinderGathererClass Class
wManager.Wow.Class Namespace


EntryGathererTarget Field

QuestGrinderGathererClass..::..EntryGathererTarget Field

The Entry of objects to harvests.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<EntryIndexQuest> EntryGathererTarget
Public EntryGathererTarget As List(Of EntryIndexQuest)
public:
List<EntryIndexQuest^>^ EntryGathererTarget

See Also

QuestGrinderGathererClass Class
wManager.Wow.Class Namespace


EntryGrinderTarget Field

QuestGrinderGathererClass..::..EntryGrinderTarget Field

The Entry of mobs to kills.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<EntryIndexQuest> EntryGrinderTarget
Public EntryGrinderTarget As List(Of EntryIndexQuest)
public:
List<EntryIndexQuest^>^ EntryGrinderTarget

See Also

QuestGrinderGathererClass Class
wManager.Wow.Class Namespace


HotSpots Field

QuestGrinderGathererClass..::..HotSpots Field

The hotspots (positions to explore, bot will generate paths between your the hotspots)

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<Vector3> HotSpots
Public HotSpots As List(Of Vector3)
public:
List<Vector3^>^ HotSpots

See Also

QuestGrinderGathererClass Class
wManager.Wow.Class Namespace


IsGrinderNotQuest Field

QuestGrinderGathererClass..::..IsGrinderNotQuest Field

Enable this option if you don't need quest to run this quest (in this case don't forget to assigns MinLevel and MaxLevel).

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsGrinderNotQuest
Public IsGrinderNotQuest As Boolean
public:
bool^ IsGrinderNotQuest

See Also

QuestGrinderGathererClass Class
wManager.Wow.Class Namespace


IsHotspots Field

QuestGrinderGathererClass..::..IsHotspots Field

It is hotspots (if disabled, bot won't generate paths between your HotSpots).

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsHotspots
Public IsHotspots As Boolean
public:
bool^ IsHotspots

See Also

QuestGrinderGathererClass Class
wManager.Wow.Class Namespace


RandomizePositions Field

QuestGrinderGathererClass..::..RandomizePositions Field

Randomize positions (if enabled, bot will go to random positions, don't forget to setting RandomizePositionsRadius).

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool RandomizePositions
Public RandomizePositions As Boolean
public:
bool^ RandomizePositions

See Also

QuestGrinderGathererClass Class
wManager.Wow.Class Namespace


RandomizePositionsRadius Field

QuestGrinderGathererClass..::..RandomizePositionsRadius Field

Maximum distance from position (HotSpots) to randomized position (don't forget to activate option RandomizePositions)..

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float RandomizePositionsRadius
Public RandomizePositionsRadius As Single
public:
float^ RandomizePositionsRadius

See Also

QuestGrinderGathererClass Class
wManager.Wow.Class Namespace


QuestGrinderGathererClass Methods

The QuestGrinderGathererClass type exposes the following members.

Methods

 | Name | Description
Public method | CanConditions | Determines whether this can (by default this option return true, conditions can be added by override this method). (Inherited from QuestClass.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | HasQuest | Check if character have one of QuestId in his quest log, if you use option IsGrinderNotQuest this method check min/max level.
Public method | IsComplete | Determines if quest objective is complete (Step and StepAutoDetect), if you use option IsGrinderNotQuest this method check min/max level.
Public method | IsCompleted | Quest is completed (already turn in, or can't do (min/max level, required quest, character class)). (Inherited from QuestClass.)
Public method | IsCompleteObjectiveIndex | Determines whether is complete objective by objective index (Inherited from QuestClass.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | PickUp | Go to NPC and Pick up quest. (Inherited from QuestClass.)
Public method | Pulse | Pulse quest
Public method | PulseAllInOne | Pulses all in one (PickUp()()()(), Pulse()()()(), TurnIn()()()()). (Inherited from QuestClass.)
Public method | Reset | Resets this instance (reset to default the progress). When you override this method don't forget to call method of super class.
Public method | ToString | (Inherited from Object.)
Public method | TurnIn | Go to NPC and turn in quest. (Inherited from QuestClass.)
Public method | WhenLeaveStep | Called one time when the quester product leave this step (with Pulse or PulseAllInOne action). (Inherited from QuestClass.)
Public method | WhenSelectStep | Called one time when the quester product select this step (with Pulse or PulseAllInOne action). (Inherited from QuestClass.)

See Also

QuestGrinderGathererClass Class
wManager.Wow.Class Namespace


HasQuest Method

QuestGrinderGathererClass..::..HasQuest Method

Check if character have one of QuestId in his quest log, if you use option IsGrinderNotQuest this method check min/max level.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool HasQuest()
Public Function HasQuest As Boolean
public:
bool^ HasQuest()

See Also

QuestGrinderGathererClass Class
wManager.Wow.Class Namespace


IsComplete Method

QuestGrinderGathererClass..::..IsComplete Method

Determines if quest objective is complete (Step and StepAutoDetect), if you use option IsGrinderNotQuest this method check min/max level.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsComplete()
Public Function IsComplete As Boolean
public:
bool^ IsComplete()

See Also

QuestGrinderGathererClass Class
wManager.Wow.Class Namespace


Pulse Method

QuestGrinderGathererClass..::..Pulse Method

Pulse quest

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool Pulse()
Public Function Pulse As Boolean
public:
bool^ Pulse()

See Also

QuestGrinderGathererClass Class
wManager.Wow.Class Namespace


Reset Method

QuestGrinderGathererClass..::..Reset Method

Resets this instance (reset to default the progress). When you override this method don't forget to call method of super class.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool Reset()
Public Function Reset As Boolean
public:
bool^ Reset()

See Also

QuestGrinderGathererClass Class
wManager.Wow.Class Namespace


QuestGrinderGathererClass Properties

The QuestGrinderGathererClass type exposes the following members.

Properties

 | Name | Description
Public property | GossipOptionItem | Gets or sets the gossip option to use to select reward item. (Inherited from QuestClass.)
Public property | NpcPickUp | Gets the NPC where pick up quest (search in NPCList). (Inherited from QuestClass.)
Public property | NpcTurnIn | Gets the NPC to turn in quest (search in NPCList).. (Inherited from QuestClass.)
Public property | QuestId | Gets or sets the quest IDs list. (Inherited from QuestClass.)
Public property | Step | Gets or sets the quest objectives required count (example, if this quest need 5 kills for objective 3 use Step = new List<int> {0, 0, 5, 0, 0};. (Inherited from QuestClass.)
Public property | StepAutoDetect | Gets or sets the quest objectives to auto detect if complete (example, if you want detect if the objective 4 is done StepAutoDetect = new List<bool> {false, false, false, true, false};. (Inherited from QuestClass.)

See Also

QuestGrinderGathererClass Class
wManager.Wow.Class Namespace


QuestInteractWithClass Class

Class QuestInteractWithClass. Override this class when quest objectives is to interact with WoWUnit, WoWGameObject. Implements the QuestClass

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public abstract class QuestInteractWithClass : QuestClass
Public MustInherit Class QuestInteractWithClass _
    Inherits QuestClass
public ref class QuestInteractWithClass abstract : public QuestClass

Inheritance Hierarchy

Object
wManager.Wow.Class..::..QuestClass
wManager.Wow.Class..::..QuestInteractWithClass

See Also

QuestInteractWithClass Members
wManager.Wow.Class Namespace
wManager.Wow.Class..::..QuestClass


QuestInteractWithClass Members

The QuestInteractWithClass type exposes the following members.

Methods

 | Name | Description
Public method | CanConditions | Determines whether this can (by default this option return true, conditions can be added by override this method). (Inherited from QuestClass.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | HasQuest | Check if character have one of QuestId in his quest log. (Inherited from QuestClass.)
Public method | IsComplete | Determines if quest objective is complete (Step and StepAutoDetect). (Inherited from QuestClass.)
Public method | IsCompleted | Quest is completed (already turn in, or can't do (min/max level, required quest, character class)). (Inherited from QuestClass.)
Public method | IsCompleteObjectiveIndex | Determines whether is complete objective by objective index (Inherited from QuestClass.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | PickUp | Go to NPC and Pick up quest. (Inherited from QuestClass.)
Public method | Pulse | Pulse quest
Public method | PulseAllInOne | Pulses all in one (PickUp()()()(), Pulse()()()(), TurnIn()()()()). (Inherited from QuestClass.)
Public method | Reset | Resets this instance (reset to default the progress). When you override this method don't forget to call method of super class. (Inherited from QuestClass.)
Public method | ToString | (Inherited from Object.)
Public method | TurnIn | Go to NPC and turn in quest. (Inherited from QuestClass.)
Public method | WhenLeaveStep | Called one time when the quester product leave this step (with Pulse or PulseAllInOne action). (Inherited from QuestClass.)
Public method | WhenSelectStep | Called one time when the quester product select this step (with Pulse or PulseAllInOne action). (Inherited from QuestClass.)

Fields

 | Name | Description
Public field | BlacklistTimeMs | The blacklist time in milliseconds (time to blacklist the object after using the script on him)
Public field | EntryIdTarget | The Entry or Entry
Public field | GossipOptionNpcInteractWith | The gossip option to use when interact with object (-1 to don't use this option)
Public field | HotSpots | The hotspots (positions to explore, bot will generate paths between your the hotspots).
Public field | IgnoreIfDead | Enable to accept dead WoWUnit.
Public field | Macro | The lua macro to run when interact
Public field | Range | The interact range

Properties

 | Name | Description
Public property | GossipOptionItem | Gets or sets the gossip option to use to select reward item. (Inherited from QuestClass.)
Public property | NpcPickUp | Gets the NPC where pick up quest (search in NPCList). (Inherited from QuestClass.)
Public property | NpcTurnIn | Gets the NPC to turn in quest (search in NPCList).. (Inherited from QuestClass.)
Public property | QuestId | Gets or sets the quest IDs list. (Inherited from QuestClass.)
Public property | Step | Gets or sets the quest objectives required count (example, if this quest need 5 kills for objective 3 use Step = new List<int> {0, 0, 5, 0, 0};. (Inherited from QuestClass.)
Public property | StepAutoDetect | Gets or sets the quest objectives to auto detect if complete (example, if you want detect if the objective 4 is done StepAutoDetect = new List<bool> {false, false, false, true, false};. (Inherited from QuestClass.)

See Also

QuestInteractWithClass Class
wManager.Wow.Class Namespace


QuestInteractWithClass Fields

The QuestInteractWithClass type exposes the following members.

Fields

 | Name | Description
Public field | BlacklistTimeMs | The blacklist time in milliseconds (time to blacklist the object after using the script on him)
Public field | EntryIdTarget | The Entry or Entry
Public field | GossipOptionNpcInteractWith | The gossip option to use when interact with object (-1 to don't use this option)
Public field | HotSpots | The hotspots (positions to explore, bot will generate paths between your the hotspots).
Public field | IgnoreIfDead | Enable to accept dead WoWUnit.
Public field | Macro | The lua macro to run when interact
Public field | Range | The interact range

See Also

QuestInteractWithClass Class
wManager.Wow.Class Namespace


BlacklistTimeMs Field

QuestInteractWithClass..::..BlacklistTimeMs Field

The blacklist time in milliseconds (time to blacklist the object after using the script on him)

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int BlacklistTimeMs
Public BlacklistTimeMs As Integer
public:
int^ BlacklistTimeMs

See Also

QuestInteractWithClass Class
wManager.Wow.Class Namespace


EntryIdTarget Field

QuestInteractWithClass..::..EntryIdTarget Field

The Entry or Entry

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<int> EntryIdTarget
Public EntryIdTarget As List(Of Integer)
public:
List<int^>^ EntryIdTarget

See Also

QuestInteractWithClass Class
wManager.Wow.Class Namespace


GossipOptionNpcInteractWith Field

QuestInteractWithClass..::..GossipOptionNpcInteractWith Field

The gossip option to use when interact with object (-1 to don't use this option)

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int GossipOptionNpcInteractWith
Public GossipOptionNpcInteractWith As Integer
public:
int^ GossipOptionNpcInteractWith

See Also

QuestInteractWithClass Class
wManager.Wow.Class Namespace


HotSpots Field

QuestInteractWithClass..::..HotSpots Field

The hotspots (positions to explore, bot will generate paths between your the hotspots).

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<Vector3> HotSpots
Public HotSpots As List(Of Vector3)
public:
List<Vector3^>^ HotSpots

See Also

QuestInteractWithClass Class
wManager.Wow.Class Namespace


IgnoreIfDead Field

QuestInteractWithClass..::..IgnoreIfDead Field

Enable to accept dead WoWUnit.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IgnoreIfDead
Public IgnoreIfDead As Boolean
public:
bool^ IgnoreIfDead

See Also

QuestInteractWithClass Class
wManager.Wow.Class Namespace


Macro Field

QuestInteractWithClass..::..Macro Field

The lua macro to run when interact

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string Macro
Public Macro As String
public:
String^ Macro

See Also

QuestInteractWithClass Class
wManager.Wow.Class Namespace


Range Field

QuestInteractWithClass..::..Range Field

The interact range

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float Range
Public Range As Single
public:
float^ Range

See Also

QuestInteractWithClass Class
wManager.Wow.Class Namespace


QuestInteractWithClass Methods

The QuestInteractWithClass type exposes the following members.

Methods

 | Name | Description
Public method | CanConditions | Determines whether this can (by default this option return true, conditions can be added by override this method). (Inherited from QuestClass.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | HasQuest | Check if character have one of QuestId in his quest log. (Inherited from QuestClass.)
Public method | IsComplete | Determines if quest objective is complete (Step and StepAutoDetect). (Inherited from QuestClass.)
Public method | IsCompleted | Quest is completed (already turn in, or can't do (min/max level, required quest, character class)). (Inherited from QuestClass.)
Public method | IsCompleteObjectiveIndex | Determines whether is complete objective by objective index (Inherited from QuestClass.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | PickUp | Go to NPC and Pick up quest. (Inherited from QuestClass.)
Public method | Pulse | Pulse quest
Public method | PulseAllInOne | Pulses all in one (PickUp()()()(), Pulse()()()(), TurnIn()()()()). (Inherited from QuestClass.)
Public method | Reset | Resets this instance (reset to default the progress). When you override this method don't forget to call method of super class. (Inherited from QuestClass.)
Public method | ToString | (Inherited from Object.)
Public method | TurnIn | Go to NPC and turn in quest. (Inherited from QuestClass.)
Public method | WhenLeaveStep | Called one time when the quester product leave this step (with Pulse or PulseAllInOne action). (Inherited from QuestClass.)
Public method | WhenSelectStep | Called one time when the quester product select this step (with Pulse or PulseAllInOne action). (Inherited from QuestClass.)

See Also

QuestInteractWithClass Class
wManager.Wow.Class Namespace


Pulse Method

QuestInteractWithClass..::..Pulse Method

Pulse quest

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool Pulse()
Public Function Pulse As Boolean
public:
bool^ Pulse()

See Also

QuestInteractWithClass Class
wManager.Wow.Class Namespace


QuestInteractWithClass Properties

The QuestInteractWithClass type exposes the following members.

Properties

 | Name | Description
Public property | GossipOptionItem | Gets or sets the gossip option to use to select reward item. (Inherited from QuestClass.)
Public property | NpcPickUp | Gets the NPC where pick up quest (search in NPCList). (Inherited from QuestClass.)
Public property | NpcTurnIn | Gets the NPC to turn in quest (search in NPCList).. (Inherited from QuestClass.)
Public property | QuestId | Gets or sets the quest IDs list. (Inherited from QuestClass.)
Public property | Step | Gets or sets the quest objectives required count (example, if this quest need 5 kills for objective 3 use Step = new List<int> {0, 0, 5, 0, 0};. (Inherited from QuestClass.)
Public property | StepAutoDetect | Gets or sets the quest objectives to auto detect if complete (example, if you want detect if the objective 4 is done StepAutoDetect = new List<bool> {false, false, false, true, false};. (Inherited from QuestClass.)

See Also

QuestInteractWithClass Class
wManager.Wow.Class Namespace


QuestParallelQuestsClass Class

Class QuestParallelQuestsClass. Override this class if you want do several quest at same time. Implements the QuestClass

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public abstract class QuestParallelQuestsClass : QuestClass
Public MustInherit Class QuestParallelQuestsClass _
    Inherits QuestClass
public ref class QuestParallelQuestsClass abstract : public QuestClass

Inheritance Hierarchy

Object
wManager.Wow.Class..::..QuestClass
wManager.Wow.Class..::..QuestParallelQuestsClass

See Also

QuestParallelQuestsClass Members
wManager.Wow.Class Namespace
wManager.Wow.Class..::..QuestClass


QuestParallelQuestsClass Members

The QuestParallelQuestsClass type exposes the following members.

Methods

 | Name | Description
Public method | CanConditions |
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | HasQuest |
Public method | IsComplete |
Public method | IsCompleted |
Public method | IsCompleteObjectiveIndex | Determines whether is complete objective by objective index (Inherited from QuestClass.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | PickUp |
Public method | Pulse |
Public method | PulseAllInOne |
Public method | Reset |
Public method | ToString | (Inherited from Object.)
Public method | TurnIn |
Public method | WhenLeaveStep | Called one time when the quester product leave this step (with Pulse or PulseAllInOne action). (Inherited from QuestClass.)
Public method | WhenSelectStep | Called one time when the quester product select this step (with Pulse or PulseAllInOne action). (Inherited from QuestClass.)

Fields

Name Description
Public field SkipNextPulseIfKillOrFarm
Skip next pulse if kill or farm
Public field SubQuests
The sub quests, add quests in class constructor.

Examples

C#
if (wManager.Wow.Helpers.Quest.QuesterCurrentContext.QuestsClasses.ContainsKey("{subQuest}"))
       SubQuests.Add(wManager.Wow.Helpers.Quest.QuesterCurrentContext.QuestsClasses["{subQuest}"]);
   else
       SubQuests.Add(new {subQuest}());

Properties

 | Name | Description
Public property | GossipOptionItem | Gets or sets the gossip option to use to select reward item. (Inherited from QuestClass.)
Public property | NpcPickUp | Gets the NPC where pick up quest (search in NPCList). (Inherited from QuestClass.)
Public property | NpcTurnIn | Gets the NPC to turn in quest (search in NPCList).. (Inherited from QuestClass.)
Public property | QuestId | Gets or sets the quest IDs list. (Inherited from QuestClass.)
Public property | Step | Gets or sets the quest objectives required count (example, if this quest need 5 kills for objective 3 use Step = new List<int> {0, 0, 5, 0, 0};. (Inherited from QuestClass.)
Public property | StepAutoDetect | Gets or sets the quest objectives to auto detect if complete (example, if you want detect if the objective 4 is done StepAutoDetect = new List<bool> {false, false, false, true, false};. (Inherited from QuestClass.)

See Also

QuestParallelQuestsClass Class
wManager.Wow.Class Namespace


QuestParallelQuestsClass Fields

The QuestParallelQuestsClass type exposes the following members.

Fields

Name Description
Public field SkipNextPulseIfKillOrFarm
Skip next pulse if kill or farm
Public field SubQuests
The sub quests, add quests in class constructor.

Examples

C#
if (wManager.Wow.Helpers.Quest.QuesterCurrentContext.QuestsClasses.ContainsKey("{subQuest}"))
       SubQuests.Add(wManager.Wow.Helpers.Quest.QuesterCurrentContext.QuestsClasses["{subQuest}"]);
   else
       SubQuests.Add(new {subQuest}());

See Also

QuestParallelQuestsClass Class
wManager.Wow.Class Namespace


SkipNextPulseIfKillOrFarm Field

QuestParallelQuestsClass..::..SkipNextPulseIfKillOrFarm Field

Skip next pulse if kill or farm

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool SkipNextPulseIfKillOrFarm
Public SkipNextPulseIfKillOrFarm As Boolean
public:
bool^ SkipNextPulseIfKillOrFarm

See Also

QuestParallelQuestsClass Class
wManager.Wow.Class Namespace


SubQuests Field

QuestParallelQuestsClass..::..SubQuests Field

The sub quests, add quests in class constructor.

Examples

C#
if (wManager.Wow.Helpers.Quest.QuesterCurrentContext.QuestsClasses.ContainsKey("{subQuest}"))
       SubQuests.Add(wManager.Wow.Helpers.Quest.QuesterCurrentContext.QuestsClasses["{subQuest}"]);
   else
       SubQuests.Add(new {subQuest}());

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<QuestClass> SubQuests
Public SubQuests As List(Of QuestClass)
public:
List<QuestClass^>^ SubQuests

See Also

QuestParallelQuestsClass Class
wManager.Wow.Class Namespace


QuestParallelQuestsClass Methods

The QuestParallelQuestsClass type exposes the following members.

Methods

 | Name | Description
Public method | CanConditions |
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | HasQuest |
Public method | IsComplete |
Public method | IsCompleted |
Public method | IsCompleteObjectiveIndex | Determines whether is complete objective by objective index (Inherited from QuestClass.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | PickUp |
Public method | Pulse |
Public method | PulseAllInOne |
Public method | Reset |
Public method | ToString | (Inherited from Object.)
Public method | TurnIn |
Public method | WhenLeaveStep | Called one time when the quester product leave this step (with Pulse or PulseAllInOne action). (Inherited from QuestClass.)
Public method | WhenSelectStep | Called one time when the quester product select this step (with Pulse or PulseAllInOne action). (Inherited from QuestClass.)

See Also

QuestParallelQuestsClass Class
wManager.Wow.Class Namespace


CanConditions Method

QuestParallelQuestsClass..::..CanConditions Method

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool CanConditions()
Public Function CanConditions As Boolean
public:
bool^ CanConditions()

See Also

QuestParallelQuestsClass Class
wManager.Wow.Class Namespace


HasQuest Method

QuestParallelQuestsClass..::..HasQuest Method

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool HasQuest()
Public Function HasQuest As Boolean
public:
bool^ HasQuest()

See Also

QuestParallelQuestsClass Class
wManager.Wow.Class Namespace


IsComplete Method

QuestParallelQuestsClass..::..IsComplete Method

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsComplete()
Public Function IsComplete As Boolean
public:
bool^ IsComplete()

See Also

QuestParallelQuestsClass Class
wManager.Wow.Class Namespace


IsCompleted Method

QuestParallelQuestsClass..::..IsCompleted Method

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsCompleted()
Public Function IsCompleted As Boolean
public:
bool^ IsCompleted()

See Also

QuestParallelQuestsClass Class
wManager.Wow.Class Namespace


PickUp Method

QuestParallelQuestsClass..::..PickUp Method

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool PickUp()
Public Function PickUp As Boolean
public:
bool^ PickUp()

See Also

QuestParallelQuestsClass Class
wManager.Wow.Class Namespace


Pulse Method

QuestParallelQuestsClass..::..Pulse Method

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool Pulse()
Public Function Pulse As Boolean
public:
bool^ Pulse()

See Also

QuestParallelQuestsClass Class
wManager.Wow.Class Namespace


PulseAllInOne Method

QuestParallelQuestsClass..::..PulseAllInOne Method

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool PulseAllInOne()
Public Function PulseAllInOne As Boolean
public:
bool^ PulseAllInOne()

See Also

QuestParallelQuestsClass Class
wManager.Wow.Class Namespace


Reset Method

QuestParallelQuestsClass..::..Reset Method

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool Reset()
Public Function Reset As Boolean
public:
bool^ Reset()

See Also

QuestParallelQuestsClass Class
wManager.Wow.Class Namespace


TurnIn Method

QuestParallelQuestsClass..::..TurnIn Method

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool TurnIn()
Public Function TurnIn As Boolean
public:
bool^ TurnIn()

See Also

QuestParallelQuestsClass Class
wManager.Wow.Class Namespace


QuestParallelQuestsClass Properties

The QuestParallelQuestsClass type exposes the following members.

Properties

 | Name | Description
Public property | GossipOptionItem | Gets or sets the gossip option to use to select reward item. (Inherited from QuestClass.)
Public property | NpcPickUp | Gets the NPC where pick up quest (search in NPCList). (Inherited from QuestClass.)
Public property | NpcTurnIn | Gets the NPC to turn in quest (search in NPCList).. (Inherited from QuestClass.)
Public property | QuestId | Gets or sets the quest IDs list. (Inherited from QuestClass.)
Public property | Step | Gets or sets the quest objectives required count (example, if this quest need 5 kills for objective 3 use Step = new List<int> {0, 0, 5, 0, 0};. (Inherited from QuestClass.)
Public property | StepAutoDetect | Gets or sets the quest objectives to auto detect if complete (example, if you want detect if the objective 4 is done StepAutoDetect = new List<bool> {false, false, false, true, false};. (Inherited from QuestClass.)

See Also

QuestParallelQuestsClass Class
wManager.Wow.Class Namespace


QuestsSorted Class

Class QuestsSorted, quest profile step.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class QuestsSorted
<SerializableAttribute> _
Public Class QuestsSorted
[SerializableAttribute]
public ref class QuestsSorted

Inheritance Hierarchy

Object
wManager.Wow.Class..::..QuestsSorted

See Also

QuestsSorted Members
wManager.Wow.Class Namespace


QuestsSorted Members

The QuestsSorted type exposes the following members.

Constructors

 | Name | Description
Public method | QuestsSorted | Initializes a new instance of the QuestsSorted class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | NeedToRun | Needs to run.
Public method | Run | Runs this instance.
Public method | ToString | Returns a String that represents this instance.

Properties

 | Name | Description
Public property | Action | Step action.
Public property | NameClass | Step action setting.
Public property | QuestClassInstance | Get the quest class instance (Get instance in QuestsClasses, key is NameClass).

See Also

QuestsSorted Class
wManager.Wow.Class Namespace


QuestsSorted Constructor

Initializes a new instance of the QuestsSorted class.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public QuestsSorted()
Public Sub New
public:
QuestsSorted()

See Also

QuestsSorted Class
wManager.Wow.Class Namespace


QuestsSorted Methods

The QuestsSorted type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | NeedToRun | Needs to run.
Public method | Run | Runs this instance.
Public method | ToString | Returns a String that represents this instance.

See Also

QuestsSorted Class
wManager.Wow.Class Namespace


NeedToRun Method

QuestsSorted..::..NeedToRun Method

Needs to run.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool NeedToRun()
Public Function NeedToRun As Boolean
public:
bool^ NeedToRun()

Return Value

true if need to run, false otherwise.

See Also

QuestsSorted Class
wManager.Wow.Class Namespace


Run Method

QuestsSorted..::..Run Method

Runs this instance.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool Run()
Public Function Run As Boolean
public:
bool^ Run()

Return Value

true if success, false otherwise.

See Also

QuestsSorted Class
wManager.Wow.Class Namespace


ToString Method

QuestsSorted..::..ToString Method

Returns a String that represents this instance.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string ToString()
Public Function ToString As String
public:
String^ ToString()

Return Value

A String that represents this instance.

See Also

QuestsSorted Class
wManager.Wow.Class Namespace


QuestsSorted Properties

The QuestsSorted type exposes the following members.

Properties

 | Name | Description
Public property | Action | Step action.
Public property | NameClass | Step action setting.
Public property | QuestClassInstance | Get the quest class instance (Get instance in QuestsClasses, key is NameClass).

See Also

QuestsSorted Class
wManager.Wow.Class Namespace


Action Property

QuestsSorted..::..Action Property

Step action.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public QuestAction Action { get; set; }
Public Property Action As QuestAction
    Get
    Set
public:
property QuestAction^ Action {
    QuestAction^ get ();
    void set (QuestAction^ value);
}

See Also

QuestsSorted Class
wManager.Wow.Class Namespace


NameClass Property

QuestsSorted..::..NameClass Property

Step action setting.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string NameClass { get; set; }
Public Property NameClass As String
    Get
    Set
public:
property String^ NameClass {
    String^ get ();
    void set (String^ value);
}

See Also

QuestsSorted Class
wManager.Wow.Class Namespace


QuestClassInstance Property

QuestsSorted..::..QuestClassInstance Property

Get the quest class instance (Get instance in QuestsClasses, key is NameClass).

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[XmlIgnoreAttribute]
public QuestClass QuestClassInstance { get; }
<XmlIgnoreAttribute> _
Public ReadOnly Property QuestClassInstance As QuestClass
    Get
[XmlIgnoreAttribute]
public:
property QuestClass^ QuestClassInstance {
    QuestClass^ get ();
}

Field Value

The quest class instance.

See Also

QuestsSorted Class
wManager.Wow.Class Namespace


QuestUseItemOnClass Class

Class QuestUseItemOnClass. Override this class when quest objectives is to use item on WoWUnit, WoWGameObject or at specific position. Implements the QuestClass

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public abstract class QuestUseItemOnClass : QuestClass
Public MustInherit Class QuestUseItemOnClass _
    Inherits QuestClass
public ref class QuestUseItemOnClass abstract : public QuestClass

Inheritance Hierarchy

Object
wManager.Wow.Class..::..QuestClass
wManager.Wow.Class..::..QuestUseItemOnClass

See Also

QuestUseItemOnClass Members
wManager.Wow.Class Namespace
wManager.Wow.Class..::..QuestClass


QuestUseItemOnClass Members

The QuestUseItemOnClass type exposes the following members.

Methods

 | Name | Description
Public method | CanConditions | Determines whether this can (by default this option return true, conditions can be added by override this method). (Inherited from QuestClass.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | HasQuest | Check if character have one of QuestId in his quest log. (Inherited from QuestClass.)
Public method | IsComplete | Determines if quest objective is complete (Step and StepAutoDetect). (Inherited from QuestClass.)
Public method | IsCompleted | Quest is completed (already turn in, or can't do (min/max level, required quest, character class)). (Inherited from QuestClass.)
Public method | IsCompleteObjectiveIndex | Determines whether is complete objective by objective index (Inherited from QuestClass.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | PickUp | Go to NPC and Pick up quest. (Inherited from QuestClass.)
Public method | Pulse | Pulse quest
Public method | PulseAllInOne | Pulses all in one (PickUp()()()(), Pulse()()()(), TurnIn()()()()). (Inherited from QuestClass.)
Public method | Reset | Resets this instance (reset to default the progress). When you override this method don't forget to call method of super class. (Inherited from QuestClass.)
Public method | ToString | (Inherited from Object.)
Public method | TurnIn | Go to NPC and turn in quest. (Inherited from QuestClass.)
Public method | WhenLeaveStep | Called one time when the quester product leave this step (with Pulse or PulseAllInOne action). (Inherited from QuestClass.)
Public method | WhenSelectStep | Called one time when the quester product select this step (with Pulse or PulseAllInOne action). (Inherited from QuestClass.)

Fields

 | Name | Description
Public field | BlacklistTimeMs | The blacklist time in milliseconds (time to blacklist the object after using the item on him)
Public field | EntryIdTarget | The Entry or Entry of object on which to use the item. If you want use item at specific position don't use this option.
Public field | HotSpots | The hotspots (positions to explore, bot will generate paths between your the hotspots). If you don't use option EntryIdTarget bot will use item on hotspot positions.
Public field | ItemId | The item id
Public field | Range | The range of item

Properties

 | Name | Description
Public property | GossipOptionItem | Gets or sets the gossip option to use to select reward item. (Inherited from QuestClass.)
Public property | NpcPickUp | Gets the NPC where pick up quest (search in NPCList). (Inherited from QuestClass.)
Public property | NpcTurnIn | Gets the NPC to turn in quest (search in NPCList).. (Inherited from QuestClass.)
Public property | QuestId | Gets or sets the quest IDs list. (Inherited from QuestClass.)
Public property | Step | Gets or sets the quest objectives required count (example, if this quest need 5 kills for objective 3 use Step = new List<int> {0, 0, 5, 0, 0};. (Inherited from QuestClass.)
Public property | StepAutoDetect | Gets or sets the quest objectives to auto detect if complete (example, if you want detect if the objective 4 is done StepAutoDetect = new List<bool> {false, false, false, true, false};. (Inherited from QuestClass.)

See Also

QuestUseItemOnClass Class
wManager.Wow.Class Namespace


QuestUseItemOnClass Fields

The QuestUseItemOnClass type exposes the following members.

Fields

 | Name | Description
Public field | BlacklistTimeMs | The blacklist time in milliseconds (time to blacklist the object after using the item on him)
Public field | EntryIdTarget | The Entry or Entry of object on which to use the item. If you want use item at specific position don't use this option.
Public field | HotSpots | The hotspots (positions to explore, bot will generate paths between your the hotspots). If you don't use option EntryIdTarget bot will use item on hotspot positions.
Public field | ItemId | The item id
Public field | Range | The range of item

See Also

QuestUseItemOnClass Class
wManager.Wow.Class Namespace


BlacklistTimeMs Field

QuestUseItemOnClass..::..BlacklistTimeMs Field

The blacklist time in milliseconds (time to blacklist the object after using the item on him)

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int BlacklistTimeMs
Public BlacklistTimeMs As Integer
public:
int^ BlacklistTimeMs

See Also

QuestUseItemOnClass Class
wManager.Wow.Class Namespace


EntryIdTarget Field

QuestUseItemOnClass..::..EntryIdTarget Field

The Entry or Entry of object on which to use the item. If you want use item at specific position don't use this option.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<int> EntryIdTarget
Public EntryIdTarget As List(Of Integer)
public:
List<int^>^ EntryIdTarget

See Also

QuestUseItemOnClass Class
wManager.Wow.Class Namespace


HotSpots Field

QuestUseItemOnClass..::..HotSpots Field

The hotspots (positions to explore, bot will generate paths between your the hotspots). If you don't use option EntryIdTarget bot will use item on hotspot positions.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<Vector3> HotSpots
Public HotSpots As List(Of Vector3)
public:
List<Vector3^>^ HotSpots

See Also

QuestUseItemOnClass Class
wManager.Wow.Class Namespace


ItemId Field

QuestUseItemOnClass..::..ItemId Field

The item id

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int ItemId
Public ItemId As Integer
public:
int^ ItemId

See Also

QuestUseItemOnClass Class
wManager.Wow.Class Namespace


Range Field

QuestUseItemOnClass..::..Range Field

The range of item

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float Range
Public Range As Single
public:
float^ Range

See Also

QuestUseItemOnClass Class
wManager.Wow.Class Namespace


QuestUseItemOnClass Methods

The QuestUseItemOnClass type exposes the following members.

Methods

 | Name | Description
Public method | CanConditions | Determines whether this can (by default this option return true, conditions can be added by override this method). (Inherited from QuestClass.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | HasQuest | Check if character have one of QuestId in his quest log. (Inherited from QuestClass.)
Public method | IsComplete | Determines if quest objective is complete (Step and StepAutoDetect). (Inherited from QuestClass.)
Public method | IsCompleted | Quest is completed (already turn in, or can't do (min/max level, required quest, character class)). (Inherited from QuestClass.)
Public method | IsCompleteObjectiveIndex | Determines whether is complete objective by objective index (Inherited from QuestClass.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | PickUp | Go to NPC and Pick up quest. (Inherited from QuestClass.)
Public method | Pulse | Pulse quest
Public method | PulseAllInOne | Pulses all in one (PickUp()()()(), Pulse()()()(), TurnIn()()()()). (Inherited from QuestClass.)
Public method | Reset | Resets this instance (reset to default the progress). When you override this method don't forget to call method of super class. (Inherited from QuestClass.)
Public method | ToString | (Inherited from Object.)
Public method | TurnIn | Go to NPC and turn in quest. (Inherited from QuestClass.)
Public method | WhenLeaveStep | Called one time when the quester product leave this step (with Pulse or PulseAllInOne action). (Inherited from QuestClass.)
Public method | WhenSelectStep | Called one time when the quester product select this step (with Pulse or PulseAllInOne action). (Inherited from QuestClass.)

See Also

QuestUseItemOnClass Class
wManager.Wow.Class Namespace


Pulse Method

QuestUseItemOnClass..::..Pulse Method

Pulse quest

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool Pulse()
Public Function Pulse As Boolean
public:
bool^ Pulse()

See Also

QuestUseItemOnClass Class
wManager.Wow.Class Namespace


QuestUseItemOnClass Properties

The QuestUseItemOnClass type exposes the following members.

Properties

 | Name | Description
Public property | GossipOptionItem | Gets or sets the gossip option to use to select reward item. (Inherited from QuestClass.)
Public property | NpcPickUp | Gets the NPC where pick up quest (search in NPCList). (Inherited from QuestClass.)
Public property | NpcTurnIn | Gets the NPC to turn in quest (search in NPCList).. (Inherited from QuestClass.)
Public property | QuestId | Gets or sets the quest IDs list. (Inherited from QuestClass.)
Public property | Step | Gets or sets the quest objectives required count (example, if this quest need 5 kills for objective 3 use Step = new List<int> {0, 0, 5, 0, 0};. (Inherited from QuestClass.)
Public property | StepAutoDetect | Gets or sets the quest objectives to auto detect if complete (example, if you want detect if the objective 4 is done StepAutoDetect = new List<bool> {false, false, false, true, false};. (Inherited from QuestClass.)

See Also

QuestUseItemOnClass Class
wManager.Wow.Class Namespace


QuestUseScriptOnClass Class

Class QuestUseScriptOnClass. Override this class when quest objectives is to use the script on WoWUnit, WoWGameObject or at specific position. Implements the QuestClass

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public abstract class QuestUseScriptOnClass : QuestClass
Public MustInherit Class QuestUseScriptOnClass _
    Inherits QuestClass
public ref class QuestUseScriptOnClass abstract : public QuestClass

Inheritance Hierarchy

Object
wManager.Wow.Class..::..QuestClass
wManager.Wow.Class..::..QuestUseScriptOnClass

See Also

QuestUseScriptOnClass Members
wManager.Wow.Class Namespace
wManager.Wow.Class..::..QuestClass


QuestUseScriptOnClass Members

The QuestUseScriptOnClass type exposes the following members.

Methods

 | Name | Description
Public method | CanConditions | Determines whether this can (by default this option return true, conditions can be added by override this method). (Inherited from QuestClass.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | HasQuest | Check if character have one of QuestId in his quest log. (Inherited from QuestClass.)
Public method | IsComplete | Determines if quest objective is complete (Step and StepAutoDetect). (Inherited from QuestClass.)
Public method | IsCompleted | Quest is completed (already turn in, or can't do (min/max level, required quest, character class)). (Inherited from QuestClass.)
Public method | IsCompleteObjectiveIndex | Determines whether is complete objective by objective index (Inherited from QuestClass.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | PickUp | Go to NPC and Pick up quest. (Inherited from QuestClass.)
Public method | Pulse | Pulse quest
Public method | PulseAllInOne | Pulses all in one (PickUp()()()(), Pulse()()()(), TurnIn()()()()). (Inherited from QuestClass.)
Public method | Reset | Resets this instance (reset to default the progress). When you override this method don't forget to call method of super class. (Inherited from QuestClass.)
Public method | ToString | (Inherited from Object.)
Public method | TurnIn | Go to NPC and turn in quest. (Inherited from QuestClass.)
Public method | WhenLeaveStep | Called one time when the quester product leave this step (with Pulse or PulseAllInOne action). (Inherited from QuestClass.)
Public method | WhenSelectStep | Called one time when the quester product select this step (with Pulse or PulseAllInOne action). (Inherited from QuestClass.)

Fields

 | Name | Description
Public field | BlacklistTimeMs | The blacklist time in milliseconds (time to blacklist the object after using the script on him)
Public field | EntryIdTarget | The Entry or Entry
Public field | HotSpots | The hotspots (positions to explore, bot will generate paths between your the hotspots). If you don't use option EntryIdTarget bot will use the script on hotspot positions.
Public field | IsCSharpCode | Enable this option is Script contain C# code (and not lua code)
Public field | Range | The range of script
Public field | Script | The script (by default it is lua code, if you want use c# code activate option IsCSharpCode)

Properties

 | Name | Description
Public property | GossipOptionItem | Gets or sets the gossip option to use to select reward item. (Inherited from QuestClass.)
Public property | NpcPickUp | Gets the NPC where pick up quest (search in NPCList). (Inherited from QuestClass.)
Public property | NpcTurnIn | Gets the NPC to turn in quest (search in NPCList).. (Inherited from QuestClass.)
Public property | QuestId | Gets or sets the quest IDs list. (Inherited from QuestClass.)
Public property | Step | Gets or sets the quest objectives required count (example, if this quest need 5 kills for objective 3 use Step = new List<int> {0, 0, 5, 0, 0};. (Inherited from QuestClass.)
Public property | StepAutoDetect | Gets or sets the quest objectives to auto detect if complete (example, if you want detect if the objective 4 is done StepAutoDetect = new List<bool> {false, false, false, true, false};. (Inherited from QuestClass.)

See Also

QuestUseScriptOnClass Class
wManager.Wow.Class Namespace


QuestUseScriptOnClass Fields

The QuestUseScriptOnClass type exposes the following members.

Fields

 | Name | Description
Public field | BlacklistTimeMs | The blacklist time in milliseconds (time to blacklist the object after using the script on him)
Public field | EntryIdTarget | The Entry or Entry
Public field | HotSpots | The hotspots (positions to explore, bot will generate paths between your the hotspots). If you don't use option EntryIdTarget bot will use the script on hotspot positions.
Public field | IsCSharpCode | Enable this option is Script contain C# code (and not lua code)
Public field | Range | The range of script
Public field | Script | The script (by default it is lua code, if you want use c# code activate option IsCSharpCode)

See Also

QuestUseScriptOnClass Class
wManager.Wow.Class Namespace


BlacklistTimeMs Field

QuestUseScriptOnClass..::..BlacklistTimeMs Field

The blacklist time in milliseconds (time to blacklist the object after using the script on him)

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int BlacklistTimeMs
Public BlacklistTimeMs As Integer
public:
int^ BlacklistTimeMs

See Also

QuestUseScriptOnClass Class
wManager.Wow.Class Namespace


EntryIdTarget Field

QuestUseScriptOnClass..::..EntryIdTarget Field

The Entry or Entry

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<int> EntryIdTarget
Public EntryIdTarget As List(Of Integer)
public:
List<int^>^ EntryIdTarget

See Also

QuestUseScriptOnClass Class
wManager.Wow.Class Namespace


HotSpots Field

QuestUseScriptOnClass..::..HotSpots Field

The hotspots (positions to explore, bot will generate paths between your the hotspots). If you don't use option EntryIdTarget bot will use the script on hotspot positions.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<Vector3> HotSpots
Public HotSpots As List(Of Vector3)
public:
List<Vector3^>^ HotSpots

See Also

QuestUseScriptOnClass Class
wManager.Wow.Class Namespace


IsCSharpCode Field

QuestUseScriptOnClass..::..IsCSharpCode Field

Enable this option is Script contain C# code (and not lua code)

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsCSharpCode
Public IsCSharpCode As Boolean
public:
bool^ IsCSharpCode

See Also

QuestUseScriptOnClass Class
wManager.Wow.Class Namespace


Range Field

QuestUseScriptOnClass..::..Range Field

The range of script

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float Range
Public Range As Single
public:
float^ Range

See Also

QuestUseScriptOnClass Class
wManager.Wow.Class Namespace


Script Field

QuestUseScriptOnClass..::..Script Field

The script (by default it is lua code, if you want use c# code activate option IsCSharpCode)

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string Script
Public Script As String
public:
String^ Script

See Also

QuestUseScriptOnClass Class
wManager.Wow.Class Namespace


QuestUseScriptOnClass Methods

The QuestUseScriptOnClass type exposes the following members.

Methods

 | Name | Description
Public method | CanConditions | Determines whether this can (by default this option return true, conditions can be added by override this method). (Inherited from QuestClass.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | HasQuest | Check if character have one of QuestId in his quest log. (Inherited from QuestClass.)
Public method | IsComplete | Determines if quest objective is complete (Step and StepAutoDetect). (Inherited from QuestClass.)
Public method | IsCompleted | Quest is completed (already turn in, or can't do (min/max level, required quest, character class)). (Inherited from QuestClass.)
Public method | IsCompleteObjectiveIndex | Determines whether is complete objective by objective index (Inherited from QuestClass.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | PickUp | Go to NPC and Pick up quest. (Inherited from QuestClass.)
Public method | Pulse | Pulse quest
Public method | PulseAllInOne | Pulses all in one (PickUp()()()(), Pulse()()()(), TurnIn()()()()). (Inherited from QuestClass.)
Public method | Reset | Resets this instance (reset to default the progress). When you override this method don't forget to call method of super class. (Inherited from QuestClass.)
Public method | ToString | (Inherited from Object.)
Public method | TurnIn | Go to NPC and turn in quest. (Inherited from QuestClass.)
Public method | WhenLeaveStep | Called one time when the quester product leave this step (with Pulse or PulseAllInOne action). (Inherited from QuestClass.)
Public method | WhenSelectStep | Called one time when the quester product select this step (with Pulse or PulseAllInOne action). (Inherited from QuestClass.)

See Also

QuestUseScriptOnClass Class
wManager.Wow.Class Namespace


Pulse Method

QuestUseScriptOnClass..::..Pulse Method

Pulse quest

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool Pulse()
Public Function Pulse As Boolean
public:
bool^ Pulse()

See Also

QuestUseScriptOnClass Class
wManager.Wow.Class Namespace


QuestUseScriptOnClass Properties

The QuestUseScriptOnClass type exposes the following members.

Properties

 | Name | Description
Public property | GossipOptionItem | Gets or sets the gossip option to use to select reward item. (Inherited from QuestClass.)
Public property | NpcPickUp | Gets the NPC where pick up quest (search in NPCList). (Inherited from QuestClass.)
Public property | NpcTurnIn | Gets the NPC to turn in quest (search in NPCList).. (Inherited from QuestClass.)
Public property | QuestId | Gets or sets the quest IDs list. (Inherited from QuestClass.)
Public property | Step | Gets or sets the quest objectives required count (example, if this quest need 5 kills for objective 3 use Step = new List<int> {0, 0, 5, 0, 0};. (Inherited from QuestClass.)
Public property | StepAutoDetect | Gets or sets the quest objectives to auto detect if complete (example, if you want detect if the objective 4 is done StepAutoDetect = new List<bool> {false, false, false, true, false};. (Inherited from QuestClass.)

See Also

QuestUseScriptOnClass Class
wManager.Wow.Class Namespace


QuestUseSpellOnClass Class

Class QuestUseSpellOnClass. Override this class when quest objectives is to use spell on WoWUnit, WoWGameObject or at specific position. Implements the QuestClass

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public abstract class QuestUseSpellOnClass : QuestClass
Public MustInherit Class QuestUseSpellOnClass _
    Inherits QuestClass
public ref class QuestUseSpellOnClass abstract : public QuestClass

Inheritance Hierarchy

Object
wManager.Wow.Class..::..QuestClass
wManager.Wow.Class..::..QuestUseSpellOnClass

See Also

QuestUseSpellOnClass Members
wManager.Wow.Class Namespace
wManager.Wow.Class..::..QuestClass


QuestUseSpellOnClass Members

The QuestUseSpellOnClass type exposes the following members.

Methods

 | Name | Description
Public method | CanConditions | Determines whether this can (by default this option return true, conditions can be added by override this method). (Inherited from QuestClass.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | HasQuest | Check if character have one of QuestId in his quest log. (Inherited from QuestClass.)
Public method | IsComplete | Determines if quest objective is complete (Step and StepAutoDetect). (Inherited from QuestClass.)
Public method | IsCompleted | Quest is completed (already turn in, or can't do (min/max level, required quest, character class)). (Inherited from QuestClass.)
Public method | IsCompleteObjectiveIndex | Determines whether is complete objective by objective index (Inherited from QuestClass.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | PickUp | Go to NPC and Pick up quest. (Inherited from QuestClass.)
Public method | Pulse | Pulse quest
Public method | PulseAllInOne | Pulses all in one (PickUp()()()(), Pulse()()()(), TurnIn()()()()). (Inherited from QuestClass.)
Public method | Reset | Resets this instance (reset to default the progress). When you override this method don't forget to call method of super class. (Inherited from QuestClass.)
Public method | ToString | (Inherited from Object.)
Public method | TurnIn | Go to NPC and turn in quest. (Inherited from QuestClass.)
Public method | WhenLeaveStep | Called one time when the quester product leave this step (with Pulse or PulseAllInOne action). (Inherited from QuestClass.)
Public method | WhenSelectStep | Called one time when the quester product select this step (with Pulse or PulseAllInOne action). (Inherited from QuestClass.)

Fields

 | Name | Description
Public field | BlacklistTimeMs | The blacklist time in milliseconds (time to blacklist the object after using the spell on him)
Public field | EntryIdTarget | The Entry or Entry of object on which to use the spell. If you want use spell at specific position don't use this option.
Public field | HotSpots | The hotspots (positions to explore, bot will generate paths between your the hotspots). If you don't use option EntryIdTarget bot will use spell on hotspot positions.
Public field | Range | The range of spell
Public field | SpellId | The spell id

Properties

 | Name | Description
Public property | GossipOptionItem | Gets or sets the gossip option to use to select reward item. (Inherited from QuestClass.)
Public property | NpcPickUp | Gets the NPC where pick up quest (search in NPCList). (Inherited from QuestClass.)
Public property | NpcTurnIn | Gets the NPC to turn in quest (search in NPCList).. (Inherited from QuestClass.)
Public property | QuestId | Gets or sets the quest IDs list. (Inherited from QuestClass.)
Public property | Step | Gets or sets the quest objectives required count (example, if this quest need 5 kills for objective 3 use Step = new List<int> {0, 0, 5, 0, 0};. (Inherited from QuestClass.)
Public property | StepAutoDetect | Gets or sets the quest objectives to auto detect if complete (example, if you want detect if the objective 4 is done StepAutoDetect = new List<bool> {false, false, false, true, false};. (Inherited from QuestClass.)

See Also

QuestUseSpellOnClass Class
wManager.Wow.Class Namespace


QuestUseSpellOnClass Fields

The QuestUseSpellOnClass type exposes the following members.

Fields

 | Name | Description
Public field | BlacklistTimeMs | The blacklist time in milliseconds (time to blacklist the object after using the spell on him)
Public field | EntryIdTarget | The Entry or Entry of object on which to use the spell. If you want use spell at specific position don't use this option.
Public field | HotSpots | The hotspots (positions to explore, bot will generate paths between your the hotspots). If you don't use option EntryIdTarget bot will use spell on hotspot positions.
Public field | Range | The range of spell
Public field | SpellId | The spell id

See Also

QuestUseSpellOnClass Class
wManager.Wow.Class Namespace


BlacklistTimeMs Field

QuestUseSpellOnClass..::..BlacklistTimeMs Field

The blacklist time in milliseconds (time to blacklist the object after using the spell on him)

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int BlacklistTimeMs
Public BlacklistTimeMs As Integer
public:
int^ BlacklistTimeMs

See Also

QuestUseSpellOnClass Class
wManager.Wow.Class Namespace


EntryIdTarget Field

QuestUseSpellOnClass..::..EntryIdTarget Field

The Entry or Entry of object on which to use the spell. If you want use spell at specific position don't use this option.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<int> EntryIdTarget
Public EntryIdTarget As List(Of Integer)
public:
List<int^>^ EntryIdTarget

See Also

QuestUseSpellOnClass Class
wManager.Wow.Class Namespace


HotSpots Field

QuestUseSpellOnClass..::..HotSpots Field

The hotspots (positions to explore, bot will generate paths between your the hotspots). If you don't use option EntryIdTarget bot will use spell on hotspot positions.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<Vector3> HotSpots
Public HotSpots As List(Of Vector3)
public:
List<Vector3^>^ HotSpots

See Also

QuestUseSpellOnClass Class
wManager.Wow.Class Namespace


Range Field

QuestUseSpellOnClass..::..Range Field

The range of spell

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float Range
Public Range As Single
public:
float^ Range

See Also

QuestUseSpellOnClass Class
wManager.Wow.Class Namespace


SpellId Field

QuestUseSpellOnClass..::..SpellId Field

The spell id

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int SpellId
Public SpellId As Integer
public:
int^ SpellId

See Also

QuestUseSpellOnClass Class
wManager.Wow.Class Namespace


QuestUseSpellOnClass Methods

The QuestUseSpellOnClass type exposes the following members.

Methods

 | Name | Description
Public method | CanConditions | Determines whether this can (by default this option return true, conditions can be added by override this method). (Inherited from QuestClass.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | HasQuest | Check if character have one of QuestId in his quest log. (Inherited from QuestClass.)
Public method | IsComplete | Determines if quest objective is complete (Step and StepAutoDetect). (Inherited from QuestClass.)
Public method | IsCompleted | Quest is completed (already turn in, or can't do (min/max level, required quest, character class)). (Inherited from QuestClass.)
Public method | IsCompleteObjectiveIndex | Determines whether is complete objective by objective index (Inherited from QuestClass.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | PickUp | Go to NPC and Pick up quest. (Inherited from QuestClass.)
Public method | Pulse | Pulse quest
Public method | PulseAllInOne | Pulses all in one (PickUp()()()(), Pulse()()()(), TurnIn()()()()). (Inherited from QuestClass.)
Public method | Reset | Resets this instance (reset to default the progress). When you override this method don't forget to call method of super class. (Inherited from QuestClass.)
Public method | ToString | (Inherited from Object.)
Public method | TurnIn | Go to NPC and turn in quest. (Inherited from QuestClass.)
Public method | WhenLeaveStep | Called one time when the quester product leave this step (with Pulse or PulseAllInOne action). (Inherited from QuestClass.)
Public method | WhenSelectStep | Called one time when the quester product select this step (with Pulse or PulseAllInOne action). (Inherited from QuestClass.)

See Also

QuestUseSpellOnClass Class
wManager.Wow.Class Namespace


Pulse Method

QuestUseSpellOnClass..::..Pulse Method

Pulse quest

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool Pulse()
Public Function Pulse As Boolean
public:
bool^ Pulse()

See Also

QuestUseSpellOnClass Class
wManager.Wow.Class Namespace


QuestUseSpellOnClass Properties

The QuestUseSpellOnClass type exposes the following members.

Properties

 | Name | Description
Public property | GossipOptionItem | Gets or sets the gossip option to use to select reward item. (Inherited from QuestClass.)
Public property | NpcPickUp | Gets the NPC where pick up quest (search in NPCList). (Inherited from QuestClass.)
Public property | NpcTurnIn | Gets the NPC to turn in quest (search in NPCList).. (Inherited from QuestClass.)
Public property | QuestId | Gets or sets the quest IDs list. (Inherited from QuestClass.)
Public property | Step | Gets or sets the quest objectives required count (example, if this quest need 5 kills for objective 3 use Step = new List<int> {0, 0, 5, 0, 0};. (Inherited from QuestClass.)
Public property | StepAutoDetect | Gets or sets the quest objectives to auto detect if complete (example, if you want detect if the objective 4 is done StepAutoDetect = new List<bool> {false, false, false, true, false};. (Inherited from QuestClass.)

See Also

QuestUseSpellOnClass Class
wManager.Wow.Class Namespace


RuneStruct Class

Class RuneStruct.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class RuneStruct
Public Class RuneStruct
public ref class RuneStruct

Inheritance Hierarchy

Object
wManager.Wow.Class..::..RuneStruct

See Also

RuneStruct Members
wManager.Wow.Class Namespace


RuneStruct Members

The RuneStruct type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | CooldownTimeLeft | The time left
Public field | Id | The rune id
Public field | IsReady | Rune is ready
Public field | RuneType | Rune type

See Also

RuneStruct Class
wManager.Wow.Class Namespace


RuneStruct Fields

The RuneStruct type exposes the following members.

Fields

 | Name | Description
Public field | CooldownTimeLeft | The time left
Public field | Id | The rune id
Public field | IsReady | Rune is ready
Public field | RuneType | Rune type

See Also

RuneStruct Class
wManager.Wow.Class Namespace


CooldownTimeLeft Field

RuneStruct..::..CooldownTimeLeft Field

The time left

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int CooldownTimeLeft
Public CooldownTimeLeft As Integer
public:
int^ CooldownTimeLeft

See Also

RuneStruct Class
wManager.Wow.Class Namespace


Id Field

RuneStruct..::..Id Field

The rune id

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int Id
Public Id As Integer
public:
int^ Id

See Also

RuneStruct Class
wManager.Wow.Class Namespace


IsReady Field

RuneStruct..::..IsReady Field

Rune is ready

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsReady
Public IsReady As Boolean
public:
bool^ IsReady

See Also

RuneStruct Class
wManager.Wow.Class Namespace


RuneType Field

RuneStruct..::..RuneType Field

Rune type

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public RuneTypes RuneType
Public RuneType As RuneTypes
public:
RuneTypes^ RuneType

See Also

RuneStruct Class
wManager.Wow.Class Namespace


RuneStruct Methods

The RuneStruct type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

RuneStruct Class
wManager.Wow.Class Namespace


Spell Class

Class Spell. Convenient to manage a spell easily.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class Spell
Public Class Spell
public ref class Spell

Inheritance Hierarchy

Object
wManager.Wow.Class..::..Spell

See Also

Spell Members
wManager.Wow.Class Namespace


Spell Members

The Spell type exposes the following members.

Constructors

 | Name | Description
Public method | Spell(Int32) | Initializes a new instance of the Spell class. This class management an spell of your wow player.
Public method | Spell(UInt32) | Initializes a new instance of the Spell class. This class management an spell of your wow player.
Public method | Spell(String) | Initializes a new instance of the Spell class. This class manage spells of your wow player.
Public method | Spell(String, Boolean) | Initializes a new instance of the Spell class. This class manage spells of your wow player.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | Launch()()()() | Cast Spell.
Public method | Launch(Boolean, Boolean, Boolean) | Cast Spell.
Public method | Launch(Boolean, Boolean, Boolean, Boolean) | Cast Spell.
Public method | Launch(Boolean, Boolean, Boolean, String) | Cast Spell.
Public method | Launch(Boolean, Boolean, Boolean, String, Boolean) | Cast Spell.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance.

Fields

 | Name | Description
 | CacheTimeIsSpellUsable | The cache time is milliseconds for IsSpellUsable
Public field | CastTime | Cast time (in seconds)
Public field | Icon | The icon
Public field | Id | The main spell id
Public field | Ids | Others spell IDs found (with same english name).
Public field | KnownSpell | True if character known spell
 | LockLaunchSpell | Lock (thread) of current spell
Public field | MinRange | The minimum spell range
Public field | Name | The spell name in english
Public field | NameInGame | The name like is appear in game
Public field | SubName | The sub name

Properties

 | Name | Description
Public property | BuffStack | Gets player buff stack count.
Public property | BuffTimeLeft | Gets player buff time left (in milliseconds).
Public property | GetBuff | Gets player buff
Public property | HaveBuff | Gets if your player have this spell in buff.
Public property | IsDistanceGood | Gets if the player distance to target is good to cast spell.
Public property | IsSpellUsable | Check if the spell is currently usable (cooldown, mana, zone, target (don't check distance)).
Public property | MaxRange | Gets or sets the maximum spell range (if you use CalcuCombatRange the value may be different from that assigned).
Public property | TargetBuffStack | Gets target buff stack count.
Public property | TargetBuffTimeLeft | Gets target buff time left (in milliseconds).
Public property | TargetGetBuff | Gets target buff.
Public property | TargetHaveBuff | Gets if the target have this spell in buff.

See Also

Spell Class
wManager.Wow.Class Namespace


Spell Constructor

Overload List

 | Name | Description
Public method | Spell(Int32) | Initializes a new instance of the Spell class. This class management an spell of your wow player.
Public method | Spell(UInt32) | Initializes a new instance of the Spell class. This class management an spell of your wow player.
Public method | Spell(String) | Initializes a new instance of the Spell class. This class manage spells of your wow player.
Public method | Spell(String, Boolean) | Initializes a new instance of the Spell class. This class manage spells of your wow player.

See Also

Spell Class
Spell Members
wManager.Wow.Class Namespace


Spell Constructor (Int32)

Initializes a new instance of the Spell class. This class management an spell of your wow player.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Spell(
    int spellId
)
Public Sub New ( _
    spellId As Integer _
)
public:
Spell(
    int^ spellId
)

Parameters

spellId
Type: Int32
The spell ID.

See Also

Spell Class
Spell Overload
wManager.Wow.Class Namespace


Spell Constructor (UInt32)

Initializes a new instance of the Spell class. This class management an spell of your wow player.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Spell(
    uint spellId
)
Public Sub New ( _
    spellId As UInteger _
)
public:
Spell(
    unsigned int^ spellId
)

Parameters

spellId
Type: UInt32
The spell ID.

See Also

Spell Class
Spell Overload
wManager.Wow.Class Namespace


Spell Constructor (String)

Initializes a new instance of the Spell class. This class manage spells of your wow player.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Spell(
    string spellNameEnglish
)
Public Sub New ( _
    spellNameEnglish As String _
)
public:
Spell(
    String^ spellNameEnglish
)

Parameters

spellNameEnglish
Type: String
English name of the spell.

See Also

Spell Class
Spell Overload
wManager.Wow.Class Namespace


Spell Constructor (String, Boolean)

Initializes a new instance of the Spell class. This class manage spells of your wow player.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Spell(
    string spellNameEnglish,
    bool showLog
)
Public Sub New ( _
    spellNameEnglish As String, _
    showLog As Boolean _
)
public:
Spell(
    String^ spellNameEnglish,
    bool^ showLog
)

Parameters

spellNameEnglish
Type: String
English name of the spell.
showLog
Type: Boolean
Show debug log

See Also

Spell Class
Spell Overload
wManager.Wow.Class Namespace


Spell Fields

The Spell type exposes the following members.

Fields

 | Name | Description
 | CacheTimeIsSpellUsable | The cache time is milliseconds for IsSpellUsable
Public field | CastTime | Cast time (in seconds)
Public field | Icon | The icon
Public field | Id | The main spell id
Public field | Ids | Others spell IDs found (with same english name).
Public field | KnownSpell | True if character known spell
 | LockLaunchSpell | Lock (thread) of current spell
Public field | MinRange | The minimum spell range
Public field | Name | The spell name in english
Public field | NameInGame | The name like is appear in game
Public field | SubName | The sub name

See Also

Spell Class
wManager.Wow.Class Namespace


CacheTimeIsSpellUsable Field

Spell..::..CacheTimeIsSpellUsable Field

The cache time is milliseconds for IsSpellUsable

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static double CacheTimeIsSpellUsable
Public Shared CacheTimeIsSpellUsable As Double
public:
static double^ CacheTimeIsSpellUsable

See Also

Spell Class
wManager.Wow.Class Namespace


CastTime Field

Spell..::..CastTime Field

Cast time (in seconds)

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float CastTime
Public CastTime As Single
public:
float^ CastTime

See Also

Spell Class
wManager.Wow.Class Namespace


Icon Field

Spell..::..Icon Field

The icon

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string Icon
Public Icon As String
public:
String^ Icon

See Also

Spell Class
wManager.Wow.Class Namespace


Id Field

Spell..::..Id Field

The main spell id

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint Id
Public Id As UInteger
public:
unsigned int^ Id

See Also

Spell Class
wManager.Wow.Class Namespace


Ids Field

Spell..::..Ids Field

Others spell IDs found (with same english name).

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<uint> Ids
Public Ids As List(Of UInteger)
public:
List<unsigned int^>^ Ids

See Also

Spell Class
wManager.Wow.Class Namespace


KnownSpell Field

Spell..::..KnownSpell Field

True if character known spell

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool KnownSpell
Public KnownSpell As Boolean
public:
bool^ KnownSpell

See Also

Spell Class
wManager.Wow.Class Namespace


LockLaunchSpell Field

Spell..::..LockLaunchSpell Field

Lock (thread) of current spell

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static Object LockLaunchSpell
Public Shared LockLaunchSpell As Object
public:
static Object^ LockLaunchSpell

See Also

Spell Class
wManager.Wow.Class Namespace


MinRange Field

Spell..::..MinRange Field

The minimum spell range

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float MinRange
Public MinRange As Single
public:
float^ MinRange

See Also

Spell Class
wManager.Wow.Class Namespace


Name Field

Spell..::..Name Field

The spell name in english

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string Name
Public Name As String
public:
String^ Name

See Also

Spell Class
wManager.Wow.Class Namespace


NameInGame Field

Spell..::..NameInGame Field

The name like is appear in game

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string NameInGame
Public NameInGame As String
public:
String^ NameInGame

See Also

Spell Class
wManager.Wow.Class Namespace


SubName Field

Spell..::..SubName Field

The sub name

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string SubName
Public SubName As String
public:
String^ SubName

See Also

Spell Class
wManager.Wow.Class Namespace


Spell Methods

The Spell type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | Launch()()()() | Cast Spell.
Public method | Launch(Boolean, Boolean, Boolean) | Cast Spell.
Public method | Launch(Boolean, Boolean, Boolean, Boolean) | Cast Spell.
Public method | Launch(Boolean, Boolean, Boolean, String) | Cast Spell.
Public method | Launch(Boolean, Boolean, Boolean, String, Boolean) | Cast Spell.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance.

See Also

Spell Class
wManager.Wow.Class Namespace


Launch Method

Spell..::..Launch Method

Overload List

 | Name | Description
Public method | Launch()()()() | Cast Spell.
Public method | Launch(Boolean, Boolean, Boolean) | Cast Spell.
Public method | Launch(Boolean, Boolean, Boolean, Boolean) | Cast Spell.
Public method | Launch(Boolean, Boolean, Boolean, String) | Cast Spell.
Public method | Launch(Boolean, Boolean, Boolean, String, Boolean) | Cast Spell.

See Also

Spell Class
Spell Members
wManager.Wow.Class Namespace


Launch Method

Spell..::..Launch Method

Cast Spell.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Launch()
Public Sub Launch
public:
void Launch()

See Also

Spell Class
Launch Overload
wManager.Wow.Class Namespace


Launch Method (Boolean, Boolean, Boolean)

Spell..::..Launch Method (Boolean, Boolean, Boolean)

Cast Spell.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Launch(
    bool stopMove,
    bool waitIsCast,
    bool ignoreIfCast
)
Public Sub Launch ( _
    stopMove As Boolean, _
    waitIsCast As Boolean, _
    ignoreIfCast As Boolean _
)
public:
void Launch(
    bool^ stopMove,
    bool^ waitIsCast,
    bool^ ignoreIfCast
)

Parameters

stopMove
Type: Boolean
if set to true don't move during cast.
waitIsCast
Type: Boolean
if set to true wait the cast end before exit method.
ignoreIfCast
Type: Boolean
if set to true ignore if character casting before to cast this spell.

See Also

Spell Class
Launch Overload
wManager.Wow.Class Namespace


Launch Method (Boolean, Boolean, Boolean, Boolean)

Spell..::..Launch Method (Boolean, Boolean, Boolean, Boolean)

Cast Spell.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Launch(
    bool stopMove,
    bool waitIsCast,
    bool ignoreIfCast,
    bool castOnSelf
)
Public Sub Launch ( _
    stopMove As Boolean, _
    waitIsCast As Boolean, _
    ignoreIfCast As Boolean, _
    castOnSelf As Boolean _
)
public:
void Launch(
    bool^ stopMove,
    bool^ waitIsCast,
    bool^ ignoreIfCast,
    bool^ castOnSelf
)

Parameters

stopMove
Type: Boolean
if set to true don't move during cast.
waitIsCast
Type: Boolean
if set to true wait the cast end before exit method.
ignoreIfCast
Type: Boolean
if set to true ignore if character casting before to cast this spell.
castOnSelf
Type: Boolean
if set to true cast on self.

See Also

Spell Class
Launch Overload
wManager.Wow.Class Namespace


Launch Method (Boolean, Boolean, Boolean, String)

Spell..::..Launch Method (Boolean, Boolean, Boolean, String)

Cast Spell.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Launch(
    bool stopMove,
    bool waitIsCast,
    bool ignoreIfCast,
    string luaUnitId
)
Public Sub Launch ( _
    stopMove As Boolean, _
    waitIsCast As Boolean, _
    ignoreIfCast As Boolean, _
    luaUnitId As String _
)
public:
void Launch(
    bool^ stopMove,
    bool^ waitIsCast,
    bool^ ignoreIfCast,
    String^ luaUnitId
)

Parameters

stopMove
Type: Boolean
if set to true don't move during cast.
waitIsCast
Type: Boolean
if set to true wait the cast end before exit method.
ignoreIfCast
Type: Boolean
if set to true ignore if character casting before to cast this spell.
luaUnitId
Type: String
http://wow.gamepedia.com/UnitId

See Also

Spell Class
Launch Overload
wManager.Wow.Class Namespace


Launch Method (Boolean, Boolean, Boolean, String, Boolean)

Spell..::..Launch Method (Boolean, Boolean, Boolean, String, Boolean)

Cast Spell.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Launch(
    bool stopMove,
    bool waitIsCast,
    bool ignoreIfCast,
    string luaUnitId,
    bool castById
)
Public Sub Launch ( _
    stopMove As Boolean, _
    waitIsCast As Boolean, _
    ignoreIfCast As Boolean, _
    luaUnitId As String, _
    castById As Boolean _
)
public:
void Launch(
    bool^ stopMove,
    bool^ waitIsCast,
    bool^ ignoreIfCast,
    String^ luaUnitId,
    bool^ castById
)

Parameters

stopMove
Type: Boolean
if set to true don't move during cast.
waitIsCast
Type: Boolean
if set to true wait the cast end before exit method.
ignoreIfCast
Type: Boolean
if set to true ignore if character casting before to cast this spell.
luaUnitId
Type: String
http://wow.gamepedia.com/UnitId
castById
Type: Boolean
if set to true cast by spell id (no spell ingame name).

See Also

Spell Class
Launch Overload
wManager.Wow.Class Namespace


ToString Method

Spell..::..ToString Method

Returns a String that represents this instance.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string ToString()
Public Function ToString As String
public:
String^ ToString()

Return Value

A String that represents this instance.

See Also

Spell Class
wManager.Wow.Class Namespace


Spell Properties

The Spell type exposes the following members.

Properties

 | Name | Description
Public property | BuffStack | Gets player buff stack count.
Public property | BuffTimeLeft | Gets player buff time left (in milliseconds).
Public property | GetBuff | Gets player buff
Public property | HaveBuff | Gets if your player have this spell in buff.
Public property | IsDistanceGood | Gets if the player distance to target is good to cast spell.
Public property | IsSpellUsable | Check if the spell is currently usable (cooldown, mana, zone, target (don't check distance)).
Public property | MaxRange | Gets or sets the maximum spell range (if you use CalcuCombatRange the value may be different from that assigned).
Public property | TargetBuffStack | Gets target buff stack count.
Public property | TargetBuffTimeLeft | Gets target buff time left (in milliseconds).
Public property | TargetGetBuff | Gets target buff.
Public property | TargetHaveBuff | Gets if the target have this spell in buff.

See Also

Spell Class
wManager.Wow.Class Namespace


BuffStack Property

Spell..::..BuffStack Property

Gets player buff stack count.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int BuffStack { get; }
Public ReadOnly Property BuffStack As Integer
    Get
public:
property int^ BuffStack {
    int^ get ();
}

Field Value

The buff stack count.

See Also

Spell Class
wManager.Wow.Class Namespace


BuffTimeLeft Property

Spell..::..BuffTimeLeft Property

Gets player buff time left (in milliseconds).

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int BuffTimeLeft { get; }
Public ReadOnly Property BuffTimeLeft As Integer
    Get
public:
property int^ BuffTimeLeft {
    int^ get ();
}

Field Value

The buff time left (in milliseconds).

See Also

Spell Class
wManager.Wow.Class Namespace


GetBuff Property

Spell..::..GetBuff Property

Gets player buff

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Aura GetBuff { get; }
Public ReadOnly Property GetBuff As Aura
    Get
public:
property Aura^ GetBuff {
    Aura^ get ();
}

Field Value

Get the buff.

See Also

Spell Class
wManager.Wow.Class Namespace


HaveBuff Property

Spell..::..HaveBuff Property

Gets if your player have this spell in buff.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool HaveBuff { get; }
Public ReadOnly Property HaveBuff As Boolean
    Get
public:
property bool^ HaveBuff {
    bool^ get ();
}

Field Value

true if have buff; otherwise, false .

See Also

Spell Class
wManager.Wow.Class Namespace


IsDistanceGood Property

Spell..::..IsDistanceGood Property

Gets if the player distance to target is good to cast spell.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsDistanceGood { get; }
Public ReadOnly Property IsDistanceGood As Boolean
    Get
public:
property bool^ IsDistanceGood {
    bool^ get ();
}

Field Value

true if the distance good; otherwise, false .

See Also

Spell Class
wManager.Wow.Class Namespace


IsSpellUsable Property

Spell..::..IsSpellUsable Property

Check if the spell is currently usable (cooldown, mana, zone, target (don't check distance)).

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsSpellUsable { get; }
Public ReadOnly Property IsSpellUsable As Boolean
    Get
public:
property bool^ IsSpellUsable {
    bool^ get ();
}

Field Value

Return true if spell usable; otherwise, false .

See Also

Spell Class
wManager.Wow.Class Namespace


MaxRange Property

Spell..::..MaxRange Property

Gets or sets the maximum spell range (if you use CalcuCombatRange the value may be different from that assigned).

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float MaxRange { get; set; }
Public Property MaxRange As Single
    Get
    Set
public:
property float^ MaxRange {
    float^ get ();
    void set (float^ value);
}

See Also

Spell Class
wManager.Wow.Class Namespace


TargetBuffStack Property

Spell..::..TargetBuffStack Property

Gets target buff stack count.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int TargetBuffStack { get; }
Public ReadOnly Property TargetBuffStack As Integer
    Get
public:
property int^ TargetBuffStack {
    int^ get ();
}

Field Value

The target buff stack count.

See Also

Spell Class
wManager.Wow.Class Namespace


TargetBuffTimeLeft Property

Spell..::..TargetBuffTimeLeft Property

Gets target buff time left (in milliseconds).

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int TargetBuffTimeLeft { get; }
Public ReadOnly Property TargetBuffTimeLeft As Integer
    Get
public:
property int^ TargetBuffTimeLeft {
    int^ get ();
}

Field Value

The target buff time left (in milliseconds).

See Also

Spell Class
wManager.Wow.Class Namespace


TargetGetBuff Property

Spell..::..TargetGetBuff Property

Gets target buff.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Aura TargetGetBuff { get; }
Public ReadOnly Property TargetGetBuff As Aura
    Get
public:
property Aura^ TargetGetBuff {
    Aura^ get ();
}

Field Value

Get the target buff.

See Also

Spell Class
wManager.Wow.Class Namespace


TargetHaveBuff Property

Spell..::..TargetHaveBuff Property

Gets if the target have this spell in buff.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool TargetHaveBuff { get; }
Public ReadOnly Property TargetHaveBuff As Boolean
    Get
public:
property bool^ TargetHaveBuff {
    bool^ get ();
}

Field Value

true if target have buff; otherwise, false .

See Also

Spell Class
wManager.Wow.Class Namespace


SpellInfo Class

Class SpellInfo.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class SpellInfo
Public Class SpellInfo
public ref class SpellInfo

Inheritance Hierarchy

Object
wManager.Wow.Class..::..SpellInfo

See Also

SpellInfo Members
wManager.Wow.Class Namespace


SpellInfo Members

The SpellInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | CastTime | The cast time
Public field | Icon | The icon
Public field | ID | The spell id
Public field | MaxRange | The maximum range
Public field | MinRange | The minimum range
Public field | Name | The name in game
Public field | SubName | The sub name in game

See Also

SpellInfo Class
wManager.Wow.Class Namespace


SpellInfo Fields

The SpellInfo type exposes the following members.

Fields

 | Name | Description
Public field | CastTime | The cast time
Public field | Icon | The icon
Public field | ID | The spell id
Public field | MaxRange | The maximum range
Public field | MinRange | The minimum range
Public field | Name | The name in game
Public field | SubName | The sub name in game

See Also

SpellInfo Class
wManager.Wow.Class Namespace


CastTime Field

SpellInfo..::..CastTime Field

The cast time

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int CastTime
Public CastTime As Integer
public:
int^ CastTime

See Also

SpellInfo Class
wManager.Wow.Class Namespace


Icon Field

SpellInfo..::..Icon Field

The icon

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string Icon
Public Icon As String
public:
String^ Icon

See Also

SpellInfo Class
wManager.Wow.Class Namespace


ID Field

SpellInfo..::..ID Field

The spell id

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint ID
Public ID As UInteger
public:
unsigned int^ ID

See Also

SpellInfo Class
wManager.Wow.Class Namespace


MaxRange Field

SpellInfo..::..MaxRange Field

The maximum range

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float MaxRange
Public MaxRange As Single
public:
float^ MaxRange

See Also

SpellInfo Class
wManager.Wow.Class Namespace


MinRange Field

SpellInfo..::..MinRange Field

The minimum range

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float MinRange
Public MinRange As Single
public:
float^ MinRange

See Also

SpellInfo Class
wManager.Wow.Class Namespace


Name Field

SpellInfo..::..Name Field

The name in game

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string Name
Public Name As String
public:
String^ Name

See Also

SpellInfo Class
wManager.Wow.Class Namespace


SubName Field

SpellInfo..::..SubName Field

The sub name in game

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string SubName
Public SubName As String
public:
String^ SubName

See Also

SpellInfo Class
wManager.Wow.Class Namespace


SpellInfo Methods

The SpellInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

SpellInfo Class
wManager.Wow.Class Namespace


TaxiNode Class

Class TaxiNode.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class TaxiNode
<SerializableAttribute> _
Public Class TaxiNode
[SerializableAttribute]
public ref class TaxiNode

Inheritance Hierarchy

Object
wManager.Wow.Class..::..TaxiNode

See Also

TaxiNode Members
wManager.Wow.Class Namespace


TaxiNode Members

The TaxiNode type exposes the following members.

Constructors

 | Name | Description
Public method | TaxiNode()()()() | Initializes a new instance of the TaxiNode class.
Public method | TaxiNode(Int32, String, Vector3, Int32) | Initializes a new instance of the TaxiNode class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IsRealPosition | Determines whether is valid position.
Public method | IsSimilar | Determines whether the specified taxi node is similar.
Public method | IsValid | Returns true if taxi is valid.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | CharacterAvailable | List of characters names who can use this taxi
Public field | Position | The position
Public field | SlotIndex | The slot index

Properties

 | Name | Description
Public property | Active | Gets or sets a value indicating whether this TaxiNode is active.
Public property | ContinentId | Gets or sets the continent id.
Public property | Name | Gets or sets the name.
Public property | PosX | Gets or sets the position x.
Public property | PosY | Gets or sets the position y.
Public property | PosZ | Gets or sets the position z.

See Also

TaxiNode Class
wManager.Wow.Class Namespace


TaxiNode Constructor

Overload List

 | Name | Description
Public method | TaxiNode()()()() | Initializes a new instance of the TaxiNode class.
Public method | TaxiNode(Int32, String, Vector3, Int32) | Initializes a new instance of the TaxiNode class.

See Also

TaxiNode Class
TaxiNode Members
wManager.Wow.Class Namespace


TaxiNode Constructor

Initializes a new instance of the TaxiNode class.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public TaxiNode()
Public Sub New
public:
TaxiNode()

See Also

TaxiNode Class
TaxiNode Overload
wManager.Wow.Class Namespace


TaxiNode Constructor (Int32, String, Vector3, Int32)

Initializes a new instance of the TaxiNode class.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public TaxiNode(
    int slotIndex,
    string name,
    Vector3 position,
    int continentId
)
Public Sub New ( _
    slotIndex As Integer, _
    name As String, _
    position As Vector3, _
    continentId As Integer _
)
public:
TaxiNode(
    int^ slotIndex,
    String^ name,
    Vector3^ position,
    int^ continentId
)

Parameters

slotIndex
Type: Int32
Index of the slot.
name
Type: String
The name.
position
Type: robotManager.Helpful..::..Vector3
The position.
continentId
Type: Int32
The continent id.

See Also

TaxiNode Class
TaxiNode Overload
wManager.Wow.Class Namespace


TaxiNode Fields

The TaxiNode type exposes the following members.

Fields

 | Name | Description
Public field | CharacterAvailable | List of characters names who can use this taxi
Public field | Position | The position
Public field | SlotIndex | The slot index

See Also

TaxiNode Class
wManager.Wow.Class Namespace


CharacterAvailable Field

TaxiNode..::..CharacterAvailable Field

List of characters names who can use this taxi

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<string> CharacterAvailable
Public CharacterAvailable As List(Of String)
public:
List<String^>^ CharacterAvailable

See Also

TaxiNode Class
wManager.Wow.Class Namespace


Position Field

TaxiNode..::..Position Field

The position

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Vector3 Position
Public Position As Vector3
public:
Vector3^ Position

See Also

TaxiNode Class
wManager.Wow.Class Namespace


SlotIndex Field

TaxiNode..::..SlotIndex Field

The slot index

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int SlotIndex
Public SlotIndex As Integer
public:
int^ SlotIndex

See Also

TaxiNode Class
wManager.Wow.Class Namespace


TaxiNode Methods

The TaxiNode type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IsRealPosition | Determines whether is valid position.
Public method | IsSimilar | Determines whether the specified taxi node is similar.
Public method | IsValid | Returns true if taxi is valid.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

TaxiNode Class
wManager.Wow.Class Namespace


IsRealPosition Method

TaxiNode..::..IsRealPosition Method

Determines whether is valid position.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsRealPosition()
Public Function IsRealPosition As Boolean
public:
bool^ IsRealPosition()

Return Value

true if is valid position; otherwise, false.

See Also

TaxiNode Class
wManager.Wow.Class Namespace


IsSimilar Method

TaxiNode..::..IsSimilar Method

Determines whether the specified taxi node is similar.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsSimilar(
    TaxiNode taxiNode
)
Public Function IsSimilar ( _
    taxiNode As TaxiNode _
) As Boolean
public:
bool^ IsSimilar(
    TaxiNode^ taxiNode
)

Parameters

taxiNode
Type: wManager.Wow.Class..::..TaxiNode
The taxi node.

Return Value

true if the specified taxi node is similar; otherwise, false.

See Also

TaxiNode Class
wManager.Wow.Class Namespace


IsValid Method

TaxiNode..::..IsValid Method

Returns true if taxi is valid.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsValid()
Public Function IsValid As Boolean
public:
bool^ IsValid()

Return Value

true if this instance is valid; otherwise, false.

See Also

TaxiNode Class
wManager.Wow.Class Namespace


TaxiNode Properties

The TaxiNode type exposes the following members.

Properties

 | Name | Description
Public property | Active | Gets or sets a value indicating whether this TaxiNode is active.
Public property | ContinentId | Gets or sets the continent id.
Public property | Name | Gets or sets the name.
Public property | PosX | Gets or sets the position x.
Public property | PosY | Gets or sets the position y.
Public property | PosZ | Gets or sets the position z.

See Also

TaxiNode Class
wManager.Wow.Class Namespace


Active Property

TaxiNode..::..Active Property

Gets or sets a value indicating whether this TaxiNode is active.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool Active { get; set; }
Public Property Active As Boolean
    Get
    Set
public:
property bool^ Active {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if active; otherwise, false.

See Also

TaxiNode Class
wManager.Wow.Class Namespace


ContinentId Property

TaxiNode..::..ContinentId Property

Gets or sets the continent id.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int ContinentId { get; set; }
Public Property ContinentId As Integer
    Get
    Set
public:
property int^ ContinentId {
    int^ get ();
    void set (int^ value);
}

Field Value

The continent id.

See Also

TaxiNode Class
wManager.Wow.Class Namespace


Name Property

TaxiNode..::..Name Property

Gets or sets the name.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Field Value

The name.

See Also

TaxiNode Class
wManager.Wow.Class Namespace


PosX Property

TaxiNode..::..PosX Property

Gets or sets the position x.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[XmlIgnoreAttribute]
public float PosX { get; set; }
<XmlIgnoreAttribute> _
Public Property PosX As Single
    Get
    Set
[XmlIgnoreAttribute]
public:
property float^ PosX {
    float^ get ();
    void set (float^ value);
}

Field Value

The position x.

See Also

TaxiNode Class
wManager.Wow.Class Namespace


PosY Property

TaxiNode..::..PosY Property

Gets or sets the position y.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[XmlIgnoreAttribute]
public float PosY { get; set; }
<XmlIgnoreAttribute> _
Public Property PosY As Single
    Get
    Set
[XmlIgnoreAttribute]
public:
property float^ PosY {
    float^ get ();
    void set (float^ value);
}

Field Value

The position y.

See Also

TaxiNode Class
wManager.Wow.Class Namespace


PosZ Property

TaxiNode..::..PosZ Property

Gets or sets the position z.

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[XmlIgnoreAttribute]
public float PosZ { get; set; }
<XmlIgnoreAttribute> _
Public Property PosZ As Single
    Get
    Set
[XmlIgnoreAttribute]
public:
property float^ PosZ {
    float^ get ();
    void set (float^ value);
}

Field Value

The position z.

See Also

TaxiNode Class
wManager.Wow.Class Namespace


wManager.Wow.Enums Namespace

Classes

 | Class | Description
Public class | DefaultConstSettings | Class DefaultConstSettings (pathfinder).
Public class | Guid128 | Class Guid128. Read info from Guid and can convert it to lua guid https://wowwiki.fandom.com/wiki/UnitId

Enumerations

 | Enumeration | Description
Public enumeration | BagType | BagType: https://wowwiki.fandom.com/wiki/ItemFamily
Public enumeration | BattleGroundID | BattleGroundID
Public enumeration | CGWorldFrameHitFlags | CGWorldFrameHitFlags, used by TraceLine
Public enumeration | ChatTypeId | ChatTypeId
Public enumeration | ClickToMoveType | ClickToMoveType
Public enumeration | ContinentId | ContinentId
Public enumeration | GameObjectFlags |
Public enumeration | GossipOptionsType | GossipOptionsType
Public enumeration | GuidSubType | GuidSubType
Public enumeration | GuidType | GuidType
Public enumeration | InventorySlot | InventorySlot http://wowpedia.org/API_TYPE_InventorySlotID
Public enumeration | Keybindings | Keybindings
Public enumeration | Landmarks | Landmarks
Public enumeration | LuaEventsId | Obsolete. LuaEventsId
Public enumeration | MountFlags | MountFlags
Public enumeration | NpcMarker | NpcMarker
Public enumeration | PlayerFactions | PlayerFactions
Public enumeration | PowerType | PowerType
Public enumeration | Reaction | Reaction
Public enumeration | RuneTypes |
Public enumeration | SkillLine | SkillLine
Public enumeration | SurveyTool | SurveyTool
Public enumeration | TotemType | TotemType
Public enumeration | TrackCreatureFlags | TrackCreatureFlags
Public enumeration | TrackObjectFlags | TrackObjectFlags
Public enumeration | UnitClassification | UnitClassification
Public enumeration | UnitDynamicFlags | UnitDynamicFlags
Public enumeration | UnitFlags | UnitFlags
Public enumeration | UnitNPCFlags | UnitNPCFlags
Public enumeration | WoWClass | WoWClass
Public enumeration | WoWGameObjectLockKeyType | WoWGameObjectLockKeyType
Public enumeration | WoWGameObjectLockType | WoWGameObjectLockType
Public enumeration | WoWGameObjectType | WoWGameObjectType
Public enumeration | WoWGender | WoWGender
Public enumeration | WoWInventorySlot |
Public enumeration | WoWItemQuality | WoWItemQuality
Public enumeration | WoWObjectType | WoWObjectType
Public enumeration | WoWRace | WoWRace (ChrRaces.db2)
Public enumeration | WowSpecializations | WowSpecializations


BagType Enumeration

BagType: https://wowwiki.fandom.com/wiki/ItemFamily

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public enum BagType
Public Enumeration BagType
public enum class BagType

Members

Member name | Description
Unspecified |
Quiver |
AmmoPouch |
Soul |
Leatherworking |
Inscription |
Herb |
Enchanting |
Engineering |
Keyring |
Gem |
Mining |
Unknown |
Vanity |

See Also

wManager.Wow.Enums Namespace


BattleGroundID Enumeration

BattleGroundID

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public enum BattleGroundID
Public Enumeration BattleGroundID
public enum class BattleGroundID

Members

Member name | Description
AB |
AV |
BfG |
EotS |
IoC |
None |
RandomBattleground |
SM |
SotA |
ToK |
TP |
WSG |
DG |

See Also

wManager.Wow.Enums Namespace


CGWorldFrameHitFlags Enumeration

CGWorldFrameHitFlags, used by TraceLine

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[FlagsAttribute]
public enum CGWorldFrameHitFlags
<FlagsAttribute> _
Public Enumeration CGWorldFrameHitFlags
[FlagsAttribute]
public enum class CGWorldFrameHitFlags

Members

Member name | Description
HitTestNothing |
HitTestBoundingModels |
HitTestSpellLoS |
HitTestWMO |
HitTestWMONoCam |
HitTestUnknown2 |
HitTestGround |
HitTestLiquid |
HitTestLiquid2 |
HitTestMovableObjects |
HitTestUnknown3 |
HitTestUnknown4 |
HitTestLOS |
HitTestGroundAndStructures |
HitTestAll |
HitTestAllWhitoutLiquid |
HitTestWater |

See Also

wManager.Wow.Enums Namespace


ChatTypeId Enumeration

ChatTypeId

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public enum ChatTypeId
Public Enumeration ChatTypeId
public enum class ChatTypeId

Members

Member name | Description
All |
SAY |
PARTY |
RAID |
GUILD |
OFFICER |
YELL |
WHISPER |
WHISPER_SEND |
EMOTE |
CHANNEL |
AFK |
DND |
RAID_WARNING |
BN |
PARTYLEADER |
BN_WHISPER |
BN_WHISPER_INFORM |
BN_CONVERSATION |
INSTANCE_CHAT |
none |

See Also

wManager.Wow.Enums Namespace


ClickToMoveType Enumeration

ClickToMoveType

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public enum ClickToMoveType
Public Enumeration ClickToMoveType
public enum class ClickToMoveType

Members

Member name | Description
FaceTarget |
Face |
StopThrowsException | Will throw a UI error. Have not figured out how to avoid it!
Move |
NpcInteract |
Loot |
ObjInteract |
FaceOther |
Skin |
AttackPosition |
AttackGuid |
ConstantFace |
None |
Attack |
Idle |

See Also

wManager.Wow.Enums Namespace


ContinentId Enumeration

ContinentId

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public enum ContinentId
Public Enumeration ContinentId
public enum class ContinentId

Members

Member name | Description
Azeroth |
Kalimdor |
test |
ScottTest |
PVPZone01 |
Shadowfang |
StormwindJail |
StormwindPrison |
DeadminesInstance |
PVPZone02 |
Collin |
WailingCaverns |
Monastery |
RazorfenKraulInstance |
Blackfathom |
Uldaman |
GnomeragonInstance |
SunkenTemple |
RazorfenDowns |
EmeraldDream |
MonasteryInstances |
TanarisInstance |
BlackRockSpire |
BlackrockDepths |
OnyxiaLairInstance |
CavernsOfTime |
SchoolofNecromancy |
Zul_gurub |
Stratholme |
Mauradon |
DeeprunTram |
OrgrimmarInstance |
MoltenCore |
DireMaul |
AlliancePVPBarracks |
HordePVPBarracks |
development |
BlackwingLair |
PVPZone03 |
AhnQiraj |
PVPZone04 |
Expansion01 |
AhnQirajTemple |
Karazahn |
Stratholme_Raid |
HyjalPast |
HellfireMilitary |
HellfireDemon |
HellfireRampart |
HellfireRaid |
CoilfangPumping |
CoilfangMarsh |
CoilfangDraenei |
CoilfangRaid |
TempestKeepRaid |
TempestKeepArcane |
TempestKeepAtrium |
TempestKeepFactory |
AuchindounShadow |
AuchindounDemon |
AuchindounEthereal |
AuchindounDraenei |
PVPZone05 |
HillsbradPast |
bladesedgearena |
BlackTemple |
GruulsLair |
NetherstormBG |
ZulAman |
Northrend |
PVPLordaeron |
ExteriorTest |
Valgarde70 |
UtgardePinnacle |
Nexus70 |
Nexus80 |
SunwellPlateau |
Transport176244 |
Transport176231 |
Sunwell5ManFix |
Transport181645 |
Transport177233 |
Transport176310 |
Transport175080 |
Transport176495 |
Transport164871 |
Transport186238 |
Transport20808 |
Transport187038 |
StratholmeCOT |
Transport187263 |
CraigTest |
Sunwell5Man |
Ulduar70 |
DrakTheronKeep |
Azjol_Uppercity |
Ulduar80 |
UlduarRaid |
GunDrak |
development_nonweighted |
QA_DVD |
NorthrendBG |
DalaranPrison |
DeathKnightStart |
Transport_Tirisfal__Vengeance_Landing |
Transport_Menethil_Valgarde |
Transport_Orgrimmar_Warsong_Hold |
Transport_Stormwind_Valiance_Keep |
ChamberOfAspectsBlack |
NexusRaid |
DalaranArena |
OrgrimmarArena |
Azjol_LowerCity |
Transport_Moa_ki_Unu_pe |
Transport_Moa_ki_Kamagua |
Transport192241 |
Transport192242 |
WintergraspRaid |
unused |
IsleofConquest |
IcecrownCitadel |
IcecrownCitadel5Man |
AbyssalMaw |
Gilneas |
Transport_AllianceAirshipBG |
Transport_HordeAirshipBG |
AbyssalMaw_Interior |
Uldum |
BlackRockSpire_4_0 |
Deephome |
Transport_Orgrimmar_to_Thunderbluff |
LostIsles |
ArgentTournamentRaid |
ArgentTournamentDungeon |
ElevatorSpawnTest |
Gilneas2 |
GilneasPhase1 |
GilneasPhase2 |
SkywallDungeon |
QuarryofTears |
LostIslesPhase1 |
Deephomeceiling |
LostIslesPhase2 |
Transport197195 |
HallsOfReflection |
BlackwingDescent |
GrimBatolDungeon |
GrimBatolRaid |
Transport197347 |
Transport197348 |
Transport197349_2 |
Transport197349 |
Transport197350 |
Transport201834 |
MountHyjalPhase1 |
Firelands1 |
Firelands2 |
Stormwind |
ChamberofAspectsRed |
DeepholmeDungeon |
CataclysmCTF |
STV_Mine_BG |
TheBattleforGilneas |
MaelstromZone |
DesolaceBomb |
TolBarad |
AhnQirajTerrace |
TwilightHighlandsDragonmawPhase |
Transport200100 |
Transport200101 |
Transport200102 |
Transport200103 |
Transport203729 |
Transport203730 |
UldumPhaseOasis |
Transport_203732 |
Transport203858 |
Transport203859 |
Transport203860 |
RedgridgeOrcBomb |
RedridgeBridgePhaseOne |
RedridgeBridgePhaseTwo |
SkywallRaid |
UldumDungeon |
BaradinHold |
UldumPhasedEntrance |
TwilightHighlandsPhasedEntrance |
Gilneas_BG_2 |
Transport_203861 |
Transport_203862 |
UldumPhaseWreckedCamp |
Transport203863 |
Transport_2033864 |
Transport_2033865 |
Zul_Gurub5Man |
NewRaceStartZone |
FirelandsDailies |
HawaiiMainLand |
ScenarioAlcazIsland |
COTDragonblight |
COTWarOfTheAncients |
TheHourOfTwilight |
NexusLegendary |
ShadowpanHideout |
EastTemple |
StormstoutBrewery |
TheGreatWall |
DeathwingBack |
EyeoftheStorm2_0 |
JadeForestAllianceHubPhase |
JadeForestBattlefieldPhase |
DarkmoonFaire |
TurtleShipPhase01 |
TurtleShipPhase02 |
MaelstromDeathwingFight |
TolVirArena |
MoguDungeon |
MoguInteriorRaid |
MoguExteriorRaid |
ValleyOfPower |
BFTAllianceScenario |
BFTHordeScenario |
ScarletSanctuaryArmoryAndLibrary |
ScarletMonasteryCathedralGY |
BrewmasterScenario01 |
NewScholomance |
MogushanPalace |
MantidRaid |
MistsCTF3 |
MantidDungeon |
MonkAreaScenario |
RuinsOfTheramore |
PandaFishingVillageScenario |
MoguRuinsScenario |
AncientMoguCryptScenario |
AncientMoguCyptDestroyedScenario |
ProvingGroundsScenario |
PetBattleJadeForest |
ValleyOfPowerScenario |
RingOfValorScenario |
BrewmasterScenario03 |
BlackOxTempleScenario |
ScenarioKlaxxiIsland |
ScenarioBrewmaster04 |
LevelDesignLand_DevOnly |
HordeBeachDailyArea |
AllianceBeachDailyArea |
MoguIslandDailyArea |
StormwindGunshipPandariaStartArea |
OrgrimmarGunshipPandariaStart |
TheramoreScenarioPhase |
JadeForestHordeStartingArea |
HordeAmbushScenario |
ThunderIslandRaid |
NavalBattleScenario |
DefenseOfTheAleHouseBG |
HordeBaseBeachScenario |
AllianceBaseBeachScenario |
ALittlePatienceScenario |
GoldRushBG |
JainaDalaranScenario |
WarlockArea |
BlackTempleScenario |
DarkmoonCarousel |
Draenor |
ThunderKingHordeHub |
ThunderIslandAllianceHub |
CitySiegeMoguIslandProgressionScenario |
LightningForgeMoguIslandProgressionScenario |
ShipyardMoguIslandProgressionScenario |
AllianceHubMoguIslandProgressionScenario |
HordeHubMoguIslandProgressionScenario |
FinalGateMoguIslandProgressionScenario |
MoguIslandEventsHordeBase |
MoguIslandEventsAllianceBase |
ShimmerRidgeScenario |
DarkHordeScenario |
Transport218599 |
Transport218600 |
ShadoPanArena |
MoguIslandLootRoom |
OrgrimmarRaid |
HeartOfTheOldGodScenario |
ProvingGrounds |
FWHordeGarrisonLevel1 |
FWHordeGarrisonLevel2 |
FWHordeGarrisonLevel3 |
Stormgarde_Keep |
HalfhillScenario |
SMVAllianceGarrisonLevel1 |
SMVAllianceGarrisonLevel2 |
SMVAllianceGarrisonLevel3 |
CelestialChallenge |
SmallBattlegroundA |
ThePurgeOfGrommarScenario |
SmallBattlegroundB |
SmallBattlegroundC |
SmallBattlegroundD |
Transport_Siege_of_Orgrimmar_Alliance |
Transport_Siege_of_Orgrimmar_Horde |
OgreCompound |
MoonCultistHideout |
WarcraftHeroes |
PattyMackTestGarrisonBldgMap |
DraenorAuchindoun |
GORAllianceGarrisonLevel1 |
GORAllianceGarrisonLevel2 |
GORAllianceGarrisonLevel3 |
BlastedLands |
Ashran |
Transport_Iron_Horde_Gorgrond_Train |
WarWharfSmackdown |
BonetownScenario |
FrostfireFinaleScenario |
BlackrockFoundryRaid |
TaladorIronHordeFinaleScenario |
BlackrockFoundryTrainDepot |
ArakkoaDungeon |
_6HU_GARRISON_Blacksmithing_hub |
alliance_garrison_alchemy |
alliance_garrison_enchanting |
garrison_alliance_engineering |
garrison_alliance_farmhouse |
garrison_alliance_inscription |
garrison_alliance_jewelcrafting |
garrison_alliance_leatherworking |
garrison_alliance_mine_1 |
garrison_alliance_mine_2 |
garrison_alliance_mine_3 |
garrison_alliance_stable_1 |
garrison_alliance_stable_2 |
garrison_alliance_stable_3 |
garrison_alliance_tailoring |
HighmaulOgreRaid |
garrison_alliance_inn_1 |
garrison_alliance_barn |
Transport227523 |
GorHordeGarrisonLevel0 |
GORHordeGarrisonLevel3 |
TALAllianceGarrisonLevel0 |
TALAllianceGarrisonLevel3 |
TALHordeGarrisonLevel0 |
TALHordeGarrisonLevel3 |
SOAAllianceGarrison0 |
SOAAllianceGarrison3 |
SOAHordeGarrison0 |
SOAHordeGarrison3 |
NAGAllianceGarrisonLevel0 |
NAGAllianceGarrisonLevel3 |
NAGHordeGarrisonLevel0 |
NAGHordeGarrisonLevel3 |
garrison_alliance_armory1 |
garrison_alliance_barracks1 |
garrison_alliance_engineering1 |
alliance_garrison_herb_garden1 |
alliance_garrison_inn1 |
garrison_alliance_lumbermill1 |
alliance_garrison_magetower1 |
garrison_alliance_pet_stable1 |
garrison_alliance_salvageyard1 |
garrison_alliance_storehouse1 |
garrison_alliance_trading_post1 |
garrison_alliance_tailoring1 |
garrison_alliance_enchanting |
garrison_alliance_blacksmith1 |
garrison_alliance_plot_small |
garrison_alliance_plot_medium |
garrison_alliance_plot_large |
Propland_DevOnly |
TanaanJungleIntro |
CircleofBloodScenario |
TerongorsConfrontation |
devland3 |
nagrand_garrison_camp_stable_2 |
DefenseOfKaraborScenario |
garrison_horde_barracks1 |
ShaperDungeon |
TrollRaid2 |
garrison_horde_alchemy1 |
garrison_horde_armory1 |
garrison_horde_barn1 |
garrison_horde_blacksmith1 |
garrison_horde_enchanting1 |
garrison_horde_engineering1 |
garrison_horde_inn1 |
garrison_horde_inscription1 |
garrison_horde_jewelcrafting1 |
garrison_horde_leatherworking1 |
garrison_horde_lumbermill1 |
garrison_horde_magetower1 |
garrison_horde_mine1 |
garrison_alliance_petstabe |
garrison_horde_salvageyard1 |
garrison_horde_sparringarena1 |
garrison_horde_stable1 |
garrison_horde_storehouse1 |
garrison_horde_tailoring1 |
garrison_horde_tradingpost1 |
garrison_horde_workshop1 |
garrison_alliance_workshop1 |
garrison_horde_farm1 |
garrison_horde_plot_large |
garrison_horde_plot_medium |
garrison_horde_plot_small |
TanaanJungleIntroForgePhase |
garrison_horde_fishing1 |
garrison_alliance_fishing1 |
Expansion5QAModelMap |
outdoorGarrisonArenaHorde |
outdoorGarrisonArenaAlliance |
outdoorGarrisonLumberMillAlliance |
outdoorGarrisonLumberMillHorde |
outdoorGarrisonArmoryHorde |
outdoorGarrisonArmoryAlliance |
outdoorGarrisonMageTowerHorde |
outdoorGarrisonMageTowerAlliance |
outdoorGarrisonStablesHorde |
outdoorGarrisonStablesAlliance |
outdoorGarrisonWorkshopHorde |
outdoorGarrisonWorkshopAlliance |
outdoorGarrisonInnHorde |
outdoorGarrisonInnAlliance |
outdoorGarrisonTradingPostHorde |
outdoorGarrisonTradingPostAlliance |
outdoorGarrisonConstructionPlotHorde |
outdoorGarrisonConstructionPlotAlliance |
GrommasharScenario |
FWHordeGarrisonLeve2new |
SMVAllianceGarrisonLevel2new |
garrison_horde_barracks2 |
garrison_horde_armory2 |
garrison_horde_barn2 |
garrison_horde_inn2 |
garrison_horde_lumbermill2 |
garrison_horde_magetower2 |
garrison_horde_petstable2 |
garrison_horde_stable2 |
garrison_horde_tradingpost2 |
garrison_horde_workshop2 |
garrison_horde_barracks3 |
garrison_horde_armory3 |
garrison_horde_barn3 |
garrison_horde_inn3 |
garrison_horde_magetower3 |
garrison_horde_petstable3 |
garrison_horde_stable3 |
garrison_horde_tradingpost3 |
garrison_horde_workshop3 |
Garrison_Alliance_Large_Construction |
Garrison_Alliance_Medium_Construction |
Garrison_Horde_Large_Construction |
Garrison_Horde_Medium_Construction |
UpperBlackRockSpire |
garrisonAllianceMageTower2 |
garrisonAllianceMageTower3 |
garrison_horde_mine2 |
garrison_horde_mine3 |
garrison_alliance_workshop2 |
garrison_alliance_workshop3 |
garrison_alliance_lumbermill2 |
garrison_alliance_lumbermill3 |
Garrison_Horde_Small_Construction |
Garrison_Alliance_Small_Construction |
AuchindounQuest |
alliance_garrison_alchemy_rank2 |
alliance_garrison_alchemy_rank3 |
garrison_alliance_blacksmith2 |
garrison_alliance_enchanting2 |
garrison_alliance_engineering2 |
garrison_alliance_inscription2 |
garrison_alliance_inscription3 |
garrison_alliance_jewelcrafting2 |
garrison_alliance_jewelcrafting3 |
garrison_alliance_leatherworking2 |
garrison_alliance_leatherworking3 |
garrison_alliance_tailoring2 |
garrison_alliance_storehouse2 |
garrison_alliance_storehouse3 |
garrison_horde_storehouse2 |
garrison_horde_storehouse3 |
garrison_alliance_salvageyard2 |
garrison_alliance_salvageyard3 |
garrison_horde_lumbermill3 |
garrison_alliance_pet_stable2 |
garrison_alliance_pet_stable3 |
garrison_alliance_trading_post2 |
garrison_alliance_trading_post3 |
garrison_alliance_barn2 |
garrison_alliance_barn3 |
garrison_alliance_inn_2 |
garrison_alliance_inn_3 |
GorgrondFinaleScenario |
garrison_alliance_barracks2 |
garrison_alliance_barracks3 |
garrison_alliance_armory2 |
garrison_alliance_armory3 |
GorgrondFinaleScenarioMap |
garrison_horde_sparringarena2 |
garrison_horde_sparringarena3 |
garrison_horde_alchemy2 |
garrison_horde_alchemy3 |
garrison_horde_blacksmith2 |
garrison_horde_blacksmith3 |
garrison_horde_enchanting2 |
garrison_horde_enchanting3 |
garrison_horde_inscription2 |
garrison_horde_inscription3 |
garrison_horde_leatherworking2 |
garrison_horde_leatherworking3 |
garrison_horde_jewelcrafting2 |
garrison_horde_jewelcrafting3 |
garrison_horde_tailoring2 |
garrison_horde_tailoring3 |
garrison_horde_salvageyard2 |
garrison_horde_salvageyard3 |
PattyMackTestGarrisonBldgMap2 |
garrison_horde_engineering2 |
garrison_horde_engineering3 |
SparringArenaLevel3Stadium |
garrison_horde_fishing2 |
garrison_horde_fishing3 |
garrison_alliance_fishing2 |
garrison_alliance_fishing3 |
garrison_alliance_petstable1 |
garrison_alliance_petstable2 |
garrison_alliance_petstable3 |
garrison_alliance_infirmary1 |
garrison_alliance_infirmary2 |
garrison_alliance_infirmary3 |
outdoorGarrisonConstructionPlotAllianceLarge |
outdoorGarrisonConstructionPlotHordeLarge |
HellfireRaid62 |
TanaanLegionTest |
EdgeofRealityMount |
Transport_The_Iron_Mountain |
TanaanJungle |
TanaanJungleNoHubsPhase |
GarrisonAllianceShipyard |
GarrisonHordeShipyard |
GarrisonShipyardAllianceSubmarine |
GarrisonShipyardAllianceDestroyer |
GarrisonShipyardTransport |
GarrisonShipyardDreadnaught |
GarrisonShipyardCarrier |
GarrisonShipyardHordeSubmarine |
GarrisonShipyardHordeDestroyer |
GarrisonShipyardCarrierAlliance |
GarrisonShipyardGalleonHorde |
None |

See Also

wManager.Wow.Enums Namespace


DefaultConstSettings Class

Class DefaultConstSettings (pathfinder).

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class DefaultConstSettings
Public NotInheritable Class DefaultConstSettings
public ref class DefaultConstSettings abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Enums..::..DefaultConstSettings

See Also

DefaultConstSettings Members
wManager.Wow.Enums Namespace


DefaultConstSettings Members

The DefaultConstSettings type exposes the following members.

Methods

Name Description

Fields

Name | Description
BlacklistTilePolyDefault | The defaults pathfinder blacklisted spots (now server side)
OffMeshConnectionsDefault | The defaults pathfinder OffMeshConnections (now server side)

See Also

DefaultConstSettings Class
wManager.Wow.Enums Namespace


DefaultConstSettings Fields

The DefaultConstSettings type exposes the following members.

Fields

Name | Description
BlacklistTilePolyDefault | The defaults pathfinder blacklisted spots (now server side)
OffMeshConnectionsDefault | The defaults pathfinder OffMeshConnections (now server side)

See Also

DefaultConstSettings Class
wManager.Wow.Enums Namespace


BlacklistTilePolyDefault Field

DefaultConstSettings..::..BlacklistTilePolyDefault Field

The defaults pathfinder blacklisted spots (now server side)

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static Blackspot[] BlacklistTilePolyDefault
Public Shared BlacklistTilePolyDefault As Blackspot()
public:
static array<Blackspot^>^ BlacklistTilePolyDefault

See Also

DefaultConstSettings Class
wManager.Wow.Enums Namespace


OffMeshConnectionsDefault Field

DefaultConstSettings..::..OffMeshConnectionsDefault Field

The defaults pathfinder OffMeshConnections (now server side)

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static OffMeshConnection[] OffMeshConnectionsDefault
Public Shared OffMeshConnectionsDefault As OffMeshConnection()
public:
static array<OffMeshConnection^>^ OffMeshConnectionsDefault

See Also

DefaultConstSettings Class
wManager.Wow.Enums Namespace


DefaultConstSettings Methods

The DefaultConstSettings type exposes the following members.

Methods

Name Description

See Also

DefaultConstSettings Class
wManager.Wow.Enums Namespace


GameObjectFlags Enumeration

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[FlagsAttribute]
public enum GameObjectFlags
<FlagsAttribute> _
Public Enumeration GameObjectFlags
[FlagsAttribute]
public enum class GameObjectFlags

Members

Member name | Description
InUse |
Locked |
ConditionalInteraction |
Transport |
CanNotBeInteracted |
DoesNotDespawn |
Triggered |
GOFlag_0x80 |
GOFlag_0x100 |
Damaged |
Destroyed |
GOFlag_0x800 |
GOFlag_0x1000 |
GOFlag_0x2000 |
GOFlag_0x4000 |
Flag_0x10000 |
Flag_0x20000 |
Flag_0x40000 |
GOFlag_0x8000 |

See Also

wManager.Wow.Enums Namespace


GossipOptionsType Enumeration

GossipOptionsType

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public enum GossipOptionsType
Public Enumeration GossipOptionsType
public enum class GossipOptionsType

Members

Member name | Description
banker |
battlemaster |
binder |
gossip |
healer |
petition |
tabard |
taxi |
trainer |
unlearn |
vendor |

See Also

wManager.Wow.Enums Namespace


Guid128 Class

Class Guid128. Read info from Guid and can convert it to lua guid https://wowwiki.fandom.com/wiki/UnitId

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class Guid128
Public Class Guid128
public ref class Guid128

Inheritance Hierarchy

Object
wManager.Wow.Enums..::..Guid128

See Also

Guid128 Members
wManager.Wow.Enums Namespace


Guid128 Members

The Guid128 type exposes the following members.

Constructors

 | Name | Description
Public method | Guid128()()()() | Initializes a new instance of the Guid128 class.
Public method | Guid128(Int128) | Initializes a new instance of the Guid128 class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance.

Fields

 | Name | Description
Public field | Guid | The unique identifier

Properties

 | Name | Description
Public property | GetWoWSubType | Gets the sub type of the object.
Public property | Id | Gets the identifier.
Public property | InstanceId | Gets the instance identifier.
Public property | ServerId | Gets the server identifier.
Public property | SpawnUID | Gets the spawn uid.
Public property | WoWType | Gets the type of the object type
Public property | ZoneUID | Gets the zone uid.

See Also

Guid128 Class
wManager.Wow.Enums Namespace


Guid128 Constructor

Overload List

 | Name | Description
Public method | Guid128()()()() | Initializes a new instance of the Guid128 class.
Public method | Guid128(Int128) | Initializes a new instance of the Guid128 class.

See Also

Guid128 Class
Guid128 Members
wManager.Wow.Enums Namespace


Guid128 Constructor

Initializes a new instance of the Guid128 class.

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Guid128()
Public Sub New
public:
Guid128()

See Also

Guid128 Class
Guid128 Overload
wManager.Wow.Enums Namespace


Guid128 Constructor (Int128)

Initializes a new instance of the Guid128 class.

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Guid128(
    Int128 guid
)
Public Sub New ( _
    guid As Int128 _
)
public:
Guid128(
    Int128^ guid
)

Parameters

guid
Type: Int128
The unique identifier.

See Also

Guid128 Class
Guid128 Overload
wManager.Wow.Enums Namespace


Guid128 Fields

The Guid128 type exposes the following members.

Fields

 | Name | Description
Public field | Guid | The unique identifier

See Also

Guid128 Class
wManager.Wow.Enums Namespace


Guid Field

Guid128..::..Guid Field

The unique identifier

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Int128 Guid
Public Guid As Int128
public:
Int128^ Guid

See Also

Guid128 Class
wManager.Wow.Enums Namespace


Guid128 Methods

The Guid128 type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance.

See Also

Guid128 Class
wManager.Wow.Enums Namespace


ToString Method

Guid128..::..ToString Method

Returns a String that represents this instance.

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string ToString()
Public Function ToString As String
public:
String^ ToString()

Return Value

A String that represents this instance.

See Also

Guid128 Class
wManager.Wow.Enums Namespace


Guid128 Properties

The Guid128 type exposes the following members.

Properties

 | Name | Description
Public property | GetWoWSubType | Gets the sub type of the object.
Public property | Id | Gets the identifier.
Public property | InstanceId | Gets the instance identifier.
Public property | ServerId | Gets the server identifier.
Public property | SpawnUID | Gets the spawn uid.
Public property | WoWType | Gets the type of the object type
Public property | ZoneUID | Gets the zone uid.

See Also

Guid128 Class
wManager.Wow.Enums Namespace


GetWoWSubType Property

Guid128..::..GetWoWSubType Property

Gets the sub type of the object.

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public GuidSubType GetWoWSubType { get; }
Public ReadOnly Property GetWoWSubType As GuidSubType
    Get
public:
property GuidSubType^ GetWoWSubType {
    GuidSubType^ get ();
}

Field Value

The object sub type.

See Also

Guid128 Class
wManager.Wow.Enums Namespace


Id Property

Guid128..::..Id Property

Gets the identifier.

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint Id { get; }
Public ReadOnly Property Id As UInteger
    Get
public:
property unsigned int^ Id {
    unsigned int^ get ();
}

Field Value

The identifier.

See Also

Guid128 Class
wManager.Wow.Enums Namespace


InstanceId Property

Guid128..::..InstanceId Property

Gets the instance identifier.

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public ushort InstanceId { get; }
Public ReadOnly Property InstanceId As UShort
    Get
public:
property unsigned short^ InstanceId {
    unsigned short^ get ();
}

Field Value

The instance identifier.

See Also

Guid128 Class
wManager.Wow.Enums Namespace


ServerId Property

Guid128..::..ServerId Property

Gets the server identifier.

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public ushort ServerId { get; }
Public ReadOnly Property ServerId As UShort
    Get
public:
property unsigned short^ ServerId {
    unsigned short^ get ();
}

Field Value

The server identifier.

See Also

Guid128 Class
wManager.Wow.Enums Namespace


SpawnUID Property

Guid128..::..SpawnUID Property

Gets the spawn uid.

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public ulong SpawnUID { get; }
Public ReadOnly Property SpawnUID As ULong
    Get
public:
property unsigned long long^ SpawnUID {
    unsigned long long^ get ();
}

Field Value

The spawn uid.

See Also

Guid128 Class
wManager.Wow.Enums Namespace


WoWType Property

Guid128..::..WoWType Property

Gets the type of the object type

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public GuidType WoWType { get; }
Public ReadOnly Property WoWType As GuidType
    Get
public:
property GuidType^ WoWType {
    GuidType^ get ();
}

Field Value

The type of the object.

See Also

Guid128 Class
wManager.Wow.Enums Namespace


ZoneUID Property

Guid128..::..ZoneUID Property

Gets the zone uid.

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public ushort ZoneUID { get; }
Public ReadOnly Property ZoneUID As UShort
    Get
public:
property unsigned short^ ZoneUID {
    unsigned short^ get ();
}

Field Value

The zone uid.

See Also

Guid128 Class
wManager.Wow.Enums Namespace


GuidSubType Enumeration

GuidSubType

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public enum GuidSubType
Public Enumeration GuidSubType
public enum class GuidSubType

Members

Member name | Description
None |

See Also

wManager.Wow.Enums Namespace


GuidType Enumeration

GuidType

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public enum GuidType
Public Enumeration GuidType
public enum class GuidType

Members

Member name | Description
None |
Uniq |
Player |
Item |
WorldTransaction |
StaticDoor |
Transport |
Conversation |
Creature |
Vehicle |
Pet |
GameObject |
DynamicObject |
AreaTrigger |
Corpse |
LootObject |
SceneObject |
Scenario |
AIGroup |
DynamicDoor |
ClientActor |
Vignette |
CallForHelp |
AIResource |
AILock |
AILockTicket |
ChatChannel |
Party |
Guild |
WowAcount |
BNetAccount |
GMTask |
MobileSession |
RaidGroup |
Spell |
Mail |
WebObj |
LFGObject |
LFGList |
UserRouter |
PVPQueueGroup |
UserClient |
PetBattle |
UniqueUserClient |
BattlePet |
CommerceObj |
ClientSession |

See Also

wManager.Wow.Enums Namespace


InventorySlot Enumeration

InventorySlot http://wowpedia.org/API_TYPE_InventorySlotID

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public enum InventorySlot
Public Enumeration InventorySlot
public enum class InventorySlot

Members

Member name | Description
INVSLOT_AMMO |
INVSLOT_HEAD |
INVSLOT_NECK |
INVSLOT_SHOULDER |
INVSLOT_BODY |
INVSLOT_CHEST |
INVSLOT_WAIST |
INVSLOT_LEGS |
INVSLOT_FEET |
INVSLOT_WRIST |
INVSLOT_HAND |
INVSLOT_FINGER1 |
INVSLOT_FINGER2 |
INVSLOT_TRINKET1 |
INVSLOT_TRINKET2 |
INVSLOT_BACK |
INVSLOT_MAINHAND |
INVSLOT_OFFHAND |
INVSLOT_RANGED |
INVSLOT_TABARD |
CONTAINER_BAG_OFFSET_1 |
CONTAINER_BAG_OFFSET_2 |
CONTAINER_BAG_OFFSET_3 |
CONTAINER_BAG_OFFSET_4 |

See Also

wManager.Wow.Enums Namespace


Keybindings Enumeration

Keybindings

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public enum Keybindings
Public Enumeration Keybindings
public enum class Keybindings

Members

Member name | Description
MOVEANDSTEER |
NONE |
MOVEFORWARD |
MOVEBACKWARD |
TURNLEFT |
TURNRIGHT |
STRAFERIGHT |
STRAFELEFT |
JUMP |
SITORSTAND |
TOGGLEAUTORUN |
PITCHUP |
PITCHDOWN |
TOGGLERUN |
OPENCHAT |
OPENCHATSLASH |
CHATPAGEUP |
CHATPAGEDOWN |
CHATBOTTOM |
COMBATLOGPAGEUP |
COMBATLOGPAGEDOWN |
COMBATLOGBOTTOM |
REPLY |
REPLY2 |
ACTIONBUTTON1 |
ACTIONBUTTON2 |
ACTIONBUTTON3 |
ACTIONBUTTON4 |
ACTIONBUTTON5 |
ACTIONBUTTON6 |
ACTIONBUTTON7 |
ACTIONBUTTON8 |
ACTIONBUTTON9 |
ACTIONBUTTON10 |
ACTIONBUTTON11 |
ACTIONBUTTON12 |
EXTRAACTIONBUTTON1 |
SHAPESHIFTBUTTON1 |
SHAPESHIFTBUTTON2 |
SHAPESHIFTBUTTON3 |
SHAPESHIFTBUTTON4 |
SHAPESHIFTBUTTON5 |
SHAPESHIFTBUTTON6 |
SHAPESHIFTBUTTON7 |
SHAPESHIFTBUTTON8 |
SHAPESHIFTBUTTON9 |
SHAPESHIFTBUTTON10 |
BONUSACTIONBUTTON1 |
BONUSACTIONBUTTON2 |
BONUSACTIONBUTTON3 |
BONUSACTIONBUTTON4 |
BONUSACTIONBUTTON5 |
BONUSACTIONBUTTON6 |
BONUSACTIONBUTTON7 |
BONUSACTIONBUTTON8 |
BONUSACTIONBUTTON9 |
BONUSACTIONBUTTON10 |
ACTIONPAGE1 |
ACTIONPAGE2 |
ACTIONPAGE3 |
ACTIONPAGE4 |
ACTIONPAGE5 |
ACTIONPAGE6 |
PREVIOUSACTIONPAGE |
NEXTACTIONPAGE |
TARGETNEARESTENEMY |
TARGETPREVIOUSENEMY |
TARGETNEARESTFRIEND |
TARGETPREVIOUSFRIEND |
TARGETSELF |
TARGETPET |
TARGETPARTYMEMBER1 |
TARGETPARTYMEMBER2 |
TARGETPARTYMEMBER3 |
TARGETPARTYMEMBER4 |
TARGETPARTYPET1 |
TARGETPARTYPET2 |
TARGETPARTYPET3 |
TARGETPARTYPET4 |
TARGETLASTHOSTILE |
ASSISTTARGET |
NAMEPLATES |
FRIENDNAMEPLATES |
ALLNAMEPLATES |
ATTACKTARGET |
PETATTACK |
TOGGLECHARACTER0 |
OPENALLBAGS |
TOGGLEBACKPACK |
TOGGLEBAG1 |
TOGGLEBAG2 |
TOGGLEBAG3 |
TOGGLEBAG4 |
TOGGLESPELLBOOK |
TOGGLEPETBOOK |
TOGGLECHARACTER3 |
TOGGLEWORLDSTATESCORES |
TOGGLEBATTLEFIELDMINIMAP |
TOGGLECHANNELPULLOUT |
TOGGLECHARACTER4 |
TOGGLETALENTS |
TOGGLECHARACTER2 |
INTERACTTARGET |
TOGGLESOCIAL |
TOGGLEQUESTLOG |
TOGGLELFGPARENT |
TOGGLEACHIEVEMENT |
TOGGLEGUILDTAB |
TOGGLESTATISTICS |
TOGGLECOMBATLOG |
TOGGLEGAMEMENU |
TOGGLEWORLDMAP |
SCREENSHOT |
MINIMAPZOOMIN |
MINIMAPZOOMOUT |
TOGGLEMUSIC |
TOGGLESOUND |
MASTERVOLUMEUP |
MASTERVOLUMEDOWN |
TOGGLEUI |
CAMERAZOOMIN |
CAMERAZOOMOUT |
NEXTVIEW |
PREVVIEW |
TOGGLEFPS |
TOGGLESTATS |
TOGGLETRIS |
TOGGLEPORTALS |
TOGGLECOLLISION |
TOGGLECOLLISIONDISPLAY |
TOGGLEANIMKITDISPLAY |
TOGGLEPLAYERBOUNDS |
TOGGLEPERFORMANCEDISPLAY |
TOGGLEPERFORMANCEPAUSE |
TOGGLEPERFORMANCEVALUES |
TURNORACTION |
CAMERAORSELECTORMOVE |
MOVIE_RECORDING_STARTSTOP |
MOVIE_RECORDING_CANCEL |
MOVIE_RECORDING_COMPRESS |
MOVIE_RECORDING_GUI |
VEHICLEEXIT |
VEHICLEPREVSEAT |
VEHICLENEXTSEAT |
VEHICLEAIMINCREMENT |
VEHICLEAIMDECREMENT |
TOGGLEGEARSETS |

See Also

wManager.Wow.Enums Namespace


Landmarks Enumeration

Landmarks

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public enum Landmarks
Public Enumeration Landmarks
public enum class Landmarks

Members

Member name | Description
Invisible |
Mine |
MineHorde |
MineAlliance |
GraveyardAllianceAssaulted |
Town |
City |
Flags |
Gravestone |
TowerAllianceAssaulted |
TowerHorde |
TowerAlliance |
TowerHordeAssaulted |
GraveyardHorde |
GraveyardHordeAssaulted |
GraveyardAlliance |
GoldMine |
GoldMineAllianceAssaulted |
GoldMineAlliance |
GoldMineHordeAssaulted |
GoldMineHorde |
LumberMill |
LumberMillAllianceAssaulted |
LumberMillAlliance |
LumberMillHordeAssaulted |
LumberMillHorde |
Blacksmith |
BlacksmithAllianceAssaulted |
BlacksmithAlliance |
BlacksmithHordeAssaulted |
BlacksmithHorde |
Farm |
FarmAllianceAssaulted |
FarmAlliance |
FarmHordeAssaulted |
FarmHorde |
Stablesneutral |
StablesAllianceAssaulted |
StablesAlliance |
StablesHordeAssaulted |
StablesHorde |
Skullpurple |
Unknown |
FlagAlliance |
FlagHorde |
Flag |
AllianCecrest |
AllianCecrestuncaptured |
HordeCrest |
HordeCrestuncaptured |
TowerAllianceDamaged |
TowerAllianceDestroyed |
TowerHordeDamaged |
TowerHordeDestroyed |
Towerdamged |
Towerdestroyed |
Bridge |
Bridgedamaged |
Bridgedestroyed |
BridgeHorde |
BridgeHordeDamaged |
BridgeHordeDestroyed |
BridgeAlliance |
BridgeAllianceDamaged |
BridgeAllianceDestroyed |
Workshop |
Workshopdamaged |
Workshopdestroyed |
WorkshopHorde |
WorkshopHordeDamaged |
WorkshopHordeDestroyed |
WorkshopAlliance |
WorkshopAllianceDamaged |
WorkshopAllianceDestroyed |
Gate |
Gatedamaged |
Gatedestroyed |
GateHorde |
GateHordeDamaged |
GateHordeDestroyed |
GateAlliance |
GateAllianceDamaged |
GateAllianceDestroyed |
Wallhorizontal |
WallhorizontalDamaged |
WallhorizontalDestroyed |
WallHordeHorizontal |
WallHordeHorizontalDamaged |
WallHordeHorizontalDestroyed |
WallAllianceHorizontal |
WallAllianceHorizontalDamaged |
WallAllianceHorizontalDestroyed |
Wallvertical |
WallverticalDamaged |
WallverticalDestroyed |
WallHordeVertical |
WallHordeVerticalDamaged |
WallHordeVerticalDestroyed |
WallAllianceVertical |
WallAllianceVerticalDamaged |
WallAllianceVerticalDestroyed |
Combat |
Gateyellow |
GateyellowDamaged |
GateyellowDestroyed |
Gatepurple |
GatepurpleDamaged |
GatepurpleDestroyed |
Gategreen |
GategreenDamaged |
GategreenDestroyed |
White0 |
White1 |
White2 |
White3 |
White4 |
White5 |
White6 |
White7 |
White8 |
White9 |
White |
Horde |
HordeDamaged |
HordeDestroyed |
Alliance |
AllianceDamaged |
AllianceDestroyed |
Towergreen |
TowergreenDamaged |
TowergreenDestroyed |
Toweryellow |
ToweryellowDamaged |
ToweryellowDestroyed |
Skullorange |
SiegeWorkshop |
SiegeWorkshopAlliance |
SiegeWorkshopAllianceAssaulted |
SiegeWorkshopHorde |
SiegeWorkshopHordeAssaulted |
Hangar |
HangarAlliance |
HangarAllianceAssaulted |
HangarHorde |
HangarHordeAssaulted |
Docks |
DocksAlliance |
DocksAllianceAssaulted |
DocksHorde |
DocksHordeAssaulted |
Refinery |
RefineryAlliance |
RefineryAllianceAssaulted |
RefineryHorde |
RefineryHordeAssaulted |

See Also

wManager.Wow.Enums Namespace


LuaEventsId Enumeration

Note: This API is now obsolete.
LuaEventsId

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[ObsoleteAttribute]
public enum LuaEventsId
<ObsoleteAttribute> _
Public Enumeration LuaEventsId
[ObsoleteAttribute]
public enum class LuaEventsId

Members

Member name | Description
UNIT_PET |
UNIT_TARGET |
UNIT_DISPLAYPOWER |
UNIT_HEALTH |
UNIT_MANA |
UNIT_RAGE |
UNIT_FOCUS |
UNIT_ENERGY |
UNIT_HAPPINESS |
UNIT_RUNIC_POWER |
UNIT_MAXHEALTH |
UNIT_MAXMANA |
UNIT_MAXRAGE |
UNIT_MAXFOCUS |
UNIT_MAXENERGY |
UNIT_MAXHAPPINESS |
UNIT_MAXRUNIC_POWER |
UNIT_LEVEL |
UNIT_FACTION |
UNIT_FLAGS |
UNIT_ATTACK_SPEED |
UNIT_RANGEDDAMAGE |
UNIT_DAMAGE |
UNIT_PET_EXPERIENCE |
UNIT_DYNAMIC_FLAGS |
UNIT_STATS |
UNIT_RESISTANCES |
UNIT_ATTACK_POWER |
UNIT_RANGED_ATTACK_POWER |
UNIT_AURA |
UNIT_COMBAT |
UNIT_NAME_UPDATE |
UNIT_PORTRAIT_UPDATE |
UNIT_MODEL_CHANGED |
UNIT_INVENTORY_CHANGED |
UNIT_CLASSIFICATION_CHANGED |
UNIT_COMBO_POINTS |
ITEM_LOCK_CHANGED |
PLAYER_XP_UPDATE |
PLAYER_REGEN_DISABLED |
PLAYER_REGEN_ENABLED |
PLAYER_AURAS_CHANGED |
PLAYER_ENTER_COMBAT |
PLAYER_LEAVE_COMBAT |
PLAYER_TARGET_CHANGED |
PLAYER_FOCUS_CHANGED |
PLAYER_CONTROL_LOST |
PLAYER_CONTROL_GAINED |
PLAYER_FARSIGHT_FOCUS_CHANGED |
PLAYER_LEVEL_UP |
PLAYER_MONEY |
PLAYER_DAMAGE_DONE_MODS |
PLAYER_TOTEM_UPDATE |
ZONE_CHANGED |
ZONE_CHANGED_INDOORS |
ZONE_CHANGED_NEW_AREA |
MINIMAP_UPDATE_ZOOM |
MINIMAP_UPDATE_TRACKING |
SCREENSHOT_SUCCEEDED |
SCREENSHOT_FAILED |
ACTIONBAR_SHOWGRID |
ACTIONBAR_HIDEGRID |
ACTIONBAR_PAGE_CHANGED |
ACTIONBAR_SLOT_CHANGED |
ACTIONBAR_UPDATE_STATE |
ACTIONBAR_UPDATE_USABLE |
ACTIONBAR_UPDATE_COOLDOWN |
UPDATE_BONUS_ACTIONBAR |
PARTY_MEMBERS_CHANGED |
PARTY_LEADER_CHANGED |
PARTY_MEMBER_ENABLE |
PARTY_MEMBER_DISABLE |
PARTY_LOOT_METHOD_CHANGED |
SYSMSG |
UI_ERROR_MESSAGE |
UI_INFO_MESSAGE |
UPDATE_CHAT_COLOR |
CHAT_MSG_ADDON |
CHAT_MSG_SYSTEM |
CHAT_MSG_SAY |
CHAT_MSG_PARTY |
CHAT_MSG_RAID |
CHAT_MSG_GUILD |
CHAT_MSG_OFFICER |
CHAT_MSG_YELL |
CHAT_MSG_WHISPER |
CHAT_MSG_WHISPER_INFORM |
CHAT_MSG_EMOTE |
CHAT_MSG_TEXT_EMOTE |
CHAT_MSG_MONSTER_SAY |
CHAT_MSG_MONSTER_PARTY |
CHAT_MSG_MONSTER_YELL |
CHAT_MSG_MONSTER_WHISPER |
CHAT_MSG_MONSTER_EMOTE |
CHAT_MSG_CHANNEL |
CHAT_MSG_CHANNEL_JOIN |
CHAT_MSG_CHANNEL_LEAVE |
CHAT_MSG_CHANNEL_LIST |
CHAT_MSG_CHANNEL_NOTICE |
CHAT_MSG_CHANNEL_NOTICE_USER |
CHAT_MSG_AFK |
CHAT_MSG_DND |
CHAT_MSG_IGNORED |
CHAT_MSG_SKILL |
CHAT_MSG_LOOT |
CHAT_MSG_MONEY |
CHAT_MSG_OPENING |
CHAT_MSG_TRADESKILLS |
CHAT_MSG_PET_INFO |
CHAT_MSG_COMBAT_MISC_INFO |
CHAT_MSG_COMBAT_XP_GAIN |
CHAT_MSG_COMBAT_HONOR_GAIN |
CHAT_MSG_COMBAT_FACTION_CHANGE |
CHAT_MSG_BG_SYSTEM_NEUTRAL |
CHAT_MSG_BG_SYSTEM_ALLIANCE |
CHAT_MSG_BG_SYSTEM_HORDE |
CHAT_MSG_RAID_LEADER |
CHAT_MSG_RAID_WARNING |
CHAT_MSG_RAID_BOSS_WHISPER |
CHAT_MSG_RAID_BOSS_EMOTE |
CHAT_MSG_FILTERED |
CHAT_MSG_BATTLEGROUND |
CHAT_MSG_BATTLEGROUND_LEADER |
CHAT_MSG_RESTRICTED |
CHAT_MSG_ACHIEVEMENT |
CHAT_MSG_GUILD_ACHIEVEMENT |
LANGUAGE_LIST_CHANGED |
TIME_PLAYED_MSG |
SPELLS_CHANGED |
CURRENT_SPELL_CAST_CHANGED |
SPELL_UPDATE_COOLDOWN |
SPELL_UPDATE_USABLE |
CHARACTER_POINTS_CHANGED |
SKILL_LINES_CHANGED |
ITEM_PUSH |
LOOT_OPENED |
LOOT_SLOT_CLEARED |
LOOT_SLOT_CHANGED |
LOOT_CLOSED |
PLAYER_LOGIN |
PLAYER_LOGOUT |
PLAYER_ENTERING_WORLD |
PLAYER_LEAVING_WORLD |
PLAYER_ALIVE |
PLAYER_DEAD |
PLAYER_CAMPING |
PLAYER_QUITING |
LOGOUT_CANCEL |
RESURRECT_REQUEST |
PARTY_INVITE_REQUEST |
PARTY_INVITE_CANCEL |
GUILD_INVITE_REQUEST |
GUILD_INVITE_CANCEL |
GUILD_MOTD |
TRADE_REQUEST |
TRADE_REQUEST_CANCEL |
LOOT_BIND_CONFIRM |
EQUIP_BIND_CONFIRM |
AUTOEQUIP_BIND_CONFIRM |
USE_BIND_CONFIRM |
DELETE_ITEM_CONFIRM |
CURSOR_UPDATE |
ITEM_TEXT_BEGIN |
ITEM_TEXT_TRANSLATION |
ITEM_TEXT_READY |
ITEM_TEXT_CLOSED |
GOSSIP_SHOW |
GOSSIP_CONFIRM |
GOSSIP_CONFIRM_CANCEL |
GOSSIP_ENTER_CODE |
GOSSIP_CLOSED |
QUEST_GREETING |
QUEST_DETAIL |
QUEST_PROGRESS |
QUEST_COMPLETE |
QUEST_FINISHED |
QUEST_ITEM_UPDATE |
TAXIMAP_OPENED |
TAXIMAP_CLOSED |
QUEST_LOG_UPDATE |
TRAINER_SHOW |
TRAINER_UPDATE |
TRAINER_DESCRIPTION_UPDATE |
TRAINER_CLOSED |
CVAR_UPDATE |
TRADE_SKILL_SHOW |
TRADE_SKILL_UPDATE |
TRADE_SKILL_CLOSE |
MERCHANT_SHOW |
MERCHANT_UPDATE |
MERCHANT_CLOSED |
TRADE_SHOW |
TRADE_CLOSED |
TRADE_UPDATE |
TRADE_ACCEPT_UPDATE |
TRADE_TARGET_ITEM_CHANGED |
TRADE_PLAYER_ITEM_CHANGED |
TRADE_MONEY_CHANGED |
PLAYER_TRADE_MONEY |
BAG_OPEN |
BAG_UPDATE |
BAG_CLOSED |
BAG_UPDATE_COOLDOWN |
LOCALPLAYER_PET_RENAMED |
UNIT_ATTACK |
UNIT_DEFENSE |
PET_ATTACK_START |
PET_ATTACK_STOP |
UPDATE_MOUSEOVER_UNIT |
UNIT_SPELLCAST_SENT |
UNIT_SPELLCAST_START |
UNIT_SPELLCAST_STOP |
UNIT_SPELLCAST_FAILED |
UNIT_SPELLCAST_FAILED_QUIET |
UNIT_SPELLCAST_INTERRUPTED |
UNIT_SPELLCAST_DELAYED |
UNIT_SPELLCAST_SUCCEEDED |
UNIT_SPELLCAST_CHANNEL_START |
UNIT_SPELLCAST_CHANNEL_UPDATE |
UNIT_SPELLCAST_CHANNEL_STOP |
UNIT_SPELLCAST_INTERRUPTIBLE |
UNIT_SPELLCAST_NOT_INTERRUPTIBLE |
PLAYER_GUILD_UPDATE |
QUEST_ACCEPT_CONFIRM |
PLAYERBANKSLOTS_CHANGED |
BANKFRAME_OPENED |
BANKFRAME_CLOSED |
PLAYERBANKBAGSLOTS_CHANGED |
FRIENDLIST_UPDATE |
IGNORELIST_UPDATE |
MUTELIST_UPDATE |
PET_BAR_UPDATE |
PET_BAR_UPDATE_COOLDOWN |
PET_BAR_SHOWGRID |
PET_BAR_HIDEGRID |
PET_BAR_HIDE |
PET_BAR_UPDATE_USABLE |
MINIMAP_PING |
MIRROR_TIMER_START |
MIRROR_TIMER_PAUSE |
MIRROR_TIMER_STOP |
WORLD_MAP_UPDATE |
WORLD_MAP_NAME_UPDATE |
AUTOFOLLOW_BEGIN |
AUTOFOLLOW_END |
CINEMATIC_START |
CINEMATIC_STOP |
UPDATE_FACTION |
CLOSE_WORLD_MAP |
OPEN_TABARD_FRAME |
CLOSE_TABARD_FRAME |
TABARD_CANSAVE_CHANGED |
GUILD_REGISTRAR_SHOW |
GUILD_REGISTRAR_CLOSED |
DUEL_REQUESTED |
DUEL_OUTOFBOUNDS |
DUEL_INBOUNDS |
DUEL_FINISHED |
TUTORIAL_TRIGGER |
PET_DISMISS_START |
UPDATE_BINDINGS |
UPDATE_SHAPESHIFT_FORMS |
UPDATE_SHAPESHIFT_FORM |
UPDATE_SHAPESHIFT_USABLE |
UPDATE_SHAPESHIFT_COOLDOWN |
WHO_LIST_UPDATE |
PETITION_SHOW |
PETITION_CLOSED |
EXECUTE_CHAT_LINE |
UPDATE_MACROS |
UPDATE_TICKET |
UPDATE_CHAT_WINDOWS |
CONFIRM_XP_LOSS |
CORPSE_IN_RANGE |
CORPSE_IN_INSTANCE |
CORPSE_OUT_OF_RANGE |
UPDATE_GM_STATUS |
PLAYER_UNGHOST |
BIND_ENCHANT |
REPLACE_ENCHANT |
TRADE_REPLACE_ENCHANT |
TRADE_POTENTIAL_BIND_ENCHANT |
PLAYER_UPDATE_RESTING |
UPDATE_EXHAUSTION |
PLAYER_FLAGS_CHANGED |
GUILD_ROSTER_UPDATE |
GM_PLAYER_INFO |
MAIL_SHOW |
MAIL_CLOSED |
SEND_MAIL_MONEY_CHANGED |
SEND_MAIL_COD_CHANGED |
MAIL_SEND_INFO_UPDATE |
MAIL_SEND_SUCCESS |
MAIL_INBOX_UPDATE |
MAIL_LOCK_SEND_ITEMS |
MAIL_UNLOCK_SEND_ITEMS |
BATTLEFIELDS_SHOW |
BATTLEFIELDS_CLOSED |
UPDATE_BATTLEFIELD_STATUS |
UPDATE_BATTLEFIELD_SCORE |
AUCTION_HOUSE_SHOW |
AUCTION_HOUSE_CLOSED |
NEW_AUCTION_UPDATE |
AUCTION_ITEM_LIST_UPDATE |
AUCTION_OWNED_LIST_UPDATE |
AUCTION_BIDDER_LIST_UPDATE |
PET_UI_UPDATE |
PET_UI_CLOSE |
ADDON_LOADED |
VARIABLES_LOADED |
MACRO_ACTION_FORBIDDEN |
ADDON_ACTION_FORBIDDEN |
MACRO_ACTION_BLOCKED |
ADDON_ACTION_BLOCKED |
START_AUTOREPEAT_SPELL |
STOP_AUTOREPEAT_SPELL |
PET_STABLE_SHOW |
PET_STABLE_UPDATE |
PET_STABLE_UPDATE_PAPERDOLL |
PET_STABLE_CLOSED |
RAID_ROSTER_UPDATE |
UPDATE_PENDING_MAIL |
UPDATE_INVENTORY_ALERTS |
UPDATE_INVENTORY_DURABILITY |
UPDATE_TRADESKILL_RECAST |
OPEN_MASTER_LOOT_LIST |
UPDATE_MASTER_LOOT_LIST |
START_LOOT_ROLL |
CANCEL_LOOT_ROLL |
CONFIRM_LOOT_ROLL |
CONFIRM_DISENCHANT_ROLL |
INSTANCE_BOOT_START |
INSTANCE_BOOT_STOP |
LEARNED_SPELL_IN_TAB |
DISPLAY_SIZE_CHANGED |
CONFIRM_TALENT_WIPE |
CONFIRM_BINDER |
MAIL_FAILED |
CLOSE_INBOX_ITEM |
CONFIRM_SUMMON |
CANCEL_SUMMON |
BILLING_NAG_DIALOG |
IGR_BILLING_NAG_DIALOG |
PLAYER_SKINNED |
TABARD_SAVE_PENDING |
UNIT_QUEST_LOG_CHANGED |
PLAYER_PVP_KILLS_CHANGED |
PLAYER_PVP_RANK_CHANGED |
INSPECT_HONOR_UPDATE |
UPDATE_WORLD_STATES |
AREA_SPIRIT_HEALER_IN_RANGE |
AREA_SPIRIT_HEALER_OUT_OF_RANGE |
PLAYTIME_CHANGED |
UPDATE_LFG_TYPES |
UPDATE_LFG_LIST |
UPDATE_LFG_LIST_INCREMENTAL |
START_MINIGAME |
MINIGAME_UPDATE |
READY_CHECK |
READY_CHECK_CONFIRM |
READY_CHECK_FINISHED |
RAID_TARGET_UPDATE |
GMSURVEY_DISPLAY |
UPDATE_INSTANCE_INFO |
SOCKET_INFO_UPDATE |
SOCKET_INFO_CLOSE |
PETITION_VENDOR_SHOW |
PETITION_VENDOR_CLOSED |
PETITION_VENDOR_UPDATE |
COMBAT_TEXT_UPDATE |
QUEST_WATCH_UPDATE |
KNOWLEDGE_BASE_SETUP_LOAD_SUCCESS |
KNOWLEDGE_BASE_SETUP_LOAD_FAILURE |
KNOWLEDGE_BASE_QUERY_LOAD_SUCCESS |
KNOWLEDGE_BASE_QUERY_LOAD_FAILURE |
KNOWLEDGE_BASE_ARTICLE_LOAD_SUCCESS |
KNOWLEDGE_BASE_ARTICLE_LOAD_FAILURE |
KNOWLEDGE_BASE_SYSTEM_MOTD_UPDATED |
KNOWLEDGE_BASE_SERVER_MESSAGE |
ARENA_TEAM_UPDATE |
ARENA_TEAM_ROSTER_UPDATE |
ARENA_TEAM_INVITE_REQUEST |
HONOR_CURRENCY_UPDATE |
KNOWN_TITLES_UPDATE |
NEW_TITLE_EARNED |
OLD_TITLE_LOST |
LFG_UPDATE |
LFG_PROPOSAL_UPDATE |
LFG_PROPOSAL_SHOW |
LFG_PROPOSAL_FAILED |
LFG_PROPOSAL_SUCCEEDED |
LFG_ROLE_UPDATE |
LFG_ROLE_CHECK_UPDATE |
LFG_ROLE_CHECK_SHOW |
LFG_ROLE_CHECK_HIDE |
LFG_ROLE_CHECK_ROLE_CHOSEN |
LFG_QUEUE_STATUS_UPDATE |
LFG_BOOT_PROPOSAL_UPDATE |
LFG_LOCK_INFO_RECEIVED |
LFG_UPDATE_RANDOM_INFO |
LFG_OFFER_CONTINUE |
LFG_OPEN_FROM_GOSSIP |
LFG_COMPLETION_REWARD |
PARTY_LFG_RESTRICTED |
PLAYER_ROLES_ASSIGNED |
COMBAT_RATING_UPDATE |
MODIFIER_STATE_CHANGED |
UPDATE_STEALTH |
ENABLE_TAXI_BENCHMARK |
DISABLE_TAXI_BENCHMARK |
VOICE_START |
VOICE_STOP |
VOICE_STATUS_UPDATE |
VOICE_CHANNEL_STATUS_UPDATE |
UPDATE_FLOATING_CHAT_WINDOWS |
RAID_INSTANCE_WELCOME |
MOVIE_RECORDING_PROGRESS |
MOVIE_COMPRESSING_PROGRESS |
MOVIE_UNCOMPRESSED_MOVIE |
VOICE_PUSH_TO_TALK_START |
VOICE_PUSH_TO_TALK_STOP |
GUILDBANKFRAME_OPENED |
GUILDBANKFRAME_CLOSED |
GUILDBANKBAGSLOTS_CHANGED |
GUILDBANK_ITEM_LOCK_CHANGED |
GUILDBANK_UPDATE_TABS |
GUILDBANK_UPDATE_MONEY |
GUILDBANKLOG_UPDATE |
GUILDBANK_UPDATE_WITHDRAWMONEY |
GUILDBANK_UPDATE_TEXT |
GUILDBANK_TEXT_CHANGED |
CHANNEL_UI_UPDATE |
CHANNEL_COUNT_UPDATE |
CHANNEL_ROSTER_UPDATE |
CHANNEL_VOICE_UPDATE |
CHANNEL_INVITE_REQUEST |
CHANNEL_PASSWORD_REQUEST |
CHANNEL_FLAGS_UPDATED |
VOICE_SESSIONS_UPDATE |
VOICE_CHAT_ENABLED_UPDATE |
VOICE_LEFT_SESSION |
INSPECT_TALENT_READY |
VOICE_SELF_MUTE |
VOICE_PLATE_START |
VOICE_PLATE_STOP |
ARENA_SEASON_WORLD_STATE |
GUILD_EVENT_LOG_UPDATE |
GUILDTABARD_UPDATE |
SOUND_DEVICE_UPDATE |
COMMENTATOR_MAP_UPDATE |
COMMENTATOR_ENTER_WORLD |
COMBAT_LOG_EVENT |
COMBAT_LOG_EVENT_UNFILTERED |
COMMENTATOR_PLAYER_UPDATE |
PLAYER_ENTERING_BATTLEGROUND |
BARBER_SHOP_OPEN |
BARBER_SHOP_CLOSE |
BARBER_SHOP_SUCCESS |
BARBER_SHOP_APPEARANCE_APPLIED |
CALENDAR_UPDATE_INVITE_LIST |
CALENDAR_UPDATE_EVENT_LIST |
CALENDAR_NEW_EVENT |
CALENDAR_OPEN_EVENT |
CALENDAR_CLOSE_EVENT |
CALENDAR_UPDATE_EVENT |
CALENDAR_UPDATE_PENDING_INVITES |
CALENDAR_EVENT_ALARM |
CALENDAR_UPDATE_ERROR |
CALENDAR_ACTION_PENDING |
VEHICLE_ANGLE_SHOW |
VEHICLE_ANGLE_UPDATE |
VEHICLE_POWER_SHOW |
UNIT_ENTERING_VEHICLE |
UNIT_ENTERED_VEHICLE |
UNIT_EXITING_VEHICLE |
UNIT_EXITED_VEHICLE |
VEHICLE_PASSENGERS_CHANGED |
PLAYER_GAINS_VEHICLE_DATA |
PLAYER_LOSES_VEHICLE_DATA |
PET_FORCE_NAME_DECLENSION |
LEVEL_GRANT_PROPOSED |
SYNCHRONIZE_SETTINGS |
PLAY_MOVIE |
RUNE_POWER_UPDATE |
RUNE_TYPE_UPDATE |
ACHIEVEMENT_EARNED |
CRITERIA_UPDATE |
RECEIVED_ACHIEVEMENT_LIST |
PET_RENAMEABLE |
KNOWN_CURRENCY_TYPES_UPDATE |
CURRENCY_DISPLAY_UPDATE |
COMPANION_LEARNED |
COMPANION_UNLEARNED |
COMPANION_UPDATE |
UNIT_THREAT_LIST_UPDATE |
UNIT_THREAT_SITUATION_UPDATE |
GLYPH_ADDED |
GLYPH_REMOVED |
GLYPH_UPDATED |
GLYPH_ENABLED |
GLYPH_DISABLED |
USE_GLYPH |
TRACKED_ACHIEVEMENT_UPDATE |
ARENA_OPPONENT_UPDATE |
INSPECT_ACHIEVEMENT_READY |
RAISED_AS_GHOUL |
PARTY_CONVERTED_TO_RAID |
PVPQUEUE_ANYWHERE_SHOW |
PVPQUEUE_ANYWHERE_UPDATE_AVAILABLE |
QUEST_ACCEPTED |
PLAYER_TALENT_UPDATE |
ACTIVE_TALENT_GROUP_CHANGED |
PET_TALENT_UPDATE |
PREVIEW_TALENT_POINTS_CHANGED |
PREVIEW_PET_TALENT_POINTS_CHANGED |
WEAR_EQUIPMENT_SET |
EQUIPMENT_SETS_CHANGED |
INSTANCE_LOCK_START |
INSTANCE_LOCK_STOP |
PLAYER_EQUIPMENT_CHANGED |
ITEM_LOCKED |
ITEM_UNLOCKED |
TRADE_SKILL_FILTER_UPDATE |
EQUIPMENT_SWAP_PENDING |
EQUIPMENT_SWAP_FINISHED |
NPC_PVPQUEUE_ANYWHERE |
UPDATE_MULTI_CAST_ACTIONBAR |
ENABLE_XP_GAIN |
DISABLE_XP_GAIN |
BATTLEFIELD_MGR_ENTRY_INVITE |
BATTLEFIELD_MGR_ENTERED |
BATTLEFIELD_MGR_QUEUE_REQUEST_RESPONSE |
BATTLEFIELD_MGR_EJECT_PENDING |
BATTLEFIELD_MGR_EJECTED |
BATTLEFIELD_MGR_QUEUE_INVITE |
BATTLEFIELD_MGR_STATE_CHANGE |
WORLD_STATE_UI_TIMER_UPDATE |
END_REFUND |
END_BOUND_TRADEABLE |
UPDATE_CHAT_COLOR_NAME_BY_CLASS |
GMRESPONSE_RECEIVED |
VEHICLE_UPDATE |
WOW_MOUSE_NOT_FOUND |
MAIL_SUCCESS |
TALENTS_INVOLUNTARILY_RESET |
INSTANCE_ENCOUNTER_ENGAGE_UNIT |
QUEST_QUERY_COMPLETE |
QUEST_POI_UPDATE |
PLAYER_DIFFICULTY_CHANGED |
CHAT_MSG_PARTY_LEADER |
VOTE_KICK_REASON_NEEDED |
ENABLE_LOW_LEVEL_RAID |
DISABLE_LOW_LEVEL_RAID |
CHAT_MSG_TARGETICONS |
AUCTION_HOUSE_DISABLED |
AUCTION_MULTISELL_START |
AUCTION_MULTISELL_UPDATE |
AUCTION_MULTISELL_FAILURE |
PET_SPELL_POWER_UPDATE |
BN_CONNECTED |
BN_DISCONNECTED |
BN_SELF_ONLINE |
BN_SELF_OFFLINE |
BN_FRIEND_LIST_SIZE_CHANGED |
BN_FRIEND_INVITE_LIST_INITIALIZED |
BN_FRIEND_INVITE_SEND_RESULT |
BN_FRIEND_INVITE_ADDED |
BN_FRIEND_INVITE_REMOVED |
BN_FRIEND_INFO_CHANGED |
BN_CUSTOM_MESSAGE_CHANGED |
BN_CUSTOM_MESSAGE_LOADED |
CHAT_MSG_BN_WHISPER |
CHAT_MSG_BN_WHISPER_INFORM |
BN_CHAT_WHISPER_UNDELIVERABLE |
BN_CHAT_CHANNEL_JOINED |
BN_CHAT_CHANNEL_LEFT |
BN_CHAT_CHANNEL_CLOSED |
CHAT_MSG_BN_CONVERSATION |
CHAT_MSG_BN_CONVERSATION_NOTICE |
CHAT_MSG_BN_CONVERSATION_LIST |
BN_CHAT_CHANNEL_MESSAGE_UNDELIVERABLE |
BN_CHAT_CHANNEL_MESSAGE_BLOCKED |
BN_CHAT_CHANNEL_MEMBER_JOINED |
BN_CHAT_CHANNEL_MEMBER_LEFT |
BN_CHAT_CHANNEL_MEMBER_UPDATED |
BN_CHAT_CHANNEL_CREATE_SUCCEEDED |
BN_CHAT_CHANNEL_CREATE_FAILED |
BN_CHAT_CHANNEL_INVITE_SUCCEEDED |
BN_CHAT_CHANNEL_INVITE_FAILED |
BN_BLOCK_LIST_UPDATED |
BN_SYSTEM_MESSAGE |
BN_REQUEST_FOF_SUCCEEDED |
BN_REQUEST_FOF_FAILED |
BN_NEW_PRESENCE |
BN_TOON_NAME_UPDATED |
BN_FRIEND_ACCOUNT_ONLINE |
BN_FRIEND_ACCOUNT_OFFLINE |
BN_FRIEND_TOON_ONLINE |
BN_FRIEND_TOON_OFFLINE |
BN_MATURE_LANGUAGE_FILTER |
COMMENTATOR_SKIRMISH_QUEUE_REQUEST |
COMMENTATOR_SKIRMISH_MODE_REQUEST |
CHAT_MSG_BN_INLINE_TOAST_ALERT |
CHAT_MSG_BN_INLINE_TOAST_BROADCAST |
CHAT_MSG_BN_INLINE_TOAST_BROADCAST_INFORM |
CHAT_MSG_BN_INLINE_TOAST_CONVERSATION |

See Also

wManager.Wow.Enums Namespace


MountFlags Enumeration

MountFlags

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[FlagsAttribute]
public enum MountFlags
<FlagsAttribute> _
Public Enumeration MountFlags
[FlagsAttribute]
public enum class MountFlags

Members

Member name | Description
None |
Ground |
GroundWalkWater |
TempleOfAhnQirajMount |
DeadMount |
Flying |
Flying2 |
Aquatic |
Aquatic2 |
Aquatic3 |
GroundForLevel1 |

See Also

wManager.Wow.Enums Namespace


NpcMarker Enumeration

NpcMarker

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public enum NpcMarker
Public Enumeration NpcMarker
public enum class NpcMarker

Members

Member name | Description
None |
SilverExclamation |
SilverQuestion |
BlueQuestion |
BlueExclamation |
YellowExclamation |
YellowQuestion |
GreenExclamation |

See Also

wManager.Wow.Enums Namespace


PlayerFactions Enumeration

PlayerFactions

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public enum PlayerFactions
Public Enumeration PlayerFactions
public enum class PlayerFactions

Members

Member name | Description
BloodElf |
Draenei |
Dwarf |
Gnome |
Human |
NightElf |
Orc |
Tauren |
Troll |
Undead |
Worgen |
Goblin |
Pandaren |
PandarenHorde |
PandarenAlliance |
None |

See Also

wManager.Wow.Enums Namespace


PowerType Enumeration

PowerType

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public enum PowerType
Public Enumeration PowerType
public enum class PowerType

Members

Member name | Description
Mana |
Rage |
Focus |
Energy |
Happiness |
Runes |
RunicPower |
SoulShards |
Eclipse |
HolyPower |
Alternate |
DarkForce |
LightForce |
ShadowOrbs |
BurningEmbers |
DemonicFury |
ArcaneCharges |

See Also

wManager.Wow.Enums Namespace


Reaction Enumeration

Reaction

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public enum Reaction
Public Enumeration Reaction
public enum class Reaction

Members

Member name | Description
Hated |
Hostile |
Unfriendly |
Neutral |
Friendly |
Honored |
Revered |
Exalted |
Unknown |

See Also

wManager.Wow.Enums Namespace


RuneTypes Enumeration

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public enum RuneTypes
Public Enumeration RuneTypes
public enum class RuneTypes

Members

Member name | Description
None |
Blood |
Unholy |
Frost |
Death |

See Also

wManager.Wow.Enums Namespace


SkillLine Enumeration

SkillLine

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public enum SkillLine
Public Enumeration SkillLine
public enum class SkillLine

Members

Member name | Description
None |
Frost |
Fire |
Arms |
Combat |
Subtlety |
Swords |
Axes |
Bows |
Guns |
BeastMastery |
HunterSurvival |
Maces |
TwoHandedSwords |
Holy |
ShadowMagic |
Defense |
LanguageCommon |
DwarvenRacial |
LanguageOrcish |
LanguageDwarven |
LanguageDarnassian |
LanguageTaurahe |
DualWield |
TaurenRacial |
OrcRacial |
NightElfRacial |
FirstAid |
FeralCombat |
Staves |
LanguageThalassian |
LanguageDraconic |
LanguageDemonTongue |
LanguageTitan |
LanguageOldTongue |
Survival |
HorseRiding |
WolfRiding |
TigerRiding |
RamRiding |
Swimming |
TwoHandedMaces |
Unarmed |
Marksmanship |
Blacksmithing |
Leatherworking |
Alchemy |
TwoHandedAxes |
Daggers |
Thrown |
Herbalism |
Retribution |
Cooking |
Mining |
PetImp |
PetFelhunter |
Tailoring |
Engineering |
PetSpider |
PetVoidwalker |
PetSuccubus |
PetInfernal |
PetDoomguard |
PetWolf |
PetCat |
PetBear |
PetBoar |
PetCrocolisk |
PetCarrionBird |
PetCrab |
PetGorilla |
PetRaptor |
PetTallstrider |
RacialUndead |
Crossbows |
Wands |
Polearms |
PetScorpid |
Arcane |
PetTurtle |
Assassination |
Fury |
Protection |
Protection2 |
PetGenericHunter |
PlateMail |
LanguageGnomish |
LanguageTroll |
Enchanting |
Demonology |
Affliction |
Fishing |
Enhancement |
ShamanRestoration |
ElementalCombat |
Skinning |
Mail |
Leather |
Cloth |
Shield |
FistWeapons |
RaptorRiding |
MechanostriderPiloting |
UndeadHorsemanship |
Restoration |
Balance |
Destruction |
DruidHoly |
Discipline |
Lockpicking |
PetBat |
PetHyena |
PetBirdofPrey |
PetWindSerpent |
LanguageGutterspeak |
KodoRiding |
RacialTroll |
RacialGnome |
RacialHuman |
Jewelcrafting |
BloodElfRacial |
PetEventRemoteControl |
LanguageDraenei |
DraeneiRacial |
PetFelguard |
Riding |
PetDragonhawk |
PetNetherRay |
PetSporebat |
PetWarpStalker |
PetRavager |
PetSerpent |
Internal |
DkBlood |
DkFrost |
DkUnholy |
Inscription |
PetMoth |
Runeforging |
Mounts |
Companions |
PetExoticChimaera |
PetExoticDevlisaur |
PetGhoul |
PetExoticSilithid |
PetExoticWorm |
PetWasp |
PetExoticRhino |
PetExoticCoreHound |
Archaeology |
Logging |
Free |

See Also

wManager.Wow.Enums Namespace


SurveyTool Enumeration

SurveyTool

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public enum SurveyTool
Public Enumeration SurveyTool
public enum class SurveyTool

Members

Member name | Description
SurveyToolRed |
SurveyToolYellow |
SurverToolGreen |

See Also

wManager.Wow.Enums Namespace


TotemType Enumeration

TotemType

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public enum TotemType
Public Enumeration TotemType
public enum class TotemType

Members

Member name | Description
Fire |
Earth |
Water |
Air |

See Also

wManager.Wow.Enums Namespace


TrackCreatureFlags Enumeration

TrackCreatureFlags

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[FlagsAttribute]
public enum TrackCreatureFlags
<FlagsAttribute> _
Public Enumeration TrackCreatureFlags
[FlagsAttribute]
public enum class TrackCreatureFlags

Members

Member name | Description
None |
Beasts |
Dragons |
Demons |
Elementals |
Giants |
Undead |
Humanoids |
Critters |
Machines |
Slimes |
Totem |
NonCombatPet |
GasCloud |
BattlePets |
All |

See Also

wManager.Wow.Enums Namespace


TrackObjectFlags Enumeration

TrackObjectFlags

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[FlagsAttribute]
public enum TrackObjectFlags
<FlagsAttribute> _
Public Enumeration TrackObjectFlags
[FlagsAttribute]
public enum class TrackObjectFlags

Members

Member name | Description
None |
Lockpicking |
Herbs |
Minerals |
DisarmTrap |
Open |
Treasure |
CalcifiedElvenGems |
Close |
ArmTrap |
QuickOpen |
QuickClose |
OpenTinkering |
OpenKneeling |
OpenAttacking |
Gahzridian |
Blasting |
PvPOpen |
PvPClose |
Fishing |
Inscription |
OpenFromVehicle |
notsure |
All |

See Also

wManager.Wow.Enums Namespace


UnitClassification Enumeration

UnitClassification

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public enum UnitClassification
Public Enumeration UnitClassification
public enum class UnitClassification

Members

Member name | Description
normal |
elite |
rareelite |
worldboss |
rare |
trivial |
minus |

See Also

wManager.Wow.Enums Namespace


UnitDynamicFlags Enumeration

UnitDynamicFlags

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public enum UnitDynamicFlags
Public Enumeration UnitDynamicFlags
public enum class UnitDynamicFlags

Members

Member name | Description
None |
Lootable |
TrackUnit |
TaggedByOther |
TaggedByMe |
SpecialInfo |
Dead |
ReferAFriendLinked |
IsTappedByAllThreatList |

See Also

wManager.Wow.Enums Namespace


UnitFlags Enumeration

UnitFlags

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[FlagsAttribute]
public enum UnitFlags
<FlagsAttribute> _
Public Enumeration UnitFlags
[FlagsAttribute]
public enum class UnitFlags

Members

Member name | Description
None |
NotSitting |
_SelectableNotAttackable_1 |
Influenced |
PlayerControlled |
Totem |
Preparation |
PlusMob |
_SelectableNotAttackable_2 |
NotAttackable |
_Flag_0x200 |
Looting |
PetInCombat |
PvPFlagged |
Silenced |
_Flag_14_0x4000 |
_Flag_15_0x8000 |
_SelectableNotAttackable_3 |
Pacified |
Stunned |
Combat |
CanPerformAction_Mask1 |
TaxiFlight |
Disarmed |
Confused |
Fleeing |
Possessed |
NotSelectable |
Skinnable |
Mounted |
_Flag_28_0x10000000 |
Dazed |
Sheathe |
_Flag_31_0x80000000 |

See Also

wManager.Wow.Enums Namespace


UnitNPCFlags Enumeration

UnitNPCFlags

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[FlagsAttribute]
public enum UnitNPCFlags
<FlagsAttribute> _
Public Enumeration UnitNPCFlags
[FlagsAttribute]
public enum class UnitNPCFlags

Members

Member name | Description
Auctioneer |
Banker |
Battlemaster |
BattlePetTrainer |
CanRepair |
CanSell |
CanTrain |
DailyQuests |
Flightmaster |
ForgeMaster |
Gossip |
GuildBanker |
Innkeeper |
MailInfo |
None |
Petitioner |
Questgiver |
SellsAmmo |
SellsFood |
SellsReagents |
SPELLCLICK |
Spiritguide |
Spirithealer |
Stablemaster |
Tabarddesigner |
Transmogrifier |
BattlePet |
UNK1 |
UNK2 |
VENDOR_POISON |
VoidStorageBanker |

See Also

wManager.Wow.Enums Namespace


WoWClass Enumeration

WoWClass

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public enum WoWClass
Public Enumeration WoWClass
public enum class WoWClass

Members

Member name | Description
None |
Warrior |
Paladin |
Hunter |
Rogue |
Priest |
DeathKnight |
Shaman |
Mage |
Warlock |
Monk |
Druid |
DemonHunter |

See Also

wManager.Wow.Enums Namespace


WoWGameObjectLockKeyType Enumeration

WoWGameObjectLockKeyType

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public enum WoWGameObjectLockKeyType
Public Enumeration WoWGameObjectLockKeyType
public enum class WoWGameObjectLockKeyType

Members

Member name | Description
LOCK_KEY_NONE |
LOCK_KEY_ITEM |
LOCK_KEY_SKILL |
LOCK_KEY_UNKNOWN |

See Also

wManager.Wow.Enums Namespace


WoWGameObjectLockType Enumeration

WoWGameObjectLockType

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public enum WoWGameObjectLockType
Public Enumeration WoWGameObjectLockType
public enum class WoWGameObjectLockType

Members

Member name | Description
LOCKTYPE_PICKLOCK |
LOCKTYPE_HERBALISM |
LOCKTYPE_MINING |
LOCKTYPE_DISARM_TRAP |
LOCKTYPE_OPEN |
LOCKTYPE_TREASURE |
LOCKTYPE_CALCIFIED_ELVEN_GEMS |
LOCKTYPE_CLOSE |
LOCKTYPE_ARM_TRAP |
LOCKTYPE_QUICK_OPEN |
LOCKTYPE_QUICK_CLOSE |
LOCKTYPE_OPEN_TINKERING |
LOCKTYPE_OPEN_KNEELING |
LOCKTYPE_OPEN_ATTACKING |
LOCKTYPE_GAHZRIDIAN |
LOCKTYPE_BLASTING |
LOCKTYPE_SLOW_OPEN |
LOCKTYPE_SLOW_CLOSE |
LOCKTYPE_FISHING |
LOCKTYPE_INSCRIPTION |
LOCKTYPE_OPEN_FROM_VEHICLE |
LOCKTYPE_ARCHAEOLOGY |
LOCKTYPE_PVP |
LOCKTYPE_TIMBER |
LOCKTYPE_SKIN |
LOCKTYPE_EXTRACT |

See Also

wManager.Wow.Enums Namespace


WoWGameObjectType Enumeration

WoWGameObjectType

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public enum WoWGameObjectType
Public Enumeration WoWGameObjectType
public enum class WoWGameObjectType

Members

Member name | Description
Door |
Button |
Questgiver |
Chest |
Binder |
Generic |
Trap |
SpellFocus |
Chair |
Text |
Goober |
Transport |
AreaDamage |
Camera |
MapObject |
MoTransport |
DuelArbiter |
FishingNode |
Ritual |
Mailbox |
AuctionHouse |
GuardPost |
SpellCaster |
MeetingStone |
FlagStand |
FishingHole |
FlagDrop |
MiniGame |
LotteryKiosk |
CapturePoint |
AuraGenerator |
DungeonDifficulty |
DestructiveBuilding |
GuildBank |
TrapDoor |
FlagHorde |
FlagAlliance |

See Also

wManager.Wow.Enums Namespace


WoWGender Enumeration

WoWGender

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public enum WoWGender
Public Enumeration WoWGender
public enum class WoWGender

Members

Member name | Description
None |
Male |
Female |

See Also

wManager.Wow.Enums Namespace


WoWInventorySlot Enumeration

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public enum WoWInventorySlot
Public Enumeration WoWInventorySlot
public enum class WoWInventorySlot

Members

Member name | Description
Ammo |
Head |
Neck |
Shoulder |
Shirt |
Chest |
Waist |
Legs |
Feet |
Wrist |
Hands |
Finger1 |
Finger2 |
Trinket1 |
Trinket2 |
Back |
MainHand |
OffHand |
Ranged |
Tabard |
Bag1 |
Bag2 |
Bag3 |
Bag4 |

See Also

wManager.Wow.Enums Namespace


WoWItemQuality Enumeration

WoWItemQuality

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public enum WoWItemQuality
Public Enumeration WoWItemQuality
public enum class WoWItemQuality

Members

Member name | Description
Artifact |
Common |
Epic |
Heirloom |
Legendary |
Poor |
Rare |
Uncommon |

See Also

wManager.Wow.Enums Namespace


WoWObjectType Enumeration

WoWObjectType

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public enum WoWObjectType
Public Enumeration WoWObjectType
public enum class WoWObjectType

Members

Member name | Description
Object |
Item |
Container |
Unit |
Player |
GameObject |
DynamicObject |
Corpse |
AiGroup |
AreaTrigger |
None |

See Also

wManager.Wow.Enums Namespace


WoWRace Enumeration

WoWRace (ChrRaces.db2)

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public enum WoWRace
<SerializableAttribute> _
Public Enumeration WoWRace
[SerializableAttribute]
public enum class WoWRace

Members

Member name | Description
None |
Human |
Orc |
Dwarf |
NightElf |
Undead |
Tauren |
Gnome |
Troll |
Goblin |
BloodElf |
Draenei |
FelOrc |
Naga |
Broken |
Skeleton |
Vrykul |
Tuskarr |
ForestTroll |
Taunka |
NorthrendSkeleton |
IceTroll |
Worgen |
Pandaren |
PandarenHorde |
PandarenAlliance |

See Also

wManager.Wow.Enums Namespace


WowSpecializations Enumeration

WowSpecializations

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public enum WowSpecializations
Public Enumeration WowSpecializations
public enum class WowSpecializations

Members

Member name | Description
None |
Warrior_Arms |
Warrior_Fury |
Warrior_Protection |
Warrior_Default |
Paladin_Holy |
Paladin_Protection |
Paladin_Restribution |
Paladin_Default |
Hunter_Beast_Mastery |
Hunter_Marksmanship |
Hunter_Survival |
Hunter_Default |
Rogue_Assassination |
Rogue_Combat |
Rogue_Subtlety |
Rogue_Default |
Priest_Discipline |
Priest_Holy |
Priest_Shadow |
Priest_Default |
DeathKnight_Blood |
DeathKnight_Frost |
DeathKnight_Unholy |
DeathKnight_Default |
Shaman_Elemental |
Shaman_Enhancement |
Shaman_Restoration |
Shaman_Default |
Mage_Arcane |
Mage_Fire |
Mage_Frost |
Mage_Default |
Warlock_Affliction |
Warlock_Demonology |
Warlock_Destruction |
Warlock_Default |
Druid_Balance |
Druid_Feral |
Druid_Guardian |
Druid_Restoration |
Druid_Default |
Monk_Brewmaster |
Monk_Mistweaver |
Monk_Windwalker |
Monk_Default |

See Also

wManager.Wow.Enums Namespace


wManager.Wow.Forms Namespace

Classes

 | Class | Description
Public class | BlacklistWindow | Logique d'interaction pour BlacklistWindow.xaml
Public class | BuyWindow | Class BuyWindow. Window for the settings BuyList Implements the Window Implements the IComponentConnector
Public class | ChatUserControler | Class ChatUserControler. Game chat usercontrol (used in tab "Chat"). Implements the UserControl Implements the IComponentConnector
Public class | NpcDbWindow | Window to edit ListNpc
Public class | OffMeshConnectionWindow | Window to add or edit offmeshconnections
Public class | PluginsUserControl | Plugins UserControl (used tab "Plugins")
Public class | TaxiDbWindow | Window to manage Nodes
Public class | ToolboxWindow | Window Toolbox (also named development tools)
Public class | UserControlMiniMap | MiniMap UserControl (game map, used tab "Map"). Too add landmarks look LandmarksMiniMap
Public class | UserControlTabGeneralSettings | UserControl GeneralSettings (used tab "General settings", main configurations, for access to the full list of options use window GeneralSettings)
Public class | UserControlTabInGame | UserControl that show in game infos (like player name, level, target, ...) (used tab "Info")
Public class | UserControlTabMain | Main UserControl of the bot (to select product, start/stop, ..., used tab "Main")
Public class | UserControlTabTools | Class UserControlTabTools. Implements the UserControl Implements the IComponentConnector

Delegates

 | Delegate | Description
Public delegate | UserControlMiniMap..::..OnMouseClickHandler | Delegate OnMouseClickHandler


BlacklistWindow Class

Logique d'interaction pour BlacklistWindow.xaml

Namespace: wManager.Wow.Forms
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class BlacklistWindow
Public Class BlacklistWindow
public ref class BlacklistWindow

Inheritance Hierarchy

Object
wManager.Wow.Forms..::..BlacklistWindow

See Also

BlacklistWindow Members
wManager.Wow.Forms Namespace


BlacklistWindow Members

The BlacklistWindow type exposes the following members.

Constructors

 | Name | Description
Public method | BlacklistWindow()()()() |
Public method | BlacklistWindow(List<(Of <<'(BlackListSerializable..::..Blackspot>)>>), List<(Of <<'(BlackListSerializable..::..BlackNpc>)>>), List<(Of <<'(BlackListSerializable..::..BlackNpcType>)>>)) |

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

BlacklistWindow Class
wManager.Wow.Forms Namespace


BlacklistWindow Constructor

Overload List

 | Name | Description
Public method | BlacklistWindow()()()() |
Public method | BlacklistWindow(List<(Of <<'(BlackListSerializable..::..Blackspot>)>>), List<(Of <<'(BlackListSerializable..::..BlackNpc>)>>), List<(Of <<'(BlackListSerializable..::..BlackNpcType>)>>)) |

See Also

BlacklistWindow Class
BlacklistWindow Members
wManager.Wow.Forms Namespace


BlacklistWindow Constructor

Namespace: wManager.Wow.Forms
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public BlacklistWindow()
Public Sub New
public:
BlacklistWindow()

See Also

BlacklistWindow Class
BlacklistWindow Overload
wManager.Wow.Forms Namespace


BlacklistWindow Constructor (List(Blackspot), List(BlackNpc), List(BlackNpcType))

BlacklistWindow Constructor (List<(Of <(<'Blackspot>)>)>, List<(Of <(<'BlackNpc>)>)>, List<(Of <(<'BlackNpcType>)>)>)

Namespace: wManager.Wow.Forms
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public BlacklistWindow(
    List<BlackListSerializable..::..Blackspot> spots,
    List<BlackListSerializable..::..BlackNpc> npcs,
    List<BlackListSerializable..::..BlackNpcType> types
)
Public Sub New ( _
    spots As List(Of BlackListSerializable..::..Blackspot), _
    npcs As List(Of BlackListSerializable..::..BlackNpc), _
    types As List(Of BlackListSerializable..::..BlackNpcType) _
)
public:
BlacklistWindow(
    List<BlackListSerializable..::..Blackspot^>^ spots,
    List<BlackListSerializable..::..BlackNpc^>^ npcs,
    List<BlackListSerializable..::..BlackNpcType^>^ types
)

Parameters

spots
Type: List <(Of <(<' BlackListSerializable..::..Blackspot >)>)>
npcs
Type: List <(Of <(<' BlackListSerializable..::..BlackNpc >)>)>
types
Type: List <(Of <(<' BlackListSerializable..::..BlackNpcType >)>)>

See Also

BlacklistWindow Class
BlacklistWindow Overload
wManager.Wow.Forms Namespace


BlacklistWindow Methods

The BlacklistWindow type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

BlacklistWindow Class
wManager.Wow.Forms Namespace


BuyWindow Class

Class BuyWindow. Window for the settings BuyList Implements the Window Implements the IComponentConnector

Namespace: wManager.Wow.Forms
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class BuyWindow
Public Class BuyWindow
public ref class BuyWindow

Inheritance Hierarchy

Object
wManager.Wow.Forms..::..BuyWindow

See Also

BuyWindow Members
wManager.Wow.Forms Namespace
Window
IComponentConnector


BuyWindow Members

The BuyWindow type exposes the following members.

Constructors

 | Name | Description
Public method | BuyWindow | Initializes a new instance of the BuyWindow class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

BuyWindow Class
wManager.Wow.Forms Namespace


BuyWindow Constructor

Initializes a new instance of the BuyWindow class.

Namespace: wManager.Wow.Forms
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public BuyWindow()
Public Sub New
public:
BuyWindow()

See Also

BuyWindow Class
wManager.Wow.Forms Namespace


BuyWindow Methods

The BuyWindow type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

BuyWindow Class
wManager.Wow.Forms Namespace


ChatUserControler Class

Class ChatUserControler. Game chat usercontrol (used in tab "Chat"). Implements the UserControl Implements the IComponentConnector

Namespace: wManager.Wow.Forms
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class ChatUserControler : UserControl
Public Class ChatUserControler _
    Inherits UserControl
public ref class ChatUserControler : public UserControl

Inheritance Hierarchy

Object
DispatcherObject
DependencyObject
Visual
UIElement
FrameworkElement
Control
ContentControl
UserControl
wManager.Wow.Forms..::..ChatUserControler

See Also

ChatUserControler Members
wManager.Wow.Forms Namespace
UserControl
IComponentConnector


ChatUserControler Members

The ChatUserControler type exposes the following members.

Constructors

 | Name | Description
Public method | ChatUserControler | Initializes a new instance of the ChatUserControler class.

Methods

 | Name | Description
Protected method | AddChild(System.Object) | (Inherited from ContentControl.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate,System.Boolean) | (Inherited from UIElement.)
Protected method | AddText(System.String) | (Inherited from ContentControl.)
Public method | AddToEventRoute(System.Windows.EventRoute,System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | AddVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock) | (Inherited from UIElement.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from FrameworkElement.)
Public method | Arrange(System.Windows.Rect) | (Inherited from UIElement.)
Protected method | ArrangeCore(System.Windows.Rect) | (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(System.Windows.Size) | (Inherited from Control.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline) | (Inherited from UIElement.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | BeginInit | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior,System.Boolean) | (Inherited from FrameworkElement.)
Public method | BringIntoView | (Inherited from FrameworkElement.)
Public method | BringIntoView(System.Windows.Rect) | (Inherited from FrameworkElement.)
Public method | CaptureMouse | (Inherited from UIElement.)
Public method | CaptureStylus | (Inherited from UIElement.)
Public method | CaptureTouch(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DispatcherObject.)
Public method | ClearValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | ClearValue(System.Windows.DependencyPropertyKey) | (Inherited from DependencyObject.)
Public method | CoerceValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | EndInit | (Inherited from FrameworkElement.)
Public method | Equals(System.Object) | (Inherited from DependencyObject.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindCommonVisualAncestor(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | FindName(System.String) | (Inherited from FrameworkElement.)
Public method | FindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from UIElement.)
Public method | GetAnimationBaseValue(System.Windows.DependencyProperty) | (Inherited from UIElement.)
Public method | GetBindingExpression(System.Windows.DependencyProperty) | (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from DependencyObject.)
Protected method | GetLayoutClip(System.Windows.Size) | (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | (Inherited from DependencyObject.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Protected method | GetVisualChild(System.Int32) | (Inherited from FrameworkElement.)
Protected method | HitTestCore(System.Windows.Media.PointHitTestParameters) | (Inherited from UIElement.)
Protected method | HitTestCore(System.Windows.Media.GeometryHitTestParameters) | (Inherited from UIElement.)
Public method | InputHitTest(System.Windows.Point) | (Inherited from UIElement.)
Public method | InvalidateArrange | (Inherited from UIElement.)
Public method | InvalidateMeasure | (Inherited from UIElement.)
Public method | InvalidateProperty(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | InvalidateVisual | (Inherited from UIElement.)
Public method | IsAncestorOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | IsDescendantOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | Measure(System.Windows.Size) | (Inherited from UIElement.)
Protected method | MeasureCore(System.Windows.Size) | (Inherited from FrameworkElement.)
Protected method | MeasureOverride(System.Windows.Size) | (Inherited from Control.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | MoveFocus(System.Windows.Input.TraversalRequest) | (Inherited from FrameworkElement.)
Protected method | OnAccessKey(System.Windows.Input.AccessKeyEventArgs) | (Inherited from UIElement.)
Public method | OnApplyTemplate | (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged(System.Windows.UIElement) | (Inherited from UIElement.)
Protected method | OnContentChanged(System.Object,System.Object) | (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged(System.String,System.String) | (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged(System.Windows.DataTemplate,System.Windows.DataTemplate) | (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged(System.Windows.Controls.DataTemplateSelector,System.Windows.Controls.DataTemplateSelector) | (Inherited from ContentControl.)
Protected method | OnContextMenuClosing(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | (Inherited from UserControl.)
Protected method | OnDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnGotFocus(System.Windows.RoutedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnGotMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnGotStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnGotTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnInitialized(System.EventArgs) | (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnLostFocus(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnLostStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnLostTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback(System.Windows.Input.ManipulationBoundaryFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationCompleted(System.Windows.Input.ManipulationCompletedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationDelta(System.Windows.Input.ManipulationDeltaEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting(System.Windows.Input.ManipulationInertiaStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarted(System.Windows.Input.ManipulationStartedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarting(System.Windows.Input.ManipulationStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseEnter(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeave(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnPreviewMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPropertyChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnQueryCursor(System.Windows.Input.QueryCursorEventArgs) | (Inherited from UIElement.)
Protected method | OnRender(System.Windows.Media.DrawingContext) | (Inherited from UIElement.)
Protected method | OnStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusEnter(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusLeave(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnTemplateChanged(System.Windows.Controls.ControlTemplate,System.Windows.Controls.ControlTemplate) | (Inherited from Control.)
Protected method | OnTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnToolTipClosing(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchEnter(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchLeave(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Public method | PointFromScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PointToScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PredictFocus(System.Windows.Input.FocusNavigationDirection) | (Inherited from FrameworkElement.)
Public method | RaiseEvent(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Public method | ReadLocalValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | RegisterName(System.String,System.Object) | (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | (Inherited from UIElement.)
Public method | ReleaseMouseCapture | (Inherited from UIElement.)
Public method | ReleaseStylusCapture | (Inherited from UIElement.)
Public method | ReleaseTouchCapture(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | RemoveHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Protected method | RemoveVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | SetBinding(System.Windows.DependencyProperty,System.Windows.Data.BindingBase) | (Inherited from FrameworkElement.)
Public method | SetBinding(System.Windows.DependencyProperty,System.String) | (Inherited from FrameworkElement.)
Public method | SetCurrentValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetResourceReference(System.Windows.DependencyProperty,System.Object) | (Inherited from FrameworkElement.)
Public method | SetValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetValue(System.Windows.DependencyPropertyKey,System.Object) | (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | (Inherited from UIElement.)
Public method | ShouldSerializeContent | (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | (Inherited from UIElement.)
Public method | ShouldSerializeResources | (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | (Inherited from FrameworkElement.)
Public method | ToString | (Inherited from Control.)
Public method | TransformToAncestor(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToAncestor(System.Windows.Media.Media3D.Visual3D) | (Inherited from Visual.)
Public method | TransformToDescendant(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToVisual(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TranslatePoint(System.Windows.Point,System.Windows.UIElement) | (Inherited from UIElement.)
Public method | TryFindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | UnregisterName(System.String) | (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | (Inherited from FrameworkElement.)
Public method | UpdateLayout | (Inherited from UIElement.)
Public method | VerifyAccess | (Inherited from DispatcherObject.)

Properties

 | Name | Description
Public property | ActualHeight | (Inherited from FrameworkElement.)
Public property | ActualWidth | (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
Public property | AreAnyTouchesOver | (Inherited from UIElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from FrameworkElement.)
Public property | BitmapEffect | (Inherited from UIElement.)
Public property | BitmapEffectInput | (Inherited from UIElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | (Inherited from UIElement.)
Public property | ClipToBounds | (Inherited from UIElement.)
Public property | CommandBindings | (Inherited from UIElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContentTemplate | (Inherited from ContentControl.)
Public property | ContentTemplateSelector | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from FrameworkElement.)
Public property | Cursor | (Inherited from FrameworkElement.)
Public property | DataContext | (Inherited from FrameworkElement.)
Public property | DependencyObjectType | (Inherited from DependencyObject.)
Public property | DesiredSize | (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DispatcherObject.)
Public property | Effect | (Inherited from UIElement.)
Public property | FlowDirection | (Inherited from FrameworkElement.)
Public property | Focusable | (Inherited from UIElement.)
Public property | FocusVisualStyle | (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from FrameworkElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasAnimatedProperties | (Inherited from UIElement.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | InputBindings | (Inherited from UIElement.)
Public property | InputScope | (Inherited from FrameworkElement.)
Public property | IsArrangeValid | (Inherited from UIElement.)
Public property | IsEnabled | (Inherited from UIElement.)
Protected property | IsEnabledCore | (Inherited from UIElement.)
Public property | IsFocused | (Inherited from UIElement.)
Public property | IsHitTestVisible | (Inherited from UIElement.)
Public property | IsInitialized | (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | (Inherited from UIElement.)
Public property | IsKeyboardFocused | (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | (Inherited from UIElement.)
Public property | IsLoaded | (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | (Inherited from UIElement.)
Public property | IsMeasureValid | (Inherited from UIElement.)
Public property | IsMouseCaptured | (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | (Inherited from UIElement.)
Public property | IsMouseOver | (Inherited from UIElement.)
Public property | IsSealed | (Inherited from DependencyObject.)
Public property | IsStylusCaptured | (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | (Inherited from UIElement.)
Public property | IsStylusOver | (Inherited from UIElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsVisible | (Inherited from UIElement.)
Public property | Language | (Inherited from FrameworkElement.)
Public property | LayoutTransform | (Inherited from FrameworkElement.)
Public property | Margin | (Inherited from FrameworkElement.)
Public property | MaxHeight | (Inherited from FrameworkElement.)
Public property | MaxWidth | (Inherited from FrameworkElement.)
Public property | MinHeight | (Inherited from FrameworkElement.)
Public property | MinWidth | (Inherited from FrameworkElement.)
Public property | Name | (Inherited from FrameworkElement.)
Public property | Opacity | (Inherited from UIElement.)
Public property | OpacityMask | (Inherited from UIElement.)
Public property | OverridesDefaultStyle | (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from FrameworkElement.)
Public property | PersistId | (Inherited from UIElement.)
Public property | RenderSize | (Inherited from UIElement.)
Public property | RenderTransform | (Inherited from UIElement.)
Public property | RenderTransformOrigin | (Inherited from UIElement.)
Public property | Resources | (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from UIElement.)
Public property | Style | (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | (Inherited from UIElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | Tag | (Inherited from FrameworkElement.)
Public property | Template | (Inherited from Control.)
Public property | TemplatedParent | (Inherited from FrameworkElement.)
Public property | ToolTip | (Inherited from FrameworkElement.)
Public property | TouchesCaptured | (Inherited from UIElement.)
Public property | TouchesCapturedWithin | (Inherited from UIElement.)
Public property | TouchesDirectlyOver | (Inherited from UIElement.)
Public property | TouchesOver | (Inherited from UIElement.)
Public property | Triggers | (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from UIElement.)
Public property | UseLayoutRounding | (Inherited from FrameworkElement.)
Public property | VerticalAlignment | (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | (Inherited from UIElement.)
Protected property | VisualChildrenCount | (Inherited from FrameworkElement.)
Protected property | VisualParent | (Inherited from Visual.)
Public property | Width | (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | ContextMenuClosing | (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | (Inherited from FrameworkElement.)
Public event | DataContextChanged | (Inherited from FrameworkElement.)
Public event | DragEnter | (Inherited from UIElement.)
Public event | DragLeave | (Inherited from UIElement.)
Public event | DragOver | (Inherited from UIElement.)
Public event | Drop | (Inherited from UIElement.)
Public event | FocusableChanged | (Inherited from UIElement.)
Public event | GiveFeedback | (Inherited from UIElement.)
Public event | GotFocus | (Inherited from UIElement.)
Public event | GotKeyboardFocus | (Inherited from UIElement.)
Public event | GotMouseCapture | (Inherited from UIElement.)
Public event | GotStylusCapture | (Inherited from UIElement.)
Public event | GotTouchCapture | (Inherited from UIElement.)
Public event | Initialized | (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsVisibleChanged | (Inherited from UIElement.)
Public event | KeyDown | (Inherited from UIElement.)
Public event | KeyUp | (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from UIElement.)
Public event | Loaded | (Inherited from FrameworkElement.)
Public event | LostFocus | (Inherited from UIElement.)
Public event | LostKeyboardFocus | (Inherited from UIElement.)
Public event | LostMouseCapture | (Inherited from UIElement.)
Public event | LostStylusCapture | (Inherited from UIElement.)
Public event | LostTouchCapture | (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | ManipulationStarting | (Inherited from UIElement.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from UIElement.)
Public event | MouseEnter | (Inherited from UIElement.)
Public event | MouseLeave | (Inherited from UIElement.)
Public event | MouseLeftButtonDown | (Inherited from UIElement.)
Public event | MouseLeftButtonUp | (Inherited from UIElement.)
Public event | MouseMove | (Inherited from UIElement.)
Public event | MouseRightButtonDown | (Inherited from UIElement.)
Public event | MouseRightButtonUp | (Inherited from UIElement.)
Public event | MouseUp | (Inherited from UIElement.)
Public event | MouseWheel | (Inherited from UIElement.)
Public event | PreviewDragEnter | (Inherited from UIElement.)
Public event | PreviewDragLeave | (Inherited from UIElement.)
Public event | PreviewDragOver | (Inherited from UIElement.)
Public event | PreviewDrop | (Inherited from UIElement.)
Public event | PreviewGiveFeedback | (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewKeyDown | (Inherited from UIElement.)
Public event | PreviewKeyUp | (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | (Inherited from Control.)
Public event | PreviewMouseDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseMove | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseUp | (Inherited from UIElement.)
Public event | PreviewMouseWheel | (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | (Inherited from UIElement.)
Public event | PreviewStylusDown | (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | (Inherited from UIElement.)
Public event | PreviewStylusInRange | (Inherited from UIElement.)
Public event | PreviewStylusMove | (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | (Inherited from UIElement.)
Public event | PreviewStylusUp | (Inherited from UIElement.)
Public event | PreviewTextInput | (Inherited from UIElement.)
Public event | PreviewTouchDown | (Inherited from UIElement.)
Public event | PreviewTouchMove | (Inherited from UIElement.)
Public event | PreviewTouchUp | (Inherited from UIElement.)
Public event | QueryContinueDrag | (Inherited from UIElement.)
Public event | QueryCursor | (Inherited from UIElement.)
Public event | RequestBringIntoView | (Inherited from FrameworkElement.)
Public event | SizeChanged | (Inherited from FrameworkElement.)
Public event | SourceUpdated | (Inherited from FrameworkElement.)
Public event | StylusButtonDown | (Inherited from UIElement.)
Public event | StylusButtonUp | (Inherited from UIElement.)
Public event | StylusDown | (Inherited from UIElement.)
Public event | StylusEnter | (Inherited from UIElement.)
Public event | StylusInAirMove | (Inherited from UIElement.)
Public event | StylusInRange | (Inherited from UIElement.)
Public event | StylusLeave | (Inherited from UIElement.)
Public event | StylusMove | (Inherited from UIElement.)
Public event | StylusOutOfRange | (Inherited from UIElement.)
Public event | StylusSystemGesture | (Inherited from UIElement.)
Public event | StylusUp | (Inherited from UIElement.)
Public event | TargetUpdated | (Inherited from FrameworkElement.)
Public event | TextInput | (Inherited from UIElement.)
Public event | ToolTipClosing | (Inherited from FrameworkElement.)
Public event | ToolTipOpening | (Inherited from FrameworkElement.)
Public event | TouchDown | (Inherited from UIElement.)
Public event | TouchEnter | (Inherited from UIElement.)
Public event | TouchLeave | (Inherited from UIElement.)
Public event | TouchMove | (Inherited from UIElement.)
Public event | TouchUp | (Inherited from UIElement.)
Public event | Unloaded | (Inherited from FrameworkElement.)

See Also

ChatUserControler Class
wManager.Wow.Forms Namespace


ChatUserControler Constructor

Initializes a new instance of the ChatUserControler class.

Namespace: wManager.Wow.Forms
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public ChatUserControler()
Public Sub New
public:
ChatUserControler()

See Also

ChatUserControler Class
wManager.Wow.Forms Namespace


ChatUserControler Methods

The ChatUserControler type exposes the following members.

Methods

 | Name | Description
Protected method | AddChild(System.Object) | (Inherited from ContentControl.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate,System.Boolean) | (Inherited from UIElement.)
Protected method | AddText(System.String) | (Inherited from ContentControl.)
Public method | AddToEventRoute(System.Windows.EventRoute,System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | AddVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock) | (Inherited from UIElement.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from FrameworkElement.)
Public method | Arrange(System.Windows.Rect) | (Inherited from UIElement.)
Protected method | ArrangeCore(System.Windows.Rect) | (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(System.Windows.Size) | (Inherited from Control.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline) | (Inherited from UIElement.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | BeginInit | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior,System.Boolean) | (Inherited from FrameworkElement.)
Public method | BringIntoView | (Inherited from FrameworkElement.)
Public method | BringIntoView(System.Windows.Rect) | (Inherited from FrameworkElement.)
Public method | CaptureMouse | (Inherited from UIElement.)
Public method | CaptureStylus | (Inherited from UIElement.)
Public method | CaptureTouch(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DispatcherObject.)
Public method | ClearValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | ClearValue(System.Windows.DependencyPropertyKey) | (Inherited from DependencyObject.)
Public method | CoerceValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | EndInit | (Inherited from FrameworkElement.)
Public method | Equals(System.Object) | (Inherited from DependencyObject.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindCommonVisualAncestor(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | FindName(System.String) | (Inherited from FrameworkElement.)
Public method | FindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from UIElement.)
Public method | GetAnimationBaseValue(System.Windows.DependencyProperty) | (Inherited from UIElement.)
Public method | GetBindingExpression(System.Windows.DependencyProperty) | (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from DependencyObject.)
Protected method | GetLayoutClip(System.Windows.Size) | (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | (Inherited from DependencyObject.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Protected method | GetVisualChild(System.Int32) | (Inherited from FrameworkElement.)
Protected method | HitTestCore(System.Windows.Media.PointHitTestParameters) | (Inherited from UIElement.)
Protected method | HitTestCore(System.Windows.Media.GeometryHitTestParameters) | (Inherited from UIElement.)
Public method | InputHitTest(System.Windows.Point) | (Inherited from UIElement.)
Public method | InvalidateArrange | (Inherited from UIElement.)
Public method | InvalidateMeasure | (Inherited from UIElement.)
Public method | InvalidateProperty(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | InvalidateVisual | (Inherited from UIElement.)
Public method | IsAncestorOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | IsDescendantOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | Measure(System.Windows.Size) | (Inherited from UIElement.)
Protected method | MeasureCore(System.Windows.Size) | (Inherited from FrameworkElement.)
Protected method | MeasureOverride(System.Windows.Size) | (Inherited from Control.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | MoveFocus(System.Windows.Input.TraversalRequest) | (Inherited from FrameworkElement.)
Protected method | OnAccessKey(System.Windows.Input.AccessKeyEventArgs) | (Inherited from UIElement.)
Public method | OnApplyTemplate | (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged(System.Windows.UIElement) | (Inherited from UIElement.)
Protected method | OnContentChanged(System.Object,System.Object) | (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged(System.String,System.String) | (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged(System.Windows.DataTemplate,System.Windows.DataTemplate) | (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged(System.Windows.Controls.DataTemplateSelector,System.Windows.Controls.DataTemplateSelector) | (Inherited from ContentControl.)
Protected method | OnContextMenuClosing(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | (Inherited from UserControl.)
Protected method | OnDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnGotFocus(System.Windows.RoutedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnGotMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnGotStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnGotTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnInitialized(System.EventArgs) | (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnLostFocus(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnLostStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnLostTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback(System.Windows.Input.ManipulationBoundaryFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationCompleted(System.Windows.Input.ManipulationCompletedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationDelta(System.Windows.Input.ManipulationDeltaEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting(System.Windows.Input.ManipulationInertiaStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarted(System.Windows.Input.ManipulationStartedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarting(System.Windows.Input.ManipulationStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseEnter(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeave(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnPreviewMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPropertyChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnQueryCursor(System.Windows.Input.QueryCursorEventArgs) | (Inherited from UIElement.)
Protected method | OnRender(System.Windows.Media.DrawingContext) | (Inherited from UIElement.)
Protected method | OnStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusEnter(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusLeave(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnTemplateChanged(System.Windows.Controls.ControlTemplate,System.Windows.Controls.ControlTemplate) | (Inherited from Control.)
Protected method | OnTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnToolTipClosing(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchEnter(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchLeave(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Public method | PointFromScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PointToScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PredictFocus(System.Windows.Input.FocusNavigationDirection) | (Inherited from FrameworkElement.)
Public method | RaiseEvent(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Public method | ReadLocalValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | RegisterName(System.String,System.Object) | (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | (Inherited from UIElement.)
Public method | ReleaseMouseCapture | (Inherited from UIElement.)
Public method | ReleaseStylusCapture | (Inherited from UIElement.)
Public method | ReleaseTouchCapture(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | RemoveHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Protected method | RemoveVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | SetBinding(System.Windows.DependencyProperty,System.Windows.Data.BindingBase) | (Inherited from FrameworkElement.)
Public method | SetBinding(System.Windows.DependencyProperty,System.String) | (Inherited from FrameworkElement.)
Public method | SetCurrentValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetResourceReference(System.Windows.DependencyProperty,System.Object) | (Inherited from FrameworkElement.)
Public method | SetValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetValue(System.Windows.DependencyPropertyKey,System.Object) | (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | (Inherited from UIElement.)
Public method | ShouldSerializeContent | (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | (Inherited from UIElement.)
Public method | ShouldSerializeResources | (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | (Inherited from FrameworkElement.)
Public method | ToString | (Inherited from Control.)
Public method | TransformToAncestor(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToAncestor(System.Windows.Media.Media3D.Visual3D) | (Inherited from Visual.)
Public method | TransformToDescendant(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToVisual(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TranslatePoint(System.Windows.Point,System.Windows.UIElement) | (Inherited from UIElement.)
Public method | TryFindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | UnregisterName(System.String) | (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | (Inherited from FrameworkElement.)
Public method | UpdateLayout | (Inherited from UIElement.)
Public method | VerifyAccess | (Inherited from DispatcherObject.)

See Also

ChatUserControler Class
wManager.Wow.Forms Namespace


ChatUserControler Properties

The ChatUserControler type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | (Inherited from FrameworkElement.)
Public property | ActualWidth | (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
Public property | AreAnyTouchesOver | (Inherited from UIElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from FrameworkElement.)
Public property | BitmapEffect | (Inherited from UIElement.)
Public property | BitmapEffectInput | (Inherited from UIElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | (Inherited from UIElement.)
Public property | ClipToBounds | (Inherited from UIElement.)
Public property | CommandBindings | (Inherited from UIElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContentTemplate | (Inherited from ContentControl.)
Public property | ContentTemplateSelector | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from FrameworkElement.)
Public property | Cursor | (Inherited from FrameworkElement.)
Public property | DataContext | (Inherited from FrameworkElement.)
Public property | DependencyObjectType | (Inherited from DependencyObject.)
Public property | DesiredSize | (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DispatcherObject.)
Public property | Effect | (Inherited from UIElement.)
Public property | FlowDirection | (Inherited from FrameworkElement.)
Public property | Focusable | (Inherited from UIElement.)
Public property | FocusVisualStyle | (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from FrameworkElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasAnimatedProperties | (Inherited from UIElement.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | InputBindings | (Inherited from UIElement.)
Public property | InputScope | (Inherited from FrameworkElement.)
Public property | IsArrangeValid | (Inherited from UIElement.)
Public property | IsEnabled | (Inherited from UIElement.)
Protected property | IsEnabledCore | (Inherited from UIElement.)
Public property | IsFocused | (Inherited from UIElement.)
Public property | IsHitTestVisible | (Inherited from UIElement.)
Public property | IsInitialized | (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | (Inherited from UIElement.)
Public property | IsKeyboardFocused | (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | (Inherited from UIElement.)
Public property | IsLoaded | (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | (Inherited from UIElement.)
Public property | IsMeasureValid | (Inherited from UIElement.)
Public property | IsMouseCaptured | (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | (Inherited from UIElement.)
Public property | IsMouseOver | (Inherited from UIElement.)
Public property | IsSealed | (Inherited from DependencyObject.)
Public property | IsStylusCaptured | (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | (Inherited from UIElement.)
Public property | IsStylusOver | (Inherited from UIElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsVisible | (Inherited from UIElement.)
Public property | Language | (Inherited from FrameworkElement.)
Public property | LayoutTransform | (Inherited from FrameworkElement.)
Public property | Margin | (Inherited from FrameworkElement.)
Public property | MaxHeight | (Inherited from FrameworkElement.)
Public property | MaxWidth | (Inherited from FrameworkElement.)
Public property | MinHeight | (Inherited from FrameworkElement.)
Public property | MinWidth | (Inherited from FrameworkElement.)
Public property | Name | (Inherited from FrameworkElement.)
Public property | Opacity | (Inherited from UIElement.)
Public property | OpacityMask | (Inherited from UIElement.)
Public property | OverridesDefaultStyle | (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from FrameworkElement.)
Public property | PersistId | (Inherited from UIElement.)
Public property | RenderSize | (Inherited from UIElement.)
Public property | RenderTransform | (Inherited from UIElement.)
Public property | RenderTransformOrigin | (Inherited from UIElement.)
Public property | Resources | (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from UIElement.)
Public property | Style | (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | (Inherited from UIElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | Tag | (Inherited from FrameworkElement.)
Public property | Template | (Inherited from Control.)
Public property | TemplatedParent | (Inherited from FrameworkElement.)
Public property | ToolTip | (Inherited from FrameworkElement.)
Public property | TouchesCaptured | (Inherited from UIElement.)
Public property | TouchesCapturedWithin | (Inherited from UIElement.)
Public property | TouchesDirectlyOver | (Inherited from UIElement.)
Public property | TouchesOver | (Inherited from UIElement.)
Public property | Triggers | (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from UIElement.)
Public property | UseLayoutRounding | (Inherited from FrameworkElement.)
Public property | VerticalAlignment | (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | (Inherited from UIElement.)
Protected property | VisualChildrenCount | (Inherited from FrameworkElement.)
Protected property | VisualParent | (Inherited from Visual.)
Public property | Width | (Inherited from FrameworkElement.)

See Also

ChatUserControler Class
wManager.Wow.Forms Namespace


ChatUserControler Events

The ChatUserControler type exposes the following members.

Events

 | Name | Description
Public event | ContextMenuClosing | (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | (Inherited from FrameworkElement.)
Public event | DataContextChanged | (Inherited from FrameworkElement.)
Public event | DragEnter | (Inherited from UIElement.)
Public event | DragLeave | (Inherited from UIElement.)
Public event | DragOver | (Inherited from UIElement.)
Public event | Drop | (Inherited from UIElement.)
Public event | FocusableChanged | (Inherited from UIElement.)
Public event | GiveFeedback | (Inherited from UIElement.)
Public event | GotFocus | (Inherited from UIElement.)
Public event | GotKeyboardFocus | (Inherited from UIElement.)
Public event | GotMouseCapture | (Inherited from UIElement.)
Public event | GotStylusCapture | (Inherited from UIElement.)
Public event | GotTouchCapture | (Inherited from UIElement.)
Public event | Initialized | (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsVisibleChanged | (Inherited from UIElement.)
Public event | KeyDown | (Inherited from UIElement.)
Public event | KeyUp | (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from UIElement.)
Public event | Loaded | (Inherited from FrameworkElement.)
Public event | LostFocus | (Inherited from UIElement.)
Public event | LostKeyboardFocus | (Inherited from UIElement.)
Public event | LostMouseCapture | (Inherited from UIElement.)
Public event | LostStylusCapture | (Inherited from UIElement.)
Public event | LostTouchCapture | (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | ManipulationStarting | (Inherited from UIElement.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from UIElement.)
Public event | MouseEnter | (Inherited from UIElement.)
Public event | MouseLeave | (Inherited from UIElement.)
Public event | MouseLeftButtonDown | (Inherited from UIElement.)
Public event | MouseLeftButtonUp | (Inherited from UIElement.)
Public event | MouseMove | (Inherited from UIElement.)
Public event | MouseRightButtonDown | (Inherited from UIElement.)
Public event | MouseRightButtonUp | (Inherited from UIElement.)
Public event | MouseUp | (Inherited from UIElement.)
Public event | MouseWheel | (Inherited from UIElement.)
Public event | PreviewDragEnter | (Inherited from UIElement.)
Public event | PreviewDragLeave | (Inherited from UIElement.)
Public event | PreviewDragOver | (Inherited from UIElement.)
Public event | PreviewDrop | (Inherited from UIElement.)
Public event | PreviewGiveFeedback | (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewKeyDown | (Inherited from UIElement.)
Public event | PreviewKeyUp | (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | (Inherited from Control.)
Public event | PreviewMouseDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseMove | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseUp | (Inherited from UIElement.)
Public event | PreviewMouseWheel | (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | (Inherited from UIElement.)
Public event | PreviewStylusDown | (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | (Inherited from UIElement.)
Public event | PreviewStylusInRange | (Inherited from UIElement.)
Public event | PreviewStylusMove | (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | (Inherited from UIElement.)
Public event | PreviewStylusUp | (Inherited from UIElement.)
Public event | PreviewTextInput | (Inherited from UIElement.)
Public event | PreviewTouchDown | (Inherited from UIElement.)
Public event | PreviewTouchMove | (Inherited from UIElement.)
Public event | PreviewTouchUp | (Inherited from UIElement.)
Public event | QueryContinueDrag | (Inherited from UIElement.)
Public event | QueryCursor | (Inherited from UIElement.)
Public event | RequestBringIntoView | (Inherited from FrameworkElement.)
Public event | SizeChanged | (Inherited from FrameworkElement.)
Public event | SourceUpdated | (Inherited from FrameworkElement.)
Public event | StylusButtonDown | (Inherited from UIElement.)
Public event | StylusButtonUp | (Inherited from UIElement.)
Public event | StylusDown | (Inherited from UIElement.)
Public event | StylusEnter | (Inherited from UIElement.)
Public event | StylusInAirMove | (Inherited from UIElement.)
Public event | StylusInRange | (Inherited from UIElement.)
Public event | StylusLeave | (Inherited from UIElement.)
Public event | StylusMove | (Inherited from UIElement.)
Public event | StylusOutOfRange | (Inherited from UIElement.)
Public event | StylusSystemGesture | (Inherited from UIElement.)
Public event | StylusUp | (Inherited from UIElement.)
Public event | TargetUpdated | (Inherited from FrameworkElement.)
Public event | TextInput | (Inherited from UIElement.)
Public event | ToolTipClosing | (Inherited from FrameworkElement.)
Public event | ToolTipOpening | (Inherited from FrameworkElement.)
Public event | TouchDown | (Inherited from UIElement.)
Public event | TouchEnter | (Inherited from UIElement.)
Public event | TouchLeave | (Inherited from UIElement.)
Public event | TouchMove | (Inherited from UIElement.)
Public event | TouchUp | (Inherited from UIElement.)
Public event | Unloaded | (Inherited from FrameworkElement.)

See Also

ChatUserControler Class
wManager.Wow.Forms Namespace


NpcDbWindow Class

Window to edit ListNpc

Namespace: wManager.Wow.Forms
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class NpcDbWindow
Public Class NpcDbWindow
public ref class NpcDbWindow

Inheritance Hierarchy

Object
wManager.Wow.Forms..::..NpcDbWindow

See Also

NpcDbWindow Members
wManager.Wow.Forms Namespace


NpcDbWindow Members

The NpcDbWindow type exposes the following members.

Constructors

 | Name | Description
Public method | NpcDbWindow | Initializes a new instance of the NpcDbWindow class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

NpcDbWindow Class
wManager.Wow.Forms Namespace


NpcDbWindow Constructor

Initializes a new instance of the NpcDbWindow class.

Namespace: wManager.Wow.Forms
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public NpcDbWindow()
Public Sub New
public:
NpcDbWindow()

See Also

NpcDbWindow Class
wManager.Wow.Forms Namespace


NpcDbWindow Methods

The NpcDbWindow type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

NpcDbWindow Class
wManager.Wow.Forms Namespace


OffMeshConnectionWindow Class

Window to add or edit offmeshconnections

Namespace: wManager.Wow.Forms
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class OffMeshConnectionWindow
Public Class OffMeshConnectionWindow
public ref class OffMeshConnectionWindow

Inheritance Hierarchy

Object
wManager.Wow.Forms..::..OffMeshConnectionWindow

See Also

OffMeshConnectionWindow Members
wManager.Wow.Forms Namespace


OffMeshConnectionWindow Members

The OffMeshConnectionWindow type exposes the following members.

Constructors

 | Name | Description
Public method | OffMeshConnectionWindow()()()() | Initializes a new instance of the OffMeshConnectionWindow class.
Public method | OffMeshConnectionWindow(List<(Of <<'(PathFinder..::..OffMeshConnection>)>>)%) | Initializes a new instance of the OffMeshConnectionWindow class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | OffMeshConnections | Gets or sets the off mesh connections.

See Also

OffMeshConnectionWindow Class
wManager.Wow.Forms Namespace


OffMeshConnectionWindow Constructor

Overload List

 | Name | Description
Public method | OffMeshConnectionWindow()()()() | Initializes a new instance of the OffMeshConnectionWindow class.
Public method | OffMeshConnectionWindow(List<(Of <<'(PathFinder..::..OffMeshConnection>)>>)%) | Initializes a new instance of the OffMeshConnectionWindow class.

See Also

OffMeshConnectionWindow Class
OffMeshConnectionWindow Members
wManager.Wow.Forms Namespace


OffMeshConnectionWindow Constructor

Initializes a new instance of the OffMeshConnectionWindow class.

Namespace: wManager.Wow.Forms
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public OffMeshConnectionWindow()
Public Sub New
public:
OffMeshConnectionWindow()

See Also

OffMeshConnectionWindow Class
OffMeshConnectionWindow Overload
wManager.Wow.Forms Namespace


OffMeshConnectionWindow Constructor (List(OffMeshConnection))

OffMeshConnectionWindow Constructor (List<(Of <(<'OffMeshConnection>)>)>%)

Initializes a new instance of the OffMeshConnectionWindow class.

Namespace: wManager.Wow.Forms
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public OffMeshConnectionWindow(
    ref List<PathFinder..::..OffMeshConnection> offMeshConnections
)
Public Sub New ( _
    ByRef offMeshConnections As List(Of PathFinder..::..OffMeshConnection) _
)
public:
OffMeshConnectionWindow(
    List<PathFinder..::..OffMeshConnection^>^% offMeshConnections
)

Parameters

offMeshConnections
Type: List <(Of <(<' PathFinder..::..OffMeshConnection >)>)>%
The off mesh connections.

See Also

OffMeshConnectionWindow Class
OffMeshConnectionWindow Overload
wManager.Wow.Forms Namespace


OffMeshConnectionWindow Methods

The OffMeshConnectionWindow type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

OffMeshConnectionWindow Class
wManager.Wow.Forms Namespace


OffMeshConnectionWindow Properties

The OffMeshConnectionWindow type exposes the following members.

Properties

 | Name | Description
Public property | OffMeshConnections | Gets or sets the off mesh connections.

See Also

OffMeshConnectionWindow Class
wManager.Wow.Forms Namespace


OffMeshConnections Property

OffMeshConnectionWindow..::..OffMeshConnections Property

Gets or sets the off mesh connections.

Namespace: wManager.Wow.Forms
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<PathFinder..::..OffMeshConnection> OffMeshConnections { get; set; }
Public Property OffMeshConnections As List(Of PathFinder..::..OffMeshConnection)
    Get
    Set
public:
property List<PathFinder..::..OffMeshConnection^>^ OffMeshConnections {
    List<PathFinder..::..OffMeshConnection^>^ get ();
    void set (List<PathFinder..::..OffMeshConnection^>^ value);
}

Field Value

The off mesh connections.

See Also

OffMeshConnectionWindow Class
wManager.Wow.Forms Namespace


PluginsUserControl Class

Plugins UserControl (used tab "Plugins")

Namespace: wManager.Wow.Forms
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class PluginsUserControl : UserControl
Public Class PluginsUserControl _
    Inherits UserControl
public ref class PluginsUserControl : public UserControl

Inheritance Hierarchy

Object
DispatcherObject
DependencyObject
Visual
UIElement
FrameworkElement
Control
ContentControl
UserControl
wManager.Wow.Forms..::..PluginsUserControl

See Also

PluginsUserControl Members
wManager.Wow.Forms Namespace


PluginsUserControl Members

The PluginsUserControl type exposes the following members.

Constructors

 | Name | Description
Public method | PluginsUserControl | Initializes a new instance of the PluginsUserControl class.

Methods

 | Name | Description
Protected method | AddChild(System.Object) | (Inherited from ContentControl.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate,System.Boolean) | (Inherited from UIElement.)
Protected method | AddText(System.String) | (Inherited from ContentControl.)
Public method | AddToEventRoute(System.Windows.EventRoute,System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | AddVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock) | (Inherited from UIElement.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from FrameworkElement.)
Public method | Arrange(System.Windows.Rect) | (Inherited from UIElement.)
Protected method | ArrangeCore(System.Windows.Rect) | (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(System.Windows.Size) | (Inherited from Control.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline) | (Inherited from UIElement.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | BeginInit | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior,System.Boolean) | (Inherited from FrameworkElement.)
Public method | BringIntoView | (Inherited from FrameworkElement.)
Public method | BringIntoView(System.Windows.Rect) | (Inherited from FrameworkElement.)
Public method | CaptureMouse | (Inherited from UIElement.)
Public method | CaptureStylus | (Inherited from UIElement.)
Public method | CaptureTouch(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DispatcherObject.)
Public method | ClearValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | ClearValue(System.Windows.DependencyPropertyKey) | (Inherited from DependencyObject.)
Public method | CoerceValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | EndInit | (Inherited from FrameworkElement.)
Public method | Equals(System.Object) | (Inherited from DependencyObject.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindCommonVisualAncestor(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | FindName(System.String) | (Inherited from FrameworkElement.)
Public method | FindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from UIElement.)
Public method | GetAnimationBaseValue(System.Windows.DependencyProperty) | (Inherited from UIElement.)
Public method | GetBindingExpression(System.Windows.DependencyProperty) | (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from DependencyObject.)
Protected method | GetLayoutClip(System.Windows.Size) | (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | (Inherited from DependencyObject.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Protected method | GetVisualChild(System.Int32) | (Inherited from FrameworkElement.)
Protected method | HitTestCore(System.Windows.Media.PointHitTestParameters) | (Inherited from UIElement.)
Protected method | HitTestCore(System.Windows.Media.GeometryHitTestParameters) | (Inherited from UIElement.)
Public method | InputHitTest(System.Windows.Point) | (Inherited from UIElement.)
Public method | InvalidateArrange | (Inherited from UIElement.)
Public method | InvalidateMeasure | (Inherited from UIElement.)
Public method | InvalidateProperty(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | InvalidateVisual | (Inherited from UIElement.)
Public method | IsAncestorOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | IsDescendantOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | Measure(System.Windows.Size) | (Inherited from UIElement.)
Protected method | MeasureCore(System.Windows.Size) | (Inherited from FrameworkElement.)
Protected method | MeasureOverride(System.Windows.Size) | (Inherited from Control.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | MoveFocus(System.Windows.Input.TraversalRequest) | (Inherited from FrameworkElement.)
Protected method | OnAccessKey(System.Windows.Input.AccessKeyEventArgs) | (Inherited from UIElement.)
Public method | OnApplyTemplate | (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged(System.Windows.UIElement) | (Inherited from UIElement.)
Protected method | OnContentChanged(System.Object,System.Object) | (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged(System.String,System.String) | (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged(System.Windows.DataTemplate,System.Windows.DataTemplate) | (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged(System.Windows.Controls.DataTemplateSelector,System.Windows.Controls.DataTemplateSelector) | (Inherited from ContentControl.)
Protected method | OnContextMenuClosing(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | (Inherited from UserControl.)
Protected method | OnDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnGotFocus(System.Windows.RoutedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnGotMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnGotStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnGotTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnInitialized(System.EventArgs) | (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnLostFocus(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnLostStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnLostTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback(System.Windows.Input.ManipulationBoundaryFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationCompleted(System.Windows.Input.ManipulationCompletedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationDelta(System.Windows.Input.ManipulationDeltaEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting(System.Windows.Input.ManipulationInertiaStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarted(System.Windows.Input.ManipulationStartedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarting(System.Windows.Input.ManipulationStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseEnter(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeave(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnPreviewMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPropertyChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnQueryCursor(System.Windows.Input.QueryCursorEventArgs) | (Inherited from UIElement.)
Protected method | OnRender(System.Windows.Media.DrawingContext) | (Inherited from UIElement.)
Protected method | OnStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusEnter(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusLeave(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnTemplateChanged(System.Windows.Controls.ControlTemplate,System.Windows.Controls.ControlTemplate) | (Inherited from Control.)
Protected method | OnTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnToolTipClosing(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchEnter(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchLeave(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Public method | PointFromScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PointToScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PredictFocus(System.Windows.Input.FocusNavigationDirection) | (Inherited from FrameworkElement.)
Public method | RaiseEvent(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Public method | ReadLocalValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | RegisterName(System.String,System.Object) | (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | (Inherited from UIElement.)
Public method | ReleaseMouseCapture | (Inherited from UIElement.)
Public method | ReleaseStylusCapture | (Inherited from UIElement.)
Public method | ReleaseTouchCapture(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | RemoveHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Protected method | RemoveVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | SetBinding(System.Windows.DependencyProperty,System.Windows.Data.BindingBase) | (Inherited from FrameworkElement.)
Public method | SetBinding(System.Windows.DependencyProperty,System.String) | (Inherited from FrameworkElement.)
Public method | SetCurrentValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetResourceReference(System.Windows.DependencyProperty,System.Object) | (Inherited from FrameworkElement.)
Public method | SetValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetValue(System.Windows.DependencyPropertyKey,System.Object) | (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | (Inherited from UIElement.)
Public method | ShouldSerializeContent | (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | (Inherited from UIElement.)
Public method | ShouldSerializeResources | (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | (Inherited from FrameworkElement.)
Public method | ToString | (Inherited from Control.)
Public method | TransformToAncestor(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToAncestor(System.Windows.Media.Media3D.Visual3D) | (Inherited from Visual.)
Public method | TransformToDescendant(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToVisual(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TranslatePoint(System.Windows.Point,System.Windows.UIElement) | (Inherited from UIElement.)
Public method | TryFindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | UnregisterName(System.String) | (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | (Inherited from FrameworkElement.)
Public method | UpdateLayout | (Inherited from UIElement.)
Public method | VerifyAccess | (Inherited from DispatcherObject.)

Properties

 | Name | Description
Public property | ActualHeight | (Inherited from FrameworkElement.)
Public property | ActualWidth | (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
Public property | AreAnyTouchesOver | (Inherited from UIElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from FrameworkElement.)
Public property | BitmapEffect | (Inherited from UIElement.)
Public property | BitmapEffectInput | (Inherited from UIElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | (Inherited from UIElement.)
Public property | ClipToBounds | (Inherited from UIElement.)
Public property | CommandBindings | (Inherited from UIElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContentTemplate | (Inherited from ContentControl.)
Public property | ContentTemplateSelector | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from FrameworkElement.)
Public property | Cursor | (Inherited from FrameworkElement.)
Public property | DataContext | (Inherited from FrameworkElement.)
Public property | DependencyObjectType | (Inherited from DependencyObject.)
Public property | DesiredSize | (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DispatcherObject.)
Public property | Effect | (Inherited from UIElement.)
Public property | FlowDirection | (Inherited from FrameworkElement.)
Public property | Focusable | (Inherited from UIElement.)
Public property | FocusVisualStyle | (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from FrameworkElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasAnimatedProperties | (Inherited from UIElement.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | InputBindings | (Inherited from UIElement.)
Public property | InputScope | (Inherited from FrameworkElement.)
Public property | IsArrangeValid | (Inherited from UIElement.)
Public property | IsEnabled | (Inherited from UIElement.)
Protected property | IsEnabledCore | (Inherited from UIElement.)
Public property | IsFocused | (Inherited from UIElement.)
Public property | IsHitTestVisible | (Inherited from UIElement.)
Public property | IsInitialized | (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | (Inherited from UIElement.)
Public property | IsKeyboardFocused | (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | (Inherited from UIElement.)
Public property | IsLoaded | (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | (Inherited from UIElement.)
Public property | IsMeasureValid | (Inherited from UIElement.)
Public property | IsMouseCaptured | (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | (Inherited from UIElement.)
Public property | IsMouseOver | (Inherited from UIElement.)
Public property | IsSealed | (Inherited from DependencyObject.)
Public property | IsStylusCaptured | (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | (Inherited from UIElement.)
Public property | IsStylusOver | (Inherited from UIElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsVisible | (Inherited from UIElement.)
Public property | Language | (Inherited from FrameworkElement.)
Public property | LayoutTransform | (Inherited from FrameworkElement.)
Public property | Margin | (Inherited from FrameworkElement.)
Public property | MaxHeight | (Inherited from FrameworkElement.)
Public property | MaxWidth | (Inherited from FrameworkElement.)
Public property | MinHeight | (Inherited from FrameworkElement.)
Public property | MinWidth | (Inherited from FrameworkElement.)
Public property | Name | (Inherited from FrameworkElement.)
Public property | Opacity | (Inherited from UIElement.)
Public property | OpacityMask | (Inherited from UIElement.)
Public property | OverridesDefaultStyle | (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from FrameworkElement.)
Public property | PersistId | (Inherited from UIElement.)
Public property | RenderSize | (Inherited from UIElement.)
Public property | RenderTransform | (Inherited from UIElement.)
Public property | RenderTransformOrigin | (Inherited from UIElement.)
Public property | Resources | (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from UIElement.)
Public property | Style | (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | (Inherited from UIElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | Tag | (Inherited from FrameworkElement.)
Public property | Template | (Inherited from Control.)
Public property | TemplatedParent | (Inherited from FrameworkElement.)
Public property | ToolTip | (Inherited from FrameworkElement.)
Public property | TouchesCaptured | (Inherited from UIElement.)
Public property | TouchesCapturedWithin | (Inherited from UIElement.)
Public property | TouchesDirectlyOver | (Inherited from UIElement.)
Public property | TouchesOver | (Inherited from UIElement.)
Public property | Triggers | (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from UIElement.)
Public property | UseLayoutRounding | (Inherited from FrameworkElement.)
Public property | VerticalAlignment | (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | (Inherited from UIElement.)
Protected property | VisualChildrenCount | (Inherited from FrameworkElement.)
Protected property | VisualParent | (Inherited from Visual.)
Public property | Width | (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | ContextMenuClosing | (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | (Inherited from FrameworkElement.)
Public event | DataContextChanged | (Inherited from FrameworkElement.)
Public event | DragEnter | (Inherited from UIElement.)
Public event | DragLeave | (Inherited from UIElement.)
Public event | DragOver | (Inherited from UIElement.)
Public event | Drop | (Inherited from UIElement.)
Public event | FocusableChanged | (Inherited from UIElement.)
Public event | GiveFeedback | (Inherited from UIElement.)
Public event | GotFocus | (Inherited from UIElement.)
Public event | GotKeyboardFocus | (Inherited from UIElement.)
Public event | GotMouseCapture | (Inherited from UIElement.)
Public event | GotStylusCapture | (Inherited from UIElement.)
Public event | GotTouchCapture | (Inherited from UIElement.)
Public event | Initialized | (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsVisibleChanged | (Inherited from UIElement.)
Public event | KeyDown | (Inherited from UIElement.)
Public event | KeyUp | (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from UIElement.)
Public event | Loaded | (Inherited from FrameworkElement.)
Public event | LostFocus | (Inherited from UIElement.)
Public event | LostKeyboardFocus | (Inherited from UIElement.)
Public event | LostMouseCapture | (Inherited from UIElement.)
Public event | LostStylusCapture | (Inherited from UIElement.)
Public event | LostTouchCapture | (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | ManipulationStarting | (Inherited from UIElement.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from UIElement.)
Public event | MouseEnter | (Inherited from UIElement.)
Public event | MouseLeave | (Inherited from UIElement.)
Public event | MouseLeftButtonDown | (Inherited from UIElement.)
Public event | MouseLeftButtonUp | (Inherited from UIElement.)
Public event | MouseMove | (Inherited from UIElement.)
Public event | MouseRightButtonDown | (Inherited from UIElement.)
Public event | MouseRightButtonUp | (Inherited from UIElement.)
Public event | MouseUp | (Inherited from UIElement.)
Public event | MouseWheel | (Inherited from UIElement.)
Public event | PreviewDragEnter | (Inherited from UIElement.)
Public event | PreviewDragLeave | (Inherited from UIElement.)
Public event | PreviewDragOver | (Inherited from UIElement.)
Public event | PreviewDrop | (Inherited from UIElement.)
Public event | PreviewGiveFeedback | (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewKeyDown | (Inherited from UIElement.)
Public event | PreviewKeyUp | (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | (Inherited from Control.)
Public event | PreviewMouseDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseMove | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseUp | (Inherited from UIElement.)
Public event | PreviewMouseWheel | (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | (Inherited from UIElement.)
Public event | PreviewStylusDown | (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | (Inherited from UIElement.)
Public event | PreviewStylusInRange | (Inherited from UIElement.)
Public event | PreviewStylusMove | (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | (Inherited from UIElement.)
Public event | PreviewStylusUp | (Inherited from UIElement.)
Public event | PreviewTextInput | (Inherited from UIElement.)
Public event | PreviewTouchDown | (Inherited from UIElement.)
Public event | PreviewTouchMove | (Inherited from UIElement.)
Public event | PreviewTouchUp | (Inherited from UIElement.)
Public event | QueryContinueDrag | (Inherited from UIElement.)
Public event | QueryCursor | (Inherited from UIElement.)
Public event | RequestBringIntoView | (Inherited from FrameworkElement.)
Public event | SizeChanged | (Inherited from FrameworkElement.)
Public event | SourceUpdated | (Inherited from FrameworkElement.)
Public event | StylusButtonDown | (Inherited from UIElement.)
Public event | StylusButtonUp | (Inherited from UIElement.)
Public event | StylusDown | (Inherited from UIElement.)
Public event | StylusEnter | (Inherited from UIElement.)
Public event | StylusInAirMove | (Inherited from UIElement.)
Public event | StylusInRange | (Inherited from UIElement.)
Public event | StylusLeave | (Inherited from UIElement.)
Public event | StylusMove | (Inherited from UIElement.)
Public event | StylusOutOfRange | (Inherited from UIElement.)
Public event | StylusSystemGesture | (Inherited from UIElement.)
Public event | StylusUp | (Inherited from UIElement.)
Public event | TargetUpdated | (Inherited from FrameworkElement.)
Public event | TextInput | (Inherited from UIElement.)
Public event | ToolTipClosing | (Inherited from FrameworkElement.)
Public event | ToolTipOpening | (Inherited from FrameworkElement.)
Public event | TouchDown | (Inherited from UIElement.)
Public event | TouchEnter | (Inherited from UIElement.)
Public event | TouchLeave | (Inherited from UIElement.)
Public event | TouchMove | (Inherited from UIElement.)
Public event | TouchUp | (Inherited from UIElement.)
Public event | Unloaded | (Inherited from FrameworkElement.)

See Also

PluginsUserControl Class
wManager.Wow.Forms Namespace


PluginsUserControl Constructor

Initializes a new instance of the PluginsUserControl class.

Namespace: wManager.Wow.Forms
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public PluginsUserControl()
Public Sub New
public:
PluginsUserControl()

See Also

PluginsUserControl Class
wManager.Wow.Forms Namespace


PluginsUserControl Methods

The PluginsUserControl type exposes the following members.

Methods

 | Name | Description
Protected method | AddChild(System.Object) | (Inherited from ContentControl.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate,System.Boolean) | (Inherited from UIElement.)
Protected method | AddText(System.String) | (Inherited from ContentControl.)
Public method | AddToEventRoute(System.Windows.EventRoute,System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | AddVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock) | (Inherited from UIElement.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from FrameworkElement.)
Public method | Arrange(System.Windows.Rect) | (Inherited from UIElement.)
Protected method | ArrangeCore(System.Windows.Rect) | (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(System.Windows.Size) | (Inherited from Control.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline) | (Inherited from UIElement.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | BeginInit | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior,System.Boolean) | (Inherited from FrameworkElement.)
Public method | BringIntoView | (Inherited from FrameworkElement.)
Public method | BringIntoView(System.Windows.Rect) | (Inherited from FrameworkElement.)
Public method | CaptureMouse | (Inherited from UIElement.)
Public method | CaptureStylus | (Inherited from UIElement.)
Public method | CaptureTouch(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DispatcherObject.)
Public method | ClearValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | ClearValue(System.Windows.DependencyPropertyKey) | (Inherited from DependencyObject.)
Public method | CoerceValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | EndInit | (Inherited from FrameworkElement.)
Public method | Equals(System.Object) | (Inherited from DependencyObject.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindCommonVisualAncestor(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | FindName(System.String) | (Inherited from FrameworkElement.)
Public method | FindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from UIElement.)
Public method | GetAnimationBaseValue(System.Windows.DependencyProperty) | (Inherited from UIElement.)
Public method | GetBindingExpression(System.Windows.DependencyProperty) | (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from DependencyObject.)
Protected method | GetLayoutClip(System.Windows.Size) | (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | (Inherited from DependencyObject.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Protected method | GetVisualChild(System.Int32) | (Inherited from FrameworkElement.)
Protected method | HitTestCore(System.Windows.Media.PointHitTestParameters) | (Inherited from UIElement.)
Protected method | HitTestCore(System.Windows.Media.GeometryHitTestParameters) | (Inherited from UIElement.)
Public method | InputHitTest(System.Windows.Point) | (Inherited from UIElement.)
Public method | InvalidateArrange | (Inherited from UIElement.)
Public method | InvalidateMeasure | (Inherited from UIElement.)
Public method | InvalidateProperty(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | InvalidateVisual | (Inherited from UIElement.)
Public method | IsAncestorOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | IsDescendantOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | Measure(System.Windows.Size) | (Inherited from UIElement.)
Protected method | MeasureCore(System.Windows.Size) | (Inherited from FrameworkElement.)
Protected method | MeasureOverride(System.Windows.Size) | (Inherited from Control.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | MoveFocus(System.Windows.Input.TraversalRequest) | (Inherited from FrameworkElement.)
Protected method | OnAccessKey(System.Windows.Input.AccessKeyEventArgs) | (Inherited from UIElement.)
Public method | OnApplyTemplate | (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged(System.Windows.UIElement) | (Inherited from UIElement.)
Protected method | OnContentChanged(System.Object,System.Object) | (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged(System.String,System.String) | (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged(System.Windows.DataTemplate,System.Windows.DataTemplate) | (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged(System.Windows.Controls.DataTemplateSelector,System.Windows.Controls.DataTemplateSelector) | (Inherited from ContentControl.)
Protected method | OnContextMenuClosing(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | (Inherited from UserControl.)
Protected method | OnDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnGotFocus(System.Windows.RoutedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnGotMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnGotStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnGotTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnInitialized(System.EventArgs) | (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnLostFocus(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnLostStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnLostTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback(System.Windows.Input.ManipulationBoundaryFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationCompleted(System.Windows.Input.ManipulationCompletedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationDelta(System.Windows.Input.ManipulationDeltaEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting(System.Windows.Input.ManipulationInertiaStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarted(System.Windows.Input.ManipulationStartedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarting(System.Windows.Input.ManipulationStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseEnter(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeave(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnPreviewMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPropertyChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnQueryCursor(System.Windows.Input.QueryCursorEventArgs) | (Inherited from UIElement.)
Protected method | OnRender(System.Windows.Media.DrawingContext) | (Inherited from UIElement.)
Protected method | OnStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusEnter(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusLeave(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnTemplateChanged(System.Windows.Controls.ControlTemplate,System.Windows.Controls.ControlTemplate) | (Inherited from Control.)
Protected method | OnTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnToolTipClosing(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchEnter(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchLeave(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Public method | PointFromScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PointToScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PredictFocus(System.Windows.Input.FocusNavigationDirection) | (Inherited from FrameworkElement.)
Public method | RaiseEvent(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Public method | ReadLocalValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | RegisterName(System.String,System.Object) | (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | (Inherited from UIElement.)
Public method | ReleaseMouseCapture | (Inherited from UIElement.)
Public method | ReleaseStylusCapture | (Inherited from UIElement.)
Public method | ReleaseTouchCapture(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | RemoveHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Protected method | RemoveVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | SetBinding(System.Windows.DependencyProperty,System.Windows.Data.BindingBase) | (Inherited from FrameworkElement.)
Public method | SetBinding(System.Windows.DependencyProperty,System.String) | (Inherited from FrameworkElement.)
Public method | SetCurrentValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetResourceReference(System.Windows.DependencyProperty,System.Object) | (Inherited from FrameworkElement.)
Public method | SetValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetValue(System.Windows.DependencyPropertyKey,System.Object) | (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | (Inherited from UIElement.)
Public method | ShouldSerializeContent | (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | (Inherited from UIElement.)
Public method | ShouldSerializeResources | (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | (Inherited from FrameworkElement.)
Public method | ToString | (Inherited from Control.)
Public method | TransformToAncestor(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToAncestor(System.Windows.Media.Media3D.Visual3D) | (Inherited from Visual.)
Public method | TransformToDescendant(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToVisual(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TranslatePoint(System.Windows.Point,System.Windows.UIElement) | (Inherited from UIElement.)
Public method | TryFindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | UnregisterName(System.String) | (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | (Inherited from FrameworkElement.)
Public method | UpdateLayout | (Inherited from UIElement.)
Public method | VerifyAccess | (Inherited from DispatcherObject.)

See Also

PluginsUserControl Class
wManager.Wow.Forms Namespace


PluginsUserControl Properties

The PluginsUserControl type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | (Inherited from FrameworkElement.)
Public property | ActualWidth | (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
Public property | AreAnyTouchesOver | (Inherited from UIElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from FrameworkElement.)
Public property | BitmapEffect | (Inherited from UIElement.)
Public property | BitmapEffectInput | (Inherited from UIElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | (Inherited from UIElement.)
Public property | ClipToBounds | (Inherited from UIElement.)
Public property | CommandBindings | (Inherited from UIElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContentTemplate | (Inherited from ContentControl.)
Public property | ContentTemplateSelector | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from FrameworkElement.)
Public property | Cursor | (Inherited from FrameworkElement.)
Public property | DataContext | (Inherited from FrameworkElement.)
Public property | DependencyObjectType | (Inherited from DependencyObject.)
Public property | DesiredSize | (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DispatcherObject.)
Public property | Effect | (Inherited from UIElement.)
Public property | FlowDirection | (Inherited from FrameworkElement.)
Public property | Focusable | (Inherited from UIElement.)
Public property | FocusVisualStyle | (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from FrameworkElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasAnimatedProperties | (Inherited from UIElement.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | InputBindings | (Inherited from UIElement.)
Public property | InputScope | (Inherited from FrameworkElement.)
Public property | IsArrangeValid | (Inherited from UIElement.)
Public property | IsEnabled | (Inherited from UIElement.)
Protected property | IsEnabledCore | (Inherited from UIElement.)
Public property | IsFocused | (Inherited from UIElement.)
Public property | IsHitTestVisible | (Inherited from UIElement.)
Public property | IsInitialized | (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | (Inherited from UIElement.)
Public property | IsKeyboardFocused | (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | (Inherited from UIElement.)
Public property | IsLoaded | (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | (Inherited from UIElement.)
Public property | IsMeasureValid | (Inherited from UIElement.)
Public property | IsMouseCaptured | (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | (Inherited from UIElement.)
Public property | IsMouseOver | (Inherited from UIElement.)
Public property | IsSealed | (Inherited from DependencyObject.)
Public property | IsStylusCaptured | (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | (Inherited from UIElement.)
Public property | IsStylusOver | (Inherited from UIElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsVisible | (Inherited from UIElement.)
Public property | Language | (Inherited from FrameworkElement.)
Public property | LayoutTransform | (Inherited from FrameworkElement.)
Public property | Margin | (Inherited from FrameworkElement.)
Public property | MaxHeight | (Inherited from FrameworkElement.)
Public property | MaxWidth | (Inherited from FrameworkElement.)
Public property | MinHeight | (Inherited from FrameworkElement.)
Public property | MinWidth | (Inherited from FrameworkElement.)
Public property | Name | (Inherited from FrameworkElement.)
Public property | Opacity | (Inherited from UIElement.)
Public property | OpacityMask | (Inherited from UIElement.)
Public property | OverridesDefaultStyle | (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from FrameworkElement.)
Public property | PersistId | (Inherited from UIElement.)
Public property | RenderSize | (Inherited from UIElement.)
Public property | RenderTransform | (Inherited from UIElement.)
Public property | RenderTransformOrigin | (Inherited from UIElement.)
Public property | Resources | (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from UIElement.)
Public property | Style | (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | (Inherited from UIElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | Tag | (Inherited from FrameworkElement.)
Public property | Template | (Inherited from Control.)
Public property | TemplatedParent | (Inherited from FrameworkElement.)
Public property | ToolTip | (Inherited from FrameworkElement.)
Public property | TouchesCaptured | (Inherited from UIElement.)
Public property | TouchesCapturedWithin | (Inherited from UIElement.)
Public property | TouchesDirectlyOver | (Inherited from UIElement.)
Public property | TouchesOver | (Inherited from UIElement.)
Public property | Triggers | (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from UIElement.)
Public property | UseLayoutRounding | (Inherited from FrameworkElement.)
Public property | VerticalAlignment | (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | (Inherited from UIElement.)
Protected property | VisualChildrenCount | (Inherited from FrameworkElement.)
Protected property | VisualParent | (Inherited from Visual.)
Public property | Width | (Inherited from FrameworkElement.)

See Also

PluginsUserControl Class
wManager.Wow.Forms Namespace


PluginsUserControl Events

The PluginsUserControl type exposes the following members.

Events

 | Name | Description
Public event | ContextMenuClosing | (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | (Inherited from FrameworkElement.)
Public event | DataContextChanged | (Inherited from FrameworkElement.)
Public event | DragEnter | (Inherited from UIElement.)
Public event | DragLeave | (Inherited from UIElement.)
Public event | DragOver | (Inherited from UIElement.)
Public event | Drop | (Inherited from UIElement.)
Public event | FocusableChanged | (Inherited from UIElement.)
Public event | GiveFeedback | (Inherited from UIElement.)
Public event | GotFocus | (Inherited from UIElement.)
Public event | GotKeyboardFocus | (Inherited from UIElement.)
Public event | GotMouseCapture | (Inherited from UIElement.)
Public event | GotStylusCapture | (Inherited from UIElement.)
Public event | GotTouchCapture | (Inherited from UIElement.)
Public event | Initialized | (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsVisibleChanged | (Inherited from UIElement.)
Public event | KeyDown | (Inherited from UIElement.)
Public event | KeyUp | (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from UIElement.)
Public event | Loaded | (Inherited from FrameworkElement.)
Public event | LostFocus | (Inherited from UIElement.)
Public event | LostKeyboardFocus | (Inherited from UIElement.)
Public event | LostMouseCapture | (Inherited from UIElement.)
Public event | LostStylusCapture | (Inherited from UIElement.)
Public event | LostTouchCapture | (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | ManipulationStarting | (Inherited from UIElement.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from UIElement.)
Public event | MouseEnter | (Inherited from UIElement.)
Public event | MouseLeave | (Inherited from UIElement.)
Public event | MouseLeftButtonDown | (Inherited from UIElement.)
Public event | MouseLeftButtonUp | (Inherited from UIElement.)
Public event | MouseMove | (Inherited from UIElement.)
Public event | MouseRightButtonDown | (Inherited from UIElement.)
Public event | MouseRightButtonUp | (Inherited from UIElement.)
Public event | MouseUp | (Inherited from UIElement.)
Public event | MouseWheel | (Inherited from UIElement.)
Public event | PreviewDragEnter | (Inherited from UIElement.)
Public event | PreviewDragLeave | (Inherited from UIElement.)
Public event | PreviewDragOver | (Inherited from UIElement.)
Public event | PreviewDrop | (Inherited from UIElement.)
Public event | PreviewGiveFeedback | (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewKeyDown | (Inherited from UIElement.)
Public event | PreviewKeyUp | (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | (Inherited from Control.)
Public event | PreviewMouseDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseMove | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseUp | (Inherited from UIElement.)
Public event | PreviewMouseWheel | (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | (Inherited from UIElement.)
Public event | PreviewStylusDown | (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | (Inherited from UIElement.)
Public event | PreviewStylusInRange | (Inherited from UIElement.)
Public event | PreviewStylusMove | (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | (Inherited from UIElement.)
Public event | PreviewStylusUp | (Inherited from UIElement.)
Public event | PreviewTextInput | (Inherited from UIElement.)
Public event | PreviewTouchDown | (Inherited from UIElement.)
Public event | PreviewTouchMove | (Inherited from UIElement.)
Public event | PreviewTouchUp | (Inherited from UIElement.)
Public event | QueryContinueDrag | (Inherited from UIElement.)
Public event | QueryCursor | (Inherited from UIElement.)
Public event | RequestBringIntoView | (Inherited from FrameworkElement.)
Public event | SizeChanged | (Inherited from FrameworkElement.)
Public event | SourceUpdated | (Inherited from FrameworkElement.)
Public event | StylusButtonDown | (Inherited from UIElement.)
Public event | StylusButtonUp | (Inherited from UIElement.)
Public event | StylusDown | (Inherited from UIElement.)
Public event | StylusEnter | (Inherited from UIElement.)
Public event | StylusInAirMove | (Inherited from UIElement.)
Public event | StylusInRange | (Inherited from UIElement.)
Public event | StylusLeave | (Inherited from UIElement.)
Public event | StylusMove | (Inherited from UIElement.)
Public event | StylusOutOfRange | (Inherited from UIElement.)
Public event | StylusSystemGesture | (Inherited from UIElement.)
Public event | StylusUp | (Inherited from UIElement.)
Public event | TargetUpdated | (Inherited from FrameworkElement.)
Public event | TextInput | (Inherited from UIElement.)
Public event | ToolTipClosing | (Inherited from FrameworkElement.)
Public event | ToolTipOpening | (Inherited from FrameworkElement.)
Public event | TouchDown | (Inherited from UIElement.)
Public event | TouchEnter | (Inherited from UIElement.)
Public event | TouchLeave | (Inherited from UIElement.)
Public event | TouchMove | (Inherited from UIElement.)
Public event | TouchUp | (Inherited from UIElement.)
Public event | Unloaded | (Inherited from FrameworkElement.)

See Also

PluginsUserControl Class
wManager.Wow.Forms Namespace


TaxiDbWindow Class

Window to manage Nodes

Namespace: wManager.Wow.Forms
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class TaxiDbWindow
Public Class TaxiDbWindow
public ref class TaxiDbWindow

Inheritance Hierarchy

Object
wManager.Wow.Forms..::..TaxiDbWindow

See Also

TaxiDbWindow Members
wManager.Wow.Forms Namespace


TaxiDbWindow Members

The TaxiDbWindow type exposes the following members.

Constructors

 | Name | Description
Public method | TaxiDbWindow | Initializes a new instance of the TaxiDbWindow class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

TaxiDbWindow Class
wManager.Wow.Forms Namespace


TaxiDbWindow Constructor

Initializes a new instance of the TaxiDbWindow class.

Namespace: wManager.Wow.Forms
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public TaxiDbWindow()
Public Sub New
public:
TaxiDbWindow()

See Also

TaxiDbWindow Class
wManager.Wow.Forms Namespace


TaxiDbWindow Methods

The TaxiDbWindow type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

TaxiDbWindow Class
wManager.Wow.Forms Namespace


ToolboxWindow Class

Window Toolbox (also named development tools)

Namespace: wManager.Wow.Forms
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class ToolboxWindow
Public Class ToolboxWindow
public ref class ToolboxWindow

Inheritance Hierarchy

Object
wManager.Wow.Forms..::..ToolboxWindow

See Also

ToolboxWindow Members
wManager.Wow.Forms Namespace


ToolboxWindow Members

The ToolboxWindow type exposes the following members.

Constructors

 | Name | Description
Public method | ToolboxWindow | Initializes a new instance of the ToolboxWindow class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Fields

Name | Description
DbgOutputVarName | The debug output variable name

See Also

ToolboxWindow Class
wManager.Wow.Forms Namespace


ToolboxWindow Constructor

Initializes a new instance of the ToolboxWindow class.

Namespace: wManager.Wow.Forms
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public ToolboxWindow()
Public Sub New
public:
ToolboxWindow()

See Also

ToolboxWindow Class
wManager.Wow.Forms Namespace


ToolboxWindow Fields

The ToolboxWindow type exposes the following members.

Fields

Name | Description
DbgOutputVarName | The debug output variable name

See Also

ToolboxWindow Class
wManager.Wow.Forms Namespace


DbgOutputVarName Field

ToolboxWindow..::..DbgOutputVarName Field

The debug output variable name

Namespace: wManager.Wow.Forms
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string DbgOutputVarName
Public Shared DbgOutputVarName As String
public:
static String^ DbgOutputVarName

See Also

ToolboxWindow Class
wManager.Wow.Forms Namespace


ToolboxWindow Methods

The ToolboxWindow type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

ToolboxWindow Class
wManager.Wow.Forms Namespace


UserControlMiniMap Class

MiniMap UserControl (game map, used tab "Map"). Too add landmarks look LandmarksMiniMap

Namespace: wManager.Wow.Forms
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class UserControlMiniMap : UserControl
Public Class UserControlMiniMap _
    Inherits UserControl
public ref class UserControlMiniMap : public UserControl

Inheritance Hierarchy

Object
DispatcherObject
DependencyObject
Visual
UIElement
FrameworkElement
Control
ContentControl
UserControl
wManager.Wow.Forms..::..UserControlMiniMap

See Also

UserControlMiniMap Members
wManager.Wow.Forms Namespace


UserControlMiniMap Members

The UserControlMiniMap type exposes the following members.

Constructors

 | Name | Description
Public method | UserControlMiniMap | Initializes a new instance of the UserControlMiniMap class.

Methods

 | Name | Description
Protected method | AddChild(System.Object) | (Inherited from ContentControl.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate,System.Boolean) | (Inherited from UIElement.)
Protected method | AddText(System.String) | (Inherited from ContentControl.)
Public method | AddToEventRoute(System.Windows.EventRoute,System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | AddVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock) | (Inherited from UIElement.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from FrameworkElement.)
Public method | Arrange(System.Windows.Rect) | (Inherited from UIElement.)
Protected method | ArrangeCore(System.Windows.Rect) | (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(System.Windows.Size) | (Inherited from Control.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline) | (Inherited from UIElement.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | BeginInit | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior,System.Boolean) | (Inherited from FrameworkElement.)
Public method | BringIntoView | (Inherited from FrameworkElement.)
Public method | BringIntoView(System.Windows.Rect) | (Inherited from FrameworkElement.)
Public method | CaptureMouse | (Inherited from UIElement.)
Public method | CaptureStylus | (Inherited from UIElement.)
Public method | CaptureTouch(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DispatcherObject.)
Public method | ClearValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | ClearValue(System.Windows.DependencyPropertyKey) | (Inherited from DependencyObject.)
Public method | CoerceValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | EndInit | (Inherited from FrameworkElement.)
Public method | Equals(System.Object) | (Inherited from DependencyObject.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindCommonVisualAncestor(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | FindName(System.String) | (Inherited from FrameworkElement.)
Public method | FindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from UIElement.)
Public method | GetAnimationBaseValue(System.Windows.DependencyProperty) | (Inherited from UIElement.)
Public method | GetBindingExpression(System.Windows.DependencyProperty) | (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from DependencyObject.)
Protected method | GetLayoutClip(System.Windows.Size) | (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | (Inherited from DependencyObject.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Protected method | GetVisualChild(System.Int32) | (Inherited from FrameworkElement.)
Protected method | HitTestCore(System.Windows.Media.PointHitTestParameters) | (Inherited from UIElement.)
Protected method | HitTestCore(System.Windows.Media.GeometryHitTestParameters) | (Inherited from UIElement.)
Public method | InputHitTest(System.Windows.Point) | (Inherited from UIElement.)
Public method | InvalidateArrange | (Inherited from UIElement.)
Public method | InvalidateMeasure | (Inherited from UIElement.)
Public method | InvalidateProperty(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | InvalidateVisual | (Inherited from UIElement.)
Public method | IsAncestorOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | IsDescendantOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | Measure(System.Windows.Size) | (Inherited from UIElement.)
Protected method | MeasureCore(System.Windows.Size) | (Inherited from FrameworkElement.)
Protected method | MeasureOverride(System.Windows.Size) | (Inherited from Control.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | MoveFocus(System.Windows.Input.TraversalRequest) | (Inherited from FrameworkElement.)
Protected method | OnAccessKey(System.Windows.Input.AccessKeyEventArgs) | (Inherited from UIElement.)
Public method | OnApplyTemplate | (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged(System.Windows.UIElement) | (Inherited from UIElement.)
Protected method | OnContentChanged(System.Object,System.Object) | (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged(System.String,System.String) | (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged(System.Windows.DataTemplate,System.Windows.DataTemplate) | (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged(System.Windows.Controls.DataTemplateSelector,System.Windows.Controls.DataTemplateSelector) | (Inherited from ContentControl.)
Protected method | OnContextMenuClosing(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | (Inherited from UserControl.)
Protected method | OnDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnGotFocus(System.Windows.RoutedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnGotMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnGotStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnGotTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnInitialized(System.EventArgs) | (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnLostFocus(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnLostStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnLostTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback(System.Windows.Input.ManipulationBoundaryFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationCompleted(System.Windows.Input.ManipulationCompletedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationDelta(System.Windows.Input.ManipulationDeltaEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting(System.Windows.Input.ManipulationInertiaStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarted(System.Windows.Input.ManipulationStartedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarting(System.Windows.Input.ManipulationStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseEnter(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeave(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnPreviewMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPropertyChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnQueryCursor(System.Windows.Input.QueryCursorEventArgs) | (Inherited from UIElement.)
Protected method | OnRender(System.Windows.Media.DrawingContext) | (Inherited from UIElement.)
Protected method | OnStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusEnter(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusLeave(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnTemplateChanged(System.Windows.Controls.ControlTemplate,System.Windows.Controls.ControlTemplate) | (Inherited from Control.)
Protected method | OnTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnToolTipClosing(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchEnter(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchLeave(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Public method | PointFromScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PointToScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PredictFocus(System.Windows.Input.FocusNavigationDirection) | (Inherited from FrameworkElement.)
Public method | RaiseEvent(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Public method | ReadLocalValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | RegisterName(System.String,System.Object) | (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | (Inherited from UIElement.)
Public method | ReleaseMouseCapture | (Inherited from UIElement.)
Public method | ReleaseStylusCapture | (Inherited from UIElement.)
Public method | ReleaseTouchCapture(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | RemoveHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Protected method | RemoveVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | SetBinding(System.Windows.DependencyProperty,System.Windows.Data.BindingBase) | (Inherited from FrameworkElement.)
Public method | SetBinding(System.Windows.DependencyProperty,System.String) | (Inherited from FrameworkElement.)
Public method | SetCurrentValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetResourceReference(System.Windows.DependencyProperty,System.Object) | (Inherited from FrameworkElement.)
Public method | SetValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetValue(System.Windows.DependencyPropertyKey,System.Object) | (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | (Inherited from UIElement.)
Public method | ShouldSerializeContent | (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | (Inherited from UIElement.)
Public method | ShouldSerializeResources | (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | (Inherited from FrameworkElement.)
Public method | ToString | (Inherited from Control.)
Public method | TransformToAncestor(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToAncestor(System.Windows.Media.Media3D.Visual3D) | (Inherited from Visual.)
Public method | TransformToDescendant(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToVisual(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TranslatePoint(System.Windows.Point,System.Windows.UIElement) | (Inherited from UIElement.)
Public method | TryFindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | UnregisterName(System.String) | (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | (Inherited from FrameworkElement.)
Public method | UpdateLayout | (Inherited from UIElement.)
Public method | VerifyAccess | (Inherited from DispatcherObject.)

Fields

Name Description
LandmarksMiniMap
The map and radar 3D landmarks.

Examples

C#
var miniMapLandmarkName = "MyCustomName";
var path = new List<Vector3> {new Vector3(1, 2, 3), new Vector3(4, 2, 3), new Vector3(3, 4, 3), }
UserControlMiniMap.LandmarksMiniMap.Remove(miniMapLandmarkName);
if (path.Count > 0)
     UserControlMiniMap.LandmarksMiniMap.Add(path[0], miniMapLandmarkName, Color.Orange, 10, miniMapLandmarkName, true);
foreach (var vector3 in path)
{
    UserControlMiniMap.LandmarksMiniMap.Add(vector3, miniMapLandmarkName, Color.Orange, 10, "", true);
}

Properties

 | Name | Description
Public property | ActualHeight | (Inherited from FrameworkElement.)
Public property | ActualWidth | (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
Public property | AreAnyTouchesOver | (Inherited from UIElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from FrameworkElement.)
Public property | BitmapEffect | (Inherited from UIElement.)
Public property | BitmapEffectInput | (Inherited from UIElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | (Inherited from UIElement.)
Public property | ClipToBounds | (Inherited from UIElement.)
Public property | CommandBindings | (Inherited from UIElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContentTemplate | (Inherited from ContentControl.)
Public property | ContentTemplateSelector | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from FrameworkElement.)
Public property | Cursor | (Inherited from FrameworkElement.)
Public property | DataContext | (Inherited from FrameworkElement.)
Public property | DependencyObjectType | (Inherited from DependencyObject.)
Public property | DesiredSize | (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DispatcherObject.)
Public property | Effect | (Inherited from UIElement.)
Public property | FlowDirection | (Inherited from FrameworkElement.)
Public property | Focusable | (Inherited from UIElement.)
Public property | FocusVisualStyle | (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from FrameworkElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasAnimatedProperties | (Inherited from UIElement.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | InputBindings | (Inherited from UIElement.)
Public property | InputScope | (Inherited from FrameworkElement.)
Public property | IsArrangeValid | (Inherited from UIElement.)
Public property | IsEnabled | (Inherited from UIElement.)
Protected property | IsEnabledCore | (Inherited from UIElement.)
Public property | IsFocused | (Inherited from UIElement.)
Public property | IsHitTestVisible | (Inherited from UIElement.)
Public property | IsInitialized | (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | (Inherited from UIElement.)
Public property | IsKeyboardFocused | (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | (Inherited from UIElement.)
Public property | IsLoaded | (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | (Inherited from UIElement.)
Public property | IsMeasureValid | (Inherited from UIElement.)
Public property | IsMouseCaptured | (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | (Inherited from UIElement.)
Public property | IsMouseOver | (Inherited from UIElement.)
Public property | IsSealed | (Inherited from DependencyObject.)
Public property | IsStylusCaptured | (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | (Inherited from UIElement.)
Public property | IsStylusOver | (Inherited from UIElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsVisible | (Inherited from UIElement.)
Public property | Language | (Inherited from FrameworkElement.)
Public property | LayoutTransform | (Inherited from FrameworkElement.)
Public property | Margin | (Inherited from FrameworkElement.)
Public property | MaxHeight | (Inherited from FrameworkElement.)
Public property | MaxWidth | (Inherited from FrameworkElement.)
Public property | MinHeight | (Inherited from FrameworkElement.)
Public property | MinWidth | (Inherited from FrameworkElement.)
Public property | Name | (Inherited from FrameworkElement.)
Public property | Opacity | (Inherited from UIElement.)
Public property | OpacityMask | (Inherited from UIElement.)
Public property | OverridesDefaultStyle | (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from FrameworkElement.)
Public property | PersistId | (Inherited from UIElement.)
Public property | RenderSize | (Inherited from UIElement.)
Public property | RenderTransform | (Inherited from UIElement.)
Public property | RenderTransformOrigin | (Inherited from UIElement.)
Public property | Resources | (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from UIElement.)
Public property | Style | (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | (Inherited from UIElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | Tag | (Inherited from FrameworkElement.)
Public property | Template | (Inherited from Control.)
Public property | TemplatedParent | (Inherited from FrameworkElement.)
Public property | ToolTip | (Inherited from FrameworkElement.)
Public property | TouchesCaptured | (Inherited from UIElement.)
Public property | TouchesCapturedWithin | (Inherited from UIElement.)
Public property | TouchesDirectlyOver | (Inherited from UIElement.)
Public property | TouchesOver | (Inherited from UIElement.)
Public property | Triggers | (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from UIElement.)
Public property | UseLayoutRounding | (Inherited from FrameworkElement.)
Public property | VerticalAlignment | (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | (Inherited from UIElement.)
Protected property | VisualChildrenCount | (Inherited from FrameworkElement.)
Protected property | VisualParent | (Inherited from Visual.)
Public property | Width | (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | ContextMenuClosing | (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | (Inherited from FrameworkElement.)
Public event | DataContextChanged | (Inherited from FrameworkElement.)
Public event | DragEnter | (Inherited from UIElement.)
Public event | DragLeave | (Inherited from UIElement.)
Public event | DragOver | (Inherited from UIElement.)
Public event | Drop | (Inherited from UIElement.)
Public event | FocusableChanged | (Inherited from UIElement.)
Public event | GiveFeedback | (Inherited from UIElement.)
Public event | GotFocus | (Inherited from UIElement.)
Public event | GotKeyboardFocus | (Inherited from UIElement.)
Public event | GotMouseCapture | (Inherited from UIElement.)
Public event | GotStylusCapture | (Inherited from UIElement.)
Public event | GotTouchCapture | (Inherited from UIElement.)
Public event | Initialized | (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsVisibleChanged | (Inherited from UIElement.)
Public event | KeyDown | (Inherited from UIElement.)
Public event | KeyUp | (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from UIElement.)
Public event | Loaded | (Inherited from FrameworkElement.)
Public event | LostFocus | (Inherited from UIElement.)
Public event | LostKeyboardFocus | (Inherited from UIElement.)
Public event | LostMouseCapture | (Inherited from UIElement.)
Public event | LostStylusCapture | (Inherited from UIElement.)
Public event | LostTouchCapture | (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | ManipulationStarting | (Inherited from UIElement.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from UIElement.)
Public event | MouseEnter | (Inherited from UIElement.)
Public event | MouseLeave | (Inherited from UIElement.)
Public event | MouseLeftButtonDown | (Inherited from UIElement.)
Public event | MouseLeftButtonUp | (Inherited from UIElement.)
Public event | MouseMove | (Inherited from UIElement.)
Public event | MouseRightButtonDown | (Inherited from UIElement.)
Public event | MouseRightButtonUp | (Inherited from UIElement.)
Public event | MouseUp | (Inherited from UIElement.)
Public event | MouseWheel | (Inherited from UIElement.)
 | OnMouseClickEvent | Occurs when [on mouse click event].
Public event | PreviewDragEnter | (Inherited from UIElement.)
Public event | PreviewDragLeave | (Inherited from UIElement.)
Public event | PreviewDragOver | (Inherited from UIElement.)
Public event | PreviewDrop | (Inherited from UIElement.)
Public event | PreviewGiveFeedback | (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewKeyDown | (Inherited from UIElement.)
Public event | PreviewKeyUp | (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | (Inherited from Control.)
Public event | PreviewMouseDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseMove | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseUp | (Inherited from UIElement.)
Public event | PreviewMouseWheel | (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | (Inherited from UIElement.)
Public event | PreviewStylusDown | (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | (Inherited from UIElement.)
Public event | PreviewStylusInRange | (Inherited from UIElement.)
Public event | PreviewStylusMove | (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | (Inherited from UIElement.)
Public event | PreviewStylusUp | (Inherited from UIElement.)
Public event | PreviewTextInput | (Inherited from UIElement.)
Public event | PreviewTouchDown | (Inherited from UIElement.)
Public event | PreviewTouchMove | (Inherited from UIElement.)
Public event | PreviewTouchUp | (Inherited from UIElement.)
Public event | QueryContinueDrag | (Inherited from UIElement.)
Public event | QueryCursor | (Inherited from UIElement.)
Public event | RequestBringIntoView | (Inherited from FrameworkElement.)
Public event | SizeChanged | (Inherited from FrameworkElement.)
Public event | SourceUpdated | (Inherited from FrameworkElement.)
Public event | StylusButtonDown | (Inherited from UIElement.)
Public event | StylusButtonUp | (Inherited from UIElement.)
Public event | StylusDown | (Inherited from UIElement.)
Public event | StylusEnter | (Inherited from UIElement.)
Public event | StylusInAirMove | (Inherited from UIElement.)
Public event | StylusInRange | (Inherited from UIElement.)
Public event | StylusLeave | (Inherited from UIElement.)
Public event | StylusMove | (Inherited from UIElement.)
Public event | StylusOutOfRange | (Inherited from UIElement.)
Public event | StylusSystemGesture | (Inherited from UIElement.)
Public event | StylusUp | (Inherited from UIElement.)
Public event | TargetUpdated | (Inherited from FrameworkElement.)
Public event | TextInput | (Inherited from UIElement.)
Public event | ToolTipClosing | (Inherited from FrameworkElement.)
Public event | ToolTipOpening | (Inherited from FrameworkElement.)
Public event | TouchDown | (Inherited from UIElement.)
Public event | TouchEnter | (Inherited from UIElement.)
Public event | TouchLeave | (Inherited from UIElement.)
Public event | TouchMove | (Inherited from UIElement.)
Public event | TouchUp | (Inherited from UIElement.)
Public event | Unloaded | (Inherited from FrameworkElement.)

See Also

UserControlMiniMap Class
wManager.Wow.Forms Namespace


UserControlMiniMap Constructor

Initializes a new instance of the UserControlMiniMap class.

Namespace: wManager.Wow.Forms
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public UserControlMiniMap()
Public Sub New
public:
UserControlMiniMap()

See Also

UserControlMiniMap Class
wManager.Wow.Forms Namespace


UserControlMiniMap Fields

The UserControlMiniMap type exposes the following members.

Fields

Name Description
LandmarksMiniMap
The map and radar 3D landmarks.

Examples

C#
var miniMapLandmarkName = "MyCustomName";
var path = new List<Vector3> {new Vector3(1, 2, 3), new Vector3(4, 2, 3), new Vector3(3, 4, 3), }
UserControlMiniMap.LandmarksMiniMap.Remove(miniMapLandmarkName);
if (path.Count > 0)
     UserControlMiniMap.LandmarksMiniMap.Add(path[0], miniMapLandmarkName, Color.Orange, 10, miniMapLandmarkName, true);
foreach (var vector3 in path)
{
    UserControlMiniMap.LandmarksMiniMap.Add(vector3, miniMapLandmarkName, Color.Orange, 10, "", true);
}

See Also

UserControlMiniMap Class
wManager.Wow.Forms Namespace


LandmarksMiniMap Field

UserControlMiniMap..::..LandmarksMiniMap Field

The map and radar 3D landmarks.

Examples

C#
var miniMapLandmarkName = "MyCustomName";
var path = new List<Vector3> {new Vector3(1, 2, 3), new Vector3(4, 2, 3), new Vector3(3, 4, 3), }
UserControlMiniMap.LandmarksMiniMap.Remove(miniMapLandmarkName);
if (path.Count > 0)
     UserControlMiniMap.LandmarksMiniMap.Add(path[0], miniMapLandmarkName, Color.Orange, 10, miniMapLandmarkName, true);
foreach (var vector3 in path)
{
    UserControlMiniMap.LandmarksMiniMap.Add(vector3, miniMapLandmarkName, Color.Orange, 10, "", true);
}

Namespace: wManager.Wow.Forms
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static MiniMapGenerator..::..LandmarksMiniMap LandmarksMiniMap
Public Shared LandmarksMiniMap As MiniMapGenerator..::..LandmarksMiniMap
public:
static MiniMapGenerator..::..LandmarksMiniMap^ LandmarksMiniMap

See Also

UserControlMiniMap Class
wManager.Wow.Forms Namespace


UserControlMiniMap Methods

The UserControlMiniMap type exposes the following members.

Methods

 | Name | Description
Protected method | AddChild(System.Object) | (Inherited from ContentControl.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate,System.Boolean) | (Inherited from UIElement.)
Protected method | AddText(System.String) | (Inherited from ContentControl.)
Public method | AddToEventRoute(System.Windows.EventRoute,System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | AddVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock) | (Inherited from UIElement.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from FrameworkElement.)
Public method | Arrange(System.Windows.Rect) | (Inherited from UIElement.)
Protected method | ArrangeCore(System.Windows.Rect) | (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(System.Windows.Size) | (Inherited from Control.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline) | (Inherited from UIElement.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | BeginInit | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior,System.Boolean) | (Inherited from FrameworkElement.)
Public method | BringIntoView | (Inherited from FrameworkElement.)
Public method | BringIntoView(System.Windows.Rect) | (Inherited from FrameworkElement.)
Public method | CaptureMouse | (Inherited from UIElement.)
Public method | CaptureStylus | (Inherited from UIElement.)
Public method | CaptureTouch(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DispatcherObject.)
Public method | ClearValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | ClearValue(System.Windows.DependencyPropertyKey) | (Inherited from DependencyObject.)
Public method | CoerceValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | EndInit | (Inherited from FrameworkElement.)
Public method | Equals(System.Object) | (Inherited from DependencyObject.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindCommonVisualAncestor(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | FindName(System.String) | (Inherited from FrameworkElement.)
Public method | FindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from UIElement.)
Public method | GetAnimationBaseValue(System.Windows.DependencyProperty) | (Inherited from UIElement.)
Public method | GetBindingExpression(System.Windows.DependencyProperty) | (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from DependencyObject.)
Protected method | GetLayoutClip(System.Windows.Size) | (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | (Inherited from DependencyObject.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Protected method | GetVisualChild(System.Int32) | (Inherited from FrameworkElement.)
Protected method | HitTestCore(System.Windows.Media.PointHitTestParameters) | (Inherited from UIElement.)
Protected method | HitTestCore(System.Windows.Media.GeometryHitTestParameters) | (Inherited from UIElement.)
Public method | InputHitTest(System.Windows.Point) | (Inherited from UIElement.)
Public method | InvalidateArrange | (Inherited from UIElement.)
Public method | InvalidateMeasure | (Inherited from UIElement.)
Public method | InvalidateProperty(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | InvalidateVisual | (Inherited from UIElement.)
Public method | IsAncestorOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | IsDescendantOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | Measure(System.Windows.Size) | (Inherited from UIElement.)
Protected method | MeasureCore(System.Windows.Size) | (Inherited from FrameworkElement.)
Protected method | MeasureOverride(System.Windows.Size) | (Inherited from Control.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | MoveFocus(System.Windows.Input.TraversalRequest) | (Inherited from FrameworkElement.)
Protected method | OnAccessKey(System.Windows.Input.AccessKeyEventArgs) | (Inherited from UIElement.)
Public method | OnApplyTemplate | (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged(System.Windows.UIElement) | (Inherited from UIElement.)
Protected method | OnContentChanged(System.Object,System.Object) | (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged(System.String,System.String) | (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged(System.Windows.DataTemplate,System.Windows.DataTemplate) | (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged(System.Windows.Controls.DataTemplateSelector,System.Windows.Controls.DataTemplateSelector) | (Inherited from ContentControl.)
Protected method | OnContextMenuClosing(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | (Inherited from UserControl.)
Protected method | OnDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnGotFocus(System.Windows.RoutedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnGotMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnGotStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnGotTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnInitialized(System.EventArgs) | (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnLostFocus(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnLostStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnLostTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback(System.Windows.Input.ManipulationBoundaryFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationCompleted(System.Windows.Input.ManipulationCompletedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationDelta(System.Windows.Input.ManipulationDeltaEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting(System.Windows.Input.ManipulationInertiaStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarted(System.Windows.Input.ManipulationStartedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarting(System.Windows.Input.ManipulationStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseEnter(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeave(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnPreviewMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPropertyChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnQueryCursor(System.Windows.Input.QueryCursorEventArgs) | (Inherited from UIElement.)
Protected method | OnRender(System.Windows.Media.DrawingContext) | (Inherited from UIElement.)
Protected method | OnStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusEnter(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusLeave(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnTemplateChanged(System.Windows.Controls.ControlTemplate,System.Windows.Controls.ControlTemplate) | (Inherited from Control.)
Protected method | OnTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnToolTipClosing(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchEnter(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchLeave(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Public method | PointFromScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PointToScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PredictFocus(System.Windows.Input.FocusNavigationDirection) | (Inherited from FrameworkElement.)
Public method | RaiseEvent(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Public method | ReadLocalValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | RegisterName(System.String,System.Object) | (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | (Inherited from UIElement.)
Public method | ReleaseMouseCapture | (Inherited from UIElement.)
Public method | ReleaseStylusCapture | (Inherited from UIElement.)
Public method | ReleaseTouchCapture(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | RemoveHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Protected method | RemoveVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | SetBinding(System.Windows.DependencyProperty,System.Windows.Data.BindingBase) | (Inherited from FrameworkElement.)
Public method | SetBinding(System.Windows.DependencyProperty,System.String) | (Inherited from FrameworkElement.)
Public method | SetCurrentValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetResourceReference(System.Windows.DependencyProperty,System.Object) | (Inherited from FrameworkElement.)
Public method | SetValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetValue(System.Windows.DependencyPropertyKey,System.Object) | (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | (Inherited from UIElement.)
Public method | ShouldSerializeContent | (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | (Inherited from UIElement.)
Public method | ShouldSerializeResources | (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | (Inherited from FrameworkElement.)
Public method | ToString | (Inherited from Control.)
Public method | TransformToAncestor(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToAncestor(System.Windows.Media.Media3D.Visual3D) | (Inherited from Visual.)
Public method | TransformToDescendant(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToVisual(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TranslatePoint(System.Windows.Point,System.Windows.UIElement) | (Inherited from UIElement.)
Public method | TryFindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | UnregisterName(System.String) | (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | (Inherited from FrameworkElement.)
Public method | UpdateLayout | (Inherited from UIElement.)
Public method | VerifyAccess | (Inherited from DispatcherObject.)

See Also

UserControlMiniMap Class
wManager.Wow.Forms Namespace


UserControlMiniMap Properties

The UserControlMiniMap type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | (Inherited from FrameworkElement.)
Public property | ActualWidth | (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
Public property | AreAnyTouchesOver | (Inherited from UIElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from FrameworkElement.)
Public property | BitmapEffect | (Inherited from UIElement.)
Public property | BitmapEffectInput | (Inherited from UIElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | (Inherited from UIElement.)
Public property | ClipToBounds | (Inherited from UIElement.)
Public property | CommandBindings | (Inherited from UIElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContentTemplate | (Inherited from ContentControl.)
Public property | ContentTemplateSelector | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from FrameworkElement.)
Public property | Cursor | (Inherited from FrameworkElement.)
Public property | DataContext | (Inherited from FrameworkElement.)
Public property | DependencyObjectType | (Inherited from DependencyObject.)
Public property | DesiredSize | (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DispatcherObject.)
Public property | Effect | (Inherited from UIElement.)
Public property | FlowDirection | (Inherited from FrameworkElement.)
Public property | Focusable | (Inherited from UIElement.)
Public property | FocusVisualStyle | (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from FrameworkElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasAnimatedProperties | (Inherited from UIElement.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | InputBindings | (Inherited from UIElement.)
Public property | InputScope | (Inherited from FrameworkElement.)
Public property | IsArrangeValid | (Inherited from UIElement.)
Public property | IsEnabled | (Inherited from UIElement.)
Protected property | IsEnabledCore | (Inherited from UIElement.)
Public property | IsFocused | (Inherited from UIElement.)
Public property | IsHitTestVisible | (Inherited from UIElement.)
Public property | IsInitialized | (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | (Inherited from UIElement.)
Public property | IsKeyboardFocused | (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | (Inherited from UIElement.)
Public property | IsLoaded | (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | (Inherited from UIElement.)
Public property | IsMeasureValid | (Inherited from UIElement.)
Public property | IsMouseCaptured | (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | (Inherited from UIElement.)
Public property | IsMouseOver | (Inherited from UIElement.)
Public property | IsSealed | (Inherited from DependencyObject.)
Public property | IsStylusCaptured | (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | (Inherited from UIElement.)
Public property | IsStylusOver | (Inherited from UIElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsVisible | (Inherited from UIElement.)
Public property | Language | (Inherited from FrameworkElement.)
Public property | LayoutTransform | (Inherited from FrameworkElement.)
Public property | Margin | (Inherited from FrameworkElement.)
Public property | MaxHeight | (Inherited from FrameworkElement.)
Public property | MaxWidth | (Inherited from FrameworkElement.)
Public property | MinHeight | (Inherited from FrameworkElement.)
Public property | MinWidth | (Inherited from FrameworkElement.)
Public property | Name | (Inherited from FrameworkElement.)
Public property | Opacity | (Inherited from UIElement.)
Public property | OpacityMask | (Inherited from UIElement.)
Public property | OverridesDefaultStyle | (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from FrameworkElement.)
Public property | PersistId | (Inherited from UIElement.)
Public property | RenderSize | (Inherited from UIElement.)
Public property | RenderTransform | (Inherited from UIElement.)
Public property | RenderTransformOrigin | (Inherited from UIElement.)
Public property | Resources | (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from UIElement.)
Public property | Style | (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | (Inherited from UIElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | Tag | (Inherited from FrameworkElement.)
Public property | Template | (Inherited from Control.)
Public property | TemplatedParent | (Inherited from FrameworkElement.)
Public property | ToolTip | (Inherited from FrameworkElement.)
Public property | TouchesCaptured | (Inherited from UIElement.)
Public property | TouchesCapturedWithin | (Inherited from UIElement.)
Public property | TouchesDirectlyOver | (Inherited from UIElement.)
Public property | TouchesOver | (Inherited from UIElement.)
Public property | Triggers | (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from UIElement.)
Public property | UseLayoutRounding | (Inherited from FrameworkElement.)
Public property | VerticalAlignment | (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | (Inherited from UIElement.)
Protected property | VisualChildrenCount | (Inherited from FrameworkElement.)
Protected property | VisualParent | (Inherited from Visual.)
Public property | Width | (Inherited from FrameworkElement.)

See Also

UserControlMiniMap Class
wManager.Wow.Forms Namespace


UserControlMiniMap Events

The UserControlMiniMap type exposes the following members.

Events

 | Name | Description
Public event | ContextMenuClosing | (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | (Inherited from FrameworkElement.)
Public event | DataContextChanged | (Inherited from FrameworkElement.)
Public event | DragEnter | (Inherited from UIElement.)
Public event | DragLeave | (Inherited from UIElement.)
Public event | DragOver | (Inherited from UIElement.)
Public event | Drop | (Inherited from UIElement.)
Public event | FocusableChanged | (Inherited from UIElement.)
Public event | GiveFeedback | (Inherited from UIElement.)
Public event | GotFocus | (Inherited from UIElement.)
Public event | GotKeyboardFocus | (Inherited from UIElement.)
Public event | GotMouseCapture | (Inherited from UIElement.)
Public event | GotStylusCapture | (Inherited from UIElement.)
Public event | GotTouchCapture | (Inherited from UIElement.)
Public event | Initialized | (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsVisibleChanged | (Inherited from UIElement.)
Public event | KeyDown | (Inherited from UIElement.)
Public event | KeyUp | (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from UIElement.)
Public event | Loaded | (Inherited from FrameworkElement.)
Public event | LostFocus | (Inherited from UIElement.)
Public event | LostKeyboardFocus | (Inherited from UIElement.)
Public event | LostMouseCapture | (Inherited from UIElement.)
Public event | LostStylusCapture | (Inherited from UIElement.)
Public event | LostTouchCapture | (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | ManipulationStarting | (Inherited from UIElement.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from UIElement.)
Public event | MouseEnter | (Inherited from UIElement.)
Public event | MouseLeave | (Inherited from UIElement.)
Public event | MouseLeftButtonDown | (Inherited from UIElement.)
Public event | MouseLeftButtonUp | (Inherited from UIElement.)
Public event | MouseMove | (Inherited from UIElement.)
Public event | MouseRightButtonDown | (Inherited from UIElement.)
Public event | MouseRightButtonUp | (Inherited from UIElement.)
Public event | MouseUp | (Inherited from UIElement.)
Public event | MouseWheel | (Inherited from UIElement.)
 | OnMouseClickEvent | Occurs when [on mouse click event].
Public event | PreviewDragEnter | (Inherited from UIElement.)
Public event | PreviewDragLeave | (Inherited from UIElement.)
Public event | PreviewDragOver | (Inherited from UIElement.)
Public event | PreviewDrop | (Inherited from UIElement.)
Public event | PreviewGiveFeedback | (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewKeyDown | (Inherited from UIElement.)
Public event | PreviewKeyUp | (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | (Inherited from Control.)
Public event | PreviewMouseDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseMove | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseUp | (Inherited from UIElement.)
Public event | PreviewMouseWheel | (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | (Inherited from UIElement.)
Public event | PreviewStylusDown | (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | (Inherited from UIElement.)
Public event | PreviewStylusInRange | (Inherited from UIElement.)
Public event | PreviewStylusMove | (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | (Inherited from UIElement.)
Public event | PreviewStylusUp | (Inherited from UIElement.)
Public event | PreviewTextInput | (Inherited from UIElement.)
Public event | PreviewTouchDown | (Inherited from UIElement.)
Public event | PreviewTouchMove | (Inherited from UIElement.)
Public event | PreviewTouchUp | (Inherited from UIElement.)
Public event | QueryContinueDrag | (Inherited from UIElement.)
Public event | QueryCursor | (Inherited from UIElement.)
Public event | RequestBringIntoView | (Inherited from FrameworkElement.)
Public event | SizeChanged | (Inherited from FrameworkElement.)
Public event | SourceUpdated | (Inherited from FrameworkElement.)
Public event | StylusButtonDown | (Inherited from UIElement.)
Public event | StylusButtonUp | (Inherited from UIElement.)
Public event | StylusDown | (Inherited from UIElement.)
Public event | StylusEnter | (Inherited from UIElement.)
Public event | StylusInAirMove | (Inherited from UIElement.)
Public event | StylusInRange | (Inherited from UIElement.)
Public event | StylusLeave | (Inherited from UIElement.)
Public event | StylusMove | (Inherited from UIElement.)
Public event | StylusOutOfRange | (Inherited from UIElement.)
Public event | StylusSystemGesture | (Inherited from UIElement.)
Public event | StylusUp | (Inherited from UIElement.)
Public event | TargetUpdated | (Inherited from FrameworkElement.)
Public event | TextInput | (Inherited from UIElement.)
Public event | ToolTipClosing | (Inherited from FrameworkElement.)
Public event | ToolTipOpening | (Inherited from FrameworkElement.)
Public event | TouchDown | (Inherited from UIElement.)
Public event | TouchEnter | (Inherited from UIElement.)
Public event | TouchLeave | (Inherited from UIElement.)
Public event | TouchMove | (Inherited from UIElement.)
Public event | TouchUp | (Inherited from UIElement.)
Public event | Unloaded | (Inherited from FrameworkElement.)

See Also

UserControlMiniMap Class
wManager.Wow.Forms Namespace


OnMouseClickEvent Event

UserControlMiniMap..::..OnMouseClickEvent Event

Occurs when [on mouse click event].

Namespace: wManager.Wow.Forms
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static event UserControlMiniMap..::..OnMouseClickHandler OnMouseClickEvent
Public Shared Event OnMouseClickEvent As UserControlMiniMap..::..OnMouseClickHandler
public:
static  event UserControlMiniMap..::..OnMouseClickHandler^ OnMouseClickEvent {
    void add (UserControlMiniMap..::..OnMouseClickHandler^ value);
    void remove (UserControlMiniMap..::..OnMouseClickHandler^ value);
}

See Also

UserControlMiniMap Class
wManager.Wow.Forms Namespace


UserControlMiniMap.OnMouseClickHandler Delegate

UserControlMiniMap..::..OnMouseClickHandler Delegate

Delegate OnMouseClickHandler

Namespace: wManager.Wow.Forms
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public delegate void OnMouseClickHandler(
    Vector3 position
)
Public Delegate Sub OnMouseClickHandler ( _
    position As Vector3 _
)
public delegate void OnMouseClickHandler(
    Vector3^ position
)

Parameters

position
Type: robotManager.Helpful..::..Vector3
The position.

See Also

wManager.Wow.Forms Namespace


UserControlTabGeneralSettings Class

UserControl GeneralSettings (used tab "General settings", main configurations, for access to the full list of options use window GeneralSettings)

Namespace: wManager.Wow.Forms
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class UserControlTabGeneralSettings
Public Class UserControlTabGeneralSettings
public ref class UserControlTabGeneralSettings

Inheritance Hierarchy

Object
wManager.Wow.Forms..::..UserControlTabGeneralSettings

See Also

UserControlTabGeneralSettings Members
wManager.Wow.Forms Namespace


UserControlTabGeneralSettings Members

The UserControlTabGeneralSettings type exposes the following members.

Constructors

 | Name | Description
Public method | UserControlTabGeneralSettings | Initializes a new instance of the UserControlTabGeneralSettings class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | LoadGeneralSettings | Loads the general settings.
Protected method | MemberwiseClone | (Inherited from Object.)
 | ReloadGeneralSettings | Reloads the general settings.
Public method | ToString | (Inherited from Object.)

See Also

UserControlTabGeneralSettings Class
wManager.Wow.Forms Namespace


UserControlTabGeneralSettings Constructor

Initializes a new instance of the UserControlTabGeneralSettings class.

Namespace: wManager.Wow.Forms
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public UserControlTabGeneralSettings()
Public Sub New
public:
UserControlTabGeneralSettings()

See Also

UserControlTabGeneralSettings Class
wManager.Wow.Forms Namespace


UserControlTabGeneralSettings Methods

The UserControlTabGeneralSettings type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | LoadGeneralSettings | Loads the general settings.
Protected method | MemberwiseClone | (Inherited from Object.)
 | ReloadGeneralSettings | Reloads the general settings.
Public method | ToString | (Inherited from Object.)

See Also

UserControlTabGeneralSettings Class
wManager.Wow.Forms Namespace


LoadGeneralSettings Method

UserControlTabGeneralSettings..::..LoadGeneralSettings Method

Loads the general settings.

Namespace: wManager.Wow.Forms
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void LoadGeneralSettings()
Public Sub LoadGeneralSettings
public:
void LoadGeneralSettings()

See Also

UserControlTabGeneralSettings Class
wManager.Wow.Forms Namespace


ReloadGeneralSettings Method

UserControlTabGeneralSettings..::..ReloadGeneralSettings Method

Reloads the general settings.

Namespace: wManager.Wow.Forms
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void ReloadGeneralSettings()
Public Shared Sub ReloadGeneralSettings
public:
static void ReloadGeneralSettings()

See Also

UserControlTabGeneralSettings Class
wManager.Wow.Forms Namespace


UserControlTabInGame Class

UserControl that show in game infos (like player name, level, target, ...) (used tab "Info")

Namespace: wManager.Wow.Forms
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class UserControlTabInGame
Public Class UserControlTabInGame
public ref class UserControlTabInGame

Inheritance Hierarchy

Object
wManager.Wow.Forms..::..UserControlTabInGame

See Also

UserControlTabInGame Members
wManager.Wow.Forms Namespace


UserControlTabInGame Members

The UserControlTabInGame type exposes the following members.

Constructors

 | Name | Description
Public method | UserControlTabInGame | Initializes a new instance of the UserControlTabInGame class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | NotifyIconText | The notify icon text

See Also

UserControlTabInGame Class
wManager.Wow.Forms Namespace


UserControlTabInGame Constructor

Initializes a new instance of the UserControlTabInGame class.

Namespace: wManager.Wow.Forms
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public UserControlTabInGame()
Public Sub New
public:
UserControlTabInGame()

See Also

UserControlTabInGame Class
wManager.Wow.Forms Namespace


UserControlTabInGame Fields

The UserControlTabInGame type exposes the following members.

Fields

 | Name | Description
Public field | NotifyIconText | The notify icon text

See Also

UserControlTabInGame Class
wManager.Wow.Forms Namespace


NotifyIconText Field

UserControlTabInGame..::..NotifyIconText Field

The notify icon text

Namespace: wManager.Wow.Forms
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string NotifyIconText
Public NotifyIconText As String
public:
String^ NotifyIconText

See Also

UserControlTabInGame Class
wManager.Wow.Forms Namespace


UserControlTabInGame Methods

The UserControlTabInGame type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

UserControlTabInGame Class
wManager.Wow.Forms Namespace


UserControlTabMain Class

Main UserControl of the bot (to select product, start/stop, ..., used tab "Main")

Namespace: wManager.Wow.Forms
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class UserControlTabMain
Public Class UserControlTabMain
public ref class UserControlTabMain

Inheritance Hierarchy

Object
wManager.Wow.Forms..::..UserControlTabMain

See Also

UserControlTabMain Members
wManager.Wow.Forms Namespace


UserControlTabMain Members

The UserControlTabMain type exposes the following members.

Constructors

 | Name | Description
Public method | UserControlTabMain | Initializes a new instance of the UserControlTabMain class.

Methods

 | Name | Description
Public method | ButtonStartBotClick | Buttons the start bot click.
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | ProductSettingsGrid | The product settings grid

See Also

UserControlTabMain Class
wManager.Wow.Forms Namespace


UserControlTabMain Constructor

Initializes a new instance of the UserControlTabMain class.

Namespace: wManager.Wow.Forms
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public UserControlTabMain()
Public Sub New
public:
UserControlTabMain()

See Also

UserControlTabMain Class
wManager.Wow.Forms Namespace


UserControlTabMain Fields

The UserControlTabMain type exposes the following members.

Fields

 | Name | Description
Public field | ProductSettingsGrid | The product settings grid

See Also

UserControlTabMain Class
wManager.Wow.Forms Namespace


ProductSettingsGrid Field

UserControlTabMain..::..ProductSettingsGrid Field

The product settings grid

Namespace: wManager.Wow.Forms
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Grid ProductSettingsGrid
Public ProductSettingsGrid As Grid
public:
Grid^ ProductSettingsGrid

See Also

UserControlTabMain Class
wManager.Wow.Forms Namespace


UserControlTabMain Methods

The UserControlTabMain type exposes the following members.

Methods

 | Name | Description
Public method | ButtonStartBotClick | Buttons the start bot click.
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

UserControlTabMain Class
wManager.Wow.Forms Namespace


ButtonStartBotClick Method

UserControlTabMain..::..ButtonStartBotClick Method

Buttons the start bot click.

Namespace: wManager.Wow.Forms
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void ButtonStartBotClick(
    Object sender,
    RoutedEventArgs e
)
Public Sub ButtonStartBotClick ( _
    sender As Object, _
    e As RoutedEventArgs _
)
public:
void ButtonStartBotClick(
    Object^ sender,
    RoutedEventArgs^ e
)

Parameters

sender
Type: Object
The sender.
e
Type: RoutedEventArgs
The RoutedEventArgs instance containing the event data.

See Also

UserControlTabMain Class
wManager.Wow.Forms Namespace


UserControlTabTools Class

Class UserControlTabTools. Implements the UserControl Implements the IComponentConnector

Namespace: wManager.Wow.Forms
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class UserControlTabTools
Public Class UserControlTabTools
public ref class UserControlTabTools

Inheritance Hierarchy

Object
wManager.Wow.Forms..::..UserControlTabTools

See Also

UserControlTabTools Members
wManager.Wow.Forms Namespace
UserControl
IComponentConnector


UserControlTabTools Members

The UserControlTabTools type exposes the following members.

Constructors

 | Name | Description
Public method | UserControlTabTools | Initializes a new instance of the UserControlTabTools class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

UserControlTabTools Class
wManager.Wow.Forms Namespace


UserControlTabTools Constructor

Initializes a new instance of the UserControlTabTools class.

Namespace: wManager.Wow.Forms
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public UserControlTabTools()
Public Sub New
public:
UserControlTabTools()

See Also

UserControlTabTools Class
wManager.Wow.Forms Namespace


UserControlTabTools Methods

The UserControlTabTools type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

UserControlTabTools Class
wManager.Wow.Forms Namespace


wManager.Wow.Forms.ProfileMaker Namespace

Classes

 | Class | Description
Public class | AddTargetGuidUserControl | UserControl used by profile creators to manage list Guid
Public class | AddTargetGuidUserControl..::..MyInt128 | Class MyInt128.
Public class | AddTargetTypeUserControl | Logique d'interaction pour AddTargetUserControl.xaml
Public class | AddTargetUserControl | UserControl used by profile creators to manage list Entry
Public class | AddTargetUserControl..::..MyInt | Class MyInt.
Public class | BlacklistProfileUserControl | UserControl used by profile creators to manage list of blackspots
Public class | NpcUserControl | UserControl used by profile creators to manage list of Npc (vendor, repair, mailbox, ...)
Public class | RecordPathUserControl | UserControl used by profile creators to manage and record path


AddTargetGuidUserControl Class

UserControl used by profile creators to manage list Guid

Namespace: wManager.Wow.Forms.ProfileMaker
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class AddTargetGuidUserControl : UserControl
Public Class AddTargetGuidUserControl _
    Inherits UserControl
public ref class AddTargetGuidUserControl : public UserControl

Inheritance Hierarchy

Object
DispatcherObject
DependencyObject
Visual
UIElement
FrameworkElement
Control
ContentControl
UserControl
wManager.Wow.Forms.ProfileMaker..::..AddTargetGuidUserControl

See Also

AddTargetGuidUserControl Members
wManager.Wow.Forms.ProfileMaker Namespace


AddTargetGuidUserControl Members

The AddTargetGuidUserControl type exposes the following members.

Constructors

 | Name | Description
Public method | AddTargetGuidUserControl | Initializes a new instance of the AddTargetGuidUserControl class.

Methods

 | Name | Description
Protected method | AddChild(System.Object) | (Inherited from ContentControl.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate,System.Boolean) | (Inherited from UIElement.)
Protected method | AddText(System.String) | (Inherited from ContentControl.)
Public method | AddToEventRoute(System.Windows.EventRoute,System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | AddVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock) | (Inherited from UIElement.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from FrameworkElement.)
Public method | Arrange(System.Windows.Rect) | (Inherited from UIElement.)
Protected method | ArrangeCore(System.Windows.Rect) | (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(System.Windows.Size) | (Inherited from Control.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline) | (Inherited from UIElement.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | BeginInit | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior,System.Boolean) | (Inherited from FrameworkElement.)
Public method | BringIntoView | (Inherited from FrameworkElement.)
Public method | BringIntoView(System.Windows.Rect) | (Inherited from FrameworkElement.)
Public method | CaptureMouse | (Inherited from UIElement.)
Public method | CaptureStylus | (Inherited from UIElement.)
Public method | CaptureTouch(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DispatcherObject.)
Public method | ClearValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | ClearValue(System.Windows.DependencyPropertyKey) | (Inherited from DependencyObject.)
Public method | Close | Closes this instance.
Public method | CoerceValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | EndInit | (Inherited from FrameworkElement.)
Public method | Equals(System.Object) | (Inherited from DependencyObject.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindCommonVisualAncestor(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | FindName(System.String) | (Inherited from FrameworkElement.)
Public method | FindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from UIElement.)
Public method | GetAnimationBaseValue(System.Windows.DependencyProperty) | (Inherited from UIElement.)
Public method | GetBindingExpression(System.Windows.DependencyProperty) | (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from DependencyObject.)
Protected method | GetLayoutClip(System.Windows.Size) | (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | (Inherited from DependencyObject.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Protected method | GetVisualChild(System.Int32) | (Inherited from FrameworkElement.)
Protected method | HitTestCore(System.Windows.Media.PointHitTestParameters) | (Inherited from UIElement.)
Protected method | HitTestCore(System.Windows.Media.GeometryHitTestParameters) | (Inherited from UIElement.)
Public method | InputHitTest(System.Windows.Point) | (Inherited from UIElement.)
Public method | InvalidateArrange | (Inherited from UIElement.)
Public method | InvalidateMeasure | (Inherited from UIElement.)
Public method | InvalidateProperty(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | InvalidateVisual | (Inherited from UIElement.)
Public method | IsAncestorOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | IsDescendantOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | Measure(System.Windows.Size) | (Inherited from UIElement.)
Protected method | MeasureCore(System.Windows.Size) | (Inherited from FrameworkElement.)
Protected method | MeasureOverride(System.Windows.Size) | (Inherited from Control.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | MoveFocus(System.Windows.Input.TraversalRequest) | (Inherited from FrameworkElement.)
Protected method | OnAccessKey(System.Windows.Input.AccessKeyEventArgs) | (Inherited from UIElement.)
Public method | OnApplyTemplate | (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged(System.Windows.UIElement) | (Inherited from UIElement.)
Protected method | OnContentChanged(System.Object,System.Object) | (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged(System.String,System.String) | (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged(System.Windows.DataTemplate,System.Windows.DataTemplate) | (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged(System.Windows.Controls.DataTemplateSelector,System.Windows.Controls.DataTemplateSelector) | (Inherited from ContentControl.)
Protected method | OnContextMenuClosing(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | (Inherited from UserControl.)
Protected method | OnDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnGotFocus(System.Windows.RoutedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnGotMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnGotStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnGotTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnInitialized(System.EventArgs) | (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnLostFocus(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnLostStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnLostTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback(System.Windows.Input.ManipulationBoundaryFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationCompleted(System.Windows.Input.ManipulationCompletedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationDelta(System.Windows.Input.ManipulationDeltaEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting(System.Windows.Input.ManipulationInertiaStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarted(System.Windows.Input.ManipulationStartedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarting(System.Windows.Input.ManipulationStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseEnter(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeave(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnPreviewMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPropertyChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnQueryCursor(System.Windows.Input.QueryCursorEventArgs) | (Inherited from UIElement.)
Protected method | OnRender(System.Windows.Media.DrawingContext) | (Inherited from UIElement.)
Protected method | OnStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusEnter(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusLeave(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnTemplateChanged(System.Windows.Controls.ControlTemplate,System.Windows.Controls.ControlTemplate) | (Inherited from Control.)
Protected method | OnTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnToolTipClosing(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchEnter(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchLeave(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Public method | PointFromScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PointToScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PredictFocus(System.Windows.Input.FocusNavigationDirection) | (Inherited from FrameworkElement.)
Public method | RaiseEvent(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Public method | ReadLocalValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | RegisterName(System.String,System.Object) | (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | (Inherited from UIElement.)
Public method | ReleaseMouseCapture | (Inherited from UIElement.)
Public method | ReleaseStylusCapture | (Inherited from UIElement.)
Public method | ReleaseTouchCapture(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | RemoveHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Protected method | RemoveVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | SetBinding(System.Windows.DependencyProperty,System.Windows.Data.BindingBase) | (Inherited from FrameworkElement.)
Public method | SetBinding(System.Windows.DependencyProperty,System.String) | (Inherited from FrameworkElement.)
Public method | SetCurrentValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetResourceReference(System.Windows.DependencyProperty,System.Object) | (Inherited from FrameworkElement.)
Public method | SetValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetValue(System.Windows.DependencyPropertyKey,System.Object) | (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | (Inherited from UIElement.)
Public method | ShouldSerializeContent | (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | (Inherited from UIElement.)
Public method | ShouldSerializeResources | (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | (Inherited from FrameworkElement.)
Public method | ToString | (Inherited from Control.)
Public method | TransformToAncestor(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToAncestor(System.Windows.Media.Media3D.Visual3D) | (Inherited from Visual.)
Public method | TransformToDescendant(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToVisual(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TranslatePoint(System.Windows.Point,System.Windows.UIElement) | (Inherited from UIElement.)
Public method | TryFindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | UnregisterName(System.String) | (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | (Inherited from FrameworkElement.)
Public method | UpdateLayout | (Inherited from UIElement.)
Public method | VerifyAccess | (Inherited from DispatcherObject.)

Properties

 | Name | Description
Public property | ActualHeight | (Inherited from FrameworkElement.)
Public property | ActualWidth | (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
Public property | AreAnyTouchesOver | (Inherited from UIElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from FrameworkElement.)
Public property | BitmapEffect | (Inherited from UIElement.)
Public property | BitmapEffectInput | (Inherited from UIElement.)
Public property | BlackNpcTarget | Gets or sets the black NPC target.
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | (Inherited from UIElement.)
Public property | ClipToBounds | (Inherited from UIElement.)
Public property | CommandBindings | (Inherited from UIElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContentTemplate | (Inherited from ContentControl.)
Public property | ContentTemplateSelector | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from FrameworkElement.)
Public property | Cursor | (Inherited from FrameworkElement.)
Public property | DataContext | (Inherited from FrameworkElement.)
Public property | DependencyObjectType | (Inherited from DependencyObject.)
Public property | DesiredSize | (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DispatcherObject.)
Public property | Effect | (Inherited from UIElement.)
Public property | FlowDirection | (Inherited from FrameworkElement.)
Public property | Focusable | (Inherited from UIElement.)
Public property | FocusVisualStyle | (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from FrameworkElement.)
Public property | Foreground | (Inherited from Control.)
Public property | GuidTarget | Gets or sets the list of Guid.
Public property | HasAnimatedProperties | (Inherited from UIElement.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | InputBindings | (Inherited from UIElement.)
Public property | InputScope | (Inherited from FrameworkElement.)
Public property | IsArrangeValid | (Inherited from UIElement.)
Public property | IsEnabled | (Inherited from UIElement.)
Protected property | IsEnabledCore | (Inherited from UIElement.)
Public property | IsFocused | (Inherited from UIElement.)
Public property | IsHitTestVisible | (Inherited from UIElement.)
Public property | IsInitialized | (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | (Inherited from UIElement.)
Public property | IsKeyboardFocused | (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | (Inherited from UIElement.)
Public property | IsLoaded | (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | (Inherited from UIElement.)
Public property | IsMeasureValid | (Inherited from UIElement.)
Public property | IsMouseCaptured | (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | (Inherited from UIElement.)
Public property | IsMouseOver | (Inherited from UIElement.)
Public property | IsSealed | (Inherited from DependencyObject.)
Public property | IsStylusCaptured | (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | (Inherited from UIElement.)
Public property | IsStylusOver | (Inherited from UIElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsVisible | (Inherited from UIElement.)
Public property | Language | (Inherited from FrameworkElement.)
Public property | LayoutTransform | (Inherited from FrameworkElement.)
Public property | Margin | (Inherited from FrameworkElement.)
Public property | MaxHeight | (Inherited from FrameworkElement.)
Public property | MaxWidth | (Inherited from FrameworkElement.)
Public property | MinHeight | (Inherited from FrameworkElement.)
Public property | MinWidth | (Inherited from FrameworkElement.)
Public property | Name | (Inherited from FrameworkElement.)
Public property | Opacity | (Inherited from UIElement.)
Public property | OpacityMask | (Inherited from UIElement.)
Public property | OverridesDefaultStyle | (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from FrameworkElement.)
Public property | PersistId | (Inherited from UIElement.)
Public property | RenderSize | (Inherited from UIElement.)
Public property | RenderTransform | (Inherited from UIElement.)
Public property | RenderTransformOrigin | (Inherited from UIElement.)
Public property | Resources | (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from UIElement.)
Public property | Style | (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | (Inherited from UIElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | Tag | (Inherited from FrameworkElement.)
Public property | Template | (Inherited from Control.)
Public property | TemplatedParent | (Inherited from FrameworkElement.)
Public property | ToolTip | (Inherited from FrameworkElement.)
Public property | TouchesCaptured | (Inherited from UIElement.)
Public property | TouchesCapturedWithin | (Inherited from UIElement.)
Public property | TouchesDirectlyOver | (Inherited from UIElement.)
Public property | TouchesOver | (Inherited from UIElement.)
Public property | Triggers | (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from UIElement.)
Public property | UseLayoutRounding | (Inherited from FrameworkElement.)
Public property | VerticalAlignment | (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | (Inherited from UIElement.)
Protected property | VisualChildrenCount | (Inherited from FrameworkElement.)
Protected property | VisualParent | (Inherited from Visual.)
Public property | Width | (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | ContextMenuClosing | (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | (Inherited from FrameworkElement.)
Public event | DataContextChanged | (Inherited from FrameworkElement.)
Public event | DragEnter | (Inherited from UIElement.)
Public event | DragLeave | (Inherited from UIElement.)
Public event | DragOver | (Inherited from UIElement.)
Public event | Drop | (Inherited from UIElement.)
Public event | FocusableChanged | (Inherited from UIElement.)
Public event | GiveFeedback | (Inherited from UIElement.)
Public event | GotFocus | (Inherited from UIElement.)
Public event | GotKeyboardFocus | (Inherited from UIElement.)
Public event | GotMouseCapture | (Inherited from UIElement.)
Public event | GotStylusCapture | (Inherited from UIElement.)
Public event | GotTouchCapture | (Inherited from UIElement.)
Public event | Initialized | (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsVisibleChanged | (Inherited from UIElement.)
Public event | KeyDown | (Inherited from UIElement.)
Public event | KeyUp | (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from UIElement.)
Public event | Loaded | (Inherited from FrameworkElement.)
Public event | LostFocus | (Inherited from UIElement.)
Public event | LostKeyboardFocus | (Inherited from UIElement.)
Public event | LostMouseCapture | (Inherited from UIElement.)
Public event | LostStylusCapture | (Inherited from UIElement.)
Public event | LostTouchCapture | (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | ManipulationStarting | (Inherited from UIElement.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from UIElement.)
Public event | MouseEnter | (Inherited from UIElement.)
Public event | MouseLeave | (Inherited from UIElement.)
Public event | MouseLeftButtonDown | (Inherited from UIElement.)
Public event | MouseLeftButtonUp | (Inherited from UIElement.)
Public event | MouseMove | (Inherited from UIElement.)
Public event | MouseRightButtonDown | (Inherited from UIElement.)
Public event | MouseRightButtonUp | (Inherited from UIElement.)
Public event | MouseUp | (Inherited from UIElement.)
Public event | MouseWheel | (Inherited from UIElement.)
Public event | PreviewDragEnter | (Inherited from UIElement.)
Public event | PreviewDragLeave | (Inherited from UIElement.)
Public event | PreviewDragOver | (Inherited from UIElement.)
Public event | PreviewDrop | (Inherited from UIElement.)
Public event | PreviewGiveFeedback | (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewKeyDown | (Inherited from UIElement.)
Public event | PreviewKeyUp | (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | (Inherited from Control.)
Public event | PreviewMouseDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseMove | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseUp | (Inherited from UIElement.)
Public event | PreviewMouseWheel | (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | (Inherited from UIElement.)
Public event | PreviewStylusDown | (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | (Inherited from UIElement.)
Public event | PreviewStylusInRange | (Inherited from UIElement.)
Public event | PreviewStylusMove | (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | (Inherited from UIElement.)
Public event | PreviewStylusUp | (Inherited from UIElement.)
Public event | PreviewTextInput | (Inherited from UIElement.)
Public event | PreviewTouchDown | (Inherited from UIElement.)
Public event | PreviewTouchMove | (Inherited from UIElement.)
Public event | PreviewTouchUp | (Inherited from UIElement.)
Public event | QueryContinueDrag | (Inherited from UIElement.)
Public event | QueryCursor | (Inherited from UIElement.)
Public event | RequestBringIntoView | (Inherited from FrameworkElement.)
Public event | SizeChanged | (Inherited from FrameworkElement.)
Public event | SourceUpdated | (Inherited from FrameworkElement.)
Public event | StylusButtonDown | (Inherited from UIElement.)
Public event | StylusButtonUp | (Inherited from UIElement.)
Public event | StylusDown | (Inherited from UIElement.)
Public event | StylusEnter | (Inherited from UIElement.)
Public event | StylusInAirMove | (Inherited from UIElement.)
Public event | StylusInRange | (Inherited from UIElement.)
Public event | StylusLeave | (Inherited from UIElement.)
Public event | StylusMove | (Inherited from UIElement.)
Public event | StylusOutOfRange | (Inherited from UIElement.)
Public event | StylusSystemGesture | (Inherited from UIElement.)
Public event | StylusUp | (Inherited from UIElement.)
Public event | TargetUpdated | (Inherited from FrameworkElement.)
Public event | TextInput | (Inherited from UIElement.)
Public event | ToolTipClosing | (Inherited from FrameworkElement.)
Public event | ToolTipOpening | (Inherited from FrameworkElement.)
Public event | TouchDown | (Inherited from UIElement.)
Public event | TouchEnter | (Inherited from UIElement.)
Public event | TouchLeave | (Inherited from UIElement.)
Public event | TouchMove | (Inherited from UIElement.)
Public event | TouchUp | (Inherited from UIElement.)
Public event | Unloaded | (Inherited from FrameworkElement.)

See Also

AddTargetGuidUserControl Class
wManager.Wow.Forms.ProfileMaker Namespace


AddTargetGuidUserControl Constructor

Initializes a new instance of the AddTargetGuidUserControl class.

Namespace: wManager.Wow.Forms.ProfileMaker
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public AddTargetGuidUserControl()
Public Sub New
public:
AddTargetGuidUserControl()

See Also

AddTargetGuidUserControl Class
wManager.Wow.Forms.ProfileMaker Namespace


AddTargetGuidUserControl Methods

The AddTargetGuidUserControl type exposes the following members.

Methods

 | Name | Description
Protected method | AddChild(System.Object) | (Inherited from ContentControl.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate,System.Boolean) | (Inherited from UIElement.)
Protected method | AddText(System.String) | (Inherited from ContentControl.)
Public method | AddToEventRoute(System.Windows.EventRoute,System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | AddVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock) | (Inherited from UIElement.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from FrameworkElement.)
Public method | Arrange(System.Windows.Rect) | (Inherited from UIElement.)
Protected method | ArrangeCore(System.Windows.Rect) | (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(System.Windows.Size) | (Inherited from Control.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline) | (Inherited from UIElement.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | BeginInit | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior,System.Boolean) | (Inherited from FrameworkElement.)
Public method | BringIntoView | (Inherited from FrameworkElement.)
Public method | BringIntoView(System.Windows.Rect) | (Inherited from FrameworkElement.)
Public method | CaptureMouse | (Inherited from UIElement.)
Public method | CaptureStylus | (Inherited from UIElement.)
Public method | CaptureTouch(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DispatcherObject.)
Public method | ClearValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | ClearValue(System.Windows.DependencyPropertyKey) | (Inherited from DependencyObject.)
Public method | Close | Closes this instance.
Public method | CoerceValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | EndInit | (Inherited from FrameworkElement.)
Public method | Equals(System.Object) | (Inherited from DependencyObject.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindCommonVisualAncestor(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | FindName(System.String) | (Inherited from FrameworkElement.)
Public method | FindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from UIElement.)
Public method | GetAnimationBaseValue(System.Windows.DependencyProperty) | (Inherited from UIElement.)
Public method | GetBindingExpression(System.Windows.DependencyProperty) | (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from DependencyObject.)
Protected method | GetLayoutClip(System.Windows.Size) | (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | (Inherited from DependencyObject.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Protected method | GetVisualChild(System.Int32) | (Inherited from FrameworkElement.)
Protected method | HitTestCore(System.Windows.Media.PointHitTestParameters) | (Inherited from UIElement.)
Protected method | HitTestCore(System.Windows.Media.GeometryHitTestParameters) | (Inherited from UIElement.)
Public method | InputHitTest(System.Windows.Point) | (Inherited from UIElement.)
Public method | InvalidateArrange | (Inherited from UIElement.)
Public method | InvalidateMeasure | (Inherited from UIElement.)
Public method | InvalidateProperty(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | InvalidateVisual | (Inherited from UIElement.)
Public method | IsAncestorOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | IsDescendantOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | Measure(System.Windows.Size) | (Inherited from UIElement.)
Protected method | MeasureCore(System.Windows.Size) | (Inherited from FrameworkElement.)
Protected method | MeasureOverride(System.Windows.Size) | (Inherited from Control.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | MoveFocus(System.Windows.Input.TraversalRequest) | (Inherited from FrameworkElement.)
Protected method | OnAccessKey(System.Windows.Input.AccessKeyEventArgs) | (Inherited from UIElement.)
Public method | OnApplyTemplate | (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged(System.Windows.UIElement) | (Inherited from UIElement.)
Protected method | OnContentChanged(System.Object,System.Object) | (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged(System.String,System.String) | (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged(System.Windows.DataTemplate,System.Windows.DataTemplate) | (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged(System.Windows.Controls.DataTemplateSelector,System.Windows.Controls.DataTemplateSelector) | (Inherited from ContentControl.)
Protected method | OnContextMenuClosing(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | (Inherited from UserControl.)
Protected method | OnDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnGotFocus(System.Windows.RoutedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnGotMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnGotStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnGotTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnInitialized(System.EventArgs) | (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnLostFocus(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnLostStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnLostTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback(System.Windows.Input.ManipulationBoundaryFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationCompleted(System.Windows.Input.ManipulationCompletedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationDelta(System.Windows.Input.ManipulationDeltaEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting(System.Windows.Input.ManipulationInertiaStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarted(System.Windows.Input.ManipulationStartedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarting(System.Windows.Input.ManipulationStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseEnter(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeave(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnPreviewMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPropertyChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnQueryCursor(System.Windows.Input.QueryCursorEventArgs) | (Inherited from UIElement.)
Protected method | OnRender(System.Windows.Media.DrawingContext) | (Inherited from UIElement.)
Protected method | OnStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusEnter(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusLeave(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnTemplateChanged(System.Windows.Controls.ControlTemplate,System.Windows.Controls.ControlTemplate) | (Inherited from Control.)
Protected method | OnTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnToolTipClosing(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchEnter(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchLeave(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Public method | PointFromScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PointToScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PredictFocus(System.Windows.Input.FocusNavigationDirection) | (Inherited from FrameworkElement.)
Public method | RaiseEvent(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Public method | ReadLocalValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | RegisterName(System.String,System.Object) | (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | (Inherited from UIElement.)
Public method | ReleaseMouseCapture | (Inherited from UIElement.)
Public method | ReleaseStylusCapture | (Inherited from UIElement.)
Public method | ReleaseTouchCapture(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | RemoveHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Protected method | RemoveVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | SetBinding(System.Windows.DependencyProperty,System.Windows.Data.BindingBase) | (Inherited from FrameworkElement.)
Public method | SetBinding(System.Windows.DependencyProperty,System.String) | (Inherited from FrameworkElement.)
Public method | SetCurrentValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetResourceReference(System.Windows.DependencyProperty,System.Object) | (Inherited from FrameworkElement.)
Public method | SetValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetValue(System.Windows.DependencyPropertyKey,System.Object) | (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | (Inherited from UIElement.)
Public method | ShouldSerializeContent | (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | (Inherited from UIElement.)
Public method | ShouldSerializeResources | (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | (Inherited from FrameworkElement.)
Public method | ToString | (Inherited from Control.)
Public method | TransformToAncestor(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToAncestor(System.Windows.Media.Media3D.Visual3D) | (Inherited from Visual.)
Public method | TransformToDescendant(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToVisual(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TranslatePoint(System.Windows.Point,System.Windows.UIElement) | (Inherited from UIElement.)
Public method | TryFindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | UnregisterName(System.String) | (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | (Inherited from FrameworkElement.)
Public method | UpdateLayout | (Inherited from UIElement.)
Public method | VerifyAccess | (Inherited from DispatcherObject.)

See Also

AddTargetGuidUserControl Class
wManager.Wow.Forms.ProfileMaker Namespace


Close Method

AddTargetGuidUserControl..::..Close Method

Closes this instance.

Namespace: wManager.Wow.Forms.ProfileMaker
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Close()
Public Sub Close
public:
void Close()

See Also

AddTargetGuidUserControl Class
wManager.Wow.Forms.ProfileMaker Namespace


AddTargetGuidUserControl Properties

The AddTargetGuidUserControl type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | (Inherited from FrameworkElement.)
Public property | ActualWidth | (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
Public property | AreAnyTouchesOver | (Inherited from UIElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from FrameworkElement.)
Public property | BitmapEffect | (Inherited from UIElement.)
Public property | BitmapEffectInput | (Inherited from UIElement.)
Public property | BlackNpcTarget | Gets or sets the black NPC target.
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | (Inherited from UIElement.)
Public property | ClipToBounds | (Inherited from UIElement.)
Public property | CommandBindings | (Inherited from UIElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContentTemplate | (Inherited from ContentControl.)
Public property | ContentTemplateSelector | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from FrameworkElement.)
Public property | Cursor | (Inherited from FrameworkElement.)
Public property | DataContext | (Inherited from FrameworkElement.)
Public property | DependencyObjectType | (Inherited from DependencyObject.)
Public property | DesiredSize | (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DispatcherObject.)
Public property | Effect | (Inherited from UIElement.)
Public property | FlowDirection | (Inherited from FrameworkElement.)
Public property | Focusable | (Inherited from UIElement.)
Public property | FocusVisualStyle | (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from FrameworkElement.)
Public property | Foreground | (Inherited from Control.)
Public property | GuidTarget | Gets or sets the list of Guid.
Public property | HasAnimatedProperties | (Inherited from UIElement.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | InputBindings | (Inherited from UIElement.)
Public property | InputScope | (Inherited from FrameworkElement.)
Public property | IsArrangeValid | (Inherited from UIElement.)
Public property | IsEnabled | (Inherited from UIElement.)
Protected property | IsEnabledCore | (Inherited from UIElement.)
Public property | IsFocused | (Inherited from UIElement.)
Public property | IsHitTestVisible | (Inherited from UIElement.)
Public property | IsInitialized | (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | (Inherited from UIElement.)
Public property | IsKeyboardFocused | (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | (Inherited from UIElement.)
Public property | IsLoaded | (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | (Inherited from UIElement.)
Public property | IsMeasureValid | (Inherited from UIElement.)
Public property | IsMouseCaptured | (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | (Inherited from UIElement.)
Public property | IsMouseOver | (Inherited from UIElement.)
Public property | IsSealed | (Inherited from DependencyObject.)
Public property | IsStylusCaptured | (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | (Inherited from UIElement.)
Public property | IsStylusOver | (Inherited from UIElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsVisible | (Inherited from UIElement.)
Public property | Language | (Inherited from FrameworkElement.)
Public property | LayoutTransform | (Inherited from FrameworkElement.)
Public property | Margin | (Inherited from FrameworkElement.)
Public property | MaxHeight | (Inherited from FrameworkElement.)
Public property | MaxWidth | (Inherited from FrameworkElement.)
Public property | MinHeight | (Inherited from FrameworkElement.)
Public property | MinWidth | (Inherited from FrameworkElement.)
Public property | Name | (Inherited from FrameworkElement.)
Public property | Opacity | (Inherited from UIElement.)
Public property | OpacityMask | (Inherited from UIElement.)
Public property | OverridesDefaultStyle | (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from FrameworkElement.)
Public property | PersistId | (Inherited from UIElement.)
Public property | RenderSize | (Inherited from UIElement.)
Public property | RenderTransform | (Inherited from UIElement.)
Public property | RenderTransformOrigin | (Inherited from UIElement.)
Public property | Resources | (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from UIElement.)
Public property | Style | (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | (Inherited from UIElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | Tag | (Inherited from FrameworkElement.)
Public property | Template | (Inherited from Control.)
Public property | TemplatedParent | (Inherited from FrameworkElement.)
Public property | ToolTip | (Inherited from FrameworkElement.)
Public property | TouchesCaptured | (Inherited from UIElement.)
Public property | TouchesCapturedWithin | (Inherited from UIElement.)
Public property | TouchesDirectlyOver | (Inherited from UIElement.)
Public property | TouchesOver | (Inherited from UIElement.)
Public property | Triggers | (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from UIElement.)
Public property | UseLayoutRounding | (Inherited from FrameworkElement.)
Public property | VerticalAlignment | (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | (Inherited from UIElement.)
Protected property | VisualChildrenCount | (Inherited from FrameworkElement.)
Protected property | VisualParent | (Inherited from Visual.)
Public property | Width | (Inherited from FrameworkElement.)

See Also

AddTargetGuidUserControl Class
wManager.Wow.Forms.ProfileMaker Namespace


BlackNpcTarget Property

AddTargetGuidUserControl..::..BlackNpcTarget Property

Gets or sets the black NPC target.

Namespace: wManager.Wow.Forms.ProfileMaker
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<BlackListSerializable..::..BlackNpc> BlackNpcTarget { get; set; }
Public Property BlackNpcTarget As List(Of BlackListSerializable..::..BlackNpc)
    Get
    Set
public:
property List<BlackListSerializable..::..BlackNpc^>^ BlackNpcTarget {
    List<BlackListSerializable..::..BlackNpc^>^ get ();
    void set (List<BlackListSerializable..::..BlackNpc^>^ value);
}

Field Value

The black NPC target.

See Also

AddTargetGuidUserControl Class
wManager.Wow.Forms.ProfileMaker Namespace


GuidTarget Property

AddTargetGuidUserControl..::..GuidTarget Property

Gets or sets the list of Guid.

Namespace: wManager.Wow.Forms.ProfileMaker
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<ulong> GuidTarget { get; set; }
Public Property GuidTarget As List(Of ULong)
    Get
    Set
public:
property List<unsigned long long^>^ GuidTarget {
    List<unsigned long long^>^ get ();
    void set (List<unsigned long long^>^ value);
}

Field Value

The unique identifier target.

See Also

AddTargetGuidUserControl Class
wManager.Wow.Forms.ProfileMaker Namespace


AddTargetGuidUserControl Events

The AddTargetGuidUserControl type exposes the following members.

Events

 | Name | Description
Public event | ContextMenuClosing | (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | (Inherited from FrameworkElement.)
Public event | DataContextChanged | (Inherited from FrameworkElement.)
Public event | DragEnter | (Inherited from UIElement.)
Public event | DragLeave | (Inherited from UIElement.)
Public event | DragOver | (Inherited from UIElement.)
Public event | Drop | (Inherited from UIElement.)
Public event | FocusableChanged | (Inherited from UIElement.)
Public event | GiveFeedback | (Inherited from UIElement.)
Public event | GotFocus | (Inherited from UIElement.)
Public event | GotKeyboardFocus | (Inherited from UIElement.)
Public event | GotMouseCapture | (Inherited from UIElement.)
Public event | GotStylusCapture | (Inherited from UIElement.)
Public event | GotTouchCapture | (Inherited from UIElement.)
Public event | Initialized | (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsVisibleChanged | (Inherited from UIElement.)
Public event | KeyDown | (Inherited from UIElement.)
Public event | KeyUp | (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from UIElement.)
Public event | Loaded | (Inherited from FrameworkElement.)
Public event | LostFocus | (Inherited from UIElement.)
Public event | LostKeyboardFocus | (Inherited from UIElement.)
Public event | LostMouseCapture | (Inherited from UIElement.)
Public event | LostStylusCapture | (Inherited from UIElement.)
Public event | LostTouchCapture | (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | ManipulationStarting | (Inherited from UIElement.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from UIElement.)
Public event | MouseEnter | (Inherited from UIElement.)
Public event | MouseLeave | (Inherited from UIElement.)
Public event | MouseLeftButtonDown | (Inherited from UIElement.)
Public event | MouseLeftButtonUp | (Inherited from UIElement.)
Public event | MouseMove | (Inherited from UIElement.)
Public event | MouseRightButtonDown | (Inherited from UIElement.)
Public event | MouseRightButtonUp | (Inherited from UIElement.)
Public event | MouseUp | (Inherited from UIElement.)
Public event | MouseWheel | (Inherited from UIElement.)
Public event | PreviewDragEnter | (Inherited from UIElement.)
Public event | PreviewDragLeave | (Inherited from UIElement.)
Public event | PreviewDragOver | (Inherited from UIElement.)
Public event | PreviewDrop | (Inherited from UIElement.)
Public event | PreviewGiveFeedback | (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewKeyDown | (Inherited from UIElement.)
Public event | PreviewKeyUp | (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | (Inherited from Control.)
Public event | PreviewMouseDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseMove | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseUp | (Inherited from UIElement.)
Public event | PreviewMouseWheel | (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | (Inherited from UIElement.)
Public event | PreviewStylusDown | (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | (Inherited from UIElement.)
Public event | PreviewStylusInRange | (Inherited from UIElement.)
Public event | PreviewStylusMove | (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | (Inherited from UIElement.)
Public event | PreviewStylusUp | (Inherited from UIElement.)
Public event | PreviewTextInput | (Inherited from UIElement.)
Public event | PreviewTouchDown | (Inherited from UIElement.)
Public event | PreviewTouchMove | (Inherited from UIElement.)
Public event | PreviewTouchUp | (Inherited from UIElement.)
Public event | QueryContinueDrag | (Inherited from UIElement.)
Public event | QueryCursor | (Inherited from UIElement.)
Public event | RequestBringIntoView | (Inherited from FrameworkElement.)
Public event | SizeChanged | (Inherited from FrameworkElement.)
Public event | SourceUpdated | (Inherited from FrameworkElement.)
Public event | StylusButtonDown | (Inherited from UIElement.)
Public event | StylusButtonUp | (Inherited from UIElement.)
Public event | StylusDown | (Inherited from UIElement.)
Public event | StylusEnter | (Inherited from UIElement.)
Public event | StylusInAirMove | (Inherited from UIElement.)
Public event | StylusInRange | (Inherited from UIElement.)
Public event | StylusLeave | (Inherited from UIElement.)
Public event | StylusMove | (Inherited from UIElement.)
Public event | StylusOutOfRange | (Inherited from UIElement.)
Public event | StylusSystemGesture | (Inherited from UIElement.)
Public event | StylusUp | (Inherited from UIElement.)
Public event | TargetUpdated | (Inherited from FrameworkElement.)
Public event | TextInput | (Inherited from UIElement.)
Public event | ToolTipClosing | (Inherited from FrameworkElement.)
Public event | ToolTipOpening | (Inherited from FrameworkElement.)
Public event | TouchDown | (Inherited from UIElement.)
Public event | TouchEnter | (Inherited from UIElement.)
Public event | TouchLeave | (Inherited from UIElement.)
Public event | TouchMove | (Inherited from UIElement.)
Public event | TouchUp | (Inherited from UIElement.)
Public event | Unloaded | (Inherited from FrameworkElement.)

See Also

AddTargetGuidUserControl Class
wManager.Wow.Forms.ProfileMaker Namespace


AddTargetGuidUserControl.MyInt128 Class

AddTargetGuidUserControl..::..MyInt128 Class

Class MyInt128.

Namespace: wManager.Wow.Forms.ProfileMaker
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class MyInt128
Public Class MyInt128
public ref class MyInt128

Inheritance Hierarchy

Object
wManager.Wow.Forms.ProfileMaker..::..AddTargetGuidUserControl..::..MyInt128

See Also

AddTargetGuidUserControl..::..MyInt128 Members
wManager.Wow.Forms.ProfileMaker Namespace


AddTargetGuidUserControl.MyInt128 Members

AddTargetGuidUserControl..::..MyInt128 Members

The AddTargetGuidUserControl..::..MyInt128 type exposes the following members.

Constructors

 | Name | Description
Public method | AddTargetGuidUserControl..::..MyInt128(UInt64) | Initializes a new instance of the AddTargetGuidUserControl..::..MyInt128 class.
Public method | AddTargetGuidUserControl..::..MyInt128()()()() | Initializes a new instance of the AddTargetGuidUserControl..::..MyInt128 class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Value | Gets or sets the value.

See Also

AddTargetGuidUserControl..::..MyInt128 Class
wManager.Wow.Forms.ProfileMaker Namespace


MyInt128 Constructor

Overload List

 | Name | Description
Public method | AddTargetGuidUserControl..::..MyInt128(UInt64) | Initializes a new instance of the AddTargetGuidUserControl..::..MyInt128 class.
Public method | AddTargetGuidUserControl..::..MyInt128()()()() | Initializes a new instance of the AddTargetGuidUserControl..::..MyInt128 class.

See Also

AddTargetGuidUserControl..::..MyInt128 Class
AddTargetGuidUserControl..::..MyInt128 Members
wManager.Wow.Forms.ProfileMaker Namespace


MyInt128 Constructor (UInt64)

Initializes a new instance of the AddTargetGuidUserControl..::..MyInt128 class.

Namespace: wManager.Wow.Forms.ProfileMaker
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public MyInt128(
    ulong v
)
Public Sub New ( _
    v As ULong _
)
public:
MyInt128(
    unsigned long long^ v
)

Parameters

v
Type: UInt64
The v.

See Also

AddTargetGuidUserControl..::..MyInt128 Class
AddTargetGuidUserControl..::..MyInt128 Overload
wManager.Wow.Forms.ProfileMaker Namespace


MyInt128 Constructor

Initializes a new instance of the AddTargetGuidUserControl..::..MyInt128 class.

Namespace: wManager.Wow.Forms.ProfileMaker
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public MyInt128()
Public Sub New
public:
MyInt128()

See Also

AddTargetGuidUserControl..::..MyInt128 Class
AddTargetGuidUserControl..::..MyInt128 Overload
wManager.Wow.Forms.ProfileMaker Namespace


AddTargetGuidUserControl.MyInt128 Methods

AddTargetGuidUserControl..::..MyInt128 Methods

The AddTargetGuidUserControl..::..MyInt128 type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

AddTargetGuidUserControl..::..MyInt128 Class
wManager.Wow.Forms.ProfileMaker Namespace


AddTargetGuidUserControl.MyInt128 Properties

AddTargetGuidUserControl..::..MyInt128 Properties

The AddTargetGuidUserControl..::..MyInt128 type exposes the following members.

Properties

 | Name | Description
Public property | Value | Gets or sets the value.

See Also

AddTargetGuidUserControl..::..MyInt128 Class
wManager.Wow.Forms.ProfileMaker Namespace


Value Property

MyInt128..::..Value Property

Gets or sets the value.

Namespace: wManager.Wow.Forms.ProfileMaker
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public ulong Value { get; set; }
Public Property Value As ULong
    Get
    Set
public:
property unsigned long long^ Value {
    unsigned long long^ get ();
    void set (unsigned long long^ value);
}

Field Value

The value.

See Also

AddTargetGuidUserControl..::..MyInt128 Class
wManager.Wow.Forms.ProfileMaker Namespace


AddTargetTypeUserControl Class

Logique d'interaction pour AddTargetUserControl.xaml

Namespace: wManager.Wow.Forms.ProfileMaker
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class AddTargetTypeUserControl : UserControl
Public Class AddTargetTypeUserControl _
    Inherits UserControl
public ref class AddTargetTypeUserControl : public UserControl

Inheritance Hierarchy

Object
DispatcherObject
DependencyObject
Visual
UIElement
FrameworkElement
Control
ContentControl
UserControl
wManager.Wow.Forms.ProfileMaker..::..AddTargetTypeUserControl

See Also

AddTargetTypeUserControl Members
wManager.Wow.Forms.ProfileMaker Namespace


AddTargetTypeUserControl Members

The AddTargetTypeUserControl type exposes the following members.

Constructors

 | Name | Description
Public method | AddTargetTypeUserControl | Initializes a new instance of the AddTargetTypeUserControl class.

Methods

 | Name | Description
Protected method | AddChild(System.Object) | (Inherited from ContentControl.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate,System.Boolean) | (Inherited from UIElement.)
Protected method | AddText(System.String) | (Inherited from ContentControl.)
Public method | AddToEventRoute(System.Windows.EventRoute,System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | AddVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock) | (Inherited from UIElement.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from FrameworkElement.)
Public method | Arrange(System.Windows.Rect) | (Inherited from UIElement.)
Protected method | ArrangeCore(System.Windows.Rect) | (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(System.Windows.Size) | (Inherited from Control.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline) | (Inherited from UIElement.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | BeginInit | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior,System.Boolean) | (Inherited from FrameworkElement.)
Public method | BringIntoView | (Inherited from FrameworkElement.)
Public method | BringIntoView(System.Windows.Rect) | (Inherited from FrameworkElement.)
Public method | CaptureMouse | (Inherited from UIElement.)
Public method | CaptureStylus | (Inherited from UIElement.)
Public method | CaptureTouch(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DispatcherObject.)
Public method | ClearValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | ClearValue(System.Windows.DependencyPropertyKey) | (Inherited from DependencyObject.)
Public method | Close | Closes this instance.
Public method | CoerceValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | EndInit | (Inherited from FrameworkElement.)
Public method | Equals(System.Object) | (Inherited from DependencyObject.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindCommonVisualAncestor(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | FindName(System.String) | (Inherited from FrameworkElement.)
Public method | FindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from UIElement.)
Public method | GetAnimationBaseValue(System.Windows.DependencyProperty) | (Inherited from UIElement.)
Public method | GetBindingExpression(System.Windows.DependencyProperty) | (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from DependencyObject.)
Protected method | GetLayoutClip(System.Windows.Size) | (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | (Inherited from DependencyObject.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Protected method | GetVisualChild(System.Int32) | (Inherited from FrameworkElement.)
Protected method | HitTestCore(System.Windows.Media.PointHitTestParameters) | (Inherited from UIElement.)
Protected method | HitTestCore(System.Windows.Media.GeometryHitTestParameters) | (Inherited from UIElement.)
Public method | InputHitTest(System.Windows.Point) | (Inherited from UIElement.)
Public method | InvalidateArrange | (Inherited from UIElement.)
Public method | InvalidateMeasure | (Inherited from UIElement.)
Public method | InvalidateProperty(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | InvalidateVisual | (Inherited from UIElement.)
Public method | IsAncestorOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | IsDescendantOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | Measure(System.Windows.Size) | (Inherited from UIElement.)
Protected method | MeasureCore(System.Windows.Size) | (Inherited from FrameworkElement.)
Protected method | MeasureOverride(System.Windows.Size) | (Inherited from Control.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | MoveFocus(System.Windows.Input.TraversalRequest) | (Inherited from FrameworkElement.)
Protected method | OnAccessKey(System.Windows.Input.AccessKeyEventArgs) | (Inherited from UIElement.)
Public method | OnApplyTemplate | (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged(System.Windows.UIElement) | (Inherited from UIElement.)
Protected method | OnContentChanged(System.Object,System.Object) | (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged(System.String,System.String) | (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged(System.Windows.DataTemplate,System.Windows.DataTemplate) | (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged(System.Windows.Controls.DataTemplateSelector,System.Windows.Controls.DataTemplateSelector) | (Inherited from ContentControl.)
Protected method | OnContextMenuClosing(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | (Inherited from UserControl.)
Protected method | OnDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnGotFocus(System.Windows.RoutedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnGotMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnGotStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnGotTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnInitialized(System.EventArgs) | (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnLostFocus(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnLostStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnLostTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback(System.Windows.Input.ManipulationBoundaryFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationCompleted(System.Windows.Input.ManipulationCompletedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationDelta(System.Windows.Input.ManipulationDeltaEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting(System.Windows.Input.ManipulationInertiaStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarted(System.Windows.Input.ManipulationStartedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarting(System.Windows.Input.ManipulationStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseEnter(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeave(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnPreviewMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPropertyChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnQueryCursor(System.Windows.Input.QueryCursorEventArgs) | (Inherited from UIElement.)
Protected method | OnRender(System.Windows.Media.DrawingContext) | (Inherited from UIElement.)
Protected method | OnStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusEnter(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusLeave(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnTemplateChanged(System.Windows.Controls.ControlTemplate,System.Windows.Controls.ControlTemplate) | (Inherited from Control.)
Protected method | OnTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnToolTipClosing(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchEnter(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchLeave(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Public method | PointFromScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PointToScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PredictFocus(System.Windows.Input.FocusNavigationDirection) | (Inherited from FrameworkElement.)
Public method | RaiseEvent(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Public method | ReadLocalValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | RegisterName(System.String,System.Object) | (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | (Inherited from UIElement.)
Public method | ReleaseMouseCapture | (Inherited from UIElement.)
Public method | ReleaseStylusCapture | (Inherited from UIElement.)
Public method | ReleaseTouchCapture(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | RemoveHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Protected method | RemoveVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | SetBinding(System.Windows.DependencyProperty,System.Windows.Data.BindingBase) | (Inherited from FrameworkElement.)
Public method | SetBinding(System.Windows.DependencyProperty,System.String) | (Inherited from FrameworkElement.)
Public method | SetCurrentValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetResourceReference(System.Windows.DependencyProperty,System.Object) | (Inherited from FrameworkElement.)
Public method | SetValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetValue(System.Windows.DependencyPropertyKey,System.Object) | (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | (Inherited from UIElement.)
Public method | ShouldSerializeContent | (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | (Inherited from UIElement.)
Public method | ShouldSerializeResources | (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | (Inherited from FrameworkElement.)
Public method | ToString | (Inherited from Control.)
Public method | TransformToAncestor(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToAncestor(System.Windows.Media.Media3D.Visual3D) | (Inherited from Visual.)
Public method | TransformToDescendant(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToVisual(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TranslatePoint(System.Windows.Point,System.Windows.UIElement) | (Inherited from UIElement.)
Public method | TryFindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | UnregisterName(System.String) | (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | (Inherited from FrameworkElement.)
Public method | UpdateLayout | (Inherited from UIElement.)
Public method | VerifyAccess | (Inherited from DispatcherObject.)

Properties

 | Name | Description
Public property | ActualHeight | (Inherited from FrameworkElement.)
Public property | ActualWidth | (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
Public property | AreAnyTouchesOver | (Inherited from UIElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from FrameworkElement.)
Public property | BitmapEffect | (Inherited from UIElement.)
Public property | BitmapEffectInput | (Inherited from UIElement.)
Public property | BlackNpcTypes | Gets or sets the black NPC types.
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | (Inherited from UIElement.)
Public property | ClipToBounds | (Inherited from UIElement.)
Public property | CommandBindings | (Inherited from UIElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContentTemplate | (Inherited from ContentControl.)
Public property | ContentTemplateSelector | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from FrameworkElement.)
Public property | Cursor | (Inherited from FrameworkElement.)
Public property | DataContext | (Inherited from FrameworkElement.)
Public property | DependencyObjectType | (Inherited from DependencyObject.)
Public property | DesiredSize | (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DispatcherObject.)
Public property | Effect | (Inherited from UIElement.)
Public property | FlowDirection | (Inherited from FrameworkElement.)
Public property | Focusable | (Inherited from UIElement.)
Public property | FocusVisualStyle | (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from FrameworkElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasAnimatedProperties | (Inherited from UIElement.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | InputBindings | (Inherited from UIElement.)
Public property | InputScope | (Inherited from FrameworkElement.)
Public property | IsArrangeValid | (Inherited from UIElement.)
Public property | IsEnabled | (Inherited from UIElement.)
Protected property | IsEnabledCore | (Inherited from UIElement.)
Public property | IsFocused | (Inherited from UIElement.)
Public property | IsHitTestVisible | (Inherited from UIElement.)
Public property | IsInitialized | (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | (Inherited from UIElement.)
Public property | IsKeyboardFocused | (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | (Inherited from UIElement.)
Public property | IsLoaded | (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | (Inherited from UIElement.)
Public property | IsMeasureValid | (Inherited from UIElement.)
Public property | IsMouseCaptured | (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | (Inherited from UIElement.)
Public property | IsMouseOver | (Inherited from UIElement.)
Public property | IsSealed | (Inherited from DependencyObject.)
Public property | IsStylusCaptured | (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | (Inherited from UIElement.)
Public property | IsStylusOver | (Inherited from UIElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsVisible | (Inherited from UIElement.)
Public property | Language | (Inherited from FrameworkElement.)
Public property | LayoutTransform | (Inherited from FrameworkElement.)
Public property | Margin | (Inherited from FrameworkElement.)
Public property | MaxHeight | (Inherited from FrameworkElement.)
Public property | MaxWidth | (Inherited from FrameworkElement.)
Public property | MinHeight | (Inherited from FrameworkElement.)
Public property | MinWidth | (Inherited from FrameworkElement.)
Public property | Name | (Inherited from FrameworkElement.)
Public property | Opacity | (Inherited from UIElement.)
Public property | OpacityMask | (Inherited from UIElement.)
Public property | OverridesDefaultStyle | (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from FrameworkElement.)
Public property | PersistId | (Inherited from UIElement.)
Public property | RenderSize | (Inherited from UIElement.)
Public property | RenderTransform | (Inherited from UIElement.)
Public property | RenderTransformOrigin | (Inherited from UIElement.)
Public property | Resources | (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from UIElement.)
Public property | Style | (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | (Inherited from UIElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | Tag | (Inherited from FrameworkElement.)
Public property | Template | (Inherited from Control.)
Public property | TemplatedParent | (Inherited from FrameworkElement.)
Public property | ToolTip | (Inherited from FrameworkElement.)
Public property | TouchesCaptured | (Inherited from UIElement.)
Public property | TouchesCapturedWithin | (Inherited from UIElement.)
Public property | TouchesDirectlyOver | (Inherited from UIElement.)
Public property | TouchesOver | (Inherited from UIElement.)
Public property | Triggers | (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from UIElement.)
Public property | UseLayoutRounding | (Inherited from FrameworkElement.)
Public property | VerticalAlignment | (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | (Inherited from UIElement.)
Protected property | VisualChildrenCount | (Inherited from FrameworkElement.)
Protected property | VisualParent | (Inherited from Visual.)
Public property | Width | (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | ContextMenuClosing | (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | (Inherited from FrameworkElement.)
Public event | DataContextChanged | (Inherited from FrameworkElement.)
Public event | DragEnter | (Inherited from UIElement.)
Public event | DragLeave | (Inherited from UIElement.)
Public event | DragOver | (Inherited from UIElement.)
Public event | Drop | (Inherited from UIElement.)
Public event | FocusableChanged | (Inherited from UIElement.)
Public event | GiveFeedback | (Inherited from UIElement.)
Public event | GotFocus | (Inherited from UIElement.)
Public event | GotKeyboardFocus | (Inherited from UIElement.)
Public event | GotMouseCapture | (Inherited from UIElement.)
Public event | GotStylusCapture | (Inherited from UIElement.)
Public event | GotTouchCapture | (Inherited from UIElement.)
Public event | Initialized | (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsVisibleChanged | (Inherited from UIElement.)
Public event | KeyDown | (Inherited from UIElement.)
Public event | KeyUp | (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from UIElement.)
Public event | Loaded | (Inherited from FrameworkElement.)
Public event | LostFocus | (Inherited from UIElement.)
Public event | LostKeyboardFocus | (Inherited from UIElement.)
Public event | LostMouseCapture | (Inherited from UIElement.)
Public event | LostStylusCapture | (Inherited from UIElement.)
Public event | LostTouchCapture | (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | ManipulationStarting | (Inherited from UIElement.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from UIElement.)
Public event | MouseEnter | (Inherited from UIElement.)
Public event | MouseLeave | (Inherited from UIElement.)
Public event | MouseLeftButtonDown | (Inherited from UIElement.)
Public event | MouseLeftButtonUp | (Inherited from UIElement.)
Public event | MouseMove | (Inherited from UIElement.)
Public event | MouseRightButtonDown | (Inherited from UIElement.)
Public event | MouseRightButtonUp | (Inherited from UIElement.)
Public event | MouseUp | (Inherited from UIElement.)
Public event | MouseWheel | (Inherited from UIElement.)
Public event | PreviewDragEnter | (Inherited from UIElement.)
Public event | PreviewDragLeave | (Inherited from UIElement.)
Public event | PreviewDragOver | (Inherited from UIElement.)
Public event | PreviewDrop | (Inherited from UIElement.)
Public event | PreviewGiveFeedback | (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewKeyDown | (Inherited from UIElement.)
Public event | PreviewKeyUp | (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | (Inherited from Control.)
Public event | PreviewMouseDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseMove | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseUp | (Inherited from UIElement.)
Public event | PreviewMouseWheel | (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | (Inherited from UIElement.)
Public event | PreviewStylusDown | (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | (Inherited from UIElement.)
Public event | PreviewStylusInRange | (Inherited from UIElement.)
Public event | PreviewStylusMove | (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | (Inherited from UIElement.)
Public event | PreviewStylusUp | (Inherited from UIElement.)
Public event | PreviewTextInput | (Inherited from UIElement.)
Public event | PreviewTouchDown | (Inherited from UIElement.)
Public event | PreviewTouchMove | (Inherited from UIElement.)
Public event | PreviewTouchUp | (Inherited from UIElement.)
Public event | QueryContinueDrag | (Inherited from UIElement.)
Public event | QueryCursor | (Inherited from UIElement.)
Public event | RequestBringIntoView | (Inherited from FrameworkElement.)
Public event | SizeChanged | (Inherited from FrameworkElement.)
Public event | SourceUpdated | (Inherited from FrameworkElement.)
Public event | StylusButtonDown | (Inherited from UIElement.)
Public event | StylusButtonUp | (Inherited from UIElement.)
Public event | StylusDown | (Inherited from UIElement.)
Public event | StylusEnter | (Inherited from UIElement.)
Public event | StylusInAirMove | (Inherited from UIElement.)
Public event | StylusInRange | (Inherited from UIElement.)
Public event | StylusLeave | (Inherited from UIElement.)
Public event | StylusMove | (Inherited from UIElement.)
Public event | StylusOutOfRange | (Inherited from UIElement.)
Public event | StylusSystemGesture | (Inherited from UIElement.)
Public event | StylusUp | (Inherited from UIElement.)
Public event | TargetUpdated | (Inherited from FrameworkElement.)
Public event | TextInput | (Inherited from UIElement.)
Public event | ToolTipClosing | (Inherited from FrameworkElement.)
Public event | ToolTipOpening | (Inherited from FrameworkElement.)
Public event | TouchDown | (Inherited from UIElement.)
Public event | TouchEnter | (Inherited from UIElement.)
Public event | TouchLeave | (Inherited from UIElement.)
Public event | TouchMove | (Inherited from UIElement.)
Public event | TouchUp | (Inherited from UIElement.)
Public event | Unloaded | (Inherited from FrameworkElement.)

See Also

AddTargetTypeUserControl Class
wManager.Wow.Forms.ProfileMaker Namespace


AddTargetTypeUserControl Constructor

Initializes a new instance of the AddTargetTypeUserControl class.

Namespace: wManager.Wow.Forms.ProfileMaker
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public AddTargetTypeUserControl()
Public Sub New
public:
AddTargetTypeUserControl()

See Also

AddTargetTypeUserControl Class
wManager.Wow.Forms.ProfileMaker Namespace


AddTargetTypeUserControl Methods

The AddTargetTypeUserControl type exposes the following members.

Methods

 | Name | Description
Protected method | AddChild(System.Object) | (Inherited from ContentControl.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate,System.Boolean) | (Inherited from UIElement.)
Protected method | AddText(System.String) | (Inherited from ContentControl.)
Public method | AddToEventRoute(System.Windows.EventRoute,System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | AddVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock) | (Inherited from UIElement.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from FrameworkElement.)
Public method | Arrange(System.Windows.Rect) | (Inherited from UIElement.)
Protected method | ArrangeCore(System.Windows.Rect) | (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(System.Windows.Size) | (Inherited from Control.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline) | (Inherited from UIElement.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | BeginInit | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior,System.Boolean) | (Inherited from FrameworkElement.)
Public method | BringIntoView | (Inherited from FrameworkElement.)
Public method | BringIntoView(System.Windows.Rect) | (Inherited from FrameworkElement.)
Public method | CaptureMouse | (Inherited from UIElement.)
Public method | CaptureStylus | (Inherited from UIElement.)
Public method | CaptureTouch(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DispatcherObject.)
Public method | ClearValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | ClearValue(System.Windows.DependencyPropertyKey) | (Inherited from DependencyObject.)
Public method | Close | Closes this instance.
Public method | CoerceValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | EndInit | (Inherited from FrameworkElement.)
Public method | Equals(System.Object) | (Inherited from DependencyObject.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindCommonVisualAncestor(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | FindName(System.String) | (Inherited from FrameworkElement.)
Public method | FindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from UIElement.)
Public method | GetAnimationBaseValue(System.Windows.DependencyProperty) | (Inherited from UIElement.)
Public method | GetBindingExpression(System.Windows.DependencyProperty) | (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from DependencyObject.)
Protected method | GetLayoutClip(System.Windows.Size) | (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | (Inherited from DependencyObject.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Protected method | GetVisualChild(System.Int32) | (Inherited from FrameworkElement.)
Protected method | HitTestCore(System.Windows.Media.PointHitTestParameters) | (Inherited from UIElement.)
Protected method | HitTestCore(System.Windows.Media.GeometryHitTestParameters) | (Inherited from UIElement.)
Public method | InputHitTest(System.Windows.Point) | (Inherited from UIElement.)
Public method | InvalidateArrange | (Inherited from UIElement.)
Public method | InvalidateMeasure | (Inherited from UIElement.)
Public method | InvalidateProperty(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | InvalidateVisual | (Inherited from UIElement.)
Public method | IsAncestorOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | IsDescendantOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | Measure(System.Windows.Size) | (Inherited from UIElement.)
Protected method | MeasureCore(System.Windows.Size) | (Inherited from FrameworkElement.)
Protected method | MeasureOverride(System.Windows.Size) | (Inherited from Control.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | MoveFocus(System.Windows.Input.TraversalRequest) | (Inherited from FrameworkElement.)
Protected method | OnAccessKey(System.Windows.Input.AccessKeyEventArgs) | (Inherited from UIElement.)
Public method | OnApplyTemplate | (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged(System.Windows.UIElement) | (Inherited from UIElement.)
Protected method | OnContentChanged(System.Object,System.Object) | (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged(System.String,System.String) | (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged(System.Windows.DataTemplate,System.Windows.DataTemplate) | (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged(System.Windows.Controls.DataTemplateSelector,System.Windows.Controls.DataTemplateSelector) | (Inherited from ContentControl.)
Protected method | OnContextMenuClosing(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | (Inherited from UserControl.)
Protected method | OnDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnGotFocus(System.Windows.RoutedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnGotMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnGotStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnGotTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnInitialized(System.EventArgs) | (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnLostFocus(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnLostStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnLostTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback(System.Windows.Input.ManipulationBoundaryFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationCompleted(System.Windows.Input.ManipulationCompletedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationDelta(System.Windows.Input.ManipulationDeltaEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting(System.Windows.Input.ManipulationInertiaStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarted(System.Windows.Input.ManipulationStartedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarting(System.Windows.Input.ManipulationStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseEnter(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeave(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnPreviewMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPropertyChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnQueryCursor(System.Windows.Input.QueryCursorEventArgs) | (Inherited from UIElement.)
Protected method | OnRender(System.Windows.Media.DrawingContext) | (Inherited from UIElement.)
Protected method | OnStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusEnter(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusLeave(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnTemplateChanged(System.Windows.Controls.ControlTemplate,System.Windows.Controls.ControlTemplate) | (Inherited from Control.)
Protected method | OnTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnToolTipClosing(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchEnter(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchLeave(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Public method | PointFromScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PointToScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PredictFocus(System.Windows.Input.FocusNavigationDirection) | (Inherited from FrameworkElement.)
Public method | RaiseEvent(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Public method | ReadLocalValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | RegisterName(System.String,System.Object) | (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | (Inherited from UIElement.)
Public method | ReleaseMouseCapture | (Inherited from UIElement.)
Public method | ReleaseStylusCapture | (Inherited from UIElement.)
Public method | ReleaseTouchCapture(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | RemoveHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Protected method | RemoveVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | SetBinding(System.Windows.DependencyProperty,System.Windows.Data.BindingBase) | (Inherited from FrameworkElement.)
Public method | SetBinding(System.Windows.DependencyProperty,System.String) | (Inherited from FrameworkElement.)
Public method | SetCurrentValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetResourceReference(System.Windows.DependencyProperty,System.Object) | (Inherited from FrameworkElement.)
Public method | SetValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetValue(System.Windows.DependencyPropertyKey,System.Object) | (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | (Inherited from UIElement.)
Public method | ShouldSerializeContent | (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | (Inherited from UIElement.)
Public method | ShouldSerializeResources | (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | (Inherited from FrameworkElement.)
Public method | ToString | (Inherited from Control.)
Public method | TransformToAncestor(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToAncestor(System.Windows.Media.Media3D.Visual3D) | (Inherited from Visual.)
Public method | TransformToDescendant(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToVisual(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TranslatePoint(System.Windows.Point,System.Windows.UIElement) | (Inherited from UIElement.)
Public method | TryFindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | UnregisterName(System.String) | (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | (Inherited from FrameworkElement.)
Public method | UpdateLayout | (Inherited from UIElement.)
Public method | VerifyAccess | (Inherited from DispatcherObject.)

See Also

AddTargetTypeUserControl Class
wManager.Wow.Forms.ProfileMaker Namespace


Close Method

AddTargetTypeUserControl..::..Close Method

Closes this instance.

Namespace: wManager.Wow.Forms.ProfileMaker
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Close()
Public Sub Close
public:
void Close()

See Also

AddTargetTypeUserControl Class
wManager.Wow.Forms.ProfileMaker Namespace


AddTargetTypeUserControl Properties

The AddTargetTypeUserControl type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | (Inherited from FrameworkElement.)
Public property | ActualWidth | (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
Public property | AreAnyTouchesOver | (Inherited from UIElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from FrameworkElement.)
Public property | BitmapEffect | (Inherited from UIElement.)
Public property | BitmapEffectInput | (Inherited from UIElement.)
Public property | BlackNpcTypes | Gets or sets the black NPC types.
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | (Inherited from UIElement.)
Public property | ClipToBounds | (Inherited from UIElement.)
Public property | CommandBindings | (Inherited from UIElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContentTemplate | (Inherited from ContentControl.)
Public property | ContentTemplateSelector | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from FrameworkElement.)
Public property | Cursor | (Inherited from FrameworkElement.)
Public property | DataContext | (Inherited from FrameworkElement.)
Public property | DependencyObjectType | (Inherited from DependencyObject.)
Public property | DesiredSize | (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DispatcherObject.)
Public property | Effect | (Inherited from UIElement.)
Public property | FlowDirection | (Inherited from FrameworkElement.)
Public property | Focusable | (Inherited from UIElement.)
Public property | FocusVisualStyle | (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from FrameworkElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasAnimatedProperties | (Inherited from UIElement.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | InputBindings | (Inherited from UIElement.)
Public property | InputScope | (Inherited from FrameworkElement.)
Public property | IsArrangeValid | (Inherited from UIElement.)
Public property | IsEnabled | (Inherited from UIElement.)
Protected property | IsEnabledCore | (Inherited from UIElement.)
Public property | IsFocused | (Inherited from UIElement.)
Public property | IsHitTestVisible | (Inherited from UIElement.)
Public property | IsInitialized | (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | (Inherited from UIElement.)
Public property | IsKeyboardFocused | (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | (Inherited from UIElement.)
Public property | IsLoaded | (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | (Inherited from UIElement.)
Public property | IsMeasureValid | (Inherited from UIElement.)
Public property | IsMouseCaptured | (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | (Inherited from UIElement.)
Public property | IsMouseOver | (Inherited from UIElement.)
Public property | IsSealed | (Inherited from DependencyObject.)
Public property | IsStylusCaptured | (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | (Inherited from UIElement.)
Public property | IsStylusOver | (Inherited from UIElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsVisible | (Inherited from UIElement.)
Public property | Language | (Inherited from FrameworkElement.)
Public property | LayoutTransform | (Inherited from FrameworkElement.)
Public property | Margin | (Inherited from FrameworkElement.)
Public property | MaxHeight | (Inherited from FrameworkElement.)
Public property | MaxWidth | (Inherited from FrameworkElement.)
Public property | MinHeight | (Inherited from FrameworkElement.)
Public property | MinWidth | (Inherited from FrameworkElement.)
Public property | Name | (Inherited from FrameworkElement.)
Public property | Opacity | (Inherited from UIElement.)
Public property | OpacityMask | (Inherited from UIElement.)
Public property | OverridesDefaultStyle | (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from FrameworkElement.)
Public property | PersistId | (Inherited from UIElement.)
Public property | RenderSize | (Inherited from UIElement.)
Public property | RenderTransform | (Inherited from UIElement.)
Public property | RenderTransformOrigin | (Inherited from UIElement.)
Public property | Resources | (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from UIElement.)
Public property | Style | (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | (Inherited from UIElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | Tag | (Inherited from FrameworkElement.)
Public property | Template | (Inherited from Control.)
Public property | TemplatedParent | (Inherited from FrameworkElement.)
Public property | ToolTip | (Inherited from FrameworkElement.)
Public property | TouchesCaptured | (Inherited from UIElement.)
Public property | TouchesCapturedWithin | (Inherited from UIElement.)
Public property | TouchesDirectlyOver | (Inherited from UIElement.)
Public property | TouchesOver | (Inherited from UIElement.)
Public property | Triggers | (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from UIElement.)
Public property | UseLayoutRounding | (Inherited from FrameworkElement.)
Public property | VerticalAlignment | (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | (Inherited from UIElement.)
Protected property | VisualChildrenCount | (Inherited from FrameworkElement.)
Protected property | VisualParent | (Inherited from Visual.)
Public property | Width | (Inherited from FrameworkElement.)

See Also

AddTargetTypeUserControl Class
wManager.Wow.Forms.ProfileMaker Namespace


BlackNpcTypes Property

AddTargetTypeUserControl..::..BlackNpcTypes Property

Gets or sets the black NPC types.

Namespace: wManager.Wow.Forms.ProfileMaker
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<BlackListSerializable..::..BlackNpcType> BlackNpcTypes { get; set; }
Public Property BlackNpcTypes As List(Of BlackListSerializable..::..BlackNpcType)
    Get
    Set
public:
property List<BlackListSerializable..::..BlackNpcType^>^ BlackNpcTypes {
    List<BlackListSerializable..::..BlackNpcType^>^ get ();
    void set (List<BlackListSerializable..::..BlackNpcType^>^ value);
}

Field Value

The black NPC types.

See Also

AddTargetTypeUserControl Class
wManager.Wow.Forms.ProfileMaker Namespace


AddTargetTypeUserControl Events

The AddTargetTypeUserControl type exposes the following members.

Events

 | Name | Description
Public event | ContextMenuClosing | (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | (Inherited from FrameworkElement.)
Public event | DataContextChanged | (Inherited from FrameworkElement.)
Public event | DragEnter | (Inherited from UIElement.)
Public event | DragLeave | (Inherited from UIElement.)
Public event | DragOver | (Inherited from UIElement.)
Public event | Drop | (Inherited from UIElement.)
Public event | FocusableChanged | (Inherited from UIElement.)
Public event | GiveFeedback | (Inherited from UIElement.)
Public event | GotFocus | (Inherited from UIElement.)
Public event | GotKeyboardFocus | (Inherited from UIElement.)
Public event | GotMouseCapture | (Inherited from UIElement.)
Public event | GotStylusCapture | (Inherited from UIElement.)
Public event | GotTouchCapture | (Inherited from UIElement.)
Public event | Initialized | (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsVisibleChanged | (Inherited from UIElement.)
Public event | KeyDown | (Inherited from UIElement.)
Public event | KeyUp | (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from UIElement.)
Public event | Loaded | (Inherited from FrameworkElement.)
Public event | LostFocus | (Inherited from UIElement.)
Public event | LostKeyboardFocus | (Inherited from UIElement.)
Public event | LostMouseCapture | (Inherited from UIElement.)
Public event | LostStylusCapture | (Inherited from UIElement.)
Public event | LostTouchCapture | (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | ManipulationStarting | (Inherited from UIElement.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from UIElement.)
Public event | MouseEnter | (Inherited from UIElement.)
Public event | MouseLeave | (Inherited from UIElement.)
Public event | MouseLeftButtonDown | (Inherited from UIElement.)
Public event | MouseLeftButtonUp | (Inherited from UIElement.)
Public event | MouseMove | (Inherited from UIElement.)
Public event | MouseRightButtonDown | (Inherited from UIElement.)
Public event | MouseRightButtonUp | (Inherited from UIElement.)
Public event | MouseUp | (Inherited from UIElement.)
Public event | MouseWheel | (Inherited from UIElement.)
Public event | PreviewDragEnter | (Inherited from UIElement.)
Public event | PreviewDragLeave | (Inherited from UIElement.)
Public event | PreviewDragOver | (Inherited from UIElement.)
Public event | PreviewDrop | (Inherited from UIElement.)
Public event | PreviewGiveFeedback | (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewKeyDown | (Inherited from UIElement.)
Public event | PreviewKeyUp | (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | (Inherited from Control.)
Public event | PreviewMouseDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseMove | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseUp | (Inherited from UIElement.)
Public event | PreviewMouseWheel | (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | (Inherited from UIElement.)
Public event | PreviewStylusDown | (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | (Inherited from UIElement.)
Public event | PreviewStylusInRange | (Inherited from UIElement.)
Public event | PreviewStylusMove | (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | (Inherited from UIElement.)
Public event | PreviewStylusUp | (Inherited from UIElement.)
Public event | PreviewTextInput | (Inherited from UIElement.)
Public event | PreviewTouchDown | (Inherited from UIElement.)
Public event | PreviewTouchMove | (Inherited from UIElement.)
Public event | PreviewTouchUp | (Inherited from UIElement.)
Public event | QueryContinueDrag | (Inherited from UIElement.)
Public event | QueryCursor | (Inherited from UIElement.)
Public event | RequestBringIntoView | (Inherited from FrameworkElement.)
Public event | SizeChanged | (Inherited from FrameworkElement.)
Public event | SourceUpdated | (Inherited from FrameworkElement.)
Public event | StylusButtonDown | (Inherited from UIElement.)
Public event | StylusButtonUp | (Inherited from UIElement.)
Public event | StylusDown | (Inherited from UIElement.)
Public event | StylusEnter | (Inherited from UIElement.)
Public event | StylusInAirMove | (Inherited from UIElement.)
Public event | StylusInRange | (Inherited from UIElement.)
Public event | StylusLeave | (Inherited from UIElement.)
Public event | StylusMove | (Inherited from UIElement.)
Public event | StylusOutOfRange | (Inherited from UIElement.)
Public event | StylusSystemGesture | (Inherited from UIElement.)
Public event | StylusUp | (Inherited from UIElement.)
Public event | TargetUpdated | (Inherited from FrameworkElement.)
Public event | TextInput | (Inherited from UIElement.)
Public event | ToolTipClosing | (Inherited from FrameworkElement.)
Public event | ToolTipOpening | (Inherited from FrameworkElement.)
Public event | TouchDown | (Inherited from UIElement.)
Public event | TouchEnter | (Inherited from UIElement.)
Public event | TouchLeave | (Inherited from UIElement.)
Public event | TouchMove | (Inherited from UIElement.)
Public event | TouchUp | (Inherited from UIElement.)
Public event | Unloaded | (Inherited from FrameworkElement.)

See Also

AddTargetTypeUserControl Class
wManager.Wow.Forms.ProfileMaker Namespace


AddTargetUserControl Class

UserControl used by profile creators to manage list Entry

Namespace: wManager.Wow.Forms.ProfileMaker
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class AddTargetUserControl : UserControl
Public Class AddTargetUserControl _
    Inherits UserControl
public ref class AddTargetUserControl : public UserControl

Inheritance Hierarchy

Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
wManager.Wow.Forms.ProfileMaker..::..AddTargetUserControl

See Also

AddTargetUserControl Members
wManager.Wow.Forms.ProfileMaker Namespace


AddTargetUserControl Members

The AddTargetUserControl type exposes the following members.

Constructors

 | Name | Description
Public method | AddTargetUserControl | Initializes a new instance of the AddTargetUserControl class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from ContainerControl.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Public method | Close | Closes this instance.
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Control.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Control.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(System.Boolean) | (Inherited from ContainerControl.)
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from UserControl.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Control.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from ContainerControl.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from UserControl.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from ContainerControl.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from ScrollableControl.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from ContainerControl.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Control.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Public method | Settings | Settingses the specified is wow unit.
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Control.)
Public method | Show | (Inherited from Control.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Component.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from ContainerControl.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from UserControl.)

Properties

 | Name | Description
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | AllowDrop | (Inherited from Control.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | (Inherited from UserControl.)
Public property | AutoValidate | (Inherited from UserControl.)
Public property | BackColor | (Inherited from Control.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | (Inherited from UserControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Control.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Control.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMirrored | (Inherited from Control.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Control.)
Public property | Margin | (Inherited from Control.)
Public property | MaximumSize | (Inherited from Control.)
Public property | MinimumSize | (Inherited from Control.)
Public property | Name | (Inherited from Control.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Control.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabStop | (Inherited from Control.)
Public property | Tag | (Inherited from Control.)
Public property | TargetEntries | Gets or sets the target entries.
Public property | Text | (Inherited from UserControl.)
Public property | Top | (Inherited from Control.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowTarget | (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | (Inherited from UserControl.)
Public event | AutoValidateChanged | (Inherited from UserControl.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from UserControl.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Control.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Control.)
Public event | TabStopChanged | (Inherited from Control.)
Public event | TextChanged | (Inherited from UserControl.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

AddTargetUserControl Class
wManager.Wow.Forms.ProfileMaker Namespace


AddTargetUserControl Constructor

Initializes a new instance of the AddTargetUserControl class.

Namespace: wManager.Wow.Forms.ProfileMaker
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public AddTargetUserControl()
Public Sub New
public:
AddTargetUserControl()

See Also

AddTargetUserControl Class
wManager.Wow.Forms.ProfileMaker Namespace


AddTargetUserControl Methods

The AddTargetUserControl type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from ContainerControl.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Public method | Close | Closes this instance.
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Control.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Control.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(System.Boolean) | (Inherited from ContainerControl.)
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from UserControl.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Control.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from ContainerControl.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from UserControl.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from ContainerControl.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from ScrollableControl.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from ContainerControl.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Control.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Public method | Settings | Settingses the specified is wow unit.
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Control.)
Public method | Show | (Inherited from Control.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Component.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from ContainerControl.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from UserControl.)

See Also

AddTargetUserControl Class
wManager.Wow.Forms.ProfileMaker Namespace


Close Method

AddTargetUserControl..::..Close Method

Closes this instance.

Namespace: wManager.Wow.Forms.ProfileMaker
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Close()
Public Sub Close
public:
void Close()

See Also

AddTargetUserControl Class
wManager.Wow.Forms.ProfileMaker Namespace


Settings Method

AddTargetUserControl..::..Settings Method

Settingses the specified is wow unit.

Namespace: wManager.Wow.Forms.ProfileMaker
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Settings(
    bool isWowUnit
)
Public Sub Settings ( _
    isWowUnit As Boolean _
)
public:
void Settings(
    bool^ isWowUnit
)

Parameters

isWowUnit
Type: Boolean
if set to true to show button Add by target and Add by name.

See Also

AddTargetUserControl Class
wManager.Wow.Forms.ProfileMaker Namespace


AddTargetUserControl Properties

The AddTargetUserControl type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | AllowDrop | (Inherited from Control.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | (Inherited from UserControl.)
Public property | AutoValidate | (Inherited from UserControl.)
Public property | BackColor | (Inherited from Control.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | (Inherited from UserControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Control.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Control.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMirrored | (Inherited from Control.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Control.)
Public property | Margin | (Inherited from Control.)
Public property | MaximumSize | (Inherited from Control.)
Public property | MinimumSize | (Inherited from Control.)
Public property | Name | (Inherited from Control.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Control.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabStop | (Inherited from Control.)
Public property | Tag | (Inherited from Control.)
Public property | TargetEntries | Gets or sets the target entries.
Public property | Text | (Inherited from UserControl.)
Public property | Top | (Inherited from Control.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowTarget | (Inherited from Control.)

See Also

AddTargetUserControl Class
wManager.Wow.Forms.ProfileMaker Namespace


TargetEntries Property

AddTargetUserControl..::..TargetEntries Property

Gets or sets the target entries.

Namespace: wManager.Wow.Forms.ProfileMaker
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<int> TargetEntries { get; set; }
Public Property TargetEntries As List(Of Integer)
    Get
    Set
public:
property List<int^>^ TargetEntries {
    List<int^>^ get ();
    void set (List<int^>^ value);
}

Field Value

The target entries.

See Also

AddTargetUserControl Class
wManager.Wow.Forms.ProfileMaker Namespace


AddTargetUserControl Events

The AddTargetUserControl type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | (Inherited from UserControl.)
Public event | AutoValidateChanged | (Inherited from UserControl.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from UserControl.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Control.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Control.)
Public event | TabStopChanged | (Inherited from Control.)
Public event | TextChanged | (Inherited from UserControl.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

AddTargetUserControl Class
wManager.Wow.Forms.ProfileMaker Namespace


AddTargetUserControl.MyInt Class

AddTargetUserControl..::..MyInt Class

Class MyInt.

Namespace: wManager.Wow.Forms.ProfileMaker
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class MyInt
Public Class MyInt
public ref class MyInt

Inheritance Hierarchy

Object
wManager.Wow.Forms.ProfileMaker..::..AddTargetUserControl..::..MyInt

See Also

AddTargetUserControl..::..MyInt Members
wManager.Wow.Forms.ProfileMaker Namespace


AddTargetUserControl.MyInt Members

AddTargetUserControl..::..MyInt Members

The AddTargetUserControl..::..MyInt type exposes the following members.

Constructors

 | Name | Description
Public method | AddTargetUserControl..::..MyInt(Int32) | Initializes a new instance of the AddTargetUserControl..::..MyInt class.
Public method | AddTargetUserControl..::..MyInt()()()() | Initializes a new instance of the AddTargetUserControl..::..MyInt class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Entry | Gets or sets the entry.

See Also

AddTargetUserControl..::..MyInt Class
wManager.Wow.Forms.ProfileMaker Namespace


MyInt Constructor

Overload List

 | Name | Description
Public method | AddTargetUserControl..::..MyInt(Int32) | Initializes a new instance of the AddTargetUserControl..::..MyInt class.
Public method | AddTargetUserControl..::..MyInt()()()() | Initializes a new instance of the AddTargetUserControl..::..MyInt class.

See Also

AddTargetUserControl..::..MyInt Class
AddTargetUserControl..::..MyInt Members
wManager.Wow.Forms.ProfileMaker Namespace


MyInt Constructor (Int32)

Initializes a new instance of the AddTargetUserControl..::..MyInt class.

Namespace: wManager.Wow.Forms.ProfileMaker
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public MyInt(
    int v
)
Public Sub New ( _
    v As Integer _
)
public:
MyInt(
    int^ v
)

Parameters

v
Type: Int32
The v.

See Also

AddTargetUserControl..::..MyInt Class
AddTargetUserControl..::..MyInt Overload
wManager.Wow.Forms.ProfileMaker Namespace


MyInt Constructor

Initializes a new instance of the AddTargetUserControl..::..MyInt class.

Namespace: wManager.Wow.Forms.ProfileMaker
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public MyInt()
Public Sub New
public:
MyInt()

See Also

AddTargetUserControl..::..MyInt Class
AddTargetUserControl..::..MyInt Overload
wManager.Wow.Forms.ProfileMaker Namespace


AddTargetUserControl.MyInt Methods

AddTargetUserControl..::..MyInt Methods

The AddTargetUserControl..::..MyInt type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

AddTargetUserControl..::..MyInt Class
wManager.Wow.Forms.ProfileMaker Namespace


AddTargetUserControl.MyInt Properties

AddTargetUserControl..::..MyInt Properties

The AddTargetUserControl..::..MyInt type exposes the following members.

Properties

 | Name | Description
Public property | Entry | Gets or sets the entry.

See Also

AddTargetUserControl..::..MyInt Class
wManager.Wow.Forms.ProfileMaker Namespace


Entry Property

MyInt..::..Entry Property

Gets or sets the entry.

Namespace: wManager.Wow.Forms.ProfileMaker
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int Entry { get; set; }
Public Property Entry As Integer
    Get
    Set
public:
property int^ Entry {
    int^ get ();
    void set (int^ value);
}

Field Value

The entry.

See Also

AddTargetUserControl..::..MyInt Class
wManager.Wow.Forms.ProfileMaker Namespace


BlacklistProfileUserControl Class

UserControl used by profile creators to manage list of blackspots

Namespace: wManager.Wow.Forms.ProfileMaker
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class BlacklistProfileUserControl : UserControl
Public Class BlacklistProfileUserControl _
    Inherits UserControl
public ref class BlacklistProfileUserControl : public UserControl

Inheritance Hierarchy

Object
DispatcherObject
DependencyObject
Visual
UIElement
FrameworkElement
Control
ContentControl
UserControl
wManager.Wow.Forms.ProfileMaker..::..BlacklistProfileUserControl

See Also

BlacklistProfileUserControl Members
wManager.Wow.Forms.ProfileMaker Namespace


BlacklistProfileUserControl Members

The BlacklistProfileUserControl type exposes the following members.

Constructors

 | Name | Description
Public method | BlacklistProfileUserControl | Initializes a new instance of the BlacklistProfileUserControl class.

Methods

 | Name | Description
Protected method | AddChild(System.Object) | (Inherited from ContentControl.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate,System.Boolean) | (Inherited from UIElement.)
Protected method | AddText(System.String) | (Inherited from ContentControl.)
Public method | AddToEventRoute(System.Windows.EventRoute,System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | AddVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock) | (Inherited from UIElement.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from FrameworkElement.)
Public method | Arrange(System.Windows.Rect) | (Inherited from UIElement.)
Protected method | ArrangeCore(System.Windows.Rect) | (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(System.Windows.Size) | (Inherited from Control.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline) | (Inherited from UIElement.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | BeginInit | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior,System.Boolean) | (Inherited from FrameworkElement.)
Public method | BringIntoView | (Inherited from FrameworkElement.)
Public method | BringIntoView(System.Windows.Rect) | (Inherited from FrameworkElement.)
Public method | CaptureMouse | (Inherited from UIElement.)
Public method | CaptureStylus | (Inherited from UIElement.)
Public method | CaptureTouch(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DispatcherObject.)
Public method | ClearValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | ClearValue(System.Windows.DependencyPropertyKey) | (Inherited from DependencyObject.)
Public method | Close | Closes this instance.
Public method | CoerceValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | EndInit | (Inherited from FrameworkElement.)
Public method | Equals(System.Object) | (Inherited from DependencyObject.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindCommonVisualAncestor(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | FindName(System.String) | (Inherited from FrameworkElement.)
Public method | FindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from UIElement.)
Public method | GetAnimationBaseValue(System.Windows.DependencyProperty) | (Inherited from UIElement.)
Public method | GetBindingExpression(System.Windows.DependencyProperty) | (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from DependencyObject.)
Protected method | GetLayoutClip(System.Windows.Size) | (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | (Inherited from DependencyObject.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Protected method | GetVisualChild(System.Int32) | (Inherited from FrameworkElement.)
Protected method | HitTestCore(System.Windows.Media.PointHitTestParameters) | (Inherited from UIElement.)
Protected method | HitTestCore(System.Windows.Media.GeometryHitTestParameters) | (Inherited from UIElement.)
Public method | InputHitTest(System.Windows.Point) | (Inherited from UIElement.)
Public method | InvalidateArrange | (Inherited from UIElement.)
Public method | InvalidateMeasure | (Inherited from UIElement.)
Public method | InvalidateProperty(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | InvalidateVisual | (Inherited from UIElement.)
Public method | IsAncestorOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | IsDescendantOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | Measure(System.Windows.Size) | (Inherited from UIElement.)
Protected method | MeasureCore(System.Windows.Size) | (Inherited from FrameworkElement.)
Protected method | MeasureOverride(System.Windows.Size) | (Inherited from Control.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | MoveFocus(System.Windows.Input.TraversalRequest) | (Inherited from FrameworkElement.)
Protected method | OnAccessKey(System.Windows.Input.AccessKeyEventArgs) | (Inherited from UIElement.)
Public method | OnApplyTemplate | (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged(System.Windows.UIElement) | (Inherited from UIElement.)
Protected method | OnContentChanged(System.Object,System.Object) | (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged(System.String,System.String) | (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged(System.Windows.DataTemplate,System.Windows.DataTemplate) | (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged(System.Windows.Controls.DataTemplateSelector,System.Windows.Controls.DataTemplateSelector) | (Inherited from ContentControl.)
Protected method | OnContextMenuClosing(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | (Inherited from UserControl.)
Protected method | OnDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnGotFocus(System.Windows.RoutedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnGotMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnGotStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnGotTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnInitialized(System.EventArgs) | (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnLostFocus(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnLostStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnLostTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback(System.Windows.Input.ManipulationBoundaryFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationCompleted(System.Windows.Input.ManipulationCompletedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationDelta(System.Windows.Input.ManipulationDeltaEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting(System.Windows.Input.ManipulationInertiaStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarted(System.Windows.Input.ManipulationStartedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarting(System.Windows.Input.ManipulationStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseEnter(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeave(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnPreviewMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPropertyChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnQueryCursor(System.Windows.Input.QueryCursorEventArgs) | (Inherited from UIElement.)
Protected method | OnRender(System.Windows.Media.DrawingContext) | (Inherited from UIElement.)
Protected method | OnStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusEnter(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusLeave(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnTemplateChanged(System.Windows.Controls.ControlTemplate,System.Windows.Controls.ControlTemplate) | (Inherited from Control.)
Protected method | OnTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnToolTipClosing(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchEnter(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchLeave(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Public method | PointFromScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PointToScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PredictFocus(System.Windows.Input.FocusNavigationDirection) | (Inherited from FrameworkElement.)
Public method | RaiseEvent(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Public method | ReadLocalValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | RegisterName(System.String,System.Object) | (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | (Inherited from UIElement.)
Public method | ReleaseMouseCapture | (Inherited from UIElement.)
Public method | ReleaseStylusCapture | (Inherited from UIElement.)
Public method | ReleaseTouchCapture(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | RemoveHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Protected method | RemoveVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | SetBinding(System.Windows.DependencyProperty,System.Windows.Data.BindingBase) | (Inherited from FrameworkElement.)
Public method | SetBinding(System.Windows.DependencyProperty,System.String) | (Inherited from FrameworkElement.)
Public method | SetCurrentValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetResourceReference(System.Windows.DependencyProperty,System.Object) | (Inherited from FrameworkElement.)
Public method | SetValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetValue(System.Windows.DependencyPropertyKey,System.Object) | (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | (Inherited from UIElement.)
Public method | ShouldSerializeContent | (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | (Inherited from UIElement.)
Public method | ShouldSerializeResources | (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | (Inherited from FrameworkElement.)
Public method | ToString | (Inherited from Control.)
Public method | TransformToAncestor(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToAncestor(System.Windows.Media.Media3D.Visual3D) | (Inherited from Visual.)
Public method | TransformToDescendant(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToVisual(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TranslatePoint(System.Windows.Point,System.Windows.UIElement) | (Inherited from UIElement.)
Public method | TryFindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | UnregisterName(System.String) | (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | (Inherited from FrameworkElement.)
Public method | UpdateLayout | (Inherited from UIElement.)
Public method | VerifyAccess | (Inherited from DispatcherObject.)

Properties

 | Name | Description
Public property | ActualHeight | (Inherited from FrameworkElement.)
Public property | ActualWidth | (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
Public property | AreAnyTouchesOver | (Inherited from UIElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from FrameworkElement.)
Public property | BitmapEffect | (Inherited from UIElement.)
Public property | BitmapEffectInput | (Inherited from UIElement.)
Public property | Blacklist | Gets or sets the blacklist.
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | (Inherited from UIElement.)
Public property | ClipToBounds | (Inherited from UIElement.)
Public property | CommandBindings | (Inherited from UIElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContentTemplate | (Inherited from ContentControl.)
Public property | ContentTemplateSelector | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from FrameworkElement.)
Public property | Cursor | (Inherited from FrameworkElement.)
Public property | DataContext | (Inherited from FrameworkElement.)
Public property | DependencyObjectType | (Inherited from DependencyObject.)
Public property | DesiredSize | (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DispatcherObject.)
Public property | Effect | (Inherited from UIElement.)
Public property | FlowDirection | (Inherited from FrameworkElement.)
Public property | Focusable | (Inherited from UIElement.)
Public property | FocusVisualStyle | (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from FrameworkElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasAnimatedProperties | (Inherited from UIElement.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | InputBindings | (Inherited from UIElement.)
Public property | InputScope | (Inherited from FrameworkElement.)
Public property | IsArrangeValid | (Inherited from UIElement.)
Public property | IsEnabled | (Inherited from UIElement.)
Protected property | IsEnabledCore | (Inherited from UIElement.)
Public property | IsFocused | (Inherited from UIElement.)
Public property | IsHitTestVisible | (Inherited from UIElement.)
Public property | IsInitialized | (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | (Inherited from UIElement.)
Public property | IsKeyboardFocused | (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | (Inherited from UIElement.)
Public property | IsLoaded | (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | (Inherited from UIElement.)
Public property | IsMeasureValid | (Inherited from UIElement.)
Public property | IsMouseCaptured | (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | (Inherited from UIElement.)
Public property | IsMouseOver | (Inherited from UIElement.)
Public property | IsSealed | (Inherited from DependencyObject.)
Public property | IsStylusCaptured | (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | (Inherited from UIElement.)
Public property | IsStylusOver | (Inherited from UIElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsVisible | (Inherited from UIElement.)
Public property | Language | (Inherited from FrameworkElement.)
Public property | LayoutTransform | (Inherited from FrameworkElement.)
Public property | Margin | (Inherited from FrameworkElement.)
Public property | MaxHeight | (Inherited from FrameworkElement.)
Public property | MaxWidth | (Inherited from FrameworkElement.)
Public property | MinHeight | (Inherited from FrameworkElement.)
Public property | MinWidth | (Inherited from FrameworkElement.)
Public property | Name | (Inherited from FrameworkElement.)
Public property | Opacity | (Inherited from UIElement.)
Public property | OpacityMask | (Inherited from UIElement.)
Public property | OverridesDefaultStyle | (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from FrameworkElement.)
Public property | PersistId | (Inherited from UIElement.)
Public property | RenderSize | (Inherited from UIElement.)
Public property | RenderTransform | (Inherited from UIElement.)
Public property | RenderTransformOrigin | (Inherited from UIElement.)
Public property | Resources | (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from UIElement.)
Public property | Style | (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | (Inherited from UIElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | Tag | (Inherited from FrameworkElement.)
Public property | Template | (Inherited from Control.)
Public property | TemplatedParent | (Inherited from FrameworkElement.)
Public property | ToolTip | (Inherited from FrameworkElement.)
Public property | TouchesCaptured | (Inherited from UIElement.)
Public property | TouchesCapturedWithin | (Inherited from UIElement.)
Public property | TouchesDirectlyOver | (Inherited from UIElement.)
Public property | TouchesOver | (Inherited from UIElement.)
Public property | Triggers | (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from UIElement.)
Public property | UseLayoutRounding | (Inherited from FrameworkElement.)
Public property | VerticalAlignment | (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | (Inherited from UIElement.)
Protected property | VisualChildrenCount | (Inherited from FrameworkElement.)
Protected property | VisualParent | (Inherited from Visual.)
Public property | Width | (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | ContextMenuClosing | (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | (Inherited from FrameworkElement.)
Public event | DataContextChanged | (Inherited from FrameworkElement.)
Public event | DragEnter | (Inherited from UIElement.)
Public event | DragLeave | (Inherited from UIElement.)
Public event | DragOver | (Inherited from UIElement.)
Public event | Drop | (Inherited from UIElement.)
Public event | FocusableChanged | (Inherited from UIElement.)
Public event | GiveFeedback | (Inherited from UIElement.)
Public event | GotFocus | (Inherited from UIElement.)
Public event | GotKeyboardFocus | (Inherited from UIElement.)
Public event | GotMouseCapture | (Inherited from UIElement.)
Public event | GotStylusCapture | (Inherited from UIElement.)
Public event | GotTouchCapture | (Inherited from UIElement.)
Public event | Initialized | (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsVisibleChanged | (Inherited from UIElement.)
Public event | KeyDown | (Inherited from UIElement.)
Public event | KeyUp | (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from UIElement.)
Public event | Loaded | (Inherited from FrameworkElement.)
Public event | LostFocus | (Inherited from UIElement.)
Public event | LostKeyboardFocus | (Inherited from UIElement.)
Public event | LostMouseCapture | (Inherited from UIElement.)
Public event | LostStylusCapture | (Inherited from UIElement.)
Public event | LostTouchCapture | (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | ManipulationStarting | (Inherited from UIElement.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from UIElement.)
Public event | MouseEnter | (Inherited from UIElement.)
Public event | MouseLeave | (Inherited from UIElement.)
Public event | MouseLeftButtonDown | (Inherited from UIElement.)
Public event | MouseLeftButtonUp | (Inherited from UIElement.)
Public event | MouseMove | (Inherited from UIElement.)
Public event | MouseRightButtonDown | (Inherited from UIElement.)
Public event | MouseRightButtonUp | (Inherited from UIElement.)
Public event | MouseUp | (Inherited from UIElement.)
Public event | MouseWheel | (Inherited from UIElement.)
Public event | PreviewDragEnter | (Inherited from UIElement.)
Public event | PreviewDragLeave | (Inherited from UIElement.)
Public event | PreviewDragOver | (Inherited from UIElement.)
Public event | PreviewDrop | (Inherited from UIElement.)
Public event | PreviewGiveFeedback | (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewKeyDown | (Inherited from UIElement.)
Public event | PreviewKeyUp | (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | (Inherited from Control.)
Public event | PreviewMouseDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseMove | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseUp | (Inherited from UIElement.)
Public event | PreviewMouseWheel | (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | (Inherited from UIElement.)
Public event | PreviewStylusDown | (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | (Inherited from UIElement.)
Public event | PreviewStylusInRange | (Inherited from UIElement.)
Public event | PreviewStylusMove | (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | (Inherited from UIElement.)
Public event | PreviewStylusUp | (Inherited from UIElement.)
Public event | PreviewTextInput | (Inherited from UIElement.)
Public event | PreviewTouchDown | (Inherited from UIElement.)
Public event | PreviewTouchMove | (Inherited from UIElement.)
Public event | PreviewTouchUp | (Inherited from UIElement.)
Public event | QueryContinueDrag | (Inherited from UIElement.)
Public event | QueryCursor | (Inherited from UIElement.)
Public event | RequestBringIntoView | (Inherited from FrameworkElement.)
Public event | SizeChanged | (Inherited from FrameworkElement.)
Public event | SourceUpdated | (Inherited from FrameworkElement.)
Public event | StylusButtonDown | (Inherited from UIElement.)
Public event | StylusButtonUp | (Inherited from UIElement.)
Public event | StylusDown | (Inherited from UIElement.)
Public event | StylusEnter | (Inherited from UIElement.)
Public event | StylusInAirMove | (Inherited from UIElement.)
Public event | StylusInRange | (Inherited from UIElement.)
Public event | StylusLeave | (Inherited from UIElement.)
Public event | StylusMove | (Inherited from UIElement.)
Public event | StylusOutOfRange | (Inherited from UIElement.)
Public event | StylusSystemGesture | (Inherited from UIElement.)
Public event | StylusUp | (Inherited from UIElement.)
Public event | TargetUpdated | (Inherited from FrameworkElement.)
Public event | TextInput | (Inherited from UIElement.)
Public event | ToolTipClosing | (Inherited from FrameworkElement.)
Public event | ToolTipOpening | (Inherited from FrameworkElement.)
Public event | TouchDown | (Inherited from UIElement.)
Public event | TouchEnter | (Inherited from UIElement.)
Public event | TouchLeave | (Inherited from UIElement.)
Public event | TouchMove | (Inherited from UIElement.)
Public event | TouchUp | (Inherited from UIElement.)
Public event | Unloaded | (Inherited from FrameworkElement.)

See Also

BlacklistProfileUserControl Class
wManager.Wow.Forms.ProfileMaker Namespace


BlacklistProfileUserControl Constructor

Initializes a new instance of the BlacklistProfileUserControl class.

Namespace: wManager.Wow.Forms.ProfileMaker
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public BlacklistProfileUserControl()
Public Sub New
public:
BlacklistProfileUserControl()

See Also

BlacklistProfileUserControl Class
wManager.Wow.Forms.ProfileMaker Namespace


BlacklistProfileUserControl Methods

The BlacklistProfileUserControl type exposes the following members.

Methods

 | Name | Description
Protected method | AddChild(System.Object) | (Inherited from ContentControl.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate,System.Boolean) | (Inherited from UIElement.)
Protected method | AddText(System.String) | (Inherited from ContentControl.)
Public method | AddToEventRoute(System.Windows.EventRoute,System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | AddVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock) | (Inherited from UIElement.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from FrameworkElement.)
Public method | Arrange(System.Windows.Rect) | (Inherited from UIElement.)
Protected method | ArrangeCore(System.Windows.Rect) | (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(System.Windows.Size) | (Inherited from Control.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline) | (Inherited from UIElement.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | BeginInit | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior,System.Boolean) | (Inherited from FrameworkElement.)
Public method | BringIntoView | (Inherited from FrameworkElement.)
Public method | BringIntoView(System.Windows.Rect) | (Inherited from FrameworkElement.)
Public method | CaptureMouse | (Inherited from UIElement.)
Public method | CaptureStylus | (Inherited from UIElement.)
Public method | CaptureTouch(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DispatcherObject.)
Public method | ClearValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | ClearValue(System.Windows.DependencyPropertyKey) | (Inherited from DependencyObject.)
Public method | Close | Closes this instance.
Public method | CoerceValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | EndInit | (Inherited from FrameworkElement.)
Public method | Equals(System.Object) | (Inherited from DependencyObject.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindCommonVisualAncestor(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | FindName(System.String) | (Inherited from FrameworkElement.)
Public method | FindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from UIElement.)
Public method | GetAnimationBaseValue(System.Windows.DependencyProperty) | (Inherited from UIElement.)
Public method | GetBindingExpression(System.Windows.DependencyProperty) | (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from DependencyObject.)
Protected method | GetLayoutClip(System.Windows.Size) | (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | (Inherited from DependencyObject.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Protected method | GetVisualChild(System.Int32) | (Inherited from FrameworkElement.)
Protected method | HitTestCore(System.Windows.Media.PointHitTestParameters) | (Inherited from UIElement.)
Protected method | HitTestCore(System.Windows.Media.GeometryHitTestParameters) | (Inherited from UIElement.)
Public method | InputHitTest(System.Windows.Point) | (Inherited from UIElement.)
Public method | InvalidateArrange | (Inherited from UIElement.)
Public method | InvalidateMeasure | (Inherited from UIElement.)
Public method | InvalidateProperty(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | InvalidateVisual | (Inherited from UIElement.)
Public method | IsAncestorOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | IsDescendantOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | Measure(System.Windows.Size) | (Inherited from UIElement.)
Protected method | MeasureCore(System.Windows.Size) | (Inherited from FrameworkElement.)
Protected method | MeasureOverride(System.Windows.Size) | (Inherited from Control.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | MoveFocus(System.Windows.Input.TraversalRequest) | (Inherited from FrameworkElement.)
Protected method | OnAccessKey(System.Windows.Input.AccessKeyEventArgs) | (Inherited from UIElement.)
Public method | OnApplyTemplate | (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged(System.Windows.UIElement) | (Inherited from UIElement.)
Protected method | OnContentChanged(System.Object,System.Object) | (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged(System.String,System.String) | (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged(System.Windows.DataTemplate,System.Windows.DataTemplate) | (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged(System.Windows.Controls.DataTemplateSelector,System.Windows.Controls.DataTemplateSelector) | (Inherited from ContentControl.)
Protected method | OnContextMenuClosing(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | (Inherited from UserControl.)
Protected method | OnDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnGotFocus(System.Windows.RoutedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnGotMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnGotStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnGotTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnInitialized(System.EventArgs) | (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnLostFocus(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnLostStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnLostTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback(System.Windows.Input.ManipulationBoundaryFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationCompleted(System.Windows.Input.ManipulationCompletedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationDelta(System.Windows.Input.ManipulationDeltaEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting(System.Windows.Input.ManipulationInertiaStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarted(System.Windows.Input.ManipulationStartedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarting(System.Windows.Input.ManipulationStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseEnter(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeave(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnPreviewMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPropertyChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnQueryCursor(System.Windows.Input.QueryCursorEventArgs) | (Inherited from UIElement.)
Protected method | OnRender(System.Windows.Media.DrawingContext) | (Inherited from UIElement.)
Protected method | OnStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusEnter(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusLeave(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnTemplateChanged(System.Windows.Controls.ControlTemplate,System.Windows.Controls.ControlTemplate) | (Inherited from Control.)
Protected method | OnTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnToolTipClosing(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchEnter(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchLeave(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Public method | PointFromScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PointToScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PredictFocus(System.Windows.Input.FocusNavigationDirection) | (Inherited from FrameworkElement.)
Public method | RaiseEvent(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Public method | ReadLocalValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | RegisterName(System.String,System.Object) | (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | (Inherited from UIElement.)
Public method | ReleaseMouseCapture | (Inherited from UIElement.)
Public method | ReleaseStylusCapture | (Inherited from UIElement.)
Public method | ReleaseTouchCapture(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | RemoveHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Protected method | RemoveVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | SetBinding(System.Windows.DependencyProperty,System.Windows.Data.BindingBase) | (Inherited from FrameworkElement.)
Public method | SetBinding(System.Windows.DependencyProperty,System.String) | (Inherited from FrameworkElement.)
Public method | SetCurrentValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetResourceReference(System.Windows.DependencyProperty,System.Object) | (Inherited from FrameworkElement.)
Public method | SetValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetValue(System.Windows.DependencyPropertyKey,System.Object) | (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | (Inherited from UIElement.)
Public method | ShouldSerializeContent | (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | (Inherited from UIElement.)
Public method | ShouldSerializeResources | (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | (Inherited from FrameworkElement.)
Public method | ToString | (Inherited from Control.)
Public method | TransformToAncestor(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToAncestor(System.Windows.Media.Media3D.Visual3D) | (Inherited from Visual.)
Public method | TransformToDescendant(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToVisual(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TranslatePoint(System.Windows.Point,System.Windows.UIElement) | (Inherited from UIElement.)
Public method | TryFindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | UnregisterName(System.String) | (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | (Inherited from FrameworkElement.)
Public method | UpdateLayout | (Inherited from UIElement.)
Public method | VerifyAccess | (Inherited from DispatcherObject.)

See Also

BlacklistProfileUserControl Class
wManager.Wow.Forms.ProfileMaker Namespace


Close Method

BlacklistProfileUserControl..::..Close Method

Closes this instance.

Namespace: wManager.Wow.Forms.ProfileMaker
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Close()
Public Sub Close
public:
void Close()

See Also

BlacklistProfileUserControl Class
wManager.Wow.Forms.ProfileMaker Namespace


BlacklistProfileUserControl Properties

The BlacklistProfileUserControl type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | (Inherited from FrameworkElement.)
Public property | ActualWidth | (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
Public property | AreAnyTouchesOver | (Inherited from UIElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from FrameworkElement.)
Public property | BitmapEffect | (Inherited from UIElement.)
Public property | BitmapEffectInput | (Inherited from UIElement.)
Public property | Blacklist | Gets or sets the blacklist.
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | (Inherited from UIElement.)
Public property | ClipToBounds | (Inherited from UIElement.)
Public property | CommandBindings | (Inherited from UIElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContentTemplate | (Inherited from ContentControl.)
Public property | ContentTemplateSelector | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from FrameworkElement.)
Public property | Cursor | (Inherited from FrameworkElement.)
Public property | DataContext | (Inherited from FrameworkElement.)
Public property | DependencyObjectType | (Inherited from DependencyObject.)
Public property | DesiredSize | (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DispatcherObject.)
Public property | Effect | (Inherited from UIElement.)
Public property | FlowDirection | (Inherited from FrameworkElement.)
Public property | Focusable | (Inherited from UIElement.)
Public property | FocusVisualStyle | (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from FrameworkElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasAnimatedProperties | (Inherited from UIElement.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | InputBindings | (Inherited from UIElement.)
Public property | InputScope | (Inherited from FrameworkElement.)
Public property | IsArrangeValid | (Inherited from UIElement.)
Public property | IsEnabled | (Inherited from UIElement.)
Protected property | IsEnabledCore | (Inherited from UIElement.)
Public property | IsFocused | (Inherited from UIElement.)
Public property | IsHitTestVisible | (Inherited from UIElement.)
Public property | IsInitialized | (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | (Inherited from UIElement.)
Public property | IsKeyboardFocused | (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | (Inherited from UIElement.)
Public property | IsLoaded | (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | (Inherited from UIElement.)
Public property | IsMeasureValid | (Inherited from UIElement.)
Public property | IsMouseCaptured | (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | (Inherited from UIElement.)
Public property | IsMouseOver | (Inherited from UIElement.)
Public property | IsSealed | (Inherited from DependencyObject.)
Public property | IsStylusCaptured | (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | (Inherited from UIElement.)
Public property | IsStylusOver | (Inherited from UIElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsVisible | (Inherited from UIElement.)
Public property | Language | (Inherited from FrameworkElement.)
Public property | LayoutTransform | (Inherited from FrameworkElement.)
Public property | Margin | (Inherited from FrameworkElement.)
Public property | MaxHeight | (Inherited from FrameworkElement.)
Public property | MaxWidth | (Inherited from FrameworkElement.)
Public property | MinHeight | (Inherited from FrameworkElement.)
Public property | MinWidth | (Inherited from FrameworkElement.)
Public property | Name | (Inherited from FrameworkElement.)
Public property | Opacity | (Inherited from UIElement.)
Public property | OpacityMask | (Inherited from UIElement.)
Public property | OverridesDefaultStyle | (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from FrameworkElement.)
Public property | PersistId | (Inherited from UIElement.)
Public property | RenderSize | (Inherited from UIElement.)
Public property | RenderTransform | (Inherited from UIElement.)
Public property | RenderTransformOrigin | (Inherited from UIElement.)
Public property | Resources | (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from UIElement.)
Public property | Style | (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | (Inherited from UIElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | Tag | (Inherited from FrameworkElement.)
Public property | Template | (Inherited from Control.)
Public property | TemplatedParent | (Inherited from FrameworkElement.)
Public property | ToolTip | (Inherited from FrameworkElement.)
Public property | TouchesCaptured | (Inherited from UIElement.)
Public property | TouchesCapturedWithin | (Inherited from UIElement.)
Public property | TouchesDirectlyOver | (Inherited from UIElement.)
Public property | TouchesOver | (Inherited from UIElement.)
Public property | Triggers | (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from UIElement.)
Public property | UseLayoutRounding | (Inherited from FrameworkElement.)
Public property | VerticalAlignment | (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | (Inherited from UIElement.)
Protected property | VisualChildrenCount | (Inherited from FrameworkElement.)
Protected property | VisualParent | (Inherited from Visual.)
Public property | Width | (Inherited from FrameworkElement.)

See Also

BlacklistProfileUserControl Class
wManager.Wow.Forms.ProfileMaker Namespace


Blacklist Property

BlacklistProfileUserControl..::..Blacklist Property

Gets or sets the blacklist.

Namespace: wManager.Wow.Forms.ProfileMaker
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<BlackListSerializable..::..Blackspot> Blacklist { get; set; }
Public Property Blacklist As List(Of BlackListSerializable..::..Blackspot)
    Get
    Set
public:
property List<BlackListSerializable..::..Blackspot^>^ Blacklist {
    List<BlackListSerializable..::..Blackspot^>^ get ();
    void set (List<BlackListSerializable..::..Blackspot^>^ value);
}

Field Value

The blacklist.

See Also

BlacklistProfileUserControl Class
wManager.Wow.Forms.ProfileMaker Namespace


BlacklistProfileUserControl Events

The BlacklistProfileUserControl type exposes the following members.

Events

 | Name | Description
Public event | ContextMenuClosing | (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | (Inherited from FrameworkElement.)
Public event | DataContextChanged | (Inherited from FrameworkElement.)
Public event | DragEnter | (Inherited from UIElement.)
Public event | DragLeave | (Inherited from UIElement.)
Public event | DragOver | (Inherited from UIElement.)
Public event | Drop | (Inherited from UIElement.)
Public event | FocusableChanged | (Inherited from UIElement.)
Public event | GiveFeedback | (Inherited from UIElement.)
Public event | GotFocus | (Inherited from UIElement.)
Public event | GotKeyboardFocus | (Inherited from UIElement.)
Public event | GotMouseCapture | (Inherited from UIElement.)
Public event | GotStylusCapture | (Inherited from UIElement.)
Public event | GotTouchCapture | (Inherited from UIElement.)
Public event | Initialized | (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsVisibleChanged | (Inherited from UIElement.)
Public event | KeyDown | (Inherited from UIElement.)
Public event | KeyUp | (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from UIElement.)
Public event | Loaded | (Inherited from FrameworkElement.)
Public event | LostFocus | (Inherited from UIElement.)
Public event | LostKeyboardFocus | (Inherited from UIElement.)
Public event | LostMouseCapture | (Inherited from UIElement.)
Public event | LostStylusCapture | (Inherited from UIElement.)
Public event | LostTouchCapture | (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | ManipulationStarting | (Inherited from UIElement.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from UIElement.)
Public event | MouseEnter | (Inherited from UIElement.)
Public event | MouseLeave | (Inherited from UIElement.)
Public event | MouseLeftButtonDown | (Inherited from UIElement.)
Public event | MouseLeftButtonUp | (Inherited from UIElement.)
Public event | MouseMove | (Inherited from UIElement.)
Public event | MouseRightButtonDown | (Inherited from UIElement.)
Public event | MouseRightButtonUp | (Inherited from UIElement.)
Public event | MouseUp | (Inherited from UIElement.)
Public event | MouseWheel | (Inherited from UIElement.)
Public event | PreviewDragEnter | (Inherited from UIElement.)
Public event | PreviewDragLeave | (Inherited from UIElement.)
Public event | PreviewDragOver | (Inherited from UIElement.)
Public event | PreviewDrop | (Inherited from UIElement.)
Public event | PreviewGiveFeedback | (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewKeyDown | (Inherited from UIElement.)
Public event | PreviewKeyUp | (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | (Inherited from Control.)
Public event | PreviewMouseDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseMove | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseUp | (Inherited from UIElement.)
Public event | PreviewMouseWheel | (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | (Inherited from UIElement.)
Public event | PreviewStylusDown | (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | (Inherited from UIElement.)
Public event | PreviewStylusInRange | (Inherited from UIElement.)
Public event | PreviewStylusMove | (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | (Inherited from UIElement.)
Public event | PreviewStylusUp | (Inherited from UIElement.)
Public event | PreviewTextInput | (Inherited from UIElement.)
Public event | PreviewTouchDown | (Inherited from UIElement.)
Public event | PreviewTouchMove | (Inherited from UIElement.)
Public event | PreviewTouchUp | (Inherited from UIElement.)
Public event | QueryContinueDrag | (Inherited from UIElement.)
Public event | QueryCursor | (Inherited from UIElement.)
Public event | RequestBringIntoView | (Inherited from FrameworkElement.)
Public event | SizeChanged | (Inherited from FrameworkElement.)
Public event | SourceUpdated | (Inherited from FrameworkElement.)
Public event | StylusButtonDown | (Inherited from UIElement.)
Public event | StylusButtonUp | (Inherited from UIElement.)
Public event | StylusDown | (Inherited from UIElement.)
Public event | StylusEnter | (Inherited from UIElement.)
Public event | StylusInAirMove | (Inherited from UIElement.)
Public event | StylusInRange | (Inherited from UIElement.)
Public event | StylusLeave | (Inherited from UIElement.)
Public event | StylusMove | (Inherited from UIElement.)
Public event | StylusOutOfRange | (Inherited from UIElement.)
Public event | StylusSystemGesture | (Inherited from UIElement.)
Public event | StylusUp | (Inherited from UIElement.)
Public event | TargetUpdated | (Inherited from FrameworkElement.)
Public event | TextInput | (Inherited from UIElement.)
Public event | ToolTipClosing | (Inherited from FrameworkElement.)
Public event | ToolTipOpening | (Inherited from FrameworkElement.)
Public event | TouchDown | (Inherited from UIElement.)
Public event | TouchEnter | (Inherited from UIElement.)
Public event | TouchLeave | (Inherited from UIElement.)
Public event | TouchMove | (Inherited from UIElement.)
Public event | TouchUp | (Inherited from UIElement.)
Public event | Unloaded | (Inherited from FrameworkElement.)

See Also

BlacklistProfileUserControl Class
wManager.Wow.Forms.ProfileMaker Namespace


NpcUserControl Class

UserControl used by profile creators to manage list of Npc (vendor, repair, mailbox, ...)

Namespace: wManager.Wow.Forms.ProfileMaker
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class NpcUserControl : UserControl
Public Class NpcUserControl _
    Inherits UserControl
public ref class NpcUserControl : public UserControl

Inheritance Hierarchy

Object
DispatcherObject
DependencyObject
Visual
UIElement
FrameworkElement
Control
ContentControl
UserControl
wManager.Wow.Forms.ProfileMaker..::..NpcUserControl

See Also

NpcUserControl Members
wManager.Wow.Forms.ProfileMaker Namespace


NpcUserControl Members

The NpcUserControl type exposes the following members.

Constructors

 | Name | Description
Public method | NpcUserControl | Initializes a new instance of the NpcUserControl class.

Methods

 | Name | Description
Protected method | AddChild(System.Object) | (Inherited from ContentControl.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate,System.Boolean) | (Inherited from UIElement.)
Protected method | AddText(System.String) | (Inherited from ContentControl.)
Public method | AddToEventRoute(System.Windows.EventRoute,System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | AddVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock) | (Inherited from UIElement.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from FrameworkElement.)
Public method | Arrange(System.Windows.Rect) | (Inherited from UIElement.)
Protected method | ArrangeCore(System.Windows.Rect) | (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(System.Windows.Size) | (Inherited from Control.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline) | (Inherited from UIElement.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | BeginInit | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior,System.Boolean) | (Inherited from FrameworkElement.)
Public method | BringIntoView | (Inherited from FrameworkElement.)
Public method | BringIntoView(System.Windows.Rect) | (Inherited from FrameworkElement.)
Public method | CaptureMouse | (Inherited from UIElement.)
Public method | CaptureStylus | (Inherited from UIElement.)
Public method | CaptureTouch(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DispatcherObject.)
Public method | ClearValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | ClearValue(System.Windows.DependencyPropertyKey) | (Inherited from DependencyObject.)
Public method | Close | Closes this instance.
Public method | CoerceValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | EndInit | (Inherited from FrameworkElement.)
Public method | Equals(System.Object) | (Inherited from DependencyObject.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindCommonVisualAncestor(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | FindName(System.String) | (Inherited from FrameworkElement.)
Public method | FindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from UIElement.)
Public method | GetAnimationBaseValue(System.Windows.DependencyProperty) | (Inherited from UIElement.)
Public method | GetBindingExpression(System.Windows.DependencyProperty) | (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from DependencyObject.)
Protected method | GetLayoutClip(System.Windows.Size) | (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | (Inherited from DependencyObject.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Protected method | GetVisualChild(System.Int32) | (Inherited from FrameworkElement.)
Protected method | HitTestCore(System.Windows.Media.PointHitTestParameters) | (Inherited from UIElement.)
Protected method | HitTestCore(System.Windows.Media.GeometryHitTestParameters) | (Inherited from UIElement.)
Public method | InputHitTest(System.Windows.Point) | (Inherited from UIElement.)
Public method | InvalidateArrange | (Inherited from UIElement.)
Public method | InvalidateMeasure | (Inherited from UIElement.)
Public method | InvalidateProperty(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | InvalidateVisual | (Inherited from UIElement.)
Public method | IsAncestorOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | IsDescendantOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | Measure(System.Windows.Size) | (Inherited from UIElement.)
Protected method | MeasureCore(System.Windows.Size) | (Inherited from FrameworkElement.)
Protected method | MeasureOverride(System.Windows.Size) | (Inherited from Control.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | MoveFocus(System.Windows.Input.TraversalRequest) | (Inherited from FrameworkElement.)
Protected method | OnAccessKey(System.Windows.Input.AccessKeyEventArgs) | (Inherited from UIElement.)
Public method | OnApplyTemplate | (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged(System.Windows.UIElement) | (Inherited from UIElement.)
Protected method | OnContentChanged(System.Object,System.Object) | (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged(System.String,System.String) | (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged(System.Windows.DataTemplate,System.Windows.DataTemplate) | (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged(System.Windows.Controls.DataTemplateSelector,System.Windows.Controls.DataTemplateSelector) | (Inherited from ContentControl.)
Protected method | OnContextMenuClosing(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | (Inherited from UserControl.)
Protected method | OnDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnGotFocus(System.Windows.RoutedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnGotMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnGotStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnGotTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnInitialized(System.EventArgs) | (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnLostFocus(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnLostStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnLostTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback(System.Windows.Input.ManipulationBoundaryFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationCompleted(System.Windows.Input.ManipulationCompletedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationDelta(System.Windows.Input.ManipulationDeltaEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting(System.Windows.Input.ManipulationInertiaStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarted(System.Windows.Input.ManipulationStartedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarting(System.Windows.Input.ManipulationStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseEnter(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeave(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnPreviewMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPropertyChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnQueryCursor(System.Windows.Input.QueryCursorEventArgs) | (Inherited from UIElement.)
Protected method | OnRender(System.Windows.Media.DrawingContext) | (Inherited from UIElement.)
Protected method | OnStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusEnter(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusLeave(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnTemplateChanged(System.Windows.Controls.ControlTemplate,System.Windows.Controls.ControlTemplate) | (Inherited from Control.)
Protected method | OnTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnToolTipClosing(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchEnter(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchLeave(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Public method | PointFromScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PointToScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PredictFocus(System.Windows.Input.FocusNavigationDirection) | (Inherited from FrameworkElement.)
Public method | RaiseEvent(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Public method | ReadLocalValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | RegisterName(System.String,System.Object) | (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | (Inherited from UIElement.)
Public method | ReleaseMouseCapture | (Inherited from UIElement.)
Public method | ReleaseStylusCapture | (Inherited from UIElement.)
Public method | ReleaseTouchCapture(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | RemoveHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Protected method | RemoveVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | SetBinding(System.Windows.DependencyProperty,System.Windows.Data.BindingBase) | (Inherited from FrameworkElement.)
Public method | SetBinding(System.Windows.DependencyProperty,System.String) | (Inherited from FrameworkElement.)
Public method | SetCurrentValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetResourceReference(System.Windows.DependencyProperty,System.Object) | (Inherited from FrameworkElement.)
Public method | SetValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetValue(System.Windows.DependencyPropertyKey,System.Object) | (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | (Inherited from UIElement.)
Public method | ShouldSerializeContent | (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | (Inherited from UIElement.)
Public method | ShouldSerializeResources | (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | (Inherited from FrameworkElement.)
Public method | ToString | (Inherited from Control.)
Public method | TransformToAncestor(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToAncestor(System.Windows.Media.Media3D.Visual3D) | (Inherited from Visual.)
Public method | TransformToDescendant(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToVisual(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TranslatePoint(System.Windows.Point,System.Windows.UIElement) | (Inherited from UIElement.)
Public method | TryFindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | UnregisterName(System.String) | (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | (Inherited from FrameworkElement.)
Public method | UpdateLayout | (Inherited from UIElement.)
Public method | VerifyAccess | (Inherited from DispatcherObject.)

Properties

 | Name | Description
Public property | ActualHeight | (Inherited from FrameworkElement.)
Public property | ActualWidth | (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
Public property | AreAnyTouchesOver | (Inherited from UIElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from FrameworkElement.)
Public property | BitmapEffect | (Inherited from UIElement.)
Public property | BitmapEffectInput | (Inherited from UIElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | (Inherited from UIElement.)
Public property | ClipToBounds | (Inherited from UIElement.)
Public property | CommandBindings | (Inherited from UIElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContentTemplate | (Inherited from ContentControl.)
Public property | ContentTemplateSelector | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from FrameworkElement.)
Public property | Cursor | (Inherited from FrameworkElement.)
Public property | DataContext | (Inherited from FrameworkElement.)
Public property | DependencyObjectType | (Inherited from DependencyObject.)
Public property | DesiredSize | (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DispatcherObject.)
Public property | Effect | (Inherited from UIElement.)
Public property | FlowDirection | (Inherited from FrameworkElement.)
Public property | Focusable | (Inherited from UIElement.)
Public property | FocusVisualStyle | (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from FrameworkElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasAnimatedProperties | (Inherited from UIElement.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | InputBindings | (Inherited from UIElement.)
Public property | InputScope | (Inherited from FrameworkElement.)
Public property | IsArrangeValid | (Inherited from UIElement.)
Public property | IsEnabled | (Inherited from UIElement.)
Protected property | IsEnabledCore | (Inherited from UIElement.)
Public property | IsFocused | (Inherited from UIElement.)
Public property | IsHitTestVisible | (Inherited from UIElement.)
Public property | IsInitialized | (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | (Inherited from UIElement.)
Public property | IsKeyboardFocused | (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | (Inherited from UIElement.)
Public property | IsLoaded | (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | (Inherited from UIElement.)
Public property | IsMeasureValid | (Inherited from UIElement.)
Public property | IsMouseCaptured | (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | (Inherited from UIElement.)
Public property | IsMouseOver | (Inherited from UIElement.)
Public property | IsSealed | (Inherited from DependencyObject.)
Public property | IsStylusCaptured | (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | (Inherited from UIElement.)
Public property | IsStylusOver | (Inherited from UIElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsVisible | (Inherited from UIElement.)
Public property | Language | (Inherited from FrameworkElement.)
Public property | LayoutTransform | (Inherited from FrameworkElement.)
Public property | Margin | (Inherited from FrameworkElement.)
Public property | MaxHeight | (Inherited from FrameworkElement.)
Public property | MaxWidth | (Inherited from FrameworkElement.)
Public property | MinHeight | (Inherited from FrameworkElement.)
Public property | MinWidth | (Inherited from FrameworkElement.)
Public property | Name | (Inherited from FrameworkElement.)
Public property | NpcList | Gets or sets the NPC list.
Public property | Opacity | (Inherited from UIElement.)
Public property | OpacityMask | (Inherited from UIElement.)
Public property | OverridesDefaultStyle | (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from FrameworkElement.)
Public property | PersistId | (Inherited from UIElement.)
Public property | RenderSize | (Inherited from UIElement.)
Public property | RenderTransform | (Inherited from UIElement.)
Public property | RenderTransformOrigin | (Inherited from UIElement.)
Public property | Resources | (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from UIElement.)
Public property | Style | (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | (Inherited from UIElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | Tag | (Inherited from FrameworkElement.)
Public property | Template | (Inherited from Control.)
Public property | TemplatedParent | (Inherited from FrameworkElement.)
Public property | ToolTip | (Inherited from FrameworkElement.)
Public property | TouchesCaptured | (Inherited from UIElement.)
Public property | TouchesCapturedWithin | (Inherited from UIElement.)
Public property | TouchesDirectlyOver | (Inherited from UIElement.)
Public property | TouchesOver | (Inherited from UIElement.)
Public property | Triggers | (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from UIElement.)
Public property | UseLayoutRounding | (Inherited from FrameworkElement.)
Public property | VerticalAlignment | (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | (Inherited from UIElement.)
Protected property | VisualChildrenCount | (Inherited from FrameworkElement.)
Protected property | VisualParent | (Inherited from Visual.)
Public property | Width | (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | ContextMenuClosing | (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | (Inherited from FrameworkElement.)
Public event | DataContextChanged | (Inherited from FrameworkElement.)
Public event | DragEnter | (Inherited from UIElement.)
Public event | DragLeave | (Inherited from UIElement.)
Public event | DragOver | (Inherited from UIElement.)
Public event | Drop | (Inherited from UIElement.)
Public event | FocusableChanged | (Inherited from UIElement.)
Public event | GiveFeedback | (Inherited from UIElement.)
Public event | GotFocus | (Inherited from UIElement.)
Public event | GotKeyboardFocus | (Inherited from UIElement.)
Public event | GotMouseCapture | (Inherited from UIElement.)
Public event | GotStylusCapture | (Inherited from UIElement.)
Public event | GotTouchCapture | (Inherited from UIElement.)
Public event | Initialized | (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsVisibleChanged | (Inherited from UIElement.)
Public event | KeyDown | (Inherited from UIElement.)
Public event | KeyUp | (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from UIElement.)
Public event | Loaded | (Inherited from FrameworkElement.)
Public event | LostFocus | (Inherited from UIElement.)
Public event | LostKeyboardFocus | (Inherited from UIElement.)
Public event | LostMouseCapture | (Inherited from UIElement.)
Public event | LostStylusCapture | (Inherited from UIElement.)
Public event | LostTouchCapture | (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | ManipulationStarting | (Inherited from UIElement.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from UIElement.)
Public event | MouseEnter | (Inherited from UIElement.)
Public event | MouseLeave | (Inherited from UIElement.)
Public event | MouseLeftButtonDown | (Inherited from UIElement.)
Public event | MouseLeftButtonUp | (Inherited from UIElement.)
Public event | MouseMove | (Inherited from UIElement.)
Public event | MouseRightButtonDown | (Inherited from UIElement.)
Public event | MouseRightButtonUp | (Inherited from UIElement.)
Public event | MouseUp | (Inherited from UIElement.)
Public event | MouseWheel | (Inherited from UIElement.)
Public event | PreviewDragEnter | (Inherited from UIElement.)
Public event | PreviewDragLeave | (Inherited from UIElement.)
Public event | PreviewDragOver | (Inherited from UIElement.)
Public event | PreviewDrop | (Inherited from UIElement.)
Public event | PreviewGiveFeedback | (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewKeyDown | (Inherited from UIElement.)
Public event | PreviewKeyUp | (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | (Inherited from Control.)
Public event | PreviewMouseDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseMove | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseUp | (Inherited from UIElement.)
Public event | PreviewMouseWheel | (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | (Inherited from UIElement.)
Public event | PreviewStylusDown | (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | (Inherited from UIElement.)
Public event | PreviewStylusInRange | (Inherited from UIElement.)
Public event | PreviewStylusMove | (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | (Inherited from UIElement.)
Public event | PreviewStylusUp | (Inherited from UIElement.)
Public event | PreviewTextInput | (Inherited from UIElement.)
Public event | PreviewTouchDown | (Inherited from UIElement.)
Public event | PreviewTouchMove | (Inherited from UIElement.)
Public event | PreviewTouchUp | (Inherited from UIElement.)
Public event | QueryContinueDrag | (Inherited from UIElement.)
Public event | QueryCursor | (Inherited from UIElement.)
Public event | RequestBringIntoView | (Inherited from FrameworkElement.)
Public event | SizeChanged | (Inherited from FrameworkElement.)
Public event | SourceUpdated | (Inherited from FrameworkElement.)
Public event | StylusButtonDown | (Inherited from UIElement.)
Public event | StylusButtonUp | (Inherited from UIElement.)
Public event | StylusDown | (Inherited from UIElement.)
Public event | StylusEnter | (Inherited from UIElement.)
Public event | StylusInAirMove | (Inherited from UIElement.)
Public event | StylusInRange | (Inherited from UIElement.)
Public event | StylusLeave | (Inherited from UIElement.)
Public event | StylusMove | (Inherited from UIElement.)
Public event | StylusOutOfRange | (Inherited from UIElement.)
Public event | StylusSystemGesture | (Inherited from UIElement.)
Public event | StylusUp | (Inherited from UIElement.)
Public event | TargetUpdated | (Inherited from FrameworkElement.)
Public event | TextInput | (Inherited from UIElement.)
Public event | ToolTipClosing | (Inherited from FrameworkElement.)
Public event | ToolTipOpening | (Inherited from FrameworkElement.)
Public event | TouchDown | (Inherited from UIElement.)
Public event | TouchEnter | (Inherited from UIElement.)
Public event | TouchLeave | (Inherited from UIElement.)
Public event | TouchMove | (Inherited from UIElement.)
Public event | TouchUp | (Inherited from UIElement.)
Public event | Unloaded | (Inherited from FrameworkElement.)

See Also

NpcUserControl Class
wManager.Wow.Forms.ProfileMaker Namespace


NpcUserControl Constructor

Initializes a new instance of the NpcUserControl class.

Namespace: wManager.Wow.Forms.ProfileMaker
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public NpcUserControl()
Public Sub New
public:
NpcUserControl()

See Also

NpcUserControl Class
wManager.Wow.Forms.ProfileMaker Namespace


NpcUserControl Methods

The NpcUserControl type exposes the following members.

Methods

 | Name | Description
Protected method | AddChild(System.Object) | (Inherited from ContentControl.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Public method | AddHandler(System.Windows.RoutedEvent,System.Delegate,System.Boolean) | (Inherited from UIElement.)
Protected method | AddText(System.String) | (Inherited from ContentControl.)
Public method | AddToEventRoute(System.Windows.EventRoute,System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | AddVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock) | (Inherited from UIElement.)
Public method | ApplyAnimationClock(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationClock,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from FrameworkElement.)
Public method | Arrange(System.Windows.Rect) | (Inherited from UIElement.)
Protected method | ArrangeCore(System.Windows.Rect) | (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(System.Windows.Size) | (Inherited from Control.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline) | (Inherited from UIElement.)
Public method | BeginAnimation(System.Windows.DependencyProperty,System.Windows.Media.Animation.AnimationTimeline,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from UIElement.)
Public method | BeginInit | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior) | (Inherited from FrameworkElement.)
Public method | BeginStoryboard(System.Windows.Media.Animation.Storyboard,System.Windows.Media.Animation.HandoffBehavior,System.Boolean) | (Inherited from FrameworkElement.)
Public method | BringIntoView | (Inherited from FrameworkElement.)
Public method | BringIntoView(System.Windows.Rect) | (Inherited from FrameworkElement.)
Public method | CaptureMouse | (Inherited from UIElement.)
Public method | CaptureStylus | (Inherited from UIElement.)
Public method | CaptureTouch(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DispatcherObject.)
Public method | ClearValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | ClearValue(System.Windows.DependencyPropertyKey) | (Inherited from DependencyObject.)
Public method | Close | Closes this instance.
Public method | CoerceValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | EndInit | (Inherited from FrameworkElement.)
Public method | Equals(System.Object) | (Inherited from DependencyObject.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindCommonVisualAncestor(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | FindName(System.String) | (Inherited from FrameworkElement.)
Public method | FindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from UIElement.)
Public method | GetAnimationBaseValue(System.Windows.DependencyProperty) | (Inherited from UIElement.)
Public method | GetBindingExpression(System.Windows.DependencyProperty) | (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from DependencyObject.)
Protected method | GetLayoutClip(System.Windows.Size) | (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | (Inherited from DependencyObject.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Protected method | GetVisualChild(System.Int32) | (Inherited from FrameworkElement.)
Protected method | HitTestCore(System.Windows.Media.PointHitTestParameters) | (Inherited from UIElement.)
Protected method | HitTestCore(System.Windows.Media.GeometryHitTestParameters) | (Inherited from UIElement.)
Public method | InputHitTest(System.Windows.Point) | (Inherited from UIElement.)
Public method | InvalidateArrange | (Inherited from UIElement.)
Public method | InvalidateMeasure | (Inherited from UIElement.)
Public method | InvalidateProperty(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | InvalidateVisual | (Inherited from UIElement.)
Public method | IsAncestorOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | IsDescendantOf(System.Windows.DependencyObject) | (Inherited from Visual.)
Public method | Measure(System.Windows.Size) | (Inherited from UIElement.)
Protected method | MeasureCore(System.Windows.Size) | (Inherited from FrameworkElement.)
Protected method | MeasureOverride(System.Windows.Size) | (Inherited from Control.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | MoveFocus(System.Windows.Input.TraversalRequest) | (Inherited from FrameworkElement.)
Protected method | OnAccessKey(System.Windows.Input.AccessKeyEventArgs) | (Inherited from UIElement.)
Public method | OnApplyTemplate | (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged(System.Windows.UIElement) | (Inherited from UIElement.)
Protected method | OnContentChanged(System.Object,System.Object) | (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged(System.String,System.String) | (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged(System.Windows.DataTemplate,System.Windows.DataTemplate) | (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged(System.Windows.Controls.DataTemplateSelector,System.Windows.Controls.DataTemplateSelector) | (Inherited from ContentControl.)
Protected method | OnContextMenuClosing(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening(System.Windows.Controls.ContextMenuEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | (Inherited from UserControl.)
Protected method | OnDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnGotFocus(System.Windows.RoutedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnGotMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnGotStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnGotTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnInitialized(System.EventArgs) | (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnLostFocus(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnLostMouseCapture(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnLostStylusCapture(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnLostTouchCapture(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback(System.Windows.Input.ManipulationBoundaryFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationCompleted(System.Windows.Input.ManipulationCompletedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationDelta(System.Windows.Input.ManipulationDeltaEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting(System.Windows.Input.ManipulationInertiaStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarted(System.Windows.Input.ManipulationStartedEventArgs) | (Inherited from UIElement.)
Protected method | OnManipulationStarting(System.Windows.Input.ManipulationStartingEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseEnter(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeave(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragEnter(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragLeave(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDragOver(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewDrop(System.Windows.DragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback(System.Windows.GiveFeedbackEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyDown(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewKeyUp(System.Windows.Input.KeyEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus(System.Windows.Input.KeyboardFocusChangedEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick(System.Windows.Input.MouseButtonEventArgs) | (Inherited from Control.)
Protected method | OnPreviewMouseDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseMove(System.Windows.Input.MouseEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseUp(System.Windows.Input.MouseButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel(System.Windows.Input.MouseWheelEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPreviewTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnPropertyChanged(System.Windows.DependencyPropertyChangedEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag(System.Windows.QueryContinueDragEventArgs) | (Inherited from UIElement.)
Protected method | OnQueryCursor(System.Windows.Input.QueryCursorEventArgs) | (Inherited from UIElement.)
Protected method | OnRender(System.Windows.Media.DrawingContext) | (Inherited from UIElement.)
Protected method | OnStylusButtonDown(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusButtonUp(System.Windows.Input.StylusButtonEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusDown(System.Windows.Input.StylusDownEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusEnter(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInAirMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusInRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusLeave(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusMove(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusOutOfRange(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusSystemGesture(System.Windows.Input.StylusSystemGestureEventArgs) | (Inherited from UIElement.)
Protected method | OnStylusUp(System.Windows.Input.StylusEventArgs) | (Inherited from UIElement.)
Protected method | OnTemplateChanged(System.Windows.Controls.ControlTemplate,System.Windows.Controls.ControlTemplate) | (Inherited from Control.)
Protected method | OnTextInput(System.Windows.Input.TextCompositionEventArgs) | (Inherited from UIElement.)
Protected method | OnToolTipClosing(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening(System.Windows.Controls.ToolTipEventArgs) | (Inherited from FrameworkElement.)
Protected method | OnTouchDown(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchEnter(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchLeave(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchMove(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Protected method | OnTouchUp(System.Windows.Input.TouchEventArgs) | (Inherited from UIElement.)
Public method | PointFromScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PointToScreen(System.Windows.Point) | (Inherited from Visual.)
Public method | PredictFocus(System.Windows.Input.FocusNavigationDirection) | (Inherited from FrameworkElement.)
Public method | RaiseEvent(System.Windows.RoutedEventArgs) | (Inherited from UIElement.)
Public method | ReadLocalValue(System.Windows.DependencyProperty) | (Inherited from DependencyObject.)
Public method | RegisterName(System.String,System.Object) | (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | (Inherited from UIElement.)
Public method | ReleaseMouseCapture | (Inherited from UIElement.)
Public method | ReleaseStylusCapture | (Inherited from UIElement.)
Public method | ReleaseTouchCapture(System.Windows.Input.TouchDevice) | (Inherited from UIElement.)
Public method | RemoveHandler(System.Windows.RoutedEvent,System.Delegate) | (Inherited from UIElement.)
Protected method | RemoveVisualChild(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | SetBinding(System.Windows.DependencyProperty,System.Windows.Data.BindingBase) | (Inherited from FrameworkElement.)
Public method | SetBinding(System.Windows.DependencyProperty,System.String) | (Inherited from FrameworkElement.)
Public method | SetCurrentValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetResourceReference(System.Windows.DependencyProperty,System.Object) | (Inherited from FrameworkElement.)
Public method | SetValue(System.Windows.DependencyProperty,System.Object) | (Inherited from DependencyObject.)
Public method | SetValue(System.Windows.DependencyPropertyKey,System.Object) | (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | (Inherited from UIElement.)
Public method | ShouldSerializeContent | (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | (Inherited from UIElement.)
Public method | ShouldSerializeResources | (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | (Inherited from FrameworkElement.)
Public method | ToString | (Inherited from Control.)
Public method | TransformToAncestor(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToAncestor(System.Windows.Media.Media3D.Visual3D) | (Inherited from Visual.)
Public method | TransformToDescendant(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TransformToVisual(System.Windows.Media.Visual) | (Inherited from Visual.)
Public method | TranslatePoint(System.Windows.Point,System.Windows.UIElement) | (Inherited from UIElement.)
Public method | TryFindResource(System.Object) | (Inherited from FrameworkElement.)
Public method | UnregisterName(System.String) | (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | (Inherited from FrameworkElement.)
Public method | UpdateLayout | (Inherited from UIElement.)
Public method | VerifyAccess | (Inherited from DispatcherObject.)

See Also

NpcUserControl Class
wManager.Wow.Forms.ProfileMaker Namespace


Close Method

NpcUserControl..::..Close Method

Closes this instance.

Namespace: wManager.Wow.Forms.ProfileMaker
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Close()
Public Sub Close
public:
void Close()

See Also

NpcUserControl Class
wManager.Wow.Forms.ProfileMaker Namespace


NpcUserControl Properties

The NpcUserControl type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | (Inherited from FrameworkElement.)
Public property | ActualWidth | (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
Public property | AreAnyTouchesOver | (Inherited from UIElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from FrameworkElement.)
Public property | BitmapEffect | (Inherited from UIElement.)
Public property | BitmapEffectInput | (Inherited from UIElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | (Inherited from UIElement.)
Public property | ClipToBounds | (Inherited from UIElement.)
Public property | CommandBindings | (Inherited from UIElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContentTemplate | (Inherited from ContentControl.)
Public property | ContentTemplateSelector | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from FrameworkElement.)
Public property | Cursor | (Inherited from FrameworkElement.)
Public property | DataContext | (Inherited from FrameworkElement.)
Public property | DependencyObjectType | (Inherited from DependencyObject.)
Public property | DesiredSize | (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DispatcherObject.)
Public property | Effect | (Inherited from UIElement.)
Public property | FlowDirection | (Inherited from FrameworkElement.)
Public property | Focusable | (Inherited from UIElement.)
Public property | FocusVisualStyle | (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from FrameworkElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasAnimatedProperties | (Inherited from UIElement.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | InputBindings | (Inherited from UIElement.)
Public property | InputScope | (Inherited from FrameworkElement.)
Public property | IsArrangeValid | (Inherited from UIElement.)
Public property | IsEnabled | (Inherited from UIElement.)
Protected property | IsEnabledCore | (Inherited from UIElement.)
Public property | IsFocused | (Inherited from UIElement.)
Public property | IsHitTestVisible | (Inherited from UIElement.)
Public property | IsInitialized | (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | (Inherited from UIElement.)
Public property | IsKeyboardFocused | (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | (Inherited from UIElement.)
Public property | IsLoaded | (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | (Inherited from UIElement.)
Public property | IsMeasureValid | (Inherited from UIElement.)
Public property | IsMouseCaptured | (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | (Inherited from UIElement.)
Public property | IsMouseOver | (Inherited from UIElement.)
Public property | IsSealed | (Inherited from DependencyObject.)
Public property | IsStylusCaptured | (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | (Inherited from UIElement.)
Public property | IsStylusOver | (Inherited from UIElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsVisible | (Inherited from UIElement.)
Public property | Language | (Inherited from FrameworkElement.)
Public property | LayoutTransform | (Inherited from FrameworkElement.)
Public property | Margin | (Inherited from FrameworkElement.)
Public property | MaxHeight | (Inherited from FrameworkElement.)
Public property | MaxWidth | (Inherited from FrameworkElement.)
Public property | MinHeight | (Inherited from FrameworkElement.)
Public property | MinWidth | (Inherited from FrameworkElement.)
Public property | Name | (Inherited from FrameworkElement.)
Public property | NpcList | Gets or sets the NPC list.
Public property | Opacity | (Inherited from UIElement.)
Public property | OpacityMask | (Inherited from UIElement.)
Public property | OverridesDefaultStyle | (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from FrameworkElement.)
Public property | PersistId | (Inherited from UIElement.)
Public property | RenderSize | (Inherited from UIElement.)
Public property | RenderTransform | (Inherited from UIElement.)
Public property | RenderTransformOrigin | (Inherited from UIElement.)
Public property | Resources | (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from UIElement.)
Public property | Style | (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | (Inherited from UIElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | Tag | (Inherited from FrameworkElement.)
Public property | Template | (Inherited from Control.)
Public property | TemplatedParent | (Inherited from FrameworkElement.)
Public property | ToolTip | (Inherited from FrameworkElement.)
Public property | TouchesCaptured | (Inherited from UIElement.)
Public property | TouchesCapturedWithin | (Inherited from UIElement.)
Public property | TouchesDirectlyOver | (Inherited from UIElement.)
Public property | TouchesOver | (Inherited from UIElement.)
Public property | Triggers | (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from UIElement.)
Public property | UseLayoutRounding | (Inherited from FrameworkElement.)
Public property | VerticalAlignment | (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | (Inherited from UIElement.)
Protected property | VisualChildrenCount | (Inherited from FrameworkElement.)
Protected property | VisualParent | (Inherited from Visual.)
Public property | Width | (Inherited from FrameworkElement.)

See Also

NpcUserControl Class
wManager.Wow.Forms.ProfileMaker Namespace


NpcList Property

NpcUserControl..::..NpcList Property

Gets or sets the NPC list.

Namespace: wManager.Wow.Forms.ProfileMaker
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<Npc> NpcList { get; set; }
Public Property NpcList As List(Of Npc)
    Get
    Set
public:
property List<Npc^>^ NpcList {
    List<Npc^>^ get ();
    void set (List<Npc^>^ value);
}

Field Value

The NPC list.

See Also

NpcUserControl Class
wManager.Wow.Forms.ProfileMaker Namespace


NpcUserControl Events

The NpcUserControl type exposes the following members.

Events

 | Name | Description
Public event | ContextMenuClosing | (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | (Inherited from FrameworkElement.)
Public event | DataContextChanged | (Inherited from FrameworkElement.)
Public event | DragEnter | (Inherited from UIElement.)
Public event | DragLeave | (Inherited from UIElement.)
Public event | DragOver | (Inherited from UIElement.)
Public event | Drop | (Inherited from UIElement.)
Public event | FocusableChanged | (Inherited from UIElement.)
Public event | GiveFeedback | (Inherited from UIElement.)
Public event | GotFocus | (Inherited from UIElement.)
Public event | GotKeyboardFocus | (Inherited from UIElement.)
Public event | GotMouseCapture | (Inherited from UIElement.)
Public event | GotStylusCapture | (Inherited from UIElement.)
Public event | GotTouchCapture | (Inherited from UIElement.)
Public event | Initialized | (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | (Inherited from UIElement.)
Public event | IsVisibleChanged | (Inherited from UIElement.)
Public event | KeyDown | (Inherited from UIElement.)
Public event | KeyUp | (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from UIElement.)
Public event | Loaded | (Inherited from FrameworkElement.)
Public event | LostFocus | (Inherited from UIElement.)
Public event | LostKeyboardFocus | (Inherited from UIElement.)
Public event | LostMouseCapture | (Inherited from UIElement.)
Public event | LostStylusCapture | (Inherited from UIElement.)
Public event | LostTouchCapture | (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | ManipulationStarting | (Inherited from UIElement.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from UIElement.)
Public event | MouseEnter | (Inherited from UIElement.)
Public event | MouseLeave | (Inherited from UIElement.)
Public event | MouseLeftButtonDown | (Inherited from UIElement.)
Public event | MouseLeftButtonUp | (Inherited from UIElement.)
Public event | MouseMove | (Inherited from UIElement.)
Public event | MouseRightButtonDown | (Inherited from UIElement.)
Public event | MouseRightButtonUp | (Inherited from UIElement.)
Public event | MouseUp | (Inherited from UIElement.)
Public event | MouseWheel | (Inherited from UIElement.)
Public event | PreviewDragEnter | (Inherited from UIElement.)
Public event | PreviewDragLeave | (Inherited from UIElement.)
Public event | PreviewDragOver | (Inherited from UIElement.)
Public event | PreviewDrop | (Inherited from UIElement.)
Public event | PreviewGiveFeedback | (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewKeyDown | (Inherited from UIElement.)
Public event | PreviewKeyUp | (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | (Inherited from Control.)
Public event | PreviewMouseDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseMove | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | (Inherited from UIElement.)
Public event | PreviewMouseUp | (Inherited from UIElement.)
Public event | PreviewMouseWheel | (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | (Inherited from UIElement.)
Public event | PreviewStylusDown | (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | (Inherited from UIElement.)
Public event | PreviewStylusInRange | (Inherited from UIElement.)
Public event | PreviewStylusMove | (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | (Inherited from UIElement.)
Public event | PreviewStylusUp | (Inherited from UIElement.)
Public event | PreviewTextInput | (Inherited from UIElement.)
Public event | PreviewTouchDown | (Inherited from UIElement.)
Public event | PreviewTouchMove | (Inherited from UIElement.)
Public event | PreviewTouchUp | (Inherited from UIElement.)
Public event | QueryContinueDrag | (Inherited from UIElement.)
Public event | QueryCursor | (Inherited from UIElement.)
Public event | RequestBringIntoView | (Inherited from FrameworkElement.)
Public event | SizeChanged | (Inherited from FrameworkElement.)
Public event | SourceUpdated | (Inherited from FrameworkElement.)
Public event | StylusButtonDown | (Inherited from UIElement.)
Public event | StylusButtonUp | (Inherited from UIElement.)
Public event | StylusDown | (Inherited from UIElement.)
Public event | StylusEnter | (Inherited from UIElement.)
Public event | StylusInAirMove | (Inherited from UIElement.)
Public event | StylusInRange | (Inherited from UIElement.)
Public event | StylusLeave | (Inherited from UIElement.)
Public event | StylusMove | (Inherited from UIElement.)
Public event | StylusOutOfRange | (Inherited from UIElement.)
Public event | StylusSystemGesture | (Inherited from UIElement.)
Public event | StylusUp | (Inherited from UIElement.)
Public event | TargetUpdated | (Inherited from FrameworkElement.)
Public event | TextInput | (Inherited from UIElement.)
Public event | ToolTipClosing | (Inherited from FrameworkElement.)
Public event | ToolTipOpening | (Inherited from FrameworkElement.)
Public event | TouchDown | (Inherited from UIElement.)
Public event | TouchEnter | (Inherited from UIElement.)
Public event | TouchLeave | (Inherited from UIElement.)
Public event | TouchMove | (Inherited from UIElement.)
Public event | TouchUp | (Inherited from UIElement.)
Public event | Unloaded | (Inherited from FrameworkElement.)

See Also

NpcUserControl Class
wManager.Wow.Forms.ProfileMaker Namespace


RecordPathUserControl Class

UserControl used by profile creators to manage and record path

Namespace: wManager.Wow.Forms.ProfileMaker
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class RecordPathUserControl : UserControl
Public Class RecordPathUserControl _
    Inherits UserControl
public ref class RecordPathUserControl : public UserControl

Inheritance Hierarchy

Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
wManager.Wow.Forms.ProfileMaker..::..RecordPathUserControl

See Also

RecordPathUserControl Members
wManager.Wow.Forms.ProfileMaker Namespace


RecordPathUserControl Members

The RecordPathUserControl type exposes the following members.

Constructors

 | Name | Description
Public method | RecordPathUserControl | Initializes a new instance of the RecordPathUserControl class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from ContainerControl.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Public method | CloseUC | Closes the uc.
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Control.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Control.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(System.Boolean) | (Inherited from ContainerControl.)
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from UserControl.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Control.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from ContainerControl.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from UserControl.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from ContainerControl.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from ScrollableControl.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from ContainerControl.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Control.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Public method | Settings(Double, Double) | Configure the minimum distance between two positions.
Public method | Settings(Double, Double, Double, Double) | Configure the minimum distance between two positions.
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Control.)
Public method | Show | (Inherited from Control.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Component.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from ContainerControl.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from UserControl.)

Properties

 | Name | Description
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | AllowDrop | (Inherited from Control.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | (Inherited from UserControl.)
Public property | AutoValidate | (Inherited from UserControl.)
Public property | BackColor | (Inherited from Control.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | (Inherited from UserControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Control.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Control.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMirrored | (Inherited from Control.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Control.)
Public property | Margin | (Inherited from Control.)
Public property | MaximumSize | (Inherited from Control.)
Public property | MinimumSize | (Inherited from Control.)
Public property | Name | (Inherited from Control.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | Path | Gets or sets the path.
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Control.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabStop | (Inherited from Control.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | (Inherited from Control.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowTarget | (Inherited from Control.)

Events

 | Name | Description
Public event | AutoSizeChanged | (Inherited from UserControl.)
Public event | AutoValidateChanged | (Inherited from UserControl.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from UserControl.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Control.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Control.)
Public event | TabStopChanged | (Inherited from Control.)
Public event | TextChanged | (Inherited from UserControl.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

RecordPathUserControl Class
wManager.Wow.Forms.ProfileMaker Namespace


RecordPathUserControl Constructor

Initializes a new instance of the RecordPathUserControl class.

Namespace: wManager.Wow.Forms.ProfileMaker
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public RecordPathUserControl()
Public Sub New
public:
RecordPathUserControl()

See Also

RecordPathUserControl Class
wManager.Wow.Forms.ProfileMaker Namespace


RecordPathUserControl Methods

The RecordPathUserControl type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from ContainerControl.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Public method | CloseUC | Closes the uc.
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Control.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Control.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(System.Boolean) | (Inherited from ContainerControl.)
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from UserControl.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Control.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from ContainerControl.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from UserControl.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from UserControl.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from ContainerControl.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from ContainerControl.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from ContainerControl.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from ScrollableControl.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from ScrollableControl.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from ContainerControl.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Control.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Public method | Settings(Double, Double) | Configure the minimum distance between two positions.
Public method | Settings(Double, Double, Double, Double) | Configure the minimum distance between two positions.
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Control.)
Public method | Show | (Inherited from Control.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Component.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from ContainerControl.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from UserControl.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from UserControl.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from UserControl.)

See Also

RecordPathUserControl Class
wManager.Wow.Forms.ProfileMaker Namespace


CloseUC Method

RecordPathUserControl..::..CloseUC Method

Closes the uc.

Namespace: wManager.Wow.Forms.ProfileMaker
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void CloseUC()
Public Sub CloseUC
public:
void CloseUC()

See Also

RecordPathUserControl Class
wManager.Wow.Forms.ProfileMaker Namespace


Settings Method

RecordPathUserControl..::..Settings Method

Overload List

 | Name | Description
Public method | Settings(Double, Double) | Configure the minimum distance between two positions.
Public method | Settings(Double, Double, Double, Double) | Configure the minimum distance between two positions.

See Also

RecordPathUserControl Class
RecordPathUserControl Members
wManager.Wow.Forms.ProfileMaker Namespace


Settings Method (Double, Double)

RecordPathUserControl..::..Settings Method (Double, Double)

Configure the minimum distance between two positions.

Namespace: wManager.Wow.Forms.ProfileMaker
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Settings(
    double distance2D,
    double distanceZ
)
Public Sub Settings ( _
    distance2D As Double, _
    distanceZ As Double _
)
public:
void Settings(
    double^ distance2D,
    double^ distanceZ
)

Parameters

distance2D
Type: Double
The distance 2d.
distanceZ
Type: Double
The distance z.

See Also

RecordPathUserControl Class
Settings Overload
wManager.Wow.Forms.ProfileMaker Namespace


Settings Method (Double, Double, Double, Double)

RecordPathUserControl..::..Settings Method (Double, Double, Double, Double)

Configure the minimum distance between two positions.

Namespace: wManager.Wow.Forms.ProfileMaker
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Settings(
    double distance2D,
    double distanceZ,
    double distance2DFly,
    double distanceZFly
)
Public Sub Settings ( _
    distance2D As Double, _
    distanceZ As Double, _
    distance2DFly As Double, _
    distanceZFly As Double _
)
public:
void Settings(
    double^ distance2D,
    double^ distanceZ,
    double^ distance2DFly,
    double^ distanceZFly
)

Parameters

distance2D
Type: Double
The distance 2d.
distanceZ
Type: Double
The distance z.
distance2DFly
Type: Double
The distance 2d when flying.
distanceZFly
Type: Double
The distance z when flying.

See Also

RecordPathUserControl Class
Settings Overload
wManager.Wow.Forms.ProfileMaker Namespace


RecordPathUserControl Properties

The RecordPathUserControl type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | AllowDrop | (Inherited from Control.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | (Inherited from UserControl.)
Public property | AutoValidate | (Inherited from UserControl.)
Public property | BackColor | (Inherited from Control.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | (Inherited from UserControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Control.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from UserControl.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Control.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from UserControl.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMirrored | (Inherited from Control.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Control.)
Public property | Margin | (Inherited from Control.)
Public property | MaximumSize | (Inherited from Control.)
Public property | MinimumSize | (Inherited from Control.)
Public property | Name | (Inherited from Control.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | Path | Gets or sets the path.
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Control.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabStop | (Inherited from Control.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Top | (Inherited from Control.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowTarget | (Inherited from Control.)

See Also

RecordPathUserControl Class
wManager.Wow.Forms.ProfileMaker Namespace


Path Property

RecordPathUserControl..::..Path Property

Gets or sets the path.

Namespace: wManager.Wow.Forms.ProfileMaker
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<Vector3> Path { get; set; }
Public Property Path As List(Of Vector3)
    Get
    Set
public:
property List<Vector3^>^ Path {
    List<Vector3^>^ get ();
    void set (List<Vector3^>^ value);
}

Field Value

The path.

See Also

RecordPathUserControl Class
wManager.Wow.Forms.ProfileMaker Namespace


RecordPathUserControl Events

The RecordPathUserControl type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | (Inherited from UserControl.)
Public event | AutoValidateChanged | (Inherited from UserControl.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from UserControl.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Control.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Control.)
Public event | TabStopChanged | (Inherited from Control.)
Public event | TextChanged | (Inherited from UserControl.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

RecordPathUserControl Class
wManager.Wow.Forms.ProfileMaker Namespace


wManager.Wow.Helpers Namespace

Classes

 | Class | Description
Public class | Archaeology | Class Archaeology. Few methods useful for archeology
Public class | AuctionHelpers | Class AuctionHelpers.
Public class | AuctionHelpers..::..AuctionItem | Class AuctionItem.
Public class | Bag | Class Bag. Methods useful to manage game bags.
Public class | Battleground | Class Battleground. Useful methods to manage battleground.
Public class | BuffManager | Class BuffManager. Useful to read buff/debuff list.
Public class | CGUnit_C__GetFacing | Class CGUnit_C__GetFacing. used to get [WoWGameObject.Rotation]
Public class | CGUnit_C__GetPosition | Class CGUnit_C__GetPosition. Used to get [WoWUnit.get_Position] when InTransport.
Public class | Channel | Class Channel.
Public class | Channel..::..Message | Class Message.
Public class | Chat | Class Chat. Several useful methods to send and get messages in game.
Public class | ClickOnTerrain | Class ClickOnTerrain. Useful for AOE spells.
Public class | ClickToMove | Class ClickToMove. Used to move character in game to specific position, by default this class use game option CTM (Click to move), but in some bot version this class can move character can move with keyboard.
Public class | Conditions | Class Conditions. Facade for several useful conditions
Public class | ConfigWowForThisBot | Class ConfigWowForThisBot. Bot use these methods to change/reset game settings to works correctly with the bot.
Public class | CustomClass | Class CustomClass. Also known as Fightclass or Fightclasses, this class allows you to manage it. To create fight class you can use Creator, but you can also use C#, VB.net or LuaBot. Fight classes need to implement interface ICustomClass (except for LuaBot fightclass). You can also look https://wrobot.eu/forums/topic/11122-c-fightclass-development-video-tutorial/
Public class | CVar | Class CVar. Wrapper for access to in game CVar https://wow.gamepedia.com/Console_variables
Public class | DBC<(Of <(<'T>)>)> |
Public class | EquippedItems | Class EquippedItems.
Public class | EventsLua | Class EventsLua (this class count the number of times the event was called, if you need event arguments use EventsLuaWithArgs). Facilitates access from the bot to the in game lua events https://wowwiki.fandom.com/wiki/Event_API .
Public class | EventsLuaWithArgs | Class EventsLuaWithArgs. (if you don't need event arguments prefer to use EventsLua). Facilitates access from the bot to the in game lua events https://wowwiki.fandom.com/wiki/Event_API .
Public class | Fight | Class Fight. Used to fight the WoWUnit.
Public class | FightBattlePet | Class FightBattlePet. Used to manage behaviour and abilities during pet battles.
Public class | FightBG | Class FightBG. Used to fight the WoWPlayer.
Public class | Fishing | Class Fishing. Useful method for fishing
Public class | GetPlayerName | Class GetPlayerName.
Public class | Interact | Class Interact.
Public class | IsOutDoorsInjection | Class IsOutDoorsInjection.
Public class | ItemsManager | Class ItemsManager. Useful method to manage items
Public class | Keybindings | Class Keybindings. Recommended methods if you need to interact with keyboard (for existing shortcut).
Public class | Login | Class Login. To login character to the game.
Public class | LongMove | Class LongMove. Useful to flying to specific destination when there are obstacles.
Public class | Lua | Class Lua. Used to run lua code in game and get lua variables value ( https://wow.gamepedia.com/World_of_Warcraft_API ).
Public class | Lua..::..WowLuaClass | Class WowLuaClass (for more information see Wow). Implements the DynamicObject
Public class | Mail | Class Mail. Methods to send or read mailboxes messages.
Public class | Milling | Class Milling.
Public class | MiniMapGenerator | Class MiniMapGenerator. Used by UserControlMiniMap
Public class | MiniMapGenerator..::..LandmarkMiniMap | Class LandmarkMiniMap, used to show information in UserControlMiniMap and Radar3D (you can found example here: LandmarksMiniMap). Implements the ICloneable
Public class | MiniMapGenerator..::..LandmarksMiniMap | Class LandmarksMiniMap (for more information look MiniMapGenerator..::..LandmarkMiniMap). Implements the ICloneable
Public class | MiniMapGenerator..::..MinimapImage | Class MinimapImage.
Public class | MiniMapGenerator..::..PathImage | Class PathImage.
Public class | Move | Class Move. Prefer to use this class to move the character (if you enabled option UseLuaToMove methods will use lua function instead keyboard).
Public class | MovementManager | Main class for handling movement with a path or a destination
Public class | NpcDB | Class NpcDB. Manage list of NPCs vendor, repair, trainer, ... Saved in the file "WRobot\Data\NpcDB.xml".
Public class | Party | Class Party. Useful methods for group of characters (party and raid)
Public class | PathFinder | Path Generator Class. Use this class to find path.
Public class | PathFinder..::..OffMeshConnection | Class OffMeshConnection. (sees PathFinder..::..OffMeshConnections and https://wrobot.eu/forums/topic/5283-offmesh-connections/ )
Public class | PathFinder..::..OffMeshConnections | Class OffMeshConnections. More information here: https://wrobot.eu/forums/topic/5283-offmesh-connections/
Public class | PetBattles | Class PetBattles. Useful methods to manage.
Public class | PetBattles..::..ModiferEffects | Class ModiferEffects.
Public class | Prospecting | Class Prospecting.
Public class | Quest | Class Quest. Useful method for game quests and Quester product.
Public class | Quest..::..QuesterCurrentContext | Class QuesterCurrentContext, "Quester" product use this class to store profile and profile state.
Public class | Radar3D | Class Radar3D. Create overlay transparent window to show bot elements in game. Used when option "Radar 3D" is enabled tab "Map".
Public class | RunCodeExtension | Class RunCodeExtension. Few useful methods to run script Implements the RunCode
Public class | RunesManager | Class RunesManager.
Public class | Skill | Class Skill.
Public class | Smelting | Class Smelting.
Public class | SpellListManager | Class SpellListManager. (more spell methods in Spell and SpellManager)
Public class | SpellManager | Class SpellManager. (more spell methods in Spell and SpellListManager)
Public class | StuckResolver | Class StuckResolver.
Public class | Talent | Talents
Public class | Taxi | Class Taxi.
Public class | Taxi..::..TaxiList | Class TaxiList. To save knows taxi nodes (to file "WRobot\Settings\TaxiNodes.xml").
Public class | Totems | Class Totems.
Public class | TraceLine | Class TraceLine (Raycast). Create an invisible line and detects if an element of the game is hit and at what position.
Public class | TraceLine..::..Line | Class Line.
Public class | Tracker | Class Tracker.
Public class | Trainer | Class Trainer.
Public class | UnitCanAttack | Class UnitCanAttack.
Public class | UnitRelation | Class UnitRelation.
Public class | Usefuls | Class Usefuls.
Public class | Vendor | Class Vendor. Few useful method to sell, repair and buy items
Public class | WoWFactionTemplate | Class WoWFactionTemplate (DB2).
Public class | WoWLock | Class WoWLock (DB2).

Structures

 | Structure | Description
Public structure | ClickOnTerrain..::..StructClickOnTerrain | Struct StructClickOnTerrain
Public structure | Login..::..SettingsLogin | Struct SettingsLogin
Public structure | PetBattles..::..AbilityInfo | Struct AbilityInfo PetBattles
Public structure | Quest..::..PlayerQuest | Struct PlayerQuest
Public structure | Taxi..::..TaxiNodesDB |
Public structure | WoWFactionTemplate..::..FactionTemplateDbcRecord |
Public structure | WoWLock..::..LockDbcRecord |

Interfaces

 | Interface | Description
Public interface | FightBattlePet..::..IFightClassPet | Interface IFightClassPet
Public interface | ICustomClass | Interface ICustomClass, used by fight classes: CustomClass

Delegates

 | Delegate | Description
Public delegate | EventsLua..::..MethodDelegate | Delegate MethodDelegate
Public delegate | EventsLuaWithArgs..::..EventsLuaStringWithArgsHandler | Delegate EventsLuaStringWithArgsHandler
Public delegate | EventsLuaWithArgs..::..EventsLuaWithArgsHandler | Delegate EventsLuaWithArgsHandler
Public delegate | Radar3D..::..OnDrawHandler | Delegate OnDrawHandler

Enumerations

 | Enumeration | Description
Public enumeration | AuctionHelpers..::..Duration | Auction duration
Public enumeration | AuctionHelpers..::..Filters | Auction search item filters
Public enumeration | AuctionHelpers..::..Rarity | Auction search item rarity
Public enumeration | AuctionHelpers..::..TimeLeft | Auction time left
Public enumeration | ItemsManager..::..ConsumableType | ConsumableType (used by [GetBestConsumableBag(ConsumableType)])
Public enumeration | Move..::..MoveAction | Press keyboard key (DownKey and UpKey)
Public enumeration | PathFinder..::..OffMeshConnectionType | OffMeshConnectionType
Public enumeration | PetBattles..::..PetFaction |
Public enumeration | PetBattles..::..PetQuality | PetQuality PetBattles
Public enumeration | PetBattles..::..PetType | PetType PetBattles
Public enumeration | Quest..::..PlayerQuest..::..StateFlag | StateFlag


Archaeology Class

Class Archaeology. Few methods useful for archeology

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class Archaeology
Public NotInheritable Class Archaeology
public ref class Archaeology abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..Archaeology

See Also

Archaeology Members
wManager.Wow.Helpers Namespace


Archaeology Members

The Archaeology type exposes the following members.

Methods

Name | Description
DigsiteZoneIsAvailable | Check if the digsite zone is available (active, works only on current continent).
GetAllDigsitesZone | Gets all digsites (list saved in the file "WRobot\Data\Digsites.xml")
GetDigsitesZoneAvailable | Gets the digsites zone available (active in game and in current continent).
SolveAllArtifact | Solves all artifact.

Fields

Name | Description
SurveyList | The survey list (SurveyTool)

Properties

Name | Description
ArchaeologyItemsFindList | List of gameobjects (entry id) to pick up

See Also

Archaeology Class
wManager.Wow.Helpers Namespace


Archaeology Fields

The Archaeology type exposes the following members.

Fields

Name | Description
SurveyList | The survey list (SurveyTool)

See Also

Archaeology Class
wManager.Wow.Helpers Namespace


SurveyList Field

Archaeology..::..SurveyList Field

The survey list (SurveyTool)

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<int> SurveyList
Public Shared SurveyList As List(Of Integer)
public:
static List<int^>^ SurveyList

See Also

Archaeology Class
wManager.Wow.Helpers Namespace


Archaeology Methods

The Archaeology type exposes the following members.

Methods

Name | Description
DigsiteZoneIsAvailable | Check if the digsite zone is available (active, works only on current continent).
GetAllDigsitesZone | Gets all digsites (list saved in the file "WRobot\Data\Digsites.xml")
GetDigsitesZoneAvailable | Gets the digsites zone available (active in game and in current continent).
SolveAllArtifact | Solves all artifact.

See Also

Archaeology Class
wManager.Wow.Helpers Namespace


DigsiteZoneIsAvailable Method

Archaeology..::..DigsiteZoneIsAvailable Method

Check if the digsite zone is available (active, works only on current continent).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool DigsiteZoneIsAvailable(
    Digsite digsitesZone
)
Public Shared Function DigsiteZoneIsAvailable ( _
    digsitesZone As Digsite _
) As Boolean
public:
static bool^ DigsiteZoneIsAvailable(
    Digsite^ digsitesZone
)

Parameters

digsitesZone
Type: wManager.Wow.Class..::..Digsite
The digsite.

See Also

Archaeology Class
wManager.Wow.Helpers Namespace


GetAllDigsitesZone Method

Archaeology..::..GetAllDigsitesZone Method

Gets all digsites (list saved in the file "WRobot\Data\Digsites.xml")

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<Digsite> GetAllDigsitesZone()
Public Shared Function GetAllDigsitesZone As List(Of Digsite)
public:
static List<Digsite^>^ GetAllDigsitesZone()

Return Value

List<Digsite>.

See Also

Archaeology Class
wManager.Wow.Helpers Namespace


GetDigsitesZoneAvailable Method

Archaeology..::..GetDigsitesZoneAvailable Method

Gets the digsites zone available (active in game and in current continent).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<Digsite> GetDigsitesZoneAvailable()
Public Shared Function GetDigsitesZoneAvailable As List(Of Digsite)
public:
static List<Digsite^>^ GetDigsitesZoneAvailable()

Return Value

List<Digsite>.

See Also

Archaeology Class
wManager.Wow.Helpers Namespace


SolveAllArtifact Method

Archaeology..::..SolveAllArtifact Method

Solves all artifact.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool SolveAllArtifact(
    bool completeFragments
)
Public Shared Function SolveAllArtifact ( _
    completeFragments As Boolean _
) As Boolean
public:
static bool^ SolveAllArtifact(
    bool^ completeFragments
)

Parameters

completeFragments
Type: Boolean
if set to true complete fragments.

See Also

Archaeology Class
wManager.Wow.Helpers Namespace


Archaeology Properties

The Archaeology type exposes the following members.

Properties

Name | Description
ArchaeologyItemsFindList | List of gameobjects (entry id) to pick up

See Also

Archaeology Class
wManager.Wow.Helpers Namespace


ArchaeologyItemsFindList Property

Archaeology..::..ArchaeologyItemsFindList Property

List of gameobjects (entry id) to pick up

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<int> ArchaeologyItemsFindList { get; }
Public Shared ReadOnly Property ArchaeologyItemsFindList As List(Of Integer)
    Get
public:
static property List<int^>^ ArchaeologyItemsFindList {
    List<int^>^ get ();
}

See Also

Archaeology Class
wManager.Wow.Helpers Namespace


AuctionHelpers Class

Class AuctionHelpers.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class AuctionHelpers
Public NotInheritable Class AuctionHelpers
public ref class AuctionHelpers abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..AuctionHelpers

See Also

AuctionHelpers Members
wManager.Wow.Helpers Namespace


AuctionHelpers Members

The AuctionHelpers type exposes the following members.

Methods

Name | Description
AuctionHouseIsShown | Auctions the house is shown.
AuctionProgressFrameIsShown | Auctions the progress frame is shown.
BrowseBidButtonClick | Browses the bid button click.
BrowseBuyoutButtonClick | Browses the buyout button click.
BrowseFilterSet | Browses the filter set.
BrowseMaxLevelSetText | Browses the maximum level set text.
BrowseMinLevelSetText | Browses the minimum level set text.
BrowseNameSetText | Browses the name set text.
BrowseNextPageButtonClick | Browses the next page button click.
BrowseNextPageButtonIsEnabled | Browses the next page button is enabled.
BrowsePageNumber | Browses the page number.
BrowsePrevPageButtonClick | Browses the previous page button click.
BrowsePrevPageButtonIsEnabled | Browses the previous page button is enabled.
BrowseRaritySet | Browses the rarity set.
BrowseSearchButtonClick | Browses the search button click.
BrowseSearchButtonIsEnabled | Browses the search button is enabled.
BuyoutBidPopupAcceptClick | Buyouts the bid popup accept click.
BuyoutBidPopupCancelClick | Buyouts the bid popup cancel click.
BuyoutBidPopupIsShown | Buyouts the bid popup is shown.
ClearAuctionSellItem | Clears the auction sell item.
CloseAuctionHouse | Closes the auction house.
ExactMatchCheckButtonSetChecked | Exacts the match check button set checked.
GetAuctionItemTimeLeft(Int32) | Gets the auction item time left.
GetAuctionItemTimeLeft()()()() | Gets the auction item time left.
GetAuctionSellItemId | Gets the auction sell item identifier.
GetAuctionSellItemName | Gets the name of the auction sell item.
GetBrowsePageItems | Gets the browse page items.
GetSelectedAuctionItem | Gets the selected auction item.
IsUsableCheckButtonSetChecked | Determines whether [is usable check button set checked] [the specified is checked].
PlaceAuctionBid | Places the auction bid.
PlayerAuctionsCountStacksByItemName | Players the name of the auctions count stacks by item.
ResetAuctionFrameBrowse | Resets the auction frame browse.
SelectAuctionItem | Selects the auction item.
SelectAuctionsTab | Selects the auctions tab.
SelectBidsTab | Selects the bids tab.
SelectBrowseTab | Selects the browse tab.
SetAuctionSellItem | Sets the auction sell item.
StartAuction | Starts the auction.
WaitInSearch | Waits the in search.

See Also

AuctionHelpers Class
wManager.Wow.Helpers Namespace


AuctionHelpers Methods

The AuctionHelpers type exposes the following members.

Methods

Name | Description
AuctionHouseIsShown | Auctions the house is shown.
AuctionProgressFrameIsShown | Auctions the progress frame is shown.
BrowseBidButtonClick | Browses the bid button click.
BrowseBuyoutButtonClick | Browses the buyout button click.
BrowseFilterSet | Browses the filter set.
BrowseMaxLevelSetText | Browses the maximum level set text.
BrowseMinLevelSetText | Browses the minimum level set text.
BrowseNameSetText | Browses the name set text.
BrowseNextPageButtonClick | Browses the next page button click.
BrowseNextPageButtonIsEnabled | Browses the next page button is enabled.
BrowsePageNumber | Browses the page number.
BrowsePrevPageButtonClick | Browses the previous page button click.
BrowsePrevPageButtonIsEnabled | Browses the previous page button is enabled.
BrowseRaritySet | Browses the rarity set.
BrowseSearchButtonClick | Browses the search button click.
BrowseSearchButtonIsEnabled | Browses the search button is enabled.
BuyoutBidPopupAcceptClick | Buyouts the bid popup accept click.
BuyoutBidPopupCancelClick | Buyouts the bid popup cancel click.
BuyoutBidPopupIsShown | Buyouts the bid popup is shown.
ClearAuctionSellItem | Clears the auction sell item.
CloseAuctionHouse | Closes the auction house.
ExactMatchCheckButtonSetChecked | Exacts the match check button set checked.
GetAuctionItemTimeLeft(Int32) | Gets the auction item time left.
GetAuctionItemTimeLeft()()()() | Gets the auction item time left.
GetAuctionSellItemId | Gets the auction sell item identifier.
GetAuctionSellItemName | Gets the name of the auction sell item.
GetBrowsePageItems | Gets the browse page items.
GetSelectedAuctionItem | Gets the selected auction item.
IsUsableCheckButtonSetChecked | Determines whether [is usable check button set checked] [the specified is checked].
PlaceAuctionBid | Places the auction bid.
PlayerAuctionsCountStacksByItemName | Players the name of the auctions count stacks by item.
ResetAuctionFrameBrowse | Resets the auction frame browse.
SelectAuctionItem | Selects the auction item.
SelectAuctionsTab | Selects the auctions tab.
SelectBidsTab | Selects the bids tab.
SelectBrowseTab | Selects the browse tab.
SetAuctionSellItem | Sets the auction sell item.
StartAuction | Starts the auction.
WaitInSearch | Waits the in search.

See Also

AuctionHelpers Class
wManager.Wow.Helpers Namespace


AuctionHouseIsShown Method

AuctionHelpers..::..AuctionHouseIsShown Method

Auctions the house is shown.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool AuctionHouseIsShown()
Public Shared Function AuctionHouseIsShown As Boolean
public:
static bool^ AuctionHouseIsShown()

See Also

AuctionHelpers Class
wManager.Wow.Helpers Namespace


AuctionProgressFrameIsShown Method

AuctionHelpers..::..AuctionProgressFrameIsShown Method

Auctions the progress frame is shown.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool AuctionProgressFrameIsShown()
Public Shared Function AuctionProgressFrameIsShown As Boolean
public:
static bool^ AuctionProgressFrameIsShown()

See Also

AuctionHelpers Class
wManager.Wow.Helpers Namespace


BrowseBidButtonClick Method

AuctionHelpers..::..BrowseBidButtonClick Method

Browses the bid button click.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void BrowseBidButtonClick()
Public Shared Sub BrowseBidButtonClick
public:
static void BrowseBidButtonClick()

See Also

AuctionHelpers Class
wManager.Wow.Helpers Namespace


BrowseBuyoutButtonClick Method

AuctionHelpers..::..BrowseBuyoutButtonClick Method

Browses the buyout button click.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void BrowseBuyoutButtonClick()
Public Shared Sub BrowseBuyoutButtonClick
public:
static void BrowseBuyoutButtonClick()

See Also

AuctionHelpers Class
wManager.Wow.Helpers Namespace


BrowseFilterSet Method

AuctionHelpers..::..BrowseFilterSet Method

Browses the filter set.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void BrowseFilterSet(
    AuctionHelpers..::..Filters filter
)
Public Shared Sub BrowseFilterSet ( _
    filter As AuctionHelpers..::..Filters _
)
public:
static void BrowseFilterSet(
    AuctionHelpers..::..Filters^ filter
)

Parameters

filter
Type: wManager.Wow.Helpers..::..AuctionHelpers..::..Filters
The filter.

See Also

AuctionHelpers Class
wManager.Wow.Helpers Namespace


BrowseMaxLevelSetText Method

AuctionHelpers..::..BrowseMaxLevelSetText Method

Browses the maximum level set text.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void BrowseMaxLevelSetText(
    int level
)
Public Shared Sub BrowseMaxLevelSetText ( _
    level As Integer _
)
public:
static void BrowseMaxLevelSetText(
    int^ level
)

Parameters

level
Type: Int32
The level.

See Also

AuctionHelpers Class
wManager.Wow.Helpers Namespace


BrowseMinLevelSetText Method

AuctionHelpers..::..BrowseMinLevelSetText Method

Browses the minimum level set text.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void BrowseMinLevelSetText(
    int level
)
Public Shared Sub BrowseMinLevelSetText ( _
    level As Integer _
)
public:
static void BrowseMinLevelSetText(
    int^ level
)

Parameters

level
Type: Int32
The level.

See Also

AuctionHelpers Class
wManager.Wow.Helpers Namespace


BrowseNameSetText Method

AuctionHelpers..::..BrowseNameSetText Method

Browses the name set text.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void BrowseNameSetText(
    string text
)
Public Shared Sub BrowseNameSetText ( _
    text As String _
)
public:
static void BrowseNameSetText(
    String^ text
)

Parameters

text
Type: String
The text.

See Also

AuctionHelpers Class
wManager.Wow.Helpers Namespace


BrowseNextPageButtonClick Method

AuctionHelpers..::..BrowseNextPageButtonClick Method

Browses the next page button click.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void BrowseNextPageButtonClick()
Public Shared Sub BrowseNextPageButtonClick
public:
static void BrowseNextPageButtonClick()

See Also

AuctionHelpers Class
wManager.Wow.Helpers Namespace


BrowseNextPageButtonIsEnabled Method

AuctionHelpers..::..BrowseNextPageButtonIsEnabled Method

Browses the next page button is enabled.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool BrowseNextPageButtonIsEnabled()
Public Shared Function BrowseNextPageButtonIsEnabled As Boolean
public:
static bool^ BrowseNextPageButtonIsEnabled()

See Also

AuctionHelpers Class
wManager.Wow.Helpers Namespace


BrowsePageNumber Method

AuctionHelpers..::..BrowsePageNumber Method

Browses the page number.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int BrowsePageNumber()
Public Shared Function BrowsePageNumber As Integer
public:
static int^ BrowsePageNumber()

Return Value

System.Int32.

See Also

AuctionHelpers Class
wManager.Wow.Helpers Namespace


BrowsePrevPageButtonClick Method

AuctionHelpers..::..BrowsePrevPageButtonClick Method

Browses the previous page button click.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void BrowsePrevPageButtonClick()
Public Shared Sub BrowsePrevPageButtonClick
public:
static void BrowsePrevPageButtonClick()

See Also

AuctionHelpers Class
wManager.Wow.Helpers Namespace


BrowsePrevPageButtonIsEnabled Method

AuctionHelpers..::..BrowsePrevPageButtonIsEnabled Method

Browses the previous page button is enabled.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool BrowsePrevPageButtonIsEnabled()
Public Shared Function BrowsePrevPageButtonIsEnabled As Boolean
public:
static bool^ BrowsePrevPageButtonIsEnabled()

See Also

AuctionHelpers Class
wManager.Wow.Helpers Namespace


BrowseRaritySet Method

AuctionHelpers..::..BrowseRaritySet Method

Browses the rarity set.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void BrowseRaritySet(
    AuctionHelpers..::..Rarity rarity
)
Public Shared Sub BrowseRaritySet ( _
    rarity As AuctionHelpers..::..Rarity _
)
public:
static void BrowseRaritySet(
    AuctionHelpers..::..Rarity^ rarity
)

Parameters

rarity
Type: wManager.Wow.Helpers..::..AuctionHelpers..::..Rarity
The rarity.

See Also

AuctionHelpers Class
wManager.Wow.Helpers Namespace


BrowseSearchButtonClick Method

AuctionHelpers..::..BrowseSearchButtonClick Method

Browses the search button click.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void BrowseSearchButtonClick()
Public Shared Sub BrowseSearchButtonClick
public:
static void BrowseSearchButtonClick()

See Also

AuctionHelpers Class
wManager.Wow.Helpers Namespace


BrowseSearchButtonIsEnabled Method

AuctionHelpers..::..BrowseSearchButtonIsEnabled Method

Browses the search button is enabled.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool BrowseSearchButtonIsEnabled()
Public Shared Function BrowseSearchButtonIsEnabled As Boolean
public:
static bool^ BrowseSearchButtonIsEnabled()

See Also

AuctionHelpers Class
wManager.Wow.Helpers Namespace


BuyoutBidPopupAcceptClick Method

AuctionHelpers..::..BuyoutBidPopupAcceptClick Method

Buyouts the bid popup accept click.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void BuyoutBidPopupAcceptClick()
Public Shared Sub BuyoutBidPopupAcceptClick
public:
static void BuyoutBidPopupAcceptClick()

See Also

AuctionHelpers Class
wManager.Wow.Helpers Namespace


BuyoutBidPopupCancelClick Method

AuctionHelpers..::..BuyoutBidPopupCancelClick Method

Buyouts the bid popup cancel click.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void BuyoutBidPopupCancelClick()
Public Shared Sub BuyoutBidPopupCancelClick
public:
static void BuyoutBidPopupCancelClick()

See Also

AuctionHelpers Class
wManager.Wow.Helpers Namespace


BuyoutBidPopupIsShown Method

AuctionHelpers..::..BuyoutBidPopupIsShown Method

Buyouts the bid popup is shown.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool BuyoutBidPopupIsShown()
Public Shared Function BuyoutBidPopupIsShown As Boolean
public:
static bool^ BuyoutBidPopupIsShown()

See Also

AuctionHelpers Class
wManager.Wow.Helpers Namespace


ClearAuctionSellItem Method

AuctionHelpers..::..ClearAuctionSellItem Method

Clears the auction sell item.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void ClearAuctionSellItem()
Public Shared Sub ClearAuctionSellItem
public:
static void ClearAuctionSellItem()

See Also

AuctionHelpers Class
wManager.Wow.Helpers Namespace


CloseAuctionHouse Method

AuctionHelpers..::..CloseAuctionHouse Method

Closes the auction house.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void CloseAuctionHouse()
Public Shared Sub CloseAuctionHouse
public:
static void CloseAuctionHouse()

See Also

AuctionHelpers Class
wManager.Wow.Helpers Namespace


ExactMatchCheckButtonSetChecked Method

AuctionHelpers..::..ExactMatchCheckButtonSetChecked Method

Exacts the match check button set checked.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void ExactMatchCheckButtonSetChecked(
    bool isChecked
)
Public Shared Sub ExactMatchCheckButtonSetChecked ( _
    isChecked As Boolean _
)
public:
static void ExactMatchCheckButtonSetChecked(
    bool^ isChecked
)

Parameters

isChecked
Type: Boolean
if set to true [is checked].

See Also

AuctionHelpers Class
wManager.Wow.Helpers Namespace


GetAuctionItemTimeLeft Method

AuctionHelpers..::..GetAuctionItemTimeLeft Method

Overload List

Name | Description
GetAuctionItemTimeLeft(Int32) | Gets the auction item time left.
GetAuctionItemTimeLeft()()()() | Gets the auction item time left.

See Also

AuctionHelpers Class
AuctionHelpers Members
wManager.Wow.Helpers Namespace


GetAuctionItemTimeLeft Method (Int32)

AuctionHelpers..::..GetAuctionItemTimeLeft Method (Int32)

Gets the auction item time left.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static AuctionHelpers..::..TimeLeft GetAuctionItemTimeLeft(
    int id
)
Public Shared Function GetAuctionItemTimeLeft ( _
    id As Integer _
) As AuctionHelpers..::..TimeLeft
public:
static AuctionHelpers..::..TimeLeft^ GetAuctionItemTimeLeft(
    int^ id
)

Parameters

id
Type: Int32
The identifier.

Return Value

TimeLeft.

See Also

AuctionHelpers Class
GetAuctionItemTimeLeft Overload
wManager.Wow.Helpers Namespace


GetAuctionItemTimeLeft Method

AuctionHelpers..::..GetAuctionItemTimeLeft Method

Gets the auction item time left.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static AuctionHelpers..::..TimeLeft GetAuctionItemTimeLeft()
Public Shared Function GetAuctionItemTimeLeft As AuctionHelpers..::..TimeLeft
public:
static AuctionHelpers..::..TimeLeft^ GetAuctionItemTimeLeft()

Return Value

TimeLeft.

See Also

AuctionHelpers Class
GetAuctionItemTimeLeft Overload
wManager.Wow.Helpers Namespace


GetAuctionSellItemId Method

AuctionHelpers..::..GetAuctionSellItemId Method

Gets the auction sell item identifier.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int GetAuctionSellItemId()
Public Shared Function GetAuctionSellItemId As Integer
public:
static int^ GetAuctionSellItemId()

Return Value

System.Int32.

See Also

AuctionHelpers Class
wManager.Wow.Helpers Namespace


GetAuctionSellItemName Method

AuctionHelpers..::..GetAuctionSellItemName Method

Gets the name of the auction sell item.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string GetAuctionSellItemName()
Public Shared Function GetAuctionSellItemName As String
public:
static String^ GetAuctionSellItemName()

Return Value

System.String.

See Also

AuctionHelpers Class
wManager.Wow.Helpers Namespace


GetBrowsePageItems Method

AuctionHelpers..::..GetBrowsePageItems Method

Gets the browse page items.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<AuctionHelpers..::..AuctionItem> GetBrowsePageItems(
    string type
)
Public Shared Function GetBrowsePageItems ( _
    type As String _
) As List(Of AuctionHelpers..::..AuctionItem)
public:
static List<AuctionHelpers..::..AuctionItem^>^ GetBrowsePageItems(
    String^ type
)

Parameters

type
Type: String
The type.

Return Value

List<AuctionItem>.

See Also

AuctionHelpers Class
wManager.Wow.Helpers Namespace


GetSelectedAuctionItem Method

AuctionHelpers..::..GetSelectedAuctionItem Method

Gets the selected auction item.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int GetSelectedAuctionItem()
Public Shared Function GetSelectedAuctionItem As Integer
public:
static int^ GetSelectedAuctionItem()

Return Value

System.Int32.

See Also

AuctionHelpers Class
wManager.Wow.Helpers Namespace


IsUsableCheckButtonSetChecked Method

AuctionHelpers..::..IsUsableCheckButtonSetChecked Method

Determines whether [is usable check button set checked] [the specified is checked].

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void IsUsableCheckButtonSetChecked(
    bool isChecked
)
Public Shared Sub IsUsableCheckButtonSetChecked ( _
    isChecked As Boolean _
)
public:
static void IsUsableCheckButtonSetChecked(
    bool^ isChecked
)

Parameters

isChecked
Type: Boolean
if set to true [is checked].

See Also

AuctionHelpers Class
wManager.Wow.Helpers Namespace


PlaceAuctionBid Method

AuctionHelpers..::..PlaceAuctionBid Method

Places the auction bid.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void PlaceAuctionBid(
    int index,
    int bidPrice
)
Public Shared Sub PlaceAuctionBid ( _
    index As Integer, _
    bidPrice As Integer _
)
public:
static void PlaceAuctionBid(
    int^ index,
    int^ bidPrice
)

Parameters

index
Type: Int32
The index.
bidPrice
Type: Int32
The bid price.

See Also

AuctionHelpers Class
wManager.Wow.Helpers Namespace


PlayerAuctionsCountStacksByItemName Method

AuctionHelpers..::..PlayerAuctionsCountStacksByItemName Method

Players the name of the auctions count stacks by item.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int PlayerAuctionsCountStacksByItemName(
    string itemName
)
Public Shared Function PlayerAuctionsCountStacksByItemName ( _
    itemName As String _
) As Integer
public:
static int^ PlayerAuctionsCountStacksByItemName(
    String^ itemName
)

Parameters

itemName
Type: String
Name of the item.

Return Value

System.Int32.

See Also

AuctionHelpers Class
wManager.Wow.Helpers Namespace


ResetAuctionFrameBrowse Method

AuctionHelpers..::..ResetAuctionFrameBrowse Method

Resets the auction frame browse.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void ResetAuctionFrameBrowse()
Public Shared Sub ResetAuctionFrameBrowse
public:
static void ResetAuctionFrameBrowse()

See Also

AuctionHelpers Class
wManager.Wow.Helpers Namespace


SelectAuctionItem Method

AuctionHelpers..::..SelectAuctionItem Method

Selects the auction item.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool SelectAuctionItem(
    int id
)
Public Shared Function SelectAuctionItem ( _
    id As Integer _
) As Boolean
public:
static bool^ SelectAuctionItem(
    int^ id
)

Parameters

id
Type: Int32
The identifier.

See Also

AuctionHelpers Class
wManager.Wow.Helpers Namespace


SelectAuctionsTab Method

AuctionHelpers..::..SelectAuctionsTab Method

Selects the auctions tab.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void SelectAuctionsTab()
Public Shared Sub SelectAuctionsTab
public:
static void SelectAuctionsTab()

See Also

AuctionHelpers Class
wManager.Wow.Helpers Namespace


SelectBidsTab Method

AuctionHelpers..::..SelectBidsTab Method

Selects the bids tab.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void SelectBidsTab()
Public Shared Sub SelectBidsTab
public:
static void SelectBidsTab()

See Also

AuctionHelpers Class
wManager.Wow.Helpers Namespace


SelectBrowseTab Method

AuctionHelpers..::..SelectBrowseTab Method

Selects the browse tab.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void SelectBrowseTab()
Public Shared Sub SelectBrowseTab
public:
static void SelectBrowseTab()

See Also

AuctionHelpers Class
wManager.Wow.Helpers Namespace


SetAuctionSellItem Method

AuctionHelpers..::..SetAuctionSellItem Method

Sets the auction sell item.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool SetAuctionSellItem(
    string itemName
)
Public Shared Function SetAuctionSellItem ( _
    itemName As String _
) As Boolean
public:
static bool^ SetAuctionSellItem(
    String^ itemName
)

Parameters

itemName
Type: String
Name of the item.

See Also

AuctionHelpers Class
wManager.Wow.Helpers Namespace


StartAuction Method

AuctionHelpers..::..StartAuction Method

Starts the auction.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void StartAuction(
    int minBid,
    int buyoutPrice,
    AuctionHelpers..::..Duration runTime,
    int stackSize,
    int numStacks
)
Public Shared Sub StartAuction ( _
    minBid As Integer, _
    buyoutPrice As Integer, _
    runTime As AuctionHelpers..::..Duration, _
    stackSize As Integer, _
    numStacks As Integer _
)
public:
static void StartAuction(
    int^ minBid,
    int^ buyoutPrice,
    AuctionHelpers..::..Duration^ runTime,
    int^ stackSize,
    int^ numStacks
)

Parameters

minBid
Type: Int32
The minimum bid.
buyoutPrice
Type: Int32
The buyout price.
runTime
Type: wManager.Wow.Helpers..::..AuctionHelpers..::..Duration
The run time.
stackSize
Type: Int32
Size of the stack.
numStacks
Type: Int32
The number stacks.

See Also

AuctionHelpers Class
wManager.Wow.Helpers Namespace


WaitInSearch Method

AuctionHelpers..::..WaitInSearch Method

Waits the in search.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void WaitInSearch()
Public Shared Sub WaitInSearch
public:
static void WaitInSearch()

See Also

AuctionHelpers Class
wManager.Wow.Helpers Namespace


AuctionHelpers.AuctionItem Class

AuctionHelpers..::..AuctionItem Class

Class AuctionItem.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class AuctionItem
Public Class AuctionItem
public ref class AuctionItem

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..AuctionHelpers..::..AuctionItem

See Also

AuctionHelpers..::..AuctionItem Members
wManager.Wow.Helpers Namespace


AuctionHelpers.AuctionItem Members

AuctionHelpers..::..AuctionItem Members

The AuctionHelpers..::..AuctionItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IsValid | Returns true if ... is valid.
Protected method | MemberwiseClone | (Inherited from Object.)
 | Parse | Parses the specified lua export.
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | BuyoutPrice | The buyout price
Public field | Count | The count
Public field | IAmHighBidder | The i am high bidder
Public field | Id | The identifier
Public field | IsSold | The is sold
Public field | ItemId | The item id
Public field | Name | The name
Public field | OwnerName | The owner name

Properties

 | Name | Description
Public property | BidPrice | Gets the bid price.
Public property | BidPricePerUnit | Gets the bid price per unit.
Public property | BuyoutPricePerUnit | Gets the buyout price per unit.

See Also

AuctionHelpers..::..AuctionItem Class
wManager.Wow.Helpers Namespace


AuctionHelpers.AuctionItem Fields

AuctionHelpers..::..AuctionItem Fields

The AuctionHelpers..::..AuctionItem type exposes the following members.

Fields

 | Name | Description
Public field | BuyoutPrice | The buyout price
Public field | Count | The count
Public field | IAmHighBidder | The i am high bidder
Public field | Id | The identifier
Public field | IsSold | The is sold
Public field | ItemId | The item id
Public field | Name | The name
Public field | OwnerName | The owner name

See Also

AuctionHelpers..::..AuctionItem Class
wManager.Wow.Helpers Namespace


BuyoutPrice Field

AuctionItem..::..BuyoutPrice Field

The buyout price

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int BuyoutPrice
Public BuyoutPrice As Integer
public:
int^ BuyoutPrice

See Also

AuctionHelpers..::..AuctionItem Class
wManager.Wow.Helpers Namespace


Count Field

AuctionItem..::..Count Field

The count

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int Count
Public Count As Integer
public:
int^ Count

See Also

AuctionHelpers..::..AuctionItem Class
wManager.Wow.Helpers Namespace


IAmHighBidder Field

AuctionItem..::..IAmHighBidder Field

The i am high bidder

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IAmHighBidder
Public IAmHighBidder As Boolean
public:
bool^ IAmHighBidder

See Also

AuctionHelpers..::..AuctionItem Class
wManager.Wow.Helpers Namespace


Id Field

AuctionItem..::..Id Field

The identifier

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int Id
Public Id As Integer
public:
int^ Id

See Also

AuctionHelpers..::..AuctionItem Class
wManager.Wow.Helpers Namespace


IsSold Field

AuctionItem..::..IsSold Field

The is sold

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsSold
Public IsSold As Boolean
public:
bool^ IsSold

See Also

AuctionHelpers..::..AuctionItem Class
wManager.Wow.Helpers Namespace


ItemId Field

AuctionItem..::..ItemId Field

The item id

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int ItemId
Public ItemId As Integer
public:
int^ ItemId

See Also

AuctionHelpers..::..AuctionItem Class
wManager.Wow.Helpers Namespace


Name Field

AuctionItem..::..Name Field

The name

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string Name
Public Name As String
public:
String^ Name

See Also

AuctionHelpers..::..AuctionItem Class
wManager.Wow.Helpers Namespace


OwnerName Field

AuctionItem..::..OwnerName Field

The owner name

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string OwnerName
Public OwnerName As String
public:
String^ OwnerName

See Also

AuctionHelpers..::..AuctionItem Class
wManager.Wow.Helpers Namespace


AuctionHelpers.AuctionItem Methods

AuctionHelpers..::..AuctionItem Methods

The AuctionHelpers..::..AuctionItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IsValid | Returns true if ... is valid.
Protected method | MemberwiseClone | (Inherited from Object.)
 | Parse | Parses the specified lua export.
Public method | ToString | (Inherited from Object.)

See Also

AuctionHelpers..::..AuctionItem Class
wManager.Wow.Helpers Namespace


IsValid Method

AuctionItem..::..IsValid Method

Returns true if ... is valid.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsValid()
Public Function IsValid As Boolean
public:
bool^ IsValid()

Return Value

true if this instance is valid; otherwise, false.

See Also

AuctionHelpers..::..AuctionItem Class
wManager.Wow.Helpers Namespace


Parse Method

AuctionItem..::..Parse Method

Parses the specified lua export.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static AuctionHelpers..::..AuctionItem Parse(
    string luaExport
)
Public Shared Function Parse ( _
    luaExport As String _
) As AuctionHelpers..::..AuctionItem
public:
static AuctionHelpers..::..AuctionItem^ Parse(
    String^ luaExport
)

Parameters

luaExport
Type: String
The lua export.

Return Value

AuctionItem.

See Also

AuctionHelpers..::..AuctionItem Class
wManager.Wow.Helpers Namespace


AuctionHelpers.AuctionItem Properties

AuctionHelpers..::..AuctionItem Properties

The AuctionHelpers..::..AuctionItem type exposes the following members.

Properties

 | Name | Description
Public property | BidPrice | Gets the bid price.
Public property | BidPricePerUnit | Gets the bid price per unit.
Public property | BuyoutPricePerUnit | Gets the buyout price per unit.

See Also

AuctionHelpers..::..AuctionItem Class
wManager.Wow.Helpers Namespace


BidPrice Property

AuctionItem..::..BidPrice Property

Gets the bid price.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int BidPrice { get; }
Public ReadOnly Property BidPrice As Integer
    Get
public:
property int^ BidPrice {
    int^ get ();
}

Field Value

The bid price.

See Also

AuctionHelpers..::..AuctionItem Class
wManager.Wow.Helpers Namespace


BidPricePerUnit Property

AuctionItem..::..BidPricePerUnit Property

Gets the bid price per unit.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int BidPricePerUnit { get; }
Public ReadOnly Property BidPricePerUnit As Integer
    Get
public:
property int^ BidPricePerUnit {
    int^ get ();
}

Field Value

The bid price per unit.

See Also

AuctionHelpers..::..AuctionItem Class
wManager.Wow.Helpers Namespace


BuyoutPricePerUnit Property

AuctionItem..::..BuyoutPricePerUnit Property

Gets the buyout price per unit.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int BuyoutPricePerUnit { get; }
Public ReadOnly Property BuyoutPricePerUnit As Integer
    Get
public:
property int^ BuyoutPricePerUnit {
    int^ get ();
}

Field Value

The buyout price per unit.

See Also

AuctionHelpers..::..AuctionItem Class
wManager.Wow.Helpers Namespace


AuctionHelpers.Duration Enumeration

AuctionHelpers..::..Duration Enumeration

Auction duration

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public enum Duration
Public Enumeration Duration
public enum class Duration

Members

Member name | Description
_12H |
_24H |
_48H |

See Also

wManager.Wow.Helpers Namespace


AuctionHelpers.Filters Enumeration

AuctionHelpers..::..Filters Enumeration

Auction search item filters

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public enum Filters
Public Enumeration Filters
public enum class Filters

Members

Member name | Description
None |
Weapon |
Armor |
Container |
Consumable |
Glyph |
TradeGoods |
Recipe |
Gem |
Miscellaneous |
Quest |
BattlePets |
GameTime |

See Also

wManager.Wow.Helpers Namespace


AuctionHelpers.Rarity Enumeration

AuctionHelpers..::..Rarity Enumeration

Auction search item rarity

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public enum Rarity
Public Enumeration Rarity
public enum class Rarity

Members

Member name | Description
All |
Poor |
Common |
Uncommon |
Rare |
Epic |
Legendary |
Artifact |

See Also

wManager.Wow.Helpers Namespace


AuctionHelpers.TimeLeft Enumeration

AuctionHelpers..::..TimeLeft Enumeration

Auction time left

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public enum TimeLeft
Public Enumeration TimeLeft
public enum class TimeLeft

Members

Member name | Description
None |
Short |
Medium |
Long |
VeryLong |

See Also

wManager.Wow.Helpers Namespace


Bag Class

Class Bag. Methods useful to manage game bags.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class Bag
Public Class Bag
public ref class Bag

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..Bag

See Also

Bag Members
wManager.Wow.Helpers Namespace


Bag Members

The Bag type exposes the following members.

Methods

 | Name | Description
 | BagCount | Count number of bags equipped
 | CloseAllBags | Closes all bags.
Public method | Equals(System.Object) | (Inherited from Object.)
 | EquipAvailableBagIfFreeContainerSlot | Equips the best available bag if free container slot.
Protected method | Finalize | (Inherited from Object.)
 | ForceResetNumFreeSlotsCache | Forces the reset cache of GetContainerNumFreeSlots and GetContainerNumFreeSlotsNormalType
 | GetBagItem | Gets the bag item.
 | GetContainerItemCooldown(Int32) | Gets the container item cooldown.
 | GetContainerItemCooldown(String) | Gets the container item cooldown.
 | GetContainerItemCooldown(List<(Of <<'(Int32>)>>)) | Gets the container item cooldown.
 | GetContainerItemCooldown(Int32, Int32) | Gets the container item cooldown.
 | GetContainerNumFreeSlotsByBagID(Int32) | Get number of free slots by container id
 | GetContainerNumFreeSlotsByBagID(Int32, BagType%) | Get number of free slots and type by container id
 | GetContainerNumFreeSlotsByType | Get number of free slots by container type.
Public method | GetHashCode | (Inherited from Object.)
 | GetItemContainerBagIdAndSlot(Int32) | Get container bag id and bag slot id which contains the chosen item
 | GetItemContainerBagIdAndSlot(String) | Get container bag id and bag slot id which contains the chosen item
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
 | OpenAllBags | Opens all bags.
 | PickupContainerItem(Int32) | Pickups the container item.
 | PickupContainerItem(String) | Pickups the container item.
 | PickupContainerItem(List<(Of <<'(Int32>)>>)) | Pickups the container item.
 | PickupContainerItem(Int32, Int32) | Pickups the container item.
 | PutSelectedItemInBag | Puts the selected item in bag.
Public method | ToString | (Inherited from Object.)

Properties

Name | Description
GetContainerNumFreeSlots | Get containers number of free slots.
GetContainerNumFreeSlotsHerbBags | Get number of free slots on herb container type.
GetContainerNumFreeSlotsMiningBags | Get number of free slots on mining container type.
GetContainerNumFreeSlotsNormalType | Get number of free slots on normal container type.

See Also

Bag Class
wManager.Wow.Helpers Namespace


Bag Methods

The Bag type exposes the following members.

Methods

 | Name | Description
 | BagCount | Count number of bags equipped
 | CloseAllBags | Closes all bags.
Public method | Equals(System.Object) | (Inherited from Object.)
 | EquipAvailableBagIfFreeContainerSlot | Equips the best available bag if free container slot.
Protected method | Finalize | (Inherited from Object.)
 | ForceResetNumFreeSlotsCache | Forces the reset cache of GetContainerNumFreeSlots and GetContainerNumFreeSlotsNormalType
 | GetBagItem | Gets the bag item.
 | GetContainerItemCooldown(Int32) | Gets the container item cooldown.
 | GetContainerItemCooldown(String) | Gets the container item cooldown.
 | GetContainerItemCooldown(List<(Of <<'(Int32>)>>)) | Gets the container item cooldown.
 | GetContainerItemCooldown(Int32, Int32) | Gets the container item cooldown.
 | GetContainerNumFreeSlotsByBagID(Int32) | Get number of free slots by container id
 | GetContainerNumFreeSlotsByBagID(Int32, BagType%) | Get number of free slots and type by container id
 | GetContainerNumFreeSlotsByType | Get number of free slots by container type.
Public method | GetHashCode | (Inherited from Object.)
 | GetItemContainerBagIdAndSlot(Int32) | Get container bag id and bag slot id which contains the chosen item
 | GetItemContainerBagIdAndSlot(String) | Get container bag id and bag slot id which contains the chosen item
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
 | OpenAllBags | Opens all bags.
 | PickupContainerItem(Int32) | Pickups the container item.
 | PickupContainerItem(String) | Pickups the container item.
 | PickupContainerItem(List<(Of <<'(Int32>)>>)) | Pickups the container item.
 | PickupContainerItem(Int32, Int32) | Pickups the container item.
 | PutSelectedItemInBag | Puts the selected item in bag.
Public method | ToString | (Inherited from Object.)

See Also

Bag Class
wManager.Wow.Helpers Namespace


BagCount Method

Bag..::..BagCount Method

Count number of bags equipped

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int BagCount()
Public Shared Function BagCount As Integer
public:
static int^ BagCount()

Return Value

System.Int32.

See Also

Bag Class
wManager.Wow.Helpers Namespace


CloseAllBags Method

Bag..::..CloseAllBags Method

Closes all bags.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void CloseAllBags()
Public Shared Sub CloseAllBags
public:
static void CloseAllBags()

See Also

Bag Class
wManager.Wow.Helpers Namespace


EquipAvailableBagIfFreeContainerSlot Method

Bag..::..EquipAvailableBagIfFreeContainerSlot Method

Equips the best available bag if free container slot.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool EquipAvailableBagIfFreeContainerSlot()
Public Shared Function EquipAvailableBagIfFreeContainerSlot As Boolean
public:
static bool^ EquipAvailableBagIfFreeContainerSlot()

Return Value

true if bag equipped, false otherwise.

See Also

Bag Class
wManager.Wow.Helpers Namespace


ForceResetNumFreeSlotsCache Method

Bag..::..ForceResetNumFreeSlotsCache Method

Forces the reset cache of GetContainerNumFreeSlots and GetContainerNumFreeSlotsNormalType

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void ForceResetNumFreeSlotsCache()
Public Shared Sub ForceResetNumFreeSlotsCache
public:
static void ForceResetNumFreeSlotsCache()

See Also

Bag Class
wManager.Wow.Helpers Namespace


GetBagItem Method

Bag..::..GetBagItem Method

Gets the bag item.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWItem> GetBagItem()
Public Shared Function GetBagItem As List(Of WoWItem)
public:
static List<WoWItem^>^ GetBagItem()

Return Value

List<WoWItem>.

See Also

Bag Class
wManager.Wow.Helpers Namespace


GetContainerItemCooldown Method

Bag..::..GetContainerItemCooldown Method

Overload List

Name | Description
GetContainerItemCooldown(Int32) | Gets the container item cooldown.
GetContainerItemCooldown(String) | Gets the container item cooldown.
GetContainerItemCooldown(List<(Of <<'(Int32>)>>)) | Gets the container item cooldown.
GetContainerItemCooldown(Int32, Int32) | Gets the container item cooldown.

See Also

Bag Class
Bag Members
wManager.Wow.Helpers Namespace


GetContainerItemCooldown Method (Int32)

Bag..::..GetContainerItemCooldown Method (Int32)

Gets the container item cooldown.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int GetContainerItemCooldown(
    int itemId
)
Public Shared Function GetContainerItemCooldown ( _
    itemId As Integer _
) As Integer
public:
static int^ GetContainerItemCooldown(
    int^ itemId
)

Parameters

itemId
Type: Int32
The item id.

Return Value

System.Int32.

See Also

Bag Class
GetContainerItemCooldown Overload
wManager.Wow.Helpers Namespace


GetContainerItemCooldown Method (String)

Bag..::..GetContainerItemCooldown Method (String)

Gets the container item cooldown.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int GetContainerItemCooldown(
    string itemName
)
Public Shared Function GetContainerItemCooldown ( _
    itemName As String _
) As Integer
public:
static int^ GetContainerItemCooldown(
    String^ itemName
)

Parameters

itemName
Type: String
Name of the item.

Return Value

System.Int32.

See Also

Bag Class
GetContainerItemCooldown Overload
wManager.Wow.Helpers Namespace


GetContainerItemCooldown Method (List(Int32))

Bag..::..GetContainerItemCooldown Method (List<(Of <(<'Int32>)>)>)

Gets the container item cooldown.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int GetContainerItemCooldown(
    List<int> bagAndSlot
)
Public Shared Function GetContainerItemCooldown ( _
    bagAndSlot As List(Of Integer) _
) As Integer
public:
static int^ GetContainerItemCooldown(
    List<int^>^ bagAndSlot
)

Parameters

bagAndSlot
Type: List <(Of <(<' Int32 >)>)>
The bag and slot.

Return Value

System.Int32.

See Also

Bag Class
GetContainerItemCooldown Overload
wManager.Wow.Helpers Namespace


GetContainerItemCooldown Method (Int32, Int32)

Bag..::..GetContainerItemCooldown Method (Int32, Int32)

Gets the container item cooldown.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int GetContainerItemCooldown(
    int bagId,
    int slotId
)
Public Shared Function GetContainerItemCooldown ( _
    bagId As Integer, _
    slotId As Integer _
) As Integer
public:
static int^ GetContainerItemCooldown(
    int^ bagId,
    int^ slotId
)

Parameters

bagId
Type: Int32
The bag identifier.
slotId
Type: Int32
The slot identifier.

Return Value

System.Int32.

See Also

Bag Class
GetContainerItemCooldown Overload
wManager.Wow.Helpers Namespace


GetContainerNumFreeSlotsByBagID Method

Bag..::..GetContainerNumFreeSlotsByBagID Method

Overload List

Name | Description
GetContainerNumFreeSlotsByBagID(Int32) | Get number of free slots by container id
GetContainerNumFreeSlotsByBagID(Int32, BagType%) | Get number of free slots and type by container id

See Also

Bag Class
Bag Members
wManager.Wow.Helpers Namespace


GetContainerNumFreeSlotsByBagID Method (Int32)

Bag..::..GetContainerNumFreeSlotsByBagID Method (Int32)

Get number of free slots by container id

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int GetContainerNumFreeSlotsByBagID(
    int bagID
)
Public Shared Function GetContainerNumFreeSlotsByBagID ( _
    bagID As Integer _
) As Integer
public:
static int^ GetContainerNumFreeSlotsByBagID(
    int^ bagID
)

Parameters

bagID
Type: Int32
The bag id.

Return Value

System.Int32.

See Also

Bag Class
GetContainerNumFreeSlotsByBagID Overload
wManager.Wow.Helpers Namespace


GetContainerNumFreeSlotsByBagID Method (Int32, BagType)

Bag..::..GetContainerNumFreeSlotsByBagID Method (Int32, BagType%)

Get number of free slots and type by container id

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int GetContainerNumFreeSlotsByBagID(
    int bagID,
    out BagType bagType
)
Public Shared Function GetContainerNumFreeSlotsByBagID ( _
    bagID As Integer, _
    <OutAttribute> ByRef bagType As BagType _
) As Integer
public:
static int^ GetContainerNumFreeSlotsByBagID(
    int^ bagID,
    [OutAttribute] BagType^% bagType
)

Parameters

bagID
Type: Int32
The bag id.
bagType
Type: wManager.Wow.Enums..::..BagType %
Type of the bag.

Return Value

System.Int32.

See Also

Bag Class
GetContainerNumFreeSlotsByBagID Overload
wManager.Wow.Helpers Namespace


GetContainerNumFreeSlotsByType Method

Bag..::..GetContainerNumFreeSlotsByType Method

Get number of free slots by container type.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int GetContainerNumFreeSlotsByType(
    BagType bagType
)
Public Shared Function GetContainerNumFreeSlotsByType ( _
    bagType As BagType _
) As Integer
public:
static int^ GetContainerNumFreeSlotsByType(
    BagType^ bagType
)

Parameters

bagType
Type: wManager.Wow.Enums..::..BagType
Type of the bag.

Return Value

System.Int32.

See Also

Bag Class
wManager.Wow.Helpers Namespace


GetItemContainerBagIdAndSlot Method

Bag..::..GetItemContainerBagIdAndSlot Method

Overload List

Name | Description
GetItemContainerBagIdAndSlot(Int32) | Get container bag id and bag slot id which contains the chosen item
GetItemContainerBagIdAndSlot(String) | Get container bag id and bag slot id which contains the chosen item

See Also

Bag Class
Bag Members
wManager.Wow.Helpers Namespace


GetItemContainerBagIdAndSlot Method (Int32)

Bag..::..GetItemContainerBagIdAndSlot Method (Int32)

Get container bag id and bag slot id which contains the chosen item

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<int> GetItemContainerBagIdAndSlot(
    int itemId
)
Public Shared Function GetItemContainerBagIdAndSlot ( _
    itemId As Integer _
) As List(Of Integer)
public:
static List<int^>^ GetItemContainerBagIdAndSlot(
    int^ itemId
)

Parameters

itemId
Type: Int32
The item id.

Return Value

List<System.Int32>.

See Also

Bag Class
GetItemContainerBagIdAndSlot Overload
wManager.Wow.Helpers Namespace


GetItemContainerBagIdAndSlot Method (String)

Bag..::..GetItemContainerBagIdAndSlot Method (String)

Get container bag id and bag slot id which contains the chosen item

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<int> GetItemContainerBagIdAndSlot(
    string itemName
)
Public Shared Function GetItemContainerBagIdAndSlot ( _
    itemName As String _
) As List(Of Integer)
public:
static List<int^>^ GetItemContainerBagIdAndSlot(
    String^ itemName
)

Parameters

itemName
Type: String
Name of the item.

Return Value

List<System.Int32>.

See Also

Bag Class
GetItemContainerBagIdAndSlot Overload
wManager.Wow.Helpers Namespace


OpenAllBags Method

Bag..::..OpenAllBags Method

Opens all bags.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void OpenAllBags()
Public Shared Sub OpenAllBags
public:
static void OpenAllBags()

See Also

Bag Class
wManager.Wow.Helpers Namespace


PickupContainerItem Method

Bag..::..PickupContainerItem Method

Overload List

Name | Description
PickupContainerItem(Int32) | Pickups the container item.
PickupContainerItem(String) | Pickups the container item.
PickupContainerItem(List<(Of <<'(Int32>)>>)) | Pickups the container item.
PickupContainerItem(Int32, Int32) | Pickups the container item.

See Also

Bag Class
Bag Members
wManager.Wow.Helpers Namespace


PickupContainerItem Method (Int32)

Bag..::..PickupContainerItem Method (Int32)

Pickups the container item.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void PickupContainerItem(
    int itemId
)
Public Shared Sub PickupContainerItem ( _
    itemId As Integer _
)
public:
static void PickupContainerItem(
    int^ itemId
)

Parameters

itemId
Type: Int32
The item id.

See Also

Bag Class
PickupContainerItem Overload
wManager.Wow.Helpers Namespace


PickupContainerItem Method (String)

Bag..::..PickupContainerItem Method (String)

Pickups the container item.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void PickupContainerItem(
    string itemName
)
Public Shared Sub PickupContainerItem ( _
    itemName As String _
)
public:
static void PickupContainerItem(
    String^ itemName
)

Parameters

itemName
Type: String
Name of the item.

See Also

Bag Class
PickupContainerItem Overload
wManager.Wow.Helpers Namespace


PickupContainerItem Method (List(Int32))

Bag..::..PickupContainerItem Method (List<(Of <(<'Int32>)>)>)

Pickups the container item.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void PickupContainerItem(
    List<int> bagAndSlot
)
Public Shared Sub PickupContainerItem ( _
    bagAndSlot As List(Of Integer) _
)
public:
static void PickupContainerItem(
    List<int^>^ bagAndSlot
)

Parameters

bagAndSlot
Type: List <(Of <(<' Int32 >)>)>
The bag and slot.

See Also

Bag Class
PickupContainerItem Overload
wManager.Wow.Helpers Namespace


PickupContainerItem Method (Int32, Int32)

Bag..::..PickupContainerItem Method (Int32, Int32)

Pickups the container item.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void PickupContainerItem(
    int bagId,
    int slotId
)
Public Shared Sub PickupContainerItem ( _
    bagId As Integer, _
    slotId As Integer _
)
public:
static void PickupContainerItem(
    int^ bagId,
    int^ slotId
)

Parameters

bagId
Type: Int32
The bag id.
slotId
Type: Int32
The bag slot id.

See Also

Bag Class
PickupContainerItem Overload
wManager.Wow.Helpers Namespace


PutSelectedItemInBag Method

Bag..::..PutSelectedItemInBag Method

Puts the selected item in bag.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void PutSelectedItemInBag()
Public Shared Sub PutSelectedItemInBag
public:
static void PutSelectedItemInBag()

See Also

Bag Class
wManager.Wow.Helpers Namespace


Bag Properties

The Bag type exposes the following members.

Properties

Name | Description
GetContainerNumFreeSlots | Get containers number of free slots.
GetContainerNumFreeSlotsHerbBags | Get number of free slots on herb container type.
GetContainerNumFreeSlotsMiningBags | Get number of free slots on mining container type.
GetContainerNumFreeSlotsNormalType | Get number of free slots on normal container type.

See Also

Bag Class
wManager.Wow.Helpers Namespace


GetContainerNumFreeSlots Property

Bag..::..GetContainerNumFreeSlots Property

Get containers number of free slots.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int GetContainerNumFreeSlots { get; }
Public Shared ReadOnly Property GetContainerNumFreeSlots As Integer
    Get
public:
static property int^ GetContainerNumFreeSlots {
    int^ get ();
}

See Also

Bag Class
wManager.Wow.Helpers Namespace


GetContainerNumFreeSlotsHerbBags Property

Bag..::..GetContainerNumFreeSlotsHerbBags Property

Get number of free slots on herb container type.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int GetContainerNumFreeSlotsHerbBags { get; }
Public Shared ReadOnly Property GetContainerNumFreeSlotsHerbBags As Integer
    Get
public:
static property int^ GetContainerNumFreeSlotsHerbBags {
    int^ get ();
}

See Also

Bag Class
wManager.Wow.Helpers Namespace


GetContainerNumFreeSlotsMiningBags Property

Bag..::..GetContainerNumFreeSlotsMiningBags Property

Get number of free slots on mining container type.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int GetContainerNumFreeSlotsMiningBags { get; }
Public Shared ReadOnly Property GetContainerNumFreeSlotsMiningBags As Integer
    Get
public:
static property int^ GetContainerNumFreeSlotsMiningBags {
    int^ get ();
}

See Also

Bag Class
wManager.Wow.Helpers Namespace


GetContainerNumFreeSlotsNormalType Property

Bag..::..GetContainerNumFreeSlotsNormalType Property

Get number of free slots on normal container type.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int GetContainerNumFreeSlotsNormalType { get; }
Public Shared ReadOnly Property GetContainerNumFreeSlotsNormalType As Integer
    Get
public:
static property int^ GetContainerNumFreeSlotsNormalType {
    int^ get ();
}

See Also

Bag Class
wManager.Wow.Helpers Namespace


Battleground Class

Class Battleground. Useful methods to manage battleground.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class Battleground
Public Class Battleground
public ref class Battleground

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..Battleground

See Also

Battleground Members
wManager.Wow.Helpers Namespace


Battleground Members

The Battleground type exposes the following members.

Methods

 | Name | Description
 | AcceptBattlefieldPort | Confirms entry into a Battleground you are queued for that is ready.
 | AcceptBattlefieldPortAll | Accept all AcceptBattlefieldPort(Int32, Boolean) index.
 | BattlefieldStatusQueued | Status of battleground queue (value can change on several game version, but example 0 generally means that the bot is not in the queue and not in battleground).
 | BattlegroundIsStarted | Battleground is started.
Public method | Equals(System.Object) | (Inherited from Object.)
 | ExitBattleGround | Leaves the current battlefield.
Protected method | Finalize | (Inherited from Object.)
 | GetCurrentBattleground | Get the current battleground ID.
Public method | GetHashCode | (Inherited from Object.)
 | GetNumberActiveQueue | Gets the number active battleground queue.
Public method | GetType | (Inherited from Object.)
 | IsFinishBattleGround | Determines whether battleground is finish.
 | IsInBattleground | Determine whether is in battleground.
 | JointBattleGroundQueue | Queues the player, or the player's group, for a battlefield instance.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Battleground Class
wManager.Wow.Helpers Namespace


Battleground Methods

The Battleground type exposes the following members.

Methods

 | Name | Description
 | AcceptBattlefieldPort | Confirms entry into a Battleground you are queued for that is ready.
 | AcceptBattlefieldPortAll | Accept all AcceptBattlefieldPort(Int32, Boolean) index.
 | BattlefieldStatusQueued | Status of battleground queue (value can change on several game version, but example 0 generally means that the bot is not in the queue and not in battleground).
 | BattlegroundIsStarted | Battleground is started.
Public method | Equals(System.Object) | (Inherited from Object.)
 | ExitBattleGround | Leaves the current battlefield.
Protected method | Finalize | (Inherited from Object.)
 | GetCurrentBattleground | Get the current battleground ID.
Public method | GetHashCode | (Inherited from Object.)
 | GetNumberActiveQueue | Gets the number active battleground queue.
Public method | GetType | (Inherited from Object.)
 | IsFinishBattleGround | Determines whether battleground is finish.
 | IsInBattleground | Determine whether is in battleground.
 | JointBattleGroundQueue | Queues the player, or the player's group, for a battlefield instance.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Battleground Class
wManager.Wow.Helpers Namespace


AcceptBattlefieldPort Method

Battleground..::..AcceptBattlefieldPort Method

Confirms entry into a Battleground you are queued for that is ready.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void AcceptBattlefieldPort(
    int index,
    bool accept
)
Public Shared Sub AcceptBattlefieldPort ( _
    index As Integer, _
    accept As Boolean _
)
public:
static void AcceptBattlefieldPort(
    int^ index,
    bool^ accept
)

Parameters

index
Type: Int32
The battlefield in queue to enter.
accept
Type: Boolean
Whether or not to accept entry to the battlefield.

See Also

Battleground Class
wManager.Wow.Helpers Namespace


AcceptBattlefieldPortAll Method

Battleground..::..AcceptBattlefieldPortAll Method

Accept all AcceptBattlefieldPort(Int32, Boolean) index.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void AcceptBattlefieldPortAll()
Public Shared Sub AcceptBattlefieldPortAll
public:
static void AcceptBattlefieldPortAll()

See Also

Battleground Class
wManager.Wow.Helpers Namespace


BattlefieldStatusQueued Method

Battleground..::..BattlefieldStatusQueued Method

Status of battleground queue (value can change on several game version, but example 0 generally means that the bot is not in the queue and not in battleground).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool BattlefieldStatusQueued()
Public Shared Function BattlefieldStatusQueued As Boolean
public:
static bool^ BattlefieldStatusQueued()

Return Value

System.Int32.

See Also

Battleground Class
wManager.Wow.Helpers Namespace


BattlegroundIsStarted Method

Battleground..::..BattlegroundIsStarted Method

Battleground is started.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool BattlegroundIsStarted()
Public Shared Function BattlegroundIsStarted As Boolean
public:
static bool^ BattlegroundIsStarted()

Return Value

true if is started (doors open), false otherwise.

See Also

Battleground Class
wManager.Wow.Helpers Namespace


ExitBattleGround Method

Battleground..::..ExitBattleGround Method

Leaves the current battlefield.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void ExitBattleGround()
Public Shared Sub ExitBattleGround
public:
static void ExitBattleGround()

See Also

Battleground Class
wManager.Wow.Helpers Namespace


GetCurrentBattleground Method

Battleground..::..GetCurrentBattleground Method

Get the current battleground ID.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static BattleGroundID GetCurrentBattleground()
Public Shared Function GetCurrentBattleground As BattleGroundID
public:
static BattleGroundID^ GetCurrentBattleground()

Return Value

BattleGroundID.

See Also

Battleground Class
wManager.Wow.Helpers Namespace


GetNumberActiveQueue Method

Battleground..::..GetNumberActiveQueue Method

Gets the number active battleground queue.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int GetNumberActiveQueue()
Public Shared Function GetNumberActiveQueue As Integer
public:
static int^ GetNumberActiveQueue()

Return Value

System.Int32.

See Also

Battleground Class
wManager.Wow.Helpers Namespace


IsFinishBattleGround Method

Battleground..::..IsFinishBattleGround Method

Determines whether battleground is finish.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool IsFinishBattleGround()
Public Shared Function IsFinishBattleGround As Boolean
public:
static bool^ IsFinishBattleGround()

Return Value

true if battleground is finish otherwise, false.

See Also

Battleground Class
wManager.Wow.Helpers Namespace


IsInBattleground Method

Battleground..::..IsInBattleground Method

Determine whether is in battleground.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool IsInBattleground()
Public Shared Function IsInBattleground As Boolean
public:
static bool^ IsInBattleground()

Return Value

true if is in battleground otherwise, false.

See Also

Battleground Class
wManager.Wow.Helpers Namespace


JointBattleGroundQueue Method

Battleground..::..JointBattleGroundQueue Method

Queues the player, or the player's group, for a battlefield instance.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void JointBattleGroundQueue(
    BattleGroundID id,
    bool asGroup
)
Public Shared Sub JointBattleGroundQueue ( _
    id As BattleGroundID, _
    asGroup As Boolean _
)
public:
static void JointBattleGroundQueue(
    BattleGroundID^ id,
    bool^ asGroup
)

Parameters

id
Type: wManager.Wow.Enums..::..BattleGroundID
Which battlefield instance to queue for (0 for first available), or which arena bracket to queue for.
asGroup
Type: Boolean
If true-equivalent, the player's group is queued for the battlefield, otherwise, only the player is queued.

See Also

Battleground Class
wManager.Wow.Helpers Namespace


BuffManager Class

Class BuffManager. Useful to read buff/debuff list.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class BuffManager
Public NotInheritable Class BuffManager
public ref class BuffManager abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..BuffManager

See Also

BuffManager Members
wManager.Wow.Helpers Namespace


BuffManager Members

The BuffManager type exposes the following members.

Methods

Name | Description
AuraStack | Buff stack count.
CastedBy | Casted by (return Guid).
CastedByAll | Casted by all (return Guid).
GetAura(UInt32, List<(Of <<'(UInt32>)>>)) | Gets the aura by spell id.
GetAura(UInt32, UInt32) | Get the buff.
GetAuras(UInt32) | Gets the auras.
GetAuras(UInt32, List<(Of <<'(UInt32>)>>)) | Gets the auras by spell IDs.
GetAuras(UInt32, UInt32) | Get the buffs.
HaveBuff(UInt32, List<(Of <<'(UInt32>)>>)) | Have the buff.
HaveBuff(UInt32, UInt32) | Have the buff.
HaveBuffLua | Check if have buff with lua.
TimeLeft | Time left.

See Also

BuffManager Class
wManager.Wow.Helpers Namespace


BuffManager Methods

The BuffManager type exposes the following members.

Methods

Name | Description
AuraStack | Buff stack count.
CastedBy | Casted by (return Guid).
CastedByAll | Casted by all (return Guid).
GetAura(UInt32, List<(Of <<'(UInt32>)>>)) | Gets the aura by spell id.
GetAura(UInt32, UInt32) | Get the buff.
GetAuras(UInt32) | Gets the auras.
GetAuras(UInt32, List<(Of <<'(UInt32>)>>)) | Gets the auras by spell IDs.
GetAuras(UInt32, UInt32) | Get the buffs.
HaveBuff(UInt32, List<(Of <<'(UInt32>)>>)) | Have the buff.
HaveBuff(UInt32, UInt32) | Have the buff.
HaveBuffLua | Check if have buff with lua.
TimeLeft | Time left.

See Also

BuffManager Class
wManager.Wow.Helpers Namespace


AuraStack Method

BuffManager..::..AuraStack Method

Buff stack count.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int AuraStack(
    uint baseAddress,
    List<uint> buffId
)
Public Shared Function AuraStack ( _
    baseAddress As UInteger, _
    buffId As List(Of UInteger) _
) As Integer
public:
static int^ AuraStack(
    unsigned int^ baseAddress,
    List<unsigned int^>^ buffId
)

Parameters

baseAddress
Type: UInt32
The wow object base address (GetBaseAddress).
buffId
Type: List <(Of <(<' UInt32 >)>)>
The spell id..

Return Value

System.Int32.

See Also

BuffManager Class
wManager.Wow.Helpers Namespace


CastedBy Method

BuffManager..::..CastedBy Method

Casted by (return Guid).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static ulong CastedBy(
    uint baseAddress,
    List<uint> buffId
)
Public Shared Function CastedBy ( _
    baseAddress As UInteger, _
    buffId As List(Of UInteger) _
) As ULong
public:
static unsigned long long^ CastedBy(
    unsigned int^ baseAddress,
    List<unsigned int^>^ buffId
)

Parameters

baseAddress
Type: UInt32
The wow object base address (GetBaseAddress).
buffId
Type: List <(Of <(<' UInt32 >)>)>
The buff id.

Return Value

Guid

See Also

BuffManager Class
wManager.Wow.Helpers Namespace


CastedByAll Method

BuffManager..::..CastedByAll Method

Casted by all (return Guid).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<ulong> CastedByAll(
    uint baseAddress,
    List<uint> buffId
)
Public Shared Function CastedByAll ( _
    baseAddress As UInteger, _
    buffId As List(Of UInteger) _
) As List(Of ULong)
public:
static List<unsigned long long^>^ CastedByAll(
    unsigned int^ baseAddress,
    List<unsigned int^>^ buffId
)

Parameters

baseAddress
Type: UInt32
The wow object base address (GetBaseAddress).
buffId
Type: List <(Of <(<' UInt32 >)>)>
The buff id.

Return Value

List<Int128>.

See Also

BuffManager Class
wManager.Wow.Helpers Namespace


GetAura Method

BuffManager..::..GetAura Method

Overload List

Name | Description
GetAura(UInt32, List<(Of <<'(UInt32>)>>)) | Gets the aura by spell id.
GetAura(UInt32, UInt32) | Get the buff.

See Also

BuffManager Class
BuffManager Members
wManager.Wow.Helpers Namespace


GetAura Method (UInt32, List(UInt32))

BuffManager..::..GetAura Method (UInt32, List<(Of <(<'UInt32>)>)>)

Gets the aura by spell id.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static Aura GetAura(
    uint baseAddress,
    List<uint> buffId
)
Public Shared Function GetAura ( _
    baseAddress As UInteger, _
    buffId As List(Of UInteger) _
) As Aura
public:
static Aura^ GetAura(
    unsigned int^ baseAddress,
    List<unsigned int^>^ buffId
)

Parameters

baseAddress
Type: UInt32
The wow object base address (GetBaseAddress).
buffId
Type: List <(Of <(<' UInt32 >)>)>
The spell id.

Return Value

Aura.

See Also

BuffManager Class
GetAura Overload
wManager.Wow.Helpers Namespace


GetAura Method (UInt32, UInt32)

BuffManager..::..GetAura Method (UInt32, UInt32)

Get the buff.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static Aura GetAura(
    uint baseAddress,
    uint buffId
)
Public Shared Function GetAura ( _
    baseAddress As UInteger, _
    buffId As UInteger _
) As Aura
public:
static Aura^ GetAura(
    unsigned int^ baseAddress,
    unsigned int^ buffId
)

Parameters

baseAddress
Type: UInt32
The wow object base address (GetBaseAddress).
buffId
Type: UInt32
The spell id.

Return Value

Aura.

See Also

BuffManager Class
GetAura Overload
wManager.Wow.Helpers Namespace


GetAuras Method

BuffManager..::..GetAuras Method

Overload List

Name | Description
GetAuras(UInt32) | Gets the auras.
GetAuras(UInt32, List<(Of <<'(UInt32>)>>)) | Gets the auras by spell IDs.
GetAuras(UInt32, UInt32) | Get the buffs.

See Also

BuffManager Class
BuffManager Members
wManager.Wow.Helpers Namespace


GetAuras Method (UInt32)

BuffManager..::..GetAuras Method (UInt32)

Gets the auras.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static IEnumerable<Aura> GetAuras(
    uint baseAddress
)
Public Shared Function GetAuras ( _
    baseAddress As UInteger _
) As IEnumerable(Of Aura)
public:
static IEnumerable<Aura^>^ GetAuras(
    unsigned int^ baseAddress
)

Parameters

baseAddress
Type: UInt32
The wow object base address (GetBaseAddress).

Return Value

IEnumerable<Aura>.

See Also

BuffManager Class
GetAuras Overload
wManager.Wow.Helpers Namespace


GetAuras Method (UInt32, List(UInt32))

BuffManager..::..GetAuras Method (UInt32, List<(Of <(<'UInt32>)>)>)

Gets the auras by spell IDs.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static IEnumerable<Aura> GetAuras(
    uint baseAddress,
    List<uint> buffId
)
Public Shared Function GetAuras ( _
    baseAddress As UInteger, _
    buffId As List(Of UInteger) _
) As IEnumerable(Of Aura)
public:
static IEnumerable<Aura^>^ GetAuras(
    unsigned int^ baseAddress,
    List<unsigned int^>^ buffId
)

Parameters

baseAddress
Type: UInt32
The wow object base address (GetBaseAddress).
buffId
Type: List <(Of <(<' UInt32 >)>)>
The spells IDs.

Return Value

IEnumerable<Aura>.

See Also

BuffManager Class
GetAuras Overload
wManager.Wow.Helpers Namespace


GetAuras Method (UInt32, UInt32)

BuffManager..::..GetAuras Method (UInt32, UInt32)

Get the buffs.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static IEnumerable<Aura> GetAuras(
    uint baseAddress,
    uint buffId
)
Public Shared Function GetAuras ( _
    baseAddress As UInteger, _
    buffId As UInteger _
) As IEnumerable(Of Aura)
public:
static IEnumerable<Aura^>^ GetAuras(
    unsigned int^ baseAddress,
    unsigned int^ buffId
)

Parameters

baseAddress
Type: UInt32
The wow object base address (GetBaseAddress).
buffId
Type: UInt32
The spell id..

Return Value

IEnumerable<Aura>.

See Also

BuffManager Class
GetAuras Overload
wManager.Wow.Helpers Namespace


HaveBuff Method

BuffManager..::..HaveBuff Method

Overload List

Name | Description
HaveBuff(UInt32, List<(Of <<'(UInt32>)>>)) | Have the buff.
HaveBuff(UInt32, UInt32) | Have the buff.

See Also

BuffManager Class
BuffManager Members
wManager.Wow.Helpers Namespace


HaveBuff Method (UInt32, List(UInt32))

BuffManager..::..HaveBuff Method (UInt32, List<(Of <(<'UInt32>)>)>)

Have the buff.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool HaveBuff(
    uint baseAddress,
    List<uint> buffId
)
Public Shared Function HaveBuff ( _
    baseAddress As UInteger, _
    buffId As List(Of UInteger) _
) As Boolean
public:
static bool^ HaveBuff(
    unsigned int^ baseAddress,
    List<unsigned int^>^ buffId
)

Parameters

baseAddress
Type: UInt32
The wow object base address (GetBaseAddress).
buffId
Type: List <(Of <(<' UInt32 >)>)>
The spell id..

Return Value

true if buff found, false otherwise.

See Also

BuffManager Class
HaveBuff Overload
wManager.Wow.Helpers Namespace


HaveBuff Method (UInt32, UInt32)

BuffManager..::..HaveBuff Method (UInt32, UInt32)

Have the buff.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool HaveBuff(
    uint objBase,
    uint buffId
)
Public Shared Function HaveBuff ( _
    objBase As UInteger, _
    buffId As UInteger _
) As Boolean
public:
static bool^ HaveBuff(
    unsigned int^ objBase,
    unsigned int^ buffId
)

Parameters

objBase
Type: UInt32
The wow object base address (GetBaseAddress).
buffId
Type: UInt32
The spell id..

Return Value

true if buff found, false otherwise.

See Also

BuffManager Class
HaveBuff Overload
wManager.Wow.Helpers Namespace


HaveBuffLua Method

BuffManager..::..HaveBuffLua Method

Check if have buff with lua.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool HaveBuffLua(
    string nameInGame,
    UnitIdLua unit
)
Public Shared Function HaveBuffLua ( _
    nameInGame As String, _
    unit As UnitIdLua _
) As Boolean
public:
static bool^ HaveBuffLua(
    String^ nameInGame,
    UnitIdLua^ unit
)

Parameters

nameInGame
Type: String
The wow object base address (GetBaseAddress).
unit
Type: wManager.Wow.Helpers.FightClassCreator..::..UnitIdLua
The unit.

Return Value

true if has buff, false otherwise.

See Also

BuffManager Class
wManager.Wow.Helpers Namespace


TimeLeft Method

BuffManager..::..TimeLeft Method

Time left.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int TimeLeft(
    uint baseAddress,
    List<uint> buffId
)
Public Shared Function TimeLeft ( _
    baseAddress As UInteger, _
    buffId As List(Of UInteger) _
) As Integer
public:
static int^ TimeLeft(
    unsigned int^ baseAddress,
    List<unsigned int^>^ buffId
)

Parameters

baseAddress
Type: UInt32
The wow object base address (GetBaseAddress).
buffId
Type: List <(Of <(<' UInt32 >)>)>
The buff id.

Return Value

System.Int32.

See Also

BuffManager Class
wManager.Wow.Helpers Namespace


CGUnit_C__GetFacing Class

Class CGUnit_C__GetFacing. used to get [WoWGameObject.Rotation]

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class CGUnit_C__GetFacing
Public NotInheritable Class CGUnit_C__GetFacing
public ref class CGUnit_C__GetFacing abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..CGUnit_C__GetFacing

See Also

CGUnit_C__GetFacing Members
wManager.Wow.Helpers Namespace


CGUnit_C__GetFacing Members

The CGUnit_C__GetFacing type exposes the following members.

Methods

Name | Description
GetFacing | Get the rotation.

See Also

CGUnit_C__GetFacing Class
wManager.Wow.Helpers Namespace


CGUnit_C__GetFacing Methods

The CGUnit_C__GetFacing type exposes the following members.

Methods

Name | Description
GetFacing | Get the rotation.

See Also

CGUnit_C__GetFacing Class
wManager.Wow.Helpers Namespace


GetFacing Method

CGUnit_C__GetFacing..::..GetFacing Method

Get the rotation.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static float GetFacing(
    uint baseAddress
)
Public Shared Function GetFacing ( _
    baseAddress As UInteger _
) As Single
public:
static float^ GetFacing(
    unsigned int^ baseAddress
)

Parameters

baseAddress
Type: UInt32
The [WoWObject.GetBaseAddress].

Return Value

System.Single.

See Also

CGUnit_C__GetFacing Class
wManager.Wow.Helpers Namespace


CGUnit_C__GetPosition Class

Class CGUnit_C__GetPosition. Used to get [WoWUnit.get_Position] when InTransport.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class CGUnit_C__GetPosition
Public NotInheritable Class CGUnit_C__GetPosition
public ref class CGUnit_C__GetPosition abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..CGUnit_C__GetPosition

See Also

CGUnit_C__GetPosition Members
wManager.Wow.Helpers Namespace


CGUnit_C__GetPosition Members

The CGUnit_C__GetPosition type exposes the following members.

Methods

Name | Description
GetPosition | Get the position.

Fields

Name | Description
CacheTime | Cache time in milliseconds

See Also

CGUnit_C__GetPosition Class
wManager.Wow.Helpers Namespace


CGUnit_C__GetPosition Fields

The CGUnit_C__GetPosition type exposes the following members.

Fields

Name | Description
CacheTime | Cache time in milliseconds

See Also

CGUnit_C__GetPosition Class
wManager.Wow.Helpers Namespace


CacheTime Field

CGUnit_C__GetPosition..::..CacheTime Field

Cache time in milliseconds

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int CacheTime
Public Shared CacheTime As Integer
public:
static int^ CacheTime

See Also

CGUnit_C__GetPosition Class
wManager.Wow.Helpers Namespace


CGUnit_C__GetPosition Methods

The CGUnit_C__GetPosition type exposes the following members.

Methods

Name | Description
GetPosition | Get the position.

See Also

CGUnit_C__GetPosition Class
wManager.Wow.Helpers Namespace


GetPosition Method

CGUnit_C__GetPosition..::..GetPosition Method

Get the position.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static Vector3 GetPosition(
    uint baseAddress
)
Public Shared Function GetPosition ( _
    baseAddress As UInteger _
) As Vector3
public:
static Vector3^ GetPosition(
    unsigned int^ baseAddress
)

Parameters

baseAddress
Type: UInt32
The base address (GetBaseAddress).

Return Value

Vector3.

See Also

CGUnit_C__GetPosition Class
wManager.Wow.Helpers Namespace


Channel Class

Class Channel.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class Channel
Public Class Channel
public ref class Channel

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..Channel

See Also

Channel Members
wManager.Wow.Helpers Namespace


Channel Members

The Channel type exposes the following members.

Constructors

 | Name | Description
Public method | Channel | Initializes a new instance of the Channel class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadAllChannel | Read all channel.
Public method | ReadChannel | Read specific channel.
Public method | ReadGuildChannel | Read the guild channel.
 | ReadLastMsg | Read last message.
Public method | ReadMsg | Read the message.
Public method | ReadSayChannel | Read the say channel.
Public method | ReadWhisperChannel | Read the whisper channel.
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | ActuelRead | The actual index position of message to read

Properties

Name | Description
GetMsgActuelInWow | The actual index position of message to read in game

See Also

Channel Class
wManager.Wow.Helpers Namespace


Channel Constructor

Initializes a new instance of the Channel class.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Channel()
Public Sub New
public:
Channel()

See Also

Channel Class
wManager.Wow.Helpers Namespace


Channel Fields

The Channel type exposes the following members.

Fields

 | Name | Description
Public field | ActuelRead | The actual index position of message to read

See Also

Channel Class
wManager.Wow.Helpers Namespace


ActuelRead Field

Channel..::..ActuelRead Field

The actual index position of message to read

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int ActuelRead
Public ActuelRead As Integer
public:
int^ ActuelRead

See Also

Channel Class
wManager.Wow.Helpers Namespace


Channel Methods

The Channel type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadAllChannel | Read all channel.
Public method | ReadChannel | Read specific channel.
Public method | ReadGuildChannel | Read the guild channel.
 | ReadLastMsg | Read last message.
Public method | ReadMsg | Read the message.
Public method | ReadSayChannel | Read the say channel.
Public method | ReadWhisperChannel | Read the whisper channel.
Public method | ToString | (Inherited from Object.)

See Also

Channel Class
wManager.Wow.Helpers Namespace


ReadAllChannel Method

Channel..::..ReadAllChannel Method

Read all channel.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string ReadAllChannel()
Public Function ReadAllChannel As String
public:
String^ ReadAllChannel()

Return Value

System.String.

See Also

Channel Class
wManager.Wow.Helpers Namespace


ReadChannel Method

Channel..::..ReadChannel Method

Read specific channel.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string ReadChannel(
    ChatTypeId chatTypeId
)
Public Function ReadChannel ( _
    chatTypeId As ChatTypeId _
) As String
public:
String^ ReadChannel(
    ChatTypeId^ chatTypeId
)

Parameters

chatTypeId
Type: wManager.Wow.Enums..::..ChatTypeId
The chat type id.

Return Value

System.String.

See Also

Channel Class
wManager.Wow.Helpers Namespace


ReadGuildChannel Method

Channel..::..ReadGuildChannel Method

Read the guild channel.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string ReadGuildChannel()
Public Function ReadGuildChannel As String
public:
String^ ReadGuildChannel()

Return Value

System.String.

See Also

Channel Class
wManager.Wow.Helpers Namespace


ReadLastMsg Method

Channel..::..ReadLastMsg Method

Read last message.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string ReadLastMsg()
Public Shared Function ReadLastMsg As String
public:
static String^ ReadLastMsg()

Return Value

message.

See Also

Channel Class
wManager.Wow.Helpers Namespace


ReadMsg Method

Channel..::..ReadMsg Method

Read the message.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Channel..::..Message ReadMsg()
Public Function ReadMsg As Channel..::..Message
public:
Channel..::..Message^ ReadMsg()

Return Value

Message.

See Also

Channel Class
wManager.Wow.Helpers Namespace


ReadSayChannel Method

Channel..::..ReadSayChannel Method

Read the say channel.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string ReadSayChannel()
Public Function ReadSayChannel As String
public:
String^ ReadSayChannel()

Return Value

System.String.

See Also

Channel Class
wManager.Wow.Helpers Namespace


ReadWhisperChannel Method

Channel..::..ReadWhisperChannel Method

Read the whisper channel.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string ReadWhisperChannel()
Public Function ReadWhisperChannel As String
public:
String^ ReadWhisperChannel()

Return Value

System.String.

See Also

Channel Class
wManager.Wow.Helpers Namespace


Channel Properties

The Channel type exposes the following members.

Properties

Name | Description
GetMsgActuelInWow | The actual index position of message to read in game

See Also

Channel Class
wManager.Wow.Helpers Namespace


GetMsgActuelInWow Property

Channel..::..GetMsgActuelInWow Property

The actual index position of message to read in game

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int GetMsgActuelInWow { get; }
Public Shared ReadOnly Property GetMsgActuelInWow As Integer
    Get
public:
static property int^ GetMsgActuelInWow {
    int^ get ();
}

See Also

Channel Class
wManager.Wow.Helpers Namespace


Channel.Message Class

Channel..::..Message Class

Class Message.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class Message
Public Class Message
public ref class Message

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..Channel..::..Message

See Also

Channel..::..Message Members
wManager.Wow.Helpers Namespace


Channel.Message Members

Channel..::..Message Members

The Channel..::..Message type exposes the following members.

Constructors

 | Name | Description
Public method | Channel..::..Message | Initializes a new instance of the Channel..::..Message class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance.

Fields

 | Name | Description
Public field | Channel | The channel id
Public field | DateTime | The date time
Public field | Msg | The message
Public field | UserName | The user name

See Also

Channel..::..Message Class
wManager.Wow.Helpers Namespace


Message Constructor

Initializes a new instance of the Channel..::..Message class.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Message()
Public Sub New
public:
Message()

See Also

Channel..::..Message Class
wManager.Wow.Helpers Namespace


Channel.Message Fields

Channel..::..Message Fields

The Channel..::..Message type exposes the following members.

Fields

 | Name | Description
Public field | Channel | The channel id
Public field | DateTime | The date time
Public field | Msg | The message
Public field | UserName | The user name

See Also

Channel..::..Message Class
wManager.Wow.Helpers Namespace


Channel Field

Message..::..Channel Field

The channel id

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public ChatTypeId Channel
Public Channel As ChatTypeId
public:
ChatTypeId^ Channel

See Also

Channel..::..Message Class
wManager.Wow.Helpers Namespace


DateTime Field

Message..::..DateTime Field

The date time

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string DateTime
Public DateTime As String
public:
String^ DateTime

See Also

Channel..::..Message Class
wManager.Wow.Helpers Namespace


Msg Field

Message..::..Msg Field

The message

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string Msg
Public Msg As String
public:
String^ Msg

See Also

Channel..::..Message Class
wManager.Wow.Helpers Namespace


UserName Field

Message..::..UserName Field

The user name

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string UserName
Public UserName As String
public:
String^ UserName

See Also

Channel..::..Message Class
wManager.Wow.Helpers Namespace


Channel.Message Methods

Channel..::..Message Methods

The Channel..::..Message type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance.

See Also

Channel..::..Message Class
wManager.Wow.Helpers Namespace


ToString Method

Message..::..ToString Method

Returns a String that represents this instance.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string ToString()
Public Function ToString As String
public:
String^ ToString()

Return Value

A String that represents this instance.

See Also

Channel..::..Message Class
wManager.Wow.Helpers Namespace


Chat Class

Class Chat. Several useful methods to send and get messages in game.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class Chat
Public Class Chat
public ref class Chat

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..Chat

See Also

Chat Members
wManager.Wow.Helpers Namespace


Chat Members

The Chat type exposes the following members.

Methods

 | Name | Description
 | ClearMessages | Clear the messages.
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
 | SendChatMessage | Send chat message.
 | SendChatMessageChannel | Send chat message.
 | SendChatMessageWhisper | Send whisper message.
 | SendChatMessageWhisperAtTarget | Send whisper message to character target.
Public method | ToString | (Inherited from Object.)

Properties

Name | Description
Messages | Get messages.

See Also

Chat Class
wManager.Wow.Helpers Namespace


Chat Methods

The Chat type exposes the following members.

Methods

 | Name | Description
 | ClearMessages | Clear the messages.
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
 | SendChatMessage | Send chat message.
 | SendChatMessageChannel | Send chat message.
 | SendChatMessageWhisper | Send whisper message.
 | SendChatMessageWhisperAtTarget | Send whisper message to character target.
Public method | ToString | (Inherited from Object.)

See Also

Chat Class
wManager.Wow.Helpers Namespace


ClearMessages Method

Chat..::..ClearMessages Method

Clear the messages.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void ClearMessages()
Public Shared Sub ClearMessages
public:
static void ClearMessages()

See Also

Chat Class
wManager.Wow.Helpers Namespace


SendChatMessage Method

Chat..::..SendChatMessage Method

Send chat message.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void SendChatMessage(
    string message,
    ChatTypeId channel
)
Public Shared Sub SendChatMessage ( _
    message As String, _
    channel As ChatTypeId _
)
public:
static void SendChatMessage(
    String^ message,
    ChatTypeId^ channel
)

Parameters

message
Type: String
The message.
channel
Type: wManager.Wow.Enums..::..ChatTypeId
The channel.

See Also

Chat Class
wManager.Wow.Helpers Namespace


SendChatMessageChannel Method

Chat..::..SendChatMessageChannel Method

Send chat message.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void SendChatMessageChannel(
    string message,
    string channelId
)
Public Shared Sub SendChatMessageChannel ( _
    message As String, _
    channelId As String _
)
public:
static void SendChatMessageChannel(
    String^ message,
    String^ channelId
)

Parameters

message
Type: String
The message.
channelId
Type: String
The channel id (ChatTypeId, https://wowwiki.fandom.com/wiki/ChatTypeId ).

See Also

Chat Class
wManager.Wow.Helpers Namespace


SendChatMessageWhisper Method

Chat..::..SendChatMessageWhisper Method

Send whisper message.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void SendChatMessageWhisper(
    string message,
    string playerName
)
Public Shared Sub SendChatMessageWhisper ( _
    message As String, _
    playerName As String _
)
public:
static void SendChatMessageWhisper(
    String^ message,
    String^ playerName
)

Parameters

message
Type: String
The message.
playerName
Type: String
Name of the player.

See Also

Chat Class
wManager.Wow.Helpers Namespace


SendChatMessageWhisperAtTarget Method

Chat..::..SendChatMessageWhisperAtTarget Method

Send whisper message to character target.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void SendChatMessageWhisperAtTarget(
    string message
)
Public Shared Sub SendChatMessageWhisperAtTarget ( _
    message As String _
)
public:
static void SendChatMessageWhisperAtTarget(
    String^ message
)

Parameters

message
Type: String
The message.

See Also

Chat Class
wManager.Wow.Helpers Namespace


Chat Properties

The Chat type exposes the following members.

Properties

Name | Description
Messages | Get messages.

See Also

Chat Class
wManager.Wow.Helpers Namespace


Messages Property

Chat..::..Messages Property

Get messages.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<Channel..::..Message> Messages { get; }
Public Shared ReadOnly Property Messages As List(Of Channel..::..Message)
    Get
public:
static property List<Channel..::..Message^>^ Messages {
    List<Channel..::..Message^>^ get ();
}

Field Value

The messages.

See Also

Chat Class
wManager.Wow.Helpers Namespace


ClickOnTerrain Class

Class ClickOnTerrain. Useful for AOE spells.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class ClickOnTerrain
Public NotInheritable Class ClickOnTerrain
public ref class ClickOnTerrain abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..ClickOnTerrain

See Also

ClickOnTerrain Members
wManager.Wow.Helpers Namespace


ClickOnTerrain Members

The ClickOnTerrain type exposes the following members.

Methods

Name | Description
Item | Use item by ID and click on terrain.
Pulse | Click on specified position.
Spell | Cast spell by ID and click on terrain.

See Also

ClickOnTerrain Class
wManager.Wow.Helpers Namespace


ClickOnTerrain Methods

The ClickOnTerrain type exposes the following members.

Methods

Name | Description
Item | Use item by ID and click on terrain.
Pulse | Click on specified position.
Spell | Cast spell by ID and click on terrain.

See Also

ClickOnTerrain Class
wManager.Wow.Helpers Namespace


Item Method

ClickOnTerrain..::..Item Method

Use item by ID and click on terrain.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void Item(
    uint itemId,
    Vector3 vector3,
    bool waitCasting,
    bool stopMove
)
Public Shared Sub Item ( _
    itemId As UInteger, _
    vector3 As Vector3, _
    waitCasting As Boolean, _
    stopMove As Boolean _
)
public:
static void Item(
    unsigned int^ itemId,
    Vector3^ vector3,
    bool^ waitCasting,
    bool^ stopMove
)

Parameters

itemId
Type: UInt32
The item id.
vector3
Type: robotManager.Helpful..::..Vector3
The position where to click.
waitCasting
Type: Boolean
if set to true wait casting.
stopMove
Type: Boolean
if set to true stop move.

See Also

ClickOnTerrain Class
wManager.Wow.Helpers Namespace


Pulse Method

ClickOnTerrain..::..Pulse Method

Click on specified position.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void Pulse(
    Vector3 vector3
)
Public Shared Sub Pulse ( _
    vector3 As Vector3 _
)
public:
static void Pulse(
    Vector3^ vector3
)

Parameters

vector3
Type: robotManager.Helpful..::..Vector3
position.

See Also

ClickOnTerrain Class
wManager.Wow.Helpers Namespace


Spell Method

ClickOnTerrain..::..Spell Method

Cast spell by ID and click on terrain.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void Spell(
    uint spellId,
    Vector3 vector3,
    bool waitCasting,
    bool stopMove
)
Public Shared Sub Spell ( _
    spellId As UInteger, _
    vector3 As Vector3, _
    waitCasting As Boolean, _
    stopMove As Boolean _
)
public:
static void Spell(
    unsigned int^ spellId,
    Vector3^ vector3,
    bool^ waitCasting,
    bool^ stopMove
)

Parameters

spellId
Type: UInt32
The spell id.
vector3
Type: robotManager.Helpful..::..Vector3
The position to click.
waitCasting
Type: Boolean
if set to true wait casting.
stopMove
Type: Boolean
if set to true stop move.

See Also

ClickOnTerrain Class
wManager.Wow.Helpers Namespace


ClickOnTerrain.StructClickOnTerrain Structure

ClickOnTerrain..::..StructClickOnTerrain Structure

Struct StructClickOnTerrain

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[StructLayoutAttribute]
public struct StructClickOnTerrain
<StructLayoutAttribute> _
Public Structure StructClickOnTerrain
[StructLayoutAttribute]
public value class StructClickOnTerrain

See Also

ClickOnTerrain..::..StructClickOnTerrain Members
wManager.Wow.Helpers Namespace


ClickOnTerrain.StructClickOnTerrain Members

ClickOnTerrain..::..StructClickOnTerrain Members

The ClickOnTerrain..::..StructClickOnTerrain type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from ValueType.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from ValueType.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from ValueType.)

Fields

 | Name | Description
Public field | Active | active (put 1)
Public field | Guid | The GUID
Public field | X | The position x
Public field | Y | The position y
Public field | Z | The position z

See Also

ClickOnTerrain..::..StructClickOnTerrain Structure
wManager.Wow.Helpers Namespace


ClickOnTerrain.StructClickOnTerrain Fields

ClickOnTerrain..::..StructClickOnTerrain Fields

The ClickOnTerrain..::..StructClickOnTerrain type exposes the following members.

Fields

 | Name | Description
Public field | Active | active (put 1)
Public field | Guid | The GUID
Public field | X | The position x
Public field | Y | The position y
Public field | Z | The position z

See Also

ClickOnTerrain..::..StructClickOnTerrain Structure
wManager.Wow.Helpers Namespace


Active Field

StructClickOnTerrain..::..Active Field

active (put 1)

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int Active
Public Active As Integer
public:
int^ Active

See Also

ClickOnTerrain..::..StructClickOnTerrain Structure
wManager.Wow.Helpers Namespace


Guid Field

StructClickOnTerrain..::..Guid Field

The GUID

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public long Guid
Public Guid As Long
public:
long long^ Guid

See Also

ClickOnTerrain..::..StructClickOnTerrain Structure
wManager.Wow.Helpers Namespace


X Field

StructClickOnTerrain..::..X Field

The position x

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float X
Public X As Single
public:
float^ X

See Also

ClickOnTerrain..::..StructClickOnTerrain Structure
wManager.Wow.Helpers Namespace


Y Field

StructClickOnTerrain..::..Y Field

The position y

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float Y
Public Y As Single
public:
float^ Y

See Also

ClickOnTerrain..::..StructClickOnTerrain Structure
wManager.Wow.Helpers Namespace


Z Field

StructClickOnTerrain..::..Z Field

The position z

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float Z
Public Z As Single
public:
float^ Z

See Also

ClickOnTerrain..::..StructClickOnTerrain Structure
wManager.Wow.Helpers Namespace


ClickOnTerrain.StructClickOnTerrain Methods

ClickOnTerrain..::..StructClickOnTerrain Methods

The ClickOnTerrain..::..StructClickOnTerrain type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from ValueType.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from ValueType.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from ValueType.)

See Also

ClickOnTerrain..::..StructClickOnTerrain Structure
wManager.Wow.Helpers Namespace


ClickToMove Class

Class ClickToMove. Used to move character in game to specific position, by default this class use game option CTM (Click to move), but in some bot version this class can move character can move with keyboard.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class ClickToMove
Public NotInheritable Class ClickToMove
public ref class ClickToMove abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..ClickToMove

See Also

ClickToMove Members
wManager.Wow.Helpers Namespace


ClickToMove Members

The ClickToMove type exposes the following members.

Methods

Name | Description
CGPlayer_C__ClickToMove | Call click to move (move to specific position or face target/position).
GetClickToMovePosition | Gets the click to move position.
GetClickToMoveTypePush | Gets the click to move push type.

Properties

Name | Description
InMove | Gets a value indicating whether CTM is in move.
IsIdle | Gets a value indicating whether CTM is idle.

See Also

ClickToMove Class
wManager.Wow.Helpers Namespace


ClickToMove Methods

The ClickToMove type exposes the following members.

Methods

Name | Description
CGPlayer_C__ClickToMove | Call click to move (move to specific position or face target/position).
GetClickToMovePosition | Gets the click to move position.
GetClickToMoveTypePush | Gets the click to move push type.

See Also

ClickToMove Class
wManager.Wow.Helpers Namespace


CGPlayer_C__ClickToMove Method

ClickToMove..::..CGPlayer_C__ClickToMove Method

Call click to move (move to specific position or face target/position).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void CGPlayer_C__ClickToMove(
    float x,
    float y,
    float z,
    ulong guid,
    int action,
    float precision
)
Public Shared Sub CGPlayer_C__ClickToMove ( _
    x As Single, _
    y As Single, _
    z As Single, _
    guid As ULong, _
    action As Integer, _
    precision As Single _
)
public:
static void CGPlayer_C__ClickToMove(
    float^ x,
    float^ y,
    float^ z,
    unsigned long long^ guid,
    int^ action,
    float^ precision
)

Parameters

x
Type: Single
The position x.
y
Type: Single
The position y.
z
Type: Single
The position z.
guid
Type: UInt64
The GUID (0 if you want move to position).
action
Type: Int32
The action (ClickToMoveType).
precision
Type: Single
The precision (bot generally force usage of 0).

See Also

ClickToMove Class
wManager.Wow.Helpers Namespace


GetClickToMovePosition Method

ClickToMove..::..GetClickToMovePosition Method

Gets the click to move position.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static Vector3 GetClickToMovePosition()
Public Shared Function GetClickToMovePosition As Vector3
public:
static Vector3^ GetClickToMovePosition()

Return Value

Vector3.

See Also

ClickToMove Class
wManager.Wow.Helpers Namespace


GetClickToMoveTypePush Method

ClickToMove..::..GetClickToMoveTypePush Method

Gets the click to move push type.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static ClickToMoveType GetClickToMoveTypePush()
Public Shared Function GetClickToMoveTypePush As ClickToMoveType
public:
static ClickToMoveType^ GetClickToMoveTypePush()

Return Value

Enums.ClickToMoveType.

See Also

ClickToMove Class
wManager.Wow.Helpers Namespace


ClickToMove Properties

The ClickToMove type exposes the following members.

Properties

Name | Description
InMove | Gets a value indicating whether CTM is in move.
IsIdle | Gets a value indicating whether CTM is idle.

See Also

ClickToMove Class
wManager.Wow.Helpers Namespace


InMove Property

ClickToMove..::..InMove Property

Gets a value indicating whether CTM is in move.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool InMove { get; }
Public Shared ReadOnly Property InMove As Boolean
    Get
public:
static property bool^ InMove {
    bool^ get ();
}

Field Value

true if CTM is in move; otherwise, false.

See Also

ClickToMove Class
wManager.Wow.Helpers Namespace


IsIdle Property

ClickToMove..::..IsIdle Property

Gets a value indicating whether CTM is idle.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool IsIdle { get; }
Public Shared ReadOnly Property IsIdle As Boolean
    Get
public:
static property bool^ IsIdle {
    bool^ get ();
}

Field Value

true if CTM is idle; otherwise, false.

See Also

ClickToMove Class
wManager.Wow.Helpers Namespace


Conditions Class

Class Conditions. Facade for several useful conditions

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class Conditions
Public NotInheritable Class Conditions
public ref class Conditions abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..Conditions

See Also

Conditions Members
wManager.Wow.Helpers Namespace


Conditions Members

The Conditions type exposes the following members.

Methods

Name Description

Fields

Name | Description
ForceIgnoreIsAttacked | Force to ignore all attack (if enabled, force IsAttackedAndCannotIgnore to return false)

Properties

Name | Description
InGameAndConnected | Get a value indicating whether in game and connected.
InGameAndConnectedAndAlive | Get a value indicating whether connected in game and alive.
InGameAndConnectedAndAliveAndProductStarted | Get a value indicating whether connected in game, alive and product is started.
InGameAndConnectedAndAliveAndProductStartedNotInPause | Get a value indicating whether connected in game, alive, product is started and not in pause.
InGameAndConnectedAndProductStarted | Get a value indicating whether connected in game, product is started.
InGameAndConnectedAndProductStartedNotInPause | Get a value indicating whether connected in game, product is started and not in pause].
IsAttackedAndCannotIgnore | Get a value indicating whether the character is attacked and can't ignore. The result is based on the bot configurations, not on what happens in the game (the character can be attacked but returned false depending on the options). To force to return false use ForceIgnoreIsAttacked.
ProductInPause | Get a value indicating whether product is in pause.
ProductIsStarted | Get a value indicating whether product is started.
ProductIsStartedNotInPause | Get a value indicating whether product is started and not in pause.

See Also

Conditions Class
wManager.Wow.Helpers Namespace


Conditions Fields

The Conditions type exposes the following members.

Fields

Name | Description
ForceIgnoreIsAttacked | Force to ignore all attack (if enabled, force IsAttackedAndCannotIgnore to return false)

See Also

Conditions Class
wManager.Wow.Helpers Namespace


ForceIgnoreIsAttacked Field

Conditions..::..ForceIgnoreIsAttacked Field

Force to ignore all attack (if enabled, force IsAttackedAndCannotIgnore to return false)

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool ForceIgnoreIsAttacked
Public Shared ForceIgnoreIsAttacked As Boolean
public:
static bool^ ForceIgnoreIsAttacked

See Also

Conditions Class
wManager.Wow.Helpers Namespace


Conditions Methods

The Conditions type exposes the following members.

Methods

Name Description

See Also

Conditions Class
wManager.Wow.Helpers Namespace


Conditions Properties

The Conditions type exposes the following members.

Properties

Name | Description
InGameAndConnected | Get a value indicating whether in game and connected.
InGameAndConnectedAndAlive | Get a value indicating whether connected in game and alive.
InGameAndConnectedAndAliveAndProductStarted | Get a value indicating whether connected in game, alive and product is started.
InGameAndConnectedAndAliveAndProductStartedNotInPause | Get a value indicating whether connected in game, alive, product is started and not in pause.
InGameAndConnectedAndProductStarted | Get a value indicating whether connected in game, product is started.
InGameAndConnectedAndProductStartedNotInPause | Get a value indicating whether connected in game, product is started and not in pause].
IsAttackedAndCannotIgnore | Get a value indicating whether the character is attacked and can't ignore. The result is based on the bot configurations, not on what happens in the game (the character can be attacked but returned false depending on the options). To force to return false use ForceIgnoreIsAttacked.
ProductInPause | Get a value indicating whether product is in pause.
ProductIsStarted | Get a value indicating whether product is started.
ProductIsStartedNotInPause | Get a value indicating whether product is started and not in pause.

See Also

Conditions Class
wManager.Wow.Helpers Namespace


InGameAndConnected Property

Conditions..::..InGameAndConnected Property

Get a value indicating whether in game and connected.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool InGameAndConnected { get; }
Public Shared ReadOnly Property InGameAndConnected As Boolean
    Get
public:
static property bool^ InGameAndConnected {
    bool^ get ();
}

See Also

Conditions Class
wManager.Wow.Helpers Namespace


InGameAndConnectedAndAlive Property

Conditions..::..InGameAndConnectedAndAlive Property

Get a value indicating whether connected in game and alive.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool InGameAndConnectedAndAlive { get; }
Public Shared ReadOnly Property InGameAndConnectedAndAlive As Boolean
    Get
public:
static property bool^ InGameAndConnectedAndAlive {
    bool^ get ();
}

See Also

Conditions Class
wManager.Wow.Helpers Namespace


InGameAndConnectedAndAliveAndProductStarted Property

Conditions..::..InGameAndConnectedAndAliveAndProductStarted Property

Get a value indicating whether connected in game, alive and product is started.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool InGameAndConnectedAndAliveAndProductStarted { get; }
Public Shared ReadOnly Property InGameAndConnectedAndAliveAndProductStarted As Boolean
    Get
public:
static property bool^ InGameAndConnectedAndAliveAndProductStarted {
    bool^ get ();
}

See Also

Conditions Class
wManager.Wow.Helpers Namespace


InGameAndConnectedAndAliveAndProductStartedNotInPause Property

Conditions..::..InGameAndConnectedAndAliveAndProductStartedNotInPause Property

Get a value indicating whether connected in game, alive, product is started and not in pause.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool InGameAndConnectedAndAliveAndProductStartedNotInPause { get; }
Public Shared ReadOnly Property InGameAndConnectedAndAliveAndProductStartedNotInPause As Boolean
    Get
public:
static property bool^ InGameAndConnectedAndAliveAndProductStartedNotInPause {
    bool^ get ();
}

See Also

Conditions Class
wManager.Wow.Helpers Namespace


InGameAndConnectedAndProductStarted Property

Conditions..::..InGameAndConnectedAndProductStarted Property

Get a value indicating whether connected in game, product is started.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool InGameAndConnectedAndProductStarted { get; }
Public Shared ReadOnly Property InGameAndConnectedAndProductStarted As Boolean
    Get
public:
static property bool^ InGameAndConnectedAndProductStarted {
    bool^ get ();
}

See Also

Conditions Class
wManager.Wow.Helpers Namespace


InGameAndConnectedAndProductStartedNotInPause Property

Conditions..::..InGameAndConnectedAndProductStartedNotInPause Property

Get a value indicating whether connected in game, product is started and not in pause].

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool InGameAndConnectedAndProductStartedNotInPause { get; }
Public Shared ReadOnly Property InGameAndConnectedAndProductStartedNotInPause As Boolean
    Get
public:
static property bool^ InGameAndConnectedAndProductStartedNotInPause {
    bool^ get ();
}

See Also

Conditions Class
wManager.Wow.Helpers Namespace


IsAttackedAndCannotIgnore Property

Conditions..::..IsAttackedAndCannotIgnore Property

Get a value indicating whether the character is attacked and can't ignore. The result is based on the bot configurations, not on what happens in the game (the character can be attacked but returned false depending on the options). To force to return false use ForceIgnoreIsAttacked.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool IsAttackedAndCannotIgnore { get; }
Public Shared ReadOnly Property IsAttackedAndCannotIgnore As Boolean
    Get
public:
static property bool^ IsAttackedAndCannotIgnore {
    bool^ get ();
}

See Also

Conditions Class
wManager.Wow.Helpers Namespace


ProductInPause Property

Conditions..::..ProductInPause Property

Get a value indicating whether product is in pause.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool ProductInPause { get; }
Public Shared ReadOnly Property ProductInPause As Boolean
    Get
public:
static property bool^ ProductInPause {
    bool^ get ();
}

See Also

Conditions Class
wManager.Wow.Helpers Namespace


ProductIsStarted Property

Conditions..::..ProductIsStarted Property

Get a value indicating whether product is started.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool ProductIsStarted { get; }
Public Shared ReadOnly Property ProductIsStarted As Boolean
    Get
public:
static property bool^ ProductIsStarted {
    bool^ get ();
}

See Also

Conditions Class
wManager.Wow.Helpers Namespace


ProductIsStartedNotInPause Property

Conditions..::..ProductIsStartedNotInPause Property

Get a value indicating whether product is started and not in pause.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool ProductIsStartedNotInPause { get; }
Public Shared ReadOnly Property ProductIsStartedNotInPause As Boolean
    Get
public:
static property bool^ ProductIsStartedNotInPause {
    bool^ get ();
}

See Also

Conditions Class
wManager.Wow.Helpers Namespace


ConfigWowForThisBot Class

Class ConfigWowForThisBot. Bot use these methods to change/reset game settings to works correctly with the bot.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class ConfigWowForThisBot
Public NotInheritable Class ConfigWowForThisBot
public ref class ConfigWowForThisBot abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..ConfigWowForThisBot

See Also

ConfigWowForThisBot Members
wManager.Wow.Helpers Namespace


ConfigWowForThisBot Members

The ConfigWowForThisBot type exposes the following members.

Methods

Name | Description
ConfigWow | Config game for the bot (option like auto loot, ctm, auto cast in self, ...).
ResetConfigWow | Reset game config.

See Also

ConfigWowForThisBot Class
wManager.Wow.Helpers Namespace


ConfigWowForThisBot Methods

The ConfigWowForThisBot type exposes the following members.

Methods

Name | Description
ConfigWow | Config game for the bot (option like auto loot, ctm, auto cast in self, ...).
ResetConfigWow | Reset game config.

See Also

ConfigWowForThisBot Class
wManager.Wow.Helpers Namespace


ConfigWow Method

ConfigWowForThisBot..::..ConfigWow Method

Config game for the bot (option like auto loot, ctm, auto cast in self, ...).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void ConfigWow()
Public Shared Sub ConfigWow
public:
static void ConfigWow()

See Also

ConfigWowForThisBot Class
wManager.Wow.Helpers Namespace


ResetConfigWow Method

ConfigWowForThisBot..::..ResetConfigWow Method

Reset game config.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void ResetConfigWow()
Public Shared Sub ResetConfigWow
public:
static void ResetConfigWow()

See Also

ConfigWowForThisBot Class
wManager.Wow.Helpers Namespace


CustomClass Class

Class CustomClass. Also known as Fightclass or Fightclasses, this class allows you to manage it. To create fight class you can use Creator, but you can also use C#, VB.net or LuaBot. Fight classes need to implement interface ICustomClass (except for LuaBot fightclass). You can also look https://wrobot.eu/forums/topic/11122-c-fightclass-development-video-tutorial/

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class CustomClass
Public NotInheritable Class CustomClass
public ref class CustomClass abstract sealed

Examples

C#
using System;
   using System.Threading;
   using System.Windows.Forms;
   using robotManager.Helpful;
   using robotManager.Products;
   using wManager.Wow.Class;
   using wManager.Wow.Enums;
   using wManager.Wow.Helpers;
   using wManager.Wow.ObjectManager;
   using Timer = robotManager.Helpful.Timer;

   public class Main : ICustomClass
   {
       public float Range { get { return 4.5f; } }

       private bool _isLaunched;
       private ulong _lastTarget;

       public void Initialize() // When product started, he calls this method in new thread
       {
           _isLaunched = true;
           Logging.Write("[My fightclass] Is initialized.");
           Rotation();
       }

       public void Dispose() // Called when product stopped
       {
           _isLaunched = false;
           Logging.Write("[My fightclass] Stop in progress.");
       }

       public void ShowConfiguration() // When use click on Fight class settings
       {
           MessageBox.Show("[My fightclass] No setting for this Fight Class.");
       }

       // SPELLS:
       // Buff:
       public Spell DeadlyPoison = new Spell("Deadly Poison");
       public Spell Sprint = new Spell("Sprint");
       // Pull:
       public Spell Stealth = new Spell("Stealth");
       // Combat:
       public Spell Garrote = new Spell("Garrote");
       public Spell SliceandDice = new Spell("Slice and Dice");
       public Spell Eviscerate = new Spell("Eviscerate");
       public Timer SliceandDiceTimer = new Timer(); // Timer

       internal void Rotation()
       {
           Logging.Write("[My fightclass] Is started.");
           while (_isLaunched)
           {
               try
               {
                   if (!Conditions.InGameAndConnectedAndAliveAndProductStartedNotInPause)
                   {
                       BuffRotation();

                       if (Fight.InFight && ObjectManager.Me.Target.IsNotZero())
                       {
                           Pull();
                           CombatRotation();
                       }
                   }
               }
               catch (Exception e)
               {
                   Logging.WriteError("[My fightclass] ERROR: " + e);
               }

               Thread.Sleep(10); // Pause 10 ms to reduce the CPU usage, you can increment sleep time.
           }
           Logging.Write("[My fightclass] Is now stopped.");
       }

       internal void BuffRotation()
       {
           if (ObjectManager.Me.IsMounted)
               return;

           // Deadly Poison:
           if (DeadlyPoison.KnownSpell && !DeadlyPoison.HaveBuff && DeadlyPoison.IsSpellUsable && !ObjectManager.Me.GetMove)
           {
               DeadlyPoison.Launch();
               return;
           }
           // Sprint
           if (Sprint.KnownSpell && !ObjectManager.Me.InCombat && ObjectManager.Me.GetMove && Sprint.IsSpellUsable)
           {
               Sprint.Launch();
               return;
           }
       }
       internal void Pull()
       {
           if (ObjectManager.Me.Target == _lastTarget)
               return;

           // Stealth:
           if (Stealth.KnownSpell && Stealth.IsSpellUsable && !Stealth.HaveBuff && ObjectManager.Target.Target != ObjectManager.Me.Guid)
           {
               Stealth.Launch();
               _lastTarget = ObjectManager.Me.Target;
           }
       }

       internal void CombatRotation()
       {
           // Garrote:
           if (Garrote.IsSpellUsable && Garrote.IsDistanceGood && Garrote.KnownSpell && ObjectManager.Me.HaveBuff(115192))
           {
               Garrote.Launch();
               return;
           }
           // Eviscerate:
           if (Eviscerate.KnownSpell && Eviscerate.IsSpellUsable && Eviscerate.IsDistanceGood && (ObjectManager.Me.ComboPoint > 4 || (SliceandDice.HaveBuff && SliceandDiceTimer.IsReady)))
           {
               Eviscerate.Launch();
               if (SliceandDice.HaveBuff)
                   SliceandDiceTimer = new Timer(1000 * 36);
               return;
           }
       }
   }
VB.NET
Imports System.Collections.Generic
   Imports System.Linq
   Imports System.Threading
   Imports robotManager.FiniteStateMachine
   Imports robotManager.Helpful
   Imports wManager.Wow.Class
   Imports wManager.Wow.Helpers
   Imports wManager.Wow.ObjectManager

   Public Class Main
       Implements ICustomClass

       Public ReadOnly Property Range As Single Implements ICustomClass.Range
           Get
               Return 5
           End Get
       End Property

       Public Sub Initialize() Implements ICustomClass.Initialize

       End Sub

       Public Sub Dispose() Implements ICustomClass.Dispose

       End Sub

       Public Sub ShowConfiguration() Implements ICustomClass.ShowConfiguration

       End Sub
   End Class

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..CustomClass

See Also

CustomClass Members
wManager.Wow.Helpers Namespace


CustomClass Members

The CustomClass type exposes the following members.

Methods

Name | Description
DisposeCustomClass | Dispose the fightclass (call Dispose()()()()).
LoadCustomClass()()()() | Load fightclass (from CustomClass).
LoadCustomClass(String, Boolean) | Load fightclass.
ResetCustomClass | Reset the fightclass (call DisposeCustomClass()()()() and LoadCustomClass()()()()).
ShowConfigurationCustomClass | Show fightclass configuration (ShowConfiguration()()()()).

Properties

Name | Description
CustomClassThread | Get the fightclass thread.
GetRange | Get combat range (5 for melee classes, 25-35 for ranged classes).
IsAliveCustomClass | Get a value indicating whether the fightclass is loaded.

See Also

CustomClass Class
wManager.Wow.Helpers Namespace


CustomClass Methods

The CustomClass type exposes the following members.

Methods

Name | Description
DisposeCustomClass | Dispose the fightclass (call Dispose()()()()).
LoadCustomClass()()()() | Load fightclass (from CustomClass).
LoadCustomClass(String, Boolean) | Load fightclass.
ResetCustomClass | Reset the fightclass (call DisposeCustomClass()()()() and LoadCustomClass()()()()).
ShowConfigurationCustomClass | Show fightclass configuration (ShowConfiguration()()()()).

See Also

CustomClass Class
wManager.Wow.Helpers Namespace


DisposeCustomClass Method

CustomClass..::..DisposeCustomClass Method

Dispose the fightclass (call Dispose()()()()).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void DisposeCustomClass()
Public Shared Sub DisposeCustomClass
public:
static void DisposeCustomClass()

See Also

CustomClass Class
wManager.Wow.Helpers Namespace


LoadCustomClass Method

CustomClass..::..LoadCustomClass Method

Overload List

Name | Description
LoadCustomClass()()()() | Load fightclass (from CustomClass).
LoadCustomClass(String, Boolean) | Load fightclass.

See Also

CustomClass Class
CustomClass Members
wManager.Wow.Helpers Namespace


LoadCustomClass Method

CustomClass..::..LoadCustomClass Method

Load fightclass (from CustomClass).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void LoadCustomClass()
Public Shared Sub LoadCustomClass
public:
static void LoadCustomClass()

See Also

CustomClass Class
LoadCustomClass Overload
wManager.Wow.Helpers Namespace


LoadCustomClass Method (String, Boolean)

CustomClass..::..LoadCustomClass Method (String, Boolean)

Load fightclass.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void LoadCustomClass(
    string pathCc,
    bool settingOnly
)
Public Shared Sub LoadCustomClass ( _
    pathCc As String, _
    settingOnly As Boolean _
)
public:
static void LoadCustomClass(
    String^ pathCc,
    bool^ settingOnly
)

Parameters

pathCc
Type: String
The full path to fightclass.
settingOnly
Type: Boolean
if set to true show fightclass setting only (ShowConfiguration()()()()).

See Also

CustomClass Class
LoadCustomClass Overload
wManager.Wow.Helpers Namespace


ResetCustomClass Method

CustomClass..::..ResetCustomClass Method

Reset the fightclass (call DisposeCustomClass()()()() and LoadCustomClass()()()()).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void ResetCustomClass()
Public Shared Sub ResetCustomClass
public:
static void ResetCustomClass()

See Also

CustomClass Class
wManager.Wow.Helpers Namespace


ShowConfigurationCustomClass Method

CustomClass..::..ShowConfigurationCustomClass Method

Show fightclass configuration (ShowConfiguration()()()()).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void ShowConfigurationCustomClass(
    string filePath
)
Public Shared Sub ShowConfigurationCustomClass ( _
    filePath As String _
)
public:
static void ShowConfigurationCustomClass(
    String^ filePath
)

Parameters

filePath
Type: String
The file path.

See Also

CustomClass Class
wManager.Wow.Helpers Namespace


CustomClass Properties

The CustomClass type exposes the following members.

Properties

Name | Description
CustomClassThread | Get the fightclass thread.
GetRange | Get combat range (5 for melee classes, 25-35 for ranged classes).
IsAliveCustomClass | Get a value indicating whether the fightclass is loaded.

See Also

CustomClass Class
wManager.Wow.Helpers Namespace


CustomClassThread Property

CustomClass..::..CustomClassThread Property

Get the fightclass thread.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static Thread CustomClassThread { get; }
Public Shared ReadOnly Property CustomClassThread As Thread
    Get
public:
static property Thread^ CustomClassThread {
    Thread^ get ();
}

Field Value

The fightclass thread.

See Also

CustomClass Class
wManager.Wow.Helpers Namespace


GetRange Property

CustomClass..::..GetRange Property

Get combat range (5 for melee classes, 25-35 for ranged classes).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static float GetRange { get; }
Public Shared ReadOnly Property GetRange As Single
    Get
public:
static property float^ GetRange {
    float^ get ();
}

Field Value

The combat range.

See Also

CustomClass Class
wManager.Wow.Helpers Namespace


IsAliveCustomClass Property

CustomClass..::..IsAliveCustomClass Property

Get a value indicating whether the fightclass is loaded.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool IsAliveCustomClass { get; }
Public Shared ReadOnly Property IsAliveCustomClass As Boolean
    Get
public:
static property bool^ IsAliveCustomClass {
    bool^ get ();
}

Field Value

true if fightclass is loaded; otherwise, false.

See Also

CustomClass Class
wManager.Wow.Helpers Namespace


CVar Class

Class CVar. Wrapper for access to in game CVar https://wow.gamepedia.com/Console_variables

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class CVar
Public NotInheritable Class CVar
public ref class CVar abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..CVar

See Also

CVar Members
wManager.Wow.Helpers Namespace


CVar Members

The CVar type exposes the following members.

Methods

Name | Description
GetCVar<(Of <<'(T>)>>) | Get CVar value.
RegisterCVar | Register CVar.
SetCVar | Set the CVar value.

See Also

CVar Class
wManager.Wow.Helpers Namespace


CVar Methods

The CVar type exposes the following members.

Methods

Name | Description
GetCVar<(Of <<'(T>)>>) | Get CVar value.
RegisterCVar | Register CVar.
SetCVar | Set the CVar value.

See Also

CVar Class
wManager.Wow.Helpers Namespace


GetCVar(T) Method

CVar..::..GetCVar<(Of <(<'T>)>)> Method

Get CVar value.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static T GetCVar<T>(
    string cvarName
)

Public Shared Function GetCVar(Of T) ( _
    cvarName As String _
) As T
public:
generic<typename T>
static T GetCVar(
    String^ cvarName
)

Type Parameters

T

Parameters

cvarName
Type: String
Name of the cvar.

Return Value

T.

See Also

CVar Class
wManager.Wow.Helpers Namespace


RegisterCVar Method

CVar..::..RegisterCVar Method

Register CVar.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void RegisterCVar(
    string cvarName,
    Object value
)
Public Shared Sub RegisterCVar ( _
    cvarName As String, _
    value As Object _
)
public:
static void RegisterCVar(
    String^ cvarName,
    Object^ value
)

Parameters

cvarName
Type: String
Name of the cvar.
value
Type: Object
The value.

See Also

CVar Class
wManager.Wow.Helpers Namespace


SetCVar Method

CVar..::..SetCVar Method

Set the CVar value.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void SetCVar(
    string cvarName,
    Object value
)
Public Shared Sub SetCVar ( _
    cvarName As String, _
    value As Object _
)
public:
static void SetCVar(
    String^ cvarName,
    Object^ value
)

Parameters

cvarName
Type: String
Name of the cvar.
value
Type: Object
The value.

See Also

CVar Class
wManager.Wow.Helpers Namespace


DBC(T) Class

DBC<(Of <(<'T>)>)> Class

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class DBC<T>

Public Class DBC(Of T)
generic<typename T>
public ref class DBC

Type Parameters

T

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..DBC<(Of <(<'T>)>)>

See Also

DBC<(Of <(<'T>)>)> Members
wManager.Wow.Helpers Namespace


DBC(T) Members

DBC<(Of <(<'T>)>)> Members

The DBC<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | DBC<(Of <(<'T>)>)> | Initializes a new instance of DBC class using specified memory address

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetRow | Returns a specific row from DBC by it's index
Public method | GetRowByIndex |
Public method | GetType | (Inherited from Object.)
Public method | HasRow |
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Item |
Public property | MaxIndex |
Public property | MinIndex |
Public property | NumRows |
Public property | Rows |

See Also

DBC<(Of <(<'T>)>)> Class
wManager.Wow.Helpers Namespace


DBC(T) Constructor

DBC<(Of <(<'T>)>)> Constructor

Initializes a new instance of DBC class using specified memory address

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public DBC(
    uint offset
)
Public Sub New ( _
    offset As UInteger _
)
public:
DBC(
    unsigned int^ offset
)

Parameters

offset
Type: UInt32
DBC memory address

See Also

DBC<(Of <(<'T>)>)> Class
wManager.Wow.Helpers Namespace


DBC(T) Methods

DBC<(Of <(<'T>)>)> Methods

The DBC<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetRow | Returns a specific row from DBC by it's index
Public method | GetRowByIndex |
Public method | GetType | (Inherited from Object.)
Public method | HasRow |
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

DBC<(Of <(<'T>)>)> Class
wManager.Wow.Helpers Namespace


GetRow Method

DBC<(Of <(<'T>)>)>..::..GetRow Method

Returns a specific row from DBC by it's index

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public T GetRow(
    int index
)
Public Function GetRow ( _
    index As Integer _
) As T
public:
T GetRow(
    int^ index
)

Parameters

index
Type: Int32
Row index

Return Value

A row of type T

See Also

DBC<(Of <(<'T>)>)> Class
wManager.Wow.Helpers Namespace


GetRowByIndex Method

DBC<(Of <(<'T>)>)>..::..GetRowByIndex Method

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public T GetRowByIndex(
    int index
)
Public Function GetRowByIndex ( _
    index As Integer _
) As T
public:
T GetRowByIndex(
    int^ index
)

Parameters

index
Type: Int32

See Also

DBC<(Of <(<'T>)>)> Class
wManager.Wow.Helpers Namespace


HasRow Method

DBC<(Of <(<'T>)>)>..::..HasRow Method

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool HasRow(
    int index
)
Public Function HasRow ( _
    index As Integer _
) As Boolean
public:
bool^ HasRow(
    int^ index
)

Parameters

index
Type: Int32

See Also

DBC<(Of <(<'T>)>)> Class
wManager.Wow.Helpers Namespace


DBC(T) Properties

DBC<(Of <(<'T>)>)> Properties

The DBC<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Item |
Public property | MaxIndex |
Public property | MinIndex |
Public property | NumRows |
Public property | Rows |

See Also

DBC<(Of <(<'T>)>)> Class
wManager.Wow.Helpers Namespace


Item Property

DBC<(Of <(<'T>)>)>..::..Item Property

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public T this[
    int index
] { get; }
Public ReadOnly Default Property Item ( _
    index As Integer _
) As T
    Get
public:
property T default[int^ index] {
    T get (int^ index);
}

Parameters

index
Type: Int32

See Also

DBC<(Of <(<'T>)>)> Class
wManager.Wow.Helpers Namespace


MaxIndex Property

DBC<(Of <(<'T>)>)>..::..MaxIndex Property

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int MaxIndex { get; }
Public ReadOnly Property MaxIndex As Integer
    Get
public:
property int^ MaxIndex {
    int^ get ();
}

See Also

DBC<(Of <(<'T>)>)> Class
wManager.Wow.Helpers Namespace


MinIndex Property

DBC<(Of <(<'T>)>)>..::..MinIndex Property

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int MinIndex { get; }
Public ReadOnly Property MinIndex As Integer
    Get
public:
property int^ MinIndex {
    int^ get ();
}

See Also

DBC<(Of <(<'T>)>)> Class
wManager.Wow.Helpers Namespace


NumRows Property

DBC<(Of <(<'T>)>)>..::..NumRows Property

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int NumRows { get; }
Public ReadOnly Property NumRows As Integer
    Get
public:
property int^ NumRows {
    int^ get ();
}

See Also

DBC<(Of <(<'T>)>)> Class
wManager.Wow.Helpers Namespace


Rows Property

DBC<(Of <(<'T>)>)>..::..Rows Property

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Dictionary<int, T> Rows { get; }
Public ReadOnly Property Rows As Dictionary(Of Integer, T)
    Get
public:
property Dictionary<int^, T>^ Rows {
    Dictionary<int^, T>^ get ();
}

See Also

DBC<(Of <(<'T>)>)> Class
wManager.Wow.Helpers Namespace


EquippedItems Class

Class EquippedItems.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class EquippedItems
Public NotInheritable Class EquippedItems
public ref class EquippedItems abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..EquippedItems

See Also

EquippedItems Members
wManager.Wow.Helpers Namespace


EquippedItems Members

The EquippedItems type exposes the following members.

Methods

Name | Description
GetEquippedItems | Get the equipped items.

See Also

EquippedItems Class
wManager.Wow.Helpers Namespace


EquippedItems Methods

The EquippedItems type exposes the following members.

Methods

Name | Description
GetEquippedItems | Get the equipped items.

See Also

EquippedItems Class
wManager.Wow.Helpers Namespace


GetEquippedItems Method

EquippedItems..::..GetEquippedItems Method

Get the equipped items.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWItem> GetEquippedItems()
Public Shared Function GetEquippedItems As List(Of WoWItem)
public:
static List<WoWItem^>^ GetEquippedItems()

Return Value

List<WoWItem>.

See Also

EquippedItems Class
wManager.Wow.Helpers Namespace


EventsLua Class

Class EventsLua (this class count the number of times the event was called, if you need event arguments use EventsLuaWithArgs). Facilitates access from the bot to the in game lua events https://wowwiki.fandom.com/wiki/Event_API .

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class EventsLua
Public Class EventsLua
public ref class EventsLua

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..EventsLua

See Also

EventsLua Members
wManager.Wow.Helpers Namespace


EventsLua Members

The EventsLua type exposes the following members.

Methods

 | Name | Description
 | AttachEventLua(String, EventsLua..::..MethodDelegate) | Attach lua event (the bot automatically detaches when you stop the product).
 | AttachEventLua(LuaEventsId, EventsLua..::..MethodDelegate) | Attach lua event (the bot automatically detaches when you stop the product).
 | DumpEventsId | Dumps list (names and IDs) of game events.
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
 | UsedCountById | Count number of time that event was called.
 | UsedCountByLuaEventsId | Count number of time that event was called.
 | UsedCountByStringId | Count number of time that event was called.

See Also

EventsLua Class
wManager.Wow.Helpers Namespace


EventsLua Methods

The EventsLua type exposes the following members.

Methods

 | Name | Description
 | AttachEventLua(String, EventsLua..::..MethodDelegate) | Attach lua event (the bot automatically detaches when you stop the product).
 | AttachEventLua(LuaEventsId, EventsLua..::..MethodDelegate) | Attach lua event (the bot automatically detaches when you stop the product).
 | DumpEventsId | Dumps list (names and IDs) of game events.
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
 | UsedCountById | Count number of time that event was called.
 | UsedCountByLuaEventsId | Count number of time that event was called.
 | UsedCountByStringId | Count number of time that event was called.

See Also

EventsLua Class
wManager.Wow.Helpers Namespace


AttachEventLua Method

EventsLua..::..AttachEventLua Method

Overload List

Name | Description
AttachEventLua(String, EventsLua..::..MethodDelegate) | Attach lua event (the bot automatically detaches when you stop the product).
AttachEventLua(LuaEventsId, EventsLua..::..MethodDelegate) | Attach lua event (the bot automatically detaches when you stop the product).

See Also

EventsLua Class
EventsLua Members
wManager.Wow.Helpers Namespace


AttachEventLua Method (String, MethodDelegate)

EventsLua..::..AttachEventLua Method (String, MethodDelegate)

Attach lua event (the bot automatically detaches when you stop the product).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void AttachEventLua(
    string eventid,
    EventsLua..::..MethodDelegate method
)
Public Shared Sub AttachEventLua ( _
    eventid As String, _
    method As EventsLua..::..MethodDelegate _
)
public:
static void AttachEventLua(
    String^ eventid,
    EventsLua..::..MethodDelegate^ method
)

Parameters

eventid
Type: String
The event id.
method
Type: wManager.Wow.Helpers..::..EventsLua..::..MethodDelegate
The method.

See Also

EventsLua Class
AttachEventLua Overload
wManager.Wow.Helpers Namespace


AttachEventLua Method (LuaEventsId, MethodDelegate)

EventsLua..::..AttachEventLua Method (LuaEventsId, MethodDelegate)

Attach lua event (the bot automatically detaches when you stop the product).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void AttachEventLua(
    LuaEventsId id,
    EventsLua..::..MethodDelegate method
)
Public Shared Sub AttachEventLua ( _
    id As LuaEventsId, _
    method As EventsLua..::..MethodDelegate _
)
public:
static void AttachEventLua(
    LuaEventsId^ id,
    EventsLua..::..MethodDelegate^ method
)

Parameters

id
Type: wManager.Wow.Enums..::..LuaEventsId
method
Type: wManager.Wow.Helpers..::..EventsLua..::..MethodDelegate
The method.

See Also

EventsLua Class
AttachEventLua Overload
wManager.Wow.Helpers Namespace


DumpEventsId Method

EventsLua..::..DumpEventsId Method

Dumps list (names and IDs) of game events.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string DumpEventsId()
Public Shared Function DumpEventsId As String
public:
static String^ DumpEventsId()

Return Value

System.String.

See Also

EventsLua Class
wManager.Wow.Helpers Namespace


UsedCountById Method

EventsLua..::..UsedCountById Method

Count number of time that event was called.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int UsedCountById(
    int id
)
Public Shared Function UsedCountById ( _
    id As Integer _
) As Integer
public:
static int^ UsedCountById(
    int^ id
)

Parameters

id
Type: Int32
The event id.

Return Value

System.Int32.

See Also

EventsLua Class
wManager.Wow.Helpers Namespace


UsedCountByLuaEventsId Method

EventsLua..::..UsedCountByLuaEventsId Method

Count number of time that event was called.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int UsedCountByLuaEventsId(
    LuaEventsId id
)
Public Shared Function UsedCountByLuaEventsId ( _
    id As LuaEventsId _
) As Integer
public:
static int^ UsedCountByLuaEventsId(
    LuaEventsId^ id
)

Parameters

id
Type: wManager.Wow.Enums..::..LuaEventsId
The event id.

Return Value

System.Int32.

See Also

EventsLua Class
wManager.Wow.Helpers Namespace


UsedCountByStringId Method

EventsLua..::..UsedCountByStringId Method

Count number of time that event was called.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int UsedCountByStringId(
    string idString
)
Public Shared Function UsedCountByStringId ( _
    idString As String _
) As Integer
public:
static int^ UsedCountByStringId(
    String^ idString
)

Parameters

idString
Type: String
The event name.

Return Value

System.Int32.

See Also

EventsLua Class
wManager.Wow.Helpers Namespace


EventsLua.MethodDelegate Delegate

EventsLua..::..MethodDelegate Delegate

Delegate MethodDelegate

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public delegate void MethodDelegate(
    Object context
)
Public Delegate Sub MethodDelegate ( _
    context As Object _
)
public delegate void MethodDelegate(
    Object^ context
)

Parameters

context
Type: Object
The context.

See Also

wManager.Wow.Helpers Namespace


EventsLuaWithArgs Class

Class EventsLuaWithArgs. (if you don't need event arguments prefer to use EventsLua). Facilitates access from the bot to the in game lua events https://wowwiki.fandom.com/wiki/Event_API .

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class EventsLuaWithArgs
Public Class EventsLuaWithArgs
public ref class EventsLuaWithArgs

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..EventsLuaWithArgs

See Also

EventsLuaWithArgs Members
wManager.Wow.Helpers Namespace


EventsLuaWithArgs Members

The EventsLuaWithArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Events

Name | Description
OnEventsLuaStringWithArgs | Occurs when new events lua.
OnEventsLuaWithArgs | Occurs when new events lua.

See Also

EventsLuaWithArgs Class
wManager.Wow.Helpers Namespace


EventsLuaWithArgs Methods

The EventsLuaWithArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

EventsLuaWithArgs Class
wManager.Wow.Helpers Namespace


EventsLuaWithArgs Events

The EventsLuaWithArgs type exposes the following members.

Events

Name | Description
OnEventsLuaStringWithArgs | Occurs when new events lua.
OnEventsLuaWithArgs | Occurs when new events lua.

See Also

EventsLuaWithArgs Class
wManager.Wow.Helpers Namespace


OnEventsLuaStringWithArgs Event

EventsLuaWithArgs..::..OnEventsLuaStringWithArgs Event

Occurs when new events lua.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static event EventsLuaWithArgs..::..EventsLuaStringWithArgsHandler OnEventsLuaStringWithArgs
Public Shared Event OnEventsLuaStringWithArgs As EventsLuaWithArgs..::..EventsLuaStringWithArgsHandler
public:
static  event EventsLuaWithArgs..::..EventsLuaStringWithArgsHandler^ OnEventsLuaStringWithArgs {
    void add (EventsLuaWithArgs..::..EventsLuaStringWithArgsHandler^ value);
    void remove (EventsLuaWithArgs..::..EventsLuaStringWithArgsHandler^ value);
}

See Also

EventsLuaWithArgs Class
wManager.Wow.Helpers Namespace


OnEventsLuaWithArgs Event

EventsLuaWithArgs..::..OnEventsLuaWithArgs Event

Occurs when new events lua.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static event EventsLuaWithArgs..::..EventsLuaWithArgsHandler OnEventsLuaWithArgs
Public Shared Event OnEventsLuaWithArgs As EventsLuaWithArgs..::..EventsLuaWithArgsHandler
public:
static  event EventsLuaWithArgs..::..EventsLuaWithArgsHandler^ OnEventsLuaWithArgs {
    void add (EventsLuaWithArgs..::..EventsLuaWithArgsHandler^ value);
    void remove (EventsLuaWithArgs..::..EventsLuaWithArgsHandler^ value);
}

See Also

EventsLuaWithArgs Class
wManager.Wow.Helpers Namespace


EventsLuaWithArgs.EventsLuaStringWithArgsHandler Delegate

EventsLuaWithArgs..::..EventsLuaStringWithArgsHandler Delegate

Delegate EventsLuaStringWithArgsHandler

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public delegate void EventsLuaStringWithArgsHandler(
    string eventid,
    List<string> args
)
Public Delegate Sub EventsLuaStringWithArgsHandler ( _
    eventid As String, _
    args As List(Of String) _
)
public delegate void EventsLuaStringWithArgsHandler(
    String^ eventid,
    List<String^>^ args
)

Parameters

eventid
Type: String
The event name.
args
Type: List <(Of <(<' String >)>)>
The arguments.

See Also

wManager.Wow.Helpers Namespace


EventsLuaWithArgs.EventsLuaWithArgsHandler Delegate

EventsLuaWithArgs..::..EventsLuaWithArgsHandler Delegate

Delegate EventsLuaWithArgsHandler

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public delegate void EventsLuaWithArgsHandler(
    LuaEventsId id,
    List<string> args
)
Public Delegate Sub EventsLuaWithArgsHandler ( _
    id As LuaEventsId, _
    args As List(Of String) _
)
public delegate void EventsLuaWithArgsHandler(
    LuaEventsId^ id,
    List<String^>^ args
)

Parameters

id
Type: wManager.Wow.Enums..::..LuaEventsId
The event id.
args
Type: List <(Of <(<' String >)>)>
The arguments.

See Also

wManager.Wow.Helpers Namespace


Fight Class

Class Fight. Used to fight the WoWUnit.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class Fight
Public NotInheritable Class Fight
public ref class Fight abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..Fight

See Also

Fight Members
wManager.Wow.Helpers Namespace


Fight Members

The Fight type exposes the following members.

Methods

Name | Description
StartFight(Boolean, Boolean, Boolean, Boolean) | Starts the fight.
StartFight(UInt64, Boolean, Boolean, Boolean, Boolean) | Starts the fight.
StopFight | Stops the fight.

Fields

Name | Description
CombatStartAtTime | The combat start time (Times).
FightLock | The fight locker
MaxEvadeCount | The maximum evade count per combat (you need also to active DetectEvadingMob)

Properties

Name | Description
CombatStartSince | Get combat elapsed time (in milliseconds)
CurrentTarget | Get or set the current target (avoid changing it unless you know what you are doing).
EvadeCountCurrentCombat | Evade count of current combat.
InFight | Get or set a value indicating whether in fight. Do not confuse with InCombat, if it returns true it means that StartFight(Boolean, Boolean, Boolean, Boolean) has been called.

See Also

Fight Class
wManager.Wow.Helpers Namespace


Fight Fields

The Fight type exposes the following members.

Fields

Name | Description
CombatStartAtTime | The combat start time (Times).
FightLock | The fight locker
MaxEvadeCount | The maximum evade count per combat (you need also to active DetectEvadingMob)

See Also

Fight Class
wManager.Wow.Helpers Namespace


CombatStartAtTime Field

Fight..::..CombatStartAtTime Field

The combat start time (Times).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static long CombatStartAtTime
Public Shared CombatStartAtTime As Long
public:
static long long^ CombatStartAtTime

See Also

Fight Class
wManager.Wow.Helpers Namespace


FightLock Field

Fight..::..FightLock Field

The fight locker

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static Object FightLock
Public Shared FightLock As Object
public:
static Object^ FightLock

See Also

Fight Class
wManager.Wow.Helpers Namespace


MaxEvadeCount Field

Fight..::..MaxEvadeCount Field

The maximum evade count per combat (you need also to active DetectEvadingMob)

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int MaxEvadeCount
Public Shared MaxEvadeCount As Integer
public:
static int^ MaxEvadeCount

See Also

Fight Class
wManager.Wow.Helpers Namespace


Fight Methods

The Fight type exposes the following members.

Methods

Name | Description
StartFight(Boolean, Boolean, Boolean, Boolean) | Starts the fight.
StartFight(UInt64, Boolean, Boolean, Boolean, Boolean) | Starts the fight.
StopFight | Stops the fight.

See Also

Fight Class
wManager.Wow.Helpers Namespace


StartFight Method

Fight..::..StartFight Method

Overload List

Name | Description
StartFight(Boolean, Boolean, Boolean, Boolean) | Starts the fight.
StartFight(UInt64, Boolean, Boolean, Boolean, Boolean) | Starts the fight.

See Also

Fight Class
Fight Members
wManager.Wow.Helpers Namespace


StartFight Method (Boolean, Boolean, Boolean, Boolean)

Fight..::..StartFight Method (Boolean, Boolean, Boolean, Boolean)

Starts the fight.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static ulong StartFight(
    bool skipIfPlayerAttackedButNotByTheTarget,
    bool managerMovement,
    bool stopIfPlayerTargetChange,
    bool rotationBot
)
Public Shared Function StartFight ( _
    skipIfPlayerAttackedButNotByTheTarget As Boolean, _
    managerMovement As Boolean, _
    stopIfPlayerTargetChange As Boolean, _
    rotationBot As Boolean _
) As ULong
public:
static unsigned long long^ StartFight(
    bool^ skipIfPlayerAttackedButNotByTheTarget,
    bool^ managerMovement,
    bool^ stopIfPlayerTargetChange,
    bool^ rotationBot
)

Parameters

skipIfPlayerAttackedButNotByTheTarget
Type: Boolean
if set to true skip if player attacked but not by the target.
managerMovement
Type: Boolean
if set to true user can manager movement.
stopIfPlayerTargetChange
Type: Boolean
if set to true stop fight if character target change.
rotationBot
Type: Boolean
if set to true it is rotation bot (used by product WRotation).

Return Value

Usually if all goes well, the method returns 0, if there is a problem it returns the GUID of the target (it is generally necessary to blacklist him in this case)

See Also

Fight Class
StartFight Overload
wManager.Wow.Helpers Namespace


StartFight Method (UInt64, Boolean, Boolean, Boolean, Boolean)

Fight..::..StartFight Method (UInt64, Boolean, Boolean, Boolean, Boolean)

Starts the fight.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static ulong StartFight(
    ulong guid,
    bool skipIfPlayerAttackedButNotByTheTarget,
    bool managerMovement,
    bool stopIfPlayerTargetChange,
    bool rotationBot
)
Public Shared Function StartFight ( _
    guid As ULong, _
    skipIfPlayerAttackedButNotByTheTarget As Boolean, _
    managerMovement As Boolean, _
    stopIfPlayerTargetChange As Boolean, _
    rotationBot As Boolean _
) As ULong
public:
static unsigned long long^ StartFight(
    unsigned long long^ guid,
    bool^ skipIfPlayerAttackedButNotByTheTarget,
    bool^ managerMovement,
    bool^ stopIfPlayerTargetChange,
    bool^ rotationBot
)

Parameters

guid
Type: UInt64
Guid to attack.
skipIfPlayerAttackedButNotByTheTarget
Type: Boolean
if set to true skip if player attacked but not by the target.
managerMovement
Type: Boolean
if set to true user can manager movement.
stopIfPlayerTargetChange
Type: Boolean
if set to true stop fight if character target change.
rotationBot
Type: Boolean
if set to true it is rotation bot (used by product WRotation).

Return Value

Usually if all goes well, the method returns 0, if there is a problem it returns the GUID of the target (it is generally necessary to blacklist him in this case)

See Also

Fight Class
StartFight Overload
wManager.Wow.Helpers Namespace


StopFight Method

Fight..::..StopFight Method

Stops the fight.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void StopFight()
Public Shared Sub StopFight
public:
static void StopFight()

See Also

Fight Class
wManager.Wow.Helpers Namespace


Fight Properties

The Fight type exposes the following members.

Properties

Name | Description
CombatStartSince | Get combat elapsed time (in milliseconds)
CurrentTarget | Get or set the current target (avoid changing it unless you know what you are doing).
EvadeCountCurrentCombat | Evade count of current combat.
InFight | Get or set a value indicating whether in fight. Do not confuse with InCombat, if it returns true it means that StartFight(Boolean, Boolean, Boolean, Boolean) has been called.

See Also

Fight Class
wManager.Wow.Helpers Namespace


CombatStartSince Property

Fight..::..CombatStartSince Property

Get combat elapsed time (in milliseconds)

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static long CombatStartSince { get; }
Public Shared ReadOnly Property CombatStartSince As Long
    Get
public:
static property long long^ CombatStartSince {
    long long^ get ();
}

Field Value

combat elapsed time (in milliseconds).

See Also

Fight Class
wManager.Wow.Helpers Namespace


CurrentTarget Property

Fight..::..CurrentTarget Property

Get or set the current target (avoid changing it unless you know what you are doing).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static WoWUnit CurrentTarget { get; set; }
Public Shared Property CurrentTarget As WoWUnit
    Get
    Set
public:
static property WoWUnit^ CurrentTarget {
    WoWUnit^ get ();
    void set (WoWUnit^ value);
}

Field Value

The current target.

See Also

Fight Class
wManager.Wow.Helpers Namespace


EvadeCountCurrentCombat Property

Fight..::..EvadeCountCurrentCombat Property

Evade count of current combat.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int EvadeCountCurrentCombat { get; set; }
Public Shared Property EvadeCountCurrentCombat As Integer
    Get
    Set
public:
static property int^ EvadeCountCurrentCombat {
    int^ get ();
    void set (int^ value);
}

See Also

Fight Class
wManager.Wow.Helpers Namespace


InFight Property

Fight..::..InFight Property

Get or set a value indicating whether in fight. Do not confuse with InCombat, if it returns true it means that StartFight(Boolean, Boolean, Boolean, Boolean) has been called.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool InFight { get; set; }
Public Shared Property InFight As Boolean
    Get
    Set
public:
static property bool^ InFight {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if in fight; otherwise, false.

See Also

Fight Class
wManager.Wow.Helpers Namespace


FightBattlePet Class

Class FightBattlePet. Used to manage behaviour and abilities during pet battles.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class FightBattlePet
Public NotInheritable Class FightBattlePet
public ref class FightBattlePet abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..FightBattlePet

See Also

FightBattlePet Members
wManager.Wow.Helpers Namespace


FightBattlePet Members

The FightBattlePet type exposes the following members.

Methods

Name | Description
StartFight()()()() | Starts the fight.
StartFight(UInt64) | Starts the fight.

Fields

Name | Description
AbilitiesBlackListed | The abilities black listed
AutoChooseBestPet | Automatic choose best pet in relation to the type of pet to fight
AutoOrderPetByLevel | Automatic order pets by level
CaptureAllPets | The capture all pets
CaptureIDontHavePets | Capture pet if I do not have it
CaptureRarePets | Capture rare pets
LuaCode | Lua code hook (Empty if no code is used, code is used before combat rotation)
PetBattlesDontFight | Starting pet battles but don't fight (if you use another addon for rotation)

Properties

Name | Description
FightClass | Get or set the pet battles fight class file, empty if you want use default class (relative to the folder "WRobot\FightClass\Pet Battle\", value like "MyPetFightclass.cs" , you can found sample code in FightBattlePet..::..IFightClassPet description).
FightClassPet | Get or set the pet fight class (if no assigned use DefaultPetBattleFightClass).

See Also

FightBattlePet Class
wManager.Wow.Helpers Namespace


FightBattlePet Fields

The FightBattlePet type exposes the following members.

Fields

Name | Description
AbilitiesBlackListed | The abilities black listed
AutoChooseBestPet | Automatic choose best pet in relation to the type of pet to fight
AutoOrderPetByLevel | Automatic order pets by level
CaptureAllPets | The capture all pets
CaptureIDontHavePets | Capture pet if I do not have it
CaptureRarePets | Capture rare pets
LuaCode | Lua code hook (Empty if no code is used, code is used before combat rotation)
PetBattlesDontFight | Starting pet battles but don't fight (if you use another addon for rotation)

See Also

FightBattlePet Class
wManager.Wow.Helpers Namespace


AbilitiesBlackListed Field

FightBattlePet..::..AbilitiesBlackListed Field

The abilities black listed

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<string> AbilitiesBlackListed
Public Shared AbilitiesBlackListed As List(Of String)
public:
static List<String^>^ AbilitiesBlackListed

See Also

FightBattlePet Class
wManager.Wow.Helpers Namespace


AutoChooseBestPet Field

FightBattlePet..::..AutoChooseBestPet Field

Automatic choose best pet in relation to the type of pet to fight

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool AutoChooseBestPet
Public Shared AutoChooseBestPet As Boolean
public:
static bool^ AutoChooseBestPet

See Also

FightBattlePet Class
wManager.Wow.Helpers Namespace


AutoOrderPetByLevel Field

FightBattlePet..::..AutoOrderPetByLevel Field

Automatic order pets by level

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool AutoOrderPetByLevel
Public Shared AutoOrderPetByLevel As Boolean
public:
static bool^ AutoOrderPetByLevel

See Also

FightBattlePet Class
wManager.Wow.Helpers Namespace


CaptureAllPets Field

FightBattlePet..::..CaptureAllPets Field

The capture all pets

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool CaptureAllPets
Public Shared CaptureAllPets As Boolean
public:
static bool^ CaptureAllPets

See Also

FightBattlePet Class
wManager.Wow.Helpers Namespace


CaptureIDontHavePets Field

FightBattlePet..::..CaptureIDontHavePets Field

Capture pet if I do not have it

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool CaptureIDontHavePets
Public Shared CaptureIDontHavePets As Boolean
public:
static bool^ CaptureIDontHavePets

See Also

FightBattlePet Class
wManager.Wow.Helpers Namespace


CaptureRarePets Field

FightBattlePet..::..CaptureRarePets Field

Capture rare pets

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool CaptureRarePets
Public Shared CaptureRarePets As Boolean
public:
static bool^ CaptureRarePets

See Also

FightBattlePet Class
wManager.Wow.Helpers Namespace


LuaCode Field

FightBattlePet..::..LuaCode Field

Lua code hook (Empty if no code is used, code is used before combat rotation)

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string LuaCode
Public Shared LuaCode As String
public:
static String^ LuaCode

See Also

FightBattlePet Class
wManager.Wow.Helpers Namespace


PetBattlesDontFight Field

FightBattlePet..::..PetBattlesDontFight Field

Starting pet battles but don't fight (if you use another addon for rotation)

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool PetBattlesDontFight
Public Shared PetBattlesDontFight As Boolean
public:
static bool^ PetBattlesDontFight

See Also

FightBattlePet Class
wManager.Wow.Helpers Namespace


FightBattlePet Methods

The FightBattlePet type exposes the following members.

Methods

Name | Description
StartFight()()()() | Starts the fight.
StartFight(UInt64) | Starts the fight.

See Also

FightBattlePet Class
wManager.Wow.Helpers Namespace


StartFight Method

FightBattlePet..::..StartFight Method

Overload List

Name | Description
StartFight()()()() | Starts the fight.
StartFight(UInt64) | Starts the fight.

See Also

FightBattlePet Class
FightBattlePet Members
wManager.Wow.Helpers Namespace


StartFight Method

FightBattlePet..::..StartFight Method

Starts the fight.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void StartFight()
Public Shared Sub StartFight
public:
static void StartFight()

See Also

FightBattlePet Class
StartFight Overload
wManager.Wow.Helpers Namespace


StartFight Method (UInt64)

FightBattlePet..::..StartFight Method (UInt64)

Starts the fight.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void StartFight(
    ulong guid
)
Public Shared Sub StartFight ( _
    guid As ULong _
)
public:
static void StartFight(
    unsigned long long^ guid
)

Parameters

guid
Type: UInt64
The GUID of pet to attack.

See Also

FightBattlePet Class
StartFight Overload
wManager.Wow.Helpers Namespace


FightBattlePet Properties

The FightBattlePet type exposes the following members.

Properties

Name | Description
FightClass | Get or set the pet battles fight class file, empty if you want use default class (relative to the folder "WRobot\FightClass\Pet Battle\", value like "MyPetFightclass.cs" , you can found sample code in FightBattlePet..::..IFightClassPet description).
FightClassPet | Get or set the pet fight class (if no assigned use DefaultPetBattleFightClass).

See Also

FightBattlePet Class
wManager.Wow.Helpers Namespace


FightClass Property

FightBattlePet..::..FightClass Property

Get or set the pet battles fight class file, empty if you want use default class (relative to the folder "WRobot\FightClass\Pet Battle\", value like "MyPetFightclass.cs" , you can found sample code in FightBattlePet..::..IFightClassPet description).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string FightClass { get; set; }
Public Shared Property FightClass As String
    Get
    Set
public:
static property String^ FightClass {
    String^ get ();
    void set (String^ value);
}

Field Value

The fight class.

See Also

FightBattlePet Class
wManager.Wow.Helpers Namespace


FightClassPet Property

FightBattlePet..::..FightClassPet Property

Get or set the pet fight class (if no assigned use DefaultPetBattleFightClass).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static FightBattlePet..::..IFightClassPet FightClassPet { get; set; }
Public Shared Property FightClassPet As FightBattlePet..::..IFightClassPet
    Get
    Set
public:
static property FightBattlePet..::..IFightClassPet^ FightClassPet {
    FightBattlePet..::..IFightClassPet^ get ();
    void set (FightBattlePet..::..IFightClassPet^ value);
}

Field Value

The pet fight class.

See Also

FightBattlePet Class
wManager.Wow.Helpers Namespace


FightBattlePet.IFightClassPet Interface

FightBattlePet..::..IFightClassPet Interface

Interface IFightClassPet

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public interface IFightClassPet
Public Interface IFightClassPet
public interface class IFightClassPet

Examples

C#
using System.Threading;
   using robotManager.Helpful;
   using wManager.Wow.Helpers;
   using Timer = robotManager.Helpful.Timer;

   public class Main : FightBattlePet.IFightClassPet
   {
       /// <summary>
       /// Called every 1000 ms in combat
       /// </summary>
       public void PulseInCombat()
       {
           if (!PetBattles.ActionSelected() && !PetBattles.IsWaitingOnOpponent())
           {

               if (!string.IsNullOrWhiteSpace(FightBattlePet.LuaCode))
               {
                   Lua.LuaDoString(FightBattlePet.LuaCode);
                   Thread.Sleep(Usefuls.Latency + 300);
                   if (PetBattles.ActionSelected() || PetBattles.IsWaitingOnOpponent())
                       return;
               }

               if (PetBattles.IsDeadPet(PetBattles.PetFaction.Ally, PetBattles.GetActivePet(PetBattles.PetFaction.Ally)))
               {
                   PetBattles.ChangeToBestPet();
                   return;
               }

               if (TargetTypeIsWeaknesses())
                   PetBattles.ChangeToBestPet();
               else if (PetBattles.GetNumberUsableAbility() <= 0)
               {
                   PetBattles.SkipTurn();
                   //PetBattles.ChangeToBestPet();
               }
               else if (TrapUsable())
                   PetBattles.UseTrap();
               else if (!FightBattlePet.PetBattlesDontFight)
                   PetBattles.UseBestAbility();
           }
       }

       private Timer _timerAutoOrderPet = new Timer(-1);
       private Timer _timerSpellRevive = new Timer(-1);

       /// <summary>
       /// Pulses the out of combat.
       /// </summary>
       public void PulseOutOfCombat()
       {
           if (PetBattles.ConditionResurrectBattlePets)
           {
               if (!PetBattles.ReviveBattlePets())
               {
                   if (PetBattles.AllPetDead())
                   {
                       ItemsManager.UseItem(86143); // Battle Pet Bandage
                       Usefuls.WaitIsCasting();

                       if (PetBattles.AllPetDead() && _timerSpellRevive.IsReady)
                       {
                           Logging.Write("[FightPetBattle] Revive Battle Pets spell not ready, wait");
                           _timerSpellRevive = new Timer(1000 * 20);

                           // Wait revive:
                           /*while (Conditions.InGameAndConnectedAndAliveAndProductStartedNotInPause &&
                                  !Conditions.IsAttackedAndCannotIgnore)
                           {
                               if (_timerSpellRevive.IsReady)
                               {
                                   PetBattles.ReviveBattlePets();
                                   if (!PetBattles.AllPetDead())
                                       break;

                                   AntiAfk.Pulse();
                                   _timerSpellRevive.Reset();
                               }
                               Thread.Sleep(50);
                           }*/
                       }
                   }
               }
           }

           if (FightBattlePet.AutoOrderPetByLevel && _timerAutoOrderPet.IsReady)
           {
               PetBattles.AutoOrderPetInJournalByLevel();
               _timerAutoOrderPet = new Timer(1000 * 60);
           }
       }

       private bool TargetTypeIsWeaknesses()
       {
           if (FightBattlePet.AutoChooseBestPet)
           {
               var typeEffects = PetBattles.TypeEffects.Find(effects => effects.Type == PetBattles.GetPetType(PetBattles.PetFaction.Ally, PetBattles.GetActivePet(PetBattles.PetFaction.Ally)));
               if (typeEffects != null)
               {
                   if (typeEffects.Weak == PetBattles.GetPetType(PetBattles.PetFaction.Enemy, PetBattles.GetActivePet(PetBattles.PetFaction.Enemy)))
                   {
                       return true;
                   }
               }
           }
           return false;
       }

       private bool TrapUsable()
       {
           bool conditionsTrap = false;
           if (PetBattles.IsTrapAvailable())
           {
               if (FightBattlePet.CaptureAllPets)
               {
                   conditionsTrap = true;
               }
               else if (FightBattlePet.CaptureRarePets)
               {
                   var quality = PetBattles.GetBreedQuality(PetBattles.PetFaction.Enemy, PetBattles.GetActivePet(PetBattles.PetFaction.Enemy));
                   if (quality == PetBattles.PetQuality.Rare ||
                       quality == PetBattles.PetQuality.Legendary ||
                       quality == PetBattles.PetQuality.Epic)
                       conditionsTrap = true;
               }
               if (FightBattlePet.CaptureIDontHavePets &&
                   conditionsTrap &&
                   PetBattles.PetJournalHavePet(PetBattles.GetPetSpeciesID(PetBattles.PetFaction.Enemy, PetBattles.GetActivePet(PetBattles.PetFaction.Enemy))))
               {
                   conditionsTrap = false;
               }
           }
           return conditionsTrap;
       }
   }

See Also

FightBattlePet..::..IFightClassPet Members
wManager.Wow.Helpers Namespace


FightBattlePet.IFightClassPet Members

FightBattlePet..::..IFightClassPet Members

The FightBattlePet..::..IFightClassPet type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | PulseInCombat | Called every 1000 ms in combat
Public method | PulseOutOfCombat | Called every 200 ms out of combat
Public method | ToString | (Inherited from Object.)

See Also

FightBattlePet..::..IFightClassPet Interface
wManager.Wow.Helpers Namespace


FightBattlePet.IFightClassPet Methods

FightBattlePet..::..IFightClassPet Methods

The FightBattlePet..::..IFightClassPet type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | PulseInCombat | Called every 1000 ms in combat
Public method | PulseOutOfCombat | Called every 200 ms out of combat
Public method | ToString | (Inherited from Object.)

See Also

FightBattlePet..::..IFightClassPet Interface
wManager.Wow.Helpers Namespace


PulseInCombat Method

IFightClassPet..::..PulseInCombat Method

Called every 1000 ms in combat

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
void PulseInCombat()
Sub PulseInCombat
void PulseInCombat()

See Also

FightBattlePet..::..IFightClassPet Interface
wManager.Wow.Helpers Namespace


PulseOutOfCombat Method

IFightClassPet..::..PulseOutOfCombat Method

Called every 200 ms out of combat

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
void PulseOutOfCombat()
Sub PulseOutOfCombat
void PulseOutOfCombat()

See Also

FightBattlePet..::..IFightClassPet Interface
wManager.Wow.Helpers Namespace


FightBG Class

Class FightBG. Used to fight the WoWPlayer.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class FightBG
Public NotInheritable Class FightBG
public ref class FightBG abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..FightBG

See Also

FightBG Members
wManager.Wow.Helpers Namespace


FightBG Members

The FightBG type exposes the following members.

Methods

Name | Description
StartFight()()()() | Starts the fight.
StartFight(UInt64) | Starts the fight.
StopFight | Stops the fight.

Fields

Name | Description
MoveDuringCombat | Move the character during the fight (to appear more human)

Properties

Name | Description
CombatStartAtTime | The combat start time (use CombatStartAtTime).
CombatStartSince | Get combat elapsed time (in milliseconds)(use CombatStartSince).

See Also

FightBG Class
wManager.Wow.Helpers Namespace


FightBG Fields

The FightBG type exposes the following members.

Fields

Name | Description
MoveDuringCombat | Move the character during the fight (to appear more human)

See Also

FightBG Class
wManager.Wow.Helpers Namespace


MoveDuringCombat Field

FightBG..::..MoveDuringCombat Field

Move the character during the fight (to appear more human)

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool MoveDuringCombat
Public Shared MoveDuringCombat As Boolean
public:
static bool^ MoveDuringCombat

See Also

FightBG Class
wManager.Wow.Helpers Namespace


FightBG Methods

The FightBG type exposes the following members.

Methods

Name | Description
StartFight()()()() | Starts the fight.
StartFight(UInt64) | Starts the fight.
StopFight | Stops the fight.

See Also

FightBG Class
wManager.Wow.Helpers Namespace


StartFight Method

FightBG..::..StartFight Method

Overload List

Name | Description
StartFight()()()() | Starts the fight.
StartFight(UInt64) | Starts the fight.

See Also

FightBG Class
FightBG Members
wManager.Wow.Helpers Namespace


StartFight Method

FightBG..::..StartFight Method

Starts the fight.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static ulong StartFight()
Public Shared Function StartFight As ULong
public:
static unsigned long long^ StartFight()

Return Value

Usually if all goes well, the method returns 0, if there is a problem it returns the GUID of the target (it is generally necessary to blacklist him in this case)

See Also

FightBG Class
StartFight Overload
wManager.Wow.Helpers Namespace


StartFight Method (UInt64)

FightBG..::..StartFight Method (UInt64)

Starts the fight.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static ulong StartFight(
    ulong guid
)
Public Shared Function StartFight ( _
    guid As ULong _
) As ULong
public:
static unsigned long long^ StartFight(
    unsigned long long^ guid
)

Parameters

guid
Type: UInt64
Guid to attack.

Return Value

Usually if all goes well, the method returns 0, if there is a problem it returns the GUID of the target (it is generally necessary to blacklist him in this case)

See Also

FightBG Class
StartFight Overload
wManager.Wow.Helpers Namespace


StopFight Method

FightBG..::..StopFight Method

Stops the fight.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void StopFight()
Public Shared Sub StopFight
public:
static void StopFight()

See Also

FightBG Class
wManager.Wow.Helpers Namespace


FightBG Properties

The FightBG type exposes the following members.

Properties

Name | Description
CombatStartAtTime | The combat start time (use CombatStartAtTime).
CombatStartSince | Get combat elapsed time (in milliseconds)(use CombatStartSince).

See Also

FightBG Class
wManager.Wow.Helpers Namespace


CombatStartAtTime Property

FightBG..::..CombatStartAtTime Property

The combat start time (use CombatStartAtTime).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static long CombatStartAtTime { get; set; }
Public Shared Property CombatStartAtTime As Long
    Get
    Set
public:
static property long long^ CombatStartAtTime {
    long long^ get ();
    void set (long long^ value);
}

See Also

FightBG Class
wManager.Wow.Helpers Namespace


CombatStartSince Property

FightBG..::..CombatStartSince Property

Get combat elapsed time (in milliseconds)(use CombatStartSince).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static long CombatStartSince { get; }
Public Shared ReadOnly Property CombatStartSince As Long
    Get
public:
static property long long^ CombatStartSince {
    long long^ get ();
}

Field Value

combat elapsed time (in milliseconds).

See Also

FightBG Class
wManager.Wow.Helpers Namespace


Fishing Class

Class Fishing. Useful method for fishing

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class Fishing
Public NotInheritable Class Fishing
public ref class Fishing abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..Fishing

See Also

Fishing Members
wManager.Wow.Helpers Namespace


Fishing Members

The Fishing type exposes the following members.

Methods

Name | Description
EquipFishingPoles | Equip fishing poles.
FindTheUltimatePoint | Find a point around the fishing hole from where we can land to fish
FishingPolesName | Get name of first fishing pole
IsEquipedFishingPoles | Determines whether fishing pole is equipped
LureName | get first lure name
SearchBobber | Return a bobber WoWGameObject address.
UseCustom | Use custom item or spell.
UseLure | Use lure.
UseTemporaryBait | Use temporary bait.

See Also

Fishing Class
wManager.Wow.Helpers Namespace


Fishing Methods

The Fishing type exposes the following members.

Methods

Name | Description
EquipFishingPoles | Equip fishing poles.
FindTheUltimatePoint | Find a point around the fishing hole from where we can land to fish
FishingPolesName | Get name of first fishing pole
IsEquipedFishingPoles | Determines whether fishing pole is equipped
LureName | get first lure name
SearchBobber | Return a bobber WoWGameObject address.
UseCustom | Use custom item or spell.
UseLure | Use lure.
UseTemporaryBait | Use temporary bait.

See Also

Fishing Class
wManager.Wow.Helpers Namespace


EquipFishingPoles Method

Fishing..::..EquipFishingPoles Method

Equip fishing poles.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void EquipFishingPoles(
    string fishingPoleName
)
Public Shared Sub EquipFishingPoles ( _
    fishingPoleName As String _
)
public:
static void EquipFishingPoles(
    String^ fishingPoleName
)

Parameters

fishingPoleName
Type: String
Name of the fishing pole.

See Also

Fishing Class
wManager.Wow.Helpers Namespace


FindTheUltimatePoint Method

Fishing..::..FindTheUltimatePoint Method

Find a point around the fishing hole from where we can land to fish

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static Vector3 FindTheUltimatePoint(
    Vector3 fishingHole,
    bool canWalkOnWater
)
Public Shared Function FindTheUltimatePoint ( _
    fishingHole As Vector3, _
    canWalkOnWater As Boolean _
) As Vector3
public:
static Vector3^ FindTheUltimatePoint(
    Vector3^ fishingHole,
    bool^ canWalkOnWater
)

Parameters

fishingHole
Type: robotManager.Helpful..::..Vector3
The fishing hole.
canWalkOnWater
Type: Boolean
if set to true can walk on water.

Return Value

Vector3.

See Also

Fishing Class
wManager.Wow.Helpers Namespace


FishingPolesName Method

Fishing..::..FishingPolesName Method

Get name of first fishing pole

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string FishingPolesName()
Public Shared Function FishingPolesName As String
public:
static String^ FishingPolesName()

Return Value

System.String.

See Also

Fishing Class
wManager.Wow.Helpers Namespace


IsEquipedFishingPoles Method

Fishing..::..IsEquipedFishingPoles Method

Determines whether fishing pole is equipped

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool IsEquipedFishingPoles(
    string fishingPoleName
)
Public Shared Function IsEquipedFishingPoles ( _
    fishingPoleName As String _
) As Boolean
public:
static bool^ IsEquipedFishingPoles(
    String^ fishingPoleName
)

Parameters

fishingPoleName
Type: String
Name of the fishing pole.

Return Value

true if fishing pole is equipped; otherwise, false.

See Also

Fishing Class
wManager.Wow.Helpers Namespace


LureName Method

Fishing..::..LureName Method

get first lure name

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string LureName()
Public Shared Function LureName As String
public:
static String^ LureName()

Return Value

first lure name.

See Also

Fishing Class
wManager.Wow.Helpers Namespace


SearchBobber Method

Fishing..::..SearchBobber Method

Return a bobber WoWGameObject address.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static uint SearchBobber()
Public Shared Function SearchBobber As UInteger
public:
static unsigned int^ SearchBobber()

Return Value

address of WoWGameObject.

See Also

Fishing Class
wManager.Wow.Helpers Namespace


UseCustom Method

Fishing..::..UseCustom Method

Use custom item or spell.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void UseCustom(
    string customName,
    int durationMs
)
Public Shared Sub UseCustom ( _
    customName As String, _
    durationMs As Integer _
)
public:
static void UseCustom(
    String^ customName,
    int^ durationMs
)

Parameters

customName
Type: String
nameitem1;nameitem2;nameitem3
durationMs
Type: Int32
The duration in millisecond.

See Also

Fishing Class
wManager.Wow.Helpers Namespace


UseLure Method

Fishing..::..UseLure Method

Use lure.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void UseLure(
    string lureName
)
Public Shared Sub UseLure ( _
    lureName As String _
)
public:
static void UseLure(
    String^ lureName
)

Parameters

lureName
Type: String
lure1;lure2;lure3

See Also

Fishing Class
wManager.Wow.Helpers Namespace


UseTemporaryBait Method

Fishing..::..UseTemporaryBait Method

Use temporary bait.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void UseTemporaryBait(
    string temporaryBait,
    int durationMs
)
Public Shared Sub UseTemporaryBait ( _
    temporaryBait As String, _
    durationMs As Integer _
)
public:
static void UseTemporaryBait(
    String^ temporaryBait,
    int^ durationMs
)

Parameters

temporaryBait
Type: String
bait1;bait2;bait3
durationMs
Type: Int32
The duration in millisecond.

See Also

Fishing Class
wManager.Wow.Helpers Namespace


GetPlayerName Class

Class GetPlayerName.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class GetPlayerName
Public NotInheritable Class GetPlayerName
public ref class GetPlayerName abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..GetPlayerName

See Also

GetPlayerName Members
wManager.Wow.Helpers Namespace


GetPlayerName Members

The GetPlayerName type exposes the following members.

Methods

Name | Description
GetName | Gets the name.

See Also

GetPlayerName Class
wManager.Wow.Helpers Namespace


GetPlayerName Methods

The GetPlayerName type exposes the following members.

Methods

Name | Description
GetName | Gets the name.

See Also

GetPlayerName Class
wManager.Wow.Helpers Namespace


GetName Method

GetPlayerName..::..GetName Method

Gets the name.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string GetName(
    ulong guid
)
Public Shared Function GetName ( _
    guid As ULong _
) As String
public:
static String^ GetName(
    unsigned long long^ guid
)

Parameters

guid
Type: UInt64
The GUID.

Return Value

the name.

See Also

GetPlayerName Class
wManager.Wow.Helpers Namespace


ICustomClass Interface

Interface ICustomClass, used by fight classes: CustomClass

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public interface ICustomClass
Public Interface ICustomClass
public interface class ICustomClass

See Also

ICustomClass Members
wManager.Wow.Helpers Namespace


ICustomClass Members

The ICustomClass type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Dispose (bot calls this method when he wants to dispose fightclass (generally when product is stopped or character level up)).
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | Initialize | Initialize (bot creates new thread and calls this method, you need to keep this thread alive until the bot calls Dispose()()()()).
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ShowConfiguration | Show the configuration (called by the bot when user want configure fightclass, this method should display a configuration window).
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Range | Get combat range (5 for melee classes, 25-35 for ranged classes).

See Also

ICustomClass Interface
wManager.Wow.Helpers Namespace


ICustomClass Methods

The ICustomClass type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Dispose (bot calls this method when he wants to dispose fightclass (generally when product is stopped or character level up)).
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | Initialize | Initialize (bot creates new thread and calls this method, you need to keep this thread alive until the bot calls Dispose()()()()).
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ShowConfiguration | Show the configuration (called by the bot when user want configure fightclass, this method should display a configuration window).
Public method | ToString | (Inherited from Object.)

See Also

ICustomClass Interface
wManager.Wow.Helpers Namespace


Dispose Method

ICustomClass..::..Dispose Method

Dispose (bot calls this method when he wants to dispose fightclass (generally when product is stopped or character level up)).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
void Dispose()
Sub Dispose
void Dispose()

See Also

ICustomClass Interface
wManager.Wow.Helpers Namespace


Initialize Method

ICustomClass..::..Initialize Method

Initialize (bot creates new thread and calls this method, you need to keep this thread alive until the bot calls Dispose()()()()).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
void Initialize()
Sub Initialize
void Initialize()

See Also

ICustomClass Interface
wManager.Wow.Helpers Namespace


ShowConfiguration Method

ICustomClass..::..ShowConfiguration Method

Show the configuration (called by the bot when user want configure fightclass, this method should display a configuration window).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
void ShowConfiguration()
Sub ShowConfiguration
void ShowConfiguration()

See Also

ICustomClass Interface
wManager.Wow.Helpers Namespace


ICustomClass Properties

The ICustomClass type exposes the following members.

Properties

 | Name | Description
Public property | Range | Get combat range (5 for melee classes, 25-35 for ranged classes).

See Also

ICustomClass Interface
wManager.Wow.Helpers Namespace


Range Property

ICustomClass..::..Range Property

Get combat range (5 for melee classes, 25-35 for ranged classes).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
float Range { get; }
ReadOnly Property Range As Single
    Get
property float^ Range {
    float^ get ();
}

Field Value

The combat range.

See Also

ICustomClass Interface
wManager.Wow.Helpers Namespace


Interact Class

Class Interact.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class Interact
Public NotInheritable Class Interact
public ref class Interact abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..Interact

See Also

Interact Members
wManager.Wow.Helpers Namespace


Interact Members

The Interact type exposes the following members.

Methods

Name | Description
ClearTarget | Clear target.
InteractGameObject(UInt32, Boolean, Boolean) | Interacts with WoWUnit, WoWPlayer or WoWGameObject
InteractGameObject(UInt32, Boolean, Boolean, Boolean) | Interacts with WoWUnit, WoWPlayer or WoWGameObject
Repop | Releases your ghost to the graveyard.
RetrieveCorpse | Resurrects when the player is standing near its corpse.
SpiritHealerAccept | Accept Spirits healer.
TeleportToSpiritHealer | Obsolete. Teleports to spirit healer.

Fields

Name | Description
IncorrectCheckIfGoodMouseShortcuts | Number of time that IsGoodMouseShortcuts return false.

Properties

Name | Description
IsGoodMouseShortcuts | You can found description here: MaxCheckIfGoodMouseShortcutsWhenInteract

See Also

Interact Class
wManager.Wow.Helpers Namespace


Interact Fields

The Interact type exposes the following members.

Fields

Name | Description
IncorrectCheckIfGoodMouseShortcuts | Number of time that IsGoodMouseShortcuts return false.

See Also

Interact Class
wManager.Wow.Helpers Namespace


IncorrectCheckIfGoodMouseShortcuts Field

Interact..::..IncorrectCheckIfGoodMouseShortcuts Field

Number of time that IsGoodMouseShortcuts return false.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int IncorrectCheckIfGoodMouseShortcuts
Public Shared IncorrectCheckIfGoodMouseShortcuts As Integer
public:
static int^ IncorrectCheckIfGoodMouseShortcuts

See Also

Interact Class
wManager.Wow.Helpers Namespace


Interact Methods

The Interact type exposes the following members.

Methods

Name | Description
ClearTarget | Clear target.
InteractGameObject(UInt32, Boolean, Boolean) | Interacts with WoWUnit, WoWPlayer or WoWGameObject
InteractGameObject(UInt32, Boolean, Boolean, Boolean) | Interacts with WoWUnit, WoWPlayer or WoWGameObject
Repop | Releases your ghost to the graveyard.
RetrieveCorpse | Resurrects when the player is standing near its corpse.
SpiritHealerAccept | Accept Spirits healer.
TeleportToSpiritHealer | Obsolete. Teleports to spirit healer.

See Also

Interact Class
wManager.Wow.Helpers Namespace


ClearTarget Method

Interact..::..ClearTarget Method

Clear target.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void ClearTarget()
Public Shared Sub ClearTarget
public:
static void ClearTarget()

See Also

Interact Class
wManager.Wow.Helpers Namespace


InteractGameObject Method

Interact..::..InteractGameObject Method

Overload List

Name | Description
InteractGameObject(UInt32, Boolean, Boolean) | Interacts with WoWUnit, WoWPlayer or WoWGameObject
InteractGameObject(UInt32, Boolean, Boolean, Boolean) | Interacts with WoWUnit, WoWPlayer or WoWGameObject

See Also

Interact Class
Interact Members
wManager.Wow.Helpers Namespace


InteractGameObject Method (UInt32, Boolean, Boolean)

Interact..::..InteractGameObject Method (UInt32, Boolean, Boolean)

Interacts with WoWUnit, WoWPlayer or WoWGameObject

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool InteractGameObject(
    uint baseAddress,
    bool stopMove,
    bool skipWaitTime
)
Public Shared Function InteractGameObject ( _
    baseAddress As UInteger, _
    stopMove As Boolean, _
    skipWaitTime As Boolean _
) As Boolean
public:
static bool^ InteractGameObject(
    unsigned int^ baseAddress,
    bool^ stopMove,
    bool^ skipWaitTime
)

Parameters

baseAddress
Type: UInt32
The GetBaseAddress.
stopMove
Type: Boolean
if set to true stop move.
skipWaitTime
Type: Boolean
if set to true don't wait after interact (by default bot wait latency time).

Return Value

true if success, false otherwise.

See Also

Interact Class
InteractGameObject Overload
wManager.Wow.Helpers Namespace


InteractGameObject Method (UInt32, Boolean, Boolean, Boolean)

Interact..::..InteractGameObject Method (UInt32, Boolean, Boolean, Boolean)

Interacts with WoWUnit, WoWPlayer or WoWGameObject

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool InteractGameObject(
    uint baseAddress,
    bool stopMove,
    bool skipWaitTime,
    bool dismountBeforeIneract
)
Public Shared Function InteractGameObject ( _
    baseAddress As UInteger, _
    stopMove As Boolean, _
    skipWaitTime As Boolean, _
    dismountBeforeIneract As Boolean _
) As Boolean
public:
static bool^ InteractGameObject(
    unsigned int^ baseAddress,
    bool^ stopMove,
    bool^ skipWaitTime,
    bool^ dismountBeforeIneract
)

Parameters

baseAddress
Type: UInt32
The GetBaseAddress.
stopMove
Type: Boolean
if set to true stop move.
skipWaitTime
Type: Boolean
if set to true don't wait after interact (by default bot wait latency time).
dismountBeforeIneract
Type: Boolean
if set to true dismount before interact.

Return Value

true if success, false otherwise.

See Also

Interact Class
InteractGameObject Overload
wManager.Wow.Helpers Namespace


Repop Method

Interact..::..Repop Method

Releases your ghost to the graveyard.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void Repop()
Public Shared Sub Repop
public:
static void Repop()

See Also

Interact Class
wManager.Wow.Helpers Namespace


RetrieveCorpse Method

Interact..::..RetrieveCorpse Method

Resurrects when the player is standing near its corpse.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void RetrieveCorpse()
Public Shared Sub RetrieveCorpse
public:
static void RetrieveCorpse()

See Also

Interact Class
wManager.Wow.Helpers Namespace


SpiritHealerAccept Method

Interact..::..SpiritHealerAccept Method

Accept Spirits healer.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void SpiritHealerAccept()
Public Shared Sub SpiritHealerAccept
public:
static void SpiritHealerAccept()

See Also

Interact Class
wManager.Wow.Helpers Namespace


TeleportToSpiritHealer Method

Interact..::..TeleportToSpiritHealer Method

Note: This API is now obsolete.
Teleports to spirit healer.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[ObsoleteAttribute]
public static void TeleportToSpiritHealer()
<ObsoleteAttribute> _
Public Shared Sub TeleportToSpiritHealer
[ObsoleteAttribute]
public:
static void TeleportToSpiritHealer()

See Also

Interact Class
wManager.Wow.Helpers Namespace


Interact Properties

The Interact type exposes the following members.

Properties

Name | Description
IsGoodMouseShortcuts | You can found description here: MaxCheckIfGoodMouseShortcutsWhenInteract

See Also

Interact Class
wManager.Wow.Helpers Namespace


IsGoodMouseShortcuts Property

Interact..::..IsGoodMouseShortcuts Property

You can found description here: MaxCheckIfGoodMouseShortcutsWhenInteract

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool IsGoodMouseShortcuts { get; }
Public Shared ReadOnly Property IsGoodMouseShortcuts As Boolean
    Get
public:
static property bool^ IsGoodMouseShortcuts {
    bool^ get ();
}

See Also

Interact Class
wManager.Wow.Helpers Namespace


IsOutDoorsInjection Class

Class IsOutDoorsInjection.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class IsOutDoorsInjection
Public NotInheritable Class IsOutDoorsInjection
public ref class IsOutDoorsInjection abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..IsOutDoorsInjection

See Also

IsOutDoorsInjection Members
wManager.Wow.Helpers Namespace


IsOutDoorsInjection Members

The IsOutDoorsInjection type exposes the following members.

Methods

Name | Description
IsOutDoors | Returns whether the player's character is currently outdoors.

See Also

IsOutDoorsInjection Class
wManager.Wow.Helpers Namespace


IsOutDoorsInjection Methods

The IsOutDoorsInjection type exposes the following members.

Methods

Name | Description
IsOutDoors | Returns whether the player's character is currently outdoors.

See Also

IsOutDoorsInjection Class
wManager.Wow.Helpers Namespace


IsOutDoors Method

IsOutDoorsInjection..::..IsOutDoors Method

Returns whether the player's character is currently outdoors.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool IsOutDoors(
    uint baseAddress
)
Public Shared Function IsOutDoors ( _
    baseAddress As UInteger _
) As Boolean
public:
static bool^ IsOutDoors(
    unsigned int^ baseAddress
)

Parameters

baseAddress
Type: UInt32
The base address.

Return Value

true if character is currently outdoors.; otherwise, false.

See Also

IsOutDoorsInjection Class
wManager.Wow.Helpers Namespace


ItemsManager Class

Class ItemsManager. Useful method to manage items

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class ItemsManager
Public NotInheritable Class ItemsManager
public ref class ItemsManager abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..ItemsManager

See Also

ItemsManager Members
wManager.Wow.Helpers Namespace


ItemsManager Members

The ItemsManager type exposes the following members.

Methods

Name | Description
EquipItemByName | Equip item by name.
GetBestConsumableBag | Get the best consumable bag.
GetBestConsumableVendor | Get the best consumable of current target vendor (need merchant window opened).
GetBestContainers | Get the best bag.
GetIdByName | Gets the item name by id.
GetItemCountById | Get item count by id.
GetItemCountByIdLUA | Get item count by id with lua.
GetItemCountByNameLUA | Get item count by name with lua.
GetItemSpell(UInt32) | Get the item spell.
GetItemSpell(String) | Get the item spell.
GetNameById(Int32) | Get the item name by id.
GetNameById(UInt32) | Gets the item name by id.
HasItemById | Determines whether has item by id (use [ObjectManager], it's faster than lua).
IsEquippableItem | Determines whether is equippable item.
UseContainerItem(String) | Use container item by name.
UseContainerItem(UInt32) | Use the container item by id.
UseContainerItemByNameOrId | Use the container item by name like is appear in game or by item id.
UseItem(String) | Use the item.
UseItem(UInt32) | Use the item.
UseItem(UInt32, Vector3) | Use the item and mouse click at position.
UseItemByNameOrId | Use the item by name or id.

See Also

ItemsManager Class
wManager.Wow.Helpers Namespace


ItemsManager Methods

The ItemsManager type exposes the following members.

Methods

Name | Description
EquipItemByName | Equip item by name.
GetBestConsumableBag | Get the best consumable bag.
GetBestConsumableVendor | Get the best consumable of current target vendor (need merchant window opened).
GetBestContainers | Get the best bag.
GetIdByName | Gets the item name by id.
GetItemCountById | Get item count by id.
GetItemCountByIdLUA | Get item count by id with lua.
GetItemCountByNameLUA | Get item count by name with lua.
GetItemSpell(UInt32) | Get the item spell.
GetItemSpell(String) | Get the item spell.
GetNameById(Int32) | Get the item name by id.
GetNameById(UInt32) | Gets the item name by id.
HasItemById | Determines whether has item by id (use [ObjectManager], it's faster than lua).
IsEquippableItem | Determines whether is equippable item.
UseContainerItem(String) | Use container item by name.
UseContainerItem(UInt32) | Use the container item by id.
UseContainerItemByNameOrId | Use the container item by name like is appear in game or by item id.
UseItem(String) | Use the item.
UseItem(UInt32) | Use the item.
UseItem(UInt32, Vector3) | Use the item and mouse click at position.
UseItemByNameOrId | Use the item by name or id.

See Also

ItemsManager Class
wManager.Wow.Helpers Namespace


EquipItemByName Method

ItemsManager..::..EquipItemByName Method

Equip item by name.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void EquipItemByName(
    string itemName
)
Public Shared Sub EquipItemByName ( _
    itemName As String _
)
public:
static void EquipItemByName(
    String^ itemName
)

Parameters

itemName
Type: String
Item name like is appear in game.

See Also

ItemsManager Class
wManager.Wow.Helpers Namespace


GetBestConsumableBag Method

ItemsManager..::..GetBestConsumableBag Method

Get the best consumable bag.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string GetBestConsumableBag(
    ItemsManager..::..ConsumableType consumableType
)
Public Shared Function GetBestConsumableBag ( _
    consumableType As ItemsManager..::..ConsumableType _
) As String
public:
static String^ GetBestConsumableBag(
    ItemsManager..::..ConsumableType^ consumableType
)

Parameters

consumableType
Type: wManager.Wow.Helpers..::..ItemsManager..::..ConsumableType
Type of the consumable.

Return Value

item name.

See Also

ItemsManager Class
wManager.Wow.Helpers Namespace


GetBestConsumableVendor Method

ItemsManager..::..GetBestConsumableVendor Method

Get the best consumable of current target vendor (need merchant window opened).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string GetBestConsumableVendor(
    ItemsManager..::..ConsumableType consumableType
)
Public Shared Function GetBestConsumableVendor ( _
    consumableType As ItemsManager..::..ConsumableType _
) As String
public:
static String^ GetBestConsumableVendor(
    ItemsManager..::..ConsumableType^ consumableType
)

Parameters

consumableType
Type: wManager.Wow.Helpers..::..ItemsManager..::..ConsumableType
Type of the consumable.

Return Value

item name.

See Also

ItemsManager Class
wManager.Wow.Helpers Namespace


GetBestContainers Method

ItemsManager..::..GetBestContainers Method

Get the best bag.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string GetBestContainers()
Public Shared Function GetBestContainers As String
public:
static String^ GetBestContainers()

Return Value

bag name.

See Also

ItemsManager Class
wManager.Wow.Helpers Namespace


GetIdByName Method

ItemsManager..::..GetIdByName Method

Gets the item name by id.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static uint GetIdByName(
    string nameItem
)
Public Shared Function GetIdByName ( _
    nameItem As String _
) As UInteger
public:
static unsigned int^ GetIdByName(
    String^ nameItem
)

Parameters

nameItem
Type: String
The item name like is appear in game.

Return Value

item id.

See Also

ItemsManager Class
wManager.Wow.Helpers Namespace


GetItemCountById Method

ItemsManager..::..GetItemCountById Method

Get item count by id.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int GetItemCountById(
    uint itemId
)
Public Shared Function GetItemCountById ( _
    itemId As UInteger _
) As Integer
public:
static int^ GetItemCountById(
    unsigned int^ itemId
)

Parameters

itemId
Type: UInt32
The item id.

Return Value

item count.

See Also

ItemsManager Class
wManager.Wow.Helpers Namespace


GetItemCountByIdLUA Method

ItemsManager..::..GetItemCountByIdLUA Method

Get item count by id with lua.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int GetItemCountByIdLUA(
    uint itemId
)
Public Shared Function GetItemCountByIdLUA ( _
    itemId As UInteger _
) As Integer
public:
static int^ GetItemCountByIdLUA(
    unsigned int^ itemId
)

Parameters

itemId
Type: UInt32
The item id.

Return Value

item count.

See Also

ItemsManager Class
wManager.Wow.Helpers Namespace


GetItemCountByNameLUA Method

ItemsManager..::..GetItemCountByNameLUA Method

Get item count by name with lua.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int GetItemCountByNameLUA(
    string itemName
)
Public Shared Function GetItemCountByNameLUA ( _
    itemName As String _
) As Integer
public:
static int^ GetItemCountByNameLUA(
    String^ itemName
)

Parameters

itemName
Type: String
Name of the item like is appear in game.

Return Value

item count.

See Also

ItemsManager Class
wManager.Wow.Helpers Namespace


GetItemSpell Method

ItemsManager..::..GetItemSpell Method

Overload List

Name | Description
GetItemSpell(UInt32) | Get the item spell.
GetItemSpell(String) | Get the item spell.

See Also

ItemsManager Class
ItemsManager Members
wManager.Wow.Helpers Namespace


GetItemSpell Method (UInt32)

ItemsManager..::..GetItemSpell Method (UInt32)

Get the item spell.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string GetItemSpell(
    uint itemId
)
Public Shared Function GetItemSpell ( _
    itemId As UInteger _
) As String
public:
static String^ GetItemSpell(
    unsigned int^ itemId
)

Parameters

itemId
Type: UInt32
The item id.

Return Value

spell name.

See Also

ItemsManager Class
GetItemSpell Overload
wManager.Wow.Helpers Namespace


GetItemSpell Method (String)

ItemsManager..::..GetItemSpell Method (String)

Get the item spell.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string GetItemSpell(
    string itemNameInGame
)
Public Shared Function GetItemSpell ( _
    itemNameInGame As String _
) As String
public:
static String^ GetItemSpell(
    String^ itemNameInGame
)

Parameters

itemNameInGame
Type: String
The item name in game.

Return Value

spell name

See Also

ItemsManager Class
GetItemSpell Overload
wManager.Wow.Helpers Namespace


GetNameById Method

ItemsManager..::..GetNameById Method

Overload List

Name | Description
GetNameById(Int32) | Get the item name by id.
GetNameById(UInt32) | Gets the item name by id.

See Also

ItemsManager Class
ItemsManager Members
wManager.Wow.Helpers Namespace


GetNameById Method (Int32)

ItemsManager..::..GetNameById Method (Int32)

Get the item name by id.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string GetNameById(
    int idItem
)
Public Shared Function GetNameById ( _
    idItem As Integer _
) As String
public:
static String^ GetNameById(
    int^ idItem
)

Parameters

idItem
Type: Int32
The item id.

Return Value

item name.

See Also

ItemsManager Class
GetNameById Overload
wManager.Wow.Helpers Namespace


GetNameById Method (UInt32)

ItemsManager..::..GetNameById Method (UInt32)

Gets the item name by id.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string GetNameById(
    uint idItem
)
Public Shared Function GetNameById ( _
    idItem As UInteger _
) As String
public:
static String^ GetNameById(
    unsigned int^ idItem
)

Parameters

idItem
Type: UInt32
The item id.

Return Value

item name.

See Also

ItemsManager Class
GetNameById Overload
wManager.Wow.Helpers Namespace


HasItemById Method

ItemsManager..::..HasItemById Method

Determines whether has item by id (use [ObjectManager], it's faster than lua).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool HasItemById(
    uint itemId
)
Public Shared Function HasItemById ( _
    itemId As UInteger _
) As Boolean
public:
static bool^ HasItemById(
    unsigned int^ itemId
)

Parameters

itemId
Type: UInt32
The item id.

Return Value

true if has item; otherwise, false.

See Also

ItemsManager Class
wManager.Wow.Helpers Namespace


IsEquippableItem Method

ItemsManager..::..IsEquippableItem Method

Determines whether is equippable item.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool IsEquippableItem(
    int itemId,
    bool ignoreCache
)
Public Shared Function IsEquippableItem ( _
    itemId As Integer, _
    ignoreCache As Boolean _
) As Boolean
public:
static bool^ IsEquippableItem(
    int^ itemId,
    bool^ ignoreCache
)

Parameters

itemId
Type: Int32
The item id.
ignoreCache
Type: Boolean
if set to true ignore cache.

Return Value

true if is equippable item; otherwise, false.

See Also

ItemsManager Class
wManager.Wow.Helpers Namespace


UseContainerItem Method

ItemsManager..::..UseContainerItem Method

Overload List

Name | Description
UseContainerItem(String) | Use container item by name.
UseContainerItem(UInt32) | Use the container item by id.

See Also

ItemsManager Class
ItemsManager Members
wManager.Wow.Helpers Namespace


UseContainerItem Method (String)

ItemsManager..::..UseContainerItem Method (String)

Use container item by name.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void UseContainerItem(
    string itemName
)
Public Shared Sub UseContainerItem ( _
    itemName As String _
)
public:
static void UseContainerItem(
    String^ itemName
)

Parameters

itemName
Type: String
Name of the item like is appear in game.

See Also

ItemsManager Class
UseContainerItem Overload
wManager.Wow.Helpers Namespace


UseContainerItem Method (UInt32)

ItemsManager..::..UseContainerItem Method (UInt32)

Use the container item by id.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void UseContainerItem(
    uint itemId
)
Public Shared Sub UseContainerItem ( _
    itemId As UInteger _
)
public:
static void UseContainerItem(
    unsigned int^ itemId
)

Parameters

itemId
Type: UInt32
The item id.

See Also

ItemsManager Class
UseContainerItem Overload
wManager.Wow.Helpers Namespace


UseContainerItemByNameOrId Method

ItemsManager..::..UseContainerItemByNameOrId Method

Use the container item by name like is appear in game or by item id.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void UseContainerItemByNameOrId(
    string itemNameOrId
)
Public Shared Sub UseContainerItemByNameOrId ( _
    itemNameOrId As String _
)
public:
static void UseContainerItemByNameOrId(
    String^ itemNameOrId
)

Parameters

itemNameOrId
Type: String
The item name like is appear in game or item id.

See Also

ItemsManager Class
wManager.Wow.Helpers Namespace


UseItem Method

ItemsManager..::..UseItem Method

Overload List

Name | Description
UseItem(String) | Use the item.
UseItem(UInt32) | Use the item.
UseItem(UInt32, Vector3) | Use the item and mouse click at position.

See Also

ItemsManager Class
ItemsManager Members
wManager.Wow.Helpers Namespace


UseItem Method (String)

ItemsManager..::..UseItem Method (String)

Use the item.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void UseItem(
    string itemName
)
Public Shared Sub UseItem ( _
    itemName As String _
)
public:
static void UseItem(
    String^ itemName
)

Parameters

itemName
Type: String
The item name like is appear in game.

See Also

ItemsManager Class
UseItem Overload
wManager.Wow.Helpers Namespace


UseItem Method (UInt32)

ItemsManager..::..UseItem Method (UInt32)

Use the item.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void UseItem(
    uint itemId
)
Public Shared Sub UseItem ( _
    itemId As UInteger _
)
public:
static void UseItem(
    unsigned int^ itemId
)

Parameters

itemId
Type: UInt32
The item id.

See Also

ItemsManager Class
UseItem Overload
wManager.Wow.Helpers Namespace


UseItem Method (UInt32, Vector3)

ItemsManager..::..UseItem Method (UInt32, Vector3)

Use the item and mouse click at position.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void UseItem(
    uint itemId,
    Vector3 vector3
)
Public Shared Sub UseItem ( _
    itemId As UInteger, _
    vector3 As Vector3 _
)
public:
static void UseItem(
    unsigned int^ itemId,
    Vector3^ vector3
)

Parameters

itemId
Type: UInt32
The item id.
vector3
Type: robotManager.Helpful..::..Vector3
The position where to click.

See Also

ItemsManager Class
UseItem Overload
wManager.Wow.Helpers Namespace


UseItemByNameOrId Method

ItemsManager..::..UseItemByNameOrId Method

Use the item by name or id.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void UseItemByNameOrId(
    string itemNameOrId
)
Public Shared Sub UseItemByNameOrId ( _
    itemNameOrId As String _
)
public:
static void UseItemByNameOrId(
    String^ itemNameOrId
)

Parameters

itemNameOrId
Type: String
The item name like is appear in game or item id.

See Also

ItemsManager Class
wManager.Wow.Helpers Namespace


ItemsManager.ConsumableType Enumeration

ItemsManager..::..ConsumableType Enumeration

ConsumableType (used by [GetBestConsumableBag(ConsumableType)])

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public enum ConsumableType
Public Enumeration ConsumableType
public enum class ConsumableType

Members

Member name | Description
Food |
Drink |

See Also

wManager.Wow.Helpers Namespace


Keybindings Class

Class Keybindings. Recommended methods if you need to interact with keyboard (for existing shortcut).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class Keybindings
Public NotInheritable Class Keybindings
public ref class Keybindings abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..Keybindings

See Also

Keybindings Members
wManager.Wow.Helpers Namespace


Keybindings Members

The Keybindings type exposes the following members.

Methods

Name | Description
DownKeybindings | Down keyboard key by keybindings.
GetAFreeKey | Get a free key (not associated to a shortcut).
GetKeyByAction | Get the key by action.
PressKeybindings | Press keyboard key by keybindings (call DownKeybindings(Keybindings) and UpKeybindings(Keybindings)).
PressSlotKey | Press Slot key (game action by).
ResetList | Reset cache list.
SetKeyByAction | Set the key by action.
UpKeybindings | Up keyboard key by keybindings.

See Also

Keybindings Class
wManager.Wow.Helpers Namespace


Keybindings Methods

The Keybindings type exposes the following members.

Methods

Name | Description
DownKeybindings | Down keyboard key by keybindings.
GetAFreeKey | Get a free key (not associated to a shortcut).
GetKeyByAction | Get the key by action.
PressKeybindings | Press keyboard key by keybindings (call DownKeybindings(Keybindings) and UpKeybindings(Keybindings)).
PressSlotKey | Press Slot key (game action by).
ResetList | Reset cache list.
SetKeyByAction | Set the key by action.
UpKeybindings | Up keyboard key by keybindings.

See Also

Keybindings Class
wManager.Wow.Helpers Namespace


DownKeybindings Method

Keybindings..::..DownKeybindings Method

Down keyboard key by keybindings.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void DownKeybindings(
    Keybindings action
)
Public Shared Sub DownKeybindings ( _
    action As Keybindings _
)
public:
static void DownKeybindings(
    Keybindings^ action
)

Parameters

action
Type: wManager.Wow.Enums..::..Keybindings
The action.

See Also

Keybindings Class
wManager.Wow.Helpers Namespace


GetAFreeKey Method

Keybindings..::..GetAFreeKey Method

Get a free key (not associated to a shortcut).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string GetAFreeKey()
Public Shared Function GetAFreeKey As String
public:
static String^ GetAFreeKey()

Return Value

the key.

See Also

Keybindings Class
wManager.Wow.Helpers Namespace


GetKeyByAction Method

Keybindings..::..GetKeyByAction Method

Get the key by action.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string GetKeyByAction(
    Keybindings action,
    bool autoAssignKeyIfNull
)
Public Shared Function GetKeyByAction ( _
    action As Keybindings, _
    autoAssignKeyIfNull As Boolean _
) As String
public:
static String^ GetKeyByAction(
    Keybindings^ action,
    bool^ autoAssignKeyIfNull
)

Parameters

action
Type: wManager.Wow.Enums..::..Keybindings
The action.
autoAssignKeyIfNull
Type: Boolean
if set to true automatic assign key if not assigned.

Return Value

the key.

See Also

Keybindings Class
wManager.Wow.Helpers Namespace


PressKeybindings Method

Keybindings..::..PressKeybindings Method

Press keyboard key by keybindings (call DownKeybindings(Keybindings) and UpKeybindings(Keybindings)).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void PressKeybindings(
    Keybindings action,
    int timeMs
)
Public Shared Sub PressKeybindings ( _
    action As Keybindings, _
    timeMs As Integer _
)
public:
static void PressKeybindings(
    Keybindings^ action,
    int^ timeMs
)

Parameters

action
Type: wManager.Wow.Enums..::..Keybindings
The action.
timeMs
Type: Int32
The time millisecond.

See Also

Keybindings Class
wManager.Wow.Helpers Namespace


PressSlotKey Method

Keybindings..::..PressSlotKey Method

Press Slot key (game action by).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void PressSlotKey(
    int key
)
Public Shared Sub PressSlotKey ( _
    key As Integer _
)
public:
static void PressSlotKey(
    int^ key
)

Parameters

key
Type: Int32
The key.

See Also

Keybindings Class
wManager.Wow.Helpers Namespace


ResetList Method

Keybindings..::..ResetList Method

Reset cache list.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void ResetList()
Public Shared Sub ResetList
public:
static void ResetList()

See Also

Keybindings Class
wManager.Wow.Helpers Namespace


SetKeyByAction Method

Keybindings..::..SetKeyByAction Method

Set the key by action.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void SetKeyByAction(
    Keybindings action,
    string key
)
Public Shared Sub SetKeyByAction ( _
    action As Keybindings, _
    key As String _
)
public:
static void SetKeyByAction(
    Keybindings^ action,
    String^ key
)

Parameters

action
Type: wManager.Wow.Enums..::..Keybindings
The action.
key
Type: String
The key.

See Also

Keybindings Class
wManager.Wow.Helpers Namespace


UpKeybindings Method

Keybindings..::..UpKeybindings Method

Up keyboard key by keybindings.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void UpKeybindings(
    Keybindings action
)
Public Shared Sub UpKeybindings ( _
    action As Keybindings _
)
public:
static void UpKeybindings(
    Keybindings^ action
)

Parameters

action
Type: wManager.Wow.Enums..::..Keybindings
The action.

See Also

Keybindings Class
wManager.Wow.Helpers Namespace


Login Class

Class Login. To login character to the game.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class Login
Public NotInheritable Class Login
public ref class Login abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..Login

See Also

Login Members
wManager.Wow.Helpers Namespace


Login Members

The Login type exposes the following members.

Methods

Name | Description
Pulse | Start login.
StopLogin | Stop login.

See Also

Login Class
wManager.Wow.Helpers Namespace


Login Methods

The Login type exposes the following members.

Methods

Name | Description
Pulse | Start login.
StopLogin | Stop login.

See Also

Login Class
wManager.Wow.Helpers Namespace


Pulse Method

Login..::..Pulse Method

Start login.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool Pulse(
    Login..::..SettingsLogin settings
)
Public Shared Function Pulse ( _
    settings As Login..::..SettingsLogin _
) As Boolean
public:
static bool^ Pulse(
    Login..::..SettingsLogin^ settings
)

Parameters

settings
Type: wManager.Wow.Helpers..::..Login..::..SettingsLogin
The login settings.

See Also

Login Class
wManager.Wow.Helpers Namespace


StopLogin Method

Login..::..StopLogin Method

Stop login.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void StopLogin()
Public Shared Sub StopLogin
public:
static void StopLogin()

See Also

Login Class
wManager.Wow.Helpers Namespace


Login.SettingsLogin Structure

Login..::..SettingsLogin Structure

Struct SettingsLogin

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public struct SettingsLogin
Public Structure SettingsLogin
public value class SettingsLogin

See Also

Login..::..SettingsLogin Members
wManager.Wow.Helpers Namespace


Login.SettingsLogin Members

Login..::..SettingsLogin Members

The Login..::..SettingsLogin type exposes the following members.

Constructors

 | Name | Description
Public method | Login..::..SettingsLogin | Initializes a new instance of the Login..::..SettingsLogin struct.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from ValueType.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from ValueType.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from ValueType.)

Fields

 | Name | Description
Public field | BNetName | Game account name BNetName="WoW1"
Public field | Character | Game character name Character="MyName"
Public field | Login | Game account mail (or name) Login="my@mail.com"
Public field | Password | Game account password Password="*****"
Public field | Realm | Game realmlist name Realm="ServerName"

See Also

Login..::..SettingsLogin Structure
wManager.Wow.Helpers Namespace


SettingsLogin Constructor

Initializes a new instance of the Login..::..SettingsLogin struct.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public SettingsLogin(
    string realm,
    string login,
    string character,
    string password,
    string bNetName
)
Public Sub New ( _
    realm As String, _
    login As String, _
    character As String, _
    password As String, _
    bNetName As String _
)
public:
SettingsLogin(
    String^ realm,
    String^ login,
    String^ character,
    String^ password,
    String^ bNetName
)

Parameters

realm
Type: String
Game realmlist name Realm="ServerName".
login
Type: String
Game account mail (or name) Login="my@mail.com".
character
Type: String
Game character name Character="MyName".
password
Type: String
Game account password Password="*****".
bNetName
Type: String
Game account name BNetName="WoW1".

See Also

Login..::..SettingsLogin Structure
wManager.Wow.Helpers Namespace


Login.SettingsLogin Fields

Login..::..SettingsLogin Fields

The Login..::..SettingsLogin type exposes the following members.

Fields

 | Name | Description
Public field | BNetName | Game account name BNetName="WoW1"
Public field | Character | Game character name Character="MyName"
Public field | Login | Game account mail (or name) Login="my@mail.com"
Public field | Password | Game account password Password="*****"
Public field | Realm | Game realmlist name Realm="ServerName"

See Also

Login..::..SettingsLogin Structure
wManager.Wow.Helpers Namespace


BNetName Field

SettingsLogin..::..BNetName Field

Game account name BNetName="WoW1"

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string BNetName
Public BNetName As String
public:
String^ BNetName

See Also

Login..::..SettingsLogin Structure
wManager.Wow.Helpers Namespace


Character Field

SettingsLogin..::..Character Field

Game character name Character="MyName"

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string Character
Public Character As String
public:
String^ Character

See Also

Login..::..SettingsLogin Structure
wManager.Wow.Helpers Namespace


Login Field

SettingsLogin..::..Login Field

Game account mail (or name) Login="my@mail.com"

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string Login
Public Login As String
public:
String^ Login

See Also

Login..::..SettingsLogin Structure
wManager.Wow.Helpers Namespace


Password Field

SettingsLogin..::..Password Field

Game account password Password="*****"

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string Password
Public Password As String
public:
String^ Password

See Also

Login..::..SettingsLogin Structure
wManager.Wow.Helpers Namespace


Realm Field

SettingsLogin..::..Realm Field

Game realmlist name Realm="ServerName"

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string Realm
Public Realm As String
public:
String^ Realm

See Also

Login..::..SettingsLogin Structure
wManager.Wow.Helpers Namespace


Login.SettingsLogin Methods

Login..::..SettingsLogin Methods

The Login..::..SettingsLogin type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from ValueType.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from ValueType.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from ValueType.)

See Also

Login..::..SettingsLogin Structure
wManager.Wow.Helpers Namespace


LongMove Class

Class LongMove. Useful to flying to specific destination when there are obstacles.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class LongMove
Public NotInheritable Class LongMove
public ref class LongMove abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..LongMove

See Also

LongMove Members
wManager.Wow.Helpers Namespace


LongMove Members

The LongMove type exposes the following members.

Methods

Name | Description
DecollideFlightPath(Single, Single, Single, Single, Single, Single) | Decollide the flight path (with TraceLine).
DecollideFlightPath(Vector3, Single, Single, Single) | Decollides the flight path (with TraceLine).
DecollideFlightPath(Vector3, Vector3, Single, Single, Single) | Decollides the flight path (with TraceLine).
LongMoveByNewThread | Pulse Long move in new thread (flying to specific destination when there are obstacles).
LongMoveGo(Vector3, Double, Double) | Pulse Long move (flying to specific destination when there are obstacles).
LongMoveGo(Vector3) | Pulse Long move (flying to specific destination when there are obstacles).
StopLongMove | Stop long move.

Properties

Name | Description
IsLongMove | Get a value indicating whether character is in long move.

See Also

LongMove Class
wManager.Wow.Helpers Namespace


LongMove Methods

The LongMove type exposes the following members.

Methods

Name | Description
DecollideFlightPath(Single, Single, Single, Single, Single, Single) | Decollide the flight path (with TraceLine).
DecollideFlightPath(Vector3, Single, Single, Single) | Decollides the flight path (with TraceLine).
DecollideFlightPath(Vector3, Vector3, Single, Single, Single) | Decollides the flight path (with TraceLine).
LongMoveByNewThread | Pulse Long move in new thread (flying to specific destination when there are obstacles).
LongMoveGo(Vector3, Double, Double) | Pulse Long move (flying to specific destination when there are obstacles).
LongMoveGo(Vector3) | Pulse Long move (flying to specific destination when there are obstacles).
StopLongMove | Stop long move.

See Also

LongMove Class
wManager.Wow.Helpers Namespace


DecollideFlightPath Method

LongMove..::..DecollideFlightPath Method

Overload List

Name | Description
DecollideFlightPath(Single, Single, Single, Single, Single, Single) | Decollide the flight path (with TraceLine).
DecollideFlightPath(Vector3, Single, Single, Single) | Decollides the flight path (with TraceLine).
DecollideFlightPath(Vector3, Vector3, Single, Single, Single) | Decollides the flight path (with TraceLine).

See Also

LongMove Class
LongMove Members
wManager.Wow.Helpers Namespace


DecollideFlightPath Method (Single, Single, Single, Single, Single, Single)

LongMove..::..DecollideFlightPath Method (Single, Single, Single, Single, Single, Single)

Decollide the flight path (with TraceLine).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static Vector3 DecollideFlightPath(
    float x,
    float y,
    float z,
    float targetHeight,
    float minGroundDistance,
    float maxGroundDistance
)
Public Shared Function DecollideFlightPath ( _
    x As Single, _
    y As Single, _
    z As Single, _
    targetHeight As Single, _
    minGroundDistance As Single, _
    maxGroundDistance As Single _
) As Vector3
public:
static Vector3^ DecollideFlightPath(
    float^ x,
    float^ y,
    float^ z,
    float^ targetHeight,
    float^ minGroundDistance,
    float^ maxGroundDistance
)

Parameters

x
Type: Single
The x.
y
Type: Single
The y.
z
Type: Single
The z.
targetHeight
Type: Single
Height of the target.
minGroundDistance
Type: Single
The minimum ground distance.
maxGroundDistance
Type: Single
The maximum ground distance.

Return Value

suggested position.

See Also

LongMove Class
DecollideFlightPath Overload
wManager.Wow.Helpers Namespace


DecollideFlightPath Method (Vector3, Single, Single, Single)

LongMove..::..DecollideFlightPath Method (Vector3, Single, Single, Single)

Decollides the flight path (with TraceLine).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static Vector3 DecollideFlightPath(
    Vector3 destination,
    float targetHeight,
    float minGroundDistance,
    float maxGroundDistance
)
Public Shared Function DecollideFlightPath ( _
    destination As Vector3, _
    targetHeight As Single, _
    minGroundDistance As Single, _
    maxGroundDistance As Single _
) As Vector3
public:
static Vector3^ DecollideFlightPath(
    Vector3^ destination,
    float^ targetHeight,
    float^ minGroundDistance,
    float^ maxGroundDistance
)

Parameters

destination
Type: robotManager.Helpful..::..Vector3
The destination.
targetHeight
Type: Single
Height of the target.
minGroundDistance
Type: Single
The minimum ground distance.
maxGroundDistance
Type: Single
The maximum ground distance.

Return Value

suggested position.

See Also

LongMove Class
DecollideFlightPath Overload
wManager.Wow.Helpers Namespace


DecollideFlightPath Method (Vector3, Vector3, Single, Single, Single)

LongMove..::..DecollideFlightPath Method (Vector3, Vector3, Single, Single, Single)

Decollides the flight path (with TraceLine).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static Vector3 DecollideFlightPath(
    Vector3 from,
    Vector3 destination,
    float targetHeight,
    float minGroundDistance,
    float maxGroundDistance
)
Public Shared Function DecollideFlightPath ( _
    from As Vector3, _
    destination As Vector3, _
    targetHeight As Single, _
    minGroundDistance As Single, _
    maxGroundDistance As Single _
) As Vector3
public:
static Vector3^ DecollideFlightPath(
    Vector3^ from,
    Vector3^ destination,
    float^ targetHeight,
    float^ minGroundDistance,
    float^ maxGroundDistance
)

Parameters

from
Type: robotManager.Helpful..::..Vector3
From.
destination
Type: robotManager.Helpful..::..Vector3
The destination.
targetHeight
Type: Single
Height of the target.
minGroundDistance
Type: Single
The minimum ground distance.
maxGroundDistance
Type: Single
The maximum ground distance.

Return Value

suggested position.

See Also

LongMove Class
DecollideFlightPath Overload
wManager.Wow.Helpers Namespace


LongMoveByNewThread Method

LongMove..::..LongMoveByNewThread Method

Pulse Long move in new thread (flying to specific destination when there are obstacles).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void LongMoveByNewThread(
    Vector3 vector3
)
Public Shared Sub LongMoveByNewThread ( _
    vector3 As Vector3 _
)
public:
static void LongMoveByNewThread(
    Vector3^ vector3
)

Parameters

vector3
Type: robotManager.Helpful..::..Vector3
destination.

See Also

LongMove Class
wManager.Wow.Helpers Namespace


LongMoveGo Method

LongMove..::..LongMoveGo Method

Overload List

Name | Description
LongMoveGo(Vector3, Double, Double) | Pulse Long move (flying to specific destination when there are obstacles).
LongMoveGo(Vector3) | Pulse Long move (flying to specific destination when there are obstacles).

See Also

LongMove Class
LongMove Members
wManager.Wow.Helpers Namespace


LongMoveGo Method (Vector3, Double, Double)

LongMove..::..LongMoveGo Method (Vector3, Double, Double)

Pulse Long move (flying to specific destination when there are obstacles).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void LongMoveGo(
    Vector3 position,
    double maxTimeMs,
    double precision2D
)
Public Shared Sub LongMoveGo ( _
    position As Vector3, _
    maxTimeMs As Double, _
    precision2D As Double _
)
public:
static void LongMoveGo(
    Vector3^ position,
    double^ maxTimeMs,
    double^ precision2D
)

Parameters

position
Type: robotManager.Helpful..::..Vector3
The destination.
maxTimeMs
Type: Double
The maximum time in milliseconds.
precision2D
Type: Double
The precision 2d.

See Also

LongMove Class
LongMoveGo Overload
wManager.Wow.Helpers Namespace


LongMoveGo Method (Vector3)

LongMove..::..LongMoveGo Method (Vector3)

Pulse Long move (flying to specific destination when there are obstacles).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void LongMoveGo(
    Vector3 vector3
)
Public Shared Sub LongMoveGo ( _
    vector3 As Vector3 _
)
public:
static void LongMoveGo(
    Vector3^ vector3
)

Parameters

vector3
Type: robotManager.Helpful..::..Vector3
The destination.

See Also

LongMove Class
LongMoveGo Overload
wManager.Wow.Helpers Namespace


StopLongMove Method

LongMove..::..StopLongMove Method

Stop long move.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void StopLongMove()
Public Shared Sub StopLongMove
public:
static void StopLongMove()

See Also

LongMove Class
wManager.Wow.Helpers Namespace


LongMove Properties

The LongMove type exposes the following members.

Properties

Name | Description
IsLongMove | Get a value indicating whether character is in long move.

See Also

LongMove Class
wManager.Wow.Helpers Namespace


IsLongMove Property

LongMove..::..IsLongMove Property

Get a value indicating whether character is in long move.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool IsLongMove { get; }
Public Shared ReadOnly Property IsLongMove As Boolean
    Get
public:
static property bool^ IsLongMove {
    bool^ get ();
}

See Also

LongMove Class
wManager.Wow.Helpers Namespace


Lua Class

Class Lua. Used to run lua code in game and get lua variables value ( https://wow.gamepedia.com/World_of_Warcraft_API ).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class Lua
Public NotInheritable Class Lua
public ref class Lua abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..Lua

See Also

Lua Members
wManager.Wow.Helpers Namespace


Lua Members

The Lua type exposes the following members.

Methods

Name | Description
GetLocalizedText | Get value of specified lua variable
LuaDoString(array<String>[]()[][], String) | Execute lua code and get result.
LuaDoString(List<(Of <<'(String>)>>), String) | Execute lua code and get result.
LuaDoString(String, Type, String) | Execute lua code and get result (you can found example in [LuaDoString{T}(string,string)]).
LuaDoString(String, String) | Execute lua code and get result (you can found example in [LuaDoString{T}(string,string)]).
LuaDoString(List<(Of <<'(String>)>>), Boolean) | Execute lua code.
LuaDoString(String, Boolean) | Execute lua code.
LuaDoString(String, Boolean, Boolean) | Execute lua code.
LuaDoString<(Of <<'(T>)>>)(array<String>[]()[][], String) | Execute lua code and get result (you can found example in [LuaDoString{T}(string,string)]).
LuaDoString<(Of <<'(T>)>>)(List<(Of <<'(String>)>>), String) | Execute lua code and get result (you can found example in [LuaDoString{T}(string,string)]).
LuaDoString<(Of <<'(T>)>>)(String, String) | Execute lua code and get result.
RunMacroText | Run lua macro (with https://wowwiki.fandom.com/wiki/API_RunMacroText).
RunMacroTextHW | Create lua macro in game and run it (by pressing a keyboard key).

Fields

Name Description
DebugstackFilterMode
Filter "debugstack" (https://wowwiki.fandom.com/wiki/API_debugstack) result (try to remove bot trace).
ListSeparator
The list separator, use when you want return an array separate the entries with this string (you can found example in [LuaDoString{T}(string,string)]).
SecureLuaCall
Secure called lua code (a lot of private servers add traps in lua to detect bots).
Wow
Allows to use/mix Lua with C# (or LuaBot).

Examples

C#
string playerName = Lua.Wow.GetUnitName("player"); // call https://wowwiki.fandom.com/wiki/API_GetUnitName
Lua.Wow.print(playerName); // call https://wowwiki.fandom.com/wiki/API_print

Properties

Name | Description
LuaFile | Get or set the lua file.

See Also

Lua Class
wManager.Wow.Helpers Namespace


Lua Fields

The Lua type exposes the following members.

Fields

Name Description
DebugstackFilterMode
Filter "debugstack" (https://wowwiki.fandom.com/wiki/API_debugstack) result (try to remove bot trace).
ListSeparator
The list separator, use when you want return an array separate the entries with this string (you can found example in [LuaDoString{T}(string,string)]).
SecureLuaCall
Secure called lua code (a lot of private servers add traps in lua to detect bots).
Wow
Allows to use/mix Lua with C# (or LuaBot).

Examples

C#
string playerName = Lua.Wow.GetUnitName("player"); // call https://wowwiki.fandom.com/wiki/API_GetUnitName
Lua.Wow.print(playerName); // call https://wowwiki.fandom.com/wiki/API_print

See Also

Lua Class
wManager.Wow.Helpers Namespace


DebugstackFilterMode Field

Lua..::..DebugstackFilterMode Field

Filter "debugstack" (https://wowwiki.fandom.com/wiki/API_debugstack) result (try to remove bot trace).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool DebugstackFilterMode
Public Shared DebugstackFilterMode As Boolean
public:
static bool^ DebugstackFilterMode

See Also

Lua Class
wManager.Wow.Helpers Namespace


ListSeparator Field

Lua..::..ListSeparator Field

The list separator, use when you want return an array separate the entries with this string (you can found example in [LuaDoString{T}(string,string)]).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const string ListSeparator
Public Const ListSeparator As String
public:
literal String^ ListSeparator

See Also

Lua Class
wManager.Wow.Helpers Namespace


SecureLuaCall Field

Lua..::..SecureLuaCall Field

Secure called lua code (a lot of private servers add traps in lua to detect bots).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool SecureLuaCall
Public Shared SecureLuaCall As Boolean
public:
static bool^ SecureLuaCall

See Also

Lua Class
wManager.Wow.Helpers Namespace


Wow Field

Lua..::..Wow Field

Allows to use/mix Lua with C# (or LuaBot).

Examples

C#
string playerName = Lua.Wow.GetUnitName("player"); // call https://wowwiki.fandom.com/wiki/API_GetUnitName
Lua.Wow.print(playerName); // call https://wowwiki.fandom.com/wiki/API_print

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static Object Wow
Public Shared Wow As Object
public:
static Object^ Wow

See Also

Lua Class
wManager.Wow.Helpers Namespace


Lua Methods

The Lua type exposes the following members.

Methods

Name | Description
GetLocalizedText | Get value of specified lua variable
LuaDoString(array<String>[]()[][], String) | Execute lua code and get result.
LuaDoString(List<(Of <<'(String>)>>), String) | Execute lua code and get result.
LuaDoString(String, Type, String) | Execute lua code and get result (you can found example in [LuaDoString{T}(string,string)]).
LuaDoString(String, String) | Execute lua code and get result (you can found example in [LuaDoString{T}(string,string)]).
LuaDoString(List<(Of <<'(String>)>>), Boolean) | Execute lua code.
LuaDoString(String, Boolean) | Execute lua code.
LuaDoString(String, Boolean, Boolean) | Execute lua code.
LuaDoString<(Of <<'(T>)>>)(array<String>[]()[][], String) | Execute lua code and get result (you can found example in [LuaDoString{T}(string,string)]).
LuaDoString<(Of <<'(T>)>>)(List<(Of <<'(String>)>>), String) | Execute lua code and get result (you can found example in [LuaDoString{T}(string,string)]).
LuaDoString<(Of <<'(T>)>>)(String, String) | Execute lua code and get result.
RunMacroText | Run lua macro (with https://wowwiki.fandom.com/wiki/API_RunMacroText).
RunMacroTextHW | Create lua macro in game and run it (by pressing a keyboard key).

See Also

Lua Class
wManager.Wow.Helpers Namespace


GetLocalizedText Method

Lua..::..GetLocalizedText Method

Get value of specified lua variable

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string GetLocalizedText(
    string commandline,
    bool deletedVariable
)
Public Shared Function GetLocalizedText ( _
    commandline As String, _
    deletedVariable As Boolean _
) As String
public:
static String^ GetLocalizedText(
    String^ commandline,
    bool^ deletedVariable
)

Parameters

commandline
Type: String
The variable name.
deletedVariable
Type: Boolean
if set to true empty variable value after reading the value.

Return Value

variable value.

See Also

Lua Class
wManager.Wow.Helpers Namespace


LuaDoString Method

Lua..::..LuaDoString Method

Overload List

Name | Description
LuaDoString(array<String>[]()[][], String) | Execute lua code and get result.
LuaDoString(List<(Of <<'(String>)>>), String) | Execute lua code and get result.
LuaDoString<(Of <<'(T>)>>)(array<String>[]()[][], String) | Execute lua code and get result (you can found example in [LuaDoString{T}(string,string)]).
LuaDoString<(Of <<'(T>)>>)(List<(Of <<'(String>)>>), String) | Execute lua code and get result (you can found example in [LuaDoString{T}(string,string)]).
LuaDoString<(Of <<'(T>)>>)(String, String) | Execute lua code and get result.
LuaDoString(String, Type, String) | Execute lua code and get result (you can found example in [LuaDoString{T}(string,string)]).
LuaDoString(String, String) | Execute lua code and get result (you can found example in [LuaDoString{T}(string,string)]).
LuaDoString(List<(Of <<'(String>)>>), Boolean) | Execute lua code.
LuaDoString(String, Boolean) | Execute lua code.
LuaDoString(String, Boolean, Boolean) | Execute lua code.

See Also

Lua Class
Lua Members
wManager.Wow.Helpers Namespace


LuaDoString Method (String[], String)

Lua..::..LuaDoString Method (array<String>[]()[][], String)

Execute lua code and get result.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string LuaDoString(
    string[] command,
    string returnVariableName
)
Public Shared Function LuaDoString ( _
    command As String(), _
    returnVariableName As String _
) As String
public:
static String^ LuaDoString(
    array<String^>^ command,
    String^ returnVariableName
)

Parameters

command
Type: array< String >[]()[][]
The lua code.
returnVariableName
Type: String
Name of variable where is save the result.

Return Value

result

See Also

Lua Class
LuaDoString Overload
wManager.Wow.Helpers Namespace


LuaDoString Method (List(String), String)

Lua..::..LuaDoString Method (List<(Of <(<'String>)>)>, String)

Execute lua code and get result.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string LuaDoString(
    List<string> command,
    string returnVariableName
)
Public Shared Function LuaDoString ( _
    command As List(Of String), _
    returnVariableName As String _
) As String
public:
static String^ LuaDoString(
    List<String^>^ command,
    String^ returnVariableName
)

Parameters

command
Type: List <(Of <(<' String >)>)>
The lua code.
returnVariableName
Type: String
Name of variable where is save the result.

Return Value

result

See Also

Lua Class
LuaDoString Overload
wManager.Wow.Helpers Namespace


LuaDoString(T) Method (String[], String)

Lua..::..LuaDoString<(Of <(<'T>)>)> Method (array<String>[]()[][], String)

Execute lua code and get result (you can found example in [LuaDoString{T}(string,string)]).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static T LuaDoString<T>(
    string[] command,
    string returnVariableName
)

Public Shared Function LuaDoString(Of T) ( _
    command As String(), _
    returnVariableName As String _
) As T
public:
generic<typename T>
static T LuaDoString(
    array<String^>^ command,
    String^ returnVariableName
)

Type Parameters

T

Parameters

command
Type: array< String >[]()[][]
The lua code.
returnVariableName
Type: String
Name of variable where is save the result (if empty, return result).

Return Value

result

Return Value

T.

See Also

Lua Class
LuaDoString Overload
wManager.Wow.Helpers Namespace


LuaDoString(T) Method (List(String), String)

Lua..::..LuaDoString<(Of <(<'T>)>)> Method (List<(Of <(<'String>)>)>, String)

Execute lua code and get result (you can found example in [LuaDoString{T}(string,string)]).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static T LuaDoString<T>(
    List<string> command,
    string returnVariableName
)

Public Shared Function LuaDoString(Of T) ( _
    command As List(Of String), _
    returnVariableName As String _
) As T
public:
generic<typename T>
static T LuaDoString(
    List<String^>^ command,
    String^ returnVariableName
)

Type Parameters

T

Parameters

command
Type: List <(Of <(<' String >)>)>
The lua code.
returnVariableName
Type: String
Name of variable where is save the result (if empty, return result).

Return Value

result

Return Value

T.

See Also

Lua Class
LuaDoString Overload
wManager.Wow.Helpers Namespace


LuaDoString(T) Method (String, String)

Lua..::..LuaDoString<(Of <(<'T>)>)> Method (String, String)

Execute lua code and get result.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static T LuaDoString<T>(
    string command,
    string returnVariableName
)

Public Shared Function LuaDoString(Of T) ( _
    command As String, _
    returnVariableName As String _
) As T
public:
generic<typename T>
static T LuaDoString(
    String^ command,
    String^ returnVariableName
)

Type Parameters

T

Parameters

command
Type: String
The lua code.
returnVariableName
Type: String
Name of variable where is save the result (if empty, return result).

Return Value

result

Examples

C#
// Example get level:
   int level1 = Lua.LuaDoString<int>("return UnitLevel('player')");
   // or
   int level2 = Lua.LuaDoString<int>("resultLevel = UnitLevel('player')", "resultLevel");

   // Example return list:
   List<int> array1 = Lua.LuaDoString<List<int>>(@"
   local r = {}
   table.insert(r, 1);
   table.insert(r, 2);
   table.insert(r, 3);
   return unpack(r);");
   // or
   List<string> array2 = Lua.LuaDoString<List<string>>(@"return 'A' .. '#LUASEPARATOR#' .. 'B' .. '#LUASEPARATOR#' .. 'C' .. '#LUASEPARATOR#'".Replace("#LUASEPARATOR#", Lua.ListSeparator));

See Also

Lua Class
LuaDoString Overload
wManager.Wow.Helpers Namespace


LuaDoString Method (String, Type, String)

Lua..::..LuaDoString Method (String, Type, String)

Execute lua code and get result (you can found example in [LuaDoString{T}(string,string)]).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static Object LuaDoString(
    string command,
    Type returnType,
    string returnVariableName
)
Public Shared Function LuaDoString ( _
    command As String, _
    returnType As Type, _
    returnVariableName As String _
) As Object
public:
static Object^ LuaDoString(
    String^ command,
    Type^ returnType,
    String^ returnVariableName
)

Parameters

command
Type: String
The lua code.
returnType
Type: Type
Type of the return.
returnVariableName
Type: String
Name of variable where is save the result (if empty, return result).

Return Value

result

See Also

Lua Class
LuaDoString Overload
wManager.Wow.Helpers Namespace


LuaDoString Method (String, String)

Lua..::..LuaDoString Method (String, String)

Execute lua code and get result (you can found example in [LuaDoString{T}(string,string)]).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string LuaDoString(
    string command,
    string returnVariableName
)
Public Shared Function LuaDoString ( _
    command As String, _
    returnVariableName As String _
) As String
public:
static String^ LuaDoString(
    String^ command,
    String^ returnVariableName
)

Parameters

command
Type: String
The lua code.
returnVariableName
Type: String
Name of variable where is save the result (if empty, return result).

Return Value

result

See Also

Lua Class
LuaDoString Overload
wManager.Wow.Helpers Namespace


LuaDoString Method (List(String), Boolean)

Lua..::..LuaDoString Method (List<(Of <(<'String>)>)>, Boolean)

Execute lua code.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void LuaDoString(
    List<string> command,
    bool notInGameMode
)
Public Shared Sub LuaDoString ( _
    command As List(Of String), _
    notInGameMode As Boolean _
)
public:
static void LuaDoString(
    List<String^>^ command,
    bool^ notInGameMode
)

Parameters

command
Type: List <(Of <(<' String >)>)>
The lua code.
notInGameMode
Type: Boolean
if set to true code can be run even if no in game.

See Also

Lua Class
LuaDoString Overload
wManager.Wow.Helpers Namespace


LuaDoString Method (String, Boolean)

Lua..::..LuaDoString Method (String, Boolean)

Execute lua code.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void LuaDoString(
    string command,
    bool notInGameMode
)
Public Shared Sub LuaDoString ( _
    command As String, _
    notInGameMode As Boolean _
)
public:
static void LuaDoString(
    String^ command,
    bool^ notInGameMode
)

Parameters

command
Type: String
The lua code.
notInGameMode
Type: Boolean
if set to true code can be run even if no in game.

See Also

Lua Class
LuaDoString Overload
wManager.Wow.Helpers Namespace


LuaDoString Method (String, Boolean, Boolean)

Lua..::..LuaDoString Method (String, Boolean, Boolean)

Execute lua code.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void LuaDoString(
    string command,
    bool notInGameMode,
    bool ignoreSecureLuaCallOption
)
Public Shared Sub LuaDoString ( _
    command As String, _
    notInGameMode As Boolean, _
    ignoreSecureLuaCallOption As Boolean _
)
public:
static void LuaDoString(
    String^ command,
    bool^ notInGameMode,
    bool^ ignoreSecureLuaCallOption
)

Parameters

command
Type: String
The lua code.
notInGameMode
Type: Boolean
if set to true code can be run even if no in game.
ignoreSecureLuaCallOption
Type: Boolean
if set to true force to ignore option SecureLuaCall.

See Also

Lua Class
LuaDoString Overload
wManager.Wow.Helpers Namespace


RunMacroText Method

Lua..::..RunMacroText Method

Run lua macro (with https://wowwiki.fandom.com/wiki/API_RunMacroText).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void RunMacroText(
    string macro
)
Public Shared Sub RunMacroText ( _
    macro As String _
)
public:
static void RunMacroText(
    String^ macro
)

Parameters

macro
Type: String
Lua macro code (code like "/run print('Hello')").

See Also

Lua Class
wManager.Wow.Helpers Namespace


RunMacroTextHW Method

Lua..::..RunMacroTextHW Method

Create lua macro in game and run it (by pressing a keyboard key).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void RunMacroTextHW(
    string macroRequiredHardware
)
Public Shared Sub RunMacroTextHW ( _
    macroRequiredHardware As String _
)
public:
static void RunMacroTextHW(
    String^ macroRequiredHardware
)

Parameters

macroRequiredHardware
Type: String
Lua macro code (code like "/run print('Hello')").

See Also

Lua Class
wManager.Wow.Helpers Namespace


Lua Properties

The Lua type exposes the following members.

Properties

Name | Description
LuaFile | Get or set the lua file.

See Also

Lua Class
wManager.Wow.Helpers Namespace


LuaFile Property

Lua..::..LuaFile Property

Get or set the lua file.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string LuaFile { get; set; }
Public Shared Property LuaFile As String
    Get
    Set
public:
static property String^ LuaFile {
    String^ get ();
    void set (String^ value);
}

Field Value

The lua file.

See Also

Lua Class
wManager.Wow.Helpers Namespace


Lua.WowLuaClass Class

Lua..::..WowLuaClass Class

Class WowLuaClass (for more information see Wow). Implements the DynamicObject

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class WowLuaClass : DynamicObject
Public Class WowLuaClass _
    Inherits DynamicObject
public ref class WowLuaClass : public DynamicObject

Inheritance Hierarchy

Object
DynamicObject
wManager.Wow.Helpers..::..Lua..::..WowLuaClass

See Also

Lua..::..WowLuaClass Members
wManager.Wow.Helpers Namespace
DynamicObject


Lua.WowLuaClass Members

Lua..::..WowLuaClass Members

The Lua..::..WowLuaClass type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDynamicMemberNames | (Inherited from DynamicObject.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetMetaObject(System.Linq.Expressions.Expression) | (Inherited from DynamicObject.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | TryBinaryOperation(System.Dynamic.BinaryOperationBinder,System.Object,System.Object@) | (Inherited from DynamicObject.)
Public method | TryConvert(System.Dynamic.ConvertBinder,System.Object@) | (Inherited from DynamicObject.)
Public method | TryCreateInstance(System.Dynamic.CreateInstanceBinder,System.Object[],System.Object@) | (Inherited from DynamicObject.)
Public method | TryDeleteIndex(System.Dynamic.DeleteIndexBinder,System.Object[]) | (Inherited from DynamicObject.)
Public method | TryDeleteMember(System.Dynamic.DeleteMemberBinder) | (Inherited from DynamicObject.)
Public method | TryGetIndex(System.Dynamic.GetIndexBinder,System.Object[],System.Object@) | (Inherited from DynamicObject.)
Public method | TryGetMember(GetMemberBinder, Object%) | Tries the get member.
Public method | TryGetMember(System.Dynamic.GetMemberBinder,System.Object@) | (Inherited from DynamicObject.)
Public method | TryInvoke(System.Dynamic.InvokeBinder,System.Object[],System.Object@) | (Inherited from DynamicObject.)
Public method | TryInvokeMember(InvokeMemberBinder, array<Object>[]()[][], Object%) | Tries the invoke member.
Public method | TryInvokeMember(System.Dynamic.InvokeMemberBinder,System.Object[],System.Object@) | (Inherited from DynamicObject.)
Public method | TrySetIndex(System.Dynamic.SetIndexBinder,System.Object[],System.Object) | (Inherited from DynamicObject.)
Public method | TrySetMember(SetMemberBinder, Object) | Tries the set member.
Public method | TrySetMember(System.Dynamic.SetMemberBinder,System.Object) | (Inherited from DynamicObject.)
Public method | TryUnaryOperation(System.Dynamic.UnaryOperationBinder,System.Object@) | (Inherited from DynamicObject.)

See Also

Lua..::..WowLuaClass Class
wManager.Wow.Helpers Namespace


Lua.WowLuaClass Methods

Lua..::..WowLuaClass Methods

The Lua..::..WowLuaClass type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDynamicMemberNames | (Inherited from DynamicObject.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetMetaObject(System.Linq.Expressions.Expression) | (Inherited from DynamicObject.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | TryBinaryOperation(System.Dynamic.BinaryOperationBinder,System.Object,System.Object@) | (Inherited from DynamicObject.)
Public method | TryConvert(System.Dynamic.ConvertBinder,System.Object@) | (Inherited from DynamicObject.)
Public method | TryCreateInstance(System.Dynamic.CreateInstanceBinder,System.Object[],System.Object@) | (Inherited from DynamicObject.)
Public method | TryDeleteIndex(System.Dynamic.DeleteIndexBinder,System.Object[]) | (Inherited from DynamicObject.)
Public method | TryDeleteMember(System.Dynamic.DeleteMemberBinder) | (Inherited from DynamicObject.)
Public method | TryGetIndex(System.Dynamic.GetIndexBinder,System.Object[],System.Object@) | (Inherited from DynamicObject.)
Public method | TryGetMember(GetMemberBinder, Object%) | Tries the get member.
Public method | TryGetMember(System.Dynamic.GetMemberBinder,System.Object@) | (Inherited from DynamicObject.)
Public method | TryInvoke(System.Dynamic.InvokeBinder,System.Object[],System.Object@) | (Inherited from DynamicObject.)
Public method | TryInvokeMember(InvokeMemberBinder, array<Object>[]()[][], Object%) | Tries the invoke member.
Public method | TryInvokeMember(System.Dynamic.InvokeMemberBinder,System.Object[],System.Object@) | (Inherited from DynamicObject.)
Public method | TrySetIndex(System.Dynamic.SetIndexBinder,System.Object[],System.Object) | (Inherited from DynamicObject.)
Public method | TrySetMember(SetMemberBinder, Object) | Tries the set member.
Public method | TrySetMember(System.Dynamic.SetMemberBinder,System.Object) | (Inherited from DynamicObject.)
Public method | TryUnaryOperation(System.Dynamic.UnaryOperationBinder,System.Object@) | (Inherited from DynamicObject.)

See Also

Lua..::..WowLuaClass Class
wManager.Wow.Helpers Namespace


TryGetMember Method

WowLuaClass..::..TryGetMember Method

Overload List

 | Name | Description
Public method | TryGetMember(GetMemberBinder, Object%) | Tries the get member.
Public method | TryGetMember(System.Dynamic.GetMemberBinder,System.Object@) | (Inherited from DynamicObject.)

See Also

Lua..::..WowLuaClass Class
Lua..::..WowLuaClass Members
wManager.Wow.Helpers Namespace


TryGetMember Method

WowLuaClass..::..TryGetMember Method

Tries the get member.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool TryGetMember(
    GetMemberBinder binder,
    out Object result
)
Public Function TryGetMember ( _
    binder As GetMemberBinder, _
    <OutAttribute> ByRef result As Object _
) As Boolean
public:
bool^ TryGetMember(
    GetMemberBinder^ binder,
    [OutAttribute] Object^% result
)

Parameters

binder
Type: GetMemberBinder
The binder.
result
Type: Object %
The result.

Return Value

true if success, false otherwise.

See Also

Lua..::..WowLuaClass Class
wManager.Wow.Helpers Namespace


TryInvokeMember Method

WowLuaClass..::..TryInvokeMember Method

Overload List

 | Name | Description
Public method | TryInvokeMember(InvokeMemberBinder, array<Object>[]()[][], Object%) | Tries the invoke member.
Public method | TryInvokeMember(System.Dynamic.InvokeMemberBinder,System.Object[],System.Object@) | (Inherited from DynamicObject.)

See Also

Lua..::..WowLuaClass Class
Lua..::..WowLuaClass Members
wManager.Wow.Helpers Namespace


TryInvokeMember Method

WowLuaClass..::..TryInvokeMember Method

Tries the invoke member.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool TryInvokeMember(
    InvokeMemberBinder binder,
    Object[] args,
    out Object result
)
Public Function TryInvokeMember ( _
    binder As InvokeMemberBinder, _
    args As Object(), _
    <OutAttribute> ByRef result As Object _
) As Boolean
public:
bool^ TryInvokeMember(
    InvokeMemberBinder^ binder,
    array<Object^>^ args,
    [OutAttribute] Object^% result
)

Parameters

binder
Type: InvokeMemberBinder
The binder.
args
Type: array< Object >[]()[][]
The arguments.
result
Type: Object %
The result.

Return Value

true if success, false otherwise.

See Also

Lua..::..WowLuaClass Class
wManager.Wow.Helpers Namespace


TrySetMember Method

WowLuaClass..::..TrySetMember Method

Overload List

 | Name | Description
Public method | TrySetMember(SetMemberBinder, Object) | Tries the set member.
Public method | TrySetMember(System.Dynamic.SetMemberBinder,System.Object) | (Inherited from DynamicObject.)

See Also

Lua..::..WowLuaClass Class
Lua..::..WowLuaClass Members
wManager.Wow.Helpers Namespace


TrySetMember Method

WowLuaClass..::..TrySetMember Method

Tries the set member.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool TrySetMember(
    SetMemberBinder binder,
    Object value
)
Public Function TrySetMember ( _
    binder As SetMemberBinder, _
    value As Object _
) As Boolean
public:
bool^ TrySetMember(
    SetMemberBinder^ binder,
    Object^ value
)

Parameters

binder
Type: SetMemberBinder
The binder.
value
Type: Object
The value.

Return Value

true if success, false otherwise.

See Also

Lua..::..WowLuaClass Class
wManager.Wow.Helpers Namespace


Mail Class

Class Mail. Methods to send or read mailboxes messages.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class Mail
Public NotInheritable Class Mail
public ref class Mail abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..Mail

See Also

Mail Members
wManager.Wow.Helpers Namespace


Mail Members

The Mail type exposes the following members.

Methods

Name | Description
CloseMailFrame | Close the mail frame.
GetNumAttachments | Get the number of items attachments (on current mail).
MailFrameIsShown | Mail frame is shown.
OpenAllAttachments | Open all attachments (of all mailbox messages, you need to open mailbox before).
SendMessage | Send message with items.

See Also

Mail Class
wManager.Wow.Helpers Namespace


Mail Methods

The Mail type exposes the following members.

Methods

Name | Description
CloseMailFrame | Close the mail frame.
GetNumAttachments | Get the number of items attachments (on current mail).
MailFrameIsShown | Mail frame is shown.
OpenAllAttachments | Open all attachments (of all mailbox messages, you need to open mailbox before).
SendMessage | Send message with items.

See Also

Mail Class
wManager.Wow.Helpers Namespace


CloseMailFrame Method

Mail..::..CloseMailFrame Method

Close the mail frame.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void CloseMailFrame()
Public Shared Sub CloseMailFrame
public:
static void CloseMailFrame()

See Also

Mail Class
wManager.Wow.Helpers Namespace


GetNumAttachments Method

Mail..::..GetNumAttachments Method

Get the number of items attachments (on current mail).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int GetNumAttachments()
Public Shared Function GetNumAttachments As Integer
public:
static int^ GetNumAttachments()

Return Value

number of items attachments.

See Also

Mail Class
wManager.Wow.Helpers Namespace


MailFrameIsShown Method

Mail..::..MailFrameIsShown Method

Mail frame is shown.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool MailFrameIsShown()
Public Shared Function MailFrameIsShown As Boolean
public:
static bool^ MailFrameIsShown()

Return Value

true if XXXX, false otherwise.

See Also

Mail Class
wManager.Wow.Helpers Namespace


OpenAllAttachments Method

Mail..::..OpenAllAttachments Method

Open all attachments (of all mailbox messages, you need to open mailbox before).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void OpenAllAttachments(
    int maxTimeMs
)
Public Shared Sub OpenAllAttachments ( _
    maxTimeMs As Integer _
)
public:
static void OpenAllAttachments(
    int^ maxTimeMs
)

Parameters

maxTimeMs
Type: Int32
The maximum time in milliseconds.

See Also

Mail Class
wManager.Wow.Helpers Namespace


SendMessage Method

Mail..::..SendMessage Method

Send message with items.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void SendMessage(
    string target,
    string titleMsg,
    string txtMsg,
    List<string> itemSend,
    List<string> itemNoSend,
    List<WoWItemQuality> itemQuality,
    out bool needRunAgain
)
Public Shared Sub SendMessage ( _
    target As String, _
    titleMsg As String, _
    txtMsg As String, _
    itemSend As List(Of String), _
    itemNoSend As List(Of String), _
    itemQuality As List(Of WoWItemQuality), _
    <OutAttribute> ByRef needRunAgain As Boolean _
)
public:
static void SendMessage(
    String^ target,
    String^ titleMsg,
    String^ txtMsg,
    List<String^>^ itemSend,
    List<String^>^ itemNoSend,
    List<WoWItemQuality^>^ itemQuality,
    [OutAttribute] bool^% needRunAgain
)

Parameters

target
Type: String
intended recipient of the mail.
titleMsg
Type: String
subject of the mail.
txtMsg
Type: String
body of the mail (can be empty).
itemSend
Type: List <(Of <(<' String >)>)>
List of items names to send.
itemNoSend
Type: List <(Of <(<' String >)>)>
List of items names to not send.
itemQuality
Type: List <(Of <(<' WoWItemQuality >)>)>
List of item qualities to send.
needRunAgain
Type: Boolean %
if set to true items in the bag can still be sent.

See Also

Mail Class
wManager.Wow.Helpers Namespace


Milling Class

Class Milling.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class Milling
Public NotInheritable Class Milling
public ref class Milling abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..Milling

See Also

Milling Members
wManager.Wow.Helpers Namespace


Milling Members

The Milling type exposes the following members.

Methods

Name | Description
NeedRun | Needs the run.
Pulse | Pulses the specified items.

See Also

Milling Class
wManager.Wow.Helpers Namespace


Milling Methods

The Milling type exposes the following members.

Methods

Name | Description
NeedRun | Needs the run.
Pulse | Pulses the specified items.

See Also

Milling Class
wManager.Wow.Helpers Namespace


NeedRun Method

Milling..::..NeedRun Method

Needs the run.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool NeedRun(
    List<string> items
)
Public Shared Function NeedRun ( _
    items As List(Of String) _
) As Boolean
public:
static bool^ NeedRun(
    List<String^>^ items
)

Parameters

items
Type: List <(Of <(<' String >)>)>
The items.

Return Value

true if need to run, false otherwise.

See Also

Milling Class
wManager.Wow.Helpers Namespace


Pulse Method

Milling..::..Pulse Method

Pulses the specified items.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void Pulse(
    List<string> items
)
Public Shared Sub Pulse ( _
    items As List(Of String) _
)
public:
static void Pulse(
    List<String^>^ items
)

Parameters

items
Type: List <(Of <(<' String >)>)>
The items.

See Also

Milling Class
wManager.Wow.Helpers Namespace


MiniMapGenerator Class

Class MiniMapGenerator. Used by UserControlMiniMap

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class MiniMapGenerator
Public NotInheritable Class MiniMapGenerator
public ref class MiniMapGenerator abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..MiniMapGenerator

See Also

MiniMapGenerator Members
wManager.Wow.Helpers Namespace


MiniMapGenerator Members

The MiniMapGenerator type exposes the following members.

Methods

Name Description

Fields

Name | Description
LowQuality | Use low render quality
TileImgSize | The image tile size

See Also

MiniMapGenerator Class
wManager.Wow.Helpers Namespace


MiniMapGenerator Fields

The MiniMapGenerator type exposes the following members.

Fields

Name | Description
LowQuality | Use low render quality
TileImgSize | The image tile size

See Also

MiniMapGenerator Class
wManager.Wow.Helpers Namespace


LowQuality Field

MiniMapGenerator..::..LowQuality Field

Use low render quality

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool LowQuality
Public Shared LowQuality As Boolean
public:
static bool^ LowQuality

See Also

MiniMapGenerator Class
wManager.Wow.Helpers Namespace


TileImgSize Field

MiniMapGenerator..::..TileImgSize Field

The image tile size

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const int TileImgSize
Public Const TileImgSize As Integer
public:
literal int^ TileImgSize

See Also

MiniMapGenerator Class
wManager.Wow.Helpers Namespace


MiniMapGenerator Methods

The MiniMapGenerator type exposes the following members.

Methods

Name Description

See Also

MiniMapGenerator Class
wManager.Wow.Helpers Namespace


MiniMapGenerator.LandmarkMiniMap Class

MiniMapGenerator..::..LandmarkMiniMap Class

Class LandmarkMiniMap, used to show information in UserControlMiniMap and Radar3D (you can found example here: LandmarksMiniMap). Implements the ICloneable

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class LandmarkMiniMap : ICloneable
Public Class LandmarkMiniMap _
    Implements ICloneable
public ref class LandmarkMiniMap : ICloneable

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..MiniMapGenerator..::..LandmarkMiniMap

See Also

MiniMapGenerator..::..LandmarkMiniMap Members
wManager.Wow.Helpers Namespace
ICloneable


MiniMapGenerator.LandmarkMiniMap Members

MiniMapGenerator..::..LandmarkMiniMap Members

The MiniMapGenerator..::..LandmarkMiniMap type exposes the following members.

Constructors

 | Name | Description
Public method | MiniMapGenerator..::..LandmarkMiniMap | Initializes a new instance of the MiniMapGenerator..::..LandmarkMiniMap class.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | AutoResizeIn3DRadar | Automatic resize in 3D radar
Public field | Color | The color
Public field | ConnectWithId | Connect with Id (can be same name)
Public field | Filled | Filled
Public field | Id | The ID (you can use same name several time)
Public field | Opacity | The opacity
Public field | Position | The position
Public field | Size | The size

See Also

MiniMapGenerator..::..LandmarkMiniMap Class
wManager.Wow.Helpers Namespace


LandmarkMiniMap Constructor

Initializes a new instance of the MiniMapGenerator..::..LandmarkMiniMap class.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public LandmarkMiniMap(
    Vector3 position,
    string id,
    Color color,
    float size,
    string connectWithId,
    bool filled,
    float opacity,
    bool autoResizeIn3DRadar
)
Public Sub New ( _
    position As Vector3, _
    id As String, _
    color As Color, _
    size As Single, _
    connectWithId As String, _
    filled As Boolean, _
    opacity As Single, _
    autoResizeIn3DRadar As Boolean _
)
public:
LandmarkMiniMap(
    Vector3^ position,
    String^ id,
    Color^ color,
    float^ size,
    String^ connectWithId,
    bool^ filled,
    float^ opacity,
    bool^ autoResizeIn3DRadar
)

Parameters

position
Type: robotManager.Helpful..::..Vector3
The position.
id
Type: String
The ID (you can use same name several time).
color
Type: Color
The color.
size
Type: Single
The size.
connectWithId
Type: String
Connect with Id (can be same name).
filled
Type: Boolean
if set to true [filled].
opacity
Type: Single
The opacity.
autoResizeIn3DRadar
Type: Boolean
if set to true automatic resize in 3D radar.

See Also

MiniMapGenerator..::..LandmarkMiniMap Class
wManager.Wow.Helpers Namespace


MiniMapGenerator.LandmarkMiniMap Fields

MiniMapGenerator..::..LandmarkMiniMap Fields

The MiniMapGenerator..::..LandmarkMiniMap type exposes the following members.

Fields

 | Name | Description
Public field | AutoResizeIn3DRadar | Automatic resize in 3D radar
Public field | Color | The color
Public field | ConnectWithId | Connect with Id (can be same name)
Public field | Filled | Filled
Public field | Id | The ID (you can use same name several time)
Public field | Opacity | The opacity
Public field | Position | The position
Public field | Size | The size

See Also

MiniMapGenerator..::..LandmarkMiniMap Class
wManager.Wow.Helpers Namespace


AutoResizeIn3DRadar Field

LandmarkMiniMap..::..AutoResizeIn3DRadar Field

Automatic resize in 3D radar

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool AutoResizeIn3DRadar
Public AutoResizeIn3DRadar As Boolean
public:
bool^ AutoResizeIn3DRadar

See Also

MiniMapGenerator..::..LandmarkMiniMap Class
wManager.Wow.Helpers Namespace


Color Field

LandmarkMiniMap..::..Color Field

The color

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Color Color
Public Color As Color
public:
Color^ Color

See Also

MiniMapGenerator..::..LandmarkMiniMap Class
wManager.Wow.Helpers Namespace


ConnectWithId Field

LandmarkMiniMap..::..ConnectWithId Field

Connect with Id (can be same name)

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string ConnectWithId
Public ConnectWithId As String
public:
String^ ConnectWithId

See Also

MiniMapGenerator..::..LandmarkMiniMap Class
wManager.Wow.Helpers Namespace


Filled Field

LandmarkMiniMap..::..Filled Field

Filled

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool Filled
Public Filled As Boolean
public:
bool^ Filled

See Also

MiniMapGenerator..::..LandmarkMiniMap Class
wManager.Wow.Helpers Namespace


Id Field

LandmarkMiniMap..::..Id Field

The ID (you can use same name several time)

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string Id
Public Id As String
public:
String^ Id

See Also

MiniMapGenerator..::..LandmarkMiniMap Class
wManager.Wow.Helpers Namespace


Opacity Field

LandmarkMiniMap..::..Opacity Field

The opacity

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float Opacity
Public Opacity As Single
public:
float^ Opacity

See Also

MiniMapGenerator..::..LandmarkMiniMap Class
wManager.Wow.Helpers Namespace


Position Field

LandmarkMiniMap..::..Position Field

The position

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Vector3 Position
Public Position As Vector3
public:
Vector3^ Position

See Also

MiniMapGenerator..::..LandmarkMiniMap Class
wManager.Wow.Helpers Namespace


Size Field

LandmarkMiniMap..::..Size Field

The size

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float Size
Public Size As Single
public:
float^ Size

See Also

MiniMapGenerator..::..LandmarkMiniMap Class
wManager.Wow.Helpers Namespace


MiniMapGenerator.LandmarkMiniMap Methods

MiniMapGenerator..::..LandmarkMiniMap Methods

The MiniMapGenerator..::..LandmarkMiniMap type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

MiniMapGenerator..::..LandmarkMiniMap Class
wManager.Wow.Helpers Namespace


Clone Method

LandmarkMiniMap..::..Clone Method

Creates a new object that is a copy of the current instance.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Object Clone()
Public Function Clone As Object
public:
Object^ Clone()

Return Value

A new object that is a copy of this instance.

See Also

MiniMapGenerator..::..LandmarkMiniMap Class
wManager.Wow.Helpers Namespace


MiniMapGenerator.LandmarksMiniMap Class

MiniMapGenerator..::..LandmarksMiniMap Class

Class LandmarksMiniMap (for more information look MiniMapGenerator..::..LandmarkMiniMap). Implements the ICloneable

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class LandmarksMiniMap : ICloneable
Public Class LandmarksMiniMap _
    Implements ICloneable
public ref class LandmarksMiniMap : ICloneable

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..MiniMapGenerator..::..LandmarksMiniMap

See Also

MiniMapGenerator..::..LandmarksMiniMap Members
wManager.Wow.Helpers Namespace
ICloneable


MiniMapGenerator.LandmarksMiniMap Members

MiniMapGenerator..::..LandmarksMiniMap Members

The MiniMapGenerator..::..LandmarksMiniMap type exposes the following members.

Methods

 | Name | Description
Public method | Add(MiniMapGenerator..::..LandmarkMiniMap) | Adds the specified landmark.
Public method | Add(List<(Of <<'(MiniMapGenerator..::..LandmarkMiniMap>)>>)) | Adds the specified landmarks.
Public method | Add(Vector3, String, Color, Single, String, Boolean, Single, Boolean) | Adds the specified position.
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove(String) | Removes the specified Id.
Public method | Remove(List<(Of <<'(String>)>>)) | Removes specified Id.
Public method | RemoveAll | Removes all (clear).
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Landmarks | Gets the landmarks.

See Also

MiniMapGenerator..::..LandmarksMiniMap Class
wManager.Wow.Helpers Namespace


MiniMapGenerator.LandmarksMiniMap Methods

MiniMapGenerator..::..LandmarksMiniMap Methods

The MiniMapGenerator..::..LandmarksMiniMap type exposes the following members.

Methods

 | Name | Description
Public method | Add(MiniMapGenerator..::..LandmarkMiniMap) | Adds the specified landmark.
Public method | Add(List<(Of <<'(MiniMapGenerator..::..LandmarkMiniMap>)>>)) | Adds the specified landmarks.
Public method | Add(Vector3, String, Color, Single, String, Boolean, Single, Boolean) | Adds the specified position.
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove(String) | Removes the specified Id.
Public method | Remove(List<(Of <<'(String>)>>)) | Removes specified Id.
Public method | RemoveAll | Removes all (clear).
Public method | ToString | (Inherited from Object.)

See Also

MiniMapGenerator..::..LandmarksMiniMap Class
wManager.Wow.Helpers Namespace


Add Method

LandmarksMiniMap..::..Add Method

Overload List

 | Name | Description
Public method | Add(MiniMapGenerator..::..LandmarkMiniMap) | Adds the specified landmark.
Public method | Add(List<(Of <<'(MiniMapGenerator..::..LandmarkMiniMap>)>>)) | Adds the specified landmarks.
Public method | Add(Vector3, String, Color, Single, String, Boolean, Single, Boolean) | Adds the specified position.

See Also

MiniMapGenerator..::..LandmarksMiniMap Class
MiniMapGenerator..::..LandmarksMiniMap Members
wManager.Wow.Helpers Namespace


Add Method (LandmarkMiniMap)

LandmarksMiniMap..::..Add Method (LandmarkMiniMap)

Adds the specified landmark.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Add(
    MiniMapGenerator..::..LandmarkMiniMap landmark
)
Public Sub Add ( _
    landmark As MiniMapGenerator..::..LandmarkMiniMap _
)
public:
void Add(
    MiniMapGenerator..::..LandmarkMiniMap^ landmark
)

Parameters

landmark
Type: wManager.Wow.Helpers..::..MiniMapGenerator..::..LandmarkMiniMap
The landmark.

See Also

MiniMapGenerator..::..LandmarksMiniMap Class
Add Overload
wManager.Wow.Helpers Namespace


Add Method (List(LandmarkMiniMap))

LandmarksMiniMap..::..Add Method (List<(Of <(<'LandmarkMiniMap>)>)>)

Adds the specified landmarks.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Add(
    List<MiniMapGenerator..::..LandmarkMiniMap> landmarks
)
Public Sub Add ( _
    landmarks As List(Of MiniMapGenerator..::..LandmarkMiniMap) _
)
public:
void Add(
    List<MiniMapGenerator..::..LandmarkMiniMap^>^ landmarks
)

Parameters

landmarks
Type: List <(Of <(<' MiniMapGenerator..::..LandmarkMiniMap >)>)>
The landmarks.

See Also

MiniMapGenerator..::..LandmarksMiniMap Class
Add Overload
wManager.Wow.Helpers Namespace


Add Method (Vector3, String, Color, Single, String, Boolean, Single, Boolean)

LandmarksMiniMap..::..Add Method (Vector3, String, Color, Single, String, Boolean, Single, Boolean)

Adds the specified position.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Add(
    Vector3 position,
    string id,
    Color color,
    float size,
    string connectWithId,
    bool filled,
    float opacity,
    bool autoResizeIn3DRadar
)
Public Sub Add ( _
    position As Vector3, _
    id As String, _
    color As Color, _
    size As Single, _
    connectWithId As String, _
    filled As Boolean, _
    opacity As Single, _
    autoResizeIn3DRadar As Boolean _
)
public:
void Add(
    Vector3^ position,
    String^ id,
    Color^ color,
    float^ size,
    String^ connectWithId,
    bool^ filled,
    float^ opacity,
    bool^ autoResizeIn3DRadar
)

Parameters

position
Type: robotManager.Helpful..::..Vector3
The position.
id
Type: String
The ID (you can use same name several time).
color
Type: Color
The color.
size
Type: Single
The size.
connectWithId
Type: String
Connect with [Id] (can be same name).
filled
Type: Boolean
if set to true [filled].
opacity
Type: Single
The opacity.
autoResizeIn3DRadar
Type: Boolean
if set to true automatic resize in 3D radar.

See Also

MiniMapGenerator..::..LandmarksMiniMap Class
Add Overload
wManager.Wow.Helpers Namespace


Clone Method

LandmarksMiniMap..::..Clone Method

Creates a new object that is a copy of the current instance.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Object Clone()
Public Function Clone As Object
public:
Object^ Clone()

Return Value

A new object that is a copy of this instance.

See Also

MiniMapGenerator..::..LandmarksMiniMap Class
wManager.Wow.Helpers Namespace


Remove Method

LandmarksMiniMap..::..Remove Method

Overload List

 | Name | Description
Public method | Remove(String) | Removes the specified Id.
Public method | Remove(List<(Of <<'(String>)>>)) | Removes specified Id.

See Also

MiniMapGenerator..::..LandmarksMiniMap Class
MiniMapGenerator..::..LandmarksMiniMap Members
wManager.Wow.Helpers Namespace


Remove Method (String)

LandmarksMiniMap..::..Remove Method (String)

Removes the specified Id.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Remove(
    string id
)
Public Sub Remove ( _
    id As String _
)
public:
void Remove(
    String^ id
)

Parameters

id
Type: String
The ID.

See Also

MiniMapGenerator..::..LandmarksMiniMap Class
Remove Overload
wManager.Wow.Helpers Namespace


Remove Method (List(String))

LandmarksMiniMap..::..Remove Method (List<(Of <(<'String>)>)>)

Removes specified Id.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Remove(
    List<string> ids
)
Public Sub Remove ( _
    ids As List(Of String) _
)
public:
void Remove(
    List<String^>^ ids
)

Parameters

ids
Type: List <(Of <(<' String >)>)>
The ids.

See Also

MiniMapGenerator..::..LandmarksMiniMap Class
Remove Overload
wManager.Wow.Helpers Namespace


RemoveAll Method

LandmarksMiniMap..::..RemoveAll Method

Removes all (clear).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void RemoveAll()
Public Sub RemoveAll
public:
void RemoveAll()

See Also

MiniMapGenerator..::..LandmarksMiniMap Class
wManager.Wow.Helpers Namespace


MiniMapGenerator.LandmarksMiniMap Properties

MiniMapGenerator..::..LandmarksMiniMap Properties

The MiniMapGenerator..::..LandmarksMiniMap type exposes the following members.

Properties

 | Name | Description
Public property | Landmarks | Gets the landmarks.

See Also

MiniMapGenerator..::..LandmarksMiniMap Class
wManager.Wow.Helpers Namespace


Landmarks Property

LandmarksMiniMap..::..Landmarks Property

Gets the landmarks.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<MiniMapGenerator..::..LandmarkMiniMap> Landmarks { get; }
Public ReadOnly Property Landmarks As List(Of MiniMapGenerator..::..LandmarkMiniMap)
    Get
public:
property List<MiniMapGenerator..::..LandmarkMiniMap^>^ Landmarks {
    List<MiniMapGenerator..::..LandmarkMiniMap^>^ get ();
}

Field Value

The landmarks.

See Also

MiniMapGenerator..::..LandmarksMiniMap Class
wManager.Wow.Helpers Namespace


MiniMapGenerator.MinimapImage Class

MiniMapGenerator..::..MinimapImage Class

Class MinimapImage.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class MinimapImage
Public Class MinimapImage
public ref class MinimapImage

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..MiniMapGenerator..::..MinimapImage

See Also

MiniMapGenerator..::..MinimapImage Members
wManager.Wow.Helpers Namespace


MiniMapGenerator.MinimapImage Members

MiniMapGenerator..::..MinimapImage Members

The MiniMapGenerator..::..MinimapImage type exposes the following members.

Constructors

 | Name | Description
Public method | MiniMapGenerator..::..MinimapImage | Initializes a new instance of the MiniMapGenerator..::..MinimapImage class.

Methods

 | Name | Description
Public method | Dispose | Disposes this instance.
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | Generate | Generates this instance.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Result | Gets or sets the result.
Public property | StartTileX | Gets the start tile x.
Public property | StartTileY | Gets the start tile y.
Public property | TileHeight | Gets the height of the tile.
Public property | TilesX | Gets the tiles x.
Public property | TilesY | Gets the tiles y.
Public property | TileWidth | Gets the width of the tile.
Public property | World | Gets the world.

See Also

MiniMapGenerator..::..MinimapImage Class
wManager.Wow.Helpers Namespace


MinimapImage Constructor

Initializes a new instance of the MiniMapGenerator..::..MinimapImage class.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public MinimapImage(
    string world,
    int width,
    int height,
    int startX,
    int endX,
    int startY,
    int endY
)
Public Sub New ( _
    world As String, _
    width As Integer, _
    height As Integer, _
    startX As Integer, _
    endX As Integer, _
    startY As Integer, _
    endY As Integer _
)
public:
MinimapImage(
    String^ world,
    int^ width,
    int^ height,
    int^ startX,
    int^ endX,
    int^ startY,
    int^ endY
)

Parameters

world
Type: String
The world.
width
Type: Int32
The width.
height
Type: Int32
The height.
startX
Type: Int32
The start x.
endX
Type: Int32
The end x.
startY
Type: Int32
The start y.
endY
Type: Int32
The end y.

See Also

MiniMapGenerator..::..MinimapImage Class
wManager.Wow.Helpers Namespace


MiniMapGenerator.MinimapImage Methods

MiniMapGenerator..::..MinimapImage Methods

The MiniMapGenerator..::..MinimapImage type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Disposes this instance.
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | Generate | Generates this instance.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

MiniMapGenerator..::..MinimapImage Class
wManager.Wow.Helpers Namespace


Dispose Method

MinimapImage..::..Dispose Method

Disposes this instance.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Dispose()
Public Sub Dispose
public:
void Dispose()

See Also

MiniMapGenerator..::..MinimapImage Class
wManager.Wow.Helpers Namespace


Generate Method

MinimapImage..::..Generate Method

Generates this instance.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Generate()
Public Sub Generate
public:
void Generate()

See Also

MiniMapGenerator..::..MinimapImage Class
wManager.Wow.Helpers Namespace


MiniMapGenerator.MinimapImage Properties

MiniMapGenerator..::..MinimapImage Properties

The MiniMapGenerator..::..MinimapImage type exposes the following members.

Properties

 | Name | Description
Public property | Result | Gets or sets the result.
Public property | StartTileX | Gets the start tile x.
Public property | StartTileY | Gets the start tile y.
Public property | TileHeight | Gets the height of the tile.
Public property | TilesX | Gets the tiles x.
Public property | TilesY | Gets the tiles y.
Public property | TileWidth | Gets the width of the tile.
Public property | World | Gets the world.

See Also

MiniMapGenerator..::..MinimapImage Class
wManager.Wow.Helpers Namespace


Result Property

MinimapImage..::..Result Property

Gets or sets the result.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Bitmap Result { get; set; }
Public Property Result As Bitmap
    Get
    Set
public:
property Bitmap^ Result {
    Bitmap^ get ();
    void set (Bitmap^ value);
}

Field Value

The result.

See Also

MiniMapGenerator..::..MinimapImage Class
wManager.Wow.Helpers Namespace


StartTileX Property

MinimapImage..::..StartTileX Property

Gets the start tile x.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int StartTileX { get; set; }
Public Property StartTileX As Integer
    Get
    Set
public:
property int^ StartTileX {
    int^ get ();
    void set (int^ value);
}

Field Value

The start tile x.

See Also

MiniMapGenerator..::..MinimapImage Class
wManager.Wow.Helpers Namespace


StartTileY Property

MinimapImage..::..StartTileY Property

Gets the start tile y.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int StartTileY { get; set; }
Public Property StartTileY As Integer
    Get
    Set
public:
property int^ StartTileY {
    int^ get ();
    void set (int^ value);
}

Field Value

The start tile y.

See Also

MiniMapGenerator..::..MinimapImage Class
wManager.Wow.Helpers Namespace


TileHeight Property

MinimapImage..::..TileHeight Property

Gets the height of the tile.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int TileHeight { get; set; }
Public Property TileHeight As Integer
    Get
    Set
public:
property int^ TileHeight {
    int^ get ();
    void set (int^ value);
}

Field Value

The height of the tile.

See Also

MiniMapGenerator..::..MinimapImage Class
wManager.Wow.Helpers Namespace


TilesX Property

MinimapImage..::..TilesX Property

Gets the tiles x.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int TilesX { get; set; }
Public Property TilesX As Integer
    Get
    Set
public:
property int^ TilesX {
    int^ get ();
    void set (int^ value);
}

Field Value

The tiles x.

See Also

MiniMapGenerator..::..MinimapImage Class
wManager.Wow.Helpers Namespace


TilesY Property

MinimapImage..::..TilesY Property

Gets the tiles y.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int TilesY { get; set; }
Public Property TilesY As Integer
    Get
    Set
public:
property int^ TilesY {
    int^ get ();
    void set (int^ value);
}

Field Value

The tiles y.

See Also

MiniMapGenerator..::..MinimapImage Class
wManager.Wow.Helpers Namespace


TileWidth Property

MinimapImage..::..TileWidth Property

Gets the width of the tile.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int TileWidth { get; set; }
Public Property TileWidth As Integer
    Get
    Set
public:
property int^ TileWidth {
    int^ get ();
    void set (int^ value);
}

Field Value

The width of the tile.

See Also

MiniMapGenerator..::..MinimapImage Class
wManager.Wow.Helpers Namespace


World Property

MinimapImage..::..World Property

Gets the world.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string World { get; set; }
Public Property World As String
    Get
    Set
public:
property String^ World {
    String^ get ();
    void set (String^ value);
}

Field Value

The world.

See Also

MiniMapGenerator..::..MinimapImage Class
wManager.Wow.Helpers Namespace


MiniMapGenerator.PathImage Class

MiniMapGenerator..::..PathImage Class

Class PathImage.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class PathImage
Public Class PathImage
public ref class PathImage

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..MiniMapGenerator..::..PathImage

See Also

MiniMapGenerator..::..PathImage Members
wManager.Wow.Helpers Namespace


MiniMapGenerator.PathImage Members

MiniMapGenerator..::..PathImage Members

The MiniMapGenerator..::..PathImage type exposes the following members.

Constructors

 | Name | Description
Public method | MiniMapGenerator..::..PathImage | Initializes a new instance of the MiniMapGenerator..::..PathImage class.

Methods

 | Name | Description
Public method | Dispose | Disposes this instance.
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | Generate | Generates the specified screen w.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Background | Gets the background.
Public property | Center | Gets the center.
Public property | Height | Gets or sets the height.
Public property | Landmarks | Gets the landmarks.
Public property | Result | Gets the result.
Public property | Width | Gets or sets the width.
Public property | World | Gets the world.
Public property | Zoom | Gets or sets the zoom.

See Also

MiniMapGenerator..::..PathImage Class
wManager.Wow.Helpers Namespace


PathImage Constructor

Initializes a new instance of the MiniMapGenerator..::..PathImage class.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public PathImage(
    string world,
    Vector3 center,
    MiniMapGenerator..::..LandmarksMiniMap landmarks,
    float zoom
)
Public Sub New ( _
    world As String, _
    center As Vector3, _
    landmarks As MiniMapGenerator..::..LandmarksMiniMap, _
    zoom As Single _
)
public:
PathImage(
    String^ world,
    Vector3^ center,
    MiniMapGenerator..::..LandmarksMiniMap^ landmarks,
    float^ zoom
)

Parameters

world
Type: String
The world.
center
Type: robotManager.Helpful..::..Vector3
The center.
landmarks
Type: wManager.Wow.Helpers..::..MiniMapGenerator..::..LandmarksMiniMap
The landmarks.
zoom
Type: Single
The zoom.

See Also

MiniMapGenerator..::..PathImage Class
wManager.Wow.Helpers Namespace


MiniMapGenerator.PathImage Methods

MiniMapGenerator..::..PathImage Methods

The MiniMapGenerator..::..PathImage type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Disposes this instance.
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | Generate | Generates the specified screen w.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

MiniMapGenerator..::..PathImage Class
wManager.Wow.Helpers Namespace


Dispose Method

PathImage..::..Dispose Method

Disposes this instance.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Dispose()
Public Sub Dispose
public:
void Dispose()

See Also

MiniMapGenerator..::..PathImage Class
wManager.Wow.Helpers Namespace


Generate Method

PathImage..::..Generate Method

Generates the specified screen w.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Generate(
    double screenW,
    double screenH
)
Public Sub Generate ( _
    screenW As Double, _
    screenH As Double _
)
public:
void Generate(
    double^ screenW,
    double^ screenH
)

Parameters

screenW
Type: Double
The screen w.
screenH
Type: Double
The screen h.

See Also

MiniMapGenerator..::..PathImage Class
wManager.Wow.Helpers Namespace


MiniMapGenerator.PathImage Properties

MiniMapGenerator..::..PathImage Properties

The MiniMapGenerator..::..PathImage type exposes the following members.

Properties

 | Name | Description
Public property | Background | Gets the background.
Public property | Center | Gets the center.
Public property | Height | Gets or sets the height.
Public property | Landmarks | Gets the landmarks.
Public property | Result | Gets the result.
Public property | Width | Gets or sets the width.
Public property | World | Gets the world.
Public property | Zoom | Gets or sets the zoom.

See Also

MiniMapGenerator..::..PathImage Class
wManager.Wow.Helpers Namespace


Background Property

PathImage..::..Background Property

Gets the background.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public MiniMapGenerator..::..MinimapImage Background { get; set; }
Public Property Background As MiniMapGenerator..::..MinimapImage
    Get
    Set
public:
property MiniMapGenerator..::..MinimapImage^ Background {
    MiniMapGenerator..::..MinimapImage^ get ();
    void set (MiniMapGenerator..::..MinimapImage^ value);
}

Field Value

The background.

See Also

MiniMapGenerator..::..PathImage Class
wManager.Wow.Helpers Namespace


Center Property

PathImage..::..Center Property

Gets the center.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Vector3 Center { get; set; }
Public Property Center As Vector3
    Get
    Set
public:
property Vector3^ Center {
    Vector3^ get ();
    void set (Vector3^ value);
}

Field Value

The center.

See Also

MiniMapGenerator..::..PathImage Class
wManager.Wow.Helpers Namespace


Height Property

PathImage..::..Height Property

Gets or sets the height.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int Height { get; set; }
Public Property Height As Integer
    Get
    Set
public:
property int^ Height {
    int^ get ();
    void set (int^ value);
}

Field Value

The height.

See Also

MiniMapGenerator..::..PathImage Class
wManager.Wow.Helpers Namespace


Landmarks Property

PathImage..::..Landmarks Property

Gets the landmarks.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public MiniMapGenerator..::..LandmarksMiniMap Landmarks { get; set; }
Public Property Landmarks As MiniMapGenerator..::..LandmarksMiniMap
    Get
    Set
public:
property MiniMapGenerator..::..LandmarksMiniMap^ Landmarks {
    MiniMapGenerator..::..LandmarksMiniMap^ get ();
    void set (MiniMapGenerator..::..LandmarksMiniMap^ value);
}

Field Value

The landmarks.

See Also

MiniMapGenerator..::..PathImage Class
wManager.Wow.Helpers Namespace


Result Property

PathImage..::..Result Property

Gets the result.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Bitmap Result { get; }
Public ReadOnly Property Result As Bitmap
    Get
public:
property Bitmap^ Result {
    Bitmap^ get ();
}

Field Value

The result.

See Also

MiniMapGenerator..::..PathImage Class
wManager.Wow.Helpers Namespace


Width Property

PathImage..::..Width Property

Gets or sets the width.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int Width { get; set; }
Public Property Width As Integer
    Get
    Set
public:
property int^ Width {
    int^ get ();
    void set (int^ value);
}

Field Value

The width.

See Also

MiniMapGenerator..::..PathImage Class
wManager.Wow.Helpers Namespace


World Property

PathImage..::..World Property

Gets the world.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string World { get; set; }
Public Property World As String
    Get
    Set
public:
property String^ World {
    String^ get ();
    void set (String^ value);
}

Field Value

The world.

See Also

MiniMapGenerator..::..PathImage Class
wManager.Wow.Helpers Namespace


Zoom Property

PathImage..::..Zoom Property

Gets or sets the zoom.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float Zoom { get; set; }
Public Property Zoom As Single
    Get
    Set
public:
property float^ Zoom {
    float^ get ();
    void set (float^ value);
}

Field Value

The zoom.

See Also

MiniMapGenerator..::..PathImage Class
wManager.Wow.Helpers Namespace


Move Class

Class Move. Prefer to use this class to move the character (if you enabled option UseLuaToMove methods will use lua function instead keyboard).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class Move
Public NotInheritable Class Move
public ref class Move abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..Move

See Also

Move Members
wManager.Wow.Helpers Namespace


Move Members

The Move type exposes the following members.

Methods

Name | Description
Backward | Move backwards.
Forward | Move forward.
JumpOrAscend | Jump or ascend.
SitStandOrDescend | Sit or descend.
StrafeLeft | Strafe left.
StrafeRight | Strafe right.
TurnLeft | Turn left.
TurnRight | Turn right.

See Also

Move Class
wManager.Wow.Helpers Namespace


Move Methods

The Move type exposes the following members.

Methods

Name | Description
Backward | Move backwards.
Forward | Move forward.
JumpOrAscend | Jump or ascend.
SitStandOrDescend | Sit or descend.
StrafeLeft | Strafe left.
StrafeRight | Strafe right.
TurnLeft | Turn left.
TurnRight | Turn right.

See Also

Move Class
wManager.Wow.Helpers Namespace


Backward Method

Move..::..Backward Method

Move backwards.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void Backward(
    Move..::..MoveAction action,
    int timeMs
)
Public Shared Sub Backward ( _
    action As Move..::..MoveAction, _
    timeMs As Integer _
)
public:
static void Backward(
    Move..::..MoveAction^ action,
    int^ timeMs
)

Parameters

action
Type: wManager.Wow.Helpers..::..Move..::..MoveAction
The action.
timeMs
Type: Int32
The time in milliseconds (if you use action PressKey).

See Also

Move Class
wManager.Wow.Helpers Namespace


Forward Method

Move..::..Forward Method

Move forward.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void Forward(
    Move..::..MoveAction action,
    int timeMs
)
Public Shared Sub Forward ( _
    action As Move..::..MoveAction, _
    timeMs As Integer _
)
public:
static void Forward(
    Move..::..MoveAction^ action,
    int^ timeMs
)

Parameters

action
Type: wManager.Wow.Helpers..::..Move..::..MoveAction
The action.
timeMs
Type: Int32
The time in milliseconds (if you use action PressKey).

See Also

Move Class
wManager.Wow.Helpers Namespace


JumpOrAscend Method

Move..::..JumpOrAscend Method

Jump or ascend.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void JumpOrAscend(
    Move..::..MoveAction action,
    int timeMs
)
Public Shared Sub JumpOrAscend ( _
    action As Move..::..MoveAction, _
    timeMs As Integer _
)
public:
static void JumpOrAscend(
    Move..::..MoveAction^ action,
    int^ timeMs
)

Parameters

action
Type: wManager.Wow.Helpers..::..Move..::..MoveAction
The action.
timeMs
Type: Int32
The time in milliseconds (if you use action PressKey).

See Also

Move Class
wManager.Wow.Helpers Namespace


SitStandOrDescend Method

Move..::..SitStandOrDescend Method

Sit or descend.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void SitStandOrDescend(
    Move..::..MoveAction action,
    int timeMs
)
Public Shared Sub SitStandOrDescend ( _
    action As Move..::..MoveAction, _
    timeMs As Integer _
)
public:
static void SitStandOrDescend(
    Move..::..MoveAction^ action,
    int^ timeMs
)

Parameters

action
Type: wManager.Wow.Helpers..::..Move..::..MoveAction
The action.
timeMs
Type: Int32
The time in milliseconds (if you use action PressKey).

See Also

Move Class
wManager.Wow.Helpers Namespace


StrafeLeft Method

Move..::..StrafeLeft Method

Strafe left.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void StrafeLeft(
    Move..::..MoveAction action,
    int timeMs
)
Public Shared Sub StrafeLeft ( _
    action As Move..::..MoveAction, _
    timeMs As Integer _
)
public:
static void StrafeLeft(
    Move..::..MoveAction^ action,
    int^ timeMs
)

Parameters

action
Type: wManager.Wow.Helpers..::..Move..::..MoveAction
The action.
timeMs
Type: Int32
The time in milliseconds (if you use action PressKey).

See Also

Move Class
wManager.Wow.Helpers Namespace


StrafeRight Method

Move..::..StrafeRight Method

Strafe right.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void StrafeRight(
    Move..::..MoveAction action,
    int timeMs
)
Public Shared Sub StrafeRight ( _
    action As Move..::..MoveAction, _
    timeMs As Integer _
)
public:
static void StrafeRight(
    Move..::..MoveAction^ action,
    int^ timeMs
)

Parameters

action
Type: wManager.Wow.Helpers..::..Move..::..MoveAction
The action.
timeMs
Type: Int32
The time in milliseconds (if you use action PressKey).

See Also

Move Class
wManager.Wow.Helpers Namespace


TurnLeft Method

Move..::..TurnLeft Method

Turn left.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void TurnLeft(
    Move..::..MoveAction action,
    int timeMs
)
Public Shared Sub TurnLeft ( _
    action As Move..::..MoveAction, _
    timeMs As Integer _
)
public:
static void TurnLeft(
    Move..::..MoveAction^ action,
    int^ timeMs
)

Parameters

action
Type: wManager.Wow.Helpers..::..Move..::..MoveAction
The action.
timeMs
Type: Int32
The time in milliseconds (if you use action PressKey).

See Also

Move Class
wManager.Wow.Helpers Namespace


TurnRight Method

Move..::..TurnRight Method

Turn right.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void TurnRight(
    Move..::..MoveAction action,
    int timeMs
)
Public Shared Sub TurnRight ( _
    action As Move..::..MoveAction, _
    timeMs As Integer _
)
public:
static void TurnRight(
    Move..::..MoveAction^ action,
    int^ timeMs
)

Parameters

action
Type: wManager.Wow.Helpers..::..Move..::..MoveAction
The action.
timeMs
Type: Int32
The time in milliseconds (if you use action PressKey).

See Also

Move Class
wManager.Wow.Helpers Namespace


Move.MoveAction Enumeration

Move..::..MoveAction Enumeration

Press keyboard key (DownKey and UpKey)

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public enum MoveAction
Public Enumeration MoveAction
public enum class MoveAction

Members

Member name | Description
PressKey | Press keyboard key (DownKey and UpKey)
UpKey | Up (start) keyboard key
DownKey | Down (strop) keyboard key

See Also

wManager.Wow.Helpers Namespace


MovementManager Class

Main class for handling movement with a path or a destination

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class MovementManager
Public NotInheritable Class MovementManager
public ref class MovementManager abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..MovementManager

See Also

MovementManager Members
wManager.Wow.Helpers Namespace


MovementManager Members

The MovementManager type exposes the following members.

Methods

Name | Description
AngleToFacing | Angle to facing position B.
AvoidWallRay | Try to avoid the wall and small obstacles TraceLine (you need to enabled option AvoidWallWithRays).
Face(WoWUnit) | Face the Unit.
Face(WoWPlayer) | Face the specified Player.
Face(WoWGameObject) | Face the specified GameObject.
Face(Vector3) | Faces the specified position.
Go | Follow path.
GoLoop | Follow path in loop.
GoUnderWater | Go under water (used by sample when character is dead if corpse is under water).
IsBehind | Determine whether the specified position is behind specified target position and rotation.
IsFacing | Determine whether the specified position and rotation is facing specified position.
LaunchThreadMovementManager | Launch the movement manager thread (if not launched).
MoveTo(Vector3) | Move to position.
MoveTo(Single, Single, Single) | Move to Position.
MoveTo(WoWUnit) | Moves to unit.
MoveTo(WoWGameObject) | Moves to game object.
StopMove | Stop Go(List<(Of <<'(Vector3>)>>), Boolean), GoLoop(List<(Of <<'(Vector3>)>>), Boolean, Int32) and MoveTo(Vector3) if required.
StopMoveNewThread | Call StopMove()()()() in new thread.
StopMoveOnly | Stop Go(List<(Of <<'(Vector3>)>>), Boolean) and GoLoop(List<(Of <<'(Vector3>)>>), Boolean, Int32) (don't stop MoveTo(Vector3)).
StopMoveTo()()()() | Stop MoveTo(Vector3).
StopMoveTo(Boolean, Int32) | Stop MoveTo(Vector3).
StopMoveToNewThread | Call StopMoveTo()()()() in new thread

Fields

Name | Description
StopMoveOnContinentChange | Stop move when continent change

Properties

Name | Description
CurrentMoveTo | Get the current move to position.
CurrentPath | Get the current path (can be modified by MovementManager when character are stuck, unmodified path is CurrentPathOrigine).
CurrentPathOrigine | Get the unmodified current path (because CurrentPath can be modified).
InMovement | Return true if the player is currently in move (Go(List<(Of <<'(Vector3>)>>), Boolean) or GoLoop(List<(Of <<'(Vector3>)>>), Boolean, Int32)).
InMovementLoop | Return true if the player is currently in move (GoLoop(List<(Of <<'(Vector3>)>>), Boolean, Int32)).
InMovementNoLoop | Return true if the player is currently in move (Go(List<(Of <<'(Vector3>)>>), Boolean)).
InMoveTo | Get if character use MoveTo(Vector3).
IsUnStuck | Return true if unstuck is in progress
PointId | Get or set the current path index (position in CurrentPath).
StuckCount | Get number of stuck

See Also

MovementManager Class
wManager.Wow.Helpers Namespace


MovementManager Fields

The MovementManager type exposes the following members.

Fields

Name | Description
StopMoveOnContinentChange | Stop move when continent change

See Also

MovementManager Class
wManager.Wow.Helpers Namespace


StopMoveOnContinentChange Field

MovementManager..::..StopMoveOnContinentChange Field

Stop move when continent change

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool StopMoveOnContinentChange
Public Shared StopMoveOnContinentChange As Boolean
public:
static bool^ StopMoveOnContinentChange

See Also

MovementManager Class
wManager.Wow.Helpers Namespace


MovementManager Methods

The MovementManager type exposes the following members.

Methods

Name | Description
AngleToFacing | Angle to facing position B.
AvoidWallRay | Try to avoid the wall and small obstacles TraceLine (you need to enabled option AvoidWallWithRays).
Face(WoWUnit) | Face the Unit.
Face(WoWPlayer) | Face the specified Player.
Face(WoWGameObject) | Face the specified GameObject.
Face(Vector3) | Faces the specified position.
Go | Follow path.
GoLoop | Follow path in loop.
GoUnderWater | Go under water (used by sample when character is dead if corpse is under water).
IsBehind | Determine whether the specified position is behind specified target position and rotation.
IsFacing | Determine whether the specified position and rotation is facing specified position.
LaunchThreadMovementManager | Launch the movement manager thread (if not launched).
MoveTo(Vector3) | Move to position.
MoveTo(Single, Single, Single) | Move to Position.
MoveTo(WoWUnit) | Moves to unit.
MoveTo(WoWGameObject) | Moves to game object.
StopMove | Stop Go(List<(Of <<'(Vector3>)>>), Boolean), GoLoop(List<(Of <<'(Vector3>)>>), Boolean, Int32) and MoveTo(Vector3) if required.
StopMoveNewThread | Call StopMove()()()() in new thread.
StopMoveOnly | Stop Go(List<(Of <<'(Vector3>)>>), Boolean) and GoLoop(List<(Of <<'(Vector3>)>>), Boolean, Int32) (don't stop MoveTo(Vector3)).
StopMoveTo()()()() | Stop MoveTo(Vector3).
StopMoveTo(Boolean, Int32) | Stop MoveTo(Vector3).
StopMoveToNewThread | Call StopMoveTo()()()() in new thread

See Also

MovementManager Class
wManager.Wow.Helpers Namespace


AngleToFacing Method

MovementManager..::..AngleToFacing Method

Angle to facing position B.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static float AngleToFacing(
    Vector3 vector3A,
    Vector3 vector3B
)
Public Shared Function AngleToFacing ( _
    vector3A As Vector3, _
    vector3B As Vector3 _
) As Single
public:
static float^ AngleToFacing(
    Vector3^ vector3A,
    Vector3^ vector3B
)

Parameters

vector3A
Type: robotManager.Helpful..::..Vector3
The position A.
vector3B
Type: robotManager.Helpful..::..Vector3
The position B.

Return Value

System.Single.

See Also

MovementManager Class
wManager.Wow.Helpers Namespace


AvoidWallRay Method

MovementManager..::..AvoidWallRay Method

Try to avoid the wall and small obstacles TraceLine (you need to enabled option AvoidWallWithRays).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void AvoidWallRay(
    Vector3 dest,
    bool force,
    bool jumpOnly
)
Public Shared Sub AvoidWallRay ( _
    dest As Vector3, _
    force As Boolean, _
    jumpOnly As Boolean _
)
public:
static void AvoidWallRay(
    Vector3^ dest,
    bool^ force,
    bool^ jumpOnly
)

Parameters

dest
Type: robotManager.Helpful..::..Vector3
The destination position.
force
Type: Boolean
if set to true force test (ignore timer).
jumpOnly
Type: Boolean
if set to true jump only if obstacle detected (by default bot can also strafe left/right).

See Also

MovementManager Class
wManager.Wow.Helpers Namespace


Face Method

MovementManager..::..Face Method

Overload List

Name | Description
Face(WoWUnit) | Face the Unit.
Face(WoWPlayer) | Face the specified Player.
Face(WoWGameObject) | Face the specified GameObject.
Face(Vector3) | Faces the specified position.

See Also

MovementManager Class
MovementManager Members
wManager.Wow.Helpers Namespace


Face Method (WoWUnit)

MovementManager..::..Face Method (WoWUnit)

Face the Unit.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void Face(
    WoWUnit obj
)
Public Shared Sub Face ( _
    obj As WoWUnit _
)
public:
static void Face(
    WoWUnit^ obj
)

Parameters

obj
Type: wManager.Wow.ObjectManager..::..WoWUnit
The Unit.

See Also

MovementManager Class
Face Overload
wManager.Wow.Helpers Namespace


Face Method (WoWPlayer)

MovementManager..::..Face Method (WoWPlayer)

Face the specified Player.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void Face(
    WoWPlayer obj
)
Public Shared Sub Face ( _
    obj As WoWPlayer _
)
public:
static void Face(
    WoWPlayer^ obj
)

Parameters

obj
Type: wManager.Wow.ObjectManager..::..WoWPlayer
The Player.

See Also

MovementManager Class
Face Overload
wManager.Wow.Helpers Namespace


Face Method (WoWGameObject)

MovementManager..::..Face Method (WoWGameObject)

Face the specified GameObject.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void Face(
    WoWGameObject obj
)
Public Shared Sub Face ( _
    obj As WoWGameObject _
)
public:
static void Face(
    WoWGameObject^ obj
)

Parameters

obj
Type: wManager.Wow.ObjectManager..::..WoWGameObject
The GameObject.

See Also

MovementManager Class
Face Overload
wManager.Wow.Helpers Namespace


Face Method (Vector3)

MovementManager..::..Face Method (Vector3)

Faces the specified position.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void Face(
    Vector3 position
)
Public Shared Sub Face ( _
    position As Vector3 _
)
public:
static void Face(
    Vector3^ position
)

Parameters

position
Type: robotManager.Helpful..::..Vector3
The position.

See Also

MovementManager Class
Face Overload
wManager.Wow.Helpers Namespace


Go Method

MovementManager..::..Go Method

Follow path.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void Go(
    List<Vector3> points,
    bool unused
)
Public Shared Sub Go ( _
    points As List(Of Vector3), _
    unused As Boolean _
)
public:
static void Go(
    List<Vector3^>^ points,
    bool^ unused
)

Parameters

points
Type: List <(Of <(<' Vector3 >)>)>
The _points.
unused
Type: Boolean
unused (avoid to break support).

See Also

MovementManager Class
wManager.Wow.Helpers Namespace


GoLoop Method

MovementManager..::..GoLoop Method

Follow path in loop.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void GoLoop(
    List<Vector3> points,
    bool unused,
    int forceStartPointId
)
Public Shared Sub GoLoop ( _
    points As List(Of Vector3), _
    unused As Boolean, _
    forceStartPointId As Integer _
)
public:
static void GoLoop(
    List<Vector3^>^ points,
    bool^ unused,
    int^ forceStartPointId
)

Parameters

points
Type: List <(Of <(<' Vector3 >)>)>
The points.
unused
Type: Boolean
if set to true [unused].
forceStartPointId
Type: Int32
The force start point identifier.

See Also

MovementManager Class
wManager.Wow.Helpers Namespace


GoUnderWater Method

MovementManager..::..GoUnderWater Method

Go under water (used by sample when character is dead if corpse is under water).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void GoUnderWater()
Public Shared Sub GoUnderWater
public:
static void GoUnderWater()

See Also

MovementManager Class
wManager.Wow.Helpers Namespace


IsBehind Method

MovementManager..::..IsBehind Method

Determine whether the specified position is behind specified target position and rotation.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool IsBehind(
    Vector3 me,
    Vector3 target,
    float targetFacingRadians,
    float arcRadians
)
Public Shared Function IsBehind ( _
    me As Vector3, _
    target As Vector3, _
    targetFacingRadians As Single, _
    arcRadians As Single _
) As Boolean
public:
static bool^ IsBehind(
    Vector3^ me,
    Vector3^ target,
    float^ targetFacingRadians,
    float^ arcRadians
)

Parameters

me
Type: robotManager.Helpful..::..Vector3
Me position.
target
Type: robotManager.Helpful..::..Vector3
The target position.
targetFacingRadians
Type: Single
The target facing radians.
arcRadians
Type: Single
The arc radians.

Return Value

true if the specified me is behind target; otherwise, false.

See Also

MovementManager Class
wManager.Wow.Helpers Namespace


IsFacing Method

MovementManager..::..IsFacing Method

Determine whether the specified position and rotation is facing specified position.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool IsFacing(
    Vector3 me,
    float meRotation,
    Vector3 target,
    float arcRadians
)
Public Shared Function IsFacing ( _
    me As Vector3, _
    meRotation As Single, _
    target As Vector3, _
    arcRadians As Single _
) As Boolean
public:
static bool^ IsFacing(
    Vector3^ me,
    float^ meRotation,
    Vector3^ target,
    float^ arcRadians
)

Parameters

me
Type: robotManager.Helpful..::..Vector3
Me position.
meRotation
Type: Single
Me rotation.
target
Type: robotManager.Helpful..::..Vector3
The target position.
arcRadians
Type: Single
The arc radians.

Return Value

true if the specified position is facing target position; otherwise, false.

See Also

MovementManager Class
wManager.Wow.Helpers Namespace


LaunchThreadMovementManager Method

MovementManager..::..LaunchThreadMovementManager Method

Launch the movement manager thread (if not launched).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void LaunchThreadMovementManager()
Public Shared Sub LaunchThreadMovementManager
public:
static void LaunchThreadMovementManager()

See Also

MovementManager Class
wManager.Wow.Helpers Namespace


MoveTo Method

MovementManager..::..MoveTo Method

Overload List

Name | Description
MoveTo(Vector3) | Move to position.
MoveTo(Single, Single, Single) | Move to Position.
MoveTo(WoWUnit) | Moves to unit.
MoveTo(WoWGameObject) | Moves to game object.

See Also

MovementManager Class
MovementManager Members
wManager.Wow.Helpers Namespace


MoveTo Method (Vector3)

MovementManager..::..MoveTo Method (Vector3)

Move to position.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void MoveTo(
    Vector3 point
)
Public Shared Sub MoveTo ( _
    point As Vector3 _
)
public:
static void MoveTo(
    Vector3^ point
)

Parameters

point
Type: robotManager.Helpful..::..Vector3
The position.

See Also

MovementManager Class
MoveTo Overload
wManager.Wow.Helpers Namespace


MoveTo Method (Single, Single, Single)

MovementManager..::..MoveTo Method (Single, Single, Single)

Move to Position.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void MoveTo(
    float x,
    float y,
    float z
)
Public Shared Sub MoveTo ( _
    x As Single, _
    y As Single, _
    z As Single _
)
public:
static void MoveTo(
    float^ x,
    float^ y,
    float^ z
)

Parameters

x
Type: Single
X.
y
Type: Single
Y.
z
Type: Single
Z.

See Also

MovementManager Class
MoveTo Overload
wManager.Wow.Helpers Namespace


MoveTo Method (WoWUnit)

MovementManager..::..MoveTo Method (WoWUnit)

Moves to unit.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void MoveTo(
    WoWUnit obj
)
Public Shared Sub MoveTo ( _
    obj As WoWUnit _
)
public:
static void MoveTo(
    WoWUnit^ obj
)

Parameters

obj
Type: wManager.Wow.ObjectManager..::..WoWUnit
The Unit.

See Also

MovementManager Class
MoveTo Overload
wManager.Wow.Helpers Namespace


MoveTo Method (WoWGameObject)

MovementManager..::..MoveTo Method (WoWGameObject)

Moves to game object.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void MoveTo(
    WoWGameObject obj
)
Public Shared Sub MoveTo ( _
    obj As WoWGameObject _
)
public:
static void MoveTo(
    WoWGameObject^ obj
)

Parameters

obj
Type: wManager.Wow.ObjectManager..::..WoWGameObject
The GameObject.

See Also

MovementManager Class
MoveTo Overload
wManager.Wow.Helpers Namespace


StopMove Method

MovementManager..::..StopMove Method

Stop Go(List<(Of <<'(Vector3>)>>), Boolean), GoLoop(List<(Of <<'(Vector3>)>>), Boolean, Int32) and MoveTo(Vector3) if required.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void StopMove()
Public Shared Sub StopMove
public:
static void StopMove()

See Also

MovementManager Class
wManager.Wow.Helpers Namespace


StopMoveNewThread Method

MovementManager..::..StopMoveNewThread Method

Call StopMove()()()() in new thread.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void StopMoveNewThread()
Public Shared Sub StopMoveNewThread
public:
static void StopMoveNewThread()

See Also

MovementManager Class
wManager.Wow.Helpers Namespace


StopMoveOnly Method

MovementManager..::..StopMoveOnly Method

Stop Go(List<(Of <<'(Vector3>)>>), Boolean) and GoLoop(List<(Of <<'(Vector3>)>>), Boolean, Int32) (don't stop MoveTo(Vector3)).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void StopMoveOnly()
Public Shared Sub StopMoveOnly
public:
static void StopMoveOnly()

See Also

MovementManager Class
wManager.Wow.Helpers Namespace


StopMoveTo Method

MovementManager..::..StopMoveTo Method

Overload List

Name | Description
StopMoveTo()()()() | Stop MoveTo(Vector3).
StopMoveTo(Boolean, Int32) | Stop MoveTo(Vector3).

See Also

MovementManager Class
MovementManager Members
wManager.Wow.Helpers Namespace


StopMoveTo Method

MovementManager..::..StopMoveTo Method

Stop MoveTo(Vector3).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void StopMoveTo()
Public Shared Sub StopMoveTo
public:
static void StopMoveTo()

See Also

MovementManager Class
StopMoveTo Overload
wManager.Wow.Helpers Namespace


StopMoveTo Method (Boolean, Int32)

MovementManager..::..StopMoveTo Method (Boolean, Int32)

Stop MoveTo(Vector3).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void StopMoveTo(
    bool upKey,
    int nextMoveToWaitTime
)
Public Shared Sub StopMoveTo ( _
    upKey As Boolean, _
    nextMoveToWaitTime As Integer _
)
public:
static void StopMoveTo(
    bool^ upKey,
    int^ nextMoveToWaitTime
)

Parameters

upKey
Type: Boolean
if set to true up keyboard keys used to move.
nextMoveToWaitTime
Type: Int32
Disable MoveTo(Vector3) during X milliseconds.

See Also

MovementManager Class
StopMoveTo Overload
wManager.Wow.Helpers Namespace


StopMoveToNewThread Method

MovementManager..::..StopMoveToNewThread Method

Call StopMoveTo()()()() in new thread

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void StopMoveToNewThread()
Public Shared Sub StopMoveToNewThread
public:
static void StopMoveToNewThread()

See Also

MovementManager Class
wManager.Wow.Helpers Namespace


MovementManager Properties

The MovementManager type exposes the following members.

Properties

Name | Description
CurrentMoveTo | Get the current move to position.
CurrentPath | Get the current path (can be modified by MovementManager when character are stuck, unmodified path is CurrentPathOrigine).
CurrentPathOrigine | Get the unmodified current path (because CurrentPath can be modified).
InMovement | Return true if the player is currently in move (Go(List<(Of <<'(Vector3>)>>), Boolean) or GoLoop(List<(Of <<'(Vector3>)>>), Boolean, Int32)).
InMovementLoop | Return true if the player is currently in move (GoLoop(List<(Of <<'(Vector3>)>>), Boolean, Int32)).
InMovementNoLoop | Return true if the player is currently in move (Go(List<(Of <<'(Vector3>)>>), Boolean)).
InMoveTo | Get if character use MoveTo(Vector3).
IsUnStuck | Return true if unstuck is in progress
PointId | Get or set the current path index (position in CurrentPath).
StuckCount | Get number of stuck

See Also

MovementManager Class
wManager.Wow.Helpers Namespace


CurrentMoveTo Property

MovementManager..::..CurrentMoveTo Property

Get the current move to position.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static Vector3 CurrentMoveTo { get; }
Public Shared ReadOnly Property CurrentMoveTo As Vector3
    Get
public:
static property Vector3^ CurrentMoveTo {
    Vector3^ get ();
}

Field Value

The current move to position.

See Also

MovementManager Class
wManager.Wow.Helpers Namespace


CurrentPath Property

MovementManager..::..CurrentPath Property

Get the current path (can be modified by MovementManager when character are stuck, unmodified path is CurrentPathOrigine).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<Vector3> CurrentPath { get; }
Public Shared ReadOnly Property CurrentPath As List(Of Vector3)
    Get
public:
static property List<Vector3^>^ CurrentPath {
    List<Vector3^>^ get ();
}

Field Value

The current path.

See Also

MovementManager Class
wManager.Wow.Helpers Namespace


CurrentPathOrigine Property

MovementManager..::..CurrentPathOrigine Property

Get the unmodified current path (because CurrentPath can be modified).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<Vector3> CurrentPathOrigine { get; }
Public Shared ReadOnly Property CurrentPathOrigine As List(Of Vector3)
    Get
public:
static property List<Vector3^>^ CurrentPathOrigine {
    List<Vector3^>^ get ();
}

Field Value

The initial current path.

See Also

MovementManager Class
wManager.Wow.Helpers Namespace


InMovement Property

MovementManager..::..InMovement Property

Return true if the player is currently in move (Go(List<(Of <<'(Vector3>)>>), Boolean) or GoLoop(List<(Of <<'(Vector3>)>>), Boolean, Int32)).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool InMovement { get; }
Public Shared ReadOnly Property InMovement As Boolean
    Get
public:
static property bool^ InMovement {
    bool^ get ();
}

Field Value

true if in movement; otherwise, false .

See Also

MovementManager Class
wManager.Wow.Helpers Namespace


InMovementLoop Property

MovementManager..::..InMovementLoop Property

Return true if the player is currently in move (GoLoop(List<(Of <<'(Vector3>)>>), Boolean, Int32)).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool InMovementLoop { get; }
Public Shared ReadOnly Property InMovementLoop As Boolean
    Get
public:
static property bool^ InMovementLoop {
    bool^ get ();
}

Field Value

true if in movement; otherwise, false .

See Also

MovementManager Class
wManager.Wow.Helpers Namespace


InMovementNoLoop Property

MovementManager..::..InMovementNoLoop Property

Return true if the player is currently in move (Go(List<(Of <<'(Vector3>)>>), Boolean)).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool InMovementNoLoop { get; }
Public Shared ReadOnly Property InMovementNoLoop As Boolean
    Get
public:
static property bool^ InMovementNoLoop {
    bool^ get ();
}

Field Value

true if in movement; otherwise, false .

See Also

MovementManager Class
wManager.Wow.Helpers Namespace


InMoveTo Property

MovementManager..::..InMoveTo Property

Get if character use MoveTo(Vector3).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool InMoveTo { get; }
Public Shared ReadOnly Property InMoveTo As Boolean
    Get
public:
static property bool^ InMoveTo {
    bool^ get ();
}

Field Value

true if the player is in MoveTo(Vector3); otherwise, false .

See Also

MovementManager Class
wManager.Wow.Helpers Namespace


IsUnStuck Property

MovementManager..::..IsUnStuck Property

Return true if unstuck is in progress

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool IsUnStuck { get; }
Public Shared ReadOnly Property IsUnStuck As Boolean
    Get
public:
static property bool^ IsUnStuck {
    bool^ get ();
}

Field Value

true if unstuck is in progress; otherwise, false.

See Also

MovementManager Class
wManager.Wow.Helpers Namespace


PointId Property

MovementManager..::..PointId Property

Get or set the current path index (position in CurrentPath).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int PointId { get; set; }
Public Shared Property PointId As Integer
    Get
    Set
public:
static property int^ PointId {
    int^ get ();
    void set (int^ value);
}

Field Value

The path index.

See Also

MovementManager Class
wManager.Wow.Helpers Namespace


StuckCount Property

MovementManager..::..StuckCount Property

Get number of stuck

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int StuckCount { get; }
Public Shared ReadOnly Property StuckCount As Integer
    Get
public:
static property int^ StuckCount {
    int^ get ();
}

Field Value

The stuck count.

See Also

MovementManager Class
wManager.Wow.Helpers Namespace


NpcDB Class

Class NpcDB. Manage list of NPCs vendor, repair, trainer, ... Saved in the file "WRobot\Data\NpcDB.xml".

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class NpcDB
Public Class NpcDB
public ref class NpcDB

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..NpcDB

See Also

NpcDB Members
wManager.Wow.Helpers Namespace


NpcDB Members

The NpcDB type exposes the following members.

Methods

 | Name | Description
 | AddNpc | Add NPC to ListNpc.
 | AddNpcRange | Add several NPCs to ListNpc.
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
 | GetNpcNearby(Npc..::..NpcType) | Get closest NPC by type.
 | GetNpcNearby(Npc..::..NpcType, Npc..::..NpcVendorItemClass) | Get closest NPC by type.
 | GetNpcNearby(Npc..::..NpcType, Npc..::..FactionType, ContinentId, Vector3, Boolean, Npc..::..NpcVendorItemClass) | Get closest NPC by type.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
 | NpcSimilarExist | Similar NPC exist.
 | Save | Save to file.
Public method | ToString | (Inherited from Object.)

Fields

Name | Description
AcceptOnlyProfileNpc | Accept only profile NPC (similar to AcceptOnlyProfileNpc).

Properties

Name | Description
ListNpc | Get or set the NPCs list (it is better to use AddNpc(Npc, Boolean, Boolean) or AddNpcRange(List<(Of <<'(Npc>)>>), Boolean, Boolean) to add NPC).

See Also

NpcDB Class
wManager.Wow.Helpers Namespace


NpcDB Fields

The NpcDB type exposes the following members.

Fields

Name | Description
AcceptOnlyProfileNpc | Accept only profile NPC (similar to AcceptOnlyProfileNpc).

See Also

NpcDB Class
wManager.Wow.Helpers Namespace


AcceptOnlyProfileNpc Field

NpcDB..::..AcceptOnlyProfileNpc Field

Accept only profile NPC (similar to AcceptOnlyProfileNpc).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool AcceptOnlyProfileNpc
Public Shared AcceptOnlyProfileNpc As Boolean
public:
static bool^ AcceptOnlyProfileNpc

See Also

NpcDB Class
wManager.Wow.Helpers Namespace


NpcDB Methods

The NpcDB type exposes the following members.

Methods

 | Name | Description
 | AddNpc | Add NPC to ListNpc.
 | AddNpcRange | Add several NPCs to ListNpc.
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
 | GetNpcNearby(Npc..::..NpcType) | Get closest NPC by type.
 | GetNpcNearby(Npc..::..NpcType, Npc..::..NpcVendorItemClass) | Get closest NPC by type.
 | GetNpcNearby(Npc..::..NpcType, Npc..::..FactionType, ContinentId, Vector3, Boolean, Npc..::..NpcVendorItemClass) | Get closest NPC by type.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
 | NpcSimilarExist | Similar NPC exist.
 | Save | Save to file.
Public method | ToString | (Inherited from Object.)

See Also

NpcDB Class
wManager.Wow.Helpers Namespace


AddNpc Method

NpcDB..::..AddNpc Method

Add NPC to ListNpc.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void AddNpc(
    Npc npc,
    bool save,
    bool currentProfileNpc
)
Public Shared Sub AddNpc ( _
    npc As Npc, _
    save As Boolean, _
    currentProfileNpc As Boolean _
)
public:
static void AddNpc(
    Npc^ npc,
    bool^ save,
    bool^ currentProfileNpc
)

Parameters

npc
Type: wManager.Wow.Class..::..Npc
The NPC to.
save
Type: Boolean
if set to true save to npcdb file for future bot usage.
currentProfileNpc
Type: Boolean
if set to true it is profile NPC (used by option AcceptOnlyProfileNpc).

See Also

NpcDB Class
wManager.Wow.Helpers Namespace


AddNpcRange Method

NpcDB..::..AddNpcRange Method

Add several NPCs to ListNpc.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void AddNpcRange(
    List<Npc> npcList,
    bool save,
    bool currentProfileNpc
)
Public Shared Sub AddNpcRange ( _
    npcList As List(Of Npc), _
    save As Boolean, _
    currentProfileNpc As Boolean _
)
public:
static void AddNpcRange(
    List<Npc^>^ npcList,
    bool^ save,
    bool^ currentProfileNpc
)

Parameters

npcList
Type: List <(Of <(<' Npc >)>)>
The NPCs list.
save
Type: Boolean
if set to true save to npcdb file for future bot usage.
currentProfileNpc
Type: Boolean
if set to true it is profile NPCs (used by option AcceptOnlyProfileNpc).

See Also

NpcDB Class
wManager.Wow.Helpers Namespace


GetNpcNearby Method

NpcDB..::..GetNpcNearby Method

Overload List

Name | Description
GetNpcNearby(Npc..::..NpcType) | Get closest NPC by type.
GetNpcNearby(Npc..::..NpcType, Npc..::..NpcVendorItemClass) | Get closest NPC by type.
GetNpcNearby(Npc..::..NpcType, Npc..::..FactionType, ContinentId, Vector3, Boolean, Npc..::..NpcVendorItemClass) | Get closest NPC by type.

See Also

NpcDB Class
NpcDB Members
wManager.Wow.Helpers Namespace


GetNpcNearby Method (NpcType)

NpcDB..::..GetNpcNearby Method (NpcType)

Get closest NPC by type.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static Npc GetNpcNearby(
    Npc..::..NpcType type
)
Public Shared Function GetNpcNearby ( _
    type As Npc..::..NpcType _
) As Npc
public:
static Npc^ GetNpcNearby(
    Npc..::..NpcType^ type
)

Parameters

type
Type: wManager.Wow.Class..::..Npc..::..NpcType
The Npc type.

Return Value

Npc.

See Also

NpcDB Class
GetNpcNearby Overload
wManager.Wow.Helpers Namespace


GetNpcNearby Method (NpcType, NpcVendorItemClass)

NpcDB..::..GetNpcNearby Method (NpcType, NpcVendorItemClass)

Get closest NPC by type.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static Npc GetNpcNearby(
    Npc..::..NpcType type,
    Npc..::..NpcVendorItemClass npcVendorItemClass
)
Public Shared Function GetNpcNearby ( _
    type As Npc..::..NpcType, _
    npcVendorItemClass As Npc..::..NpcVendorItemClass _
) As Npc
public:
static Npc^ GetNpcNearby(
    Npc..::..NpcType^ type,
    Npc..::..NpcVendorItemClass^ npcVendorItemClass
)

Parameters

type
Type: wManager.Wow.Class..::..Npc..::..NpcType
The Npc type.
npcVendorItemClass
Type: wManager.Wow.Class..::..Npc..::..NpcVendorItemClass
The NPC vendor item class.

Return Value

Npc.

See Also

NpcDB Class
GetNpcNearby Overload
wManager.Wow.Helpers Namespace


GetNpcNearby Method (NpcType, FactionType, ContinentId, Vector3, Boolean, NpcVendorItemClass)

NpcDB..::..GetNpcNearby Method (NpcType, FactionType, ContinentId, Vector3, Boolean, NpcVendorItemClass)

Get closest NPC by type.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static Npc GetNpcNearby(
    Npc..::..NpcType type,
    Npc..::..FactionType faction,
    ContinentId continentId,
    Vector3 currentPosition,
    bool forceFlying,
    Npc..::..NpcVendorItemClass npcVendorItemClass
)
Public Shared Function GetNpcNearby ( _
    type As Npc..::..NpcType, _
    faction As Npc..::..FactionType, _
    continentId As ContinentId, _
    currentPosition As Vector3, _
    forceFlying As Boolean, _
    npcVendorItemClass As Npc..::..NpcVendorItemClass _
) As Npc
public:
static Npc^ GetNpcNearby(
    Npc..::..NpcType^ type,
    Npc..::..FactionType^ faction,
    ContinentId^ continentId,
    Vector3^ currentPosition,
    bool^ forceFlying,
    Npc..::..NpcVendorItemClass^ npcVendorItemClass
)

Parameters

type
Type: wManager.Wow.Class..::..Npc..::..NpcType
The type.
faction
Type: wManager.Wow.Class..::..Npc..::..FactionType
The faction.
continentId
Type: wManager.Wow.Enums..::..ContinentId
The continent id.
currentPosition
Type: robotManager.Helpful..::..Vector3
The current position.
forceFlying
Type: Boolean
if set to true select only NPCs with CanFlyTo enabled.
npcVendorItemClass
Type: wManager.Wow.Class..::..Npc..::..NpcVendorItemClass
The NPC vendor item class.

Return Value

Npc.

See Also

NpcDB Class
GetNpcNearby Overload
wManager.Wow.Helpers Namespace


NpcSimilarExist Method

NpcDB..::..NpcSimilarExist Method

Similar NPC exist.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool NpcSimilarExist(
    ContinentId continentId,
    int entryId,
    Vector3 position,
    Npc..::..FactionType faction
)
Public Shared Function NpcSimilarExist ( _
    continentId As ContinentId, _
    entryId As Integer, _
    position As Vector3, _
    faction As Npc..::..FactionType _
) As Boolean
public:
static bool^ NpcSimilarExist(
    ContinentId^ continentId,
    int^ entryId,
    Vector3^ position,
    Npc..::..FactionType^ faction
)

Parameters

continentId
Type: wManager.Wow.Enums..::..ContinentId
The continent id.
entryId
Type: Int32
The npc entry id.
position
Type: robotManager.Helpful..::..Vector3
The position.
faction
Type: wManager.Wow.Class..::..Npc..::..FactionType
The faction.

Return Value

true if already exist in DB, false otherwise.

See Also

NpcDB Class
wManager.Wow.Helpers Namespace


Save Method

NpcDB..::..Save Method

Save to file.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void Save()
Public Shared Sub Save
public:
static void Save()

See Also

NpcDB Class
wManager.Wow.Helpers Namespace


NpcDB Properties

The NpcDB type exposes the following members.

Properties

Name | Description
ListNpc | Get or set the NPCs list (it is better to use AddNpc(Npc, Boolean, Boolean) or AddNpcRange(List<(Of <<'(Npc>)>>), Boolean, Boolean) to add NPC).

See Also

NpcDB Class
wManager.Wow.Helpers Namespace


ListNpc Property

NpcDB..::..ListNpc Property

Get or set the NPCs list (it is better to use AddNpc(Npc, Boolean, Boolean) or AddNpcRange(List<(Of <<'(Npc>)>>), Boolean, Boolean) to add NPC).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<Npc> ListNpc { get; set; }
Public Shared Property ListNpc As List(Of Npc)
    Get
    Set
public:
static property List<Npc^>^ ListNpc {
    List<Npc^>^ get ();
    void set (List<Npc^>^ value);
}

Field Value

The list NPC.

See Also

NpcDB Class
wManager.Wow.Helpers Namespace


Party Class

Class Party. Useful methods for group of characters (party and raid)

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class Party
Public NotInheritable Class Party
public ref class Party abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..Party

See Also

Party Members
wManager.Wow.Helpers Namespace


Party Members

The Party type exposes the following members.

Methods

Name | Description
CurrentPlayerIsLeader | Current player is leader.
GetMember1GUID | Get group member 1 GUID.
GetMember2GUID | Get group member 2 GUID.
GetMember3GUID | Get group member 3 GUID.
GetMember4GUID | Get group member 4 GUID.
GetParty |
GetPartyGUID | Get group GUIDs.
GetPartyGUIDHomeAndInstance | Gets the group GUIDs (party and raid).
GetPartyHomeAndInstance | Get players objects (party and raid).
GetPartyLeaderGUID | Get group leader GUID.
GetPartyLeaderGUIDHomeAndInstance | Get party leader GUID (party and raid).
GetPartyNumberPlayers | Get group members count.
GetRaidMemberCount |
GetRaidMemberGUID |
GetRaidMembers |
GetRaidMembersGuid |
IsInGroup | Determines whether character is in group (party and raid).
IsInGroupHome | Determines whether is in party group.
IsInGroupInstance | Determines whether is in raid group.

See Also

Party Class
wManager.Wow.Helpers Namespace


Party Methods

The Party type exposes the following members.

Methods

Name | Description
CurrentPlayerIsLeader | Current player is leader.
GetMember1GUID | Get group member 1 GUID.
GetMember2GUID | Get group member 2 GUID.
GetMember3GUID | Get group member 3 GUID.
GetMember4GUID | Get group member 4 GUID.
GetParty |
GetPartyGUID | Get group GUIDs.
GetPartyGUIDHomeAndInstance | Gets the group GUIDs (party and raid).
GetPartyHomeAndInstance | Get players objects (party and raid).
GetPartyLeaderGUID | Get group leader GUID.
GetPartyLeaderGUIDHomeAndInstance | Get party leader GUID (party and raid).
GetPartyNumberPlayers | Get group members count.
GetRaidMemberCount |
GetRaidMemberGUID |
GetRaidMembers |
GetRaidMembersGuid |
IsInGroup | Determines whether character is in group (party and raid).
IsInGroupHome | Determines whether is in party group.
IsInGroupInstance | Determines whether is in raid group.

See Also

Party Class
wManager.Wow.Helpers Namespace


CurrentPlayerIsLeader Method

Party..::..CurrentPlayerIsLeader Method

Current player is leader.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool CurrentPlayerIsLeader()
Public Shared Function CurrentPlayerIsLeader As Boolean
public:
static bool^ CurrentPlayerIsLeader()

Return Value

true if character is leader, false otherwise.

See Also

Party Class
wManager.Wow.Helpers Namespace


GetMember1GUID Method

Party..::..GetMember1GUID Method

Get group member 1 GUID.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static ulong GetMember1GUID()
Public Shared Function GetMember1GUID As ULong
public:
static unsigned long long^ GetMember1GUID()

See Also

Party Class
wManager.Wow.Helpers Namespace


GetMember2GUID Method

Party..::..GetMember2GUID Method

Get group member 2 GUID.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static ulong GetMember2GUID()
Public Shared Function GetMember2GUID As ULong
public:
static unsigned long long^ GetMember2GUID()

See Also

Party Class
wManager.Wow.Helpers Namespace


GetMember3GUID Method

Party..::..GetMember3GUID Method

Get group member 3 GUID.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static ulong GetMember3GUID()
Public Shared Function GetMember3GUID As ULong
public:
static unsigned long long^ GetMember3GUID()

See Also

Party Class
wManager.Wow.Helpers Namespace


GetMember4GUID Method

Party..::..GetMember4GUID Method

Get group member 4 GUID.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static ulong GetMember4GUID()
Public Shared Function GetMember4GUID As ULong
public:
static unsigned long long^ GetMember4GUID()

See Also

Party Class
wManager.Wow.Helpers Namespace


GetParty Method

Party..::..GetParty Method

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWPlayer> GetParty()
Public Shared Function GetParty As List(Of WoWPlayer)
public:
static List<WoWPlayer^>^ GetParty()

See Also

Party Class
wManager.Wow.Helpers Namespace


GetPartyGUID Method

Party..::..GetPartyGUID Method

Get group GUIDs.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<ulong> GetPartyGUID()
Public Shared Function GetPartyGUID As List(Of ULong)
public:
static List<unsigned long long^>^ GetPartyGUID()

See Also

Party Class
wManager.Wow.Helpers Namespace


GetPartyGUIDHomeAndInstance Method

Party..::..GetPartyGUIDHomeAndInstance Method

Gets the group GUIDs (party and raid).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<ulong> GetPartyGUIDHomeAndInstance()
Public Shared Function GetPartyGUIDHomeAndInstance As List(Of ULong)
public:
static List<unsigned long long^>^ GetPartyGUIDHomeAndInstance()

Return Value

List<Int128>.

See Also

Party Class
wManager.Wow.Helpers Namespace


GetPartyHomeAndInstance Method

Party..::..GetPartyHomeAndInstance Method

Get players objects (party and raid).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWPlayer> GetPartyHomeAndInstance()
Public Shared Function GetPartyHomeAndInstance As List(Of WoWPlayer)
public:
static List<WoWPlayer^>^ GetPartyHomeAndInstance()

Return Value

List<WoWPlayer>.

See Also

Party Class
wManager.Wow.Helpers Namespace


GetPartyLeaderGUID Method

Party..::..GetPartyLeaderGUID Method

Get group leader GUID.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static ulong GetPartyLeaderGUID()
Public Shared Function GetPartyLeaderGUID As ULong
public:
static unsigned long long^ GetPartyLeaderGUID()

See Also

Party Class
wManager.Wow.Helpers Namespace


GetPartyLeaderGUIDHomeAndInstance Method

Party..::..GetPartyLeaderGUIDHomeAndInstance Method

Get party leader GUID (party and raid).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static ulong GetPartyLeaderGUIDHomeAndInstance()
Public Shared Function GetPartyLeaderGUIDHomeAndInstance As ULong
public:
static unsigned long long^ GetPartyLeaderGUIDHomeAndInstance()

Return Value

Int128.

See Also

Party Class
wManager.Wow.Helpers Namespace


GetPartyNumberPlayers Method

Party..::..GetPartyNumberPlayers Method

Get group members count.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static uint GetPartyNumberPlayers()
Public Shared Function GetPartyNumberPlayers As UInteger
public:
static unsigned int^ GetPartyNumberPlayers()

Return Value

System.UInt32.

See Also

Party Class
wManager.Wow.Helpers Namespace


GetRaidMemberCount Method

Party..::..GetRaidMemberCount Method

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int GetRaidMemberCount()
Public Shared Function GetRaidMemberCount As Integer
public:
static int^ GetRaidMemberCount()

See Also

Party Class
wManager.Wow.Helpers Namespace


GetRaidMemberGUID Method

Party..::..GetRaidMemberGUID Method

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static ulong GetRaidMemberGUID(
    int num
)
Public Shared Function GetRaidMemberGUID ( _
    num As Integer _
) As ULong
public:
static unsigned long long^ GetRaidMemberGUID(
    int^ num
)

Parameters

num
Type: Int32

See Also

Party Class
wManager.Wow.Helpers Namespace


GetRaidMembers Method

Party..::..GetRaidMembers Method

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWPlayer> GetRaidMembers()
Public Shared Function GetRaidMembers As List(Of WoWPlayer)
public:
static List<WoWPlayer^>^ GetRaidMembers()

See Also

Party Class
wManager.Wow.Helpers Namespace


GetRaidMembersGuid Method

Party..::..GetRaidMembersGuid Method

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<ulong> GetRaidMembersGuid()
Public Shared Function GetRaidMembersGuid As List(Of ULong)
public:
static List<unsigned long long^>^ GetRaidMembersGuid()

See Also

Party Class
wManager.Wow.Helpers Namespace


IsInGroup Method

Party..::..IsInGroup Method

Determines whether character is in group (party and raid).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool IsInGroup()
Public Shared Function IsInGroup As Boolean
public:
static bool^ IsInGroup()

Return Value

true if is in group; otherwise, false.

See Also

Party Class
wManager.Wow.Helpers Namespace


IsInGroupHome Method

Party..::..IsInGroupHome Method

Determines whether is in party group.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool IsInGroupHome()
Public Shared Function IsInGroupHome As Boolean
public:
static bool^ IsInGroupHome()

Return Value

true if is in party; otherwise, false.

See Also

Party Class
wManager.Wow.Helpers Namespace


IsInGroupInstance Method

Party..::..IsInGroupInstance Method

Determines whether is in raid group.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool IsInGroupInstance()
Public Shared Function IsInGroupInstance As Boolean
public:
static bool^ IsInGroupInstance()

Return Value

true if is in raid; otherwise, false.

See Also

Party Class
wManager.Wow.Helpers Namespace


PathFinder Class

Path Generator Class. Use this class to find path.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class PathFinder
Public NotInheritable Class PathFinder
public ref class PathFinder abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..PathFinder

See Also

PathFinder Members
wManager.Wow.Helpers Namespace


PathFinder Members

The PathFinder type exposes the following members.

Methods

Name | Description
FindPath(Vector3) | Find path.
FindPath(Vector3, Boolean) | Find path.
FindPath(Vector3, Vector3) | Find path.
FindPath(Vector3, Vector3, Boolean) | Find path.
FindPath(Vector3, Boolean%) | Find path.
FindPath(Vector3, Boolean%, Boolean) | Find path.
FindPath(Vector3, Boolean%, Boolean, Boolean) | Find path.
FindPath(Vector3, Vector3, String, Boolean) | Find path.
FindPath(Vector3, Vector3, Boolean%, Boolean) | Find path.
FindPath(Vector3, Vector3, String, Boolean%, Boolean, Boolean, Boolean, Boolean) | Find path.
GetZPosition | Get position Z.
InitPather()()()() | Initialize the pather (with current continent).
InitPather(String) | Initialize the pather.
ReportArea | Report the area.
ReportBigDangerArea | Reports the big danger area (POLYAREA_BIGDANGER()()()()).
ReportDangerArea | Report danger area (POLYAREA_DANGER()()()()).
ReportNormalArea | Report the normal area (POLYAREA_GROUND()()()()).
ResetArea | Reset area to POLYAREA_GROUND()()()() by position and type.
ResetAreaByType | Reset area to POLYAREA_GROUND()()()() by type.
SmoothPath | Smooth the path.

Properties

Name | Description
Pather | Get the pather.
UsePatherFind | Enable or disable path finder.
UsePathFinderServer | Get a value indicating whether use path finder from server.

See Also

PathFinder Class
wManager.Wow.Helpers Namespace


PathFinder Methods

The PathFinder type exposes the following members.

Methods

Name | Description
FindPath(Vector3) | Find path.
FindPath(Vector3, Boolean) | Find path.
FindPath(Vector3, Vector3) | Find path.
FindPath(Vector3, Vector3, Boolean) | Find path.
FindPath(Vector3, Boolean%) | Find path.
FindPath(Vector3, Boolean%, Boolean) | Find path.
FindPath(Vector3, Boolean%, Boolean, Boolean) | Find path.
FindPath(Vector3, Vector3, String, Boolean) | Find path.
FindPath(Vector3, Vector3, Boolean%, Boolean) | Find path.
FindPath(Vector3, Vector3, String, Boolean%, Boolean, Boolean, Boolean, Boolean) | Find path.
GetZPosition | Get position Z.
InitPather()()()() | Initialize the pather (with current continent).
InitPather(String) | Initialize the pather.
ReportArea | Report the area.
ReportBigDangerArea | Reports the big danger area (POLYAREA_BIGDANGER()()()()).
ReportDangerArea | Report danger area (POLYAREA_DANGER()()()()).
ReportNormalArea | Report the normal area (POLYAREA_GROUND()()()()).
ResetArea | Reset area to POLYAREA_GROUND()()()() by position and type.
ResetAreaByType | Reset area to POLYAREA_GROUND()()()() by type.
SmoothPath | Smooth the path.

See Also

PathFinder Class
wManager.Wow.Helpers Namespace


FindPath Method

PathFinder..::..FindPath Method

Overload List

Name | Description
FindPath(Vector3) | Find path.
FindPath(Vector3, Boolean) | Find path.
FindPath(Vector3, Vector3) | Find path.
FindPath(Vector3, Vector3, Boolean) | Find path.
FindPath(Vector3, Boolean%) | Find path.
FindPath(Vector3, Boolean%, Boolean) | Find path.
FindPath(Vector3, Boolean%, Boolean, Boolean) | Find path.
FindPath(Vector3, Vector3, String, Boolean) | Find path.
FindPath(Vector3, Vector3, Boolean%, Boolean) | Find path.
FindPath(Vector3, Vector3, String, Boolean%, Boolean, Boolean, Boolean, Boolean) | Find path.

See Also

PathFinder Class
PathFinder Members
wManager.Wow.Helpers Namespace


FindPath Method (Vector3)

PathFinder..::..FindPath Method (Vector3)

Find path.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<Vector3> FindPath(
    Vector3 to
)
Public Shared Function FindPath ( _
    to As Vector3 _
) As List(Of Vector3)
public:
static List<Vector3^>^ FindPath(
    Vector3^ to
)

Parameters

to
Type: robotManager.Helpful..::..Vector3
destination position.

Return Value

path.

See Also

PathFinder Class
FindPath Overload
wManager.Wow.Helpers Namespace


FindPath Method (Vector3, Boolean)

PathFinder..::..FindPath Method (Vector3, Boolean)

Find path.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<Vector3> FindPath(
    Vector3 to,
    bool skipIfPartiel
)
Public Shared Function FindPath ( _
    to As Vector3, _
    skipIfPartiel As Boolean _
) As List(Of Vector3)
public:
static List<Vector3^>^ FindPath(
    Vector3^ to,
    bool^ skipIfPartiel
)

Parameters

to
Type: robotManager.Helpful..::..Vector3
destination position.
skipIfPartiel
Type: Boolean
if set to true skip if partial (don't try to resolve path with offmeshconnetions).

Return Value

path.

See Also

PathFinder Class
FindPath Overload
wManager.Wow.Helpers Namespace


FindPath Method (Vector3, Vector3)

PathFinder..::..FindPath Method (Vector3, Vector3)

Find path.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<Vector3> FindPath(
    Vector3 from,
    Vector3 to
)
Public Shared Function FindPath ( _
    from As Vector3, _
    to As Vector3 _
) As List(Of Vector3)
public:
static List<Vector3^>^ FindPath(
    Vector3^ from,
    Vector3^ to
)

Parameters

from
Type: robotManager.Helpful..::..Vector3
to
Type: robotManager.Helpful..::..Vector3
Starting position.destination position.

Return Value

path.

See Also

PathFinder Class
FindPath Overload
wManager.Wow.Helpers Namespace


FindPath Method (Vector3, Vector3, Boolean)

PathFinder..::..FindPath Method (Vector3, Vector3, Boolean)

Find path.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<Vector3> FindPath(
    Vector3 from,
    Vector3 to,
    bool skipIfPartiel
)
Public Shared Function FindPath ( _
    from As Vector3, _
    to As Vector3, _
    skipIfPartiel As Boolean _
) As List(Of Vector3)
public:
static List<Vector3^>^ FindPath(
    Vector3^ from,
    Vector3^ to,
    bool^ skipIfPartiel
)

Parameters

from
Type: robotManager.Helpful..::..Vector3
to
Type: robotManager.Helpful..::..Vector3
Starting position.destination position.
skipIfPartiel
Type: Boolean
if set to true skip if partial (don't try to resolve path with offmeshconnetions).

Return Value

path.

See Also

PathFinder Class
FindPath Overload
wManager.Wow.Helpers Namespace


FindPath Method (Vector3, Boolean)

PathFinder..::..FindPath Method (Vector3, Boolean%)

Find path.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<Vector3> FindPath(
    Vector3 to,
    out bool resultSuccess
)
Public Shared Function FindPath ( _
    to As Vector3, _
    <OutAttribute> ByRef resultSuccess As Boolean _
) As List(Of Vector3)
public:
static List<Vector3^>^ FindPath(
    Vector3^ to,
    [OutAttribute] bool^% resultSuccess
)

Parameters

to
Type: robotManager.Helpful..::..Vector3
destination position.
resultSuccess
Type: Boolean %
if set to true success.

Return Value

path.

See Also

PathFinder Class
FindPath Overload
wManager.Wow.Helpers Namespace


FindPath Method (Vector3, Boolean, Boolean)

PathFinder..::..FindPath Method (Vector3, Boolean%, Boolean)

Find path.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<Vector3> FindPath(
    Vector3 to,
    out bool resultSuccess,
    bool skipIfPartiel
)
Public Shared Function FindPath ( _
    to As Vector3, _
    <OutAttribute> ByRef resultSuccess As Boolean, _
    skipIfPartiel As Boolean _
) As List(Of Vector3)
public:
static List<Vector3^>^ FindPath(
    Vector3^ to,
    [OutAttribute] bool^% resultSuccess,
    bool^ skipIfPartiel
)

Parameters

to
Type: robotManager.Helpful..::..Vector3
destination position.
resultSuccess
Type: Boolean %
if set to true success.
skipIfPartiel
Type: Boolean
if set to true skip if partial (don't try to resolve path with offmeshconnetions).

Return Value

path.

See Also

PathFinder Class
FindPath Overload
wManager.Wow.Helpers Namespace


FindPath Method (Vector3, Boolean, Boolean, Boolean)

PathFinder..::..FindPath Method (Vector3, Boolean%, Boolean, Boolean)

Find path.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<Vector3> FindPath(
    Vector3 to,
    out bool resultSuccess,
    bool skipIfPartiel,
    bool ignoreServerRoadsWater
)
Public Shared Function FindPath ( _
    to As Vector3, _
    <OutAttribute> ByRef resultSuccess As Boolean, _
    skipIfPartiel As Boolean, _
    ignoreServerRoadsWater As Boolean _
) As List(Of Vector3)
public:
static List<Vector3^>^ FindPath(
    Vector3^ to,
    [OutAttribute] bool^% resultSuccess,
    bool^ skipIfPartiel,
    bool^ ignoreServerRoadsWater
)

Parameters

to
Type: robotManager.Helpful..::..Vector3
destination position.
resultSuccess
Type: Boolean %
if set to true success.
skipIfPartiel
Type: Boolean
if set to true skip if partial (don't try to resolve path with offmeshconnetions).
ignoreServerRoadsWater
Type: Boolean
if set to true [ignore server roads water].

Return Value

path.

See Also

PathFinder Class
FindPath Overload
wManager.Wow.Helpers Namespace


FindPath Method (Vector3, Vector3, String, Boolean)

PathFinder..::..FindPath Method (Vector3, Vector3, String, Boolean)

Find path.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<Vector3> FindPath(
    Vector3 from,
    Vector3 to,
    string continentNameMpq,
    bool skipIfPartiel
)
Public Shared Function FindPath ( _
    from As Vector3, _
    to As Vector3, _
    continentNameMpq As String, _
    skipIfPartiel As Boolean _
) As List(Of Vector3)
public:
static List<Vector3^>^ FindPath(
    Vector3^ from,
    Vector3^ to,
    String^ continentNameMpq,
    bool^ skipIfPartiel
)

Parameters

from
Type: robotManager.Helpful..::..Vector3
to
Type: robotManager.Helpful..::..Vector3
Starting position.destination position.
continentNameMpq
Type: String
The continent name (file name like ContinentNameMpq).
skipIfPartiel
Type: Boolean
if set to true skip if partial (don't try to resolve path with offmeshconnetions).

Return Value

path.

See Also

PathFinder Class
FindPath Overload
wManager.Wow.Helpers Namespace


FindPath Method (Vector3, Vector3, Boolean, Boolean)

PathFinder..::..FindPath Method (Vector3, Vector3, Boolean%, Boolean)

Find path.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<Vector3> FindPath(
    Vector3 from,
    Vector3 to,
    out bool resultSuccess,
    bool skipIfPartiel
)
Public Shared Function FindPath ( _
    from As Vector3, _
    to As Vector3, _
    <OutAttribute> ByRef resultSuccess As Boolean, _
    skipIfPartiel As Boolean _
) As List(Of Vector3)
public:
static List<Vector3^>^ FindPath(
    Vector3^ from,
    Vector3^ to,
    [OutAttribute] bool^% resultSuccess,
    bool^ skipIfPartiel
)

Parameters

from
Type: robotManager.Helpful..::..Vector3
to
Type: robotManager.Helpful..::..Vector3
Starting position.destination position.
resultSuccess
Type: Boolean %
if set to true success.
skipIfPartiel
Type: Boolean
if set to true skip if partial (don't try to resolve path with offmeshconnetions).

Return Value

path.

See Also

PathFinder Class
FindPath Overload
wManager.Wow.Helpers Namespace


FindPath Method (Vector3, Vector3, String, Boolean, Boolean, Boolean, Boolean, Boolean)

PathFinder..::..FindPath Method (Vector3, Vector3, String, Boolean%, Boolean, Boolean, Boolean, Boolean)

Find path.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<Vector3> FindPath(
    Vector3 from,
    Vector3 to,
    string continentNameMpq,
    out bool resultSuccess,
    bool addFromAndStart,
    bool loadAllTile,
    bool skipIfPartiel,
    bool ignoreServerRoadsWater
)
Public Shared Function FindPath ( _
    from As Vector3, _
    to As Vector3, _
    continentNameMpq As String, _
    <OutAttribute> ByRef resultSuccess As Boolean, _
    addFromAndStart As Boolean, _
    loadAllTile As Boolean, _
    skipIfPartiel As Boolean, _
    ignoreServerRoadsWater As Boolean _
) As List(Of Vector3)
public:
static List<Vector3^>^ FindPath(
    Vector3^ from,
    Vector3^ to,
    String^ continentNameMpq,
    [OutAttribute] bool^% resultSuccess,
    bool^ addFromAndStart,
    bool^ loadAllTile,
    bool^ skipIfPartiel,
    bool^ ignoreServerRoadsWater
)

Parameters

from
Type: robotManager.Helpful..::..Vector3
to
Type: robotManager.Helpful..::..Vector3
Starting position.destination position.
continentNameMpq
Type: String
The continent name (file name like ContinentNameMpq).
resultSuccess
Type: Boolean %
if set to true success.
addFromAndStart
Type: Boolean
if set to true [add from and start].
loadAllTile
Type: Boolean
if set to true [load all tile].
skipIfPartiel
Type: Boolean
if set to true skip if partial (don't try to resolve path with offmeshconnetions).
ignoreServerRoadsWater
Type: Boolean
if set to true [ignore server roads water].

Return Value

path.

See Also

PathFinder Class
FindPath Overload
wManager.Wow.Helpers Namespace


GetZPosition Method

PathFinder..::..GetZPosition Method

Get position Z.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static float GetZPosition(
    Vector3 point,
    bool strict
)
Public Shared Function GetZPosition ( _
    point As Vector3, _
    strict As Boolean _
) As Single
public:
static float^ GetZPosition(
    Vector3^ point,
    bool^ strict
)

Parameters

point
Type: robotManager.Helpful..::..Vector3
Position where get height.
strict
Type: Boolean
if set to true the pathfinder will be strict, if set to false if pathfinder don't found Z position of specified X,Y position he will look for the Z position of a near X,Y position.

Return Value

position Z.

See Also

PathFinder Class
wManager.Wow.Helpers Namespace


InitPather Method

PathFinder..::..InitPather Method

Overload List

Name | Description
InitPather()()()() | Initialize the pather (with current continent).
InitPather(String) | Initialize the pather.

See Also

PathFinder Class
PathFinder Members
wManager.Wow.Helpers Namespace


InitPather Method

PathFinder..::..InitPather Method

Initialize the pather (with current continent).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void InitPather()
Public Shared Sub InitPather
public:
static void InitPather()

See Also

PathFinder Class
InitPather Overload
wManager.Wow.Helpers Namespace


InitPather Method (String)

PathFinder..::..InitPather Method (String)

Initialize the pather.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void InitPather(
    string continentNameMpq
)
Public Shared Sub InitPather ( _
    continentNameMpq As String _
)
public:
static void InitPather(
    String^ continentNameMpq
)

Parameters

continentNameMpq
Type: String
The continent name (ContinentNameMpq).

See Also

PathFinder Class
InitPather Overload
wManager.Wow.Helpers Namespace


ReportArea Method

PathFinder..::..ReportArea Method

Report the area.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool ReportArea(
    Vector3 position,
    float radius,
    PolyArea areaType,
    bool addToList
)
Public Shared Function ReportArea ( _
    position As Vector3, _
    radius As Single, _
    areaType As PolyArea, _
    addToList As Boolean _
) As Boolean
public:
static bool^ ReportArea(
    Vector3^ position,
    float^ radius,
    PolyArea^ areaType,
    bool^ addToList
)

Parameters

position
Type: robotManager.Helpful..::..Vector3
The position.
radius
Type: Single
The radius.
areaType
Type: PolyArea
Type of the area.
addToList
Type: Boolean
if set to true add to list (AddAreaToList(ReportAreaStruct)).

Return Value

true if added, false otherwise.

See Also

PathFinder Class
wManager.Wow.Helpers Namespace


ReportBigDangerArea Method

PathFinder..::..ReportBigDangerArea Method

Reports the big danger area (POLYAREA_BIGDANGER()()()()).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool ReportBigDangerArea(
    Vector3 position,
    float radius
)
Public Shared Function ReportBigDangerArea ( _
    position As Vector3, _
    radius As Single _
) As Boolean
public:
static bool^ ReportBigDangerArea(
    Vector3^ position,
    float^ radius
)

Parameters

position
Type: robotManager.Helpful..::..Vector3
The position.
radius
Type: Single
The radius.

Return Value

true if added, false otherwise.

See Also

PathFinder Class
wManager.Wow.Helpers Namespace


ReportDangerArea Method

PathFinder..::..ReportDangerArea Method

Report danger area (POLYAREA_DANGER()()()()).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool ReportDangerArea(
    Vector3 position,
    float radius
)
Public Shared Function ReportDangerArea ( _
    position As Vector3, _
    radius As Single _
) As Boolean
public:
static bool^ ReportDangerArea(
    Vector3^ position,
    float^ radius
)

Parameters

position
Type: robotManager.Helpful..::..Vector3
The position.
radius
Type: Single
The radius.

Return Value

true if added, false otherwise.

See Also

PathFinder Class
wManager.Wow.Helpers Namespace


ReportNormalArea Method

PathFinder..::..ReportNormalArea Method

Report the normal area (POLYAREA_GROUND()()()()).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool ReportNormalArea(
    Vector3 position,
    float radius
)
Public Shared Function ReportNormalArea ( _
    position As Vector3, _
    radius As Single _
) As Boolean
public:
static bool^ ReportNormalArea(
    Vector3^ position,
    float^ radius
)

Parameters

position
Type: robotManager.Helpful..::..Vector3
The position.
radius
Type: Single
The radius.

Return Value

true if added, false otherwise.

See Also

PathFinder Class
wManager.Wow.Helpers Namespace


ResetArea Method

PathFinder..::..ResetArea Method

Reset area to POLYAREA_GROUND()()()() by position and type.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void ResetArea(
    Vector3 position,
    float radius,
    PolyArea areaType
)
Public Shared Sub ResetArea ( _
    position As Vector3, _
    radius As Single, _
    areaType As PolyArea _
)
public:
static void ResetArea(
    Vector3^ position,
    float^ radius,
    PolyArea^ areaType
)

Parameters

position
Type: robotManager.Helpful..::..Vector3
The position.
radius
Type: Single
The radius.
areaType
Type: PolyArea
Type of area.

See Also

PathFinder Class
wManager.Wow.Helpers Namespace


ResetAreaByType Method

PathFinder..::..ResetAreaByType Method

Reset area to POLYAREA_GROUND()()()() by type.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void ResetAreaByType(
    PolyArea areaType
)
Public Shared Sub ResetAreaByType ( _
    areaType As PolyArea _
)
public:
static void ResetAreaByType(
    PolyArea^ areaType
)

Parameters

areaType
Type: PolyArea
Type to reset.

See Also

PathFinder Class
wManager.Wow.Helpers Namespace


SmoothPath Method

PathFinder..::..SmoothPath Method

Smooth the path.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<Vector3> SmoothPath(
    List<Vector3> path,
    float smoothPathDistance
)
Public Shared Function SmoothPath ( _
    path As List(Of Vector3), _
    smoothPathDistance As Single _
) As List(Of Vector3)
public:
static List<Vector3^>^ SmoothPath(
    List<Vector3^>^ path,
    float^ smoothPathDistance
)

Parameters

path
Type: List <(Of <(<' Vector3 >)>)>
The path.
smoothPathDistance
Type: Single
The smooth path distance.

Return Value

path.

See Also

PathFinder Class
wManager.Wow.Helpers Namespace


PathFinder Properties

The PathFinder type exposes the following members.

Properties

Name | Description
Pather | Get the pather.
UsePatherFind | Enable or disable path finder.
UsePathFinderServer | Get a value indicating whether use path finder from server.

See Also

PathFinder Class
wManager.Wow.Helpers Namespace


Pather Property

PathFinder..::..Pather Property

Get the pather.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static Pather Pather { get; }
Public Shared ReadOnly Property Pather As Pather
    Get
public:
static property Pather^ Pather {
    Pather^ get ();
}

Field Value

The pather.

See Also

PathFinder Class
wManager.Wow.Helpers Namespace


UsePatherFind Property

PathFinder..::..UsePatherFind Property

Enable or disable path finder.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool UsePatherFind { get; }
Public Shared ReadOnly Property UsePatherFind As Boolean
    Get
public:
static property bool^ UsePatherFind {
    bool^ get ();
}

Field Value

true if use pather finder; otherwise, false .

See Also

PathFinder Class
wManager.Wow.Helpers Namespace


UsePathFinderServer Property

PathFinder..::..UsePathFinderServer Property

Get a value indicating whether use path finder from server.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool UsePathFinderServer { get; }
Public Shared ReadOnly Property UsePathFinderServer As Boolean
    Get
public:
static property bool^ UsePathFinderServer {
    bool^ get ();
}

Field Value

true if use path finder from server; otherwise, false.

See Also

PathFinder Class
wManager.Wow.Helpers Namespace


PathFinder.OffMeshConnection Class

PathFinder..::..OffMeshConnection Class

Class OffMeshConnection. (sees PathFinder..::..OffMeshConnections and https://wrobot.eu/forums/topic/5283-offmesh-connections/ )

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class OffMeshConnection
<SerializableAttribute> _
Public Class OffMeshConnection
[SerializableAttribute]
public ref class OffMeshConnection

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..PathFinder..::..OffMeshConnection

See Also

PathFinder..::..OffMeshConnection Members
wManager.Wow.Helpers Namespace


PathFinder.OffMeshConnection Members

PathFinder..::..OffMeshConnection Members

The PathFinder..::..OffMeshConnection type exposes the following members.

Constructors

 | Name | Description
Public method | PathFinder..::..OffMeshConnection()()()() | Initializes a new instance of the PathFinder..::..OffMeshConnection class.
Public method | PathFinder..::..OffMeshConnection(List<(Of <<'(Vector3>)>>), Int32) | Initialize a new instance of the PathFinder..::..OffMeshConnection class.
Public method | PathFinder..::..OffMeshConnection(List<(Of <<'(Vector3>)>>), Int32, PathFinder..::..OffMeshConnectionType, Boolean) | Initialize a new instance of the PathFinder..::..OffMeshConnection class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IsSame | Determines whether the specified o is same.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance.

Properties

 | Name | Description
Public property | ContinentId | Get or set the continent id (-1 to use on all continents).
Public property | Name | Get or set the name (description).
Public property | Path | Get or set the path.
Public property | TryToUseEvenIfCanFindPathSuccess | If true try to use even if can find path success (and use this if path distance is smaller with), use this option if you know what you are doing.
Public property | Type | Get or set the type.

See Also

PathFinder..::..OffMeshConnection Class
wManager.Wow.Helpers Namespace


OffMeshConnection Constructor

Overload List

 | Name | Description
Public method | PathFinder..::..OffMeshConnection()()()() | Initializes a new instance of the PathFinder..::..OffMeshConnection class.
Public method | PathFinder..::..OffMeshConnection(List<(Of <<'(Vector3>)>>), Int32) | Initialize a new instance of the PathFinder..::..OffMeshConnection class.
Public method | PathFinder..::..OffMeshConnection(List<(Of <<'(Vector3>)>>), Int32, PathFinder..::..OffMeshConnectionType, Boolean) | Initialize a new instance of the PathFinder..::..OffMeshConnection class.

See Also

PathFinder..::..OffMeshConnection Class
PathFinder..::..OffMeshConnection Members
wManager.Wow.Helpers Namespace


OffMeshConnection Constructor

Initializes a new instance of the PathFinder..::..OffMeshConnection class.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public OffMeshConnection()
Public Sub New
public:
OffMeshConnection()

See Also

PathFinder..::..OffMeshConnection Class
PathFinder..::..OffMeshConnection Overload
wManager.Wow.Helpers Namespace


OffMeshConnection Constructor (List(Vector3), Int32)

OffMeshConnection Constructor (List<(Of <(<'Vector3>)>)>, Int32)

Initialize a new instance of the PathFinder..::..OffMeshConnection class.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public OffMeshConnection(
    List<Vector3> path,
    int continentId
)
Public Sub New ( _
    path As List(Of Vector3), _
    continentId As Integer _
)
public:
OffMeshConnection(
    List<Vector3^>^ path,
    int^ continentId
)

Parameters

path
Type: List <(Of <(<' Vector3 >)>)>
The path.
continentId
Type: Int32
The continent id (-1 to use on all continents).

See Also

PathFinder..::..OffMeshConnection Class
PathFinder..::..OffMeshConnection Overload
wManager.Wow.Helpers Namespace


OffMeshConnection Constructor (List(Vector3), Int32, OffMeshConnectionType, Boolean)

OffMeshConnection Constructor (List<(Of <(<'Vector3>)>)>, Int32, OffMeshConnectionType, Boolean)

Initialize a new instance of the PathFinder..::..OffMeshConnection class.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public OffMeshConnection(
    List<Vector3> path,
    int continentId,
    PathFinder..::..OffMeshConnectionType type,
    bool tryToUseEvenIfCanFindPathSuccess
)
Public Sub New ( _
    path As List(Of Vector3), _
    continentId As Integer, _
    type As PathFinder..::..OffMeshConnectionType, _
    tryToUseEvenIfCanFindPathSuccess As Boolean _
)
public:
OffMeshConnection(
    List<Vector3^>^ path,
    int^ continentId,
    PathFinder..::..OffMeshConnectionType^ type,
    bool^ tryToUseEvenIfCanFindPathSuccess
)

Parameters

path
Type: List <(Of <(<' Vector3 >)>)>
The path.
continentId
Type: Int32
The continent id (-1 to use on all continents)
type
Type: wManager.Wow.Helpers..::..PathFinder..::..OffMeshConnectionType
The type.
tryToUseEvenIfCanFindPathSuccess
Type: Boolean
if set to true try to use even if can find path success (and use this if path distance is smaller with), use this option if you know what you are doing.

See Also

PathFinder..::..OffMeshConnection Class
PathFinder..::..OffMeshConnection Overload
wManager.Wow.Helpers Namespace


PathFinder.OffMeshConnection Methods

PathFinder..::..OffMeshConnection Methods

The PathFinder..::..OffMeshConnection type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IsSame | Determines whether the specified o is same.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance.

See Also

PathFinder..::..OffMeshConnection Class
wManager.Wow.Helpers Namespace


IsSame Method

OffMeshConnection..::..IsSame Method

Determines whether the specified o is same.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsSame(
    PathFinder..::..OffMeshConnection o
)
Public Function IsSame ( _
    o As PathFinder..::..OffMeshConnection _
) As Boolean
public:
bool^ IsSame(
    PathFinder..::..OffMeshConnection^ o
)

Parameters

o
Type: wManager.Wow.Helpers..::..PathFinder..::..OffMeshConnection
compare to.

Return Value

true if the specified offMeshConnection is same; otherwise, false.

See Also

PathFinder..::..OffMeshConnection Class
wManager.Wow.Helpers Namespace


ToString Method

OffMeshConnection..::..ToString Method

Returns a String that represents this instance.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string ToString()
Public Function ToString As String
public:
String^ ToString()

Return Value

A String that represents this instance.

See Also

PathFinder..::..OffMeshConnection Class
wManager.Wow.Helpers Namespace


PathFinder.OffMeshConnection Properties

PathFinder..::..OffMeshConnection Properties

The PathFinder..::..OffMeshConnection type exposes the following members.

Properties

 | Name | Description
Public property | ContinentId | Get or set the continent id (-1 to use on all continents).
Public property | Name | Get or set the name (description).
Public property | Path | Get or set the path.
Public property | TryToUseEvenIfCanFindPathSuccess | If true try to use even if can find path success (and use this if path distance is smaller with), use this option if you know what you are doing.
Public property | Type | Get or set the type.

See Also

PathFinder..::..OffMeshConnection Class
wManager.Wow.Helpers Namespace


ContinentId Property

OffMeshConnection..::..ContinentId Property

Get or set the continent id (-1 to use on all continents).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int ContinentId { get; set; }
Public Property ContinentId As Integer
    Get
    Set
public:
property int^ ContinentId {
    int^ get ();
    void set (int^ value);
}

See Also

PathFinder..::..OffMeshConnection Class
wManager.Wow.Helpers Namespace


Name Property

OffMeshConnection..::..Name Property

Get or set the name (description).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Field Value

The name.

See Also

PathFinder..::..OffMeshConnection Class
wManager.Wow.Helpers Namespace


Path Property

OffMeshConnection..::..Path Property

Get or set the path.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<Vector3> Path { get; set; }
Public Property Path As List(Of Vector3)
    Get
    Set
public:
property List<Vector3^>^ Path {
    List<Vector3^>^ get ();
    void set (List<Vector3^>^ value);
}

Field Value

The path.

See Also

PathFinder..::..OffMeshConnection Class
wManager.Wow.Helpers Namespace


TryToUseEvenIfCanFindPathSuccess Property

OffMeshConnection..::..TryToUseEvenIfCanFindPathSuccess Property

If true try to use even if can find path success (and use this if path distance is smaller with), use this option if you know what you are doing.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool TryToUseEvenIfCanFindPathSuccess { get; set; }
Public Property TryToUseEvenIfCanFindPathSuccess As Boolean
    Get
    Set
public:
property bool^ TryToUseEvenIfCanFindPathSuccess {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true If true try to use even if can find path success (and use this if path distance is smaller with); otherwise, false.

See Also

PathFinder..::..OffMeshConnection Class
wManager.Wow.Helpers Namespace


Type Property

OffMeshConnection..::..Type Property

Get or set the type.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public PathFinder..::..OffMeshConnectionType Type { get; set; }
Public Property Type As PathFinder..::..OffMeshConnectionType
    Get
    Set
public:
property PathFinder..::..OffMeshConnectionType^ Type {
    PathFinder..::..OffMeshConnectionType^ get ();
    void set (PathFinder..::..OffMeshConnectionType^ value);
}

Field Value

The type.

See Also

PathFinder..::..OffMeshConnection Class
wManager.Wow.Helpers Namespace


PathFinder.OffMeshConnections Class

PathFinder..::..OffMeshConnections Class

Class OffMeshConnections. More information here: https://wrobot.eu/forums/topic/5283-offmesh-connections/

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class OffMeshConnections
Public NotInheritable Class OffMeshConnections
public ref class OffMeshConnections abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..PathFinder..::..OffMeshConnections

See Also

PathFinder..::..OffMeshConnections Members
wManager.Wow.Helpers Namespace


PathFinder.OffMeshConnections Members

PathFinder..::..OffMeshConnections Members

The PathFinder..::..OffMeshConnections type exposes the following members.

Methods

Name | Description
Add | Add specified offmeshconnection to MeshConnection.
AddRange | Add several offmeshconnections to MeshConnection.
GetOffMeshConnectionForCurrentContinent | Get offmeshconnections for current continent (from MeshConnection and OffMeshConnectionsDefault).
Load | Load MeshConnection from FileName.
Save | Save MeshConnection to FileName.

Properties

Name | Description
FileName | Get the name file (where MeshConnection is saved, by default "WRobot\Data\OffMeshConnections.xml").
MeshConnection | Get or set offmeshconnections (to use use Add(PathFinder..::..OffMeshConnection, Boolean) or AddRange(List<(Of <<'(PathFinder..::..OffMeshConnection>)>>), Boolean)).

See Also

PathFinder..::..OffMeshConnections Class
wManager.Wow.Helpers Namespace


PathFinder.OffMeshConnections Methods

PathFinder..::..OffMeshConnections Methods

The PathFinder..::..OffMeshConnections type exposes the following members.

Methods

Name | Description
Add | Add specified offmeshconnection to MeshConnection.
AddRange | Add several offmeshconnections to MeshConnection.
GetOffMeshConnectionForCurrentContinent | Get offmeshconnections for current continent (from MeshConnection and OffMeshConnectionsDefault).
Load | Load MeshConnection from FileName.
Save | Save MeshConnection to FileName.

See Also

PathFinder..::..OffMeshConnections Class
wManager.Wow.Helpers Namespace


Add Method

OffMeshConnections..::..Add Method

Add specified offmeshconnection to MeshConnection.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void Add(
    PathFinder..::..OffMeshConnection offMeshConnection,
    bool skipIfAlreadyInList
)
Public Shared Sub Add ( _
    offMeshConnection As PathFinder..::..OffMeshConnection, _
    skipIfAlreadyInList As Boolean _
)
public:
static void Add(
    PathFinder..::..OffMeshConnection^ offMeshConnection,
    bool^ skipIfAlreadyInList
)

Parameters

offMeshConnection
Type: wManager.Wow.Helpers..::..PathFinder..::..OffMeshConnection
The offmeshconnection.
skipIfAlreadyInList
Type: Boolean
if set to true ignore offmeshconnection if already in list.

See Also

PathFinder..::..OffMeshConnections Class
wManager.Wow.Helpers Namespace


AddRange Method

OffMeshConnections..::..AddRange Method

Add several offmeshconnections to MeshConnection.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void AddRange(
    List<PathFinder..::..OffMeshConnection> offMeshConnections,
    bool skipIfAlreadyInList
)
Public Shared Sub AddRange ( _
    offMeshConnections As List(Of PathFinder..::..OffMeshConnection), _
    skipIfAlreadyInList As Boolean _
)
public:
static void AddRange(
    List<PathFinder..::..OffMeshConnection^>^ offMeshConnections,
    bool^ skipIfAlreadyInList
)

Parameters

offMeshConnections
Type: List <(Of <(<' PathFinder..::..OffMeshConnection >)>)>
Offmeshconnections list.
skipIfAlreadyInList
Type: Boolean
if set to true ignore offmeshconnection if already in list.

See Also

PathFinder..::..OffMeshConnections Class
wManager.Wow.Helpers Namespace


GetOffMeshConnectionForCurrentContinent Method

OffMeshConnections..::..GetOffMeshConnectionForCurrentContinent Method

Get offmeshconnections for current continent (from MeshConnection and OffMeshConnectionsDefault).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<PathFinder..::..OffMeshConnection> GetOffMeshConnectionForCurrentContinent()
Public Shared Function GetOffMeshConnectionForCurrentContinent As List(Of PathFinder..::..OffMeshConnection)
public:
static List<PathFinder..::..OffMeshConnection^>^ GetOffMeshConnectionForCurrentContinent()

Return Value

offmeshconnections list.

See Also

PathFinder..::..OffMeshConnections Class
wManager.Wow.Helpers Namespace


Load Method

OffMeshConnections..::..Load Method

Load MeshConnection from FileName.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void Load()
Public Shared Sub Load
public:
static void Load()

See Also

PathFinder..::..OffMeshConnections Class
wManager.Wow.Helpers Namespace


Save Method

OffMeshConnections..::..Save Method

Save MeshConnection to FileName.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void Save()
Public Shared Sub Save
public:
static void Save()

See Also

PathFinder..::..OffMeshConnections Class
wManager.Wow.Helpers Namespace


PathFinder.OffMeshConnections Properties

PathFinder..::..OffMeshConnections Properties

The PathFinder..::..OffMeshConnections type exposes the following members.

Properties

Name | Description
FileName | Get the name file (where MeshConnection is saved, by default "WRobot\Data\OffMeshConnections.xml").
MeshConnection | Get or set offmeshconnections (to use use Add(PathFinder..::..OffMeshConnection, Boolean) or AddRange(List<(Of <<'(PathFinder..::..OffMeshConnection>)>>), Boolean)).

See Also

PathFinder..::..OffMeshConnections Class
wManager.Wow.Helpers Namespace


FileName Property

OffMeshConnections..::..FileName Property

Get the name file (where MeshConnection is saved, by default "WRobot\Data\OffMeshConnections.xml").

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string FileName { get; }
Public Shared ReadOnly Property FileName As String
    Get
public:
static property String^ FileName {
    String^ get ();
}

Field Value

The file name.

See Also

PathFinder..::..OffMeshConnections Class
wManager.Wow.Helpers Namespace


MeshConnection Property

OffMeshConnections..::..MeshConnection Property

Get or set offmeshconnections (to use use Add(PathFinder..::..OffMeshConnection, Boolean) or AddRange(List<(Of <<'(PathFinder..::..OffMeshConnection>)>>), Boolean)).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<PathFinder..::..OffMeshConnection> MeshConnection { get; set; }
Public Shared Property MeshConnection As List(Of PathFinder..::..OffMeshConnection)
    Get
    Set
public:
static property List<PathFinder..::..OffMeshConnection^>^ MeshConnection {
    List<PathFinder..::..OffMeshConnection^>^ get ();
    void set (List<PathFinder..::..OffMeshConnection^>^ value);
}

Field Value

The offmeshconnections.

See Also

PathFinder..::..OffMeshConnections Class
wManager.Wow.Helpers Namespace


PathFinder.OffMeshConnectionType Enumeration

PathFinder..::..OffMeshConnectionType Enumeration

OffMeshConnectionType

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public enum OffMeshConnectionType
<SerializableAttribute> _
Public Enumeration OffMeshConnectionType
[SerializableAttribute]
public enum class OffMeshConnectionType

Members

Member name | Description
Unidirectional | The unidirectional
Bidirectional | The bidirectional (can be used in both directions)

See Also

wManager.Wow.Helpers Namespace


PetBattles Class

Class PetBattles. Useful methods to manage.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class PetBattles
Public NotInheritable Class PetBattles
public ref class PetBattles abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..PetBattles

See Also

PetBattles Members
wManager.Wow.Helpers Namespace


PetBattles Members

The PetBattles type exposes the following members.

Methods

Name | Description
ActionSelected | Actions the selected.
AllPetDead | All pet are dead.
AutoOrderPetInJournalByLevel | Order pets in journal by level.
ChangePet | Changes the active pet out for a different pet in a pet battle.
ChangeToBestPet | Changes to best pet.
GetAbilityInfo | Gets the ability information.
GetAbilityState | Gets the state of the ability.
GetActivePet | Gets the active pet.
GetBestAbility | Gets the best ability (against the current target).
GetBestPet | Gets the best pet (against current target).
GetBreedQuality | Gets the breed quality.
GetHealth | Gets the health.
GetLevel | Gets the level.
GetMaxHealth | Gets the maximum health.
GetName | Gets the name.
GetNumberUsableAbility | Gets the number of usable abilities.
GetPetGuid | Gets the pet GUID.
GetPetSpeciesID | Returns the species ID of a specific pet in the pet battle.
GetPetType | Gets the type of the pet.
GetPower | Gets the power.
GetSpeed | Gets the speed.
HasPetTeam | Determines whether has pet team.
IsDeadPet | Determines whether pet is dead.
IsTrapAvailable | Determines whether is trap available.
IsWaitingOnOpponent | Determines whether is waiting on opponent.
NumberPetAlive | Number of pet alive.
PetJournalGetExistPetActiveId | Pet journal get exist pet active IDs.
PetJournalGetHealth | Pet journal get health.
PetJournalGetLevel | Pet journal get level.
PetJournalGetMaxHealth | Pet journal get maximum health.
PetJournalHavePet | Pet journal have pet.
PetJournalPetLoadOutGuid | Pet journal get actives pets GUIDs.
PetJournalSetPetLoadOutInfo | Pet journal, places the specified pet into a battle pet slot..
PvpQueueAndAccept | PVPs queue and accept.
ReviveBattlePets | Revives the battle pets.
SkipTurn | Skips the turn.
UseAbility | Uses the ability.
UseBestAbility | Uses the best ability.
UseTrap | Uses the trap.

Fields

Name | Description
AbilityModifer | The ability modifer
MAX_ACTIVE_PETS | The maximum active pets
NUM_BATTLE_PET_ABILITIES | The number battle pet abilities
NUM_BATTLE_PETS_IN_BATTLE | The number battle pets in battle
ReviveOne | The revive one
TypeEffects | The type effects

Properties

Name | Description
CanBattlePet | Gets a value indicating whether can battle pet.
ConditionResurrectBattlePets | Gets a value indicating whether [condition resurrect battle pets].
IsInBattle | Gets a value indicating whether is in battle.
ReviveBattlePetsIsUsable | Gets a value indicating whether revive battle pets is usable.

See Also

PetBattles Class
wManager.Wow.Helpers Namespace


PetBattles Fields

The PetBattles type exposes the following members.

Fields

Name | Description
AbilityModifer | The ability modifer
MAX_ACTIVE_PETS | The maximum active pets
NUM_BATTLE_PET_ABILITIES | The number battle pet abilities
NUM_BATTLE_PETS_IN_BATTLE | The number battle pets in battle
ReviveOne | The revive one
TypeEffects | The type effects

See Also

PetBattles Class
wManager.Wow.Helpers Namespace


AbilityModifer Field

PetBattles..::..AbilityModifer Field

The ability modifer

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<PetBattles..::..ModiferEffects> AbilityModifer
Public Shared AbilityModifer As List(Of PetBattles..::..ModiferEffects)
public:
static List<PetBattles..::..ModiferEffects^>^ AbilityModifer

See Also

PetBattles Class
wManager.Wow.Helpers Namespace


MAX_ACTIVE_PETS Field

PetBattles..::..MAX_ACTIVE_PETS Field

The maximum active pets

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const int MAX_ACTIVE_PETS
Public Const MAX_ACTIVE_PETS As Integer
public:
literal int^ MAX_ACTIVE_PETS

See Also

PetBattles Class
wManager.Wow.Helpers Namespace


NUM_BATTLE_PET_ABILITIES Field

PetBattles..::..NUM_BATTLE_PET_ABILITIES Field

The number battle pet abilities

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const int NUM_BATTLE_PET_ABILITIES
Public Const NUM_BATTLE_PET_ABILITIES As Integer
public:
literal int^ NUM_BATTLE_PET_ABILITIES

See Also

PetBattles Class
wManager.Wow.Helpers Namespace


NUM_BATTLE_PETS_IN_BATTLE Field

PetBattles..::..NUM_BATTLE_PETS_IN_BATTLE Field

The number battle pets in battle

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const int NUM_BATTLE_PETS_IN_BATTLE
Public Const NUM_BATTLE_PETS_IN_BATTLE As Integer
public:
literal int^ NUM_BATTLE_PETS_IN_BATTLE

See Also

PetBattles Class
wManager.Wow.Helpers Namespace


ReviveOne Field

PetBattles..::..ReviveOne Field

The revive one

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool ReviveOne
Public Shared ReviveOne As Boolean
public:
static bool^ ReviveOne

See Also

PetBattles Class
wManager.Wow.Helpers Namespace


TypeEffects Field

PetBattles..::..TypeEffects Field

The type effects

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<PetBattles..::..ModiferEffects> TypeEffects
Public Shared TypeEffects As List(Of PetBattles..::..ModiferEffects)
public:
static List<PetBattles..::..ModiferEffects^>^ TypeEffects

See Also

PetBattles Class
wManager.Wow.Helpers Namespace


PetBattles Methods

The PetBattles type exposes the following members.

Methods

Name | Description
ActionSelected | Actions the selected.
AllPetDead | All pet are dead.
AutoOrderPetInJournalByLevel | Order pets in journal by level.
ChangePet | Changes the active pet out for a different pet in a pet battle.
ChangeToBestPet | Changes to best pet.
GetAbilityInfo | Gets the ability information.
GetAbilityState | Gets the state of the ability.
GetActivePet | Gets the active pet.
GetBestAbility | Gets the best ability (against the current target).
GetBestPet | Gets the best pet (against current target).
GetBreedQuality | Gets the breed quality.
GetHealth | Gets the health.
GetLevel | Gets the level.
GetMaxHealth | Gets the maximum health.
GetName | Gets the name.
GetNumberUsableAbility | Gets the number of usable abilities.
GetPetGuid | Gets the pet GUID.
GetPetSpeciesID | Returns the species ID of a specific pet in the pet battle.
GetPetType | Gets the type of the pet.
GetPower | Gets the power.
GetSpeed | Gets the speed.
HasPetTeam | Determines whether has pet team.
IsDeadPet | Determines whether pet is dead.
IsTrapAvailable | Determines whether is trap available.
IsWaitingOnOpponent | Determines whether is waiting on opponent.
NumberPetAlive | Number of pet alive.
PetJournalGetExistPetActiveId | Pet journal get exist pet active IDs.
PetJournalGetHealth | Pet journal get health.
PetJournalGetLevel | Pet journal get level.
PetJournalGetMaxHealth | Pet journal get maximum health.
PetJournalHavePet | Pet journal have pet.
PetJournalPetLoadOutGuid | Pet journal get actives pets GUIDs.
PetJournalSetPetLoadOutInfo | Pet journal, places the specified pet into a battle pet slot..
PvpQueueAndAccept | PVPs queue and accept.
ReviveBattlePets | Revives the battle pets.
SkipTurn | Skips the turn.
UseAbility | Uses the ability.
UseBestAbility | Uses the best ability.
UseTrap | Uses the trap.

See Also

PetBattles Class
wManager.Wow.Helpers Namespace


ActionSelected Method

PetBattles..::..ActionSelected Method

Actions the selected.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool ActionSelected()
Public Shared Function ActionSelected As Boolean
public:
static bool^ ActionSelected()

Return Value

true if selected, false otherwise.

See Also

PetBattles Class
wManager.Wow.Helpers Namespace


AllPetDead Method

PetBattles..::..AllPetDead Method

All pet are dead.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool AllPetDead()
Public Shared Function AllPetDead As Boolean
public:
static bool^ AllPetDead()

Return Value

true if all are dead, false otherwise.

See Also

PetBattles Class
wManager.Wow.Helpers Namespace


AutoOrderPetInJournalByLevel Method

PetBattles..::..AutoOrderPetInJournalByLevel Method

Order pets in journal by level.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool AutoOrderPetInJournalByLevel()
Public Shared Function AutoOrderPetInJournalByLevel As Boolean
public:
static bool^ AutoOrderPetInJournalByLevel()

Return Value

true if success, false otherwise.

See Also

PetBattles Class
wManager.Wow.Helpers Namespace


ChangePet Method

PetBattles..::..ChangePet Method

Changes the active pet out for a different pet in a pet battle.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void ChangePet(
    int petId
)
Public Shared Sub ChangePet ( _
    petId As Integer _
)
public:
static void ChangePet(
    int^ petId
)

Parameters

petId
Type: Int32
Accepted values are 1-3, but the order is based off of the initial order. Which pet is currently active is irrelevant to the index, if it was your 3rd pet when you entered battle, it will always be 3 on the index..

See Also

PetBattles Class
wManager.Wow.Helpers Namespace


ChangeToBestPet Method

PetBattles..::..ChangeToBestPet Method

Changes to best pet.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void ChangeToBestPet()
Public Shared Sub ChangeToBestPet
public:
static void ChangeToBestPet()

See Also

PetBattles Class
wManager.Wow.Helpers Namespace


GetAbilityInfo Method

PetBattles..::..GetAbilityInfo Method

Gets the ability information.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static PetBattles..::..AbilityInfo GetAbilityInfo(
    PetBattles..::..PetFaction petFaction,
    int petId,
    int abilityIndex
)
Public Shared Function GetAbilityInfo ( _
    petFaction As PetBattles..::..PetFaction, _
    petId As Integer, _
    abilityIndex As Integer _
) As PetBattles..::..AbilityInfo
public:
static PetBattles..::..AbilityInfo^ GetAbilityInfo(
    PetBattles..::..PetFaction^ petFaction,
    int^ petId,
    int^ abilityIndex
)

Parameters

petFaction
Type: wManager.Wow.Helpers..::..PetBattles..::..PetFaction
1: Current player, 2: Opponent.
petId
Type: Int32
Accepted values are 1-3, but the order is based off of the initial order. Which pet is currently active is irrelevant to the index, if it was your 3rd pet when you entered battle, it will always be 3 on the index..
abilityIndex
Type: Int32
Accepted values are 1-3, corresponding to the ability buttons from left to right.

Return Value

AbilityInfo.

See Also

PetBattles Class
wManager.Wow.Helpers Namespace


GetAbilityState Method

PetBattles..::..GetAbilityState Method

Gets the state of the ability.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool GetAbilityState(
    PetBattles..::..PetFaction petFaction,
    int petId,
    int abilityIndex
)
Public Shared Function GetAbilityState ( _
    petFaction As PetBattles..::..PetFaction, _
    petId As Integer, _
    abilityIndex As Integer _
) As Boolean
public:
static bool^ GetAbilityState(
    PetBattles..::..PetFaction^ petFaction,
    int^ petId,
    int^ abilityIndex
)

Parameters

petFaction
Type: wManager.Wow.Helpers..::..PetBattles..::..PetFaction
1: Current player, 2: Opponent.
petId
Type: Int32
Accepted values are 1-3, but the order is based off of the initial order. Which pet is currently active is irrelevant to the index, if it was your 3rd pet when you entered battle, it will always be 3 on the index..
abilityIndex
Type: Int32
Accepted values are 1-3, corresponding to the ability buttons from left to right.

Return Value

true if available, false otherwise.

See Also

PetBattles Class
wManager.Wow.Helpers Namespace


GetActivePet Method

PetBattles..::..GetActivePet Method

Gets the active pet.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int GetActivePet(
    PetBattles..::..PetFaction petFaction
)
Public Shared Function GetActivePet ( _
    petFaction As PetBattles..::..PetFaction _
) As Integer
public:
static int^ GetActivePet(
    PetBattles..::..PetFaction^ petFaction
)

Parameters

petFaction
Type: wManager.Wow.Helpers..::..PetBattles..::..PetFaction
1: Current player, 2: Opponent.

Return Value

System.Int32.

See Also

PetBattles Class
wManager.Wow.Helpers Namespace


GetBestAbility Method

PetBattles..::..GetBestAbility Method

Gets the best ability (against the current target).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int GetBestAbility()
Public Shared Function GetBestAbility As Integer
public:
static int^ GetBestAbility()

Return Value

ability index.

See Also

PetBattles Class
wManager.Wow.Helpers Namespace


GetBestPet Method

PetBattles..::..GetBestPet Method

Gets the best pet (against current target).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int GetBestPet()
Public Shared Function GetBestPet As Integer
public:
static int^ GetBestPet()

Return Value

pet index.

See Also

PetBattles Class
wManager.Wow.Helpers Namespace


GetBreedQuality Method

PetBattles..::..GetBreedQuality Method

Gets the breed quality.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static PetBattles..::..PetQuality GetBreedQuality(
    PetBattles..::..PetFaction petFaction,
    int petId
)
Public Shared Function GetBreedQuality ( _
    petFaction As PetBattles..::..PetFaction, _
    petId As Integer _
) As PetBattles..::..PetQuality
public:
static PetBattles..::..PetQuality^ GetBreedQuality(
    PetBattles..::..PetFaction^ petFaction,
    int^ petId
)

Parameters

petFaction
Type: wManager.Wow.Helpers..::..PetBattles..::..PetFaction
1: Current player, 2: Opponent.
petId
Type: Int32
Accepted values are 1-3, but the order is based off of the initial order. Which pet is currently active is irrelevant to the index, if it was your 3rd pet when you entered battle, it will always be 3 on the index..

Return Value

PetQuality.

See Also

PetBattles Class
wManager.Wow.Helpers Namespace


GetHealth Method

PetBattles..::..GetHealth Method

Gets the health.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int GetHealth(
    PetBattles..::..PetFaction petFaction,
    int petId
)
Public Shared Function GetHealth ( _
    petFaction As PetBattles..::..PetFaction, _
    petId As Integer _
) As Integer
public:
static int^ GetHealth(
    PetBattles..::..PetFaction^ petFaction,
    int^ petId
)

Parameters

petFaction
Type: wManager.Wow.Helpers..::..PetBattles..::..PetFaction
1: Current player, 2: Opponent.
petId
Type: Int32
Accepted values are 1-3, but the order is based off of the initial order. Which pet is currently active is irrelevant to the index, if it was your 3rd pet when you entered battle, it will always be 3 on the index..

Return Value

System.Int32.

See Also

PetBattles Class
wManager.Wow.Helpers Namespace


GetLevel Method

PetBattles..::..GetLevel Method

Gets the level.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string GetLevel(
    PetBattles..::..PetFaction petFaction,
    int petId
)
Public Shared Function GetLevel ( _
    petFaction As PetBattles..::..PetFaction, _
    petId As Integer _
) As String
public:
static String^ GetLevel(
    PetBattles..::..PetFaction^ petFaction,
    int^ petId
)

Parameters

petFaction
Type: wManager.Wow.Helpers..::..PetBattles..::..PetFaction
1: Current player, 2: Opponent.
petId
Type: Int32
Accepted values are 1-3, but the order is based off of the initial order. Which pet is currently active is irrelevant to the index, if it was your 3rd pet when you entered battle, it will always be 3 on the index..

Return Value

System.String.

See Also

PetBattles Class
wManager.Wow.Helpers Namespace


GetMaxHealth Method

PetBattles..::..GetMaxHealth Method

Gets the maximum health.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int GetMaxHealth(
    PetBattles..::..PetFaction petFaction,
    int petId
)
Public Shared Function GetMaxHealth ( _
    petFaction As PetBattles..::..PetFaction, _
    petId As Integer _
) As Integer
public:
static int^ GetMaxHealth(
    PetBattles..::..PetFaction^ petFaction,
    int^ petId
)

Parameters

petFaction
Type: wManager.Wow.Helpers..::..PetBattles..::..PetFaction
1: Current player, 2: Opponent.
petId
Type: Int32
Accepted values are 1-3, but the order is based off of the initial order. Which pet is currently active is irrelevant to the index, if it was your 3rd pet when you entered battle, it will always be 3 on the index..

Return Value

System.Int32.

See Also

PetBattles Class
wManager.Wow.Helpers Namespace


GetName Method

PetBattles..::..GetName Method

Gets the name.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string GetName(
    PetBattles..::..PetFaction petFaction,
    int petId
)
Public Shared Function GetName ( _
    petFaction As PetBattles..::..PetFaction, _
    petId As Integer _
) As String
public:
static String^ GetName(
    PetBattles..::..PetFaction^ petFaction,
    int^ petId
)

Parameters

petFaction
Type: wManager.Wow.Helpers..::..PetBattles..::..PetFaction
1: Current player, 2: Opponent.
petId
Type: Int32
Accepted values are 1-3, but the order is based off of the initial order. Which pet is currently active is irrelevant to the index, if it was your 3rd pet when you entered battle, it will always be 3 on the index..

Return Value

System.String.

See Also

PetBattles Class
wManager.Wow.Helpers Namespace


GetNumberUsableAbility Method

PetBattles..::..GetNumberUsableAbility Method

Gets the number of usable abilities.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int GetNumberUsableAbility()
Public Shared Function GetNumberUsableAbility As Integer
public:
static int^ GetNumberUsableAbility()

Return Value

number of usable abilities.

See Also

PetBattles Class
wManager.Wow.Helpers Namespace


GetPetGuid Method

PetBattles..::..GetPetGuid Method

Gets the pet GUID.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string GetPetGuid(
    int petActiveId
)
Public Shared Function GetPetGuid ( _
    petActiveId As Integer _
) As String
public:
static String^ GetPetGuid(
    int^ petActiveId
)

Parameters

petActiveId
Type: Int32
The active pet ID.

Return Value

GUID.

See Also

PetBattles Class
wManager.Wow.Helpers Namespace


GetPetSpeciesID Method

PetBattles..::..GetPetSpeciesID Method

Returns the species ID of a specific pet in the pet battle.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int GetPetSpeciesID(
    PetBattles..::..PetFaction petFaction,
    int petId
)
Public Shared Function GetPetSpeciesID ( _
    petFaction As PetBattles..::..PetFaction, _
    petId As Integer _
) As Integer
public:
static int^ GetPetSpeciesID(
    PetBattles..::..PetFaction^ petFaction,
    int^ petId
)

Parameters

petFaction
Type: wManager.Wow.Helpers..::..PetBattles..::..PetFaction
1: Current player, 2: Opponent.
petId
Type: Int32
Accepted values are 1-3, but the order is based off of the initial order. Which pet is currently active is irrelevant to the index, if it was your 3rd pet when you entered battle, it will always be 3 on the index..

Return Value

System.Int32.

See Also

PetBattles Class
wManager.Wow.Helpers Namespace


GetPetType Method

PetBattles..::..GetPetType Method

Gets the type of the pet.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static PetBattles..::..PetType GetPetType(
    PetBattles..::..PetFaction petFaction,
    int petId
)
Public Shared Function GetPetType ( _
    petFaction As PetBattles..::..PetFaction, _
    petId As Integer _
) As PetBattles..::..PetType
public:
static PetBattles..::..PetType^ GetPetType(
    PetBattles..::..PetFaction^ petFaction,
    int^ petId
)

Parameters

petFaction
Type: wManager.Wow.Helpers..::..PetBattles..::..PetFaction
1: Current player, 2: Opponent.
petId
Type: Int32
Accepted values are 1-3, but the order is based off of the initial order. Which pet is currently active is irrelevant to the index, if it was your 3rd pet when you entered battle, it will always be 3 on the index..

Return Value

PetType.

See Also

PetBattles Class
wManager.Wow.Helpers Namespace


GetPower Method

PetBattles..::..GetPower Method

Gets the power.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string GetPower(
    PetBattles..::..PetFaction petFaction,
    int petId
)
Public Shared Function GetPower ( _
    petFaction As PetBattles..::..PetFaction, _
    petId As Integer _
) As String
public:
static String^ GetPower(
    PetBattles..::..PetFaction^ petFaction,
    int^ petId
)

Parameters

petFaction
Type: wManager.Wow.Helpers..::..PetBattles..::..PetFaction
1: Current player, 2: Opponent.
petId
Type: Int32
Accepted values are 1-3, but the order is based off of the initial order. Which pet is currently active is irrelevant to the index, if it was your 3rd pet when you entered battle, it will always be 3 on the index..

Return Value

System.String.

See Also

PetBattles Class
wManager.Wow.Helpers Namespace


GetSpeed Method

PetBattles..::..GetSpeed Method

Gets the speed.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string GetSpeed(
    PetBattles..::..PetFaction petFaction,
    int petId
)
Public Shared Function GetSpeed ( _
    petFaction As PetBattles..::..PetFaction, _
    petId As Integer _
) As String
public:
static String^ GetSpeed(
    PetBattles..::..PetFaction^ petFaction,
    int^ petId
)

Parameters

petFaction
Type: wManager.Wow.Helpers..::..PetBattles..::..PetFaction
1: Current player, 2: Opponent.
petId
Type: Int32
Accepted values are 1-3, but the order is based off of the initial order. Which pet is currently active is irrelevant to the index, if it was your 3rd pet when you entered battle, it will always be 3 on the index..

Return Value

System.String.

See Also

PetBattles Class
wManager.Wow.Helpers Namespace


HasPetTeam Method

PetBattles..::..HasPetTeam Method

Determines whether has pet team.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool HasPetTeam(
    bool forceResetTimerCheck
)
Public Shared Function HasPetTeam ( _
    forceResetTimerCheck As Boolean _
) As Boolean
public:
static bool^ HasPetTeam(
    bool^ forceResetTimerCheck
)

Parameters

forceResetTimerCheck
Type: Boolean
if set to true force reset cache.

Return Value

true if has pet team; otherwise, false.

See Also

PetBattles Class
wManager.Wow.Helpers Namespace


IsDeadPet Method

PetBattles..::..IsDeadPet Method

Determines whether pet is dead.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool IsDeadPet(
    PetBattles..::..PetFaction petFaction,
    int petId
)
Public Shared Function IsDeadPet ( _
    petFaction As PetBattles..::..PetFaction, _
    petId As Integer _
) As Boolean
public:
static bool^ IsDeadPet(
    PetBattles..::..PetFaction^ petFaction,
    int^ petId
)

Parameters

petFaction
Type: wManager.Wow.Helpers..::..PetBattles..::..PetFaction
1: Current player, 2: Opponent.
petId
Type: Int32
Accepted values are 1-3, but the order is based off of the initial order. Which pet is currently active is irrelevant to the index, if it was your 3rd pet when you entered battle, it will always be 3 on the index..

Return Value

true if is dead; otherwise, false.

See Also

PetBattles Class
wManager.Wow.Helpers Namespace


IsTrapAvailable Method

PetBattles..::..IsTrapAvailable Method

Determines whether is trap available.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool IsTrapAvailable()
Public Shared Function IsTrapAvailable As Boolean
public:
static bool^ IsTrapAvailable()

Return Value

true if is trap available; otherwise, false.

See Also

PetBattles Class
wManager.Wow.Helpers Namespace


IsWaitingOnOpponent Method

PetBattles..::..IsWaitingOnOpponent Method

Determines whether is waiting on opponent.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool IsWaitingOnOpponent()
Public Shared Function IsWaitingOnOpponent As Boolean
public:
static bool^ IsWaitingOnOpponent()

Return Value

true if is waiting on opponent; otherwise, false.

See Also

PetBattles Class
wManager.Wow.Helpers Namespace


NumberPetAlive Method

PetBattles..::..NumberPetAlive Method

Number of pet alive.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int NumberPetAlive()
Public Shared Function NumberPetAlive As Integer
public:
static int^ NumberPetAlive()

Return Value

pet alive count.

See Also

PetBattles Class
wManager.Wow.Helpers Namespace


PetJournalGetExistPetActiveId Method

PetBattles..::..PetJournalGetExistPetActiveId Method

Pet journal get exist pet active IDs.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<int> PetJournalGetExistPetActiveId()
Public Shared Function PetJournalGetExistPetActiveId As List(Of Integer)
public:
static List<int^>^ PetJournalGetExistPetActiveId()

Return Value

IDs.

See Also

PetBattles Class
wManager.Wow.Helpers Namespace


PetJournalGetHealth Method

PetBattles..::..PetJournalGetHealth Method

Pet journal get health.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int PetJournalGetHealth(
    int petActiveId
)
Public Shared Function PetJournalGetHealth ( _
    petActiveId As Integer _
) As Integer
public:
static int^ PetJournalGetHealth(
    int^ petActiveId
)

Parameters

petActiveId
Type: Int32
The pet active identifier.

Return Value

System.Int32.

See Also

PetBattles Class
wManager.Wow.Helpers Namespace


PetJournalGetLevel Method

PetBattles..::..PetJournalGetLevel Method

Pet journal get level.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int PetJournalGetLevel(
    int petActiveId
)
Public Shared Function PetJournalGetLevel ( _
    petActiveId As Integer _
) As Integer
public:
static int^ PetJournalGetLevel(
    int^ petActiveId
)

Parameters

petActiveId
Type: Int32
The pet active id.

Return Value

System.Int32.

See Also

PetBattles Class
wManager.Wow.Helpers Namespace


PetJournalGetMaxHealth Method

PetBattles..::..PetJournalGetMaxHealth Method

Pet journal get maximum health.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int PetJournalGetMaxHealth(
    int petActiveId
)
Public Shared Function PetJournalGetMaxHealth ( _
    petActiveId As Integer _
) As Integer
public:
static int^ PetJournalGetMaxHealth(
    int^ petActiveId
)

Parameters

petActiveId
Type: Int32
The pet active id.

Return Value

System.Int32.

See Also

PetBattles Class
wManager.Wow.Helpers Namespace


PetJournalHavePet Method

PetBattles..::..PetJournalHavePet Method

Pet journal have pet.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool PetJournalHavePet(
    int petSpeciesID
)
Public Shared Function PetJournalHavePet ( _
    petSpeciesID As Integer _
) As Boolean
public:
static bool^ PetJournalHavePet(
    int^ petSpeciesID
)

Parameters

petSpeciesID
Type: Int32
The pet species id.

Return Value

true if found, false otherwise.

See Also

PetBattles Class
wManager.Wow.Helpers Namespace


PetJournalPetLoadOutGuid Method

PetBattles..::..PetJournalPetLoadOutGuid Method

Pet journal get actives pets GUIDs.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<string> PetJournalPetLoadOutGuid()
Public Shared Function PetJournalPetLoadOutGuid As List(Of String)
public:
static List<String^>^ PetJournalPetLoadOutGuid()

Return Value

GUIDs.

See Also

PetBattles Class
wManager.Wow.Helpers Namespace


PetJournalSetPetLoadOutInfo Method

PetBattles..::..PetJournalSetPetLoadOutInfo Method

Pet journal, places the specified pet into a battle pet slot..

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void PetJournalSetPetLoadOutInfo(
    int slotIndex,
    string petID
)
Public Shared Sub PetJournalSetPetLoadOutInfo ( _
    slotIndex As Integer, _
    petID As String _
)
public:
static void PetJournalSetPetLoadOutInfo(
    int^ slotIndex,
    String^ petID
)

Parameters

slotIndex
Type: Int32
Index of the slot.
petID
Type: String

See Also

PetBattles Class
wManager.Wow.Helpers Namespace


PvpQueueAndAccept Method

PetBattles..::..PvpQueueAndAccept Method

PVPs queue and accept.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void PvpQueueAndAccept()
Public Shared Sub PvpQueueAndAccept
public:
static void PvpQueueAndAccept()

See Also

PetBattles Class
wManager.Wow.Helpers Namespace


ReviveBattlePets Method

PetBattles..::..ReviveBattlePets Method

Revives the battle pets.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool ReviveBattlePets()
Public Shared Function ReviveBattlePets As Boolean
public:
static bool^ ReviveBattlePets()

Return Value

true if success, false otherwise.

See Also

PetBattles Class
wManager.Wow.Helpers Namespace


SkipTurn Method

PetBattles..::..SkipTurn Method

Skips the turn.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void SkipTurn()
Public Shared Sub SkipTurn
public:
static void SkipTurn()

See Also

PetBattles Class
wManager.Wow.Helpers Namespace


UseAbility Method

PetBattles..::..UseAbility Method

Uses the ability.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void UseAbility(
    int abilityIndex
)
Public Shared Sub UseAbility ( _
    abilityIndex As Integer _
)
public:
static void UseAbility(
    int^ abilityIndex
)

Parameters

abilityIndex
Type: Int32
Accepted values are 1-3, corresponding to the ability buttons from left to right.

See Also

PetBattles Class
wManager.Wow.Helpers Namespace


UseBestAbility Method

PetBattles..::..UseBestAbility Method

Uses the best ability.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void UseBestAbility()
Public Shared Sub UseBestAbility
public:
static void UseBestAbility()

See Also

PetBattles Class
wManager.Wow.Helpers Namespace


UseTrap Method

PetBattles..::..UseTrap Method

Uses the trap.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void UseTrap()
Public Shared Sub UseTrap
public:
static void UseTrap()

See Also

PetBattles Class
wManager.Wow.Helpers Namespace


PetBattles Properties

The PetBattles type exposes the following members.

Properties

Name | Description
CanBattlePet | Gets a value indicating whether can battle pet.
ConditionResurrectBattlePets | Gets a value indicating whether [condition resurrect battle pets].
IsInBattle | Gets a value indicating whether is in battle.
ReviveBattlePetsIsUsable | Gets a value indicating whether revive battle pets is usable.

See Also

PetBattles Class
wManager.Wow.Helpers Namespace


CanBattlePet Property

PetBattles..::..CanBattlePet Property

Gets a value indicating whether can battle pet.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool CanBattlePet { get; }
Public Shared ReadOnly Property CanBattlePet As Boolean
    Get
public:
static property bool^ CanBattlePet {
    bool^ get ();
}

Field Value

true if can battle pet; otherwise, false.

See Also

PetBattles Class
wManager.Wow.Helpers Namespace


ConditionResurrectBattlePets Property

PetBattles..::..ConditionResurrectBattlePets Property

Gets a value indicating whether [condition resurrect battle pets].

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool ConditionResurrectBattlePets { get; }
Public Shared ReadOnly Property ConditionResurrectBattlePets As Boolean
    Get
public:
static property bool^ ConditionResurrectBattlePets {
    bool^ get ();
}

Field Value

true if [condition resurrect battle pets]; otherwise, false.

See Also

PetBattles Class
wManager.Wow.Helpers Namespace


IsInBattle Property

PetBattles..::..IsInBattle Property

Gets a value indicating whether is in battle.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool IsInBattle { get; }
Public Shared ReadOnly Property IsInBattle As Boolean
    Get
public:
static property bool^ IsInBattle {
    bool^ get ();
}

Field Value

true if is in battle; otherwise, false.

See Also

PetBattles Class
wManager.Wow.Helpers Namespace


ReviveBattlePetsIsUsable Property

PetBattles..::..ReviveBattlePetsIsUsable Property

Gets a value indicating whether revive battle pets is usable.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool ReviveBattlePetsIsUsable { get; }
Public Shared ReadOnly Property ReviveBattlePetsIsUsable As Boolean
    Get
public:
static property bool^ ReviveBattlePetsIsUsable {
    bool^ get ();
}

Field Value

true if revive battle pets is usable; otherwise, false.

See Also

PetBattles Class
wManager.Wow.Helpers Namespace


PetBattles.AbilityInfo Structure

PetBattles..::..AbilityInfo Structure

Struct AbilityInfo PetBattles

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public struct AbilityInfo
Public Structure AbilityInfo
public value class AbilityInfo

See Also

PetBattles..::..AbilityInfo Members
wManager.Wow.Helpers Namespace


PetBattles.AbilityInfo Members

PetBattles..::..AbilityInfo Members

The PetBattles..::..AbilityInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from ValueType.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from ValueType.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from ValueType.)

Fields

 | Name | Description
Public field | AbilityPetType | The ability type
Public field | Description | The description
Public field | Icon | The icon
Public field | ID | The id
Public field | MaxCooldown | The maximum cooldown
Public field | Name | The name
Public field | NoStrongWeakHints | The no strong weak hints
Public field | NumTurns | The number turns

See Also

PetBattles..::..AbilityInfo Structure
wManager.Wow.Helpers Namespace


PetBattles.AbilityInfo Fields

PetBattles..::..AbilityInfo Fields

The PetBattles..::..AbilityInfo type exposes the following members.

Fields

 | Name | Description
Public field | AbilityPetType | The ability type
Public field | Description | The description
Public field | Icon | The icon
Public field | ID | The id
Public field | MaxCooldown | The maximum cooldown
Public field | Name | The name
Public field | NoStrongWeakHints | The no strong weak hints
Public field | NumTurns | The number turns

See Also

PetBattles..::..AbilityInfo Structure
wManager.Wow.Helpers Namespace


AbilityPetType Field

AbilityInfo..::..AbilityPetType Field

The ability type

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public PetBattles..::..PetType AbilityPetType
Public AbilityPetType As PetBattles..::..PetType
public:
PetBattles..::..PetType^ AbilityPetType

See Also

PetBattles..::..AbilityInfo Structure
wManager.Wow.Helpers Namespace


Description Field

AbilityInfo..::..Description Field

The description

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string Description
Public Description As String
public:
String^ Description

See Also

PetBattles..::..AbilityInfo Structure
wManager.Wow.Helpers Namespace


Icon Field

AbilityInfo..::..Icon Field

The icon

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string Icon
Public Icon As String
public:
String^ Icon

See Also

PetBattles..::..AbilityInfo Structure
wManager.Wow.Helpers Namespace


ID Field

AbilityInfo..::..ID Field

The id

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int ID
Public ID As Integer
public:
int^ ID

See Also

PetBattles..::..AbilityInfo Structure
wManager.Wow.Helpers Namespace


MaxCooldown Field

AbilityInfo..::..MaxCooldown Field

The maximum cooldown

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int MaxCooldown
Public MaxCooldown As Integer
public:
int^ MaxCooldown

See Also

PetBattles..::..AbilityInfo Structure
wManager.Wow.Helpers Namespace


Name Field

AbilityInfo..::..Name Field

The name

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string Name
Public Name As String
public:
String^ Name

See Also

PetBattles..::..AbilityInfo Structure
wManager.Wow.Helpers Namespace


NoStrongWeakHints Field

AbilityInfo..::..NoStrongWeakHints Field

The no strong weak hints

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string NoStrongWeakHints
Public NoStrongWeakHints As String
public:
String^ NoStrongWeakHints

See Also

PetBattles..::..AbilityInfo Structure
wManager.Wow.Helpers Namespace


NumTurns Field

AbilityInfo..::..NumTurns Field

The number turns

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int NumTurns
Public NumTurns As Integer
public:
int^ NumTurns

See Also

PetBattles..::..AbilityInfo Structure
wManager.Wow.Helpers Namespace


PetBattles.AbilityInfo Methods

PetBattles..::..AbilityInfo Methods

The PetBattles..::..AbilityInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from ValueType.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from ValueType.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from ValueType.)

See Also

PetBattles..::..AbilityInfo Structure
wManager.Wow.Helpers Namespace


PetBattles.ModiferEffects Class

PetBattles..::..ModiferEffects Class

Class ModiferEffects.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class ModiferEffects
Public Class ModiferEffects
public ref class ModiferEffects

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..PetBattles..::..ModiferEffects

See Also

PetBattles..::..ModiferEffects Members
wManager.Wow.Helpers Namespace


PetBattles.ModiferEffects Members

PetBattles..::..ModiferEffects Members

The PetBattles..::..ModiferEffects type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | Strong | The strong
Public field | Type | The type
Public field | Weak | The weak

See Also

PetBattles..::..ModiferEffects Class
wManager.Wow.Helpers Namespace


PetBattles.ModiferEffects Fields

PetBattles..::..ModiferEffects Fields

The PetBattles..::..ModiferEffects type exposes the following members.

Fields

 | Name | Description
Public field | Strong | The strong
Public field | Type | The type
Public field | Weak | The weak

See Also

PetBattles..::..ModiferEffects Class
wManager.Wow.Helpers Namespace


Strong Field

ModiferEffects..::..Strong Field

The strong

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public PetBattles..::..PetType Strong
Public Strong As PetBattles..::..PetType
public:
PetBattles..::..PetType^ Strong

See Also

PetBattles..::..ModiferEffects Class
wManager.Wow.Helpers Namespace


Type Field

ModiferEffects..::..Type Field

The type

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public PetBattles..::..PetType Type
Public Type As PetBattles..::..PetType
public:
PetBattles..::..PetType^ Type

See Also

PetBattles..::..ModiferEffects Class
wManager.Wow.Helpers Namespace


Weak Field

ModiferEffects..::..Weak Field

The weak

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public PetBattles..::..PetType Weak
Public Weak As PetBattles..::..PetType
public:
PetBattles..::..PetType^ Weak

See Also

PetBattles..::..ModiferEffects Class
wManager.Wow.Helpers Namespace


PetBattles.ModiferEffects Methods

PetBattles..::..ModiferEffects Methods

The PetBattles..::..ModiferEffects type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

PetBattles..::..ModiferEffects Class
wManager.Wow.Helpers Namespace


PetBattles.PetFaction Enumeration

PetBattles..::..PetFaction Enumeration

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public enum PetFaction
Public Enumeration PetFaction
public enum class PetFaction

Members

Member name | Description
Ally | The ally
Enemy | The enemy

See Also

wManager.Wow.Helpers Namespace


PetBattles.PetQuality Enumeration

PetBattles..::..PetQuality Enumeration

PetQuality PetBattles

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public enum PetQuality
Public Enumeration PetQuality
public enum class PetQuality

Members

Member name | Description
Poor |
Common |
Uncommon |
Rare |
Epic |
Legendary |

See Also

wManager.Wow.Helpers Namespace


PetBattles.PetType Enumeration

PetBattles..::..PetType Enumeration

PetType PetBattles

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public enum PetType
Public Enumeration PetType
public enum class PetType

Members

Member name | Description
Humanoid |
Dragonkin |
Flying |
Undead |
Critter |
Magic |
Elemental |
Beast |
Aquatic |
Mechanical |

See Also

wManager.Wow.Helpers Namespace


Prospecting Class

Class Prospecting.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class Prospecting
Public NotInheritable Class Prospecting
public ref class Prospecting abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..Prospecting

See Also

Prospecting Members
wManager.Wow.Helpers Namespace


Prospecting Members

The Prospecting type exposes the following members.

Methods

Name | Description
NeedRun | Needs the run.
Pulse | Prospecting specified items.

See Also

Prospecting Class
wManager.Wow.Helpers Namespace


Prospecting Methods

The Prospecting type exposes the following members.

Methods

Name | Description
NeedRun | Needs the run.
Pulse | Prospecting specified items.

See Also

Prospecting Class
wManager.Wow.Helpers Namespace


NeedRun Method

Prospecting..::..NeedRun Method

Needs the run.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool NeedRun(
    List<string> itemsParse
)
Public Shared Function NeedRun ( _
    itemsParse As List(Of String) _
) As Boolean
public:
static bool^ NeedRun(
    List<String^>^ itemsParse
)

Parameters

itemsParse
Type: List <(Of <(<' String >)>)>
The items parse.

Return Value

true if need to run, false otherwise.

See Also

Prospecting Class
wManager.Wow.Helpers Namespace


Pulse Method

Prospecting..::..Pulse Method

Prospecting specified items.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void Pulse(
    List<string> itemsParse
)
Public Shared Sub Pulse ( _
    itemsParse As List(Of String) _
)
public:
static void Pulse(
    List<String^>^ itemsParse
)

Parameters

itemsParse
Type: List <(Of <(<' String >)>)>
The items.

See Also

Prospecting Class
wManager.Wow.Helpers Namespace


Quest Class

Class Quest. Useful method for game quests and Quester product.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class Quest
Public NotInheritable Class Quest
public ref class Quest abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..Quest

See Also

Quest Members
wManager.Wow.Helpers Namespace


Quest Members

The Quest type exposes the following members.

Methods

Name | Description
AbandonLastQuest | Abandon last quest.
AcceptQuest | Accept quest.
CloseQuestWindow | Close quest window.
CompleteQuest | Complete the quest.
ConsumeQuestsCompletedRequest | Update FinishedQuestSet.
GetLogQuestId | Get game quest log.
GetLogQuestIsComplete | Check if quest id is complete.
GetNumGossipActiveQuests | Returns the number of active quests that you should eventually turn in to this NPC.
GetNumGossipAvailableQuests | Returns the number of quests (that you are not already on) offered by this NPC.
GetQuestCompleted(List<(Of <<'(Int32>)>>)) | Check if one of the quest id is completed.
GetQuestCompleted(Int32) | Check if quest id is completed.
HasQuest | Determine whether has the specified quest id.
IsObjectiveComplete | Determine whether quest objective is complete.
RequestQuestsCompleted | Update FinishedQuestSet if not in progress.
SelectGossipActiveQuest | Selects an active quest from a gossip list.
SelectGossipAvailableQuest | Selects an available quest from a gossip list.
SelectGossipOption | Selects a gossip (conversation) option.

Fields

Name | Description
FinishedQuestSet | List of quests id completed (better to use GetQuestCompleted(List<(Of <<'(Int32>)>>)) or GetQuestCompleted(List<(Of <<'(Int32>)>>)))

See Also

Quest Class
wManager.Wow.Helpers Namespace


Quest Fields

The Quest type exposes the following members.

Fields

Name | Description
FinishedQuestSet | List of quests id completed (better to use GetQuestCompleted(List<(Of <<'(Int32>)>>)) or GetQuestCompleted(List<(Of <<'(Int32>)>>)))

See Also

Quest Class
wManager.Wow.Helpers Namespace


FinishedQuestSet Field

Quest..::..FinishedQuestSet Field

List of quests id completed (better to use GetQuestCompleted(List<(Of <<'(Int32>)>>)) or GetQuestCompleted(List<(Of <<'(Int32>)>>)))

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static HashSet<int> FinishedQuestSet
Public Shared FinishedQuestSet As HashSet(Of Integer)
public:
static HashSet<int^>^ FinishedQuestSet

See Also

Quest Class
wManager.Wow.Helpers Namespace


Quest Methods

The Quest type exposes the following members.

Methods

Name | Description
AbandonLastQuest | Abandon last quest.
AcceptQuest | Accept quest.
CloseQuestWindow | Close quest window.
CompleteQuest | Complete the quest.
ConsumeQuestsCompletedRequest | Update FinishedQuestSet.
GetLogQuestId | Get game quest log.
GetLogQuestIsComplete | Check if quest id is complete.
GetNumGossipActiveQuests | Returns the number of active quests that you should eventually turn in to this NPC.
GetNumGossipAvailableQuests | Returns the number of quests (that you are not already on) offered by this NPC.
GetQuestCompleted(List<(Of <<'(Int32>)>>)) | Check if one of the quest id is completed.
GetQuestCompleted(Int32) | Check if quest id is completed.
HasQuest | Determine whether has the specified quest id.
IsObjectiveComplete | Determine whether quest objective is complete.
RequestQuestsCompleted | Update FinishedQuestSet if not in progress.
SelectGossipActiveQuest | Selects an active quest from a gossip list.
SelectGossipAvailableQuest | Selects an available quest from a gossip list.
SelectGossipOption | Selects a gossip (conversation) option.

See Also

Quest Class
wManager.Wow.Helpers Namespace


AbandonLastQuest Method

Quest..::..AbandonLastQuest Method

Abandon last quest.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void AbandonLastQuest()
Public Shared Sub AbandonLastQuest
public:
static void AbandonLastQuest()

See Also

Quest Class
wManager.Wow.Helpers Namespace


AcceptQuest Method

Quest..::..AcceptQuest Method

Accept quest.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void AcceptQuest()
Public Shared Sub AcceptQuest
public:
static void AcceptQuest()

See Also

Quest Class
wManager.Wow.Helpers Namespace


CloseQuestWindow Method

Quest..::..CloseQuestWindow Method

Close quest window.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void CloseQuestWindow()
Public Shared Sub CloseQuestWindow
public:
static void CloseQuestWindow()

See Also

Quest Class
wManager.Wow.Helpers Namespace


CompleteQuest Method

Quest..::..CompleteQuest Method

Complete the quest.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void CompleteQuest(
    int gossipOptionItem
)
Public Shared Sub CompleteQuest ( _
    gossipOptionItem As Integer _
)
public:
static void CompleteQuest(
    int^ gossipOptionItem
)

Parameters

gossipOptionItem
Type: Int32
The gossip option item.

See Also

Quest Class
wManager.Wow.Helpers Namespace


ConsumeQuestsCompletedRequest Method

Quest..::..ConsumeQuestsCompletedRequest Method

Update FinishedQuestSet.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void ConsumeQuestsCompletedRequest()
Public Shared Sub ConsumeQuestsCompletedRequest
public:
static void ConsumeQuestsCompletedRequest()

See Also

Quest Class
wManager.Wow.Helpers Namespace


GetLogQuestId Method

Quest..::..GetLogQuestId Method

Get game quest log.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<Quest..::..PlayerQuest> GetLogQuestId()
Public Shared Function GetLogQuestId As List(Of Quest..::..PlayerQuest)
public:
static List<Quest..::..PlayerQuest^>^ GetLogQuestId()

Return Value

current quest log.

See Also

Quest Class
wManager.Wow.Helpers Namespace


GetLogQuestIsComplete Method

Quest..::..GetLogQuestIsComplete Method

Check if quest id is complete.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool GetLogQuestIsComplete(
    int questId
)
Public Shared Function GetLogQuestIsComplete ( _
    questId As Integer _
) As Boolean
public:
static bool^ GetLogQuestIsComplete(
    int^ questId
)

Parameters

questId
Type: Int32
The quest id.

See Also

Quest Class
wManager.Wow.Helpers Namespace


GetNumGossipActiveQuests Method

Quest..::..GetNumGossipActiveQuests Method

Returns the number of active quests that you should eventually turn in to this NPC.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int GetNumGossipActiveQuests()
Public Shared Function GetNumGossipActiveQuests As Integer
public:
static int^ GetNumGossipActiveQuests()

Return Value

number.

See Also

Quest Class
wManager.Wow.Helpers Namespace


GetNumGossipAvailableQuests Method

Quest..::..GetNumGossipAvailableQuests Method

Returns the number of quests (that you are not already on) offered by this NPC.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int GetNumGossipAvailableQuests()
Public Shared Function GetNumGossipAvailableQuests As Integer
public:
static int^ GetNumGossipAvailableQuests()

Return Value

number.

See Also

Quest Class
wManager.Wow.Helpers Namespace


GetQuestCompleted Method

Quest..::..GetQuestCompleted Method

Overload List

Name | Description
GetQuestCompleted(List<(Of <<'(Int32>)>>)) | Check if one of the quest id is completed.
GetQuestCompleted(Int32) | Check if quest id is completed.

See Also

Quest Class
Quest Members
wManager.Wow.Helpers Namespace


GetQuestCompleted Method (List(Int32))

Quest..::..GetQuestCompleted Method (List<(Of <(<'Int32>)>)>)

Check if one of the quest id is completed.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool GetQuestCompleted(
    List<int> qList
)
Public Shared Function GetQuestCompleted ( _
    qList As List(Of Integer) _
) As Boolean
public:
static bool^ GetQuestCompleted(
    List<int^>^ qList
)

Parameters

qList
Type: List <(Of <(<' Int32 >)>)>
The quest id list.

Return Value

true if any quest completed, false otherwise.

See Also

Quest Class
GetQuestCompleted Overload
wManager.Wow.Helpers Namespace


GetQuestCompleted Method (Int32)

Quest..::..GetQuestCompleted Method (Int32)

Check if quest id is completed.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool GetQuestCompleted(
    int questId
)
Public Shared Function GetQuestCompleted ( _
    questId As Integer _
) As Boolean
public:
static bool^ GetQuestCompleted(
    int^ questId
)

Parameters

questId
Type: Int32
The quest id.

Return Value

true if quest completed, false otherwise.

See Also

Quest Class
GetQuestCompleted Overload
wManager.Wow.Helpers Namespace


HasQuest Method

Quest..::..HasQuest Method

Determine whether has the specified quest id.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool HasQuest(
    int questId
)
Public Shared Function HasQuest ( _
    questId As Integer _
) As Boolean
public:
static bool^ HasQuest(
    int^ questId
)

Parameters

questId
Type: Int32
The quest id.

Return Value

true if has quest; otherwise, false.

See Also

Quest Class
wManager.Wow.Helpers Namespace


IsObjectiveComplete Method

Quest..::..IsObjectiveComplete Method

Determine whether quest objective is complete.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool IsObjectiveComplete(
    int objectiveIndex,
    int questID
)
Public Shared Function IsObjectiveComplete ( _
    objectiveIndex As Integer, _
    questID As Integer _
) As Boolean
public:
static bool^ IsObjectiveComplete(
    int^ objectiveIndex,
    int^ questID
)

Parameters

objectiveIndex
Type: Int32
Index of the quest objective.
questID
Type: Int32
The quest id.

Return Value

true if objective is complete; otherwise, false.

See Also

Quest Class
wManager.Wow.Helpers Namespace


RequestQuestsCompleted Method

Quest..::..RequestQuestsCompleted Method

Update FinishedQuestSet if not in progress.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void RequestQuestsCompleted()
Public Shared Sub RequestQuestsCompleted
public:
static void RequestQuestsCompleted()

See Also

Quest Class
wManager.Wow.Helpers Namespace


SelectGossipActiveQuest Method

Quest..::..SelectGossipActiveQuest Method

Selects an active quest from a gossip list.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void SelectGossipActiveQuest(
    int gossipOption
)
Public Shared Sub SelectGossipActiveQuest ( _
    gossipOption As Integer _
)
public:
static void SelectGossipActiveQuest(
    int^ gossipOption
)

Parameters

gossipOption
Type: Int32
- Ranging from 1 to [GetNumActiveQuests()].

See Also

Quest Class
wManager.Wow.Helpers Namespace


SelectGossipAvailableQuest Method

Quest..::..SelectGossipAvailableQuest Method

Selects an available quest from a gossip list.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void SelectGossipAvailableQuest(
    int gossipOption
)
Public Shared Sub SelectGossipAvailableQuest ( _
    gossipOption As Integer _
)
public:
static void SelectGossipAvailableQuest(
    int^ gossipOption
)

Parameters

gossipOption
Type: Int32
Ranging from 1 to GetNumGossipAvailableQuests()()()().

See Also

Quest Class
wManager.Wow.Helpers Namespace


SelectGossipOption Method

Quest..::..SelectGossipOption Method

Selects a gossip (conversation) option.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void SelectGossipOption(
    int gossipOption
)
Public Shared Sub SelectGossipOption ( _
    gossipOption As Integer _
)
public:
static void SelectGossipOption(
    int^ gossipOption
)

Parameters

gossipOption
Type: Int32
Ranging from 1

See Also

Quest Class
wManager.Wow.Helpers Namespace


Quest.PlayerQuest Structure

Quest..::..PlayerQuest Structure

Struct PlayerQuest

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[StructLayoutAttribute]
public struct PlayerQuest
<StructLayoutAttribute> _
Public Structure PlayerQuest
[StructLayoutAttribute]
public value class PlayerQuest

See Also

Quest..::..PlayerQuest Members
wManager.Wow.Helpers Namespace


Quest.PlayerQuest Members

Quest..::..PlayerQuest Members

The Quest..::..PlayerQuest type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from ValueType.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from ValueType.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from ValueType.)

Fields

 | Name | Description
Public field | ID | The quest id
Public field | ObjectiveRequiredCounts | The status of the objectives
Public field | State | The quest state (unreliable)
Public field | Time | The time

See Also

Quest..::..PlayerQuest Structure
wManager.Wow.Helpers Namespace


Quest.PlayerQuest Fields

Quest..::..PlayerQuest Fields

The Quest..::..PlayerQuest type exposes the following members.

Fields

 | Name | Description
Public field | ID | The quest id
Public field | ObjectiveRequiredCounts | The status of the objectives
Public field | State | The quest state (unreliable)
Public field | Time | The time

See Also

Quest..::..PlayerQuest Structure
wManager.Wow.Helpers Namespace


ID Field

PlayerQuest..::..ID Field

The quest id

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int ID
Public ID As Integer
public:
int^ ID

See Also

Quest..::..PlayerQuest Structure
wManager.Wow.Helpers Namespace


ObjectiveRequiredCounts Field

PlayerQuest..::..ObjectiveRequiredCounts Field

The status of the objectives

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[MarshalAsAttribute]
public short[] ObjectiveRequiredCounts
<MarshalAsAttribute> _
Public ObjectiveRequiredCounts As Short()
[MarshalAsAttribute]
public:
array<short^>^ ObjectiveRequiredCounts

See Also

Quest..::..PlayerQuest Structure
wManager.Wow.Helpers Namespace


State Field

PlayerQuest..::..State Field

The quest state (unreliable)

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Quest..::..PlayerQuest..::..StateFlag State
Public State As Quest..::..PlayerQuest..::..StateFlag
public:
Quest..::..PlayerQuest..::..StateFlag^ State

See Also

Quest..::..PlayerQuest Structure
wManager.Wow.Helpers Namespace


Complete Field

StateFlag..::..Complete Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Quest..::..PlayerQuest..::..StateFlag Complete
Public Const Complete As Quest..::..PlayerQuest..::..StateFlag
public:
literal Quest..::..PlayerQuest..::..StateFlag Complete

See Also

Quest..::..PlayerQuest..::..StateFlag Enumeration
wManager.Wow.Helpers Namespace


Failed Field

StateFlag..::..Failed Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Quest..::..PlayerQuest..::..StateFlag Failed
Public Const Failed As Quest..::..PlayerQuest..::..StateFlag
public:
literal Quest..::..PlayerQuest..::..StateFlag Failed

See Also

Quest..::..PlayerQuest..::..StateFlag Enumeration
wManager.Wow.Helpers Namespace


None Field

StateFlag..::..None Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Quest..::..PlayerQuest..::..StateFlag None
Public Const None As Quest..::..PlayerQuest..::..StateFlag
public:
literal Quest..::..PlayerQuest..::..StateFlag None

See Also

Quest..::..PlayerQuest..::..StateFlag Enumeration
wManager.Wow.Helpers Namespace


Time Field

PlayerQuest..::..Time Field

The time

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int Time
Public Time As Integer
public:
int^ Time

See Also

Quest..::..PlayerQuest Structure
wManager.Wow.Helpers Namespace


Quest.PlayerQuest Methods

Quest..::..PlayerQuest Methods

The Quest..::..PlayerQuest type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from ValueType.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from ValueType.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from ValueType.)

See Also

Quest..::..PlayerQuest Structure
wManager.Wow.Helpers Namespace


PlayerQuest.StateFlag Enumeration

PlayerQuest..::..StateFlag Enumeration

StateFlag

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public enum StateFlag
Public Enumeration StateFlag
public enum class StateFlag

Members

Member name | Description
None |
Complete |
Failed |

See Also

wManager.Wow.Helpers Namespace


Quest.QuesterCurrentContext Class

Quest..::..QuesterCurrentContext Class

Class QuesterCurrentContext, "Quester" product use this class to store profile and profile state.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class QuesterCurrentContext
Public NotInheritable Class QuesterCurrentContext
public ref class QuesterCurrentContext abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..Quest..::..QuesterCurrentContext

See Also

Quest..::..QuesterCurrentContext Members
wManager.Wow.Helpers Namespace


Quest.QuesterCurrentContext Members

Quest..::..QuesterCurrentContext Members

The Quest..::..QuesterCurrentContext type exposes the following members.

Methods

Name Description

Fields

Name | Description
CodeNamespace | The code namespace (Xml is converted to C# code, this c# code use this namespace). New namespace is generated when a profile is loaded.
CurrentStep | The current step (example usage: (Quest.QuesterCurrentContext.Profile as Quester.Profile.EasyQuestProfile).QuestsSorted[Quest.QuesterCurrentContext.CurrentStep])
NPCList | The NPC list (of current profile)
Profile | The profile (generally it is [Quester.Profile.EasyQuestProfile]wManager.Wow.Helpers.Quest.QuesterCurrentContext.Profile as Quester.Profile.EasyQuestProfile)
ProfileName | The profile name (like "FileName.xml", relative to "WRobot\Profiles\Quester\")
QuestsClasses | The quests classes
SkipPickUpQuestAfterXSecondes | Seconds to wait before to skip quest if cannot pickup.

See Also

Quest..::..QuesterCurrentContext Class
wManager.Wow.Helpers Namespace


Quest.QuesterCurrentContext Fields

Quest..::..QuesterCurrentContext Fields

The Quest..::..QuesterCurrentContext type exposes the following members.

Fields

Name | Description
CodeNamespace | The code namespace (Xml is converted to C# code, this c# code use this namespace). New namespace is generated when a profile is loaded.
CurrentStep | The current step (example usage: (Quest.QuesterCurrentContext.Profile as Quester.Profile.EasyQuestProfile).QuestsSorted[Quest.QuesterCurrentContext.CurrentStep])
NPCList | The NPC list (of current profile)
Profile | The profile (generally it is [Quester.Profile.EasyQuestProfile]wManager.Wow.Helpers.Quest.QuesterCurrentContext.Profile as Quester.Profile.EasyQuestProfile)
ProfileName | The profile name (like "FileName.xml", relative to "WRobot\Profiles\Quester\")
QuestsClasses | The quests classes
SkipPickUpQuestAfterXSecondes | Seconds to wait before to skip quest if cannot pickup.

See Also

Quest..::..QuesterCurrentContext Class
wManager.Wow.Helpers Namespace


CodeNamespace Field

QuesterCurrentContext..::..CodeNamespace Field

The code namespace (Xml is converted to C# code, this c# code use this namespace). New namespace is generated when a profile is loaded.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string CodeNamespace
Public Shared CodeNamespace As String
public:
static String^ CodeNamespace

See Also

Quest..::..QuesterCurrentContext Class
wManager.Wow.Helpers Namespace


CurrentStep Field

QuesterCurrentContext..::..CurrentStep Field

The current step (example usage: (Quest.QuesterCurrentContext.Profile as Quester.Profile.EasyQuestProfile).QuestsSorted[Quest.QuesterCurrentContext.CurrentStep])

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int CurrentStep
Public Shared CurrentStep As Integer
public:
static int^ CurrentStep

See Also

Quest..::..QuesterCurrentContext Class
wManager.Wow.Helpers Namespace


NPCList Field

QuesterCurrentContext..::..NPCList Field

The NPC list (of current profile)

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<NPCQuest> NPCList
Public Shared NPCList As List(Of NPCQuest)
public:
static List<NPCQuest^>^ NPCList

See Also

Quest..::..QuesterCurrentContext Class
wManager.Wow.Helpers Namespace


Profile Field

QuesterCurrentContext..::..Profile Field

The profile (generally it is [Quester.Profile.EasyQuestProfile]wManager.Wow.Helpers.Quest.QuesterCurrentContext.Profile as Quester.Profile.EasyQuestProfile)

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static Object Profile
Public Shared Profile As Object
public:
static Object^ Profile

See Also

Quest..::..QuesterCurrentContext Class
wManager.Wow.Helpers Namespace


ProfileName Field

QuesterCurrentContext..::..ProfileName Field

The profile name (like "FileName.xml", relative to "WRobot\Profiles\Quester\")

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string ProfileName
Public Shared ProfileName As String
public:
static String^ ProfileName

See Also

Quest..::..QuesterCurrentContext Class
wManager.Wow.Helpers Namespace


QuestsClasses Field

QuesterCurrentContext..::..QuestsClasses Field

The quests classes

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static Dictionary<string, QuestClass> QuestsClasses
Public Shared QuestsClasses As Dictionary(Of String, QuestClass)
public:
static Dictionary<String^, QuestClass^>^ QuestsClasses

See Also

Quest..::..QuesterCurrentContext Class
wManager.Wow.Helpers Namespace


SkipPickUpQuestAfterXSecondes Field

QuesterCurrentContext..::..SkipPickUpQuestAfterXSecondes Field

Seconds to wait before to skip quest if cannot pickup.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static long SkipPickUpQuestAfterXSecondes
Public Shared SkipPickUpQuestAfterXSecondes As Long
public:
static long long^ SkipPickUpQuestAfterXSecondes

See Also

Quest..::..QuesterCurrentContext Class
wManager.Wow.Helpers Namespace


Quest.QuesterCurrentContext Methods

Quest..::..QuesterCurrentContext Methods

The Quest..::..QuesterCurrentContext type exposes the following members.

Methods

Name Description

See Also

Quest..::..QuesterCurrentContext Class
wManager.Wow.Helpers Namespace


Radar3D Class

Class Radar3D. Create overlay transparent window to show bot elements in game. Used when option "Radar 3D" is enabled tab "Map".

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class Radar3D
Public NotInheritable Class Radar3D
public ref class Radar3D abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..Radar3D

See Also

Radar3D Members
wManager.Wow.Helpers Namespace


Radar3D Members

The Radar3D type exposes the following members.

Methods

Name | Description
DrawCircle | Draw circle (call this method when OnDrawEvent is called).
DrawLine | Draw line (call this method when OnDrawEvent is called).
DrawString | Draw string (call this method when OnDrawEvent is called).
Pulse | Active radar 3d.
Stop | Stop radar 3d.

Properties

Name | Description
DeviceDX | Gets the directx device (if you need to draw custom objects, add them when OnDrawEvent is called).
IsLaunched | Gets a value indicating whether this instance is launched.

Events

Name | Description
OnDrawEvent | Occurs before to draw scene (add all objects to draw when this event is called).

See Also

Radar3D Class
wManager.Wow.Helpers Namespace


Radar3D Methods

The Radar3D type exposes the following members.

Methods

Name | Description
DrawCircle | Draw circle (call this method when OnDrawEvent is called).
DrawLine | Draw line (call this method when OnDrawEvent is called).
DrawString | Draw string (call this method when OnDrawEvent is called).
Pulse | Active radar 3d.
Stop | Stop radar 3d.

See Also

Radar3D Class
wManager.Wow.Helpers Namespace


DrawCircle Method

Radar3D..::..DrawCircle Method

Draw circle (call this method when OnDrawEvent is called).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void DrawCircle(
    Vector3 center,
    float radius,
    Color color,
    bool filled,
    int alpha
)
Public Shared Sub DrawCircle ( _
    center As Vector3, _
    radius As Single, _
    color As Color, _
    filled As Boolean, _
    alpha As Integer _
)
public:
static void DrawCircle(
    Vector3^ center,
    float^ radius,
    Color^ color,
    bool^ filled,
    int^ alpha
)

Parameters

center
Type: robotManager.Helpful..::..Vector3
The center.
radius
Type: Single
The radius.
color
Type: Color
The color.
filled
Type: Boolean
if set to true is filled.
alpha
Type: Int32
The alpha.

See Also

Radar3D Class
wManager.Wow.Helpers Namespace


DrawLine Method

Radar3D..::..DrawLine Method

Draw line (call this method when OnDrawEvent is called).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void DrawLine(
    Vector3 from,
    Vector3 to,
    Color color,
    int alpha
)
Public Shared Sub DrawLine ( _
    from As Vector3, _
    to As Vector3, _
    color As Color, _
    alpha As Integer _
)
public:
static void DrawLine(
    Vector3^ from,
    Vector3^ to,
    Color^ color,
    int^ alpha
)

Parameters

from
Type: robotManager.Helpful..::..Vector3
From.
to
Type: robotManager.Helpful..::..Vector3
To.
color
Type: Color
The color.
alpha
Type: Int32
The alpha.

See Also

Radar3D Class
wManager.Wow.Helpers Namespace


DrawString Method

Radar3D..::..DrawString Method

Draw string (call this method when OnDrawEvent is called).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void DrawString(
    string text,
    Vector3 screenPosition,
    float size,
    Color color,
    int alpha,
    FontFamily fontFamily
)
Public Shared Sub DrawString ( _
    text As String, _
    screenPosition As Vector3, _
    size As Single, _
    color As Color, _
    alpha As Integer, _
    fontFamily As FontFamily _
)
public:
static void DrawString(
    String^ text,
    Vector3^ screenPosition,
    float^ size,
    Color^ color,
    int^ alpha,
    FontFamily^ fontFamily
)

Parameters

text
Type: String
The text.
screenPosition
Type: robotManager.Helpful..::..Vector3
The screen position.
size
Type: Single
The size.
color
Type: Color
The color.
alpha
Type: Int32
The alpha.
fontFamily
Type: FontFamily
The font family.

See Also

Radar3D Class
wManager.Wow.Helpers Namespace


Pulse Method

Radar3D..::..Pulse Method

Active radar 3d.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool Pulse()
Public Shared Function Pulse As Boolean
public:
static bool^ Pulse()

Return Value

true if XXXX, false otherwise.

See Also

Radar3D Class
wManager.Wow.Helpers Namespace


Stop Method

Radar3D..::..Stop Method

Stop radar 3d.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool Stop()
Public Shared Function Stop As Boolean
public:
static bool^ Stop()

Return Value

true if XXXX, false otherwise.

See Also

Radar3D Class
wManager.Wow.Helpers Namespace


Radar3D Properties

The Radar3D type exposes the following members.

Properties

Name | Description
DeviceDX | Gets the directx device (if you need to draw custom objects, add them when OnDrawEvent is called).
IsLaunched | Gets a value indicating whether this instance is launched.

See Also

Radar3D Class
wManager.Wow.Helpers Namespace


DeviceDX Property

Radar3D..::..DeviceDX Property

Gets the directx device (if you need to draw custom objects, add them when OnDrawEvent is called).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static Device DeviceDX { get; }
Public Shared ReadOnly Property DeviceDX As Device
    Get
public:
static property Device^ DeviceDX {
    Device^ get ();
}

Field Value

The directx device.

See Also

Radar3D Class
wManager.Wow.Helpers Namespace


IsLaunched Property

Radar3D..::..IsLaunched Property

Gets a value indicating whether this instance is launched.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool IsLaunched { get; }
Public Shared ReadOnly Property IsLaunched As Boolean
    Get
public:
static property bool^ IsLaunched {
    bool^ get ();
}

Field Value

true if this instance is launched; otherwise, false.

See Also

Radar3D Class
wManager.Wow.Helpers Namespace


Radar3D Events

The Radar3D type exposes the following members.

Events

Name | Description
OnDrawEvent | Occurs before to draw scene (add all objects to draw when this event is called).

See Also

Radar3D Class
wManager.Wow.Helpers Namespace


OnDrawEvent Event

Radar3D..::..OnDrawEvent Event

Occurs before to draw scene (add all objects to draw when this event is called).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static event Radar3D..::..OnDrawHandler OnDrawEvent
Public Shared Event OnDrawEvent As Radar3D..::..OnDrawHandler
public:
static  event Radar3D..::..OnDrawHandler^ OnDrawEvent {
    void add (Radar3D..::..OnDrawHandler^ value);
    void remove (Radar3D..::..OnDrawHandler^ value);
}

See Also

Radar3D Class
wManager.Wow.Helpers Namespace


Radar3D.OnDrawHandler Delegate

Radar3D..::..OnDrawHandler Delegate

Delegate OnDrawHandler

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public delegate void OnDrawHandler()
Public Delegate Sub OnDrawHandler
public delegate void OnDrawHandler()

See Also

wManager.Wow.Helpers Namespace


RunCodeExtension Class

Class RunCodeExtension. Few useful methods to run script Implements the RunCode

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class RunCodeExtension : RunCode
Public Class RunCodeExtension _
    Inherits RunCode
public ref class RunCodeExtension : public RunCode

Inheritance Hierarchy

Object
robotManager.Helpful..::..RunCode
wManager.Wow.Helpers..::..RunCodeExtension

See Also

RunCodeExtension Members
wManager.Wow.Helpers Namespace
robotManager.Helpful..::..RunCode


RunCodeExtension Members

The RunCodeExtension type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
 | RunCsharpScript | Run C# script.
 | RunCsharpScriptWithCustomNamespace | Run C# script with additional namespaces.
 | RunLuaBotScript | Run LuaBot script.
 | RunScript | Run script.
 | RunVBScript | Run VB.net script.
 | RunVBScriptWithCustomNamespace | Run VB.net script with additional namespaces.
Public method | ToString | (Inherited from Object.)

See Also

RunCodeExtension Class
wManager.Wow.Helpers Namespace


RunCodeExtension Methods

The RunCodeExtension type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
 | RunCsharpScript | Run C# script.
 | RunCsharpScriptWithCustomNamespace | Run C# script with additional namespaces.
 | RunLuaBotScript | Run LuaBot script.
 | RunScript | Run script.
 | RunVBScript | Run VB.net script.
 | RunVBScriptWithCustomNamespace | Run VB.net script with additional namespaces.
Public method | ToString | (Inherited from Object.)

See Also

RunCodeExtension Class
wManager.Wow.Helpers Namespace


RunCsharpScript Method

RunCodeExtension..::..RunCsharpScript Method

Run C# script.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool RunCsharpScript(
    string code
)
Public Shared Function RunCsharpScript ( _
    code As String _
) As Boolean
public:
static bool^ RunCsharpScript(
    String^ code
)

Parameters

code
Type: String
The script, it is added in a method with a void return type.

Return Value

true if success, false otherwise.

See Also

RunCodeExtension Class
wManager.Wow.Helpers Namespace


RunCsharpScriptWithCustomNamespace Method

RunCodeExtension..::..RunCsharpScriptWithCustomNamespace Method

Run C# script with additional namespaces.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool RunCsharpScriptWithCustomNamespace(
    string code,
    string usingNamespaceAdditional
)
Public Shared Function RunCsharpScriptWithCustomNamespace ( _
    code As String, _
    usingNamespaceAdditional As String _
) As Boolean
public:
static bool^ RunCsharpScriptWithCustomNamespace(
    String^ code,
    String^ usingNamespaceAdditional
)

Parameters

code
Type: String
The script, it is added in a method with a void return type.
usingNamespaceAdditional
Type: String
Additional namespaces (the main namespaces of wManager and robotManager are already added).

Return Value

true if success, false otherwise.

See Also

RunCodeExtension Class
wManager.Wow.Helpers Namespace


RunLuaBotScript Method

RunCodeExtension..::..RunLuaBotScript Method

Run LuaBot script.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool RunLuaBotScript(
    string code
)
Public Shared Function RunLuaBotScript ( _
    code As String _
) As Boolean
public:
static bool^ RunLuaBotScript(
    String^ code
)

Parameters

code
Type: String
The code.

Return Value

true if success, false otherwise.

See Also

RunCodeExtension Class
wManager.Wow.Helpers Namespace


RunScript Method

RunCodeExtension..::..RunScript Method

Run script.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool RunScript(
    RunCode..::..CodeType codetype,
    string code,
    string usingNamespaceAdditional,
    out string errors
)
Public Shared Function RunScript ( _
    codetype As RunCode..::..CodeType, _
    code As String, _
    usingNamespaceAdditional As String, _
    <OutAttribute> ByRef errors As String _
) As Boolean
public:
static bool^ RunScript(
    RunCode..::..CodeType^ codetype,
    String^ code,
    String^ usingNamespaceAdditional,
    [OutAttribute] String^% errors
)

Parameters

codetype
Type: robotManager.Helpful..::..RunCode..::..CodeType
Code language.
code
Type: String
The script, it is added in a method with a void return type.
usingNamespaceAdditional
Type: String
Additional namespaces (the main namespaces of wManager and robotManager are already added).
errors
Type: String %
The errors (empty if no error).

Return Value

true if success, false otherwise.

See Also

RunCodeExtension Class
wManager.Wow.Helpers Namespace


RunVBScript Method

RunCodeExtension..::..RunVBScript Method

Run VB.net script.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool RunVBScript(
    string code
)
Public Shared Function RunVBScript ( _
    code As String _
) As Boolean
public:
static bool^ RunVBScript(
    String^ code
)

Parameters

code
Type: String
The script, it is added in a method with a void return type.

Return Value

true if success, false otherwise.

See Also

RunCodeExtension Class
wManager.Wow.Helpers Namespace


RunVBScriptWithCustomNamespace Method

RunCodeExtension..::..RunVBScriptWithCustomNamespace Method

Run VB.net script with additional namespaces.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool RunVBScriptWithCustomNamespace(
    string code,
    string usingNamespaceAdditional
)
Public Shared Function RunVBScriptWithCustomNamespace ( _
    code As String, _
    usingNamespaceAdditional As String _
) As Boolean
public:
static bool^ RunVBScriptWithCustomNamespace(
    String^ code,
    String^ usingNamespaceAdditional
)

Parameters

code
Type: String
The script, it is added in a method with a void return type.
usingNamespaceAdditional
Type: String
Additional namespaces (the main namespaces of wManager and robotManager are already added).

Return Value

true if success, false otherwise.

See Also

RunCodeExtension Class
wManager.Wow.Helpers Namespace


RunesManager Class

Class RunesManager.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class RunesManager
Public NotInheritable Class RunesManager
public ref class RunesManager abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..RunesManager

See Also

RunesManager Members
wManager.Wow.Helpers Namespace


RunesManager Members

The RunesManager type exposes the following members.

Methods

Name | Description
GetRune | Get rune.
GetRunes()()()() | Get runes.
GetRunes(RuneTypes) |
GetRunesReady()()()() | Get runes ready.
GetRunesReady(RuneTypes) |

See Also

RunesManager Class
wManager.Wow.Helpers Namespace


RunesManager Methods

The RunesManager type exposes the following members.

Methods

Name | Description
GetRune | Get rune.
GetRunes()()()() | Get runes.
GetRunes(RuneTypes) |
GetRunesReady()()()() | Get runes ready.
GetRunesReady(RuneTypes) |

See Also

RunesManager Class
wManager.Wow.Helpers Namespace


GetRune Method

RunesManager..::..GetRune Method

Get rune.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static RuneStruct GetRune(
    int id
)
Public Shared Function GetRune ( _
    id As Integer _
) As RuneStruct
public:
static RuneStruct^ GetRune(
    int^ id
)

Parameters

id
Type: Int32
The identifier.

Return Value

RuneStruct.

See Also

RunesManager Class
wManager.Wow.Helpers Namespace


GetRunes Method

RunesManager..::..GetRunes Method

Overload List

Name | Description
GetRunes()()()() | Get runes.
GetRunes(RuneTypes) |

See Also

RunesManager Class
RunesManager Members
wManager.Wow.Helpers Namespace


GetRunes Method

RunesManager..::..GetRunes Method

Get runes.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static RuneStruct[] GetRunes()
Public Shared Function GetRunes As RuneStruct()
public:
static array<RuneStruct^>^ GetRunes()

Return Value

RuneStruct[].

See Also

RunesManager Class
GetRunes Overload
wManager.Wow.Helpers Namespace


GetRunes Method (RuneTypes)

RunesManager..::..GetRunes Method (RuneTypes)

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<RuneStruct> GetRunes(
    RuneTypes type
)
Public Shared Function GetRunes ( _
    type As RuneTypes _
) As List(Of RuneStruct)
public:
static List<RuneStruct^>^ GetRunes(
    RuneTypes^ type
)

Parameters

type
Type: wManager.Wow.Enums..::..RuneTypes

See Also

RunesManager Class
GetRunes Overload
wManager.Wow.Helpers Namespace


GetRunesReady Method

RunesManager..::..GetRunesReady Method

Overload List

Name | Description
GetRunesReady()()()() | Get runes ready.
GetRunesReady(RuneTypes) |

See Also

RunesManager Class
RunesManager Members
wManager.Wow.Helpers Namespace


GetRunesReady Method

RunesManager..::..GetRunesReady Method

Get runes ready.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<RuneStruct> GetRunesReady()
Public Shared Function GetRunesReady As List(Of RuneStruct)
public:
static List<RuneStruct^>^ GetRunesReady()

Return Value

List<RuneStruct>.

See Also

RunesManager Class
GetRunesReady Overload
wManager.Wow.Helpers Namespace


GetRunesReady Method (RuneTypes)

RunesManager..::..GetRunesReady Method (RuneTypes)

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<RuneStruct> GetRunesReady(
    RuneTypes type
)
Public Shared Function GetRunesReady ( _
    type As RuneTypes _
) As List(Of RuneStruct)
public:
static List<RuneStruct^>^ GetRunesReady(
    RuneTypes^ type
)

Parameters

type
Type: wManager.Wow.Enums..::..RuneTypes

See Also

RunesManager Class
GetRunesReady Overload
wManager.Wow.Helpers Namespace


Skill Class

Class Skill.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class Skill
Public NotInheritable Class Skill
public ref class Skill abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..Skill

See Also

Skill Members
wManager.Wow.Helpers Namespace


Skill Members

The Skill type exposes the following members.

Methods

Name | Description
GetMaxValue | Get the maximum value.
GetValue | Get the value.
Has | Has skill.

See Also

Skill Class
wManager.Wow.Helpers Namespace


Skill Methods

The Skill type exposes the following members.

Methods

Name | Description
GetMaxValue | Get the maximum value.
GetValue | Get the value.
Has | Has skill.

See Also

Skill Class
wManager.Wow.Helpers Namespace


GetMaxValue Method

Skill..::..GetMaxValue Method

Get the maximum value.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int GetMaxValue(
    SkillLine skill
)
Public Shared Function GetMaxValue ( _
    skill As SkillLine _
) As Integer
public:
static int^ GetMaxValue(
    SkillLine^ skill
)

Parameters

skill
Type: wManager.Wow.Enums..::..SkillLine
The skill.

Return Value

value.

See Also

Skill Class
wManager.Wow.Helpers Namespace


GetValue Method

Skill..::..GetValue Method

Get the value.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int GetValue(
    SkillLine skill
)
Public Shared Function GetValue ( _
    skill As SkillLine _
) As Integer
public:
static int^ GetValue(
    SkillLine^ skill
)

Parameters

skill
Type: wManager.Wow.Enums..::..SkillLine
The skill.

Return Value

value.

See Also

Skill Class
wManager.Wow.Helpers Namespace


Has Method

Skill..::..Has Method

Has skill.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool Has(
    SkillLine skill
)
Public Shared Function Has ( _
    skill As SkillLine _
) As Boolean
public:
static bool^ Has(
    SkillLine^ skill
)

Parameters

skill
Type: wManager.Wow.Enums..::..SkillLine
The skill.

Return Value

has.

See Also

Skill Class
wManager.Wow.Helpers Namespace


Smelting Class

Class Smelting.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class Smelting
Public NotInheritable Class Smelting
public ref class Smelting abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..Smelting

See Also

Smelting Members
wManager.Wow.Helpers Namespace


Smelting Members

The Smelting type exposes the following members.

Methods

Name | Description
CloseSmeltingWindow | Close the smelting window.
NeedRun | Need the run.
OpenSmeltingWindow | Open the smelting window.
Pulse | Pulses Smelting.

See Also

Smelting Class
wManager.Wow.Helpers Namespace


Smelting Methods

The Smelting type exposes the following members.

Methods

Name | Description
CloseSmeltingWindow | Close the smelting window.
NeedRun | Need the run.
OpenSmeltingWindow | Open the smelting window.
Pulse | Pulses Smelting.

See Also

Smelting Class
wManager.Wow.Helpers Namespace


CloseSmeltingWindow Method

Smelting..::..CloseSmeltingWindow Method

Close the smelting window.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void CloseSmeltingWindow()
Public Shared Sub CloseSmeltingWindow
public:
static void CloseSmeltingWindow()

See Also

Smelting Class
wManager.Wow.Helpers Namespace


NeedRun Method

Smelting..::..NeedRun Method

Need the run.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool NeedRun(
    bool openWindow
)
Public Shared Function NeedRun ( _
    openWindow As Boolean _
) As Boolean
public:
static bool^ NeedRun(
    bool^ openWindow
)

Parameters

openWindow
Type: Boolean
if set to true open window.

Return Value

true if need to run, false otherwise.

See Also

Smelting Class
wManager.Wow.Helpers Namespace


OpenSmeltingWindow Method

Smelting..::..OpenSmeltingWindow Method

Open the smelting window.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void OpenSmeltingWindow()
Public Shared Sub OpenSmeltingWindow
public:
static void OpenSmeltingWindow()

See Also

Smelting Class
wManager.Wow.Helpers Namespace


Pulse Method

Smelting..::..Pulse Method

Pulses Smelting.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void Pulse()
Public Shared Sub Pulse
public:
static void Pulse()

See Also

Smelting Class
wManager.Wow.Helpers Namespace


SpellListManager Class

Class SpellListManager. (more spell methods in Spell and SpellManager)

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class SpellListManager
Public Class SpellListManager
public ref class SpellListManager

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..SpellListManager

See Also

SpellListManager Members
wManager.Wow.Helpers Namespace


SpellListManager Members

The SpellListManager type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
 | LoadSpellListe | Loads the spell list (called when bot is attached to the game).
Protected method | MemberwiseClone | (Inherited from Object.)
 | SpellIdByName | Get spell ID by Name (in english)
 | SpellNameById | Get spell name (in english) by ID.
 | SpellNameInGameById | Get spell name (name in game) by ID.
 | SpellNameInGameByName | Get spell name (in game) by spell name (in english)
Public method | ToString | (Inherited from Object.)

Properties

Name | Description
ListSpell | Gets the list spells (key is spell ID, name is in English).
ListSpellName | Gets the names of spells (in English).

See Also

SpellListManager Class
wManager.Wow.Helpers Namespace


SpellListManager Methods

The SpellListManager type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
 | LoadSpellListe | Loads the spell list (called when bot is attached to the game).
Protected method | MemberwiseClone | (Inherited from Object.)
 | SpellIdByName | Get spell ID by Name (in english)
 | SpellNameById | Get spell name (in english) by ID.
 | SpellNameInGameById | Get spell name (name in game) by ID.
 | SpellNameInGameByName | Get spell name (in game) by spell name (in english)
Public method | ToString | (Inherited from Object.)

See Also

SpellListManager Class
wManager.Wow.Helpers Namespace


LoadSpellListe Method

SpellListManager..::..LoadSpellListe Method

Loads the spell list (called when bot is attached to the game).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void LoadSpellListe()
Public Shared Sub LoadSpellListe
public:
static void LoadSpellListe()

See Also

SpellListManager Class
wManager.Wow.Helpers Namespace


SpellIdByName Method

SpellListManager..::..SpellIdByName Method

Get spell ID by Name (in english)

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<uint> SpellIdByName(
    string spellName
)
Public Shared Function SpellIdByName ( _
    spellName As String _
) As List(Of UInteger)
public:
static List<unsigned int^>^ SpellIdByName(
    String^ spellName
)

Parameters

spellName
Type: String
Name (in english).

Return Value

id.

See Also

SpellListManager Class
wManager.Wow.Helpers Namespace


SpellNameById Method

SpellListManager..::..SpellNameById Method

Get spell name (in english) by ID.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string SpellNameById(
    uint spellId
)
Public Shared Function SpellNameById ( _
    spellId As UInteger _
) As String
public:
static String^ SpellNameById(
    unsigned int^ spellId
)

Parameters

spellId
Type: UInt32
The spell id.

Return Value

name.

See Also

SpellListManager Class
wManager.Wow.Helpers Namespace


SpellNameInGameById Method

SpellListManager..::..SpellNameInGameById Method

Get spell name (name in game) by ID.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string SpellNameInGameById(
    uint spellId
)
Public Shared Function SpellNameInGameById ( _
    spellId As UInteger _
) As String
public:
static String^ SpellNameInGameById(
    unsigned int^ spellId
)

Parameters

spellId
Type: UInt32
The spell id.

Return Value

name.

See Also

SpellListManager Class
wManager.Wow.Helpers Namespace


SpellNameInGameByName Method

SpellListManager..::..SpellNameInGameByName Method

Get spell name (in game) by spell name (in english)

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string SpellNameInGameByName(
    string spellName
)
Public Shared Function SpellNameInGameByName ( _
    spellName As String _
) As String
public:
static String^ SpellNameInGameByName(
    String^ spellName
)

Parameters

spellName
Type: String
spell name (in english).

Return Value

spell name (in game)

See Also

SpellListManager Class
wManager.Wow.Helpers Namespace


SpellListManager Properties

The SpellListManager type exposes the following members.

Properties

Name | Description
ListSpell | Gets the list spells (key is spell ID, name is in English).
ListSpellName | Gets the names of spells (in English).

See Also

SpellListManager Class
wManager.Wow.Helpers Namespace


ListSpell Property

SpellListManager..::..ListSpell Property

Gets the list spells (key is spell ID, name is in English).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static Dictionary<uint, string> ListSpell { get; set; }
Public Shared Property ListSpell As Dictionary(Of UInteger, String)
    Get
    Set
public:
static property Dictionary<unsigned int^, String^>^ ListSpell {
    Dictionary<unsigned int^, String^>^ get ();
    void set (Dictionary<unsigned int^, String^>^ value);
}

Field Value

The list spell.

See Also

SpellListManager Class
wManager.Wow.Helpers Namespace


ListSpellName Property

SpellListManager..::..ListSpellName Property

Gets the names of spells (in English).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<string> ListSpellName { get; set; }
Public Shared Property ListSpellName As List(Of String)
    Get
    Set
public:
static property List<String^>^ ListSpellName {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

Field Value

list of spells names.

See Also

SpellListManager Class
wManager.Wow.Helpers Namespace


SpellManager Class

Class SpellManager. (more spell methods in Spell and SpellListManager)

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class SpellManager
Public Class SpellManager
public ref class SpellManager

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..SpellManager

See Also

SpellManager Members
wManager.Wow.Helpers Namespace


SpellManager Members

The SpellManager type exposes the following members.

Methods

 | Name | Description
 | CastSpellByIDAndPosition | Cast spell by ID and position.
 | CastSpellByIdLUA(UInt32) | Cast spell by ID with lua.
 | CastSpellByIdLUA(UInt32, String) | Casts spell by ID with lua.
 | CastSpellByNameLUA |
 | CastSpellByNameOn | Cast spell by name (in game) on.
 | CastSpellByNameOnSelfLUA | Cast spell by name (in game) on self with lua.
Public method | Equals(System.Object) | (Inherited from Object.)
 | ExistMount(String) | Mount exist.
 | ExistMount(UInt32) | Mount exist.
 | ExistSpellBook | Exist in spell book.
Protected method | Finalize | (Inherited from Object.)
 | GetAquaticMountName | Get of aquatic mounts.
 | GetCompanionInfo | Gets companions information.
 | GetFlyMountName | Get of flying mounts.
 | GetGroudMountForLevel1Name | Get of ground mounts for level 1.
 | GetGroudMountName | Get of ground mounts.
Public method | GetHashCode | (Inherited from Object.)
 | GetSpellCooldownTimeLeft(UInt32) | Get the spell cooldown time left.
 | GetSpellCooldownTimeLeft(String) | Get the spell cooldown time left by spell name (in game) or spell ID.
 | GetSpellCooldownTimeLeftBySpellName | Get the spell cooldown time left by spell name (in english).
 | GetSpellInfo | Gets spell information.
Public method | GetType | (Inherited from Object.)
 | GlobalCooldownTimeLeft | Global cooldown time left.
 | HaveBuffLua | Have the buff with lua.
 | IsAutoAttacking | Determines whether is automatic attacking.
 | IsAutoRepeating | Determines whether is automatic repeating.
 | IsCurrentSpell | Returns whether a spell is currently is being casted by the player or is placed in the queue to be casted next. If spell is current then action bar indicates its slot with highlighted frame.
 | KnowSpell(List<(Of <<'(UInt32>)>>)) | Know the spell.
 | KnowSpell(UInt32) | Know the spell.
 | KnowSpell(String) | Know the spell.
Protected method | MemberwiseClone | (Inherited from Object.)
 | MountDruidId | Druid forms IDs.
 | SpellBook | Spellbooks.
 | SpellBookID | Spellbooks get spells IDs.
 | SpellBookName | Spellbooks get spells names (in english).
 | SpellInfoCreateCache | get spell information and create cache.
 | SpellUsableLUA | Spell is usable lua.
Public method | ToString | (Inherited from Object.)
 | UpdateSpellBook | Updates the spellbooks.

Fields

Name | Description
MountsId | List of mount spell id

See Also

SpellManager Class
wManager.Wow.Helpers Namespace


SpellManager Fields

The SpellManager type exposes the following members.

Fields

Name | Description
MountsId | List of mount spell id

See Also

SpellManager Class
wManager.Wow.Helpers Namespace


MountsId Field

SpellManager..::..MountsId Field

List of mount spell id

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<uint> MountsId
Public Shared MountsId As List(Of UInteger)
public:
static List<unsigned int^>^ MountsId

See Also

SpellManager Class
wManager.Wow.Helpers Namespace


SpellManager Methods

The SpellManager type exposes the following members.

Methods

 | Name | Description
 | CastSpellByIDAndPosition | Cast spell by ID and position.
 | CastSpellByIdLUA(UInt32) | Cast spell by ID with lua.
 | CastSpellByIdLUA(UInt32, String) | Casts spell by ID with lua.
 | CastSpellByNameLUA |
 | CastSpellByNameOn | Cast spell by name (in game) on.
 | CastSpellByNameOnSelfLUA | Cast spell by name (in game) on self with lua.
Public method | Equals(System.Object) | (Inherited from Object.)
 | ExistMount(String) | Mount exist.
 | ExistMount(UInt32) | Mount exist.
 | ExistSpellBook | Exist in spell book.
Protected method | Finalize | (Inherited from Object.)
 | GetAquaticMountName | Get of aquatic mounts.
 | GetCompanionInfo | Gets companions information.
 | GetFlyMountName | Get of flying mounts.
 | GetGroudMountForLevel1Name | Get of ground mounts for level 1.
 | GetGroudMountName | Get of ground mounts.
Public method | GetHashCode | (Inherited from Object.)
 | GetSpellCooldownTimeLeft(UInt32) | Get the spell cooldown time left.
 | GetSpellCooldownTimeLeft(String) | Get the spell cooldown time left by spell name (in game) or spell ID.
 | GetSpellCooldownTimeLeftBySpellName | Get the spell cooldown time left by spell name (in english).
 | GetSpellInfo | Gets spell information.
Public method | GetType | (Inherited from Object.)
 | GlobalCooldownTimeLeft | Global cooldown time left.
 | HaveBuffLua | Have the buff with lua.
 | IsAutoAttacking | Determines whether is automatic attacking.
 | IsAutoRepeating | Determines whether is automatic repeating.
 | IsCurrentSpell | Returns whether a spell is currently is being casted by the player or is placed in the queue to be casted next. If spell is current then action bar indicates its slot with highlighted frame.
 | KnowSpell(List<(Of <<'(UInt32>)>>)) | Know the spell.
 | KnowSpell(UInt32) | Know the spell.
 | KnowSpell(String) | Know the spell.
Protected method | MemberwiseClone | (Inherited from Object.)
 | MountDruidId | Druid forms IDs.
 | SpellBook | Spellbooks.
 | SpellBookID | Spellbooks get spells IDs.
 | SpellBookName | Spellbooks get spells names (in english).
 | SpellInfoCreateCache | get spell information and create cache.
 | SpellUsableLUA | Spell is usable lua.
Public method | ToString | (Inherited from Object.)
 | UpdateSpellBook | Updates the spellbooks.

See Also

SpellManager Class
wManager.Wow.Helpers Namespace


CastSpellByIDAndPosition Method

SpellManager..::..CastSpellByIDAndPosition Method

Cast spell by ID and position.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void CastSpellByIDAndPosition(
    uint spellId,
    Vector3 position
)
Public Shared Sub CastSpellByIDAndPosition ( _
    spellId As UInteger, _
    position As Vector3 _
)
public:
static void CastSpellByIDAndPosition(
    unsigned int^ spellId,
    Vector3^ position
)

Parameters

spellId
Type: UInt32
The spell ID.
position
Type: robotManager.Helpful..::..Vector3
The position.

See Also

SpellManager Class
wManager.Wow.Helpers Namespace


CastSpellByIdLUA Method

SpellManager..::..CastSpellByIdLUA Method

Overload List

Name | Description
CastSpellByIdLUA(UInt32) | Cast spell by ID with lua.
CastSpellByIdLUA(UInt32, String) | Casts spell by ID with lua.

See Also

SpellManager Class
SpellManager Members
wManager.Wow.Helpers Namespace


CastSpellByIdLUA Method (UInt32)

SpellManager..::..CastSpellByIdLUA Method (UInt32)

Cast spell by ID with lua.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void CastSpellByIdLUA(
    uint spellId
)
Public Shared Sub CastSpellByIdLUA ( _
    spellId As UInteger _
)
public:
static void CastSpellByIdLUA(
    unsigned int^ spellId
)

Parameters

spellId
Type: UInt32
The spell ID.

See Also

SpellManager Class
CastSpellByIdLUA Overload
wManager.Wow.Helpers Namespace


CastSpellByIdLUA Method (UInt32, String)

SpellManager..::..CastSpellByIdLUA Method (UInt32, String)

Casts spell by ID with lua.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void CastSpellByIdLUA(
    uint spellId,
    string luaUnitId
)
Public Shared Sub CastSpellByIdLUA ( _
    spellId As UInteger, _
    luaUnitId As String _
)
public:
static void CastSpellByIdLUA(
    unsigned int^ spellId,
    String^ luaUnitId
)

Parameters

spellId
Type: UInt32
The spell id.
luaUnitId
Type: String
Unit Id (lua api: http://wow.gamepedia.com/UnitId ).

See Also

SpellManager Class
CastSpellByIdLUA Overload
wManager.Wow.Helpers Namespace


CastSpellByNameLUA Method

SpellManager..::..CastSpellByNameLUA Method

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void CastSpellByNameLUA(
    string spellName
)
Public Shared Sub CastSpellByNameLUA ( _
    spellName As String _
)
public:
static void CastSpellByNameLUA(
    String^ spellName
)

Parameters

spellName
Type: String

See Also

SpellManager Class
wManager.Wow.Helpers Namespace


CastSpellByNameOn Method

SpellManager..::..CastSpellByNameOn Method

Cast spell by name (in game) on.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void CastSpellByNameOn(
    string spellName,
    string luaUnitId
)
Public Shared Sub CastSpellByNameOn ( _
    spellName As String, _
    luaUnitId As String _
)
public:
static void CastSpellByNameOn(
    String^ spellName,
    String^ luaUnitId
)

Parameters

spellName
Type: String
Name of the spell (client language name).
luaUnitId
Type: String
Unit Id (lua api: http://wow.gamepedia.com/UnitId ).

See Also

SpellManager Class
wManager.Wow.Helpers Namespace


CastSpellByNameOnSelfLUA Method

SpellManager..::..CastSpellByNameOnSelfLUA Method

Cast spell by name (in game) on self with lua.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void CastSpellByNameOnSelfLUA(
    string spellName
)
Public Shared Sub CastSpellByNameOnSelfLUA ( _
    spellName As String _
)
public:
static void CastSpellByNameOnSelfLUA(
    String^ spellName
)

Parameters

spellName
Type: String
Name of the spell (in game).

See Also

SpellManager Class
wManager.Wow.Helpers Namespace


ExistMount Method

SpellManager..::..ExistMount Method

Overload List

Name | Description
ExistMount(String) | Mount exist.
ExistMount(UInt32) | Mount exist.

See Also

SpellManager Class
SpellManager Members
wManager.Wow.Helpers Namespace


ExistMount Method (String)

SpellManager..::..ExistMount Method (String)

Mount exist.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool ExistMount(
    string spellNameInGame
)
Public Shared Function ExistMount ( _
    spellNameInGame As String _
) As Boolean
public:
static bool^ ExistMount(
    String^ spellNameInGame
)

Parameters

spellNameInGame
Type: String
The spell name in game.

Return Value

true if exist, false otherwise.

See Also

SpellManager Class
ExistMount Overload
wManager.Wow.Helpers Namespace


ExistMount Method (UInt32)

SpellManager..::..ExistMount Method (UInt32)

Mount exist.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool ExistMount(
    uint spellId
)
Public Shared Function ExistMount ( _
    spellId As UInteger _
) As Boolean
public:
static bool^ ExistMount(
    unsigned int^ spellId
)

Parameters

spellId
Type: UInt32
The spell id.

Return Value

true if exist, false otherwise.

See Also

SpellManager Class
ExistMount Overload
wManager.Wow.Helpers Namespace


ExistSpellBook Method

SpellManager..::..ExistSpellBook Method

Exist in spell book.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool ExistSpellBook(
    string spellNameInGame
)
Public Shared Function ExistSpellBook ( _
    spellNameInGame As String _
) As Boolean
public:
static bool^ ExistSpellBook(
    String^ spellNameInGame
)

Parameters

spellNameInGame
Type: String
The spell name in game.

Return Value

true if exist, false otherwise.

See Also

SpellManager Class
wManager.Wow.Helpers Namespace


GetAquaticMountName Method

SpellManager..::..GetAquaticMountName Method

Get of aquatic mounts.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string GetAquaticMountName()
Public Shared Function GetAquaticMountName As String
public:
static String^ GetAquaticMountName()

Return Value

names.

See Also

SpellManager Class
wManager.Wow.Helpers Namespace


GetCompanionInfo Method

SpellManager..::..GetCompanionInfo Method

Gets companions information.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<CompanionInfo> GetCompanionInfo()
Public Shared Function GetCompanionInfo As List(Of CompanionInfo)
public:
static List<CompanionInfo^>^ GetCompanionInfo()

Return Value

companions.

See Also

SpellManager Class
wManager.Wow.Helpers Namespace


GetFlyMountName Method

SpellManager..::..GetFlyMountName Method

Get of flying mounts.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string GetFlyMountName()
Public Shared Function GetFlyMountName As String
public:
static String^ GetFlyMountName()

Return Value

names.

See Also

SpellManager Class
wManager.Wow.Helpers Namespace


GetGroudMountForLevel1Name Method

SpellManager..::..GetGroudMountForLevel1Name Method

Get of ground mounts for level 1.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string GetGroudMountForLevel1Name()
Public Shared Function GetGroudMountForLevel1Name As String
public:
static String^ GetGroudMountForLevel1Name()

Return Value

names.

See Also

SpellManager Class
wManager.Wow.Helpers Namespace


GetGroudMountName Method

SpellManager..::..GetGroudMountName Method

Get of ground mounts.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string GetGroudMountName()
Public Shared Function GetGroudMountName As String
public:
static String^ GetGroudMountName()

Return Value

names.

See Also

SpellManager Class
wManager.Wow.Helpers Namespace


GetSpellCooldownTimeLeft Method

SpellManager..::..GetSpellCooldownTimeLeft Method

Overload List

Name | Description
GetSpellCooldownTimeLeft(UInt32) | Get the spell cooldown time left.
GetSpellCooldownTimeLeft(String) | Get the spell cooldown time left by spell name (in game) or spell ID.

See Also

SpellManager Class
SpellManager Members
wManager.Wow.Helpers Namespace


GetSpellCooldownTimeLeft Method (UInt32)

SpellManager..::..GetSpellCooldownTimeLeft Method (UInt32)

Get the spell cooldown time left.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int GetSpellCooldownTimeLeft(
    uint spellId
)
Public Shared Function GetSpellCooldownTimeLeft ( _
    spellId As UInteger _
) As Integer
public:
static int^ GetSpellCooldownTimeLeft(
    unsigned int^ spellId
)

Parameters

spellId
Type: UInt32
The spell id.

Return Value

time left milliseconds.

See Also

SpellManager Class
GetSpellCooldownTimeLeft Overload
wManager.Wow.Helpers Namespace


GetSpellCooldownTimeLeft Method (String)

SpellManager..::..GetSpellCooldownTimeLeft Method (String)

Get the spell cooldown time left by spell name (in game) or spell ID.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int GetSpellCooldownTimeLeft(
    string spellIdOrSpellNameInGame
)
Public Shared Function GetSpellCooldownTimeLeft ( _
    spellIdOrSpellNameInGame As String _
) As Integer
public:
static int^ GetSpellCooldownTimeLeft(
    String^ spellIdOrSpellNameInGame
)

Parameters

spellIdOrSpellNameInGame
Type: String
spell name (in game) or spell ID.

Return Value

time left milliseconds.

See Also

SpellManager Class
GetSpellCooldownTimeLeft Overload
wManager.Wow.Helpers Namespace


GetSpellCooldownTimeLeftBySpellName Method

SpellManager..::..GetSpellCooldownTimeLeftBySpellName Method

Get the spell cooldown time left by spell name (in english).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int GetSpellCooldownTimeLeftBySpellName(
    string spellName
)
Public Shared Function GetSpellCooldownTimeLeftBySpellName ( _
    spellName As String _
) As Integer
public:
static int^ GetSpellCooldownTimeLeftBySpellName(
    String^ spellName
)

Parameters

spellName
Type: String
spell name (in english)

Return Value

time left milliseconds.

See Also

SpellManager Class
wManager.Wow.Helpers Namespace


GetSpellInfo Method

SpellManager..::..GetSpellInfo Method

Gets spell information.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static SpellInfo GetSpellInfo(
    uint id
)
Public Shared Function GetSpellInfo ( _
    id As UInteger _
) As SpellInfo
public:
static SpellInfo^ GetSpellInfo(
    unsigned int^ id
)

Parameters

id
Type: UInt32
The spell id.

Return Value

SpellInfo.

See Also

SpellManager Class
wManager.Wow.Helpers Namespace


GlobalCooldownTimeLeft Method

SpellManager..::..GlobalCooldownTimeLeft Method

Global cooldown time left.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int GlobalCooldownTimeLeft()
Public Shared Function GlobalCooldownTimeLeft As Integer
public:
static int^ GlobalCooldownTimeLeft()

Return Value

time left milliseconds.

See Also

SpellManager Class
wManager.Wow.Helpers Namespace


HaveBuffLua Method

SpellManager..::..HaveBuffLua Method

Have the buff with lua.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool HaveBuffLua(
    string spellNameInGame
)
Public Shared Function HaveBuffLua ( _
    spellNameInGame As String _
) As Boolean
public:
static bool^ HaveBuffLua(
    String^ spellNameInGame
)

Parameters

spellNameInGame
Type: String
The spell name in game.

Return Value

true if have, false otherwise.

See Also

SpellManager Class
wManager.Wow.Helpers Namespace


IsAutoAttacking Method

SpellManager..::..IsAutoAttacking Method

Determines whether is automatic attacking.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool IsAutoAttacking()
Public Shared Function IsAutoAttacking As Boolean
public:
static bool^ IsAutoAttacking()

Return Value

true if is automatic attacking; otherwise, false.

See Also

SpellManager Class
wManager.Wow.Helpers Namespace


IsAutoRepeating Method

SpellManager..::..IsAutoRepeating Method

Determines whether is automatic repeating.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool IsAutoRepeating(
    string name
)
Public Shared Function IsAutoRepeating ( _
    name As String _
) As Boolean
public:
static bool^ IsAutoRepeating(
    String^ name
)

Parameters

name
Type: String
The name (in game).

Return Value

true if is automatic repeating; otherwise, false.

See Also

SpellManager Class
wManager.Wow.Helpers Namespace


IsCurrentSpell Method

SpellManager..::..IsCurrentSpell Method

Returns whether a spell is currently is being casted by the player or is placed in the queue to be casted next. If spell is current then action bar indicates its slot with highlighted frame.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool IsCurrentSpell(
    string name
)
Public Shared Function IsCurrentSpell ( _
    name As String _
) As Boolean
public:
static bool^ IsCurrentSpell(
    String^ name
)

Parameters

name
Type: String
The spell name (in english).

Return Value

true if IsCurrentSpell; otherwise, false.

See Also

SpellManager Class
wManager.Wow.Helpers Namespace


KnowSpell Method

SpellManager..::..KnowSpell Method

Overload List

Name | Description
KnowSpell(List<(Of <<'(UInt32>)>>)) | Know the spell.
KnowSpell(UInt32) | Know the spell.
KnowSpell(String) | Know the spell.

See Also

SpellManager Class
SpellManager Members
wManager.Wow.Helpers Namespace


KnowSpell Method (List(UInt32))

SpellManager..::..KnowSpell Method (List<(Of <(<'UInt32>)>)>)

Know the spell.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool KnowSpell(
    List<uint> spellsId
)
Public Shared Function KnowSpell ( _
    spellsId As List(Of UInteger) _
) As Boolean
public:
static bool^ KnowSpell(
    List<unsigned int^>^ spellsId
)

Parameters

spellsId
Type: List <(Of <(<' UInt32 >)>)>
The spell ids.

Return Value

true if know, false otherwise.

See Also

SpellManager Class
KnowSpell Overload
wManager.Wow.Helpers Namespace


KnowSpell Method (UInt32)

SpellManager..::..KnowSpell Method (UInt32)

Know the spell.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool KnowSpell(
    uint spellsId
)
Public Shared Function KnowSpell ( _
    spellsId As UInteger _
) As Boolean
public:
static bool^ KnowSpell(
    unsigned int^ spellsId
)

Parameters

spellsId
Type: UInt32
The spells id.

Return Value

true if know, false otherwise.

See Also

SpellManager Class
KnowSpell Overload
wManager.Wow.Helpers Namespace


KnowSpell Method (String)

SpellManager..::..KnowSpell Method (String)

Know the spell.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool KnowSpell(
    string spellNameEnglish
)
Public Shared Function KnowSpell ( _
    spellNameEnglish As String _
) As Boolean
public:
static bool^ KnowSpell(
    String^ spellNameEnglish
)

Parameters

spellNameEnglish
Type: String
The spell name english.

Return Value

true if know, false otherwise.

See Also

SpellManager Class
KnowSpell Overload
wManager.Wow.Helpers Namespace


MountDruidId Method

SpellManager..::..MountDruidId Method

Druid forms IDs.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<uint> MountDruidId()
Public Shared Function MountDruidId As List(Of UInteger)
public:
static List<unsigned int^>^ MountDruidId()

Return Value

forms IDs.

See Also

SpellManager Class
wManager.Wow.Helpers Namespace


SpellBook Method

SpellManager..::..SpellBook Method

Spellbooks.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<Spell> SpellBook()
Public Shared Function SpellBook As List(Of Spell)
public:
static List<Spell^>^ SpellBook()

Return Value

spells of spellbooks.

See Also

SpellManager Class
wManager.Wow.Helpers Namespace


SpellBookID Method

SpellManager..::..SpellBookID Method

Spellbooks get spells IDs.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<uint> SpellBookID()
Public Shared Function SpellBookID As List(Of UInteger)
public:
static List<unsigned int^>^ SpellBookID()

Return Value

spells IDs.

See Also

SpellManager Class
wManager.Wow.Helpers Namespace


SpellBookName Method

SpellManager..::..SpellBookName Method

Spellbooks get spells names (in english).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<string> SpellBookName()
Public Shared Function SpellBookName As List(Of String)
public:
static List<String^>^ SpellBookName()

Return Value

names.

See Also

SpellManager Class
wManager.Wow.Helpers Namespace


SpellInfoCreateCache Method

SpellManager..::..SpellInfoCreateCache Method

get spell information and create cache.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<SpellInfo> SpellInfoCreateCache(
    List<uint> listId
)
Public Shared Function SpellInfoCreateCache ( _
    listId As List(Of UInteger) _
) As List(Of SpellInfo)
public:
static List<SpellInfo^>^ SpellInfoCreateCache(
    List<unsigned int^>^ listId
)

Parameters

listId
Type: List <(Of <(<' UInt32 >)>)>
The list of IDs.

Return Value

spells info.

See Also

SpellManager Class
wManager.Wow.Helpers Namespace


SpellUsableLUA Method

SpellManager..::..SpellUsableLUA Method

Spell is usable lua.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool SpellUsableLUA(
    string spellNameInGame
)
Public Shared Function SpellUsableLUA ( _
    spellNameInGame As String _
) As Boolean
public:
static bool^ SpellUsableLUA(
    String^ spellNameInGame
)

Parameters

spellNameInGame
Type: String
The spell name in game.

Return Value

true if is usable, false otherwise.

See Also

SpellManager Class
wManager.Wow.Helpers Namespace


UpdateSpellBook Method

SpellManager..::..UpdateSpellBook Method

Updates the spellbooks.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void UpdateSpellBook()
Public Shared Sub UpdateSpellBook
public:
static void UpdateSpellBook()

See Also

SpellManager Class
wManager.Wow.Helpers Namespace


StuckResolver Class

Class StuckResolver.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class StuckResolver
Public NotInheritable Class StuckResolver
public ref class StuckResolver abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..StuckResolver

See Also

StuckResolver Members
wManager.Wow.Helpers Namespace


StuckResolver Members

The StuckResolver type exposes the following members.

Methods

Name | Description
UnStuck | UnStuck the player.
UnStuckFly | UnStuck the player when flying.

Fields

Name | Description
IsUnStuck | Unstuck in progress
StuckCount | Get number of stuck

See Also

StuckResolver Class
wManager.Wow.Helpers Namespace


StuckResolver Fields

The StuckResolver type exposes the following members.

Fields

Name | Description
IsUnStuck | Unstuck in progress
StuckCount | Get number of stuck

See Also

StuckResolver Class
wManager.Wow.Helpers Namespace


IsUnStuck Field

StuckResolver..::..IsUnStuck Field

Unstuck in progress

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool IsUnStuck
Public Shared IsUnStuck As Boolean
public:
static bool^ IsUnStuck

See Also

StuckResolver Class
wManager.Wow.Helpers Namespace


StuckCount Field

StuckResolver..::..StuckCount Field

Get number of stuck

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int StuckCount
Public Shared StuckCount As Integer
public:
static int^ StuckCount

See Also

StuckResolver Class
wManager.Wow.Helpers Namespace


StuckResolver Methods

The StuckResolver type exposes the following members.

Methods

Name | Description
UnStuck | UnStuck the player.
UnStuckFly | UnStuck the player when flying.

See Also

StuckResolver Class
wManager.Wow.Helpers Namespace


UnStuck Method

StuckResolver..::..UnStuck Method

UnStuck the player.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void UnStuck()
Public Shared Sub UnStuck
public:
static void UnStuck()

See Also

StuckResolver Class
wManager.Wow.Helpers Namespace


UnStuckFly Method

StuckResolver..::..UnStuckFly Method

UnStuck the player when flying.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void UnStuckFly()
Public Shared Sub UnStuckFly
public:
static void UnStuckFly()

See Also

StuckResolver Class
wManager.Wow.Helpers Namespace


Talent Class

Talents

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class Talent
Public NotInheritable Class Talent
public ref class Talent abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..Talent

See Also

Talent Members
wManager.Wow.Helpers Namespace


Talent Members

The Talent type exposes the following members.

Methods

Name | Description
DoTalents | Pulse.

See Also

Talent Class
wManager.Wow.Helpers Namespace


Talent Methods

The Talent type exposes the following members.

Methods

Name | Description
DoTalents | Pulse.

See Also

Talent Class
wManager.Wow.Helpers Namespace


DoTalents Method

Talent..::..DoTalents Method

Pulse.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void DoTalents()
Public Shared Sub DoTalents
public:
static void DoTalents()

See Also

Talent Class
wManager.Wow.Helpers Namespace


Taxi Class

Class Taxi.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class Taxi
Public NotInheritable Class Taxi
public ref class Taxi abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..Taxi

See Also

Taxi Members
wManager.Wow.Helpers Namespace


Taxi Members

The Taxi type exposes the following members.

Methods

Name | Description
GetNearestNode(Vector3, Boolean%) | Gets the nearest node (need taxi frame open).
GetNearestNode(Vector3, List<(Of <<'(TaxiNode>)>>), Boolean%) | Gets the nearest node.
GetNearestNode(List<(Of <<'(TaxiNode>)>>), Single, Boolean%) | Gets the nearest node.
GetTaxiNodes | Gets taxi nodes of current taxi (need taxi frame open).
TakeNearestNode | Takes the nearest node (need taxi frame open).
TakeTaxiNode(Int32, String) | Takes the taxi node (need taxi frame open).
TakeTaxiNode(TaxiNode) | Takes the taxi node (need taxi frame open).
TaxiFrameIsVisible |

Fields

Name | Description
_taxiLock |

See Also

Taxi Class
wManager.Wow.Helpers Namespace


Taxi Fields

The Taxi type exposes the following members.

Fields

Name | Description
_taxiLock |

See Also

Taxi Class
wManager.Wow.Helpers Namespace


_taxiLock Field

Taxi..::.._taxiLock Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static Object _taxiLock
Public Shared _taxiLock As Object
public:
static Object^ _taxiLock

See Also

Taxi Class
wManager.Wow.Helpers Namespace


Taxi Methods

The Taxi type exposes the following members.

Methods

Name | Description
GetNearestNode(Vector3, Boolean%) | Gets the nearest node (need taxi frame open).
GetNearestNode(Vector3, List<(Of <<'(TaxiNode>)>>), Boolean%) | Gets the nearest node.
GetNearestNode(List<(Of <<'(TaxiNode>)>>), Single, Boolean%) | Gets the nearest node.
GetTaxiNodes | Gets taxi nodes of current taxi (need taxi frame open).
TakeNearestNode | Takes the nearest node (need taxi frame open).
TakeTaxiNode(Int32, String) | Takes the taxi node (need taxi frame open).
TakeTaxiNode(TaxiNode) | Takes the taxi node (need taxi frame open).
TaxiFrameIsVisible |

See Also

Taxi Class
wManager.Wow.Helpers Namespace


GetNearestNode Method

Taxi..::..GetNearestNode Method

Overload List

Name | Description
GetNearestNode(Vector3, Boolean%) | Gets the nearest node (need taxi frame open).
GetNearestNode(Vector3, List<(Of <<'(TaxiNode>)>>), Boolean%) | Gets the nearest node.
GetNearestNode(List<(Of <<'(TaxiNode>)>>), Single, Boolean%) | Gets the nearest node.

See Also

Taxi Class
Taxi Members
wManager.Wow.Helpers Namespace


GetNearestNode Method (Vector3, Boolean)

Taxi..::..GetNearestNode Method (Vector3, Boolean%)

Gets the nearest node (need taxi frame open).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static TaxiNode GetNearestNode(
    Vector3 targetPosition,
    out bool result
)
Public Shared Function GetNearestNode ( _
    targetPosition As Vector3, _
    <OutAttribute> ByRef result As Boolean _
) As TaxiNode
public:
static TaxiNode^ GetNearestNode(
    Vector3^ targetPosition,
    [OutAttribute] bool^% result
)

Parameters

targetPosition
Type: robotManager.Helpful..::..Vector3
The target position.
result
Type: Boolean %
true if success.

Return Value

TaxiNode.

See Also

Taxi Class
GetNearestNode Overload
wManager.Wow.Helpers Namespace


GetNearestNode Method (Vector3, List(TaxiNode), Boolean)

Taxi..::..GetNearestNode Method (Vector3, List<(Of <(<'TaxiNode>)>)>, Boolean%)

Gets the nearest node.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static TaxiNode GetNearestNode(
    Vector3 targetPosition,
    List<TaxiNode> taxiNodes,
    out bool result
)
Public Shared Function GetNearestNode ( _
    targetPosition As Vector3, _
    taxiNodes As List(Of TaxiNode), _
    <OutAttribute> ByRef result As Boolean _
) As TaxiNode
public:
static TaxiNode^ GetNearestNode(
    Vector3^ targetPosition,
    List<TaxiNode^>^ taxiNodes,
    [OutAttribute] bool^% result
)

Parameters

targetPosition
Type: robotManager.Helpful..::..Vector3
The target position.
taxiNodes
Type: List <(Of <(<' TaxiNode >)>)>
The taxi nodes.
result
Type: Boolean %
true if success.

Return Value

TaxiNode.

See Also

Taxi Class
GetNearestNode Overload
wManager.Wow.Helpers Namespace


GetNearestNode Method (List(TaxiNode), Single, Boolean)

Taxi..::..GetNearestNode Method (List<(Of <(<'TaxiNode>)>)>, Single, Boolean%)

Gets the nearest node.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static TaxiNode GetNearestNode(
    List<TaxiNode> taxiNodes,
    float maxDistanceMe,
    out bool result
)
Public Shared Function GetNearestNode ( _
    taxiNodes As List(Of TaxiNode), _
    maxDistanceMe As Single, _
    <OutAttribute> ByRef result As Boolean _
) As TaxiNode
public:
static TaxiNode^ GetNearestNode(
    List<TaxiNode^>^ taxiNodes,
    float^ maxDistanceMe,
    [OutAttribute] bool^% result
)

Parameters

taxiNodes
Type: List <(Of <(<' TaxiNode >)>)>
The taxi nodes.
maxDistanceMe
Type: Single
The maximum distance me.
result
Type: Boolean %
true if success.

Return Value

TaxiNode.

See Also

Taxi Class
GetNearestNode Overload
wManager.Wow.Helpers Namespace


GetTaxiNodes Method

Taxi..::..GetTaxiNodes Method

Gets taxi nodes of current taxi (need taxi frame open).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<TaxiNode> GetTaxiNodes()
Public Shared Function GetTaxiNodes As List(Of TaxiNode)
public:
static List<TaxiNode^>^ GetTaxiNodes()

Return Value

nodes.

See Also

Taxi Class
wManager.Wow.Helpers Namespace


TakeNearestNode Method

Taxi..::..TakeNearestNode Method

Takes the nearest node (need taxi frame open).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool TakeNearestNode(
    Vector3 targetPosition,
    bool onlyIfCanMakePathFormTaxiToPos
)
Public Shared Function TakeNearestNode ( _
    targetPosition As Vector3, _
    onlyIfCanMakePathFormTaxiToPos As Boolean _
) As Boolean
public:
static bool^ TakeNearestNode(
    Vector3^ targetPosition,
    bool^ onlyIfCanMakePathFormTaxiToPos
)

Parameters

targetPosition
Type: robotManager.Helpful..::..Vector3
The target position.
onlyIfCanMakePathFormTaxiToPos
Type: Boolean
if set to true take only if can make path form destination taxi position to final destination position.

Return Value

true if success, false otherwise.

See Also

Taxi Class
wManager.Wow.Helpers Namespace


TakeTaxiNode Method

Taxi..::..TakeTaxiNode Method

Overload List

Name | Description
TakeTaxiNode(Int32, String) | Takes the taxi node (need taxi frame open).
TakeTaxiNode(TaxiNode) | Takes the taxi node (need taxi frame open).

See Also

Taxi Class
Taxi Members
wManager.Wow.Helpers Namespace


TakeTaxiNode Method (Int32, String)

Taxi..::..TakeTaxiNode Method (Int32, String)

Takes the taxi node (need taxi frame open).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool TakeTaxiNode(
    int slotIndex,
    string nodeName
)
Public Shared Function TakeTaxiNode ( _
    slotIndex As Integer, _
    nodeName As String _
) As Boolean
public:
static bool^ TakeTaxiNode(
    int^ slotIndex,
    String^ nodeName
)

Parameters

slotIndex
Type: Int32
Index of the slot.
nodeName
Type: String
Name of the node.

Return Value

true if success, false otherwise.

See Also

Taxi Class
TakeTaxiNode Overload
wManager.Wow.Helpers Namespace


TakeTaxiNode Method (TaxiNode)

Taxi..::..TakeTaxiNode Method (TaxiNode)

Takes the taxi node (need taxi frame open).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool TakeTaxiNode(
    TaxiNode node
)
Public Shared Function TakeTaxiNode ( _
    node As TaxiNode _
) As Boolean
public:
static bool^ TakeTaxiNode(
    TaxiNode^ node
)

Parameters

node
Type: wManager.Wow.Class..::..TaxiNode
The node.

Return Value

true if success, false otherwise.

See Also

Taxi Class
TakeTaxiNode Overload
wManager.Wow.Helpers Namespace


TaxiFrameIsVisible Method

Taxi..::..TaxiFrameIsVisible Method

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool TaxiFrameIsVisible()
Public Shared Function TaxiFrameIsVisible As Boolean
public:
static bool^ TaxiFrameIsVisible()

See Also

Taxi Class
wManager.Wow.Helpers Namespace


Taxi.TaxiList Class

Taxi..::..TaxiList Class

Class TaxiList. To save knows taxi nodes (to file "WRobot\Settings\TaxiNodes.xml").

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class TaxiList
Public NotInheritable Class TaxiList
public ref class TaxiList abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..Taxi..::..TaxiList

See Also

Taxi..::..TaxiList Members
wManager.Wow.Helpers Namespace


Taxi.TaxiList Members

Taxi..::..TaxiList Members

The Taxi..::..TaxiList type exposes the following members.

Methods

Name | Description
Active | Actives the specified taxi node.
AddOrEditForCurrentPlayer(List<(Of <<'(TaxiNode>)>>), Boolean) | Adds the or edit for current player.
AddOrEditForCurrentPlayer(TaxiNode, Boolean) | Adds the or edit for current player.
Disable | Disables the specified taxi node.
GetTaxiNodesOfCurrentPlayer | Gets the taxi nodes of current player.
Load | Loads this instance.
Save | Saves this instance.

Fields

Name | Description
Locker | The locker

Properties

Name | Description
Nodes | Gets or sets the nodes.

See Also

Taxi..::..TaxiList Class
wManager.Wow.Helpers Namespace


Taxi.TaxiList Fields

Taxi..::..TaxiList Fields

The Taxi..::..TaxiList type exposes the following members.

Fields

Name | Description
Locker | The locker

See Also

Taxi..::..TaxiList Class
wManager.Wow.Helpers Namespace


Locker Field

TaxiList..::..Locker Field

The locker

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static Object Locker
Public Shared Locker As Object
public:
static Object^ Locker

See Also

Taxi..::..TaxiList Class
wManager.Wow.Helpers Namespace


Taxi.TaxiList Methods

Taxi..::..TaxiList Methods

The Taxi..::..TaxiList type exposes the following members.

Methods

Name | Description
Active | Actives the specified taxi node.
AddOrEditForCurrentPlayer(List<(Of <<'(TaxiNode>)>>), Boolean) | Adds the or edit for current player.
AddOrEditForCurrentPlayer(TaxiNode, Boolean) | Adds the or edit for current player.
Disable | Disables the specified taxi node.
GetTaxiNodesOfCurrentPlayer | Gets the taxi nodes of current player.
Load | Loads this instance.
Save | Saves this instance.

See Also

Taxi..::..TaxiList Class
wManager.Wow.Helpers Namespace


Active Method

TaxiList..::..Active Method

Actives the specified taxi node.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void Active(
    TaxiNode taxiNode
)
Public Shared Sub Active ( _
    taxiNode As TaxiNode _
)
public:
static void Active(
    TaxiNode^ taxiNode
)

Parameters

taxiNode
Type: wManager.Wow.Class..::..TaxiNode
The taxi node.

See Also

Taxi..::..TaxiList Class
wManager.Wow.Helpers Namespace


AddOrEditForCurrentPlayer Method

TaxiList..::..AddOrEditForCurrentPlayer Method

Overload List

Name | Description
AddOrEditForCurrentPlayer(List<(Of <<'(TaxiNode>)>>), Boolean) | Adds the or edit for current player.
AddOrEditForCurrentPlayer(TaxiNode, Boolean) | Adds the or edit for current player.

See Also

Taxi..::..TaxiList Class
Taxi..::..TaxiList Members
wManager.Wow.Helpers Namespace


AddOrEditForCurrentPlayer Method (List(TaxiNode), Boolean)

TaxiList..::..AddOrEditForCurrentPlayer Method (List<(Of <(<'TaxiNode>)>)>, Boolean)

Adds the or edit for current player.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void AddOrEditForCurrentPlayer(
    List<TaxiNode> taxiNodes,
    bool save
)
Public Shared Sub AddOrEditForCurrentPlayer ( _
    taxiNodes As List(Of TaxiNode), _
    save As Boolean _
)
public:
static void AddOrEditForCurrentPlayer(
    List<TaxiNode^>^ taxiNodes,
    bool^ save
)

Parameters

taxiNodes
Type: List <(Of <(<' TaxiNode >)>)>
The taxi nodes.
save
Type: Boolean
if set to true to save.

See Also

Taxi..::..TaxiList Class
AddOrEditForCurrentPlayer Overload
wManager.Wow.Helpers Namespace


AddOrEditForCurrentPlayer Method (TaxiNode, Boolean)

TaxiList..::..AddOrEditForCurrentPlayer Method (TaxiNode, Boolean)

Adds the or edit for current player.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void AddOrEditForCurrentPlayer(
    TaxiNode taxiNode,
    bool save
)
Public Shared Sub AddOrEditForCurrentPlayer ( _
    taxiNode As TaxiNode, _
    save As Boolean _
)
public:
static void AddOrEditForCurrentPlayer(
    TaxiNode^ taxiNode,
    bool^ save
)

Parameters

taxiNode
Type: wManager.Wow.Class..::..TaxiNode
The taxi node.
save
Type: Boolean
if set to true [save].

See Also

Taxi..::..TaxiList Class
AddOrEditForCurrentPlayer Overload
wManager.Wow.Helpers Namespace


Disable Method

TaxiList..::..Disable Method

Disables the specified taxi node.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void Disable(
    TaxiNode taxiNode
)
Public Shared Sub Disable ( _
    taxiNode As TaxiNode _
)
public:
static void Disable(
    TaxiNode^ taxiNode
)

Parameters

taxiNode
Type: wManager.Wow.Class..::..TaxiNode
The taxi node.

See Also

Taxi..::..TaxiList Class
wManager.Wow.Helpers Namespace


GetTaxiNodesOfCurrentPlayer Method

TaxiList..::..GetTaxiNodesOfCurrentPlayer Method

Gets the taxi nodes of current player.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<TaxiNode> GetTaxiNodesOfCurrentPlayer(
    bool onlyActive
)
Public Shared Function GetTaxiNodesOfCurrentPlayer ( _
    onlyActive As Boolean _
) As List(Of TaxiNode)
public:
static List<TaxiNode^>^ GetTaxiNodesOfCurrentPlayer(
    bool^ onlyActive
)

Parameters

onlyActive
Type: Boolean
if set to true [only active].

Return Value

List<TaxiNode>.

See Also

Taxi..::..TaxiList Class
wManager.Wow.Helpers Namespace


Load Method

TaxiList..::..Load Method

Loads this instance.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void Load()
Public Shared Sub Load
public:
static void Load()

See Also

Taxi..::..TaxiList Class
wManager.Wow.Helpers Namespace


Save Method

TaxiList..::..Save Method

Saves this instance.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void Save()
Public Shared Sub Save
public:
static void Save()

See Also

Taxi..::..TaxiList Class
wManager.Wow.Helpers Namespace


Taxi.TaxiList Properties

Taxi..::..TaxiList Properties

The Taxi..::..TaxiList type exposes the following members.

Properties

Name | Description
Nodes | Gets or sets the nodes.

See Also

Taxi..::..TaxiList Class
wManager.Wow.Helpers Namespace


Nodes Property

TaxiList..::..Nodes Property

Gets or sets the nodes.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<TaxiNode> Nodes { get; set; }
Public Shared Property Nodes As List(Of TaxiNode)
    Get
    Set
public:
static property List<TaxiNode^>^ Nodes {
    List<TaxiNode^>^ get ();
    void set (List<TaxiNode^>^ value);
}

Field Value

The nodes.

See Also

Taxi..::..TaxiList Class
wManager.Wow.Helpers Namespace


Taxi.TaxiNodesDB Structure

Taxi..::..TaxiNodesDB Structure

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[StructLayoutAttribute]
public struct TaxiNodesDB
<StructLayoutAttribute> _
Public Structure TaxiNodesDB
[StructLayoutAttribute]
public value class TaxiNodesDB

See Also

Taxi..::..TaxiNodesDB Members
wManager.Wow.Helpers Namespace


Taxi.TaxiNodesDB Members

Taxi..::..TaxiNodesDB Members

The Taxi..::..TaxiNodesDB type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from ValueType.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from ValueType.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from ValueType.)

Fields

 | Name | Description
Public field | ContinentID |
Public field | ID |
Public field | MountCreatureID |
Public field | Name |
Public field | pos |

See Also

Taxi..::..TaxiNodesDB Structure
wManager.Wow.Helpers Namespace


Taxi.TaxiNodesDB Fields

Taxi..::..TaxiNodesDB Fields

The Taxi..::..TaxiNodesDB type exposes the following members.

Fields

 | Name | Description
Public field | ContinentID |
Public field | ID |
Public field | MountCreatureID |
Public field | Name |
Public field | pos |

See Also

Taxi..::..TaxiNodesDB Structure
wManager.Wow.Helpers Namespace


ContinentID Field

TaxiNodesDB..::..ContinentID Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint ContinentID
Public ContinentID As UInteger
public:
unsigned int^ ContinentID

See Also

Taxi..::..TaxiNodesDB Structure
wManager.Wow.Helpers Namespace


ID Field

TaxiNodesDB..::..ID Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint ID
Public ID As UInteger
public:
unsigned int^ ID

See Also

Taxi..::..TaxiNodesDB Structure
wManager.Wow.Helpers Namespace


MountCreatureID Field

TaxiNodesDB..::..MountCreatureID Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[MarshalAsAttribute]
public int[] MountCreatureID
<MarshalAsAttribute> _
Public MountCreatureID As Integer()
[MarshalAsAttribute]
public:
array<int^>^ MountCreatureID

See Also

Taxi..::..TaxiNodesDB Structure
wManager.Wow.Helpers Namespace


Name Field

TaxiNodesDB..::..Name Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[MarshalAsAttribute]
public string Name
<MarshalAsAttribute> _
Public Name As String
[MarshalAsAttribute]
public:
String^ Name

See Also

Taxi..::..TaxiNodesDB Structure
wManager.Wow.Helpers Namespace


pos Field

TaxiNodesDB..::..pos Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[MarshalAsAttribute]
public float[] pos
<MarshalAsAttribute> _
Public pos As Single()
[MarshalAsAttribute]
public:
array<float^>^ pos

See Also

Taxi..::..TaxiNodesDB Structure
wManager.Wow.Helpers Namespace


Taxi.TaxiNodesDB Methods

Taxi..::..TaxiNodesDB Methods

The Taxi..::..TaxiNodesDB type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from ValueType.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from ValueType.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from ValueType.)

See Also

Taxi..::..TaxiNodesDB Structure
wManager.Wow.Helpers Namespace


Totems Class

Class Totems.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class Totems
Public NotInheritable Class Totems
public ref class Totems abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..Totems

See Also

Totems Members
wManager.Wow.Helpers Namespace


Totems Members

The Totems type exposes the following members.

Methods

Name | Description
TotemExist | Totem exist.
TotemTimeLeft | Totems time left.

See Also

Totems Class
wManager.Wow.Helpers Namespace


Totems Methods

The Totems type exposes the following members.

Methods

Name | Description
TotemExist | Totem exist.
TotemTimeLeft | Totems time left.

See Also

Totems Class
wManager.Wow.Helpers Namespace


TotemExist Method

Totems..::..TotemExist Method

Totem exist.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool TotemExist(
    TotemType totemType
)
Public Shared Function TotemExist ( _
    totemType As TotemType _
) As Boolean
public:
static bool^ TotemExist(
    TotemType^ totemType
)

Parameters

totemType
Type: wManager.Wow.Enums..::..TotemType
Type of totem.

Return Value

true if exist, false otherwise.

See Also

Totems Class
wManager.Wow.Helpers Namespace


TotemTimeLeft Method

Totems..::..TotemTimeLeft Method

Totems time left.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int TotemTimeLeft(
    TotemType totemType
)
Public Shared Function TotemTimeLeft ( _
    totemType As TotemType _
) As Integer
public:
static int^ TotemTimeLeft(
    TotemType^ totemType
)

Parameters

totemType
Type: wManager.Wow.Enums..::..TotemType
Type of totem.

Return Value

time left in milliseconds

See Also

Totems Class
wManager.Wow.Helpers Namespace


TraceLine Class

Class TraceLine (Raycast). Create an invisible line and detects if an element of the game is hit and at what position.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class TraceLine
Public NotInheritable Class TraceLine
public ref class TraceLine abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..TraceLine

See Also

TraceLine Members
wManager.Wow.Helpers Namespace


TraceLine Members

The TraceLine type exposes the following members.

Methods

Name | Description
TraceLineGo(Vector3) | Trace line from character position to destination, return true if the line hit game element.
TraceLineGo(Vector3, Vector3, CGWorldFrameHitFlags) | Trace line from position to destination, return true if the line hit game element.
TraceLineGo(Vector3, Vector3, CGWorldFrameHitFlags, Vector3%) | Trace line from position to destination, return true if the line hit game element.
TraceLineMass(List<(Of <<'(TraceLine..::..Line>)>>)%, CGWorldFrameHitFlags) | Mass TraceLine.
TraceLineMass(List<(Of <<'(TraceLine..::..Line>)>>)%, CGWorldFrameHitFlags, Nullable<(Of <<'(Boolean>)>>)) | Mass TraceLine.

See Also

TraceLine Class
wManager.Wow.Helpers Namespace


TraceLine Methods

The TraceLine type exposes the following members.

Methods

Name | Description
TraceLineGo(Vector3) | Trace line from character position to destination, return true if the line hit game element.
TraceLineGo(Vector3, Vector3, CGWorldFrameHitFlags) | Trace line from position to destination, return true if the line hit game element.
TraceLineGo(Vector3, Vector3, CGWorldFrameHitFlags, Vector3%) | Trace line from position to destination, return true if the line hit game element.
TraceLineMass(List<(Of <<'(TraceLine..::..Line>)>>)%, CGWorldFrameHitFlags) | Mass TraceLine.
TraceLineMass(List<(Of <<'(TraceLine..::..Line>)>>)%, CGWorldFrameHitFlags, Nullable<(Of <<'(Boolean>)>>)) | Mass TraceLine.

See Also

TraceLine Class
wManager.Wow.Helpers Namespace


TraceLineGo Method

TraceLine..::..TraceLineGo Method

Overload List

Name | Description
TraceLineGo(Vector3) | Trace line from character position to destination, return true if the line hit game element.
TraceLineGo(Vector3, Vector3, CGWorldFrameHitFlags) | Trace line from position to destination, return true if the line hit game element.
TraceLineGo(Vector3, Vector3, CGWorldFrameHitFlags, Vector3%) | Trace line from position to destination, return true if the line hit game element.

See Also

TraceLine Class
TraceLine Members
wManager.Wow.Helpers Namespace


TraceLineGo Method (Vector3)

TraceLine..::..TraceLineGo Method (Vector3)

Trace line from character position to destination, return true if the line hit game element.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool TraceLineGo(
    Vector3 to
)
Public Shared Function TraceLineGo ( _
    to As Vector3 _
) As Boolean
public:
static bool^ TraceLineGo(
    Vector3^ to
)

Parameters

to
Type: robotManager.Helpful..::..Vector3
destination.

Return Value

true if hit, false otherwise.

See Also

TraceLine Class
TraceLineGo Overload
wManager.Wow.Helpers Namespace


TraceLineGo Method (Vector3, Vector3, CGWorldFrameHitFlags)

TraceLine..::..TraceLineGo Method (Vector3, Vector3, CGWorldFrameHitFlags)

Trace line from position to destination, return true if the line hit game element.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool TraceLineGo(
    Vector3 from,
    Vector3 to,
    CGWorldFrameHitFlags hitFlags
)
Public Shared Function TraceLineGo ( _
    from As Vector3, _
    to As Vector3, _
    hitFlags As CGWorldFrameHitFlags _
) As Boolean
public:
static bool^ TraceLineGo(
    Vector3^ from,
    Vector3^ to,
    CGWorldFrameHitFlags^ hitFlags
)

Parameters

from
Type: robotManager.Helpful..::..Vector3
From.
to
Type: robotManager.Helpful..::..Vector3
destination.
hitFlags
Type: wManager.Wow.Enums..::..CGWorldFrameHitFlags
The hit filter.

Return Value

true if hit, false otherwise.

See Also

TraceLine Class
TraceLineGo Overload
wManager.Wow.Helpers Namespace


TraceLineGo Method (Vector3, Vector3, CGWorldFrameHitFlags, Vector3)

TraceLine..::..TraceLineGo Method (Vector3, Vector3, CGWorldFrameHitFlags, Vector3%)

Trace line from position to destination, return true if the line hit game element.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool TraceLineGo(
    Vector3 from,
    Vector3 to,
    CGWorldFrameHitFlags hitFlags,
    out Vector3 hitPoint
)
Public Shared Function TraceLineGo ( _
    from As Vector3, _
    to As Vector3, _
    hitFlags As CGWorldFrameHitFlags, _
    <OutAttribute> ByRef hitPoint As Vector3 _
) As Boolean
public:
static bool^ TraceLineGo(
    Vector3^ from,
    Vector3^ to,
    CGWorldFrameHitFlags^ hitFlags,
    [OutAttribute] Vector3^% hitPoint
)

Parameters

from
Type: robotManager.Helpful..::..Vector3
From.
to
Type: robotManager.Helpful..::..Vector3
To.
hitFlags
Type: wManager.Wow.Enums..::..CGWorldFrameHitFlags
The hit flags.
hitPoint
Type: robotManager.Helpful..::..Vector3 %
The hit position.

Return Value

true if hit, false otherwise.

See Also

TraceLine Class
TraceLineGo Overload
wManager.Wow.Helpers Namespace


TraceLineMass Method

TraceLine..::..TraceLineMass Method

Overload List

Name | Description
TraceLineMass(List<(Of <<'(TraceLine..::..Line>)>>)%, CGWorldFrameHitFlags) | Mass TraceLine.
TraceLineMass(List<(Of <<'(TraceLine..::..Line>)>>)%, CGWorldFrameHitFlags, Nullable<(Of <<'(Boolean>)>>)) | Mass TraceLine.

See Also

TraceLine Class
TraceLine Members
wManager.Wow.Helpers Namespace


TraceLineMass Method (List(Line), CGWorldFrameHitFlags)

TraceLine..::..TraceLineMass Method (List<(Of <(<'Line>)>)>%, CGWorldFrameHitFlags)

Mass TraceLine.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void TraceLineMass(
    ref List<TraceLine..::..Line> toArray,
    CGWorldFrameHitFlags cgWorldFrameHitFlags
)
Public Shared Sub TraceLineMass ( _
    ByRef toArray As List(Of TraceLine..::..Line), _
    cgWorldFrameHitFlags As CGWorldFrameHitFlags _
)
public:
static void TraceLineMass(
    List<TraceLine..::..Line^>^% toArray,
    CGWorldFrameHitFlags^ cgWorldFrameHitFlags
)

Parameters

toArray
Type: List <(Of <(<' TraceLine..::..Line >)>)>%
Lines.
cgWorldFrameHitFlags
Type: wManager.Wow.Enums..::..CGWorldFrameHitFlags
filter flag.

See Also

TraceLine Class
TraceLineMass Overload
wManager.Wow.Helpers Namespace


TraceLineMass Method (List(Line), CGWorldFrameHitFlags, Nullable(Boolean))

TraceLine..::..TraceLineMass Method (List<(Of <(<'Line>)>)>%, CGWorldFrameHitFlags, Nullable<(Of <(<'Boolean>)>)>)

Mass TraceLine.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void TraceLineMass(
    ref List<TraceLine..::..Line> toArray,
    CGWorldFrameHitFlags cgWorldFrameHitFlags,
    Nullable<bool> stopWhenResult
)
Public Shared Sub TraceLineMass ( _
    ByRef toArray As List(Of TraceLine..::..Line), _
    cgWorldFrameHitFlags As CGWorldFrameHitFlags, _
    stopWhenResult As Nullable(Of Boolean) _
)
public:
static void TraceLineMass(
    List<TraceLine..::..Line^>^% toArray,
    CGWorldFrameHitFlags^ cgWorldFrameHitFlags,
    Nullable<bool^> stopWhenResult
)

Parameters

toArray
Type: List <(Of <(<' TraceLine..::..Line >)>)>%
Lines.
cgWorldFrameHitFlags
Type: wManager.Wow.Enums..::..CGWorldFrameHitFlags
filter flag.
stopWhenResult
Type: Nullable <(Of <(<' Boolean >)>)>
if set to true stop when hit, if set to false stop when no hit, if set to null don't use this option.

See Also

TraceLine Class
TraceLineMass Overload
wManager.Wow.Helpers Namespace


TraceLine.Line Class

TraceLine..::..Line Class

Class Line.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class Line
Public Class Line
public ref class Line

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..TraceLine..::..Line

See Also

TraceLine..::..Line Members
wManager.Wow.Helpers Namespace


TraceLine.Line Members

TraceLine..::..Line Members

The TraceLine..::..Line type exposes the following members.

Constructors

 | Name | Description
Public method | TraceLine..::..Line()()()() | Initializes a new instance of the TraceLine..::..Line class.
Public method | TraceLine..::..Line(Vector3, Vector3) | Initializes a new instance of the TraceLine..::..Line class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | From | From
Public field | HitPoint | The hit point
Public field | Result | The result
Public field | To | To

See Also

TraceLine..::..Line Class
wManager.Wow.Helpers Namespace


Line Constructor

Overload List

 | Name | Description
Public method | TraceLine..::..Line()()()() | Initializes a new instance of the TraceLine..::..Line class.
Public method | TraceLine..::..Line(Vector3, Vector3) | Initializes a new instance of the TraceLine..::..Line class.

See Also

TraceLine..::..Line Class
TraceLine..::..Line Members
wManager.Wow.Helpers Namespace


Line Constructor

Initializes a new instance of the TraceLine..::..Line class.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Line()
Public Sub New
public:
Line()

See Also

TraceLine..::..Line Class
TraceLine..::..Line Overload
wManager.Wow.Helpers Namespace


Line Constructor (Vector3, Vector3)

Initializes a new instance of the TraceLine..::..Line class.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Line(
    Vector3 from,
    Vector3 to
)
Public Sub New ( _
    from As Vector3, _
    to As Vector3 _
)
public:
Line(
    Vector3^ from,
    Vector3^ to
)

Parameters

from
Type: robotManager.Helpful..::..Vector3
From.
to
Type: robotManager.Helpful..::..Vector3
To.

See Also

TraceLine..::..Line Class
TraceLine..::..Line Overload
wManager.Wow.Helpers Namespace


TraceLine.Line Fields

TraceLine..::..Line Fields

The TraceLine..::..Line type exposes the following members.

Fields

 | Name | Description
Public field | From | From
Public field | HitPoint | The hit point
Public field | Result | The result
Public field | To | To

See Also

TraceLine..::..Line Class
wManager.Wow.Helpers Namespace


From Field

Line..::..From Field

From

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Vector3 From
Public From As Vector3
public:
Vector3^ From

See Also

TraceLine..::..Line Class
wManager.Wow.Helpers Namespace


HitPoint Field

Line..::..HitPoint Field

The hit point

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Vector3 HitPoint
Public HitPoint As Vector3
public:
Vector3^ HitPoint

See Also

TraceLine..::..Line Class
wManager.Wow.Helpers Namespace


Result Field

Line..::..Result Field

The result

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool Result
Public Result As Boolean
public:
bool^ Result

See Also

TraceLine..::..Line Class
wManager.Wow.Helpers Namespace


To Field

Line..::..To Field

To

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Vector3 To
Public To As Vector3
public:
Vector3^ To

See Also

TraceLine..::..Line Class
wManager.Wow.Helpers Namespace


TraceLine.Line Methods

TraceLine..::..Line Methods

The TraceLine..::..Line type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

TraceLine..::..Line Class
wManager.Wow.Helpers Namespace


Tracker Class

Class Tracker.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class Tracker
Public Class Tracker
public ref class Tracker

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..Tracker

See Also

Tracker Members
wManager.Wow.Helpers Namespace


Tracker Members

The Tracker type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
 | TrackCreatureFlags | Track the creature flags.
 | TrackObjectFlags | Track the object flags.

See Also

Tracker Class
wManager.Wow.Helpers Namespace


Tracker Methods

The Tracker type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
 | TrackCreatureFlags | Track the creature flags.
 | TrackObjectFlags | Track the object flags.

See Also

Tracker Class
wManager.Wow.Helpers Namespace


TrackCreatureFlags Method

Tracker..::..TrackCreatureFlags Method

Track the creature flags.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void TrackCreatureFlags(
    List<string> listTrackCreatureFlags
)
Public Shared Sub TrackCreatureFlags ( _
    listTrackCreatureFlags As List(Of String) _
)
public:
static void TrackCreatureFlags(
    List<String^>^ listTrackCreatureFlags
)

Parameters

listTrackCreatureFlags
Type: List <(Of <(<' String >)>)>
The list track creature flags.

See Also

Tracker Class
wManager.Wow.Helpers Namespace


TrackObjectFlags Method

Tracker..::..TrackObjectFlags Method

Track the object flags.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void TrackObjectFlags(
    List<string> listTrackObjectFlags
)
Public Shared Sub TrackObjectFlags ( _
    listTrackObjectFlags As List(Of String) _
)
public:
static void TrackObjectFlags(
    List<String^>^ listTrackObjectFlags
)

Parameters

listTrackObjectFlags
Type: List <(Of <(<' String >)>)>
The list track object flags.

See Also

Tracker Class
wManager.Wow.Helpers Namespace


Trainer Class

Class Trainer.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class Trainer
Public NotInheritable Class Trainer
public ref class Trainer abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..Trainer

See Also

Trainer Members
wManager.Wow.Helpers Namespace


Trainer Members

The Trainer type exposes the following members.

Methods

Name | Description
TrainingSpell | Training spells.

See Also

Trainer Class
wManager.Wow.Helpers Namespace


Trainer Methods

The Trainer type exposes the following members.

Methods

Name | Description
TrainingSpell | Training spells.

See Also

Trainer Class
wManager.Wow.Helpers Namespace


TrainingSpell Method

Trainer..::..TrainingSpell Method

Training spells.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void TrainingSpell()
Public Shared Sub TrainingSpell
public:
static void TrainingSpell()

See Also

Trainer Class
wManager.Wow.Helpers Namespace


UnitCanAttack Class

Class UnitCanAttack.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class UnitCanAttack
Public NotInheritable Class UnitCanAttack
public ref class UnitCanAttack abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..UnitCanAttack

See Also

UnitCanAttack Members
wManager.Wow.Helpers Namespace


UnitCanAttack Members

The UnitCanAttack type exposes the following members.

Methods

Name | Description
CanAttack(UInt32) | Returns true if the character can attack the specified unit, false otherwise.
CanAttack(UInt32, UInt32) | Returns true if the first unit can attack the second unit, false otherwise.
CanAttackMe | Returns true if the specified unit can attack the character, false otherwise.

Fields

Name | Description
CanAttackCacheTimeMs | cache time (in milliseconds)

See Also

UnitCanAttack Class
wManager.Wow.Helpers Namespace


UnitCanAttack Fields

The UnitCanAttack type exposes the following members.

Fields

Name | Description
CanAttackCacheTimeMs | cache time (in milliseconds)

See Also

UnitCanAttack Class
wManager.Wow.Helpers Namespace


CanAttackCacheTimeMs Field

UnitCanAttack..::..CanAttackCacheTimeMs Field

cache time (in milliseconds)

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int CanAttackCacheTimeMs
Public Shared CanAttackCacheTimeMs As Integer
public:
static int^ CanAttackCacheTimeMs

See Also

UnitCanAttack Class
wManager.Wow.Helpers Namespace


UnitCanAttack Methods

The UnitCanAttack type exposes the following members.

Methods

Name | Description
CanAttack(UInt32) | Returns true if the character can attack the specified unit, false otherwise.
CanAttack(UInt32, UInt32) | Returns true if the first unit can attack the second unit, false otherwise.
CanAttackMe | Returns true if the specified unit can attack the character, false otherwise.

See Also

UnitCanAttack Class
wManager.Wow.Helpers Namespace


CanAttack Method

UnitCanAttack..::..CanAttack Method

Overload List

Name | Description
CanAttack(UInt32) | Returns true if the character can attack the specified unit, false otherwise.
CanAttack(UInt32, UInt32) | Returns true if the first unit can attack the second unit, false otherwise.

See Also

UnitCanAttack Class
UnitCanAttack Members
wManager.Wow.Helpers Namespace


CanAttack Method (UInt32)

UnitCanAttack..::..CanAttack Method (UInt32)

Returns true if the character can attack the specified unit, false otherwise.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool CanAttack(
    uint baseAddressTarget
)
Public Shared Function CanAttack ( _
    baseAddressTarget As UInteger _
) As Boolean
public:
static bool^ CanAttack(
    unsigned int^ baseAddressTarget
)

Parameters

baseAddressTarget
Type: UInt32
[WoWObject.GetBaseAddress] of specified unit.

Return Value

true if can attack; otherwise, false.

See Also

UnitCanAttack Class
CanAttack Overload
wManager.Wow.Helpers Namespace


CanAttack Method (UInt32, UInt32)

UnitCanAttack..::..CanAttack Method (UInt32, UInt32)

Returns true if the first unit can attack the second unit, false otherwise.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool CanAttack(
    uint baseAddressUnit1,
    uint baseAddressUnit2
)
Public Shared Function CanAttack ( _
    baseAddressUnit1 As UInteger, _
    baseAddressUnit2 As UInteger _
) As Boolean
public:
static bool^ CanAttack(
    unsigned int^ baseAddressUnit1,
    unsigned int^ baseAddressUnit2
)

Parameters

baseAddressUnit1
Type: UInt32
[WoWObject.GetBaseAddress] of first unit.
baseAddressUnit2
Type: UInt32
[WoWObject.GetBaseAddress] of second unit.

Return Value

true if can attack; otherwise, false.

See Also

UnitCanAttack Class
CanAttack Overload
wManager.Wow.Helpers Namespace


CanAttackMe Method

UnitCanAttack..::..CanAttackMe Method

Returns true if the specified unit can attack the character, false otherwise.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool CanAttackMe(
    uint baseAddressTarget
)
Public Shared Function CanAttackMe ( _
    baseAddressTarget As UInteger _
) As Boolean
public:
static bool^ CanAttackMe(
    unsigned int^ baseAddressTarget
)

Parameters

baseAddressTarget
Type: UInt32
[WoWObject.GetBaseAddress] of specified unit.

Return Value

true if can attack; otherwise, false.

See Also

UnitCanAttack Class
wManager.Wow.Helpers Namespace


UnitRelation Class

Class UnitRelation.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class UnitRelation
Public NotInheritable Class UnitRelation
public ref class UnitRelation abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..UnitRelation

See Also

UnitRelation Members
wManager.Wow.Helpers Namespace


UnitRelation Members

The UnitRelation type exposes the following members.

Methods

Name | Description
GetReaction(UInt32) | Get reaction.
GetReaction(UInt32, UInt32) | Get reaction.
GetReaction(WoWObject, WoWObject) | Get reaction.

See Also

UnitRelation Class
wManager.Wow.Helpers Namespace


UnitRelation Methods

The UnitRelation type exposes the following members.

Methods

Name | Description
GetReaction(UInt32) | Get reaction.
GetReaction(UInt32, UInt32) | Get reaction.
GetReaction(WoWObject, WoWObject) | Get reaction.

See Also

UnitRelation Class
wManager.Wow.Helpers Namespace


GetReaction Method

UnitRelation..::..GetReaction Method

Overload List

Name | Description
GetReaction(UInt32) | Get reaction.
GetReaction(UInt32, UInt32) | Get reaction.
GetReaction(WoWObject, WoWObject) | Get reaction.

See Also

UnitRelation Class
UnitRelation Members
wManager.Wow.Helpers Namespace


GetReaction Method (UInt32)

UnitRelation..::..GetReaction Method (UInt32)

Get reaction.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static Reaction GetReaction(
    uint mobFaction
)
Public Shared Function GetReaction ( _
    mobFaction As UInteger _
) As Reaction
public:
static Reaction^ GetReaction(
    unsigned int^ mobFaction
)

Parameters

mobFaction
Type: UInt32
The mob Faction.

Return Value

Reaction.

See Also

UnitRelation Class
GetReaction Overload
wManager.Wow.Helpers Namespace


GetReaction Method (UInt32, UInt32)

UnitRelation..::..GetReaction Method (UInt32, UInt32)

Get reaction.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static Reaction GetReaction(
    uint localFaction,
    uint mobFaction
)
Public Shared Function GetReaction ( _
    localFaction As UInteger, _
    mobFaction As UInteger _
) As Reaction
public:
static Reaction^ GetReaction(
    unsigned int^ localFaction,
    unsigned int^ mobFaction
)

Parameters

localFaction
Type: UInt32
The local Faction.
mobFaction
Type: UInt32
The mob Faction.

Return Value

Reaction.

See Also

UnitRelation Class
GetReaction Overload
wManager.Wow.Helpers Namespace


GetReaction Method (WoWObject, WoWObject)

UnitRelation..::..GetReaction Method (WoWObject, WoWObject)

Get reaction.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static Reaction GetReaction(
    WoWObject localObj,
    WoWObject mobObj
)
Public Shared Function GetReaction ( _
    localObj As WoWObject, _
    mobObj As WoWObject _
) As Reaction
public:
static Reaction^ GetReaction(
    WoWObject^ localObj,
    WoWObject^ mobObj
)

Parameters

localObj
Type: wManager.Wow.ObjectManager..::..WoWObject
The local object.
mobObj
Type: wManager.Wow.ObjectManager..::..WoWObject
The mob object.

Return Value

Reaction.

See Also

UnitRelation Class
GetReaction Overload
wManager.Wow.Helpers Namespace


Usefuls Class

Class Usefuls.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class Usefuls
Public NotInheritable Class Usefuls
public ref class Usefuls abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..Usefuls

See Also

Usefuls Members
wManager.Wow.Helpers Namespace


Usefuls Members

The Usefuls type exposes the following members.

Methods

Name | Description
CopperToString | Coppers to string (result like "0 G 00 S 00 C").
EjectVehicle | Ejects from vehicle.
FrameTime_GetCurTimeMs | Game time in milliseconds.
LaunchWow | Launch World Of Warcraft (return process id).
LuaErrorsCount | Lua errors count.
NeedToUseLuaToMove | Needs to use lua to move (check if simulate keyboard update LastHardwareAction).
SelectGossipOption(Int32) | Selects a gossip (conversation) option.
SelectGossipOption(GossipOptionsType) | Selects the gossip option.
SimulateHardwardAction | Simulates hardware action (anti-afk).
StringToCopper | Strings to copper (value like "0 G 00 S 00 C").
TextBoxActivated | Textbox activated (game textbox for send chat message or use macro).
WaitIsCasting | Wait the is casting (max Latency + 350 + 1000 * 60).
WaitIsCastingAndLooting | Wait is casting and looting (call WaitIsCasting()()()() and WaitIsLooting()()()()).
WaitIsLooting | Wait is looting (max 2200 ms + Latency * 2).
WowAddon | Gets Wow addons.
WowVersionBuild | Gets game build (extract from WowVersionString(Memory), value like "12340").
WowVersionString | Gets game version (string format like "Version 3.3.5 (12340) (Release)").

Fields

Name | Description
ForceIsFlyableArea | Force IsFlyableArea to return true (bot use https://wow.gamepedia.com/API_IsFlyableArea , but sometime result is incorrect)

Properties

Name | Description
AreaId | Obsolete. Gets the area id.
ContinentId | Gets the continent id.
ContinentNameMpq | Gets the continent name (file name).
InGame | Gets a value indicating whether in game (to be safe you need to check if not IsLoadingOrConnecting).
IsFlyableArea | Gets a value indicating whether is flyable area (you can force value with ForceIsFlyableArea).
IsLoadingOrConnecting | Gets a value indicating whether game is loading or connecting.
LastHardwareAction | Gets the last hardware action.
Latency | Gets the latency (between LatencyMax and LatencyMin, to get real latency use LatencyReal).
LatencyReal | Gets the real latency (home+world)).
MapZoneName | Gets the name of the map zone.
RealmName | Gets the name of the realm.
SubMapZoneName | Gets the name of the sub map zone.
WowVersion | Gets game build (extract from WowVersionString(Memory), value like "12340").

See Also

Usefuls Class
wManager.Wow.Helpers Namespace


Usefuls Fields

The Usefuls type exposes the following members.

Fields

Name | Description
ForceIsFlyableArea | Force IsFlyableArea to return true (bot use https://wow.gamepedia.com/API_IsFlyableArea , but sometime result is incorrect)

See Also

Usefuls Class
wManager.Wow.Helpers Namespace


ForceIsFlyableArea Field

Usefuls..::..ForceIsFlyableArea Field

Force IsFlyableArea to return true (bot use https://wow.gamepedia.com/API_IsFlyableArea , but sometime result is incorrect)

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool ForceIsFlyableArea
Public Shared ForceIsFlyableArea As Boolean
public:
static bool^ ForceIsFlyableArea

See Also

Usefuls Class
wManager.Wow.Helpers Namespace


Usefuls Methods

The Usefuls type exposes the following members.

Methods

Name | Description
CopperToString | Coppers to string (result like "0 G 00 S 00 C").
EjectVehicle | Ejects from vehicle.
FrameTime_GetCurTimeMs | Game time in milliseconds.
LaunchWow | Launch World Of Warcraft (return process id).
LuaErrorsCount | Lua errors count.
NeedToUseLuaToMove | Needs to use lua to move (check if simulate keyboard update LastHardwareAction).
SelectGossipOption(Int32) | Selects a gossip (conversation) option.
SelectGossipOption(GossipOptionsType) | Selects the gossip option.
SimulateHardwardAction | Simulates hardware action (anti-afk).
StringToCopper | Strings to copper (value like "0 G 00 S 00 C").
TextBoxActivated | Textbox activated (game textbox for send chat message or use macro).
WaitIsCasting | Wait the is casting (max Latency + 350 + 1000 * 60).
WaitIsCastingAndLooting | Wait is casting and looting (call WaitIsCasting()()()() and WaitIsLooting()()()()).
WaitIsLooting | Wait is looting (max 2200 ms + Latency * 2).
WowAddon | Gets Wow addons.
WowVersionBuild | Gets game build (extract from WowVersionString(Memory), value like "12340").
WowVersionString | Gets game version (string format like "Version 3.3.5 (12340) (Release)").

See Also

Usefuls Class
wManager.Wow.Helpers Namespace


CopperToString Method

Usefuls..::..CopperToString Method

Coppers to string (result like "0 G 00 S 00 C").

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string CopperToString(
    long copper
)
Public Shared Function CopperToString ( _
    copper As Long _
) As String
public:
static String^ CopperToString(
    long long^ copper
)

Parameters

copper
Type: Int64
The copper.

Return Value

System.String.

See Also

Usefuls Class
wManager.Wow.Helpers Namespace


EjectVehicle Method

Usefuls..::..EjectVehicle Method

Ejects from vehicle.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void EjectVehicle()
Public Shared Sub EjectVehicle
public:
static void EjectVehicle()

See Also

Usefuls Class
wManager.Wow.Helpers Namespace


FrameTime_GetCurTimeMs Method

Usefuls..::..FrameTime_GetCurTimeMs Method

Game time in milliseconds.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int FrameTime_GetCurTimeMs()
Public Shared Function FrameTime_GetCurTimeMs As Integer
public:
static int^ FrameTime_GetCurTimeMs()

Return Value

System.Int32.

See Also

Usefuls Class
wManager.Wow.Helpers Namespace


LaunchWow Method

Usefuls..::..LaunchWow Method

Launch World Of Warcraft (return process id).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int LaunchWow(
    bool deleteWow64Process,
    bool requestIfWantLaunch
)
Public Shared Function LaunchWow ( _
    deleteWow64Process As Boolean, _
    requestIfWantLaunch As Boolean _
) As Integer
public:
static int^ LaunchWow(
    bool^ deleteWow64Process,
    bool^ requestIfWantLaunch
)

Parameters

deleteWow64Process
Type: Boolean
if set to true delete wow64 process.
requestIfWantLaunch
Type: Boolean
if set to true request if want launch (before to launch).

Return Value

System.Int32.

See Also

Usefuls Class
wManager.Wow.Helpers Namespace


LuaErrorsCount Method

Usefuls..::..LuaErrorsCount Method

Lua errors count.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int LuaErrorsCount()
Public Shared Function LuaErrorsCount As Integer
public:
static int^ LuaErrorsCount()

Return Value

System.Int32.

See Also

Usefuls Class
wManager.Wow.Helpers Namespace


NeedToUseLuaToMove Method

Usefuls..::..NeedToUseLuaToMove Method

Needs to use lua to move (check if simulate keyboard update LastHardwareAction).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool NeedToUseLuaToMove()
Public Shared Function NeedToUseLuaToMove As Boolean
public:
static bool^ NeedToUseLuaToMove()

Return Value

true if cannot use keyboard, false otherwise.

See Also

Usefuls Class
wManager.Wow.Helpers Namespace


SelectGossipOption Method

Usefuls..::..SelectGossipOption Method

Overload List

Name | Description
SelectGossipOption(Int32) | Selects a gossip (conversation) option.
SelectGossipOption(GossipOptionsType) | Selects the gossip option.

See Also

Usefuls Class
Usefuls Members
wManager.Wow.Helpers Namespace


SelectGossipOption Method (Int32)

Usefuls..::..SelectGossipOption Method (Int32)

Selects a gossip (conversation) option.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void SelectGossipOption(
    int gossipOption
)
Public Shared Sub SelectGossipOption ( _
    gossipOption As Integer _
)
public:
static void SelectGossipOption(
    int^ gossipOption
)

Parameters

gossipOption
Type: Int32
Ranging from 1

See Also

Usefuls Class
SelectGossipOption Overload
wManager.Wow.Helpers Namespace


SelectGossipOption Method (GossipOptionsType)

Usefuls..::..SelectGossipOption Method (GossipOptionsType)

Selects the gossip option.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void SelectGossipOption(
    GossipOptionsType gossipOption
)
Public Shared Sub SelectGossipOption ( _
    gossipOption As GossipOptionsType _
)
public:
static void SelectGossipOption(
    GossipOptionsType^ gossipOption
)

Parameters

gossipOption
Type: wManager.Wow.Enums..::..GossipOptionsType
The gossip option type.

See Also

Usefuls Class
SelectGossipOption Overload
wManager.Wow.Helpers Namespace


SimulateHardwardAction Method

Usefuls..::..SimulateHardwardAction Method

Simulates hardware action (anti-afk).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void SimulateHardwardAction()
Public Shared Sub SimulateHardwardAction
public:
static void SimulateHardwardAction()

See Also

Usefuls Class
wManager.Wow.Helpers Namespace


StringToCopper Method

Usefuls..::..StringToCopper Method

Strings to copper (value like "0 G 00 S 00 C").

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static long StringToCopper(
    string stringMoney
)
Public Shared Function StringToCopper ( _
    stringMoney As String _
) As Long
public:
static long long^ StringToCopper(
    String^ stringMoney
)

Parameters

stringMoney
Type: String
The string money (value like "0 G 00 S 00 C").

Return Value

System.Int64.

See Also

Usefuls Class
wManager.Wow.Helpers Namespace


TextBoxActivated Method

Usefuls..::..TextBoxActivated Method

Textbox activated (game textbox for send chat message or use macro).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool TextBoxActivated()
Public Shared Function TextBoxActivated As Boolean
public:
static bool^ TextBoxActivated()

Return Value

true if active, false otherwise.

See Also

Usefuls Class
wManager.Wow.Helpers Namespace


WaitIsCasting Method

Usefuls..::..WaitIsCasting Method

Wait the is casting (max Latency + 350 + 1000 * 60).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void WaitIsCasting()
Public Shared Sub WaitIsCasting
public:
static void WaitIsCasting()

See Also

Usefuls Class
wManager.Wow.Helpers Namespace


WaitIsCastingAndLooting Method

Usefuls..::..WaitIsCastingAndLooting Method

Wait is casting and looting (call WaitIsCasting()()()() and WaitIsLooting()()()()).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void WaitIsCastingAndLooting()
Public Shared Sub WaitIsCastingAndLooting
public:
static void WaitIsCastingAndLooting()

See Also

Usefuls Class
wManager.Wow.Helpers Namespace


WaitIsLooting Method

Usefuls..::..WaitIsLooting Method

Wait is looting (max 2200 ms + Latency * 2).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void WaitIsLooting()
Public Shared Sub WaitIsLooting
public:
static void WaitIsLooting()

See Also

Usefuls Class
wManager.Wow.Helpers Namespace


WowAddon Method

Usefuls..::..WowAddon Method

Gets Wow addons.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string[] WowAddon()
Public Shared Function WowAddon As String()
public:
static array<String^>^ WowAddon()

Return Value

addons list.

See Also

Usefuls Class
wManager.Wow.Helpers Namespace


WowVersionBuild Method

Usefuls..::..WowVersionBuild Method

Gets game build (extract from WowVersionString(Memory), value like "12340").

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static uint WowVersionBuild(
    Memory memory
)
Public Shared Function WowVersionBuild ( _
    memory As Memory _
) As UInteger
public:
static unsigned int^ WowVersionBuild(
    Memory^ memory
)

Parameters

memory
Type: Memory
The game memory.

Return Value

the game build.

See Also

Usefuls Class
wManager.Wow.Helpers Namespace


WowVersionString Method

Usefuls..::..WowVersionString Method

Gets game version (string format like "Version 3.3.5 (12340) (Release)").

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string WowVersionString(
    Memory memory
)
Public Shared Function WowVersionString ( _
    memory As Memory _
) As String
public:
static String^ WowVersionString(
    Memory^ memory
)

Parameters

memory
Type: Memory
The game memory.

Return Value

the game version.

See Also

Usefuls Class
wManager.Wow.Helpers Namespace


Usefuls Properties

The Usefuls type exposes the following members.

Properties

Name | Description
AreaId | Obsolete. Gets the area id.
ContinentId | Gets the continent id.
ContinentNameMpq | Gets the continent name (file name).
InGame | Gets a value indicating whether in game (to be safe you need to check if not IsLoadingOrConnecting).
IsFlyableArea | Gets a value indicating whether is flyable area (you can force value with ForceIsFlyableArea).
IsLoadingOrConnecting | Gets a value indicating whether game is loading or connecting.
LastHardwareAction | Gets the last hardware action.
Latency | Gets the latency (between LatencyMax and LatencyMin, to get real latency use LatencyReal).
LatencyReal | Gets the real latency (home+world)).
MapZoneName | Gets the name of the map zone.
RealmName | Gets the name of the realm.
SubMapZoneName | Gets the name of the sub map zone.
WowVersion | Gets game build (extract from WowVersionString(Memory), value like "12340").

See Also

Usefuls Class
wManager.Wow.Helpers Namespace


AreaId Property

Usefuls..::..AreaId Property

Note: This API is now obsolete.
Gets the area id.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[ObsoleteAttribute]
public static int AreaId { get; }
<ObsoleteAttribute> _
Public Shared ReadOnly Property AreaId As Integer
    Get
[ObsoleteAttribute]
public:
static property int^ AreaId {
    int^ get ();
}

Field Value

The area id.

See Also

Usefuls Class
wManager.Wow.Helpers Namespace


ContinentId Property

Usefuls..::..ContinentId Property

Gets the continent id.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int ContinentId { get; }
Public Shared ReadOnly Property ContinentId As Integer
    Get
public:
static property int^ ContinentId {
    int^ get ();
}

Field Value

The continent id.

See Also

Usefuls Class
wManager.Wow.Helpers Namespace


ContinentNameMpq Property

Usefuls..::..ContinentNameMpq Property

Gets the continent name (file name).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string ContinentNameMpq { get; }
Public Shared ReadOnly Property ContinentNameMpq As String
    Get
public:
static property String^ ContinentNameMpq {
    String^ get ();
}

Field Value

The continent name (file name).

See Also

Usefuls Class
wManager.Wow.Helpers Namespace


InGame Property

Usefuls..::..InGame Property

Gets a value indicating whether in game (to be safe you need to check if not IsLoadingOrConnecting).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool InGame { get; }
Public Shared ReadOnly Property InGame As Boolean
    Get
public:
static property bool^ InGame {
    bool^ get ();
}

Field Value

true if in game; otherwise, false.

See Also

Usefuls Class
wManager.Wow.Helpers Namespace


IsFlyableArea Property

Usefuls..::..IsFlyableArea Property

Gets a value indicating whether is flyable area (you can force value with ForceIsFlyableArea).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool IsFlyableArea { get; }
Public Shared ReadOnly Property IsFlyableArea As Boolean
    Get
public:
static property bool^ IsFlyableArea {
    bool^ get ();
}

Field Value

true if this is flyable area; otherwise, false.

See Also

Usefuls Class
wManager.Wow.Helpers Namespace


IsLoadingOrConnecting Property

Usefuls..::..IsLoadingOrConnecting Property

Gets a value indicating whether game is loading or connecting.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool IsLoadingOrConnecting { get; }
Public Shared ReadOnly Property IsLoadingOrConnecting As Boolean
    Get
public:
static property bool^ IsLoadingOrConnecting {
    bool^ get ();
}

Field Value

true if is loading or connecting; otherwise, false.

See Also

Usefuls Class
wManager.Wow.Helpers Namespace


LastHardwareAction Property

Usefuls..::..LastHardwareAction Property

Gets the last hardware action.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static ulong LastHardwareAction { get; }
Public Shared ReadOnly Property LastHardwareAction As ULong
    Get
public:
static property unsigned long long^ LastHardwareAction {
    unsigned long long^ get ();
}

Field Value

The last hardware action.

See Also

Usefuls Class
wManager.Wow.Helpers Namespace


Latency Property

Usefuls..::..Latency Property

Gets the latency (between LatencyMax and LatencyMin, to get real latency use LatencyReal).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int Latency { get; }
Public Shared ReadOnly Property Latency As Integer
    Get
public:
static property int^ Latency {
    int^ get ();
}

Field Value

The latency.

See Also

Usefuls Class
wManager.Wow.Helpers Namespace


LatencyReal Property

Usefuls..::..LatencyReal Property

Gets the real latency (home+world)).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int LatencyReal { get; }
Public Shared ReadOnly Property LatencyReal As Integer
    Get
public:
static property int^ LatencyReal {
    int^ get ();
}

Field Value

The real latency.

See Also

Usefuls Class
wManager.Wow.Helpers Namespace


MapZoneName Property

Usefuls..::..MapZoneName Property

Gets the name of the map zone.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string MapZoneName { get; }
Public Shared ReadOnly Property MapZoneName As String
    Get
public:
static property String^ MapZoneName {
    String^ get ();
}

Field Value

The name of the map zone.

See Also

Usefuls Class
wManager.Wow.Helpers Namespace


RealmName Property

Usefuls..::..RealmName Property

Gets the name of the realm.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string RealmName { get; }
Public Shared ReadOnly Property RealmName As String
    Get
public:
static property String^ RealmName {
    String^ get ();
}

Field Value

The name of the realm.

See Also

Usefuls Class
wManager.Wow.Helpers Namespace


SubMapZoneName Property

Usefuls..::..SubMapZoneName Property

Gets the name of the sub map zone.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string SubMapZoneName { get; }
Public Shared ReadOnly Property SubMapZoneName As String
    Get
public:
static property String^ SubMapZoneName {
    String^ get ();
}

Field Value

The name of the sub map zone.

See Also

Usefuls Class
wManager.Wow.Helpers Namespace


WowVersion Property

Usefuls..::..WowVersion Property

Gets game build (extract from WowVersionString(Memory), value like "12340").

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static uint WowVersion { get; }
Public Shared ReadOnly Property WowVersion As UInteger
    Get
public:
static property unsigned int^ WowVersion {
    unsigned int^ get ();
}

Return Value

the game build.

See Also

Usefuls Class
wManager.Wow.Helpers Namespace


Vendor Class

Class Vendor. Few useful method to sell, repair and buy items

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class Vendor
Public NotInheritable Class Vendor
public ref class Vendor abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..Vendor

See Also

Vendor Members
wManager.Wow.Helpers Namespace


Vendor Members

The Vendor type exposes the following members.

Methods

Name | Description
BuyItem | Buy item.
RepairAllItems | Repair all items.
SellItems | Sell the items.

See Also

Vendor Class
wManager.Wow.Helpers Namespace


Vendor Methods

The Vendor type exposes the following members.

Methods

Name | Description
BuyItem | Buy item.
RepairAllItems | Repair all items.
SellItems | Sell the items.

See Also

Vendor Class
wManager.Wow.Helpers Namespace


BuyItem Method

Vendor..::..BuyItem Method

Buy item.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void BuyItem(
    string name,
    int number
)
Public Shared Sub BuyItem ( _
    name As String, _
    number As Integer _
)
public:
static void BuyItem(
    String^ name,
    int^ number
)

Parameters

name
Type: String
The name.
number
Type: Int32
The number.

See Also

Vendor Class
wManager.Wow.Helpers Namespace


RepairAllItems Method

Vendor..::..RepairAllItems Method

Repair all items.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void RepairAllItems()
Public Shared Sub RepairAllItems
public:
static void RepairAllItems()

See Also

Vendor Class
wManager.Wow.Helpers Namespace


SellItems Method

Vendor..::..SellItems Method

Sell the items.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void SellItems(
    List<string> itemSell,
    List<string> itemNoSell,
    List<WoWItemQuality> itemQuality
)
Public Shared Sub SellItems ( _
    itemSell As List(Of String), _
    itemNoSell As List(Of String), _
    itemQuality As List(Of WoWItemQuality) _
)
public:
static void SellItems(
    List<String^>^ itemSell,
    List<String^>^ itemNoSell,
    List<WoWItemQuality^>^ itemQuality
)

Parameters

itemSell
Type: List <(Of <(<' String >)>)>
items to sell.
itemNoSell
Type: List <(Of <(<' String >)>)>
items to not sell.
itemQuality
Type: List <(Of <(<' WoWItemQuality >)>)>
qualities of items to sell.

See Also

Vendor Class
wManager.Wow.Helpers Namespace


WoWFactionTemplate Class

Class WoWFactionTemplate (DB2).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class WoWFactionTemplate
Public Class WoWFactionTemplate
public ref class WoWFactionTemplate

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..WoWFactionTemplate

See Also

WoWFactionTemplate Members
wManager.Wow.Helpers Namespace


WoWFactionTemplate Members

The WoWFactionTemplate type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
 | FromId | By ID.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetReactionTowards | Get the reaction towards.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Id | Get the id.
Public property | Record | Get record.

See Also

WoWFactionTemplate Class
wManager.Wow.Helpers Namespace


WoWFactionTemplate Methods

The WoWFactionTemplate type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
 | FromId | By ID.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetReactionTowards | Get the reaction towards.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

WoWFactionTemplate Class
wManager.Wow.Helpers Namespace


FromId Method

WoWFactionTemplate..::..FromId Method

By ID.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static WoWFactionTemplate FromId(
    uint id
)
Public Shared Function FromId ( _
    id As UInteger _
) As WoWFactionTemplate
public:
static WoWFactionTemplate^ FromId(
    unsigned int^ id
)

Parameters

id
Type: UInt32
The id.

Return Value

WoWFactionTemplate.

See Also

WoWFactionTemplate Class
wManager.Wow.Helpers Namespace


GetReactionTowards Method

WoWFactionTemplate..::..GetReactionTowards Method

Get the reaction towards.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Reaction GetReactionTowards(
    WoWFactionTemplate otherFaction
)
Public Function GetReactionTowards ( _
    otherFaction As WoWFactionTemplate _
) As Reaction
public:
Reaction^ GetReactionTowards(
    WoWFactionTemplate^ otherFaction
)

Parameters

otherFaction
Type: wManager.Wow.Helpers..::..WoWFactionTemplate
The other faction.

Return Value

Reaction.

See Also

WoWFactionTemplate Class
wManager.Wow.Helpers Namespace


WoWFactionTemplate Properties

The WoWFactionTemplate type exposes the following members.

Properties

 | Name | Description
Public property | Id | Get the id.
Public property | Record | Get record.

See Also

WoWFactionTemplate Class
wManager.Wow.Helpers Namespace


Id Property

WoWFactionTemplate..::..Id Property

Get the id.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[CompilerGeneratedAttribute]
[CompilerGeneratedAttribute]
public uint Id { get; set; }
<CompilerGeneratedAttribute> _
<CompilerGeneratedAttribute> _
Public Property Id As UInteger
    Get
    Set
[CompilerGeneratedAttribute]
[CompilerGeneratedAttribute]
public:
property unsigned int^ Id {
    unsigned int^ get ();
    void set (unsigned int^ value);
}

Field Value

The id.

See Also

WoWFactionTemplate Class
wManager.Wow.Helpers Namespace


Record Property

WoWFactionTemplate..::..Record Property

Get record.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[CompilerGeneratedAttribute]
[CompilerGeneratedAttribute]
public WoWFactionTemplate..::..FactionTemplateDbcRecord Record { get; set; }
<CompilerGeneratedAttribute> _
<CompilerGeneratedAttribute> _
Public Property Record As WoWFactionTemplate..::..FactionTemplateDbcRecord
    Get
    Set
[CompilerGeneratedAttribute]
[CompilerGeneratedAttribute]
public:
property WoWFactionTemplate..::..FactionTemplateDbcRecord^ Record {
    WoWFactionTemplate..::..FactionTemplateDbcRecord^ get ();
    void set (WoWFactionTemplate..::..FactionTemplateDbcRecord^ value);
}

Field Value

The record.

See Also

WoWFactionTemplate Class
wManager.Wow.Helpers Namespace


WoWFactionTemplate.FactionTemplateDbcRecord Structure

WoWFactionTemplate..::..FactionTemplateDbcRecord Structure

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[StructLayoutAttribute]
public struct FactionTemplateDbcRecord
<StructLayoutAttribute> _
Public Structure FactionTemplateDbcRecord
[StructLayoutAttribute]
public value class FactionTemplateDbcRecord

See Also

WoWFactionTemplate..::..FactionTemplateDbcRecord Members
wManager.Wow.Helpers Namespace


WoWFactionTemplate.FactionTemplateDbcRecord Members

WoWFactionTemplate..::..FactionTemplateDbcRecord Members

The WoWFactionTemplate..::..FactionTemplateDbcRecord type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from ValueType.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from ValueType.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from ValueType.)

Fields

 | Name | Description
Public field | EnemyFactions |
Public field | FactionFlags |
Public field | FactionId |
Public field | FightSupport |
Public field | FriendlyFactions |
Public field | FriendlyMask |
Public field | HostileMask |
Public field | Id |

See Also

WoWFactionTemplate..::..FactionTemplateDbcRecord Structure
wManager.Wow.Helpers Namespace


WoWFactionTemplate.FactionTemplateDbcRecord Fields

WoWFactionTemplate..::..FactionTemplateDbcRecord Fields

The WoWFactionTemplate..::..FactionTemplateDbcRecord type exposes the following members.

Fields

 | Name | Description
Public field | EnemyFactions |
Public field | FactionFlags |
Public field | FactionId |
Public field | FightSupport |
Public field | FriendlyFactions |
Public field | FriendlyMask |
Public field | HostileMask |
Public field | Id |

See Also

WoWFactionTemplate..::..FactionTemplateDbcRecord Structure
wManager.Wow.Helpers Namespace


EnemyFactions Field

FactionTemplateDbcRecord..::..EnemyFactions Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[MarshalAsAttribute]
public uint[] EnemyFactions
<MarshalAsAttribute> _
Public EnemyFactions As UInteger()
[MarshalAsAttribute]
public:
array<unsigned int^>^ EnemyFactions

See Also

WoWFactionTemplate..::..FactionTemplateDbcRecord Structure
wManager.Wow.Helpers Namespace


FactionFlags Field

FactionTemplateDbcRecord..::..FactionFlags Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint FactionFlags
Public FactionFlags As UInteger
public:
unsigned int^ FactionFlags

See Also

WoWFactionTemplate..::..FactionTemplateDbcRecord Structure
wManager.Wow.Helpers Namespace


FactionId Field

FactionTemplateDbcRecord..::..FactionId Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint FactionId
Public FactionId As UInteger
public:
unsigned int^ FactionId

See Also

WoWFactionTemplate..::..FactionTemplateDbcRecord Structure
wManager.Wow.Helpers Namespace


FightSupport Field

FactionTemplateDbcRecord..::..FightSupport Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint FightSupport
Public FightSupport As UInteger
public:
unsigned int^ FightSupport

See Also

WoWFactionTemplate..::..FactionTemplateDbcRecord Structure
wManager.Wow.Helpers Namespace


FriendlyFactions Field

FactionTemplateDbcRecord..::..FriendlyFactions Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[MarshalAsAttribute]
public uint[] FriendlyFactions
<MarshalAsAttribute> _
Public FriendlyFactions As UInteger()
[MarshalAsAttribute]
public:
array<unsigned int^>^ FriendlyFactions

See Also

WoWFactionTemplate..::..FactionTemplateDbcRecord Structure
wManager.Wow.Helpers Namespace


FriendlyMask Field

FactionTemplateDbcRecord..::..FriendlyMask Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint FriendlyMask
Public FriendlyMask As UInteger
public:
unsigned int^ FriendlyMask

See Also

WoWFactionTemplate..::..FactionTemplateDbcRecord Structure
wManager.Wow.Helpers Namespace


HostileMask Field

FactionTemplateDbcRecord..::..HostileMask Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint HostileMask
Public HostileMask As UInteger
public:
unsigned int^ HostileMask

See Also

WoWFactionTemplate..::..FactionTemplateDbcRecord Structure
wManager.Wow.Helpers Namespace


Id Field

FactionTemplateDbcRecord..::..Id Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint Id
Public Id As UInteger
public:
unsigned int^ Id

See Also

WoWFactionTemplate..::..FactionTemplateDbcRecord Structure
wManager.Wow.Helpers Namespace


WoWFactionTemplate.FactionTemplateDbcRecord Methods

WoWFactionTemplate..::..FactionTemplateDbcRecord Methods

The WoWFactionTemplate..::..FactionTemplateDbcRecord type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from ValueType.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from ValueType.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from ValueType.)

See Also

WoWFactionTemplate..::..FactionTemplateDbcRecord Structure
wManager.Wow.Helpers Namespace


WoWLock Class

Class WoWLock (DB2).

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class WoWLock
Public Class WoWLock
public ref class WoWLock

Inheritance Hierarchy

Object
wManager.Wow.Helpers..::..WoWLock

See Also

WoWLock Members
wManager.Wow.Helpers Namespace


WoWLock Members

The WoWLock type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
 | FromId | By id.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Record | Get record.

See Also

WoWLock Class
wManager.Wow.Helpers Namespace


WoWLock Methods

The WoWLock type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
 | FromId | By id.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

WoWLock Class
wManager.Wow.Helpers Namespace


FromId Method

WoWLock..::..FromId Method

By id.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static WoWLock FromId(
    uint id
)
Public Shared Function FromId ( _
    id As UInteger _
) As WoWLock
public:
static WoWLock^ FromId(
    unsigned int^ id
)

Parameters

id
Type: UInt32
The id.

Return Value

WoWLock.

See Also

WoWLock Class
wManager.Wow.Helpers Namespace


WoWLock Properties

The WoWLock type exposes the following members.

Properties

 | Name | Description
Public property | Record | Get record.

See Also

WoWLock Class
wManager.Wow.Helpers Namespace


Record Property

WoWLock..::..Record Property

Get record.

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public WoWLock..::..LockDbcRecord Record { get; }
Public ReadOnly Property Record As WoWLock..::..LockDbcRecord
    Get
public:
property WoWLock..::..LockDbcRecord^ Record {
    WoWLock..::..LockDbcRecord^ get ();
}

Field Value

The record.

See Also

WoWLock Class
wManager.Wow.Helpers Namespace


WoWLock.LockDbcRecord Structure

WoWLock..::..LockDbcRecord Structure

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[StructLayoutAttribute]
public struct LockDbcRecord
<StructLayoutAttribute> _
Public Structure LockDbcRecord
[StructLayoutAttribute]
public value class LockDbcRecord

See Also

WoWLock..::..LockDbcRecord Members
wManager.Wow.Helpers Namespace


WoWLock.LockDbcRecord Members

WoWLock..::..LockDbcRecord Members

The WoWLock..::..LockDbcRecord type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from ValueType.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from ValueType.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from ValueType.)

Fields

 | Name | Description
Public field | Action |
Public field | Id |
Public field | KeyType |
Public field | LockType |
Public field | Skill |

See Also

WoWLock..::..LockDbcRecord Structure
wManager.Wow.Helpers Namespace


WoWLock.LockDbcRecord Fields

WoWLock..::..LockDbcRecord Fields

The WoWLock..::..LockDbcRecord type exposes the following members.

Fields

 | Name | Description
Public field | Action |
Public field | Id |
Public field | KeyType |
Public field | LockType |
Public field | Skill |

See Also

WoWLock..::..LockDbcRecord Structure
wManager.Wow.Helpers Namespace


Action Field

LockDbcRecord..::..Action Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[MarshalAsAttribute]
public uint[] Action
<MarshalAsAttribute> _
Public Action As UInteger()
[MarshalAsAttribute]
public:
array<unsigned int^>^ Action

See Also

WoWLock..::..LockDbcRecord Structure
wManager.Wow.Helpers Namespace


Id Field

LockDbcRecord..::..Id Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint Id
Public Id As UInteger
public:
unsigned int^ Id

See Also

WoWLock..::..LockDbcRecord Structure
wManager.Wow.Helpers Namespace


KeyType Field

LockDbcRecord..::..KeyType Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[MarshalAsAttribute]
public uint[] KeyType
<MarshalAsAttribute> _
Public KeyType As UInteger()
[MarshalAsAttribute]
public:
array<unsigned int^>^ KeyType

See Also

WoWLock..::..LockDbcRecord Structure
wManager.Wow.Helpers Namespace


LockType Field

LockDbcRecord..::..LockType Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[MarshalAsAttribute]
public uint[] LockType
<MarshalAsAttribute> _
Public LockType As UInteger()
[MarshalAsAttribute]
public:
array<unsigned int^>^ LockType

See Also

WoWLock..::..LockDbcRecord Structure
wManager.Wow.Helpers Namespace


Skill Field

LockDbcRecord..::..Skill Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[MarshalAsAttribute]
public uint[] Skill
<MarshalAsAttribute> _
Public Skill As UInteger()
[MarshalAsAttribute]
public:
array<unsigned int^>^ Skill

See Also

WoWLock..::..LockDbcRecord Structure
wManager.Wow.Helpers Namespace


WoWLock.LockDbcRecord Methods

WoWLock..::..LockDbcRecord Methods

The WoWLock..::..LockDbcRecord type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from ValueType.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from ValueType.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from ValueType.)

See Also

WoWLock..::..LockDbcRecord Structure
wManager.Wow.Helpers Namespace


wManager.Wow.Helpers.FightClassCreator Namespace

Classes

 | Class | Description
Public class | Creator | Fight classes creator. Implements the Form
Public class | FightClass | Class FightClass (used by XML fight classes and editor).
Public class | FightClassCondition | Class FightClassCondition (used by XML fight classes and editor).
Public class | FightClassConditionBase | Class FightClassConditionBase (used by XML fight classes and editor).
Public class | FightClassConditionBool | Class FightClassConditionBool (used by XML fight classes and editor). Implements the FightClassConditionBase
Public class | FightClassConditionBuffStack | Class FightClassConditionBuffStack (used by XML fight classes and editor). Implements the FightClassConditionBase
Public class | FightClassConditionItemNumber | Class FightClassConditionItemNumber (used by XML fight classes and editor). Implements the FightClassConditionBase
Public class | FightClassConditionLua | Class FightClassConditionLua (used by XML fight classes and editor). Implements the FightClassConditionBase
Public class | FightClassConditionNumber | Class FightClassConditionNumber (used by XML fight classes and editor). Implements the FightClassConditionBase
Public class | FightClassConditionString | Class FightClassConditionString (used by XML fight classes and editor). Implements the FightClassConditionBase
Public class | FightClassConditionStringArray | Class FightClassConditionStringArray (used by XML fight classes and editor). Implements the FightClassConditionBase
Public class | FightClassConditionStringBool | Class FightClassConditionStringBool (used by XML fight classes and editor). Implements the FightClassConditionBase
Public class | FightClassConditionUnitNear | Class FightClassConditionUnitNear (used by XML fight classes and editor). Implements the FightClassConditionBase
Public class | FightClassGeneralSettings | Class FightClassGeneralSettings (used by XML fight classes and editor).
Public class | FightClassSpell | Class FightClassSpell (used by XML fight classes and editor).
Public class | FightClassSpellsDB | Class FightClassSpellsDB. Implements the Form

Enumerations

 | Enumeration | Description
Public enumeration | FightClassConditionNumberType | FightClassConditionNumberType (used by XML fight classes and editor).
Public enumeration | FightClassContionsType | FightClassContionsType (used by XML fight classes and editor).
Public enumeration | UnitIdLua | UnitIdLua (used by XML fight classes and editor).
Public enumeration | YesNoAuto | YesNoAuto (used by XML fight classes and editor).


Creator Class

Fight classes creator. Implements the Form

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class Creator : Form
Public Class Creator _
    Inherits Form
public ref class Creator : public Form

Inheritance Hierarchy

Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
wManager.Wow.Helpers.FightClassCreator..::..Creator

See Also

Creator Members
wManager.Wow.Helpers.FightClassCreator Namespace
Form


Creator Members

The Creator type exposes the following members.

Constructors

 | Name | Description
Public method | Creator |

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Public method | Activate | (Inherited from Form.)
Protected method | ActivateMdiChild(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | AddOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from Form.)
Protected method | ApplyAutoScaling | (Inherited from Form.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Protected method | CenterToParent | (Inherited from Form.)
Protected method | CenterToScreen | (Inherited from Form.)
Public method | Close | (Inherited from Form.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Form.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Clean up any resources being used.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Public method | LayoutMdi(System.Windows.Forms.MdiLayout) | (Inherited from Form.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnActivated(System.EventArgs) | (Inherited from Form.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnClosed(System.EventArgs) | (Inherited from Form.)
Protected method | OnClosing(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from Form.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDeactivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Form.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnFormClosed(System.Windows.Forms.FormClosedEventArgs) | (Inherited from Form.)
Protected method | OnFormClosing(System.Windows.Forms.FormClosingEventArgs) | (Inherited from Form.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Form.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Form.)
Protected method | OnHelpButtonClicked(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInputLanguageChanged(System.Windows.Forms.InputLanguageChangedEventArgs) | (Inherited from Form.)
Protected method | OnInputLanguageChanging(System.Windows.Forms.InputLanguageChangingEventArgs) | (Inherited from Form.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from Form.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from Form.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMaximumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMdiChildActivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuComplete(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuStart(System.EventArgs) | (Inherited from Form.)
Protected method | OnMinimumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Form.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeBegin(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeEnd(System.EventArgs) | (Inherited from Form.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnShown(System.EventArgs) | (Inherited from Form.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from Form.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from Form.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from Form.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | RemoveOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from Form.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from Form.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopLocation(System.Int32,System.Int32) | (Inherited from Form.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Form.)
Public method | Show(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Public method | Show | (Inherited from Control.)
Public method | ShowDialog | (Inherited from Form.)
Public method | ShowDialog(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Form.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from Form.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from Form.)

Properties

 | Name | Description
Public property | AcceptButton | (Inherited from Form.)
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | ActiveMdiChild | (Inherited from Form.)
Public property | AllowDrop | (Inherited from Control.)
Public property | AllowTransparency | (Inherited from Form.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScale | (Inherited from Form.)
Public property | AutoScaleBaseSize | (Inherited from Form.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from Form.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Form.)
Public property | AutoSizeMode | (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Public property | CancelButton | (Inherited from Form.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Form.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | ControlBox | (Inherited from Form.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Form.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DesktopBounds | (Inherited from Form.)
Public property | DesktopLocation | (Inherited from Form.)
Public property | DialogResult | (Inherited from Form.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | FormBorderStyle | (Inherited from Form.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HelpButton | (Inherited from Form.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | Icon | (Inherited from Form.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMdiChild | (Inherited from Form.)
Public property | IsMdiContainer | (Inherited from Form.)
Public property | IsMirrored | (Inherited from Control.)
Public property | IsRestrictedWindow | (Inherited from Form.)
Public property | KeyPreview | (Inherited from Form.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Form.)
Public property | MainMenuStrip | (Inherited from Form.)
Public property | Margin | (Inherited from Form.)
Public property | MaximizeBox | (Inherited from Form.)
Protected property | MaximizedBounds | (Inherited from Form.)
Public property | MaximumSize | (Inherited from Form.)
Public property | MdiChildren | (Inherited from Form.)
Public property | MdiParent | (Inherited from Form.)
Public property | Menu | (Inherited from Form.)
Public property | MergedMenu | (Inherited from Form.)
Public property | MinimizeBox | (Inherited from Form.)
Public property | MinimumSize | (Inherited from Form.)
Public property | Modal | (Inherited from Form.)
Public property | Name | (Inherited from Control.)
Public property | Opacity | (Inherited from Form.)
Public property | OwnedForms | (Inherited from Form.)
Public property | Owner | (Inherited from Form.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | RestoreBounds | (Inherited from Form.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Public property | RightToLeftLayout | (Inherited from Form.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | ShowIcon | (Inherited from Form.)
Public property | ShowInTaskbar | (Inherited from Form.)
Protected property | ShowWithoutActivation | (Inherited from Form.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Form.)
Public property | SizeGripStyle | (Inherited from Form.)
Public property | StartPosition | (Inherited from Form.)
Public property | TabIndex | (Inherited from Form.)
Public property | TabStop | (Inherited from Form.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | (Inherited from Control.)
Public property | TopLevel | (Inherited from Form.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | TopMost | (Inherited from Form.)
Public property | TransparencyKey | (Inherited from Form.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowState | (Inherited from Form.)
Public property | WindowTarget | (Inherited from Control.)

Events

 | Name | Description
Public event | Activated | (Inherited from Form.)
Public event | AutoSizeChanged | (Inherited from Form.)
Public event | AutoValidateChanged | (Inherited from Form.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | Closed | (Inherited from Form.)
Public event | Closing | (Inherited from Form.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Deactivate | (Inherited from Form.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | FormClosed | (Inherited from Form.)
Public event | FormClosing | (Inherited from Form.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpButtonClicked | (Inherited from Form.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | InputLanguageChanged | (Inherited from Form.)
Public event | InputLanguageChanging | (Inherited from Form.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from Form.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Form.)
Public event | MaximizedBoundsChanged | (Inherited from Form.)
Public event | MaximumSizeChanged | (Inherited from Form.)
Public event | MdiChildActivate | (Inherited from Form.)
Public event | MenuComplete | (Inherited from Form.)
Public event | MenuStart | (Inherited from Form.)
Public event | MinimumSizeChanged | (Inherited from Form.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | ResizeBegin | (Inherited from Form.)
Public event | ResizeEnd | (Inherited from Form.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | RightToLeftLayoutChanged | (Inherited from Form.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | Shown | (Inherited from Form.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Form.)
Public event | TabStopChanged | (Inherited from Form.)
Public event | TextChanged | (Inherited from Control.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

Creator Class
wManager.Wow.Helpers.FightClassCreator Namespace


Creator Constructor

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Creator()
Public Sub New
public:
Creator()

See Also

Creator Class
wManager.Wow.Helpers.FightClassCreator Namespace


Creator Methods

The Creator type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Public method | Activate | (Inherited from Form.)
Protected method | ActivateMdiChild(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | AddOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from Form.)
Protected method | ApplyAutoScaling | (Inherited from Form.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Protected method | CenterToParent | (Inherited from Form.)
Protected method | CenterToScreen | (Inherited from Form.)
Public method | Close | (Inherited from Form.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Form.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Clean up any resources being used.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Public method | LayoutMdi(System.Windows.Forms.MdiLayout) | (Inherited from Form.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnActivated(System.EventArgs) | (Inherited from Form.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnClosed(System.EventArgs) | (Inherited from Form.)
Protected method | OnClosing(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from Form.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDeactivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Form.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnFormClosed(System.Windows.Forms.FormClosedEventArgs) | (Inherited from Form.)
Protected method | OnFormClosing(System.Windows.Forms.FormClosingEventArgs) | (Inherited from Form.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Form.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Form.)
Protected method | OnHelpButtonClicked(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInputLanguageChanged(System.Windows.Forms.InputLanguageChangedEventArgs) | (Inherited from Form.)
Protected method | OnInputLanguageChanging(System.Windows.Forms.InputLanguageChangingEventArgs) | (Inherited from Form.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from Form.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from Form.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMaximumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMdiChildActivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuComplete(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuStart(System.EventArgs) | (Inherited from Form.)
Protected method | OnMinimumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Form.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeBegin(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeEnd(System.EventArgs) | (Inherited from Form.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnShown(System.EventArgs) | (Inherited from Form.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from Form.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from Form.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from Form.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | RemoveOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from Form.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from Form.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopLocation(System.Int32,System.Int32) | (Inherited from Form.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Form.)
Public method | Show(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Public method | Show | (Inherited from Control.)
Public method | ShowDialog | (Inherited from Form.)
Public method | ShowDialog(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Form.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from Form.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from Form.)

See Also

Creator Class
wManager.Wow.Helpers.FightClassCreator Namespace


Dispose Method

Creator..::..Dispose Method

Overload List

 | Name | Description
Protected method | Dispose(Boolean) | Clean up any resources being used.
Public method | Dispose | (Inherited from Component.)

See Also

Creator Class
Creator Members
wManager.Wow.Helpers.FightClassCreator Namespace


Dispose Method

Creator..::..Dispose Method

Clean up any resources being used.

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
protected void Dispose(
    bool disposing
)
Protected Sub Dispose ( _
    disposing As Boolean _
)
protected:
void Dispose(
    bool^ disposing
)

Parameters

disposing
Type: Boolean
true if managed resources should be disposed; otherwise, false.

See Also

Creator Class
wManager.Wow.Helpers.FightClassCreator Namespace


Creator Properties

The Creator type exposes the following members.

Properties

 | Name | Description
Public property | AcceptButton | (Inherited from Form.)
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | ActiveMdiChild | (Inherited from Form.)
Public property | AllowDrop | (Inherited from Control.)
Public property | AllowTransparency | (Inherited from Form.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScale | (Inherited from Form.)
Public property | AutoScaleBaseSize | (Inherited from Form.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from Form.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Form.)
Public property | AutoSizeMode | (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Public property | CancelButton | (Inherited from Form.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Form.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | ControlBox | (Inherited from Form.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Form.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DesktopBounds | (Inherited from Form.)
Public property | DesktopLocation | (Inherited from Form.)
Public property | DialogResult | (Inherited from Form.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | FormBorderStyle | (Inherited from Form.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HelpButton | (Inherited from Form.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | Icon | (Inherited from Form.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMdiChild | (Inherited from Form.)
Public property | IsMdiContainer | (Inherited from Form.)
Public property | IsMirrored | (Inherited from Control.)
Public property | IsRestrictedWindow | (Inherited from Form.)
Public property | KeyPreview | (Inherited from Form.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Form.)
Public property | MainMenuStrip | (Inherited from Form.)
Public property | Margin | (Inherited from Form.)
Public property | MaximizeBox | (Inherited from Form.)
Protected property | MaximizedBounds | (Inherited from Form.)
Public property | MaximumSize | (Inherited from Form.)
Public property | MdiChildren | (Inherited from Form.)
Public property | MdiParent | (Inherited from Form.)
Public property | Menu | (Inherited from Form.)
Public property | MergedMenu | (Inherited from Form.)
Public property | MinimizeBox | (Inherited from Form.)
Public property | MinimumSize | (Inherited from Form.)
Public property | Modal | (Inherited from Form.)
Public property | Name | (Inherited from Control.)
Public property | Opacity | (Inherited from Form.)
Public property | OwnedForms | (Inherited from Form.)
Public property | Owner | (Inherited from Form.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | RestoreBounds | (Inherited from Form.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Public property | RightToLeftLayout | (Inherited from Form.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | ShowIcon | (Inherited from Form.)
Public property | ShowInTaskbar | (Inherited from Form.)
Protected property | ShowWithoutActivation | (Inherited from Form.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Form.)
Public property | SizeGripStyle | (Inherited from Form.)
Public property | StartPosition | (Inherited from Form.)
Public property | TabIndex | (Inherited from Form.)
Public property | TabStop | (Inherited from Form.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | (Inherited from Control.)
Public property | TopLevel | (Inherited from Form.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | TopMost | (Inherited from Form.)
Public property | TransparencyKey | (Inherited from Form.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowState | (Inherited from Form.)
Public property | WindowTarget | (Inherited from Control.)

See Also

Creator Class
wManager.Wow.Helpers.FightClassCreator Namespace


Creator Events

The Creator type exposes the following members.

Events

 | Name | Description
Public event | Activated | (Inherited from Form.)
Public event | AutoSizeChanged | (Inherited from Form.)
Public event | AutoValidateChanged | (Inherited from Form.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | Closed | (Inherited from Form.)
Public event | Closing | (Inherited from Form.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Deactivate | (Inherited from Form.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | FormClosed | (Inherited from Form.)
Public event | FormClosing | (Inherited from Form.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpButtonClicked | (Inherited from Form.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | InputLanguageChanged | (Inherited from Form.)
Public event | InputLanguageChanging | (Inherited from Form.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from Form.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Form.)
Public event | MaximizedBoundsChanged | (Inherited from Form.)
Public event | MaximumSizeChanged | (Inherited from Form.)
Public event | MdiChildActivate | (Inherited from Form.)
Public event | MenuComplete | (Inherited from Form.)
Public event | MenuStart | (Inherited from Form.)
Public event | MinimumSizeChanged | (Inherited from Form.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | ResizeBegin | (Inherited from Form.)
Public event | ResizeEnd | (Inherited from Form.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | RightToLeftLayoutChanged | (Inherited from Form.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | Shown | (Inherited from Form.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Form.)
Public event | TabStopChanged | (Inherited from Form.)
Public event | TextChanged | (Inherited from Control.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

Creator Class
wManager.Wow.Helpers.FightClassCreator Namespace


FightClass Class

Class FightClass (used by XML fight classes and editor).

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class FightClass
<SerializableAttribute> _
Public Class FightClass
[SerializableAttribute]
public ref class FightClass

Inheritance Hierarchy

Object
wManager.Wow.Helpers.FightClassCreator..::..FightClass

See Also

FightClass Members
wManager.Wow.Helpers.FightClassCreator Namespace


FightClass Members

The FightClass type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
 | LoadFightClass | Loads the fight class.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | FightClassGeneralSettings | The fight class general settings
Public field | FightClassSpells | The fight class spells

See Also

FightClass Class
wManager.Wow.Helpers.FightClassCreator Namespace


FightClass Fields

The FightClass type exposes the following members.

Fields

 | Name | Description
Public field | FightClassGeneralSettings | The fight class general settings
Public field | FightClassSpells | The fight class spells

See Also

FightClass Class
wManager.Wow.Helpers.FightClassCreator Namespace


FightClassGeneralSettings Field

FightClass..::..FightClassGeneralSettings Field

The fight class general settings

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public FightClassGeneralSettings FightClassGeneralSettings
Public FightClassGeneralSettings As FightClassGeneralSettings
public:
FightClassGeneralSettings^ FightClassGeneralSettings

See Also

FightClass Class
wManager.Wow.Helpers.FightClassCreator Namespace


FightClassSpells Field

FightClass..::..FightClassSpells Field

The fight class spells

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<FightClassSpell> FightClassSpells
Public FightClassSpells As List(Of FightClassSpell)
public:
List<FightClassSpell^>^ FightClassSpells

See Also

FightClass Class
wManager.Wow.Helpers.FightClassCreator Namespace


FightClass Methods

The FightClass type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
 | LoadFightClass | Loads the fight class.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

FightClass Class
wManager.Wow.Helpers.FightClassCreator Namespace


LoadFightClass Method

FightClass..::..LoadFightClass Method

Loads the fight class.

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static FightClass LoadFightClass(
    string value,
    bool isPath
)
Public Shared Function LoadFightClass ( _
    value As String, _
    isPath As Boolean _
) As FightClass
public:
static FightClass^ LoadFightClass(
    String^ value,
    bool^ isPath
)

Parameters

value
Type: String
The value.
isPath
Type: Boolean
if set to true [is path].

Return Value

FightClass.

See Also

FightClass Class
wManager.Wow.Helpers.FightClassCreator Namespace


FightClassCondition Class

Class FightClassCondition (used by XML fight classes and editor).

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class FightClassCondition
<SerializableAttribute> _
Public Class FightClassCondition
[SerializableAttribute]
public ref class FightClassCondition

Inheritance Hierarchy

Object
wManager.Wow.Helpers.FightClassCreator..::..FightClassCondition

See Also

FightClassCondition Members
wManager.Wow.Helpers.FightClassCreator Namespace


FightClassCondition Members

The FightClassCondition type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | ContionType | Gets or sets the type of the contion.
Public property | Param | Gets or sets the parameter.

See Also

FightClassCondition Class
wManager.Wow.Helpers.FightClassCreator Namespace


FightClassConditionBase Members

The FightClassConditionBase type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

FightClassConditionBase Class
wManager.Wow.Helpers.FightClassCreator Namespace


FightClassCondition Methods

The FightClassCondition type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

FightClassCondition Class
wManager.Wow.Helpers.FightClassCreator Namespace


FightClassCondition Properties

The FightClassCondition type exposes the following members.

Properties

 | Name | Description
Public property | ContionType | Gets or sets the type of the contion.
Public property | Param | Gets or sets the parameter.

See Also

FightClassCondition Class
wManager.Wow.Helpers.FightClassCreator Namespace


ContionType Property

FightClassCondition..::..ContionType Property

Gets or sets the type of the contion.

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public FightClassContionsType ContionType { get; set; }
Public Property ContionType As FightClassContionsType
    Get
    Set
public:
property FightClassContionsType^ ContionType {
    FightClassContionsType^ get ();
    void set (FightClassContionsType^ value);
}

Field Value

The type of the contion.

See Also

FightClassCondition Class
wManager.Wow.Helpers.FightClassCreator Namespace


Param Property

FightClassCondition..::..Param Property

Gets or sets the parameter.

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public FightClassConditionBase Param { get; set; }
Public Property Param As FightClassConditionBase
    Get
    Set
public:
property FightClassConditionBase^ Param {
    FightClassConditionBase^ get ();
    void set (FightClassConditionBase^ value);
}

Field Value

The parameter.

See Also

FightClassCondition Class
wManager.Wow.Helpers.FightClassCreator Namespace


FightClassConditionBase Class

Class FightClassConditionBase (used by XML fight classes and editor).

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
[XmlIncludeAttribute]
[XmlIncludeAttribute]
[XmlIncludeAttribute]
[XmlIncludeAttribute]
[XmlIncludeAttribute]
[XmlIncludeAttribute]
[XmlIncludeAttribute]
[XmlIncludeAttribute]
[XmlIncludeAttribute]
public class FightClassConditionBase
<SerializableAttribute> _
<XmlIncludeAttribute> _
<XmlIncludeAttribute> _
<XmlIncludeAttribute> _
<XmlIncludeAttribute> _
<XmlIncludeAttribute> _
<XmlIncludeAttribute> _
<XmlIncludeAttribute> _
<XmlIncludeAttribute> _
<XmlIncludeAttribute> _
Public Class FightClassConditionBase
[SerializableAttribute]
[XmlIncludeAttribute]
[XmlIncludeAttribute]
[XmlIncludeAttribute]
[XmlIncludeAttribute]
[XmlIncludeAttribute]
[XmlIncludeAttribute]
[XmlIncludeAttribute]
[XmlIncludeAttribute]
[XmlIncludeAttribute]
public ref class FightClassConditionBase

Inheritance Hierarchy

Object
wManager.Wow.Helpers.FightClassCreator..::..FightClassConditionBase

See Also

wManager.Wow.Helpers.FightClassCreator Namespace


FightClassConditionBase Methods

The FightClassConditionBase type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

FightClassConditionBase Class
wManager.Wow.Helpers.FightClassCreator Namespace


FightClassConditionBool Class

Class FightClassConditionBool (used by XML fight classes and editor). Implements the FightClassConditionBase

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class FightClassConditionBool : FightClassConditionBase
<SerializableAttribute> _
Public Class FightClassConditionBool _
    Inherits FightClassConditionBase
[SerializableAttribute]
public ref class FightClassConditionBool : public FightClassConditionBase

Inheritance Hierarchy

Object
wManager.Wow.Helpers.FightClassCreator..::..FightClassConditionBase
wManager.Wow.Helpers.FightClassCreator..::..FightClassConditionBool

See Also

FightClassConditionBool Members
wManager.Wow.Helpers.FightClassCreator Namespace
wManager.Wow.Helpers.FightClassCreator..::..FightClassConditionBase


FightClassConditionBool Members

The FightClassConditionBool type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Value | Gets or sets a value indicating whether this FightClassConditionBool is value.

See Also

FightClassConditionBool Class
wManager.Wow.Helpers.FightClassCreator Namespace


FightClassConditionBool Methods

The FightClassConditionBool type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

FightClassConditionBool Class
wManager.Wow.Helpers.FightClassCreator Namespace


FightClassConditionBool Properties

The FightClassConditionBool type exposes the following members.

Properties

 | Name | Description
Public property | Value | Gets or sets a value indicating whether this FightClassConditionBool is value.

See Also

FightClassConditionBool Class
wManager.Wow.Helpers.FightClassCreator Namespace


Value Property

FightClassConditionBool..::..Value Property

Gets or sets a value indicating whether this FightClassConditionBool is value.

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public bool Value { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property Value As Boolean
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property bool^ Value {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if value; otherwise, false.

See Also

FightClassConditionBool Class
wManager.Wow.Helpers.FightClassCreator Namespace


FightClassConditionBuffStack Class

Class FightClassConditionBuffStack (used by XML fight classes and editor). Implements the FightClassConditionBase

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class FightClassConditionBuffStack : FightClassConditionBase
<SerializableAttribute> _
Public Class FightClassConditionBuffStack _
    Inherits FightClassConditionBase
[SerializableAttribute]
public ref class FightClassConditionBuffStack : public FightClassConditionBase

Inheritance Hierarchy

Object
wManager.Wow.Helpers.FightClassCreator..::..FightClassConditionBase
wManager.Wow.Helpers.FightClassCreator..::..FightClassConditionBuffStack

See Also

FightClassConditionBuffStack Members
wManager.Wow.Helpers.FightClassCreator Namespace
wManager.Wow.Helpers.FightClassCreator..::..FightClassConditionBase


FightClassConditionBuffStack Members

The FightClassConditionBuffStack type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Name | Gets or sets the name.
Public property | Number | Gets or sets the number.
Public property | Type | Gets or sets the type.

See Also

FightClassConditionBuffStack Class
wManager.Wow.Helpers.FightClassCreator Namespace


FightClassConditionBuffStack Methods

The FightClassConditionBuffStack type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

FightClassConditionBuffStack Class
wManager.Wow.Helpers.FightClassCreator Namespace


FightClassConditionBuffStack Properties

The FightClassConditionBuffStack type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets or sets the name.
Public property | Number | Gets or sets the number.
Public property | Type | Gets or sets the type.

See Also

FightClassConditionBuffStack Class
wManager.Wow.Helpers.FightClassCreator Namespace


Name Property

FightClassConditionBuffStack..::..Name Property

Gets or sets the name.

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public string Name { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property Name As String
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Field Value

The name.

See Also

FightClassConditionBuffStack Class
wManager.Wow.Helpers.FightClassCreator Namespace


Number Property

FightClassConditionBuffStack..::..Number Property

Gets or sets the number.

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public int Number { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property Number As Integer
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property int^ Number {
    int^ get ();
    void set (int^ value);
}

Field Value

The number.

See Also

FightClassConditionBuffStack Class
wManager.Wow.Helpers.FightClassCreator Namespace


Type Property

FightClassConditionBuffStack..::..Type Property

Gets or sets the type.

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public FightClassConditionNumberType Type { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property Type As FightClassConditionNumberType
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property FightClassConditionNumberType^ Type {
    FightClassConditionNumberType^ get ();
    void set (FightClassConditionNumberType^ value);
}

Field Value

The type.

See Also

FightClassConditionBuffStack Class
wManager.Wow.Helpers.FightClassCreator Namespace


FightClassConditionItemNumber Class

Class FightClassConditionItemNumber (used by XML fight classes and editor). Implements the FightClassConditionBase

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class FightClassConditionItemNumber : FightClassConditionBase
<SerializableAttribute> _
Public Class FightClassConditionItemNumber _
    Inherits FightClassConditionBase
[SerializableAttribute]
public ref class FightClassConditionItemNumber : public FightClassConditionBase

Inheritance Hierarchy

Object
wManager.Wow.Helpers.FightClassCreator..::..FightClassConditionBase
wManager.Wow.Helpers.FightClassCreator..::..FightClassConditionItemNumber

See Also

FightClassConditionItemNumber Members
wManager.Wow.Helpers.FightClassCreator Namespace
wManager.Wow.Helpers.FightClassCreator..::..FightClassConditionBase


FightClassConditionItemNumber Members

The FightClassConditionItemNumber type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Id | Gets or sets the identifier.
Public property | Number | Gets or sets the number.
Public property | Type | Gets or sets the type.

See Also

FightClassConditionItemNumber Class
wManager.Wow.Helpers.FightClassCreator Namespace


FightClassConditionItemNumber Methods

The FightClassConditionItemNumber type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

FightClassConditionItemNumber Class
wManager.Wow.Helpers.FightClassCreator Namespace


FightClassConditionItemNumber Properties

The FightClassConditionItemNumber type exposes the following members.

Properties

 | Name | Description
Public property | Id | Gets or sets the identifier.
Public property | Number | Gets or sets the number.
Public property | Type | Gets or sets the type.

See Also

FightClassConditionItemNumber Class
wManager.Wow.Helpers.FightClassCreator Namespace


Id Property

FightClassConditionItemNumber..::..Id Property

Gets or sets the identifier.

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public int Id { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property Id As Integer
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property int^ Id {
    int^ get ();
    void set (int^ value);
}

Field Value

The identifier.

See Also

FightClassConditionItemNumber Class
wManager.Wow.Helpers.FightClassCreator Namespace


Number Property

FightClassConditionItemNumber..::..Number Property

Gets or sets the number.

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public int Number { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property Number As Integer
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property int^ Number {
    int^ get ();
    void set (int^ value);
}

Field Value

The number.

See Also

FightClassConditionItemNumber Class
wManager.Wow.Helpers.FightClassCreator Namespace


Type Property

FightClassConditionItemNumber..::..Type Property

Gets or sets the type.

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public FightClassConditionNumberType Type { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property Type As FightClassConditionNumberType
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property FightClassConditionNumberType^ Type {
    FightClassConditionNumberType^ get ();
    void set (FightClassConditionNumberType^ value);
}

Field Value

The type.

See Also

FightClassConditionItemNumber Class
wManager.Wow.Helpers.FightClassCreator Namespace


FightClassConditionLua Class

Class FightClassConditionLua (used by XML fight classes and editor). Implements the FightClassConditionBase

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class FightClassConditionLua : FightClassConditionBase
<SerializableAttribute> _
Public Class FightClassConditionLua _
    Inherits FightClassConditionBase
[SerializableAttribute]
public ref class FightClassConditionLua : public FightClassConditionBase

Inheritance Hierarchy

Object
wManager.Wow.Helpers.FightClassCreator..::..FightClassConditionBase
wManager.Wow.Helpers.FightClassCreator..::..FightClassConditionLua

See Also

FightClassConditionLua Members
wManager.Wow.Helpers.FightClassCreator Namespace
wManager.Wow.Helpers.FightClassCreator..::..FightClassConditionBase


FightClassConditionLua Members

The FightClassConditionLua type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | LuaScript | Gets or sets the lua script.
Public property | ValueRet | Gets or sets the value ret.
Public property | VarRet | Gets or sets the variable ret.

See Also

FightClassConditionLua Class
wManager.Wow.Helpers.FightClassCreator Namespace


FightClassConditionLua Methods

The FightClassConditionLua type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

FightClassConditionLua Class
wManager.Wow.Helpers.FightClassCreator Namespace


FightClassConditionLua Properties

The FightClassConditionLua type exposes the following members.

Properties

 | Name | Description
Public property | LuaScript | Gets or sets the lua script.
Public property | ValueRet | Gets or sets the value ret.
Public property | VarRet | Gets or sets the variable ret.

See Also

FightClassConditionLua Class
wManager.Wow.Helpers.FightClassCreator Namespace


LuaScript Property

FightClassConditionLua..::..LuaScript Property

Gets or sets the lua script.

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
[EditorAttribute]
public string LuaScript { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
<EditorAttribute> _
Public Property LuaScript As String
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
[EditorAttribute]
public:
property String^ LuaScript {
    String^ get ();
    void set (String^ value);
}

Field Value

The lua script.

See Also

FightClassConditionLua Class
wManager.Wow.Helpers.FightClassCreator Namespace


ValueRet Property

FightClassConditionLua..::..ValueRet Property

Gets or sets the value ret.

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public string ValueRet { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property ValueRet As String
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property String^ ValueRet {
    String^ get ();
    void set (String^ value);
}

Field Value

The value ret.

See Also

FightClassConditionLua Class
wManager.Wow.Helpers.FightClassCreator Namespace


VarRet Property

FightClassConditionLua..::..VarRet Property

Gets or sets the variable ret.

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public string VarRet { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property VarRet As String
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property String^ VarRet {
    String^ get ();
    void set (String^ value);
}

Field Value

The variable ret.

See Also

FightClassConditionLua Class
wManager.Wow.Helpers.FightClassCreator Namespace


FightClassConditionNumber Class

Class FightClassConditionNumber (used by XML fight classes and editor). Implements the FightClassConditionBase

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class FightClassConditionNumber : FightClassConditionBase
<SerializableAttribute> _
Public Class FightClassConditionNumber _
    Inherits FightClassConditionBase
[SerializableAttribute]
public ref class FightClassConditionNumber : public FightClassConditionBase

Inheritance Hierarchy

Object
wManager.Wow.Helpers.FightClassCreator..::..FightClassConditionBase
wManager.Wow.Helpers.FightClassCreator..::..FightClassConditionNumber

See Also

FightClassConditionNumber Members
wManager.Wow.Helpers.FightClassCreator Namespace
wManager.Wow.Helpers.FightClassCreator..::..FightClassConditionBase


FightClassConditionNumber Members

The FightClassConditionNumber type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the value.

See Also

FightClassConditionNumber Class
wManager.Wow.Helpers.FightClassCreator Namespace


FightClassConditionNumber Methods

The FightClassConditionNumber type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

FightClassConditionNumber Class
wManager.Wow.Helpers.FightClassCreator Namespace


FightClassConditionNumber Properties

The FightClassConditionNumber type exposes the following members.

Properties

 | Name | Description
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the value.

See Also

FightClassConditionNumber Class
wManager.Wow.Helpers.FightClassCreator Namespace


Type Property

FightClassConditionNumber..::..Type Property

Gets or sets the type.

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public FightClassConditionNumberType Type { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property Type As FightClassConditionNumberType
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property FightClassConditionNumberType^ Type {
    FightClassConditionNumberType^ get ();
    void set (FightClassConditionNumberType^ value);
}

Field Value

The type.

See Also

FightClassConditionNumber Class
wManager.Wow.Helpers.FightClassCreator Namespace


Value Property

FightClassConditionNumber..::..Value Property

Gets or sets the value.

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public int Value { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property Value As Integer
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property int^ Value {
    int^ get ();
    void set (int^ value);
}

Field Value

The value.

See Also

FightClassConditionNumber Class
wManager.Wow.Helpers.FightClassCreator Namespace


FightClassConditionNumberType Enumeration

FightClassConditionNumberType (used by XML fight classes and editor).

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public enum FightClassConditionNumberType
<SerializableAttribute> _
Public Enumeration FightClassConditionNumberType
[SerializableAttribute]
public enum class FightClassConditionNumberType

Members

Member name | Description
Equal |
Bigger |
Smaller |
NotEqual |
BiggerOrEqual |
SmallerOrEqual |
Egal |
NotEgal |

See Also

wManager.Wow.Helpers.FightClassCreator Namespace


FightClassConditionString Class

Class FightClassConditionString (used by XML fight classes and editor). Implements the FightClassConditionBase

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class FightClassConditionString : FightClassConditionBase
<SerializableAttribute> _
Public Class FightClassConditionString _
    Inherits FightClassConditionBase
[SerializableAttribute]
public ref class FightClassConditionString : public FightClassConditionBase

Inheritance Hierarchy

Object
wManager.Wow.Helpers.FightClassCreator..::..FightClassConditionBase
wManager.Wow.Helpers.FightClassCreator..::..FightClassConditionString

See Also

FightClassConditionString Members
wManager.Wow.Helpers.FightClassCreator Namespace
wManager.Wow.Helpers.FightClassCreator..::..FightClassConditionBase


FightClassConditionString Members

The FightClassConditionString type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Value | Gets or sets the value.

See Also

FightClassConditionString Class
wManager.Wow.Helpers.FightClassCreator Namespace


FightClassConditionString Methods

The FightClassConditionString type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

FightClassConditionString Class
wManager.Wow.Helpers.FightClassCreator Namespace


FightClassConditionString Properties

The FightClassConditionString type exposes the following members.

Properties

 | Name | Description
Public property | Value | Gets or sets the value.

See Also

FightClassConditionString Class
wManager.Wow.Helpers.FightClassCreator Namespace


Value Property

FightClassConditionString..::..Value Property

Gets or sets the value.

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
[EditorAttribute]
public string Value { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
<EditorAttribute> _
Public Property Value As String
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
[EditorAttribute]
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

Field Value

The value.

See Also

FightClassConditionString Class
wManager.Wow.Helpers.FightClassCreator Namespace


FightClassConditionStringArray Class

Class FightClassConditionStringArray (used by XML fight classes and editor). Implements the FightClassConditionBase

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class FightClassConditionStringArray : FightClassConditionBase
<SerializableAttribute> _
Public Class FightClassConditionStringArray _
    Inherits FightClassConditionBase
[SerializableAttribute]
public ref class FightClassConditionStringArray : public FightClassConditionBase

Inheritance Hierarchy

Object
wManager.Wow.Helpers.FightClassCreator..::..FightClassConditionBase
wManager.Wow.Helpers.FightClassCreator..::..FightClassConditionStringArray

See Also

FightClassConditionStringArray Members
wManager.Wow.Helpers.FightClassCreator Namespace
wManager.Wow.Helpers.FightClassCreator..::..FightClassConditionBase


FightClassConditionStringArray Members

The FightClassConditionStringArray type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Value | Gets or sets the value.

See Also

FightClassConditionStringArray Class
wManager.Wow.Helpers.FightClassCreator Namespace


FightClassConditionStringArray Methods

The FightClassConditionStringArray type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

FightClassConditionStringArray Class
wManager.Wow.Helpers.FightClassCreator Namespace


FightClassConditionStringArray Properties

The FightClassConditionStringArray type exposes the following members.

Properties

 | Name | Description
Public property | Value | Gets or sets the value.

See Also

FightClassConditionStringArray Class
wManager.Wow.Helpers.FightClassCreator Namespace


Value Property

FightClassConditionStringArray..::..Value Property

Gets or sets the value.

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public List<string> Value { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property Value As List(Of String)
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property List<String^>^ Value {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

Field Value

The value.

See Also

FightClassConditionStringArray Class
wManager.Wow.Helpers.FightClassCreator Namespace


FightClassConditionStringBool Class

Class FightClassConditionStringBool (used by XML fight classes and editor). Implements the FightClassConditionBase

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class FightClassConditionStringBool : FightClassConditionBase
<SerializableAttribute> _
Public Class FightClassConditionStringBool _
    Inherits FightClassConditionBase
[SerializableAttribute]
public ref class FightClassConditionStringBool : public FightClassConditionBase

Inheritance Hierarchy

Object
wManager.Wow.Helpers.FightClassCreator..::..FightClassConditionBase
wManager.Wow.Helpers.FightClassCreator..::..FightClassConditionStringBool

See Also

FightClassConditionStringBool Members
wManager.Wow.Helpers.FightClassCreator Namespace
wManager.Wow.Helpers.FightClassCreator..::..FightClassConditionBase


FightClassConditionStringBool Members

The FightClassConditionStringBool type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Name | Gets or sets the name.
Public property | Need | Gets or sets a value indicating whether this FightClassConditionStringBool is need.

See Also

FightClassConditionStringBool Class
wManager.Wow.Helpers.FightClassCreator Namespace


FightClassConditionStringBool Methods

The FightClassConditionStringBool type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

FightClassConditionStringBool Class
wManager.Wow.Helpers.FightClassCreator Namespace


FightClassConditionStringBool Properties

The FightClassConditionStringBool type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets or sets the name.
Public property | Need | Gets or sets a value indicating whether this FightClassConditionStringBool is need.

See Also

FightClassConditionStringBool Class
wManager.Wow.Helpers.FightClassCreator Namespace


Name Property

FightClassConditionStringBool..::..Name Property

Gets or sets the name.

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public string Name { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property Name As String
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Field Value

The name.

See Also

FightClassConditionStringBool Class
wManager.Wow.Helpers.FightClassCreator Namespace


Need Property

FightClassConditionStringBool..::..Need Property

Gets or sets a value indicating whether this FightClassConditionStringBool is need.

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public bool Need { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property Need As Boolean
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property bool^ Need {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if need; otherwise, false.

See Also

FightClassConditionStringBool Class
wManager.Wow.Helpers.FightClassCreator Namespace


FightClassConditionUnitNear Class

Class FightClassConditionUnitNear (used by XML fight classes and editor). Implements the FightClassConditionBase

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class FightClassConditionUnitNear : FightClassConditionBase
<SerializableAttribute> _
Public Class FightClassConditionUnitNear _
    Inherits FightClassConditionBase
[SerializableAttribute]
public ref class FightClassConditionUnitNear : public FightClassConditionBase

Inheritance Hierarchy

Object
wManager.Wow.Helpers.FightClassCreator..::..FightClassConditionBase
wManager.Wow.Helpers.FightClassCreator..::..FightClassConditionUnitNear

See Also

FightClassConditionUnitNear Members
wManager.Wow.Helpers.FightClassCreator Namespace
wManager.Wow.Helpers.FightClassCreator..::..FightClassConditionBase


FightClassConditionUnitNear Members

The FightClassConditionUnitNear type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Number | Gets or sets the number.
Public property | Radius | Gets or sets the radius.
Public property | Type | Gets or sets the type.

See Also

FightClassConditionUnitNear Class
wManager.Wow.Helpers.FightClassCreator Namespace


FightClassConditionUnitNear Methods

The FightClassConditionUnitNear type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

FightClassConditionUnitNear Class
wManager.Wow.Helpers.FightClassCreator Namespace


FightClassConditionUnitNear Properties

The FightClassConditionUnitNear type exposes the following members.

Properties

 | Name | Description
Public property | Number | Gets or sets the number.
Public property | Radius | Gets or sets the radius.
Public property | Type | Gets or sets the type.

See Also

FightClassConditionUnitNear Class
wManager.Wow.Helpers.FightClassCreator Namespace


Number Property

FightClassConditionUnitNear..::..Number Property

Gets or sets the number.

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public int Number { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property Number As Integer
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property int^ Number {
    int^ get ();
    void set (int^ value);
}

Field Value

The number.

See Also

FightClassConditionUnitNear Class
wManager.Wow.Helpers.FightClassCreator Namespace


Radius Property

FightClassConditionUnitNear..::..Radius Property

Gets or sets the radius.

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public int Radius { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property Radius As Integer
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property int^ Radius {
    int^ get ();
    void set (int^ value);
}

Field Value

The radius.

See Also

FightClassConditionUnitNear Class
wManager.Wow.Helpers.FightClassCreator Namespace


Type Property

FightClassConditionUnitNear..::..Type Property

Gets or sets the type.

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public FightClassConditionNumberType Type { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property Type As FightClassConditionNumberType
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property FightClassConditionNumberType^ Type {
    FightClassConditionNumberType^ get ();
    void set (FightClassConditionNumberType^ value);
}

Field Value

The type.

See Also

FightClassConditionUnitNear Class
wManager.Wow.Helpers.FightClassCreator Namespace


FightClassContionsType Enumeration

FightClassContionsType (used by XML fight classes and editor).

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public enum FightClassContionsType
<SerializableAttribute> _
Public Enumeration FightClassContionsType
[SerializableAttribute]
public enum class FightClassContionsType

Members

Member name | Description
None |
PetHealthPercent |
TargetHealthPercent |
HealthPercent |
HealthPoints |
HealthPointsLost |
TargetHealthPoints |
TargetHealthPointsLost |
PetHealthPoints |
PetHealthPointsLost |
ComboPoint |
Mana |
ManaPercent |
Rage |
Focus |
Energy |
Chi |
Runes |
RunicPower |
SoulShards |
Eclipse |
HolyPower |
Alternate |
DarkForce |
LightForce |
ShadowOrbs |
BurningEmbers |
DemonicFury |
ArcaneCharges |
TargetDistance |
DistancePetToTarget |
DistanceMeToPet |
MeLevel |
TargetLevel |
CombatStartSinceMs |
TotemFireTimeLeftMs |
TotemEarthTimeLeftMs |
TotemWaterTimeLeftMs |
TotemAirTimeLeftMs |
RunesReadyCount |
RunesBloodReadyCount |
RunesUnholyReadyCount |
RunesFrostReadyCount |
RunesDeathReadyCount |
GlobalCooldownTimeLeft |
CastingTimeLeft |
TargetCastingTimeLeft |
PetCastingTimeLeft |
HostileUnitNear |
UnitAttackPlayerNear |
HostileUnitNearTarget |
UnitAttackPlayerNearTarget |
PartyMemberNearTarget |
PartyMemberNear |
Buff |
TargetBuff |
PetBuff |
KnowSpell |
IsSpellUsable |
BuffCastedByMe |
TargetBuffCastedByMe |
PetBuffCastedByMe |
CooldownEnabled |
CastingSpellName |
TargetCastingSpellName |
PetCastingSpellName |
ItemIdCooldownEnabled |
SpellAffectedByAProc |
IsSpellOverlayed |
InBattleground |
HaveTarget |
HavePet |
MeInCombat |
MeInMove |
TargetInMove |
PetInMove |
TargetInCast |
PetInCast |
MeInCast |
TargetIsPlayer |
TargetIsSummoned |
TargetPetIsMyTarget |
TargetTargetingMe |
TargetTargetingMeOrMyPet |
TargetTargetingMyPet |
TargetTargetingPartyMember |
TargetIsElite |
TargetIsWorldBoss |
TargetIsBoss |
MeIsStunned |
TargetIsStunned |
PetIsStunned |
MeIsSwimming |
TargetIsSwimming |
PetIsSwimming |
MeIsFlying |
TargetIsFlying |
PetIsFlying |
RuneReadySlot1 |
RuneReadySlot2 |
RuneReadySlot3 |
RuneReadySlot4 |
RuneReadySlot5 |
RuneReadySlot6 |
MeInGroup |
IsFacing |
IsBehind |
TotemFireExist |
TotemEarthExist |
TotemWaterExist |
TotemAirExist |
TargetCanInterruptCasting |
GlobalCooldownEnabled |
Possessed |
Fleeing |
Influenced |
Confused |
Pacified |
TargetPossessed |
TargetFleeing |
TargetInfluenced |
TargetConfused |
TargetPacified |
PetPossessed |
PetFleeing |
PetInfluenced |
PetConfused |
PetPacified |
IsOnTaxi |
TargetInCombatRange |
CSharpCode |
ItemCount |
LuaScript |
BuffStack |
BuffStackTarget |
BuffStackPet |
BuffTimeLeft |
BuffTimeLeftTarget |
BuffTimeLeftPet |
CooldownTimeLeft |

See Also

wManager.Wow.Helpers.FightClassCreator Namespace


FightClassGeneralSettings Class

Class FightClassGeneralSettings (used by XML fight classes and editor).

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class FightClassGeneralSettings
<SerializableAttribute> _
Public Class FightClassGeneralSettings
[SerializableAttribute]
public ref class FightClassGeneralSettings

Inheritance Hierarchy

Object
wManager.Wow.Helpers.FightClassCreator..::..FightClassGeneralSettings

See Also

FightClassGeneralSettings Members
wManager.Wow.Helpers.FightClassCreator Namespace


FightClassGeneralSettings Members

The FightClassGeneralSettings type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | AdditionalCode | Gets or sets the additional code.
Public property | FightClassName | Gets or sets the name of the fight class.
Public property | FramePerSecond | Gets or sets the frame per second.
Public property | Pet | Gets or sets a value indicating whether this FightClassGeneralSettings is pet.
Public property | PetCallSpellName | Gets or sets the name of the pet call spell.
Public property | PetReviveSpellName | Gets or sets the name of the pet revive spell.
Public property | Range | Gets or sets the range.

See Also

FightClassGeneralSettings Class
wManager.Wow.Helpers.FightClassCreator Namespace


FightClassGeneralSettings Methods

The FightClassGeneralSettings type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

FightClassGeneralSettings Class
wManager.Wow.Helpers.FightClassCreator Namespace


FightClassGeneralSettings Properties

The FightClassGeneralSettings type exposes the following members.

Properties

 | Name | Description
Public property | AdditionalCode | Gets or sets the additional code.
Public property | FightClassName | Gets or sets the name of the fight class.
Public property | FramePerSecond | Gets or sets the frame per second.
Public property | Pet | Gets or sets a value indicating whether this FightClassGeneralSettings is pet.
Public property | PetCallSpellName | Gets or sets the name of the pet call spell.
Public property | PetReviveSpellName | Gets or sets the name of the pet revive spell.
Public property | Range | Gets or sets the range.

See Also

FightClassGeneralSettings Class
wManager.Wow.Helpers.FightClassCreator Namespace


AdditionalCode Property

FightClassGeneralSettings..::..AdditionalCode Property

Gets or sets the additional code.

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
[EditorAttribute]
public string AdditionalCode { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
<EditorAttribute> _
Public Property AdditionalCode As String
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
[EditorAttribute]
public:
property String^ AdditionalCode {
    String^ get ();
    void set (String^ value);
}

Field Value

The additional code.

See Also

FightClassGeneralSettings Class
wManager.Wow.Helpers.FightClassCreator Namespace


FightClassName Property

FightClassGeneralSettings..::..FightClassName Property

Gets or sets the name of the fight class.

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public string FightClassName { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property FightClassName As String
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property String^ FightClassName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the fight class.

See Also

FightClassGeneralSettings Class
wManager.Wow.Helpers.FightClassCreator Namespace


FramePerSecond Property

FightClassGeneralSettings..::..FramePerSecond Property

Gets or sets the frame per second.

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public int FramePerSecond { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property FramePerSecond As Integer
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property int^ FramePerSecond {
    int^ get ();
    void set (int^ value);
}

Field Value

The frame per second.

See Also

FightClassGeneralSettings Class
wManager.Wow.Helpers.FightClassCreator Namespace


Pet Property

FightClassGeneralSettings..::..Pet Property

Gets or sets a value indicating whether this FightClassGeneralSettings is pet.

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public bool Pet { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property Pet As Boolean
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property bool^ Pet {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if pet; otherwise, false.

See Also

FightClassGeneralSettings Class
wManager.Wow.Helpers.FightClassCreator Namespace


PetCallSpellName Property

FightClassGeneralSettings..::..PetCallSpellName Property

Gets or sets the name of the pet call spell.

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public string PetCallSpellName { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property PetCallSpellName As String
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property String^ PetCallSpellName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the pet call spell.

See Also

FightClassGeneralSettings Class
wManager.Wow.Helpers.FightClassCreator Namespace


PetReviveSpellName Property

FightClassGeneralSettings..::..PetReviveSpellName Property

Gets or sets the name of the pet revive spell.

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public string PetReviveSpellName { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property PetReviveSpellName As String
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property String^ PetReviveSpellName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the pet revive spell.

See Also

FightClassGeneralSettings Class
wManager.Wow.Helpers.FightClassCreator Namespace


Range Property

FightClassGeneralSettings..::..Range Property

Gets or sets the range.

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public int Range { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property Range As Integer
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property int^ Range {
    int^ get ();
    void set (int^ value);
}

Field Value

The range.

See Also

FightClassGeneralSettings Class
wManager.Wow.Helpers.FightClassCreator Namespace


FightClassSpell Class

Class FightClassSpell (used by XML fight classes and editor).

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class FightClassSpell
<SerializableAttribute> _
Public Class FightClassSpell
[SerializableAttribute]
public ref class FightClassSpell

Inheritance Hierarchy

Object
wManager.Wow.Helpers.FightClassCreator..::..FightClassSpell

See Also

FightClassSpell Members
wManager.Wow.Helpers.FightClassCreator Namespace


FightClassSpell Members

The FightClassSpell type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | FightClassConditions | The fight class conditions

Properties

 | Name | Description
Public property | AddToSettings | Gets or sets a value indicating whether [add to settings].
Public property | AddToSettingsActiveByDefault | Gets or sets a value indicating whether [add to settings active by default].
Public property | AddToSettingsName | Gets or sets the name of the add to settings.
Public property | AOESpell | Gets or sets a value indicating whether [aoe spell].
Public property | AOESpellMePos | Gets or sets a value indicating whether [aoe spell me position].
Public property | CanMoveDuringCast | Gets or sets the can move during cast.
Public property | CastIfDead | Gets or sets a value indicating whether [cast if dead].
Public property | CastIfMounted | Gets or sets a value indicating whether [cast if mounted].
Public property | CastOn | Gets or sets the cast on.
Public property | CastOnSelf | Gets or sets a value indicating whether [cast on self].
Public property | CheckIfKnow | Gets or sets a value indicating whether [check if know].
Public property | CheckIfSpellUsable | Gets or sets a value indicating whether [check if spell usable].
Public property | CheckIfView | Gets or sets a value indicating whether [check if view].
Public property | CheckSpellDistance | Gets or sets a value indicating whether [check spell distance].
Public property | CombatOnly | Gets or sets a value indicating whether [combat only].
Public property | Debug | Gets or sets a value indicating whether this FightClassSpell is debug.
Public property | DescriptionSpell | Gets or sets the description spell.
Public property | IsBuff | Gets or sets a value indicating whether this instance is buff.
Public property | LockFrame | Gets or sets a value indicating whether [lock frame].
Public property | NotSpellIsCSharpCode | Gets or sets a value indicating whether [not spell is c sharp code].
Public property | NotSpellIsItemId | Gets or sets a value indicating whether [not spell is item identifier].
Public property | NotSpellIsLuaBotCode | Gets or sets a value indicating whether [not spell is lua bot code].
Public property | NotSpellIsLuaScript | Gets or sets a value indicating whether [not spell is lua script].
Public property | NotSpellIsVBCode | Gets or sets a value indicating whether [not spell is vb code].
Public property | OncePerTarget | Gets or sets a value indicating whether [once per target].
Public property | Priority | Gets or sets the priority.
Public property | SpellName | Gets or sets the name of the spell.
Public property | TargetFriends | Gets or sets a value indicating whether [target friends].
Public property | Timer | Gets or sets the timer.
Public property | WaitDuringCasting | Gets or sets a value indicating whether [wait during casting].

See Also

FightClassSpell Class
wManager.Wow.Helpers.FightClassCreator Namespace


FightClassSpell Fields

The FightClassSpell type exposes the following members.

Fields

 | Name | Description
Public field | FightClassConditions | The fight class conditions

See Also

FightClassSpell Class
wManager.Wow.Helpers.FightClassCreator Namespace


FightClassConditions Field

FightClassSpell..::..FightClassConditions Field

The fight class conditions

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<FightClassCondition> FightClassConditions
Public FightClassConditions As List(Of FightClassCondition)
public:
List<FightClassCondition^>^ FightClassConditions

See Also

FightClassSpell Class
wManager.Wow.Helpers.FightClassCreator Namespace


FightClassSpell Methods

The FightClassSpell type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

FightClassSpell Class
wManager.Wow.Helpers.FightClassCreator Namespace


FightClassSpell Properties

The FightClassSpell type exposes the following members.

Properties

 | Name | Description
Public property | AddToSettings | Gets or sets a value indicating whether [add to settings].
Public property | AddToSettingsActiveByDefault | Gets or sets a value indicating whether [add to settings active by default].
Public property | AddToSettingsName | Gets or sets the name of the add to settings.
Public property | AOESpell | Gets or sets a value indicating whether [aoe spell].
Public property | AOESpellMePos | Gets or sets a value indicating whether [aoe spell me position].
Public property | CanMoveDuringCast | Gets or sets the can move during cast.
Public property | CastIfDead | Gets or sets a value indicating whether [cast if dead].
Public property | CastIfMounted | Gets or sets a value indicating whether [cast if mounted].
Public property | CastOn | Gets or sets the cast on.
Public property | CastOnSelf | Gets or sets a value indicating whether [cast on self].
Public property | CheckIfKnow | Gets or sets a value indicating whether [check if know].
Public property | CheckIfSpellUsable | Gets or sets a value indicating whether [check if spell usable].
Public property | CheckIfView | Gets or sets a value indicating whether [check if view].
Public property | CheckSpellDistance | Gets or sets a value indicating whether [check spell distance].
Public property | CombatOnly | Gets or sets a value indicating whether [combat only].
Public property | Debug | Gets or sets a value indicating whether this FightClassSpell is debug.
Public property | DescriptionSpell | Gets or sets the description spell.
Public property | IsBuff | Gets or sets a value indicating whether this instance is buff.
Public property | LockFrame | Gets or sets a value indicating whether [lock frame].
Public property | NotSpellIsCSharpCode | Gets or sets a value indicating whether [not spell is c sharp code].
Public property | NotSpellIsItemId | Gets or sets a value indicating whether [not spell is item identifier].
Public property | NotSpellIsLuaBotCode | Gets or sets a value indicating whether [not spell is lua bot code].
Public property | NotSpellIsLuaScript | Gets or sets a value indicating whether [not spell is lua script].
Public property | NotSpellIsVBCode | Gets or sets a value indicating whether [not spell is vb code].
Public property | OncePerTarget | Gets or sets a value indicating whether [once per target].
Public property | Priority | Gets or sets the priority.
Public property | SpellName | Gets or sets the name of the spell.
Public property | TargetFriends | Gets or sets a value indicating whether [target friends].
Public property | Timer | Gets or sets the timer.
Public property | WaitDuringCasting | Gets or sets a value indicating whether [wait during casting].

See Also

FightClassSpell Class
wManager.Wow.Helpers.FightClassCreator Namespace


AddToSettings Property

FightClassSpell..::..AddToSettings Property

Gets or sets a value indicating whether [add to settings].

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public bool AddToSettings { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property AddToSettings As Boolean
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property bool^ AddToSettings {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if [add to settings]; otherwise, false.

See Also

FightClassSpell Class
wManager.Wow.Helpers.FightClassCreator Namespace


AddToSettingsActiveByDefault Property

FightClassSpell..::..AddToSettingsActiveByDefault Property

Gets or sets a value indicating whether [add to settings active by default].

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public bool AddToSettingsActiveByDefault { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property AddToSettingsActiveByDefault As Boolean
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property bool^ AddToSettingsActiveByDefault {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if [add to settings active by default]; otherwise, false.

See Also

FightClassSpell Class
wManager.Wow.Helpers.FightClassCreator Namespace


AddToSettingsName Property

FightClassSpell..::..AddToSettingsName Property

Gets or sets the name of the add to settings.

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public string AddToSettingsName { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property AddToSettingsName As String
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property String^ AddToSettingsName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the add to settings.

See Also

FightClassSpell Class
wManager.Wow.Helpers.FightClassCreator Namespace


AOESpell Property

FightClassSpell..::..AOESpell Property

Gets or sets a value indicating whether [aoe spell].

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public bool AOESpell { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property AOESpell As Boolean
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property bool^ AOESpell {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if [aoe spell]; otherwise, false.

See Also

FightClassSpell Class
wManager.Wow.Helpers.FightClassCreator Namespace


AOESpellMePos Property

FightClassSpell..::..AOESpellMePos Property

Gets or sets a value indicating whether [aoe spell me position].

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public bool AOESpellMePos { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property AOESpellMePos As Boolean
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property bool^ AOESpellMePos {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if [aoe spell me position]; otherwise, false.

See Also

FightClassSpell Class
wManager.Wow.Helpers.FightClassCreator Namespace


CanMoveDuringCast Property

FightClassSpell..::..CanMoveDuringCast Property

Gets or sets the can move during cast.

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public YesNoAuto CanMoveDuringCast { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property CanMoveDuringCast As YesNoAuto
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property YesNoAuto^ CanMoveDuringCast {
    YesNoAuto^ get ();
    void set (YesNoAuto^ value);
}

Field Value

The can move during cast.

See Also

FightClassSpell Class
wManager.Wow.Helpers.FightClassCreator Namespace


CastIfDead Property

FightClassSpell..::..CastIfDead Property

Gets or sets a value indicating whether [cast if dead].

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public bool CastIfDead { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property CastIfDead As Boolean
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property bool^ CastIfDead {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if [cast if dead]; otherwise, false.

See Also

FightClassSpell Class
wManager.Wow.Helpers.FightClassCreator Namespace


CastIfMounted Property

FightClassSpell..::..CastIfMounted Property

Gets or sets a value indicating whether [cast if mounted].

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public bool CastIfMounted { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property CastIfMounted As Boolean
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property bool^ CastIfMounted {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if [cast if mounted]; otherwise, false.

See Also

FightClassSpell Class
wManager.Wow.Helpers.FightClassCreator Namespace


CastOn Property

FightClassSpell..::..CastOn Property

Gets or sets the cast on.

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public UnitIdLua CastOn { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property CastOn As UnitIdLua
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property UnitIdLua^ CastOn {
    UnitIdLua^ get ();
    void set (UnitIdLua^ value);
}

Field Value

The cast on.

See Also

FightClassSpell Class
wManager.Wow.Helpers.FightClassCreator Namespace


CastOnSelf Property

FightClassSpell..::..CastOnSelf Property

Gets or sets a value indicating whether [cast on self].

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public bool CastOnSelf { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property CastOnSelf As Boolean
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property bool^ CastOnSelf {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if [cast on self]; otherwise, false.

See Also

FightClassSpell Class
wManager.Wow.Helpers.FightClassCreator Namespace


CheckIfKnow Property

FightClassSpell..::..CheckIfKnow Property

Gets or sets a value indicating whether [check if know].

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public bool CheckIfKnow { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property CheckIfKnow As Boolean
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property bool^ CheckIfKnow {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if [check if know]; otherwise, false.

See Also

FightClassSpell Class
wManager.Wow.Helpers.FightClassCreator Namespace


CheckIfSpellUsable Property

FightClassSpell..::..CheckIfSpellUsable Property

Gets or sets a value indicating whether [check if spell usable].

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public bool CheckIfSpellUsable { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property CheckIfSpellUsable As Boolean
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property bool^ CheckIfSpellUsable {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if [check if spell usable]; otherwise, false.

See Also

FightClassSpell Class
wManager.Wow.Helpers.FightClassCreator Namespace


CheckIfView Property

FightClassSpell..::..CheckIfView Property

Gets or sets a value indicating whether [check if view].

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public bool CheckIfView { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property CheckIfView As Boolean
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property bool^ CheckIfView {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if [check if view]; otherwise, false.

See Also

FightClassSpell Class
wManager.Wow.Helpers.FightClassCreator Namespace


CheckSpellDistance Property

FightClassSpell..::..CheckSpellDistance Property

Gets or sets a value indicating whether [check spell distance].

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public bool CheckSpellDistance { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property CheckSpellDistance As Boolean
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property bool^ CheckSpellDistance {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if [check spell distance]; otherwise, false.

See Also

FightClassSpell Class
wManager.Wow.Helpers.FightClassCreator Namespace


CombatOnly Property

FightClassSpell..::..CombatOnly Property

Gets or sets a value indicating whether [combat only].

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public bool CombatOnly { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property CombatOnly As Boolean
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property bool^ CombatOnly {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if [combat only]; otherwise, false.

See Also

FightClassSpell Class
wManager.Wow.Helpers.FightClassCreator Namespace


Debug Property

FightClassSpell..::..Debug Property

Gets or sets a value indicating whether this FightClassSpell is debug.

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public bool Debug { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property Debug As Boolean
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property bool^ Debug {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if debug; otherwise, false.

See Also

FightClassSpell Class
wManager.Wow.Helpers.FightClassCreator Namespace


DescriptionSpell Property

FightClassSpell..::..DescriptionSpell Property

Gets or sets the description spell.

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public string DescriptionSpell { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property DescriptionSpell As String
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property String^ DescriptionSpell {
    String^ get ();
    void set (String^ value);
}

Field Value

The description spell.

See Also

FightClassSpell Class
wManager.Wow.Helpers.FightClassCreator Namespace


IsBuff Property

FightClassSpell..::..IsBuff Property

Gets or sets a value indicating whether this instance is buff.

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public bool IsBuff { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property IsBuff As Boolean
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property bool^ IsBuff {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if this instance is buff; otherwise, false.

See Also

FightClassSpell Class
wManager.Wow.Helpers.FightClassCreator Namespace


LockFrame Property

FightClassSpell..::..LockFrame Property

Gets or sets a value indicating whether [lock frame].

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public bool LockFrame { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property LockFrame As Boolean
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property bool^ LockFrame {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if [lock frame]; otherwise, false.

See Also

FightClassSpell Class
wManager.Wow.Helpers.FightClassCreator Namespace


NotSpellIsCSharpCode Property

FightClassSpell..::..NotSpellIsCSharpCode Property

Gets or sets a value indicating whether [not spell is c sharp code].

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public bool NotSpellIsCSharpCode { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property NotSpellIsCSharpCode As Boolean
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property bool^ NotSpellIsCSharpCode {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if [not spell is c sharp code]; otherwise, false.

See Also

FightClassSpell Class
wManager.Wow.Helpers.FightClassCreator Namespace


NotSpellIsItemId Property

FightClassSpell..::..NotSpellIsItemId Property

Gets or sets a value indicating whether [not spell is item identifier].

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public bool NotSpellIsItemId { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property NotSpellIsItemId As Boolean
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property bool^ NotSpellIsItemId {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if [not spell is item identifier]; otherwise, false.

See Also

FightClassSpell Class
wManager.Wow.Helpers.FightClassCreator Namespace


NotSpellIsLuaBotCode Property

FightClassSpell..::..NotSpellIsLuaBotCode Property

Gets or sets a value indicating whether [not spell is lua bot code].

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public bool NotSpellIsLuaBotCode { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property NotSpellIsLuaBotCode As Boolean
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property bool^ NotSpellIsLuaBotCode {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if [not spell is lua bot code]; otherwise, false.

See Also

FightClassSpell Class
wManager.Wow.Helpers.FightClassCreator Namespace


NotSpellIsLuaScript Property

FightClassSpell..::..NotSpellIsLuaScript Property

Gets or sets a value indicating whether [not spell is lua script].

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public bool NotSpellIsLuaScript { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property NotSpellIsLuaScript As Boolean
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property bool^ NotSpellIsLuaScript {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if [not spell is lua script]; otherwise, false.

See Also

FightClassSpell Class
wManager.Wow.Helpers.FightClassCreator Namespace


NotSpellIsVBCode Property

FightClassSpell..::..NotSpellIsVBCode Property

Gets or sets a value indicating whether [not spell is vb code].

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public bool NotSpellIsVBCode { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property NotSpellIsVBCode As Boolean
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property bool^ NotSpellIsVBCode {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if [not spell is vb code]; otherwise, false.

See Also

FightClassSpell Class
wManager.Wow.Helpers.FightClassCreator Namespace


OncePerTarget Property

FightClassSpell..::..OncePerTarget Property

Gets or sets a value indicating whether [once per target].

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public bool OncePerTarget { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property OncePerTarget As Boolean
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property bool^ OncePerTarget {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if [once per target]; otherwise, false.

See Also

FightClassSpell Class
wManager.Wow.Helpers.FightClassCreator Namespace


Priority Property

FightClassSpell..::..Priority Property

Gets or sets the priority.

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[ReadOnlyAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public int Priority { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<ReadOnlyAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property Priority As Integer
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[ReadOnlyAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property int^ Priority {
    int^ get ();
    void set (int^ value);
}

Field Value

The priority.

See Also

FightClassSpell Class
wManager.Wow.Helpers.FightClassCreator Namespace


SpellName Property

FightClassSpell..::..SpellName Property

Gets or sets the name of the spell.

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
[EditorAttribute]
public string SpellName { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
<EditorAttribute> _
Public Property SpellName As String
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
[EditorAttribute]
public:
property String^ SpellName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the spell.

See Also

FightClassSpell Class
wManager.Wow.Helpers.FightClassCreator Namespace


TargetFriends Property

FightClassSpell..::..TargetFriends Property

Gets or sets a value indicating whether [target friends].

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public bool TargetFriends { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property TargetFriends As Boolean
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property bool^ TargetFriends {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if [target friends]; otherwise, false.

See Also

FightClassSpell Class
wManager.Wow.Helpers.FightClassCreator Namespace


Timer Property

FightClassSpell..::..Timer Property

Gets or sets the timer.

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public int Timer { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property Timer As Integer
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property int^ Timer {
    int^ get ();
    void set (int^ value);
}

Field Value

The timer.

See Also

FightClassSpell Class
wManager.Wow.Helpers.FightClassCreator Namespace


WaitDuringCasting Property

FightClassSpell..::..WaitDuringCasting Property

Gets or sets a value indicating whether [wait during casting].

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public bool WaitDuringCasting { get; set; }
<SettingAttribute> _
<DefaultValueAttribute> _
<CategoryAttribute> _
<DisplayNameAttribute> _
<DescriptionAttribute> _
Public Property WaitDuringCasting As Boolean
    Get
    Set
[SettingAttribute]
[DefaultValueAttribute]
[CategoryAttribute]
[DisplayNameAttribute]
[DescriptionAttribute]
public:
property bool^ WaitDuringCasting {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if [wait during casting]; otherwise, false.

See Also

FightClassSpell Class
wManager.Wow.Helpers.FightClassCreator Namespace


FightClassSpellsDB Class

Class FightClassSpellsDB. Implements the Form

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class FightClassSpellsDB : Form
Public Class FightClassSpellsDB _
    Inherits Form
public ref class FightClassSpellsDB : public Form

Inheritance Hierarchy

Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
wManager.Wow.Helpers.FightClassCreator..::..FightClassSpellsDB

See Also

FightClassSpellsDB Members
wManager.Wow.Helpers.FightClassCreator Namespace
Form


FightClassSpellsDB Members

The FightClassSpellsDB type exposes the following members.

Constructors

 | Name | Description
Public method | FightClassSpellsDB | Initializes a new instance of the FightClassSpellsDB class.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Public method | Activate | (Inherited from Form.)
Protected method | ActivateMdiChild(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | AddOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from Form.)
Protected method | ApplyAutoScaling | (Inherited from Form.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Protected method | CenterToParent | (Inherited from Form.)
Protected method | CenterToScreen | (Inherited from Form.)
Public method | Close | (Inherited from Form.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Form.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Clean up any resources being used.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Public method | LayoutMdi(System.Windows.Forms.MdiLayout) | (Inherited from Form.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnActivated(System.EventArgs) | (Inherited from Form.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnClosed(System.EventArgs) | (Inherited from Form.)
Protected method | OnClosing(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from Form.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDeactivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Form.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnFormClosed(System.Windows.Forms.FormClosedEventArgs) | (Inherited from Form.)
Protected method | OnFormClosing(System.Windows.Forms.FormClosingEventArgs) | (Inherited from Form.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Form.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Form.)
Protected method | OnHelpButtonClicked(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInputLanguageChanged(System.Windows.Forms.InputLanguageChangedEventArgs) | (Inherited from Form.)
Protected method | OnInputLanguageChanging(System.Windows.Forms.InputLanguageChangingEventArgs) | (Inherited from Form.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from Form.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from Form.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMaximumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMdiChildActivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuComplete(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuStart(System.EventArgs) | (Inherited from Form.)
Protected method | OnMinimumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Form.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeBegin(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeEnd(System.EventArgs) | (Inherited from Form.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnShown(System.EventArgs) | (Inherited from Form.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from Form.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from Form.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from Form.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | RemoveOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from Form.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from Form.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopLocation(System.Int32,System.Int32) | (Inherited from Form.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Form.)
Public method | Show(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Public method | Show | (Inherited from Control.)
Public method | ShowDialog | (Inherited from Form.)
Public method | ShowDialog(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Form.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from Form.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from Form.)

Fields

 | Name | Description
Public field | ReturnSpell | The return spell

Properties

 | Name | Description
Public property | AcceptButton | (Inherited from Form.)
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | ActiveMdiChild | (Inherited from Form.)
Public property | AllowDrop | (Inherited from Control.)
Public property | AllowTransparency | (Inherited from Form.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScale | (Inherited from Form.)
Public property | AutoScaleBaseSize | (Inherited from Form.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from Form.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Form.)
Public property | AutoSizeMode | (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Public property | CancelButton | (Inherited from Form.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Form.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | ControlBox | (Inherited from Form.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Form.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DesktopBounds | (Inherited from Form.)
Public property | DesktopLocation | (Inherited from Form.)
Public property | DialogResult | (Inherited from Form.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | FormBorderStyle | (Inherited from Form.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HelpButton | (Inherited from Form.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | Icon | (Inherited from Form.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMdiChild | (Inherited from Form.)
Public property | IsMdiContainer | (Inherited from Form.)
Public property | IsMirrored | (Inherited from Control.)
Public property | IsRestrictedWindow | (Inherited from Form.)
Public property | KeyPreview | (Inherited from Form.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Form.)
Public property | MainMenuStrip | (Inherited from Form.)
Public property | Margin | (Inherited from Form.)
Public property | MaximizeBox | (Inherited from Form.)
Protected property | MaximizedBounds | (Inherited from Form.)
Public property | MaximumSize | (Inherited from Form.)
Public property | MdiChildren | (Inherited from Form.)
Public property | MdiParent | (Inherited from Form.)
Public property | Menu | (Inherited from Form.)
Public property | MergedMenu | (Inherited from Form.)
Public property | MinimizeBox | (Inherited from Form.)
Public property | MinimumSize | (Inherited from Form.)
Public property | Modal | (Inherited from Form.)
Public property | Name | (Inherited from Control.)
Public property | Opacity | (Inherited from Form.)
Public property | OwnedForms | (Inherited from Form.)
Public property | Owner | (Inherited from Form.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | RestoreBounds | (Inherited from Form.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Public property | RightToLeftLayout | (Inherited from Form.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | ShowIcon | (Inherited from Form.)
Public property | ShowInTaskbar | (Inherited from Form.)
Protected property | ShowWithoutActivation | (Inherited from Form.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Form.)
Public property | SizeGripStyle | (Inherited from Form.)
Public property | StartPosition | (Inherited from Form.)
Public property | TabIndex | (Inherited from Form.)
Public property | TabStop | (Inherited from Form.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | (Inherited from Control.)
Public property | TopLevel | (Inherited from Form.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | TopMost | (Inherited from Form.)
Public property | TransparencyKey | (Inherited from Form.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowState | (Inherited from Form.)
Public property | WindowTarget | (Inherited from Control.)

Events

 | Name | Description
Public event | Activated | (Inherited from Form.)
Public event | AutoSizeChanged | (Inherited from Form.)
Public event | AutoValidateChanged | (Inherited from Form.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | Closed | (Inherited from Form.)
Public event | Closing | (Inherited from Form.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Deactivate | (Inherited from Form.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | FormClosed | (Inherited from Form.)
Public event | FormClosing | (Inherited from Form.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpButtonClicked | (Inherited from Form.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | InputLanguageChanged | (Inherited from Form.)
Public event | InputLanguageChanging | (Inherited from Form.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from Form.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Form.)
Public event | MaximizedBoundsChanged | (Inherited from Form.)
Public event | MaximumSizeChanged | (Inherited from Form.)
Public event | MdiChildActivate | (Inherited from Form.)
Public event | MenuComplete | (Inherited from Form.)
Public event | MenuStart | (Inherited from Form.)
Public event | MinimumSizeChanged | (Inherited from Form.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | ResizeBegin | (Inherited from Form.)
Public event | ResizeEnd | (Inherited from Form.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | RightToLeftLayoutChanged | (Inherited from Form.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | Shown | (Inherited from Form.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Form.)
Public event | TabStopChanged | (Inherited from Form.)
Public event | TextChanged | (Inherited from Control.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

FightClassSpellsDB Class
wManager.Wow.Helpers.FightClassCreator Namespace


FightClassSpellsDB Constructor

Initializes a new instance of the FightClassSpellsDB class.

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public FightClassSpellsDB()
Public Sub New
public:
FightClassSpellsDB()

See Also

FightClassSpellsDB Class
wManager.Wow.Helpers.FightClassCreator Namespace


FightClassSpellsDB Fields

The FightClassSpellsDB type exposes the following members.

Fields

 | Name | Description
Public field | ReturnSpell | The return spell

See Also

FightClassSpellsDB Class
wManager.Wow.Helpers.FightClassCreator Namespace


ReturnSpell Field

FightClassSpellsDB..::..ReturnSpell Field

The return spell

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public FightClassSpell ReturnSpell
Public ReturnSpell As FightClassSpell
public:
FightClassSpell^ ReturnSpell

See Also

FightClassSpellsDB Class
wManager.Wow.Helpers.FightClassCreator Namespace


FightClassSpellsDB Methods

The FightClassSpellsDB type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(System.Windows.Forms.AccessibleEvents,System.Int32,System.Int32) | (Inherited from Control.)
Public method | Activate | (Inherited from Form.)
Protected method | ActivateMdiChild(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | AddOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Protected method | AdjustFormScrollbars(System.Boolean) | (Inherited from Form.)
Protected method | ApplyAutoScaling | (Inherited from Form.)
Public method | BeginInvoke(System.Delegate) | (Inherited from Control.)
Public method | BeginInvoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Protected method | CenterToParent | (Inherited from Form.)
Protected method | CenterToScreen | (Inherited from Form.)
Public method | Close | (Inherited from Form.)
Public method | Contains(System.Windows.Forms.Control) | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Form.)
Public method | CreateObjRef(System.Type) | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | DestroyHandle | (Inherited from Control.)
Protected method | Dispose(Boolean) | Clean up any resources being used.
Public method | Dispose | (Inherited from Component.)
Public method | DoDragDrop(System.Object,System.Windows.Forms.DragDropEffects) | (Inherited from Control.)
Public method | DrawToBitmap(System.Drawing.Bitmap,System.Drawing.Rectangle) | (Inherited from Control.)
Public method | EndInvoke(System.IAsyncResult) | (Inherited from Control.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById(System.Int32) | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point,System.Windows.Forms.GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetChildAtPoint(System.Drawing.Point) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl(System.Windows.Forms.Control,System.Boolean) | (Inherited from Control.)
Public method | GetPreferredSize(System.Drawing.Size) | (Inherited from Control.)
Protected method | GetScaledBounds(System.Drawing.Rectangle,System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | GetScrollState(System.Int32) | (Inherited from ScrollableControl.)
Protected method | GetService(System.Type) | (Inherited from Component.)
Protected method | GetStyle(System.Windows.Forms.ControlStyles) | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Region,System.Boolean) | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(System.Boolean) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Invalidate(System.Drawing.Rectangle,System.Boolean) | (Inherited from Control.)
Public method | Invoke(System.Delegate) | (Inherited from Control.)
Public method | Invoke(System.Delegate,System.Object[]) | (Inherited from Control.)
Protected method | InvokeGotFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeLostFocus(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokeOnClick(System.Windows.Forms.Control,System.EventArgs) | (Inherited from Control.)
Protected method | InvokePaint(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | InvokePaintBackground(System.Windows.Forms.Control,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | IsInputChar(System.Char) | (Inherited from Control.)
Protected method | IsInputKey(System.Windows.Forms.Keys) | (Inherited from Control.)
Public method | LayoutMdi(System.Windows.Forms.MdiLayout) | (Inherited from Form.)
Protected method | MemberwiseClone(System.Boolean) | (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyInvalidate(System.Drawing.Rectangle) | (Inherited from Control.)
Protected method | OnActivated(System.EventArgs) | (Inherited from Form.)
Protected method | OnAutoSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnAutoValidateChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnBackgroundImageChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnCausesValidationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnChangeUICues(System.Windows.Forms.UICuesEventArgs) | (Inherited from Control.)
Protected method | OnClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnClientSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnClosed(System.EventArgs) | (Inherited from Form.)
Protected method | OnClosing(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnContextMenuChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnContextMenuStripChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnControlAdded(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnControlRemoved(System.Windows.Forms.ControlEventArgs) | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from Form.)
Protected method | OnCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDeactivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnDockChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnDoubleClick(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragDrop(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragEnter(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnDragLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnDragOver(System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | OnEnabledChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnEnter(System.EventArgs) | (Inherited from Form.)
Protected method | OnFontChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnFormClosed(System.Windows.Forms.FormClosedEventArgs) | (Inherited from Form.)
Protected method | OnFormClosing(System.Windows.Forms.FormClosingEventArgs) | (Inherited from Form.)
Protected method | OnGiveFeedback(System.Windows.Forms.GiveFeedbackEventArgs) | (Inherited from Control.)
Protected method | OnGotFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnHandleCreated(System.EventArgs) | (Inherited from Form.)
Protected method | OnHandleDestroyed(System.EventArgs) | (Inherited from Form.)
Protected method | OnHelpButtonClicked(System.ComponentModel.CancelEventArgs) | (Inherited from Form.)
Protected method | OnHelpRequested(System.Windows.Forms.HelpEventArgs) | (Inherited from Control.)
Protected method | OnImeModeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnInputLanguageChanged(System.Windows.Forms.InputLanguageChangedEventArgs) | (Inherited from Form.)
Protected method | OnInputLanguageChanging(System.Windows.Forms.InputLanguageChangingEventArgs) | (Inherited from Form.)
Protected method | OnInvalidated(System.Windows.Forms.InvalidateEventArgs) | (Inherited from Control.)
Protected method | OnKeyDown(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnKeyPress(System.Windows.Forms.KeyPressEventArgs) | (Inherited from Control.)
Protected method | OnKeyUp(System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | OnLayout(System.Windows.Forms.LayoutEventArgs) | (Inherited from Form.)
Protected method | OnLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnLoad(System.EventArgs) | (Inherited from Form.)
Protected method | OnLocationChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnLostFocus(System.EventArgs) | (Inherited from Control.)
Protected method | OnMarginChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMaximumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMdiChildActivate(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuComplete(System.EventArgs) | (Inherited from Form.)
Protected method | OnMenuStart(System.EventArgs) | (Inherited from Form.)
Protected method | OnMinimumSizeChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnMouseCaptureChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseDown(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseEnter(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseHover(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseLeave(System.EventArgs) | (Inherited from Control.)
Protected method | OnMouseMove(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseUp(System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | OnMouseWheel(System.Windows.Forms.MouseEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnMove(System.EventArgs) | (Inherited from Control.)
Protected method | OnNotifyMessage(System.Windows.Forms.Message) | (Inherited from Control.)
Protected method | OnPaddingChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnPaint(System.Windows.Forms.PaintEventArgs) | (Inherited from Form.)
Protected method | OnPaintBackground(System.Windows.Forms.PaintEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentBindingContextChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentChanged(System.EventArgs) | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentEnabledChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentFontChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentForeColorChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnParentVisibleChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnPreviewKeyDown(System.Windows.Forms.PreviewKeyDownEventArgs) | (Inherited from Control.)
Protected method | OnPrint(System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | OnQueryContinueDrag(System.Windows.Forms.QueryContinueDragEventArgs) | (Inherited from Control.)
Protected method | OnRegionChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnResize(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeBegin(System.EventArgs) | (Inherited from Form.)
Protected method | OnResizeEnd(System.EventArgs) | (Inherited from Form.)
Protected method | OnRightToLeftChanged(System.EventArgs) | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnScroll(System.Windows.Forms.ScrollEventArgs) | (Inherited from ScrollableControl.)
Protected method | OnShown(System.EventArgs) | (Inherited from Form.)
Protected method | OnSizeChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnStyleChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnSystemColorsChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabIndexChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTabStopChanged(System.EventArgs) | (Inherited from Control.)
Protected method | OnTextChanged(System.EventArgs) | (Inherited from Form.)
Protected method | OnValidated(System.EventArgs) | (Inherited from Control.)
Protected method | OnValidating(System.ComponentModel.CancelEventArgs) | (Inherited from Control.)
Protected method | OnVisibleChanged(System.EventArgs) | (Inherited from Form.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(System.Windows.Forms.Control,System.String) | (Inherited from Control.)
Public method | PointToClient(System.Drawing.Point) | (Inherited from Control.)
Public method | PointToScreen(System.Drawing.Point) | (Inherited from Control.)
Public method | PreProcessControlMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Public method | PreProcessMessage(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessCmdKey(System.Windows.Forms.Message@,System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessDialogChar(System.Char) | (Inherited from Form.)
Protected method | ProcessDialogKey(System.Windows.Forms.Keys) | (Inherited from Form.)
Protected method | ProcessKeyEventArgs(System.Windows.Forms.Message@) | (Inherited from Control.)
Protected method | ProcessKeyPreview(System.Windows.Forms.Message@) | (Inherited from Form.)
Protected method | ProcessTabKey(System.Boolean) | (Inherited from Form.)
Protected method | RaiseDragEvent(System.Object,System.Windows.Forms.DragEventArgs) | (Inherited from Control.)
Protected method | RaiseKeyEvent(System.Object,System.Windows.Forms.KeyEventArgs) | (Inherited from Control.)
Protected method | RaiseMouseEvent(System.Object,System.Windows.Forms.MouseEventArgs) | (Inherited from Control.)
Protected method | RaisePaintEvent(System.Object,System.Windows.Forms.PaintEventArgs) | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | RectangleToScreen(System.Drawing.Rectangle) | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | RemoveOwnedForm(System.Windows.Forms.Form) | (Inherited from Form.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(System.Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(System.Drawing.ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateHorizontal(System.Windows.Forms.HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateLeftRight(System.Windows.Forms.LeftRightAlignment) | (Inherited from Control.)
Public method | Scale(System.Single) | (Inherited from Control.)
Public method | Scale(System.Single,System.Single) | (Inherited from Control.)
Public method | Scale(System.Drawing.SizeF) | (Inherited from Control.)
Protected method | ScaleControl(System.Drawing.SizeF,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | ScaleCore(System.Single,System.Single) | (Inherited from Form.)
Public method | ScrollControlIntoView(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | ScrollToControl(System.Windows.Forms.Control) | (Inherited from ScrollableControl.)
Protected method | Select(System.Boolean,System.Boolean) | (Inherited from Form.)
Public method | Select | (Inherited from Control.)
Public method | SelectNextControl(System.Windows.Forms.Control,System.Boolean,System.Boolean,System.Boolean,System.Boolean) | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode(System.Windows.Forms.AutoSizeMode) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Public method | SetBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.BoundsSpecified) | (Inherited from Form.)
Protected method | SetClientSizeCore(System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Form.)
Public method | SetDesktopLocation(System.Int32,System.Int32) | (Inherited from Form.)
Protected method | SetDisplayRectLocation(System.Int32,System.Int32) | (Inherited from ScrollableControl.)
Protected method | SetScrollState(System.Int32,System.Boolean) | (Inherited from ScrollableControl.)
Protected method | SetStyle(System.Windows.Forms.ControlStyles,System.Boolean) | (Inherited from Control.)
Protected method | SetTopLevel(System.Boolean) | (Inherited from Control.)
Protected method | SetVisibleCore(System.Boolean) | (Inherited from Form.)
Public method | Show(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Public method | Show | (Inherited from Control.)
Public method | ShowDialog | (Inherited from Form.)
Public method | ShowDialog(System.Windows.Forms.IWin32Window) | (Inherited from Form.)
Protected method | SizeFromClientSize(System.Drawing.Size) | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Form.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateBounds(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from Form.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(System.Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(System.Windows.Forms.ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc(System.Windows.Forms.Message@) | (Inherited from Form.)

See Also

FightClassSpellsDB Class
wManager.Wow.Helpers.FightClassCreator Namespace


Dispose Method

FightClassSpellsDB..::..Dispose Method

Overload List

 | Name | Description
Protected method | Dispose(Boolean) | Clean up any resources being used.
Public method | Dispose | (Inherited from Component.)

See Also

FightClassSpellsDB Class
FightClassSpellsDB Members
wManager.Wow.Helpers.FightClassCreator Namespace


Dispose Method

FightClassSpellsDB..::..Dispose Method

Clean up any resources being used.

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
protected void Dispose(
    bool disposing
)
Protected Sub Dispose ( _
    disposing As Boolean _
)
protected:
void Dispose(
    bool^ disposing
)

Parameters

disposing
Type: Boolean
true if managed resources should be disposed; otherwise, false.

See Also

FightClassSpellsDB Class
wManager.Wow.Helpers.FightClassCreator Namespace


FightClassSpellsDB Properties

The FightClassSpellsDB type exposes the following members.

Properties

 | Name | Description
Public property | AcceptButton | (Inherited from Form.)
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | ActiveMdiChild | (Inherited from Form.)
Public property | AllowDrop | (Inherited from Control.)
Public property | AllowTransparency | (Inherited from Form.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScale | (Inherited from Form.)
Public property | AutoScaleBaseSize | (Inherited from Form.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from Form.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Form.)
Public property | AutoSizeMode | (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Public property | CancelButton | (Inherited from Form.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Form.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | ControlBox | (Inherited from Form.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Form.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DesktopBounds | (Inherited from Form.)
Public property | DesktopLocation | (Inherited from Form.)
Public property | DialogResult | (Inherited from Form.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | FormBorderStyle | (Inherited from Form.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HelpButton | (Inherited from Form.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | Icon | (Inherited from Form.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMdiChild | (Inherited from Form.)
Public property | IsMdiContainer | (Inherited from Form.)
Public property | IsMirrored | (Inherited from Control.)
Public property | IsRestrictedWindow | (Inherited from Form.)
Public property | KeyPreview | (Inherited from Form.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Form.)
Public property | MainMenuStrip | (Inherited from Form.)
Public property | Margin | (Inherited from Form.)
Public property | MaximizeBox | (Inherited from Form.)
Protected property | MaximizedBounds | (Inherited from Form.)
Public property | MaximumSize | (Inherited from Form.)
Public property | MdiChildren | (Inherited from Form.)
Public property | MdiParent | (Inherited from Form.)
Public property | Menu | (Inherited from Form.)
Public property | MergedMenu | (Inherited from Form.)
Public property | MinimizeBox | (Inherited from Form.)
Public property | MinimumSize | (Inherited from Form.)
Public property | Modal | (Inherited from Form.)
Public property | Name | (Inherited from Control.)
Public property | Opacity | (Inherited from Form.)
Public property | OwnedForms | (Inherited from Form.)
Public property | Owner | (Inherited from Form.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | RestoreBounds | (Inherited from Form.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Public property | RightToLeftLayout | (Inherited from Form.)
Protected property | ScaleChildren | (Inherited from Control.)
Public property | ShowIcon | (Inherited from Form.)
Public property | ShowInTaskbar | (Inherited from Form.)
Protected property | ShowWithoutActivation | (Inherited from Form.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Form.)
Public property | SizeGripStyle | (Inherited from Form.)
Public property | StartPosition | (Inherited from Form.)
Public property | TabIndex | (Inherited from Form.)
Public property | TabStop | (Inherited from Form.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | (Inherited from Control.)
Public property | TopLevel | (Inherited from Form.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | TopMost | (Inherited from Form.)
Public property | TransparencyKey | (Inherited from Form.)
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | Width | (Inherited from Control.)
Public property | WindowState | (Inherited from Form.)
Public property | WindowTarget | (Inherited from Control.)

See Also

FightClassSpellsDB Class
wManager.Wow.Helpers.FightClassCreator Namespace


FightClassSpellsDB Events

The FightClassSpellsDB type exposes the following members.

Events

 | Name | Description
Public event | Activated | (Inherited from Form.)
Public event | AutoSizeChanged | (Inherited from Form.)
Public event | AutoValidateChanged | (Inherited from Form.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | Closed | (Inherited from Form.)
Public event | Closing | (Inherited from Form.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Deactivate | (Inherited from Form.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | FormClosed | (Inherited from Form.)
Public event | FormClosing | (Inherited from Form.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpButtonClicked | (Inherited from Form.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | InputLanguageChanged | (Inherited from Form.)
Public event | InputLanguageChanging | (Inherited from Form.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from Form.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Form.)
Public event | MaximizedBoundsChanged | (Inherited from Form.)
Public event | MaximumSizeChanged | (Inherited from Form.)
Public event | MdiChildActivate | (Inherited from Form.)
Public event | MenuComplete | (Inherited from Form.)
Public event | MenuStart | (Inherited from Form.)
Public event | MinimumSizeChanged | (Inherited from Form.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | ResizeBegin | (Inherited from Form.)
Public event | ResizeEnd | (Inherited from Form.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | RightToLeftLayoutChanged | (Inherited from Form.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | Shown | (Inherited from Form.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Form.)
Public event | TabStopChanged | (Inherited from Form.)
Public event | TextChanged | (Inherited from Control.)
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)

See Also

FightClassSpellsDB Class
wManager.Wow.Helpers.FightClassCreator Namespace


UnitIdLua Enumeration

UnitIdLua (used by XML fight classes and editor).

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public enum UnitIdLua
<SerializableAttribute> _
Public Enumeration UnitIdLua
[SerializableAttribute]
public enum class UnitIdLua

Members

Member name | Description
none |
target |
player |
pet |
focus |
mouseover |
party1 |
party2 |
party3 |
party4 |
partypet1 |
partypet2 |
partypet3 |
partypet4 |

See Also

wManager.Wow.Helpers.FightClassCreator Namespace


YesNoAuto Enumeration

YesNoAuto (used by XML fight classes and editor).

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public enum YesNoAuto
<SerializableAttribute> _
Public Enumeration YesNoAuto
[SerializableAttribute]
public enum class YesNoAuto

Members

Member name | Description
Yes |
No |
Auto |

See Also

wManager.Wow.Helpers.FightClassCreator Namespace


wManager.Wow.Helpers.PathFinderClass Namespace

Classes

 | Class | Description
Public class | FindPathPacket |
Public class | FindPathPacket..::..Area |
Public class | FindPathPacket..::..OffMeshConnection |
Public class | FindZPositionPacket |
Public class | Pather | Class Pather. Use the PathFinder for findpath.
Public class | PatherServer | Class PatherServer. Use the PathFinder for findpath.
Public class | PathPacket |
Public class | Utility | Class Utility. Useful methods for PathFinder
Public class | Vector3Simple |
Public class | ZPositionPacket |

Interfaces

 | Interface | Description
Public interface | PathFinderInterface | Interface PathFinderInterface, you have possibility to use you own pathfinder, for that implement this interface on class named "PathFinder" without namespace and save dll to "WRobot\Bin\pathfinderoverride.dll".

Delegates

 | Delegate | Description
Public delegate | Pather..::..MeshFileAddedHandler | Delegate MeshFileAddedHandler
Public delegate | Pather..::..MeshFileRemovedHandler | Delegate MeshFileRemovedHandler

Enumerations

 | Enumeration | Description
Public enumeration | FindPathPacket..::..Faction |
Public enumeration | FindPathPacket..::..OffMeshConnection..::..OffMeshConnectionType |
Public enumeration | Packets |


FindPathPacket Class

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class FindPathPacket
<SerializableAttribute> _
Public Class FindPathPacket
[SerializableAttribute]
public ref class FindPathPacket

Inheritance Hierarchy

Object
wManager.Wow.Helpers.PathFinderClass..::..FindPathPacket

See Also

FindPathPacket Members
wManager.Wow.Helpers.PathFinderClass Namespace


FindPathPacket Members

The FindPathPacket type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | Areas |
Public field | BigExtents |
Public field | Continent |
Public field | End |
Public field | GarrisonLevel |
Public field | IgnoreServerRoadsWater |
Public field | NeedLog |
Public field | OffMeshConnections |
Public field | PlayerFaction |
Public field | SessionKey |
Public field | SkipIfPartiel |
Public field | Start |
Public field | WallDistance |

See Also

FindPathPacket Class
wManager.Wow.Helpers.PathFinderClass Namespace


FindPathPacket Fields

The FindPathPacket type exposes the following members.

Fields

 | Name | Description
Public field | Areas |
Public field | BigExtents |
Public field | Continent |
Public field | End |
Public field | GarrisonLevel |
Public field | IgnoreServerRoadsWater |
Public field | NeedLog |
Public field | OffMeshConnections |
Public field | PlayerFaction |
Public field | SessionKey |
Public field | SkipIfPartiel |
Public field | Start |
Public field | WallDistance |

See Also

FindPathPacket Class
wManager.Wow.Helpers.PathFinderClass Namespace


Areas Field

FindPathPacket..::..Areas Field

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[JsonPropertyAttribute]
public List<FindPathPacket..::..Area> Areas
<JsonPropertyAttribute> _
Public Areas As List(Of FindPathPacket..::..Area)
[JsonPropertyAttribute]
public:
List<FindPathPacket..::..Area^>^ Areas

See Also

FindPathPacket Class
wManager.Wow.Helpers.PathFinderClass Namespace


BigExtents Field

FindPathPacket..::..BigExtents Field

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[JsonPropertyAttribute]
public bool BigExtents
<JsonPropertyAttribute> _
Public BigExtents As Boolean
[JsonPropertyAttribute]
public:
bool^ BigExtents

See Also

FindPathPacket Class
wManager.Wow.Helpers.PathFinderClass Namespace


Continent Field

FindPathPacket..::..Continent Field

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[JsonPropertyAttribute]
public string Continent
<JsonPropertyAttribute> _
Public Continent As String
[JsonPropertyAttribute]
public:
String^ Continent

See Also

FindPathPacket Class
wManager.Wow.Helpers.PathFinderClass Namespace


End Field

FindPathPacket..::..End Field

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[JsonPropertyAttribute]
public Vector3Simple End
<JsonPropertyAttribute> _
Public End As Vector3Simple
[JsonPropertyAttribute]
public:
Vector3Simple^ End

See Also

FindPathPacket Class
wManager.Wow.Helpers.PathFinderClass Namespace


GarrisonLevel Field

FindPathPacket..::..GarrisonLevel Field

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[JsonPropertyAttribute]
public int GarrisonLevel
<JsonPropertyAttribute> _
Public GarrisonLevel As Integer
[JsonPropertyAttribute]
public:
int^ GarrisonLevel

See Also

FindPathPacket Class
wManager.Wow.Helpers.PathFinderClass Namespace


IgnoreServerRoadsWater Field

FindPathPacket..::..IgnoreServerRoadsWater Field

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[JsonPropertyAttribute]
public bool IgnoreServerRoadsWater
<JsonPropertyAttribute> _
Public IgnoreServerRoadsWater As Boolean
[JsonPropertyAttribute]
public:
bool^ IgnoreServerRoadsWater

See Also

FindPathPacket Class
wManager.Wow.Helpers.PathFinderClass Namespace


NeedLog Field

FindPathPacket..::..NeedLog Field

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[JsonPropertyAttribute]
public bool NeedLog
<JsonPropertyAttribute> _
Public NeedLog As Boolean
[JsonPropertyAttribute]
public:
bool^ NeedLog

See Also

FindPathPacket Class
wManager.Wow.Helpers.PathFinderClass Namespace


OffMeshConnections Field

FindPathPacket..::..OffMeshConnections Field

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[JsonPropertyAttribute]
public List<FindPathPacket..::..OffMeshConnection> OffMeshConnections
<JsonPropertyAttribute> _
Public OffMeshConnections As List(Of FindPathPacket..::..OffMeshConnection)
[JsonPropertyAttribute]
public:
List<FindPathPacket..::..OffMeshConnection^>^ OffMeshConnections

See Also

FindPathPacket Class
wManager.Wow.Helpers.PathFinderClass Namespace


PlayerFaction Field

FindPathPacket..::..PlayerFaction Field

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[JsonPropertyAttribute]
public FindPathPacket..::..Faction PlayerFaction
<JsonPropertyAttribute> _
Public PlayerFaction As FindPathPacket..::..Faction
[JsonPropertyAttribute]
public:
FindPathPacket..::..Faction^ PlayerFaction

See Also

FindPathPacket Class
wManager.Wow.Helpers.PathFinderClass Namespace


SessionKey Field

FindPathPacket..::..SessionKey Field

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[JsonPropertyAttribute]
public string SessionKey
<JsonPropertyAttribute> _
Public SessionKey As String
[JsonPropertyAttribute]
public:
String^ SessionKey

See Also

FindPathPacket Class
wManager.Wow.Helpers.PathFinderClass Namespace


SkipIfPartiel Field

FindPathPacket..::..SkipIfPartiel Field

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[JsonPropertyAttribute]
public bool SkipIfPartiel
<JsonPropertyAttribute> _
Public SkipIfPartiel As Boolean
[JsonPropertyAttribute]
public:
bool^ SkipIfPartiel

See Also

FindPathPacket Class
wManager.Wow.Helpers.PathFinderClass Namespace


Start Field

FindPathPacket..::..Start Field

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[JsonPropertyAttribute]
public Vector3Simple Start
<JsonPropertyAttribute> _
Public Start As Vector3Simple
[JsonPropertyAttribute]
public:
Vector3Simple^ Start

See Also

FindPathPacket Class
wManager.Wow.Helpers.PathFinderClass Namespace


WallDistance Field

FindPathPacket..::..WallDistance Field

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[JsonPropertyAttribute]
public float WallDistance
<JsonPropertyAttribute> _
Public WallDistance As Single
[JsonPropertyAttribute]
public:
float^ WallDistance

See Also

FindPathPacket Class
wManager.Wow.Helpers.PathFinderClass Namespace


FindPathPacket Methods

The FindPathPacket type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

FindPathPacket Class
wManager.Wow.Helpers.PathFinderClass Namespace


FindPathPacket.Area Class

FindPathPacket..::..Area Class

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class Area
<SerializableAttribute> _
Public Class Area
[SerializableAttribute]
public ref class Area

Inheritance Hierarchy

Object
wManager.Wow.Helpers.PathFinderClass..::..FindPathPacket..::..Area

See Also

FindPathPacket..::..Area Members
wManager.Wow.Helpers.PathFinderClass Namespace


FindPathPacket.Area Members

FindPathPacket..::..Area Members

The FindPathPacket..::..Area type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | AreaType |
Public field | Position |
Public field | Radius |

See Also

FindPathPacket..::..Area Class
wManager.Wow.Helpers.PathFinderClass Namespace


FindPathPacket.Area Fields

FindPathPacket..::..Area Fields

The FindPathPacket..::..Area type exposes the following members.

Fields

 | Name | Description
Public field | AreaType |
Public field | Position |
Public field | Radius |

See Also

FindPathPacket..::..Area Class
wManager.Wow.Helpers.PathFinderClass Namespace


AreaType Field

Area..::..AreaType Field

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[JsonPropertyAttribute]
public PolyArea AreaType
<JsonPropertyAttribute> _
Public AreaType As PolyArea
[JsonPropertyAttribute]
public:
PolyArea^ AreaType

See Also

FindPathPacket..::..Area Class
wManager.Wow.Helpers.PathFinderClass Namespace


Position Field

Area..::..Position Field

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[JsonPropertyAttribute]
public Vector3Simple Position
<JsonPropertyAttribute> _
Public Position As Vector3Simple
[JsonPropertyAttribute]
public:
Vector3Simple^ Position

See Also

FindPathPacket..::..Area Class
wManager.Wow.Helpers.PathFinderClass Namespace


Radius Field

Area..::..Radius Field

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[JsonPropertyAttribute]
public float Radius
<JsonPropertyAttribute> _
Public Radius As Single
[JsonPropertyAttribute]
public:
float^ Radius

See Also

FindPathPacket..::..Area Class
wManager.Wow.Helpers.PathFinderClass Namespace


FindPathPacket.Area Methods

FindPathPacket..::..Area Methods

The FindPathPacket..::..Area type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

FindPathPacket..::..Area Class
wManager.Wow.Helpers.PathFinderClass Namespace


FindPathPacket.Faction Enumeration

FindPathPacket..::..Faction Enumeration

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public enum Faction
Public Enumeration Faction
public enum class Faction

Members

Member name | Description
Neutral |
Horde |
Alliance |

See Also

wManager.Wow.Helpers.PathFinderClass Namespace


FindPathPacket.OffMeshConnection Class

FindPathPacket..::..OffMeshConnection Class

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class OffMeshConnection
<SerializableAttribute> _
Public Class OffMeshConnection
[SerializableAttribute]
public ref class OffMeshConnection

Inheritance Hierarchy

Object
wManager.Wow.Helpers.PathFinderClass..::..FindPathPacket..::..OffMeshConnection

See Also

FindPathPacket..::..OffMeshConnection Members
wManager.Wow.Helpers.PathFinderClass Namespace


FindPathPacket.OffMeshConnection Members

FindPathPacket..::..OffMeshConnection Members

The FindPathPacket..::..OffMeshConnection type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | Path |
Public field | TryToUseEvenIfCanFindPathSuccess |
Public field | Type |

See Also

FindPathPacket..::..OffMeshConnection Class
wManager.Wow.Helpers.PathFinderClass Namespace


FindPathPacket.OffMeshConnection Fields

FindPathPacket..::..OffMeshConnection Fields

The FindPathPacket..::..OffMeshConnection type exposes the following members.

Fields

 | Name | Description
Public field | Path |
Public field | TryToUseEvenIfCanFindPathSuccess |
Public field | Type |

See Also

FindPathPacket..::..OffMeshConnection Class
wManager.Wow.Helpers.PathFinderClass Namespace


Path Field

OffMeshConnection..::..Path Field

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[JsonPropertyAttribute]
public List<Vector3Simple> Path
<JsonPropertyAttribute> _
Public Path As List(Of Vector3Simple)
[JsonPropertyAttribute]
public:
List<Vector3Simple^>^ Path

See Also

FindPathPacket..::..OffMeshConnection Class
wManager.Wow.Helpers.PathFinderClass Namespace


TryToUseEvenIfCanFindPathSuccess Field

OffMeshConnection..::..TryToUseEvenIfCanFindPathSuccess Field

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[JsonPropertyAttribute]
public bool TryToUseEvenIfCanFindPathSuccess
<JsonPropertyAttribute> _
Public TryToUseEvenIfCanFindPathSuccess As Boolean
[JsonPropertyAttribute]
public:
bool^ TryToUseEvenIfCanFindPathSuccess

See Also

FindPathPacket..::..OffMeshConnection Class
wManager.Wow.Helpers.PathFinderClass Namespace


Type Field

OffMeshConnection..::..Type Field

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[JsonPropertyAttribute]
public FindPathPacket..::..OffMeshConnection..::..OffMeshConnectionType Type
<JsonPropertyAttribute> _
Public Type As FindPathPacket..::..OffMeshConnection..::..OffMeshConnectionType
[JsonPropertyAttribute]
public:
FindPathPacket..::..OffMeshConnection..::..OffMeshConnectionType^ Type

See Also

FindPathPacket..::..OffMeshConnection Class
wManager.Wow.Helpers.PathFinderClass Namespace


FindPathPacket.OffMeshConnection Methods

FindPathPacket..::..OffMeshConnection Methods

The FindPathPacket..::..OffMeshConnection type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

FindPathPacket..::..OffMeshConnection Class
wManager.Wow.Helpers.PathFinderClass Namespace


OffMeshConnection.OffMeshConnectionType Enumeration

OffMeshConnection..::..OffMeshConnectionType Enumeration

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public enum OffMeshConnectionType
<SerializableAttribute> _
Public Enumeration OffMeshConnectionType
[SerializableAttribute]
public enum class OffMeshConnectionType

Members

Member name | Description
Unidirectional |
Bidirectional |

See Also

wManager.Wow.Helpers.PathFinderClass Namespace


FindZPositionPacket Class

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class FindZPositionPacket
<SerializableAttribute> _
Public Class FindZPositionPacket
[SerializableAttribute]
public ref class FindZPositionPacket

Inheritance Hierarchy

Object
wManager.Wow.Helpers.PathFinderClass..::..FindZPositionPacket

See Also

FindZPositionPacket Members
wManager.Wow.Helpers.PathFinderClass Namespace


FindZPositionPacket Members

The FindZPositionPacket type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | Continent |
Public field | Position |
Public field | SessionKey |
Public field | Strict |

See Also

FindZPositionPacket Class
wManager.Wow.Helpers.PathFinderClass Namespace


FindZPositionPacket Fields

The FindZPositionPacket type exposes the following members.

Fields

 | Name | Description
Public field | Continent |
Public field | Position |
Public field | SessionKey |
Public field | Strict |

See Also

FindZPositionPacket Class
wManager.Wow.Helpers.PathFinderClass Namespace


Continent Field

FindZPositionPacket..::..Continent Field

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[JsonPropertyAttribute]
public string Continent
<JsonPropertyAttribute> _
Public Continent As String
[JsonPropertyAttribute]
public:
String^ Continent

See Also

FindZPositionPacket Class
wManager.Wow.Helpers.PathFinderClass Namespace


Position Field

FindZPositionPacket..::..Position Field

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[JsonPropertyAttribute]
public Vector3Simple Position
<JsonPropertyAttribute> _
Public Position As Vector3Simple
[JsonPropertyAttribute]
public:
Vector3Simple^ Position

See Also

FindZPositionPacket Class
wManager.Wow.Helpers.PathFinderClass Namespace


SessionKey Field

FindZPositionPacket..::..SessionKey Field

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[JsonPropertyAttribute]
public string SessionKey
<JsonPropertyAttribute> _
Public SessionKey As String
[JsonPropertyAttribute]
public:
String^ SessionKey

See Also

FindZPositionPacket Class
wManager.Wow.Helpers.PathFinderClass Namespace


Strict Field

FindZPositionPacket..::..Strict Field

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[JsonPropertyAttribute]
public bool Strict
<JsonPropertyAttribute> _
Public Strict As Boolean
[JsonPropertyAttribute]
public:
bool^ Strict

See Also

FindZPositionPacket Class
wManager.Wow.Helpers.PathFinderClass Namespace


FindZPositionPacket Methods

The FindZPositionPacket type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

FindZPositionPacket Class
wManager.Wow.Helpers.PathFinderClass Namespace


Packets Enumeration

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public enum Packets
Public Enumeration Packets
public enum class Packets

Members

Member name | Description
None |
FindPath |
FindZPosition |
IsOnline |
InfoCurrentSession |
GO |

See Also

wManager.Wow.Helpers.PathFinderClass Namespace


Pather Class

Class Pather. Use the PathFinder for findpath.

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class Pather
Public Class Pather
public ref class Pather

Inheritance Hierarchy

Object
wManager.Wow.Helpers.PathFinderClass..::..Pather

See Also

Pather Members
wManager.Wow.Helpers.PathFinderClass Namespace


Pather Members

The Pather type exposes the following members.

Constructors

 | Name | Description
Public method | Pather | Initializes a new instance of the Pather class.

Methods

 | Name | Description
Public method | Dispose | Disposes this instance.
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindPath | Find path (use [PathFinder.FindPath(robotManager.Helpful.Vector3)]).
Public method | FindZ | Get Z position (better to use GetZPosition(Vector3, Boolean)).
Public method | GetHashCode | (Inherited from Object.)
 | GetLocationByTile(Single, Single, array<Single>[]()[][]%) | Get location by tile.
 | GetLocationByTile(Double, Double, array<Single>[]()[][]%) | Get location by tile.
 | GetTileByLocation(Vector3, Single%, Single%) | Get tile by location.
 | GetTileByLocation(array<Single>[]()[][], Single%, Single%) | Get tile by location.
Public method | GetTileName | Get name of the tile.
Public method | GetTilePath | Get tile path.
Public method | GetType | (Inherited from Object.)
Public method | LoadAllTiles | Load all continent tiles.
Public method | LoadAround | Load tiles around.
Public method | LoadTile | Load the tile.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | RemoveTile | unload tile.
Public method | ReportArea | Report area.
Public method | ReportBigDangerArea | Report big danger area.
Public method | ReportDangerArea | Reports danger area.
Public method | ReportNormalArea | Report normal area.
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | Continent | Get the continent.
 | PathFinderLocker | Get the path finder locker.
Public property | RD | Get rd instance.

Events

 | Name | Description
Public event | OnMeshFileAdded | Occurs when mesh file added.
Public event | OnMeshFileRemoved | Occurs when mesh file removed.

See Also

Pather Class
wManager.Wow.Helpers.PathFinderClass Namespace


Pather Constructor

Initializes a new instance of the Pather class.

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Pather(
    string continent
)
Public Sub New ( _
    continent As String _
)
public:
Pather(
    String^ continent
)

Parameters

continent
Type: String
The continent.

See Also

Pather Class
wManager.Wow.Helpers.PathFinderClass Namespace


Pather Methods

The Pather type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Disposes this instance.
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindPath | Find path (use [PathFinder.FindPath(robotManager.Helpful.Vector3)]).
Public method | FindZ | Get Z position (better to use GetZPosition(Vector3, Boolean)).
Public method | GetHashCode | (Inherited from Object.)
 | GetLocationByTile(Single, Single, array<Single>[]()[][]%) | Get location by tile.
 | GetLocationByTile(Double, Double, array<Single>[]()[][]%) | Get location by tile.
 | GetTileByLocation(Vector3, Single%, Single%) | Get tile by location.
 | GetTileByLocation(array<Single>[]()[][], Single%, Single%) | Get tile by location.
Public method | GetTileName | Get name of the tile.
Public method | GetTilePath | Get tile path.
Public method | GetType | (Inherited from Object.)
Public method | LoadAllTiles | Load all continent tiles.
Public method | LoadAround | Load tiles around.
Public method | LoadTile | Load the tile.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | RemoveTile | unload tile.
Public method | ReportArea | Report area.
Public method | ReportBigDangerArea | Report big danger area.
Public method | ReportDangerArea | Reports danger area.
Public method | ReportNormalArea | Report normal area.
Public method | ToString | (Inherited from Object.)

See Also

Pather Class
wManager.Wow.Helpers.PathFinderClass Namespace


Dispose Method

Pather..::..Dispose Method

Disposes this instance.

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void Dispose()
Public Sub Dispose
public:
void Dispose()

See Also

Pather Class
wManager.Wow.Helpers.PathFinderClass Namespace


FindPath Method

Pather..::..FindPath Method

Find path (use [PathFinder.FindPath(robotManager.Helpful.Vector3)]).

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<Vector3> FindPath(
    Vector3 startVec,
    Vector3 endVec,
    out bool resultSuccess,
    out bool resultPartial,
    int maxPathCount,
    float wallDistance,
    bool bigExtents,
    bool skipIfPartiel
)
Public Function FindPath ( _
    startVec As Vector3, _
    endVec As Vector3, _
    <OutAttribute> ByRef resultSuccess As Boolean, _
    <OutAttribute> ByRef resultPartial As Boolean, _
    maxPathCount As Integer, _
    wallDistance As Single, _
    bigExtents As Boolean, _
    skipIfPartiel As Boolean _
) As List(Of Vector3)
public:
List<Vector3^>^ FindPath(
    Vector3^ startVec,
    Vector3^ endVec,
    [OutAttribute] bool^% resultSuccess,
    [OutAttribute] bool^% resultPartial,
    int^ maxPathCount,
    float^ wallDistance,
    bool^ bigExtents,
    bool^ skipIfPartiel
)

Parameters

startVec
Type: robotManager.Helpful..::..Vector3
The start vec.
endVec
Type: robotManager.Helpful..::..Vector3
The end vec.
resultSuccess
Type: Boolean %
if set to true [result success].
resultPartial
Type: Boolean %
if set to true [result partial].
maxPathCount
Type: Int32
The maximum path count.
wallDistance
Type: Single
The wall distance.
bigExtents
Type: Boolean
if set to true [big extents].
skipIfPartiel
Type: Boolean
if set to true [skip if partiel].

Return Value

List<Vector3>.

See Also

Pather Class
wManager.Wow.Helpers.PathFinderClass Namespace


FindZ Method

Pather..::..FindZ Method

Get Z position (better to use GetZPosition(Vector3, Boolean)).

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float FindZ(
    Vector3 position,
    bool strict
)
Public Function FindZ ( _
    position As Vector3, _
    strict As Boolean _
) As Single
public:
float^ FindZ(
    Vector3^ position,
    bool^ strict
)

Parameters

position
Type: robotManager.Helpful..::..Vector3
The position.
strict
Type: Boolean
if set to true [strict].

Return Value

System.Single.

See Also

Pather Class
wManager.Wow.Helpers.PathFinderClass Namespace


GetLocationByTile Method

Pather..::..GetLocationByTile Method

Overload List

Name | Description
GetLocationByTile(Single, Single, array<Single>[]()[][]%) | Get location by tile.
GetLocationByTile(Double, Double, array<Single>[]()[][]%) | Get location by tile.

See Also

Pather Class
Pather Members
wManager.Wow.Helpers.PathFinderClass Namespace


GetLocationByTile Method (Single, Single, Single[])

Pather..::..GetLocationByTile Method (Single, Single, array<Single>[]()[][]%)

Get location by tile.

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void GetLocationByTile(
    float x,
    float y,
    out float[] loc
)
Public Shared Sub GetLocationByTile ( _
    x As Single, _
    y As Single, _
    <OutAttribute> ByRef loc As Single() _
)
public:
static void GetLocationByTile(
    float^ x,
    float^ y,
    [OutAttribute] array<float^>^% loc
)

Parameters

x
Type: Single
The x.
y
Type: Single
The y.
loc
Type: array< Single >[]()[][]%
The loc.

See Also

Pather Class
GetLocationByTile Overload
wManager.Wow.Helpers.PathFinderClass Namespace


GetLocationByTile Method (Double, Double, Single[])

Pather..::..GetLocationByTile Method (Double, Double, array<Single>[]()[][]%)

Get location by tile.

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void GetLocationByTile(
    double x,
    double y,
    out float[] loc
)
Public Shared Sub GetLocationByTile ( _
    x As Double, _
    y As Double, _
    <OutAttribute> ByRef loc As Single() _
)
public:
static void GetLocationByTile(
    double^ x,
    double^ y,
    [OutAttribute] array<float^>^% loc
)

Parameters

x
Type: Double
The x.
y
Type: Double
The y.
loc
Type: array< Single >[]()[][]%
The loc.

See Also

Pather Class
GetLocationByTile Overload
wManager.Wow.Helpers.PathFinderClass Namespace


GetTileByLocation Method

Pather..::..GetTileByLocation Method

Overload List

Name | Description
GetTileByLocation(Vector3, Single%, Single%) | Get tile by location.
GetTileByLocation(array<Single>[]()[][], Single%, Single%) | Get tile by location.

See Also

Pather Class
Pather Members
wManager.Wow.Helpers.PathFinderClass Namespace


GetTileByLocation Method (Vector3, Single, Single)

Pather..::..GetTileByLocation Method (Vector3, Single%, Single%)

Get tile by location.

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void GetTileByLocation(
    Vector3 loc,
    out float x,
    out float y
)
Public Shared Sub GetTileByLocation ( _
    loc As Vector3, _
    <OutAttribute> ByRef x As Single, _
    <OutAttribute> ByRef y As Single _
)
public:
static void GetTileByLocation(
    Vector3^ loc,
    [OutAttribute] float^% x,
    [OutAttribute] float^% y
)

Parameters

loc
Type: robotManager.Helpful..::..Vector3
The loc.
x
Type: Single %
The x.
y
Type: Single %
The y.

See Also

Pather Class
GetTileByLocation Overload
wManager.Wow.Helpers.PathFinderClass Namespace


GetTileByLocation Method (Single[], Single, Single)

Pather..::..GetTileByLocation Method (array<Single>[]()[][], Single%, Single%)

Get tile by location.

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void GetTileByLocation(
    float[] loc,
    out float x,
    out float y
)
Public Shared Sub GetTileByLocation ( _
    loc As Single(), _
    <OutAttribute> ByRef x As Single, _
    <OutAttribute> ByRef y As Single _
)
public:
static void GetTileByLocation(
    array<float^>^ loc,
    [OutAttribute] float^% x,
    [OutAttribute] float^% y
)

Parameters

loc
Type: array< Single >[]()[][]
The loc.
x
Type: Single %
The x.
y
Type: Single %
The y.

See Also

Pather Class
GetTileByLocation Overload
wManager.Wow.Helpers.PathFinderClass Namespace


GetTileName Method

Pather..::..GetTileName Method

Get name of the tile.

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string GetTileName(
    int x,
    int y,
    bool continentNameOnly
)
Public Function GetTileName ( _
    x As Integer, _
    y As Integer, _
    continentNameOnly As Boolean _
) As String
public:
String^ GetTileName(
    int^ x,
    int^ y,
    bool^ continentNameOnly
)

Parameters

x
Type: Int32
The x.
y
Type: Int32
The y.
continentNameOnly
Type: Boolean
if set to true [continent name only].

Return Value

System.String.

See Also

Pather Class
wManager.Wow.Helpers.PathFinderClass Namespace


GetTilePath Method

Pather..::..GetTilePath Method

Get tile path.

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string GetTilePath(
    int x,
    int y
)
Public Function GetTilePath ( _
    x As Integer, _
    y As Integer _
) As String
public:
String^ GetTilePath(
    int^ x,
    int^ y
)

Parameters

x
Type: Int32
The x.
y
Type: Int32
The y.

Return Value

System.String.

See Also

Pather Class
wManager.Wow.Helpers.PathFinderClass Namespace


LoadAllTiles Method

Pather..::..LoadAllTiles Method

Load all continent tiles.

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void LoadAllTiles()
Public Sub LoadAllTiles
public:
void LoadAllTiles()

See Also

Pather Class
wManager.Wow.Helpers.PathFinderClass Namespace


LoadAround Method

Pather..::..LoadAround Method

Load tiles around.

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public void LoadAround(
    Vector3 loc
)
Public Sub LoadAround ( _
    loc As Vector3 _
)
public:
void LoadAround(
    Vector3^ loc
)

Parameters

loc
Type: robotManager.Helpful..::..Vector3
The loc.

See Also

Pather Class
wManager.Wow.Helpers.PathFinderClass Namespace


LoadTile Method

Pather..::..LoadTile Method

Load the tile.

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool LoadTile(
    int x,
    int y
)
Public Function LoadTile ( _
    x As Integer, _
    y As Integer _
) As Boolean
public:
bool^ LoadTile(
    int^ x,
    int^ y
)

Parameters

x
Type: Int32
The x.
y
Type: Int32
The y.

Return Value

true if success, false otherwise.

See Also

Pather Class
wManager.Wow.Helpers.PathFinderClass Namespace


RemoveTile Method

Pather..::..RemoveTile Method

unload tile.

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool RemoveTile(
    int x,
    int y
)
Public Function RemoveTile ( _
    x As Integer, _
    y As Integer _
) As Boolean
public:
bool^ RemoveTile(
    int^ x,
    int^ y
)

Parameters

x
Type: Int32
The x.
y
Type: Int32
The y.

Return Value

true if XXXX, false otherwise.

See Also

Pather Class
wManager.Wow.Helpers.PathFinderClass Namespace


ReportArea Method

Pather..::..ReportArea Method

Report area.

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool ReportArea(
    Vector3 position,
    float radius,
    PolyArea areaType
)
Public Function ReportArea ( _
    position As Vector3, _
    radius As Single, _
    areaType As PolyArea _
) As Boolean
public:
bool^ ReportArea(
    Vector3^ position,
    float^ radius,
    PolyArea^ areaType
)

Parameters

position
Type: robotManager.Helpful..::..Vector3
The position.
radius
Type: Single
The radius.
areaType
Type: PolyArea
Type of the area.

Return Value

true if added, false otherwise.

See Also

Pather Class
wManager.Wow.Helpers.PathFinderClass Namespace


ReportBigDangerArea Method

Pather..::..ReportBigDangerArea Method

Report big danger area.

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool ReportBigDangerArea(
    Vector3 position,
    float radius
)
Public Function ReportBigDangerArea ( _
    position As Vector3, _
    radius As Single _
) As Boolean
public:
bool^ ReportBigDangerArea(
    Vector3^ position,
    float^ radius
)

Parameters

position
Type: robotManager.Helpful..::..Vector3
The position.
radius
Type: Single
The radius.

Return Value

true if added, false otherwise.

See Also

Pather Class
wManager.Wow.Helpers.PathFinderClass Namespace


ReportDangerArea Method

Pather..::..ReportDangerArea Method

Reports danger area.

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool ReportDangerArea(
    Vector3 position,
    float radius
)
Public Function ReportDangerArea ( _
    position As Vector3, _
    radius As Single _
) As Boolean
public:
bool^ ReportDangerArea(
    Vector3^ position,
    float^ radius
)

Parameters

position
Type: robotManager.Helpful..::..Vector3
The position.
radius
Type: Single
The radius.

Return Value

true if added, false otherwise.

See Also

Pather Class
wManager.Wow.Helpers.PathFinderClass Namespace


ReportNormalArea Method

Pather..::..ReportNormalArea Method

Report normal area.

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool ReportNormalArea(
    Vector3 position,
    float radius
)
Public Function ReportNormalArea ( _
    position As Vector3, _
    radius As Single _
) As Boolean
public:
bool^ ReportNormalArea(
    Vector3^ position,
    float^ radius
)

Parameters

position
Type: robotManager.Helpful..::..Vector3
The position.
radius
Type: Single
The radius.

Return Value

true if added, false otherwise.

See Also

Pather Class
wManager.Wow.Helpers.PathFinderClass Namespace


Pather Properties

The Pather type exposes the following members.

Properties

 | Name | Description
Public property | Continent | Get the continent.
 | PathFinderLocker | Get the path finder locker.
Public property | RD | Get rd instance.

See Also

Pather Class
wManager.Wow.Helpers.PathFinderClass Namespace


Continent Property

Pather..::..Continent Property

Get the continent.

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string Continent { get; set; }
Public Property Continent As String
    Get
    Set
public:
property String^ Continent {
    String^ get ();
    void set (String^ value);
}

Field Value

The continent.

See Also

Pather Class
wManager.Wow.Helpers.PathFinderClass Namespace


PathFinderLocker Property

Pather..::..PathFinderLocker Property

Get the path finder locker.

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static Object PathFinderLocker { get; }
Public Shared ReadOnly Property PathFinderLocker As Object
    Get
public:
static property Object^ PathFinderLocker {
    Object^ get ();
}

Field Value

The path finder locker.

See Also

Pather Class
wManager.Wow.Helpers.PathFinderClass Namespace


RD Property

Pather..::..RD Property

Get rd instance.

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public RD RD { get; }
Public ReadOnly Property RD As RD
    Get
public:
property RD^ RD {
    RD^ get ();
}

Field Value

The rd.

See Also

Pather Class
wManager.Wow.Helpers.PathFinderClass Namespace


Pather Events

The Pather type exposes the following members.

Events

 | Name | Description
Public event | OnMeshFileAdded | Occurs when mesh file added.
Public event | OnMeshFileRemoved | Occurs when mesh file removed.

See Also

Pather Class
wManager.Wow.Helpers.PathFinderClass Namespace


OnMeshFileAdded Event

Pather..::..OnMeshFileAdded Event

Occurs when mesh file added.

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public event Pather..::..MeshFileAddedHandler OnMeshFileAdded
Public Event OnMeshFileAdded As Pather..::..MeshFileAddedHandler
public:
 event Pather..::..MeshFileAddedHandler^ OnMeshFileAdded {
    void add (Pather..::..MeshFileAddedHandler^ value);
    void remove (Pather..::..MeshFileAddedHandler^ value);
}

See Also

Pather Class
wManager.Wow.Helpers.PathFinderClass Namespace


OnMeshFileRemoved Event

Pather..::..OnMeshFileRemoved Event

Occurs when mesh file removed.

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public event Pather..::..MeshFileRemovedHandler OnMeshFileRemoved
Public Event OnMeshFileRemoved As Pather..::..MeshFileRemovedHandler
public:
 event Pather..::..MeshFileRemovedHandler^ OnMeshFileRemoved {
    void add (Pather..::..MeshFileRemovedHandler^ value);
    void remove (Pather..::..MeshFileRemovedHandler^ value);
}

See Also

Pather Class
wManager.Wow.Helpers.PathFinderClass Namespace


Pather.MeshFileAddedHandler Delegate

Pather..::..MeshFileAddedHandler Delegate

Delegate MeshFileAddedHandler

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public delegate void MeshFileAddedHandler(
    float x,
    float y
)
Public Delegate Sub MeshFileAddedHandler ( _
    x As Single, _
    y As Single _
)
public delegate void MeshFileAddedHandler(
    float^ x,
    float^ y
)

Parameters

x
Type: Single
The x.
y
Type: Single
The y.

See Also

wManager.Wow.Helpers.PathFinderClass Namespace


Pather.MeshFileRemovedHandler Delegate

Pather..::..MeshFileRemovedHandler Delegate

Delegate MeshFileRemovedHandler

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public delegate void MeshFileRemovedHandler(
    float x,
    float y
)
Public Delegate Sub MeshFileRemovedHandler ( _
    x As Single, _
    y As Single _
)
public delegate void MeshFileRemovedHandler(
    float^ x,
    float^ y
)

Parameters

x
Type: Single
The x.
y
Type: Single
The y.

See Also

wManager.Wow.Helpers.PathFinderClass Namespace


PatherServer Class

Class PatherServer. Use the PathFinder for findpath.

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class PatherServer
Public NotInheritable Class PatherServer
public ref class PatherServer abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Helpers.PathFinderClass..::..PatherServer

See Also

PatherServer Members
wManager.Wow.Helpers.PathFinderClass Namespace


PatherServer Members

The PatherServer type exposes the following members.

Methods

Name | Description
FindPath | Find path (use [PathFinder.FindPath(robotManager.Helpful.Vector3)]).
FindZ | Get Z position (better to use GetZPosition(Vector3, Boolean)).
GetLocationByTile(Single, Single, array<Single>[]()[][]%) | Get location by tile.
GetLocationByTile(Double, Double, array<Single>[]()[][]%) | Get location by tile.
GetTileByLocation(Vector3, Single%, Single%) | Get tile by location.
GetTileByLocation(array<Single>[]()[][], Single%, Single%) | Get tile by location.
GetTileName | Get name of the tile.

Fields

Name | Description
MaxCacheSize | The maximum cache size
PathFinderLocker | The path finder locker

See Also

PatherServer Class
wManager.Wow.Helpers.PathFinderClass Namespace


PatherServer Fields

The PatherServer type exposes the following members.

Fields

Name | Description
MaxCacheSize | The maximum cache size
PathFinderLocker | The path finder locker

See Also

PatherServer Class
wManager.Wow.Helpers.PathFinderClass Namespace


MaxCacheSize Field

PatherServer..::..MaxCacheSize Field

The maximum cache size

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int MaxCacheSize
Public Shared MaxCacheSize As Integer
public:
static int^ MaxCacheSize

See Also

PatherServer Class
wManager.Wow.Helpers.PathFinderClass Namespace


PathFinderLocker Field

PatherServer..::..PathFinderLocker Field

The path finder locker

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static Object PathFinderLocker
Public Shared PathFinderLocker As Object
public:
static Object^ PathFinderLocker

See Also

PatherServer Class
wManager.Wow.Helpers.PathFinderClass Namespace


PatherServer Methods

The PatherServer type exposes the following members.

Methods

Name | Description
FindPath | Find path (use [PathFinder.FindPath(robotManager.Helpful.Vector3)]).
FindZ | Get Z position (better to use GetZPosition(Vector3, Boolean)).
GetLocationByTile(Single, Single, array<Single>[]()[][]%) | Get location by tile.
GetLocationByTile(Double, Double, array<Single>[]()[][]%) | Get location by tile.
GetTileByLocation(Vector3, Single%, Single%) | Get tile by location.
GetTileByLocation(array<Single>[]()[][], Single%, Single%) | Get tile by location.
GetTileName | Get name of the tile.

See Also

PatherServer Class
wManager.Wow.Helpers.PathFinderClass Namespace


FindPath Method

PatherServer..::..FindPath Method

Find path (use [PathFinder.FindPath(robotManager.Helpful.Vector3)]).

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<Vector3> FindPath(
    string continent,
    Vector3 startVec,
    Vector3 endVec,
    out bool resultSuccess,
    out bool resultPartial,
    int maxPathCount,
    float wallDistance,
    bool bigExtents,
    bool skipIfPartiel,
    bool ignoreServerRoadsWater
)
Public Shared Function FindPath ( _
    continent As String, _
    startVec As Vector3, _
    endVec As Vector3, _
    <OutAttribute> ByRef resultSuccess As Boolean, _
    <OutAttribute> ByRef resultPartial As Boolean, _
    maxPathCount As Integer, _
    wallDistance As Single, _
    bigExtents As Boolean, _
    skipIfPartiel As Boolean, _
    ignoreServerRoadsWater As Boolean _
) As List(Of Vector3)
public:
static List<Vector3^>^ FindPath(
    String^ continent,
    Vector3^ startVec,
    Vector3^ endVec,
    [OutAttribute] bool^% resultSuccess,
    [OutAttribute] bool^% resultPartial,
    int^ maxPathCount,
    float^ wallDistance,
    bool^ bigExtents,
    bool^ skipIfPartiel,
    bool^ ignoreServerRoadsWater
)

Parameters

continent
Type: String
The continent.
startVec
Type: robotManager.Helpful..::..Vector3
The start vec.
endVec
Type: robotManager.Helpful..::..Vector3
The end vec.
resultSuccess
Type: Boolean %
if set to true [result success].
resultPartial
Type: Boolean %
if set to true [result partial].
maxPathCount
Type: Int32
The maximum path count.
wallDistance
Type: Single
The wall distance.
bigExtents
Type: Boolean
if set to true [big extents].
skipIfPartiel
Type: Boolean
if set to true [skip if partiel].
ignoreServerRoadsWater
Type: Boolean
if set to true [ignore server roads water].

Return Value

List<Vector3>.

See Also

PatherServer Class
wManager.Wow.Helpers.PathFinderClass Namespace


FindZ Method

PatherServer..::..FindZ Method

Get Z position (better to use GetZPosition(Vector3, Boolean)).

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static float FindZ(
    string continent,
    Vector3 position,
    bool strict
)
Public Shared Function FindZ ( _
    continent As String, _
    position As Vector3, _
    strict As Boolean _
) As Single
public:
static float^ FindZ(
    String^ continent,
    Vector3^ position,
    bool^ strict
)

Parameters

continent
Type: String
The continent.
position
Type: robotManager.Helpful..::..Vector3
The position.
strict
Type: Boolean
if set to true strict mode.

Return Value

System.Single.

See Also

PatherServer Class
wManager.Wow.Helpers.PathFinderClass Namespace


GetLocationByTile Method

PatherServer..::..GetLocationByTile Method

Overload List

Name | Description
GetLocationByTile(Single, Single, array<Single>[]()[][]%) | Get location by tile.
GetLocationByTile(Double, Double, array<Single>[]()[][]%) | Get location by tile.

See Also

PatherServer Class
PatherServer Members
wManager.Wow.Helpers.PathFinderClass Namespace


GetLocationByTile Method (Single, Single, Single[])

PatherServer..::..GetLocationByTile Method (Single, Single, array<Single>[]()[][]%)

Get location by tile.

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void GetLocationByTile(
    float x,
    float y,
    out float[] loc
)
Public Shared Sub GetLocationByTile ( _
    x As Single, _
    y As Single, _
    <OutAttribute> ByRef loc As Single() _
)
public:
static void GetLocationByTile(
    float^ x,
    float^ y,
    [OutAttribute] array<float^>^% loc
)

Parameters

x
Type: Single
The x.
y
Type: Single
The y.
loc
Type: array< Single >[]()[][]%
The loc.

See Also

PatherServer Class
GetLocationByTile Overload
wManager.Wow.Helpers.PathFinderClass Namespace


GetLocationByTile Method (Double, Double, Single[])

PatherServer..::..GetLocationByTile Method (Double, Double, array<Single>[]()[][]%)

Get location by tile.

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void GetLocationByTile(
    double x,
    double y,
    out float[] loc
)
Public Shared Sub GetLocationByTile ( _
    x As Double, _
    y As Double, _
    <OutAttribute> ByRef loc As Single() _
)
public:
static void GetLocationByTile(
    double^ x,
    double^ y,
    [OutAttribute] array<float^>^% loc
)

Parameters

x
Type: Double
The x.
y
Type: Double
The y.
loc
Type: array< Single >[]()[][]%
The loc.

See Also

PatherServer Class
GetLocationByTile Overload
wManager.Wow.Helpers.PathFinderClass Namespace


GetTileByLocation Method

PatherServer..::..GetTileByLocation Method

Overload List

Name | Description
GetTileByLocation(Vector3, Single%, Single%) | Get tile by location.
GetTileByLocation(array<Single>[]()[][], Single%, Single%) | Get tile by location.

See Also

PatherServer Class
PatherServer Members
wManager.Wow.Helpers.PathFinderClass Namespace


GetTileByLocation Method (Vector3, Single, Single)

PatherServer..::..GetTileByLocation Method (Vector3, Single%, Single%)

Get tile by location.

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void GetTileByLocation(
    Vector3 loc,
    out float x,
    out float y
)
Public Shared Sub GetTileByLocation ( _
    loc As Vector3, _
    <OutAttribute> ByRef x As Single, _
    <OutAttribute> ByRef y As Single _
)
public:
static void GetTileByLocation(
    Vector3^ loc,
    [OutAttribute] float^% x,
    [OutAttribute] float^% y
)

Parameters

loc
Type: robotManager.Helpful..::..Vector3
The loc.
x
Type: Single %
The x.
y
Type: Single %
The y.

See Also

PatherServer Class
GetTileByLocation Overload
wManager.Wow.Helpers.PathFinderClass Namespace


GetTileByLocation Method (Single[], Single, Single)

PatherServer..::..GetTileByLocation Method (array<Single>[]()[][], Single%, Single%)

Get tile by location.

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void GetTileByLocation(
    float[] loc,
    out float x,
    out float y
)
Public Shared Sub GetTileByLocation ( _
    loc As Single(), _
    <OutAttribute> ByRef x As Single, _
    <OutAttribute> ByRef y As Single _
)
public:
static void GetTileByLocation(
    array<float^>^ loc,
    [OutAttribute] float^% x,
    [OutAttribute] float^% y
)

Parameters

loc
Type: array< Single >[]()[][]
The loc.
x
Type: Single %
The x.
y
Type: Single %
The y.

See Also

PatherServer Class
GetTileByLocation Overload
wManager.Wow.Helpers.PathFinderClass Namespace


GetTileName Method

PatherServer..::..GetTileName Method

Get name of the tile.

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static string GetTileName(
    string continent,
    int x,
    int y,
    bool continentNameOnly
)
Public Shared Function GetTileName ( _
    continent As String, _
    x As Integer, _
    y As Integer, _
    continentNameOnly As Boolean _
) As String
public:
static String^ GetTileName(
    String^ continent,
    int^ x,
    int^ y,
    bool^ continentNameOnly
)

Parameters

continent
Type: String
The continent.
x
Type: Int32
The x.
y
Type: Int32
The y.
continentNameOnly
Type: Boolean
if set to true [continent name only].

Return Value

System.String.

See Also

PatherServer Class
wManager.Wow.Helpers.PathFinderClass Namespace


PathFinderInterface Interface

Interface PathFinderInterface, you have possibility to use you own pathfinder, for that implement this interface on class named "PathFinder" without namespace and save dll to "WRobot\Bin\pathfinderoverride.dll".

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public interface PathFinderInterface
Public Interface PathFinderInterface
public interface class PathFinderInterface

See Also

PathFinderInterface Members
wManager.Wow.Helpers.PathFinderClass Namespace


PathFinderInterface Members

The PathFinderInterface type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindPath | Find path.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | GetZPosition | Get position Z.
Public method | InitPather | Initialize the pather.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReportArea | Report the area.
Public method | ResetArea | Reset area to POLYAREA_GROUND()()()() by position and type.
Public method | ResetAreaByType | Reset area to POLYAREA_GROUND()()()() by type.
Public method | ToString | (Inherited from Object.)

See Also

PathFinderInterface Interface
wManager.Wow.Helpers.PathFinderClass Namespace


PathFinderInterface Methods

The PathFinderInterface type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindPath | Find path.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | GetZPosition | Get position Z.
Public method | InitPather | Initialize the pather.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReportArea | Report the area.
Public method | ResetArea | Reset area to POLYAREA_GROUND()()()() by position and type.
Public method | ResetAreaByType | Reset area to POLYAREA_GROUND()()()() by type.
Public method | ToString | (Inherited from Object.)

See Also

PathFinderInterface Interface
wManager.Wow.Helpers.PathFinderClass Namespace


FindPath Method

PathFinderInterface..::..FindPath Method

Find path.

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
List<Vector3> FindPath(
    Vector3 from,
    Vector3 to,
    string continentNameMpq,
    out bool resultSuccess,
    bool addFromAndStart,
    bool loadAllTile
)
Function FindPath ( _
    from As Vector3, _
    to As Vector3, _
    continentNameMpq As String, _
    <OutAttribute> ByRef resultSuccess As Boolean, _
    addFromAndStart As Boolean, _
    loadAllTile As Boolean _
) As List(Of Vector3)
List<Vector3^>^ FindPath(
    Vector3^ from,
    Vector3^ to,
    String^ continentNameMpq,
    [OutAttribute] bool^% resultSuccess,
    bool^ addFromAndStart,
    bool^ loadAllTile
)

Parameters

from
Type: robotManager.Helpful..::..Vector3
Starting position.
to
Type: robotManager.Helpful..::..Vector3
destination position.
continentNameMpq
Type: String
The continent name (file name like ContinentNameMpq).
resultSuccess
Type: Boolean %
if set to true success.
addFromAndStart
Type: Boolean
if set to true [add from and start].
loadAllTile
Type: Boolean
if set to true [load all tile].

Return Value

path.

See Also

PathFinderInterface Interface
wManager.Wow.Helpers.PathFinderClass Namespace


GetZPosition Method

PathFinderInterface..::..GetZPosition Method

Get position Z.

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
float GetZPosition(
    Vector3 point,
    bool strict
)
Function GetZPosition ( _
    point As Vector3, _
    strict As Boolean _
) As Single
float^ GetZPosition(
    Vector3^ point,
    bool^ strict
)

Parameters

point
Type: robotManager.Helpful..::..Vector3
Position where get height.
strict
Type: Boolean
if set to true the pathfinder will be strict, if set to false if pathfinder don't found Z position of specified X,Y position he will look for the Z position of a near X,Y position.

Return Value

position Z.

See Also

PathFinderInterface Interface
wManager.Wow.Helpers.PathFinderClass Namespace


InitPather Method

PathFinderInterface..::..InitPather Method

Initialize the pather.

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
void InitPather(
    string continentNameMpq
)
Sub InitPather ( _
    continentNameMpq As String _
)
void InitPather(
    String^ continentNameMpq
)

Parameters

continentNameMpq
Type: String
The continent name (ContinentNameMpq).

See Also

PathFinderInterface Interface
wManager.Wow.Helpers.PathFinderClass Namespace


ReportArea Method

PathFinderInterface..::..ReportArea Method

Report the area.

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
bool ReportArea(
    Vector3 position,
    float radius,
    PolyArea areaType,
    bool addToList
)
Function ReportArea ( _
    position As Vector3, _
    radius As Single, _
    areaType As PolyArea, _
    addToList As Boolean _
) As Boolean
bool^ ReportArea(
    Vector3^ position,
    float^ radius,
    PolyArea^ areaType,
    bool^ addToList
)

Parameters

position
Type: robotManager.Helpful..::..Vector3
The position.
radius
Type: Single
The radius.
areaType
Type: PolyArea
Type of the area.
addToList
Type: Boolean
if set to true add to list (by default AddAreaToList(ReportAreaStruct)).

Return Value

true if added, false otherwise.

See Also

PathFinderInterface Interface
wManager.Wow.Helpers.PathFinderClass Namespace


ResetArea Method

PathFinderInterface..::..ResetArea Method

Reset area to POLYAREA_GROUND()()()() by position and type.

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
void ResetArea(
    Vector3 position,
    float radius,
    PolyArea areaType
)
Sub ResetArea ( _
    position As Vector3, _
    radius As Single, _
    areaType As PolyArea _
)
void ResetArea(
    Vector3^ position,
    float^ radius,
    PolyArea^ areaType
)

Parameters

position
Type: robotManager.Helpful..::..Vector3
The position.
radius
Type: Single
The radius.
areaType
Type: PolyArea
Type of area.

See Also

PathFinderInterface Interface
wManager.Wow.Helpers.PathFinderClass Namespace


ResetAreaByType Method

PathFinderInterface..::..ResetAreaByType Method

Reset area to POLYAREA_GROUND()()()() by type.

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
void ResetAreaByType(
    PolyArea areaType
)
Sub ResetAreaByType ( _
    areaType As PolyArea _
)
void ResetAreaByType(
    PolyArea^ areaType
)

Parameters

areaType
Type: PolyArea
Type to reset.

See Also

PathFinderInterface Interface
wManager.Wow.Helpers.PathFinderClass Namespace


PathPacket Class

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class PathPacket
<SerializableAttribute> _
Public Class PathPacket
[SerializableAttribute]
public ref class PathPacket

Inheritance Hierarchy

Object
wManager.Wow.Helpers.PathFinderClass..::..PathPacket

See Also

PathPacket Members
wManager.Wow.Helpers.PathFinderClass Namespace


PathPacket Members

The PathPacket type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | Logs |
Public field | Path |
Public field | ResultPartial |
Public field | ResultSuccess |

See Also

PathPacket Class
wManager.Wow.Helpers.PathFinderClass Namespace


PathPacket Fields

The PathPacket type exposes the following members.

Fields

 | Name | Description
Public field | Logs |
Public field | Path |
Public field | ResultPartial |
Public field | ResultSuccess |

See Also

PathPacket Class
wManager.Wow.Helpers.PathFinderClass Namespace


Logs Field

PathPacket..::..Logs Field

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[JsonPropertyAttribute]
public List<string> Logs
<JsonPropertyAttribute> _
Public Logs As List(Of String)
[JsonPropertyAttribute]
public:
List<String^>^ Logs

See Also

PathPacket Class
wManager.Wow.Helpers.PathFinderClass Namespace


Path Field

PathPacket..::..Path Field

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[JsonPropertyAttribute]
public List<Vector3Simple> Path
<JsonPropertyAttribute> _
Public Path As List(Of Vector3Simple)
[JsonPropertyAttribute]
public:
List<Vector3Simple^>^ Path

See Also

PathPacket Class
wManager.Wow.Helpers.PathFinderClass Namespace


ResultPartial Field

PathPacket..::..ResultPartial Field

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[JsonPropertyAttribute]
public bool ResultPartial
<JsonPropertyAttribute> _
Public ResultPartial As Boolean
[JsonPropertyAttribute]
public:
bool^ ResultPartial

See Also

PathPacket Class
wManager.Wow.Helpers.PathFinderClass Namespace


ResultSuccess Field

PathPacket..::..ResultSuccess Field

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[JsonPropertyAttribute]
public bool ResultSuccess
<JsonPropertyAttribute> _
Public ResultSuccess As Boolean
[JsonPropertyAttribute]
public:
bool^ ResultSuccess

See Also

PathPacket Class
wManager.Wow.Helpers.PathFinderClass Namespace


PathPacket Methods

The PathPacket type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

PathPacket Class
wManager.Wow.Helpers.PathFinderClass Namespace


Utility Class

Class Utility. Useful methods for PathFinder

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class Utility
Public NotInheritable Class Utility
public ref class Utility abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.Helpers.PathFinderClass..::..Utility

See Also

Utility Members
wManager.Wow.Helpers.PathFinderClass Namespace


Utility Members

The Utility type exposes the following members.

Methods

Name | Description
GetPostion2DOfLineByDistance | Get position 2d of line by distance.
ToFloatArray | Convert vector3 to float array.
ToRecast(array<Single>[]()[][]) | Converts to recast position (from wow).
ToRecast(Vector3) | Converts to recast position (from wow).
ToWoW(array<Single>[]()[][]) | Converts to wow position (from recast).
ToWoW(Vector3) | Converts to wow position (from recast).
ToWowListVector3 | Convert from recast to wow list vector3.

Fields

Name | Description
MaxDistance2DUseRoadWater | The maximum distance 2d to use road and water when find path (used server side, RatioIncludeDistance2DFromCenter)
MaxPos | The maximum position (of game continent)
MaxSessionPerBotSession | The maximum pathfinder server sessions per bot session
MinPos | The minimum position (of game continent)
OffMeshConnectionsSearchDistance | The offmeshconnections search distance when find path (used server side, RatioIncludeDistance2DFromCenter)
Origin | The origin (game continent)
RatioIncludeDistance2DFromCenter | The distance ratio from center of areas and offmeshconnections to include (start.DistanceTo2D(end) * RatioIncludeDistance2DFromCenter;).
StopSearchToResolveAfterMs | Stop search after milliseconds

Properties

Name | Description
RDSettings | generate the rd settings.
TileSize | Get the size of tile.

See Also

Utility Class
wManager.Wow.Helpers.PathFinderClass Namespace


Utility Fields

The Utility type exposes the following members.

Fields

Name | Description
MaxDistance2DUseRoadWater | The maximum distance 2d to use road and water when find path (used server side, RatioIncludeDistance2DFromCenter)
MaxPos | The maximum position (of game continent)
MaxSessionPerBotSession | The maximum pathfinder server sessions per bot session
MinPos | The minimum position (of game continent)
OffMeshConnectionsSearchDistance | The offmeshconnections search distance when find path (used server side, RatioIncludeDistance2DFromCenter)
Origin | The origin (game continent)
RatioIncludeDistance2DFromCenter | The distance ratio from center of areas and offmeshconnections to include (start.DistanceTo2D(end) * RatioIncludeDistance2DFromCenter;).
StopSearchToResolveAfterMs | Stop search after milliseconds

See Also

Utility Class
wManager.Wow.Helpers.PathFinderClass Namespace


MaxDistance2DUseRoadWater Field

Utility..::..MaxDistance2DUseRoadWater Field

The maximum distance 2d to use road and water when find path (used server side, RatioIncludeDistance2DFromCenter)

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const float MaxDistance2DUseRoadWater
Public Const MaxDistance2DUseRoadWater As Single
public:
literal float^ MaxDistance2DUseRoadWater

See Also

Utility Class
wManager.Wow.Helpers.PathFinderClass Namespace


MaxPos Field

Utility..::..MaxPos Field

The maximum position (of game continent)

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static float MaxPos
Public Shared MaxPos As Single
public:
static float^ MaxPos

See Also

Utility Class
wManager.Wow.Helpers.PathFinderClass Namespace


MaxSessionPerBotSession Field

Utility..::..MaxSessionPerBotSession Field

The maximum pathfinder server sessions per bot session

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const int MaxSessionPerBotSession
Public Const MaxSessionPerBotSession As Integer
public:
literal int^ MaxSessionPerBotSession

See Also

Utility Class
wManager.Wow.Helpers.PathFinderClass Namespace


MinPos Field

Utility..::..MinPos Field

The minimum position (of game continent)

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static float MinPos
Public Shared MinPos As Single
public:
static float^ MinPos

See Also

Utility Class
wManager.Wow.Helpers.PathFinderClass Namespace


OffMeshConnectionsSearchDistance Field

Utility..::..OffMeshConnectionsSearchDistance Field

The offmeshconnections search distance when find path (used server side, RatioIncludeDistance2DFromCenter)

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static float OffMeshConnectionsSearchDistance
Public Shared OffMeshConnectionsSearchDistance As Single
public:
static float^ OffMeshConnectionsSearchDistance

See Also

Utility Class
wManager.Wow.Helpers.PathFinderClass Namespace


Origin Field

Utility..::..Origin Field

The origin (game continent)

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static float[] Origin
Public Shared Origin As Single()
public:
static array<float^>^ Origin

See Also

Utility Class
wManager.Wow.Helpers.PathFinderClass Namespace


RatioIncludeDistance2DFromCenter Field

Utility..::..RatioIncludeDistance2DFromCenter Field

The distance ratio from center of areas and offmeshconnections to include (start.DistanceTo2D(end) * RatioIncludeDistance2DFromCenter;).

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const float RatioIncludeDistance2DFromCenter
Public Const RatioIncludeDistance2DFromCenter As Single
public:
literal float^ RatioIncludeDistance2DFromCenter

See Also

Utility Class
wManager.Wow.Helpers.PathFinderClass Namespace


StopSearchToResolveAfterMs Field

Utility..::..StopSearchToResolveAfterMs Field

Stop search after milliseconds

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const int StopSearchToResolveAfterMs
Public Const StopSearchToResolveAfterMs As Integer
public:
literal int^ StopSearchToResolveAfterMs

See Also

Utility Class
wManager.Wow.Helpers.PathFinderClass Namespace


Utility Methods

The Utility type exposes the following members.

Methods

Name | Description
GetPostion2DOfLineByDistance | Get position 2d of line by distance.
ToFloatArray | Convert vector3 to float array.
ToRecast(array<Single>[]()[][]) | Converts to recast position (from wow).
ToRecast(Vector3) | Converts to recast position (from wow).
ToWoW(array<Single>[]()[][]) | Converts to wow position (from recast).
ToWoW(Vector3) | Converts to wow position (from recast).
ToWowListVector3 | Convert from recast to wow list vector3.

See Also

Utility Class
wManager.Wow.Helpers.PathFinderClass Namespace


GetPostion2DOfLineByDistance Method

Utility..::..GetPostion2DOfLineByDistance Method

Get position 2d of line by distance.

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static Vector3 GetPostion2DOfLineByDistance(
    Vector3 a,
    Vector3 b,
    float distance
)
Public Shared Function GetPostion2DOfLineByDistance ( _
    a As Vector3, _
    b As Vector3, _
    distance As Single _
) As Vector3
public:
static Vector3^ GetPostion2DOfLineByDistance(
    Vector3^ a,
    Vector3^ b,
    float^ distance
)

Parameters

a
Type: robotManager.Helpful..::..Vector3
base line position.
b
Type: robotManager.Helpful..::..Vector3
point of line.
distance
Type: Single
The line distance.

Return Value

Vector3.

See Also

Utility Class
wManager.Wow.Helpers.PathFinderClass Namespace


ToFloatArray Method

Utility..::..ToFloatArray Method

Convert vector3 to float array.

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static float[] ToFloatArray(
    this Vector3 v
)
<ExtensionAttribute> _
Public Shared Function ToFloatArray ( _
    v As Vector3 _
) As Single()
[ExtensionAttribute]
public:
static array<float^>^ ToFloatArray(
    Vector3^ v
)

Parameters

v
Type: robotManager.Helpful..::..Vector3
The vector3.

Return Value

position float array.

See Also

Utility Class
wManager.Wow.Helpers.PathFinderClass Namespace


ToRecast Method

Utility..::..ToRecast Method

Overload List

Name | Description
ToRecast(array<Single>[]()[][]) | Converts to recast position (from wow).
ToRecast(Vector3) | Converts to recast position (from wow).

See Also

Utility Class
Utility Members
wManager.Wow.Helpers.PathFinderClass Namespace


ToRecast Method (Single[])

Utility..::..ToRecast Method (array<Single>[]()[][])

Converts to recast position (from wow).

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static float[] ToRecast(
    this float[] v
)
<ExtensionAttribute> _
Public Shared Function ToRecast ( _
    v As Single() _
) As Single()
[ExtensionAttribute]
public:
static array<float^>^ ToRecast(
    array<float^>^ v
)

Parameters

v
Type: array< Single >[]()[][]
The v.

Return Value

System.Single[].

See Also

Utility Class
ToRecast Overload
wManager.Wow.Helpers.PathFinderClass Namespace


ToRecast Method (Vector3)

Utility..::..ToRecast Method (Vector3)

Converts to recast position (from wow).

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static Vector3 ToRecast(
    this Vector3 v
)
<ExtensionAttribute> _
Public Shared Function ToRecast ( _
    v As Vector3 _
) As Vector3
[ExtensionAttribute]
public:
static Vector3^ ToRecast(
    Vector3^ v
)

Parameters

v
Type: robotManager.Helpful..::..Vector3
The v.

Return Value

Vector3.

See Also

Utility Class
ToRecast Overload
wManager.Wow.Helpers.PathFinderClass Namespace


ToWoW Method

Utility..::..ToWoW Method

Overload List

Name | Description
ToWoW(array<Single>[]()[][]) | Converts to wow position (from recast).
ToWoW(Vector3) | Converts to wow position (from recast).

See Also

Utility Class
Utility Members
wManager.Wow.Helpers.PathFinderClass Namespace


ToWoW Method (Single[])

Utility..::..ToWoW Method (array<Single>[]()[][])

Converts to wow position (from recast).

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static float[] ToWoW(
    this float[] v
)
<ExtensionAttribute> _
Public Shared Function ToWoW ( _
    v As Single() _
) As Single()
[ExtensionAttribute]
public:
static array<float^>^ ToWoW(
    array<float^>^ v
)

Parameters

v
Type: array< Single >[]()[][]
The v.

Return Value

System.Single[].

See Also

Utility Class
ToWoW Overload
wManager.Wow.Helpers.PathFinderClass Namespace


ToWoW Method (Vector3)

Utility..::..ToWoW Method (Vector3)

Converts to wow position (from recast).

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static Vector3 ToWoW(
    this Vector3 v
)
<ExtensionAttribute> _
Public Shared Function ToWoW ( _
    v As Vector3 _
) As Vector3
[ExtensionAttribute]
public:
static Vector3^ ToWoW(
    Vector3^ v
)

Parameters

v
Type: robotManager.Helpful..::..Vector3
The v.

Return Value

Vector3.

See Also

Utility Class
ToWoW Overload
wManager.Wow.Helpers.PathFinderClass Namespace


ToWowListVector3 Method

Utility..::..ToWowListVector3 Method

Convert from recast to wow list vector3.

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<Vector3> ToWowListVector3(
    this List<float> array
)
<ExtensionAttribute> _
Public Shared Function ToWowListVector3 ( _
    array As List(Of Single) _
) As List(Of Vector3)
[ExtensionAttribute]
public:
static List<Vector3^>^ ToWowListVector3(
    List<float^>^ array
)

Parameters

array
Type: List <(Of <(<' Single >)>)>
The recast position.

Return Value

List<Vector3>.

See Also

Utility Class
wManager.Wow.Helpers.PathFinderClass Namespace


Utility Properties

The Utility type exposes the following members.

Properties

Name | Description
RDSettings | generate the rd settings.
TileSize | Get the size of tile.

See Also

Utility Class
wManager.Wow.Helpers.PathFinderClass Namespace


RDSettings Property

Utility..::..RDSettings Property

generate the rd settings.

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static RDSettings RDSettings { get; }
Public Shared ReadOnly Property RDSettings As RDSettings
    Get
public:
static property RDSettings^ RDSettings {
    RDSettings^ get ();
}

Field Value

The rd settings.

See Also

Utility Class
wManager.Wow.Helpers.PathFinderClass Namespace


TileSize Property

Utility..::..TileSize Property

Get the size of tile.

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static float TileSize { get; }
Public Shared ReadOnly Property TileSize As Single
    Get
public:
static property float^ TileSize {
    float^ get ();
}

Field Value

The size of the tile.

See Also

Utility Class
wManager.Wow.Helpers.PathFinderClass Namespace


Vector3Simple Class

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class Vector3Simple
<SerializableAttribute> _
Public Class Vector3Simple
[SerializableAttribute]
public ref class Vector3Simple

Inheritance Hierarchy

Object
wManager.Wow.Helpers.PathFinderClass..::..Vector3Simple

See Also

Vector3Simple Members
wManager.Wow.Helpers.PathFinderClass Namespace


Vector3Simple Members

The Vector3Simple type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
 | FromListVector3 |
 | FromVector3 |
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IsValid |
Protected method | MemberwiseClone | (Inherited from Object.)
 | ToListVector3 |
Public method | ToString |
Public method | ToVector3 |

Fields

 | Name | Description
Public field | Action |
Public field | X |
Public field | Y |
Public field | Z |

See Also

Vector3Simple Class
wManager.Wow.Helpers.PathFinderClass Namespace


Vector3Simple Fields

The Vector3Simple type exposes the following members.

Fields

 | Name | Description
Public field | Action |
Public field | X |
Public field | Y |
Public field | Z |

See Also

Vector3Simple Class
wManager.Wow.Helpers.PathFinderClass Namespace


Action Field

Vector3Simple..::..Action Field

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[JsonPropertyAttribute]
public string Action
<JsonPropertyAttribute> _
Public Action As String
[JsonPropertyAttribute]
public:
String^ Action

See Also

Vector3Simple Class
wManager.Wow.Helpers.PathFinderClass Namespace


X Field

Vector3Simple..::..X Field

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float X
Public X As Single
public:
float^ X

See Also

Vector3Simple Class
wManager.Wow.Helpers.PathFinderClass Namespace


Y Field

Vector3Simple..::..Y Field

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float Y
Public Y As Single
public:
float^ Y

See Also

Vector3Simple Class
wManager.Wow.Helpers.PathFinderClass Namespace


Z Field

Vector3Simple..::..Z Field

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float Z
Public Z As Single
public:
float^ Z

See Also

Vector3Simple Class
wManager.Wow.Helpers.PathFinderClass Namespace


Vector3Simple Methods

The Vector3Simple type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
 | FromListVector3 |
 | FromVector3 |
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IsValid |
Protected method | MemberwiseClone | (Inherited from Object.)
 | ToListVector3 |
Public method | ToString |
Public method | ToVector3 |

See Also

Vector3Simple Class
wManager.Wow.Helpers.PathFinderClass Namespace


FromListVector3 Method

Vector3Simple..::..FromListVector3 Method

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<Vector3Simple> FromListVector3(
    List<Vector3> v
)
Public Shared Function FromListVector3 ( _
    v As List(Of Vector3) _
) As List(Of Vector3Simple)
public:
static List<Vector3Simple^>^ FromListVector3(
    List<Vector3^>^ v
)

Parameters

v
Type: List <(Of <(<' Vector3 >)>)>

See Also

Vector3Simple Class
wManager.Wow.Helpers.PathFinderClass Namespace


FromVector3 Method

Vector3Simple..::..FromVector3 Method

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static Vector3Simple FromVector3(
    Vector3 v
)
Public Shared Function FromVector3 ( _
    v As Vector3 _
) As Vector3Simple
public:
static Vector3Simple^ FromVector3(
    Vector3^ v
)

Parameters

v
Type: robotManager.Helpful..::..Vector3

See Also

Vector3Simple Class
wManager.Wow.Helpers.PathFinderClass Namespace


IsValid Method

Vector3Simple..::..IsValid Method

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsValid()
Public Function IsValid As Boolean
public:
bool^ IsValid()

See Also

Vector3Simple Class
wManager.Wow.Helpers.PathFinderClass Namespace


ToListVector3 Method

Vector3Simple..::..ToListVector3 Method

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<Vector3> ToListVector3(
    List<Vector3Simple> v
)
Public Shared Function ToListVector3 ( _
    v As List(Of Vector3Simple) _
) As List(Of Vector3)
public:
static List<Vector3^>^ ToListVector3(
    List<Vector3Simple^>^ v
)

Parameters

v
Type: List <(Of <(<' Vector3Simple >)>)>

See Also

Vector3Simple Class
wManager.Wow.Helpers.PathFinderClass Namespace


ToString Method

Vector3Simple..::..ToString Method

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string ToString()
Public Function ToString As String
public:
String^ ToString()

See Also

Vector3Simple Class
wManager.Wow.Helpers.PathFinderClass Namespace


ToVector3 Method

Vector3Simple..::..ToVector3 Method

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Vector3 ToVector3()
Public Function ToVector3 As Vector3
public:
Vector3^ ToVector3()

See Also

Vector3Simple Class
wManager.Wow.Helpers.PathFinderClass Namespace


ZPositionPacket Class

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[SerializableAttribute]
public class ZPositionPacket
<SerializableAttribute> _
Public Class ZPositionPacket
[SerializableAttribute]
public ref class ZPositionPacket

Inheritance Hierarchy

Object
wManager.Wow.Helpers.PathFinderClass..::..ZPositionPacket

See Also

ZPositionPacket Members
wManager.Wow.Helpers.PathFinderClass Namespace


ZPositionPacket Members

The ZPositionPacket type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

Fields

 | Name | Description
Public field | Z |

See Also

ZPositionPacket Class
wManager.Wow.Helpers.PathFinderClass Namespace


ZPositionPacket Fields

The ZPositionPacket type exposes the following members.

Fields

 | Name | Description
Public field | Z |

See Also

ZPositionPacket Class
wManager.Wow.Helpers.PathFinderClass Namespace


Z Field

ZPositionPacket..::..Z Field

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float Z
Public Z As Single
public:
float^ Z

See Also

ZPositionPacket Class
wManager.Wow.Helpers.PathFinderClass Namespace


ZPositionPacket Methods

The ZPositionPacket type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

ZPositionPacket Class
wManager.Wow.Helpers.PathFinderClass Namespace


wManager.Wow.ObjectManager Namespace

Classes

 | Class | Description
Public class | ObjectManager | Class ObjectManager. Get list of in-game objects/units/players.
Public class | Pulsator | Class Pulsator.
Public class | WowCamera | Class WowCamera.
Public class | WoWContainer | Class WoWContainer. Implements the WoWItem
Public class | WoWCorpse | Class WoWCorpse. Implements the WoWObject
Public class | WoWGameObject | Class WoWGameObject. Implements the WoWObject
Public class | WoWItem | Class WoWItem. Implements the WoWObject
Public class | WoWLocalPlayer | Class WoWLocalPlayer. Your Character. Implements the WoWPlayer
Public class | WoWObject | The base object class that all objects in WoW inherit.
Public class | WoWPlayer | Class WoWPlayer. Implements the WoWUnit
Public class | WoWUnit | Class WoWUnit. Implements the WoWObject

Structures

 | Structure | Description
Public structure | WowCamera..::..MatrixMemoryStruct | Struct MatrixMemoryStruct


ObjectManager Class

Class ObjectManager. Get list of in-game objects/units/players.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class ObjectManager
Public NotInheritable Class ObjectManager
public ref class ObjectManager abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.ObjectManager..::..ObjectManager

See Also

ObjectManager Members
wManager.Wow.ObjectManager Namespace


ObjectManager Members

The ObjectManager type exposes the following members.

Methods

Name | Description
GetNearestWoWGameObject(List<(Of <<'(WoWGameObject>)>>), Vector3, Boolean) | Gets the nearest game object.
GetNearestWoWGameObject(List<(Of <<'(WoWGameObject>)>>), Boolean, Boolean) | Gets the nearest game object.
GetNearestWoWPlayer(List<(Of <<'(WoWPlayer>)>>)) | Gets the nearest player.
GetNearestWoWPlayer(List<(Of <<'(WoWPlayer>)>>), Vector3) | Gets the nearest player.
GetNearestWoWUnit(List<(Of <<'(WoWUnit>)>>), Vector3, Boolean) | Gets the nearest unit.
GetNearestWoWUnit(List<(Of <<'(WoWUnit>)>>), Boolean) | Gets the nearest unit.
GetNumberAttackPlayer(List<(Of <<'(WoWUnit>)>>)) | Gets number of units that attack local player.
GetNumberAttackPlayer()()()() | Gets number of units that attack local player.
GetObjectByGuid | Gets the object by GUID.
GetObjectWoW | Gets all objects.
GetObjectWoWContainer | Gets objects container.
GetObjectWoWCorpse | Gets objects corpse.
GetObjectWoWGameObject | Gets objects GameObject.
GetObjectWoWItem |
GetObjectWoWPlayer | Gets objects player.
GetObjectWoWPlayerTargetMe | Gets objects player that target me.
GetObjectWoWUnit | Gets objects unit.
GetUnitAttackPlayer(List<(Of <<'(WoWUnit>)>>)) | Gets the units that attack local player.
GetUnitAttackPlayer()()()() | Gets the units that attack local player.
GetWoWGameObjectByDisplayId(List<(Of <<'(WoWGameObject>)>>), List<(Of <<'(Int32>)>>)) | Gets GameObjects by display id.
GetWoWGameObjectByDisplayId(Int32) | GameObjects by display id.
GetWoWGameObjectByDisplayId(List<(Of <<'(Int32>)>>)) | GameObjects by display id.
GetWoWGameObjectByEntry(List<(Of <<'(WoWGameObject>)>>), List<(Of <<'(Int32>)>>)) | Gets GameObjects by entries.
GetWoWGameObjectByEntry(Int32) | Gets GameObjects by entry.
GetWoWGameObjectByEntry(List<(Of <<'(Int32>)>>)) | Gets GameObjects by entries.
GetWoWGameObjectById(List<(Of <<'(WoWGameObject>)>>), List<(Of <<'(Int32>)>>)) | Gets GameObjects by entries.
GetWoWGameObjectById(List<(Of <<'(Int32>)>>)) | Gets the GameObjects by entries.
GetWoWGameObjectByName(List<(Of <<'(WoWGameObject>)>>), List<(Of <<'(String>)>>)) | Gets GameObjects by names
GetWoWGameObjectByName(List<(Of <<'(WoWGameObject>)>>), String) | Gets GameObjects by name.
GetWoWGameObjectByName(String) | Gets GameObjects by name.
GetWoWGameObjectByName(List<(Of <<'(String>)>>)) | Gets GameObjects by names.
GetWoWGameObjectByyId | Gets the GameObjects by entry.
GetWoWGameObjectForFarm | Gets GameObjects for farm (chests).
GetWoWGameObjectOfType | Gets objects by type.
GetWoWPlayerDead()()()() | Gets players dead.
GetWoWPlayerDead(List<(Of <<'(WoWPlayer>)>>)) | Gets players dead.
GetWoWPlayerLootable()()()() | Gets players lootable.
GetWoWPlayerLootable(List<(Of <<'(WoWPlayer>)>>)) | Gets players lootable.
GetWoWUnitAlliance(List<(Of <<'(WoWPlayer>)>>)) | Gets players alliance.
GetWoWUnitAlliance()()()() | Gets players alliance.
GetWoWUnitAllianceDead(List<(Of <<'(WoWPlayer>)>>)) | Gets players alliance dead.
GetWoWUnitAllianceDead()()()() | Gets players alliance dead.
GetWoWUnitAttackables | Gets units attackables.
GetWoWUnitByEntry(List<(Of <<'(WoWUnit>)>>), List<(Of <<'(Int32>)>>), Boolean) | Gets units by entries.
GetWoWUnitByEntry(List<(Of <<'(WoWUnit>)>>), List<(Of <<'(Int32>)>>)) | Gets units by entries.
GetWoWUnitByEntry(List<(Of <<'(WoWUnit>)>>), Int32) | Gets units by entry.
GetWoWUnitByEntry(Int32) | Gets units by entry.
GetWoWUnitByEntry(Int32, Boolean) | Gets units by entry.
GetWoWUnitByEntry(List<(Of <<'(Int32>)>>)) | Gets units by entries.
GetWoWUnitByFaction(List<(Of <<'(WoWUnit>)>>), List<(Of <<'(UInt32>)>>), Boolean) | Gets units by faction.
GetWoWUnitByFaction(List<(Of <<'(WoWUnit>)>>), UInt32) | Gets units by faction.
GetWoWUnitByFaction(UInt32) | Gets units by faction.
GetWoWUnitByFaction(List<(Of <<'(UInt32>)>>), Boolean) | Gets units by faction.
GetWoWUnitByName(List<(Of <<'(WoWUnit>)>>), List<(Of <<'(String>)>>)) | Gets units by names.
GetWoWUnitByName(List<(Of <<'(WoWUnit>)>>), String) | Gets units by name.
GetWoWUnitByName(String) | Gets units by name.
GetWoWUnitByName(List<(Of <<'(String>)>>)) | Gets units by names.
GetWoWUnitFlightMaster(List<(Of <<'(WoWUnit>)>>)) | Gets units flight master.
GetWoWUnitFlightMaster()()()() | Gets units flight master.
GetWoWUnitHorde(List<(Of <<'(WoWPlayer>)>>)) | Gets players horde.
GetWoWUnitHorde()()()() | Gets players horde.
GetWoWUnitHordeDead(List<(Of <<'(WoWPlayer>)>>)) | Gets players horde dead.
GetWoWUnitHordeDead()()()() | Gets players horde dead.
GetWoWUnitHostile | Gets units hostile.
GetWoWUnitLootable(List<(Of <<'(WoWUnit>)>>)) | Gets units lootable.
GetWoWUnitLootable()()()() | Gets units lootable.
GetWoWUnitRepair(List<(Of <<'(WoWUnit>)>>)) | Gets units repair.
GetWoWUnitRepair()()()() | Gets units repair.
GetWoWUnitSkinnable(List<(Of <<'(WoWUnit>)>>), List<(Of <<'(UInt64>)>>)) | Gets units skinnable.
GetWoWUnitSkinnable(List<(Of <<'(UInt64>)>>)) | Gets units skinnable.
GetWoWUnitSpiritHealer(List<(Of <<'(WoWUnit>)>>)) | Gets units spirit healer.
GetWoWUnitSpiritHealer()()()() | Gets units spirit healer.
GetWoWUnitTrainer(List<(Of <<'(WoWUnit>)>>)) | Gets units trainer.
GetWoWUnitTrainer()()()() | Gets units trainer.
GetWoWUnitVendor(List<(Of <<'(WoWUnit>)>>)) | Gets units vendor.
GetWoWUnitVendor()()()() | Gets units vendor.
GetWoWUnitVendorFood(List<(Of <<'(WoWUnit>)>>)) | Gets units vendor food.
GetWoWUnitVendorFood()()()() | Gets units vendor food.
GetWoWUnitWildPets(List<(Of <<'(WoWUnit>)>>)) | Gets units wild pets.
GetWoWUnitWildPets()()()() | Gets units wild pets.

Fields

Name | Description
BlackListGetUnitAttackPlayerGuidTime | Ignore units present in this list when bot check GetUnitAttackPlayer(List<(Of <<'(WoWUnit>)>>)), can be used like ObjectManager.BlackListGetUnitAttackPlayerGuidTime.Add(unit.Guid, DateTime.Now + TimeSpan.FromMinutes(10));
BlackListObjectManagerGuid | Remove from objects list object present in this list.
Locker | The locker

Properties

Name | Description
CameraActive | Gets camera active.
Me | Gets local character.
ObjectDictionary | Gets or sets the objects dictionary.
ObjectList | Gets the objects list.
ObjectManagerAddress |
Pet | Gets the pet.
Target | Gets the target.

See Also

ObjectManager Class
wManager.Wow.ObjectManager Namespace


ObjectManager Fields

The ObjectManager type exposes the following members.

Fields

Name | Description
BlackListGetUnitAttackPlayerGuidTime | Ignore units present in this list when bot check GetUnitAttackPlayer(List<(Of <<'(WoWUnit>)>>)), can be used like ObjectManager.BlackListGetUnitAttackPlayerGuidTime.Add(unit.Guid, DateTime.Now + TimeSpan.FromMinutes(10));
BlackListObjectManagerGuid | Remove from objects list object present in this list.
Locker | The locker

See Also

ObjectManager Class
wManager.Wow.ObjectManager Namespace


BlackListGetUnitAttackPlayerGuidTime Field

ObjectManager..::..BlackListGetUnitAttackPlayerGuidTime Field

Ignore units present in this list when bot check GetUnitAttackPlayer(List<(Of <<'(WoWUnit>)>>)), can be used like ObjectManager.BlackListGetUnitAttackPlayerGuidTime.Add(unit.Guid, DateTime.Now + TimeSpan.FromMinutes(10));

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static Dictionary<ulong, DateTime> BlackListGetUnitAttackPlayerGuidTime
Public Shared BlackListGetUnitAttackPlayerGuidTime As Dictionary(Of ULong, DateTime)
public:
static Dictionary<unsigned long long^, DateTime^>^ BlackListGetUnitAttackPlayerGuidTime

See Also

ObjectManager Class
wManager.Wow.ObjectManager Namespace


BlackListObjectManagerGuid Field

ObjectManager..::..BlackListObjectManagerGuid Field

Remove from objects list object present in this list.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static HashSet<ulong> BlackListObjectManagerGuid
Public Shared BlackListObjectManagerGuid As HashSet(Of ULong)
public:
static HashSet<unsigned long long^>^ BlackListObjectManagerGuid

See Also

ObjectManager Class
wManager.Wow.ObjectManager Namespace


Locker Field

ObjectManager..::..Locker Field

The locker

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static Object Locker
Public Shared Locker As Object
public:
static Object^ Locker

See Also

ObjectManager Class
wManager.Wow.ObjectManager Namespace


ObjectManager Methods

The ObjectManager type exposes the following members.

Methods

Name | Description
GetNearestWoWGameObject(List<(Of <<'(WoWGameObject>)>>), Vector3, Boolean) | Gets the nearest game object.
GetNearestWoWGameObject(List<(Of <<'(WoWGameObject>)>>), Boolean, Boolean) | Gets the nearest game object.
GetNearestWoWPlayer(List<(Of <<'(WoWPlayer>)>>)) | Gets the nearest player.
GetNearestWoWPlayer(List<(Of <<'(WoWPlayer>)>>), Vector3) | Gets the nearest player.
GetNearestWoWUnit(List<(Of <<'(WoWUnit>)>>), Vector3, Boolean) | Gets the nearest unit.
GetNearestWoWUnit(List<(Of <<'(WoWUnit>)>>), Boolean) | Gets the nearest unit.
GetNumberAttackPlayer(List<(Of <<'(WoWUnit>)>>)) | Gets number of units that attack local player.
GetNumberAttackPlayer()()()() | Gets number of units that attack local player.
GetObjectByGuid | Gets the object by GUID.
GetObjectWoW | Gets all objects.
GetObjectWoWContainer | Gets objects container.
GetObjectWoWCorpse | Gets objects corpse.
GetObjectWoWGameObject | Gets objects GameObject.
GetObjectWoWItem |
GetObjectWoWPlayer | Gets objects player.
GetObjectWoWPlayerTargetMe | Gets objects player that target me.
GetObjectWoWUnit | Gets objects unit.
GetUnitAttackPlayer(List<(Of <<'(WoWUnit>)>>)) | Gets the units that attack local player.
GetUnitAttackPlayer()()()() | Gets the units that attack local player.
GetWoWGameObjectByDisplayId(List<(Of <<'(WoWGameObject>)>>), List<(Of <<'(Int32>)>>)) | Gets GameObjects by display id.
GetWoWGameObjectByDisplayId(Int32) | GameObjects by display id.
GetWoWGameObjectByDisplayId(List<(Of <<'(Int32>)>>)) | GameObjects by display id.
GetWoWGameObjectByEntry(List<(Of <<'(WoWGameObject>)>>), List<(Of <<'(Int32>)>>)) | Gets GameObjects by entries.
GetWoWGameObjectByEntry(Int32) | Gets GameObjects by entry.
GetWoWGameObjectByEntry(List<(Of <<'(Int32>)>>)) | Gets GameObjects by entries.
GetWoWGameObjectById(List<(Of <<'(WoWGameObject>)>>), List<(Of <<'(Int32>)>>)) | Gets GameObjects by entries.
GetWoWGameObjectById(List<(Of <<'(Int32>)>>)) | Gets the GameObjects by entries.
GetWoWGameObjectByName(List<(Of <<'(WoWGameObject>)>>), List<(Of <<'(String>)>>)) | Gets GameObjects by names
GetWoWGameObjectByName(List<(Of <<'(WoWGameObject>)>>), String) | Gets GameObjects by name.
GetWoWGameObjectByName(String) | Gets GameObjects by name.
GetWoWGameObjectByName(List<(Of <<'(String>)>>)) | Gets GameObjects by names.
GetWoWGameObjectByyId | Gets the GameObjects by entry.
GetWoWGameObjectForFarm | Gets GameObjects for farm (chests).
GetWoWGameObjectOfType | Gets objects by type.
GetWoWPlayerDead()()()() | Gets players dead.
GetWoWPlayerDead(List<(Of <<'(WoWPlayer>)>>)) | Gets players dead.
GetWoWPlayerLootable()()()() | Gets players lootable.
GetWoWPlayerLootable(List<(Of <<'(WoWPlayer>)>>)) | Gets players lootable.
GetWoWUnitAlliance(List<(Of <<'(WoWPlayer>)>>)) | Gets players alliance.
GetWoWUnitAlliance()()()() | Gets players alliance.
GetWoWUnitAllianceDead(List<(Of <<'(WoWPlayer>)>>)) | Gets players alliance dead.
GetWoWUnitAllianceDead()()()() | Gets players alliance dead.
GetWoWUnitAttackables | Gets units attackables.
GetWoWUnitByEntry(List<(Of <<'(WoWUnit>)>>), List<(Of <<'(Int32>)>>), Boolean) | Gets units by entries.
GetWoWUnitByEntry(List<(Of <<'(WoWUnit>)>>), List<(Of <<'(Int32>)>>)) | Gets units by entries.
GetWoWUnitByEntry(List<(Of <<'(WoWUnit>)>>), Int32) | Gets units by entry.
GetWoWUnitByEntry(Int32) | Gets units by entry.
GetWoWUnitByEntry(Int32, Boolean) | Gets units by entry.
GetWoWUnitByEntry(List<(Of <<'(Int32>)>>)) | Gets units by entries.
GetWoWUnitByFaction(List<(Of <<'(WoWUnit>)>>), List<(Of <<'(UInt32>)>>), Boolean) | Gets units by faction.
GetWoWUnitByFaction(List<(Of <<'(WoWUnit>)>>), UInt32) | Gets units by faction.
GetWoWUnitByFaction(UInt32) | Gets units by faction.
GetWoWUnitByFaction(List<(Of <<'(UInt32>)>>), Boolean) | Gets units by faction.
GetWoWUnitByName(List<(Of <<'(WoWUnit>)>>), List<(Of <<'(String>)>>)) | Gets units by names.
GetWoWUnitByName(List<(Of <<'(WoWUnit>)>>), String) | Gets units by name.
GetWoWUnitByName(String) | Gets units by name.
GetWoWUnitByName(List<(Of <<'(String>)>>)) | Gets units by names.
GetWoWUnitFlightMaster(List<(Of <<'(WoWUnit>)>>)) | Gets units flight master.
GetWoWUnitFlightMaster()()()() | Gets units flight master.
GetWoWUnitHorde(List<(Of <<'(WoWPlayer>)>>)) | Gets players horde.
GetWoWUnitHorde()()()() | Gets players horde.
GetWoWUnitHordeDead(List<(Of <<'(WoWPlayer>)>>)) | Gets players horde dead.
GetWoWUnitHordeDead()()()() | Gets players horde dead.
GetWoWUnitHostile | Gets units hostile.
GetWoWUnitLootable(List<(Of <<'(WoWUnit>)>>)) | Gets units lootable.
GetWoWUnitLootable()()()() | Gets units lootable.
GetWoWUnitRepair(List<(Of <<'(WoWUnit>)>>)) | Gets units repair.
GetWoWUnitRepair()()()() | Gets units repair.
GetWoWUnitSkinnable(List<(Of <<'(WoWUnit>)>>), List<(Of <<'(UInt64>)>>)) | Gets units skinnable.
GetWoWUnitSkinnable(List<(Of <<'(UInt64>)>>)) | Gets units skinnable.
GetWoWUnitSpiritHealer(List<(Of <<'(WoWUnit>)>>)) | Gets units spirit healer.
GetWoWUnitSpiritHealer()()()() | Gets units spirit healer.
GetWoWUnitTrainer(List<(Of <<'(WoWUnit>)>>)) | Gets units trainer.
GetWoWUnitTrainer()()()() | Gets units trainer.
GetWoWUnitVendor(List<(Of <<'(WoWUnit>)>>)) | Gets units vendor.
GetWoWUnitVendor()()()() | Gets units vendor.
GetWoWUnitVendorFood(List<(Of <<'(WoWUnit>)>>)) | Gets units vendor food.
GetWoWUnitVendorFood()()()() | Gets units vendor food.
GetWoWUnitWildPets(List<(Of <<'(WoWUnit>)>>)) | Gets units wild pets.
GetWoWUnitWildPets()()()() | Gets units wild pets.

See Also

ObjectManager Class
wManager.Wow.ObjectManager Namespace


GetNearestWoWGameObject Method

ObjectManager..::..GetNearestWoWGameObject Method

Overload List

Name | Description
GetNearestWoWGameObject(List<(Of <<'(WoWGameObject>)>>), Vector3, Boolean) | Gets the nearest game object.
GetNearestWoWGameObject(List<(Of <<'(WoWGameObject>)>>), Boolean, Boolean) | Gets the nearest game object.

See Also

ObjectManager Class
ObjectManager Members
wManager.Wow.ObjectManager Namespace


GetNearestWoWGameObject Method (List(WoWGameObject), Vector3, Boolean)

ObjectManager..::..GetNearestWoWGameObject Method (List<(Of <(<'WoWGameObject>)>)>, Vector3, Boolean)

Gets the nearest game object.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static WoWGameObject GetNearestWoWGameObject(
    List<WoWGameObject> listWoWGameObject,
    Vector3 point,
    bool ignoreBlackListed
)
Public Shared Function GetNearestWoWGameObject ( _
    listWoWGameObject As List(Of WoWGameObject), _
    point As Vector3, _
    ignoreBlackListed As Boolean _
) As WoWGameObject
public:
static WoWGameObject^ GetNearestWoWGameObject(
    List<WoWGameObject^>^ listWoWGameObject,
    Vector3^ point,
    bool^ ignoreBlackListed
)

Parameters

listWoWGameObject
Type: List <(Of <(<' WoWGameObject >)>)>
The list game object.
point
Type: robotManager.Helpful..::..Vector3
The point.
ignoreBlackListed
Type: Boolean
if set to true ignore black listed.

Return Value

WoWGameObject.

See Also

ObjectManager Class
GetNearestWoWGameObject Overload
wManager.Wow.ObjectManager Namespace


GetNearestWoWGameObject Method (List(WoWGameObject), Boolean, Boolean)

ObjectManager..::..GetNearestWoWGameObject Method (List<(Of <(<'WoWGameObject>)>)>, Boolean, Boolean)

Gets the nearest game object.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static WoWGameObject GetNearestWoWGameObject(
    List<WoWGameObject> listWoWGameObject,
    bool ignoreBlackListed,
    bool ignoreIfInBlackListZone
)
Public Shared Function GetNearestWoWGameObject ( _
    listWoWGameObject As List(Of WoWGameObject), _
    ignoreBlackListed As Boolean, _
    ignoreIfInBlackListZone As Boolean _
) As WoWGameObject
public:
static WoWGameObject^ GetNearestWoWGameObject(
    List<WoWGameObject^>^ listWoWGameObject,
    bool^ ignoreBlackListed,
    bool^ ignoreIfInBlackListZone
)

Parameters

listWoWGameObject
Type: List <(Of <(<' WoWGameObject >)>)>
The list game object.
ignoreBlackListed
Type: Boolean
if set to true ignore black listed.
ignoreIfInBlackListZone
Type: Boolean
if set to true ignore if in black list zone.

Return Value

WoWGameObject.

See Also

ObjectManager Class
GetNearestWoWGameObject Overload
wManager.Wow.ObjectManager Namespace


GetNearestWoWPlayer Method

ObjectManager..::..GetNearestWoWPlayer Method

Overload List

Name | Description
GetNearestWoWPlayer(List<(Of <<'(WoWPlayer>)>>)) | Gets the nearest player.
GetNearestWoWPlayer(List<(Of <<'(WoWPlayer>)>>), Vector3) | Gets the nearest player.

See Also

ObjectManager Class
ObjectManager Members
wManager.Wow.ObjectManager Namespace


GetNearestWoWPlayer Method (List(WoWPlayer))

ObjectManager..::..GetNearestWoWPlayer Method (List<(Of <(<'WoWPlayer>)>)>)

Gets the nearest player.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static WoWPlayer GetNearestWoWPlayer(
    List<WoWPlayer> listWoWPlayer
)
Public Shared Function GetNearestWoWPlayer ( _
    listWoWPlayer As List(Of WoWPlayer) _
) As WoWPlayer
public:
static WoWPlayer^ GetNearestWoWPlayer(
    List<WoWPlayer^>^ listWoWPlayer
)

Parameters

listWoWPlayer
Type: List <(Of <(<' WoWPlayer >)>)>
The list player.

Return Value

WoWPlayer.

See Also

ObjectManager Class
GetNearestWoWPlayer Overload
wManager.Wow.ObjectManager Namespace


GetNearestWoWPlayer Method (List(WoWPlayer), Vector3)

ObjectManager..::..GetNearestWoWPlayer Method (List<(Of <(<'WoWPlayer>)>)>, Vector3)

Gets the nearest player.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static WoWPlayer GetNearestWoWPlayer(
    List<WoWPlayer> listWoWPlayer,
    Vector3 position
)
Public Shared Function GetNearestWoWPlayer ( _
    listWoWPlayer As List(Of WoWPlayer), _
    position As Vector3 _
) As WoWPlayer
public:
static WoWPlayer^ GetNearestWoWPlayer(
    List<WoWPlayer^>^ listWoWPlayer,
    Vector3^ position
)

Parameters

listWoWPlayer
Type: List <(Of <(<' WoWPlayer >)>)>
The list player.
position
Type: robotManager.Helpful..::..Vector3
The position.

Return Value

WoWPlayer.

See Also

ObjectManager Class
GetNearestWoWPlayer Overload
wManager.Wow.ObjectManager Namespace


GetNearestWoWUnit Method

ObjectManager..::..GetNearestWoWUnit Method

Overload List

Name | Description
GetNearestWoWUnit(List<(Of <<'(WoWUnit>)>>), Vector3, Boolean) | Gets the nearest unit.
GetNearestWoWUnit(List<(Of <<'(WoWUnit>)>>), Boolean) | Gets the nearest unit.

See Also

ObjectManager Class
ObjectManager Members
wManager.Wow.ObjectManager Namespace


GetNearestWoWUnit Method (List(WoWUnit), Vector3, Boolean)

ObjectManager..::..GetNearestWoWUnit Method (List<(Of <(<'WoWUnit>)>)>, Vector3, Boolean)

Gets the nearest unit.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static WoWUnit GetNearestWoWUnit(
    List<WoWUnit> listWoWUnit,
    Vector3 point,
    bool ignoreBlackListed
)
Public Shared Function GetNearestWoWUnit ( _
    listWoWUnit As List(Of WoWUnit), _
    point As Vector3, _
    ignoreBlackListed As Boolean _
) As WoWUnit
public:
static WoWUnit^ GetNearestWoWUnit(
    List<WoWUnit^>^ listWoWUnit,
    Vector3^ point,
    bool^ ignoreBlackListed
)

Parameters

listWoWUnit
Type: List <(Of <(<' WoWUnit >)>)>
The unit list.
point
Type: robotManager.Helpful..::..Vector3
The point.
ignoreBlackListed
Type: Boolean
if set to true ignore black listed.

Return Value

WoWUnit.

See Also

ObjectManager Class
GetNearestWoWUnit Overload
wManager.Wow.ObjectManager Namespace


GetNearestWoWUnit Method (List(WoWUnit), Boolean)

ObjectManager..::..GetNearestWoWUnit Method (List<(Of <(<'WoWUnit>)>)>, Boolean)

Gets the nearest unit.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static WoWUnit GetNearestWoWUnit(
    List<WoWUnit> listWoWUnit,
    bool ignoreBlackListed
)
Public Shared Function GetNearestWoWUnit ( _
    listWoWUnit As List(Of WoWUnit), _
    ignoreBlackListed As Boolean _
) As WoWUnit
public:
static WoWUnit^ GetNearestWoWUnit(
    List<WoWUnit^>^ listWoWUnit,
    bool^ ignoreBlackListed
)

Parameters

listWoWUnit
Type: List <(Of <(<' WoWUnit >)>)>
The list unit.
ignoreBlackListed
Type: Boolean
if set to true ignore black listed.

Return Value

WoWUnit.

See Also

ObjectManager Class
GetNearestWoWUnit Overload
wManager.Wow.ObjectManager Namespace


GetNumberAttackPlayer Method

ObjectManager..::..GetNumberAttackPlayer Method

Overload List

Name | Description
GetNumberAttackPlayer(List<(Of <<'(WoWUnit>)>>)) | Gets number of units that attack local player.
GetNumberAttackPlayer()()()() | Gets number of units that attack local player.

See Also

ObjectManager Class
ObjectManager Members
wManager.Wow.ObjectManager Namespace


GetNumberAttackPlayer Method (List(WoWUnit))

ObjectManager..::..GetNumberAttackPlayer Method (List<(Of <(<'WoWUnit>)>)>)

Gets number of units that attack local player.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int GetNumberAttackPlayer(
    List<WoWUnit> listWoWUnit
)
Public Shared Function GetNumberAttackPlayer ( _
    listWoWUnit As List(Of WoWUnit) _
) As Integer
public:
static int^ GetNumberAttackPlayer(
    List<WoWUnit^>^ listWoWUnit
)

Parameters

listWoWUnit
Type: List <(Of <(<' WoWUnit >)>)>
The list.

Return Value

System.Int32.

See Also

ObjectManager Class
GetNumberAttackPlayer Overload
wManager.Wow.ObjectManager Namespace


GetNumberAttackPlayer Method

ObjectManager..::..GetNumberAttackPlayer Method

Gets number of units that attack local player.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static int GetNumberAttackPlayer()
Public Shared Function GetNumberAttackPlayer As Integer
public:
static int^ GetNumberAttackPlayer()

Return Value

System.Int32.

See Also

ObjectManager Class
GetNumberAttackPlayer Overload
wManager.Wow.ObjectManager Namespace


GetObjectByGuid Method

ObjectManager..::..GetObjectByGuid Method

Gets the object by GUID.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static WoWObject GetObjectByGuid(
    ulong guid
)
Public Shared Function GetObjectByGuid ( _
    guid As ULong _
) As WoWObject
public:
static WoWObject^ GetObjectByGuid(
    unsigned long long^ guid
)

Parameters

guid
Type: UInt64
The GUID.

Return Value

WoWObject.

See Also

ObjectManager Class
wManager.Wow.ObjectManager Namespace


GetObjectWoW Method

ObjectManager..::..GetObjectWoW Method

Gets all objects.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWObject> GetObjectWoW()
Public Shared Function GetObjectWoW As List(Of WoWObject)
public:
static List<WoWObject^>^ GetObjectWoW()

Return Value

List<WoWObject>.

See Also

ObjectManager Class
wManager.Wow.ObjectManager Namespace


GetObjectWoWContainer Method

ObjectManager..::..GetObjectWoWContainer Method

Gets objects container.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWContainer> GetObjectWoWContainer()
Public Shared Function GetObjectWoWContainer As List(Of WoWContainer)
public:
static List<WoWContainer^>^ GetObjectWoWContainer()

Return Value

List<WoWContainer>.

See Also

ObjectManager Class
wManager.Wow.ObjectManager Namespace


GetObjectWoWCorpse Method

ObjectManager..::..GetObjectWoWCorpse Method

Gets objects corpse.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWCorpse> GetObjectWoWCorpse()
Public Shared Function GetObjectWoWCorpse As List(Of WoWCorpse)
public:
static List<WoWCorpse^>^ GetObjectWoWCorpse()

Return Value

List<WoWCorpse>.

See Also

ObjectManager Class
wManager.Wow.ObjectManager Namespace


GetObjectWoWGameObject Method

ObjectManager..::..GetObjectWoWGameObject Method

Gets objects GameObject.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWGameObject> GetObjectWoWGameObject()
Public Shared Function GetObjectWoWGameObject As List(Of WoWGameObject)
public:
static List<WoWGameObject^>^ GetObjectWoWGameObject()

Return Value

List<WoWGameObject>.

See Also

ObjectManager Class
wManager.Wow.ObjectManager Namespace


GetObjectWoWItem Method

ObjectManager..::..GetObjectWoWItem Method

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWItem> GetObjectWoWItem()
Public Shared Function GetObjectWoWItem As List(Of WoWItem)
public:
static List<WoWItem^>^ GetObjectWoWItem()

See Also

ObjectManager Class
wManager.Wow.ObjectManager Namespace


GetObjectWoWPlayer Method

ObjectManager..::..GetObjectWoWPlayer Method

Gets objects player.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWPlayer> GetObjectWoWPlayer()
Public Shared Function GetObjectWoWPlayer As List(Of WoWPlayer)
public:
static List<WoWPlayer^>^ GetObjectWoWPlayer()

Return Value

List<WoWPlayer>.

See Also

ObjectManager Class
wManager.Wow.ObjectManager Namespace


GetObjectWoWPlayerTargetMe Method

ObjectManager..::..GetObjectWoWPlayerTargetMe Method

Gets objects player that target me.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWPlayer> GetObjectWoWPlayerTargetMe()
Public Shared Function GetObjectWoWPlayerTargetMe As List(Of WoWPlayer)
public:
static List<WoWPlayer^>^ GetObjectWoWPlayerTargetMe()

Return Value

List<WoWPlayer>.

See Also

ObjectManager Class
wManager.Wow.ObjectManager Namespace


GetObjectWoWUnit Method

ObjectManager..::..GetObjectWoWUnit Method

Gets objects unit.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWUnit> GetObjectWoWUnit()
Public Shared Function GetObjectWoWUnit As List(Of WoWUnit)
public:
static List<WoWUnit^>^ GetObjectWoWUnit()

Return Value

List<WoWUnit>.

See Also

ObjectManager Class
wManager.Wow.ObjectManager Namespace


GetUnitAttackPlayer Method

ObjectManager..::..GetUnitAttackPlayer Method

Overload List

Name | Description
GetUnitAttackPlayer(List<(Of <<'(WoWUnit>)>>)) | Gets the units that attack local player.
GetUnitAttackPlayer()()()() | Gets the units that attack local player.

See Also

ObjectManager Class
ObjectManager Members
wManager.Wow.ObjectManager Namespace


GetUnitAttackPlayer Method (List(WoWUnit))

ObjectManager..::..GetUnitAttackPlayer Method (List<(Of <(<'WoWUnit>)>)>)

Gets the units that attack local player.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWUnit> GetUnitAttackPlayer(
    List<WoWUnit> listWoWUnit
)
Public Shared Function GetUnitAttackPlayer ( _
    listWoWUnit As List(Of WoWUnit) _
) As List(Of WoWUnit)
public:
static List<WoWUnit^>^ GetUnitAttackPlayer(
    List<WoWUnit^>^ listWoWUnit
)

Parameters

listWoWUnit
Type: List <(Of <(<' WoWUnit >)>)>
The list.

Return Value

List<WoWUnit>.

See Also

ObjectManager Class
GetUnitAttackPlayer Overload
wManager.Wow.ObjectManager Namespace


GetUnitAttackPlayer Method

ObjectManager..::..GetUnitAttackPlayer Method

Gets the units that attack local player.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWUnit> GetUnitAttackPlayer()
Public Shared Function GetUnitAttackPlayer As List(Of WoWUnit)
public:
static List<WoWUnit^>^ GetUnitAttackPlayer()

Return Value

List<WoWUnit>.

See Also

ObjectManager Class
GetUnitAttackPlayer Overload
wManager.Wow.ObjectManager Namespace


GetWoWGameObjectByDisplayId Method

ObjectManager..::..GetWoWGameObjectByDisplayId Method

Overload List

Name | Description
GetWoWGameObjectByDisplayId(List<(Of <<'(WoWGameObject>)>>), List<(Of <<'(Int32>)>>)) | Gets GameObjects by display id.
GetWoWGameObjectByDisplayId(Int32) | GameObjects by display id.
GetWoWGameObjectByDisplayId(List<(Of <<'(Int32>)>>)) | GameObjects by display id.

See Also

ObjectManager Class
ObjectManager Members
wManager.Wow.ObjectManager Namespace


GetWoWGameObjectByDisplayId Method (List(WoWGameObject), List(Int32))

ObjectManager..::..GetWoWGameObjectByDisplayId Method (List<(Of <(<'WoWGameObject>)>)>, List<(Of <(<'Int32>)>)>)

Gets GameObjects by display id.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWGameObject> GetWoWGameObjectByDisplayId(
    List<WoWGameObject> listWoWGameObject,
    List<int> displayId
)
Public Shared Function GetWoWGameObjectByDisplayId ( _
    listWoWGameObject As List(Of WoWGameObject), _
    displayId As List(Of Integer) _
) As List(Of WoWGameObject)
public:
static List<WoWGameObject^>^ GetWoWGameObjectByDisplayId(
    List<WoWGameObject^>^ listWoWGameObject,
    List<int^>^ displayId
)

Parameters

listWoWGameObject
Type: List <(Of <(<' WoWGameObject >)>)>
The list.
displayId
Type: List <(Of <(<' Int32 >)>)>
The display ids.

Return Value

List<WoWGameObject>.

See Also

ObjectManager Class
GetWoWGameObjectByDisplayId Overload
wManager.Wow.ObjectManager Namespace


GetWoWGameObjectByDisplayId Method (Int32)

ObjectManager..::..GetWoWGameObjectByDisplayId Method (Int32)

GameObjects by display id.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWGameObject> GetWoWGameObjectByDisplayId(
    int displayId
)
Public Shared Function GetWoWGameObjectByDisplayId ( _
    displayId As Integer _
) As List(Of WoWGameObject)
public:
static List<WoWGameObject^>^ GetWoWGameObjectByDisplayId(
    int^ displayId
)

Parameters

displayId
Type: Int32
The display id.

Return Value

List<WoWGameObject>.

See Also

ObjectManager Class
GetWoWGameObjectByDisplayId Overload
wManager.Wow.ObjectManager Namespace


GetWoWGameObjectByDisplayId Method (List(Int32))

ObjectManager..::..GetWoWGameObjectByDisplayId Method (List<(Of <(<'Int32>)>)>)

GameObjects by display id.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWGameObject> GetWoWGameObjectByDisplayId(
    List<int> displayId
)
Public Shared Function GetWoWGameObjectByDisplayId ( _
    displayId As List(Of Integer) _
) As List(Of WoWGameObject)
public:
static List<WoWGameObject^>^ GetWoWGameObjectByDisplayId(
    List<int^>^ displayId
)

Parameters

displayId
Type: List <(Of <(<' Int32 >)>)>
The display ids.

Return Value

List<WoWGameObject>.

See Also

ObjectManager Class
GetWoWGameObjectByDisplayId Overload
wManager.Wow.ObjectManager Namespace


GetWoWGameObjectByEntry Method

ObjectManager..::..GetWoWGameObjectByEntry Method

Overload List

Name | Description
GetWoWGameObjectByEntry(List<(Of <<'(WoWGameObject>)>>), List<(Of <<'(Int32>)>>)) | Gets GameObjects by entries.
GetWoWGameObjectByEntry(Int32) | Gets GameObjects by entry.
GetWoWGameObjectByEntry(List<(Of <<'(Int32>)>>)) | Gets GameObjects by entries.

See Also

ObjectManager Class
ObjectManager Members
wManager.Wow.ObjectManager Namespace


GetWoWGameObjectByEntry Method (List(WoWGameObject), List(Int32))

ObjectManager..::..GetWoWGameObjectByEntry Method (List<(Of <(<'WoWGameObject>)>)>, List<(Of <(<'Int32>)>)>)

Gets GameObjects by entries.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWGameObject> GetWoWGameObjectByEntry(
    List<WoWGameObject> listWoWGameObject,
    List<int> entry
)
Public Shared Function GetWoWGameObjectByEntry ( _
    listWoWGameObject As List(Of WoWGameObject), _
    entry As List(Of Integer) _
) As List(Of WoWGameObject)
public:
static List<WoWGameObject^>^ GetWoWGameObjectByEntry(
    List<WoWGameObject^>^ listWoWGameObject,
    List<int^>^ entry
)

Parameters

listWoWGameObject
Type: List <(Of <(<' WoWGameObject >)>)>
The list.
entry
Type: List <(Of <(<' Int32 >)>)>
The entries.

Return Value

List<WoWGameObject>.

See Also

ObjectManager Class
GetWoWGameObjectByEntry Overload
wManager.Wow.ObjectManager Namespace


GetWoWGameObjectByEntry Method (Int32)

ObjectManager..::..GetWoWGameObjectByEntry Method (Int32)

Gets GameObjects by entry.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWGameObject> GetWoWGameObjectByEntry(
    int entry
)
Public Shared Function GetWoWGameObjectByEntry ( _
    entry As Integer _
) As List(Of WoWGameObject)
public:
static List<WoWGameObject^>^ GetWoWGameObjectByEntry(
    int^ entry
)

Parameters

entry
Type: Int32
The entry.

Return Value

List<WoWGameObject>.

See Also

ObjectManager Class
GetWoWGameObjectByEntry Overload
wManager.Wow.ObjectManager Namespace


GetWoWGameObjectByEntry Method (List(Int32))

ObjectManager..::..GetWoWGameObjectByEntry Method (List<(Of <(<'Int32>)>)>)

Gets GameObjects by entries.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWGameObject> GetWoWGameObjectByEntry(
    List<int> entry
)
Public Shared Function GetWoWGameObjectByEntry ( _
    entry As List(Of Integer) _
) As List(Of WoWGameObject)
public:
static List<WoWGameObject^>^ GetWoWGameObjectByEntry(
    List<int^>^ entry
)

Parameters

entry
Type: List <(Of <(<' Int32 >)>)>
The entries.

Return Value

List<WoWGameObject>.

See Also

ObjectManager Class
GetWoWGameObjectByEntry Overload
wManager.Wow.ObjectManager Namespace


GetWoWGameObjectById Method

ObjectManager..::..GetWoWGameObjectById Method

Overload List

Name | Description
GetWoWGameObjectById(List<(Of <<'(WoWGameObject>)>>), List<(Of <<'(Int32>)>>)) | Gets GameObjects by entries.
GetWoWGameObjectById(List<(Of <<'(Int32>)>>)) | Gets the GameObjects by entries.

See Also

ObjectManager Class
ObjectManager Members
wManager.Wow.ObjectManager Namespace


GetWoWGameObjectById Method (List(WoWGameObject), List(Int32))

ObjectManager..::..GetWoWGameObjectById Method (List<(Of <(<'WoWGameObject>)>)>, List<(Of <(<'Int32>)>)>)

Gets GameObjects by entries.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWGameObject> GetWoWGameObjectById(
    List<WoWGameObject> listWoWGameObject,
    List<int> id
)
Public Shared Function GetWoWGameObjectById ( _
    listWoWGameObject As List(Of WoWGameObject), _
    id As List(Of Integer) _
) As List(Of WoWGameObject)
public:
static List<WoWGameObject^>^ GetWoWGameObjectById(
    List<WoWGameObject^>^ listWoWGameObject,
    List<int^>^ id
)

Parameters

listWoWGameObject
Type: List <(Of <(<' WoWGameObject >)>)>
The list.
id
Type: List <(Of <(<' Int32 >)>)>
The entries.

Return Value

List<WoWGameObject>.

See Also

ObjectManager Class
GetWoWGameObjectById Overload
wManager.Wow.ObjectManager Namespace


GetWoWGameObjectById Method (List(Int32))

ObjectManager..::..GetWoWGameObjectById Method (List<(Of <(<'Int32>)>)>)

Gets the GameObjects by entries.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWGameObject> GetWoWGameObjectById(
    List<int> id
)
Public Shared Function GetWoWGameObjectById ( _
    id As List(Of Integer) _
) As List(Of WoWGameObject)
public:
static List<WoWGameObject^>^ GetWoWGameObjectById(
    List<int^>^ id
)

Parameters

id
Type: List <(Of <(<' Int32 >)>)>
The entries.

Return Value

List<WoWGameObject>.

See Also

ObjectManager Class
GetWoWGameObjectById Overload
wManager.Wow.ObjectManager Namespace


GetWoWGameObjectByName Method

ObjectManager..::..GetWoWGameObjectByName Method

Overload List

Name | Description
GetWoWGameObjectByName(List<(Of <<'(WoWGameObject>)>>), List<(Of <<'(String>)>>)) | Gets GameObjects by names
GetWoWGameObjectByName(List<(Of <<'(WoWGameObject>)>>), String) | Gets GameObjects by name.
GetWoWGameObjectByName(String) | Gets GameObjects by name.
GetWoWGameObjectByName(List<(Of <<'(String>)>>)) | Gets GameObjects by names.

See Also

ObjectManager Class
ObjectManager Members
wManager.Wow.ObjectManager Namespace


GetWoWGameObjectByName Method (List(WoWGameObject), List(String))

ObjectManager..::..GetWoWGameObjectByName Method (List<(Of <(<'WoWGameObject>)>)>, List<(Of <(<'String>)>)>)

Gets GameObjects by names

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWGameObject> GetWoWGameObjectByName(
    List<WoWGameObject> listWoWGameObject,
    List<string> names
)
Public Shared Function GetWoWGameObjectByName ( _
    listWoWGameObject As List(Of WoWGameObject), _
    names As List(Of String) _
) As List(Of WoWGameObject)
public:
static List<WoWGameObject^>^ GetWoWGameObjectByName(
    List<WoWGameObject^>^ listWoWGameObject,
    List<String^>^ names
)

Parameters

listWoWGameObject
Type: List <(Of <(<' WoWGameObject >)>)>
The list.
names
Type: List <(Of <(<' String >)>)>
The names.

Return Value

List<WoWGameObject>.

See Also

ObjectManager Class
GetWoWGameObjectByName Overload
wManager.Wow.ObjectManager Namespace


GetWoWGameObjectByName Method (List(WoWGameObject), String)

ObjectManager..::..GetWoWGameObjectByName Method (List<(Of <(<'WoWGameObject>)>)>, String)

Gets GameObjects by name.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWGameObject> GetWoWGameObjectByName(
    List<WoWGameObject> listWoWGameObject,
    string name
)
Public Shared Function GetWoWGameObjectByName ( _
    listWoWGameObject As List(Of WoWGameObject), _
    name As String _
) As List(Of WoWGameObject)
public:
static List<WoWGameObject^>^ GetWoWGameObjectByName(
    List<WoWGameObject^>^ listWoWGameObject,
    String^ name
)

Parameters

listWoWGameObject
Type: List <(Of <(<' WoWGameObject >)>)>
The list.
name
Type: String
The name.

Return Value

List<WoWGameObject>.

See Also

ObjectManager Class
GetWoWGameObjectByName Overload
wManager.Wow.ObjectManager Namespace


GetWoWGameObjectByName Method (String)

ObjectManager..::..GetWoWGameObjectByName Method (String)

Gets GameObjects by name.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWGameObject> GetWoWGameObjectByName(
    string name
)
Public Shared Function GetWoWGameObjectByName ( _
    name As String _
) As List(Of WoWGameObject)
public:
static List<WoWGameObject^>^ GetWoWGameObjectByName(
    String^ name
)

Parameters

name
Type: String
The name.

Return Value

List<WoWGameObject>.

See Also

ObjectManager Class
GetWoWGameObjectByName Overload
wManager.Wow.ObjectManager Namespace


GetWoWGameObjectByName Method (List(String))

ObjectManager..::..GetWoWGameObjectByName Method (List<(Of <(<'String>)>)>)

Gets GameObjects by names.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWGameObject> GetWoWGameObjectByName(
    List<string> names
)
Public Shared Function GetWoWGameObjectByName ( _
    names As List(Of String) _
) As List(Of WoWGameObject)
public:
static List<WoWGameObject^>^ GetWoWGameObjectByName(
    List<String^>^ names
)

Parameters

names
Type: List <(Of <(<' String >)>)>
The names.

Return Value

List<WoWGameObject>.

See Also

ObjectManager Class
GetWoWGameObjectByName Overload
wManager.Wow.ObjectManager Namespace


GetWoWGameObjectByyId Method

ObjectManager..::..GetWoWGameObjectByyId Method

Gets the GameObjects by entry.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWGameObject> GetWoWGameObjectByyId(
    int id
)
Public Shared Function GetWoWGameObjectByyId ( _
    id As Integer _
) As List(Of WoWGameObject)
public:
static List<WoWGameObject^>^ GetWoWGameObjectByyId(
    int^ id
)

Parameters

id
Type: Int32
The entry.

Return Value

List<WoWGameObject>.

See Also

ObjectManager Class
wManager.Wow.ObjectManager Namespace


GetWoWGameObjectForFarm Method

ObjectManager..::..GetWoWGameObjectForFarm Method

Gets GameObjects for farm (chests).

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWGameObject> GetWoWGameObjectForFarm()
Public Shared Function GetWoWGameObjectForFarm As List(Of WoWGameObject)
public:
static List<WoWGameObject^>^ GetWoWGameObjectForFarm()

Return Value

List<WoWGameObject>.

See Also

ObjectManager Class
wManager.Wow.ObjectManager Namespace


GetWoWGameObjectOfType Method

ObjectManager..::..GetWoWGameObjectOfType Method

Gets objects by type.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWGameObject> GetWoWGameObjectOfType(
    WoWGameObjectType reqtype
)
Public Shared Function GetWoWGameObjectOfType ( _
    reqtype As WoWGameObjectType _
) As List(Of WoWGameObject)
public:
static List<WoWGameObject^>^ GetWoWGameObjectOfType(
    WoWGameObjectType^ reqtype
)

Parameters

reqtype
Type: wManager.Wow.Enums..::..WoWGameObjectType
The reqtype.

Return Value

List<WoWGameObject>.

See Also

ObjectManager Class
wManager.Wow.ObjectManager Namespace


GetWoWPlayerDead Method

ObjectManager..::..GetWoWPlayerDead Method

Overload List

Name | Description
GetWoWPlayerDead()()()() | Gets players dead.
GetWoWPlayerDead(List<(Of <<'(WoWPlayer>)>>)) | Gets players dead.

See Also

ObjectManager Class
ObjectManager Members
wManager.Wow.ObjectManager Namespace


GetWoWPlayerDead Method

ObjectManager..::..GetWoWPlayerDead Method

Gets players dead.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWPlayer> GetWoWPlayerDead()
Public Shared Function GetWoWPlayerDead As List(Of WoWPlayer)
public:
static List<WoWPlayer^>^ GetWoWPlayerDead()

Return Value

List<WoWPlayer>.

See Also

ObjectManager Class
GetWoWPlayerDead Overload
wManager.Wow.ObjectManager Namespace


GetWoWPlayerDead Method (List(WoWPlayer))

ObjectManager..::..GetWoWPlayerDead Method (List<(Of <(<'WoWPlayer>)>)>)

Gets players dead.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWPlayer> GetWoWPlayerDead(
    List<WoWPlayer> listWoWPlayer
)
Public Shared Function GetWoWPlayerDead ( _
    listWoWPlayer As List(Of WoWPlayer) _
) As List(Of WoWPlayer)
public:
static List<WoWPlayer^>^ GetWoWPlayerDead(
    List<WoWPlayer^>^ listWoWPlayer
)

Parameters

listWoWPlayer
Type: List <(Of <(<' WoWPlayer >)>)>
The list.

Return Value

List<WoWPlayer>.

See Also

ObjectManager Class
GetWoWPlayerDead Overload
wManager.Wow.ObjectManager Namespace


GetWoWPlayerLootable Method

ObjectManager..::..GetWoWPlayerLootable Method

Overload List

Name | Description
GetWoWPlayerLootable()()()() | Gets players lootable.
GetWoWPlayerLootable(List<(Of <<'(WoWPlayer>)>>)) | Gets players lootable.

See Also

ObjectManager Class
ObjectManager Members
wManager.Wow.ObjectManager Namespace


GetWoWPlayerLootable Method

ObjectManager..::..GetWoWPlayerLootable Method

Gets players lootable.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWPlayer> GetWoWPlayerLootable()
Public Shared Function GetWoWPlayerLootable As List(Of WoWPlayer)
public:
static List<WoWPlayer^>^ GetWoWPlayerLootable()

Return Value

List<WoWPlayer>.

See Also

ObjectManager Class
GetWoWPlayerLootable Overload
wManager.Wow.ObjectManager Namespace


GetWoWPlayerLootable Method (List(WoWPlayer))

ObjectManager..::..GetWoWPlayerLootable Method (List<(Of <(<'WoWPlayer>)>)>)

Gets players lootable.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWPlayer> GetWoWPlayerLootable(
    List<WoWPlayer> listWoWPlayer
)
Public Shared Function GetWoWPlayerLootable ( _
    listWoWPlayer As List(Of WoWPlayer) _
) As List(Of WoWPlayer)
public:
static List<WoWPlayer^>^ GetWoWPlayerLootable(
    List<WoWPlayer^>^ listWoWPlayer
)

Parameters

listWoWPlayer
Type: List <(Of <(<' WoWPlayer >)>)>
The list.

Return Value

List<WoWPlayer>.

See Also

ObjectManager Class
GetWoWPlayerLootable Overload
wManager.Wow.ObjectManager Namespace


GetWoWUnitAlliance Method

ObjectManager..::..GetWoWUnitAlliance Method

Overload List

Name | Description
GetWoWUnitAlliance(List<(Of <<'(WoWPlayer>)>>)) | Gets players alliance.
GetWoWUnitAlliance()()()() | Gets players alliance.

See Also

ObjectManager Class
ObjectManager Members
wManager.Wow.ObjectManager Namespace


GetWoWUnitAlliance Method (List(WoWPlayer))

ObjectManager..::..GetWoWUnitAlliance Method (List<(Of <(<'WoWPlayer>)>)>)

Gets players alliance.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWPlayer> GetWoWUnitAlliance(
    List<WoWPlayer> listWoWUnit
)
Public Shared Function GetWoWUnitAlliance ( _
    listWoWUnit As List(Of WoWPlayer) _
) As List(Of WoWPlayer)
public:
static List<WoWPlayer^>^ GetWoWUnitAlliance(
    List<WoWPlayer^>^ listWoWUnit
)

Parameters

listWoWUnit
Type: List <(Of <(<' WoWPlayer >)>)>
The list unit.

Return Value

List<WoWPlayer>.

See Also

ObjectManager Class
GetWoWUnitAlliance Overload
wManager.Wow.ObjectManager Namespace


GetWoWUnitAlliance Method

ObjectManager..::..GetWoWUnitAlliance Method

Gets players alliance.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWPlayer> GetWoWUnitAlliance()
Public Shared Function GetWoWUnitAlliance As List(Of WoWPlayer)
public:
static List<WoWPlayer^>^ GetWoWUnitAlliance()

Return Value

List<WoWPlayer>.

See Also

ObjectManager Class
GetWoWUnitAlliance Overload
wManager.Wow.ObjectManager Namespace


GetWoWUnitAllianceDead Method

ObjectManager..::..GetWoWUnitAllianceDead Method

Overload List

Name | Description
GetWoWUnitAllianceDead(List<(Of <<'(WoWPlayer>)>>)) | Gets players alliance dead.
GetWoWUnitAllianceDead()()()() | Gets players alliance dead.

See Also

ObjectManager Class
ObjectManager Members
wManager.Wow.ObjectManager Namespace


GetWoWUnitAllianceDead Method (List(WoWPlayer))

ObjectManager..::..GetWoWUnitAllianceDead Method (List<(Of <(<'WoWPlayer>)>)>)

Gets players alliance dead.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWPlayer> GetWoWUnitAllianceDead(
    List<WoWPlayer> listWoWUnit
)
Public Shared Function GetWoWUnitAllianceDead ( _
    listWoWUnit As List(Of WoWPlayer) _
) As List(Of WoWPlayer)
public:
static List<WoWPlayer^>^ GetWoWUnitAllianceDead(
    List<WoWPlayer^>^ listWoWUnit
)

Parameters

listWoWUnit
Type: List <(Of <(<' WoWPlayer >)>)>
The list.

Return Value

List<WoWPlayer>.

See Also

ObjectManager Class
GetWoWUnitAllianceDead Overload
wManager.Wow.ObjectManager Namespace


GetWoWUnitAllianceDead Method

ObjectManager..::..GetWoWUnitAllianceDead Method

Gets players alliance dead.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWPlayer> GetWoWUnitAllianceDead()
Public Shared Function GetWoWUnitAllianceDead As List(Of WoWPlayer)
public:
static List<WoWPlayer^>^ GetWoWUnitAllianceDead()

Return Value

List<WoWPlayer>.

See Also

ObjectManager Class
GetWoWUnitAllianceDead Overload
wManager.Wow.ObjectManager Namespace


GetWoWUnitAttackables Method

ObjectManager..::..GetWoWUnitAttackables Method

Gets units attackables.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWUnit> GetWoWUnitAttackables(
    float range
)
Public Shared Function GetWoWUnitAttackables ( _
    range As Single _
) As List(Of WoWUnit)
public:
static List<WoWUnit^>^ GetWoWUnitAttackables(
    float^ range
)

Parameters

range
Type: Single
The range.

Return Value

List<WoWUnit>.

See Also

ObjectManager Class
wManager.Wow.ObjectManager Namespace


GetWoWUnitByEntry Method

ObjectManager..::..GetWoWUnitByEntry Method

Overload List

Name | Description
GetWoWUnitByEntry(List<(Of <<'(WoWUnit>)>>), List<(Of <<'(Int32>)>>), Boolean) | Gets units by entries.
GetWoWUnitByEntry(List<(Of <<'(WoWUnit>)>>), List<(Of <<'(Int32>)>>)) | Gets units by entries.
GetWoWUnitByEntry(List<(Of <<'(WoWUnit>)>>), Int32) | Gets units by entry.
GetWoWUnitByEntry(Int32) | Gets units by entry.
GetWoWUnitByEntry(Int32, Boolean) | Gets units by entry.
GetWoWUnitByEntry(List<(Of <<'(Int32>)>>)) | Gets units by entries.

See Also

ObjectManager Class
ObjectManager Members
wManager.Wow.ObjectManager Namespace


GetWoWUnitByEntry Method (List(WoWUnit), List(Int32), Boolean)

ObjectManager..::..GetWoWUnitByEntry Method (List<(Of <(<'WoWUnit>)>)>, List<(Of <(<'Int32>)>)>, Boolean)

Gets units by entries.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWUnit> GetWoWUnitByEntry(
    List<WoWUnit> listWoWUnit,
    List<int> entrys,
    bool acceptNpcDead
)
Public Shared Function GetWoWUnitByEntry ( _
    listWoWUnit As List(Of WoWUnit), _
    entrys As List(Of Integer), _
    acceptNpcDead As Boolean _
) As List(Of WoWUnit)
public:
static List<WoWUnit^>^ GetWoWUnitByEntry(
    List<WoWUnit^>^ listWoWUnit,
    List<int^>^ entrys,
    bool^ acceptNpcDead
)

Parameters

listWoWUnit
Type: List <(Of <(<' WoWUnit >)>)>
The list.
entrys
Type: List <(Of <(<' Int32 >)>)>
The entries.
acceptNpcDead
Type: Boolean
if set to true accept dead.

Return Value

List<WoWUnit>.

See Also

ObjectManager Class
GetWoWUnitByEntry Overload
wManager.Wow.ObjectManager Namespace


GetWoWUnitByEntry Method (List(WoWUnit), List(Int32))

ObjectManager..::..GetWoWUnitByEntry Method (List<(Of <(<'WoWUnit>)>)>, List<(Of <(<'Int32>)>)>)

Gets units by entries.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWUnit> GetWoWUnitByEntry(
    List<WoWUnit> listWoWUnit,
    List<int> entrys
)
Public Shared Function GetWoWUnitByEntry ( _
    listWoWUnit As List(Of WoWUnit), _
    entrys As List(Of Integer) _
) As List(Of WoWUnit)
public:
static List<WoWUnit^>^ GetWoWUnitByEntry(
    List<WoWUnit^>^ listWoWUnit,
    List<int^>^ entrys
)

Parameters

listWoWUnit
Type: List <(Of <(<' WoWUnit >)>)>
The list.
entrys
Type: List <(Of <(<' Int32 >)>)>
The entries.

Return Value

List<WoWUnit>.

See Also

ObjectManager Class
GetWoWUnitByEntry Overload
wManager.Wow.ObjectManager Namespace


GetWoWUnitByEntry Method (List(WoWUnit), Int32)

ObjectManager..::..GetWoWUnitByEntry Method (List<(Of <(<'WoWUnit>)>)>, Int32)

Gets units by entry.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWUnit> GetWoWUnitByEntry(
    List<WoWUnit> listWoWUnit,
    int entry
)
Public Shared Function GetWoWUnitByEntry ( _
    listWoWUnit As List(Of WoWUnit), _
    entry As Integer _
) As List(Of WoWUnit)
public:
static List<WoWUnit^>^ GetWoWUnitByEntry(
    List<WoWUnit^>^ listWoWUnit,
    int^ entry
)

Parameters

listWoWUnit
Type: List <(Of <(<' WoWUnit >)>)>
The list.
entry
Type: Int32
The entry.

Return Value

List<WoWUnit>.

See Also

ObjectManager Class
GetWoWUnitByEntry Overload
wManager.Wow.ObjectManager Namespace


GetWoWUnitByEntry Method (Int32)

ObjectManager..::..GetWoWUnitByEntry Method (Int32)

Gets units by entry.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWUnit> GetWoWUnitByEntry(
    int entry
)
Public Shared Function GetWoWUnitByEntry ( _
    entry As Integer _
) As List(Of WoWUnit)
public:
static List<WoWUnit^>^ GetWoWUnitByEntry(
    int^ entry
)

Parameters

entry
Type: Int32
The entry.

Return Value

List<WoWUnit>.

See Also

ObjectManager Class
GetWoWUnitByEntry Overload
wManager.Wow.ObjectManager Namespace


GetWoWUnitByEntry Method (Int32, Boolean)

ObjectManager..::..GetWoWUnitByEntry Method (Int32, Boolean)

Gets units by entry.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWUnit> GetWoWUnitByEntry(
    int entry,
    bool acceptNpcDead
)
Public Shared Function GetWoWUnitByEntry ( _
    entry As Integer, _
    acceptNpcDead As Boolean _
) As List(Of WoWUnit)
public:
static List<WoWUnit^>^ GetWoWUnitByEntry(
    int^ entry,
    bool^ acceptNpcDead
)

Parameters

entry
Type: Int32
The entry.
acceptNpcDead
Type: Boolean
if set to true accept dead.

Return Value

List<WoWUnit>.

See Also

ObjectManager Class
GetWoWUnitByEntry Overload
wManager.Wow.ObjectManager Namespace


GetWoWUnitByEntry Method (List(Int32))

ObjectManager..::..GetWoWUnitByEntry Method (List<(Of <(<'Int32>)>)>)

Gets units by entries.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWUnit> GetWoWUnitByEntry(
    List<int> entrys
)
Public Shared Function GetWoWUnitByEntry ( _
    entrys As List(Of Integer) _
) As List(Of WoWUnit)
public:
static List<WoWUnit^>^ GetWoWUnitByEntry(
    List<int^>^ entrys
)

Parameters

entrys
Type: List <(Of <(<' Int32 >)>)>
The entries.

Return Value

List<WoWUnit>.

See Also

ObjectManager Class
GetWoWUnitByEntry Overload
wManager.Wow.ObjectManager Namespace


GetWoWUnitByFaction Method

ObjectManager..::..GetWoWUnitByFaction Method

Overload List

Name | Description
GetWoWUnitByFaction(List<(Of <<'(WoWUnit>)>>), List<(Of <<'(UInt32>)>>), Boolean) | Gets units by faction.
GetWoWUnitByFaction(List<(Of <<'(WoWUnit>)>>), UInt32) | Gets units by faction.
GetWoWUnitByFaction(UInt32) | Gets units by faction.
GetWoWUnitByFaction(List<(Of <<'(UInt32>)>>), Boolean) | Gets units by faction.

See Also

ObjectManager Class
ObjectManager Members
wManager.Wow.ObjectManager Namespace


GetWoWUnitByFaction Method (List(WoWUnit), List(UInt32), Boolean)

ObjectManager..::..GetWoWUnitByFaction Method (List<(Of <(<'WoWUnit>)>)>, List<(Of <(<'UInt32>)>)>, Boolean)

Gets units by faction.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWUnit> GetWoWUnitByFaction(
    List<WoWUnit> listWoWUnit,
    List<uint> factions,
    bool pvp
)
Public Shared Function GetWoWUnitByFaction ( _
    listWoWUnit As List(Of WoWUnit), _
    factions As List(Of UInteger), _
    pvp As Boolean _
) As List(Of WoWUnit)
public:
static List<WoWUnit^>^ GetWoWUnitByFaction(
    List<WoWUnit^>^ listWoWUnit,
    List<unsigned int^>^ factions,
    bool^ pvp
)

Parameters

listWoWUnit
Type: List <(Of <(<' WoWUnit >)>)>
The list.
factions
Type: List <(Of <(<' UInt32 >)>)>
The factions.
pvp
Type: Boolean
if set to true [PVP].

Return Value

List<WoWUnit>.

See Also

ObjectManager Class
GetWoWUnitByFaction Overload
wManager.Wow.ObjectManager Namespace


GetWoWUnitByFaction Method (List(WoWUnit), UInt32)

ObjectManager..::..GetWoWUnitByFaction Method (List<(Of <(<'WoWUnit>)>)>, UInt32)

Gets units by faction.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWUnit> GetWoWUnitByFaction(
    List<WoWUnit> listWoWUnit,
    uint faction
)
Public Shared Function GetWoWUnitByFaction ( _
    listWoWUnit As List(Of WoWUnit), _
    faction As UInteger _
) As List(Of WoWUnit)
public:
static List<WoWUnit^>^ GetWoWUnitByFaction(
    List<WoWUnit^>^ listWoWUnit,
    unsigned int^ faction
)

Parameters

listWoWUnit
Type: List <(Of <(<' WoWUnit >)>)>
The list.
faction
Type: UInt32
The faction.

Return Value

List<WoWUnit>.

See Also

ObjectManager Class
GetWoWUnitByFaction Overload
wManager.Wow.ObjectManager Namespace


GetWoWUnitByFaction Method (UInt32)

ObjectManager..::..GetWoWUnitByFaction Method (UInt32)

Gets units by faction.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWUnit> GetWoWUnitByFaction(
    uint faction
)
Public Shared Function GetWoWUnitByFaction ( _
    faction As UInteger _
) As List(Of WoWUnit)
public:
static List<WoWUnit^>^ GetWoWUnitByFaction(
    unsigned int^ faction
)

Parameters

faction
Type: UInt32
The faction.

Return Value

List<WoWUnit>.

See Also

ObjectManager Class
GetWoWUnitByFaction Overload
wManager.Wow.ObjectManager Namespace


GetWoWUnitByFaction Method (List(UInt32), Boolean)

ObjectManager..::..GetWoWUnitByFaction Method (List<(Of <(<'UInt32>)>)>, Boolean)

Gets units by faction.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWUnit> GetWoWUnitByFaction(
    List<uint> factions,
    bool pvp
)
Public Shared Function GetWoWUnitByFaction ( _
    factions As List(Of UInteger), _
    pvp As Boolean _
) As List(Of WoWUnit)
public:
static List<WoWUnit^>^ GetWoWUnitByFaction(
    List<unsigned int^>^ factions,
    bool^ pvp
)

Parameters

factions
Type: List <(Of <(<' UInt32 >)>)>
The factions.
pvp
Type: Boolean
if set to true [PVP].

Return Value

List<WoWUnit>.

See Also

ObjectManager Class
GetWoWUnitByFaction Overload
wManager.Wow.ObjectManager Namespace


GetWoWUnitByName Method

ObjectManager..::..GetWoWUnitByName Method

Overload List

Name | Description
GetWoWUnitByName(List<(Of <<'(WoWUnit>)>>), List<(Of <<'(String>)>>)) | Gets units by names.
GetWoWUnitByName(List<(Of <<'(WoWUnit>)>>), String) | Gets units by name.
GetWoWUnitByName(String) | Gets units by name.
GetWoWUnitByName(List<(Of <<'(String>)>>)) | Gets units by names.

See Also

ObjectManager Class
ObjectManager Members
wManager.Wow.ObjectManager Namespace


GetWoWUnitByName Method (List(WoWUnit), List(String))

ObjectManager..::..GetWoWUnitByName Method (List<(Of <(<'WoWUnit>)>)>, List<(Of <(<'String>)>)>)

Gets units by names.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWUnit> GetWoWUnitByName(
    List<WoWUnit> listWoWUnit,
    List<string> names
)
Public Shared Function GetWoWUnitByName ( _
    listWoWUnit As List(Of WoWUnit), _
    names As List(Of String) _
) As List(Of WoWUnit)
public:
static List<WoWUnit^>^ GetWoWUnitByName(
    List<WoWUnit^>^ listWoWUnit,
    List<String^>^ names
)

Parameters

listWoWUnit
Type: List <(Of <(<' WoWUnit >)>)>
The list.
names
Type: List <(Of <(<' String >)>)>
The names.

Return Value

List<WoWUnit>.

See Also

ObjectManager Class
GetWoWUnitByName Overload
wManager.Wow.ObjectManager Namespace


GetWoWUnitByName Method (List(WoWUnit), String)

ObjectManager..::..GetWoWUnitByName Method (List<(Of <(<'WoWUnit>)>)>, String)

Gets units by name.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWUnit> GetWoWUnitByName(
    List<WoWUnit> listWoWUnit,
    string name
)
Public Shared Function GetWoWUnitByName ( _
    listWoWUnit As List(Of WoWUnit), _
    name As String _
) As List(Of WoWUnit)
public:
static List<WoWUnit^>^ GetWoWUnitByName(
    List<WoWUnit^>^ listWoWUnit,
    String^ name
)

Parameters

listWoWUnit
Type: List <(Of <(<' WoWUnit >)>)>
The list.
name
Type: String
The name.

Return Value

List<WoWUnit>.

See Also

ObjectManager Class
GetWoWUnitByName Overload
wManager.Wow.ObjectManager Namespace


GetWoWUnitByName Method (String)

ObjectManager..::..GetWoWUnitByName Method (String)

Gets units by name.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWUnit> GetWoWUnitByName(
    string name
)
Public Shared Function GetWoWUnitByName ( _
    name As String _
) As List(Of WoWUnit)
public:
static List<WoWUnit^>^ GetWoWUnitByName(
    String^ name
)

Parameters

name
Type: String
The name.

Return Value

List<WoWUnit>.

See Also

ObjectManager Class
GetWoWUnitByName Overload
wManager.Wow.ObjectManager Namespace


GetWoWUnitByName Method (List(String))

ObjectManager..::..GetWoWUnitByName Method (List<(Of <(<'String>)>)>)

Gets units by names.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWUnit> GetWoWUnitByName(
    List<string> names
)
Public Shared Function GetWoWUnitByName ( _
    names As List(Of String) _
) As List(Of WoWUnit)
public:
static List<WoWUnit^>^ GetWoWUnitByName(
    List<String^>^ names
)

Parameters

names
Type: List <(Of <(<' String >)>)>
The names.

Return Value

List<WoWUnit>.

See Also

ObjectManager Class
GetWoWUnitByName Overload
wManager.Wow.ObjectManager Namespace


GetWoWUnitFlightMaster Method

ObjectManager..::..GetWoWUnitFlightMaster Method

Overload List

Name | Description
GetWoWUnitFlightMaster(List<(Of <<'(WoWUnit>)>>)) | Gets units flight master.
GetWoWUnitFlightMaster()()()() | Gets units flight master.

See Also

ObjectManager Class
ObjectManager Members
wManager.Wow.ObjectManager Namespace


GetWoWUnitFlightMaster Method (List(WoWUnit))

ObjectManager..::..GetWoWUnitFlightMaster Method (List<(Of <(<'WoWUnit>)>)>)

Gets units flight master.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWUnit> GetWoWUnitFlightMaster(
    List<WoWUnit> listWoWUnit
)
Public Shared Function GetWoWUnitFlightMaster ( _
    listWoWUnit As List(Of WoWUnit) _
) As List(Of WoWUnit)
public:
static List<WoWUnit^>^ GetWoWUnitFlightMaster(
    List<WoWUnit^>^ listWoWUnit
)

Parameters

listWoWUnit
Type: List <(Of <(<' WoWUnit >)>)>
The list unit.

Return Value

List<WoWUnit>.

See Also

ObjectManager Class
GetWoWUnitFlightMaster Overload
wManager.Wow.ObjectManager Namespace


GetWoWUnitFlightMaster Method

ObjectManager..::..GetWoWUnitFlightMaster Method

Gets units flight master.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWUnit> GetWoWUnitFlightMaster()
Public Shared Function GetWoWUnitFlightMaster As List(Of WoWUnit)
public:
static List<WoWUnit^>^ GetWoWUnitFlightMaster()

Return Value

List<WoWUnit>.

See Also

ObjectManager Class
GetWoWUnitFlightMaster Overload
wManager.Wow.ObjectManager Namespace


GetWoWUnitHorde Method

ObjectManager..::..GetWoWUnitHorde Method

Overload List

Name | Description
GetWoWUnitHorde(List<(Of <<'(WoWPlayer>)>>)) | Gets players horde.
GetWoWUnitHorde()()()() | Gets players horde.

See Also

ObjectManager Class
ObjectManager Members
wManager.Wow.ObjectManager Namespace


GetWoWUnitHorde Method (List(WoWPlayer))

ObjectManager..::..GetWoWUnitHorde Method (List<(Of <(<'WoWPlayer>)>)>)

Gets players horde.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWPlayer> GetWoWUnitHorde(
    List<WoWPlayer> listWoWUnit
)
Public Shared Function GetWoWUnitHorde ( _
    listWoWUnit As List(Of WoWPlayer) _
) As List(Of WoWPlayer)
public:
static List<WoWPlayer^>^ GetWoWUnitHorde(
    List<WoWPlayer^>^ listWoWUnit
)

Parameters

listWoWUnit
Type: List <(Of <(<' WoWPlayer >)>)>
The list.

Return Value

List<WoWPlayer>.

See Also

ObjectManager Class
GetWoWUnitHorde Overload
wManager.Wow.ObjectManager Namespace


GetWoWUnitHorde Method

ObjectManager..::..GetWoWUnitHorde Method

Gets players horde.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWPlayer> GetWoWUnitHorde()
Public Shared Function GetWoWUnitHorde As List(Of WoWPlayer)
public:
static List<WoWPlayer^>^ GetWoWUnitHorde()

Return Value

List<WoWPlayer>.

See Also

ObjectManager Class
GetWoWUnitHorde Overload
wManager.Wow.ObjectManager Namespace


GetWoWUnitHordeDead Method

ObjectManager..::..GetWoWUnitHordeDead Method

Overload List

Name | Description
GetWoWUnitHordeDead(List<(Of <<'(WoWPlayer>)>>)) | Gets players horde dead.
GetWoWUnitHordeDead()()()() | Gets players horde dead.

See Also

ObjectManager Class
ObjectManager Members
wManager.Wow.ObjectManager Namespace


GetWoWUnitHordeDead Method (List(WoWPlayer))

ObjectManager..::..GetWoWUnitHordeDead Method (List<(Of <(<'WoWPlayer>)>)>)

Gets players horde dead.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWPlayer> GetWoWUnitHordeDead(
    List<WoWPlayer> listWoWUnit
)
Public Shared Function GetWoWUnitHordeDead ( _
    listWoWUnit As List(Of WoWPlayer) _
) As List(Of WoWPlayer)
public:
static List<WoWPlayer^>^ GetWoWUnitHordeDead(
    List<WoWPlayer^>^ listWoWUnit
)

Parameters

listWoWUnit
Type: List <(Of <(<' WoWPlayer >)>)>
The list.

Return Value

List<WoWPlayer>.

See Also

ObjectManager Class
GetWoWUnitHordeDead Overload
wManager.Wow.ObjectManager Namespace


GetWoWUnitHordeDead Method

ObjectManager..::..GetWoWUnitHordeDead Method

Gets players horde dead.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWPlayer> GetWoWUnitHordeDead()
Public Shared Function GetWoWUnitHordeDead As List(Of WoWPlayer)
public:
static List<WoWPlayer^>^ GetWoWUnitHordeDead()

Return Value

List<WoWPlayer>.

See Also

ObjectManager Class
GetWoWUnitHordeDead Overload
wManager.Wow.ObjectManager Namespace


GetWoWUnitHostile Method

ObjectManager..::..GetWoWUnitHostile Method

Gets units hostile.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWUnit> GetWoWUnitHostile()
Public Shared Function GetWoWUnitHostile As List(Of WoWUnit)
public:
static List<WoWUnit^>^ GetWoWUnitHostile()

Return Value

List<WoWUnit>.

See Also

ObjectManager Class
wManager.Wow.ObjectManager Namespace


GetWoWUnitLootable Method

ObjectManager..::..GetWoWUnitLootable Method

Overload List

Name | Description
GetWoWUnitLootable(List<(Of <<'(WoWUnit>)>>)) | Gets units lootable.
GetWoWUnitLootable()()()() | Gets units lootable.

See Also

ObjectManager Class
ObjectManager Members
wManager.Wow.ObjectManager Namespace


GetWoWUnitLootable Method (List(WoWUnit))

ObjectManager..::..GetWoWUnitLootable Method (List<(Of <(<'WoWUnit>)>)>)

Gets units lootable.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWUnit> GetWoWUnitLootable(
    List<WoWUnit> listWoWUnit
)
Public Shared Function GetWoWUnitLootable ( _
    listWoWUnit As List(Of WoWUnit) _
) As List(Of WoWUnit)
public:
static List<WoWUnit^>^ GetWoWUnitLootable(
    List<WoWUnit^>^ listWoWUnit
)

Parameters

listWoWUnit
Type: List <(Of <(<' WoWUnit >)>)>
The list.

Return Value

List<WoWUnit>.

See Also

ObjectManager Class
GetWoWUnitLootable Overload
wManager.Wow.ObjectManager Namespace


GetWoWUnitLootable Method

ObjectManager..::..GetWoWUnitLootable Method

Gets units lootable.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWUnit> GetWoWUnitLootable()
Public Shared Function GetWoWUnitLootable As List(Of WoWUnit)
public:
static List<WoWUnit^>^ GetWoWUnitLootable()

Return Value

List<WoWUnit>.

See Also

ObjectManager Class
GetWoWUnitLootable Overload
wManager.Wow.ObjectManager Namespace


GetWoWUnitRepair Method

ObjectManager..::..GetWoWUnitRepair Method

Overload List

Name | Description
GetWoWUnitRepair(List<(Of <<'(WoWUnit>)>>)) | Gets units repair.
GetWoWUnitRepair()()()() | Gets units repair.

See Also

ObjectManager Class
ObjectManager Members
wManager.Wow.ObjectManager Namespace


GetWoWUnitRepair Method (List(WoWUnit))

ObjectManager..::..GetWoWUnitRepair Method (List<(Of <(<'WoWUnit>)>)>)

Gets units repair.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWUnit> GetWoWUnitRepair(
    List<WoWUnit> listWoWUnit
)
Public Shared Function GetWoWUnitRepair ( _
    listWoWUnit As List(Of WoWUnit) _
) As List(Of WoWUnit)
public:
static List<WoWUnit^>^ GetWoWUnitRepair(
    List<WoWUnit^>^ listWoWUnit
)

Parameters

listWoWUnit
Type: List <(Of <(<' WoWUnit >)>)>
The list.

Return Value

List<WoWUnit>.

See Also

ObjectManager Class
GetWoWUnitRepair Overload
wManager.Wow.ObjectManager Namespace


GetWoWUnitRepair Method

ObjectManager..::..GetWoWUnitRepair Method

Gets units repair.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWUnit> GetWoWUnitRepair()
Public Shared Function GetWoWUnitRepair As List(Of WoWUnit)
public:
static List<WoWUnit^>^ GetWoWUnitRepair()

Return Value

List<WoWUnit>.

See Also

ObjectManager Class
GetWoWUnitRepair Overload
wManager.Wow.ObjectManager Namespace


GetWoWUnitSkinnable Method

ObjectManager..::..GetWoWUnitSkinnable Method

Overload List

Name | Description
GetWoWUnitSkinnable(List<(Of <<'(WoWUnit>)>>), List<(Of <<'(UInt64>)>>)) | Gets units skinnable.
GetWoWUnitSkinnable(List<(Of <<'(UInt64>)>>)) | Gets units skinnable.

See Also

ObjectManager Class
ObjectManager Members
wManager.Wow.ObjectManager Namespace


GetWoWUnitSkinnable Method (List(WoWUnit), List(UInt64))

ObjectManager..::..GetWoWUnitSkinnable Method (List<(Of <(<'WoWUnit>)>)>, List<(Of <(<'UInt64>)>)>)

Gets units skinnable.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWUnit> GetWoWUnitSkinnable(
    List<WoWUnit> listWoWUnit,
    List<ulong> withoutGuid
)
Public Shared Function GetWoWUnitSkinnable ( _
    listWoWUnit As List(Of WoWUnit), _
    withoutGuid As List(Of ULong) _
) As List(Of WoWUnit)
public:
static List<WoWUnit^>^ GetWoWUnitSkinnable(
    List<WoWUnit^>^ listWoWUnit,
    List<unsigned long long^>^ withoutGuid
)

Parameters

listWoWUnit
Type: List <(Of <(<' WoWUnit >)>)>
The list.
withoutGuid
Type: List <(Of <(<' UInt64 >)>)>
ignore GUID.

Return Value

List<WoWUnit>.

See Also

ObjectManager Class
GetWoWUnitSkinnable Overload
wManager.Wow.ObjectManager Namespace


GetWoWUnitSkinnable Method (List(UInt64))

ObjectManager..::..GetWoWUnitSkinnable Method (List<(Of <(<'UInt64>)>)>)

Gets units skinnable.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWUnit> GetWoWUnitSkinnable(
    List<ulong> withoutGuid
)
Public Shared Function GetWoWUnitSkinnable ( _
    withoutGuid As List(Of ULong) _
) As List(Of WoWUnit)
public:
static List<WoWUnit^>^ GetWoWUnitSkinnable(
    List<unsigned long long^>^ withoutGuid
)

Parameters

withoutGuid
Type: List <(Of <(<' UInt64 >)>)>
ignore GUID.

Return Value

List<WoWUnit>.

See Also

ObjectManager Class
GetWoWUnitSkinnable Overload
wManager.Wow.ObjectManager Namespace


GetWoWUnitSpiritHealer Method

ObjectManager..::..GetWoWUnitSpiritHealer Method

Overload List

Name | Description
GetWoWUnitSpiritHealer(List<(Of <<'(WoWUnit>)>>)) | Gets units spirit healer.
GetWoWUnitSpiritHealer()()()() | Gets units spirit healer.

See Also

ObjectManager Class
ObjectManager Members
wManager.Wow.ObjectManager Namespace


GetWoWUnitSpiritHealer Method (List(WoWUnit))

ObjectManager..::..GetWoWUnitSpiritHealer Method (List<(Of <(<'WoWUnit>)>)>)

Gets units spirit healer.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWUnit> GetWoWUnitSpiritHealer(
    List<WoWUnit> listWoWUnit
)
Public Shared Function GetWoWUnitSpiritHealer ( _
    listWoWUnit As List(Of WoWUnit) _
) As List(Of WoWUnit)
public:
static List<WoWUnit^>^ GetWoWUnitSpiritHealer(
    List<WoWUnit^>^ listWoWUnit
)

Parameters

listWoWUnit
Type: List <(Of <(<' WoWUnit >)>)>
The list.

Return Value

List<WoWUnit>.

See Also

ObjectManager Class
GetWoWUnitSpiritHealer Overload
wManager.Wow.ObjectManager Namespace


GetWoWUnitSpiritHealer Method

ObjectManager..::..GetWoWUnitSpiritHealer Method

Gets units spirit healer.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWUnit> GetWoWUnitSpiritHealer()
Public Shared Function GetWoWUnitSpiritHealer As List(Of WoWUnit)
public:
static List<WoWUnit^>^ GetWoWUnitSpiritHealer()

Return Value

List<WoWUnit>.

See Also

ObjectManager Class
GetWoWUnitSpiritHealer Overload
wManager.Wow.ObjectManager Namespace


GetWoWUnitTrainer Method

ObjectManager..::..GetWoWUnitTrainer Method

Overload List

Name | Description
GetWoWUnitTrainer(List<(Of <<'(WoWUnit>)>>)) | Gets units trainer.
GetWoWUnitTrainer()()()() | Gets units trainer.

See Also

ObjectManager Class
ObjectManager Members
wManager.Wow.ObjectManager Namespace


GetWoWUnitTrainer Method (List(WoWUnit))

ObjectManager..::..GetWoWUnitTrainer Method (List<(Of <(<'WoWUnit>)>)>)

Gets units trainer.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWUnit> GetWoWUnitTrainer(
    List<WoWUnit> listWoWUnit
)
Public Shared Function GetWoWUnitTrainer ( _
    listWoWUnit As List(Of WoWUnit) _
) As List(Of WoWUnit)
public:
static List<WoWUnit^>^ GetWoWUnitTrainer(
    List<WoWUnit^>^ listWoWUnit
)

Parameters

listWoWUnit
Type: List <(Of <(<' WoWUnit >)>)>
The list.

Return Value

List<WoWUnit>.

See Also

ObjectManager Class
GetWoWUnitTrainer Overload
wManager.Wow.ObjectManager Namespace


GetWoWUnitTrainer Method

ObjectManager..::..GetWoWUnitTrainer Method

Gets units trainer.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWUnit> GetWoWUnitTrainer()
Public Shared Function GetWoWUnitTrainer As List(Of WoWUnit)
public:
static List<WoWUnit^>^ GetWoWUnitTrainer()

Return Value

List<WoWUnit>.

See Also

ObjectManager Class
GetWoWUnitTrainer Overload
wManager.Wow.ObjectManager Namespace


GetWoWUnitVendor Method

ObjectManager..::..GetWoWUnitVendor Method

Overload List

Name | Description
GetWoWUnitVendor(List<(Of <<'(WoWUnit>)>>)) | Gets units vendor.
GetWoWUnitVendor()()()() | Gets units vendor.

See Also

ObjectManager Class
ObjectManager Members
wManager.Wow.ObjectManager Namespace


GetWoWUnitVendor Method (List(WoWUnit))

ObjectManager..::..GetWoWUnitVendor Method (List<(Of <(<'WoWUnit>)>)>)

Gets units vendor.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWUnit> GetWoWUnitVendor(
    List<WoWUnit> listWoWUnit
)
Public Shared Function GetWoWUnitVendor ( _
    listWoWUnit As List(Of WoWUnit) _
) As List(Of WoWUnit)
public:
static List<WoWUnit^>^ GetWoWUnitVendor(
    List<WoWUnit^>^ listWoWUnit
)

Parameters

listWoWUnit
Type: List <(Of <(<' WoWUnit >)>)>
The list.

Return Value

List<WoWUnit>.

See Also

ObjectManager Class
GetWoWUnitVendor Overload
wManager.Wow.ObjectManager Namespace


GetWoWUnitVendor Method

ObjectManager..::..GetWoWUnitVendor Method

Gets units vendor.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWUnit> GetWoWUnitVendor()
Public Shared Function GetWoWUnitVendor As List(Of WoWUnit)
public:
static List<WoWUnit^>^ GetWoWUnitVendor()

Return Value

List<WoWUnit>.

See Also

ObjectManager Class
GetWoWUnitVendor Overload
wManager.Wow.ObjectManager Namespace


GetWoWUnitVendorFood Method

ObjectManager..::..GetWoWUnitVendorFood Method

Overload List

Name | Description
GetWoWUnitVendorFood(List<(Of <<'(WoWUnit>)>>)) | Gets units vendor food.
GetWoWUnitVendorFood()()()() | Gets units vendor food.

See Also

ObjectManager Class
ObjectManager Members
wManager.Wow.ObjectManager Namespace


GetWoWUnitVendorFood Method (List(WoWUnit))

ObjectManager..::..GetWoWUnitVendorFood Method (List<(Of <(<'WoWUnit>)>)>)

Gets units vendor food.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWUnit> GetWoWUnitVendorFood(
    List<WoWUnit> listWoWUnit
)
Public Shared Function GetWoWUnitVendorFood ( _
    listWoWUnit As List(Of WoWUnit) _
) As List(Of WoWUnit)
public:
static List<WoWUnit^>^ GetWoWUnitVendorFood(
    List<WoWUnit^>^ listWoWUnit
)

Parameters

listWoWUnit
Type: List <(Of <(<' WoWUnit >)>)>
The list.

Return Value

List<WoWUnit>.

See Also

ObjectManager Class
GetWoWUnitVendorFood Overload
wManager.Wow.ObjectManager Namespace


GetWoWUnitVendorFood Method

ObjectManager..::..GetWoWUnitVendorFood Method

Gets units vendor food.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWUnit> GetWoWUnitVendorFood()
Public Shared Function GetWoWUnitVendorFood As List(Of WoWUnit)
public:
static List<WoWUnit^>^ GetWoWUnitVendorFood()

Return Value

List<WoWUnit>.

See Also

ObjectManager Class
GetWoWUnitVendorFood Overload
wManager.Wow.ObjectManager Namespace


GetWoWUnitWildPets Method

ObjectManager..::..GetWoWUnitWildPets Method

Overload List

Name | Description
GetWoWUnitWildPets(List<(Of <<'(WoWUnit>)>>)) | Gets units wild pets.
GetWoWUnitWildPets()()()() | Gets units wild pets.

See Also

ObjectManager Class
ObjectManager Members
wManager.Wow.ObjectManager Namespace


GetWoWUnitWildPets Method (List(WoWUnit))

ObjectManager..::..GetWoWUnitWildPets Method (List<(Of <(<'WoWUnit>)>)>)

Gets units wild pets.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWUnit> GetWoWUnitWildPets(
    List<WoWUnit> listWoWUnit
)
Public Shared Function GetWoWUnitWildPets ( _
    listWoWUnit As List(Of WoWUnit) _
) As List(Of WoWUnit)
public:
static List<WoWUnit^>^ GetWoWUnitWildPets(
    List<WoWUnit^>^ listWoWUnit
)

Parameters

listWoWUnit
Type: List <(Of <(<' WoWUnit >)>)>
The list.

Return Value

List<WoWUnit>.

See Also

ObjectManager Class
GetWoWUnitWildPets Overload
wManager.Wow.ObjectManager Namespace


GetWoWUnitWildPets Method

ObjectManager..::..GetWoWUnitWildPets Method

Gets units wild pets.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWUnit> GetWoWUnitWildPets()
Public Shared Function GetWoWUnitWildPets As List(Of WoWUnit)
public:
static List<WoWUnit^>^ GetWoWUnitWildPets()

Return Value

List<WoWUnit>.

See Also

ObjectManager Class
GetWoWUnitWildPets Overload
wManager.Wow.ObjectManager Namespace


ObjectManager Properties

The ObjectManager type exposes the following members.

Properties

Name | Description
CameraActive | Gets camera active.
Me | Gets local character.
ObjectDictionary | Gets or sets the objects dictionary.
ObjectList | Gets the objects list.
ObjectManagerAddress |
Pet | Gets the pet.
Target | Gets the target.

See Also

ObjectManager Class
wManager.Wow.ObjectManager Namespace


CameraActive Property

ObjectManager..::..CameraActive Property

Gets camera active.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static WowCamera CameraActive { get; }
Public Shared ReadOnly Property CameraActive As WowCamera
    Get
public:
static property WowCamera^ CameraActive {
    WowCamera^ get ();
}

Field Value

The camera active.

See Also

ObjectManager Class
wManager.Wow.ObjectManager Namespace


Me Property

ObjectManager..::..Me Property

Gets local character.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static WoWLocalPlayer Me { get; set; }
Public Shared Property Me As WoWLocalPlayer
    Get
    Set
public:
static property WoWLocalPlayer^ Me {
    WoWLocalPlayer^ get ();
    void set (WoWLocalPlayer^ value);
}

Field Value

local character.

See Also

ObjectManager Class
wManager.Wow.ObjectManager Namespace


ObjectDictionary Property

ObjectManager..::..ObjectDictionary Property

Gets or sets the objects dictionary.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static Dictionary<ulong, WoWObject> ObjectDictionary { get; set; }
Public Shared Property ObjectDictionary As Dictionary(Of ULong, WoWObject)
    Get
    Set
public:
static property Dictionary<unsigned long long^, WoWObject^>^ ObjectDictionary {
    Dictionary<unsigned long long^, WoWObject^>^ get ();
    void set (Dictionary<unsigned long long^, WoWObject^>^ value);
}

Field Value

The objects dictionary.

See Also

ObjectManager Class
wManager.Wow.ObjectManager Namespace


ObjectList Property

ObjectManager..::..ObjectList Property

Gets the objects list.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static List<WoWObject> ObjectList { get; set; }
Public Shared Property ObjectList As List(Of WoWObject)
    Get
    Set
public:
static property List<WoWObject^>^ ObjectList {
    List<WoWObject^>^ get ();
    void set (List<WoWObject^>^ value);
}

Field Value

The objects list.

See Also

ObjectManager Class
wManager.Wow.ObjectManager Namespace


ObjectManagerAddress Property

ObjectManager..::..ObjectManagerAddress Property

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static uint ObjectManagerAddress { get; }
Public Shared ReadOnly Property ObjectManagerAddress As UInteger
    Get
public:
static property unsigned int^ ObjectManagerAddress {
    unsigned int^ get ();
}

See Also

ObjectManager Class
wManager.Wow.ObjectManager Namespace


Pet Property

ObjectManager..::..Pet Property

Gets the pet.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static WoWUnit Pet { get; }
Public Shared ReadOnly Property Pet As WoWUnit
    Get
public:
static property WoWUnit^ Pet {
    WoWUnit^ get ();
}

Field Value

The pet.

See Also

ObjectManager Class
wManager.Wow.ObjectManager Namespace


Target Property

ObjectManager..::..Target Property

Gets the target.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static WoWUnit Target { get; }
Public Shared ReadOnly Property Target As WoWUnit
    Get
public:
static property WoWUnit^ Target {
    WoWUnit^ get ();
}

Field Value

The target.

See Also

ObjectManager Class
wManager.Wow.ObjectManager Namespace


Pulsator Class

Class Pulsator.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static class Pulsator
Public NotInheritable Class Pulsator
public ref class Pulsator abstract sealed

Inheritance Hierarchy

Object
wManager.Wow.ObjectManager..::..Pulsator

See Also

Pulsator Members
wManager.Wow.ObjectManager Namespace


Pulsator Members

The Pulsator type exposes the following members.

Methods

Name | Description
Initialize | Initializes the pulsator with the specified process ID, optionally creating a thread that runs at roughly 30FPS to pulse the object manager.
Pulse | Pulses the object manager. This should be called from an EndScene hook, or some other form of 'OnFrame' type function. (This class has a built in thread handler to deal with said OnFrame function)
Shutdown | Shuts down the pulsator, and closes the opened process handle.

Properties

Name | Description
IsActive | ObjectManager Active.

See Also

Pulsator Class
wManager.Wow.ObjectManager Namespace


Pulsator Methods

The Pulsator type exposes the following members.

Methods

Name | Description
Initialize | Initializes the pulsator with the specified process ID, optionally creating a thread that runs at roughly 30FPS to pulse the object manager.
Pulse | Pulses the object manager. This should be called from an EndScene hook, or some other form of 'OnFrame' type function. (This class has a built in thread handler to deal with said OnFrame function)
Shutdown | Shuts down the pulsator, and closes the opened process handle.

See Also

Pulsator Class
wManager.Wow.ObjectManager Namespace


Initialize Method

Pulsator..::..Initialize Method

Initializes the pulsator with the specified process ID, optionally creating a thread that runs at roughly 30FPS to pulse the object manager.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void Initialize(
    bool useThread
)
Public Shared Sub Initialize ( _
    useThread As Boolean _
)
public:
static void Initialize(
    bool^ useThread
)

Parameters

useThread
Type: Boolean
if set to true [use thread].

See Also

Pulsator Class
wManager.Wow.ObjectManager Namespace


Pulse Method

Pulsator..::..Pulse Method

Pulses the object manager. This should be called from an EndScene hook, or some other form of 'OnFrame' type function. (This class has a built in thread handler to deal with said OnFrame function)

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void Pulse()
Public Shared Sub Pulse
public:
static void Pulse()

See Also

Pulsator Class
wManager.Wow.ObjectManager Namespace


Shutdown Method

Pulsator..::..Shutdown Method

Shuts down the pulsator, and closes the opened process handle.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static void Shutdown()
Public Shared Sub Shutdown
public:
static void Shutdown()

See Also

Pulsator Class
wManager.Wow.ObjectManager Namespace


Pulsator Properties

The Pulsator type exposes the following members.

Properties

Name | Description
IsActive | ObjectManager Active.

See Also

Pulsator Class
wManager.Wow.ObjectManager Namespace


IsActive Property

Pulsator..::..IsActive Property

ObjectManager Active.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool IsActive { get; }
Public Shared ReadOnly Property IsActive As Boolean
    Get
public:
static property bool^ IsActive {
    bool^ get ();
}

Field Value

true if this instance is active; otherwise, false.

See Also

Pulsator Class
wManager.Wow.ObjectManager Namespace


WowCamera Class

Class WowCamera.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class WowCamera
Public Class WowCamera
public ref class WowCamera

Inheritance Hierarchy

Object
wManager.Wow.ObjectManager..::..WowCamera

See Also

WowCamera Members
wManager.Wow.ObjectManager Namespace


WowCamera Members

The WowCamera type exposes the following members.

Constructors

 | Name | Description
Public method | WowCamera | Initializes a new instance of the WowCamera class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | ViewMatrix | Views the matrix.

Fields

 | Name | Description
Public field | CameraBaseAddress | The camera base address

Properties

 | Name | Description
Public property | CameraMatrix | Gets the camera matrix.
Public property | Forward | Gets the forward.
Public property | Fov | Gets the fov.
Public property | Position | Gets the position.
Public property | ProjectionMatrix | Gets the projection matrix.

See Also

WowCamera Class
wManager.Wow.ObjectManager Namespace


WowCamera Constructor

Initializes a new instance of the WowCamera class.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public WowCamera(
    uint baseAddress
)
Public Sub New ( _
    baseAddress As UInteger _
)
public:
WowCamera(
    unsigned int^ baseAddress
)

Parameters

baseAddress
Type: UInt32
The base address.

See Also

WowCamera Class
wManager.Wow.ObjectManager Namespace


WowCamera Fields

The WowCamera type exposes the following members.

Fields

 | Name | Description
Public field | CameraBaseAddress | The camera base address

See Also

WowCamera Class
wManager.Wow.ObjectManager Namespace


CameraBaseAddress Field

WowCamera..::..CameraBaseAddress Field

The camera base address

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint CameraBaseAddress
Public CameraBaseAddress As UInteger
public:
unsigned int^ CameraBaseAddress

See Also

WowCamera Class
wManager.Wow.ObjectManager Namespace


WowCamera Methods

The WowCamera type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | ViewMatrix | Views the matrix.

See Also

WowCamera Class
wManager.Wow.ObjectManager Namespace


ViewMatrix Method

WowCamera..::..ViewMatrix Method

Views the matrix.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Matrix ViewMatrix()
Public Function ViewMatrix As Matrix
public:
Matrix^ ViewMatrix()

Return Value

Matrix.

See Also

WowCamera Class
wManager.Wow.ObjectManager Namespace


WowCamera Properties

The WowCamera type exposes the following members.

Properties

 | Name | Description
Public property | CameraMatrix | Gets the camera matrix.
Public property | Forward | Gets the forward.
Public property | Fov | Gets the fov.
Public property | Position | Gets the position.
Public property | ProjectionMatrix | Gets the projection matrix.

See Also

WowCamera Class
wManager.Wow.ObjectManager Namespace


CameraMatrix Property

WowCamera..::..CameraMatrix Property

Gets the camera matrix.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Matrix CameraMatrix { get; }
Public ReadOnly Property CameraMatrix As Matrix
    Get
public:
property Matrix^ CameraMatrix {
    Matrix^ get ();
}

Field Value

The camera matrix.

See Also

WowCamera Class
wManager.Wow.ObjectManager Namespace


Forward Property

WowCamera..::..Forward Property

Gets the forward.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Vector3 Forward { get; }
Public ReadOnly Property Forward As Vector3
    Get
public:
property Vector3^ Forward {
    Vector3^ get ();
}

Field Value

The forward.

See Also

WowCamera Class
wManager.Wow.ObjectManager Namespace


Fov Property

WowCamera..::..Fov Property

Gets the fov.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float Fov { get; }
Public ReadOnly Property Fov As Single
    Get
public:
property float^ Fov {
    float^ get ();
}

Field Value

The fov.

See Also

WowCamera Class
wManager.Wow.ObjectManager Namespace


Position Property

WowCamera..::..Position Property

Gets the position.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Vector3 Position { get; }
Public ReadOnly Property Position As Vector3
    Get
public:
property Vector3^ Position {
    Vector3^ get ();
}

Field Value

The position.

See Also

WowCamera Class
wManager.Wow.ObjectManager Namespace


ProjectionMatrix Property

WowCamera..::..ProjectionMatrix Property

Gets the projection matrix.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Matrix ProjectionMatrix { get; }
Public ReadOnly Property ProjectionMatrix As Matrix
    Get
public:
property Matrix^ ProjectionMatrix {
    Matrix^ get ();
}

Field Value

The projection matrix.

See Also

WowCamera Class
wManager.Wow.ObjectManager Namespace


WowCamera.MatrixMemoryStruct Structure

WowCamera..::..MatrixMemoryStruct Structure

Struct MatrixMemoryStruct

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[StructLayoutAttribute]
public struct MatrixMemoryStruct
<StructLayoutAttribute> _
Public Structure MatrixMemoryStruct
[StructLayoutAttribute]
public value class MatrixMemoryStruct

See Also

WowCamera..::..MatrixMemoryStruct Members
wManager.Wow.ObjectManager Namespace


WowCamera.MatrixMemoryStruct Members

WowCamera..::..MatrixMemoryStruct Members

The WowCamera..::..MatrixMemoryStruct type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from ValueType.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from ValueType.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from ValueType.)

Fields

 | Name | Description
Public field | M11 | The M11
Public field | M12 | The M12
Public field | M13 | The M13
Public field | M21 | The M21
Public field | M22 | The M22
Public field | M23 | The M23
Public field | M31 | The M31
Public field | M32 | The M32
Public field | M33 | The M33

See Also

WowCamera..::..MatrixMemoryStruct Structure
wManager.Wow.ObjectManager Namespace


WowCamera.MatrixMemoryStruct Fields

WowCamera..::..MatrixMemoryStruct Fields

The WowCamera..::..MatrixMemoryStruct type exposes the following members.

Fields

 | Name | Description
Public field | M11 | The M11
Public field | M12 | The M12
Public field | M13 | The M13
Public field | M21 | The M21
Public field | M22 | The M22
Public field | M23 | The M23
Public field | M31 | The M31
Public field | M32 | The M32
Public field | M33 | The M33

See Also

WowCamera..::..MatrixMemoryStruct Structure
wManager.Wow.ObjectManager Namespace


M11 Field

MatrixMemoryStruct..::..M11 Field

The M11

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float M11
Public M11 As Single
public:
float^ M11

See Also

WowCamera..::..MatrixMemoryStruct Structure
wManager.Wow.ObjectManager Namespace


M12 Field

MatrixMemoryStruct..::..M12 Field

The M12

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float M12
Public M12 As Single
public:
float^ M12

See Also

WowCamera..::..MatrixMemoryStruct Structure
wManager.Wow.ObjectManager Namespace


M13 Field

MatrixMemoryStruct..::..M13 Field

The M13

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float M13
Public M13 As Single
public:
float^ M13

See Also

WowCamera..::..MatrixMemoryStruct Structure
wManager.Wow.ObjectManager Namespace


M21 Field

MatrixMemoryStruct..::..M21 Field

The M21

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float M21
Public M21 As Single
public:
float^ M21

See Also

WowCamera..::..MatrixMemoryStruct Structure
wManager.Wow.ObjectManager Namespace


M22 Field

MatrixMemoryStruct..::..M22 Field

The M22

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float M22
Public M22 As Single
public:
float^ M22

See Also

WowCamera..::..MatrixMemoryStruct Structure
wManager.Wow.ObjectManager Namespace


M23 Field

MatrixMemoryStruct..::..M23 Field

The M23

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float M23
Public M23 As Single
public:
float^ M23

See Also

WowCamera..::..MatrixMemoryStruct Structure
wManager.Wow.ObjectManager Namespace


M31 Field

MatrixMemoryStruct..::..M31 Field

The M31

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float M31
Public M31 As Single
public:
float^ M31

See Also

WowCamera..::..MatrixMemoryStruct Structure
wManager.Wow.ObjectManager Namespace


M32 Field

MatrixMemoryStruct..::..M32 Field

The M32

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float M32
Public M32 As Single
public:
float^ M32

See Also

WowCamera..::..MatrixMemoryStruct Structure
wManager.Wow.ObjectManager Namespace


M33 Field

MatrixMemoryStruct..::..M33 Field

The M33

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float M33
Public M33 As Single
public:
float^ M33

See Also

WowCamera..::..MatrixMemoryStruct Structure
wManager.Wow.ObjectManager Namespace


WowCamera.MatrixMemoryStruct Methods

WowCamera..::..MatrixMemoryStruct Methods

The WowCamera..::..MatrixMemoryStruct type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from ValueType.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from ValueType.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from ValueType.)

See Also

WowCamera..::..MatrixMemoryStruct Structure
wManager.Wow.ObjectManager Namespace


WoWContainer Class

Class WoWContainer. Implements the WoWItem

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class WoWContainer : WoWItem
Public Class WoWContainer _
    Inherits WoWItem
public ref class WoWContainer : public WoWItem

Inheritance Hierarchy

Object
wManager.Wow.ObjectManager..::..WoWObject
wManager.Wow.ObjectManager..::..WoWItem
wManager.Wow.ObjectManager..::..WoWContainer

See Also

WoWContainer Members
wManager.Wow.ObjectManager Namespace
wManager.Wow.ObjectManager..::..WoWItem


WoWContainer Members

The WoWContainer type exposes the following members.

Constructors

 | Name | Description
Public method | WoWContainer | Initializes a new instance of the WoWContainer class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDescriptorAddress(Descriptors..::..ContainerFields) |
Public method | GetDescriptorAddress(Descriptors..::..ItemFields) | (Inherited from WoWItem.)
Public method | GetDescriptorAddress(Descriptors..::..ObjectFields) | Gets the descriptor address. (Inherited from WoWObject.)
Public method | GetDescriptorAddress(UInt32) | Gets the descriptor address. (Inherited from WoWObject.)
Public method | GetDescriptorAddress(UInt32, UInt32) | Gets the descriptor address. (Inherited from WoWObject.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetSlot | Gets the slot.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Inherited from WoWObject.)

Properties

 | Name | Description
Protected property | BaseAddress | (Inherited from WoWObject.)
Protected property | BaseDescriptorAddressCACHE | (Inherited from WoWObject.)
Public property | ContainedIn | Gets the contained in. (Inherited from WoWItem.)
Public property | Durability | Gets durability. (Inherited from WoWItem.)
Public property | Entry | (Inherited from WoWObject.)
Public property | GetBaseAddress | Gets the base address. (Inherited from WoWObject.)
Public property | GetDescriptorStartAddress | Gets the descriptor start address. (Inherited from WoWObject.)
Public property | GetDistance | Gets the distance (from local character). (Inherited from WoWObject.)
Public property | GetItemInfo | Gets the item information. (Inherited from WoWItem.)
Public property | Guid | Gets the GUID. (Inherited from WoWObject.)
Public property | InBag | (Inherited from WoWItem.)
Public property | IsEquippableItem | Gets a value indicating whether is equippable item. (Inherited from WoWItem.)
Public property | IsValid | Returns true if is valid. (Inherited from WoWObject.)
Public property | MaxDurability | Gets maximum durability. (Inherited from WoWItem.)
Public property | Name | Gets the name. (Inherited from WoWItem.)
Public property | NumberSlot | Gets the number of slot.
Public property | Owner | Gets the owner. (Inherited from WoWItem.)
Public property | Position | Gets the position. (Inherited from WoWObject.)
Public property | Scale | Gets the scale. (Inherited from WoWObject.)
Public property | StackCount | Gets stack count. (Inherited from WoWItem.)
Public property | Type | Gets the type. (Inherited from WoWObject.)

See Also

WoWContainer Class
wManager.Wow.ObjectManager Namespace


WoWContainer Constructor

Initializes a new instance of the WoWContainer class.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public WoWContainer(
    uint address
)
Public Sub New ( _
    address As UInteger _
)
public:
WoWContainer(
    unsigned int^ address
)

Parameters

address
Type: UInt32
The address.

See Also

WoWContainer Class
wManager.Wow.ObjectManager Namespace


WoWContainer Methods

The WoWContainer type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDescriptorAddress(Descriptors..::..ContainerFields) |
Public method | GetDescriptorAddress(Descriptors..::..ItemFields) | (Inherited from WoWItem.)
Public method | GetDescriptorAddress(Descriptors..::..ObjectFields) | Gets the descriptor address. (Inherited from WoWObject.)
Public method | GetDescriptorAddress(UInt32) | Gets the descriptor address. (Inherited from WoWObject.)
Public method | GetDescriptorAddress(UInt32, UInt32) | Gets the descriptor address. (Inherited from WoWObject.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetSlot | Gets the slot.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Inherited from WoWObject.)

See Also

WoWContainer Class
wManager.Wow.ObjectManager Namespace


GetDescriptorAddress Method

WoWContainer..::..GetDescriptorAddress Method

Overload List

 | Name | Description
Public method | GetDescriptorAddress(Descriptors..::..ContainerFields) |
Public method | GetDescriptorAddress(Descriptors..::..ItemFields) | (Inherited from WoWItem.)
Public method | GetDescriptorAddress(Descriptors..::..ObjectFields) | Gets the descriptor address. (Inherited from WoWObject.)
Public method | GetDescriptorAddress(UInt32) | Gets the descriptor address. (Inherited from WoWObject.)
Public method | GetDescriptorAddress(UInt32, UInt32) | Gets the descriptor address. (Inherited from WoWObject.)

See Also

WoWContainer Class
WoWContainer Members
wManager.Wow.ObjectManager Namespace


GetDescriptorAddress Method

WoWContainer..::..GetDescriptorAddress Method

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint GetDescriptorAddress(
    Descriptors..::..ContainerFields field
)
Public Function GetDescriptorAddress ( _
    field As Descriptors..::..ContainerFields _
) As UInteger
public:
unsigned int^ GetDescriptorAddress(
    Descriptors..::..ContainerFields^ field
)

Parameters

field
Type: wManager.Wow.Patchables..::..Descriptors..::..ContainerFields

See Also

WoWContainer Class
wManager.Wow.ObjectManager Namespace


GetSlot Method

WoWContainer..::..GetSlot Method

Gets the slot.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int GetSlot(
    int slot
)
Public Function GetSlot ( _
    slot As Integer _
) As Integer
public:
int^ GetSlot(
    int^ slot
)

Parameters

slot
Type: Int32
The slot.

Return Value

System.Int32.

See Also

WoWContainer Class
wManager.Wow.ObjectManager Namespace


WoWContainer Properties

The WoWContainer type exposes the following members.

Properties

 | Name | Description
Protected property | BaseAddress | (Inherited from WoWObject.)
Protected property | BaseDescriptorAddressCACHE | (Inherited from WoWObject.)
Public property | ContainedIn | Gets the contained in. (Inherited from WoWItem.)
Public property | Durability | Gets durability. (Inherited from WoWItem.)
Public property | Entry | (Inherited from WoWObject.)
Public property | GetBaseAddress | Gets the base address. (Inherited from WoWObject.)
Public property | GetDescriptorStartAddress | Gets the descriptor start address. (Inherited from WoWObject.)
Public property | GetDistance | Gets the distance (from local character). (Inherited from WoWObject.)
Public property | GetItemInfo | Gets the item information. (Inherited from WoWItem.)
Public property | Guid | Gets the GUID. (Inherited from WoWObject.)
Public property | InBag | (Inherited from WoWItem.)
Public property | IsEquippableItem | Gets a value indicating whether is equippable item. (Inherited from WoWItem.)
Public property | IsValid | Returns true if is valid. (Inherited from WoWObject.)
Public property | MaxDurability | Gets maximum durability. (Inherited from WoWItem.)
Public property | Name | Gets the name. (Inherited from WoWItem.)
Public property | NumberSlot | Gets the number of slot.
Public property | Owner | Gets the owner. (Inherited from WoWItem.)
Public property | Position | Gets the position. (Inherited from WoWObject.)
Public property | Scale | Gets the scale. (Inherited from WoWObject.)
Public property | StackCount | Gets stack count. (Inherited from WoWItem.)
Public property | Type | Gets the type. (Inherited from WoWObject.)

See Also

WoWContainer Class
wManager.Wow.ObjectManager Namespace


NumberSlot Property

WoWContainer..::..NumberSlot Property

Gets the number of slot.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int NumberSlot { get; }
Public ReadOnly Property NumberSlot As Integer
    Get
public:
property int^ NumberSlot {
    int^ get ();
}

Field Value

The number of slot.

See Also

WoWContainer Class
wManager.Wow.ObjectManager Namespace


WoWCorpse Class

Class WoWCorpse. Implements the WoWObject

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class WoWCorpse : WoWObject
Public Class WoWCorpse _
    Inherits WoWObject
public ref class WoWCorpse : public WoWObject

Inheritance Hierarchy

Object
wManager.Wow.ObjectManager..::..WoWObject
wManager.Wow.ObjectManager..::..WoWCorpse

See Also

WoWCorpse Members
wManager.Wow.ObjectManager Namespace
wManager.Wow.ObjectManager..::..WoWObject


WoWCorpse Members

The WoWCorpse type exposes the following members.

Constructors

 | Name | Description
Public method | WoWCorpse | Initializes a new instance of the WoWCorpse class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDescriptorAddress(Descriptors..::..CorpseFields) |
Public method | GetDescriptorAddress(Descriptors..::..ObjectFields) | Gets the descriptor address. (Inherited from WoWObject.)
Public method | GetDescriptorAddress(UInt32) | Gets the descriptor address. (Inherited from WoWObject.)
Public method | GetDescriptorAddress(UInt32, UInt32) | Gets the descriptor address. (Inherited from WoWObject.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Inherited from WoWObject.)

Properties

 | Name | Description
Protected property | BaseAddress | (Inherited from WoWObject.)
Protected property | BaseDescriptorAddressCACHE | (Inherited from WoWObject.)
Public property | Entry | (Inherited from WoWObject.)
Public property | GetBaseAddress | Gets the base address. (Inherited from WoWObject.)
Public property | GetDescriptorStartAddress | Gets the descriptor start address. (Inherited from WoWObject.)
Public property | GetDistance | Gets the distance (from local character). (Inherited from WoWObject.)
Public property | Guid | Gets the GUID. (Inherited from WoWObject.)
Public property | IsValid | Returns true if is valid. (Inherited from WoWObject.)
Public property | Name | Gets the name. (Inherited from WoWObject.)
Public property | Position | Gets the position. (Inherited from WoWObject.)
Public property | Scale | Gets the scale. (Inherited from WoWObject.)
Public property | Type | Gets the type. (Inherited from WoWObject.)

See Also

WoWCorpse Class
wManager.Wow.ObjectManager Namespace


WoWCorpse Constructor

Initializes a new instance of the WoWCorpse class.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public WoWCorpse(
    uint address
)
Public Sub New ( _
    address As UInteger _
)
public:
WoWCorpse(
    unsigned int^ address
)

Parameters

address
Type: UInt32
The address.

See Also

WoWCorpse Class
wManager.Wow.ObjectManager Namespace


WoWCorpse Methods

The WoWCorpse type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDescriptorAddress(Descriptors..::..CorpseFields) |
Public method | GetDescriptorAddress(Descriptors..::..ObjectFields) | Gets the descriptor address. (Inherited from WoWObject.)
Public method | GetDescriptorAddress(UInt32) | Gets the descriptor address. (Inherited from WoWObject.)
Public method | GetDescriptorAddress(UInt32, UInt32) | Gets the descriptor address. (Inherited from WoWObject.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Inherited from WoWObject.)

See Also

WoWCorpse Class
wManager.Wow.ObjectManager Namespace


GetDescriptorAddress Method

WoWCorpse..::..GetDescriptorAddress Method

Overload List

 | Name | Description
Public method | GetDescriptorAddress(Descriptors..::..CorpseFields) |
Public method | GetDescriptorAddress(Descriptors..::..ObjectFields) | Gets the descriptor address. (Inherited from WoWObject.)
Public method | GetDescriptorAddress(UInt32) | Gets the descriptor address. (Inherited from WoWObject.)
Public method | GetDescriptorAddress(UInt32, UInt32) | Gets the descriptor address. (Inherited from WoWObject.)

See Also

WoWCorpse Class
WoWCorpse Members
wManager.Wow.ObjectManager Namespace


GetDescriptorAddress Method

WoWCorpse..::..GetDescriptorAddress Method

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint GetDescriptorAddress(
    Descriptors..::..CorpseFields field
)
Public Function GetDescriptorAddress ( _
    field As Descriptors..::..CorpseFields _
) As UInteger
public:
unsigned int^ GetDescriptorAddress(
    Descriptors..::..CorpseFields^ field
)

Parameters

field
Type: wManager.Wow.Patchables..::..Descriptors..::..CorpseFields

See Also

WoWCorpse Class
wManager.Wow.ObjectManager Namespace


WoWCorpse Properties

The WoWCorpse type exposes the following members.

Properties

 | Name | Description
Protected property | BaseAddress | (Inherited from WoWObject.)
Protected property | BaseDescriptorAddressCACHE | (Inherited from WoWObject.)
Public property | Entry | (Inherited from WoWObject.)
Public property | GetBaseAddress | Gets the base address. (Inherited from WoWObject.)
Public property | GetDescriptorStartAddress | Gets the descriptor start address. (Inherited from WoWObject.)
Public property | GetDistance | Gets the distance (from local character). (Inherited from WoWObject.)
Public property | Guid | Gets the GUID. (Inherited from WoWObject.)
Public property | IsValid | Returns true if is valid. (Inherited from WoWObject.)
Public property | Name | Gets the name. (Inherited from WoWObject.)
Public property | Position | Gets the position. (Inherited from WoWObject.)
Public property | Scale | Gets the scale. (Inherited from WoWObject.)
Public property | Type | Gets the type. (Inherited from WoWObject.)

See Also

WoWCorpse Class
wManager.Wow.ObjectManager Namespace


WoWGameObject Class

Class WoWGameObject. Implements the WoWObject

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class WoWGameObject : WoWObject
Public Class WoWGameObject _
    Inherits WoWObject
public ref class WoWGameObject : public WoWObject

Inheritance Hierarchy

Object
wManager.Wow.ObjectManager..::..WoWObject
wManager.Wow.ObjectManager..::..WoWGameObject

See Also

WoWGameObject Members
wManager.Wow.ObjectManager Namespace
wManager.Wow.ObjectManager..::..WoWObject


WoWGameObject Members

The WoWGameObject type exposes the following members.

Constructors

 | Name | Description
Public method | WoWGameObject | Initializes a new instance of the WoWGameObject class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDescriptorAddress(Descriptors..::..GameObjectFields) |
Public method | GetDescriptorAddress(Descriptors..::..ObjectFields) | Gets the descriptor address. (Inherited from WoWObject.)
Public method | GetDescriptorAddress(UInt32) | Gets the descriptor address. (Inherited from WoWObject.)
Public method | GetDescriptorAddress(UInt32, UInt32) | Gets the descriptor address. (Inherited from WoWObject.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ModelName | Gets model file name.
Public method | Rotation | Gets rotation (facing)
Public method | ToString | Returns a String that represents this instance. (Inherited from WoWObject.)

Properties

 | Name | Description
Protected property | BaseAddress | (Inherited from WoWObject.)
Protected property | BaseDescriptorAddressCACHE | (Inherited from WoWObject.)
Public property | CanOpen | Gets a value indicating whether can open.
Public property | CreatedBy | Gets creator GUID.
Public property | Data0 | Gets the data0.
Public property | Data1 | Gets the data1.
Public property | Data8 | Gets the data8.
Public property | DisplayId | Gets display id.
Public property | Entry | (Inherited from WoWObject.)
Public property | Flags | Gets the Flags.
Public property | FlagsInt | Gets the Flags.
Public property | GetBaseAddress | Gets the base address. (Inherited from WoWObject.)
Public property | GetDescriptorStartAddress | Gets the descriptor start address. (Inherited from WoWObject.)
Public property | GetDistance | Gets the distance (from local player).
Public property | GetDistance2D | Gets the distance 2d (from local player).
Public property | GetDistanceZ | Gets the distance z (from local player).
Public property | GOType | Gets the type of the gameobject.
Public property | Guid | Gets the GUID. (Inherited from WoWObject.)
Public property | InteractDistance | Gets or sets the interact distance (memorized in InteractDistanceByEntry).
 | InteractDistanceByEntry | Gets or set the interact distance by entry.
Public property | IsBlacklisted | Gets a value indicating whether this object is blacklisted (IsBlackListedAllConditions(WoWUnit)).
Public property | IsGoodInteractDistance | Gets a value indicating whether is good interact distance.
Public property | IsIndoors | Gets a value indicating whether is indoors.
Public property | IsMailbox | Gets a value indicating whether is mailbox.
Public property | IsMDXCollidable | Gets a value indicating whether is MDX collidable.
Public property | IsOutdoors | Gets a value indicating whether is outdoors.
Public property | IsValid | Returns true if is valid. (Inherited from WoWObject.)
Public property | LockEntry | Gets the lock entry.
Public property | Matrix | Gets the matrix.
Public property | Name | Gets the name.
Public property | ParentRotation | Gets the Parent Rotation.
Public property | Position | Gets the position.
Public property | Scale | Gets the scale. (Inherited from WoWObject.)
Public property | SkillLineRequired | Gets the skill line required.
Public property | Type | Gets the type. (Inherited from WoWObject.)

See Also

WoWGameObject Class
wManager.Wow.ObjectManager Namespace


WoWGameObject Constructor

Initializes a new instance of the WoWGameObject class.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public WoWGameObject(
    uint address
)
Public Sub New ( _
    address As UInteger _
)
public:
WoWGameObject(
    unsigned int^ address
)

Parameters

address
Type: UInt32
The address.

See Also

WoWGameObject Class
wManager.Wow.ObjectManager Namespace


WoWGameObject Methods

The WoWGameObject type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDescriptorAddress(Descriptors..::..GameObjectFields) |
Public method | GetDescriptorAddress(Descriptors..::..ObjectFields) | Gets the descriptor address. (Inherited from WoWObject.)
Public method | GetDescriptorAddress(UInt32) | Gets the descriptor address. (Inherited from WoWObject.)
Public method | GetDescriptorAddress(UInt32, UInt32) | Gets the descriptor address. (Inherited from WoWObject.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ModelName | Gets model file name.
Public method | Rotation | Gets rotation (facing)
Public method | ToString | Returns a String that represents this instance. (Inherited from WoWObject.)

See Also

WoWGameObject Class
wManager.Wow.ObjectManager Namespace


GetDescriptorAddress Method

WoWGameObject..::..GetDescriptorAddress Method

Overload List

 | Name | Description
Public method | GetDescriptorAddress(Descriptors..::..GameObjectFields) |
Public method | GetDescriptorAddress(Descriptors..::..ObjectFields) | Gets the descriptor address. (Inherited from WoWObject.)
Public method | GetDescriptorAddress(UInt32) | Gets the descriptor address. (Inherited from WoWObject.)
Public method | GetDescriptorAddress(UInt32, UInt32) | Gets the descriptor address. (Inherited from WoWObject.)

See Also

WoWGameObject Class
WoWGameObject Members
wManager.Wow.ObjectManager Namespace


GetDescriptorAddress Method

WoWGameObject..::..GetDescriptorAddress Method

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint GetDescriptorAddress(
    Descriptors..::..GameObjectFields field
)
Public Function GetDescriptorAddress ( _
    field As Descriptors..::..GameObjectFields _
) As UInteger
public:
unsigned int^ GetDescriptorAddress(
    Descriptors..::..GameObjectFields^ field
)

Parameters

field
Type: wManager.Wow.Patchables..::..Descriptors..::..GameObjectFields

See Also

WoWGameObject Class
wManager.Wow.ObjectManager Namespace


ModelName Method

WoWGameObject..::..ModelName Method

Gets model file name.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string ModelName()
Public Function ModelName As String
public:
String^ ModelName()

Field Value

model file name.

See Also

WoWGameObject Class
wManager.Wow.ObjectManager Namespace


Rotation Method

WoWGameObject..::..Rotation Method

Gets rotation (facing)

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float Rotation()
Public Function Rotation As Single
public:
float^ Rotation()

Return Value

rotation.

See Also

WoWGameObject Class
wManager.Wow.ObjectManager Namespace


WoWGameObject Properties

The WoWGameObject type exposes the following members.

Properties

 | Name | Description
Protected property | BaseAddress | (Inherited from WoWObject.)
Protected property | BaseDescriptorAddressCACHE | (Inherited from WoWObject.)
Public property | CanOpen | Gets a value indicating whether can open.
Public property | CreatedBy | Gets creator GUID.
Public property | Data0 | Gets the data0.
Public property | Data1 | Gets the data1.
Public property | Data8 | Gets the data8.
Public property | DisplayId | Gets display id.
Public property | Entry | (Inherited from WoWObject.)
Public property | Flags | Gets the Flags.
Public property | FlagsInt | Gets the Flags.
Public property | GetBaseAddress | Gets the base address. (Inherited from WoWObject.)
Public property | GetDescriptorStartAddress | Gets the descriptor start address. (Inherited from WoWObject.)
Public property | GetDistance | Gets the distance (from local player).
Public property | GetDistance2D | Gets the distance 2d (from local player).
Public property | GetDistanceZ | Gets the distance z (from local player).
Public property | GOType | Gets the type of the gameobject.
Public property | Guid | Gets the GUID. (Inherited from WoWObject.)
Public property | InteractDistance | Gets or sets the interact distance (memorized in InteractDistanceByEntry).
 | InteractDistanceByEntry | Gets or set the interact distance by entry.
Public property | IsBlacklisted | Gets a value indicating whether this object is blacklisted (IsBlackListedAllConditions(WoWUnit)).
Public property | IsGoodInteractDistance | Gets a value indicating whether is good interact distance.
Public property | IsIndoors | Gets a value indicating whether is indoors.
Public property | IsMailbox | Gets a value indicating whether is mailbox.
Public property | IsMDXCollidable | Gets a value indicating whether is MDX collidable.
Public property | IsOutdoors | Gets a value indicating whether is outdoors.
Public property | IsValid | Returns true if is valid. (Inherited from WoWObject.)
Public property | LockEntry | Gets the lock entry.
Public property | Matrix | Gets the matrix.
Public property | Name | Gets the name.
Public property | ParentRotation | Gets the Parent Rotation.
Public property | Position | Gets the position.
Public property | Scale | Gets the scale. (Inherited from WoWObject.)
Public property | SkillLineRequired | Gets the skill line required.
Public property | Type | Gets the type. (Inherited from WoWObject.)

See Also

WoWGameObject Class
wManager.Wow.ObjectManager Namespace


CanOpen Property

WoWGameObject..::..CanOpen Property

Gets a value indicating whether can open.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool CanOpen { get; }
Public ReadOnly Property CanOpen As Boolean
    Get
public:
property bool^ CanOpen {
    bool^ get ();
}

Field Value

true if can open; otherwise, false.

See Also

WoWGameObject Class
wManager.Wow.ObjectManager Namespace


CreatedBy Property

WoWGameObject..::..CreatedBy Property

Gets creator GUID.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public ulong CreatedBy { get; }
Public ReadOnly Property CreatedBy As ULong
    Get
public:
property unsigned long long^ CreatedBy {
    unsigned long long^ get ();
}

Field Value

The created by.

See Also

WoWGameObject Class
wManager.Wow.ObjectManager Namespace


Data0 Property

WoWGameObject..::..Data0 Property

Gets the data0.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint Data0 { get; }
Public ReadOnly Property Data0 As UInteger
    Get
public:
property unsigned int^ Data0 {
    unsigned int^ get ();
}

Field Value

The data0.

See Also

WoWGameObject Class
wManager.Wow.ObjectManager Namespace


Data1 Property

WoWGameObject..::..Data1 Property

Gets the data1.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint Data1 { get; }
Public ReadOnly Property Data1 As UInteger
    Get
public:
property unsigned int^ Data1 {
    unsigned int^ get ();
}

Field Value

The data1.

See Also

WoWGameObject Class
wManager.Wow.ObjectManager Namespace


Data8 Property

WoWGameObject..::..Data8 Property

Gets the data8.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint Data8 { get; }
Public ReadOnly Property Data8 As UInteger
    Get
public:
property unsigned int^ Data8 {
    unsigned int^ get ();
}

Field Value

The data8.

See Also

WoWGameObject Class
wManager.Wow.ObjectManager Namespace


DisplayId Property

WoWGameObject..::..DisplayId Property

Gets display id.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int DisplayId { get; }
Public ReadOnly Property DisplayId As Integer
    Get
public:
property int^ DisplayId {
    int^ get ();
}

Field Value

The display id.

See Also

WoWGameObject Class
wManager.Wow.ObjectManager Namespace


Flags Property

WoWGameObject..::..Flags Property

Gets the Flags.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public GameObjectFlags Flags { get; }
Public ReadOnly Property Flags As GameObjectFlags
    Get
public:
property GameObjectFlags^ Flags {
    GameObjectFlags^ get ();
}

Field Value

The Flags.

See Also

WoWGameObject Class
wManager.Wow.ObjectManager Namespace


FlagsInt Property

WoWGameObject..::..FlagsInt Property

Gets the Flags.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int FlagsInt { get; }
Public ReadOnly Property FlagsInt As Integer
    Get
public:
property int^ FlagsInt {
    int^ get ();
}

Field Value

The Flags.

See Also

WoWGameObject Class
wManager.Wow.ObjectManager Namespace


GetDistance Property

WoWGameObject..::..GetDistance Property

Gets the distance (from local player).

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float GetDistance { get; }
Public ReadOnly Property GetDistance As Single
    Get
public:
property float^ GetDistance {
    float^ get ();
}

Field Value

The distance.

See Also

WoWGameObject Class
wManager.Wow.ObjectManager Namespace


GetDistance2D Property

WoWGameObject..::..GetDistance2D Property

Gets the distance 2d (from local player).

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float GetDistance2D { get; }
Public ReadOnly Property GetDistance2D As Single
    Get
public:
property float^ GetDistance2D {
    float^ get ();
}

Field Value

The distance 2d.

See Also

WoWGameObject Class
wManager.Wow.ObjectManager Namespace


GetDistanceZ Property

WoWGameObject..::..GetDistanceZ Property

Gets the distance z (from local player).

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float GetDistanceZ { get; }
Public ReadOnly Property GetDistanceZ As Single
    Get
public:
property float^ GetDistanceZ {
    float^ get ();
}

Field Value

The distance z.

See Also

WoWGameObject Class
wManager.Wow.ObjectManager Namespace


GOType Property

WoWGameObject..::..GOType Property

Gets the type of the gameobject.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public WoWGameObjectType GOType { get; }
Public ReadOnly Property GOType As WoWGameObjectType
    Get
public:
property WoWGameObjectType^ GOType {
    WoWGameObjectType^ get ();
}

Field Value

The type of the gameobject.

See Also

WoWGameObject Class
wManager.Wow.ObjectManager Namespace


InteractDistance Property

WoWGameObject..::..InteractDistance Property

Gets or sets the interact distance (memorized in InteractDistanceByEntry).

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float InteractDistance { get; set; }
Public Property InteractDistance As Single
    Get
    Set
public:
property float^ InteractDistance {
    float^ get ();
    void set (float^ value);
}

Field Value

The interact distance.

See Also

WoWGameObject Class
wManager.Wow.ObjectManager Namespace


InteractDistanceByEntry Property

WoWGameObject..::..InteractDistanceByEntry Property

Gets or set the interact distance by entry.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static Dictionary<int, float> InteractDistanceByEntry { get; }
Public Shared ReadOnly Property InteractDistanceByEntry As Dictionary(Of Integer, Single)
    Get
public:
static property Dictionary<int^, float^>^ InteractDistanceByEntry {
    Dictionary<int^, float^>^ get ();
}

Field Value

The interact distance by entry.

See Also

WoWGameObject Class
wManager.Wow.ObjectManager Namespace


IsBlacklisted Property

WoWGameObject..::..IsBlacklisted Property

Gets a value indicating whether this object is blacklisted (IsBlackListedAllConditions(WoWUnit)).

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsBlacklisted { get; }
Public ReadOnly Property IsBlacklisted As Boolean
    Get
public:
property bool^ IsBlacklisted {
    bool^ get ();
}

Field Value

true if is blacklisted; otherwise, false.

See Also

WoWGameObject Class
wManager.Wow.ObjectManager Namespace


IsGoodInteractDistance Property

WoWGameObject..::..IsGoodInteractDistance Property

Gets a value indicating whether is good interact distance.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsGoodInteractDistance { get; }
Public ReadOnly Property IsGoodInteractDistance As Boolean
    Get
public:
property bool^ IsGoodInteractDistance {
    bool^ get ();
}

Field Value

true if is good interact distance; otherwise, false.

See Also

WoWGameObject Class
wManager.Wow.ObjectManager Namespace


IsIndoors Property

WoWGameObject..::..IsIndoors Property

Gets a value indicating whether is indoors.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsIndoors { get; }
Public ReadOnly Property IsIndoors As Boolean
    Get
public:
property bool^ IsIndoors {
    bool^ get ();
}

Field Value

true if is indoors; otherwise, false.

See Also

WoWGameObject Class
wManager.Wow.ObjectManager Namespace


IsMailbox Property

WoWGameObject..::..IsMailbox Property

Gets a value indicating whether is mailbox.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsMailbox { get; }
Public ReadOnly Property IsMailbox As Boolean
    Get
public:
property bool^ IsMailbox {
    bool^ get ();
}

Field Value

true if is mailbox; otherwise, false.

See Also

WoWGameObject Class
wManager.Wow.ObjectManager Namespace


IsMDXCollidable Property

WoWGameObject..::..IsMDXCollidable Property

Gets a value indicating whether is MDX collidable.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsMDXCollidable { get; }
Public ReadOnly Property IsMDXCollidable As Boolean
    Get
public:
property bool^ IsMDXCollidable {
    bool^ get ();
}

Field Value

true if is MDX collidable; otherwise, false.

See Also

WoWGameObject Class
wManager.Wow.ObjectManager Namespace


IsOutdoors Property

WoWGameObject..::..IsOutdoors Property

Gets a value indicating whether is outdoors.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsOutdoors { get; }
Public ReadOnly Property IsOutdoors As Boolean
    Get
public:
property bool^ IsOutdoors {
    bool^ get ();
}

Field Value

true if is outdoors; otherwise, false.

See Also

WoWGameObject Class
wManager.Wow.ObjectManager Namespace


LockEntry Property

WoWGameObject..::..LockEntry Property

Gets the lock entry.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint LockEntry { get; }
Public ReadOnly Property LockEntry As UInteger
    Get
public:
property unsigned int^ LockEntry {
    unsigned int^ get ();
}

Field Value

The lock entry.

See Also

WoWGameObject Class
wManager.Wow.ObjectManager Namespace


Matrix Property

WoWGameObject..::..Matrix Property

Gets the matrix.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Matrix Matrix { get; }
Public ReadOnly Property Matrix As Matrix
    Get
public:
property Matrix^ Matrix {
    Matrix^ get ();
}

Field Value

The matrix.

See Also

WoWGameObject Class
wManager.Wow.ObjectManager Namespace


Name Property

WoWGameObject..::..Name Property

Gets the name.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}

Field Value

The name.

See Also

WoWGameObject Class
wManager.Wow.ObjectManager Namespace


ParentRotation Property

WoWGameObject..::..ParentRotation Property

Gets the Parent Rotation.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float ParentRotation { get; }
Public ReadOnly Property ParentRotation As Single
    Get
public:
property float^ ParentRotation {
    float^ get ();
}

Field Value

The Parent Rotation.

See Also

WoWGameObject Class
wManager.Wow.ObjectManager Namespace


Position Property

WoWGameObject..::..Position Property

Gets the position.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Vector3 Position { get; }
Public ReadOnly Property Position As Vector3
    Get
public:
property Vector3^ Position {
    Vector3^ get ();
}

Field Value

The position.

See Also

WoWGameObject Class
wManager.Wow.ObjectManager Namespace


SkillLineRequired Property

WoWGameObject..::..SkillLineRequired Property

Gets the skill line required.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public SkillLine SkillLineRequired { get; }
Public ReadOnly Property SkillLineRequired As SkillLine
    Get
public:
property SkillLine^ SkillLineRequired {
    SkillLine^ get ();
}

Field Value

The skill line required.

See Also

WoWGameObject Class
wManager.Wow.ObjectManager Namespace


WoWItem Class

Class WoWItem. Implements the WoWObject

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class WoWItem : WoWObject
Public Class WoWItem _
    Inherits WoWObject
public ref class WoWItem : public WoWObject

Inheritance Hierarchy

Object
wManager.Wow.ObjectManager..::..WoWObject
wManager.Wow.ObjectManager..::..WoWItem

See Also

WoWItem Members
wManager.Wow.ObjectManager Namespace
wManager.Wow.ObjectManager..::..WoWObject


WoWItem Members

The WoWItem type exposes the following members.

Constructors

 | Name | Description
Public method | WoWItem | Initializes a new instance of the WoWItem class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDescriptorAddress(Descriptors..::..ItemFields) |
Public method | GetDescriptorAddress(Descriptors..::..ObjectFields) | Gets the descriptor address. (Inherited from WoWObject.)
Public method | GetDescriptorAddress(UInt32) | Gets the descriptor address. (Inherited from WoWObject.)
Public method | GetDescriptorAddress(UInt32, UInt32) | Gets the descriptor address. (Inherited from WoWObject.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Inherited from WoWObject.)

Properties

 | Name | Description
Protected property | BaseAddress | (Inherited from WoWObject.)
Protected property | BaseDescriptorAddressCACHE | (Inherited from WoWObject.)
Public property | ContainedIn | Gets the contained in.
Public property | Durability | Gets durability.
Public property | Entry | (Inherited from WoWObject.)
Public property | GetBaseAddress | Gets the base address. (Inherited from WoWObject.)
Public property | GetDescriptorStartAddress | Gets the descriptor start address. (Inherited from WoWObject.)
Public property | GetDistance | Gets the distance (from local character). (Inherited from WoWObject.)
Public property | GetItemInfo | Gets the item information.
Public property | Guid | Gets the GUID. (Inherited from WoWObject.)
Public property | InBag |
Public property | IsEquippableItem | Gets a value indicating whether is equippable item.
Public property | IsValid | Returns true if is valid. (Inherited from WoWObject.)
Public property | MaxDurability | Gets maximum durability.
Public property | Name | Gets the name.
Public property | Owner | Gets the owner.
Public property | Position | Gets the position. (Inherited from WoWObject.)
Public property | Scale | Gets the scale. (Inherited from WoWObject.)
Public property | StackCount | Gets stack count.
Public property | Type | Gets the type. (Inherited from WoWObject.)

See Also

WoWItem Class
wManager.Wow.ObjectManager Namespace


WoWItem Constructor

Initializes a new instance of the WoWItem class.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public WoWItem(
    uint address
)
Public Sub New ( _
    address As UInteger _
)
public:
WoWItem(
    unsigned int^ address
)

Parameters

address
Type: UInt32
The address.

See Also

WoWItem Class
wManager.Wow.ObjectManager Namespace


WoWItem Methods

The WoWItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDescriptorAddress(Descriptors..::..ItemFields) |
Public method | GetDescriptorAddress(Descriptors..::..ObjectFields) | Gets the descriptor address. (Inherited from WoWObject.)
Public method | GetDescriptorAddress(UInt32) | Gets the descriptor address. (Inherited from WoWObject.)
Public method | GetDescriptorAddress(UInt32, UInt32) | Gets the descriptor address. (Inherited from WoWObject.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Inherited from WoWObject.)

See Also

WoWItem Class
wManager.Wow.ObjectManager Namespace


GetDescriptorAddress Method

WoWItem..::..GetDescriptorAddress Method

Overload List

 | Name | Description
Public method | GetDescriptorAddress(Descriptors..::..ItemFields) |
Public method | GetDescriptorAddress(Descriptors..::..ObjectFields) | Gets the descriptor address. (Inherited from WoWObject.)
Public method | GetDescriptorAddress(UInt32) | Gets the descriptor address. (Inherited from WoWObject.)
Public method | GetDescriptorAddress(UInt32, UInt32) | Gets the descriptor address. (Inherited from WoWObject.)

See Also

WoWItem Class
WoWItem Members
wManager.Wow.ObjectManager Namespace


GetDescriptorAddress Method

WoWItem..::..GetDescriptorAddress Method

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint GetDescriptorAddress(
    Descriptors..::..ItemFields field
)
Public Function GetDescriptorAddress ( _
    field As Descriptors..::..ItemFields _
) As UInteger
public:
unsigned int^ GetDescriptorAddress(
    Descriptors..::..ItemFields^ field
)

Parameters

field
Type: wManager.Wow.Patchables..::..Descriptors..::..ItemFields

See Also

WoWItem Class
wManager.Wow.ObjectManager Namespace


WoWItem Properties

The WoWItem type exposes the following members.

Properties

 | Name | Description
Protected property | BaseAddress | (Inherited from WoWObject.)
Protected property | BaseDescriptorAddressCACHE | (Inherited from WoWObject.)
Public property | ContainedIn | Gets the contained in.
Public property | Durability | Gets durability.
Public property | Entry | (Inherited from WoWObject.)
Public property | GetBaseAddress | Gets the base address. (Inherited from WoWObject.)
Public property | GetDescriptorStartAddress | Gets the descriptor start address. (Inherited from WoWObject.)
Public property | GetDistance | Gets the distance (from local character). (Inherited from WoWObject.)
Public property | GetItemInfo | Gets the item information.
Public property | Guid | Gets the GUID. (Inherited from WoWObject.)
Public property | InBag |
Public property | IsEquippableItem | Gets a value indicating whether is equippable item.
Public property | IsValid | Returns true if is valid. (Inherited from WoWObject.)
Public property | MaxDurability | Gets maximum durability.
Public property | Name | Gets the name.
Public property | Owner | Gets the owner.
Public property | Position | Gets the position. (Inherited from WoWObject.)
Public property | Scale | Gets the scale. (Inherited from WoWObject.)
Public property | StackCount | Gets stack count.
Public property | Type | Gets the type. (Inherited from WoWObject.)

See Also

WoWItem Class
wManager.Wow.ObjectManager Namespace


ContainedIn Property

WoWItem..::..ContainedIn Property

Gets the contained in.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public ulong ContainedIn { get; }
Public ReadOnly Property ContainedIn As ULong
    Get
public:
property unsigned long long^ ContainedIn {
    unsigned long long^ get ();
}

Field Value

The contained in.

See Also

WoWItem Class
wManager.Wow.ObjectManager Namespace


Durability Property

WoWItem..::..Durability Property

Gets durability.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int Durability { get; }
Public ReadOnly Property Durability As Integer
    Get
public:
property int^ Durability {
    int^ get ();
}

Field Value

The durability.

See Also

WoWItem Class
wManager.Wow.ObjectManager Namespace


GetItemInfo Property

WoWItem..::..GetItemInfo Property

Gets the item information.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public ItemInfo GetItemInfo { get; }
Public ReadOnly Property GetItemInfo As ItemInfo
    Get
public:
property ItemInfo^ GetItemInfo {
    ItemInfo^ get ();
}

Field Value

The item information.

See Also

WoWItem Class
wManager.Wow.ObjectManager Namespace


InBag Property

WoWItem..::..InBag Property

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool InBag { get; }
Public ReadOnly Property InBag As Boolean
    Get
public:
property bool^ InBag {
    bool^ get ();
}

See Also

WoWItem Class
wManager.Wow.ObjectManager Namespace


IsEquippableItem Property

WoWItem..::..IsEquippableItem Property

Gets a value indicating whether is equippable item.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsEquippableItem { get; }
Public ReadOnly Property IsEquippableItem As Boolean
    Get
public:
property bool^ IsEquippableItem {
    bool^ get ();
}

Field Value

true if is equippable item; otherwise, false.

See Also

WoWItem Class
wManager.Wow.ObjectManager Namespace


MaxDurability Property

WoWItem..::..MaxDurability Property

Gets maximum durability.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int MaxDurability { get; }
Public ReadOnly Property MaxDurability As Integer
    Get
public:
property int^ MaxDurability {
    int^ get ();
}

Field Value

The maximum durability.

See Also

WoWItem Class
wManager.Wow.ObjectManager Namespace


Name Property

WoWItem..::..Name Property

Gets the name.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}

Field Value

The name.

See Also

WoWItem Class
wManager.Wow.ObjectManager Namespace


Owner Property

WoWItem..::..Owner Property

Gets the owner.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public ulong Owner { get; }
Public ReadOnly Property Owner As ULong
    Get
public:
property unsigned long long^ Owner {
    unsigned long long^ get ();
}

Field Value

The owner.

See Also

WoWItem Class
wManager.Wow.ObjectManager Namespace


StackCount Property

WoWItem..::..StackCount Property

Gets stack count.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int StackCount { get; }
Public ReadOnly Property StackCount As Integer
    Get
public:
property int^ StackCount {
    int^ get ();
}

Field Value

The stack count.

See Also

WoWItem Class
wManager.Wow.ObjectManager Namespace


WoWLocalPlayer Class

Class WoWLocalPlayer. Your Character. Implements the WoWPlayer

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class WoWLocalPlayer : WoWPlayer
Public Class WoWLocalPlayer _
    Inherits WoWPlayer
public ref class WoWLocalPlayer : public WoWPlayer

Inheritance Hierarchy

Object
wManager.Wow.ObjectManager..::..WoWObject
wManager.Wow.ObjectManager..::..WoWUnit
wManager.Wow.ObjectManager..::..WoWPlayer
wManager.Wow.ObjectManager..::..WoWLocalPlayer

See Also

WoWLocalPlayer Members
wManager.Wow.ObjectManager Namespace
wManager.Wow.ObjectManager..::..WoWPlayer


WoWLocalPlayer Members

The WoWLocalPlayer type exposes the following members.

Constructors

 | Name | Description
Public method | WoWLocalPlayer | Initializes a new instance of the WoWLocalPlayer class.

Methods

 | Name | Description
Public method | BuffCastedBy | Buff casted by. (Inherited from WoWUnit.)
Public method | BuffCastedByAll | Buff casted by all. (Inherited from WoWUnit.)
Public method | BuffStack(List<(Of <<'(UInt32>)>>)) | Buff stack count. (Inherited from WoWUnit.)
Public method | BuffStack(UInt32) | Buff stack count. (Inherited from WoWUnit.)
Public method | BuffStack(String) | Buff stack count. (Inherited from WoWUnit.)
Public method | BuffTimeLeft(String) | Buff time left. (Inherited from WoWUnit.)
Public method | BuffTimeLeft(List<(Of <<'(UInt32>)>>)) | Buff time left. (Inherited from WoWUnit.)
Public method | CooldownEnabled(UInt32) | Cooldown enabled.
Public method | CooldownEnabled(String, Boolean) | Cooldown enabled.
Public method | CooldownTimeLeft(UInt32) | Cooldown time left.
Public method | CooldownTimeLeft(String, Boolean) | Cooldown time left.
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAllBuff | Gets all buff. (Inherited from WoWUnit.)
Public method | GetBuff(String) | Gets the buff. (Inherited from WoWUnit.)
Public method | GetBuff(List<(Of <<'(UInt32>)>>)) | Gets the buff. (Inherited from WoWUnit.)
Public method | GetBuffs(String) | Gets the buffs. (Inherited from WoWUnit.)
Public method | GetBuffs(List<(Of <<'(UInt32>)>>)) | Gets the buffs. (Inherited from WoWUnit.)
Public method | GetCorpseRecoveryDelay | Gets the corpse recovery delay.
Public method | GetDescriptorAddress(Descriptors..::..PlayerFields) | (Inherited from WoWPlayer.)
Public method | GetDescriptorAddress(Descriptors..::..UnitFields) | (Inherited from WoWUnit.)
Public method | GetDescriptorAddress(Descriptors..::..ObjectFields) | Gets the descriptor address. (Inherited from WoWObject.)
Public method | GetDescriptorAddress(UInt32) | Gets the descriptor address. (Inherited from WoWObject.)
Public method | GetDescriptorAddress(UInt32, UInt32) | Gets the descriptor address. (Inherited from WoWObject.)
Public method | GetEquipedItemBySlot | Gets the equipped item by slot. (Inherited from WoWPlayer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetMaxPowerByPowerType | Gets maximum power value by type. (Inherited from WoWUnit.)
Public method | GetMovementFlag | Gets if movement flag is present. (Inherited from WoWUnit.)
Public method | GetMyBuff | Gets my buff. (Inherited from WoWUnit.)
Public method | GetPowerByPowerType | Gets power value by power type. (Inherited from WoWUnit.)
Public method | GetRunes()()()() | Gets the runes.
Public method | GetRunes(RuneTypes) | Gets the runes by type.
Public method | GetRunesReady(RuneTypes) | Gets the runes readies by type.
Public method | GetRunesReady()()()() | Gets the runes readies.
Public method | GetType | (Inherited from Object.)
Public method | HaveBuff(String) | Has the buff. (Inherited from WoWUnit.)
Public method | HaveBuff(List<(Of <<'(UInt32>)>>)) | Has the buff. (Inherited from WoWUnit.)
Public method | HaveBuff(UInt32) | Has the buff. (Inherited from WoWUnit.)
Public method | IsAchievementCompleted | Determines whether achievement is completed.
Public method | IsBehind | Determines whether the specified target position is behind. (Inherited from WoWUnit.)
Public method | IsFacing | Determines whether the specified target position is facing. (Inherited from WoWUnit.)
Public method | IsLooting | Determines whether is looting.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | MoneyStringFormat()()()() | GetMoneyCopper to string format (CopperToString(Int64))
Public method | MoneyStringFormat(Int64) | Money to string format (CopperToString(Int64)).
Public method | RuneIsReady | Rune slot is ready.
Public method | RunesReadyCount()()()() | Runes readies count.
Public method | RunesReadyCount(RuneTypes) | Runes ready count.
Public method | ToString | Returns a String that represents this instance. (Inherited from WoWObject.)
Public method | TotemExist | Totem exist.
Public method | TotemTimeLeft | Totem time left.

Fields

 | Name | Description
Public field | ForceIsCast | Force IsCast

Properties

 | Name | Description
Public property | AggroDistance | Gets the aggro distance. (Inherited from WoWUnit.)
Public property | Alternate | Gets the alternate. (Inherited from WoWUnit.)
Public property | AlternatePercentage | Gets the alternate percentage. (Inherited from WoWUnit.)
Public property | ArcaneCharges | Gets the arcane charges. (Inherited from WoWUnit.)
Public property | ArcaneChargesPercentage | Gets the arcane charges percentage. (Inherited from WoWUnit.)
Public property | BarTwo | Gets the bar two value. (Inherited from WoWPlayer.)
Public property | BarTwoMax | Gets the bar two max value. (Inherited from WoWPlayer.)
Public property | BarTwoPercentage | Gets the bar two percentage. (Inherited from WoWPlayer.)
Protected property | BaseAddress | (Inherited from WoWObject.)
Protected property | BaseDescriptorAddressCACHE | (Inherited from WoWObject.)
Public property | BreathActive | Gets a value indicating whether breath active.
Public property | BreathTimerLeft | Gets the breath timer left.
Public property | BurningEmbers | Gets the Burning Embers. (Inherited from WoWUnit.)
Public property | BurningEmbersPercentage | Gets the Burning Embers percentage. (Inherited from WoWUnit.)
Public property | CanInterruptCasting | Gets a value indicating whether can interrupt casting. (Inherited from WoWUnit.)
Public property | CanMove | Gets a value indicating whether can move (!IsCast && !Influenced && !IsStunned && !IsOnTaxi).
Public property | CastingSpell | Gets the casting spell. (Inherited from WoWUnit.)
Public property | CastingSpellId | Gets the casting spell id. (Inherited from WoWUnit.)
Public property | CastingTimeLeft | Gets the casting time left (in milliseconds). (Inherited from WoWUnit.)
Public property | Chi | Gets the chi. (Inherited from WoWUnit.)
Public property | ChiPercentage | Gets the chi percentage. (Inherited from WoWUnit.)
Public property | CombatReach | Gets the combat reach. (Inherited from WoWUnit.)
Public property | ComboPoint | Gets the combo point. (Inherited from WoWPlayer.)
Public property | Confused | Gets a value indicating whether is confused. (Inherited from WoWUnit.)
Public property | CreatedBy | Gets the created by. (Inherited from WoWUnit.)
Public property | CreatedBySpell | Gets spell id used to create him. (Inherited from WoWUnit.)
Public property | CreatureTypeTarget | Gets the creature type target (work only in unit is your current target). (Inherited from WoWUnit.)
Public property | DarkForce | Gets the dark force. (Inherited from WoWUnit.)
Public property | DarkForcePercentage | Gets the percentage dark force. (Inherited from WoWUnit.)
Public property | DBCacheRow | Gets the database cache row. (Inherited from WoWUnit.)
Public property | DemonicFury | Gets the Demonic Fury. (Inherited from WoWUnit.)
Public property | DemonicFuryPercentage | Gets the Demonic Fury percentage. (Inherited from WoWUnit.)
Public property | DisplayId | Gets the display id. (Inherited from WoWUnit.)
Public property | Eclipse | (Inherited from WoWPlayer.)
Public property | EclipsePercentage | (Inherited from WoWPlayer.)
Public property | Energy | Gets the energy. (Inherited from WoWUnit.)
Public property | EnergyPercentage | Gets the energy percentage. (Inherited from WoWUnit.)
Public property | Entry | (Inherited from WoWObject.)
Public property | Experience | Gets experience.
Public property | ExperienceMax | Gets experience maximum.
Public property | Faction | Gets the faction. (Inherited from WoWUnit.)
Public property | FactionTemplate | Gets the faction template. (Inherited from WoWUnit.)
Public property | FatigueActive | Gets a value indicating whether fatigue active.
Public property | FatigueTimerLeft | Gets the fatigue timer left.
Public property | Fleeing | Gets a value indicating whether is fleeing. (Inherited from WoWUnit.)
Public property | Focus | Gets the focus. (Inherited from WoWUnit.)
Public property | FocusGuid | Gets or sets the focus GUID.
Public property | FocusObj | Gets the focus object.
Public property | FocusPercentage | Gets the focus percentage. (Inherited from WoWUnit.)
Public property | GeHitBoxtDistance | Gets the HitBox distance. (Inherited from WoWUnit.)
Public property | Gender | Gets the gender.
Public property | GetBaseAddress | Gets the base address. (Inherited from WoWObject.)
Public property | GetDescriptorStartAddress | Gets the descriptor start address. (Inherited from WoWObject.)
Public property | GetDistance | Gets the get distance (from local player). (Inherited from WoWUnit.)
Public property | GetDistance2D | Gets the get distance 2D (from local player). (Inherited from WoWUnit.)
Public property | GetDistanceZ | Gets the get distance Z (from local player). (Inherited from WoWUnit.)
Public property | GetDurabilityPercent | Gets the durability percent.
Public property | GetDynamicFlags | Gets the unit dynamic flags. (Inherited from WoWUnit.)
Public property | GetEquipedItem | Gets the get equipped items. (Inherited from WoWPlayer.)
Public property | GetHonorPoint | Gets the honor point.
Public property | GetLowerItemDurabilityPercent | Gets the lower item durability percent.
Public property | GetMoneyCopper | Gets the money copper.
Public property | GetMove | Gets a value indicating whether get move. (Inherited from WoWUnit.)
Public property | GetUnitDynamicFlags | Gets the unit dynamic flags. (Inherited from WoWUnit.)
Public property | GetWeaponDurabilityPercent | Gets the weapon durability percent.
Public property | GlobalCooldownEnabled | Gets a value indicating whether global cooldown enabled.
Public property | GlobalCooldownTimeLeft | Gets the global cooldown time left.
Public property | Guid | Gets the GUID. (Inherited from WoWObject.)
Public property | HasFocus | Gets a value indicating whether has focus.
Public property | HasMouseOver | Gets a value indicating whether has mouse over.
Public property | HasNewMail | Gets a value indicating whether has new mail.
Public property | HasTarget | Gets a value indicating whether has target. (Inherited from WoWUnit.)
Public property | Health | Gets the health. (Inherited from WoWUnit.)
Public property | HealthPercent | Gets the health percent. (Inherited from WoWUnit.)
Public property | HealthRatio | Gets the health ratio. (Inherited from WoWUnit.)
Public property | HolyPower | Gets the holy power. (Inherited from WoWUnit.)
Public property | HolyPowerPercentage | Gets the holy power percentage. (Inherited from WoWUnit.)
Public property | InCombat | Gets a value indicating whether in combat (relating to bot configurations/blacklist, to check if the game determined you are in combat use InCombatFlagOnly).
Public property | InCombatFlagOnly | Gets a value indicating whether in combat flag only. (Inherited from WoWUnit.)
Public property | InCombatWithMe | Gets a value indicating whether in combat with me. (Inherited from WoWUnit.)
Public property | Influenced | Gets a value indicating whether is influenced. (Inherited from WoWUnit.)
Public property | InteractDistance | Gets or sets the interact distance (you can adjust with MinInteractDistance, MaxInteractDistance and InteractDistanceByEntry, if you set value it is save to InteractDistanceByEntry). (Inherited from WoWUnit.)
Public property | InTransport | Gets a value indicating whether in transport. (Inherited from WoWUnit.)
Public property | InvSlots |
Public property | IsAlive | Gets a value indicating whether is alive. (Inherited from WoWUnit.)
Public property | IsAlliance | Gets a value indicating whether is in alliance. (Inherited from WoWPlayer.)
Public property | IsAttackable | Gets a value indicating whether is attackable. (Inherited from WoWUnit.)
Public property | IsAuctioneer | Gets a value indicating whether is auctioneer. (Inherited from WoWUnit.)
Public property | IsBlacklisted | Gets a value indicating whether is blacklisted. (Inherited from WoWUnit.)
Public property | IsBoss | Gets a value indicating whether is boss. (Inherited from WoWUnit.)
Public property | IsCast | Gets a value indicating whether is cast (can be force with ForceIsCast).
Public property | IsDead | Gets a value indicating whether is dead (call IsDeadMe).
Public property | IsDeadMe | Gets a value indicating whether is dead.
Public property | IsElite | Gets a value indicating whether is elite. (Inherited from WoWUnit.)
Public property | IsFlightMaster | Gets a value indicating whether is flight master. (Inherited from WoWUnit.)
Public property | IsFlying | Gets a value indicating whether is flying. (Inherited from WoWUnit.)
Public property | IsGoodInteractDistance | Gets a value indicating whether is good interact distance (look InteractDistance). (Inherited from WoWUnit.)
Public property | IsHorde | Gets a value indicating whether is in horde. (Inherited from WoWPlayer.)
Public property | IsIndoors | Gets a value indicating whether is indoors. (Inherited from WoWUnit.)
Public property | IsInGroup | Gets a value indicating whether is in group.
Public property | IsInParty | Gets a value indicating whethe is in party.
Public property | IsInPetBattle | Gets a value indicating whether in pet battle.
Public property | IsLocalPlayer | Gets a value indicating whether is local player. (Inherited from WoWUnit.)
Public property | IsLootable | Gets a value indicating whether is lootable. (Inherited from WoWUnit.)
Public property | IsMeOrMyPetOrPartyMemberTarget | Gets a value indicating whether is my target or my pet or party member target. (Inherited from WoWUnit.)
Public property | IsMeOrMyPetTarget | Gets a value indicating whether is my target or my pet target. (Inherited from WoWUnit.)
Public property | IsMounted | Gets a value indicating whether is mounted.
Public property | IsMyPet | Gets a value indicating whether is my pet. (Inherited from WoWUnit.)
Public property | IsMyPetTarget | Gets a value indicating whether is my pet target. (Inherited from WoWUnit.)
Public property | IsMyTarget | Gets a value indicating whether is my target. (Inherited from WoWUnit.)
Public property | IsNeutral | Gets a value indicating whether is neutral (no horde or alliance faction). (Inherited from WoWPlayer.)
Public property | IsNpcInnkeeper | Gets a value indicating whether is NPC innkeeper. (Inherited from WoWUnit.)
Public property | IsNpcRepair | Gets a value indicating whether is NPC repair. (Inherited from WoWUnit.)
Public property | IsNpcSpiritHealer | Gets a value indicating whether is NPC spirit healer. (Inherited from WoWUnit.)
Public property | IsNpcTrainer | Gets a value indicating whether is NPC trainer. (Inherited from WoWUnit.)
Public property | IsNpcVendor | Gets a value indicating whether is NPC vendor. (Inherited from WoWUnit.)
Public property | IsNpcVendorFood | Gets a value indicating whether is NPC vendor food. (Inherited from WoWUnit.)
Public property | IsNpcWildPets | Gets a value indicating whether is NPC wild pets. (Inherited from WoWUnit.)
Public property | IsOnTaxi | Gets a value indicating whether is on taxi. (Inherited from WoWUnit.)
Public property | IsOutdoors | Gets a value indicating whether is outdoors. (Inherited from WoWUnit.)
Public property | IsPartyLeader | Gets a value indicating whether is party leader. (Inherited from WoWUnit.)
Public property | IsPartyMember | Gets a value indicating whether is party member.
Public property | IsPartyMemberTarget | Gets a value indicating whether is party member target. (Inherited from WoWUnit.)
Public property | IsPet | Gets a value indicating whether is pet. (Inherited from WoWUnit.)
Public property | IsStunned | Gets a value indicating whether is stunned. (Inherited from WoWUnit.)
Public property | IsSwimming | Gets a value indicating whether is swimming. (Inherited from WoWUnit.)
Public property | IsTaggedByOther | Gets a value indicating Tagged By Other. (Inherited from WoWUnit.)
Public property | IsTapDenied | Gets a value indicating whether is tap denied. (Inherited from WoWUnit.)
Public property | IsTargetingMe | Gets a value indicating whether is targeting me. (Inherited from WoWUnit.)
Public property | IsTargetingMeOrMyPet | Gets a value indicating whether is targeting me or my pet. (Inherited from WoWUnit.)
Public property | IsTargetingMeOrMyPetOrPartyMember | Gets a value indicating whether is targeting me or my pet or (my) party member. (Inherited from WoWUnit.)
Public property | IsTargetingMyPet | Gets a value indicating whether is targeting my pet. (Inherited from WoWUnit.)
Public property | IsTargetingPartyMember | Gets a value indicating whether is targeting (my) party member. (Inherited from WoWUnit.)
Public property | IsTracked | Gets or sets a value indicating whether is tracked (in in-game minimap). (Inherited from WoWUnit.)
Public property | IsValid | Returns true if is valid. (Inherited from WoWObject.)
Public property | IsWorldBoss | Gets a value indicating whether is world boss. (Inherited from WoWUnit.)
Public property | Level | Gets the level. (Inherited from WoWUnit.)
Public property | LevelDecimal | Gets level decimal (Level + Experience / ExperienceMax).
Public property | LightForce | Gets the light force. (Inherited from WoWUnit.)
Public property | LightForcePercentage | Gets the percentage light force. (Inherited from WoWUnit.)
Public property | Mana | Gets the mana. (Inherited from WoWUnit.)
Public property | ManaPercentage | Gets the mana percentage. (Inherited from WoWUnit.)
Public property | MapPositionLua | Gets the map position lua (X = MapPositionLua[0], Y = MapPositionLua[1]).
Public property | MaxAlternate | Gets the maximum alternate. (Inherited from WoWUnit.)
Public property | MaxArcaneCharges | Gets the maximum arcane charges. (Inherited from WoWUnit.)
Public property | MaxBurningEmbers | Gets the max Burning Embers. (Inherited from WoWUnit.)
Public property | MaxChi | Gets the maximum chi. (Inherited from WoWUnit.)
Public property | MaxDarkForce | Gets the max dark force. (Inherited from WoWUnit.)
Public property | MaxDemonicFury | Gets the max Demonic Fury. (Inherited from WoWUnit.)
Public property | MaxEclipse | (Inherited from WoWPlayer.)
Public property | MaxEnergy | Gets the maximum energy. (Inherited from WoWUnit.)
Public property | MaxFocus | Gets the maximum focus. (Inherited from WoWUnit.)
Public property | MaxHealth | Gets the maximum health. (Inherited from WoWUnit.)
Public property | MaxHolyPower | Gets the maximum holy power. (Inherited from WoWUnit.)
Public property | MaxLightForce | Gets the max light force. (Inherited from WoWUnit.)
Public property | MaxMana | Gets the maximum mana. (Inherited from WoWUnit.)
Public property | MaxRage | Gets the maximum rage. (Inherited from WoWUnit.)
Public property | MaxRunes | Gets the maximum runes. (Inherited from WoWUnit.)
Public property | MaxRunicPower | Gets the maximum runic power. (Inherited from WoWUnit.)
Public property | MaxShadowOrbs | Gets the max Shadow Orbs. (Inherited from WoWUnit.)
Public property | MaxSoulShards | Gets the maximum soul shards. (Inherited from WoWUnit.)
Public property | MeCreatureTrack | Gets or sets creatures to track.
Public property | MeObjectTrack | Gets or sets objects to track.
Public property | MinEclipse | (Inherited from WoWPlayer.)
Public property | MountDisplayId | Gets the mount display id. (Inherited from WoWUnit.)
Public property | MouseOverGuid | Gets or sets the mouse over GUID.
Public property | MouseOverObj | Gets the mouse over object.
Public property | MyCharacterInFrontHim | Gets a value indicating whether my character in front him. (Inherited from WoWUnit.)
Public property | Name | Gets the name.
Public property | NotSelectable | Gets a value indicating whether not selectable. (Inherited from WoWUnit.)
Public property | NpcFlightMastrerIsDiscover | FlightMastrer is discover. (Inherited from WoWUnit.)
Public property | NpcMarker | Gets the NPC marker. (Inherited from WoWUnit.)
Public property | NpcMarkerId | Gets the NPC marker id (used by NpcMarker). (Inherited from WoWUnit.)
Public property | Pacified | Gets a value indicating whether is pacified. (Inherited from WoWUnit.)
Public property | PetNumber | Gets the pet number. (Inherited from WoWUnit.)
Public property | PetOwnerGuid | Gets the pet owner GUID. (Inherited from WoWUnit.)
Public property | Pitch | Gets or sets the pitch. (Inherited from WoWUnit.)
Public property | PlayerControlled | Gets a value indicating whether player controlled. (Inherited from WoWUnit.)
Public property | PlayerFaction | Gets the player faction (value like "Alliance", "Horde", "Neutral"). (Inherited from WoWPlayer.)
Public property | PlayerRace | Gets the player race. (Inherited from WoWPlayer.)
Public property | PlayerRaceString | Gets the player race string. (Inherited from WoWPlayer.)
Public property | PlayerUsingVehicle | Gets a value indicating whether player using vehicle.
Public property | Position | Gets the position. (Inherited from WoWUnit.)
Public property | PositionCorpse | Gets corpse position.
Public property | PositionRelativeWithoutType | Gets position relative without type (more information about relative position here: UseRelativePosition). (Inherited from WoWUnit.)
Public property | PositionWithoutType | Gets position without type (without "Flying", ....). (Inherited from WoWUnit.)
Public property | Possessed | Gets a value indicating whether is possessed. (Inherited from WoWUnit.)
Public property | PowerType | The unit's power type. (Inherited from WoWPlayer.)
Public property | Rage | Gets the rage. (Inherited from WoWUnit.)
Public property | RagePercentage | Gets the rage percentage. (Inherited from WoWUnit.)
Public property | Reaction | Gets the reaction. (Inherited from WoWUnit.)
Public property | Rooted | Gets a value indicating whether is rooted. (Inherited from WoWUnit.)
Public property | Rotation | Gets or sets the rotation (facing). (Inherited from WoWUnit.)
Public property | Runes | Gets the runes.
Public property | RunesPercentage | Gets the runes percentage. (Inherited from WoWUnit.)
Public property | RunicPower | Gets the runic power. (Inherited from WoWUnit.)
Public property | RunicPowerPercentage | Gets the runic power percentage. (Inherited from WoWUnit.)
Public property | Scale | Gets the scale. (Inherited from WoWObject.)
Public property | ShadowOrbs | Gets the Shadow Orbs. (Inherited from WoWUnit.)
Public property | ShadowOrbsPercentage | Gets the Shadow Orbs percentage. (Inherited from WoWUnit.)
Public property | Silenced | Gets a value indicating whether is silenced. (Inherited from WoWUnit.)
Public property | Skinnable | Gets a value indicating whether is skinnable. (Inherited from WoWUnit.)
Public property | SoulShards | Gets the soul shards. (Inherited from WoWUnit.)
Public property | SoulShardsPercentage | Gets the soul shards percentage. (Inherited from WoWUnit.)
Public property | SpeedMoving | Gets the speed moving. (Inherited from WoWUnit.)
Public property | Summon | Gets the summon. (Inherited from WoWUnit.)
Public property | SummonedBy | Gets the summoned by GUID. (Inherited from WoWUnit.)
Public property | TaggedByMe | Gets a value indicating Tagged By Me. (Inherited from WoWUnit.)
Public property | Target | Gets or sets the target. (Inherited from WoWUnit.)
Public property | TargetObject | Gets the target object. (Inherited from WoWUnit.)
Public property | TransportGuid | Gets the transport GUID (it is WoWGameObject). (Inherited from WoWUnit.)
Public property | Type | Gets the type. (Inherited from WoWObject.)
Public property | UnitClassification | Gets the unit classification. (Inherited from WoWUnit.)
Public property | UnitFlags | Gets the unit flags. (Inherited from WoWUnit.)
Public property | UnitNPCFlags | Gets the unit NPC flags. (Inherited from WoWUnit.)
Public property | WowClass | Gets the wow class. (Inherited from WoWUnit.)
Public property | WowRace | Gets the wow race. (Inherited from WoWPlayer.)

See Also

WoWLocalPlayer Class
wManager.Wow.ObjectManager Namespace


WoWLocalPlayer Constructor

Initializes a new instance of the WoWLocalPlayer class.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public WoWLocalPlayer(
    uint address
)
Public Sub New ( _
    address As UInteger _
)
public:
WoWLocalPlayer(
    unsigned int^ address
)

Parameters

address
Type: UInt32
The address.

See Also

WoWLocalPlayer Class
wManager.Wow.ObjectManager Namespace


WoWLocalPlayer Fields

The WoWLocalPlayer type exposes the following members.

Fields

 | Name | Description
Public field | ForceIsCast | Force IsCast

See Also

WoWLocalPlayer Class
wManager.Wow.ObjectManager Namespace


ForceIsCast Field

WoWLocalPlayer..::..ForceIsCast Field

Force IsCast

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool ForceIsCast
Public ForceIsCast As Boolean
public:
bool^ ForceIsCast

See Also

WoWLocalPlayer Class
wManager.Wow.ObjectManager Namespace


WoWLocalPlayer Methods

The WoWLocalPlayer type exposes the following members.

Methods

 | Name | Description
Public method | BuffCastedBy | Buff casted by. (Inherited from WoWUnit.)
Public method | BuffCastedByAll | Buff casted by all. (Inherited from WoWUnit.)
Public method | BuffStack(List<(Of <<'(UInt32>)>>)) | Buff stack count. (Inherited from WoWUnit.)
Public method | BuffStack(UInt32) | Buff stack count. (Inherited from WoWUnit.)
Public method | BuffStack(String) | Buff stack count. (Inherited from WoWUnit.)
Public method | BuffTimeLeft(String) | Buff time left. (Inherited from WoWUnit.)
Public method | BuffTimeLeft(List<(Of <<'(UInt32>)>>)) | Buff time left. (Inherited from WoWUnit.)
Public method | CooldownEnabled(UInt32) | Cooldown enabled.
Public method | CooldownEnabled(String, Boolean) | Cooldown enabled.
Public method | CooldownTimeLeft(UInt32) | Cooldown time left.
Public method | CooldownTimeLeft(String, Boolean) | Cooldown time left.
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAllBuff | Gets all buff. (Inherited from WoWUnit.)
Public method | GetBuff(String) | Gets the buff. (Inherited from WoWUnit.)
Public method | GetBuff(List<(Of <<'(UInt32>)>>)) | Gets the buff. (Inherited from WoWUnit.)
Public method | GetBuffs(String) | Gets the buffs. (Inherited from WoWUnit.)
Public method | GetBuffs(List<(Of <<'(UInt32>)>>)) | Gets the buffs. (Inherited from WoWUnit.)
Public method | GetCorpseRecoveryDelay | Gets the corpse recovery delay.
Public method | GetDescriptorAddress(Descriptors..::..PlayerFields) | (Inherited from WoWPlayer.)
Public method | GetDescriptorAddress(Descriptors..::..UnitFields) | (Inherited from WoWUnit.)
Public method | GetDescriptorAddress(Descriptors..::..ObjectFields) | Gets the descriptor address. (Inherited from WoWObject.)
Public method | GetDescriptorAddress(UInt32) | Gets the descriptor address. (Inherited from WoWObject.)
Public method | GetDescriptorAddress(UInt32, UInt32) | Gets the descriptor address. (Inherited from WoWObject.)
Public method | GetEquipedItemBySlot | Gets the equipped item by slot. (Inherited from WoWPlayer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetMaxPowerByPowerType | Gets maximum power value by type. (Inherited from WoWUnit.)
Public method | GetMovementFlag | Gets if movement flag is present. (Inherited from WoWUnit.)
Public method | GetMyBuff | Gets my buff. (Inherited from WoWUnit.)
Public method | GetPowerByPowerType | Gets power value by power type. (Inherited from WoWUnit.)
Public method | GetRunes()()()() | Gets the runes.
Public method | GetRunes(RuneTypes) | Gets the runes by type.
Public method | GetRunesReady(RuneTypes) | Gets the runes readies by type.
Public method | GetRunesReady()()()() | Gets the runes readies.
Public method | GetType | (Inherited from Object.)
Public method | HaveBuff(String) | Has the buff. (Inherited from WoWUnit.)
Public method | HaveBuff(List<(Of <<'(UInt32>)>>)) | Has the buff. (Inherited from WoWUnit.)
Public method | HaveBuff(UInt32) | Has the buff. (Inherited from WoWUnit.)
Public method | IsAchievementCompleted | Determines whether achievement is completed.
Public method | IsBehind | Determines whether the specified target position is behind. (Inherited from WoWUnit.)
Public method | IsFacing | Determines whether the specified target position is facing. (Inherited from WoWUnit.)
Public method | IsLooting | Determines whether is looting.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | MoneyStringFormat()()()() | GetMoneyCopper to string format (CopperToString(Int64))
Public method | MoneyStringFormat(Int64) | Money to string format (CopperToString(Int64)).
Public method | RuneIsReady | Rune slot is ready.
Public method | RunesReadyCount()()()() | Runes readies count.
Public method | RunesReadyCount(RuneTypes) | Runes ready count.
Public method | ToString | Returns a String that represents this instance. (Inherited from WoWObject.)
Public method | TotemExist | Totem exist.
Public method | TotemTimeLeft | Totem time left.

See Also

WoWLocalPlayer Class
wManager.Wow.ObjectManager Namespace


CooldownEnabled Method

WoWLocalPlayer..::..CooldownEnabled Method

Overload List

 | Name | Description
Public method | CooldownEnabled(UInt32) | Cooldown enabled.
Public method | CooldownEnabled(String, Boolean) | Cooldown enabled.

See Also

WoWLocalPlayer Class
WoWLocalPlayer Members
wManager.Wow.ObjectManager Namespace


CooldownEnabled Method (UInt32)

WoWLocalPlayer..::..CooldownEnabled Method (UInt32)

Cooldown enabled.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool CooldownEnabled(
    uint spellId
)
Public Function CooldownEnabled ( _
    spellId As UInteger _
) As Boolean
public:
bool^ CooldownEnabled(
    unsigned int^ spellId
)

Parameters

spellId
Type: UInt32
The spell id.

Return Value

true if enabled, false otherwise.

See Also

WoWLocalPlayer Class
CooldownEnabled Overload
wManager.Wow.ObjectManager Namespace


CooldownEnabled Method (String, Boolean)

WoWLocalPlayer..::..CooldownEnabled Method (String, Boolean)

Cooldown enabled.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool CooldownEnabled(
    string spellName,
    bool isSpellNameInGame
)
Public Function CooldownEnabled ( _
    spellName As String, _
    isSpellNameInGame As Boolean _
) As Boolean
public:
bool^ CooldownEnabled(
    String^ spellName,
    bool^ isSpellNameInGame
)

Parameters

spellName
Type: String
The spell name.
isSpellNameInGame
Type: Boolean
if set to true is spell name in game (if false it is english name)).

Return Value

true if enabled, false otherwise.

See Also

WoWLocalPlayer Class
CooldownEnabled Overload
wManager.Wow.ObjectManager Namespace


CooldownTimeLeft Method

WoWLocalPlayer..::..CooldownTimeLeft Method

Overload List

 | Name | Description
Public method | CooldownTimeLeft(UInt32) | Cooldown time left.
Public method | CooldownTimeLeft(String, Boolean) | Cooldown time left.

See Also

WoWLocalPlayer Class
WoWLocalPlayer Members
wManager.Wow.ObjectManager Namespace


CooldownTimeLeft Method (UInt32)

WoWLocalPlayer..::..CooldownTimeLeft Method (UInt32)

Cooldown time left.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int CooldownTimeLeft(
    uint spellId
)
Public Function CooldownTimeLeft ( _
    spellId As UInteger _
) As Integer
public:
int^ CooldownTimeLeft(
    unsigned int^ spellId
)

Parameters

spellId
Type: UInt32
The spell id.

Return Value

time left.

See Also

WoWLocalPlayer Class
CooldownTimeLeft Overload
wManager.Wow.ObjectManager Namespace


CooldownTimeLeft Method (String, Boolean)

WoWLocalPlayer..::..CooldownTimeLeft Method (String, Boolean)

Cooldown time left.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int CooldownTimeLeft(
    string spellName,
    bool isSpellNameInGame
)
Public Function CooldownTimeLeft ( _
    spellName As String, _
    isSpellNameInGame As Boolean _
) As Integer
public:
int^ CooldownTimeLeft(
    String^ spellName,
    bool^ isSpellNameInGame
)

Parameters

spellName
Type: String
Name of spell.
isSpellNameInGame
Type: Boolean
if set to true is spell name in game (if false it is english name)).

Return Value

System.Int32.

See Also

WoWLocalPlayer Class
CooldownTimeLeft Overload
wManager.Wow.ObjectManager Namespace


GetCorpseRecoveryDelay Method

WoWLocalPlayer..::..GetCorpseRecoveryDelay Method

Gets the corpse recovery delay.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int GetCorpseRecoveryDelay()
Public Function GetCorpseRecoveryDelay As Integer
public:
int^ GetCorpseRecoveryDelay()

Return Value

System.Int32.

See Also

WoWLocalPlayer Class
wManager.Wow.ObjectManager Namespace


GetRunes Method

WoWLocalPlayer..::..GetRunes Method

Overload List

 | Name | Description
Public method | GetRunes()()()() | Gets the runes.
Public method | GetRunes(RuneTypes) | Gets the runes by type.

See Also

WoWLocalPlayer Class
WoWLocalPlayer Members
wManager.Wow.ObjectManager Namespace


GetRunes Method

WoWLocalPlayer..::..GetRunes Method

Gets the runes.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public RuneStruct[] GetRunes()
Public Function GetRunes As RuneStruct()
public:
array<RuneStruct^>^ GetRunes()

Return Value

RuneStruct[].

See Also

WoWLocalPlayer Class
GetRunes Overload
wManager.Wow.ObjectManager Namespace


GetRunes Method (RuneTypes)

WoWLocalPlayer..::..GetRunes Method (RuneTypes)

Gets the runes by type.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<RuneStruct> GetRunes(
    RuneTypes type
)
Public Function GetRunes ( _
    type As RuneTypes _
) As List(Of RuneStruct)
public:
List<RuneStruct^>^ GetRunes(
    RuneTypes^ type
)

Parameters

type
Type: wManager.Wow.Enums..::..RuneTypes

Return Value

runes readies.

See Also

WoWLocalPlayer Class
GetRunes Overload
wManager.Wow.ObjectManager Namespace


GetRunesReady Method

WoWLocalPlayer..::..GetRunesReady Method

Overload List

 | Name | Description
Public method | GetRunesReady(RuneTypes) | Gets the runes readies by type.
Public method | GetRunesReady()()()() | Gets the runes readies.

See Also

WoWLocalPlayer Class
WoWLocalPlayer Members
wManager.Wow.ObjectManager Namespace


GetRunesReady Method (RuneTypes)

WoWLocalPlayer..::..GetRunesReady Method (RuneTypes)

Gets the runes readies by type.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<RuneStruct> GetRunesReady(
    RuneTypes type
)
Public Function GetRunesReady ( _
    type As RuneTypes _
) As List(Of RuneStruct)
public:
List<RuneStruct^>^ GetRunesReady(
    RuneTypes^ type
)

Parameters

type
Type: wManager.Wow.Enums..::..RuneTypes

Return Value

runes readies.

See Also

WoWLocalPlayer Class
GetRunesReady Overload
wManager.Wow.ObjectManager Namespace


GetRunesReady Method

WoWLocalPlayer..::..GetRunesReady Method

Gets the runes readies.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<RuneStruct> GetRunesReady()
Public Function GetRunesReady As List(Of RuneStruct)
public:
List<RuneStruct^>^ GetRunesReady()

Return Value

runes readies.

See Also

WoWLocalPlayer Class
GetRunesReady Overload
wManager.Wow.ObjectManager Namespace


IsAchievementCompleted Method

WoWLocalPlayer..::..IsAchievementCompleted Method

Determines whether achievement is completed.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsAchievementCompleted(
    int achievementID,
    int index
)
Public Function IsAchievementCompleted ( _
    achievementID As Integer, _
    index As Integer _
) As Boolean
public:
bool^ IsAchievementCompleted(
    int^ achievementID,
    int^ index
)

Parameters

achievementID
Type: Int32
ID of the achievement (or achievement category ID) to retrieve information for.
index
Type: Int32
If you use achievement ID use -1, if you use achievement category ID select offset into the achievement category, between 1 and number of achievements.

Return Value

true if achievement is completed; otherwise, false.

See Also

WoWLocalPlayer Class
wManager.Wow.ObjectManager Namespace


IsLooting Method

WoWLocalPlayer..::..IsLooting Method

Determines whether is looting.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsLooting()
Public Function IsLooting As Boolean
public:
bool^ IsLooting()

Return Value

true if is looting; otherwise, false.

See Also

WoWLocalPlayer Class
wManager.Wow.ObjectManager Namespace


MoneyStringFormat Method

WoWLocalPlayer..::..MoneyStringFormat Method

Overload List

 | Name | Description
Public method | MoneyStringFormat()()()() | GetMoneyCopper to string format (CopperToString(Int64))
Public method | MoneyStringFormat(Int64) | Money to string format (CopperToString(Int64)).

See Also

WoWLocalPlayer Class
WoWLocalPlayer Members
wManager.Wow.ObjectManager Namespace


MoneyStringFormat Method

WoWLocalPlayer..::..MoneyStringFormat Method

GetMoneyCopper to string format (CopperToString(Int64))

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string MoneyStringFormat()
Public Function MoneyStringFormat As String
public:
String^ MoneyStringFormat()

Return Value

System.String.

See Also

WoWLocalPlayer Class
MoneyStringFormat Overload
wManager.Wow.ObjectManager Namespace


MoneyStringFormat Method (Int64)

WoWLocalPlayer..::..MoneyStringFormat Method (Int64)

Money to string format (CopperToString(Int64)).

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string MoneyStringFormat(
    long copperMoney
)
Public Function MoneyStringFormat ( _
    copperMoney As Long _
) As String
public:
String^ MoneyStringFormat(
    long long^ copperMoney
)

Parameters

copperMoney
Type: Int64
The copper money.

Return Value

System.String.

See Also

WoWLocalPlayer Class
MoneyStringFormat Overload
wManager.Wow.ObjectManager Namespace


RuneIsReady Method

WoWLocalPlayer..::..RuneIsReady Method

Rune slot is ready.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool RuneIsReady(
    int slotId
)
Public Function RuneIsReady ( _
    slotId As Integer _
) As Boolean
public:
bool^ RuneIsReady(
    int^ slotId
)

Parameters

slotId
Type: Int32
The slot identifier.

Return Value

true if ready, false otherwise.

See Also

WoWLocalPlayer Class
wManager.Wow.ObjectManager Namespace


RunesReadyCount Method

WoWLocalPlayer..::..RunesReadyCount Method

Overload List

 | Name | Description
Public method | RunesReadyCount()()()() | Runes readies count.
Public method | RunesReadyCount(RuneTypes) | Runes ready count.

See Also

WoWLocalPlayer Class
WoWLocalPlayer Members
wManager.Wow.ObjectManager Namespace


RunesReadyCount Method

WoWLocalPlayer..::..RunesReadyCount Method

Runes readies count.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int RunesReadyCount()
Public Function RunesReadyCount As Integer
public:
int^ RunesReadyCount()

Return Value

Runes readies count.

See Also

WoWLocalPlayer Class
RunesReadyCount Overload
wManager.Wow.ObjectManager Namespace


RunesReadyCount Method (RuneTypes)

WoWLocalPlayer..::..RunesReadyCount Method (RuneTypes)

Runes ready count.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int RunesReadyCount(
    RuneTypes type
)
Public Function RunesReadyCount ( _
    type As RuneTypes _
) As Integer
public:
int^ RunesReadyCount(
    RuneTypes^ type
)

Parameters

type
Type: wManager.Wow.Enums..::..RuneTypes

Return Value

int.

See Also

WoWLocalPlayer Class
RunesReadyCount Overload
wManager.Wow.ObjectManager Namespace


TotemExist Method

WoWLocalPlayer..::..TotemExist Method

Totem exist.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool TotemExist(
    TotemType totemType
)
Public Function TotemExist ( _
    totemType As TotemType _
) As Boolean
public:
bool^ TotemExist(
    TotemType^ totemType
)

Parameters

totemType
Type: wManager.Wow.Enums..::..TotemType
Type of the totem.

Return Value

true if exist, false otherwise.

See Also

WoWLocalPlayer Class
wManager.Wow.ObjectManager Namespace


TotemTimeLeft Method

WoWLocalPlayer..::..TotemTimeLeft Method

Totem time left.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int TotemTimeLeft(
    TotemType totemType
)
Public Function TotemTimeLeft ( _
    totemType As TotemType _
) As Integer
public:
int^ TotemTimeLeft(
    TotemType^ totemType
)

Parameters

totemType
Type: wManager.Wow.Enums..::..TotemType
Type of the totem.

Return Value

time left.

See Also

WoWLocalPlayer Class
wManager.Wow.ObjectManager Namespace


WoWLocalPlayer Properties

The WoWLocalPlayer type exposes the following members.

Properties

 | Name | Description
Public property | AggroDistance | Gets the aggro distance. (Inherited from WoWUnit.)
Public property | Alternate | Gets the alternate. (Inherited from WoWUnit.)
Public property | AlternatePercentage | Gets the alternate percentage. (Inherited from WoWUnit.)
Public property | ArcaneCharges | Gets the arcane charges. (Inherited from WoWUnit.)
Public property | ArcaneChargesPercentage | Gets the arcane charges percentage. (Inherited from WoWUnit.)
Public property | BarTwo | Gets the bar two value. (Inherited from WoWPlayer.)
Public property | BarTwoMax | Gets the bar two max value. (Inherited from WoWPlayer.)
Public property | BarTwoPercentage | Gets the bar two percentage. (Inherited from WoWPlayer.)
Protected property | BaseAddress | (Inherited from WoWObject.)
Protected property | BaseDescriptorAddressCACHE | (Inherited from WoWObject.)
Public property | BreathActive | Gets a value indicating whether breath active.
Public property | BreathTimerLeft | Gets the breath timer left.
Public property | BurningEmbers | Gets the Burning Embers. (Inherited from WoWUnit.)
Public property | BurningEmbersPercentage | Gets the Burning Embers percentage. (Inherited from WoWUnit.)
Public property | CanInterruptCasting | Gets a value indicating whether can interrupt casting. (Inherited from WoWUnit.)
Public property | CanMove | Gets a value indicating whether can move (!IsCast && !Influenced && !IsStunned && !IsOnTaxi).
Public property | CastingSpell | Gets the casting spell. (Inherited from WoWUnit.)
Public property | CastingSpellId | Gets the casting spell id. (Inherited from WoWUnit.)
Public property | CastingTimeLeft | Gets the casting time left (in milliseconds). (Inherited from WoWUnit.)
Public property | Chi | Gets the chi. (Inherited from WoWUnit.)
Public property | ChiPercentage | Gets the chi percentage. (Inherited from WoWUnit.)
Public property | CombatReach | Gets the combat reach. (Inherited from WoWUnit.)
Public property | ComboPoint | Gets the combo point. (Inherited from WoWPlayer.)
Public property | Confused | Gets a value indicating whether is confused. (Inherited from WoWUnit.)
Public property | CreatedBy | Gets the created by. (Inherited from WoWUnit.)
Public property | CreatedBySpell | Gets spell id used to create him. (Inherited from WoWUnit.)
Public property | CreatureTypeTarget | Gets the creature type target (work only in unit is your current target). (Inherited from WoWUnit.)
Public property | DarkForce | Gets the dark force. (Inherited from WoWUnit.)
Public property | DarkForcePercentage | Gets the percentage dark force. (Inherited from WoWUnit.)
Public property | DBCacheRow | Gets the database cache row. (Inherited from WoWUnit.)
Public property | DemonicFury | Gets the Demonic Fury. (Inherited from WoWUnit.)
Public property | DemonicFuryPercentage | Gets the Demonic Fury percentage. (Inherited from WoWUnit.)
Public property | DisplayId | Gets the display id. (Inherited from WoWUnit.)
Public property | Eclipse | (Inherited from WoWPlayer.)
Public property | EclipsePercentage | (Inherited from WoWPlayer.)
Public property | Energy | Gets the energy. (Inherited from WoWUnit.)
Public property | EnergyPercentage | Gets the energy percentage. (Inherited from WoWUnit.)
Public property | Entry | (Inherited from WoWObject.)
Public property | Experience | Gets experience.
Public property | ExperienceMax | Gets experience maximum.
Public property | Faction | Gets the faction. (Inherited from WoWUnit.)
Public property | FactionTemplate | Gets the faction template. (Inherited from WoWUnit.)
Public property | FatigueActive | Gets a value indicating whether fatigue active.
Public property | FatigueTimerLeft | Gets the fatigue timer left.
Public property | Fleeing | Gets a value indicating whether is fleeing. (Inherited from WoWUnit.)
Public property | Focus | Gets the focus. (Inherited from WoWUnit.)
Public property | FocusGuid | Gets or sets the focus GUID.
Public property | FocusObj | Gets the focus object.
Public property | FocusPercentage | Gets the focus percentage. (Inherited from WoWUnit.)
Public property | GeHitBoxtDistance | Gets the HitBox distance. (Inherited from WoWUnit.)
Public property | Gender | Gets the gender.
Public property | GetBaseAddress | Gets the base address. (Inherited from WoWObject.)
Public property | GetDescriptorStartAddress | Gets the descriptor start address. (Inherited from WoWObject.)
Public property | GetDistance | Gets the get distance (from local player). (Inherited from WoWUnit.)
Public property | GetDistance2D | Gets the get distance 2D (from local player). (Inherited from WoWUnit.)
Public property | GetDistanceZ | Gets the get distance Z (from local player). (Inherited from WoWUnit.)
Public property | GetDurabilityPercent | Gets the durability percent.
Public property | GetDynamicFlags | Gets the unit dynamic flags. (Inherited from WoWUnit.)
Public property | GetEquipedItem | Gets the get equipped items. (Inherited from WoWPlayer.)
Public property | GetHonorPoint | Gets the honor point.
Public property | GetLowerItemDurabilityPercent | Gets the lower item durability percent.
Public property | GetMoneyCopper | Gets the money copper.
Public property | GetMove | Gets a value indicating whether get move. (Inherited from WoWUnit.)
Public property | GetUnitDynamicFlags | Gets the unit dynamic flags. (Inherited from WoWUnit.)
Public property | GetWeaponDurabilityPercent | Gets the weapon durability percent.
Public property | GlobalCooldownEnabled | Gets a value indicating whether global cooldown enabled.
Public property | GlobalCooldownTimeLeft | Gets the global cooldown time left.
Public property | Guid | Gets the GUID. (Inherited from WoWObject.)
Public property | HasFocus | Gets a value indicating whether has focus.
Public property | HasMouseOver | Gets a value indicating whether has mouse over.
Public property | HasNewMail | Gets a value indicating whether has new mail.
Public property | HasTarget | Gets a value indicating whether has target. (Inherited from WoWUnit.)
Public property | Health | Gets the health. (Inherited from WoWUnit.)
Public property | HealthPercent | Gets the health percent. (Inherited from WoWUnit.)
Public property | HealthRatio | Gets the health ratio. (Inherited from WoWUnit.)
Public property | HolyPower | Gets the holy power. (Inherited from WoWUnit.)
Public property | HolyPowerPercentage | Gets the holy power percentage. (Inherited from WoWUnit.)
Public property | InCombat | Gets a value indicating whether in combat (relating to bot configurations/blacklist, to check if the game determined you are in combat use InCombatFlagOnly).
Public property | InCombatFlagOnly | Gets a value indicating whether in combat flag only. (Inherited from WoWUnit.)
Public property | InCombatWithMe | Gets a value indicating whether in combat with me. (Inherited from WoWUnit.)
Public property | Influenced | Gets a value indicating whether is influenced. (Inherited from WoWUnit.)
Public property | InteractDistance | Gets or sets the interact distance (you can adjust with MinInteractDistance, MaxInteractDistance and InteractDistanceByEntry, if you set value it is save to InteractDistanceByEntry). (Inherited from WoWUnit.)
Public property | InTransport | Gets a value indicating whether in transport. (Inherited from WoWUnit.)
Public property | InvSlots |
Public property | IsAlive | Gets a value indicating whether is alive. (Inherited from WoWUnit.)
Public property | IsAlliance | Gets a value indicating whether is in alliance. (Inherited from WoWPlayer.)
Public property | IsAttackable | Gets a value indicating whether is attackable. (Inherited from WoWUnit.)
Public property | IsAuctioneer | Gets a value indicating whether is auctioneer. (Inherited from WoWUnit.)
Public property | IsBlacklisted | Gets a value indicating whether is blacklisted. (Inherited from WoWUnit.)
Public property | IsBoss | Gets a value indicating whether is boss. (Inherited from WoWUnit.)
Public property | IsCast | Gets a value indicating whether is cast (can be force with ForceIsCast).
Public property | IsDead | Gets a value indicating whether is dead (call IsDeadMe).
Public property | IsDeadMe | Gets a value indicating whether is dead.
Public property | IsElite | Gets a value indicating whether is elite. (Inherited from WoWUnit.)
Public property | IsFlightMaster | Gets a value indicating whether is flight master. (Inherited from WoWUnit.)
Public property | IsFlying | Gets a value indicating whether is flying. (Inherited from WoWUnit.)
Public property | IsGoodInteractDistance | Gets a value indicating whether is good interact distance (look InteractDistance). (Inherited from WoWUnit.)
Public property | IsHorde | Gets a value indicating whether is in horde. (Inherited from WoWPlayer.)
Public property | IsIndoors | Gets a value indicating whether is indoors. (Inherited from WoWUnit.)
Public property | IsInGroup | Gets a value indicating whether is in group.
Public property | IsInParty | Gets a value indicating whethe is in party.
Public property | IsInPetBattle | Gets a value indicating whether in pet battle.
Public property | IsLocalPlayer | Gets a value indicating whether is local player. (Inherited from WoWUnit.)
Public property | IsLootable | Gets a value indicating whether is lootable. (Inherited from WoWUnit.)
Public property | IsMeOrMyPetOrPartyMemberTarget | Gets a value indicating whether is my target or my pet or party member target. (Inherited from WoWUnit.)
Public property | IsMeOrMyPetTarget | Gets a value indicating whether is my target or my pet target. (Inherited from WoWUnit.)
Public property | IsMounted | Gets a value indicating whether is mounted.
Public property | IsMyPet | Gets a value indicating whether is my pet. (Inherited from WoWUnit.)
Public property | IsMyPetTarget | Gets a value indicating whether is my pet target. (Inherited from WoWUnit.)
Public property | IsMyTarget | Gets a value indicating whether is my target. (Inherited from WoWUnit.)
Public property | IsNeutral | Gets a value indicating whether is neutral (no horde or alliance faction). (Inherited from WoWPlayer.)
Public property | IsNpcInnkeeper | Gets a value indicating whether is NPC innkeeper. (Inherited from WoWUnit.)
Public property | IsNpcRepair | Gets a value indicating whether is NPC repair. (Inherited from WoWUnit.)
Public property | IsNpcSpiritHealer | Gets a value indicating whether is NPC spirit healer. (Inherited from WoWUnit.)
Public property | IsNpcTrainer | Gets a value indicating whether is NPC trainer. (Inherited from WoWUnit.)
Public property | IsNpcVendor | Gets a value indicating whether is NPC vendor. (Inherited from WoWUnit.)
Public property | IsNpcVendorFood | Gets a value indicating whether is NPC vendor food. (Inherited from WoWUnit.)
Public property | IsNpcWildPets | Gets a value indicating whether is NPC wild pets. (Inherited from WoWUnit.)
Public property | IsOnTaxi | Gets a value indicating whether is on taxi. (Inherited from WoWUnit.)
Public property | IsOutdoors | Gets a value indicating whether is outdoors. (Inherited from WoWUnit.)
Public property | IsPartyLeader | Gets a value indicating whether is party leader. (Inherited from WoWUnit.)
Public property | IsPartyMember | Gets a value indicating whether is party member.
Public property | IsPartyMemberTarget | Gets a value indicating whether is party member target. (Inherited from WoWUnit.)
Public property | IsPet | Gets a value indicating whether is pet. (Inherited from WoWUnit.)
Public property | IsStunned | Gets a value indicating whether is stunned. (Inherited from WoWUnit.)
Public property | IsSwimming | Gets a value indicating whether is swimming. (Inherited from WoWUnit.)
Public property | IsTaggedByOther | Gets a value indicating Tagged By Other. (Inherited from WoWUnit.)
Public property | IsTapDenied | Gets a value indicating whether is tap denied. (Inherited from WoWUnit.)
Public property | IsTargetingMe | Gets a value indicating whether is targeting me. (Inherited from WoWUnit.)
Public property | IsTargetingMeOrMyPet | Gets a value indicating whether is targeting me or my pet. (Inherited from WoWUnit.)
Public property | IsTargetingMeOrMyPetOrPartyMember | Gets a value indicating whether is targeting me or my pet or (my) party member. (Inherited from WoWUnit.)
Public property | IsTargetingMyPet | Gets a value indicating whether is targeting my pet. (Inherited from WoWUnit.)
Public property | IsTargetingPartyMember | Gets a value indicating whether is targeting (my) party member. (Inherited from WoWUnit.)
Public property | IsTracked | Gets or sets a value indicating whether is tracked (in in-game minimap). (Inherited from WoWUnit.)
Public property | IsValid | Returns true if is valid. (Inherited from WoWObject.)
Public property | IsWorldBoss | Gets a value indicating whether is world boss. (Inherited from WoWUnit.)
Public property | Level | Gets the level. (Inherited from WoWUnit.)
Public property | LevelDecimal | Gets level decimal (Level + Experience / ExperienceMax).
Public property | LightForce | Gets the light force. (Inherited from WoWUnit.)
Public property | LightForcePercentage | Gets the percentage light force. (Inherited from WoWUnit.)
Public property | Mana | Gets the mana. (Inherited from WoWUnit.)
Public property | ManaPercentage | Gets the mana percentage. (Inherited from WoWUnit.)
Public property | MapPositionLua | Gets the map position lua (X = MapPositionLua[0], Y = MapPositionLua[1]).
Public property | MaxAlternate | Gets the maximum alternate. (Inherited from WoWUnit.)
Public property | MaxArcaneCharges | Gets the maximum arcane charges. (Inherited from WoWUnit.)
Public property | MaxBurningEmbers | Gets the max Burning Embers. (Inherited from WoWUnit.)
Public property | MaxChi | Gets the maximum chi. (Inherited from WoWUnit.)
Public property | MaxDarkForce | Gets the max dark force. (Inherited from WoWUnit.)
Public property | MaxDemonicFury | Gets the max Demonic Fury. (Inherited from WoWUnit.)
Public property | MaxEclipse | (Inherited from WoWPlayer.)
Public property | MaxEnergy | Gets the maximum energy. (Inherited from WoWUnit.)
Public property | MaxFocus | Gets the maximum focus. (Inherited from WoWUnit.)
Public property | MaxHealth | Gets the maximum health. (Inherited from WoWUnit.)
Public property | MaxHolyPower | Gets the maximum holy power. (Inherited from WoWUnit.)
Public property | MaxLightForce | Gets the max light force. (Inherited from WoWUnit.)
Public property | MaxMana | Gets the maximum mana. (Inherited from WoWUnit.)
Public property | MaxRage | Gets the maximum rage. (Inherited from WoWUnit.)
Public property | MaxRunes | Gets the maximum runes. (Inherited from WoWUnit.)
Public property | MaxRunicPower | Gets the maximum runic power. (Inherited from WoWUnit.)
Public property | MaxShadowOrbs | Gets the max Shadow Orbs. (Inherited from WoWUnit.)
Public property | MaxSoulShards | Gets the maximum soul shards. (Inherited from WoWUnit.)
Public property | MeCreatureTrack | Gets or sets creatures to track.
Public property | MeObjectTrack | Gets or sets objects to track.
Public property | MinEclipse | (Inherited from WoWPlayer.)
Public property | MountDisplayId | Gets the mount display id. (Inherited from WoWUnit.)
Public property | MouseOverGuid | Gets or sets the mouse over GUID.
Public property | MouseOverObj | Gets the mouse over object.
Public property | MyCharacterInFrontHim | Gets a value indicating whether my character in front him. (Inherited from WoWUnit.)
Public property | Name | Gets the name.
Public property | NotSelectable | Gets a value indicating whether not selectable. (Inherited from WoWUnit.)
Public property | NpcFlightMastrerIsDiscover | FlightMastrer is discover. (Inherited from WoWUnit.)
Public property | NpcMarker | Gets the NPC marker. (Inherited from WoWUnit.)
Public property | NpcMarkerId | Gets the NPC marker id (used by NpcMarker). (Inherited from WoWUnit.)
Public property | Pacified | Gets a value indicating whether is pacified. (Inherited from WoWUnit.)
Public property | PetNumber | Gets the pet number. (Inherited from WoWUnit.)
Public property | PetOwnerGuid | Gets the pet owner GUID. (Inherited from WoWUnit.)
Public property | Pitch | Gets or sets the pitch. (Inherited from WoWUnit.)
Public property | PlayerControlled | Gets a value indicating whether player controlled. (Inherited from WoWUnit.)
Public property | PlayerFaction | Gets the player faction (value like "Alliance", "Horde", "Neutral"). (Inherited from WoWPlayer.)
Public property | PlayerRace | Gets the player race. (Inherited from WoWPlayer.)
Public property | PlayerRaceString | Gets the player race string. (Inherited from WoWPlayer.)
Public property | PlayerUsingVehicle | Gets a value indicating whether player using vehicle.
Public property | Position | Gets the position. (Inherited from WoWUnit.)
Public property | PositionCorpse | Gets corpse position.
Public property | PositionRelativeWithoutType | Gets position relative without type (more information about relative position here: UseRelativePosition). (Inherited from WoWUnit.)
Public property | PositionWithoutType | Gets position without type (without "Flying", ....). (Inherited from WoWUnit.)
Public property | Possessed | Gets a value indicating whether is possessed. (Inherited from WoWUnit.)
Public property | PowerType | The unit's power type. (Inherited from WoWPlayer.)
Public property | Rage | Gets the rage. (Inherited from WoWUnit.)
Public property | RagePercentage | Gets the rage percentage. (Inherited from WoWUnit.)
Public property | Reaction | Gets the reaction. (Inherited from WoWUnit.)
Public property | Rooted | Gets a value indicating whether is rooted. (Inherited from WoWUnit.)
Public property | Rotation | Gets or sets the rotation (facing). (Inherited from WoWUnit.)
Public property | Runes | Gets the runes.
Public property | RunesPercentage | Gets the runes percentage. (Inherited from WoWUnit.)
Public property | RunicPower | Gets the runic power. (Inherited from WoWUnit.)
Public property | RunicPowerPercentage | Gets the runic power percentage. (Inherited from WoWUnit.)
Public property | Scale | Gets the scale. (Inherited from WoWObject.)
Public property | ShadowOrbs | Gets the Shadow Orbs. (Inherited from WoWUnit.)
Public property | ShadowOrbsPercentage | Gets the Shadow Orbs percentage. (Inherited from WoWUnit.)
Public property | Silenced | Gets a value indicating whether is silenced. (Inherited from WoWUnit.)
Public property | Skinnable | Gets a value indicating whether is skinnable. (Inherited from WoWUnit.)
Public property | SoulShards | Gets the soul shards. (Inherited from WoWUnit.)
Public property | SoulShardsPercentage | Gets the soul shards percentage. (Inherited from WoWUnit.)
Public property | SpeedMoving | Gets the speed moving. (Inherited from WoWUnit.)
Public property | Summon | Gets the summon. (Inherited from WoWUnit.)
Public property | SummonedBy | Gets the summoned by GUID. (Inherited from WoWUnit.)
Public property | TaggedByMe | Gets a value indicating Tagged By Me. (Inherited from WoWUnit.)
Public property | Target | Gets or sets the target. (Inherited from WoWUnit.)
Public property | TargetObject | Gets the target object. (Inherited from WoWUnit.)
Public property | TransportGuid | Gets the transport GUID (it is WoWGameObject). (Inherited from WoWUnit.)
Public property | Type | Gets the type. (Inherited from WoWObject.)
Public property | UnitClassification | Gets the unit classification. (Inherited from WoWUnit.)
Public property | UnitFlags | Gets the unit flags. (Inherited from WoWUnit.)
Public property | UnitNPCFlags | Gets the unit NPC flags. (Inherited from WoWUnit.)
Public property | WowClass | Gets the wow class. (Inherited from WoWUnit.)
Public property | WowRace | Gets the wow race. (Inherited from WoWPlayer.)

See Also

WoWLocalPlayer Class
wManager.Wow.ObjectManager Namespace


BreathActive Property

WoWLocalPlayer..::..BreathActive Property

Gets a value indicating whether breath active.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool BreathActive { get; }
Public ReadOnly Property BreathActive As Boolean
    Get
public:
property bool^ BreathActive {
    bool^ get ();
}

Field Value

true if breath active; otherwise, false.

See Also

WoWLocalPlayer Class
wManager.Wow.ObjectManager Namespace


BreathTimerLeft Property

WoWLocalPlayer..::..BreathTimerLeft Property

Gets the breath timer left.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int BreathTimerLeft { get; }
Public ReadOnly Property BreathTimerLeft As Integer
    Get
public:
property int^ BreathTimerLeft {
    int^ get ();
}

Field Value

The breath timer left.

See Also

WoWLocalPlayer Class
wManager.Wow.ObjectManager Namespace


CanMove Property

WoWLocalPlayer..::..CanMove Property

Gets a value indicating whether can move (!IsCast && !Influenced && !IsStunned && !IsOnTaxi).

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool CanMove { get; }
Public ReadOnly Property CanMove As Boolean
    Get
public:
property bool^ CanMove {
    bool^ get ();
}

Field Value

true if can move; otherwise, false.

See Also

WoWLocalPlayer Class
wManager.Wow.ObjectManager Namespace


Experience Property

WoWLocalPlayer..::..Experience Property

Gets experience.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int Experience { get; }
Public ReadOnly Property Experience As Integer
    Get
public:
property int^ Experience {
    int^ get ();
}

Field Value

The experience.

See Also

WoWLocalPlayer Class
wManager.Wow.ObjectManager Namespace


ExperienceMax Property

WoWLocalPlayer..::..ExperienceMax Property

Gets experience maximum.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int ExperienceMax { get; }
Public ReadOnly Property ExperienceMax As Integer
    Get
public:
property int^ ExperienceMax {
    int^ get ();
}

Field Value

The experience maximum.

See Also

WoWLocalPlayer Class
wManager.Wow.ObjectManager Namespace


FatigueActive Property

WoWLocalPlayer..::..FatigueActive Property

Gets a value indicating whether fatigue active.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool FatigueActive { get; }
Public ReadOnly Property FatigueActive As Boolean
    Get
public:
property bool^ FatigueActive {
    bool^ get ();
}

Field Value

true if fatigue active; otherwise, false.

See Also

WoWLocalPlayer Class
wManager.Wow.ObjectManager Namespace


FatigueTimerLeft Property

WoWLocalPlayer..::..FatigueTimerLeft Property

Gets the fatigue timer left.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int FatigueTimerLeft { get; }
Public ReadOnly Property FatigueTimerLeft As Integer
    Get
public:
property int^ FatigueTimerLeft {
    int^ get ();
}

Field Value

The fatigue timer left.

See Also

WoWLocalPlayer Class
wManager.Wow.ObjectManager Namespace


FocusGuid Property

WoWLocalPlayer..::..FocusGuid Property

Gets or sets the focus GUID.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public ulong FocusGuid { get; set; }
Public Property FocusGuid As ULong
    Get
    Set
public:
property unsigned long long^ FocusGuid {
    unsigned long long^ get ();
    void set (unsigned long long^ value);
}

Field Value

The focus GUID.

See Also

WoWLocalPlayer Class
wManager.Wow.ObjectManager Namespace


FocusObj Property

WoWLocalPlayer..::..FocusObj Property

Gets the focus object.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public WoWUnit FocusObj { get; }
Public ReadOnly Property FocusObj As WoWUnit
    Get
public:
property WoWUnit^ FocusObj {
    WoWUnit^ get ();
}

Field Value

The focus object.

See Also

WoWLocalPlayer Class
wManager.Wow.ObjectManager Namespace


Gender Property

WoWLocalPlayer..::..Gender Property

Gets the gender.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public WoWGender Gender { get; }
Public ReadOnly Property Gender As WoWGender
    Get
public:
property WoWGender^ Gender {
    WoWGender^ get ();
}

Field Value

The gender.

See Also

WoWLocalPlayer Class
wManager.Wow.ObjectManager Namespace


GetDurabilityPercent Property

WoWLocalPlayer..::..GetDurabilityPercent Property

Gets the durability percent.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public double GetDurabilityPercent { get; }
Public ReadOnly Property GetDurabilityPercent As Double
    Get
public:
property double^ GetDurabilityPercent {
    double^ get ();
}

Field Value

The durability percent.

See Also

WoWLocalPlayer Class
wManager.Wow.ObjectManager Namespace


GetHonorPoint Property

WoWLocalPlayer..::..GetHonorPoint Property

Gets the honor point.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int GetHonorPoint { get; }
Public ReadOnly Property GetHonorPoint As Integer
    Get
public:
property int^ GetHonorPoint {
    int^ get ();
}

Field Value

The honor point.

See Also

WoWLocalPlayer Class
wManager.Wow.ObjectManager Namespace


GetLowerItemDurabilityPercent Property

WoWLocalPlayer..::..GetLowerItemDurabilityPercent Property

Gets the lower item durability percent.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public double GetLowerItemDurabilityPercent { get; }
Public ReadOnly Property GetLowerItemDurabilityPercent As Double
    Get
public:
property double^ GetLowerItemDurabilityPercent {
    double^ get ();
}

Field Value

The lower item durability percent.

See Also

WoWLocalPlayer Class
wManager.Wow.ObjectManager Namespace


GetMoneyCopper Property

WoWLocalPlayer..::..GetMoneyCopper Property

Gets the money copper.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public long GetMoneyCopper { get; }
Public ReadOnly Property GetMoneyCopper As Long
    Get
public:
property long long^ GetMoneyCopper {
    long long^ get ();
}

Field Value

The money copper.

See Also

WoWLocalPlayer Class
wManager.Wow.ObjectManager Namespace


GetWeaponDurabilityPercent Property

WoWLocalPlayer..::..GetWeaponDurabilityPercent Property

Gets the weapon durability percent.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public double GetWeaponDurabilityPercent { get; }
Public ReadOnly Property GetWeaponDurabilityPercent As Double
    Get
public:
property double^ GetWeaponDurabilityPercent {
    double^ get ();
}

Field Value

The weapon durability percent.

See Also

WoWLocalPlayer Class
wManager.Wow.ObjectManager Namespace


GlobalCooldownEnabled Property

WoWLocalPlayer..::..GlobalCooldownEnabled Property

Gets a value indicating whether global cooldown enabled.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool GlobalCooldownEnabled { get; }
Public ReadOnly Property GlobalCooldownEnabled As Boolean
    Get
public:
property bool^ GlobalCooldownEnabled {
    bool^ get ();
}

Field Value

true if global cooldown is enabled; otherwise, false.

See Also

WoWLocalPlayer Class
wManager.Wow.ObjectManager Namespace


GlobalCooldownTimeLeft Property

WoWLocalPlayer..::..GlobalCooldownTimeLeft Property

Gets the global cooldown time left.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int GlobalCooldownTimeLeft { get; }
Public ReadOnly Property GlobalCooldownTimeLeft As Integer
    Get
public:
property int^ GlobalCooldownTimeLeft {
    int^ get ();
}

Field Value

The global cooldown time left.

See Also

WoWLocalPlayer Class
wManager.Wow.ObjectManager Namespace


HasFocus Property

WoWLocalPlayer..::..HasFocus Property

Gets a value indicating whether has focus.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool HasFocus { get; }
Public ReadOnly Property HasFocus As Boolean
    Get
public:
property bool^ HasFocus {
    bool^ get ();
}

Field Value

true if has focus; otherwise, false.

See Also

WoWLocalPlayer Class
wManager.Wow.ObjectManager Namespace


HasMouseOver Property

WoWLocalPlayer..::..HasMouseOver Property

Gets a value indicating whether has mouse over.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool HasMouseOver { get; }
Public ReadOnly Property HasMouseOver As Boolean
    Get
public:
property bool^ HasMouseOver {
    bool^ get ();
}

Field Value

true if has mouse over; otherwise, false.

See Also

WoWLocalPlayer Class
wManager.Wow.ObjectManager Namespace


HasNewMail Property

WoWLocalPlayer..::..HasNewMail Property

Gets a value indicating whether has new mail.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool HasNewMail { get; }
Public ReadOnly Property HasNewMail As Boolean
    Get
public:
property bool^ HasNewMail {
    bool^ get ();
}

Field Value

true if has new mail; otherwise, false.

See Also

WoWLocalPlayer Class
wManager.Wow.ObjectManager Namespace


InCombat Property

WoWLocalPlayer..::..InCombat Property

Gets a value indicating whether in combat (relating to bot configurations/blacklist, to check if the game determined you are in combat use InCombatFlagOnly).

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool InCombat { get; }
Public ReadOnly Property InCombat As Boolean
    Get
public:
property bool^ InCombat {
    bool^ get ();
}

Field Value

true if in combat; otherwise, false.

See Also

WoWLocalPlayer Class
wManager.Wow.ObjectManager Namespace


InvSlots Property

WoWLocalPlayer..::..InvSlots Property

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<ulong> InvSlots { get; }
Public ReadOnly Property InvSlots As List(Of ULong)
    Get
public:
property List<unsigned long long^>^ InvSlots {
    List<unsigned long long^>^ get ();
}

See Also

WoWLocalPlayer Class
wManager.Wow.ObjectManager Namespace


IsCast Property

WoWLocalPlayer..::..IsCast Property

Gets a value indicating whether is cast (can be force with ForceIsCast).

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsCast { get; }
Public ReadOnly Property IsCast As Boolean
    Get
public:
property bool^ IsCast {
    bool^ get ();
}

Field Value

true if is cast; otherwise, false.

See Also

WoWLocalPlayer Class
wManager.Wow.ObjectManager Namespace


IsDead Property

WoWLocalPlayer..::..IsDead Property

Gets a value indicating whether is dead (call IsDeadMe).

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsDead { get; }
Public ReadOnly Property IsDead As Boolean
    Get
public:
property bool^ IsDead {
    bool^ get ();
}

Field Value

true if is dead; otherwise, false.

See Also

WoWLocalPlayer Class
wManager.Wow.ObjectManager Namespace


IsDeadMe Property

WoWLocalPlayer..::..IsDeadMe Property

Gets a value indicating whether is dead.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsDeadMe { get; }
Public ReadOnly Property IsDeadMe As Boolean
    Get
public:
property bool^ IsDeadMe {
    bool^ get ();
}

Field Value

true if is dead; otherwise, false.

See Also

WoWLocalPlayer Class
wManager.Wow.ObjectManager Namespace


IsInGroup Property

WoWLocalPlayer..::..IsInGroup Property

Gets a value indicating whether is in group.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsInGroup { get; }
Public ReadOnly Property IsInGroup As Boolean
    Get
public:
property bool^ IsInGroup {
    bool^ get ();
}

Field Value

true if is in group; otherwise, false.

See Also

WoWLocalPlayer Class
wManager.Wow.ObjectManager Namespace


IsInParty Property

WoWLocalPlayer..::..IsInParty Property

Gets a value indicating whethe is in party.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsInParty { get; }
Public ReadOnly Property IsInParty As Boolean
    Get
public:
property bool^ IsInParty {
    bool^ get ();
}

Field Value

true if is in party; otherwise, false.

See Also

WoWLocalPlayer Class
wManager.Wow.ObjectManager Namespace


IsInPetBattle Property

WoWLocalPlayer..::..IsInPetBattle Property

Gets a value indicating whether in pet battle.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsInPetBattle { get; }
Public ReadOnly Property IsInPetBattle As Boolean
    Get
public:
property bool^ IsInPetBattle {
    bool^ get ();
}

Field Value

true if is in pet battle; otherwise, false.

See Also

WoWLocalPlayer Class
wManager.Wow.ObjectManager Namespace


IsMounted Property

WoWLocalPlayer..::..IsMounted Property

Gets a value indicating whether is mounted.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsMounted { get; }
Public ReadOnly Property IsMounted As Boolean
    Get
public:
property bool^ IsMounted {
    bool^ get ();
}

Field Value

true if is mounted; otherwise, false.

See Also

WoWLocalPlayer Class
wManager.Wow.ObjectManager Namespace


IsPartyMember Property

WoWLocalPlayer..::..IsPartyMember Property

Gets a value indicating whether is party member.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsPartyMember { get; }
Public ReadOnly Property IsPartyMember As Boolean
    Get
public:
property bool^ IsPartyMember {
    bool^ get ();
}

Field Value

true if is party member; otherwise, false.

See Also

WoWLocalPlayer Class
wManager.Wow.ObjectManager Namespace


LevelDecimal Property

WoWLocalPlayer..::..LevelDecimal Property

Gets level decimal (Level + Experience / ExperienceMax).

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public double LevelDecimal { get; }
Public ReadOnly Property LevelDecimal As Double
    Get
public:
property double^ LevelDecimal {
    double^ get ();
}

Field Value

The level decimal.

See Also

WoWLocalPlayer Class
wManager.Wow.ObjectManager Namespace


MapPositionLua Property

WoWLocalPlayer..::..MapPositionLua Property

Gets the map position lua (X = MapPositionLua[0], Y = MapPositionLua[1]).

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string[] MapPositionLua { get; }
Public ReadOnly Property MapPositionLua As String()
    Get
public:
property array<String^>^ MapPositionLua {
    array<String^>^ get ();
}

Field Value

The map position lua.

See Also

WoWLocalPlayer Class
wManager.Wow.ObjectManager Namespace


MeCreatureTrack Property

WoWLocalPlayer..::..MeCreatureTrack Property

Gets or sets creatures to track.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public TrackCreatureFlags MeCreatureTrack { get; set; }
Public Property MeCreatureTrack As TrackCreatureFlags
    Get
    Set
public:
property TrackCreatureFlags^ MeCreatureTrack {
    TrackCreatureFlags^ get ();
    void set (TrackCreatureFlags^ value);
}

Field Value

creatures tracked.

See Also

WoWLocalPlayer Class
wManager.Wow.ObjectManager Namespace


MeObjectTrack Property

WoWLocalPlayer..::..MeObjectTrack Property

Gets or sets objects to track.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public TrackObjectFlags MeObjectTrack { get; set; }
Public Property MeObjectTrack As TrackObjectFlags
    Get
    Set
public:
property TrackObjectFlags^ MeObjectTrack {
    TrackObjectFlags^ get ();
    void set (TrackObjectFlags^ value);
}

Field Value

Me objects tracked.

See Also

WoWLocalPlayer Class
wManager.Wow.ObjectManager Namespace


MouseOverGuid Property

WoWLocalPlayer..::..MouseOverGuid Property

Gets or sets the mouse over GUID.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public ulong MouseOverGuid { get; set; }
Public Property MouseOverGuid As ULong
    Get
    Set
public:
property unsigned long long^ MouseOverGuid {
    unsigned long long^ get ();
    void set (unsigned long long^ value);
}

Field Value

The mouse over GUID.

See Also

WoWLocalPlayer Class
wManager.Wow.ObjectManager Namespace


MouseOverObj Property

WoWLocalPlayer..::..MouseOverObj Property

Gets the mouse over object.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public WoWUnit MouseOverObj { get; }
Public ReadOnly Property MouseOverObj As WoWUnit
    Get
public:
property WoWUnit^ MouseOverObj {
    WoWUnit^ get ();
}

Field Value

The mouse over object.

See Also

WoWLocalPlayer Class
wManager.Wow.ObjectManager Namespace


Name Property

WoWLocalPlayer..::..Name Property

Gets the name.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}

Field Value

The name.

See Also

WoWLocalPlayer Class
wManager.Wow.ObjectManager Namespace


PlayerUsingVehicle Property

WoWLocalPlayer..::..PlayerUsingVehicle Property

Gets a value indicating whether player using vehicle.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool PlayerUsingVehicle { get; }
Public ReadOnly Property PlayerUsingVehicle As Boolean
    Get
public:
property bool^ PlayerUsingVehicle {
    bool^ get ();
}

Field Value

true if player using vehicle; otherwise, false.

See Also

WoWLocalPlayer Class
wManager.Wow.ObjectManager Namespace


PositionCorpse Property

WoWLocalPlayer..::..PositionCorpse Property

Gets corpse position.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Vector3 PositionCorpse { get; }
Public ReadOnly Property PositionCorpse As Vector3
    Get
public:
property Vector3^ PositionCorpse {
    Vector3^ get ();
}

Field Value

The corpse position.

See Also

WoWLocalPlayer Class
wManager.Wow.ObjectManager Namespace


Runes Property

WoWLocalPlayer..::..Runes Property

Gets the runes.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint Runes { get; }
Public ReadOnly Property Runes As UInteger
    Get
public:
property unsigned int^ Runes {
    unsigned int^ get ();
}

Field Value

The runes.

See Also

WoWLocalPlayer Class
wManager.Wow.ObjectManager Namespace


WoWObject Class

The base object class that all objects in WoW inherit.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class WoWObject
Public Class WoWObject
public ref class WoWObject

Inheritance Hierarchy

Object
wManager.Wow.ObjectManager..::..WoWObject

See Also

WoWObject Members
wManager.Wow.ObjectManager Namespace


WoWObject Members

The WoWObject type exposes the following members.

Constructors

 | Name | Description
Public method | WoWObject | Initializes a new instance of the WoWObject class.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDescriptorAddress(Descriptors..::..ObjectFields) | Gets the descriptor address.
Public method | GetDescriptorAddress(UInt32) | Gets the descriptor address.
Public method | GetDescriptorAddress(UInt32, UInt32) | Gets the descriptor address.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance.

Operators

Name | Description
False | Implements the false operator.
True | Implements the true operator.

Properties

 | Name | Description
Protected property | BaseAddress |
Protected property | BaseDescriptorAddressCACHE |
Public property | Entry |
Public property | GetBaseAddress | Gets the base address.
Public property | GetDescriptorStartAddress | Gets the descriptor start address.
Public property | GetDistance | Gets the distance (from local character).
Public property | Guid | Gets the GUID.
Public property | IsValid | Returns true if is valid.
Public property | Name | Gets the name.
Public property | Position | Gets the position.
Public property | Scale | Gets the scale.
Public property | Type | Gets the type.

See Also

WoWObject Class
wManager.Wow.ObjectManager Namespace


WoWObject Constructor

Initializes a new instance of the WoWObject class.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public WoWObject(
    uint address
)
Public Sub New ( _
    address As UInteger _
)
public:
WoWObject(
    unsigned int^ address
)

Parameters

address
Type: UInt32
The address.

See Also

WoWObject Class
wManager.Wow.ObjectManager Namespace


WoWObject Methods

The WoWObject type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDescriptorAddress(Descriptors..::..ObjectFields) | Gets the descriptor address.
Public method | GetDescriptorAddress(UInt32) | Gets the descriptor address.
Public method | GetDescriptorAddress(UInt32, UInt32) | Gets the descriptor address.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance.

See Also

WoWObject Class
wManager.Wow.ObjectManager Namespace


GetDescriptorAddress Method

WoWObject..::..GetDescriptorAddress Method

Overload List

 | Name | Description
Public method | GetDescriptorAddress(Descriptors..::..ObjectFields) | Gets the descriptor address.
Public method | GetDescriptorAddress(UInt32) | Gets the descriptor address.
Public method | GetDescriptorAddress(UInt32, UInt32) | Gets the descriptor address.

See Also

WoWObject Class
WoWObject Members
wManager.Wow.ObjectManager Namespace


GetDescriptorAddress Method (ObjectFields)

WoWObject..::..GetDescriptorAddress Method (ObjectFields)

Gets the descriptor address.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint GetDescriptorAddress(
    Descriptors..::..ObjectFields field
)
Public Function GetDescriptorAddress ( _
    field As Descriptors..::..ObjectFields _
) As UInteger
public:
unsigned int^ GetDescriptorAddress(
    Descriptors..::..ObjectFields^ field
)

Parameters

field
Type: wManager.Wow.Patchables..::..Descriptors..::..ObjectFields
The field.

Return Value

Ptr.

See Also

WoWObject Class
GetDescriptorAddress Overload
wManager.Wow.ObjectManager Namespace


GetDescriptorAddress Method (UInt32)

WoWObject..::..GetDescriptorAddress Method (UInt32)

Gets the descriptor address.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint GetDescriptorAddress(
    uint field
)
Public Function GetDescriptorAddress ( _
    field As UInteger _
) As UInteger
public:
unsigned int^ GetDescriptorAddress(
    unsigned int^ field
)

Parameters

field
Type: UInt32
The field.

Return Value

Ptr.

See Also

WoWObject Class
GetDescriptorAddress Overload
wManager.Wow.ObjectManager Namespace


GetDescriptorAddress Method (UInt32, UInt32)

WoWObject..::..GetDescriptorAddress Method (UInt32, UInt32)

Gets the descriptor address.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint GetDescriptorAddress(
    uint baseAddress,
    uint field
)
Public Function GetDescriptorAddress ( _
    baseAddress As UInteger, _
    field As UInteger _
) As UInteger
public:
unsigned int^ GetDescriptorAddress(
    unsigned int^ baseAddress,
    unsigned int^ field
)

Parameters

baseAddress
Type: UInt32
The base address.
field
Type: UInt32
The field.

Return Value

Ptr.

See Also

WoWObject Class
GetDescriptorAddress Overload
wManager.Wow.ObjectManager Namespace


ToString Method

WoWObject..::..ToString Method

Returns a String that represents this instance.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string ToString()
Public Function ToString As String
public:
String^ ToString()

Return Value

A String that represents this instance.

See Also

WoWObject Class
wManager.Wow.ObjectManager Namespace


WoWObject Operators

The WoWObject type exposes the following members.

Operators

Name | Description
False | Implements the false operator.
True | Implements the true operator.

See Also

WoWObject Class
wManager.Wow.ObjectManager Namespace


False Operator

WoWObject..::..False Operator

Implements the false operator.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool operator false(
    WoWObject obj1
)
Public Shared Operator IsFalse ( _
    obj1 As WoWObject _
) As Boolean
Visual C++ does not support this operator.

Parameters

obj1
Type: wManager.Wow.ObjectManager..::..WoWObject
The obj1.

Return Value

The result of the operator.

See Also

WoWObject Class
wManager.Wow.ObjectManager Namespace


True Operator

WoWObject..::..True Operator

Implements the true operator.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool operator true(
    WoWObject obj1
)
Public Shared Operator IsTrue ( _
    obj1 As WoWObject _
) As Boolean
Visual C++ does not support this operator.

Parameters

obj1
Type: wManager.Wow.ObjectManager..::..WoWObject
The obj1.

Return Value

The result of the operator.

See Also

WoWObject Class
wManager.Wow.ObjectManager Namespace


WoWObject Properties

The WoWObject type exposes the following members.

Properties

 | Name | Description
Protected property | BaseAddress |
Protected property | BaseDescriptorAddressCACHE |
Public property | Entry |
Public property | GetBaseAddress | Gets the base address.
Public property | GetDescriptorStartAddress | Gets the descriptor start address.
Public property | GetDistance | Gets the distance (from local character).
Public property | Guid | Gets the GUID.
Public property | IsValid | Returns true if is valid.
Public property | Name | Gets the name.
Public property | Position | Gets the position.
Public property | Scale | Gets the scale.
Public property | Type | Gets the type.

See Also

WoWObject Class
wManager.Wow.ObjectManager Namespace


BaseAddress Property

WoWObject..::..BaseAddress Property

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
protected uint BaseAddress { get; set; }
Protected Property BaseAddress As UInteger
    Get
    Set
protected:
property unsigned int^ BaseAddress {
    unsigned int^ get ();
    void set (unsigned int^ value);
}

See Also

WoWObject Class
wManager.Wow.ObjectManager Namespace


BaseDescriptorAddressCACHE Property

WoWObject..::..BaseDescriptorAddressCACHE Property

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
protected uint BaseDescriptorAddressCACHE { get; set; }
Protected Property BaseDescriptorAddressCACHE As UInteger
    Get
    Set
protected:
property unsigned int^ BaseDescriptorAddressCACHE {
    unsigned int^ get ();
    void set (unsigned int^ value);
}

See Also

WoWObject Class
wManager.Wow.ObjectManager Namespace


Entry Property

WoWObject..::..Entry Property

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int Entry { get; }
Public ReadOnly Property Entry As Integer
    Get
public:
property int^ Entry {
    int^ get ();
}

See Also

WoWObject Class
wManager.Wow.ObjectManager Namespace


GetBaseAddress Property

WoWObject..::..GetBaseAddress Property

Gets the base address.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint GetBaseAddress { get; }
Public ReadOnly Property GetBaseAddress As UInteger
    Get
public:
property unsigned int^ GetBaseAddress {
    unsigned int^ get ();
}

Field Value

The base address.

See Also

WoWObject Class
wManager.Wow.ObjectManager Namespace


GetDescriptorStartAddress Property

WoWObject..::..GetDescriptorStartAddress Property

Gets the descriptor start address.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint GetDescriptorStartAddress { get; }
Public ReadOnly Property GetDescriptorStartAddress As UInteger
    Get
public:
property unsigned int^ GetDescriptorStartAddress {
    unsigned int^ get ();
}

Field Value

The descriptor start address.

See Also

WoWObject Class
wManager.Wow.ObjectManager Namespace


GetDistance Property

WoWObject..::..GetDistance Property

Gets the distance (from local character).

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public virtual float GetDistance { get; }
Public Overridable ReadOnly Property GetDistance As Single
    Get
public:
virtual property float^ GetDistance {
    float^ get ();
}

Field Value

The distance.

See Also

WoWObject Class
wManager.Wow.ObjectManager Namespace


Guid Property

WoWObject..::..Guid Property

Gets the GUID.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public ulong Guid { get; }
Public ReadOnly Property Guid As ULong
    Get
public:
property unsigned long long^ Guid {
    unsigned long long^ get ();
}

Field Value

The GUID.

See Also

WoWObject Class
wManager.Wow.ObjectManager Namespace


IsValid Property

WoWObject..::..IsValid Property

Returns true if is valid.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsValid { get; }
Public ReadOnly Property IsValid As Boolean
    Get
public:
property bool^ IsValid {
    bool^ get ();
}

Field Value

true if this instance is valid; otherwise, false.

See Also

WoWObject Class
wManager.Wow.ObjectManager Namespace


Name Property

WoWObject..::..Name Property

Gets the name.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public virtual string Name { get; }
Public Overridable ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get ();
}

Field Value

The name.

See Also

WoWObject Class
wManager.Wow.ObjectManager Namespace


Position Property

WoWObject..::..Position Property

Gets the position.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public virtual Vector3 Position { get; }
Public Overridable ReadOnly Property Position As Vector3
    Get
public:
virtual property Vector3^ Position {
    Vector3^ get ();
}

Field Value

The position.

See Also

WoWObject Class
wManager.Wow.ObjectManager Namespace


Scale Property

WoWObject..::..Scale Property

Gets the scale.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float Scale { get; }
Public ReadOnly Property Scale As Single
    Get
public:
property float^ Scale {
    float^ get ();
}

Field Value

The scale.

See Also

WoWObject Class
wManager.Wow.ObjectManager Namespace


Type Property

WoWObject..::..Type Property

Gets the type.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public WoWObjectType Type { get; }
Public ReadOnly Property Type As WoWObjectType
    Get
public:
property WoWObjectType^ Type {
    WoWObjectType^ get ();
}

Field Value

The type.

See Also

WoWObject Class
wManager.Wow.ObjectManager Namespace


WoWPlayer Class

Class WoWPlayer. Implements the WoWUnit

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class WoWPlayer : WoWUnit
Public Class WoWPlayer _
    Inherits WoWUnit
public ref class WoWPlayer : public WoWUnit

Inheritance Hierarchy

Object
wManager.Wow.ObjectManager..::..WoWObject
wManager.Wow.ObjectManager..::..WoWUnit
wManager.Wow.ObjectManager..::..WoWPlayer

See Also

WoWPlayer Members
wManager.Wow.ObjectManager Namespace
wManager.Wow.ObjectManager..::..WoWUnit


WoWPlayer Members

The WoWPlayer type exposes the following members.

Constructors

 | Name | Description
Public method | WoWPlayer | Initializes a new instance of the WoWPlayer class.

Methods

 | Name | Description
Public method | BuffCastedBy | Buff casted by. (Inherited from WoWUnit.)
Public method | BuffCastedByAll | Buff casted by all. (Inherited from WoWUnit.)
Public method | BuffStack(List<(Of <<'(UInt32>)>>)) | Buff stack count. (Inherited from WoWUnit.)
Public method | BuffStack(UInt32) | Buff stack count. (Inherited from WoWUnit.)
Public method | BuffStack(String) | Buff stack count. (Inherited from WoWUnit.)
Public method | BuffTimeLeft(String) | Buff time left. (Inherited from WoWUnit.)
Public method | BuffTimeLeft(List<(Of <<'(UInt32>)>>)) | Buff time left. (Inherited from WoWUnit.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAllBuff | Gets all buff. (Inherited from WoWUnit.)
Public method | GetBuff(String) | Gets the buff. (Inherited from WoWUnit.)
Public method | GetBuff(List<(Of <<'(UInt32>)>>)) | Gets the buff. (Inherited from WoWUnit.)
Public method | GetBuffs(String) | Gets the buffs. (Inherited from WoWUnit.)
Public method | GetBuffs(List<(Of <<'(UInt32>)>>)) | Gets the buffs. (Inherited from WoWUnit.)
Public method | GetDescriptorAddress(Descriptors..::..PlayerFields) |
Public method | GetDescriptorAddress(Descriptors..::..UnitFields) | (Inherited from WoWUnit.)
Public method | GetDescriptorAddress(Descriptors..::..ObjectFields) | Gets the descriptor address. (Inherited from WoWObject.)
Public method | GetDescriptorAddress(UInt32) | Gets the descriptor address. (Inherited from WoWObject.)
Public method | GetDescriptorAddress(UInt32, UInt32) | Gets the descriptor address. (Inherited from WoWObject.)
Public method | GetEquipedItemBySlot | Gets the equipped item by slot.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetMaxPowerByPowerType | Gets maximum power value by type. (Inherited from WoWUnit.)
Public method | GetMovementFlag | Gets if movement flag is present. (Inherited from WoWUnit.)
Public method | GetMyBuff | Gets my buff. (Inherited from WoWUnit.)
Public method | GetPowerByPowerType | Gets power value by power type. (Inherited from WoWUnit.)
Public method | GetType | (Inherited from Object.)
Public method | HaveBuff(String) | Has the buff. (Inherited from WoWUnit.)
Public method | HaveBuff(List<(Of <<'(UInt32>)>>)) | Has the buff. (Inherited from WoWUnit.)
Public method | HaveBuff(UInt32) | Has the buff. (Inherited from WoWUnit.)
Public method | IsBehind | Determines whether the specified target position is behind. (Inherited from WoWUnit.)
Public method | IsFacing | Determines whether the specified target position is facing. (Inherited from WoWUnit.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Inherited from WoWObject.)

Properties

 | Name | Description
Public property | AggroDistance | Gets the aggro distance. (Inherited from WoWUnit.)
Public property | Alternate | Gets the alternate. (Inherited from WoWUnit.)
Public property | AlternatePercentage | Gets the alternate percentage. (Inherited from WoWUnit.)
Public property | ArcaneCharges | Gets the arcane charges. (Inherited from WoWUnit.)
Public property | ArcaneChargesPercentage | Gets the arcane charges percentage. (Inherited from WoWUnit.)
Public property | BarTwo | Gets the bar two value.
Public property | BarTwoMax | Gets the bar two max value.
Public property | BarTwoPercentage | Gets the bar two percentage.
Protected property | BaseAddress | (Inherited from WoWObject.)
Protected property | BaseDescriptorAddressCACHE | (Inherited from WoWObject.)
Public property | BurningEmbers | Gets the Burning Embers. (Inherited from WoWUnit.)
Public property | BurningEmbersPercentage | Gets the Burning Embers percentage. (Inherited from WoWUnit.)
Public property | CanInterruptCasting | Gets a value indicating whether can interrupt casting. (Inherited from WoWUnit.)
Public property | CastingSpell | Gets the casting spell. (Inherited from WoWUnit.)
Public property | CastingSpellId | Gets the casting spell id. (Inherited from WoWUnit.)
Public property | CastingTimeLeft | Gets the casting time left (in milliseconds). (Inherited from WoWUnit.)
Public property | Chi | Gets the chi. (Inherited from WoWUnit.)
Public property | ChiPercentage | Gets the chi percentage. (Inherited from WoWUnit.)
Public property | CombatReach | Gets the combat reach. (Inherited from WoWUnit.)
Public property | ComboPoint | Gets the combo point.
Public property | Confused | Gets a value indicating whether is confused. (Inherited from WoWUnit.)
Public property | CreatedBy | Gets the created by. (Inherited from WoWUnit.)
Public property | CreatedBySpell | Gets spell id used to create him. (Inherited from WoWUnit.)
Public property | CreatureTypeTarget | Gets the creature type target (work only in unit is your current target). (Inherited from WoWUnit.)
Public property | DarkForce | Gets the dark force. (Inherited from WoWUnit.)
Public property | DarkForcePercentage | Gets the percentage dark force. (Inherited from WoWUnit.)
Public property | DBCacheRow | Gets the database cache row. (Inherited from WoWUnit.)
Public property | DemonicFury | Gets the Demonic Fury. (Inherited from WoWUnit.)
Public property | DemonicFuryPercentage | Gets the Demonic Fury percentage. (Inherited from WoWUnit.)
Public property | DisplayId | Gets the display id. (Inherited from WoWUnit.)
Public property | Eclipse |
Public property | EclipsePercentage |
Public property | Energy | Gets the energy. (Inherited from WoWUnit.)
Public property | EnergyPercentage | Gets the energy percentage. (Inherited from WoWUnit.)
Public property | Entry | (Inherited from WoWObject.)
Public property | Faction | Gets the faction. (Inherited from WoWUnit.)
Public property | FactionTemplate | Gets the faction template. (Inherited from WoWUnit.)
Public property | Fleeing | Gets a value indicating whether is fleeing. (Inherited from WoWUnit.)
Public property | Focus | Gets the focus. (Inherited from WoWUnit.)
Public property | FocusPercentage | Gets the focus percentage. (Inherited from WoWUnit.)
Public property | GeHitBoxtDistance | Gets the HitBox distance. (Inherited from WoWUnit.)
Public property | GetBaseAddress | Gets the base address. (Inherited from WoWObject.)
Public property | GetDescriptorStartAddress | Gets the descriptor start address. (Inherited from WoWObject.)
Public property | GetDistance | Gets the get distance (from local player). (Inherited from WoWUnit.)
Public property | GetDistance2D | Gets the get distance 2D (from local player). (Inherited from WoWUnit.)
Public property | GetDistanceZ | Gets the get distance Z (from local player). (Inherited from WoWUnit.)
Public property | GetDynamicFlags | Gets the unit dynamic flags. (Inherited from WoWUnit.)
Public property | GetEquipedItem | Gets the get equipped items.
Public property | GetMove | Gets a value indicating whether get move. (Inherited from WoWUnit.)
Public property | GetUnitDynamicFlags | Gets the unit dynamic flags. (Inherited from WoWUnit.)
Public property | Guid | Gets the GUID. (Inherited from WoWObject.)
Public property | HasTarget | Gets a value indicating whether has target. (Inherited from WoWUnit.)
Public property | Health | Gets the health. (Inherited from WoWUnit.)
Public property | HealthPercent | Gets the health percent. (Inherited from WoWUnit.)
Public property | HealthRatio | Gets the health ratio. (Inherited from WoWUnit.)
Public property | HolyPower | Gets the holy power. (Inherited from WoWUnit.)
Public property | HolyPowerPercentage | Gets the holy power percentage. (Inherited from WoWUnit.)
Public property | InCombat | Gets a value indicating whether in combat. (Inherited from WoWUnit.)
Public property | InCombatFlagOnly | Gets a value indicating whether in combat flag only. (Inherited from WoWUnit.)
Public property | InCombatWithMe | Gets a value indicating whether in combat with me. (Inherited from WoWUnit.)
Public property | Influenced | Gets a value indicating whether is influenced. (Inherited from WoWUnit.)
Public property | InteractDistance | Gets or sets the interact distance (you can adjust with MinInteractDistance, MaxInteractDistance and InteractDistanceByEntry, if you set value it is save to InteractDistanceByEntry). (Inherited from WoWUnit.)
Public property | InTransport | Gets a value indicating whether in transport. (Inherited from WoWUnit.)
Public property | IsAlive | Gets a value indicating whether is alive. (Inherited from WoWUnit.)
Public property | IsAlliance | Gets a value indicating whether is in alliance.
Public property | IsAttackable | Gets a value indicating whether is attackable. (Inherited from WoWUnit.)
Public property | IsAuctioneer | Gets a value indicating whether is auctioneer. (Inherited from WoWUnit.)
Public property | IsBlacklisted | Gets a value indicating whether is blacklisted. (Inherited from WoWUnit.)
Public property | IsBoss | Gets a value indicating whether is boss. (Inherited from WoWUnit.)
Public property | IsCast | Gets a value indicating whether is cast. (Inherited from WoWUnit.)
Public property | IsDead | Gets a value indicating whether is dead.
Public property | IsElite | Gets a value indicating whether is elite. (Inherited from WoWUnit.)
Public property | IsFlightMaster | Gets a value indicating whether is flight master. (Inherited from WoWUnit.)
Public property | IsFlying | Gets a value indicating whether is flying. (Inherited from WoWUnit.)
Public property | IsGoodInteractDistance | Gets a value indicating whether is good interact distance (look InteractDistance). (Inherited from WoWUnit.)
Public property | IsHorde | Gets a value indicating whether is in horde.
Public property | IsIndoors | Gets a value indicating whether is indoors. (Inherited from WoWUnit.)
Public property | IsLocalPlayer | Gets a value indicating whether is local player. (Inherited from WoWUnit.)
Public property | IsLootable | Gets a value indicating whether is lootable. (Inherited from WoWUnit.)
Public property | IsMeOrMyPetOrPartyMemberTarget | Gets a value indicating whether is my target or my pet or party member target. (Inherited from WoWUnit.)
Public property | IsMeOrMyPetTarget | Gets a value indicating whether is my target or my pet target. (Inherited from WoWUnit.)
Public property | IsMounted | Gets a value indicating whether is mounted. (Inherited from WoWUnit.)
Public property | IsMyPet | Gets a value indicating whether is my pet. (Inherited from WoWUnit.)
Public property | IsMyPetTarget | Gets a value indicating whether is my pet target. (Inherited from WoWUnit.)
Public property | IsMyTarget | Gets a value indicating whether is my target. (Inherited from WoWUnit.)
Public property | IsNeutral | Gets a value indicating whether is neutral (no horde or alliance faction).
Public property | IsNpcInnkeeper | Gets a value indicating whether is NPC innkeeper. (Inherited from WoWUnit.)
Public property | IsNpcRepair | Gets a value indicating whether is NPC repair. (Inherited from WoWUnit.)
Public property | IsNpcSpiritHealer | Gets a value indicating whether is NPC spirit healer. (Inherited from WoWUnit.)
Public property | IsNpcTrainer | Gets a value indicating whether is NPC trainer. (Inherited from WoWUnit.)
Public property | IsNpcVendor | Gets a value indicating whether is NPC vendor. (Inherited from WoWUnit.)
Public property | IsNpcVendorFood | Gets a value indicating whether is NPC vendor food. (Inherited from WoWUnit.)
Public property | IsNpcWildPets | Gets a value indicating whether is NPC wild pets. (Inherited from WoWUnit.)
Public property | IsOnTaxi | Gets a value indicating whether is on taxi. (Inherited from WoWUnit.)
Public property | IsOutdoors | Gets a value indicating whether is outdoors. (Inherited from WoWUnit.)
Public property | IsPartyLeader | Gets a value indicating whether is party leader. (Inherited from WoWUnit.)
Public property | IsPartyMember | Gets a value indicating whether is party member. (Inherited from WoWUnit.)
Public property | IsPartyMemberTarget | Gets a value indicating whether is party member target. (Inherited from WoWUnit.)
Public property | IsPet | Gets a value indicating whether is pet. (Inherited from WoWUnit.)
Public property | IsStunned | Gets a value indicating whether is stunned. (Inherited from WoWUnit.)
Public property | IsSwimming | Gets a value indicating whether is swimming. (Inherited from WoWUnit.)
Public property | IsTaggedByOther | Gets a value indicating Tagged By Other. (Inherited from WoWUnit.)
Public property | IsTapDenied | Gets a value indicating whether is tap denied. (Inherited from WoWUnit.)
Public property | IsTargetingMe | Gets a value indicating whether is targeting me. (Inherited from WoWUnit.)
Public property | IsTargetingMeOrMyPet | Gets a value indicating whether is targeting me or my pet. (Inherited from WoWUnit.)
Public property | IsTargetingMeOrMyPetOrPartyMember | Gets a value indicating whether is targeting me or my pet or (my) party member. (Inherited from WoWUnit.)
Public property | IsTargetingMyPet | Gets a value indicating whether is targeting my pet. (Inherited from WoWUnit.)
Public property | IsTargetingPartyMember | Gets a value indicating whether is targeting (my) party member. (Inherited from WoWUnit.)
Public property | IsTracked | Gets or sets a value indicating whether is tracked (in in-game minimap). (Inherited from WoWUnit.)
Public property | IsValid | Returns true if is valid. (Inherited from WoWObject.)
Public property | IsWorldBoss | Gets a value indicating whether is world boss. (Inherited from WoWUnit.)
Public property | Level | Gets the level. (Inherited from WoWUnit.)
Public property | LightForce | Gets the light force. (Inherited from WoWUnit.)
Public property | LightForcePercentage | Gets the percentage light force. (Inherited from WoWUnit.)
Public property | Mana | Gets the mana. (Inherited from WoWUnit.)
Public property | ManaPercentage | Gets the mana percentage. (Inherited from WoWUnit.)
Public property | MaxAlternate | Gets the maximum alternate. (Inherited from WoWUnit.)
Public property | MaxArcaneCharges | Gets the maximum arcane charges. (Inherited from WoWUnit.)
Public property | MaxBurningEmbers | Gets the max Burning Embers. (Inherited from WoWUnit.)
Public property | MaxChi | Gets the maximum chi. (Inherited from WoWUnit.)
Public property | MaxDarkForce | Gets the max dark force. (Inherited from WoWUnit.)
Public property | MaxDemonicFury | Gets the max Demonic Fury. (Inherited from WoWUnit.)
Public property | MaxEclipse |
Public property | MaxEnergy | Gets the maximum energy. (Inherited from WoWUnit.)
Public property | MaxFocus | Gets the maximum focus. (Inherited from WoWUnit.)
Public property | MaxHealth | Gets the maximum health. (Inherited from WoWUnit.)
Public property | MaxHolyPower | Gets the maximum holy power. (Inherited from WoWUnit.)
Public property | MaxLightForce | Gets the max light force. (Inherited from WoWUnit.)
Public property | MaxMana | Gets the maximum mana. (Inherited from WoWUnit.)
Public property | MaxRage | Gets the maximum rage. (Inherited from WoWUnit.)
Public property | MaxRunes | Gets the maximum runes. (Inherited from WoWUnit.)
Public property | MaxRunicPower | Gets the maximum runic power. (Inherited from WoWUnit.)
Public property | MaxShadowOrbs | Gets the max Shadow Orbs. (Inherited from WoWUnit.)
Public property | MaxSoulShards | Gets the maximum soul shards. (Inherited from WoWUnit.)
Public property | MinEclipse |
Public property | MountDisplayId | Gets the mount display id. (Inherited from WoWUnit.)
Public property | MyCharacterInFrontHim | Gets a value indicating whether my character in front him. (Inherited from WoWUnit.)
Public property | Name | Gets the name. (Inherited from WoWUnit.)
Public property | NotSelectable | Gets a value indicating whether not selectable. (Inherited from WoWUnit.)
Public property | NpcFlightMastrerIsDiscover | FlightMastrer is discover. (Inherited from WoWUnit.)
Public property | NpcMarker | Gets the NPC marker. (Inherited from WoWUnit.)
Public property | NpcMarkerId | Gets the NPC marker id (used by NpcMarker). (Inherited from WoWUnit.)
Public property | Pacified | Gets a value indicating whether is pacified. (Inherited from WoWUnit.)
Public property | PetNumber | Gets the pet number. (Inherited from WoWUnit.)
Public property | PetOwnerGuid | Gets the pet owner GUID. (Inherited from WoWUnit.)
Public property | Pitch | Gets or sets the pitch. (Inherited from WoWUnit.)
Public property | PlayerControlled | Gets a value indicating whether player controlled. (Inherited from WoWUnit.)
Public property | PlayerFaction | Gets the player faction (value like "Alliance", "Horde", "Neutral").
Public property | PlayerRace | Gets the player race.
Public property | PlayerRaceString | Gets the player race string.
Public property | Position | Gets the position. (Inherited from WoWUnit.)
Public property | PositionRelativeWithoutType | Gets position relative without type (more information about relative position here: UseRelativePosition). (Inherited from WoWUnit.)
Public property | PositionWithoutType | Gets position without type (without "Flying", ....). (Inherited from WoWUnit.)
Public property | Possessed | Gets a value indicating whether is possessed. (Inherited from WoWUnit.)
Public property | PowerType | The unit's power type.
Public property | Rage | Gets the rage. (Inherited from WoWUnit.)
Public property | RagePercentage | Gets the rage percentage. (Inherited from WoWUnit.)
Public property | Reaction | Gets the reaction. (Inherited from WoWUnit.)
Public property | Rooted | Gets a value indicating whether is rooted. (Inherited from WoWUnit.)
Public property | Rotation | Gets or sets the rotation (facing). (Inherited from WoWUnit.)
Public property | Runes | Gets the runes. (Inherited from WoWUnit.)
Public property | RunesPercentage | Gets the runes percentage. (Inherited from WoWUnit.)
Public property | RunicPower | Gets the runic power. (Inherited from WoWUnit.)
Public property | RunicPowerPercentage | Gets the runic power percentage. (Inherited from WoWUnit.)
Public property | Scale | Gets the scale. (Inherited from WoWObject.)
Public property | ShadowOrbs | Gets the Shadow Orbs. (Inherited from WoWUnit.)
Public property | ShadowOrbsPercentage | Gets the Shadow Orbs percentage. (Inherited from WoWUnit.)
Public property | Silenced | Gets a value indicating whether is silenced. (Inherited from WoWUnit.)
Public property | Skinnable | Gets a value indicating whether is skinnable. (Inherited from WoWUnit.)
Public property | SoulShards | Gets the soul shards. (Inherited from WoWUnit.)
Public property | SoulShardsPercentage | Gets the soul shards percentage. (Inherited from WoWUnit.)
Public property | SpeedMoving | Gets the speed moving. (Inherited from WoWUnit.)
Public property | Summon | Gets the summon. (Inherited from WoWUnit.)
Public property | SummonedBy | Gets the summoned by GUID. (Inherited from WoWUnit.)
Public property | TaggedByMe | Gets a value indicating Tagged By Me. (Inherited from WoWUnit.)
Public property | Target | Gets or sets the target. (Inherited from WoWUnit.)
Public property | TargetObject | Gets the target object. (Inherited from WoWUnit.)
Public property | TransportGuid | Gets the transport GUID (it is WoWGameObject). (Inherited from WoWUnit.)
Public property | Type | Gets the type. (Inherited from WoWObject.)
Public property | UnitClassification | Gets the unit classification. (Inherited from WoWUnit.)
Public property | UnitFlags | Gets the unit flags. (Inherited from WoWUnit.)
Public property | UnitNPCFlags | Gets the unit NPC flags. (Inherited from WoWUnit.)
Public property | WowClass | Gets the wow class. (Inherited from WoWUnit.)
Public property | WowRace | Gets the wow race.

See Also

WoWPlayer Class
wManager.Wow.ObjectManager Namespace


WoWPlayer Constructor

Initializes a new instance of the WoWPlayer class.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public WoWPlayer(
    uint address
)
Public Sub New ( _
    address As UInteger _
)
public:
WoWPlayer(
    unsigned int^ address
)

Parameters

address
Type: UInt32
The address.

See Also

WoWPlayer Class
wManager.Wow.ObjectManager Namespace


WoWPlayer Methods

The WoWPlayer type exposes the following members.

Methods

 | Name | Description
Public method | BuffCastedBy | Buff casted by. (Inherited from WoWUnit.)
Public method | BuffCastedByAll | Buff casted by all. (Inherited from WoWUnit.)
Public method | BuffStack(List<(Of <<'(UInt32>)>>)) | Buff stack count. (Inherited from WoWUnit.)
Public method | BuffStack(UInt32) | Buff stack count. (Inherited from WoWUnit.)
Public method | BuffStack(String) | Buff stack count. (Inherited from WoWUnit.)
Public method | BuffTimeLeft(String) | Buff time left. (Inherited from WoWUnit.)
Public method | BuffTimeLeft(List<(Of <<'(UInt32>)>>)) | Buff time left. (Inherited from WoWUnit.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAllBuff | Gets all buff. (Inherited from WoWUnit.)
Public method | GetBuff(String) | Gets the buff. (Inherited from WoWUnit.)
Public method | GetBuff(List<(Of <<'(UInt32>)>>)) | Gets the buff. (Inherited from WoWUnit.)
Public method | GetBuffs(String) | Gets the buffs. (Inherited from WoWUnit.)
Public method | GetBuffs(List<(Of <<'(UInt32>)>>)) | Gets the buffs. (Inherited from WoWUnit.)
Public method | GetDescriptorAddress(Descriptors..::..PlayerFields) |
Public method | GetDescriptorAddress(Descriptors..::..UnitFields) | (Inherited from WoWUnit.)
Public method | GetDescriptorAddress(Descriptors..::..ObjectFields) | Gets the descriptor address. (Inherited from WoWObject.)
Public method | GetDescriptorAddress(UInt32) | Gets the descriptor address. (Inherited from WoWObject.)
Public method | GetDescriptorAddress(UInt32, UInt32) | Gets the descriptor address. (Inherited from WoWObject.)
Public method | GetEquipedItemBySlot | Gets the equipped item by slot.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetMaxPowerByPowerType | Gets maximum power value by type. (Inherited from WoWUnit.)
Public method | GetMovementFlag | Gets if movement flag is present. (Inherited from WoWUnit.)
Public method | GetMyBuff | Gets my buff. (Inherited from WoWUnit.)
Public method | GetPowerByPowerType | Gets power value by power type. (Inherited from WoWUnit.)
Public method | GetType | (Inherited from Object.)
Public method | HaveBuff(String) | Has the buff. (Inherited from WoWUnit.)
Public method | HaveBuff(List<(Of <<'(UInt32>)>>)) | Has the buff. (Inherited from WoWUnit.)
Public method | HaveBuff(UInt32) | Has the buff. (Inherited from WoWUnit.)
Public method | IsBehind | Determines whether the specified target position is behind. (Inherited from WoWUnit.)
Public method | IsFacing | Determines whether the specified target position is facing. (Inherited from WoWUnit.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Inherited from WoWObject.)

See Also

WoWPlayer Class
wManager.Wow.ObjectManager Namespace


GetDescriptorAddress Method

WoWPlayer..::..GetDescriptorAddress Method

Overload List

 | Name | Description
Public method | GetDescriptorAddress(Descriptors..::..PlayerFields) |
Public method | GetDescriptorAddress(Descriptors..::..UnitFields) | (Inherited from WoWUnit.)
Public method | GetDescriptorAddress(Descriptors..::..ObjectFields) | Gets the descriptor address. (Inherited from WoWObject.)
Public method | GetDescriptorAddress(UInt32) | Gets the descriptor address. (Inherited from WoWObject.)
Public method | GetDescriptorAddress(UInt32, UInt32) | Gets the descriptor address. (Inherited from WoWObject.)

See Also

WoWPlayer Class
WoWPlayer Members
wManager.Wow.ObjectManager Namespace


GetDescriptorAddress Method

WoWPlayer..::..GetDescriptorAddress Method

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint GetDescriptorAddress(
    Descriptors..::..PlayerFields field
)
Public Function GetDescriptorAddress ( _
    field As Descriptors..::..PlayerFields _
) As UInteger
public:
unsigned int^ GetDescriptorAddress(
    Descriptors..::..PlayerFields^ field
)

Parameters

field
Type: wManager.Wow.Patchables..::..Descriptors..::..PlayerFields

See Also

WoWPlayer Class
wManager.Wow.ObjectManager Namespace


GetEquipedItemBySlot Method

WoWPlayer..::..GetEquipedItemBySlot Method

Gets the equipped item by slot.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint GetEquipedItemBySlot(
    InventorySlot slot
)
Public Function GetEquipedItemBySlot ( _
    slot As InventorySlot _
) As UInteger
public:
unsigned int^ GetEquipedItemBySlot(
    InventorySlot^ slot
)

Parameters

slot
Type: wManager.Wow.Enums..::..InventorySlot
The slot.

Return Value

System.UInt32.

See Also

WoWPlayer Class
wManager.Wow.ObjectManager Namespace


WoWPlayer Properties

The WoWPlayer type exposes the following members.

Properties

 | Name | Description
Public property | AggroDistance | Gets the aggro distance. (Inherited from WoWUnit.)
Public property | Alternate | Gets the alternate. (Inherited from WoWUnit.)
Public property | AlternatePercentage | Gets the alternate percentage. (Inherited from WoWUnit.)
Public property | ArcaneCharges | Gets the arcane charges. (Inherited from WoWUnit.)
Public property | ArcaneChargesPercentage | Gets the arcane charges percentage. (Inherited from WoWUnit.)
Public property | BarTwo | Gets the bar two value.
Public property | BarTwoMax | Gets the bar two max value.
Public property | BarTwoPercentage | Gets the bar two percentage.
Protected property | BaseAddress | (Inherited from WoWObject.)
Protected property | BaseDescriptorAddressCACHE | (Inherited from WoWObject.)
Public property | BurningEmbers | Gets the Burning Embers. (Inherited from WoWUnit.)
Public property | BurningEmbersPercentage | Gets the Burning Embers percentage. (Inherited from WoWUnit.)
Public property | CanInterruptCasting | Gets a value indicating whether can interrupt casting. (Inherited from WoWUnit.)
Public property | CastingSpell | Gets the casting spell. (Inherited from WoWUnit.)
Public property | CastingSpellId | Gets the casting spell id. (Inherited from WoWUnit.)
Public property | CastingTimeLeft | Gets the casting time left (in milliseconds). (Inherited from WoWUnit.)
Public property | Chi | Gets the chi. (Inherited from WoWUnit.)
Public property | ChiPercentage | Gets the chi percentage. (Inherited from WoWUnit.)
Public property | CombatReach | Gets the combat reach. (Inherited from WoWUnit.)
Public property | ComboPoint | Gets the combo point.
Public property | Confused | Gets a value indicating whether is confused. (Inherited from WoWUnit.)
Public property | CreatedBy | Gets the created by. (Inherited from WoWUnit.)
Public property | CreatedBySpell | Gets spell id used to create him. (Inherited from WoWUnit.)
Public property | CreatureTypeTarget | Gets the creature type target (work only in unit is your current target). (Inherited from WoWUnit.)
Public property | DarkForce | Gets the dark force. (Inherited from WoWUnit.)
Public property | DarkForcePercentage | Gets the percentage dark force. (Inherited from WoWUnit.)
Public property | DBCacheRow | Gets the database cache row. (Inherited from WoWUnit.)
Public property | DemonicFury | Gets the Demonic Fury. (Inherited from WoWUnit.)
Public property | DemonicFuryPercentage | Gets the Demonic Fury percentage. (Inherited from WoWUnit.)
Public property | DisplayId | Gets the display id. (Inherited from WoWUnit.)
Public property | Eclipse |
Public property | EclipsePercentage |
Public property | Energy | Gets the energy. (Inherited from WoWUnit.)
Public property | EnergyPercentage | Gets the energy percentage. (Inherited from WoWUnit.)
Public property | Entry | (Inherited from WoWObject.)
Public property | Faction | Gets the faction. (Inherited from WoWUnit.)
Public property | FactionTemplate | Gets the faction template. (Inherited from WoWUnit.)
Public property | Fleeing | Gets a value indicating whether is fleeing. (Inherited from WoWUnit.)
Public property | Focus | Gets the focus. (Inherited from WoWUnit.)
Public property | FocusPercentage | Gets the focus percentage. (Inherited from WoWUnit.)
Public property | GeHitBoxtDistance | Gets the HitBox distance. (Inherited from WoWUnit.)
Public property | GetBaseAddress | Gets the base address. (Inherited from WoWObject.)
Public property | GetDescriptorStartAddress | Gets the descriptor start address. (Inherited from WoWObject.)
Public property | GetDistance | Gets the get distance (from local player). (Inherited from WoWUnit.)
Public property | GetDistance2D | Gets the get distance 2D (from local player). (Inherited from WoWUnit.)
Public property | GetDistanceZ | Gets the get distance Z (from local player). (Inherited from WoWUnit.)
Public property | GetDynamicFlags | Gets the unit dynamic flags. (Inherited from WoWUnit.)
Public property | GetEquipedItem | Gets the get equipped items.
Public property | GetMove | Gets a value indicating whether get move. (Inherited from WoWUnit.)
Public property | GetUnitDynamicFlags | Gets the unit dynamic flags. (Inherited from WoWUnit.)
Public property | Guid | Gets the GUID. (Inherited from WoWObject.)
Public property | HasTarget | Gets a value indicating whether has target. (Inherited from WoWUnit.)
Public property | Health | Gets the health. (Inherited from WoWUnit.)
Public property | HealthPercent | Gets the health percent. (Inherited from WoWUnit.)
Public property | HealthRatio | Gets the health ratio. (Inherited from WoWUnit.)
Public property | HolyPower | Gets the holy power. (Inherited from WoWUnit.)
Public property | HolyPowerPercentage | Gets the holy power percentage. (Inherited from WoWUnit.)
Public property | InCombat | Gets a value indicating whether in combat. (Inherited from WoWUnit.)
Public property | InCombatFlagOnly | Gets a value indicating whether in combat flag only. (Inherited from WoWUnit.)
Public property | InCombatWithMe | Gets a value indicating whether in combat with me. (Inherited from WoWUnit.)
Public property | Influenced | Gets a value indicating whether is influenced. (Inherited from WoWUnit.)
Public property | InteractDistance | Gets or sets the interact distance (you can adjust with MinInteractDistance, MaxInteractDistance and InteractDistanceByEntry, if you set value it is save to InteractDistanceByEntry). (Inherited from WoWUnit.)
Public property | InTransport | Gets a value indicating whether in transport. (Inherited from WoWUnit.)
Public property | IsAlive | Gets a value indicating whether is alive. (Inherited from WoWUnit.)
Public property | IsAlliance | Gets a value indicating whether is in alliance.
Public property | IsAttackable | Gets a value indicating whether is attackable. (Inherited from WoWUnit.)
Public property | IsAuctioneer | Gets a value indicating whether is auctioneer. (Inherited from WoWUnit.)
Public property | IsBlacklisted | Gets a value indicating whether is blacklisted. (Inherited from WoWUnit.)
Public property | IsBoss | Gets a value indicating whether is boss. (Inherited from WoWUnit.)
Public property | IsCast | Gets a value indicating whether is cast. (Inherited from WoWUnit.)
Public property | IsDead | Gets a value indicating whether is dead.
Public property | IsElite | Gets a value indicating whether is elite. (Inherited from WoWUnit.)
Public property | IsFlightMaster | Gets a value indicating whether is flight master. (Inherited from WoWUnit.)
Public property | IsFlying | Gets a value indicating whether is flying. (Inherited from WoWUnit.)
Public property | IsGoodInteractDistance | Gets a value indicating whether is good interact distance (look InteractDistance). (Inherited from WoWUnit.)
Public property | IsHorde | Gets a value indicating whether is in horde.
Public property | IsIndoors | Gets a value indicating whether is indoors. (Inherited from WoWUnit.)
Public property | IsLocalPlayer | Gets a value indicating whether is local player. (Inherited from WoWUnit.)
Public property | IsLootable | Gets a value indicating whether is lootable. (Inherited from WoWUnit.)
Public property | IsMeOrMyPetOrPartyMemberTarget | Gets a value indicating whether is my target or my pet or party member target. (Inherited from WoWUnit.)
Public property | IsMeOrMyPetTarget | Gets a value indicating whether is my target or my pet target. (Inherited from WoWUnit.)
Public property | IsMounted | Gets a value indicating whether is mounted. (Inherited from WoWUnit.)
Public property | IsMyPet | Gets a value indicating whether is my pet. (Inherited from WoWUnit.)
Public property | IsMyPetTarget | Gets a value indicating whether is my pet target. (Inherited from WoWUnit.)
Public property | IsMyTarget | Gets a value indicating whether is my target. (Inherited from WoWUnit.)
Public property | IsNeutral | Gets a value indicating whether is neutral (no horde or alliance faction).
Public property | IsNpcInnkeeper | Gets a value indicating whether is NPC innkeeper. (Inherited from WoWUnit.)
Public property | IsNpcRepair | Gets a value indicating whether is NPC repair. (Inherited from WoWUnit.)
Public property | IsNpcSpiritHealer | Gets a value indicating whether is NPC spirit healer. (Inherited from WoWUnit.)
Public property | IsNpcTrainer | Gets a value indicating whether is NPC trainer. (Inherited from WoWUnit.)
Public property | IsNpcVendor | Gets a value indicating whether is NPC vendor. (Inherited from WoWUnit.)
Public property | IsNpcVendorFood | Gets a value indicating whether is NPC vendor food. (Inherited from WoWUnit.)
Public property | IsNpcWildPets | Gets a value indicating whether is NPC wild pets. (Inherited from WoWUnit.)
Public property | IsOnTaxi | Gets a value indicating whether is on taxi. (Inherited from WoWUnit.)
Public property | IsOutdoors | Gets a value indicating whether is outdoors. (Inherited from WoWUnit.)
Public property | IsPartyLeader | Gets a value indicating whether is party leader. (Inherited from WoWUnit.)
Public property | IsPartyMember | Gets a value indicating whether is party member. (Inherited from WoWUnit.)
Public property | IsPartyMemberTarget | Gets a value indicating whether is party member target. (Inherited from WoWUnit.)
Public property | IsPet | Gets a value indicating whether is pet. (Inherited from WoWUnit.)
Public property | IsStunned | Gets a value indicating whether is stunned. (Inherited from WoWUnit.)
Public property | IsSwimming | Gets a value indicating whether is swimming. (Inherited from WoWUnit.)
Public property | IsTaggedByOther | Gets a value indicating Tagged By Other. (Inherited from WoWUnit.)
Public property | IsTapDenied | Gets a value indicating whether is tap denied. (Inherited from WoWUnit.)
Public property | IsTargetingMe | Gets a value indicating whether is targeting me. (Inherited from WoWUnit.)
Public property | IsTargetingMeOrMyPet | Gets a value indicating whether is targeting me or my pet. (Inherited from WoWUnit.)
Public property | IsTargetingMeOrMyPetOrPartyMember | Gets a value indicating whether is targeting me or my pet or (my) party member. (Inherited from WoWUnit.)
Public property | IsTargetingMyPet | Gets a value indicating whether is targeting my pet. (Inherited from WoWUnit.)
Public property | IsTargetingPartyMember | Gets a value indicating whether is targeting (my) party member. (Inherited from WoWUnit.)
Public property | IsTracked | Gets or sets a value indicating whether is tracked (in in-game minimap). (Inherited from WoWUnit.)
Public property | IsValid | Returns true if is valid. (Inherited from WoWObject.)
Public property | IsWorldBoss | Gets a value indicating whether is world boss. (Inherited from WoWUnit.)
Public property | Level | Gets the level. (Inherited from WoWUnit.)
Public property | LightForce | Gets the light force. (Inherited from WoWUnit.)
Public property | LightForcePercentage | Gets the percentage light force. (Inherited from WoWUnit.)
Public property | Mana | Gets the mana. (Inherited from WoWUnit.)
Public property | ManaPercentage | Gets the mana percentage. (Inherited from WoWUnit.)
Public property | MaxAlternate | Gets the maximum alternate. (Inherited from WoWUnit.)
Public property | MaxArcaneCharges | Gets the maximum arcane charges. (Inherited from WoWUnit.)
Public property | MaxBurningEmbers | Gets the max Burning Embers. (Inherited from WoWUnit.)
Public property | MaxChi | Gets the maximum chi. (Inherited from WoWUnit.)
Public property | MaxDarkForce | Gets the max dark force. (Inherited from WoWUnit.)
Public property | MaxDemonicFury | Gets the max Demonic Fury. (Inherited from WoWUnit.)
Public property | MaxEclipse |
Public property | MaxEnergy | Gets the maximum energy. (Inherited from WoWUnit.)
Public property | MaxFocus | Gets the maximum focus. (Inherited from WoWUnit.)
Public property | MaxHealth | Gets the maximum health. (Inherited from WoWUnit.)
Public property | MaxHolyPower | Gets the maximum holy power. (Inherited from WoWUnit.)
Public property | MaxLightForce | Gets the max light force. (Inherited from WoWUnit.)
Public property | MaxMana | Gets the maximum mana. (Inherited from WoWUnit.)
Public property | MaxRage | Gets the maximum rage. (Inherited from WoWUnit.)
Public property | MaxRunes | Gets the maximum runes. (Inherited from WoWUnit.)
Public property | MaxRunicPower | Gets the maximum runic power. (Inherited from WoWUnit.)
Public property | MaxShadowOrbs | Gets the max Shadow Orbs. (Inherited from WoWUnit.)
Public property | MaxSoulShards | Gets the maximum soul shards. (Inherited from WoWUnit.)
Public property | MinEclipse |
Public property | MountDisplayId | Gets the mount display id. (Inherited from WoWUnit.)
Public property | MyCharacterInFrontHim | Gets a value indicating whether my character in front him. (Inherited from WoWUnit.)
Public property | Name | Gets the name. (Inherited from WoWUnit.)
Public property | NotSelectable | Gets a value indicating whether not selectable. (Inherited from WoWUnit.)
Public property | NpcFlightMastrerIsDiscover | FlightMastrer is discover. (Inherited from WoWUnit.)
Public property | NpcMarker | Gets the NPC marker. (Inherited from WoWUnit.)
Public property | NpcMarkerId | Gets the NPC marker id (used by NpcMarker). (Inherited from WoWUnit.)
Public property | Pacified | Gets a value indicating whether is pacified. (Inherited from WoWUnit.)
Public property | PetNumber | Gets the pet number. (Inherited from WoWUnit.)
Public property | PetOwnerGuid | Gets the pet owner GUID. (Inherited from WoWUnit.)
Public property | Pitch | Gets or sets the pitch. (Inherited from WoWUnit.)
Public property | PlayerControlled | Gets a value indicating whether player controlled. (Inherited from WoWUnit.)
Public property | PlayerFaction | Gets the player faction (value like "Alliance", "Horde", "Neutral").
Public property | PlayerRace | Gets the player race.
Public property | PlayerRaceString | Gets the player race string.
Public property | Position | Gets the position. (Inherited from WoWUnit.)
Public property | PositionRelativeWithoutType | Gets position relative without type (more information about relative position here: UseRelativePosition). (Inherited from WoWUnit.)
Public property | PositionWithoutType | Gets position without type (without "Flying", ....). (Inherited from WoWUnit.)
Public property | Possessed | Gets a value indicating whether is possessed. (Inherited from WoWUnit.)
Public property | PowerType | The unit's power type.
Public property | Rage | Gets the rage. (Inherited from WoWUnit.)
Public property | RagePercentage | Gets the rage percentage. (Inherited from WoWUnit.)
Public property | Reaction | Gets the reaction. (Inherited from WoWUnit.)
Public property | Rooted | Gets a value indicating whether is rooted. (Inherited from WoWUnit.)
Public property | Rotation | Gets or sets the rotation (facing). (Inherited from WoWUnit.)
Public property | Runes | Gets the runes. (Inherited from WoWUnit.)
Public property | RunesPercentage | Gets the runes percentage. (Inherited from WoWUnit.)
Public property | RunicPower | Gets the runic power. (Inherited from WoWUnit.)
Public property | RunicPowerPercentage | Gets the runic power percentage. (Inherited from WoWUnit.)
Public property | Scale | Gets the scale. (Inherited from WoWObject.)
Public property | ShadowOrbs | Gets the Shadow Orbs. (Inherited from WoWUnit.)
Public property | ShadowOrbsPercentage | Gets the Shadow Orbs percentage. (Inherited from WoWUnit.)
Public property | Silenced | Gets a value indicating whether is silenced. (Inherited from WoWUnit.)
Public property | Skinnable | Gets a value indicating whether is skinnable. (Inherited from WoWUnit.)
Public property | SoulShards | Gets the soul shards. (Inherited from WoWUnit.)
Public property | SoulShardsPercentage | Gets the soul shards percentage. (Inherited from WoWUnit.)
Public property | SpeedMoving | Gets the speed moving. (Inherited from WoWUnit.)
Public property | Summon | Gets the summon. (Inherited from WoWUnit.)
Public property | SummonedBy | Gets the summoned by GUID. (Inherited from WoWUnit.)
Public property | TaggedByMe | Gets a value indicating Tagged By Me. (Inherited from WoWUnit.)
Public property | Target | Gets or sets the target. (Inherited from WoWUnit.)
Public property | TargetObject | Gets the target object. (Inherited from WoWUnit.)
Public property | TransportGuid | Gets the transport GUID (it is WoWGameObject). (Inherited from WoWUnit.)
Public property | Type | Gets the type. (Inherited from WoWObject.)
Public property | UnitClassification | Gets the unit classification. (Inherited from WoWUnit.)
Public property | UnitFlags | Gets the unit flags. (Inherited from WoWUnit.)
Public property | UnitNPCFlags | Gets the unit NPC flags. (Inherited from WoWUnit.)
Public property | WowClass | Gets the wow class. (Inherited from WoWUnit.)
Public property | WowRace | Gets the wow race.

See Also

WoWPlayer Class
wManager.Wow.ObjectManager Namespace


BarTwo Property

WoWPlayer..::..BarTwo Property

Gets the bar two value.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint BarTwo { get; }
Public ReadOnly Property BarTwo As UInteger
    Get
public:
property unsigned int^ BarTwo {
    unsigned int^ get ();
}

Field Value

The bar two value.

See Also

WoWPlayer Class
wManager.Wow.ObjectManager Namespace


BarTwoMax Property

WoWPlayer..::..BarTwoMax Property

Gets the bar two max value.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint BarTwoMax { get; }
Public ReadOnly Property BarTwoMax As UInteger
    Get
public:
property unsigned int^ BarTwoMax {
    unsigned int^ get ();
}

Field Value

The bar two max value.

See Also

WoWPlayer Class
wManager.Wow.ObjectManager Namespace


BarTwoPercentage Property

WoWPlayer..::..BarTwoPercentage Property

Gets the bar two percentage.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint BarTwoPercentage { get; }
Public ReadOnly Property BarTwoPercentage As UInteger
    Get
public:
property unsigned int^ BarTwoPercentage {
    unsigned int^ get ();
}

Field Value

The bar two percentage.

See Also

WoWPlayer Class
wManager.Wow.ObjectManager Namespace


ComboPoint Property

WoWPlayer..::..ComboPoint Property

Gets the combo point.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int ComboPoint { get; }
Public ReadOnly Property ComboPoint As Integer
    Get
public:
property int^ ComboPoint {
    int^ get ();
}

Field Value

The combo point.

See Also

WoWPlayer Class
wManager.Wow.ObjectManager Namespace


Eclipse Property

WoWPlayer..::..Eclipse Property

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int Eclipse { get; }
Public ReadOnly Property Eclipse As Integer
    Get
public:
property int^ Eclipse {
    int^ get ();
}

See Also

WoWPlayer Class
wManager.Wow.ObjectManager Namespace


EclipsePercentage Property

WoWPlayer..::..EclipsePercentage Property

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int EclipsePercentage { get; }
Public ReadOnly Property EclipsePercentage As Integer
    Get
public:
property int^ EclipsePercentage {
    int^ get ();
}

See Also

WoWPlayer Class
wManager.Wow.ObjectManager Namespace


GetEquipedItem Property

WoWPlayer..::..GetEquipedItem Property

Gets the get equipped items.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint GetEquipedItem { get; }
Public ReadOnly Property GetEquipedItem As UInteger
    Get
public:
property unsigned int^ GetEquipedItem {
    unsigned int^ get ();
}

Field Value

The get equipped items.

See Also

WoWPlayer Class
wManager.Wow.ObjectManager Namespace


IsAlliance Property

WoWPlayer..::..IsAlliance Property

Gets a value indicating whether is in alliance.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsAlliance { get; }
Public ReadOnly Property IsAlliance As Boolean
    Get
public:
property bool^ IsAlliance {
    bool^ get ();
}

Field Value

true if is in alliance; otherwise, false.

See Also

WoWPlayer Class
wManager.Wow.ObjectManager Namespace


IsDead Property

WoWPlayer..::..IsDead Property

Gets a value indicating whether is dead.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsDead { get; }
Public ReadOnly Property IsDead As Boolean
    Get
public:
property bool^ IsDead {
    bool^ get ();
}

Field Value

true if is dead; otherwise, false.

See Also

WoWPlayer Class
wManager.Wow.ObjectManager Namespace


IsHorde Property

WoWPlayer..::..IsHorde Property

Gets a value indicating whether is in horde.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsHorde { get; }
Public ReadOnly Property IsHorde As Boolean
    Get
public:
property bool^ IsHorde {
    bool^ get ();
}

Field Value

true if is in horde; otherwise, false.

See Also

WoWPlayer Class
wManager.Wow.ObjectManager Namespace


IsNeutral Property

WoWPlayer..::..IsNeutral Property

Gets a value indicating whether is neutral (no horde or alliance faction).

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsNeutral { get; }
Public ReadOnly Property IsNeutral As Boolean
    Get
public:
property bool^ IsNeutral {
    bool^ get ();
}

Field Value

true if is neutral; otherwise, false.

See Also

WoWPlayer Class
wManager.Wow.ObjectManager Namespace


MaxEclipse Property

WoWPlayer..::..MaxEclipse Property

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int MaxEclipse { get; }
Public ReadOnly Property MaxEclipse As Integer
    Get
public:
property int^ MaxEclipse {
    int^ get ();
}

See Also

WoWPlayer Class
wManager.Wow.ObjectManager Namespace


MinEclipse Property

WoWPlayer..::..MinEclipse Property

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int MinEclipse { get; }
Public ReadOnly Property MinEclipse As Integer
    Get
public:
property int^ MinEclipse {
    int^ get ();
}

See Also

WoWPlayer Class
wManager.Wow.ObjectManager Namespace


PlayerFaction Property

WoWPlayer..::..PlayerFaction Property

Gets the player faction (value like "Alliance", "Horde", "Neutral").

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string PlayerFaction { get; }
Public ReadOnly Property PlayerFaction As String
    Get
public:
property String^ PlayerFaction {
    String^ get ();
}

Field Value

The player faction.

See Also

WoWPlayer Class
wManager.Wow.ObjectManager Namespace


PlayerRace Property

WoWPlayer..::..PlayerRace Property

Gets the player race.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public PlayerFactions PlayerRace { get; }
Public ReadOnly Property PlayerRace As PlayerFactions
    Get
public:
property PlayerFactions^ PlayerRace {
    PlayerFactions^ get ();
}

Field Value

The player race.

See Also

WoWPlayer Class
wManager.Wow.ObjectManager Namespace


PlayerRaceString Property

WoWPlayer..::..PlayerRaceString Property

Gets the player race string.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string PlayerRaceString { get; }
Public ReadOnly Property PlayerRaceString As String
    Get
public:
property String^ PlayerRaceString {
    String^ get ();
}

Field Value

The player race string.

See Also

WoWPlayer Class
wManager.Wow.ObjectManager Namespace


PowerType Property

WoWPlayer..::..PowerType Property

The unit's power type.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public PowerType PowerType { get; }
Public ReadOnly Property PowerType As PowerType
    Get
public:
property PowerType^ PowerType {
    PowerType^ get ();
}

See Also

WoWPlayer Class
wManager.Wow.ObjectManager Namespace


WowRace Property

WoWPlayer..::..WowRace Property

Gets the wow race.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public WoWRace WowRace { get; }
Public ReadOnly Property WowRace As WoWRace
    Get
public:
property WoWRace^ WowRace {
    WoWRace^ get ();
}

Field Value

The wow race.

See Also

WoWPlayer Class
wManager.Wow.ObjectManager Namespace


WoWUnit Class

Class WoWUnit. Implements the WoWObject

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public class WoWUnit : WoWObject
Public Class WoWUnit _
    Inherits WoWObject
public ref class WoWUnit : public WoWObject

Inheritance Hierarchy

Object
wManager.Wow.ObjectManager..::..WoWObject
wManager.Wow.ObjectManager..::..WoWUnit

See Also

WoWUnit Members
wManager.Wow.ObjectManager Namespace
wManager.Wow.ObjectManager..::..WoWObject


WoWUnit Members

The WoWUnit type exposes the following members.

Constructors

 | Name | Description
Public method | WoWUnit | Initializes a new instance of the WoWUnit class.

Methods

 | Name | Description
Public method | BuffCastedBy | Buff casted by.
Public method | BuffCastedByAll | Buff casted by all.
Public method | BuffStack(List<(Of <<'(UInt32>)>>)) | Buff stack count.
Public method | BuffStack(UInt32) | Buff stack count.
Public method | BuffStack(String) | Buff stack count.
Public method | BuffTimeLeft(String) | Buff time left.
Public method | BuffTimeLeft(List<(Of <<'(UInt32>)>>)) | Buff time left.
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAllBuff | Gets all buff.
Public method | GetBuff(String) | Gets the buff.
Public method | GetBuff(List<(Of <<'(UInt32>)>>)) | Gets the buff.
Public method | GetBuffs(String) | Gets the buffs.
Public method | GetBuffs(List<(Of <<'(UInt32>)>>)) | Gets the buffs.
Public method | GetDescriptorAddress(Descriptors..::..UnitFields) |
Public method | GetDescriptorAddress(Descriptors..::..ObjectFields) | Gets the descriptor address. (Inherited from WoWObject.)
Public method | GetDescriptorAddress(UInt32) | Gets the descriptor address. (Inherited from WoWObject.)
Public method | GetDescriptorAddress(UInt32, UInt32) | Gets the descriptor address. (Inherited from WoWObject.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetMaxPowerByPowerType | Gets maximum power value by type.
Public method | GetMovementFlag | Gets if movement flag is present.
Public method | GetMyBuff | Gets my buff.
Public method | GetPowerByPowerType | Gets power value by power type.
Public method | GetType | (Inherited from Object.)
Public method | HaveBuff(String) | Has the buff.
Public method | HaveBuff(List<(Of <<'(UInt32>)>>)) | Has the buff.
Public method | HaveBuff(UInt32) | Has the buff.
Public method | IsBehind | Determines whether the specified target position is behind.
Public method | IsFacing | Determines whether the specified target position is facing.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Inherited from WoWObject.)

Fields

Name | Description
MaxInteractDistance | The maximum interact distance
MinInteractDistance | The minimum interact distance

Properties

 | Name | Description
Public property | AggroDistance | Gets the aggro distance.
Public property | Alternate | Gets the alternate.
Public property | AlternatePercentage | Gets the alternate percentage.
Public property | ArcaneCharges | Gets the arcane charges.
Public property | ArcaneChargesPercentage | Gets the arcane charges percentage.
Protected property | BaseAddress | (Inherited from WoWObject.)
Protected property | BaseDescriptorAddressCACHE | (Inherited from WoWObject.)
Public property | BurningEmbers | Gets the Burning Embers.
Public property | BurningEmbersPercentage | Gets the Burning Embers percentage.
Public property | CanInterruptCasting | Gets a value indicating whether can interrupt casting.
Public property | CastingSpell | Gets the casting spell.
Public property | CastingSpellId | Gets the casting spell id.
Public property | CastingTimeLeft | Gets the casting time left (in milliseconds).
Public property | Chi | Gets the chi.
Public property | ChiPercentage | Gets the chi percentage.
Public property | CombatReach | Gets the combat reach.
Public property | Confused | Gets a value indicating whether is confused.
Public property | CreatedBy | Gets the created by.
Public property | CreatedBySpell | Gets spell id used to create him.
Public property | CreatureTypeTarget | Gets the creature type target (work only in unit is your current target).
Public property | DarkForce | Gets the dark force.
Public property | DarkForcePercentage | Gets the percentage dark force.
Public property | DBCacheRow | Gets the database cache row.
Public property | DemonicFury | Gets the Demonic Fury.
Public property | DemonicFuryPercentage | Gets the Demonic Fury percentage.
Public property | DisplayId | Gets the display id.
Public property | Eclipse | Gets the Eclipse.
Public property | EclipsePercentage | Gets the Eclipse percentage.
Public property | Energy | Gets the energy.
Public property | EnergyPercentage | Gets the energy percentage.
Public property | Entry | (Inherited from WoWObject.)
Public property | Faction | Gets the faction.
Public property | FactionTemplate | Gets the faction template.
Public property | Fleeing | Gets a value indicating whether is fleeing.
Public property | Focus | Gets the focus.
Public property | FocusPercentage | Gets the focus percentage.
 | ForceRelativePosition | Gets or sets a value indicating whether force to use UseRelativePosition.
Public property | GeHitBoxtDistance | Gets the HitBox distance.
Public property | GetBaseAddress | Gets the base address. (Inherited from WoWObject.)
Public property | GetDescriptorStartAddress | Gets the descriptor start address. (Inherited from WoWObject.)
Public property | GetDistance | Gets the get distance (from local player).
Public property | GetDistance2D | Gets the get distance 2D (from local player).
Public property | GetDistanceZ | Gets the get distance Z (from local player).
Public property | GetDynamicFlags | Gets the unit dynamic flags.
Public property | GetMove | Gets a value indicating whether get move.
Public property | GetUnitDynamicFlags | Gets the unit dynamic flags.
Public property | Guid | Gets the GUID. (Inherited from WoWObject.)
Public property | HasTarget | Gets a value indicating whether has target.
Public property | Health | Gets the health.
Public property | HealthPercent | Gets the health percent.
Public property | HealthRatio | Gets the health ratio.
Public property | HolyPower | Gets the holy power.
Public property | HolyPowerPercentage | Gets the holy power percentage.
Public property | InCombat | Gets a value indicating whether in combat.
Public property | InCombatFlagOnly | Gets a value indicating whether in combat flag only.
Public property | InCombatWithMe | Gets a value indicating whether in combat with me.
Public property | Influenced | Gets a value indicating whether is influenced.
Public property | InteractDistance | Gets or sets the interact distance (you can adjust with MinInteractDistance, MaxInteractDistance and InteractDistanceByEntry, if you set value it is save to InteractDistanceByEntry).
 | InteractDistanceByEntry | Get or set interact distance by entry.
Public property | InTransport | Gets a value indicating whether in transport.
Public property | IsAlive | Gets a value indicating whether is alive.
Public property | IsAttackable | Gets a value indicating whether is attackable.
Public property | IsAuctioneer | Gets a value indicating whether is auctioneer.
Public property | IsBlacklisted | Gets a value indicating whether is blacklisted.
Public property | IsBoss | Gets a value indicating whether is boss.
Public property | IsCast | Gets a value indicating whether is cast.
Public property | IsDead | Gets a value indicating whether is dead.
Public property | IsElite | Gets a value indicating whether is elite.
Public property | IsFlightMaster | Gets a value indicating whether is flight master.
Public property | IsFlying | Gets a value indicating whether is flying.
Public property | IsGoodInteractDistance | Gets a value indicating whether is good interact distance (look InteractDistance).
Public property | IsIndoors | Gets a value indicating whether is indoors.
Public property | IsLocalPlayer | Gets a value indicating whether is local player.
Public property | IsLootable | Gets a value indicating whether is lootable.
Public property | IsMeOrMyPetOrPartyMemberTarget | Gets a value indicating whether is my target or my pet or party member target.
Public property | IsMeOrMyPetTarget | Gets a value indicating whether is my target or my pet target.
Public property | IsMounted | Gets a value indicating whether is mounted.
Public property | IsMyPet | Gets a value indicating whether is my pet.
Public property | IsMyPetTarget | Gets a value indicating whether is my pet target.
Public property | IsMyTarget | Gets a value indicating whether is my target.
Public property | IsNpcInnkeeper | Gets a value indicating whether is NPC innkeeper.
Public property | IsNpcRepair | Gets a value indicating whether is NPC repair.
Public property | IsNpcSpiritHealer | Gets a value indicating whether is NPC spirit healer.
Public property | IsNpcTrainer | Gets a value indicating whether is NPC trainer.
Public property | IsNpcVendor | Gets a value indicating whether is NPC vendor.
Public property | IsNpcVendorFood | Gets a value indicating whether is NPC vendor food.
Public property | IsNpcWildPets | Gets a value indicating whether is NPC wild pets.
Public property | IsOnTaxi | Gets a value indicating whether is on taxi.
Public property | IsOutdoors | Gets a value indicating whether is outdoors.
Public property | IsPartyLeader | Gets a value indicating whether is party leader.
Public property | IsPartyMember | Gets a value indicating whether is party member.
Public property | IsPartyMemberTarget | Gets a value indicating whether is party member target.
Public property | IsPet | Gets a value indicating whether is pet.
Public property | IsStunned | Gets a value indicating whether is stunned.
Public property | IsSwimming | Gets a value indicating whether is swimming.
Public property | IsTaggedByOther | Gets a value indicating Tagged By Other.
Public property | IsTapDenied | Gets a value indicating whether is tap denied.
Public property | IsTargetingMe | Gets a value indicating whether is targeting me.
Public property | IsTargetingMeOrMyPet | Gets a value indicating whether is targeting me or my pet.
Public property | IsTargetingMeOrMyPetOrPartyMember | Gets a value indicating whether is targeting me or my pet or (my) party member.
Public property | IsTargetingMyPet | Gets a value indicating whether is targeting my pet.
Public property | IsTargetingPartyMember | Gets a value indicating whether is targeting (my) party member.
Public property | IsTracked | Gets or sets a value indicating whether is tracked (in in-game minimap).
Public property | IsValid | Returns true if is valid. (Inherited from WoWObject.)
Public property | IsWorldBoss | Gets a value indicating whether is world boss.
Public property | Level | Gets the level.
Public property | LightForce | Gets the light force.
Public property | LightForcePercentage | Gets the percentage light force.
Public property | Mana | Gets the mana.
Public property | ManaPercentage | Gets the mana percentage.
Public property | MaxAlternate | Gets the maximum alternate.
Public property | MaxArcaneCharges | Gets the maximum arcane charges.
Public property | MaxBurningEmbers | Gets the max Burning Embers.
Public property | MaxChi | Gets the maximum chi.
Public property | MaxDarkForce | Gets the max dark force.
Public property | MaxDemonicFury | Gets the max Demonic Fury.
Public property | MaxEclipse | Gets the max Eclipse.
Public property | MaxEnergy | Gets the maximum energy.
Public property | MaxFocus | Gets the maximum focus.
Public property | MaxHealth | Gets the maximum health.
Public property | MaxHolyPower | Gets the maximum holy power.
Public property | MaxLightForce | Gets the max light force.
Public property | MaxMana | Gets the maximum mana.
Public property | MaxRage | Gets the maximum rage.
Public property | MaxRunes | Gets the maximum runes.
Public property | MaxRunicPower | Gets the maximum runic power.
Public property | MaxShadowOrbs | Gets the max Shadow Orbs.
Public property | MaxSoulShards | Gets the maximum soul shards.
Public property | MountDisplayId | Gets the mount display id.
Public property | MyCharacterInFrontHim | Gets a value indicating whether my character in front him.
Public property | Name | Gets the name.
Public property | NotSelectable | Gets a value indicating whether not selectable.
Public property | NpcFlightMastrerIsDiscover | FlightMastrer is discover.
Public property | NpcMarker | Gets the NPC marker.
Public property | NpcMarkerId | Gets the NPC marker id (used by NpcMarker).
Public property | Pacified | Gets a value indicating whether is pacified.
Public property | PetNumber | Gets the pet number.
Public property | PetOwnerGuid | Gets the pet owner GUID.
Public property | Pitch | Gets or sets the pitch.
Public property | PlayerControlled | Gets a value indicating whether player controlled.
Public property | Position | Gets the position.
Public property | PositionRelativeWithoutType | Gets position relative without type (more information about relative position here: UseRelativePosition).
Public property | PositionWithoutType | Gets position without type (without "Flying", ....).
Public property | Possessed | Gets a value indicating whether is possessed.
Public property | Rage | Gets the rage.
Public property | RagePercentage | Gets the rage percentage.
Public property | Reaction | Gets the reaction.
Public property | Rooted | Gets a value indicating whether is rooted.
Public property | Rotation | Gets or sets the rotation (facing).
Public property | Runes | Gets the runes.
Public property | RunesPercentage | Gets the runes percentage.
Public property | RunicPower | Gets the runic power.
Public property | RunicPowerPercentage | Gets the runic power percentage.
Public property | Scale | Gets the scale. (Inherited from WoWObject.)
Public property | ShadowOrbs | Gets the Shadow Orbs.
Public property | ShadowOrbsPercentage | Gets the Shadow Orbs percentage.
Public property | Silenced | Gets a value indicating whether is silenced.
Public property | Skinnable | Gets a value indicating whether is skinnable.
Public property | SoulShards | Gets the soul shards.
Public property | SoulShardsPercentage | Gets the soul shards percentage.
Public property | SpeedMoving | Gets the speed moving.
Public property | Summon | Gets the summon.
Public property | SummonedBy | Gets the summoned by GUID.
Public property | TaggedByMe | Gets a value indicating Tagged By Me.
Public property | Target | Gets or sets the target.
Public property | TargetObject | Gets the target object.
Public property | TransportGuid | Gets the transport GUID (it is WoWGameObject).
Public property | Type | Gets the type. (Inherited from WoWObject.)
Public property | UnitClassification | Gets the unit classification.
Public property | UnitFlags | Gets the unit flags.
Public property | UnitNPCFlags | Gets the unit NPC flags.
 | UseRelativePosition | Gets a value indicating whether use relative position (by default if you are InTransport and this return false the bot returns the Position relative to the world and not relative to transport (boat, elevator, ...), you can force to return true and use PositionRelativeWithoutType with ForceRelativePosition).
Public property | WowClass | Gets the wow class.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


WoWUnit Constructor

Initializes a new instance of the WoWUnit class.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public WoWUnit(
    uint address
)
Public Sub New ( _
    address As UInteger _
)
public:
WoWUnit(
    unsigned int^ address
)

Parameters

address
Type: UInt32
The address.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


WoWUnit Fields

The WoWUnit type exposes the following members.

Fields

Name | Description
MaxInteractDistance | The maximum interact distance
MinInteractDistance | The minimum interact distance

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


MaxInteractDistance Field

WoWUnit..::..MaxInteractDistance Field

The maximum interact distance

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static float MaxInteractDistance
Public Shared MaxInteractDistance As Single
public:
static float^ MaxInteractDistance

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


MinInteractDistance Field

WoWUnit..::..MinInteractDistance Field

The minimum interact distance

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static float MinInteractDistance
Public Shared MinInteractDistance As Single
public:
static float^ MinInteractDistance

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


WoWUnit Methods

The WoWUnit type exposes the following members.

Methods

 | Name | Description
Public method | BuffCastedBy | Buff casted by.
Public method | BuffCastedByAll | Buff casted by all.
Public method | BuffStack(List<(Of <<'(UInt32>)>>)) | Buff stack count.
Public method | BuffStack(UInt32) | Buff stack count.
Public method | BuffStack(String) | Buff stack count.
Public method | BuffTimeLeft(String) | Buff time left.
Public method | BuffTimeLeft(List<(Of <<'(UInt32>)>>)) | Buff time left.
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAllBuff | Gets all buff.
Public method | GetBuff(String) | Gets the buff.
Public method | GetBuff(List<(Of <<'(UInt32>)>>)) | Gets the buff.
Public method | GetBuffs(String) | Gets the buffs.
Public method | GetBuffs(List<(Of <<'(UInt32>)>>)) | Gets the buffs.
Public method | GetDescriptorAddress(Descriptors..::..UnitFields) |
Public method | GetDescriptorAddress(Descriptors..::..ObjectFields) | Gets the descriptor address. (Inherited from WoWObject.)
Public method | GetDescriptorAddress(UInt32) | Gets the descriptor address. (Inherited from WoWObject.)
Public method | GetDescriptorAddress(UInt32, UInt32) | Gets the descriptor address. (Inherited from WoWObject.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetMaxPowerByPowerType | Gets maximum power value by type.
Public method | GetMovementFlag | Gets if movement flag is present.
Public method | GetMyBuff | Gets my buff.
Public method | GetPowerByPowerType | Gets power value by power type.
Public method | GetType | (Inherited from Object.)
Public method | HaveBuff(String) | Has the buff.
Public method | HaveBuff(List<(Of <<'(UInt32>)>>)) | Has the buff.
Public method | HaveBuff(UInt32) | Has the buff.
Public method | IsBehind | Determines whether the specified target position is behind.
Public method | IsFacing | Determines whether the specified target position is facing.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Inherited from WoWObject.)

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


BuffCastedBy Method

WoWUnit..::..BuffCastedBy Method

Buff casted by.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public ulong BuffCastedBy(
    string spellName
)
Public Function BuffCastedBy ( _
    spellName As String _
) As ULong
public:
unsigned long long^ BuffCastedBy(
    String^ spellName
)

Parameters

spellName
Type: String
Name of the spell (in english).

Return Value

GUID.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


BuffCastedByAll Method

WoWUnit..::..BuffCastedByAll Method

Buff casted by all.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<ulong> BuffCastedByAll(
    string spellName
)
Public Function BuffCastedByAll ( _
    spellName As String _
) As List(Of ULong)
public:
List<unsigned long long^>^ BuffCastedByAll(
    String^ spellName
)

Parameters

spellName
Type: String
Name of the spell (in english).

Return Value

GUID.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


BuffStack Method

WoWUnit..::..BuffStack Method

Overload List

 | Name | Description
Public method | BuffStack(List<(Of <<'(UInt32>)>>)) | Buff stack count.
Public method | BuffStack(UInt32) | Buff stack count.
Public method | BuffStack(String) | Buff stack count.

See Also

WoWUnit Class
WoWUnit Members
wManager.Wow.ObjectManager Namespace


BuffStack Method (List(UInt32))

WoWUnit..::..BuffStack Method (List<(Of <(<'UInt32>)>)>)

Buff stack count.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int BuffStack(
    List<uint> idBuffs
)
Public Function BuffStack ( _
    idBuffs As List(Of UInteger) _
) As Integer
public:
int^ BuffStack(
    List<unsigned int^>^ idBuffs
)

Parameters

idBuffs
Type: List <(Of <(<' UInt32 >)>)>
The spell ids.

Return Value

stack count.

See Also

WoWUnit Class
BuffStack Overload
wManager.Wow.ObjectManager Namespace


BuffStack Method (UInt32)

WoWUnit..::..BuffStack Method (UInt32)

Buff stack count.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int BuffStack(
    uint idBuff
)
Public Function BuffStack ( _
    idBuff As UInteger _
) As Integer
public:
int^ BuffStack(
    unsigned int^ idBuff
)

Parameters

idBuff
Type: UInt32
The spell id.

Return Value

stack count.

See Also

WoWUnit Class
BuffStack Overload
wManager.Wow.ObjectManager Namespace


BuffStack Method (String)

WoWUnit..::..BuffStack Method (String)

Buff stack count.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int BuffStack(
    string spellName
)
Public Function BuffStack ( _
    spellName As String _
) As Integer
public:
int^ BuffStack(
    String^ spellName
)

Parameters

spellName
Type: String
Name of the spell (in english).

Return Value

stack count.

See Also

WoWUnit Class
BuffStack Overload
wManager.Wow.ObjectManager Namespace


BuffTimeLeft Method

WoWUnit..::..BuffTimeLeft Method

Overload List

 | Name | Description
Public method | BuffTimeLeft(String) | Buff time left.
Public method | BuffTimeLeft(List<(Of <<'(UInt32>)>>)) | Buff time left.

See Also

WoWUnit Class
WoWUnit Members
wManager.Wow.ObjectManager Namespace


BuffTimeLeft Method (String)

WoWUnit..::..BuffTimeLeft Method (String)

Buff time left.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int BuffTimeLeft(
    string spellName
)
Public Function BuffTimeLeft ( _
    spellName As String _
) As Integer
public:
int^ BuffTimeLeft(
    String^ spellName
)

Parameters

spellName
Type: String
Name of the spell (in english).

Return Value

time left in milliseconds.

See Also

WoWUnit Class
BuffTimeLeft Overload
wManager.Wow.ObjectManager Namespace


BuffTimeLeft Method (List(UInt32))

WoWUnit..::..BuffTimeLeft Method (List<(Of <(<'UInt32>)>)>)

Buff time left.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int BuffTimeLeft(
    List<uint> idBuffs
)
Public Function BuffTimeLeft ( _
    idBuffs As List(Of UInteger) _
) As Integer
public:
int^ BuffTimeLeft(
    List<unsigned int^>^ idBuffs
)

Parameters

idBuffs
Type: List <(Of <(<' UInt32 >)>)>
The spell ids.

Return Value

Time left in milliseconds.

See Also

WoWUnit Class
BuffTimeLeft Overload
wManager.Wow.ObjectManager Namespace


GetAllBuff Method

WoWUnit..::..GetAllBuff Method

Gets all buff.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<Aura> GetAllBuff()
Public Function GetAllBuff As List(Of Aura)
public:
List<Aura^>^ GetAllBuff()

Return Value

Auras.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


GetBuff Method

WoWUnit..::..GetBuff Method

Overload List

 | Name | Description
Public method | GetBuff(String) | Gets the buff.
Public method | GetBuff(List<(Of <<'(UInt32>)>>)) | Gets the buff.

See Also

WoWUnit Class
WoWUnit Members
wManager.Wow.ObjectManager Namespace


GetBuff Method (String)

WoWUnit..::..GetBuff Method (String)

Gets the buff.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Aura GetBuff(
    string spellName
)
Public Function GetBuff ( _
    spellName As String _
) As Aura
public:
Aura^ GetBuff(
    String^ spellName
)

Parameters

spellName
Type: String
Name of the spell (in english).

Return Value

Aura.

See Also

WoWUnit Class
GetBuff Overload
wManager.Wow.ObjectManager Namespace


GetBuff Method (List(UInt32))

WoWUnit..::..GetBuff Method (List<(Of <(<'UInt32>)>)>)

Gets the buff.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Aura GetBuff(
    List<uint> idBuffs
)
Public Function GetBuff ( _
    idBuffs As List(Of UInteger) _
) As Aura
public:
Aura^ GetBuff(
    List<unsigned int^>^ idBuffs
)

Parameters

idBuffs
Type: List <(Of <(<' UInt32 >)>)>
The spell id.

Return Value

Aura.

See Also

WoWUnit Class
GetBuff Overload
wManager.Wow.ObjectManager Namespace


GetBuffs Method

WoWUnit..::..GetBuffs Method

Overload List

 | Name | Description
Public method | GetBuffs(String) | Gets the buffs.
Public method | GetBuffs(List<(Of <<'(UInt32>)>>)) | Gets the buffs.

See Also

WoWUnit Class
WoWUnit Members
wManager.Wow.ObjectManager Namespace


GetBuffs Method (String)

WoWUnit..::..GetBuffs Method (String)

Gets the buffs.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<Aura> GetBuffs(
    string spellName
)
Public Function GetBuffs ( _
    spellName As String _
) As List(Of Aura)
public:
List<Aura^>^ GetBuffs(
    String^ spellName
)

Parameters

spellName
Type: String
Name of the spell (in english).

Return Value

Auras.

See Also

WoWUnit Class
GetBuffs Overload
wManager.Wow.ObjectManager Namespace


GetBuffs Method (List(UInt32))

WoWUnit..::..GetBuffs Method (List<(Of <(<'UInt32>)>)>)

Gets the buffs.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public List<Aura> GetBuffs(
    List<uint> idBuffs
)
Public Function GetBuffs ( _
    idBuffs As List(Of UInteger) _
) As List(Of Aura)
public:
List<Aura^>^ GetBuffs(
    List<unsigned int^>^ idBuffs
)

Parameters

idBuffs
Type: List <(Of <(<' UInt32 >)>)>
The spell ids.

Return Value

Auras.

See Also

WoWUnit Class
GetBuffs Overload
wManager.Wow.ObjectManager Namespace


GetDescriptorAddress Method

WoWUnit..::..GetDescriptorAddress Method

Overload List

 | Name | Description
Public method | GetDescriptorAddress(Descriptors..::..UnitFields) |
Public method | GetDescriptorAddress(Descriptors..::..ObjectFields) | Gets the descriptor address. (Inherited from WoWObject.)
Public method | GetDescriptorAddress(UInt32) | Gets the descriptor address. (Inherited from WoWObject.)
Public method | GetDescriptorAddress(UInt32, UInt32) | Gets the descriptor address. (Inherited from WoWObject.)

See Also

WoWUnit Class
WoWUnit Members
wManager.Wow.ObjectManager Namespace


GetDescriptorAddress Method

WoWUnit..::..GetDescriptorAddress Method

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint GetDescriptorAddress(
    Descriptors..::..UnitFields field
)
Public Function GetDescriptorAddress ( _
    field As Descriptors..::..UnitFields _
) As UInteger
public:
unsigned int^ GetDescriptorAddress(
    Descriptors..::..UnitFields^ field
)

Parameters

field
Type: wManager.Wow.Patchables..::..Descriptors..::..UnitFields

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


GetMaxPowerByPowerType Method

WoWUnit..::..GetMaxPowerByPowerType Method

Gets maximum power value by type.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint GetMaxPowerByPowerType(
    PowerType powerType
)
Public Function GetMaxPowerByPowerType ( _
    powerType As PowerType _
) As UInteger
public:
unsigned int^ GetMaxPowerByPowerType(
    PowerType^ powerType
)

Parameters

powerType
Type: wManager.Wow.Enums..::..PowerType
Type of power.

Return Value

maximum power value.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


GetMovementFlag Method

WoWUnit..::..GetMovementFlag Method

Gets if movement flag is present.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool GetMovementFlag(
    uint offset,
    int flag
)
Public Function GetMovementFlag ( _
    offset As UInteger, _
    flag As Integer _
) As Boolean
public:
bool^ GetMovementFlag(
    unsigned int^ offset,
    int^ flag
)

Parameters

offset
Type: UInt32
The offset.
flag
Type: Int32
The flag.

Return Value

true if movement flag is present., false otherwise.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


GetMyBuff Method

WoWUnit..::..GetMyBuff Method

Gets my buff.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public IEnumerable<Aura> GetMyBuff()
Public Function GetMyBuff As IEnumerable(Of Aura)
public:
IEnumerable<Aura^>^ GetMyBuff()

Return Value

IEnumerable Auras.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


GetPowerByPowerType Method

WoWUnit..::..GetPowerByPowerType Method

Gets power value by power type.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint GetPowerByPowerType(
    PowerType powerType
)
Public Function GetPowerByPowerType ( _
    powerType As PowerType _
) As UInteger
public:
unsigned int^ GetPowerByPowerType(
    PowerType^ powerType
)

Parameters

powerType
Type: wManager.Wow.Enums..::..PowerType
Type of power.

Return Value

power value.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


HaveBuff Method

WoWUnit..::..HaveBuff Method

Overload List

 | Name | Description
Public method | HaveBuff(String) | Has the buff.
Public method | HaveBuff(List<(Of <<'(UInt32>)>>)) | Has the buff.
Public method | HaveBuff(UInt32) | Has the buff.

See Also

WoWUnit Class
WoWUnit Members
wManager.Wow.ObjectManager Namespace


HaveBuff Method (String)

WoWUnit..::..HaveBuff Method (String)

Has the buff.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool HaveBuff(
    string spellName
)
Public Function HaveBuff ( _
    spellName As String _
) As Boolean
public:
bool^ HaveBuff(
    String^ spellName
)

Parameters

spellName
Type: String
Name of the spell (in english).

Return Value

true if has, false otherwise.

See Also

WoWUnit Class
HaveBuff Overload
wManager.Wow.ObjectManager Namespace


HaveBuff Method (List(UInt32))

WoWUnit..::..HaveBuff Method (List<(Of <(<'UInt32>)>)>)

Has the buff.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool HaveBuff(
    List<uint> idBuffs
)
Public Function HaveBuff ( _
    idBuffs As List(Of UInteger) _
) As Boolean
public:
bool^ HaveBuff(
    List<unsigned int^>^ idBuffs
)

Parameters

idBuffs
Type: List <(Of <(<' UInt32 >)>)>
The spell ids.

Return Value

true if has, false otherwise.

See Also

WoWUnit Class
HaveBuff Overload
wManager.Wow.ObjectManager Namespace


HaveBuff Method (UInt32)

WoWUnit..::..HaveBuff Method (UInt32)

Has the buff.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool HaveBuff(
    uint idBuffs
)
Public Function HaveBuff ( _
    idBuffs As UInteger _
) As Boolean
public:
bool^ HaveBuff(
    unsigned int^ idBuffs
)

Parameters

idBuffs
Type: UInt32
The spell id.

Return Value

true if has, false otherwise.

See Also

WoWUnit Class
HaveBuff Overload
wManager.Wow.ObjectManager Namespace


IsBehind Method

WoWUnit..::..IsBehind Method

Determines whether the specified target position is behind.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsBehind(
    Vector3 targetPosition,
    float targetRotationRadian,
    float arcRadians
)
Public Function IsBehind ( _
    targetPosition As Vector3, _
    targetRotationRadian As Single, _
    arcRadians As Single _
) As Boolean
public:
bool^ IsBehind(
    Vector3^ targetPosition,
    float^ targetRotationRadian,
    float^ arcRadians
)

Parameters

targetPosition
Type: robotManager.Helpful..::..Vector3
The target position.
targetRotationRadian
Type: Single
The target rotation radian.
arcRadians
Type: Single
The arc radians.

Return Value

true if the specified target position is behind; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


IsFacing Method

WoWUnit..::..IsFacing Method

Determines whether the specified target position is facing.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsFacing(
    Vector3 targetPosition,
    float arcRadians
)
Public Function IsFacing ( _
    targetPosition As Vector3, _
    arcRadians As Single _
) As Boolean
public:
bool^ IsFacing(
    Vector3^ targetPosition,
    float^ arcRadians
)

Parameters

targetPosition
Type: robotManager.Helpful..::..Vector3
The target position.
arcRadians
Type: Single
The arc radians.

Return Value

true if the specified target position is facing; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


WoWUnit Properties

The WoWUnit type exposes the following members.

Properties

 | Name | Description
Public property | AggroDistance | Gets the aggro distance.
Public property | Alternate | Gets the alternate.
Public property | AlternatePercentage | Gets the alternate percentage.
Public property | ArcaneCharges | Gets the arcane charges.
Public property | ArcaneChargesPercentage | Gets the arcane charges percentage.
Protected property | BaseAddress | (Inherited from WoWObject.)
Protected property | BaseDescriptorAddressCACHE | (Inherited from WoWObject.)
Public property | BurningEmbers | Gets the Burning Embers.
Public property | BurningEmbersPercentage | Gets the Burning Embers percentage.
Public property | CanInterruptCasting | Gets a value indicating whether can interrupt casting.
Public property | CastingSpell | Gets the casting spell.
Public property | CastingSpellId | Gets the casting spell id.
Public property | CastingTimeLeft | Gets the casting time left (in milliseconds).
Public property | Chi | Gets the chi.
Public property | ChiPercentage | Gets the chi percentage.
Public property | CombatReach | Gets the combat reach.
Public property | Confused | Gets a value indicating whether is confused.
Public property | CreatedBy | Gets the created by.
Public property | CreatedBySpell | Gets spell id used to create him.
Public property | CreatureTypeTarget | Gets the creature type target (work only in unit is your current target).
Public property | DarkForce | Gets the dark force.
Public property | DarkForcePercentage | Gets the percentage dark force.
Public property | DBCacheRow | Gets the database cache row.
Public property | DemonicFury | Gets the Demonic Fury.
Public property | DemonicFuryPercentage | Gets the Demonic Fury percentage.
Public property | DisplayId | Gets the display id.
Public property | Eclipse | Gets the Eclipse.
Public property | EclipsePercentage | Gets the Eclipse percentage.
Public property | Energy | Gets the energy.
Public property | EnergyPercentage | Gets the energy percentage.
Public property | Entry | (Inherited from WoWObject.)
Public property | Faction | Gets the faction.
Public property | FactionTemplate | Gets the faction template.
Public property | Fleeing | Gets a value indicating whether is fleeing.
Public property | Focus | Gets the focus.
Public property | FocusPercentage | Gets the focus percentage.
 | ForceRelativePosition | Gets or sets a value indicating whether force to use UseRelativePosition.
Public property | GeHitBoxtDistance | Gets the HitBox distance.
Public property | GetBaseAddress | Gets the base address. (Inherited from WoWObject.)
Public property | GetDescriptorStartAddress | Gets the descriptor start address. (Inherited from WoWObject.)
Public property | GetDistance | Gets the get distance (from local player).
Public property | GetDistance2D | Gets the get distance 2D (from local player).
Public property | GetDistanceZ | Gets the get distance Z (from local player).
Public property | GetDynamicFlags | Gets the unit dynamic flags.
Public property | GetMove | Gets a value indicating whether get move.
Public property | GetUnitDynamicFlags | Gets the unit dynamic flags.
Public property | Guid | Gets the GUID. (Inherited from WoWObject.)
Public property | HasTarget | Gets a value indicating whether has target.
Public property | Health | Gets the health.
Public property | HealthPercent | Gets the health percent.
Public property | HealthRatio | Gets the health ratio.
Public property | HolyPower | Gets the holy power.
Public property | HolyPowerPercentage | Gets the holy power percentage.
Public property | InCombat | Gets a value indicating whether in combat.
Public property | InCombatFlagOnly | Gets a value indicating whether in combat flag only.
Public property | InCombatWithMe | Gets a value indicating whether in combat with me.
Public property | Influenced | Gets a value indicating whether is influenced.
Public property | InteractDistance | Gets or sets the interact distance (you can adjust with MinInteractDistance, MaxInteractDistance and InteractDistanceByEntry, if you set value it is save to InteractDistanceByEntry).
 | InteractDistanceByEntry | Get or set interact distance by entry.
Public property | InTransport | Gets a value indicating whether in transport.
Public property | IsAlive | Gets a value indicating whether is alive.
Public property | IsAttackable | Gets a value indicating whether is attackable.
Public property | IsAuctioneer | Gets a value indicating whether is auctioneer.
Public property | IsBlacklisted | Gets a value indicating whether is blacklisted.
Public property | IsBoss | Gets a value indicating whether is boss.
Public property | IsCast | Gets a value indicating whether is cast.
Public property | IsDead | Gets a value indicating whether is dead.
Public property | IsElite | Gets a value indicating whether is elite.
Public property | IsFlightMaster | Gets a value indicating whether is flight master.
Public property | IsFlying | Gets a value indicating whether is flying.
Public property | IsGoodInteractDistance | Gets a value indicating whether is good interact distance (look InteractDistance).
Public property | IsIndoors | Gets a value indicating whether is indoors.
Public property | IsLocalPlayer | Gets a value indicating whether is local player.
Public property | IsLootable | Gets a value indicating whether is lootable.
Public property | IsMeOrMyPetOrPartyMemberTarget | Gets a value indicating whether is my target or my pet or party member target.
Public property | IsMeOrMyPetTarget | Gets a value indicating whether is my target or my pet target.
Public property | IsMounted | Gets a value indicating whether is mounted.
Public property | IsMyPet | Gets a value indicating whether is my pet.
Public property | IsMyPetTarget | Gets a value indicating whether is my pet target.
Public property | IsMyTarget | Gets a value indicating whether is my target.
Public property | IsNpcInnkeeper | Gets a value indicating whether is NPC innkeeper.
Public property | IsNpcRepair | Gets a value indicating whether is NPC repair.
Public property | IsNpcSpiritHealer | Gets a value indicating whether is NPC spirit healer.
Public property | IsNpcTrainer | Gets a value indicating whether is NPC trainer.
Public property | IsNpcVendor | Gets a value indicating whether is NPC vendor.
Public property | IsNpcVendorFood | Gets a value indicating whether is NPC vendor food.
Public property | IsNpcWildPets | Gets a value indicating whether is NPC wild pets.
Public property | IsOnTaxi | Gets a value indicating whether is on taxi.
Public property | IsOutdoors | Gets a value indicating whether is outdoors.
Public property | IsPartyLeader | Gets a value indicating whether is party leader.
Public property | IsPartyMember | Gets a value indicating whether is party member.
Public property | IsPartyMemberTarget | Gets a value indicating whether is party member target.
Public property | IsPet | Gets a value indicating whether is pet.
Public property | IsStunned | Gets a value indicating whether is stunned.
Public property | IsSwimming | Gets a value indicating whether is swimming.
Public property | IsTaggedByOther | Gets a value indicating Tagged By Other.
Public property | IsTapDenied | Gets a value indicating whether is tap denied.
Public property | IsTargetingMe | Gets a value indicating whether is targeting me.
Public property | IsTargetingMeOrMyPet | Gets a value indicating whether is targeting me or my pet.
Public property | IsTargetingMeOrMyPetOrPartyMember | Gets a value indicating whether is targeting me or my pet or (my) party member.
Public property | IsTargetingMyPet | Gets a value indicating whether is targeting my pet.
Public property | IsTargetingPartyMember | Gets a value indicating whether is targeting (my) party member.
Public property | IsTracked | Gets or sets a value indicating whether is tracked (in in-game minimap).
Public property | IsValid | Returns true if is valid. (Inherited from WoWObject.)
Public property | IsWorldBoss | Gets a value indicating whether is world boss.
Public property | Level | Gets the level.
Public property | LightForce | Gets the light force.
Public property | LightForcePercentage | Gets the percentage light force.
Public property | Mana | Gets the mana.
Public property | ManaPercentage | Gets the mana percentage.
Public property | MaxAlternate | Gets the maximum alternate.
Public property | MaxArcaneCharges | Gets the maximum arcane charges.
Public property | MaxBurningEmbers | Gets the max Burning Embers.
Public property | MaxChi | Gets the maximum chi.
Public property | MaxDarkForce | Gets the max dark force.
Public property | MaxDemonicFury | Gets the max Demonic Fury.
Public property | MaxEclipse | Gets the max Eclipse.
Public property | MaxEnergy | Gets the maximum energy.
Public property | MaxFocus | Gets the maximum focus.
Public property | MaxHealth | Gets the maximum health.
Public property | MaxHolyPower | Gets the maximum holy power.
Public property | MaxLightForce | Gets the max light force.
Public property | MaxMana | Gets the maximum mana.
Public property | MaxRage | Gets the maximum rage.
Public property | MaxRunes | Gets the maximum runes.
Public property | MaxRunicPower | Gets the maximum runic power.
Public property | MaxShadowOrbs | Gets the max Shadow Orbs.
Public property | MaxSoulShards | Gets the maximum soul shards.
Public property | MountDisplayId | Gets the mount display id.
Public property | MyCharacterInFrontHim | Gets a value indicating whether my character in front him.
Public property | Name | Gets the name.
Public property | NotSelectable | Gets a value indicating whether not selectable.
Public property | NpcFlightMastrerIsDiscover | FlightMastrer is discover.
Public property | NpcMarker | Gets the NPC marker.
Public property | NpcMarkerId | Gets the NPC marker id (used by NpcMarker).
Public property | Pacified | Gets a value indicating whether is pacified.
Public property | PetNumber | Gets the pet number.
Public property | PetOwnerGuid | Gets the pet owner GUID.
Public property | Pitch | Gets or sets the pitch.
Public property | PlayerControlled | Gets a value indicating whether player controlled.
Public property | Position | Gets the position.
Public property | PositionRelativeWithoutType | Gets position relative without type (more information about relative position here: UseRelativePosition).
Public property | PositionWithoutType | Gets position without type (without "Flying", ....).
Public property | Possessed | Gets a value indicating whether is possessed.
Public property | Rage | Gets the rage.
Public property | RagePercentage | Gets the rage percentage.
Public property | Reaction | Gets the reaction.
Public property | Rooted | Gets a value indicating whether is rooted.
Public property | Rotation | Gets or sets the rotation (facing).
Public property | Runes | Gets the runes.
Public property | RunesPercentage | Gets the runes percentage.
Public property | RunicPower | Gets the runic power.
Public property | RunicPowerPercentage | Gets the runic power percentage.
Public property | Scale | Gets the scale. (Inherited from WoWObject.)
Public property | ShadowOrbs | Gets the Shadow Orbs.
Public property | ShadowOrbsPercentage | Gets the Shadow Orbs percentage.
Public property | Silenced | Gets a value indicating whether is silenced.
Public property | Skinnable | Gets a value indicating whether is skinnable.
Public property | SoulShards | Gets the soul shards.
Public property | SoulShardsPercentage | Gets the soul shards percentage.
Public property | SpeedMoving | Gets the speed moving.
Public property | Summon | Gets the summon.
Public property | SummonedBy | Gets the summoned by GUID.
Public property | TaggedByMe | Gets a value indicating Tagged By Me.
Public property | Target | Gets or sets the target.
Public property | TargetObject | Gets the target object.
Public property | TransportGuid | Gets the transport GUID (it is WoWGameObject).
Public property | Type | Gets the type. (Inherited from WoWObject.)
Public property | UnitClassification | Gets the unit classification.
Public property | UnitFlags | Gets the unit flags.
Public property | UnitNPCFlags | Gets the unit NPC flags.
 | UseRelativePosition | Gets a value indicating whether use relative position (by default if you are InTransport and this return false the bot returns the Position relative to the world and not relative to transport (boat, elevator, ...), you can force to return true and use PositionRelativeWithoutType with ForceRelativePosition).
Public property | WowClass | Gets the wow class.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


AggroDistance Property

WoWUnit..::..AggroDistance Property

Gets the aggro distance.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int AggroDistance { get; }
Public ReadOnly Property AggroDistance As Integer
    Get
public:
property int^ AggroDistance {
    int^ get ();
}

Field Value

The aggro distance.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


Alternate Property

WoWUnit..::..Alternate Property

Gets the alternate.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint Alternate { get; }
Public ReadOnly Property Alternate As UInteger
    Get
public:
property unsigned int^ Alternate {
    unsigned int^ get ();
}

Field Value

The alternate.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


AlternatePercentage Property

WoWUnit..::..AlternatePercentage Property

Gets the alternate percentage.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint AlternatePercentage { get; }
Public ReadOnly Property AlternatePercentage As UInteger
    Get
public:
property unsigned int^ AlternatePercentage {
    unsigned int^ get ();
}

Field Value

The alternate percentage.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


ArcaneCharges Property

WoWUnit..::..ArcaneCharges Property

Gets the arcane charges.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint ArcaneCharges { get; }
Public ReadOnly Property ArcaneCharges As UInteger
    Get
public:
property unsigned int^ ArcaneCharges {
    unsigned int^ get ();
}

Field Value

The arcane charges.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


ArcaneChargesPercentage Property

WoWUnit..::..ArcaneChargesPercentage Property

Gets the arcane charges percentage.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint ArcaneChargesPercentage { get; }
Public ReadOnly Property ArcaneChargesPercentage As UInteger
    Get
public:
property unsigned int^ ArcaneChargesPercentage {
    unsigned int^ get ();
}

Field Value

The arcane charges percentage.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


BurningEmbers Property

WoWUnit..::..BurningEmbers Property

Gets the Burning Embers.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint BurningEmbers { get; }
Public ReadOnly Property BurningEmbers As UInteger
    Get
public:
property unsigned int^ BurningEmbers {
    unsigned int^ get ();
}

Field Value

The Burning Embers.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


BurningEmbersPercentage Property

WoWUnit..::..BurningEmbersPercentage Property

Gets the Burning Embers percentage.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint BurningEmbersPercentage { get; }
Public ReadOnly Property BurningEmbersPercentage As UInteger
    Get
public:
property unsigned int^ BurningEmbersPercentage {
    unsigned int^ get ();
}

Field Value

The Burning Embers percentage.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


CanInterruptCasting Property

WoWUnit..::..CanInterruptCasting Property

Gets a value indicating whether can interrupt casting.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool CanInterruptCasting { get; }
Public ReadOnly Property CanInterruptCasting As Boolean
    Get
public:
property bool^ CanInterruptCasting {
    bool^ get ();
}

Field Value

true if can interrupt casting; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


CastingSpell Property

WoWUnit..::..CastingSpell Property

Gets the casting spell.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Spell CastingSpell { get; }
Public ReadOnly Property CastingSpell As Spell
    Get
public:
property Spell^ CastingSpell {
    Spell^ get ();
}

Field Value

The casting spell.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


CastingSpellId Property

WoWUnit..::..CastingSpellId Property

Gets the casting spell id.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int CastingSpellId { get; }
Public ReadOnly Property CastingSpellId As Integer
    Get
public:
property int^ CastingSpellId {
    int^ get ();
}

Field Value

The casting spell id.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


CastingTimeLeft Property

WoWUnit..::..CastingTimeLeft Property

Gets the casting time left (in milliseconds).

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int CastingTimeLeft { get; }
Public ReadOnly Property CastingTimeLeft As Integer
    Get
public:
property int^ CastingTimeLeft {
    int^ get ();
}

Field Value

The casting time left (in milliseconds).

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


Chi Property

WoWUnit..::..Chi Property

Gets the chi.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint Chi { get; }
Public ReadOnly Property Chi As UInteger
    Get
public:
property unsigned int^ Chi {
    unsigned int^ get ();
}

Field Value

The chi.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


ChiPercentage Property

WoWUnit..::..ChiPercentage Property

Gets the chi percentage.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint ChiPercentage { get; }
Public ReadOnly Property ChiPercentage As UInteger
    Get
public:
property unsigned int^ ChiPercentage {
    unsigned int^ get ();
}

Field Value

The chi percentage.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


CombatReach Property

WoWUnit..::..CombatReach Property

Gets the combat reach.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float CombatReach { get; }
Public ReadOnly Property CombatReach As Single
    Get
public:
property float^ CombatReach {
    float^ get ();
}

Field Value

The combat reach.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


Confused Property

WoWUnit..::..Confused Property

Gets a value indicating whether is confused.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool Confused { get; }
Public ReadOnly Property Confused As Boolean
    Get
public:
property bool^ Confused {
    bool^ get ();
}

Field Value

true if confused; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


CreatedBy Property

WoWUnit..::..CreatedBy Property

Gets the created by.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public ulong CreatedBy { get; }
Public ReadOnly Property CreatedBy As ULong
    Get
public:
property unsigned long long^ CreatedBy {
    unsigned long long^ get ();
}

Field Value

The created by.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


CreatedBySpell Property

WoWUnit..::..CreatedBySpell Property

Gets spell id used to create him.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int CreatedBySpell { get; }
Public ReadOnly Property CreatedBySpell As Integer
    Get
public:
property int^ CreatedBySpell {
    int^ get ();
}

Field Value

The spell id.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


CreatureTypeTarget Property

WoWUnit..::..CreatureTypeTarget Property

Gets the creature type target (work only in unit is your current target).

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string CreatureTypeTarget { get; }
Public ReadOnly Property CreatureTypeTarget As String
    Get
public:
property String^ CreatureTypeTarget {
    String^ get ();
}

Field Value

The creature type target.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


DarkForce Property

WoWUnit..::..DarkForce Property

Gets the dark force.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint DarkForce { get; }
Public ReadOnly Property DarkForce As UInteger
    Get
public:
property unsigned int^ DarkForce {
    unsigned int^ get ();
}

Field Value

The dark foce.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


DarkForcePercentage Property

WoWUnit..::..DarkForcePercentage Property

Gets the percentage dark force.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint DarkForcePercentage { get; }
Public ReadOnly Property DarkForcePercentage As UInteger
    Get
public:
property unsigned int^ DarkForcePercentage {
    unsigned int^ get ();
}

Field Value

The percentage dark foce.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


DBCacheRow Property

WoWUnit..::..DBCacheRow Property

Gets the database cache row.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint DBCacheRow { get; }
Public ReadOnly Property DBCacheRow As UInteger
    Get
public:
property unsigned int^ DBCacheRow {
    unsigned int^ get ();
}

Field Value

The database cache row.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


DemonicFury Property

WoWUnit..::..DemonicFury Property

Gets the Demonic Fury.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint DemonicFury { get; }
Public ReadOnly Property DemonicFury As UInteger
    Get
public:
property unsigned int^ DemonicFury {
    unsigned int^ get ();
}

Field Value

The Demonic Fury.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


DemonicFuryPercentage Property

WoWUnit..::..DemonicFuryPercentage Property

Gets the Demonic Fury percentage.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint DemonicFuryPercentage { get; }
Public ReadOnly Property DemonicFuryPercentage As UInteger
    Get
public:
property unsigned int^ DemonicFuryPercentage {
    unsigned int^ get ();
}

Field Value

The Demonic Fury percentage.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


DisplayId Property

WoWUnit..::..DisplayId Property

Gets the display id.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint DisplayId { get; }
Public ReadOnly Property DisplayId As UInteger
    Get
public:
property unsigned int^ DisplayId {
    unsigned int^ get ();
}

Field Value

The display id.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


Eclipse Property

WoWUnit..::..Eclipse Property

Gets the Eclipse.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int Eclipse { get; }
Public ReadOnly Property Eclipse As Integer
    Get
public:
property int^ Eclipse {
    int^ get ();
}

Field Value

The Eclipse.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


EclipsePercentage Property

WoWUnit..::..EclipsePercentage Property

Gets the Eclipse percentage.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int EclipsePercentage { get; }
Public ReadOnly Property EclipsePercentage As Integer
    Get
public:
property int^ EclipsePercentage {
    int^ get ();
}

Field Value

The Eclipse percentage.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


Energy Property

WoWUnit..::..Energy Property

Gets the energy.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint Energy { get; }
Public ReadOnly Property Energy As UInteger
    Get
public:
property unsigned int^ Energy {
    unsigned int^ get ();
}

Field Value

The energy.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


EnergyPercentage Property

WoWUnit..::..EnergyPercentage Property

Gets the energy percentage.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint EnergyPercentage { get; }
Public ReadOnly Property EnergyPercentage As UInteger
    Get
public:
property unsigned int^ EnergyPercentage {
    unsigned int^ get ();
}

Field Value

The energy percentage.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


Faction Property

WoWUnit..::..Faction Property

Gets the faction.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint Faction { get; }
Public ReadOnly Property Faction As UInteger
    Get
public:
property unsigned int^ Faction {
    unsigned int^ get ();
}

Field Value

The faction.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


FactionTemplate Property

WoWUnit..::..FactionTemplate Property

Gets the faction template.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public WoWFactionTemplate FactionTemplate { get; }
Public ReadOnly Property FactionTemplate As WoWFactionTemplate
    Get
public:
property WoWFactionTemplate^ FactionTemplate {
    WoWFactionTemplate^ get ();
}

Field Value

The faction template.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


Fleeing Property

WoWUnit..::..Fleeing Property

Gets a value indicating whether is fleeing.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool Fleeing { get; }
Public ReadOnly Property Fleeing As Boolean
    Get
public:
property bool^ Fleeing {
    bool^ get ();
}

Field Value

true if fleeing; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


Focus Property

WoWUnit..::..Focus Property

Gets the focus.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint Focus { get; }
Public ReadOnly Property Focus As UInteger
    Get
public:
property unsigned int^ Focus {
    unsigned int^ get ();
}

Field Value

The focus.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


FocusPercentage Property

WoWUnit..::..FocusPercentage Property

Gets the focus percentage.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint FocusPercentage { get; }
Public ReadOnly Property FocusPercentage As UInteger
    Get
public:
property unsigned int^ FocusPercentage {
    unsigned int^ get ();
}

Field Value

The focus percentage.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


ForceRelativePosition Property

WoWUnit..::..ForceRelativePosition Property

Gets or sets a value indicating whether force to use UseRelativePosition.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool ForceRelativePosition { get; set; }
Public Shared Property ForceRelativePosition As Boolean
    Get
    Set
public:
static property bool^ ForceRelativePosition {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if force to use UseRelativePosition; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


GeHitBoxtDistance Property

WoWUnit..::..GeHitBoxtDistance Property

Gets the HitBox distance.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float GeHitBoxtDistance { get; }
Public ReadOnly Property GeHitBoxtDistance As Single
    Get
public:
property float^ GeHitBoxtDistance {
    float^ get ();
}

Field Value

The HitBox distance.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


GetDistance Property

WoWUnit..::..GetDistance Property

Gets the get distance (from local player).

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float GetDistance { get; }
Public ReadOnly Property GetDistance As Single
    Get
public:
property float^ GetDistance {
    float^ get ();
}

Field Value

The get distance.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


GetDistance2D Property

WoWUnit..::..GetDistance2D Property

Gets the get distance 2D (from local player).

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float GetDistance2D { get; }
Public ReadOnly Property GetDistance2D As Single
    Get
public:
property float^ GetDistance2D {
    float^ get ();
}

Field Value

The get distance 2d.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


GetDistanceZ Property

WoWUnit..::..GetDistanceZ Property

Gets the get distance Z (from local player).

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float GetDistanceZ { get; }
Public ReadOnly Property GetDistanceZ As Single
    Get
public:
property float^ GetDistanceZ {
    float^ get ();
}

Field Value

The get distance z.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


GetDynamicFlags Property

WoWUnit..::..GetDynamicFlags Property

Gets the unit dynamic flags.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int GetDynamicFlags { get; }
Public ReadOnly Property GetDynamicFlags As Integer
    Get
public:
property int^ GetDynamicFlags {
    int^ get ();
}

Field Value

The unit dynamic flags.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


GetMove Property

WoWUnit..::..GetMove Property

Gets a value indicating whether get move.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool GetMove { get; }
Public ReadOnly Property GetMove As Boolean
    Get
public:
property bool^ GetMove {
    bool^ get ();
}

Field Value

true if get move; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


GetUnitDynamicFlags Property

WoWUnit..::..GetUnitDynamicFlags Property

Gets the unit dynamic flags.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public UnitDynamicFlags GetUnitDynamicFlags { get; }
Public ReadOnly Property GetUnitDynamicFlags As UnitDynamicFlags
    Get
public:
property UnitDynamicFlags^ GetUnitDynamicFlags {
    UnitDynamicFlags^ get ();
}

Field Value

The unit dynamic flags.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


HasTarget Property

WoWUnit..::..HasTarget Property

Gets a value indicating whether has target.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool HasTarget { get; }
Public ReadOnly Property HasTarget As Boolean
    Get
public:
property bool^ HasTarget {
    bool^ get ();
}

Field Value

true if has target; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


Health Property

WoWUnit..::..Health Property

Gets the health.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public long Health { get; }
Public ReadOnly Property Health As Long
    Get
public:
property long long^ Health {
    long long^ get ();
}

Field Value

The health.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


HealthPercent Property

WoWUnit..::..HealthPercent Property

Gets the health percent.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public double HealthPercent { get; }
Public ReadOnly Property HealthPercent As Double
    Get
public:
property double^ HealthPercent {
    double^ get ();
}

Field Value

The health percent.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


HealthRatio Property

WoWUnit..::..HealthRatio Property

Gets the health ratio.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public double HealthRatio { get; }
Public ReadOnly Property HealthRatio As Double
    Get
public:
property double^ HealthRatio {
    double^ get ();
}

Field Value

The health ratio.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


HolyPower Property

WoWUnit..::..HolyPower Property

Gets the holy power.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint HolyPower { get; }
Public ReadOnly Property HolyPower As UInteger
    Get
public:
property unsigned int^ HolyPower {
    unsigned int^ get ();
}

Field Value

The holy power.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


HolyPowerPercentage Property

WoWUnit..::..HolyPowerPercentage Property

Gets the holy power percentage.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint HolyPowerPercentage { get; }
Public ReadOnly Property HolyPowerPercentage As UInteger
    Get
public:
property unsigned int^ HolyPowerPercentage {
    unsigned int^ get ();
}

Field Value

The holy power percentage.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


InCombat Property

WoWUnit..::..InCombat Property

Gets a value indicating whether in combat.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public virtual bool InCombat { get; }
Public Overridable ReadOnly Property InCombat As Boolean
    Get
public:
virtual property bool^ InCombat {
    bool^ get ();
}

Field Value

true if in combat; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


InCombatFlagOnly Property

WoWUnit..::..InCombatFlagOnly Property

Gets a value indicating whether in combat flag only.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool InCombatFlagOnly { get; }
Public ReadOnly Property InCombatFlagOnly As Boolean
    Get
public:
property bool^ InCombatFlagOnly {
    bool^ get ();
}

Field Value

true if in combat flag only; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


InCombatWithMe Property

WoWUnit..::..InCombatWithMe Property

Gets a value indicating whether in combat with me.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool InCombatWithMe { get; }
Public ReadOnly Property InCombatWithMe As Boolean
    Get
public:
property bool^ InCombatWithMe {
    bool^ get ();
}

Field Value

true if in combat with me; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


Influenced Property

WoWUnit..::..Influenced Property

Gets a value indicating whether is influenced.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool Influenced { get; }
Public ReadOnly Property Influenced As Boolean
    Get
public:
property bool^ Influenced {
    bool^ get ();
}

Field Value

true if influenced; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


InteractDistance Property

WoWUnit..::..InteractDistance Property

Gets or sets the interact distance (you can adjust with MinInteractDistance, MaxInteractDistance and InteractDistanceByEntry, if you set value it is save to InteractDistanceByEntry).

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float InteractDistance { get; }
Public ReadOnly Property InteractDistance As Single
    Get
public:
property float^ InteractDistance {
    float^ get ();
}

Field Value

The interact distance.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


InteractDistanceByEntry Property

WoWUnit..::..InteractDistanceByEntry Property

Get or set interact distance by entry.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static Dictionary<int, float> InteractDistanceByEntry { get; }
Public Shared ReadOnly Property InteractDistanceByEntry As Dictionary(Of Integer, Single)
    Get
public:
static property Dictionary<int^, float^>^ InteractDistanceByEntry {
    Dictionary<int^, float^>^ get ();
}

Field Value

The interact distance by entry.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


InTransport Property

WoWUnit..::..InTransport Property

Gets a value indicating whether in transport.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool InTransport { get; }
Public ReadOnly Property InTransport As Boolean
    Get
public:
property bool^ InTransport {
    bool^ get ();
}

Field Value

true if in transport; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


IsAlive Property

WoWUnit..::..IsAlive Property

Gets a value indicating whether is alive.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsAlive { get; }
Public ReadOnly Property IsAlive As Boolean
    Get
public:
property bool^ IsAlive {
    bool^ get ();
}

Field Value

true if is alive; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


IsAttackable Property

WoWUnit..::..IsAttackable Property

Gets a value indicating whether is attackable.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsAttackable { get; }
Public ReadOnly Property IsAttackable As Boolean
    Get
public:
property bool^ IsAttackable {
    bool^ get ();
}

Field Value

true if is attackable; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


IsAuctioneer Property

WoWUnit..::..IsAuctioneer Property

Gets a value indicating whether is auctioneer.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsAuctioneer { get; }
Public ReadOnly Property IsAuctioneer As Boolean
    Get
public:
property bool^ IsAuctioneer {
    bool^ get ();
}

Field Value

true if is auctioneer; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


IsBlacklisted Property

WoWUnit..::..IsBlacklisted Property

Gets a value indicating whether is blacklisted.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsBlacklisted { get; }
Public ReadOnly Property IsBlacklisted As Boolean
    Get
public:
property bool^ IsBlacklisted {
    bool^ get ();
}

Field Value

true if is blacklisted; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


IsBoss Property

WoWUnit..::..IsBoss Property

Gets a value indicating whether is boss.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsBoss { get; }
Public ReadOnly Property IsBoss As Boolean
    Get
public:
property bool^ IsBoss {
    bool^ get ();
}

Field Value

true if is boss; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


IsCast Property

WoWUnit..::..IsCast Property

Gets a value indicating whether is cast.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public virtual bool IsCast { get; }
Public Overridable ReadOnly Property IsCast As Boolean
    Get
public:
virtual property bool^ IsCast {
    bool^ get ();
}

Field Value

true if is cast; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


IsDead Property

WoWUnit..::..IsDead Property

Gets a value indicating whether is dead.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public virtual bool IsDead { get; }
Public Overridable ReadOnly Property IsDead As Boolean
    Get
public:
virtual property bool^ IsDead {
    bool^ get ();
}

Field Value

true if is dead; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


IsElite Property

WoWUnit..::..IsElite Property

Gets a value indicating whether is elite.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsElite { get; }
Public ReadOnly Property IsElite As Boolean
    Get
public:
property bool^ IsElite {
    bool^ get ();
}

Field Value

true if is elite; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


IsFlightMaster Property

WoWUnit..::..IsFlightMaster Property

Gets a value indicating whether is flight master.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsFlightMaster { get; }
Public ReadOnly Property IsFlightMaster As Boolean
    Get
public:
property bool^ IsFlightMaster {
    bool^ get ();
}

Field Value

true if is flight master; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


IsFlying Property

WoWUnit..::..IsFlying Property

Gets a value indicating whether is flying.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsFlying { get; }
Public ReadOnly Property IsFlying As Boolean
    Get
public:
property bool^ IsFlying {
    bool^ get ();
}

Field Value

true if is flying; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


IsGoodInteractDistance Property

WoWUnit..::..IsGoodInteractDistance Property

Gets a value indicating whether is good interact distance (look InteractDistance).

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsGoodInteractDistance { get; }
Public ReadOnly Property IsGoodInteractDistance As Boolean
    Get
public:
property bool^ IsGoodInteractDistance {
    bool^ get ();
}

Field Value

true if is good interact distance; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


IsIndoors Property

WoWUnit..::..IsIndoors Property

Gets a value indicating whether is indoors.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsIndoors { get; }
Public ReadOnly Property IsIndoors As Boolean
    Get
public:
property bool^ IsIndoors {
    bool^ get ();
}

Field Value

true if is indoors; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


IsLocalPlayer Property

WoWUnit..::..IsLocalPlayer Property

Gets a value indicating whether is local player.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsLocalPlayer { get; }
Public ReadOnly Property IsLocalPlayer As Boolean
    Get
public:
property bool^ IsLocalPlayer {
    bool^ get ();
}

Field Value

true if is local player; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


IsLootable Property

WoWUnit..::..IsLootable Property

Gets a value indicating whether is lootable.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsLootable { get; }
Public ReadOnly Property IsLootable As Boolean
    Get
public:
property bool^ IsLootable {
    bool^ get ();
}

Field Value

true if is lootable; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


IsMeOrMyPetOrPartyMemberTarget Property

WoWUnit..::..IsMeOrMyPetOrPartyMemberTarget Property

Gets a value indicating whether is my target or my pet or party member target.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsMeOrMyPetOrPartyMemberTarget { get; }
Public ReadOnly Property IsMeOrMyPetOrPartyMemberTarget As Boolean
    Get
public:
property bool^ IsMeOrMyPetOrPartyMemberTarget {
    bool^ get ();
}

Field Value

true if is my target or my pet or party member target; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


IsMeOrMyPetTarget Property

WoWUnit..::..IsMeOrMyPetTarget Property

Gets a value indicating whether is my target or my pet target.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsMeOrMyPetTarget { get; }
Public ReadOnly Property IsMeOrMyPetTarget As Boolean
    Get
public:
property bool^ IsMeOrMyPetTarget {
    bool^ get ();
}

Field Value

true if is my target or my pet target; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


IsMounted Property

WoWUnit..::..IsMounted Property

Gets a value indicating whether is mounted.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public virtual bool IsMounted { get; }
Public Overridable ReadOnly Property IsMounted As Boolean
    Get
public:
virtual property bool^ IsMounted {
    bool^ get ();
}

Field Value

true if is mounted; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


IsMyPet Property

WoWUnit..::..IsMyPet Property

Gets a value indicating whether is my pet.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsMyPet { get; }
Public ReadOnly Property IsMyPet As Boolean
    Get
public:
property bool^ IsMyPet {
    bool^ get ();
}

Field Value

true if is my pet; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


IsMyPetTarget Property

WoWUnit..::..IsMyPetTarget Property

Gets a value indicating whether is my pet target.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsMyPetTarget { get; }
Public ReadOnly Property IsMyPetTarget As Boolean
    Get
public:
property bool^ IsMyPetTarget {
    bool^ get ();
}

Field Value

true if is my pet target; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


IsMyTarget Property

WoWUnit..::..IsMyTarget Property

Gets a value indicating whether is my target.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsMyTarget { get; }
Public ReadOnly Property IsMyTarget As Boolean
    Get
public:
property bool^ IsMyTarget {
    bool^ get ();
}

Field Value

true if is my target; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


IsNpcInnkeeper Property

WoWUnit..::..IsNpcInnkeeper Property

Gets a value indicating whether is NPC innkeeper.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsNpcInnkeeper { get; }
Public ReadOnly Property IsNpcInnkeeper As Boolean
    Get
public:
property bool^ IsNpcInnkeeper {
    bool^ get ();
}

Field Value

true if is NPC innkeeper; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


IsNpcRepair Property

WoWUnit..::..IsNpcRepair Property

Gets a value indicating whether is NPC repair.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsNpcRepair { get; }
Public ReadOnly Property IsNpcRepair As Boolean
    Get
public:
property bool^ IsNpcRepair {
    bool^ get ();
}

Field Value

true if is NPC repair; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


IsNpcSpiritHealer Property

WoWUnit..::..IsNpcSpiritHealer Property

Gets a value indicating whether is NPC spirit healer.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsNpcSpiritHealer { get; }
Public ReadOnly Property IsNpcSpiritHealer As Boolean
    Get
public:
property bool^ IsNpcSpiritHealer {
    bool^ get ();
}

Field Value

true if is NPC spirit healer; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


IsNpcTrainer Property

WoWUnit..::..IsNpcTrainer Property

Gets a value indicating whether is NPC trainer.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsNpcTrainer { get; }
Public ReadOnly Property IsNpcTrainer As Boolean
    Get
public:
property bool^ IsNpcTrainer {
    bool^ get ();
}

Field Value

true if is NPC trainer; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


IsNpcVendor Property

WoWUnit..::..IsNpcVendor Property

Gets a value indicating whether is NPC vendor.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsNpcVendor { get; }
Public ReadOnly Property IsNpcVendor As Boolean
    Get
public:
property bool^ IsNpcVendor {
    bool^ get ();
}

Field Value

true if is NPC vendor; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


IsNpcVendorFood Property

WoWUnit..::..IsNpcVendorFood Property

Gets a value indicating whether is NPC vendor food.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsNpcVendorFood { get; }
Public ReadOnly Property IsNpcVendorFood As Boolean
    Get
public:
property bool^ IsNpcVendorFood {
    bool^ get ();
}

Field Value

true if is NPC vendor food; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


IsNpcWildPets Property

WoWUnit..::..IsNpcWildPets Property

Gets a value indicating whether is NPC wild pets.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsNpcWildPets { get; }
Public ReadOnly Property IsNpcWildPets As Boolean
    Get
public:
property bool^ IsNpcWildPets {
    bool^ get ();
}

Field Value

true if is NPC wild pets; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


IsOnTaxi Property

WoWUnit..::..IsOnTaxi Property

Gets a value indicating whether is on taxi.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsOnTaxi { get; }
Public ReadOnly Property IsOnTaxi As Boolean
    Get
public:
property bool^ IsOnTaxi {
    bool^ get ();
}

Field Value

true if is on taxi; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


IsOutdoors Property

WoWUnit..::..IsOutdoors Property

Gets a value indicating whether is outdoors.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsOutdoors { get; }
Public ReadOnly Property IsOutdoors As Boolean
    Get
public:
property bool^ IsOutdoors {
    bool^ get ();
}

Field Value

true if is outdoors; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


IsPartyLeader Property

WoWUnit..::..IsPartyLeader Property

Gets a value indicating whether is party leader.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsPartyLeader { get; }
Public ReadOnly Property IsPartyLeader As Boolean
    Get
public:
property bool^ IsPartyLeader {
    bool^ get ();
}

Field Value

true if is party leader; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


IsPartyMember Property

WoWUnit..::..IsPartyMember Property

Gets a value indicating whether is party member.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public virtual bool IsPartyMember { get; }
Public Overridable ReadOnly Property IsPartyMember As Boolean
    Get
public:
virtual property bool^ IsPartyMember {
    bool^ get ();
}

Field Value

true if is party member; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


IsPartyMemberTarget Property

WoWUnit..::..IsPartyMemberTarget Property

Gets a value indicating whether is party member target.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsPartyMemberTarget { get; }
Public ReadOnly Property IsPartyMemberTarget As Boolean
    Get
public:
property bool^ IsPartyMemberTarget {
    bool^ get ();
}

Field Value

true if is party member target; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


IsPet Property

WoWUnit..::..IsPet Property

Gets a value indicating whether is pet.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsPet { get; }
Public ReadOnly Property IsPet As Boolean
    Get
public:
property bool^ IsPet {
    bool^ get ();
}

Field Value

true if is pet; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


IsStunned Property

WoWUnit..::..IsStunned Property

Gets a value indicating whether is stunned.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsStunned { get; }
Public ReadOnly Property IsStunned As Boolean
    Get
public:
property bool^ IsStunned {
    bool^ get ();
}

Field Value

true if is stunned; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


IsSwimming Property

WoWUnit..::..IsSwimming Property

Gets a value indicating whether is swimming.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsSwimming { get; }
Public ReadOnly Property IsSwimming As Boolean
    Get
public:
property bool^ IsSwimming {
    bool^ get ();
}

Field Value

true if is swimming; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


IsTaggedByOther Property

WoWUnit..::..IsTaggedByOther Property

Gets a value indicating Tagged By Other.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsTaggedByOther { get; }
Public ReadOnly Property IsTaggedByOther As Boolean
    Get
public:
property bool^ IsTaggedByOther {
    bool^ get ();
}

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


IsTapDenied Property

WoWUnit..::..IsTapDenied Property

Gets a value indicating whether is tap denied.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsTapDenied { get; }
Public ReadOnly Property IsTapDenied As Boolean
    Get
public:
property bool^ IsTapDenied {
    bool^ get ();
}

Field Value

true if is tap denied; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


IsTargetingMe Property

WoWUnit..::..IsTargetingMe Property

Gets a value indicating whether is targeting me.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsTargetingMe { get; }
Public ReadOnly Property IsTargetingMe As Boolean
    Get
public:
property bool^ IsTargetingMe {
    bool^ get ();
}

Field Value

true if is targeting me; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


IsTargetingMeOrMyPet Property

WoWUnit..::..IsTargetingMeOrMyPet Property

Gets a value indicating whether is targeting me or my pet.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsTargetingMeOrMyPet { get; }
Public ReadOnly Property IsTargetingMeOrMyPet As Boolean
    Get
public:
property bool^ IsTargetingMeOrMyPet {
    bool^ get ();
}

Field Value

true if is targeting me or my pet; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


IsTargetingMeOrMyPetOrPartyMember Property

WoWUnit..::..IsTargetingMeOrMyPetOrPartyMember Property

Gets a value indicating whether is targeting me or my pet or (my) party member.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsTargetingMeOrMyPetOrPartyMember { get; }
Public ReadOnly Property IsTargetingMeOrMyPetOrPartyMember As Boolean
    Get
public:
property bool^ IsTargetingMeOrMyPetOrPartyMember {
    bool^ get ();
}

Field Value

true if is targeting me or my pet or party member; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


IsTargetingMyPet Property

WoWUnit..::..IsTargetingMyPet Property

Gets a value indicating whether is targeting my pet.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsTargetingMyPet { get; }
Public ReadOnly Property IsTargetingMyPet As Boolean
    Get
public:
property bool^ IsTargetingMyPet {
    bool^ get ();
}

Field Value

true if is targeting my pet; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


IsTargetingPartyMember Property

WoWUnit..::..IsTargetingPartyMember Property

Gets a value indicating whether is targeting (my) party member.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsTargetingPartyMember { get; }
Public ReadOnly Property IsTargetingPartyMember As Boolean
    Get
public:
property bool^ IsTargetingPartyMember {
    bool^ get ();
}

Field Value

true if is targeting party member; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


IsTracked Property

WoWUnit..::..IsTracked Property

Gets or sets a value indicating whether is tracked (in in-game minimap).

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsTracked { get; set; }
Public Property IsTracked As Boolean
    Get
    Set
public:
property bool^ IsTracked {
    bool^ get ();
    void set (bool^ value);
}

Field Value

true if is tracked; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


IsWorldBoss Property

WoWUnit..::..IsWorldBoss Property

Gets a value indicating whether is world boss.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool IsWorldBoss { get; }
Public ReadOnly Property IsWorldBoss As Boolean
    Get
public:
property bool^ IsWorldBoss {
    bool^ get ();
}

Field Value

true if is world boss; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


Level Property

WoWUnit..::..Level Property

Gets the level.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint Level { get; }
Public ReadOnly Property Level As UInteger
    Get
public:
property unsigned int^ Level {
    unsigned int^ get ();
}

Field Value

The level.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


LightForce Property

WoWUnit..::..LightForce Property

Gets the light force.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint LightForce { get; }
Public ReadOnly Property LightForce As UInteger
    Get
public:
property unsigned int^ LightForce {
    unsigned int^ get ();
}

Field Value

The light foce.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


LightForcePercentage Property

WoWUnit..::..LightForcePercentage Property

Gets the percentage light force.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint LightForcePercentage { get; }
Public ReadOnly Property LightForcePercentage As UInteger
    Get
public:
property unsigned int^ LightForcePercentage {
    unsigned int^ get ();
}

Field Value

The percentage light foce.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


Mana Property

WoWUnit..::..Mana Property

Gets the mana.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint Mana { get; }
Public ReadOnly Property Mana As UInteger
    Get
public:
property unsigned int^ Mana {
    unsigned int^ get ();
}

Field Value

The mana.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


ManaPercentage Property

WoWUnit..::..ManaPercentage Property

Gets the mana percentage.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint ManaPercentage { get; }
Public ReadOnly Property ManaPercentage As UInteger
    Get
public:
property unsigned int^ ManaPercentage {
    unsigned int^ get ();
}

Field Value

The mana percentage.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


MaxAlternate Property

WoWUnit..::..MaxAlternate Property

Gets the maximum alternate.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint MaxAlternate { get; }
Public ReadOnly Property MaxAlternate As UInteger
    Get
public:
property unsigned int^ MaxAlternate {
    unsigned int^ get ();
}

Field Value

The maximum alternate.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


MaxArcaneCharges Property

WoWUnit..::..MaxArcaneCharges Property

Gets the maximum arcane charges.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint MaxArcaneCharges { get; }
Public ReadOnly Property MaxArcaneCharges As UInteger
    Get
public:
property unsigned int^ MaxArcaneCharges {
    unsigned int^ get ();
}

Field Value

The maximum arcane charges.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


MaxBurningEmbers Property

WoWUnit..::..MaxBurningEmbers Property

Gets the max Burning Embers.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint MaxBurningEmbers { get; }
Public ReadOnly Property MaxBurningEmbers As UInteger
    Get
public:
property unsigned int^ MaxBurningEmbers {
    unsigned int^ get ();
}

Field Value

The max Burning Embers.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


MaxChi Property

WoWUnit..::..MaxChi Property

Gets the maximum chi.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint MaxChi { get; }
Public ReadOnly Property MaxChi As UInteger
    Get
public:
property unsigned int^ MaxChi {
    unsigned int^ get ();
}

Field Value

The maximum chi.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


MaxDarkForce Property

WoWUnit..::..MaxDarkForce Property

Gets the max dark force.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint MaxDarkForce { get; }
Public ReadOnly Property MaxDarkForce As UInteger
    Get
public:
property unsigned int^ MaxDarkForce {
    unsigned int^ get ();
}

Field Value

The max dark foce.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


MaxDemonicFury Property

WoWUnit..::..MaxDemonicFury Property

Gets the max Demonic Fury.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint MaxDemonicFury { get; }
Public ReadOnly Property MaxDemonicFury As UInteger
    Get
public:
property unsigned int^ MaxDemonicFury {
    unsigned int^ get ();
}

Field Value

The max Demonic Fury.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


MaxEclipse Property

WoWUnit..::..MaxEclipse Property

Gets the max Eclipse.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int MaxEclipse { get; }
Public ReadOnly Property MaxEclipse As Integer
    Get
public:
property int^ MaxEclipse {
    int^ get ();
}

Field Value

The max Eclipse.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


MaxEnergy Property

WoWUnit..::..MaxEnergy Property

Gets the maximum energy.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint MaxEnergy { get; }
Public ReadOnly Property MaxEnergy As UInteger
    Get
public:
property unsigned int^ MaxEnergy {
    unsigned int^ get ();
}

Field Value

The maximum energy.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


MaxFocus Property

WoWUnit..::..MaxFocus Property

Gets the maximum focus.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint MaxFocus { get; }
Public ReadOnly Property MaxFocus As UInteger
    Get
public:
property unsigned int^ MaxFocus {
    unsigned int^ get ();
}

Field Value

The maximum focus.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


MaxHealth Property

WoWUnit..::..MaxHealth Property

Gets the maximum health.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public long MaxHealth { get; }
Public ReadOnly Property MaxHealth As Long
    Get
public:
property long long^ MaxHealth {
    long long^ get ();
}

Field Value

The maximum health.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


MaxHolyPower Property

WoWUnit..::..MaxHolyPower Property

Gets the maximum holy power.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint MaxHolyPower { get; }
Public ReadOnly Property MaxHolyPower As UInteger
    Get
public:
property unsigned int^ MaxHolyPower {
    unsigned int^ get ();
}

Field Value

The maximum holy power.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


MaxLightForce Property

WoWUnit..::..MaxLightForce Property

Gets the max light force.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint MaxLightForce { get; }
Public ReadOnly Property MaxLightForce As UInteger
    Get
public:
property unsigned int^ MaxLightForce {
    unsigned int^ get ();
}

Field Value

The max light foce.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


MaxMana Property

WoWUnit..::..MaxMana Property

Gets the maximum mana.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint MaxMana { get; }
Public ReadOnly Property MaxMana As UInteger
    Get
public:
property unsigned int^ MaxMana {
    unsigned int^ get ();
}

Field Value

The maximum mana.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


MaxRage Property

WoWUnit..::..MaxRage Property

Gets the maximum rage.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint MaxRage { get; }
Public ReadOnly Property MaxRage As UInteger
    Get
public:
property unsigned int^ MaxRage {
    unsigned int^ get ();
}

Field Value

The maximum rage.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


MaxRunes Property

WoWUnit..::..MaxRunes Property

Gets the maximum runes.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint MaxRunes { get; }
Public ReadOnly Property MaxRunes As UInteger
    Get
public:
property unsigned int^ MaxRunes {
    unsigned int^ get ();
}

Field Value

The maximum runes.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


MaxRunicPower Property

WoWUnit..::..MaxRunicPower Property

Gets the maximum runic power.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint MaxRunicPower { get; }
Public ReadOnly Property MaxRunicPower As UInteger
    Get
public:
property unsigned int^ MaxRunicPower {
    unsigned int^ get ();
}

Field Value

The maximum runic power.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


MaxShadowOrbs Property

WoWUnit..::..MaxShadowOrbs Property

Gets the max Shadow Orbs.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint MaxShadowOrbs { get; }
Public ReadOnly Property MaxShadowOrbs As UInteger
    Get
public:
property unsigned int^ MaxShadowOrbs {
    unsigned int^ get ();
}

Field Value

The max Shadow Orbs.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


MaxSoulShards Property

WoWUnit..::..MaxSoulShards Property

Gets the maximum soul shards.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint MaxSoulShards { get; }
Public ReadOnly Property MaxSoulShards As UInteger
    Get
public:
property unsigned int^ MaxSoulShards {
    unsigned int^ get ();
}

Field Value

The maximum soul shards.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


MountDisplayId Property

WoWUnit..::..MountDisplayId Property

Gets the mount display id.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int MountDisplayId { get; }
Public ReadOnly Property MountDisplayId As Integer
    Get
public:
property int^ MountDisplayId {
    int^ get ();
}

Field Value

The mount display id.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


MyCharacterInFrontHim Property

WoWUnit..::..MyCharacterInFrontHim Property

Gets a value indicating whether my character in front him.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool MyCharacterInFrontHim { get; }
Public ReadOnly Property MyCharacterInFrontHim As Boolean
    Get
public:
property bool^ MyCharacterInFrontHim {
    bool^ get ();
}

Field Value

true if my character in front him; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


Name Property

WoWUnit..::..Name Property

Gets the name.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}

Field Value

The name.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


NotSelectable Property

WoWUnit..::..NotSelectable Property

Gets a value indicating whether not selectable.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool NotSelectable { get; }
Public ReadOnly Property NotSelectable As Boolean
    Get
public:
property bool^ NotSelectable {
    bool^ get ();
}

Field Value

true if not selectable; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


NpcFlightMastrerIsDiscover Property

WoWUnit..::..NpcFlightMastrerIsDiscover Property

FlightMastrer is discover.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool NpcFlightMastrerIsDiscover { get; }
Public ReadOnly Property NpcFlightMastrerIsDiscover As Boolean
    Get
public:
property bool^ NpcFlightMastrerIsDiscover {
    bool^ get ();
}

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


NpcMarker Property

WoWUnit..::..NpcMarker Property

Gets the NPC marker.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public NpcMarker NpcMarker { get; }
Public ReadOnly Property NpcMarker As NpcMarker
    Get
public:
property NpcMarker^ NpcMarker {
    NpcMarker^ get ();
}

Field Value

The NPC marker.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


NpcMarkerId Property

WoWUnit..::..NpcMarkerId Property

Gets the NPC marker id (used by NpcMarker).

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int NpcMarkerId { get; }
Public ReadOnly Property NpcMarkerId As Integer
    Get
public:
property int^ NpcMarkerId {
    int^ get ();
}

Field Value

The NPC marker identifier.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


Pacified Property

WoWUnit..::..Pacified Property

Gets a value indicating whether is pacified.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool Pacified { get; }
Public ReadOnly Property Pacified As Boolean
    Get
public:
property bool^ Pacified {
    bool^ get ();
}

Field Value

true if pacified; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


PetNumber Property

WoWUnit..::..PetNumber Property

Gets the pet number.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int PetNumber { get; }
Public ReadOnly Property PetNumber As Integer
    Get
public:
property int^ PetNumber {
    int^ get ();
}

Field Value

The pet number.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


PetOwnerGuid Property

WoWUnit..::..PetOwnerGuid Property

Gets the pet owner GUID.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public ulong PetOwnerGuid { get; }
Public ReadOnly Property PetOwnerGuid As ULong
    Get
public:
property unsigned long long^ PetOwnerGuid {
    unsigned long long^ get ();
}

Field Value

owner GUID.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


Pitch Property

WoWUnit..::..Pitch Property

Gets or sets the pitch.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float Pitch { get; set; }
Public Property Pitch As Single
    Get
    Set
public:
property float^ Pitch {
    float^ get ();
    void set (float^ value);
}

Field Value

The pitch.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


PlayerControlled Property

WoWUnit..::..PlayerControlled Property

Gets a value indicating whether player controlled.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool PlayerControlled { get; }
Public ReadOnly Property PlayerControlled As Boolean
    Get
public:
property bool^ PlayerControlled {
    bool^ get ();
}

Field Value

true if player controlled; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


Position Property

WoWUnit..::..Position Property

Gets the position.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Vector3 Position { get; }
Public ReadOnly Property Position As Vector3
    Get
public:
property Vector3^ Position {
    Vector3^ get ();
}

Field Value

The position.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


PositionRelativeWithoutType Property

WoWUnit..::..PositionRelativeWithoutType Property

Gets position relative without type (more information about relative position here: UseRelativePosition).

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Vector3 PositionRelativeWithoutType { get; }
Public ReadOnly Property PositionRelativeWithoutType As Vector3
    Get
public:
property Vector3^ PositionRelativeWithoutType {
    Vector3^ get ();
}

Field Value

The position relative without type.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


PositionWithoutType Property

WoWUnit..::..PositionWithoutType Property

Gets position without type (without "Flying", ....).

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Vector3 PositionWithoutType { get; }
Public ReadOnly Property PositionWithoutType As Vector3
    Get
public:
property Vector3^ PositionWithoutType {
    Vector3^ get ();
}

Field Value

The position without type.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


Possessed Property

WoWUnit..::..Possessed Property

Gets a value indicating whether is possessed.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool Possessed { get; }
Public ReadOnly Property Possessed As Boolean
    Get
public:
property bool^ Possessed {
    bool^ get ();
}

Field Value

true if possessed; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


Rage Property

WoWUnit..::..Rage Property

Gets the rage.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint Rage { get; }
Public ReadOnly Property Rage As UInteger
    Get
public:
property unsigned int^ Rage {
    unsigned int^ get ();
}

Field Value

The rage.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


RagePercentage Property

WoWUnit..::..RagePercentage Property

Gets the rage percentage.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint RagePercentage { get; }
Public ReadOnly Property RagePercentage As UInteger
    Get
public:
property unsigned int^ RagePercentage {
    unsigned int^ get ();
}

Field Value

The rage percentage.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


Reaction Property

WoWUnit..::..Reaction Property

Gets the reaction.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Reaction Reaction { get; }
Public ReadOnly Property Reaction As Reaction
    Get
public:
property Reaction^ Reaction {
    Reaction^ get ();
}

Field Value

The reaction.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


Rooted Property

WoWUnit..::..Rooted Property

Gets a value indicating whether is rooted.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool Rooted { get; }
Public ReadOnly Property Rooted As Boolean
    Get
public:
property bool^ Rooted {
    bool^ get ();
}

Field Value

true if rooted; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


Rotation Property

WoWUnit..::..Rotation Property

Gets or sets the rotation (facing).

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float Rotation { get; set; }
Public Property Rotation As Single
    Get
    Set
public:
property float^ Rotation {
    float^ get ();
    void set (float^ value);
}

Field Value

The rotation.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


Runes Property

WoWUnit..::..Runes Property

Gets the runes.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public virtual uint Runes { get; }
Public Overridable ReadOnly Property Runes As UInteger
    Get
public:
virtual property unsigned int^ Runes {
    unsigned int^ get ();
}

Field Value

The runes.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


RunesPercentage Property

WoWUnit..::..RunesPercentage Property

Gets the runes percentage.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint RunesPercentage { get; }
Public ReadOnly Property RunesPercentage As UInteger
    Get
public:
property unsigned int^ RunesPercentage {
    unsigned int^ get ();
}

Field Value

The runes percentage.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


RunicPower Property

WoWUnit..::..RunicPower Property

Gets the runic power.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint RunicPower { get; }
Public ReadOnly Property RunicPower As UInteger
    Get
public:
property unsigned int^ RunicPower {
    unsigned int^ get ();
}

Field Value

The runic power.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


RunicPowerPercentage Property

WoWUnit..::..RunicPowerPercentage Property

Gets the runic power percentage.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint RunicPowerPercentage { get; }
Public ReadOnly Property RunicPowerPercentage As UInteger
    Get
public:
property unsigned int^ RunicPowerPercentage {
    unsigned int^ get ();
}

Field Value

The runic power percentage.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


ShadowOrbs Property

WoWUnit..::..ShadowOrbs Property

Gets the Shadow Orbs.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint ShadowOrbs { get; }
Public ReadOnly Property ShadowOrbs As UInteger
    Get
public:
property unsigned int^ ShadowOrbs {
    unsigned int^ get ();
}

Field Value

The Shadow Orbs.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


ShadowOrbsPercentage Property

WoWUnit..::..ShadowOrbsPercentage Property

Gets the Shadow Orbs percentage.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint ShadowOrbsPercentage { get; }
Public ReadOnly Property ShadowOrbsPercentage As UInteger
    Get
public:
property unsigned int^ ShadowOrbsPercentage {
    unsigned int^ get ();
}

Field Value

The Shadow Orbs percentage.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


Silenced Property

WoWUnit..::..Silenced Property

Gets a value indicating whether is silenced.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool Silenced { get; }
Public ReadOnly Property Silenced As Boolean
    Get
public:
property bool^ Silenced {
    bool^ get ();
}

Field Value

true if silenced; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


Skinnable Property

WoWUnit..::..Skinnable Property

Gets a value indicating whether is skinnable.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool Skinnable { get; }
Public ReadOnly Property Skinnable As Boolean
    Get
public:
property bool^ Skinnable {
    bool^ get ();
}

Field Value

true if skinnable; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


SoulShards Property

WoWUnit..::..SoulShards Property

Gets the soul shards.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint SoulShards { get; }
Public ReadOnly Property SoulShards As UInteger
    Get
public:
property unsigned int^ SoulShards {
    unsigned int^ get ();
}

Field Value

The soul shards.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


SoulShardsPercentage Property

WoWUnit..::..SoulShardsPercentage Property

Gets the soul shards percentage.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint SoulShardsPercentage { get; }
Public ReadOnly Property SoulShardsPercentage As UInteger
    Get
public:
property unsigned int^ SoulShardsPercentage {
    unsigned int^ get ();
}

Field Value

The soul shards percentage.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


SpeedMoving Property

WoWUnit..::..SpeedMoving Property

Gets the speed moving.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public float SpeedMoving { get; }
Public ReadOnly Property SpeedMoving As Single
    Get
public:
property float^ SpeedMoving {
    float^ get ();
}

Field Value

The speed moving.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


Summon Property

WoWUnit..::..Summon Property

Gets the summon.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public ulong Summon { get; }
Public ReadOnly Property Summon As ULong
    Get
public:
property unsigned long long^ Summon {
    unsigned long long^ get ();
}

Field Value

The summon.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


SummonedBy Property

WoWUnit..::..SummonedBy Property

Gets the summoned by GUID.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public ulong SummonedBy { get; }
Public ReadOnly Property SummonedBy As ULong
    Get
public:
property unsigned long long^ SummonedBy {
    unsigned long long^ get ();
}

Field Value

GUID.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


TaggedByMe Property

WoWUnit..::..TaggedByMe Property

Gets a value indicating Tagged By Me.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public bool TaggedByMe { get; }
Public ReadOnly Property TaggedByMe As Boolean
    Get
public:
property bool^ TaggedByMe {
    bool^ get ();
}

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


Target Property

WoWUnit..::..Target Property

Gets or sets the target.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public ulong Target { get; set; }
Public Property Target As ULong
    Get
    Set
public:
property unsigned long long^ Target {
    unsigned long long^ get ();
    void set (unsigned long long^ value);
}

Field Value

The target.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


TargetObject Property

WoWUnit..::..TargetObject Property

Gets the target object.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public WoWUnit TargetObject { get; }
Public ReadOnly Property TargetObject As WoWUnit
    Get
public:
property WoWUnit^ TargetObject {
    WoWUnit^ get ();
}

Field Value

The target object.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


TransportGuid Property

WoWUnit..::..TransportGuid Property

Gets the transport GUID (it is WoWGameObject).

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public ulong TransportGuid { get; }
Public ReadOnly Property TransportGuid As ULong
    Get
public:
property unsigned long long^ TransportGuid {
    unsigned long long^ get ();
}

Field Value

The transport GUID.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


UnitClassification Property

WoWUnit..::..UnitClassification Property

Gets the unit classification.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public UnitClassification UnitClassification { get; }
Public ReadOnly Property UnitClassification As UnitClassification
    Get
public:
property UnitClassification^ UnitClassification {
    UnitClassification^ get ();
}

Field Value

The unit classification.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


UnitFlags Property

WoWUnit..::..UnitFlags Property

Gets the unit flags.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public UnitFlags UnitFlags { get; }
Public ReadOnly Property UnitFlags As UnitFlags
    Get
public:
property UnitFlags^ UnitFlags {
    UnitFlags^ get ();
}

Field Value

The unit flags.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


UnitNPCFlags Property

WoWUnit..::..UnitNPCFlags Property

Gets the unit NPC flags.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public UnitNPCFlags UnitNPCFlags { get; }
Public ReadOnly Property UnitNPCFlags As UnitNPCFlags
    Get
public:
property UnitNPCFlags^ UnitNPCFlags {
    UnitNPCFlags^ get ();
}

Field Value

The unit NPC flags.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


UseRelativePosition Property

WoWUnit..::..UseRelativePosition Property

Gets a value indicating whether use relative position (by default if you are InTransport and this return false the bot returns the Position relative to the world and not relative to transport (boat, elevator, ...), you can force to return true and use PositionRelativeWithoutType with ForceRelativePosition).

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public static bool UseRelativePosition { get; }
Public Shared ReadOnly Property UseRelativePosition As Boolean
    Get
public:
static property bool^ UseRelativePosition {
    bool^ get ();
}

Field Value

true if use relative position; otherwise, false.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


WowClass Property

WoWUnit..::..WowClass Property

Gets the wow class.

Namespace: wManager.Wow.ObjectManager
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public WoWClass WowClass { get; }
Public ReadOnly Property WowClass As WoWClass
    Get
public:
property WoWClass^ WowClass {
    WoWClass^ get ();
}

Field Value

The wow class.

See Also

WoWUnit Class
wManager.Wow.ObjectManager Namespace


wManager.Wow.Patchables Namespace

Enumerations

 | Enumeration | Description
Public enumeration | Descriptors..::..ContainerFields |
Public enumeration | Descriptors..::..CorpseFields |
Public enumeration | Descriptors..::..DynamicObjectFields |
Public enumeration | Descriptors..::..GameObjectFields |
Public enumeration | Descriptors..::..ItemFields |
Public enumeration | Descriptors..::..ObjectFields |
Public enumeration | Descriptors..::..PlayerFields |
Public enumeration | Descriptors..::..UnitFields |


Descriptors.ContainerFields Enumeration

Descriptors..::..ContainerFields Enumeration

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public enum ContainerFields
Public Enumeration ContainerFields
public enum class ContainerFields

Members

Member name | Description
NumSlots |
AlignPad |
Slot1 |

See Also

wManager.Wow.Patchables Namespace


Descriptors.CorpseFields Enumeration

Descriptors..::..CorpseFields Enumeration

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public enum CorpseFields
Public Enumeration CorpseFields
public enum class CorpseFields

Members

Member name | Description
Owner |
Party |
DisplayID |
Item |
bytes1 |
Bytes2 |
Guild |
Flags |
Dynamicflags |
Pad |

See Also

wManager.Wow.Patchables Namespace


Descriptors.DynamicObjectFields Enumeration

Descriptors..::..DynamicObjectFields Enumeration

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public enum DynamicObjectFields
Public Enumeration DynamicObjectFields
public enum class DynamicObjectFields

Members

Member name | Description
Caster |
Bytes |
SpellID |
Radius |
CastTime |

See Also

wManager.Wow.Patchables Namespace


Descriptors.GameObjectFields Enumeration

Descriptors..::..GameObjectFields Enumeration

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public enum GameObjectFields
Public Enumeration GameObjectFields
public enum class GameObjectFields

Members

Member name | Description
CreatedBy |
DisplayID |
Flags |
ParentRotation |
Dynamic |
Faction |
Level |
Bytes1 |

See Also

wManager.Wow.Patchables Namespace


Descriptors.ItemFields Enumeration

Descriptors..::..ItemFields Enumeration

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public enum ItemFields
Public Enumeration ItemFields
public enum class ItemFields

Members

Member name | Description
Owner |
ContainedIn |
Creator |
Giftcreator |
StackCount |
Duration |
SpellCharges |
Flags |
Enchantment11 |
Enchantment13 |
Enchantment21 |
Enchantment23 |
Enchantment31 |
Enchantment33 |
Enchantment41 |
Enchantment43 |
Enchantment51 |
Enchantment53 |
Enchantment61 |
Enchantment63 |
Enchantment71 |
Enchantment73 |
Enchantment81 |
Enchantment83 |
Enchantment91 |
Enchantment93 |
Enchantment101 |
Enchantment103 |
Enchantment111 |
Enchantment113 |
Enchantment121 |
Enchantment123 |
PropertySeed |
RandomPropertiesid |
Durability |
MaxDurability |
CreatePlayedTime |
Pad |

See Also

wManager.Wow.Patchables Namespace


Descriptors.ObjectFields Enumeration

Descriptors..::..ObjectFields Enumeration

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public enum ObjectFields
Public Enumeration ObjectFields
public enum class ObjectFields

Members

Member name | Description
Guid |
Type |
EntryID |
Scale |
Padding |

See Also

wManager.Wow.Patchables Namespace


Descriptors.PlayerFields Enumeration

Descriptors..::..PlayerFields Enumeration

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public enum PlayerFields
Public Enumeration PlayerFields
public enum class PlayerFields

Members

Member name | Description
DuelArbiter |
Flags |
GuildID |
GuildRank |
Bytes |
Bytes2 |
Bytes3 |
DuelTeam |
GuildTimeStamp |
QuestLog11 |
QuestLog12 |
QuestLog13 |
QuestLog14 |
QuestLog21 |
QuestLog22 |
QuestLog23 |
QuestLog25 |
QuestLog31 |
QuestLog32 |
QuestLog33 |
QuestLog35 |
QuestLog41 |
QuestLog42 |
QuestLog43 |
QuestLog45 |
QuestLog51 |
QuestLog52 |
QuestLog53 |
QuestLog55 |
QuestLog61 |
QuestLog62 |
QuestLog63 |
QuestLog65 |
QuestLog71 |
QuestLog72 |
QuestLog73 |
QuestLog75 |
QuestLog81 |
QuestLog82 |
QuestLog83 |
QuestLog85 |
QuestLog91 |
QuestLog92 |
QuestLog93 |
QuestLog95 |
QuestLog101 |
QuestLog102 |
QuestLog103 |
QuestLog105 |
QuestLog111 |
QuestLog112 |
QuestLog113 |
QuestLog115 |
QuestLog121 |
QuestLog122 |
QuestLog123 |
QuestLog125 |
QuestLog131 |
QuestLog132 |
QuestLog133 |
QuestLog135 |
QuestLog141 |
QuestLog142 |
QuestLog143 |
QuestLog145 |
QuestLog151 |
QuestLog152 |
QuestLog153 |
QuestLog155 |
QuestLog161 |
QuestLog162 |
QuestLog163 |
QuestLog165 |
QuestLog171 |
QuestLog172 |
QuestLog173 |
QuestLog175 |
QuestLog181 |
QuestLog182 |
QuestLog183 |
QuestLog185 |
QuestLog191 |
QuestLog192 |
QuestLog193 |
QuestLog195 |
QuestLog201 |
QuestLog202 |
QuestLog203 |
QuestLog205 |
QuestLog211 |
QuestLog212 |
QuestLog213 |
QuestLog215 |
QuestLog221 |
QuestLog222 |
QuestLog223 |
QuestLog225 |
QuestLog231 |
QuestLog232 |
QuestLog233 |
QuestLog235 |
QuestLog241 |
QuestLog242 |
QuestLog243 |
QuestLog245 |
QuestLog251 |
QuestLog252 |
QuestLog253 |
QuestLog255 |
VisibleItem1Entryid |
VisibleItem1Enchantment |
VisibleItem2Entryid |
VisibleItem2Enchantment |
VisibleItem3Entryid |
VisibleItem3Enchantment |
VisibleItem4Entryid |
VisibleItem4Enchantment |
VisibleItem5Entryid |
VisibleItem5Enchantment |
VisibleItem6Entryid |
VisibleItem6Enchantment |
VisibleItem7Entryid |
VisibleItem7Enchantment |
VisibleItem8Entryid |
VisibleItem8Enchantment |
VisibleItem9Entryid |
VisibleItem9Enchantment |
VisibleItem10Entryid |
VisibleItem10Enchantment |
VisibleItem11Entryid |
VisibleItem11Enchantment |
VisibleItem12Entryid |
VisibleItem12Enchantment |
VisibleItem13Entryid |
VisibleItem13Enchantment |
VisibleItem14Entryid |
VisibleItem14Enchantment |
VisibleItem15Entryid |
VisibleItem15Enchantment |
VisibleItem16Entryid |
VisibleItem16Enchantment |
VisibleItem17Entryid |
VisibleItem17Enchantment |
VisibleItem18Entryid |
VisibleItem18Enchantment |
VisibleItem19Entryid |
VisibleItem19Enchantment |
ChosenTitle |
FakeInebriation |
Pad0 |
InvSlotHead |
PackSlot1 |
BankSlot1 |
BankBagSlot1 |
VendorBuyBackSlot1 |
KeyringSlot1 |
CurrencyTokenSlot1 |
Farsight |
KnownTitles |
KnownTitles1 |
KnownTitles2 |
KnownCurrencies |
XP |
NextLevelXP |
SkillInfo11 |
CharacterPointS1 |
CharacterPointS2 |
TrackCreatureMask |
TrackResourceMask |
BlockPercentagE |
DodgePercentage |
ParryPercentage |
Expertise |
OffhandExPertise |
CritPercentage |
RangedCritPercentage |
OffhandCritPercentage |
SpellCritPercentage1 |
ShieldBlock |
ShieldBlockCritPercentage |
ExploredZoneS1 |
RestStateExperience |
Coinage |
ModDamageDonePos |
ModDamageDoneNeg |
ModDamageDonePct |
ModHEALINGDonePos |
ModHealingPct |
ModHealingDonePct |
ModTargetResistance |
ModTargetPhysicalResistance |
FieldBytes |
Ammoid |
SelfREsSpell |
PvpMedals |
BuyBackPrice1 |
BuyBackTimeStamp1 |
Kills |
TodayContribution |
YesterdayContribution |
LifetimeHonorbaleKills |
FieldBytes2 |
WATCHEDFACTIONINDEX |
COMBATRATING1 |
ARENATEAMINFO11 |
HONORCurrency |
ARENACurrency |
MaxLEVEL |
DailyQuests1 |
RuneRegen1 |
NoReagentCost1 |
GlyphSlots1 |
Glyphs1 |
GlyphsEnabled |
PetSpellPower |

See Also

wManager.Wow.Patchables Namespace


Descriptors.UnitFields Enumeration

Descriptors..::..UnitFields Enumeration

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public enum UnitFields
Public Enumeration UnitFields
public enum class UnitFields

Members

Member name | Description
Charm |
Summon |
Critter |
CharmedBy |
SummonedBy |
CreatedBy |
Target |
ChannelObject |
UnitChannelSpell |
Bytes0 |
Health |
Power1 |
Power2 |
Power3 |
Power4 |
Power5 |
Power6 |
Power7 |
MaxHealth |
Maxpower1 |
Maxpower2 |
Maxpower3 |
Maxpower4 |
Maxpower5 |
Maxpower6 |
Maxpower7 |
PowerRegenFlatModifier |
PowerRegenInterruptedFlatModifier |
Level |
FactionTemplate |
UnitVirtualItemSlotID |
Flags |
Flags2 |
auraState |
BaseAttackTime |
RangeDattackTime |
BoundingRadius |
CombatReach |
DisplayID |
NativeDisplayID |
MountDisplayID |
MinDamage |
MaxDamage |
MinOffhandDamage |
MaxOffhandDamage |
Bytes1 |
PetNumber |
PetNameTimeStamp |
PetExperience |
PetNextLevelExp |
DynamicFlags |
ModCastSpeed |
CreatedBySpell |
NpcFlags |
NpcEmoteState |
Stat0 |
Stat1 |
Stat2 |
Stat3 |
Stat4 |
PosStat0 |
PosStat1 |
PosStat2 |
PosStat3 |
PosStat4 |
NegStat0 |
NegStat1 |
NegStat2 |
NegStat3 |
NegStat4 |
Resistances |
ResistanceBuffModsPositive |
RESISTANCEBUFFMODSNegative |
BaseMana |
BaseHealth |
Bytes2 |
AttackPower |
AttackPowerMods |
AttackPowerMultiplier |
RangedAttackPower |
RangedAttackPowerMods |
RangedAttackPowerMultiplier |
MinRangedDamage |
MaxRangedDamage |
PowerCostModifier |
PowerCostMultiplier |
MaxHealthModifier |
HoverHeight |
Padding |

See Also

wManager.Wow.Patchables Namespace


Else Members

The Else type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Else Class
Quester.Profile.HB Namespace


ElseIf Members

The ElseIf type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

ElseIf Class
Quester.Profile.HB Namespace


EndWhile Members

The EndWhile type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

EndWhile Class
Quester.Profile.HB Namespace


GrindTo Members

The GrindTo type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

GrindTo Class
Quester.Profile.HB Namespace


Hotspot Members

The Hotspot type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Hotspot Class
Quester.Profile.HB Namespace


Mailbox Members

The Mailbox type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

Mailbox Class
Quester.Profile.HB Namespace


While Members

The While type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

While Class
Quester.Profile.HB Namespace


DBCStruct Members

The DBCStruct type exposes the following members.

Methods

 | Name | Description
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)

See Also

DBCStruct Class
wManager.Wow.Class Namespace


QuestEmptyClass Members

The QuestEmptyClass type exposes the following members.

Methods

 | Name | Description
Public method | CanConditions | Determines whether this can (by default this option return true, conditions can be added by override this method). (Inherited from QuestClass.)
Public method | Equals(System.Object) | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | HasQuest | Check if character have one of QuestId in his quest log. (Inherited from QuestClass.)
Public method | IsComplete | Determines if quest objective is complete (Step and StepAutoDetect). (Inherited from QuestClass.)
Public method | IsCompleted | Quest is completed (already turn in, or can't do (min/max level, required quest, character class)). (Inherited from QuestClass.)
Public method | IsCompleteObjectiveIndex | Determines whether is complete objective by objective index (Inherited from QuestClass.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | PickUp | Go to NPC and Pick up quest. (Inherited from QuestClass.)
Public method | Pulse | Pulse quest (Inherited from QuestClass.)
Public method | PulseAllInOne | Pulses all in one (PickUp()()()(), Pulse()()()(), TurnIn()()()()). (Inherited from QuestClass.)
Public method | Reset | Resets this instance (reset to default the progress). When you override this method don't forget to call method of super class. (Inherited from QuestClass.)
Public method | ToString | (Inherited from Object.)
Public method | TurnIn | Go to NPC and turn in quest. (Inherited from QuestClass.)
Public method | WhenLeaveStep | Called one time when the quester product leave this step (with Pulse or PulseAllInOne action). (Inherited from QuestClass.)
Public method | WhenSelectStep | Called one time when the quester product select this step (with Pulse or PulseAllInOne action). (Inherited from QuestClass.)

Properties

 | Name | Description
Public property | GossipOptionItem | Gets or sets the gossip option to use to select reward item. (Inherited from QuestClass.)
Public property | NpcPickUp | Gets the NPC where pick up quest (search in NPCList). (Inherited from QuestClass.)
Public property | NpcTurnIn | Gets the NPC to turn in quest (search in NPCList).. (Inherited from QuestClass.)
Public property | QuestId | Gets or sets the quest IDs list. (Inherited from QuestClass.)
Public property | Step | Gets or sets the quest objectives required count (example, if this quest need 5 kills for objective 3 use Step = new List<int> {0, 0, 5, 0, 0};. (Inherited from QuestClass.)
Public property | StepAutoDetect | Gets or sets the quest objectives to auto detect if complete (example, if you want detect if the objective 4 is done StepAutoDetect = new List<bool> {false, false, false, true, false};. (Inherited from QuestClass.)

See Also

QuestEmptyClass Class
wManager.Wow.Class Namespace


FollowNpc Field

EasyQuestType..::..FollowNpc Field

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public const EasyQuestType FollowNpc
Public Const FollowNpc As EasyQuestType
public:
literal EasyQuestType FollowNpc

See Also

EasyQuestType Enumeration
Quester.Profile Namespace


FollowPath Field

EasyQuestType..::..FollowPath Field

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public const EasyQuestType FollowPath
Public Const FollowPath As EasyQuestType
public:
literal EasyQuestType FollowPath

See Also

EasyQuestType Enumeration
Quester.Profile Namespace


FullCSharpCode Field

EasyQuestType..::..FullCSharpCode Field

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public const EasyQuestType FullCSharpCode
Public Const FullCSharpCode As EasyQuestType
public:
literal EasyQuestType FullCSharpCode

See Also

EasyQuestType Enumeration
Quester.Profile Namespace


Gatherer Field

EasyQuestType..::..Gatherer Field

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public const EasyQuestType Gatherer
Public Const Gatherer As EasyQuestType
public:
literal EasyQuestType Gatherer

See Also

EasyQuestType Enumeration
Quester.Profile Namespace


GrinderGathererQuests Field

EasyQuestType..::..GrinderGathererQuests Field

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public const EasyQuestType GrinderGathererQuests
Public Const GrinderGathererQuests As EasyQuestType
public:
literal EasyQuestType GrinderGathererQuests

See Also

EasyQuestType Enumeration
Quester.Profile Namespace


InteractWithNpc Field

EasyQuestType..::..InteractWithNpc Field

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public const EasyQuestType InteractWithNpc
Public Const InteractWithNpc As EasyQuestType
public:
literal EasyQuestType InteractWithNpc

See Also

EasyQuestType Enumeration
Quester.Profile Namespace


KillAndLoot Field

EasyQuestType..::..KillAndLoot Field

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public const EasyQuestType KillAndLoot
Public Const KillAndLoot As EasyQuestType
public:
literal EasyQuestType KillAndLoot

See Also

EasyQuestType Enumeration
Quester.Profile Namespace


None Field

EasyQuestType..::..None Field

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public const EasyQuestType None
Public Const None As EasyQuestType
public:
literal EasyQuestType None

See Also

EasyQuestType Enumeration
Quester.Profile Namespace


OverridePulseCSharpCode Field

EasyQuestType..::..OverridePulseCSharpCode Field

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public const EasyQuestType OverridePulseCSharpCode
Public Const OverridePulseCSharpCode As EasyQuestType
public:
literal EasyQuestType OverridePulseCSharpCode

See Also

EasyQuestType Enumeration
Quester.Profile Namespace


ParallelQuests Field

EasyQuestType..::..ParallelQuests Field

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public const EasyQuestType ParallelQuests
Public Const ParallelQuests As EasyQuestType
public:
literal EasyQuestType ParallelQuests

See Also

EasyQuestType Enumeration
Quester.Profile Namespace


UseItemOn Field

EasyQuestType..::..UseItemOn Field

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public const EasyQuestType UseItemOn
Public Const UseItemOn As EasyQuestType
public:
literal EasyQuestType UseItemOn

See Also

EasyQuestType Enumeration
Quester.Profile Namespace


UseScriptOn Field

EasyQuestType..::..UseScriptOn Field

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public const EasyQuestType UseScriptOn
Public Const UseScriptOn As EasyQuestType
public:
literal EasyQuestType UseScriptOn

See Also

EasyQuestType Enumeration
Quester.Profile Namespace


UseSpellOn Field

EasyQuestType..::..UseSpellOn Field

Namespace: Quester.Profile
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public const EasyQuestType UseSpellOn
Public Const UseSpellOn As EasyQuestType
public:
literal EasyQuestType UseSpellOn

See Also

EasyQuestType Enumeration
Quester.Profile Namespace


Running Field

Status..::..Running Field

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public const Status Running
Public Const Running As Status
public:
literal Status Running

See Also

Status Enumeration
Relogger.Classes Namespace


Stopped Field

Status..::..Stopped Field

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public const Status Stopped
Public Const Stopped As Status
public:
literal Status Stopped

See Also

Status Enumeration
Relogger.Classes Namespace


Stopping Field

Status..::..Stopping Field

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public const Status Stopping
Public Const Stopping As Status
public:
literal Status Stopping

See Also

Status Enumeration
Relogger.Classes Namespace


WaitingSchedule Field

Status..::..WaitingSchedule Field

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public const Status WaitingSchedule
Public Const WaitingSchedule As Status
public:
literal Status WaitingSchedule

See Also

Status Enumeration
Relogger.Classes Namespace


ChangeCharacter Field

TaskType..::..ChangeCharacter Field

Task ChangeCharacterReloggerTask

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public const TaskType ChangeCharacter
Public Const ChangeCharacter As TaskType
public:
literal TaskType ChangeCharacter

See Also

TaskType Enumeration
Relogger.Classes Namespace


ChangeRagnarLicenseKey Field

TaskType..::..ChangeRagnarLicenseKey Field

Task ChangeWRobotLicenseKeyReloggerTask

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public const TaskType ChangeRagnarLicenseKey
Public Const ChangeRagnarLicenseKey As TaskType
public:
literal TaskType ChangeRagnarLicenseKey

See Also

TaskType Enumeration
Relogger.Classes Namespace


ChangeRagnarPath Field

TaskType..::..ChangeRagnarPath Field

Task ChangeWRobotPathReloggerTask

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public const TaskType ChangeRagnarPath
Public Const ChangeRagnarPath As TaskType
public:
literal TaskType ChangeRagnarPath

See Also

TaskType Enumeration
Relogger.Classes Namespace


ChangeWowPath Field

TaskType..::..ChangeWowPath Field

Task ChangeWowPathReloggerTask

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public const TaskType ChangeWowPath
Public Const ChangeWowPath As TaskType
public:
literal TaskType ChangeWowPath

See Also

TaskType Enumeration
Relogger.Classes Namespace


None Field

TaskType..::..None Field

Task BaseReloggerTask

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public const TaskType None
Public Const None As TaskType
public:
literal TaskType None

See Also

TaskType Enumeration
Relogger.Classes Namespace


Run Field

TaskType..::..Run Field

Task RunReloggerTask

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public const TaskType Run
Public Const Run As TaskType
public:
literal TaskType Run

See Also

TaskType Enumeration
Relogger.Classes Namespace


Wait Field

TaskType..::..Wait Field

Task WaitReloggerTask

Namespace: Relogger.Classes
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public const TaskType Wait
Public Const Wait As TaskType
public:
literal TaskType Wait

See Also

TaskType Enumeration
Relogger.Classes Namespace


SWP_ASYNCWINDOWPOS Field

SetWindowPosFlags..::..SWP_ASYNCWINDOWPOS Field

If the calling thread and the thread that owns the window are attached to different input queues, the system posts the request to the thread that owns the window. This prevents the calling thread from blocking its execution while other threads process the request.

Namespace: Relogger
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public const Utility..::..SetWindowPosFlags SWP_ASYNCWINDOWPOS
Public Const SWP_ASYNCWINDOWPOS As Utility..::..SetWindowPosFlags
public:
literal Utility..::..SetWindowPosFlags SWP_ASYNCWINDOWPOS

See Also

Utility..::..SetWindowPosFlags Enumeration
Relogger Namespace


SWP_DEFERERASE Field

SetWindowPosFlags..::..SWP_DEFERERASE Field

Prevents generation of the WM_SYNCPAINT message.

Namespace: Relogger
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public const Utility..::..SetWindowPosFlags SWP_DEFERERASE
Public Const SWP_DEFERERASE As Utility..::..SetWindowPosFlags
public:
literal Utility..::..SetWindowPosFlags SWP_DEFERERASE

See Also

Utility..::..SetWindowPosFlags Enumeration
Relogger Namespace


SWP_DRAWFRAME Field

SetWindowPosFlags..::..SWP_DRAWFRAME Field

Draws a frame (defined in the window's class description) around the window.

Namespace: Relogger
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public const Utility..::..SetWindowPosFlags SWP_DRAWFRAME
Public Const SWP_DRAWFRAME As Utility..::..SetWindowPosFlags
public:
literal Utility..::..SetWindowPosFlags SWP_DRAWFRAME

See Also

Utility..::..SetWindowPosFlags Enumeration
Relogger Namespace


SWP_FRAMECHANGED Field

SetWindowPosFlags..::..SWP_FRAMECHANGED Field

Applies new frame styles set using the SetWindowLong function. Sends a WM_NCCALCSIZE message to the window, even if the window's size is not being changed. If this flag is not specified, WM_NCCALCSIZE is sent only when the window's size is being changed.

Namespace: Relogger
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public const Utility..::..SetWindowPosFlags SWP_FRAMECHANGED
Public Const SWP_FRAMECHANGED As Utility..::..SetWindowPosFlags
public:
literal Utility..::..SetWindowPosFlags SWP_FRAMECHANGED

See Also

Utility..::..SetWindowPosFlags Enumeration
Relogger Namespace


SWP_HIDEWINDOW Field

SetWindowPosFlags..::..SWP_HIDEWINDOW Field

Hides the window.

Namespace: Relogger
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public const Utility..::..SetWindowPosFlags SWP_HIDEWINDOW
Public Const SWP_HIDEWINDOW As Utility..::..SetWindowPosFlags
public:
literal Utility..::..SetWindowPosFlags SWP_HIDEWINDOW

See Also

Utility..::..SetWindowPosFlags Enumeration
Relogger Namespace


SWP_NOACTIVATE Field

SetWindowPosFlags..::..SWP_NOACTIVATE Field

Does not activate the window. If this flag is not set, the window is activated and moved to the top of either the topmost or non-topmost group (depending on the setting of the hWndInsertAfter parameter).

Namespace: Relogger
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public const Utility..::..SetWindowPosFlags SWP_NOACTIVATE
Public Const SWP_NOACTIVATE As Utility..::..SetWindowPosFlags
public:
literal Utility..::..SetWindowPosFlags SWP_NOACTIVATE

See Also

Utility..::..SetWindowPosFlags Enumeration
Relogger Namespace


SWP_NOCOPYBITS Field

SetWindowPosFlags..::..SWP_NOCOPYBITS Field

Discards the entire contents of the client area. If this flag is not specified, the valid contents of the client area are saved and copied back into the client area after the window is sized or repositioned.

Namespace: Relogger
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public const Utility..::..SetWindowPosFlags SWP_NOCOPYBITS
Public Const SWP_NOCOPYBITS As Utility..::..SetWindowPosFlags
public:
literal Utility..::..SetWindowPosFlags SWP_NOCOPYBITS

See Also

Utility..::..SetWindowPosFlags Enumeration
Relogger Namespace


SWP_NOMOVE Field

SetWindowPosFlags..::..SWP_NOMOVE Field

Retains the current position (ignores X and Y parameters).

Namespace: Relogger
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public const Utility..::..SetWindowPosFlags SWP_NOMOVE
Public Const SWP_NOMOVE As Utility..::..SetWindowPosFlags
public:
literal Utility..::..SetWindowPosFlags SWP_NOMOVE

See Also

Utility..::..SetWindowPosFlags Enumeration
Relogger Namespace


SWP_NOOWNERZORDER Field

SetWindowPosFlags..::..SWP_NOOWNERZORDER Field

Does not change the owner window's position in the Z order.

Namespace: Relogger
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public const Utility..::..SetWindowPosFlags SWP_NOOWNERZORDER
Public Const SWP_NOOWNERZORDER As Utility..::..SetWindowPosFlags
public:
literal Utility..::..SetWindowPosFlags SWP_NOOWNERZORDER

See Also

Utility..::..SetWindowPosFlags Enumeration
Relogger Namespace


SWP_NOREDRAW Field

SetWindowPosFlags..::..SWP_NOREDRAW Field

Does not redraw changes. If this flag is set, no repainting of any kind occurs. This applies to the client area, the nonclient area (including the title bar and scroll bars), and any part of the parent window uncovered as a result of the window being moved. When this flag is set, the application must explicitly invalidate or redraw any parts of the window and parent window that need redrawing.

Namespace: Relogger
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public const Utility..::..SetWindowPosFlags SWP_NOREDRAW
Public Const SWP_NOREDRAW As Utility..::..SetWindowPosFlags
public:
literal Utility..::..SetWindowPosFlags SWP_NOREDRAW

See Also

Utility..::..SetWindowPosFlags Enumeration
Relogger Namespace


SWP_NOREPOSITION Field

SetWindowPosFlags..::..SWP_NOREPOSITION Field

Same as the SWP_NOOWNERZORDER flag.

Namespace: Relogger
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public const Utility..::..SetWindowPosFlags SWP_NOREPOSITION
Public Const SWP_NOREPOSITION As Utility..::..SetWindowPosFlags
public:
literal Utility..::..SetWindowPosFlags SWP_NOREPOSITION

See Also

Utility..::..SetWindowPosFlags Enumeration
Relogger Namespace


SWP_NOSENDCHANGING Field

SetWindowPosFlags..::..SWP_NOSENDCHANGING Field

Prevents the window from receiving the WM_WINDOWPOSCHANGING message.

Namespace: Relogger
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public const Utility..::..SetWindowPosFlags SWP_NOSENDCHANGING
Public Const SWP_NOSENDCHANGING As Utility..::..SetWindowPosFlags
public:
literal Utility..::..SetWindowPosFlags SWP_NOSENDCHANGING

See Also

Utility..::..SetWindowPosFlags Enumeration
Relogger Namespace


SWP_NOSIZE Field

SetWindowPosFlags..::..SWP_NOSIZE Field

Retains the current size (ignores the cx and cy parameters).

Namespace: Relogger
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public const Utility..::..SetWindowPosFlags SWP_NOSIZE
Public Const SWP_NOSIZE As Utility..::..SetWindowPosFlags
public:
literal Utility..::..SetWindowPosFlags SWP_NOSIZE

See Also

Utility..::..SetWindowPosFlags Enumeration
Relogger Namespace


SWP_NOZORDER Field

SetWindowPosFlags..::..SWP_NOZORDER Field

Retains the current Z order (ignores the hWndInsertAfter parameter).

Namespace: Relogger
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public const Utility..::..SetWindowPosFlags SWP_NOZORDER
Public Const SWP_NOZORDER As Utility..::..SetWindowPosFlags
public:
literal Utility..::..SetWindowPosFlags SWP_NOZORDER

See Also

Utility..::..SetWindowPosFlags Enumeration
Relogger Namespace


SWP_SHOWWINDOW Field

SetWindowPosFlags..::..SWP_SHOWWINDOW Field

Displays the window.

Namespace: Relogger
Assembly: Relogger (in Relogger.exe)

Syntax

C#
VB
C++
public const Utility..::..SetWindowPosFlags SWP_SHOWWINDOW
Public Const SWP_SHOWWINDOW As Utility..::..SetWindowPosFlags
public:
literal Utility..::..SetWindowPosFlags SWP_SHOWWINDOW

See Also

Utility..::..SetWindowPosFlags Enumeration
Relogger Namespace


Debug Field

LogType..::..Debug Field

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const Logging..::..LogType Debug
Public Const Debug As Logging..::..LogType
public:
literal Logging..::..LogType Debug

See Also

Logging..::..LogType Enumeration
robotManager.Helpful Namespace


Error Field

LogType..::..Error Field

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const Logging..::..LogType Error
Public Const Error As Logging..::..LogType
public:
literal Logging..::..LogType Error

See Also

Logging..::..LogType Enumeration
robotManager.Helpful Namespace


Fight Field

LogType..::..Fight Field

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const Logging..::..LogType Fight
Public Const Fight As Logging..::..LogType
public:
literal Logging..::..LogType Fight

See Also

Logging..::..LogType Enumeration
robotManager.Helpful Namespace


FileOnly Field

LogType..::..FileOnly Field

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const Logging..::..LogType FileOnly
Public Const FileOnly As Logging..::..LogType
public:
literal Logging..::..LogType FileOnly

See Also

Logging..::..LogType Enumeration
robotManager.Helpful Namespace


Navigator Field

LogType..::..Navigator Field

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const Logging..::..LogType Navigator
Public Const Navigator As Logging..::..LogType
public:
literal Logging..::..LogType Navigator

See Also

Logging..::..LogType Enumeration
robotManager.Helpful Namespace


None Field

LogType..::..None Field

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const Logging..::..LogType None
Public Const None As Logging..::..LogType
public:
literal Logging..::..LogType None

See Also

Logging..::..LogType Enumeration
robotManager.Helpful Namespace


Normal Field

LogType..::..Normal Field

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const Logging..::..LogType Normal
Public Const Normal As Logging..::..LogType
public:
literal Logging..::..LogType Normal

See Also

Logging..::..LogType Enumeration
robotManager.Helpful Namespace


Alt Field

ModifierKeys..::..Alt Field

ALT

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const ModifierKeys Alt
Public Const Alt As ModifierKeys
public:
literal ModifierKeys Alt

See Also

ModifierKeys Enumeration
robotManager.Helpful Namespace


Control Field

ModifierKeys..::..Control Field

CTRL

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const ModifierKeys Control
Public Const Control As ModifierKeys
public:
literal ModifierKeys Control

See Also

ModifierKeys Enumeration
robotManager.Helpful Namespace


Shift Field

ModifierKeys..::..Shift Field

shift

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const ModifierKeys Shift
Public Const Shift As ModifierKeys
public:
literal ModifierKeys Shift

See Also

ModifierKeys Enumeration
robotManager.Helpful Namespace


Win Field

ModifierKeys..::..Win Field

win

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const ModifierKeys Win
Public Const Win As ModifierKeys
public:
literal ModifierKeys Win

See Also

ModifierKeys Enumeration
robotManager.Helpful Namespace


CSharp Field

CodeType..::..CSharp Field

C#

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const RunCode..::..CodeType CSharp
Public Const CSharp As RunCode..::..CodeType
public:
literal RunCode..::..CodeType CSharp

See Also

RunCode..::..CodeType Enumeration
robotManager.Helpful Namespace


VB Field

CodeType..::..VB Field

VB.net

Namespace: robotManager.Helpful
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const RunCode..::..CodeType VB
Public Const VB As RunCode..::..CodeType
public:
literal RunCode..::..CodeType VB

See Also

RunCode..::..CodeType Enumeration
robotManager.Helpful Namespace


Add Field

ChangeWindowMessageFilterFlags..::..Add Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const Native..::..ChangeWindowMessageFilterFlags Add
Public Const Add As Native..::..ChangeWindowMessageFilterFlags
public:
literal Native..::..ChangeWindowMessageFilterFlags Add

See Also

Native..::..ChangeWindowMessageFilterFlags Enumeration
robotManager.Helpful.Win32 Namespace


Remove Field

ChangeWindowMessageFilterFlags..::..Remove Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const Native..::..ChangeWindowMessageFilterFlags Remove
Public Const Remove As Native..::..ChangeWindowMessageFilterFlags
public:
literal Native..::..ChangeWindowMessageFilterFlags Remove

See Also

Native..::..ChangeWindowMessageFilterFlags Enumeration
robotManager.Helpful.Win32 Namespace


DWM_EC_DISABLECOMPOSITION Field

CompositionAction..::..DWM_EC_DISABLECOMPOSITION Field

To enable DWM composition

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const Native..::..CompositionAction DWM_EC_DISABLECOMPOSITION
Public Const DWM_EC_DISABLECOMPOSITION As Native..::..CompositionAction
public:
literal Native..::..CompositionAction DWM_EC_DISABLECOMPOSITION

See Also

Native..::..CompositionAction Enumeration
robotManager.Helpful.Win32 Namespace


DWM_EC_ENABLECOMPOSITION Field

CompositionAction..::..DWM_EC_ENABLECOMPOSITION Field

To disable composition.

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const Native..::..CompositionAction DWM_EC_ENABLECOMPOSITION
Public Const DWM_EC_ENABLECOMPOSITION As Native..::..CompositionAction
public:
literal Native..::..CompositionAction DWM_EC_ENABLECOMPOSITION

See Also

Native..::..CompositionAction Enumeration
robotManager.Helpful.Win32 Namespace


CTRL_BREAK_EVENT Field

ConsoleHandlerEventCode..::..CTRL_BREAK_EVENT Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const Native..::..ConsoleHandlerEventCode CTRL_BREAK_EVENT
Public Const CTRL_BREAK_EVENT As Native..::..ConsoleHandlerEventCode
public:
literal Native..::..ConsoleHandlerEventCode CTRL_BREAK_EVENT

See Also

Native..::..ConsoleHandlerEventCode Enumeration
robotManager.Helpful.Win32 Namespace


CTRL_C_EVENT Field

ConsoleHandlerEventCode..::..CTRL_C_EVENT Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const Native..::..ConsoleHandlerEventCode CTRL_C_EVENT
Public Const CTRL_C_EVENT As Native..::..ConsoleHandlerEventCode
public:
literal Native..::..ConsoleHandlerEventCode CTRL_C_EVENT

See Also

Native..::..ConsoleHandlerEventCode Enumeration
robotManager.Helpful.Win32 Namespace


CTRL_CLOSE_EVENT Field

ConsoleHandlerEventCode..::..CTRL_CLOSE_EVENT Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const Native..::..ConsoleHandlerEventCode CTRL_CLOSE_EVENT
Public Const CTRL_CLOSE_EVENT As Native..::..ConsoleHandlerEventCode
public:
literal Native..::..ConsoleHandlerEventCode CTRL_CLOSE_EVENT

See Also

Native..::..ConsoleHandlerEventCode Enumeration
robotManager.Helpful.Win32 Namespace


CTRL_LOGOFF_EVENT Field

ConsoleHandlerEventCode..::..CTRL_LOGOFF_EVENT Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const Native..::..ConsoleHandlerEventCode CTRL_LOGOFF_EVENT
Public Const CTRL_LOGOFF_EVENT As Native..::..ConsoleHandlerEventCode
public:
literal Native..::..ConsoleHandlerEventCode CTRL_LOGOFF_EVENT

See Also

Native..::..ConsoleHandlerEventCode Enumeration
robotManager.Helpful.Win32 Namespace


CTRL_SHUTDOWN_EVENT Field

ConsoleHandlerEventCode..::..CTRL_SHUTDOWN_EVENT Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const Native..::..ConsoleHandlerEventCode CTRL_SHUTDOWN_EVENT
Public Const CTRL_SHUTDOWN_EVENT As Native..::..ConsoleHandlerEventCode
public:
literal Native..::..ConsoleHandlerEventCode CTRL_SHUTDOWN_EVENT

See Also

Native..::..ConsoleHandlerEventCode Enumeration
robotManager.Helpful.Win32 Namespace


Monitor Field

DisplayAffinity..::..Monitor Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const Native..::..DisplayAffinity Monitor
Public Const Monitor As Native..::..DisplayAffinity
public:
literal Native..::..DisplayAffinity Monitor

See Also

Native..::..DisplayAffinity Enumeration
robotManager.Helpful.Win32 Namespace


None Field

DisplayAffinity..::..None Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const Native..::..DisplayAffinity None
Public Const None As Native..::..DisplayAffinity
public:
literal Native..::..DisplayAffinity None

See Also

Native..::..DisplayAffinity Enumeration
robotManager.Helpful.Win32 Namespace


DownKeyVk Field

Native..::..DownKeyVk Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const uint DownKeyVk
Public Const DownKeyVk As UInteger
public:
literal unsigned int^ DownKeyVk

See Also

Native
robotManager.Helpful.Win32 Namespace


CREATE_BREAKAWAY_FROM_JOB Field

ProcessCreationFlags..::..CREATE_BREAKAWAY_FROM_JOB Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const Native..::..ProcessCreationFlags CREATE_BREAKAWAY_FROM_JOB
Public Const CREATE_BREAKAWAY_FROM_JOB As Native..::..ProcessCreationFlags
public:
literal Native..::..ProcessCreationFlags CREATE_BREAKAWAY_FROM_JOB

See Also

Native..::..ProcessCreationFlags Enumeration
robotManager.Helpful.Win32 Namespace


CREATE_DEFAULT_ERROR_MODE Field

ProcessCreationFlags..::..CREATE_DEFAULT_ERROR_MODE Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const Native..::..ProcessCreationFlags CREATE_DEFAULT_ERROR_MODE
Public Const CREATE_DEFAULT_ERROR_MODE As Native..::..ProcessCreationFlags
public:
literal Native..::..ProcessCreationFlags CREATE_DEFAULT_ERROR_MODE

See Also

Native..::..ProcessCreationFlags Enumeration
robotManager.Helpful.Win32 Namespace


CREATE_NEW_CONSOLE Field

ProcessCreationFlags..::..CREATE_NEW_CONSOLE Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const Native..::..ProcessCreationFlags CREATE_NEW_CONSOLE
Public Const CREATE_NEW_CONSOLE As Native..::..ProcessCreationFlags
public:
literal Native..::..ProcessCreationFlags CREATE_NEW_CONSOLE

See Also

Native..::..ProcessCreationFlags Enumeration
robotManager.Helpful.Win32 Namespace


CREATE_NEW_PROCESS_GROUP Field

ProcessCreationFlags..::..CREATE_NEW_PROCESS_GROUP Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const Native..::..ProcessCreationFlags CREATE_NEW_PROCESS_GROUP
Public Const CREATE_NEW_PROCESS_GROUP As Native..::..ProcessCreationFlags
public:
literal Native..::..ProcessCreationFlags CREATE_NEW_PROCESS_GROUP

See Also

Native..::..ProcessCreationFlags Enumeration
robotManager.Helpful.Win32 Namespace


CREATE_NO_WINDOW Field

ProcessCreationFlags..::..CREATE_NO_WINDOW Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const Native..::..ProcessCreationFlags CREATE_NO_WINDOW
Public Const CREATE_NO_WINDOW As Native..::..ProcessCreationFlags
public:
literal Native..::..ProcessCreationFlags CREATE_NO_WINDOW

See Also

Native..::..ProcessCreationFlags Enumeration
robotManager.Helpful.Win32 Namespace


CREATE_PRESERVE_CODE_AUTHZ_LEVEL Field

ProcessCreationFlags..::..CREATE_PRESERVE_CODE_AUTHZ_LEVEL Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const Native..::..ProcessCreationFlags CREATE_PRESERVE_CODE_AUTHZ_LEVEL
Public Const CREATE_PRESERVE_CODE_AUTHZ_LEVEL As Native..::..ProcessCreationFlags
public:
literal Native..::..ProcessCreationFlags CREATE_PRESERVE_CODE_AUTHZ_LEVEL

See Also

Native..::..ProcessCreationFlags Enumeration
robotManager.Helpful.Win32 Namespace


CREATE_PROTECTED_PROCESS Field

ProcessCreationFlags..::..CREATE_PROTECTED_PROCESS Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const Native..::..ProcessCreationFlags CREATE_PROTECTED_PROCESS
Public Const CREATE_PROTECTED_PROCESS As Native..::..ProcessCreationFlags
public:
literal Native..::..ProcessCreationFlags CREATE_PROTECTED_PROCESS

See Also

Native..::..ProcessCreationFlags Enumeration
robotManager.Helpful.Win32 Namespace


CREATE_SEPARATE_WOW_VDM Field

ProcessCreationFlags..::..CREATE_SEPARATE_WOW_VDM Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const Native..::..ProcessCreationFlags CREATE_SEPARATE_WOW_VDM
Public Const CREATE_SEPARATE_WOW_VDM As Native..::..ProcessCreationFlags
public:
literal Native..::..ProcessCreationFlags CREATE_SEPARATE_WOW_VDM

See Also

Native..::..ProcessCreationFlags Enumeration
robotManager.Helpful.Win32 Namespace


CREATE_SHARED_WOW_VDM Field

ProcessCreationFlags..::..CREATE_SHARED_WOW_VDM Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const Native..::..ProcessCreationFlags CREATE_SHARED_WOW_VDM
Public Const CREATE_SHARED_WOW_VDM As Native..::..ProcessCreationFlags
public:
literal Native..::..ProcessCreationFlags CREATE_SHARED_WOW_VDM

See Also

Native..::..ProcessCreationFlags Enumeration
robotManager.Helpful.Win32 Namespace


CREATE_SUSPENDED Field

ProcessCreationFlags..::..CREATE_SUSPENDED Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const Native..::..ProcessCreationFlags CREATE_SUSPENDED
Public Const CREATE_SUSPENDED As Native..::..ProcessCreationFlags
public:
literal Native..::..ProcessCreationFlags CREATE_SUSPENDED

See Also

Native..::..ProcessCreationFlags Enumeration
robotManager.Helpful.Win32 Namespace


CREATE_UNICODE_ENVIRONMENT Field

ProcessCreationFlags..::..CREATE_UNICODE_ENVIRONMENT Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const Native..::..ProcessCreationFlags CREATE_UNICODE_ENVIRONMENT
Public Const CREATE_UNICODE_ENVIRONMENT As Native..::..ProcessCreationFlags
public:
literal Native..::..ProcessCreationFlags CREATE_UNICODE_ENVIRONMENT

See Also

Native..::..ProcessCreationFlags Enumeration
robotManager.Helpful.Win32 Namespace


DEBUG_ONLY_THIS_PROCESS Field

ProcessCreationFlags..::..DEBUG_ONLY_THIS_PROCESS Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const Native..::..ProcessCreationFlags DEBUG_ONLY_THIS_PROCESS
Public Const DEBUG_ONLY_THIS_PROCESS As Native..::..ProcessCreationFlags
public:
literal Native..::..ProcessCreationFlags DEBUG_ONLY_THIS_PROCESS

See Also

Native..::..ProcessCreationFlags Enumeration
robotManager.Helpful.Win32 Namespace


DEBUG_PROCESS Field

ProcessCreationFlags..::..DEBUG_PROCESS Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const Native..::..ProcessCreationFlags DEBUG_PROCESS
Public Const DEBUG_PROCESS As Native..::..ProcessCreationFlags
public:
literal Native..::..ProcessCreationFlags DEBUG_PROCESS

See Also

Native..::..ProcessCreationFlags Enumeration
robotManager.Helpful.Win32 Namespace


DETACHED_PROCESS Field

ProcessCreationFlags..::..DETACHED_PROCESS Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const Native..::..ProcessCreationFlags DETACHED_PROCESS
Public Const DETACHED_PROCESS As Native..::..ProcessCreationFlags
public:
literal Native..::..ProcessCreationFlags DETACHED_PROCESS

See Also

Native..::..ProcessCreationFlags Enumeration
robotManager.Helpful.Win32 Namespace


EXTENDED_STARTUPINFO_PRESENT Field

ProcessCreationFlags..::..EXTENDED_STARTUPINFO_PRESENT Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const Native..::..ProcessCreationFlags EXTENDED_STARTUPINFO_PRESENT
Public Const EXTENDED_STARTUPINFO_PRESENT As Native..::..ProcessCreationFlags
public:
literal Native..::..ProcessCreationFlags EXTENDED_STARTUPINFO_PRESENT

See Also

Native..::..ProcessCreationFlags Enumeration
robotManager.Helpful.Win32 Namespace


INHERIT_PARENT_AFFINITY Field

ProcessCreationFlags..::..INHERIT_PARENT_AFFINITY Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const Native..::..ProcessCreationFlags INHERIT_PARENT_AFFINITY
Public Const INHERIT_PARENT_AFFINITY As Native..::..ProcessCreationFlags
public:
literal Native..::..ProcessCreationFlags INHERIT_PARENT_AFFINITY

See Also

Native..::..ProcessCreationFlags Enumeration
robotManager.Helpful.Win32 Namespace


ZERO_FLAG Field

ProcessCreationFlags..::..ZERO_FLAG Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const Native..::..ProcessCreationFlags ZERO_FLAG
Public Const ZERO_FLAG As Native..::..ProcessCreationFlags
public:
literal Native..::..ProcessCreationFlags ZERO_FLAG

See Also

Native..::..ProcessCreationFlags Enumeration
robotManager.Helpful.Win32 Namespace


SwMinimize Field

Native..::..SwMinimize Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const int SwMinimize
Public Const SwMinimize As Integer
public:
literal int^ SwMinimize

See Also

Native
robotManager.Helpful.Win32 Namespace


SwRestore Field

Native..::..SwRestore Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const int SwRestore
Public Const SwRestore As Integer
public:
literal int^ SwRestore

See Also

Native
robotManager.Helpful.Win32 Namespace


SwShow Field

Native..::..SwShow Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const int SwShow
Public Const SwShow As Integer
public:
literal int^ SwShow

See Also

Native
robotManager.Helpful.Win32 Namespace


DIRECT_IMPERSONATION Field

ThreadAccess..::..DIRECT_IMPERSONATION Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const Native..::..ThreadAccess DIRECT_IMPERSONATION
Public Const DIRECT_IMPERSONATION As Native..::..ThreadAccess
public:
literal Native..::..ThreadAccess DIRECT_IMPERSONATION

See Also

Native..::..ThreadAccess Enumeration
robotManager.Helpful.Win32 Namespace


GET_CONTEXT Field

ThreadAccess..::..GET_CONTEXT Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const Native..::..ThreadAccess GET_CONTEXT
Public Const GET_CONTEXT As Native..::..ThreadAccess
public:
literal Native..::..ThreadAccess GET_CONTEXT

See Also

Native..::..ThreadAccess Enumeration
robotManager.Helpful.Win32 Namespace


IMPERSONATE Field

ThreadAccess..::..IMPERSONATE Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const Native..::..ThreadAccess IMPERSONATE
Public Const IMPERSONATE As Native..::..ThreadAccess
public:
literal Native..::..ThreadAccess IMPERSONATE

See Also

Native..::..ThreadAccess Enumeration
robotManager.Helpful.Win32 Namespace


QUERY_INFORMATION Field

ThreadAccess..::..QUERY_INFORMATION Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const Native..::..ThreadAccess QUERY_INFORMATION
Public Const QUERY_INFORMATION As Native..::..ThreadAccess
public:
literal Native..::..ThreadAccess QUERY_INFORMATION

See Also

Native..::..ThreadAccess Enumeration
robotManager.Helpful.Win32 Namespace


SET_CONTEXT Field

ThreadAccess..::..SET_CONTEXT Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const Native..::..ThreadAccess SET_CONTEXT
Public Const SET_CONTEXT As Native..::..ThreadAccess
public:
literal Native..::..ThreadAccess SET_CONTEXT

See Also

Native..::..ThreadAccess Enumeration
robotManager.Helpful.Win32 Namespace


SET_INFORMATION Field

ThreadAccess..::..SET_INFORMATION Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const Native..::..ThreadAccess SET_INFORMATION
Public Const SET_INFORMATION As Native..::..ThreadAccess
public:
literal Native..::..ThreadAccess SET_INFORMATION

See Also

Native..::..ThreadAccess Enumeration
robotManager.Helpful.Win32 Namespace


SET_THREAD_TOKEN Field

ThreadAccess..::..SET_THREAD_TOKEN Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const Native..::..ThreadAccess SET_THREAD_TOKEN
Public Const SET_THREAD_TOKEN As Native..::..ThreadAccess
public:
literal Native..::..ThreadAccess SET_THREAD_TOKEN

See Also

Native..::..ThreadAccess Enumeration
robotManager.Helpful.Win32 Namespace


SUSPEND_RESUME Field

ThreadAccess..::..SUSPEND_RESUME Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const Native..::..ThreadAccess SUSPEND_RESUME
Public Const SUSPEND_RESUME As Native..::..ThreadAccess
public:
literal Native..::..ThreadAccess SUSPEND_RESUME

See Also

Native..::..ThreadAccess Enumeration
robotManager.Helpful.Win32 Namespace


TERMINATE Field

ThreadAccess..::..TERMINATE Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const Native..::..ThreadAccess TERMINATE
Public Const TERMINATE As Native..::..ThreadAccess
public:
literal Native..::..ThreadAccess TERMINATE

See Also

Native..::..ThreadAccess Enumeration
robotManager.Helpful.Win32 Namespace


UpKeyVk Field

Native..::..UpKeyVk Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const uint UpKeyVk
Public Const UpKeyVk As UInteger
public:
literal unsigned int^ UpKeyVk

See Also

Native
robotManager.Helpful.Win32 Namespace


WM_MOUSECLICKUP Field

Native..::..WM_MOUSECLICKUP Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const uint WM_MOUSECLICKUP
Public Const WM_MOUSECLICKUP As UInteger
public:
literal unsigned int^ WM_MOUSECLICKUP

See Also

Native
robotManager.Helpful.Win32 Namespace


WM_MOUSEMOVE Field

Native..::..WM_MOUSEMOVE Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const uint WM_MOUSEMOVE
Public Const WM_MOUSEMOVE As UInteger
public:
literal unsigned int^ WM_MOUSEMOVE

See Also

Native
robotManager.Helpful.Win32 Namespace


A Field

UnreservedVK..::..A Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK A
Public Const A As UnreservedVK
public:
literal UnreservedVK A

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


B Field

UnreservedVK..::..B Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK B
Public Const B As UnreservedVK
public:
literal UnreservedVK B

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


C Field

UnreservedVK..::..C Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK C
Public Const C As UnreservedVK
public:
literal UnreservedVK C

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


D Field

UnreservedVK..::..D Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK D
Public Const D As UnreservedVK
public:
literal UnreservedVK D

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


E Field

UnreservedVK..::..E Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK E
Public Const E As UnreservedVK
public:
literal UnreservedVK E

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


F Field

UnreservedVK..::..F Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK F
Public Const F As UnreservedVK
public:
literal UnreservedVK F

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


F1 Field

UnreservedVK..::..F1 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK F1
Public Const F1 As UnreservedVK
public:
literal UnreservedVK F1

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


F2 Field

UnreservedVK..::..F2 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK F2
Public Const F2 As UnreservedVK
public:
literal UnreservedVK F2

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


F3 Field

UnreservedVK..::..F3 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK F3
Public Const F3 As UnreservedVK
public:
literal UnreservedVK F3

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


F4 Field

UnreservedVK..::..F4 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK F4
Public Const F4 As UnreservedVK
public:
literal UnreservedVK F4

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


F5 Field

UnreservedVK..::..F5 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK F5
Public Const F5 As UnreservedVK
public:
literal UnreservedVK F5

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


F6 Field

UnreservedVK..::..F6 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK F6
Public Const F6 As UnreservedVK
public:
literal UnreservedVK F6

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


F7 Field

UnreservedVK..::..F7 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK F7
Public Const F7 As UnreservedVK
public:
literal UnreservedVK F7

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


F8 Field

UnreservedVK..::..F8 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK F8
Public Const F8 As UnreservedVK
public:
literal UnreservedVK F8

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


F9 Field

UnreservedVK..::..F9 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK F9
Public Const F9 As UnreservedVK
public:
literal UnreservedVK F9

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


F10 Field

UnreservedVK..::..F10 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK F10
Public Const F10 As UnreservedVK
public:
literal UnreservedVK F10

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


F11 Field

UnreservedVK..::..F11 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK F11
Public Const F11 As UnreservedVK
public:
literal UnreservedVK F11

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


F12 Field

UnreservedVK..::..F12 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK F12
Public Const F12 As UnreservedVK
public:
literal UnreservedVK F12

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


F13 Field

UnreservedVK..::..F13 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK F13
Public Const F13 As UnreservedVK
public:
literal UnreservedVK F13

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


F14 Field

UnreservedVK..::..F14 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK F14
Public Const F14 As UnreservedVK
public:
literal UnreservedVK F14

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


F15 Field

UnreservedVK..::..F15 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK F15
Public Const F15 As UnreservedVK
public:
literal UnreservedVK F15

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


F16 Field

UnreservedVK..::..F16 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK F16
Public Const F16 As UnreservedVK
public:
literal UnreservedVK F16

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


F17 Field

UnreservedVK..::..F17 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK F17
Public Const F17 As UnreservedVK
public:
literal UnreservedVK F17

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


F18 Field

UnreservedVK..::..F18 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK F18
Public Const F18 As UnreservedVK
public:
literal UnreservedVK F18

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


F19 Field

UnreservedVK..::..F19 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK F19
Public Const F19 As UnreservedVK
public:
literal UnreservedVK F19

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


F20 Field

UnreservedVK..::..F20 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK F20
Public Const F20 As UnreservedVK
public:
literal UnreservedVK F20

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


F21 Field

UnreservedVK..::..F21 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK F21
Public Const F21 As UnreservedVK
public:
literal UnreservedVK F21

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


F23 Field

UnreservedVK..::..F23 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK F23
Public Const F23 As UnreservedVK
public:
literal UnreservedVK F23

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


F24 Field

UnreservedVK..::..F24 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK F24
Public Const F24 As UnreservedVK
public:
literal UnreservedVK F24

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


G Field

UnreservedVK..::..G Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK G
Public Const G As UnreservedVK
public:
literal UnreservedVK G

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


H Field

UnreservedVK..::..H Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK H
Public Const H As UnreservedVK
public:
literal UnreservedVK H

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


I Field

UnreservedVK..::..I Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK I
Public Const I As UnreservedVK
public:
literal UnreservedVK I

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


J Field

UnreservedVK..::..J Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK J
Public Const J As UnreservedVK
public:
literal UnreservedVK J

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


K Field

UnreservedVK..::..K Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK K
Public Const K As UnreservedVK
public:
literal UnreservedVK K

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


L Field

UnreservedVK..::..L Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK L
Public Const L As UnreservedVK
public:
literal UnreservedVK L

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


M Field

UnreservedVK..::..M Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK M
Public Const M As UnreservedVK
public:
literal UnreservedVK M

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


N Field

UnreservedVK..::..N Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK N
Public Const N As UnreservedVK
public:
literal UnreservedVK N

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


NUMPAD0 Field

UnreservedVK..::..NUMPAD0 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK NUMPAD0
Public Const NUMPAD0 As UnreservedVK
public:
literal UnreservedVK NUMPAD0

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


NUMPAD1 Field

UnreservedVK..::..NUMPAD1 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK NUMPAD1
Public Const NUMPAD1 As UnreservedVK
public:
literal UnreservedVK NUMPAD1

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


NUMPAD2 Field

UnreservedVK..::..NUMPAD2 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK NUMPAD2
Public Const NUMPAD2 As UnreservedVK
public:
literal UnreservedVK NUMPAD2

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


NUMPAD3 Field

UnreservedVK..::..NUMPAD3 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK NUMPAD3
Public Const NUMPAD3 As UnreservedVK
public:
literal UnreservedVK NUMPAD3

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


NUMPAD4 Field

UnreservedVK..::..NUMPAD4 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK NUMPAD4
Public Const NUMPAD4 As UnreservedVK
public:
literal UnreservedVK NUMPAD4

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


NUMPAD5 Field

UnreservedVK..::..NUMPAD5 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK NUMPAD5
Public Const NUMPAD5 As UnreservedVK
public:
literal UnreservedVK NUMPAD5

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


NUMPAD6 Field

UnreservedVK..::..NUMPAD6 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK NUMPAD6
Public Const NUMPAD6 As UnreservedVK
public:
literal UnreservedVK NUMPAD6

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


NUMPAD7 Field

UnreservedVK..::..NUMPAD7 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK NUMPAD7
Public Const NUMPAD7 As UnreservedVK
public:
literal UnreservedVK NUMPAD7

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


NUMPAD8 Field

UnreservedVK..::..NUMPAD8 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK NUMPAD8
Public Const NUMPAD8 As UnreservedVK
public:
literal UnreservedVK NUMPAD8

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


NUMPAD9 Field

UnreservedVK..::..NUMPAD9 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK NUMPAD9
Public Const NUMPAD9 As UnreservedVK
public:
literal UnreservedVK NUMPAD9

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


O Field

UnreservedVK..::..O Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK O
Public Const O As UnreservedVK
public:
literal UnreservedVK O

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


P Field

UnreservedVK..::..P Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK P
Public Const P As UnreservedVK
public:
literal UnreservedVK P

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


Q Field

UnreservedVK..::..Q Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK Q
Public Const Q As UnreservedVK
public:
literal UnreservedVK Q

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


R Field

UnreservedVK..::..R Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK R
Public Const R As UnreservedVK
public:
literal UnreservedVK R

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


S Field

UnreservedVK..::..S Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK S
Public Const S As UnreservedVK
public:
literal UnreservedVK S

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


T Field

UnreservedVK..::..T Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK T
Public Const T As UnreservedVK
public:
literal UnreservedVK T

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


U Field

UnreservedVK..::..U Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK U
Public Const U As UnreservedVK
public:
literal UnreservedVK U

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


V Field

UnreservedVK..::..V Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK V
Public Const V As UnreservedVK
public:
literal UnreservedVK V

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


W Field

UnreservedVK..::..W Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK W
Public Const W As UnreservedVK
public:
literal UnreservedVK W

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


X Field

UnreservedVK..::..X Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK X
Public Const X As UnreservedVK
public:
literal UnreservedVK X

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


Y Field

UnreservedVK..::..Y Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK Y
Public Const Y As UnreservedVK
public:
literal UnreservedVK Y

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


Z Field

UnreservedVK..::..Z Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const UnreservedVK Z
Public Const Z As UnreservedVK
public:
literal UnreservedVK Z

See Also

UnreservedVK Enumeration
robotManager.Helpful.Win32 Namespace


ACCEPT Field

VK..::..ACCEPT Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK ACCEPT
Public Const ACCEPT As VK
public:
literal VK ACCEPT

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


ADD Field

VK..::..ADD Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK ADD
Public Const ADD As VK
public:
literal VK ADD

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


APPS Field

VK..::..APPS Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK APPS
Public Const APPS As VK
public:
literal VK APPS

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


ATTN Field

VK..::..ATTN Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK ATTN
Public Const ATTN As VK
public:
literal VK ATTN

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


BACK Field

VK..::..BACK Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK BACK
Public Const BACK As VK
public:
literal VK BACK

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


BROWSER_BACK Field

VK..::..BROWSER_BACK Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK BROWSER_BACK
Public Const BROWSER_BACK As VK
public:
literal VK BROWSER_BACK

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


BROWSER_FAVORITES Field

VK..::..BROWSER_FAVORITES Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK BROWSER_FAVORITES
Public Const BROWSER_FAVORITES As VK
public:
literal VK BROWSER_FAVORITES

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


BROWSER_FORWARD Field

VK..::..BROWSER_FORWARD Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK BROWSER_FORWARD
Public Const BROWSER_FORWARD As VK
public:
literal VK BROWSER_FORWARD

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


BROWSER_HOME Field

VK..::..BROWSER_HOME Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK BROWSER_HOME
Public Const BROWSER_HOME As VK
public:
literal VK BROWSER_HOME

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


BROWSER_REFRESH Field

VK..::..BROWSER_REFRESH Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK BROWSER_REFRESH
Public Const BROWSER_REFRESH As VK
public:
literal VK BROWSER_REFRESH

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


BROWSER_SEARCH Field

VK..::..BROWSER_SEARCH Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK BROWSER_SEARCH
Public Const BROWSER_SEARCH As VK
public:
literal VK BROWSER_SEARCH

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


BROWSER_STOP Field

VK..::..BROWSER_STOP Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK BROWSER_STOP
Public Const BROWSER_STOP As VK
public:
literal VK BROWSER_STOP

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


CANCEL Field

VK..::..CANCEL Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK CANCEL
Public Const CANCEL As VK
public:
literal VK CANCEL

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


CAPITAL Field

VK..::..CAPITAL Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK CAPITAL
Public Const CAPITAL As VK
public:
literal VK CAPITAL

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


CLEAR Field

VK..::..CLEAR Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK CLEAR
Public Const CLEAR As VK
public:
literal VK CLEAR

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


CONTROL Field

VK..::..CONTROL Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK CONTROL
Public Const CONTROL As VK
public:
literal VK CONTROL

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


CONVERT Field

VK..::..CONVERT Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK CONVERT
Public Const CONVERT As VK
public:
literal VK CONVERT

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


CRSEL Field

VK..::..CRSEL Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK CRSEL
Public Const CRSEL As VK
public:
literal VK CRSEL

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


DECIMAL Field

VK..::..DECIMAL Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK DECIMAL
Public Const DECIMAL As VK
public:
literal VK DECIMAL

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


DELETE Field

VK..::..DELETE Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK DELETE
Public Const DELETE As VK
public:
literal VK DELETE

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


DIVIDE Field

VK..::..DIVIDE Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK DIVIDE
Public Const DIVIDE As VK
public:
literal VK DIVIDE

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


DOWN Field

VK..::..DOWN Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK DOWN
Public Const DOWN As VK
public:
literal VK DOWN

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


END Field

VK..::..END Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK END
Public Const END As VK
public:
literal VK END

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


EREOF Field

VK..::..EREOF Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK EREOF
Public Const EREOF As VK
public:
literal VK EREOF

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


ESCAPE Field

VK..::..ESCAPE Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK ESCAPE
Public Const ESCAPE As VK
public:
literal VK ESCAPE

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


EXECUTE Field

VK..::..EXECUTE Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK EXECUTE
Public Const EXECUTE As VK
public:
literal VK EXECUTE

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


EXSEL Field

VK..::..EXSEL Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK EXSEL
Public Const EXSEL As VK
public:
literal VK EXSEL

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


F1 Field

VK..::..F1 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK F1
Public Const F1 As VK
public:
literal VK F1

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


F2 Field

VK..::..F2 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK F2
Public Const F2 As VK
public:
literal VK F2

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


F3 Field

VK..::..F3 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK F3
Public Const F3 As VK
public:
literal VK F3

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


F4 Field

VK..::..F4 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK F4
Public Const F4 As VK
public:
literal VK F4

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


F5 Field

VK..::..F5 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK F5
Public Const F5 As VK
public:
literal VK F5

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


F6 Field

VK..::..F6 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK F6
Public Const F6 As VK
public:
literal VK F6

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


F7 Field

VK..::..F7 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK F7
Public Const F7 As VK
public:
literal VK F7

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


F8 Field

VK..::..F8 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK F8
Public Const F8 As VK
public:
literal VK F8

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


F9 Field

VK..::..F9 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK F9
Public Const F9 As VK
public:
literal VK F9

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


F10 Field

VK..::..F10 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK F10
Public Const F10 As VK
public:
literal VK F10

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


F11 Field

VK..::..F11 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK F11
Public Const F11 As VK
public:
literal VK F11

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


F12 Field

VK..::..F12 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK F12
Public Const F12 As VK
public:
literal VK F12

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


F13 Field

VK..::..F13 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK F13
Public Const F13 As VK
public:
literal VK F13

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


F14 Field

VK..::..F14 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK F14
Public Const F14 As VK
public:
literal VK F14

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


F15 Field

VK..::..F15 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK F15
Public Const F15 As VK
public:
literal VK F15

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


F16 Field

VK..::..F16 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK F16
Public Const F16 As VK
public:
literal VK F16

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


F17 Field

VK..::..F17 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK F17
Public Const F17 As VK
public:
literal VK F17

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


F18 Field

VK..::..F18 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK F18
Public Const F18 As VK
public:
literal VK F18

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


F19 Field

VK..::..F19 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK F19
Public Const F19 As VK
public:
literal VK F19

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


F20 Field

VK..::..F20 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK F20
Public Const F20 As VK
public:
literal VK F20

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


F21 Field

VK..::..F21 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK F21
Public Const F21 As VK
public:
literal VK F21

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


F22 Field

VK..::..F22 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK F22
Public Const F22 As VK
public:
literal VK F22

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


F23 Field

VK..::..F23 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK F23
Public Const F23 As VK
public:
literal VK F23

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


F24 Field

VK..::..F24 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK F24
Public Const F24 As VK
public:
literal VK F24

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


FINAL Field

VK..::..FINAL Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK FINAL
Public Const FINAL As VK
public:
literal VK FINAL

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


HANGUL Field

VK..::..HANGUL Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK HANGUL
Public Const HANGUL As VK
public:
literal VK HANGUL

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


HANJA Field

VK..::..HANJA Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK HANJA
Public Const HANJA As VK
public:
literal VK HANJA

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


HELP Field

VK..::..HELP Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK HELP
Public Const HELP As VK
public:
literal VK HELP

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


HOME Field

VK..::..HOME Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK HOME
Public Const HOME As VK
public:
literal VK HOME

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


INSERT Field

VK..::..INSERT Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK INSERT
Public Const INSERT As VK
public:
literal VK INSERT

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


JUNJA Field

VK..::..JUNJA Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK JUNJA
Public Const JUNJA As VK
public:
literal VK JUNJA

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


KANA Field

VK..::..KANA Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK KANA
Public Const KANA As VK
public:
literal VK KANA

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


KANJI Field

VK..::..KANJI Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK KANJI
Public Const KANJI As VK
public:
literal VK KANJI

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


KEY_0 Field

VK..::..KEY_0 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK KEY_0
Public Const KEY_0 As VK
public:
literal VK KEY_0

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


KEY_1 Field

VK..::..KEY_1 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK KEY_1
Public Const KEY_1 As VK
public:
literal VK KEY_1

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


KEY_2 Field

VK..::..KEY_2 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK KEY_2
Public Const KEY_2 As VK
public:
literal VK KEY_2

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


KEY_3 Field

VK..::..KEY_3 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK KEY_3
Public Const KEY_3 As VK
public:
literal VK KEY_3

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


KEY_4 Field

VK..::..KEY_4 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK KEY_4
Public Const KEY_4 As VK
public:
literal VK KEY_4

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


KEY_5 Field

VK..::..KEY_5 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK KEY_5
Public Const KEY_5 As VK
public:
literal VK KEY_5

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


KEY_6 Field

VK..::..KEY_6 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK KEY_6
Public Const KEY_6 As VK
public:
literal VK KEY_6

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


KEY_7 Field

VK..::..KEY_7 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK KEY_7
Public Const KEY_7 As VK
public:
literal VK KEY_7

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


KEY_8 Field

VK..::..KEY_8 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK KEY_8
Public Const KEY_8 As VK
public:
literal VK KEY_8

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


KEY_9 Field

VK..::..KEY_9 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK KEY_9
Public Const KEY_9 As VK
public:
literal VK KEY_9

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


KEY_A Field

VK..::..KEY_A Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK KEY_A
Public Const KEY_A As VK
public:
literal VK KEY_A

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


KEY_B Field

VK..::..KEY_B Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK KEY_B
Public Const KEY_B As VK
public:
literal VK KEY_B

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


KEY_C Field

VK..::..KEY_C Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK KEY_C
Public Const KEY_C As VK
public:
literal VK KEY_C

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


KEY_D Field

VK..::..KEY_D Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK KEY_D
Public Const KEY_D As VK
public:
literal VK KEY_D

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


KEY_E Field

VK..::..KEY_E Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK KEY_E
Public Const KEY_E As VK
public:
literal VK KEY_E

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


KEY_F Field

VK..::..KEY_F Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK KEY_F
Public Const KEY_F As VK
public:
literal VK KEY_F

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


KEY_G Field

VK..::..KEY_G Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK KEY_G
Public Const KEY_G As VK
public:
literal VK KEY_G

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


KEY_H Field

VK..::..KEY_H Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK KEY_H
Public Const KEY_H As VK
public:
literal VK KEY_H

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


KEY_I Field

VK..::..KEY_I Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK KEY_I
Public Const KEY_I As VK
public:
literal VK KEY_I

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


KEY_J Field

VK..::..KEY_J Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK KEY_J
Public Const KEY_J As VK
public:
literal VK KEY_J

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


KEY_K Field

VK..::..KEY_K Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK KEY_K
Public Const KEY_K As VK
public:
literal VK KEY_K

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


KEY_L Field

VK..::..KEY_L Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK KEY_L
Public Const KEY_L As VK
public:
literal VK KEY_L

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


KEY_M Field

VK..::..KEY_M Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK KEY_M
Public Const KEY_M As VK
public:
literal VK KEY_M

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


KEY_N Field

VK..::..KEY_N Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK KEY_N
Public Const KEY_N As VK
public:
literal VK KEY_N

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


KEY_O Field

VK..::..KEY_O Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK KEY_O
Public Const KEY_O As VK
public:
literal VK KEY_O

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


KEY_P Field

VK..::..KEY_P Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK KEY_P
Public Const KEY_P As VK
public:
literal VK KEY_P

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


KEY_Q Field

VK..::..KEY_Q Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK KEY_Q
Public Const KEY_Q As VK
public:
literal VK KEY_Q

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


KEY_R Field

VK..::..KEY_R Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK KEY_R
Public Const KEY_R As VK
public:
literal VK KEY_R

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


KEY_S Field

VK..::..KEY_S Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK KEY_S
Public Const KEY_S As VK
public:
literal VK KEY_S

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


KEY_T Field

VK..::..KEY_T Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK KEY_T
Public Const KEY_T As VK
public:
literal VK KEY_T

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


KEY_U Field

VK..::..KEY_U Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK KEY_U
Public Const KEY_U As VK
public:
literal VK KEY_U

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


KEY_V Field

VK..::..KEY_V Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK KEY_V
Public Const KEY_V As VK
public:
literal VK KEY_V

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


KEY_W Field

VK..::..KEY_W Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK KEY_W
Public Const KEY_W As VK
public:
literal VK KEY_W

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


KEY_X Field

VK..::..KEY_X Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK KEY_X
Public Const KEY_X As VK
public:
literal VK KEY_X

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


KEY_Y Field

VK..::..KEY_Y Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK KEY_Y
Public Const KEY_Y As VK
public:
literal VK KEY_Y

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


KEY_Z Field

VK..::..KEY_Z Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK KEY_Z
Public Const KEY_Z As VK
public:
literal VK KEY_Z

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


LAUNCH_APP1 Field

VK..::..LAUNCH_APP1 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK LAUNCH_APP1
Public Const LAUNCH_APP1 As VK
public:
literal VK LAUNCH_APP1

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


LAUNCH_APP2 Field

VK..::..LAUNCH_APP2 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK LAUNCH_APP2
Public Const LAUNCH_APP2 As VK
public:
literal VK LAUNCH_APP2

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


LAUNCH_MAIL Field

VK..::..LAUNCH_MAIL Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK LAUNCH_MAIL
Public Const LAUNCH_MAIL As VK
public:
literal VK LAUNCH_MAIL

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


LAUNCH_MEDIA_SELECT Field

VK..::..LAUNCH_MEDIA_SELECT Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK LAUNCH_MEDIA_SELECT
Public Const LAUNCH_MEDIA_SELECT As VK
public:
literal VK LAUNCH_MEDIA_SELECT

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


LBUTTON Field

VK..::..LBUTTON Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK LBUTTON
Public Const LBUTTON As VK
public:
literal VK LBUTTON

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


LCONTROL Field

VK..::..LCONTROL Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK LCONTROL
Public Const LCONTROL As VK
public:
literal VK LCONTROL

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


LEFT Field

VK..::..LEFT Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK LEFT
Public Const LEFT As VK
public:
literal VK LEFT

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


LMENU Field

VK..::..LMENU Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK LMENU
Public Const LMENU As VK
public:
literal VK LMENU

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


LSHIFT Field

VK..::..LSHIFT Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK LSHIFT
Public Const LSHIFT As VK
public:
literal VK LSHIFT

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


LWIN Field

VK..::..LWIN Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK LWIN
Public Const LWIN As VK
public:
literal VK LWIN

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


MBUTTON Field

VK..::..MBUTTON Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK MBUTTON
Public Const MBUTTON As VK
public:
literal VK MBUTTON

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


MEDIA_NEXT_TRACK Field

VK..::..MEDIA_NEXT_TRACK Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK MEDIA_NEXT_TRACK
Public Const MEDIA_NEXT_TRACK As VK
public:
literal VK MEDIA_NEXT_TRACK

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


MEDIA_PLAY_PAUSE Field

VK..::..MEDIA_PLAY_PAUSE Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK MEDIA_PLAY_PAUSE
Public Const MEDIA_PLAY_PAUSE As VK
public:
literal VK MEDIA_PLAY_PAUSE

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


MEDIA_PREV_TRACK Field

VK..::..MEDIA_PREV_TRACK Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK MEDIA_PREV_TRACK
Public Const MEDIA_PREV_TRACK As VK
public:
literal VK MEDIA_PREV_TRACK

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


MEDIA_STOP Field

VK..::..MEDIA_STOP Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK MEDIA_STOP
Public Const MEDIA_STOP As VK
public:
literal VK MEDIA_STOP

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


MENU Field

VK..::..MENU Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK MENU
Public Const MENU As VK
public:
literal VK MENU

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


MODECHANGE Field

VK..::..MODECHANGE Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK MODECHANGE
Public Const MODECHANGE As VK
public:
literal VK MODECHANGE

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


MULTIPLY Field

VK..::..MULTIPLY Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK MULTIPLY
Public Const MULTIPLY As VK
public:
literal VK MULTIPLY

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


NEXT Field

VK..::..NEXT Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK NEXT
Public Const NEXT As VK
public:
literal VK NEXT

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


NONAME Field

VK..::..NONAME Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK NONAME
Public Const NONAME As VK
public:
literal VK NONAME

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


NONCONVERT Field

VK..::..NONCONVERT Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK NONCONVERT
Public Const NONCONVERT As VK
public:
literal VK NONCONVERT

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


NUMLOCK Field

VK..::..NUMLOCK Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK NUMLOCK
Public Const NUMLOCK As VK
public:
literal VK NUMLOCK

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


NUMPAD0 Field

VK..::..NUMPAD0 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK NUMPAD0
Public Const NUMPAD0 As VK
public:
literal VK NUMPAD0

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


NUMPAD1 Field

VK..::..NUMPAD1 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK NUMPAD1
Public Const NUMPAD1 As VK
public:
literal VK NUMPAD1

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


NUMPAD2 Field

VK..::..NUMPAD2 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK NUMPAD2
Public Const NUMPAD2 As VK
public:
literal VK NUMPAD2

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


NUMPAD3 Field

VK..::..NUMPAD3 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK NUMPAD3
Public Const NUMPAD3 As VK
public:
literal VK NUMPAD3

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


NUMPAD4 Field

VK..::..NUMPAD4 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK NUMPAD4
Public Const NUMPAD4 As VK
public:
literal VK NUMPAD4

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


NUMPAD5 Field

VK..::..NUMPAD5 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK NUMPAD5
Public Const NUMPAD5 As VK
public:
literal VK NUMPAD5

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


NUMPAD6 Field

VK..::..NUMPAD6 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK NUMPAD6
Public Const NUMPAD6 As VK
public:
literal VK NUMPAD6

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


NUMPAD7 Field

VK..::..NUMPAD7 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK NUMPAD7
Public Const NUMPAD7 As VK
public:
literal VK NUMPAD7

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


NUMPAD8 Field

VK..::..NUMPAD8 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK NUMPAD8
Public Const NUMPAD8 As VK
public:
literal VK NUMPAD8

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


NUMPAD9 Field

VK..::..NUMPAD9 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK NUMPAD9
Public Const NUMPAD9 As VK
public:
literal VK NUMPAD9

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


OEM_1 Field

VK..::..OEM_1 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK OEM_1
Public Const OEM_1 As VK
public:
literal VK OEM_1

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


OEM_2 Field

VK..::..OEM_2 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK OEM_2
Public Const OEM_2 As VK
public:
literal VK OEM_2

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


OEM_3 Field

VK..::..OEM_3 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK OEM_3
Public Const OEM_3 As VK
public:
literal VK OEM_3

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


OEM_4 Field

VK..::..OEM_4 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK OEM_4
Public Const OEM_4 As VK
public:
literal VK OEM_4

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


OEM_5 Field

VK..::..OEM_5 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK OEM_5
Public Const OEM_5 As VK
public:
literal VK OEM_5

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


OEM_6 Field

VK..::..OEM_6 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK OEM_6
Public Const OEM_6 As VK
public:
literal VK OEM_6

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


OEM_7 Field

VK..::..OEM_7 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK OEM_7
Public Const OEM_7 As VK
public:
literal VK OEM_7

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


OEM_8 Field

VK..::..OEM_8 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK OEM_8
Public Const OEM_8 As VK
public:
literal VK OEM_8

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


OEM_102 Field

VK..::..OEM_102 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK OEM_102
Public Const OEM_102 As VK
public:
literal VK OEM_102

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


OEM_CLEAR Field

VK..::..OEM_CLEAR Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK OEM_CLEAR
Public Const OEM_CLEAR As VK
public:
literal VK OEM_CLEAR

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


OEM_COMMA Field

VK..::..OEM_COMMA Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK OEM_COMMA
Public Const OEM_COMMA As VK
public:
literal VK OEM_COMMA

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


OEM_MINUS Field

VK..::..OEM_MINUS Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK OEM_MINUS
Public Const OEM_MINUS As VK
public:
literal VK OEM_MINUS

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


OEM_PERIOD Field

VK..::..OEM_PERIOD Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK OEM_PERIOD
Public Const OEM_PERIOD As VK
public:
literal VK OEM_PERIOD

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


OEM_PLUS Field

VK..::..OEM_PLUS Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK OEM_PLUS
Public Const OEM_PLUS As VK
public:
literal VK OEM_PLUS

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


PA1 Field

VK..::..PA1 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK PA1
Public Const PA1 As VK
public:
literal VK PA1

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


PACKET Field

VK..::..PACKET Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK PACKET
Public Const PACKET As VK
public:
literal VK PACKET

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


PAUSE Field

VK..::..PAUSE Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK PAUSE
Public Const PAUSE As VK
public:
literal VK PAUSE

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


PLAY Field

VK..::..PLAY Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK PLAY
Public Const PLAY As VK
public:
literal VK PLAY

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


PRINT Field

VK..::..PRINT Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK PRINT
Public Const PRINT As VK
public:
literal VK PRINT

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


PRIOR Field

VK..::..PRIOR Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK PRIOR
Public Const PRIOR As VK
public:
literal VK PRIOR

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


PROCESSKEY Field

VK..::..PROCESSKEY Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK PROCESSKEY
Public Const PROCESSKEY As VK
public:
literal VK PROCESSKEY

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


RBUTTON Field

VK..::..RBUTTON Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK RBUTTON
Public Const RBUTTON As VK
public:
literal VK RBUTTON

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


RCONTROL Field

VK..::..RCONTROL Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK RCONTROL
Public Const RCONTROL As VK
public:
literal VK RCONTROL

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


RETURN Field

VK..::..RETURN Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK RETURN
Public Const RETURN As VK
public:
literal VK RETURN

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


RIGHT Field

VK..::..RIGHT Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK RIGHT
Public Const RIGHT As VK
public:
literal VK RIGHT

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


RMENU Field

VK..::..RMENU Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK RMENU
Public Const RMENU As VK
public:
literal VK RMENU

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


RSHIFT Field

VK..::..RSHIFT Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK RSHIFT
Public Const RSHIFT As VK
public:
literal VK RSHIFT

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


RWIN Field

VK..::..RWIN Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK RWIN
Public Const RWIN As VK
public:
literal VK RWIN

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


SCROLL Field

VK..::..SCROLL Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK SCROLL
Public Const SCROLL As VK
public:
literal VK SCROLL

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


SELECT Field

VK..::..SELECT Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK SELECT
Public Const SELECT As VK
public:
literal VK SELECT

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


SEPARATOR Field

VK..::..SEPARATOR Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK SEPARATOR
Public Const SEPARATOR As VK
public:
literal VK SEPARATOR

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


SHIFT Field

VK..::..SHIFT Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK SHIFT
Public Const SHIFT As VK
public:
literal VK SHIFT

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


SLEEP Field

VK..::..SLEEP Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK SLEEP
Public Const SLEEP As VK
public:
literal VK SLEEP

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


SNAPSHOT Field

VK..::..SNAPSHOT Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK SNAPSHOT
Public Const SNAPSHOT As VK
public:
literal VK SNAPSHOT

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


SPACE Field

VK..::..SPACE Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK SPACE
Public Const SPACE As VK
public:
literal VK SPACE

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


SUBTRACT Field

VK..::..SUBTRACT Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK SUBTRACT
Public Const SUBTRACT As VK
public:
literal VK SUBTRACT

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


TAB Field

VK..::..TAB Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK TAB
Public Const TAB As VK
public:
literal VK TAB

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


UP Field

VK..::..UP Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK UP
Public Const UP As VK
public:
literal VK UP

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


VOLUME_DOWN Field

VK..::..VOLUME_DOWN Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK VOLUME_DOWN
Public Const VOLUME_DOWN As VK
public:
literal VK VOLUME_DOWN

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


VOLUME_MUTE Field

VK..::..VOLUME_MUTE Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK VOLUME_MUTE
Public Const VOLUME_MUTE As VK
public:
literal VK VOLUME_MUTE

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


VOLUME_UP Field

VK..::..VOLUME_UP Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK VOLUME_UP
Public Const VOLUME_UP As VK
public:
literal VK VOLUME_UP

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


XBUTTON1 Field

VK..::..XBUTTON1 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK XBUTTON1
Public Const XBUTTON1 As VK
public:
literal VK XBUTTON1

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


XBUTTON2 Field

VK..::..XBUTTON2 Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK XBUTTON2
Public Const XBUTTON2 As VK
public:
literal VK XBUTTON2

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


ZOOM Field

VK..::..ZOOM Field

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public const VK ZOOM
Public Const ZOOM As VK
public:
literal VK ZOOM

See Also

VK Enumeration
robotManager.Helpful.Win32 Namespace


AllocData Field

Hook..::..AllocData Field

Namespace: robotManager.MemoryClass
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public AllocManager AllocData
Public AllocData As AllocManager
public:
AllocManager^ AllocData

See Also

Hook
robotManager.MemoryClass Namespace


AllocText Field

Hook..::..AllocText Field

Namespace: robotManager.MemoryClass
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public AllocManager AllocText
Public AllocText As AllocManager
public:
AllocManager^ AllocText

See Also

Hook
robotManager.MemoryClass Namespace


AllowFrameLock Field

Hook..::..AllowFrameLock Field

Namespace: robotManager.MemoryClass
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static bool AllowFrameLock
Public Shared AllowFrameLock As Boolean
public:
static bool^ AllowFrameLock

See Also

Hook
robotManager.MemoryClass Namespace


Locker Field

Hook..::..Locker Field

Namespace: robotManager.MemoryClass
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static Object Locker
Public Shared Locker As Object
public:
static Object^ Locker

See Also

Hook
robotManager.MemoryClass Namespace


LockFrameLocker Field

Hook..::..LockFrameLocker Field

Namespace: robotManager.MemoryClass
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public Object LockFrameLocker
Public LockFrameLocker As Object
public:
Object^ LockFrameLocker

See Also

Hook
robotManager.MemoryClass Namespace


Obfuscate Field

Hook..::..Obfuscate Field

Namespace: robotManager.MemoryClass
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static bool Obfuscate
Public Shared Obfuscate As Boolean
public:
static bool^ Obfuscate

See Also

Hook
robotManager.MemoryClass Namespace


ObfuscateHard Field

Hook..::..ObfuscateHard Field

Namespace: robotManager.MemoryClass
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static bool ObfuscateHard
Public Shared ObfuscateHard As Boolean
public:
static bool^ ObfuscateHard

See Also

Hook
robotManager.MemoryClass Namespace


RetnToHookCode Field

Hook..::..RetnToHookCode Field

Namespace: robotManager.MemoryClass
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public string RetnToHookCode
Public RetnToHookCode As String
public:
String^ RetnToHookCode

See Also

Hook
robotManager.MemoryClass Namespace


SleepTimeWaitCalled Field

Hook..::..SleepTimeWaitCalled Field

Namespace: robotManager.MemoryClass
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static int SleepTimeWaitCalled
Public Shared SleepTimeWaitCalled As Integer
public:
static int^ SleepTimeWaitCalled

See Also

Hook
robotManager.MemoryClass Namespace


ThreadHooked Field

Hook..::..ThreadHooked Field

Thread Hoocked

Namespace: robotManager.MemoryClass
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public bool ThreadHooked
Public ThreadHooked As Boolean
public:
bool^ ThreadHooked

See Also

Hook
robotManager.MemoryClass Namespace


Feet Field

MountCapacity..::..Feet Field

Namespace: wManager.Wow.Bot.Tasks
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const MountTask..::..MountCapacity Feet
Public Const Feet As MountTask..::..MountCapacity
public:
literal MountTask..::..MountCapacity Feet

See Also

MountTask..::..MountCapacity Enumeration
wManager.Wow.Bot.Tasks Namespace


Fly Field

MountCapacity..::..Fly Field

Namespace: wManager.Wow.Bot.Tasks
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const MountTask..::..MountCapacity Fly
Public Const Fly As MountTask..::..MountCapacity
public:
literal MountTask..::..MountCapacity Fly

See Also

MountTask..::..MountCapacity Enumeration
wManager.Wow.Bot.Tasks Namespace


Ground Field

MountCapacity..::..Ground Field

Namespace: wManager.Wow.Bot.Tasks
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const MountTask..::..MountCapacity Ground
Public Const Ground As MountTask..::..MountCapacity
public:
literal MountTask..::..MountCapacity Ground

See Also

MountTask..::..MountCapacity Enumeration
wManager.Wow.Bot.Tasks Namespace


Swimm Field

MountCapacity..::..Swimm Field

Namespace: wManager.Wow.Bot.Tasks
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const MountTask..::..MountCapacity Swimm
Public Const Swimm As MountTask..::..MountCapacity
public:
literal MountTask..::..MountCapacity Swimm

See Also

MountTask..::..MountCapacity Enumeration
wManager.Wow.Bot.Tasks Namespace


Build Field

GOFound..::..Build Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public uint Build
Public Build As UInteger
public:
unsigned int^ Build

See Also

GOFound
wManager.Wow.Class Namespace


ContinentName Field

GOFound..::..ContinentName Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string ContinentName
Public ContinentName As String
public:
String^ ContinentName

See Also

GOFound
wManager.Wow.Class Namespace


Entry Field

GOFound..::..Entry Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int Entry
Public Entry As Integer
public:
int^ Entry

See Also

GOFound
wManager.Wow.Class Namespace


GameObjectType Field

GOFound..::..GameObjectType Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string GameObjectType
Public GameObjectType As String
public:
String^ GameObjectType

See Also

GOFound
wManager.Wow.Class Namespace


Guid Field

GOFound..::..Guid Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Object Guid
Public Guid As Object
public:
Object^ Guid

See Also

GOFound
wManager.Wow.Class Namespace


Matrix Field

GOFound..::..Matrix Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public Matrix Matrix
Public Matrix As Matrix
public:
Matrix^ Matrix

See Also

GOFound
wManager.Wow.Class Namespace


ModelId Field

GOFound..::..ModelId Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public int ModelId
Public ModelId As Integer
public:
int^ ModelId

See Also

GOFound
wManager.Wow.Class Namespace


ModelName Field

GOFound..::..ModelName Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string ModelName
Public ModelName As String
public:
String^ ModelName

See Also

GOFound
wManager.Wow.Class Namespace


Name Field

GOFound..::..Name Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string Name
Public Name As String
public:
String^ Name

See Also

GOFound
wManager.Wow.Class Namespace


Server Field

GOFound..::..Server Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string Server
Public Server As String
public:
String^ Server

See Also

GOFound
wManager.Wow.Class Namespace


TilePath Field

GOFound..::..TilePath Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string TilePath
Public TilePath As String
public:
String^ TilePath

See Also

GOFound
wManager.Wow.Class Namespace


Alliance Field

FactionType..::..Alliance Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..FactionType Alliance
Public Const Alliance As Npc..::..FactionType
public:
literal Npc..::..FactionType Alliance

See Also

Npc..::..FactionType Enumeration
wManager.Wow.Class Namespace


Horde Field

FactionType..::..Horde Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..FactionType Horde
Public Const Horde As Npc..::..FactionType
public:
literal Npc..::..FactionType Horde

See Also

Npc..::..FactionType Enumeration
wManager.Wow.Class Namespace


Neutral Field

FactionType..::..Neutral Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..FactionType Neutral
Public Const Neutral As Npc..::..FactionType
public:
literal Npc..::..FactionType Neutral

See Also

Npc..::..FactionType Enumeration
wManager.Wow.Class Namespace


AlchemyTrainer Field

NpcType..::..AlchemyTrainer Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcType AlchemyTrainer
Public Const AlchemyTrainer As Npc..::..NpcType
public:
literal Npc..::..NpcType AlchemyTrainer

See Also

Npc..::..NpcType Enumeration
wManager.Wow.Class Namespace


ArchaeologyTrainers Field

NpcType..::..ArchaeologyTrainers Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcType ArchaeologyTrainers
Public Const ArchaeologyTrainers As Npc..::..NpcType
public:
literal Npc..::..NpcType ArchaeologyTrainers

See Also

Npc..::..NpcType Enumeration
wManager.Wow.Class Namespace


AuctionHouse Field

NpcType..::..AuctionHouse Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcType AuctionHouse
Public Const AuctionHouse As Npc..::..NpcType
public:
literal Npc..::..NpcType AuctionHouse

See Also

Npc..::..NpcType Enumeration
wManager.Wow.Class Namespace


BlacksmithingTrainer Field

NpcType..::..BlacksmithingTrainer Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcType BlacksmithingTrainer
Public Const BlacksmithingTrainer As Npc..::..NpcType
public:
literal Npc..::..NpcType BlacksmithingTrainer

See Also

Npc..::..NpcType Enumeration
wManager.Wow.Class Namespace


CookingTrainer Field

NpcType..::..CookingTrainer Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcType CookingTrainer
Public Const CookingTrainer As Npc..::..NpcType
public:
literal Npc..::..NpcType CookingTrainer

See Also

Npc..::..NpcType Enumeration
wManager.Wow.Class Namespace


DeathKnightTrainer Field

NpcType..::..DeathKnightTrainer Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcType DeathKnightTrainer
Public Const DeathKnightTrainer As Npc..::..NpcType
public:
literal Npc..::..NpcType DeathKnightTrainer

See Also

Npc..::..NpcType Enumeration
wManager.Wow.Class Namespace


DruidTrainer Field

NpcType..::..DruidTrainer Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcType DruidTrainer
Public Const DruidTrainer As Npc..::..NpcType
public:
literal Npc..::..NpcType DruidTrainer

See Also

Npc..::..NpcType Enumeration
wManager.Wow.Class Namespace


EnchantingTrainer Field

NpcType..::..EnchantingTrainer Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcType EnchantingTrainer
Public Const EnchantingTrainer As Npc..::..NpcType
public:
literal Npc..::..NpcType EnchantingTrainer

See Also

Npc..::..NpcType Enumeration
wManager.Wow.Class Namespace


EngineeringTrainer Field

NpcType..::..EngineeringTrainer Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcType EngineeringTrainer
Public Const EngineeringTrainer As Npc..::..NpcType
public:
literal Npc..::..NpcType EngineeringTrainer

See Also

Npc..::..NpcType Enumeration
wManager.Wow.Class Namespace


FirstAidTrainer Field

NpcType..::..FirstAidTrainer Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcType FirstAidTrainer
Public Const FirstAidTrainer As Npc..::..NpcType
public:
literal Npc..::..NpcType FirstAidTrainer

See Also

Npc..::..NpcType Enumeration
wManager.Wow.Class Namespace


FishingTrainer Field

NpcType..::..FishingTrainer Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcType FishingTrainer
Public Const FishingTrainer As Npc..::..NpcType
public:
literal Npc..::..NpcType FishingTrainer

See Also

Npc..::..NpcType Enumeration
wManager.Wow.Class Namespace


HerbalismTrainer Field

NpcType..::..HerbalismTrainer Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcType HerbalismTrainer
Public Const HerbalismTrainer As Npc..::..NpcType
public:
literal Npc..::..NpcType HerbalismTrainer

See Also

Npc..::..NpcType Enumeration
wManager.Wow.Class Namespace


HunterTrainer Field

NpcType..::..HunterTrainer Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcType HunterTrainer
Public Const HunterTrainer As Npc..::..NpcType
public:
literal Npc..::..NpcType HunterTrainer

See Also

Npc..::..NpcType Enumeration
wManager.Wow.Class Namespace


InscriptionTrainer Field

NpcType..::..InscriptionTrainer Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcType InscriptionTrainer
Public Const InscriptionTrainer As Npc..::..NpcType
public:
literal Npc..::..NpcType InscriptionTrainer

See Also

Npc..::..NpcType Enumeration
wManager.Wow.Class Namespace


JewelcraftingTrainer Field

NpcType..::..JewelcraftingTrainer Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcType JewelcraftingTrainer
Public Const JewelcraftingTrainer As Npc..::..NpcType
public:
literal Npc..::..NpcType JewelcraftingTrainer

See Also

Npc..::..NpcType Enumeration
wManager.Wow.Class Namespace


LeatherworkingTrainer Field

NpcType..::..LeatherworkingTrainer Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcType LeatherworkingTrainer
Public Const LeatherworkingTrainer As Npc..::..NpcType
public:
literal Npc..::..NpcType LeatherworkingTrainer

See Also

Npc..::..NpcType Enumeration
wManager.Wow.Class Namespace


MageTrainer Field

NpcType..::..MageTrainer Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcType MageTrainer
Public Const MageTrainer As Npc..::..NpcType
public:
literal Npc..::..NpcType MageTrainer

See Also

Npc..::..NpcType Enumeration
wManager.Wow.Class Namespace


Mailbox Field

NpcType..::..Mailbox Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcType Mailbox
Public Const Mailbox As Npc..::..NpcType
public:
literal Npc..::..NpcType Mailbox

See Also

Npc..::..NpcType Enumeration
wManager.Wow.Class Namespace


MiningTrainer Field

NpcType..::..MiningTrainer Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcType MiningTrainer
Public Const MiningTrainer As Npc..::..NpcType
public:
literal Npc..::..NpcType MiningTrainer

See Also

Npc..::..NpcType Enumeration
wManager.Wow.Class Namespace


MonkTrainer Field

NpcType..::..MonkTrainer Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcType MonkTrainer
Public Const MonkTrainer As Npc..::..NpcType
public:
literal Npc..::..NpcType MonkTrainer

See Also

Npc..::..NpcType Enumeration
wManager.Wow.Class Namespace


None Field

NpcType..::..None Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcType None
Public Const None As Npc..::..NpcType
public:
literal Npc..::..NpcType None

See Also

Npc..::..NpcType Enumeration
wManager.Wow.Class Namespace


PaladinTrainer Field

NpcType..::..PaladinTrainer Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcType PaladinTrainer
Public Const PaladinTrainer As Npc..::..NpcType
public:
literal Npc..::..NpcType PaladinTrainer

See Also

Npc..::..NpcType Enumeration
wManager.Wow.Class Namespace


PriestTrainer Field

NpcType..::..PriestTrainer Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcType PriestTrainer
Public Const PriestTrainer As Npc..::..NpcType
public:
literal Npc..::..NpcType PriestTrainer

See Also

Npc..::..NpcType Enumeration
wManager.Wow.Class Namespace


Repair Field

NpcType..::..Repair Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcType Repair
Public Const Repair As Npc..::..NpcType
public:
literal Npc..::..NpcType Repair

See Also

Npc..::..NpcType Enumeration
wManager.Wow.Class Namespace


ResurrectBattlePets Field

NpcType..::..ResurrectBattlePets Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcType ResurrectBattlePets
Public Const ResurrectBattlePets As Npc..::..NpcType
public:
literal Npc..::..NpcType ResurrectBattlePets

See Also

Npc..::..NpcType Enumeration
wManager.Wow.Class Namespace


RidingTrainer Field

NpcType..::..RidingTrainer Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcType RidingTrainer
Public Const RidingTrainer As Npc..::..NpcType
public:
literal Npc..::..NpcType RidingTrainer

See Also

Npc..::..NpcType Enumeration
wManager.Wow.Class Namespace


RogueTrainer Field

NpcType..::..RogueTrainer Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcType RogueTrainer
Public Const RogueTrainer As Npc..::..NpcType
public:
literal Npc..::..NpcType RogueTrainer

See Also

Npc..::..NpcType Enumeration
wManager.Wow.Class Namespace


ShamanTrainer Field

NpcType..::..ShamanTrainer Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcType ShamanTrainer
Public Const ShamanTrainer As Npc..::..NpcType
public:
literal Npc..::..NpcType ShamanTrainer

See Also

Npc..::..NpcType Enumeration
wManager.Wow.Class Namespace


SkinningTrainer Field

NpcType..::..SkinningTrainer Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcType SkinningTrainer
Public Const SkinningTrainer As Npc..::..NpcType
public:
literal Npc..::..NpcType SkinningTrainer

See Also

Npc..::..NpcType Enumeration
wManager.Wow.Class Namespace


Smelting Field

NpcType..::..Smelting Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcType Smelting
Public Const Smelting As Npc..::..NpcType
public:
literal Npc..::..NpcType Smelting

See Also

Npc..::..NpcType Enumeration
wManager.Wow.Class Namespace


TailoringTrainer Field

NpcType..::..TailoringTrainer Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcType TailoringTrainer
Public Const TailoringTrainer As Npc..::..NpcType
public:
literal Npc..::..NpcType TailoringTrainer

See Also

Npc..::..NpcType Enumeration
wManager.Wow.Class Namespace


Vendor Field

NpcType..::..Vendor Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcType Vendor
Public Const Vendor As Npc..::..NpcType
public:
literal Npc..::..NpcType Vendor

See Also

Npc..::..NpcType Enumeration
wManager.Wow.Class Namespace


WarlockTrainer Field

NpcType..::..WarlockTrainer Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcType WarlockTrainer
Public Const WarlockTrainer As Npc..::..NpcType
public:
literal Npc..::..NpcType WarlockTrainer

See Also

Npc..::..NpcType Enumeration
wManager.Wow.Class Namespace


WarriorTrainer Field

NpcType..::..WarriorTrainer Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcType WarriorTrainer
Public Const WarriorTrainer As Npc..::..NpcType
public:
literal Npc..::..NpcType WarriorTrainer

See Also

Npc..::..NpcType Enumeration
wManager.Wow.Class Namespace


AlchemyRecipe Field

NpcVendorItemClass..::..AlchemyRecipe Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass AlchemyRecipe
Public Const AlchemyRecipe As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass AlchemyRecipe

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


AmmoPouch Field

NpcVendorItemClass..::..AmmoPouch Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass AmmoPouch
Public Const AmmoPouch As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass AmmoPouch

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


ArmorBuckler Field

NpcVendorItemClass..::..ArmorBuckler Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass ArmorBuckler
Public Const ArmorBuckler As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass ArmorBuckler

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


ArmorCloth Field

NpcVendorItemClass..::..ArmorCloth Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass ArmorCloth
Public Const ArmorCloth As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass ArmorCloth

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


ArmorIdol Field

NpcVendorItemClass..::..ArmorIdol Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass ArmorIdol
Public Const ArmorIdol As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass ArmorIdol

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


ArmorLeather Field

NpcVendorItemClass..::..ArmorLeather Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass ArmorLeather
Public Const ArmorLeather As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass ArmorLeather

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


ArmorLibram Field

NpcVendorItemClass..::..ArmorLibram Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass ArmorLibram
Public Const ArmorLibram As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass ArmorLibram

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


ArmorMail Field

NpcVendorItemClass..::..ArmorMail Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass ArmorMail
Public Const ArmorMail As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass ArmorMail

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


ArmorMisc Field

NpcVendorItemClass..::..ArmorMisc Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass ArmorMisc
Public Const ArmorMisc As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass ArmorMisc

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


ArmorPlate Field

NpcVendorItemClass..::..ArmorPlate Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass ArmorPlate
Public Const ArmorPlate As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass ArmorPlate

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


ArmorShield Field

NpcVendorItemClass..::..ArmorShield Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass ArmorShield
Public Const ArmorShield As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass ArmorShield

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


ArmorTotem Field

NpcVendorItemClass..::..ArmorTotem Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass ArmorTotem
Public Const ArmorTotem As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass ArmorTotem

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


Arrow Field

NpcVendorItemClass..::..Arrow Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass Arrow
Public Const Arrow As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass Arrow

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


Bandage Field

NpcVendorItemClass..::..Bandage Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass Bandage
Public Const Bandage As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass Bandage

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


Blacksmithing Field

NpcVendorItemClass..::..Blacksmithing Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass Blacksmithing
Public Const Blacksmithing As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass Blacksmithing

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


Book Field

NpcVendorItemClass..::..Book Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass Book
Public Const Book As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass Book

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


Bullet Field

NpcVendorItemClass..::..Bullet Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass Bullet
Public Const Bullet As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass Bullet

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


Consumable Field

NpcVendorItemClass..::..Consumable Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass Consumable
Public Const Consumable As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass Consumable

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


ConsumableOther Field

NpcVendorItemClass..::..ConsumableOther Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass ConsumableOther
Public Const ConsumableOther As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass ConsumableOther

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


Container Field

NpcVendorItemClass..::..Container Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass Container
Public Const Container As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass Container

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


CookingRecipe Field

NpcVendorItemClass..::..CookingRecipe Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass CookingRecipe
Public Const CookingRecipe As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass CookingRecipe

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


Custom Field

NpcVendorItemClass..::..Custom Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass Custom
Public Const Custom As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass Custom

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


Devices Field

NpcVendorItemClass..::..Devices Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass Devices
Public Const Devices As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass Devices

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


Elixir Field

NpcVendorItemClass..::..Elixir Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass Elixir
Public Const Elixir As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass Elixir

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


EnchantingContainer Field

NpcVendorItemClass..::..EnchantingContainer Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass EnchantingContainer
Public Const EnchantingContainer As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass EnchantingContainer

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


EnchantingFormula Field

NpcVendorItemClass..::..EnchantingFormula Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass EnchantingFormula
Public Const EnchantingFormula As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass EnchantingFormula

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


EngineeringContainer Field

NpcVendorItemClass..::..EngineeringContainer Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass EngineeringContainer
Public Const EngineeringContainer As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass EngineeringContainer

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


EngineeringSchematic Field

NpcVendorItemClass..::..EngineeringSchematic Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass EngineeringSchematic
Public Const EngineeringSchematic As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass EngineeringSchematic

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


Explosives Field

NpcVendorItemClass..::..Explosives Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass Explosives
Public Const Explosives As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass Explosives

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


FirstAidManual Field

NpcVendorItemClass..::..FirstAidManual Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass FirstAidManual
Public Const FirstAidManual As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass FirstAidManual

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


FishingManual Field

NpcVendorItemClass..::..FishingManual Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass FishingManual
Public Const FishingManual As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass FishingManual

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


Flask Field

NpcVendorItemClass..::..Flask Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass Flask
Public Const Flask As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass Flask

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


Food Field

NpcVendorItemClass..::..Food Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass Food
Public Const Food As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass Food

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


HerbContainer Field

NpcVendorItemClass..::..HerbContainer Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass HerbContainer
Public Const HerbContainer As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass HerbContainer

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


ItemEnhancement Field

NpcVendorItemClass..::..ItemEnhancement Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass ItemEnhancement
Public Const ItemEnhancement As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass ItemEnhancement

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


Junk Field

NpcVendorItemClass..::..Junk Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass Junk
Public Const Junk As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass Junk

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


Key Field

NpcVendorItemClass..::..Key Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass Key
Public Const Key As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass Key

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


LeatherworkingPattern Field

NpcVendorItemClass..::..LeatherworkingPattern Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass LeatherworkingPattern
Public Const LeatherworkingPattern As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass LeatherworkingPattern

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


Lockpick Field

NpcVendorItemClass..::..Lockpick Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass Lockpick
Public Const Lockpick As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass Lockpick

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


None Field

NpcVendorItemClass..::..None Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass None
Public Const None As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass None

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


Parts Field

NpcVendorItemClass..::..Parts Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass Parts
Public Const Parts As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass Parts

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


Permanent Field

NpcVendorItemClass..::..Permanent Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass Permanent
Public Const Permanent As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass Permanent

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


Potion Field

NpcVendorItemClass..::..Potion Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass Potion
Public Const Potion As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass Potion

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


Quest Field

NpcVendorItemClass..::..Quest Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass Quest
Public Const Quest As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass Quest

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


Quiver Field

NpcVendorItemClass..::..Quiver Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass Quiver
Public Const Quiver As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass Quiver

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


Reagent Field

NpcVendorItemClass..::..Reagent Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass Reagent
Public Const Reagent As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass Reagent

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


Scroll Field

NpcVendorItemClass..::..Scroll Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass Scroll
Public Const Scroll As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass Scroll

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


SoulContainer Field

NpcVendorItemClass..::..SoulContainer Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass SoulContainer
Public Const SoulContainer As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass SoulContainer

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


TailoringPattern Field

NpcVendorItemClass..::..TailoringPattern Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass TailoringPattern
Public Const TailoringPattern As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass TailoringPattern

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


TradeGoods Field

NpcVendorItemClass..::..TradeGoods Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass TradeGoods
Public Const TradeGoods As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass TradeGoods

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


WeaponAxe Field

NpcVendorItemClass..::..WeaponAxe Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass WeaponAxe
Public Const WeaponAxe As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass WeaponAxe

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


WeaponAxe2 Field

NpcVendorItemClass..::..WeaponAxe2 Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass WeaponAxe2
Public Const WeaponAxe2 As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass WeaponAxe2

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


WeaponBow Field

NpcVendorItemClass..::..WeaponBow Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass WeaponBow
Public Const WeaponBow As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass WeaponBow

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


WeaponCrossbow Field

NpcVendorItemClass..::..WeaponCrossbow Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass WeaponCrossbow
Public Const WeaponCrossbow As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass WeaponCrossbow

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


WeaponDagger Field

NpcVendorItemClass..::..WeaponDagger Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass WeaponDagger
Public Const WeaponDagger As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass WeaponDagger

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


WeaponFishingPole Field

NpcVendorItemClass..::..WeaponFishingPole Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass WeaponFishingPole
Public Const WeaponFishingPole As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass WeaponFishingPole

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


WeaponFist Field

NpcVendorItemClass..::..WeaponFist Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass WeaponFist
Public Const WeaponFist As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass WeaponFist

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


WeaponGun Field

NpcVendorItemClass..::..WeaponGun Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass WeaponGun
Public Const WeaponGun As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass WeaponGun

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


WeaponMace Field

NpcVendorItemClass..::..WeaponMace Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass WeaponMace
Public Const WeaponMace As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass WeaponMace

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


WeaponMace2 Field

NpcVendorItemClass..::..WeaponMace2 Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass WeaponMace2
Public Const WeaponMace2 As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass WeaponMace2

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


WeaponMisc Field

NpcVendorItemClass..::..WeaponMisc Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass WeaponMisc
Public Const WeaponMisc As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass WeaponMisc

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


WeaponPolearm Field

NpcVendorItemClass..::..WeaponPolearm Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass WeaponPolearm
Public Const WeaponPolearm As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass WeaponPolearm

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


WeaponReserved1 Field

NpcVendorItemClass..::..WeaponReserved1 Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass WeaponReserved1
Public Const WeaponReserved1 As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass WeaponReserved1

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


WeaponReserved2 Field

NpcVendorItemClass..::..WeaponReserved2 Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass WeaponReserved2
Public Const WeaponReserved2 As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass WeaponReserved2

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


WeaponReserved3 Field

NpcVendorItemClass..::..WeaponReserved3 Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass WeaponReserved3
Public Const WeaponReserved3 As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass WeaponReserved3

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


WeaponSpear Field

NpcVendorItemClass..::..WeaponSpear Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass WeaponSpear
Public Const WeaponSpear As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass WeaponSpear

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


WeaponStaff Field

NpcVendorItemClass..::..WeaponStaff Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass WeaponStaff
Public Const WeaponStaff As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass WeaponStaff

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


WeaponSword Field

NpcVendorItemClass..::..WeaponSword Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass WeaponSword
Public Const WeaponSword As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass WeaponSword

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


WeaponSword2 Field

NpcVendorItemClass..::..WeaponSword2 Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass WeaponSword2
Public Const WeaponSword2 As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass WeaponSword2

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


WeaponThrown Field

NpcVendorItemClass..::..WeaponThrown Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass WeaponThrown
Public Const WeaponThrown As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass WeaponThrown

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


WeaponWand Field

NpcVendorItemClass..::..WeaponWand Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Npc..::..NpcVendorItemClass WeaponWand
Public Const WeaponWand As Npc..::..NpcVendorItemClass
public:
literal Npc..::..NpcVendorItemClass WeaponWand

See Also

Npc..::..NpcVendorItemClass Enumeration
wManager.Wow.Class Namespace


EndIf Field

QuestAction..::..EndIf Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const QuestAction EndIf
Public Const EndIf As QuestAction
public:
literal QuestAction EndIf

See Also

QuestAction Enumeration
wManager.Wow.Class Namespace


EndWhile Field

QuestAction..::..EndWhile Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const QuestAction EndWhile
Public Const EndWhile As QuestAction
public:
literal QuestAction EndWhile

See Also

QuestAction Enumeration
wManager.Wow.Class Namespace


GoToStep Field

QuestAction..::..GoToStep Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const QuestAction GoToStep
Public Const GoToStep As QuestAction
public:
literal QuestAction GoToStep

See Also

QuestAction Enumeration
wManager.Wow.Class Namespace


If Field

QuestAction..::..If Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const QuestAction If
Public Const If As QuestAction
public:
literal QuestAction If

See Also

QuestAction Enumeration
wManager.Wow.Class Namespace


IfHasNotQuest Field

QuestAction..::..IfHasNotQuest Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const QuestAction IfHasNotQuest
Public Const IfHasNotQuest As QuestAction
public:
literal QuestAction IfHasNotQuest

See Also

QuestAction Enumeration
wManager.Wow.Class Namespace


IfHasQuest Field

QuestAction..::..IfHasQuest Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const QuestAction IfHasQuest
Public Const IfHasQuest As QuestAction
public:
literal QuestAction IfHasQuest

See Also

QuestAction Enumeration
wManager.Wow.Class Namespace


IfVB Field

QuestAction..::..IfVB Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const QuestAction IfVB
Public Const IfVB As QuestAction
public:
literal QuestAction IfVB

See Also

QuestAction Enumeration
wManager.Wow.Class Namespace


LoadProfile Field

QuestAction..::..LoadProfile Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const QuestAction LoadProfile
Public Const LoadProfile As QuestAction
public:
literal QuestAction LoadProfile

See Also

QuestAction Enumeration
wManager.Wow.Class Namespace


MessageBox Field

QuestAction..::..MessageBox Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const QuestAction MessageBox
Public Const MessageBox As QuestAction
public:
literal QuestAction MessageBox

See Also

QuestAction Enumeration
wManager.Wow.Class Namespace


None Field

QuestAction..::..None Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const QuestAction None
Public Const None As QuestAction
public:
literal QuestAction None

See Also

QuestAction Enumeration
wManager.Wow.Class Namespace


PickUp Field

QuestAction..::..PickUp Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const QuestAction PickUp
Public Const PickUp As QuestAction
public:
literal QuestAction PickUp

See Also

QuestAction Enumeration
wManager.Wow.Class Namespace


Pulse Field

QuestAction..::..Pulse Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const QuestAction Pulse
Public Const Pulse As QuestAction
public:
literal QuestAction Pulse

See Also

QuestAction Enumeration
wManager.Wow.Class Namespace


PulseAllInOne Field

QuestAction..::..PulseAllInOne Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const QuestAction PulseAllInOne
Public Const PulseAllInOne As QuestAction
public:
literal QuestAction PulseAllInOne

See Also

QuestAction Enumeration
wManager.Wow.Class Namespace


Reset Field

QuestAction..::..Reset Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const QuestAction Reset
Public Const Reset As QuestAction
public:
literal QuestAction Reset

See Also

QuestAction Enumeration
wManager.Wow.Class Namespace


RunCode Field

QuestAction..::..RunCode Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const QuestAction RunCode
Public Const RunCode As QuestAction
public:
literal QuestAction RunCode

See Also

QuestAction Enumeration
wManager.Wow.Class Namespace


RunCodeLuaBot Field

QuestAction..::..RunCodeLuaBot Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const QuestAction RunCodeLuaBot
Public Const RunCodeLuaBot As QuestAction
public:
literal QuestAction RunCodeLuaBot

See Also

QuestAction Enumeration
wManager.Wow.Class Namespace


RunCodeVB Field

QuestAction..::..RunCodeVB Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const QuestAction RunCodeVB
Public Const RunCodeVB As QuestAction
public:
literal QuestAction RunCodeVB

See Also

QuestAction Enumeration
wManager.Wow.Class Namespace


RunLuaCode Field

QuestAction..::..RunLuaCode Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const QuestAction RunLuaCode
Public Const RunLuaCode As QuestAction
public:
literal QuestAction RunLuaCode

See Also

QuestAction Enumeration
wManager.Wow.Class Namespace


RunMacroLua Field

QuestAction..::..RunMacroLua Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const QuestAction RunMacroLua
Public Const RunMacroLua As QuestAction
public:
literal QuestAction RunMacroLua

See Also

QuestAction Enumeration
wManager.Wow.Class Namespace


StepName Field

QuestAction..::..StepName Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const QuestAction StepName
Public Const StepName As QuestAction
public:
literal QuestAction StepName

See Also

QuestAction Enumeration
wManager.Wow.Class Namespace


StopBot Field

QuestAction..::..StopBot Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const QuestAction StopBot
Public Const StopBot As QuestAction
public:
literal QuestAction StopBot

See Also

QuestAction Enumeration
wManager.Wow.Class Namespace


TurnIn Field

QuestAction..::..TurnIn Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const QuestAction TurnIn
Public Const TurnIn As QuestAction
public:
literal QuestAction TurnIn

See Also

QuestAction Enumeration
wManager.Wow.Class Namespace


Wait Field

QuestAction..::..Wait Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const QuestAction Wait
Public Const Wait As QuestAction
public:
literal QuestAction Wait

See Also

QuestAction Enumeration
wManager.Wow.Class Namespace


While Field

QuestAction..::..While Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const QuestAction While
Public Const While As QuestAction
public:
literal QuestAction While

See Also

QuestAction Enumeration
wManager.Wow.Class Namespace


WhileHasNotQuest Field

QuestAction..::..WhileHasNotQuest Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const QuestAction WhileHasNotQuest
Public Const WhileHasNotQuest As QuestAction
public:
literal QuestAction WhileHasNotQuest

See Also

QuestAction Enumeration
wManager.Wow.Class Namespace


WhileHasQuest Field

QuestAction..::..WhileHasQuest Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const QuestAction WhileHasQuest
Public Const WhileHasQuest As QuestAction
public:
literal QuestAction WhileHasQuest

See Also

QuestAction Enumeration
wManager.Wow.Class Namespace


WhileVB Field

QuestAction..::..WhileVB Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const QuestAction WhileVB
Public Const WhileVB As QuestAction
public:
literal QuestAction WhileVB

See Also

QuestAction Enumeration
wManager.Wow.Class Namespace


WriteDebugLog Field

QuestAction..::..WriteDebugLog Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const QuestAction WriteDebugLog
Public Const WriteDebugLog As QuestAction
public:
literal QuestAction WriteDebugLog

See Also

QuestAction Enumeration
wManager.Wow.Class Namespace


WriteLog Field

QuestAction..::..WriteLog Field

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const QuestAction WriteLog
Public Const WriteLog As QuestAction
public:
literal QuestAction WriteLog

See Also

QuestAction Enumeration
wManager.Wow.Class Namespace


AmmoPouch Field

BagType..::..AmmoPouch Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const BagType AmmoPouch
Public Const AmmoPouch As BagType
public:
literal BagType AmmoPouch

See Also

BagType Enumeration
wManager.Wow.Enums Namespace


Enchanting Field

BagType..::..Enchanting Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const BagType Enchanting
Public Const Enchanting As BagType
public:
literal BagType Enchanting

See Also

BagType Enumeration
wManager.Wow.Enums Namespace


Engineering Field

BagType..::..Engineering Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const BagType Engineering
Public Const Engineering As BagType
public:
literal BagType Engineering

See Also

BagType Enumeration
wManager.Wow.Enums Namespace


Gem Field

BagType..::..Gem Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const BagType Gem
Public Const Gem As BagType
public:
literal BagType Gem

See Also

BagType Enumeration
wManager.Wow.Enums Namespace


Herb Field

BagType..::..Herb Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const BagType Herb
Public Const Herb As BagType
public:
literal BagType Herb

See Also

BagType Enumeration
wManager.Wow.Enums Namespace


Inscription Field

BagType..::..Inscription Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const BagType Inscription
Public Const Inscription As BagType
public:
literal BagType Inscription

See Also

BagType Enumeration
wManager.Wow.Enums Namespace


Keyring Field

BagType..::..Keyring Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const BagType Keyring
Public Const Keyring As BagType
public:
literal BagType Keyring

See Also

BagType Enumeration
wManager.Wow.Enums Namespace


Leatherworking Field

BagType..::..Leatherworking Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const BagType Leatherworking
Public Const Leatherworking As BagType
public:
literal BagType Leatherworking

See Also

BagType Enumeration
wManager.Wow.Enums Namespace


Mining Field

BagType..::..Mining Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const BagType Mining
Public Const Mining As BagType
public:
literal BagType Mining

See Also

BagType Enumeration
wManager.Wow.Enums Namespace


Quiver Field

BagType..::..Quiver Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const BagType Quiver
Public Const Quiver As BagType
public:
literal BagType Quiver

See Also

BagType Enumeration
wManager.Wow.Enums Namespace


Soul Field

BagType..::..Soul Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const BagType Soul
Public Const Soul As BagType
public:
literal BagType Soul

See Also

BagType Enumeration
wManager.Wow.Enums Namespace


Unknown Field

BagType..::..Unknown Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const BagType Unknown
Public Const Unknown As BagType
public:
literal BagType Unknown

See Also

BagType Enumeration
wManager.Wow.Enums Namespace


Unspecified Field

BagType..::..Unspecified Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const BagType Unspecified
Public Const Unspecified As BagType
public:
literal BagType Unspecified

See Also

BagType Enumeration
wManager.Wow.Enums Namespace


Vanity Field

BagType..::..Vanity Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const BagType Vanity
Public Const Vanity As BagType
public:
literal BagType Vanity

See Also

BagType Enumeration
wManager.Wow.Enums Namespace


AB Field

BattleGroundID..::..AB Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const BattleGroundID AB
Public Const AB As BattleGroundID
public:
literal BattleGroundID AB

See Also

BattleGroundID Enumeration
wManager.Wow.Enums Namespace


AV Field

BattleGroundID..::..AV Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const BattleGroundID AV
Public Const AV As BattleGroundID
public:
literal BattleGroundID AV

See Also

BattleGroundID Enumeration
wManager.Wow.Enums Namespace


BfG Field

BattleGroundID..::..BfG Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const BattleGroundID BfG
Public Const BfG As BattleGroundID
public:
literal BattleGroundID BfG

See Also

BattleGroundID Enumeration
wManager.Wow.Enums Namespace


DG Field

BattleGroundID..::..DG Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const BattleGroundID DG
Public Const DG As BattleGroundID
public:
literal BattleGroundID DG

See Also

BattleGroundID Enumeration
wManager.Wow.Enums Namespace


EotS Field

BattleGroundID..::..EotS Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const BattleGroundID EotS
Public Const EotS As BattleGroundID
public:
literal BattleGroundID EotS

See Also

BattleGroundID Enumeration
wManager.Wow.Enums Namespace


IoC Field

BattleGroundID..::..IoC Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const BattleGroundID IoC
Public Const IoC As BattleGroundID
public:
literal BattleGroundID IoC

See Also

BattleGroundID Enumeration
wManager.Wow.Enums Namespace


None Field

BattleGroundID..::..None Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const BattleGroundID None
Public Const None As BattleGroundID
public:
literal BattleGroundID None

See Also

BattleGroundID Enumeration
wManager.Wow.Enums Namespace


RandomBattleground Field

BattleGroundID..::..RandomBattleground Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const BattleGroundID RandomBattleground
Public Const RandomBattleground As BattleGroundID
public:
literal BattleGroundID RandomBattleground

See Also

BattleGroundID Enumeration
wManager.Wow.Enums Namespace


SM Field

BattleGroundID..::..SM Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const BattleGroundID SM
Public Const SM As BattleGroundID
public:
literal BattleGroundID SM

See Also

BattleGroundID Enumeration
wManager.Wow.Enums Namespace


SotA Field

BattleGroundID..::..SotA Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const BattleGroundID SotA
Public Const SotA As BattleGroundID
public:
literal BattleGroundID SotA

See Also

BattleGroundID Enumeration
wManager.Wow.Enums Namespace


ToK Field

BattleGroundID..::..ToK Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const BattleGroundID ToK
Public Const ToK As BattleGroundID
public:
literal BattleGroundID ToK

See Also

BattleGroundID Enumeration
wManager.Wow.Enums Namespace


TP Field

BattleGroundID..::..TP Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const BattleGroundID TP
Public Const TP As BattleGroundID
public:
literal BattleGroundID TP

See Also

BattleGroundID Enumeration
wManager.Wow.Enums Namespace


WSG Field

BattleGroundID..::..WSG Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const BattleGroundID WSG
Public Const WSG As BattleGroundID
public:
literal BattleGroundID WSG

See Also

BattleGroundID Enumeration
wManager.Wow.Enums Namespace


HitTestAll Field

CGWorldFrameHitFlags..::..HitTestAll Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const CGWorldFrameHitFlags HitTestAll
Public Const HitTestAll As CGWorldFrameHitFlags
public:
literal CGWorldFrameHitFlags HitTestAll

See Also

CGWorldFrameHitFlags Enumeration
wManager.Wow.Enums Namespace


HitTestAllWhitoutLiquid Field

CGWorldFrameHitFlags..::..HitTestAllWhitoutLiquid Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const CGWorldFrameHitFlags HitTestAllWhitoutLiquid
Public Const HitTestAllWhitoutLiquid As CGWorldFrameHitFlags
public:
literal CGWorldFrameHitFlags HitTestAllWhitoutLiquid

See Also

CGWorldFrameHitFlags Enumeration
wManager.Wow.Enums Namespace


HitTestBoundingModels Field

CGWorldFrameHitFlags..::..HitTestBoundingModels Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const CGWorldFrameHitFlags HitTestBoundingModels
Public Const HitTestBoundingModels As CGWorldFrameHitFlags
public:
literal CGWorldFrameHitFlags HitTestBoundingModels

See Also

CGWorldFrameHitFlags Enumeration
wManager.Wow.Enums Namespace


HitTestGround Field

CGWorldFrameHitFlags..::..HitTestGround Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const CGWorldFrameHitFlags HitTestGround
Public Const HitTestGround As CGWorldFrameHitFlags
public:
literal CGWorldFrameHitFlags HitTestGround

See Also

CGWorldFrameHitFlags Enumeration
wManager.Wow.Enums Namespace


HitTestGroundAndStructures Field

CGWorldFrameHitFlags..::..HitTestGroundAndStructures Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const CGWorldFrameHitFlags HitTestGroundAndStructures
Public Const HitTestGroundAndStructures As CGWorldFrameHitFlags
public:
literal CGWorldFrameHitFlags HitTestGroundAndStructures

See Also

CGWorldFrameHitFlags Enumeration
wManager.Wow.Enums Namespace


HitTestLiquid Field

CGWorldFrameHitFlags..::..HitTestLiquid Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const CGWorldFrameHitFlags HitTestLiquid
Public Const HitTestLiquid As CGWorldFrameHitFlags
public:
literal CGWorldFrameHitFlags HitTestLiquid

See Also

CGWorldFrameHitFlags Enumeration
wManager.Wow.Enums Namespace


HitTestLiquid2 Field

CGWorldFrameHitFlags..::..HitTestLiquid2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const CGWorldFrameHitFlags HitTestLiquid2
Public Const HitTestLiquid2 As CGWorldFrameHitFlags
public:
literal CGWorldFrameHitFlags HitTestLiquid2

See Also

CGWorldFrameHitFlags Enumeration
wManager.Wow.Enums Namespace


HitTestLOS Field

CGWorldFrameHitFlags..::..HitTestLOS Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const CGWorldFrameHitFlags HitTestLOS
Public Const HitTestLOS As CGWorldFrameHitFlags
public:
literal CGWorldFrameHitFlags HitTestLOS

See Also

CGWorldFrameHitFlags Enumeration
wManager.Wow.Enums Namespace


HitTestMovableObjects Field

CGWorldFrameHitFlags..::..HitTestMovableObjects Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const CGWorldFrameHitFlags HitTestMovableObjects
Public Const HitTestMovableObjects As CGWorldFrameHitFlags
public:
literal CGWorldFrameHitFlags HitTestMovableObjects

See Also

CGWorldFrameHitFlags Enumeration
wManager.Wow.Enums Namespace


HitTestNothing Field

CGWorldFrameHitFlags..::..HitTestNothing Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const CGWorldFrameHitFlags HitTestNothing
Public Const HitTestNothing As CGWorldFrameHitFlags
public:
literal CGWorldFrameHitFlags HitTestNothing

See Also

CGWorldFrameHitFlags Enumeration
wManager.Wow.Enums Namespace


HitTestSpellLoS Field

CGWorldFrameHitFlags..::..HitTestSpellLoS Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const CGWorldFrameHitFlags HitTestSpellLoS
Public Const HitTestSpellLoS As CGWorldFrameHitFlags
public:
literal CGWorldFrameHitFlags HitTestSpellLoS

See Also

CGWorldFrameHitFlags Enumeration
wManager.Wow.Enums Namespace


HitTestUnknown2 Field

CGWorldFrameHitFlags..::..HitTestUnknown2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const CGWorldFrameHitFlags HitTestUnknown2
Public Const HitTestUnknown2 As CGWorldFrameHitFlags
public:
literal CGWorldFrameHitFlags HitTestUnknown2

See Also

CGWorldFrameHitFlags Enumeration
wManager.Wow.Enums Namespace


HitTestUnknown3 Field

CGWorldFrameHitFlags..::..HitTestUnknown3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const CGWorldFrameHitFlags HitTestUnknown3
Public Const HitTestUnknown3 As CGWorldFrameHitFlags
public:
literal CGWorldFrameHitFlags HitTestUnknown3

See Also

CGWorldFrameHitFlags Enumeration
wManager.Wow.Enums Namespace


HitTestUnknown4 Field

CGWorldFrameHitFlags..::..HitTestUnknown4 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const CGWorldFrameHitFlags HitTestUnknown4
Public Const HitTestUnknown4 As CGWorldFrameHitFlags
public:
literal CGWorldFrameHitFlags HitTestUnknown4

See Also

CGWorldFrameHitFlags Enumeration
wManager.Wow.Enums Namespace


HitTestWater Field

CGWorldFrameHitFlags..::..HitTestWater Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const CGWorldFrameHitFlags HitTestWater
Public Const HitTestWater As CGWorldFrameHitFlags
public:
literal CGWorldFrameHitFlags HitTestWater

See Also

CGWorldFrameHitFlags Enumeration
wManager.Wow.Enums Namespace


HitTestWMO Field

CGWorldFrameHitFlags..::..HitTestWMO Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const CGWorldFrameHitFlags HitTestWMO
Public Const HitTestWMO As CGWorldFrameHitFlags
public:
literal CGWorldFrameHitFlags HitTestWMO

See Also

CGWorldFrameHitFlags Enumeration
wManager.Wow.Enums Namespace


HitTestWMONoCam Field

CGWorldFrameHitFlags..::..HitTestWMONoCam Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const CGWorldFrameHitFlags HitTestWMONoCam
Public Const HitTestWMONoCam As CGWorldFrameHitFlags
public:
literal CGWorldFrameHitFlags HitTestWMONoCam

See Also

CGWorldFrameHitFlags Enumeration
wManager.Wow.Enums Namespace


AFK Field

ChatTypeId..::..AFK Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ChatTypeId AFK
Public Const AFK As ChatTypeId
public:
literal ChatTypeId AFK

See Also

ChatTypeId Enumeration
wManager.Wow.Enums Namespace


All Field

ChatTypeId..::..All Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ChatTypeId All
Public Const All As ChatTypeId
public:
literal ChatTypeId All

See Also

ChatTypeId Enumeration
wManager.Wow.Enums Namespace


BN Field

ChatTypeId..::..BN Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ChatTypeId BN
Public Const BN As ChatTypeId
public:
literal ChatTypeId BN

See Also

ChatTypeId Enumeration
wManager.Wow.Enums Namespace


BN_CONVERSATION Field

ChatTypeId..::..BN_CONVERSATION Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ChatTypeId BN_CONVERSATION
Public Const BN_CONVERSATION As ChatTypeId
public:
literal ChatTypeId BN_CONVERSATION

See Also

ChatTypeId Enumeration
wManager.Wow.Enums Namespace


BN_WHISPER Field

ChatTypeId..::..BN_WHISPER Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ChatTypeId BN_WHISPER
Public Const BN_WHISPER As ChatTypeId
public:
literal ChatTypeId BN_WHISPER

See Also

ChatTypeId Enumeration
wManager.Wow.Enums Namespace


BN_WHISPER_INFORM Field

ChatTypeId..::..BN_WHISPER_INFORM Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ChatTypeId BN_WHISPER_INFORM
Public Const BN_WHISPER_INFORM As ChatTypeId
public:
literal ChatTypeId BN_WHISPER_INFORM

See Also

ChatTypeId Enumeration
wManager.Wow.Enums Namespace


CHANNEL Field

ChatTypeId..::..CHANNEL Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ChatTypeId CHANNEL
Public Const CHANNEL As ChatTypeId
public:
literal ChatTypeId CHANNEL

See Also

ChatTypeId Enumeration
wManager.Wow.Enums Namespace


DND Field

ChatTypeId..::..DND Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ChatTypeId DND
Public Const DND As ChatTypeId
public:
literal ChatTypeId DND

See Also

ChatTypeId Enumeration
wManager.Wow.Enums Namespace


EMOTE Field

ChatTypeId..::..EMOTE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ChatTypeId EMOTE
Public Const EMOTE As ChatTypeId
public:
literal ChatTypeId EMOTE

See Also

ChatTypeId Enumeration
wManager.Wow.Enums Namespace


GUILD Field

ChatTypeId..::..GUILD Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ChatTypeId GUILD
Public Const GUILD As ChatTypeId
public:
literal ChatTypeId GUILD

See Also

ChatTypeId Enumeration
wManager.Wow.Enums Namespace


INSTANCE_CHAT Field

ChatTypeId..::..INSTANCE_CHAT Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ChatTypeId INSTANCE_CHAT
Public Const INSTANCE_CHAT As ChatTypeId
public:
literal ChatTypeId INSTANCE_CHAT

See Also

ChatTypeId Enumeration
wManager.Wow.Enums Namespace


none Field

ChatTypeId..::..none Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ChatTypeId none
Public Const none As ChatTypeId
public:
literal ChatTypeId none

See Also

ChatTypeId Enumeration
wManager.Wow.Enums Namespace


OFFICER Field

ChatTypeId..::..OFFICER Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ChatTypeId OFFICER
Public Const OFFICER As ChatTypeId
public:
literal ChatTypeId OFFICER

See Also

ChatTypeId Enumeration
wManager.Wow.Enums Namespace


PARTY Field

ChatTypeId..::..PARTY Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ChatTypeId PARTY
Public Const PARTY As ChatTypeId
public:
literal ChatTypeId PARTY

See Also

ChatTypeId Enumeration
wManager.Wow.Enums Namespace


PARTYLEADER Field

ChatTypeId..::..PARTYLEADER Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ChatTypeId PARTYLEADER
Public Const PARTYLEADER As ChatTypeId
public:
literal ChatTypeId PARTYLEADER

See Also

ChatTypeId Enumeration
wManager.Wow.Enums Namespace


RAID Field

ChatTypeId..::..RAID Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ChatTypeId RAID
Public Const RAID As ChatTypeId
public:
literal ChatTypeId RAID

See Also

ChatTypeId Enumeration
wManager.Wow.Enums Namespace


RAID_WARNING Field

ChatTypeId..::..RAID_WARNING Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ChatTypeId RAID_WARNING
Public Const RAID_WARNING As ChatTypeId
public:
literal ChatTypeId RAID_WARNING

See Also

ChatTypeId Enumeration
wManager.Wow.Enums Namespace


SAY Field

ChatTypeId..::..SAY Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ChatTypeId SAY
Public Const SAY As ChatTypeId
public:
literal ChatTypeId SAY

See Also

ChatTypeId Enumeration
wManager.Wow.Enums Namespace


WHISPER Field

ChatTypeId..::..WHISPER Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ChatTypeId WHISPER
Public Const WHISPER As ChatTypeId
public:
literal ChatTypeId WHISPER

See Also

ChatTypeId Enumeration
wManager.Wow.Enums Namespace


WHISPER_SEND Field

ChatTypeId..::..WHISPER_SEND Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ChatTypeId WHISPER_SEND
Public Const WHISPER_SEND As ChatTypeId
public:
literal ChatTypeId WHISPER_SEND

See Also

ChatTypeId Enumeration
wManager.Wow.Enums Namespace


YELL Field

ChatTypeId..::..YELL Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ChatTypeId YELL
Public Const YELL As ChatTypeId
public:
literal ChatTypeId YELL

See Also

ChatTypeId Enumeration
wManager.Wow.Enums Namespace


Attack Field

ClickToMoveType..::..Attack Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ClickToMoveType Attack
Public Const Attack As ClickToMoveType
public:
literal ClickToMoveType Attack

See Also

ClickToMoveType Enumeration
wManager.Wow.Enums Namespace


AttackGuid Field

ClickToMoveType..::..AttackGuid Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ClickToMoveType AttackGuid
Public Const AttackGuid As ClickToMoveType
public:
literal ClickToMoveType AttackGuid

See Also

ClickToMoveType Enumeration
wManager.Wow.Enums Namespace


AttackPosition Field

ClickToMoveType..::..AttackPosition Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ClickToMoveType AttackPosition
Public Const AttackPosition As ClickToMoveType
public:
literal ClickToMoveType AttackPosition

See Also

ClickToMoveType Enumeration
wManager.Wow.Enums Namespace


ConstantFace Field

ClickToMoveType..::..ConstantFace Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ClickToMoveType ConstantFace
Public Const ConstantFace As ClickToMoveType
public:
literal ClickToMoveType ConstantFace

See Also

ClickToMoveType Enumeration
wManager.Wow.Enums Namespace


Face Field

ClickToMoveType..::..Face Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ClickToMoveType Face
Public Const Face As ClickToMoveType
public:
literal ClickToMoveType Face

See Also

ClickToMoveType Enumeration
wManager.Wow.Enums Namespace


FaceOther Field

ClickToMoveType..::..FaceOther Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ClickToMoveType FaceOther
Public Const FaceOther As ClickToMoveType
public:
literal ClickToMoveType FaceOther

See Also

ClickToMoveType Enumeration
wManager.Wow.Enums Namespace


FaceTarget Field

ClickToMoveType..::..FaceTarget Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ClickToMoveType FaceTarget
Public Const FaceTarget As ClickToMoveType
public:
literal ClickToMoveType FaceTarget

See Also

ClickToMoveType Enumeration
wManager.Wow.Enums Namespace


Idle Field

ClickToMoveType..::..Idle Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ClickToMoveType Idle
Public Const Idle As ClickToMoveType
public:
literal ClickToMoveType Idle

See Also

ClickToMoveType Enumeration
wManager.Wow.Enums Namespace


Loot Field

ClickToMoveType..::..Loot Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ClickToMoveType Loot
Public Const Loot As ClickToMoveType
public:
literal ClickToMoveType Loot

See Also

ClickToMoveType Enumeration
wManager.Wow.Enums Namespace


Move Field

ClickToMoveType..::..Move Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ClickToMoveType Move
Public Const Move As ClickToMoveType
public:
literal ClickToMoveType Move

See Also

ClickToMoveType Enumeration
wManager.Wow.Enums Namespace


None Field

ClickToMoveType..::..None Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ClickToMoveType None
Public Const None As ClickToMoveType
public:
literal ClickToMoveType None

See Also

ClickToMoveType Enumeration
wManager.Wow.Enums Namespace


NpcInteract Field

ClickToMoveType..::..NpcInteract Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ClickToMoveType NpcInteract
Public Const NpcInteract As ClickToMoveType
public:
literal ClickToMoveType NpcInteract

See Also

ClickToMoveType Enumeration
wManager.Wow.Enums Namespace


ObjInteract Field

ClickToMoveType..::..ObjInteract Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ClickToMoveType ObjInteract
Public Const ObjInteract As ClickToMoveType
public:
literal ClickToMoveType ObjInteract

See Also

ClickToMoveType Enumeration
wManager.Wow.Enums Namespace


Skin Field

ClickToMoveType..::..Skin Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ClickToMoveType Skin
Public Const Skin As ClickToMoveType
public:
literal ClickToMoveType Skin

See Also

ClickToMoveType Enumeration
wManager.Wow.Enums Namespace


StopThrowsException Field

ClickToMoveType..::..StopThrowsException Field

Will throw a UI error. Have not figured out how to avoid it!

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ClickToMoveType StopThrowsException
Public Const StopThrowsException As ClickToMoveType
public:
literal ClickToMoveType StopThrowsException

See Also

ClickToMoveType Enumeration
wManager.Wow.Enums Namespace


_6HU_GARRISON_Blacksmithing_hub Field

ContinentId..::.._6HU_GARRISON_Blacksmithing_hub Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId _6HU_GARRISON_Blacksmithing_hub
Public Const _6HU_GARRISON_Blacksmithing_hub As ContinentId
public:
literal ContinentId _6HU_GARRISON_Blacksmithing_hub

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


AbyssalMaw Field

ContinentId..::..AbyssalMaw Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId AbyssalMaw
Public Const AbyssalMaw As ContinentId
public:
literal ContinentId AbyssalMaw

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


AbyssalMaw_Interior Field

ContinentId..::..AbyssalMaw_Interior Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId AbyssalMaw_Interior
Public Const AbyssalMaw_Interior As ContinentId
public:
literal ContinentId AbyssalMaw_Interior

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


AhnQiraj Field

ContinentId..::..AhnQiraj Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId AhnQiraj
Public Const AhnQiraj As ContinentId
public:
literal ContinentId AhnQiraj

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


AhnQirajTemple Field

ContinentId..::..AhnQirajTemple Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId AhnQirajTemple
Public Const AhnQirajTemple As ContinentId
public:
literal ContinentId AhnQirajTemple

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


AhnQirajTerrace Field

ContinentId..::..AhnQirajTerrace Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId AhnQirajTerrace
Public Const AhnQirajTerrace As ContinentId
public:
literal ContinentId AhnQirajTerrace

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


ALittlePatienceScenario Field

ContinentId..::..ALittlePatienceScenario Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId ALittlePatienceScenario
Public Const ALittlePatienceScenario As ContinentId
public:
literal ContinentId ALittlePatienceScenario

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


alliance_garrison_alchemy Field

ContinentId..::..alliance_garrison_alchemy Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId alliance_garrison_alchemy
Public Const alliance_garrison_alchemy As ContinentId
public:
literal ContinentId alliance_garrison_alchemy

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


alliance_garrison_alchemy_rank2 Field

ContinentId..::..alliance_garrison_alchemy_rank2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId alliance_garrison_alchemy_rank2
Public Const alliance_garrison_alchemy_rank2 As ContinentId
public:
literal ContinentId alliance_garrison_alchemy_rank2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


alliance_garrison_alchemy_rank3 Field

ContinentId..::..alliance_garrison_alchemy_rank3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId alliance_garrison_alchemy_rank3
Public Const alliance_garrison_alchemy_rank3 As ContinentId
public:
literal ContinentId alliance_garrison_alchemy_rank3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


alliance_garrison_enchanting Field

ContinentId..::..alliance_garrison_enchanting Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId alliance_garrison_enchanting
Public Const alliance_garrison_enchanting As ContinentId
public:
literal ContinentId alliance_garrison_enchanting

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


alliance_garrison_herb_garden1 Field

ContinentId..::..alliance_garrison_herb_garden1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId alliance_garrison_herb_garden1
Public Const alliance_garrison_herb_garden1 As ContinentId
public:
literal ContinentId alliance_garrison_herb_garden1

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


alliance_garrison_inn1 Field

ContinentId..::..alliance_garrison_inn1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId alliance_garrison_inn1
Public Const alliance_garrison_inn1 As ContinentId
public:
literal ContinentId alliance_garrison_inn1

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


alliance_garrison_magetower1 Field

ContinentId..::..alliance_garrison_magetower1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId alliance_garrison_magetower1
Public Const alliance_garrison_magetower1 As ContinentId
public:
literal ContinentId alliance_garrison_magetower1

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


AllianceBaseBeachScenario Field

ContinentId..::..AllianceBaseBeachScenario Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId AllianceBaseBeachScenario
Public Const AllianceBaseBeachScenario As ContinentId
public:
literal ContinentId AllianceBaseBeachScenario

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


AllianceBeachDailyArea Field

ContinentId..::..AllianceBeachDailyArea Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId AllianceBeachDailyArea
Public Const AllianceBeachDailyArea As ContinentId
public:
literal ContinentId AllianceBeachDailyArea

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


AllianceHubMoguIslandProgressionScenario Field

ContinentId..::..AllianceHubMoguIslandProgressionScenario Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId AllianceHubMoguIslandProgressionScenario
Public Const AllianceHubMoguIslandProgressionScenario As ContinentId
public:
literal ContinentId AllianceHubMoguIslandProgressionScenario

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


AlliancePVPBarracks Field

ContinentId..::..AlliancePVPBarracks Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId AlliancePVPBarracks
Public Const AlliancePVPBarracks As ContinentId
public:
literal ContinentId AlliancePVPBarracks

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


AncientMoguCryptScenario Field

ContinentId..::..AncientMoguCryptScenario Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId AncientMoguCryptScenario
Public Const AncientMoguCryptScenario As ContinentId
public:
literal ContinentId AncientMoguCryptScenario

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


AncientMoguCyptDestroyedScenario Field

ContinentId..::..AncientMoguCyptDestroyedScenario Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId AncientMoguCyptDestroyedScenario
Public Const AncientMoguCyptDestroyedScenario As ContinentId
public:
literal ContinentId AncientMoguCyptDestroyedScenario

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


ArakkoaDungeon Field

ContinentId..::..ArakkoaDungeon Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId ArakkoaDungeon
Public Const ArakkoaDungeon As ContinentId
public:
literal ContinentId ArakkoaDungeon

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


ArgentTournamentDungeon Field

ContinentId..::..ArgentTournamentDungeon Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId ArgentTournamentDungeon
Public Const ArgentTournamentDungeon As ContinentId
public:
literal ContinentId ArgentTournamentDungeon

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


ArgentTournamentRaid Field

ContinentId..::..ArgentTournamentRaid Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId ArgentTournamentRaid
Public Const ArgentTournamentRaid As ContinentId
public:
literal ContinentId ArgentTournamentRaid

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Ashran Field

ContinentId..::..Ashran Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Ashran
Public Const Ashran As ContinentId
public:
literal ContinentId Ashran

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


AuchindounDemon Field

ContinentId..::..AuchindounDemon Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId AuchindounDemon
Public Const AuchindounDemon As ContinentId
public:
literal ContinentId AuchindounDemon

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


AuchindounDraenei Field

ContinentId..::..AuchindounDraenei Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId AuchindounDraenei
Public Const AuchindounDraenei As ContinentId
public:
literal ContinentId AuchindounDraenei

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


AuchindounEthereal Field

ContinentId..::..AuchindounEthereal Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId AuchindounEthereal
Public Const AuchindounEthereal As ContinentId
public:
literal ContinentId AuchindounEthereal

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


AuchindounQuest Field

ContinentId..::..AuchindounQuest Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId AuchindounQuest
Public Const AuchindounQuest As ContinentId
public:
literal ContinentId AuchindounQuest

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


AuchindounShadow Field

ContinentId..::..AuchindounShadow Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId AuchindounShadow
Public Const AuchindounShadow As ContinentId
public:
literal ContinentId AuchindounShadow

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Azeroth Field

ContinentId..::..Azeroth Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Azeroth
Public Const Azeroth As ContinentId
public:
literal ContinentId Azeroth

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Azjol_LowerCity Field

ContinentId..::..Azjol_LowerCity Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Azjol_LowerCity
Public Const Azjol_LowerCity As ContinentId
public:
literal ContinentId Azjol_LowerCity

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Azjol_Uppercity Field

ContinentId..::..Azjol_Uppercity Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Azjol_Uppercity
Public Const Azjol_Uppercity As ContinentId
public:
literal ContinentId Azjol_Uppercity

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


BaradinHold Field

ContinentId..::..BaradinHold Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId BaradinHold
Public Const BaradinHold As ContinentId
public:
literal ContinentId BaradinHold

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


BFTAllianceScenario Field

ContinentId..::..BFTAllianceScenario Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId BFTAllianceScenario
Public Const BFTAllianceScenario As ContinentId
public:
literal ContinentId BFTAllianceScenario

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


BFTHordeScenario Field

ContinentId..::..BFTHordeScenario Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId BFTHordeScenario
Public Const BFTHordeScenario As ContinentId
public:
literal ContinentId BFTHordeScenario

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Blackfathom Field

ContinentId..::..Blackfathom Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Blackfathom
Public Const Blackfathom As ContinentId
public:
literal ContinentId Blackfathom

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


BlackOxTempleScenario Field

ContinentId..::..BlackOxTempleScenario Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId BlackOxTempleScenario
Public Const BlackOxTempleScenario As ContinentId
public:
literal ContinentId BlackOxTempleScenario

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


BlackrockDepths Field

ContinentId..::..BlackrockDepths Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId BlackrockDepths
Public Const BlackrockDepths As ContinentId
public:
literal ContinentId BlackrockDepths

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


BlackrockFoundryRaid Field

ContinentId..::..BlackrockFoundryRaid Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId BlackrockFoundryRaid
Public Const BlackrockFoundryRaid As ContinentId
public:
literal ContinentId BlackrockFoundryRaid

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


BlackrockFoundryTrainDepot Field

ContinentId..::..BlackrockFoundryTrainDepot Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId BlackrockFoundryTrainDepot
Public Const BlackrockFoundryTrainDepot As ContinentId
public:
literal ContinentId BlackrockFoundryTrainDepot

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


BlackRockSpire Field

ContinentId..::..BlackRockSpire Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId BlackRockSpire
Public Const BlackRockSpire As ContinentId
public:
literal ContinentId BlackRockSpire

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


BlackRockSpire_4_0 Field

ContinentId..::..BlackRockSpire_4_0 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId BlackRockSpire_4_0
Public Const BlackRockSpire_4_0 As ContinentId
public:
literal ContinentId BlackRockSpire_4_0

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


BlackTemple Field

ContinentId..::..BlackTemple Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId BlackTemple
Public Const BlackTemple As ContinentId
public:
literal ContinentId BlackTemple

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


BlackTempleScenario Field

ContinentId..::..BlackTempleScenario Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId BlackTempleScenario
Public Const BlackTempleScenario As ContinentId
public:
literal ContinentId BlackTempleScenario

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


BlackwingDescent Field

ContinentId..::..BlackwingDescent Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId BlackwingDescent
Public Const BlackwingDescent As ContinentId
public:
literal ContinentId BlackwingDescent

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


BlackwingLair Field

ContinentId..::..BlackwingLair Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId BlackwingLair
Public Const BlackwingLair As ContinentId
public:
literal ContinentId BlackwingLair

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


bladesedgearena Field

ContinentId..::..bladesedgearena Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId bladesedgearena
Public Const bladesedgearena As ContinentId
public:
literal ContinentId bladesedgearena

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


BlastedLands Field

ContinentId..::..BlastedLands Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId BlastedLands
Public Const BlastedLands As ContinentId
public:
literal ContinentId BlastedLands

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


BonetownScenario Field

ContinentId..::..BonetownScenario Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId BonetownScenario
Public Const BonetownScenario As ContinentId
public:
literal ContinentId BonetownScenario

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


BrewmasterScenario01 Field

ContinentId..::..BrewmasterScenario01 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId BrewmasterScenario01
Public Const BrewmasterScenario01 As ContinentId
public:
literal ContinentId BrewmasterScenario01

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


BrewmasterScenario03 Field

ContinentId..::..BrewmasterScenario03 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId BrewmasterScenario03
Public Const BrewmasterScenario03 As ContinentId
public:
literal ContinentId BrewmasterScenario03

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


CataclysmCTF Field

ContinentId..::..CataclysmCTF Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId CataclysmCTF
Public Const CataclysmCTF As ContinentId
public:
literal ContinentId CataclysmCTF

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


CavernsOfTime Field

ContinentId..::..CavernsOfTime Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId CavernsOfTime
Public Const CavernsOfTime As ContinentId
public:
literal ContinentId CavernsOfTime

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


CelestialChallenge Field

ContinentId..::..CelestialChallenge Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId CelestialChallenge
Public Const CelestialChallenge As ContinentId
public:
literal ContinentId CelestialChallenge

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


ChamberOfAspectsBlack Field

ContinentId..::..ChamberOfAspectsBlack Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId ChamberOfAspectsBlack
Public Const ChamberOfAspectsBlack As ContinentId
public:
literal ContinentId ChamberOfAspectsBlack

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


ChamberofAspectsRed Field

ContinentId..::..ChamberofAspectsRed Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId ChamberofAspectsRed
Public Const ChamberofAspectsRed As ContinentId
public:
literal ContinentId ChamberofAspectsRed

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


CircleofBloodScenario Field

ContinentId..::..CircleofBloodScenario Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId CircleofBloodScenario
Public Const CircleofBloodScenario As ContinentId
public:
literal ContinentId CircleofBloodScenario

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


CitySiegeMoguIslandProgressionScenario Field

ContinentId..::..CitySiegeMoguIslandProgressionScenario Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId CitySiegeMoguIslandProgressionScenario
Public Const CitySiegeMoguIslandProgressionScenario As ContinentId
public:
literal ContinentId CitySiegeMoguIslandProgressionScenario

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


CoilfangDraenei Field

ContinentId..::..CoilfangDraenei Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId CoilfangDraenei
Public Const CoilfangDraenei As ContinentId
public:
literal ContinentId CoilfangDraenei

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


CoilfangMarsh Field

ContinentId..::..CoilfangMarsh Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId CoilfangMarsh
Public Const CoilfangMarsh As ContinentId
public:
literal ContinentId CoilfangMarsh

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


CoilfangPumping Field

ContinentId..::..CoilfangPumping Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId CoilfangPumping
Public Const CoilfangPumping As ContinentId
public:
literal ContinentId CoilfangPumping

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


CoilfangRaid Field

ContinentId..::..CoilfangRaid Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId CoilfangRaid
Public Const CoilfangRaid As ContinentId
public:
literal ContinentId CoilfangRaid

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Collin Field

ContinentId..::..Collin Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Collin
Public Const Collin As ContinentId
public:
literal ContinentId Collin

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


COTDragonblight Field

ContinentId..::..COTDragonblight Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId COTDragonblight
Public Const COTDragonblight As ContinentId
public:
literal ContinentId COTDragonblight

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


COTWarOfTheAncients Field

ContinentId..::..COTWarOfTheAncients Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId COTWarOfTheAncients
Public Const COTWarOfTheAncients As ContinentId
public:
literal ContinentId COTWarOfTheAncients

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


CraigTest Field

ContinentId..::..CraigTest Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId CraigTest
Public Const CraigTest As ContinentId
public:
literal ContinentId CraigTest

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


DalaranArena Field

ContinentId..::..DalaranArena Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId DalaranArena
Public Const DalaranArena As ContinentId
public:
literal ContinentId DalaranArena

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


DalaranPrison Field

ContinentId..::..DalaranPrison Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId DalaranPrison
Public Const DalaranPrison As ContinentId
public:
literal ContinentId DalaranPrison

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


DarkHordeScenario Field

ContinentId..::..DarkHordeScenario Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId DarkHordeScenario
Public Const DarkHordeScenario As ContinentId
public:
literal ContinentId DarkHordeScenario

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


DarkmoonCarousel Field

ContinentId..::..DarkmoonCarousel Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId DarkmoonCarousel
Public Const DarkmoonCarousel As ContinentId
public:
literal ContinentId DarkmoonCarousel

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


DarkmoonFaire Field

ContinentId..::..DarkmoonFaire Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId DarkmoonFaire
Public Const DarkmoonFaire As ContinentId
public:
literal ContinentId DarkmoonFaire

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


DeadminesInstance Field

ContinentId..::..DeadminesInstance Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId DeadminesInstance
Public Const DeadminesInstance As ContinentId
public:
literal ContinentId DeadminesInstance

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


DeathKnightStart Field

ContinentId..::..DeathKnightStart Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId DeathKnightStart
Public Const DeathKnightStart As ContinentId
public:
literal ContinentId DeathKnightStart

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


DeathwingBack Field

ContinentId..::..DeathwingBack Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId DeathwingBack
Public Const DeathwingBack As ContinentId
public:
literal ContinentId DeathwingBack

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


DeepholmeDungeon Field

ContinentId..::..DeepholmeDungeon Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId DeepholmeDungeon
Public Const DeepholmeDungeon As ContinentId
public:
literal ContinentId DeepholmeDungeon

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Deephome Field

ContinentId..::..Deephome Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Deephome
Public Const Deephome As ContinentId
public:
literal ContinentId Deephome

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Deephomeceiling Field

ContinentId..::..Deephomeceiling Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Deephomeceiling
Public Const Deephomeceiling As ContinentId
public:
literal ContinentId Deephomeceiling

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


DeeprunTram Field

ContinentId..::..DeeprunTram Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId DeeprunTram
Public Const DeeprunTram As ContinentId
public:
literal ContinentId DeeprunTram

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


DefenseOfKaraborScenario Field

ContinentId..::..DefenseOfKaraborScenario Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId DefenseOfKaraborScenario
Public Const DefenseOfKaraborScenario As ContinentId
public:
literal ContinentId DefenseOfKaraborScenario

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


DefenseOfTheAleHouseBG Field

ContinentId..::..DefenseOfTheAleHouseBG Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId DefenseOfTheAleHouseBG
Public Const DefenseOfTheAleHouseBG As ContinentId
public:
literal ContinentId DefenseOfTheAleHouseBG

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


DesolaceBomb Field

ContinentId..::..DesolaceBomb Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId DesolaceBomb
Public Const DesolaceBomb As ContinentId
public:
literal ContinentId DesolaceBomb

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


development Field

ContinentId..::..development Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId development
Public Const development As ContinentId
public:
literal ContinentId development

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


development_nonweighted Field

ContinentId..::..development_nonweighted Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId development_nonweighted
Public Const development_nonweighted As ContinentId
public:
literal ContinentId development_nonweighted

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


devland3 Field

ContinentId..::..devland3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId devland3
Public Const devland3 As ContinentId
public:
literal ContinentId devland3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


DireMaul Field

ContinentId..::..DireMaul Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId DireMaul
Public Const DireMaul As ContinentId
public:
literal ContinentId DireMaul

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Draenor Field

ContinentId..::..Draenor Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Draenor
Public Const Draenor As ContinentId
public:
literal ContinentId Draenor

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


DraenorAuchindoun Field

ContinentId..::..DraenorAuchindoun Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId DraenorAuchindoun
Public Const DraenorAuchindoun As ContinentId
public:
literal ContinentId DraenorAuchindoun

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


DrakTheronKeep Field

ContinentId..::..DrakTheronKeep Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId DrakTheronKeep
Public Const DrakTheronKeep As ContinentId
public:
literal ContinentId DrakTheronKeep

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


EastTemple Field

ContinentId..::..EastTemple Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId EastTemple
Public Const EastTemple As ContinentId
public:
literal ContinentId EastTemple

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


EdgeofRealityMount Field

ContinentId..::..EdgeofRealityMount Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId EdgeofRealityMount
Public Const EdgeofRealityMount As ContinentId
public:
literal ContinentId EdgeofRealityMount

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


ElevatorSpawnTest Field

ContinentId..::..ElevatorSpawnTest Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId ElevatorSpawnTest
Public Const ElevatorSpawnTest As ContinentId
public:
literal ContinentId ElevatorSpawnTest

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


EmeraldDream Field

ContinentId..::..EmeraldDream Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId EmeraldDream
Public Const EmeraldDream As ContinentId
public:
literal ContinentId EmeraldDream

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Expansion01 Field

ContinentId..::..Expansion01 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Expansion01
Public Const Expansion01 As ContinentId
public:
literal ContinentId Expansion01

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Expansion5QAModelMap Field

ContinentId..::..Expansion5QAModelMap Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Expansion5QAModelMap
Public Const Expansion5QAModelMap As ContinentId
public:
literal ContinentId Expansion5QAModelMap

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


ExteriorTest Field

ContinentId..::..ExteriorTest Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId ExteriorTest
Public Const ExteriorTest As ContinentId
public:
literal ContinentId ExteriorTest

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


EyeoftheStorm2_0 Field

ContinentId..::..EyeoftheStorm2_0 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId EyeoftheStorm2_0
Public Const EyeoftheStorm2_0 As ContinentId
public:
literal ContinentId EyeoftheStorm2_0

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


FinalGateMoguIslandProgressionScenario Field

ContinentId..::..FinalGateMoguIslandProgressionScenario Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId FinalGateMoguIslandProgressionScenario
Public Const FinalGateMoguIslandProgressionScenario As ContinentId
public:
literal ContinentId FinalGateMoguIslandProgressionScenario

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Firelands1 Field

ContinentId..::..Firelands1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Firelands1
Public Const Firelands1 As ContinentId
public:
literal ContinentId Firelands1

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Firelands2 Field

ContinentId..::..Firelands2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Firelands2
Public Const Firelands2 As ContinentId
public:
literal ContinentId Firelands2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


FirelandsDailies Field

ContinentId..::..FirelandsDailies Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId FirelandsDailies
Public Const FirelandsDailies As ContinentId
public:
literal ContinentId FirelandsDailies

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


FrostfireFinaleScenario Field

ContinentId..::..FrostfireFinaleScenario Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId FrostfireFinaleScenario
Public Const FrostfireFinaleScenario As ContinentId
public:
literal ContinentId FrostfireFinaleScenario

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


FWHordeGarrisonLeve2new Field

ContinentId..::..FWHordeGarrisonLeve2new Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId FWHordeGarrisonLeve2new
Public Const FWHordeGarrisonLeve2new As ContinentId
public:
literal ContinentId FWHordeGarrisonLeve2new

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


FWHordeGarrisonLevel1 Field

ContinentId..::..FWHordeGarrisonLevel1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId FWHordeGarrisonLevel1
Public Const FWHordeGarrisonLevel1 As ContinentId
public:
literal ContinentId FWHordeGarrisonLevel1

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


FWHordeGarrisonLevel2 Field

ContinentId..::..FWHordeGarrisonLevel2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId FWHordeGarrisonLevel2
Public Const FWHordeGarrisonLevel2 As ContinentId
public:
literal ContinentId FWHordeGarrisonLevel2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


FWHordeGarrisonLevel3 Field

ContinentId..::..FWHordeGarrisonLevel3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId FWHordeGarrisonLevel3
Public Const FWHordeGarrisonLevel3 As ContinentId
public:
literal ContinentId FWHordeGarrisonLevel3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_armory1 Field

ContinentId..::..garrison_alliance_armory1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_armory1
Public Const garrison_alliance_armory1 As ContinentId
public:
literal ContinentId garrison_alliance_armory1

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_armory2 Field

ContinentId..::..garrison_alliance_armory2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_armory2
Public Const garrison_alliance_armory2 As ContinentId
public:
literal ContinentId garrison_alliance_armory2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_armory3 Field

ContinentId..::..garrison_alliance_armory3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_armory3
Public Const garrison_alliance_armory3 As ContinentId
public:
literal ContinentId garrison_alliance_armory3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_barn Field

ContinentId..::..garrison_alliance_barn Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_barn
Public Const garrison_alliance_barn As ContinentId
public:
literal ContinentId garrison_alliance_barn

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_barn2 Field

ContinentId..::..garrison_alliance_barn2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_barn2
Public Const garrison_alliance_barn2 As ContinentId
public:
literal ContinentId garrison_alliance_barn2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_barn3 Field

ContinentId..::..garrison_alliance_barn3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_barn3
Public Const garrison_alliance_barn3 As ContinentId
public:
literal ContinentId garrison_alliance_barn3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_barracks1 Field

ContinentId..::..garrison_alliance_barracks1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_barracks1
Public Const garrison_alliance_barracks1 As ContinentId
public:
literal ContinentId garrison_alliance_barracks1

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_barracks2 Field

ContinentId..::..garrison_alliance_barracks2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_barracks2
Public Const garrison_alliance_barracks2 As ContinentId
public:
literal ContinentId garrison_alliance_barracks2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_barracks3 Field

ContinentId..::..garrison_alliance_barracks3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_barracks3
Public Const garrison_alliance_barracks3 As ContinentId
public:
literal ContinentId garrison_alliance_barracks3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_blacksmith1 Field

ContinentId..::..garrison_alliance_blacksmith1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_blacksmith1
Public Const garrison_alliance_blacksmith1 As ContinentId
public:
literal ContinentId garrison_alliance_blacksmith1

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_blacksmith2 Field

ContinentId..::..garrison_alliance_blacksmith2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_blacksmith2
Public Const garrison_alliance_blacksmith2 As ContinentId
public:
literal ContinentId garrison_alliance_blacksmith2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_enchanting Field

ContinentId..::..garrison_alliance_enchanting Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_enchanting
Public Const garrison_alliance_enchanting As ContinentId
public:
literal ContinentId garrison_alliance_enchanting

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_enchanting2 Field

ContinentId..::..garrison_alliance_enchanting2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_enchanting2
Public Const garrison_alliance_enchanting2 As ContinentId
public:
literal ContinentId garrison_alliance_enchanting2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_engineering Field

ContinentId..::..garrison_alliance_engineering Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_engineering
Public Const garrison_alliance_engineering As ContinentId
public:
literal ContinentId garrison_alliance_engineering

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_engineering1 Field

ContinentId..::..garrison_alliance_engineering1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_engineering1
Public Const garrison_alliance_engineering1 As ContinentId
public:
literal ContinentId garrison_alliance_engineering1

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_engineering2 Field

ContinentId..::..garrison_alliance_engineering2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_engineering2
Public Const garrison_alliance_engineering2 As ContinentId
public:
literal ContinentId garrison_alliance_engineering2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_farmhouse Field

ContinentId..::..garrison_alliance_farmhouse Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_farmhouse
Public Const garrison_alliance_farmhouse As ContinentId
public:
literal ContinentId garrison_alliance_farmhouse

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_fishing1 Field

ContinentId..::..garrison_alliance_fishing1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_fishing1
Public Const garrison_alliance_fishing1 As ContinentId
public:
literal ContinentId garrison_alliance_fishing1

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_fishing2 Field

ContinentId..::..garrison_alliance_fishing2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_fishing2
Public Const garrison_alliance_fishing2 As ContinentId
public:
literal ContinentId garrison_alliance_fishing2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_fishing3 Field

ContinentId..::..garrison_alliance_fishing3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_fishing3
Public Const garrison_alliance_fishing3 As ContinentId
public:
literal ContinentId garrison_alliance_fishing3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_infirmary1 Field

ContinentId..::..garrison_alliance_infirmary1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_infirmary1
Public Const garrison_alliance_infirmary1 As ContinentId
public:
literal ContinentId garrison_alliance_infirmary1

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_infirmary2 Field

ContinentId..::..garrison_alliance_infirmary2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_infirmary2
Public Const garrison_alliance_infirmary2 As ContinentId
public:
literal ContinentId garrison_alliance_infirmary2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_infirmary3 Field

ContinentId..::..garrison_alliance_infirmary3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_infirmary3
Public Const garrison_alliance_infirmary3 As ContinentId
public:
literal ContinentId garrison_alliance_infirmary3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_inn_1 Field

ContinentId..::..garrison_alliance_inn_1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_inn_1
Public Const garrison_alliance_inn_1 As ContinentId
public:
literal ContinentId garrison_alliance_inn_1

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_inn_2 Field

ContinentId..::..garrison_alliance_inn_2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_inn_2
Public Const garrison_alliance_inn_2 As ContinentId
public:
literal ContinentId garrison_alliance_inn_2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_inn_3 Field

ContinentId..::..garrison_alliance_inn_3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_inn_3
Public Const garrison_alliance_inn_3 As ContinentId
public:
literal ContinentId garrison_alliance_inn_3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_inscription Field

ContinentId..::..garrison_alliance_inscription Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_inscription
Public Const garrison_alliance_inscription As ContinentId
public:
literal ContinentId garrison_alliance_inscription

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_inscription2 Field

ContinentId..::..garrison_alliance_inscription2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_inscription2
Public Const garrison_alliance_inscription2 As ContinentId
public:
literal ContinentId garrison_alliance_inscription2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_inscription3 Field

ContinentId..::..garrison_alliance_inscription3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_inscription3
Public Const garrison_alliance_inscription3 As ContinentId
public:
literal ContinentId garrison_alliance_inscription3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_jewelcrafting Field

ContinentId..::..garrison_alliance_jewelcrafting Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_jewelcrafting
Public Const garrison_alliance_jewelcrafting As ContinentId
public:
literal ContinentId garrison_alliance_jewelcrafting

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_jewelcrafting2 Field

ContinentId..::..garrison_alliance_jewelcrafting2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_jewelcrafting2
Public Const garrison_alliance_jewelcrafting2 As ContinentId
public:
literal ContinentId garrison_alliance_jewelcrafting2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_jewelcrafting3 Field

ContinentId..::..garrison_alliance_jewelcrafting3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_jewelcrafting3
Public Const garrison_alliance_jewelcrafting3 As ContinentId
public:
literal ContinentId garrison_alliance_jewelcrafting3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Garrison_Alliance_Large_Construction Field

ContinentId..::..Garrison_Alliance_Large_Construction Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Garrison_Alliance_Large_Construction
Public Const Garrison_Alliance_Large_Construction As ContinentId
public:
literal ContinentId Garrison_Alliance_Large_Construction

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_leatherworking Field

ContinentId..::..garrison_alliance_leatherworking Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_leatherworking
Public Const garrison_alliance_leatherworking As ContinentId
public:
literal ContinentId garrison_alliance_leatherworking

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_leatherworking2 Field

ContinentId..::..garrison_alliance_leatherworking2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_leatherworking2
Public Const garrison_alliance_leatherworking2 As ContinentId
public:
literal ContinentId garrison_alliance_leatherworking2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_leatherworking3 Field

ContinentId..::..garrison_alliance_leatherworking3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_leatherworking3
Public Const garrison_alliance_leatherworking3 As ContinentId
public:
literal ContinentId garrison_alliance_leatherworking3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_lumbermill1 Field

ContinentId..::..garrison_alliance_lumbermill1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_lumbermill1
Public Const garrison_alliance_lumbermill1 As ContinentId
public:
literal ContinentId garrison_alliance_lumbermill1

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_lumbermill2 Field

ContinentId..::..garrison_alliance_lumbermill2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_lumbermill2
Public Const garrison_alliance_lumbermill2 As ContinentId
public:
literal ContinentId garrison_alliance_lumbermill2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_lumbermill3 Field

ContinentId..::..garrison_alliance_lumbermill3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_lumbermill3
Public Const garrison_alliance_lumbermill3 As ContinentId
public:
literal ContinentId garrison_alliance_lumbermill3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Garrison_Alliance_Medium_Construction Field

ContinentId..::..Garrison_Alliance_Medium_Construction Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Garrison_Alliance_Medium_Construction
Public Const Garrison_Alliance_Medium_Construction As ContinentId
public:
literal ContinentId Garrison_Alliance_Medium_Construction

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_mine_1 Field

ContinentId..::..garrison_alliance_mine_1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_mine_1
Public Const garrison_alliance_mine_1 As ContinentId
public:
literal ContinentId garrison_alliance_mine_1

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_mine_2 Field

ContinentId..::..garrison_alliance_mine_2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_mine_2
Public Const garrison_alliance_mine_2 As ContinentId
public:
literal ContinentId garrison_alliance_mine_2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_mine_3 Field

ContinentId..::..garrison_alliance_mine_3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_mine_3
Public Const garrison_alliance_mine_3 As ContinentId
public:
literal ContinentId garrison_alliance_mine_3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_pet_stable1 Field

ContinentId..::..garrison_alliance_pet_stable1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_pet_stable1
Public Const garrison_alliance_pet_stable1 As ContinentId
public:
literal ContinentId garrison_alliance_pet_stable1

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_pet_stable2 Field

ContinentId..::..garrison_alliance_pet_stable2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_pet_stable2
Public Const garrison_alliance_pet_stable2 As ContinentId
public:
literal ContinentId garrison_alliance_pet_stable2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_pet_stable3 Field

ContinentId..::..garrison_alliance_pet_stable3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_pet_stable3
Public Const garrison_alliance_pet_stable3 As ContinentId
public:
literal ContinentId garrison_alliance_pet_stable3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_petstabe Field

ContinentId..::..garrison_alliance_petstabe Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_petstabe
Public Const garrison_alliance_petstabe As ContinentId
public:
literal ContinentId garrison_alliance_petstabe

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_petstable1 Field

ContinentId..::..garrison_alliance_petstable1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_petstable1
Public Const garrison_alliance_petstable1 As ContinentId
public:
literal ContinentId garrison_alliance_petstable1

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_petstable2 Field

ContinentId..::..garrison_alliance_petstable2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_petstable2
Public Const garrison_alliance_petstable2 As ContinentId
public:
literal ContinentId garrison_alliance_petstable2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_petstable3 Field

ContinentId..::..garrison_alliance_petstable3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_petstable3
Public Const garrison_alliance_petstable3 As ContinentId
public:
literal ContinentId garrison_alliance_petstable3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_plot_large Field

ContinentId..::..garrison_alliance_plot_large Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_plot_large
Public Const garrison_alliance_plot_large As ContinentId
public:
literal ContinentId garrison_alliance_plot_large

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_plot_medium Field

ContinentId..::..garrison_alliance_plot_medium Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_plot_medium
Public Const garrison_alliance_plot_medium As ContinentId
public:
literal ContinentId garrison_alliance_plot_medium

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_plot_small Field

ContinentId..::..garrison_alliance_plot_small Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_plot_small
Public Const garrison_alliance_plot_small As ContinentId
public:
literal ContinentId garrison_alliance_plot_small

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_salvageyard1 Field

ContinentId..::..garrison_alliance_salvageyard1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_salvageyard1
Public Const garrison_alliance_salvageyard1 As ContinentId
public:
literal ContinentId garrison_alliance_salvageyard1

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_salvageyard2 Field

ContinentId..::..garrison_alliance_salvageyard2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_salvageyard2
Public Const garrison_alliance_salvageyard2 As ContinentId
public:
literal ContinentId garrison_alliance_salvageyard2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_salvageyard3 Field

ContinentId..::..garrison_alliance_salvageyard3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_salvageyard3
Public Const garrison_alliance_salvageyard3 As ContinentId
public:
literal ContinentId garrison_alliance_salvageyard3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Garrison_Alliance_Small_Construction Field

ContinentId..::..Garrison_Alliance_Small_Construction Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Garrison_Alliance_Small_Construction
Public Const Garrison_Alliance_Small_Construction As ContinentId
public:
literal ContinentId Garrison_Alliance_Small_Construction

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_stable_1 Field

ContinentId..::..garrison_alliance_stable_1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_stable_1
Public Const garrison_alliance_stable_1 As ContinentId
public:
literal ContinentId garrison_alliance_stable_1

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_stable_2 Field

ContinentId..::..garrison_alliance_stable_2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_stable_2
Public Const garrison_alliance_stable_2 As ContinentId
public:
literal ContinentId garrison_alliance_stable_2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_stable_3 Field

ContinentId..::..garrison_alliance_stable_3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_stable_3
Public Const garrison_alliance_stable_3 As ContinentId
public:
literal ContinentId garrison_alliance_stable_3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_storehouse1 Field

ContinentId..::..garrison_alliance_storehouse1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_storehouse1
Public Const garrison_alliance_storehouse1 As ContinentId
public:
literal ContinentId garrison_alliance_storehouse1

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_storehouse2 Field

ContinentId..::..garrison_alliance_storehouse2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_storehouse2
Public Const garrison_alliance_storehouse2 As ContinentId
public:
literal ContinentId garrison_alliance_storehouse2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_storehouse3 Field

ContinentId..::..garrison_alliance_storehouse3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_storehouse3
Public Const garrison_alliance_storehouse3 As ContinentId
public:
literal ContinentId garrison_alliance_storehouse3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_tailoring Field

ContinentId..::..garrison_alliance_tailoring Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_tailoring
Public Const garrison_alliance_tailoring As ContinentId
public:
literal ContinentId garrison_alliance_tailoring

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_tailoring1 Field

ContinentId..::..garrison_alliance_tailoring1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_tailoring1
Public Const garrison_alliance_tailoring1 As ContinentId
public:
literal ContinentId garrison_alliance_tailoring1

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_tailoring2 Field

ContinentId..::..garrison_alliance_tailoring2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_tailoring2
Public Const garrison_alliance_tailoring2 As ContinentId
public:
literal ContinentId garrison_alliance_tailoring2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_trading_post1 Field

ContinentId..::..garrison_alliance_trading_post1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_trading_post1
Public Const garrison_alliance_trading_post1 As ContinentId
public:
literal ContinentId garrison_alliance_trading_post1

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_trading_post2 Field

ContinentId..::..garrison_alliance_trading_post2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_trading_post2
Public Const garrison_alliance_trading_post2 As ContinentId
public:
literal ContinentId garrison_alliance_trading_post2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_trading_post3 Field

ContinentId..::..garrison_alliance_trading_post3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_trading_post3
Public Const garrison_alliance_trading_post3 As ContinentId
public:
literal ContinentId garrison_alliance_trading_post3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_workshop1 Field

ContinentId..::..garrison_alliance_workshop1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_workshop1
Public Const garrison_alliance_workshop1 As ContinentId
public:
literal ContinentId garrison_alliance_workshop1

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_workshop2 Field

ContinentId..::..garrison_alliance_workshop2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_workshop2
Public Const garrison_alliance_workshop2 As ContinentId
public:
literal ContinentId garrison_alliance_workshop2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_alliance_workshop3 Field

ContinentId..::..garrison_alliance_workshop3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_alliance_workshop3
Public Const garrison_alliance_workshop3 As ContinentId
public:
literal ContinentId garrison_alliance_workshop3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_alchemy1 Field

ContinentId..::..garrison_horde_alchemy1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_alchemy1
Public Const garrison_horde_alchemy1 As ContinentId
public:
literal ContinentId garrison_horde_alchemy1

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_alchemy2 Field

ContinentId..::..garrison_horde_alchemy2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_alchemy2
Public Const garrison_horde_alchemy2 As ContinentId
public:
literal ContinentId garrison_horde_alchemy2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_alchemy3 Field

ContinentId..::..garrison_horde_alchemy3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_alchemy3
Public Const garrison_horde_alchemy3 As ContinentId
public:
literal ContinentId garrison_horde_alchemy3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_armory1 Field

ContinentId..::..garrison_horde_armory1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_armory1
Public Const garrison_horde_armory1 As ContinentId
public:
literal ContinentId garrison_horde_armory1

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_armory2 Field

ContinentId..::..garrison_horde_armory2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_armory2
Public Const garrison_horde_armory2 As ContinentId
public:
literal ContinentId garrison_horde_armory2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_armory3 Field

ContinentId..::..garrison_horde_armory3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_armory3
Public Const garrison_horde_armory3 As ContinentId
public:
literal ContinentId garrison_horde_armory3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_barn1 Field

ContinentId..::..garrison_horde_barn1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_barn1
Public Const garrison_horde_barn1 As ContinentId
public:
literal ContinentId garrison_horde_barn1

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_barn2 Field

ContinentId..::..garrison_horde_barn2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_barn2
Public Const garrison_horde_barn2 As ContinentId
public:
literal ContinentId garrison_horde_barn2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_barn3 Field

ContinentId..::..garrison_horde_barn3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_barn3
Public Const garrison_horde_barn3 As ContinentId
public:
literal ContinentId garrison_horde_barn3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_barracks1 Field

ContinentId..::..garrison_horde_barracks1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_barracks1
Public Const garrison_horde_barracks1 As ContinentId
public:
literal ContinentId garrison_horde_barracks1

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_barracks2 Field

ContinentId..::..garrison_horde_barracks2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_barracks2
Public Const garrison_horde_barracks2 As ContinentId
public:
literal ContinentId garrison_horde_barracks2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_barracks3 Field

ContinentId..::..garrison_horde_barracks3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_barracks3
Public Const garrison_horde_barracks3 As ContinentId
public:
literal ContinentId garrison_horde_barracks3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_blacksmith1 Field

ContinentId..::..garrison_horde_blacksmith1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_blacksmith1
Public Const garrison_horde_blacksmith1 As ContinentId
public:
literal ContinentId garrison_horde_blacksmith1

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_blacksmith2 Field

ContinentId..::..garrison_horde_blacksmith2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_blacksmith2
Public Const garrison_horde_blacksmith2 As ContinentId
public:
literal ContinentId garrison_horde_blacksmith2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_blacksmith3 Field

ContinentId..::..garrison_horde_blacksmith3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_blacksmith3
Public Const garrison_horde_blacksmith3 As ContinentId
public:
literal ContinentId garrison_horde_blacksmith3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_enchanting1 Field

ContinentId..::..garrison_horde_enchanting1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_enchanting1
Public Const garrison_horde_enchanting1 As ContinentId
public:
literal ContinentId garrison_horde_enchanting1

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_enchanting2 Field

ContinentId..::..garrison_horde_enchanting2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_enchanting2
Public Const garrison_horde_enchanting2 As ContinentId
public:
literal ContinentId garrison_horde_enchanting2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_enchanting3 Field

ContinentId..::..garrison_horde_enchanting3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_enchanting3
Public Const garrison_horde_enchanting3 As ContinentId
public:
literal ContinentId garrison_horde_enchanting3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_engineering1 Field

ContinentId..::..garrison_horde_engineering1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_engineering1
Public Const garrison_horde_engineering1 As ContinentId
public:
literal ContinentId garrison_horde_engineering1

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_engineering2 Field

ContinentId..::..garrison_horde_engineering2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_engineering2
Public Const garrison_horde_engineering2 As ContinentId
public:
literal ContinentId garrison_horde_engineering2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_engineering3 Field

ContinentId..::..garrison_horde_engineering3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_engineering3
Public Const garrison_horde_engineering3 As ContinentId
public:
literal ContinentId garrison_horde_engineering3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_farm1 Field

ContinentId..::..garrison_horde_farm1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_farm1
Public Const garrison_horde_farm1 As ContinentId
public:
literal ContinentId garrison_horde_farm1

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_fishing1 Field

ContinentId..::..garrison_horde_fishing1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_fishing1
Public Const garrison_horde_fishing1 As ContinentId
public:
literal ContinentId garrison_horde_fishing1

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_fishing2 Field

ContinentId..::..garrison_horde_fishing2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_fishing2
Public Const garrison_horde_fishing2 As ContinentId
public:
literal ContinentId garrison_horde_fishing2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_fishing3 Field

ContinentId..::..garrison_horde_fishing3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_fishing3
Public Const garrison_horde_fishing3 As ContinentId
public:
literal ContinentId garrison_horde_fishing3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_inn1 Field

ContinentId..::..garrison_horde_inn1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_inn1
Public Const garrison_horde_inn1 As ContinentId
public:
literal ContinentId garrison_horde_inn1

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_inn2 Field

ContinentId..::..garrison_horde_inn2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_inn2
Public Const garrison_horde_inn2 As ContinentId
public:
literal ContinentId garrison_horde_inn2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_inn3 Field

ContinentId..::..garrison_horde_inn3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_inn3
Public Const garrison_horde_inn3 As ContinentId
public:
literal ContinentId garrison_horde_inn3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_inscription1 Field

ContinentId..::..garrison_horde_inscription1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_inscription1
Public Const garrison_horde_inscription1 As ContinentId
public:
literal ContinentId garrison_horde_inscription1

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_inscription2 Field

ContinentId..::..garrison_horde_inscription2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_inscription2
Public Const garrison_horde_inscription2 As ContinentId
public:
literal ContinentId garrison_horde_inscription2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_inscription3 Field

ContinentId..::..garrison_horde_inscription3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_inscription3
Public Const garrison_horde_inscription3 As ContinentId
public:
literal ContinentId garrison_horde_inscription3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_jewelcrafting1 Field

ContinentId..::..garrison_horde_jewelcrafting1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_jewelcrafting1
Public Const garrison_horde_jewelcrafting1 As ContinentId
public:
literal ContinentId garrison_horde_jewelcrafting1

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_jewelcrafting2 Field

ContinentId..::..garrison_horde_jewelcrafting2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_jewelcrafting2
Public Const garrison_horde_jewelcrafting2 As ContinentId
public:
literal ContinentId garrison_horde_jewelcrafting2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_jewelcrafting3 Field

ContinentId..::..garrison_horde_jewelcrafting3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_jewelcrafting3
Public Const garrison_horde_jewelcrafting3 As ContinentId
public:
literal ContinentId garrison_horde_jewelcrafting3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Garrison_Horde_Large_Construction Field

ContinentId..::..Garrison_Horde_Large_Construction Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Garrison_Horde_Large_Construction
Public Const Garrison_Horde_Large_Construction As ContinentId
public:
literal ContinentId Garrison_Horde_Large_Construction

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_leatherworking1 Field

ContinentId..::..garrison_horde_leatherworking1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_leatherworking1
Public Const garrison_horde_leatherworking1 As ContinentId
public:
literal ContinentId garrison_horde_leatherworking1

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_leatherworking2 Field

ContinentId..::..garrison_horde_leatherworking2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_leatherworking2
Public Const garrison_horde_leatherworking2 As ContinentId
public:
literal ContinentId garrison_horde_leatherworking2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_leatherworking3 Field

ContinentId..::..garrison_horde_leatherworking3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_leatherworking3
Public Const garrison_horde_leatherworking3 As ContinentId
public:
literal ContinentId garrison_horde_leatherworking3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_lumbermill1 Field

ContinentId..::..garrison_horde_lumbermill1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_lumbermill1
Public Const garrison_horde_lumbermill1 As ContinentId
public:
literal ContinentId garrison_horde_lumbermill1

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_lumbermill2 Field

ContinentId..::..garrison_horde_lumbermill2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_lumbermill2
Public Const garrison_horde_lumbermill2 As ContinentId
public:
literal ContinentId garrison_horde_lumbermill2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_lumbermill3 Field

ContinentId..::..garrison_horde_lumbermill3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_lumbermill3
Public Const garrison_horde_lumbermill3 As ContinentId
public:
literal ContinentId garrison_horde_lumbermill3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_magetower1 Field

ContinentId..::..garrison_horde_magetower1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_magetower1
Public Const garrison_horde_magetower1 As ContinentId
public:
literal ContinentId garrison_horde_magetower1

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_magetower2 Field

ContinentId..::..garrison_horde_magetower2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_magetower2
Public Const garrison_horde_magetower2 As ContinentId
public:
literal ContinentId garrison_horde_magetower2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_magetower3 Field

ContinentId..::..garrison_horde_magetower3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_magetower3
Public Const garrison_horde_magetower3 As ContinentId
public:
literal ContinentId garrison_horde_magetower3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Garrison_Horde_Medium_Construction Field

ContinentId..::..Garrison_Horde_Medium_Construction Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Garrison_Horde_Medium_Construction
Public Const Garrison_Horde_Medium_Construction As ContinentId
public:
literal ContinentId Garrison_Horde_Medium_Construction

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_mine1 Field

ContinentId..::..garrison_horde_mine1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_mine1
Public Const garrison_horde_mine1 As ContinentId
public:
literal ContinentId garrison_horde_mine1

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_mine2 Field

ContinentId..::..garrison_horde_mine2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_mine2
Public Const garrison_horde_mine2 As ContinentId
public:
literal ContinentId garrison_horde_mine2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_mine3 Field

ContinentId..::..garrison_horde_mine3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_mine3
Public Const garrison_horde_mine3 As ContinentId
public:
literal ContinentId garrison_horde_mine3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_petstable2 Field

ContinentId..::..garrison_horde_petstable2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_petstable2
Public Const garrison_horde_petstable2 As ContinentId
public:
literal ContinentId garrison_horde_petstable2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_petstable3 Field

ContinentId..::..garrison_horde_petstable3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_petstable3
Public Const garrison_horde_petstable3 As ContinentId
public:
literal ContinentId garrison_horde_petstable3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_plot_large Field

ContinentId..::..garrison_horde_plot_large Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_plot_large
Public Const garrison_horde_plot_large As ContinentId
public:
literal ContinentId garrison_horde_plot_large

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_plot_medium Field

ContinentId..::..garrison_horde_plot_medium Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_plot_medium
Public Const garrison_horde_plot_medium As ContinentId
public:
literal ContinentId garrison_horde_plot_medium

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_plot_small Field

ContinentId..::..garrison_horde_plot_small Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_plot_small
Public Const garrison_horde_plot_small As ContinentId
public:
literal ContinentId garrison_horde_plot_small

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_salvageyard1 Field

ContinentId..::..garrison_horde_salvageyard1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_salvageyard1
Public Const garrison_horde_salvageyard1 As ContinentId
public:
literal ContinentId garrison_horde_salvageyard1

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_salvageyard2 Field

ContinentId..::..garrison_horde_salvageyard2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_salvageyard2
Public Const garrison_horde_salvageyard2 As ContinentId
public:
literal ContinentId garrison_horde_salvageyard2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_salvageyard3 Field

ContinentId..::..garrison_horde_salvageyard3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_salvageyard3
Public Const garrison_horde_salvageyard3 As ContinentId
public:
literal ContinentId garrison_horde_salvageyard3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Garrison_Horde_Small_Construction Field

ContinentId..::..Garrison_Horde_Small_Construction Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Garrison_Horde_Small_Construction
Public Const Garrison_Horde_Small_Construction As ContinentId
public:
literal ContinentId Garrison_Horde_Small_Construction

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_sparringarena1 Field

ContinentId..::..garrison_horde_sparringarena1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_sparringarena1
Public Const garrison_horde_sparringarena1 As ContinentId
public:
literal ContinentId garrison_horde_sparringarena1

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_sparringarena2 Field

ContinentId..::..garrison_horde_sparringarena2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_sparringarena2
Public Const garrison_horde_sparringarena2 As ContinentId
public:
literal ContinentId garrison_horde_sparringarena2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_sparringarena3 Field

ContinentId..::..garrison_horde_sparringarena3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_sparringarena3
Public Const garrison_horde_sparringarena3 As ContinentId
public:
literal ContinentId garrison_horde_sparringarena3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_stable1 Field

ContinentId..::..garrison_horde_stable1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_stable1
Public Const garrison_horde_stable1 As ContinentId
public:
literal ContinentId garrison_horde_stable1

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_stable2 Field

ContinentId..::..garrison_horde_stable2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_stable2
Public Const garrison_horde_stable2 As ContinentId
public:
literal ContinentId garrison_horde_stable2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_stable3 Field

ContinentId..::..garrison_horde_stable3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_stable3
Public Const garrison_horde_stable3 As ContinentId
public:
literal ContinentId garrison_horde_stable3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_storehouse1 Field

ContinentId..::..garrison_horde_storehouse1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_storehouse1
Public Const garrison_horde_storehouse1 As ContinentId
public:
literal ContinentId garrison_horde_storehouse1

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_storehouse2 Field

ContinentId..::..garrison_horde_storehouse2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_storehouse2
Public Const garrison_horde_storehouse2 As ContinentId
public:
literal ContinentId garrison_horde_storehouse2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_storehouse3 Field

ContinentId..::..garrison_horde_storehouse3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_storehouse3
Public Const garrison_horde_storehouse3 As ContinentId
public:
literal ContinentId garrison_horde_storehouse3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_tailoring1 Field

ContinentId..::..garrison_horde_tailoring1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_tailoring1
Public Const garrison_horde_tailoring1 As ContinentId
public:
literal ContinentId garrison_horde_tailoring1

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_tailoring2 Field

ContinentId..::..garrison_horde_tailoring2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_tailoring2
Public Const garrison_horde_tailoring2 As ContinentId
public:
literal ContinentId garrison_horde_tailoring2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_tailoring3 Field

ContinentId..::..garrison_horde_tailoring3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_tailoring3
Public Const garrison_horde_tailoring3 As ContinentId
public:
literal ContinentId garrison_horde_tailoring3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_tradingpost1 Field

ContinentId..::..garrison_horde_tradingpost1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_tradingpost1
Public Const garrison_horde_tradingpost1 As ContinentId
public:
literal ContinentId garrison_horde_tradingpost1

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_tradingpost2 Field

ContinentId..::..garrison_horde_tradingpost2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_tradingpost2
Public Const garrison_horde_tradingpost2 As ContinentId
public:
literal ContinentId garrison_horde_tradingpost2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_tradingpost3 Field

ContinentId..::..garrison_horde_tradingpost3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_tradingpost3
Public Const garrison_horde_tradingpost3 As ContinentId
public:
literal ContinentId garrison_horde_tradingpost3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_workshop1 Field

ContinentId..::..garrison_horde_workshop1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_workshop1
Public Const garrison_horde_workshop1 As ContinentId
public:
literal ContinentId garrison_horde_workshop1

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_workshop2 Field

ContinentId..::..garrison_horde_workshop2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_workshop2
Public Const garrison_horde_workshop2 As ContinentId
public:
literal ContinentId garrison_horde_workshop2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrison_horde_workshop3 Field

ContinentId..::..garrison_horde_workshop3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrison_horde_workshop3
Public Const garrison_horde_workshop3 As ContinentId
public:
literal ContinentId garrison_horde_workshop3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrisonAllianceMageTower2 Field

ContinentId..::..garrisonAllianceMageTower2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrisonAllianceMageTower2
Public Const garrisonAllianceMageTower2 As ContinentId
public:
literal ContinentId garrisonAllianceMageTower2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


garrisonAllianceMageTower3 Field

ContinentId..::..garrisonAllianceMageTower3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId garrisonAllianceMageTower3
Public Const garrisonAllianceMageTower3 As ContinentId
public:
literal ContinentId garrisonAllianceMageTower3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


GarrisonAllianceShipyard Field

ContinentId..::..GarrisonAllianceShipyard Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId GarrisonAllianceShipyard
Public Const GarrisonAllianceShipyard As ContinentId
public:
literal ContinentId GarrisonAllianceShipyard

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


GarrisonHordeShipyard Field

ContinentId..::..GarrisonHordeShipyard Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId GarrisonHordeShipyard
Public Const GarrisonHordeShipyard As ContinentId
public:
literal ContinentId GarrisonHordeShipyard

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


GarrisonShipyardAllianceDestroyer Field

ContinentId..::..GarrisonShipyardAllianceDestroyer Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId GarrisonShipyardAllianceDestroyer
Public Const GarrisonShipyardAllianceDestroyer As ContinentId
public:
literal ContinentId GarrisonShipyardAllianceDestroyer

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


GarrisonShipyardAllianceSubmarine Field

ContinentId..::..GarrisonShipyardAllianceSubmarine Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId GarrisonShipyardAllianceSubmarine
Public Const GarrisonShipyardAllianceSubmarine As ContinentId
public:
literal ContinentId GarrisonShipyardAllianceSubmarine

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


GarrisonShipyardCarrier Field

ContinentId..::..GarrisonShipyardCarrier Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId GarrisonShipyardCarrier
Public Const GarrisonShipyardCarrier As ContinentId
public:
literal ContinentId GarrisonShipyardCarrier

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


GarrisonShipyardCarrierAlliance Field

ContinentId..::..GarrisonShipyardCarrierAlliance Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId GarrisonShipyardCarrierAlliance
Public Const GarrisonShipyardCarrierAlliance As ContinentId
public:
literal ContinentId GarrisonShipyardCarrierAlliance

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


GarrisonShipyardDreadnaught Field

ContinentId..::..GarrisonShipyardDreadnaught Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId GarrisonShipyardDreadnaught
Public Const GarrisonShipyardDreadnaught As ContinentId
public:
literal ContinentId GarrisonShipyardDreadnaught

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


GarrisonShipyardGalleonHorde Field

ContinentId..::..GarrisonShipyardGalleonHorde Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId GarrisonShipyardGalleonHorde
Public Const GarrisonShipyardGalleonHorde As ContinentId
public:
literal ContinentId GarrisonShipyardGalleonHorde

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


GarrisonShipyardHordeDestroyer Field

ContinentId..::..GarrisonShipyardHordeDestroyer Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId GarrisonShipyardHordeDestroyer
Public Const GarrisonShipyardHordeDestroyer As ContinentId
public:
literal ContinentId GarrisonShipyardHordeDestroyer

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


GarrisonShipyardHordeSubmarine Field

ContinentId..::..GarrisonShipyardHordeSubmarine Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId GarrisonShipyardHordeSubmarine
Public Const GarrisonShipyardHordeSubmarine As ContinentId
public:
literal ContinentId GarrisonShipyardHordeSubmarine

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


GarrisonShipyardTransport Field

ContinentId..::..GarrisonShipyardTransport Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId GarrisonShipyardTransport
Public Const GarrisonShipyardTransport As ContinentId
public:
literal ContinentId GarrisonShipyardTransport

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Gilneas Field

ContinentId..::..Gilneas Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Gilneas
Public Const Gilneas As ContinentId
public:
literal ContinentId Gilneas

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Gilneas2 Field

ContinentId..::..Gilneas2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Gilneas2
Public Const Gilneas2 As ContinentId
public:
literal ContinentId Gilneas2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Gilneas_BG_2 Field

ContinentId..::..Gilneas_BG_2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Gilneas_BG_2
Public Const Gilneas_BG_2 As ContinentId
public:
literal ContinentId Gilneas_BG_2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


GilneasPhase1 Field

ContinentId..::..GilneasPhase1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId GilneasPhase1
Public Const GilneasPhase1 As ContinentId
public:
literal ContinentId GilneasPhase1

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


GilneasPhase2 Field

ContinentId..::..GilneasPhase2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId GilneasPhase2
Public Const GilneasPhase2 As ContinentId
public:
literal ContinentId GilneasPhase2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


GnomeragonInstance Field

ContinentId..::..GnomeragonInstance Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId GnomeragonInstance
Public Const GnomeragonInstance As ContinentId
public:
literal ContinentId GnomeragonInstance

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


GoldRushBG Field

ContinentId..::..GoldRushBG Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId GoldRushBG
Public Const GoldRushBG As ContinentId
public:
literal ContinentId GoldRushBG

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


GORAllianceGarrisonLevel1 Field

ContinentId..::..GORAllianceGarrisonLevel1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId GORAllianceGarrisonLevel1
Public Const GORAllianceGarrisonLevel1 As ContinentId
public:
literal ContinentId GORAllianceGarrisonLevel1

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


GORAllianceGarrisonLevel2 Field

ContinentId..::..GORAllianceGarrisonLevel2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId GORAllianceGarrisonLevel2
Public Const GORAllianceGarrisonLevel2 As ContinentId
public:
literal ContinentId GORAllianceGarrisonLevel2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


GORAllianceGarrisonLevel3 Field

ContinentId..::..GORAllianceGarrisonLevel3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId GORAllianceGarrisonLevel3
Public Const GORAllianceGarrisonLevel3 As ContinentId
public:
literal ContinentId GORAllianceGarrisonLevel3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


GorgrondFinaleScenario Field

ContinentId..::..GorgrondFinaleScenario Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId GorgrondFinaleScenario
Public Const GorgrondFinaleScenario As ContinentId
public:
literal ContinentId GorgrondFinaleScenario

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


GorgrondFinaleScenarioMap Field

ContinentId..::..GorgrondFinaleScenarioMap Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId GorgrondFinaleScenarioMap
Public Const GorgrondFinaleScenarioMap As ContinentId
public:
literal ContinentId GorgrondFinaleScenarioMap

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


GorHordeGarrisonLevel0 Field

ContinentId..::..GorHordeGarrisonLevel0 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId GorHordeGarrisonLevel0
Public Const GorHordeGarrisonLevel0 As ContinentId
public:
literal ContinentId GorHordeGarrisonLevel0

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


GORHordeGarrisonLevel3 Field

ContinentId..::..GORHordeGarrisonLevel3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId GORHordeGarrisonLevel3
Public Const GORHordeGarrisonLevel3 As ContinentId
public:
literal ContinentId GORHordeGarrisonLevel3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


GrimBatolDungeon Field

ContinentId..::..GrimBatolDungeon Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId GrimBatolDungeon
Public Const GrimBatolDungeon As ContinentId
public:
literal ContinentId GrimBatolDungeon

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


GrimBatolRaid Field

ContinentId..::..GrimBatolRaid Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId GrimBatolRaid
Public Const GrimBatolRaid As ContinentId
public:
literal ContinentId GrimBatolRaid

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


GrommasharScenario Field

ContinentId..::..GrommasharScenario Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId GrommasharScenario
Public Const GrommasharScenario As ContinentId
public:
literal ContinentId GrommasharScenario

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


GruulsLair Field

ContinentId..::..GruulsLair Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId GruulsLair
Public Const GruulsLair As ContinentId
public:
literal ContinentId GruulsLair

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


GunDrak Field

ContinentId..::..GunDrak Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId GunDrak
Public Const GunDrak As ContinentId
public:
literal ContinentId GunDrak

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


HalfhillScenario Field

ContinentId..::..HalfhillScenario Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId HalfhillScenario
Public Const HalfhillScenario As ContinentId
public:
literal ContinentId HalfhillScenario

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


HallsOfReflection Field

ContinentId..::..HallsOfReflection Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId HallsOfReflection
Public Const HallsOfReflection As ContinentId
public:
literal ContinentId HallsOfReflection

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


HawaiiMainLand Field

ContinentId..::..HawaiiMainLand Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId HawaiiMainLand
Public Const HawaiiMainLand As ContinentId
public:
literal ContinentId HawaiiMainLand

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


HeartOfTheOldGodScenario Field

ContinentId..::..HeartOfTheOldGodScenario Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId HeartOfTheOldGodScenario
Public Const HeartOfTheOldGodScenario As ContinentId
public:
literal ContinentId HeartOfTheOldGodScenario

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


HellfireDemon Field

ContinentId..::..HellfireDemon Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId HellfireDemon
Public Const HellfireDemon As ContinentId
public:
literal ContinentId HellfireDemon

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


HellfireMilitary Field

ContinentId..::..HellfireMilitary Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId HellfireMilitary
Public Const HellfireMilitary As ContinentId
public:
literal ContinentId HellfireMilitary

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


HellfireRaid Field

ContinentId..::..HellfireRaid Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId HellfireRaid
Public Const HellfireRaid As ContinentId
public:
literal ContinentId HellfireRaid

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


HellfireRaid62 Field

ContinentId..::..HellfireRaid62 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId HellfireRaid62
Public Const HellfireRaid62 As ContinentId
public:
literal ContinentId HellfireRaid62

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


HellfireRampart Field

ContinentId..::..HellfireRampart Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId HellfireRampart
Public Const HellfireRampart As ContinentId
public:
literal ContinentId HellfireRampart

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


HighmaulOgreRaid Field

ContinentId..::..HighmaulOgreRaid Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId HighmaulOgreRaid
Public Const HighmaulOgreRaid As ContinentId
public:
literal ContinentId HighmaulOgreRaid

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


HillsbradPast Field

ContinentId..::..HillsbradPast Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId HillsbradPast
Public Const HillsbradPast As ContinentId
public:
literal ContinentId HillsbradPast

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


HordeAmbushScenario Field

ContinentId..::..HordeAmbushScenario Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId HordeAmbushScenario
Public Const HordeAmbushScenario As ContinentId
public:
literal ContinentId HordeAmbushScenario

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


HordeBaseBeachScenario Field

ContinentId..::..HordeBaseBeachScenario Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId HordeBaseBeachScenario
Public Const HordeBaseBeachScenario As ContinentId
public:
literal ContinentId HordeBaseBeachScenario

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


HordeBeachDailyArea Field

ContinentId..::..HordeBeachDailyArea Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId HordeBeachDailyArea
Public Const HordeBeachDailyArea As ContinentId
public:
literal ContinentId HordeBeachDailyArea

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


HordeHubMoguIslandProgressionScenario Field

ContinentId..::..HordeHubMoguIslandProgressionScenario Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId HordeHubMoguIslandProgressionScenario
Public Const HordeHubMoguIslandProgressionScenario As ContinentId
public:
literal ContinentId HordeHubMoguIslandProgressionScenario

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


HordePVPBarracks Field

ContinentId..::..HordePVPBarracks Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId HordePVPBarracks
Public Const HordePVPBarracks As ContinentId
public:
literal ContinentId HordePVPBarracks

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


HyjalPast Field

ContinentId..::..HyjalPast Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId HyjalPast
Public Const HyjalPast As ContinentId
public:
literal ContinentId HyjalPast

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


IcecrownCitadel Field

ContinentId..::..IcecrownCitadel Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId IcecrownCitadel
Public Const IcecrownCitadel As ContinentId
public:
literal ContinentId IcecrownCitadel

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


IcecrownCitadel5Man Field

ContinentId..::..IcecrownCitadel5Man Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId IcecrownCitadel5Man
Public Const IcecrownCitadel5Man As ContinentId
public:
literal ContinentId IcecrownCitadel5Man

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


IsleofConquest Field

ContinentId..::..IsleofConquest Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId IsleofConquest
Public Const IsleofConquest As ContinentId
public:
literal ContinentId IsleofConquest

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


JadeForestAllianceHubPhase Field

ContinentId..::..JadeForestAllianceHubPhase Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId JadeForestAllianceHubPhase
Public Const JadeForestAllianceHubPhase As ContinentId
public:
literal ContinentId JadeForestAllianceHubPhase

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


JadeForestBattlefieldPhase Field

ContinentId..::..JadeForestBattlefieldPhase Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId JadeForestBattlefieldPhase
Public Const JadeForestBattlefieldPhase As ContinentId
public:
literal ContinentId JadeForestBattlefieldPhase

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


JadeForestHordeStartingArea Field

ContinentId..::..JadeForestHordeStartingArea Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId JadeForestHordeStartingArea
Public Const JadeForestHordeStartingArea As ContinentId
public:
literal ContinentId JadeForestHordeStartingArea

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


JainaDalaranScenario Field

ContinentId..::..JainaDalaranScenario Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId JainaDalaranScenario
Public Const JainaDalaranScenario As ContinentId
public:
literal ContinentId JainaDalaranScenario

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Kalimdor Field

ContinentId..::..Kalimdor Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Kalimdor
Public Const Kalimdor As ContinentId
public:
literal ContinentId Kalimdor

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Karazahn Field

ContinentId..::..Karazahn Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Karazahn
Public Const Karazahn As ContinentId
public:
literal ContinentId Karazahn

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


LevelDesignLand_DevOnly Field

ContinentId..::..LevelDesignLand_DevOnly Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId LevelDesignLand_DevOnly
Public Const LevelDesignLand_DevOnly As ContinentId
public:
literal ContinentId LevelDesignLand_DevOnly

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


LightningForgeMoguIslandProgressionScenario Field

ContinentId..::..LightningForgeMoguIslandProgressionScenario Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId LightningForgeMoguIslandProgressionScenario
Public Const LightningForgeMoguIslandProgressionScenario As ContinentId
public:
literal ContinentId LightningForgeMoguIslandProgressionScenario

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


LostIsles Field

ContinentId..::..LostIsles Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId LostIsles
Public Const LostIsles As ContinentId
public:
literal ContinentId LostIsles

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


LostIslesPhase1 Field

ContinentId..::..LostIslesPhase1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId LostIslesPhase1
Public Const LostIslesPhase1 As ContinentId
public:
literal ContinentId LostIslesPhase1

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


LostIslesPhase2 Field

ContinentId..::..LostIslesPhase2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId LostIslesPhase2
Public Const LostIslesPhase2 As ContinentId
public:
literal ContinentId LostIslesPhase2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


MaelstromDeathwingFight Field

ContinentId..::..MaelstromDeathwingFight Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId MaelstromDeathwingFight
Public Const MaelstromDeathwingFight As ContinentId
public:
literal ContinentId MaelstromDeathwingFight

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


MaelstromZone Field

ContinentId..::..MaelstromZone Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId MaelstromZone
Public Const MaelstromZone As ContinentId
public:
literal ContinentId MaelstromZone

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


MantidDungeon Field

ContinentId..::..MantidDungeon Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId MantidDungeon
Public Const MantidDungeon As ContinentId
public:
literal ContinentId MantidDungeon

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


MantidRaid Field

ContinentId..::..MantidRaid Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId MantidRaid
Public Const MantidRaid As ContinentId
public:
literal ContinentId MantidRaid

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Mauradon Field

ContinentId..::..Mauradon Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Mauradon
Public Const Mauradon As ContinentId
public:
literal ContinentId Mauradon

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


MistsCTF3 Field

ContinentId..::..MistsCTF3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId MistsCTF3
Public Const MistsCTF3 As ContinentId
public:
literal ContinentId MistsCTF3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


MoguDungeon Field

ContinentId..::..MoguDungeon Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId MoguDungeon
Public Const MoguDungeon As ContinentId
public:
literal ContinentId MoguDungeon

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


MoguExteriorRaid Field

ContinentId..::..MoguExteriorRaid Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId MoguExteriorRaid
Public Const MoguExteriorRaid As ContinentId
public:
literal ContinentId MoguExteriorRaid

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


MoguInteriorRaid Field

ContinentId..::..MoguInteriorRaid Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId MoguInteriorRaid
Public Const MoguInteriorRaid As ContinentId
public:
literal ContinentId MoguInteriorRaid

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


MoguIslandDailyArea Field

ContinentId..::..MoguIslandDailyArea Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId MoguIslandDailyArea
Public Const MoguIslandDailyArea As ContinentId
public:
literal ContinentId MoguIslandDailyArea

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


MoguIslandEventsAllianceBase Field

ContinentId..::..MoguIslandEventsAllianceBase Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId MoguIslandEventsAllianceBase
Public Const MoguIslandEventsAllianceBase As ContinentId
public:
literal ContinentId MoguIslandEventsAllianceBase

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


MoguIslandEventsHordeBase Field

ContinentId..::..MoguIslandEventsHordeBase Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId MoguIslandEventsHordeBase
Public Const MoguIslandEventsHordeBase As ContinentId
public:
literal ContinentId MoguIslandEventsHordeBase

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


MoguIslandLootRoom Field

ContinentId..::..MoguIslandLootRoom Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId MoguIslandLootRoom
Public Const MoguIslandLootRoom As ContinentId
public:
literal ContinentId MoguIslandLootRoom

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


MoguRuinsScenario Field

ContinentId..::..MoguRuinsScenario Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId MoguRuinsScenario
Public Const MoguRuinsScenario As ContinentId
public:
literal ContinentId MoguRuinsScenario

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


MogushanPalace Field

ContinentId..::..MogushanPalace Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId MogushanPalace
Public Const MogushanPalace As ContinentId
public:
literal ContinentId MogushanPalace

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


MoltenCore Field

ContinentId..::..MoltenCore Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId MoltenCore
Public Const MoltenCore As ContinentId
public:
literal ContinentId MoltenCore

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Monastery Field

ContinentId..::..Monastery Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Monastery
Public Const Monastery As ContinentId
public:
literal ContinentId Monastery

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


MonasteryInstances Field

ContinentId..::..MonasteryInstances Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId MonasteryInstances
Public Const MonasteryInstances As ContinentId
public:
literal ContinentId MonasteryInstances

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


MonkAreaScenario Field

ContinentId..::..MonkAreaScenario Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId MonkAreaScenario
Public Const MonkAreaScenario As ContinentId
public:
literal ContinentId MonkAreaScenario

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


MoonCultistHideout Field

ContinentId..::..MoonCultistHideout Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId MoonCultistHideout
Public Const MoonCultistHideout As ContinentId
public:
literal ContinentId MoonCultistHideout

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


MountHyjalPhase1 Field

ContinentId..::..MountHyjalPhase1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId MountHyjalPhase1
Public Const MountHyjalPhase1 As ContinentId
public:
literal ContinentId MountHyjalPhase1

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


NAGAllianceGarrisonLevel0 Field

ContinentId..::..NAGAllianceGarrisonLevel0 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId NAGAllianceGarrisonLevel0
Public Const NAGAllianceGarrisonLevel0 As ContinentId
public:
literal ContinentId NAGAllianceGarrisonLevel0

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


NAGAllianceGarrisonLevel3 Field

ContinentId..::..NAGAllianceGarrisonLevel3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId NAGAllianceGarrisonLevel3
Public Const NAGAllianceGarrisonLevel3 As ContinentId
public:
literal ContinentId NAGAllianceGarrisonLevel3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


NAGHordeGarrisonLevel0 Field

ContinentId..::..NAGHordeGarrisonLevel0 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId NAGHordeGarrisonLevel0
Public Const NAGHordeGarrisonLevel0 As ContinentId
public:
literal ContinentId NAGHordeGarrisonLevel0

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


NAGHordeGarrisonLevel3 Field

ContinentId..::..NAGHordeGarrisonLevel3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId NAGHordeGarrisonLevel3
Public Const NAGHordeGarrisonLevel3 As ContinentId
public:
literal ContinentId NAGHordeGarrisonLevel3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


nagrand_garrison_camp_stable_2 Field

ContinentId..::..nagrand_garrison_camp_stable_2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId nagrand_garrison_camp_stable_2
Public Const nagrand_garrison_camp_stable_2 As ContinentId
public:
literal ContinentId nagrand_garrison_camp_stable_2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


NavalBattleScenario Field

ContinentId..::..NavalBattleScenario Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId NavalBattleScenario
Public Const NavalBattleScenario As ContinentId
public:
literal ContinentId NavalBattleScenario

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


NetherstormBG Field

ContinentId..::..NetherstormBG Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId NetherstormBG
Public Const NetherstormBG As ContinentId
public:
literal ContinentId NetherstormBG

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


NewRaceStartZone Field

ContinentId..::..NewRaceStartZone Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId NewRaceStartZone
Public Const NewRaceStartZone As ContinentId
public:
literal ContinentId NewRaceStartZone

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


NewScholomance Field

ContinentId..::..NewScholomance Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId NewScholomance
Public Const NewScholomance As ContinentId
public:
literal ContinentId NewScholomance

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Nexus70 Field

ContinentId..::..Nexus70 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Nexus70
Public Const Nexus70 As ContinentId
public:
literal ContinentId Nexus70

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Nexus80 Field

ContinentId..::..Nexus80 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Nexus80
Public Const Nexus80 As ContinentId
public:
literal ContinentId Nexus80

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


NexusLegendary Field

ContinentId..::..NexusLegendary Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId NexusLegendary
Public Const NexusLegendary As ContinentId
public:
literal ContinentId NexusLegendary

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


NexusRaid Field

ContinentId..::..NexusRaid Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId NexusRaid
Public Const NexusRaid As ContinentId
public:
literal ContinentId NexusRaid

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


None Field

ContinentId..::..None Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId None
Public Const None As ContinentId
public:
literal ContinentId None

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Northrend Field

ContinentId..::..Northrend Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Northrend
Public Const Northrend As ContinentId
public:
literal ContinentId Northrend

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


NorthrendBG Field

ContinentId..::..NorthrendBG Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId NorthrendBG
Public Const NorthrendBG As ContinentId
public:
literal ContinentId NorthrendBG

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


OgreCompound Field

ContinentId..::..OgreCompound Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId OgreCompound
Public Const OgreCompound As ContinentId
public:
literal ContinentId OgreCompound

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


OnyxiaLairInstance Field

ContinentId..::..OnyxiaLairInstance Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId OnyxiaLairInstance
Public Const OnyxiaLairInstance As ContinentId
public:
literal ContinentId OnyxiaLairInstance

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


OrgrimmarArena Field

ContinentId..::..OrgrimmarArena Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId OrgrimmarArena
Public Const OrgrimmarArena As ContinentId
public:
literal ContinentId OrgrimmarArena

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


OrgrimmarGunshipPandariaStart Field

ContinentId..::..OrgrimmarGunshipPandariaStart Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId OrgrimmarGunshipPandariaStart
Public Const OrgrimmarGunshipPandariaStart As ContinentId
public:
literal ContinentId OrgrimmarGunshipPandariaStart

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


OrgrimmarInstance Field

ContinentId..::..OrgrimmarInstance Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId OrgrimmarInstance
Public Const OrgrimmarInstance As ContinentId
public:
literal ContinentId OrgrimmarInstance

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


OrgrimmarRaid Field

ContinentId..::..OrgrimmarRaid Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId OrgrimmarRaid
Public Const OrgrimmarRaid As ContinentId
public:
literal ContinentId OrgrimmarRaid

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


outdoorGarrisonArenaAlliance Field

ContinentId..::..outdoorGarrisonArenaAlliance Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId outdoorGarrisonArenaAlliance
Public Const outdoorGarrisonArenaAlliance As ContinentId
public:
literal ContinentId outdoorGarrisonArenaAlliance

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


outdoorGarrisonArenaHorde Field

ContinentId..::..outdoorGarrisonArenaHorde Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId outdoorGarrisonArenaHorde
Public Const outdoorGarrisonArenaHorde As ContinentId
public:
literal ContinentId outdoorGarrisonArenaHorde

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


outdoorGarrisonArmoryAlliance Field

ContinentId..::..outdoorGarrisonArmoryAlliance Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId outdoorGarrisonArmoryAlliance
Public Const outdoorGarrisonArmoryAlliance As ContinentId
public:
literal ContinentId outdoorGarrisonArmoryAlliance

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


outdoorGarrisonArmoryHorde Field

ContinentId..::..outdoorGarrisonArmoryHorde Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId outdoorGarrisonArmoryHorde
Public Const outdoorGarrisonArmoryHorde As ContinentId
public:
literal ContinentId outdoorGarrisonArmoryHorde

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


outdoorGarrisonConstructionPlotAlliance Field

ContinentId..::..outdoorGarrisonConstructionPlotAlliance Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId outdoorGarrisonConstructionPlotAlliance
Public Const outdoorGarrisonConstructionPlotAlliance As ContinentId
public:
literal ContinentId outdoorGarrisonConstructionPlotAlliance

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


outdoorGarrisonConstructionPlotAllianceLarge Field

ContinentId..::..outdoorGarrisonConstructionPlotAllianceLarge Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId outdoorGarrisonConstructionPlotAllianceLarge
Public Const outdoorGarrisonConstructionPlotAllianceLarge As ContinentId
public:
literal ContinentId outdoorGarrisonConstructionPlotAllianceLarge

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


outdoorGarrisonConstructionPlotHorde Field

ContinentId..::..outdoorGarrisonConstructionPlotHorde Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId outdoorGarrisonConstructionPlotHorde
Public Const outdoorGarrisonConstructionPlotHorde As ContinentId
public:
literal ContinentId outdoorGarrisonConstructionPlotHorde

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


outdoorGarrisonConstructionPlotHordeLarge Field

ContinentId..::..outdoorGarrisonConstructionPlotHordeLarge Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId outdoorGarrisonConstructionPlotHordeLarge
Public Const outdoorGarrisonConstructionPlotHordeLarge As ContinentId
public:
literal ContinentId outdoorGarrisonConstructionPlotHordeLarge

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


outdoorGarrisonInnAlliance Field

ContinentId..::..outdoorGarrisonInnAlliance Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId outdoorGarrisonInnAlliance
Public Const outdoorGarrisonInnAlliance As ContinentId
public:
literal ContinentId outdoorGarrisonInnAlliance

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


outdoorGarrisonInnHorde Field

ContinentId..::..outdoorGarrisonInnHorde Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId outdoorGarrisonInnHorde
Public Const outdoorGarrisonInnHorde As ContinentId
public:
literal ContinentId outdoorGarrisonInnHorde

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


outdoorGarrisonLumberMillAlliance Field

ContinentId..::..outdoorGarrisonLumberMillAlliance Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId outdoorGarrisonLumberMillAlliance
Public Const outdoorGarrisonLumberMillAlliance As ContinentId
public:
literal ContinentId outdoorGarrisonLumberMillAlliance

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


outdoorGarrisonLumberMillHorde Field

ContinentId..::..outdoorGarrisonLumberMillHorde Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId outdoorGarrisonLumberMillHorde
Public Const outdoorGarrisonLumberMillHorde As ContinentId
public:
literal ContinentId outdoorGarrisonLumberMillHorde

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


outdoorGarrisonMageTowerAlliance Field

ContinentId..::..outdoorGarrisonMageTowerAlliance Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId outdoorGarrisonMageTowerAlliance
Public Const outdoorGarrisonMageTowerAlliance As ContinentId
public:
literal ContinentId outdoorGarrisonMageTowerAlliance

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


outdoorGarrisonMageTowerHorde Field

ContinentId..::..outdoorGarrisonMageTowerHorde Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId outdoorGarrisonMageTowerHorde
Public Const outdoorGarrisonMageTowerHorde As ContinentId
public:
literal ContinentId outdoorGarrisonMageTowerHorde

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


outdoorGarrisonStablesAlliance Field

ContinentId..::..outdoorGarrisonStablesAlliance Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId outdoorGarrisonStablesAlliance
Public Const outdoorGarrisonStablesAlliance As ContinentId
public:
literal ContinentId outdoorGarrisonStablesAlliance

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


outdoorGarrisonStablesHorde Field

ContinentId..::..outdoorGarrisonStablesHorde Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId outdoorGarrisonStablesHorde
Public Const outdoorGarrisonStablesHorde As ContinentId
public:
literal ContinentId outdoorGarrisonStablesHorde

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


outdoorGarrisonTradingPostAlliance Field

ContinentId..::..outdoorGarrisonTradingPostAlliance Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId outdoorGarrisonTradingPostAlliance
Public Const outdoorGarrisonTradingPostAlliance As ContinentId
public:
literal ContinentId outdoorGarrisonTradingPostAlliance

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


outdoorGarrisonTradingPostHorde Field

ContinentId..::..outdoorGarrisonTradingPostHorde Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId outdoorGarrisonTradingPostHorde
Public Const outdoorGarrisonTradingPostHorde As ContinentId
public:
literal ContinentId outdoorGarrisonTradingPostHorde

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


outdoorGarrisonWorkshopAlliance Field

ContinentId..::..outdoorGarrisonWorkshopAlliance Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId outdoorGarrisonWorkshopAlliance
Public Const outdoorGarrisonWorkshopAlliance As ContinentId
public:
literal ContinentId outdoorGarrisonWorkshopAlliance

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


outdoorGarrisonWorkshopHorde Field

ContinentId..::..outdoorGarrisonWorkshopHorde Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId outdoorGarrisonWorkshopHorde
Public Const outdoorGarrisonWorkshopHorde As ContinentId
public:
literal ContinentId outdoorGarrisonWorkshopHorde

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


PandaFishingVillageScenario Field

ContinentId..::..PandaFishingVillageScenario Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId PandaFishingVillageScenario
Public Const PandaFishingVillageScenario As ContinentId
public:
literal ContinentId PandaFishingVillageScenario

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


PattyMackTestGarrisonBldgMap Field

ContinentId..::..PattyMackTestGarrisonBldgMap Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId PattyMackTestGarrisonBldgMap
Public Const PattyMackTestGarrisonBldgMap As ContinentId
public:
literal ContinentId PattyMackTestGarrisonBldgMap

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


PattyMackTestGarrisonBldgMap2 Field

ContinentId..::..PattyMackTestGarrisonBldgMap2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId PattyMackTestGarrisonBldgMap2
Public Const PattyMackTestGarrisonBldgMap2 As ContinentId
public:
literal ContinentId PattyMackTestGarrisonBldgMap2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


PetBattleJadeForest Field

ContinentId..::..PetBattleJadeForest Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId PetBattleJadeForest
Public Const PetBattleJadeForest As ContinentId
public:
literal ContinentId PetBattleJadeForest

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Propland_DevOnly Field

ContinentId..::..Propland_DevOnly Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Propland_DevOnly
Public Const Propland_DevOnly As ContinentId
public:
literal ContinentId Propland_DevOnly

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


ProvingGrounds Field

ContinentId..::..ProvingGrounds Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId ProvingGrounds
Public Const ProvingGrounds As ContinentId
public:
literal ContinentId ProvingGrounds

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


ProvingGroundsScenario Field

ContinentId..::..ProvingGroundsScenario Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId ProvingGroundsScenario
Public Const ProvingGroundsScenario As ContinentId
public:
literal ContinentId ProvingGroundsScenario

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


PVPLordaeron Field

ContinentId..::..PVPLordaeron Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId PVPLordaeron
Public Const PVPLordaeron As ContinentId
public:
literal ContinentId PVPLordaeron

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


PVPZone01 Field

ContinentId..::..PVPZone01 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId PVPZone01
Public Const PVPZone01 As ContinentId
public:
literal ContinentId PVPZone01

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


PVPZone02 Field

ContinentId..::..PVPZone02 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId PVPZone02
Public Const PVPZone02 As ContinentId
public:
literal ContinentId PVPZone02

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


PVPZone03 Field

ContinentId..::..PVPZone03 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId PVPZone03
Public Const PVPZone03 As ContinentId
public:
literal ContinentId PVPZone03

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


PVPZone04 Field

ContinentId..::..PVPZone04 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId PVPZone04
Public Const PVPZone04 As ContinentId
public:
literal ContinentId PVPZone04

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


PVPZone05 Field

ContinentId..::..PVPZone05 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId PVPZone05
Public Const PVPZone05 As ContinentId
public:
literal ContinentId PVPZone05

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


QA_DVD Field

ContinentId..::..QA_DVD Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId QA_DVD
Public Const QA_DVD As ContinentId
public:
literal ContinentId QA_DVD

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


QuarryofTears Field

ContinentId..::..QuarryofTears Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId QuarryofTears
Public Const QuarryofTears As ContinentId
public:
literal ContinentId QuarryofTears

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


RazorfenDowns Field

ContinentId..::..RazorfenDowns Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId RazorfenDowns
Public Const RazorfenDowns As ContinentId
public:
literal ContinentId RazorfenDowns

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


RazorfenKraulInstance Field

ContinentId..::..RazorfenKraulInstance Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId RazorfenKraulInstance
Public Const RazorfenKraulInstance As ContinentId
public:
literal ContinentId RazorfenKraulInstance

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


RedgridgeOrcBomb Field

ContinentId..::..RedgridgeOrcBomb Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId RedgridgeOrcBomb
Public Const RedgridgeOrcBomb As ContinentId
public:
literal ContinentId RedgridgeOrcBomb

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


RedridgeBridgePhaseOne Field

ContinentId..::..RedridgeBridgePhaseOne Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId RedridgeBridgePhaseOne
Public Const RedridgeBridgePhaseOne As ContinentId
public:
literal ContinentId RedridgeBridgePhaseOne

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


RedridgeBridgePhaseTwo Field

ContinentId..::..RedridgeBridgePhaseTwo Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId RedridgeBridgePhaseTwo
Public Const RedridgeBridgePhaseTwo As ContinentId
public:
literal ContinentId RedridgeBridgePhaseTwo

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


RingOfValorScenario Field

ContinentId..::..RingOfValorScenario Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId RingOfValorScenario
Public Const RingOfValorScenario As ContinentId
public:
literal ContinentId RingOfValorScenario

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


RuinsOfTheramore Field

ContinentId..::..RuinsOfTheramore Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId RuinsOfTheramore
Public Const RuinsOfTheramore As ContinentId
public:
literal ContinentId RuinsOfTheramore

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


ScarletMonasteryCathedralGY Field

ContinentId..::..ScarletMonasteryCathedralGY Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId ScarletMonasteryCathedralGY
Public Const ScarletMonasteryCathedralGY As ContinentId
public:
literal ContinentId ScarletMonasteryCathedralGY

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


ScarletSanctuaryArmoryAndLibrary Field

ContinentId..::..ScarletSanctuaryArmoryAndLibrary Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId ScarletSanctuaryArmoryAndLibrary
Public Const ScarletSanctuaryArmoryAndLibrary As ContinentId
public:
literal ContinentId ScarletSanctuaryArmoryAndLibrary

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


ScenarioAlcazIsland Field

ContinentId..::..ScenarioAlcazIsland Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId ScenarioAlcazIsland
Public Const ScenarioAlcazIsland As ContinentId
public:
literal ContinentId ScenarioAlcazIsland

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


ScenarioBrewmaster04 Field

ContinentId..::..ScenarioBrewmaster04 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId ScenarioBrewmaster04
Public Const ScenarioBrewmaster04 As ContinentId
public:
literal ContinentId ScenarioBrewmaster04

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


ScenarioKlaxxiIsland Field

ContinentId..::..ScenarioKlaxxiIsland Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId ScenarioKlaxxiIsland
Public Const ScenarioKlaxxiIsland As ContinentId
public:
literal ContinentId ScenarioKlaxxiIsland

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


SchoolofNecromancy Field

ContinentId..::..SchoolofNecromancy Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId SchoolofNecromancy
Public Const SchoolofNecromancy As ContinentId
public:
literal ContinentId SchoolofNecromancy

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


ScottTest Field

ContinentId..::..ScottTest Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId ScottTest
Public Const ScottTest As ContinentId
public:
literal ContinentId ScottTest

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


ShadoPanArena Field

ContinentId..::..ShadoPanArena Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId ShadoPanArena
Public Const ShadoPanArena As ContinentId
public:
literal ContinentId ShadoPanArena

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Shadowfang Field

ContinentId..::..Shadowfang Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Shadowfang
Public Const Shadowfang As ContinentId
public:
literal ContinentId Shadowfang

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


ShadowpanHideout Field

ContinentId..::..ShadowpanHideout Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId ShadowpanHideout
Public Const ShadowpanHideout As ContinentId
public:
literal ContinentId ShadowpanHideout

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


ShaperDungeon Field

ContinentId..::..ShaperDungeon Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId ShaperDungeon
Public Const ShaperDungeon As ContinentId
public:
literal ContinentId ShaperDungeon

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


ShimmerRidgeScenario Field

ContinentId..::..ShimmerRidgeScenario Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId ShimmerRidgeScenario
Public Const ShimmerRidgeScenario As ContinentId
public:
literal ContinentId ShimmerRidgeScenario

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


ShipyardMoguIslandProgressionScenario Field

ContinentId..::..ShipyardMoguIslandProgressionScenario Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId ShipyardMoguIslandProgressionScenario
Public Const ShipyardMoguIslandProgressionScenario As ContinentId
public:
literal ContinentId ShipyardMoguIslandProgressionScenario

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


SkywallDungeon Field

ContinentId..::..SkywallDungeon Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId SkywallDungeon
Public Const SkywallDungeon As ContinentId
public:
literal ContinentId SkywallDungeon

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


SkywallRaid Field

ContinentId..::..SkywallRaid Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId SkywallRaid
Public Const SkywallRaid As ContinentId
public:
literal ContinentId SkywallRaid

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


SmallBattlegroundA Field

ContinentId..::..SmallBattlegroundA Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId SmallBattlegroundA
Public Const SmallBattlegroundA As ContinentId
public:
literal ContinentId SmallBattlegroundA

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


SmallBattlegroundB Field

ContinentId..::..SmallBattlegroundB Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId SmallBattlegroundB
Public Const SmallBattlegroundB As ContinentId
public:
literal ContinentId SmallBattlegroundB

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


SmallBattlegroundC Field

ContinentId..::..SmallBattlegroundC Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId SmallBattlegroundC
Public Const SmallBattlegroundC As ContinentId
public:
literal ContinentId SmallBattlegroundC

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


SmallBattlegroundD Field

ContinentId..::..SmallBattlegroundD Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId SmallBattlegroundD
Public Const SmallBattlegroundD As ContinentId
public:
literal ContinentId SmallBattlegroundD

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


SMVAllianceGarrisonLevel1 Field

ContinentId..::..SMVAllianceGarrisonLevel1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId SMVAllianceGarrisonLevel1
Public Const SMVAllianceGarrisonLevel1 As ContinentId
public:
literal ContinentId SMVAllianceGarrisonLevel1

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


SMVAllianceGarrisonLevel2 Field

ContinentId..::..SMVAllianceGarrisonLevel2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId SMVAllianceGarrisonLevel2
Public Const SMVAllianceGarrisonLevel2 As ContinentId
public:
literal ContinentId SMVAllianceGarrisonLevel2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


SMVAllianceGarrisonLevel2new Field

ContinentId..::..SMVAllianceGarrisonLevel2new Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId SMVAllianceGarrisonLevel2new
Public Const SMVAllianceGarrisonLevel2new As ContinentId
public:
literal ContinentId SMVAllianceGarrisonLevel2new

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


SMVAllianceGarrisonLevel3 Field

ContinentId..::..SMVAllianceGarrisonLevel3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId SMVAllianceGarrisonLevel3
Public Const SMVAllianceGarrisonLevel3 As ContinentId
public:
literal ContinentId SMVAllianceGarrisonLevel3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


SOAAllianceGarrison0 Field

ContinentId..::..SOAAllianceGarrison0 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId SOAAllianceGarrison0
Public Const SOAAllianceGarrison0 As ContinentId
public:
literal ContinentId SOAAllianceGarrison0

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


SOAAllianceGarrison3 Field

ContinentId..::..SOAAllianceGarrison3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId SOAAllianceGarrison3
Public Const SOAAllianceGarrison3 As ContinentId
public:
literal ContinentId SOAAllianceGarrison3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


SOAHordeGarrison0 Field

ContinentId..::..SOAHordeGarrison0 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId SOAHordeGarrison0
Public Const SOAHordeGarrison0 As ContinentId
public:
literal ContinentId SOAHordeGarrison0

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


SOAHordeGarrison3 Field

ContinentId..::..SOAHordeGarrison3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId SOAHordeGarrison3
Public Const SOAHordeGarrison3 As ContinentId
public:
literal ContinentId SOAHordeGarrison3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


SparringArenaLevel3Stadium Field

ContinentId..::..SparringArenaLevel3Stadium Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId SparringArenaLevel3Stadium
Public Const SparringArenaLevel3Stadium As ContinentId
public:
literal ContinentId SparringArenaLevel3Stadium

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Stormgarde_Keep Field

ContinentId..::..Stormgarde_Keep Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Stormgarde_Keep
Public Const Stormgarde_Keep As ContinentId
public:
literal ContinentId Stormgarde_Keep

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


StormstoutBrewery Field

ContinentId..::..StormstoutBrewery Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId StormstoutBrewery
Public Const StormstoutBrewery As ContinentId
public:
literal ContinentId StormstoutBrewery

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Stormwind Field

ContinentId..::..Stormwind Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Stormwind
Public Const Stormwind As ContinentId
public:
literal ContinentId Stormwind

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


StormwindGunshipPandariaStartArea Field

ContinentId..::..StormwindGunshipPandariaStartArea Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId StormwindGunshipPandariaStartArea
Public Const StormwindGunshipPandariaStartArea As ContinentId
public:
literal ContinentId StormwindGunshipPandariaStartArea

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


StormwindJail Field

ContinentId..::..StormwindJail Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId StormwindJail
Public Const StormwindJail As ContinentId
public:
literal ContinentId StormwindJail

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


StormwindPrison Field

ContinentId..::..StormwindPrison Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId StormwindPrison
Public Const StormwindPrison As ContinentId
public:
literal ContinentId StormwindPrison

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Stratholme Field

ContinentId..::..Stratholme Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Stratholme
Public Const Stratholme As ContinentId
public:
literal ContinentId Stratholme

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Stratholme_Raid Field

ContinentId..::..Stratholme_Raid Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Stratholme_Raid
Public Const Stratholme_Raid As ContinentId
public:
literal ContinentId Stratholme_Raid

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


StratholmeCOT Field

ContinentId..::..StratholmeCOT Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId StratholmeCOT
Public Const StratholmeCOT As ContinentId
public:
literal ContinentId StratholmeCOT

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


STV_Mine_BG Field

ContinentId..::..STV_Mine_BG Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId STV_Mine_BG
Public Const STV_Mine_BG As ContinentId
public:
literal ContinentId STV_Mine_BG

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


SunkenTemple Field

ContinentId..::..SunkenTemple Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId SunkenTemple
Public Const SunkenTemple As ContinentId
public:
literal ContinentId SunkenTemple

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Sunwell5Man Field

ContinentId..::..Sunwell5Man Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Sunwell5Man
Public Const Sunwell5Man As ContinentId
public:
literal ContinentId Sunwell5Man

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Sunwell5ManFix Field

ContinentId..::..Sunwell5ManFix Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Sunwell5ManFix
Public Const Sunwell5ManFix As ContinentId
public:
literal ContinentId Sunwell5ManFix

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


SunwellPlateau Field

ContinentId..::..SunwellPlateau Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId SunwellPlateau
Public Const SunwellPlateau As ContinentId
public:
literal ContinentId SunwellPlateau

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


TaladorIronHordeFinaleScenario Field

ContinentId..::..TaladorIronHordeFinaleScenario Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId TaladorIronHordeFinaleScenario
Public Const TaladorIronHordeFinaleScenario As ContinentId
public:
literal ContinentId TaladorIronHordeFinaleScenario

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


TALAllianceGarrisonLevel0 Field

ContinentId..::..TALAllianceGarrisonLevel0 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId TALAllianceGarrisonLevel0
Public Const TALAllianceGarrisonLevel0 As ContinentId
public:
literal ContinentId TALAllianceGarrisonLevel0

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


TALAllianceGarrisonLevel3 Field

ContinentId..::..TALAllianceGarrisonLevel3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId TALAllianceGarrisonLevel3
Public Const TALAllianceGarrisonLevel3 As ContinentId
public:
literal ContinentId TALAllianceGarrisonLevel3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


TALHordeGarrisonLevel0 Field

ContinentId..::..TALHordeGarrisonLevel0 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId TALHordeGarrisonLevel0
Public Const TALHordeGarrisonLevel0 As ContinentId
public:
literal ContinentId TALHordeGarrisonLevel0

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


TALHordeGarrisonLevel3 Field

ContinentId..::..TALHordeGarrisonLevel3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId TALHordeGarrisonLevel3
Public Const TALHordeGarrisonLevel3 As ContinentId
public:
literal ContinentId TALHordeGarrisonLevel3

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


TanaanJungle Field

ContinentId..::..TanaanJungle Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId TanaanJungle
Public Const TanaanJungle As ContinentId
public:
literal ContinentId TanaanJungle

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


TanaanJungleIntro Field

ContinentId..::..TanaanJungleIntro Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId TanaanJungleIntro
Public Const TanaanJungleIntro As ContinentId
public:
literal ContinentId TanaanJungleIntro

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


TanaanJungleIntroForgePhase Field

ContinentId..::..TanaanJungleIntroForgePhase Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId TanaanJungleIntroForgePhase
Public Const TanaanJungleIntroForgePhase As ContinentId
public:
literal ContinentId TanaanJungleIntroForgePhase

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


TanaanJungleNoHubsPhase Field

ContinentId..::..TanaanJungleNoHubsPhase Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId TanaanJungleNoHubsPhase
Public Const TanaanJungleNoHubsPhase As ContinentId
public:
literal ContinentId TanaanJungleNoHubsPhase

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


TanaanLegionTest Field

ContinentId..::..TanaanLegionTest Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId TanaanLegionTest
Public Const TanaanLegionTest As ContinentId
public:
literal ContinentId TanaanLegionTest

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


TanarisInstance Field

ContinentId..::..TanarisInstance Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId TanarisInstance
Public Const TanarisInstance As ContinentId
public:
literal ContinentId TanarisInstance

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


TempestKeepArcane Field

ContinentId..::..TempestKeepArcane Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId TempestKeepArcane
Public Const TempestKeepArcane As ContinentId
public:
literal ContinentId TempestKeepArcane

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


TempestKeepAtrium Field

ContinentId..::..TempestKeepAtrium Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId TempestKeepAtrium
Public Const TempestKeepAtrium As ContinentId
public:
literal ContinentId TempestKeepAtrium

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


TempestKeepFactory Field

ContinentId..::..TempestKeepFactory Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId TempestKeepFactory
Public Const TempestKeepFactory As ContinentId
public:
literal ContinentId TempestKeepFactory

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


TempestKeepRaid Field

ContinentId..::..TempestKeepRaid Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId TempestKeepRaid
Public Const TempestKeepRaid As ContinentId
public:
literal ContinentId TempestKeepRaid

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


TerongorsConfrontation Field

ContinentId..::..TerongorsConfrontation Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId TerongorsConfrontation
Public Const TerongorsConfrontation As ContinentId
public:
literal ContinentId TerongorsConfrontation

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


test Field

ContinentId..::..test Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId test
Public Const test As ContinentId
public:
literal ContinentId test

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


TheBattleforGilneas Field

ContinentId..::..TheBattleforGilneas Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId TheBattleforGilneas
Public Const TheBattleforGilneas As ContinentId
public:
literal ContinentId TheBattleforGilneas

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


TheGreatWall Field

ContinentId..::..TheGreatWall Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId TheGreatWall
Public Const TheGreatWall As ContinentId
public:
literal ContinentId TheGreatWall

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


TheHourOfTwilight Field

ContinentId..::..TheHourOfTwilight Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId TheHourOfTwilight
Public Const TheHourOfTwilight As ContinentId
public:
literal ContinentId TheHourOfTwilight

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


ThePurgeOfGrommarScenario Field

ContinentId..::..ThePurgeOfGrommarScenario Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId ThePurgeOfGrommarScenario
Public Const ThePurgeOfGrommarScenario As ContinentId
public:
literal ContinentId ThePurgeOfGrommarScenario

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


TheramoreScenarioPhase Field

ContinentId..::..TheramoreScenarioPhase Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId TheramoreScenarioPhase
Public Const TheramoreScenarioPhase As ContinentId
public:
literal ContinentId TheramoreScenarioPhase

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


ThunderIslandAllianceHub Field

ContinentId..::..ThunderIslandAllianceHub Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId ThunderIslandAllianceHub
Public Const ThunderIslandAllianceHub As ContinentId
public:
literal ContinentId ThunderIslandAllianceHub

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


ThunderIslandRaid Field

ContinentId..::..ThunderIslandRaid Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId ThunderIslandRaid
Public Const ThunderIslandRaid As ContinentId
public:
literal ContinentId ThunderIslandRaid

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


ThunderKingHordeHub Field

ContinentId..::..ThunderKingHordeHub Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId ThunderKingHordeHub
Public Const ThunderKingHordeHub As ContinentId
public:
literal ContinentId ThunderKingHordeHub

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


TolBarad Field

ContinentId..::..TolBarad Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId TolBarad
Public Const TolBarad As ContinentId
public:
literal ContinentId TolBarad

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


TolVirArena Field

ContinentId..::..TolVirArena Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId TolVirArena
Public Const TolVirArena As ContinentId
public:
literal ContinentId TolVirArena

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Transport20808 Field

ContinentId..::..Transport20808 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Transport20808
Public Const Transport20808 As ContinentId
public:
literal ContinentId Transport20808

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Transport164871 Field

ContinentId..::..Transport164871 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Transport164871
Public Const Transport164871 As ContinentId
public:
literal ContinentId Transport164871

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Transport175080 Field

ContinentId..::..Transport175080 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Transport175080
Public Const Transport175080 As ContinentId
public:
literal ContinentId Transport175080

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Transport176231 Field

ContinentId..::..Transport176231 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Transport176231
Public Const Transport176231 As ContinentId
public:
literal ContinentId Transport176231

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Transport176244 Field

ContinentId..::..Transport176244 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Transport176244
Public Const Transport176244 As ContinentId
public:
literal ContinentId Transport176244

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Transport176310 Field

ContinentId..::..Transport176310 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Transport176310
Public Const Transport176310 As ContinentId
public:
literal ContinentId Transport176310

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Transport176495 Field

ContinentId..::..Transport176495 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Transport176495
Public Const Transport176495 As ContinentId
public:
literal ContinentId Transport176495

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Transport177233 Field

ContinentId..::..Transport177233 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Transport177233
Public Const Transport177233 As ContinentId
public:
literal ContinentId Transport177233

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Transport181645 Field

ContinentId..::..Transport181645 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Transport181645
Public Const Transport181645 As ContinentId
public:
literal ContinentId Transport181645

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Transport186238 Field

ContinentId..::..Transport186238 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Transport186238
Public Const Transport186238 As ContinentId
public:
literal ContinentId Transport186238

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Transport187038 Field

ContinentId..::..Transport187038 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Transport187038
Public Const Transport187038 As ContinentId
public:
literal ContinentId Transport187038

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Transport187263 Field

ContinentId..::..Transport187263 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Transport187263
Public Const Transport187263 As ContinentId
public:
literal ContinentId Transport187263

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Transport192241 Field

ContinentId..::..Transport192241 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Transport192241
Public Const Transport192241 As ContinentId
public:
literal ContinentId Transport192241

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Transport192242 Field

ContinentId..::..Transport192242 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Transport192242
Public Const Transport192242 As ContinentId
public:
literal ContinentId Transport192242

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Transport197195 Field

ContinentId..::..Transport197195 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Transport197195
Public Const Transport197195 As ContinentId
public:
literal ContinentId Transport197195

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Transport197347 Field

ContinentId..::..Transport197347 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Transport197347
Public Const Transport197347 As ContinentId
public:
literal ContinentId Transport197347

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Transport197348 Field

ContinentId..::..Transport197348 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Transport197348
Public Const Transport197348 As ContinentId
public:
literal ContinentId Transport197348

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Transport197349 Field

ContinentId..::..Transport197349 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Transport197349
Public Const Transport197349 As ContinentId
public:
literal ContinentId Transport197349

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Transport197349_2 Field

ContinentId..::..Transport197349_2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Transport197349_2
Public Const Transport197349_2 As ContinentId
public:
literal ContinentId Transport197349_2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Transport197350 Field

ContinentId..::..Transport197350 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Transport197350
Public Const Transport197350 As ContinentId
public:
literal ContinentId Transport197350

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Transport200100 Field

ContinentId..::..Transport200100 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Transport200100
Public Const Transport200100 As ContinentId
public:
literal ContinentId Transport200100

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Transport200101 Field

ContinentId..::..Transport200101 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Transport200101
Public Const Transport200101 As ContinentId
public:
literal ContinentId Transport200101

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Transport200102 Field

ContinentId..::..Transport200102 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Transport200102
Public Const Transport200102 As ContinentId
public:
literal ContinentId Transport200102

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Transport200103 Field

ContinentId..::..Transport200103 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Transport200103
Public Const Transport200103 As ContinentId
public:
literal ContinentId Transport200103

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Transport201834 Field

ContinentId..::..Transport201834 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Transport201834
Public Const Transport201834 As ContinentId
public:
literal ContinentId Transport201834

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Transport203729 Field

ContinentId..::..Transport203729 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Transport203729
Public Const Transport203729 As ContinentId
public:
literal ContinentId Transport203729

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Transport203730 Field

ContinentId..::..Transport203730 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Transport203730
Public Const Transport203730 As ContinentId
public:
literal ContinentId Transport203730

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Transport203858 Field

ContinentId..::..Transport203858 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Transport203858
Public Const Transport203858 As ContinentId
public:
literal ContinentId Transport203858

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Transport203859 Field

ContinentId..::..Transport203859 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Transport203859
Public Const Transport203859 As ContinentId
public:
literal ContinentId Transport203859

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Transport203860 Field

ContinentId..::..Transport203860 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Transport203860
Public Const Transport203860 As ContinentId
public:
literal ContinentId Transport203860

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Transport203863 Field

ContinentId..::..Transport203863 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Transport203863
Public Const Transport203863 As ContinentId
public:
literal ContinentId Transport203863

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Transport218599 Field

ContinentId..::..Transport218599 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Transport218599
Public Const Transport218599 As ContinentId
public:
literal ContinentId Transport218599

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Transport218600 Field

ContinentId..::..Transport218600 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Transport218600
Public Const Transport218600 As ContinentId
public:
literal ContinentId Transport218600

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Transport227523 Field

ContinentId..::..Transport227523 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Transport227523
Public Const Transport227523 As ContinentId
public:
literal ContinentId Transport227523

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Transport_203732 Field

ContinentId..::..Transport_203732 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Transport_203732
Public Const Transport_203732 As ContinentId
public:
literal ContinentId Transport_203732

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Transport_203861 Field

ContinentId..::..Transport_203861 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Transport_203861
Public Const Transport_203861 As ContinentId
public:
literal ContinentId Transport_203861

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Transport_203862 Field

ContinentId..::..Transport_203862 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Transport_203862
Public Const Transport_203862 As ContinentId
public:
literal ContinentId Transport_203862

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Transport_2033864 Field

ContinentId..::..Transport_2033864 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Transport_2033864
Public Const Transport_2033864 As ContinentId
public:
literal ContinentId Transport_2033864

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Transport_2033865 Field

ContinentId..::..Transport_2033865 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Transport_2033865
Public Const Transport_2033865 As ContinentId
public:
literal ContinentId Transport_2033865

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Transport_AllianceAirshipBG Field

ContinentId..::..Transport_AllianceAirshipBG Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Transport_AllianceAirshipBG
Public Const Transport_AllianceAirshipBG As ContinentId
public:
literal ContinentId Transport_AllianceAirshipBG

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Transport_HordeAirshipBG Field

ContinentId..::..Transport_HordeAirshipBG Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Transport_HordeAirshipBG
Public Const Transport_HordeAirshipBG As ContinentId
public:
literal ContinentId Transport_HordeAirshipBG

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Transport_Iron_Horde_Gorgrond_Train Field

ContinentId..::..Transport_Iron_Horde_Gorgrond_Train Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Transport_Iron_Horde_Gorgrond_Train
Public Const Transport_Iron_Horde_Gorgrond_Train As ContinentId
public:
literal ContinentId Transport_Iron_Horde_Gorgrond_Train

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Transport_Menethil_Valgarde Field

ContinentId..::..Transport_Menethil_Valgarde Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Transport_Menethil_Valgarde
Public Const Transport_Menethil_Valgarde As ContinentId
public:
literal ContinentId Transport_Menethil_Valgarde

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Transport_Moa_ki_Kamagua Field

ContinentId..::..Transport_Moa_ki_Kamagua Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Transport_Moa_ki_Kamagua
Public Const Transport_Moa_ki_Kamagua As ContinentId
public:
literal ContinentId Transport_Moa_ki_Kamagua

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Transport_Moa_ki_Unu_pe Field

ContinentId..::..Transport_Moa_ki_Unu_pe Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Transport_Moa_ki_Unu_pe
Public Const Transport_Moa_ki_Unu_pe As ContinentId
public:
literal ContinentId Transport_Moa_ki_Unu_pe

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Transport_Orgrimmar_to_Thunderbluff Field

ContinentId..::..Transport_Orgrimmar_to_Thunderbluff Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Transport_Orgrimmar_to_Thunderbluff
Public Const Transport_Orgrimmar_to_Thunderbluff As ContinentId
public:
literal ContinentId Transport_Orgrimmar_to_Thunderbluff

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Transport_Orgrimmar_Warsong_Hold Field

ContinentId..::..Transport_Orgrimmar_Warsong_Hold Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Transport_Orgrimmar_Warsong_Hold
Public Const Transport_Orgrimmar_Warsong_Hold As ContinentId
public:
literal ContinentId Transport_Orgrimmar_Warsong_Hold

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Transport_Siege_of_Orgrimmar_Alliance Field

ContinentId..::..Transport_Siege_of_Orgrimmar_Alliance Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Transport_Siege_of_Orgrimmar_Alliance
Public Const Transport_Siege_of_Orgrimmar_Alliance As ContinentId
public:
literal ContinentId Transport_Siege_of_Orgrimmar_Alliance

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Transport_Siege_of_Orgrimmar_Horde Field

ContinentId..::..Transport_Siege_of_Orgrimmar_Horde Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Transport_Siege_of_Orgrimmar_Horde
Public Const Transport_Siege_of_Orgrimmar_Horde As ContinentId
public:
literal ContinentId Transport_Siege_of_Orgrimmar_Horde

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Transport_Stormwind_Valiance_Keep Field

ContinentId..::..Transport_Stormwind_Valiance_Keep Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Transport_Stormwind_Valiance_Keep
Public Const Transport_Stormwind_Valiance_Keep As ContinentId
public:
literal ContinentId Transport_Stormwind_Valiance_Keep

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Transport_The_Iron_Mountain Field

ContinentId..::..Transport_The_Iron_Mountain Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Transport_The_Iron_Mountain
Public Const Transport_The_Iron_Mountain As ContinentId
public:
literal ContinentId Transport_The_Iron_Mountain

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Transport_Tirisfal__Vengeance_Landing Field

ContinentId..::..Transport_Tirisfal__Vengeance_Landing Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Transport_Tirisfal__Vengeance_Landing
Public Const Transport_Tirisfal__Vengeance_Landing As ContinentId
public:
literal ContinentId Transport_Tirisfal__Vengeance_Landing

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


TrollRaid2 Field

ContinentId..::..TrollRaid2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId TrollRaid2
Public Const TrollRaid2 As ContinentId
public:
literal ContinentId TrollRaid2

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


TurtleShipPhase01 Field

ContinentId..::..TurtleShipPhase01 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId TurtleShipPhase01
Public Const TurtleShipPhase01 As ContinentId
public:
literal ContinentId TurtleShipPhase01

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


TurtleShipPhase02 Field

ContinentId..::..TurtleShipPhase02 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId TurtleShipPhase02
Public Const TurtleShipPhase02 As ContinentId
public:
literal ContinentId TurtleShipPhase02

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


TwilightHighlandsDragonmawPhase Field

ContinentId..::..TwilightHighlandsDragonmawPhase Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId TwilightHighlandsDragonmawPhase
Public Const TwilightHighlandsDragonmawPhase As ContinentId
public:
literal ContinentId TwilightHighlandsDragonmawPhase

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


TwilightHighlandsPhasedEntrance Field

ContinentId..::..TwilightHighlandsPhasedEntrance Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId TwilightHighlandsPhasedEntrance
Public Const TwilightHighlandsPhasedEntrance As ContinentId
public:
literal ContinentId TwilightHighlandsPhasedEntrance

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Uldaman Field

ContinentId..::..Uldaman Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Uldaman
Public Const Uldaman As ContinentId
public:
literal ContinentId Uldaman

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Ulduar70 Field

ContinentId..::..Ulduar70 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Ulduar70
Public Const Ulduar70 As ContinentId
public:
literal ContinentId Ulduar70

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Ulduar80 Field

ContinentId..::..Ulduar80 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Ulduar80
Public Const Ulduar80 As ContinentId
public:
literal ContinentId Ulduar80

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


UlduarRaid Field

ContinentId..::..UlduarRaid Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId UlduarRaid
Public Const UlduarRaid As ContinentId
public:
literal ContinentId UlduarRaid

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Uldum Field

ContinentId..::..Uldum Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Uldum
Public Const Uldum As ContinentId
public:
literal ContinentId Uldum

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


UldumDungeon Field

ContinentId..::..UldumDungeon Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId UldumDungeon
Public Const UldumDungeon As ContinentId
public:
literal ContinentId UldumDungeon

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


UldumPhasedEntrance Field

ContinentId..::..UldumPhasedEntrance Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId UldumPhasedEntrance
Public Const UldumPhasedEntrance As ContinentId
public:
literal ContinentId UldumPhasedEntrance

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


UldumPhaseOasis Field

ContinentId..::..UldumPhaseOasis Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId UldumPhaseOasis
Public Const UldumPhaseOasis As ContinentId
public:
literal ContinentId UldumPhaseOasis

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


UldumPhaseWreckedCamp Field

ContinentId..::..UldumPhaseWreckedCamp Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId UldumPhaseWreckedCamp
Public Const UldumPhaseWreckedCamp As ContinentId
public:
literal ContinentId UldumPhaseWreckedCamp

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


unused Field

ContinentId..::..unused Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId unused
Public Const unused As ContinentId
public:
literal ContinentId unused

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


UpperBlackRockSpire Field

ContinentId..::..UpperBlackRockSpire Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId UpperBlackRockSpire
Public Const UpperBlackRockSpire As ContinentId
public:
literal ContinentId UpperBlackRockSpire

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


UtgardePinnacle Field

ContinentId..::..UtgardePinnacle Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId UtgardePinnacle
Public Const UtgardePinnacle As ContinentId
public:
literal ContinentId UtgardePinnacle

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Valgarde70 Field

ContinentId..::..Valgarde70 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Valgarde70
Public Const Valgarde70 As ContinentId
public:
literal ContinentId Valgarde70

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


ValleyOfPower Field

ContinentId..::..ValleyOfPower Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId ValleyOfPower
Public Const ValleyOfPower As ContinentId
public:
literal ContinentId ValleyOfPower

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


ValleyOfPowerScenario Field

ContinentId..::..ValleyOfPowerScenario Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId ValleyOfPowerScenario
Public Const ValleyOfPowerScenario As ContinentId
public:
literal ContinentId ValleyOfPowerScenario

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


WailingCaverns Field

ContinentId..::..WailingCaverns Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId WailingCaverns
Public Const WailingCaverns As ContinentId
public:
literal ContinentId WailingCaverns

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


WarcraftHeroes Field

ContinentId..::..WarcraftHeroes Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId WarcraftHeroes
Public Const WarcraftHeroes As ContinentId
public:
literal ContinentId WarcraftHeroes

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


WarlockArea Field

ContinentId..::..WarlockArea Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId WarlockArea
Public Const WarlockArea As ContinentId
public:
literal ContinentId WarlockArea

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


WarWharfSmackdown Field

ContinentId..::..WarWharfSmackdown Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId WarWharfSmackdown
Public Const WarWharfSmackdown As ContinentId
public:
literal ContinentId WarWharfSmackdown

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


WintergraspRaid Field

ContinentId..::..WintergraspRaid Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId WintergraspRaid
Public Const WintergraspRaid As ContinentId
public:
literal ContinentId WintergraspRaid

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Zul_gurub Field

ContinentId..::..Zul_gurub Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Zul_gurub
Public Const Zul_gurub As ContinentId
public:
literal ContinentId Zul_gurub

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


Zul_Gurub5Man Field

ContinentId..::..Zul_Gurub5Man Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId Zul_Gurub5Man
Public Const Zul_Gurub5Man As ContinentId
public:
literal ContinentId Zul_Gurub5Man

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


ZulAman Field

ContinentId..::..ZulAman Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ContinentId ZulAman
Public Const ZulAman As ContinentId
public:
literal ContinentId ZulAman

See Also

ContinentId Enumeration
wManager.Wow.Enums Namespace


CanNotBeInteracted Field

GameObjectFlags..::..CanNotBeInteracted Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GameObjectFlags CanNotBeInteracted
Public Const CanNotBeInteracted As GameObjectFlags
public:
literal GameObjectFlags CanNotBeInteracted

See Also

GameObjectFlags Enumeration
wManager.Wow.Enums Namespace


ConditionalInteraction Field

GameObjectFlags..::..ConditionalInteraction Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GameObjectFlags ConditionalInteraction
Public Const ConditionalInteraction As GameObjectFlags
public:
literal GameObjectFlags ConditionalInteraction

See Also

GameObjectFlags Enumeration
wManager.Wow.Enums Namespace


Damaged Field

GameObjectFlags..::..Damaged Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GameObjectFlags Damaged
Public Const Damaged As GameObjectFlags
public:
literal GameObjectFlags Damaged

See Also

GameObjectFlags Enumeration
wManager.Wow.Enums Namespace


Destroyed Field

GameObjectFlags..::..Destroyed Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GameObjectFlags Destroyed
Public Const Destroyed As GameObjectFlags
public:
literal GameObjectFlags Destroyed

See Also

GameObjectFlags Enumeration
wManager.Wow.Enums Namespace


DoesNotDespawn Field

GameObjectFlags..::..DoesNotDespawn Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GameObjectFlags DoesNotDespawn
Public Const DoesNotDespawn As GameObjectFlags
public:
literal GameObjectFlags DoesNotDespawn

See Also

GameObjectFlags Enumeration
wManager.Wow.Enums Namespace


Flag_0x10000 Field

GameObjectFlags..::..Flag_0x10000 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GameObjectFlags Flag_0x10000
Public Const Flag_0x10000 As GameObjectFlags
public:
literal GameObjectFlags Flag_0x10000

See Also

GameObjectFlags Enumeration
wManager.Wow.Enums Namespace


Flag_0x20000 Field

GameObjectFlags..::..Flag_0x20000 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GameObjectFlags Flag_0x20000
Public Const Flag_0x20000 As GameObjectFlags
public:
literal GameObjectFlags Flag_0x20000

See Also

GameObjectFlags Enumeration
wManager.Wow.Enums Namespace


Flag_0x40000 Field

GameObjectFlags..::..Flag_0x40000 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GameObjectFlags Flag_0x40000
Public Const Flag_0x40000 As GameObjectFlags
public:
literal GameObjectFlags Flag_0x40000

See Also

GameObjectFlags Enumeration
wManager.Wow.Enums Namespace


GOFlag_0x80 Field

GameObjectFlags..::..GOFlag_0x80 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GameObjectFlags GOFlag_0x80
Public Const GOFlag_0x80 As GameObjectFlags
public:
literal GameObjectFlags GOFlag_0x80

See Also

GameObjectFlags Enumeration
wManager.Wow.Enums Namespace


GOFlag_0x100 Field

GameObjectFlags..::..GOFlag_0x100 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GameObjectFlags GOFlag_0x100
Public Const GOFlag_0x100 As GameObjectFlags
public:
literal GameObjectFlags GOFlag_0x100

See Also

GameObjectFlags Enumeration
wManager.Wow.Enums Namespace


GOFlag_0x800 Field

GameObjectFlags..::..GOFlag_0x800 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GameObjectFlags GOFlag_0x800
Public Const GOFlag_0x800 As GameObjectFlags
public:
literal GameObjectFlags GOFlag_0x800

See Also

GameObjectFlags Enumeration
wManager.Wow.Enums Namespace


GOFlag_0x1000 Field

GameObjectFlags..::..GOFlag_0x1000 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GameObjectFlags GOFlag_0x1000
Public Const GOFlag_0x1000 As GameObjectFlags
public:
literal GameObjectFlags GOFlag_0x1000

See Also

GameObjectFlags Enumeration
wManager.Wow.Enums Namespace


GOFlag_0x2000 Field

GameObjectFlags..::..GOFlag_0x2000 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GameObjectFlags GOFlag_0x2000
Public Const GOFlag_0x2000 As GameObjectFlags
public:
literal GameObjectFlags GOFlag_0x2000

See Also

GameObjectFlags Enumeration
wManager.Wow.Enums Namespace


GOFlag_0x4000 Field

GameObjectFlags..::..GOFlag_0x4000 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GameObjectFlags GOFlag_0x4000
Public Const GOFlag_0x4000 As GameObjectFlags
public:
literal GameObjectFlags GOFlag_0x4000

See Also

GameObjectFlags Enumeration
wManager.Wow.Enums Namespace


GOFlag_0x8000 Field

GameObjectFlags..::..GOFlag_0x8000 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GameObjectFlags GOFlag_0x8000
Public Const GOFlag_0x8000 As GameObjectFlags
public:
literal GameObjectFlags GOFlag_0x8000

See Also

GameObjectFlags Enumeration
wManager.Wow.Enums Namespace


InUse Field

GameObjectFlags..::..InUse Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GameObjectFlags InUse
Public Const InUse As GameObjectFlags
public:
literal GameObjectFlags InUse

See Also

GameObjectFlags Enumeration
wManager.Wow.Enums Namespace


Locked Field

GameObjectFlags..::..Locked Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GameObjectFlags Locked
Public Const Locked As GameObjectFlags
public:
literal GameObjectFlags Locked

See Also

GameObjectFlags Enumeration
wManager.Wow.Enums Namespace


Transport Field

GameObjectFlags..::..Transport Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GameObjectFlags Transport
Public Const Transport As GameObjectFlags
public:
literal GameObjectFlags Transport

See Also

GameObjectFlags Enumeration
wManager.Wow.Enums Namespace


Triggered Field

GameObjectFlags..::..Triggered Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GameObjectFlags Triggered
Public Const Triggered As GameObjectFlags
public:
literal GameObjectFlags Triggered

See Also

GameObjectFlags Enumeration
wManager.Wow.Enums Namespace


banker Field

GossipOptionsType..::..banker Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GossipOptionsType banker
Public Const banker As GossipOptionsType
public:
literal GossipOptionsType banker

See Also

GossipOptionsType Enumeration
wManager.Wow.Enums Namespace


battlemaster Field

GossipOptionsType..::..battlemaster Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GossipOptionsType battlemaster
Public Const battlemaster As GossipOptionsType
public:
literal GossipOptionsType battlemaster

See Also

GossipOptionsType Enumeration
wManager.Wow.Enums Namespace


binder Field

GossipOptionsType..::..binder Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GossipOptionsType binder
Public Const binder As GossipOptionsType
public:
literal GossipOptionsType binder

See Also

GossipOptionsType Enumeration
wManager.Wow.Enums Namespace


gossip Field

GossipOptionsType..::..gossip Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GossipOptionsType gossip
Public Const gossip As GossipOptionsType
public:
literal GossipOptionsType gossip

See Also

GossipOptionsType Enumeration
wManager.Wow.Enums Namespace


healer Field

GossipOptionsType..::..healer Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GossipOptionsType healer
Public Const healer As GossipOptionsType
public:
literal GossipOptionsType healer

See Also

GossipOptionsType Enumeration
wManager.Wow.Enums Namespace


petition Field

GossipOptionsType..::..petition Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GossipOptionsType petition
Public Const petition As GossipOptionsType
public:
literal GossipOptionsType petition

See Also

GossipOptionsType Enumeration
wManager.Wow.Enums Namespace


tabard Field

GossipOptionsType..::..tabard Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GossipOptionsType tabard
Public Const tabard As GossipOptionsType
public:
literal GossipOptionsType tabard

See Also

GossipOptionsType Enumeration
wManager.Wow.Enums Namespace


taxi Field

GossipOptionsType..::..taxi Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GossipOptionsType taxi
Public Const taxi As GossipOptionsType
public:
literal GossipOptionsType taxi

See Also

GossipOptionsType Enumeration
wManager.Wow.Enums Namespace


trainer Field

GossipOptionsType..::..trainer Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GossipOptionsType trainer
Public Const trainer As GossipOptionsType
public:
literal GossipOptionsType trainer

See Also

GossipOptionsType Enumeration
wManager.Wow.Enums Namespace


unlearn Field

GossipOptionsType..::..unlearn Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GossipOptionsType unlearn
Public Const unlearn As GossipOptionsType
public:
literal GossipOptionsType unlearn

See Also

GossipOptionsType Enumeration
wManager.Wow.Enums Namespace


vendor Field

GossipOptionsType..::..vendor Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GossipOptionsType vendor
Public Const vendor As GossipOptionsType
public:
literal GossipOptionsType vendor

See Also

GossipOptionsType Enumeration
wManager.Wow.Enums Namespace


None Field

GuidSubType..::..None Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GuidSubType None
Public Const None As GuidSubType
public:
literal GuidSubType None

See Also

GuidSubType Enumeration
wManager.Wow.Enums Namespace


AIGroup Field

GuidType..::..AIGroup Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GuidType AIGroup
Public Const AIGroup As GuidType
public:
literal GuidType AIGroup

See Also

GuidType Enumeration
wManager.Wow.Enums Namespace


AILock Field

GuidType..::..AILock Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GuidType AILock
Public Const AILock As GuidType
public:
literal GuidType AILock

See Also

GuidType Enumeration
wManager.Wow.Enums Namespace


AILockTicket Field

GuidType..::..AILockTicket Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GuidType AILockTicket
Public Const AILockTicket As GuidType
public:
literal GuidType AILockTicket

See Also

GuidType Enumeration
wManager.Wow.Enums Namespace


AIResource Field

GuidType..::..AIResource Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GuidType AIResource
Public Const AIResource As GuidType
public:
literal GuidType AIResource

See Also

GuidType Enumeration
wManager.Wow.Enums Namespace


AreaTrigger Field

GuidType..::..AreaTrigger Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GuidType AreaTrigger
Public Const AreaTrigger As GuidType
public:
literal GuidType AreaTrigger

See Also

GuidType Enumeration
wManager.Wow.Enums Namespace


BattlePet Field

GuidType..::..BattlePet Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GuidType BattlePet
Public Const BattlePet As GuidType
public:
literal GuidType BattlePet

See Also

GuidType Enumeration
wManager.Wow.Enums Namespace


BNetAccount Field

GuidType..::..BNetAccount Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GuidType BNetAccount
Public Const BNetAccount As GuidType
public:
literal GuidType BNetAccount

See Also

GuidType Enumeration
wManager.Wow.Enums Namespace


CallForHelp Field

GuidType..::..CallForHelp Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GuidType CallForHelp
Public Const CallForHelp As GuidType
public:
literal GuidType CallForHelp

See Also

GuidType Enumeration
wManager.Wow.Enums Namespace


ChatChannel Field

GuidType..::..ChatChannel Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GuidType ChatChannel
Public Const ChatChannel As GuidType
public:
literal GuidType ChatChannel

See Also

GuidType Enumeration
wManager.Wow.Enums Namespace


ClientActor Field

GuidType..::..ClientActor Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GuidType ClientActor
Public Const ClientActor As GuidType
public:
literal GuidType ClientActor

See Also

GuidType Enumeration
wManager.Wow.Enums Namespace


ClientSession Field

GuidType..::..ClientSession Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GuidType ClientSession
Public Const ClientSession As GuidType
public:
literal GuidType ClientSession

See Also

GuidType Enumeration
wManager.Wow.Enums Namespace


CommerceObj Field

GuidType..::..CommerceObj Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GuidType CommerceObj
Public Const CommerceObj As GuidType
public:
literal GuidType CommerceObj

See Also

GuidType Enumeration
wManager.Wow.Enums Namespace


Conversation Field

GuidType..::..Conversation Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GuidType Conversation
Public Const Conversation As GuidType
public:
literal GuidType Conversation

See Also

GuidType Enumeration
wManager.Wow.Enums Namespace


Corpse Field

GuidType..::..Corpse Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GuidType Corpse
Public Const Corpse As GuidType
public:
literal GuidType Corpse

See Also

GuidType Enumeration
wManager.Wow.Enums Namespace


Creature Field

GuidType..::..Creature Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GuidType Creature
Public Const Creature As GuidType
public:
literal GuidType Creature

See Also

GuidType Enumeration
wManager.Wow.Enums Namespace


DynamicDoor Field

GuidType..::..DynamicDoor Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GuidType DynamicDoor
Public Const DynamicDoor As GuidType
public:
literal GuidType DynamicDoor

See Also

GuidType Enumeration
wManager.Wow.Enums Namespace


DynamicObject Field

GuidType..::..DynamicObject Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GuidType DynamicObject
Public Const DynamicObject As GuidType
public:
literal GuidType DynamicObject

See Also

GuidType Enumeration
wManager.Wow.Enums Namespace


GameObject Field

GuidType..::..GameObject Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GuidType GameObject
Public Const GameObject As GuidType
public:
literal GuidType GameObject

See Also

GuidType Enumeration
wManager.Wow.Enums Namespace


GMTask Field

GuidType..::..GMTask Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GuidType GMTask
Public Const GMTask As GuidType
public:
literal GuidType GMTask

See Also

GuidType Enumeration
wManager.Wow.Enums Namespace


Guild Field

GuidType..::..Guild Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GuidType Guild
Public Const Guild As GuidType
public:
literal GuidType Guild

See Also

GuidType Enumeration
wManager.Wow.Enums Namespace


Item Field

GuidType..::..Item Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GuidType Item
Public Const Item As GuidType
public:
literal GuidType Item

See Also

GuidType Enumeration
wManager.Wow.Enums Namespace


LFGList Field

GuidType..::..LFGList Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GuidType LFGList
Public Const LFGList As GuidType
public:
literal GuidType LFGList

See Also

GuidType Enumeration
wManager.Wow.Enums Namespace


LFGObject Field

GuidType..::..LFGObject Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GuidType LFGObject
Public Const LFGObject As GuidType
public:
literal GuidType LFGObject

See Also

GuidType Enumeration
wManager.Wow.Enums Namespace


LootObject Field

GuidType..::..LootObject Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GuidType LootObject
Public Const LootObject As GuidType
public:
literal GuidType LootObject

See Also

GuidType Enumeration
wManager.Wow.Enums Namespace


Mail Field

GuidType..::..Mail Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GuidType Mail
Public Const Mail As GuidType
public:
literal GuidType Mail

See Also

GuidType Enumeration
wManager.Wow.Enums Namespace


MobileSession Field

GuidType..::..MobileSession Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GuidType MobileSession
Public Const MobileSession As GuidType
public:
literal GuidType MobileSession

See Also

GuidType Enumeration
wManager.Wow.Enums Namespace


None Field

GuidType..::..None Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GuidType None
Public Const None As GuidType
public:
literal GuidType None

See Also

GuidType Enumeration
wManager.Wow.Enums Namespace


Party Field

GuidType..::..Party Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GuidType Party
Public Const Party As GuidType
public:
literal GuidType Party

See Also

GuidType Enumeration
wManager.Wow.Enums Namespace


Pet Field

GuidType..::..Pet Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GuidType Pet
Public Const Pet As GuidType
public:
literal GuidType Pet

See Also

GuidType Enumeration
wManager.Wow.Enums Namespace


PetBattle Field

GuidType..::..PetBattle Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GuidType PetBattle
Public Const PetBattle As GuidType
public:
literal GuidType PetBattle

See Also

GuidType Enumeration
wManager.Wow.Enums Namespace


Player Field

GuidType..::..Player Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GuidType Player
Public Const Player As GuidType
public:
literal GuidType Player

See Also

GuidType Enumeration
wManager.Wow.Enums Namespace


PVPQueueGroup Field

GuidType..::..PVPQueueGroup Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GuidType PVPQueueGroup
Public Const PVPQueueGroup As GuidType
public:
literal GuidType PVPQueueGroup

See Also

GuidType Enumeration
wManager.Wow.Enums Namespace


RaidGroup Field

GuidType..::..RaidGroup Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GuidType RaidGroup
Public Const RaidGroup As GuidType
public:
literal GuidType RaidGroup

See Also

GuidType Enumeration
wManager.Wow.Enums Namespace


Scenario Field

GuidType..::..Scenario Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GuidType Scenario
Public Const Scenario As GuidType
public:
literal GuidType Scenario

See Also

GuidType Enumeration
wManager.Wow.Enums Namespace


SceneObject Field

GuidType..::..SceneObject Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GuidType SceneObject
Public Const SceneObject As GuidType
public:
literal GuidType SceneObject

See Also

GuidType Enumeration
wManager.Wow.Enums Namespace


Spell Field

GuidType..::..Spell Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GuidType Spell
Public Const Spell As GuidType
public:
literal GuidType Spell

See Also

GuidType Enumeration
wManager.Wow.Enums Namespace


StaticDoor Field

GuidType..::..StaticDoor Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GuidType StaticDoor
Public Const StaticDoor As GuidType
public:
literal GuidType StaticDoor

See Also

GuidType Enumeration
wManager.Wow.Enums Namespace


Transport Field

GuidType..::..Transport Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GuidType Transport
Public Const Transport As GuidType
public:
literal GuidType Transport

See Also

GuidType Enumeration
wManager.Wow.Enums Namespace


Uniq Field

GuidType..::..Uniq Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GuidType Uniq
Public Const Uniq As GuidType
public:
literal GuidType Uniq

See Also

GuidType Enumeration
wManager.Wow.Enums Namespace


UniqueUserClient Field

GuidType..::..UniqueUserClient Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GuidType UniqueUserClient
Public Const UniqueUserClient As GuidType
public:
literal GuidType UniqueUserClient

See Also

GuidType Enumeration
wManager.Wow.Enums Namespace


UserClient Field

GuidType..::..UserClient Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GuidType UserClient
Public Const UserClient As GuidType
public:
literal GuidType UserClient

See Also

GuidType Enumeration
wManager.Wow.Enums Namespace


UserRouter Field

GuidType..::..UserRouter Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GuidType UserRouter
Public Const UserRouter As GuidType
public:
literal GuidType UserRouter

See Also

GuidType Enumeration
wManager.Wow.Enums Namespace


Vehicle Field

GuidType..::..Vehicle Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GuidType Vehicle
Public Const Vehicle As GuidType
public:
literal GuidType Vehicle

See Also

GuidType Enumeration
wManager.Wow.Enums Namespace


Vignette Field

GuidType..::..Vignette Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GuidType Vignette
Public Const Vignette As GuidType
public:
literal GuidType Vignette

See Also

GuidType Enumeration
wManager.Wow.Enums Namespace


WebObj Field

GuidType..::..WebObj Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GuidType WebObj
Public Const WebObj As GuidType
public:
literal GuidType WebObj

See Also

GuidType Enumeration
wManager.Wow.Enums Namespace


WorldTransaction Field

GuidType..::..WorldTransaction Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GuidType WorldTransaction
Public Const WorldTransaction As GuidType
public:
literal GuidType WorldTransaction

See Also

GuidType Enumeration
wManager.Wow.Enums Namespace


WowAcount Field

GuidType..::..WowAcount Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const GuidType WowAcount
Public Const WowAcount As GuidType
public:
literal GuidType WowAcount

See Also

GuidType Enumeration
wManager.Wow.Enums Namespace


CONTAINER_BAG_OFFSET_1 Field

InventorySlot..::..CONTAINER_BAG_OFFSET_1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const InventorySlot CONTAINER_BAG_OFFSET_1
Public Const CONTAINER_BAG_OFFSET_1 As InventorySlot
public:
literal InventorySlot CONTAINER_BAG_OFFSET_1

See Also

InventorySlot Enumeration
wManager.Wow.Enums Namespace


CONTAINER_BAG_OFFSET_2 Field

InventorySlot..::..CONTAINER_BAG_OFFSET_2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const InventorySlot CONTAINER_BAG_OFFSET_2
Public Const CONTAINER_BAG_OFFSET_2 As InventorySlot
public:
literal InventorySlot CONTAINER_BAG_OFFSET_2

See Also

InventorySlot Enumeration
wManager.Wow.Enums Namespace


CONTAINER_BAG_OFFSET_3 Field

InventorySlot..::..CONTAINER_BAG_OFFSET_3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const InventorySlot CONTAINER_BAG_OFFSET_3
Public Const CONTAINER_BAG_OFFSET_3 As InventorySlot
public:
literal InventorySlot CONTAINER_BAG_OFFSET_3

See Also

InventorySlot Enumeration
wManager.Wow.Enums Namespace


CONTAINER_BAG_OFFSET_4 Field

InventorySlot..::..CONTAINER_BAG_OFFSET_4 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const InventorySlot CONTAINER_BAG_OFFSET_4
Public Const CONTAINER_BAG_OFFSET_4 As InventorySlot
public:
literal InventorySlot CONTAINER_BAG_OFFSET_4

See Also

InventorySlot Enumeration
wManager.Wow.Enums Namespace


INVSLOT_AMMO Field

InventorySlot..::..INVSLOT_AMMO Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const InventorySlot INVSLOT_AMMO
Public Const INVSLOT_AMMO As InventorySlot
public:
literal InventorySlot INVSLOT_AMMO

See Also

InventorySlot Enumeration
wManager.Wow.Enums Namespace


INVSLOT_BACK Field

InventorySlot..::..INVSLOT_BACK Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const InventorySlot INVSLOT_BACK
Public Const INVSLOT_BACK As InventorySlot
public:
literal InventorySlot INVSLOT_BACK

See Also

InventorySlot Enumeration
wManager.Wow.Enums Namespace


INVSLOT_BODY Field

InventorySlot..::..INVSLOT_BODY Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const InventorySlot INVSLOT_BODY
Public Const INVSLOT_BODY As InventorySlot
public:
literal InventorySlot INVSLOT_BODY

See Also

InventorySlot Enumeration
wManager.Wow.Enums Namespace


INVSLOT_CHEST Field

InventorySlot..::..INVSLOT_CHEST Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const InventorySlot INVSLOT_CHEST
Public Const INVSLOT_CHEST As InventorySlot
public:
literal InventorySlot INVSLOT_CHEST

See Also

InventorySlot Enumeration
wManager.Wow.Enums Namespace


INVSLOT_FEET Field

InventorySlot..::..INVSLOT_FEET Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const InventorySlot INVSLOT_FEET
Public Const INVSLOT_FEET As InventorySlot
public:
literal InventorySlot INVSLOT_FEET

See Also

InventorySlot Enumeration
wManager.Wow.Enums Namespace


INVSLOT_FINGER1 Field

InventorySlot..::..INVSLOT_FINGER1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const InventorySlot INVSLOT_FINGER1
Public Const INVSLOT_FINGER1 As InventorySlot
public:
literal InventorySlot INVSLOT_FINGER1

See Also

InventorySlot Enumeration
wManager.Wow.Enums Namespace


INVSLOT_FINGER2 Field

InventorySlot..::..INVSLOT_FINGER2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const InventorySlot INVSLOT_FINGER2
Public Const INVSLOT_FINGER2 As InventorySlot
public:
literal InventorySlot INVSLOT_FINGER2

See Also

InventorySlot Enumeration
wManager.Wow.Enums Namespace


INVSLOT_HAND Field

InventorySlot..::..INVSLOT_HAND Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const InventorySlot INVSLOT_HAND
Public Const INVSLOT_HAND As InventorySlot
public:
literal InventorySlot INVSLOT_HAND

See Also

InventorySlot Enumeration
wManager.Wow.Enums Namespace


INVSLOT_HEAD Field

InventorySlot..::..INVSLOT_HEAD Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const InventorySlot INVSLOT_HEAD
Public Const INVSLOT_HEAD As InventorySlot
public:
literal InventorySlot INVSLOT_HEAD

See Also

InventorySlot Enumeration
wManager.Wow.Enums Namespace


INVSLOT_LEGS Field

InventorySlot..::..INVSLOT_LEGS Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const InventorySlot INVSLOT_LEGS
Public Const INVSLOT_LEGS As InventorySlot
public:
literal InventorySlot INVSLOT_LEGS

See Also

InventorySlot Enumeration
wManager.Wow.Enums Namespace


INVSLOT_MAINHAND Field

InventorySlot..::..INVSLOT_MAINHAND Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const InventorySlot INVSLOT_MAINHAND
Public Const INVSLOT_MAINHAND As InventorySlot
public:
literal InventorySlot INVSLOT_MAINHAND

See Also

InventorySlot Enumeration
wManager.Wow.Enums Namespace


INVSLOT_NECK Field

InventorySlot..::..INVSLOT_NECK Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const InventorySlot INVSLOT_NECK
Public Const INVSLOT_NECK As InventorySlot
public:
literal InventorySlot INVSLOT_NECK

See Also

InventorySlot Enumeration
wManager.Wow.Enums Namespace


INVSLOT_OFFHAND Field

InventorySlot..::..INVSLOT_OFFHAND Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const InventorySlot INVSLOT_OFFHAND
Public Const INVSLOT_OFFHAND As InventorySlot
public:
literal InventorySlot INVSLOT_OFFHAND

See Also

InventorySlot Enumeration
wManager.Wow.Enums Namespace


INVSLOT_RANGED Field

InventorySlot..::..INVSLOT_RANGED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const InventorySlot INVSLOT_RANGED
Public Const INVSLOT_RANGED As InventorySlot
public:
literal InventorySlot INVSLOT_RANGED

See Also

InventorySlot Enumeration
wManager.Wow.Enums Namespace


INVSLOT_SHOULDER Field

InventorySlot..::..INVSLOT_SHOULDER Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const InventorySlot INVSLOT_SHOULDER
Public Const INVSLOT_SHOULDER As InventorySlot
public:
literal InventorySlot INVSLOT_SHOULDER

See Also

InventorySlot Enumeration
wManager.Wow.Enums Namespace


INVSLOT_TABARD Field

InventorySlot..::..INVSLOT_TABARD Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const InventorySlot INVSLOT_TABARD
Public Const INVSLOT_TABARD As InventorySlot
public:
literal InventorySlot INVSLOT_TABARD

See Also

InventorySlot Enumeration
wManager.Wow.Enums Namespace


INVSLOT_TRINKET1 Field

InventorySlot..::..INVSLOT_TRINKET1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const InventorySlot INVSLOT_TRINKET1
Public Const INVSLOT_TRINKET1 As InventorySlot
public:
literal InventorySlot INVSLOT_TRINKET1

See Also

InventorySlot Enumeration
wManager.Wow.Enums Namespace


INVSLOT_TRINKET2 Field

InventorySlot..::..INVSLOT_TRINKET2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const InventorySlot INVSLOT_TRINKET2
Public Const INVSLOT_TRINKET2 As InventorySlot
public:
literal InventorySlot INVSLOT_TRINKET2

See Also

InventorySlot Enumeration
wManager.Wow.Enums Namespace


INVSLOT_WAIST Field

InventorySlot..::..INVSLOT_WAIST Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const InventorySlot INVSLOT_WAIST
Public Const INVSLOT_WAIST As InventorySlot
public:
literal InventorySlot INVSLOT_WAIST

See Also

InventorySlot Enumeration
wManager.Wow.Enums Namespace


INVSLOT_WRIST Field

InventorySlot..::..INVSLOT_WRIST Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const InventorySlot INVSLOT_WRIST
Public Const INVSLOT_WRIST As InventorySlot
public:
literal InventorySlot INVSLOT_WRIST

See Also

InventorySlot Enumeration
wManager.Wow.Enums Namespace


ACTIONBUTTON1 Field

Keybindings..::..ACTIONBUTTON1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings ACTIONBUTTON1
Public Const ACTIONBUTTON1 As Keybindings
public:
literal Keybindings ACTIONBUTTON1

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


ACTIONBUTTON2 Field

Keybindings..::..ACTIONBUTTON2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings ACTIONBUTTON2
Public Const ACTIONBUTTON2 As Keybindings
public:
literal Keybindings ACTIONBUTTON2

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


ACTIONBUTTON3 Field

Keybindings..::..ACTIONBUTTON3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings ACTIONBUTTON3
Public Const ACTIONBUTTON3 As Keybindings
public:
literal Keybindings ACTIONBUTTON3

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


ACTIONBUTTON4 Field

Keybindings..::..ACTIONBUTTON4 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings ACTIONBUTTON4
Public Const ACTIONBUTTON4 As Keybindings
public:
literal Keybindings ACTIONBUTTON4

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


ACTIONBUTTON5 Field

Keybindings..::..ACTIONBUTTON5 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings ACTIONBUTTON5
Public Const ACTIONBUTTON5 As Keybindings
public:
literal Keybindings ACTIONBUTTON5

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


ACTIONBUTTON6 Field

Keybindings..::..ACTIONBUTTON6 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings ACTIONBUTTON6
Public Const ACTIONBUTTON6 As Keybindings
public:
literal Keybindings ACTIONBUTTON6

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


ACTIONBUTTON7 Field

Keybindings..::..ACTIONBUTTON7 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings ACTIONBUTTON7
Public Const ACTIONBUTTON7 As Keybindings
public:
literal Keybindings ACTIONBUTTON7

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


ACTIONBUTTON8 Field

Keybindings..::..ACTIONBUTTON8 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings ACTIONBUTTON8
Public Const ACTIONBUTTON8 As Keybindings
public:
literal Keybindings ACTIONBUTTON8

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


ACTIONBUTTON9 Field

Keybindings..::..ACTIONBUTTON9 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings ACTIONBUTTON9
Public Const ACTIONBUTTON9 As Keybindings
public:
literal Keybindings ACTIONBUTTON9

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


ACTIONBUTTON10 Field

Keybindings..::..ACTIONBUTTON10 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings ACTIONBUTTON10
Public Const ACTIONBUTTON10 As Keybindings
public:
literal Keybindings ACTIONBUTTON10

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


ACTIONBUTTON11 Field

Keybindings..::..ACTIONBUTTON11 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings ACTIONBUTTON11
Public Const ACTIONBUTTON11 As Keybindings
public:
literal Keybindings ACTIONBUTTON11

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


ACTIONBUTTON12 Field

Keybindings..::..ACTIONBUTTON12 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings ACTIONBUTTON12
Public Const ACTIONBUTTON12 As Keybindings
public:
literal Keybindings ACTIONBUTTON12

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


ACTIONPAGE1 Field

Keybindings..::..ACTIONPAGE1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings ACTIONPAGE1
Public Const ACTIONPAGE1 As Keybindings
public:
literal Keybindings ACTIONPAGE1

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


ACTIONPAGE2 Field

Keybindings..::..ACTIONPAGE2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings ACTIONPAGE2
Public Const ACTIONPAGE2 As Keybindings
public:
literal Keybindings ACTIONPAGE2

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


ACTIONPAGE3 Field

Keybindings..::..ACTIONPAGE3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings ACTIONPAGE3
Public Const ACTIONPAGE3 As Keybindings
public:
literal Keybindings ACTIONPAGE3

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


ACTIONPAGE4 Field

Keybindings..::..ACTIONPAGE4 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings ACTIONPAGE4
Public Const ACTIONPAGE4 As Keybindings
public:
literal Keybindings ACTIONPAGE4

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


ACTIONPAGE5 Field

Keybindings..::..ACTIONPAGE5 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings ACTIONPAGE5
Public Const ACTIONPAGE5 As Keybindings
public:
literal Keybindings ACTIONPAGE5

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


ACTIONPAGE6 Field

Keybindings..::..ACTIONPAGE6 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings ACTIONPAGE6
Public Const ACTIONPAGE6 As Keybindings
public:
literal Keybindings ACTIONPAGE6

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


ALLNAMEPLATES Field

Keybindings..::..ALLNAMEPLATES Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings ALLNAMEPLATES
Public Const ALLNAMEPLATES As Keybindings
public:
literal Keybindings ALLNAMEPLATES

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


ASSISTTARGET Field

Keybindings..::..ASSISTTARGET Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings ASSISTTARGET
Public Const ASSISTTARGET As Keybindings
public:
literal Keybindings ASSISTTARGET

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


ATTACKTARGET Field

Keybindings..::..ATTACKTARGET Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings ATTACKTARGET
Public Const ATTACKTARGET As Keybindings
public:
literal Keybindings ATTACKTARGET

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


BONUSACTIONBUTTON1 Field

Keybindings..::..BONUSACTIONBUTTON1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings BONUSACTIONBUTTON1
Public Const BONUSACTIONBUTTON1 As Keybindings
public:
literal Keybindings BONUSACTIONBUTTON1

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


BONUSACTIONBUTTON2 Field

Keybindings..::..BONUSACTIONBUTTON2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings BONUSACTIONBUTTON2
Public Const BONUSACTIONBUTTON2 As Keybindings
public:
literal Keybindings BONUSACTIONBUTTON2

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


BONUSACTIONBUTTON3 Field

Keybindings..::..BONUSACTIONBUTTON3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings BONUSACTIONBUTTON3
Public Const BONUSACTIONBUTTON3 As Keybindings
public:
literal Keybindings BONUSACTIONBUTTON3

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


BONUSACTIONBUTTON4 Field

Keybindings..::..BONUSACTIONBUTTON4 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings BONUSACTIONBUTTON4
Public Const BONUSACTIONBUTTON4 As Keybindings
public:
literal Keybindings BONUSACTIONBUTTON4

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


BONUSACTIONBUTTON5 Field

Keybindings..::..BONUSACTIONBUTTON5 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings BONUSACTIONBUTTON5
Public Const BONUSACTIONBUTTON5 As Keybindings
public:
literal Keybindings BONUSACTIONBUTTON5

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


BONUSACTIONBUTTON6 Field

Keybindings..::..BONUSACTIONBUTTON6 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings BONUSACTIONBUTTON6
Public Const BONUSACTIONBUTTON6 As Keybindings
public:
literal Keybindings BONUSACTIONBUTTON6

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


BONUSACTIONBUTTON7 Field

Keybindings..::..BONUSACTIONBUTTON7 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings BONUSACTIONBUTTON7
Public Const BONUSACTIONBUTTON7 As Keybindings
public:
literal Keybindings BONUSACTIONBUTTON7

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


BONUSACTIONBUTTON8 Field

Keybindings..::..BONUSACTIONBUTTON8 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings BONUSACTIONBUTTON8
Public Const BONUSACTIONBUTTON8 As Keybindings
public:
literal Keybindings BONUSACTIONBUTTON8

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


BONUSACTIONBUTTON9 Field

Keybindings..::..BONUSACTIONBUTTON9 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings BONUSACTIONBUTTON9
Public Const BONUSACTIONBUTTON9 As Keybindings
public:
literal Keybindings BONUSACTIONBUTTON9

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


BONUSACTIONBUTTON10 Field

Keybindings..::..BONUSACTIONBUTTON10 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings BONUSACTIONBUTTON10
Public Const BONUSACTIONBUTTON10 As Keybindings
public:
literal Keybindings BONUSACTIONBUTTON10

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


CAMERAORSELECTORMOVE Field

Keybindings..::..CAMERAORSELECTORMOVE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings CAMERAORSELECTORMOVE
Public Const CAMERAORSELECTORMOVE As Keybindings
public:
literal Keybindings CAMERAORSELECTORMOVE

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


CAMERAZOOMIN Field

Keybindings..::..CAMERAZOOMIN Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings CAMERAZOOMIN
Public Const CAMERAZOOMIN As Keybindings
public:
literal Keybindings CAMERAZOOMIN

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


CAMERAZOOMOUT Field

Keybindings..::..CAMERAZOOMOUT Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings CAMERAZOOMOUT
Public Const CAMERAZOOMOUT As Keybindings
public:
literal Keybindings CAMERAZOOMOUT

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


CHATBOTTOM Field

Keybindings..::..CHATBOTTOM Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings CHATBOTTOM
Public Const CHATBOTTOM As Keybindings
public:
literal Keybindings CHATBOTTOM

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


CHATPAGEDOWN Field

Keybindings..::..CHATPAGEDOWN Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings CHATPAGEDOWN
Public Const CHATPAGEDOWN As Keybindings
public:
literal Keybindings CHATPAGEDOWN

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


CHATPAGEUP Field

Keybindings..::..CHATPAGEUP Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings CHATPAGEUP
Public Const CHATPAGEUP As Keybindings
public:
literal Keybindings CHATPAGEUP

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


COMBATLOGBOTTOM Field

Keybindings..::..COMBATLOGBOTTOM Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings COMBATLOGBOTTOM
Public Const COMBATLOGBOTTOM As Keybindings
public:
literal Keybindings COMBATLOGBOTTOM

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


COMBATLOGPAGEDOWN Field

Keybindings..::..COMBATLOGPAGEDOWN Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings COMBATLOGPAGEDOWN
Public Const COMBATLOGPAGEDOWN As Keybindings
public:
literal Keybindings COMBATLOGPAGEDOWN

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


COMBATLOGPAGEUP Field

Keybindings..::..COMBATLOGPAGEUP Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings COMBATLOGPAGEUP
Public Const COMBATLOGPAGEUP As Keybindings
public:
literal Keybindings COMBATLOGPAGEUP

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


EXTRAACTIONBUTTON1 Field

Keybindings..::..EXTRAACTIONBUTTON1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings EXTRAACTIONBUTTON1
Public Const EXTRAACTIONBUTTON1 As Keybindings
public:
literal Keybindings EXTRAACTIONBUTTON1

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


FRIENDNAMEPLATES Field

Keybindings..::..FRIENDNAMEPLATES Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings FRIENDNAMEPLATES
Public Const FRIENDNAMEPLATES As Keybindings
public:
literal Keybindings FRIENDNAMEPLATES

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


INTERACTTARGET Field

Keybindings..::..INTERACTTARGET Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings INTERACTTARGET
Public Const INTERACTTARGET As Keybindings
public:
literal Keybindings INTERACTTARGET

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


JUMP Field

Keybindings..::..JUMP Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings JUMP
Public Const JUMP As Keybindings
public:
literal Keybindings JUMP

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


MASTERVOLUMEDOWN Field

Keybindings..::..MASTERVOLUMEDOWN Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings MASTERVOLUMEDOWN
Public Const MASTERVOLUMEDOWN As Keybindings
public:
literal Keybindings MASTERVOLUMEDOWN

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


MASTERVOLUMEUP Field

Keybindings..::..MASTERVOLUMEUP Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings MASTERVOLUMEUP
Public Const MASTERVOLUMEUP As Keybindings
public:
literal Keybindings MASTERVOLUMEUP

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


MINIMAPZOOMIN Field

Keybindings..::..MINIMAPZOOMIN Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings MINIMAPZOOMIN
Public Const MINIMAPZOOMIN As Keybindings
public:
literal Keybindings MINIMAPZOOMIN

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


MINIMAPZOOMOUT Field

Keybindings..::..MINIMAPZOOMOUT Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings MINIMAPZOOMOUT
Public Const MINIMAPZOOMOUT As Keybindings
public:
literal Keybindings MINIMAPZOOMOUT

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


MOVEANDSTEER Field

Keybindings..::..MOVEANDSTEER Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings MOVEANDSTEER
Public Const MOVEANDSTEER As Keybindings
public:
literal Keybindings MOVEANDSTEER

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


MOVEBACKWARD Field

Keybindings..::..MOVEBACKWARD Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings MOVEBACKWARD
Public Const MOVEBACKWARD As Keybindings
public:
literal Keybindings MOVEBACKWARD

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


MOVEFORWARD Field

Keybindings..::..MOVEFORWARD Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings MOVEFORWARD
Public Const MOVEFORWARD As Keybindings
public:
literal Keybindings MOVEFORWARD

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


MOVIE_RECORDING_CANCEL Field

Keybindings..::..MOVIE_RECORDING_CANCEL Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings MOVIE_RECORDING_CANCEL
Public Const MOVIE_RECORDING_CANCEL As Keybindings
public:
literal Keybindings MOVIE_RECORDING_CANCEL

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


MOVIE_RECORDING_COMPRESS Field

Keybindings..::..MOVIE_RECORDING_COMPRESS Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings MOVIE_RECORDING_COMPRESS
Public Const MOVIE_RECORDING_COMPRESS As Keybindings
public:
literal Keybindings MOVIE_RECORDING_COMPRESS

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


MOVIE_RECORDING_GUI Field

Keybindings..::..MOVIE_RECORDING_GUI Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings MOVIE_RECORDING_GUI
Public Const MOVIE_RECORDING_GUI As Keybindings
public:
literal Keybindings MOVIE_RECORDING_GUI

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


MOVIE_RECORDING_STARTSTOP Field

Keybindings..::..MOVIE_RECORDING_STARTSTOP Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings MOVIE_RECORDING_STARTSTOP
Public Const MOVIE_RECORDING_STARTSTOP As Keybindings
public:
literal Keybindings MOVIE_RECORDING_STARTSTOP

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


NAMEPLATES Field

Keybindings..::..NAMEPLATES Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings NAMEPLATES
Public Const NAMEPLATES As Keybindings
public:
literal Keybindings NAMEPLATES

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


NEXTACTIONPAGE Field

Keybindings..::..NEXTACTIONPAGE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings NEXTACTIONPAGE
Public Const NEXTACTIONPAGE As Keybindings
public:
literal Keybindings NEXTACTIONPAGE

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


NEXTVIEW Field

Keybindings..::..NEXTVIEW Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings NEXTVIEW
Public Const NEXTVIEW As Keybindings
public:
literal Keybindings NEXTVIEW

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


NONE Field

Keybindings..::..NONE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings NONE
Public Const NONE As Keybindings
public:
literal Keybindings NONE

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


OPENALLBAGS Field

Keybindings..::..OPENALLBAGS Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings OPENALLBAGS
Public Const OPENALLBAGS As Keybindings
public:
literal Keybindings OPENALLBAGS

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


OPENCHAT Field

Keybindings..::..OPENCHAT Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings OPENCHAT
Public Const OPENCHAT As Keybindings
public:
literal Keybindings OPENCHAT

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


OPENCHATSLASH Field

Keybindings..::..OPENCHATSLASH Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings OPENCHATSLASH
Public Const OPENCHATSLASH As Keybindings
public:
literal Keybindings OPENCHATSLASH

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


PETATTACK Field

Keybindings..::..PETATTACK Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings PETATTACK
Public Const PETATTACK As Keybindings
public:
literal Keybindings PETATTACK

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


PITCHDOWN Field

Keybindings..::..PITCHDOWN Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings PITCHDOWN
Public Const PITCHDOWN As Keybindings
public:
literal Keybindings PITCHDOWN

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


PITCHUP Field

Keybindings..::..PITCHUP Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings PITCHUP
Public Const PITCHUP As Keybindings
public:
literal Keybindings PITCHUP

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


PREVIOUSACTIONPAGE Field

Keybindings..::..PREVIOUSACTIONPAGE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings PREVIOUSACTIONPAGE
Public Const PREVIOUSACTIONPAGE As Keybindings
public:
literal Keybindings PREVIOUSACTIONPAGE

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


PREVVIEW Field

Keybindings..::..PREVVIEW Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings PREVVIEW
Public Const PREVVIEW As Keybindings
public:
literal Keybindings PREVVIEW

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


REPLY Field

Keybindings..::..REPLY Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings REPLY
Public Const REPLY As Keybindings
public:
literal Keybindings REPLY

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


REPLY2 Field

Keybindings..::..REPLY2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings REPLY2
Public Const REPLY2 As Keybindings
public:
literal Keybindings REPLY2

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


SCREENSHOT Field

Keybindings..::..SCREENSHOT Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings SCREENSHOT
Public Const SCREENSHOT As Keybindings
public:
literal Keybindings SCREENSHOT

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


SHAPESHIFTBUTTON1 Field

Keybindings..::..SHAPESHIFTBUTTON1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings SHAPESHIFTBUTTON1
Public Const SHAPESHIFTBUTTON1 As Keybindings
public:
literal Keybindings SHAPESHIFTBUTTON1

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


SHAPESHIFTBUTTON2 Field

Keybindings..::..SHAPESHIFTBUTTON2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings SHAPESHIFTBUTTON2
Public Const SHAPESHIFTBUTTON2 As Keybindings
public:
literal Keybindings SHAPESHIFTBUTTON2

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


SHAPESHIFTBUTTON3 Field

Keybindings..::..SHAPESHIFTBUTTON3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings SHAPESHIFTBUTTON3
Public Const SHAPESHIFTBUTTON3 As Keybindings
public:
literal Keybindings SHAPESHIFTBUTTON3

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


SHAPESHIFTBUTTON4 Field

Keybindings..::..SHAPESHIFTBUTTON4 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings SHAPESHIFTBUTTON4
Public Const SHAPESHIFTBUTTON4 As Keybindings
public:
literal Keybindings SHAPESHIFTBUTTON4

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


SHAPESHIFTBUTTON5 Field

Keybindings..::..SHAPESHIFTBUTTON5 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings SHAPESHIFTBUTTON5
Public Const SHAPESHIFTBUTTON5 As Keybindings
public:
literal Keybindings SHAPESHIFTBUTTON5

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


SHAPESHIFTBUTTON6 Field

Keybindings..::..SHAPESHIFTBUTTON6 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings SHAPESHIFTBUTTON6
Public Const SHAPESHIFTBUTTON6 As Keybindings
public:
literal Keybindings SHAPESHIFTBUTTON6

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


SHAPESHIFTBUTTON7 Field

Keybindings..::..SHAPESHIFTBUTTON7 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings SHAPESHIFTBUTTON7
Public Const SHAPESHIFTBUTTON7 As Keybindings
public:
literal Keybindings SHAPESHIFTBUTTON7

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


SHAPESHIFTBUTTON8 Field

Keybindings..::..SHAPESHIFTBUTTON8 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings SHAPESHIFTBUTTON8
Public Const SHAPESHIFTBUTTON8 As Keybindings
public:
literal Keybindings SHAPESHIFTBUTTON8

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


SHAPESHIFTBUTTON9 Field

Keybindings..::..SHAPESHIFTBUTTON9 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings SHAPESHIFTBUTTON9
Public Const SHAPESHIFTBUTTON9 As Keybindings
public:
literal Keybindings SHAPESHIFTBUTTON9

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


SHAPESHIFTBUTTON10 Field

Keybindings..::..SHAPESHIFTBUTTON10 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings SHAPESHIFTBUTTON10
Public Const SHAPESHIFTBUTTON10 As Keybindings
public:
literal Keybindings SHAPESHIFTBUTTON10

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


SITORSTAND Field

Keybindings..::..SITORSTAND Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings SITORSTAND
Public Const SITORSTAND As Keybindings
public:
literal Keybindings SITORSTAND

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


STRAFELEFT Field

Keybindings..::..STRAFELEFT Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings STRAFELEFT
Public Const STRAFELEFT As Keybindings
public:
literal Keybindings STRAFELEFT

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


STRAFERIGHT Field

Keybindings..::..STRAFERIGHT Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings STRAFERIGHT
Public Const STRAFERIGHT As Keybindings
public:
literal Keybindings STRAFERIGHT

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TARGETLASTHOSTILE Field

Keybindings..::..TARGETLASTHOSTILE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TARGETLASTHOSTILE
Public Const TARGETLASTHOSTILE As Keybindings
public:
literal Keybindings TARGETLASTHOSTILE

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TARGETNEARESTENEMY Field

Keybindings..::..TARGETNEARESTENEMY Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TARGETNEARESTENEMY
Public Const TARGETNEARESTENEMY As Keybindings
public:
literal Keybindings TARGETNEARESTENEMY

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TARGETNEARESTFRIEND Field

Keybindings..::..TARGETNEARESTFRIEND Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TARGETNEARESTFRIEND
Public Const TARGETNEARESTFRIEND As Keybindings
public:
literal Keybindings TARGETNEARESTFRIEND

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TARGETPARTYMEMBER1 Field

Keybindings..::..TARGETPARTYMEMBER1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TARGETPARTYMEMBER1
Public Const TARGETPARTYMEMBER1 As Keybindings
public:
literal Keybindings TARGETPARTYMEMBER1

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TARGETPARTYMEMBER2 Field

Keybindings..::..TARGETPARTYMEMBER2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TARGETPARTYMEMBER2
Public Const TARGETPARTYMEMBER2 As Keybindings
public:
literal Keybindings TARGETPARTYMEMBER2

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TARGETPARTYMEMBER3 Field

Keybindings..::..TARGETPARTYMEMBER3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TARGETPARTYMEMBER3
Public Const TARGETPARTYMEMBER3 As Keybindings
public:
literal Keybindings TARGETPARTYMEMBER3

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TARGETPARTYMEMBER4 Field

Keybindings..::..TARGETPARTYMEMBER4 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TARGETPARTYMEMBER4
Public Const TARGETPARTYMEMBER4 As Keybindings
public:
literal Keybindings TARGETPARTYMEMBER4

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TARGETPARTYPET1 Field

Keybindings..::..TARGETPARTYPET1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TARGETPARTYPET1
Public Const TARGETPARTYPET1 As Keybindings
public:
literal Keybindings TARGETPARTYPET1

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TARGETPARTYPET2 Field

Keybindings..::..TARGETPARTYPET2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TARGETPARTYPET2
Public Const TARGETPARTYPET2 As Keybindings
public:
literal Keybindings TARGETPARTYPET2

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TARGETPARTYPET3 Field

Keybindings..::..TARGETPARTYPET3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TARGETPARTYPET3
Public Const TARGETPARTYPET3 As Keybindings
public:
literal Keybindings TARGETPARTYPET3

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TARGETPARTYPET4 Field

Keybindings..::..TARGETPARTYPET4 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TARGETPARTYPET4
Public Const TARGETPARTYPET4 As Keybindings
public:
literal Keybindings TARGETPARTYPET4

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TARGETPET Field

Keybindings..::..TARGETPET Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TARGETPET
Public Const TARGETPET As Keybindings
public:
literal Keybindings TARGETPET

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TARGETPREVIOUSENEMY Field

Keybindings..::..TARGETPREVIOUSENEMY Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TARGETPREVIOUSENEMY
Public Const TARGETPREVIOUSENEMY As Keybindings
public:
literal Keybindings TARGETPREVIOUSENEMY

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TARGETPREVIOUSFRIEND Field

Keybindings..::..TARGETPREVIOUSFRIEND Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TARGETPREVIOUSFRIEND
Public Const TARGETPREVIOUSFRIEND As Keybindings
public:
literal Keybindings TARGETPREVIOUSFRIEND

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TARGETSELF Field

Keybindings..::..TARGETSELF Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TARGETSELF
Public Const TARGETSELF As Keybindings
public:
literal Keybindings TARGETSELF

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TOGGLEACHIEVEMENT Field

Keybindings..::..TOGGLEACHIEVEMENT Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TOGGLEACHIEVEMENT
Public Const TOGGLEACHIEVEMENT As Keybindings
public:
literal Keybindings TOGGLEACHIEVEMENT

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TOGGLEANIMKITDISPLAY Field

Keybindings..::..TOGGLEANIMKITDISPLAY Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TOGGLEANIMKITDISPLAY
Public Const TOGGLEANIMKITDISPLAY As Keybindings
public:
literal Keybindings TOGGLEANIMKITDISPLAY

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TOGGLEAUTORUN Field

Keybindings..::..TOGGLEAUTORUN Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TOGGLEAUTORUN
Public Const TOGGLEAUTORUN As Keybindings
public:
literal Keybindings TOGGLEAUTORUN

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TOGGLEBACKPACK Field

Keybindings..::..TOGGLEBACKPACK Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TOGGLEBACKPACK
Public Const TOGGLEBACKPACK As Keybindings
public:
literal Keybindings TOGGLEBACKPACK

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TOGGLEBAG1 Field

Keybindings..::..TOGGLEBAG1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TOGGLEBAG1
Public Const TOGGLEBAG1 As Keybindings
public:
literal Keybindings TOGGLEBAG1

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TOGGLEBAG2 Field

Keybindings..::..TOGGLEBAG2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TOGGLEBAG2
Public Const TOGGLEBAG2 As Keybindings
public:
literal Keybindings TOGGLEBAG2

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TOGGLEBAG3 Field

Keybindings..::..TOGGLEBAG3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TOGGLEBAG3
Public Const TOGGLEBAG3 As Keybindings
public:
literal Keybindings TOGGLEBAG3

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TOGGLEBAG4 Field

Keybindings..::..TOGGLEBAG4 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TOGGLEBAG4
Public Const TOGGLEBAG4 As Keybindings
public:
literal Keybindings TOGGLEBAG4

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TOGGLEBATTLEFIELDMINIMAP Field

Keybindings..::..TOGGLEBATTLEFIELDMINIMAP Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TOGGLEBATTLEFIELDMINIMAP
Public Const TOGGLEBATTLEFIELDMINIMAP As Keybindings
public:
literal Keybindings TOGGLEBATTLEFIELDMINIMAP

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TOGGLECHANNELPULLOUT Field

Keybindings..::..TOGGLECHANNELPULLOUT Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TOGGLECHANNELPULLOUT
Public Const TOGGLECHANNELPULLOUT As Keybindings
public:
literal Keybindings TOGGLECHANNELPULLOUT

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TOGGLECHARACTER0 Field

Keybindings..::..TOGGLECHARACTER0 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TOGGLECHARACTER0
Public Const TOGGLECHARACTER0 As Keybindings
public:
literal Keybindings TOGGLECHARACTER0

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TOGGLECHARACTER2 Field

Keybindings..::..TOGGLECHARACTER2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TOGGLECHARACTER2
Public Const TOGGLECHARACTER2 As Keybindings
public:
literal Keybindings TOGGLECHARACTER2

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TOGGLECHARACTER3 Field

Keybindings..::..TOGGLECHARACTER3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TOGGLECHARACTER3
Public Const TOGGLECHARACTER3 As Keybindings
public:
literal Keybindings TOGGLECHARACTER3

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TOGGLECHARACTER4 Field

Keybindings..::..TOGGLECHARACTER4 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TOGGLECHARACTER4
Public Const TOGGLECHARACTER4 As Keybindings
public:
literal Keybindings TOGGLECHARACTER4

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TOGGLECOLLISION Field

Keybindings..::..TOGGLECOLLISION Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TOGGLECOLLISION
Public Const TOGGLECOLLISION As Keybindings
public:
literal Keybindings TOGGLECOLLISION

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TOGGLECOLLISIONDISPLAY Field

Keybindings..::..TOGGLECOLLISIONDISPLAY Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TOGGLECOLLISIONDISPLAY
Public Const TOGGLECOLLISIONDISPLAY As Keybindings
public:
literal Keybindings TOGGLECOLLISIONDISPLAY

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TOGGLECOMBATLOG Field

Keybindings..::..TOGGLECOMBATLOG Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TOGGLECOMBATLOG
Public Const TOGGLECOMBATLOG As Keybindings
public:
literal Keybindings TOGGLECOMBATLOG

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TOGGLEFPS Field

Keybindings..::..TOGGLEFPS Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TOGGLEFPS
Public Const TOGGLEFPS As Keybindings
public:
literal Keybindings TOGGLEFPS

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TOGGLEGAMEMENU Field

Keybindings..::..TOGGLEGAMEMENU Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TOGGLEGAMEMENU
Public Const TOGGLEGAMEMENU As Keybindings
public:
literal Keybindings TOGGLEGAMEMENU

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TOGGLEGEARSETS Field

Keybindings..::..TOGGLEGEARSETS Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TOGGLEGEARSETS
Public Const TOGGLEGEARSETS As Keybindings
public:
literal Keybindings TOGGLEGEARSETS

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TOGGLEGUILDTAB Field

Keybindings..::..TOGGLEGUILDTAB Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TOGGLEGUILDTAB
Public Const TOGGLEGUILDTAB As Keybindings
public:
literal Keybindings TOGGLEGUILDTAB

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TOGGLELFGPARENT Field

Keybindings..::..TOGGLELFGPARENT Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TOGGLELFGPARENT
Public Const TOGGLELFGPARENT As Keybindings
public:
literal Keybindings TOGGLELFGPARENT

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TOGGLEMUSIC Field

Keybindings..::..TOGGLEMUSIC Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TOGGLEMUSIC
Public Const TOGGLEMUSIC As Keybindings
public:
literal Keybindings TOGGLEMUSIC

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TOGGLEPERFORMANCEDISPLAY Field

Keybindings..::..TOGGLEPERFORMANCEDISPLAY Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TOGGLEPERFORMANCEDISPLAY
Public Const TOGGLEPERFORMANCEDISPLAY As Keybindings
public:
literal Keybindings TOGGLEPERFORMANCEDISPLAY

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TOGGLEPERFORMANCEPAUSE Field

Keybindings..::..TOGGLEPERFORMANCEPAUSE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TOGGLEPERFORMANCEPAUSE
Public Const TOGGLEPERFORMANCEPAUSE As Keybindings
public:
literal Keybindings TOGGLEPERFORMANCEPAUSE

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TOGGLEPERFORMANCEVALUES Field

Keybindings..::..TOGGLEPERFORMANCEVALUES Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TOGGLEPERFORMANCEVALUES
Public Const TOGGLEPERFORMANCEVALUES As Keybindings
public:
literal Keybindings TOGGLEPERFORMANCEVALUES

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TOGGLEPETBOOK Field

Keybindings..::..TOGGLEPETBOOK Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TOGGLEPETBOOK
Public Const TOGGLEPETBOOK As Keybindings
public:
literal Keybindings TOGGLEPETBOOK

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TOGGLEPLAYERBOUNDS Field

Keybindings..::..TOGGLEPLAYERBOUNDS Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TOGGLEPLAYERBOUNDS
Public Const TOGGLEPLAYERBOUNDS As Keybindings
public:
literal Keybindings TOGGLEPLAYERBOUNDS

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TOGGLEPORTALS Field

Keybindings..::..TOGGLEPORTALS Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TOGGLEPORTALS
Public Const TOGGLEPORTALS As Keybindings
public:
literal Keybindings TOGGLEPORTALS

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TOGGLEQUESTLOG Field

Keybindings..::..TOGGLEQUESTLOG Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TOGGLEQUESTLOG
Public Const TOGGLEQUESTLOG As Keybindings
public:
literal Keybindings TOGGLEQUESTLOG

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TOGGLERUN Field

Keybindings..::..TOGGLERUN Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TOGGLERUN
Public Const TOGGLERUN As Keybindings
public:
literal Keybindings TOGGLERUN

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TOGGLESOCIAL Field

Keybindings..::..TOGGLESOCIAL Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TOGGLESOCIAL
Public Const TOGGLESOCIAL As Keybindings
public:
literal Keybindings TOGGLESOCIAL

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TOGGLESOUND Field

Keybindings..::..TOGGLESOUND Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TOGGLESOUND
Public Const TOGGLESOUND As Keybindings
public:
literal Keybindings TOGGLESOUND

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TOGGLESPELLBOOK Field

Keybindings..::..TOGGLESPELLBOOK Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TOGGLESPELLBOOK
Public Const TOGGLESPELLBOOK As Keybindings
public:
literal Keybindings TOGGLESPELLBOOK

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TOGGLESTATISTICS Field

Keybindings..::..TOGGLESTATISTICS Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TOGGLESTATISTICS
Public Const TOGGLESTATISTICS As Keybindings
public:
literal Keybindings TOGGLESTATISTICS

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TOGGLESTATS Field

Keybindings..::..TOGGLESTATS Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TOGGLESTATS
Public Const TOGGLESTATS As Keybindings
public:
literal Keybindings TOGGLESTATS

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TOGGLETALENTS Field

Keybindings..::..TOGGLETALENTS Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TOGGLETALENTS
Public Const TOGGLETALENTS As Keybindings
public:
literal Keybindings TOGGLETALENTS

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TOGGLETRIS Field

Keybindings..::..TOGGLETRIS Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TOGGLETRIS
Public Const TOGGLETRIS As Keybindings
public:
literal Keybindings TOGGLETRIS

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TOGGLEUI Field

Keybindings..::..TOGGLEUI Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TOGGLEUI
Public Const TOGGLEUI As Keybindings
public:
literal Keybindings TOGGLEUI

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TOGGLEWORLDMAP Field

Keybindings..::..TOGGLEWORLDMAP Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TOGGLEWORLDMAP
Public Const TOGGLEWORLDMAP As Keybindings
public:
literal Keybindings TOGGLEWORLDMAP

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TOGGLEWORLDSTATESCORES Field

Keybindings..::..TOGGLEWORLDSTATESCORES Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TOGGLEWORLDSTATESCORES
Public Const TOGGLEWORLDSTATESCORES As Keybindings
public:
literal Keybindings TOGGLEWORLDSTATESCORES

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TURNLEFT Field

Keybindings..::..TURNLEFT Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TURNLEFT
Public Const TURNLEFT As Keybindings
public:
literal Keybindings TURNLEFT

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TURNORACTION Field

Keybindings..::..TURNORACTION Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TURNORACTION
Public Const TURNORACTION As Keybindings
public:
literal Keybindings TURNORACTION

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


TURNRIGHT Field

Keybindings..::..TURNRIGHT Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings TURNRIGHT
Public Const TURNRIGHT As Keybindings
public:
literal Keybindings TURNRIGHT

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


VEHICLEAIMDECREMENT Field

Keybindings..::..VEHICLEAIMDECREMENT Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings VEHICLEAIMDECREMENT
Public Const VEHICLEAIMDECREMENT As Keybindings
public:
literal Keybindings VEHICLEAIMDECREMENT

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


VEHICLEAIMINCREMENT Field

Keybindings..::..VEHICLEAIMINCREMENT Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings VEHICLEAIMINCREMENT
Public Const VEHICLEAIMINCREMENT As Keybindings
public:
literal Keybindings VEHICLEAIMINCREMENT

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


VEHICLEEXIT Field

Keybindings..::..VEHICLEEXIT Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings VEHICLEEXIT
Public Const VEHICLEEXIT As Keybindings
public:
literal Keybindings VEHICLEEXIT

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


VEHICLENEXTSEAT Field

Keybindings..::..VEHICLENEXTSEAT Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings VEHICLENEXTSEAT
Public Const VEHICLENEXTSEAT As Keybindings
public:
literal Keybindings VEHICLENEXTSEAT

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


VEHICLEPREVSEAT Field

Keybindings..::..VEHICLEPREVSEAT Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Keybindings VEHICLEPREVSEAT
Public Const VEHICLEPREVSEAT As Keybindings
public:
literal Keybindings VEHICLEPREVSEAT

See Also

Keybindings Enumeration
wManager.Wow.Enums Namespace


Alliance Field

Landmarks..::..Alliance Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks Alliance
Public Const Alliance As Landmarks
public:
literal Landmarks Alliance

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


AllianCecrest Field

Landmarks..::..AllianCecrest Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks AllianCecrest
Public Const AllianCecrest As Landmarks
public:
literal Landmarks AllianCecrest

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


AllianCecrestuncaptured Field

Landmarks..::..AllianCecrestuncaptured Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks AllianCecrestuncaptured
Public Const AllianCecrestuncaptured As Landmarks
public:
literal Landmarks AllianCecrestuncaptured

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


AllianceDamaged Field

Landmarks..::..AllianceDamaged Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks AllianceDamaged
Public Const AllianceDamaged As Landmarks
public:
literal Landmarks AllianceDamaged

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


AllianceDestroyed Field

Landmarks..::..AllianceDestroyed Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks AllianceDestroyed
Public Const AllianceDestroyed As Landmarks
public:
literal Landmarks AllianceDestroyed

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


Blacksmith Field

Landmarks..::..Blacksmith Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks Blacksmith
Public Const Blacksmith As Landmarks
public:
literal Landmarks Blacksmith

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


BlacksmithAlliance Field

Landmarks..::..BlacksmithAlliance Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks BlacksmithAlliance
Public Const BlacksmithAlliance As Landmarks
public:
literal Landmarks BlacksmithAlliance

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


BlacksmithAllianceAssaulted Field

Landmarks..::..BlacksmithAllianceAssaulted Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks BlacksmithAllianceAssaulted
Public Const BlacksmithAllianceAssaulted As Landmarks
public:
literal Landmarks BlacksmithAllianceAssaulted

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


BlacksmithHorde Field

Landmarks..::..BlacksmithHorde Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks BlacksmithHorde
Public Const BlacksmithHorde As Landmarks
public:
literal Landmarks BlacksmithHorde

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


BlacksmithHordeAssaulted Field

Landmarks..::..BlacksmithHordeAssaulted Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks BlacksmithHordeAssaulted
Public Const BlacksmithHordeAssaulted As Landmarks
public:
literal Landmarks BlacksmithHordeAssaulted

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


Bridge Field

Landmarks..::..Bridge Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks Bridge
Public Const Bridge As Landmarks
public:
literal Landmarks Bridge

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


BridgeAlliance Field

Landmarks..::..BridgeAlliance Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks BridgeAlliance
Public Const BridgeAlliance As Landmarks
public:
literal Landmarks BridgeAlliance

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


BridgeAllianceDamaged Field

Landmarks..::..BridgeAllianceDamaged Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks BridgeAllianceDamaged
Public Const BridgeAllianceDamaged As Landmarks
public:
literal Landmarks BridgeAllianceDamaged

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


BridgeAllianceDestroyed Field

Landmarks..::..BridgeAllianceDestroyed Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks BridgeAllianceDestroyed
Public Const BridgeAllianceDestroyed As Landmarks
public:
literal Landmarks BridgeAllianceDestroyed

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


Bridgedamaged Field

Landmarks..::..Bridgedamaged Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks Bridgedamaged
Public Const Bridgedamaged As Landmarks
public:
literal Landmarks Bridgedamaged

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


Bridgedestroyed Field

Landmarks..::..Bridgedestroyed Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks Bridgedestroyed
Public Const Bridgedestroyed As Landmarks
public:
literal Landmarks Bridgedestroyed

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


BridgeHorde Field

Landmarks..::..BridgeHorde Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks BridgeHorde
Public Const BridgeHorde As Landmarks
public:
literal Landmarks BridgeHorde

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


BridgeHordeDamaged Field

Landmarks..::..BridgeHordeDamaged Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks BridgeHordeDamaged
Public Const BridgeHordeDamaged As Landmarks
public:
literal Landmarks BridgeHordeDamaged

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


BridgeHordeDestroyed Field

Landmarks..::..BridgeHordeDestroyed Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks BridgeHordeDestroyed
Public Const BridgeHordeDestroyed As Landmarks
public:
literal Landmarks BridgeHordeDestroyed

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


City Field

Landmarks..::..City Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks City
Public Const City As Landmarks
public:
literal Landmarks City

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


Combat Field

Landmarks..::..Combat Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks Combat
Public Const Combat As Landmarks
public:
literal Landmarks Combat

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


Docks Field

Landmarks..::..Docks Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks Docks
Public Const Docks As Landmarks
public:
literal Landmarks Docks

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


DocksAlliance Field

Landmarks..::..DocksAlliance Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks DocksAlliance
Public Const DocksAlliance As Landmarks
public:
literal Landmarks DocksAlliance

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


DocksAllianceAssaulted Field

Landmarks..::..DocksAllianceAssaulted Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks DocksAllianceAssaulted
Public Const DocksAllianceAssaulted As Landmarks
public:
literal Landmarks DocksAllianceAssaulted

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


DocksHorde Field

Landmarks..::..DocksHorde Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks DocksHorde
Public Const DocksHorde As Landmarks
public:
literal Landmarks DocksHorde

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


DocksHordeAssaulted Field

Landmarks..::..DocksHordeAssaulted Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks DocksHordeAssaulted
Public Const DocksHordeAssaulted As Landmarks
public:
literal Landmarks DocksHordeAssaulted

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


Farm Field

Landmarks..::..Farm Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks Farm
Public Const Farm As Landmarks
public:
literal Landmarks Farm

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


FarmAlliance Field

Landmarks..::..FarmAlliance Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks FarmAlliance
Public Const FarmAlliance As Landmarks
public:
literal Landmarks FarmAlliance

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


FarmAllianceAssaulted Field

Landmarks..::..FarmAllianceAssaulted Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks FarmAllianceAssaulted
Public Const FarmAllianceAssaulted As Landmarks
public:
literal Landmarks FarmAllianceAssaulted

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


FarmHorde Field

Landmarks..::..FarmHorde Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks FarmHorde
Public Const FarmHorde As Landmarks
public:
literal Landmarks FarmHorde

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


FarmHordeAssaulted Field

Landmarks..::..FarmHordeAssaulted Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks FarmHordeAssaulted
Public Const FarmHordeAssaulted As Landmarks
public:
literal Landmarks FarmHordeAssaulted

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


Flag Field

Landmarks..::..Flag Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks Flag
Public Const Flag As Landmarks
public:
literal Landmarks Flag

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


FlagAlliance Field

Landmarks..::..FlagAlliance Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks FlagAlliance
Public Const FlagAlliance As Landmarks
public:
literal Landmarks FlagAlliance

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


FlagHorde Field

Landmarks..::..FlagHorde Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks FlagHorde
Public Const FlagHorde As Landmarks
public:
literal Landmarks FlagHorde

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


Flags Field

Landmarks..::..Flags Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks Flags
Public Const Flags As Landmarks
public:
literal Landmarks Flags

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


Gate Field

Landmarks..::..Gate Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks Gate
Public Const Gate As Landmarks
public:
literal Landmarks Gate

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


GateAlliance Field

Landmarks..::..GateAlliance Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks GateAlliance
Public Const GateAlliance As Landmarks
public:
literal Landmarks GateAlliance

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


GateAllianceDamaged Field

Landmarks..::..GateAllianceDamaged Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks GateAllianceDamaged
Public Const GateAllianceDamaged As Landmarks
public:
literal Landmarks GateAllianceDamaged

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


GateAllianceDestroyed Field

Landmarks..::..GateAllianceDestroyed Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks GateAllianceDestroyed
Public Const GateAllianceDestroyed As Landmarks
public:
literal Landmarks GateAllianceDestroyed

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


Gatedamaged Field

Landmarks..::..Gatedamaged Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks Gatedamaged
Public Const Gatedamaged As Landmarks
public:
literal Landmarks Gatedamaged

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


Gatedestroyed Field

Landmarks..::..Gatedestroyed Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks Gatedestroyed
Public Const Gatedestroyed As Landmarks
public:
literal Landmarks Gatedestroyed

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


Gategreen Field

Landmarks..::..Gategreen Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks Gategreen
Public Const Gategreen As Landmarks
public:
literal Landmarks Gategreen

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


GategreenDamaged Field

Landmarks..::..GategreenDamaged Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks GategreenDamaged
Public Const GategreenDamaged As Landmarks
public:
literal Landmarks GategreenDamaged

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


GategreenDestroyed Field

Landmarks..::..GategreenDestroyed Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks GategreenDestroyed
Public Const GategreenDestroyed As Landmarks
public:
literal Landmarks GategreenDestroyed

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


GateHorde Field

Landmarks..::..GateHorde Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks GateHorde
Public Const GateHorde As Landmarks
public:
literal Landmarks GateHorde

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


GateHordeDamaged Field

Landmarks..::..GateHordeDamaged Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks GateHordeDamaged
Public Const GateHordeDamaged As Landmarks
public:
literal Landmarks GateHordeDamaged

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


GateHordeDestroyed Field

Landmarks..::..GateHordeDestroyed Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks GateHordeDestroyed
Public Const GateHordeDestroyed As Landmarks
public:
literal Landmarks GateHordeDestroyed

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


Gatepurple Field

Landmarks..::..Gatepurple Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks Gatepurple
Public Const Gatepurple As Landmarks
public:
literal Landmarks Gatepurple

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


GatepurpleDamaged Field

Landmarks..::..GatepurpleDamaged Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks GatepurpleDamaged
Public Const GatepurpleDamaged As Landmarks
public:
literal Landmarks GatepurpleDamaged

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


GatepurpleDestroyed Field

Landmarks..::..GatepurpleDestroyed Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks GatepurpleDestroyed
Public Const GatepurpleDestroyed As Landmarks
public:
literal Landmarks GatepurpleDestroyed

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


Gateyellow Field

Landmarks..::..Gateyellow Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks Gateyellow
Public Const Gateyellow As Landmarks
public:
literal Landmarks Gateyellow

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


GateyellowDamaged Field

Landmarks..::..GateyellowDamaged Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks GateyellowDamaged
Public Const GateyellowDamaged As Landmarks
public:
literal Landmarks GateyellowDamaged

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


GateyellowDestroyed Field

Landmarks..::..GateyellowDestroyed Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks GateyellowDestroyed
Public Const GateyellowDestroyed As Landmarks
public:
literal Landmarks GateyellowDestroyed

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


GoldMine Field

Landmarks..::..GoldMine Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks GoldMine
Public Const GoldMine As Landmarks
public:
literal Landmarks GoldMine

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


GoldMineAlliance Field

Landmarks..::..GoldMineAlliance Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks GoldMineAlliance
Public Const GoldMineAlliance As Landmarks
public:
literal Landmarks GoldMineAlliance

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


GoldMineAllianceAssaulted Field

Landmarks..::..GoldMineAllianceAssaulted Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks GoldMineAllianceAssaulted
Public Const GoldMineAllianceAssaulted As Landmarks
public:
literal Landmarks GoldMineAllianceAssaulted

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


GoldMineHorde Field

Landmarks..::..GoldMineHorde Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks GoldMineHorde
Public Const GoldMineHorde As Landmarks
public:
literal Landmarks GoldMineHorde

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


GoldMineHordeAssaulted Field

Landmarks..::..GoldMineHordeAssaulted Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks GoldMineHordeAssaulted
Public Const GoldMineHordeAssaulted As Landmarks
public:
literal Landmarks GoldMineHordeAssaulted

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


Gravestone Field

Landmarks..::..Gravestone Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks Gravestone
Public Const Gravestone As Landmarks
public:
literal Landmarks Gravestone

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


GraveyardAlliance Field

Landmarks..::..GraveyardAlliance Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks GraveyardAlliance
Public Const GraveyardAlliance As Landmarks
public:
literal Landmarks GraveyardAlliance

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


GraveyardAllianceAssaulted Field

Landmarks..::..GraveyardAllianceAssaulted Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks GraveyardAllianceAssaulted
Public Const GraveyardAllianceAssaulted As Landmarks
public:
literal Landmarks GraveyardAllianceAssaulted

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


GraveyardHorde Field

Landmarks..::..GraveyardHorde Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks GraveyardHorde
Public Const GraveyardHorde As Landmarks
public:
literal Landmarks GraveyardHorde

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


GraveyardHordeAssaulted Field

Landmarks..::..GraveyardHordeAssaulted Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks GraveyardHordeAssaulted
Public Const GraveyardHordeAssaulted As Landmarks
public:
literal Landmarks GraveyardHordeAssaulted

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


Hangar Field

Landmarks..::..Hangar Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks Hangar
Public Const Hangar As Landmarks
public:
literal Landmarks Hangar

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


HangarAlliance Field

Landmarks..::..HangarAlliance Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks HangarAlliance
Public Const HangarAlliance As Landmarks
public:
literal Landmarks HangarAlliance

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


HangarAllianceAssaulted Field

Landmarks..::..HangarAllianceAssaulted Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks HangarAllianceAssaulted
Public Const HangarAllianceAssaulted As Landmarks
public:
literal Landmarks HangarAllianceAssaulted

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


HangarHorde Field

Landmarks..::..HangarHorde Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks HangarHorde
Public Const HangarHorde As Landmarks
public:
literal Landmarks HangarHorde

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


HangarHordeAssaulted Field

Landmarks..::..HangarHordeAssaulted Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks HangarHordeAssaulted
Public Const HangarHordeAssaulted As Landmarks
public:
literal Landmarks HangarHordeAssaulted

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


Horde Field

Landmarks..::..Horde Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks Horde
Public Const Horde As Landmarks
public:
literal Landmarks Horde

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


HordeCrest Field

Landmarks..::..HordeCrest Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks HordeCrest
Public Const HordeCrest As Landmarks
public:
literal Landmarks HordeCrest

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


HordeCrestuncaptured Field

Landmarks..::..HordeCrestuncaptured Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks HordeCrestuncaptured
Public Const HordeCrestuncaptured As Landmarks
public:
literal Landmarks HordeCrestuncaptured

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


HordeDamaged Field

Landmarks..::..HordeDamaged Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks HordeDamaged
Public Const HordeDamaged As Landmarks
public:
literal Landmarks HordeDamaged

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


HordeDestroyed Field

Landmarks..::..HordeDestroyed Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks HordeDestroyed
Public Const HordeDestroyed As Landmarks
public:
literal Landmarks HordeDestroyed

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


Invisible Field

Landmarks..::..Invisible Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks Invisible
Public Const Invisible As Landmarks
public:
literal Landmarks Invisible

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


LumberMill Field

Landmarks..::..LumberMill Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks LumberMill
Public Const LumberMill As Landmarks
public:
literal Landmarks LumberMill

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


LumberMillAlliance Field

Landmarks..::..LumberMillAlliance Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks LumberMillAlliance
Public Const LumberMillAlliance As Landmarks
public:
literal Landmarks LumberMillAlliance

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


LumberMillAllianceAssaulted Field

Landmarks..::..LumberMillAllianceAssaulted Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks LumberMillAllianceAssaulted
Public Const LumberMillAllianceAssaulted As Landmarks
public:
literal Landmarks LumberMillAllianceAssaulted

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


LumberMillHorde Field

Landmarks..::..LumberMillHorde Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks LumberMillHorde
Public Const LumberMillHorde As Landmarks
public:
literal Landmarks LumberMillHorde

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


LumberMillHordeAssaulted Field

Landmarks..::..LumberMillHordeAssaulted Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks LumberMillHordeAssaulted
Public Const LumberMillHordeAssaulted As Landmarks
public:
literal Landmarks LumberMillHordeAssaulted

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


Mine Field

Landmarks..::..Mine Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks Mine
Public Const Mine As Landmarks
public:
literal Landmarks Mine

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


MineAlliance Field

Landmarks..::..MineAlliance Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks MineAlliance
Public Const MineAlliance As Landmarks
public:
literal Landmarks MineAlliance

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


MineHorde Field

Landmarks..::..MineHorde Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks MineHorde
Public Const MineHorde As Landmarks
public:
literal Landmarks MineHorde

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


Refinery Field

Landmarks..::..Refinery Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks Refinery
Public Const Refinery As Landmarks
public:
literal Landmarks Refinery

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


RefineryAlliance Field

Landmarks..::..RefineryAlliance Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks RefineryAlliance
Public Const RefineryAlliance As Landmarks
public:
literal Landmarks RefineryAlliance

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


RefineryAllianceAssaulted Field

Landmarks..::..RefineryAllianceAssaulted Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks RefineryAllianceAssaulted
Public Const RefineryAllianceAssaulted As Landmarks
public:
literal Landmarks RefineryAllianceAssaulted

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


RefineryHorde Field

Landmarks..::..RefineryHorde Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks RefineryHorde
Public Const RefineryHorde As Landmarks
public:
literal Landmarks RefineryHorde

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


RefineryHordeAssaulted Field

Landmarks..::..RefineryHordeAssaulted Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks RefineryHordeAssaulted
Public Const RefineryHordeAssaulted As Landmarks
public:
literal Landmarks RefineryHordeAssaulted

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


SiegeWorkshop Field

Landmarks..::..SiegeWorkshop Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks SiegeWorkshop
Public Const SiegeWorkshop As Landmarks
public:
literal Landmarks SiegeWorkshop

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


SiegeWorkshopAlliance Field

Landmarks..::..SiegeWorkshopAlliance Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks SiegeWorkshopAlliance
Public Const SiegeWorkshopAlliance As Landmarks
public:
literal Landmarks SiegeWorkshopAlliance

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


SiegeWorkshopAllianceAssaulted Field

Landmarks..::..SiegeWorkshopAllianceAssaulted Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks SiegeWorkshopAllianceAssaulted
Public Const SiegeWorkshopAllianceAssaulted As Landmarks
public:
literal Landmarks SiegeWorkshopAllianceAssaulted

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


SiegeWorkshopHorde Field

Landmarks..::..SiegeWorkshopHorde Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks SiegeWorkshopHorde
Public Const SiegeWorkshopHorde As Landmarks
public:
literal Landmarks SiegeWorkshopHorde

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


SiegeWorkshopHordeAssaulted Field

Landmarks..::..SiegeWorkshopHordeAssaulted Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks SiegeWorkshopHordeAssaulted
Public Const SiegeWorkshopHordeAssaulted As Landmarks
public:
literal Landmarks SiegeWorkshopHordeAssaulted

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


Skullorange Field

Landmarks..::..Skullorange Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks Skullorange
Public Const Skullorange As Landmarks
public:
literal Landmarks Skullorange

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


Skullpurple Field

Landmarks..::..Skullpurple Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks Skullpurple
Public Const Skullpurple As Landmarks
public:
literal Landmarks Skullpurple

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


StablesAlliance Field

Landmarks..::..StablesAlliance Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks StablesAlliance
Public Const StablesAlliance As Landmarks
public:
literal Landmarks StablesAlliance

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


StablesAllianceAssaulted Field

Landmarks..::..StablesAllianceAssaulted Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks StablesAllianceAssaulted
Public Const StablesAllianceAssaulted As Landmarks
public:
literal Landmarks StablesAllianceAssaulted

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


StablesHorde Field

Landmarks..::..StablesHorde Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks StablesHorde
Public Const StablesHorde As Landmarks
public:
literal Landmarks StablesHorde

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


StablesHordeAssaulted Field

Landmarks..::..StablesHordeAssaulted Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks StablesHordeAssaulted
Public Const StablesHordeAssaulted As Landmarks
public:
literal Landmarks StablesHordeAssaulted

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


Stablesneutral Field

Landmarks..::..Stablesneutral Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks Stablesneutral
Public Const Stablesneutral As Landmarks
public:
literal Landmarks Stablesneutral

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


TowerAlliance Field

Landmarks..::..TowerAlliance Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks TowerAlliance
Public Const TowerAlliance As Landmarks
public:
literal Landmarks TowerAlliance

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


TowerAllianceAssaulted Field

Landmarks..::..TowerAllianceAssaulted Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks TowerAllianceAssaulted
Public Const TowerAllianceAssaulted As Landmarks
public:
literal Landmarks TowerAllianceAssaulted

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


TowerAllianceDamaged Field

Landmarks..::..TowerAllianceDamaged Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks TowerAllianceDamaged
Public Const TowerAllianceDamaged As Landmarks
public:
literal Landmarks TowerAllianceDamaged

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


TowerAllianceDestroyed Field

Landmarks..::..TowerAllianceDestroyed Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks TowerAllianceDestroyed
Public Const TowerAllianceDestroyed As Landmarks
public:
literal Landmarks TowerAllianceDestroyed

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


Towerdamged Field

Landmarks..::..Towerdamged Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks Towerdamged
Public Const Towerdamged As Landmarks
public:
literal Landmarks Towerdamged

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


Towerdestroyed Field

Landmarks..::..Towerdestroyed Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks Towerdestroyed
Public Const Towerdestroyed As Landmarks
public:
literal Landmarks Towerdestroyed

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


Towergreen Field

Landmarks..::..Towergreen Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks Towergreen
Public Const Towergreen As Landmarks
public:
literal Landmarks Towergreen

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


TowergreenDamaged Field

Landmarks..::..TowergreenDamaged Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks TowergreenDamaged
Public Const TowergreenDamaged As Landmarks
public:
literal Landmarks TowergreenDamaged

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


TowergreenDestroyed Field

Landmarks..::..TowergreenDestroyed Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks TowergreenDestroyed
Public Const TowergreenDestroyed As Landmarks
public:
literal Landmarks TowergreenDestroyed

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


TowerHorde Field

Landmarks..::..TowerHorde Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks TowerHorde
Public Const TowerHorde As Landmarks
public:
literal Landmarks TowerHorde

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


TowerHordeAssaulted Field

Landmarks..::..TowerHordeAssaulted Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks TowerHordeAssaulted
Public Const TowerHordeAssaulted As Landmarks
public:
literal Landmarks TowerHordeAssaulted

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


TowerHordeDamaged Field

Landmarks..::..TowerHordeDamaged Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks TowerHordeDamaged
Public Const TowerHordeDamaged As Landmarks
public:
literal Landmarks TowerHordeDamaged

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


TowerHordeDestroyed Field

Landmarks..::..TowerHordeDestroyed Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks TowerHordeDestroyed
Public Const TowerHordeDestroyed As Landmarks
public:
literal Landmarks TowerHordeDestroyed

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


Toweryellow Field

Landmarks..::..Toweryellow Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks Toweryellow
Public Const Toweryellow As Landmarks
public:
literal Landmarks Toweryellow

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


ToweryellowDamaged Field

Landmarks..::..ToweryellowDamaged Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks ToweryellowDamaged
Public Const ToweryellowDamaged As Landmarks
public:
literal Landmarks ToweryellowDamaged

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


ToweryellowDestroyed Field

Landmarks..::..ToweryellowDestroyed Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks ToweryellowDestroyed
Public Const ToweryellowDestroyed As Landmarks
public:
literal Landmarks ToweryellowDestroyed

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


Town Field

Landmarks..::..Town Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks Town
Public Const Town As Landmarks
public:
literal Landmarks Town

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


Unknown Field

Landmarks..::..Unknown Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks Unknown
Public Const Unknown As Landmarks
public:
literal Landmarks Unknown

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


WallAllianceHorizontal Field

Landmarks..::..WallAllianceHorizontal Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks WallAllianceHorizontal
Public Const WallAllianceHorizontal As Landmarks
public:
literal Landmarks WallAllianceHorizontal

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


WallAllianceHorizontalDamaged Field

Landmarks..::..WallAllianceHorizontalDamaged Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks WallAllianceHorizontalDamaged
Public Const WallAllianceHorizontalDamaged As Landmarks
public:
literal Landmarks WallAllianceHorizontalDamaged

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


WallAllianceHorizontalDestroyed Field

Landmarks..::..WallAllianceHorizontalDestroyed Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks WallAllianceHorizontalDestroyed
Public Const WallAllianceHorizontalDestroyed As Landmarks
public:
literal Landmarks WallAllianceHorizontalDestroyed

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


WallAllianceVertical Field

Landmarks..::..WallAllianceVertical Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks WallAllianceVertical
Public Const WallAllianceVertical As Landmarks
public:
literal Landmarks WallAllianceVertical

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


WallAllianceVerticalDamaged Field

Landmarks..::..WallAllianceVerticalDamaged Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks WallAllianceVerticalDamaged
Public Const WallAllianceVerticalDamaged As Landmarks
public:
literal Landmarks WallAllianceVerticalDamaged

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


WallAllianceVerticalDestroyed Field

Landmarks..::..WallAllianceVerticalDestroyed Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks WallAllianceVerticalDestroyed
Public Const WallAllianceVerticalDestroyed As Landmarks
public:
literal Landmarks WallAllianceVerticalDestroyed

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


WallHordeHorizontal Field

Landmarks..::..WallHordeHorizontal Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks WallHordeHorizontal
Public Const WallHordeHorizontal As Landmarks
public:
literal Landmarks WallHordeHorizontal

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


WallHordeHorizontalDamaged Field

Landmarks..::..WallHordeHorizontalDamaged Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks WallHordeHorizontalDamaged
Public Const WallHordeHorizontalDamaged As Landmarks
public:
literal Landmarks WallHordeHorizontalDamaged

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


WallHordeHorizontalDestroyed Field

Landmarks..::..WallHordeHorizontalDestroyed Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks WallHordeHorizontalDestroyed
Public Const WallHordeHorizontalDestroyed As Landmarks
public:
literal Landmarks WallHordeHorizontalDestroyed

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


WallHordeVertical Field

Landmarks..::..WallHordeVertical Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks WallHordeVertical
Public Const WallHordeVertical As Landmarks
public:
literal Landmarks WallHordeVertical

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


WallHordeVerticalDamaged Field

Landmarks..::..WallHordeVerticalDamaged Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks WallHordeVerticalDamaged
Public Const WallHordeVerticalDamaged As Landmarks
public:
literal Landmarks WallHordeVerticalDamaged

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


WallHordeVerticalDestroyed Field

Landmarks..::..WallHordeVerticalDestroyed Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks WallHordeVerticalDestroyed
Public Const WallHordeVerticalDestroyed As Landmarks
public:
literal Landmarks WallHordeVerticalDestroyed

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


Wallhorizontal Field

Landmarks..::..Wallhorizontal Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks Wallhorizontal
Public Const Wallhorizontal As Landmarks
public:
literal Landmarks Wallhorizontal

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


WallhorizontalDamaged Field

Landmarks..::..WallhorizontalDamaged Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks WallhorizontalDamaged
Public Const WallhorizontalDamaged As Landmarks
public:
literal Landmarks WallhorizontalDamaged

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


WallhorizontalDestroyed Field

Landmarks..::..WallhorizontalDestroyed Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks WallhorizontalDestroyed
Public Const WallhorizontalDestroyed As Landmarks
public:
literal Landmarks WallhorizontalDestroyed

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


Wallvertical Field

Landmarks..::..Wallvertical Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks Wallvertical
Public Const Wallvertical As Landmarks
public:
literal Landmarks Wallvertical

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


WallverticalDamaged Field

Landmarks..::..WallverticalDamaged Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks WallverticalDamaged
Public Const WallverticalDamaged As Landmarks
public:
literal Landmarks WallverticalDamaged

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


WallverticalDestroyed Field

Landmarks..::..WallverticalDestroyed Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks WallverticalDestroyed
Public Const WallverticalDestroyed As Landmarks
public:
literal Landmarks WallverticalDestroyed

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


White Field

Landmarks..::..White Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks White
Public Const White As Landmarks
public:
literal Landmarks White

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


White0 Field

Landmarks..::..White0 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks White0
Public Const White0 As Landmarks
public:
literal Landmarks White0

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


White1 Field

Landmarks..::..White1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks White1
Public Const White1 As Landmarks
public:
literal Landmarks White1

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


White2 Field

Landmarks..::..White2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks White2
Public Const White2 As Landmarks
public:
literal Landmarks White2

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


White3 Field

Landmarks..::..White3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks White3
Public Const White3 As Landmarks
public:
literal Landmarks White3

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


White4 Field

Landmarks..::..White4 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks White4
Public Const White4 As Landmarks
public:
literal Landmarks White4

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


White5 Field

Landmarks..::..White5 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks White5
Public Const White5 As Landmarks
public:
literal Landmarks White5

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


White6 Field

Landmarks..::..White6 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks White6
Public Const White6 As Landmarks
public:
literal Landmarks White6

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


White7 Field

Landmarks..::..White7 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks White7
Public Const White7 As Landmarks
public:
literal Landmarks White7

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


White8 Field

Landmarks..::..White8 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks White8
Public Const White8 As Landmarks
public:
literal Landmarks White8

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


White9 Field

Landmarks..::..White9 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks White9
Public Const White9 As Landmarks
public:
literal Landmarks White9

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


Workshop Field

Landmarks..::..Workshop Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks Workshop
Public Const Workshop As Landmarks
public:
literal Landmarks Workshop

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


WorkshopAlliance Field

Landmarks..::..WorkshopAlliance Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks WorkshopAlliance
Public Const WorkshopAlliance As Landmarks
public:
literal Landmarks WorkshopAlliance

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


WorkshopAllianceDamaged Field

Landmarks..::..WorkshopAllianceDamaged Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks WorkshopAllianceDamaged
Public Const WorkshopAllianceDamaged As Landmarks
public:
literal Landmarks WorkshopAllianceDamaged

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


WorkshopAllianceDestroyed Field

Landmarks..::..WorkshopAllianceDestroyed Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks WorkshopAllianceDestroyed
Public Const WorkshopAllianceDestroyed As Landmarks
public:
literal Landmarks WorkshopAllianceDestroyed

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


Workshopdamaged Field

Landmarks..::..Workshopdamaged Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks Workshopdamaged
Public Const Workshopdamaged As Landmarks
public:
literal Landmarks Workshopdamaged

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


Workshopdestroyed Field

Landmarks..::..Workshopdestroyed Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks Workshopdestroyed
Public Const Workshopdestroyed As Landmarks
public:
literal Landmarks Workshopdestroyed

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


WorkshopHorde Field

Landmarks..::..WorkshopHorde Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks WorkshopHorde
Public Const WorkshopHorde As Landmarks
public:
literal Landmarks WorkshopHorde

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


WorkshopHordeDamaged Field

Landmarks..::..WorkshopHordeDamaged Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks WorkshopHordeDamaged
Public Const WorkshopHordeDamaged As Landmarks
public:
literal Landmarks WorkshopHordeDamaged

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


WorkshopHordeDestroyed Field

Landmarks..::..WorkshopHordeDestroyed Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Landmarks WorkshopHordeDestroyed
Public Const WorkshopHordeDestroyed As Landmarks
public:
literal Landmarks WorkshopHordeDestroyed

See Also

Landmarks Enumeration
wManager.Wow.Enums Namespace


ACHIEVEMENT_EARNED Field

LuaEventsId..::..ACHIEVEMENT_EARNED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId ACHIEVEMENT_EARNED
Public Const ACHIEVEMENT_EARNED As LuaEventsId
public:
literal LuaEventsId ACHIEVEMENT_EARNED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


ACTIONBAR_HIDEGRID Field

LuaEventsId..::..ACTIONBAR_HIDEGRID Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId ACTIONBAR_HIDEGRID
Public Const ACTIONBAR_HIDEGRID As LuaEventsId
public:
literal LuaEventsId ACTIONBAR_HIDEGRID

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


ACTIONBAR_PAGE_CHANGED Field

LuaEventsId..::..ACTIONBAR_PAGE_CHANGED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId ACTIONBAR_PAGE_CHANGED
Public Const ACTIONBAR_PAGE_CHANGED As LuaEventsId
public:
literal LuaEventsId ACTIONBAR_PAGE_CHANGED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


ACTIONBAR_SHOWGRID Field

LuaEventsId..::..ACTIONBAR_SHOWGRID Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId ACTIONBAR_SHOWGRID
Public Const ACTIONBAR_SHOWGRID As LuaEventsId
public:
literal LuaEventsId ACTIONBAR_SHOWGRID

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


ACTIONBAR_SLOT_CHANGED Field

LuaEventsId..::..ACTIONBAR_SLOT_CHANGED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId ACTIONBAR_SLOT_CHANGED
Public Const ACTIONBAR_SLOT_CHANGED As LuaEventsId
public:
literal LuaEventsId ACTIONBAR_SLOT_CHANGED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


ACTIONBAR_UPDATE_COOLDOWN Field

LuaEventsId..::..ACTIONBAR_UPDATE_COOLDOWN Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId ACTIONBAR_UPDATE_COOLDOWN
Public Const ACTIONBAR_UPDATE_COOLDOWN As LuaEventsId
public:
literal LuaEventsId ACTIONBAR_UPDATE_COOLDOWN

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


ACTIONBAR_UPDATE_STATE Field

LuaEventsId..::..ACTIONBAR_UPDATE_STATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId ACTIONBAR_UPDATE_STATE
Public Const ACTIONBAR_UPDATE_STATE As LuaEventsId
public:
literal LuaEventsId ACTIONBAR_UPDATE_STATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


ACTIONBAR_UPDATE_USABLE Field

LuaEventsId..::..ACTIONBAR_UPDATE_USABLE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId ACTIONBAR_UPDATE_USABLE
Public Const ACTIONBAR_UPDATE_USABLE As LuaEventsId
public:
literal LuaEventsId ACTIONBAR_UPDATE_USABLE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


ACTIVE_TALENT_GROUP_CHANGED Field

LuaEventsId..::..ACTIVE_TALENT_GROUP_CHANGED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId ACTIVE_TALENT_GROUP_CHANGED
Public Const ACTIVE_TALENT_GROUP_CHANGED As LuaEventsId
public:
literal LuaEventsId ACTIVE_TALENT_GROUP_CHANGED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


ADDON_ACTION_BLOCKED Field

LuaEventsId..::..ADDON_ACTION_BLOCKED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId ADDON_ACTION_BLOCKED
Public Const ADDON_ACTION_BLOCKED As LuaEventsId
public:
literal LuaEventsId ADDON_ACTION_BLOCKED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


ADDON_ACTION_FORBIDDEN Field

LuaEventsId..::..ADDON_ACTION_FORBIDDEN Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId ADDON_ACTION_FORBIDDEN
Public Const ADDON_ACTION_FORBIDDEN As LuaEventsId
public:
literal LuaEventsId ADDON_ACTION_FORBIDDEN

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


ADDON_LOADED Field

LuaEventsId..::..ADDON_LOADED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId ADDON_LOADED
Public Const ADDON_LOADED As LuaEventsId
public:
literal LuaEventsId ADDON_LOADED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


AREA_SPIRIT_HEALER_IN_RANGE Field

LuaEventsId..::..AREA_SPIRIT_HEALER_IN_RANGE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId AREA_SPIRIT_HEALER_IN_RANGE
Public Const AREA_SPIRIT_HEALER_IN_RANGE As LuaEventsId
public:
literal LuaEventsId AREA_SPIRIT_HEALER_IN_RANGE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


AREA_SPIRIT_HEALER_OUT_OF_RANGE Field

LuaEventsId..::..AREA_SPIRIT_HEALER_OUT_OF_RANGE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId AREA_SPIRIT_HEALER_OUT_OF_RANGE
Public Const AREA_SPIRIT_HEALER_OUT_OF_RANGE As LuaEventsId
public:
literal LuaEventsId AREA_SPIRIT_HEALER_OUT_OF_RANGE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


ARENA_OPPONENT_UPDATE Field

LuaEventsId..::..ARENA_OPPONENT_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId ARENA_OPPONENT_UPDATE
Public Const ARENA_OPPONENT_UPDATE As LuaEventsId
public:
literal LuaEventsId ARENA_OPPONENT_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


ARENA_SEASON_WORLD_STATE Field

LuaEventsId..::..ARENA_SEASON_WORLD_STATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId ARENA_SEASON_WORLD_STATE
Public Const ARENA_SEASON_WORLD_STATE As LuaEventsId
public:
literal LuaEventsId ARENA_SEASON_WORLD_STATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


ARENA_TEAM_INVITE_REQUEST Field

LuaEventsId..::..ARENA_TEAM_INVITE_REQUEST Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId ARENA_TEAM_INVITE_REQUEST
Public Const ARENA_TEAM_INVITE_REQUEST As LuaEventsId
public:
literal LuaEventsId ARENA_TEAM_INVITE_REQUEST

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


ARENA_TEAM_ROSTER_UPDATE Field

LuaEventsId..::..ARENA_TEAM_ROSTER_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId ARENA_TEAM_ROSTER_UPDATE
Public Const ARENA_TEAM_ROSTER_UPDATE As LuaEventsId
public:
literal LuaEventsId ARENA_TEAM_ROSTER_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


ARENA_TEAM_UPDATE Field

LuaEventsId..::..ARENA_TEAM_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId ARENA_TEAM_UPDATE
Public Const ARENA_TEAM_UPDATE As LuaEventsId
public:
literal LuaEventsId ARENA_TEAM_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


AUCTION_BIDDER_LIST_UPDATE Field

LuaEventsId..::..AUCTION_BIDDER_LIST_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId AUCTION_BIDDER_LIST_UPDATE
Public Const AUCTION_BIDDER_LIST_UPDATE As LuaEventsId
public:
literal LuaEventsId AUCTION_BIDDER_LIST_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


AUCTION_HOUSE_CLOSED Field

LuaEventsId..::..AUCTION_HOUSE_CLOSED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId AUCTION_HOUSE_CLOSED
Public Const AUCTION_HOUSE_CLOSED As LuaEventsId
public:
literal LuaEventsId AUCTION_HOUSE_CLOSED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


AUCTION_HOUSE_DISABLED Field

LuaEventsId..::..AUCTION_HOUSE_DISABLED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId AUCTION_HOUSE_DISABLED
Public Const AUCTION_HOUSE_DISABLED As LuaEventsId
public:
literal LuaEventsId AUCTION_HOUSE_DISABLED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


AUCTION_HOUSE_SHOW Field

LuaEventsId..::..AUCTION_HOUSE_SHOW Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId AUCTION_HOUSE_SHOW
Public Const AUCTION_HOUSE_SHOW As LuaEventsId
public:
literal LuaEventsId AUCTION_HOUSE_SHOW

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


AUCTION_ITEM_LIST_UPDATE Field

LuaEventsId..::..AUCTION_ITEM_LIST_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId AUCTION_ITEM_LIST_UPDATE
Public Const AUCTION_ITEM_LIST_UPDATE As LuaEventsId
public:
literal LuaEventsId AUCTION_ITEM_LIST_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


AUCTION_MULTISELL_FAILURE Field

LuaEventsId..::..AUCTION_MULTISELL_FAILURE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId AUCTION_MULTISELL_FAILURE
Public Const AUCTION_MULTISELL_FAILURE As LuaEventsId
public:
literal LuaEventsId AUCTION_MULTISELL_FAILURE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


AUCTION_MULTISELL_START Field

LuaEventsId..::..AUCTION_MULTISELL_START Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId AUCTION_MULTISELL_START
Public Const AUCTION_MULTISELL_START As LuaEventsId
public:
literal LuaEventsId AUCTION_MULTISELL_START

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


AUCTION_MULTISELL_UPDATE Field

LuaEventsId..::..AUCTION_MULTISELL_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId AUCTION_MULTISELL_UPDATE
Public Const AUCTION_MULTISELL_UPDATE As LuaEventsId
public:
literal LuaEventsId AUCTION_MULTISELL_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


AUCTION_OWNED_LIST_UPDATE Field

LuaEventsId..::..AUCTION_OWNED_LIST_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId AUCTION_OWNED_LIST_UPDATE
Public Const AUCTION_OWNED_LIST_UPDATE As LuaEventsId
public:
literal LuaEventsId AUCTION_OWNED_LIST_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


AUTOEQUIP_BIND_CONFIRM Field

LuaEventsId..::..AUTOEQUIP_BIND_CONFIRM Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId AUTOEQUIP_BIND_CONFIRM
Public Const AUTOEQUIP_BIND_CONFIRM As LuaEventsId
public:
literal LuaEventsId AUTOEQUIP_BIND_CONFIRM

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


AUTOFOLLOW_BEGIN Field

LuaEventsId..::..AUTOFOLLOW_BEGIN Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId AUTOFOLLOW_BEGIN
Public Const AUTOFOLLOW_BEGIN As LuaEventsId
public:
literal LuaEventsId AUTOFOLLOW_BEGIN

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


AUTOFOLLOW_END Field

LuaEventsId..::..AUTOFOLLOW_END Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId AUTOFOLLOW_END
Public Const AUTOFOLLOW_END As LuaEventsId
public:
literal LuaEventsId AUTOFOLLOW_END

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BAG_CLOSED Field

LuaEventsId..::..BAG_CLOSED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BAG_CLOSED
Public Const BAG_CLOSED As LuaEventsId
public:
literal LuaEventsId BAG_CLOSED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BAG_OPEN Field

LuaEventsId..::..BAG_OPEN Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BAG_OPEN
Public Const BAG_OPEN As LuaEventsId
public:
literal LuaEventsId BAG_OPEN

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BAG_UPDATE Field

LuaEventsId..::..BAG_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BAG_UPDATE
Public Const BAG_UPDATE As LuaEventsId
public:
literal LuaEventsId BAG_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BAG_UPDATE_COOLDOWN Field

LuaEventsId..::..BAG_UPDATE_COOLDOWN Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BAG_UPDATE_COOLDOWN
Public Const BAG_UPDATE_COOLDOWN As LuaEventsId
public:
literal LuaEventsId BAG_UPDATE_COOLDOWN

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BANKFRAME_CLOSED Field

LuaEventsId..::..BANKFRAME_CLOSED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BANKFRAME_CLOSED
Public Const BANKFRAME_CLOSED As LuaEventsId
public:
literal LuaEventsId BANKFRAME_CLOSED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BANKFRAME_OPENED Field

LuaEventsId..::..BANKFRAME_OPENED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BANKFRAME_OPENED
Public Const BANKFRAME_OPENED As LuaEventsId
public:
literal LuaEventsId BANKFRAME_OPENED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BARBER_SHOP_APPEARANCE_APPLIED Field

LuaEventsId..::..BARBER_SHOP_APPEARANCE_APPLIED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BARBER_SHOP_APPEARANCE_APPLIED
Public Const BARBER_SHOP_APPEARANCE_APPLIED As LuaEventsId
public:
literal LuaEventsId BARBER_SHOP_APPEARANCE_APPLIED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BARBER_SHOP_CLOSE Field

LuaEventsId..::..BARBER_SHOP_CLOSE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BARBER_SHOP_CLOSE
Public Const BARBER_SHOP_CLOSE As LuaEventsId
public:
literal LuaEventsId BARBER_SHOP_CLOSE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BARBER_SHOP_OPEN Field

LuaEventsId..::..BARBER_SHOP_OPEN Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BARBER_SHOP_OPEN
Public Const BARBER_SHOP_OPEN As LuaEventsId
public:
literal LuaEventsId BARBER_SHOP_OPEN

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BARBER_SHOP_SUCCESS Field

LuaEventsId..::..BARBER_SHOP_SUCCESS Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BARBER_SHOP_SUCCESS
Public Const BARBER_SHOP_SUCCESS As LuaEventsId
public:
literal LuaEventsId BARBER_SHOP_SUCCESS

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BATTLEFIELD_MGR_EJECT_PENDING Field

LuaEventsId..::..BATTLEFIELD_MGR_EJECT_PENDING Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BATTLEFIELD_MGR_EJECT_PENDING
Public Const BATTLEFIELD_MGR_EJECT_PENDING As LuaEventsId
public:
literal LuaEventsId BATTLEFIELD_MGR_EJECT_PENDING

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BATTLEFIELD_MGR_EJECTED Field

LuaEventsId..::..BATTLEFIELD_MGR_EJECTED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BATTLEFIELD_MGR_EJECTED
Public Const BATTLEFIELD_MGR_EJECTED As LuaEventsId
public:
literal LuaEventsId BATTLEFIELD_MGR_EJECTED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BATTLEFIELD_MGR_ENTERED Field

LuaEventsId..::..BATTLEFIELD_MGR_ENTERED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BATTLEFIELD_MGR_ENTERED
Public Const BATTLEFIELD_MGR_ENTERED As LuaEventsId
public:
literal LuaEventsId BATTLEFIELD_MGR_ENTERED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BATTLEFIELD_MGR_ENTRY_INVITE Field

LuaEventsId..::..BATTLEFIELD_MGR_ENTRY_INVITE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BATTLEFIELD_MGR_ENTRY_INVITE
Public Const BATTLEFIELD_MGR_ENTRY_INVITE As LuaEventsId
public:
literal LuaEventsId BATTLEFIELD_MGR_ENTRY_INVITE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BATTLEFIELD_MGR_QUEUE_INVITE Field

LuaEventsId..::..BATTLEFIELD_MGR_QUEUE_INVITE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BATTLEFIELD_MGR_QUEUE_INVITE
Public Const BATTLEFIELD_MGR_QUEUE_INVITE As LuaEventsId
public:
literal LuaEventsId BATTLEFIELD_MGR_QUEUE_INVITE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BATTLEFIELD_MGR_QUEUE_REQUEST_RESPONSE Field

LuaEventsId..::..BATTLEFIELD_MGR_QUEUE_REQUEST_RESPONSE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BATTLEFIELD_MGR_QUEUE_REQUEST_RESPONSE
Public Const BATTLEFIELD_MGR_QUEUE_REQUEST_RESPONSE As LuaEventsId
public:
literal LuaEventsId BATTLEFIELD_MGR_QUEUE_REQUEST_RESPONSE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BATTLEFIELD_MGR_STATE_CHANGE Field

LuaEventsId..::..BATTLEFIELD_MGR_STATE_CHANGE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BATTLEFIELD_MGR_STATE_CHANGE
Public Const BATTLEFIELD_MGR_STATE_CHANGE As LuaEventsId
public:
literal LuaEventsId BATTLEFIELD_MGR_STATE_CHANGE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BATTLEFIELDS_CLOSED Field

LuaEventsId..::..BATTLEFIELDS_CLOSED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BATTLEFIELDS_CLOSED
Public Const BATTLEFIELDS_CLOSED As LuaEventsId
public:
literal LuaEventsId BATTLEFIELDS_CLOSED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BATTLEFIELDS_SHOW Field

LuaEventsId..::..BATTLEFIELDS_SHOW Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BATTLEFIELDS_SHOW
Public Const BATTLEFIELDS_SHOW As LuaEventsId
public:
literal LuaEventsId BATTLEFIELDS_SHOW

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BILLING_NAG_DIALOG Field

LuaEventsId..::..BILLING_NAG_DIALOG Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BILLING_NAG_DIALOG
Public Const BILLING_NAG_DIALOG As LuaEventsId
public:
literal LuaEventsId BILLING_NAG_DIALOG

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BIND_ENCHANT Field

LuaEventsId..::..BIND_ENCHANT Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BIND_ENCHANT
Public Const BIND_ENCHANT As LuaEventsId
public:
literal LuaEventsId BIND_ENCHANT

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BN_BLOCK_LIST_UPDATED Field

LuaEventsId..::..BN_BLOCK_LIST_UPDATED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BN_BLOCK_LIST_UPDATED
Public Const BN_BLOCK_LIST_UPDATED As LuaEventsId
public:
literal LuaEventsId BN_BLOCK_LIST_UPDATED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BN_CHAT_CHANNEL_CLOSED Field

LuaEventsId..::..BN_CHAT_CHANNEL_CLOSED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BN_CHAT_CHANNEL_CLOSED
Public Const BN_CHAT_CHANNEL_CLOSED As LuaEventsId
public:
literal LuaEventsId BN_CHAT_CHANNEL_CLOSED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BN_CHAT_CHANNEL_CREATE_FAILED Field

LuaEventsId..::..BN_CHAT_CHANNEL_CREATE_FAILED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BN_CHAT_CHANNEL_CREATE_FAILED
Public Const BN_CHAT_CHANNEL_CREATE_FAILED As LuaEventsId
public:
literal LuaEventsId BN_CHAT_CHANNEL_CREATE_FAILED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BN_CHAT_CHANNEL_CREATE_SUCCEEDED Field

LuaEventsId..::..BN_CHAT_CHANNEL_CREATE_SUCCEEDED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BN_CHAT_CHANNEL_CREATE_SUCCEEDED
Public Const BN_CHAT_CHANNEL_CREATE_SUCCEEDED As LuaEventsId
public:
literal LuaEventsId BN_CHAT_CHANNEL_CREATE_SUCCEEDED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BN_CHAT_CHANNEL_INVITE_FAILED Field

LuaEventsId..::..BN_CHAT_CHANNEL_INVITE_FAILED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BN_CHAT_CHANNEL_INVITE_FAILED
Public Const BN_CHAT_CHANNEL_INVITE_FAILED As LuaEventsId
public:
literal LuaEventsId BN_CHAT_CHANNEL_INVITE_FAILED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BN_CHAT_CHANNEL_INVITE_SUCCEEDED Field

LuaEventsId..::..BN_CHAT_CHANNEL_INVITE_SUCCEEDED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BN_CHAT_CHANNEL_INVITE_SUCCEEDED
Public Const BN_CHAT_CHANNEL_INVITE_SUCCEEDED As LuaEventsId
public:
literal LuaEventsId BN_CHAT_CHANNEL_INVITE_SUCCEEDED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BN_CHAT_CHANNEL_JOINED Field

LuaEventsId..::..BN_CHAT_CHANNEL_JOINED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BN_CHAT_CHANNEL_JOINED
Public Const BN_CHAT_CHANNEL_JOINED As LuaEventsId
public:
literal LuaEventsId BN_CHAT_CHANNEL_JOINED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BN_CHAT_CHANNEL_LEFT Field

LuaEventsId..::..BN_CHAT_CHANNEL_LEFT Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BN_CHAT_CHANNEL_LEFT
Public Const BN_CHAT_CHANNEL_LEFT As LuaEventsId
public:
literal LuaEventsId BN_CHAT_CHANNEL_LEFT

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BN_CHAT_CHANNEL_MEMBER_JOINED Field

LuaEventsId..::..BN_CHAT_CHANNEL_MEMBER_JOINED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BN_CHAT_CHANNEL_MEMBER_JOINED
Public Const BN_CHAT_CHANNEL_MEMBER_JOINED As LuaEventsId
public:
literal LuaEventsId BN_CHAT_CHANNEL_MEMBER_JOINED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BN_CHAT_CHANNEL_MEMBER_LEFT Field

LuaEventsId..::..BN_CHAT_CHANNEL_MEMBER_LEFT Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BN_CHAT_CHANNEL_MEMBER_LEFT
Public Const BN_CHAT_CHANNEL_MEMBER_LEFT As LuaEventsId
public:
literal LuaEventsId BN_CHAT_CHANNEL_MEMBER_LEFT

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BN_CHAT_CHANNEL_MEMBER_UPDATED Field

LuaEventsId..::..BN_CHAT_CHANNEL_MEMBER_UPDATED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BN_CHAT_CHANNEL_MEMBER_UPDATED
Public Const BN_CHAT_CHANNEL_MEMBER_UPDATED As LuaEventsId
public:
literal LuaEventsId BN_CHAT_CHANNEL_MEMBER_UPDATED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BN_CHAT_CHANNEL_MESSAGE_BLOCKED Field

LuaEventsId..::..BN_CHAT_CHANNEL_MESSAGE_BLOCKED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BN_CHAT_CHANNEL_MESSAGE_BLOCKED
Public Const BN_CHAT_CHANNEL_MESSAGE_BLOCKED As LuaEventsId
public:
literal LuaEventsId BN_CHAT_CHANNEL_MESSAGE_BLOCKED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BN_CHAT_CHANNEL_MESSAGE_UNDELIVERABLE Field

LuaEventsId..::..BN_CHAT_CHANNEL_MESSAGE_UNDELIVERABLE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BN_CHAT_CHANNEL_MESSAGE_UNDELIVERABLE
Public Const BN_CHAT_CHANNEL_MESSAGE_UNDELIVERABLE As LuaEventsId
public:
literal LuaEventsId BN_CHAT_CHANNEL_MESSAGE_UNDELIVERABLE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BN_CHAT_WHISPER_UNDELIVERABLE Field

LuaEventsId..::..BN_CHAT_WHISPER_UNDELIVERABLE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BN_CHAT_WHISPER_UNDELIVERABLE
Public Const BN_CHAT_WHISPER_UNDELIVERABLE As LuaEventsId
public:
literal LuaEventsId BN_CHAT_WHISPER_UNDELIVERABLE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BN_CONNECTED Field

LuaEventsId..::..BN_CONNECTED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BN_CONNECTED
Public Const BN_CONNECTED As LuaEventsId
public:
literal LuaEventsId BN_CONNECTED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BN_CUSTOM_MESSAGE_CHANGED Field

LuaEventsId..::..BN_CUSTOM_MESSAGE_CHANGED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BN_CUSTOM_MESSAGE_CHANGED
Public Const BN_CUSTOM_MESSAGE_CHANGED As LuaEventsId
public:
literal LuaEventsId BN_CUSTOM_MESSAGE_CHANGED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BN_CUSTOM_MESSAGE_LOADED Field

LuaEventsId..::..BN_CUSTOM_MESSAGE_LOADED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BN_CUSTOM_MESSAGE_LOADED
Public Const BN_CUSTOM_MESSAGE_LOADED As LuaEventsId
public:
literal LuaEventsId BN_CUSTOM_MESSAGE_LOADED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BN_DISCONNECTED Field

LuaEventsId..::..BN_DISCONNECTED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BN_DISCONNECTED
Public Const BN_DISCONNECTED As LuaEventsId
public:
literal LuaEventsId BN_DISCONNECTED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BN_FRIEND_ACCOUNT_OFFLINE Field

LuaEventsId..::..BN_FRIEND_ACCOUNT_OFFLINE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BN_FRIEND_ACCOUNT_OFFLINE
Public Const BN_FRIEND_ACCOUNT_OFFLINE As LuaEventsId
public:
literal LuaEventsId BN_FRIEND_ACCOUNT_OFFLINE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BN_FRIEND_ACCOUNT_ONLINE Field

LuaEventsId..::..BN_FRIEND_ACCOUNT_ONLINE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BN_FRIEND_ACCOUNT_ONLINE
Public Const BN_FRIEND_ACCOUNT_ONLINE As LuaEventsId
public:
literal LuaEventsId BN_FRIEND_ACCOUNT_ONLINE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BN_FRIEND_INFO_CHANGED Field

LuaEventsId..::..BN_FRIEND_INFO_CHANGED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BN_FRIEND_INFO_CHANGED
Public Const BN_FRIEND_INFO_CHANGED As LuaEventsId
public:
literal LuaEventsId BN_FRIEND_INFO_CHANGED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BN_FRIEND_INVITE_ADDED Field

LuaEventsId..::..BN_FRIEND_INVITE_ADDED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BN_FRIEND_INVITE_ADDED
Public Const BN_FRIEND_INVITE_ADDED As LuaEventsId
public:
literal LuaEventsId BN_FRIEND_INVITE_ADDED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BN_FRIEND_INVITE_LIST_INITIALIZED Field

LuaEventsId..::..BN_FRIEND_INVITE_LIST_INITIALIZED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BN_FRIEND_INVITE_LIST_INITIALIZED
Public Const BN_FRIEND_INVITE_LIST_INITIALIZED As LuaEventsId
public:
literal LuaEventsId BN_FRIEND_INVITE_LIST_INITIALIZED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BN_FRIEND_INVITE_REMOVED Field

LuaEventsId..::..BN_FRIEND_INVITE_REMOVED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BN_FRIEND_INVITE_REMOVED
Public Const BN_FRIEND_INVITE_REMOVED As LuaEventsId
public:
literal LuaEventsId BN_FRIEND_INVITE_REMOVED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BN_FRIEND_INVITE_SEND_RESULT Field

LuaEventsId..::..BN_FRIEND_INVITE_SEND_RESULT Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BN_FRIEND_INVITE_SEND_RESULT
Public Const BN_FRIEND_INVITE_SEND_RESULT As LuaEventsId
public:
literal LuaEventsId BN_FRIEND_INVITE_SEND_RESULT

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BN_FRIEND_LIST_SIZE_CHANGED Field

LuaEventsId..::..BN_FRIEND_LIST_SIZE_CHANGED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BN_FRIEND_LIST_SIZE_CHANGED
Public Const BN_FRIEND_LIST_SIZE_CHANGED As LuaEventsId
public:
literal LuaEventsId BN_FRIEND_LIST_SIZE_CHANGED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BN_FRIEND_TOON_OFFLINE Field

LuaEventsId..::..BN_FRIEND_TOON_OFFLINE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BN_FRIEND_TOON_OFFLINE
Public Const BN_FRIEND_TOON_OFFLINE As LuaEventsId
public:
literal LuaEventsId BN_FRIEND_TOON_OFFLINE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BN_FRIEND_TOON_ONLINE Field

LuaEventsId..::..BN_FRIEND_TOON_ONLINE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BN_FRIEND_TOON_ONLINE
Public Const BN_FRIEND_TOON_ONLINE As LuaEventsId
public:
literal LuaEventsId BN_FRIEND_TOON_ONLINE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BN_MATURE_LANGUAGE_FILTER Field

LuaEventsId..::..BN_MATURE_LANGUAGE_FILTER Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BN_MATURE_LANGUAGE_FILTER
Public Const BN_MATURE_LANGUAGE_FILTER As LuaEventsId
public:
literal LuaEventsId BN_MATURE_LANGUAGE_FILTER

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BN_NEW_PRESENCE Field

LuaEventsId..::..BN_NEW_PRESENCE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BN_NEW_PRESENCE
Public Const BN_NEW_PRESENCE As LuaEventsId
public:
literal LuaEventsId BN_NEW_PRESENCE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BN_REQUEST_FOF_FAILED Field

LuaEventsId..::..BN_REQUEST_FOF_FAILED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BN_REQUEST_FOF_FAILED
Public Const BN_REQUEST_FOF_FAILED As LuaEventsId
public:
literal LuaEventsId BN_REQUEST_FOF_FAILED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BN_REQUEST_FOF_SUCCEEDED Field

LuaEventsId..::..BN_REQUEST_FOF_SUCCEEDED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BN_REQUEST_FOF_SUCCEEDED
Public Const BN_REQUEST_FOF_SUCCEEDED As LuaEventsId
public:
literal LuaEventsId BN_REQUEST_FOF_SUCCEEDED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BN_SELF_OFFLINE Field

LuaEventsId..::..BN_SELF_OFFLINE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BN_SELF_OFFLINE
Public Const BN_SELF_OFFLINE As LuaEventsId
public:
literal LuaEventsId BN_SELF_OFFLINE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BN_SELF_ONLINE Field

LuaEventsId..::..BN_SELF_ONLINE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BN_SELF_ONLINE
Public Const BN_SELF_ONLINE As LuaEventsId
public:
literal LuaEventsId BN_SELF_ONLINE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BN_SYSTEM_MESSAGE Field

LuaEventsId..::..BN_SYSTEM_MESSAGE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BN_SYSTEM_MESSAGE
Public Const BN_SYSTEM_MESSAGE As LuaEventsId
public:
literal LuaEventsId BN_SYSTEM_MESSAGE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


BN_TOON_NAME_UPDATED Field

LuaEventsId..::..BN_TOON_NAME_UPDATED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId BN_TOON_NAME_UPDATED
Public Const BN_TOON_NAME_UPDATED As LuaEventsId
public:
literal LuaEventsId BN_TOON_NAME_UPDATED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CALENDAR_ACTION_PENDING Field

LuaEventsId..::..CALENDAR_ACTION_PENDING Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CALENDAR_ACTION_PENDING
Public Const CALENDAR_ACTION_PENDING As LuaEventsId
public:
literal LuaEventsId CALENDAR_ACTION_PENDING

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CALENDAR_CLOSE_EVENT Field

LuaEventsId..::..CALENDAR_CLOSE_EVENT Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CALENDAR_CLOSE_EVENT
Public Const CALENDAR_CLOSE_EVENT As LuaEventsId
public:
literal LuaEventsId CALENDAR_CLOSE_EVENT

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CALENDAR_EVENT_ALARM Field

LuaEventsId..::..CALENDAR_EVENT_ALARM Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CALENDAR_EVENT_ALARM
Public Const CALENDAR_EVENT_ALARM As LuaEventsId
public:
literal LuaEventsId CALENDAR_EVENT_ALARM

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CALENDAR_NEW_EVENT Field

LuaEventsId..::..CALENDAR_NEW_EVENT Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CALENDAR_NEW_EVENT
Public Const CALENDAR_NEW_EVENT As LuaEventsId
public:
literal LuaEventsId CALENDAR_NEW_EVENT

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CALENDAR_OPEN_EVENT Field

LuaEventsId..::..CALENDAR_OPEN_EVENT Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CALENDAR_OPEN_EVENT
Public Const CALENDAR_OPEN_EVENT As LuaEventsId
public:
literal LuaEventsId CALENDAR_OPEN_EVENT

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CALENDAR_UPDATE_ERROR Field

LuaEventsId..::..CALENDAR_UPDATE_ERROR Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CALENDAR_UPDATE_ERROR
Public Const CALENDAR_UPDATE_ERROR As LuaEventsId
public:
literal LuaEventsId CALENDAR_UPDATE_ERROR

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CALENDAR_UPDATE_EVENT Field

LuaEventsId..::..CALENDAR_UPDATE_EVENT Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CALENDAR_UPDATE_EVENT
Public Const CALENDAR_UPDATE_EVENT As LuaEventsId
public:
literal LuaEventsId CALENDAR_UPDATE_EVENT

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CALENDAR_UPDATE_EVENT_LIST Field

LuaEventsId..::..CALENDAR_UPDATE_EVENT_LIST Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CALENDAR_UPDATE_EVENT_LIST
Public Const CALENDAR_UPDATE_EVENT_LIST As LuaEventsId
public:
literal LuaEventsId CALENDAR_UPDATE_EVENT_LIST

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CALENDAR_UPDATE_INVITE_LIST Field

LuaEventsId..::..CALENDAR_UPDATE_INVITE_LIST Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CALENDAR_UPDATE_INVITE_LIST
Public Const CALENDAR_UPDATE_INVITE_LIST As LuaEventsId
public:
literal LuaEventsId CALENDAR_UPDATE_INVITE_LIST

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CALENDAR_UPDATE_PENDING_INVITES Field

LuaEventsId..::..CALENDAR_UPDATE_PENDING_INVITES Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CALENDAR_UPDATE_PENDING_INVITES
Public Const CALENDAR_UPDATE_PENDING_INVITES As LuaEventsId
public:
literal LuaEventsId CALENDAR_UPDATE_PENDING_INVITES

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CANCEL_LOOT_ROLL Field

LuaEventsId..::..CANCEL_LOOT_ROLL Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CANCEL_LOOT_ROLL
Public Const CANCEL_LOOT_ROLL As LuaEventsId
public:
literal LuaEventsId CANCEL_LOOT_ROLL

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CANCEL_SUMMON Field

LuaEventsId..::..CANCEL_SUMMON Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CANCEL_SUMMON
Public Const CANCEL_SUMMON As LuaEventsId
public:
literal LuaEventsId CANCEL_SUMMON

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHANNEL_COUNT_UPDATE Field

LuaEventsId..::..CHANNEL_COUNT_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHANNEL_COUNT_UPDATE
Public Const CHANNEL_COUNT_UPDATE As LuaEventsId
public:
literal LuaEventsId CHANNEL_COUNT_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHANNEL_FLAGS_UPDATED Field

LuaEventsId..::..CHANNEL_FLAGS_UPDATED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHANNEL_FLAGS_UPDATED
Public Const CHANNEL_FLAGS_UPDATED As LuaEventsId
public:
literal LuaEventsId CHANNEL_FLAGS_UPDATED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHANNEL_INVITE_REQUEST Field

LuaEventsId..::..CHANNEL_INVITE_REQUEST Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHANNEL_INVITE_REQUEST
Public Const CHANNEL_INVITE_REQUEST As LuaEventsId
public:
literal LuaEventsId CHANNEL_INVITE_REQUEST

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHANNEL_PASSWORD_REQUEST Field

LuaEventsId..::..CHANNEL_PASSWORD_REQUEST Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHANNEL_PASSWORD_REQUEST
Public Const CHANNEL_PASSWORD_REQUEST As LuaEventsId
public:
literal LuaEventsId CHANNEL_PASSWORD_REQUEST

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHANNEL_ROSTER_UPDATE Field

LuaEventsId..::..CHANNEL_ROSTER_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHANNEL_ROSTER_UPDATE
Public Const CHANNEL_ROSTER_UPDATE As LuaEventsId
public:
literal LuaEventsId CHANNEL_ROSTER_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHANNEL_UI_UPDATE Field

LuaEventsId..::..CHANNEL_UI_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHANNEL_UI_UPDATE
Public Const CHANNEL_UI_UPDATE As LuaEventsId
public:
literal LuaEventsId CHANNEL_UI_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHANNEL_VOICE_UPDATE Field

LuaEventsId..::..CHANNEL_VOICE_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHANNEL_VOICE_UPDATE
Public Const CHANNEL_VOICE_UPDATE As LuaEventsId
public:
literal LuaEventsId CHANNEL_VOICE_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHARACTER_POINTS_CHANGED Field

LuaEventsId..::..CHARACTER_POINTS_CHANGED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHARACTER_POINTS_CHANGED
Public Const CHARACTER_POINTS_CHANGED As LuaEventsId
public:
literal LuaEventsId CHARACTER_POINTS_CHANGED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_ACHIEVEMENT Field

LuaEventsId..::..CHAT_MSG_ACHIEVEMENT Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_ACHIEVEMENT
Public Const CHAT_MSG_ACHIEVEMENT As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_ACHIEVEMENT

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_ADDON Field

LuaEventsId..::..CHAT_MSG_ADDON Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_ADDON
Public Const CHAT_MSG_ADDON As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_ADDON

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_AFK Field

LuaEventsId..::..CHAT_MSG_AFK Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_AFK
Public Const CHAT_MSG_AFK As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_AFK

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_BATTLEGROUND Field

LuaEventsId..::..CHAT_MSG_BATTLEGROUND Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_BATTLEGROUND
Public Const CHAT_MSG_BATTLEGROUND As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_BATTLEGROUND

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_BATTLEGROUND_LEADER Field

LuaEventsId..::..CHAT_MSG_BATTLEGROUND_LEADER Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_BATTLEGROUND_LEADER
Public Const CHAT_MSG_BATTLEGROUND_LEADER As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_BATTLEGROUND_LEADER

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_BG_SYSTEM_ALLIANCE Field

LuaEventsId..::..CHAT_MSG_BG_SYSTEM_ALLIANCE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_BG_SYSTEM_ALLIANCE
Public Const CHAT_MSG_BG_SYSTEM_ALLIANCE As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_BG_SYSTEM_ALLIANCE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_BG_SYSTEM_HORDE Field

LuaEventsId..::..CHAT_MSG_BG_SYSTEM_HORDE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_BG_SYSTEM_HORDE
Public Const CHAT_MSG_BG_SYSTEM_HORDE As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_BG_SYSTEM_HORDE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_BG_SYSTEM_NEUTRAL Field

LuaEventsId..::..CHAT_MSG_BG_SYSTEM_NEUTRAL Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_BG_SYSTEM_NEUTRAL
Public Const CHAT_MSG_BG_SYSTEM_NEUTRAL As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_BG_SYSTEM_NEUTRAL

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_BN_CONVERSATION Field

LuaEventsId..::..CHAT_MSG_BN_CONVERSATION Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_BN_CONVERSATION
Public Const CHAT_MSG_BN_CONVERSATION As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_BN_CONVERSATION

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_BN_CONVERSATION_LIST Field

LuaEventsId..::..CHAT_MSG_BN_CONVERSATION_LIST Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_BN_CONVERSATION_LIST
Public Const CHAT_MSG_BN_CONVERSATION_LIST As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_BN_CONVERSATION_LIST

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_BN_CONVERSATION_NOTICE Field

LuaEventsId..::..CHAT_MSG_BN_CONVERSATION_NOTICE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_BN_CONVERSATION_NOTICE
Public Const CHAT_MSG_BN_CONVERSATION_NOTICE As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_BN_CONVERSATION_NOTICE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_BN_INLINE_TOAST_ALERT Field

LuaEventsId..::..CHAT_MSG_BN_INLINE_TOAST_ALERT Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_BN_INLINE_TOAST_ALERT
Public Const CHAT_MSG_BN_INLINE_TOAST_ALERT As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_BN_INLINE_TOAST_ALERT

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_BN_INLINE_TOAST_BROADCAST Field

LuaEventsId..::..CHAT_MSG_BN_INLINE_TOAST_BROADCAST Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_BN_INLINE_TOAST_BROADCAST
Public Const CHAT_MSG_BN_INLINE_TOAST_BROADCAST As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_BN_INLINE_TOAST_BROADCAST

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_BN_INLINE_TOAST_BROADCAST_INFORM Field

LuaEventsId..::..CHAT_MSG_BN_INLINE_TOAST_BROADCAST_INFORM Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_BN_INLINE_TOAST_BROADCAST_INFORM
Public Const CHAT_MSG_BN_INLINE_TOAST_BROADCAST_INFORM As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_BN_INLINE_TOAST_BROADCAST_INFORM

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_BN_INLINE_TOAST_CONVERSATION Field

LuaEventsId..::..CHAT_MSG_BN_INLINE_TOAST_CONVERSATION Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_BN_INLINE_TOAST_CONVERSATION
Public Const CHAT_MSG_BN_INLINE_TOAST_CONVERSATION As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_BN_INLINE_TOAST_CONVERSATION

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_BN_WHISPER Field

LuaEventsId..::..CHAT_MSG_BN_WHISPER Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_BN_WHISPER
Public Const CHAT_MSG_BN_WHISPER As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_BN_WHISPER

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_BN_WHISPER_INFORM Field

LuaEventsId..::..CHAT_MSG_BN_WHISPER_INFORM Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_BN_WHISPER_INFORM
Public Const CHAT_MSG_BN_WHISPER_INFORM As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_BN_WHISPER_INFORM

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_CHANNEL Field

LuaEventsId..::..CHAT_MSG_CHANNEL Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_CHANNEL
Public Const CHAT_MSG_CHANNEL As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_CHANNEL

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_CHANNEL_JOIN Field

LuaEventsId..::..CHAT_MSG_CHANNEL_JOIN Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_CHANNEL_JOIN
Public Const CHAT_MSG_CHANNEL_JOIN As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_CHANNEL_JOIN

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_CHANNEL_LEAVE Field

LuaEventsId..::..CHAT_MSG_CHANNEL_LEAVE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_CHANNEL_LEAVE
Public Const CHAT_MSG_CHANNEL_LEAVE As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_CHANNEL_LEAVE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_CHANNEL_LIST Field

LuaEventsId..::..CHAT_MSG_CHANNEL_LIST Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_CHANNEL_LIST
Public Const CHAT_MSG_CHANNEL_LIST As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_CHANNEL_LIST

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_CHANNEL_NOTICE Field

LuaEventsId..::..CHAT_MSG_CHANNEL_NOTICE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_CHANNEL_NOTICE
Public Const CHAT_MSG_CHANNEL_NOTICE As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_CHANNEL_NOTICE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_CHANNEL_NOTICE_USER Field

LuaEventsId..::..CHAT_MSG_CHANNEL_NOTICE_USER Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_CHANNEL_NOTICE_USER
Public Const CHAT_MSG_CHANNEL_NOTICE_USER As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_CHANNEL_NOTICE_USER

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_COMBAT_FACTION_CHANGE Field

LuaEventsId..::..CHAT_MSG_COMBAT_FACTION_CHANGE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_COMBAT_FACTION_CHANGE
Public Const CHAT_MSG_COMBAT_FACTION_CHANGE As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_COMBAT_FACTION_CHANGE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_COMBAT_HONOR_GAIN Field

LuaEventsId..::..CHAT_MSG_COMBAT_HONOR_GAIN Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_COMBAT_HONOR_GAIN
Public Const CHAT_MSG_COMBAT_HONOR_GAIN As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_COMBAT_HONOR_GAIN

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_COMBAT_MISC_INFO Field

LuaEventsId..::..CHAT_MSG_COMBAT_MISC_INFO Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_COMBAT_MISC_INFO
Public Const CHAT_MSG_COMBAT_MISC_INFO As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_COMBAT_MISC_INFO

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_COMBAT_XP_GAIN Field

LuaEventsId..::..CHAT_MSG_COMBAT_XP_GAIN Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_COMBAT_XP_GAIN
Public Const CHAT_MSG_COMBAT_XP_GAIN As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_COMBAT_XP_GAIN

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_DND Field

LuaEventsId..::..CHAT_MSG_DND Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_DND
Public Const CHAT_MSG_DND As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_DND

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_EMOTE Field

LuaEventsId..::..CHAT_MSG_EMOTE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_EMOTE
Public Const CHAT_MSG_EMOTE As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_EMOTE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_FILTERED Field

LuaEventsId..::..CHAT_MSG_FILTERED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_FILTERED
Public Const CHAT_MSG_FILTERED As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_FILTERED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_GUILD Field

LuaEventsId..::..CHAT_MSG_GUILD Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_GUILD
Public Const CHAT_MSG_GUILD As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_GUILD

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_GUILD_ACHIEVEMENT Field

LuaEventsId..::..CHAT_MSG_GUILD_ACHIEVEMENT Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_GUILD_ACHIEVEMENT
Public Const CHAT_MSG_GUILD_ACHIEVEMENT As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_GUILD_ACHIEVEMENT

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_IGNORED Field

LuaEventsId..::..CHAT_MSG_IGNORED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_IGNORED
Public Const CHAT_MSG_IGNORED As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_IGNORED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_LOOT Field

LuaEventsId..::..CHAT_MSG_LOOT Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_LOOT
Public Const CHAT_MSG_LOOT As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_LOOT

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_MONEY Field

LuaEventsId..::..CHAT_MSG_MONEY Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_MONEY
Public Const CHAT_MSG_MONEY As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_MONEY

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_MONSTER_EMOTE Field

LuaEventsId..::..CHAT_MSG_MONSTER_EMOTE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_MONSTER_EMOTE
Public Const CHAT_MSG_MONSTER_EMOTE As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_MONSTER_EMOTE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_MONSTER_PARTY Field

LuaEventsId..::..CHAT_MSG_MONSTER_PARTY Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_MONSTER_PARTY
Public Const CHAT_MSG_MONSTER_PARTY As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_MONSTER_PARTY

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_MONSTER_SAY Field

LuaEventsId..::..CHAT_MSG_MONSTER_SAY Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_MONSTER_SAY
Public Const CHAT_MSG_MONSTER_SAY As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_MONSTER_SAY

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_MONSTER_WHISPER Field

LuaEventsId..::..CHAT_MSG_MONSTER_WHISPER Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_MONSTER_WHISPER
Public Const CHAT_MSG_MONSTER_WHISPER As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_MONSTER_WHISPER

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_MONSTER_YELL Field

LuaEventsId..::..CHAT_MSG_MONSTER_YELL Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_MONSTER_YELL
Public Const CHAT_MSG_MONSTER_YELL As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_MONSTER_YELL

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_OFFICER Field

LuaEventsId..::..CHAT_MSG_OFFICER Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_OFFICER
Public Const CHAT_MSG_OFFICER As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_OFFICER

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_OPENING Field

LuaEventsId..::..CHAT_MSG_OPENING Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_OPENING
Public Const CHAT_MSG_OPENING As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_OPENING

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_PARTY Field

LuaEventsId..::..CHAT_MSG_PARTY Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_PARTY
Public Const CHAT_MSG_PARTY As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_PARTY

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_PARTY_LEADER Field

LuaEventsId..::..CHAT_MSG_PARTY_LEADER Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_PARTY_LEADER
Public Const CHAT_MSG_PARTY_LEADER As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_PARTY_LEADER

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_PET_INFO Field

LuaEventsId..::..CHAT_MSG_PET_INFO Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_PET_INFO
Public Const CHAT_MSG_PET_INFO As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_PET_INFO

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_RAID Field

LuaEventsId..::..CHAT_MSG_RAID Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_RAID
Public Const CHAT_MSG_RAID As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_RAID

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_RAID_BOSS_EMOTE Field

LuaEventsId..::..CHAT_MSG_RAID_BOSS_EMOTE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_RAID_BOSS_EMOTE
Public Const CHAT_MSG_RAID_BOSS_EMOTE As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_RAID_BOSS_EMOTE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_RAID_BOSS_WHISPER Field

LuaEventsId..::..CHAT_MSG_RAID_BOSS_WHISPER Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_RAID_BOSS_WHISPER
Public Const CHAT_MSG_RAID_BOSS_WHISPER As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_RAID_BOSS_WHISPER

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_RAID_LEADER Field

LuaEventsId..::..CHAT_MSG_RAID_LEADER Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_RAID_LEADER
Public Const CHAT_MSG_RAID_LEADER As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_RAID_LEADER

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_RAID_WARNING Field

LuaEventsId..::..CHAT_MSG_RAID_WARNING Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_RAID_WARNING
Public Const CHAT_MSG_RAID_WARNING As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_RAID_WARNING

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_RESTRICTED Field

LuaEventsId..::..CHAT_MSG_RESTRICTED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_RESTRICTED
Public Const CHAT_MSG_RESTRICTED As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_RESTRICTED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_SAY Field

LuaEventsId..::..CHAT_MSG_SAY Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_SAY
Public Const CHAT_MSG_SAY As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_SAY

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_SKILL Field

LuaEventsId..::..CHAT_MSG_SKILL Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_SKILL
Public Const CHAT_MSG_SKILL As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_SKILL

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_SYSTEM Field

LuaEventsId..::..CHAT_MSG_SYSTEM Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_SYSTEM
Public Const CHAT_MSG_SYSTEM As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_SYSTEM

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_TARGETICONS Field

LuaEventsId..::..CHAT_MSG_TARGETICONS Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_TARGETICONS
Public Const CHAT_MSG_TARGETICONS As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_TARGETICONS

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_TEXT_EMOTE Field

LuaEventsId..::..CHAT_MSG_TEXT_EMOTE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_TEXT_EMOTE
Public Const CHAT_MSG_TEXT_EMOTE As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_TEXT_EMOTE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_TRADESKILLS Field

LuaEventsId..::..CHAT_MSG_TRADESKILLS Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_TRADESKILLS
Public Const CHAT_MSG_TRADESKILLS As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_TRADESKILLS

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_WHISPER Field

LuaEventsId..::..CHAT_MSG_WHISPER Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_WHISPER
Public Const CHAT_MSG_WHISPER As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_WHISPER

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_WHISPER_INFORM Field

LuaEventsId..::..CHAT_MSG_WHISPER_INFORM Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_WHISPER_INFORM
Public Const CHAT_MSG_WHISPER_INFORM As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_WHISPER_INFORM

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CHAT_MSG_YELL Field

LuaEventsId..::..CHAT_MSG_YELL Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CHAT_MSG_YELL
Public Const CHAT_MSG_YELL As LuaEventsId
public:
literal LuaEventsId CHAT_MSG_YELL

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CINEMATIC_START Field

LuaEventsId..::..CINEMATIC_START Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CINEMATIC_START
Public Const CINEMATIC_START As LuaEventsId
public:
literal LuaEventsId CINEMATIC_START

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CINEMATIC_STOP Field

LuaEventsId..::..CINEMATIC_STOP Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CINEMATIC_STOP
Public Const CINEMATIC_STOP As LuaEventsId
public:
literal LuaEventsId CINEMATIC_STOP

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CLOSE_INBOX_ITEM Field

LuaEventsId..::..CLOSE_INBOX_ITEM Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CLOSE_INBOX_ITEM
Public Const CLOSE_INBOX_ITEM As LuaEventsId
public:
literal LuaEventsId CLOSE_INBOX_ITEM

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CLOSE_TABARD_FRAME Field

LuaEventsId..::..CLOSE_TABARD_FRAME Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CLOSE_TABARD_FRAME
Public Const CLOSE_TABARD_FRAME As LuaEventsId
public:
literal LuaEventsId CLOSE_TABARD_FRAME

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CLOSE_WORLD_MAP Field

LuaEventsId..::..CLOSE_WORLD_MAP Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CLOSE_WORLD_MAP
Public Const CLOSE_WORLD_MAP As LuaEventsId
public:
literal LuaEventsId CLOSE_WORLD_MAP

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


COMBAT_LOG_EVENT Field

LuaEventsId..::..COMBAT_LOG_EVENT Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId COMBAT_LOG_EVENT
Public Const COMBAT_LOG_EVENT As LuaEventsId
public:
literal LuaEventsId COMBAT_LOG_EVENT

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


COMBAT_LOG_EVENT_UNFILTERED Field

LuaEventsId..::..COMBAT_LOG_EVENT_UNFILTERED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId COMBAT_LOG_EVENT_UNFILTERED
Public Const COMBAT_LOG_EVENT_UNFILTERED As LuaEventsId
public:
literal LuaEventsId COMBAT_LOG_EVENT_UNFILTERED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


COMBAT_RATING_UPDATE Field

LuaEventsId..::..COMBAT_RATING_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId COMBAT_RATING_UPDATE
Public Const COMBAT_RATING_UPDATE As LuaEventsId
public:
literal LuaEventsId COMBAT_RATING_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


COMBAT_TEXT_UPDATE Field

LuaEventsId..::..COMBAT_TEXT_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId COMBAT_TEXT_UPDATE
Public Const COMBAT_TEXT_UPDATE As LuaEventsId
public:
literal LuaEventsId COMBAT_TEXT_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


COMMENTATOR_ENTER_WORLD Field

LuaEventsId..::..COMMENTATOR_ENTER_WORLD Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId COMMENTATOR_ENTER_WORLD
Public Const COMMENTATOR_ENTER_WORLD As LuaEventsId
public:
literal LuaEventsId COMMENTATOR_ENTER_WORLD

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


COMMENTATOR_MAP_UPDATE Field

LuaEventsId..::..COMMENTATOR_MAP_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId COMMENTATOR_MAP_UPDATE
Public Const COMMENTATOR_MAP_UPDATE As LuaEventsId
public:
literal LuaEventsId COMMENTATOR_MAP_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


COMMENTATOR_PLAYER_UPDATE Field

LuaEventsId..::..COMMENTATOR_PLAYER_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId COMMENTATOR_PLAYER_UPDATE
Public Const COMMENTATOR_PLAYER_UPDATE As LuaEventsId
public:
literal LuaEventsId COMMENTATOR_PLAYER_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


COMMENTATOR_SKIRMISH_MODE_REQUEST Field

LuaEventsId..::..COMMENTATOR_SKIRMISH_MODE_REQUEST Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId COMMENTATOR_SKIRMISH_MODE_REQUEST
Public Const COMMENTATOR_SKIRMISH_MODE_REQUEST As LuaEventsId
public:
literal LuaEventsId COMMENTATOR_SKIRMISH_MODE_REQUEST

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


COMMENTATOR_SKIRMISH_QUEUE_REQUEST Field

LuaEventsId..::..COMMENTATOR_SKIRMISH_QUEUE_REQUEST Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId COMMENTATOR_SKIRMISH_QUEUE_REQUEST
Public Const COMMENTATOR_SKIRMISH_QUEUE_REQUEST As LuaEventsId
public:
literal LuaEventsId COMMENTATOR_SKIRMISH_QUEUE_REQUEST

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


COMPANION_LEARNED Field

LuaEventsId..::..COMPANION_LEARNED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId COMPANION_LEARNED
Public Const COMPANION_LEARNED As LuaEventsId
public:
literal LuaEventsId COMPANION_LEARNED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


COMPANION_UNLEARNED Field

LuaEventsId..::..COMPANION_UNLEARNED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId COMPANION_UNLEARNED
Public Const COMPANION_UNLEARNED As LuaEventsId
public:
literal LuaEventsId COMPANION_UNLEARNED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


COMPANION_UPDATE Field

LuaEventsId..::..COMPANION_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId COMPANION_UPDATE
Public Const COMPANION_UPDATE As LuaEventsId
public:
literal LuaEventsId COMPANION_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CONFIRM_BINDER Field

LuaEventsId..::..CONFIRM_BINDER Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CONFIRM_BINDER
Public Const CONFIRM_BINDER As LuaEventsId
public:
literal LuaEventsId CONFIRM_BINDER

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CONFIRM_DISENCHANT_ROLL Field

LuaEventsId..::..CONFIRM_DISENCHANT_ROLL Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CONFIRM_DISENCHANT_ROLL
Public Const CONFIRM_DISENCHANT_ROLL As LuaEventsId
public:
literal LuaEventsId CONFIRM_DISENCHANT_ROLL

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CONFIRM_LOOT_ROLL Field

LuaEventsId..::..CONFIRM_LOOT_ROLL Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CONFIRM_LOOT_ROLL
Public Const CONFIRM_LOOT_ROLL As LuaEventsId
public:
literal LuaEventsId CONFIRM_LOOT_ROLL

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CONFIRM_SUMMON Field

LuaEventsId..::..CONFIRM_SUMMON Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CONFIRM_SUMMON
Public Const CONFIRM_SUMMON As LuaEventsId
public:
literal LuaEventsId CONFIRM_SUMMON

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CONFIRM_TALENT_WIPE Field

LuaEventsId..::..CONFIRM_TALENT_WIPE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CONFIRM_TALENT_WIPE
Public Const CONFIRM_TALENT_WIPE As LuaEventsId
public:
literal LuaEventsId CONFIRM_TALENT_WIPE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CONFIRM_XP_LOSS Field

LuaEventsId..::..CONFIRM_XP_LOSS Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CONFIRM_XP_LOSS
Public Const CONFIRM_XP_LOSS As LuaEventsId
public:
literal LuaEventsId CONFIRM_XP_LOSS

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CORPSE_IN_INSTANCE Field

LuaEventsId..::..CORPSE_IN_INSTANCE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CORPSE_IN_INSTANCE
Public Const CORPSE_IN_INSTANCE As LuaEventsId
public:
literal LuaEventsId CORPSE_IN_INSTANCE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CORPSE_IN_RANGE Field

LuaEventsId..::..CORPSE_IN_RANGE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CORPSE_IN_RANGE
Public Const CORPSE_IN_RANGE As LuaEventsId
public:
literal LuaEventsId CORPSE_IN_RANGE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CORPSE_OUT_OF_RANGE Field

LuaEventsId..::..CORPSE_OUT_OF_RANGE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CORPSE_OUT_OF_RANGE
Public Const CORPSE_OUT_OF_RANGE As LuaEventsId
public:
literal LuaEventsId CORPSE_OUT_OF_RANGE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CRITERIA_UPDATE Field

LuaEventsId..::..CRITERIA_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CRITERIA_UPDATE
Public Const CRITERIA_UPDATE As LuaEventsId
public:
literal LuaEventsId CRITERIA_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CURRENCY_DISPLAY_UPDATE Field

LuaEventsId..::..CURRENCY_DISPLAY_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CURRENCY_DISPLAY_UPDATE
Public Const CURRENCY_DISPLAY_UPDATE As LuaEventsId
public:
literal LuaEventsId CURRENCY_DISPLAY_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CURRENT_SPELL_CAST_CHANGED Field

LuaEventsId..::..CURRENT_SPELL_CAST_CHANGED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CURRENT_SPELL_CAST_CHANGED
Public Const CURRENT_SPELL_CAST_CHANGED As LuaEventsId
public:
literal LuaEventsId CURRENT_SPELL_CAST_CHANGED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CURSOR_UPDATE Field

LuaEventsId..::..CURSOR_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CURSOR_UPDATE
Public Const CURSOR_UPDATE As LuaEventsId
public:
literal LuaEventsId CURSOR_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


CVAR_UPDATE Field

LuaEventsId..::..CVAR_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId CVAR_UPDATE
Public Const CVAR_UPDATE As LuaEventsId
public:
literal LuaEventsId CVAR_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


DELETE_ITEM_CONFIRM Field

LuaEventsId..::..DELETE_ITEM_CONFIRM Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId DELETE_ITEM_CONFIRM
Public Const DELETE_ITEM_CONFIRM As LuaEventsId
public:
literal LuaEventsId DELETE_ITEM_CONFIRM

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


DISABLE_LOW_LEVEL_RAID Field

LuaEventsId..::..DISABLE_LOW_LEVEL_RAID Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId DISABLE_LOW_LEVEL_RAID
Public Const DISABLE_LOW_LEVEL_RAID As LuaEventsId
public:
literal LuaEventsId DISABLE_LOW_LEVEL_RAID

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


DISABLE_TAXI_BENCHMARK Field

LuaEventsId..::..DISABLE_TAXI_BENCHMARK Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId DISABLE_TAXI_BENCHMARK
Public Const DISABLE_TAXI_BENCHMARK As LuaEventsId
public:
literal LuaEventsId DISABLE_TAXI_BENCHMARK

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


DISABLE_XP_GAIN Field

LuaEventsId..::..DISABLE_XP_GAIN Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId DISABLE_XP_GAIN
Public Const DISABLE_XP_GAIN As LuaEventsId
public:
literal LuaEventsId DISABLE_XP_GAIN

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


DISPLAY_SIZE_CHANGED Field

LuaEventsId..::..DISPLAY_SIZE_CHANGED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId DISPLAY_SIZE_CHANGED
Public Const DISPLAY_SIZE_CHANGED As LuaEventsId
public:
literal LuaEventsId DISPLAY_SIZE_CHANGED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


DUEL_FINISHED Field

LuaEventsId..::..DUEL_FINISHED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId DUEL_FINISHED
Public Const DUEL_FINISHED As LuaEventsId
public:
literal LuaEventsId DUEL_FINISHED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


DUEL_INBOUNDS Field

LuaEventsId..::..DUEL_INBOUNDS Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId DUEL_INBOUNDS
Public Const DUEL_INBOUNDS As LuaEventsId
public:
literal LuaEventsId DUEL_INBOUNDS

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


DUEL_OUTOFBOUNDS Field

LuaEventsId..::..DUEL_OUTOFBOUNDS Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId DUEL_OUTOFBOUNDS
Public Const DUEL_OUTOFBOUNDS As LuaEventsId
public:
literal LuaEventsId DUEL_OUTOFBOUNDS

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


DUEL_REQUESTED Field

LuaEventsId..::..DUEL_REQUESTED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId DUEL_REQUESTED
Public Const DUEL_REQUESTED As LuaEventsId
public:
literal LuaEventsId DUEL_REQUESTED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


ENABLE_LOW_LEVEL_RAID Field

LuaEventsId..::..ENABLE_LOW_LEVEL_RAID Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId ENABLE_LOW_LEVEL_RAID
Public Const ENABLE_LOW_LEVEL_RAID As LuaEventsId
public:
literal LuaEventsId ENABLE_LOW_LEVEL_RAID

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


ENABLE_TAXI_BENCHMARK Field

LuaEventsId..::..ENABLE_TAXI_BENCHMARK Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId ENABLE_TAXI_BENCHMARK
Public Const ENABLE_TAXI_BENCHMARK As LuaEventsId
public:
literal LuaEventsId ENABLE_TAXI_BENCHMARK

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


ENABLE_XP_GAIN Field

LuaEventsId..::..ENABLE_XP_GAIN Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId ENABLE_XP_GAIN
Public Const ENABLE_XP_GAIN As LuaEventsId
public:
literal LuaEventsId ENABLE_XP_GAIN

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


END_BOUND_TRADEABLE Field

LuaEventsId..::..END_BOUND_TRADEABLE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId END_BOUND_TRADEABLE
Public Const END_BOUND_TRADEABLE As LuaEventsId
public:
literal LuaEventsId END_BOUND_TRADEABLE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


END_REFUND Field

LuaEventsId..::..END_REFUND Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId END_REFUND
Public Const END_REFUND As LuaEventsId
public:
literal LuaEventsId END_REFUND

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


EQUIP_BIND_CONFIRM Field

LuaEventsId..::..EQUIP_BIND_CONFIRM Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId EQUIP_BIND_CONFIRM
Public Const EQUIP_BIND_CONFIRM As LuaEventsId
public:
literal LuaEventsId EQUIP_BIND_CONFIRM

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


EQUIPMENT_SETS_CHANGED Field

LuaEventsId..::..EQUIPMENT_SETS_CHANGED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId EQUIPMENT_SETS_CHANGED
Public Const EQUIPMENT_SETS_CHANGED As LuaEventsId
public:
literal LuaEventsId EQUIPMENT_SETS_CHANGED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


EQUIPMENT_SWAP_FINISHED Field

LuaEventsId..::..EQUIPMENT_SWAP_FINISHED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId EQUIPMENT_SWAP_FINISHED
Public Const EQUIPMENT_SWAP_FINISHED As LuaEventsId
public:
literal LuaEventsId EQUIPMENT_SWAP_FINISHED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


EQUIPMENT_SWAP_PENDING Field

LuaEventsId..::..EQUIPMENT_SWAP_PENDING Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId EQUIPMENT_SWAP_PENDING
Public Const EQUIPMENT_SWAP_PENDING As LuaEventsId
public:
literal LuaEventsId EQUIPMENT_SWAP_PENDING

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


EXECUTE_CHAT_LINE Field

LuaEventsId..::..EXECUTE_CHAT_LINE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId EXECUTE_CHAT_LINE
Public Const EXECUTE_CHAT_LINE As LuaEventsId
public:
literal LuaEventsId EXECUTE_CHAT_LINE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


FRIENDLIST_UPDATE Field

LuaEventsId..::..FRIENDLIST_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId FRIENDLIST_UPDATE
Public Const FRIENDLIST_UPDATE As LuaEventsId
public:
literal LuaEventsId FRIENDLIST_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


GLYPH_ADDED Field

LuaEventsId..::..GLYPH_ADDED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId GLYPH_ADDED
Public Const GLYPH_ADDED As LuaEventsId
public:
literal LuaEventsId GLYPH_ADDED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


GLYPH_DISABLED Field

LuaEventsId..::..GLYPH_DISABLED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId GLYPH_DISABLED
Public Const GLYPH_DISABLED As LuaEventsId
public:
literal LuaEventsId GLYPH_DISABLED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


GLYPH_ENABLED Field

LuaEventsId..::..GLYPH_ENABLED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId GLYPH_ENABLED
Public Const GLYPH_ENABLED As LuaEventsId
public:
literal LuaEventsId GLYPH_ENABLED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


GLYPH_REMOVED Field

LuaEventsId..::..GLYPH_REMOVED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId GLYPH_REMOVED
Public Const GLYPH_REMOVED As LuaEventsId
public:
literal LuaEventsId GLYPH_REMOVED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


GLYPH_UPDATED Field

LuaEventsId..::..GLYPH_UPDATED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId GLYPH_UPDATED
Public Const GLYPH_UPDATED As LuaEventsId
public:
literal LuaEventsId GLYPH_UPDATED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


GM_PLAYER_INFO Field

LuaEventsId..::..GM_PLAYER_INFO Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId GM_PLAYER_INFO
Public Const GM_PLAYER_INFO As LuaEventsId
public:
literal LuaEventsId GM_PLAYER_INFO

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


GMRESPONSE_RECEIVED Field

LuaEventsId..::..GMRESPONSE_RECEIVED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId GMRESPONSE_RECEIVED
Public Const GMRESPONSE_RECEIVED As LuaEventsId
public:
literal LuaEventsId GMRESPONSE_RECEIVED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


GMSURVEY_DISPLAY Field

LuaEventsId..::..GMSURVEY_DISPLAY Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId GMSURVEY_DISPLAY
Public Const GMSURVEY_DISPLAY As LuaEventsId
public:
literal LuaEventsId GMSURVEY_DISPLAY

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


GOSSIP_CLOSED Field

LuaEventsId..::..GOSSIP_CLOSED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId GOSSIP_CLOSED
Public Const GOSSIP_CLOSED As LuaEventsId
public:
literal LuaEventsId GOSSIP_CLOSED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


GOSSIP_CONFIRM Field

LuaEventsId..::..GOSSIP_CONFIRM Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId GOSSIP_CONFIRM
Public Const GOSSIP_CONFIRM As LuaEventsId
public:
literal LuaEventsId GOSSIP_CONFIRM

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


GOSSIP_CONFIRM_CANCEL Field

LuaEventsId..::..GOSSIP_CONFIRM_CANCEL Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId GOSSIP_CONFIRM_CANCEL
Public Const GOSSIP_CONFIRM_CANCEL As LuaEventsId
public:
literal LuaEventsId GOSSIP_CONFIRM_CANCEL

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


GOSSIP_ENTER_CODE Field

LuaEventsId..::..GOSSIP_ENTER_CODE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId GOSSIP_ENTER_CODE
Public Const GOSSIP_ENTER_CODE As LuaEventsId
public:
literal LuaEventsId GOSSIP_ENTER_CODE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


GOSSIP_SHOW Field

LuaEventsId..::..GOSSIP_SHOW Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId GOSSIP_SHOW
Public Const GOSSIP_SHOW As LuaEventsId
public:
literal LuaEventsId GOSSIP_SHOW

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


GUILD_EVENT_LOG_UPDATE Field

LuaEventsId..::..GUILD_EVENT_LOG_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId GUILD_EVENT_LOG_UPDATE
Public Const GUILD_EVENT_LOG_UPDATE As LuaEventsId
public:
literal LuaEventsId GUILD_EVENT_LOG_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


GUILD_INVITE_CANCEL Field

LuaEventsId..::..GUILD_INVITE_CANCEL Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId GUILD_INVITE_CANCEL
Public Const GUILD_INVITE_CANCEL As LuaEventsId
public:
literal LuaEventsId GUILD_INVITE_CANCEL

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


GUILD_INVITE_REQUEST Field

LuaEventsId..::..GUILD_INVITE_REQUEST Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId GUILD_INVITE_REQUEST
Public Const GUILD_INVITE_REQUEST As LuaEventsId
public:
literal LuaEventsId GUILD_INVITE_REQUEST

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


GUILD_MOTD Field

LuaEventsId..::..GUILD_MOTD Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId GUILD_MOTD
Public Const GUILD_MOTD As LuaEventsId
public:
literal LuaEventsId GUILD_MOTD

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


GUILD_REGISTRAR_CLOSED Field

LuaEventsId..::..GUILD_REGISTRAR_CLOSED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId GUILD_REGISTRAR_CLOSED
Public Const GUILD_REGISTRAR_CLOSED As LuaEventsId
public:
literal LuaEventsId GUILD_REGISTRAR_CLOSED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


GUILD_REGISTRAR_SHOW Field

LuaEventsId..::..GUILD_REGISTRAR_SHOW Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId GUILD_REGISTRAR_SHOW
Public Const GUILD_REGISTRAR_SHOW As LuaEventsId
public:
literal LuaEventsId GUILD_REGISTRAR_SHOW

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


GUILD_ROSTER_UPDATE Field

LuaEventsId..::..GUILD_ROSTER_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId GUILD_ROSTER_UPDATE
Public Const GUILD_ROSTER_UPDATE As LuaEventsId
public:
literal LuaEventsId GUILD_ROSTER_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


GUILDBANK_ITEM_LOCK_CHANGED Field

LuaEventsId..::..GUILDBANK_ITEM_LOCK_CHANGED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId GUILDBANK_ITEM_LOCK_CHANGED
Public Const GUILDBANK_ITEM_LOCK_CHANGED As LuaEventsId
public:
literal LuaEventsId GUILDBANK_ITEM_LOCK_CHANGED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


GUILDBANK_TEXT_CHANGED Field

LuaEventsId..::..GUILDBANK_TEXT_CHANGED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId GUILDBANK_TEXT_CHANGED
Public Const GUILDBANK_TEXT_CHANGED As LuaEventsId
public:
literal LuaEventsId GUILDBANK_TEXT_CHANGED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


GUILDBANK_UPDATE_MONEY Field

LuaEventsId..::..GUILDBANK_UPDATE_MONEY Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId GUILDBANK_UPDATE_MONEY
Public Const GUILDBANK_UPDATE_MONEY As LuaEventsId
public:
literal LuaEventsId GUILDBANK_UPDATE_MONEY

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


GUILDBANK_UPDATE_TABS Field

LuaEventsId..::..GUILDBANK_UPDATE_TABS Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId GUILDBANK_UPDATE_TABS
Public Const GUILDBANK_UPDATE_TABS As LuaEventsId
public:
literal LuaEventsId GUILDBANK_UPDATE_TABS

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


GUILDBANK_UPDATE_TEXT Field

LuaEventsId..::..GUILDBANK_UPDATE_TEXT Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId GUILDBANK_UPDATE_TEXT
Public Const GUILDBANK_UPDATE_TEXT As LuaEventsId
public:
literal LuaEventsId GUILDBANK_UPDATE_TEXT

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


GUILDBANK_UPDATE_WITHDRAWMONEY Field

LuaEventsId..::..GUILDBANK_UPDATE_WITHDRAWMONEY Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId GUILDBANK_UPDATE_WITHDRAWMONEY
Public Const GUILDBANK_UPDATE_WITHDRAWMONEY As LuaEventsId
public:
literal LuaEventsId GUILDBANK_UPDATE_WITHDRAWMONEY

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


GUILDBANKBAGSLOTS_CHANGED Field

LuaEventsId..::..GUILDBANKBAGSLOTS_CHANGED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId GUILDBANKBAGSLOTS_CHANGED
Public Const GUILDBANKBAGSLOTS_CHANGED As LuaEventsId
public:
literal LuaEventsId GUILDBANKBAGSLOTS_CHANGED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


GUILDBANKFRAME_CLOSED Field

LuaEventsId..::..GUILDBANKFRAME_CLOSED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId GUILDBANKFRAME_CLOSED
Public Const GUILDBANKFRAME_CLOSED As LuaEventsId
public:
literal LuaEventsId GUILDBANKFRAME_CLOSED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


GUILDBANKFRAME_OPENED Field

LuaEventsId..::..GUILDBANKFRAME_OPENED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId GUILDBANKFRAME_OPENED
Public Const GUILDBANKFRAME_OPENED As LuaEventsId
public:
literal LuaEventsId GUILDBANKFRAME_OPENED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


GUILDBANKLOG_UPDATE Field

LuaEventsId..::..GUILDBANKLOG_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId GUILDBANKLOG_UPDATE
Public Const GUILDBANKLOG_UPDATE As LuaEventsId
public:
literal LuaEventsId GUILDBANKLOG_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


GUILDTABARD_UPDATE Field

LuaEventsId..::..GUILDTABARD_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId GUILDTABARD_UPDATE
Public Const GUILDTABARD_UPDATE As LuaEventsId
public:
literal LuaEventsId GUILDTABARD_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


HONOR_CURRENCY_UPDATE Field

LuaEventsId..::..HONOR_CURRENCY_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId HONOR_CURRENCY_UPDATE
Public Const HONOR_CURRENCY_UPDATE As LuaEventsId
public:
literal LuaEventsId HONOR_CURRENCY_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


IGNORELIST_UPDATE Field

LuaEventsId..::..IGNORELIST_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId IGNORELIST_UPDATE
Public Const IGNORELIST_UPDATE As LuaEventsId
public:
literal LuaEventsId IGNORELIST_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


IGR_BILLING_NAG_DIALOG Field

LuaEventsId..::..IGR_BILLING_NAG_DIALOG Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId IGR_BILLING_NAG_DIALOG
Public Const IGR_BILLING_NAG_DIALOG As LuaEventsId
public:
literal LuaEventsId IGR_BILLING_NAG_DIALOG

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


INSPECT_ACHIEVEMENT_READY Field

LuaEventsId..::..INSPECT_ACHIEVEMENT_READY Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId INSPECT_ACHIEVEMENT_READY
Public Const INSPECT_ACHIEVEMENT_READY As LuaEventsId
public:
literal LuaEventsId INSPECT_ACHIEVEMENT_READY

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


INSPECT_HONOR_UPDATE Field

LuaEventsId..::..INSPECT_HONOR_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId INSPECT_HONOR_UPDATE
Public Const INSPECT_HONOR_UPDATE As LuaEventsId
public:
literal LuaEventsId INSPECT_HONOR_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


INSPECT_TALENT_READY Field

LuaEventsId..::..INSPECT_TALENT_READY Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId INSPECT_TALENT_READY
Public Const INSPECT_TALENT_READY As LuaEventsId
public:
literal LuaEventsId INSPECT_TALENT_READY

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


INSTANCE_BOOT_START Field

LuaEventsId..::..INSTANCE_BOOT_START Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId INSTANCE_BOOT_START
Public Const INSTANCE_BOOT_START As LuaEventsId
public:
literal LuaEventsId INSTANCE_BOOT_START

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


INSTANCE_BOOT_STOP Field

LuaEventsId..::..INSTANCE_BOOT_STOP Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId INSTANCE_BOOT_STOP
Public Const INSTANCE_BOOT_STOP As LuaEventsId
public:
literal LuaEventsId INSTANCE_BOOT_STOP

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


INSTANCE_ENCOUNTER_ENGAGE_UNIT Field

LuaEventsId..::..INSTANCE_ENCOUNTER_ENGAGE_UNIT Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId INSTANCE_ENCOUNTER_ENGAGE_UNIT
Public Const INSTANCE_ENCOUNTER_ENGAGE_UNIT As LuaEventsId
public:
literal LuaEventsId INSTANCE_ENCOUNTER_ENGAGE_UNIT

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


INSTANCE_LOCK_START Field

LuaEventsId..::..INSTANCE_LOCK_START Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId INSTANCE_LOCK_START
Public Const INSTANCE_LOCK_START As LuaEventsId
public:
literal LuaEventsId INSTANCE_LOCK_START

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


INSTANCE_LOCK_STOP Field

LuaEventsId..::..INSTANCE_LOCK_STOP Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId INSTANCE_LOCK_STOP
Public Const INSTANCE_LOCK_STOP As LuaEventsId
public:
literal LuaEventsId INSTANCE_LOCK_STOP

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


ITEM_LOCK_CHANGED Field

LuaEventsId..::..ITEM_LOCK_CHANGED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId ITEM_LOCK_CHANGED
Public Const ITEM_LOCK_CHANGED As LuaEventsId
public:
literal LuaEventsId ITEM_LOCK_CHANGED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


ITEM_LOCKED Field

LuaEventsId..::..ITEM_LOCKED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId ITEM_LOCKED
Public Const ITEM_LOCKED As LuaEventsId
public:
literal LuaEventsId ITEM_LOCKED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


ITEM_PUSH Field

LuaEventsId..::..ITEM_PUSH Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId ITEM_PUSH
Public Const ITEM_PUSH As LuaEventsId
public:
literal LuaEventsId ITEM_PUSH

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


ITEM_TEXT_BEGIN Field

LuaEventsId..::..ITEM_TEXT_BEGIN Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId ITEM_TEXT_BEGIN
Public Const ITEM_TEXT_BEGIN As LuaEventsId
public:
literal LuaEventsId ITEM_TEXT_BEGIN

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


ITEM_TEXT_CLOSED Field

LuaEventsId..::..ITEM_TEXT_CLOSED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId ITEM_TEXT_CLOSED
Public Const ITEM_TEXT_CLOSED As LuaEventsId
public:
literal LuaEventsId ITEM_TEXT_CLOSED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


ITEM_TEXT_READY Field

LuaEventsId..::..ITEM_TEXT_READY Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId ITEM_TEXT_READY
Public Const ITEM_TEXT_READY As LuaEventsId
public:
literal LuaEventsId ITEM_TEXT_READY

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


ITEM_TEXT_TRANSLATION Field

LuaEventsId..::..ITEM_TEXT_TRANSLATION Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId ITEM_TEXT_TRANSLATION
Public Const ITEM_TEXT_TRANSLATION As LuaEventsId
public:
literal LuaEventsId ITEM_TEXT_TRANSLATION

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


ITEM_UNLOCKED Field

LuaEventsId..::..ITEM_UNLOCKED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId ITEM_UNLOCKED
Public Const ITEM_UNLOCKED As LuaEventsId
public:
literal LuaEventsId ITEM_UNLOCKED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


KNOWLEDGE_BASE_ARTICLE_LOAD_FAILURE Field

LuaEventsId..::..KNOWLEDGE_BASE_ARTICLE_LOAD_FAILURE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId KNOWLEDGE_BASE_ARTICLE_LOAD_FAILURE
Public Const KNOWLEDGE_BASE_ARTICLE_LOAD_FAILURE As LuaEventsId
public:
literal LuaEventsId KNOWLEDGE_BASE_ARTICLE_LOAD_FAILURE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


KNOWLEDGE_BASE_ARTICLE_LOAD_SUCCESS Field

LuaEventsId..::..KNOWLEDGE_BASE_ARTICLE_LOAD_SUCCESS Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId KNOWLEDGE_BASE_ARTICLE_LOAD_SUCCESS
Public Const KNOWLEDGE_BASE_ARTICLE_LOAD_SUCCESS As LuaEventsId
public:
literal LuaEventsId KNOWLEDGE_BASE_ARTICLE_LOAD_SUCCESS

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


KNOWLEDGE_BASE_QUERY_LOAD_FAILURE Field

LuaEventsId..::..KNOWLEDGE_BASE_QUERY_LOAD_FAILURE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId KNOWLEDGE_BASE_QUERY_LOAD_FAILURE
Public Const KNOWLEDGE_BASE_QUERY_LOAD_FAILURE As LuaEventsId
public:
literal LuaEventsId KNOWLEDGE_BASE_QUERY_LOAD_FAILURE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


KNOWLEDGE_BASE_QUERY_LOAD_SUCCESS Field

LuaEventsId..::..KNOWLEDGE_BASE_QUERY_LOAD_SUCCESS Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId KNOWLEDGE_BASE_QUERY_LOAD_SUCCESS
Public Const KNOWLEDGE_BASE_QUERY_LOAD_SUCCESS As LuaEventsId
public:
literal LuaEventsId KNOWLEDGE_BASE_QUERY_LOAD_SUCCESS

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


KNOWLEDGE_BASE_SERVER_MESSAGE Field

LuaEventsId..::..KNOWLEDGE_BASE_SERVER_MESSAGE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId KNOWLEDGE_BASE_SERVER_MESSAGE
Public Const KNOWLEDGE_BASE_SERVER_MESSAGE As LuaEventsId
public:
literal LuaEventsId KNOWLEDGE_BASE_SERVER_MESSAGE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


KNOWLEDGE_BASE_SETUP_LOAD_FAILURE Field

LuaEventsId..::..KNOWLEDGE_BASE_SETUP_LOAD_FAILURE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId KNOWLEDGE_BASE_SETUP_LOAD_FAILURE
Public Const KNOWLEDGE_BASE_SETUP_LOAD_FAILURE As LuaEventsId
public:
literal LuaEventsId KNOWLEDGE_BASE_SETUP_LOAD_FAILURE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


KNOWLEDGE_BASE_SETUP_LOAD_SUCCESS Field

LuaEventsId..::..KNOWLEDGE_BASE_SETUP_LOAD_SUCCESS Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId KNOWLEDGE_BASE_SETUP_LOAD_SUCCESS
Public Const KNOWLEDGE_BASE_SETUP_LOAD_SUCCESS As LuaEventsId
public:
literal LuaEventsId KNOWLEDGE_BASE_SETUP_LOAD_SUCCESS

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


KNOWLEDGE_BASE_SYSTEM_MOTD_UPDATED Field

LuaEventsId..::..KNOWLEDGE_BASE_SYSTEM_MOTD_UPDATED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId KNOWLEDGE_BASE_SYSTEM_MOTD_UPDATED
Public Const KNOWLEDGE_BASE_SYSTEM_MOTD_UPDATED As LuaEventsId
public:
literal LuaEventsId KNOWLEDGE_BASE_SYSTEM_MOTD_UPDATED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


KNOWN_CURRENCY_TYPES_UPDATE Field

LuaEventsId..::..KNOWN_CURRENCY_TYPES_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId KNOWN_CURRENCY_TYPES_UPDATE
Public Const KNOWN_CURRENCY_TYPES_UPDATE As LuaEventsId
public:
literal LuaEventsId KNOWN_CURRENCY_TYPES_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


KNOWN_TITLES_UPDATE Field

LuaEventsId..::..KNOWN_TITLES_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId KNOWN_TITLES_UPDATE
Public Const KNOWN_TITLES_UPDATE As LuaEventsId
public:
literal LuaEventsId KNOWN_TITLES_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


LANGUAGE_LIST_CHANGED Field

LuaEventsId..::..LANGUAGE_LIST_CHANGED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId LANGUAGE_LIST_CHANGED
Public Const LANGUAGE_LIST_CHANGED As LuaEventsId
public:
literal LuaEventsId LANGUAGE_LIST_CHANGED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


LEARNED_SPELL_IN_TAB Field

LuaEventsId..::..LEARNED_SPELL_IN_TAB Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId LEARNED_SPELL_IN_TAB
Public Const LEARNED_SPELL_IN_TAB As LuaEventsId
public:
literal LuaEventsId LEARNED_SPELL_IN_TAB

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


LEVEL_GRANT_PROPOSED Field

LuaEventsId..::..LEVEL_GRANT_PROPOSED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId LEVEL_GRANT_PROPOSED
Public Const LEVEL_GRANT_PROPOSED As LuaEventsId
public:
literal LuaEventsId LEVEL_GRANT_PROPOSED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


LFG_BOOT_PROPOSAL_UPDATE Field

LuaEventsId..::..LFG_BOOT_PROPOSAL_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId LFG_BOOT_PROPOSAL_UPDATE
Public Const LFG_BOOT_PROPOSAL_UPDATE As LuaEventsId
public:
literal LuaEventsId LFG_BOOT_PROPOSAL_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


LFG_COMPLETION_REWARD Field

LuaEventsId..::..LFG_COMPLETION_REWARD Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId LFG_COMPLETION_REWARD
Public Const LFG_COMPLETION_REWARD As LuaEventsId
public:
literal LuaEventsId LFG_COMPLETION_REWARD

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


LFG_LOCK_INFO_RECEIVED Field

LuaEventsId..::..LFG_LOCK_INFO_RECEIVED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId LFG_LOCK_INFO_RECEIVED
Public Const LFG_LOCK_INFO_RECEIVED As LuaEventsId
public:
literal LuaEventsId LFG_LOCK_INFO_RECEIVED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


LFG_OFFER_CONTINUE Field

LuaEventsId..::..LFG_OFFER_CONTINUE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId LFG_OFFER_CONTINUE
Public Const LFG_OFFER_CONTINUE As LuaEventsId
public:
literal LuaEventsId LFG_OFFER_CONTINUE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


LFG_OPEN_FROM_GOSSIP Field

LuaEventsId..::..LFG_OPEN_FROM_GOSSIP Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId LFG_OPEN_FROM_GOSSIP
Public Const LFG_OPEN_FROM_GOSSIP As LuaEventsId
public:
literal LuaEventsId LFG_OPEN_FROM_GOSSIP

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


LFG_PROPOSAL_FAILED Field

LuaEventsId..::..LFG_PROPOSAL_FAILED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId LFG_PROPOSAL_FAILED
Public Const LFG_PROPOSAL_FAILED As LuaEventsId
public:
literal LuaEventsId LFG_PROPOSAL_FAILED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


LFG_PROPOSAL_SHOW Field

LuaEventsId..::..LFG_PROPOSAL_SHOW Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId LFG_PROPOSAL_SHOW
Public Const LFG_PROPOSAL_SHOW As LuaEventsId
public:
literal LuaEventsId LFG_PROPOSAL_SHOW

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


LFG_PROPOSAL_SUCCEEDED Field

LuaEventsId..::..LFG_PROPOSAL_SUCCEEDED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId LFG_PROPOSAL_SUCCEEDED
Public Const LFG_PROPOSAL_SUCCEEDED As LuaEventsId
public:
literal LuaEventsId LFG_PROPOSAL_SUCCEEDED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


LFG_PROPOSAL_UPDATE Field

LuaEventsId..::..LFG_PROPOSAL_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId LFG_PROPOSAL_UPDATE
Public Const LFG_PROPOSAL_UPDATE As LuaEventsId
public:
literal LuaEventsId LFG_PROPOSAL_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


LFG_QUEUE_STATUS_UPDATE Field

LuaEventsId..::..LFG_QUEUE_STATUS_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId LFG_QUEUE_STATUS_UPDATE
Public Const LFG_QUEUE_STATUS_UPDATE As LuaEventsId
public:
literal LuaEventsId LFG_QUEUE_STATUS_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


LFG_ROLE_CHECK_HIDE Field

LuaEventsId..::..LFG_ROLE_CHECK_HIDE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId LFG_ROLE_CHECK_HIDE
Public Const LFG_ROLE_CHECK_HIDE As LuaEventsId
public:
literal LuaEventsId LFG_ROLE_CHECK_HIDE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


LFG_ROLE_CHECK_ROLE_CHOSEN Field

LuaEventsId..::..LFG_ROLE_CHECK_ROLE_CHOSEN Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId LFG_ROLE_CHECK_ROLE_CHOSEN
Public Const LFG_ROLE_CHECK_ROLE_CHOSEN As LuaEventsId
public:
literal LuaEventsId LFG_ROLE_CHECK_ROLE_CHOSEN

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


LFG_ROLE_CHECK_SHOW Field

LuaEventsId..::..LFG_ROLE_CHECK_SHOW Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId LFG_ROLE_CHECK_SHOW
Public Const LFG_ROLE_CHECK_SHOW As LuaEventsId
public:
literal LuaEventsId LFG_ROLE_CHECK_SHOW

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


LFG_ROLE_CHECK_UPDATE Field

LuaEventsId..::..LFG_ROLE_CHECK_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId LFG_ROLE_CHECK_UPDATE
Public Const LFG_ROLE_CHECK_UPDATE As LuaEventsId
public:
literal LuaEventsId LFG_ROLE_CHECK_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


LFG_ROLE_UPDATE Field

LuaEventsId..::..LFG_ROLE_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId LFG_ROLE_UPDATE
Public Const LFG_ROLE_UPDATE As LuaEventsId
public:
literal LuaEventsId LFG_ROLE_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


LFG_UPDATE Field

LuaEventsId..::..LFG_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId LFG_UPDATE
Public Const LFG_UPDATE As LuaEventsId
public:
literal LuaEventsId LFG_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


LFG_UPDATE_RANDOM_INFO Field

LuaEventsId..::..LFG_UPDATE_RANDOM_INFO Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId LFG_UPDATE_RANDOM_INFO
Public Const LFG_UPDATE_RANDOM_INFO As LuaEventsId
public:
literal LuaEventsId LFG_UPDATE_RANDOM_INFO

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


LOCALPLAYER_PET_RENAMED Field

LuaEventsId..::..LOCALPLAYER_PET_RENAMED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId LOCALPLAYER_PET_RENAMED
Public Const LOCALPLAYER_PET_RENAMED As LuaEventsId
public:
literal LuaEventsId LOCALPLAYER_PET_RENAMED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


LOGOUT_CANCEL Field

LuaEventsId..::..LOGOUT_CANCEL Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId LOGOUT_CANCEL
Public Const LOGOUT_CANCEL As LuaEventsId
public:
literal LuaEventsId LOGOUT_CANCEL

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


LOOT_BIND_CONFIRM Field

LuaEventsId..::..LOOT_BIND_CONFIRM Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId LOOT_BIND_CONFIRM
Public Const LOOT_BIND_CONFIRM As LuaEventsId
public:
literal LuaEventsId LOOT_BIND_CONFIRM

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


LOOT_CLOSED Field

LuaEventsId..::..LOOT_CLOSED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId LOOT_CLOSED
Public Const LOOT_CLOSED As LuaEventsId
public:
literal LuaEventsId LOOT_CLOSED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


LOOT_OPENED Field

LuaEventsId..::..LOOT_OPENED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId LOOT_OPENED
Public Const LOOT_OPENED As LuaEventsId
public:
literal LuaEventsId LOOT_OPENED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


LOOT_SLOT_CHANGED Field

LuaEventsId..::..LOOT_SLOT_CHANGED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId LOOT_SLOT_CHANGED
Public Const LOOT_SLOT_CHANGED As LuaEventsId
public:
literal LuaEventsId LOOT_SLOT_CHANGED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


LOOT_SLOT_CLEARED Field

LuaEventsId..::..LOOT_SLOT_CLEARED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId LOOT_SLOT_CLEARED
Public Const LOOT_SLOT_CLEARED As LuaEventsId
public:
literal LuaEventsId LOOT_SLOT_CLEARED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


MACRO_ACTION_BLOCKED Field

LuaEventsId..::..MACRO_ACTION_BLOCKED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId MACRO_ACTION_BLOCKED
Public Const MACRO_ACTION_BLOCKED As LuaEventsId
public:
literal LuaEventsId MACRO_ACTION_BLOCKED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


MACRO_ACTION_FORBIDDEN Field

LuaEventsId..::..MACRO_ACTION_FORBIDDEN Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId MACRO_ACTION_FORBIDDEN
Public Const MACRO_ACTION_FORBIDDEN As LuaEventsId
public:
literal LuaEventsId MACRO_ACTION_FORBIDDEN

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


MAIL_CLOSED Field

LuaEventsId..::..MAIL_CLOSED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId MAIL_CLOSED
Public Const MAIL_CLOSED As LuaEventsId
public:
literal LuaEventsId MAIL_CLOSED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


MAIL_FAILED Field

LuaEventsId..::..MAIL_FAILED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId MAIL_FAILED
Public Const MAIL_FAILED As LuaEventsId
public:
literal LuaEventsId MAIL_FAILED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


MAIL_INBOX_UPDATE Field

LuaEventsId..::..MAIL_INBOX_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId MAIL_INBOX_UPDATE
Public Const MAIL_INBOX_UPDATE As LuaEventsId
public:
literal LuaEventsId MAIL_INBOX_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


MAIL_LOCK_SEND_ITEMS Field

LuaEventsId..::..MAIL_LOCK_SEND_ITEMS Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId MAIL_LOCK_SEND_ITEMS
Public Const MAIL_LOCK_SEND_ITEMS As LuaEventsId
public:
literal LuaEventsId MAIL_LOCK_SEND_ITEMS

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


MAIL_SEND_INFO_UPDATE Field

LuaEventsId..::..MAIL_SEND_INFO_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId MAIL_SEND_INFO_UPDATE
Public Const MAIL_SEND_INFO_UPDATE As LuaEventsId
public:
literal LuaEventsId MAIL_SEND_INFO_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


MAIL_SEND_SUCCESS Field

LuaEventsId..::..MAIL_SEND_SUCCESS Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId MAIL_SEND_SUCCESS
Public Const MAIL_SEND_SUCCESS As LuaEventsId
public:
literal LuaEventsId MAIL_SEND_SUCCESS

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


MAIL_SHOW Field

LuaEventsId..::..MAIL_SHOW Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId MAIL_SHOW
Public Const MAIL_SHOW As LuaEventsId
public:
literal LuaEventsId MAIL_SHOW

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


MAIL_SUCCESS Field

LuaEventsId..::..MAIL_SUCCESS Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId MAIL_SUCCESS
Public Const MAIL_SUCCESS As LuaEventsId
public:
literal LuaEventsId MAIL_SUCCESS

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


MAIL_UNLOCK_SEND_ITEMS Field

LuaEventsId..::..MAIL_UNLOCK_SEND_ITEMS Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId MAIL_UNLOCK_SEND_ITEMS
Public Const MAIL_UNLOCK_SEND_ITEMS As LuaEventsId
public:
literal LuaEventsId MAIL_UNLOCK_SEND_ITEMS

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


MERCHANT_CLOSED Field

LuaEventsId..::..MERCHANT_CLOSED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId MERCHANT_CLOSED
Public Const MERCHANT_CLOSED As LuaEventsId
public:
literal LuaEventsId MERCHANT_CLOSED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


MERCHANT_SHOW Field

LuaEventsId..::..MERCHANT_SHOW Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId MERCHANT_SHOW
Public Const MERCHANT_SHOW As LuaEventsId
public:
literal LuaEventsId MERCHANT_SHOW

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


MERCHANT_UPDATE Field

LuaEventsId..::..MERCHANT_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId MERCHANT_UPDATE
Public Const MERCHANT_UPDATE As LuaEventsId
public:
literal LuaEventsId MERCHANT_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


MINIGAME_UPDATE Field

LuaEventsId..::..MINIGAME_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId MINIGAME_UPDATE
Public Const MINIGAME_UPDATE As LuaEventsId
public:
literal LuaEventsId MINIGAME_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


MINIMAP_PING Field

LuaEventsId..::..MINIMAP_PING Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId MINIMAP_PING
Public Const MINIMAP_PING As LuaEventsId
public:
literal LuaEventsId MINIMAP_PING

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


MINIMAP_UPDATE_TRACKING Field

LuaEventsId..::..MINIMAP_UPDATE_TRACKING Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId MINIMAP_UPDATE_TRACKING
Public Const MINIMAP_UPDATE_TRACKING As LuaEventsId
public:
literal LuaEventsId MINIMAP_UPDATE_TRACKING

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


MINIMAP_UPDATE_ZOOM Field

LuaEventsId..::..MINIMAP_UPDATE_ZOOM Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId MINIMAP_UPDATE_ZOOM
Public Const MINIMAP_UPDATE_ZOOM As LuaEventsId
public:
literal LuaEventsId MINIMAP_UPDATE_ZOOM

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


MIRROR_TIMER_PAUSE Field

LuaEventsId..::..MIRROR_TIMER_PAUSE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId MIRROR_TIMER_PAUSE
Public Const MIRROR_TIMER_PAUSE As LuaEventsId
public:
literal LuaEventsId MIRROR_TIMER_PAUSE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


MIRROR_TIMER_START Field

LuaEventsId..::..MIRROR_TIMER_START Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId MIRROR_TIMER_START
Public Const MIRROR_TIMER_START As LuaEventsId
public:
literal LuaEventsId MIRROR_TIMER_START

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


MIRROR_TIMER_STOP Field

LuaEventsId..::..MIRROR_TIMER_STOP Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId MIRROR_TIMER_STOP
Public Const MIRROR_TIMER_STOP As LuaEventsId
public:
literal LuaEventsId MIRROR_TIMER_STOP

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


MODIFIER_STATE_CHANGED Field

LuaEventsId..::..MODIFIER_STATE_CHANGED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId MODIFIER_STATE_CHANGED
Public Const MODIFIER_STATE_CHANGED As LuaEventsId
public:
literal LuaEventsId MODIFIER_STATE_CHANGED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


MOVIE_COMPRESSING_PROGRESS Field

LuaEventsId..::..MOVIE_COMPRESSING_PROGRESS Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId MOVIE_COMPRESSING_PROGRESS
Public Const MOVIE_COMPRESSING_PROGRESS As LuaEventsId
public:
literal LuaEventsId MOVIE_COMPRESSING_PROGRESS

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


MOVIE_RECORDING_PROGRESS Field

LuaEventsId..::..MOVIE_RECORDING_PROGRESS Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId MOVIE_RECORDING_PROGRESS
Public Const MOVIE_RECORDING_PROGRESS As LuaEventsId
public:
literal LuaEventsId MOVIE_RECORDING_PROGRESS

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


MOVIE_UNCOMPRESSED_MOVIE Field

LuaEventsId..::..MOVIE_UNCOMPRESSED_MOVIE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId MOVIE_UNCOMPRESSED_MOVIE
Public Const MOVIE_UNCOMPRESSED_MOVIE As LuaEventsId
public:
literal LuaEventsId MOVIE_UNCOMPRESSED_MOVIE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


MUTELIST_UPDATE Field

LuaEventsId..::..MUTELIST_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId MUTELIST_UPDATE
Public Const MUTELIST_UPDATE As LuaEventsId
public:
literal LuaEventsId MUTELIST_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


NEW_AUCTION_UPDATE Field

LuaEventsId..::..NEW_AUCTION_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId NEW_AUCTION_UPDATE
Public Const NEW_AUCTION_UPDATE As LuaEventsId
public:
literal LuaEventsId NEW_AUCTION_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


NEW_TITLE_EARNED Field

LuaEventsId..::..NEW_TITLE_EARNED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId NEW_TITLE_EARNED
Public Const NEW_TITLE_EARNED As LuaEventsId
public:
literal LuaEventsId NEW_TITLE_EARNED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


NPC_PVPQUEUE_ANYWHERE Field

LuaEventsId..::..NPC_PVPQUEUE_ANYWHERE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId NPC_PVPQUEUE_ANYWHERE
Public Const NPC_PVPQUEUE_ANYWHERE As LuaEventsId
public:
literal LuaEventsId NPC_PVPQUEUE_ANYWHERE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


OLD_TITLE_LOST Field

LuaEventsId..::..OLD_TITLE_LOST Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId OLD_TITLE_LOST
Public Const OLD_TITLE_LOST As LuaEventsId
public:
literal LuaEventsId OLD_TITLE_LOST

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


OPEN_MASTER_LOOT_LIST Field

LuaEventsId..::..OPEN_MASTER_LOOT_LIST Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId OPEN_MASTER_LOOT_LIST
Public Const OPEN_MASTER_LOOT_LIST As LuaEventsId
public:
literal LuaEventsId OPEN_MASTER_LOOT_LIST

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


OPEN_TABARD_FRAME Field

LuaEventsId..::..OPEN_TABARD_FRAME Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId OPEN_TABARD_FRAME
Public Const OPEN_TABARD_FRAME As LuaEventsId
public:
literal LuaEventsId OPEN_TABARD_FRAME

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PARTY_CONVERTED_TO_RAID Field

LuaEventsId..::..PARTY_CONVERTED_TO_RAID Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PARTY_CONVERTED_TO_RAID
Public Const PARTY_CONVERTED_TO_RAID As LuaEventsId
public:
literal LuaEventsId PARTY_CONVERTED_TO_RAID

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PARTY_INVITE_CANCEL Field

LuaEventsId..::..PARTY_INVITE_CANCEL Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PARTY_INVITE_CANCEL
Public Const PARTY_INVITE_CANCEL As LuaEventsId
public:
literal LuaEventsId PARTY_INVITE_CANCEL

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PARTY_INVITE_REQUEST Field

LuaEventsId..::..PARTY_INVITE_REQUEST Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PARTY_INVITE_REQUEST
Public Const PARTY_INVITE_REQUEST As LuaEventsId
public:
literal LuaEventsId PARTY_INVITE_REQUEST

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PARTY_LEADER_CHANGED Field

LuaEventsId..::..PARTY_LEADER_CHANGED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PARTY_LEADER_CHANGED
Public Const PARTY_LEADER_CHANGED As LuaEventsId
public:
literal LuaEventsId PARTY_LEADER_CHANGED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PARTY_LFG_RESTRICTED Field

LuaEventsId..::..PARTY_LFG_RESTRICTED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PARTY_LFG_RESTRICTED
Public Const PARTY_LFG_RESTRICTED As LuaEventsId
public:
literal LuaEventsId PARTY_LFG_RESTRICTED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PARTY_LOOT_METHOD_CHANGED Field

LuaEventsId..::..PARTY_LOOT_METHOD_CHANGED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PARTY_LOOT_METHOD_CHANGED
Public Const PARTY_LOOT_METHOD_CHANGED As LuaEventsId
public:
literal LuaEventsId PARTY_LOOT_METHOD_CHANGED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PARTY_MEMBER_DISABLE Field

LuaEventsId..::..PARTY_MEMBER_DISABLE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PARTY_MEMBER_DISABLE
Public Const PARTY_MEMBER_DISABLE As LuaEventsId
public:
literal LuaEventsId PARTY_MEMBER_DISABLE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PARTY_MEMBER_ENABLE Field

LuaEventsId..::..PARTY_MEMBER_ENABLE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PARTY_MEMBER_ENABLE
Public Const PARTY_MEMBER_ENABLE As LuaEventsId
public:
literal LuaEventsId PARTY_MEMBER_ENABLE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PARTY_MEMBERS_CHANGED Field

LuaEventsId..::..PARTY_MEMBERS_CHANGED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PARTY_MEMBERS_CHANGED
Public Const PARTY_MEMBERS_CHANGED As LuaEventsId
public:
literal LuaEventsId PARTY_MEMBERS_CHANGED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PET_ATTACK_START Field

LuaEventsId..::..PET_ATTACK_START Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PET_ATTACK_START
Public Const PET_ATTACK_START As LuaEventsId
public:
literal LuaEventsId PET_ATTACK_START

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PET_ATTACK_STOP Field

LuaEventsId..::..PET_ATTACK_STOP Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PET_ATTACK_STOP
Public Const PET_ATTACK_STOP As LuaEventsId
public:
literal LuaEventsId PET_ATTACK_STOP

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PET_BAR_HIDE Field

LuaEventsId..::..PET_BAR_HIDE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PET_BAR_HIDE
Public Const PET_BAR_HIDE As LuaEventsId
public:
literal LuaEventsId PET_BAR_HIDE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PET_BAR_HIDEGRID Field

LuaEventsId..::..PET_BAR_HIDEGRID Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PET_BAR_HIDEGRID
Public Const PET_BAR_HIDEGRID As LuaEventsId
public:
literal LuaEventsId PET_BAR_HIDEGRID

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PET_BAR_SHOWGRID Field

LuaEventsId..::..PET_BAR_SHOWGRID Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PET_BAR_SHOWGRID
Public Const PET_BAR_SHOWGRID As LuaEventsId
public:
literal LuaEventsId PET_BAR_SHOWGRID

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PET_BAR_UPDATE Field

LuaEventsId..::..PET_BAR_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PET_BAR_UPDATE
Public Const PET_BAR_UPDATE As LuaEventsId
public:
literal LuaEventsId PET_BAR_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PET_BAR_UPDATE_COOLDOWN Field

LuaEventsId..::..PET_BAR_UPDATE_COOLDOWN Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PET_BAR_UPDATE_COOLDOWN
Public Const PET_BAR_UPDATE_COOLDOWN As LuaEventsId
public:
literal LuaEventsId PET_BAR_UPDATE_COOLDOWN

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PET_BAR_UPDATE_USABLE Field

LuaEventsId..::..PET_BAR_UPDATE_USABLE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PET_BAR_UPDATE_USABLE
Public Const PET_BAR_UPDATE_USABLE As LuaEventsId
public:
literal LuaEventsId PET_BAR_UPDATE_USABLE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PET_DISMISS_START Field

LuaEventsId..::..PET_DISMISS_START Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PET_DISMISS_START
Public Const PET_DISMISS_START As LuaEventsId
public:
literal LuaEventsId PET_DISMISS_START

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PET_FORCE_NAME_DECLENSION Field

LuaEventsId..::..PET_FORCE_NAME_DECLENSION Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PET_FORCE_NAME_DECLENSION
Public Const PET_FORCE_NAME_DECLENSION As LuaEventsId
public:
literal LuaEventsId PET_FORCE_NAME_DECLENSION

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PET_RENAMEABLE Field

LuaEventsId..::..PET_RENAMEABLE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PET_RENAMEABLE
Public Const PET_RENAMEABLE As LuaEventsId
public:
literal LuaEventsId PET_RENAMEABLE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PET_SPELL_POWER_UPDATE Field

LuaEventsId..::..PET_SPELL_POWER_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PET_SPELL_POWER_UPDATE
Public Const PET_SPELL_POWER_UPDATE As LuaEventsId
public:
literal LuaEventsId PET_SPELL_POWER_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PET_STABLE_CLOSED Field

LuaEventsId..::..PET_STABLE_CLOSED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PET_STABLE_CLOSED
Public Const PET_STABLE_CLOSED As LuaEventsId
public:
literal LuaEventsId PET_STABLE_CLOSED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PET_STABLE_SHOW Field

LuaEventsId..::..PET_STABLE_SHOW Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PET_STABLE_SHOW
Public Const PET_STABLE_SHOW As LuaEventsId
public:
literal LuaEventsId PET_STABLE_SHOW

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PET_STABLE_UPDATE Field

LuaEventsId..::..PET_STABLE_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PET_STABLE_UPDATE
Public Const PET_STABLE_UPDATE As LuaEventsId
public:
literal LuaEventsId PET_STABLE_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PET_STABLE_UPDATE_PAPERDOLL Field

LuaEventsId..::..PET_STABLE_UPDATE_PAPERDOLL Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PET_STABLE_UPDATE_PAPERDOLL
Public Const PET_STABLE_UPDATE_PAPERDOLL As LuaEventsId
public:
literal LuaEventsId PET_STABLE_UPDATE_PAPERDOLL

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PET_TALENT_UPDATE Field

LuaEventsId..::..PET_TALENT_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PET_TALENT_UPDATE
Public Const PET_TALENT_UPDATE As LuaEventsId
public:
literal LuaEventsId PET_TALENT_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PET_UI_CLOSE Field

LuaEventsId..::..PET_UI_CLOSE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PET_UI_CLOSE
Public Const PET_UI_CLOSE As LuaEventsId
public:
literal LuaEventsId PET_UI_CLOSE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PET_UI_UPDATE Field

LuaEventsId..::..PET_UI_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PET_UI_UPDATE
Public Const PET_UI_UPDATE As LuaEventsId
public:
literal LuaEventsId PET_UI_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PETITION_CLOSED Field

LuaEventsId..::..PETITION_CLOSED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PETITION_CLOSED
Public Const PETITION_CLOSED As LuaEventsId
public:
literal LuaEventsId PETITION_CLOSED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PETITION_SHOW Field

LuaEventsId..::..PETITION_SHOW Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PETITION_SHOW
Public Const PETITION_SHOW As LuaEventsId
public:
literal LuaEventsId PETITION_SHOW

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PETITION_VENDOR_CLOSED Field

LuaEventsId..::..PETITION_VENDOR_CLOSED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PETITION_VENDOR_CLOSED
Public Const PETITION_VENDOR_CLOSED As LuaEventsId
public:
literal LuaEventsId PETITION_VENDOR_CLOSED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PETITION_VENDOR_SHOW Field

LuaEventsId..::..PETITION_VENDOR_SHOW Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PETITION_VENDOR_SHOW
Public Const PETITION_VENDOR_SHOW As LuaEventsId
public:
literal LuaEventsId PETITION_VENDOR_SHOW

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PETITION_VENDOR_UPDATE Field

LuaEventsId..::..PETITION_VENDOR_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PETITION_VENDOR_UPDATE
Public Const PETITION_VENDOR_UPDATE As LuaEventsId
public:
literal LuaEventsId PETITION_VENDOR_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PLAY_MOVIE Field

LuaEventsId..::..PLAY_MOVIE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PLAY_MOVIE
Public Const PLAY_MOVIE As LuaEventsId
public:
literal LuaEventsId PLAY_MOVIE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PLAYER_ALIVE Field

LuaEventsId..::..PLAYER_ALIVE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PLAYER_ALIVE
Public Const PLAYER_ALIVE As LuaEventsId
public:
literal LuaEventsId PLAYER_ALIVE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PLAYER_AURAS_CHANGED Field

LuaEventsId..::..PLAYER_AURAS_CHANGED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PLAYER_AURAS_CHANGED
Public Const PLAYER_AURAS_CHANGED As LuaEventsId
public:
literal LuaEventsId PLAYER_AURAS_CHANGED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PLAYER_CAMPING Field

LuaEventsId..::..PLAYER_CAMPING Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PLAYER_CAMPING
Public Const PLAYER_CAMPING As LuaEventsId
public:
literal LuaEventsId PLAYER_CAMPING

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PLAYER_CONTROL_GAINED Field

LuaEventsId..::..PLAYER_CONTROL_GAINED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PLAYER_CONTROL_GAINED
Public Const PLAYER_CONTROL_GAINED As LuaEventsId
public:
literal LuaEventsId PLAYER_CONTROL_GAINED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PLAYER_CONTROL_LOST Field

LuaEventsId..::..PLAYER_CONTROL_LOST Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PLAYER_CONTROL_LOST
Public Const PLAYER_CONTROL_LOST As LuaEventsId
public:
literal LuaEventsId PLAYER_CONTROL_LOST

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PLAYER_DAMAGE_DONE_MODS Field

LuaEventsId..::..PLAYER_DAMAGE_DONE_MODS Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PLAYER_DAMAGE_DONE_MODS
Public Const PLAYER_DAMAGE_DONE_MODS As LuaEventsId
public:
literal LuaEventsId PLAYER_DAMAGE_DONE_MODS

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PLAYER_DEAD Field

LuaEventsId..::..PLAYER_DEAD Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PLAYER_DEAD
Public Const PLAYER_DEAD As LuaEventsId
public:
literal LuaEventsId PLAYER_DEAD

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PLAYER_DIFFICULTY_CHANGED Field

LuaEventsId..::..PLAYER_DIFFICULTY_CHANGED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PLAYER_DIFFICULTY_CHANGED
Public Const PLAYER_DIFFICULTY_CHANGED As LuaEventsId
public:
literal LuaEventsId PLAYER_DIFFICULTY_CHANGED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PLAYER_ENTER_COMBAT Field

LuaEventsId..::..PLAYER_ENTER_COMBAT Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PLAYER_ENTER_COMBAT
Public Const PLAYER_ENTER_COMBAT As LuaEventsId
public:
literal LuaEventsId PLAYER_ENTER_COMBAT

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PLAYER_ENTERING_BATTLEGROUND Field

LuaEventsId..::..PLAYER_ENTERING_BATTLEGROUND Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PLAYER_ENTERING_BATTLEGROUND
Public Const PLAYER_ENTERING_BATTLEGROUND As LuaEventsId
public:
literal LuaEventsId PLAYER_ENTERING_BATTLEGROUND

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PLAYER_ENTERING_WORLD Field

LuaEventsId..::..PLAYER_ENTERING_WORLD Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PLAYER_ENTERING_WORLD
Public Const PLAYER_ENTERING_WORLD As LuaEventsId
public:
literal LuaEventsId PLAYER_ENTERING_WORLD

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PLAYER_EQUIPMENT_CHANGED Field

LuaEventsId..::..PLAYER_EQUIPMENT_CHANGED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PLAYER_EQUIPMENT_CHANGED
Public Const PLAYER_EQUIPMENT_CHANGED As LuaEventsId
public:
literal LuaEventsId PLAYER_EQUIPMENT_CHANGED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PLAYER_FARSIGHT_FOCUS_CHANGED Field

LuaEventsId..::..PLAYER_FARSIGHT_FOCUS_CHANGED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PLAYER_FARSIGHT_FOCUS_CHANGED
Public Const PLAYER_FARSIGHT_FOCUS_CHANGED As LuaEventsId
public:
literal LuaEventsId PLAYER_FARSIGHT_FOCUS_CHANGED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PLAYER_FLAGS_CHANGED Field

LuaEventsId..::..PLAYER_FLAGS_CHANGED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PLAYER_FLAGS_CHANGED
Public Const PLAYER_FLAGS_CHANGED As LuaEventsId
public:
literal LuaEventsId PLAYER_FLAGS_CHANGED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PLAYER_FOCUS_CHANGED Field

LuaEventsId..::..PLAYER_FOCUS_CHANGED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PLAYER_FOCUS_CHANGED
Public Const PLAYER_FOCUS_CHANGED As LuaEventsId
public:
literal LuaEventsId PLAYER_FOCUS_CHANGED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PLAYER_GAINS_VEHICLE_DATA Field

LuaEventsId..::..PLAYER_GAINS_VEHICLE_DATA Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PLAYER_GAINS_VEHICLE_DATA
Public Const PLAYER_GAINS_VEHICLE_DATA As LuaEventsId
public:
literal LuaEventsId PLAYER_GAINS_VEHICLE_DATA

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PLAYER_GUILD_UPDATE Field

LuaEventsId..::..PLAYER_GUILD_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PLAYER_GUILD_UPDATE
Public Const PLAYER_GUILD_UPDATE As LuaEventsId
public:
literal LuaEventsId PLAYER_GUILD_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PLAYER_LEAVE_COMBAT Field

LuaEventsId..::..PLAYER_LEAVE_COMBAT Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PLAYER_LEAVE_COMBAT
Public Const PLAYER_LEAVE_COMBAT As LuaEventsId
public:
literal LuaEventsId PLAYER_LEAVE_COMBAT

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PLAYER_LEAVING_WORLD Field

LuaEventsId..::..PLAYER_LEAVING_WORLD Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PLAYER_LEAVING_WORLD
Public Const PLAYER_LEAVING_WORLD As LuaEventsId
public:
literal LuaEventsId PLAYER_LEAVING_WORLD

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PLAYER_LEVEL_UP Field

LuaEventsId..::..PLAYER_LEVEL_UP Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PLAYER_LEVEL_UP
Public Const PLAYER_LEVEL_UP As LuaEventsId
public:
literal LuaEventsId PLAYER_LEVEL_UP

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PLAYER_LOGIN Field

LuaEventsId..::..PLAYER_LOGIN Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PLAYER_LOGIN
Public Const PLAYER_LOGIN As LuaEventsId
public:
literal LuaEventsId PLAYER_LOGIN

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PLAYER_LOGOUT Field

LuaEventsId..::..PLAYER_LOGOUT Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PLAYER_LOGOUT
Public Const PLAYER_LOGOUT As LuaEventsId
public:
literal LuaEventsId PLAYER_LOGOUT

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PLAYER_LOSES_VEHICLE_DATA Field

LuaEventsId..::..PLAYER_LOSES_VEHICLE_DATA Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PLAYER_LOSES_VEHICLE_DATA
Public Const PLAYER_LOSES_VEHICLE_DATA As LuaEventsId
public:
literal LuaEventsId PLAYER_LOSES_VEHICLE_DATA

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PLAYER_MONEY Field

LuaEventsId..::..PLAYER_MONEY Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PLAYER_MONEY
Public Const PLAYER_MONEY As LuaEventsId
public:
literal LuaEventsId PLAYER_MONEY

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PLAYER_PVP_KILLS_CHANGED Field

LuaEventsId..::..PLAYER_PVP_KILLS_CHANGED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PLAYER_PVP_KILLS_CHANGED
Public Const PLAYER_PVP_KILLS_CHANGED As LuaEventsId
public:
literal LuaEventsId PLAYER_PVP_KILLS_CHANGED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PLAYER_PVP_RANK_CHANGED Field

LuaEventsId..::..PLAYER_PVP_RANK_CHANGED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PLAYER_PVP_RANK_CHANGED
Public Const PLAYER_PVP_RANK_CHANGED As LuaEventsId
public:
literal LuaEventsId PLAYER_PVP_RANK_CHANGED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PLAYER_QUITING Field

LuaEventsId..::..PLAYER_QUITING Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PLAYER_QUITING
Public Const PLAYER_QUITING As LuaEventsId
public:
literal LuaEventsId PLAYER_QUITING

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PLAYER_REGEN_DISABLED Field

LuaEventsId..::..PLAYER_REGEN_DISABLED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PLAYER_REGEN_DISABLED
Public Const PLAYER_REGEN_DISABLED As LuaEventsId
public:
literal LuaEventsId PLAYER_REGEN_DISABLED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PLAYER_REGEN_ENABLED Field

LuaEventsId..::..PLAYER_REGEN_ENABLED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PLAYER_REGEN_ENABLED
Public Const PLAYER_REGEN_ENABLED As LuaEventsId
public:
literal LuaEventsId PLAYER_REGEN_ENABLED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PLAYER_ROLES_ASSIGNED Field

LuaEventsId..::..PLAYER_ROLES_ASSIGNED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PLAYER_ROLES_ASSIGNED
Public Const PLAYER_ROLES_ASSIGNED As LuaEventsId
public:
literal LuaEventsId PLAYER_ROLES_ASSIGNED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PLAYER_SKINNED Field

LuaEventsId..::..PLAYER_SKINNED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PLAYER_SKINNED
Public Const PLAYER_SKINNED As LuaEventsId
public:
literal LuaEventsId PLAYER_SKINNED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PLAYER_TALENT_UPDATE Field

LuaEventsId..::..PLAYER_TALENT_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PLAYER_TALENT_UPDATE
Public Const PLAYER_TALENT_UPDATE As LuaEventsId
public:
literal LuaEventsId PLAYER_TALENT_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PLAYER_TARGET_CHANGED Field

LuaEventsId..::..PLAYER_TARGET_CHANGED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PLAYER_TARGET_CHANGED
Public Const PLAYER_TARGET_CHANGED As LuaEventsId
public:
literal LuaEventsId PLAYER_TARGET_CHANGED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PLAYER_TOTEM_UPDATE Field

LuaEventsId..::..PLAYER_TOTEM_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PLAYER_TOTEM_UPDATE
Public Const PLAYER_TOTEM_UPDATE As LuaEventsId
public:
literal LuaEventsId PLAYER_TOTEM_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PLAYER_TRADE_MONEY Field

LuaEventsId..::..PLAYER_TRADE_MONEY Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PLAYER_TRADE_MONEY
Public Const PLAYER_TRADE_MONEY As LuaEventsId
public:
literal LuaEventsId PLAYER_TRADE_MONEY

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PLAYER_UNGHOST Field

LuaEventsId..::..PLAYER_UNGHOST Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PLAYER_UNGHOST
Public Const PLAYER_UNGHOST As LuaEventsId
public:
literal LuaEventsId PLAYER_UNGHOST

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PLAYER_UPDATE_RESTING Field

LuaEventsId..::..PLAYER_UPDATE_RESTING Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PLAYER_UPDATE_RESTING
Public Const PLAYER_UPDATE_RESTING As LuaEventsId
public:
literal LuaEventsId PLAYER_UPDATE_RESTING

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PLAYER_XP_UPDATE Field

LuaEventsId..::..PLAYER_XP_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PLAYER_XP_UPDATE
Public Const PLAYER_XP_UPDATE As LuaEventsId
public:
literal LuaEventsId PLAYER_XP_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PLAYERBANKBAGSLOTS_CHANGED Field

LuaEventsId..::..PLAYERBANKBAGSLOTS_CHANGED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PLAYERBANKBAGSLOTS_CHANGED
Public Const PLAYERBANKBAGSLOTS_CHANGED As LuaEventsId
public:
literal LuaEventsId PLAYERBANKBAGSLOTS_CHANGED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PLAYERBANKSLOTS_CHANGED Field

LuaEventsId..::..PLAYERBANKSLOTS_CHANGED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PLAYERBANKSLOTS_CHANGED
Public Const PLAYERBANKSLOTS_CHANGED As LuaEventsId
public:
literal LuaEventsId PLAYERBANKSLOTS_CHANGED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PLAYTIME_CHANGED Field

LuaEventsId..::..PLAYTIME_CHANGED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PLAYTIME_CHANGED
Public Const PLAYTIME_CHANGED As LuaEventsId
public:
literal LuaEventsId PLAYTIME_CHANGED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PREVIEW_PET_TALENT_POINTS_CHANGED Field

LuaEventsId..::..PREVIEW_PET_TALENT_POINTS_CHANGED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PREVIEW_PET_TALENT_POINTS_CHANGED
Public Const PREVIEW_PET_TALENT_POINTS_CHANGED As LuaEventsId
public:
literal LuaEventsId PREVIEW_PET_TALENT_POINTS_CHANGED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PREVIEW_TALENT_POINTS_CHANGED Field

LuaEventsId..::..PREVIEW_TALENT_POINTS_CHANGED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PREVIEW_TALENT_POINTS_CHANGED
Public Const PREVIEW_TALENT_POINTS_CHANGED As LuaEventsId
public:
literal LuaEventsId PREVIEW_TALENT_POINTS_CHANGED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PVPQUEUE_ANYWHERE_SHOW Field

LuaEventsId..::..PVPQUEUE_ANYWHERE_SHOW Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PVPQUEUE_ANYWHERE_SHOW
Public Const PVPQUEUE_ANYWHERE_SHOW As LuaEventsId
public:
literal LuaEventsId PVPQUEUE_ANYWHERE_SHOW

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


PVPQUEUE_ANYWHERE_UPDATE_AVAILABLE Field

LuaEventsId..::..PVPQUEUE_ANYWHERE_UPDATE_AVAILABLE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId PVPQUEUE_ANYWHERE_UPDATE_AVAILABLE
Public Const PVPQUEUE_ANYWHERE_UPDATE_AVAILABLE As LuaEventsId
public:
literal LuaEventsId PVPQUEUE_ANYWHERE_UPDATE_AVAILABLE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


QUEST_ACCEPT_CONFIRM Field

LuaEventsId..::..QUEST_ACCEPT_CONFIRM Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId QUEST_ACCEPT_CONFIRM
Public Const QUEST_ACCEPT_CONFIRM As LuaEventsId
public:
literal LuaEventsId QUEST_ACCEPT_CONFIRM

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


QUEST_ACCEPTED Field

LuaEventsId..::..QUEST_ACCEPTED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId QUEST_ACCEPTED
Public Const QUEST_ACCEPTED As LuaEventsId
public:
literal LuaEventsId QUEST_ACCEPTED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


QUEST_COMPLETE Field

LuaEventsId..::..QUEST_COMPLETE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId QUEST_COMPLETE
Public Const QUEST_COMPLETE As LuaEventsId
public:
literal LuaEventsId QUEST_COMPLETE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


QUEST_DETAIL Field

LuaEventsId..::..QUEST_DETAIL Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId QUEST_DETAIL
Public Const QUEST_DETAIL As LuaEventsId
public:
literal LuaEventsId QUEST_DETAIL

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


QUEST_FINISHED Field

LuaEventsId..::..QUEST_FINISHED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId QUEST_FINISHED
Public Const QUEST_FINISHED As LuaEventsId
public:
literal LuaEventsId QUEST_FINISHED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


QUEST_GREETING Field

LuaEventsId..::..QUEST_GREETING Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId QUEST_GREETING
Public Const QUEST_GREETING As LuaEventsId
public:
literal LuaEventsId QUEST_GREETING

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


QUEST_ITEM_UPDATE Field

LuaEventsId..::..QUEST_ITEM_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId QUEST_ITEM_UPDATE
Public Const QUEST_ITEM_UPDATE As LuaEventsId
public:
literal LuaEventsId QUEST_ITEM_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


QUEST_LOG_UPDATE Field

LuaEventsId..::..QUEST_LOG_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId QUEST_LOG_UPDATE
Public Const QUEST_LOG_UPDATE As LuaEventsId
public:
literal LuaEventsId QUEST_LOG_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


QUEST_POI_UPDATE Field

LuaEventsId..::..QUEST_POI_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId QUEST_POI_UPDATE
Public Const QUEST_POI_UPDATE As LuaEventsId
public:
literal LuaEventsId QUEST_POI_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


QUEST_PROGRESS Field

LuaEventsId..::..QUEST_PROGRESS Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId QUEST_PROGRESS
Public Const QUEST_PROGRESS As LuaEventsId
public:
literal LuaEventsId QUEST_PROGRESS

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


QUEST_QUERY_COMPLETE Field

LuaEventsId..::..QUEST_QUERY_COMPLETE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId QUEST_QUERY_COMPLETE
Public Const QUEST_QUERY_COMPLETE As LuaEventsId
public:
literal LuaEventsId QUEST_QUERY_COMPLETE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


QUEST_WATCH_UPDATE Field

LuaEventsId..::..QUEST_WATCH_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId QUEST_WATCH_UPDATE
Public Const QUEST_WATCH_UPDATE As LuaEventsId
public:
literal LuaEventsId QUEST_WATCH_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


RAID_INSTANCE_WELCOME Field

LuaEventsId..::..RAID_INSTANCE_WELCOME Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId RAID_INSTANCE_WELCOME
Public Const RAID_INSTANCE_WELCOME As LuaEventsId
public:
literal LuaEventsId RAID_INSTANCE_WELCOME

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


RAID_ROSTER_UPDATE Field

LuaEventsId..::..RAID_ROSTER_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId RAID_ROSTER_UPDATE
Public Const RAID_ROSTER_UPDATE As LuaEventsId
public:
literal LuaEventsId RAID_ROSTER_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


RAID_TARGET_UPDATE Field

LuaEventsId..::..RAID_TARGET_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId RAID_TARGET_UPDATE
Public Const RAID_TARGET_UPDATE As LuaEventsId
public:
literal LuaEventsId RAID_TARGET_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


RAISED_AS_GHOUL Field

LuaEventsId..::..RAISED_AS_GHOUL Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId RAISED_AS_GHOUL
Public Const RAISED_AS_GHOUL As LuaEventsId
public:
literal LuaEventsId RAISED_AS_GHOUL

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


READY_CHECK Field

LuaEventsId..::..READY_CHECK Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId READY_CHECK
Public Const READY_CHECK As LuaEventsId
public:
literal LuaEventsId READY_CHECK

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


READY_CHECK_CONFIRM Field

LuaEventsId..::..READY_CHECK_CONFIRM Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId READY_CHECK_CONFIRM
Public Const READY_CHECK_CONFIRM As LuaEventsId
public:
literal LuaEventsId READY_CHECK_CONFIRM

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


READY_CHECK_FINISHED Field

LuaEventsId..::..READY_CHECK_FINISHED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId READY_CHECK_FINISHED
Public Const READY_CHECK_FINISHED As LuaEventsId
public:
literal LuaEventsId READY_CHECK_FINISHED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


RECEIVED_ACHIEVEMENT_LIST Field

LuaEventsId..::..RECEIVED_ACHIEVEMENT_LIST Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId RECEIVED_ACHIEVEMENT_LIST
Public Const RECEIVED_ACHIEVEMENT_LIST As LuaEventsId
public:
literal LuaEventsId RECEIVED_ACHIEVEMENT_LIST

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


REPLACE_ENCHANT Field

LuaEventsId..::..REPLACE_ENCHANT Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId REPLACE_ENCHANT
Public Const REPLACE_ENCHANT As LuaEventsId
public:
literal LuaEventsId REPLACE_ENCHANT

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


RESURRECT_REQUEST Field

LuaEventsId..::..RESURRECT_REQUEST Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId RESURRECT_REQUEST
Public Const RESURRECT_REQUEST As LuaEventsId
public:
literal LuaEventsId RESURRECT_REQUEST

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


RUNE_POWER_UPDATE Field

LuaEventsId..::..RUNE_POWER_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId RUNE_POWER_UPDATE
Public Const RUNE_POWER_UPDATE As LuaEventsId
public:
literal LuaEventsId RUNE_POWER_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


RUNE_TYPE_UPDATE Field

LuaEventsId..::..RUNE_TYPE_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId RUNE_TYPE_UPDATE
Public Const RUNE_TYPE_UPDATE As LuaEventsId
public:
literal LuaEventsId RUNE_TYPE_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


SCREENSHOT_FAILED Field

LuaEventsId..::..SCREENSHOT_FAILED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId SCREENSHOT_FAILED
Public Const SCREENSHOT_FAILED As LuaEventsId
public:
literal LuaEventsId SCREENSHOT_FAILED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


SCREENSHOT_SUCCEEDED Field

LuaEventsId..::..SCREENSHOT_SUCCEEDED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId SCREENSHOT_SUCCEEDED
Public Const SCREENSHOT_SUCCEEDED As LuaEventsId
public:
literal LuaEventsId SCREENSHOT_SUCCEEDED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


SEND_MAIL_COD_CHANGED Field

LuaEventsId..::..SEND_MAIL_COD_CHANGED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId SEND_MAIL_COD_CHANGED
Public Const SEND_MAIL_COD_CHANGED As LuaEventsId
public:
literal LuaEventsId SEND_MAIL_COD_CHANGED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


SEND_MAIL_MONEY_CHANGED Field

LuaEventsId..::..SEND_MAIL_MONEY_CHANGED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId SEND_MAIL_MONEY_CHANGED
Public Const SEND_MAIL_MONEY_CHANGED As LuaEventsId
public:
literal LuaEventsId SEND_MAIL_MONEY_CHANGED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


SKILL_LINES_CHANGED Field

LuaEventsId..::..SKILL_LINES_CHANGED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId SKILL_LINES_CHANGED
Public Const SKILL_LINES_CHANGED As LuaEventsId
public:
literal LuaEventsId SKILL_LINES_CHANGED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


SOCKET_INFO_CLOSE Field

LuaEventsId..::..SOCKET_INFO_CLOSE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId SOCKET_INFO_CLOSE
Public Const SOCKET_INFO_CLOSE As LuaEventsId
public:
literal LuaEventsId SOCKET_INFO_CLOSE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


SOCKET_INFO_UPDATE Field

LuaEventsId..::..SOCKET_INFO_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId SOCKET_INFO_UPDATE
Public Const SOCKET_INFO_UPDATE As LuaEventsId
public:
literal LuaEventsId SOCKET_INFO_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


SOUND_DEVICE_UPDATE Field

LuaEventsId..::..SOUND_DEVICE_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId SOUND_DEVICE_UPDATE
Public Const SOUND_DEVICE_UPDATE As LuaEventsId
public:
literal LuaEventsId SOUND_DEVICE_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


SPELL_UPDATE_COOLDOWN Field

LuaEventsId..::..SPELL_UPDATE_COOLDOWN Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId SPELL_UPDATE_COOLDOWN
Public Const SPELL_UPDATE_COOLDOWN As LuaEventsId
public:
literal LuaEventsId SPELL_UPDATE_COOLDOWN

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


SPELL_UPDATE_USABLE Field

LuaEventsId..::..SPELL_UPDATE_USABLE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId SPELL_UPDATE_USABLE
Public Const SPELL_UPDATE_USABLE As LuaEventsId
public:
literal LuaEventsId SPELL_UPDATE_USABLE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


SPELLS_CHANGED Field

LuaEventsId..::..SPELLS_CHANGED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId SPELLS_CHANGED
Public Const SPELLS_CHANGED As LuaEventsId
public:
literal LuaEventsId SPELLS_CHANGED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


START_AUTOREPEAT_SPELL Field

LuaEventsId..::..START_AUTOREPEAT_SPELL Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId START_AUTOREPEAT_SPELL
Public Const START_AUTOREPEAT_SPELL As LuaEventsId
public:
literal LuaEventsId START_AUTOREPEAT_SPELL

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


START_LOOT_ROLL Field

LuaEventsId..::..START_LOOT_ROLL Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId START_LOOT_ROLL
Public Const START_LOOT_ROLL As LuaEventsId
public:
literal LuaEventsId START_LOOT_ROLL

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


START_MINIGAME Field

LuaEventsId..::..START_MINIGAME Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId START_MINIGAME
Public Const START_MINIGAME As LuaEventsId
public:
literal LuaEventsId START_MINIGAME

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


STOP_AUTOREPEAT_SPELL Field

LuaEventsId..::..STOP_AUTOREPEAT_SPELL Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId STOP_AUTOREPEAT_SPELL
Public Const STOP_AUTOREPEAT_SPELL As LuaEventsId
public:
literal LuaEventsId STOP_AUTOREPEAT_SPELL

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


SYNCHRONIZE_SETTINGS Field

LuaEventsId..::..SYNCHRONIZE_SETTINGS Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId SYNCHRONIZE_SETTINGS
Public Const SYNCHRONIZE_SETTINGS As LuaEventsId
public:
literal LuaEventsId SYNCHRONIZE_SETTINGS

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


SYSMSG Field

LuaEventsId..::..SYSMSG Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId SYSMSG
Public Const SYSMSG As LuaEventsId
public:
literal LuaEventsId SYSMSG

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


TABARD_CANSAVE_CHANGED Field

LuaEventsId..::..TABARD_CANSAVE_CHANGED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId TABARD_CANSAVE_CHANGED
Public Const TABARD_CANSAVE_CHANGED As LuaEventsId
public:
literal LuaEventsId TABARD_CANSAVE_CHANGED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


TABARD_SAVE_PENDING Field

LuaEventsId..::..TABARD_SAVE_PENDING Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId TABARD_SAVE_PENDING
Public Const TABARD_SAVE_PENDING As LuaEventsId
public:
literal LuaEventsId TABARD_SAVE_PENDING

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


TALENTS_INVOLUNTARILY_RESET Field

LuaEventsId..::..TALENTS_INVOLUNTARILY_RESET Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId TALENTS_INVOLUNTARILY_RESET
Public Const TALENTS_INVOLUNTARILY_RESET As LuaEventsId
public:
literal LuaEventsId TALENTS_INVOLUNTARILY_RESET

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


TAXIMAP_CLOSED Field

LuaEventsId..::..TAXIMAP_CLOSED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId TAXIMAP_CLOSED
Public Const TAXIMAP_CLOSED As LuaEventsId
public:
literal LuaEventsId TAXIMAP_CLOSED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


TAXIMAP_OPENED Field

LuaEventsId..::..TAXIMAP_OPENED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId TAXIMAP_OPENED
Public Const TAXIMAP_OPENED As LuaEventsId
public:
literal LuaEventsId TAXIMAP_OPENED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


TIME_PLAYED_MSG Field

LuaEventsId..::..TIME_PLAYED_MSG Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId TIME_PLAYED_MSG
Public Const TIME_PLAYED_MSG As LuaEventsId
public:
literal LuaEventsId TIME_PLAYED_MSG

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


TRACKED_ACHIEVEMENT_UPDATE Field

LuaEventsId..::..TRACKED_ACHIEVEMENT_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId TRACKED_ACHIEVEMENT_UPDATE
Public Const TRACKED_ACHIEVEMENT_UPDATE As LuaEventsId
public:
literal LuaEventsId TRACKED_ACHIEVEMENT_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


TRADE_ACCEPT_UPDATE Field

LuaEventsId..::..TRADE_ACCEPT_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId TRADE_ACCEPT_UPDATE
Public Const TRADE_ACCEPT_UPDATE As LuaEventsId
public:
literal LuaEventsId TRADE_ACCEPT_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


TRADE_CLOSED Field

LuaEventsId..::..TRADE_CLOSED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId TRADE_CLOSED
Public Const TRADE_CLOSED As LuaEventsId
public:
literal LuaEventsId TRADE_CLOSED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


TRADE_MONEY_CHANGED Field

LuaEventsId..::..TRADE_MONEY_CHANGED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId TRADE_MONEY_CHANGED
Public Const TRADE_MONEY_CHANGED As LuaEventsId
public:
literal LuaEventsId TRADE_MONEY_CHANGED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


TRADE_PLAYER_ITEM_CHANGED Field

LuaEventsId..::..TRADE_PLAYER_ITEM_CHANGED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId TRADE_PLAYER_ITEM_CHANGED
Public Const TRADE_PLAYER_ITEM_CHANGED As LuaEventsId
public:
literal LuaEventsId TRADE_PLAYER_ITEM_CHANGED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


TRADE_POTENTIAL_BIND_ENCHANT Field

LuaEventsId..::..TRADE_POTENTIAL_BIND_ENCHANT Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId TRADE_POTENTIAL_BIND_ENCHANT
Public Const TRADE_POTENTIAL_BIND_ENCHANT As LuaEventsId
public:
literal LuaEventsId TRADE_POTENTIAL_BIND_ENCHANT

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


TRADE_REPLACE_ENCHANT Field

LuaEventsId..::..TRADE_REPLACE_ENCHANT Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId TRADE_REPLACE_ENCHANT
Public Const TRADE_REPLACE_ENCHANT As LuaEventsId
public:
literal LuaEventsId TRADE_REPLACE_ENCHANT

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


TRADE_REQUEST Field

LuaEventsId..::..TRADE_REQUEST Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId TRADE_REQUEST
Public Const TRADE_REQUEST As LuaEventsId
public:
literal LuaEventsId TRADE_REQUEST

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


TRADE_REQUEST_CANCEL Field

LuaEventsId..::..TRADE_REQUEST_CANCEL Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId TRADE_REQUEST_CANCEL
Public Const TRADE_REQUEST_CANCEL As LuaEventsId
public:
literal LuaEventsId TRADE_REQUEST_CANCEL

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


TRADE_SHOW Field

LuaEventsId..::..TRADE_SHOW Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId TRADE_SHOW
Public Const TRADE_SHOW As LuaEventsId
public:
literal LuaEventsId TRADE_SHOW

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


TRADE_SKILL_CLOSE Field

LuaEventsId..::..TRADE_SKILL_CLOSE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId TRADE_SKILL_CLOSE
Public Const TRADE_SKILL_CLOSE As LuaEventsId
public:
literal LuaEventsId TRADE_SKILL_CLOSE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


TRADE_SKILL_FILTER_UPDATE Field

LuaEventsId..::..TRADE_SKILL_FILTER_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId TRADE_SKILL_FILTER_UPDATE
Public Const TRADE_SKILL_FILTER_UPDATE As LuaEventsId
public:
literal LuaEventsId TRADE_SKILL_FILTER_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


TRADE_SKILL_SHOW Field

LuaEventsId..::..TRADE_SKILL_SHOW Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId TRADE_SKILL_SHOW
Public Const TRADE_SKILL_SHOW As LuaEventsId
public:
literal LuaEventsId TRADE_SKILL_SHOW

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


TRADE_SKILL_UPDATE Field

LuaEventsId..::..TRADE_SKILL_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId TRADE_SKILL_UPDATE
Public Const TRADE_SKILL_UPDATE As LuaEventsId
public:
literal LuaEventsId TRADE_SKILL_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


TRADE_TARGET_ITEM_CHANGED Field

LuaEventsId..::..TRADE_TARGET_ITEM_CHANGED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId TRADE_TARGET_ITEM_CHANGED
Public Const TRADE_TARGET_ITEM_CHANGED As LuaEventsId
public:
literal LuaEventsId TRADE_TARGET_ITEM_CHANGED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


TRADE_UPDATE Field

LuaEventsId..::..TRADE_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId TRADE_UPDATE
Public Const TRADE_UPDATE As LuaEventsId
public:
literal LuaEventsId TRADE_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


TRAINER_CLOSED Field

LuaEventsId..::..TRAINER_CLOSED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId TRAINER_CLOSED
Public Const TRAINER_CLOSED As LuaEventsId
public:
literal LuaEventsId TRAINER_CLOSED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


TRAINER_DESCRIPTION_UPDATE Field

LuaEventsId..::..TRAINER_DESCRIPTION_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId TRAINER_DESCRIPTION_UPDATE
Public Const TRAINER_DESCRIPTION_UPDATE As LuaEventsId
public:
literal LuaEventsId TRAINER_DESCRIPTION_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


TRAINER_SHOW Field

LuaEventsId..::..TRAINER_SHOW Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId TRAINER_SHOW
Public Const TRAINER_SHOW As LuaEventsId
public:
literal LuaEventsId TRAINER_SHOW

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


TRAINER_UPDATE Field

LuaEventsId..::..TRAINER_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId TRAINER_UPDATE
Public Const TRAINER_UPDATE As LuaEventsId
public:
literal LuaEventsId TRAINER_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


TUTORIAL_TRIGGER Field

LuaEventsId..::..TUTORIAL_TRIGGER Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId TUTORIAL_TRIGGER
Public Const TUTORIAL_TRIGGER As LuaEventsId
public:
literal LuaEventsId TUTORIAL_TRIGGER

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UI_ERROR_MESSAGE Field

LuaEventsId..::..UI_ERROR_MESSAGE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UI_ERROR_MESSAGE
Public Const UI_ERROR_MESSAGE As LuaEventsId
public:
literal LuaEventsId UI_ERROR_MESSAGE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UI_INFO_MESSAGE Field

LuaEventsId..::..UI_INFO_MESSAGE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UI_INFO_MESSAGE
Public Const UI_INFO_MESSAGE As LuaEventsId
public:
literal LuaEventsId UI_INFO_MESSAGE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_ATTACK Field

LuaEventsId..::..UNIT_ATTACK Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_ATTACK
Public Const UNIT_ATTACK As LuaEventsId
public:
literal LuaEventsId UNIT_ATTACK

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_ATTACK_POWER Field

LuaEventsId..::..UNIT_ATTACK_POWER Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_ATTACK_POWER
Public Const UNIT_ATTACK_POWER As LuaEventsId
public:
literal LuaEventsId UNIT_ATTACK_POWER

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_ATTACK_SPEED Field

LuaEventsId..::..UNIT_ATTACK_SPEED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_ATTACK_SPEED
Public Const UNIT_ATTACK_SPEED As LuaEventsId
public:
literal LuaEventsId UNIT_ATTACK_SPEED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_AURA Field

LuaEventsId..::..UNIT_AURA Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_AURA
Public Const UNIT_AURA As LuaEventsId
public:
literal LuaEventsId UNIT_AURA

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_CLASSIFICATION_CHANGED Field

LuaEventsId..::..UNIT_CLASSIFICATION_CHANGED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_CLASSIFICATION_CHANGED
Public Const UNIT_CLASSIFICATION_CHANGED As LuaEventsId
public:
literal LuaEventsId UNIT_CLASSIFICATION_CHANGED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_COMBAT Field

LuaEventsId..::..UNIT_COMBAT Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_COMBAT
Public Const UNIT_COMBAT As LuaEventsId
public:
literal LuaEventsId UNIT_COMBAT

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_COMBO_POINTS Field

LuaEventsId..::..UNIT_COMBO_POINTS Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_COMBO_POINTS
Public Const UNIT_COMBO_POINTS As LuaEventsId
public:
literal LuaEventsId UNIT_COMBO_POINTS

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_DAMAGE Field

LuaEventsId..::..UNIT_DAMAGE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_DAMAGE
Public Const UNIT_DAMAGE As LuaEventsId
public:
literal LuaEventsId UNIT_DAMAGE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_DEFENSE Field

LuaEventsId..::..UNIT_DEFENSE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_DEFENSE
Public Const UNIT_DEFENSE As LuaEventsId
public:
literal LuaEventsId UNIT_DEFENSE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_DISPLAYPOWER Field

LuaEventsId..::..UNIT_DISPLAYPOWER Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_DISPLAYPOWER
Public Const UNIT_DISPLAYPOWER As LuaEventsId
public:
literal LuaEventsId UNIT_DISPLAYPOWER

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_DYNAMIC_FLAGS Field

LuaEventsId..::..UNIT_DYNAMIC_FLAGS Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_DYNAMIC_FLAGS
Public Const UNIT_DYNAMIC_FLAGS As LuaEventsId
public:
literal LuaEventsId UNIT_DYNAMIC_FLAGS

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_ENERGY Field

LuaEventsId..::..UNIT_ENERGY Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_ENERGY
Public Const UNIT_ENERGY As LuaEventsId
public:
literal LuaEventsId UNIT_ENERGY

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_ENTERED_VEHICLE Field

LuaEventsId..::..UNIT_ENTERED_VEHICLE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_ENTERED_VEHICLE
Public Const UNIT_ENTERED_VEHICLE As LuaEventsId
public:
literal LuaEventsId UNIT_ENTERED_VEHICLE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_ENTERING_VEHICLE Field

LuaEventsId..::..UNIT_ENTERING_VEHICLE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_ENTERING_VEHICLE
Public Const UNIT_ENTERING_VEHICLE As LuaEventsId
public:
literal LuaEventsId UNIT_ENTERING_VEHICLE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_EXITED_VEHICLE Field

LuaEventsId..::..UNIT_EXITED_VEHICLE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_EXITED_VEHICLE
Public Const UNIT_EXITED_VEHICLE As LuaEventsId
public:
literal LuaEventsId UNIT_EXITED_VEHICLE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_EXITING_VEHICLE Field

LuaEventsId..::..UNIT_EXITING_VEHICLE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_EXITING_VEHICLE
Public Const UNIT_EXITING_VEHICLE As LuaEventsId
public:
literal LuaEventsId UNIT_EXITING_VEHICLE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_FACTION Field

LuaEventsId..::..UNIT_FACTION Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_FACTION
Public Const UNIT_FACTION As LuaEventsId
public:
literal LuaEventsId UNIT_FACTION

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_FLAGS Field

LuaEventsId..::..UNIT_FLAGS Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_FLAGS
Public Const UNIT_FLAGS As LuaEventsId
public:
literal LuaEventsId UNIT_FLAGS

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_FOCUS Field

LuaEventsId..::..UNIT_FOCUS Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_FOCUS
Public Const UNIT_FOCUS As LuaEventsId
public:
literal LuaEventsId UNIT_FOCUS

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_HAPPINESS Field

LuaEventsId..::..UNIT_HAPPINESS Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_HAPPINESS
Public Const UNIT_HAPPINESS As LuaEventsId
public:
literal LuaEventsId UNIT_HAPPINESS

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_HEALTH Field

LuaEventsId..::..UNIT_HEALTH Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_HEALTH
Public Const UNIT_HEALTH As LuaEventsId
public:
literal LuaEventsId UNIT_HEALTH

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_INVENTORY_CHANGED Field

LuaEventsId..::..UNIT_INVENTORY_CHANGED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_INVENTORY_CHANGED
Public Const UNIT_INVENTORY_CHANGED As LuaEventsId
public:
literal LuaEventsId UNIT_INVENTORY_CHANGED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_LEVEL Field

LuaEventsId..::..UNIT_LEVEL Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_LEVEL
Public Const UNIT_LEVEL As LuaEventsId
public:
literal LuaEventsId UNIT_LEVEL

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_MANA Field

LuaEventsId..::..UNIT_MANA Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_MANA
Public Const UNIT_MANA As LuaEventsId
public:
literal LuaEventsId UNIT_MANA

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_MAXENERGY Field

LuaEventsId..::..UNIT_MAXENERGY Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_MAXENERGY
Public Const UNIT_MAXENERGY As LuaEventsId
public:
literal LuaEventsId UNIT_MAXENERGY

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_MAXFOCUS Field

LuaEventsId..::..UNIT_MAXFOCUS Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_MAXFOCUS
Public Const UNIT_MAXFOCUS As LuaEventsId
public:
literal LuaEventsId UNIT_MAXFOCUS

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_MAXHAPPINESS Field

LuaEventsId..::..UNIT_MAXHAPPINESS Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_MAXHAPPINESS
Public Const UNIT_MAXHAPPINESS As LuaEventsId
public:
literal LuaEventsId UNIT_MAXHAPPINESS

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_MAXHEALTH Field

LuaEventsId..::..UNIT_MAXHEALTH Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_MAXHEALTH
Public Const UNIT_MAXHEALTH As LuaEventsId
public:
literal LuaEventsId UNIT_MAXHEALTH

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_MAXMANA Field

LuaEventsId..::..UNIT_MAXMANA Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_MAXMANA
Public Const UNIT_MAXMANA As LuaEventsId
public:
literal LuaEventsId UNIT_MAXMANA

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_MAXRAGE Field

LuaEventsId..::..UNIT_MAXRAGE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_MAXRAGE
Public Const UNIT_MAXRAGE As LuaEventsId
public:
literal LuaEventsId UNIT_MAXRAGE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_MAXRUNIC_POWER Field

LuaEventsId..::..UNIT_MAXRUNIC_POWER Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_MAXRUNIC_POWER
Public Const UNIT_MAXRUNIC_POWER As LuaEventsId
public:
literal LuaEventsId UNIT_MAXRUNIC_POWER

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_MODEL_CHANGED Field

LuaEventsId..::..UNIT_MODEL_CHANGED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_MODEL_CHANGED
Public Const UNIT_MODEL_CHANGED As LuaEventsId
public:
literal LuaEventsId UNIT_MODEL_CHANGED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_NAME_UPDATE Field

LuaEventsId..::..UNIT_NAME_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_NAME_UPDATE
Public Const UNIT_NAME_UPDATE As LuaEventsId
public:
literal LuaEventsId UNIT_NAME_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_PET Field

LuaEventsId..::..UNIT_PET Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_PET
Public Const UNIT_PET As LuaEventsId
public:
literal LuaEventsId UNIT_PET

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_PET_EXPERIENCE Field

LuaEventsId..::..UNIT_PET_EXPERIENCE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_PET_EXPERIENCE
Public Const UNIT_PET_EXPERIENCE As LuaEventsId
public:
literal LuaEventsId UNIT_PET_EXPERIENCE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_PORTRAIT_UPDATE Field

LuaEventsId..::..UNIT_PORTRAIT_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_PORTRAIT_UPDATE
Public Const UNIT_PORTRAIT_UPDATE As LuaEventsId
public:
literal LuaEventsId UNIT_PORTRAIT_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_QUEST_LOG_CHANGED Field

LuaEventsId..::..UNIT_QUEST_LOG_CHANGED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_QUEST_LOG_CHANGED
Public Const UNIT_QUEST_LOG_CHANGED As LuaEventsId
public:
literal LuaEventsId UNIT_QUEST_LOG_CHANGED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_RAGE Field

LuaEventsId..::..UNIT_RAGE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_RAGE
Public Const UNIT_RAGE As LuaEventsId
public:
literal LuaEventsId UNIT_RAGE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_RANGED_ATTACK_POWER Field

LuaEventsId..::..UNIT_RANGED_ATTACK_POWER Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_RANGED_ATTACK_POWER
Public Const UNIT_RANGED_ATTACK_POWER As LuaEventsId
public:
literal LuaEventsId UNIT_RANGED_ATTACK_POWER

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_RANGEDDAMAGE Field

LuaEventsId..::..UNIT_RANGEDDAMAGE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_RANGEDDAMAGE
Public Const UNIT_RANGEDDAMAGE As LuaEventsId
public:
literal LuaEventsId UNIT_RANGEDDAMAGE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_RESISTANCES Field

LuaEventsId..::..UNIT_RESISTANCES Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_RESISTANCES
Public Const UNIT_RESISTANCES As LuaEventsId
public:
literal LuaEventsId UNIT_RESISTANCES

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_RUNIC_POWER Field

LuaEventsId..::..UNIT_RUNIC_POWER Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_RUNIC_POWER
Public Const UNIT_RUNIC_POWER As LuaEventsId
public:
literal LuaEventsId UNIT_RUNIC_POWER

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_SPELLCAST_CHANNEL_START Field

LuaEventsId..::..UNIT_SPELLCAST_CHANNEL_START Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_SPELLCAST_CHANNEL_START
Public Const UNIT_SPELLCAST_CHANNEL_START As LuaEventsId
public:
literal LuaEventsId UNIT_SPELLCAST_CHANNEL_START

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_SPELLCAST_CHANNEL_STOP Field

LuaEventsId..::..UNIT_SPELLCAST_CHANNEL_STOP Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_SPELLCAST_CHANNEL_STOP
Public Const UNIT_SPELLCAST_CHANNEL_STOP As LuaEventsId
public:
literal LuaEventsId UNIT_SPELLCAST_CHANNEL_STOP

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_SPELLCAST_CHANNEL_UPDATE Field

LuaEventsId..::..UNIT_SPELLCAST_CHANNEL_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_SPELLCAST_CHANNEL_UPDATE
Public Const UNIT_SPELLCAST_CHANNEL_UPDATE As LuaEventsId
public:
literal LuaEventsId UNIT_SPELLCAST_CHANNEL_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_SPELLCAST_DELAYED Field

LuaEventsId..::..UNIT_SPELLCAST_DELAYED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_SPELLCAST_DELAYED
Public Const UNIT_SPELLCAST_DELAYED As LuaEventsId
public:
literal LuaEventsId UNIT_SPELLCAST_DELAYED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_SPELLCAST_FAILED Field

LuaEventsId..::..UNIT_SPELLCAST_FAILED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_SPELLCAST_FAILED
Public Const UNIT_SPELLCAST_FAILED As LuaEventsId
public:
literal LuaEventsId UNIT_SPELLCAST_FAILED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_SPELLCAST_FAILED_QUIET Field

LuaEventsId..::..UNIT_SPELLCAST_FAILED_QUIET Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_SPELLCAST_FAILED_QUIET
Public Const UNIT_SPELLCAST_FAILED_QUIET As LuaEventsId
public:
literal LuaEventsId UNIT_SPELLCAST_FAILED_QUIET

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_SPELLCAST_INTERRUPTED Field

LuaEventsId..::..UNIT_SPELLCAST_INTERRUPTED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_SPELLCAST_INTERRUPTED
Public Const UNIT_SPELLCAST_INTERRUPTED As LuaEventsId
public:
literal LuaEventsId UNIT_SPELLCAST_INTERRUPTED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_SPELLCAST_INTERRUPTIBLE Field

LuaEventsId..::..UNIT_SPELLCAST_INTERRUPTIBLE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_SPELLCAST_INTERRUPTIBLE
Public Const UNIT_SPELLCAST_INTERRUPTIBLE As LuaEventsId
public:
literal LuaEventsId UNIT_SPELLCAST_INTERRUPTIBLE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_SPELLCAST_NOT_INTERRUPTIBLE Field

LuaEventsId..::..UNIT_SPELLCAST_NOT_INTERRUPTIBLE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_SPELLCAST_NOT_INTERRUPTIBLE
Public Const UNIT_SPELLCAST_NOT_INTERRUPTIBLE As LuaEventsId
public:
literal LuaEventsId UNIT_SPELLCAST_NOT_INTERRUPTIBLE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_SPELLCAST_SENT Field

LuaEventsId..::..UNIT_SPELLCAST_SENT Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_SPELLCAST_SENT
Public Const UNIT_SPELLCAST_SENT As LuaEventsId
public:
literal LuaEventsId UNIT_SPELLCAST_SENT

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_SPELLCAST_START Field

LuaEventsId..::..UNIT_SPELLCAST_START Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_SPELLCAST_START
Public Const UNIT_SPELLCAST_START As LuaEventsId
public:
literal LuaEventsId UNIT_SPELLCAST_START

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_SPELLCAST_STOP Field

LuaEventsId..::..UNIT_SPELLCAST_STOP Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_SPELLCAST_STOP
Public Const UNIT_SPELLCAST_STOP As LuaEventsId
public:
literal LuaEventsId UNIT_SPELLCAST_STOP

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_SPELLCAST_SUCCEEDED Field

LuaEventsId..::..UNIT_SPELLCAST_SUCCEEDED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_SPELLCAST_SUCCEEDED
Public Const UNIT_SPELLCAST_SUCCEEDED As LuaEventsId
public:
literal LuaEventsId UNIT_SPELLCAST_SUCCEEDED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_STATS Field

LuaEventsId..::..UNIT_STATS Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_STATS
Public Const UNIT_STATS As LuaEventsId
public:
literal LuaEventsId UNIT_STATS

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_TARGET Field

LuaEventsId..::..UNIT_TARGET Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_TARGET
Public Const UNIT_TARGET As LuaEventsId
public:
literal LuaEventsId UNIT_TARGET

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_THREAT_LIST_UPDATE Field

LuaEventsId..::..UNIT_THREAT_LIST_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_THREAT_LIST_UPDATE
Public Const UNIT_THREAT_LIST_UPDATE As LuaEventsId
public:
literal LuaEventsId UNIT_THREAT_LIST_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UNIT_THREAT_SITUATION_UPDATE Field

LuaEventsId..::..UNIT_THREAT_SITUATION_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UNIT_THREAT_SITUATION_UPDATE
Public Const UNIT_THREAT_SITUATION_UPDATE As LuaEventsId
public:
literal LuaEventsId UNIT_THREAT_SITUATION_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UPDATE_BATTLEFIELD_SCORE Field

LuaEventsId..::..UPDATE_BATTLEFIELD_SCORE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UPDATE_BATTLEFIELD_SCORE
Public Const UPDATE_BATTLEFIELD_SCORE As LuaEventsId
public:
literal LuaEventsId UPDATE_BATTLEFIELD_SCORE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UPDATE_BATTLEFIELD_STATUS Field

LuaEventsId..::..UPDATE_BATTLEFIELD_STATUS Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UPDATE_BATTLEFIELD_STATUS
Public Const UPDATE_BATTLEFIELD_STATUS As LuaEventsId
public:
literal LuaEventsId UPDATE_BATTLEFIELD_STATUS

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UPDATE_BINDINGS Field

LuaEventsId..::..UPDATE_BINDINGS Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UPDATE_BINDINGS
Public Const UPDATE_BINDINGS As LuaEventsId
public:
literal LuaEventsId UPDATE_BINDINGS

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UPDATE_BONUS_ACTIONBAR Field

LuaEventsId..::..UPDATE_BONUS_ACTIONBAR Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UPDATE_BONUS_ACTIONBAR
Public Const UPDATE_BONUS_ACTIONBAR As LuaEventsId
public:
literal LuaEventsId UPDATE_BONUS_ACTIONBAR

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UPDATE_CHAT_COLOR Field

LuaEventsId..::..UPDATE_CHAT_COLOR Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UPDATE_CHAT_COLOR
Public Const UPDATE_CHAT_COLOR As LuaEventsId
public:
literal LuaEventsId UPDATE_CHAT_COLOR

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UPDATE_CHAT_COLOR_NAME_BY_CLASS Field

LuaEventsId..::..UPDATE_CHAT_COLOR_NAME_BY_CLASS Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UPDATE_CHAT_COLOR_NAME_BY_CLASS
Public Const UPDATE_CHAT_COLOR_NAME_BY_CLASS As LuaEventsId
public:
literal LuaEventsId UPDATE_CHAT_COLOR_NAME_BY_CLASS

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UPDATE_CHAT_WINDOWS Field

LuaEventsId..::..UPDATE_CHAT_WINDOWS Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UPDATE_CHAT_WINDOWS
Public Const UPDATE_CHAT_WINDOWS As LuaEventsId
public:
literal LuaEventsId UPDATE_CHAT_WINDOWS

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UPDATE_EXHAUSTION Field

LuaEventsId..::..UPDATE_EXHAUSTION Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UPDATE_EXHAUSTION
Public Const UPDATE_EXHAUSTION As LuaEventsId
public:
literal LuaEventsId UPDATE_EXHAUSTION

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UPDATE_FACTION Field

LuaEventsId..::..UPDATE_FACTION Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UPDATE_FACTION
Public Const UPDATE_FACTION As LuaEventsId
public:
literal LuaEventsId UPDATE_FACTION

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UPDATE_FLOATING_CHAT_WINDOWS Field

LuaEventsId..::..UPDATE_FLOATING_CHAT_WINDOWS Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UPDATE_FLOATING_CHAT_WINDOWS
Public Const UPDATE_FLOATING_CHAT_WINDOWS As LuaEventsId
public:
literal LuaEventsId UPDATE_FLOATING_CHAT_WINDOWS

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UPDATE_GM_STATUS Field

LuaEventsId..::..UPDATE_GM_STATUS Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UPDATE_GM_STATUS
Public Const UPDATE_GM_STATUS As LuaEventsId
public:
literal LuaEventsId UPDATE_GM_STATUS

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UPDATE_INSTANCE_INFO Field

LuaEventsId..::..UPDATE_INSTANCE_INFO Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UPDATE_INSTANCE_INFO
Public Const UPDATE_INSTANCE_INFO As LuaEventsId
public:
literal LuaEventsId UPDATE_INSTANCE_INFO

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UPDATE_INVENTORY_ALERTS Field

LuaEventsId..::..UPDATE_INVENTORY_ALERTS Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UPDATE_INVENTORY_ALERTS
Public Const UPDATE_INVENTORY_ALERTS As LuaEventsId
public:
literal LuaEventsId UPDATE_INVENTORY_ALERTS

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UPDATE_INVENTORY_DURABILITY Field

LuaEventsId..::..UPDATE_INVENTORY_DURABILITY Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UPDATE_INVENTORY_DURABILITY
Public Const UPDATE_INVENTORY_DURABILITY As LuaEventsId
public:
literal LuaEventsId UPDATE_INVENTORY_DURABILITY

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UPDATE_LFG_LIST Field

LuaEventsId..::..UPDATE_LFG_LIST Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UPDATE_LFG_LIST
Public Const UPDATE_LFG_LIST As LuaEventsId
public:
literal LuaEventsId UPDATE_LFG_LIST

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UPDATE_LFG_LIST_INCREMENTAL Field

LuaEventsId..::..UPDATE_LFG_LIST_INCREMENTAL Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UPDATE_LFG_LIST_INCREMENTAL
Public Const UPDATE_LFG_LIST_INCREMENTAL As LuaEventsId
public:
literal LuaEventsId UPDATE_LFG_LIST_INCREMENTAL

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UPDATE_LFG_TYPES Field

LuaEventsId..::..UPDATE_LFG_TYPES Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UPDATE_LFG_TYPES
Public Const UPDATE_LFG_TYPES As LuaEventsId
public:
literal LuaEventsId UPDATE_LFG_TYPES

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UPDATE_MACROS Field

LuaEventsId..::..UPDATE_MACROS Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UPDATE_MACROS
Public Const UPDATE_MACROS As LuaEventsId
public:
literal LuaEventsId UPDATE_MACROS

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UPDATE_MASTER_LOOT_LIST Field

LuaEventsId..::..UPDATE_MASTER_LOOT_LIST Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UPDATE_MASTER_LOOT_LIST
Public Const UPDATE_MASTER_LOOT_LIST As LuaEventsId
public:
literal LuaEventsId UPDATE_MASTER_LOOT_LIST

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UPDATE_MOUSEOVER_UNIT Field

LuaEventsId..::..UPDATE_MOUSEOVER_UNIT Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UPDATE_MOUSEOVER_UNIT
Public Const UPDATE_MOUSEOVER_UNIT As LuaEventsId
public:
literal LuaEventsId UPDATE_MOUSEOVER_UNIT

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UPDATE_MULTI_CAST_ACTIONBAR Field

LuaEventsId..::..UPDATE_MULTI_CAST_ACTIONBAR Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UPDATE_MULTI_CAST_ACTIONBAR
Public Const UPDATE_MULTI_CAST_ACTIONBAR As LuaEventsId
public:
literal LuaEventsId UPDATE_MULTI_CAST_ACTIONBAR

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UPDATE_PENDING_MAIL Field

LuaEventsId..::..UPDATE_PENDING_MAIL Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UPDATE_PENDING_MAIL
Public Const UPDATE_PENDING_MAIL As LuaEventsId
public:
literal LuaEventsId UPDATE_PENDING_MAIL

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UPDATE_SHAPESHIFT_COOLDOWN Field

LuaEventsId..::..UPDATE_SHAPESHIFT_COOLDOWN Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UPDATE_SHAPESHIFT_COOLDOWN
Public Const UPDATE_SHAPESHIFT_COOLDOWN As LuaEventsId
public:
literal LuaEventsId UPDATE_SHAPESHIFT_COOLDOWN

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UPDATE_SHAPESHIFT_FORM Field

LuaEventsId..::..UPDATE_SHAPESHIFT_FORM Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UPDATE_SHAPESHIFT_FORM
Public Const UPDATE_SHAPESHIFT_FORM As LuaEventsId
public:
literal LuaEventsId UPDATE_SHAPESHIFT_FORM

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UPDATE_SHAPESHIFT_FORMS Field

LuaEventsId..::..UPDATE_SHAPESHIFT_FORMS Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UPDATE_SHAPESHIFT_FORMS
Public Const UPDATE_SHAPESHIFT_FORMS As LuaEventsId
public:
literal LuaEventsId UPDATE_SHAPESHIFT_FORMS

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UPDATE_SHAPESHIFT_USABLE Field

LuaEventsId..::..UPDATE_SHAPESHIFT_USABLE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UPDATE_SHAPESHIFT_USABLE
Public Const UPDATE_SHAPESHIFT_USABLE As LuaEventsId
public:
literal LuaEventsId UPDATE_SHAPESHIFT_USABLE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UPDATE_STEALTH Field

LuaEventsId..::..UPDATE_STEALTH Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UPDATE_STEALTH
Public Const UPDATE_STEALTH As LuaEventsId
public:
literal LuaEventsId UPDATE_STEALTH

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UPDATE_TICKET Field

LuaEventsId..::..UPDATE_TICKET Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UPDATE_TICKET
Public Const UPDATE_TICKET As LuaEventsId
public:
literal LuaEventsId UPDATE_TICKET

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UPDATE_TRADESKILL_RECAST Field

LuaEventsId..::..UPDATE_TRADESKILL_RECAST Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UPDATE_TRADESKILL_RECAST
Public Const UPDATE_TRADESKILL_RECAST As LuaEventsId
public:
literal LuaEventsId UPDATE_TRADESKILL_RECAST

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


UPDATE_WORLD_STATES Field

LuaEventsId..::..UPDATE_WORLD_STATES Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId UPDATE_WORLD_STATES
Public Const UPDATE_WORLD_STATES As LuaEventsId
public:
literal LuaEventsId UPDATE_WORLD_STATES

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


USE_BIND_CONFIRM Field

LuaEventsId..::..USE_BIND_CONFIRM Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId USE_BIND_CONFIRM
Public Const USE_BIND_CONFIRM As LuaEventsId
public:
literal LuaEventsId USE_BIND_CONFIRM

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


USE_GLYPH Field

LuaEventsId..::..USE_GLYPH Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId USE_GLYPH
Public Const USE_GLYPH As LuaEventsId
public:
literal LuaEventsId USE_GLYPH

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


VARIABLES_LOADED Field

LuaEventsId..::..VARIABLES_LOADED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId VARIABLES_LOADED
Public Const VARIABLES_LOADED As LuaEventsId
public:
literal LuaEventsId VARIABLES_LOADED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


VEHICLE_ANGLE_SHOW Field

LuaEventsId..::..VEHICLE_ANGLE_SHOW Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId VEHICLE_ANGLE_SHOW
Public Const VEHICLE_ANGLE_SHOW As LuaEventsId
public:
literal LuaEventsId VEHICLE_ANGLE_SHOW

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


VEHICLE_ANGLE_UPDATE Field

LuaEventsId..::..VEHICLE_ANGLE_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId VEHICLE_ANGLE_UPDATE
Public Const VEHICLE_ANGLE_UPDATE As LuaEventsId
public:
literal LuaEventsId VEHICLE_ANGLE_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


VEHICLE_PASSENGERS_CHANGED Field

LuaEventsId..::..VEHICLE_PASSENGERS_CHANGED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId VEHICLE_PASSENGERS_CHANGED
Public Const VEHICLE_PASSENGERS_CHANGED As LuaEventsId
public:
literal LuaEventsId VEHICLE_PASSENGERS_CHANGED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


VEHICLE_POWER_SHOW Field

LuaEventsId..::..VEHICLE_POWER_SHOW Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId VEHICLE_POWER_SHOW
Public Const VEHICLE_POWER_SHOW As LuaEventsId
public:
literal LuaEventsId VEHICLE_POWER_SHOW

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


VEHICLE_UPDATE Field

LuaEventsId..::..VEHICLE_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId VEHICLE_UPDATE
Public Const VEHICLE_UPDATE As LuaEventsId
public:
literal LuaEventsId VEHICLE_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


VOICE_CHANNEL_STATUS_UPDATE Field

LuaEventsId..::..VOICE_CHANNEL_STATUS_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId VOICE_CHANNEL_STATUS_UPDATE
Public Const VOICE_CHANNEL_STATUS_UPDATE As LuaEventsId
public:
literal LuaEventsId VOICE_CHANNEL_STATUS_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


VOICE_CHAT_ENABLED_UPDATE Field

LuaEventsId..::..VOICE_CHAT_ENABLED_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId VOICE_CHAT_ENABLED_UPDATE
Public Const VOICE_CHAT_ENABLED_UPDATE As LuaEventsId
public:
literal LuaEventsId VOICE_CHAT_ENABLED_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


VOICE_LEFT_SESSION Field

LuaEventsId..::..VOICE_LEFT_SESSION Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId VOICE_LEFT_SESSION
Public Const VOICE_LEFT_SESSION As LuaEventsId
public:
literal LuaEventsId VOICE_LEFT_SESSION

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


VOICE_PLATE_START Field

LuaEventsId..::..VOICE_PLATE_START Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId VOICE_PLATE_START
Public Const VOICE_PLATE_START As LuaEventsId
public:
literal LuaEventsId VOICE_PLATE_START

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


VOICE_PLATE_STOP Field

LuaEventsId..::..VOICE_PLATE_STOP Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId VOICE_PLATE_STOP
Public Const VOICE_PLATE_STOP As LuaEventsId
public:
literal LuaEventsId VOICE_PLATE_STOP

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


VOICE_PUSH_TO_TALK_START Field

LuaEventsId..::..VOICE_PUSH_TO_TALK_START Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId VOICE_PUSH_TO_TALK_START
Public Const VOICE_PUSH_TO_TALK_START As LuaEventsId
public:
literal LuaEventsId VOICE_PUSH_TO_TALK_START

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


VOICE_PUSH_TO_TALK_STOP Field

LuaEventsId..::..VOICE_PUSH_TO_TALK_STOP Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId VOICE_PUSH_TO_TALK_STOP
Public Const VOICE_PUSH_TO_TALK_STOP As LuaEventsId
public:
literal LuaEventsId VOICE_PUSH_TO_TALK_STOP

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


VOICE_SELF_MUTE Field

LuaEventsId..::..VOICE_SELF_MUTE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId VOICE_SELF_MUTE
Public Const VOICE_SELF_MUTE As LuaEventsId
public:
literal LuaEventsId VOICE_SELF_MUTE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


VOICE_SESSIONS_UPDATE Field

LuaEventsId..::..VOICE_SESSIONS_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId VOICE_SESSIONS_UPDATE
Public Const VOICE_SESSIONS_UPDATE As LuaEventsId
public:
literal LuaEventsId VOICE_SESSIONS_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


VOICE_START Field

LuaEventsId..::..VOICE_START Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId VOICE_START
Public Const VOICE_START As LuaEventsId
public:
literal LuaEventsId VOICE_START

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


VOICE_STATUS_UPDATE Field

LuaEventsId..::..VOICE_STATUS_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId VOICE_STATUS_UPDATE
Public Const VOICE_STATUS_UPDATE As LuaEventsId
public:
literal LuaEventsId VOICE_STATUS_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


VOICE_STOP Field

LuaEventsId..::..VOICE_STOP Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId VOICE_STOP
Public Const VOICE_STOP As LuaEventsId
public:
literal LuaEventsId VOICE_STOP

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


VOTE_KICK_REASON_NEEDED Field

LuaEventsId..::..VOTE_KICK_REASON_NEEDED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId VOTE_KICK_REASON_NEEDED
Public Const VOTE_KICK_REASON_NEEDED As LuaEventsId
public:
literal LuaEventsId VOTE_KICK_REASON_NEEDED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


WEAR_EQUIPMENT_SET Field

LuaEventsId..::..WEAR_EQUIPMENT_SET Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId WEAR_EQUIPMENT_SET
Public Const WEAR_EQUIPMENT_SET As LuaEventsId
public:
literal LuaEventsId WEAR_EQUIPMENT_SET

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


WHO_LIST_UPDATE Field

LuaEventsId..::..WHO_LIST_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId WHO_LIST_UPDATE
Public Const WHO_LIST_UPDATE As LuaEventsId
public:
literal LuaEventsId WHO_LIST_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


WORLD_MAP_NAME_UPDATE Field

LuaEventsId..::..WORLD_MAP_NAME_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId WORLD_MAP_NAME_UPDATE
Public Const WORLD_MAP_NAME_UPDATE As LuaEventsId
public:
literal LuaEventsId WORLD_MAP_NAME_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


WORLD_MAP_UPDATE Field

LuaEventsId..::..WORLD_MAP_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId WORLD_MAP_UPDATE
Public Const WORLD_MAP_UPDATE As LuaEventsId
public:
literal LuaEventsId WORLD_MAP_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


WORLD_STATE_UI_TIMER_UPDATE Field

LuaEventsId..::..WORLD_STATE_UI_TIMER_UPDATE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId WORLD_STATE_UI_TIMER_UPDATE
Public Const WORLD_STATE_UI_TIMER_UPDATE As LuaEventsId
public:
literal LuaEventsId WORLD_STATE_UI_TIMER_UPDATE

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


WOW_MOUSE_NOT_FOUND Field

LuaEventsId..::..WOW_MOUSE_NOT_FOUND Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId WOW_MOUSE_NOT_FOUND
Public Const WOW_MOUSE_NOT_FOUND As LuaEventsId
public:
literal LuaEventsId WOW_MOUSE_NOT_FOUND

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


ZONE_CHANGED Field

LuaEventsId..::..ZONE_CHANGED Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId ZONE_CHANGED
Public Const ZONE_CHANGED As LuaEventsId
public:
literal LuaEventsId ZONE_CHANGED

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


ZONE_CHANGED_INDOORS Field

LuaEventsId..::..ZONE_CHANGED_INDOORS Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId ZONE_CHANGED_INDOORS
Public Const ZONE_CHANGED_INDOORS As LuaEventsId
public:
literal LuaEventsId ZONE_CHANGED_INDOORS

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


ZONE_CHANGED_NEW_AREA Field

LuaEventsId..::..ZONE_CHANGED_NEW_AREA Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const LuaEventsId ZONE_CHANGED_NEW_AREA
Public Const ZONE_CHANGED_NEW_AREA As LuaEventsId
public:
literal LuaEventsId ZONE_CHANGED_NEW_AREA

See Also

LuaEventsId Enumeration
wManager.Wow.Enums Namespace


Aquatic Field

MountFlags..::..Aquatic Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const MountFlags Aquatic
Public Const Aquatic As MountFlags
public:
literal MountFlags Aquatic

See Also

MountFlags Enumeration
wManager.Wow.Enums Namespace


Aquatic2 Field

MountFlags..::..Aquatic2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const MountFlags Aquatic2
Public Const Aquatic2 As MountFlags
public:
literal MountFlags Aquatic2

See Also

MountFlags Enumeration
wManager.Wow.Enums Namespace


Aquatic3 Field

MountFlags..::..Aquatic3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const MountFlags Aquatic3
Public Const Aquatic3 As MountFlags
public:
literal MountFlags Aquatic3

See Also

MountFlags Enumeration
wManager.Wow.Enums Namespace


DeadMount Field

MountFlags..::..DeadMount Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const MountFlags DeadMount
Public Const DeadMount As MountFlags
public:
literal MountFlags DeadMount

See Also

MountFlags Enumeration
wManager.Wow.Enums Namespace


Flying Field

MountFlags..::..Flying Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const MountFlags Flying
Public Const Flying As MountFlags
public:
literal MountFlags Flying

See Also

MountFlags Enumeration
wManager.Wow.Enums Namespace


Flying2 Field

MountFlags..::..Flying2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const MountFlags Flying2
Public Const Flying2 As MountFlags
public:
literal MountFlags Flying2

See Also

MountFlags Enumeration
wManager.Wow.Enums Namespace


Ground Field

MountFlags..::..Ground Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const MountFlags Ground
Public Const Ground As MountFlags
public:
literal MountFlags Ground

See Also

MountFlags Enumeration
wManager.Wow.Enums Namespace


GroundForLevel1 Field

MountFlags..::..GroundForLevel1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const MountFlags GroundForLevel1
Public Const GroundForLevel1 As MountFlags
public:
literal MountFlags GroundForLevel1

See Also

MountFlags Enumeration
wManager.Wow.Enums Namespace


GroundWalkWater Field

MountFlags..::..GroundWalkWater Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const MountFlags GroundWalkWater
Public Const GroundWalkWater As MountFlags
public:
literal MountFlags GroundWalkWater

See Also

MountFlags Enumeration
wManager.Wow.Enums Namespace


None Field

MountFlags..::..None Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const MountFlags None
Public Const None As MountFlags
public:
literal MountFlags None

See Also

MountFlags Enumeration
wManager.Wow.Enums Namespace


TempleOfAhnQirajMount Field

MountFlags..::..TempleOfAhnQirajMount Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const MountFlags TempleOfAhnQirajMount
Public Const TempleOfAhnQirajMount As MountFlags
public:
literal MountFlags TempleOfAhnQirajMount

See Also

MountFlags Enumeration
wManager.Wow.Enums Namespace


BlueExclamation Field

NpcMarker..::..BlueExclamation Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const NpcMarker BlueExclamation
Public Const BlueExclamation As NpcMarker
public:
literal NpcMarker BlueExclamation

See Also

NpcMarker Enumeration
wManager.Wow.Enums Namespace


BlueQuestion Field

NpcMarker..::..BlueQuestion Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const NpcMarker BlueQuestion
Public Const BlueQuestion As NpcMarker
public:
literal NpcMarker BlueQuestion

See Also

NpcMarker Enumeration
wManager.Wow.Enums Namespace


GreenExclamation Field

NpcMarker..::..GreenExclamation Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const NpcMarker GreenExclamation
Public Const GreenExclamation As NpcMarker
public:
literal NpcMarker GreenExclamation

See Also

NpcMarker Enumeration
wManager.Wow.Enums Namespace


None Field

NpcMarker..::..None Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const NpcMarker None
Public Const None As NpcMarker
public:
literal NpcMarker None

See Also

NpcMarker Enumeration
wManager.Wow.Enums Namespace


SilverExclamation Field

NpcMarker..::..SilverExclamation Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const NpcMarker SilverExclamation
Public Const SilverExclamation As NpcMarker
public:
literal NpcMarker SilverExclamation

See Also

NpcMarker Enumeration
wManager.Wow.Enums Namespace


SilverQuestion Field

NpcMarker..::..SilverQuestion Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const NpcMarker SilverQuestion
Public Const SilverQuestion As NpcMarker
public:
literal NpcMarker SilverQuestion

See Also

NpcMarker Enumeration
wManager.Wow.Enums Namespace


YellowExclamation Field

NpcMarker..::..YellowExclamation Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const NpcMarker YellowExclamation
Public Const YellowExclamation As NpcMarker
public:
literal NpcMarker YellowExclamation

See Also

NpcMarker Enumeration
wManager.Wow.Enums Namespace


YellowQuestion Field

NpcMarker..::..YellowQuestion Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const NpcMarker YellowQuestion
Public Const YellowQuestion As NpcMarker
public:
literal NpcMarker YellowQuestion

See Also

NpcMarker Enumeration
wManager.Wow.Enums Namespace


BloodElf Field

PlayerFactions..::..BloodElf Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const PlayerFactions BloodElf
Public Const BloodElf As PlayerFactions
public:
literal PlayerFactions BloodElf

See Also

PlayerFactions Enumeration
wManager.Wow.Enums Namespace


Draenei Field

PlayerFactions..::..Draenei Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const PlayerFactions Draenei
Public Const Draenei As PlayerFactions
public:
literal PlayerFactions Draenei

See Also

PlayerFactions Enumeration
wManager.Wow.Enums Namespace


Dwarf Field

PlayerFactions..::..Dwarf Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const PlayerFactions Dwarf
Public Const Dwarf As PlayerFactions
public:
literal PlayerFactions Dwarf

See Also

PlayerFactions Enumeration
wManager.Wow.Enums Namespace


Gnome Field

PlayerFactions..::..Gnome Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const PlayerFactions Gnome
Public Const Gnome As PlayerFactions
public:
literal PlayerFactions Gnome

See Also

PlayerFactions Enumeration
wManager.Wow.Enums Namespace


Goblin Field

PlayerFactions..::..Goblin Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const PlayerFactions Goblin
Public Const Goblin As PlayerFactions
public:
literal PlayerFactions Goblin

See Also

PlayerFactions Enumeration
wManager.Wow.Enums Namespace


Human Field

PlayerFactions..::..Human Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const PlayerFactions Human
Public Const Human As PlayerFactions
public:
literal PlayerFactions Human

See Also

PlayerFactions Enumeration
wManager.Wow.Enums Namespace


NightElf Field

PlayerFactions..::..NightElf Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const PlayerFactions NightElf
Public Const NightElf As PlayerFactions
public:
literal PlayerFactions NightElf

See Also

PlayerFactions Enumeration
wManager.Wow.Enums Namespace


None Field

PlayerFactions..::..None Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const PlayerFactions None
Public Const None As PlayerFactions
public:
literal PlayerFactions None

See Also

PlayerFactions Enumeration
wManager.Wow.Enums Namespace


Orc Field

PlayerFactions..::..Orc Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const PlayerFactions Orc
Public Const Orc As PlayerFactions
public:
literal PlayerFactions Orc

See Also

PlayerFactions Enumeration
wManager.Wow.Enums Namespace


Pandaren Field

PlayerFactions..::..Pandaren Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const PlayerFactions Pandaren
Public Const Pandaren As PlayerFactions
public:
literal PlayerFactions Pandaren

See Also

PlayerFactions Enumeration
wManager.Wow.Enums Namespace


PandarenAlliance Field

PlayerFactions..::..PandarenAlliance Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const PlayerFactions PandarenAlliance
Public Const PandarenAlliance As PlayerFactions
public:
literal PlayerFactions PandarenAlliance

See Also

PlayerFactions Enumeration
wManager.Wow.Enums Namespace


PandarenHorde Field

PlayerFactions..::..PandarenHorde Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const PlayerFactions PandarenHorde
Public Const PandarenHorde As PlayerFactions
public:
literal PlayerFactions PandarenHorde

See Also

PlayerFactions Enumeration
wManager.Wow.Enums Namespace


Tauren Field

PlayerFactions..::..Tauren Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const PlayerFactions Tauren
Public Const Tauren As PlayerFactions
public:
literal PlayerFactions Tauren

See Also

PlayerFactions Enumeration
wManager.Wow.Enums Namespace


Troll Field

PlayerFactions..::..Troll Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const PlayerFactions Troll
Public Const Troll As PlayerFactions
public:
literal PlayerFactions Troll

See Also

PlayerFactions Enumeration
wManager.Wow.Enums Namespace


Undead Field

PlayerFactions..::..Undead Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const PlayerFactions Undead
Public Const Undead As PlayerFactions
public:
literal PlayerFactions Undead

See Also

PlayerFactions Enumeration
wManager.Wow.Enums Namespace


Worgen Field

PlayerFactions..::..Worgen Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const PlayerFactions Worgen
Public Const Worgen As PlayerFactions
public:
literal PlayerFactions Worgen

See Also

PlayerFactions Enumeration
wManager.Wow.Enums Namespace


Alternate Field

PowerType..::..Alternate Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const PowerType Alternate
Public Const Alternate As PowerType
public:
literal PowerType Alternate

See Also

PowerType Enumeration
wManager.Wow.Enums Namespace


ArcaneCharges Field

PowerType..::..ArcaneCharges Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const PowerType ArcaneCharges
Public Const ArcaneCharges As PowerType
public:
literal PowerType ArcaneCharges

See Also

PowerType Enumeration
wManager.Wow.Enums Namespace


BurningEmbers Field

PowerType..::..BurningEmbers Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const PowerType BurningEmbers
Public Const BurningEmbers As PowerType
public:
literal PowerType BurningEmbers

See Also

PowerType Enumeration
wManager.Wow.Enums Namespace


DarkForce Field

PowerType..::..DarkForce Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const PowerType DarkForce
Public Const DarkForce As PowerType
public:
literal PowerType DarkForce

See Also

PowerType Enumeration
wManager.Wow.Enums Namespace


DemonicFury Field

PowerType..::..DemonicFury Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const PowerType DemonicFury
Public Const DemonicFury As PowerType
public:
literal PowerType DemonicFury

See Also

PowerType Enumeration
wManager.Wow.Enums Namespace


Eclipse Field

PowerType..::..Eclipse Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const PowerType Eclipse
Public Const Eclipse As PowerType
public:
literal PowerType Eclipse

See Also

PowerType Enumeration
wManager.Wow.Enums Namespace


Energy Field

PowerType..::..Energy Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const PowerType Energy
Public Const Energy As PowerType
public:
literal PowerType Energy

See Also

PowerType Enumeration
wManager.Wow.Enums Namespace


Focus Field

PowerType..::..Focus Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const PowerType Focus
Public Const Focus As PowerType
public:
literal PowerType Focus

See Also

PowerType Enumeration
wManager.Wow.Enums Namespace


Happiness Field

PowerType..::..Happiness Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const PowerType Happiness
Public Const Happiness As PowerType
public:
literal PowerType Happiness

See Also

PowerType Enumeration
wManager.Wow.Enums Namespace


HolyPower Field

PowerType..::..HolyPower Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const PowerType HolyPower
Public Const HolyPower As PowerType
public:
literal PowerType HolyPower

See Also

PowerType Enumeration
wManager.Wow.Enums Namespace


LightForce Field

PowerType..::..LightForce Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const PowerType LightForce
Public Const LightForce As PowerType
public:
literal PowerType LightForce

See Also

PowerType Enumeration
wManager.Wow.Enums Namespace


Mana Field

PowerType..::..Mana Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const PowerType Mana
Public Const Mana As PowerType
public:
literal PowerType Mana

See Also

PowerType Enumeration
wManager.Wow.Enums Namespace


Rage Field

PowerType..::..Rage Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const PowerType Rage
Public Const Rage As PowerType
public:
literal PowerType Rage

See Also

PowerType Enumeration
wManager.Wow.Enums Namespace


Runes Field

PowerType..::..Runes Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const PowerType Runes
Public Const Runes As PowerType
public:
literal PowerType Runes

See Also

PowerType Enumeration
wManager.Wow.Enums Namespace


RunicPower Field

PowerType..::..RunicPower Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const PowerType RunicPower
Public Const RunicPower As PowerType
public:
literal PowerType RunicPower

See Also

PowerType Enumeration
wManager.Wow.Enums Namespace


ShadowOrbs Field

PowerType..::..ShadowOrbs Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const PowerType ShadowOrbs
Public Const ShadowOrbs As PowerType
public:
literal PowerType ShadowOrbs

See Also

PowerType Enumeration
wManager.Wow.Enums Namespace


SoulShards Field

PowerType..::..SoulShards Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const PowerType SoulShards
Public Const SoulShards As PowerType
public:
literal PowerType SoulShards

See Also

PowerType Enumeration
wManager.Wow.Enums Namespace


Exalted Field

Reaction..::..Exalted Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Reaction Exalted
Public Const Exalted As Reaction
public:
literal Reaction Exalted

See Also

Reaction Enumeration
wManager.Wow.Enums Namespace


Friendly Field

Reaction..::..Friendly Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Reaction Friendly
Public Const Friendly As Reaction
public:
literal Reaction Friendly

See Also

Reaction Enumeration
wManager.Wow.Enums Namespace


Hated Field

Reaction..::..Hated Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Reaction Hated
Public Const Hated As Reaction
public:
literal Reaction Hated

See Also

Reaction Enumeration
wManager.Wow.Enums Namespace


Honored Field

Reaction..::..Honored Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Reaction Honored
Public Const Honored As Reaction
public:
literal Reaction Honored

See Also

Reaction Enumeration
wManager.Wow.Enums Namespace


Hostile Field

Reaction..::..Hostile Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Reaction Hostile
Public Const Hostile As Reaction
public:
literal Reaction Hostile

See Also

Reaction Enumeration
wManager.Wow.Enums Namespace


Neutral Field

Reaction..::..Neutral Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Reaction Neutral
Public Const Neutral As Reaction
public:
literal Reaction Neutral

See Also

Reaction Enumeration
wManager.Wow.Enums Namespace


Revered Field

Reaction..::..Revered Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Reaction Revered
Public Const Revered As Reaction
public:
literal Reaction Revered

See Also

Reaction Enumeration
wManager.Wow.Enums Namespace


Unfriendly Field

Reaction..::..Unfriendly Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Reaction Unfriendly
Public Const Unfriendly As Reaction
public:
literal Reaction Unfriendly

See Also

Reaction Enumeration
wManager.Wow.Enums Namespace


Unknown Field

Reaction..::..Unknown Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Reaction Unknown
Public Const Unknown As Reaction
public:
literal Reaction Unknown

See Also

Reaction Enumeration
wManager.Wow.Enums Namespace


Blood Field

RuneTypes..::..Blood Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const RuneTypes Blood
Public Const Blood As RuneTypes
public:
literal RuneTypes Blood

See Also

RuneTypes Enumeration
wManager.Wow.Enums Namespace


Death Field

RuneTypes..::..Death Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const RuneTypes Death
Public Const Death As RuneTypes
public:
literal RuneTypes Death

See Also

RuneTypes Enumeration
wManager.Wow.Enums Namespace


Frost Field

RuneTypes..::..Frost Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const RuneTypes Frost
Public Const Frost As RuneTypes
public:
literal RuneTypes Frost

See Also

RuneTypes Enumeration
wManager.Wow.Enums Namespace


None Field

RuneTypes..::..None Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const RuneTypes None
Public Const None As RuneTypes
public:
literal RuneTypes None

See Also

RuneTypes Enumeration
wManager.Wow.Enums Namespace


Unholy Field

RuneTypes..::..Unholy Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const RuneTypes Unholy
Public Const Unholy As RuneTypes
public:
literal RuneTypes Unholy

See Also

RuneTypes Enumeration
wManager.Wow.Enums Namespace


Affliction Field

SkillLine..::..Affliction Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Affliction
Public Const Affliction As SkillLine
public:
literal SkillLine Affliction

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Alchemy Field

SkillLine..::..Alchemy Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Alchemy
Public Const Alchemy As SkillLine
public:
literal SkillLine Alchemy

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Arcane Field

SkillLine..::..Arcane Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Arcane
Public Const Arcane As SkillLine
public:
literal SkillLine Arcane

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Archaeology Field

SkillLine..::..Archaeology Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Archaeology
Public Const Archaeology As SkillLine
public:
literal SkillLine Archaeology

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Arms Field

SkillLine..::..Arms Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Arms
Public Const Arms As SkillLine
public:
literal SkillLine Arms

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Assassination Field

SkillLine..::..Assassination Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Assassination
Public Const Assassination As SkillLine
public:
literal SkillLine Assassination

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Axes Field

SkillLine..::..Axes Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Axes
Public Const Axes As SkillLine
public:
literal SkillLine Axes

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Balance Field

SkillLine..::..Balance Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Balance
Public Const Balance As SkillLine
public:
literal SkillLine Balance

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


BeastMastery Field

SkillLine..::..BeastMastery Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine BeastMastery
Public Const BeastMastery As SkillLine
public:
literal SkillLine BeastMastery

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Blacksmithing Field

SkillLine..::..Blacksmithing Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Blacksmithing
Public Const Blacksmithing As SkillLine
public:
literal SkillLine Blacksmithing

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


BloodElfRacial Field

SkillLine..::..BloodElfRacial Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine BloodElfRacial
Public Const BloodElfRacial As SkillLine
public:
literal SkillLine BloodElfRacial

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Bows Field

SkillLine..::..Bows Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Bows
Public Const Bows As SkillLine
public:
literal SkillLine Bows

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Cloth Field

SkillLine..::..Cloth Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Cloth
Public Const Cloth As SkillLine
public:
literal SkillLine Cloth

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Combat Field

SkillLine..::..Combat Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Combat
Public Const Combat As SkillLine
public:
literal SkillLine Combat

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Companions Field

SkillLine..::..Companions Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Companions
Public Const Companions As SkillLine
public:
literal SkillLine Companions

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Cooking Field

SkillLine..::..Cooking Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Cooking
Public Const Cooking As SkillLine
public:
literal SkillLine Cooking

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Crossbows Field

SkillLine..::..Crossbows Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Crossbows
Public Const Crossbows As SkillLine
public:
literal SkillLine Crossbows

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Daggers Field

SkillLine..::..Daggers Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Daggers
Public Const Daggers As SkillLine
public:
literal SkillLine Daggers

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Defense Field

SkillLine..::..Defense Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Defense
Public Const Defense As SkillLine
public:
literal SkillLine Defense

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Demonology Field

SkillLine..::..Demonology Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Demonology
Public Const Demonology As SkillLine
public:
literal SkillLine Demonology

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Destruction Field

SkillLine..::..Destruction Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Destruction
Public Const Destruction As SkillLine
public:
literal SkillLine Destruction

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Discipline Field

SkillLine..::..Discipline Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Discipline
Public Const Discipline As SkillLine
public:
literal SkillLine Discipline

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


DkBlood Field

SkillLine..::..DkBlood Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine DkBlood
Public Const DkBlood As SkillLine
public:
literal SkillLine DkBlood

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


DkFrost Field

SkillLine..::..DkFrost Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine DkFrost
Public Const DkFrost As SkillLine
public:
literal SkillLine DkFrost

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


DkUnholy Field

SkillLine..::..DkUnholy Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine DkUnholy
Public Const DkUnholy As SkillLine
public:
literal SkillLine DkUnholy

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


DraeneiRacial Field

SkillLine..::..DraeneiRacial Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine DraeneiRacial
Public Const DraeneiRacial As SkillLine
public:
literal SkillLine DraeneiRacial

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


DruidHoly Field

SkillLine..::..DruidHoly Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine DruidHoly
Public Const DruidHoly As SkillLine
public:
literal SkillLine DruidHoly

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


DualWield Field

SkillLine..::..DualWield Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine DualWield
Public Const DualWield As SkillLine
public:
literal SkillLine DualWield

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


DwarvenRacial Field

SkillLine..::..DwarvenRacial Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine DwarvenRacial
Public Const DwarvenRacial As SkillLine
public:
literal SkillLine DwarvenRacial

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


ElementalCombat Field

SkillLine..::..ElementalCombat Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine ElementalCombat
Public Const ElementalCombat As SkillLine
public:
literal SkillLine ElementalCombat

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Enchanting Field

SkillLine..::..Enchanting Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Enchanting
Public Const Enchanting As SkillLine
public:
literal SkillLine Enchanting

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Engineering Field

SkillLine..::..Engineering Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Engineering
Public Const Engineering As SkillLine
public:
literal SkillLine Engineering

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Enhancement Field

SkillLine..::..Enhancement Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Enhancement
Public Const Enhancement As SkillLine
public:
literal SkillLine Enhancement

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


FeralCombat Field

SkillLine..::..FeralCombat Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine FeralCombat
Public Const FeralCombat As SkillLine
public:
literal SkillLine FeralCombat

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Fire Field

SkillLine..::..Fire Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Fire
Public Const Fire As SkillLine
public:
literal SkillLine Fire

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


FirstAid Field

SkillLine..::..FirstAid Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine FirstAid
Public Const FirstAid As SkillLine
public:
literal SkillLine FirstAid

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Fishing Field

SkillLine..::..Fishing Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Fishing
Public Const Fishing As SkillLine
public:
literal SkillLine Fishing

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


FistWeapons Field

SkillLine..::..FistWeapons Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine FistWeapons
Public Const FistWeapons As SkillLine
public:
literal SkillLine FistWeapons

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Free Field

SkillLine..::..Free Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Free
Public Const Free As SkillLine
public:
literal SkillLine Free

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Frost Field

SkillLine..::..Frost Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Frost
Public Const Frost As SkillLine
public:
literal SkillLine Frost

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Fury Field

SkillLine..::..Fury Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Fury
Public Const Fury As SkillLine
public:
literal SkillLine Fury

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Guns Field

SkillLine..::..Guns Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Guns
Public Const Guns As SkillLine
public:
literal SkillLine Guns

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Herbalism Field

SkillLine..::..Herbalism Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Herbalism
Public Const Herbalism As SkillLine
public:
literal SkillLine Herbalism

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Holy Field

SkillLine..::..Holy Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Holy
Public Const Holy As SkillLine
public:
literal SkillLine Holy

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


HorseRiding Field

SkillLine..::..HorseRiding Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine HorseRiding
Public Const HorseRiding As SkillLine
public:
literal SkillLine HorseRiding

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


HunterSurvival Field

SkillLine..::..HunterSurvival Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine HunterSurvival
Public Const HunterSurvival As SkillLine
public:
literal SkillLine HunterSurvival

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Inscription Field

SkillLine..::..Inscription Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Inscription
Public Const Inscription As SkillLine
public:
literal SkillLine Inscription

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Internal Field

SkillLine..::..Internal Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Internal
Public Const Internal As SkillLine
public:
literal SkillLine Internal

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Jewelcrafting Field

SkillLine..::..Jewelcrafting Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Jewelcrafting
Public Const Jewelcrafting As SkillLine
public:
literal SkillLine Jewelcrafting

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


KodoRiding Field

SkillLine..::..KodoRiding Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine KodoRiding
Public Const KodoRiding As SkillLine
public:
literal SkillLine KodoRiding

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


LanguageCommon Field

SkillLine..::..LanguageCommon Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine LanguageCommon
Public Const LanguageCommon As SkillLine
public:
literal SkillLine LanguageCommon

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


LanguageDarnassian Field

SkillLine..::..LanguageDarnassian Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine LanguageDarnassian
Public Const LanguageDarnassian As SkillLine
public:
literal SkillLine LanguageDarnassian

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


LanguageDemonTongue Field

SkillLine..::..LanguageDemonTongue Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine LanguageDemonTongue
Public Const LanguageDemonTongue As SkillLine
public:
literal SkillLine LanguageDemonTongue

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


LanguageDraconic Field

SkillLine..::..LanguageDraconic Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine LanguageDraconic
Public Const LanguageDraconic As SkillLine
public:
literal SkillLine LanguageDraconic

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


LanguageDraenei Field

SkillLine..::..LanguageDraenei Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine LanguageDraenei
Public Const LanguageDraenei As SkillLine
public:
literal SkillLine LanguageDraenei

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


LanguageDwarven Field

SkillLine..::..LanguageDwarven Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine LanguageDwarven
Public Const LanguageDwarven As SkillLine
public:
literal SkillLine LanguageDwarven

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


LanguageGnomish Field

SkillLine..::..LanguageGnomish Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine LanguageGnomish
Public Const LanguageGnomish As SkillLine
public:
literal SkillLine LanguageGnomish

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


LanguageGutterspeak Field

SkillLine..::..LanguageGutterspeak Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine LanguageGutterspeak
Public Const LanguageGutterspeak As SkillLine
public:
literal SkillLine LanguageGutterspeak

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


LanguageOldTongue Field

SkillLine..::..LanguageOldTongue Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine LanguageOldTongue
Public Const LanguageOldTongue As SkillLine
public:
literal SkillLine LanguageOldTongue

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


LanguageOrcish Field

SkillLine..::..LanguageOrcish Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine LanguageOrcish
Public Const LanguageOrcish As SkillLine
public:
literal SkillLine LanguageOrcish

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


LanguageTaurahe Field

SkillLine..::..LanguageTaurahe Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine LanguageTaurahe
Public Const LanguageTaurahe As SkillLine
public:
literal SkillLine LanguageTaurahe

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


LanguageThalassian Field

SkillLine..::..LanguageThalassian Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine LanguageThalassian
Public Const LanguageThalassian As SkillLine
public:
literal SkillLine LanguageThalassian

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


LanguageTitan Field

SkillLine..::..LanguageTitan Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine LanguageTitan
Public Const LanguageTitan As SkillLine
public:
literal SkillLine LanguageTitan

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


LanguageTroll Field

SkillLine..::..LanguageTroll Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine LanguageTroll
Public Const LanguageTroll As SkillLine
public:
literal SkillLine LanguageTroll

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Leather Field

SkillLine..::..Leather Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Leather
Public Const Leather As SkillLine
public:
literal SkillLine Leather

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Leatherworking Field

SkillLine..::..Leatherworking Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Leatherworking
Public Const Leatherworking As SkillLine
public:
literal SkillLine Leatherworking

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Lockpicking Field

SkillLine..::..Lockpicking Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Lockpicking
Public Const Lockpicking As SkillLine
public:
literal SkillLine Lockpicking

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Logging Field

SkillLine..::..Logging Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Logging
Public Const Logging As SkillLine
public:
literal SkillLine Logging

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Maces Field

SkillLine..::..Maces Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Maces
Public Const Maces As SkillLine
public:
literal SkillLine Maces

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Mail Field

SkillLine..::..Mail Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Mail
Public Const Mail As SkillLine
public:
literal SkillLine Mail

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Marksmanship Field

SkillLine..::..Marksmanship Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Marksmanship
Public Const Marksmanship As SkillLine
public:
literal SkillLine Marksmanship

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


MechanostriderPiloting Field

SkillLine..::..MechanostriderPiloting Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine MechanostriderPiloting
Public Const MechanostriderPiloting As SkillLine
public:
literal SkillLine MechanostriderPiloting

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Mining Field

SkillLine..::..Mining Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Mining
Public Const Mining As SkillLine
public:
literal SkillLine Mining

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Mounts Field

SkillLine..::..Mounts Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Mounts
Public Const Mounts As SkillLine
public:
literal SkillLine Mounts

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


NightElfRacial Field

SkillLine..::..NightElfRacial Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine NightElfRacial
Public Const NightElfRacial As SkillLine
public:
literal SkillLine NightElfRacial

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


None Field

SkillLine..::..None Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine None
Public Const None As SkillLine
public:
literal SkillLine None

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


OrcRacial Field

SkillLine..::..OrcRacial Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine OrcRacial
Public Const OrcRacial As SkillLine
public:
literal SkillLine OrcRacial

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


PetBat Field

SkillLine..::..PetBat Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine PetBat
Public Const PetBat As SkillLine
public:
literal SkillLine PetBat

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


PetBear Field

SkillLine..::..PetBear Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine PetBear
Public Const PetBear As SkillLine
public:
literal SkillLine PetBear

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


PetBirdofPrey Field

SkillLine..::..PetBirdofPrey Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine PetBirdofPrey
Public Const PetBirdofPrey As SkillLine
public:
literal SkillLine PetBirdofPrey

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


PetBoar Field

SkillLine..::..PetBoar Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine PetBoar
Public Const PetBoar As SkillLine
public:
literal SkillLine PetBoar

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


PetCarrionBird Field

SkillLine..::..PetCarrionBird Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine PetCarrionBird
Public Const PetCarrionBird As SkillLine
public:
literal SkillLine PetCarrionBird

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


PetCat Field

SkillLine..::..PetCat Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine PetCat
Public Const PetCat As SkillLine
public:
literal SkillLine PetCat

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


PetCrab Field

SkillLine..::..PetCrab Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine PetCrab
Public Const PetCrab As SkillLine
public:
literal SkillLine PetCrab

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


PetCrocolisk Field

SkillLine..::..PetCrocolisk Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine PetCrocolisk
Public Const PetCrocolisk As SkillLine
public:
literal SkillLine PetCrocolisk

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


PetDoomguard Field

SkillLine..::..PetDoomguard Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine PetDoomguard
Public Const PetDoomguard As SkillLine
public:
literal SkillLine PetDoomguard

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


PetDragonhawk Field

SkillLine..::..PetDragonhawk Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine PetDragonhawk
Public Const PetDragonhawk As SkillLine
public:
literal SkillLine PetDragonhawk

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


PetEventRemoteControl Field

SkillLine..::..PetEventRemoteControl Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine PetEventRemoteControl
Public Const PetEventRemoteControl As SkillLine
public:
literal SkillLine PetEventRemoteControl

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


PetExoticChimaera Field

SkillLine..::..PetExoticChimaera Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine PetExoticChimaera
Public Const PetExoticChimaera As SkillLine
public:
literal SkillLine PetExoticChimaera

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


PetExoticCoreHound Field

SkillLine..::..PetExoticCoreHound Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine PetExoticCoreHound
Public Const PetExoticCoreHound As SkillLine
public:
literal SkillLine PetExoticCoreHound

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


PetExoticDevlisaur Field

SkillLine..::..PetExoticDevlisaur Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine PetExoticDevlisaur
Public Const PetExoticDevlisaur As SkillLine
public:
literal SkillLine PetExoticDevlisaur

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


PetExoticRhino Field

SkillLine..::..PetExoticRhino Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine PetExoticRhino
Public Const PetExoticRhino As SkillLine
public:
literal SkillLine PetExoticRhino

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


PetExoticSilithid Field

SkillLine..::..PetExoticSilithid Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine PetExoticSilithid
Public Const PetExoticSilithid As SkillLine
public:
literal SkillLine PetExoticSilithid

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


PetExoticWorm Field

SkillLine..::..PetExoticWorm Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine PetExoticWorm
Public Const PetExoticWorm As SkillLine
public:
literal SkillLine PetExoticWorm

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


PetFelguard Field

SkillLine..::..PetFelguard Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine PetFelguard
Public Const PetFelguard As SkillLine
public:
literal SkillLine PetFelguard

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


PetFelhunter Field

SkillLine..::..PetFelhunter Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine PetFelhunter
Public Const PetFelhunter As SkillLine
public:
literal SkillLine PetFelhunter

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


PetGenericHunter Field

SkillLine..::..PetGenericHunter Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine PetGenericHunter
Public Const PetGenericHunter As SkillLine
public:
literal SkillLine PetGenericHunter

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


PetGhoul Field

SkillLine..::..PetGhoul Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine PetGhoul
Public Const PetGhoul As SkillLine
public:
literal SkillLine PetGhoul

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


PetGorilla Field

SkillLine..::..PetGorilla Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine PetGorilla
Public Const PetGorilla As SkillLine
public:
literal SkillLine PetGorilla

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


PetHyena Field

SkillLine..::..PetHyena Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine PetHyena
Public Const PetHyena As SkillLine
public:
literal SkillLine PetHyena

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


PetImp Field

SkillLine..::..PetImp Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine PetImp
Public Const PetImp As SkillLine
public:
literal SkillLine PetImp

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


PetInfernal Field

SkillLine..::..PetInfernal Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine PetInfernal
Public Const PetInfernal As SkillLine
public:
literal SkillLine PetInfernal

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


PetMoth Field

SkillLine..::..PetMoth Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine PetMoth
Public Const PetMoth As SkillLine
public:
literal SkillLine PetMoth

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


PetNetherRay Field

SkillLine..::..PetNetherRay Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine PetNetherRay
Public Const PetNetherRay As SkillLine
public:
literal SkillLine PetNetherRay

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


PetRaptor Field

SkillLine..::..PetRaptor Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine PetRaptor
Public Const PetRaptor As SkillLine
public:
literal SkillLine PetRaptor

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


PetRavager Field

SkillLine..::..PetRavager Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine PetRavager
Public Const PetRavager As SkillLine
public:
literal SkillLine PetRavager

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


PetScorpid Field

SkillLine..::..PetScorpid Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine PetScorpid
Public Const PetScorpid As SkillLine
public:
literal SkillLine PetScorpid

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


PetSerpent Field

SkillLine..::..PetSerpent Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine PetSerpent
Public Const PetSerpent As SkillLine
public:
literal SkillLine PetSerpent

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


PetSpider Field

SkillLine..::..PetSpider Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine PetSpider
Public Const PetSpider As SkillLine
public:
literal SkillLine PetSpider

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


PetSporebat Field

SkillLine..::..PetSporebat Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine PetSporebat
Public Const PetSporebat As SkillLine
public:
literal SkillLine PetSporebat

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


PetSuccubus Field

SkillLine..::..PetSuccubus Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine PetSuccubus
Public Const PetSuccubus As SkillLine
public:
literal SkillLine PetSuccubus

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


PetTallstrider Field

SkillLine..::..PetTallstrider Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine PetTallstrider
Public Const PetTallstrider As SkillLine
public:
literal SkillLine PetTallstrider

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


PetTurtle Field

SkillLine..::..PetTurtle Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine PetTurtle
Public Const PetTurtle As SkillLine
public:
literal SkillLine PetTurtle

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


PetVoidwalker Field

SkillLine..::..PetVoidwalker Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine PetVoidwalker
Public Const PetVoidwalker As SkillLine
public:
literal SkillLine PetVoidwalker

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


PetWarpStalker Field

SkillLine..::..PetWarpStalker Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine PetWarpStalker
Public Const PetWarpStalker As SkillLine
public:
literal SkillLine PetWarpStalker

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


PetWasp Field

SkillLine..::..PetWasp Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine PetWasp
Public Const PetWasp As SkillLine
public:
literal SkillLine PetWasp

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


PetWindSerpent Field

SkillLine..::..PetWindSerpent Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine PetWindSerpent
Public Const PetWindSerpent As SkillLine
public:
literal SkillLine PetWindSerpent

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


PetWolf Field

SkillLine..::..PetWolf Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine PetWolf
Public Const PetWolf As SkillLine
public:
literal SkillLine PetWolf

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


PlateMail Field

SkillLine..::..PlateMail Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine PlateMail
Public Const PlateMail As SkillLine
public:
literal SkillLine PlateMail

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Polearms Field

SkillLine..::..Polearms Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Polearms
Public Const Polearms As SkillLine
public:
literal SkillLine Polearms

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Protection Field

SkillLine..::..Protection Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Protection
Public Const Protection As SkillLine
public:
literal SkillLine Protection

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Protection2 Field

SkillLine..::..Protection2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Protection2
Public Const Protection2 As SkillLine
public:
literal SkillLine Protection2

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


RacialGnome Field

SkillLine..::..RacialGnome Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine RacialGnome
Public Const RacialGnome As SkillLine
public:
literal SkillLine RacialGnome

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


RacialHuman Field

SkillLine..::..RacialHuman Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine RacialHuman
Public Const RacialHuman As SkillLine
public:
literal SkillLine RacialHuman

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


RacialTroll Field

SkillLine..::..RacialTroll Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine RacialTroll
Public Const RacialTroll As SkillLine
public:
literal SkillLine RacialTroll

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


RacialUndead Field

SkillLine..::..RacialUndead Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine RacialUndead
Public Const RacialUndead As SkillLine
public:
literal SkillLine RacialUndead

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


RamRiding Field

SkillLine..::..RamRiding Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine RamRiding
Public Const RamRiding As SkillLine
public:
literal SkillLine RamRiding

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


RaptorRiding Field

SkillLine..::..RaptorRiding Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine RaptorRiding
Public Const RaptorRiding As SkillLine
public:
literal SkillLine RaptorRiding

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Restoration Field

SkillLine..::..Restoration Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Restoration
Public Const Restoration As SkillLine
public:
literal SkillLine Restoration

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Retribution Field

SkillLine..::..Retribution Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Retribution
Public Const Retribution As SkillLine
public:
literal SkillLine Retribution

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Riding Field

SkillLine..::..Riding Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Riding
Public Const Riding As SkillLine
public:
literal SkillLine Riding

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Runeforging Field

SkillLine..::..Runeforging Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Runeforging
Public Const Runeforging As SkillLine
public:
literal SkillLine Runeforging

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


ShadowMagic Field

SkillLine..::..ShadowMagic Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine ShadowMagic
Public Const ShadowMagic As SkillLine
public:
literal SkillLine ShadowMagic

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


ShamanRestoration Field

SkillLine..::..ShamanRestoration Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine ShamanRestoration
Public Const ShamanRestoration As SkillLine
public:
literal SkillLine ShamanRestoration

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Shield Field

SkillLine..::..Shield Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Shield
Public Const Shield As SkillLine
public:
literal SkillLine Shield

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Skinning Field

SkillLine..::..Skinning Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Skinning
Public Const Skinning As SkillLine
public:
literal SkillLine Skinning

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Staves Field

SkillLine..::..Staves Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Staves
Public Const Staves As SkillLine
public:
literal SkillLine Staves

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Subtlety Field

SkillLine..::..Subtlety Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Subtlety
Public Const Subtlety As SkillLine
public:
literal SkillLine Subtlety

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Survival Field

SkillLine..::..Survival Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Survival
Public Const Survival As SkillLine
public:
literal SkillLine Survival

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Swimming Field

SkillLine..::..Swimming Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Swimming
Public Const Swimming As SkillLine
public:
literal SkillLine Swimming

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Swords Field

SkillLine..::..Swords Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Swords
Public Const Swords As SkillLine
public:
literal SkillLine Swords

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Tailoring Field

SkillLine..::..Tailoring Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Tailoring
Public Const Tailoring As SkillLine
public:
literal SkillLine Tailoring

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


TaurenRacial Field

SkillLine..::..TaurenRacial Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine TaurenRacial
Public Const TaurenRacial As SkillLine
public:
literal SkillLine TaurenRacial

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Thrown Field

SkillLine..::..Thrown Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Thrown
Public Const Thrown As SkillLine
public:
literal SkillLine Thrown

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


TigerRiding Field

SkillLine..::..TigerRiding Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine TigerRiding
Public Const TigerRiding As SkillLine
public:
literal SkillLine TigerRiding

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


TwoHandedAxes Field

SkillLine..::..TwoHandedAxes Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine TwoHandedAxes
Public Const TwoHandedAxes As SkillLine
public:
literal SkillLine TwoHandedAxes

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


TwoHandedMaces Field

SkillLine..::..TwoHandedMaces Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine TwoHandedMaces
Public Const TwoHandedMaces As SkillLine
public:
literal SkillLine TwoHandedMaces

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


TwoHandedSwords Field

SkillLine..::..TwoHandedSwords Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine TwoHandedSwords
Public Const TwoHandedSwords As SkillLine
public:
literal SkillLine TwoHandedSwords

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Unarmed Field

SkillLine..::..Unarmed Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Unarmed
Public Const Unarmed As SkillLine
public:
literal SkillLine Unarmed

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


UndeadHorsemanship Field

SkillLine..::..UndeadHorsemanship Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine UndeadHorsemanship
Public Const UndeadHorsemanship As SkillLine
public:
literal SkillLine UndeadHorsemanship

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


Wands Field

SkillLine..::..Wands Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine Wands
Public Const Wands As SkillLine
public:
literal SkillLine Wands

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


WolfRiding Field

SkillLine..::..WolfRiding Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SkillLine WolfRiding
Public Const WolfRiding As SkillLine
public:
literal SkillLine WolfRiding

See Also

SkillLine Enumeration
wManager.Wow.Enums Namespace


SurverToolGreen Field

SurveyTool..::..SurverToolGreen Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SurveyTool SurverToolGreen
Public Const SurverToolGreen As SurveyTool
public:
literal SurveyTool SurverToolGreen

See Also

SurveyTool Enumeration
wManager.Wow.Enums Namespace


SurveyToolRed Field

SurveyTool..::..SurveyToolRed Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SurveyTool SurveyToolRed
Public Const SurveyToolRed As SurveyTool
public:
literal SurveyTool SurveyToolRed

See Also

SurveyTool Enumeration
wManager.Wow.Enums Namespace


SurveyToolYellow Field

SurveyTool..::..SurveyToolYellow Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const SurveyTool SurveyToolYellow
Public Const SurveyToolYellow As SurveyTool
public:
literal SurveyTool SurveyToolYellow

See Also

SurveyTool Enumeration
wManager.Wow.Enums Namespace


Air Field

TotemType..::..Air Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const TotemType Air
Public Const Air As TotemType
public:
literal TotemType Air

See Also

TotemType Enumeration
wManager.Wow.Enums Namespace


Earth Field

TotemType..::..Earth Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const TotemType Earth
Public Const Earth As TotemType
public:
literal TotemType Earth

See Also

TotemType Enumeration
wManager.Wow.Enums Namespace


Fire Field

TotemType..::..Fire Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const TotemType Fire
Public Const Fire As TotemType
public:
literal TotemType Fire

See Also

TotemType Enumeration
wManager.Wow.Enums Namespace


Water Field

TotemType..::..Water Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const TotemType Water
Public Const Water As TotemType
public:
literal TotemType Water

See Also

TotemType Enumeration
wManager.Wow.Enums Namespace


All Field

TrackCreatureFlags..::..All Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const TrackCreatureFlags All
Public Const All As TrackCreatureFlags
public:
literal TrackCreatureFlags All

See Also

TrackCreatureFlags Enumeration
wManager.Wow.Enums Namespace


BattlePets Field

TrackCreatureFlags..::..BattlePets Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const TrackCreatureFlags BattlePets
Public Const BattlePets As TrackCreatureFlags
public:
literal TrackCreatureFlags BattlePets

See Also

TrackCreatureFlags Enumeration
wManager.Wow.Enums Namespace


Beasts Field

TrackCreatureFlags..::..Beasts Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const TrackCreatureFlags Beasts
Public Const Beasts As TrackCreatureFlags
public:
literal TrackCreatureFlags Beasts

See Also

TrackCreatureFlags Enumeration
wManager.Wow.Enums Namespace


Critters Field

TrackCreatureFlags..::..Critters Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const TrackCreatureFlags Critters
Public Const Critters As TrackCreatureFlags
public:
literal TrackCreatureFlags Critters

See Also

TrackCreatureFlags Enumeration
wManager.Wow.Enums Namespace


Demons Field

TrackCreatureFlags..::..Demons Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const TrackCreatureFlags Demons
Public Const Demons As TrackCreatureFlags
public:
literal TrackCreatureFlags Demons

See Also

TrackCreatureFlags Enumeration
wManager.Wow.Enums Namespace


Dragons Field

TrackCreatureFlags..::..Dragons Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const TrackCreatureFlags Dragons
Public Const Dragons As TrackCreatureFlags
public:
literal TrackCreatureFlags Dragons

See Also

TrackCreatureFlags Enumeration
wManager.Wow.Enums Namespace


Elementals Field

TrackCreatureFlags..::..Elementals Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const TrackCreatureFlags Elementals
Public Const Elementals As TrackCreatureFlags
public:
literal TrackCreatureFlags Elementals

See Also

TrackCreatureFlags Enumeration
wManager.Wow.Enums Namespace


GasCloud Field

TrackCreatureFlags..::..GasCloud Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const TrackCreatureFlags GasCloud
Public Const GasCloud As TrackCreatureFlags
public:
literal TrackCreatureFlags GasCloud

See Also

TrackCreatureFlags Enumeration
wManager.Wow.Enums Namespace


Giants Field

TrackCreatureFlags..::..Giants Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const TrackCreatureFlags Giants
Public Const Giants As TrackCreatureFlags
public:
literal TrackCreatureFlags Giants

See Also

TrackCreatureFlags Enumeration
wManager.Wow.Enums Namespace


Humanoids Field

TrackCreatureFlags..::..Humanoids Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const TrackCreatureFlags Humanoids
Public Const Humanoids As TrackCreatureFlags
public:
literal TrackCreatureFlags Humanoids

See Also

TrackCreatureFlags Enumeration
wManager.Wow.Enums Namespace


Machines Field

TrackCreatureFlags..::..Machines Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const TrackCreatureFlags Machines
Public Const Machines As TrackCreatureFlags
public:
literal TrackCreatureFlags Machines

See Also

TrackCreatureFlags Enumeration
wManager.Wow.Enums Namespace


NonCombatPet Field

TrackCreatureFlags..::..NonCombatPet Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const TrackCreatureFlags NonCombatPet
Public Const NonCombatPet As TrackCreatureFlags
public:
literal TrackCreatureFlags NonCombatPet

See Also

TrackCreatureFlags Enumeration
wManager.Wow.Enums Namespace


None Field

TrackCreatureFlags..::..None Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const TrackCreatureFlags None
Public Const None As TrackCreatureFlags
public:
literal TrackCreatureFlags None

See Also

TrackCreatureFlags Enumeration
wManager.Wow.Enums Namespace


Slimes Field

TrackCreatureFlags..::..Slimes Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const TrackCreatureFlags Slimes
Public Const Slimes As TrackCreatureFlags
public:
literal TrackCreatureFlags Slimes

See Also

TrackCreatureFlags Enumeration
wManager.Wow.Enums Namespace


Totem Field

TrackCreatureFlags..::..Totem Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const TrackCreatureFlags Totem
Public Const Totem As TrackCreatureFlags
public:
literal TrackCreatureFlags Totem

See Also

TrackCreatureFlags Enumeration
wManager.Wow.Enums Namespace


Undead Field

TrackCreatureFlags..::..Undead Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const TrackCreatureFlags Undead
Public Const Undead As TrackCreatureFlags
public:
literal TrackCreatureFlags Undead

See Also

TrackCreatureFlags Enumeration
wManager.Wow.Enums Namespace


All Field

TrackObjectFlags..::..All Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const TrackObjectFlags All
Public Const All As TrackObjectFlags
public:
literal TrackObjectFlags All

See Also

TrackObjectFlags Enumeration
wManager.Wow.Enums Namespace


ArmTrap Field

TrackObjectFlags..::..ArmTrap Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const TrackObjectFlags ArmTrap
Public Const ArmTrap As TrackObjectFlags
public:
literal TrackObjectFlags ArmTrap

See Also

TrackObjectFlags Enumeration
wManager.Wow.Enums Namespace


Blasting Field

TrackObjectFlags..::..Blasting Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const TrackObjectFlags Blasting
Public Const Blasting As TrackObjectFlags
public:
literal TrackObjectFlags Blasting

See Also

TrackObjectFlags Enumeration
wManager.Wow.Enums Namespace


CalcifiedElvenGems Field

TrackObjectFlags..::..CalcifiedElvenGems Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const TrackObjectFlags CalcifiedElvenGems
Public Const CalcifiedElvenGems As TrackObjectFlags
public:
literal TrackObjectFlags CalcifiedElvenGems

See Also

TrackObjectFlags Enumeration
wManager.Wow.Enums Namespace


Close Field

TrackObjectFlags..::..Close Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const TrackObjectFlags Close
Public Const Close As TrackObjectFlags
public:
literal TrackObjectFlags Close

See Also

TrackObjectFlags Enumeration
wManager.Wow.Enums Namespace


DisarmTrap Field

TrackObjectFlags..::..DisarmTrap Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const TrackObjectFlags DisarmTrap
Public Const DisarmTrap As TrackObjectFlags
public:
literal TrackObjectFlags DisarmTrap

See Also

TrackObjectFlags Enumeration
wManager.Wow.Enums Namespace


Fishing Field

TrackObjectFlags..::..Fishing Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const TrackObjectFlags Fishing
Public Const Fishing As TrackObjectFlags
public:
literal TrackObjectFlags Fishing

See Also

TrackObjectFlags Enumeration
wManager.Wow.Enums Namespace


Gahzridian Field

TrackObjectFlags..::..Gahzridian Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const TrackObjectFlags Gahzridian
Public Const Gahzridian As TrackObjectFlags
public:
literal TrackObjectFlags Gahzridian

See Also

TrackObjectFlags Enumeration
wManager.Wow.Enums Namespace


Herbs Field

TrackObjectFlags..::..Herbs Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const TrackObjectFlags Herbs
Public Const Herbs As TrackObjectFlags
public:
literal TrackObjectFlags Herbs

See Also

TrackObjectFlags Enumeration
wManager.Wow.Enums Namespace


Inscription Field

TrackObjectFlags..::..Inscription Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const TrackObjectFlags Inscription
Public Const Inscription As TrackObjectFlags
public:
literal TrackObjectFlags Inscription

See Also

TrackObjectFlags Enumeration
wManager.Wow.Enums Namespace


Lockpicking Field

TrackObjectFlags..::..Lockpicking Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const TrackObjectFlags Lockpicking
Public Const Lockpicking As TrackObjectFlags
public:
literal TrackObjectFlags Lockpicking

See Also

TrackObjectFlags Enumeration
wManager.Wow.Enums Namespace


Minerals Field

TrackObjectFlags..::..Minerals Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const TrackObjectFlags Minerals
Public Const Minerals As TrackObjectFlags
public:
literal TrackObjectFlags Minerals

See Also

TrackObjectFlags Enumeration
wManager.Wow.Enums Namespace


None Field

TrackObjectFlags..::..None Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const TrackObjectFlags None
Public Const None As TrackObjectFlags
public:
literal TrackObjectFlags None

See Also

TrackObjectFlags Enumeration
wManager.Wow.Enums Namespace


notsure Field

TrackObjectFlags..::..notsure Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const TrackObjectFlags notsure
Public Const notsure As TrackObjectFlags
public:
literal TrackObjectFlags notsure

See Also

TrackObjectFlags Enumeration
wManager.Wow.Enums Namespace


Open Field

TrackObjectFlags..::..Open Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const TrackObjectFlags Open
Public Const Open As TrackObjectFlags
public:
literal TrackObjectFlags Open

See Also

TrackObjectFlags Enumeration
wManager.Wow.Enums Namespace


OpenAttacking Field

TrackObjectFlags..::..OpenAttacking Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const TrackObjectFlags OpenAttacking
Public Const OpenAttacking As TrackObjectFlags
public:
literal TrackObjectFlags OpenAttacking

See Also

TrackObjectFlags Enumeration
wManager.Wow.Enums Namespace


OpenFromVehicle Field

TrackObjectFlags..::..OpenFromVehicle Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const TrackObjectFlags OpenFromVehicle
Public Const OpenFromVehicle As TrackObjectFlags
public:
literal TrackObjectFlags OpenFromVehicle

See Also

TrackObjectFlags Enumeration
wManager.Wow.Enums Namespace


OpenKneeling Field

TrackObjectFlags..::..OpenKneeling Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const TrackObjectFlags OpenKneeling
Public Const OpenKneeling As TrackObjectFlags
public:
literal TrackObjectFlags OpenKneeling

See Also

TrackObjectFlags Enumeration
wManager.Wow.Enums Namespace


OpenTinkering Field

TrackObjectFlags..::..OpenTinkering Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const TrackObjectFlags OpenTinkering
Public Const OpenTinkering As TrackObjectFlags
public:
literal TrackObjectFlags OpenTinkering

See Also

TrackObjectFlags Enumeration
wManager.Wow.Enums Namespace


PvPClose Field

TrackObjectFlags..::..PvPClose Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const TrackObjectFlags PvPClose
Public Const PvPClose As TrackObjectFlags
public:
literal TrackObjectFlags PvPClose

See Also

TrackObjectFlags Enumeration
wManager.Wow.Enums Namespace


PvPOpen Field

TrackObjectFlags..::..PvPOpen Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const TrackObjectFlags PvPOpen
Public Const PvPOpen As TrackObjectFlags
public:
literal TrackObjectFlags PvPOpen

See Also

TrackObjectFlags Enumeration
wManager.Wow.Enums Namespace


QuickClose Field

TrackObjectFlags..::..QuickClose Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const TrackObjectFlags QuickClose
Public Const QuickClose As TrackObjectFlags
public:
literal TrackObjectFlags QuickClose

See Also

TrackObjectFlags Enumeration
wManager.Wow.Enums Namespace


QuickOpen Field

TrackObjectFlags..::..QuickOpen Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const TrackObjectFlags QuickOpen
Public Const QuickOpen As TrackObjectFlags
public:
literal TrackObjectFlags QuickOpen

See Also

TrackObjectFlags Enumeration
wManager.Wow.Enums Namespace


Treasure Field

TrackObjectFlags..::..Treasure Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const TrackObjectFlags Treasure
Public Const Treasure As TrackObjectFlags
public:
literal TrackObjectFlags Treasure

See Also

TrackObjectFlags Enumeration
wManager.Wow.Enums Namespace


elite Field

UnitClassification..::..elite Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitClassification elite
Public Const elite As UnitClassification
public:
literal UnitClassification elite

See Also

UnitClassification Enumeration
wManager.Wow.Enums Namespace


minus Field

UnitClassification..::..minus Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitClassification minus
Public Const minus As UnitClassification
public:
literal UnitClassification minus

See Also

UnitClassification Enumeration
wManager.Wow.Enums Namespace


normal Field

UnitClassification..::..normal Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitClassification normal
Public Const normal As UnitClassification
public:
literal UnitClassification normal

See Also

UnitClassification Enumeration
wManager.Wow.Enums Namespace


rare Field

UnitClassification..::..rare Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitClassification rare
Public Const rare As UnitClassification
public:
literal UnitClassification rare

See Also

UnitClassification Enumeration
wManager.Wow.Enums Namespace


rareelite Field

UnitClassification..::..rareelite Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitClassification rareelite
Public Const rareelite As UnitClassification
public:
literal UnitClassification rareelite

See Also

UnitClassification Enumeration
wManager.Wow.Enums Namespace


trivial Field

UnitClassification..::..trivial Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitClassification trivial
Public Const trivial As UnitClassification
public:
literal UnitClassification trivial

See Also

UnitClassification Enumeration
wManager.Wow.Enums Namespace


worldboss Field

UnitClassification..::..worldboss Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitClassification worldboss
Public Const worldboss As UnitClassification
public:
literal UnitClassification worldboss

See Also

UnitClassification Enumeration
wManager.Wow.Enums Namespace


Dead Field

UnitDynamicFlags..::..Dead Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitDynamicFlags Dead
Public Const Dead As UnitDynamicFlags
public:
literal UnitDynamicFlags Dead

See Also

UnitDynamicFlags Enumeration
wManager.Wow.Enums Namespace


IsTappedByAllThreatList Field

UnitDynamicFlags..::..IsTappedByAllThreatList Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitDynamicFlags IsTappedByAllThreatList
Public Const IsTappedByAllThreatList As UnitDynamicFlags
public:
literal UnitDynamicFlags IsTappedByAllThreatList

See Also

UnitDynamicFlags Enumeration
wManager.Wow.Enums Namespace


Lootable Field

UnitDynamicFlags..::..Lootable Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitDynamicFlags Lootable
Public Const Lootable As UnitDynamicFlags
public:
literal UnitDynamicFlags Lootable

See Also

UnitDynamicFlags Enumeration
wManager.Wow.Enums Namespace


None Field

UnitDynamicFlags..::..None Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitDynamicFlags None
Public Const None As UnitDynamicFlags
public:
literal UnitDynamicFlags None

See Also

UnitDynamicFlags Enumeration
wManager.Wow.Enums Namespace


ReferAFriendLinked Field

UnitDynamicFlags..::..ReferAFriendLinked Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitDynamicFlags ReferAFriendLinked
Public Const ReferAFriendLinked As UnitDynamicFlags
public:
literal UnitDynamicFlags ReferAFriendLinked

See Also

UnitDynamicFlags Enumeration
wManager.Wow.Enums Namespace


SpecialInfo Field

UnitDynamicFlags..::..SpecialInfo Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitDynamicFlags SpecialInfo
Public Const SpecialInfo As UnitDynamicFlags
public:
literal UnitDynamicFlags SpecialInfo

See Also

UnitDynamicFlags Enumeration
wManager.Wow.Enums Namespace


TaggedByMe Field

UnitDynamicFlags..::..TaggedByMe Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitDynamicFlags TaggedByMe
Public Const TaggedByMe As UnitDynamicFlags
public:
literal UnitDynamicFlags TaggedByMe

See Also

UnitDynamicFlags Enumeration
wManager.Wow.Enums Namespace


TaggedByOther Field

UnitDynamicFlags..::..TaggedByOther Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitDynamicFlags TaggedByOther
Public Const TaggedByOther As UnitDynamicFlags
public:
literal UnitDynamicFlags TaggedByOther

See Also

UnitDynamicFlags Enumeration
wManager.Wow.Enums Namespace


TrackUnit Field

UnitDynamicFlags..::..TrackUnit Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitDynamicFlags TrackUnit
Public Const TrackUnit As UnitDynamicFlags
public:
literal UnitDynamicFlags TrackUnit

See Also

UnitDynamicFlags Enumeration
wManager.Wow.Enums Namespace


_Flag_0x200 Field

UnitFlags..::.._Flag_0x200 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitFlags _Flag_0x200
Public Const _Flag_0x200 As UnitFlags
public:
literal UnitFlags _Flag_0x200

See Also

UnitFlags Enumeration
wManager.Wow.Enums Namespace


_Flag_14_0x4000 Field

UnitFlags..::.._Flag_14_0x4000 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitFlags _Flag_14_0x4000
Public Const _Flag_14_0x4000 As UnitFlags
public:
literal UnitFlags _Flag_14_0x4000

See Also

UnitFlags Enumeration
wManager.Wow.Enums Namespace


_Flag_15_0x8000 Field

UnitFlags..::.._Flag_15_0x8000 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitFlags _Flag_15_0x8000
Public Const _Flag_15_0x8000 As UnitFlags
public:
literal UnitFlags _Flag_15_0x8000

See Also

UnitFlags Enumeration
wManager.Wow.Enums Namespace


_Flag_28_0x10000000 Field

UnitFlags..::.._Flag_28_0x10000000 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitFlags _Flag_28_0x10000000
Public Const _Flag_28_0x10000000 As UnitFlags
public:
literal UnitFlags _Flag_28_0x10000000

See Also

UnitFlags Enumeration
wManager.Wow.Enums Namespace


_Flag_31_0x80000000 Field

UnitFlags..::.._Flag_31_0x80000000 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitFlags _Flag_31_0x80000000
Public Const _Flag_31_0x80000000 As UnitFlags
public:
literal UnitFlags _Flag_31_0x80000000

See Also

UnitFlags Enumeration
wManager.Wow.Enums Namespace


_SelectableNotAttackable_1 Field

UnitFlags..::.._SelectableNotAttackable_1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitFlags _SelectableNotAttackable_1
Public Const _SelectableNotAttackable_1 As UnitFlags
public:
literal UnitFlags _SelectableNotAttackable_1

See Also

UnitFlags Enumeration
wManager.Wow.Enums Namespace


_SelectableNotAttackable_2 Field

UnitFlags..::.._SelectableNotAttackable_2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitFlags _SelectableNotAttackable_2
Public Const _SelectableNotAttackable_2 As UnitFlags
public:
literal UnitFlags _SelectableNotAttackable_2

See Also

UnitFlags Enumeration
wManager.Wow.Enums Namespace


_SelectableNotAttackable_3 Field

UnitFlags..::.._SelectableNotAttackable_3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitFlags _SelectableNotAttackable_3
Public Const _SelectableNotAttackable_3 As UnitFlags
public:
literal UnitFlags _SelectableNotAttackable_3

See Also

UnitFlags Enumeration
wManager.Wow.Enums Namespace


CanPerformAction_Mask1 Field

UnitFlags..::..CanPerformAction_Mask1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitFlags CanPerformAction_Mask1
Public Const CanPerformAction_Mask1 As UnitFlags
public:
literal UnitFlags CanPerformAction_Mask1

See Also

UnitFlags Enumeration
wManager.Wow.Enums Namespace


Combat Field

UnitFlags..::..Combat Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitFlags Combat
Public Const Combat As UnitFlags
public:
literal UnitFlags Combat

See Also

UnitFlags Enumeration
wManager.Wow.Enums Namespace


Confused Field

UnitFlags..::..Confused Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitFlags Confused
Public Const Confused As UnitFlags
public:
literal UnitFlags Confused

See Also

UnitFlags Enumeration
wManager.Wow.Enums Namespace


Dazed Field

UnitFlags..::..Dazed Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitFlags Dazed
Public Const Dazed As UnitFlags
public:
literal UnitFlags Dazed

See Also

UnitFlags Enumeration
wManager.Wow.Enums Namespace


Disarmed Field

UnitFlags..::..Disarmed Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitFlags Disarmed
Public Const Disarmed As UnitFlags
public:
literal UnitFlags Disarmed

See Also

UnitFlags Enumeration
wManager.Wow.Enums Namespace


Fleeing Field

UnitFlags..::..Fleeing Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitFlags Fleeing
Public Const Fleeing As UnitFlags
public:
literal UnitFlags Fleeing

See Also

UnitFlags Enumeration
wManager.Wow.Enums Namespace


Influenced Field

UnitFlags..::..Influenced Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitFlags Influenced
Public Const Influenced As UnitFlags
public:
literal UnitFlags Influenced

See Also

UnitFlags Enumeration
wManager.Wow.Enums Namespace


Looting Field

UnitFlags..::..Looting Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitFlags Looting
Public Const Looting As UnitFlags
public:
literal UnitFlags Looting

See Also

UnitFlags Enumeration
wManager.Wow.Enums Namespace


Mounted Field

UnitFlags..::..Mounted Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitFlags Mounted
Public Const Mounted As UnitFlags
public:
literal UnitFlags Mounted

See Also

UnitFlags Enumeration
wManager.Wow.Enums Namespace


None Field

UnitFlags..::..None Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitFlags None
Public Const None As UnitFlags
public:
literal UnitFlags None

See Also

UnitFlags Enumeration
wManager.Wow.Enums Namespace


NotAttackable Field

UnitFlags..::..NotAttackable Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitFlags NotAttackable
Public Const NotAttackable As UnitFlags
public:
literal UnitFlags NotAttackable

See Also

UnitFlags Enumeration
wManager.Wow.Enums Namespace


NotSelectable Field

UnitFlags..::..NotSelectable Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitFlags NotSelectable
Public Const NotSelectable As UnitFlags
public:
literal UnitFlags NotSelectable

See Also

UnitFlags Enumeration
wManager.Wow.Enums Namespace


NotSitting Field

UnitFlags..::..NotSitting Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitFlags NotSitting
Public Const NotSitting As UnitFlags
public:
literal UnitFlags NotSitting

See Also

UnitFlags Enumeration
wManager.Wow.Enums Namespace


Pacified Field

UnitFlags..::..Pacified Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitFlags Pacified
Public Const Pacified As UnitFlags
public:
literal UnitFlags Pacified

See Also

UnitFlags Enumeration
wManager.Wow.Enums Namespace


PetInCombat Field

UnitFlags..::..PetInCombat Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitFlags PetInCombat
Public Const PetInCombat As UnitFlags
public:
literal UnitFlags PetInCombat

See Also

UnitFlags Enumeration
wManager.Wow.Enums Namespace


PlayerControlled Field

UnitFlags..::..PlayerControlled Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitFlags PlayerControlled
Public Const PlayerControlled As UnitFlags
public:
literal UnitFlags PlayerControlled

See Also

UnitFlags Enumeration
wManager.Wow.Enums Namespace


PlusMob Field

UnitFlags..::..PlusMob Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitFlags PlusMob
Public Const PlusMob As UnitFlags
public:
literal UnitFlags PlusMob

See Also

UnitFlags Enumeration
wManager.Wow.Enums Namespace


Possessed Field

UnitFlags..::..Possessed Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitFlags Possessed
Public Const Possessed As UnitFlags
public:
literal UnitFlags Possessed

See Also

UnitFlags Enumeration
wManager.Wow.Enums Namespace


Preparation Field

UnitFlags..::..Preparation Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitFlags Preparation
Public Const Preparation As UnitFlags
public:
literal UnitFlags Preparation

See Also

UnitFlags Enumeration
wManager.Wow.Enums Namespace


PvPFlagged Field

UnitFlags..::..PvPFlagged Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitFlags PvPFlagged
Public Const PvPFlagged As UnitFlags
public:
literal UnitFlags PvPFlagged

See Also

UnitFlags Enumeration
wManager.Wow.Enums Namespace


Sheathe Field

UnitFlags..::..Sheathe Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitFlags Sheathe
Public Const Sheathe As UnitFlags
public:
literal UnitFlags Sheathe

See Also

UnitFlags Enumeration
wManager.Wow.Enums Namespace


Silenced Field

UnitFlags..::..Silenced Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitFlags Silenced
Public Const Silenced As UnitFlags
public:
literal UnitFlags Silenced

See Also

UnitFlags Enumeration
wManager.Wow.Enums Namespace


Skinnable Field

UnitFlags..::..Skinnable Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitFlags Skinnable
Public Const Skinnable As UnitFlags
public:
literal UnitFlags Skinnable

See Also

UnitFlags Enumeration
wManager.Wow.Enums Namespace


Stunned Field

UnitFlags..::..Stunned Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitFlags Stunned
Public Const Stunned As UnitFlags
public:
literal UnitFlags Stunned

See Also

UnitFlags Enumeration
wManager.Wow.Enums Namespace


TaxiFlight Field

UnitFlags..::..TaxiFlight Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitFlags TaxiFlight
Public Const TaxiFlight As UnitFlags
public:
literal UnitFlags TaxiFlight

See Also

UnitFlags Enumeration
wManager.Wow.Enums Namespace


Totem Field

UnitFlags..::..Totem Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitFlags Totem
Public Const Totem As UnitFlags
public:
literal UnitFlags Totem

See Also

UnitFlags Enumeration
wManager.Wow.Enums Namespace


Auctioneer Field

UnitNPCFlags..::..Auctioneer Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitNPCFlags Auctioneer
Public Const Auctioneer As UnitNPCFlags
public:
literal UnitNPCFlags Auctioneer

See Also

UnitNPCFlags Enumeration
wManager.Wow.Enums Namespace


Banker Field

UnitNPCFlags..::..Banker Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitNPCFlags Banker
Public Const Banker As UnitNPCFlags
public:
literal UnitNPCFlags Banker

See Also

UnitNPCFlags Enumeration
wManager.Wow.Enums Namespace


Battlemaster Field

UnitNPCFlags..::..Battlemaster Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitNPCFlags Battlemaster
Public Const Battlemaster As UnitNPCFlags
public:
literal UnitNPCFlags Battlemaster

See Also

UnitNPCFlags Enumeration
wManager.Wow.Enums Namespace


BattlePet Field

UnitNPCFlags..::..BattlePet Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitNPCFlags BattlePet
Public Const BattlePet As UnitNPCFlags
public:
literal UnitNPCFlags BattlePet

See Also

UnitNPCFlags Enumeration
wManager.Wow.Enums Namespace


BattlePetTrainer Field

UnitNPCFlags..::..BattlePetTrainer Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitNPCFlags BattlePetTrainer
Public Const BattlePetTrainer As UnitNPCFlags
public:
literal UnitNPCFlags BattlePetTrainer

See Also

UnitNPCFlags Enumeration
wManager.Wow.Enums Namespace


CanRepair Field

UnitNPCFlags..::..CanRepair Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitNPCFlags CanRepair
Public Const CanRepair As UnitNPCFlags
public:
literal UnitNPCFlags CanRepair

See Also

UnitNPCFlags Enumeration
wManager.Wow.Enums Namespace


CanSell Field

UnitNPCFlags..::..CanSell Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitNPCFlags CanSell
Public Const CanSell As UnitNPCFlags
public:
literal UnitNPCFlags CanSell

See Also

UnitNPCFlags Enumeration
wManager.Wow.Enums Namespace


CanTrain Field

UnitNPCFlags..::..CanTrain Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitNPCFlags CanTrain
Public Const CanTrain As UnitNPCFlags
public:
literal UnitNPCFlags CanTrain

See Also

UnitNPCFlags Enumeration
wManager.Wow.Enums Namespace


DailyQuests Field

UnitNPCFlags..::..DailyQuests Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitNPCFlags DailyQuests
Public Const DailyQuests As UnitNPCFlags
public:
literal UnitNPCFlags DailyQuests

See Also

UnitNPCFlags Enumeration
wManager.Wow.Enums Namespace


Flightmaster Field

UnitNPCFlags..::..Flightmaster Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitNPCFlags Flightmaster
Public Const Flightmaster As UnitNPCFlags
public:
literal UnitNPCFlags Flightmaster

See Also

UnitNPCFlags Enumeration
wManager.Wow.Enums Namespace


ForgeMaster Field

UnitNPCFlags..::..ForgeMaster Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitNPCFlags ForgeMaster
Public Const ForgeMaster As UnitNPCFlags
public:
literal UnitNPCFlags ForgeMaster

See Also

UnitNPCFlags Enumeration
wManager.Wow.Enums Namespace


Gossip Field

UnitNPCFlags..::..Gossip Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitNPCFlags Gossip
Public Const Gossip As UnitNPCFlags
public:
literal UnitNPCFlags Gossip

See Also

UnitNPCFlags Enumeration
wManager.Wow.Enums Namespace


GuildBanker Field

UnitNPCFlags..::..GuildBanker Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitNPCFlags GuildBanker
Public Const GuildBanker As UnitNPCFlags
public:
literal UnitNPCFlags GuildBanker

See Also

UnitNPCFlags Enumeration
wManager.Wow.Enums Namespace


Innkeeper Field

UnitNPCFlags..::..Innkeeper Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitNPCFlags Innkeeper
Public Const Innkeeper As UnitNPCFlags
public:
literal UnitNPCFlags Innkeeper

See Also

UnitNPCFlags Enumeration
wManager.Wow.Enums Namespace


MailInfo Field

UnitNPCFlags..::..MailInfo Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitNPCFlags MailInfo
Public Const MailInfo As UnitNPCFlags
public:
literal UnitNPCFlags MailInfo

See Also

UnitNPCFlags Enumeration
wManager.Wow.Enums Namespace


None Field

UnitNPCFlags..::..None Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitNPCFlags None
Public Const None As UnitNPCFlags
public:
literal UnitNPCFlags None

See Also

UnitNPCFlags Enumeration
wManager.Wow.Enums Namespace


Petitioner Field

UnitNPCFlags..::..Petitioner Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitNPCFlags Petitioner
Public Const Petitioner As UnitNPCFlags
public:
literal UnitNPCFlags Petitioner

See Also

UnitNPCFlags Enumeration
wManager.Wow.Enums Namespace


Questgiver Field

UnitNPCFlags..::..Questgiver Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitNPCFlags Questgiver
Public Const Questgiver As UnitNPCFlags
public:
literal UnitNPCFlags Questgiver

See Also

UnitNPCFlags Enumeration
wManager.Wow.Enums Namespace


SellsAmmo Field

UnitNPCFlags..::..SellsAmmo Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitNPCFlags SellsAmmo
Public Const SellsAmmo As UnitNPCFlags
public:
literal UnitNPCFlags SellsAmmo

See Also

UnitNPCFlags Enumeration
wManager.Wow.Enums Namespace


SellsFood Field

UnitNPCFlags..::..SellsFood Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitNPCFlags SellsFood
Public Const SellsFood As UnitNPCFlags
public:
literal UnitNPCFlags SellsFood

See Also

UnitNPCFlags Enumeration
wManager.Wow.Enums Namespace


SellsReagents Field

UnitNPCFlags..::..SellsReagents Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitNPCFlags SellsReagents
Public Const SellsReagents As UnitNPCFlags
public:
literal UnitNPCFlags SellsReagents

See Also

UnitNPCFlags Enumeration
wManager.Wow.Enums Namespace


SPELLCLICK Field

UnitNPCFlags..::..SPELLCLICK Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitNPCFlags SPELLCLICK
Public Const SPELLCLICK As UnitNPCFlags
public:
literal UnitNPCFlags SPELLCLICK

See Also

UnitNPCFlags Enumeration
wManager.Wow.Enums Namespace


Spiritguide Field

UnitNPCFlags..::..Spiritguide Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitNPCFlags Spiritguide
Public Const Spiritguide As UnitNPCFlags
public:
literal UnitNPCFlags Spiritguide

See Also

UnitNPCFlags Enumeration
wManager.Wow.Enums Namespace


Spirithealer Field

UnitNPCFlags..::..Spirithealer Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitNPCFlags Spirithealer
Public Const Spirithealer As UnitNPCFlags
public:
literal UnitNPCFlags Spirithealer

See Also

UnitNPCFlags Enumeration
wManager.Wow.Enums Namespace


Stablemaster Field

UnitNPCFlags..::..Stablemaster Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitNPCFlags Stablemaster
Public Const Stablemaster As UnitNPCFlags
public:
literal UnitNPCFlags Stablemaster

See Also

UnitNPCFlags Enumeration
wManager.Wow.Enums Namespace


Tabarddesigner Field

UnitNPCFlags..::..Tabarddesigner Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitNPCFlags Tabarddesigner
Public Const Tabarddesigner As UnitNPCFlags
public:
literal UnitNPCFlags Tabarddesigner

See Also

UnitNPCFlags Enumeration
wManager.Wow.Enums Namespace


Transmogrifier Field

UnitNPCFlags..::..Transmogrifier Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitNPCFlags Transmogrifier
Public Const Transmogrifier As UnitNPCFlags
public:
literal UnitNPCFlags Transmogrifier

See Also

UnitNPCFlags Enumeration
wManager.Wow.Enums Namespace


UNK1 Field

UnitNPCFlags..::..UNK1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitNPCFlags UNK1
Public Const UNK1 As UnitNPCFlags
public:
literal UnitNPCFlags UNK1

See Also

UnitNPCFlags Enumeration
wManager.Wow.Enums Namespace


UNK2 Field

UnitNPCFlags..::..UNK2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitNPCFlags UNK2
Public Const UNK2 As UnitNPCFlags
public:
literal UnitNPCFlags UNK2

See Also

UnitNPCFlags Enumeration
wManager.Wow.Enums Namespace


VENDOR_POISON Field

UnitNPCFlags..::..VENDOR_POISON Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitNPCFlags VENDOR_POISON
Public Const VENDOR_POISON As UnitNPCFlags
public:
literal UnitNPCFlags VENDOR_POISON

See Also

UnitNPCFlags Enumeration
wManager.Wow.Enums Namespace


VoidStorageBanker Field

UnitNPCFlags..::..VoidStorageBanker Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitNPCFlags VoidStorageBanker
Public Const VoidStorageBanker As UnitNPCFlags
public:
literal UnitNPCFlags VoidStorageBanker

See Also

UnitNPCFlags Enumeration
wManager.Wow.Enums Namespace


DeathKnight Field

WoWClass..::..DeathKnight Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWClass DeathKnight
Public Const DeathKnight As WoWClass
public:
literal WoWClass DeathKnight

See Also

WoWClass Enumeration
wManager.Wow.Enums Namespace


DemonHunter Field

WoWClass..::..DemonHunter Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWClass DemonHunter
Public Const DemonHunter As WoWClass
public:
literal WoWClass DemonHunter

See Also

WoWClass Enumeration
wManager.Wow.Enums Namespace


Druid Field

WoWClass..::..Druid Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWClass Druid
Public Const Druid As WoWClass
public:
literal WoWClass Druid

See Also

WoWClass Enumeration
wManager.Wow.Enums Namespace


Hunter Field

WoWClass..::..Hunter Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWClass Hunter
Public Const Hunter As WoWClass
public:
literal WoWClass Hunter

See Also

WoWClass Enumeration
wManager.Wow.Enums Namespace


Mage Field

WoWClass..::..Mage Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWClass Mage
Public Const Mage As WoWClass
public:
literal WoWClass Mage

See Also

WoWClass Enumeration
wManager.Wow.Enums Namespace


Monk Field

WoWClass..::..Monk Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWClass Monk
Public Const Monk As WoWClass
public:
literal WoWClass Monk

See Also

WoWClass Enumeration
wManager.Wow.Enums Namespace


None Field

WoWClass..::..None Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWClass None
Public Const None As WoWClass
public:
literal WoWClass None

See Also

WoWClass Enumeration
wManager.Wow.Enums Namespace


Paladin Field

WoWClass..::..Paladin Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWClass Paladin
Public Const Paladin As WoWClass
public:
literal WoWClass Paladin

See Also

WoWClass Enumeration
wManager.Wow.Enums Namespace


Priest Field

WoWClass..::..Priest Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWClass Priest
Public Const Priest As WoWClass
public:
literal WoWClass Priest

See Also

WoWClass Enumeration
wManager.Wow.Enums Namespace


Rogue Field

WoWClass..::..Rogue Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWClass Rogue
Public Const Rogue As WoWClass
public:
literal WoWClass Rogue

See Also

WoWClass Enumeration
wManager.Wow.Enums Namespace


Shaman Field

WoWClass..::..Shaman Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWClass Shaman
Public Const Shaman As WoWClass
public:
literal WoWClass Shaman

See Also

WoWClass Enumeration
wManager.Wow.Enums Namespace


Warlock Field

WoWClass..::..Warlock Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWClass Warlock
Public Const Warlock As WoWClass
public:
literal WoWClass Warlock

See Also

WoWClass Enumeration
wManager.Wow.Enums Namespace


Warrior Field

WoWClass..::..Warrior Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWClass Warrior
Public Const Warrior As WoWClass
public:
literal WoWClass Warrior

See Also

WoWClass Enumeration
wManager.Wow.Enums Namespace


LOCK_KEY_ITEM Field

WoWGameObjectLockKeyType..::..LOCK_KEY_ITEM Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectLockKeyType LOCK_KEY_ITEM
Public Const LOCK_KEY_ITEM As WoWGameObjectLockKeyType
public:
literal WoWGameObjectLockKeyType LOCK_KEY_ITEM

See Also

WoWGameObjectLockKeyType Enumeration
wManager.Wow.Enums Namespace


LOCK_KEY_NONE Field

WoWGameObjectLockKeyType..::..LOCK_KEY_NONE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectLockKeyType LOCK_KEY_NONE
Public Const LOCK_KEY_NONE As WoWGameObjectLockKeyType
public:
literal WoWGameObjectLockKeyType LOCK_KEY_NONE

See Also

WoWGameObjectLockKeyType Enumeration
wManager.Wow.Enums Namespace


LOCK_KEY_SKILL Field

WoWGameObjectLockKeyType..::..LOCK_KEY_SKILL Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectLockKeyType LOCK_KEY_SKILL
Public Const LOCK_KEY_SKILL As WoWGameObjectLockKeyType
public:
literal WoWGameObjectLockKeyType LOCK_KEY_SKILL

See Also

WoWGameObjectLockKeyType Enumeration
wManager.Wow.Enums Namespace


LOCK_KEY_UNKNOWN Field

WoWGameObjectLockKeyType..::..LOCK_KEY_UNKNOWN Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectLockKeyType LOCK_KEY_UNKNOWN
Public Const LOCK_KEY_UNKNOWN As WoWGameObjectLockKeyType
public:
literal WoWGameObjectLockKeyType LOCK_KEY_UNKNOWN

See Also

WoWGameObjectLockKeyType Enumeration
wManager.Wow.Enums Namespace


LOCKTYPE_ARCHAEOLOGY Field

WoWGameObjectLockType..::..LOCKTYPE_ARCHAEOLOGY Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectLockType LOCKTYPE_ARCHAEOLOGY
Public Const LOCKTYPE_ARCHAEOLOGY As WoWGameObjectLockType
public:
literal WoWGameObjectLockType LOCKTYPE_ARCHAEOLOGY

See Also

WoWGameObjectLockType Enumeration
wManager.Wow.Enums Namespace


LOCKTYPE_ARM_TRAP Field

WoWGameObjectLockType..::..LOCKTYPE_ARM_TRAP Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectLockType LOCKTYPE_ARM_TRAP
Public Const LOCKTYPE_ARM_TRAP As WoWGameObjectLockType
public:
literal WoWGameObjectLockType LOCKTYPE_ARM_TRAP

See Also

WoWGameObjectLockType Enumeration
wManager.Wow.Enums Namespace


LOCKTYPE_BLASTING Field

WoWGameObjectLockType..::..LOCKTYPE_BLASTING Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectLockType LOCKTYPE_BLASTING
Public Const LOCKTYPE_BLASTING As WoWGameObjectLockType
public:
literal WoWGameObjectLockType LOCKTYPE_BLASTING

See Also

WoWGameObjectLockType Enumeration
wManager.Wow.Enums Namespace


LOCKTYPE_CALCIFIED_ELVEN_GEMS Field

WoWGameObjectLockType..::..LOCKTYPE_CALCIFIED_ELVEN_GEMS Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectLockType LOCKTYPE_CALCIFIED_ELVEN_GEMS
Public Const LOCKTYPE_CALCIFIED_ELVEN_GEMS As WoWGameObjectLockType
public:
literal WoWGameObjectLockType LOCKTYPE_CALCIFIED_ELVEN_GEMS

See Also

WoWGameObjectLockType Enumeration
wManager.Wow.Enums Namespace


LOCKTYPE_CLOSE Field

WoWGameObjectLockType..::..LOCKTYPE_CLOSE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectLockType LOCKTYPE_CLOSE
Public Const LOCKTYPE_CLOSE As WoWGameObjectLockType
public:
literal WoWGameObjectLockType LOCKTYPE_CLOSE

See Also

WoWGameObjectLockType Enumeration
wManager.Wow.Enums Namespace


LOCKTYPE_DISARM_TRAP Field

WoWGameObjectLockType..::..LOCKTYPE_DISARM_TRAP Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectLockType LOCKTYPE_DISARM_TRAP
Public Const LOCKTYPE_DISARM_TRAP As WoWGameObjectLockType
public:
literal WoWGameObjectLockType LOCKTYPE_DISARM_TRAP

See Also

WoWGameObjectLockType Enumeration
wManager.Wow.Enums Namespace


LOCKTYPE_EXTRACT Field

WoWGameObjectLockType..::..LOCKTYPE_EXTRACT Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectLockType LOCKTYPE_EXTRACT
Public Const LOCKTYPE_EXTRACT As WoWGameObjectLockType
public:
literal WoWGameObjectLockType LOCKTYPE_EXTRACT

See Also

WoWGameObjectLockType Enumeration
wManager.Wow.Enums Namespace


LOCKTYPE_FISHING Field

WoWGameObjectLockType..::..LOCKTYPE_FISHING Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectLockType LOCKTYPE_FISHING
Public Const LOCKTYPE_FISHING As WoWGameObjectLockType
public:
literal WoWGameObjectLockType LOCKTYPE_FISHING

See Also

WoWGameObjectLockType Enumeration
wManager.Wow.Enums Namespace


LOCKTYPE_GAHZRIDIAN Field

WoWGameObjectLockType..::..LOCKTYPE_GAHZRIDIAN Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectLockType LOCKTYPE_GAHZRIDIAN
Public Const LOCKTYPE_GAHZRIDIAN As WoWGameObjectLockType
public:
literal WoWGameObjectLockType LOCKTYPE_GAHZRIDIAN

See Also

WoWGameObjectLockType Enumeration
wManager.Wow.Enums Namespace


LOCKTYPE_HERBALISM Field

WoWGameObjectLockType..::..LOCKTYPE_HERBALISM Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectLockType LOCKTYPE_HERBALISM
Public Const LOCKTYPE_HERBALISM As WoWGameObjectLockType
public:
literal WoWGameObjectLockType LOCKTYPE_HERBALISM

See Also

WoWGameObjectLockType Enumeration
wManager.Wow.Enums Namespace


LOCKTYPE_INSCRIPTION Field

WoWGameObjectLockType..::..LOCKTYPE_INSCRIPTION Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectLockType LOCKTYPE_INSCRIPTION
Public Const LOCKTYPE_INSCRIPTION As WoWGameObjectLockType
public:
literal WoWGameObjectLockType LOCKTYPE_INSCRIPTION

See Also

WoWGameObjectLockType Enumeration
wManager.Wow.Enums Namespace


LOCKTYPE_MINING Field

WoWGameObjectLockType..::..LOCKTYPE_MINING Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectLockType LOCKTYPE_MINING
Public Const LOCKTYPE_MINING As WoWGameObjectLockType
public:
literal WoWGameObjectLockType LOCKTYPE_MINING

See Also

WoWGameObjectLockType Enumeration
wManager.Wow.Enums Namespace


LOCKTYPE_OPEN Field

WoWGameObjectLockType..::..LOCKTYPE_OPEN Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectLockType LOCKTYPE_OPEN
Public Const LOCKTYPE_OPEN As WoWGameObjectLockType
public:
literal WoWGameObjectLockType LOCKTYPE_OPEN

See Also

WoWGameObjectLockType Enumeration
wManager.Wow.Enums Namespace


LOCKTYPE_OPEN_ATTACKING Field

WoWGameObjectLockType..::..LOCKTYPE_OPEN_ATTACKING Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectLockType LOCKTYPE_OPEN_ATTACKING
Public Const LOCKTYPE_OPEN_ATTACKING As WoWGameObjectLockType
public:
literal WoWGameObjectLockType LOCKTYPE_OPEN_ATTACKING

See Also

WoWGameObjectLockType Enumeration
wManager.Wow.Enums Namespace


LOCKTYPE_OPEN_FROM_VEHICLE Field

WoWGameObjectLockType..::..LOCKTYPE_OPEN_FROM_VEHICLE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectLockType LOCKTYPE_OPEN_FROM_VEHICLE
Public Const LOCKTYPE_OPEN_FROM_VEHICLE As WoWGameObjectLockType
public:
literal WoWGameObjectLockType LOCKTYPE_OPEN_FROM_VEHICLE

See Also

WoWGameObjectLockType Enumeration
wManager.Wow.Enums Namespace


LOCKTYPE_OPEN_KNEELING Field

WoWGameObjectLockType..::..LOCKTYPE_OPEN_KNEELING Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectLockType LOCKTYPE_OPEN_KNEELING
Public Const LOCKTYPE_OPEN_KNEELING As WoWGameObjectLockType
public:
literal WoWGameObjectLockType LOCKTYPE_OPEN_KNEELING

See Also

WoWGameObjectLockType Enumeration
wManager.Wow.Enums Namespace


LOCKTYPE_OPEN_TINKERING Field

WoWGameObjectLockType..::..LOCKTYPE_OPEN_TINKERING Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectLockType LOCKTYPE_OPEN_TINKERING
Public Const LOCKTYPE_OPEN_TINKERING As WoWGameObjectLockType
public:
literal WoWGameObjectLockType LOCKTYPE_OPEN_TINKERING

See Also

WoWGameObjectLockType Enumeration
wManager.Wow.Enums Namespace


LOCKTYPE_PICKLOCK Field

WoWGameObjectLockType..::..LOCKTYPE_PICKLOCK Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectLockType LOCKTYPE_PICKLOCK
Public Const LOCKTYPE_PICKLOCK As WoWGameObjectLockType
public:
literal WoWGameObjectLockType LOCKTYPE_PICKLOCK

See Also

WoWGameObjectLockType Enumeration
wManager.Wow.Enums Namespace


LOCKTYPE_PVP Field

WoWGameObjectLockType..::..LOCKTYPE_PVP Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectLockType LOCKTYPE_PVP
Public Const LOCKTYPE_PVP As WoWGameObjectLockType
public:
literal WoWGameObjectLockType LOCKTYPE_PVP

See Also

WoWGameObjectLockType Enumeration
wManager.Wow.Enums Namespace


LOCKTYPE_QUICK_CLOSE Field

WoWGameObjectLockType..::..LOCKTYPE_QUICK_CLOSE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectLockType LOCKTYPE_QUICK_CLOSE
Public Const LOCKTYPE_QUICK_CLOSE As WoWGameObjectLockType
public:
literal WoWGameObjectLockType LOCKTYPE_QUICK_CLOSE

See Also

WoWGameObjectLockType Enumeration
wManager.Wow.Enums Namespace


LOCKTYPE_QUICK_OPEN Field

WoWGameObjectLockType..::..LOCKTYPE_QUICK_OPEN Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectLockType LOCKTYPE_QUICK_OPEN
Public Const LOCKTYPE_QUICK_OPEN As WoWGameObjectLockType
public:
literal WoWGameObjectLockType LOCKTYPE_QUICK_OPEN

See Also

WoWGameObjectLockType Enumeration
wManager.Wow.Enums Namespace


LOCKTYPE_SKIN Field

WoWGameObjectLockType..::..LOCKTYPE_SKIN Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectLockType LOCKTYPE_SKIN
Public Const LOCKTYPE_SKIN As WoWGameObjectLockType
public:
literal WoWGameObjectLockType LOCKTYPE_SKIN

See Also

WoWGameObjectLockType Enumeration
wManager.Wow.Enums Namespace


LOCKTYPE_SLOW_CLOSE Field

WoWGameObjectLockType..::..LOCKTYPE_SLOW_CLOSE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectLockType LOCKTYPE_SLOW_CLOSE
Public Const LOCKTYPE_SLOW_CLOSE As WoWGameObjectLockType
public:
literal WoWGameObjectLockType LOCKTYPE_SLOW_CLOSE

See Also

WoWGameObjectLockType Enumeration
wManager.Wow.Enums Namespace


LOCKTYPE_SLOW_OPEN Field

WoWGameObjectLockType..::..LOCKTYPE_SLOW_OPEN Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectLockType LOCKTYPE_SLOW_OPEN
Public Const LOCKTYPE_SLOW_OPEN As WoWGameObjectLockType
public:
literal WoWGameObjectLockType LOCKTYPE_SLOW_OPEN

See Also

WoWGameObjectLockType Enumeration
wManager.Wow.Enums Namespace


LOCKTYPE_TIMBER Field

WoWGameObjectLockType..::..LOCKTYPE_TIMBER Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectLockType LOCKTYPE_TIMBER
Public Const LOCKTYPE_TIMBER As WoWGameObjectLockType
public:
literal WoWGameObjectLockType LOCKTYPE_TIMBER

See Also

WoWGameObjectLockType Enumeration
wManager.Wow.Enums Namespace


LOCKTYPE_TREASURE Field

WoWGameObjectLockType..::..LOCKTYPE_TREASURE Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectLockType LOCKTYPE_TREASURE
Public Const LOCKTYPE_TREASURE As WoWGameObjectLockType
public:
literal WoWGameObjectLockType LOCKTYPE_TREASURE

See Also

WoWGameObjectLockType Enumeration
wManager.Wow.Enums Namespace


AreaDamage Field

WoWGameObjectType..::..AreaDamage Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectType AreaDamage
Public Const AreaDamage As WoWGameObjectType
public:
literal WoWGameObjectType AreaDamage

See Also

WoWGameObjectType Enumeration
wManager.Wow.Enums Namespace


AuctionHouse Field

WoWGameObjectType..::..AuctionHouse Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectType AuctionHouse
Public Const AuctionHouse As WoWGameObjectType
public:
literal WoWGameObjectType AuctionHouse

See Also

WoWGameObjectType Enumeration
wManager.Wow.Enums Namespace


AuraGenerator Field

WoWGameObjectType..::..AuraGenerator Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectType AuraGenerator
Public Const AuraGenerator As WoWGameObjectType
public:
literal WoWGameObjectType AuraGenerator

See Also

WoWGameObjectType Enumeration
wManager.Wow.Enums Namespace


Binder Field

WoWGameObjectType..::..Binder Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectType Binder
Public Const Binder As WoWGameObjectType
public:
literal WoWGameObjectType Binder

See Also

WoWGameObjectType Enumeration
wManager.Wow.Enums Namespace


Button Field

WoWGameObjectType..::..Button Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectType Button
Public Const Button As WoWGameObjectType
public:
literal WoWGameObjectType Button

See Also

WoWGameObjectType Enumeration
wManager.Wow.Enums Namespace


Camera Field

WoWGameObjectType..::..Camera Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectType Camera
Public Const Camera As WoWGameObjectType
public:
literal WoWGameObjectType Camera

See Also

WoWGameObjectType Enumeration
wManager.Wow.Enums Namespace


CapturePoint Field

WoWGameObjectType..::..CapturePoint Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectType CapturePoint
Public Const CapturePoint As WoWGameObjectType
public:
literal WoWGameObjectType CapturePoint

See Also

WoWGameObjectType Enumeration
wManager.Wow.Enums Namespace


Chair Field

WoWGameObjectType..::..Chair Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectType Chair
Public Const Chair As WoWGameObjectType
public:
literal WoWGameObjectType Chair

See Also

WoWGameObjectType Enumeration
wManager.Wow.Enums Namespace


Chest Field

WoWGameObjectType..::..Chest Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectType Chest
Public Const Chest As WoWGameObjectType
public:
literal WoWGameObjectType Chest

See Also

WoWGameObjectType Enumeration
wManager.Wow.Enums Namespace


DestructiveBuilding Field

WoWGameObjectType..::..DestructiveBuilding Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectType DestructiveBuilding
Public Const DestructiveBuilding As WoWGameObjectType
public:
literal WoWGameObjectType DestructiveBuilding

See Also

WoWGameObjectType Enumeration
wManager.Wow.Enums Namespace


Door Field

WoWGameObjectType..::..Door Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectType Door
Public Const Door As WoWGameObjectType
public:
literal WoWGameObjectType Door

See Also

WoWGameObjectType Enumeration
wManager.Wow.Enums Namespace


DuelArbiter Field

WoWGameObjectType..::..DuelArbiter Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectType DuelArbiter
Public Const DuelArbiter As WoWGameObjectType
public:
literal WoWGameObjectType DuelArbiter

See Also

WoWGameObjectType Enumeration
wManager.Wow.Enums Namespace


DungeonDifficulty Field

WoWGameObjectType..::..DungeonDifficulty Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectType DungeonDifficulty
Public Const DungeonDifficulty As WoWGameObjectType
public:
literal WoWGameObjectType DungeonDifficulty

See Also

WoWGameObjectType Enumeration
wManager.Wow.Enums Namespace


FishingHole Field

WoWGameObjectType..::..FishingHole Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectType FishingHole
Public Const FishingHole As WoWGameObjectType
public:
literal WoWGameObjectType FishingHole

See Also

WoWGameObjectType Enumeration
wManager.Wow.Enums Namespace


FishingNode Field

WoWGameObjectType..::..FishingNode Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectType FishingNode
Public Const FishingNode As WoWGameObjectType
public:
literal WoWGameObjectType FishingNode

See Also

WoWGameObjectType Enumeration
wManager.Wow.Enums Namespace


FlagAlliance Field

WoWGameObjectType..::..FlagAlliance Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectType FlagAlliance
Public Const FlagAlliance As WoWGameObjectType
public:
literal WoWGameObjectType FlagAlliance

See Also

WoWGameObjectType Enumeration
wManager.Wow.Enums Namespace


FlagDrop Field

WoWGameObjectType..::..FlagDrop Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectType FlagDrop
Public Const FlagDrop As WoWGameObjectType
public:
literal WoWGameObjectType FlagDrop

See Also

WoWGameObjectType Enumeration
wManager.Wow.Enums Namespace


FlagHorde Field

WoWGameObjectType..::..FlagHorde Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectType FlagHorde
Public Const FlagHorde As WoWGameObjectType
public:
literal WoWGameObjectType FlagHorde

See Also

WoWGameObjectType Enumeration
wManager.Wow.Enums Namespace


FlagStand Field

WoWGameObjectType..::..FlagStand Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectType FlagStand
Public Const FlagStand As WoWGameObjectType
public:
literal WoWGameObjectType FlagStand

See Also

WoWGameObjectType Enumeration
wManager.Wow.Enums Namespace


Generic Field

WoWGameObjectType..::..Generic Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectType Generic
Public Const Generic As WoWGameObjectType
public:
literal WoWGameObjectType Generic

See Also

WoWGameObjectType Enumeration
wManager.Wow.Enums Namespace


Goober Field

WoWGameObjectType..::..Goober Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectType Goober
Public Const Goober As WoWGameObjectType
public:
literal WoWGameObjectType Goober

See Also

WoWGameObjectType Enumeration
wManager.Wow.Enums Namespace


GuardPost Field

WoWGameObjectType..::..GuardPost Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectType GuardPost
Public Const GuardPost As WoWGameObjectType
public:
literal WoWGameObjectType GuardPost

See Also

WoWGameObjectType Enumeration
wManager.Wow.Enums Namespace


GuildBank Field

WoWGameObjectType..::..GuildBank Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectType GuildBank
Public Const GuildBank As WoWGameObjectType
public:
literal WoWGameObjectType GuildBank

See Also

WoWGameObjectType Enumeration
wManager.Wow.Enums Namespace


LotteryKiosk Field

WoWGameObjectType..::..LotteryKiosk Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectType LotteryKiosk
Public Const LotteryKiosk As WoWGameObjectType
public:
literal WoWGameObjectType LotteryKiosk

See Also

WoWGameObjectType Enumeration
wManager.Wow.Enums Namespace


Mailbox Field

WoWGameObjectType..::..Mailbox Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectType Mailbox
Public Const Mailbox As WoWGameObjectType
public:
literal WoWGameObjectType Mailbox

See Also

WoWGameObjectType Enumeration
wManager.Wow.Enums Namespace


MapObject Field

WoWGameObjectType..::..MapObject Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectType MapObject
Public Const MapObject As WoWGameObjectType
public:
literal WoWGameObjectType MapObject

See Also

WoWGameObjectType Enumeration
wManager.Wow.Enums Namespace


MeetingStone Field

WoWGameObjectType..::..MeetingStone Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectType MeetingStone
Public Const MeetingStone As WoWGameObjectType
public:
literal WoWGameObjectType MeetingStone

See Also

WoWGameObjectType Enumeration
wManager.Wow.Enums Namespace


MiniGame Field

WoWGameObjectType..::..MiniGame Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectType MiniGame
Public Const MiniGame As WoWGameObjectType
public:
literal WoWGameObjectType MiniGame

See Also

WoWGameObjectType Enumeration
wManager.Wow.Enums Namespace


MoTransport Field

WoWGameObjectType..::..MoTransport Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectType MoTransport
Public Const MoTransport As WoWGameObjectType
public:
literal WoWGameObjectType MoTransport

See Also

WoWGameObjectType Enumeration
wManager.Wow.Enums Namespace


Questgiver Field

WoWGameObjectType..::..Questgiver Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectType Questgiver
Public Const Questgiver As WoWGameObjectType
public:
literal WoWGameObjectType Questgiver

See Also

WoWGameObjectType Enumeration
wManager.Wow.Enums Namespace


Ritual Field

WoWGameObjectType..::..Ritual Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectType Ritual
Public Const Ritual As WoWGameObjectType
public:
literal WoWGameObjectType Ritual

See Also

WoWGameObjectType Enumeration
wManager.Wow.Enums Namespace


SpellCaster Field

WoWGameObjectType..::..SpellCaster Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectType SpellCaster
Public Const SpellCaster As WoWGameObjectType
public:
literal WoWGameObjectType SpellCaster

See Also

WoWGameObjectType Enumeration
wManager.Wow.Enums Namespace


SpellFocus Field

WoWGameObjectType..::..SpellFocus Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectType SpellFocus
Public Const SpellFocus As WoWGameObjectType
public:
literal WoWGameObjectType SpellFocus

See Also

WoWGameObjectType Enumeration
wManager.Wow.Enums Namespace


Text Field

WoWGameObjectType..::..Text Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectType Text
Public Const Text As WoWGameObjectType
public:
literal WoWGameObjectType Text

See Also

WoWGameObjectType Enumeration
wManager.Wow.Enums Namespace


Transport Field

WoWGameObjectType..::..Transport Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectType Transport
Public Const Transport As WoWGameObjectType
public:
literal WoWGameObjectType Transport

See Also

WoWGameObjectType Enumeration
wManager.Wow.Enums Namespace


Trap Field

WoWGameObjectType..::..Trap Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectType Trap
Public Const Trap As WoWGameObjectType
public:
literal WoWGameObjectType Trap

See Also

WoWGameObjectType Enumeration
wManager.Wow.Enums Namespace


TrapDoor Field

WoWGameObjectType..::..TrapDoor Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGameObjectType TrapDoor
Public Const TrapDoor As WoWGameObjectType
public:
literal WoWGameObjectType TrapDoor

See Also

WoWGameObjectType Enumeration
wManager.Wow.Enums Namespace


Female Field

WoWGender..::..Female Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGender Female
Public Const Female As WoWGender
public:
literal WoWGender Female

See Also

WoWGender Enumeration
wManager.Wow.Enums Namespace


Male Field

WoWGender..::..Male Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGender Male
Public Const Male As WoWGender
public:
literal WoWGender Male

See Also

WoWGender Enumeration
wManager.Wow.Enums Namespace


None Field

WoWGender..::..None Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWGender None
Public Const None As WoWGender
public:
literal WoWGender None

See Also

WoWGender Enumeration
wManager.Wow.Enums Namespace


Ammo Field

WoWInventorySlot..::..Ammo Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWInventorySlot Ammo
Public Const Ammo As WoWInventorySlot
public:
literal WoWInventorySlot Ammo

See Also

WoWInventorySlot Enumeration
wManager.Wow.Enums Namespace


Back Field

WoWInventorySlot..::..Back Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWInventorySlot Back
Public Const Back As WoWInventorySlot
public:
literal WoWInventorySlot Back

See Also

WoWInventorySlot Enumeration
wManager.Wow.Enums Namespace


Bag1 Field

WoWInventorySlot..::..Bag1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWInventorySlot Bag1
Public Const Bag1 As WoWInventorySlot
public:
literal WoWInventorySlot Bag1

See Also

WoWInventorySlot Enumeration
wManager.Wow.Enums Namespace


Bag2 Field

WoWInventorySlot..::..Bag2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWInventorySlot Bag2
Public Const Bag2 As WoWInventorySlot
public:
literal WoWInventorySlot Bag2

See Also

WoWInventorySlot Enumeration
wManager.Wow.Enums Namespace


Bag3 Field

WoWInventorySlot..::..Bag3 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWInventorySlot Bag3
Public Const Bag3 As WoWInventorySlot
public:
literal WoWInventorySlot Bag3

See Also

WoWInventorySlot Enumeration
wManager.Wow.Enums Namespace


Bag4 Field

WoWInventorySlot..::..Bag4 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWInventorySlot Bag4
Public Const Bag4 As WoWInventorySlot
public:
literal WoWInventorySlot Bag4

See Also

WoWInventorySlot Enumeration
wManager.Wow.Enums Namespace


Chest Field

WoWInventorySlot..::..Chest Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWInventorySlot Chest
Public Const Chest As WoWInventorySlot
public:
literal WoWInventorySlot Chest

See Also

WoWInventorySlot Enumeration
wManager.Wow.Enums Namespace


Feet Field

WoWInventorySlot..::..Feet Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWInventorySlot Feet
Public Const Feet As WoWInventorySlot
public:
literal WoWInventorySlot Feet

See Also

WoWInventorySlot Enumeration
wManager.Wow.Enums Namespace


Finger1 Field

WoWInventorySlot..::..Finger1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWInventorySlot Finger1
Public Const Finger1 As WoWInventorySlot
public:
literal WoWInventorySlot Finger1

See Also

WoWInventorySlot Enumeration
wManager.Wow.Enums Namespace


Finger2 Field

WoWInventorySlot..::..Finger2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWInventorySlot Finger2
Public Const Finger2 As WoWInventorySlot
public:
literal WoWInventorySlot Finger2

See Also

WoWInventorySlot Enumeration
wManager.Wow.Enums Namespace


Hands Field

WoWInventorySlot..::..Hands Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWInventorySlot Hands
Public Const Hands As WoWInventorySlot
public:
literal WoWInventorySlot Hands

See Also

WoWInventorySlot Enumeration
wManager.Wow.Enums Namespace


Head Field

WoWInventorySlot..::..Head Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWInventorySlot Head
Public Const Head As WoWInventorySlot
public:
literal WoWInventorySlot Head

See Also

WoWInventorySlot Enumeration
wManager.Wow.Enums Namespace


Legs Field

WoWInventorySlot..::..Legs Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWInventorySlot Legs
Public Const Legs As WoWInventorySlot
public:
literal WoWInventorySlot Legs

See Also

WoWInventorySlot Enumeration
wManager.Wow.Enums Namespace


MainHand Field

WoWInventorySlot..::..MainHand Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWInventorySlot MainHand
Public Const MainHand As WoWInventorySlot
public:
literal WoWInventorySlot MainHand

See Also

WoWInventorySlot Enumeration
wManager.Wow.Enums Namespace


Neck Field

WoWInventorySlot..::..Neck Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWInventorySlot Neck
Public Const Neck As WoWInventorySlot
public:
literal WoWInventorySlot Neck

See Also

WoWInventorySlot Enumeration
wManager.Wow.Enums Namespace


OffHand Field

WoWInventorySlot..::..OffHand Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWInventorySlot OffHand
Public Const OffHand As WoWInventorySlot
public:
literal WoWInventorySlot OffHand

See Also

WoWInventorySlot Enumeration
wManager.Wow.Enums Namespace


Ranged Field

WoWInventorySlot..::..Ranged Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWInventorySlot Ranged
Public Const Ranged As WoWInventorySlot
public:
literal WoWInventorySlot Ranged

See Also

WoWInventorySlot Enumeration
wManager.Wow.Enums Namespace


Shirt Field

WoWInventorySlot..::..Shirt Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWInventorySlot Shirt
Public Const Shirt As WoWInventorySlot
public:
literal WoWInventorySlot Shirt

See Also

WoWInventorySlot Enumeration
wManager.Wow.Enums Namespace


Shoulder Field

WoWInventorySlot..::..Shoulder Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWInventorySlot Shoulder
Public Const Shoulder As WoWInventorySlot
public:
literal WoWInventorySlot Shoulder

See Also

WoWInventorySlot Enumeration
wManager.Wow.Enums Namespace


Tabard Field

WoWInventorySlot..::..Tabard Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWInventorySlot Tabard
Public Const Tabard As WoWInventorySlot
public:
literal WoWInventorySlot Tabard

See Also

WoWInventorySlot Enumeration
wManager.Wow.Enums Namespace


Trinket1 Field

WoWInventorySlot..::..Trinket1 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWInventorySlot Trinket1
Public Const Trinket1 As WoWInventorySlot
public:
literal WoWInventorySlot Trinket1

See Also

WoWInventorySlot Enumeration
wManager.Wow.Enums Namespace


Trinket2 Field

WoWInventorySlot..::..Trinket2 Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWInventorySlot Trinket2
Public Const Trinket2 As WoWInventorySlot
public:
literal WoWInventorySlot Trinket2

See Also

WoWInventorySlot Enumeration
wManager.Wow.Enums Namespace


Waist Field

WoWInventorySlot..::..Waist Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWInventorySlot Waist
Public Const Waist As WoWInventorySlot
public:
literal WoWInventorySlot Waist

See Also

WoWInventorySlot Enumeration
wManager.Wow.Enums Namespace


Wrist Field

WoWInventorySlot..::..Wrist Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWInventorySlot Wrist
Public Const Wrist As WoWInventorySlot
public:
literal WoWInventorySlot Wrist

See Also

WoWInventorySlot Enumeration
wManager.Wow.Enums Namespace


Artifact Field

WoWItemQuality..::..Artifact Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWItemQuality Artifact
Public Const Artifact As WoWItemQuality
public:
literal WoWItemQuality Artifact

See Also

WoWItemQuality Enumeration
wManager.Wow.Enums Namespace


Common Field

WoWItemQuality..::..Common Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWItemQuality Common
Public Const Common As WoWItemQuality
public:
literal WoWItemQuality Common

See Also

WoWItemQuality Enumeration
wManager.Wow.Enums Namespace


Epic Field

WoWItemQuality..::..Epic Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWItemQuality Epic
Public Const Epic As WoWItemQuality
public:
literal WoWItemQuality Epic

See Also

WoWItemQuality Enumeration
wManager.Wow.Enums Namespace


Heirloom Field

WoWItemQuality..::..Heirloom Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWItemQuality Heirloom
Public Const Heirloom As WoWItemQuality
public:
literal WoWItemQuality Heirloom

See Also

WoWItemQuality Enumeration
wManager.Wow.Enums Namespace


Legendary Field

WoWItemQuality..::..Legendary Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWItemQuality Legendary
Public Const Legendary As WoWItemQuality
public:
literal WoWItemQuality Legendary

See Also

WoWItemQuality Enumeration
wManager.Wow.Enums Namespace


Poor Field

WoWItemQuality..::..Poor Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWItemQuality Poor
Public Const Poor As WoWItemQuality
public:
literal WoWItemQuality Poor

See Also

WoWItemQuality Enumeration
wManager.Wow.Enums Namespace


Rare Field

WoWItemQuality..::..Rare Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWItemQuality Rare
Public Const Rare As WoWItemQuality
public:
literal WoWItemQuality Rare

See Also

WoWItemQuality Enumeration
wManager.Wow.Enums Namespace


Uncommon Field

WoWItemQuality..::..Uncommon Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWItemQuality Uncommon
Public Const Uncommon As WoWItemQuality
public:
literal WoWItemQuality Uncommon

See Also

WoWItemQuality Enumeration
wManager.Wow.Enums Namespace


AiGroup Field

WoWObjectType..::..AiGroup Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWObjectType AiGroup
Public Const AiGroup As WoWObjectType
public:
literal WoWObjectType AiGroup

See Also

WoWObjectType Enumeration
wManager.Wow.Enums Namespace


AreaTrigger Field

WoWObjectType..::..AreaTrigger Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWObjectType AreaTrigger
Public Const AreaTrigger As WoWObjectType
public:
literal WoWObjectType AreaTrigger

See Also

WoWObjectType Enumeration
wManager.Wow.Enums Namespace


Container Field

WoWObjectType..::..Container Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWObjectType Container
Public Const Container As WoWObjectType
public:
literal WoWObjectType Container

See Also

WoWObjectType Enumeration
wManager.Wow.Enums Namespace


Corpse Field

WoWObjectType..::..Corpse Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWObjectType Corpse
Public Const Corpse As WoWObjectType
public:
literal WoWObjectType Corpse

See Also

WoWObjectType Enumeration
wManager.Wow.Enums Namespace


DynamicObject Field

WoWObjectType..::..DynamicObject Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWObjectType DynamicObject
Public Const DynamicObject As WoWObjectType
public:
literal WoWObjectType DynamicObject

See Also

WoWObjectType Enumeration
wManager.Wow.Enums Namespace


GameObject Field

WoWObjectType..::..GameObject Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWObjectType GameObject
Public Const GameObject As WoWObjectType
public:
literal WoWObjectType GameObject

See Also

WoWObjectType Enumeration
wManager.Wow.Enums Namespace


Item Field

WoWObjectType..::..Item Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWObjectType Item
Public Const Item As WoWObjectType
public:
literal WoWObjectType Item

See Also

WoWObjectType Enumeration
wManager.Wow.Enums Namespace


None Field

WoWObjectType..::..None Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWObjectType None
Public Const None As WoWObjectType
public:
literal WoWObjectType None

See Also

WoWObjectType Enumeration
wManager.Wow.Enums Namespace


Object Field

WoWObjectType..::..Object Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWObjectType Object
Public Const Object As WoWObjectType
public:
literal WoWObjectType Object

See Also

WoWObjectType Enumeration
wManager.Wow.Enums Namespace


Player Field

WoWObjectType..::..Player Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWObjectType Player
Public Const Player As WoWObjectType
public:
literal WoWObjectType Player

See Also

WoWObjectType Enumeration
wManager.Wow.Enums Namespace


Unit Field

WoWObjectType..::..Unit Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWObjectType Unit
Public Const Unit As WoWObjectType
public:
literal WoWObjectType Unit

See Also

WoWObjectType Enumeration
wManager.Wow.Enums Namespace


BloodElf Field

WoWRace..::..BloodElf Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWRace BloodElf
Public Const BloodElf As WoWRace
public:
literal WoWRace BloodElf

See Also

WoWRace Enumeration
wManager.Wow.Enums Namespace


Broken Field

WoWRace..::..Broken Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWRace Broken
Public Const Broken As WoWRace
public:
literal WoWRace Broken

See Also

WoWRace Enumeration
wManager.Wow.Enums Namespace


Draenei Field

WoWRace..::..Draenei Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWRace Draenei
Public Const Draenei As WoWRace
public:
literal WoWRace Draenei

See Also

WoWRace Enumeration
wManager.Wow.Enums Namespace


Dwarf Field

WoWRace..::..Dwarf Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWRace Dwarf
Public Const Dwarf As WoWRace
public:
literal WoWRace Dwarf

See Also

WoWRace Enumeration
wManager.Wow.Enums Namespace


FelOrc Field

WoWRace..::..FelOrc Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWRace FelOrc
Public Const FelOrc As WoWRace
public:
literal WoWRace FelOrc

See Also

WoWRace Enumeration
wManager.Wow.Enums Namespace


ForestTroll Field

WoWRace..::..ForestTroll Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWRace ForestTroll
Public Const ForestTroll As WoWRace
public:
literal WoWRace ForestTroll

See Also

WoWRace Enumeration
wManager.Wow.Enums Namespace


Gnome Field

WoWRace..::..Gnome Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWRace Gnome
Public Const Gnome As WoWRace
public:
literal WoWRace Gnome

See Also

WoWRace Enumeration
wManager.Wow.Enums Namespace


Goblin Field

WoWRace..::..Goblin Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWRace Goblin
Public Const Goblin As WoWRace
public:
literal WoWRace Goblin

See Also

WoWRace Enumeration
wManager.Wow.Enums Namespace


Human Field

WoWRace..::..Human Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWRace Human
Public Const Human As WoWRace
public:
literal WoWRace Human

See Also

WoWRace Enumeration
wManager.Wow.Enums Namespace


IceTroll Field

WoWRace..::..IceTroll Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWRace IceTroll
Public Const IceTroll As WoWRace
public:
literal WoWRace IceTroll

See Also

WoWRace Enumeration
wManager.Wow.Enums Namespace


Naga Field

WoWRace..::..Naga Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWRace Naga
Public Const Naga As WoWRace
public:
literal WoWRace Naga

See Also

WoWRace Enumeration
wManager.Wow.Enums Namespace


NightElf Field

WoWRace..::..NightElf Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWRace NightElf
Public Const NightElf As WoWRace
public:
literal WoWRace NightElf

See Also

WoWRace Enumeration
wManager.Wow.Enums Namespace


None Field

WoWRace..::..None Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWRace None
Public Const None As WoWRace
public:
literal WoWRace None

See Also

WoWRace Enumeration
wManager.Wow.Enums Namespace


NorthrendSkeleton Field

WoWRace..::..NorthrendSkeleton Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWRace NorthrendSkeleton
Public Const NorthrendSkeleton As WoWRace
public:
literal WoWRace NorthrendSkeleton

See Also

WoWRace Enumeration
wManager.Wow.Enums Namespace


Orc Field

WoWRace..::..Orc Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWRace Orc
Public Const Orc As WoWRace
public:
literal WoWRace Orc

See Also

WoWRace Enumeration
wManager.Wow.Enums Namespace


Pandaren Field

WoWRace..::..Pandaren Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWRace Pandaren
Public Const Pandaren As WoWRace
public:
literal WoWRace Pandaren

See Also

WoWRace Enumeration
wManager.Wow.Enums Namespace


PandarenAlliance Field

WoWRace..::..PandarenAlliance Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWRace PandarenAlliance
Public Const PandarenAlliance As WoWRace
public:
literal WoWRace PandarenAlliance

See Also

WoWRace Enumeration
wManager.Wow.Enums Namespace


PandarenHorde Field

WoWRace..::..PandarenHorde Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWRace PandarenHorde
Public Const PandarenHorde As WoWRace
public:
literal WoWRace PandarenHorde

See Also

WoWRace Enumeration
wManager.Wow.Enums Namespace


Skeleton Field

WoWRace..::..Skeleton Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWRace Skeleton
Public Const Skeleton As WoWRace
public:
literal WoWRace Skeleton

See Also

WoWRace Enumeration
wManager.Wow.Enums Namespace


Taunka Field

WoWRace..::..Taunka Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWRace Taunka
Public Const Taunka As WoWRace
public:
literal WoWRace Taunka

See Also

WoWRace Enumeration
wManager.Wow.Enums Namespace


Tauren Field

WoWRace..::..Tauren Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWRace Tauren
Public Const Tauren As WoWRace
public:
literal WoWRace Tauren

See Also

WoWRace Enumeration
wManager.Wow.Enums Namespace


Troll Field

WoWRace..::..Troll Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWRace Troll
Public Const Troll As WoWRace
public:
literal WoWRace Troll

See Also

WoWRace Enumeration
wManager.Wow.Enums Namespace


Tuskarr Field

WoWRace..::..Tuskarr Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWRace Tuskarr
Public Const Tuskarr As WoWRace
public:
literal WoWRace Tuskarr

See Also

WoWRace Enumeration
wManager.Wow.Enums Namespace


Undead Field

WoWRace..::..Undead Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWRace Undead
Public Const Undead As WoWRace
public:
literal WoWRace Undead

See Also

WoWRace Enumeration
wManager.Wow.Enums Namespace


Vrykul Field

WoWRace..::..Vrykul Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWRace Vrykul
Public Const Vrykul As WoWRace
public:
literal WoWRace Vrykul

See Also

WoWRace Enumeration
wManager.Wow.Enums Namespace


Worgen Field

WoWRace..::..Worgen Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WoWRace Worgen
Public Const Worgen As WoWRace
public:
literal WoWRace Worgen

See Also

WoWRace Enumeration
wManager.Wow.Enums Namespace


DeathKnight_Blood Field

WowSpecializations..::..DeathKnight_Blood Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WowSpecializations DeathKnight_Blood
Public Const DeathKnight_Blood As WowSpecializations
public:
literal WowSpecializations DeathKnight_Blood

See Also

WowSpecializations Enumeration
wManager.Wow.Enums Namespace


DeathKnight_Default Field

WowSpecializations..::..DeathKnight_Default Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WowSpecializations DeathKnight_Default
Public Const DeathKnight_Default As WowSpecializations
public:
literal WowSpecializations DeathKnight_Default

See Also

WowSpecializations Enumeration
wManager.Wow.Enums Namespace


DeathKnight_Frost Field

WowSpecializations..::..DeathKnight_Frost Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WowSpecializations DeathKnight_Frost
Public Const DeathKnight_Frost As WowSpecializations
public:
literal WowSpecializations DeathKnight_Frost

See Also

WowSpecializations Enumeration
wManager.Wow.Enums Namespace


DeathKnight_Unholy Field

WowSpecializations..::..DeathKnight_Unholy Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WowSpecializations DeathKnight_Unholy
Public Const DeathKnight_Unholy As WowSpecializations
public:
literal WowSpecializations DeathKnight_Unholy

See Also

WowSpecializations Enumeration
wManager.Wow.Enums Namespace


Druid_Balance Field

WowSpecializations..::..Druid_Balance Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WowSpecializations Druid_Balance
Public Const Druid_Balance As WowSpecializations
public:
literal WowSpecializations Druid_Balance

See Also

WowSpecializations Enumeration
wManager.Wow.Enums Namespace


Druid_Default Field

WowSpecializations..::..Druid_Default Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WowSpecializations Druid_Default
Public Const Druid_Default As WowSpecializations
public:
literal WowSpecializations Druid_Default

See Also

WowSpecializations Enumeration
wManager.Wow.Enums Namespace


Druid_Feral Field

WowSpecializations..::..Druid_Feral Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WowSpecializations Druid_Feral
Public Const Druid_Feral As WowSpecializations
public:
literal WowSpecializations Druid_Feral

See Also

WowSpecializations Enumeration
wManager.Wow.Enums Namespace


Druid_Guardian Field

WowSpecializations..::..Druid_Guardian Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WowSpecializations Druid_Guardian
Public Const Druid_Guardian As WowSpecializations
public:
literal WowSpecializations Druid_Guardian

See Also

WowSpecializations Enumeration
wManager.Wow.Enums Namespace


Druid_Restoration Field

WowSpecializations..::..Druid_Restoration Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WowSpecializations Druid_Restoration
Public Const Druid_Restoration As WowSpecializations
public:
literal WowSpecializations Druid_Restoration

See Also

WowSpecializations Enumeration
wManager.Wow.Enums Namespace


Hunter_Beast_Mastery Field

WowSpecializations..::..Hunter_Beast_Mastery Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WowSpecializations Hunter_Beast_Mastery
Public Const Hunter_Beast_Mastery As WowSpecializations
public:
literal WowSpecializations Hunter_Beast_Mastery

See Also

WowSpecializations Enumeration
wManager.Wow.Enums Namespace


Hunter_Default Field

WowSpecializations..::..Hunter_Default Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WowSpecializations Hunter_Default
Public Const Hunter_Default As WowSpecializations
public:
literal WowSpecializations Hunter_Default

See Also

WowSpecializations Enumeration
wManager.Wow.Enums Namespace


Hunter_Marksmanship Field

WowSpecializations..::..Hunter_Marksmanship Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WowSpecializations Hunter_Marksmanship
Public Const Hunter_Marksmanship As WowSpecializations
public:
literal WowSpecializations Hunter_Marksmanship

See Also

WowSpecializations Enumeration
wManager.Wow.Enums Namespace


Hunter_Survival Field

WowSpecializations..::..Hunter_Survival Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WowSpecializations Hunter_Survival
Public Const Hunter_Survival As WowSpecializations
public:
literal WowSpecializations Hunter_Survival

See Also

WowSpecializations Enumeration
wManager.Wow.Enums Namespace


Mage_Arcane Field

WowSpecializations..::..Mage_Arcane Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WowSpecializations Mage_Arcane
Public Const Mage_Arcane As WowSpecializations
public:
literal WowSpecializations Mage_Arcane

See Also

WowSpecializations Enumeration
wManager.Wow.Enums Namespace


Mage_Default Field

WowSpecializations..::..Mage_Default Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WowSpecializations Mage_Default
Public Const Mage_Default As WowSpecializations
public:
literal WowSpecializations Mage_Default

See Also

WowSpecializations Enumeration
wManager.Wow.Enums Namespace


Mage_Fire Field

WowSpecializations..::..Mage_Fire Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WowSpecializations Mage_Fire
Public Const Mage_Fire As WowSpecializations
public:
literal WowSpecializations Mage_Fire

See Also

WowSpecializations Enumeration
wManager.Wow.Enums Namespace


Mage_Frost Field

WowSpecializations..::..Mage_Frost Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WowSpecializations Mage_Frost
Public Const Mage_Frost As WowSpecializations
public:
literal WowSpecializations Mage_Frost

See Also

WowSpecializations Enumeration
wManager.Wow.Enums Namespace


Monk_Brewmaster Field

WowSpecializations..::..Monk_Brewmaster Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WowSpecializations Monk_Brewmaster
Public Const Monk_Brewmaster As WowSpecializations
public:
literal WowSpecializations Monk_Brewmaster

See Also

WowSpecializations Enumeration
wManager.Wow.Enums Namespace


Monk_Default Field

WowSpecializations..::..Monk_Default Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WowSpecializations Monk_Default
Public Const Monk_Default As WowSpecializations
public:
literal WowSpecializations Monk_Default

See Also

WowSpecializations Enumeration
wManager.Wow.Enums Namespace


Monk_Mistweaver Field

WowSpecializations..::..Monk_Mistweaver Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WowSpecializations Monk_Mistweaver
Public Const Monk_Mistweaver As WowSpecializations
public:
literal WowSpecializations Monk_Mistweaver

See Also

WowSpecializations Enumeration
wManager.Wow.Enums Namespace


Monk_Windwalker Field

WowSpecializations..::..Monk_Windwalker Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WowSpecializations Monk_Windwalker
Public Const Monk_Windwalker As WowSpecializations
public:
literal WowSpecializations Monk_Windwalker

See Also

WowSpecializations Enumeration
wManager.Wow.Enums Namespace


None Field

WowSpecializations..::..None Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WowSpecializations None
Public Const None As WowSpecializations
public:
literal WowSpecializations None

See Also

WowSpecializations Enumeration
wManager.Wow.Enums Namespace


Paladin_Default Field

WowSpecializations..::..Paladin_Default Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WowSpecializations Paladin_Default
Public Const Paladin_Default As WowSpecializations
public:
literal WowSpecializations Paladin_Default

See Also

WowSpecializations Enumeration
wManager.Wow.Enums Namespace


Paladin_Holy Field

WowSpecializations..::..Paladin_Holy Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WowSpecializations Paladin_Holy
Public Const Paladin_Holy As WowSpecializations
public:
literal WowSpecializations Paladin_Holy

See Also

WowSpecializations Enumeration
wManager.Wow.Enums Namespace


Paladin_Protection Field

WowSpecializations..::..Paladin_Protection Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WowSpecializations Paladin_Protection
Public Const Paladin_Protection As WowSpecializations
public:
literal WowSpecializations Paladin_Protection

See Also

WowSpecializations Enumeration
wManager.Wow.Enums Namespace


Paladin_Restribution Field

WowSpecializations..::..Paladin_Restribution Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WowSpecializations Paladin_Restribution
Public Const Paladin_Restribution As WowSpecializations
public:
literal WowSpecializations Paladin_Restribution

See Also

WowSpecializations Enumeration
wManager.Wow.Enums Namespace


Priest_Default Field

WowSpecializations..::..Priest_Default Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WowSpecializations Priest_Default
Public Const Priest_Default As WowSpecializations
public:
literal WowSpecializations Priest_Default

See Also

WowSpecializations Enumeration
wManager.Wow.Enums Namespace


Priest_Discipline Field

WowSpecializations..::..Priest_Discipline Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WowSpecializations Priest_Discipline
Public Const Priest_Discipline As WowSpecializations
public:
literal WowSpecializations Priest_Discipline

See Also

WowSpecializations Enumeration
wManager.Wow.Enums Namespace


Priest_Holy Field

WowSpecializations..::..Priest_Holy Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WowSpecializations Priest_Holy
Public Const Priest_Holy As WowSpecializations
public:
literal WowSpecializations Priest_Holy

See Also

WowSpecializations Enumeration
wManager.Wow.Enums Namespace


Priest_Shadow Field

WowSpecializations..::..Priest_Shadow Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WowSpecializations Priest_Shadow
Public Const Priest_Shadow As WowSpecializations
public:
literal WowSpecializations Priest_Shadow

See Also

WowSpecializations Enumeration
wManager.Wow.Enums Namespace


Rogue_Assassination Field

WowSpecializations..::..Rogue_Assassination Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WowSpecializations Rogue_Assassination
Public Const Rogue_Assassination As WowSpecializations
public:
literal WowSpecializations Rogue_Assassination

See Also

WowSpecializations Enumeration
wManager.Wow.Enums Namespace


Rogue_Combat Field

WowSpecializations..::..Rogue_Combat Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WowSpecializations Rogue_Combat
Public Const Rogue_Combat As WowSpecializations
public:
literal WowSpecializations Rogue_Combat

See Also

WowSpecializations Enumeration
wManager.Wow.Enums Namespace


Rogue_Default Field

WowSpecializations..::..Rogue_Default Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WowSpecializations Rogue_Default
Public Const Rogue_Default As WowSpecializations
public:
literal WowSpecializations Rogue_Default

See Also

WowSpecializations Enumeration
wManager.Wow.Enums Namespace


Rogue_Subtlety Field

WowSpecializations..::..Rogue_Subtlety Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WowSpecializations Rogue_Subtlety
Public Const Rogue_Subtlety As WowSpecializations
public:
literal WowSpecializations Rogue_Subtlety

See Also

WowSpecializations Enumeration
wManager.Wow.Enums Namespace


Shaman_Default Field

WowSpecializations..::..Shaman_Default Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WowSpecializations Shaman_Default
Public Const Shaman_Default As WowSpecializations
public:
literal WowSpecializations Shaman_Default

See Also

WowSpecializations Enumeration
wManager.Wow.Enums Namespace


Shaman_Elemental Field

WowSpecializations..::..Shaman_Elemental Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WowSpecializations Shaman_Elemental
Public Const Shaman_Elemental As WowSpecializations
public:
literal WowSpecializations Shaman_Elemental

See Also

WowSpecializations Enumeration
wManager.Wow.Enums Namespace


Shaman_Enhancement Field

WowSpecializations..::..Shaman_Enhancement Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WowSpecializations Shaman_Enhancement
Public Const Shaman_Enhancement As WowSpecializations
public:
literal WowSpecializations Shaman_Enhancement

See Also

WowSpecializations Enumeration
wManager.Wow.Enums Namespace


Shaman_Restoration Field

WowSpecializations..::..Shaman_Restoration Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WowSpecializations Shaman_Restoration
Public Const Shaman_Restoration As WowSpecializations
public:
literal WowSpecializations Shaman_Restoration

See Also

WowSpecializations Enumeration
wManager.Wow.Enums Namespace


Warlock_Affliction Field

WowSpecializations..::..Warlock_Affliction Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WowSpecializations Warlock_Affliction
Public Const Warlock_Affliction As WowSpecializations
public:
literal WowSpecializations Warlock_Affliction

See Also

WowSpecializations Enumeration
wManager.Wow.Enums Namespace


Warlock_Default Field

WowSpecializations..::..Warlock_Default Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WowSpecializations Warlock_Default
Public Const Warlock_Default As WowSpecializations
public:
literal WowSpecializations Warlock_Default

See Also

WowSpecializations Enumeration
wManager.Wow.Enums Namespace


Warlock_Demonology Field

WowSpecializations..::..Warlock_Demonology Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WowSpecializations Warlock_Demonology
Public Const Warlock_Demonology As WowSpecializations
public:
literal WowSpecializations Warlock_Demonology

See Also

WowSpecializations Enumeration
wManager.Wow.Enums Namespace


Warlock_Destruction Field

WowSpecializations..::..Warlock_Destruction Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WowSpecializations Warlock_Destruction
Public Const Warlock_Destruction As WowSpecializations
public:
literal WowSpecializations Warlock_Destruction

See Also

WowSpecializations Enumeration
wManager.Wow.Enums Namespace


Warrior_Arms Field

WowSpecializations..::..Warrior_Arms Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WowSpecializations Warrior_Arms
Public Const Warrior_Arms As WowSpecializations
public:
literal WowSpecializations Warrior_Arms

See Also

WowSpecializations Enumeration
wManager.Wow.Enums Namespace


Warrior_Default Field

WowSpecializations..::..Warrior_Default Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WowSpecializations Warrior_Default
Public Const Warrior_Default As WowSpecializations
public:
literal WowSpecializations Warrior_Default

See Also

WowSpecializations Enumeration
wManager.Wow.Enums Namespace


Warrior_Fury Field

WowSpecializations..::..Warrior_Fury Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WowSpecializations Warrior_Fury
Public Const Warrior_Fury As WowSpecializations
public:
literal WowSpecializations Warrior_Fury

See Also

WowSpecializations Enumeration
wManager.Wow.Enums Namespace


Warrior_Protection Field

WowSpecializations..::..Warrior_Protection Field

Namespace: wManager.Wow.Enums
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const WowSpecializations Warrior_Protection
Public Const Warrior_Protection As WowSpecializations
public:
literal WowSpecializations Warrior_Protection

See Also

WowSpecializations Enumeration
wManager.Wow.Enums Namespace


_12H Field

Duration..::.._12H Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const AuctionHelpers..::..Duration _12H
Public Const _12H As AuctionHelpers..::..Duration
public:
literal AuctionHelpers..::..Duration _12H

See Also

AuctionHelpers..::..Duration Enumeration
wManager.Wow.Helpers Namespace


_24H Field

Duration..::.._24H Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const AuctionHelpers..::..Duration _24H
Public Const _24H As AuctionHelpers..::..Duration
public:
literal AuctionHelpers..::..Duration _24H

See Also

AuctionHelpers..::..Duration Enumeration
wManager.Wow.Helpers Namespace


_48H Field

Duration..::.._48H Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const AuctionHelpers..::..Duration _48H
Public Const _48H As AuctionHelpers..::..Duration
public:
literal AuctionHelpers..::..Duration _48H

See Also

AuctionHelpers..::..Duration Enumeration
wManager.Wow.Helpers Namespace


Armor Field

Filters..::..Armor Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const AuctionHelpers..::..Filters Armor
Public Const Armor As AuctionHelpers..::..Filters
public:
literal AuctionHelpers..::..Filters Armor

See Also

AuctionHelpers..::..Filters Enumeration
wManager.Wow.Helpers Namespace


BattlePets Field

Filters..::..BattlePets Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const AuctionHelpers..::..Filters BattlePets
Public Const BattlePets As AuctionHelpers..::..Filters
public:
literal AuctionHelpers..::..Filters BattlePets

See Also

AuctionHelpers..::..Filters Enumeration
wManager.Wow.Helpers Namespace


Consumable Field

Filters..::..Consumable Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const AuctionHelpers..::..Filters Consumable
Public Const Consumable As AuctionHelpers..::..Filters
public:
literal AuctionHelpers..::..Filters Consumable

See Also

AuctionHelpers..::..Filters Enumeration
wManager.Wow.Helpers Namespace


Container Field

Filters..::..Container Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const AuctionHelpers..::..Filters Container
Public Const Container As AuctionHelpers..::..Filters
public:
literal AuctionHelpers..::..Filters Container

See Also

AuctionHelpers..::..Filters Enumeration
wManager.Wow.Helpers Namespace


GameTime Field

Filters..::..GameTime Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const AuctionHelpers..::..Filters GameTime
Public Const GameTime As AuctionHelpers..::..Filters
public:
literal AuctionHelpers..::..Filters GameTime

See Also

AuctionHelpers..::..Filters Enumeration
wManager.Wow.Helpers Namespace


Gem Field

Filters..::..Gem Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const AuctionHelpers..::..Filters Gem
Public Const Gem As AuctionHelpers..::..Filters
public:
literal AuctionHelpers..::..Filters Gem

See Also

AuctionHelpers..::..Filters Enumeration
wManager.Wow.Helpers Namespace


Glyph Field

Filters..::..Glyph Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const AuctionHelpers..::..Filters Glyph
Public Const Glyph As AuctionHelpers..::..Filters
public:
literal AuctionHelpers..::..Filters Glyph

See Also

AuctionHelpers..::..Filters Enumeration
wManager.Wow.Helpers Namespace


Miscellaneous Field

Filters..::..Miscellaneous Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const AuctionHelpers..::..Filters Miscellaneous
Public Const Miscellaneous As AuctionHelpers..::..Filters
public:
literal AuctionHelpers..::..Filters Miscellaneous

See Also

AuctionHelpers..::..Filters Enumeration
wManager.Wow.Helpers Namespace


None Field

Filters..::..None Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const AuctionHelpers..::..Filters None
Public Const None As AuctionHelpers..::..Filters
public:
literal AuctionHelpers..::..Filters None

See Also

AuctionHelpers..::..Filters Enumeration
wManager.Wow.Helpers Namespace


Quest Field

Filters..::..Quest Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const AuctionHelpers..::..Filters Quest
Public Const Quest As AuctionHelpers..::..Filters
public:
literal AuctionHelpers..::..Filters Quest

See Also

AuctionHelpers..::..Filters Enumeration
wManager.Wow.Helpers Namespace


Recipe Field

Filters..::..Recipe Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const AuctionHelpers..::..Filters Recipe
Public Const Recipe As AuctionHelpers..::..Filters
public:
literal AuctionHelpers..::..Filters Recipe

See Also

AuctionHelpers..::..Filters Enumeration
wManager.Wow.Helpers Namespace


TradeGoods Field

Filters..::..TradeGoods Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const AuctionHelpers..::..Filters TradeGoods
Public Const TradeGoods As AuctionHelpers..::..Filters
public:
literal AuctionHelpers..::..Filters TradeGoods

See Also

AuctionHelpers..::..Filters Enumeration
wManager.Wow.Helpers Namespace


Weapon Field

Filters..::..Weapon Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const AuctionHelpers..::..Filters Weapon
Public Const Weapon As AuctionHelpers..::..Filters
public:
literal AuctionHelpers..::..Filters Weapon

See Also

AuctionHelpers..::..Filters Enumeration
wManager.Wow.Helpers Namespace


All Field

Rarity..::..All Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const AuctionHelpers..::..Rarity All
Public Const All As AuctionHelpers..::..Rarity
public:
literal AuctionHelpers..::..Rarity All

See Also

AuctionHelpers..::..Rarity Enumeration
wManager.Wow.Helpers Namespace


Artifact Field

Rarity..::..Artifact Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const AuctionHelpers..::..Rarity Artifact
Public Const Artifact As AuctionHelpers..::..Rarity
public:
literal AuctionHelpers..::..Rarity Artifact

See Also

AuctionHelpers..::..Rarity Enumeration
wManager.Wow.Helpers Namespace


Common Field

Rarity..::..Common Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const AuctionHelpers..::..Rarity Common
Public Const Common As AuctionHelpers..::..Rarity
public:
literal AuctionHelpers..::..Rarity Common

See Also

AuctionHelpers..::..Rarity Enumeration
wManager.Wow.Helpers Namespace


Epic Field

Rarity..::..Epic Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const AuctionHelpers..::..Rarity Epic
Public Const Epic As AuctionHelpers..::..Rarity
public:
literal AuctionHelpers..::..Rarity Epic

See Also

AuctionHelpers..::..Rarity Enumeration
wManager.Wow.Helpers Namespace


Legendary Field

Rarity..::..Legendary Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const AuctionHelpers..::..Rarity Legendary
Public Const Legendary As AuctionHelpers..::..Rarity
public:
literal AuctionHelpers..::..Rarity Legendary

See Also

AuctionHelpers..::..Rarity Enumeration
wManager.Wow.Helpers Namespace


Poor Field

Rarity..::..Poor Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const AuctionHelpers..::..Rarity Poor
Public Const Poor As AuctionHelpers..::..Rarity
public:
literal AuctionHelpers..::..Rarity Poor

See Also

AuctionHelpers..::..Rarity Enumeration
wManager.Wow.Helpers Namespace


Rare Field

Rarity..::..Rare Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const AuctionHelpers..::..Rarity Rare
Public Const Rare As AuctionHelpers..::..Rarity
public:
literal AuctionHelpers..::..Rarity Rare

See Also

AuctionHelpers..::..Rarity Enumeration
wManager.Wow.Helpers Namespace


Uncommon Field

Rarity..::..Uncommon Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const AuctionHelpers..::..Rarity Uncommon
Public Const Uncommon As AuctionHelpers..::..Rarity
public:
literal AuctionHelpers..::..Rarity Uncommon

See Also

AuctionHelpers..::..Rarity Enumeration
wManager.Wow.Helpers Namespace


Long Field

TimeLeft..::..Long Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const AuctionHelpers..::..TimeLeft Long
Public Const Long As AuctionHelpers..::..TimeLeft
public:
literal AuctionHelpers..::..TimeLeft Long

See Also

AuctionHelpers..::..TimeLeft Enumeration
wManager.Wow.Helpers Namespace


Medium Field

TimeLeft..::..Medium Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const AuctionHelpers..::..TimeLeft Medium
Public Const Medium As AuctionHelpers..::..TimeLeft
public:
literal AuctionHelpers..::..TimeLeft Medium

See Also

AuctionHelpers..::..TimeLeft Enumeration
wManager.Wow.Helpers Namespace


None Field

TimeLeft..::..None Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const AuctionHelpers..::..TimeLeft None
Public Const None As AuctionHelpers..::..TimeLeft
public:
literal AuctionHelpers..::..TimeLeft None

See Also

AuctionHelpers..::..TimeLeft Enumeration
wManager.Wow.Helpers Namespace


Short Field

TimeLeft..::..Short Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const AuctionHelpers..::..TimeLeft Short
Public Const Short As AuctionHelpers..::..TimeLeft
public:
literal AuctionHelpers..::..TimeLeft Short

See Also

AuctionHelpers..::..TimeLeft Enumeration
wManager.Wow.Helpers Namespace


VeryLong Field

TimeLeft..::..VeryLong Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const AuctionHelpers..::..TimeLeft VeryLong
Public Const VeryLong As AuctionHelpers..::..TimeLeft
public:
literal AuctionHelpers..::..TimeLeft VeryLong

See Also

AuctionHelpers..::..TimeLeft Enumeration
wManager.Wow.Helpers Namespace


Bigger Field

FightClassConditionNumberType..::..Bigger Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassConditionNumberType Bigger
Public Const Bigger As FightClassConditionNumberType
public:
literal FightClassConditionNumberType Bigger

See Also

FightClassConditionNumberType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


BiggerOrEqual Field

FightClassConditionNumberType..::..BiggerOrEqual Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassConditionNumberType BiggerOrEqual
Public Const BiggerOrEqual As FightClassConditionNumberType
public:
literal FightClassConditionNumberType BiggerOrEqual

See Also

FightClassConditionNumberType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


Egal Field

FightClassConditionNumberType..::..Egal Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassConditionNumberType Egal
Public Const Egal As FightClassConditionNumberType
public:
literal FightClassConditionNumberType Egal

See Also

FightClassConditionNumberType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


Equal Field

FightClassConditionNumberType..::..Equal Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassConditionNumberType Equal
Public Const Equal As FightClassConditionNumberType
public:
literal FightClassConditionNumberType Equal

See Also

FightClassConditionNumberType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


NotEgal Field

FightClassConditionNumberType..::..NotEgal Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassConditionNumberType NotEgal
Public Const NotEgal As FightClassConditionNumberType
public:
literal FightClassConditionNumberType NotEgal

See Also

FightClassConditionNumberType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


NotEqual Field

FightClassConditionNumberType..::..NotEqual Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassConditionNumberType NotEqual
Public Const NotEqual As FightClassConditionNumberType
public:
literal FightClassConditionNumberType NotEqual

See Also

FightClassConditionNumberType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


Smaller Field

FightClassConditionNumberType..::..Smaller Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassConditionNumberType Smaller
Public Const Smaller As FightClassConditionNumberType
public:
literal FightClassConditionNumberType Smaller

See Also

FightClassConditionNumberType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


SmallerOrEqual Field

FightClassConditionNumberType..::..SmallerOrEqual Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassConditionNumberType SmallerOrEqual
Public Const SmallerOrEqual As FightClassConditionNumberType
public:
literal FightClassConditionNumberType SmallerOrEqual

See Also

FightClassConditionNumberType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


Alternate Field

FightClassContionsType..::..Alternate Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType Alternate
Public Const Alternate As FightClassContionsType
public:
literal FightClassContionsType Alternate

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


ArcaneCharges Field

FightClassContionsType..::..ArcaneCharges Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType ArcaneCharges
Public Const ArcaneCharges As FightClassContionsType
public:
literal FightClassContionsType ArcaneCharges

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


Buff Field

FightClassContionsType..::..Buff Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType Buff
Public Const Buff As FightClassContionsType
public:
literal FightClassContionsType Buff

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


BuffCastedByMe Field

FightClassContionsType..::..BuffCastedByMe Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType BuffCastedByMe
Public Const BuffCastedByMe As FightClassContionsType
public:
literal FightClassContionsType BuffCastedByMe

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


BuffStack Field

FightClassContionsType..::..BuffStack Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType BuffStack
Public Const BuffStack As FightClassContionsType
public:
literal FightClassContionsType BuffStack

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


BuffStackPet Field

FightClassContionsType..::..BuffStackPet Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType BuffStackPet
Public Const BuffStackPet As FightClassContionsType
public:
literal FightClassContionsType BuffStackPet

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


BuffStackTarget Field

FightClassContionsType..::..BuffStackTarget Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType BuffStackTarget
Public Const BuffStackTarget As FightClassContionsType
public:
literal FightClassContionsType BuffStackTarget

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


BuffTimeLeft Field

FightClassContionsType..::..BuffTimeLeft Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType BuffTimeLeft
Public Const BuffTimeLeft As FightClassContionsType
public:
literal FightClassContionsType BuffTimeLeft

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


BuffTimeLeftPet Field

FightClassContionsType..::..BuffTimeLeftPet Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType BuffTimeLeftPet
Public Const BuffTimeLeftPet As FightClassContionsType
public:
literal FightClassContionsType BuffTimeLeftPet

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


BuffTimeLeftTarget Field

FightClassContionsType..::..BuffTimeLeftTarget Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType BuffTimeLeftTarget
Public Const BuffTimeLeftTarget As FightClassContionsType
public:
literal FightClassContionsType BuffTimeLeftTarget

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


BurningEmbers Field

FightClassContionsType..::..BurningEmbers Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType BurningEmbers
Public Const BurningEmbers As FightClassContionsType
public:
literal FightClassContionsType BurningEmbers

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


CastingSpellName Field

FightClassContionsType..::..CastingSpellName Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType CastingSpellName
Public Const CastingSpellName As FightClassContionsType
public:
literal FightClassContionsType CastingSpellName

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


CastingTimeLeft Field

FightClassContionsType..::..CastingTimeLeft Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType CastingTimeLeft
Public Const CastingTimeLeft As FightClassContionsType
public:
literal FightClassContionsType CastingTimeLeft

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


Chi Field

FightClassContionsType..::..Chi Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType Chi
Public Const Chi As FightClassContionsType
public:
literal FightClassContionsType Chi

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


CombatStartSinceMs Field

FightClassContionsType..::..CombatStartSinceMs Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType CombatStartSinceMs
Public Const CombatStartSinceMs As FightClassContionsType
public:
literal FightClassContionsType CombatStartSinceMs

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


ComboPoint Field

FightClassContionsType..::..ComboPoint Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType ComboPoint
Public Const ComboPoint As FightClassContionsType
public:
literal FightClassContionsType ComboPoint

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


Confused Field

FightClassContionsType..::..Confused Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType Confused
Public Const Confused As FightClassContionsType
public:
literal FightClassContionsType Confused

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


CooldownEnabled Field

FightClassContionsType..::..CooldownEnabled Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType CooldownEnabled
Public Const CooldownEnabled As FightClassContionsType
public:
literal FightClassContionsType CooldownEnabled

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


CooldownTimeLeft Field

FightClassContionsType..::..CooldownTimeLeft Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType CooldownTimeLeft
Public Const CooldownTimeLeft As FightClassContionsType
public:
literal FightClassContionsType CooldownTimeLeft

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


CSharpCode Field

FightClassContionsType..::..CSharpCode Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType CSharpCode
Public Const CSharpCode As FightClassContionsType
public:
literal FightClassContionsType CSharpCode

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


DarkForce Field

FightClassContionsType..::..DarkForce Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType DarkForce
Public Const DarkForce As FightClassContionsType
public:
literal FightClassContionsType DarkForce

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


DemonicFury Field

FightClassContionsType..::..DemonicFury Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType DemonicFury
Public Const DemonicFury As FightClassContionsType
public:
literal FightClassContionsType DemonicFury

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


DistanceMeToPet Field

FightClassContionsType..::..DistanceMeToPet Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType DistanceMeToPet
Public Const DistanceMeToPet As FightClassContionsType
public:
literal FightClassContionsType DistanceMeToPet

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


DistancePetToTarget Field

FightClassContionsType..::..DistancePetToTarget Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType DistancePetToTarget
Public Const DistancePetToTarget As FightClassContionsType
public:
literal FightClassContionsType DistancePetToTarget

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


Eclipse Field

FightClassContionsType..::..Eclipse Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType Eclipse
Public Const Eclipse As FightClassContionsType
public:
literal FightClassContionsType Eclipse

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


Energy Field

FightClassContionsType..::..Energy Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType Energy
Public Const Energy As FightClassContionsType
public:
literal FightClassContionsType Energy

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


Fleeing Field

FightClassContionsType..::..Fleeing Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType Fleeing
Public Const Fleeing As FightClassContionsType
public:
literal FightClassContionsType Fleeing

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


Focus Field

FightClassContionsType..::..Focus Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType Focus
Public Const Focus As FightClassContionsType
public:
literal FightClassContionsType Focus

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


GlobalCooldownEnabled Field

FightClassContionsType..::..GlobalCooldownEnabled Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType GlobalCooldownEnabled
Public Const GlobalCooldownEnabled As FightClassContionsType
public:
literal FightClassContionsType GlobalCooldownEnabled

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


GlobalCooldownTimeLeft Field

FightClassContionsType..::..GlobalCooldownTimeLeft Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType GlobalCooldownTimeLeft
Public Const GlobalCooldownTimeLeft As FightClassContionsType
public:
literal FightClassContionsType GlobalCooldownTimeLeft

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


HavePet Field

FightClassContionsType..::..HavePet Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType HavePet
Public Const HavePet As FightClassContionsType
public:
literal FightClassContionsType HavePet

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


HaveTarget Field

FightClassContionsType..::..HaveTarget Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType HaveTarget
Public Const HaveTarget As FightClassContionsType
public:
literal FightClassContionsType HaveTarget

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


HealthPercent Field

FightClassContionsType..::..HealthPercent Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType HealthPercent
Public Const HealthPercent As FightClassContionsType
public:
literal FightClassContionsType HealthPercent

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


HealthPoints Field

FightClassContionsType..::..HealthPoints Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType HealthPoints
Public Const HealthPoints As FightClassContionsType
public:
literal FightClassContionsType HealthPoints

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


HealthPointsLost Field

FightClassContionsType..::..HealthPointsLost Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType HealthPointsLost
Public Const HealthPointsLost As FightClassContionsType
public:
literal FightClassContionsType HealthPointsLost

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


HolyPower Field

FightClassContionsType..::..HolyPower Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType HolyPower
Public Const HolyPower As FightClassContionsType
public:
literal FightClassContionsType HolyPower

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


HostileUnitNear Field

FightClassContionsType..::..HostileUnitNear Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType HostileUnitNear
Public Const HostileUnitNear As FightClassContionsType
public:
literal FightClassContionsType HostileUnitNear

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


HostileUnitNearTarget Field

FightClassContionsType..::..HostileUnitNearTarget Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType HostileUnitNearTarget
Public Const HostileUnitNearTarget As FightClassContionsType
public:
literal FightClassContionsType HostileUnitNearTarget

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


InBattleground Field

FightClassContionsType..::..InBattleground Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType InBattleground
Public Const InBattleground As FightClassContionsType
public:
literal FightClassContionsType InBattleground

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


Influenced Field

FightClassContionsType..::..Influenced Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType Influenced
Public Const Influenced As FightClassContionsType
public:
literal FightClassContionsType Influenced

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


IsBehind Field

FightClassContionsType..::..IsBehind Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType IsBehind
Public Const IsBehind As FightClassContionsType
public:
literal FightClassContionsType IsBehind

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


IsFacing Field

FightClassContionsType..::..IsFacing Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType IsFacing
Public Const IsFacing As FightClassContionsType
public:
literal FightClassContionsType IsFacing

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


IsOnTaxi Field

FightClassContionsType..::..IsOnTaxi Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType IsOnTaxi
Public Const IsOnTaxi As FightClassContionsType
public:
literal FightClassContionsType IsOnTaxi

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


IsSpellOverlayed Field

FightClassContionsType..::..IsSpellOverlayed Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType IsSpellOverlayed
Public Const IsSpellOverlayed As FightClassContionsType
public:
literal FightClassContionsType IsSpellOverlayed

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


IsSpellUsable Field

FightClassContionsType..::..IsSpellUsable Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType IsSpellUsable
Public Const IsSpellUsable As FightClassContionsType
public:
literal FightClassContionsType IsSpellUsable

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


ItemCount Field

FightClassContionsType..::..ItemCount Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType ItemCount
Public Const ItemCount As FightClassContionsType
public:
literal FightClassContionsType ItemCount

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


ItemIdCooldownEnabled Field

FightClassContionsType..::..ItemIdCooldownEnabled Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType ItemIdCooldownEnabled
Public Const ItemIdCooldownEnabled As FightClassContionsType
public:
literal FightClassContionsType ItemIdCooldownEnabled

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


KnowSpell Field

FightClassContionsType..::..KnowSpell Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType KnowSpell
Public Const KnowSpell As FightClassContionsType
public:
literal FightClassContionsType KnowSpell

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


LightForce Field

FightClassContionsType..::..LightForce Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType LightForce
Public Const LightForce As FightClassContionsType
public:
literal FightClassContionsType LightForce

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


LuaScript Field

FightClassContionsType..::..LuaScript Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType LuaScript
Public Const LuaScript As FightClassContionsType
public:
literal FightClassContionsType LuaScript

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


Mana Field

FightClassContionsType..::..Mana Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType Mana
Public Const Mana As FightClassContionsType
public:
literal FightClassContionsType Mana

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


ManaPercent Field

FightClassContionsType..::..ManaPercent Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType ManaPercent
Public Const ManaPercent As FightClassContionsType
public:
literal FightClassContionsType ManaPercent

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


MeInCast Field

FightClassContionsType..::..MeInCast Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType MeInCast
Public Const MeInCast As FightClassContionsType
public:
literal FightClassContionsType MeInCast

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


MeInCombat Field

FightClassContionsType..::..MeInCombat Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType MeInCombat
Public Const MeInCombat As FightClassContionsType
public:
literal FightClassContionsType MeInCombat

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


MeInGroup Field

FightClassContionsType..::..MeInGroup Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType MeInGroup
Public Const MeInGroup As FightClassContionsType
public:
literal FightClassContionsType MeInGroup

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


MeInMove Field

FightClassContionsType..::..MeInMove Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType MeInMove
Public Const MeInMove As FightClassContionsType
public:
literal FightClassContionsType MeInMove

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


MeIsFlying Field

FightClassContionsType..::..MeIsFlying Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType MeIsFlying
Public Const MeIsFlying As FightClassContionsType
public:
literal FightClassContionsType MeIsFlying

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


MeIsStunned Field

FightClassContionsType..::..MeIsStunned Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType MeIsStunned
Public Const MeIsStunned As FightClassContionsType
public:
literal FightClassContionsType MeIsStunned

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


MeIsSwimming Field

FightClassContionsType..::..MeIsSwimming Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType MeIsSwimming
Public Const MeIsSwimming As FightClassContionsType
public:
literal FightClassContionsType MeIsSwimming

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


MeLevel Field

FightClassContionsType..::..MeLevel Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType MeLevel
Public Const MeLevel As FightClassContionsType
public:
literal FightClassContionsType MeLevel

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


None Field

FightClassContionsType..::..None Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType None
Public Const None As FightClassContionsType
public:
literal FightClassContionsType None

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


Pacified Field

FightClassContionsType..::..Pacified Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType Pacified
Public Const Pacified As FightClassContionsType
public:
literal FightClassContionsType Pacified

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


PartyMemberNear Field

FightClassContionsType..::..PartyMemberNear Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType PartyMemberNear
Public Const PartyMemberNear As FightClassContionsType
public:
literal FightClassContionsType PartyMemberNear

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


PartyMemberNearTarget Field

FightClassContionsType..::..PartyMemberNearTarget Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType PartyMemberNearTarget
Public Const PartyMemberNearTarget As FightClassContionsType
public:
literal FightClassContionsType PartyMemberNearTarget

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


PetBuff Field

FightClassContionsType..::..PetBuff Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType PetBuff
Public Const PetBuff As FightClassContionsType
public:
literal FightClassContionsType PetBuff

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


PetBuffCastedByMe Field

FightClassContionsType..::..PetBuffCastedByMe Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType PetBuffCastedByMe
Public Const PetBuffCastedByMe As FightClassContionsType
public:
literal FightClassContionsType PetBuffCastedByMe

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


PetCastingSpellName Field

FightClassContionsType..::..PetCastingSpellName Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType PetCastingSpellName
Public Const PetCastingSpellName As FightClassContionsType
public:
literal FightClassContionsType PetCastingSpellName

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


PetCastingTimeLeft Field

FightClassContionsType..::..PetCastingTimeLeft Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType PetCastingTimeLeft
Public Const PetCastingTimeLeft As FightClassContionsType
public:
literal FightClassContionsType PetCastingTimeLeft

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


PetConfused Field

FightClassContionsType..::..PetConfused Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType PetConfused
Public Const PetConfused As FightClassContionsType
public:
literal FightClassContionsType PetConfused

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


PetFleeing Field

FightClassContionsType..::..PetFleeing Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType PetFleeing
Public Const PetFleeing As FightClassContionsType
public:
literal FightClassContionsType PetFleeing

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


PetHealthPercent Field

FightClassContionsType..::..PetHealthPercent Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType PetHealthPercent
Public Const PetHealthPercent As FightClassContionsType
public:
literal FightClassContionsType PetHealthPercent

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


PetHealthPoints Field

FightClassContionsType..::..PetHealthPoints Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType PetHealthPoints
Public Const PetHealthPoints As FightClassContionsType
public:
literal FightClassContionsType PetHealthPoints

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


PetHealthPointsLost Field

FightClassContionsType..::..PetHealthPointsLost Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType PetHealthPointsLost
Public Const PetHealthPointsLost As FightClassContionsType
public:
literal FightClassContionsType PetHealthPointsLost

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


PetInCast Field

FightClassContionsType..::..PetInCast Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType PetInCast
Public Const PetInCast As FightClassContionsType
public:
literal FightClassContionsType PetInCast

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


PetInfluenced Field

FightClassContionsType..::..PetInfluenced Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType PetInfluenced
Public Const PetInfluenced As FightClassContionsType
public:
literal FightClassContionsType PetInfluenced

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


PetInMove Field

FightClassContionsType..::..PetInMove Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType PetInMove
Public Const PetInMove As FightClassContionsType
public:
literal FightClassContionsType PetInMove

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


PetIsFlying Field

FightClassContionsType..::..PetIsFlying Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType PetIsFlying
Public Const PetIsFlying As FightClassContionsType
public:
literal FightClassContionsType PetIsFlying

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


PetIsStunned Field

FightClassContionsType..::..PetIsStunned Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType PetIsStunned
Public Const PetIsStunned As FightClassContionsType
public:
literal FightClassContionsType PetIsStunned

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


PetIsSwimming Field

FightClassContionsType..::..PetIsSwimming Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType PetIsSwimming
Public Const PetIsSwimming As FightClassContionsType
public:
literal FightClassContionsType PetIsSwimming

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


PetPacified Field

FightClassContionsType..::..PetPacified Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType PetPacified
Public Const PetPacified As FightClassContionsType
public:
literal FightClassContionsType PetPacified

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


PetPossessed Field

FightClassContionsType..::..PetPossessed Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType PetPossessed
Public Const PetPossessed As FightClassContionsType
public:
literal FightClassContionsType PetPossessed

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


Possessed Field

FightClassContionsType..::..Possessed Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType Possessed
Public Const Possessed As FightClassContionsType
public:
literal FightClassContionsType Possessed

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


Rage Field

FightClassContionsType..::..Rage Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType Rage
Public Const Rage As FightClassContionsType
public:
literal FightClassContionsType Rage

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


RuneReadySlot1 Field

FightClassContionsType..::..RuneReadySlot1 Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType RuneReadySlot1
Public Const RuneReadySlot1 As FightClassContionsType
public:
literal FightClassContionsType RuneReadySlot1

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


RuneReadySlot2 Field

FightClassContionsType..::..RuneReadySlot2 Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType RuneReadySlot2
Public Const RuneReadySlot2 As FightClassContionsType
public:
literal FightClassContionsType RuneReadySlot2

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


RuneReadySlot3 Field

FightClassContionsType..::..RuneReadySlot3 Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType RuneReadySlot3
Public Const RuneReadySlot3 As FightClassContionsType
public:
literal FightClassContionsType RuneReadySlot3

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


RuneReadySlot4 Field

FightClassContionsType..::..RuneReadySlot4 Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType RuneReadySlot4
Public Const RuneReadySlot4 As FightClassContionsType
public:
literal FightClassContionsType RuneReadySlot4

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


RuneReadySlot5 Field

FightClassContionsType..::..RuneReadySlot5 Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType RuneReadySlot5
Public Const RuneReadySlot5 As FightClassContionsType
public:
literal FightClassContionsType RuneReadySlot5

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


RuneReadySlot6 Field

FightClassContionsType..::..RuneReadySlot6 Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType RuneReadySlot6
Public Const RuneReadySlot6 As FightClassContionsType
public:
literal FightClassContionsType RuneReadySlot6

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


Runes Field

FightClassContionsType..::..Runes Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType Runes
Public Const Runes As FightClassContionsType
public:
literal FightClassContionsType Runes

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


RunesBloodReadyCount Field

FightClassContionsType..::..RunesBloodReadyCount Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType RunesBloodReadyCount
Public Const RunesBloodReadyCount As FightClassContionsType
public:
literal FightClassContionsType RunesBloodReadyCount

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


RunesDeathReadyCount Field

FightClassContionsType..::..RunesDeathReadyCount Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType RunesDeathReadyCount
Public Const RunesDeathReadyCount As FightClassContionsType
public:
literal FightClassContionsType RunesDeathReadyCount

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


RunesFrostReadyCount Field

FightClassContionsType..::..RunesFrostReadyCount Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType RunesFrostReadyCount
Public Const RunesFrostReadyCount As FightClassContionsType
public:
literal FightClassContionsType RunesFrostReadyCount

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


RunesReadyCount Field

FightClassContionsType..::..RunesReadyCount Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType RunesReadyCount
Public Const RunesReadyCount As FightClassContionsType
public:
literal FightClassContionsType RunesReadyCount

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


RunesUnholyReadyCount Field

FightClassContionsType..::..RunesUnholyReadyCount Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType RunesUnholyReadyCount
Public Const RunesUnholyReadyCount As FightClassContionsType
public:
literal FightClassContionsType RunesUnholyReadyCount

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


RunicPower Field

FightClassContionsType..::..RunicPower Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType RunicPower
Public Const RunicPower As FightClassContionsType
public:
literal FightClassContionsType RunicPower

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


ShadowOrbs Field

FightClassContionsType..::..ShadowOrbs Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType ShadowOrbs
Public Const ShadowOrbs As FightClassContionsType
public:
literal FightClassContionsType ShadowOrbs

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


SoulShards Field

FightClassContionsType..::..SoulShards Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType SoulShards
Public Const SoulShards As FightClassContionsType
public:
literal FightClassContionsType SoulShards

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


SpellAffectedByAProc Field

FightClassContionsType..::..SpellAffectedByAProc Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType SpellAffectedByAProc
Public Const SpellAffectedByAProc As FightClassContionsType
public:
literal FightClassContionsType SpellAffectedByAProc

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


TargetBuff Field

FightClassContionsType..::..TargetBuff Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType TargetBuff
Public Const TargetBuff As FightClassContionsType
public:
literal FightClassContionsType TargetBuff

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


TargetBuffCastedByMe Field

FightClassContionsType..::..TargetBuffCastedByMe Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType TargetBuffCastedByMe
Public Const TargetBuffCastedByMe As FightClassContionsType
public:
literal FightClassContionsType TargetBuffCastedByMe

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


TargetCanInterruptCasting Field

FightClassContionsType..::..TargetCanInterruptCasting Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType TargetCanInterruptCasting
Public Const TargetCanInterruptCasting As FightClassContionsType
public:
literal FightClassContionsType TargetCanInterruptCasting

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


TargetCastingSpellName Field

FightClassContionsType..::..TargetCastingSpellName Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType TargetCastingSpellName
Public Const TargetCastingSpellName As FightClassContionsType
public:
literal FightClassContionsType TargetCastingSpellName

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


TargetCastingTimeLeft Field

FightClassContionsType..::..TargetCastingTimeLeft Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType TargetCastingTimeLeft
Public Const TargetCastingTimeLeft As FightClassContionsType
public:
literal FightClassContionsType TargetCastingTimeLeft

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


TargetConfused Field

FightClassContionsType..::..TargetConfused Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType TargetConfused
Public Const TargetConfused As FightClassContionsType
public:
literal FightClassContionsType TargetConfused

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


TargetDistance Field

FightClassContionsType..::..TargetDistance Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType TargetDistance
Public Const TargetDistance As FightClassContionsType
public:
literal FightClassContionsType TargetDistance

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


TargetFleeing Field

FightClassContionsType..::..TargetFleeing Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType TargetFleeing
Public Const TargetFleeing As FightClassContionsType
public:
literal FightClassContionsType TargetFleeing

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


TargetHealthPercent Field

FightClassContionsType..::..TargetHealthPercent Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType TargetHealthPercent
Public Const TargetHealthPercent As FightClassContionsType
public:
literal FightClassContionsType TargetHealthPercent

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


TargetHealthPoints Field

FightClassContionsType..::..TargetHealthPoints Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType TargetHealthPoints
Public Const TargetHealthPoints As FightClassContionsType
public:
literal FightClassContionsType TargetHealthPoints

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


TargetHealthPointsLost Field

FightClassContionsType..::..TargetHealthPointsLost Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType TargetHealthPointsLost
Public Const TargetHealthPointsLost As FightClassContionsType
public:
literal FightClassContionsType TargetHealthPointsLost

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


TargetInCast Field

FightClassContionsType..::..TargetInCast Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType TargetInCast
Public Const TargetInCast As FightClassContionsType
public:
literal FightClassContionsType TargetInCast

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


TargetInCombatRange Field

FightClassContionsType..::..TargetInCombatRange Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType TargetInCombatRange
Public Const TargetInCombatRange As FightClassContionsType
public:
literal FightClassContionsType TargetInCombatRange

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


TargetInfluenced Field

FightClassContionsType..::..TargetInfluenced Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType TargetInfluenced
Public Const TargetInfluenced As FightClassContionsType
public:
literal FightClassContionsType TargetInfluenced

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


TargetInMove Field

FightClassContionsType..::..TargetInMove Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType TargetInMove
Public Const TargetInMove As FightClassContionsType
public:
literal FightClassContionsType TargetInMove

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


TargetIsBoss Field

FightClassContionsType..::..TargetIsBoss Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType TargetIsBoss
Public Const TargetIsBoss As FightClassContionsType
public:
literal FightClassContionsType TargetIsBoss

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


TargetIsElite Field

FightClassContionsType..::..TargetIsElite Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType TargetIsElite
Public Const TargetIsElite As FightClassContionsType
public:
literal FightClassContionsType TargetIsElite

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


TargetIsFlying Field

FightClassContionsType..::..TargetIsFlying Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType TargetIsFlying
Public Const TargetIsFlying As FightClassContionsType
public:
literal FightClassContionsType TargetIsFlying

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


TargetIsPlayer Field

FightClassContionsType..::..TargetIsPlayer Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType TargetIsPlayer
Public Const TargetIsPlayer As FightClassContionsType
public:
literal FightClassContionsType TargetIsPlayer

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


TargetIsStunned Field

FightClassContionsType..::..TargetIsStunned Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType TargetIsStunned
Public Const TargetIsStunned As FightClassContionsType
public:
literal FightClassContionsType TargetIsStunned

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


TargetIsSummoned Field

FightClassContionsType..::..TargetIsSummoned Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType TargetIsSummoned
Public Const TargetIsSummoned As FightClassContionsType
public:
literal FightClassContionsType TargetIsSummoned

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


TargetIsSwimming Field

FightClassContionsType..::..TargetIsSwimming Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType TargetIsSwimming
Public Const TargetIsSwimming As FightClassContionsType
public:
literal FightClassContionsType TargetIsSwimming

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


TargetIsWorldBoss Field

FightClassContionsType..::..TargetIsWorldBoss Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType TargetIsWorldBoss
Public Const TargetIsWorldBoss As FightClassContionsType
public:
literal FightClassContionsType TargetIsWorldBoss

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


TargetLevel Field

FightClassContionsType..::..TargetLevel Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType TargetLevel
Public Const TargetLevel As FightClassContionsType
public:
literal FightClassContionsType TargetLevel

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


TargetPacified Field

FightClassContionsType..::..TargetPacified Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType TargetPacified
Public Const TargetPacified As FightClassContionsType
public:
literal FightClassContionsType TargetPacified

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


TargetPetIsMyTarget Field

FightClassContionsType..::..TargetPetIsMyTarget Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType TargetPetIsMyTarget
Public Const TargetPetIsMyTarget As FightClassContionsType
public:
literal FightClassContionsType TargetPetIsMyTarget

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


TargetPossessed Field

FightClassContionsType..::..TargetPossessed Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType TargetPossessed
Public Const TargetPossessed As FightClassContionsType
public:
literal FightClassContionsType TargetPossessed

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


TargetTargetingMe Field

FightClassContionsType..::..TargetTargetingMe Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType TargetTargetingMe
Public Const TargetTargetingMe As FightClassContionsType
public:
literal FightClassContionsType TargetTargetingMe

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


TargetTargetingMeOrMyPet Field

FightClassContionsType..::..TargetTargetingMeOrMyPet Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType TargetTargetingMeOrMyPet
Public Const TargetTargetingMeOrMyPet As FightClassContionsType
public:
literal FightClassContionsType TargetTargetingMeOrMyPet

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


TargetTargetingMyPet Field

FightClassContionsType..::..TargetTargetingMyPet Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType TargetTargetingMyPet
Public Const TargetTargetingMyPet As FightClassContionsType
public:
literal FightClassContionsType TargetTargetingMyPet

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


TargetTargetingPartyMember Field

FightClassContionsType..::..TargetTargetingPartyMember Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType TargetTargetingPartyMember
Public Const TargetTargetingPartyMember As FightClassContionsType
public:
literal FightClassContionsType TargetTargetingPartyMember

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


TotemAirExist Field

FightClassContionsType..::..TotemAirExist Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType TotemAirExist
Public Const TotemAirExist As FightClassContionsType
public:
literal FightClassContionsType TotemAirExist

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


TotemAirTimeLeftMs Field

FightClassContionsType..::..TotemAirTimeLeftMs Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType TotemAirTimeLeftMs
Public Const TotemAirTimeLeftMs As FightClassContionsType
public:
literal FightClassContionsType TotemAirTimeLeftMs

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


TotemEarthExist Field

FightClassContionsType..::..TotemEarthExist Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType TotemEarthExist
Public Const TotemEarthExist As FightClassContionsType
public:
literal FightClassContionsType TotemEarthExist

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


TotemEarthTimeLeftMs Field

FightClassContionsType..::..TotemEarthTimeLeftMs Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType TotemEarthTimeLeftMs
Public Const TotemEarthTimeLeftMs As FightClassContionsType
public:
literal FightClassContionsType TotemEarthTimeLeftMs

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


TotemFireExist Field

FightClassContionsType..::..TotemFireExist Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType TotemFireExist
Public Const TotemFireExist As FightClassContionsType
public:
literal FightClassContionsType TotemFireExist

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


TotemFireTimeLeftMs Field

FightClassContionsType..::..TotemFireTimeLeftMs Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType TotemFireTimeLeftMs
Public Const TotemFireTimeLeftMs As FightClassContionsType
public:
literal FightClassContionsType TotemFireTimeLeftMs

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


TotemWaterExist Field

FightClassContionsType..::..TotemWaterExist Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType TotemWaterExist
Public Const TotemWaterExist As FightClassContionsType
public:
literal FightClassContionsType TotemWaterExist

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


TotemWaterTimeLeftMs Field

FightClassContionsType..::..TotemWaterTimeLeftMs Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType TotemWaterTimeLeftMs
Public Const TotemWaterTimeLeftMs As FightClassContionsType
public:
literal FightClassContionsType TotemWaterTimeLeftMs

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


UnitAttackPlayerNear Field

FightClassContionsType..::..UnitAttackPlayerNear Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType UnitAttackPlayerNear
Public Const UnitAttackPlayerNear As FightClassContionsType
public:
literal FightClassContionsType UnitAttackPlayerNear

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


UnitAttackPlayerNearTarget Field

FightClassContionsType..::..UnitAttackPlayerNearTarget Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const FightClassContionsType UnitAttackPlayerNearTarget
Public Const UnitAttackPlayerNearTarget As FightClassContionsType
public:
literal FightClassContionsType UnitAttackPlayerNearTarget

See Also

FightClassContionsType Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


focus Field

UnitIdLua..::..focus Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitIdLua focus
Public Const focus As UnitIdLua
public:
literal UnitIdLua focus

See Also

UnitIdLua Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


mouseover Field

UnitIdLua..::..mouseover Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitIdLua mouseover
Public Const mouseover As UnitIdLua
public:
literal UnitIdLua mouseover

See Also

UnitIdLua Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


none Field

UnitIdLua..::..none Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitIdLua none
Public Const none As UnitIdLua
public:
literal UnitIdLua none

See Also

UnitIdLua Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


party1 Field

UnitIdLua..::..party1 Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitIdLua party1
Public Const party1 As UnitIdLua
public:
literal UnitIdLua party1

See Also

UnitIdLua Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


party2 Field

UnitIdLua..::..party2 Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitIdLua party2
Public Const party2 As UnitIdLua
public:
literal UnitIdLua party2

See Also

UnitIdLua Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


party3 Field

UnitIdLua..::..party3 Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitIdLua party3
Public Const party3 As UnitIdLua
public:
literal UnitIdLua party3

See Also

UnitIdLua Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


party4 Field

UnitIdLua..::..party4 Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitIdLua party4
Public Const party4 As UnitIdLua
public:
literal UnitIdLua party4

See Also

UnitIdLua Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


partypet1 Field

UnitIdLua..::..partypet1 Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitIdLua partypet1
Public Const partypet1 As UnitIdLua
public:
literal UnitIdLua partypet1

See Also

UnitIdLua Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


partypet2 Field

UnitIdLua..::..partypet2 Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitIdLua partypet2
Public Const partypet2 As UnitIdLua
public:
literal UnitIdLua partypet2

See Also

UnitIdLua Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


partypet3 Field

UnitIdLua..::..partypet3 Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitIdLua partypet3
Public Const partypet3 As UnitIdLua
public:
literal UnitIdLua partypet3

See Also

UnitIdLua Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


partypet4 Field

UnitIdLua..::..partypet4 Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitIdLua partypet4
Public Const partypet4 As UnitIdLua
public:
literal UnitIdLua partypet4

See Also

UnitIdLua Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


pet Field

UnitIdLua..::..pet Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitIdLua pet
Public Const pet As UnitIdLua
public:
literal UnitIdLua pet

See Also

UnitIdLua Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


player Field

UnitIdLua..::..player Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitIdLua player
Public Const player As UnitIdLua
public:
literal UnitIdLua player

See Also

UnitIdLua Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


target Field

UnitIdLua..::..target Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const UnitIdLua target
Public Const target As UnitIdLua
public:
literal UnitIdLua target

See Also

UnitIdLua Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


Auto Field

YesNoAuto..::..Auto Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const YesNoAuto Auto
Public Const Auto As YesNoAuto
public:
literal YesNoAuto Auto

See Also

YesNoAuto Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


No Field

YesNoAuto..::..No Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const YesNoAuto No
Public Const No As YesNoAuto
public:
literal YesNoAuto No

See Also

YesNoAuto Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


Yes Field

YesNoAuto..::..Yes Field

Namespace: wManager.Wow.Helpers.FightClassCreator
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const YesNoAuto Yes
Public Const Yes As YesNoAuto
public:
literal YesNoAuto Yes

See Also

YesNoAuto Enumeration
wManager.Wow.Helpers.FightClassCreator Namespace


Drink Field

ConsumableType..::..Drink Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ItemsManager..::..ConsumableType Drink
Public Const Drink As ItemsManager..::..ConsumableType
public:
literal ItemsManager..::..ConsumableType Drink

See Also

ItemsManager..::..ConsumableType Enumeration
wManager.Wow.Helpers Namespace


Food Field

ConsumableType..::..Food Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const ItemsManager..::..ConsumableType Food
Public Const Food As ItemsManager..::..ConsumableType
public:
literal ItemsManager..::..ConsumableType Food

See Also

ItemsManager..::..ConsumableType Enumeration
wManager.Wow.Helpers Namespace


DownKey Field

MoveAction..::..DownKey Field

Down (strop) keyboard key

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Move..::..MoveAction DownKey
Public Const DownKey As Move..::..MoveAction
public:
literal Move..::..MoveAction DownKey

See Also

Move..::..MoveAction Enumeration
wManager.Wow.Helpers Namespace


PressKey Field

MoveAction..::..PressKey Field

Press keyboard key (DownKey and UpKey)

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Move..::..MoveAction PressKey
Public Const PressKey As Move..::..MoveAction
public:
literal Move..::..MoveAction PressKey

See Also

Move..::..MoveAction Enumeration
wManager.Wow.Helpers Namespace


UpKey Field

MoveAction..::..UpKey Field

Up (start) keyboard key

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Move..::..MoveAction UpKey
Public Const UpKey As Move..::..MoveAction
public:
literal Move..::..MoveAction UpKey

See Also

Move..::..MoveAction Enumeration
wManager.Wow.Helpers Namespace


Bidirectional Field

OffMeshConnectionType..::..Bidirectional Field

The bidirectional (can be used in both directions)

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const PathFinder..::..OffMeshConnectionType Bidirectional
Public Const Bidirectional As PathFinder..::..OffMeshConnectionType
public:
literal PathFinder..::..OffMeshConnectionType Bidirectional

See Also

PathFinder..::..OffMeshConnectionType Enumeration
wManager.Wow.Helpers Namespace


Unidirectional Field

OffMeshConnectionType..::..Unidirectional Field

The unidirectional

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const PathFinder..::..OffMeshConnectionType Unidirectional
Public Const Unidirectional As PathFinder..::..OffMeshConnectionType
public:
literal PathFinder..::..OffMeshConnectionType Unidirectional

See Also

PathFinder..::..OffMeshConnectionType Enumeration
wManager.Wow.Helpers Namespace


Alliance Field

Faction..::..Alliance Field

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[JsonPropertyAttribute]
public const FindPathPacket..::..Faction Alliance
<JsonPropertyAttribute> _
Public Const Alliance As FindPathPacket..::..Faction
[JsonPropertyAttribute]
public:
literal FindPathPacket..::..Faction Alliance

See Also

FindPathPacket..::..Faction Enumeration
wManager.Wow.Helpers.PathFinderClass Namespace


Horde Field

Faction..::..Horde Field

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[JsonPropertyAttribute]
public const FindPathPacket..::..Faction Horde
<JsonPropertyAttribute> _
Public Const Horde As FindPathPacket..::..Faction
[JsonPropertyAttribute]
public:
literal FindPathPacket..::..Faction Horde

See Also

FindPathPacket..::..Faction Enumeration
wManager.Wow.Helpers.PathFinderClass Namespace


Neutral Field

Faction..::..Neutral Field

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[JsonPropertyAttribute]
public const FindPathPacket..::..Faction Neutral
<JsonPropertyAttribute> _
Public Const Neutral As FindPathPacket..::..Faction
[JsonPropertyAttribute]
public:
literal FindPathPacket..::..Faction Neutral

See Also

FindPathPacket..::..Faction Enumeration
wManager.Wow.Helpers.PathFinderClass Namespace


Bidirectional Field

OffMeshConnectionType..::..Bidirectional Field

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[JsonPropertyAttribute]
public const FindPathPacket..::..OffMeshConnection..::..OffMeshConnectionType Bidirectional
<JsonPropertyAttribute> _
Public Const Bidirectional As FindPathPacket..::..OffMeshConnection..::..OffMeshConnectionType
[JsonPropertyAttribute]
public:
literal FindPathPacket..::..OffMeshConnection..::..OffMeshConnectionType Bidirectional

See Also

FindPathPacket..::..OffMeshConnection..::..OffMeshConnectionType Enumeration
wManager.Wow.Helpers.PathFinderClass Namespace


Unidirectional Field

OffMeshConnectionType..::..Unidirectional Field

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
[JsonPropertyAttribute]
public const FindPathPacket..::..OffMeshConnection..::..OffMeshConnectionType Unidirectional
<JsonPropertyAttribute> _
Public Const Unidirectional As FindPathPacket..::..OffMeshConnection..::..OffMeshConnectionType
[JsonPropertyAttribute]
public:
literal FindPathPacket..::..OffMeshConnection..::..OffMeshConnectionType Unidirectional

See Also

FindPathPacket..::..OffMeshConnection..::..OffMeshConnectionType Enumeration
wManager.Wow.Helpers.PathFinderClass Namespace


FindPath Field

Packets..::..FindPath Field

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Packets FindPath
Public Const FindPath As Packets
public:
literal Packets FindPath

See Also

Packets Enumeration
wManager.Wow.Helpers.PathFinderClass Namespace


FindZPosition Field

Packets..::..FindZPosition Field

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Packets FindZPosition
Public Const FindZPosition As Packets
public:
literal Packets FindZPosition

See Also

Packets Enumeration
wManager.Wow.Helpers.PathFinderClass Namespace


GO Field

Packets..::..GO Field

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Packets GO
Public Const GO As Packets
public:
literal Packets GO

See Also

Packets Enumeration
wManager.Wow.Helpers.PathFinderClass Namespace


InfoCurrentSession Field

Packets..::..InfoCurrentSession Field

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Packets InfoCurrentSession
Public Const InfoCurrentSession As Packets
public:
literal Packets InfoCurrentSession

See Also

Packets Enumeration
wManager.Wow.Helpers.PathFinderClass Namespace


IsOnline Field

Packets..::..IsOnline Field

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Packets IsOnline
Public Const IsOnline As Packets
public:
literal Packets IsOnline

See Also

Packets Enumeration
wManager.Wow.Helpers.PathFinderClass Namespace


None Field

Packets..::..None Field

Namespace: wManager.Wow.Helpers.PathFinderClass
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Packets None
Public Const None As Packets
public:
literal Packets None

See Also

Packets Enumeration
wManager.Wow.Helpers.PathFinderClass Namespace


Ally Field

PetFaction..::..Ally Field

The ally

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const PetBattles..::..PetFaction Ally
Public Const Ally As PetBattles..::..PetFaction
public:
literal PetBattles..::..PetFaction Ally

See Also

PetBattles..::..PetFaction Enumeration
wManager.Wow.Helpers Namespace


Enemy Field

PetFaction..::..Enemy Field

The enemy

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const PetBattles..::..PetFaction Enemy
Public Const Enemy As PetBattles..::..PetFaction
public:
literal PetBattles..::..PetFaction Enemy

See Also

PetBattles..::..PetFaction Enumeration
wManager.Wow.Helpers Namespace


Common Field

PetQuality..::..Common Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const PetBattles..::..PetQuality Common
Public Const Common As PetBattles..::..PetQuality
public:
literal PetBattles..::..PetQuality Common

See Also

PetBattles..::..PetQuality Enumeration
wManager.Wow.Helpers Namespace


Epic Field

PetQuality..::..Epic Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const PetBattles..::..PetQuality Epic
Public Const Epic As PetBattles..::..PetQuality
public:
literal PetBattles..::..PetQuality Epic

See Also

PetBattles..::..PetQuality Enumeration
wManager.Wow.Helpers Namespace


Legendary Field

PetQuality..::..Legendary Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const PetBattles..::..PetQuality Legendary
Public Const Legendary As PetBattles..::..PetQuality
public:
literal PetBattles..::..PetQuality Legendary

See Also

PetBattles..::..PetQuality Enumeration
wManager.Wow.Helpers Namespace


Poor Field

PetQuality..::..Poor Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const PetBattles..::..PetQuality Poor
Public Const Poor As PetBattles..::..PetQuality
public:
literal PetBattles..::..PetQuality Poor

See Also

PetBattles..::..PetQuality Enumeration
wManager.Wow.Helpers Namespace


Rare Field

PetQuality..::..Rare Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const PetBattles..::..PetQuality Rare
Public Const Rare As PetBattles..::..PetQuality
public:
literal PetBattles..::..PetQuality Rare

See Also

PetBattles..::..PetQuality Enumeration
wManager.Wow.Helpers Namespace


Uncommon Field

PetQuality..::..Uncommon Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const PetBattles..::..PetQuality Uncommon
Public Const Uncommon As PetBattles..::..PetQuality
public:
literal PetBattles..::..PetQuality Uncommon

See Also

PetBattles..::..PetQuality Enumeration
wManager.Wow.Helpers Namespace


Aquatic Field

PetType..::..Aquatic Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const PetBattles..::..PetType Aquatic
Public Const Aquatic As PetBattles..::..PetType
public:
literal PetBattles..::..PetType Aquatic

See Also

PetBattles..::..PetType Enumeration
wManager.Wow.Helpers Namespace


Beast Field

PetType..::..Beast Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const PetBattles..::..PetType Beast
Public Const Beast As PetBattles..::..PetType
public:
literal PetBattles..::..PetType Beast

See Also

PetBattles..::..PetType Enumeration
wManager.Wow.Helpers Namespace


Critter Field

PetType..::..Critter Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const PetBattles..::..PetType Critter
Public Const Critter As PetBattles..::..PetType
public:
literal PetBattles..::..PetType Critter

See Also

PetBattles..::..PetType Enumeration
wManager.Wow.Helpers Namespace


Dragonkin Field

PetType..::..Dragonkin Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const PetBattles..::..PetType Dragonkin
Public Const Dragonkin As PetBattles..::..PetType
public:
literal PetBattles..::..PetType Dragonkin

See Also

PetBattles..::..PetType Enumeration
wManager.Wow.Helpers Namespace


Elemental Field

PetType..::..Elemental Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const PetBattles..::..PetType Elemental
Public Const Elemental As PetBattles..::..PetType
public:
literal PetBattles..::..PetType Elemental

See Also

PetBattles..::..PetType Enumeration
wManager.Wow.Helpers Namespace


Flying Field

PetType..::..Flying Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const PetBattles..::..PetType Flying
Public Const Flying As PetBattles..::..PetType
public:
literal PetBattles..::..PetType Flying

See Also

PetBattles..::..PetType Enumeration
wManager.Wow.Helpers Namespace


Humanoid Field

PetType..::..Humanoid Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const PetBattles..::..PetType Humanoid
Public Const Humanoid As PetBattles..::..PetType
public:
literal PetBattles..::..PetType Humanoid

See Also

PetBattles..::..PetType Enumeration
wManager.Wow.Helpers Namespace


Magic Field

PetType..::..Magic Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const PetBattles..::..PetType Magic
Public Const Magic As PetBattles..::..PetType
public:
literal PetBattles..::..PetType Magic

See Also

PetBattles..::..PetType Enumeration
wManager.Wow.Helpers Namespace


Mechanical Field

PetType..::..Mechanical Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const PetBattles..::..PetType Mechanical
Public Const Mechanical As PetBattles..::..PetType
public:
literal PetBattles..::..PetType Mechanical

See Also

PetBattles..::..PetType Enumeration
wManager.Wow.Helpers Namespace


Undead Field

PetType..::..Undead Field

Namespace: wManager.Wow.Helpers
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const PetBattles..::..PetType Undead
Public Const Undead As PetBattles..::..PetType
public:
literal PetBattles..::..PetType Undead

See Also

PetBattles..::..PetType Enumeration
wManager.Wow.Helpers Namespace


AlignPad Field

ContainerFields..::..AlignPad Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..ContainerFields AlignPad
Public Const AlignPad As Descriptors..::..ContainerFields
public:
literal Descriptors..::..ContainerFields AlignPad

See Also

Descriptors..::..ContainerFields Enumeration
wManager.Wow.Patchables Namespace


NumSlots Field

ContainerFields..::..NumSlots Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..ContainerFields NumSlots
Public Const NumSlots As Descriptors..::..ContainerFields
public:
literal Descriptors..::..ContainerFields NumSlots

See Also

Descriptors..::..ContainerFields Enumeration
wManager.Wow.Patchables Namespace


Slot1 Field

ContainerFields..::..Slot1 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..ContainerFields Slot1
Public Const Slot1 As Descriptors..::..ContainerFields
public:
literal Descriptors..::..ContainerFields Slot1

See Also

Descriptors..::..ContainerFields Enumeration
wManager.Wow.Patchables Namespace


bytes1 Field

CorpseFields..::..bytes1 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..CorpseFields bytes1
Public Const bytes1 As Descriptors..::..CorpseFields
public:
literal Descriptors..::..CorpseFields bytes1

See Also

Descriptors..::..CorpseFields Enumeration
wManager.Wow.Patchables Namespace


Bytes2 Field

CorpseFields..::..Bytes2 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..CorpseFields Bytes2
Public Const Bytes2 As Descriptors..::..CorpseFields
public:
literal Descriptors..::..CorpseFields Bytes2

See Also

Descriptors..::..CorpseFields Enumeration
wManager.Wow.Patchables Namespace


DisplayID Field

CorpseFields..::..DisplayID Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..CorpseFields DisplayID
Public Const DisplayID As Descriptors..::..CorpseFields
public:
literal Descriptors..::..CorpseFields DisplayID

See Also

Descriptors..::..CorpseFields Enumeration
wManager.Wow.Patchables Namespace


Dynamicflags Field

CorpseFields..::..Dynamicflags Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..CorpseFields Dynamicflags
Public Const Dynamicflags As Descriptors..::..CorpseFields
public:
literal Descriptors..::..CorpseFields Dynamicflags

See Also

Descriptors..::..CorpseFields Enumeration
wManager.Wow.Patchables Namespace


Flags Field

CorpseFields..::..Flags Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..CorpseFields Flags
Public Const Flags As Descriptors..::..CorpseFields
public:
literal Descriptors..::..CorpseFields Flags

See Also

Descriptors..::..CorpseFields Enumeration
wManager.Wow.Patchables Namespace


Guild Field

CorpseFields..::..Guild Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..CorpseFields Guild
Public Const Guild As Descriptors..::..CorpseFields
public:
literal Descriptors..::..CorpseFields Guild

See Also

Descriptors..::..CorpseFields Enumeration
wManager.Wow.Patchables Namespace


Item Field

CorpseFields..::..Item Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..CorpseFields Item
Public Const Item As Descriptors..::..CorpseFields
public:
literal Descriptors..::..CorpseFields Item

See Also

Descriptors..::..CorpseFields Enumeration
wManager.Wow.Patchables Namespace


Owner Field

CorpseFields..::..Owner Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..CorpseFields Owner
Public Const Owner As Descriptors..::..CorpseFields
public:
literal Descriptors..::..CorpseFields Owner

See Also

Descriptors..::..CorpseFields Enumeration
wManager.Wow.Patchables Namespace


Pad Field

CorpseFields..::..Pad Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..CorpseFields Pad
Public Const Pad As Descriptors..::..CorpseFields
public:
literal Descriptors..::..CorpseFields Pad

See Also

Descriptors..::..CorpseFields Enumeration
wManager.Wow.Patchables Namespace


Party Field

CorpseFields..::..Party Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..CorpseFields Party
Public Const Party As Descriptors..::..CorpseFields
public:
literal Descriptors..::..CorpseFields Party

See Also

Descriptors..::..CorpseFields Enumeration
wManager.Wow.Patchables Namespace


Bytes Field

DynamicObjectFields..::..Bytes Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..DynamicObjectFields Bytes
Public Const Bytes As Descriptors..::..DynamicObjectFields
public:
literal Descriptors..::..DynamicObjectFields Bytes

See Also

Descriptors..::..DynamicObjectFields Enumeration
wManager.Wow.Patchables Namespace


Caster Field

DynamicObjectFields..::..Caster Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..DynamicObjectFields Caster
Public Const Caster As Descriptors..::..DynamicObjectFields
public:
literal Descriptors..::..DynamicObjectFields Caster

See Also

Descriptors..::..DynamicObjectFields Enumeration
wManager.Wow.Patchables Namespace


CastTime Field

DynamicObjectFields..::..CastTime Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..DynamicObjectFields CastTime
Public Const CastTime As Descriptors..::..DynamicObjectFields
public:
literal Descriptors..::..DynamicObjectFields CastTime

See Also

Descriptors..::..DynamicObjectFields Enumeration
wManager.Wow.Patchables Namespace


Radius Field

DynamicObjectFields..::..Radius Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..DynamicObjectFields Radius
Public Const Radius As Descriptors..::..DynamicObjectFields
public:
literal Descriptors..::..DynamicObjectFields Radius

See Also

Descriptors..::..DynamicObjectFields Enumeration
wManager.Wow.Patchables Namespace


SpellID Field

DynamicObjectFields..::..SpellID Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..DynamicObjectFields SpellID
Public Const SpellID As Descriptors..::..DynamicObjectFields
public:
literal Descriptors..::..DynamicObjectFields SpellID

See Also

Descriptors..::..DynamicObjectFields Enumeration
wManager.Wow.Patchables Namespace


Bytes1 Field

GameObjectFields..::..Bytes1 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..GameObjectFields Bytes1
Public Const Bytes1 As Descriptors..::..GameObjectFields
public:
literal Descriptors..::..GameObjectFields Bytes1

See Also

Descriptors..::..GameObjectFields Enumeration
wManager.Wow.Patchables Namespace


CreatedBy Field

GameObjectFields..::..CreatedBy Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..GameObjectFields CreatedBy
Public Const CreatedBy As Descriptors..::..GameObjectFields
public:
literal Descriptors..::..GameObjectFields CreatedBy

See Also

Descriptors..::..GameObjectFields Enumeration
wManager.Wow.Patchables Namespace


DisplayID Field

GameObjectFields..::..DisplayID Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..GameObjectFields DisplayID
Public Const DisplayID As Descriptors..::..GameObjectFields
public:
literal Descriptors..::..GameObjectFields DisplayID

See Also

Descriptors..::..GameObjectFields Enumeration
wManager.Wow.Patchables Namespace


Dynamic Field

GameObjectFields..::..Dynamic Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..GameObjectFields Dynamic
Public Const Dynamic As Descriptors..::..GameObjectFields
public:
literal Descriptors..::..GameObjectFields Dynamic

See Also

Descriptors..::..GameObjectFields Enumeration
wManager.Wow.Patchables Namespace


Faction Field

GameObjectFields..::..Faction Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..GameObjectFields Faction
Public Const Faction As Descriptors..::..GameObjectFields
public:
literal Descriptors..::..GameObjectFields Faction

See Also

Descriptors..::..GameObjectFields Enumeration
wManager.Wow.Patchables Namespace


Flags Field

GameObjectFields..::..Flags Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..GameObjectFields Flags
Public Const Flags As Descriptors..::..GameObjectFields
public:
literal Descriptors..::..GameObjectFields Flags

See Also

Descriptors..::..GameObjectFields Enumeration
wManager.Wow.Patchables Namespace


Level Field

GameObjectFields..::..Level Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..GameObjectFields Level
Public Const Level As Descriptors..::..GameObjectFields
public:
literal Descriptors..::..GameObjectFields Level

See Also

Descriptors..::..GameObjectFields Enumeration
wManager.Wow.Patchables Namespace


ParentRotation Field

GameObjectFields..::..ParentRotation Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..GameObjectFields ParentRotation
Public Const ParentRotation As Descriptors..::..GameObjectFields
public:
literal Descriptors..::..GameObjectFields ParentRotation

See Also

Descriptors..::..GameObjectFields Enumeration
wManager.Wow.Patchables Namespace


ContainedIn Field

ItemFields..::..ContainedIn Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..ItemFields ContainedIn
Public Const ContainedIn As Descriptors..::..ItemFields
public:
literal Descriptors..::..ItemFields ContainedIn

See Also

Descriptors..::..ItemFields Enumeration
wManager.Wow.Patchables Namespace


CreatePlayedTime Field

ItemFields..::..CreatePlayedTime Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..ItemFields CreatePlayedTime
Public Const CreatePlayedTime As Descriptors..::..ItemFields
public:
literal Descriptors..::..ItemFields CreatePlayedTime

See Also

Descriptors..::..ItemFields Enumeration
wManager.Wow.Patchables Namespace


Creator Field

ItemFields..::..Creator Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..ItemFields Creator
Public Const Creator As Descriptors..::..ItemFields
public:
literal Descriptors..::..ItemFields Creator

See Also

Descriptors..::..ItemFields Enumeration
wManager.Wow.Patchables Namespace


Durability Field

ItemFields..::..Durability Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..ItemFields Durability
Public Const Durability As Descriptors..::..ItemFields
public:
literal Descriptors..::..ItemFields Durability

See Also

Descriptors..::..ItemFields Enumeration
wManager.Wow.Patchables Namespace


Duration Field

ItemFields..::..Duration Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..ItemFields Duration
Public Const Duration As Descriptors..::..ItemFields
public:
literal Descriptors..::..ItemFields Duration

See Also

Descriptors..::..ItemFields Enumeration
wManager.Wow.Patchables Namespace


Enchantment11 Field

ItemFields..::..Enchantment11 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..ItemFields Enchantment11
Public Const Enchantment11 As Descriptors..::..ItemFields
public:
literal Descriptors..::..ItemFields Enchantment11

See Also

Descriptors..::..ItemFields Enumeration
wManager.Wow.Patchables Namespace


Enchantment13 Field

ItemFields..::..Enchantment13 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..ItemFields Enchantment13
Public Const Enchantment13 As Descriptors..::..ItemFields
public:
literal Descriptors..::..ItemFields Enchantment13

See Also

Descriptors..::..ItemFields Enumeration
wManager.Wow.Patchables Namespace


Enchantment21 Field

ItemFields..::..Enchantment21 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..ItemFields Enchantment21
Public Const Enchantment21 As Descriptors..::..ItemFields
public:
literal Descriptors..::..ItemFields Enchantment21

See Also

Descriptors..::..ItemFields Enumeration
wManager.Wow.Patchables Namespace


Enchantment23 Field

ItemFields..::..Enchantment23 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..ItemFields Enchantment23
Public Const Enchantment23 As Descriptors..::..ItemFields
public:
literal Descriptors..::..ItemFields Enchantment23

See Also

Descriptors..::..ItemFields Enumeration
wManager.Wow.Patchables Namespace


Enchantment31 Field

ItemFields..::..Enchantment31 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..ItemFields Enchantment31
Public Const Enchantment31 As Descriptors..::..ItemFields
public:
literal Descriptors..::..ItemFields Enchantment31

See Also

Descriptors..::..ItemFields Enumeration
wManager.Wow.Patchables Namespace


Enchantment33 Field

ItemFields..::..Enchantment33 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..ItemFields Enchantment33
Public Const Enchantment33 As Descriptors..::..ItemFields
public:
literal Descriptors..::..ItemFields Enchantment33

See Also

Descriptors..::..ItemFields Enumeration
wManager.Wow.Patchables Namespace


Enchantment41 Field

ItemFields..::..Enchantment41 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..ItemFields Enchantment41
Public Const Enchantment41 As Descriptors..::..ItemFields
public:
literal Descriptors..::..ItemFields Enchantment41

See Also

Descriptors..::..ItemFields Enumeration
wManager.Wow.Patchables Namespace


Enchantment43 Field

ItemFields..::..Enchantment43 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..ItemFields Enchantment43
Public Const Enchantment43 As Descriptors..::..ItemFields
public:
literal Descriptors..::..ItemFields Enchantment43

See Also

Descriptors..::..ItemFields Enumeration
wManager.Wow.Patchables Namespace


Enchantment51 Field

ItemFields..::..Enchantment51 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..ItemFields Enchantment51
Public Const Enchantment51 As Descriptors..::..ItemFields
public:
literal Descriptors..::..ItemFields Enchantment51

See Also

Descriptors..::..ItemFields Enumeration
wManager.Wow.Patchables Namespace


Enchantment53 Field

ItemFields..::..Enchantment53 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..ItemFields Enchantment53
Public Const Enchantment53 As Descriptors..::..ItemFields
public:
literal Descriptors..::..ItemFields Enchantment53

See Also

Descriptors..::..ItemFields Enumeration
wManager.Wow.Patchables Namespace


Enchantment61 Field

ItemFields..::..Enchantment61 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..ItemFields Enchantment61
Public Const Enchantment61 As Descriptors..::..ItemFields
public:
literal Descriptors..::..ItemFields Enchantment61

See Also

Descriptors..::..ItemFields Enumeration
wManager.Wow.Patchables Namespace


Enchantment63 Field

ItemFields..::..Enchantment63 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..ItemFields Enchantment63
Public Const Enchantment63 As Descriptors..::..ItemFields
public:
literal Descriptors..::..ItemFields Enchantment63

See Also

Descriptors..::..ItemFields Enumeration
wManager.Wow.Patchables Namespace


Enchantment71 Field

ItemFields..::..Enchantment71 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..ItemFields Enchantment71
Public Const Enchantment71 As Descriptors..::..ItemFields
public:
literal Descriptors..::..ItemFields Enchantment71

See Also

Descriptors..::..ItemFields Enumeration
wManager.Wow.Patchables Namespace


Enchantment73 Field

ItemFields..::..Enchantment73 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..ItemFields Enchantment73
Public Const Enchantment73 As Descriptors..::..ItemFields
public:
literal Descriptors..::..ItemFields Enchantment73

See Also

Descriptors..::..ItemFields Enumeration
wManager.Wow.Patchables Namespace


Enchantment81 Field

ItemFields..::..Enchantment81 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..ItemFields Enchantment81
Public Const Enchantment81 As Descriptors..::..ItemFields
public:
literal Descriptors..::..ItemFields Enchantment81

See Also

Descriptors..::..ItemFields Enumeration
wManager.Wow.Patchables Namespace


Enchantment83 Field

ItemFields..::..Enchantment83 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..ItemFields Enchantment83
Public Const Enchantment83 As Descriptors..::..ItemFields
public:
literal Descriptors..::..ItemFields Enchantment83

See Also

Descriptors..::..ItemFields Enumeration
wManager.Wow.Patchables Namespace


Enchantment91 Field

ItemFields..::..Enchantment91 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..ItemFields Enchantment91
Public Const Enchantment91 As Descriptors..::..ItemFields
public:
literal Descriptors..::..ItemFields Enchantment91

See Also

Descriptors..::..ItemFields Enumeration
wManager.Wow.Patchables Namespace


Enchantment93 Field

ItemFields..::..Enchantment93 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..ItemFields Enchantment93
Public Const Enchantment93 As Descriptors..::..ItemFields
public:
literal Descriptors..::..ItemFields Enchantment93

See Also

Descriptors..::..ItemFields Enumeration
wManager.Wow.Patchables Namespace


Enchantment101 Field

ItemFields..::..Enchantment101 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..ItemFields Enchantment101
Public Const Enchantment101 As Descriptors..::..ItemFields
public:
literal Descriptors..::..ItemFields Enchantment101

See Also

Descriptors..::..ItemFields Enumeration
wManager.Wow.Patchables Namespace


Enchantment103 Field

ItemFields..::..Enchantment103 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..ItemFields Enchantment103
Public Const Enchantment103 As Descriptors..::..ItemFields
public:
literal Descriptors..::..ItemFields Enchantment103

See Also

Descriptors..::..ItemFields Enumeration
wManager.Wow.Patchables Namespace


Enchantment111 Field

ItemFields..::..Enchantment111 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..ItemFields Enchantment111
Public Const Enchantment111 As Descriptors..::..ItemFields
public:
literal Descriptors..::..ItemFields Enchantment111

See Also

Descriptors..::..ItemFields Enumeration
wManager.Wow.Patchables Namespace


Enchantment113 Field

ItemFields..::..Enchantment113 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..ItemFields Enchantment113
Public Const Enchantment113 As Descriptors..::..ItemFields
public:
literal Descriptors..::..ItemFields Enchantment113

See Also

Descriptors..::..ItemFields Enumeration
wManager.Wow.Patchables Namespace


Enchantment121 Field

ItemFields..::..Enchantment121 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..ItemFields Enchantment121
Public Const Enchantment121 As Descriptors..::..ItemFields
public:
literal Descriptors..::..ItemFields Enchantment121

See Also

Descriptors..::..ItemFields Enumeration
wManager.Wow.Patchables Namespace


Enchantment123 Field

ItemFields..::..Enchantment123 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..ItemFields Enchantment123
Public Const Enchantment123 As Descriptors..::..ItemFields
public:
literal Descriptors..::..ItemFields Enchantment123

See Also

Descriptors..::..ItemFields Enumeration
wManager.Wow.Patchables Namespace


Flags Field

ItemFields..::..Flags Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..ItemFields Flags
Public Const Flags As Descriptors..::..ItemFields
public:
literal Descriptors..::..ItemFields Flags

See Also

Descriptors..::..ItemFields Enumeration
wManager.Wow.Patchables Namespace


Giftcreator Field

ItemFields..::..Giftcreator Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..ItemFields Giftcreator
Public Const Giftcreator As Descriptors..::..ItemFields
public:
literal Descriptors..::..ItemFields Giftcreator

See Also

Descriptors..::..ItemFields Enumeration
wManager.Wow.Patchables Namespace


MaxDurability Field

ItemFields..::..MaxDurability Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..ItemFields MaxDurability
Public Const MaxDurability As Descriptors..::..ItemFields
public:
literal Descriptors..::..ItemFields MaxDurability

See Also

Descriptors..::..ItemFields Enumeration
wManager.Wow.Patchables Namespace


Owner Field

ItemFields..::..Owner Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..ItemFields Owner
Public Const Owner As Descriptors..::..ItemFields
public:
literal Descriptors..::..ItemFields Owner

See Also

Descriptors..::..ItemFields Enumeration
wManager.Wow.Patchables Namespace


Pad Field

ItemFields..::..Pad Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..ItemFields Pad
Public Const Pad As Descriptors..::..ItemFields
public:
literal Descriptors..::..ItemFields Pad

See Also

Descriptors..::..ItemFields Enumeration
wManager.Wow.Patchables Namespace


PropertySeed Field

ItemFields..::..PropertySeed Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..ItemFields PropertySeed
Public Const PropertySeed As Descriptors..::..ItemFields
public:
literal Descriptors..::..ItemFields PropertySeed

See Also

Descriptors..::..ItemFields Enumeration
wManager.Wow.Patchables Namespace


RandomPropertiesid Field

ItemFields..::..RandomPropertiesid Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..ItemFields RandomPropertiesid
Public Const RandomPropertiesid As Descriptors..::..ItemFields
public:
literal Descriptors..::..ItemFields RandomPropertiesid

See Also

Descriptors..::..ItemFields Enumeration
wManager.Wow.Patchables Namespace


SpellCharges Field

ItemFields..::..SpellCharges Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..ItemFields SpellCharges
Public Const SpellCharges As Descriptors..::..ItemFields
public:
literal Descriptors..::..ItemFields SpellCharges

See Also

Descriptors..::..ItemFields Enumeration
wManager.Wow.Patchables Namespace


StackCount Field

ItemFields..::..StackCount Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..ItemFields StackCount
Public Const StackCount As Descriptors..::..ItemFields
public:
literal Descriptors..::..ItemFields StackCount

See Also

Descriptors..::..ItemFields Enumeration
wManager.Wow.Patchables Namespace


Multiplicator Field

Descriptors..::..Multiplicator Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const uint Multiplicator
Public Const Multiplicator As UInteger
public:
literal unsigned int^ Multiplicator

See Also

Descriptors
wManager.Wow.Patchables Namespace


EntryID Field

ObjectFields..::..EntryID Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..ObjectFields EntryID
Public Const EntryID As Descriptors..::..ObjectFields
public:
literal Descriptors..::..ObjectFields EntryID

See Also

Descriptors..::..ObjectFields Enumeration
wManager.Wow.Patchables Namespace


Guid Field

ObjectFields..::..Guid Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..ObjectFields Guid
Public Const Guid As Descriptors..::..ObjectFields
public:
literal Descriptors..::..ObjectFields Guid

See Also

Descriptors..::..ObjectFields Enumeration
wManager.Wow.Patchables Namespace


Padding Field

ObjectFields..::..Padding Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..ObjectFields Padding
Public Const Padding As Descriptors..::..ObjectFields
public:
literal Descriptors..::..ObjectFields Padding

See Also

Descriptors..::..ObjectFields Enumeration
wManager.Wow.Patchables Namespace


Scale Field

ObjectFields..::..Scale Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..ObjectFields Scale
Public Const Scale As Descriptors..::..ObjectFields
public:
literal Descriptors..::..ObjectFields Scale

See Also

Descriptors..::..ObjectFields Enumeration
wManager.Wow.Patchables Namespace


Type Field

ObjectFields..::..Type Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..ObjectFields Type
Public Const Type As Descriptors..::..ObjectFields
public:
literal Descriptors..::..ObjectFields Type

See Also

Descriptors..::..ObjectFields Enumeration
wManager.Wow.Patchables Namespace


Ammoid Field

PlayerFields..::..Ammoid Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields Ammoid
Public Const Ammoid As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields Ammoid

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


ARENACurrency Field

PlayerFields..::..ARENACurrency Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields ARENACurrency
Public Const ARENACurrency As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields ARENACurrency

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


ARENATEAMINFO11 Field

PlayerFields..::..ARENATEAMINFO11 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields ARENATEAMINFO11
Public Const ARENATEAMINFO11 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields ARENATEAMINFO11

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


BankBagSlot1 Field

PlayerFields..::..BankBagSlot1 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields BankBagSlot1
Public Const BankBagSlot1 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields BankBagSlot1

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


BankSlot1 Field

PlayerFields..::..BankSlot1 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields BankSlot1
Public Const BankSlot1 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields BankSlot1

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


BlockPercentagE Field

PlayerFields..::..BlockPercentagE Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields BlockPercentagE
Public Const BlockPercentagE As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields BlockPercentagE

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


BuyBackPrice1 Field

PlayerFields..::..BuyBackPrice1 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields BuyBackPrice1
Public Const BuyBackPrice1 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields BuyBackPrice1

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


BuyBackTimeStamp1 Field

PlayerFields..::..BuyBackTimeStamp1 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields BuyBackTimeStamp1
Public Const BuyBackTimeStamp1 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields BuyBackTimeStamp1

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


Bytes Field

PlayerFields..::..Bytes Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields Bytes
Public Const Bytes As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields Bytes

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


Bytes2 Field

PlayerFields..::..Bytes2 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields Bytes2
Public Const Bytes2 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields Bytes2

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


Bytes3 Field

PlayerFields..::..Bytes3 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields Bytes3
Public Const Bytes3 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields Bytes3

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


CharacterPointS1 Field

PlayerFields..::..CharacterPointS1 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields CharacterPointS1
Public Const CharacterPointS1 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields CharacterPointS1

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


CharacterPointS2 Field

PlayerFields..::..CharacterPointS2 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields CharacterPointS2
Public Const CharacterPointS2 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields CharacterPointS2

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


ChosenTitle Field

PlayerFields..::..ChosenTitle Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields ChosenTitle
Public Const ChosenTitle As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields ChosenTitle

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


Coinage Field

PlayerFields..::..Coinage Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields Coinage
Public Const Coinage As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields Coinage

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


COMBATRATING1 Field

PlayerFields..::..COMBATRATING1 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields COMBATRATING1
Public Const COMBATRATING1 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields COMBATRATING1

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


CritPercentage Field

PlayerFields..::..CritPercentage Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields CritPercentage
Public Const CritPercentage As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields CritPercentage

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


CurrencyTokenSlot1 Field

PlayerFields..::..CurrencyTokenSlot1 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields CurrencyTokenSlot1
Public Const CurrencyTokenSlot1 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields CurrencyTokenSlot1

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


DailyQuests1 Field

PlayerFields..::..DailyQuests1 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields DailyQuests1
Public Const DailyQuests1 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields DailyQuests1

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


DodgePercentage Field

PlayerFields..::..DodgePercentage Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields DodgePercentage
Public Const DodgePercentage As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields DodgePercentage

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


DuelArbiter Field

PlayerFields..::..DuelArbiter Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields DuelArbiter
Public Const DuelArbiter As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields DuelArbiter

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


DuelTeam Field

PlayerFields..::..DuelTeam Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields DuelTeam
Public Const DuelTeam As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields DuelTeam

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


Expertise Field

PlayerFields..::..Expertise Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields Expertise
Public Const Expertise As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields Expertise

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


ExploredZoneS1 Field

PlayerFields..::..ExploredZoneS1 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields ExploredZoneS1
Public Const ExploredZoneS1 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields ExploredZoneS1

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


FakeInebriation Field

PlayerFields..::..FakeInebriation Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields FakeInebriation
Public Const FakeInebriation As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields FakeInebriation

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


Farsight Field

PlayerFields..::..Farsight Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields Farsight
Public Const Farsight As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields Farsight

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


FieldBytes Field

PlayerFields..::..FieldBytes Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields FieldBytes
Public Const FieldBytes As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields FieldBytes

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


FieldBytes2 Field

PlayerFields..::..FieldBytes2 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields FieldBytes2
Public Const FieldBytes2 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields FieldBytes2

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


Flags Field

PlayerFields..::..Flags Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields Flags
Public Const Flags As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields Flags

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


Glyphs1 Field

PlayerFields..::..Glyphs1 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields Glyphs1
Public Const Glyphs1 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields Glyphs1

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


GlyphsEnabled Field

PlayerFields..::..GlyphsEnabled Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields GlyphsEnabled
Public Const GlyphsEnabled As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields GlyphsEnabled

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


GlyphSlots1 Field

PlayerFields..::..GlyphSlots1 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields GlyphSlots1
Public Const GlyphSlots1 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields GlyphSlots1

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


GuildID Field

PlayerFields..::..GuildID Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields GuildID
Public Const GuildID As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields GuildID

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


GuildRank Field

PlayerFields..::..GuildRank Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields GuildRank
Public Const GuildRank As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields GuildRank

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


GuildTimeStamp Field

PlayerFields..::..GuildTimeStamp Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields GuildTimeStamp
Public Const GuildTimeStamp As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields GuildTimeStamp

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


HONORCurrency Field

PlayerFields..::..HONORCurrency Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields HONORCurrency
Public Const HONORCurrency As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields HONORCurrency

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


InvSlotHead Field

PlayerFields..::..InvSlotHead Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields InvSlotHead
Public Const InvSlotHead As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields InvSlotHead

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


KeyringSlot1 Field

PlayerFields..::..KeyringSlot1 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields KeyringSlot1
Public Const KeyringSlot1 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields KeyringSlot1

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


Kills Field

PlayerFields..::..Kills Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields Kills
Public Const Kills As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields Kills

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


KnownCurrencies Field

PlayerFields..::..KnownCurrencies Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields KnownCurrencies
Public Const KnownCurrencies As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields KnownCurrencies

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


KnownTitles Field

PlayerFields..::..KnownTitles Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields KnownTitles
Public Const KnownTitles As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields KnownTitles

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


KnownTitles1 Field

PlayerFields..::..KnownTitles1 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields KnownTitles1
Public Const KnownTitles1 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields KnownTitles1

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


KnownTitles2 Field

PlayerFields..::..KnownTitles2 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields KnownTitles2
Public Const KnownTitles2 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields KnownTitles2

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


LifetimeHonorbaleKills Field

PlayerFields..::..LifetimeHonorbaleKills Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields LifetimeHonorbaleKills
Public Const LifetimeHonorbaleKills As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields LifetimeHonorbaleKills

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


MaxLEVEL Field

PlayerFields..::..MaxLEVEL Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields MaxLEVEL
Public Const MaxLEVEL As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields MaxLEVEL

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


ModDamageDoneNeg Field

PlayerFields..::..ModDamageDoneNeg Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields ModDamageDoneNeg
Public Const ModDamageDoneNeg As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields ModDamageDoneNeg

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


ModDamageDonePct Field

PlayerFields..::..ModDamageDonePct Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields ModDamageDonePct
Public Const ModDamageDonePct As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields ModDamageDonePct

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


ModDamageDonePos Field

PlayerFields..::..ModDamageDonePos Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields ModDamageDonePos
Public Const ModDamageDonePos As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields ModDamageDonePos

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


ModHealingDonePct Field

PlayerFields..::..ModHealingDonePct Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields ModHealingDonePct
Public Const ModHealingDonePct As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields ModHealingDonePct

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


ModHEALINGDonePos Field

PlayerFields..::..ModHEALINGDonePos Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields ModHEALINGDonePos
Public Const ModHEALINGDonePos As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields ModHEALINGDonePos

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


ModHealingPct Field

PlayerFields..::..ModHealingPct Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields ModHealingPct
Public Const ModHealingPct As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields ModHealingPct

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


ModTargetPhysicalResistance Field

PlayerFields..::..ModTargetPhysicalResistance Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields ModTargetPhysicalResistance
Public Const ModTargetPhysicalResistance As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields ModTargetPhysicalResistance

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


ModTargetResistance Field

PlayerFields..::..ModTargetResistance Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields ModTargetResistance
Public Const ModTargetResistance As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields ModTargetResistance

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


NextLevelXP Field

PlayerFields..::..NextLevelXP Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields NextLevelXP
Public Const NextLevelXP As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields NextLevelXP

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


NoReagentCost1 Field

PlayerFields..::..NoReagentCost1 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields NoReagentCost1
Public Const NoReagentCost1 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields NoReagentCost1

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


OffhandCritPercentage Field

PlayerFields..::..OffhandCritPercentage Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields OffhandCritPercentage
Public Const OffhandCritPercentage As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields OffhandCritPercentage

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


OffhandExPertise Field

PlayerFields..::..OffhandExPertise Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields OffhandExPertise
Public Const OffhandExPertise As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields OffhandExPertise

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


PackSlot1 Field

PlayerFields..::..PackSlot1 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields PackSlot1
Public Const PackSlot1 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields PackSlot1

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


Pad0 Field

PlayerFields..::..Pad0 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields Pad0
Public Const Pad0 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields Pad0

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


ParryPercentage Field

PlayerFields..::..ParryPercentage Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields ParryPercentage
Public Const ParryPercentage As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields ParryPercentage

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


PetSpellPower Field

PlayerFields..::..PetSpellPower Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields PetSpellPower
Public Const PetSpellPower As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields PetSpellPower

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


PvpMedals Field

PlayerFields..::..PvpMedals Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields PvpMedals
Public Const PvpMedals As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields PvpMedals

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog11 Field

PlayerFields..::..QuestLog11 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog11
Public Const QuestLog11 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog11

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog12 Field

PlayerFields..::..QuestLog12 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog12
Public Const QuestLog12 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog12

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog13 Field

PlayerFields..::..QuestLog13 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog13
Public Const QuestLog13 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog13

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog14 Field

PlayerFields..::..QuestLog14 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog14
Public Const QuestLog14 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog14

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog21 Field

PlayerFields..::..QuestLog21 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog21
Public Const QuestLog21 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog21

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog22 Field

PlayerFields..::..QuestLog22 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog22
Public Const QuestLog22 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog22

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog23 Field

PlayerFields..::..QuestLog23 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog23
Public Const QuestLog23 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog23

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog25 Field

PlayerFields..::..QuestLog25 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog25
Public Const QuestLog25 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog25

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog31 Field

PlayerFields..::..QuestLog31 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog31
Public Const QuestLog31 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog31

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog32 Field

PlayerFields..::..QuestLog32 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog32
Public Const QuestLog32 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog32

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog33 Field

PlayerFields..::..QuestLog33 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog33
Public Const QuestLog33 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog33

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog35 Field

PlayerFields..::..QuestLog35 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog35
Public Const QuestLog35 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog35

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog41 Field

PlayerFields..::..QuestLog41 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog41
Public Const QuestLog41 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog41

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog42 Field

PlayerFields..::..QuestLog42 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog42
Public Const QuestLog42 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog42

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog43 Field

PlayerFields..::..QuestLog43 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog43
Public Const QuestLog43 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog43

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog45 Field

PlayerFields..::..QuestLog45 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog45
Public Const QuestLog45 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog45

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog51 Field

PlayerFields..::..QuestLog51 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog51
Public Const QuestLog51 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog51

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog52 Field

PlayerFields..::..QuestLog52 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog52
Public Const QuestLog52 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog52

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog53 Field

PlayerFields..::..QuestLog53 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog53
Public Const QuestLog53 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog53

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog55 Field

PlayerFields..::..QuestLog55 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog55
Public Const QuestLog55 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog55

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog61 Field

PlayerFields..::..QuestLog61 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog61
Public Const QuestLog61 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog61

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog62 Field

PlayerFields..::..QuestLog62 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog62
Public Const QuestLog62 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog62

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog63 Field

PlayerFields..::..QuestLog63 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog63
Public Const QuestLog63 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog63

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog65 Field

PlayerFields..::..QuestLog65 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog65
Public Const QuestLog65 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog65

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog71 Field

PlayerFields..::..QuestLog71 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog71
Public Const QuestLog71 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog71

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog72 Field

PlayerFields..::..QuestLog72 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog72
Public Const QuestLog72 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog72

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog73 Field

PlayerFields..::..QuestLog73 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog73
Public Const QuestLog73 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog73

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog75 Field

PlayerFields..::..QuestLog75 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog75
Public Const QuestLog75 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog75

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog81 Field

PlayerFields..::..QuestLog81 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog81
Public Const QuestLog81 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog81

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog82 Field

PlayerFields..::..QuestLog82 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog82
Public Const QuestLog82 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog82

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog83 Field

PlayerFields..::..QuestLog83 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog83
Public Const QuestLog83 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog83

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog85 Field

PlayerFields..::..QuestLog85 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog85
Public Const QuestLog85 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog85

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog91 Field

PlayerFields..::..QuestLog91 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog91
Public Const QuestLog91 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog91

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog92 Field

PlayerFields..::..QuestLog92 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog92
Public Const QuestLog92 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog92

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog93 Field

PlayerFields..::..QuestLog93 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog93
Public Const QuestLog93 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog93

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog95 Field

PlayerFields..::..QuestLog95 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog95
Public Const QuestLog95 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog95

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog101 Field

PlayerFields..::..QuestLog101 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog101
Public Const QuestLog101 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog101

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog102 Field

PlayerFields..::..QuestLog102 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog102
Public Const QuestLog102 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog102

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog103 Field

PlayerFields..::..QuestLog103 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog103
Public Const QuestLog103 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog103

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog105 Field

PlayerFields..::..QuestLog105 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog105
Public Const QuestLog105 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog105

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog111 Field

PlayerFields..::..QuestLog111 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog111
Public Const QuestLog111 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog111

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog112 Field

PlayerFields..::..QuestLog112 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog112
Public Const QuestLog112 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog112

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog113 Field

PlayerFields..::..QuestLog113 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog113
Public Const QuestLog113 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog113

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog115 Field

PlayerFields..::..QuestLog115 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog115
Public Const QuestLog115 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog115

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog121 Field

PlayerFields..::..QuestLog121 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog121
Public Const QuestLog121 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog121

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog122 Field

PlayerFields..::..QuestLog122 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog122
Public Const QuestLog122 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog122

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog123 Field

PlayerFields..::..QuestLog123 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog123
Public Const QuestLog123 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog123

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog125 Field

PlayerFields..::..QuestLog125 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog125
Public Const QuestLog125 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog125

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog131 Field

PlayerFields..::..QuestLog131 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog131
Public Const QuestLog131 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog131

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog132 Field

PlayerFields..::..QuestLog132 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog132
Public Const QuestLog132 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog132

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog133 Field

PlayerFields..::..QuestLog133 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog133
Public Const QuestLog133 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog133

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog135 Field

PlayerFields..::..QuestLog135 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog135
Public Const QuestLog135 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog135

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog141 Field

PlayerFields..::..QuestLog141 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog141
Public Const QuestLog141 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog141

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog142 Field

PlayerFields..::..QuestLog142 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog142
Public Const QuestLog142 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog142

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog143 Field

PlayerFields..::..QuestLog143 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog143
Public Const QuestLog143 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog143

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog145 Field

PlayerFields..::..QuestLog145 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog145
Public Const QuestLog145 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog145

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog151 Field

PlayerFields..::..QuestLog151 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog151
Public Const QuestLog151 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog151

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog152 Field

PlayerFields..::..QuestLog152 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog152
Public Const QuestLog152 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog152

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog153 Field

PlayerFields..::..QuestLog153 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog153
Public Const QuestLog153 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog153

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog155 Field

PlayerFields..::..QuestLog155 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog155
Public Const QuestLog155 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog155

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog161 Field

PlayerFields..::..QuestLog161 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog161
Public Const QuestLog161 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog161

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog162 Field

PlayerFields..::..QuestLog162 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog162
Public Const QuestLog162 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog162

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog163 Field

PlayerFields..::..QuestLog163 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog163
Public Const QuestLog163 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog163

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog165 Field

PlayerFields..::..QuestLog165 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog165
Public Const QuestLog165 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog165

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog171 Field

PlayerFields..::..QuestLog171 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog171
Public Const QuestLog171 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog171

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog172 Field

PlayerFields..::..QuestLog172 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog172
Public Const QuestLog172 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog172

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog173 Field

PlayerFields..::..QuestLog173 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog173
Public Const QuestLog173 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog173

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog175 Field

PlayerFields..::..QuestLog175 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog175
Public Const QuestLog175 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog175

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog181 Field

PlayerFields..::..QuestLog181 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog181
Public Const QuestLog181 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog181

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog182 Field

PlayerFields..::..QuestLog182 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog182
Public Const QuestLog182 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog182

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog183 Field

PlayerFields..::..QuestLog183 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog183
Public Const QuestLog183 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog183

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog185 Field

PlayerFields..::..QuestLog185 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog185
Public Const QuestLog185 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog185

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog191 Field

PlayerFields..::..QuestLog191 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog191
Public Const QuestLog191 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog191

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog192 Field

PlayerFields..::..QuestLog192 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog192
Public Const QuestLog192 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog192

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog193 Field

PlayerFields..::..QuestLog193 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog193
Public Const QuestLog193 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog193

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog195 Field

PlayerFields..::..QuestLog195 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog195
Public Const QuestLog195 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog195

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog201 Field

PlayerFields..::..QuestLog201 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog201
Public Const QuestLog201 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog201

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog202 Field

PlayerFields..::..QuestLog202 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog202
Public Const QuestLog202 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog202

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog203 Field

PlayerFields..::..QuestLog203 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog203
Public Const QuestLog203 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog203

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog205 Field

PlayerFields..::..QuestLog205 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog205
Public Const QuestLog205 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog205

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog211 Field

PlayerFields..::..QuestLog211 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog211
Public Const QuestLog211 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog211

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog212 Field

PlayerFields..::..QuestLog212 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog212
Public Const QuestLog212 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog212

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog213 Field

PlayerFields..::..QuestLog213 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog213
Public Const QuestLog213 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog213

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog215 Field

PlayerFields..::..QuestLog215 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog215
Public Const QuestLog215 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog215

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog221 Field

PlayerFields..::..QuestLog221 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog221
Public Const QuestLog221 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog221

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog222 Field

PlayerFields..::..QuestLog222 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog222
Public Const QuestLog222 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog222

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog223 Field

PlayerFields..::..QuestLog223 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog223
Public Const QuestLog223 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog223

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog225 Field

PlayerFields..::..QuestLog225 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog225
Public Const QuestLog225 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog225

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog231 Field

PlayerFields..::..QuestLog231 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog231
Public Const QuestLog231 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog231

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog232 Field

PlayerFields..::..QuestLog232 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog232
Public Const QuestLog232 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog232

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog233 Field

PlayerFields..::..QuestLog233 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog233
Public Const QuestLog233 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog233

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog235 Field

PlayerFields..::..QuestLog235 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog235
Public Const QuestLog235 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog235

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog241 Field

PlayerFields..::..QuestLog241 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog241
Public Const QuestLog241 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog241

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog242 Field

PlayerFields..::..QuestLog242 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog242
Public Const QuestLog242 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog242

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog243 Field

PlayerFields..::..QuestLog243 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog243
Public Const QuestLog243 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog243

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog245 Field

PlayerFields..::..QuestLog245 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog245
Public Const QuestLog245 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog245

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog251 Field

PlayerFields..::..QuestLog251 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog251
Public Const QuestLog251 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog251

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog252 Field

PlayerFields..::..QuestLog252 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog252
Public Const QuestLog252 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog252

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog253 Field

PlayerFields..::..QuestLog253 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog253
Public Const QuestLog253 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog253

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


QuestLog255 Field

PlayerFields..::..QuestLog255 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields QuestLog255
Public Const QuestLog255 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields QuestLog255

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


RangedCritPercentage Field

PlayerFields..::..RangedCritPercentage Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields RangedCritPercentage
Public Const RangedCritPercentage As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields RangedCritPercentage

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


RestStateExperience Field

PlayerFields..::..RestStateExperience Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields RestStateExperience
Public Const RestStateExperience As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields RestStateExperience

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


RuneRegen1 Field

PlayerFields..::..RuneRegen1 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields RuneRegen1
Public Const RuneRegen1 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields RuneRegen1

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


SelfREsSpell Field

PlayerFields..::..SelfREsSpell Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields SelfREsSpell
Public Const SelfREsSpell As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields SelfREsSpell

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


ShieldBlock Field

PlayerFields..::..ShieldBlock Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields ShieldBlock
Public Const ShieldBlock As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields ShieldBlock

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


ShieldBlockCritPercentage Field

PlayerFields..::..ShieldBlockCritPercentage Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields ShieldBlockCritPercentage
Public Const ShieldBlockCritPercentage As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields ShieldBlockCritPercentage

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


SkillInfo11 Field

PlayerFields..::..SkillInfo11 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields SkillInfo11
Public Const SkillInfo11 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields SkillInfo11

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


SpellCritPercentage1 Field

PlayerFields..::..SpellCritPercentage1 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields SpellCritPercentage1
Public Const SpellCritPercentage1 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields SpellCritPercentage1

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


TodayContribution Field

PlayerFields..::..TodayContribution Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields TodayContribution
Public Const TodayContribution As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields TodayContribution

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


TrackCreatureMask Field

PlayerFields..::..TrackCreatureMask Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields TrackCreatureMask
Public Const TrackCreatureMask As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields TrackCreatureMask

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


TrackResourceMask Field

PlayerFields..::..TrackResourceMask Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields TrackResourceMask
Public Const TrackResourceMask As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields TrackResourceMask

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


VendorBuyBackSlot1 Field

PlayerFields..::..VendorBuyBackSlot1 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields VendorBuyBackSlot1
Public Const VendorBuyBackSlot1 As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields VendorBuyBackSlot1

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


VisibleItem1Enchantment Field

PlayerFields..::..VisibleItem1Enchantment Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields VisibleItem1Enchantment
Public Const VisibleItem1Enchantment As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields VisibleItem1Enchantment

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


VisibleItem1Entryid Field

PlayerFields..::..VisibleItem1Entryid Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields VisibleItem1Entryid
Public Const VisibleItem1Entryid As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields VisibleItem1Entryid

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


VisibleItem2Enchantment Field

PlayerFields..::..VisibleItem2Enchantment Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields VisibleItem2Enchantment
Public Const VisibleItem2Enchantment As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields VisibleItem2Enchantment

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


VisibleItem2Entryid Field

PlayerFields..::..VisibleItem2Entryid Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields VisibleItem2Entryid
Public Const VisibleItem2Entryid As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields VisibleItem2Entryid

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


VisibleItem3Enchantment Field

PlayerFields..::..VisibleItem3Enchantment Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields VisibleItem3Enchantment
Public Const VisibleItem3Enchantment As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields VisibleItem3Enchantment

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


VisibleItem3Entryid Field

PlayerFields..::..VisibleItem3Entryid Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields VisibleItem3Entryid
Public Const VisibleItem3Entryid As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields VisibleItem3Entryid

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


VisibleItem4Enchantment Field

PlayerFields..::..VisibleItem4Enchantment Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields VisibleItem4Enchantment
Public Const VisibleItem4Enchantment As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields VisibleItem4Enchantment

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


VisibleItem4Entryid Field

PlayerFields..::..VisibleItem4Entryid Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields VisibleItem4Entryid
Public Const VisibleItem4Entryid As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields VisibleItem4Entryid

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


VisibleItem5Enchantment Field

PlayerFields..::..VisibleItem5Enchantment Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields VisibleItem5Enchantment
Public Const VisibleItem5Enchantment As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields VisibleItem5Enchantment

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


VisibleItem5Entryid Field

PlayerFields..::..VisibleItem5Entryid Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields VisibleItem5Entryid
Public Const VisibleItem5Entryid As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields VisibleItem5Entryid

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


VisibleItem6Enchantment Field

PlayerFields..::..VisibleItem6Enchantment Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields VisibleItem6Enchantment
Public Const VisibleItem6Enchantment As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields VisibleItem6Enchantment

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


VisibleItem6Entryid Field

PlayerFields..::..VisibleItem6Entryid Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields VisibleItem6Entryid
Public Const VisibleItem6Entryid As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields VisibleItem6Entryid

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


VisibleItem7Enchantment Field

PlayerFields..::..VisibleItem7Enchantment Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields VisibleItem7Enchantment
Public Const VisibleItem7Enchantment As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields VisibleItem7Enchantment

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


VisibleItem7Entryid Field

PlayerFields..::..VisibleItem7Entryid Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields VisibleItem7Entryid
Public Const VisibleItem7Entryid As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields VisibleItem7Entryid

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


VisibleItem8Enchantment Field

PlayerFields..::..VisibleItem8Enchantment Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields VisibleItem8Enchantment
Public Const VisibleItem8Enchantment As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields VisibleItem8Enchantment

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


VisibleItem8Entryid Field

PlayerFields..::..VisibleItem8Entryid Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields VisibleItem8Entryid
Public Const VisibleItem8Entryid As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields VisibleItem8Entryid

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


VisibleItem9Enchantment Field

PlayerFields..::..VisibleItem9Enchantment Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields VisibleItem9Enchantment
Public Const VisibleItem9Enchantment As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields VisibleItem9Enchantment

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


VisibleItem9Entryid Field

PlayerFields..::..VisibleItem9Entryid Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields VisibleItem9Entryid
Public Const VisibleItem9Entryid As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields VisibleItem9Entryid

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


VisibleItem10Enchantment Field

PlayerFields..::..VisibleItem10Enchantment Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields VisibleItem10Enchantment
Public Const VisibleItem10Enchantment As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields VisibleItem10Enchantment

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


VisibleItem10Entryid Field

PlayerFields..::..VisibleItem10Entryid Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields VisibleItem10Entryid
Public Const VisibleItem10Entryid As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields VisibleItem10Entryid

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


VisibleItem11Enchantment Field

PlayerFields..::..VisibleItem11Enchantment Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields VisibleItem11Enchantment
Public Const VisibleItem11Enchantment As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields VisibleItem11Enchantment

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


VisibleItem11Entryid Field

PlayerFields..::..VisibleItem11Entryid Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields VisibleItem11Entryid
Public Const VisibleItem11Entryid As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields VisibleItem11Entryid

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


VisibleItem12Enchantment Field

PlayerFields..::..VisibleItem12Enchantment Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields VisibleItem12Enchantment
Public Const VisibleItem12Enchantment As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields VisibleItem12Enchantment

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


VisibleItem12Entryid Field

PlayerFields..::..VisibleItem12Entryid Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields VisibleItem12Entryid
Public Const VisibleItem12Entryid As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields VisibleItem12Entryid

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


VisibleItem13Enchantment Field

PlayerFields..::..VisibleItem13Enchantment Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields VisibleItem13Enchantment
Public Const VisibleItem13Enchantment As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields VisibleItem13Enchantment

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


VisibleItem13Entryid Field

PlayerFields..::..VisibleItem13Entryid Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields VisibleItem13Entryid
Public Const VisibleItem13Entryid As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields VisibleItem13Entryid

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


VisibleItem14Enchantment Field

PlayerFields..::..VisibleItem14Enchantment Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields VisibleItem14Enchantment
Public Const VisibleItem14Enchantment As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields VisibleItem14Enchantment

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


VisibleItem14Entryid Field

PlayerFields..::..VisibleItem14Entryid Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields VisibleItem14Entryid
Public Const VisibleItem14Entryid As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields VisibleItem14Entryid

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


VisibleItem15Enchantment Field

PlayerFields..::..VisibleItem15Enchantment Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields VisibleItem15Enchantment
Public Const VisibleItem15Enchantment As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields VisibleItem15Enchantment

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


VisibleItem15Entryid Field

PlayerFields..::..VisibleItem15Entryid Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields VisibleItem15Entryid
Public Const VisibleItem15Entryid As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields VisibleItem15Entryid

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


VisibleItem16Enchantment Field

PlayerFields..::..VisibleItem16Enchantment Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields VisibleItem16Enchantment
Public Const VisibleItem16Enchantment As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields VisibleItem16Enchantment

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


VisibleItem16Entryid Field

PlayerFields..::..VisibleItem16Entryid Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields VisibleItem16Entryid
Public Const VisibleItem16Entryid As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields VisibleItem16Entryid

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


VisibleItem17Enchantment Field

PlayerFields..::..VisibleItem17Enchantment Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields VisibleItem17Enchantment
Public Const VisibleItem17Enchantment As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields VisibleItem17Enchantment

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


VisibleItem17Entryid Field

PlayerFields..::..VisibleItem17Entryid Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields VisibleItem17Entryid
Public Const VisibleItem17Entryid As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields VisibleItem17Entryid

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


VisibleItem18Enchantment Field

PlayerFields..::..VisibleItem18Enchantment Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields VisibleItem18Enchantment
Public Const VisibleItem18Enchantment As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields VisibleItem18Enchantment

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


VisibleItem18Entryid Field

PlayerFields..::..VisibleItem18Entryid Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields VisibleItem18Entryid
Public Const VisibleItem18Entryid As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields VisibleItem18Entryid

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


VisibleItem19Enchantment Field

PlayerFields..::..VisibleItem19Enchantment Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields VisibleItem19Enchantment
Public Const VisibleItem19Enchantment As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields VisibleItem19Enchantment

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


VisibleItem19Entryid Field

PlayerFields..::..VisibleItem19Entryid Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields VisibleItem19Entryid
Public Const VisibleItem19Entryid As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields VisibleItem19Entryid

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


WATCHEDFACTIONINDEX Field

PlayerFields..::..WATCHEDFACTIONINDEX Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields WATCHEDFACTIONINDEX
Public Const WATCHEDFACTIONINDEX As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields WATCHEDFACTIONINDEX

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


XP Field

PlayerFields..::..XP Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields XP
Public Const XP As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields XP

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


YesterdayContribution Field

PlayerFields..::..YesterdayContribution Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..PlayerFields YesterdayContribution
Public Const YesterdayContribution As Descriptors..::..PlayerFields
public:
literal Descriptors..::..PlayerFields YesterdayContribution

See Also

Descriptors..::..PlayerFields Enumeration
wManager.Wow.Patchables Namespace


StartDescriptors Field

Descriptors..::..StartDescriptors Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const uint StartDescriptors
Public Const StartDescriptors As UInteger
public:
literal unsigned int^ StartDescriptors

See Also

Descriptors
wManager.Wow.Patchables Namespace


AttackPower Field

UnitFields..::..AttackPower Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields AttackPower
Public Const AttackPower As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields AttackPower

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


AttackPowerMods Field

UnitFields..::..AttackPowerMods Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields AttackPowerMods
Public Const AttackPowerMods As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields AttackPowerMods

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


AttackPowerMultiplier Field

UnitFields..::..AttackPowerMultiplier Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields AttackPowerMultiplier
Public Const AttackPowerMultiplier As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields AttackPowerMultiplier

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


auraState Field

UnitFields..::..auraState Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields auraState
Public Const auraState As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields auraState

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


BaseAttackTime Field

UnitFields..::..BaseAttackTime Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields BaseAttackTime
Public Const BaseAttackTime As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields BaseAttackTime

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


BaseHealth Field

UnitFields..::..BaseHealth Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields BaseHealth
Public Const BaseHealth As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields BaseHealth

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


BaseMana Field

UnitFields..::..BaseMana Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields BaseMana
Public Const BaseMana As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields BaseMana

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


BoundingRadius Field

UnitFields..::..BoundingRadius Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields BoundingRadius
Public Const BoundingRadius As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields BoundingRadius

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


Bytes0 Field

UnitFields..::..Bytes0 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields Bytes0
Public Const Bytes0 As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields Bytes0

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


Bytes1 Field

UnitFields..::..Bytes1 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields Bytes1
Public Const Bytes1 As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields Bytes1

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


Bytes2 Field

UnitFields..::..Bytes2 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields Bytes2
Public Const Bytes2 As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields Bytes2

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


ChannelObject Field

UnitFields..::..ChannelObject Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields ChannelObject
Public Const ChannelObject As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields ChannelObject

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


Charm Field

UnitFields..::..Charm Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields Charm
Public Const Charm As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields Charm

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


CharmedBy Field

UnitFields..::..CharmedBy Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields CharmedBy
Public Const CharmedBy As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields CharmedBy

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


CombatReach Field

UnitFields..::..CombatReach Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields CombatReach
Public Const CombatReach As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields CombatReach

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


CreatedBy Field

UnitFields..::..CreatedBy Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields CreatedBy
Public Const CreatedBy As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields CreatedBy

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


CreatedBySpell Field

UnitFields..::..CreatedBySpell Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields CreatedBySpell
Public Const CreatedBySpell As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields CreatedBySpell

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


Critter Field

UnitFields..::..Critter Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields Critter
Public Const Critter As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields Critter

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


DisplayID Field

UnitFields..::..DisplayID Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields DisplayID
Public Const DisplayID As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields DisplayID

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


DynamicFlags Field

UnitFields..::..DynamicFlags Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields DynamicFlags
Public Const DynamicFlags As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields DynamicFlags

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


FactionTemplate Field

UnitFields..::..FactionTemplate Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields FactionTemplate
Public Const FactionTemplate As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields FactionTemplate

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


Flags Field

UnitFields..::..Flags Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields Flags
Public Const Flags As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields Flags

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


Flags2 Field

UnitFields..::..Flags2 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields Flags2
Public Const Flags2 As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields Flags2

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


Health Field

UnitFields..::..Health Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields Health
Public Const Health As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields Health

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


HoverHeight Field

UnitFields..::..HoverHeight Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields HoverHeight
Public Const HoverHeight As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields HoverHeight

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


Level Field

UnitFields..::..Level Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields Level
Public Const Level As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields Level

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


MaxDamage Field

UnitFields..::..MaxDamage Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields MaxDamage
Public Const MaxDamage As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields MaxDamage

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


MaxHealth Field

UnitFields..::..MaxHealth Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields MaxHealth
Public Const MaxHealth As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields MaxHealth

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


MaxHealthModifier Field

UnitFields..::..MaxHealthModifier Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields MaxHealthModifier
Public Const MaxHealthModifier As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields MaxHealthModifier

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


MaxOffhandDamage Field

UnitFields..::..MaxOffhandDamage Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields MaxOffhandDamage
Public Const MaxOffhandDamage As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields MaxOffhandDamage

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


Maxpower1 Field

UnitFields..::..Maxpower1 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields Maxpower1
Public Const Maxpower1 As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields Maxpower1

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


Maxpower2 Field

UnitFields..::..Maxpower2 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields Maxpower2
Public Const Maxpower2 As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields Maxpower2

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


Maxpower3 Field

UnitFields..::..Maxpower3 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields Maxpower3
Public Const Maxpower3 As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields Maxpower3

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


Maxpower4 Field

UnitFields..::..Maxpower4 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields Maxpower4
Public Const Maxpower4 As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields Maxpower4

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


Maxpower5 Field

UnitFields..::..Maxpower5 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields Maxpower5
Public Const Maxpower5 As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields Maxpower5

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


Maxpower6 Field

UnitFields..::..Maxpower6 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields Maxpower6
Public Const Maxpower6 As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields Maxpower6

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


Maxpower7 Field

UnitFields..::..Maxpower7 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields Maxpower7
Public Const Maxpower7 As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields Maxpower7

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


MaxRangedDamage Field

UnitFields..::..MaxRangedDamage Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields MaxRangedDamage
Public Const MaxRangedDamage As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields MaxRangedDamage

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


MinDamage Field

UnitFields..::..MinDamage Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields MinDamage
Public Const MinDamage As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields MinDamage

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


MinOffhandDamage Field

UnitFields..::..MinOffhandDamage Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields MinOffhandDamage
Public Const MinOffhandDamage As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields MinOffhandDamage

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


MinRangedDamage Field

UnitFields..::..MinRangedDamage Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields MinRangedDamage
Public Const MinRangedDamage As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields MinRangedDamage

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


ModCastSpeed Field

UnitFields..::..ModCastSpeed Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields ModCastSpeed
Public Const ModCastSpeed As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields ModCastSpeed

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


MountDisplayID Field

UnitFields..::..MountDisplayID Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields MountDisplayID
Public Const MountDisplayID As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields MountDisplayID

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


NativeDisplayID Field

UnitFields..::..NativeDisplayID Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields NativeDisplayID
Public Const NativeDisplayID As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields NativeDisplayID

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


NegStat0 Field

UnitFields..::..NegStat0 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields NegStat0
Public Const NegStat0 As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields NegStat0

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


NegStat1 Field

UnitFields..::..NegStat1 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields NegStat1
Public Const NegStat1 As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields NegStat1

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


NegStat2 Field

UnitFields..::..NegStat2 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields NegStat2
Public Const NegStat2 As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields NegStat2

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


NegStat3 Field

UnitFields..::..NegStat3 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields NegStat3
Public Const NegStat3 As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields NegStat3

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


NegStat4 Field

UnitFields..::..NegStat4 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields NegStat4
Public Const NegStat4 As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields NegStat4

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


NpcEmoteState Field

UnitFields..::..NpcEmoteState Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields NpcEmoteState
Public Const NpcEmoteState As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields NpcEmoteState

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


NpcFlags Field

UnitFields..::..NpcFlags Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields NpcFlags
Public Const NpcFlags As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields NpcFlags

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


Padding Field

UnitFields..::..Padding Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields Padding
Public Const Padding As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields Padding

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


PetExperience Field

UnitFields..::..PetExperience Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields PetExperience
Public Const PetExperience As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields PetExperience

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


PetNameTimeStamp Field

UnitFields..::..PetNameTimeStamp Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields PetNameTimeStamp
Public Const PetNameTimeStamp As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields PetNameTimeStamp

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


PetNextLevelExp Field

UnitFields..::..PetNextLevelExp Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields PetNextLevelExp
Public Const PetNextLevelExp As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields PetNextLevelExp

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


PetNumber Field

UnitFields..::..PetNumber Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields PetNumber
Public Const PetNumber As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields PetNumber

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


PosStat0 Field

UnitFields..::..PosStat0 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields PosStat0
Public Const PosStat0 As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields PosStat0

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


PosStat1 Field

UnitFields..::..PosStat1 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields PosStat1
Public Const PosStat1 As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields PosStat1

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


PosStat2 Field

UnitFields..::..PosStat2 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields PosStat2
Public Const PosStat2 As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields PosStat2

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


PosStat3 Field

UnitFields..::..PosStat3 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields PosStat3
Public Const PosStat3 As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields PosStat3

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


PosStat4 Field

UnitFields..::..PosStat4 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields PosStat4
Public Const PosStat4 As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields PosStat4

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


Power1 Field

UnitFields..::..Power1 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields Power1
Public Const Power1 As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields Power1

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


Power2 Field

UnitFields..::..Power2 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields Power2
Public Const Power2 As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields Power2

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


Power3 Field

UnitFields..::..Power3 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields Power3
Public Const Power3 As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields Power3

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


Power4 Field

UnitFields..::..Power4 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields Power4
Public Const Power4 As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields Power4

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


Power5 Field

UnitFields..::..Power5 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields Power5
Public Const Power5 As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields Power5

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


Power6 Field

UnitFields..::..Power6 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields Power6
Public Const Power6 As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields Power6

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


Power7 Field

UnitFields..::..Power7 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields Power7
Public Const Power7 As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields Power7

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


PowerCostModifier Field

UnitFields..::..PowerCostModifier Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields PowerCostModifier
Public Const PowerCostModifier As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields PowerCostModifier

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


PowerCostMultiplier Field

UnitFields..::..PowerCostMultiplier Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields PowerCostMultiplier
Public Const PowerCostMultiplier As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields PowerCostMultiplier

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


PowerRegenFlatModifier Field

UnitFields..::..PowerRegenFlatModifier Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields PowerRegenFlatModifier
Public Const PowerRegenFlatModifier As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields PowerRegenFlatModifier

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


PowerRegenInterruptedFlatModifier Field

UnitFields..::..PowerRegenInterruptedFlatModifier Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields PowerRegenInterruptedFlatModifier
Public Const PowerRegenInterruptedFlatModifier As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields PowerRegenInterruptedFlatModifier

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


RangedAttackPower Field

UnitFields..::..RangedAttackPower Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields RangedAttackPower
Public Const RangedAttackPower As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields RangedAttackPower

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


RangedAttackPowerMods Field

UnitFields..::..RangedAttackPowerMods Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields RangedAttackPowerMods
Public Const RangedAttackPowerMods As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields RangedAttackPowerMods

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


RangedAttackPowerMultiplier Field

UnitFields..::..RangedAttackPowerMultiplier Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields RangedAttackPowerMultiplier
Public Const RangedAttackPowerMultiplier As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields RangedAttackPowerMultiplier

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


RangeDattackTime Field

UnitFields..::..RangeDattackTime Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields RangeDattackTime
Public Const RangeDattackTime As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields RangeDattackTime

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


RESISTANCEBUFFMODSNegative Field

UnitFields..::..RESISTANCEBUFFMODSNegative Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields RESISTANCEBUFFMODSNegative
Public Const RESISTANCEBUFFMODSNegative As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields RESISTANCEBUFFMODSNegative

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


ResistanceBuffModsPositive Field

UnitFields..::..ResistanceBuffModsPositive Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields ResistanceBuffModsPositive
Public Const ResistanceBuffModsPositive As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields ResistanceBuffModsPositive

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


Resistances Field

UnitFields..::..Resistances Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields Resistances
Public Const Resistances As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields Resistances

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


Stat0 Field

UnitFields..::..Stat0 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields Stat0
Public Const Stat0 As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields Stat0

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


Stat1 Field

UnitFields..::..Stat1 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields Stat1
Public Const Stat1 As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields Stat1

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


Stat2 Field

UnitFields..::..Stat2 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields Stat2
Public Const Stat2 As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields Stat2

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


Stat3 Field

UnitFields..::..Stat3 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields Stat3
Public Const Stat3 As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields Stat3

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


Stat4 Field

UnitFields..::..Stat4 Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields Stat4
Public Const Stat4 As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields Stat4

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


Summon Field

UnitFields..::..Summon Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields Summon
Public Const Summon As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields Summon

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


SummonedBy Field

UnitFields..::..SummonedBy Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields SummonedBy
Public Const SummonedBy As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields SummonedBy

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


Target Field

UnitFields..::..Target Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields Target
Public Const Target As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields Target

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


UnitChannelSpell Field

UnitFields..::..UnitChannelSpell Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields UnitChannelSpell
Public Const UnitChannelSpell As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields UnitChannelSpell

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


UnitVirtualItemSlotID Field

UnitFields..::..UnitVirtualItemSlotID Field

Namespace: wManager.Wow.Patchables
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public const Descriptors..::..UnitFields UnitVirtualItemSlotID
Public Const UnitVirtualItemSlotID As Descriptors..::..UnitFields
public:
literal Descriptors..::..UnitFields UnitVirtualItemSlotID

See Also

Descriptors..::..UnitFields Enumeration
wManager.Wow.Patchables Namespace


Dispose Method

Main..::..Dispose Method

Namespace: global
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public void Dispose()
Public Sub Dispose
public:
void Dispose()

See Also

Main
global Namespace


Initialize Method

Main..::..Initialize Method

Namespace: global
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public void Initialize()
Public Sub Initialize
public:
void Initialize()

See Also

Main
global Namespace


Start Method

Main..::..Start Method

Namespace: global
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public void Start()
Public Sub Start
public:
void Start()

See Also

Main
global Namespace


Stop Method

Main..::..Stop Method

Namespace: global
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public void Stop()
Public Sub Stop
public:
void Stop()

See Also

Main
global Namespace


DelSpecialChar Method

BaseToolsHelperClass..::..DelSpecialChar Method

Namespace: Quester.Profile.ProfilesCreator
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public string DelSpecialChar(
    string stringSpecialChar
)
Public Function DelSpecialChar ( _
    stringSpecialChar As String _
) As String
public:
String^ DelSpecialChar(
    String^ stringSpecialChar
)

Parameters

stringSpecialChar
Type: String

See Also

BaseToolsHelperClass
Quester.Profile.ProfilesCreator Namespace


ExtractIntOfString Method

BaseToolsHelperClass..::..ExtractIntOfString Method

Namespace: Quester.Profile.ProfilesCreator
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public int ExtractIntOfString(
    string text
)
Public Function ExtractIntOfString ( _
    text As String _
) As Integer
public:
int^ ExtractIntOfString(
    String^ text
)

Parameters

text
Type: String

See Also

BaseToolsHelperClass
Quester.Profile.ProfilesCreator Namespace


GetNpcNameFromWeb Method

BaseToolsHelperClass..::..GetNpcNameFromWeb Method

Namespace: Quester.Profile.ProfilesCreator
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public string GetNpcNameFromWeb(
    int npcId
)
Public Function GetNpcNameFromWeb ( _
    npcId As Integer _
) As String
public:
String^ GetNpcNameFromWeb(
    int^ npcId
)

Parameters

npcId
Type: Int32

See Also

BaseToolsHelperClass
Quester.Profile.ProfilesCreator Namespace


GetRequest Method

BaseToolsHelperClass..::..GetRequest Method

Namespace: Quester.Profile.ProfilesCreator
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public static string GetRequest(
    string url,
    string data
)
Public Shared Function GetRequest ( _
    url As String, _
    data As String _
) As String
public:
static String^ GetRequest(
    String^ url,
    String^ data
)

Parameters

url
Type: String
data
Type: String

See Also

BaseToolsHelperClass
Quester.Profile.ProfilesCreator Namespace


NPCGiverInfoWowHead Method

BaseToolsHelperClass..::..NPCGiverInfoWowHead Method

Namespace: Quester.Profile.ProfilesCreator
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public BaseToolsHelperClass..::..NPCGiver NPCGiverInfoWowHead(
    int npcId
)
Public Function NPCGiverInfoWowHead ( _
    npcId As Integer _
) As BaseToolsHelperClass..::..NPCGiver
public:
BaseToolsHelperClass..::..NPCGiver^ NPCGiverInfoWowHead(
    int^ npcId
)

Parameters

npcId
Type: Int32

See Also

BaseToolsHelperClass
Quester.Profile.ProfilesCreator Namespace


ParseFloat Method (String)

BaseToolsHelperClass..::..ParseFloat Method (String)

Namespace: Quester.Profile.ProfilesCreator
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public float ParseFloat(
    string floatString
)
Public Function ParseFloat ( _
    floatString As String _
) As Single
public:
float^ ParseFloat(
    String^ floatString
)

Parameters

floatString
Type: String

See Also

BaseToolsHelperClass
ParseFloat Overload
Quester.Profile.ProfilesCreator Namespace


ParseFloat Method (String, Boolean)

BaseToolsHelperClass..::..ParseFloat Method (String, Boolean%)

Namespace: Quester.Profile.ProfilesCreator
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public float ParseFloat(
    string floatString,
    out bool result
)
Public Function ParseFloat ( _
    floatString As String, _
    <OutAttribute> ByRef result As Boolean _
) As Single
public:
float^ ParseFloat(
    String^ floatString,
    [OutAttribute] bool^% result
)

Parameters

floatString
Type: String
result
Type: Boolean %

See Also

BaseToolsHelperClass
ParseFloat Overload
Quester.Profile.ProfilesCreator Namespace


ParseInt Method (String)

BaseToolsHelperClass..::..ParseInt Method (String)

Namespace: Quester.Profile.ProfilesCreator
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public int ParseInt(
    string intString
)
Public Function ParseInt ( _
    intString As String _
) As Integer
public:
int^ ParseInt(
    String^ intString
)

Parameters

intString
Type: String

See Also

BaseToolsHelperClass
ParseInt Overload
Quester.Profile.ProfilesCreator Namespace


ParseInt Method (String, Boolean)

BaseToolsHelperClass..::..ParseInt Method (String, Boolean%)

Namespace: Quester.Profile.ProfilesCreator
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public int ParseInt(
    string intString,
    out bool result
)
Public Function ParseInt ( _
    intString As String, _
    <OutAttribute> ByRef result As Boolean _
) As Integer
public:
int^ ParseInt(
    String^ intString,
    [OutAttribute] bool^% result
)

Parameters

intString
Type: String
result
Type: Boolean %

See Also

BaseToolsHelperClass
ParseInt Overload
Quester.Profile.ProfilesCreator Namespace


QuestInfo Method

BaseToolsHelperClass..::..QuestInfo Method

Namespace: Quester.Profile.ProfilesCreator
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public BaseToolsHelperClass..::..Quest QuestInfo(
    int questId
)
Public Function QuestInfo ( _
    questId As Integer _
) As BaseToolsHelperClass..::..Quest
public:
BaseToolsHelperClass..::..Quest^ QuestInfo(
    int^ questId
)

Parameters

questId
Type: Int32

See Also

BaseToolsHelperClass
Quester.Profile.ProfilesCreator Namespace


StringBetween Method

BaseToolsHelperClass..::..StringBetween Method

Namespace: Quester.Profile.ProfilesCreator
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public string StringBetween(
    string chaine,
    string debut,
    string fin,
    bool trim
)
Public Function StringBetween ( _
    chaine As String, _
    debut As String, _
    fin As String, _
    trim As Boolean _
) As String
public:
String^ StringBetween(
    String^ chaine,
    String^ debut,
    String^ fin,
    bool^ trim
)

Parameters

chaine
Type: String
debut
Type: String
fin
Type: String
trim
Type: Boolean

See Also

BaseToolsHelperClass
Quester.Profile.ProfilesCreator Namespace


TextToVarName Method

BaseToolsHelperClass..::..TextToVarName Method

Namespace: Quester.Profile.ProfilesCreator
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public string TextToVarName(
    string text,
    bool privateVar
)
Public Function TextToVarName ( _
    text As String, _
    privateVar As Boolean _
) As String
public:
String^ TextToVarName(
    String^ text,
    bool^ privateVar
)

Parameters

text
Type: String
privateVar
Type: Boolean

See Also

BaseToolsHelperClass
Quester.Profile.ProfilesCreator Namespace


Dispose Method

ImportQuestsUI..::..Dispose Method

Clean up any resources being used.

Namespace: Quester.Profile.ProfilesCreator
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
protected void Dispose(
    bool disposing
)
Protected Sub Dispose ( _
    disposing As Boolean _
)
protected:
void Dispose(
    bool^ disposing
)

Parameters

disposing
Type: Boolean
true if managed resources should be disposed; otherwise, false.

See Also

ImportQuestsUI
Quester.Profile.ProfilesCreator Namespace


AllocConsole Method

Native..::..AllocConsole Method

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[DllImportAttribute]
public static bool AllocConsole()
<DllImportAttribute> _
Public Shared Function AllocConsole As Boolean
[DllImportAttribute]
public:
static bool^ AllocConsole()

See Also

Native
robotManager.Helpful.Win32 Namespace


BitBlt Method

Native..::..BitBlt Method

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[DllImportAttribute]
public static bool BitBlt(
    IntPtr hObject,
    int nXDest,
    int nYDest,
    int nWidth,
    int nHeight,
    IntPtr hObjectSource,
    int nXSrc,
    int nYSrc,
    int dwRop
)
<DllImportAttribute> _
Public Shared Function BitBlt ( _
    hObject As IntPtr, _
    nXDest As Integer, _
    nYDest As Integer, _
    nWidth As Integer, _
    nHeight As Integer, _
    hObjectSource As IntPtr, _
    nXSrc As Integer, _
    nYSrc As Integer, _
    dwRop As Integer _
) As Boolean
[DllImportAttribute]
public:
static bool^ BitBlt(
    IntPtr^ hObject,
    int^ nXDest,
    int^ nYDest,
    int^ nWidth,
    int^ nHeight,
    IntPtr^ hObjectSource,
    int^ nXSrc,
    int^ nYSrc,
    int^ dwRop
)

Parameters

hObject
Type: IntPtr
nXDest
Type: Int32
nYDest
Type: Int32
nWidth
Type: Int32
nHeight
Type: Int32
hObjectSource
Type: IntPtr
nXSrc
Type: Int32
nYSrc
Type: Int32
dwRop
Type: Int32

See Also

Native
robotManager.Helpful.Win32 Namespace


ChangeWindowMessageFilter Method

Native..::..ChangeWindowMessageFilter Method

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[DllImportAttribute]
public static bool ChangeWindowMessageFilter(
    uint msg,
    Native..::..ChangeWindowMessageFilterFlags flags
)
<DllImportAttribute> _
Public Shared Function ChangeWindowMessageFilter ( _
    msg As UInteger, _
    flags As Native..::..ChangeWindowMessageFilterFlags _
) As Boolean
[DllImportAttribute]
public:
static bool^ ChangeWindowMessageFilter(
    unsigned int^ msg,
    Native..::..ChangeWindowMessageFilterFlags^ flags
)

Parameters

msg
Type: UInt32
flags
Type: robotManager.Helpful.Win32..::..Native..::..ChangeWindowMessageFilterFlags

See Also

Native
robotManager.Helpful.Win32 Namespace


CloseHandle Method

Native..::..CloseHandle Method

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[DllImportAttribute]
public static bool CloseHandle(
    IntPtr hHandle
)
<DllImportAttribute> _
Public Shared Function CloseHandle ( _
    hHandle As IntPtr _
) As Boolean
[DllImportAttribute]
public:
static bool^ CloseHandle(
    IntPtr^ hHandle
)

Parameters

hHandle
Type: IntPtr

See Also

Native
robotManager.Helpful.Win32 Namespace


CreateCompatibleBitmap Method

Native..::..CreateCompatibleBitmap Method

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[DllImportAttribute]
public static IntPtr CreateCompatibleBitmap(
    IntPtr hDC,
    int nWidth,
    int nHeight
)
<DllImportAttribute> _
Public Shared Function CreateCompatibleBitmap ( _
    hDC As IntPtr, _
    nWidth As Integer, _
    nHeight As Integer _
) As IntPtr
[DllImportAttribute]
public:
static IntPtr^ CreateCompatibleBitmap(
    IntPtr^ hDC,
    int^ nWidth,
    int^ nHeight
)

Parameters

hDC
Type: IntPtr
nWidth
Type: Int32
nHeight
Type: Int32

See Also

Native
robotManager.Helpful.Win32 Namespace


CreateCompatibleDC Method

Native..::..CreateCompatibleDC Method

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[DllImportAttribute]
public static IntPtr CreateCompatibleDC(
    IntPtr hDC
)
<DllImportAttribute> _
Public Shared Function CreateCompatibleDC ( _
    hDC As IntPtr _
) As IntPtr
[DllImportAttribute]
public:
static IntPtr^ CreateCompatibleDC(
    IntPtr^ hDC
)

Parameters

hDC
Type: IntPtr

See Also

Native
robotManager.Helpful.Win32 Namespace


CreateProcess Method

Native..::..CreateProcess Method

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[DllImportAttribute]
public static bool CreateProcess(
    string lpApplicationName,
    string lpCommandLine,
    IntPtr lpProcessAttributes,
    IntPtr lpThreadAttributes,
    bool bInheritHandles,
    Native..::..ProcessCreationFlags dwCreationFlags,
    IntPtr lpEnvironment,
    string lpCurrentDirectory,
    ref Native..::..STARTUPINFO lpStartupInfo,
    out Native..::..PROCESS_INFORMATION lpProcessInformation
)
<DllImportAttribute> _
Public Shared Function CreateProcess ( _
    lpApplicationName As String, _
    lpCommandLine As String, _
    lpProcessAttributes As IntPtr, _
    lpThreadAttributes As IntPtr, _
    bInheritHandles As Boolean, _
    dwCreationFlags As Native..::..ProcessCreationFlags, _
    lpEnvironment As IntPtr, _
    lpCurrentDirectory As String, _
    ByRef lpStartupInfo As Native..::..STARTUPINFO, _
    <OutAttribute> ByRef lpProcessInformation As Native..::..PROCESS_INFORMATION _
) As Boolean
[DllImportAttribute]
public:
static bool^ CreateProcess(
    String^ lpApplicationName,
    String^ lpCommandLine,
    IntPtr^ lpProcessAttributes,
    IntPtr^ lpThreadAttributes,
    bool^ bInheritHandles,
    Native..::..ProcessCreationFlags^ dwCreationFlags,
    IntPtr^ lpEnvironment,
    String^ lpCurrentDirectory,
    Native..::..STARTUPINFO^% lpStartupInfo,
    [OutAttribute] Native..::..PROCESS_INFORMATION^% lpProcessInformation
)

Parameters

lpApplicationName
Type: String
lpCommandLine
Type: String
lpProcessAttributes
Type: IntPtr
lpThreadAttributes
Type: IntPtr
bInheritHandles
Type: Boolean
dwCreationFlags
Type: robotManager.Helpful.Win32..::..Native..::..ProcessCreationFlags
lpEnvironment
Type: IntPtr
lpCurrentDirectory
Type: String
lpStartupInfo
Type: robotManager.Helpful.Win32..::..Native..::..STARTUPINFO %
lpProcessInformation
Type: robotManager.Helpful.Win32..::..Native..::..PROCESS_INFORMATION %

See Also

Native
robotManager.Helpful.Win32 Namespace


DeleteDC Method

Native..::..DeleteDC Method

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[DllImportAttribute]
public static bool DeleteDC(
    IntPtr hDC
)
<DllImportAttribute> _
Public Shared Function DeleteDC ( _
    hDC As IntPtr _
) As Boolean
[DllImportAttribute]
public:
static bool^ DeleteDC(
    IntPtr^ hDC
)

Parameters

hDC
Type: IntPtr

See Also

Native
robotManager.Helpful.Win32 Namespace


DeleteObject Method

Native..::..DeleteObject Method

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[DllImportAttribute]
public static bool DeleteObject(
    IntPtr hObject
)
<DllImportAttribute> _
Public Shared Function DeleteObject ( _
    hObject As IntPtr _
) As Boolean
[DllImportAttribute]
public:
static bool^ DeleteObject(
    IntPtr^ hObject
)

Parameters

hObject
Type: IntPtr

See Also

Native
robotManager.Helpful.Win32 Namespace


DwmEnableComposition Method

Native..::..DwmEnableComposition Method

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[DllImportAttribute]
public static void DwmEnableComposition(
    Native..::..CompositionAction uCompositionAction
)
<DllImportAttribute> _
Public Shared Sub DwmEnableComposition ( _
    uCompositionAction As Native..::..CompositionAction _
)
[DllImportAttribute]
public:
static void DwmEnableComposition(
    Native..::..CompositionAction^ uCompositionAction
)

Parameters

uCompositionAction
Type: robotManager.Helpful.Win32..::..Native..::..CompositionAction

See Also

Native
robotManager.Helpful.Win32 Namespace


FreeConsole Method

Native..::..FreeConsole Method

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[DllImportAttribute]
public static bool FreeConsole()
<DllImportAttribute> _
Public Shared Function FreeConsole As Boolean
[DllImportAttribute]
public:
static bool^ FreeConsole()

See Also

Native
robotManager.Helpful.Win32 Namespace


GetDesktopWindow Method

Native..::..GetDesktopWindow Method

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[DllImportAttribute]
public static IntPtr GetDesktopWindow()
<DllImportAttribute> _
Public Shared Function GetDesktopWindow As IntPtr
[DllImportAttribute]
public:
static IntPtr^ GetDesktopWindow()

See Also

Native
robotManager.Helpful.Win32 Namespace


GetWindowDC Method

Native..::..GetWindowDC Method

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[DllImportAttribute]
public static IntPtr GetWindowDC(
    IntPtr hWnd
)
<DllImportAttribute> _
Public Shared Function GetWindowDC ( _
    hWnd As IntPtr _
) As IntPtr
[DllImportAttribute]
public:
static IntPtr^ GetWindowDC(
    IntPtr^ hWnd
)

Parameters

hWnd
Type: IntPtr

See Also

Native
robotManager.Helpful.Win32 Namespace


GetWindowRect Method

Native..::..GetWindowRect Method

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[DllImportAttribute]
public static IntPtr GetWindowRect(
    IntPtr hWnd,
    ref Native..::..RECT rect
)
<DllImportAttribute> _
Public Shared Function GetWindowRect ( _
    hWnd As IntPtr, _
    ByRef rect As Native..::..RECT _
) As IntPtr
[DllImportAttribute]
public:
static IntPtr^ GetWindowRect(
    IntPtr^ hWnd,
    Native..::..RECT^% rect
)

Parameters

hWnd
Type: IntPtr
rect
Type: robotManager.Helpful.Win32..::..Native..::..RECT %

See Also

Native
robotManager.Helpful.Win32 Namespace


keybd_event Method

Native..::..keybd_event Method

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[DllImportAttribute]
public static void keybd_event(
    byte bVk,
    byte bScan,
    long dwFlags,
    long dwExtraInfo
)
<DllImportAttribute> _
Public Shared Sub keybd_event ( _
    bVk As Byte, _
    bScan As Byte, _
    dwFlags As Long, _
    dwExtraInfo As Long _
)
[DllImportAttribute]
public:
static void keybd_event(
    unsigned char^ bVk,
    unsigned char^ bScan,
    long long^ dwFlags,
    long long^ dwExtraInfo
)

Parameters

bVk
Type: Byte
bScan
Type: Byte
dwFlags
Type: Int64
dwExtraInfo
Type: Int64

See Also

Native
robotManager.Helpful.Win32 Namespace


MAKEPARAM Method

Native..::..MAKEPARAM Method

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static IntPtr MAKEPARAM(
    int l,
    int h
)
Public Shared Function MAKEPARAM ( _
    l As Integer, _
    h As Integer _
) As IntPtr
public:
static IntPtr^ MAKEPARAM(
    int^ l,
    int^ h
)

Parameters

l
Type: Int32
h
Type: Int32

See Also

Native
robotManager.Helpful.Win32 Namespace


mouse_event Method

Native..::..mouse_event Method

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[DllImportAttribute]
public static void mouse_event(
    int dwFlags,
    int dx,
    int dy,
    int dwData,
    int dwExtraInfo
)
<DllImportAttribute> _
Public Shared Sub mouse_event ( _
    dwFlags As Integer, _
    dx As Integer, _
    dy As Integer, _
    dwData As Integer, _
    dwExtraInfo As Integer _
)
[DllImportAttribute]
public:
static void mouse_event(
    int^ dwFlags,
    int^ dx,
    int^ dy,
    int^ dwData,
    int^ dwExtraInfo
)

Parameters

dwFlags
Type: Int32
dx
Type: Int32
dy
Type: Int32
dwData
Type: Int32
dwExtraInfo
Type: Int32

See Also

Native
robotManager.Helpful.Win32 Namespace


NtResumeProcess Method

Native..::..NtResumeProcess Method

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[DllImportAttribute]
public static void NtResumeProcess(
    IntPtr processHandle
)
<DllImportAttribute> _
Public Shared Sub NtResumeProcess ( _
    processHandle As IntPtr _
)
[DllImportAttribute]
public:
static void NtResumeProcess(
    IntPtr^ processHandle
)

Parameters

processHandle
Type: IntPtr

See Also

Native
robotManager.Helpful.Win32 Namespace


NtSuspendProcess Method

Native..::..NtSuspendProcess Method

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[DllImportAttribute]
public static void NtSuspendProcess(
    IntPtr processHandle
)
<DllImportAttribute> _
Public Shared Sub NtSuspendProcess ( _
    processHandle As IntPtr _
)
[DllImportAttribute]
public:
static void NtSuspendProcess(
    IntPtr^ processHandle
)

Parameters

processHandle
Type: IntPtr

See Also

Native
robotManager.Helpful.Win32 Namespace


OpenProcess Method

Native..::..OpenProcess Method

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[DllImportAttribute]
public static IntPtr OpenProcess(
    uint dwDesiredAccess,
    bool bInheritHandle,
    int dwProcessId
)
<DllImportAttribute> _
Public Shared Function OpenProcess ( _
    dwDesiredAccess As UInteger, _
    bInheritHandle As Boolean, _
    dwProcessId As Integer _
) As IntPtr
[DllImportAttribute]
public:
static IntPtr^ OpenProcess(
    unsigned int^ dwDesiredAccess,
    bool^ bInheritHandle,
    int^ dwProcessId
)

Parameters

dwDesiredAccess
Type: UInt32
bInheritHandle
Type: Boolean
dwProcessId
Type: Int32

See Also

Native
robotManager.Helpful.Win32 Namespace


OpenThread Method

Native..::..OpenThread Method

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[DllImportAttribute]
public static IntPtr OpenThread(
    Native..::..ThreadAccess dwDesiredAccess,
    bool bInheritHandle,
    uint dwThreadId
)
<DllImportAttribute> _
Public Shared Function OpenThread ( _
    dwDesiredAccess As Native..::..ThreadAccess, _
    bInheritHandle As Boolean, _
    dwThreadId As UInteger _
) As IntPtr
[DllImportAttribute]
public:
static IntPtr^ OpenThread(
    Native..::..ThreadAccess^ dwDesiredAccess,
    bool^ bInheritHandle,
    unsigned int^ dwThreadId
)

Parameters

dwDesiredAccess
Type: robotManager.Helpful.Win32..::..Native..::..ThreadAccess
bInheritHandle
Type: Boolean
dwThreadId
Type: UInt32

See Also

Native
robotManager.Helpful.Win32 Namespace


PostMessageSafe Method

Native..::..PostMessageSafe Method

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static bool PostMessageSafe(
    IntPtr hWnd,
    uint msg,
    IntPtr wParam,
    IntPtr lParam
)
Public Shared Function PostMessageSafe ( _
    hWnd As IntPtr, _
    msg As UInteger, _
    wParam As IntPtr, _
    lParam As IntPtr _
) As Boolean
public:
static bool^ PostMessageSafe(
    IntPtr^ hWnd,
    unsigned int^ msg,
    IntPtr^ wParam,
    IntPtr^ lParam
)

Parameters

hWnd
Type: IntPtr
msg
Type: UInt32
wParam
Type: IntPtr
lParam
Type: IntPtr

See Also

Native
robotManager.Helpful.Win32 Namespace


ReadProcessMemory Method

Native..::..ReadProcessMemory Method

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[DllImportAttribute]
public static bool ReadProcessMemory(
    IntPtr hProcess,
    IntPtr lpBaseAddress,
    byte[] lpBuffer,
    int dwSize,
    out int lpNumberOfBytesRead
)
<DllImportAttribute> _
Public Shared Function ReadProcessMemory ( _
    hProcess As IntPtr, _
    lpBaseAddress As IntPtr, _
    lpBuffer As Byte(), _
    dwSize As Integer, _
    <OutAttribute> ByRef lpNumberOfBytesRead As Integer _
) As Boolean
[DllImportAttribute]
public:
static bool^ ReadProcessMemory(
    IntPtr^ hProcess,
    IntPtr^ lpBaseAddress,
    array<unsigned char^>^ lpBuffer,
    int^ dwSize,
    [OutAttribute] int^% lpNumberOfBytesRead
)

Parameters

hProcess
Type: IntPtr
lpBaseAddress
Type: IntPtr
lpBuffer
Type: array< Byte >[]()[][]
dwSize
Type: Int32
lpNumberOfBytesRead
Type: Int32 %

See Also

Native
robotManager.Helpful.Win32 Namespace


ReleaseDC Method

Native..::..ReleaseDC Method

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[DllImportAttribute]
public static IntPtr ReleaseDC(
    IntPtr hWnd,
    IntPtr hDC
)
<DllImportAttribute> _
Public Shared Function ReleaseDC ( _
    hWnd As IntPtr, _
    hDC As IntPtr _
) As IntPtr
[DllImportAttribute]
public:
static IntPtr^ ReleaseDC(
    IntPtr^ hWnd,
    IntPtr^ hDC
)

Parameters

hWnd
Type: IntPtr
hDC
Type: IntPtr

See Also

Native
robotManager.Helpful.Win32 Namespace


ResumeThread Method

Native..::..ResumeThread Method

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[DllImportAttribute]
public static int ResumeThread(
    IntPtr hThread
)
<DllImportAttribute> _
Public Shared Function ResumeThread ( _
    hThread As IntPtr _
) As Integer
[DllImportAttribute]
public:
static int^ ResumeThread(
    IntPtr^ hThread
)

Parameters

hThread
Type: IntPtr

See Also

Native
robotManager.Helpful.Win32 Namespace


SelectObject Method

Native..::..SelectObject Method

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[DllImportAttribute]
public static IntPtr SelectObject(
    IntPtr hDC,
    IntPtr hObject
)
<DllImportAttribute> _
Public Shared Function SelectObject ( _
    hDC As IntPtr, _
    hObject As IntPtr _
) As IntPtr
[DllImportAttribute]
public:
static IntPtr^ SelectObject(
    IntPtr^ hDC,
    IntPtr^ hObject
)

Parameters

hDC
Type: IntPtr
hObject
Type: IntPtr

See Also

Native
robotManager.Helpful.Win32 Namespace


SendMessage Method

Native..::..SendMessage Method

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[DllImportAttribute]
public static IntPtr SendMessage(
    IntPtr hWnd,
    uint Msg,
    uint wParam,
    uint lParam
)
<DllImportAttribute> _
Public Shared Function SendMessage ( _
    hWnd As IntPtr, _
    Msg As UInteger, _
    wParam As UInteger, _
    lParam As UInteger _
) As IntPtr
[DllImportAttribute]
public:
static IntPtr^ SendMessage(
    IntPtr^ hWnd,
    unsigned int^ Msg,
    unsigned int^ wParam,
    unsigned int^ lParam
)

Parameters

hWnd
Type: IntPtr
Msg
Type: UInt32
wParam
Type: UInt32
lParam
Type: UInt32

See Also

Native
robotManager.Helpful.Win32 Namespace


SetConsoleCtrlHandler Method

Native..::..SetConsoleCtrlHandler Method

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[DllImportAttribute]
public static bool SetConsoleCtrlHandler(
    Native..::..ConsoleEventHandlerDelegate handlerProc,
    bool add
)
<DllImportAttribute> _
Public Shared Function SetConsoleCtrlHandler ( _
    handlerProc As Native..::..ConsoleEventHandlerDelegate, _
    add As Boolean _
) As Boolean
[DllImportAttribute]
public:
static bool^ SetConsoleCtrlHandler(
    Native..::..ConsoleEventHandlerDelegate^ handlerProc,
    bool^ add
)

Parameters

handlerProc
Type: robotManager.Helpful.Win32..::..Native..::..ConsoleEventHandlerDelegate
add
Type: Boolean

See Also

Native
robotManager.Helpful.Win32 Namespace


SetCursorPos Method

Native..::..SetCursorPos Method

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[DllImportAttribute]
public static bool SetCursorPos(
    int x,
    int y
)
<DllImportAttribute> _
Public Shared Function SetCursorPos ( _
    x As Integer, _
    y As Integer _
) As Boolean
[DllImportAttribute]
public:
static bool^ SetCursorPos(
    int^ x,
    int^ y
)

Parameters

x
Type: Int32
y
Type: Int32

See Also

Native
robotManager.Helpful.Win32 Namespace


SetForegroundWindow Method

Native..::..SetForegroundWindow Method

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[DllImportAttribute]
public static int SetForegroundWindow(
    IntPtr hwnd
)
<DllImportAttribute> _
Public Shared Function SetForegroundWindow ( _
    hwnd As IntPtr _
) As Integer
[DllImportAttribute]
public:
static int^ SetForegroundWindow(
    IntPtr^ hwnd
)

Parameters

hwnd
Type: IntPtr

See Also

Native
robotManager.Helpful.Win32 Namespace


SetWindowDisplayAffinity Method

Native..::..SetWindowDisplayAffinity Method

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[DllImportAttribute]
public static bool SetWindowDisplayAffinity(
    IntPtr hwnd,
    Native..::..DisplayAffinity affinity
)
<DllImportAttribute> _
Public Shared Function SetWindowDisplayAffinity ( _
    hwnd As IntPtr, _
    affinity As Native..::..DisplayAffinity _
) As Boolean
[DllImportAttribute]
public:
static bool^ SetWindowDisplayAffinity(
    IntPtr^ hwnd,
    Native..::..DisplayAffinity^ affinity
)

Parameters

hwnd
Type: IntPtr
affinity
Type: robotManager.Helpful.Win32..::..Native..::..DisplayAffinity

See Also

Native
robotManager.Helpful.Win32 Namespace


SetWindowPos Method

Native..::..SetWindowPos Method

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[DllImportAttribute]
public static int SetWindowPos(
    IntPtr hWnd,
    IntPtr hWndInsertAfter,
    int x,
    int y,
    int cx,
    int cy,
    uint uFlags
)
<DllImportAttribute> _
Public Shared Function SetWindowPos ( _
    hWnd As IntPtr, _
    hWndInsertAfter As IntPtr, _
    x As Integer, _
    y As Integer, _
    cx As Integer, _
    cy As Integer, _
    uFlags As UInteger _
) As Integer
[DllImportAttribute]
public:
static int^ SetWindowPos(
    IntPtr^ hWnd,
    IntPtr^ hWndInsertAfter,
    int^ x,
    int^ y,
    int^ cx,
    int^ cy,
    unsigned int^ uFlags
)

Parameters

hWnd
Type: IntPtr
hWndInsertAfter
Type: IntPtr
x
Type: Int32
y
Type: Int32
cx
Type: Int32
cy
Type: Int32
uFlags
Type: UInt32

See Also

Native
robotManager.Helpful.Win32 Namespace


ShowWindow Method

Native..::..ShowWindow Method

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[DllImportAttribute]
public static bool ShowWindow(
    IntPtr hWnd,
    int nCmdShow
)
<DllImportAttribute> _
Public Shared Function ShowWindow ( _
    hWnd As IntPtr, _
    nCmdShow As Integer _
) As Boolean
[DllImportAttribute]
public:
static bool^ ShowWindow(
    IntPtr^ hWnd,
    int^ nCmdShow
)

Parameters

hWnd
Type: IntPtr
nCmdShow
Type: Int32

See Also

Native
robotManager.Helpful.Win32 Namespace


SuspendThread Method

Native..::..SuspendThread Method

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[DllImportAttribute]
public static uint SuspendThread(
    IntPtr hThread
)
<DllImportAttribute> _
Public Shared Function SuspendThread ( _
    hThread As IntPtr _
) As UInteger
[DllImportAttribute]
public:
static unsigned int^ SuspendThread(
    IntPtr^ hThread
)

Parameters

hThread
Type: IntPtr

See Also

Native
robotManager.Helpful.Win32 Namespace


TerminateThread Method

Native..::..TerminateThread Method

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[DllImportAttribute]
public static bool TerminateThread(
    IntPtr hThread,
    uint dwExitCode
)
<DllImportAttribute> _
Public Shared Function TerminateThread ( _
    hThread As IntPtr, _
    dwExitCode As UInteger _
) As Boolean
[DllImportAttribute]
public:
static bool^ TerminateThread(
    IntPtr^ hThread,
    unsigned int^ dwExitCode
)

Parameters

hThread
Type: IntPtr
dwExitCode
Type: UInt32

See Also

Native
robotManager.Helpful.Win32 Namespace


VkKeyScan Method

Native..::..VkKeyScan Method

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[DllImportAttribute]
public static short VkKeyScan(
    char ch
)
<DllImportAttribute> _
Public Shared Function VkKeyScan ( _
    ch As Char _
) As Short
[DllImportAttribute]
public:
static short^ VkKeyScan(
    wchar_t^ ch
)

Parameters

ch
Type: Char

See Also

Native
robotManager.Helpful.Win32 Namespace


WaitForSingleObject Method

Native..::..WaitForSingleObject Method

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[DllImportAttribute]
public static uint WaitForSingleObject(
    IntPtr hHandle,
    uint dwMilliseconds
)
<DllImportAttribute> _
Public Shared Function WaitForSingleObject ( _
    hHandle As IntPtr, _
    dwMilliseconds As UInteger _
) As UInteger
[DllImportAttribute]
public:
static unsigned int^ WaitForSingleObject(
    IntPtr^ hHandle,
    unsigned int^ dwMilliseconds
)

Parameters

hHandle
Type: IntPtr
dwMilliseconds
Type: UInt32

See Also

Native
robotManager.Helpful.Win32 Namespace


WriteProcessMemory Method

Native..::..WriteProcessMemory Method

Namespace: robotManager.Helpful.Win32
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[DllImportAttribute]
public static bool WriteProcessMemory(
    IntPtr hProcess,
    IntPtr lpBaseAddress,
    byte[] lpBuffer,
    uint nSize,
    out int lpNumberOfBytesWritten
)
<DllImportAttribute> _
Public Shared Function WriteProcessMemory ( _
    hProcess As IntPtr, _
    lpBaseAddress As IntPtr, _
    lpBuffer As Byte(), _
    nSize As UInteger, _
    <OutAttribute> ByRef lpNumberOfBytesWritten As Integer _
) As Boolean
[DllImportAttribute]
public:
static bool^ WriteProcessMemory(
    IntPtr^ hProcess,
    IntPtr^ lpBaseAddress,
    array<unsigned char^>^ lpBuffer,
    unsigned int^ nSize,
    [OutAttribute] int^% lpNumberOfBytesWritten
)

Parameters

hProcess
Type: IntPtr
lpBaseAddress
Type: IntPtr
lpBuffer
Type: array< Byte >[]()[][]
nSize
Type: UInt32
lpNumberOfBytesWritten
Type: Int32 %

See Also

Native
robotManager.Helpful.Win32 Namespace


Hook Constructor

Initializes a new instance of the Hook class.

Namespace: robotManager.MemoryClass
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public (
    int processId,
    ulong detourAddress,
    byte[] originalBytes,
    ulong jumpOrCallEsiWrapper,
    ulong jumpOrCallEsiWrapperOffset,
    bool rebaseCallAndJmpAddress,
    bool hwbpHook,
    ulong searchStackRequiredValue,
    ulong searchStackMaxDistance,
    ulong detourPointerDefaultValue,
    uint threadId
)
Public Sub New ( _
    processId As Integer, _
    detourAddress As ULong, _
    originalBytes As Byte(), _
    jumpOrCallEsiWrapper As ULong, _
    jumpOrCallEsiWrapperOffset As ULong, _
    rebaseCallAndJmpAddress As Boolean, _
    hwbpHook As Boolean, _
    searchStackRequiredValue As ULong, _
    searchStackMaxDistance As ULong, _
    detourPointerDefaultValue As ULong, _
    threadId As UInteger _
)
public:
(
    int^ processId,
    unsigned long long^ detourAddress,
    array<unsigned char^>^ originalBytes,
    unsigned long long^ jumpOrCallEsiWrapper,
    unsigned long long^ jumpOrCallEsiWrapperOffset,
    bool^ rebaseCallAndJmpAddress,
    bool^ hwbpHook,
    unsigned long long^ searchStackRequiredValue,
    unsigned long long^ searchStackMaxDistance,
    unsigned long long^ detourPointerDefaultValue,
    unsigned int^ threadId
)

Parameters

processId
Type: Int32
detourAddress
Type: UInt64
originalBytes
Type: array< Byte >[]()[][]
jumpOrCallEsiWrapper
Type: UInt64
jumpOrCallEsiWrapperOffset
Type: UInt64
rebaseCallAndJmpAddress
Type: Boolean
hwbpHook
Type: Boolean
searchStackRequiredValue
Type: UInt64
searchStackMaxDistance
Type: UInt64
detourPointerDefaultValue
Type: UInt64
threadId
Type: UInt32

See Also

Hook
robotManager.MemoryClass Namespace


Assemble Method

Hook..::..Assemble Method

Namespace: robotManager.MemoryClass
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public byte[] Assemble(
    string[] asm
)
Public Function Assemble ( _
    asm As String() _
) As Byte()
public:
array<unsigned char^>^ Assemble(
    array<String^>^ asm
)

Parameters

asm
Type: array< String >[]()[][]

See Also

Hook
robotManager.MemoryClass Namespace


CalculateFrameRate Method

Hook..::..CalculateFrameRate Method

Namespace: robotManager.MemoryClass
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static int CalculateFrameRate()
Public Shared Function CalculateFrameRate As Integer
public:
static int^ CalculateFrameRate()

See Also

Hook
robotManager.MemoryClass Namespace


CallWrapperCode Method

Hook..::..CallWrapperCode Method

Namespace: robotManager.MemoryClass
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public string CallWrapperCode(
    ulong address,
    params Object[] param
)
Public Function CallWrapperCode ( _
    address As ULong, _
    ParamArray param As Object() _
) As String
public:
String^ CallWrapperCode(
    unsigned long long^ address,
    ... array<Object^>^ param
)

Parameters

address
Type: UInt64
param
Type: array< Object >[]()[][]

See Also

Hook
robotManager.MemoryClass Namespace


CallWrapperCodeRebaseEsp Method

Hook..::..CallWrapperCodeRebaseEsp Method

Namespace: robotManager.MemoryClass
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public string CallWrapperCodeRebaseEsp(
    ulong address,
    int espRebase,
    params Object[] param
)
Public Function CallWrapperCodeRebaseEsp ( _
    address As ULong, _
    espRebase As Integer, _
    ParamArray param As Object() _
) As String
public:
String^ CallWrapperCodeRebaseEsp(
    unsigned long long^ address,
    int^ espRebase,
    ... array<Object^>^ param
)

Parameters

address
Type: UInt64
espRebase
Type: Int32
param
Type: array< Object >[]()[][]

See Also

Hook
robotManager.MemoryClass Namespace


CloseHookedProcess Method

Hook..::..CloseHookedProcess Method

Namespace: robotManager.MemoryClass
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public void CloseHookedProcess()
Public Sub CloseHookedProcess
public:
void CloseHookedProcess()

See Also

Hook
robotManager.MemoryClass Namespace


DetourInUse Method

Hook..::..DetourInUse Method

Namespace: robotManager.MemoryClass
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public bool DetourInUse()
Public Function DetourInUse As Boolean
public:
bool^ DetourInUse()

See Also

Hook
robotManager.MemoryClass Namespace


Dispose Method

Hook..::..Dispose Method

Namespace: robotManager.MemoryClass
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public void Dispose()
Public Sub Dispose
public:
void Dispose()

See Also

Hook
robotManager.MemoryClass Namespace


DisposeHooking Method

Hook..::..DisposeHooking Method

Disposes the hook.

Namespace: robotManager.MemoryClass
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public void DisposeHooking(
    bool closeMemory
)
Public Sub DisposeHooking ( _
    closeMemory As Boolean _
)
public:
void DisposeHooking(
    bool^ closeMemory
)

Parameters

closeMemory
Type: Boolean

See Also

Hook
robotManager.MemoryClass Namespace


Execute Method

Hook..::..Execute Method

Namespace: robotManager.MemoryClass
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public byte[] Execute(
    ulong functionAddress,
    bool returnValue,
    int returnLength
)
Public Function Execute ( _
    functionAddress As ULong, _
    returnValue As Boolean, _
    returnLength As Integer _
) As Byte()
public:
array<unsigned char^>^ Execute(
    unsigned long long^ functionAddress,
    bool^ returnValue,
    int^ returnLength
)

Parameters

functionAddress
Type: UInt64
returnValue
Type: Boolean
returnLength
Type: Int32

See Also

Hook
robotManager.MemoryClass Namespace


ExecuteNewThread Method

Hook..::..ExecuteNewThread Method

Namespace: robotManager.MemoryClass
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public bool ExecuteNewThread(
    ulong functionAddress
)
Public Function ExecuteNewThread ( _
    functionAddress As ULong _
) As Boolean
public:
bool^ ExecuteNewThread(
    unsigned long long^ functionAddress
)

Parameters

functionAddress
Type: UInt64

See Also

Hook
robotManager.MemoryClass Namespace


GetCurrentThreadId Method

Hook..::..GetCurrentThreadId Method

Namespace: robotManager.MemoryClass
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[DllImportAttribute]
public static int GetCurrentThreadId()
<DllImportAttribute> _
Public Shared Function GetCurrentThreadId As Integer
[DllImportAttribute]
public:
static int^ GetCurrentThreadId()

See Also

Hook
robotManager.MemoryClass Namespace


HookedProcessIsUserAnAdmin Method

Hook..::..HookedProcessIsUserAnAdmin Method

Namespace: robotManager.MemoryClass
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public bool HookedProcessIsUserAnAdmin()
Public Function HookedProcessIsUserAnAdmin As Boolean
public:
bool^ HookedProcessIsUserAnAdmin()

See Also

Hook
robotManager.MemoryClass Namespace


Inject Method (String[], UInt64, UInt64)

Hook..::..Inject Method (array<String>[]()[][], UInt64%, UInt64%)

Namespace: robotManager.MemoryClass
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public bool Inject(
    string[] asm,
    out ulong baseCodecave,
    out ulong injectionStart
)
Public Function Inject ( _
    asm As String(), _
    <OutAttribute> ByRef baseCodecave As ULong, _
    <OutAttribute> ByRef injectionStart As ULong _
) As Boolean
public:
bool^ Inject(
    array<String^>^ asm,
    [OutAttribute] unsigned long long^% baseCodecave,
    [OutAttribute] unsigned long long^% injectionStart
)

Parameters

asm
Type: array< String >[]()[][]
baseCodecave
Type: UInt64 %
injectionStart
Type: UInt64 %

See Also

Hook
Inject Overload
robotManager.MemoryClass Namespace


Inject Method (Byte[], UInt64, UInt64)

Hook..::..Inject Method (array<Byte>[]()[][], UInt64%, UInt64%)

Namespace: robotManager.MemoryClass
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public bool Inject(
    byte[] asm,
    out ulong baseCodecave,
    out ulong injectionStart
)
Public Function Inject ( _
    asm As Byte(), _
    <OutAttribute> ByRef baseCodecave As ULong, _
    <OutAttribute> ByRef injectionStart As ULong _
) As Boolean
public:
bool^ Inject(
    array<unsigned char^>^ asm,
    [OutAttribute] unsigned long long^% baseCodecave,
    [OutAttribute] unsigned long long^% injectionStart
)

Parameters

asm
Type: array< Byte >[]()[][]
baseCodecave
Type: UInt64 %
injectionStart
Type: UInt64 %

See Also

Hook
Inject Overload
robotManager.MemoryClass Namespace


InjectAndExecute Method (String[], Boolean, Int32, Boolean)

Hook..::..InjectAndExecute Method (array<String>[]()[][], Boolean, Int32, Boolean)

Injects the and execute Asm lines.

Namespace: robotManager.MemoryClass
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public byte[] InjectAndExecute(
    string[] asm,
    bool returnValue,
    int returnLength,
    bool freeMemory
)
Public Function InjectAndExecute ( _
    asm As String(), _
    returnValue As Boolean, _
    returnLength As Integer, _
    freeMemory As Boolean _
) As Byte()
public:
array<unsigned char^>^ InjectAndExecute(
    array<String^>^ asm,
    bool^ returnValue,
    int^ returnLength,
    bool^ freeMemory
)

Parameters

asm
Type: array< String >[]()[][]
The asm code.
returnValue
Type: Boolean
if set to true [return value].
returnLength
Type: Int32
Length of the return.
freeMemory
Type: Boolean
Free codecave memory

Return Value

See Also

Hook
InjectAndExecute Overload
robotManager.MemoryClass Namespace


InjectAndExecute Method (Byte[], Boolean, Int32, Boolean)

Hook..::..InjectAndExecute Method (array<Byte>[]()[][], Boolean, Int32, Boolean)

Injects the and execute Asm lines.

Namespace: robotManager.MemoryClass
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public byte[] InjectAndExecute(
    byte[] asm,
    bool returnValue,
    int returnLength,
    bool freeMemory
)
Public Function InjectAndExecute ( _
    asm As Byte(), _
    returnValue As Boolean, _
    returnLength As Integer, _
    freeMemory As Boolean _
) As Byte()
public:
array<unsigned char^>^ InjectAndExecute(
    array<unsigned char^>^ asm,
    bool^ returnValue,
    int^ returnLength,
    bool^ freeMemory
)

Parameters

asm
Type: array< Byte >[]()[][]
The asm code.
returnValue
Type: Boolean
if set to true [return value].
returnLength
Type: Int32
Length of the return.
freeMemory
Type: Boolean
Free codecave memory

Return Value

See Also

Hook
InjectAndExecute Overload
robotManager.MemoryClass Namespace


InjectExecuteNewThread Method

Hook..::..InjectExecuteNewThread Method

Namespace: robotManager.MemoryClass
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public bool InjectExecuteNewThread(
    string[] asm
)
Public Function InjectExecuteNewThread ( _
    asm As String() _
) As Boolean
public:
bool^ InjectExecuteNewThread(
    array<String^>^ asm
)

Parameters

asm
Type: array< String >[]()[][]

See Also

Hook
robotManager.MemoryClass Namespace


IsUsed Method

Hook..::..IsUsed Method

Namespace: robotManager.MemoryClass
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public static bool IsUsed(
    int processId,
    ulong detourAddress,
    bool hwbpHook,
    ulong isPointerHookDefaultValue
)
Public Shared Function IsUsed ( _
    processId As Integer, _
    detourAddress As ULong, _
    hwbpHook As Boolean, _
    isPointerHookDefaultValue As ULong _
) As Boolean
public:
static bool^ IsUsed(
    int^ processId,
    unsigned long long^ detourAddress,
    bool^ hwbpHook,
    unsigned long long^ isPointerHookDefaultValue
)

Parameters

processId
Type: Int32
detourAddress
Type: UInt64
hwbpHook
Type: Boolean
isPointerHookDefaultValue
Type: UInt64

See Also

Hook
robotManager.MemoryClass Namespace


LockFrame Method

Hook..::..LockFrame Method

Namespace: robotManager.MemoryClass
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public void LockFrame()
Public Sub LockFrame
public:
void LockFrame()

See Also

Hook
robotManager.MemoryClass Namespace


UnlockFrame Method

Hook..::..UnlockFrame Method

Namespace: robotManager.MemoryClass
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public void UnlockFrame(
    bool force
)
Public Sub UnlockFrame ( _
    force As Boolean _
)
public:
void UnlockFrame(
    bool^ force
)

Parameters

force
Type: Boolean

See Also

Hook
robotManager.MemoryClass Namespace


GOFound Constructor

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public (
    Object guidInt128,
    string name,
    int entry,
    string continentName,
    string tilePath,
    string gameObjectType,
    Matrix matrix,
    int modelId,
    string modelName,
    string server,
    uint build
)
Public Sub New ( _
    guidInt128 As Object, _
    name As String, _
    entry As Integer, _
    continentName As String, _
    tilePath As String, _
    gameObjectType As String, _
    matrix As Matrix, _
    modelId As Integer, _
    modelName As String, _
    server As String, _
    build As UInteger _
)
public:
(
    Object^ guidInt128,
    String^ name,
    int^ entry,
    String^ continentName,
    String^ tilePath,
    String^ gameObjectType,
    Matrix^ matrix,
    int^ modelId,
    String^ modelName,
    String^ server,
    unsigned int^ build
)

Parameters

guidInt128
Type: Object
name
Type: String
entry
Type: Int32
continentName
Type: String
tilePath
Type: String
gameObjectType
Type: String
matrix
Type: Matrix
modelId
Type: Int32
modelName
Type: String
server
Type: String
build
Type: UInt32

See Also

GOFound
wManager.Wow.Class Namespace


ToString Method

GOFound..::..ToString Method

Namespace: wManager.Wow.Class
Assembly: wManager (in wManager.dll)

Syntax

C#
VB
C++
public string ToString()
Public Function ToString As String
public:
String^ ToString()

See Also

GOFound
wManager.Wow.Class Namespace


IsStarted Property

Main..::..IsStarted Property

Namespace: global
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public bool IsStarted { get; }
Public ReadOnly Property IsStarted As Boolean
    Get
public:
property bool^ IsStarted {
    bool^ get ();
}

See Also

Main
global Namespace


Settings Property

Main..::..Settings Property

Namespace: global
Assembly: Quester (in Quester.dll)

Syntax

C#
VB
C++
public UserControl Settings { get; }
Public ReadOnly Property Settings As UserControl
    Get
public:
property UserControl^ Settings {
    UserControl^ get ();
}

See Also

Main
global Namespace


AfterCall Property

Hook..::..AfterCall Property

Namespace: robotManager.MemoryClass
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
[ObfuscationAttribute]
public ulong AfterCall { get; }
<ObfuscationAttribute> _
Public ReadOnly Property AfterCall As ULong
    Get
[ObfuscationAttribute]
public:
property unsigned long long^ AfterCall {
    unsigned long long^ get ();
}

See Also

Hook
robotManager.MemoryClass Namespace


FrameIsLocked Property

Hook..::..FrameIsLocked Property

Namespace: robotManager.MemoryClass
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public bool FrameIsLocked { get; set; }
Public Property FrameIsLocked As Boolean
    Get
    Set
public:
property bool^ FrameIsLocked {
    bool^ get ();
    void set (bool^ value);
}

See Also

Hook
robotManager.MemoryClass Namespace


Memory Property

Hook..::..Memory Property

MemoryRobot - Memory lib.

Namespace: robotManager.MemoryClass
Assembly: robotManager (in robotManager.dll)

Syntax

C#
VB
C++
public Memory Memory { get; }
Public ReadOnly Property Memory As Memory
    Get
public:
property Memory^ Memory {
    Memory^ get ();
}

Field Value

MemoryRobot - Memory lib.

See Also

Hook
robotManager.MemoryClass Namespace