Jump to content
This site uses cookies! Learn More

This site uses cookies!

By continuing to use this site, you agree to allow us to store cookies on your computer. :)


Bot unable to "corpse run" | WoW 1.12.1 client

Recommended Posts

Dear wRobot crew & Droidz,

My friend and I have encountered an odd problem today, were none of our programs would "corpse run" after dying.
This resulted in the character just AFK'ing at the spirit healer, eventually disconnecting.

As troubleshooting generally requires a lot of info here goes:

  • OS: Windows 10
  • wRobot version: 2.2.5 (19784) for wow 1.12.1 (~5875)
  • Issues encountered: 11.01.2019

We've tried:

  • Deleting WDB & WTF.
  • Reseting wRobot settings to default.
  • Rebooting both programs.
  • Rebooting the PC's.
  • Using various FightClasses, profiles and "types" (Grinder, Quester etc).
  • Dying in different zones (Eastern Plaguelands, Un'goro Crater & Silithus)
  • Re-entering the order ID (For both wRobot & my FightClass)

Upon death the following shows up in the logs:

"[D] 14.11.59 - [Fight] Fight stopped
14.11.59 - [Resurrect] Player dead"

The  "[Resurrect] Player dead" message appears in the log every 10-25 seconds(See logs).
The log file is attached to the post, for good measure. 

It feels like this is a wRobot issue of some kind, however I do not know if others has encountered this issue these days.
We're living quite far from each other, using different kind of hardware and different classes.  The only common things are the server and the software(wRobot).

I hope that you'll be able to assist us, as we both really appreciate the software.
Thank you in advance.

Best Regards,


11 Jan 2019 14H06.log.html

Share this post

Link to post
Share on other sites

Hello, it is very strange, you have try to redownload and reinstall WRobot in new folder and run it when you are dead (to check if he run to corpse)? you have try to redownload wow client

Share this post

Link to post
Share on other sites

Hello Droidz,

As per your instructions I have tried to turn a completely blank page.

I have now made a completely fresh installation of wRobot & downloaded a new World of Warcraft 1.12.1 folder.
This however has been done on my Laptop, which have previous not been used to neither play WoW nor use wRobot.
This was to completely rule out the possibility of hardware & software issues on my desktop.

I ran the bot while dead as per your instructions, being dead at the spirit healer, and the bot didn't do anything.
The issue persisted even across hardware, with fresh installs.

I have attached the log files to this reply.

I have no idea what is wrong, as the bot worked flawlessly from the 27th of December where I purchased it, up untill the morning of the 11th of January. The issue seemed however to colide with the update you released around the same time, even tho it worked fine the first day. Might be worth to look at?

However please let me know if I can do any further to assist you with the troubleshooting.

Best regards,


12 jan 2019 11H41.log.html

Share this post

Link to post
Share on other sites

Can you try when you are dead to use product "Automaton" to be sure than problem is not caused by your profile, and you have try with another character? 

And when I told with fresh wrobot install, don't copy settings/profiles/fightclass, just launch WRobot and run automaton to check if he resurect

Share this post

Link to post
Share on other sites

We have now found a very odd "band-aid"-solution to the problem.

Apparently there's a buff granted to our characters upon death called "Waiting to Resurrect"(See attached picture below).

If I right-click this icon/buff and dismiss it, then the bot runs to the corpse and resurrects properly.
Is there a way to make the bot auto-dismiss this buff when it is present(When dead), so the bot may move again?
The fact that we would have to check up on the bot if it's dead to dismiss this thing, sort of defeats the purpose of this software a little bit 🙂

I hope that you can help! 🙂  


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now