Jump to content

Rogue opens with autoattack


Recommended Posts

I have not been able to find any working Cata rogue profiles, so I downloaded wotlk/mop/wod ones and tried to get them working. With some editing, it works for the most part.

However, sometimes it uses shadowstep but no ambush. It just opens with autoattack (sometimes with cheap shot, which is ok, sometimes with ambush, which is ideal, and sometimes with hemorrhage, BAD). 

Could someone have a look and tell me why?

Or maybe it isn't even the fight class settings itself?

 

Thanks in advance!

 

P.s. if anyone has working rogue profiles for cata please let me know!

Premed - v1.0.xml

Link to comment
Share on other sites

  • 2 years later...

Push!!

Same problem here with TBC.

The problem is that autoattack is activated when bot "starts to interact" there is no option to turn this off.

Should i write a ticket?

Link to comment
Share on other sites

  • 2 months later...

up!
wManager.Wow.Helpers.SpellManager.CastSpellByNameLUA("Shadowstep"); System.Threading.Thread.Sleep(250 * 1); wManager.Wow.Helpers.SpellManager.CastSpellByNameLUA("Cheap Shot");

somehow between these two spells i need bot to stop trying to autoattack target, and after cheapshot turn autoattack back on.
Fight.StopFight(); didnt help. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...