Jump to content

Recommended Posts

Two questions im trying to resolve before I put money into this bot. 

 

1. Is there a way to have wrobot detect custom wow application names? If wow.exe launches and its named "CoolServerBro", id like wrobot to be able to allow me to customize that name in it so it can detect the wow window. Manually name changing the wow window wither a third application is very annoying, and having devs of custom servers change their name because i want to bot on their servers is unreasonable and hilarious.

 

2. I have ONLY flying mount setup, yet the bot keeps flying at ground level taking ground-mount pathing to destinations. Meaning if im far away from a grind path, wrobots automatic pathing to get to the profile start location (not the profile waypoints, ive not tested them yet using the flying node mode.) of the profile takes ground pathing. In flyable areas. This looks extremely botty and lame.  

I have been looking through the forums all day and have not found a resolution for this. Just bad hacks that force the bot to press space when entering flight mode, and 'fixes' that never seemed to have worked as far back as 2013. Pathing in the air should be 100x easier than pathing on the ground going point-to-point in 98% of cases. Go up, fly directly toward end-location. If you hit something. Fly up more. Can we do this?

Link to post
Share on other sites

Hey,

1. I'll add option like that but rename only wow.exe file don't cause this problem (file is probably modified).

2. To avoid this problem you need to use "Flying" position. Bot is flying when he goes to "Flying" position. If it is not problem please share your log

Link to post
Share on other sites

Hi Droidz thanks for the reply.

So the exe probably is modified, and if this gets me detected, then I am willing to risk that (its been alright for a few months of me botting on and off) and I dont blame the bot if I do get detected. The rename/ability to see custom name of the window is mainly for flexibility and I can ditch having to rename 5 windows everytime. 

 

As for the flying, I will check again and post a log if it continues to be a problem. 

Link to post
Share on other sites

Yes, I've been doing it that way for a week or so, its tedious but for now it at least gets the bots to run. This is a big issue for me though becus ethe relogger does not work, and with 5+ accounts, watching a crash or a disconnect is constant gruelling maintenance 🙂

 

Do you have an ETA on wrobot able to detect Ascension again without these extra steps? A simple window name change works but like i said it has other problems. I was looking here in the relogger (see picture). I got hopeful that the "window name" part would let me change it to "Ascension" and get the relogger to see the window and run as usual, but it doesnt seem to work that way. I changed it back to "World of Warcraft", hoping that maybe the relogger would launch the "path to wow" executable, and then rename it to "World of Warcraft", but again no luck. 

 

My final hope it that i can make a .bat file that will launch ascension.exe and change the name at the same time, and then have the "path to wow" point to that .bat file...

 

QyLuQY8[1].png

Link to post
Share on other sites

Try to use this relogger plugin (no tested), save it as .cs file in the folder "WRobot\Plugins\Relogger\":

using System;
using System.Runtime.InteropServices;
using System.Windows.Forms;

namespace Renamer
{
    public class RenameWowWindow : Relogger.ReloggerPlugin
    {
        public override string Name { get { return "Rename wow window"; } }

        [DllImport("user32.dll")]
        static extern bool SetWindowText(IntPtr hWnd, string text);
        
        public override void OnStart()
        {
            Relogger.Events.OnStartBot += (profile, cancelable) =>
            {
                if (profile.ExistWowProcess() && profile.CurrentWowProcess.MainWindowTitle != "World of Warcraft")
                    SetWindowText(profile.CurrentWowProcess.MainWindowHandle, "World of Warcraft");
            };
        }
        
        public override void OnStop()
        {
        }

        public override void OnButtonPress()
        {
            MessageBox.Show("No settings");
            base.OnButtonPress();
        }
    }
}

 

Link to post
Share on other sites

Okay tried it out, and it gave me an error about a missing .DLL file. Looks like it didnt compile (i guess these compile and go into that dll folder?). I changed events to event but same issue.

 

[E] 02:45:58 - Cannot compile plugin 'C:\Users\padun\Desktop\Ascension Launcher\resources\client\_WRobot\\Plugins\Relogger\plugin.cs': Compilator Error :
c:\Users\padun\Desktop\Ascension Launcher\resources\client\_WRobot\Data\temp\dnzig5zf.0.cs(16,22) : error CS0234: The type or namespace name 'Events' does not exist in the namespace 'Relogger' (are you missing an assembly reference?)

[E] 02:45:58 - Cannot load plugin 'C:\Users\padun\Desktop\Ascension Launcher\resources\client\_WRobot\\Plugins\Relogger\plugin.cs': System.IO.FileNotFoundException: Could not load file or assembly 'file:///C:\Users\padun\Desktop\Ascension Launcher\resources\client\_WRobot\Data\temp\dnzig5zf.dll' or one of its dependencies. The system cannot find the file specified.
File name: 'file:///C:\Users\padun\Desktop\Ascension Launcher\resources\client\_WRobot\Data\temp\dnzig5zf.dll'
   at System.Reflection.RuntimeAssembly._nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, RuntimeAssembly locationHint, StackCrawlMark& stackMark, IntPtr pPrivHostBinder, Boolean throwOnFileNotFound, Boolean forIntrospection, Boolean suppressSecurityChecks)
   at System.Reflection.RuntimeAssembly.nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, RuntimeAssembly locationHint, StackCrawlMark& stackMark, IntPtr pPrivHostBinder, Boolean throwOnFileNotFound, Boolean forIntrospection, Boolean suppressSecurityChecks)
   at System.Reflection.RuntimeAssembly.InternalLoadAssemblyName(AssemblyName assemblyRef, Evidence assemblySecurity, RuntimeAssembly reqAssembly, StackCrawlMark& stackMark, IntPtr pPrivHostBinder, Boolean throwOnFileNotFound, Boolean forIntrospection, Boolean suppressSecurityChecks)
   at System.Reflection.Assembly.Load(AssemblyName assemblyRef, Evidence assemblySecurity)
   at System.CodeDom.Compiler.CompilerResults.get_CompiledAssembly()
   at Relogger.ReloggerPlugin.LoadPlugin(String pathOrUrl)

WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].

 

 

Link to post
Share on other sites

This is much better great plugin!

 

However what is happening now is it opens wow, does its thing well with renaming, then opens wrobot. Wow finishes logging in and then 1 of 2 things happends:

1. Wrobot doesn't fully finish launching to its main window ("launch bot" and "please connect to the game" window) Before wow can finish loading up, relogging quits wow and quits wrobot and tries again

2. Wow finished loading and i get ingame, and 5 or so seconds later wrobot also loads and starts playing the tasks i have it play. Then relogger force-quits wow and wrobot and this also repeats??

 

Am i bad luck? I have tried it with and without the ping, i have tried default wait times and long wait times too

Relogger 060221 032926 720x1000.png

Link to post
Share on other sites

Log:

[D] 03:34:32 - [Info] Log file created: 2 Jun 2021 03H34.log.html
03:34:32 - Relogger 1.2.0 (21544) started.
[D] 03:34:32 - [Info] Offical website: https://wrobot.eu/
[D] 03:34:32 - [Info] Operating System Details: Windows 10 Enterprise
[D] 03:34:32 - [Info] Lang: English (United States)
03:34:32 - Tips: To improve CPU usage, it is recommended to minimize this window when unused.
03:35:45 - Start profile Profile name.
03:35:45 - Profile Profile name, Run task[1]: Run (Run)
[D] 03:35:45 - Profile Profile name, running task for 62.2196562784815 minutes.
[D] 03:35:46 - Profile Profile name: Launch Wow.
[D] 03:35:52 - Profile Profile name: Launch bot.
[D] 03:36:07 - Profile Profile name: Wait 15 seconds before to relaunch Wow/bot.
[D] 03:36:22 - Profile Profile name: Launch Wow.
[D] 03:36:28 - Profile Profile name: Launch bot.
[D] 03:36:43 - Profile Profile name: Wait 15 seconds before to relaunch Wow/bot.
[D] 03:36:58 - Profile Profile name: Launch Wow.
[D] 03:37:04 - Profile Profile name: Launch bot.
[D] 03:37:19 - Profile Profile name: Wait 3 seconds before to relaunch Wow/bot.
[D] 03:37:21 - Stopping profile Profile name, please wait.
03:37:22 - Profile Profile name stopped.
03:38:22 - Start profile Profile name.
03:38:22 - Profile Profile name, Run task[1]: Run (Run)
[D] 03:38:22 - Profile Profile name, running task for 63.7741553661293 minutes.
[D] 03:38:23 - Profile Profile name: Launch Wow.
[D] 03:38:29 - Profile Profile name: Launch bot.
[D] 03:38:44 - Profile Profile name: Wait 3 seconds before to relaunch Wow/bot.
[D] 03:38:47 - Stopping profile Profile name, please wait.
03:38:47 - Profile Profile name stopped.

 

Link to post
Share on other sites

So after more testing, i believe the relogger thinks the bot crashed and tries to reload it. 

Unticking "Relaunch if wow or bot crash" allows the bot to get fully running and not trigger it thinking its crashed. However this now makes it so the bot wont relaunch if actually does crash, but at least we know whats wrong. This is still much better than it was this morning. Thanks Droidz.

 166316956_Relogger060221035234383x202.png.29b04ad810dca8608e9376206f599b75.png

Link to post
Share on other sites

Yes I do not use the ascension launcher for this, and I can login with the ascension.exe manually.

The relogger allows this too as long as I dont select "relaunch if wow or bot crash". If I select that then the relogger thinks ascension.exe has crashed. Likely because its a modified wrath wow.exe that wrobot doesn't fully recognize as a working version of the wrath client, even though it functions fine ingame.

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...