Jump to content
This site uses cookies! Learn More

This site uses cookies!

By continuing to use this site, you agree to allow us to store cookies on your computer. :)

Sinjien

Need help with using an item at a location.

Recommended Posts

I having nothing but problems with a profile quest in Eversong Woods (WoTLK).

I have the previous 45 or so quests working fine, but this one is the simplest of them all but nothing I have tried works.

The quest ("Whitebark's Memory") requires that you use an item ("Old Whitebark's Pendant") next to a giant runestone, which spawns "Whitebark's Spirit" that you have to fight until he turns into an NPC that you turn the quest into.

I have used UseItemOn in the editor with numerous hotspots all around the runestone, but no matter which location I enter, it goes to the same spot each time and just stands there, not using the item.

I know I am at a valid location and verified the item is in the bags, because I can manually click on the item and it continues the quest.

I have also tried OverridePulseCSharpCode and FullCSharpCode, creating a separate quest in the profile to pulse this step, but nothing works.

The only runestone that shows up in the GameObject dump as - Scorched Grove Runestone: 181260 (0 ; 0 ; 0 ; "None", 10407.02y) but using its ID or name in the editor doesn't work either plus that location leads me to believe maybe it might not actually be it.

 

if (wManager.Wow.Helpers.ItemsManager.GetItemCountByIdLUA(28209) == 1);
    {
    var position1 = new Vector3(8206.86f, -6337.222f, 64.50987f); // Directly in front of Runestone - Character stops somewhere in the vicinity each time, but never at the location specified.
    var position2 = new Vector3(8211.855f, -6336.466f, 64.50996f); // Where Whitebark's Spirit will be standing to interact with.
    int npcID = 19456; // Whitebark's Spirit NPC ID
    wManager.Wow.Bot.Tasks.GoToTask.ToPosition(position1);

    //ItemsManager.UseItem(28209);
    ItemsManager.UseItem("Old Whitebark's Pendant"); // This actually worked only 1 time I started the bot at the precise location instead of a test distance away but it would not interact with the NPC.
    wManager.Wow.Bot.Tasks.GoToTask.ToPositionAndIntecractWithNpc(position2, npcID);
    wManager.Wow.Helpers.Quest.CompleteQuest();
    return true;
    }    

return true;

Any ideas?

WhiteBarksMemory.xml

Share this post


Link to post
Share on other sites

There is no object to use the item on and I have always left the "Object" box in the editor blank.

As you can see from the code above, I am simply attempting to travel to the location and use the item.

I have also tried RunMacroTask("/use Old Whitebark's Pendant"); - which the macro works fine if I type it into the client, but not from the bot.

Share this post


Link to post
Share on other sites

I finally figured it all out....it appears when you accept this quest, it was showing "Complete" when I dumped current quests (and apparently this quest does not report objectives), so it did not pulse the next step and went straight to turn in.

Since there was no turn in NPC, it just stood there.

I had to create an "IsComplete" condition that the NPC was Alive and Not Attackable. then it properly went to the position, used the item, was automatically attacked by Whitebark and once the bot fought it down to 35%, he turned green and satisfied the condition for pulsing next step to turn in.

Although if you have the bot set to ignore being attacked, this would fail.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...