Jump to content

The People's Militia part 1 never complete


Recommended Posts


I have some major issues with the quest "The People's Militia" . The bot won't recognize that the quest has been completed and just continues grinding the specified mobs. It doesn't change if I use manual objective count, it doesn't change if I use full C#, it doesn't change if I use custom complete condition. Furthermore, Quest.GetQuestCompleted and Quest.IsObjectiveComplete always return false, even if the quest is complete. The Current Quests Memory info does display weird values as well, as you can see on the picture below (quest was complete in quest log). First value increments by 64 sometimes, sometimes by 1. The second one does increment by 1 if the first counter goes too high(?). The state there says "complete", but has no effect.

It's just this one quests. I recorded several hundreds of quests over the last months, but the only quest with this issues has been PPM part 1. The following similar quests of this chain function without any issues. Version is vanilla.

Someone an idea, why this specific quest causes so much trouble?



3 Feb 2018 13H03.log.html

Link to comment
Share on other sites

Hello :) I don't currently have a human of suitable level on a vanilla server to test for myself, but I have made some modifications to the way the quest is completed and I think this should work for you. I've ran into almost the same issue on a few quests and was able to solve it this way. Would you be willing to test it for me and let me know if this fixes your issue? If it doesn't work, I'll likely level up a human to Westfall so I can figure out why it's not working and assist you in getting this solved by actually testing it via a character. I also noticed when searching that you had this issue on your alliance quester from last year, and you said it was solved with Matenia's help? Is her fix no longer working, or it was never working the way you wanted? Hope this works for you :)

Edit: I am getting an error trying to upload any files via the attachments here on the forums, so I uploaded the .xml via another site so you can download it. Here's the link: https://ufile.io/bvvo8

Link to comment
Share on other sites

I tried running your code, but it is only functioning if I only run this quest alone. It doesn't function if it's embeded in the whole profile. @Droidz Can other quests / general killing of mobs effect the objective counter? Is there a way to force reset the objective counter without stopping the bot, before pulsing this quest?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...