Jump to content

[Need Help] Bot stopping and other things


xsonz
 Share

Recommended Posts

Hey all, I bought a bot couple of days ago and I am having some problems, hope you can fix it.

First thing: My char sometimes stucks on a flat surface. There is no obstacles or anything like that on the ground. He just starts running in circle or something similar and bot log says he stucked and after some time char logs out. (and does not log back in.)

I attached my bot log for you to see.
 

 

Second: More often than not, my char keeps running couple of yards (10-15y) away from mob after killing him and then comes back to loot and skin. It's not a major problem but its time consuming over time and looks un-natural to someone who looks at him (lets say if there is another player near.)

 

Third: I created macro in game to open 'Plump Intestines' and placed it in action bar position 1. In general settings under 'my macros' I activated macro 1 and changed 'x time' to 10, told him to use it out of combat and when not on the mount but bot doesn't use it. I tested the macro myself by clicking on it ingame and it works, but bot doesn't  use it on his own.

 

 

I would appreciate any help you can give me.

 

Thanks,
Xsonz

 

 

UPDATE: I noticed,according to bot that macro is ran after every kill (Bot state > Bot: My Macro) , however, plump is not used/opened.

 

I know there is way to change this, but I don't know how. Any ideas?

4 Nov 2013 11H20.log.html

Link to comment
Share on other sites

For your macro after looting you can also use option "Auto Make Elemental" (in "General settings" > "Advanced settings" > Tab "Looting and Farming...") and open with notepad "WRobot\Data\autoMakeElementalMacro.txt" and add this line:

itemName = GetItemInfo(72201) if GetItemCount(itemName) > 0 then RunMacroText("/use " .. itemName) end

(don't forget to save file).

 

Can you give me position where your character sometimes stucks?

 

Thanks

Link to comment
Share on other sites

Hey Druidz, thx for the macro alternative but I did what you said but he still doesn't use Plumps.

 

I added that line to 

"WRobot\Data\autoMakeElementalMacro.txt"

and checked the box on Auto Make Elemental.

 

Am I missing something?

 

P.S. The bot kept stucking on that spot where I was farming so I changed the spot, created new profile and it seems fine for now. So that problem is gone for godo. (I hope)

Link to comment
Share on other sites

Btw, not casting buffs on himself and not opening Plumps is irritated but I can live without it. It's not a big deal.

 

What bugs me the most is the fact that in 3 days I have this bot, I didn't run it longer than one hour straight, it always stucks somewhere and logs out.

 

To clarify that last part: I am not running my third or fourth profile and the problem is always the same. He makes couple of rounds (grinding between given spots) with no problem what so ever, and then at one point he somehow stucks on the spot he passed already couple of times with no problem,and logs out and doesn't come back in game. 

 

When I manually start him again (without even stopping the bot), he just continues from that "stuck" spot like nothing happened. Which means, he wasn't stuck in a first place. (but of course, logs says he did.) . I don't get it and it drives me crazy.

I changed couple of grinding locations I made couple of profiles for each (ground, fly paths)...I did everything I could think of..but it continues to happen.

 

And this is always around 60min of grinding. (sometimes is after 15min, sometimes 35,somtimes 1hour and 2min)...

If you have any idea why is this happening, please tell me because I can't take it any longer.

I bought the bot so I don't have to play, but it turns out I am playing it more now than I played before xD

 

 

 

UPDATE: I found a profile of someone else here on forum for the same spot I was farming, so I decided to try it out.

 

I can't say I am surprised, but here is the result.

 

In short:

[D] 16:30:13 - Profile used: Krasarang Wilds- Kea Krak.xml
17:27:15 - Relog Player

He farmed for 57min and somehow stuck. Note that,the creator of profile did something wrong with hotspots so I found my char on a close by island when I logged back in, but non the less... look at the picture below to see where it "stucked".
 
 
16m8zrp.png
 
There is nothing close by to stuck..and he did it..

I also uploaded the log for you to see.

6 Nov 2013 16H24.log.html

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...