Jump to content

Blacklist being ignored


zomgqwert
 Share

Recommended Posts

Hello, I've been having some problems blacklisting certain zones while using The script itself is excellent and I highly recommend it, but there are a few problem spots that I added to the blacklist in the script to avoid underground nodes. However, when I run the scripts, I find that the blacklisted location is being ignored, and it is still trying to gather ore from an underground node. From what I could see, I figured that the problem might lie within the script's blacklist, so I opened it up with the profile editor and found that the zones were set to "None" (having them edited earlier using the profile creator under product settings).

 

When using the profile creator, it allows me to select the zone to the matching location (HawaiiMainland) as shown here:

b571.png

 

Once selected, I save it and re-open it it shows this:

3ud5.png

 

When looking at the XML for the script I find that it is indeed saved as "None" instead of "Hawaii Mainland" as shown here (highlighted):

mmfa.png

 

Even when editing the script through a word processor, and changing "None" to "Hawaii Mainland", when I run the script and re-open the file, it has been reverted to "None". Even weirder so, the highlighted area is still shown on the map; showing that it recognizes there is a blacklist in that location (or at least the map knows, but the bot doesn't).

 

What I am thinking here, is that there might be a setting that I forgot to set when using blacklist, or there might be a problem occurring with the bot itself that I am not aware of. If anyone has a solution or a workaround to this problem, feel free to post it.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...