Jump to content



Recommended Posts

Being in the instance at some point I want to turn off the patfinder and then turn it back on


Tried several options but does not work since there is no documentation for wManager

wManager.wManagerSetting.CurrentSetting.PathFinder = false;

wManager.wManagerSetting.CurrentSetting.UsePathFinder = false;


Found a problem here on the forum. It was a syntax error. It is necessary like this: UsePathsFinder
But this did not solve the main problem:
To move through the dungeon, I use a FollowPath. At the first pass, everything looks perfect and everything happens as I planned. But when the bot enters the next time in the dungeon, it starts from the last point of the first FollowPath. And in order to run along the short path the bot runs into the door that can not be opened until the final boss is alive. In total, the profile uses 3 followers, but only the first one works incorrectly. disabling the pathfinder solved the problem with the door but now the bot is trying to run to the last point "through the walls"

Link to comment
Share on other sites

On 23.03.2018 at 6:02 PM, Droidz said:

Hello, use quest type "follow path" and put lower search radius don't resolve this problem?

Solved the problem with "Reset" action
But there is still a problem with the resurrection if death is inside the dungeon.
There are several ways to implement this through various checks. But I encounter a trivial problem with the fact that in the event of death, not the code of the quester does not execute, but its main code, and therefore, in any case, first he tries to resurrect himself by running to the corpse and he does not care about all the conditions.
Perhaps there is a way to force a bot to execute code in the thread or check the condition instead of trying to resurrect in the usual way?

Link to comment
Share on other sites

  • 5 years later...

very sorry for bringing this topic back to live, but I have been seaching the forum for solution and have no result. I have exactly the same problem you had.

May I know you solved the problem with "Reset" action?

I'm using gatherer profile, and I have no idea how to use the quester profile.

I know there is very little hope you still see this post but I want to try my luck.


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...