Jump to content

Wrobot making WoW Crash in Virtualbox


Recommended Posts

I have tried Wrobot on VirutalBox (Windows 7 32 bit). It crashes my WoW every time. Just before it crashes my WoW it asks about updating DirectX  saying "Cannot initialize Directx, you need to update it, do you want update DirectX now?" After it tries to launch the bot, it crashes my wow saying "Error #132 (0x8510084) Fatal Exception" ... "instruction at "0x04E903DC" referenced memory at "0xDB4802E9" The memory could not be "read". 

I have tried downloading both Directx 11 and SlimDX onto the VirtualBox. It has not worked. I also installed the "Guest Additions" with the "Direct3D" support. Still doesn't work. Does anyone have any suggestions or work-a-rounds?

Thanks!

Link to comment
Share on other sites

hi iroy,

i have always taken the VMwarePlayer. Here you have no problems with the DX support.
VMbox is a great VM but if you want to bot I would recommend you from experience rather the VMPlayer. Had a better / error-free DX support as with the VMbox.

The player is also free

one tip
if you want in the vm bot you have to adjust the mouse in wow
hardware or software because otherwise the mouse moves very quickly simply change

 

have a nice day

Link to comment
Share on other sites

2 hours ago, snow21 said:

hi iroy,

i have always taken the VMwarePlayer. Here you have no problems with the DX support.
VMbox is a great VM but if you want to bot I would recommend you from experience rather the VMPlayer. Had a better / error-free DX support as with the VMbox.

The player is also free

one tip
if you want in the vm bot you have to adjust the mouse in wow
hardware or software because otherwise the mouse moves very quickly simply change

 

have a nice day

Looks like you have to pay for this program?

Link to comment
Share on other sites

On 9/8/2018 at 7:23 AM, Matenia said:

Try running wRobot with the NoDX shortcut!

This definitely helps, however, now the bot is giving me another error.  "Hooking Error"..."Error during hook test. If the program freezes or has problems, I recommend to change your ingame directx version."

Then when I get into the bot it just freezes up the entire time.

I looked at how to maybe repair this, but no solution for me so far.

-Tried reinstalling, Running as Admin, Running "No Lock Frame", Deleting WTF folder.

Link to comment
Share on other sites

  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...