Jump to content

Stop looting with full bags


Recommended Posts

Hey @Droidz Since vendoring is Not perfect on wrobot, sometimes i have problems with bots grinding with full bags, The problem is even if bot relog and he get correct vendor in database, he trying to go ToTown, but he loop between 2 unlooted mobs forever, before mob corpse disappears, but most likely new mob will respawn and bot kill him, making another corpse unlooted, Any fixes for disable loot when you go toTown etc? Probably default blacklist unit timer can solve it, my server has high respawn rate and i'm on 12 sec

Link to comment
Share on other sites

Hey,

You can increment option "wManager.wManagerSetting.CurrentSetting.BlacklistUnitDefaultTimeMs" (default: 120000 ms (2 minutes))

Or you can increment option "wManager.wManagerSetting.CurrentSetting.MinFreeBagSlotsToGoToTown" (default 2) (you can found this option in advanced general settings)

Or you can try plugin like:

using wManager.Wow.Bot.States;
using wManager.Wow.Helpers;

public class Main : wManager.Plugin.IPlugin
{
    public void Initialize()
    {
        robotManager.Events.FiniteStateMachineEvents.OnBeforeCheckIfNeedToRunState += (engine, state, cancelable) =>
        {
            if (state is Looting && Bag.GetContainerNumFreeSlotsNormalType == 0)
                cancelable.Cancel = true;
        };
    }

    public void Dispose()
    {
    }

    public void Settings()
    {
    }
}

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...