Jump to content

Click to accept / Click to Turn In Quests. Droidz Budday!


Networkz
 Share

Recommended Posts

I TOOK TO LONG OF A BREAK I FORGET IT ALL ! ! ! ! ! OMG ! ! !

Okay So ive Been through the Forum and Been looking and i did find what i thought was an answer to my question, I in turn tried it out and am still experience an issue.

My Log Comes up with the steps and the steps actually look good, I dont have any debug errors or errors at all.

 

But when i use (EDIT* 35933 is the Quest Azeroths last stand. This is for starting your 90 - 100 Journey.. and i beleive the second turn in for 90 - 100, after doing the quest The Dark Portal.

 

wManager.Wow.Helpers.Quest.CompleteQuest(35933);

 

 

or

 

Thread.Sleep(3500);
wManager.Wow.Helpers.Quest.CompleteQuest(35933);

 

 

 

It just stands there, It doesnt try and open the window to accept the quest or Turn it in..

 

And Also If i wanted to accept one or more of these types of quests would the code look like this or would this work for accepting or not lol.. Sorry this is like relearning my ABC's

 

wManager.Wow.Helpers.Quest.AcceptQuest(35933);

 

The Log is Fairly Long and 95% of my issues are all at the bottom, I went through and deleted the first quest on the profile because ill just make it start in the Blasted lands. Ummmmm!!! What else.. Yea thats about all. Everything at the bottom of log is my issues lol. top 75% is irrelevant to the question so far xD

 

This is also quite literally the very first quest on the profile lol!

21 May 2015 12H15.log.html

90-100 Horde.xml

Link to comment
Share on other sites

Is anything wrong with the code droidz.. I can't seem to find a mistake in it. Was practically a copy / paste from yours haha!

Link to comment
Share on other sites

Hello,
 
"wManager.Wow.Helpers.Quest.CompleteQuest" works only if you have target quest giver (no on popup quest).
 
To resolve your problem look this profile:  (steps 10, 11, 12, 13).
 
You need to, in "Quests order editor":

  • Add steps type While with param :
    wManager.Wow.Helpers.Quest.HasQuest(35933)
    
  • Add steps type RunLuaCode with param:
    RunMacroText("/click ObjectiveTrackerBlocksFrameHeader"); 
    RunMacroText("/click QuestFrameCompleteButton"); 
    RunMacroText("/click QuestFrameCompleteQuestButton"); 
    
  • Add steps type Wait with param:
    1500
    
  • Add steps type EndWhile.
Link to comment
Share on other sites

  • 3 months later...

Having the same issues, tried the code above - but it's still not accepting, Any ideas? 

PS, The profile itself has been uploaded under the name 'Redridge - A few more quests' I've had the quester just hand in at Magistrate soloman but if you guys could shed some light on why I couldn't get it to work that'd be gravy.

Edited by Deathguardjamie
Link to comment
Share on other sites

  • 1 month later...

Hello,

It is possible that the name of the buttons changes on some quests.

You can get the name of the buttons with this script: http://wrobot.eu/forums/topic/1689-useful-scripts/?do=findComment&comment=8447

In this script replace "TheButtonName" by name returned by the script

RunMacroText("/click TheButtonName"); 

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...