Jump to content

Using "Combat only = true" spells when not in combat...


Recommended Posts

Hi

I want the bot to only cast Bloodrage if he is in combat. however, even with these 2 options. "combat only = true" and a spell condition of "me in combat = true" he still casts it when he's running around and ready to engage. 

This hinders the warriors ooc healing ability and stops him using charge. 

Am i missing something here?

Thanks

 

 

image.png.5b8935a7514855f2c1bdef2e4a27654a.png

Link to comment
Share on other sites

In Combat for wRobot means flagged for combat or even just starting a fight.
Use C#  => ObjectManager.Me.InCombatFlagOnly
Which is just combat flag, or
ObjectManager.GetObjectWoWUnit().Any(u => u.IsTargetingMe) 

Link to comment
Share on other sites

2 hours ago, Matenia said:

In Combat for wRobot means flagged for combat or even just starting a fight.
Use C#  => ObjectManager.Me.InCombatFlagOnly
Which is just combat flag, or
ObjectManager.GetObjectWoWUnit().Any(u => u.IsTargetingMe) 

Thanks @matenia I'll give that a whirl! So neither of the 2 options i linked are actually "in combat"? they are both referring to in combat or "about to be in combat"? strange. 

Link to comment
Share on other sites

1 hour ago, KDiddy said:

Try using Target in Combat Range = True

I dont want them in range though, i want to be physically in combat before using it ? could try some kind of <10 yrd range though

Link to comment
Share on other sites

21 hours ago, KDiddy said:

It works perfectly for me on that setting ?

I have it prioritised just after a charge check, so I don't lose the option to close in quick if needed.

Thanks, this does indeed work. The Target in combat range must mean target in melee range. He now only does the range if he is in combat and already charged or unable to charge. ?

 

Thanks

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...