Jump to content
This site uses cookies! Learn More

This site uses cookies!

By continuing to use this site, you agree to allow us to store cookies on your computer. :)

ScripterQQ

Huge FPS Drops and freezes while using Battlegrounder

Recommended Posts

So recently I noticed the battleground product causes major fps drops, when I stop WRobot the game goes back to smooth (50-60 fps), the moment I press start on WRobot it drops to 10-20 fps, and it stucks very often, like there is a cpu/memory issue (in fact I noticed the cpu usage is huge, usually100%). I remember time ago running smooth even 4-5 battlegrounder together with no problems.

Any idea about how to fix this? I tried even with no addon, same problem. I tried also that "max fps<50>" in the file settings but didn't work.

Thanks for any help.

Share this post


Link to post
Share on other sites
10 minutes ago, ScripterQQ said:

So recently I noticed the battleground product causes major fps drops, when I stop WRobot the game goes back to smooth (50-60 fps), the moment I press start on WRobot it drops to 10-20 fps, and it stucks very often, like there is a cpu/memory issue (in fact I noticed the cpu usage is huge, usually100%). I remember time ago running smooth even 4-5 battlegrounder together with no problems.

Any idea about how to fix this? I tried even with no addon, same problem. I tried also that "max fps<50>" in the file settings but didn't work.

Thanks for any help.

on what server?

Share this post


Link to post
Share on other sites

I noticed it happens when I have multiple WoW windows, but I remember multiboxing 5 chars together with ISBoxer and WRobot, and I have a laptop..So I don't know if something changed in last updates but the CPU basically is always at 100%, WoW is at 40% around and each WRobot is 30-35% (which is huge imho). How can I reduce the WRobot %?

Any help is appreciated 🙂

Share this post


Link to post
Share on other sites
22 minutes ago, ScripterQQ said:

I noticed it happens when I have multiple WoW windows, but I remember multiboxing 5 chars together with ISBoxer and WRobot, and I have a laptop..So I don't know if something changed in last updates but the CPU basically is always at 100%, WoW is at 40% around and each WRobot is 30-35% (which is huge imho). How can I reduce the WRobot %?

Any help is appreciated 🙂

Disable all plugins and delete the fightclass out of the settings (just select it and hit backspace) then start battlegrounder, is the CPU usage then a lot lower? If yes then it's likely some poorly coded plugin or fightclass causing your issues.

Share this post


Link to post
Share on other sites
1 hour ago, Marsbar said:

Disable all plugins and delete the fightclass out of the settings (just select it and hit backspace) then start battlegrounder, is the CPU usage then a lot lower? If yes then it's likely some poorly coded plugin or fightclass causing your issues.

Ok it was the fight class. But it happens on every class I use (Paladin, Priest, Warrior, Rogue) and they never lagged so bad, so I don't understand how suddently every fight class makes the game freeze.

Anyway, how can I focus where is exactly the problem in the fight class? I don't think it's poorly coded, my fight classes are all made by myself step by step. Can it be a fight class too complex and long? For example I use a lot of LUA conditions (for kick, for stunning, for trinket..). And the warrior's fight class one has like 6-7 rows of charge/intercept based on every scenario (it's 30kbs size). But again, these fight classes never lagged so I don't know...

 

EDIT: Also I remember, if I run 1 single WoW session, the fight class is smooth, doesn't make lag/freezes. So I believe it's my computer at this point, I just wanted to know if something has changed in WRobot that now requires more memory/better CPU.

Share this post


Link to post
Share on other sites
17 hours ago, ScripterQQ said:

Ok it was the fight class. But it happens on every class I use (Paladin, Priest, Warrior, Rogue) and they never lagged so bad, so I don't understand how suddently every fight class makes the game freeze.

Anyway, how can I focus where is exactly the problem in the fight class? I don't think it's poorly coded, my fight classes are all made by myself step by step. Can it be a fight class too complex and long? For example I use a lot of LUA conditions (for kick, for stunning, for trinket..). And the warrior's fight class one has like 6-7 rows of charge/intercept based on every scenario (it's 30kbs size). But again, these fight classes never lagged so I don't know...

 

EDIT: Also I remember, if I run 1 single WoW session, the fight class is smooth, doesn't make lag/freezes. So I believe it's my computer at this point, I just wanted to know if something has changed in WRobot that now requires more memory/better CPU.

Hello, no recent change, and recent versions are normally very optimized (compared to the olds), only in TBC you get problem with CPU usage if you have a lot of players in your zone.

Share this post


Link to post
Share on other sites
7 hours ago, Droidz said:

Hello, no recent change, and recent versions are normally very optimized (compared to the olds), only in TBC you get problem with CPU usage if you have a lot of players in your zone.

Do you have any tip about improving my computer performance? Like some folders to clean, I don't know..I remember time ago I was so smooth with 4+ windows 😞 I don't know what happened

Share this post


Link to post
Share on other sites
12 hours ago, ScripterQQ said:

Do you have any tip about improving my computer performance? Like some folders to clean, I don't know..I remember time ago I was so smooth with 4+ windows 😞 I don't know what happened

I'd say just try to optimize your fcs, even the most advanced fcs shouldnt increase the cpu constantly, only temporarily while they do some pathfinding or similar. You using a xml or cs fc? you could increase the sleep between rotations which would probably also give you some performance gains. 

Share this post


Link to post
Share on other sites

Warmane has lags on high populated battlefields, like IoC. And if your fightclass has high fps settings, it will 100% freeze wow client, because client cant handle all robot commands. Simply leave such BG's or slow down your fightclass and all plugins.

If you lpay random, use BG blacklist and this plugin: 

 

Share this post


Link to post
Share on other sites

Nono it goes smooth on Alterac valley, even against Multiboxers, it's not an issue, until I launch another WoW window.

I will try with different fight classes, maybe some basic with 1-2 spells and see if I still get the problem.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...