Jump to content

Bot does not rest before re-engaging after death


Recommended Posts

So my bot dies, then walks back to the corpse. Two different problems:

1. The bot will resurrect on top of the corpse, regardless of whether there is an enemy nearby.
Please research/review Honorbuddy and copy their behavior - the bot TRIANGULATES between corpse and closest enemies, to find THE BEST LOCATION TO RESS AT. I mean this is so basic I can't even believe I'm here writing this.

2. The bot will re-engage in griding/fightting BEFORE IT RESTS. PLEASE ENSURE BOT HAS FULL LIFE AND MANA BEFORE RE-ENGAGING, another "DUH" bug.
 

With the two bugs above, bot will engage into chain-deaths until I stop the bot and move it somewhere safe. These bugs prevent AFK botting, especially for weaker characters at lower levels.

Link to comment
Share on other sites

You would want higher value regen options... IE. Eat at 55 instead of default 35. 

As an aside. WROBOT, alteast for vanilla definitely does try to find the best spot to rez at. My bot 99% of the time pretty much will rez on the exactly location it dies in. IE. it's corpse. I agree with OP on his first point. Could a better safe area be determined when rezurecting?

Link to comment
Share on other sites

On 22. 12. 2017 at 10:30 PM, Marshalek said:

So my bot dies, then walks back to the corpse. Two different problems:

1. The bot will resurrect on top of the corpse, regardless of whether there is an enemy nearby.
Please research/review Honorbuddy and copy their behavior - the bot TRIANGULATES between corpse and closest enemies, to find THE BEST LOCATION TO RESS AT. I mean this is so basic I can't even believe I'm here writing this.

2. The bot will re-engage in griding/fightting BEFORE IT RESTS. PLEASE ENSURE BOT HAS FULL LIFE AND MANA BEFORE RE-ENGAGING, another "DUH" bug.
 

With the two bugs above, bot will engage into chain-deaths until I stop the bot and move it somewhere safe. These bugs prevent AFK botting, especially for weaker characters at lower levels.

  1. WRobot does that
  2. WRobot does that

If it doesn't for you, the issue is with your settings / code. You would do yourself more good if you asked what might be causing this or how WRobot handles these scenarios instead of using CAPS and complaining that Wrobot doesn't work the way you are used to.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...