Jump to content

Bot spiraling up as high as possible


Recommended Posts

Hi, sometimes the bot will just start flying up and spiraling, and also do that when it reaches the top of the skybox. I've turned the radar on to see what it was doing, and it seemed like the bot wasn't trying to do that as it kept trying to click down, but the character wasnt reacting to it. I've turned all addons off and it still happened. Used gatherer

7 Jul 2020 10H02.log.html

Link to comment
Share on other sites

I'll give it a try. When it happens, even after i turn the bot off my character will still fly to the sky even if i try to interact with him by holding both mouse buttons to move or using w, it wont stop it flying up, only way to stop him flying is to press space, idk if that helps

Link to comment
Share on other sites

nope, radar3d just showed that the bot tried to move down to near ground level, and i believe that's what is causing it to spin, as because if i turn the bot off, my character will only just fly up

Link to comment
Share on other sites

  • 3 weeks later...

Hey, long time ago, but today i had again this issue.

 

at this char I use Druid_Feral_Leveling_ScripterQQ.xml and at another chars I used AiO. 

 

But here is my log. could be log, but at the and it happend.

EDIT: I also added another one, where it happens instantly

31_Jul_2020_08H59.log.html

31 Jul 2020 13H55.log.html

Link to comment
Share on other sites

  • 2 weeks later...

I have to say that this occurred for me as well when flying the path I had setup for Fishing.
Once Pathfinder has a problem finding a direct "route" to the nearest path "node", it will fly up and spiral until the bot is stopped.

Link to comment
Share on other sites

  • 1 month later...
  • 3 weeks later...

It is happening for me (and not only me) too. I need to press "space" or "q" / "e" because sometimes he is flying constantly up or behaving like the any of the strafe keys was pressed. Looking veeeeery bottish and can lead to very quick ban ?

 

Link to comment
Share on other sites

Hello,

In all of your logs you use option "Use lua to move", maybe this version of Wow have bug with lua move API (or WRobot sometime skip lua commands). Try to don't use this option (it is better to don't use this option for ractivity too)

Link to comment
Share on other sites

If anyone has time to try with this file: robotManager.dll (move and replace file in the "Bin" folder and ignore the update request when the bot starts). This file will log when WRobot presses a key, with several log files I could have been a better idea of what is happening with Wotlk (do not use 'Use lua to move' option)

Link to comment
Share on other sites

8 hours ago, Droidz said:

If anyone has time to try with this file: robotManager.dll (move and replace file in the "Bin" folder and ignore the update request when the bot starts). This file will log when WRobot presses a key, with several log files I could have been a better idea of what is happening with Wotlk (do not use 'Use lua to move' option)

Working on it now. Thanks!

Link to comment
Share on other sites

Hi, 

it is partially profile problem, WRobot can't find good position to fish and try to go underwater (you need to blacklist this spot).

But in your case seems to be CTM problem (not that wrobot keep key pressed).

I need more logs / videos to find commonalities. If you have this problem again do not hesitate to activate the radar3d (to see where WRobot wants to go) (and if you have time to do a tools> dev tool> all info)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...