Jump to content

Path finding during Gather


Recommended Posts

Since the 'file encrypter' release of wrobot im seeing that when a bot hits a gather pulse, it will spend 30-120 seconds on path finding.

Tried new install

Tried removing mesh's from new install

Each bot i run though- the second it hits a gather pulse- it sits still for a short wait... 

Anyone seen this / got ideas?

19 Aug 2017 19H09.log.html


Link to comment
Share on other sites

should be added

Re-recording the pulse points or the step doesnt really improve the situation.  after the long pause the bot Will go, eventually. 

Link to comment
Share on other sites


To avoid this problem you can try to put lower value at option "Search Radius" or to blacklist zones where WRobot cannot found path to go.

The problem is that gatherer task select the nearest gameobject by path distance (and not by fly distance), to get path distance he generate path for all gameobject found in search radius and not blacklisted, and when WRobot cannot generate path he take long time to load meshes/search (this take time and increment ram usage, I have already try to found solution but if I put lower limit, some paths was not generated correctly).

To resolve problem with http://www.wowhead.com/quest=25136/galgars-cactus-apple-surprise you can add to your blacklisted zones:

    <Blackspot X="-317.307373" Y="-4437.53027" Z="57.3852348" Radius="10" />
    <Blackspot X="-360" Y="-4337" Z="58" Radius="10" />


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...