Jump to content

Missing flightmasters in Taxi DB


Recommended Posts

Hi

I'm sure this has probably been answered but I cannot find it specifically. I have 4 flight masters unlocked, xroads, TB, south barrens and Org. I can see this when I goto a flight master. 

However, my Taxi DB is missing the org flight master. I have the same thing on 2 toons, lvl 15 and 20. Both of them are in the barrens grinding and every time they need a trainer they walk to Org. They walk almost past the org flight master to get to their class trainers. 

How do i get the org taxi into the taxi DB and why is it missing in the first place?

Thanks in advance!

Adam

 

Edit: They both have "use taxi" ticked in general settings and a flight master discover range of 3000

Link to comment
Share on other sites

1 hour ago, Droidz said:

Hello, it is normally automatic, do you use wow addons? if yes try to disable all.

Flight Master for Vanilla is broken and unreliable in general. Enabling / disabling and blacklisting taxi nodes after not being able to find a taxi node that doesn't even exist in Vanilla in the first place. I assume it's the same system used for later expansions with these additional taxi nodes. Or just not being able to fly from an active & discovered taxi node to another active & discovered taxi node, because wRobot thinks there is no flight path available, even if there clearly is. Not to speak about endless loops of bots running from one Flight Master to the other, just to fly back to the first one and repeat.

Would really appreciate some ❤️ for Vanilla Flight Master.

 

To give an example:

Bot is located in Westfall, Sentinel Hill and his destination is the Light House in the same zone. The bot will walk up to the Flight Master and search for a taxi node to travel to. But the taxi node at the Light House does not exist in Vanilla. So what happens is that wRobot blacklists the Sentinel Hill Flight Master and is now unable to fly from Westfall back to Stormwind. This can lead to even more taxi nodes being blacklisted, when the bot is in Stormwind and tries to fly back to Westfall.

Edited by FNV316
Link to comment
Share on other sites

2 hours ago, Droidz said:

Hello, it is normally automatic, do you use wow addons? if yes try to disable all.

Thanks for the reply Droidz.

I do have a LOT of addons so here's what I tried:

1) Disabled all addons. 

2) Logged back in wow

3) Ran to Org and stood 2 yards from the flightmaster, targeted him. 

4) Launched bot program, started quester. It checked all the paths and ran down the flight master tower and is currently walking back to the barrens! ha. I've left him to it, he seems he wants the exercise. 

I can see it is not in his DB still. Interestingly he does have the south barrens flight master in his database even though this particular character has not visited it yet. My 22 lock has 4 flight paths, my warrior has 2 flight masters. Just xroads and org. Do they share the database? can i not upload a full vanilla database somehow?

Link to comment
Share on other sites

OK so today I check the bot and it has now picked up Orgrimmar on both characters. However, it doesn't seem to use it when travelling there. 

One of the bots has moved into Ashenvale and is using Splintertree post for its town, it's made numerous trips but it hasn't added that taxi to its database either yet. 

@Droidz please can you enlighten me on the logic behind that side of the bot? should it grab the flight master as it comes into range. He is currently set to 200 range and ticked to use taxi. Should it add to the database as soon as its in range? does wrobot have to be restarted for it to reload the db? 

Thanks

 

Adam

 

Link to comment
Share on other sites

5 hours ago, inselmann said:

Does it help?

 

Thanks, I will give this a go but I can't see it helping. My issue is that firstly he doesn't seem to want to add the flightmasters in a timely manner so my taxiDB doesn't even have the flightmaster in! Splinter tree post has been missing despite me grinding that area now for a full 24 hours. They all seem enabled once they go in there but even though they are in and enabled, the bot still decides to walk! Warrior is grinding south barrens and has the flight master from Camp T and also for Orgrimmar. He still decides to do the 10 minute walk all the way upto Org though rather than using the flight master.

To be perfectly honest, I am yet to see my bot take any flight master anywhere. Maybe he has, but I've never seen it happen yet. 2 chars so far. 1-31 lock and a 1-25 warrior. 

Thanks

Adam

 

Link to comment
Share on other sites

They are actually read from DBC, so they don't even have to be discovered afaik. wRobot then decides to add them to the "visible" database once you see them, where it keeps track of you deactivating them (potentially).
I tried filling the DB from HMP's database in the beginning but it actually didn't help at all.

Link to comment
Share on other sites

? seems such a shame. Everything else works really well... grinding in Desolace now and he grabbed the flight master at the town and he hasn't used it even once yet. To goto the trainer he runs to stonetalon mountains, runs through barrens and through durator into Org and then all the way back lol. He gets ganked and killed about 5 times each way to boot. I'm leaving him to it just to see how well he does on the 1 to 60 profile all on his own. 

lock /played 4d 3h atm and is level 34...

Warrior is 2d 21h and is level 29. 

Link to comment
Share on other sites

On 7/16/2018 at 9:07 PM, Droidz said:

Hello, it is normally automatic, do you use wow addons? if yes try to disable all.

Any chance the vanilla bot is going to get an update for the broken flying system in the future? It really is broken to a point where its impossible to use

Link to comment
Share on other sites

2 minutes ago, Nostradamus said:

Any chance the vanilla bot is going to get an update for the broken flying system in the future? It really is broken to a point where its impossible to use

Do you have take taxi enabled in general settings? aside from "use flight master" you also have to enable taxi use. My bot definitely does take flightpaths to go to certain areas, but it's not perfect.

It will sometimes go to take a flightpath, get in a fight or something, talk to the flightmaster, then start running to the destination instead, however if it goes to flightpath with no interruptions, repairs etc It takes the flight no problem at all.

Link to comment
Share on other sites

1 minute ago, Faffywaffy said:

Do you have take taxi enabled in general settings? aside from "use flight master" you also have to enable taxi use. My bot definitely does take flightpaths to go to certain areas, but it's not perfect.

It will sometimes go to take a flightpath, get in a fight or something ,take to the flightmaster, then start running to the destination instead, however if it goes to flightpath with no interruptions, repairs etc It takes the flight no problem at all.

Yes everything is the way it is supposed to be. I can't count how many times the bot tried to run for hours instead of flying for a few minutes. Sometimes the bot gets stuck between deciding what to do and rather runs against a wall.

Link to comment
Share on other sites

1 minute ago, Nostradamus said:

Yes everything is the way it is supposed to be. I can't count how many times the bot tried to run for hours instead of flying for a few minutes. Sometimes the bot gets stuck between deciding what to do and rather runs against a wall.

I've only had it run against a wall when herbalism or mining was enabled, and It was trying to go after nodes that were in the mountains by stormwind, when they are enbaled they always get priority if nearby so make sure that's not the case, If for example It were to be going to a flight master, but then wanted to mine a node that It could not reach, you were to pause the bot, move it, and then run it again, It would talk to the flightmaster, but then start running to the destination instead..

Link to comment
Share on other sites

1 minute ago, Faffywaffy said:

I've only had it run against a wall when herbalism or mining was enabled, and It was trying to go after nodes that were in the mountains by stormwind, when they are enbaled they always get priority if nearby so make sure that's not the case, If for example It were to be going to a flight master, but then wanted to mine a node that It could not reach, you were to pause the bot, move it, and then run it again, It would talk to the flightmaster, but then start running to the destination instead..

Thats not the issue.

Link to comment
Share on other sites

  • 4 weeks later...
  • 2 years later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...