Jump to content

Some Wrobot Instances just "freeze"


Recommended Posts

Hey,

 

now that my cpu usage got a little bit better I am running 8 wrobot instances at once. Still very laggy sometimes.. ;(

 

but the real problem here is that some wrobot.exes just seem to forget they even "exist". the bots do absolutely nothing until i tab in the wrobot.exe. then it suddenly realizes that it should do something and the bot starts his work...

 

is this due to cpu overload ? is there any way to reduce cpu usage (except for the main.cs plugin by Droidz)? Or how can i fix those "stucks"?

Link to comment
Share on other sites

After a clean fresh install it is a little bit better. This is the second reinstall within 3 days. How can i keep this state? Are there any hidden temp files that i should delete sometimes?

For now the wrobots dont seem to forget about themselves but I am sure in a few days it will be broken again.

Any ideas?

Link to comment
Share on other sites

Since the last update, it happens sometimes that wRobot "doesn't do anything". So my plugin for example, will log "looting NPC", but nothing happens. It will think it's stuck because it hasn't moved in a while, the unstuck event is sent and my plugin tries to use hearthstone, but none of my Lua calls or SpellManager function calls actually do anything to the game.

Restarted the bot - got this:

ZCeMGYi.png
 

and this:

[E] 21:48:43 - Warning: You need to activate 'Vertical Sync' option, for it go to 'Game Menu' > 'Video Options' > in 'Miscellaneous' activate 'Vertical Sync'.

[E] 21:48:43 - Warning: You need to activate 'Vertical Sync' option, for it go to 'Game Menu' > 'Video Options' > in 'Miscellaneous' activate 'Vertical Sync'.

[E] 21:48:43 - Warning: You need to use '60Hz' at option the option 'Refresh', for it go to 'Game Menu' > 'Video Options' > in 'Display' select '60Hz' at the option 'Refresh'.

[E] 21:48:43 - Warning: You need to run Wow in Windowed mode, for it go to 'Game Menu' > 'Video Options' > in 'Display' activate option 'Windowed Mode'.

But I am definitely running it in windowed mode with vertical sync.

 

Wow error after a bit:

Wv4D161.png

Edited by Matenia
Link to comment
Share on other sites

Just now, Matenia said:

Since the last update, it happens sometimes that wRobot "doesn't do anything". So my plugin for example, will log "looting NPC", but nothing happens. It will think it's stuck because it hasn't moved in a while, the unstuck event is sent and my plugin tries to use hearthstone, but none of my Lua calls or SpellManager function calls actually do anything to the game.

does it help to alt tab into to that specific wrobot.exe? because thats what i was experiencing as well. lowering down the overall number of active sessions has helped me so far

Link to comment
Share on other sites

2 hours ago, Matenia said:

Since the last update, it happens sometimes that wRobot "doesn't do anything". So my plugin for example, will log "looting NPC", but nothing happens. It will think it's stuck because it hasn't moved in a while, the unstuck event is sent and my plugin tries to use hearthstone, but none of my Lua calls or SpellManager function calls actually do anything to the game.

Restarted the bot - got this:

ZCeMGYi.png
 

and this:

[E] 21:48:43 - Warning: You need to activate 'Vertical Sync' option, for it go to 'Game Menu' > 'Video Options' > in 'Miscellaneous' activate 'Vertical Sync'.

[E] 21:48:43 - Warning: You need to activate 'Vertical Sync' option, for it go to 'Game Menu' > 'Video Options' > in 'Miscellaneous' activate 'Vertical Sync'.

[E] 21:48:43 - Warning: You need to use '60Hz' at option the option 'Refresh', for it go to 'Game Menu' > 'Video Options' > in 'Display' select '60Hz' at the option 'Refresh'.

[E] 21:48:43 - Warning: You need to run Wow in Windowed mode, for it go to 'Game Menu' > 'Video Options' > in 'Display' activate option 'Windowed Mode'.

But I am definitely running it in windowed mode with vertical sync.

 

Wow error after a bit:

Wv4D161.png

 

Link to comment
Share on other sites

4 hours ago, NameChanger3000 said:

I am the same guy from this thread Buddy xD yea i use it. Do I uncomment that line now?

 

BTW: I am also experiencing many WoW and wrobot crashes recently. Dont know how to fix that either ?

If sometime you get freeze, you need to put lower value at the sleep times 

Link to comment
Share on other sites

6 hours ago, Droidz said:

If sometime you get freeze, you need to put lower value at the sleep times 

Where do I find that sleep time setting? Does that mean I could go for more active sessions? Is there any fps limit where you would say that the bot will not work anymore? Or is Everything memory based and the fps are just for visuals? 

Link to comment
Share on other sites

You can also try to use shortcut "WRobot No Lock Frame" (freeze problem will be resolved, but you will lost performance) or "WRobot No DX" (you can get better performance)

Link to comment
Share on other sites

i already disabled all addons, delete the WDB & WTF folder of WoW and did a complete new setup of the bot.

Those freezes appeared super out of nowhere but after the last bot-update.

One more fact about those freezes. They appear super random. sometimes all 5 minutes and sometimes its running smoothe for hours.

 

 

but i will give that shortcuts a try for sure.

thx & cheers

Link to comment
Share on other sites

I have freeze problems since february-march this year. Not playing often, so its not big problem, but before robot worked better. My notebook is old, but i am playing on private server, and it is good enough for pandaria (core i5, 12 gb ram, ssd, external video card, win7). WoW clients works fine until loading wrobot.

I think something was changed in robot (maybe stronger protection, maybe new alghorythm), but this is fact: since february-march its really freezes on my notebook, random. I've saved old copies of robot, and run it in heavily loaded instanses.

Link to comment
Share on other sites

Do all steps:

  1. Disable all wow addons.
  2. Download and install WRobot in new folder, install only your profile (don't install plugins/fightclasses).
  3. Run Wow in window mode (not full screen, and never minimize wow window!).
  4. Put lower wow graphics quality, but try to get good FPS (40 or more)
  5. Run WRobot and check CPU usage and if Wow don't freeze during few minutes. (tell me here with your log file if you get freeze/cpu usage problem)
  6. Now start to add you fightclass and check again CPU/freeze during few minutes.
  7. Now add one per one Wrobot plugins, wow addons.
Link to comment
Share on other sites

13 hours ago, Droidz said:

Do all steps:

  1. Disable all wow addons.
  2. Download and install WRobot in new folder, install only your profile (don't install plugins/fightclasses).
  3. Run Wow in window mode (not full screen, and never minimize wow window!).
  4. Put lower wow graphics quality, but try to get good FPS (40 or more)
  5. Run WRobot and check CPU usage and if Wow don't freeze during few minutes. (tell me here with your log file if you get freeze/cpu usage problem)
  6. Now start to add you fightclass and check again CPU/freeze during few minutes.
  7. Now add one per one Wrobot plugins, wow addons.

This is what I did. Multiple times already. It works a few days but then performance cracks down again.

 

Looks like there might be some temp files that should be deleted from time to time or something like that. 
I can not reinstall my wrobot and all my classes every few days droidz, this is not gonna work out.

Link to comment
Share on other sites

3 hours ago, Droidz said:

One of your profiles/plugins/fightclasses change bad wow/wrobot settings. Do you have low FPS in game? 

Yea i have very low fps as soon as i start running more than 4 wrobots. I personally think that it is something on your end to be honest. Because my fightclasses have not changed. And i was able to run 9 sessions a few weeks ago. now 5 sessions are laggy as hell

Link to comment
Share on other sites

before last update wrobot with your plugin droidz for low fps- go perfect,now with updated wrobot  can skyrocket even to 200% of last time usage it is nightmare

i have i7 and i talk about wotlk wrobot please help

Link to comment
Share on other sites

24 minutes ago, artur.k said:

before last update wrobot with your plugin droidz for low fps- go perfect,now with updated wrobot  can skyrocket even to 200% of last time usage it is nightmare

i have i7 and i talk about wotlk wrobot please help

What is old/new cpu usage?

Link to comment
Share on other sites

it is now unstable before was 1-4%  now can skyrocket to 12% and now it is like computer works slow,before update wrobot + your both plugins for vanilla and others exp makes wrobot smoth and realy stable with low core usage now i feel like have dual core processor

Link to comment
Share on other sites

Ya i noticed this some of my toons in the late 30's take 8-10 hours to lvl with a grinder because they will kill something then spend 30 seconds standing there with addon saying "looting" making it look super bottish and instead of 3 hours a lvl 8-10  =(.  This all happened after the  2.0 update duno what change happened but it wrecked something cause my room is even hot from it crashing and cpu usage spiking.  ITs only done this about one other time i can think of after a major update in 2 years then was fixed about 3 weeks - month later randomly with an update to the bot.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...